Info…

ABBYY FlexiCapture ist eine Softwarelösung, mit der Daten aus Papierdokumenten automatisch in Informationssysteme und Datenbanken übertragen werden können.

Durch den Einsatz moderner Technologien zur Erkennung gedruckter und handschriftlicher Zeichen, zur Bildverarbeitung und zur Dokumentanalyse können mit ABBYY FlexiCapture alle wichtigen Arten von Informationen automatisch aus Dokumenten extrahiert werden. Dabei können in einem Durchgang sowohl strukturierte (statische) Formulare als auch teilweise strukturierte (flexible) und nicht strukturierte Dokumente verarbeitet werden. Mit ABBYY FlexiCapture ersparen Sie sich die aufwendige und ineffiziente Arbeit, die bei der manuellen Sortierung und Erfassung von Informationen aus Dokumenten entsteht.

Die Dokumentverarbeitung umfasst im Allgemeinen folgende Arbeitsschritte:

  1. Zunächst werden die Dokumente in die automatische Dokumentenzufuhr des Scanners eingelegt, und der Scanvorgang wird gestartet.
  2. Anschließend werden die gescannten Dokumentenbilder zur Erkennung weitergeleitet. Die Software erkennt auch mehrseitige Dokumente automatisch, sucht nach aussagekräftigen Feldern, extrahiert die Daten und lädt die Überprüfungsregeln.
  3. Sofern erforderlich, werden die Daten dann visuell überprüft und auf mögliche Regelfehler hin untersucht.
  4. Abschließend werden die erkannten und geprüften Daten zusammen mit den elektronischen Kopien der Dokumente in einer Datenbank, einem Informationssystem oder einer Datei gespeichert.


Neue Funktionen in ABBYY FlexiCapture

Betriebsbereites Add-On für die Rechnungsverarbeitung

ABBYY FlexiCapture for Invoices

ABBYY FlexiCapture kann mit einem betriebsbereiten Add-On erweitert werden, das zusätzliche Funktionen, vorgegebene Einstellungen, Überprüfungsregeln, eine erweiterte Datenbanksuche und Anpassungen der Benutzeroberfläche speziell für die maßgeschneiderte Verarbeitung von Rechnungen bietet.

Funktionen: ABBYY FlexiCapture for Invoices

Aus E-Mail importieren

Aus POP3-Server importieren

Der Import von einem POP3-E-Mail-Server mit SSL- oder TLS-Verschlüsselung wird unterstützt.

Importprofil

Verbesserungen der Benutzeroberfläche der Station des Überprüfungsoperators

Vorschläge für Feldwerte aus dem Cache

Beginnt der Operator mit der Eingabe eines Werts in ein leeres Feld, schlägt die Software mögliche Werte vor, die aus dem OCR-Cache der Seite generiert werden. Der Überprüfungsoperator wählt einfach die korrekte Variante aus der Liste aus, um das Feld aufzufüllen.
Gruppieren von Feldern

Datenformularfelder können unter einem gemeinsamen Namen zusammengefasst werden und es wird die Gesamtsumme angezeigt, um die Überprüfung zu beschleunigen. Feldgruppen können so eingerichtet werden, dass sie je nach Zustand automatisch aus- und eingeblendet werden.
Anzeige von Schnappschüssen der Felder im Datenformular

Die Felder des Typs Text, Barcode und Auswahlfeldgruppe können auf dem Datenformular gemeinsam mit einem Schnappschuss (Fragment des Originalbilds) dargestellt werden, um die visuelle Prüfung der Informationen zu erleichtern.
Dialogfeld Datenbanksuche

Ein neu eingeführtes Dialogfeld der Datenbanksuche wird angezeigt, wenn der Überprüfungsoperator beginnt, die Gruppe der Felder zu korrigieren, für die eine Datenbanksuchregel aktiviert wurde. Das Dialogfeld stellt die passendsten Einträge der Datenbanktabelle zur Auswahl. Sie können die Datenbankeinträge durchsuchen, indem Sie ein Schlüsselwort in das Feld eingeben. Wurde ein Eintrag ausgewählt, werden alle Felder der Gruppe mit den Werten der Datenbank aufgefüllt. Mit dieser Funktion werden viele zusammenhängende Felder durch die Angabe des richtigen Feldwerts für ein Hauptfeld aufgefüllt.

Konfiguration

Suchregeln und einfache Regeleinrichtung

Um die Ansicht und die Einrichtung der Überprüfungsregeln komfortabler und benutzerfreundlicher zu gestalten, wurden verschiedene Verbesserungen eingeführt. Die neuen Funktionen sehen die Möglichkeit vor, die Regeln je nach Zustand anzuwenden, sowie eine flexible Suche nach Regeln, ein flexibles Filtern und die Gruppierung von Regeln.
Erweiterte Einstellungen der Datenbanksuche

Die Einstellungen der Datenbanksuche wurden erheblich erweitert und sind nun flexibler. Folgende Optionen wurden eingeführt:

  • Auswahl der Spalten und Einrichtung der Reihenfolge der Anzeige der Spalten in der erweiterten Datenbanksuche;
  • Auswahl der Spalten, die dem Benutzer in verschiedenen Datenbanktabellen angezeigt werden;
  • Auswahl der Datenbankfelder, aus denen ersetzt wird;
  • Generierung einer Liste möglicher Feldwerte aus der Datenbank, die angezeigt werden, wenn ein Wert in das Feld eingegeben wird;
  • Möglichkeit der Auswahl einer Ansicht, die vom Benutzer als Tabelle erstellt wurde.
Datensatz (lokal gespeicherte Datenbankversion)

ABBYY FlexiCapture ermöglicht eine Verbindung mit der Datenbank mittels eines Datensatzes, der eine temporär gespeicherte Version der Datenbank darstellt und für den eine regelmäßige Synchronisation mit der Quelldatenbank eingerichtet werden kann. Durch die Verwendung eines Datensatzes anstelle einer direkten Datenbankverbindung wird eine Verlangsamung beim Zugriff auf die Datenbank vermieden und dem Überprüfungsoperator ermöglicht, während der Überprüfung von Dokumenten neue Einträge in den Datensatz einzugeben und vorhandene Datensätze, die weiter genutzt werden sollen, zu korrigieren.
Bedingter Export

Es wurde eine Option eingeführt, mit der das Exportziel abhängig vom Regelfehler oder Wert eines bestimmten Feldes festgelegt werden kann.
Collapsed Neue Funktionen von ABBYY FlexiCapture 10, die nicht in ABBYY FlexiCapture 9.0 verfügbar sind

Import und Verarbeitung von Bildern

Import images from e-mail and via FTP

Bilder können vom E-Mail-Posteingang aus hinzugefügt werden, einschließlich der Anhänge. Es werden die Protokolle MAPI und POP3 unterstützt. Bei der Verwendung des MAPI-Protokolls sollten die Verarbeitungsstationen ebenfalls unter dem Konto des E-Mail-Postfach-Besitzers gestartet werden. Bilder können auch vom FTP-Server heruntergeladen werden.

Bildimportprofile

Überprüfung

Feldüberprüfung für Gruppen von Auswahlfeldern

Gruppen von Auswahlfeldern, für die nur eine Auswahl erlaubt ist, werden an die Feldüberprüfung gesendet, falls mehr als eine Option markiert wurde. Der Datenüberprüfungsoperator kann die Auswahl korrigieren.

Anpassung

Skripte

Zahlreiche Skripte wurden implementiert, wie z. B. Erkennungsskript, Event-Handler usw.

Verwenden von Skripten in ABBYY FlexiCapture
Benutzerdefinierte Tastenkombinationen

Es wurde die Möglichkeit hinzugefügt, Tastenkombinationen bestimmen zu können. Ein Benutzer kann die Standard-Tastaturbefehle auf Stationen ändern.

Tastenkombinationen anpassen
Collapsed Neue Funktionen von ABBYY FlexiCapture 9.0, die nicht in ABBYY FlexiCapture 8.0 verfügbar sind

Projektmanagement

Stapeltypen

Für jeden Stapel kann ein Typ bestimmt werden (wenn kein Typ bestimmt wurde, wird ein "Standard"typ festgelegt). Ein Projekt kann eine beliebige Anzahl von Stapeltypen enthalten. Ein Stapeltyp definiert die Bildverarbeitungs- und Erkennungsoptionen, Stapelintegritätsprüfungen, Standardexporteinstellungen und die Art und Weise, wie die zu diesem Typ gehörenden Stapel verarbeitet werden sollen. Die Projekteinstellungen werden für Stapel des "Standard"typs verwendet.

Dokumentstapel

Registrierungsparameter

Es ist nun möglich, Registrierungsparameter für Stapel und Dokumente anzugeben. Diese Parameter können für den späteren Bild- und Datenexport genutzt werden.

Registrierungsparameter
Prioritäten

Für die Steuerung der Verarbeitungsreihenfolge können nun Prioritäten für Dokumente und Stapel angegeben werden.

Analyse und Erkennung

Reihenfolge, in der die Dokumentdefinitionen zugeordnet werden

Sie können jetzt die Reihenfolge kontrollieren, in der die Dokumentdefinitionen zugeordnet werden. Folgende Methoden können zur Bestimmung der Zuordnungsreihenfolge verwendet werden:

  • Genaue Bestimmung der Reihenfolge der Dokumentdefinitionen im Dialogfeld Dokumentdefinitionen

  • Für FlexiLayouts: verwenden Sie einen Klassifikator, um die gewünschte Dokumentdefinition auszuwählen

  • Für FlexiLayouts: Bestimmen Sie im Dialogfeld Dokumentdefinitionen wie das entsprechende FlexiLayout ausgewählt werden soll

Bearbeiten und Veröffentlichen einer Dokumentdefinition
Klassifikator
Aktualisieren der Version einer Dokumentdefinition ohne erneute Erkennung

Sie können jetzt die Version einer Dokumentdefinition aktualisieren, ohne die Erkennung zu wiederholen. Dies ist möglich, wenn eine der folgenden Bedinungen erfüllt ist:

  • Wenn nur die Exporteinstellungen verändert wurden. In diesem Fall wird das Dokument mit den neuen Einstellungen exportiert

  • Wenn die Regeln verändert wurden. In diesem Fall wird die regelbasierte Validierung noch einmal durchgeführt

Überprüfung und Validierung

Überprüfungs- und Validierungstasks können nun automatisch abgerufen werden
Während der Gruppen- und Feldvalidierung können die Bilder betrachtet werden
Dateien und Datenbanken können als Datenquellen für die regelbasierte Validierung verwendet werden
Die Regel für die Datenbanküberprüfung kann für leere Felder deaktiviert werden
Es wurde eine Regel für die Summenberechnung hinzugefügt
Die Stufe für die Erkennungszuverlässigkeit wird für den gesamten Stapel angegeben
Es wurden Einstellungen für die Gruppen- und Feldüberprüfung ergänzt. Dazu gehört die Möglichkeit, Eindeutigkeitsanforderungen für spezifische Zeichen zu konfigurieren
Für die Feldüberprüfung kann die Startposition des Mauszeigers bestimmt werden
Während der Feldüberprüfung können ganze Felder optional markiert werden (nützlich, wenn der Benutzer Eingaben vornehmen möchte)
Jeder Fehlertyp wird separat angezeigt. Folgende Fehlerarten werden erkannt:

  • Zusammenstellungsfehler

  • Formatfehler

  • Regelfehler

Überprüfung erkannter Daten

Export

Automatischer Export

Dokumente mit einer hohen Erkennungsqualität und ohne Regel- oder Formatfehler werden nun ohne Eingriff des Benutzers automatisch exportiert. Der erforderliche Prozentsatz der nicht eindeutigen Zeichen wird beim Einrichten des Projekts bestimmt.

Arbeitsablauf
Exportieren in mehrere Zielorte

Daten und Bilder können in mehrere Zielorte exportiert werden. Einige Zielorte können als kritisch markiert werden. Wenn das Exportieren in einen kritischen Zielort fehlschlägt, wird eine Fehlermeldung angezeigt. Wenn das Exportieren in einen unkritischen Zielort fehlschlägt, führt dies nicht zu einem generellen Exportfehler.

Konfigurieren des Datenexports
Einrichten von Dateinamen und Speicherorten

Für die Konfiguration von Namensvorlagen für Dateien, in denen exportierte Daten und Bilder gespeichert werden, sowie deren Pfade gibt es jetzt mehr Möglichkeiten. Neu ist außerdem die Möglichkeit, die Ordnerstruktur während des Exports aus einem Hot Folder nachzubilden.

Namensschema für Exportdateien
Archivieren von Dokumenten mit Fehlern

Dokumente mit Format- oder Regelfehlern können in einem vorgegebenen Speicherort abgelegt werden. Der Export von Dokumenten mit Fehlern wird auf dieselbe Weise eingerichtet wie das Exportieren von normalen Dokumenten.

Konfigurieren des Datenexports
Automatisches Löschen von Dokumeten nach dem Export

Exportierte Dokumente können gelöscht werden, wenn der Export erfolgreich durchgeführt wurde. Die Option, die Dokumente manuell zu löschen, besteht nach wie vor.

Arbeitsablauf

Gewährleistung der Geheimhaltung

Einzelne Felder auf Dokumentbildern können nun geschwärzt werden (d. h. überdeckt werden). Es können für jeden Export verschiedene Schwärzungsregeln bestimmt werden. Somit wird die Anzahl der für verschiedene Benutzer sichtbaren Informationen gesteuert.

Konfigurieren des Datenexports

Optionen

Stapelintegritätsüberprüfungen

Skripte können verwendet werden, um Stapel auf Integrität zu überprüfen. Skripte werden vor dem Export automatisch gestartet.

Dokumentstapel

Beispielskripte zum Erstellen benutzerdefinierter Regeln
Normalisierungsskripte

Skripte können verwendet werden, um die aus den Feldern extrahierten Informationen zu korrigieren.

Verarbeiten eingegebener Werte
Beispielskripte zum Erstellen benutzerdefinierter Regeln
Benutzerdefinierte Skripte

Für jedes Feld kann ein vom Überprüfungsoperator ausgelöstes Skript angegeben werden.

Benutzerdefinierte Aktion
Dienstfelder

Ein neuer Feldtyp ist hinzugekommen: das Dienstfeld. Felder dieser Art werden automatisch mit den Daten der ausgewählten Quelle ausgefüllt.

Dienstfelder

Unterstützte Sprachen

Neue OCR-Sprachen

OCR-Unterstützung für die folgenden Sprachen wurde hinzugefügt:

  • Vietnamesisch

  • Chinesisch

  • Koreanisch

  • Japanisch


Unterstützte Dokumenttypen in ABBYY FlexiCapture

ABBYY FlexiCapture ist ein Softwaresystem, mit dem Daten aus unterschiedlich aufgebauten Dokumenten erfasst werden können.

Dabei können verschiedene Dokumenttypen in einem Durchgang verarbeitet werden. Sie können das Programm zudem so konfigurieren, dass Dokumente mit einer Kombination verschiedener Dokumenttypen, z. B. Dokumente mit strukturierten und teilweise strukturierten Bereichen, verarbeitet werden. Die einzelnen Dokumenttypen wirken sich lediglich auf die Systemkonfiguration und dabei vor allem auf die Erstellung von Dokumentdefinitionen aus. Sie haben keinerlei Einfluss auf die Arbeit der Operatoren.

ABBYY FlexiCapture kann für die automatische Erfassung der folgenden Dokumente in einem Durchgang konfiguriert werden:

Collapsed Strukturierte Dokumente (statische Formulare):

Strukturierte Dokumente verfügen über eine Reihe markierter Informationsfelder, deren Formatierung, Anzahl und Layout bei den verschiedenen Instanzen des Dokuments unverändert bleiben. Diese Dokumente werden auch als statische Formulare bezeichnet. Die meisten Fragebogen und Antragsformulare können als statische Formulare betrachtet werden. Derartige Formulare werden in der Regel als leere Formulare verteilt und dann von Hand ausgefüllt.

Um ein statisches Formular innerhalb eines Dokumentstapels zu erkennen und Daten daraus extrahieren zu können, müssen Sie ein statisches Layout erstellen, auf dessen Grundlage das Programm die Felder erkennen kann, aus denen Daten zu extrahieren sind.

Am effektivsten lassen sich statische Formulare verarbeiten, die an die Anforderungen der automatischen Datenerfassung angepasst sind. Diese Formulare werden auch als maschinenlesbare Formulare bezeichnet. Weitere Informationen über Anforderungen an diese Formulare sowie Hinweise zu ihrer Erstellung finden Sie im Abschnitt Erstellen von maschinenlesbaren Formularen.

Ein besonders effizientes Programm zum Erstellen maschinenlesbarer Formulare ist ABBYY FormDesigner, das im Lieferumfang von ABBYY FlexiCapture enthalten ist. Hinweise zum Entwerfen von Formularen mit ABBYY FormDesigner finden Sie im Benutzerhandbuch und in der Online-Hilfe.

Die wichtigsten Schritte zum Erstellen einer Dokumentdefinition werden speziell für strukturierte Dokumente beschrieben.

Collapsed Teilweise strukturierte Dokumente (flexible Formulare):

Hierbei handelt es sich um Dokumente mit einem Satz von Datenfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Diese Dokumente werden auch als flexibel bezeichnet. Ein gutes Beispiel für flexible Dokumente sind Rechnungen, da bei ihnen die Anzahl und das Format der Datenfelder je nach Unternehmen unterschiedlich sein können Natürlich verfügen alle Rechnungen über eine Rechnungsnummer und einen Zahlbetrag, allerdings können sich diese Felder an sehr unterschiedlichen Stellen im Dokument befinden.

Um flexible Dokumente zu erkennen und Daten daraus zu extrahieren, werden in ABBYY FlexiCapture sogenannte FlexiLayouts verwendet. FlexiLayouts können mithilfe von ABBYY FlexiLayout Studio erstellt werden. Ausführliche Informationen über dieses Programm finden Sie im Benutzerhandbuch und in der Online-Hilfe.

Die Verarbeitung flexibler Dokumente unterscheidet sich von der Verarbeitung statischer Dokumente nur im Hinblick auf das Erstellen und Laden der Layouts. Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Collapsed Nicht strukturierte Dokumente mit freiem Layout:

Mithilfe von ABBYY FlexiCapture können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Diagramme. Das Programm kann nicht strukturierte Dokumente automatisch als Anlagen statischer bzw. flexibler Dokumente erkennen. Die Erkennung ist auch mithilfe eines FlexiLayouts möglich. Die Dokumente werden dann als durchsuchbare PDF-Dateien oder als Grafikdateien exportiert. Indexfelder können aus nicht strukturierten Dokumenten sowohl automatisch (mithilfe eines FlexiLayouts) als auch durch manuelle Eingaben extrahiert werden.

Ein typisches Beispiel für die Verarbeitung nicht strukturierter Dokumente ist die Übertragung eines Papierarchivs in ein elektronisches Format und das Extrahieren mehrerer Indexfelder für die Organisation einer attributbasierten Schnellsuche.

Nähere Informationen hierzu finden Sie unter Verarbeiten nicht strukturierter Dokumente.


Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture

In diesem Abschnitt finden Sie eine allgemeine Übersicht über die Verarbeitung von Dokumenten mit ABBYY FlexiCapture.

Die Programmverwendung wird in den Abschnitten Konfigurieren des Programms und Arbeiten mit einem konfigurierten ProjektArbeiten mit einem konfigurierten Projekt genauer beschrieben.

Übersicht über die Konfiguration des Programms für die Dokumentverarbeitung

Übersicht über die Arbeit mit einem konfigurierten Programm


Kurzbeschreibung der Programmeinstellungen für die Dokumentverarbeitung

Das Programm wird durch den Administrator für die Verarbeitung bestimmter Dokumenttypen konfiguriert. Um das Programm auf die Dokumentverarbeitung vorzubereiten, muss Folgendes erstellt werden:

  1. Ein Projekt

    Ein Projekt enthält alle Einstellungen für das Verarbeiten eines bestimmten Dokumenttyps: Bildimportprofile, Dokumentdefinitionen und Dokumentstapel für die Verarbeitung.

  2. Eine oder mehrere Dokumentdefinitionen

    Der wichtigste Schritt beim Konfigurieren eines Projekts ist das Erstellen einer Dokumentdefinition. Wenn Sie die kontinuierliche Verarbeitung unterschiedlicher Dokumenttypen planen, müssen Sie in einem Projekt mehrere Dokumentdefinitionen erstellen.

  3. Durch Importprofile wird die Arbeit der Operatoren vereinfacht und optimiert. Wenn keine Importprofile konfiguriert wurden, müssen Sie jedes Mal, wenn Sie Bilder hinzufügen, die Importquelle auswählen und die Einstellungen konfigurieren. Mit Importprofilen können Sie Bilder mit nur einem Mausklick auf eine Schaltfläche hinzufügen und sehr schnell zwischen Importquellen wechseln.

  4. Ein Dokumentstapel

    Die zur Verarbeitung bestätigten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde. Wenn Sie Bilder hinzufügen, für die keine Stapel vorhanden sind, wird automatisch ein Stapel erstellt.

Weitere Informationen zum Konfigurieren des Programms


Erstellen eines Projekts

Damit Sie unterschiedliche Dokumente in einem Projekt verarbeiten können, muss dieses über mehrere Dokumentdefinitionen verfügen. Wenn sich die Dokumente nicht überschneiden und sich ihre Verarbeitungseinstellungen deutlich unterscheiden, können Sie auch getrennte Projekte erstellen.

Dazu müssen Sie zunächst mindestens ein Projekt erstellen.

Um ein neues Projekt zu erstellen, startet Sie die Projektkonfigurationsstation und wählen Sie Datei>Neues Projekt…

Weitere Informationen zum Erstellen eines Projekts


You are here: Info… > Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture > Kurzbeschreibung der Programmeinstellungen für die Dokumentverarbeitung > Übersicht über das Erstellen einer Dokumentdefinition

Übersicht über das Erstellen einer Dokumentdefinition

Die Erstellung von Dokumentdefinitionen ist der entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

In einer Dokumentdefinition sind die Positionen von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben.

Zum Erstellen einer Dokumentdefinition starten Sie den Dokumentdefinitionsassistenten:

  1. Wählen Sie im Hauptfenster der Projektkonfigurationsstation Projekt>Dokumentdefinitionen…
  2. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Dokumentdefinitionsassistenten.

Die einzelnen Schritte bei der Erstellung von Dokumentdefinitionen hängen vom verarbeiteten Dokumenttyp ab.

Collapsed Die wichtigsten Schritte beim Erstellen einer Dokumentdefinition für statische Formulare

  1. Erstellen Sie mit dem Dokumentdefinitionsassistenten eine neue Dokumentdefinition. Öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, auf dessen Basis die Markierungen der Dokumentdefinition erstellt werden.

  2. Markieren Sie die statischen Elemente (Anker und Objekte zur Identifizierung), und konfigurieren Sie ihre Eigenschaften. Statische Elemente werden zur Zuordnung und Identifizierung der Dokumentdefinition verwendet. Normalerweise werden statische Elemente automatisch erkannt und Standardeigenschaften zugeordnet.

  3. Markieren Sie die Felder auf dem Bild. Felder werden für die Datenextraktion verwendet.

  4. Konfigurieren Sie die Feldeigenschaften. Feldeigenschaften beeinflussen die Erkennungsqualität und legen fest, ob die Werte der Felder exportiert und zur Überprüfung an den Operator gesendet werden. Sie geben die Datentypen und den Wertebereich eines Felds an.

  5. Erstellen einer Dokumentdefinition für mehrseitige Dokumente: Fügen Sie Seiten hinzu, und wiederholen Sie sämtliche Schritte für alle Seiten.

  6. Konfigurieren Sie den Datenexport.

  7. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.

  8. Testen Sie eine Dokumentdefinition mithilfe der Bilder verschiedener Dokumente.

Hinweis: Wenn Sie mit ABBYY FormDesigner maschinenlesbare Formulare erstellt haben, müssen Sie anstelle der ersten drei Schritte lediglich eine Datei mit der Dateinamenerweiterung *.xfd importieren. Daraufhin wird ein Seitenbild mit vorbereiteter Markierung geöffnet (bzw. Bilder mehrerer Seiten, wenn Sie mit ABBYY FormDesigner ein mehrseitiges Formular erstellt haben). Einzelheiten finden Sie unter Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare.

Collapsed Die wichtigsten Schritte beim Erstellen einer Dokumentdefinition für flexible Dokumente

  1. Erstellen Sie mit ABBYY FlexiLayout Studio ein FlexiLayout (eine Datei mit der Dateinamenerweiterung *.afl). Einzelheiten finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.

  2. Erstellen Sie mit dem Dokumentdefinitionsassistenten eine neue Dokumentdefinition. Öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, und fügen Sie ein FlexiLayout an (die von Ihnen erstellte AFL-Datei). Nach Abschluss des Assistenten werden auf dem Bild die Feldmarkierungen angezeigt.

  3. Konfigurieren Sie die Feldeigenschaften. Folgen Sie dabei den Schritten beim Konfigurieren der Dokumentdefinitionseigenschaften für ein statisches Formular.

  4. Konfigurieren Sie den Datenexport.

  5. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.

  6. Testen Sie eine Dokumentdefinition mithilfe der Bilder verschiedener Dokumente.

Bei kombinierten Dokumenttypen, die Seiten mit statischen Formularen und teilweise strukturierte Bereiche enthalten, können Sie ein FlexiLayout als einen der Dokumentdefinitionsbereiche anfügen. Erstellen Sie zunächst eine Dokumentdefinition für einen der Bereiche (flexibel oder statisch), und fügen Sie dann einen neuen Bereich eines anderen Typs hinzu.

Sie können in einem Durchgang Dokumente unterschiedlichen Typs verarbeiten: Sie können als Teil desselben Projekts sowohl Dokumentdefinitionen für statische Formulare und flexible Dokumente als auch Dokumentdefinitionen für kombinierte Dokumenttypen erstellen. Das Programm wählt dann automatisch eine Dokumentdefinition aus.

Für die Verarbeitung von Dokumenten mit Anhängen erstellen Sie eine Dokumentdefinition und aktivieren dann in den Dokumentdefinitionseigenschaften die Option Anhangseiten berücksichtigen. Siehe Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Weitere Informationen über das Erstellen von Dokumentdefinitionen


Creating batch types

You are here: Info… > Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture > Kurzbeschreibung der Programmeinstellungen für die Dokumentverarbeitung > Erstellung von Stapeltypen

Erstellung von Stapeltypen

Dokumente werden in Stapeln verarbeitet. Stapel werden beim Importieren oder Scannen von Dokumenten erstellt Gleichzeitig wird jedem Stapel ein Typ zugeordnet.

Der Stapeltyp legt die folgenden Dokumentverarbeitungsparameter fest:

  • Bildvorverarbeitung

  • Abgleich von Dokumentdefinitionen mit den entsprechenden Dokumenten

  • Stapelintegritätsprüfung

  • Standard-Stapel-

  • Stapelverarbeitung

Stapeltypen

Erstellen von Dokumentstapeln


Verarbeitungseinstellungen

Die Verarbeitungsreihenfolge wird für jeden Stapeltyp einzeln festgelegt. Wenn Sie einen Stapel erstellen, wird dem Stapel ein bestimmter Typ zugewiesen und die Stapelverarbeitungsreihenfolge wird gebildet.

Wurden keine Stapeltypen erstellt, werden alle Stapel mithilfe der vorab konfigurierten <Default Settings> verarbeitet (Projekt>Projekteigenschaften…, Workflow).

Die Stapelverarbeitungseinstellungen werden in der Registerkarte Workflow im Dialogfeld Stapeltypeigenschaften konfiguriert.

Verarbeitungseinstellungen:

  1. Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als - liegt die Anzahl markierter Zeichen niedriger, als im Feld % pro Dokument angegeben, werden die Schritte Datenüberprüfung und Überprüfungübersprungen.
  2. Damit Dokumente automatisch exportiert werden, wählen Sie die Option Auto-Export aktivieren auf der Registerkarte Exportziele im Dialogfeld Eigenschaften der Dokumentdefinition.


Erstellen von Importprofilen

Der Operator beginnt damit, dem Projekt neue Bilder hinzuzufügen: Dabei kann es sich um Papierdokumente handeln, die gescannt werden müssen, oder um vorhandene elektronische Bilder.

Häufig wiederholte Aktionen oder das Hinzufügen von Bildern aus derselben Quelle können automatisiert werden, damit der Import mit nur einem Mausklick auf eine Schaltfläche durchgeführt werden kann. Erstellen Sie dazu ein Bildimportprofil. Sie können darüber hinaus auch noch die Verarbeitung eingehender Bilder und das regelmäßige Hinzufügen von Bildern im Hintergrundmodus konfigurieren. Nach dem Festlegen der erforderlichen Einstellungen können die Bilder mit nur einem Mausklick auf eine Schaltfläche gescannt oder aus einer zuvor definierten Quelle importiert und verarbeitet werden (z. B. das Entfernen von Störungen). Sie können bei Bedarf die Quelle für den Bildimport oder die Einstellungen ändern.

Werden die Importquellen häufig geändert, können Sie mehrere Importprofile erstellen und zwischen diesen wechseln, so dass Sie nicht jedes Mal die Einstellungen für die Importquelle ändern müssen.

Wählen Sie zum Hinzufügen eines Importprofils im Hauptfenster des Programms die Menüoption Projekt > Bildimportprofile… aus. Im daraufhin geöffneten Dialogfeld können Sie Importprofile erstellen, bearbeiten, löschen und kopieren.

Weitere Informationen zum Erstellen von Importprofilen


Erstellen von Dokumentstapeln

Die zur Verarbeitung bestätigten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde.

Wenn ein Projekt keine Stapel enthält, wird beim Hinzufügen von Bildern automatisch ein Stapel erstellt.

Wenn Sie einen neuen Stapel erstellen möchten, klicken Sie mit der rechten Maustaste in das Hauptfenster und wählen im Kontextmenü mit der Liste der Stapel die Option Neuer Stapel… aus.

Weitere Informationen über das Erstellen von Dokumentstapeln


Übersicht über die Arbeit von Operatoren mit einem konfigurierten Programm

Die Operatoren verwenden ein Programm, dass für die Verarbeitung bestimmter Dokumenttypen vorkonfiguriert wurde. Die Dokumentverarbeitung ist bei allen Dokumenttypen gleich und umfasst folgende Schritte:

  1. Bilder werden hinzugefügt

    Sie können das Hinzufügen von Bildern der Dokumentseiten durch das Konfigurieren von Importprofilen deutlich vereinfachen. Außerdem können Sie Bilder hinzufügen, indem Sie diese scannen oder aus Dateien laden.

  2. Starten des Erkennungsvorgangs

    Die Erkennung läuft automatisch ab: Das Programm erkennt die Dokumentdefinition anhand der Position der statischen Elemente, die in der Definition vorkonfiguriert wurden, und wendet die Dokumentdefinition an, um die Daten in den in der Definition angegebenen Feldern zu erkennen. Vor dem Starten der Erkennung können Sie die Dokumente oder deren Seiten analysieren und dem Bild eine entsprechende Dokumentdefinition zuordnen.

  3. Überprüfung

    Die Überprüfung der Daten ist der arbeitsintensivste Teil der Arbeit von Operatoren. Er umfasst Folgendes:

    • Überprüfung der Dokumentzusammenstellung – Überprüfung der richtigen Zusammenstellung der Dokumentseiten;

    • Gruppenüberprüfung – visuelle Überprüfung von Gruppen als gleich erkannter Zeichen;
    • Feldüberprüfung – Überprüfung nicht eindeutig erkannter Zeichen im Kontext von Feldern mit einem bekannten Wertebereich;
    • Überprüfung im Dokumenteditor – Überprüfung von Fehlern im Dokumenteditorfenster, einschließlich der regelbasierten Validierung.
  4. Datenexport

    Der Export wird durch Klicken auf eine Schaltfläche entsprechend den Exporteinstellungen in der Dokumentdefinition durchgeführt. Sie können die Daten auch in eine Datei oder Datenbank exportieren, ohne die Exporteinstellungen einer Dokumentdefinition zu verwenden.

    Wählen Sie die Option Dokumente nach Export löschen aus, um die Stapel nach dem Export automatisch zu löschen.

Hinweis: Damit die Dokumente automatisch verarbeitet werden, verwenden Sie die folgenden Einstellungen:

  • Erstellen Sie ein Importprofil, um die Bilder automatisch zu importieren.

  • Wählen Sie die Option Hinzugefügte Bilder automatisch erkennen auf der Registerkarte Dokumentverarbeitung im Menü Tools > Optionen….
  • Wählen Sie auf der Registerkarte Workflow der Stapeltypeigenschaften die Option Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als.
  • Wählen Sie auf der Registerkarte Exportziele in den Eigenschaften der Dokumentdefinition die Option Auto-Export aktivieren, damit Dokumente automatisch exportiert werden.
  • Wählen Sie die Option Dokumente nach Export löschen aus, um die Dokumente nach dem Export automatisch zu löschen.
Weitere Informationen über die Arbeit von Operatoren mit konfigurierten Projekten


Hinzufügen von Bildern

Wählen Sie zum Hinzufügen von Bildern den entsprechenden Stapel aus oder erstellen Sie einen neuen Stapel. Über die Importschaltfläche können Sie Bilder auf verschiedene Weise importieren. Der Name der Schaltfläche ändert sich je nach ausgewählter Importmethode.

Sofern im Projekt Importprofile konfiguriert wurden, werden ihre Namen als Einträge im Menü der Importschaltfläche angezeigt. Um einen Import zu starten, müssen Sie lediglich eine Menüoption auswählen.

Zum Laden von Bildern aus einer Datei klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche und wählen Bilder laden… aus. Wählen Sie Dateien mit Bildern aus, konfigurieren Sie die erforderlichen Optionen und führen Sie den Import durch.

Zum Hinzufügen von Bildern von einem Scanner klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche und wählen Bilder scannen… aus.

Nachdem Sie im Menü Bilder importieren… ausgewählt haben, können Sie ein vorhandenes Bildimportprofil auswählen, um den Import zu starten, ein neues Profil erstellen oder ein vorhandenes Profil bearbeiten.

Weitere Informationen zum Hinzufügen von Bildern


You are here: Info… > Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture > Übersicht über die Arbeit von Operatoren mit einem konfigurierten Programm > Starten der Erkennung und Analysieren und Zuordnen einer Dokumentdefinition

Starten der Erkennung und Analysieren und Zuordnen einer Dokumentdefinition

Zum Starten der Erkennung klicken Sie auf Erkennen.

Wenn Sie zuvor eine Analyse der Bilder durchführen möchten, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen und wählen Dokumentdefinition zuordnen… aus. Wenn eine Dokumentdefinition zugeordnet werden kann, werden die Seite und das Dokument entsprechend benannt. Wenn dem Bild keine Dokumentdefinition zugeordnet werden kann, wird die Seite nicht verarbeitet.

Sie können einer Seite oder einem vollständigen Dokument auch eine bestimmte Dokumentdefinition zuordnen. Größtenteils werden Seiten ordnungsgemäß erstellten Dokumentdefinitionen automatisch zugeordnet. In einigen Fällen müssen Sie jedoch möglicherweise Dokumentdefinitionen manuell zuordnen. Um eine Dokumentdefinition anzuwenden, markieren Sie ein Dokument oder eine Seite. Klicken Sie anschließend auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen, und klicken Sie dann auf Dokumentdefinition zuordnen….

Weitere Informationen über die Erkennung


Überprüfung

Bei der Überprüfung wird festgestellt, ob die Daten erkannt wurden, die Seiten korrekt in Dokumente zusammengefasst wurden und die Regeln keine Fehler zurückgegeben haben. Überprüfung auf der Operator Station gemacht.

Klicken Sie zum Starten des Überprüfungsvorgangs auf Überprüfung ausführen…. Der Vorgang beginnt mit der Gruppenüberprüfung, danach folgt die Feldüberprüfung. Wenn eine Dokumentdefinition über keine Felder verfügt, die in die Gruppen- oder Feldüberprüfung einbezogen werden, wird der entsprechende Überprüfungsschritt ausgelassen.

Sie müssen beim Erstellen einer Dokumentdefinition eine Regel für die Dokumentzusammenstellung definierenDiese umfasst Festlegungen zur Reihenfolge und Anzahl der Seitenwiederholungen. Außerdem können Sie die Überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren: Dabei müssen die Werte von Schlüsselfeldern auf sämtlichen Seiten des Dokuments gleich sein. In der Erfassungsphase werden die Seiten automatisch zu Dokumenten zusammengestellt. In der Überprüfungsphase müssen Sie eventuelle Zusammenstellungsfehler mehrseitiger Dokumente korrigieren. Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Eine Beschreibung des Fehlers finden Sie in roten Buchstaben unter dem Namen der Dokumentdefinition. Bei Abweichungen wird eine entsprechende Meldung angezeigt, und die Werte der Schlüsselfelder werden rot hervorgehoben. Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt.

Bei der Gruppenüberprüfung werden Gruppen von als gleich erkannten Zeichen für die Überprüfung übermittelt. Der Operator muss dann abweichende Zeichen bestimmen, die falsch erkannt wurden. Nachdem der Operator das Feld mit diesem Zeichen angezeigt hat, kann er seine Werte berichtigen. Wenn ein Zeichen nicht korrigiert werden kann, können Sie es als nicht eindeutig markieren.

Bei der Feldüberprüfung werden Felder mit einem bekannten Wertebereich zur Überprüfung übermittelt. Der Operator muss dann nicht eindeutig erkannte Zeichen im Kontext des vollständigen Felds überprüfen. Die Feldüberprüfung kann in zwei Modi durchgeführt werden: in der Einzelfeldansicht mit Zeichenausschnitten und in der Ansicht mehrerer gleichartiger Felder.

Nicht eingehaltene Regeln sind durch eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet. Formatfehler sind mit [image] gekennzeichnet. Der Operator muss Felder mit Regelfehlern überprüfen und ggf. korrigieren. Um die Regelfehler zu überprüfen, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche und wählen die Menüoption Regeln erneut überprüfen aus. Werden die Regeln nach der Korrektur der Feldwerte erfüllt, werden die Markierungen entfernt.

Das Symbol [image] wird auch verwendet, wenn Felder von FlexiLayouts nicht angewendet werden konnten. Ein Operator kann Regionen für solche Felder auf dem Dokumentbild manuell festlegen.

Die Datenüberprüfung kann auch im Dokumentfenster durchgeführt werden, das Sie durch Doppelklicken auf den Namen eines Dokuments oder einer Seite öffnen. Im Dokumentfenster werden nicht einzelne Felder, sondern das gesamte Dokument angezeigt. Außerdem enthält es alle nicht eindeutig erkannten Zeichen, Regelfehler usw.

Weitere Informationen über die Überprüfung


Export

Zum Exportieren erkannter und überprüfter Dokumente klicken Sie auf ExportierenDer Export wird anhand der Einstellungen in der Dokumentdefinition durchgeführt.

Wenn Sie einen Export in eine Datei durchführen möchten, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche und wählen Daten in Datei exportieren… aus.

Müssen Bilder in eine Datei exportiert werden, wählen Sie Bilder in Dateien exportieren.

Wenn der Export in eine Datenbank erfolgen soll, wählen Sie stattdessen In Datenbank exportieren… aus.

Ändern Sie ggf. die Exporteinstellungen und führen den Export durch.

Weitere Informationen zum Export


Installieren und Ausführen des Programms

Dieser Abschnitt enthält grundlegende Informationen zum Installieren, Schützen und Ausführen von ABBYY FlexiCapture. Außerdem enthält er die Systemanforderungen für die Installation.

Software- und Hardwareanforderungen
Installieren von ABBYY FlexiCapture

Ausführen der Software


Software- und Hardware-Anforderungen

Hardware-Voraussetzungen

  1. Intel® Pentium®/Celeron®/Core™2 Duo/Quad/Xeon®/Core™ i3/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™ 2 GHz-Prozessor oder schneller. Die Verwendung eines Prozessors mit 2 oder mehr Kernen wird für den Anwendungsserver empfohlen.
  2. RAM: 512 MB-RAM für jeden CPU-Kern, jedoch mindestens 1,5 GB
  3. Festplattenspeicher: 1.5 GB Festplattenspeicher, davon werden 1 GB zu Installationszwecken benötigt
  4. TWAIN, WIA oder ISIS-Scanner
  5. Eine aktive Internet-Verbindung, um Ihre Seriennummer zu aktivieren, USB-Anschluss für einen Dongle
  6. Mindestens 1024 × 768 Grafikkarte und Monitor
  7. Tastatur, Maus oder anderes Zeigegerät

Softwareanforderungen

  1. Betriebssystem:
    • Windows XP SP3
    • Windows Vista SP2
    • Windows 7 SP1

    • Windows 8/8.1;

    • Windows Server 2003 SP2
    • Windows Server 2008 SP2, R2 SP1, 2012 oder 2012 R2 + Desktop Experience.

    64-Bit-Betriebssysteme werden über den 32-Bit-Emulationsmodus unterstützt.

    Wenn Sie eine lokalisierte Benutzeroberfläche verwenden, muss Ihr Betriebssystem die entsprechende Sprache unterstützen.

    Die Verwendung der Schriftart Arial Unicode MS wird empfohlen. Andere Schriftarten können CJK-Zeichen falsch anzeigen.

  2. .Net Framework 3.5 SP1


Installieren von ABBYY FlexiCapture

Schließen Sie vor der Installation von ABBYY FlexiCapture alle anderen Anwendungen (z. B. Microsoft Outlook oder Microsoft Word).

Wichtig! Das Konfigurationsprogramm kopiert temporäre Dateien in den durch die Umgebungsvariable %temp% definierten Ordner. Falls bei der Installation Probleme auftreten, stellen Sie sicher, dass auf den Ordner zugegriffen werden kann und genug freier Festplattenplatz zur Speicherung der temporären Dateien verfügbar ist.

Die Installation von ABBYY FlexiCapture umfasst die folgenden Schritte:

So installieren Sie ABBYY FlexiCapture:

  1. Legen Sie die CD-ROM für ABBYY FlexiCapture in das CD-ROM-Laufwerk ein.

  2. Wählen Sie im Autorun-Menü die Option Lokale Installationaus , und befolgen Sie die Anweisungen im Installationsprogramm. (Wenn die Autorun-Funktion auf Ihrem Computer deaktiviert ist, doppelklicken Sie auf die Datei setup.exe auf der CD-ROM.)

  3. Wählen Sie eine Installationssprache aus (Englisch oder Deutsch). Im Installationsprogramm wird das Gebietsschema Ihres Computers mit der ausgewählten Sprache verglichen. Wenn die Sprachen nicht kompatibel sind, wird eine Warnmeldung angezeigt.

  4. Anschließend werden die Version des Betriebssystems und die Verfügbarkeit der Administratorrechte überprüft. Wenn die Version des Betriebssystems nicht unterstützt wird oder Sie über keine Administratorrechte verfügen, wird eine Warnmeldung angezeigt und das Installationsprogramm beendet.

  5. IWenn alle Überprüfungen erfolgreich abgeschlossen wurden, wird der Endbenutzer-Lizenzvertrag angezeigt. Lesen Sie den Lizenzvertrag sorgfältig durch, und aktivieren Sie die entsprechende Option, wenn Sie den Vertragsbedingungen zustimmen. Klicken Sie anschließend auf Weiter.

  6. Im daraufhin geöffneten Dialogfeld werden Sie aufgefordert, einige Angaben zu Ihrer Person zu machen. Geben Sie die erforderlichen Informationen ein, und setzen Sie den Installationsvorgang fort.

  7. Wählen Sie im nächsten geöffneten Dialogfeld eine der verfügbaren Installationsmethoden aus:
    • Administratorstation – Das Programm wird vollständig installiert. Sie können zwischen dem Administrator- und dem Operatormodus wechseln sowie FormDesigner und FlexiLayout Studio verwenden.
    • Operatorstation – Es wird nur die Software für den Operatormodus installiert. (Die Administratorstation, FormDesigner und FlexiLayout Studio werden nicht installiert.)
    Sie können sowohl die Administratorstation als auch die Operatorstation auf demselben Computer installieren.

  8. Wählen Sie dann einen Zielordner aus. In der Standardeinstellung wird das Programm im folgenden Verzeichnis installiert: <Laufwerksbezeichnung>:\Programme\ABBYY FlexiCapture. Wenn auf der ausgewählten Festplatte nicht genügend Speicherplatz zur Verfügung steht, wird ein Fenster geöffnet, in dem alle Festplatten, der jeweils verfügbare Speicherplatz und der für die Installation erforderliche Speicherplatz angezeigt werden. Wählen Sie eine Festplatte mit ausreichend freiem Speicherplatz aus, und setzen Sie den Installationsvorgang fort.

  9. Die Programmdateien werden auf den Computer kopiert. Nach Abschluss der Installation wird in einer Meldung angezeigt, dass die Anwendung erfolgreich installiert wurde.

  10. Der FlexiCapture Lizenzmanager wird automatisch gestartet, so dass Sie die Anwendung aktivieren können. Geben Sie Ihre Seriennummer ein, und aktivieren Sie die Anwendung.


Lizenzmanager

Mit dem Lizenzmanager werden die Lizenzschlüssel verwaltet und Informationen über den Status von ABBYY FlexiCapture-Lizenzen gesammelt.

So starten Sie den Lizenzmanager:

  • Gehen Sie zu Start>Programe>ABBYY FlexiCapture 11>Tools und wählen Sie ABBYY FlexiCapture Lizenzmanager.

Verwalten von Lizenzen

Hinzufügen einer neuer Lizenz

Klicken Sie im Hauptfenster des ABBYY FlexiCapture Lizenzmanager auf Aktivieren.... Geben Sie die neue Seriennummer ein und klicken Sie auf Weiter. Wählen Sie dann eine Lizenzaktivierungsart aus und aktivieren Sie Ihre Lizenz. Die neue Lizenz wird im Hauptfenster des Lizenzmanagers angezeigt. Um die Arbeit mit der aktivierten Lizenz zu beginnen, wählen Sie diese aus der Lizenzliste im Hauptfenster des Lizenzmanagers aus und klicken Sie auf die Schaltfläche Auswählen.

Aktualisieren einer Lizenz

Im Hauptfenster des Lizenzmanagers wählen Sie die zu aktualisierende Lizenz aus und klicken Sie auf Lizenz aktualisieren .... Sie müssen Ihre Lizenz außerdem über das Internet oder per E-Mail aktivieren. Befolgen Sie die auf dem Bildschirm angezeigten Anweisungen.

Deaktivieren einer Lizenz

Im Hauptfenster des Lizenzmanagers wählen Sie die zu deaktivierende Lizenz aus und klicken Sie anschließend im Lizenzmenü auf Deaktivieren.... Folgen Sie zur Deaktivierung der Lizenz den Anweisungen des Deaktivierungsassistenten.

Lizenzparameter

Sie können im Lizenzmanager die Parameter Ihrer Lizenz ansehen. Wählen Sie eine Lizenz aus der Liste und klicken Sie auf Lizenzparameter.... Die Parameter der aktuellen Lizenz werden in Kurzform im Hauptanwendungsfenster angezeigt.

Lizenznutzungsstatistik

Für die Anzeige der Lizenznutzungsstatistiken für eine ausgewählte Lizenz wählen Sie das entsprechende Element im Menü Service. Im sich öffnenden Dialogfeld wird die Gesamtanzahl verfügbarer und verwendeter Seiten für die Lizenz angezeigt. Sie können den Zeitraum festlegen, für den die Statistik erstellt werden soll. Wurde der Zeitraum geändert, klicken Sie auf die Schaltfläche Aktualisieren, um die aktuellen Informationen anzeigen zu lassen. Für eine detaillierte Statistik der einzelnen Stationen klicken Sie auf die Schaltfläche Exportieren... und speichern Sie die Statistikdatei in den Formaten .txt oder .csv. Die resultierende Datei enthält Informationen über den Namen der Workstation, den Benutzernamen, das Verarbeitungsdatum und die Anzahl verarbeiteter Seiten. Um die Erfassung der Statistik auszuschalten, wählen Sie im Menü Service das entsprechende Element. Standardmäßig ist die Option für die Erfassung der Statistik aktiviert.


Schutztypen

Für die Installation und Verwendung von ABBYY FlexiCapture ist ein gültiger Lizenzschlüssel erforderlich.

ABBYY FlexiCapture kann einen der beiden folgenden Typen von Lizenzschlüsseln enthalten:

  • Dongle

  • Softwareschlüssel

Dongle

Der Dongle wird an einen USB-Anschluss des Computers (USB-Dongle) angeschlossen.

Um ABBYY FlexiCapture mit einem Dongle ausführen zu können, müssen Sie den iKey-Treiber oder CodeMeter-Schlüssel installieren. Bei 32-Bit-Betriebssystemen werden beide Treiber automatisch installiert. Auf 64-Bit-Betriebssystemen sollte die Setup-Datei manuell ausgeführt werden. Diese befindet sich im iKey-Unterverzeichnis des Distributionsordners. Der Dongle muss immer angeschlossen bleiben, wenn die Software verwendet wird.

Auf dem Dongle sind die Parameter Ihrer Lizenz gespeichert.

Aktivierungsmethoden:

  • Dezentral über das Internet
    Sie können einen leeren Dongle per Fernzugriff aktivieren, wofür lediglich die Seriennummer der Lizenz erforderlich ist. Dazu wird der Lizenzmanager verwendet, der über das Internet den Aktivierungsserver kontaktiert, die Parameter der Seriennummer abfragt und sie im Dongle speichert.
  • Per E-Mail
    Bei dieser Aktivierungsmethode wird automatisch eine E-Mail mit einer Aktivierungsanfrage erstellt. Senden Sie diese E-Mail-Nachricht an die angegebene Adresse. Damit das automatische E-Mail-Programm direkt antworten kann, dürfen Sie weder den Betreff noch den Text der E-Mail ändern.

Softwareschlüssel

Dies ist eine Lizenzdatei.

Wenn Sie ABBYY FlexiCapture mit einem Softwareschlüssel ausführen möchten, muss die Lizenzdatei auf dem Aktivierungsserver von ABBYY aktiviert werden. Sie können Ihre Lizenz mit dem Lizenzmanager aktivieren.

Die für das Aktivieren der Lizenz erforderlichen Informationen werden kodiert (Produkt-ID) an ABBYY gesendet, wobei der Code auf Informationen über den Computer beruht, auf dem ABBYY FlexiCapture installiert ist. Für die Generierung einer Produkt-ID werden keine persönlichen Informationen verwendet, auch ist es nicht möglich, mit diesem Code einen Benutzer zu identifizieren.

Aktivierungsmethoden:

  • Über das Internet
    Die Aktivierung erfolgt automatisch über das Internet und dauert nur wenige Sekunden. Sie benötigen für diese Methode eine funktionierende Internetverbindung.
  • Per E-Mail
    Bei dieser Aktivierungsmethode wird automatisch eine E-Mail mit einer Aktivierungsanfrage erstellt. Senden Sie diese E-Mail-Nachricht an die angegebene Adresse. Damit das automatische E-Mail-Programm direkt antworten kann, dürfen Sie weder den Betreff noch den Text der E-Mail ändern.

Bei der Aktivierung über das Internet sind keine weiteren Schritte erforderlich. Bei der Aktivierung per E-Mail wird Ihnen vom Aktivierungsprogramm eine Aktivierungsdatei zugesendet. Speichern Sie diese Datei auf Ihrer Festplatte, führen Sie den Lizenzmanager aus, und geben Sie den Pfad zu der gespeicherten Datei im Aktivierungsassistenten an.

Wiederholen der Aktivierung

Sie können ABBYY FlexiCapture beliebig oft neu auf dem Computer installieren, auf dem die Software aktiviert wurde. Wenn Sie jedoch grundlegende Änderungen vornehmen, die Festplatte formatieren oder das Betriebssystem neu installieren, müssen Sie die Software möglicherweise erneut aktivieren.

Der Aktivierungsserver speichert ein Protokoll mit der Anzahl der Aktivierungen der einzelnen Seriennummern. Wenn ein bestimmter Schwellenwert überschritten wurde, wird die Seriennummer gesperrt und kann nicht mehr verwendet werden.

Sie können Lizenzen deaktivieren und wieder aktivieren, um sie auf einem anderen Computer zu verwenden. Wenn Sie eine Lizenz deaktivieren, verringert der Aktivierungsserver den Aktivierungszähler für diese Lizenz um eins.

Wichtig! Sie können das aktivierte Programm nur auf dem Computer verwenden, auf dem die Produkt-ID generiert wurde. Wenn Sie die Software auf einem anderen Computer verwenden möchten, müssen Sie die Lizenz zunächst deaktivieren.


Lizenzparameter

Jede Lizenz hat ihre eigene Seriennummer. Eine Lizenz umfasst einen Satz von Parametern, in dem festgelegt ist, ob der Benutzer die Berechtigung zur Durchführung bestimmter Vorgänge zur Dokumentverarbeitung hat.

Lizenzparameter:

  • Description – Seriennummer, Lizenzart, Verfügbarkeit einer virtuellen Maschine
  • Lizenzzweck – Lizenztyp (Software oder Hardware), Möglichkeit der Bereitstellung von Dokumentverarbeitungsdiensten
  • Workstations, Werkzeuge – Einschränkungen bei der Anzahl der Stationen und Entwicklungswerkzeuge (FlexiLayout Studio, FormDesigner)

    Hinweis:Je nach Lizenztyp können die Beschränkungen für die Anzahl der Stationen entweder für Rich- und Webstationen separat oder für beide Stationstypen gemeinsam festgelegt werden.

  • Produktivität – Beschränkungen für die Anzahl der Seiten und der CPU-Kerne. In der Gruppe Seitenbeschränkung wird sowohl die für die Lizenz erlaubte Gesamtseitenmenge als auch die derzeit verfügbare Seitenanzahl angezeigt.
  • Verarbeitung – zusätzliche Parameter für die Dokumentverarbeitung: Verwendung von FlexiLayouts und zusätzlichen Erkennungssprachen
  • Benutzerdefinierte Komponenten (einschließlich Dokumentdefinitionen) – die Verwendung von vom Benutzer entwickelten Komponenten.

Zur Verwendung ABBYY FlexiCapture for Invoices von muss die Lizenz die Kundenkomponente EuropeanInvoice des Lieferanten ABBYY HQ enthalten.

  • Import – zusätzliche Importoptionen; legt fest, ob das ISIS-Protokoll und das Öffnen von PDF-Dateien erlaubt sind
  • Export – zusätzliche Exportoptionen; legt fest, ob der Export in durchsuchbare PDF und der erweiterte XML-Export erlaubt sind


Ändern des Installationsverfahrens, Reparieren und Deinstallieren von ABBYY FlexiCapture

So ändern Sie das Installationsverfahren (wählen Sie entweder die vollständige Installation oder die Operatorstation aus):

  1. Gehen Sie auft Start > Systemsteuerung > Software, wählen Sie in der Liste der installierten Programme ABBYY FlexiCapture 10 aus, und klicken Sie dann auf Ändern.

  2. Wählen Sie Ändern aus, und klicken Sie auf Weiter.

  3. Wählen Sie im angezeigten Dialogfeld das gewünschte Installationsverfahren aus.

So reparieren Sie beschädigte oder gelöschte Dateien:

  1. Gehen Sie auf Start > Systemsteuerung > Software,und wählen Sie dann in der Liste der installierten Programme ABBYY FlexiCapture 11 aus, und klicken Sie dann auf Ändern.

  2. Wählen Sie Reparieren aus, und klicken Sie auf Weiter.

So entfernen Sie ABBYY FlexiCapturevom Computer:

  1. Gehen Sie auf Start > Systemsteuerung > Software, wählen Sie in der Liste der installierten Programme ABBYY FlexiCapture aus, und klicken Sie dann auf Entfernen.

  2. Bestätigen Sie, dass das Programm entfernt werden soll.


Ausführen der Software

So starten Sie ABBYY FlexiCapture:

  • Im Administratormodus: Rufen Sie Start>Programe>ABBYY FlexiCapture 11 auf und wählen Sie ABBYY FlexiCapture Administratorstation.
  • Im Operatormodus: Rufen Sie Start>Programe>ABBYY FlexiCapture 11 auf und wählen Sie ABBYY FlexiCapture Operatorstation.

Wichtig! Stellen Sie vor dem Programmstart Folgendes sicher:

  • Prüfen Sie, ob der Scanner eingeschaltet und mit dem Rechner verbunden ist.

    Wenn der Scanner nicht angeschlossen ist, lesen Sie im Handbuch des Scanners nach.

    Damit der Scanner ordnungsgemäß funktioniert, muss er vor dem Computer eingeschaltet werden.

  • Auf dem Computer wurde ein Lizenzschlüssel installiert. Sie können die Software nur mit diesem Schlüssel ausführen.

Registrierungsschlüssel, die den Anwendungsstart steuern

Sie können die folgenden Registrierungsschlüssel (unter Shell\StartUp) verwenden, um den Start der Anwendung zu steuern:

  • AdminMode: Legt fest, ob die Anwendung im Operatormodus oder im Administratormodus gestartet wird;

  • Projekt: Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird;
  • Batch: Bestimmt den Stapel, der beim Start der Anwendung automatisch geöffnet wird (der Stapel muss angegeben werden).

Diese Schlüssel werden nicht standardmäßig in der Registrierung erstellt. Der Administrator kann diese Schlüssel gegebenenfalls zur Registrierung des Betriebssystems auf dem Rechner des Benutzers hinzufügen.

Die Registrierungsschlüssel können von den entsprechenden Startparametern in der Befehlszeile überschrieben werden.

Befehlszeilen-Startparameter

Die folgenden Parameter können beim Aufruf der Anwendung über die Befehlszeile verwendet werden:

FlexiCapture.exe [/Station:(Admin,Operator)] [/Project:"Projektpfad"] [/Batch:"Stapelname"] [/ProhibitChangePath].

  • [/Station:(Admin,Operator)]: Legt fest, ob die Anwendung im Operatormodus oder im Administratormodus gestartet wird. Ist kein Modus angegeben, wird beim Anwendungsstart ein Dialogfeld angezeigt, in dem der Benutzer aufgefordert wird, den gewünschten Modus auszuwählen.
  • [/Project:"Pfad zum Projekt"]: Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird
  • [/Batch:"Stapelname"]: Legt den Stapel fest, der beim Start der Anwendung automatisch geöffnet wird
  • [/ProhibitChangePath]: Unterbindet das Ändern von Stapel und Projekt, die automatisch im Operatormodus geöffnet werden


Verwenden von Vorlagen, die mit älteren Versionen von ABBYY FormReader erstellt wurden

Vorlagen, die in ABBYY FormReader 6.5 und 6.0 erstellt wurden, können in ABBYY FlexiCapture importiert werden.

Wenn Sie eine Dokumentdefinition importieren, die mit einer älteren Version erstellt wurde, werden die Seitenmarkierungen (mit Ausnahme der Servicefelder) und die Datentypen importiert. Die Datentypen werden in den Ordner Benutzerdefiniert der Dokumentdefinition kopiert. Weitere Informationen finden Sie unter Datentypen für Texteingabefelder.

Wichtig! Exporteinstellungen, Überprüfungsregeln und Bilder aus dem Stapel werden nicht importiert.

So importieren Sie eine Dokumentdefinition, die in ABBYY FormReader 6.5 oder 6.0 erstellt wurde:

  1. Starten Sie ABBYY FlexiCapture im Administratormodus.
  2. Erstellen Sie ein neues Projekt oder öffnen Sie ein vorhandenes Projekt, in das Sie eine Dokumentdefinition importieren möchten, die mit einer älteren Programmversion erstellt wurde.
  3. Wählen Sie im Hauptmenü Projekt > Dokumentdefinitionen… aus.
  4. Klicken Sie im Dialogfeld Dokumentdefinitionen auf Importieren….
  5. Wählen Sie aus der Dropdownliste Dateityp FormReader 6.5-Stapel aus, und wählen Sie dann den Stapel aus, dessen Dokumentdefinition Sie importieren möchten.

Die importierte Dokumentdefinition wird der Vorlagenliste hinzugefügt. Wenn der Stapel mehrere Dokumentdefinitionen enthält, werden alle Vorlagen importiert. Wenn Sie in ABBYY FormReader 6.5 eine Struktur für mehrseitige Dokumente ausgewählt haben, werden die durch diese Struktur beschriebenen Vorlagen in einer mehrseitigen Dokumentdefinition zusammengeführt.

Tipp.

  1. Einzelheiten zu den Unterschieden zwischen den Regeln der älteren und neueren Version finden Sie unter Vergleich von Regeln in FormReader 6.5 und FlexiCapture.
  2. Empfehlungen zur Migration von Wenn-Dann-Regeln, Automatisierungsregeln und Automatisierungsexporten aus FormReader 6.5 in FlexiCapture-Skripte finden Sie unter Migrieren von FormReader 6.5-Regeln und -Exporten in FlexiCapture-Skripte.


Konfigurieren des Programms

Vor der Masseneingabe von Dokumenten muss das Programm für die Verarbeitung der Dokumente des gewünschten Typs konfiguriert werden. Der Administrator konfiguriert alle erforderlichen Einstellungen.

Erstellen Sie zum Konfigurieren der Dokumentverarbeitung ein Projekt mit folgenden Elementen:

  • Bildimportprofile
  • Eine oder mehrere Dokumentdefinitionen
  • Dokumentstapel zur Verarbeitung

Sie können verschiedene Dokumentdefinitionen in das Projekt einbinden. In diesem Fall werden je nach zugeordneter Dokumentdefinition verschiedene Dokumente im gleichen Projekt verarbeitet. Wenn sich die verschiedenen Dokumente jedoch nicht überschneiden, können Sie jeweils separate Projekte erstellen.

Administrator- und Operatormodus
Erstellen eines Projekts
Dokumentdefinitionen
Bildimportprofile

Standardexporteinstellungen

Stapeltypen

Dokumentstapel

Indexfelder


Administrator- und Operatormodus

Für die Dateneingabe in einem Durchgang mithilfe von ABBYY FlexiCapture 10 müssen Sie das System für die Verarbeitung bestimmter Dokumenttypen konfigurieren. Alle Einstellungen werden vom Administrator konfiguriert, die Eingabe der Dokumente wird dagegen von Operatoren durchgeführt. Die Anzahl der Workstations hängt von der Anzahl und dem Volumen der zu verarbeitenden Dokumente ab.

Administratoren konfigurieren das System und steuern den Systembetrieb. Administratoren führen folgende Tasks durch:

  • Entwerfen neuer Formulare (dieser Task kann auch von Entwicklern durchgeführt werden)
  • Konfigurieren des Bildimports und der Scanoptionen
  • Vorbereiten von Dokumentdefinitionen
  • Überwachen der Dateneingabe im konfigurierten System und Anleiten der Operatoren

Operatoren sind für die Dokumenterfassung zuständig. Sie arbeiten in einem durch Administratoren vordefinierten System, in dem bestimmte Dokumenttypen verarbeitet werden können. Operatoren führen folgende Tasks durch:

  • Scannen oder Importieren von Dokumenten
  • Überprüfen der Daten
  • Exportieren der Daten

Die Dokumenterkennung erfolgt automatisch.

Das Programm verfügt über zwei Betriebsmodi: Administratormodus und Operatormodus. Der Administrator hat vollständigen Zugriff auf sämtliche Programmfunktionen. Der Administratormodus kann durch ein Kennwort geschützt werden. Operatoren sind nicht berechtigt, Dokumentdefinitionen zu erstellen oder zu bearbeiten bzw. Importprofile zu erstellen und sie können jeweils nur an einem Projekt oder Stapel gleichzeitig arbeiten.

Bei der Programminstallation können Sie entscheiden, ob Sie nur die Operatorstation oder das gesamte Programm installieren möchten. Wenn Sie die vollständige Installation auswählen, können Sie jederzeit zwischen dem Administrator- und dem Operatormodus wechseln. Zum Wechseln des Modus wählen Sie entweder Start > Alle Programme > ABBYY FlexiCapture > ABBYY FlexiCapture Administrator Station oder Start > Alle Programe > ABBYY FlexiCapture >ABBYY FlexiCapture Operator Station aus. (Detaillierte Informationen finden Sie unter Ausführen der Software).

Im Administratormodus enthält das Hauptmenü die Menüoptionen Teststapel, Dokumentdefinitionen…, Mit Kennwort schützen…, Kennwortschutz aufheben… und auf die im Operatormodus nicht zugegriffen werden kann. Teststapelund Dokumentdefinitionen können somit nur im Administratormodus verwendet werden. Der Operator kann Bildimportprofile und Stapeltypen nicht bearbeiten oder Projekteigenschaften und Exportprojekte ansehen. Administratoren können zudem Projekte durch ein Kennwort schützen sowie den Kennwortschutz aufheben. Wenn Sie ein kennwortgeschütztes Projekt im Administratormodus öffnen möchten, werden Sie zur Eingabe des Kennworts aufgefordert.

Im Operatormodus enthält das Menü Projekt die Menüoption In Administratormodus wechseln…. Wenn Sie diese Menüoption auswählen, werden das aktuelle Projekt und der aktuelle Stapel geöffnet (nach Eingabe des entsprechenden Kennworts, falls der Stapel kennwortgeschützt ist). Wenn Sie nicht über die Berechtigung verfügen, das aktuelle Projekt oder den aktuellen Stapel im Operatormodus zu ändern, werden die entsprechenden Menüoptionen und Symbolleisten nicht angezeigt.


Erstellen eines Projekts

Bevor Sie mit der Verarbeitung von Dokumenten starten können, müssen Sie ein Projekt erstellen. Projekte umfassen:

  • Bildimportprofile
  • Eine oder mehrere Dokumentdefinitionen
  • Stapeltypen

Laden Sie das fertige Projekt zum Anwendungsserver hoch.

Projekte werden auf der Projektkonfigurationsstation erstellt und über die Verwaltungs- und Überwachungskonsole zum Anwendungsserver hochgeladen.

Nach dem Ausführen des Programms wird das Dialogfeld Projekt öffnenangezeigt, in dem Sie eines der vorhandenen Projekte auswählen oder ein neues Projekt erstellen können.

So erstellen Sie ein neues Projekt:

  1. Klicken Sie auf die Schaltfläche Neu erstellen….

  2. Wählen Sie in der Dropdownliste Projekttyp Allgemein als Projekttyp.

Hinweis: ABBYY FlexiCapture for Invoices erlaubt Ihnen die Erstellung von Projekten speziell für die Verarbeitung von Rechnungen. Um ein Rechnungsverarbeitungsprojekt zu erstellen, wählen Sie als Projekttyp Rechnungsverarbeitung.

Einzelheiten finden Sie unter, See " Was ist ABBYY FlexiCapture for Invoices? "

  3. Geben Sie einen Ordner zum Speichern des Projekts sowie den Namen des Projekts an

  4. Klicken Sie auf Erstellen

Projekteigenschaften

Dokumentdefinitionen
Bildimportprofile

Stapeltypen

Dokumentstapel


Stapeltypen

ABBYY FlexiCapture ermöglicht die Stapelverarbeitung von Dokumenten: Vor der eigentlichen Verarbeitung wird ein Stapel erstellt und ihm die Dokumentbilder hinzugefügt. Stapel können beim Import von Bildern automatisch oder manuell erstellt werden (d.h. beim Einscannen von Dokumenten oder beim Import von Bildern bereits gescannter Dokumente). Die Einstellungen für die Dokumentverarbeitung werden für jeden Stapeltyp einzeln festgelegt. Sie können mehrere Stapeltypen für die am häufigsten genutzten Verarbeitungskonfigurationen erstellen. In diesem Fall reduziert sich die Arbeit der Operatoren darauf, einen geeigneten Stapeltyp auszuwählen.

Ein Stapeltyp definiert die folgenden Verarbeitungseinstellungen:

  • Bildvorverarbeitung

  • Dokumentdefinitionen und die Reihenfolge, in der sie angewendet werden sollen

  • Stapelintegritätsprüfung

  • Standard-Stapel- Export
  • Stapelverarbeitung
  • Stapeltyptools

Der Stapeltyp legt auch den Inhalt der Liste der Registrierungsparameter fest (dabei handelt es sich um Textinformationen, die einen Stapel charakterisieren).

Stapeltypen werden für jedes Projekt einzeln erstellt.

So erstellen Sie einen Stapeltyp:

  1. Öffnen Sie das Projekt vom Server

  2. Öffnen Sie das Dialogfeld Stapeltypen durch Auswahl von Projekt>Stapeltypen…
  3. Klicken Sie auf Neu und folgen den Bildschirmanweisungen.


Projekteigenschaften

Die Eigenschaften eines Projekts können in einem separaten Dialogfeld angezeigt und geändert werden, wenn Sie im Hauptfenster die Option Projekt>Projekteigenschaften… auswählen..

  • Die Registerkarte Allgemein zeigt den Namen des Projekts, den Pfad zu den Projektdateien und eine Beschreibung des Projekts an. Auf dieser Registerkarte konfigurieren Sie außerdem die Stapeltyptools. Zum öffnen des Dialogfelds klicken Sie auf die Schaltfläche Tool bearbeiten… im Dialogfeld Stapeltyptool-Einstellungen.
  • Die Registerkarte Bildvorverarbeitungzeigt die Optionen für die Bildvorverarbeitung an. Sie können diese Optionen gegebenenfalls ändern. Einzelheiten finden Sie unter Optionen für die Bildvorverarbeitung.
  • Die Registerkarte Erkennung enthält die Option Leerseiten bei der Erkennung löschen. Aktivieren Sie diese Option, wenn Sie möchten, dass leere Seiten während des Erkennungsvorgangs gelöscht werden. Zusätzlich können Sie auf dieser Registerkarte einen FlexiLayout Klassifikator in Ihr Projekt einbinden.
  • Wählen Sie auf der Registerkarte Überprüfung die Option Felder bei Feldüberprüfung gruppieren , um in dieser Phase die Felder zu gruppieren. Die Felder werden entsprechend des Feldnamens oder der in den Feldeigenschaften bestimmten Gruppe gruppiert.
  • Die Registerkarte Exportziele zeigt die Standardexporteinstellungen an. Um nicht erkannte Dokumente zu exportieren, wählen Sie Export nicht erkannter Dokumente und geben die gewünschten Exporteinstellungen an.
  • Auf der Registerkarte Workflow Workflow können Sie die Stapelverarbeitung (für den "Standard"-Stapeltyp).
  • Die Registerkarte Event-Handler enthält eine Liste der Events, die mit der Hilfe eines Skripts verarbeitet werden können. Um einen Event-Handler zu erstellen, wählen Sie ein Event aus der Liste und klicken auf die Schaltfläche Skript bearbeiten…. Schreiben Sie Ihren Text in den sich öffnenden Skripteditor Einzelheiten finden Sie unter Event-Handler.
  • Auf der Registerkarte .Net-Referenzen können Sie externe Assemblys hinzufügen, die in Skripten und globalen Modulen verwendet werden können. Es können sowohl Standard- als auch kompilierte Benutzerassemblys verwendet werden. Um eine Assembly hinzuzufügen, klicken Sie auf Hinzufügen….Im daraufhin angezeigten Dialogfeld wählen Sie den Typ: Standardname für Assembly oder Angehängte Datei. Je nach ausgewähltem Typ wählen Sie entweder den Standardnamen der Assembly oder suchen Sie nach der Assemblydatei. Einzelheiten finden Sie unter Externe Assemblys.
  • Auf der Registerkarte Umgebungsvariablen können Sie die in Regeln, Exporteinstellungen und Skripten verwendeten Umgebungsvariablen festlegen. Weitere Informationen finden Sie unter Umgebungsvariablen.


Umgebungsvariablen

Eine Umgebungsvariable ist eine Zeichenkette, die dazu dient, Text zu speichern, z. B. den Pfad zu einer externen Ressource. Umgebungsvariablen werden in den Projekteigenschaften (Projekt > Projekteigenschaften > Umgebungsvariablen) festgelegt und in den Dokumentdefinitionen und Skripten verwendet.

Wird ein Projekt auf einem anderen Anwendungsserver oder auf einem anderen Computer bearbeitet, können sich die Pfade zu externen Ressourcen ändern.

Enthält ein Objekt verschiedene Dokumentdefinitionen, mehrere Regeln für die Datenbanküberprüfung und mehrere Skripte, ist die Bearbeitung dieser Objekte zeitaufwändig.

Um die Verarbeitung aller vom Projekt verwendeten Objekte zu vermeiden, können Sie die Pfade zu den externen Objekten in den Umgebungsvariablen angeben und diese Variablen verwenden, wenn Sie Regeln erstellen, den Export einrichten oder Skripte schreiben. Wenn Sie Ihr Projekt jetzt in einer anderen Umgebung bearbeiten, müssen Sie nur die Verbindungsparameter im Dialogfeld Umgebungsvariablen bearbeiten.

Typen von Umgebungsvariablen

In ABBYY FlexiCapture gibt es zwei Typen von Umgebungsvariablen:

  • Zeichenkette – Dies ist eine Textvariable.
  • ADO-Verbindungszeichenfolge – Dies ist eine Zeichenkette, die eine Verbindung zu einer ODBC-kompatiblen Datenbank herstellt.

Erstellen und Bearbeiten von Umgebungsvariablen

So erstellen Sie eine neue Umgebungsvariable:

  1. Klicken Sie im Dialogfeld Projekteigenschaften auf die Registerkarte Umgebungsvariablen und anschließend auf die Schaltfläche Neu….

  2. Wählen Sie im Dialogfeld Neue Umgebungsvariable einen Typ und einen Namen für die Umgebungsvariable aus. Der Typ der Umgebungsvariablen kann später nicht mehr verändert werden.

  3. Füllen Sie in Abhängigkeit vom Typ Ihrer Umgebungsvariable das Feld Wert aus:

    • Geben Sie für die Umgebungsvariable des Typs Zeichenkette einen Wert ein (z. B. den Pfad zu einem Ordner).

    • Geben Sie für die Umgebungsvariable des Typs ADO-Verbindungszeichenfolge den Pfad zu einer Datenbank, die Zugriffsparameter oder andere Verbindungsparameter ein, die für den von Ihnen verwendeten Treiber erforderlich sind.

  4. Geben Sie im Feld Beschreibung die erforderlichen Informationen ein.

Klicken Sie auf Bearbeiten... oder Löschen, um vorhandene Umgebungsvariablen zu bearbeiten oder zu löschen.

Verwenden von Umgebungsvariablen

  • Umgebungsvariablen des Typs Zeichenkette können verwendet werden, um einen Dokumentenexport in Daten- oder Bilddateien einzurichten. Verwenden Sie den Tag <Env:Name_of_environment_vartable>, wenn Sie eine Dateinamenvorlage erstellen.

  • Umgebungsvariablen des Typs ADO-Verbindungszeichenfolge dienen der Verbindung mit verschiedenen Datenbanken:

    • Wenn Sie eine Regel für die Datenbanküberprüfung erstellen
    • Wenn Sie in der Dokumentdefinition den Datenexport einrichten

    • Wenn Sie in einer Dokumentdefinition einen Datensatz mit einer externen Datenbank verbinden

    • Im Feld Eigenschaften, wenn Sie die Einschränkungen für einen Wert eingeben
  • In Skripten können Umgebungsvariablen jeden Typs verwendet werden. Verwenden Sie die Eigenschaft EnvironmentVariables der IProperties, die in der Benutzeroberfläche IProject zur Verfügung steht.


Tooleinstellungen

Mittels des Dialogs Tooleinstellungen können Sie die Verarbeitung bestimmter Ereignisse für alle Stapeltypen konfigurieren. Die Tooleinstellungen gelten unabhängig vom Typ für alle Stapel. Andernfalls werden die Stapel gemäß den für einen Stapeltyp angegebenen Einstellungen verarbeitet.

Die Tooleinstellungen werden für die Stapel wirksam, wenn sie in eine Phase eintreten.

Um das Dialogfeld Tooleinstellungen zu öffnen, klicken Sie auf die Schaltfläche Tool bearbeiten… auf der RegisterkarteAllgemein im Dialogfeld ProjekteigenschaftenProjekteigenschaften dialog box. Das jetzt angezeigte Dialogfeld enthält die folgenden Einstellungen:

Option | Beschreibung
Gruppe Event settings
Schaltfläche Ereignis hinzufügen… | Öffnet das Dialogfeld Event hinzufügenin dem Sie ein Event auswählen, das verarbeitet werden soll. Um das Skript für die Verarbeitung dieses Events zu schreiben, klicken Sie auf die Schaltfläche Skript bearbeiten….
Schaltfläche Skript bearbeiten… | Öffnet den Skripteditor, in dem Sie das Skript für die Verarbeitung des ausgewählten Events bearbeiten können.
Schaltfläche Delete | Entfernt das ausgewählte Event aus der Liste.
Gruppe Skin settings
Schaltfläche Design bearbeiten… | Öffnet das Dialogfeld Designeinstellungen, in dem Sie das Erscheinungsbild der Station einrichten können.
Schaltfläche Design zurücksetzen | Stellt die Design-Standardeinstellungen wieder her.


Designeinstellungen

Im Dialogfeld Designeinstellungen können Sie das Erscheinungsbild der Operatorstation mittels Stapeltyptools. Zum Öffnen des Dialogfelds klicken Sie auf die Schaltfläche Design bearbeiten… im Dialogfeld Stapeltyptool-Einstellungen.

In der Registerkarte Symbolleisten des Dialogfelds können Sie den Satz Symbolleisten konfigurieren. Die Liste der Symbolleisten enthält die vier obligatorischen Symbolleisten: Tasks, Standard, Ansicht und Navigation. Um eine neue Symbolleiste hinzuzufügen, klicken Sie auf die Schaltfläche Hinzufügen.... Geben Sie im daraufhin geöffneten Dialogfeld den Namen der Symbolleiste an und klicken Sie auf OK. Die Symbolleiste wird der Liste hinzugefügt. Um den Namen einer benutzerspezifischen Symbolleiste zu ändern, klicken Sie auf Umbenennen….

In der Registerkarte Befehle können Sie die Befehle im Menü und in der Symbolleiste neu anordnen. Wählen Sie Menü oder Symbolleiste und dann in der entsprechenden Dropdown-Liste ein Menüelement oder eine Symbolleiste, deren Anordnung Sie ändern möchten. Die Gruppe Befehle enthält die Liste der für das ausgewählte Menüelement oder die ausgewählte Symbolleiste verfügbaren Befehle. Für jeden Befehl sind die folgenden Optionen verfügbar:

Option | Beschreibung
Schaltfläche Hinzufügen... | Öffnet das Dialogfeld Befehl bearbeiten, um einen neuen Befehl hinzuzufügen.
Schaltfläche Bearbeiten... | Öffnet das Dialogfeld Befehl bearbeiten, in dem Sie den Namen des Befehls ändern können.
Schaltfläche Löschen | Entfernt den ausgewählten Befehl aus der Liste.
Schaltflächen Nach oben und Nach unten | Verschiebt den ausgewählten Befehl in der Liste nach oben oder nach unten.
Schaltfläche Zurücksetzen | Stellt die Standardeinstellungen wieder her.

Das Feld Tooltipp enthält den Tooltipp-Text für einen Befehl und eine Tastenkombination (sofern ein solcher Schnellzugriff für den Befehl angegeben ist).

Hinweis: Wenn Sie einen Benutzerbefehl hinzufügen, können Sie den Tooltipp-Text für diesen Befehl eingeben. Die maximale Länge des Tooltipp-Texts beträgt 80 Zeichen. Tastenkombinationen für Benutzerbefehle werden in der Registerkarte Tastenkombinationen über das Menü Extras > Optionen… konfiguriert.

Wenn Sie Befehle der Symbolleiste hinzufügen oder bearbeiten, können Sie angeben, ob der Befehl als Text oder als Symbol angezeigt werden soll. Ist die Option Symbol verwenden ausgewählt, klicken Sie auf Durchsuchen (bmp, 24x24)… , um ein Bild für das Symbol des Befehls zu laden. Das Bild muss das Format *.bmp und die Größe 24x24 Pixel haben. Bei Befehlen für die Symbolleiste Tasks muss das Bild 32x32 Pixel groß sein.

Um ein Menüelement hinzuzufügen, das alle benutzerspezifischen Befehle der Symbolleiste anzeigt/ausblendet, wählen Sie in der Registerkarte Befehleein Menüelement aus, dem die Liste der benutzerspezifischen Symbolleisten hinzugefügt wird, und klicken auf Bearbeiten.... Wählen Sie im daraufhin geöffneten Dialogfeld Befehl bearbeiten in der Liste Kategorien den Eintrag Ansicht aus und in der Liste Befehle den Eintrag Benutzerdefinierte Werkzeugleisten. Das Element Benutzerdefinierte Werkzeugleisten mit der Liste alle benutzerdefinierten Symbolleisten wird dem Stationsmenü hinzugefügt.

Hinweis: Der Befehl Benutzerdefinierte Werkzeugleisten kann nicht in eine Symbolleiste, sondern nur ins Menü eingefügt werden.


Registrierungsparameter

Registrierungsparameter sind textuelle Eigenschaften für die Identifizierung eines spezifischen Stapels oder Dokuments. Solche Eigenschaften können das Scandatum, der Name des Scanoperators usw. sein. Ein Registrierungsparameter kann zwingend erforderlich oder optional sein.

Registrierungsparameter können dem Stapel während der Erstellung zugewiesen werden (wenn der Stapel automatisch mittels Importprofilenerstellt wird). Registrierungsparameter können Stapeln und Dokumenten auch auf der Scanstation zugewiesen und zusammen mit den Bildern an ABBYY FlexiCapture gesendet werden.

Die Registrierungsparameter können in der Registerkarte Registrierungsparameter des Dialogfelds für die Stapeleigenschaften oder Dokumenteigenschaften konfiguriert werden (klicken Sie hierfür im Kontextmenü auf Eigenschaften…).

Hinweis: Es wird empfohlen, verschiedene Namen für die Stapel- und Dokument-Registrierungsparameter zu verwenden. Im Falle identischer Namen wird der Dokument-Registrierungsparameter immer beim Ersetzen des Registrierungsparameterwerts verwendet. Beispielsweise beim Generieren von Dateinamen während des Exports.

Collapsed Benannte Registrierungsparameter

Einige Einstellungen für die Dokumentverarbeitung können auch mit benannten Registrierungsparametern vorgenommen werden.

  • fc_Predefined:DefinitionsToMatch. Dieser Registrierungsparameter gibt Ihnen die Möglichkeit, die Anzahl der für die Zuordnung verwendeten Dokumentdefinitionen zu begrenzen. Der Parameterwert wird als Gruppe von Dokumentdefinitionen für die Zuordnung zu einem gegebenen Dokument behandelt. Der Wert kann der Name einer Dokumentdefinition, der Name eines bestimmten Bereiches oder einer Gruppe von Bereichen und Dokumentdefinitionen sein, wobei die einzelnen Elemente durch Semikolons getrennt werden. Beispiel:

    «Document Definition 1; Document Definition 2\Section 1; Document Definition 2\ Section 2».

    Dieser Registrierungsparameter kann vom Operator auf der Scanstation (manuell oder per Script) eingetragen werden. Dieser Parameter kann auch in jeder vor der Erkennung erfolgenden Phase eingetragen werden, wenn klar ist, welcher Dokumentdefinition er zugeordnet werden sollte (z. B. als Ergebnis der Klassifizierung).

  • fc_Predefined:DocumentError. Ist dieser Parameter nicht leer, wird das Dokument in der Exportphase als Dokument mit Fehler betrachtet und entsprechend den Exportprofilen für fehlerhafte Dokumente exportiert. Die Beschreibung eines Fehlers enthält den Wert des Registrierungsparameters.
Collapsed Speichern allgemeiner Informationen der Nachrichtenkopfzeile in den Registrierungsparametern

Wenn Sie mithilfe der MAPI- oder POP3-Serverprotokolle Bilder aus einem E-Mail-Ordner importieren, werden die Informationen über die Nachricht automatisch zu den Registrierungsparametern des von Ihnen erstellten Stapels hinzugefügt. Folgende Parameter werden hinzugefügt:

  • fc_Predefined:EmailSubject
    Der Betreff der Nachricht.
  • fc_Predefined:EmailSender
    Der Name der Nachricht.
  • fc_Predefined:EmailAddressee
    Der Adressat der Nachricht.
  • fc_Predefined:EmailDate
    Empfangsdatum und -zeit der Nachricht.

Hinweis: Wenn keine Informationen über die Nachricht zu den Stapelregistrierungsparametern hinzugefügt werden sollen, setzen Sie folgenden Registrierungsschlüssel: [HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller] "UseHotFolderSpecialParameters"="false".


Qualität der angezeigten Bilder

Die Option Qualität der angezeigten Bilder bestimmt die Qualität der Bilder, die auf den Stationen geladen werden.

Die Qualität der angezeigten Bilder wird für jeden Stapeltyp festgelegt. Beim Erstellen eines Stapels wird sein Typ bestimmt und die Bilder des Stapels werden mit der festgelegten Qualität angezeigt.

Wenn keine Stapeltypen erstellt werden, werden alle Stapelbilder mit der für das gesamte Projekt festgelegten Qualität angezeigt (Registerkarte (Projekt>Projekteigenschaften…, Allgemein).

Jedes Bild wird als eine Reihe von Dateien gespeichert: die Originaldatei, die reduzierten Kopien (Farbe und Schwarz-Weiß) und die Miniaturansicht. Die Originaldatei wird für Erkennung und Export verwendet. Für die Anzeige des Bildes auf den Stationen wird dessen reduzierte Kopie verwendet.

Die folgenden Werte für die Qualität der Bildanzeige können ausgewählt werden: 20%, 40%, 60%, 80% oder 100%.

Durch die Reduzierung der Bildanzeigequalität kann das Laden der Bilder beschleunigt werden, falls die Kapazitäten des Netzwerks auf dem Computer des Operators sehr niedrig sind (z. B. bei Remote-Arbeit). Wird eine niedrigere Qualität ausgewählt, werden die Bilder aufgrund ihrer geringeren Größe schneller geladen.


Dokumentdefinitionen

Das Erstellen von Dokumentdefinitionen ist der wichtigste und entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

Dokumentdefinitionen können nur im Administratormodus erstellt werden.

In einer Dokumentdefinition sind die Positionen von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben. Beim Erstellen einer Dokumentdefinition werden die Eigenschaften der Felder und deren Wertebereiche festgelegt. Darüber hinaus werden Exporteinstellungen für die Daten konfiguriert.

Zum Erstellen einer Dokumentdefinition starten Sie den Dokumentdefinitionsassistenten:

  1. Wählen Sie im Hauptmenü von ABBYY FlexiCapture Projekt>Dokumentdefinitionen… aus.
  2. Klicken Sie im daraufhin geöffneten Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Dokumentdefinitionsassistenten.
Dokumentdefinitionsassistent
Automatische Erkennung von Feldern und statischen Elementen
Statische Elemente
Erstellen von Feldern einer Dokumentdefinition
Feldeigenschaften
Regelbasierte Validierung
Konfigurieren des Datenexports
Konfigurieren der Datendarstellung im Dokumentfenster
Eigenschaften der Dokumentdefinition
Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare
Erstellen von Dokumentdefinitionen für mehrseitige Dokumente
Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente
Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen
Verarbeiten nicht strukturierter Dokumente
Bearbeiten und Veröffentlichen einer Dokumentdefinition
Testen einer Dokumentdefinition
Lokalisierung einer Dokumentdefinition


Dokumentdefinitionsassistent

Wenn Sie eine neue Dokumentdefinition erstellen möchten, wählen Sie im Hauptmenü die Option Projekt>Dokumentdefinitionen… aus und klicken dann im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu…. Daraufhin wird der Assistent zum Erstellen neuer Dokumentdefinitionen geöffnet.

  1. Legen Sie im Dialogfeld Neue Dokumentdefinition erstellen die Grundeinstellungen der Dokumentdefinition fest: Name und Kommentar, verwendete Sprache (Sprache (Gebietsschema)) und Schreibstil (Schreibstil). Die Dropdownliste enthält standardmäßig nur Sprachen mit Wörterbuchunterstützung. Wenn Sie eine Sprache ohne Wörterbuchunterstützung auswählen möchten, aktivieren Sie die Option Alle Sprachen zeigen. Es ist sehr wichtig, die Sprache korrekt anzugeben, da die präzise Dokumenterkennung davon abhängt. Der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, so dass im Programm der jeweils typische Schreibstil ausgewählt wird.

    Collapsed Beispiele für unterschiedliche Schreibstile von Zahlen anzeigen
    - russische Zwei
    - amerikanische Zwei
    - „normale“ Fünf in jedem Schreibstil
    - japanische Fünf
    - russische Eins
    - deutsche Eins
    - „normale“ Neun in jedem Schreibstil
    - tschechische Neun mit Kreis rechts
    - amerikanische Neun ohne Bogenabschluss

    Geben Sie den Texttyp an:

    • ICR (Handschrift)– Aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden;
    • OCR (Druck) – Aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis: Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

    Klicken Sie auf Weiter, um mit dem nächsten Schritt fortzufahren.

  2. Im zweiten Schritt laden Sie das Bild der Dokumentseite, um die Dokumentdefinition zu erstellen. Sie können das Bild einer unausgefüllten Seite scannen oder aus einer Datei laden.

    Hinweis: Die Dokumentdefinition für statische Formulare wird mithilfe eines Bilds erstellt, das durch Scannen eines unausgefüllten Formulars entsteht. Dabei sollte es sich um ein Bild mit guter Qualität ohne Verzerrungen (ohne Schrägstellen, Fehlstellen usw.) handeln. Beim Erstellen von Dokumentdefinitionen von Formularen mit farbigem Hintergrund sollten die Seiten ohne Filter gescannt werden, sodass der Hintergrund beim Scannen nicht ausgeblendet wird. (Wählen Sie später beim Scannen von Seitenbildern zur Datenerkennung einen Scanmodus aus, bei dem der Hintergrund ausgeblendet wird.)

    Wenn Dokumente mehrere Seiten umfassen, laden Sie die erste Seite, und fügen Sie die restlichen Seiten entsprechend den Empfehlungen im Abschnitt Erstellen von Dokumentdefinitionen für mehrseitige Dokumente hinzu.

    Wenn Sie ein FlexiLayout verwenden möchten, das mit ABBYY FlexiLayout Studio erstellt wurde, aktivieren Sie die Option FlexiLayout laden, und geben Sie den Pfad der FlexiLayout-Datei an. Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

    Klicken Sie auf die Schaltfläche Weiter.

  3. Im nächsten Schritt wählen Sie Feldtypen aus, die automatisch im Bild erkannt werden sollen. Sie können Auswahlfelder und Texteingabefelder auswählen. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

    Hinweis: Die automatische Ankersuche wird immer durchgeführt. Wenn ein Formular Anker enthält, werden diese erkannt und im Bild gekennzeichnet.

    Klicken Sie auf die Schaltfläche Fertigstellen.

Nach Beenden des Dokumentdefinitionsassistenten wird das Fenster des Dokumentdefinitionseditors geöffnet, in dem Sie weitere Vorgänge zum Erstellen einer Dokumentdefinition durchführen können. Der nächste Schritt der Erstellung einer Dokumentdefinition ist die Kennzeichnung von Feldern und statischen Elementen im Seitenbild und die Konfiguration der zugehörigen Eigenschaften.


Automatische Erkennung von Feldern und statischen Elementen

Automatische Erkennung beim Hinzufügen eines Bilds:

Beim Hinzufügen eines Seitenbilds werden Anker vom Programm immer erkannt. Wenn das Bild Standardanker enthält (z. B. schwarze Quadrate) werden diese erkannt und markiert. Wenn die Optionen Text oderr Auswahlfelder aktiviert sind, werden Textfelder und Auswahlfelder gesucht. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

Automatische Erkennung im Fenster des Dokumentdefinitionseditors:

Wenn Sie die automatische Erkennung im Fenster des Dokumentdefinitionseditors festlegen möchten, wählen Sie den entsprechenden Modus (Feldmodus oder Modus für statische Elemente) und anschließend die Menüoptionen Extras>Objekte automatisch nach Typ erkennen…. Markieren Sie die Typen der Felder oder statischen Elemente, die automatisch erkannt werden sollen.

Wenn spezifische Objekte im Bild automatisch erkannt werden sollen, wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus, und klicken Sie in der Symbolleiste auf [image]. Wenn Sie auf das betreffende Element klicken, wird es mit einem Rechteck markiert. Der Elementtyp wird automatisch erkannt.

Automatische Erkennung eines Bereichs:

Führen Sie folgende Schritte aus, damit der Bereich eines Felds oder eines statischen Elements eines bestimmten Typs automatisch erkannt wird:

  1. Wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus.

  2. Wählen Sie den Typ des Felds oder statischen Elements über die entsprechende Schaltfläche in der Symbolleiste aus.

  3. Drücken Sie die Umschalttaste

  4. Klicken Sie mit der linken Maustaste in den Bereich des Felds oder des statischen Elements.


Statische Elemente

Statische Elemente werden zur Zuordnung und Identifizierung von Dokumentdefinitionen verwendet. Aus statischen Elementen werden keine Daten extrahiert.

Klicken Sie auf die Schaltfläche [image], um in den Modus für statische Elemente zu wechseln und statische Elemente im Dokumentdefinitionseditor bearbeiten zu können.

Statische Elemente können zur Zuordnung und Identifizierung von Dokumentdefinitionen verwendet werden. Die entsprechende Verwendung wird beim Konfigurieren der Eigenschaften der Elemente festgelegt. Anker dienen der Zuordnung von Dokumentdefinitionen zu Formularbildern. Kennungen sind erforderlich, um beim Verarbeiten mehrerer Formulare in einem Durchgang ermitteln zu können, zu welchen Formularen die entsprechenden Seiten jeweils gehören. Weitere Informationen finden Sie unter Erstellen von maschinenlesbaren Formularen.

Statischen Elementen sind keine Namen, sondern nur Bereiche im Bild zugewiesen.

Wenn eine Dokumentdefinition einem Dokumentbild zugeordnet wird, sucht das Programm nach statischen Elementen. Anhand ihrer Position wird dann eine Dokumentdefinition ausgewählt. Die Erkennung der Werte statischer Elemente (Text und Barcode) wird nur dann durchgeführt, wenn dies zur Identifizierung erforderlich ist. Siehe Angeben von Werten für Objekte zur Identifizierung.

Im Programm werden folgende statische Elemente verwendet:

Statisches Element | Schaltfläche in der Symbolleiste
Anker |
Trennlinie |
Ankertext |
Ankerbarcode |

Beim Hinzufügen eines Bilds wird im Programm automatisch nach Ankern gesucht.

So erstellen Sie ein statisches Element manuell:

  1. Wählen Sie den Modus für statische Elemente aus.

  2. Wählen Sie das Tool zum Erstellen des gewünschten Elementtyps aus.

  3. Setzen Sie den Mauszeiger in die Ecke des Elements, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Bereich des Elements.

Der Bereich des statischen Elements wird in einem Rechteck eingerahmt. Je nach Elementtyp wird der Rahmen in einer anderen Farbe angezeigt. Dem statischen Element werden Standardeigenschaften zugewiesen.

So ändern Sie die Eigenschaften eines statischen Elements:

  1. Markieren Sie den Bereich des statischen Elements im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Ändern Sie die Eigenschaften des statischen Elements im daraufhin geöffneten Dialogfeld.

Weitere Informationen zu statischen Elementen:

  • Anker
  • Trennlinien
  • Ankertext
  • Ankerbarcode


Anker

Anker sind statische Elemente, die im Bild automatisch markiert werden.

So markieren Sie Anker manuell:

  1. Wechseln Sie in den Modus für statische Elemente.

  2. Klicken Sie in der Symbolleiste auf [image] .

  3. Setzen Sie den Mauszeiger in die Ecke eines Ankers, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankerbereich.

Ankereigenschaften

So ändern Sie die Ankereigenschaften:

  1. Markieren Sie den entsprechenden Anker.

  2. Klicken Sie mit der rechten Maustaste in den Ankerbereich und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Eigenschaften im daraufhin geöffneten Dialogfeld:
    • Für Zuordnung von Dokumentdefinitionen verwenden – Diese Option muss aktiviert sein, damit der Anker für die Zuordnung von Dokumentdefinitionen verwendet wird (empfohlen).
    • Für Identifizierung von Dokumentdefinitionen verwenden – Aktivieren Sie diese Option, um den Ankertext zur Identifizierung von Dokumentdefinitionen zu verwenden.
    • Ankertyp – Es ist wichtig, für eine korrekte Zuordnung von Dokumentdefinitionen den Ankertyp anzugeben. Folgende Optionen sind verfügbar: Schwarzes Quadrat, Kreuz, Ecke oder Zeitmarkierung.


Ankertext

Ankertext ist ein statisches Element. Dabei kann es sich um einen beliebigen statischen Text in einem Bild handeln, beispielsweise eine Kopfzeile oder Signatur.

So markieren Sie Ankertext:

  1. Wechseln Sie in den Modus für statische Elemente.

  2. Klicken Sie in der Symbolleiste auf [image].

  3. Setzen Sie den Mauszeiger in die Ecke des Ankertexts, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankertextbereich.

AAnkertexteigenschaften

So ändern Sie die Ankertexteigenschaften:

  1. Markieren Sie den Text.

  2. Klicken Sie mit der rechten Maustaste in den Ankertextbereich und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Eigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Zuordnung von Dokumentdefinitionen verwenden – Diese Option muss aktiviert sein, damit der Ankertext zur Zuordnung von Dokumentdefinitionen verwendet wird.
    • Für Identifizierung von Dokumentdefinitionen verwenden – Aktivieren Sie diese Option, um den Ankertext zur Identifizierung von Dokumentdefinitionen zu verwenden.
    • Wert – Wenn Sie Ankertext als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Wenn automatisch ein Wert eingefügt werden soll, klicken Sie auf die Schaltfläche Tipp.
    • Maximale Fehlerzahl - Hier können Sie die maximal zulässige Anzahl von Fehlern für die Ankertextzeichenfolge festlegen.

    Legen Sie auf der Registerkarte Erkennung Erkennungsoptionen für den mit maximaler Genauigkeit zu erkennenden statischen Text fest:

    • ICR (Handschrift) – Aktivieren Sie diese Option, wenn statischer Text handschriftlich vorliegt.

    • OCR (Druck) – Aktivieren Sie diese Option, wenn statischer Text gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (Druckmaschine, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

    • Erweitert – Über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben.

    • Datentyp – Wählen Sie die Sprache des Texts aus. Verwenden Sie dazu die Schaltfläche Auswählen… .

    • Groß-/Kleinschreibung – Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im statischen Text aus. Wenn der Text Groß- und Kleinschreibung enthält, ändern Sie den Wert Automatisch nicht.

    • Ausrichtung – Geben Sie die Ausrichtung des Texts an.

    • Aktivieren Sie bei einzeiligem Text die Option Eine Zeile.

    • Wenn der Text keine Leerzeichen enthält, z. B. nur aus einem Wort besteht, aktivieren Sie die Option Ein Wort.

    • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:
    • Invertieren –Das Bild wird invertiert.
    • Textur entfernen – Die Textur wird entfernt.
    • Störungen entfernen – Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Nur überflüssige Elemente der festgelegten Größe entfernen – Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Trennlinien

Trennlinien sind statische Elemente. Dabei handelt es sich um horizontale oder vertikale Linien in einem Bild.

So markieren Sie Trennlinien:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].

  3. Setzen Sie den Mauszeiger in die Ecke einer Trennlinie, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    oder

    Klicken Sie bei gedrückter Umschalttaste in den Bereich der Trennlinie.

Eigenschaften von Trennlinien

So ändern Sie die Eigenschaften von Trennlinien:

  1. Markieren Sie die Trennlinie.

  2. Klicken Sie mit der rechten Maustaste in den Bereich der Trennlinie, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.

  3. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:

    • Für Zuordnung von Dokumentdefinitionen verwenden – Diese Option muss aktiviert sein, damit die Trennlinie zur Zuordnung von Dokumentdefinitionen verwendet werden kann.
    • Für Identifizierung von Dokumentdefinitionen verwenden – Aktivieren Sie diese Option, um die Trennlinie zur Identifizierung von Dokumentdefinitionen zu verwenden.


Ankerbarcode

Der Ankerbarcode ist ein statisches Element.

Wichtig! Ein Barcode kann sowohl als Feld als auch als statisches Element markiert werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Zuordnung oder Identifizierung von Dokumentdefinitionen vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Eigenschaften eines statischen Elements, eines Ankerbarcodes, erläutert. Siehe auch Barcodefeld.

So markieren Sie einen Ankerbarcode:

  1. Wechseln Sie in den Modus für statische Elemente.

  2. Klicken Sie in der Symbolleiste auf [image].

  3. Setzen Sie den Mauszeiger in die Ecke eines Barcodes, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    oder

    Klicken Sie bei gedrückter Umschalttaste in den Barcodebereich.

Eigenschaften eines Ankerbarcodes

So ändern Sie die Eigenschaften eines Ankerbarcodes:

  1. Markieren Sie den Barcode.

  2. Klicken Sie mit der rechten Maustaste in den Barcodebereich, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Zuordnung von Dokumentdefinitionen verwenden – Diese Option muss aktiviert sein, damit der Barcode zur Zuordnung von Dokumentdefinitionen verwendet wird
    • Für Identifizierung von Dokumentdefinitionen verwenden – Aktivieren Sie diese Option, um den Barcode zur Identifizierung von Dokumentdefinitionen zu verwenden
    • Wert – Wenn Sie einen Ankerbarcode als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Um einen Wert automatisch einzufügen, klicken Sie auf die Schaltfläche Tipp
    • Für Zuordnung von Dokumentdefinitionen erforderlich – Wenn diese Option aktiviert ist, wird die Dokumentdefinition nur zugeordnet, wenn der Barcode zugeordnet wird. Aktivieren Sie diese Option, wenn ein Stapel zahlreiche ähnliche Dokumentdefinitionen enthält, die nur durch die Werte der Barcodes oder die Werte eines von mehreren Barcodes unterschieden werden können. Dies beschleunigt die Auswahl von Dokumentdefinitionen. Aktivieren Sie diese Option nicht, wenn die Dokumentdefinition zugeordnet werden soll, obwohl kein Barcode vorliegt oder der Barcode zu undeutlich ist.

    Registerkarte Erkennung :

    • Codetyp – Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt)
    • Ausrichtung – Geben Sie die Ausrichtung des Barcodes an

    • Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

    • Invert – Das Bild wird invertiert
    • Textur entfernen - Die Textur wird entfernt
    • Störungen entfernen – Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen
    • Überflüssige Elemente nur in angegebener Größe löschen – Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Angabe von Werten für Objekte zur Identifizierung

Mithilfe von Objekten zur Identifizierung kann festgestellt werden, zu welchem Formular eine Seite gehört und eine Dokumentdefinition ausgewählt werden, bei der der Stapel mehrere Dokumentdefinitionen mit der anfänglichen Ankergruppe enthält. Bei der gleichzeitigen Verarbeitung mehrerer Formulare in einem Durchgang wird anhand der Position der Objekte zur Identifizierung ermittelt, zu welchem Formular die betreffende Seite gehört.

Wenn ein Ankerbarcode oder Ankertext als Objekt zur Identifizierung verwendet wird, können Sie die Werte dieser Objekte zur Identifizierung angeben. In diesem Fall werden beim Zuordnen einer Dokumentdefinition die im Bild erkannten Daten mit dem Wert des Objekts zur Identifizierung verglichen. Die Zuordnung der Dokumentdefinition ist dann nur bei Übereinstimmung der Werte möglich.

Die Werte von Objekten zur Identifizierung können im Dialogfeld für die Eigenschaften von statischen Elementen auf der Registerkarte Allgemein festgelegt werden. Die Werte für Text und Barcodes können automatisch eingetragen werden. Dies erfolgt über die Schaltfläche Tipp.

Hinweis: Wenn es möglich ist, eine Seite nur anhand der Position der Elemente mit absoluter Sicherheit zu identifizieren, müssen Sie diese Werte nicht festlegen. Sie sollten diese Funktion nur einsetzen, wenn dies absolut notwendig ist, da durch die Zuweisung des Werts für das Objekt zur Identifizierung das Erkennungsmodul bei der Anwendung von Dokumentdefinitionen gestartet wird, wodurch sich die Zuordnung von Dokumentdefinitionen mit Bildern verlangsamt.


Erstellen von Feldern einer Dokumentdefinition

Felder sind zur Datenextraktion vorgesehen.

Klicken Sie auf die Schaltfläche [image], um in den Modus für Feldbereiche zu wechseln und Felder im Dokumentdefinitionseditor bearbeiten zu können.

Alle Bereiche im Bild, die zur Datenerfassung eingesetzt werden sollen, müssen als Felder markiert sein. Die Daten in diesen Feldern werden erkannt, und die zugehörigen Werte können exportiert werden.

Feldern sind Namen zugewiesen, deren Listen im Fenster Dokumentstruktur angezeigt werden. Normalerweise verfügen Felder über einen Bereich im Bild. Sie können jedoch auch Felder ohne Bereich erstellen, z. B. zum Speichern von Zwischenergebnissen.

Folgende Feldtypen werden vom Programm erkannt:

Field | Toolbar button
Texteingabefeld |
Auswahlfeld |
Auswahlfeldgruppe |
Barcode |
Bild |
Tabelle |
Feldgruppe |
Bereich für Feld ohne Bereich |
Unbekannter Bereich |

So erstellen Sie ein Feld::

  1. Wählen Sie den Modus für Feldbereiche aus.

  2. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.

  3. Setzen Sie den Mauszeiger in die Ecke des Felds, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Feldbereich.

Der Feldbereich wird durch ein Rechteck eingerahmt. Je nach Feldtyp wird der Rahmen in einer anderen Farbe angezeigt.

Dem erstellten Feld wird ein Standardname zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt. Der Name wird im Fenster "Dokumentstruktur" in der Registerkarte

Felder in der Liste der Felder angezeigt.

Dem Feld werden Standardeigenschaften zugewiesen.

Ein Feld kann auch wie folgt erstellt werden:

  1. Wählen Sie im Menü Bearbeiten oder in der Registerkarte Felder im Kontextmenü einer Seite in der Feldliste den Befehl Feld erstellen.
  2. Geben Sie im Dialogfeld Feldeigenschaften die Feldeigenschaften an und klicken Sie auf OK.
  3. TDas neue Feld wird der Liste hinzugefügt. Es wird durch ein rotes Sternchen als Feld ohne Bereich gekennzeichnet.

  4. Um einen Feldbereich zu erstellen, klicken Sie in der Symbolleiste auf die Schaltfläche [image] und zeichnen den Bereich im Bild. Sie werden aufgefordert, in der Popup-Liste einen zugehörigen Feldnamen auszuwählen.

Um einen Bereich aus der Erkennung auszuschließen, zeichnen Sie im Bild einen Bereich, der nicht erkannt werden soll. Verwenden Sie hierfür die Schaltfläche [image].

  • Erstellen von Gruppen von Auswahlfeldern
  • Erstellen von Tabellen
  • Erstellen einer Feldgruppe
  • Ändern eines Feldnamens
  • Kopieren, Verschieben und Löschen von Feldern
  • Felder ohne Bereich
  • Feldeigenschaften

Auswählen mehrerer Felder

ABBYY FlexiCapture beinhaltet eine Funktion, mit der Sie schnell mehrere Felder auswählen können, wenn Sie eine Gruppe von Feldern nach dem Typ bearbeiten möchten. Öffnen Sie dazu das Menü Bearbeiten und klicken Sie auf Felder nach Typ auswählen… oder drücken Sie Strg+Umschalt+F. Geben Sie im sich öffnenden Fenster die Feldtypen an, die Sie auswählen möchten, und klicken Sie auf OK. Um alle Felder gleichzeitig auszuwählen, klicken Sie auf die Schaltfläche Alles auswählen.


Erstellen einer Gruppe von Auswahlfeldern

In einer Gruppe von Auswahlfeldern werden logisch verknüpfte Auswahlfelder zusammengefasst, die normalerweise sich gegenseitig ausschließenden Antworten auf eine Frage entsprechen. In diesem Fall wird ein Auswahlfeld aus der Gruppe ausgewählt und der zugehörige Wert exportiert. Dabei handelt es sich jedoch nicht um eine zwingende Bedingung. Sie können im Programm festlegen, dass mehrere Auswahlfelder einer Gruppe aktiviert werden können (die entsprechende Option wählen Sie in den Eigenschaften für Gruppen von Auswahlfeldern aus).

Erste Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

So erstellen Sie eine Gruppe von Auswahlfeldern:

  1. Klicken Sie auf das Tool [image], und erstellen Sie Auswahlfelder für die entsprechende Gruppe.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Auswahlfelder der Gruppe einen Auswahlrahmen.

  3. Die innerhalb des Rechtecks liegenden Auswahlfelder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Gruppe positioniert. Die Eigenschaften der Auswahlfelder in einer Gruppe sind identisch und können nicht einzeln bearbeitet werden.

Zweite Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

Sie müssen nicht jedes Auswahlfeld in der Gruppe markieren.

  1. Klicken Sie auf das Tool [image], und markieren Sie stattdessen alle Auswahlfelder, die ein und derselben Gruppe angehören sollen, mit einem Rechteck.

  2. Die Auswahlfelder innerhalb des Rechtecks werden automatisch erkannt, benannt und in einer Gruppe zusammengefasst.


Erstellen einer Feldgruppe

Felder können in Gruppen zusammengefasst werden, so dass Dokumentstrukturen klar dargestellt sowie mehrfach vorkommende Feldgruppen erstellt werden können. So können z. B. Ort, Straße und Hausnummer als „Anschrift“ zusammengefasst werden. Sie können dann Felder für die Gruppe „Firmenanschrift“ einfach durch Kopieren der Feldgruppe „Anschrift“ erstellen.

So erstellen Sie eine Feldgruppe:

  1. Erstellen Sie die Felder, die der Gruppe angehören sollen.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Felder der Gruppe einen Auswahlrahmen.

  3. Die innerhalb des Rechtecks liegenden Felder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Feldgruppe positioniert.

Wenn in einem Formular bestimmte Feldgruppen mehrfach vorkommen, können Sie nach dem Erstellen einer Gruppe mehrere Instanzen dieser Gruppe erstellen. Alle Feldeigenschaften und Regeln der Gruppe gelten jeweils für alle Instanzen der Gruppe. Siehe Felder mit mehreren Instanzen.

Sie können eine Feldgruppe auch kopieren. Dadurch wird jedoch eine neue unabhängige Gruppe erstellt.


Erstellen einer Tabelle

Mit ABBYY FlexiCapture können Sie Dokumentdefinitionen für Dokumente mit Tabellen erstellen. Durch Erstellen von Tabellenfeldern können die Konfiguration von Tabellen, die Datenextraktion sowie der Datenexport aus Tabellen erheblich vereinfacht werden. Bei einem Tabellenfeld handelt es sich um eine Gruppe mit Spalten des gleichen Typs und mehreren Zeilen.

Es stehen folgende Typen von Tabellenspalten zur Verfügung:

  • Text
  • Auswahlfelder
  • Barcodes
  • Bilder

So erstellen Sie eine Tabelle:

  1. Wählen Sie das Tool [image] aus, und ziehen Sie um den Tabellenbereich einen Auswahlrahmen. Die Tabellenkopfzeile muss außerhalb des ausgewählten Bereichs liegen. In der Symbolleiste wird ein weiteres Tool der Tabellenverarbeitung zum Löschen einer Trennlinie angezeigt:
    Trennlinie löschen
  2. Grenzen Sie Tabellenzellen ab, indem Sie die erforderliche Anzahl Trennlinien zeichnen. Um Trennlinien zu erstellen, klicken Sie auf die Stelle, an der die Trennlinie eingefügt werden soll. Setzen Sie zum Erstellen einer vertikalen Trennlinie den Mauszeiger in den Tabellenbereich, drücken Sie die Umschalttaste und klicken Sie einmal mit der linken Maustaste. Führen Sie zum Erstellen einer horizontalen Trennlinie den gleichen Vorgang bei gedrückter Alt-Taste aus. Sie können auch festlegen, dass Trennlinien automatisch erkannt werden. Markieren Sie die erstellte Tabelle, und wählen Sie dann im Menü die Optionen Vertikale Trennlinien automatisch erkennen und Horizontale Trennlinien automatisch erkennen aus.

  3. Erstellen von Tabellenspalten. Um eine Spalte zu erstellen, klicken Sie in den Spaltenbereich und wählen in der Dropdown-Liste einen Spaltentyp aus.


Ändern eines Feldnamens

So benennen Sie ein Feld um:

  • Klicken Sie in der Dokumentstruktur auf den entsprechenden Feldnamen, klicken Sie mit der rechten Maustaste, wählen Sie im Kontextmenü die Option Umbenennenaus, und geben Sie einen neuen Namen ein.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Name vorschlagenaus. Dem Feld wird ein Name zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste und wählen Sie im Kontextmenü die Option Name aus Bild abrufen… aus. Markieren Sie anschließend mit dem Mauszeiger den erklärenden Text, der als Feldname verwendet werden kann. Daraufhin wird der ausgewählte Text als Feldname angezeigt.

Oder

  • Öffnen Sie das Dialogfeld für die Feldeigenschaften und ändern Sie den Namen auf der Registerkarte Allgemein.


Kopieren, Verschieben und Löschen von Feldern

Felder können kopiert, gelöscht, verschoben und geändert werden. Die Namen kopierter Felder sind durch eine unterschiedliche Nummerierung gekennzeichnet. Mehrere Felder können Sie durch Klicken bei gedrückter Strg-Taste markieren. Die ausgewählte Aktion wird dann auf alle markierten Felder angewendet.

Wenn Sie ein Feld löschen möchten, markieren Sie es und drücken Sie Entf oder wählen Sie im Kontextmenü die Option Löschen aus. Wenn Sie nur den Bereich löschen und das Feld in der Dokumentstruktur beibehalten möchten, drücken Sie Umschalt+Entf oder wählen Sie im Kontextmenü des entsprechenden Felds die Option Bereich löschenaus. Siehe Felder ohne Bereich.


Felder ohne Bereich

Felder haben im Bild möglicherweise keinen Bereich. Die Namen der Felder ohne Bereich sind in der Liste durch ein rotes Sternchen gekennzeichnet. In diesen Feldern können beispielsweise Zwischenergebnisse aus Berechnungen gespeichert werden, die anhand der Werte der erkannten Felder durchgeführt werden. Sie können z. B. die Werte mehrerer Felder mithilfe der Regel zum Verbinden von Feldwerten kombinieren und das Ergebnis in einem Feld ohne Bereich speichern.

Felder ohne Bereich haben alle Eigenschaften des entsprechenden Feldtyps. Die Werte dieser Felder können ebenfalls exportiert werden.

Felder ohne Bereich können folgendermaßen erstellt werden:

  1. Klicken Sie im Dokumentdefinitionseditor auf die Menüoption Bearbeiten>Feld erstellen und erstellen Sie ein Feld mit dem gewünschten Feldtyp. Der Feldname wird in der Liste mit einem Sternchen angezeigt. Damit wird in der Dokumentstruktur ein Feld, jedoch kein Bereich im Bild erstellt.
  2. Die andere Möglichkeit besteht darin, den Bereich eines regulären Felds zu löschen. Markieren Sie das gewünschte Feld im Bild oder in der Liste und wählen Sie im Kontextmenü die Option Bereich löschen aus. Der Bereich wird gelöscht, und der Name des Felds wird durch ein rotes Sternchen gekennzeichnet.

Wenn Sie einen Bereich für Felder erstellen möchten, die im Bild keinen Bereich haben, klicken Sie in der Symbolleiste auf [image], und markieren Sie den gewünschten Bereich mit dem Mauszeiger. Wenn die Liste Felder mit Sternchen enthält, werden Sie aufgefordert, ein Feld mit dieser Kennzeichnung auszuwählen.


Ausschließen eines Bereichs von der Erkennung

Manchmal ist es erforderlich, einen bestimmten Bereich von der Erkennung auszuschließen, z. B. einen Bereich mit erklärendem Text, der die Extraktion der Daten aus einem Feld erschwert.

Wenn Sie einen Bereich von der Erkennung ausschließen möchten, klicken Sie auf das Tool [image], und markieren Sie den auszuschließenden Bereich mit dem Mauszeiger.


Erstellen eines Felds mit einem nicht rechteckigen Bereich

Manchmal ist es notwendig, Felder mit nicht rechteckigen Bereichen zu erstellen, z. B. im folgenden Fragebogen:

So erstellen Sie einen nicht rechteckigen Feldbereich:

  1. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.
  2. Wählen Sie einen rechteckigen Bereich aus, in dem Sie Bereichsteile in der gewünschten Form hinzufügen oder entfernen können.
  3. Wählen Sie das Tool [image] aus und markieren Sie den rechteckigen Bereich.

  4. So fügen Sie ein Bereichsfragment in den Bereich ein: Drücken Sie die Umschalttaste (der Mauszeiger wird als Pluszeichen angezeigt), und markieren Sie das entsprechende Fragment.

  5. So entfernen Sie ein Bereichsfragment: Drücken Sie Alt (der Mauszeiger wird als Minuszeichen angezeigt) und markieren Sie das entsprechende Fragment.


Felder mit mehreren Bereichen

Ein Feld kann mehrere Bereiche im Bild umfassen. Diese Bereiche können sich voneinander entfernt und auch auf verschiedenen Seiten befinden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert.

Es empfiehlt sich, bei Feldern, die sich auf mehreren Seiten befinden, mehrere Bereiche zu erstellen, z. B. bei großen Tabellen.

Collapsed Beispiel anzeigen

In diesen Feldern sind die Werte vertikal sortiert, d. h. der Wert eines Bereichs mit der obersten Grenze ist der erste Bereich im Feld.

So erstellen Sie ein Feld mit mehreren Bereichen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Bereich fortsetzen… aus.

  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Felder mit mehreren Instanzen

In Feldern können manche Elemente wiederholt auftreten. Dabei handelt es sich um Felder und Feldgruppen, die in einem Formular mehrfach vorkommen und ähnliche Objekte betreffen, z. B. die gleichen Details mehrerer Mitarbeiter, Kinder, Konten usw. Für diese Objekte werden Felder mit mehreren Instanzen erstellt.

Für jedes Feld können mehrere Instanzen festgelegt werden. Die zugehörigen Bereiche können voneinander entfernt und auch auf verschiedenen Seiten positioniert werden. Feldinstanzen weisen die gleichen Eigenschaften auf. Sie werden in separate Dateien oder Datenbanktabellen exportiert.

Sie können mehrere Instanzen einer Feldgruppe erstellen, wenn in einem Feld Gruppen mehrfach vorkommen.

Collapsed Beispiel anzeigen

So erstellen Sie ein Feld mit mehreren Instanzen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Neue Instanz… aus.
  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Feldeigenschaften

Es ist sehr wichtig, dass die Eigenschaften jedes Felds korrekt konfiguriert werden. Feldeigenschaften wirken sich auf die Qualität beim Erkennen der Felder sowie darauf aus, ob die Werte der Felder exportiert und zur Überprüfung an den Operator gesendet werden können. Einige Eigenschaften spielen bei der Datenerkennung eine große Rolle. Dies betrifft beispielsweise die Markierungsmethode eines Texteingabefelds. Wenn das Texteingabefeld falsch konfiguriert ist, wird die beim Scannen nicht ausgeblendete Markierung nicht von den Zeichen getrennt. Die Erkennung ist dadurch möglicherweise nicht zufriedenstellend.

Die verschiedenen Feldtypen verfügen jeweils über andere Eigenschaften. Wenn Sie in einem Bild ein Feld eines bestimmten Typs erstellen, werden dem Feld die entsprechenden Standardeigenschaften zugewiesen.

So können Sie Feldeigenschaften ändern:

  1. Markieren Sie den Feldnamen in der Dokumentstruktur oder den Feldbereich im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.

  2. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld.

Über die folgenden Links erhalten Sie weitere Informationen zu den Feldeigenschaften:

Texteingabefelder
Auswahlkästchen
Gruppen von Auswahlfeldern
Barcodes
Bilder
Tabellen
Feldgruppen
Dienstfeld


Texteingabefeld

Wenn Sie ein Textfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Datentypen
Erkennungseigenschaften
Überprüfungseigenschaften
Regelbasierte Validierung
Benutzerskript (benutzerdefinierte Aktion)


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie die allgemeinen Eigenschaften eines Feldes festlegen.

  • Name
    Der Name eines Feldes. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem treffendsten Beschreibungstext für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Weitere Informationen finden. Sie unter Ändern des Feldnamens.
  • Überschrift
    Die Beschriftung des Feldes im Datenformular.
  • Feldwert exportieren
    Bestimmt, ob das Feld exportiert wird. Diese Option ist standardmäßig aktiviert. Sie können sie jedoch deaktivieren, beispielsweise, wenn der Feldwert nur zur Berechnung eines anderen Feldwerts dient und selbst nicht exportiert werden muss (weitere Informationen finden Sie unter Regelbasierte Validierung). Diese Option steht für alle Felder zur Verfügung.
  • Schreibgeschützt
    Gibt an, dass ein Feld nur im Lesezugriff verwendet werden kann. Ist diese Option aktiviert, kann der Operator den Wert nicht ändern. Diese Eigenschaft ist praktisch, wenn Feldwerte automatisch berechnet werden, z. B. durch Hinzufügen von oder Verketten mit anderen Feldwerten (weitere Informationen finden Sie unter Regeln).
    Diese Eigenschaft steht für die Feldtypen Text, Barcode, Auswahlfeld und Auswahlfeldgruppe zur Verfügung.
  • Bei Überprüfung anzeigen
    Gibt an, ob ein Feld im Datenformular angezeigt wird. Diese Eigenschaft ist standardmäßig aktiviert und für alle Felder verfügbar.
  • Indexfeld
    Ist diese Eigenschaft für ein Feld aktiviert, können die Dokumente anhand des Werts dieses Feldes sortiert und abgerufen werden. Über diese Eigenschaft verfügen die Feldtypen Text und Barcode.
  • Feld in Vorschaufenster anzeigen
    Gibt an, ob der Wert des Feldes im Vorschaufenster angezeigt wird, wenn die Ansicht der Gruppe, zu der es gehört, minimiert wurde.
    Diese Eigenschaft steht für die Feldtypen Text, Barcode, Auswahlfeld, Dienstfeld und Auswahlfeldgruppe zur Verfügung.
  • Kann Bereich enthalten
    Aktivieren Sie diese Option, wenn Sie einen Bereich für ein Feld oder eine Gruppe angeben möchten.
    Diese Eigenschaft steht für alle Felder außer dem Dienstfeld zur Verfügung.
  • Sollte zugeordnet werden
    Wurde diese Option für ein Feld aktiviert, wird das Feld während der Überprüfung hervorgehoben, wenn kein Feldbereich gefunden werden kann. Diese Option kann auch im Modus Bei Übereinstimmung zum nächsten nicht zugeordneten Feld gehen gewählt werden.
    Diese Option steht nur zur Verfügung, wenn die Option Kann Bereich enthalten aktiviert ist.
  • Kommentar
    Der Kommentar eines Feldes.

Hinweis: Rechts neben allen Feldnamen wird ein Symbol eingeblendet, das den Feldtyp angibt.


Datentypen für Texteingabefelder

Einige der wichtigsten Parameter für Textfelder, die sich auf die Erkennungsqualität, die vorläufige Überprüfung und die Änderung von Felddaten auswirken können, sind die Einstellungen der Datentypen.

ABBYY FlexiCapture nutzt Datentypen, um Text in Feldern zu erkennen. Korrekt angegebene Daten verbessern die Erkennungsqualität, erhöhen den Zuverlässigkeitsgrad erkannter Symbole und verringern somit die Arbeitsbelastung des Datenüberprüfungsoperators.

Die Funktionen von ABBYY FlexiCapture zum Erstellen von Datentypen sind sehr flexibel. Sie können Datentypen aus einer Liste vorhandener Typen auswählen oder benutzerdefinierte Typen erstellen, indem Sie das Alphabet regulärer Ausdrücke oder ein für den vorliegenden Task passendes benutzerdefiniertes Wörterbuch verwenden.

Auf der Registerkarte Daten des Dialogfelds Eigenschaften eines Feldes können Sie die Datentypen von Textfeldern angeben. Dieser Artikel behandelt die Einstellungen, die für alle Felder und Einstellungen bestimmter Feldtypen gelten.

Allgemeine Einstellungen für Textfelder

  • Datentyp (Dropdownliste)
    Legen Sie mit dieser Dropdownliste den Datentyp (d. h. den Datentyp, den Sie im Feld erwarten) wie eine Adresse, die Uhrzeit, das Datum, einen Geldbetrag, einen Namen, einen Code, Text oder eine Zahl fest.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist.

    • Der Standardwert wird einem Feld auch zugewiesen, wenn der Bereich des Felds gelöscht wurde. Hat ein Benutzer das Feld leer gelassen (zum Beispiel in der Überprüfungsphase), wird dem Feld kein Standardwert zugewiesen.
    Sie können den Standardwert ändern. Ist der Standardwert leer, bleiben die Felder bis zur Eingabe eines Wertes leer.
    Hinweis: Diese Option steht für Textfelder und Textspalten von Tabellen zur Verfügung.

  • Autokorrektur-Optionen
    Diese Optionen legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können den Austausch oder das Löschen von Sonderzeichen oder Leerzeichen und das Ändern der Groß- und Kleinschreibung beinhalten.

    Die automatische Korrektur kann auch zur Formatierung der Daten verwendet werden und verringert die Arbeitsbelastung der Operatoren, die die Daten auf den Export vorbereiten. Sie können die standardmäßigen Autokorrekturoptionen von ABBYY FlexiCapture verwenden oder ein Benutzerskript, das vor allem bei der Ausführung komplexer Formatierungen nützlich sein kann. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.

  • Validierung
    Diese Optionsgruppe enthält Einstellungen, mit denen festgelegt werden kann, wie Werte geprüft werden, und mit denen Grenzwerte für die Anzahl der Zeichen, die Mindestwerte und Höchstwerte für Zahlenfelder oder ein zulässiger Datenbereich eingestellt werden.
    Die Option Kann nicht leer sein in dieser Gruppe gibt vor, ob das Feld erforderlich ist.
    • Collapsed Externe Quellen zulässiger Werte

    Der Bereich der zulässigen Werte eines Felds kann mithilfe externer Datenbanken oder einer Textdatei eingeschränkt werden. Die Einschränkungs- und Prüfungsparameter hängen vom Datentyp des Feldes ab. Entsprechen die erkannten Daten nicht den Prüfparametern, werden während der Überprüfung im Dokumentfenster Formatierungsfehler angezeigt.

    Die Verwendung einer externen Quelle zulässiger Werte ermöglicht Folgendes:

    • Die Verbesserung der Erkennungsqualität eines Feldes durch die Angabe zulässiger Wörter zusätzlich zu zulässigen Zeichen. Werte dieser Liste verwendet das Programm während der Erkennung. Die Ausgabewerte sind entweder mit einem Element aus der Liste identisch oder entsprechen einem Listenelement weitestgehend. Findet das Programm die erkannten Daten nicht im Wörterbuch, wird bei der Erkennung nur das Alphabet verwendet. Verwenden Sie die Einstellungen für Inhaltstypen von Feldern, um benutzerdefinierte Wörterbücher einzurichten.
    • Ein bereits erkanntes Feld kann mit einer lokalen oder externen Liste zulässiger Werte geprüft werden. Wird der erkannte Wert in der Liste nicht gefunden, wird eine Formatierungsfehlermeldung angezeigt. Mit den Validierungsoptionen der Felder können Sie eine Liste der zulässigen Werte laden und einrichten.
  • Normalisierung verwenden
    Legen Sie mit dieser Option das gewünschte Format von Textfeldern des Typs Zeit, Datum, Geldbetrag und Zahl fest. Diese Option ist standardmäßig deaktiviert. Die erkannten Daten werden im Formular angezeigt und in ihrem Originalformat exportiert.

Einrichten bestimmter Textfeldtypen

Collapsed Adresse

Textfelder des Typs Adresse haben die folgenden Einstellungen:

  • Details
    Mit den Optionen dieser Gruppe verändern Sie die Erkennungssprache, geben Sie das benutzerdefinierte Wörterbuch an und wählen Sie spezifischere Datentypen wie E-Mail-Adressen und Postadressen. Die Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten... rechts neben dem Textfeld klicken; eine Zusammenfassung der ausgewählten Feldeigenschaften wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache des Feldes.
    • Inhaltseinstellungen: Allgemein
      In diesem Fall empfehlen wir Ihnen, ein benutzerdefiniertes Wörterbuch einzufügen, um die Erkennungsqualität zu verbessern. Aktivieren Sie dazu die Option Benutzerdefiniertes Wörterbuch verwenden und klicken Sie zur Bearbeitung des Wörterbuchs auf Bearbeiten.... Über die Schaltfläche Hinzufügen... oder durch den Import von Wörtern aus einer TXT- oder DIC-Datei können Sie ein benutzerdefiniertes Wörterbuch hinzufügen. Klicken Sie auf die Schaltfläche Laden..., um Wörter aus einer Datei zu importieren oder den Dateipfad anzugeben.
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können den Austausch oder das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Führen Sie mit den Optionen dieser Gruppe Einschränkungen für den Inhalt von Feldern ein, z. B. für die Anzahl der Zeichen, die ein Feld enthalten darf.
    Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps „Text“.

    Mit der Option Kann nicht leer sein in dieser Gruppe wird festgelegt, ob das Feld erforderlich ist.

Collapsed Geldbetrag

Textfelder des Typs Geldbetrag haben die folgenden Einstellungen:

  • Wert als Text verarbeiten
    Aktivieren Sie diese Option, wenn der Feldwert wie regulärer Text verarbeitet werden soll. Dies kann nützlich sein, wenn ein Geldbetrag nicht in das Standardformat gebracht werden kann oder wenn Sie ihn nicht als Zahl zu verarbeiten brauchen. Der Wert kann mit einem benutzerdefinierten Wörterbuch geprüft werden. Die Einschränkung des Wertebereichs erfolgt ebenso wie für Text. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache zu ändern, zusätzliche Parameter für ganze Zahlen oder Brüche anzugeben und spezifischere Datentypen wie zweistellige Zahlen oder römische Ziffern auszuwählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache des Feldes.
    • Inhaltseinstellungen: Allgemein
      Diese Gruppe enthält zusätzliche Einstellungen für ganze Zahlen und Brüche.

      Bei negativen Zahlen können Sie ein Minuszeichen links von der Zahl zulassen (Beispiel: - 54). Sie können Klammern für negative Zahlen zulassen, (54) entspricht dann - 54.

      Folgende Optionen stehen Ihnen für Bruchzahlen zur Verfügung: Muss Dezimalwert enthalten, Mehr als zwei Stellen in Dezimalwert erlauben: 54,3679 und Leerzeichen als Dezimalsymbol erlauben 54 36.

      Wenn die Option Nur ganzzahlige Werte markiert ist, werden die Trennzeichen zwischen der ganzen Zahl und dem Dezimalwert ignoriert. Dazu zählen Dezimalpunkte, Kommas, Bindestriche, Gleichheitszeichen und Leerzeichen.

      Hinweis: Die Option Leerzeichen als Dezimalsymbol erlauben 54 36 funktioniert nur, wenn die Option Ein Wort auf der Registerkarte Erkennung deaktiviert wurde.

    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Prüft, ob ein Wert in einen festgelegten Bereich fällt. Klicken Sie zur Angabe dieses Bereichs auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Weitere Informationen finden Sie unter Einschränkungen für den Wertebereich von Zahlen.
    Mit der Option Kann nicht leer sein wird festgelegt, ob das Feld erforderlich ist.
  • Normalisierung verwenden
    Geben Sie mit dieser Option benutzerdefinierte Formate für Werte des Typs Geldbetrag an. Klicken Sie auf die Schaltfläche Normalisierungseinstellung bearbeiten…, um den Dialog Normalisierungseinstellungen für Währung zu öffnen, der diese Optionen enthält. Der obere Teil dieses Dialogfelds zeigt ein Beispiel dafür an, wie eine positive und eine negative Zahl nach der Anwendung der Einstellungen aussehen. Diese Einstellungen sind nachfolgend beschrieben:
    • Mindestanzahl der Ziffern in Ganzzahlteil
      Mögliche Werte liegen im Bereich zwischen 0 und 9.
    • Zifferngruppierung
      Trennt Gruppen von jeweils drei Ziffern in Zahlen mit Leerzeichen.
    • Symbol für Zifferngruppierung
      Dieses Symbol dient zum Trennen von Zifferngruppen. Mögliche Werte sind Leerzeichen, Komma und Punkt.
    • Dezimalsymbol
      Dieses Symbol dient zum Trennen des ganzzahligen Teils einer Dezimalzahl von den Dezimalstellen. Mögliche Werte sind Punkt oder Komma.
    • Mindestanzahl der Ziffern nach dem Dezimalzeichen
      Die Mindestanzahl der Ziffern im Dezimalwert einer Dezimalzahl. Mögliche Werte: 0 bis 4.
    • Maximalanzahl der Ziffern nach dem Dezimalzeichen
      Die maximale Anzahl der Ziffern im Dezimalwert einer Dezimalzahl. Mögliche Werte: 0 bis 4.
      Ist dieser Parameter auf 0 gesetzt, wird der Bruch auf die nächste ganze Zahl gerundet.
    • Klammern für negative Werte verwenden
      Aktivieren Sie diese Option, wenn negative Werte anstelle eines Minuszeichens links von der Zahl in Klammern gesetzt werden sollen.
    • Währungsformat
      Wählen Sie aus dieser Dropdownliste das gewünschte Währungsformat aus.

    Hinweis: Für diese Felder müssen normalisierte Zahlen zur Verfügung stehen. Widersprechen Einstellungen der Gruppe Normalisierung verwenden den Einstellungen der Gruppe Details, tritt bei der Prüfung der Vorlage ein Fehler auf.

Wichtig!
Die Datentypen für Zahlen sollten nicht für Felder verwendet werden, die nur Ziffern enthalten, bei denen es sich jedoch um mehr als eine einfache Zahl handelt, wie z. B. Kreditkarten- und Passnummern. Die Verwendung des Datentyps „Zahl“ für diese Felder kann Probleme verursachen wie die Entfernung von Nullen aus Werten, die mit Nullen beginnen. In diesen Fällen empfehlen wir Ihnen, auf der Grundlage eines regulären Ausdrucks ein benutzerdefiniertes Datenfeld mit einem Alphabet zu erstellen, das alle Ziffern (von 0 bis 9) enthält. Wenn Sie trotzdem einen Datentyp „Zahl“ verwenden möchten, müssen Sie die Option Wert als Text verarbeiten aktivieren.

Collapsed Code

Textfelder des Typs Code (Codes enthalten Buchstaben und Ziffern) haben folgende Einstellungen:

  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache zu verändern, benutzerdefinierte Wörterbücher hinzuzufügen und spezifischere Datentypen wie eine Sozialversicherungsnummer auszuwählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache für das Feld.
    • Inhaltseinstellungen: Allgemein
      In diesem Fall empfehlen wir Ihnen, ein benutzerdefiniertes Wörterbuch einzufügen, um die Erkennungsqualität zu verbessern. Aktivieren Sie dazu die Option Benutzerdefiniertes Wörterbuch verwenden und klicken Sie zur Bearbeitung des Wörterbuchs auf Bearbeiten.... Über die Schaltfläche Hinzufügen... oder durch den Import von Wörtern aus einer TXT- oder DIC-Datei können Sie ein benutzerdefiniertes Wörterbuch hinzufügen. Klicken Sie auf die Schaltfläche Laden..., um Wörter aus einer Datei zu importieren oder den Dateipfad anzugeben.
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Führen Sie mit den Optionen dieser Gruppe Einschränkungen für den Inhalt eines Feldes ein, z. B. für die Anzahl der Zeichen. Einzelheiten finden Sie unterEinschränkungen für den Wertebereich des Datentyps „Text“.
    Die Option Kann nicht leer sein bestimmt, ob das Feld erforderlich ist.
Collapsed Datum

Textfelder des Typs Datum haben die folgenden Einstellungen:

  • Wert als Text verarbeiten
    Aktivieren Sie diese Option, wenn der Feldwert wie regulärer Text verarbeitet werden soll. Dies kann nützlich sein, wenn ein Datum nicht in das Standardformat gebracht werden kann oder wenn Sie es nicht als Datum zu verarbeiten brauchen. Der Wert kann mit einem benutzerdefinierten Wörterbuch geprüft werden. Die Einschränkung des Wertebereichs erfolgt ebenso wie für Text. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
  • Details
    Mit den Optionen dieser Gruppe können Sie die Erkennungssprache verändern, die Reihenfolge von Bestandteilen des Datums ändern, die Uhrzeit oder einen Wochentag hinzufügen und einen spezifischeren Datentyp wie Monatsangaben in römischen Zahlen wählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Zusammenfassung der Eigenschaften des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache für das Feld.
    • Inhaltseinstellungen: Allgemein
      Die Einstellungen von Standardtypen für Datumsangaben enthalten: Kann Monate in Worten enthalten (lässt zusätzlich zu Ziffern auch ausgeschriebene Monate zu), Kann Wochentag enthalten (lässt Wochentage im Datumsfeld zu), und Kann Zeit enthalten (lässt Zeitangaben im Datumsfeld zu).
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
    • Reihenfolge der Datumskomponenten
      Wählen Sie einen oder mehrere mögliche Datentypen aus. Wenn mehrere Datumstypen ausgewählt wurden und die Option Erstes akzeptables Datumsformat verwenden nicht aktiviert ist, wird ein geeignetes Datumsformat vom Programm ausgewählt.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Prüft, ob ein Datum in einen festgelegten Zeitraum fällt. Klicken Sie zur Angabe dieses Bereichs auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Weitere Informationen finden Sie unter Einschränkungen für den Wertebereich von Datumsangaben.
    Die Option Kann nicht leer sein bestimmt, ob dieses Feld erforderlich ist.
  • Normalisierung verwenden
    Optionen in dieser Gruppe können verwendet werden, um benutzerdefinierte Ausgabeformate für Werte des Typs Datum festzulegen. Klicken Sie auf die Schaltfläche Normalisierungseinstellung bearbeiten…, um diese Einstellungen zu ändern. Der obere Teil des Dialogs Normalisierungseinstellungen bearbeiten… enthält Beispiele, die zeigen, wie die Einträge nach der Anwendung aller Einstellungen angezeigt werden. Diese Einstellungen sind nachfolgend beschrieben:
    • Datumsformat
      Das Ausgabeformat für das Datum.
    • Datumstrennzeichen
      Das Zeichen, das zur Trennung der verschiedenen Bestandteile des Datums verwendet wird.
    • Enthält Wochentag
      Gibt an, dass der Wochentag am Anfang des Datums steht. Wird bei der Erkennung kein Wochentag gefunden, legt das System den Wochentag anhand des Datums fest.
    • Enthält Uhrzeit
      Gibt an, dass auf das Datum die Uhrzeit folgt. Wird bei der Erkennung keine Uhrzeit gefunden, wird 00:00 zum Datum hinzugefügt. Das Uhrzeitformat wird mit den beiden folgenden Optionen festgelegt.
    • Zeitformat
      Das Ausgabeformat der Werte der Uhrzeit.
    • Uhrzeittrennzeichen
      Das Zeichen, das zur Trennung der Bestandteile des Werts für die Uhrzeit verwendet wird.

    Hinweis:
    Für diese Felder müssen normalisierte Zahlen zur Verfügung stehen. Widersprechen Einstellungen der Gruppe Normalisierung verwenden den Einstellungen der Gruppe Details, tritt bei der Prüfung der Vorlage ein Fehler auf.

    Hinweis: Das Programm umfasst einen intelligenten Mechanismus zur Datumserkennung.
    Findet das Programm beispielsweise ein nicht eindeutiges Datum (wie 01/02/02), schlägt es auf der Grundlage der festgelegten Einstellungen eine Liste mit möglichen Werte vor.
    Enthält das Datum einen Wochentag, der nicht mit dem Datum übereinstimmt, wird während der Überprüfung ein Formatierungsfehler angezeigt.
    Werte mit Schreib- und Erkennungsfehlern werden automatisch durch korrekte Werte ersetzt (z. B. wird „Mitwoch“ durch „Mittwoch“ ersetzt und „Septembere“ durch „September“).

Collapsed Name

Textfelder des Typs Name haben die folgenden Einstellungen:

  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache zu verändern, benutzerdefinierte Wörterbücher hinzuzufügen und spezifischere Datentypen wie Vor- und Nachname auszuwählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache für das Feld.
    • Inhaltseinstellungen: Allgemein
      In diesem Fall empfehlen wir Ihnen, ein benutzerdefiniertes Wörterbuch einzufügen, um die Erkennungsqualität zu verbessern. Aktivieren Sie dazu die Option Benutzerdefiniertes Wörterbuch verwenden und klicken Sie zur Bearbeitung des Wörterbuchs auf Bearbeiten.... Über die Schaltfläche Hinzufügen... oder durch den Import von Wörtern aus einer TXT- oder DIC-Datei können Sie ein benutzerdefiniertes Wörterbuch hinzufügen. Klicken Sie auf die Schaltfläche Laden..., um Wörter aus einer Datei zu importieren oder den Dateipfad anzugeben.
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem FeldAutokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Führen Sie mit den Optionen dieser Gruppe Einschränkungen für den Inhalt eines Feldes ein, z. B. für die Anzahl der Zeichen. Einzelheiten finden Sie unterEinschränkungen für den Wertebereich des Datentyps „Text“.
    Die Option Kann nicht leer sein bestimmt, ob das Feld erforderlich ist.
Collapsed Zahl

Textfelder des Typs Zahl haben die folgenden Einstellungen:

  • Wert als Text verarbeiten
    Aktivieren Sie diese Option, wenn der Feldwert wie regulärer Text verarbeitet werden soll. Dies kann nützlich sein, wenn eine Zahl nicht in das Standardformat gebracht werden kann oder wenn Sie sie nicht als Zahl zu verarbeiten brauchen. Der Wert kann mit einem benutzerdefinierten Wörterbuch geprüft werden. Die Einschränkung des Wertebereichs erfolgt ebenso wie für Text. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache zu ändern, zusätzliche Parameter für ganze Zahlen oder Brüche anzugeben und spezifischere Datentypen wie zweistellige Zahlen oder römische Ziffern auszuwählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache des Feldes.
    • Inhaltseinstellungen: Allgemein
      Diese Gruppe enthält zusätzliche Einstellungen für ganze Zahlen und Brüche.

      Bei negativen Zahlen können Sie ein Minuszeichen links von der Zahl zulassen (Beispiel: - 54). Sie können Klammern für negative Zahlen zulassen, (54) entspricht dann - 54.

      Folgende Optionen stehen Ihnen für Bruchzahlen zur Verfügung: Muss Dezimalwert enthalten, Mehr als zwei Dezimalstellen im Dezimalwert und Leerzeichen als Dezimalsymbol erlauben.

      Wurde die Option Nur ganzzahlige Werte gewählt, werden die Trennzeichen zwischen der ganzen Zahl und dem Dezimalwert ignoriert. Dazu zählen Dezimalpunkte, Kommas, Bindestriche, Gleichheitszeichen und Leerzeichen.

      Hinweis: Die Option Leerzeichen als Dezimalsymbol erlauben funktioniert nur, wenn die Option Ein Wort auf der Registerkarte Erkennung deaktiviert ist.

    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Prüft, ob ein Datum in einen festgelegten Zeitraum fällt. Klicken Sie zur Angabe dieses Bereichs auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Weitere Informationen finden Sie unter Einschränkungen für den Wertebereich von Zahlen.
    Mit der Option Kann nicht leer sein wird festgelegt, ob das Feld erforderlich ist.
  • Normalisierung verwenden
    Geben Sie mit dieser Option der Gruppe benutzerdefinierte Formate für Werte des Typs Zahl an. Klicken Sie auf die Schaltfläche Normalisierungseinstellung bearbeiten…, um den Dialog Normalisierungseinstellungen für Zahlen zu öffnen, das diese Optionen enthält. Der obere Teil dieses Dialogfelds zeigt ein Beispiel dafür an, wie eine positive und eine negative Zahl nach der Anwendung der Einstellungen aussehen. Diese Einstellungen sind nachfolgend beschrieben:
    • Mindestanzahl der Ziffern in Ganzzahlteil
      Mögliche Werte liegen im Bereich zwischen 0 und 9.
    • Zifferngruppierung
      Trennt Gruppen von jeweils drei Ziffern in Zahlen mit Leerzeichen.
    • Symbol für Zifferngruppierung
      Dieses Symbol dient zum Trennen von Zifferngruppen. Mögliche Werte sind Leerzeichen, Komma und Punkt.
    • Dezimalsymbol
      Dieses Symbol dient zum Trennen des ganzzahligen Teils einer Dezimalzahl von den Dezimalstellen. Mögliche Werte sind Punkt oder Komma.
    • Mindestanzahl der Ziffern nach dem Dezimalzeichen
      Die Mindestanzahl der Ziffern im Dezimalwert einer Dezimalzahl. Mögliche Werte: 0 bis 4.
    • Maximalanzahl der Ziffern nach dem Dezimalzeichen
      Die maximale Anzahl der Ziffern im Dezimalwert einer Dezimalzahl. Mögliche Werte: 0 bis 4.
      Ist dieser Parameter auf 0 gesetzt, wird der Bruch auf die nächste ganze Zahl gerundet.
    • Klammern für negative Werte verwenden
      Aktivieren Sie diese Option, wenn negative Werte anstelle eines Minuszeichens links von der Zahl in Klammern gesetzt werden sollen.

Hinweis: Für diese Felder müssen normalisierte Zahlen zur Verfügung stehen. Widersprechen Einstellungen der Gruppe Normalisierung verwenden den Einstellungen der Gruppe Details, tritt bei der Prüfung der Vorlage ein Fehler auf.

Wichtig!
Die Datentypen für Zahlen sollten nicht für Felder verwendet werden, die nur Ziffern enthalten, bei denen es sich jedoch um mehr als eine einfache Zahl handelt, wie z. B. Kreditkarten- und Passnummern. Die Verwendung des Datentyps „Zahl“ für diese Felder kann Probleme verursachen wie die Entfernung von Nullen aus Werten, die mit Nullen beginnen. In diesen Fällen empfehlen wir Ihnen, auf der Grundlage eines regulären Ausdrucks ein benutzerdefiniertes Datenfeld mit einem Alphabet zu erstellen, das alle Ziffern (von 0 bis 9) enthält. Wenn Sie trotzdem einen Datentyp „Zahl“ verwenden möchten, müssen Sie die Option Wert als Text verarbeiten aktivieren.

Collapsed Text

Textfelder des Typs Text haben die folgenden Einstellungen:

  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache zu verändern, benutzerdefinierte Wörterbücher hinzuzufügen und spezifischere Datentypen wie Vor- und Nachname auszuwählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache für das Feld.
    • Inhaltseinstellungen: Allgemein
      In diesem Fall empfehlen wir ein integriertes oder benutzerdefiniertes Wörterbuch. Der Wert des Feldes wird mithilfe dieses Wörterbuchs überprüft. Wenn Sie ein integriertes Wörterbuch verwenden möchten, wählen Sie die Option Integriertes Wörterbuch verwenden. Um ein benutzerdefiniertes Wörterbuch zu verwenden, aktivieren Sie die Option Benutzerdefiniertes Wörterbuch verwenden und klicken Sie zur Bearbeitung des Wörterbuchs auf Bearbeiten.... Über die Schaltfläche Hinzufügen... oder durch den Import von Wörtern aus einer TXT- oder DIC-Datei können Sie ein benutzerdefiniertes Wörterbuch hinzufügen. Klicken Sie auf die Schaltfläche Laden... und geben Sie den Dateipfad an, um Wörter aus einer Datei zu importieren.
      Hinweis: DIC-Dateien sind im Wesentlichen Textdateien, die eine Wortliste mit jeweils einem Wort pro Zeile enthalten. Das Dateiformat stammt von Microsoft Office.
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem FeldAutokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Führen Sie mit den Optionen dieser Gruppe Einschränkungen für den Inhalt eines Feldes ein, z. B. für die Anzahl der Zeichen. Einzelheiten finden Sie unterEinschränkungen für den Wertebereich des Datentyps „Text“.
    Die Option Kann nicht leer sein bestimmt, ob das Feld erforderlich ist.
Collapsed Uhrzeit

Die folgenden Einstellungen sind für Felder des Typs Zeit verfügbar:

  • Wert als Text verarbeiten
    Aktivieren Sie diese Option, wenn der Feldwert wie regulärer Text verarbeitet werden soll. Dies kann nützlich sein, wenn ein Geldbetrag nicht in das Standardformat gebracht werden kann oder wenn Sie ihn nicht als Zahl zu verarbeiten brauchen. Der Wert kann mit einem benutzerdefinierten Wörterbuch geprüft werden. Die Einschränkung des Wertebereichs erfolgt ebenso wie für Text. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
  • Details
    Verwenden Sie die Einstellungen dieser Gruppe, um die Erkennungssprache und die Formatierung von Uhrzeiten zu verändern und spezifischere Datentypen wie die Angabe der Zeit im 12-Stunden-Format zu wählen. Um diese Optionen zu ändern, klicken Sie auf die Schaltfläche Bearbeiten... rechts neben dem Feld; eine Beschreibung der Parameter des ausgewählten Feldes wird ebenfalls angezeigt.
    • Sprache
      Die Erkennungssprache für das Feld.
    • Inhaltseinstellungen: Allgemein
      Wird für Standardzeitangaben verwendet.
    • Inhaltseinstellungen: Spezial
      Verwenden Sie diese Option, um einen Datentyp aus einer vordefinierten Liste von Datentypen auszuwählen. Die Beschreibung im unteren Teil des Dialogfensters hilft Ihnen bei der Auswahl des richtigen Typs. Sie können auch benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  • Standardwert
    Der Standardwert wird einem Textfeld automatisch zugewiesen, wenn es nach Anwendung der Dokumentdefinition oder der Zusammenstellung des Dokuments leer ist. Weitere Einzelheiten finden Sie oben.
  • Autokorrektur-Optionen
    Die Optionen dieser Gruppe legen fest, auf welche Weise das Programm automatisch Feldwerte korrigiert. Diese Korrekturen können das Löschen von zusätzlichen Leerzeichen oder das Ändern der Groß- und Kleinschreibung und den Austausch spezifischer Zeichen oder Textfragmente beinhalten. Diese Optionsgruppe wird angezeigt, wenn Sie auf die Schaltfläche Bearbeiten… rechts neben dem FeldAutokorrektur-Optionen klicken. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  • Validierung
    Mit der Option Kann nicht leer sein in dieser Gruppe wird festgelegt, ob das Feld erforderlich ist.
  • Normalisierung verwenden
    Geben Sie mit dieser Option der Gruppe benutzerdefinierte Formate für Werte des Typs Zeit an. Klicken Sie auf die Schaltfläche Normalisierungseinstellung bearbeiten…, um das Dialogfeld Normalisierungseinstellungen für die Uhrzeit zu öffnen, in dem Sie das Format für die Uhrzeit und das Symbol zur Trennung der Bestandteile des Werts für die Uhrzeit (z. B. eine Trennung der Minuten von den Stunden durch einen Doppelpunkt) festlegen können.


Erstellen benutzerdefinierter Datentypen

Wählen Sie zum Erstellen eines neuen Datentyps in den Feldeigenschaften auf der Registerkarte Daten das gewünschte Element aus der Liste Datentyp. Sie können jedes Element aus der Liste wählen, das der Semantik Ihres benutzerdefinierten Datentyps entspricht. Das hat zwar keinen Einfluss auf die Art des neuen Datentyps, aber er wird in der ausgewählten Kategorie gespeichert.

Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details.

Wählen Sie in dem daraufhin angezeigten Dialogfeld die Option Sonderformat im Feld Inhaltseinstellungen.

Klicken Sie auf die Schaltfläche Neu… rechts neben dem Feld Datentypen für ausgewählte Sprache.

Befolgen Sie die Anweisungen im Assistenten für neue Datentypen.

Im ersten Fenster des Assistenten wählen Sie aus, wie Ihre Daten erstellt werden sollen. Sie können einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks, eines Alphabets oder eines vorhandenen Datentyps erstellen (z. B., indem Sie gewünschte Zeichen zu seinem Alphabet hinzufügen oder sein Wörterbuch erweitern).

So erstellen Sie einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks oder eines Alphabets:

  1. Wählen Sie Neuer Datentyp beruht aufund dann die Grundlage, die für Ihren neuen Datentyp verwendet werden soll: ein Wörterbuch, ein regulärer Ausdruck oder ein Alphabet. Wählen Sie dann die Sprache (Gebietsschema) für Ihren Datentyp, und klicken Sie auf Weiter.
  2. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Wörterbuchs zu erstellen, dann fordert Sie der Assistent im nächsten Fenster dazu auf, die Art des Wörterbuchs auszuwählen, das verwendet werden soll.
    Wählen Sie Integriertes Wörterbuch verwenden wenn Sie das integrierte Wörterbuch für die Sprache verwenden möchten, die Sie im Fenster zuvor ausgewählt haben. Wenn Sie prüfen möchten, ob das Wörterbuch ein bestimmtes Wort enthält, dann klicken Sie auf Anzeigen… und geben das Wort ein. Durch Klicken auf die Schaltfläche Anzeigen werden entweder die gebeugten Formen des Worts angezeigt oder eine Warnmeldung, die besagt, dass es dieses Wort im Wörterbuch nicht gibt.
    Wählen Sie Benutzerdefinierte Wörterbücher verwenden , wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, und klicken Sie auf Bearbeiten… , um das entsprechende Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden... und geben Sie den Pfad zur gewünschten Datei mit der Endung *.txt oder *.dic an). Klicken Sie auf Weiter.
    Note: Die DIC-Datei ist ein benutzerdefiniertes Wörterbuch in Microsoft Office. Es handelt sich um eine einfache Textdatei mit einer Wortliste, ein Wort pro Zeile.
    Note: Für ein benutzerdefiniertes Wörterbuch, das Wörter des folgenden Typs enthält:

    201.01.063.030
    201.01.063.031
    201.01.063.040

    muss eine *.txt-Datei mit den folgenden Daten erstellt werden:

    DICTIONARY_PROPERTIES=USE_CONFIDENCE
    201.01.063.030 100
    201.01.063.031 100
    201.01.063.040 100

  3. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines regulären Ausdrucks zu erstellen, wird der Assistent Sie dazu auffordern, einen regulären Ausdruck einzugeben. Verwenden Sie die Schaltfläche [image] rechts neben dem Feld für den regulären Ausdruck, um Ihren regulären Ausdruck zusammenzusetzen. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken. Klicken Sie auf Weiter.
  4. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Alphabets zu erstellen, oder wenn Sie in Ihrem regulären Ausdruck Zeichen verwendet haben, die nicht Teil des Alphabets der gewählten Sprache sind, dann werden Sie vom Assistenten aufgefordert, ein Alphabet für Ihren Datentyp anzugeben. Sie können die gewünschten Zeichen entweder direkt über die Tastatur eingeben oder auf Anpassen… klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Wenn Sie Satzzeichen und ausgeschlossene (unzulässige) Zeichen einfügen möchten, klicken Sie auf Erweiterte Parameter…. Sie können die unzulässigen Zeichen entweder direkt über die Tastatur eingeben oder auf die Schaltfläche auf der rechten Seite klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Klicken Sie auf Weiter.

  5. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

So erstellen Sie einen neuen Datentyp auf der Grundlage eines vorhandenen Datentyps:

  1. Wählen Sie im ersten Fenster des Assistenten für neue Datentypen Datentyp beruht auf vorhandenen Typen. Wählen Sie die gewünschte(n) Sprache(n) aus, und klicken Sie auf Weiter.
  2. Wählen Sie im nächsten Fenster den (die) Quelldatentyp(en) aus, welche(r) die Grundlage für Ihren neuen Datentyp bilden soll(en). Diejenigen Datentypen, die den ausgewählten Sprachen entsprechen, werden auf der linken Seite des Dialogfelds in der Liste List1 aufgeführt. Der Ordner Text enthält die natürlichen Sprachen, die im ersten Fenster ausgewählt wurden. Der Ordner Benutzerdefiniert enthält die Datentypen, die von Benutzern erstellt wurden. Die anderen Ordner enthalten die Datentypen entsprechend der Kategorie und den Sonderformaten für spezielle Inhalte.
    Sie wählen einen Quelldatentyp aus, indem Sie ihn im Feld List1 markieren (halten Sie die Strg-Taste gedrückt, um mehrere Typen zu markieren) und dann auf Hinzufügen -> klicken, um ihn in den rechten Bereich zu übertragen. Klicken Sie auf Weiter.
    Hinweis: Basiert ein neuer Datentyp auf mehreren Typen, wird das gesamte Feld auf Einhaltung mindestens eines Datentyps hin überprüft.
  3. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

Der neu erstellte Datentyp wird in der Liste der vordefinierten Datentypen angezeigt, wenn Sie den Inhalt auswählen, der beim Erstellen des Datentyps gewählt wurde.

So legen Sie den neu erstellten Datentyp für Ihr Feld fest:

  1. Wählen Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Daten tdas gewünschte Element in der Liste Datentyp aus;
  2. Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details;
  3. Wählen Sie in der Liste Inhaltseinstellungen die Option Sonderformat;
  4. Wählen Sie in der nun angezeigten Liste den Datentyp aus, den Sie erstellt haben (benutzerdefinierte Datentypen sind mit einem speziellen Symbol gekennzeichnet), und klicken Sie auf OK.


Einschränkungen für den Wertebereich des Datentyps "Text"

Im Dialogfeld Validierungseinstellungen können Sie Einschränkungen für den Wertebereich von Text festlegen, der in diesem Feld eingegeben wird.

Hinweis: Das Programm behandelt nicht nur Datentypen mit Textinhalten als Texttyp, sondern auch alle Datentypen mit anderen Inhalten, für die die Option Wert als Text verarbeiten aktiviert wurde.

  • Maximale Länge – Geben Sie die maximale Länge für Text in diesem Feld an.;
  • Wählen Sie im Feld Inhalts-Einschränkung die Option Regulärer Ausdruck aus der Liste aus, wenn ein regulärer Ausdruck zur Überprüfung der Feldwerte verwendet werden soll. Über die Schaltfläche [image] erhalten Sie Hilfe zur korrekten Formulierung von regulären Ausdrücken. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken.
  • Um Fehlermeldungen besser lesbar zu machen, auf dem Feld Beschreibung des regulären Ausdrucks, eine Beschreibung der regulären Ausdrücke, die in Fehlermeldungen verwendet wird.
  • Wählen Sie im Feld Inhalts-Einschränkung die Option Zulässige Werte aus der Liste aus, wenn Sie eine Liste zulässiger Werte festlegen müssen. Um einen Wert hinzuzufügen, klicken Sie auf Hinzufügen… und geben den Wert ein. Wenn Sie einen Wert bearbeiten möchten, klicken Sie auf Bearbeiten…, und wenn Sie einen Wert löschen möchten, klicken Sie auf Löschen. Um zulässige Werte aus einer Datei zu laden, klicken Sie auf Laden…
  • Wählen Sie die Option Externe Quelle zulässiger Werte verwenden , wenn erkannte Werte in der Liste zulässiger Werte anhand einer externen Textdatei oder Datenbank überprüft werden müssen. Um die Quelle der Werte festzulegen, klicken Sie auf die Schaltfläche Bearbeiten…. Bei dieser Art von Überprüfung wird die Liste zulässiger Werte nicht in das Projekt kopiert und die Verbindung zur externen Quelle wird direkt während der Überprüfung hergestellt.
  • Validierungsfehler als Warnungen behandeln – Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen. Warnungen gestatten es dem Operator, weiterhin Dokumente zur nächsten Verarbeitungsphase zu senden, während bei unkorrigierten Formatfehlern vor dem Senden eine zusätzliche Bestätigung vom Operator erforderlich ist.


Einschränkungen für den Wertebereich von Zahlen

So geben Sie Einschränkungen für den Wertebereich von Zahlen an:

  1. Aktivieren Sie die Option Einschränkungen verwenden.

  2. Geben Sie die Höchst- und Mindestwerte für die Zahlen an.

  3. Validierungsfehler als Warnungen behandeln – Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.

Bei der Dokumentverarbeitung überprüft die Software, ob der eingegebene Wert im angegebenen Intervall liegt.


Einschränkungen für den Wertebereich von Datumsangaben

Im Dialogfeld Validierungseinstellungen können Sie das Intervall für das in diesem Feld eingegebene Datum festlegen.

  1. Aktivieren Sie die Option Datum muss innerhalb des folgenden Bereichs liegen.
  2. Wählen Sie Fest vorgegeben, um ein festes Zeitintervall festzulegen, oder wählen Sie In Abhängigkeit vom Überprüfungsdatum , um ein Zeitintervall einzurichten, das sich relativ zum Datum der Dokumentüberprüfung verhält.

  3. Geben Sie den Beginn und das Ende des Zeitraums ein.

  4. Validierungsfehler als Warnungen behandeln – Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.


Verarbeiten eingegebener Werte

Für jeden Datentyp können Sie festlegen, dass die eingegebenen Werte automatisch verarbeitet und dabei folgende Schritte ausgeführt werden: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben, automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung von Feldwerten auf der Registerkarte Daten des Dialogfelds für die Feldeigenschaften auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen.

Wählen Sie die gewünschten Optionen für die automatische Verarbeitung aus.

Wenn die Option AutoCorrect nur unmittelbar nach Erkennung anwenden ausgewählt ist, wird die automatische Verarbeitung nur einmal ausgeführt, nachdem der Feldwert erkannt worden ist. Anderenfalls wird die automatische Verarbeitung jedes Mal ausgeführt, wenn der Wert des Felds geändert wird.

  • Um die Zeichen im erkannten Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Zeichen ersetzen. Im daraufhin angezeigten Dialogfeld können Sie Zeichen für die automatische Ersetzung hinzufügen. Hinzugefügte Werte werden in alphabetischer Reihenfolge sortiert. Sofern die angegebenen Zeichen in den erkannten Feldwerten auftreten, werden sie automatisch ersetzt. Sie können die folgenden Ersetzungsparameter angeben:
    1. Geben Sie in das Feld Ersetzen ein oder mehrere zu ersetzende Zeichen ein.
    2. In das Feld Mit geben Sie ein zu ersetzendes Zeichen oder eine zu ersetzende Zeichenfolge ein.
      Hinweis: Die Zeichenfolge kann angewendet werden, wenn die Ersetzung für den gesamten Text durchgeführt wird. Für andere Optionen (Präfix, Suffix, Präfix und Suffix) gilt nur das erste Zeichen..
      Collapsed Beispiel zeigen

      Bei der Ersetzung im Präfix wird "A" durch das erste Zeichen der Ersetzungszeichenfolge ersetzt.

      Bei der Ersetzung von Gesamter Text wird jedes Zeichen der Zeichenfolge "ENT" durch "WXY" ersetzt.

    3. Im Feld Wo wählen Sie aus, ob bestimmte Zeichen in Präfix, Suffix, Prefix und Suffix oder im gesamten Text ersetzt werden sollen.

      Wird Präfix ausgewählt, werden alle in der Liste Ersetzen festgelegten aufeinanderfolgenden Zeichen ab Beginn des Textes ersetzt. Für Suffix erfolgt die Zeichenersetzung vom Ende des Textes aufwärts.

      Beispiel: Wenn Sie das Ersetzen von " B" mit "%" und "AC" mit "#" im Präfix wählen, wird die Zeichenfolge "ABC ENTERTAC CORP" konvertiert zu "#%#%ENTERTAC CORP".

      Collapsed Beispiel zeigen

  • Um den gesamten erkannten Feldwert oder einzelne Wörter im Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Text ersetzen.

    Im angezeigten Dialogfeld können Sie Wörter und Ausdrücke für die automatische Ersetzung hinzufügen. Damit nur ganze Felder ersetzt werden, wählen Sie Nach gesamtem Feldinhalt suchen.

    Wenn Sie die Option Genaue Suche aktivieren, sucht das Programm nach genau dem eingegebenen Wort oder Ausdruck und ersetzt diesen. Wenn Sie jedoch Tolerante Suche aktivieren, sucht das Programm nach einem dem eingegebenen Wort oder Ausdruck ähnlichen Wert und ersetzt diesen. Die Anzahl der zulässigen Fehler hängt von der Länge des Wortes ab.

    Wenn Sie jedoch Groß-/Kleinschreibung beachten aktivieren, sucht das Programm nach einem dem eingegebenen Wort oder Ausdruck ähnlichen Wert und ersetzt diesen. Die Anzahl der zulässigen Fehler hängt von der Länge des Wortes ab.

  • Wählen Sie in der Dropdownliste Groß-/Kleinschreibung ändern eines der Verfahren für die Buchstabenumwandlung aus:

    Kein – Es erfolgt keine Umwandlung;

    GROSSSCHREIBUNG – Alle Buchstaben werden in Großschreibung geändert;

    kleinschreibung – Alle Buchstaben werden in Kleinschreibung geändert;

    Erster Buchstabe groß – Der erste Buchstabe wird in einen Großbuchstaben und die übrigen werden in Kleinbuchstaben geändert.

  • Überschüssige Leerzeichen entfernen – Aktivieren Sie diese Option, wenn überzählige Leerzeichen entfernt werden sollen.

Für automatische Ersetzungen können Sie auch ein Autokorrekturskript verwenden. wählen Sie die Option Skript verwenden, klicken Sie auf Bearbeiten… , um den Skripteditor zu öffnen, und geben Sie den Code des Skripts ein.


Erkennungsoptionen für Textfelder

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte wird die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

Wählen Sie im Feld "Fülltyp" den gewünschten Erkennungsmodus aus: Standarderkennung, Nicht erkennen oder Skripterkennung.

Im Modus Standarderkennung legen Sie die folgenden Optionen fest:

  • ICR (Handschrift) – Aktivieren Sie diese Option, wenn statischer Text in diesem Feld handschriftlich vorliegt.

  • OCR (Druck) – Aktivieren Sie diese Option, wenn statischer Text in diesem Feld gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (typografisch, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

  • Erweitert – Über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben. Diese Option erlaubt Ihnen außerdem das Laden einer Musterdatei im *.ptn-Format. Ein Muster besteht aus einem während der Musterprobe erstelltem Satz Paare "ein Zeichenbild - das Zeichen selbst". Während der Erkennung wird als Quelle zusätzlicher Informationen ein Benutzermuster verwendet. Die Musterprobe wird verwendet für:

    • Texte in dekorativen Schriftarten;
    • Texte, die ungewöhnliche Zeichen enthalten (z. B. mathematische Symbole);
    • lange (über hundert Seiten) Dokuemte mit schlechter Druckqualität.

    Sie können Benutzermuster in ABBYY FineReader Professional/Corporate Edition 9.0 (oder älter) oder in ABBYY FineReader Engine 9.0 (oder älter) erstellen.

    Klicken Sie zum Laden eines Musters auf Ändern…. Wählen Sie im angezeigten Dialogfeld Folgendes Muster verwenden und geben Sie den dazu gehörigen Pfad an.

  • Markierungstyp – Wählen Sie den Markierungstyp aus. Zur Vereinfachung können Sie in der Dropdownliste Beispiele auswählen. Wenn die Markierung beim Scannen verschwindet, wird für die Markierung der gleiche Abstand zwischen den Zeichen verwendet (graue Felder). Wenn die Markierung beim Scannen nicht verschwindet und für die Leerzeichen in Zellen unterteilt wird, müssen Sie die Gesamtanzahl der Zellen eingeben. Wenn Felder mit dieser Markierung im Programm automatisch erkannt werden, wird auch die Anzahl der Zellen automatisch festgelegt.

  • Groß-/Kleinschreibung – Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im Feld aus. Wenn sowohl Groß- als auch Kleinschreibung möglich ist, lassen Sie die Option Automatisch aktiviert.

  • Ausrichtung – Geben Sie die Ausrichtung des Texts an.

  • Aktivieren Sie bei einzeiligen Feldern die Option Eine Zeile.

  • Aktivieren Sie bei Feldern, die immer nur ein Wort enthalten, die Option Ein Wort. Wählen Sie diese Option, wenn ein regulärer Ausdruck für das gesamte Feld angewendet werden soll, unabhängig von der Anzahl Wörter darin.

  • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:

    • Invertieren – Das Bild wird invertiert..
    • Textur entfernen – Die Textur wird entfernt.
    • Störungen entfernen – Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Überflüssige Elemente nur in angegebener Größe löschen – Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Ist diese Option deaktiviert und nur die Option Störungen entfernen aktiviert, wird die Größe der überflüssigen Elemente automatisch ausgewählt.

    Wählen Sie den Modus Nicht erkennen aus, wenn das Feld aus einem bestimmten Grund nicht erkannt werden kann (z. B. wenn der Text im Feld verschwommene Zeichen enthält) und der Operator den Wert manuell eingeben muss. In diesem Fall müssen Sie die anderen Erkennungseigenschaften nicht konfigurieren, da das Feld nicht erkannt wird. Der Operator wird während der Überprüfung aufgefordert, den Feldwert einzugeben.

    Wählen Sie den Modus Skripterkennung aus, wenn Sie eine benutzerdefinierte Erkennung oder einen Initialisierungsalgorithmus ausführen möchten. Weitere Informationen finden Sie unter Benutzerdefiniertes Erkennungsskript.


Feldüberprüfungseigenschaften

Überprüfung Bei der Überprüfung handelt es sich um die Kontrolle der erkannten Daten durch einen Operator. Das Programm markiert unzuverlässig erkannte Zeichen rot und fordert den Operator auf, die Zeichen zu bestätigen oder zu korrigieren. Dazu werden die Zeichen gemeinsam mit den ursprünglichen Bildern angezeigt. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn keine unzuverlässig erkannten Zeichen darin vorkommen. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn unzuverlässig erkannte Zeichen darin vorkommen.

Alle in der Dokumentdefinition beschriebenen Felder werden standardmäßig zur Überprüfung weitergeleitet.

Auf der Registerkarte Überprüfung des Dialogfelds Eigenschaften des Feldes können Sie die Überprüfungsparameter für ein Feld konfigurieren

Soll ein Feld überprüft werden, muss die Option Erfordert Überprüfung aktiviert sein. Geben Sie dann an, wie die Zeichen dem Überprüfungsoperator angezeigt werden:

  • Zeichen nicht hervorheben - Unzuverlässig erkannte Zeichen werden nicht hervorgehoben.
  • Zeichen hervorheben, wenn der Zuverlässigkeitsgrad geringer ist als - Es werden nur die Zeichen hervorgehoben, deren Zuverlässigkeitsgrad geringer als der für dieses Feld angegebene Wert ist (mögliche Werte sind 40 %, 60 % und 80 %).
  • Alle Zeichen hervorheben - Alle unzuverlässig erkannten Zeichen werden hervorgehoben.

Gruppenüberprüfung

Ist eine group verification erforderlich, wählen Sie die Option An Gruppenüberprüfung senden Geben Sie anschließend an, welche Zeichen zur Gruppenüberprüfung weitergeleitet werden sollen. Sie haben zwei Optionen zur Auswahl:

  • nur hervorgehobene Zeichen
  • alle Zeichen

Wählen Sie einen Zeichensatz, der zur Gruppenüberprüfung gesendet wird:

  • Nur Ziffern
  • Benutzerdefiniert
    Verändern Sie die benutzerdefinierten Zeichen durch Klicken auf Ändern… und geben Sie die notwendigen Zeichen im Dialogfeld Zeichensatz für Gruppenüberprüfung ein.

Feldüberprüfung

Ist eine field verification erforderlich, wählen Sie die Option An Feldüberprüfung senden. Geben Sie anschließend an, welche Zeichen zur Feldüberprüfung weitergeleitet werden sollen:

  • Immer
    Das Feld wird unabhängig vom Anteil unzuverlässig erkannter Zeichen oder von Formatfehlern immer an die Feldüberprüfung gesendet. Während der Überprüfung wird das Feld mit einer gepunkteten roten Linie hervorgehoben.
  • Wenn das Feld Formatfehler enthält oder wenn der prozentuale Anteil der hervorgehobenen Zeichen größer ist als oder gleich
    Das Feld wird zur Feldüberprüfung weitergeleitet, wenn es Formatfehler enthält oder wenn der Anteil unzuverlässig erkannter Zeichen größer oder gleich dem für das Feld festgelegten Grenzwert ist (mögliche Werte liegen im Bereich zwischen 0 und 100 %). Geben Sie einen Grenzwert von 0 % an, wird das Feld zur Feldüberprüfung weitergeleitet, wenn es mindestens ein hervorgehobenes Zeichen enthält. Sie können die Werte manuell in das Feld eingeben oder auf die Pfeilschaltfläche auf der rechten Seite klicken, um den Wert um 10 % zu erhöhen oder zu verringern.

Feldüberprüfung für eine Gruppe von Feldern

Soll das Feld als Teil einer Gruppe von Feldern zur Feldüberprüfung weitergeleitet werden, geben Sie im Feld Name der Feldgruppe den Namen der Gruppe ein. Sie müssen auch die Option Felder bei Feldüberprüfung gruppieren auf der Registerkarte Überprüfung des Dialogfelds Projekteigenschaften aktivieren.

Doppelüberprüfung

Soll das Feld unabhängig von zwei Operatoren überprüft werden, wählen Sie die Option Erfordert doppelte Überprüfung.


Benutzerskript (benutzerdefinierte Aktion)

Ein Benutzerskript ist eine benutzerdefinierte Skriptregel, die vom Benutzer bei der Ansicht eines Felds während der Feldüberprüfung oder im Dokumenteditor ausgelöst wird. Das Skript wird aktiviert, indem Sie auf … rechts vom Feldwert klicken oder Strg+Umschalt+A drücken.

Sie können das benutzerdefinierte Skript in der Registerkarte Benutzerdefinierte Aktion im Dialogfeld "Feldeigenschaften" festlegen (klicken Sie dafür mit der rechten Maustaste auf das Feld und wählen Sie im Kontextmenü Eigenschaften... aus). Um Feldinformationen im Benutzerskript zur Verfügung zu stellen oder zu löschen, verwenden Sie die Schaltflächen Hinzufügen… und Löschen. Um das Skript zu bearbeiten, rufen Sie das Fenster Skripteditor auf. Dieses wird geöffnet, wenn Sie auf Bearbeiten… klicken.

Um das Skript für die Operatoren zugänglich zu machen, wählen Sie Benutzerdefinierte Aktion aktivieren aus.

Hinweis: Das Benutzerskript kann in der Web-Datenüberprüfungsstation nicht angewendet werden.

Weitere Informationen zu Skriptparametern finden Sie unter Benutzerskript.


Auswahlfelder

Wichtig! Die Eigenschaften von Auswahlfeldern, die in Gruppen zusammengefasst werden, werden für die gesamte Gruppe von Auswahlfeldern konfiguriert. Wenn Sie die Eigenschaften eines Auswahlfelds bearbeiten, das einer Gruppe angehört, wird ein Dialogfeld zum Bearbeiten der Eigenschaften der Gruppe geöffnet.

Wenn Sie ein Auswahlfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
Überprüfungseigenschaften
Regelbasierte Validierung


Datentypen für Auswahlfelder

Der Datentyp für Auswahlfelder kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Daten festgelegt werden.

Mit dem Datentyp für Auswahlfelder werden die Werte festgelegt, die dem Auswahlfeld zugewiesen werden, wenn das Auswahlkästchen aktiviert oder deaktiviert ist. Der entsprechende Wert ist in den Exportergebnissen und der Eigenschaft Wert der Schnittstelle ICheckmarkValue enthalten.

Wählen Sie die entsprechenden Optionen für die Werte des Auswahlfelds aus:

  • Ja/Nein – Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "Ja". Wenn es deaktiviert ist, lautet der Wert "Nein".
  • 1/0 – Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "1". Wenn es deaktiviert ist, lautet der Wert "0".
  • <Auswahlfeldname>/Leer – Wenn das Auswahlkästchen aktiviert ist, entspricht der Feldwert dem Namen des Auswahlfelds. Wenn das Auswahlkästchen deaktiviert ist, wird dem Feld ein leerer Wert zugewiesen.
  • Benutzerdefiniert – Durch Aktivieren dieser Option können Sie benutzerdefinierte Werte eingeben. Ausgewählt – Aktiviertes Auswahlkästchen, Nicht ausgewählt – Deaktiviertes Auswahlkästchen.


Erkennungseigenschaften für Auswahlfelder

Die Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte wird die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Auswahlfeldtyp – Wählen Sie den Auswahlfeldtyp aus. Diese Eigenschaft ist sehr wichtig für die korrekte Erkennung von Auswahlfeldern.

    Quadrat – Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder in begrenzten quadratischen Rahmen positioniert werden. Beispiele: und [image].

    Ohne Rahmen – Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder ohne Rahmen vor einem weißen Hintergrund positioniert werden. Beispiele: und [image].

    Automatisch –Wenn Sie diesen Typ auswählen, wird der Auswahlfeldtyp automatisch festgelegt. Dieser Typ sollte nur dann ausgewählt werden, wenn die zwei anderen Typen nicht geeignet sind, wie z. B. wenn ein Auswahlfeld ein nicht-quadratisches Trennzeichen aufweist. Beispiele: und [image].

    Im Modus Automatisch ermittelt das Programm, ob das Auswahlfeld ausgewählt wird oder nicht, indem es das Abbild des Auswahlfelds in einem verarbeiteten Dokument mit dem Abbild des zum Erstellen der Dokumentdefinition verwendeten Formulars vergleicht. Für eine korrekte Erkennung von Auswahlfeldern muss der Bereich eines Auswahlfeldes in der Dokumentdefinition exakt angegeben wird. Der Modus "Automatisch" kann sowohl auf feste als auch auf flexible Beschreibungen angewendet werden:

    • Für feste Beschreibungen
      Das Auswahlfeld im Formular muss leer bleiben. Ob das Auswahlfeld markiert wurde oder nicht, wird durch einen Vergleich des Auswahlfeldbereiches in dem zu verarbeitenden Dokument mit dem Auswahlfeldbereich der Dokumentdefinition ermittelt.
    • Für flexible Beschreibungen
      Der Referenzwert ist die Menge an Schwarz im Auswahlfeldbereich der Dokumentdefinition. Ob das Auswahlfeld markiert wurde oder nicht, wird durch einen Vergleich des Prozentsatzes mit schwarzer Farbe im Auswahlfeldbereich in dem zu verarbeitenden Dokument mit dem Auswahlfeldbereich der Dokumentdefinition ermittelt.
  • Korrekturen zulassen – Aktivieren Sie diese Option, wenn Sie Korrekturen an den Auswahlfeldern zulassen möchten: In diesem Fall werden durchgestrichene Auswahlfelder als nicht ausgewählt eingestuft. Wenn Sie jedoch den Auswahlfeldtyp Automatisch ausgewählt haben, können Sie keine Korrekturen der entsprechenden Auswahlfelder zulassen.

    • Sie können folgende Optionen für die Verarbeitung des Feldbilds festlegen:

  • Invertieren – Das Bild wird invertiert.
  • Textur entfernen – Die Textur wird entfernt.
  • Störungen entfernen – Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen – Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Überprüfung Bei der Überprüfung handelt es sich um die Kontrolle der erkannten Daten durch einen Operator. Das Programm markiert unzuverlässig erkannte Zeichen rot und fordert den Operator auf, die Zeichen zu bestätigen oder zu korrigieren. Dazu werden die Zeichen gemeinsam mit den ursprünglichen Bildern angezeigt. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn keine unzuverlässig erkannten Zeichen darin vorkommen. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn unzuverlässig erkannte Zeichen darin vorkommen.

Alle in der Dokumentdefinition beschriebenen Felder werden standardmäßig zur Überprüfung weitergeleitet.

Auf der Registerkarte Überprüfung des Dialogfelds Eigenschaften des Feldes können Sie die Überprüfungsparameter für ein Feld konfigurieren

Gruppenüberprüfung

Ist eine group verification erforderlich, wählen Sie die Option An Gruppenüberprüfung senden Geben Sie anschließend an, welche Zeichen zur Gruppenüberprüfung weitergeleitet werden sollen. Sie haben zwei Optionen zur Auswahl:

  • nur hervorgehobene Zeichen
  • alle Zeichen

Feldüberprüfung (nur für Gruppen von Auswahlfeldern)

Ist eine field verification erforderlich, wählen Sie die Option An Feldüberprüfung senden. Geben Sie anschließend an, welche Zeichen zur Feldüberprüfung weitergeleitet werden sollen:

  • Immer
    Das Feld wird unabhängig vom Anteil unzuverlässig erkannter Zeichen oder von Formatfehlern immer an die Feldüberprüfung gesendet. Während der Überprüfung wird das Feld mit einer gepunkteten roten Linie hervorgehoben.
  • Wenn das Feld Formatfehler enthält oder wenn der prozentuale Anteil der hervorgehobenen Zeichen größer ist als oder gleich
    Das Feld wird zur Feldüberprüfung weitergeleitet, wenn es Formatfehler enthält.

Feldüberprüfung für eine Gruppe von Feldern

Soll das Feld als Teil einer Gruppe von Feldern zur Feldüberprüfung weitergeleitet werden, geben Sie im Feld Name der Feldgruppe den Namen der Gruppe ein. Sie müssen auch die Option Felder bei Feldüberprüfung gruppieren auf der Registerkarte Überprüfung des Dialogfelds Projekteigenschaften aktivieren.

Doppelüberprüfung

Soll das Feld unabhängig von zwei Operatoren überprüft werden, wählen Sie die Option Erfordert doppelte Überprüfung.


Gruppen von Auswahlfeldern

Wichtig! Gruppeneigenschaften gelten für alle Auswahlkästchen, die einer Gruppe von Auswahlfeldern angehören.

Der Wert einer Auswahlfeldgruppe ist eine Liste mit den Namen der ausgewählten Auswahlkästchen, die durch ein Semikolon (;) getrennt sind, oder eine leere Zeichenfolge, wenn keine Auswahlkästchen ausgewählt wurden.

Wenn Sie eine Gruppe von Auswahlfeldern erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
Überprüfungseigenschaften
Regelbasierte Validierung


Datentypen für Gruppen von Auswahlfeldern

Der Datentyp für eine Gruppe von Auswahlfeldern kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Daten festgelegt werden.

Leere Auswahl zulassen – Aktivieren Sie diese Option, wenn mindestens ein Auswahlkästchen in der Gruppe aktiviert sein muss. Wenn kein Auswahlfeld in der Gruppe aktiviert ist, wird eine entsprechende Warnmeldung angezeigt.

Mehrfachauswahl zulassen – Aktivieren Sie diese Option, damit mehrere Auswahlkästchen in der Gruppe aktiviert werden können. Wenn die Option deaktiviert ist, wird eine Warnmeldung angezeigt, wenn mehrere Auswahlfelder in der Gruppe aktiviert wurden.

Validierungsfehler als Warnungen behandeln – Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen. Warnungen gestatten es dem Operator, weiterhin Dokumente zur nächsten Verarbeitungsphase zu senden, während bei unkorrigierten Formatfehlern vor dem Senden eine zusätzliche Bestätigung vom Operator erforderlich ist.

Export as number –Wenn diese Option ausgewählt ist, wird überprüft, ob alle Auswahlfelder Zahlen sind. Wenn mehrere Auswahlfelder markiert sind, kann die Summe der Werte von Auswahlfeldern exportiert werden. Der Wert einer Auswahlfeldgruppe ist aus Skripten über die Eigenschaft Wert der Schnittstelle IField verfügbar.

Wenn Sie den Namen eines Auswahlfelds ändern möchten, markieren Sie die entsprechende Zeile und klicken Sie auf Bearbeiten…. Geben Sie im daraufhin geöffneten Dialogfeld einen neuen Namen für das Auswahlfeld sowie einen neuen Namen ein, der dem Auswahlfeld beim Exportieren zugewiesen wird.

Sie können die zu exportierenden Werte für Fälle auswählen, in denen keine Auswahlfelder aktiviert sind, und für Fälle, in denen mehrere Auswahlfelder aktiviert sind. Wählen Sie hierzu <Es wurde kein Objekt ausgewählt.> bzw. <Mehrere Objekte…> aus der Liste, klicken Sie auf Bearbeiten… und geben Sie in dem dann angezeigten Dialogfeld den gewünschten Wert in das Feld Exportierter Wert ein. Wenn keine Exportwerte festgelegt wurden, passiert Folgendes: a) Wenn keine Auswahlfelder aktiviert wurden, wird eine leere Zeichenfolge exportiert, oder b), wenn mehrere Felder ausgewählt wurden, werden die Werte der aktivierten Auswahlfelder (getrennt durch Kommas) angegeben, wenn mehrere Auswahlfelder aktiviert sind, oder, wenn die Option Als Zahl exportieren ausgewählt ist, wird eine Überprüfung durchgeführt, ob alle Auswahlfelder Zahlen sind, und die Summe der Werte von Auswahlfeldern wird exportiert.

Erstellen einer Gruppe von Auswahlfeldern


Barcode

Wenn Sie ein Barcodefeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften.

Wichtig! Ein Barcode kann sowohl als Feld als auch als statisches Element hervorgehoben werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Dokumentdefinitionszuordnung oder -identifizierung vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Feldeigenschaften beschrieben. Siehe auch Ankerbarcode.

Allgemeine Eigenschaften
Erkennungseigenschaften
Überprüfungseigenschaften
Regelbasierte Validierung


Datentypen für Barcodes

Der Datentyp für Barcodes kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Daten festgelegt werden.

Wählen Sie die entsprechenden Optionen für die Werte des Barcodes aus:

  • Maximale Länge – Geben Sie die maximale Abzahl der Zeichen in diesem Feld an.
  • Validierungsfehler als Warnungen behandeln – Wählen Sie diese Option aus, wenn Abweichungen von den Einschränkungen, die Sie festgelegt haben, als Warnungen gewertet werden sollen. Warnungen gestatten es dem Operator, weiterhin Dokumente zur nächsten Verarbeitungsphase zu senden, während bei unkorrigierten Formatfehlern vor dem Senden eine zusätzliche Bestätigung vom Operator erforderlich ist.


Barcodeerkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte wird die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Keine Erkennung (Manueller Eingabeblock – wird manuell eingegeben) – Aktivieren Sie diese Option, wenn der Barcodewert vom Operator manuell eingegeben wird. In diesem Fall müssen Sie die restlichen Erkennungseigenschaften nicht festlegen.
  • Codetyp – Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt). Klicken Sie auf Typen auswählen…, um die Barcodetypen manuell auszuwählen.

    Hinweis: Das Erkennen der Barcodes der Typen QR Code, Aztec und DataMatrix kann die Leistung beeinflussen, wählen Sie diese daher nur dann aus, wenn Barcodes dieses Typs in Ihrem Projekt vorhanden sind. Die Erkennung der Barcodes dieses Typs muss nur dann erfolgen, wenn mindestens eine Dokumentdefinition des gegebenen Type einen statischen oder flexiblen Bereich enthält, der einen 2d-Barcode verwendet (QR Code, Aztec oder DataMatrix) oder wenn ein 2d-Barcode in einem für den Stapeltyp geladenen Klassifikator verwendet wird.

    Ist Code 39 ohne Sternchen-Barcodes in dem Projekt vorhanden, sollte dieser Barcode explizit angegeben werden, da dieser sonst nicht erkannt wird.

  • Ausrichtung – Geben Sie die Ausrichtung des Barcodes an.

Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

  • Invert – Das Bild wird invertiert.
  • Textur entfernen – Die Textur wird entfernt.
  • Störungen entfernen – Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen – Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Überprüfung Bei der Überprüfung handelt es sich um die Kontrolle der erkannten Daten durch einen Operator. Das Programm markiert unzuverlässig erkannte Zeichen rot und fordert den Operator auf, die Zeichen zu bestätigen oder zu korrigieren. Dazu werden die Zeichen gemeinsam mit den ursprünglichen Bildern angezeigt. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn keine unzuverlässig erkannten Zeichen darin vorkommen. Sie können das Programm so einrichten, dass es bestimmte Felder zur Überprüfung weiterleitet, auch wenn unzuverlässig erkannte Zeichen darin vorkommen.

Alle in der Dokumentdefinition beschriebenen Felder werden standardmäßig zur Überprüfung weitergeleitet.

Auf der Registerkarte Überprüfung des Dialogfelds Eigenschaften des Feldes können Sie die Überprüfungsparameter für ein Feld konfigurieren.

Feldüberprüfung

Ist eine field verification erforderlich, wählen Sie die Option An Feldüberprüfung senden. Geben Sie anschließend an, welche Zeichen zur Feldüberprüfung weitergeleitet werden sollen:

  • Immer
    Das Feld wird unabhängig vom Anteil unzuverlässig erkannter Zeichen oder von Formatfehlern immer an die Feldüberprüfung gesendet. Während der Überprüfung wird das Feld mit einer gepunkteten roten Linie hervorgehoben.
  • Wenn das Feld Formatfehler enthält oder wenn der prozentuale Anteil der hervorgehobenen Zeichen größer ist als oder gleich
    Das Feld wird zur Feldüberprüfung weitergeleitet, wenn es Formatfehler enthält.

Doppelüberprüfung

Soll das Feld unabhängig von zwei Operatoren überprüft werden, wählen Sie die Option Erfordert doppelte Überprüfung.


Bilder

Bei der Erstellung werden einem Bild Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst vier Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Erkennungseigenschaften
Exportieren von Bildern
Regelbasierte Validierung


Bilderkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt.

  • Von Erkennung ausschließen – Aktivieren Sie diese Option, wenn der Bereich eines Bildfelds von den Erkennungsbereichen der anderen Felder ausgeschlossen werden soll. (Diese Option ist nur bei Bildfeldern verfügbar, um die Kompatibilität mit Vorlagen von FormReader 6.5 sicherzustellen.)


Exportieren von Bildern

In einer Dokumentdefinition können Sie für jedes Bild die Exporteinstellungen auswählen. Klicken Sie zum Auswählen der Exporteinstellungen für Bilder mit der rechten Maustaste in das gewünschte Feld, wählen Sie Eigenschaften… und klicken Sie auf die Registerkarte Exportieren. Folgende Optionen stehen zur Auswahl:

  • Dateityp: (TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits, PNG).
  • Qualität: Für TIFF, JPEG, and JPEG2000-Dateien können Sie die Qualität der erzeugten Datei auswählen: von "Beste" bis "Gering".
  • Farbtyp: Farbe, Graustufen, Raster (Schwarz-Weiß).

Sie können auch die Auflösung des erzeugten Bildes festlegen: Aktivieren Sie die Option Auflösung ändern in und geben Sie entweder die gewünschte Auflösung ein oder wählen Sie eine in der Liste aus.

Der Name der Datei, in der das Bild gespeichert wird, wird automatisch anhand der vom Benutzer vorgegebenen Parameter gebildet. Um diese Parameter festzulegen, klicken Sie auf die Schaltfläche

Ändern… und wählen die gewünschten Optionen im daraufhin angezeigten Dialogfeld Dateinamenoptionen aus. Ausführliche Informationen finden Sie unter Export File Naming Options.


Tabellen

Wenn Sie eine Tabelle erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Spalten
Regelbasierte Validierung


Tabellenspalten

Auf der Registerkarte Spalten sind die Spalten der entsprechenden Tabelle aufgeführt. Jede Tabellenspalte ist einem bestimmten Feldtyp zugewiesen (siehe Erstellen einer Tabelle) und verfügt über für diesen Feldtyp spezifische Eigenschaften.

So bearbeiten Sie die Eigenschaften einer Tabellenspalte:

  1. Wählen Sie die entsprechende Spalte in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….


Feldgruppe

Wenn Sie eine Feldgruppe erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Eigenschaftsgruppen.

Allgemeine Eigenschaften
Felder
Regelbasierte Validierung


Gruppenfelder

Auf der Registerkarte Felder wird eine Liste der Felder der entsprechenden Gruppe angezeigt.

So bearbeiten Sie die Eigenschaften eines dieser Felder:

  1. Wählen Sie den Namen des entsprechenden Felds in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….

Erstellen einer Feldgruppe


Dienstfeld

Wenn ein Dienstfeld erstellt wird, verfügt es über die Standardeigenschaften, die durch Klicken auf Eigenschaften… im Kontextmenü konfiguriert werden können. Das Eigenschaftsdialogfeld hat zwei Registerkarten, eine für jede Gruppe von Eigenschaften.

Eigenschaften des Basisfelds
Eigenschaften der Datenquelle


Eigenschaften der Datenquelle

In der Registerkarte Datenquelle werden die Quelle und der Datentyp des Dienstfelds angegeben:

  1. Wählen Sie in der Liste Quelle eine Datenquelle für das Feld aus.
  2. Wenn Sie Dokument-Registrierungsparameter oder Stapel-Registrierungsparameter auswählen, geben Sie den Namen der Registrierungseigenschaft an, die im Feld Parametername als Datenquelle verwendet werden soll.
  3. Wählen Sie unter Datentyp den gewünschten Datentyp für das Dienstfeld aus.


Regelbasierte Validierung

You are here: Konfigurieren des Programms > Dokumentdefinitionen > Regelbasierte Validierung

Regeln

Regeln bieten eine weitere Möglichkeit zur Prüfung erfasster Daten. Mit Regeln können Sie Einschränkungen festlegen, die für Daten in bestimmten Feldern gelten (mit anderen Worten, Bedingungen, die von den erfassten Werten bestimmter Felder erfüllt werden müssen).

Außerdem können Sie Regeln zur Verarbeitung von erfassten Werten nutzen. Sie können beispielsweise Werte mehrere Felder zusammenfassen oder erfasste Werte durch Werte aus einer Datenbank ersetzen.

Sie können festlegen, wie streng eine Regel ist, d. h. ob sie bei Verstößen eine Warnung oder eine Fehlermeldung erzeugt. Die Felder, für die eine Regelwarnung ausgegeben wurde, sind mit einem gelben Kennzeichen markiert und Felder mit Regelfehlern erhalten ein rotes Kennzeichen. Einzelheiten finden Sie unter Regelbasierte Validierung.

Regeln werden auf der Registerkarte Regeln des Dialogfelds „Eigenschaften“ eines Feldes, eines Abschnitts, einer Dokumentdefinition oder eines anderen Elements festgelegt, für das Regeln angegeben werden können.

Ansicht von Regeln

Wählen Sie in der Dropdownliste Regeln anzeigen, welche Art von Regeln angezeigt werden sollen:

  • verweisen auf %0 – Zeigt nur die Regeln für das aktuelle Objekt an.

  • im Besitz von %0 – Zeigt nur die Regeln an, die im aktuellen Objekt gespeichert sind.
  • im Besitz von %0 und dessen untergeordneten Elementen – Zeigt nur die Regeln an, die in aktuellen Objekten und den zugehörigen untergeordneten Objekten gespeichert sind (wenn beispielsweise das Objekt eine Gruppe ist, werden die in der Gruppe gespeicherten Regeln zusammen mit den Regeln angezeigt, die in Feldern gespeichert sind, bei denen es sich um Teile der Gruppe handelt).

Hinweis: Sie können eine neue Regel erstellen, wenn Sie Regeln mithilfe der Optionen im Besitz von %0 und im Besitz von %0 und dessen untergeordneten Elementen anzeigen lassen. Wenn Sie verweisen auf %0 auswählen, können Sie keine neue Regel erstellen.

Collapsed Filtern von Regeln

Sie können Regeln nach dem Namen, einem Feld oder einer Bedingung filtern.

Um das Dialogfeld Filter zu öffnen, klicken Sie auf die Schaltfläche Filter auf der Registerkarte Regeln.

Folgende Filterkriterien sind verfügbar:

  • Regelname enthält – Filtert Regeln nach dem Namen (wählen Sie den gewünschten Namen aus der Dropdownliste aus).
  • Feld – Filtert Regeln nach dem Feld (wählen Sie ein Feld, um sich nur die Regeln anzeigen zu lassen, die dieses Feld verwenden).
  • Regeln anwenden – Diese Optionsgruppe filtert Regeln danach, ob sie die Erfüllung einer Bedingung voraussetzen, um wirksam zu werden, und nach diesen Bedingungen. Wählen Sie die Option Immer, wenn Sie nur diejenigen Regeln sehen möchten, die immer ausgeführt werden, d. h. die von keiner Bedingung ausgelöst werden. Wählen Sie Ist diese Bedingung wahr, wenn Sie sich die Regeln ansehen möchten, die durch eine der folgenden Bedingungen ausgelöst werden:

    • Gehört zum Satz (exakte Übereinstimmung) – Zeigt nur die Regeln an, deren Feldwerte (d. h. die Werte, die die Regel auslösen) exakt die dieselben sind wie die im Filter festgelegten Werte.

    • Gehört nicht zum Satz (exakte Übereinstimmung) – Zeigt nur die Regeln an, deren unzulässige Feldwerte (d. h. die Werte, die die Regel nicht auslösen) exakt dieselben sind wie die im Filter festgelegten Werte.

    • Ist leer – Zeigt nur die Regeln an, die angewendet werden, wenn der Feldwert leer ist.

    • Ist nicht leer – Zeigt nur die Regeln an, die angewendet werden, wenn der Feldwert nicht leer ist.

    • Überschneidet mit dem Satz – Zeigt nur die Regeln an, deren Feldwerte (d. h. die Werte, die die Regel auslösen) mindestens einen der im Filter festgelegten Werte enthalten.

Eine Kombination mehrerer Filterkriterien zeigt nur die Regeln an, die allen Kriterien entsprechen.

Wenn Sie Filterkriterien angeben, werden sie als Textzeichenkette neben der Schaltfläche Filter angezeigt. Klicken Sie auf [image], um den Filter zu löschen. Wenn Sie den Filter löschen, werden alle Regeln angezeigt. Der Filter wird automatisch gelöscht, wenn Sie das Dialogfeld Regeln schließen.

Beispiel für die Verwendung des Filters

Angenommen, Sie haben die folgenden zwei Regeln festgelegt:

ErsteRegel wird angewendet, wenn Währung = EUR, USD

ZweiteRegel wird angewendet, wenn Währung = EUR, RUR.

Die folgende Tabelle veranschaulicht, welche Regel bei den unterschiedlichen Filterkriterien angezeigt wird.

Bedingung der Regel | Wertesatz | Angezeigte Regeln
Gehört zum Satz (exakte Übereinstimmung) | EUR, USD | ErsteRegel
Gehört nicht zum Satz (exakte Übereinstimmung) | EUR | —
Überschneidung mit dem Satz | EUR | ErsteRegel, ZweiteRegel
Überschneidung mit dem Satz | EUR, XXX | ErsteRegel, ZweiteRegel

Aufstellen von Regeln

Die Regelliste enthält alle Regeln, die aufgestellt wurden, und einige weitere Kriterien für jede Regel.

Um eine neue Regel aufzustellen, klicken Sie auf die Schaltfläche Neue Regel… auf der Registerkarte Regeln. Im sich öffnenden Dialogfeld wählen Sie die Regeltypen, die erstellt werden sollen, und klicken Sie anschließend auf OK. Es öffnet sich New Rule mit den folgenden Optionen:

  • Regeln anzeigen - Der Name der Regel.
  • Regelname in Nachricht für Prüfer anzeigen - Aktivieren Sie diese Option, wenn der Name der Regel, die einen Fehler erzeugt hat, in Fehlermeldungen angezeigt werden soll. Standardmäßig sehen Meldungen zu Regelfehlern wie folgt aus: „Name der Regel: Fehlermeldung“. Ist diese Option deaktiviert, enthält die Meldung nur die Fehlermeldung.
  • Schwierigkeit - Der Schweregrad der Regel. Wenn eine Regel zu einem Fehler führt, werden eine Fehlermeldung und ein Kennzeichen generiert. Es gibt zwei mögliche Kennzeichen: Fehler oder den Typ Warnung.

    Wird versucht, Dokumente mit Regelfehlern zu exportieren, wird eine entsprechende Meldung angezeigt. Dokumente mit Regelfehlern können jedoch exportiert werden.

    Hinweis: Diese Option steht für die Regeln Summe berechnen und Felder verbinden nicht zur Verfügung.

  • Regel anwenden - Optionen dieser Gruppe ermöglichen Ihnen, festzulegen, wann eine Regel angewendet wird.

    • Immer – Diese Regel wird immer angewendet, d. h. sie wird angewendet, sobald Veränderungen an den von ihr überwachten Feldern vorgenommen werden. Diese Option ist standardmäßig aktiviert.
    • Ist diese Bedingung wahr Wenn diese Option aktiviert ist, wird die Regel nur dann angewendet, wenn bestimmte Bedingungen erfüllt sind. Weitere Informationen finden Sie im Abschnitt Bedingungen für die Anwendung von Regeln dieses Artikels.
  • Aktivierte Regel - Zum Aktivieren oder Deaktivieren der Regel.

Die folgenden Optionen hängen vom Regeltyp ab:

  • Summe berechnen - Berechnung der Summe der Werte mehrerer Felder und schreibt sie in ein anderes Feld.
  • Felder verbinden– Zusammenführen der Werte mehrerer Felder. Wenn Sie Feldwerte zu einem Wert verbinden, können Sie jedes beliebige Trennzeichen hinzufügen.
  • Datenbanküberprüfung – Überprüfung erfasste Werte anhand ihrer aus einer Datenbank entnommenen Gegenstücke.
  • Summenüberprüfung – Berechnung der Summe der Werte mehrerer Felder und überprüft sie anhand einer vordefinierten Zahl oder des Wertes eines anderen Feldes.
  • Skript – Ein benutzerdefiniertes Skript, das die für bestimmte Daten geltenden Einschränkungen beschreibt.
  • Felder vergleichen – Vergleichen der Werte mehrerer Felder.
  • Summe in Zahlen und Summe in Worten (Russisch) – Vergleich einer Summe der geschriebenen Wörter mit der Zahlensumme (nur für die russische Sprache).

Bedingungen für die Anwendung von Regeln

In der aktuellen Version von können Regeln durch spezielle Werte in einem bestimmten Feld ausgelöst werden. Wenn Sie eine Regel erstellen oder bearbeiten, können Sie angegeben, wann die Regel angewendet wird, indem Sie die Option Immer oder Ist diese Bedingung wahr wählen. Wenn Sie eine Bedingung angeben möchten, die eine Regel auslöst, wählen Sie die Option Ist diese Bedingung wahr und klicken Sie dann auf die Schaltfläche Bearbeiten rechts von dieser Option, um das Dialogfeld Bedingung für Anwendung der Regel zu öffnen. In diesem Dialogfeld:

  • Wählen Sie ein Feld aus.

  • Wählen Sie die Bedingung, die erfüllt werden muss, damit die Regel ausgelöst wird.

    • Gehört zum Satz – Die Regel wird angewendet, wenn der Feldwert mit einem der von Ihnen festgelegten zulässigen Werte übereinstimmt.

    • Gehört nicht zum Satz – Die Regel wird nicht angewendet, wenn der Feldwert mit einem der von Ihnen festgelegten unzulässigen Werte übereinstimmt.

    • Ist leer – Die Regel wird angewendet, wenn der Feldwert leer ist.

    • Ist nicht leer – Die Regel wird angewendet, wenn der Feldwert nicht leer ist.

  • Sie können auch einen Bereich möglicher (zulässiger) Feldwerte festlegen.

  • Um einen Wert zu einem Satz möglicher Werte hinzuzufügen, geben Sie den Wert ein und klicken Sie auf Hinzufügen. Um einen Wert aus dem Satz zu löschen, wählen Sie den Wert aus und klicken Sie auf Löschen. Sie können auch einen leeren Wert zum Satz möglicher Werte hinzufügen. Um einen leeren Wert hinzuzufügen, klicken Sie auf Hinzufügen, ohne einen Wert einzugeben. Der leere Wert erscheint im Satz möglicher Werte als . Ein Wert kann nur einmal hinzugefügt werden.

Die Bedingungen für die Anwendung von Regeln können nur Textfelder betreffen (einschließlich Felder mit fortgesetzten Bereichen), Barcodes und Tabellenspalten. Die Bedingungen für die Anwendung von Regeln können keine Auswahlfelder, Auswahlfeldgruppen, Felder mit mehreren Instanzen, Bilder oder Tabellenzellen betreffen.

Wichtig! Ist die Option Bei Überprüfung anzeigen den Feldeigenschaften nicht aktiviert, werden Fehler dieses Felds während der Überprüfung nicht angezeigt. Das bedeutet, dass ein Dokument mit diesem Feld eine Fehlermarkierung erhält, die nicht entfernt werden kann.

Hinweis: Alle Regeln geben, wenn sie verletzt werden, entweder eine Warnung oder eine Fehlermeldung aus. Wird versucht, Dokumente mit Regelfehlern zu exportieren, wird eine Fehlermeldung angezeigt und werden die Dokumente nicht exportiert. Dokumente mit Regelwarnungen können jedoch frei exportiert werden.

Regelketten

Regelketten sind Gruppen von Regeln mit einer bestimmten Anwendungsreihenfolge. Sie können mehrere Regeln aufstellen, die dasselbe Feld betreffen.

Um eine Regelkette zu erstellen:

  • Klicken Sie in der Registerkarte Regeln auf die Schaltfläche Ketten….
  • Im sich öffnenden Dialogfeld klicken Sie auf die Schaltfläche Neue Kette….
  • Geben Sie den Namen der Regelkette und einen Kommentar (optional).
  • Klicken Sie anschließend auf OK.

Die neue Kettenregel wird in der Liste im Dialogfeld Ketten angezeigt. Fügen Sie anschließend Regeln zur Regelkette:

  • Hinzu, indem Sie auf Regel hinzufügen… klicken.
  • Die gewünschte Regel auswählen.
  • Ordnen Sie die Regeln mit den Schaltflächen Nach oben und Nach unten in der von Ihnen gewünschten Reihenfolge der Anwendung an.

Wichtig! Jede Regel kann nur zu einer Kette gehören. Wenn Sie versuchen, eine Regel, die bereits in einer Regelkette verwendet wird, zu einer anderen Regelkette hinzuzufügen, wird die Fehlermeldung „Kette 'chain_name' enthält diese Regel bereits>“ angezeigt.

Hinweis: Wenn Sie versuchen, ein bearbeitbares Feld (wobei die Option „Schreibgeschützt“ in den Feldeigenschaften deaktiviert ist) zu einer Regel hinzuzufügen, diese Regel aber bereits Teil einer Regelkette ist, in der es ebenfalls bearbeitet werden kann, fordert Sie das Programm auf, diese Regel mit der Regelkette zu verbinden. Wenn Sie dem zustimmen und die Regel, zu der Sie das Feld hinzufügten, einer anderen Regelkette angehört, werden die beiden Regelketten zu einer Regelkette verbunden.

Collapsed Wo Regeln gespeichert werden

Die Regeln werden auf der Ebene des Elements gespeichert, auf der sie erstellt wurden. Dabei kann es sich um ein Feld, einen Bereich oder eine Dokumentdefinition handeln. In den meisten Fällen ist es irrelevant, wo das Programm die Regeln speichert. Wenn Ihre Dokumentdefinition jedoch sehr komplex ist und mehrere Feldgruppen oder wiederkehrende Element enthält, sollten Sie wissen, wo jede Regel gespeichert ist. Wenn Sie beispielsweise mit einer Gruppe von Feldern arbeiten, in der für einige Felder eine bestimmte Regel gilt, sollten Sie diese Regel in der Gruppe oder in einem ihrer Felder speichern. Wenn Sie eine neue Gruppeninstanz erstellen, wird die Regel ansonsten nicht in die neue Instanz kopiert oder auf sie angewendet. Im Dialogfeld „Eigenschaften“ eines Elements können Sie die Regeln, die sich auf das Element beziehen, die Regeln, die zum Element gehören (d. h. im Element gespeichert sind) oder die Regeln, die dem Element und dessen untergeordneten Elementen gehören, anzeigen lassen. Wählen Sie in der Dropdownliste Regeln anzeigen, welche Art von Regeln angezeigt werden soll.


Regel zum Überprüfen von Wertsummen

Mit dieser Regel wird die Summe der Werte mehrerer Felder überprüft. Die Summe der Werte bestimmter Felder wird mit einer festgelegten Zahl oder dem Wert in einem anderen Feld verglichen. Wenn ein Dokument beispielsweise Felder für Gehälter, Zulagen und andere Ausgleichszahlungen sowie ein Feld für die Gesamtsumme enthält, können Sie eine Regel definieren, mit der überprüft wird, ob die Summe der Feldwerte mit der Gesamtsumme im Ergebnisfeld übereinstimmt. Wenn dies nicht der Fall ist, wird eine Fehlermeldung angezeigt.

Hinweis: Wenn Sie diese Regel auf ein Feld vom Typ Tabelle anwenden, hängt die Berechnung von der Ebene ab, auf der die Regel erstellt wird. Wenn Sie die Summe der Werte aller Zellen einer Tabellenspalte mit einer berechneten oder vorgegebenen Zahl vergleichen müssen, muss die Regel in den Eigenschaften der Dokumentdefinition oder in den Eigenschaften der Dokumentbereiche erstellt werden. Wenn Sie jede Zelle einer Spalte oder die Summe aller Zellen einiger weniger Tabellenspalten mit einer berechneten oder vorgegebenen Zahl vergleichen müssen, muss die Regel in den Tabelleneigenschaften oder in den Eigenschaften der Tabellenspalten erstellt werden.

Diese Hinweise müssen auch beim Erstellen einer Regel, die die Summe der Werte von Feldern mit einigen wenigen Instanzen prüft, berücksichtigt werden.

So erstellen Sie eine Regel für die Summenüberprüfung:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften Eigenschaften…) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summenüberprüfung aus, und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Legen Sie den Schweregrad der Regel fest.
  8. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  9. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  10. Klicken Sie auf Weiter >.
  11. Fügen Sie in der Liste Feldwerte zusammenfassen die Felder ein, für die die Summe der entsprechenden Werte überprüft werden soll. Fügen Sie die Felder über die Schaltfläche Hinzufügen….

  12. Aktivieren Sie eine der folgenden Optionen:

    • Feld – Vergleich der Summe mit dem Wert des Ergebnisfelds. Wählen Sie den Namen des Felds über die Schaltfläche Auswählen… aus.
    • Nummer – Vergleich der Summe mit der angegebenen Zahl. Geben Sie die entsprechende Zahl ein.
  13. Präzision ist der maximal zulässige Unterschied zwischen Feldwerten, für die eine Regel erstellt wird. Eine Regel gilt als erfüllt, wenn der absolute Wert des Unterschieds zwischen den Werten kleiner oder gleich dem festgelegten Präzisionswert ist. Ist das nicht der Fall, gilt die Regel als nicht erfüllt und es wird eine Fehlermeldung erzeugt.
  14. Aktivieren Sie die Option Mindestens zwei zu addierende Elemente ungleich Null, wenn mindestens zwei Summanden, die nicht leer und nicht null sind, verwendet werden sollen. Sofern diese Bedindung nicht erfüllt ist, wird während der Überprüfung der Regel im Fenster "Regelfehler" ein Fehler ausgegeben.
  15. Felder bestätigen bei erfolgreicher Regelüberprüfung – Ist diese Option aktiviert, werden die Feldwerte, die die regelbasierte Validierung erfüllen, im Dokumentdefinitionseditor automatisch bestätigt. Anderenfalls muss der Überprüfungsoperator die Feldwerte manuell bestätigen.
  16. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel zum Vergleichen mehrerer Feldwerte

Diese Regel dient zur Überprüfung von Werten mehrerer Felder. Mithilfe der Regel kann ein Dokument mit mehreren Feldern überprüft werden, deren Werte identisch sein müssen. Wenn die Werte nicht übereinstimmen, wird für das Dokument eine Regelfehlermeldung angezeigt.

So erstellen Sie eine Regel zum Vergleichen von Werten:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder vergleichen aus und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Legen Sie den Schweregrad der Regel fest.
  8. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  9. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  10. Klicken Sie auf Weiter >.
  11. Fügen Sie in der Liste Zu vergleichende Felder die Felder ein, deren Werte verglichen werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein.

  12. Wählen Sie den Übereinstimmungstyp aus:

    • Genau – Exakte Übereinstimmung der Werte;
    • Annähernd – Annähernde Übereinstimmung der Werte. In diesem Fall werden die Felder verglichen, ohne dass die Groß- und Kleinschreibung oder Leerzeichen berücksichtigt werden. Für Feldwerte mit mehr als vier Zeichen ist ein Fehler zulässig.
  13. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel für die Datenbanküberprüfung

Bei der Datenbanküberprüfung von Feldwerten wird ein erkannter Feldwert mit Werten in der Datenbanktabelle verglichen. Die Überprüfung gilt als bestanden, wenn ein erfasster Feldwert mit einem Wert der Datenbank übereinstimmt. Anderenfalls gibt die Regel einen Fehler zurück.

Mit dieser Regel können Sie prüfen, ob Ihre Datenbank einen Eintrag für einen erfassten Wert enthält, wodurch Sie eine fehlertolerante Suche sogar dann durchführen können, wenn der Felder Tippfehler oder Fehler enthalten, einen Feldwert durch eine entsprechenden Aufzeichnung aus der Datenbank ersetzen und bestimmte Werte aus der Datenbank in Dokumentfelder kopieren können.

Erstellen einer Regel für die Datenbanküberprüfung

So erstellen Sie eine Regel für die Datenbanküberprüfung:

  1. Öffnen Sie das Dialogfeld Eigenschaften (klicken Sie mit der rechten Maustaste auf das Feld, um sein Kontextmenü zu öffnen, und wählen Sie Eigenschaften…) oder öffnen Sie das Dialogfeld Eigenschaften der Dokumentdefinition (wählen Sie im Menü Dokumentdefinitionseditor Dokumentdefinition>Eigenschaften der Dokumentdefinition…).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel…
  4. Wählen Sie in der Liste der Regeltypen die Option Datenbanküberprüfung und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Legen Sie den Schweregrad der Regel fest.
  8. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  9. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  10. Klicken Sie auf Weiter >.
  11. Richten Sie eine Verbindung zur Datenquelle ein, indem Sie ihren Typ und die Verbindungsparameter angeben.

    Die folgenden Datenquellen werden unterstützt:

    • Externe Datenbank (einfach) – Für jede Regel der Dokumentdefinition wird eine Verbindung zur externen Datenquelle hergestellt.
    • Externe Datenbank (variabel) – Die Verbindung zur externen Datenbank wird nur in den Projekteigenschaften eingerichtet (Projekteigenschaften > Umgebungsvariablen). Der Typ der Datenquelle kann simultan für mehrere Regeln verwendet werden. Verwenden Sie für ein Projekt eine andere Datenbank, müssen Sie die Verbindungseinstellungen nur in den Projekteigenschaften ändern.
    • Datensatz – Die Verbindung zum Datensatz wird vom Benutzer in den Eigenschaften der Dokumentdefinition festgelegt (Eigenschaften der Dokumentdefinition > Datensätze).

    Tipp. Wir empfehlen die folgenden OLE-DB-Anbieter:

    • Für den Export in SQL ist ein OLE-DB-Anbieter für ODBC-Treiber vorzuziehen
    • Wenn Sie nach Oracle exportieren, ist der Oracle-Anbieter für OLE-DB vorzuziehen
    Hinweis: Um nicht jedes Mal, wenn Sie eine Verbindung mit der Datenbank herstellen, das Passwort eingeben zu müssen, wählen Sie die Option Passwort speichern erlauben oder richten Sie die Datenbank so ein, dass kein Passwort für die Verbindung mit der Datenbank erforderlich ist (nutzen Sie zum Beispiel die Windows-Authentifizierung).

  12. Wählen Sie aus den Dropdownlisten das benötigte Schema und die erforderliche Datenbanktabelle aus oder geben Sie den benötigten Datensatz ein, um eine Verbindung zu einer Quelle des Typs Datensatz einzurichten.

    Hinweis: Wurde In allen Schemas suchen als Schema ausgewählt und ist die angegebene Tabelle im Standardschema nicht enthalten, kann die folgende Meldung auftreten:

    [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name K1. [Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared.

    Tritt diese Fehlermeldung auf, sollte der Name des Schemas, das die Tabelle enthält, explizit festgelegt werden.

  13. Wählen Sie die Option Nicht prüfen, wenn alle Felder leer aus, um die Regelüberprüfung zu überspringen, wenn Felder, die für den Vergleich herangezogen werden, keine Werte enthalten. Dies beschleunigt die regelbasierte Validierung.
  14. Stellen Sie Verknüpfungen zwischen den Feldern der Dokumentdefinition und den Feldern der Datenbank her (siehe unten „Angabe von zu vergleichenden Felder“).
  15. Über die Schaltflächen Hinzufügen…, Bearbeiten… und Löschen können Sie Verknüpfungen zwischen Feldern hinzufügen, bearbeiten oder entfernen.

Angeben von zu vergleichenden Feldern

Die bereits festgelegten Feldvergleiche finden Sie in der Gruppe Feldverknüpfungen auf der Registerkarte Regeleinstellungen. Sie können entweder für ein einzelnes Feld oder für einen Satz von Feldern eine Regel für die Datenbanküberprüfung festlegen.

Wenn Sie zu vergleichende Felder hinzufügen oder ändern, müssen Sie Folgendes festlegen:

  • Dokumentfeld – Das Feld der Dokumentdefinition, das mit einem Datenbankfeld verglichen werden soll
  • Datenbankfeld – Das Feld in der Datenbank, das mit dem Dokumentfeld verglichen werden soll
  • Suche – Gibt den Vergleichstyp an:
    • Genau – Der Wert des Dokumentfelds muss mit dem Wert im Datenbankfeld genau übereinstimmen (beachten Sie jedoch, dass die Suche Groß- und Kleinschreibung nicht berücksichtigt)
    • Annähernd – Der Wert des Dokumentfelds stimmt nur zum Teil mit dem Datenbankwert überein. Diese Art von Vergleich ist nur mit Textfeldern möglich.

      • Collapsed Hinweise zur fehlertoleranten Suche:

      Fehlertolerante Suchanfragen suchen nach den größten Übereinstimmungen, z. B. nach Wörtern, in denen nur wenige Buchstaben hinzugefügt, entfernt oder ersetzt werden müssen, um eine vollständige Übereinstimmung zu erreichen. Die Anzahl der zulässigen Fehler hängt von der Länge des ursprünglichen Worts ab. Wenn eine fehlertolerante Suche mehr als einen übereinstimmenden Wert findet, wird dem Operator die folgende Fehlermeldung angezeigt: Es wurden zu viele Datensätze gefunden.. Die Fehlermeldung zeigt zugleich die Liste der besten Übereinstimmungen mit der Datenbank an, sodass der Operator der Liste den richtigen Wert entnehmen kann.

Die folgenden erweiterten Optionen sind verfügbar:

  • Keine Suche bei leerem Feld–Ist das Feld leer, kann sein Wert nicht mit Werten aus der Datenbank verglichen werden.
  • Wert aus Datenbank eingeben – Findet die fehlertolerante Suche in der Datenbank einen übereinstimmenden Wert, kann dieser Wert automatisch in das Feld eingetragen werden, wenn:
    • sich die Werte im Feld und in der Datenbank unterscheiden
    • das Feld leer ist.

      Hinweis: Im Fall der exakten Suche macht die Option Aus der Datenbank übernehmen keinen Sinn, da die beiden Werte identisch sind.

  • Leere Werte in Datenbanken erlauben – In Abhängigkeit von den Resultaten der Datenbanküberprüfung und anderer Einstellungen hat diese Option folgende Bedeutung:
    • ist das Datenbankfeld leer und ist das Dokumentfeld nicht leer, werden Feld- und Datenbankwert als identisch interpretiert
    • ist das Datenbankfeld leer und ist das Dokumentfeld nicht leer und wurde Aus der Datenbank entnehmen gewählt, wird der leere Datenbankwert nicht in das Feld übernommen.

Durchführung einer Datenbanküberprüfung für einen Satz von Feldern

In diesem Fall sucht das Programm in der Datenbank nach einer übereinstimmenden Zeichenkette für die Werte in einem Satz von Feldern, wobei jeder Wert des Satzes von Feldern mit unterschiedlichen Spalten der gefundenen Zeichenkette verknüpft ist.

Beachten Sie folgendes Beispiel:

Wir assoziieren die Dokumentfelder Fa, Fb und Fc mit den Datenbankspalten Ta, Tb und Tc wie folgt:

  • Der Wert des Felds Fa stimmt genau mit dem Wert von Ta überein
  • Der Wert von Fb stimmt fehlertolerant mit dem Wert von Tb überein
  • Sind alle angegebenen Bedingungen erfüllt, wird der Wert des Felds Tc in das Feld Fc kopiert.

Die Datenbanküberprüfung ist erfolgreich, wenn das Programm in der Datenbank eine Zeichenkette findet, für die der Wert der Spalte Ta genau mit dem Wert des Felds Fa übereinstimmt und der Wert der Spalte Tb fehlertolerant mit dem Wert des Felds Fb übereinstimmt. Der Wert der Spalte Tc dieser Zeichenkette wird in das Feld Fc kopiert.

Wird keine solche Zeichenkette gefunden, gibt die Regel eine Fehlermeldung aus, auch wenn das Programm in verschiedenen Zeichenketten Ta = Fa und Tb = Fb findet.

Hinweis: Es sind unterschiedliche Kombinationen möglich: genaue/fehlertolerante/gemischte Übereinstimmungen, kein automatisches Ausfüllen, unbestimmte Anzahl Felder usw.


Regel zum Verbinden von Feldwerten

Diese Regel dient zum Verbinden von Werten mehrerer Felder. Verbundene Feldwerte können durch einen Punkt, ein Leerzeichen oder andere Trennzeichen getrennt werden.

So erstellen Sie eine Regel zum Verbinden von Werten:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften ( Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder verbinden aus, und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  8. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  9. Klicken Sie auf Weiter >.
  10. Fügen Sie in der Liste Zu verbindende Felder die Felder ein, die verbunden werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein. Wählen Sie Ergebnisfeld aus, d. h. ein Feld, in dem das Ergebnis der verbundenen Feldwerte angezeigt wird. Geben Sie im Fenster Trennzeichen das gewünschte Trennzeichen ein.
  11. Standardmäßig werden zwischen nicht leeren Werten Trennzeichen eingefügt. Wenn Trennzeichen immer, d. h. auch bei leeren Feldwerten, eingefügt werden sollen, aktivieren Sie die Option Trennzeichen für leere Feldwerte einsetzen.
  12. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.

Das Ergebnis kann in jeder beliebigen Dokumentdefinition gespeichert werden. Es empfiehlt sich die Verwendung von Feldern ohne Bereich.

Wenn Sie nur den Wert des Ergebnisfelds und nicht die Werte der verbundenen Felder exportieren möchten, deaktivieren Sie die Option Feldwert exportieren der entsprechenden Felder.


Festlegen einer Regel mithilfe eines Skripts

Mithilfe von ABBYY FlexiCapture können Sie eine Regel zum Überprüfen von Daten mithilfe eines Skripts konfigurieren.

So erstellen Sie diese Regel:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Skript aus, und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Legen Sie den Schweregrad der Regel fest.
  8. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  9. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  10. Klicken Sie auf Weiter >.
  11. In der Liste Verfügbare Felder sind die verfügbaren Objekte aufgeführt. Über die Schaltfläche Hinzufügen… oder Löschen können Sie Felder hinzufügen bzw. löschen. Die Werte der Felder, bei denen die Option Schreibgeschützt aktiviert ist, können nur gelesen werden, während die Werte der Felder, bei denen diese Option deaktiviert ist, mithilfe eines Skripts überschrieben werden können.

    Hinweis: Alle Felder, die Sie im Skript adressieren, müssen der Liste Verfügbare Felder hinzugefügt werden. Felder, die nicht der Liste hinzugefügt wurden, können im Skript nicht verwendet werden.

  12. Klicken Sie auf die Schaltfläche Bearbeiten…, um ein spezielles Fenster zur Skriptbearbeitung öffnen.
  13. Wählen Sie die Skriptsprache aus und geben Sie den Skripttext ein.
  14. Das Skript kann durch Auswahl von Extras>Skript überprüfen aus dem Hauptmenü überprüft werden.
  15. Speichern Sie das Skript durch Auswahl von Datei>Speichern.
  16. Klicken Sie auf Fertig stellen. Die erstellte Regel wird in der Liste auf der Registerkarte Regeln angezeigt.

Weitere Informationen zu den Skriptparametern finden Sie unter Skriptregel.


Summe in Zahlen und Summe in Wörtern

Wichtig! Diese Regel kann nur eingerichtet werden, wenn Sie für Ihre Dokumentdefinition die Erkennungssprache Russisch wählen (Dokumentdefinition>Eigenschaften der Dokumentdefinition…).

Der Zweck dieser Regel ist es, eine Zahlensumme mit der entsprechenden Summe von in Russisch geschriebenen Wörtern zu vergleichen. Wenn diese beiden Summen nicht identisch sind, dann wird die Meldung angezeigt, dass die Regel einen Fehler zurückgegeben hat.

So erstellen Sie die Regel „Summe in Zahlen und Summe in Wörtern“:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Dokumentdefinition Dokumentdefinition>Eigenschaften der Dokumentdefinition…).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summe in Zahlen und Summe in Worten (Russisch)aus, und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Legen Sie den Schweregrad der Regel fest.
  8. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  9. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  10. Klicken Sie auf Weiter >.
  11. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Zahlen, und wählen Sie dann das Feld der Dokumentdefinition aus, das die Summe in Zahlen enthält.
  12. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Wörtern, und wählen Sie dann das Feld der Dokumentdefinition aus, das dieselbe Summe in Wörtern enthält.
  13. Aktivieren Sie gegebenenfalls die Option Erlaube Kopeken in Summe
  14. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel für die Berechnung der Wertesumme

Diese Regel dient dazu, die Summe aus mehreren Feldwerten zu berechnen und in ein festgelegtes Feld einzugeben. Wenn das Dokument beispielsweise Felder mit Gehalts-, Bonus- und anderen Zahlungen enthält, können Sie eine Regel aufstellen, die deren Summe berechnet und die Ergebnisse in ein vorgegebenes Feld einträgt.

Diese Regel kann auch für die Berechnung einer Summe von Werten in einer Tabellenspalte verwendet werden. Hierfür muss die Regel in den Eigenschaften der Dokumentdefinition oder in den Eigenschaften des Dokumentbereichs erstellt werden. Die Option Mindestens zwei zu addierende Elemente ungleich Null muss deaktiviert sein.

So erstellen Sie eine Regel für die Summenberechnung:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld für die Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf Neue Regel….
  4. Wählen Sie in der Liste der Regeln Summe berechnen und klicken Sie auf OK.
  5. Geben Sie den Namen der Regel ein.
  6. Deaktivieren Sie gegebenenfalls die Option Regelname in Nachricht für Prüfer anzeigen. Ist diese Option deaktiviert, wird die Fehlermeldung als „Fehlermeldung“ angezeigt und nicht als „Name der Regel: Fehlermeldung“.
  7. Geben Sie gegebenenfalls die Bedingungen an, unter denen die Regel angewendet werden muss (standardmäßig wird eine Regel bedingungslos ausgeführt). Weitere Informationen finden Sie unter Bedingungen für die Anwendung von Regeln.
  8. Deaktivieren Sie gegebenenfalls die Option Aktivierte Regel. Die Regel wird erstellt, aber nicht angewendet, bis diese Option von einem Benutzer aktiviert wird.
  9. Klicken Sie auf Weiter >.
  10. Geben Sie in die Liste Feldwerte zusammenfassen die Felder ein, deren Werte summiert werden sollen. Klicken Sie dazu auf Hinzufügen….
  11. Geben Sie im Feld Ergebnisfeld das Feld ein, in das die Summe eingegeben werden soll. Klicken Sie hierfür auf Auswählen….
  12. Wählen Sie Mindestens zwei zu addierende Elemente ungleich Null, wenn mindestens zwei Summanden, die nicht leer und nicht null sind, verwendet werden sollen. Sofern diese Bedindung nicht erfüllt ist, wird während der Überprüfung der Regel im Fenster "Regelfehler" ein Fehler ausgegeben.

    Hinweis: Wenn Sie diese Option in Regelparametern verwenden, müssen der Addition mindestens zwei Dokumentfelder (oder zwei Tabellenspalten) hinzugefügt werden. Wenn Sie diese Regel also für die Addition der Werte aller Zellen einer Tabellenspalte verwenden, brauchen Sie diese Option nicht auszuwählen.

  13. Klicken Sie auf Fertig stellen, um die Erstellung der Regel zu beenden. Der Name der Regel wird in der Registerkarte Regeln angezeigt.


Konfigurieren des Datenexports

Um die Exporteinstellungen zu konfigurieren, wählen Sie im Dokumentdefinitionseditor Dokumentdefinition > Exporteinstellungen….

Sie können innerhalb einer Dokumentdefinition mehrere Exportprofile festlegen, wodurch Sie Ihre Verarbeitungsresultate in verschiedenen Formaten und zu mehreren Zielorten exportieren können.

Grundlegende Exportparameter und Exporttypen

Auf der Registerkarte Exportziele finden Sie eine Liste der konfigurierten Exportprofile und die folgenden Informationen über jedes Profil:

  • Name – Der Name des Exportprofils.
  • Typ – Der Exporttyp. Folgende Exporttypen sind verfügbar:
    • Benutzerdefinierter Export (verwendet ein Skript)
    • Exportieren in Datendateien (Standard, alle Dokumentdefinitionen enthalten ein Exportprofil für den Export von Daten in eine Excel-Tabelle)
    • In Bilddateien exportieren
    • In eine Datenbank exportieren
    • Nach SharePoint exportieren
  • Kritisch – Wurde diese Option ausgewählt, muss das Exportprofil zwingend ausgeführt werden. Anderenfalls ist das Exportprofil optional.

    Ist ein Export eines kritischen Exportprofils fehlgeschlagen, wird der Fehler im Ereignisprotokoll festgehalten und der Exporttask erhält den Status Fehlgeschlagen. Ist ein Export eines nicht kritischen Exportprofils fehlgeschlagen, wird eine Warnung für das Exportprofil aufgezeichnet und der entsprechende Exporttask erhält den Status Erfolgreich.

    Hinweis: Der Export kann aus mehreren Gründen fehlschlagen. Beispielsweise kann auf eine Datei oder eine Datenbank nicht zugegriffen werden.

  • Aktiviert – Wird diese Option gewählt, verwendet das Programm dieses Profil für den Datenexport. Anderenfalls wird das Profil als deaktiviert interpretiert.
  • Bedingungen – Die Bedingungen, die für das Programm erfüllt sein müssen, um erfasste Daten zu exportieren.

Exportbedingungen

Sie können ABBYY FlexiCapture so einrichten, dass Daten exportiert werden, wenn bestimmte Bedingungen erfüllt sind. Sie können beispielsweise nur Dokumente mit Regelfehlern, nur Dokumente ohne Regelfehler oder nur Dokumente, in denen ein bestimmtes Feld einen bestimmten Wert hat, exportieren. Sie können die Exportbedingungen unter Exportieren, wenn diese Bedingungen erfüllt sind festlegen.

Wenn die Exportbedingungen auf Regelfehlern beruhen sollen, wählen Sie in der Dropdownliste Dokumentfehler eine der drei folgenden Optionen:

  • Mit Fehlern – Wählen Sie diese Option, um nur Dokumente ohne Regel- und Formatfehler zu exportieren.
  • Ohne Fehler – Wählen Sie diese Option, um nur Dokumente mit Regel- und Formatfehlern zu exportieren.
  • Fehler sind irrelevant– Wählen Sie diese Option, um alle Dokumente unabhängig von Regel- und Formatfehlern zu exportieren.

Wenn die Exportbedingungen auf einem bestimmten Feldwert beruhen sollen, aktivieren Sie die Option Feldwertzuordnung im Dialogfeld Exportbedingungen:

  1. Wählen Sie ein Feld aus
  2. Wählen Sie in der Dropdownliste eine Bedingung aus, die den Export auslöst
  3. Geben Sie die möglichen Feldwerte an (soweit vorhanden)

Die folgenden Feldwerte können den Export auslösen:

  • Gehört zur Menge – Die Daten werden exportiert, wenn der Feldwert mit einem der von Ihnen angegebenen Werte übereinstimmt.
  • Gehört nicht zur Menge – Die Daten werden exportiert, wenn der Feldwert nicht mit einem der von Ihnen angegebenen Werte übereinstimmt.
  • Ist leer – Die Daten werden exportiert, wenn das Feld leer ist.
  • Ist nicht leer – Die Daten werden exportiert, wenn das Feld nicht leer ist.

Um einen Wert zu einem Satz möglicher Werte hinzuzufügen, geben Sie den Wert ein und klicken Sie auf Hinzufügen. Um den Wert aus dem Satz zu löschen, wählen Sie den Wert aus und klicken Sie auf Löschen. Sie können auch einen leeren Wert zum Satz möglicher Werte hinzufügen. Klicken Sie dazu auf Hinzufügen, ohne einen Wert einzugeben. Der leere Wert erscheint im Satz möglicher Werte als <Leerer Wert>. Ein Wert kann nur einmal hinzugefügt werden.

Die Exportbedingungen können Textfelder beinhalten (einschließlich Felder mit fortgesetzten Bereichen), Barcodes und Tabellenspalten. Die Exportbedingungen dürfen keine Auswahlfelder, Auswahlfeldgruppen, Felder mit mehreren Instanzen, Bilder oder Tabellenzellen enthalten.

Hinweis: Enthält die Exportbedingung eine Tabellenspalte, werden die Daten exportiert, wenn wenigstens eine Zelle in der Spalte der Bedingung entspricht.

Sie können die Exportbedingungen nutzen, um den Speicherort der verarbeiteten Dokumente festzulegen. Sie können beispielsweise Dokumente in Abhängigkeit von einem bestimmten Feldwert (z. B. Tochtergesellschaft) in unterschiedlichen Ordnern ablegen. Ebenso können Sie Dokumente mit Regelfehlern in einen bestimmten Ordner exportieren (z. B. Fehlgeschlagen).

Feineinstellung des Exports

Der Satz der zu exportierenden Felder wird zunächst auf der Grundlage der Feldeigenschaften generiert (d. h. abhängig davon, ob die Option Feldwert exportieren gewählt wurde). Wenn Sie dann ein Exportprofil erstellen, können Sie alle Felder aus dem so generierten Satz von Feldern entfernen. Felder eines Satzes können zu verschiedenen Zielorten exportiert werden. Wählen Sie Exporteinstellungen und klicken Sie nacheinander auf Bearbeiten…> Optionen… > Feldzuordnung einrichten…. Es öffnet sich das Dialogfeld Feldzuordnung, in dem Sie die gewünschten Zielorte festlegen können.

Hinweis: Wenn Sie Daten in ein Bildformat (oder in eine PDF-Datei) exportieren, steht Ihnen die Option Vertrauliche Daten aus Bildern entfernen zur Verfügung. Mit dieser Option können Sie die Bilder der Felder entfernen, deren Inhalt nicht sichtbar sein soll. Wählen Sie Exporteinstellungen, klicken Sie auf Bearbeiten, wählen Sie Vertrauliche Daten aus Bildern entfernen und klicken Sie anschließend auf Zu schwärzende Felder auswählen…. Es öffnet sich das Dialogfeld Zu schwärzende Felder auswählen, in dem Sie vertrauliche Felder schwärzen können.

Automatischer Export

Sie können ABBYY FlexiCapture für den automatischen Export einrichten. Klicken Sie im Dialogfeld Eigenschaften Ihrer Dokumentdefinition auf Exporteinstellungen und wählen Sie Auto-Export aktivieren. Jetzt werden verarbeitete Dokumente automatisch exportiert, ohne dass ein Operator den Export durch Klicken auf eine Schaltfläche starten muss.

Der automatische Export ist nur möglich, wenn in Ihrer Dokumentdefinition die Seitenzahl des Dokuments explizit angegeben ist. Das bedeutet, dass der automatische Export nicht funktioniert, wenn Seiten mehrfach vorhanden sind oder die Anzahl der Bereiche mittels eines Intervalls (einschließlich 0-1) angegeben wurde. Dokumente, die zur Überprüfung eingereicht wurden, können ebenfalls nicht automatisch exportiert werden.

Hinweis: Wenn Dokumente automatisch exportiert werden, wird die Stapelintegritätsprüfung übersprungen und eine Warnung in das Taskprotokoll geschrieben.

Speichern von Resultaten im Dateisystem

Sie können ABBYY FlexiCapture so einrichten, dass erfasste Daten und/oder Dokumentbilder im Dateisystem gespeichert werden.

Wird ein absoluter Pfad zu einem Speicherort verwendet, können Sie entweder einen lokalen Pfad oder einen Pfad im UNC-Netzwerk festlegen.

Wird eine relativer Pfad verwendet, beispielsweise, wenn nur ein Unterordner angegeben ist, wird der Unterordner im Unterordner Export des Projektordners erstellt. Um einen anderen Speicherort festzulegen, geben Sie in den Projekteinstellungen einen Exportstammpfad an. Jetzt werden alle neuen Unterordner in Bezug auf den von Ihnen festgelegten Stammpfad erstellt. Sie können entweder einen lokalen Pfad oder einen UNC-Netzwerkpfad als Stammpfad eingeben.

Export in eine Datei
Bildexport in eine Datei
In Datenbank exportieren
Nach SharePoint exportieren
Export mithilfe eines Skripts


Datenexport in eine Datei

So konfigurieren Sie den Export in eine Datei:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoptionen Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Feld Typ die Option Exportieren in Datendateien.

  3. Bestimmen Sie, ob der Export obligatorisch ist.

  4. Bestimmen Sie, ob Bilder exportiert werden sollen.

  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Legen Sie die Exportparameter fest und klicken Sie auf Weiter>. Die änderbaren Exportparameter richten sich nach dem im Feld Ziel angegebenen Wert.

    Collapsed Dateinamen und Struktur der Unterordner des Hot Folders nachbilden

    Wenn Sie diese Option wählen, entspricht die Ordnerstruktur der des Hot Folders, aus dem die Dokumentbilder importiert wurden. Wenn Sie diesen Exporttyp konfigurieren, wählen Sie im Feld Exportpfad den Ordner aus, der die Struktur des Hot Folders widerspiegeln soll.

    Collapsed Alle Dokumente in eine Datei exportieren

    Wählen Sie diese Option aus, um alle Daten in eine Datei zu exportieren. Wenn Sie diesen Exporttyp konfigurieren, geben Sie im Feld Exportpfad den Pfad und den Namen der Datei für den Datenexport an.

    Collapsed Für jeden Stapel separaten Ordner erstellen

    Wählen Sie diese Option aus, um jedes Dokument als eine separate Datei zu exportieren:

    • Geben Sie im Feld Dateipräfix den Pfad und die ersten Zeichen des Dateinamens ein.

    • Wenn jeder Stapel in einen eigenen Ordner exportiert werden soll, wählen Sie die Option Für jeden Stapel separaten Ordner erstellen aus.
    Collapsed Ordnerstruktur und Dateiname mittels Vorlage erstellen

    Wenn Sie diese Option auswählen, werden die Dateinamen und die Struktur der Unterordner in Abhängigkeit von den Dokumentparametern gebildet.

    • Geben Sie im Feld Exportpfad den Stammpfad für den Export an..
    • Legen Sie die Optionen für die Dateinamen fest. Klicken Sie hierfür auf Bearbeiten… und geben Sie die benötigten Regeln ein. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
    • Wählen Sie im Feld Wenn Datei bereits vorhanden aus, welche Aktion das Programm durchführen soll, wenn bereits eine Datei mit dem generierten Namen existiert.

    Exportfehler treten auf, wenn der Pfad in folgendem Format angegeben wird: <Datenträger:>\[Pfad].

  7. Wählen Sie den Dateityp aus (unterstützt werden die Formate CSV, DBF, TXT, XLS und XML), legen Sie weitere Exporteigenschaften für den ausgewählten Dateityp fest und wählen Sie ggf. die Textcodierung aus. Klicken Sie dann auf Weiter>.

    Collapsed Microsoft Office Excel-Arbeitsmappe (*.xls)
    • Wählen Sie die Version von Microsoft Excel (5.0/95; 97-2003; 97-2003 (kompatibel mit 5,0/95);
    • Wählen Sie Werttyp beim Exportieren beibehalten aus, um die Daten basierend auf ihrem Typ zu exportieren. Deaktivieren Sie diese Option, um alle Daten mit dem Typ "Allgemein" zu exportieren;
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, um mehrmals vorkommende Felder und Tabellen in separate Dateien zu exportieren. Beachten Sie den Hinweis;

    • Wählen Sie bei Excel 5.0/95 eine Zeichencodierung aus;

    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    Collapsed XML Dokument (*.xml)

    • Geben Sie die zusätzlich zu exportierenden Daten ein (Feldpositionen und -typen, Fehler, Daten zur Erkennungsqualität);

    • Wählen Sie Werttyp beim Exportieren beibehalten, wenn Sie das XML-Schema mit den Beschreibungen der Feldtypen speichern möchten;
    • Wählen Sie die Codierung aus;
    • Legen Sie ggf. die Feldnamen fest. Klicken Sie hierfür auf Feldzuordnung und geben Sie im Dialogfeld Feldzuordnung die Feldnamen ein.
    Collapsed Kommagetrennte Datei (*.csv)
    • Wählen Sie das Spaltentrennlinie aus;
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen,aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten. Beachten Sie den Hinweis;
    • Wählen Sie die Codierung aus.;
    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    Collapsed Textdatei (*.txt)
    • Wählen Sie das Spaltentrennlinie;
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten. Beachten Sie den Hinweis;
    • Wählen Sie die Codierung aus;
    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    Collapsed DBase-Datei (*.dbf)
    • Wählen Sie Werttyp beim Exportieren beibehalten , um die Daten basierend auf ihrem Typ zu exportieren. Deaktivieren Sie diese Option für alle Felder, damit diese vom Typ "Text" sind;
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten. Beachten Sie den Hinweis;
    • Konfigurieren Sie ggf. die Feldnamen. Klicken Sie hierfür auf Feldzuordnung und geben Sie im Dialogfeld Feldzuordnung die Feldnamen ein.

    8. Führen Sie die Schritte 8 und 9 nur aus, wenn Sie in Schritt 4 die Option Dokumentbilder speichern gewählt haben.

  8. Wenn Sie die Bilder speichern möchten, legen Sie die Parameter zum Speichern von Bildern fest und klicken auf Weiter>.
    • Wählen Sie aus, ob die Bilder zusammen mit den Daten gespeichert werden sollen, oder geben Sie den Bildordner an;
    • Wählen Sie das Namensschema für die Bilddateien aus: ähnlich wie bei den Datendateien oder anders. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
    • Geben Sie die Felder an, die Bilder enthalten, die Sie beim Export ausblenden möchten.
  9. Wenn Bilder gespeichert werden sollen, bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.

    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.

    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbares PDF erstellen wählen. Bei durchsuchbaren PDF wird der gesamte Text des Dokuments durchsucht: Die Textebene wird sowohl aus den überprüften Feldwerten als auch aus Dokumentbereichen außerhalb dieser Felder gebildet. Für die Bereiche außerhalb der Felder wird eine Volltexterkennung durchgeführt. Legen Sie im Feld Suchtextfest, wo Text gesucht werden soll: auf allen Seiten, auf Bereichsseiten oderauf Anhangseiten.

      Die Erkennungssprache wird folgendermaßen definiert:

      • Für Felder wird die Erkennungssprache auf der Registerkarte Datentypder Feldeigenschaften definiert.

      • Für die Volltexterkennung wird die Sprache der Dokumentdefinition verwendet.

      • Für Anhangseiten können Sie eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet. Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen… und fügen Sie die entsprechenden Sprache hinzu. Standardmäßig wird die Sprache der Dokumentdefinition verwendet.

  10. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Hinweis: Mehrfach vorkommende Felder (d. h. Felder mit mehreren Instanzen und Tabellen) werden jeweils in separate Dateien exportiert, für die ein neuer Ordner erstellt wird. Der Name des Ordners besteht aus dem Namen der Exportdatei. Wenn mehrfach vorkommende Felder nicht in separate Dateien exportiert werden sollen, deaktivieren Sie auf der Registerkarte Separate Dateien für wiederholbare Elemente erstellen die Option Exportzielassistent die Option ist für alle Formate mit Ausnahme von XML verfügbar). In diesem Fall werden mehrfach vorkommende Felder in eine Exportdatei exportiert und es wird eine neue Zeile für jede Elementinstanz hinzugefügt.

Hinweis: Wenn Sie Daten über die exportieren Bilder (Seitenbilder oder Felder) in eine Datei exportieren, kann der Pfad zur Datei folgende Eigenschaften haben:

  • relativ, wenn die Bilder in denselben Ordner (oder deren Unterordner) exportiert werden, in dem sich die Datei befindet

  • absolut in allen anderen Fällen


Bildexport in eine Datei

So exportieren Sie Bilder in eine Datei:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Option Dokumentdefinition > Exporteinstellungen…
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Typ Feld Exportieren in Bilddateien.

  3. Bestimmen Sie, ob der Export obligatorisch ist.

  4. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  5. Legen Sie die Exportparameter fest und klicken Sie auf Weiter>. Die änderbaren Exportparameter richten sich nach dem im Feld Typ angegebenen Wert.
      Collapsed Dateinamen und Struktur der Unterordner des Hot Folders nachbilden

      Wenn Sie diese Option wählen, entspricht die Ordnerstruktur der des Hot Folders, aus dem die Dokumentbilder importiert wurden. Wenn Sie diesen Exporttyp konfigurieren, wählen Sie im Feld Exportpfad den Ordner aus, der die Struktur des Hot Folders widerspiegeln soll.

      Collapsed Alle Dokumente in eine Datei exportieren

      Wählen Sie diese Option aus, um alle Daten in eine Datei zu exportieren. Wenn Sie diesen Exporttyp konfigurieren, geben Sie im Feld Pfad den Pfad und den Namen der Datei für den Datenexport an.

      Collapsed Dokumente als einzelne Dateien exportieren

      Wählen Sie diese Option aus, um jedes Dokument als eine separate Datei zu exportieren:

      • Geben Sie im Feld Dateipräfix den Pfad und die ersten Zeichen des Dateinamens ein;
      • Wenn jeder Stapel in einen eigenen Ordner exportiert werden soll, wählen Sie die Option Für jeden Stapel separaten Ordner erstellen aus.
      Collapsed Ordnerstruktur und Dateiname mittels Vorlage erstellen

      Wenn Sie diese Option auswählen, werden die Dateinamen und die Struktur der Unterordner in Abhängigkeit von den Dokumentparametern gebildet.

      • Geben Sie im Feld Exportpfad den Stammpfad für den Export an..
      • Legen Sie die Optionen für die Dateinamen fest. Klicken Sie hierfür auf Bearbeiten… und geben Sie die erforderlichen Regeln ein. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
      • Wählen Sie im Feld Wenn Datei bereits vorhanden aus, welche Aktion das Programm durchführen soll, wenn bereits eine Datei mit dem generierten Namen existiert.
  6. Legen Sie die Bildspeicheroptionen fest und klicken Sie auf Weiter>.

    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.

    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie als Speicherformat die Option PDF oder PDF/A auswählen, dann können Sie durchsuchbare PDF-Dateien erstellen, indem Sie die Option Durchsuchbares PDF erstellenwählen. Bei durchsuchbaren PDF erfolgt die Suche über den gesamten Text des Dokuments: Die Textebene wird sowohl aus den überprüften Feldwerten als auch aus Dokumentbereichen außerhalb dieser Felder gebildet. Für die Bereiche außerhalb der Felder wird eine Volltexterkennung durchgeführt. Legen Sie im Feld Suchtext fest, wo Text gesucht werden soll:a auf allen Seiten, auf Bereichsseiten oder auf Anhangseiten.

      Die Erkennungssprache wird folgendermaßen definiert:

      • Für Felder wird die Erkennungssprache auf der Registerkarte Datentyp der Feldeigenschaften definiert.

      • Für die Volltexterkennung wird die Sprache der Dokumentdefinition verwendet.

      • Für Anhangseiten können Sie eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet. Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen... und fügen Sie die entsprechenden Sprachen hinzu. Standardmäßig wird die Sprache der Dokumentdefinition verwendet

      Wählen Sie die Option MRC verwenden (Mixed Raster Content) wenn Sie eine höhere Erkennungsgeschwindigkeit erreichen möchten und die Ausgabedateien kleiner sein sollen. Mit dieser Option können die Felder, für die der Modus Nicht erkennen ausgewählt wurde, mit einer geringeren Qualität exportiert werden.

  7. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.


In Datenbank exportieren

So konfigurieren Sie den Export in eine Datenbank:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoption Dokumentdefinition > Exporteinstellungen…
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Feld Typ die Option In ODBC-kompatible Datenbank exportieren.

  3. Bestimmen Sie, ob der Export obligatorisch ist.

  4. Bestimmen Sie, ob Bilder exportiert werden sollen.

  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Legen Sie die Exporteinstellungen fest und klicken Sie auf Weiter>.

    • Stellen Sie eine Verbindung mit einer Datenbank her. Geben Sie im Fenster Verbindungszeichenfolge die Verbindungsparameter ein, oder klicken Sie auf die Schaltfläche Einrichtung… und legen Sie im Dialogfeld Eigenschaften von Datenverbindung die Verbindungsparameter fest.

      • Collapsed Getestete Anbieter und Treiber

      Für die Datenbanken SQL 2000, 2005, 2008, 2008R2, 2012:

      1. Anbieter - OLE-DB-Anbieter für ODBC-Treiber;

        Hinweis: Die Auswahl von "OLE-DB-Anbieter für SQL-Server" führt bei der Verwendung bestimmter Datentypen und langer Felder möglicherweise zu Fehlern.

      Für den Zugriff auf die Datenbanken Access 2003, 2007, 2010:

      1. Anbieter - OLE-DB-Anbieter für ODBC-Treiber;
      2. Treiber - Microsoft Access-Treiber (Driver do Microsoft Access oder Microsoft Access-Treiber)..

      Für die Datenbanken Oracle 9g, 10g, 11g:

      1. Anbieter - Oracle-Anbieter für OLE DB;
      2. Eine Auswahl des Treibers nicht erforderlich.

      Anbieter und Treiber müssen auf dem Computer verfügbar sein, auf dem der Export ausgeführt wird.

    • Wählen Sie in der Dropdownliste ein Schema aus.

    • Sie können die Verbindung mit der Datenbank überprüfen, indem Sie auf die Schaltfläche Verbindung testen klicken.
    • Klicken Sie auf die Schaltfläche Tabellen automatisch erstellen um in der Datenbank automatisch neue Tabellen zu erstellen, in die Daten aus Dokumenten exportiert werden. Für jeden Dokumentbereich wird eine eigene Tabelle erstellt. Struktur und Format der Felder in automatisch erstellten Tabellen entsprechen dem Satz von Feldern in der Dokumentdefinition und ihren Datentypen.

    Hinweis: Vor dem Export fragt ABBYY FlexiCapture die Datenbank auf Informationen über alle Objekte des Schemas ab. Es wird empfohlen, für den Export Schemen mit einer geringen Anzahl von Objekten zu verwenden. Die Erstellung der Tabellen kann sonst viel Zeit in Anspruch nehmen (bis zu mehreren Stunden).

    • Wenn es erforderlich ist, Daten in bestehende Tabellen einer Datenbank zu exportieren, stellen Sie eine Übereinstimmung zwischen den Feldern in der Dokumentdefinition und den Feldern in der Datenbanktabelle her. Wählen Sie dafür die Schaltfläche Feldzuordnung wird eingerichtet….
    • Geben Sie im Dialogfeld Feldzuordnung an, in welche Tabellen und Tabellenspalten der Datenbank die Feldwerte der Dokumentdefinition exportiert werden sollen.
      • Collapsed Details...

      Im linken Bereich des Dialogfelds Feldzuordnung sind Dokumentbereiche und -felder aufgeführt. Im rechten Bereich müssen Sie diese Bereiche und Felder den Tabellen und Feldern in der Datenbank zuordnen. Wenn die Datenbank bereits Tabellen für den Datenexport enthält, müssen Sie im Dialogfeld Feldzuordnung eine Datenbanktabelle für jeden Dokumentbereich und eine Datenbanktabellenspalte für jedes Dokumentfeld auswählen. (Neben dem direkten Export in Datenbanktabellen ist es möglich, Daten über gespeicherte Prozeduren in einer Datenbank zu speichern. Weitere Informationen hierzu finden Sie unter Details zur Konfiguration des Datenexports über gespeicherte Prozeduren von Datenbanken.

      Wenn die Datenbank keine Tabellen für den Export enthält, können Sie Datenbanktabellen automatisch erstellen. Klicken Sie dazu auf die Schaltfläche Tabellen automatisch erstellen. Damit werden Tabellen mit der für den Export erforderlichen Struktur erstellt. Die Dokumentfelder werden Tabellenspalten zugeordnet.

      Feldgruppen, Felder mit mehreren Instanzen und Dokumenttabellen werden jeweils in separate Datenbanktabellen exportiert. Die Haupttabelle wird mithilfe eines primären Schlüssels und eines Fremdschlüssels mit den untergeordneten Tabellen verknüpft. In der Haupttabelle wird jedem Eintrag ein primärer Schlüssel hinzugefügt. In der untergeordneten Tabelle wird jedem Eintrag ein Fremdschlüssel zugewiesen, mit dem der Wert des primären Schlüssels des entsprechenden Eintrags in der Haupttabelle erfasst wird. Die primären und Fremdschlüssel werden an den entsprechenden Stellen automatisch hinzugefügt. Sie müssen lediglich das Feld angeben, zu dem der Schlüssel exportiert werden soll.

      Wählen Sie für jedes Dokumentfeld eine Spalte einer Datenbanktabelle aus.

      Wenn eine Spalte, in die Daten aus einem Feld exportiert werden sollen, in der Tabelle fehlt, kann sie automatisch zur bestehenden Tabelle hinzugefügt werden. Hierfür ist es ausreichend, die Übereinstimmung des Dokumentfelds mit dem Datenbankfeld mit einem ähnlichen Namen und mit dem Kommentar (Automatisch) in Klammern zu lassen. Sie können auch ein gewünschtes Feld mit der Maus auswählen und auf die Schaltfläche Automatisch klicken.
      Mit der Schaltfläche Automatisch können Sie auch eine neue Tabelle in der Datenbank erstellen, deren Name dem Bereichs- oder Tabellennamen der Dokumentdefinition ähnlich ist.

      Wenn im Dialogfeld für die Einstellungen der Feldübereinstimmung eine neue Tabelle, deren Name und Spaltenüberschriften sich von den Feldnamen der Dokumentdefinition unterscheiden, erstellt werden muss, verwenden Sie die Schaltfläche Neu, um für jedes Feld eine Tabelle zu erstellen.

      Mit den Schaltflächen Nach oben und Nach unten verwalten Sie die Reihenfolge der Spalten in der automatisch erstellten Datenbanktabelle.

      Mit der Schaltfläche Format… konfigurieren Sie Parameter zum Speichern typisierter Felder, z. B. der Anzahl der Dezimalziffern im Feldwert des Typs Zahl oder Format und Trennzeichen für ein Feld vom Typ Daten.

      Hinweis: Beim Export eines Feldes des Datentyps Time muss in der Datenbanktabelle eine entsprechende Tabelle des Typs DateTime erstellt werden. Standardmäßig wird die Spalte des Typs SmallDateTime erstellt, was zu einem Fehler führt.

  7. Wenn Bilder gespeichert werden sollen (Dokumentbilder und/oder Feldbilder vom Typ <b>Bild</b>), geben Sie die Bildspeicheroptionen an und klicken auf Weiter >.

    • Legen Sie fest, ob die Bilder in der Datenbank oder als Dateien gespeichert werden sollen.

    • Wenn Sie Bilder in Dateien speichern möchten, müssen Sie eine Dateinamenvorlage angeben (klicken Sie auf Bearbeiten…)…), und wenn Dateien denselben Namen tragen, geben Sie an, ob eine Datei überschrieben werden soll. Weitere Informationen finden Sie unter Kriterien für die Namen von Exportdateien.

    • Legen Sie bei Bedarf die Felder fest, die beim Export nicht berücksichtigt werden sollen.

    Hinweis: Je nach ausgewählter Option können Inhalte der Felder vom Typ Bild und Dokumentbilder in das Dateisystem oder in eine Datenbank exportiert werden.

    Beim Export in separate Dateien werden der Name und der Pfad eines Bildes oder einer Bilddatei im entsprechenden Feld einer Datenbank gespeichert (dieses wird beim Herstellen der Übereinstimmung der Felder konfiguriert). Wenn ein Netzlaufwerk als Pfad eines Exportordners (für Dokumente, Bilder usw.) angegeben ist, müssen Sie sicherstellen, dass alle Stationen, die mit diesem Laufwerk arbeiten, darauf Zugriff haben. Mittels eines besonderen Verfahrens können Sie ein Binärbild aus einer Datenbank in eine Datei umwandeln.

    Hinweis: Beim Export von Bildern als separate Dateien kann die Länge einer Zeichenfolge des Speicherpfads 255 Zeichen überschreiten und es wird eine Fehlermeldung ausgegeben. In diesem Fall sollten Sie die Zeichenbeschränkung für die gegebene Spalte erhöhen.

  8. Wenn die Option zum Speichern von Bildern ausgewählt wurde, geben Sie ein Dateiformat zum Speichern an und klicken auf Weiter >.

    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.

    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie als Speicherformat die Option PDF oder PDF/A auswählen, dann können Sie durchsuchbare PDF-Dateien erstellen, indem Sie die Option Durchsuchbares PDF erstellen. wählen. Bei durchsuchbaren PDF erfolgt die Suche über den gesamten Text des Dokuments: Die Textebene wird sowohl aus den überprüften Feldwerten als auch aus Dokumentbereichen außerhalb dieser Felder gebildet. Für die Bereiche außerhalb der Felder wird eine Volltexterkennung durchgeführt. Legen Sie im Feld Suchtext fest, wo Text gesucht werden soll: auf allen Seiten, auf Bereichsseiten oder auf Anhangseiten.

      Die Erkennungssprache wird folgendermaßen definiert:

      • Für Felder wird die Erkennungssprache auf der Registerkarte Datentyp der Feldeigenschaften definiert.

      • Für die Volltexterkennung wird die Sprache der Dokumentdefinition verwendet.

      • Für Anhangseiten können Sie eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet. Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen... und fügen Sie die entsprechenden Sprachen hinzu. Standardmäßig wird die Sprache der Dokumentdefinition verwendet

  9. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Hinweis:

  1. Bilder werden in separate Dateien exportiert. Name und Pfad der Bilddatei können in dem entsprechenden Feld der Datenbank gespeichert werden (dieses kann beim Zuordnen der Felder eingerichtet werden).

  2. Wenn sich der Pfad zum Zielordner für Dokumente, Bilder usw. auf ein Netzlaufwerk bezieht, stellen Sie sicher, dass alle am Projekt beteiligten Verarbeitungsstationen Zugriff auf dieses Laufwerk haben.

Details zur Konfiguration des Datenexports über gespeicherte Prozeduren von Datenbanken

Neben dem direkten Export von Daten in Datenbanktabellen ist es möglich, Daten über gespeicherte Prozeduren in einer Datenbank zu speichern.

Eine gespeicherte Prozedur ist ein aus einem Satz SQL-Anweisungen bestehendes Datenbankobjekt, das einmal kompiliert und dann auf dem Server gespeichert wird. Gespeicherte Prozeduren können zur Durchführung numerischer Berechnungen und Operationen mit Zeichendaten verwendet werden, deren Ergebnisse Variablen und Parametern zugewiesen werden können, zudem können sie zur Durchführung von Standardoperationen mit Datenbanken herangezogen werden.

Die Verwendung gespeicherter Prozeduren hat im Vergleich zum direkten Export in Datentabellen die folgenden Vorteile:

  • Schnelligkeit der Arbeit mit einer Datenbank

  • Möglichkeit der Verwendung zusätzlicher Berechnungen

  • Sicherstellung der Datenintegrität

Ein Beispiel für eine freigegebene Prozedur für MS SQL:

Create procedure Export( @userId as int, @lastName as nvarchar(255), @firstName as nvarchar(255) )
as
begin
if Exists( Select Id from Users where Id = @userId ) begin
Update Users set LastName = @lastName, FirstName=@firstName where Id = @userId
end else begin
Insert into Users ( Id, LastName, FirstName ) values( @userId, @lastName, @firstName
)
end
end

Wenn über die oben aufgeführte Prozedur Daten von FlexiCapture an eine Datenbank gesendet werden, werden die folgenden Bearbeitungsschritte durchgeführt:

Die drei Parameter, die an den Eingang der Prozedur übergeben werden, sind die Felder eines FlexiCapture-Dokuments: eine Kennung (UserId), der Vorname (FirstName) und der Nachname (LastName). Gibt es in der Datenbanktabelle (Users) keinen Eintrag mit einer solchen Kennung, wird der Tabelle ein neuer Eintrag hinzugefügt. Ist ein Eintrag mit einer solchen Kennung vorhanden, werden die Werte des Vor- und Nachnamens in diesem Eintrag durch neue Werte ersetzt (durch die Werte aus den FlexiCapture-Feldern).

Konfigurieren des Exports über gespeicherte Prozeduren

Um den Export mit Hilfe von gespeicherten Prozeduren zu konfigurieren, ist es nötig, zunächst eine Verbindung zu einer Datenbank aufzubauen (siehe oben). Klicken Sie anschließend auf Feldzuordnung wird eingerichtet…, um die Übereinstimmung der Dokumentfelder mit den Parametern der gespeicherten Prozedur festzulegen.

Wählen Sie im Dialogfeld Feldzuordnung wird eingerichtet… aus der Liste von Tabellen und gespeicherten Prozeduren für Datenbanken eine erforderliche gespeicherte Prozedur zum Speichern der Daten aus.

Im Gegensatz zur Konfiguration des direkten Exports in Spalten einer Datenbank handelt es sich bei den für den Export vorgeschlagenen Feldern um Parameter einer gespeicherten Prozedur. Prozedurparameter sind typisiert. Für die Zuordnung ist es erforderlich, dass der Parametertyp mit dem Datentyp des Dokumentdefinitionsfelds übereinstimmt.

Stellen Sie die Zuordnung der Dokumentfelder zu den Parametern der gespeicherten Prozedur der Datenbank her.

Hinweis: Wenn es erforderlich ist, nicht nur separate Felder aus dem Dokument zu exportieren, sondern auch Tabellen und komplexe Felder (z. B. Felder mit einigen Instanzen), müssen Sie korrekte Indexe einrichten, damit untergeordnete Einträge mit dem Dateneintrag im Hauptdokument verbunden werden können. Geben Sie den Rückgabewert (@RETURN_VALUE) oder einen Ausgangsparameter der gespeicherten Prozedur als exportierbaren Primärschlüssel (ROW_INDEX) an. Dann schreibt die Prozedur beim Datenexport die Daten in die Datenbanktabelle und gibt die Kennung des aktuellen Eintrags zurück, der daraufhin für den Export der untergeordneten Einträge an die gespeicherte Prozedur übergeben wird.


Exportieren von Daten in eine SharePoint-Dokumentbibliothek

ABBYY FlexiCapture ermöglicht Ihnen das Exportieren von Dokumenten in eine MicrosoftTM SharePoint-Dokumentbibliothek. Als Ergebnis erhalten Sie eine Bibliothek Ihrer Dokumentbilder mit zusätzlichen Spalten für jedes Dokument, die mit Werten bestimmter Felder ausgefüllt sind.

Hinweis:

  1. Die folgenden Versionen von MicrosoftTM SharePoint werden unterstützt: MS SharePoint 2003, MS SharePoint 2007, MS SharePoint 2010 und MS SharePoint 2013.
  2. Zum Einrichten des Exports von Daten nach SharePoint sind Administratorrechte erforderlich. Für den eigentlichen Export nach SharePoint sind Mitarbeiterrechte ausreichend.

  3. Die SharePoint-Spalten, in denen die Daten erfasst werden sollen, müssen vom Typ Eine Textzeile oder Mehrere Textzeilen sein (Einzelheiten finden Sie im Abschnitt Konvertieren von Daten beim Export in Microsoft SharePoint2013 dieses Artikels).

  4. Die Option Kernel-Modus-Authentifizierung aktivieren muss für die SharePoint-Seite in den Einstellungen von Internet Information Server (IIS) ausgewählt werden.
    Collapsed Bild anzeigen

    Wird dieser Modus deaktiviert, tritt während des Exports der folgende Fehler auf: "Fehler bei der Verbindung mit dem SharePoint-Server:" Nicht autorisierter Zugriff auf SharePoint-Server".

So richten Sie den Export nach SharePoint ein:

  1. Wählen Sie im Dokumentdefinitionseditor die Option Dokumentdefinition > Exporteinstellungen…
  2. Klicken Sie auf Hinzufügen….
  3. Wählen Sie die Option Nach SharePoint exportieren im Feld Typ aus.

  4. Bestimmen Sie, ob der Export obligatorisch ist.

  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Legen Sie die Exporteinstellungen fest und klicken Sie auf Weiter>.

    • Server-URL (z.B. http://meinserver) – Geben Sie die Adresse des Servers ein, auf dem sich Ihre SharePoint-Bibliotheken befinden. Verwenden Sie die Schaltfläche Verbindungseinstellungen…, um gegebenenfalls die Authentifizierungsparameter (standardmäßig werden die Windows-Authentifizierungsparameter verwendet) und die Proxy-Einstellungen einzurichten.
    • Unter der Serveradresse wird der Verbindungsstatus angezeigt. Wenn die Serververbindung getrennt ist, klicken Sie auf Verbinden, um die Verbindung wiederherzustellen.
    • Wenn Sie mit dem SharePoint-Server verbunden sind, wählen Sie aus der Liste SharePoint-Bibliothek auswählen eine Bibliothek aus.
    • Klicken Sie auf Durchsuchen… und suchen Sie den gewünschten Ordner in der Bibliothek.
    • Wählen Sie im Feld Inhaltstyp den Inhaltstyp Ihres Dokuments aus (unterstützt ab SharePoint 2007). In diesem Fall haben Sie die Möglichkeit, Werte in die Felder zu exportieren, die dem ausgewählten Inhaltstyp entsprechen.

      Hinweis: Inhaltstyp ist die vom Benutzer angegebene Liste der Inhaltstypen in SharePoint. Die in SharePoint für die Zuordnung verfügbaren Felder werden durch den ausgewählten Inhaltstyp bestimmt.

    • Legen Sie nun fest, welche Dokumentdefinitionsfelder wohin exportiert werden sollen. Klicken Sie auf die Schaltfläche Feldzuordnung einrichten… und wählen Sie die gewünschten Optionen im Dialogfeld Feldzuordnung wird eingerichtet… aus. In diesem Dialogfeld müssen Sie die Übereinstimmung zwischen den Dokumentdefinitionsfeldern und den SharePoint-Dokumentspalten herstellen. Die Dokumentdefinitionsfelder werden auf der linken Seite angezeigt. Für jedes zu exportierende Dokumentdefinitionsfeld (mit Ausnahme von Gruppen und Tabellen) können Sie eine freie SharePoint-Spalte auswählen.
  7. Legen Sie die Bildspeicheroptionen fest und klicken Sie auf Weiter>.
    • Geben Sie eine Dateinamenvorlage an (klicken Sie auf Bearbeiten…) und legen Sie fest, ob eine Datei bei identischen Namen überschrieben werden soll.
    • Legen Sie bei Bedarf die Felder fest, die beim Export nicht berücksichtigt werden sollen.

  8. Wenn Bilder gespeichert werden sollen, bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.

    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.

    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie als Speicherformat die Option PDF oder PDF/A auswählen, dann können Sie durchsuchbare PDF-Dateien erstellen, indem Sie die Option Durchsuchbares PDF erstellen wählen. Bei durchsuchbaren PDF erfolgt die Suche über den gesamten Text des Dokuments: Die Textebene wird sowohl aus den überprüften Feldwerten als auch aus Dokumentbereichen außerhalb dieser Felder gebildet. Für die Bereiche außerhalb der Felder wird eine Volltexterkennung durchgeführt. Legen Sie im Feld Suchtext fest, wo Text gesucht werden soll: auf allen Seiten, auf Bereichsseiten oder auf Anhangseiten.

      Die Erkennungssprache wird folgendermaßen definiert:

      • Für Felder wird die Erkennungssprache auf der Registerkarte Datentyp der Feldeigenschaften definiert.
      • Für die Volltexterkennung wird die Sprache der Dokumentdefinition verwendet.

      • Für Anhangseiten können Sie eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet. Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen... und fügen Sie die entsprechenden Sprachen hinzu. Standardmäßig wird die Sprache der Dokumentdefinition verwendet

  9. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Nachdem der Export abgeschlossen ist, werden die Dokumente in der angegebenen SharePoint-Bibliothek gespeichert. Jedes Dokument verfügt dann über eine entsprechende Spalte, die mit den Werten der festgelegten Felder ausgefüllt ist. Diese Werte können für Suchvorgänge und zur Dokumentindizierung verwendet werden.

Collapsed Konvertieren von Daten beim Export in Microsoft SharePoint2013

Wenn Sie in Microsoft SharePoint2013 exportieren, können Sie Daten in eines der folgenden Formate konvertieren:

  • Eine Textzeile;

  • Mehrere Textzeilen;

  • Nummer;

  • Währung;

  • Datum/Uhrzeit;

  • Ja/Nein.

Sie können den Datentyp der Zelle auch in ein kompatibles Format konvertieren, z. B.:

  • Datumsangaben in die Datentypen Datum/Uhrzeit oder Text konvertieren;
  • Markierungen in die Datentypen Ja/Nein oder Text konvertieren.

Experimentieren Sie mit den Datentypen! Nicht unterstützte Datentypen sind nicht verfügbar (ausgegraut).


Export mithilfe eines Skripts

So konfigurieren Sie den Export mithilfe eines Skripts:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Option Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen…
  3. Wählen Sie im Feld Typ den Wert Benutzerdefinierter Export (Skript) aus.

  4. Bestimmen Sie, ob der Export obligatorisch ist.

  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Wählen Sie die Sprache des Skripts aus.

  7. Geben Sie den Skriptcode im Fenster des Editors ein, das angezeigt wird, wenn Sie auf Skript bearbeiten… klicken. Klicken Sie dann auf Weiter>.

  8. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Weitere Informationen zu Skriptparametern finden Sie unter Exportskript.


Namenskriterien für Exportdateien

Dateinamen und -pfade werden während des Exports basierend auf den vom Benutzer angegebenen Kriterien automatisch generiert. Sie können sowohl die Namen von Datendateien als auch die Namen von Bilddateien konfigurieren.

Hinweis: Beim Exportieren in Dateien können Sie eine Vorlage für die Benennung der Datendateien angeben. Eine Vorlage für die Benennung der Bilddatei kann beim Exportieren in Dateien, eine ODBC-kompatible Datenbank, Sharepoint- und Bilddateien angegeben werden.

Die Erstellung von Dateinamen und -pfaden kann im Fenster Vorlage für Ziel und Dateinamen konfiguriert werden. Je nach ausgewähltem Exporttyp wird dieses Fenster entweder durch Klicken auf Bearbeiten… (links neben dem Feld mit der Dateinamenvorlage) oder auf Dateinamenoptionen… geöffnet.

Es gibt zwei Typen für die Bildung von Dateiexportvorlagen (wählen Sie im Feld Ansicht aus):

Collapsed Einfach

Bei diesem Typ können Sie einen zusätzlichen Pfad (außer beim Einrichten des Bildexports zusammen mit dem Export von Daten in eine Datei) und den signifikanten Teil des Dateinamens auswählen sowie ggf. Kennungen ergänzen.

Um den relativen Pfad festzulegen, wählen Sie Zusätzlichen Pfad verwenden und dann die Methode aus: Ähnlich der Struktur des Hot Folders (Quellpfad relativ zum Hot Folder) oder anhand des Stapelnamens (Stapelname).

Folgende Elemente können als signifikanter Teil des Dateinamens verwendet werden:

  • Quelldateiname, der folgendermaßen bestimmt wird:
    • Für die vom Ordner importierten Dateien werden die Namen der Originaldateien verwendet;
    • Bei mehreren Eingabedateien wird der Name der ersten Datei verwendet;
    • Für die in der Scanstation gescannten Dateien wird der Name der Scanquelle verwendet. Die Ausgabedatei jedoch wird mit dem Namen {Empty Value} erstellt;
    • Für die in der Projektkonfigurationsstation gescannten Dateien werden die Namen der temporären Dateien verwendet.
  • Name der Dokumentdefinition;
  • Festgelegter Dateiname - Kombination aus vom Benutzer festgelegten Zeichen.

Folgende Elemente können als zusätzliche Kennungen verwendet werden:

  • Dokumentkennung (wählen Sie Dokumentkennung zum Dateinamen hinzufügen);
  • Indexfeldwert (wählen Sie Indexfeld zum Dateinamen hinzufügen, und klicken Sie dann auf …, um das Indexfeld im Fenster Felder auswählen auszuwählen).
Collapsed Erweitert

Bei diesem Typ wird die Dateinamenvorlage als Textzeile ins Feld Dateinamenvorlage eingegeben. Die Vorlage kann einen permanenten Teil und Markierungen umfassen, die durch Angaben für spezifische Dateien ersetzt werden. Die Markierungen können über die Tastatur eingegeben und mit Hilfe der Schaltflächen Markierung hinzufügen… und Markierung löschen ergänzt oder gelöscht werden.

Damit die Dateinamen korrekt erzeugt werden können, stellen Sie sicher, dass die von Ihnen ausgewählten Dateinamenoptionen nicht zu leeren Dateinamen führen. Tritt dieser Fall ein, zeigt das Programm eine Warnmeldung an.

Hinweis: Bei dem für die Benennung von Dokumentbilddateien, die gemeinsam mit den Daten exportiert werden sollen, verwendeten Schema kann es sich um das gleiche Schema handeln wie das für die Benennung von Daten. Um das gleiche Schema zu verwenden, wählen Sie in der Registerkarte Bildexport-Einstellungen im Dialogfeld Vorlage für Ziel und Dateinamen die Option Genauso wie Daten.


Konfigurieren der Datendarstellung im Dokumentfenster

Nach der Erkennung werden die Daten im Dokumentfenster angezeigt. Die Daten werden standardmäßig der Reihe nach angeordnet. Die zugehörigen Beschriftungen entsprechen jeweils den Namen der Felder der Dokumentdefinitionen.

Sie können jedoch die Darstellung der Daten ändern, die Anordnung nach Bedarf anpassen oder Elemente umbenennen. Die Datendarstellung kann in der rechten unteren Ecke des Dokumentdefinitionseditors bearbeitet werden.

Sie können Felder verschieben, bearbeiten und umbenennen sowie andere Feldeigenschaften ändern. Wählen Sie im Kontextmenü die entsprechende Option aus, um wieder zur anfänglichen Felddarstellung zu wechseln.

Collapsed Feldbeschriftungen im Fenster Datenformular

Sie können die Beschriftung eines Felds im Datenformular ändern, ohne den Namen des Felds in der Dokumentstruktur zu verändern. Öffnen Sie zum Ändern einer Beschriftung das Dialogfeld für die Feldeigenschaften, klicken Sie auf die Registerkarte Allgemein und geben Sie einen neuen Namen in das Feld Überschrift ein. Dieser Name wird nun für die Beschriftung des Felds im Datenformular verwendet. Diese Funktion kann hilfreich sein bei der Anpassung von Spaltennamen, insbesondere bei FlexiLayouts, bei denen Sie die Namen der Felder nicht ändern können.

Collapsed Schriftarten und Schriftgrößen

Die Textschrift und -größe von Feldnamen und Werten erkannter Daten können auf der Registerkarte Datenformular des Dialogfelds Eigenschaften der Dokumentdefinition (Dokumentdefinition >Eigenschaften der Dokumentdefinition…). geändert werden. Sie können die Größe auch ändern, indem Sie mit der rechten Maustaste in das Fenster Datenformular klicken und die gewünschte Größe auswählen (Menü Textgröße im Kontextmenü).

Collapsed Hinzufügen von Text im Fenster Datenformular

Sie können Text hinzufügen, beispielsweise Erläuterungen. Klicken Sie dazu mit der rechten Maustaste in das Fenster Datenformular und wählen Sie im Kontextmenü die Option Text einfügen aus. Ersetzen Sie den Beschriftungstext durch den gewünschten Text.

Collapsed Anzeigen des Feldbereichs im Fenster Datenformular

Sie können das Fenster Datenformular so einstellen, dass bei der Überprüfung der Felder Feldbereiche des Bildes neben Feldern mit deren Daten angezeigt werden.

Diese Option steht für die folgenden Feldtypen zur Verfügung:

  • Text
  • Barcode
  • Feldgruppe

Klicken Sie mit der rechten Maustaste auf den Titel eines Feldes im Fenster Datenformular und wählen Sie aus dem Kontextmenü Feldbild hinzufügen.

Das Bild des Feldbereichs erscheint unter dem Feld. Seine Breite entspricht derjenigen des Feldes und ändert sich mit ihr. Wird das Feld gelöscht, wird auch das Bild des Feldbereichs gelöscht.

Collapsed Anzeigen von Feldern von Gruppen im Fenster Datenformular

Sie können festlegen, welche Felder von Feldgruppen im Fenster Datenformular angezeigt werden. Wählen Sie in der Registerkarte Felder des Fensters Dokumentstruktur eine Feldgruppe, öffnen Sie deren Dialogfeld Eigenschaften, wählen Sie die Registerkarte Format und in der Dropdownliste Gruppe minimieren eines der Elemente aus.

  • Nie - Die Gruppenansicht wird maximiert und der Überprüfungsoperator sieht alle Felder. Dies ist die Standardeinstellung.
  • Immer - Die Ansicht der Gruppe wird minimiert. Erweitern Sie die Ansicht, um alle Felder zu sehen.
  • Wenn keine Formatfehler vorhanden sind - Enthält die Gruppe in den Feldern keine Formatierungsfehler, wird sie minimiert.
  • Wenn alle Felder leer sind - Die Gruppe wird minimiert, wenn alle ihre Felder leer sind.

Treten in einem Dokument Formatierungsfehler auf, nachdem es geöffnet wurde, ändert sich die Gruppenansicht nicht.

Collapsed Reihenfolge der Registerkarten während der Überprüfung

Die standardmäßige Reihenfolge der Registerkarten verläuft von oben nach unten und von links nach rechts. Sie können die Reihenfolge der Registerkarten Ihren Anforderungen entsprechend anpassen.

Klicken Sie mit der rechten Maustaste auf das Fenster Datenformular und wählen Sie im Kontextmenü Reihenfolge der Registerkarten… Geben Sie im daraufhin geöffneten Dialogfeld die Reihenfolge der Felder an, indem Sie die Felder mit den Schaltflächen Nach oben und Nach unten bewegen. Das funktioniert nur, wenn die Option Von oben nach unten und von links nach rechts. deaktiviert ist. Klicken Sie auf die Schaltfläche Automatische Anordnung, um die standardmäßige Reihenfolge wieder herzustellen.


Eigenschaften der Dokumentdefinition

Die allgemeinen Eigenschaften einer Dokumentdefinition, z. B. Name, Sprache und Schreibstil, werden mithilfe des Dokumentdefinitionsassistenten festgelegt. Andere Eigenschaften werden automatisch konfiguriert.

Sie können die Eigenschaften einer Dokumentdefinition im entsprechenden Eigenschaftsdialogfeld anzeigen und ändern. Dieses Dialogfeld wird geöffnet, wenn Sie im Fenster des Dokumentdefinitionseditors die Menüoption Dokumentdefinition>Eigenschaften der Dokumentdefinition… auswählen.

Das Dialogfeld enthält sieben Registerkarten

Collapsed Registerkarte Allgemein

Auf dieser Registerkarte können Sie die Dokumentdefinition umbenennen und ihre Beschreibung eingeben oder bearbeiten. Über die Option Aktiviert wird die Dokumentdefinition in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen.

Collapsed Registerkarte Erkennung

Auf dieser Registerkarte können Sie die allgemeinen Eigenschaften zur Erkennung einer Dokumentdefinition ändern.

  • Sprache (Gebietsschema) – für eine korrekte Erkennung ist es wichtig, die verwendete Sprache einzugeben. Diese Eigenschaft legt die Eingabesprache und andere lokale Einstellungen fest, z. B. Datumsformat, Währung usw.
  • Schreibstil – der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, so dass im Programm der jeweils typische Schreibstil ausgewählt wird. Wählen Sie den Stil, der der Dokumentsprache entspricht. Befindet sich in der Liste kein solcher Stil, wählen Sie Andere.

  • Geben Sie den Texttyp an:

    ICR (Handschrift) – aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden.

    OCR (Druck) – aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis: Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

  • Sie können in der Gruppe Mögliche Seitenausrichtung eine oder mehrere Optionen aktivieren, so dass die Seite bei der automatischen Seitenausrichtung um 180° oder um 90° im Uhrzeigersinn bzw. gegen den Uhrzeigersinn gedreht wird.

  • Klicken Sie auf Erweiterte Optionen…, um die Korrektur linearer oder nicht linearer Bildverzerrungen festzulegen.

    Hinweis: Wählen Sie die Option Lineare Bildverzerrung korrigieren zur Bestimmung der Streckungs- und Verkleinerungsbeschränkungen für Bildbreite- und höhe. Für die Bildskalierung werden vorhandene Anker (schwarze Quadrate, Kreuze oder Ecken) sowie horizontale und vertikale Trennlinien verwendet.

  • Gesamten Text des Dokuments speichern - wählen Sie diese Option, wenn die erkannten Daten aus dem Cache beim Befüllen der Feldwerte während der Überprüfung verfügbar sein sollen.
Collapsed Registerkarte Zusammenstellung

Auf dieser Registerkarte können Zusammenstellungsregeln für mehrseitige Dokumente konfiguriert werden.

Im einfachsten Fall enthält die Dokumentdefinition einen Bereich, der genau einmal vorkommt. Wenn eine Dokumentdefinition mehrere Bereiche umfasst, wird auf dieser Registerkarte eine Liste mit den zugehörigen Namen angezeigt. Sie können die Anzahl der Wiederholungen jedes Bereichs angeben, indem Sie jeweils die Zahl in den Spalten Mindestanzahl und Maximalanzahl ändern.

  • Gleichwertigkeitszusammenstellungsregel für Schlüsselfelder verwenden – aktivieren Sie diese Option, wenn eine Überprüfung der Dokumentzusammenstellung anhand von Schlüsselfeldern durchgeführt werden soll. Wählen Sie dann in der Spalte Schlüsselfeld für jeden Bereich ein Schlüsselfeld aus. Bei der Eingabe von Dokumenten werden nur Dokumente mit übereinstimmenden Schlüsselfeldwerten in jedem Bereich als korrekt zusammengestellt eingestuft. Wenn die Werte nicht übereinstimmen, wird eine Zusammenstellungsfehlermeldung angezeigt.
  • Standardzusammenstellungsregeln verwenden - aktivieren Sie diese Option, wenn Sie eine Überprüfung der Dokumentzusammenstellung anhand der folgenden Standardregeln durchführen möchten:
    • Überprüfung der Bereichsreihenfolge deaktivieren - Aktivieren Sie diese Option, wenn Sie die Überprüfung der Reihenfolge der Bereiche im Dokument deaktivieren möchten (z. B. wenn die Reihenfolge der Bereiche keinen Einfluss auf die Dokumentzusammenstellung hat). Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.
    • Anhangseiten berücksichtigen - Aktivieren Sie diese Option, wenn Dokumente mit Anhängen verarbeitet werden sollen. Wenn die Verarbeitung von Dokumenten mit Anhängen aktiviert ist, können Sie auch die Option Anhänge gemäß vorgegebener Dokumentstruktur erkennen, ohne Analyse (schnell) auswählen, um eine schnellere Erkennung von Anhängen basierend auf der vorhandenen Dokumentstruktur zu ermöglichen.

      Hinweis: Die Option Anhänge gemäß vorgegebener Dokumentstruktur erkennen, ohne Analyse (schnell) gilt nur für Dokumente, die durch Trennung während des Importvorgangs oder durch Anwenden eines speziellen Flags in der API erstellt wurden. Solche Dokumente werden aus der Zusammenstellung ausgeschlossen.

  • Benutzerdefinierte Zusammenstellungsregeln verwenden - Aktivieren Sie diese Option, wenn Sie eine Überprüfung der Dokumentzusammenstellung anhand eines Dokumentzusammenstellungsskripts durchführen möchten. Ein benutzerdefiniertes Zusammenstellungsskript kann sowohl einzeln als auch gemeinsam mit den Standardzusammenstellungsregeln ausgeführt werden. Um das Skript zu bearbeiten, klicken Sie auf die Schaltfläche Zusammenstellungsskript bearbeiten…. Der Skripteditor wird geöffnet.

Weitere Informationen finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente, Zusammenstellen von Seiten in Dokumenten und Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Collapsed Registerkarte Regeln

Diese Registerkarte ist für die Arbeit mit Regeln in der Dokumentdefinition vorgesehen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.

Collapsed Registerkarte Exportziele

Auf dieser Registerkarte werden die aktuellen Exporteinstellungen der entsprechenden Dokumentdefinition angezeigt. Wenn Sie die Exporteinstellungen ändern möchten, klicken Sie auf die Schaltfläche Bearbeiten….

Collapsed Registerkarte Datenformular

Auf dieser Registerkarte können Sie die Schriftkontur und Schriftgröße zum Anzeigen erkannter Daten ändern.

Die Gruppe Einstellungen für Datentext enthält Schrifteinstellungen zum Anzeigen erkannter Werte.

Die Gruppe Einstellungen für Beschriftungstext enthält Einstellungen zum Anzeigen des erklärenden Texts (Feldnamen).

Weitere Informationen finden Sie unter Konfigurieren der Datendarstellung im Dokumentfenster.

Collapsed Registerkarte Datensätze

Auf dieser Registerkarte können Sie benutzerdefinierte Datensätze erstellen und bearbeiten.

Collapsed Registerkarte Event-Handler

Auf dieser Registerkarte können Sie Event-Handler für Dokumente des gegenwärtigen Typs erstellen.

Weitere Informationen finden Sie unter Event-Handler.

Collapsed Registerkarte .Net-Referenzen

Auf dieser Registerkarte können Sie externe Assemblys hinzufügen, die in Skripten und globalen Modulen verwendet werden können. Es können sowohl Standard- als auch kompilierte Benutzerassemblys verwendet werden. Um eine Assembly hinzuzufügen, klicken Sie auf Hinzufügen….Im daraufhin angezeigten Dialogfeld wählen Sie den Typ: Standardname für Assembly oder Angehängte Datei. Je nach ausgewähltem Typ wählen Sie entweder den Standardnamen der Assembly oder suchen Sie nach der Assemblydatei.

Ausführliche Informationen finden Sie unter Externe Assemblys.


Eigenschaften eines Dokumentdefinitionsbereichs

Sie können die Eigenschaften eines Dokumentdefinitionsbereichs im entsprechenden Eigenschaftsdialogfeld anzeigen und ändern. Wählen Sie dazu im Kontextmenü des Bereichs die Option Eigenschaften… aus.

Das Dialogfeld enthält drei Registerkarten:

Collapsed Registerkarte Allgemein

Auf dieser Registerkarte können Sie den Namen eines Dokumentbereichs ändern, die Beschreibung eingeben oder bearbeiten sowie die Mindest- oder Maximalanzahl der Bereichswiederholungen im Dokument eingeben oder ändern. Über die Option Aktiviert wird die Abschnitts-Dokumentdefinition in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen. Ausführliche Informationen zu mehrseitigen Dokumenten und zum Verwenden von Vorlagenbereichen finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente.

Collapsed Registerkarte FlexiLayout

Wenn einem Bereich ein FlexiLayout zugewiesen wurde, werden auf dieser Registerkarte Name, Version und Kommentar angezeigt. Sie können ein FlexiLayout anfügen, indem Sie auf die Schaltfläche Laden…klicken, und entfernen, indem Sie auf die Schaltfläche Entladen klicken.

Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Collapsed Registerkarte Bilder

Auf dieser Registerkarte werden die Parameter für die Seitenbilder eines Bereichs angezeigt. Folgende Parameter sind verfügbar: Größe, Auflösung, Druckgröße und Farbmodus.

Collapsed Registerkarte Regeln

Auf dieser Registerkarte können Sie Vorgänge mithilfe von Regeln für Vorlagen durchführen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.


Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare

ABBYY FormDesigner ist ein benutzerfreundliches Tool, das speziell zum Erstellen maschinenlesbarer Formulare entwickelt wurde. Mit ABBYY FormDesigner können Sie nicht nur Formulare erstellen, die allen Anforderungen für die automatische Dokumentverarbeitung entsprechen, das Tool enthält darüber hinaus eine nahezu vollständige Dokumentdefinition zum Verarbeiten dieser Formulare in ABBYY FlexiCapture.

So erstellen Sie eine Dokumentdefinition zum Verarbeiten von Formularen, die mit ABBYY FormDesigner erstellt wurden:

In ABBYY FormDesigner:

  1. Erstellen Sie ein Formular.

  2. Veröffentlichen Sie das Formular.

  3. Exportieren Sie es in das XML-Formulardefinitionsformat. Sie erhalten eine Datei mit der Dateierweiterung „xfd“.

Ausführliche Informationen zum Erstellen, Veröffentlichen und Exportieren von Formularen finden Sie in den Hilfethemen und im Benutzerhandbuch für ABBYY FormDesigner.

In ABBYY FlexiCapture:

  1. Wählen Sie im Hauptmenü die Menüoption Projekt > Dokumentdefinitionen… aus;
  2. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Importieren…;
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Datei zum Importieren öffnen in der Dropdownliste Dateityp die Option XML-Formulardefinitionsdateien (*.xfd) aus und geben den Pfad der XFD-Datei an;
  4. Der Name der neuen Dokumentdefinition wird dann in der Liste des Dialogfelds Dokumentdefinitionen angezeigt.

Nach dem Öffnen einer importierten Dokumentdefinition, die Sie bearbeiten möchten, sind die Felder und statischen Elemente im Bild bereits gekennzeichnet. Sie müssen lediglich die Feldeigenschaften bearbeiten und den Export konfigurieren.


Erstellen von Dokumentdefinitionen für mehrseitige Dokumente

Mit ABBYY FlexiCapture können Sie Dokumentdefinitionen für mehrseitige Dokumente erstellen. Eine Dokumentdefinition kann aus einer beliebigen Anzahl von Bereichen bestehen, die jeweils eine oder mehrere Seiten umfassen können. Bei Dokumentdefinitionen für mehrseitige Dokumente müssen Sie die Reihenfolge der Bereiche, die Anzahl der Bereiche und die Regeln angeben, anhand derer Seiten zu Dokumenten zusammengestellt werden.

Im Assistenten wird eine neue einfache Dokumentdefinition ohne Bereiche erstellt. Dieser Dokumentdefinition können Seiten und Bereiche hinzugefügt werden.

Hinzufügen von Seiten

Sie können dieser Dokumentdefinition Seiten hinzufügen. Beim Hinzufügen einer Seite wird das entsprechende Bild zur Bildregion im Fenster des Dokumentdefinitionseditors hinzugefügt. Die in diesem Bereich erstellten Felder sind dagegen in der Liste der allgemeinen Felder aufgeführt. Das Dokument umfasst dann nur einen Bereich, obwohl es mehrere Seiten enthalten kann.

Sie sollten einem Bereich Seiten hinzufügen, wenn das Dokument Bereichsblöcke enthält, die sich über mehrere Seiten oder über Tabellen auf mehreren Seiten erstrecken oder auf mehreren Seiten mehrfach vorkommen. Das gleiche Verfahren wird zum Laden eines FlexiLayouts für mehrseitige Dokumente angewendet (siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente). Alle Felder in einem FlexiLayout müssen ein und demselben Bereich einer Dokumentdefinition zugewiesen sein.

Wenn Sie einem Bereich eine Seite hinzufügen möchten, wählen Sie im Dokumentdefinitionseditor die Menüoption Dokumentdefinition > Seiten hinzufügen… oder im Kontextmenü des Bilds die Option Seiten hinzufügen…. Laden Sie dann das Bild einer neuen unausgefüllten Seite, und wählen Sie Objekttypen aus, die in der Seite automatisch markiert werden sollen.

Hinzufügen von Bereichen

Eine andere Möglichkeit besteht darin, der Dokumentdefinition Bereiche hinzuzufügen. Im einfachsten Fall enthält ein Bereich genau eine Seite. Sie können festlegen, ob Feldgruppen auf Seiten voneinander unabhängig sind. Dieses Verfahren ist anschaulicher: In der Dokumentstruktur wird angezeigt, welchem Bereich die Felder zugewiesen sind. Sie können zudem eine benutzerdefinierte Struktur der Dokumentzusammenstellung konfigurieren. Angenommen, Ihr Dokument enthält drei Seitentypen, wobei Seiten des ersten und dritten Typs nur einmal auftreten können, Seiten des zweiten Typs jedoch 2 bis 5-mal. Sie müssen dann drei Bereiche – für jeden Seitentyp einen – erstellen und festlegen, in welcher Reihenfolge die Bereiche innerhalb des Dokuments angeordnet sind und wie oft sie auftreten können.

Ein komplexeres Beispiel ist eine Dokumentdefinition mit mehreren Bereichen, von denen einige mehrere Seiten umfassen. Dabei handelt es sich beispielsweise um eine Dokumentdefinition mit statischen Bereichen und einem flexiblen mehrseitigen Bereich oder um eine Dokumentdefinition für Dokumente mit einem doppelseitigen Bogen, der mehrfach vorkommen kann. Beispiel: Sie möchten eine Dokumentdefinition für ein Dokument mit einer Titelseite (Seite A) und einer bestimmten Anzahl doppelseitiger Blätter (Seitenfolge BCBC…) erstellen. Sie erstellen dann den Bereich A mit der Seite A sowie den Bereich BC mit den zwei Seiten B und C. Die Dokumentstruktur wird folgendermaßen definiert: Bereich A wird einmal wiederholt, gefolgt von Bereich BC, der 3- bis 7-mal wiederholt wird.

Wenn Sie einen neuen Bereich hinzufügen möchten, wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoption Dokumentdefinition > Dokumentbereich hinzufügen…aus. Daraufhin wird der Assistent zum Erstellen von Bereichen geöffnet, in dem Sie alle erforderlichen Parameter festlegen können. Befolgen Sie die Anweisungen des Assistenten, und führen Sie folgende Schritte aus:

  • Geben Sie den Namen des Bereichs an.

  • Laden Sie das Bild einer unausgefüllten Seite (Scannen oder Laden aus Datei) oder eine FlexiLayout-Datei.

  • Wählen Sie Objekttypen aus, die automatisch markiert werden sollen.

Damit wird im Fenster "Dokumentstruktur" ein neuer Bereich mit den zugehörigen Feldern angezeigt.

Zusätzliche Einstellungen

Bei einer Dokumentdefinition mit mehreren Bereichen können Sie neben der Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche die Überprüfung von Schlüsselfeldern festlegen. Dazu müssen Sie die Schlüsselfelder in jedem Dokumentbereich identifizieren. Die entsprechenden Werte müssen in verschiedenen Bereichen identisch sein. Um das Schlüsselfeld mehreren Seiten des gleichen Bereichs hinzuzufügen, erstellen Sie ein Mehrfach-Schlüsselfeld, dessen Instanzen sich auf verschiedenen Seiten befinden. Ein Beispiel für ein Schlüsselfeld ist der Nachname einer Person, die ein Dokument ausfüllt, der auf jeder Seite eingetragen werden muss, oder eine bestimmte Identifikationsnummer.

Beim Verarbeiten eines Stapels wird im Programm eine Folge von Seiten in Dokumenten zusammengestellt. Dabei werden die Zusammenstellungsregeln überprüft. Zudem wird eine Überprüfung der Schlüsselfeldwerte durchgeführt, sofern die entsprechende Option dafür ausgewählt ist. Wenn Schlüsselfelder auf den Seiten eines Dokuments nicht übereinstimmen, wird eine Fehlermeldung angezeigt. Die Schlüsselfelder stimmen manchmal nicht überein, da die Seiten eines Dokuments beim Scannen in falscher Reihenfolge angeordnet wurden. Nach dem Ändern der Reihenfolge der Seiten sind die Zusammenstellungsregeln dann wieder erfüllt. Siehe Zusammenstellen von Seiten in Dokumenten.

Sie können auch einen Bereich aus einer anderen Dokumentdefinition im Projekt importieren. Hierfür klicken Sie im Hauptmenü auf Dokumentdefinition > Dokumentbereich importieren und wählen den Bereich im Dialogfeld Zu importierende Bereichsdefinition auswählen aus.

Hinweis: Beim Importieren von Bereichen werden freigegebene Skriptmodule nicht importiert. Daraus kann folgen, dass die in einen neuen Bereich geschriebenen Skriptregeln ungültig sind oder nicht einwandfrei funktionieren.

Anzeige und Bearbeitung der Ergebnisse

Wenn Sie beim Erstellen einer Dokumentdefinition die entsprechende Dokumentstruktur anzeigen möchten, klicken Sie im rechten Bereich des Dokumentdefinitionseditors im Fenster Dokumentstruktur auf die Registerkarte Seiten. Hier wird die Dokumentstruktur in der Gliederungsansicht angezeigt. Auf dieser Registerkarte können Sie die Anzahl der Bereichswiederholungen in einem Dokument ändern (geben Sie dazu im Feld rechts neben dem Namen des Bereichs einen neuen Wert ein, d. h. eine Anzahl oder ein Intervall), Seiten eines Anhangs anfügen, die Reihenfolge der Seiten im Bereich ändern und Seiten per Drag&Drop zwischen verschiedenen Bereichen verschieben.

Für Seiten, die in einem Bereich wiederholt werden können, wählen Sie in den Seiteneigenschaften die Option Kann in Bereich wiederholt werdenaus. Um das Dialogfeld Seiteneigenschaften aufzurufen, wählen Sie im Kontextmenü der Seite die Option Eigenschaften... oder drücken Alt+Eingabetaste.

Collapsed Fenster Dokumentstruktur anzeigen

Dokumentzusammenstellung

Über die Menüoption Dokumentdefinition > Eigenschaften der Dokumentdefinition… im Fenster des Dokumentdefinitionseditors können Sie die Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche sowie die Zusammenstellungsregel festlegen. Geben Sie auf der Registerkarte Zusammenstellung für jeden Bereich im Dokument die Mindest- und Höchstanzahl der Wiederholungen an (Standardwert ist 1). Wenn die Werte der Schlüsselfelder überprüft werden sollen, aktivieren Sie die Option Gleichwertigkeitszusammenstellungsregel für Schlüsselfelder verwenden und wählen in jedem Bereich ein Schlüsselfeld aus.

Wählen Sie die zu verwendenden Zusammenstellungsregeln aus. Es können sowohl die Standardzusammenstellungsregeln als auch benutzerdefinierte Zusammenstellungsregeln verwendet werden.

Mithilfe der Standardzusammenstellungsregeln können Sie die Überprüfung der Reihenfolge von Bereichen deaktivieren und Dokumente mit Anhangseiten zusammenstellen.

Die Deaktivierung der Überprüfung der Reihenfolge von Bereichen (Option Überprüfung der Bereichsreihenfolge deaktivieren) gilt beispielsweise, wenn sich die Reihenfolge der Bereiche nicht auf die Dokumentzusammenstellung auswirkt). Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.

Um Dokumente mit Anhängen zusammenzustellen, wählen Sie die Option Anhangseiten berücksichtigen aus. Um Anhangseiten basierend auf der vorhandenen Dokumentstruktur zu erkennen, aktivieren Sie die entsprechende Option.

Um Dokumente mithilfe des Dokumentzusammenstellungsskripts zusammenzustellen, aktivieren Sie die Option Benutzerdefinierte Zusammenstellungsregeln verwenden. Um das Skript zu bearbeiten, klicken Sie auf die Schaltfläche Zusammenstellungsskript bearbeiten….

Collapsed Registerkarte Zusammenstellung anzeigen


Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente

Für Rechnungen, Zahlungsaufträge und ähnliche Dokumente können Sie keine Dokumentdefinition mit statischen Feldern erstellen. Die Position, Größe und Anzahl der Felder ist möglicherweise nicht immer identisch, so dass eine statische Dokumentdefinition nicht auf alle Dokumente angewendet werden kann. In diesen Dokumenten wird nach einer Vorerkennung der gesamten Seite nach Feldern gesucht und anhand von Schlüsselwörtern und der relativen Position der Felder ein FlexiLayout erstellt. Ein spezielles Programmmodul, ABBYY FlexiLayout Studio, wurde für die Festlegung von FlexiLayouts konzipiert (dieses Modul ist im Lieferumfang von ABBYY FlexiCapture enthalten). Ausführliche Anweisungen zum Erstellen eines FlexiLayouts finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.

FlexiLayouts werden in eine AFL-Datei exportiert und dann in ABBYY FlexiCapture geladen. Sie können ein FlexiLayout für die gesamte Dokumentdefinition oder einen ihrer Bereiche verwenden. FlexiLayouts können mehrseitig sein.

Anfügen eines FlexiLayouts

Ein FlexiLayout kann beim Erstellen einer Dokumentdefinition angefügt werden. Fügen Sie dazu im zweiten Schritt im Dokumentdefinitionsassistenten das Dokumentbild hinzu, aktivieren Sie dann die Option FlexiLayout laden und geben Sie den Pfad der AFL-Datei ein, die das FlexiLayout enthält.

Über das Fenster des Dokumentdefinitionseditors können Sie ein FlexiLayout im Dialogfeld des Dokumentdefinitionsbereichs anfügen.

  1. Wählen Sie einen Dokumentbereich aus. (Wenn das Dokument nur einen Bereich umfasst, klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten und wählen Sie den Namen des Bereichs aus.) Klicken Sie mit der rechten Maustaste und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Klicken Sie auf die Registerkarte FlexiLayout.
  3. Klicken Sie auf Laden….

  4. Wählen Sie die entsprechende AFL-Datei aus.

Nach dem Anfügen eines FlexiLayouts wird im Bild das geometrische Layout der Felder angezeigt. Sie müssen dann die Feldeigenschaften wie bei einer statischen Dokumentdefinition festlegen. Geben Sie die Erkennungs-, Überprüfungs- und Exporteigenschaften an, und legen Sie die gewünschten Regeln fest.

FlexiLayouts aktualisieren

Um in der Dokumentdefinition verwendete FlexiLayouts zu aktualisieren, wählen Sie Extras > FlexiLayouts aktualisieren…. Geben Sie im daraufhin geöffneten Dialogfeld den Pfad des FlexiLayouts an und klicken Sie auf Aktualisieren.

Hinweis: Beim Import eines FlexiLayouts mit Textdateien, die mögliche Feldwerte enthalten, werden diese Dateien entlang der beim Erstellen des FlexiLayouts definierten relativen Pfade positioniert. Die relativen Pfade stehen in Bezug zur Projektdatei. Um diese Dateien zu bearbeiten, speichern Sie das Projekt lokal (wählen Sie Projekt>Projekt exportieren…), bearbeiten Sie die Dateien und aktualisieren Sie das Projekt auf dem Server (wählen Sie Projekt>Projekt aktualisieren…).


Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen

Mit ABBYY FlexiCapture können Sie Dokumentdefinitionen für Dokumente mit Anhängen erstellen. Anhänge sind zusätzliche Seiten, die jedem Formular beigefügt werden können. Diesen Seiten wird keine Dokumentdefinition zugeordnet. Sie werden jedoch bei der Dokumentzusammenstellung berücksichtigt. Ein Darlehensantrag (statisches Formular) wird beispielsweise zusammen mit einem Einkommensnachweis ohne feste Struktur übermittelt. Dieser Einkommensnachweis kann als Anhang verarbeitet werden.

So erstellen Sie eine Dokumentdefinition für ein Dokument mit Anhang:

Erste Methode:

  1. Klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten (erster Teil des Dokumentdefinitionseditors).
  2. Aktivieren Sie die Option Anhangseiten im Dokument berücksichtigen.

  3. Geben Sie die Anzahl oder den Bereich der Anhangseiten in dem Feld ein, das rechts neben dem Namen des Bereichs angezeigt wird.

Collapsed Fenster Dokumentstruktur anzeigen

Alternative Methode für das Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen:
  1. Öffnen Sie das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition > Eigenschaften der Dokumentdefinition… im Fenster des Dokumentdefinitionseditors).
  2. Klicken Sie auf die Registerkarte Zusammenstellung.
  3. Aktivieren Sie die Option Anhangseiten berücksichtigen. Die Zeile Anhangseiten wird in der Liste der Bereiche angezeigt.
  4. Geben Sie die Mindest- und Höchstanzahl für die Anhangseiten an.
Collapsed Dialogfeld anzeigen

Wenn Sie den Text eines Anhangs speichern möchten, müssen Sie beim Konfigurieren des Datenexports Optionen zum Speichern von Bildern angeben (im Dialogfeld Exporteinstellungen). Wenn Sie Durchsuchbares PDF zum Speichern der Bilder auswählen, wird der Text erkannt und in einer durchsuchbaren PDF-Datei gespeichert.


Verarbeiten nicht strukturierter Dokumente

Mithilfe von ABBYY FlexiCapture können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Anhänge. Nicht strukturierte Dokumente mit Text oder Bildern, die durch leere Blätter oder Seiten mit Barcodes getrennt sind, werden verarbeitet und in durchsuchbare PDF-Dateien oder Grafikdateien exportiert.

Die Verarbeitung dieser Dokumente umfasst normalerweise das Konvertieren der Dokumente in elektronische Formate sowie das Durchführen einer Suche nach Schlüsselfeldwerten.

Wenn möglich, sollte die Suche nach Schlüsselfeldern (z. B. einer Vertragsnummer) in diesen Dokumenten anhand eines in ABBYY FlexiLayout Studio erstellten FlexiLayouts durchgeführt werden. Siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Wenn die automatische Suche nach Schlüsselfeldern nicht möglich ist, können Sie die Werte manuell eingeben. Erstellen Sie dazu eine Dokumentdefinition mit einem Feld (oder gegebenenfalls mit mehreren Feldern), und aktivieren Sie in den Erkennungseigenschaften dieses Felds die Option Keine Erkennung (Manueller Eingabeblock – wird manuell eingegeben) Beim Durchführen des Überprüfungsvorgangs können Sie dann die Schlüsselfeldwerte manuell eingeben.

Zum Aktivieren der Datenspeicherung müssen Sie den Export konfigurieren.Sie können Schlüsselfeldwerte in Dateien oder Datenbanken exportieren und Dokumentbilder in einem benutzerfreundlichen Format speichern. Sie können Dokumentbilder in Grafikdateien oder durchsuchbaren PDF-Dateien speichern.

Geben Sie Acht beim Zusammenstellen von Seiten zu Dokumenten. Bei nicht strukturierten Dokumenten kann fest definiert werden, zu welchem Dokument eine bestimmte Seite gehört. Für die automatische Zusammenstellung nicht strukturierter Dokumente wird empfohlen, Dokumente durch leere Blätter oder Seiten mit Barcodes zu trennen. Beim Hinzufügen von Bildern zu einem Stapel (durch Scannen, Hinzufügen aus einer Datei oder Erstellen eines Importprofils) müssen Sie dann die Option Für Bilder getrennt durch aktivieren und in der Dropdownliste den Wert Leere Seiten oder Seiten mit Barcode auswählen, je nachdem welche Seiten als Trennseiten verwendet werden sollen. Die Seiten werden automatisch in Dokumenten zusammengestellt. Sie werden bis zur nächsten Trennseite dem aktuellen Dokument hinzugefügt. Ausführliche Informationen hierzu finden Sie unter Hinzufügen von Seitenbildern.


Bearbeitung und Veröffentlichung einer Dokumentdefinition

Im Fenster des Dokumentdefinitionseditors können Dokumentdefinitionen erstellt und bearbeitet werden. In diesem Fenster können Sie das Layout von Feldern und statischen Elementen ändern, die zugehörigen Eigenschaften, Regeln oder Exporteinstellungen bearbeiten usw.

Damit sich Änderungen nicht auf die Arbeit anderer Projektmitarbeiter auswirken, können Sie eine lokale Kopie der Dokumentdefinition bearbeiten, während die zuletzt veröffentlichte Version zur Erkennung verwendet wird. In diesem Modus können Dokumentdefinitionen lokal geändert und getestet werden, während Operatoren erkannte Dokumente weiterhin mit der alten Version überprüfen und exportieren können, auch wenn die Dokumentdefinition erheblich geändert oder gelöscht wurde. Andere Benutzer können an der bearbeiteten Dokumentdefinition keine Änderungen vornehmen. Nach der Bearbeitung der Dokumentdefinition können Sie sie entweder veröffentlichen – die neue Version steht dann zur Dokumenterkennung zur Verfügung – oder alle Änderungen rückgängig machen.

Zum Bearbeiten einer Dokumentdefinition gehen Sie wie folgt vor:

  1. Wählen Sie im Hauptmenü die Menüoption Projekt>Dokumentdefinitionen… aus.

  2. Wählen Sie die zu bearbeitende Dokumentdefinition aus.

  3. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Bearbeiten…, um die Bearbeitung der Dokumentdefinition zu starten. Eine lokale Version der Dokumentdefinition wird auf Ihren Computer kopiert. Andere Benutzer können diese Dokumentdefinition nun nicht mehr bearbeiten.

  4. Nehmen Sie im Dokumentdefinitionseditor die gewünschten Änderungen vor. Speichern Sie die Dokumentdefinition.

  5. Testen Sie die Dokumentdefinition anhand einiger Bilder. Zur Anpassung von Dokumentdefinitionen können Sie Teststapel einsetzen, bei denen die lokale Version der Dokumentdefinition verwendet wird.
  6. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Veröffentlichen, um die Dokumentdefinition zu veröffentlichen. Nach der Veröffentlichung wird die neue Version der Dokumentdefinition zum Erkennen der Dokumente in den Arbeitsstapeln verwendet. Die Dokumentdefinition kann nun von anderen Administratoren bearbeitet werden. Wenn Sie die ursprüngliche Dokumentdefinition wiederherstellen möchten, klicken Sie auf Änderungen rückgängig machen.
  7. Die Dokumentdefinitionen werden in der Reihenfolge angewandt, in der sie im Fenster Dokumentdefinitionen aufgelistet werden. Ändern Sie ggfs. die Reihenfolge der Dokumentdefinitionen.
  8. Sie können die Zuordnung eines FlexiLayouts beschleunigen, indem Sie die Option Erstes akzeptables FlexiLayout verwenden auswählen. Das Programm benutzt dann das erste geeignete FlexiLayout. Andernfalls testet das Programm alle FlexiLayouts und wählt dann das am besten übereinstimmende aus.

Neue Dokumentdefinitionen werden unmittelbar nach der Veröffentlichung zur Erkennung und weiteren Dokumentverarbeitung eingesetzt. Für diejenigen Dokumente, deren Verarbeitung zum Zeitpunkt der Veröffentlichung bereits begonnen hat, wird jedoch noch die vorherige Version der Dokumentdefinition benutzt. Sie können die Dokumentdefinition für die gerade verarbeiteten Dokumente aktualisieren, indem Sie Extras>Auf neueste Version aktualisieren wählen. Je nachdem, welche Änderungen an einer Dokumentdefinition vorgenommen wurden, werden Sie gefragt, ob die Dokumente neu erkannt (bei geänderten Erkennungsparametern), die Regeln neu überprüft (bei Regeländerungen) oder die Dokumente neu exportiert (wenn nur die Exporteinstellungen geändert wurden) werden sollen. Bei folgenden Änderungen wird eine Meldung angezeigt, mit der Sie aufgefordert werden, die Dokumente neu zu erkennen:

  • die Struktur der Felder wurde geändert (Felder wurden hinzugefügt/entfernt, die Schachtelungstiefe der Felder wurde geändert) oder
  • Feldbereiche wurden geändert oder
  • Erkennungseigenschaften wurden geändert (inklusive der Einstellungen des Datentyps, mit Ausnahme der Einstellungen für Formatüberprüfung und Autokorrektur).


Testen von Dokumentdefinitionen

Vor der Masseneingabe von Dokumenten müssen die Dokumentdefinitionen getestet werden. Beim Testen werden Dokumente zu Teststapeln hinzugefügt, da für diese Stapel die lokale Version der Dokumentdefinition verwendet wird. Diese Stapel sind im Hauptfenster des Programms über Ansicht>Teststapel verfügbar. Sie können auf die Teststapel auch vom Fenster des Dokumentdefinitionseditors aus zugreifen, indem Sie Stapel>Zu Teststapel wechseln….

Wichtig! Ein Teststapel kann nur von demjenigen Benutzer verwendet werden, der ihn erstellt hat. Gegebenenfalls kann ein Arbeitsstapel als Teststapel verwendet werden. Er dient dann als Bildquelle für den Teststapel.

Eine Dokumentdefinition kann direkt im Dokumentdefinitionseditor mit dem Bild getestet werden, das zum Erstellen der Dokumentdefinition verwendet wurde. Wählen Sie zum Starten des Tests Testen>Test ausführen. Wie bei einer Dokumentverarbeitung wird das Datenformular angezeigt und es werden Formatfehler, nicht eindeutige Zeichen und Regelfehler ausgegeben.

Sie können das Menü Testen > Ansicht verwenden, um die Anordnung der Fenster zu verändern, und das Menü Testen > Überprüfung, um die einzelnen Elemente der Überprüfung, nicht eindeutige Zeichen und Regelfehler durchzugehen. Klicken Sie auf die Schaltfläche Test beenden, oder wählen Sie Testen>Test beenden, um den Test zu beenden.

Wichtig! Im Testmodus führt eine Veränderung der Feldränder nicht dazu, dass das Programm das Feld erneut erkennt. Im Gegensatz dazu ist dies bei einer Änderung der Feldränder im Dokumentfenster der Fall.

Um Ihre Dokumentdefinition mit anderen Bildern zu testen, wählen Sie einen Teststapel aus (Sie können dies tun, indem Sie im Dokumentdefinitionseditor Stapel>Zu Teststapel wechseln…wählen). Bevor das Dialogfeld zur Stapelauswahl angezeigt wird, prüft das Programm die aktuelle Dokumentdefinition auf Fehler. Wenn die Dokumentdefinition fehlerfrei ist, wird sie gespeichert und das Dialogfeld zur Stapelauswahl wird angezeigt. Wenn Sie in diesem Dialogfeld einen Stapel auswählen, wird das Programmfenster aktiviert und wechselt automatisch zum neu gewählten Stapel.

Wichtig! Bei Bedarf können Dokumente zwischen Stapeln kopiert oder verschoben werden. Bei diesen Vorgängen werden alle Informationen über das Dokument wie z. B. die zugeordnete Dokumentdefinition und erkannte Daten beibehalten. Um Dokumente zu kopieren oder zu verschieben (z. B. von einem Arbeits- zu einem Teststapel für Debuggingzwecke), wählen Sie diese beim Anzeigen des Stapelinhalts aus der Liste, drücken Sie Strg+C (zum Kopieren) oder Strg+X (zum Verschieben), klicken Sie auf die Schaltfläche [image] oder [image] in der Symbolleiste oder wahlweise auf das Element Kopieren oder Ausschneiden im Menüpunkt Bearbeiten. Öffnen Sie dann den Stapel, in den die Dokumente kopiert oder verschoben werden sollen, und drücken Sie Strg+V oder klicken Sie auf die Schaltfläche [image] in der Symbolleiste oder auf das Element Bearbeiten>Einfügen im Hauptmenü.

Es wird empfohlen, jede Dokumentdefinition mit mindestens 20 Dokumentbildern zu überprüfen (wenn Dokumente von Hand ausgefüllt werden, empfiehlt es sich, Dokumente mit verschiedenen Handschriften zu testen).

Beim Testen muss Folgendes überprüft werden:

  1. Ist eine ausreichende Anzahl markierter Anker und Kennungen für die zielgerichtete Anwendung einer Dokumentdefinition auf ein Bild vorhanden?
  2. Wurden die Feldeigenschaften korrekt konfiguriert?
  3. Wurden die Regeln korrekt konfiguriert?
  4. Wurde der Export korrekt konfiguriert?

Beim Testen müssen Sie die gesamten Vorgänge durchführen, die beim Verarbeiten von Dokumenten anfallen.

Wenn beim Testen Regelfehler, falsche Feldwerte o. Ä. erkannt werden, müssen Sie die Dokumentdefinition bearbeiten , um die Fehler zu korrigieren.

Sie können die Dokumentdefinition erst nach Beheben aller Fehler veröffentlichen und dann mit der Masseneingabe von Dokumenten beginnen.

Arbeiten mit einem konfigurierten Projekt


Lokalisierung einer Dokumentdefinition

Eine lokalisierte Dokumentdefinition ist eine Dokumentdefinition, die von der Sprache, in der sie entwickelt wurde, in eine andere Sprache übersetzt wurde. ABBYY FlexiCapture Benutzer wählen während der Installation die Sprache der Benutzeroberfläche. Steht eine lokalisierte Dokumentdefinition für die ausgewählte Sprache zur Verfügung, wird diese Version verwendet.

Lokalisierung bedeutet die Übersetzung folgender Inhalte:

  • Feldnamen, Schaltflächen und Text im Datenformular
  • Skriptnachrichten der Benutzer (zum Beispiel Nachrichten, die nach Skriptregeln angezeigt werden, Exporteinstellungen und Event-Handler)

Beim Bearbeiten einer Dokumentdefinition arbeitet der Benutzer, der die Projektarbeit einrichtet, mit Standardwerten, die sich während der Lokalisierung nicht ändern (Informationen dazu finden Sie im Abschnitt „Die Lokalisierungsdatei“ in diesem Artikel). Wenn ein Benutzer jedoch den Dokumenteditor öffnet, wird eine Dokumentdefinition in der Sprache der Benutzeroberfläche des Dokumenteditors verwendet.

Der Lokalisierungsprozess

Dokumentdefinitionen werden wie folgt lokalisiert:

  1. Die Kennungen der Zeichenketten, die lokalisiert werden müssen, werden in eine Textdatei exportiert.
  2. In der Textdatei ist für jede Zeichenkettenkennung ein lokalisierter Text enthalten.
  3. Der lokalisierte Text und die entsprechende Kennungen (gemeinsam als die "Lokalisierung" bezeichnet) werden aus der Textdatei in die Dokumentdefinition exportiert.

Hinweis: Die Lokalisierung wird nur in eine Dokumentdefinition exportiert, die Zeichenketten und die bei der Lokalisierung verwendeten Kennungen enthält.

Die Lokalisierungsdatei

Die Lokalisierungsdatei ist eine TXT-Datei, die eine Liste von lokalisierten Zeichenketten enthält. Diese Datei wird automatisch erstellt, wenn ein Benutzer im Dokumentdefinitionseditor auf Dokumentdefinition> Lokalisierung > Text für Lokalisierung exportieren... klickt. Die Zeichenketten sind nach dem Typ des Benutzeroberflächenelements, in dem sie erscheinen (Feldnamen, Name der Dokumentdefinition, Shell-Nachrichten und Skriptnachrichten) und dann alphabetisch nach dem Namen sortiert.

Beispiel für eine Zeichenkette in einer Lokalisierungsdatei, die noch nicht übersetzt wurde:

BANK_CODE ,"Bank code"

In diesem Beispiel ist BANK_CODE die Kennung der Zeichenkette. Kein anderes Feld der Dokumentdefinition darf diese Kennung haben. Die Kennung kann auf zwei Arten automatisch erstellt werden: entweder auf der Grundlage des Feldnamens oder mithilfe der Vorlage FC_<number of the field>.

Nach der Kennung folgt ein Komma und nach dem Komma in Anführungszeichen die Zeichenkette, die dem Benutzer angezeigt wird ("Bank code"). Diese Zeichenkette ist der Teil, der während der Lokalisierung übersetzt wird.

Wurde die Zeichenkette übersetzt und in die Dokumentdefinition zurück importiert, werden nach der lokalisierten Zeichenkette automatisch ein Kommentartrennzeichen (zwei Schrägstriche), gefolgt von der ursprüngliche Zeichenkette ("Bank Code"), hinzugefügt. Die ursprüngliche Zeichenkette ist die Standardzeichenkette, die Benutzer sehen, welche die Dokumentdefinition bearbeiten.

Diese Zeichenkette sieht nach der Lokalisierung in die deutsche Sprache wie folgt aus:

BANK_CODE ,"Bankleitzahl" // "Bank Code"

Syntax der Lokalisierungsdatei

  • Die Kennung einer Zeichenkette und die Zeichenkette selbst sind durch ein Komma getrennt (,)
  • Vor den Kommentaren steht ein Kommentartrennzeichen (//)
  • Die Zeichenketten stehen in Anführungszeichen ("Zeichenkette")
  • Vor den Anführungszeichen in der Zeichenkette muss ein umgekehrter Schrägstrich stehen (\")
  • Vor umgekehrten Schrägstrichen in der Zeichenkette muss ein umgekehrter Schrägstrich stehen (\\)
  • Zeilenumbrüche werden mit der Zeichenfolge Neue Zeile \n gekennzeichnet.

Verwendung einer Lokalisierungsdatei zur Lokalisierung einer Dokumentdefinition

Erstellen einer Lokalisierungsdatei

  1. Klicken Sie im Dokumenteditor auf Dokumentdefinition> Lokalisierung > Text für Lokalisierung exportieren....
  2. Geben Sie den Pfad zum Ordner, in dem die Datei gespeichert werden soll, und den Dateinamen ein. Wählen Sie in der Dropdownliste Sprache die Originalsprache der Dokumentdefinition aus.

    Bearbeiten einer Lokalisierungsdatei

  3. Öffnen Sie die Lokalisierungsdatei in einem Texteditor und übersetzen Sie die Zeichenketten.
  4. Speichern Sie die Datei. Achten Sie darauf, dass sie in Unicode codiert ist.

    Importieren einer Lokalisierungsdatei in eine Dokumentdefinition

  5. Klicken Sie im Dokumenteditor auf Dokumentdefinition> Lokalisierung > Lokalisierten Text importieren....
  6. Geben Sie im daraufhin angezeigten Dialogfeld den Pfad zur Lokalisierungsdatei an. Wählen Sie in der Dropdownliste Sprache die Sprache der Lokalisierungsdatei.
  7. Speichern Sie die Dokumentdefinition.

Nachdem eine Lokalisierungsdatei importiert wurde, enthält das Datenformular des Dokumentdefinitionseditors weiterhin (nicht lokalisierten) Standardtext. Der lokalisierte Text erscheint nur im Dokumenteditor. Benutzer der Projektkonfigurationsstation sehen den lokalisierten Text nur, wenn sie die Dokumentdefinitionen testen, und nur, wenn die Sprache der Lokalisierung als Sprache der Benutzeroberfläche vonABBYY FlexiCapture gewählt wurde.

Ist eine lokalisierte Zeichenkette länger als die ursprüngliche Zeichenkette, werden die Felder des Datenformulars so verschoben, dass die längere Zeichenketten ausreichend Platz hat.

Lokalisierung von Nachrichten aus Benutzerskripten

Um Nachrichten von Benutzerskripten (Skriptregeln und Event-Handler) zu lokalisieren, erstellen Sie eine Kennung für jede Nachricht, geben den lokalisierten Text für jede Nachricht ein und erstellen im Skriptcode Verweise auf die Kennungen der Nachrichten.

Um Nachrichten von Benutzerskripten in eine Lokalisierungsdatei zu exportieren, klicken Sie auf Dokumentdefinition> Lokalisierung > Text für Lokalisierung exportieren.... Sie können die Nachrichten dann übersetzen und die Lokalisierungsdatei in die Dokumentdefinition importieren, wie im Abschnitt „Importieren einer Lokalisierungsdatei in eine Dokumentdefinition“ dieses Artikels beschrieben.

Die lokalisierten Benutzerskriptnachrichten werden angezeigt, wenn in ABBYY FlexiCapture die entsprechende Sprache gewählt wird.

Klicken Sie im Dokumentdefinitionseditor auf Dokumentdefinition> Lokalisierung > Bearbeiten….

Es öffnet sich ein Dialogfeld mit einer Liste aller möglichen Fehlermeldungen. Klicken Sie zur Bearbeitung von Nachrichten auf die Schaltflächen Hinzufügen…, Bearbeiten… und Löschen. Wenn Sie im daraufhin geöffneten Dialogfeld auf Hinzufügen… oder Bearbeiten… klicken, können Sie den Namen der Nachricht und ihren Standardtext ändern.

Mit dem Objekt FCTools.LocalizedStrings rufen Sie eine Nachricht aus einem Benutzerskript auf. Dieses Objekt verwendet die Methode IProperties.

Das folgende Beispiel für einen Code gibt eine lokalisierte Nachricht mit der Kennung MY_ MESSAGE_1 zurück:

FCTools.LocalizedStrings.Get("MY _MESSAGE_1")


Klassifikator

Klassifikatoren sind mit ABBYY FlexiLayout Studio erstellte Projekte, die der vorbereitenden Analyse einzelner Seiten und deren Klassifizierung mit einem bestimmten Typ dienen. Seiten können z.B. basierend auf einem FlexiLayout oder alternativem Layout klassifiziert werden. Nachdem ein Klassifikator mit ABBYY FlexiLayout Studio erstellt wurde, kann er von ABBYY FlexiCapture zur Klassifikation von Dokumenten auf Projekt- oder Stapeltypebene verwendet werden.

So fügen Sie auf Projektebene ein Klassifikationsprojekt hinzu:

  1. Öffnen Sie das Projekt.

  2. Wählen Sie im Hauptfenster aus dem Menü Projekt die Option Projekteigenschaften…. Das Dialogfeld Projekteigenschaften öffnet sich.
  3. Klicken Sie auf die Registerkarte Erkennung und dann auf Laden….

  4. Wählen Sie die *.CFL-Datei, die den Klassifikator enthält.

Hinweis: Falls bei der Erstellung eines Stapels als Typ Standard gewählt wurde, werden die in den Projekteigenschaften gewählten Einstellungen zur Verarbeitung verwendet.

So fügen Sie auf Stapeltypebene ein Klassifikationsprojekt hinzu:

  1. Öffnen Sie das Dialogfeld Stapeltypen durch Auswahl von Projejt>Stapeltypen…
  2. Wählen Sie den Stapeltyp aus der Liste und klicken Sie auf Bearbeiten…. Das Dialogfeld Stapeltypeigenschaften öffnet sich.
  3. Klicken Sie auf die Registerkarte Erkennung und dann im Abschnitt Klassifikator auf Laden….
  4. Wählen Sie die *.CFL-Datei, die den Klassifikator enthält.

Klassifikatoren können wie folgt eingesetzt werden:

  • Zur Beschleunigung der Auswahl der Dokumentdefinition. Bei Verwendung eines Klassifikators muss das Programm nicht alle verfügbaren Dokumentendefinitionen untersuchen, sondern kann auf Grundlage der Klassifikationsmerkmale die beste auswählen. Die Suchreihenfolge wird von demjenigen Benutzer festgelegt, der die Klassifikationsmerkmale auswählt und einen Klassifikationsbaum erstellt. Der Zugewinn an Geschwindigkeit ist vor allem bei umfangreichen Projekten mit vielen Dokumentdefinitionen deutlich.
  • Zur Verteilung der Klassifikationsmerkmale im Klassifikationsbaum. Auf der obersten Ebene können Sie z.B. anhand eines Dokumentabschnitts, der den Namen eines bestimmten Unternehmens enthält, von diesem Unternehmen verschickte Dokumente auswählen. Auf der nächsten Ebene können Dokumente nach ihrem Titel oder der Anzahl von Trennzeichen auf einer bestimmten Seite klassifiziert werden.
  • Zur Verwaltung der FlexiLayouts von Drittanbietern. Von Drittanbietern entwickelte FlexiLayouts entsprechen manchmal nicht vollständig deren Dokumenten. In diesem Fall können Sie mit einem Klassifikator Abhilfe schaffen, ohne den Entwickler kontaktieren zu müssen.
  • Zur Beschleunigung von Projekten mit mehrsprachigen Dokumentdefinitionen. Bei Verwendung eines Klassifikators wird die Vorerkennung der Dokumente nur zweimal durchgeführt: Bei der Klassifizierung der Dokumente und bei der Anwendung der gewählten Dokumentdefinition. Ansonsten muss die Vorerkennung für jede Sprache der Dokumentdefinitionen im Projekt durchgeführt werden.

Ausführliche Informationen zu Klassifikatoren finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.


Bildimportprofile

Die Dokumentverarbeitung beginnt mit dem Hinzufügen neuer Bilder. Dabei kann es sich um Papierdokumente handeln, die gescannt werden müssen, oder um vorhandene elektronische Bilder. Sie können die Vorgänge zum Hinzufügen von Bildern automatisieren, wenn Bilder regelmäßig aus derselben Quelle entnommen werden. Zur Automatisierung des Vorgangs müssen Sie in der Administratorstation ein Bildimportprofil. Sie können darüber hinaus auch die Verarbeitung eingehender Bilder und das regelmäßige Hinzufügen von Bildern im Hintergrund konfigurieren. Nach dem Festlegen der erforderlichen Einstellungen können die Bilder durch Klicken auf nur eine Schaltfläche gescannt oder aus einer zuvor definierten Quelle importiert und verarbeitet werden (z. B. Entfernen von Störungen). Sie können bei Bedarf die Quelle für den Bildimport oder die entsprechenden Einstellungen ändern.

Wenn sich die Importquellen häufig ändern, können Sie mehrere Importprofile erstellen und zwischen diesen Profilen wechseln, so dass Sie nicht jedes Mal die Einstellungen für die Importquelle ändern müssen.

Erstellen eines Importprofils

Wählen Sie zum Hinzufügen eines Importprofils im Hauptfenster des Programms die Menüoption Projekt>Bildimportprofile… aus. Im daraufhin geöffneten Dialogfeld können Sie Importprofile erstellen, bearbeiten, löschen und kopieren.

Sie können neue Importprofile mithilfe des Assistenten für Importprofile erstellen. Der Assistent kann durch Klicken auf Neu… im Dialogfeld Bildimportprofile ausgeführt werden. Wählen Sie im ersten Schritt des Assistenten eine Importquelle aus, z. B. einen Scanner oder Hot Folder.

Collapsed Erstellen eines Importprofils mit einem Scanner
  1. Wählen Sie als Importquelle die Option Scanner aus.

    Wichtig! Der Scanner muss angeschlossen sein. Anweisungen zum ordnungsgemäßen Anschluss des Scanners finden Sie in der zugehörigen Dokumentation. Vergewissern Sie sich, dass alle mit dem Scanner gelieferten Softwarekomponenten installiert sind.

  2. Im zweiten Schritt können Sie die Optionen zum Scannen und Verarbeiten der Bilder festlegen:
    • Stil des Dialogfelds 'Scannereinstellungen' – wählen Sie die Verbindung zwischen Programm und Scanner aus:
      • FlexiCapture-Scannereinstellungen:In diesem Fall wird das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture zum Konfigurieren der Scanoptionen verwendet. Zum Konfigurieren der Scanoptionen klicken Sie auf die Schaltfläche Einstellungen…. Wenn Sie die Option Scannereinstellungen vor dem Scannen anzeigen auswählen, wird bei der Auswahl des entsprechenden Importprofils vor dem Scannen das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture angezeigt.
      • Scanoptionen: Das Dialogfeld des entsprechenden Scannertreibers wird zum Konfigurieren der Scanoptionen verwendet. In diesem Fall können Sie beim Erstellen eines Importprofils die Scanoptionen nicht ändern. Das Dialogfeld für die Einstellungen des Scanners wird jedoch jedes Mal angezeigt, bevor Sie mit dem Scannen von Bildern beginnen.

    • Geben Sie an, ob ein Bild oder mehrere Bilder in einem Durchgang gescannt werden sollen.

  3. Im nächsten Schritt können Sie Optionen zum Hinzufügen von Bildern zu Dokumenten sowie Optionen für die Bildverarbeitung festlegen. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.

  4. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.

Collapsed Erstellen eines Importprofils mit einem Hot Folder
  1. Wählen Sie als Importquelle die Option Hot Folder aus. Wählen Sie den Typ des Hot Folder: Lokaler Ordner oder LAN-Ordner, POP3-Server, MAPI (Postfach) oder FTP-Server. Geben Sie den Pfad zum Hot Folder an, indem Sie auf die Schaltfläche Durchsuchen… klicken oder Login und Passwort durch Anklicken von Einstellungen….

    Wichtig! Zum Hinzufügen von Bildern zum Hot Folder müssen Sie über Lese- und Schreibzugriff für diesen Ordner verfügen.

    Collapsed Einrichtung des Imports über MAPI (Postfach)

    • Das E-Mail-Konto muss auf dem Computer konfiguriert sein.

    • Der Importvorgang (Benutzerstation oder Verarbeitungsstation) muss unter demselben Benutzerkonto ausgeführt werden, zu dem auch das Postfach gehört.
      Hinweis: Microsoft Outlook muss unter diesem Benutzerkonto auf diesem Computer mindestens einmal gestartet werden, bevor das Importprofil eingerichtet wird.

      Hinweis: Microsoft Outlook 2010 64-Bit wird nicht unterstützt.

    • Um ein verfügbares Postfach auszuwählen, klicken Sie auf Durchsuchen…
    Collapsed Zur Einrichtung des Imports über POP3-Server
    • Geben Sie die Adresse des POP3-E-Mail-Servers ein.
    • Klicken Sie auf Einstellungen… und geben Sie in dem sich öffnenden Dialogfeld Benutzername und Passwort für die Anmeldung ein. Wählen Sie SSL verwenden, um die SSL-Technologie (995) zum Schutz der gesendeten Daten zu verwenden.

    Hinweis: Wenn alle Einstellungen korrekt sind, aber ABBYY FlexiCapture keine Nachrichten vom POP3-E-Mail-Server abrufen kann, sollte überprüft werden, ob die Verbindung zum E-Mail-Server von einer Firewall blockiert wird.

  2. Legen Sie im zweiten Schritt die Optionen zum Laden von Bildern fest:

    • Hot Folder alle – Aktivieren Sie diese Option, und geben Sie ein Zeitintervall ein, in dem automatisch überprüft wird, ob der Hot Folder neue Bilder enthält.

      Hinweis: Um den Bildimport aus Hot Foldern zu starten, aktivieren Sie die Hot Folder für das gegebene Projekt über den Monitor des Verarbeitungsservers.

    • Aktivieren Sie unter Stapeleinstellungen eine der Optionen zum Festlegen des Stapels, dem neue Bilder hinzugefügt werden.

      • Bilder zum aktuellen Stapel hinzufügen – Aktivieren Sie diese Option, um Bilder aus dem Hot Folder zum aktuellen Stapel hinzuzufügen.
      • Bilder zum angegebenen Stapel hinzufügen – Aktivieren Sie diese Option, und wählen Sie in der Dropdownliste den Stapel aus, dem Bilder hinzugefügt werden sollen.
      • Neue Stapel für importierte Bilder automatisch erstellen – enable this option to create batches for new images automatically. Mit dieser Option wird/werden bei jeder Markierung des Hot Folders (Hot Folder Hot Folder alle) ein oder mehrere Stapel erstellt, und Bilder aus dem Hot Folder werden diesen Stapeln entsprechend der nachfolgend festgelegten Regel hinzugefügt.
        Bestimmen Sie im Feld Stapeltypden Typ des Stapels, der automatisch erstellt werden soll. Klicken Sie gegebenenfalls auf Registrierungsparameter…), um die Registrierungsparameter des Stapels zu bestimmen und die Stapelpriorität im Feld Priorität zu ändern.

        • Hinweis: Werden Importaufgaben über den Verarbeitungsserver verarbeitet, muss die Option Neue Stapel für importierte Bilder automatisch erstellen ausgewählt werden. Die Optionen Bilder zum aktuellen Stapel hinzufügen und Bilder zum angegebenen Stapel hinzufügen können nur dann verwendet werden, wenn die Bilder in die Projektkonfigurationsstation importiert werden oder wenn die Einzelplatzversion benutzt wird.

    • E-Mail zum Stapel hinzufügen (nur für Hot Folder РОР3 Server)
      Aktivieren Sie diese Option, wenn Sie eine Datei mit Nachrichteninhalt an den von Ihnen erstellten Stapel anhängen möchten. Sie können diese Datei speichern und mit einem E-Mail-Client öffnen. Ausführliche Informationen finden Sie unter Anhänge.
    • Wählen Sie in der Dropdownliste Anzahl der hinzuzufügenden Dateien einen Wert aus, um die Anzahl der Dateien festzulegen, die dem angegebenen oder neu erstellten Stapel hinzugefügt werden sollen.
      • Entsprechend Beschreibungsdatei – Dateien werden entsprechend der Beschreibung hinzugefügt. Klicken Sie auf die Schaltfläche Einstellungen…, um den Namen und den Typ der Beschreibungsdatei anzugeben. Ausführliche Informationen finden Sie unter Beschreibungsdatei.
      • Alle Dateien - Alle Dateien aus dem Hot Folder werden hinzugefügt.
      • Aus dem Unterverzeichnis - Fügt Dateien aus den Unterverzeichnissen hinzu, deren Namen mit der angegebenen Vorlage übereinstimmen. Klicken Sie zur Bestimmung eines Namensvorlage auf Einstellungen….

        Hinweis: Ein Stern * steht für eine Zeichenfolge, ein Fragezeichen ? steht für ein einzelnes Zeichen.

        Hinweis: Benennen Sie ein Unterverzeichnis entsprechend des festgelegten Namensschemas nur um, nachdem alle erforderlichen Dateien hineinkopiert wurden. Es kann sonst ein Zugriffskonflikt mit der Datei auftreten.

      • Mehrere Dateien– Mehrere Dateien werden hinzugefügt. Klicken Sie zum Angeben der Anzahl der Dateien auf die Schaltfläche Einstellungen…, und geben Sie die Anzahl oder den Wertebereich ein.
      • Hinweis: Wenn Sie eine bestimmte Anzahl von Dateien, z. B. 5, angeben und sich im Hot Folder nur 4 Dateien befinden, werden diese Dateien nicht importiert. Wenn Sie einen Bereich festlegen, z. B. 1-5, werden die restlichen 5 Dateien importiert.
      • Einzelne Datei – Es wird nur eine Datei hinzugefügt.
      • Angehängt an Nachricht – alle der Nachricht angehängten Dateien werden hinzugefügt.
      Hinweis: Die neuen Bilder werden dem Stapel in aufsteigender Reihenfolge des Dateinamens hinzugefügt.
    • Wählen Sie Bild als Foto behandeln, wenn das Profil eher für das Importieren von Fotos und nicht für gescannte Bilder verwendet werden soll. .
  3. Im nächsten Schritt können Sie Optionen zum Hinzufügen von Bildern zu Dokumenten sowie Optionen für die Bildverarbeitung festlegen. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung. Sie können auch die für den Stapeltyp festgelegten Einstellungen für die Dokumenttrennung und die Bildverarbeitung verwenden. Wählen Sie dazu die Option Bildverarbeitungsoptionen aus Stapeltyp verwenden.

  4. Im vierten Schritt werden Sie im Assistenten für Importprofile aufgefordert, Optionen zur Handhabung der Dateien im Hot Folder nach dem Import anzugeben: Erfolgreich importierte Bilder können gelöscht oder in einen bestimmten Ordner verschoben werden. Bilder, die mit Fehlern verarbeitet wurden, können im Hot Folder verbleiben oder ebenfalls in einen bestimmten Ordner verschoben werden. Wenn Bilder verschoben werden sollen, geben Sie die entsprechenden Ordner an.

    Hinweis: Es wird empfohlen, dass die mit Fehlern verarbeiteten Bilder im Hot Folder verbleiben sollten, wenn:

    • die Bilder manuell importiert werden. Während des Auto-Exports kann eine beschädigte Datei im Hot Folder die Verarbeitung anderer Dateien im Ordner verhindern;

    • die Verarbeitung des Hot Folder aufgrund eines instabilen Netzwerks öfters unterbrochen wird.

  5. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.

Sie können auch im Dialogfeld Importprofil auswählen Bildimportprofile bearbeiten. Es erscheint, wenn Sie aus dem Hauptmenü Datei > Bilder importieren… auswählen.

Hinzufügen von Seitenbildern


Beschreibungsdatei

Eine Beschreibungsdatei ist eine Hilfsdatei, in der definiert ist, auf welche Weise ein Stapel beim Hinzufügen von Bildern aus einem Hot Folder gebildet wird. Je nach Format der Beschreibungsdatei wird der Stapel aus unterschiedlichen Dateigruppen gebildet.

Im Programm werden die folgenden Beschreibungsdateitypen verwendet:

  1. Captiva QuickScan
    Alle in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt. Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.
  2. Capture Software for Kodak
    Die Bilddateien im Ordner des Kodak-Stapels werden nach Dateinamen sortiert in aufsteigender Reihenfolge zum Stapel hinzugefügt. Der Pfad zu dem Ordner, von dem aus die Bilder hinzugefügt werden, wird im Schlüssel Stapel des Bereichs Eigenschaften in der *.ini-Beschreibungsdatei festgelegt:

    [Properties]
    BatchPath=\\computer\HotFolder\PathInHF"

    Auch die Bilder aus den Unterordnern werden dem Stapel hinzugefügt.

  3. Leere Datei
    Diese Datei dient als Merker und weist darauf hin, dass ein neuer Stapel zu erstellen ist. Der Inhalt der Datei ist irrelevant, nur der Name ist von Bedeutung. Bilder werden in alphabetischer Reihenfolge aus dem Hot Folder hinzugefügt. Wenn eine Datei mit einem Namen entsprechend dem im Feld Dateiname angegebenen Schema gefunden wird, erstellt das System einen neuen Stapel. Wenn z.B. das Schema *.dat angegeben wurde und der Hot Folder die folgenden Dateien enthält:
    Contract1.jpg
    Contract2.jpg
    Contract3.dat
    Contract4.jpg
    Contract5.jpg
    Contract6.dat
    wird für die Dateien Contract1.jpg und Contract2.jpg ein Stapel erstellt (wenn Contract3.dat gefunden wird), und ein weiterer Stapel wird für die Dateien Contract4.jpg und Contract5.jpg erstellt (wenn Contract6.dat gefunden wird).
  4. XML-Datei
    Hierbei handelt es sich um eine XML-Datei mit dokumentierter Struktur. Eine XML-Datei wird verwendet, wenn die anderen drei Dateitypen nicht verwendet werden können, jedoch eine benutzerdefinierte Beschreibungsdatei generiert werden kann. Die in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt.

    Ein XML-Datei muss das Stammelement Batch mit den folgenden untergeordneten Elementen enthalten: RegistrationParams, Documents und Images. Jedes Element Images muss wiederum Elemente vom Typ Image enthalten, deren Anzahl der Anzahl der Seiten im zu erstellenden Stapel entspricht.

    Das Element Batch enthält die folgenden Tags:

    • Priority - die Priorität des Stapels: Lowest, Low, Normal, High oder Highest (niedrigste, niedrig, normal, hoch oder höchste). Diese Tags können entfallen. Wird die Priorität nicht festgelegt, so wird die im Importprofil festgelegte Priorität verwendet.
    • Name - a desired batch name.
    • TypeName - der Name des Stapeltyps. Gilt, wenn der Standard-Stapeltyp im Importprofil festgelegt wird.
      Wird der Ausgabeordner der Scanstation als Hot Folder verwendet, muss der im Tag angegebene Name mit dem Namen des Stapeltyps in der Scanstation übereinstimmen. In diesem Fall wird ein Stapel des angegebenen Typs erstellt.

    • Attachments - Anhänge des Stapels.

    • SourceID - die Kennung der Stapelquelle als Zeichenfolge.

    • Description - eine Beschreibung des Stapels.

    • RegistrationParams - die Liste der Registrierungsparameter des Stapels. Die Registrierungsparameter aus der Beschreibungsdatei werden den im Importprofil angegebenen Registrierungsparametern hinzugefügt.

    • Attachments - Anhänge des Dokuments.

    • Documents - die Liste der Dokumente (ausgeschlossen von der automatischen Dokumentzusammenstellung).

    • Images - die Liste der separaten Seiten (eingeschlossen in die automatische Zusammenstellung).

    Das Element Document enthält die folgenden Tags:

    • Index (ein zwingend erforderliches Attribut) - der Index des Dokuments innerhalb der Dokumente des Stapels, durchnummeriert ab Null.

    • Priority - die Priorität des Dokuments: Lowest, Low, Normal, High oder Highest (niedrigste, niedrig, normal, hoch oder höchste). Diese Tags können entfallen.

    • Name - der Name des Dokuments.

    • Barcode - der Barcodewert.

    • RegistrationParams - die Liste der Registrierungsparameter des Dokuments.

    • Images - die Liste der Dokumentseiten.

    Das Element Parameter (untergeordnetes Element des Elements RegistrationParams) enthält die folgenden Tags:

    • Name (ein Attribut) - der Name des Registrierungsparameters.
    • Value - der Wert des Registrierungsparameters

    Das Element Image enthält die folgenden Tags:

    • Index (ein zwingend erforderliches Attribut) - der Index der Seite (das entsprechende Dokument für Seiten des Elements Images) innerhalb der Dokumentseiten (die Dokumente des Stapels), durchnummeriert ab Null.
    • PageIndex (ein Attribut) - die Seitenzahl, beginnend mit Null innerhalb einer mehrseitigen Importdatei.
    • SourcePath (ein Attribut) - der Pfad zu einem Ordner mit Quellbildern.
    • SourceFile (ein Attribut) - die Quelldatei mit dem Seitenbild (ein Pfad, relativ zu SourcePath).
    • SourceFilePageIndex (ein Attribut) - die Seitenzahl, beginnend mit Null innerhalb einer mehrseitigen Quelldatei.
    • SourceDetails (ein Attribut) - eine Beschreibung der Quelle (der Name des Scanners).
    • Attachments - Anhänge der Seite.
    • Value - der Pfad zur Importdatei, angegeben für eine Seite relativ zum Hot Folder.

    Das Element Attachment enthält die folgenden Tags:

    • Name - der Name des Anhangs. Ist der Name nicht angegeben, wird der Name der Quelldatei verwendet.
    • Value - der Pfad des Anhangs. Es können Pfade in Bezug zum Stammverzeichnis des Hot Folder festgelegt werden.

    Wir empfehlen, das Scanprogramm so einzurichten, dass gescannte Bilder direkt im Hot Folder oder in den zugehörigen Unterordnern der nächsten Ebene abgelegt werden. Beim Erstellen eines Stapels werden diesem alle in den Elementen vom Typ Image der entsprechenden Beschreibungsdatei aufgeführten Bilder hinzugefügt. Die Bilder werden in der Reihenfolge hinzugefügt, in der sie in der Beschreibungsdatei angeordnet sind.

    Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.


Optionen zur Bildvorverarbeitung

Wenn neue Bilder zu einem Stapel hinzugefügt werden, führt das Programm eine Bildvorverarbeitung durch: Die Bilder werden in Dokumente unterteilt, Störungen werden beseitigt, sie werden gedreht usw.

Die Optionen zur Bildvorverarbeitung können Sie in der Registerkarte Bildvorverarbeitung auswählen. Die Optionen für die Bildvorverarbeitung können für folgende Programmbereiche ausgewählt werden:

  1. Ein Projekt. In diesem Fall werden die ausgewählten Optionen standardmäßig verwendet, wenn neue Bilder manuell zu Projektstapeln hinzugefügt werden. Wählen Sie im Hauptfenster Projekt>Projekteigenschaften… und klicken Sie auf die Registerkarte Bildvorverarbeitung.
  2. Ein Importprofil. Diese Optionen werden verwendet, wenn das entsprechende Importprofil zum Hinzufügen neuer Bilder verwendet wird. Wählen Sie beim Erstellen eines neuen Importprofils die gewünschten Optionen zur Bildvorverarbeitung in der Phase Bildvorverarbeitung.
  3. Manuell hinzugefügte Bilder. Klicken Sie beim aus einer Datei auf die Schaltfläche Einstellungen zur Bildvorverarbeitung… im Dialogfeld Bilder laden.

    Hinweis: Wenn Bilder manuell gescannt werden, findet keine Bildvorverarbeitung statt. Bilder durchlaufen nur dann die Bildvorverarbeitung, wenn zum Hinzufügen ein Importprofil verwendet wird.

  4. Ein Stapeltyp. In diesem Fall werden die ausgewählten Optionen für die Verarbeitung der Bilder aus Stapeln des vorgegebenen Typs verwendet. Wählen Sie bei der Erstellung eines Stapeltyps die Vorverarbeitungsoptionen auf der Registerkarte Bildvorverarbeitung. Die für einen Stapeltyp festgelegten Optionen gelten auch für Bilder:

    • die von der Scanstation oder der Web-Scanstation erhalten werden, wenn sie nicht in der entsprechenden Station zu einem Dokument zusammengestellt wurden. Die im Abschnitt Bildverarbeitung festgelegten Optionen gelten für die erhaltenen Bilder unabhängig davon, ob sie zu Dokumenten zusammengestellt wurden oder nicht;

    • die durch Webservices-API Methoden hinzufügt werden (wenn das Kennzeichen ExcludeFromAutomaticAssembling auf false gesetzt ist). Detaillierte Informationen finden Sie in der Hilfedatei der Webservices-API;

    • die aus einem Hot Folder hinzugefügt werden (wenn die Option Bildverarbeitungsoptionen aus Stapeltyp verwendenaktiviert ist). Weitere Informationen finden Sie unter Bildimportprofile;

    • die aus einer Datei hinzugefügt manuell werden. In diesem Fall werden die für den Stapeltyp festgelegten Optionen standardmäßig verwendet.

Die Benutzer können aus den folgenden Vorverarbeitungsoptionen beliebig auswählen:

  • Optionen, welche die Vorgehensweise beim Hinzufügen von Bildern zu Dokumenten festlegen:
    • Automatisch, wenn Dokumentdefinition angewandt wird – Wählen Sie diese Option, wenn Bilder bei der Zuordnung (bei der Erkennung) in Dokumente aufgeteilt werden sollen.In diesem Fall werden Bilder nicht, sobald sie hinzugefügt werden, sofort in Dokumente getrennt, und Dokumente werden erst zusammengestellt, nachdem die Seiten analysiert und anhand der in der entsprechenden Dokumentdefinition beschriebenen Struktur erkannt wurden. Ausführliche Informationen hierzu finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente und Zusammenstellen von Seiten zu Dokumenten.
    • Für jede Bilddatei - Ist diese Option ausgewählt, wird für jede Datei ein neues Dokument erstellt (Bilddateien können mehrere Seiten umfassen).
    • Für Bilder getrennt durch - Beim Erreichen einer Trennseite wird ein neues Dokument erstellt. Um leere Seiten als Trennzeichen zu verwenden, wählen Sie in der Dropdownliste die Option Leere Seiten aus. Im sich daraufhin geöffneten Dialogfeld Erkennung leerer Seiten können Sie die Parameter festlegen, anhand derer leere Seiten erkannt werden. Wenn Sie Seiten mit Barcodes als Trennzeichen verwenden möchten, wählen Sie in der Dropdownliste die Option Seiten mit Barcode aus. Sie können zusätzliche Parameter festlegen, indem Sie auf die Schaltfläche Einstellungen… klicken. Wenn die Trennseiten nicht zum Stapel hinzugefügt werden sollen, wählen Sie Trennseiten löschen. Wenn diese Option nicht aktiviert ist, werden die Trennseiten dem Stapel hinzugefügt und in den einzelnen Dokumenten jeweils als erste Seite verwendet.

    Hinweis: Sie müssen die Seiten zwischen Dokumenten nicht mithilfe von Trennseiten aufteilen. Trennseiten müssen nur verwendet werden, wenn es aufgrund der Darstellung einer Seite nicht möglich ist zu ermitteln, ob sie zum vorherigen oder nächsten Dokument gehört. Dies ist beispielsweise der Fall, wenn ein Dokument mehrere identische Seiten und der Stapel mehrere solcher Dokumente enthält.

    Hinweis: Für in der Scanstation gescannte oder hinzugefügte Dokumente sind die Optionen des Stapels und der Dokumenttrennung in den Einstellungen für den Stapeltyp der Scanstation festgelegt.

  • Konfigurieren Sie die Optionen für die Bildverarbeitung:
    • Störungen in Bildern entfernen – Verzerrungen in Bildern werden entfernt;
    • Farbige und graue Bilder in Schwarz-Weiß konvertieren – Die Bilder werden in Schwarzweiß-Bilder umgewandelt;
    • Bilder drehen um – Die Bilder werden in die angegebene Richtung gedreht.

  • Entzerrungsoptionen Standardmäßig sind diese Optionen aktiviert, und das Programm entzerrt neu hinzugefügte Bilder auf der Grundlage von schwarzen Quadraten und/oder vertikalen und horizontalen Trennzeichen und Text. Es ist nicht zu empfehlen, die Entzerrungsoptionen auszuschalten, solange kein Fehler bei der Entzerrung auftritt (z. B., wenn das Programm einen Stempel oder eine Grafik als Trennzeichen interpretiert und versucht, das Bild auf der Grundlage dieser falschen Daten zu entzerren).

    • Zur Korrektur von Verzerrungen schwarze Trennzeichen verwenden– Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von Trennlinien entzerrt;
    • Zur Korrektur von Verzerrungen schwarze Quadrate verwenden – Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von schwarzen Quadraten entzerrt;
    • Zur Korrektur von Verzerrungen Text verwenden - Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von Text im Bild entzerrt.


Einstellungen für die Erkennung leerer Seiten

You are here: Konfigurieren des Programms > Einstellungen für die Erkennung leerer Seiten

Erkennung leerer Seiten

In diesem Dialogfeld können die bei der Dokumenttrennung verwendeten Einstellungen für die Erkennung leerer Seiten bestimmt werden. Um dieses Dialogfeld zu öffnen, klicken Sie auf Einstellungen… , nachdem Sie in den Optionen Bildvorverarbeitung die Trennung nach leeren Seiten ausgewählt haben.

Option | Beschreibung
Ränder ignorieren, mm | Wählen Sie diese Option, um die Seite automatisch zuzuschneiden (oben, unten, links und rechts in Millimeter), nachdem bestimmt wurde, ob die Seite leer ist oder nicht. Nach dem Zuschneiden wird die resultierende Seite auf andere Parameter überprüft.
Schwarze Quadrate | Wählen Sie diese Option, wenn Seiten mit einer bestimmten Anzahl an schwarzen Quadraten (spezielle Elemente des Formularlayouts) als leer betrachtet werden sollen. Bestimmen Sie die maximale Anzahl der auf einer Seite erlaubten schwarzen Quadrate.
Textobjekte | Wählen Sie diese Option, wenn Seiten mit einer bestimmten Anzahl an Textobjekten als leer betrachtet werden sollen. Textobjekte beinhalten getrennte Textfragmente. Sie können diese Option z. B. bei Seiten mit Kopf- und Fußzeilen verwenden. Bestimmen Sie die maximale Anzahl der auf einer Seite erlaubten Textblöcke.
Barcodes | Wählen Sie diese Option, wenn Seiten mit einer bestimmten Anzahl an Barcodes als leer betrachtet werden sollen. Bestimmen Sie die maximale Anzahl der auf einer Seite erlaubten Barcodes.
Schwärzeanteil (%) | Wählen Sie diese Option, wenn Seiten mit einem bestimmten Prozentsatz an schwarzer Farbe als leer betrachtet werden sollen. Bestimmen Sie den maximalen Prozentsatz des auf einer Seite erlaubten Schwärzeanteils. Der Schwarz-Weiß-Grad wird nach der Bild-Binärumwandlung bestimmt.

Hinweis: Die Verwendung von Schwarze Quadrate als primäre Option wird nicht empfohlen, da beim Scannen von Dokumenten unerwünschte Punkte entstehen können. Die Anzahl der Textobjekte ist eine weitaus zuverlässigere Option, während die Beschränkung der Anzahl schwarzer Quadrate als zusätzliche Überprüfung eingesetzt werden kann.


Exporteinstellungen

You are here: Konfigurieren des Programms > Standardexporteinstellungen

Standardexporteinstellungen

Standardexporteinstellungen werden beim Exportieren von Daten in eine Datei oder Datenbank oder Bilder in Dateien ohne Verwendung von Dokumentdefinitionseinstellungen sowie für Dokumentdefinitionen verwendet, in denen keine Exporteinstellungen konfiguriert wurden.

Exporteinstellungen sind für jede Dokumentdefinition konfiguriert. Es kann jedoch vorkommen, dass Sie die Daten in einen anderen Speicherort exportieren möchten, z. B. bei einem Testexport. In diesem Fall können Sie die Daten über die Exportschaltfläche mit Einstellungen, die von den in der Dokumentdefinition vorhandenen Vorgaben abweichen, in eine Datei oder Datenbank oder Bilder in Dateien exportieren. Siehe dazu Exportieren erkannter Daten. Beim erstmaligen Export werden die Standardeinstellungen verwendet. Wenn die Exporteinstellungen geändert werden, werden jeweils die zuletzt verwendeten Einstellungen gespeichert.

Die Standardeinstellungen zum Exportieren von Daten in eine Datei oder Datenbank oder von Bildern in Dateien können auf der Registerkarte Exportzieledes Dialogfelds Projekteigenschaften (Menüoption Projejt > Projekteigenschaften…). im Hauptfenster) konfiguriert werden. Auf dieser Registerkarte werden die aktuellen Standardexporteinstellungen angezeigt. Sie können Einstellungen für den Export in eine Datei oder in eine Datenbank konfigurieren. Wenn Sie die Standardexporteinstellungen ändern möchten, klicken Sie auf Bearbeiten…,und legen Sie Exporteinstellungen fest, die den Exporteinstellungen in der Dokumentdefinition ähneln (siehe Konfigurieren des Datenexports).


Dokumentstapel

Zu verarbeitende Dokumente werden in Stapeln zusammengefasst. Das Prinzip der Dokumentgruppierung in Stapel wird vom Benutzer bestimmt. Der Benutzer kann beispielsweise wählen, alle Dokumente als einen Stapel zu verarbeiten oder die Dokumente zu gruppieren, die am gleichen Tag importiert oder in einem Durchgang gescannt wurden.

Stapel werden an den Verarbeitungsstationen automatisch erstellt, wenn Bilder aus Hot Foldern importiert werden. Stapel können an der Scanstation vom Operator manuell oder automatisch erstellt werden, wenn die entsprechenden Scanprofile verfügbar sind. Wenn ein Stapel erstellt wird, sollte ein Typ spezifiziert werden, der definiert, wie der Stapel verarbeitet werden muss.

Seitenbilder werden während der Verarbeitung hinzugefügt. Siehe Hinzufügen von Seitenbildern für weitere Einzelheiten.

An der Projektkonfigurationsstation können Dokumentdefinitionen durch das Erstellen von Stapeln, Hinzufügen von Dokumentbildern zu den Stapeln und Verarbeitung dieser getestet und korrigiert werden (d. h. Erkennung, Verifizierung und Export der Ergebnisse). Wenn Sie einen neuen Stapel erstellen möchten, klicken Sie mit der rechten Maustaste auf die Stapelliste im Hauptfenster und wählen Sie im Kontextmenü die Option Neuer Stapel... aus.

Arbeits- und Teststapel

Die Teststapel werden vom Batch Setup Operator verwendet, um die Dokumentdefinitionen zu testen und zu korrigieren. Arbeitsstapel sind für die Verarbeitung von Dokumenten mit ABBYY FlexiCapture 10 vorgesehen. Der Batch Setup Operator kann auch auf Arbeitsstapel zugreifen, wenn während der Verarbeitung Fehler auftreten. Im Falle eines Fehlers kann der Operator den Stapel öffnen und den Fehler beheben. Teststapel und Arbeitsstapel unterscheiden sich dadurch, dass die lokale Dokumentdefinition verwendet wird, um die Dokumente eines Teststapels zu verarbeiten, während eine veröffentlichte Dokumentdefinition verwendet wird, um die Dokumente eines Arbeitsstapels zu verarbeiten. Siehe Bearbeitung und Veröffentlichung einer Dokumentdefinition.

Um die Stapelliste zu öffnen, wählen Sie die Option Arbeitsstapel oder Teststapel aus dem Menü 'Ansicht' in der Projektkonfigurationsstation.


Anhänge

Benutzeranhänge können Seiten, Dokumenten und Stapeln hinzugefügt werden. Angehängte Dateien können später bearbeitet und heruntergeladen werden.

Sie können Dateien aller Formate anhängen, wie z. B. eine Datei mit digitaler Signatur beim Scannen von Bildern.

Anhänge können folgendermaßen hinzugefügt werden:

  1. Beim Import von Bildern aus dem Hot Folder entsprechend den in der Beschreibungsdatei vorgenommenen Einstellungen.
  2. Klicken Sie auf der Registerkarte Anhänge im Dialogfeld für die Stapeleigenschaften oder Dokumenteigenschaften auf die Schaltfläche Hinzufügen….Geben Sie im angezeigten Dialogfeld den Namen der Vorlage und den Pfad dorthin an.
  3. Mittels eines Skripts mit der Methode IUserAttachments.AddNew. Die Methoden der Benutzeroberfläche IUserAttachment ierlauben Ihnen außerdem die Bearbeitung hinzugefügter Anhänge.

  4. Durch Verwendung der Webservice-API. Detaillierte Informationen finden Sie in der Hilfedatei der Webservices-API.

Möchten Sie den Anhang auf der Festplatte Ihres Computers speichern, klicken Sie auf die Schaltfläche Speichern unter… auf der Registerkarte Anhänge oder verwenden Sie die Methode IUserAttachment.ToFile.


Indexfelder

Um die Suche und Verarbeitung von Dokumenten zu vereinfachen, können Sie Dokumente mit den Werten beliebiger Felder aus einer Dokumentdefinition indizieren. Sie können dann zusätzlich zu den allgemeinen Informationen in den Dokumentlisten im Hauptfenster des Programms für jedes Dokument die Werte der Indexfelder ausgeben, die Dokumente nach diesen Werten sortieren und die gewünschten Dokumente auf einfache Weise suchen.

Aktivieren Sie für die Indizierung nach Feldwerten für das entsprechende Feld die Option Indexfeld (Registerkarte Allgemein im Dokumentdefinitionseditor).

So zeigen Sie den Wert des Indexfelds in der Dokumentliste an:

  • Öffnen Sie im Hauptfenster des Programms einen Dokumentstapel, und aktivieren Sie den Modus für die detaillierte Dokumentliste (Schaltfläche [image] in der Symbolleiste).
  • Klicken Sie mit der rechten Maustaste in den Bereich der Tabellenkopfzeile (Spaltennamen), und wählen Sie in der Dropdownliste die Option Anpassen… aus.
  • Klicken Sie im Dialogfeld Spalten auswählen auf die Schaltfläche Neu….
  • Klicken Sie im Dialogfeld Spalte bearbeiten auf die Schaltfläche Auswählen… rechts neben dem Indexfeld. Wählen Sie im daraufhin geöffneten Dialogfeld eines der Felder aus, bei denen die Indexfeld. aktiviert ist. Sie können auch einen Spaltennamen eingeben und die entsprechende Indizierungsmethode festlegen.

  • In der Tabelle wird eine neue Spalte mit dem Wert des Indexfelds angezeigt. Klicken Sie auf diese Spalte, um Dokumente nach dem Wert des Indexfelds zu sortieren.


Arbeiten mit einem konfigurierten Projekt

Damit Operatoren Dokumente verarbeiten können, muss ein Administrator zunächst Projekteinstellungen vornehmen. Die Dokumentverarbeitung kann so konfiguriert werden, dass sich die Arbeit der Operatoren beim Scannen und dem Import von Bildern sowie bei der Erkennung und dem Export von Daten auf ein Minimum beschränkt. In diesem Fall besteht die wesentliche Aufgabe von Operatoren darin, die erkannten Daten zu überprüfen und gegebenenfalls zu korrigieren. Dies erfolgt in der Phase der Überprüfung.

Die jeweils verwendeten Dokumenttypen haben keine Auswirkungen auf die Arbeit der Operatoren.

Die Dokumentverarbeitung erfolgt in vier Schritten. Jedem Schritt entspricht dabei eine Schaltfläche in der Symbolleiste.

1. Hinzufügen von Bildern

Über das Pfeilsymbol rechts neben der Schaltfläche können Sie eine der folgenden Optionen für den Bildimport auswählen: Bilder laden…, Bilder scannen… oder Bilder importieren durch die Auswahl eines der konfigurierten Bildprofile. Die Beschriftung der Schaltfläche ändert sich je nach der ausgewählten Aktion.

2. Erkennung

Über diese Schaltfläche wird die Erkennung von Dokumenten durchgeführt. Über das Pfeilsymbol rechts neben der Schaltfläche können Sie zudem Dokumente analysieren oder eine der Dokumentdefinitionen zuordnen.

3. Überprüfung

Über diese Schaltfläche wird der Überprüfungsvorgang durchgeführt. Über das Pfeilsymbol können Sie darüber hinaus eine regelbasierte Validierung durchführen.

4. Exportieren

Über diese Schaltfläche wird der Datenexport entsprechend den Einstellungen in der Dokumentdefinition gestartet. Wenn Sie auf das Pfeilsymbol klicken, können Sie festlegen, ob Daten in eine Datei oder in eine Datenbank oder ob Dokumentbilder exportiert werden sollen.


Hinzufügen von Seitenbildern

Die Verarbeitung von Dokumenten beginnt mit dem Bildimport, d. h. dem Hinzufügen von Seitenbildern der Dokumente zu einem Projekt. Wählen Sie einen Arbeitsstapel aus, oder erstellen Sie einen neuen Arbeitsstapel, dem die Bilder hinzugefügt werden sollen. Klicken Sie zum Erstellen eines Stapels mit der rechten Maustaste in das Hauptfenster des Programms, und wählen Sie Neuer Stapel… aus. Öffnen Sie den entsprechenden Stapel durch Doppelklicken, oder markieren Sie ihn einfach in der Liste.

Hinweis: Beim Hinzufügen von Bildern zu einem Projekt ohne Stapel wird automatisch ein Dokumentstapel erstellt.

Bilder können folgendermaßen zu Stapeln hinzugefügt werden:

  1. Laden zuvor gespeicherter Bilder aus Dateien;

  2. Scannen der Bilder;
  3. Importieren der Bilder mit einem der Bildimportprofile, die zuvor von einem Administrator erstellt wurden (siehe Bildimportprofile)

Klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche, und wählen Sie eine der Menüoptionen zum Hinzufügen von Bildern aus.

Hinzufügen von Bildern aus einer Datei

Wenn Sie Bilder aus einer Datei laden möchten, wählen Sie die Menüoption Bilder laden… aus, oder drücken Sie Strg+O auf der Tastatur. Wählen Sie im daraufhin geöffneten Dialogfeld die gewünschte Bilddatei aus, und konfigurieren Sie die folgenden Optionen für den Bildimport:

  • Neues Dokument erstellen – für die hinzugefügten Bilder werden neue Dokumente erstellt;
  • Zum aktuellen Dokument hinzufügen – Die Bilder werden zum aktuellen markierten Dokument hinzugefügt.
  • Sie können zudem Optionen für die Vorverarbeitung eines Bilds auswählen. Klicken Sie auf die Schaltfläche Einstellungen zur Bildvorverarbeitung…, und wählen Sie die gewünschten Optionen im angezeigten Dialogfeld aus. Einzelheiten finden Sie unter Optionen für die Bildvorverarbeitung.

Scannen von Bildern

Wählen Sie zum Hinzufügen von Bildern von einem Scanner die Option Bilder scannen… aus. Wählen Sie einen Scanner aus, konfigurieren Sie die Scanoptionen, und scannen Sie anschließend die Bilder.

Hinzufügen von Bildern mithilfe von Importprofilen

Wenn vom Administrator Importprofile konfiguriert wurden, werden sie im Menü der Importschaltfläche angezeigt. Um Bilder zu importieren, müssen Sie lediglich eines der Importprofile auswählen.

Wenn Sie Bilder importieren… auswählen, wird das Dialogfeld Importprofil auswählen geöffnet. Wählen Sie in der Liste ein Importprofil aus, und klicken Sie auf die Schaltfläche Importieren, um den Vorgang zum Importieren der Bilder zu starten. Im Administratormodus können Sie in diesem Dialogfeld darüber hinaus ein neues Importprofil erstellen oder vorhandene Profile bearbeiten.

Bildimport im Hintergrund

Bildimporte können im Hintergrund durchgeführt werden, wenn ein entsprechendes Importprofil konfiguriert wurde. Bilder aus dem Hot Folder werden automatisch in das System importiert. In dem in den Einstellungen festgelegten Zeitintervall wird automatisch überprüft, ob der Hot Folder neue Bilder enthält.

Die Überwachung des Hot Folders wird gestartet, wenn der Benutzer Bilder mithilfe eines Profils importiert, bei dem die Option Hot Folder alle aktiviert ist. Sie wird beendet, wenn der Benutzer das Projekt beendet oder in den Eigenschaften des Profils die Option Hot Folder alle deaktiviert. Detaillierte Informationen finden Sie unter Bildimportprofile.

Hinweis: Um Bilder zum Hot Folder hinzufügen zu können, muss der Benutzer über Lese- und Schreibzugriff für diesen Ordner verfügen.


Konfigurieren von Scanoptionen

Normalerweise kommen zu verarbeitende Dokumente von der Scanstation oder dem Hot Folder. Dokumente können jedoch auch auf der Verifizierungsstation oder auf der Projektkonfigurationsstation gescannt werden. In diesem Fall müssen die erforderlichen Scanparameter ausgewählt werden.

Die Qualität der Erkennung hängt größtenteils von der Qualität der gescannten Bilder ab. Die Qualität der Bilder kann durch Konfigurieren der allgemeinen Scaneinstellungen für den Bildtyp, die Auflösung und die Helligkeit reguliert werden.

Beim Scannen von Bildern mit ABBYY FlexiCapture kann auf zweierlei Weise eine Verbindung zwischen dem Programm und den Scannern über den TWAIN- oder ISIS-Treiber hergestellt werden:

  • Über die Schnittstelle von ABBYY FlexiCapture:
    In diesem Fall werden die Scanoptionen im ABBYY FlexiCapture-Dialogfeld Scannereinstellungen konfiguriert. Die Scanoptionen können beim Erstellen eines Importprofils festgelegt werden, bei dem Scanner als Importquelle angegeben ist.
  • Über die Schnittstelle des TWAIN- oder ISIS-Treibers des Scanners:
    Dabei werden die Scanoptionen im Dialogfeld des entsprechenden Scannertreibers konfiguriert. Dieses Dialogfeld wird automatisch geöffnet, wenn Sie im Dropdownmenü der Importschaltfläche die Option Bilder scannen… auswählen.

Allgemeine Scanoptionen

  • Bildtyp – das Scannen in Graustufen (256 Grautöne) ist der optimale Modus für das Erkennungssystem. Wenn Sie im Graustufenmodus scannen, wird der Grad der Helligkeit automatisch ausgewählt.

    Durch den Bildtyp Schwarz-weiß erhöht sich die Scangeschwindigkeit auf Kosten einiger Buchstabeninformationen. Dies wirkt sich möglicherweise auf die Erkennungsqualität von Dokumenten mit mittlerer und schlechter Druckqualität aus.

    Wenn Farbelemente eines Dokuments (Bilder, farbige Buchstaben oder Farbhintergrund) im elektronischen Dokument farbig dargestellt werden sollen, muss dagegen der Bildtyp Farbe ausgewählt werden. In anderen Fällen eignet sich wiederum der Bildtyp Graustufen besser.

  • Die Werte für Helligkeit und Kontrast müssen so ausgewählt werden, dass erstens die Ankerblöcke beibehalten werden und zweitens die Bilder der zur Erkennung vorgesehenen Blöcke möglichst klar und eindeutig dargestellt werden.
    In den meisten Fällen ist der durchschnittliche Helligkeitswert von 50 % geeignet.
    Unter Umständen müssen Sie beim Scannen bestimmter Dokumente im Schwarz-Weiß-Modus den Helligkeitsgrad ändern.
  • Auflösung – für die Verarbeitung von Formularen, die von Hand ausgefüllt wurden, empfiehlt sich im Schwarz-Weiß-Modus eine Auflösung von 300 dpi. Die Auflösung gescannter Formulare muss mit der Auflösung des Vorlagenbilds übereinstimmen.

Hinweis:

  1. Scanvorgänge mit einer Auflösung von 400 bis 600 dpi anstelle von 300 dpi sowie im Graustufen- oder Farbmodus anstelle des Schwarz-Weiß-Modus dauern unter Umständen erheblich länger. Bei einigen Scannermodellen dauern Scanvorgänge mit einer Auflösung von 600 dpi viermal so lange wie Scanvorgänge mit einer Auflösung von 300 dpi. Vom Scannen mit einer Auflösung unter 200 dpi wird abgeraten.
  2. Wenn Sie die Scanoptionen im Dialogfeld des Scannertreibers konfigurieren, können die entsprechenden Optionen je nach Scannermodell abweichende Bezeichnungen tragen. Die Helligkeit wird beispielsweise als Schwellenwert bezeichnet oder mit einer Sonne oder einem schwarz-weißen Kreis angezeigt. Erklärungen zu den einzelnen Einstellungen finden Sie in der Dokumentation des jeweiligen Scanners.

Tipp.

  1. Scannen von Formularen mit Farbhintergrund mit einem Schwarz-Weiß-Scanner: Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie den Scanner mit einer entsprechenden Lampe zum Filtern des Lichts ausrüsten. Verwenden Sie bei rosafarbenen Formularen eine rote Lampe und bei grünen Formularen eine grüne Lampe.
  2. Scannen von Formularen mit Farbhintergrund mit einem Farbscanner: Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie in den Scannereinstellungen den Filtermodus für die entsprechende Farbe konfigurieren.
  3. Scannen von Formularen mit Farbhintergrund in hellen Farbtönen: Wenn Sie Formulare mit hellen Farbtönen verarbeiten, wird der Hintergrund aufgrund der geringen Farbstärke beim Scannen mit einer weißen Lampe möglicherweise auch ausgeblendet, wenn in den Scaneinstellungen keine Farbfilter ausgewählt sind. In der Regel wird das Verfahren zum Scannen von Formularen beim Entwerfen der Formulare gewählt.

Tipp.

  1. Ein gescanntes Bild muss lesbar sein (öffnen Sie das gescannte Bild im Dokumentfenster).

  2. Wenn Buchstaben im gescannten Bild unvollständig, hell oder ausgebrochen angezeigt werden, gehen Sie folgendermaßen vor:

    • Verringern Sie den Helligkeitsgrad, und erhöhen Sie den Kontrast (das Bild wird dunkler).
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).

  3. Wenn das gescannte Bild einen fleckigen Hintergrund, verzerrte, verschmierte oder verschwommene Zeichen oder dunkle bzw. fette Buchstaben aufweist, gehen Sie wie folgt vor:

    • Erhöhen Sie den Helligkeitsgrad (das Bild wird heller) oder
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).


Erkennung

Klicken Sie zum Aktivieren der Erkennung auf die Schaltfläche Erkennen. Im Programm wird eine Dokumentdefinition anhand von Ankern und Objekten zur Identifizierung ausgewählt und zugeordnet. Anschließend wird die Datenerkennung in den Dokumentbereichen durchgeführt, die mit Feldbereichen der ausgewählten Dokumentdefinition übereinstimmen.

Die Bilderkennung kann beim Hinzufügen von Bildern zum Stapel automatisch durchgeführt werden. Aktivieren Sie dazu die Option Hinzugefügte Bilder automatisch erkennen (im Menü Extras des Hauptfensters, Optionen…, Registerkarte Dokumentverarbeitung).

In der Spalte Grad der Zuverlässigkeit wird das Verhältnis von eindeutig erkannten Zeichen zur Gesamtanzahl der Zeichen angezeigt. Nach der Erkennung können Sie die Dokumentüberprüfung ausführen.

Vor der Erkennung kann der Operator bei Bedarf eine Voranalyse von Bildern und Zuordnung von Dokumentdefinitionen ausführen.

Hinweis: Während der Erkennung kann die folgende Nachricht angezeigt werden: "<ProjectDirectory>\<BatchName>\BatchHeader.tmp kann nicht erstellt werden". Die angegebene Datei ist bereits vorhanden." Der Fehler tritt aufgrund des Indexierungsdienstes der Windows-Suche auf, die sich auf die Funktion des Programms auswirkt. Der Indexierungsdienst Windows Search verarbeitet Dateien, die Im Projektverzeichnis erstellt und während des Programmbetriebs gelöscht wurden, was den Fehler verursacht. Aus diesem Grund empfehlen wir die Deaktivierung des Indexierungsdienstes Windows Search.


Voranalyse von Bildern und Zuordnung von Dokumentdefinitionen

Vor der Erkennung können Sie analysieren oder festlegen, welche Dokumentdefinition einer bestimmten Seite zugeordnet werden kann. Wählen Sie dazu im Hauptmenü die Optionen Erkennung > Analyse aus oder klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen und wählen Sie Analysieren.aus. Wenn eine Dokumentdefinition zugeordnet werden kann, werden die Seite und das Dokument entsprechend benannt. Wenn dem Bild keine Dokumentdefinition zugeordnet werden kann, wird die Seite nicht verarbeitet.

Sie können einer Seite oder einem vollständigen Dokument auch eine bestimmte Dokumentdefinition zuordnen. Größtenteils werden Seiten ordnungsgemäß erstellten Dokumentdefinitionen automatisch zugeordnet. In einigen Fällen müssen Sie jedoch möglicherweise Dokumentdefinitionen manuell zuordnen.

So ordnen Sie eine Dokumentdefinition zu:

  1. Markieren Sie das Dokument;

  2. Wählen Sie im Kontextmenü des Dokuments die Option Dokumentdefinition zuordnen… oder im Hauptmenü die Optionen Erkennung>Dokumentdefinition zuordnen… aus oder klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen und wählen Sie Dokumentdefinition zuordnen… aus;
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Dokumentdefinition auswählen eine der Dokumentdefinitionen aus, und klicken Sie dann auf OK.

Nachdem die ausgewählte Dokumentdefinition erfolgreich zugeordnet wurde, wird dem Dokument und den zugehörigen Seiten der Name der entsprechenden Dokumentdefinition und der zugehörigen Bereiche zugewiesen.

So ordnen Sie einer Seite eine Dokumentdefinition zu:

  1. Markieren Sie die Seite;
  2. Wählen Sie im Kontextmenü der Seite die Option Dokumentdefinition zuordnen… oder im Hauptmenü die Option Erkennung>Dokumentdefinition zuordnen… aus;
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Dokumentdefinition für Zuordnung auswählen eine der Dokumentdefinitionen aus, und klicken Sie dann auf OK.

Wenn die Dokumentdefinition erfolgreich zugeordnet wird, wird der ausgewählten Seite der Name des entsprechenden Dokumentdefinitionsbereichs zugeordnet.


Überprüfung erkannter Daten

Die Überprüfung der erkannten Daten ist die arbeitsintensivste Aufgabe von Operatoren. Bei ABBYY-Produkten wurden Technologien für die Überprüfung implementiert, die bestimmte Eigenheiten von Benutzern ( Routine, Können, Wahrnehmungsvermögen) berücksichtigen. Dadurch wurde der Überprüfungsprozess in ABBYY FlexiCapture so konzipiert, dass einerseits die Benutzerfreundlichkeit für Operatoren im Vordergrund steht und sich andererseits die Anzahl möglicher Fehler auf ein Minimum reduziert.

Wenn bestimmte Zeichen nicht mit absoluter Sicherheit erkannt werden können, werden sie im Programm als nicht eindeutig erkannt gekennzeichnet. Bei der Überprüfung wird geprüft, ob diese Zeichen richtig erkannt wurden. Bei Bedarf werden dann eventuelle Korrekturen vorgenommen.

Die regelbasierte Validierung wird automatisch durchgeführt. Wenn Feldwerte den festgelegten Regeln entsprechen, können die entsprechenden Felder als eindeutig erkannt gekennzeichnet und aus dem Validierungsvorgang ausgenommen werden. Felder, deren Werte nicht den Regeln entsprechen, werden zur Überprüfung weitergeleitet.

Bei mehrseitigen Dokumenten muss zunächst die Zusammenstellung der Seiten zu Dokumenten überprüft werden.

Dann wird der Überprüfungsvorgang durchgeführt. Die Überprüfung erfolgt in zwei Schritten: Zunächst wird eine Gruppen- und anschließend eine Feldüberprüfung durchgeführt. Wenn eine Dokumentdefinition keine Felder zur Gruppen- oder Feldüberprüfung enthält (siehe Feldüberprüfungseigenschaften), wird der entsprechende Überprüfungsschritt übersprungen.

Nach der Gruppen- und Feldüberprüfung können Sie die Zeichen im Dokumentfenster überprüfen. Die Zeichen, die in früheren Schritten nicht bestätigt wurden, werden weiterhin rot angezeigt.

Durch Klicken auf die Schaltfläche [image] und [image] in der Symbolleiste des Hauptfensters können Sie durch die einzelnen Fehler navigieren. Dabei werden alle Fehlerkategorien angezeigt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler usw.

Zusammenstellen von Seiten zu Dokumenten
Gruppenüberprüfung
Feldüberprüfung
Überprüfung im Dokumentfenster
Regelbasierte Validierung


Zusammenstellen von Seiten zu Dokumenten

Korrigieren von Zusammenstellungsfehlern

  1. Falsche Reihenfolge der Seiten in einem Dokument

    Möglicherweise enthält das Dokument zu viele oder zu wenige Seiten, oder die Dokumentseiten sind nicht in der richtigen Reihenfolge angeordnet. Wenn Sie den entsprechenden Tipp lesen möchten, setzen Sie den Mauszeiger auf die Seite mit dem roten Kreuz:

    Diese Fehler können Sie korrigieren, indem Sie die entsprechende Seite mit dem Mauszeiger in einem Dokument oder zwischen verschiedenen Dokumenten verschieben.

    Seiten mehrerer Dokumente können wie folgt in einem Dokument zusammengeführt werden:

    • Markieren Sie die entsprechenden Dokumente (durch Klicken bei gedrückter Strg-Taste können Sie mehrere Dokumente markieren);

    • Klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Verbinden aus.

    So trennen Sie Seiten in einem Dokument und positionieren sie jeweils in einem separaten Dokument:

    • Markieren Sie das Dokument, in dem Seiten getrennt werden sollen;
    • Wählen Sie im Kontextmenü die Option Teilen aus.

  2. Wenn in einer Dokumentdefinition festgelegt ist, dass die Zusammenstellung von Seiten anhand von Schlüsselfeldern überprüft wird, werden die Schlüsselfeldwerte jeweils unterhalb der Seitenbilder angezeigt:

    • Bei Übereinstimmung werden die Werte grau angezeigt;
    • Bei Nichtübereinstimmung werden sie rot angezeigt.

    Schlüsselfelder stimmen möglicherweise nicht überein, wenn sie falsch erkannt oder ausgefüllt wurden. Überprüfen Sie die Werte der Schlüsselfelder. Wenn die Werte weiterhin nicht übereinstimmen, handelt es sich wahrscheinlich nicht um die Seiten ein und desselben Dokuments. Wenn die Seiten in der falschen Reihenfolge angeordnet sind, suchen Sie Seiten mit identischen Schlüsselfeldern, und stellen Sie sie zu Dokumenten zusammen (siehe Punkt 1).

Über das Zusammenstellen von Seiten zu Dokumenten

Die Seiten werden entweder automatisch oder durch einen expliziten Benutzerbefehl zu Dokumenten zusammengestellt. Die Zusammenstellungsregeln können beim Erstellen von Dokumentdefinitionen für mehrseitige Dokumente definiert.

Besonderheiten von in den Dokumentdefinitionseigenschaften beschriebenen Zusammenstellungen

  1. Werden ausgeführt:
    • bei der Auswahl eines Befehls: Extras > Zusammenstellung aktualisieren

    • nach der Analyse/Erkennung einer Sammlung von Dokumenten; in diesem Fall enthält die Zusammenstellung nur Dokumente, die in die Analyse/Erkennung einbezogen sind

  2. Sowohl die Standard-Zusammenstellungsregeln als auch ein Zusammenstellungsskript können angewendet werden.
  3. Dokumente, für die das Flag IsExcludedFromAutomaticAssembly auf true gesetzt ist, werden von der Zusammenstellung ausgeschlossen. Das Flag IsExcludedFromAutomaticAssembly wird in den folgenden Fällen auf true gesetzt:

    • die Dokumentstruktur wird während der Importphase definiert (durch XML-Beschreibung, bei der Aufteilung der Dokumente durch Leerseiten, Patchcodes oder mehrseitige Dateien)

    • Dokumentdefinition zuordnen… wird für das Dokument angewendet

    • das Flag kann durch jedes Skript gesetzt werden, dem die Bearbeitung von Dokumenten erlaubt ist

  4. Die Zusammenstellung wird nicht für erkannte Dokumente mit verschiedenen Dokumentdefinitionen oder mit verschiedenen Versionen der gleichen Dokumentdefinition durchgeführt.

  5. Wird die Dokumentdefinition nicht zugeordnet, wird keine Zusammenstellung durchgeführt. Beispiel: handelt es sich bei allen Seiten eines Stapels um Anhangseiten, wird keine Zusammenstellung durchgeführt.

  6. Die Reihenfolge der Seiten kann während der Zusammenstellung nicht geändert werden.

Besonderheiten einer in den Stapeltypeigenschaften beschriebenen Zusammenstellung

Operatoren müssen eventuelle Fehler bei der Dokumentzusammenstellung identifizieren und korrigieren.

Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt. Klicken Sie auf die Schaltfläche [image], um in die Gliederungsansicht zu wechseln.

Hinweis: können die Größe der Seitengliederung ändern, um Details anzuzeigen. Drehen Sie dazu bei gedrückter Strg-Taste das Scrollrad der Maus in die gewünschte Richtung.

Hinweis: Die Reihenfolge der Bereiche wird beim Erstellen der Dokumentdefinition nicht überprüft, wenn die Option Überprüfung der Bereichsreihenfolge deaktivieren auf der Registerkarte Zusammenstellung tab. ausgewählt wurde. Das Programm wird weiterhin überprüfen, ob alle Bereiche im Dokument vorhanden sind, aber die Reihenfolge wird dabei ignoriert.

Sie müssen beim Erstellen einer Dokumentdefinition die Regel für die Dokumentzusammenstellung definieren: Reihenfolge und Anzahl wiederholter Dokumentbereiche. Zudem können Sie die Überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren: dabei müssen die Werte von Schlüsselfeldern auf sämtlichen Seiten des Dokuments gleich sein.

Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Die entsprechende Fehlerbeschreibung wird unterhalb der Dokumentdefinition in roter Schrift angezeigt.


Gruppenüberprüfung

Die Gruppenüberprüfung beinhaltet die Überprüfung der Zeichenbilder, die als Bilder mit identischen Werten erkannt wurden. Sie ermöglicht es dem Operator, die von der Gruppe abweichenden Zeichen einfach zu identifizieren und zu korrigieren.

Falsch erkannte Zeichen können wie folgt korrigiert werden: Markieren Sie das Zeichen, das nicht mit der Zeichengruppe übereinstimmt, und geben Sie das richtige Zeichen ein. Dieser Wert wird links oben im Zeichenbild grün angezeigt.

Ist das Zeichen im Bild schwer zu lesen und Sie können bestimmen, ob es korrekt erkannt wurde, können das Textfeld, Zahlenfeld oder die Feldgruppe angezeigt werden, welche(s) das Symbol im Dokumentbild enthält. Das kann Sie bei der Bestimmung des Symbols unterstützen. Dafür klicken Sie mit der linken Maustaste auf das Symbol und wählen aus dem Kontextmenü des Symbols Zeichenbild anzeigen anzeigen" oder drücken die Taste F2.

Sie können zudem einen Modus aktivieren, in dem das Feld des überprüften Zeichens angezeigt wird, wenn Sie den Mauszeiger auf das Zeichen setzen. Wählen Sie dazu im Überprüfungsfenster die Menüoption Ansicht>Feldbild>Feldbild anzeigen aus, oder drücken Sie Strg+I auf der Tastatur.

Wird ein irrelevantes Bild als ein Zeichen erkannt, können Sie es entfernen, indem Sie auf die Schaltfläche Löschen klicken.

Wenn selbst nach der Anzeige eines Zeichens in seinem Kontext Zweifel bestehen, klicken Sie mit der linken Taste auf das Zeichen. Es wird dann mit einem roten Fragezeichen gekennzeichnet. Sie können es später während der Feldüberprüfung bestätigen oder korrigieren.

Der Status von Zeichen kann darüber hinaus über die Schaltfläche Status ändern in der Symbolleiste geändert werden.

Wurden alle falsch erkannten Zeichen korrigiert oder aufgeschoben, können Sie alle anderen Zeichen gleichzeitig bestätigen, indem Sie auf der Symbolleiste die Schaltfläche Alle bestätigen anklicken. Durch Auswählen von Bestätigen im Kontextmenü können Sie richtig erkannte Zeichen nacheinander bestätigen.


Feldüberprüfung

Die Feldüberprüfung dient zur effektiven Korrektur von Formatfehlern bei leicht erkennbaren Feldern, d. h. Feldern, deren Wertebereich bekannt ist oder einfach identifiziert werden kann. Beispiele für diese Felder sind Länder oder Orte. da die Werte dieser Felder im Voraus bekannt sind.

Um zu entscheiden, wie ein Feldwert korrigiert werden muss, muss der Benutzer lediglich das Feld anzeigen und dessen Wertebereich kennen. Sowohl Eingabefehler als auch Fehler beim Feldformat können berichtigt werden.

Sie können falsch erkannte Zeichen mit den Standardmodi von Texteditoren korrigieren, d. h. Einfügen oder Ersetzen von Zeichen. Durch Drücken der Einfg-Taste auf der Tastatur können Sie zwischen den beiden Modi wechseln.

Sie können den Korrekturmodus ändern, indem Sie z.B. die Auswahl eines gesamten Feldes aktivieren, um dessen Inhalt neu einzutippen. Sie können außerdem das Erscheinungsbild des Fensters ändern, damit so mehr Informationen angezeigt werden können, z.B. das Feldbild, Bilder analoger Felder anderer Dokumente usw.

Sie können die Erkennungsergebnisse der einzelnen Felder überprüfen, sie gegebenenfalls korrigieren und durch Klicken auf die Schaltfläche Feld bestätigen bestätigen.

Die Werte dieser Felder müssen berichtigt werden. Wenn sie nicht korrigiert werden können, können Sie das entsprechende Feld überspringen oder ablehnen, um es in der Überprüfungsphase zu korrigieren. Klicken Sie dazu auf die Schaltfläche Aufschieben.


Überprüfung im Dokumentfenster

Im Dokumentfenster können Sie die Genauigkeit der Erkennung überprüfen und falsch erkannte Zeichen korrigieren. Das Dokumentfenster wird geöffnet, wenn Sie auf den Namen der Seite doppelklicken. Das Dokumentfenster umfasst den Datenbereich, das Seitenbild und den Bereich für Fehler (sofern Fehler aufgetreten sind). Sie können die anzuzeigenden Fehlerarten auswählen: Zusammenstellungsfehler, Formatfehler, Regelfehler oder beliebige Kombinationen davon. Um Fehler einer bestimmten Art anzuzeigen, klicken Sie in der oberen rechten Ecke im Fehlerbereich auf die entsprechende Schaltfläche.

Im Dokumentfenster können nicht nur Zeichengruppen oder einzelne Felder, sondern das gesamte Dokument angezeigt werden. Durch Klicken auf die Schaltfläche Layout können Sie das Layout des Fensters festlegen. Um das Bild auf einem zweiten Monitor anzuzeigen, wählen Sie Bildfenster > Abgekoppelt. In diesem Modus können Sie das Seitenbild skalieren, wählen einen Block aus und löschen unnötige Trennzeichen.

Collapsed Dokumentfenster anzeigen

Vom lokalen Menü des Dokumentfenster aus können Sie ein Feld bestätigen, die Anzeige von Formatfehlern wählen, zum letzten oder nächsten zu überprüfenden Element gehen, eine Datentextgröße sowie den Navigationsmodus durch die Felder wählen. Wählen Sie Bei Bestätigung zu nicht eindeutigem Feld wechselnzur Navigation durch nicht eindeutig erkannte Felder. Für die Navigation durch Felder mit unerkannten Bereichen wählen Sie Bei Übereinstimmung zum nächsten nicht zugeordneten Feld gehen (siehe nachfolgende Beschreibung).

Im Datenbereich werden nicht eindeutig erkannte und fragliche Zeichen farbig angezeigt. Felder mit falschen Datentypen oder nicht eingehaltenen Regeln werden hervorgehoben.

Wenn Sie ein Feld mit nicht eindeutig erkannten Zeichen bestätigen möchten, setzen Sie den Mauszeiger in das Feld und drücken die Eingabetaste.

Felder zum Anzeigen und Bearbeiten erkannter Daten können nicht nur nacheinander, sondern in jeder gewünschten Weise angeordnet werden. Sie können die Anordnung der Felder im Dokumentdefinitionseditor ändern. Siehe dazu Konfigurieren der Datendarstellung im Dokumentfenster.

YSie können zum nächsten Fehler im Dokumentfenster wechseln, indem Sie in der Symbolleiste des Hauptfensters auf die Schaltfläche [image] und [image] klicken. Über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.

Schnelle Eingabe von Werten für nicht zugeordnete Felder

Diese Funktion steht für Projekte mit flexiblen Beschreibungen zur Verfügung und ermöglicht die schnelle Eingabe von Feldwerten bei nicht zugeordnetem Feld.

Der schnelle Eingabemodus ermöglicht es, per Mausklick Daten von einem ausgewählten Bereich zu einem aktiven Feld zu übertragen. Damit der Modus während der Überprüfung verfügbar ist, muss die Option Gesamten Text des Dokuments speichern in Dokumentdefinitionseigenschaften ausgewählt werden. Mit dieser Option werden erkannte Daten aus dem Cache als Ersatz verwendet.

Wurde der Feldwert nicht oder falsch gefunden, klicken Sie auf den Feldbereich auf der Seite, um den Wert schnell hinzuzufügen. Oder Sie wählen einen Teil des Textes durch Festhalten der Maustaste. Befindet sich nur ein nicht zugeordnetes Feld in dem Dokument, wird der Wert automatisch hinzugefügt. Anderenfalls werden Sie dazu aufgefordert, den mit dem Feld in Bezug stehenden Wert auszuwählen.

Ist keiner der vorgeschlagenen Werte korrekt, wählen Sie, falls die Überprüfung in der Projektkonfigurationsstation oder Überprüfungsstation durchgeführt wird, Erkennung (Strg+R). Das Feld wird dann anhand der in der Dokumentdefinition angegebenen Einstellungen erkannt. Wird die Überprüfung in einer Web-station durchgeführt, ist diese Funktion nicht verfügbar.

Der Navigationsmodus durch nicht zugeordnete Felder

Um durch die Felder zu navigieren, deren Bereiche nicht erkannt wurden, wählen Sie die Option Bei Übereinstimmung zum nächsten nicht zugeordneten Feld gehen im lokalen Menü des Dokumentfensters. Wurde dieser Modus aktiviert, wird das erste nicht zugeordnete Feld fokussiert. Bei der Eingabe des Feldwertes oder beim Anklicken der Schaltflächen [image] und [image], wechselt der Fokus zum nächsten nicht zugeordneten Feld.

Hinweis: Damit das Feld hervorgehoben wird, wenn dessen Bereich nicht gefunden wird und im Modus Bei Übereinstimmung zum nächsten nicht zugeordneten Feld gehen nicht verfügbar ist, muss die Option Sollte zugeordnet werden unter Eigenschaften des Feldes aktiviert werden.

Anzeige von Fehlerinformationen im Zusammenhang mit ausgeblendeten Feldern

Felder im Datenformular können aus folgenden Gründen ausgeblendet sein:

  • Die Option Bei Überprüfung anzeigen ist in den Feldeigenschaften deaktiviert.

  • Der Datensatz wird in den Phaseneigenschaften begrenzt.

Fehler im Zusammenhang mit ausgeblendeten Feldern können wie folgt angezeigt werden:

  1. Hängt ein Formatfehler mit dem ausgeblendeten Feld zusammen, werden im Fehlerbereich keine Fehlerinformationen angezeigt.

  2. Hängt ein feldübergreifender Regelfehler mit dem ausgeblendeten Feld zusammen und ist nur dieses Feld von der Regel betroffen, werden im Fehlerbereich keine Fehlerinformationen angezeigt.

  3. Hängt ein feldübergreifender Regelfehler mit dem ausgeblendeten Feld zusammen und sind auch andere Felder von der Regel betroffen, so werden Fehlerinformationen im Fehlerbereich angezeigt; beim ausgeblendeten Feld wird jedoch nur der Name (ohne einen Link zum Feld) angezeigt.

    Collapsed Anzeigen

Enthält ein Dokument Fehler, die aufgrund ausgeblendeter Felder nicht im Fehlerbereich angezeigt werden, hängt die Sichtbarkeit des Dokuments in der Liste von der Phase ab, in der das Dokument betrachtet wird.

  • Wird das Dokument in der Überprüfungsphase bei begrenztem Datensatz betrachtet, so wird das Dokument in der Liste ohne Fehlersymbol angezeigt. Im Fehlerbereich werden keine Fehlerinformationen angezeigt.

    Collapsed Anzeigen

  • Wird das Dokument in der Phase bei nicht begrenztem Datensatz betrachtet, z. B. in der Phase Ausnahmen, so wird das Dokument in der Liste mit Fehlersymbol angezeigt. Im Fehlerbereich werden keine Fehlerinformationen angezeigt.

    Collapsed Anzeigen


Regelbasierte Validierung

Nicht eingehaltene Regeln sind durch eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet.

Regelfehler werden im Dokumenteditor in einem separaten Fenster angezeigt. Dokumente mit nicht eingehaltenen Regeln sind durch rote Markierungen gekennzeichnet.

Bei Dokumenten mit nicht eingehaltenen Regeln muss der Operator die Qualität der Datenerkennung überprüfen. Wenn es sich um einen Erkennungsfehler handelt, muss dieser behoben werden. Wenn es sich um einen Fehler beim Ausfüllen eines Formulars handelt, der nicht korrigiert werden kann, sollte das Dokument nicht exportiert werden. Dokumente mit Fehlern können zu einem späteren Zeitpunkt überprüft werden, indem sie mit Papierdokumenten oder anderen verfügbaren Quellen verglichen werden.

Klicken Sie zum erneuten Überprüfen der Regeln auf das Pfeilsymbol rechts neben der Schaltfläche Überprüfung ausführen…, und wählen Sie die Menüoption Regeln erneut überprüfen aus. Wenn die Dokumente nach dem Ändern der Feldwerte den Regeln entsprechen, werden die Markierungen entfernt.


Exportieren erkannter Daten

Nach der Überprüfung der erkannten Daten exportiert der Operator den Stapel durch Klicken auf die Schaltfläche Exportieren. Der Export erfolgt entsprechend den Einstellungen der Dokumentdefinition.

Sie können die Daten zudem in eine Datei oder Datenbank exportieren, ohne die Exporteinstellungen der Dokumentdefinition zu verwenden.

Hinweis: Beim Exportieren der Daten in eine Datei oder Datenbank können Sie die Standardeinstellungen beibehalten oder bei Bedarf ändern. Die Standardeinstellungen sind im Eigenschaftsdialogfeld des Projekts Projekt>Projekteigenschaften…) auf der Registerkarte Export festgelegt. Siehe Standardexporteinstellungen.

Exportieren von Daten in eine Datei

  1. Wenn Sie Daten in eine Datei exportieren möchten, klicken Sie auf das Pfeilsymbol rechts neben der Exportschaltfläche, und wählen Sie die Option Daten in Datei exportieren… aus.

  2. Wählen Sie den Speicherort und das Präfix für den Dateinamen aus. Der Name beginnt mit diesem Präfix, gefolgt vom Namen der Dokumentdefinition, dem Namen des Stapels und der Dokumentnummer, wenn Sie die einzelnen Dokumente jeweils als separate Datei speichern (siehe Punkt 3).

  3. Folgende Optionen sind verfügbar:
    • Dokumente als einzelne Dateien exportieren – Die Daten von Dokumenten werden jeweils in separaten Dateien gespeichert;
    • Datei neu schreiben – um die Exportdatei zu überschreiben;
    • Dokumentbilder speichern – Die Dokumentbilder werden gespeichert.
  4. Wenn Sie andere Exporteinstellungen ändern möchten, klicken Sie auf die Schaltfläche Einstellungen… Ausführliche Informationen zur Exportkonfiguration finden Sie unter Konfigurieren des Datenexports.
  5. Wenn Sie die geänderten Exporteinstellungen speichern möchten, klicken Sie im Dialogfeld Exporteinstellungen für Datei auf die Schaltfläche In Dokumentdefinition speichern und wählen Sie die Dokumentdefinition aus, in der die aktuellen Einstellungen gespeichert werden sollen.

Bilder in Datei exportieren

  1. Wenn Sie Daten in eine Datei exportieren möchten, klicken Sie auf das Pfeilsymbol rechts neben der Exportschaltfläche, und wählen Sie die Option Bilder in Dateien exportieren aus.
  2. Wählen Sie Speicherort und Dateiformat aus (TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits oder PNG).
  3. Klicken Sie auf die Schaltfläche Einstellungen…, um die Bildexport-Einstellungen zu konfigurieren.

In Datenbank exportieren

  1. Wenn Sie Daten in eine Datenbank exportieren möchten, klicken Sie auf das Pfeilsymbol rechts neben der Exportschaltfläche und wählen Sie die Option In Datenbank exportieren… aus.
  2. Stellen Sie eine Verbindung mit einer Datenbank her. Ausführliche Informationen finden Sie unter Export in eine Datenbank.
  3. Klicken Sie auf die Registerkarte Bilder und legen Sie die Einstellungen zum Speichern der Bilder fest.

Hinweis:

  1. Dokumente, deren Daten erfolgreich exportiert wurden, können anschließend automatisch im Stapel gelöscht werden. Aktivieren Sie dazu im Dialogfeld Optionen auf der Registerkarte Dokumentverarbeitung die Option Dokumente nach Export löschen.

  2. Wenn Sie Dokumente mit Regelfehlern exportieren, wird eine Fehlermeldung angezeigt. Regelwarnungen haben keine Auswirkungen auf den Exportvorgang.


Hintergrundmodus

Wenn keinerlei Interaktion mit dem Operator erforderlich ist, dann kann das Importieren, Erkennen und Exportieren von Dokumenten im Hintergrundmodus ausgeführt werden.

Klicken Sie zum Übertragen eines Tasks in den Hintergrundmodus auf die Schaltfläche Hintergrundmodus im Dialogfeld Bilder werden hinzugefügt… (oder in den Dialogfeldern Erkennungsvorgang wird durchgeführt… oder Export wird durchgeführt…...).

Folgende Tasks können im Hintergrundmodus ausgeführt werden:

  • Das Laden von Bildern aus einem Hot Folder mithilfe des entsprechenden Importprofils.
  • Die Dokumenterkennung, sofern die Option Hinzugefügte Bilder automatisch erkennen aktiviert ist (Extras > Optionen…, Registerkarte Dokumentverarbeitung).

  • Export von Dokumenten.

Beim Wechsel in den Hintergrundmodus erscheint in der Taskleiste das Symbol [image]. Durch Klicken auf dieses Symbol wird das Dialogfeld Hintergrundtasks aufgerufen, in dem die Liste der Tasks angezeigt wird.

  • Die Tasks werden entweder in der Reihenfolge ihres Aufrufs oder auf der Grundlage der vom Benutzer (mithilfe der Schaltfläche Priorität festlegen…) angegebenen Prioritäten ausgeführt.
  • Die Ausführung der Tasks wird in einer Protokolldatei protokolliert, die vom Benutzer angepasst werden kann (Extras > Optionen…, Registerkarte Taskstatus). Klicken Sie auf die Schaltfläche Protokoll anzeigen, um das Protokoll anzuzeigen.
  • Sie können einen Task unterbrechen, indem Sie auf die Schaltfläche Task beenden klicken.

Das Programm informiert Sie gegebenenfalls über den Fortschritt eines Hintergrundtasks mithilfe von Popup-Meldungen, die in der rechten unteren Ecke angezeigt werden. Die Meldungen werden beim Start, bei einem Fehler und bei der Fertigstellung eines Tasks angezeigt. Einzelheiten finden Sie unter Zusätzliche Optionen.


Benutzeroberfläche von ABBYY FlexiCapture

In diesem Abschnitt finden Sie eine Übersicht über die Hauptelemente der Benutzeroberfläche von ABBYY FlexiCapture, d. h. die Hauptfenster, Menüs und Symbolleisten.

Projektkonfigurationsstation
Menüs der Projektkonfigurationsstation
Symbolleisten der Projektkonfigurationsstation
Verifizierungsstation
Menü der Verifizierungsstation
Symbolleisten der Verifizierungsstation
Datenverifizierungsstation
Menü der Datenverifizierungsstation
Symbolleisten der Datenverifizierungsstation
Hauptfenster des Programms
Menü des Hauptfensters
Symbolleisten im Hauptfenster
Dokumentdefinitionseditor
Menüs des Dokumentdefinitionseditors
Symbolleisten des Dokumentdefinitionseditors
Fenster für die Gruppenüberprüfung
Menüs im Fenster für die Gruppenüberprüfung
Symbolleisten im Fenster für die Gruppenüberprüfung
Fenster für die Feldüberprüfung
Menüs im Fenster für die Feldüberprüfung
Symbolleisten im Fenster für die Feldüberprüfung


Hauptfenster von ABBYY FlexiCapture

Im Hauptfenster des Programms wird die Liste der Dokumentstapel des geöffneten Projekts angezeigt.

Collapsed Zeigt das Hauptfenster mit der Liste der Stapel

Um den Inhalt eines Stapels anzuzeigen, doppelklicken Sie auf den Stapel. Daraufhin wird eine Liste der Dokumente im Stapel angezeigt.

Wenn Sie zur Liste der Stapel zurückkehren möchten, klicken Sie auf Ansicht>Arbeitsstapel (oder Teststapel, wenn Sie Teststapel verwenden).

Collapsed Zeigt das Hauptfenster mit dem geöffneten Stapel an

Das Hauptmenü mit den darunter liegenden Symbolleisten befindet sich am oberen Rand des Fensters.

Der Rest des Hauptfensters wird durch das Fenster des geöffneten Stapels mit der Liste der darin enthaltenen Dokumente belegt.

Die Statusleiste befindet sich am unteren Rand des Fensters. Die Statusleiste zeigt den Status des Programms und die Operationen, die gerade durchgeführt werden. Wenn Sie den Mauszeiger auf einem Menübefehl oder einer Schaltfläche positionieren, zeigt die Statusleiste eine kurze Beschreibung dazu an.

Um die erkannten Daten zu prüfen, öffnen Sie das Dokumentfenster. Doppelklicken Sie hierfür auf ein Dokument oder eine der Dokumentseiten. Das Dokumentfenster besteht aus drei Bereichen:

  • Bild der Dokumentseite;
  • Erkannte Daten;
  • Regelfehler (wird nur angezeigt, wenn Regelfehler aufgetreten sind).

Regelfehler (wird nur angezeigt, wenn Regelfehler aufgetreten sind) Überprüfung im Dokumentfenster

Collapsed Dokumentfenster anzeigen

Menü des Hauptfensters ABBYY FlexiCapture
Symbolleisten im Hauptfenster von ABBYY FlexiCapture


Menü des Hauptfensters von ABBYY FlexiCapture

Collapsed Datei
Menü | Beschreibung
Neues Projekt… | Erstellt ein neues Projekt
Projekt öffnen… | Öffnet ein vorhandenes Projekt
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert Änderungen
Neuer Stapel… | Erstellt ein neues Stapel
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt Bilder vom Scanner hinzu
Bilder importieren… | Importiert Bilder mit einem der konfigurierten Importprofile
Exportieren | Exportiert Daten mithilfe der Exporteinstellungen von Dokumentdefinitionen
Exportieren in |
Daten in Dateien… | Exportiert die Daten in eine Datei
Bilder in Dateien… | Exportiert die Bilden
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzlich geöffnete Projekte | Öffnet eines der kürzlich geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture
Collapsed Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Verbinden | Verbindet die ausgewählten Seiten zu einem Dokument
Teilen | Teilt das ausgewählte Dokument in Seiten auf
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht vorgegebenen Text
Weitersuchen | Sucht den nächsten zuvor angegebenen Text
Gehe zu |
Nächstes Dokument | Geht zum nächsten Dokument im Stapel
Vorheriges Dokument | Geht zum vorherigen Dokument im Stapel
Bild |
Störungen entfernen | Entfernt Flecken im Bild
Invertieren | Invertiert das Bild
Horizontal spiegeln | Spiegelt das Bild horizontal (in Bezug auf die vertikale Achse)
Vertikal spiegeln | Spiegelt das Bild vertikal (in Bezug auf die horizontale Achse)
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern… | Ändert die Auflösung des Bilds
Speichern unter… | Speichert das Bild unter dem angegebenen Namen
Collapsed Ansicht
Menü | Beschreibung
Teststapel | Öffnet die Liste der Stapel
Arbeitsstapel | Öffnet die Liste der Warteschlangen
Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Dokumentbilder als Miniaturansichten an
Spalten auswählen… | Ermöglicht die Konfiguration der Liste von Spalten, die in der Detailansicht angezeigt werden
Dokumenteditor |
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Positionierung des Bilds im Dokumentfenster
Fehlerfenster | Ermöglicht die Positionierung des Fehlerfensters im Dokumentfenster
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Datentextgröße | Ermöglicht die Auswahl der Schriftgröße für die Anzeige erkannter Daten
Symbolleiste anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. Über diese Symbolleiste können Sie einige der Zuordnungsfehler korrigieren, z.B. können Sie ein nicht gefundenes Feld hinzufügen oder eine Tabellentrennlinie hinzufügen bzw. löschen. Diese Funktionen werden im Wesentlichen bei der Arbeit mit FlexiLayouts verwendet.
Formatfehler des aktiven Felds anzeigen | Ermöglicht die Angabe des Anzeigemodus für Formatfehler
Bild schwarz-weiß anzeigen | Zeigt Farb- und Graustufenbilder als Schwarz-Weiß-Bilder an
Miniaturgröße | Ermöglicht die Auswahl der Größe für Miniaturansichten von Seiten
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Eigenschaften… | Öffnet das Dialogfeld für die Dokumenteigenschaften
Collapsed Erkennung
Menü | Beschreibung
Analyse | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
Erkennung | Startet die Erkennung
Collapsed Überprüfung
Menu | Beschreibung
Überprüfung ausführen… | Startet die Überprüfung
Nächstes zu überprüfendes Element | Wechselt zum nächsten Überprüfungsobjekt
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen Überprüfungsobjekt
Nächstes Dokument mit Zusammenstellungsfehler(n) | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriges Dokument mit Zusammenstellungsfehler(n) | Wechselt zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler
Collapsed Projekt
Menü | Beschreibung
Dokumentdefinitionen… | Öffnet das Dialogfeld mit der Liste der Dokumentdefinitionen, in dem Definitionen erstellt, bearbeitet, importiert und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Stapeltypen… | Öffnet das Dialogfeld mit der Liste der Stapeltypen, in dem Stapeltypen erstellt, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Bildimportprofile… | Öffnet das Dialogfeld mit der Liste der Bildimportprofile, in dem Profile erstellt, kopiert, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
In Administratormodus wechseln… | Schaltet in den Administratormodus um (dieses Menü steht nur Operatoren zur Verfügung)
Mit Kennwort schützen… | Ermöglicht den Schutz des aktuellen Projekts durch ein Passwort (dieses Menü steht nur dem Administrator zur Verfügung)
Kennwortschutz aufheben… | Ermöglicht die Deaktivierung des Passwortschutzes für das Projekt (dieses Menü steht nur dem Administrator zur Verfügung)
Projekt exportieren… | Exportiert das Projekt in den angegebenen Ordner. Bilder werden aus dem aktuellen Projekt genommen.
Projekt aktualisieren… | Konfiguriert die Projektaktualisierung. Meldungen und Fehler, die während des Exports auftreten, können in einer Datei gespeichert werden (klicken Sie mit der rechten Maustaste und wählen Sie "In Datei exportieren").
Projekteigenschaften… | Öffnet das Dialogfeld für die Projekteigenschaften
Collapsed Extras
Menü | Beschreibung
Auf neueste Version aktualisieren | Wendet die Projektänderungen auf die Dokumente an, die gerade verarbeitet werden
Neu analysieren | Wiederholt die Analyse des Dokuments
Neu erkennen | Wiederholt die Erkennung des Dokuments
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung der Seiten zu Dokumenten
Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
Stapelintegritätsprüfung | Prüft die Stapelintegrität
Stapeltyp ändern… | Ändert den Stapeltyp
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Technischer Support | Öffnet den Bereich Technischer Support in der Programmhilfe
ABBYY-Produkte erwerben | Öffnet den Bereich ABBYY FlexiCapture erwerben in der Programmhilfe
ABBYY-Website | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit einer kurzen Beschreibung des Programms


Symbolleisten im Hauptfenster von ABBYY FlexiCapture

Collapsed Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Projekt öffnen |  | Öffnet ein Projekt
Änderungen speichern |  | Speichert die Änderungen
Ausschneiden |  | Bei der Arbeit mit Daten im Dokumentfenster: schneidet das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen |  | Löscht das ausgewählte Objekt
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Collapsed Dokumentansicht

Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt Miniaturansichten der Dokumentbilder
Teststapel | Zeigt die Liste der Teststapel
Arbeitsstapel | Zeigt die Liste der Arbeitsstapel
Aktualisieren | Aktualisiert die Informationen im Hauptfenster
Collapsed Navigation

Vorheriges zu überprüfendes Element | Geht zum vorherigen Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element | Geht zum nächsten Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument | Wechselt zum vorherigen Dokument.
Nächstes Dokument | Wechselt zum nächsten Dokument.
Collapsed Verarbeitung

Diese Symbolleiste dient dazu, die gesamte Dokumentverarbeitung zu durchlaufen. Die Schaltflächen in dieser Symbolleiste sind multifunktional und haben jeweils mehrere Modi.

Der Text auf der ersten Schaltfläche zum Hinzufügen von Bildern ändert sich je nach ausgewähltem Modus. Die dem Text entsprechende Aktion wird ausgeführt, wenn Sie auf die Schaltfläche klicken.

Um den Modus auszuwählen, klicken Sie auf das Dreieck im rechten Teil der erforderlichen Schaltfläche.

Schaltfläche | Modus | Beschreibung
 | Bilder laden… | Lädt Bilder aus Dateien und fügt sie dem aktuellen Projekt hinzu
 | Bilder scannen… | Fügt dem Stapel gescannte Bilder hinzu
 | Bilder importieren… | Importiert Bilder mit einem der konfigurierten Bildimportprofile
 | Vorhandene Importprofile… | Wählen Sie zum Importieren von Bildern einfach eines der konfigurierten Bildimportprofile in der Liste aus.
 | Erkennen | Startet den Erkennungsvorgang
 | Analysieren | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
 | Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
 | Überprüfung ausführen… | Startet die Überprüfung
 | Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
 | Exportieren | Exportiert Daten mithilfe der Exporteinstellungen der Dokumentdefinition
 | Daten in Datei exportieren… | Exportiert die Daten in eine Datei
 | Bilder in Dateien exportieren | Exportiert Bilder in eine Datei
 | In Datenbank exportieren… | Exportiert die Daten in eine Datenbank


Fenster des Dokumentdefinitionseditors

Dokumentdefinitionen werden im Fenster des Dokumentdefinitionseditors erstellt und bearbeitet. Dieses Fenster ist nur auf der Projektkonfigurationsstation verfügbar.

So öffnen Sie den Dokumentdefinitionseditor im Hauptfenster des Programms:

  1. Wählen Sie die Menüoption Projekt>Dokumentdefinitionen… aus;
  2. Markieren Sie im daraufhin geöffneten Dialogfeld Dokumentdefinitionen den Namen der Dokumentdefinition, und klicken Sie auf Bearbeiten….

Das Fenster des Dokumentdefinitionseditors wird auch nach dem Beenden des Dokumentdefinitionsassistenten geöffnet.

Collapsed Fenster des Dokumentdefinitionseditors anzeigen

Das Fenster des Dokumentdefinitionseditors besteht aus drei Bereichen:

  1. Bild der Seite mit der Kennzeichnung der Felder und statischen Elemente links oben im Fenster.

    Zur Bearbeitung der Felder und statischen Elemente verfügt das Programm über zwei Modi:

    • Modus für Feldbereiche: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert;
    • Modus für statische Elemente: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert.
  2. Editor zum Konfigurieren der Darstellung erkannter Daten links unten im Fenster.
  3. Dokumentstruktur mit einer Liste aller Dokumentdefinitionsfelder (Registerkarte (Felder) im rechten Bereich des Fensters. Sie können darüber hinaus in die Gliederungsansicht (Registerkarte Seiten) wechseln.
Menü des Dokumentdefinitionseditors
Symbolleisten des Dokumentdefinitionseditors


Menü des Dokumentdefinitionseditors

Collapsed Dokumentdefinition
Menüoption | Beschreibung
Seiten hinzufügen… | Fügt ein neues Seitenbild zur Dokumentdefinition hinzu
Dokumentbereich hinzufügen… | Fügt einen neuen Bereich zum Stapel hinzu
Dokumentbereich importieren | IImportiert den ausgewählten Dokumentbereich
Skriptmodule |
Regelskript… | Öffnet das Regel für globales Skriptmodul im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter Verwenden von Skripten in FlexiCapture.
Exportskript… | Öffnet das Globales Skriptmodul exportieren im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter UVerwenden von Skripten in FlexiCapture.
Exporteinstellungen… | Öffnet das Dialogfeld Exporteinstellungen zum Konfigurieren der Optionen für den Datenexport
Eigenschaften der Dokumentdefinition… | Öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der Eigenschaften der Dokumentdefinition
Speichern | Speichert Änderungen
Schließen | Schließt den Dokumentdefinitionseditor
Collapsed Bearbeiten
Menüoption | Beschreibung
Rückgängig machen | Macht die vorherige Aktion rückgängig
Wiederherstellen | Stellt die rückgängig gemachte Aktion wieder her
Ausschneiden | Schneidet die markierten Objekte aus
Kopieren | Kopiert die markierten Objekte in die Zwischenablage
Einfügen | Fügt den Inhalt der Zwischenablage ein
Löschen | Löscht die markierten Objekte
Bereich löschen | Entfernt Bereiche aus den Bildern der markierten Objekte
Alles auswählen | Wählt alle Objekte aus
Bereiche nach Typ auswählen… | Erkennt bestimmte Objekttypen
Create Field |
Text | Fügt der Dokumentstruktur ein Texteingabefeld hinzu (ohne Bereich im Bild)
Auswahlfeld | Fügt der Dokumentstruktur ein Auswahlfeld hinzu (ohne Bereich im Bild)
Auswahlfeldgruppe | Fügt der Dokumentstruktur eine Gruppe von Auswahlfeldern hinzu (ohne Bereich im Bild)
Barcode | Fügt der Dokumentstruktur ein Barcodefeld hinzu (ohne Bereich im Bild)
Bild | Fügt der Dokumentstruktur ein Bildfeld hinzu (ohne Bereich im Bild)
Tabelle | Fügt der Dokumentstruktur ein Tabellenfeld hinzu (ohne Bereich im Bild)
Gruppe | Fügt der Dokumentstruktur eine Gruppe von Feldern hinzu (ohne Bereich im Bild)
Gruppe | Gruppiert die markierten Objekte
Gruppierung aufheben | Hebt die Gruppierung der markierten Objekte auf
Text aus Bild kopieren… | Kopiert Text aus einem Bereich des Bilds und speichert ihn in der Zwischenablage. Markieren Sie nach der Auswahl dieses Befehls den Bereich, in dem sich der gewünschte Text befindet.
Bild... |
Störungen entfernen | Entfernt Störungen im Bild
Invertieren | Invertiert das Bild
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern… | Öffnet das Dialogfeld Auflösung einstellenin dem Sie einen neuen Bildauflösungswert eingeben können
Speichern unter… | Speichert das Bild der Vorlagenseite in der angegebenen Datei
Ersetzen… | Ersetzt das Bild der Vorlagenseite
Collapsed Ansicht
Menüoption | Beschreibung
Bildlayout |
Statische Elemente | Wechselt in den Modus für statische Elemente
Feldbereiche | Wechselt in den Modus für Feldbereiche
Dokumentstruktur |
Dokumentstruktur anzeigen | Blendet das Fenster Dokumentstruktur ein oder aus
Felder | Schaltet das Fenster Dokumentstruktur in den Feldmodus um
Seiten | Schaltet das Fenster Dokumentstruktur in den Seitenmodus um
Datenformular | Blendet das Fenster des Dateneditors ein oder aus
Symbolleiste "Layout" |
Horizontal | Dockt die Symbolleiste horizontal im Bildlayoutfenster an
Vertikal | Dockt die Symbolleiste vertikal im Bildlayoutfenster an
Statusleiste | Blendet die Statusleiste ein oder aus
Bild schwarz-weiß anzeigen | Zeigt die Farb- und Graustufenbilder von Seiten im Schwarz-Weiß-Modus an
Bildanzeige | Legt eine geeignete Bildskalierung fest
Eigenschaften… | Öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der Eigenschaften des markierten Objekts
Collapsed Testen
Menüoption | Beschreibung
Test ausführen | Startet das Testen von Dokumentdefinitionen anhand des Dokumentbilds.
Test beenden | Beendet das Testen der Dokumentdefinition.
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an.
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an.
Layout |
Bildfenster | Ändert die Position des Bilds im Dokumentfenster.
Oben | Positioniert das Bildfenster oben auf dem Bildschirm.
Unten | Positioniert das Bildfenster unten auf dem Bildschirm.
Links | Positioniert das Bildfenster links.
Rechts | Positioniert das Bildfenster rechts.
Fehlerfenster | Ändert die Position des Fehlerfensters im Dokumentfenster.
Oben | Positioniert das Fehlerfenster oben auf dem Bildschirm.
Unten | Positioniert das Fehlerfenster unten auf dem Bildschirm.
Links | Positioniert das Fehlerfenster links.
Rechts | Positioniert das Fehlerfenster rechts.
Symbolleiste anzeigen | Blendet die Symbolleiste im Datenmodus ein oder aus. Im Bildmodus wird die Symbolleiste ständig angezeigt und kann nicht ausgeblendet werden.
Überprüfung |
Nächstes zu überprüfendes Element | Wechselt zum nächsten zu überprüfenden Element.
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen zu überprüfenden Element.
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutigen Zeichen.
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutigen Zeichen.
Nächster Regelfehler | Wechselt zum nächsten Regelfehler.
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler.
Collapsed Stapel
Menüoption | Beschreibung
Zu Teststapel wechseln… | Ermöglicht das Testen der Dokumentdefinition mit Teststapeln
Teststapel schließen… | Schließt den Teststapel
Ansicht |
Details | Wechselt in den Detailansichtsmodus
Miniaturansichten | Wechselt in den Miniaturansichtsmodus
Dokumenttabelle anpassen… | Öffnet das Dialogfeld Spalten auswählen, in dem Sie die Spalten auswählen können, die angezeigt werden sollen, und deren Aussehen anpassen können
Bilder laden… | Öffnet das Dialogfeld Bilder laden, in dem Sie die Bilder auswählen können, die geladen werden sollen, und die Optionen für die Bildvorverarbeitung bestimmen können
Bilder scannen… | Öffnet das Dialogfeld, in dem Sie Bilder scannen können, die dem Stapel hinzugefügt werden sollen
Erkennung | Erkennt den Stapel
Überprüfung ausführen… | Startet die Überprüfung des Stapels
Exportieren | Exportiert den Stapel
Exportieren in |
Daten in Dateien… | Öffnet das Dialogfeld, in dem Sie die Datenspeicherungsoptionen bestimmen können
Bilder in Dateien… | Öffnet das Dialogfeld, in dem Sie die Bildspeicherungsoptionen bestimmen können
Datenbank… | Öffnet das Dialogfeld, in dem Sie die Datenbankverbindungseinstellungen konfigurieren können
Collapsed Extras
Menüoption | Beschreibung
Objekte automatisch nach Typ erkennen… | Erkennt und markiert automatisch Felder und statische Elemente eines bestimmten Typs (je nach Modus)
Dokumentdefinition überprüfen | Überprüft die Dokumentdefinition
Bereich zuordnen | Überprüft die Zuordnung eines Dokumentdefinitionsbereichs
FlexiLayouts aktualisieren… | Ermöglicht die Aktualisierung verwendeter FlexiLayouts
Collapsed Hilfe
Menüoption | Beschreibung
Hilfethemen | Öffnet die Hilfethemen von ABBYY FlexiCapture
Feedback senden… | Über diesen Link können Benutzer ihre Kommentare und Anregungen an ABBYY senden.


Symbolleisten des Dokumentdefinitionseditors

Collapsed Symbolleiste "Standard"

Name | Schaltfläche | Beschreibung
Änderungen speichern |  | Speichert Änderungen
Ausschneiden |  | Schneidet beim Bearbeiten der Daten im Dokumentfenster das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt ein zuvor kopiertes Objekt aus der Zwischenablage ein
Löschen |  | Löscht ein markiertes Objekt
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Dokumentdefinition überprüfen |  | Überprüft eine Dokumentdefinition. Die Ergebnisanzeige erfolgt unten im Fenster des Dokumentdefinitionseditors
Collapsed Symbolleiste im Bildlayoutfenster

Über die Symbolleiste im Bildlayoutfenster können statische Elemente und Dokumentdefinitionsfelder erstellt werden. Die Symbolleiste enthält je nach dem ausgewählten Modus unterschiedliche Schaltflächen.

Modus für statische Elemente:

Modus für Feldbereiche:

Die Symbolleiste kann horizontal oder vertikal im Fenster angedockt werden. Die Ausrichtung der Symbolleiste kann unter Ansicht > Symbolleiste "Layout" geändert werden.

Name | Schaltfläche | Beschreibung
Allgemein
Modus für statische Elemente |  | Wechselt in den Modus für statische Elemente
Modus für Feldbereiche |  | Wechselt in den Modus für Feldbereiche
Zoom |  | Vergrößert die Bildanzeige
Objekte automatisch erkennen |  | Erkennt automatisch Objekte im Bild. Wählen Sie dieses Tool und klicken anschließend mit der linken Taste in den Objektbereich.
Bereiche auswählen |  | Hebt die Objektbereiche hervor, die im Bild markiert wurden. Wählen Sie zum Hervorheben eines Bereichs dieses Tool und klicken anschließend mit der linken Taste in den Objektbereich.
Modus für statische Elemente
Anker erstellen |  | Erstellt einen Anker. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Anker.
Trennzeichen erstellen |  | Erstellt ein Trennzeichen. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um das Trennzeichen.
Ankertext erstellen |  | Erstellt einen Ankertext. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Text.
Ankerbarcode erstellen |  | Erstellt einen Ankerbarcode. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Modus für Feldbereiche
Create Text |  | Erstellt ein Texteingabefeld. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Texteingabebereich.
Create Checkmark |  | Erstellt ein Auswahlfeld. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Auswahlfeldbereich.
Create Checkmark Group |  | Erstellt eine Gruppe von Auswahlfeldern. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Gruppe von Auswahlfeldern.
Create Barcode |  | Erstellt ein Barcodefeld. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Create Picture |  | Erstellt ein Bildfeld. Wählen Sie auf dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um das Bild.
Create Table |  | Erstellt ein Tabellenfeld. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Tabelle. In der Symbolleiste werden weitere Schaltflächen für Markierungen in Tabellen angezeigt.
Create Group |  | Erstellt eine Feldgruppe. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Feldgruppe.
Create Region for Field without Region |  | Erstellt einen Bereich für ein Feld, das in der Dokumentstruktur enthalten ist, dem jedoch im Bild kein Bereich zugewiesen ist. Wählen Sie dieses Tool und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Bereich des Felds. Wählen Sie in der Dropdownliste einen Namen aus. (In der Liste sind die Namen der Felder aufgeführt, denen im Bild kein Bereich zugeordnet ist.)
Create Unrecognizable Region |  | Markiert ein Feld, das beim Erkennungsvorgang ausgeschlossen werden soll.
Schaltflächen zum Markieren in Tabellen Diese Schaltflächen werden angezeigt, wenn in einem Dokumentdefinitionsbereich mindestens eine Tabelle erstellt wurde.
Trennzeichen löschen |  | Löscht ein Trennzeichen


Fenster für die Gruppenüberprüfung

Das Fenster für die Gruppenüberprüfung wird nach dem Start der Überprüfung angezeigt. Dieses Fenster dient dazu, die mit demselben Wert erkannten Zeichen visuell zu prüfen. Als gleich erkannte Zeichen werden angezeigt, um die Identifizierung zu ermöglichen und abweichende Zeichen zu korrigieren. Siehe Gruppenüberprüfung.
Menü im Fenster für die Gruppenüberprüfung
Symbolleiste im Fenster für die Gruppenüberprüfung


Menü im Fenster für die Gruppenüberprüfung

Collapsed Überprüfung
Menü | Beschreibung
Alle bestätigen | Bestätigt die korrekte Überprüfung aller Zeichen und wechselt zur nächsten Phase
Alle aufschieben | Schiebt die Überprüfung aller Zeichen auf und kennzeichnet sie mit einem Fragezeichen
Status ändern | Schiebt die Überprüfung des ausgewählten Zeichens auf und kennzeichnet es mit einem Fragezeichen
Nächste Seite | Geht zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Vorherige Seite | Geht zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Schließen | Schließt das Überprüfungsfenster
Collapsed Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Alles auswählen | Wählt alle Zeichen aus
Collapsed Ansicht
Menü | Beschreibung
Feldbild |
Feldbild anzeigen | Blendet das Bild des Felds mit dem aktuellen Zeichen ein bzw. aus
Oben | Positioniert das Feldbild im oberen Bereich des Überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des Überprüfungsfensters
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Feldbild anzeigen | Blendet das Bild des Zeichens ein
Symbolleiste | Blendet die Symbolleisten ein oder aus
Infoleiste | Blendet die Infoleiste ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Zeichengröße | Ermöglicht die Auswahl der geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Collapsed Extras
Menü | Beschreibung
Optionen… | Ermöglicht die Einstellung des an das Zeichen angrenzenden Bereichs
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit kurzen Informationen zum Programm.


Symbolleisten im Fenster für die Gruppenüberprüfung

Collapsed Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Vorherige Seite |  | Geht zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Nächste Seite |  | Geht zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Alle bestätigen |  | Bestätigt die korrekte Erkennung aller Zeichen und wechselt zur nächsten Phase
Zeichenstatus ändern |  | Ändert den Zeichenstatus (in abgelehnt und zurück)
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her


Fenster für die Feldüberprüfung

Das Fenster für die Feldüberprüfung wird nach Beendigung der Gruppenüberprüfung angezeigt.

Dieses Fenster dient dazu, nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds visuell zu prüfen. Siehe Feldüberprüfung.

Menü im Fenster für die Feldüberprüfung
Symbolleisten im Fenster für die Feldüberprüfung


Menü im Fenster für die Feldüberprüfung

Collapsed Überprüfung
Menü | Beschreibung
Feld bestätigen | Bestätigt das Feld
Aufschieben | Schiebt die Feldüberprüfung auf
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes Feld | Wechselt zum nächsten Feld
Vorheriges Feld | Wechselt zum vorherigen Feld
Schließen | Schließt das Überprüfungsfenster
Collapsed Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Alle löschen | Löscht alle Objekte
Alles auswählen | Wählt alle Objekte aus
Zeilenumbruch einfügen | Fügt einen Zeilenumbruch ein
Zeichen verbinden | Verbindet die ausgewählten Zeichen, wenn ein Zeichen während der Erkennung in mehrere Zeichen aufgeteilt wurde
Collapsed Ansicht
Menü | Beschreibung
Felddaten |
Erkannter Text | Blendet den erkannten Text ein oder aus
Zeichenausschnitt | Wechselt in die Feldansicht mit Zeichenbildausschnitt
Sonderzeichen anzeigen | Blendet Sonderzeichen ein bzw. aus
Feldbild |
Feldbild anzeigen | Blendet das Bild des Felds mit dem aktuellen Zeichen ein bzw. aus
Oben | Positioniert das Feldbild im oberen Bereich des Überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des Überprüfungsfensters
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Analoge Felder | Blendet ähnliche Felder in anderen Dokumenten ein bzw. aus
Zeichenbild anzeigen | Blendet das Bild des Zeichens ein
Symbolleiste | Blendet die Symbolleisten im Hauptfenster ein oder aus
Infoleiste | Blendet die Infoleiste ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Character Size | Ermöglicht die Auswahl der geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Collapsed Extras
Menü | Beschreibung
Optionen… | Ermöglicht die Einstellung des an das Zeichen angrenzenden Bereichs
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit kurzen Informationen zum Programm.


Fenster des Skripteditors

Mit dem Skripteditor können Sie Skripte schreiben und bearbeiten.

Sie können eine gewünschte Skriptsprache für Ihr Skript auswählen: VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net oder JScript.Net.

Die gewählte Sprache wird auch verwendet, wenn Sie den Editor das nächste Mal starten.

Überprüfen von Skripten

Es gibt mehrere Möglichkeiten, um das Debugging eines Skripts zu beginnen:

  • Drücken Sie F9
  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Überprüfen
  • Öffnen Sie das Menü Extras und klicken Sie auf Skript überprüfen

Wurden keine Fehler festgestellt, wird die Nachricht Skript ist korrekt. angezeigt.

Enthält das Skript Fehler, erscheint im Fehlerfenster eine Liste der Fehler. Doppelklicken Sie auf eine Fehlermeldung im Fehlerbereich, um den Mauszeiger über der Stelle mit dem Fehler im Skripteditor zu positionieren.

Hinweis: Sie können fehlerhafte Skripte speichern und die Fehler später beheben.

Standardmäßig wird das Fenster mit den Fehlermeldungen unten im Editor angezeigt. Sie können die Größe dieses Fensters mit der Maus ändern. Sie können auch seine Position ändern (weitere Informationen finden Sie weiter unten).

Anpassen des Editors

Im Menü Ansicht können Sie das Erscheinungsbild des Editors anpassen. Das Menü Ansicht enthält die folgenden Elemente:

  • Fehlerfenster
    Verändert die Position des Fehlerfensters im Editor. Sie können es oben, unten (Standard), rechts oder links anordnen.
  • Symbolleiste
    Zeigt oder verbirgt die Symbolleiste.
  • Statusleiste
    Zeigt oder verbirgt die Statusleiste.

Hinzufügen einer benutzerdefinierten Funktion

Um eine benutzerdefinierte Funktion hinzuzufügen, wählen Sie in der Dropdownliste der Symbolleiste eines der folgenden globalen Module: Skript in <object_name\document_defenition_name>, Regel für globales Skriptmodul, Globales Skriptmodul exportieren

Mehr Informationen über Skripte in ABBYY FlexiCapture finden Sie im Artikel "Verwenden von Skripten".


ABBYY FlexiCapture for Invoices

You are here: ABBYY FlexiCapture for Invoices

Was ist ABBYY FlexiCapture for Invoices?

  • ABBYY FlexiCapture for Invoices ist eine leicht zu bedienende, intelligente Softwarelösung für die Verarbeitung von Rechnungen. Sie ersetzt arbeitsintensive Aufgaben der Dateneingabe durch eine transparente, handliche, effiziente und automatisierte Datenerfassung auf der Basis einer intelligenten Dokumentanalyse und von Technologien zur Zeichenerkennung.
  • ABBYY FlexiCapture for Invoices basiert auf der leistungsstarken ABBYY FlexiCapture-Plattform und beinhaltet Zusatzfunktionen, vordefinierte Einstellungen, Validierungsregeln, eine erweiterte Datenbanksuche und Verbesserungen der Benutzeroberfläche, die speziell auf die Verarbeitung von Rechnungen zugeschnitten sind.
  • ABBYY FlexiCapture for Invoices ist eine einsatzbereite Lösung, mit der Datenfelder der meisten Rechnungen identifiziert werden können, sodass die Verarbeitung sofort beginnen kann. Die intelligente und direkte Auto-Training-Technologie verfeinert die Extraktion von Daten aus Rechnungen mit nicht dem Standard entsprechenden Layouts.
  • ABBYY FlexiCapture for Invoices bietet landesspezifische Validierungsregeln, anpassbare logische und arithmetische Überprüfungen und kann die erfassten Daten mit den Datenbanken des Unternehmens abgleichen, was Rechtssicherheit und Datenkonsistenz gewährleistet, die Freigabe von Rechnungen und die Erkennung von Falschrechnungen ermöglicht. Die flexiblen Einstellungen des Programms ermöglichen Ihnen die Anpassung des Verarbeitungsworkflows in Übereinstimmung mit den spezifischen Geschäftsanforderungen des Unternehmens und die Implementierung einer direkten Verarbeitung von Rechnungen, die erfolgreich alle automatischen Validierungsregeln durchlaufen haben, sodass sich das Prüfpersonal auf die Dokumente konzentrieren kann, die wirklich deren Aufmerksamkeit erfordern.

Prozess der Rechnungserfassung

  1. Erfassen von Bildern

    2. Es gibt mehrere Möglichkeiten, das Programm mit Rechnungsbildern zu versorgen:

    • Scannen gedruckter Rechnungen
    • Herunterladen der Rechnungsbilder von einem E-Mail-Posteingang
    • Herunterladen der Rechnungsbilder von einem Ordner auf einem Computer oder einem FTP-Server
  2. Erkennung und Regelprüfungen

    Nach der Eingabe werden die Rechnungen vom Programm automatisch erkannt. Die Daten aus den Rechnungen werden dann anhand von Regeln geprüft und der Rechnung wird basierend auf dem Ergebnis dieser Prüfung ein Status zugewiesen.

    Status | Beschreibung
    Gültig | Die Regelüberprüfungen wurden erfolgreich abgeschlossen und die Rechnung kann jetzt exportiert werden
    Abgelehnt | Die Rechnung muss überprüft werden
    Ausnahme | Die Rechnung entspricht nicht der Gesetzgebung (die erforderlichen Daten konnten nicht gefunden werden, fehlen oder wurden falsch erkannt). Diese Daten müssen manuell angegeben oder die Rechnung muss auf andere Weise verarbeitet werden (z. B. Rückgabe an den Lieferanten)

    Rechnungen, die nicht bearbeitet werden müssen, erhalten den Status Gültig und sind bereit für den Export.

  3. Überprüfung und Korrektur von Fehlern

    4. Rechnungen mit einem anderen Status als Gültig müssen von einem Operator überprüft werden. Operatoren überprüfen diese Dokumente und korrigieren Fehler und Warnungen, die von den Prüfregeln ausgegeben wurden. Sobald alle Fehler korrigiert wurden, erhält eine Rechnung den Status Gültig. Die Operatoren können außerdem einen Status bestätigen, der automatisch zugewiesen wurde. Der Status einer Rechnung kann durch einen Operator manuell geändert werden, der dabei einen Grund für die Statusänderung angeben muss.

    Gelingt es dem Programm dauerhaft nicht, Felder auf der Rechnung zu lokalisieren, kann das Programm während der Dokumenterfassung durch den Operator trainiert werden.

  4. Datenexport

    5. Der Datenexport ist die letzte Verarbeitungsphase, in der die Daten gemäß den Einstellungen des Programms exportiert werden. Dokumente mit verschiedenem Status können auf verschiedene Weise exportiert werden, z. B. können Dokumente mit dem Status Gültig und Ausnahme in einen anderen Ordner exportiert werden als Dokumente mit dem Status Abgelehnt. Es können mehrere Exportziele eingerichtet und die Rechnungen können zu jedem dieser Ziele exportiert werden.

    Wurde der Status einer Rechnung manuell geändert, wird der vom Operator angegebene Grund für die Statusänderung auch exportiert.

    Das Programm unterstützt den Export zu Daten- und Bilddateien, ODBC-kompatiblen Datenbanken und Microsoft SharePoint. Die einfach bedienbare API ermöglicht die Integration in jedes System.

Für weitere Informationen über die Erfassung von Rechnungen mit ABBYY FlexiCapture for Invoices See "Erfassen von Rechnungen"."

ABBYY FlexiCapture for Invoices konfigurieren

ABBYY FlexiCapture for Invoices enthält ein vorkonfiguriertes Projekt, das sofort einsatzbereit ist.

Bevor Sie mit der Rechnungserfassung beginnen, müssen Sie dem Programm Daten über Lieferanten und Geschäftseinheiten bereitstellen. Das Programm kann dann anhand dieser Daten Felder finden und erkennen, die Daten zu Lieferanten und Geschäftseinheiten im Rechnungsbild enthalten. Werden Lieferanten- und Geschäftseinheitsdaten nicht bereitgestellt, muss ein Operator die Position dieser Felder manuell festlegen. In diesem Fall werden die erkannten Daten gespeichert und während der Verarbeitung von Rechnungen dieses Lieferanten/dieser Geschäftseinheit verwendet.

Auch wenn ABBYY FlexiCapture for Invoices vorkonfiguriert und einsatzbereit ist, kann eine Reihe zusätzlicher Einstellungen festgelegt werden:

  • Sie können der Felderliste weitere Felder hinzufügen, die aus der Rechnung extrahiert werden sollen. Diese Felder können vordefinierte Felder enthalten, die standardmäßig deaktiviert sind, sowie alle anderen Felder.
  • Der Satz von Regeln kann an verschiedene Organisationen und Gesetzgebungen angepasst werden.
  • Rechnungen eines bestimmten Lieferanten enthalten unter Umständen ein nicht dem Standard entsprechendes Layout, was zu einer unbefriedigenden Qualität der Datenerfassung führt. ABBYY FlexiCapture for Invoices kann trainiert werden, um die Qualität der erfassten Daten aus solchen Rechnungen zu verbessern.
  • Erfasste Rechnungen können den Bestellungen zugeordnet werden.

Zu weiteren Informationen über die Einrichtung von ABBYY FlexiCapture for Invoices See "Einrichtung eines Projekts zur Rechnungserfassung".See "Einrichtung eines Projekts zur Rechnungserfassung"

Hinweis: Um ABBYY FlexiCapture zu verwenden, benötigen Sie eine entsprechende ABBYY FlexiCapture-Lizenz. Zu weiteren Informationen über Lizenzen See "Lizenzparameter".


Funktionen von ABBYY FlexiCapture for Invoices

Erkennung und Datenextraktion

Für die Rechnungsverarbeitung angepasstes FlexiLayout

ABBYY FlexiCapture for Invoices beinhaltet ein einsatzbereites FlexiLayout, das speziell für die sofortige Verarbeitung von Rechnungen angepasst wurde. Es enthält einen vordefinierten Satz von Datenfeldern für die Erkennung, der durch zusätzliche Felder erweitert werden kann. Dieses FlexiLayout ermöglicht die Erkennung aller benötigten Datenfelder aus den meisten Dokumenten ohne zusätzliche Anpassungen oder das Zurückgreifen auf integrierte Trainingsfunktionen.
Landesspezifische Einstellungen

ABBYY FlexiCapture for Invoices bietet eine vordefinierte Reihe von Verarbeitungsregeln und anderen landesspezifischen Einstellungen, die dann angewendet werden, sobald das Programm das Land der abrechnenden Geschäftseinheit identifiziert hat. Automatische Validierungsregeln gewährleisten, dass die Daten den landesspezifischen Verordnungen oder Verfahren entsprechen.

Diese einsatzbereiten Einstellungen stehen für eine Liste speziell unterstützter Länder zur Verfügung, die die Länder Österreich, Belgien, Frankreich, Deutschland, Niederlande, Spanien, Schweiz und Großbritannien beinhaltet. Während der Einrichtung kann vom Benutzer für jedes andere Land ein neues Profil hinzugefügt werden.
Validierungsregeln

Überprüfungen mithilfe vordefinierter Validierungsregeln gewährleisten die Konsistenz der Daten und unterstützen bei der Erkennung falscher oder unvollständiger Rechnungen und problematischer Felder. Während der automatischen Überprüfung erkannte Fehler wirken sich auf den Dokumentstatus aus. Das erlaubt die Unterscheidung völlig korrekter Dokumente von Ausnahmen, die eine spezielle Handhabung erfordern.

Bei der Überprüfungsphase werden die durch Validierungsregeln erkannten Fehler mit kurzen Kommentaren bereitgestellt, die die Art des Fehlers erläutern.
Erkennung des Dokumentstatus

Jede Rechnung erhält einen von drei möglichen Statusarten, die einem Dokument automatisch auf der Basis der Ergebnisse der Überprüfung durch die Validierungsregeln zugewiesen werden. Die Erkennung des Dokumentstatus führt eine Differenzierung der Rechnungen durch und ermöglicht eine Verarbeitung vollständig korrekter Dokumente ohne die Notwendigkeit, einzugreifen.

Rechnungen ohne Fehler wird dem Status "Gültig" zugewiesen, Rechnungen mit kleinen Fehlern, die einer speziellen Aufmerksamkeit bedürfen, wird der Status "Ausnahme" zugewiesen und diejenigen, die nicht den gesetzlichen Anforderungen entsprechen oder in denen Daten fehlen, wird der Status "Abgelehnt" zugewiesen.

Der Status eines Dokuments wechselt automatisch zu "Gültig", sobald die Fehler korrigiert wurden. Der prüfende kann den zugewiesenen Status bestätigen oder eine Statusänderung erzwingen und in einem Kommentarfeld die Gründe für diese Entscheidung eingeben. Für Rechnungen mit dem Status "Abgelehnt" kann ein spezielles Exportziel festgelegt werden.
Erweiterte Datenbanksuche

Während der Erkennung vergleicht die Software die Rechnungsdaten mit den jeweiligen Lieferanten- und Geschäftseinheitsdatenbanken des Benutzers. Die Feldwerte werden automatisch von diesen Datenbanken bezogen, sofern die korrekten Einträge zuverlässig erkannt wurden. Wird kein oder werden mehrere Einträge in der Datenbank gefunden, kann der prüfende den korrekten Eintrag manuell auswählen.
Kontrolle von Rechnungspositionen

Wurde eine Verbindung zu einer Datenbank mit Bestellungen oder Verträgen eingerichtet, können die Rechnungsdaten in der Überprüfungsphase mit den jeweiligen Bestellungen verglichen werden. In diesem Fall kann der prüfende eine übereinstimmende Bestellung aus der Datenbank öffnen, deren Daten mit denen der Rechnung vergleichen und die erfassten Daten aus dem jeweiligen Feld bestätigen.

Mobile Trainingstechnologie

Operatorgesteuertes Training

Um die Erkennung von Datenfeldern zu verbessern, bietet ABBYY FlexiCapture for Invoices ein mobiles Training, durch das sich die Software vom Benutzer in der Überprüfungsphase durchgeführte Korrekturen merkt und das FlexiLayout automatisch um neue FlexiLayout-Alternativen erweitert.
Administratorgesteuertes Training

Die Datenerkennung kann außerdem durch die Überprüfung der Ergebnisse des operatorgesteuerten Trainings verbessert werden. Ein Administrator kann diese Ergebnisse überprüfen, zurücksetzen oder korrigieren, den für das Training verwendeten Dokumentensatz anzeigen und bearbeiten und die als Ergebnis des operatorgesteuerten Trainings erstellten Alternativen deaktivieren oder aktivieren.

Benutzeroberfläche der Überprüfung

Speziell entwickeltes Formular für die Datenüberprüfung

Die intuitive Überprüfungsoberfläche von ABBYY FlexiCapture for Invoices wurde sorgfältig speziell für die Arbeit mit diesem Dokumenttyp entwickelt. Die Datenfelder auf dem Überprüfungsformular wurden gruppiert und so angeordnet, wie es für Rechnungen am praktikabelsten ist. Die Schlüsselfelder werden durch einen Schnappschuss des Originalbildes ergänzt. Die Pflichtfelder sind hervorgehoben; Warn- und Fehlermeldungen werden gemeinsam mit den Kommentaren angezeigt, um so schnelle und exakte Korrekturen zu ermöglichen.

Das Formular für die Datenüberprüfung und die Reihenfolge, in der die Felder überprüft werden sollen, können auf einfache Weise den Anforderungen des Benutzers und etablierten Verfahren angepasst werden.

Konfiguration

Länderbereich

Solche Einstellungen wie beispielsweise Sprache, Währung, Datumsformate, Zahlenformate, Validierungsregeln, Steuersätze usw. sind landesabhängig. ABBYY FlexiCapture for Invoices stellt Standardeinstellungen für die speziell unterstützten Länder bereit. Diese Einstellungen können bei Bedarf vom Benutzer angepasst werden.

Der Benutzer kann problemlos ein neues Profil hinzufügen und die korrekten Einstellungen für jedes andere Land festlegen, für das in der Software derzeit keine Standardeinstellungen verfügbar sind.


Erfassen von Rechnungen

Das Erfassen von Rechnungen umfasst die folgenden Schritte:

  • Hinzufügen und Erkennen von Bildern
  • Überprüfung und Korrektur von Fehlern
  • Exportieren der überprüften Daten


Hinzufügen und Erkennen von Bildern

Hinzufügen von Bildern

Die Rechnungsverarbeitung beginnt mit dem Hinzufügen von Dokumentbildern.

Hinweis: Die hinzugefügten Bilder müssen vor der Verarbeitung in Dokumente aufgeteilt werden. Die Aufteilung der Dokumente kann in den Importeinstellungen konfiguriert werden, See "Bildimportprofile"

Dafür gibt es mehrere Möglichkeiten:

  • Scannen von Papierdokumenten mit einem Scanner
  • Hinzufügen vorhandener Scans aus einem Ordner
  • Verwendung eines Bildimportprofils, das vom Administrator festgelegt wurde (Importieren der Bilder von einem Scanner, Hot Folder oder einem E-Mail-Postfach).

Für weitere Informationen über die Möglichkeiten für das Importieren von Bildern See "Hinzufügen von Seitenbildern".

Erkennung

Nachdem die Bilder hinzugefügt wurden, beginnt die Erkennung automatisch.

Eine erkannte Rechnung erhält den Namen Europäische Rechnung und die Spalten Rechnungsstatus und Grad der Zuverlässigkeit werden ausgefüllt.

Collapsed Was ist zu tun, wenn Dokumente nicht automatisch erkannt werden

Wählen Sie die Dokumente aus, öffnen Sie das Menü Erkennung und klicken Sie auf Erkennung.

Um die automatische Erkennung zu aktivieren, wählen Sie Hinzugefügte Bilder automatisch erkennen auf der Registerkarte Dokumentverarbeitung (Extras>Optionen…).

Collapsed Wenn Dokumente nach der Erkennung mit <Unbekannt> benannt werden
  1. Prüfen Sie die Spalte Hinweise zur Verarbeitung, um zu sehen, warum das Dokument nicht erkannt wurde.

    Beispiel: Prüfen Sie die Erkennungssprache. Das bedeutet, dass die Sprache der Rechnung nicht unterstützt wird. Wenden Sie sich an Ihren Administrator.

  2. Öffnen Sie das Dokument und stellen Sie sicher, dass es sich um eine Rechnung handelt.
  3. Wenden Sie die Dokumentdefinition manuell an.
    4. Collapsed Manuelle Anwendung einer Dokumentdefinition
    1. Klicken Sie mit der rechten Maustaste auf das Dokument und wählen Sie Dokumentdefinition zuordnen… aus dem Kontextmenü. Ein Dialogfeld mit einer Liste von Dokumentdefinitionen wird geöffnet.
    2. Wählen Sie Europäische Rechnung in der Liste und klicken Sie auf OK.


Überprüfung

In dieser Phase werden die zu überprüfenden Dokumente durchgesehen und Fehler korrigiert.

Ein Dokument muss überprüft werden, wenn

  • sein Status nicht Gültig ist (überprüfen Sie die Spalte Rechnungsstatus in der Dokumentliste)

  • durch die Validierungsregeln Fehler erkannt wurden (auf dem Dokumentsymbol wird eine rote Markierung angezeigt)

  • die Anzahl der zu überprüfenden Objekte größer ist als 0 (prüfen Sie die Spalte Zu überprüfende Zeichen in der Dokumentliste)

Öffnen Sie ein zu überprüfendes Dokument im Dokumenteditor, um mit der Überprüfung zu beginnen.


Rechnungsstatus

Ein Status wird den Rechnungen auf der Basis von Regelprüfungen und/oder von Operatoren durchgeführten manuellen Überprüfungen zugewiesen. Der Status wird in der Dokumentliste in der Spalte Rechnungsstatus angezeigt.

Status | Beschreibung
Gültig | Die Regelüberprüfungen wurden erfolgreich abgeschlossen und die Rechnung kann jetzt exportiert werden
Abgelehnt | Die Rechnung muss überprüft werden
Ausnahme | Die Rechnung entspricht nicht der Gesetzgebung (die erforderlichen Daten konnten nicht gefunden werden, fehlen oder wurden falsch erkannt). Diese Daten müssen manuell angegeben oder die Rechnung muss auf andere Weise verarbeitet werden (z. B. Rückgabe an den Lieferanten)

Der Status einer Rechnung wird automatisch nach Validierungsregeln bestimmt. Wurden Fehler korrigiert, werden die Überprüfungsregeln erneut ausgeführt und der Rechnung wird automatisch ein neuer Status zugewiesen. Zu ausführlichen Informationen See "Verfügbare Regeln".

Enthält eine Rechnung Fehler, die nicht korrigiert werden konnten und trägt einen anderen Status als Gültig, muss der Status vom Operator bestätigt werden. Solche Rechnungen werden dann getrennt von den korrekt verarbeiteten Rechnungen exportiert (soweit vom Administrator festgelegt).

Der Status einer Rechnung kann manuell festgelegt werden. Beispiel: Um dem Programm das Exportieren von Rechnungen zu erlauben, die nicht allen Regeln entsprechen, kann der Operator deren Status auf Gültig ändern. Ähnlich verhält es sich mit dem Status einer Rechnung, die allen Regeln entspricht, aber nicht exportiert werden soll, er muss manuell geändert werden zu Abgelehnt oder Ausnahme.

Collapsed Ändern des Status' einer Rechnung

Der aktuelle Status einer Rechnung und eine Beschreibung der Regel, die für die Bestimmung des Status verwendet wurde, werden im oberen Bereich des Datenformulars angezeigt. Der Grund für die manuelle Statusänderung wird evtl. auch hier angezeigt. Um den Status einer Rechnung zu ändern, gehen Sie wie folgt vor:

  1. Klicken Sie rechts neben dem Status auf die Schaltfläche [image].
  2. Wählen Sie den Status aus, den Sie zuweisen möchten.
  3. Wählen Sie den Grund für die manuelle Statusänderung oder geben Sie Ihren eigenen Grund ein (sofern die Eingabe eines benutzerdefinierten Grundes durch den Administrator nicht untersagt wurde).


Korrigieren von Erkennungsfehlern

Während der Überprüfung werden Rechnungen mit dem Status Ausnahme oder Abgelehnt überprüft und Fehler werden korrigiert. Um die Überprüfung einer Rechnung zu starten, führen Sie einen Doppelklick darauf aus und das Fenster des Dokumenteditors wird geöffnet.

Das Fenster des Dokumenteditors besteht aus drei Bereichen: dem Seitenbild, dem Datenformular und dem Fehlerbereich (dieser Bereich wird nur dann angezeigt, wenn in der Rechnung Fehler vorhanden sind). Es gibt vier Arten von Fehlern: Zusammenstellungsfehler, Formatfehler, Regelfehler und Fehler über fehlende Feldbereiche. Um Fehler einer bestimmten Art anzuzeigen, klicken Sie in der oberen rechten Ecke des Fehlerbereichs auf die entsprechende Schaltfläche (es kann jede beliebige Kombination von Fehlertypen ausgewählt werden).

Über das Kontextmenü des Datenformulars können der Wert eines Feldes bestätigt, die Anzeige oder das Ausblenden von Formatfehlern, der Wechsel zum nächsten Objekt oder zum vorherigen Objekt zur Überprüfung und die Änderung des Feldnavigationsmodus' durchgeführt werden.

Felder, deren Werte nicht den festgelegten Datentypen oder Regeln entsprechen, sind hervorgehoben. Um den Wert eines Feldes zu bestätigen, platzieren Sie den Mauszeiger in diesem Feld und drücken die Taste Enter.

Um einen Feldbereich festzulegen, der nicht automatisch gefunden wurde, führen Sie die folgenden Schritte durch.

  1. Platzieren Sie im Datenformular den Mauszeiger in dem Feld, das den Bereich enthält, den Sie festlegen möchten.
  2. Legen Sie den Bereich fest:
    • Klicken Sie auf einen erkannten Bereich (diese Bereiche sind blau hervorgehoben)

      • oder

    • Zeichnen Sie den Bereich, indem Sie die linke Maustaste gedrückt halten und den Mauszeiger von der linken oberen Ecke des gewünschten Bereichs zur rechten unteren Ecke ziehen.

    Hinweis: Wird vor Auswahl oder Zeichnen eines Bereichs kein Feld ausgewählt, wird ein Dialogfeld mit einer Liste von Feldern geöffnet. Wählen Sie das gewünschte Feld in diesem Dialog aus.

Hat der Administrator eine Datenbank für die Lieferanten und/oder Geschäftseinheiten erstellt, kann ein Eintrag aus dieser Datenbank verwendet werden (für ausführliche Informationen See "Suchen von Lieferanten und Geschäftseinheiten in der Datenbank").


Suchen von Lieferanten und Geschäftseinheiten in der Datenbank

Wurde ein Lieferant oder eine Geschäftseinheit während der Erkennung einer Rechnung nicht automatisch bestimmt, kann eine(r) aus der Datenbank ausgewählt werden. Dafür gibt es zwei Möglichkeiten:

Collapsed Beginnen Sie den gewünschten Wert in eines der Felder der Gruppe einzutippen

Eine Liste mit Vorschlägen wird angezeigt. Alle Einträge, die dem eingegebenen Text entsprechen, werden fett angezeigt.

Es spielt keine Rolle, in welches Feld der Gruppe Sie tippen. Sie können beispielsweise einen Straßennamen in ein Feld eingeben, das einen Firmennamen enthält.

Sobald der gewünschte Datensatz angezeigt wird, wählen Sie diesen aus der Liste, indem sie ihn anklicken oder mithilfe der Pfeiltasten auswählen (drücken Sie die Taste Enter, um Ihre Auswahl zu bestätigen).

Die Felder aus diesem Eintrag werden in die entsprechenden Felder der Gruppe im Formular eingefügt.

Kann der gewünschte Eintrag in der Liste der Vorschläge nicht gefunden werden, klicken Sie auf Lieferant (Geschäftseinheit) wurde nicht gefunden oder drücken Strg+Entf, um alle Felder in der Gruppe zu löschen.

Collapsed Klicken Sie auf die Schaltfläche Suchen... im Formular

Das Dialogfeld Suchen nach Lieferant (Geschäftseinheit) wird geöffnet. Mit diesem Dialogfeld können Einträge in der Datenbank gesucht werden.

Beginnen Sie, Ihren Suchbegriff in das Suchfeld einzugeben. Vorschläge werden rechts in der Liste und alle Übereinstimmungen in Fettschrift angezeigt. Alle Felder des ausgewählten Eintrags werden links angezeigt.

Wählen Sie mithilfe der Maus oder Pfeiltasten den gewünschten Eintrag und klicken Sie auf die Schaltfläche Auswählen. Die Felder aus diesem Eintrag werden in die Felder der Gruppe im Formular eingefügt.

Kann der gewünschte Eintrag im Dialogfeld nicht gefunden werden, klicken Sie auf die Schaltfläche Daten zurücksetzen, um alle Felder in der Gruppe zu löschen.

Einträge von Lieferanten und Geschäftseinheiten ändern und hinzufügen

Die Informationen über Lieferanten und Geschäftseinheiten sind für die Erfassung von Rechnungen erforderlich. Die Feldgruppen für Lieferanten und Geschäftseinheiten enthalten grundlegende Informationen. Die automatische Verarbeitung von Rechnungen beginnt mit einer Suche nach einem Lieferanten oder einer Geschäftseinheit im Bild. Konnte kein Lieferant oder keine Geschäftseinheit gefunden werden, wird die Rechnung nicht verarbeitet.

Mithilfe der Informationen aus Ihrer Liste der Lieferanten und Geschäftseinheiten werden diese Felder in der Rechnung gesucht. Diese Liste ist eine lokale Kopie einer externen Datenbank, die Informationen über Lieferanten und Geschäftseinheiten enthält. Sie wird regelmäßig mit der Datenbank synchronisiert.

Konnte ein Lieferant oder eine Geschäftseinheit in der lokalen Kopie der Datenbank nicht gefunden werden, muss ein Eintrag manuell erstellt werden.

Sollten sich Lieferantendaten ändern (wie beispielsweise die Adresse des Lieferanten), muss der Eintrag in der lokalen Kopie der Datenbank entsprechend geändert werden.

Collapsed Hinzufügen eines neuen Eintrags zur lokalen Kopie der Datenbank
  1. Füllen Sie alle Felder in der Lieferanten-/Geschäftsgruppe aus.
  2. Klicken Sie auf die Schaltfläche Änderungen speichern.

Der Eintrag wird der lokalen Kopie der Datenbank hinzugefügt (nicht aber der externen Datenbank). Die Felder werden grün hervorgehoben. Das Feld ID im Dokumentformular enthält den Wert UNBEKANNT. Das bedeutet, dass dieser Eintrag nur in der lokalen Kopie der Datenbank vorhanden ist, nicht aber in der externen Datenbank.

Der Status Ausnahme wird der Rechnung und allen nachfolgenden Rechnungen des selben Lieferanten zugewiesen.

Nachdem der neue Eintrag der externen Datenbank hinzugefügt wurde, wird das Feld ID in nachfolgenden Rechnungen ausgefüllt.

Collapsed Bearbeitung eines vorhandenen Eintrags in der lokalen Kopie der Datenbank
  1. Nehmen Sie die gewünschten Änderungen vor.
  2. Klicken Sie auf die Schaltfläche Änderungen speichern.


Training während der Rechnungserfassung

Sind Sie mit der Qualität der Daten nicht zufrieden, die ABBYY FlexiCapture for Invoices automatisch aus den Feldern extrahiert, kann das Programm während der Rechnungserfassung trainiert werden.

Das geschieht durch Angabe der korrekten Position der Felder im Bild und Anklicken der Schaltfläche [image]. Sobald das Programm mindestens drei Exemplare eines Rechnungstyps gesammelt hat, wird das Training ausgeführt und die Ergebnisse dieses Prozesses werden dann bei der Verarbeitung neuer Rechnungen dieses Typs verwendet.

Das Trainieren während der Rechnungserfassung muss vom Administrator erlaubt werden.

Trainieren des Programms während der Erfassung von Rechnungen

  1. Sammeln Sie einen Stapel von Rechnungen (z. B. Rechnungen, die Sie während des letzten Monats erhalten haben) und beginnen Sie mit deren Eingabe ( See "Erfassen von Rechnungen").
  2. Nach der Eingabe werden die Dokumente automatisch erkannt (sofern diese Option vom Administrator aktiviert wurde) und mithilfe von Regeln überprüft.
  3. Lautet der Status einer Rechnung nicht Gültig oder bestehen andere Gründe für die Annahme, dass einige der Felder im Bild vom Programm nicht oder falsch erkannt wurden, öffnen Sie die Rechnung im Dokumenteditor.
  4. Überprüfen Sie das Dokumentformular. Die Feldgruppe Lieferant muss korrekt ausgefüllt sein.
Collapsed Sonstiges...

Das Training wird getrennt für jeden Dokumenttyp durchgeführt. Rechnungen eines einzelnen Lieferanten werden als einem einzelnen Typ zugehörig angesehen. Wird der Lieferant in einer Rechnung falsch bestimmt, wird diese Rechnung während des Trainings dem falschen Dokumenttyp zugewiesen. Wurde der Lieferant nicht bestimmt, wählen Sie einen Lieferant aus der Datenbank. Kann der korrekte Lieferant in der Datenbank nicht gefunden werden, geben Sie die Daten aus dem Bild in die Felder der Gruppe Lieferant ein und speichern diese Änderungen in der Datenbank, indem Sie auf die Schaltfläche Änderungen speichern klicken.

Ja nach Projekteinstellungen müssen Sie u. U. auch die einzigartige ID des Lieferanten in der Rechnung festlegen, damit das Programm mit dieser Rechnung trainieren kann. Dafür geben Sie in das Feld USt-IdNr die einzigartige ID ein (dieses Feld kann bei einigen Lokalisierungen des Projekts einen anderen Namen haben). Die USt-IdNr ist eine einzigartige Identifikationsnummer, die den Unternehmen für wertschöpfende Besteuerungszwecke zugewiesen wird.

  5. Eine für das Training erforderliche Bedingung ist, dass die Positionen der Bereiche aller Felder im Bild den echten Positionen der Felder in der Rechnung entsprechen. Sie müssen sicherstellen, dass sich die Bereiche an den korrekten Positionen befinden.

Korrigieren Sie die Positionen der Bereiche im Dokumentbild und zeichnen Sie Bereiche für Felder, die nicht erkannt wurden.

Collapsed Den Bereich eines Feldes ändern
  • Positionieren Sie den Mauszeiger im gewünschten Feld im Datenformular, suchen Sie den entsprechenden Bereich im Bild (dieser wird blau markiert) und klicken Sie diesen an (oder zeichnen Sie mit der Maus ein Rechteck).
  • Positionieren Sie den Mauszeiger auf dem gewünschten Bereich im Bild (dieser wird blau markiert), klicken Sie diesen an (oder zeichnen Sie den Bereich mit der Maus) und wählen Sie dann das entsprechende Feld aus dem sich daraufhin öffnenden Dropdownmenü.
  • Korrigieren Sie die Position eines Bereichs im Bild, indem Sie dessen Ränder mit der Maus bewegen.
  • Löschen eines falsch positionierten Bereichs aus dem Bild: Positionieren Sie den Mauszeiger auf dessen Rechteck und klicken Sie auf das rote Kreuz, sobald es in der Ecke oben rechts angezeigt wird. Der Markierung des Bereichs wird daraufhin gelöscht. Erstellen Sie jetzt einen neuen Bereich für dieses Feld an der korrekten Position.
  • Beginnen Sie im Datenformular, einen Wert in das Feld einzugeben. Es wird jetzt eine Dropdownliste mit den aus dem Bild erfassten Wörtern angezeigt, die dem eingegebenen Wort ähnlich sind. Wählen Sie das korrekte Wort aus der Liste aus und die Position des Wortes im Bild wird dann zum Bereich des Feldes.
  6. Nachdem nun alle Felder korrekt markiert wurden, klicken Sie auf die Schaltfläche [image] und das Dokument wird den Beispielbildern hinzugefügt, die für diesen Dokumenttyp verwendet werden.

Die Schaltfläche [image] wird anklickbar, sobald die folgenden Bedingungen erfüllt sind:

  • Mindestens ein Feldbereich im Bild wurde geändert.

Wichtig! Gelöschte Feldbereiche können für das Training des Programms nicht verwendet werden, d. h. das Programm kann die Informationen darüber, wo die Felder nicht positioniert sein können, nicht nutzen.

  • Die Lieferantendaten sind korrekt.

Kann die Schaltfläche [image] nicht angeklickt werden, halten Sie den Mauszeiger über die Schaltfläche und es wird eine Benachrichtigung mit einer Erläuterung angezeigt.

Klicken Sie auf [image], werden alle Felder der Rechnung zu Trainingszwecken verwendet, nicht nur diejenigen, deren Markierungen von Ihnen hinzugefügt oder bearbeitet wurden. Klicken Sie daher unbedingt erst dann auf [image], wenn sich die Bereiche aller Felder im Bild an den korrekten Positionen befinden.

Haben Sie mindestens ein Beispielbild für einen Dokumenttyp hinzugefügt, ist die Schaltfläche [image] sofort für nachfolgende Dokumente verfügbar, die Sie diesem Dokumenttyp hinzufügen. Die Begründung für die aktive Schaltfläche [image] ist, Ihnen das Hinzufügen von Beispielbildern zu ermöglichen, bei denen alle Felder korrekt erkannt wurden und für die keine weiteren Korrekturen erforderlich sind.

  7. Wiederholen Sie die Schritte 4-6 für das nächste Dokument.
  8. Nachdem Sie für diesen Dokumenttyp ein drittes und nachfolgende Beispielbilder hinzugefügt haben, wird der Trainingsvorgang jedes Mal gestartet, sobald Sie ein neues Beispiel hinzufügen (das Fenster Dokumentdefinition trainieren angezeigt). Entweder wird eine spezielle FlexiLayout-Variante für diesen Dokumenttyp erstellt oder das Programm fordert Sie auf, mit dem Hinzufügen von Beispielbildern fortzufahren (in diesem Fall wählen Sie das nächste Dokument aus und gehen zurück zu Schritt 4).

Wurde die FlexiLayout-Variante erfolgreich trainiert, wird diese für die nächste Rechnung von dem Lieferanten verwendet, dessen Rechnungen zu dem vorgegebenen Dokumenttyp gehören. Nach der Erkennung werden die Feldbereiche den Feldern im Rechnungsbild zugeordnet, und das trainierte Wissen wird berücksichtigt.

Die Schaltfläche [image] wechselt jetzt zurück in den normalen Modus, d. h. sie wird dann wieder anklickbar sein, wenn Sie die Markierung von mindestens einem Bereich bearbeitet haben).

Nachdem Sie jetzt eine ausreichende Anzahl von Beispielbildern für den Dokumenttyp gesammelt haben, wird das Training jedes Mal beim Hinzufügen eines neuen Beispielbildes gestartet (d h. jedes Mal, wenn Sie [image] anklicken). Klicken Sie nur auf [image], wenn einige der Bereiche ihren Feldern nicht korrekt zugeordnet wurden und wenn deren Positionen im Bild korrigiert werden mussten.

  9. Fügen Sie einige weitere Rechnungen von dem Lieferanten hinzu, dessen Dokumenttyp trainiert wurde, und erkennen Sie sie. Öffnen Sie dann die neu hinzugefügten Rechnungen der Reihe nach im Dokumenteditor, um die korrekte Markierung der Bereiche zu überprüfen. Wurden alle Bereiche korrekt markiert, ist kein zusätzliches Training erforderlich.

Sind Sie mit den Ergebnissen nicht zufrieden, die Sie durch Ausführen der Schritte in diesem Kapitel erhalten haben, setzen Sie das Training für Rechnungen des Lieferanten fort (Schritte 4-6).


Exportieren der Daten

Nach der Überprüfung von Daten müssen diese exportiert werden.

Um Ihre Daten anhand der durch den Administrator festgelegten Einstellungen zu exportieren, klicken Sie in der Hauptsymbolleiste auf die Schaltfläche Export.

Hinweis: Der Export kann auch manuell durchgeführt werden. Dafür klicken Sie auf ▼ rechts neben der Schaltfläche Export und wählen einen der Menüpunkte:

  • Exportieren in Datendateien , um Daten in Dateien zu exportieren
  • Exportieren in Bilddateien , um Bilder in Dateien zu exportieren
  • In ODBC-kompatible Datenbank exportieren , um Daten in eine Datenbank zu exportieren

Für weitere Informationen zu den Exportoptionen See "Exportieren erkannter Daten".


Einrichtung eines Projekts zur Rechnungserfassung

Bevor Sie mit der Verarbeitung von Rechnungen beginnen, müssen Sie:

  1. Ein neues Projekt erstellen.

    Öffnen Sie das Menü Datei und wählen Sie Neues Rechnungsprojekt.... Wählen Sie in der Dropdownliste Projekttyp die Option Rechnungsverarbeitung als Projekttyp aus. Bestimmen Sie einen Namen für das Projekt und den Pfad zu dem Ordner, in dem es gespeichert werden soll. Es können mehrere Projekte erstellt werden. Beispielsweise kann jeweils ein separates Projekt für jede Abteilung oder für bestimmte Lieferanten erstellt werden.

  2. Konfigurieren Sie das Projekt. Ein ordnungsgemäß konfiguriertes Projekt sorgt für eine höhere Genauigkeit bei der Datenerfassung. Die Einstellungen, die vor Beginn der Verarbeitung konfiguriert werden müssen, sind nachfolgend beschrieben.

Einrichtung von Importprofilen

Die Rechnungsverarbeitung beginnt mit der Beschaffung von Dokumentbildern. Für die Beschaffung von Bildern gibt es mehrere Möglichkeiten:

  • Ein Operator kann Papierdokumente scannen.
  • Ein Operator kann Bilder aus einem Ordner hinzufügen.
  • Ein Importprofil kann verwendet werden. Importprofile werden vom Administrator eingerichtet und beinhalten den Import von einem Scanner, von einem Hot Folder und von einem E-Mail-Postfach.

Weitere Informationen über Importprofile finden Sie unter See "Bildimportprofile"

Wichtig! Die aktuelle Version von ABBYY FlexiCapture for Invoices besitzt eine Einschränkung für die Verarbeitung mehrseitiger Rechnungen. Enthält eine Rechnung mehrere Seiten, müssen diese in der korrekten Reihenfolge zusammengestellt werden (von Anfang bis Ende). Beginn und Ende eines mehrseitigen Dokuments müssen definiert werden. Das kann in den Importeinstellungen erfolgen.

Bestimmung der Regions- und Spracheinstellungen

Erstellen Sie eine Liste der Länder, aus denen Sie Rechnungen erhalten werden. Anhand dieser Liste wird der Satz von Regeln bestimmt, der für die Überprüfung Ihrer Rechnungen, die Formatierung von Zahlen, Daten und Summen, Steuersätzen, Währungen und der Werte von Spezialfeldern sowie für eine Liste der erlaubten Sprachen für die Rechnungen verwendet wird. Diese Sprachenliste wird dann für die Auswahl der Schlüsselwörter verwendet, mit deren Hilfe Felder in Rechnungen gefunden werden können.

Datenbanken hinzufügen

Führen Sie diesen Schritt durch, wenn Sie eine Datenbank von Lieferanten und Geschäftseinheiten besitzen. Solche Datenbanken unterstützen Sie bei der korrekten Identifizierung von Feldgruppen für Lieferanten und Geschäftseinheiten im Rechnungsbild und das Extrahieren der Daten daraus. Ohne Datenbanken müssen die Feldgruppen für Lieferanten und Geschäftseinheiten während der Überprüfung per Hand festgelegt werden.

Konfiguration der Exporteinstellungen

Bestimmen Sie einen Exportpfad für die extrahierten Daten. Das Projekt enthält bereits ein Standard-Exportprofil, es können aber für Dokumente mit verschiedenen Statusarten zahlreiche andere Profile eingerichtet werden. Sie können beispielsweise Dokumente mit dem Status Abgelehnt in einen separaten Ordner exportieren.

Hinweis: Weitere Informationen über Statusarten und deren Verwendung finden Sie unter See "Der Status von Dokumenten in Projekten von ABBYY FlexiCapture for Invoices".

Zusätzliche Einstellungen

Training

Der Administrator kann das System während der Einrichtung des Projekts trainieren. Ergeben Tests, dass die Qualität der Datenerfassung bei manchen Rechnungen von geringer Qualität ist, kann die Qualität der Datenerfassung durch das Training verbessert werden.

Regeln

Bestimmen Sie Regeln, die für das Überprüfen von Rechnungen verwendet werden.

Datenerfassung aus zusätzlichen Feldern

Legen Sie zusätzliche Felder für die Datenextrahierung fest oder erstellen Sie Ihre eigenen benutzerdefinierten Felder.

Kontrolle von Rechnungspositionen

Richten Sie einen automatischen Abgleich von Rechnungsfeldern mit Bestellungen ein.

Zusätzliche Optionen für Operatoren

Aktivieren Sie das Training während der Rechnungsverarbeitung oder erlauben Sie den Operatoren das Hinzufügen bzw. Bearbeiten von Einträgen für Lieferanten und Geschäftseinheiten.

Einstellungen der grafischen BenutzeroberflächeABBYY FlexiCapture for Invoices:

Einrichtung des Erscheinungsbildes des Dokumentformulars

Lokalisierung der Dokumentdefinition

Übersetzen Sie Feldbezeichnungen, Namen der Schaltflächen, Tooltipps und anderen Text im Datenformular. Übersetzen Sie Fehlermeldungen.

Aktualisierung der Dokumentdefinition

Die Benutzer können nach der Veröffentlichung einer neuen Version von ABBYY FlexiCapture ihre Projekte aktualisieren. Die vor der Aktualisierung vom Benutzer durchgeführten Änderungen werden soweit als möglich beibehalten.

Workstation-Einstellungen

  • Globale Einstellungen
  • Einzelne Einstellungen (verfügbar unter Extras>Optionen…)
Collapsed Weitere Informationen über persönliche Einstellungen...

Mithilfe des Dialogfeldes Optionen können Sie:

  • Auswählen, welche Daten im Protokoll gespeichert werden und festlegen, wann Tooltips angezeigt werden
  • Tastaturkombinationen definieren
  • GUI-Farben ändern
  • Automatische Erkennungseinstellungen ändern
  • Die Anzeige des Dialogfeldes einrichten

Wichtig! Alle im Dialogfeld Optionen durchgeführten Änderungen werden lokal gespeichert und bei Änderung oder Aktualisierung des Projekts nicht geändert.


Land- und Spracheinstellungen

ABBYY FlexiCapture for Invoices kann Rechnungen verarbeiten, die aus einer Reihe verschiedener Länder stammen, und unterstützt eine breite Auswahl von Sprachen.

Alle unterstützten Länder sind standardmäßig in der Dokumentdefinition aktiviert. Sie sollten jedoch nur die Länder auswählen, aus denen Sie auch Rechnungen erwarten.

Der Versuch der Verarbeitung einer Rechnung aus einem Land, das sich nicht in der Liste befindet, führt aus folgenden Gründen voraussichtlich zu einem nicht zufriedenstellenden Ergebnis:

  • Es sind keine Schlüsselwörter verfügbar. Anhand der Schlüsselwörter werden Daten in der Rechnung gefunden.
  • Die Erkennungsqualität wird wesentlich niedriger sein, da die Sprache der Rechnung möglicherweise deaktiviert ist.
  • Das Land der Rechnung besitzt eventuell eigene Zahlen- und Währungsformate.

Das Land der Rechnung wird für die Bestimmung der Währung, von Schlüsselwörtern, zusätzlichen Feldern und der Formate solcher Felder wie z. B. IBAN und USt-IdNr verwendet.

Das Land der Rechnung bestimmt außerdem den Sprachensatz. Aktivieren Sie nur Sprachen, die während der Erkennung verwendet werden. Zusätzliche Sprachen können die Verarbeitung beeinträchtigen und die Leistung reduzieren.

Festlegen von Ländern und Sprachen

  1. Öffnen Sie das Menü Projekt und klicken Sie auf Dokumentdefinitionen….
  2. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Schaltfläche Bearbeiten….
  3. Öffnen Sie das Menü Dokumentdefinition und klicken Sie auf Eigenschaften der Dokumentdefinition….
  4. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Rechnungseinstellungen.
  5. Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Gruppe Länder und Sprachen.
  6. Legen Sie im daraufhin geöffneten Dialogfeld Länder und Sprachen die gewünschten Einstellungen fest.
Collapsed Bearbeiten der Länderliste

Länder können durch Markieren oder Deaktivieren der jeweiligen Auswahlfelder hinzugefügt oder entfernt werden.

Collapsed Bearbeiten der Sprachenliste

Die Sprachenliste wird automatisch auf der Basis der Länderliste generiert (jedes Land besitzt seinen eigenen Sprachensatz, der in den Eigenschaften des Landes bearbeitet werden kann). Zusätzliche Sprachen können entfernt und fehlende Sprachen hinzugefügt werden:

  1. Wählen Sie das entsprechende Land in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Sprachen und bearbeiten Sie die Sprachenliste.
Collapsed Bearbeiten der Steuersätze eines Landes

Haben sich die Steuersätze eines Landes geändert, müssen diese Änderungen entsprechend in den Einstellungen des Landes eingetragen werden. Um die Steuersätze eines Landes zu bearbeiten, gehen Sie wie folgt vor:

  1. Wählen Sie das Land in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Steuersätze.
  4. Wählen Sie den zu ändernden Steuersatz in der Liste aus und klicken Sie auf Bearbeiten…. Klicken Sie auf Hinzufügen…, um eine neue Steuer hinzuzufügen.
  5. Legen Sie im Dialogfeld Einstellungen für Steuersätze den neuen Steuersatz, Dauer und Schlüsselwörter fest.
Collapsed Formate für IBAN und MWST ändern

Um das Format von Bankkonto, Bankleitzahl, IBAN, Nationaler Steuer-ID, USt-IdNr, Gesamtsumme oder Gesamtsteuer zu ändern, gehen Sie wie folgt vor:

  1. Wählen Sie das entsprechende Land in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Formate und bearbeiten Sie die Formatierungseinstellungen. Für ausführliche Informationen See "Erweiterte reguläre Ausdrücke".
Collapsed Ändern der Währungsformatierung

Zum Ändern der Formatierung einer Währung oder Hinzufügen einer neuen Währung gehen Sie wie folgt vor:

  1. Wählen Sie das entsprechende Land in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Currency und ändern Sie die Formatierungseinstellungen der Währung.
Collapsed Ändern der Schlüsselwörter für das Auffinden von Feldern in einer Rechnung

Schlüsselwörter sind Wörter, die häufig neben bestimmten Feldern in Rechnungen anzutreffen sind. Das Programm verwendet sie für das Auffinden dieser Felder. Schlüsselwörter auf Rechnungen, die aus einem bestimmten Land stammen, sind von der Rechnungssprache abhängig, aber Schlüsselwörter in einer Sprache, die in mehreren Ländern verwendet wird, können für diese Länder unterschiedlich sein.

Die Schlüsselwörter für die Felder werden in den Eigenschaften der Länder und Sprachen festgelegt. Korrekt festgelegte Schlüsselwörter unterstützen ABBYY FlexiCapture for Invoices beim Auffinden der Felder und verbessern die Erkennungsgenauigkeit.

Um eine Liste der Schlüsselwörter anzuzeigen und zu bearbeiten, gehen Sie wie folgt vor:

  • Schlüsselwörter für ein bestimmtes Land:
  1. Wählen Sie das Land in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Schlüsselwörter und bearbeiten Sie die Schlüsselwörter.
  • Schlüsselwörter für eine bestimmte Sprache:

Hinweis: Die Spracheigenschaften enthalten eine Liste von Elementen, die anstatt eines Feldsatzes für das Auffinden von Feldern verwendet werden. Für ausführliche Informationen See "Schlüsselwörter".

  1. Wählen Sie die Sprache in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten….
  3. Geben Sie in das Dialogfeld Sprachschlüsselwörter die Schlüsselwörter ein.
Collapsed Neues Land hinzufügen

Ist ein Land in der Liste nicht vorhanden, kann es angelegt und seine Eigenschaften festgelegt werden (Währung, Steuersätze, Regeln usw.).

  1. Wählen Sie ein Land in der Liste aus.

Alle Eigenschaften des von Ihnen ausgewählten Landes, mit Ausnahme der Sprachen, werden kopiert, daher sollte ein Land ausgewählt werden, dessen Eigenschaften den gewünschten möglichst genau entsprechen.

  2. Klicken Sie auf die Schaltfläche Duplizieren….
  3. Geben Sie im daraufhin geöffneten Dialogfeld den Namen des hinzuzufügenden Landes ein und klicken Sie auf OK.
  4. Bearbeiten Sie die Eigenschaften des neuen Landes.


Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten

Für die Erfassung von Rechnungen werden Informationen über Lieferanten und Geschäftseinheiten benötigt. Die Feldgruppen Lieferant und Geschäftseinheit sind die Schlüsselfelder. Das Programm startet die Zuordnung der Dokumentdefinition zu einer Rechnung mit diesen Feldern. Sie bestimmen außerdem die Regeln für die Erfassung und Überprüfung der Daten aus den Feldern.

Ein Lieferant ist ein Unternehmen, das eine Rechnung ausstellt. Der Lieferant wählt die Sprache der Rechnung und die Formatierung von Zahlen, Daten und Beträgen aus.

Eine Geschäftseinheit ist ein Unternehmen oder der Bereich eines Unternehmens, das/der eine Rechnung erhält. Die für die Überprüfung von Rechnungsdaten, Steuersätzen und anderen Daten verwendeten Regelsätze werden auf der Basis der Geschäftseinheit bestimmt.

Die automatische Verarbeitung (Erkennung) einer Rechnung beginnt mit der Suche nach dem Lieferanten und der Geschäftseinheit. Für das Auffinden von Lieferanten- und Geschäftseinheitsdaten auf der Rechnung werden die Daten aus Ihren Datenbanken für Lieferanten und Geschäftseinheiten verwendet. Die Regeln vergleichen automatisch die Daten der Lieferanten und Geschäftseinheiten einer Rechnung mit den Daten aus der Datenbank.

Die Operatoren können während der manuellen Überprüfung die Datenbank nach bestimmten Lieferanten und Geschäftseinheiten durchsuchen.

Um dem Programm Informationen über Lieferanten und Geschäftseinheiten bereitzustellen, müssen die Datenbanken mit den in der Dokumentdefinition festgelegten Datensätzen verbunden sein.

Ein Datensatz ist eine lokale Kopie einer Tabelle aus einer externen Datenbank, in der Informationen über Lieferanten und Geschäftseinheiten gespeichert werden. Die Werte eines Datensatzes können typisiert und normalisiert werden. Ein Datensatz kann regelmäßig aktualisiert werden, um ihn so mit seiner externen Datenbank zu synchronisieren.

See "Vorbereitung der Datenbanken für Lieferanten und Geschäftseinheiten"

Datenbanken verbinden

Die Datenbanken für Lieferanten und Geschäftseinheiten werden auf die gleiche Weise verbunden:

  1. Öffnen Sie das Menü Projekt und klicken Sie auf Dokumentdefinitionen….
  2. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Schaltfläche Bearbeiten….
  3. Öffnen Sie das Menü Dokumentdefinition und klicken Sie auf Eigenschaften der Dokumentdefinition….
  4. Öffnen Sie im daraufhin geöffneten Dialogfeld die Registerkarte Datensätze.
  5. Doppelklicken Sie die Zeile BusinessUnits (Vendors) oder klicken Sie auf die Schaltfläche Einrichtung…. Das Dialogfeld Datensatz wird geöffnet.

Ein Datensatz ist im Wesentlichen eine Tabelle mit Daten. Er enthält die benötigten Spalten und deren Typen. Diese Spalten und Typen können nicht von dem Benutzer geändert werden, der jede Spalte im Datensatz einer Spalte in einer externen Datenbank zuordnen muss. Enthält eine Datenbank keine Tabelle mit den benötigten Daten, muss anhand dieser Daten eine Ansicht erstellt und diese Ansicht als Tabelle festgelegt werden.

  6. Legen Sie die Verbindungszeichenfolge für die Datenbank fest.

Sie können eine der vorhandenen Umgebungsvariablen aus dem Projekt auswählen oder eine neue Zeichenfolge definieren, indem Sie auf die Schaltfläche Festlegen… klicken. Durch die Verwendung einer Umgebungsvariable kann das Projekt verschoben und mit Datenbanken der gleichen Struktur verbunden werden, ohne die Dokumentdefinition zu bearbeiten.

  7. Wählen Sie Datenschema und Datenbanktabelle.
  8. Ordnen Sie die Spalten aus dem Datensatz den entsprechenden Spalten in der externen Datenbank zu.

Für jede Spalte im Datensatz kann eine entsprechende Spalte in der externen Datenbank oder der Wert <Not used> festgelegt werden.

  • Die Namen der Spalten im Datensatz
  • Die entsprechenden Spalten aus der externen Datenbank

    Standardmäßig enthält jedes Feld in der Spalte Externe Datenbankspalte des Datensatzes den Wert <Not used>. Das bedeutet, es wurden keine Spalten von einer externen Datenbank festgelegt.

  • Die Spalte Gefunden, die ein Auswahlkästchen enthält, falls eine Übereinstimmung zwischen dem Feld Datensatz und einer Datenbankspalte besteht.
  • Die Spalte Normalisierung, die den für den Wert verwendeten Normalisierungstyp anzeigt

    Durch die Normalisierung können mehrere, unwesentlich unterschiedliche Werte als identisch behandelt werden (Ausführliche Informationen finden Sie unter See "Normalisierung von Werten in Datensätzen").

Wählen Sie eine Spalte in der Tabelle und klicken Sie auf die Schaltfläche Bearbeiten….

  9. Wählen Sie im Dialogfeld Spaltenzuordnung der Datensätze die übereinstimmende Datenbankspalte aus der Liste Datenbankspalten.

Rechnungen desselben Lieferanten können unterschiedliche Namen für das Unternehmen des Lieferanten und verschiedene Adressen enthalten. Für den Fall, dass mehrere Werte demselben Lieferanten entsprechen (die gleiche USt-IdNr), müssen diese in verschiedenen Spalten der Tabelle (oder Ansicht) der externen Datenbank platziert werden, wie z. B. Name 1, Name 2, Adresse 1, Adresse 2. Sie können beim Festlegen der übereinstimmenden Spalten Mehrere Spalten… aus der Liste auswählen und die Anzahl der Spalten aus der Datenbank als Zuordnungen für die Spalte Datensatz festlegen.

Hinweis: Die externe Datenbank kann beispielsweise nur einen Wert für Name und Straße des Unternehmens enthalten. Von diesen Feldern bestehen jedoch unter Umständen mehrere Varianten, wenn sie auf Rechnungen auftreten. Um eine maximal mögliche Erkennungsqualität zu erreichen, sollte der auf einer Rechnung gedruckte Text dieser Felder möglichst genau dem entsprechenden Text im Datensatz entsprechen. Wir empfehlen die Erstellung einer Ansicht in der externen Datenbank, die der Datentabelle entspricht, aber zusätzliche Leerspalten enthält. Beispielsweise können Sie für die Spalte Firmenname in der Datentabelle mehrere Spalten in der Ansicht erstellen ( Name1,Name2...), wobei eine davon den Namen des Unternehmens enthält und die anderen leer bleiben. Bei der Herstellung von Übereinstimmungen zwischen dem Datensatz und der externen Datenbank wählen Sie Mehrere Spalten… und weisen das Feld Name des Datensatzes allen Name*-Spalten in der Ansicht zu. So können von Ihnen während der Rechnungsverarbeitung dem Datensatz neue Varianten des Firmennamens hinzugefügt werden (nicht der externen Datenbank!), was die Qualität der Erkennung erhöht.

Siehe "Komplexe Spalten eines Datensatzes"

Enthält Ihre Datenbank keine übereinstimmende Spalte für eine Datensatzspalte, wählen Sie <Not used>.

See "Spalten im Datensatz Vendors"

See "Spalten im Datensatz BusinessUnits"

  10. Wählen Sie einen Eintrag aus der Liste Normalisierung, der am besten zu dem Datentyp in der Spalte passt (ausführliche Informationen finden Sie unter See "Normalisierung von Werten in Datensätzen").
  11. Sind automatische Aktualisierungen erforderlich, legen Sie im Datensatz einen Zeitraum für die Datenbank-Aktualisierung fest.

Der Datensatz für Geschäftseinheiten und Lieferanten wird innerhalb des Projekts gespeichert und muss mit einer externen Datenbank synchronisiert werden, deren Daten sich von Zeit zu Zeit ändern. Synchronisierungen werden dann durchgeführt, wenn die nach der letzten Synchronisierung vergangene Zeit den festgelegten Aktualisierungszeitraum überschreitet. Weitere Informationen über Aktualisierungen finden Sie unter See "Aktualisierung von Datensätzen".

Regeln für die Datenbanküberprüfung

Die Dokumentdefinition Europäische Rechnung enthält Regeln für die Überprüfung der Daten in den Feldgruppen Lieferant und Geschäftseinheit im Vergleich mit den Datenbanken. Dabei handelt es sich um Standardregeln des Typs Datenbanküberprüfung mit den Namen (Abgelehnt) Lieferant muss in der Datenbank vorhanden sein und (Abgelehnt) Geschäftseinheit muss in der Datenbank vorhanden sein. Unter See "Regeln" erfahren Sie, wie Regeln in der Liste gesucht werden.

Sie können sich Eigenschaften dieser Regeln anzeigen lassen, um so herauszufinden, welche Felder aus den Gruppen Lieferant und Geschäftseinheit exakt mit den Einträgen im Datensatz übereinstimmen müssen (und infolgedessen in der Datenbank), welche nicht perfekt übereinstimmen müssen und welche Felder einfach aus der Datenbank kopiert werden. Für weitere Informationen über die Überprüfungsregeln für Datenbanken See "Regel für die Datenbanküberprüfung".

Regeln für die Datenbanküberprüfung werden bei Erkennung einer Rechnung automatisch angewendet, weiterhin jedes Mal, nachdem ein Operator während der Überprüfung ein Feld in der Gruppe ändert.

Durchführung von Datenbanksuchen während der Verarbeitung von Rechnungen

Wurde ein Lieferant oder eine Geschäftseinheit nicht automatisch bestimmt, kann der Operator den entsprechenden Eintrag aus der Datenbank auswählen (d. h. den Datensatz).

See "Suchen von Lieferanten und Geschäftseinheiten in der Datenbank"

Einträge von Lieferanten und Geschäftseinheiten ändern und hinzufügen

Sie können den Operatoren das Hinzufügen neuer Einträge von Lieferanten und Geschäftseinheiten zu den Datensätzen während der Überprüfung und Bearbeitung vorhandener Einträge erlauben (sofern nicht in der Datenbank vorhanden) Diese Daten werden nicht in den externen Datenbanken für Lieferanten und Geschäftseinheiten gespeichert, werden aber während der Rechnungsverarbeitung und den Regelüberprüfungen verwendet. Für ausführliche Informationen See "Zusätzliche Programmfunktionen für Operatoren aktivieren".

See "Suchen von Lieferanten und Geschäftseinheiten in der Datenbank"


You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten > Vorbereitung der Datenbanken für Lieferanten und Geschäftseinheiten

Vorbereitung der Datenbanken für Lieferanten und Geschäftseinheiten

ODBC-kompatible Datenbanken

ABBYY FlexiCapture for Invoices ermöglicht Ihnen die Verbindung eines Datensatzes mit einer ODBC-kompatiblen Datenbank (See "Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten"), um die Daten einmal zu laden oder um einen Datensatz anhand von Daten aus einer externen Datenbank in regelmäßigen Abständen zu aktualisieren (See "Aktualisierung von Datensätzen").

Daher sollte Ihr erster Schritt die Bereitstellung der externen Daten in einer ODBC-kompatiblen Datenbank sein, wie z. B. Microsoft Access, Microsoft SQL Server oder Oracle.

Beseitigung doppelter Datensätze in der externen Datenbank

Es ist wichtig, das Feld in der externen Datenbank für Lieferanten (oder Geschäftseinheiten) zu bestimmen, dessen Wert als Ergebnis der Erkennung des Lieferanten (oder der Geschäftseinheit) in einer Rechnung abgerufen werden soll. Dieses Feld (oder eine Reihe von Feldern) wird dann zum einzigartigen Schlüssel das Datensatzes.

Der einzigartige Schlüssel des Datensatzes Geschäftseinheit ist das Feld ID (See "Spalten im Datensatz BusinessUnits"). Aus der Perspektive des Benutzers ist dieses Feld das Ergebnis der ABBYY FlexiCapture for Invoices-Erkennung der Geschäftseinheit, für die die gegebene Rechnung ausgestellt wurde.

Der einzigartige Schlüssel eines Lieferantendatensatzes muss der Wert sein, der dem externen Informationssystem als Ergebnis der ABBYY FlexiCapture for Invoices-Erkennung des Lieferanten übergeben wurde, der die gegebene Rechnung ausgestellt hat. Wird eine Lieferantentabelle verwendet, muss der einzigartige Schlüssel dem Feld ID des Datensatzes zugeordnet sein. Dieser Wert wird an das externe Informationssystem weitergegeben, sobald der Lieferant in der Rechnung erkannt wird.

Planen Sie in einem Projekt die Verarbeitung von Rechnungen, die für verschiedene Geschäftseinheiten Ihres Unternehmens ausgestellt wurden, wobei jede davon ihre eigene Lieferantendatenbank besitzt, muss der einzigartige Schlüssel der jeweiligen Geschäftseinheiten der Spalte BusinessUnitId des Datensatzes Vendors und der Schlüssel der jeweiligen Geschäftseinheit der Spalte ID des Datensatzes Vendors zugeordnet werden. Daher muss der einzigartige Schlüssel des Lieferantendatensatzes, der an das externe Informationssystem weitergegeben wird, aus dem Paar ID und BusinessUnitId bestehen. (See "Spalten im Datensatz Vendors").

In den folgenden Erläuterungen berücksichtigen wir nur die Lieferantenerkennung, da die Situation bei Geschäftseinheiten komplett identisch ist.

Der einzigartige Schlüssel eines Datensatzes muss die einzigartige Kombination von Parametern bestimmen, die für die Lieferantenerkennung verwendet werden. Sehr oft wird ein externes Informationssystem einen Lieferantendatensatz als einzigartig ansehen und sich dabei auf mehr Parameter stützen, als in der Rechnung angegeben sind und/oder für die Lieferantenerkennung verwendet werden.

Beispiel: Ein externes Informationssystem erwartet die Kennung MCN_USD, wenn der Lieferant Mein Firmenname AG eine Rechnung in US-Dollar ausstellt, oder erwartet die Kennung MCN_EUR, wenn das gleiche Unternehmen eine Rechnung in Euro ausgestellt hat. Auch wenn die Währung in der Rechnung angegeben ist (und auch der Grund, wann MCN_USD zurückgegeben werden muss, kann vom Grund, wann die Kennung MCN_EUR zurückgegeben werden muss, unterschieden werden), wird die Währung nicht zur Erkennung des Lieferanten verwendet.

Daher kann der Erkennungsmechanismus für den Lieferanten nicht zwischen MCN_USD und MCN_EUR entscheiden.

In Fällen wie diesen erstellen Sie eine Kennung MCN, die sowohl MCN_USD als auch MCN_EUR entspricht, und die dann zurückgegeben wird, sobald der Lieferant erkannt wird. Als Nächstes erstellen Sie eine Regel in der Dokumentdefinition, die zwischen MCN_USD und MCN_EUR je nach Währung der gegebenen Rechnung auswählt.

Um zu generalisieren, muss die einzigartige Kennung eines Lieferanteneintrags einen einzigartigen Parametersatz enthalten, der für die Lieferantenerkennung verwendet wird, wie z. B. Firmenname, Firmenadresse, Steuer-IDs (USt-IdNr, Nationale Steuer-ID) und die internationale Bankkontonummer (IBAN). (See "Spalten im Datensatz Vendors") Nur dann ist es dem Lieferantenerkennungsmechanismus möglich, den korrekten Lieferanteneintrag für eine Rechnung auszuwählen.

Hinweis: Als Nächstes kann das Programm zusätzliche Felder erfassen und Regeln in der Dokumentdefinition für die Feinabstimmung des Ergebnisses anwenden, um so den benötigten Wert zu erhalten.

Entspricht der gleiche (oder leicht veränderte) Parametersatz, der für die Lieferantenerkennung verwendet wird, mehreren einzigartigen Schlüsseln, wird es dem Programm nicht möglich sein, nur einen Schlüssel auszuwählen, die Lieferantenerkennung erfolgt willkürlich und die Qualität nimmt ab.

Der Grund dafür ist folgender. Wenn das Programm die auf der Rechnungen gedruckten Daten für eine zuverlässige Erkennung des Lieferanten Mein Firmenname verwenden kann, aber mehrere Datensätze (MCN1, MCN2, ... MCNN) in dem Datensatz vorhanden sind, der den Rechnungsdaten entspricht, entscheidet das Programm evtl. zugunsten eines anderen Datensatzes, was für die Rechnungsdaten eine schlechtere Übereinstimmung bedeutet, aber zu weniger Einträgen führt. Das wird letztendlich zu einer falschen Erkennung des Lieferanten führen.

Daher ist die Beseitigung doppelter Datensätze in der externen Datenbank sehr wichtig und die externe Datenbank muss eine Spalte enthalten, die einen eindeutigen Wert für jeden eindeutigen Wertesatz der Datensatzfelder enthält, die zur Lieferantenerkennung verwendet werden.

Bei der Verbindung zum Datensatz werden die Reihen mit identischen Werten in der Spalte, die dem einzigartigen Schlüssel des Datensatzes zugeordnet werden, automatisch auf einen Eintrag im Datensatz reduziert.

Komplexe Spalten eines Datensatzes

Ein Datensatz kann mehrere Werte für eine logische Spalte eines Firmeneintrags speichern.

Die Speicherung mehrerer Werte ist erforderlich, da solche Firmenparameter wie z. B. Firmenname, Straße usw. von Rechnung zu Rechnung unterschiedlich sein können (z. B. haben wir "Mein Firmenname" und "MCN-AG"), um aber das Unternehmen zuverlässig zu erkennen, muss der Text im Datensatz ziemlich genau dem in einem Rechnungsbild erfassten Text entsprechen. Darüber hinaus können Unternehmen mehrere Bankkonten oder andere Attribute besitzen.

Werte für "multiplizierte" Spalten können einer externen Datenbank entnommen werden (z. B. kann eine Tabelle der Lieferanten ein bis fünf Bankdaten für jedes Unternehmen enthalten) oder sie können vom Benutzer während der Datenerfassung hinzugefügt werden (ein Operator möchte beispielsweise dem Datensatz eine häufig verwendete Variante eines Firmennamens hinzufügen, die der externen Datenbank unbekannt ist).

Datensätze verwenden die Denormalisierung von Spalten, d. h. sie speichern die Daten in der folgenden Form:

Einzigartiger Schlüssel des Datensatzes* | Name1 | Name2 | ... | NameN | ...
1 | Mein Firmenname | MCN-AG | ... | <leerer Wert> | ...
2 | Die zweite Firma, AG. | S-Firma | ... | <leerer Wert> | ...
... | ... | ... | ... | ... | ...

Für ein logisches Feld eines Eintrags, nennen wir es Name, werden mehrere Spalten im Datensatz erstellt, in denen alle möglichen Werte des logischen Feldes gespeichert werden. Daher könnte Name als "komplexe Spalte" bezeichnet werden.

Bei der Verbindung einer Tabelle (oder einer Ansicht) einer externen Datenbank kann wie oben beschrieben die Spaltendenormalisierung oder eine eher übliche Zeilendenormalisierung verwendet werden. Im zweiten Fall müssen die Zeilen, die im Datensatz in Parameter eines Eintrags zusammengeführt werden sollen, den gleichen Wert der Spalte besitzen, die dem einzigartigen Schlüssel im Datensatz entspricht. Beispiel:

Die dem einzigartigen Schlüssel im Datensatz zugeordnete Spalte | Name | ...
1 | Mein Firmenname | ...
1 | MCN-AG | ...
... | ... | ...
N | <leerer Wert> | ...
2 | Die zweite Firma, AG. | ...
2 | S-Firma | ...
... | ... | ...
N | <leerer Wert> | ...
... | ... | ...

*Der einzigartige Schlüssel eines Datensatzes BusinessUnits ist das Feld ID. Der einzigartige Schlüssel eines Datensatzes Vendors ist entweder das Feld ID oder das Feldpaar ID und BusinessUnitId, ja nach Einstellung. (See "Spalten im Datensatz Vendors")


Aktualisierung von Datensätzen

Es gibt zwei Typen von Datensätzen in ABBYY FlexiCapture:

  • Der erste Typ enthält nur Informationen über die Datenstruktur.
  • Der zweite Typ enthält die Daten aus einer externen Datenbank. Das wird aktiviert durch die Auswahl der Option Daten zwischenspeichern in den Eigenschaften des Datensatzes.

Durch die Aktualisierung eines Datensatzes wird dieser mit seiner externen Datenbank synchronisiert. Die Aktualisierung eines Datensatzes macht nur dann Sinn, wenn dieser Daten einer externen Datenbank enthält.

Eine Aktualisierung kann manuell durch den Benutzer oder automatisch zu gewissen Zeitspannen gestartet werden, die in den Eigenschaften des Datensatzes festgelegt werden.

Manuelle Aktualisierung eines Datensatzes

  1. Öffnen Sie das Menü Dokumentdefinition und klicken Sie auf Eigenschaften der Dokumentdefinition….
  2. Gehen Sie im daraufhin geöffneten Dialogfeld zur Registerkarte Datensätze.
  3. Wählen Sie den zu aktualisierenden Datensatz aus und klicken Sie auf die Schaltfläche Aktualisieren.

Automatische Aktualisierung von Datensätzen

Um automatische Aktualisierungen zu aktivieren, öffnen Sie die Eigenschaften des Datensatzes, wählen Aktualisierungsintervall und legen das Intervall zwischen den Aktualisierungen fest. Eine Aktualisierung wird ausgeführt, nachdem die Zeitspanne abgelaufen ist und der Stapel durch einen Operator geöffnet wird.

Die automatischen Aktualisierungen von Datensätzen werden gestartet, sobald ein Stapel auf einer ABBYY FlexiCapture-Workstation geöffnet wird, die auf einem Computer installiert ist (bei Webstationen und Remotestationen wird keine Aktualisierung durchgeführt), und wenn keine Operationen auf den Workstations von ABBYY FlexiCapture ausgeführt werden, vorausgesetzt die Zeitspanne für die Aktualisierung ist abgelaufen. Die Aktualisierung kann von jeder Sitzung aus gestartet werden und der aktualisierte Datensatz ist dann für alle Komponenten von ABBYY FlexiCapture verfügbar.

Hinweis: Hat eine auf einem Computer installierte Workstation keinen Zugriff auf die externe Datenbank, schlägt die Aktualisierung fehl. Die Aktualisierung für Datensätze auf einer Workstation können durch die Einstellung des folgenden Registrierungseintrags deaktiviert werden:

[HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller]

"DisableCacheUpdate"="1".

Zusammenführung von Daten bei der Aktualisierung eines Datensatzes

Mit ABBYY FlexiCapture können die Datensätze von den Operatoren während der Verarbeitung bearbeitet werden. Das heißt im Einzelnen, dass neue Lieferanten- und Geschäftseinheitsdaten hinzugefügt und bestehende Daten geändert werden können. Diese Änderungen werden nicht auf die externe Datenbank übertragen.

Die externe Datenbank kann unabhängig bearbeitet werden.

Die Datensätze werden wie folgt aktualisiert:

  • Wird in der externen Datenbank ein neuer Eintrag erstellt, wird dieser dem Datensatz hinzugefügt.
  • Wird in der externen Datenbank ein Eintrag gelöscht, wird dieser aus dem Datensatz gelöscht.

Einträge, die im Datensatz von Operatoren erstellt wurden, werden gelöscht, und Einträge, die in der externen Datenbank von Operatoren erstellt wurden, werden dem Datensatz hinzugefügt. Ist ein Eintrag sowohl im Datensatz als auch in der externen Datenbank vorhanden, können dessen Felder in der Datenbank und im Datensatz unabhängig voneinander geändert werden. In diesem Fall wird der Datensatz wie folgt aktualisiert:

  • Wurden die Felder des Eintrags während der Dokumentverarbeitung durch Operatoren geändert (wurde beispielsweise eine neue Lieferantenadresse eingegeben), werden diese Änderungen im Datensatz gespeichert.
  • Wurden in der externen Datenbank Felder von Operatoren geändert, nicht aber im Datensatz, (d. h. die Originalwerte aus der externen Datenbank wurden beibehalten), werden deren Werte im Datensatz durch die Werte aus der externen Datenbank ersetzt.

Ersetzen von Daten in einem Datensatz durch Daten aus einer externen Datenbank

Nehmen die Operatoren keine Änderungen am Datensatz vor, werden die darin enthaltenen Daten nach jeder Aktualisierung durch Daten aus der externen Datenbank ersetzt. Wird der Datensatz von den Operatoren geändert, hat der Administrator die Option, diese mit den Daten aus der externen Datenbank zu überschreiben, wodurch alle Änderungen des Operators überschrieben werden.

Stellen Sie dafür eine Verbindung mit dem Datensatz her:

  1. Öffnen Sie die Registerkarte Datensätze im Dialogfeld Eigenschaften der Dokumentdefinition und wählen Sie den Datensatz aus, für den die Verbindung wiederhergestellt werden soll.
  2. Klicken Sie auf die Schaltfläche Einrichtung….
  3. Legen Sie die Verbindungszeichenfolge fest, wählen Sie ein Schema und eine Tabelle aus und legen Sie die zugeordneten Spalten fest.

Für ausführliche Informationen See "Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten".


You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten > Normalisierung von Werten in Datensätzen

Normalisierung von Werten in Datensätzen

Dieser Artikel beschreibt die unterschiedlichen Arten der Normalisierung, die beim Hinzufügen von Spalten zu einer externen Datenbank für einen Datensatz in einer Dokumentdefinition verwendet werden können sowie die Einstellungen dieser Normalisierungsarten.

Mit der Normalisierung kann das Format von Werten geändert werden, die unterschiedlich geschrieben sind, aber im Wesentlichen dasselbe bedeuten. Die Normalisierung erzwingt eine konsistente Formatierung der Werte, sodass sie verglichen werden können. Adresse und Name eines Unternehmens sind beispielsweise auf verschiedene Art und Weise geschrieben. Da sich diese Werte auf das gleiche Unternehmen und die gleiche Adresse beziehen, müssen sie normalisiert werden, damit das Programm einen korrekten Vergleich anstellen kann.

Die Art der Normalisierung kann für jede Spalte eines Datensatzes festgelegt werden, wenn diese Spalten den Spalten einer externen Datenbank zugeordnet werden.

Die Normalisierung wird nur auf Werte angewendet, die im Datensatz gespeichert sind (die Option Daten zwischenspeichern muss in den Eigenschaften des Datensatzes aktiviert werden). Die Werte in der externen Datenbank werden nicht geändert.

Collapsed Wie funktioniert die Normalisierung während der Datenextrahierung in ABBYY FlexiCapture for Invoices?

ABBYY FlexiCapture for Invoices verwendet Datensätze für die Anwendung von FlexiLayouts, für das Extrahieren von Daten aus Feldern und für die automatisierte Überprüfung von Rechnungen. Beispielsweise könnten die Einträge für Name und Adresse eines Lieferanten in einer Datenbank auf die eine Weise und auf den Rechnungen dieses Lieferanten auf eine andere Weise geschrieben sein. Wird ein FlexiLayout auf diese Rechnungen angewendet, verwendet das Programm den Wert aus der Datenbank für das Generieren einer Werteliste, die bei der Normalisierung den Wert aus der Datenbank bezieht und dann das Bild nach diesen generierten Werten durchsucht.

ABBYY FlexiCapture for Invoices bietet zwei Arten der Normalisierung für Werte aus einem Datensatz.

1. Text

Mit dieser Normalisierungsart können Zeichenfolgen verglichen werden, wie beispielsweise Firmennamen und -adressen.

  1. Leerraum (das beinhaltet Zeilenvorschub und Tabstoppzeichen) und Trennungssymbole werden durch reguläre Leerzeichen ersetzt.
  2. Als Trennzeichen verwendete Punkte (zwischen Wörter platzierte Punkte) werden durch Leerzeichen ersetzt und Punkte in Abkürzungen werden entfernt.
  3. Normalisierung von Verbindungssymbolen (&, +, -, /, ~):
    • Wortreihen, die mit einem einbuchstabigen Wort beginnen und durch das gleiche Verbindungssymbol getrennt werden, werden zu einem Wort zusammengefasst, wie z. B. R & D wird zu R&D;
    • In allen anderen Fällen werden die Verbindungssymbole durch Leerzeichen ersetzt, wie z. B. Procter&Gamble wird zu Procter Gamble.
  4. Doppelte Leerzeichen werden entfernt.
  5. Für die Aufteilung von Wörtern wird eine vorab festgelegte Liste verwendet. CoKG beispielsweise wird aufgeteilt in Co KG.
  6. Mithilfe von Leerzeichen im erkannten Text wird dieser in separate Wörter aufgeteilt.
  7. Für das Ersetzen von Suffixen in jedem Wort wird eine vorab festgelegte Liste verwendet. Beispielsweise kann der Suffix strasse durch den Suffix str ersetzt werden.
  8. Automatisches Ersetzen von Zeichenfolgen in Wörtern entsprechend einer vorab festgelegten Liste. Beispielsweise kann das Wort Limited durch die Abkürzung Ltd ersetzt werden.

Die Normalisierungsparameter sind in der Datei Normalization.xml festgelegt, die im Projektordner gespeichert wird.

Collapsed Sonstiges...

Der Pfad zur Datei Normalization.xml in einem Projekt, das auf einer lokalen Festplatte gespeichert ist: <Pfad zum Projektordner>\ Templates\InvoiceData\<Name des Datensatzes>.Cache\Normalization.xml.

Beispiel: C:\InvoicesProject\Templates\InvoiceData\Vendors.Cache\Normalization.xml.

Der Pfad zur Datei Normalization.xml in einem Projekt, das zum Anwendungsserver hochgeladen und im Dateiablageordner ABBYY FlexiCapture for Invoices gespeichert wurde: <Pfad zu Dateispeicher>\<GUID des Dateispeichers>\project_<project id>\ DatabaseCaches\<Name des Datensatzes>\Normalization.xml.

Beispiel: D:\FileStorage\2FBE40C5-26EF-4756-AA7F-A52E7FBDA97D\project_1\DatabaseCaches\Vendors\Normalization.xml.

Die Normalization.xml-Datei eines Datensatzes wird bei Erstellung des Datensatzes erzeugt. Jede dieser Dateien gilt spezifisch für ihren Datensatz und die darin gespeicherten Parameter gelten nicht für andere Datensätze.

Hinweis: In zukünftigen Versionen des Programms werden u. U. erhebliche Änderungen am Normalisierungsalgorithmus vorgenommen.

2. Alphanumerischer Code

Diese Normalisierungsart ist beim Vergleich alphanumerischer Codes sehr nützlich, wie z. B. Steuernummer-IDs, Bankkonten und Buchungsindexe.

Alle Symbole mit Ausnahme von Zahlen und Buchstaben werden aus den Werten entfernt, so lassen sich Werte vergleichen, während Leerzeichen, Bindestriche, Schrägstriche und andere beliebige Zeichen ignoriert werden, die in diesen Werten enthalten sein können

Bei Anwendung der Normalisierung steht die Option Normalisierten Wert speichern zur Verfügung, sobald die Spalte Datensatz einer Spalte in einer externen Datenbank zugeordnet wird.

  • Wird diese Option aktiviert, werden die normalisierten Werte im Datensatz gespeichert.
  • Wird diese Option deaktiviert, werden die Originalwerte aus der externen Datenbank in den Datensatz kopiert.

Diese Option wirkt sich nicht auf die Datenextrahierung oder automatisierte Überprüfungen aus, legt aber fest, welcher Wert einem Benutzer angezeigt wird, sobald dieser nach einem Eintrag im Wörterbuch sucht.


Einstellungen für den Datenexport

In einem Projekt kann für jeden Dokumentstatus ein Exportprofil eingerichtet werden (weitere Informationen über das Thema Status finden Sie unter See " Was ist ABBYY FlexiCapture for Invoices? "). Sie können beispielsweise Dokumente mit dem Status Abgelehnt in einen separaten Ordner exportieren. Jedes Exportprofil kann seine eigenen Exporteinstellungen (wie beispielsweise das Exportieren zu Datendateien oder ODBC-kompatiblen Datenbanken), den Exportpfad und eine Liste der Felder enthalten, aus denen die Daten exportiert werden sollen.

Die erfassten Daten müssen nach der Überprüfung exportiert werden. Ein Projekt besitzt bereits zwei Exportprofile, die als Beispiele bereitgestellt werden. Eines dieser Profile ist für Dokumente mit dem Status Gültig, das andere ist für Dokumente mit dem Status Ausnahme. Beide Profile exportieren die Daten in das Format *.csv, verwenden aber unterschiedliche Pfade: das erste Profil exportiert die Daten in den Ordner Export (gültig) und das zweite Profil in den Ordner Export (Ausnahme). Für weitere Informationen zu Exportprofilen See "Konfigurieren des Datenexports"

Einrichtung des Exports auf Basis des Dokumentenstatus

Die Exporteinrichtung in ABBYY FlexiCapture for Invoices funktioniert größtenteils wie in ABBYY FlexiCapture (See "Konfigurieren des Datenexports")

  1. Öffnen Sie das Menü Projekt und klicken Sie auf Dokumentdefinitionen….
  2. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Schaltfläche Bearbeiten….
  3. Öffnen Sie das Menü Dokumentdefinition und klicken Sie auf Exporteinstellungen….
  4. Im daraufhin angezeigten Dialogfeld klicken Sie auf Hinzufügen…, um den Exportzielassistent anzuzeigen.
  5. Bestimmen Sie die Exporteinstellungen.
  6. Wählen Sie die Option Feldbedingung.
  7. Klicken Sie im daraufhin geöffneten Dialogfeld Exportbedingungen auf die Schaltfläche Auswählen….
  8. Wählen Sie aus der Feldliste das Element Status durch Doppelklick.
  9. Wählen Sie Gehört zu Satz aus der Dropdownliste.
  10. Bestimmen Sie den Status (Gültig, Ausnahme oder Abgelehnt), den eine Rechnung haben muss, um exportiert werden zu können.
  11. Klicken Sie auf die Schaltfläche Hinzufügen.
  12. Klicken Sie auf OK. Der ausgewählte Status wird im Exportzielassistent angezeigt.
  13. Folgen Sie den Anweisungen im Assistenten für die Einrichtung des Exportprofils.

Die Liste der Exportprofile enthält jetzt ein neues Profil, das auf Dokumente mit dem von Ihnen festgelegten Status angewendet wird.

Liste der Felder bearbeiten, aus denen die Daten exportiert werden sollen

Standardmäßig werden die Daten aller Felder exportiert. Sie können jedoch das Exportieren von Daten aus bestimmten Feldern verhindern oder eine separate Liste von Feldern erstellen, aus der die Daten in die jeweiligen Exportprofile exportiert werden sollen. Für ausführliche Informationen See "Konfigurieren des Datenexports".


Der Status von Dokumenten in Projekten von ABBYY FlexiCapture for Invoices

Nachdem die Rechnungen in das Programm eingespeist wurden, werden sie automatisch erkannt und dann anhand einer Reihe von Validierungsregeln überprüft. Nach der Anwendung der Regeln wird jeder Rechnung ein Status zugewiesen.

Status | Beschreibung
Gültig | Die Regelüberprüfungen wurden erfolgreich abgeschlossen und die Rechnung kann jetzt exportiert werden
Abgelehnt | Die Rechnung muss überprüft werden
Ausnahme | Die Rechnung entspricht nicht der Gesetzgebung (die erforderlichen Daten konnten nicht gefunden werden, fehlen oder wurden falsch erkannt). Diese Daten müssen manuell angegeben oder die Rechnung muss auf andere Weise verarbeitet werden (z. B. Rückgabe an den Lieferanten)

Der Status einer Rechnung wird auf der Basis von Regelsätzen zugewiesen, die bereits erstellt wurden (See "Verfügbare Regeln").

Die Dokumente mit dem Status Gültig können ohne Überprüfung exportiert werden.

Rechnungen mit einem anderen Status müssen zuerst vom Operator überprüft werden. Der Operator untersucht jedes Dokument und korrigiert Fehler oder Warnungen, die von den Regeln ausgegeben werden. Nachdem die Fehler und Warnungen in einer Rechnung korrigiert wurden, ändert sich der Status auf Gültig. Der Operator kann außerdem wählen, ob er einem automatisch zugewiesenen Status zustimmen oder einen Status manuell zuweisen möchte, und kann den Grund dafür in das Kommentarfeld eingeben.

Kann das Programm durchgehend bestimmte Felder in Rechnungsbildern nicht erkennen, kann der Operator das Programm trainieren, indem die korrekten Feldpositionen im aktuellen Bild angegeben werden.

Dokumente mit unterschiedlichen Statusangaben können zur nachfolgenden Verarbeitung durch Ihre Finanzsoftware zu verschiedenen Zielen exportiert werden. Die vom Operator angegebenen Statusänderungen werden auch in Ihrer Finanzsoftware angezeigt.

Vom Operator zugewiesener Status: Kommentare des Operators und vordefinierte Gründe für die Statusänderung

Der Operator kann die von den Regeln ausgegebenen Fehler und Warnungen ignorieren und der Rechnung manuell einen Status zuweisen. Ist das der Fall, muss der Operator einen Kommentar eingeben oder aus der Liste vordefinierter Gründe einen Grund auswählen.

  1. Wählen Sie im Menü Projekt Dokumentdefinitionen….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf Bearbeiten….
  3. Öffnen Sie das Menü Dokumentdefinition und wählen Sie Eigenschaften der Dokumentdefinition….
  4. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte Rechnungseinstellungen.
  5. Klicken Sie auf Bearbeiten… neben der Gruppe Bearbeitung des Status der Rechnungsausgabe. Das Dialogfeld Gründe der Statusänderung wird geöffnet.

Bearbeiten der Liste mit vordefinierten Gründen:

Durch die Auswahl eines Elements in der Liste Status kann die Liste vordefinierter Gründe für die Statusänderung einer Rechnung angezeigt werden.

Um einen neuen benutzerdefinierten Grund hinzuzufügen, klicken Sie auf Hinzufügen…. Geben Sie im Dialogfeld Grund für Statusänderung einen neuen Grund und dessen Code ein.

Um einen Grund aus einer Textdatei zu laden, klicken Sie auf die Schaltfläche Laden….

Operatoren erlauben, ihre eigenen Gründe einzugeben:

Wählen Sie die Option Der Operator kann benutzerdefinierte Gründe eingeben, wenn es dem Operator erlaubt sein soll, seine eigenen Gründe für die Statusänderung einzugeben.

Einrichtung eines statusabhängigen Exports

Im Allgemeinen unterscheidet sich der Export für ABBYY FlexiCapture for Invoices nicht von der Einrichtung eines Exports in ABBYY FlexiCapture (See "Konfigurieren des Datenexports"). Zu ausführlichen Anweisungen für die Einrichtung eines statusabhängigen Exports in ABBYY FlexiCapture for Invoices See "Einstellungen für den Datenexport".

Regeln, die sich auf den Status einer Rechnung auswirken

Anzeige der Regeln:

  1. Öffnen Sie das Menü Dokumentdefinition und wählen Sie Eigenschaften der Dokumentdefinition….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf die Registerkarte Regeln.

Eine Regel kann sich auf den Status einer Rechnung auswirken.

Damit sich eine Regel auf den Status einer Rechnung auswirkt, fügen Sie ihrem Namen den Präfix (Abgelehnt) oder (Ausnahme) hinzu. Von einer Regel mit diesem Präfix ausgegebene Fehler führen dazu, dass der entsprechende Status einer fehlgeschlagenen Rechnung zugewiesen wird. Ein statusändernder Präfix kann einer Regel entweder bei Erstellung einer neuen Regel oder bei Bearbeitung einer vorhandenen Regel hinzugefügt werden.


ABBYY FlexiCapture for Invoices Trainieren

You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > ABBYY FlexiCapture for Invoices Trainieren

ABBYY FlexiCapture for InvoicesTrainieren

Die Qualität der Datenerfassung kann durch das Training von ABBYY FlexiCapture for Invoices verbessert werden. Die Benutzer können ABBYY FlexiCapture for Invoices vor oder während der Rechnungsverarbeitung trainieren.

Das Training wird nur für folgende Bildarten und in folgenden Fällen durchgeführt:

  • die Dokumentdefinition kann Felder in einem Bild nicht korrekt erkennen;
  • der Benutzer muss Daten aus Feldern extrahieren, die nicht in der Dokumentdefinition definiert sind.
Collapsed Wann kann Training nützlich sein

In einem Strom von Dokumenten des gleichen Typs können Dokumente auftreten, bei denen sich die Feldpositionen von denen im Standarddokument unterscheiden. Kann ABBYY FlexiCapture für Rechnungen Felder in solchen Dokumenten nicht zuverlässig erkennen, kann der Benutzer die korrekten Feldpositionen angeben und das Programm "lernt", wie man diese Felder erkennt.

Neben den standardmäßig unterstützten Haupt- und zusätzlichen Feldern kann es erforderlich sein, Daten aus Feldern erfassen, die dem Programm noch unbekannt sind. Trifft das zu, kann der Benutzer benutzerdefinierte Felder in der Dokumentdefinition erstellen und dann deren Positionen in den Rechnungsbildern angeben. Jetzt ist es dem Programm möglich, Daten auch aus diesen Feldern zu erfassen.

Typischerweise bevorzugt jeder Lieferant Rechnungen eines bestimmten Typs. Daher sollten das Training für Rechnungen von verschiedenen Lieferanten separat durchgeführt werden. Rechnungen von verschiedenen Lieferanten werden als Dokumentvarianten behandelt.

Collapsed So funktioniert das Training

Der Benutzer fügt Bilder von Rechnungen hinzu, deren Erfassung das Programm trainieren muss. Das kann entweder während der normalen Dokumentverarbeitung oder in einem speziellen Trainingsmodus ausgeführt werden. Die hinzugefügten Rechnungen werden automatisch erkannt und zur Überprüfung weitergeleitet. Der Benutzer überprüft die Dokumente und korrigiert die Feldpositionen, wo es erforderlich ist, wodurch ein Referenzlayout erstellt wird.

Dann kann der Benutzer das Dokument dem Satz von Beispielrechnungen für den gegebenen Lieferanten hinzufügen. Dem Administrator wird in der Liste [image] Lernstapel eine Liste aller Rechnungsvarianten und deren Beispielbilder angezeigt. Nachdem das erste Beispielbild für eine Dokumentvariante hinzugefügt wurde, wechselt die Dokumentvariante in den Beispiel-Sammelmodus.

Mindestens drei Beispielbilder sind für das Trainieren einer neuen Dokumentvariante erforderlich. Hat das Programm eine ausreichende Anzahl von Dokumentbildern erhalten, startet das Training automatisch. Der Benutzer kann den Trainingsprozess auch durch Anklicken der entsprechenden Schaltfläche manuell starten.

Das Training erzeugt eine FlexiLayout-Variante, die für alle Dokumente verwendet wird, die zu dieser Dokumentvariante gehören (d. h. für alle Rechnungen von diesem Lieferanten).

Nachdem das Training abgeschlossen ist, wird die FlexiLayout-Variante vom Programm automatisch getestet. Alle Beispielbilder für diese Dokumentvariante werden durch die Anwendung des neu erstellten FlexiLayouts erkannt.

Die Qualität der neuen FlexiLayout-Variante wird durch den Vergleich der Erkennungsergebnisse mit dem vom Benutzer festgelegten Referenzlayout bestimmt. Die gleiche Vorgehensweise wird auch für die Bestimmung der Qualität eines Haupt-FlexiLayouts genutzt, das verwendet wird, wenn kein Training durchgeführt wurde. Als Nächstes wird die Qualität der FlexiLayout-Variante mit der Qualität der vorherigen FlexiLayout-Variante oder mit der Qualität des Haupt-FlexiLayouts verglichen:

  • Ist die Qualität der neuen FlexiLayout-Variante schlechter als die Qualität der alten FlexiLayout-Variante oder des Haupt-FlexiLayouts, wird das neue FlexiLayout nicht gespeichert und dem Benutzer wird im Fenster Dokumentdefinition lernen eine entsprechende Meldung angezeigt.
  • Ist die Qualität der neuen FlexiLayout-Variante besser als die Qualität der alten FlexiLayout-Variante oder des Haupt-FlexiLayouts, wird diese gespeichert und für die weitere Verarbeitung von Dokumenten verwendet, die zu dieser Dokumentvariante gehören (d. h. Rechnungen von diesem Lieferanten).

Das Training von ABBYY FlexiCapture for Invoices kann auch während der Verarbeitung von Dokumenten durchgeführt werden. Der Benutzer kann dem Arbeitsstapel Rechnungsbilder hinzufügen, die dann automatisch erkannt und zur Überprüfung weitergeleitet werden. Der Benutzer überprüft die Dokumente und korrigiert die Feldpositionen, wo es erforderlich ist. Als Nächstes klickt der Benutzer auf die Schaltfläche [image] im Dokumenteditor. Dadurch wird das Dokument dem Satz von Beispielbildern für die gegebene Dokumentvariante hinzugefügt. Jeder Dokumenttyp wird basierend auf dem ausstellenden Lieferanten bestimmt. Hat das Programm eine ausreichende Anzahl von Dokumentbildern für die Dokumentvariante erhalten, startet das Training automatisch. Zukünftig wird das Programm bei der Verarbeitung von Dokumenten, die zu diesem Dokumentlieferanten gehören, das während des Trainingsprozesses erhaltene Wissen einsetzen. Das "Training während der Verarbeitung" kann vom Administrator oder von Operatoren durchgeführt werden, vorausgesetzt die Person besitzt die erforderlichen Berechtigungen.

Wurde durch das "Training während der Verarbeitung" keine Verbesserung bei der Datenerfassung erreicht, kann der Administrator zur speziellen Ansicht [image] Lernstapel wechseln und mit dem Training dieser speziellen Dokumentvariante fortfahren. Der Administrator kann folgende Aktionen durchführen:

  • Verwaltung des Satzes von Beispielbildern, die für das Training der Dokumentvariante verwendet werden (z. B. neue Bilder hinzufügen und Bilder löschen, die seiner Meinung nach für die Dokumentvariante nicht repräsentativ sind);
  • Hinzufügen von Beispielbildern, die nicht für das Training an sich verwendet werden, sondern für das Testen der FlexiLayout-Variante, die durch das Training erhalten wurde.
  • Exportieren der resultierenden FlexiLayout-Variante zu ABBYY FlexiLayout Studio oder Importieren eines FlexiLayouts aus ABBYY FlexiLayout Studio.

Diese zusätzlichen Funktionen ermöglichen dem Administrator, den Nutzen des Trainings zu maximieren. Sobald das gewünschte Ergebnis erreicht ist, kann der Administrator das "Training während der Verarbeitung" für die gegebene Dokumentvariante verbieten.

See "Training während der Verarbeitung von Dokumenten"

See "Training durch Benutzer mit Berechtigungen zur Projekteinrichtung"


Training während der Verarbeitung von Dokumenten

Mit ABBYY FlexiCapture for Invoices kann während der Verarbeitung von Dokumenten die Erkennungsqualität verbessert werden. Kann die korrekte Position eines Feldes in einem Dokumentbild vom Programm nicht bestimmt werden, kann ein Operator die korrekte Position festlegen und auf die Schaltfläche [image] klicken. Das Programm speichert dann diesen Speicherort und nutzt ihn bei der Erkennung anderer Dokumente.

Dieser Artikel erläutert das Training von ABBYY FlexiCapture for Invoices mithilfe der lokal installierten Version der Überprüfungsstation und behandelt einige trainingsbezogene Probleme, die Operatoren kennen sollten. Die Unterschiede zwischen dem Training mit der lokal installierten Version und mit den Remote- und Webversionen der Überprüfungsstation werden in einem separaten Artikel behandelt.

  1. Sammeln Sie einen Stapel von Rechnungen (z. B. die innerhalb des letzten Monats verarbeiteten Rechnungen) und speisen Sie diese in das Programm ein. See "Erfassen von Rechnungen"
  2. Nachdem die Dokumente in das Programm eingespeist wurden, werden sie automatisch erkannt (das geschieht nur bei aktivierter Option Hinzugefügte Bilder automatisch erkennen auf der Registerkarte Dokumentverarbeitung im Dialog Optionen; um diesen Dialog zu öffnen, klicken Sie auf Extras> Optionen…) und die Daten werden anhand der Validierungsregeln überprüft.
  3. Lautet der Status einer erkannten Rechnung nicht Gültig oder bestehen andere Gründe für die Annahme, dass einige der Felder vom Programm nicht erkannt werden konnten, öffnen Sie das Dokument im Dokumenteditor.
  4. Überprüfen Sie das Dokumentformular. Die Feldgruppe Lieferant muss korrekt ausgefüllt sein.
Collapsed Sonstiges...

Das Training erfolgt unabhängig für jede einzelnen Dokumentvariante. Rechnungen desselben Lieferanten werden als der gleichen Dokumentvariante zugehörig angesehen. Wurde der Lieferant falsch ausgewählt, wird während des Trainings die falsche Dokumentvariante für eine Rechnung ausgewählt. Kann der Lieferant vom Programm nicht erkannt werden, wählen Sie mithilfe der Funktion Lieferantensuche den richtigen Lieferanten aus. Kann der Lieferant in der Datenbank nicht gefunden werden, geben Sie den Namen manuell ein, wie er im Bild angezeigt wird, und speichern ihn in der Datenbank, indem Sie auf Speichern klicken.

Ja nach Projekteinstellungen müssen Sie u. U. auch die einzigartige ID des Lieferanten in der Rechnung festlegen, damit das Programm mit dieser Rechnung trainieren kann. Dafür geben Sie in das Feld USt-IdNr die einzigartige ID ein (dieses Feld kann bei einigen Lokalisierungen des Projekts einen anderen Namen haben). Die USt-IdNr ist eine einzigartige Identifikationsnummer, die den Unternehmen für wertschöpfende Besteuerungszwecke zugewiesen wird.

  5. Das Training wird nur dann erfolgreich sein, wenn die Bereiche aller Felder korrekt markiert wurden, stellen Sie daher sicher, dass die Bereiche den tatsächlichen Bereichen ihrer jeweiligen Felder im Bild entsprechen.

Um das zu erreichen, passen Sie im Bildfenster des Dokumenteditors die Bereiche an oder zeichnen Bereiche für die Felder, die das Programm nicht erkennen konnte.

Collapsed Den Bereich eines Feldes ändern
  • Positionieren Sie den Mauszeiger im gewünschten Feld im Datenformular, suchen Sie den entsprechenden Bereich im Bild (dieser wird blau markiert) und klicken Sie diesen an (oder zeichnen Sie mit der Maus ein Rechteck);
  • Positionieren Sie den Mauszeiger auf einem gewünschten Bereich im Bild (dieser wird blau markiert), klicken Sie diesen an (oder zeichnen Sie den Bereich mit der Maus) und wählen Sie dann das entsprechende Feld aus dem sich daraufhin öffnenden Dropdownmenü;
  • Korrigieren Sie die Position eines Bereichs im Bild, indem Sie dessen Ränder mit der Maus bewegen;
  • Löschen eines falsch positionierten Bereichs aus dem Bild: Positionieren Sie den Mauszeiger auf dessen Rechteck und klicken Sie auf das rote Kreuz, sobald es in der Ecke oben rechts angezeigt wird. Der Markierung des Bereichs wird daraufhin gelöscht. Erstellen Sie jetzt einen neuen Bereich für dieses Feld an der korrekten Position;
  • Beginnen Sie im Datenformular, einen Wert in das Feld einzugeben. Es wird jetzt eine Dropdownliste mit den aus dem Bild erfassten Wörtern angezeigt, die dem eingegebenen Wort ähnlich sind. Wählen Sie das korrekte Wort aus der Liste aus und die Position des Wortes im Bild wird dann zum Bereich des Feldes.
  6. Nachdem nun alle Felder korrekt markiert wurden, klicken Sie auf die Schaltfläche [image] und das Dokument wird den Beispielbildern hinzugefügt, die für diese Dokumentvariante verwendet werden.

Die Schaltfläche [image] wird anklickbar, sobald die folgenden Bedingungen erfüllt sind:

  • Mindestens ein Feldbereich im Bild wurde geändert.

Wichtig! Gelöschte Feldbereiche können für das Training des Programms nicht verwendet werden, d. h. das Programm kann die Informationen darüber, wo die Felder nicht positioniert sein können, nicht nutzen.

  • Die Lieferantendaten sind korrekt.

Kann die Schaltfläche [image] nicht angeklickt werden, halten Sie den Mauszeiger über die Schaltfläche und es wird eine Benachrichtigung mit einer Erläuterung angezeigt.

Klicken Sie auf [image], werden alle Felder der Rechnung zu Trainingszwecken verwendet, nicht nur diejenigen, deren Markierungen von Ihnen hinzugefügt oder bearbeitet wurden. Klicken Sie daher unbedingt erst dann auf [image], wenn sich die Bereiche aller Felder im Bild an den korrekten Positionen befinden.

Haben Sie mindestens ein Beispielbild für eine Dokumentvariante hinzugefügt, ist die Schaltfläche [image] sofort für nachfolgende Dokumente verfügbar, die Sie dieser Dokumentvariante hinzufügen. Die Begründung für die aktive Schaltfläche [image] ist, Ihnen das Hinzufügen von Beispielbildern zu ermöglichen, bei denen alle Felder korrekt erkannt wurden und für die keine weiteren Korrekturen erforderlich sind.

  7. Wiederholen Sie die Schritte 4-6 für das nächste Dokument.
  8. Nachdem Sie für diese Dokumentvariante ein drittes und nachfolgende Beispielbilder hinzugefügt haben, wird der Trainingsvorgang jedes Mal gestartet, sobald Sie ein neues Beispiel hinzufügen (das Fenster Dokumentdefinition lernen angezeigt). Entweder wird eine spezielle FlexiLayout-Variante für diese Dokumentvariante erstellt oder das Programm fordert Sie auf, mit dem Hinzufügen von Beispielbildern fortzufahren (in diesem Fall wählen Sie das nächste Dokument aus und gehen zurück zu Schritt 4).

Wurde die FlexiLayout-Variante erfolgreich trainiert, wird diese für die nächste Rechnung von dem Lieferanten verwendet, dessen Rechnungen zu der vorgegebenen Dokumentvariante gehören. Nach der Erkennung werden die Feldbereiche den Feldern im Rechnungsbild zugeordnet, und das trainierte Wissen wird berücksichtigt.

Die Schaltfläche [image] wechselt jetzt zurück in den normalen Modus, d. h. sie wird dann wieder anklickbar sein, wenn Sie die Markierung von mindestens einem Bereich bearbeitet haben).

Nachdem Sie jetzt eine ausreichende Anzahl von Beispielbildern für die Dokumentvariante gesammelt haben, wird das Training jedes Mal beim Hinzufügen eines neuen Beispielbildes gestartet (d h. jedes Mal, wenn Sie [image] anklicken). Klicken Sie nur auf [image], wenn einige der Bereiche nicht korrekt ihren Feldern zugeordnet wurden und wenn deren Positionen im Bild korrigiert werden mussten.

  9. Fügen Sie weitere Rechnungen von dem Lieferanten hinzu, dessen Dokumentvariante trainiert wurde und erkennen Sie sie. Öffnen Sie dann die neu hinzugefügten Rechnungen der Reihe nach im Dokumenteditor, um die korrekte Markierung der Bereiche zu überprüfen. Wurden alle Bereiche korrekt markiert, ist kein zusätzliches Training erforderlich.

Sind Sie mit den Ergebnissen nicht zufrieden, trainieren Sie weiter mit dem Programm anhand von Rechnungen des gegebenen Lieferanten (wiederholen Sie die Schritte 4-6). Jetzt wird nach jedem Klicken auf [image] der Trainingsprozess gestartet. War das Training erfolgreich, wird eine neue FlexiLayout-Variante erstellt.

See "Training durch Benutzer mit Berechtigungen zur Projekteinrichtung"


You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > ABBYY FlexiCapture for Invoices Trainieren > Training durch Benutzer mit Berechtigungen zur Projekteinrichtung

Training durch Benutzer mit Berechtigungen zur Projekteinrichtung

Während des Trainings mit Beispielstapeln sammelt der Administrator einen Stapel mit Beispielrechnungen von einem Lieferanten und das Programm trainiert während ihrer Verarbeitung. Sind die Ergebnisse eines solchen Trainings nicht zufriedenstellend, kann der Operator zur Stapelansicht wechseln und die erweiterte Auswahl von Trainingswerkzeugen nutzen, die diese Ansicht bereitstellt. Sobald der Trainingsprozess abgeschlossen ist, kann der Administrator den Operatoren das Trainieren von ABBYY FlexiCapture for Invoices mit Rechnungen des Lieferanten verbieten, der die Rechnungen des Beispielstapels ausgestellt hat.

Hinweis: Die in diesem Abschnitt beschriebenen Aktionen können nur von Administratoren oder Benutzern ausgeführt werden, die zur Einrichtung von Projekten in ABBYY FlexiCapture for Invoices berechtigt sind.

In der Beispielstapelansicht werden alle Bilder angezeigt, die durch Klicken auf die Schaltfläche [image] hinzugefügt wurden. Um diese Ansicht zu öffnen, klicken Sie in der Symbolleiste auf [image] (Lernstapel) oder wählen Ansicht>Lernstapel.

Das Programm zeigt dann eine Liste aller Dokumentvarianten an, denen Operatoren durch Klicken auf die Schaltfläche [image] Beispielbilder hinzugefügt haben.

Der Rechnungstyp wird basierend auf dem Lieferanten bestimmt und trägt denselben Namen wie das Unternehmen des Lieferanten. Um die Suche zu vereinfachen, enthalten die Spalten Informationen über den Lieferanten, einschließlich der USt-IdNr (die einzigartige Steueridentifikationsnummer des Lieferanten), IBAN und die ID des Lieferanten in der externen Datenbank.

In dieser Ansicht kann keine neue Dokumentvariante erstellt werden. Die einzige Möglichkeit für das Hinzufügen einer neuen Dokumentvariante ist das Anklicken der Schaltfläche [image] während der Verarbeitung von Rechnungen.

In dieser Ansicht können jedoch die Dokumentvarianten verwaltet werden. Folgende Aktionen sind möglich:

Collapsed Verwaltung der Beispielbilder, die für das Trainieren der FlexiLayout-Varianten verwendet werden

Doppelklicken Sie auf eine Dokumentvariante und wählen Sie Öffnen aus dem Kontextmenü. Eine Liste der Beispieldateien für diese Dokumentvariante wird angezeigt.

Jedes Beispielbild kann eine der folgenden drei Statusarten besitzen:

  • Nicht verwendet - Dieses Beispielbild wird nicht verwendet
  • Für Lernen - Dieses Beispielbild wird für das Trainieren und Testen der FlexiLayout-Variante verwendet
  • Für Tests - Dieses Beispielbild wird nur für das Testen der FlexiLayout-Variante verwendet

In dieser Ansicht benötigen Sie nur ein Beispielbild, um das Trainieren einer FlexiLayout-Variante zu starten. Wir empfehlen jedoch mindestens drei Beispielbilder mit dem Status Für Lernen.

Sind nicht ausreichend Beispielbilder für das Training vorhanden, können durch Klicken auf Bilder laden… weitere Bilder geladen werden. Standardmäßig werden alle neu hinzugefügten Bilder markiert als Nicht verwendet.

Werden die von Ihnen hinzugefügten Bilder nicht automatisch erkannt, kann der Start der Erkennung durch Klicken auf Erkennung erzwungen werden..

  1. Ändern Sie den Status der Bilder, die Sie verwenden möchten, auf Für Lernen. Um den Status zu ändern, wählen Sie die benötigten Bilder aus, klicken diese mit der rechten Maustaste an und wählen Dokumentstatus festlegen>Für Lernen. Wir empfehlen die Änderung des Status' für alle Beispielbilder auf Für Lernen, wenn für diese Dokumentvariante zuvor kein Training durchgeführt wurde.
  2. Überprüfen Sie die Markierungen aller Bereiche und nehmen Sie bei Bedarf Korrekturen vor. Das ist wichtig, da die Positionen aller Bereiche berücksichtigt werden.
  3. Beginnen Sie das Trainieren der FlexiLayout-Variante. Entweder
    • Wählen Sie Projekt>Training>Lernen aus dem Hauptmenü, oder
    • Klicken Sie mit der rechten Maustaste auf die Liste und wählen im Kontextmenü die Option Lernen aus.
    • Wechseln Sie zur Beispielstapelansicht und wählen im Kontextmenü der Dokumentvariante Lernen.

Der Trainingsfortschritt wird im Fenster Dokumentdefinition lernen angezeigt. Als Ergebnis dieses Trainings wird eine FlexiLayout-Variante erstellt. Als Nächstes wird die FlexiLayout-Variante an allen Dokumenten getestet, die mit Für Lernen und Für Tests markiert sind. Das Programm wendet jetzt das FlexiLayout auf jedes Beispielbild an (dieser Vorgang wird dem Benutzer nicht angezeigt) und vergleicht die Ergebnisse mit dem Referenzlayout (d. h. dem manuell vom Benutzer erstellten Layout). Dann wird die Qualität der Zuordnung bestimmt.

Erzeugt die neue FlexiLayout-Variante eine bessere Qualität als die vorherige Version dieser FlexiLayout-Variante und des Haupt-FlexiLayouts, wird die neue FlexiLayout-Variante gespeichert und für die nachfolgende Datenerfassung verwendet.

Haben Sie den Eindruck, dass sich einige der Beispielbilder negativ auf das Training auswirken, diese aber dennoch zum Testen weiter verwendet werden sollen, ändern Sie deren Status auf Für Tests.

Stellen Sie sicher, dass zum Zeitpunkt des Trainings (d. h., wenn Sie auf [image] klicken) die Bereiche aller Felder in diesen Beispielbildern korrekt positioniert sind. Der Testvorgang selbst ist dem Benutzer nicht sichtbar.

Collapsed Exportieren einer FlexiLayout-Variante zu FlexiLayout Studio für eine manuelle Feinabstimmung

Klicken Sie mit der rechten Maustaste auf die gewünschte Dokumentvariante und wählen Sie Erlerntes FlexiLayout exportieren… aus dem Kontextmenü.

Das kann erforderlich sein, wenn durch das einfache Hinzufügen oder Entfernen von Beispielbildern die gewünschten Ergebnisse nicht erzielt werden können.

Collapsed Importieren einer FlexiLayout-Variante von FlexiLayout Studio

Klicken Sie mit der rechten Maustaste auf die gewünschte Dokumentvariante und wählen Sie FlexiLayout importieren… aus dem Kontextmenü.

Das kann erforderlich sein, wenn ein FlexiLayout vorliegt, das in FlexiLayout Studio manuell für die Dokumentvariante erstellt wurde.

Collapsed Weiteres Training mit Rechnungen eines bestimmten Lieferanten verbieten

Klicken Sie mit der rechten Maustaste auf die gewünschte Dokumentvariante und wählen Sie Gesperrt aus dem Kontextmenü.

Das kann erforderlich sein, wenn das FlexiLayout bereits für die Dokument-Variante trainiert (oder manuell erstellt) wurde und wenn während der Rechnungsverarbeitung kein weiteres Training mehr erforderlich ist.

Collapsed Weitere Verwendung der Trainingsergebnisse bei der Verarbeitung von Rechnungen eines bestimmten Lieferanten verbieten

Klicken Sie mit der rechten Maustaste auf die gewünschte Dokumentvariante und wählen Sie Deaktiviert aus dem Kontextmenü.

Wählen Sie diese Option, wenn das Haupt-FlexiLayout nur bei der Verarbeitung von Rechnungen des Lieferanten aus dieser Dokumentvariante verwendet werden soll.

Der Status der jeweiligen Dokumentvariante wird in der Spalte Status in der Liste der Beispielstapel angezeigt.

Mindestens drei Beispielbilder sind für das Trainieren einer FlexiLayout-Variante erforderlich. Das Training beginnt erst, nachdem während der Rechnungsverarbeitung durch Klicken auf die Schaltfläche [image] mindestens drei Beispielbilder hinzugefügt wurden. Bis zu diesem Zeitpunkt werden die Wörter Erfassung von Beispielen in der Spalte Status neben der Dokumentvariante angezeigt.

Nachdem eine Variante trainiert wurde und das Programm mit ihrer Qualität zufrieden ist, ändert sich deren Status zu Stabil.


You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > ABBYY FlexiCapture for Invoices Trainieren > Übertragung der Trainingsergebnisse in ein anderes Projekt

Übertragung der Trainingsergebnisse in ein anderes Projekt

Mit ABBYY FlexiCapture for Invoices können Trainingsergebnisse in mehreren Projekten wiederverwendet werden.

Um Ihre Trainingsergebnisse in einem anderen Projekt verwenden zu können, müssen die Trainingsstapel in dieses Projekt importiert werden.

Für Rechnungen, die von einem bestimmten Lieferanten ausgestellt wurden, wird ein Trainingsstapel erstellt. Aus diesem Grund ist es beim Importieren der Trainingsstapel in ein neues Projekt wichtig, die Trainingsstapel mit ihren jeweiligen Lieferanten dem Datensatz Lieferanten des neuen Projekts zuzuordnen.

Zuordnung der Trainingsstapel zu Lieferanten auf der Basis der Lieferanten-ID

In ABBYY FlexiCapture for Invoices und in dem externen System, in welches die aus den Rechnungen erfassten Daten exportiert werden, werden die Lieferanten anhand des Werts der Lieferanten-ID (VendorId) identifiziert. Diese Werte sind abhängig vom verwendeten externen System und können sich von Projekt zu Projekt unterscheiden.

Verwenden die Projekte die gleiche Lieferantenliste, entsprechen ihre Werte der Lieferanten-ID den Lieferanten-Datensätzen der ABBYY FlexiCapture-Projekte. In diesem Fall ist die beste Vorgehensweise die Zuordnung der importierten Trainingsstapel zu ihren jeweiligen Lieferanten auf der Basis der Werte der Lieferanten-ID. Ein Trainingsstapel speichert den Wert der Lieferanten-ID des Lieferanten, für den er erstellt wurde. Beim Importieren in das neue Projekt wird der Trainingsstapel dem Lieferanten mit der gleichen Lieferanten-ID zugeordnet.

Um die Trainingsstapel auf der Basis der Lieferanten-ID den jeweiligen Lieferanten zuordnen zu können, wählen Sie die Option Hersteller-ID beibehalten im Dialogfeld Lernstapel importieren.

Diese Vorgehensweise kann bei Projekten, bei denen die Lieferanten-ID von der Geschäftseinheit abhängig ist, nicht verwendet werden, da die Lieferanten-ID in diesem Fall nicht als einzigartige Kennung des Lieferanten fungieren kann. Für ein und denselben Lieferanten, der nur einen Trainingsstapel haben soll, gibt es dann mehrere Lieferanten-IDs, jeweils eine pro Geschäftseinheit.

Zuordnung der Trainingsstapel zu Lieferanten auf der Basis von USt-IdNr und IBAN

Die Trainingsstapel können ihren jeweiligen Lieferanten nicht auf der Basis der Lieferanten-ID zugeordnet werden, wenn:

  • das Projekt die aus Rechnungen erfassten Daten in verschiedene externe Systeme exportiert (da verschiedene Lieferantenlisten verwendet werden)
  • wenn die verschiedenen Geschäftseinheiten jeweils eine andere Lieferanten-ID haben

Um einen Trainingsstapel mit seinem Lieferanten zu verbinden, können andere einzigartige Lieferantenkennungen verwendet werden, wie z. B. USt-IdNr und IBAN. Ein Trainingsstapel speichert die Werte für USt-IdNr und IBAN seines Lieferanten. Wird ein Trainingsstapel in ein neues Projekt importiert, sucht das Programm nach einem Lieferanten mit den gleichen Werten für USt-IdNr und IBAN. Gleicht mindestens einer dieser zwei Werte dem Eintrag im Datensatz Lieferanten des neuen Projekts, wird der Trainingsstapel dem entsprechenden Lieferanten zugeordnet.

Um die Trainingsstapel auf der Basis von USt-IdNr und IBAN den Lieferanten zuordnen zu können, deaktivieren Sie die Option Hersteller-ID beibehalten im Dialogfeld Lernstapel importieren.

Importieren von Trainingsstapeln in ein neues Projekt

  1. Öffnen Sie das neue Projekt in ABBYY FlexiCapture.
  2. Klicken Sie im Hauptmenü auf Projekt>Lernen>Lernstapel importieren….
  3. Je nachdem, wie die Trainingsstapel ihren Lieferanten zugeordnet werden sollen, wählen Sie die Option Hersteller-ID beibehalten im Dialogfeld Lernstapel importieren oder deaktivieren diese.
  4. Bestimmen Sie den Pfad zum Projekt, das die zu importierenden Trainingsstapel enthält.

Als Ergebnis werden die Trainingsstapel, die das Programm ihren Lieferanten aus dem Datensatz Lieferanten des neuen Projekt zuordnen kann, in das neue Projekt importiert, und zwar gemeinsam mit den im Ergebnis des Trainings erstellten FlexiLayout-Varianten und der Beispielbilder, anhand derer das Programm trainiert wurde. Durch das Hinzufügen neuer Rechnungsbilder zu denen, die in das neue Projekt importiert wurden, kann ein zusätzliches Training der importierten FlexiLayout-Varianten durchgeführt werden.

Wenn Sie versuchen, einen Trainingsstapel für einen Lieferanten zu importieren, für den im neuen Projekt bereits ein Trainingsstapel vorhanden ist, wird das Programm den besten Trainingsstapel auswählen: die Dokumente des jeweiligen Stapels werden den trainierten FlexiLayout-Varianten jedes gegebenen Stapels zugeordnet und der Stapel mit der größeren Anzahl korrekt erkannter Felder gewinnt.


Regeln

ABBYY FlexiCapture for Invoices verwendet Regeln für die automatische Überprüfung von Rechnungen. Nach der Überprüfung wird der Rechnung ein Status zugewiesen und eine Liste der ausgegebenen Fehler und Warnungen wird generiert, sodass der Operator entscheiden kann, ob die Rechnung manuell überprüft werden muss. Während der Überprüfung einer Rechnung im Dokumenteditor wird dem Operator eine Liste der Fehler angezeigt, die von den Regeln erkannt wurden, und mit deren Hilfe die fehlerhaften Felder navigiert und überprüft werden können.

ABBYY FlexiCapture für Rechnungen enthält bereits vordefinierte Validierungsregeln für Rechnungen, wie sie in verschiedenen Ländern im Allgemeinen verwendet werden (See "Verfügbare Regeln"). Die Benutzer können vorhandene Regeln bearbeiten oder entfernen und neue benutzerdefinierte Regeln erstellen.

Einige spezielle Funktionen von Regeln in ABBYY FlexiCapture for Invoices

Zu ausführlichen Anweisungen für die Arbeit mit Regeln in ABBYY FlexiCapture See "Regeln"

Die Regeln in ABBYY FlexiCapture for Invoices enthalten die folgenden spezifischen Funktionen:

Collapsed Regeln können sich auf den Status eines Dokuments auswirken

Damit sich eine Regel auf den Status eines Dokuments auswirkt, muss die Regel den entsprechenden Präfix im Namen enthalten. Durch das Hinzufügen des Präfix (Ausnahme) oder (Abgelehnt) zum Namen einer Regel wird der Status einer Rechnung geändert zu Ausnahme oder Abgelehnt, sobald die Regel in der Rechnung Fehler findet.

Collapsed Regeln können einer bestimmten Auswahl von Ländern hinzugefügt werden

Verwenden Sie für die Implementierung dieser Funktion die Bedingungen für das Anwenden von Regeln. Für weitere Informationen See "Regeln".

Regeln erkennen das Land einer Rechnung auf der Basis des Landes der Geschäftseinheit, für die die Rechnung ausgestellt wurde.

Ist eine bestimmte Art der Überprüfung nur für bestimmte Länder relevant, sollten nur relevante Länder in den Regelbedingungen festgelegt werden. Müssen umgekehrt Rechnungen aller Länder mit der Ausnahme eines bestimmten Landes überprüft werden, muss dieses Land in den Regelbedingungen ausgenommen werden (die Bedingung darf die Regel nur dann anwenden, wenn der Wert des Landes der Geschäftseinheit nicht dem Namen des ausgenommenen Landes entspricht).

Verwenden der Regelliste

Anzeige der vollständigen Regelliste

So zeigen Sie alle für das Projekt eingerichteten Regeln an:

  1. Öffnen Sie das Menü Dokumentdefinition und wählen Sie Eigenschaften der Dokumentdefinition….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf die Registerkarte Regeln.
  3. Wählen Sie aus der Liste Regeln anzeigen die Option im Besitz von europäischer Rechnung und deren untergeordneten Rechnungen.

Verwenden Sie den Filter, um alle Regeln anzuzeigen, die für Rechnungen aus einem bestimmten Land angewendet werden, wie beispielsweise für Deutschland.

Collapsed Einrichtung eines Filters
  1. Klicken Sie im Dialogfeld Eigenschaften der Dokumentdefinition auf die Registerkarte Regeln und dann auf die Schaltfläche Filter….
  2. Wählen Sie im Dialogfeld Filter die Option Ist diese Bedingung wahr und wählen Sie dann ein gewünschtes Feld in Feld im Feld Rechnungslayout\GE\Land, das das Land der Geschäftseinheit definiert.
  3. Wählen Sie die Bedingung Überschneidet sich mit Satz aus der Dropdownliste aus.
  4. Legen Sie mithilfe der Schaltfläche Auswählen… im unteren Feld die gewünschten Länder fest. Im daraufhin geöffneten Dialogfeld Feldwert müssen Sie die Länder auswählen, für die die Regeln angezeigt werden sollen. Für Deutschland wählen Sie beispielsweise DE.
  5. Klicken Sie auf OK.

Jetzt wird die Liste alle Regeln anzeigen, die für Rechnungen des Landes angewendet werden, das Sie im Filter festgelegt haben.

Beachten Sie, dass die Bedingung, die eine Regel auslöst, in der Spalte Regel anwenden angezeigt wird.

Collapsed Eine Regel in der Liste suchen

Für die Suche nach einer Regel können die folgenden Filterkriterien verwendet werden:

  • Regelname
  • der Name eines Feldes, auf das sich die Regel bezieht
  • die Bedingung, die die Regel auslöst
  1. Klicken Sie im Dialogfeld Eigenschaften der Dokumentdefinition auf die Registerkarte Regeln und dann auf die Schaltfläche Filter….
  2. Im Dialogfeld Filter kann der Name der gesuchten Regel eingegeben werden (die Namen sind alphabetisch aufgelistet), ein Feld ausgewählt werden, auf das sich die Regel bezieht, oder die Bedingung festgelegt werden, die die Regel auslöst.

Zu ausführlichen Anweisungen für die Verwendung von Filtern See "Regeln".

Erstellen neuer Regeln

So erstellen Sie eine neue Regel:

  1. Öffnen Sie das Menü Dokumentdefinition und wählen Sie Eigenschaften der Dokumentdefinition….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf die Registerkarte Regeln.
  3. Wählen Sie aus der Liste Regeln anzeigen die Option im Besitz von europäischer Rechnung und deren untergeordneten Rechnungen.
  4. Wählen Sie das Feld aus, in dem die Regel gespeichert wird. Das kann sich auf die Ausführung mancher Regeln auswirken (z. B. wie ihre Fehlermeldungen generiert werden). Wenn Sie sich nicht sicher sind, welches Feld Sie auswählen sollen, wählen Sie den obersten Knoten, d. h. Rechnungslayout.
  5. Klicken Sie auf Neue Regel….
  6. Im sich daraufhin öffnenden Dialogfeld wählen Sie einen der Standardregeltypen oder wählen Skript, was Ihnen das Erstellen Ihrer eigenen Regel erlaubt.

Hinweis: Zu ausführlichen Informationen über die einzelnen Regeltypen und Anweisungen für deren Erstellung See "Regeln".

Die folgenden Anweisungen gelten speziell für die Erstellung von Regeln in ABBYY FlexiCapture for Invoices.

  7. Nachdem Sie einen Regeltyp ausgewählt haben, müssen Sie Folgendes festlegen:
    1. Name

    Der Name der Regel sollte die Art der Überprüfung wiedergeben, die von der Regel durchgeführt wird. Von der Regel ausgegebene Fehler werden dem Operator im folgenden Format angezeigt:

    Regelname: Fehlermeldung.

    Soll sich die Regel auf den Status der Rechnungen auswirken, muss ihrem Namen der Präfix (Ausnahme) oder (Abgelehnt) vorangestellt werden, je nachdem, welcher Status einer Rechnung zugewiesen werden soll, sobald die Regel einen Fehler erkennt.

    2. Schweregrad

    Schweregradflags unterstützen den Operator bei der Überprüfung von Fehlern und Warnungen und bei der Entscheidung, welche Rechnungen manuell überprüft werden sollen.

    Der Datenexport kann auch in Abhängigkeit vom Schweregradflag durchgeführt werden. Beispielsweise könnten Sie:

    • Dokumente zu Ihrer Arbeitsdatenbank exportieren, die keine Regelfehler, aber Regelwarnungen enthalten
    • Dokumente mit Regelfehlern zu einem Ausnahmeordner exportieren
    • den Export eines Dokument mit Fehlern gänzlich verbieten

    Zu ausführlichen Anweisungen für die Einrichtung eines Exports auf der Basis des Schweregrads einer Regel See "Regeln".

    3. Ob die Regel nach der Erstellung aktiviert werden soll (Option Regel ist aktiviert)
  8. In diesem Schritt müssen Sie die Bedingung für das Anwenden der Regel festlegen. Typischerweise wird diese Bedingung durch den Wert des Felds Rechnungslayout\GE\Land definiert.

Standardmäßig wird eine Regel immer angewendet (Regel anwenden=immer). Wenn eine Regel nur unter bestimmten Bedingungen angewendet werden soll:

  1. Wählen Sie aus der Liste Regel anwenden die Option unter der Bedingung.
  2. Klicken Sie auf Bearbeiten…, um die Bedingung zu bearbeiten.
  3. Wählen Sie das Feld, dessen Wert die Regel auslösen wird (Rechnungslayout\GE\Land).
  4. Legen Sie die Bedingung fest, und falls anwendbar, erlaubte und nicht erlaubte Werte.

Beispiel 1. Die Regel soll für Rechnungen aus Deutschland angewendet werden.

Wählen Sie die Bedingung Gehört zu Satz, klicken Sie auf Hinzufügen und fügen Sie den Wert DE hinzu.

Beispiel 2. Die Regeln müssen für alle Rechnungen angewendet werden, mit Ausnahme von deutschen und französischen Rechnungen.

Wählen Sie die Bedingung Gehört nicht zu Satz, klicken Sie auf Hinzufügen und fügen Sie die Werte DE und FR hinzu.

  9. In diesem Schritt muss die Regel eingerichtet werden. Zu ausführlichen Informationen See "Regeln".

Deaktivierung einer Regel

So deaktivieren Sie eine zuvor eingerichtete Regel:

  1. Suchen Sie die Regel in der Liste (siehe oben).
  2. Demarkieren Sie das Feld in der Spalte Aktiviert neben dieser Regel. Alternativ doppelklicken Sie auf die Regel, um deren Dialogfeld Eigenschaften zu öffnen und demarkieren die Option Aktivierte Regel auf der Registerkarte Allgemein.

Wenn Sie sich sicher sind, eine Regel nicht mehr zu benötigen, kann diese gelöscht werden. So löschen Sie eine Regel:

  1. Suchen Sie die Regel in der Liste (siehe oben).
  2. Wählen Sie die Regel aus, indem Sie deren Name in der Liste anklicken, und klicken dann auf Löschen.


Erfassung zusätzlicher Rechnungsfelder

Standardmäßig erfasst ABBYY FlexiCapture for Invoices nur eine bestimmte Reihe von Feldern (bezeichnet als "Standardfelder"). See "Erfasste Felder".

Für das Extrahieren zusätzlicher Felder gibt es mehrere Möglichkeiten:

  • Aktivierung der Extraktion zusätzlicher vordefinierter Felder in der Dokumentdefinition
  • Trainieren des Programms zur Extraktion beliebiger Felder aus Rechnungen eines jedes Lieferanten
  • Erstellung eines FlexiLayouts für die Extraktion beliebiger Felder aus Rechnungen eines jeden Lieferanten oder jeder Rechnung, unabhängig vom Lieferanten.
Feld | Beschreibung
Standardfelder | Das sind die Hauptfelder der Rechnung, die deren Nummer, Datum, Lieferant, empfangende Geschäftseinheit usw. enthalten (See "Erfasste Felder"). Die Erfassung von Daten aus den Hauptfeldern kann nicht deaktiviert werden, diese Felder können aber ausgeblendet werden. Ausgeblendete Felder sind während der Überprüfung für die Operatoren nicht sichtbar.
Zusätzliche Felder | Das sind typische Rechnungsfelder, wie z. B. Bestellnummer und Artikel. Diese Felder werden standardmäßig nicht extrahiert, können aber von den Benutzern aktiviert werden.
Benutzerdefinierte Felder | ABBYY FlexiCapture for Invoices enthält keine Beschreibungen ungewöhnlicher Rechnungsfelder. Das Programm kann so eingerichtet werden, dass diese Felder extrahiert werden.

Sie können mithilfe des Trainings die Art und Weise ändern, wie die Felder extrahiert werden. See "ABBYY FlexiCapture for InvoicesTrainieren"


Zusätzliche Felder

Die zusätzlichen Felder können im Dialogfeld Eigenschaften der Dokumentdefinition verwaltet werden. Wählen Sie im Hauptmenü des Dokumentdefinitionseditors Dokumentdefinition>Eigenschaften der Dokumentdefinition…. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte Rechnungseinstellungen und dann auf die Schaltfläche Bearbeiten… in der Gruppe Zusätzliche Felder und Funktionen.

Das Dialogfeld Rechnungsfunktionen wird geöffnet, das zusätzliche Optionen für die Rechnungsverarbeitung bietet. Jede Option beinhaltet ein oder mehrere Rechnungsfelder und deren zugeordnete Regeln.

Liste der zusätzlichen Felder im Dialogfeld Rechnungsfunktionen.

  • Fälligkeitsdatum;
  • Lieferdatum;
  • Käufername;
  • Bestellungszuordnung;
  • Rechnungspositionen den Bestellpositionen zuordnen.

Jede Option in dem Dialogfeld enthält eine Beschreibung mit einer Liste der Felder, von denen die Daten erfasst werden sollen.

Um eine Option zu aktivieren, markieren Sie das Feld neben ihrem Namen.

Um die Option Bestellungszuordnung zu aktivieren, wird eine Verbindung zu der Datenbank benötigt, in der Ihre Bestellungen gespeichert werden. See "Kontrolle von Rechnungspositionen"

Die Namen der Felder, die mit deaktivierten Optionen verknüpft sind, werden grau angezeigt. Im Datenformular, das im Dokumentdefinitionseditor angezeigt wird, sind diese Felder auch grau dargestellt. Diese Felder werden während der Überprüfung im Dokumenteditor nicht angezeigt. Werden die Eigenschaften eines grauen Feldes geöffnet, wird eine Meldung angezeigt, die besagt Feld wurde durch seine Funktion deaktiviert.

Die mit den deaktivierten Optionen verknüpften Regeln werden auch in der Liste der Regeln der Dokumentdefinition deaktiviert.

Sobald Sie eine Option aktivieren, werden deren verknüpfte Felder und Regeln aktiviert.


Benutzerdefinierte Felder

ABBYY FlexiCapture for Invoices ermöglicht es, Rechnungsfelder zu extrahieren, für die keine vordefinierten Datentypen verfügbar sind, und die Art und Weise zu ändern, wie ein Feld extrahiert wird.

Dafür gibt es mehrere Möglichkeiten:

Methode | Beschreibung
Entwicklung eines zusätzlichen FlexiLayouts | Mit einem zusätzlichen FlexiLayout extrahieren Sie Felder, für die keine vordefinierten Datentypen verfügbar sind, und ändern die Art und Weise, wie die Standardfelder aus Rechnungen beliebiger Lieferanten extrahiert werden.
Entwicklung eines FlexiLayouts für einen bestimmten Lieferanten | Mit lieferantenspezifischen FlexiLayouts extrahieren Sie Felder, für die keine vordefinierten Datentypen verfügbar sind, und ändern die Art und Weise, wie die Standardfelder aus Rechnungen eines bestimmten Lieferanten extrahiert werden.
Trainieren einer Dokumentdefinition für einen bestimmten Lieferanten | Durch die Erstellung einer Dokumentdefinition für Rechnungen eines bestimmten Lieferanten kann das Programm die Extrahierung der Felder aus diesen Lieferantenrechnungen trainieren.

Sie können alle diese Lösungen beliebig nutzen oder kombinieren. Beispielsweise können Sie einer zusätzlichen Dokumentdefinition ein neues Feld hinzufügen, das auf Rechnungen aller Lieferanten angewendet wird, und dann das Programm für die Erkennung des neuen Feldes auf Rechnungen einiger Lieferanten trainieren und eine FlexiLayout-Variante für die anderen Lieferanten erstellen.

Weitere Informationen über die Anwendung mehrerer FlexiLayouts finden Sie unter See "Zusammenführung der FlexiLayout-Zuordnungsergebnisse".

Erstellung eines zusätzlichen FlexiLayouts

Jedes in ABBYY FlexiLayout Studio erstellte FlexiLayout kann als zusätzliches FlexiLayout in ABBYY FlexiCapture for Invoices verwendet werden.

Um einen neuen Feldtyp zu extrahieren, erstellen Sie einen neuen Block mit einem eindeutigen Namen in einem FlexiLayout und definieren die Logik für das Auffinden des Feldes in Bildern. Wird dieses FlexiLayout einer Dokumentdefinition hinzugefügt, wird im FlexiLayout ein neues Feld mit dem Namen erstellt, der dem des neuen Blocks im FlexiLayout entspricht.

Entspricht der Name des Blocks im zusätzlichen FlexiLayout dem Namen eines Standardfeldes in der Dokumentdefinition, wird das zusätzliche FlexiLayout für die Extrahierung des Blocks verwendet.

Ein FlexiLayout einer Dokumentdefinition hinzufügen:

  1. Klicken Sie auf Dokumentdefinitionen… im Menü Projekt.
  2. Wählen Sie im daraufhin geöffneten Dialogfeld eine Dokumentdefinition und klicken Sie auf die Schaltfläche Bearbeiten….
  3. Klicken Sie auf Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinition.
  4. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte FlexiLayout.
  5. Klicken Sie auf die Schaltfläche Laden… in der Optionsgruppe Zusätzliches FlexiLayout und geben Sie im daraufhin geöffneten Dialogfeld den Pfad zur FlexiLayout-Datei an (FlexiLayout-Dateien haben die Erweiterung *.afl).

ABBYY FlexiLayout Studio bietet mehrere Funktionen für die Entwicklung zusätzlicher FlexiLayouts für Rechnungen:

  • Sie können die IDs des Lieferanten und der Geschäftseinheit einer Rechnung herausfinden und einen Datensatz in einer Dokumentdefinition referenzieren.
  • Sie können die Positionen der Elemente in Bezug auf die Felder festlegen, die bei Anwendung des FlexiLayouts erkannt werden können.
  • Sie können das FlexiLayout mithilfe einer XML-Datei parametrisieren, mit der komplexe Schlüsselwortlisten und andere FlexiLayout-Parameter gespeichert und bearbeitet werden können, ohne das FlexiLayout oder die Dokumentdefinition zu bearbeiten.

Weitere Informationen über die Spezialfunktionen in ABBYY FlexiLayout Studio finden Sie unter See "Spezielle Funktionen von ABBYY FlexiLayout Studio für das Erstellen zusätzlicher FlexiLayouts".

Entwicklung einer FlexiLayout-Variante für einen bestimmten Lieferanten

Mit ABBYY FlexiCapture for Invoices können Sie bei der Verarbeitung von Rechnungen eines bestimmten Lieferanten eine separate FlexiLayout-Variante verwenden. Diese zusätzliche FlexiLayout-Variante kann während des Trainings automatisch erstellt werden. Sind Sie mit der Variante unzufrieden, kann diese in ABBYY FlexiLayout Studio geöffnet und der Feldsuchalgorithmus manuell geändert werden.

Collapsed Erstellen einer FlexiLayout-Variante

  1. Um Daten aus einem neuen Feld zu extrahieren, muss dieses Feld zuerst in der Dokumentdefinition erstellt werden.

    Erstellen Sie ein Feld des Namens MeinFeld:

    Wählen Sie im Dokumentdefinitionseditor Bearbeiten>Feld erstellen und klicken Sie auf einen Feldtyp. Geben Sie im daraufhin geöffneten Dialogfeld den Namen des Feldes ein (MeinFeld).

Muss der Suchalgorithmus für ein Standardfeld geändert werden, überspringen Sie diesen Schritt.

  2. Einen Trainingsstapel erstellen:

    • Fügen Sie mindestens eine Rechnung des Lieferanten einem Stapel hinzu.
    • Erkennen Sie diese.
    • Stellen Sie sicher, dass der Lieferant vom Programm korrekt erkannt wird. Ist dem nicht der Fall, legen Sie den korrekten Lieferanten manuell fest.
    • Klicken Sie auf die Schaltfläche [image]. Es wird ein Trainingsstapel erstellt.
  3. Klicken Sie auf die Schaltfläche [image] in der Symbolleiste, um zur Ansicht mit dem Trainingsstapel zu wechseln. Der Trainingsstapel enthält Teststapel eines bestimmten Lieferanten, der dann für das Trainieren des FlexiLayouts für diesen Lieferanten verwendet wird. Entscheiden Sie als Nächstes, ob das automatische Training verwendet oder die FlexiLayout-Variante manuell bearbeitet werden soll:
    • Soll das automatische Training verwendet werden, fügen Sie dem Stapel einige Beispielrechnungen hinzu (wir empfehlen mindestens 3) und legen die Feldbereiche fest. Weitere Informationen über das Trainieren mit Beispielstapeln finden Sie unter See "Training durch Benutzer mit Berechtigungen zur Projekteinrichtung"
    • Soll die FlexiLayout-Variante manuell bearbeitet werden, überspringen Sie den nächsten Schritt und gehen zu Schritt 5.

  4. Training starten:

    • Klicken Sie auf Training>Lernen im Menü Projekt

    oder

    • klicken Sie mit der rechten Maustaste auf den Stapel und klicken Sie dann im Kontextmenü auf Lernen.

    Es wird jetzt automatisch eine FlexiLayout-Variante erstellt.

  5. Erstellen Sie ein ABBYY FlexiLayout Studio-Projekt, das Bilder aus dem Trainingsstapel und das FlexiLayout enthält, das während des Trainings erstellt wurde. Exportieren des FlexiLayouts zu ABBYY FlexiLayout Studio:
    • Klicken Sie auf Training>Erlerntes FlexiLayout exportieren… im Menü Projekt

    oder

    • klicken Sie mit der rechten Maustaste auf den Stapel und wählen Sie Erlerntes FlexiLayout exportieren… aus dem Kontextmenü des Stapels.

    Speichern Sie das Projekt.

  6. Öffnen Sie das in ABBYY FlexiLayout Studio erstellte Projekt.

    Die Blöcke im FlexiLayout entsprechen den Feldern in der Dokumentdefinition. Alle Blöcke tragen das Symbol [image]. Dieses Symbol weist darauf hin, dass der Algorithmus für die Extrahierung des Blocks automatisch generiert wurde.

    Änderungen am FlexiLayout führen dazu, dass das Programm diese Blöcke als manuell erstellt betrachtet. Bei Anwendung der Dokumentdefinition muss das Programm das FlexiLayout auswählen, aus dem der Feldbereich entnommen wird (für ausführliche Informationen See "Zusammenführung der FlexiLayout-Zuordnungsergebnisse"). Manuell erstellte Blöcke besitzen immer eine höhere Priorität.

Daher müssen Sie die Blöcke entfernen, für die der Suchalgorithmus nicht geändert werden soll. Diese Blöcke sind auch weiterhin im Haupt-FlexiLayout vorhanden und werden bei Anwendung der Dokumentdefinition auch weiterhin extrahiert. Möchten Sie beispielsweise einen benutzerdefinierten Algorithmus für die Blöcke Rechnungsdatum und Mein Feld festlegen, belassen Sie diese Blöcke im FlexiLayout und löschen alle anderen Blöcke,

Hinweis: Neue Felder in einer Dokumentdefinition für einen bestimmten Lieferanten können nicht einfach durch Hinzufügen eines neuen Blocks zu einem FlexiLayout erstellt werden. Blöcke in FlexiLayout-Varianten, die nicht mit einem Feld in einer Dokumentdefinition übereinstimmen, verursachen bei der Verarbeitung von Rechnungen des Lieferanten einen Fehler. Muss ein neues Feld aus den Rechnungen eines bestimmten Lieferanten extrahiert werden, erstellen Sie zuerst das Feld in der Dokumentdefinition (siehe Schritt 1).

  7. Legen Sie den Suchalgorithmus fest, der für die Suche von Blöcken mithilfe der Standardtools von ABBYY FlexiLayout Studio verwendet werden soll.

  8. Klicken Sie auf Erstellen im Menü FlexiLayout, um das FlexiLayout zu erstellen, und exportieren Sie es in eine *.afl-Datei durch Klicken auf Exportieren... im Menü Datei.

  9. In ABBYY FlexiCapture klicken Sie auf die Schaltfläche [image] Lernstapel in der Symbolleiste, um zur Teststapelansicht zu wechseln. Importieren Sie dann das FlexiLayout:

  • Klicken Sie auf Training>FlexiLayout importieren… im Menü Projekt

oder

  • Klicken Sie mit der rechten Maustaste auf den Stapel und klicken im Kontextmenü auf FlexiLayout importieren….

  • Geben Sie den Pfad zur im vorherigen Schritt erstellten *.afl-Datei an.

    10. Erkennen Sie die Beispielrechnungen des Lieferanten.

      Dieses Vorgangsprotokoll enthält Meldungen darüber, welche Feldbereiche aus der FlexiLayout-Variante für diesen Lieferanten ausgewählt wurden.

    11. Überprüfen Sie die verarbeiteten Dokumente, indem Sie diese in einem Editor öffnen.

    Trainieren einer Dokumentdefinition für einen bestimmten Lieferanten

    So erstellen Sie ein neues Feld:

    1. Wählen Sie im Dokumentdefinitionseditor Bearbeiten>Feld erstellen (oder klicken Sie mit der rechten Maustaste in die Liste der Felder). Wählen Sie einen Feldtyp.
    2. Geben Sie in das Dialogfeld der Eigenschaften einen Namen für das zusätzliche Feld ein und wählen Sie die Option Kann Bereich enthalten.

    Hinweis: Für ausführliche Informationen über die Konfiguration von Feldern verschiedener Typen siehe See "Feldeigenschaften"

    Ein neues Feld mit dem von Ihnen festgelegten Namen wird im Datenformular und in der Liste von Feldern angezeigt.

    Jetzt muss das Programm für die Erfassung von Daten aus diesem Feld trainiert werden. Sie müssen dem Programm mindestens drei Beispielbilder bereitstellen, die dieses Feld enthalten. Beachten Sie, dass das Training für jeden Lieferanten getrennt erfolgt. Für weitere Informationen See "Training während der Rechnungserfassung ".


You are here: ABBYY FlexiCapture for Invoices > Einrichtung eines Projekts zur Rechnungserfassung > Erfassung zusätzlicher Rechnungsfelder > Spezielle Funktionen von ABBYY FlexiLayout Studio für das Erstellen zusätzlicher FlexiLayouts

Spezielle Funktionen von ABBYY FlexiLayout Studio für das Erstellen zusätzlicher FlexiLayouts

ABBYY FlexiLayout Studio bietet mehrere Spezialfunktionen für die Entwicklung zusätzlicher FlexiLayouts für Rechnungsprojekte:

  • Sie können die Positionen der Elemente in Bezug auf die Feldbereiche festlegen, die beim Anwenden des Haupt-FlexiLayouts vom Rechnungsprojekt erkannt wurden.
  • In Anfragen an den Datensatz der Dokumentdefinition können Kennungen für Lieferanten und Geschäftseinheiten verwendet werden.
  • Die Listen mit Schlüsselwörtern und andere Parameter eines FlexiLayouts können in eine XML-Datei exportiert werden, wo diese dann ohne Bearbeitung des FlexiLayouts oder der Dokumentdefinition bearbeitet werden können.
Collapsed Erstellung eines zusätzlichen FlexiLayouts
  1. Öffnen Sie einen Stapel mit erkannten Rechnungen in ABBYY FlexiCapture.
  2. Erstellen Sie ein neues Projekt in ABBYY FlexiLayout Studio und klicken Sie dann in ABBYY FlexiCapture auf Neues FLS-Projekt erstellen… im Menü Optionen.

Hinweis: Dieser Befehl ist nur verfügbar für ABBYY FlexiCapture Projekte, die auf Ihrem Computer gespeichert sind. Nutzen Sie eine verteilte Version von ABBYY FlexiCapture und das Projekt ist auf dem Server gespeichert, muss es zuerst durch Klicken auf Projekt exportieren… im Menü Projekt auf Ihren Computer heruntergeladen werden.

Hinweis: Der Suffix des ABBYY FlexiLayout Studio-Projekts gibt die Version der Dokumentdefinition zum Zeitpunkt der Projekterstellung an.

Das von Ihnen soeben erstellte ABBYY FlexiLayout Studio-Projekt enthält alle Dokumente aus dem ABBYY FlexiCapture-Stapel und die Regionen der Felder, die während der Erkennung in ABBYY FlexiCapture in der Form eines Referenzlayouts erfasst wurden.

Der Baum SearchElements enthält die folgenden Knoten:

CommonBlockRegions

Dieser Knoten enthält Elemente, die allen Feldern der Dokumentdefinition entsprechen. Die Koordinaten aller Blockbereiche, die bei der Anwendung der FlexiLayouts auf die einzelnen Dokumente in ABBYY FlexiCapture erkannt wurden, werden im ABBYY FlexiLayout Studio-Projekt gespeichert. Standardmäßig werden Bereiche mit diesen Koordinaten den Elementen zugewiesen, die den gleichen Namen tragen wie die Felder in der Dokumentdefinition. Das ermöglicht die Verwendung dieser Felder für das Festlegen relativer Positionen von Elementen und für die Erstellung neuer Elemente.

CustomSearchElements

Diese Knoten enthält Beispielelemente. Diese sind standardmäßig deaktiviert, um so Überschneidungen bei der Anwendung des FlexiLayouts zu vermeiden.

DataSetRequestSample
Ein Beispiel für eine Anfrage an den Datensatz der Lieferanten und Geschäftseinheiten, die in der Dokumentdefinition gespeichert sind. Dieser Datensatz enthält Kennungen von Lieferanten und Geschäftseinheiten.

XMLSettingsSample
Ein Beispiel dafür, wie man eine Liste von Schlüsselwörtern aus der KeywordsCustom.xml erhält. Diese Datei finden Sie im Unterordner Einstellungen des ABBYY FlexiLayout Studio-Projektordners.

Collapsed Hinzufügen eines Feldes zu einem zusätzlichen FlexiLayout

Um einem zusätzlichen FlexiLayout ein Feld hinzuzufügen, muss ein Block für dieses Feld erstellt und dessen Suchelement festgelegt werden.

Die Felder in der Dokumentdefinition müssen einzigartige Namen besitzen. Das bedeutet:

  • Zur Beschreibung der Suchlogik für ein Feld muss ein Block mit einem einzigartigen Namen erstellt werden.
  • Zur Änderung der Suchlogik für ein Feld, das bereits in der Dokumentdefinition vorhanden ist, muss ein Block mit demselben Namen erstellt werden.
Collapsed Anfragen für Datensätze von der Dokumentdefinition formulieren

Sie finden eine Beispielanfrage im Element "DataSetRequestSample". Dieses Element ist standardmäßig deaktiviert.

Typ | Beschreibung
NamedValue | Ein benannter Wert
Konstruktor |
NamedValue( String, String ) |
Methoden |
String Name() | Gibt den Namen eines benannten Werts zurück
String Value() | Gibt den Wert einer benannten Werts zurück
NamedValueArray | Ein Array aus benannten Werten
Konstruktoren |
NamedValueArray() |
NamedValueArray( NamedValue namedValue ) |
Methoden |
Int Count() | Gibt die Gesamtanzahl der Elemente im Array zurück.
NamedValue GetAt( Int index ) | Gibt das Element mit der angegebenen Indexnummer zurück.
Void Add( NamedValue namedValue ) | Fügt dem Array einen benannten Wert hinzu.
Void Add( NamedValueArray namedValueArray ) | Fügt einem benannten Wertearray ein benanntes Wertearray hinzu.
Void InsertAt( Int index, NamedValue namedValue ) | Fügt namedValue an der Position index ein.
Void DeleteAll() | Löscht alle Elemente in einem Array.
Void DeleteAt( Int index ) | Löscht ein Element an der Position index.
Int FindByName( String name ) | Gibt die Position des benannten Wertes name zurück.

Funktionen

Syntax:

  • Der Pfad zur Dokumentdefinition und der Name des Datensatzes werden bei der Arbeit mit einem FlexiLayout in ABBYY FlexiLayout Studio für den Zugriff auf den Datensatz verwendet.
  • Nachdem ein kompiliertes FlexiLayout einer Dokumentdefinition in ABBYY FlexiCapture hinzugefügt wurde, wird beim Zugriff auf den Datensatz nur dessen Name verwendet.
  • connectionString Format:

"dbtype=FCDataset;fcTemplate=path_to_Document_Definition;datasetName=name_of_Data_Set;" (Teile des Pfads müssen durch doppelte umgekehrte Schrägstriche getrennt werden "\\")

  • searchFields
    Array der Namen der Spalten, aus denen die Werte abgerufen werden sollen.

  • searchCriteria
    Array aus Spalten-Eintrags-Paaren, gibt alle Werte zurück, wenn leer.
    • Enthält eine Anfrage mehrere Werte für ein Feld, verwenden Sie den Operator OR
    • Enthält eine Anfrage mehrere Werte, wobei jeder davon nur einem Feld entspricht, verwenden Sie den Operator AND
    • Enthält eine Anfrage mehrere Werte für ein Feld und Werte für mehrere Felder, verwenden Sie den Operator OR, um mehrere Werte für ein Feld zu trennen, und den Operator AND für die Verbindung von Werten für verschiedene Felder.
Definition | Beschreibung
Logic TestAccessToFCDataSet( String connectionString ) | Testet die Verbindung zum Datensatz
Logic TestFCDataSetSearchCriteria( String connectionString, StringArray searchFields, NamedValueArray searchCriteria ) | Testet die Suchbedingungen für den Datensatz
StringArray FieldNamesOfFCDataset( String connectionString ) | Gibt eine Liste aller Felder im Datensatz zurück, sortiert in aufsteigender Reihenfolge ihrer Indexnummern.
StringArray FieldNamesOfFCDataset( String connectionString, StringArray searchFields ) | Gibt eine Liste aller Datensatzfelder vom festgelegten Datensatz zurück, sortiert in aufsteigender Reihenfolge ihrer Indexnummern. Sollte in Verbindung mit der Funktion RecordOfFCDataset verwendet werden, wenn komplexe Spalten vorhanden sind.
Int RecordCountOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria ) | Gibt die Menge der Einträge aus dem Datensatz zurück, die in den Suchbedingungen festgelegt ist. Verwendbar um herauszufinden, wie viele Einträge mithilfe der Funktion RecordOfFCDataset voraussichtlich zurückgegeben werden
Void PrepareRecordsetOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ) | Bereitet die Daten für eine Abfrage des Datensatzes vor. Muss für jeden neuen Satz von Suchbedingungen ausgeführt werden, bevor die Funktion RecordOfFCDataset aufgerufen wird.
StringArray RecordOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria, Int rowIndex ) | Gibt ein Array aus Werten des Eintrags mit der Anzahl rowIndex von den Ergebnissen zurück, die von einer Abfrage des Datensatzes zurückgegeben werden. Die Anzahl der Werte entspricht der Anzahl der in searchFields weitergegebenen Felder (schließt den Fall komplexer Spalten ein).
Quality ValidateByFCDataSet( String word, String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxErrors, Rational maxErrorsPart, Logic ignoreSpaces = true, Int maxRecordsCount = DefaultMaxRecordsCount ); | Gibt die Qualität der Zeichenfolge word zurück. Akzeptiert die Indexnummern von Feldern. Sie erhalten die Indexnummern durch Indexierung der Ausgabe der Funktion FieldNamesOfFCDataset.
Void SearchTextFromFCDataSet( String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ) | Mit dieser Funktion können die Suchbedingungen für Wörter der Funktion Statischer Text festgelegt werden. Wird diese Funktion aufgerufen, werden die vorhandenen Suchbedingungen durch neue ersetzt. Akzeptiert Feldindexnummern. Sie erhalten die Indexnummern durch Indexierung der Ausgabe der Funktion FieldNamesOfFCDataset.
Void RegularExpressionFromFCDataSet( String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ) | Mit dieser Funktion können die Suchbedingungen für die Verwendung regulärer Ausdrücke für die Funktion CharString festgelegt werden. Wird diese Funktion aufgerufen, werden die vorhandenen Suchbedingungen durch neue ersetzt. Akzeptiert Feldindexnummern. Sie erhalten die Indexnummern durch Indexierung der Ausgabe der Funktion FieldNamesOfFCDataset.

Suchen nach Zeilen von einer Spalte aus einer externen Datenbank in einem Bild

  1. Mit FieldNamesOfFCDataset erhalten Sie eine Liste der Spalten, sortiert in aufsteigender Reihenfolge ihrer Indexnummern.
  2. Bestimmen Sie die Indexnummer der Spalte, in der Daten gefunden werden sollen.
  3. Erstellen Sie aus dem Datensatz ein Array von Bedingungen für die Filterung von Daten.
  4. Geben Sie die Indexnummern der Spalte und die Filterbedingungen an SearchTextFromFCDataSet weiter (oder an RegularExpressionFromFCDataSet, wenn reguläre Ausdrücke verwendet werden müssen).

Dieser Code wird automatisch generiert, sobald ein erkannter Stapel von ABBYY FlexiCapture exportiert wird

Ein Bild nach Einträgen aus mehreren Spalten einer externen Datenbank durchsuchen

Da die Suchparameter bei jedem Aufruf der Funktion SearchTextFromFCDataSet ersetzt werden, ist der mehrmalige Aufruf dieser Funktion sinnlos. Aber es gibt eine Lösung: Sie können Zeichenfolgen von einer externen Datenbank abrufen und diese an die Funktion SearchText weiterleiten. Der Aufruf dieser Funktion fügt den String den vorhandenen Suchparametern hinzu, anstatt diese zu ersetzen.

Führen Sie dafür die folgenden Schritte aus:

  1. Erstellen Sie ein Array aus Namen der Spalten, in denen Daten gesucht werden sollen.
  2. Erstellen Sie ein Array von Filterbedingungen für die Filterung von Daten aus dem Datensatz.
  3. Bestimmen Sie die Menge von Einträgen, die bei der Verwendung der Funktion RecordCountOfFCDataset zurückgegeben werden.
  4. Bereiten Sie mithilfe der Funktion PrepareRecordsetOfFCDataset die Abfragedaten vor.
  5. Durchsuchen Sie alle Einträge und finden Sie mithilfe der Methode RecordOfFCDataset das Array für jeden Eintrag.
  6. Geben Sie den Wert der einzelnen Elemente im Array an die Funktion SearchText weiter.

Zusätzliche Überlegungen im Umgang mit komplexen Spalten

  • Die Funktion FieldNamesOfFCDataset gibt ein Array zurück, in dem der Name der komplexen Spalte mehrmals auftritt. Die Anzahl der Vorkommen entspricht der Anzahl der Spalteninstanzen in einer codierten externen Datenbank.

Beispiel: {VendorId, VATID, Name, Name, Name, City}. In diesem Falle enthält die externe Datenbank 3 Spalten für die eine komplexe Spalte im Datensatz Name.

  • Enthält SearchCriteria eine Bedingung für ein Feld, das der komplexen Spalte entspricht (wie im Beispiel oben), wird diese Bedingung für die Überprüfung aller dieser Spalteninstanzen verwendet.
  • Enthält searchFields eine Bedingung für ein Feld, das der komplexen Spalte entspricht (wie im Beispiel oben), enthält das Ergebnis das Array aus Werten jeder Spalteninstanz.

Beispielsweise, wenn Sie für {VendorId, VATID, Name, Name, Name, City} anfordern:

searchFields = { VATID, Name, Сity}, werden Sie erhalten

{VATID_value, Name_valueInColumn1, Name_valueInColumn2, Name_valueInColumn3, City_value}

  • Sie erhalten eine Liste der Spalten, die durch die Weitergabe des Arrays searchFields an die Funktion FieldNamesOfFCDataset zurückgegeben wird.
Collapsed Anfrage an eine XML-Datei, die FlexiLayout-Einstellungen enthält

Sie können mithilfe der in der Dokumentation für ABBYY FlexiLayout-Studio beschriebenen zwei Standardfunktionen Anfragen an eine XML-Datei mit FlexiLayout-Einstellungen stellen:

StringArray ReadFromXML(String filename, String xPathQuery)

String ReadSingleStringFromXML(String filename, String xPathQuery)

Das Element XMLSettingsSample enthält Beispielcode, der eine Liste von Schlüsselwörtern aus der Datei KeywordsCustom.xml ausliest. Diese Datei finden Sie im Unterordner Einstellungen des ABBYY FlexiLayout Studio-Projektordners.

Diese Datei muss sich in den Unterordnern des ABBYY FlexiLayout Studio-Projektordners befinden, wenn diese bei der Arbeit mit einem FlexiLayout in ABBYY FlexiLayout Studio verwendet werden soll. Der Pfad zu dieser Datei ist relativ zur ABBYY FlexiLayout Studio-Projektdatei.

Laden Sie ein kompiliertes FlexiLayout in eine Dokumentdefinition in ABBYY FlexiCapture und verwenden es als zusätzliches FlexiLayout, wird die XML-Datei im Ordner Vorlagen abgelegt, wo sie dann bearbeitet werden kann. Wird das FlexiLayout angewendet, verwaltet das Programm den Zugriff auf diese Datei automatisch.


Zusammenführung der FlexiLayout-Zuordnungsergebnisse

Dieser Artikel beschreibt die Reihenfolge, in der FlexiLayouts Dokumenten zugeordnet und wie Feldregionen ausgewählt werden.

ABBYY FlexiCapture for Invoices kann bei der Zuordnung der Dokumentdefinition verschiedene FlexiLayout-Arten verwenden:

  1. Allgemeines FlexiLayout, wird verwendet für die Verarbeitung aller Rechnungen und kann wiederum zwei FlexiLayout-Arten enthalten:
    1. Haupt-FlexiLayout, wird verwendet für die Erkennung der Standard-Rechnungsfelder, die bereits im Programm definiert sind. Dieses FlexiLayout wird gemeinsam mit ABBYY FlexiCapture for Invoices bereitgestellt und kann vom Benutzer nicht geändert werden.
    2. Zusätzliches FlexiLayout, wird verwendet für die Erkennung benutzerdefinierter Felder und Standard-Rechnungsfelder, deren Erkennungsalgorithmus vom Benutzer geändert wurde. Dieses FlexiLayout wird vom Benutzer erstellt.
  2. FlexiLayout-Variante, wird verwendet für die Verarbeitung einer bestimmten Rechnungsvariante, d. h. Rechnungen eines bestimmten Lieferanten. Dieses FlexiLayout kann für die Erkennung beliebiger Felder verwendet werden, die in der jeweiligen Dokumentdefinition definiert werden. Dieses FlexiLayout kann vom Benutzer oder vom Programm als Ergebnis des Trainings von ABBYY FlexiCapture for Invoices mit Rechnungen eines bestimmten Lieferanten erstellt werden.

Nach Zuordnung der Dokumentdefinition zu einer Rechnung erhält das Programm einen Satz von Feldbereichen, die von den verschiedenen FlexiLayouts stammen, die in der Dokumentdefinition enthalten sind.

1. Zuordnung eines allgemeinen FlexiLayouts

  1. Zuerst wird das Programm das Haupt-FlexiLayout zuordnen, das der wesentliche Bestandteil des allgemeinen FlexiLayouts ist.

Ersterkennungsparameter

Für ein Dokumentbild wird mithilfe der in der Dokumentdefinition festgelegten Parameter eine Ersterkennung durchgeführt:

  • Die zu verwendenden Sprachen werden auf der Registerkarte Rechnungseinstellungen im Dialogfeld Eigenschaften der Dokumentdefinition (Länder und Sprachen festgelegt
  • Der Ersterkennungsmodus (Sehr schnell / Schnell / Ausgewogen / Vollständig) auf der Registerkarte FlexiLayout im Dialogfeld Eigenschaften der Dokumentdefinition.

Ergebnisse durch die Zuordnung des Haupt-FlexiLayouts

Nach der Zuordnung des Haupt-FlexiLayouts zu einer Rechnung kann das Programm folgende Daten erhalten:

  • die ID des Lieferanten und die ID der Geschäftseinheit, falls erkannt
  • die Bereiche der Standardfelder. (Für weitere Informationen See "Erfasste Felder".)
  2. Als Nächstes wird das Programm das zusätzliche FlexiLayout zuordnen, das im allgemeinen FlexiLayout verfügbar ist.

Ersterkennungsparameter

Für ein Dokumentbild wird mithilfe der im FlexiLayout festgelegten Parameter (d. h. die zu verwendenden Sprachen und der Ersterkennungsmodus) eine Ersterkennung durchgeführt . Wir empfehlen das Festlegen der gleichen Ersterkennungsparameter im zusätzlichen FlexiLayout, wie sie auch in der Dokumentdefinition festgelegt sind, sodass das Programm statt einer zweimaligen Ersterkennung eines Dokuments das in Schritt A erhaltene Ersterkennungsergebnis verwenden kann.

Für die Verarbeitung ungewöhnlicher Felder können im zusätzlichen FlexiLayout Ersterkennungsparameter festgelegt werden, die sich von denen in der Dokumentdefinition unterscheiden, wodurch die Verarbeitung allerdings verlangsamt wird.

Ergebnisse durch die Zuordnung des zusätzlichen FlexiLayouts

Nach der Zuordnung des Haupt-FlexiLayouts zur Rechnung erhält das Programm die Bereiche aller Felder, die im zusätzlichen FlexiLayout definiert sind. Das können Standard-Rechnungsfelder sein, deren Erkennungsalgorithmus geändert werden musste, oder zusätzliche Felder, die im Haupt-FlexiLayout nicht definiert sind.

  3. Als nächstes generiert das Programm das Gesamtergebnis der Zuordnung des allgemeinen FlexiLayouts.

Enthält die Dokumentdefinition ein zusätzliches FlexiLayout, wird das Programm in diesem Schritt die durch die Zuordnung des Haupt-FlexiLayouts erhaltenen und durch die Zuordnung des zusätzlichen FlexiLayouts erhaltenen Ergebnisse zusammenführen.

Die Felder werden anhand ihrer Namen identifiziert. Das Ergebnis ist eine Sammlung einzigartiger Felder, die vom Haupt- und dem zusätzlichen FlexiLayout abgeleitet wurden. Befinden sich im Haupt- und zusätzlichen FlexiLayout Felder mit identischen Namen, wird das Programm den Feldbereich verwenden, den es durch die Zuordnung des zusätzlichen FlexiLayouts erhalten hat.

Diese Vorgehensweise ermöglicht die Definition neuer Felder oder die Änderung der Logik der Erfassung von Standard-Rechnungsfeldern.

2. Zuordnung einer FlexiLayout-Variante

Hat das Programm nach der Zuordnung des FlexiLayouts den Lieferanten (Schritt A) erkannt und ist eine FlexiLayout-Variante für diesen Lieferanten vorhanden, wird diese Variante in diesem Schritt zugeordnet.

Ersterkennungsparameter

Die Ersterkennungsparameter aus der Dokumentdefinition werden verwendet. Das sind dieselben Ersterkennungsparameter, die bei der Zuordnung des Haupt-FlexiLayouts, das im allgemeinen FlexiLayout enthalten ist, verwendet wurden. Daher ist keine zusätzliche Ersterkennung erforderlich.

Ergebnisse durch die Zuordnung der FlexiLayout-Variante

Nach der Zuordnung des FlexiLayout-Variante zur Rechnung erhält das Programm die Bereiche aller Felder, die in der FlexiLayout-Variante für diesen jeweiligen Lieferanten definiert sind. Beachten Sie, dass wenn eine FlexiLayout-Variante durch das Trainieren des Programms mit einer Reihe von Rechnungen erstellt wurde, diese alle in der Dokumentdefinition definierten Felder enthält. Wird eine FlexiLayout-Variante manuell erstellt, dürfen nur die Felder in der Variante verbleiben, für deren Erkennung Aktionen spezifisch für den vorgegebenen Lieferanten erforderlich sind.

3. Zusammenführung der Ergebnisse

In diesem Schritt werden die durch Zuordnung des allgemeines FlexiLayouts erhaltenen Ergebnisse mit den durch die Zuordnung der FlexiLayout-Variante erhaltenen Ergebnissen zusammengeführt.

Wurde eine FlexiLayout-Variante durch das Trainieren des Programms mit einer Reihe von Rechnungen erstellt, enthält diese alle in der Dokumentdefinition definierten Felder. Die Dokumentdefinition speichert Informationen über die Felder, deren Bereiche während des Trainings vom Benutzer geändert werden mussten, wie z. B. die Felder, die vom allgemeinen FlexiLayout unzuverlässig erkannt wurden. Das Programm stützt sich auf diese Informationen, wenn entschieden werden soll, welche Feldbereiche aus dem allgemeinen FlexiLayout und welche Bereiche aus der FlexiLayout-Variante entnommen werden sollen, die anhand von Rechnungen dieses bestimmten Lieferanten für das Training genutzt wurde.

Hinweis: Bereiche der Felder Betrag werden unterschiedlich ausgewählt. Bei der Zuordnung des allgemeinen FlexiLayouts wird das Programm den Zuverlässigkeitsgrad festlegen, mit dem die Bereiche der Felder Betrag erkannt wurden. Wurden die Bereiche unzuverlässig erkannt, muss das Feld Gesamtsumme überprüft werden. Wurde eine FlexiLayout-Variante anhand von Rechnungen dieses vorgegebenen Lieferanten trainiert, werden die Bereiche der Felder Betrag der FlexiLayout-Variante entnommen, sofern das allgemeine FlexiLayout diese Felder nicht oder nur unzuverlässig erkennt.

Wurde die FlexiLayout-Variante manuell erstellt, wird das Programm die Bereiche aller Felder verwenden, die in der FlexiLayout-Variante enthalten sind. Die Bereiche der anderen Felder werden den Ergebnissen entnommen, die man durch Zuordnung des allgemeinen FlexiLayouts erhalten hat.

Informationen darüber, welches FlexiLayout für die Erkennung eines Feldbereichs verwendet wurde, werden im Erkennungsprotokoll aufgezeichnet.

Collapsed Beispiel

Lassen Sie uns einige der in der Dokumentdefinition definierten Felder betrachten.

Beachten Sie die zwei Standard-Rechnungsfelder InvoiceDate und InvoiceNumber und die zwei benutzerdefinierten Felder CustomFieldA und CustomFieldB.

  • InvoiceDate und InvoiceNumber sind Standardfelder und der Erkennungsalgorithmus für diese Felder wird im Haupt-FlexiLayout festgelegt, das im allgemeinen FlexiLayout enthalten ist.
  • CustomFieldA und CustomFieldB sind benutzerdefinierte Felder und der Erkennungsalgorithmus für diese Felder wird im zusätzlichen FlexiLayout festgelegt, das im allgemeinen FlexiLayout enthalten ist.

Nehmen wir an, der Operator ist mit der Qualität der Erkennung der Felder InvoiceDate und CustomFieldB in einer Rechnung eines bestimmten Lieferanten nicht zufrieden und trainiert das Programm mit Rechnungen von diesem Lieferanten.

Die Feldbereiche der Rechnungen dieses Lieferanten werden wie folgt zusammengeführt:

  • InvoiceNumber — Dieser Bereich stammt von den Ergebnissen, die man mit dem Haupt-FlexiLayout erhalten hat.
  • CustomFieldA — Dieser Bereich stammt von den Ergebnissen, die man mit dem zusätzlichen FlexiLayout erhalten hat.
  • InvoiceDate und CustomFieldB — Diese Bereiche stammen aus den Ergebnissen, die man mit der FlexiLayout-Variante erhalten hat, die durch das Training mit Rechnungen von diesem Lieferanten generiert wurde.

Bei Rechnungen von anderen Lieferanten werden die Feldbereiche wie folgt zusammengeführt:

  • InvoiceDate und InvoiceNumber — Diese Bereiche stammen von den Ergebnissen, die man mit dem Haupt-FlexiLayout erhalten hat.
  • CustomFieldA und CustomFieldB — Diese Bereiche stammen von den Ergebnissen, die man mit dem zusätzlichen FlexiLayout erhalten hat.


Kontrolle von Rechnungspositionen

Eine Bestellung ist ein Geschäftsdokument, das von einem Käufer an einen Verkäufer ausgestellt wird, und in dem Typ, Menge und vereinbarter Preis für die Produkte oder Dienstleistungen angegeben werden, die der Verkäufer dem Käufer liefern wird. Eine Rechnung ist ein Geschäftsdokument, das von einem Verkäufer an einen Käufer ausgestellt wird, und in dem Produkte, Mengen und vereinbarter Preis für die Produkte oder Dienstleistungen angegeben werden, die der Verkäufer dem Käufer geliefert hat.

Viele Unternehmen führen Aufzeichnungen über ihre Bestellungen. Von Lieferanten ausgestellte Rechnungen enthalten die Nummern der jeweiligen Bestellung. Bei der Verarbeitung von Rechnungen können die darin angegebenen Produkte und Dienstleistungen mit den in den jeweiligen Bestellungen angegebenen verglichen werden.

Standardmäßig ist der Vergleich von Bestellungen und Rechnungen deaktiviert.

Aktivierung des Vergleichs von Rechnungen mit deren jeweiligen Bestellungen

I. Aktivieren Sie die entsprechende Funktion in ABBYY FlexiCapture for Invoices.

  1. Wählen Sie im Menü Projekt Dokumentdefinitionen….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf Bearbeiten….
  3. Öffnen Sie das Menü Dokumentdefinition und wählen Sie Eigenschaften der Dokumentdefinition… .
  4. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte Rechnungseinstellungen.
  5. Klicken Sie auf die Schaltfläche Bearbeiten… neben der Gruppe Zusätzliche Felder und Funktionen, um das Dialogfeld Rechnungsfunktionen zu öffnen.
  6. Wählen Sie die Option Bestellungszuordnung.

II. Verbinden Sie eine Datenbank mit Bestellungen.

  1. Wählen Sie im Hauptfenster des Dokumentdefinitionseditors Dokumentdefinition>Eigenschaften der Dokumentdefinition….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf die Registerkarte Datensätze.

Ein Datensatz ist eine Tabelle, die die Datenstruktur festlegt und entweder Daten speichert oder diese von einer externen Datenbank bezieht.

  3. Wählen Sie PurchaseOrders aus der Liste und klicken Sie auf Einrichtung….

Beachten Sie die Struktur der verbundenen Daten. See "Spalten im Datensatz PurchaseOrders"

Befindet sich in Ihrer Datenbank keine solche Tabelle, muss mithilfe der in Ihrer Datenbanksoftware verfügbaren Tools eine entsprechende Ansicht erstellt werden.

  4. Im Dialogfeld Datensatz (PurchaseOrders) legen Sie die Zeichenfolge fest, die für die Verbindung zu Ihrer ODBC-kompatiblen Datenbank von Bestellungen verwendet werden soll, sowie das zu verwendende Datenschema und wählen dann die gewünschte Tabelle oder Datenbankansicht.
  5. Bestimmen Sie die Korrespondenz zwischen den Spalten im Datensatz und der externen Datenbank.

Jetzt wird das Programm Bestellnummern und Gesamtbeträge in den Rechnungen suchen und diese mit den in der Bestelldatenbank gespeicherten vergleichen.

III. Verbinden der Artikel der Bestellung

  1. Wählen Sie im Hauptfenster des Dokumentdefinitionseditors Dokumentdefinition>Eigenschaften der Dokumentdefinition….
  2. Im daraufhin angezeigten Dialogfeld klicken Sie auf die Registerkarte Datensätze.

Ein Datensatz ist eine Tabelle, die die Datenstruktur festlegt und entweder Daten speichert oder diese von einer externen Datenbank bezieht.

  3. Wählen Sie Artikel der Bestellung aus der Liste und klicken Sie auf Einrichtung….

Beachten Sie die Struktur der verbundenen Daten. See "Spalten im Datensatz PurchaseOrdersItems "

Es ist wichtig, dass die Nummer einer Bestellung mit der in der Bestelldatenbank angegebenen Nummer übereinstimmt.

Datensatz Bestellungen ist eine Pflichtspalte. Alle anderen Spalten sind optional.

Befindet sich in Ihrer Datenbank keine solche Tabelle, muss mithilfe der in Ihrer Datenbanksoftware verfügbaren Tools eine entsprechende Ansicht erstellt werden.

  4. Im Dialogfeld Datensatz (Artikel der Bestellungen) legen Sie die Zeichenfolge fest, die für die Verbindung zu Ihrer ODBC-kompatiblen Datenbank von Bestellungen verwendet werden soll, sowie das zu verwendende Datenschema und wählen dann die gewünschte Tabelle oder Datenbankansicht.
  5. Bestimmen Sie die Korrespondenz zwischen den Spalten im Datensatz und der externen Datenbank.

Für weitere Informationen See "Erkennung der Hauptfelder"

Vergleich der Rechnungspositionen mit den Artikeln der Bestellung

Ist Bestellungszuordnung ausgewählt, wird die Gruppe PurchaseOrders bei der Überprüfung der Rechnungen im Datenformular angezeigt.

Für jede Bestellung, die in einer Rechnung gefunden wird, wird ein Gruppenelement angezeigt, das folgendermaßen aufgebaut ist:

  • Bestellnummer
  • Gesamtbetrag
  • Schaltfläche Details...

Durch Klicken auf Details... werden weitere Informationen über die Bestellung angezeigt, vorausgesetzt, der Administrator hat eine Datenbank verbunden, die solche Informationen enthält. Diese zusätzlichen Informationen werden unten im Bildfenster angezeigt, sodass Rechnungspositionen mit ihren jeweiligen Bestellungen auf einfache Weise verglichen werden können.

  • Wurden Bestellnummer und Betrag korrekt erfasst, bestätigen Sie die entsprechenden Felder durch Anklicken der Schaltfläche Enter.
  • Wurde die Bestellnummer falsch erfasst, geben Sie in das Feld Bestellnummer die korrekte Nummer ein oder bestimmen Sie diese im Bild.
  • Wurde keine Bestellungen erkannt und werden im Datenformular nicht angezeigt, klicken Sie auf den Link Artikel der 'Bestellung' hinzufügen unten in der Gruppe PurchaseOrders. Der Gruppe PurchaseOrders wird ein leeres Element hinzugefügt. Geben Sie die Werte der Felder Bestellnummer und Gesamtsumme ein, indem Sie diese entweder im Bild angeben oder manuell eingeben. Das Programm wird eine Regel anwenden, um die eingegebenen Werte automatisch mit der Bestelldatenbank zu überprüfen.
  • Wurde die Bestellnummer korrekt erkannt, aber die Beträge sind verschieden, klicken Sie auf die Schaltfläche Details... und vergleichen die Rechnungspositionen mit deren Bestellungen, um die Ursache der Abweichung zu identifizieren.


Zusätzliche Programmfunktionen für Operatoren aktivieren

Der Administrator kann für die Operatoren zusätzliche Funktionen für die Verarbeitung von Rechnungen aktivieren. Beachten Sie, dass diese zusätzlichen Funktionen für Benutzer mit Administratorberechtigungen immer verfügbar sind.

Trainieren des Programms während der Verarbeitung von Rechnungen

Ist die Qualität der Datenerfassung unzureichend, z. B. bei Rechnungen mit ungewöhnlichen Feldpositionen, kann der Operator das Programm zusätzlich trainieren, um die Daten solcher Rechnungen zu erfassen.

Damit das Programm die Erfassung ungewöhnlich positionierter Felder lernt, muss der Operator die korrekte Position der Felder auf dem Bild angeben und auf die Schaltfläche [image] klicken. Nachdem das Programm mindestens drei Bilder mit solchen ungewöhnlichen Feldpositionen erfasst hat, erlernt es die Erfassung von Daten aus diesen Positionen. Die Daten aller nachfolgenden Rechnungen werden mithilfe dieses Wissens erfasst. Für weitere Informationen dazu See "ABBYY FlexiCapture for InvoicesTrainieren".

Standardmäßig ist die Trainingsfunktion aktiviert und für Operatoren verfügbar. So wird die Trainingsfunktion für Operatoren deaktiviert:

  1. Wählen Sie im Hauptfenster des Dokumentdefinitionseditors Dokumentdefinition>Eigenschaften der Dokumentdefinition….
  2. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte Rechnungseinstellungen.
  3. Klicken Sie auf die Schaltfläche Bearbeiten… neben der Gruppe Zusätzliche Felder und Funktionen, um das Dialogfeld Rechnungsfunktionen zu öffnen.
  4. Deaktivieren Sie die Option Lernen während der Rechnungsverarbeitung.

Um die Trainingsfunktion für Operatoren zu aktivieren (wenn sie deaktiviert wurde), wählen Sie die Option Lernen während der Rechnungsverarbeitung.

Datensätze von Lieferanten und Geschäftseinheiten ändern und hinzufügen

Bei der Einrichtung Ihres Projekts zur Rechnungserfassung haben Sie Datenbanken von Lieferanten und Geschäftseinheiten mit den entsprechenden Datensätzen des Projekts verbunden. Diese Datensätze legen die Datenstruktur fest und speichern eine Kopie der Daten innerhalb des Projekts, wobei sie dann regelmäßig mit Ihrer externen Datenbank synchronisiert werden. See "Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten".

Die Rechnungserkennung startet mit der Suche nach dem Lieferanten und der Geschäftseinheit. Diese Feldgruppen können in einem Bild nur dann gefunden werden, wenn sie im Datensatz vorhanden sind. Es ist wichtig, dass der Lieferant und die Geschäftseinheit vom Programm gefunden werden, da diese Daten für die Auswahl des Landes der Rechnung verwendet werden, was die Steuersätze bestimmt, die beim Auffinden der Felder Beträge im Bild und für die Auswahl der Validierungsregeln verwendet werden.

Im Allgemeinen werden alle Lieferanten und Geschäftseinheiten bereits in den entsprechenden Datensätzen enthalten sein. Erhalten Sie jedoch eine Rechnung von einem neuen Lieferanten, der sich nicht in der Datenbank befindet, wird die Feldgruppe Lieferant nicht erkannt. Je nach Geschäftsvorgang können das Hinzufügen des neuen Lieferanten zur Lieferantendatenbank und ihre Synchronisierung mit den Datensätzen viel Zeit in Anspruch nehmen und das Programm kann erst dann Rechnungen von diesem Lieferanten verarbeiten, sobald der Lieferant im Datensatz gefunden wird.

Ein weiteres Beispiel ist die Änderung der Adresse oder Kontonummer eines vorhandenen Lieferanten. Die Aktualisierung der Lieferantendatenbank und ihre Synchronisierung mit dem Datensatz kann viel Zeit in Anspruch nehmen, aber der Operator benötigt aktuelle Informationen, um die Rechnungen verarbeiten zu können.

Um die oben genannten Probleme zu lösen, kann der Administrator den Operatoren ermöglichen, den Datensätzen Einträge hinzuzufügen oder diese zu bearbeiten. Die Änderungen werden an den im Projekt gespeicherten Datensätzen vorgenommen, nicht an den externen Datenbanken für Lieferanten und Geschäftseinheiten.

Fügt ein Operator dem Datensatz einen neuen Lieferanten hinzu, kann das Programm die Feldgruppe Lieferant in den nachfolgenden Rechnungen dieses Lieferanten erkennen, so als wäre ein Datensatz für diesen Lieferanten in der externen Lieferantendatenbank vorhanden. Die Validierungsregeln werden jedoch erkennen, dass der Lieferant nicht in der externen Datenbank vorhanden ist und der Rechnung den Status Ausnahme zuweisen.

Wird der Datensatz das nächste Mal mit der externen Datenbank synchronisiert, werden alle von den Operatoren hinzugefügten Lieferanten durch die entsprechenden Einträge aus der Datenbank ersetzt oder aus dem Datensatz entfernt. See "Aktualisierung von Datensätzen" für weitere Informationen über die Aktualisierung von Datensätzen.

Standardmäßig können Operatoren den Datensätzen keine neuen Einträge hinzufügen. So wird diese Funktion für Operatoren aktiviert:

  1. Wählen Sie im Hauptfenster des Dokumentdefinitionseditors Dokumentdefinition>Eigenschaften der Dokumentdefinition….
  2. Klicken Sie im daraufhin geöffneten Dialogfeld auf die Registerkarte Rechnungseinstellungen.
  3. Klicken Sie auf die Schaltfläche Bearbeiten… neben der Gruppe Zusätzliche Felder und Funktionen, um das Dialogfeld Rechnungsfunktionen zu öffnen.
  4. Wählen Sie die Option Operatoren können Datensätze bearbeiten.

Um die Trainingsfunktion für Operatoren zu deaktivieren (wenn sie aktiviert wurde), wählen Sie die Option Operatoren können Datensätze bearbeiten ab.


Aktualisierung der Dokumentdefinition für Rechnungen

ABBYY FlexiCapture for Invoices wird mit einer integrierten Dokumentdefinition ausgeliefert, die speziell für die Verarbeitung von Rechnungen entwickelt wurde. Mit jeder veröffentlichten neuen Version von ABBYY FlexiCapture for Invoices wird auch die integrierte Dokumentdefinition aktualisiert.

Benutzer, die mit älteren Versionen von ABBYY FlexiCapture for Invoices ein Projekt zur Rechnungsverarbeitung erstellt haben, können ihre Dokumentdefinition für Rechnungen aktualisieren, wobei die alten Einstellungen übernommen werden (das Erscheinungsbild des Datenformulars, benutzerdefinierter Felder, Regeln usw.) und profitieren von den Verbesserungen, die mit der neueren Version von ABBYY FlexiCapture for Invoices eingeführt wurden.

Die folgenden Funktionen werden aktualisiert oder hinzugefügt | Die folgenden Funktionen bleiben unverändert
Felder

Die für die Hauptfelder der ABBYY FlexiCapture for Invoices-Dokumentdefinition verwendeten Einstellungen werden aktualisiert (siehe Liste der Felder).

Alle mit der neuen Version der ABBYY FlexiCapture for Invoices-Dokumentdefinition eingeführten neuen Felder werden der Dokumentdefinition des Benutzers hinzugefügt.

Hat der Benutzer in seiner eigenen Dokumentdefinition ein neues Feld erstellt und ist in der neuen Version der ABBYY FlexiCapture for Invoices-Dokumentdefinition eine Regel mit dem gleichen Namen vorhanden, wird die Aktualisierung unterbrochen und es wird eine Fehlermeldung angezeigt. Um mit der Aktualisierung fortzufahren, muss der Benutzer das den Konflikt hervorrufende Feld in der Dokumentdefinition umbenennen.

Die vom Benutzer erstellten Felder.

Die für die Hauptfelder der ABBYY FlexiCapture for InvoicesDokumentdefinition verwendeten Einstellungen (siehe Liste der Felder), wenn diese vom Benutzer geändert wurden.

Regeln

Die für die Hauptregeln der ABBYY FlexiCapture for Invoices-Dokumentdefinition verwendeten Einstellungen werden aktualisiert (siehe Liste der Regeln).

Alle mit der neuen Version der ABBYY FlexiCapture for Invoices-Dokumentdefinition eingeführten neuen Regeln werden der Dokumentdefinition des Benutzers hinzugefügt.

Die vom Benutzer erstellten Regeln. Im Falle eines Konflikts der Regelnamen: Die vom Benutzer erstellten Regeln, die in Konflikt stehen, werden automatisch umbenannt (der Suffix "_1" wird jedem in Konflikt stehendem Namen hinzugefügt).

Die Skripte des Benutzers für alle Felder.

Datensätze | Die Standarddatensätze und die Datensätze des Benutzers.
FlexiLayouts | Das Haupt-FlexiLayout. | Das zusätzliche FlexiLayout.
Einstellungen für die Rechnungsverarbeitung Alle neuen Schlüsselwörter, Steuersätze und landes- und sprachspezifischen Formate werden der Dokumentdefinition des Benutzers hinzugefügt.

Die vom Benutzer aktivierten Funktionen zur Rechnungsverarbeitung.

Die vom Benutzer aktivierten Länder und Sprachen.

Alle vom Benutzer festgelegten Schlüsselwörter, Steuersätze und Feldformate.

Event-Handler | Alle in der Dokumentdefinition des Benutzers deaktivierten Event-Handler werden aktualisiert. | Alle in der Dokumentdefinition des Benutzers aktivierten Event-Handler.
Externe Assemblies | Die in der ABBYY FlexiCapture for InvoicesDokument-Definition enthaltenen Standard-Assemblies. | Vom Benutzer hinzugefügte Assemblies.

Die Exporteinstellungen, das Datenformular und die Lokalisierung der Dokumentdefinition bleiben unverändert.

Durchführen der Aktualisierung

  1. Klicken Sie im Hauptmenü auf Projekt> Dokumentdefinitionen…. Das Dialogfeld Dokumentdefinitionen wird angezeigt, in dem Sie Ihre Dokumentdefinitionen verwalten können.

Hinweis: Wir empfehlen vor der Aktualisierung die Sicherung Ihrer Dokumentdefinition. Um eine Sicherungskopie einer Dokumentdefinition zu erstellen, wählen Sie diese in der Liste aus und Klicken auf Duplizieren.

  2. Um eine Dokumentdefinition zu aktualisieren, wählen Sie diese in der Liste aus und klicken auf Aktualisieren.
  3. Klicken Sie auf Veröffentlichen, um die Änderungen zu veröffentlichen.

Sollen die von der Aktualisierung durchgeführten Änderungen verworfen werden, klicken Sie auf Änderungen rückgängig machen.

Mögliche Fehler und Warnungen

Auch wenn während des Aktualisierungsvorgangs Fehlermeldungen und Warnungen angezeigt werden, wird Ihre Dokumentdefinition aktualisiert. Ihre aktualisierte Dokumentdefinition kann geöffnet, bearbeitet und veröffentlicht werden oder die von der Aktualisierung durchgeführten Änderungen können verworfen werden.

Tritt während der Aktualisierung Ihrer Dokumentdefinition ein Fehler auf, wird die Fehlerursache anhand der entsprechenden Fehlermeldung angezeigt. Die Änderungen, die den Fehler verursachen, sind nicht in der aktualisierten Dokumentdefinition vorhanden.

Werden während der Aktualisierung Ihrer Dokumentdefinition Fehlermeldungen angezeigt, ist eine manuelle Bearbeitung erforderlich. Die Verwendung einer Dokumentdefinition, die mit Fehlern und Warnungen aktualisiert wurde, wird von uns nicht empfohlen.


Spezifikationen

Dieser Abschnitt enthält Informationen über ein ABBYY FlexiCapture for Invoices-Projekt:

See "Unterstützte Länder und Sprachen"

See "Erfasste Felder"

See "Verfügbare Regeln"

See "Schlüsselwörter"

See "Erweiterte reguläre Ausdrücke"

See "Glossar "


Unterstützte Länder und Sprachen

Unterstützte Länder:

  • Österreich
  • Belgien
  • Frankreich
  • Deutschland
  • Großbritannien
  • Irland
  • Italien
  • Niederlande
  • Spanien
  • Schweiz

Unterstützte Sprachen:

  • Englisch
  • Deutsch
  • Französisch
  • Niederländisch
  • Italienisch
  • Spanisch

Hinweis: Es können weitere Länder hinzugefügt werden. Für ausführliche Informationen See "Land- und Spracheinstellungen".


Erfasste Felder

Feldgruppe Feldnamen
Geschäftsbereich / Business Unit
  • ID-GB / ID-BU
  • Straße-GB / Street-BU
  • Postleitzahl-GB / PostalCode-BU
  • Ort-GB / City-BU
  • Land-GB / Country-BU
  • Umsatzsteuer-ID-GB / VATID-BU
  • Name-GB / Name-BU
Lieferant / Vendor
  • ID-Lieferanten / ID-Vendor
  • Umsatzsteuer-ID-Lieferant / VATID-Vendor
  • Steuernummer-Lieferant / NationalVAT-Vendor
  • IBAN / IBAN
  • Bankleitzahl / BankCode
  • Bankkonto / BankAccount
  • Straße-Lieferant / Street-Vendor
  • PLZ-Lieferant / ZIP-Vendor
  • Ort-Lieferant / City-Vendor
  • Land-Lieferant/ Country-Vendor
  • Name-Lieferant / Name-Vendor
Daten der Rechnungskopfzeile / Invoice Header Data
  • Rechnungstyp / Invoice Type (Rechnung (Invoice) / Gutschrift (Credit Note))
  • Rechnungsnummer / Invoice Number
  • Rechnungsdatum / Invoice Date

  • Lieferdatum* / Delivery Date*

  • Fälligkeitsdatum* / Due Date*

  • Einkäufer* / Purchaser Name*
Beträge / Amounts

  • Bruttogesamtbetrag / Total

  • Währung / Currency
  • Reversed Charge / Reversed Charge
  • Steuern / Taxes
  • Nettobetrag / Net Value

  • Nettobetrag 1 / Net Value 1
  • Steuersatz 1 / Tax Rate 1
  • Steuerbetrag 1 / Tax 1

  • Nettobetrag 2 / Net Value 2
  • Steuersatz 2 / Tax Rate 2
  • Steuerbetrag 2 / Tax 2

  • Steuergesamtbetrag / Total Tax
  • Nettogesamtbetrag / Total Net

Nebenkosten / AdditionalCosts

  • Nebenkosten 1 / Additional Cost 1

  • Nebenkosten 2 / Additional Cost 2

  • Zusatzgesamtkosten / Total Additional Cost

Bestellung* / Purchase Order*

  • Bestellnummer / Order Number
  • Bruttogesamtbetrag / Total
Artikel* / Line Items*
  • Bestellnummer / Order Number
  • Position / Position
  • Beschreibung / Description
  • Artikelnummer / Article Number
  • Menge / Quantity
  • Menge, nicht geliefert / Quantity Undelivered
  • Menge, bestellt / Quantity Ordered
  • Maßeinheit / Unit of Measurement
  • Artikelpreis / Unit Price
  • Rabatt in Prozent / Discount Percentage
  • Rabattwert / Discount Value
  • Nettogesamtpreis / Total Price Netto
  • Bruttogesamtpreis / Total Price Brutto
  • Währung / Currency
  • Bestelldatum / Order Date
  • Lieferdatum / Delivery Date
  • MwSt. in Prozent / VAT Percentage
  • MwSt. Wert / VAT Value
  • MwSt.-Code / VAT Code
  • Materialnummer / Material Number

* kennzeichnet zusätzliche Felder, die standardmäßig nicht erfasst werden. Für weitere Informationen über zusätzliche Felder See "Erfassung zusätzlicher Rechnungsfelder".

Hinweis: ABBYY FlexiCapture for Invoices kann auch für die Erfassung benutzerdefinierter Felder trainiert werden. Für weitere Informationen über das Training See "Erfassung zusätzlicher Rechnungsfelder".


Erkennung der Hauptfelder

Dieser Artikel beschreibt, wie die Hauptfelder einer Rechnung erkannt und erfasst werden.

Ersterkennung

Das Programm startet die Verarbeitung einer Rechnung durch die Ersterkennung ihres Textes in Übereinstimmung mit den Einstellungen der Dokumentdefinition:

  • Der Ersterkennungsmodus (Sehr schnell / Schnell / Ausgewogen / Vollständig) bestimmt die Geschwindigkeit der Ersterkennung und die Qualität der daraus erhaltenen Textebene. Um einen Ersterkennungsmodus festzulegen, klicken Sie im Dokumentdefinitionseditor auf Dokumentdefinition > Eigenschaften der Dokumentdefinition… > FlexiLayout.)
  • Ersterkennungssprachen sind die Sprachen, die für die Ersterkennung verwendet werden. Um Ersterkennungssprachen festzulegen, klicken Sie im Dokumentdefinitionseditor auf Dokumentdefinition > Eigenschaften der Dokumentdefinition… > Rechnungseinstellungen und klicken dann auf Bearbeiten in der Gruppe Länder und Sprachen, um die gewünschten Sprachen auszuwählen.

Nachdem eine Rechnung ersterkannt wurde, beginnt das Programm mit der Erfassung der Felder.

Geschäftseinheit und Lieferant

Nachdem das Programm Geschäftseinheit und Lieferant in einer Rechnung erkannt hat, wird Folgendes abgerufen:

  • die Kennung und der entsprechende Datensatz der Geschäftseinheit im Datensatz BusinessUnits
  • die Kennung und der entsprechende Datensatz des Lieferanten im Datensatz Lieferant

Das Programm nutzt Folgendes für die Erkennung des Lieferanten (oder der Geschäftseinheit):

  • die folgenden Felder des Eintrags in einem Datensatz: IBAN, USt-IdNr, Nationale Steuer-ID, Name, Straße, Stadt, PLZ
  • die Einstellungen der Dokumentdefinition: die Formate von IBAN, USt-IdNr und Nationaler Steuer-ID und deren entsprechende Schlüsselwörter

Weitere Informationen über die Spalten in den Datensätzen BusinessUnits und Vendors und wie sie verwendet werden, finden Sie unter See "Spalten im Datensatz BusinessUnits" und See "Spalten im Datensatz Vendors"

Algorithmus für die Erkennung von Unternehmen

  1. Suche nach den einzigartigen Unternehmens-IDs

Die Felder, die ein Unternehmen eindeutig identifizieren, sind:

  • USt-IdNr
  • Nationale Steuer-ID
  • IBAN

ABBYY FlexiCapture for Invoices wird zuerst nach dem Unternehmen suchen, das zur Rechnung im Datensatz passt, und sich dabei auf die oben genannten Felder stützen. Damit diese Suche erfolgreich ist, müssen die entsprechenden Spalten des Unternehmenseintrags im Datensatz vollständig und deren Werte im Bild präsent sein.

Die Formate von MWSTID, Nationale MWSTID und IBAN werden festgelegt anhand regulärer Ausdrücke in den Eigenschaften der Dokumentdefinition (klicken Sie auf Dokumentdefinition > Eigenschaften der Dokumentdefinition… > Rechnungseinstellungen, klicken Sie auf Bearbeiten in Länder und Sprachen, wählen Sie das gewünschte Land aus der Liste Länder, klicken Sie auf Bearbeiten und dann auf die Registerkarte Formate). Die Schlüsselwörter werden auf der Registerkarte Schlüsselwörter im gleichen Dialogfeld festgelegt.

Damit diese Felder erkannt werden, muss das Programm deren exakte Zuordnungen im Bild finden. Sie können erweiterte reguläre Ausdrücke verwenden, um dem Programm etwas Spielraum zu geben und um mögliche Erkennungsfehler zu berücksichtigen (See "Erweiterte reguläre Ausdrücke").

Die erkannten Werte für die Felder USt-IdNr, Nationale Steuer-ID und IBAN werden dann normalisiert:

  • alle Buchstaben werden zu Großschreibung geändert,
  • Leerzeichen und die folgenden Zeichen werden entfernt: ., ,, —, /, \.

Wird auf der Registerkarte Formate ein regulärer Ausdruck für das Festlegen eines Buchstabenpräfixes für einen Feldwert verwendet, wird der erkannte Präfix durch den auf derselben Registerkarte festgelegten primären Präfix ersetzt.

Beispielsweise wird die Kennung DE12345 u. U. erkannt als OE12345, die Normalisierung wird aber das OE durch ein korrektes DE ersetzen.

Das Programm verwendet dann die im Bild erkannten Felder USt-IdNr, Nationale Steuer-ID und IBAN für die Abfrage des Datensatzes. Die Werte der vom Datensatz erhaltenen Spalten USt-IdNr, Nationale Steuer-ID und IBAN werden auf die gleiche Weise normalisiert wie die Werte der Felder, die im Bild erkannt werden. Danach werden die Werte des Datensatzes mit den Werten im Bild verglichen (es wird eine unscharfe Zuordnung verwendet) und die Anzahl der Abweichungen wird gezählt.

Ein Unternehmenseintrag aus dem Datensatz wird als eine zuverlässige Übereinstimmung für das Unternehmen im Bild angesehen, wenn:

  • mindestens zwei Kennungen im Eintrag mit denen im Bild erkannten identisch sind, mit nicht mehr als einer Abweichung

    oder

  • wenn alle drei Kennungen des Eintrags (USt-IdNr, Nationale Steuer-ID und IBAN) mit denen im Bild erkannten identisch sind, mit nicht mehr als zwei Abweichungen

Wird eine zuverlässige Übereinstimmung gefunden, wird die Suche beendet.

Ansonsten sucht das Programm nach Name und Adresse des Unternehmens und verwendet als Annahme die Einträge, die vom Datensatz abgerufen wurden.

  2. Suche nach Firmenname und Adresse

Das Programm verwendet bei der Suche nach Name und Adresse des Unternehmens die vom Datensatz abgerufenen Einträge als Annahmen.

Ergibt die Suche des Programms nach den einzigartigen IDs einen nicht leeren Satz von Einträgen aus dem Datensatz, wird dieser Satz verwendet.

Wenn das Programm auf der Basis dieses Satzes von Einträgen weder Firmenname oder Adresse findet oder wenn dieser Satz leer ist:

  • die Felder USt-IdNr, Nationale Steuer-ID und IBAN wurden im Bild nicht erkannt

    oder

  • die Spalten USt-IdNr, Nationale Steuer-ID und IBAN des übereinstimmenden Eintrags im Datensatz enthalten keine Werte

das Programm fragt mithilfe des gesamten Textes der Seite den Datensatz ab. Als Ergebnis wird der Unternehmenseintrag mit der besten Übereinstimmung zum Text auf der Seite zurückgegeben und dann als Annahme verwendet.

Das Programm durchsucht das Bild nach dem Namensfeld und den Komponenten Straße, PLZ und Stadt der Adresse der einzelnen Einträge, die als Annahme dienen:

  1. Das Programm sucht nach den Feldern Name und Straße als eine Zeichenfolge mit erlaubten 25 % Fehlern oder als einzelne Wörter (wobei bei Letzterem das Clustering der Wörter im Bild berücksichtigt wird).
  2. Das Programm sucht nach den Feldern PLZ und Stadt als Einzelkomponente und erwartet die Positionierung beider Felder in der gleichen Zeile.

Die erkannten Werte der Felder Name, Straße, PLZ und Stadt werden mit den Werten im Datensatzeintrag verglichen und die Anzahl der Abweichungen wird gezählt.

Die Entscheidung darüber, welcher Datensatzeintrag dem Bild am besten entspricht, wird folgendermaßen getroffen:

  • Der Eintrag wird dann als zuverlässige Übereinstimmung angesehen, wenn neben den einzigartigen Kennungen (USt-IdNr, Nationale Steuer-ID, IBAN) das Feld "Name" und mindestens eine Adresskomponente (z. B. Straße oder die Kombination aus PLZ und Straße) mit dem Text im Bild übereinstimmen und nicht mehr als vier Abweichungen vorhanden sind.
  • Der Eintrag wird dann als unzuverlässig angesehen, wenn neben den einzigartigen Kennungen (USt-IdNr, Nationale Steuer-ID, IBAN) alle Adresskomponenten mit dem Text im Bild übereinstimmen, aber das Feld "Name" nicht mit dem Bildtext übereinstimmt.
  • Enthält der Datensatzeintrag keine einzigartigen Kennungen (USt-IdNr, Nationale Steuer-ID, IBAN) oder wurden diese im Bild nicht erkannt, wird das Programm als zuverlässige Übereinstimmung den Eintrag mit einem übereinstimmenden Namen und mindestens einer übereinstimmenden Adresskomponente (z. B. Straße oder die Kombination aus PLZ und Stadt) auswählen und es dürfen nicht mehr als acht Abweichungen gesamt vorhanden sein.

Ansonsten wird der Eintrag mit der höchsten Anzahl von Feldübereinstimmungen mit den erkannten Werten in den Bildern als eine unzuverlässige Übereinstimmung angesehen.

Ergebnisse der Erkennung von Lieferant und Geschäftseinheit

Die Hauptergebnisse der Erkennung von Lieferant und Geschäftseinheit in Rechnungen sind:

  • die Kennung des Lieferanteneintrags im Datensatz Lieferant

  • die Kennung des Geschäftseinheiteintrags im Datensatz BusinessUnits

Hinweis: Legt der Datensatz Vendors fest, dass ID abhängig ist von BusinessUnitId (ausführliche Informationen finden Sie unter See "Spalten im Datensatz Vendors"), enthält das Ergebnis der Lieferantenerkennung die ID, die der Geschäftseinheit-ID entspricht.

Eine Geschäftseinheit kann u. U. unzuverlässig erkannt werden. In diesem Fall wird der Registrierungsparameter fc_Predefined:InvoiceIsVendorSuspicious (fc_Predefined:InvoiceIsBusinessUnitSuspicious) des Dokuments auf true festgelegt.

Die Bereiche der folgenden Felder können als Ergebnis der Erkennung von Lieferant und Geschäftseinheit gefunden werden:

Für den Lieferanten:

  • Name
  • USt-IdNr
  • Nationale Steuer-ID
  • IBAN
  • Straße
  • PLZ
  • Stadt

Für die Geschäftseinheit:

  • Name
  • USt-IdNr
  • Straße
  • PLZ
  • Stadt

Durch die Untersuchung der Positionen dieser Bereiche im Bild können Sie erkennen, wo exakt im Bild das Programm die Felder der Gruppen Lieferant und Geschäftseinheit gefunden hat, was es dem Programm ermöglichte, Lieferant und Geschäftseinheit zu erkennen.

Hinweis: Enthält das Feld IBAN im Datensatz Vendors keinen Wert, kann dessen Bereich durch einen separaten Erfassungsmechanismus für Bankdetails gefunden werden, der auf deren Schlüsselwörtern und Format basiert. Dieser Vorgang kann nach Erkennung des Lieferanten durchgeführt werden.

Hinweis: Die Suche nach Feldbereichen kann durch Training oder durch Anwendung eines zusätzlichen FlexiLayouts verändert werden (See "Erfassung zusätzlicher Rechnungsfelder".) Das hat keine Auswirkungen auf die Erkennung von Lieferant oder Geschäftseinheit, kann sich aber auf die Position der Bereiche dieser Felder in diesen Gruppen nach der Zuordnung der Dokumentdefinition zu den Rechnungen auswirken.

Ein wichtiges Ergebnis der Erkennung von Lieferant und Geschäftseinheit ist, dass Informationen über ihre jeweiligen Länder vom Feld Ländercode der im Datensatz gefundenen Einträge abgefragt werden. Mit diesen Informationen können dann die Schlüsselwörter und Steuersätze ausgewählt und andere Rechnungsfelder erfasst werden. Die Informationen können außerdem als Bedingung für das Anwenden von Validierungsregeln für die Rechnung verwendet werden.

Änderung der Art und Weise, wie das Programm Lieferant und Geschäftseinheit bestimmt

Je mehr Lieferant und Geschäftseinheit in den Einträgen des Datensatzes mit dem aus dem Bild extrahierten Text übereinstimmen, desto exakter können Lieferant und Geschäftseinheit vom Programm bestimmt werden.

Zuerst muss das Programm die Daten identifizieren, die den Spalten im Datensatz entsprechen und für die Suche nach dem Unternehmen auf der Rechnung in der externen Datenbank verwendet werden. Externe Datenbank und Datensatz müssen ordnungsgemäß verbunden sein (See "Verbindung mit Datenbanken für Lieferanten und Geschäftseinheiten").

So korrigieren Sie mögliche Varianten von Feldwerten im Bild:

  • Normalisierung der Spalten im Datensatz (See "Normalisierung von Werten in Datensätzen"),
  • "multiplizierte" Werte von Spalten im Datensatz (siehe "Komplexe Spalten eines Datensatzes").

Verwendung vorbestimmter Werte für Lieferant und Geschäftseinheit in Verbindung mit extrahierten Werten

Lieferant oder Geschäftseinheit der Rechnungsfirma können basierend auf der Rechnungsquelle im Voraus bestimmt werden (Name des Scan-Operators oder die E-Mail-Adresse des Nachrichtenabsenders).

Sie können vor der automatischen Erkennung Lieferant und/oder Geschäftseinheit ausdrücklich festlegen.

Dafür legen Sie den Wert des Registrierungsparameters fc_Predefined:InvoicePredefinedVendorId (fc_Predefined:InvoicePredefinedBusinessUnitId) für das Dokument auf die Kennung (ID) eines Eintrags im Datensatz von Lieferant oder Geschäftseinheit fest.

Dadurch wird die automatische Erkennung des Lieferanten und/oder der Geschäftseinheit nicht verhindert. Deshalb erhalten Sie darüber hinaus neben dem vorbestimmten Lieferanten und/oder der Geschäftseinheit einen Zuverlässigkeitswert (dieser Wert gibt an, in welchem Maß vorbestimmte Werte den aus dem Bild extrahierten Werten entsprechen) sowie die Bereiche der Felder aus den Gruppen Lieferant und/oder Geschäftseinheit.

Feldgruppen im Rechnungskopf

Rechnungsnummer, Rechnungsdatum

Ein Rechnungskopf enthält unter anderem die Felder Rechnungsnummer und Rechnungsdatum.

Diese Felder werden mithilfe von Schlüsselwörtern erkannt, die in den Spracheigenschaften der Dokumentdefinition festgelegt werden. Lieferant und Geschäftseinheit werden zuerst erkannt und stellen so Informationen über die Länder von Lieferant und Geschäftseinheit bereit. Durch die Länder werden die Sprachen bestimmt (Sprachen, die einem Land entsprechen, werden in der Dokumentdefinition festgelegt). Der Satz von Schlüsselwörtern für das Auffinden von Feldern wird den Ländern des Lieferanten und der Geschäftseinheit entnommen.

Sie können die Art und Weise ändern, wie das Programm nach Feldbereichen sucht, indem Sie die Schlüsselwörter bearbeiten (See "Schlüsselwörter") und das Training verwenden (See "ABBYY FlexiCapture for InvoicesTrainieren").

Wie erkennt das Programm, dass ein Dokument eine Rechnung ist?

ABBYY FlexiCapture bestimmt bei der Anwendung des FlexiLayouts, ob es sich bei einem Dokument um eine Rechnung handelt.

Die nachfolgend aufgeführten Bedingungen weisen darauf hin, dass es sich bei einem Dokument um eine Rechnung handelt. Nicht alle diese Bedingungen müssen erfüllt werden, aber jede davon hat eine bestimmte Gewichtung.

  • Die Felder Rechnungsnummer und Rechnungsdatum wurden erkannt.
  • Die Schlüsselwörter aus den Rechnungskennungen Gefundene Elemente wurden erkannt (See "Schlüsselwörter").
  • Ein Lieferant oder eine Geschäftseinheit wurde im Dokument erkannt.

Ein Dokument kann als Gutschrift identifiziert werden, wenn die Schlüsselwörter aus dem Element CreditNoreKeyword im Bild erkannt wurden oder wenn das Dokument eine negative Gesamtsumme aufweist.

Die Feldgruppen "Beträge"

ABBYY FlexiCapture for Invoices erfasst die folgenden Felder einer Rechnung:

  • Gesamtsummt
    Die Gesamtsumme der Rechnung
  • Währung
    Die Währung der Rechnung
  • Die Gesamtsumme der Rechnung vor Steuer (Nettogesamtsumme) und den Betrag der fälligen Steuer (Steuergesamtsumme),
  • Steuergruppen; Steuersätze und die entsprechenden Summen (vor Steuer) und die Beträge für die fällige Steuer.

Für die Suche nach Summen und Steuersätzen werden die Informationen aus der Dokumentdefinition verwendet:

  • Die im Land des Lieferanten zahlbaren Steuersätze (diese können auf der Registerkarte Steuersätze der Eigenschaften eines Landes festgelegt werden)
  • Schlüsselwörter für Steuersätze (diese können in den Eigenschaften eines Steuersatzes festgelegt werden).

ABBYY FlexiCapture for Invoices durchsucht das Bild nach drei Zahlen, die sich in der gleichen Reihe befinden und Teil eines Ausdrucks sind, der den Steuersatz verwendet. Die Schlüsselwörter werden für die Filterung falscher Steuergruppenannahmen verwendet.

Für die Suche nach den Feldern Gesamtsumme, Nettogesamtsumme und Steuergesamtsumme werden die Schlüsselwörter aus den Einstellungen der Dokumentdefinition verwendet. Das Programm sucht dann nach:

  • Zahlen, die zwei- oder dreimal in der gleichen Zeile oder in der gleichen Spalte im Bild angezeigt werden, in Fällen, wenn keine Steuern bezahlt werden müssen.
  • Zahlen, die Summen der Zahlen sind, die sich in der gleichen Spalte darüber befinden.
  • Die größten (nach absolutem Wert) Zahlen, die sich am Ende des Dokuments befinden.

Das Programm sucht nur dann nach dem Währungsfeld, wenn das Feld "Gesamtsumme" erkannt wurde. Es werden die Schlüsselwörter aus den Eigenschaften des Landes in der Dokumentdefinition verwendet.

Felder aus der Gruppe "Beträge" die nicht im Bild erkannt werden konnten, werden automatisch berechnet, mit Ausnahme des Feldes "Gesamtsumme". Dieses Feld muss im Bild erkannt werden.

Wurden Felder aus der Gruppe "Gesamtsumme" mit einer niedrigen Zuverlässigkeit erkannt und benötigen eine Überprüfung, wird das Feld "Gesamtsumme" auch als notwendig zu überprüfen markiert. Gelingt es dem Programm nicht, die Gesamtsumme mit einer hohen Zuverlässigkeit zu erkennen, kann die Erkennungsgenauigkeit durch Training verbessert werden.

Die Feldgruppe "Bestellung"

ABBYY FlexiCapture for Invoices kann alle Bestellnummern und deren entsprechende Summen aus der Rechnung extrahieren. Diese Funktion ist standardmäßig deaktiviert (See "Kontrolle von Rechnungspositionen").

Für das Extrahieren von Bestellnummern benötigen Sie einen Datensatz mit einer Liste möglicher Bestellnummern und deren Summen (See "Spalten im Datensatz PurchaseOrders").

ABBYY FlexiCapture for Invoices durchsucht dann das Dokumentbild auf mögliche Bestellnummern. Es ist von großer Bedeutung, dass nicht zu viele mögliche Bestellnummern im Datensatz enthalten sind.
Für eine Reduzierung der Menge von Bestellnummern wird Folgendes empfohlen:

  • Verwenden Sie die Spalte Lieferanten-ID aus dem Datensatz. In diesem Fall wird das Programm nur Bestellnummern vom Rechnungslieferanten verwenden.
  • Entfernen Sie alle Bestellungen aus dem Datensatz, für die bereits eine Rechnung verarbeitet wurde.

Das Programm durchsucht dann die Datenbank nach Summen, die den erkannten Bestellnummern entsprechen.

Das Programm durchsucht das Bild außerdem nach allen Bestellnummern, einschließlich derjenigen, die sich in den Rechnungspositionen befinden.

Die Feldgruppe "Positionen"

ABBYY FlexiCapture for Invoices kann Rechnungspositionen aus Bildern extrahieren.

Hinweis: Diese Funktion ist auf die aktuelle Version von ABBYY FlexiCapture for Invoices beschränkt. Sie wurde zu Demonstrationszwecken integriert.

Die Extrahierung der Rechnungspositionen ist standardmäßig deaktiviert (See "Zusätzliche Felder").

Für eine Liste der Felder, die das Programm automatisch extrahiert, See "Erfasste Felder".

ABBYY FlexiCapture for Invoices durchsucht das Bild zuerst nach einer Tabelle. Während dieser Suche werden Schlüsselwörter für Spaltentitel verwendet, die für jede Sprache in den Eigenschaften der Dokumentdefinition festgelegt werden. Auch für die Klassifizierung von Positionsspalten werden Schlüsselwörter verwendet, wie z. B. für die Bestimmung des Typs jeder Positionsspalte einer Rechnung.

Danach verwendet das Programm die Informationen über erkannte Spalten und mathematische Ausdrücke, um so die Rechnungspositionen in der Tabelle der Rechnung zu finden.

Und schließlich durchsucht das Programm die Rechnungspositionen auf Felder in Spalten.


Spalten im Datensatz BusinessUnits

Dieser Datensatz enthält Informationen über Geschäftseinheiten. Mit ihm wird die Geschäftseinheit automatisch bestimmt (der Bereich des Unternehmens, der die Rechnung erhalten hat) und die Informationen über die Geschäftseinheit werden mit einer Datenbank abgeglichen.

Name | Text | Beschreibung
ID / ID | Text, keine Normalisierung | Pflichtfeld. Das Programm wählt die Werte aus diesen Feldern bei der Bestimmung der Geschäftseinheit und der Kennung in einer externen Datenbank. Für die Suche nach der Geschäftseinheit im Bild werden keine IDs verwendet. Einzigartiger Schlüssel des Eintrags im Datensatz.
Umsatzsteuer-ID-GB / VATID | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Die einem Unternehmen zugewiesene einzigartige Kennung zu Steuerzwecken. Dieses Feld wird für das Auffinden von Geschäftseinheiten in Bildern verwendet und beeinflusst die Erkennung stark.
Name-GB / Name-BU | Text, Normalisierung: Text | Optionales Feld. Der Name der Geschäftseinheit. Dieses Feld wird genutzt, um Geschäftseinheiten in Bildern zu erkennen.
Straße-GB / Street-BU | Text, Normalisierung: Text | Optionales Feld. Teil der Adresse der Geschäftseinheit. Dieses Feld wird genutzt, um Geschäftseinheiten in Bildern zu erkennen.
PLZ-GB / ZIP-BU | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Teil der Adresse der Geschäftseinheit. Dieses Feld wird genutzt, um Geschäftseinheiten in Bildern zu erkennen.
Ort-GB / City-BU | Text, Normalisierung: Text | Optionales Feld. Teil der Adresse der Geschäftseinheit. Dieses Feld wird genutzt, um Geschäftseinheiten in Bildern zu erkennen.
Ländercode / CountryCode | Text, Normalisierung: Alphanumerischer Code | Pflichtfeld. Teil der Adresse der Geschäftseinheit. Für die Suche der Geschäftseinheit in einem Bild. Das Programm verwendet den Ländercode nicht bei der Suche nach der Geschäftseinheit. Ländercodes sind zweistellige ISO 3166-1 Alpha-2-Codes. Hierbei handelt es sich um ein Pflichtfeld, da das Programm das Land der Geschäftseinheit für die Bestimmung der Art und Weise verwendet, wie ein FlexiLayout für Rechnungen angewendet wird und wie die Felder überprüft werden.


Spalten im Datensatz Vendors

Dieser Datensatz enthält Informationen über die Lieferanten und dient zur Erkennung des Ausstellers einer Rechnung und zur Überprüfung der Lieferantendetails anhand einer Datenbank.

Name | Typ | Beschreibung
ID / ID Text, ohne Normalisierung

Pflichtfeld. Das ist das Ergebnis der Erkennung des Lieferanten. Dient außerdem zur Identifizierung des Lieferanten in einem externen Informationssystem. Das Feld wird nicht für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.

Hinweis: Wird das Feld BusinessUnitId nicht verwendet, ist das Feld ID der einzigartige Schlüssel des Eintrags im Datensatz.

ID-GB / BusinessUnitId Text, ohne Normalisierung

Optionales Feld. Die Kennung der Geschäftseinheit des Unternehmens, das die Rechnung erhalten hat. Das Feld wird nicht für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.

Hinweis: Ist dieses Feld ausgefüllt, wird das Feld ID nicht als einzigartig behandelt und wird als abhängig vom Feld BusinessUnitId angesehen. Der Hintergrund ist, dass jede Geschäftseinheit (BusinessUnitId) eines Unternehmens ihre eigene einzigartige Liste von Lieferanten (ID) besitzt. Das Paar BusinessUnitId + ID stellt den einzigartigen Schlüssel des Lieferanteneintrags im Datensatz dar.

Umsatzsteuer-ID-Lieferant / VATID | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Die einzigartige Kennung des Lieferanten zu Zwecken der Steuerzahlung. Das Feld wird für das Auffinden des Lieferanten in einem Rechnungsbild verwendet und wirkt sich stark auf die Erkennung aus.
Steuernummer-Lieferant / Natoinal VATID | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Die einzigartige nationale Kennung des Lieferanten zu Zwecken der Steuerzahlung. Das Feld wird für das Auffinden des Lieferanten in einem Rechnungsbild verwendet und wirkt sich stark auf die Erkennung aus.
IBAN / IBAN | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Die internationale Bankkontonummer des Lieferanten. Das Feld wird für das Auffinden des Lieferanten in einem Rechnungsbild verwendet und wirkt sich stark auf die Erkennung aus. Mit diesem Feld werden die erfassten Bankdetails des Lieferanten anhand der Datenbank überprüft.
Bankkonto / BankAccount | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Das Bankkonto des Lieferanten. Das Feld wird nicht für die Erkennung des Lieferanten in einem Rechnungsbild verwendet. Mit diesem Feld werden die erfassten Bankdetails des Lieferanten anhand der Datenbank überprüft.
Bankleitzahl / BankCode | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Das Bankkonto des Lieferanten. Das Feld wird nicht für die Erkennung des Lieferanten in einem Rechnungsbild verwendet. Mit diesem Feld werden die erfassten Bankdetails des Lieferanten anhand der Datenbank überprüft.
Name-Lieferant / Name-Vendor | Text, Normalisierung: Text | Optionales Feld. Der Name des Lieferanten. Das Feld wird für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.
Straße-Lieferant / Street-Vendor | Text, Normalisierung: Text | Optionales Feld. Die Straßenkomponente der Lieferantenadresse. Das Feld wird für die Erkennung des Lieferanten in einem Rechnungsbild verwendet
PLZ-Lieferant / ZIP-Vendor | Text, Normalisierung: Alphanumerischer Code | Optionales Feld. Die Postleitzahlkomponente der Lieferantenadresse. Das Feld wird für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.
Ort-Lieferant / City-Vendor | Text, Normalisierung: Text | Optionales Feld. Die Stadtkomponente der Lieferantenadresse. Das Feld wird für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.
Ländercode / CountryCode Text, Normalisierung: Alphanumerischer Code

Pflichtfeld. Die Landkomponente der Lieferantenadresse. Das Feld wird nicht für die Erkennung des Lieferanten in einem Rechnungsbild verwendet.

Hinweis: Dieses Feld enthält den zweistelligen Code des Landes, wie unter ISO 3166-1 Alpha-2 festgelegt. Dieses Feld darf nicht leer sein, da das Land des Lieferanten die Regeln für die Zuordnung der Dokumentdefinitionen für Rechnungen und die Überprüfung der erfassten Felder bestimmt.


Spalten im Datensatz PurchaseOrders

Dieser Datensatz enthält Informationen über Bestellungen. Mit ihnen können Bestellnummern und Beträge von Rechnungen erfasst und Rechnungen den jeweiligen Bestellungen zugeordnet werden.

Name | Typ | Beschreibung
Bestellnummer / PONumber | Text, ohne Normalisierung | Pflichtfeld. Bestellnummer. Für die Erkennung der Bestellnummer in Bildern. Einzigartiger Schlüssel des Eintrags in einem Datensatz.
Nettobetrag / Netto | Doppelt, ohne Normalisierung | Pflichtfeld. Die Bestellsumme. Für die Erkennung der Bestellsumme in Bildern.
ID-Lieferanten / VendorId | Text, ohne Normalisierung | Optionales Feld. Die ID des Lieferanten entsprechend der Bestellnummer. Sind die Werte dieser Spalte festgelegt und wurde der Lieferant erkannt, wird die Bestellliste gefiltert und das Programm arbeitet nur mit Bestellungen aus dem Datensatz dieses Lieferanten.


Spalten im Datensatz PurchaseOrdersItems

Dieser Datensatz enthält Informationen über die Artikel der Bestellung und ist über den Schlüssel PONumber mit dem Datensatz PurchaseOrders verbunden. Dieser Datensatz wird verwendet, um die Artikel der Bestellung für die Überprüfung durch einen Operator anzuzeigen.

Name | Typ | Beschreibung
Bestellnummer / PONumber | Text, ohne Normalisierung | Pflichtfeld. Bestellnummer. Einzigartiger Schlüssel eines Eintrags in einem Datensatz. Verbindet die Artikel mit den entsprechenden Einträgen im Datensatz PurchaseOrders.
Artikel / Article | Text, ohne Normalisierung | Optionales Feld. Artikelcode.
Beschreibung / Description | Text, ohne Normalisierung | Optionales Feld. Artikelbeschreibung.
Menge / Quantity | Ganzzahl, ohne Normalisierung | Optionales Feld. Artikelmenge
Artikelpreis / UnitPrice | Doppelt, ohne Normalisierung | Optionales Feld. Artikelpreis.
Rabatt / Discount | Doppelt, ohne Normalisierung | Optionales Feld. Artikelrabatt.
Steuer / TaxSum | Doppelt, ohne Normalisierung | Optionales Feld. Steuerbetrag des Artikels.
Nettogesamtpreis / TotalPriceNetto | Doppelt, ohne Normalisierung | Optionales Feld. Preis des Artikels vor Steuern.
Bruttogesamtpreis / TotalPriceBrutto | Doppelt, ohne Normalisierung | Optionales Feld. Artikelpreis.


Verfügbare Regeln

Regeln für die Rechnungsvalidierung

Jede vorkonfigurierte Regel kann vom Benutzer in den Eigenschaften der Dokumentdefinition deaktiviert werden. Es können außerdem benutzerdefinierte Regeln erstellt werden.

Feldgruppen | Regel | Beschreibung | Auswirkung auf Rechnungsstatus | Standardmäßig aktiviert
Geschäftsbereich / Business Unit | Informationen über Geschäftseinheiten müssen der Datenbank hinzugefügt werden (Information about business units must be added to database) | Diese Regel überprüft, ob eine neue Geschäftseinheit, die in dem Bild gefunden und im Datensatz der GE gespeichert wurde, der Datenbank hinzugefügt wurde. | Abgelehnt | Ja
 | Die Adresse der Geschäftseinheit ist erforderlich (Business Unit's address is required) | Diese Regel überprüft und stellt sicher, dass das Feld GE\Straße nicht leer ist. | Abgelehnt | Ja
 | Der Name der Geschäftseinheit ist erforderlich (Business Unit's name is required) | Diese Regel überprüft und stellt sicher, dass das Feld GE\Name nicht leer ist. | Abgelehnt | Ja
 | Die USt-IdNr der Geschäftseinheit ist erforderlich (Business Unit's VATID is required) | Diese Regel überprüft und stellt sicher, dass das Feld GE\USt-IdNr nicht leer ist. * Die Regel wird für Rechnungen aus allen unterstützten Ländern mit Ausnahme der Schweiz angewendet. | Abgelehnt | Ja
 | Die Geschäftseinheit muss in der Datenbank vorhanden sein (Business Unit must be found in database) | Diese Regel überprüft, ob die im Rechnungsbild gefundene Geschäftseinheit im Datensatz der GE vorhanden ist. | Abgelehnt | Ja
 | Das Land der Geschäftseinheit ist erforderlich (Business Unit's Country is required) | Diese Regel überprüft und stellt sicher, dass das Feld GE\Land nicht leer ist. | Abgelehnt | Nein
 | Steuersätze bei nationalen Rechnungen prüfen (Check tax rates on national invoices) | Überprüft, ob die angewendeten Steuersätze für Rechnungen aus dem eigenen Land korrekt sind. Die möglichen Steuersätze und deren Gültigkeitszeiträume sind für die jeweiligen Länder bekannt. | Abgelehnt | Ja
 | Steuersatzfeld bei internationalen Rechnungen prüfen (Check tax rate field on international invoices) | Überprüft, ob die angewendeten Steuersätze für internationale Rechnungen korrekt sind. Die möglichen Steuersätze und deren Gültigkeitszeiträume sind für die jeweiligen Länder bekannt. | Abgelehnt | Ja
Lieferant / Vendor | Adresse des Lieferanten ist erforderlich (Vendor address is required) | Diese Regel überprüft und stellt sicher, dass das Feld Lieferant\Straße nicht leer ist. | Abgelehnt | Ja
 | Name des Lieferanten ist erforderlich (Vendor name is required) | Diese Regel überprüft und stellt sicher, dass das Feld Lieferant\Name nicht leer ist. | Abgelehnt | Ja
 | USt-IdNr des Lieferanten ist erforderlich (Vendor VATID is required) | Diese Regel überprüft und stellt sicher, dass das Feld Lieferant\USt-IdNr nicht leer ist. * Die Regel wird für Rechnungen aus allen unterstützten Ländern mit Ausnahme der Schweiz angewendet. | Abgelehnt | Ja
 | Lieferant muss in der Datenbank vorhanden sein (Vendor must be found in database) | Diese Regel überprüft, ob der im Rechnungsbild gefundene Lieferant auch im Lieferantendatensatz vorhanden ist. | Ausnahme | Ja
 | Lieferantendetails müssen der Datenbank hinzugefügt werden (Vendor details must be added to database) | Diese Regel überprüft, ob ein neuer Lieferant, der in dem Bild gefunden und im Lieferantendatensatz gespeichert wurde, der Datenbank hinzugefügt wurde. | Ausnahme | Ja
 | Bankdaten des Lieferanten sind erforderlich (Vendor's bank details are required) | Diese Regel überprüft, ob IBAN, Bankleitzahl und Bankkonto den Werten im Lieferantendatensatz entsprechen. | Kein Einfluss | Ja
 | Bankdaten des Lieferanten anhand der Datenbank überprüfen (Check vendor's bank details against database) | Überprüft, ob die im Rechnungsbild erkannten Bankdaten des Lieferanten mit den Bankdaten im Datensatz Lieferant übereinstimmen. | Kein Einfluss | Ja
Daten der Rechnungskopfzeile / Invoice Header Data | Rechnungsnummer ist erforderlich (Invoice number is required) | Diese Regel überprüft und stellt sicher, dass das Feld Rechnungsnummer nicht leer ist. * Die Regel wird für Rechnungen aus allen unterstützten Ländern mit Ausnahme der Schweiz angewendet. | Abgelehnt | Ja
 | Rechnungsdatum ist erforderlich (Invoice date is required) | Diese Regel überprüft und stellt sicher, dass das Feld Rechnungsdatum nicht leer ist. | Abgelehnt | Ja
 | Lieferdatum ist erforderlich (Delivery date is required) | Diese Regel überprüft und stellt sicher, dass das Feld Lieferdatum nicht leer ist. Die Regel hat keine Auswirkung, wenn der Lieferdatum-Indikator gesetzt ist. | Abgelehnt | Nein
 | Lieferdatum darf nicht vor Rechnungsdatum liegen (Delivery date must not be earlier than Invoice date) | Die folgende Prüfung wird durchgeführt: Lieferdatum liegt innerhalb der Zeitspanne Lieferdatum <= Rechnungsdatum. | Ausnahme | Nein
 | Lieferdatum darf nicht älter als ein Jahr sein (Delivery date must not be earlier than a year ago) | Die folgende Prüfung wird durchgeführt: Lieferdatum liegt innerhalb der Zeitspanne Heute - 360 Tage <= Lieferdatum | Ausnahme | Nein
Beträge / Amounts | Gesamtsumme ist ein Pflichtfeld (Total is a required field) | Diese Regel überprüft und stellt sicher, dass das Feld Gesamtsumme nicht leer ist. | Abgelehnt | Ja
 | Währung ist erforderlich (Currency is required) | Diese Regel überprüft und stellt sicher, dass das Feld Währung nicht leer ist. | Abgelehnt | Ja
 | Überprüfung der MWST-Sätze bei nationaler Rechnung (VAT rates check for national invoice) | Diese Regel überprüft und stellt sicher, dass die im Rechnungsbild gefundenen MWST-Sätze mit den MWST-Sätzen des Landes übereinstimmen (entsprechend der festgelegten Landeseinstellung). | Abgelehnt | Ja
 | Feld Steuersatz darf nicht leer sein (Tax Rate field must not be empty) | Wurde Nettobetrag oder Steuerbetrag nicht eingegeben, darf der entsprechende Steuersatz nicht leer sein. | Abgelehnt | Ja
 | Wird ein Steuersatz erkannt, ist ein Vorsteuerbetrag erforderlich (If tax rate is detected, pre-tax amount is required) | Diese Regel überprüft für jeden gefundenen Steuersatz, ob der jeweilige Nettobetrag und Steuerbetrag nicht leer sind und stellt außerdem sicher, dass Steuerbetrag = (Steuersatz/100) x Nettobetrag. * Die Regel wird nur für Rechnungen aus Deutschland angewandt. | Abgelehnt | Ja
 | Wird ein Steuersatz gefunden, ist ein Steuerbetrag erforderlich (If tax rate is found, tax amount is required) | Diese Regel überprüft für jeden gefundenen Steuersatz, ob der entsprechende Steuerbetrag nicht leer ist | Abgelehnt | Ja
 | Gesamtsteuer ist erforderlich (Total Tax is required) | Diese Regel überprüft und stellt sicher, dass das Feld Beträge\Steuergesamtsumme nicht leer ist. * Die Regel wird für Rechnungen aus allen unterstützten Ländern mit Ausnahme von Deutschland angewendet. | Abgelehnt | Ja
 | Steuerfeld überprüfen (Check Tax field) | Diese Regel überprüft für jeden gefundenen Steuersatz, ob der entsprechende Steuerbetrag für jeweiligen Nettobetrag und Steuersatz korrekt ist (dass die arithmetische Gleichung Steuerbetrag = Nettobetrag * Steuersatz richtig ist). | Ausnahme | Ja
 | Gesamtsteuerfeld überprüfen (Check Total Tax field) | Die folgende Prüfung wird durchgeführt: Steuergesamtbetrag = Steuerbetrag 1 + Steuerbetrag 2. * Die Regel wird für Rechnungen aus allen unterstützten Ländern mit Ausnahme von Deutschland angewendet. | Ausnahme | Ja
 | Nettogesamtsummenfeld prüfen (Check Net Total field) | Die folgende Prüfung wird durchgeführt: Nettogesamtbetrag = Nettobetrag 0 + Nettobetrag 1 + Nettobetrag 2. Ist das Feld Nettogesamtbetrag leer, gibt diese Regel entsprechend den Berechnungen Daten in das Feld ein. | Ausnahme | Ja
 | Gesamtsummenfeld prüfen, wenn Steuergesamtbetrag erforderlich (Check Total field if total tax amount is required) | Diese Regel überprüft, ob die Summe aus gefundenen Nettobeträgen, Steuerbeträgen und Zusatzkosten der Gesamtsumme entspricht. * Die Regel wird für Rechnungen aus allen Ländern mit Ausnahme von Deutschland angewendet. | Ausnahme | Ja
 | Gesamtsummenfeld prüfen, wenn Steuergesamtbetrag optional (Check Total field if total tax amount is optional) | Diese Regel überprüft, ob die Summe aus gefundenen Nettobeträgen, Steuerbeträgen und Zusatzkosten der Gesamtsumme entspricht * Die Regel wird nur für Rechnungen aus Deutschland angewandt. | Ausnahme | Ja
 | Nettogesamtsumme anhand Bestellpositionen überprüfen (Verify net total against order items) | Überprüft die Gesamtsumme der Werte in der Spalte Nettogesamtpreis der Tabelle Artikel anhand des Rechnungsbetrags vor Steuern (Nettogesamtbetrag). | Kein Einfluss | Nein
Bestellung / Purchase Order | Überprüfen anhand Bestelldatenbank (Check against database of orders) | Überprüft die Werte der erkannten Nummer (Auftragsnummer) und Betrag (Netto) des Auftrags anhand des Datensatzes Bestellungen. | Kein Einfluss | Nein
Artikel / Line Items | Betrag prüfen (Check amount ) | Überprüft für jede Rechnungsposition, ob das Folgende wahr ist: Menge * Einheitspreis entspricht Nettogesamtpreis für den Artikel nach Anwendung des Rabatts in Prozent. | Kein Einfluss | Nein
 | Vergleichen mit Bestellpositionen (Check against order items) | Diese Regel überprüft, ob für jede Position einer Rechnung das entsprechende Element im Datensatz Bestellpositionen vorhanden ist. | Kein Einfluss | Nein

Serviceregeln

Diese Regeln haben keinen Einfluss auf den Status eines Dokuments und an die Operatoren werden keine Meldungen ausgegeben. Sie sind für das korrekte Funktionieren der ABBYY FlexiCapture for Invoices-Dokumentdefinition erforderlich

Alle vorkonfigurierten Regeln können vom Benutzer in den Eigenschaften der Dokumentdefinition deaktiviert werden. Es können außerdem benutzerdefinierte Regeln erstellt werden.

Feldgruppen | Regel | Beschreibung | Standardmäßig aktiviert
Daten der Rechnungskopfzeile / Invoice Header Data | Rechnungstyp erkennen (Detect invoice type) | Ist der Rechnungsbetrag negativ oder das Wort "Gutschrift" wird gefunden, wird der Rechnungstyp geändert zu Gutschrift. | Ja
Feld für Lieferdatum ist leer oder ausgefüllt (Delivery Date field is empty or completed) | Diese Regel bestimmt/löscht den Wert des Feldes Lieferdatum-Indikator in Abhängigkeit davon, ob das Feld Lieferdatum ausgefüllt ist oder nicht (ist Lieferdatum leer, wird Lieferdatum-Indikator nicht gesetzt). Die Regel hat keine Auswirkung, wenn der Lieferdatum-Indikator überprüft wurde. | Nein
Beträge / Amounts | Feld für Steuerschuldumkehr ist leer oder ausgefüllt (Reversed Charge field is empty or completed) | Entspricht der einzige gefundene MwSt-Satz dem Wert 0 oder das Wort "Steuerschuldumkehr" wird gefunden, wird der Wert des Feldes Steuerschuldumkehr auf "Ja" gesetzt. | Ja
Nationale Währung erkennen (Detect national currency) | Mit dieser Regel werden in das Feld Währung automatisch Daten in Rechnungen aus Frankreich, Großbritannien und Spanien eingegeben (wenn es leer ist). | Ja
Feld Zusatzgesamtkosten ausfüllen (Complete Total Additional Cost field) | Berechnet den Gesamtbetrag der Zusatzkosten. | Ja
Feld Steuersatz ausfüllen, wenn leer (Complete Tax Rate field if it is empty) | Berechnet den Wert des Steuersatzes, wenn dieser im Rechnungsbild nicht gefunden wird und unter der Voraussetzung, dass die anderen Steuerfelder gefunden wurden. | Ja
Feld Gesamtsteuer ausfüllen, wenn es optional ist (Complete Total Tax field if it is optional)

Mit diese Regel werden in das Feld Beträge\Steuergesamtbetrag automatisch Daten für Länder eingegeben, bei denen dieses Feld nicht obligatorisch ist.

* Die Regel wird nur für Rechnungen aus Deutschland angewandt.

 Ja
Gesamtsteuer ausfüllen bei nur einem gefundenen Steuersatz (Complete Total Tax if only one tax rate is found) | Mit dieser Regel werden in das Feld Beträge\Steuergesamtbetrag automatisch Daten eingegeben, wenn die Rechnung nur eine Steuer enthält. | Ja
Zusammenfassungsinformationen für Gruppe Beträge abrufen (Get summary information for Amounts group)

Mit dieser Regel werden in das Feld Beträge\Zusammenfassung Daten auf der Basis der folgenden Werte eingegeben:

Netto0, Netto1, Netto2, Steuerbetrag 1, Steuerbetrag 2, Steuersatz 1, Steuersatz 2. Format: Summe (= Netto0 + Netto1 + Netto2 + Steuerbetrag 1 + Steuerbetrag 2); und MwSt-Sätze, die in der Rechnung gefunden werden. Beispiel: 256; 0%

 Ja
Währung aus Rechnungsdaten kopieren bei Zuordnungsfehler Rechnungsposition-Währung (Copy currency from invoice data if Line Items currency is not matched) | Wird die Spalte Währung nicht der Tabelle Rechnungspositionen zugeordnet, wird der Währungswert vom Feld Währung in diese Tabelle kopiert (der Währungswert wird neben dem Feld Gesamtsumme angezeigt). | Nein
Währung von Betrag in Feld <Feldname> trennen (für 11 Felder) / Separate currency from amount in <Field Name> field (for 11 fields) | Diese Regel teilt einen Betrag und eine Währung auf und kopiert die Währung in das Feld Währung, sofern es leer ist. | Ja


Schlüsselwörter

Schlüsselwörter für Lieferant/Geschäftseinheit und Feldgruppen von Rechnungskopfzeilendaten

ABBYY FlexiCapture for Invoices verwendet Schlüsselwörter für die Suche nach Feldern in einem Bild: wird ein Schlüsselwort erkannt, sucht das Programm für ein Feld in dessen Umgebung. Allgemeine Beispiele für Schlüsselwörter enthalten Feldtitel und Bezeichnungen.

Nehmen wir beispielsweise an, eine Rechnung enthält den folgenden Text: Rechnungsdatum: <Wert>. In diesem Fall wäre "Rechnungsdatum" das Schlüsselwort für die Suche nach dem Feld Rechnungsdatum.

Die Schlüsselwörter können mithilfe der Gefundenen Elemente festgelegt werden. Jedes Gefundene Element kann nur einem Feld in der Dokumentdefinition zugeschrieben werden, aber jedes Feld kann mehr als ein Gefundenes Element enthalten, wobei jedes davon ein separates Modell der Beziehung zwischen dem Schlüsselwort und dem Feld in der Rechnung beschreibt.

  • Schlüsselwörter sind speziell für Sprachen und Länder. Wird eine Dokumentdefinition angewendet, nimmt das Programm Schlüsselwörter aus dem Land des Lieferanten, dem Land der Geschäftseinheit und aus den Sprachen dieser Länder.
  • Für die Schlüsselwörter wird eine Normalisierung durchgeführt.
    • Tabulatoren, Leerzeichen, Zeilenumbruchzeichen und Aussprachezeichen werden ignoriert
    • Groß- und Kleinschreibung wird ignoriert (das Programm macht keinen Unterschied zwischen klein- und großgeschriebenen Buchstaben)

      Für Schlüsselwortzwecke ist Steuerpunkt dasselbe wie steuerpunkt.

  • Das Programm erlaubt 2 bis 3 Erkennungsfehler in Schlüsselwörtern (abhängig vom Element).

  • Manchmal erscheint ein Schlüsselwort in mehr als einer Sprache, wie beispielsweise Quantity/Anzahl. Wir empfehlen das Hinzufügen des gesamten Schlüsselwortes (Quantity/Anzahl) zu beiden Sprachen.
Feldgruppe | Gefundene Elemente | Beschreibung | Festgelegt in den Eigenschaften von
Lieferant/Geschäftseinheit | Bankkonto | Schlüsselwörter für das Feld Bankkonto | Land (die Registerkarte Schlüsselwörter)
 | Bankleitzahl | Schlüsselwörter für das Feld Bankleitzahl | Land (die Registerkarte Schlüsselwörter)
 | IBAN | Schlüsselwörter für das Feld IBAN | Land (die Registerkarte Schlüsselwörter)
 | Nationale Steuer-ID | Schlüsselwörter für die nationale Steuer-ID | Land (die Registerkarte Schlüsselwörter)
 | USt-IdNr | Schlüsselwörter für das Feld USt-IdNr | Land (die Registerkarte Schlüsselwörter)
Daten der Rechnungskopfzeile | PurchaserNameLabels | Die verschiedenen möglichen Namen des Feldes PurchaserName in der Sprache. | Sprache
 | PurchaserNameFalseFieldPrefixes | Verschiedene mögliche Namen von Feldern, die eventuell falsch als das Feld PurchaserName identifiziert werden. Wir empfehlen deren Festlegung nur, wenn Ihnen bestimmte Fälle auffallen. | Sprache
 | CreditNoteKeywords | Wörter in der Sprache, die für die Identifizierung der Sprache als Gutschrift verwendet werden. | Sprache
 | InvoiceIdentifiers | Wörter, die darauf hinweisen, dass es sich bei dem Dokument um eine Rechnung handelt. | Sprache
 | OrderNumberLabels | Die möglichen Namen des Feldes OrderNumber in der Sprache. | Sprache
 | InvoiceNumberExcludePreffixes | Wörter, die vor Zahlen platziert werden und evtl. weggelassen werden können, wie z. B. "Nr." | Sprache
 | InvoiceNumberExcludeSuffixes | Wörter, die nach Zahlen platziert werden und evtl. weggelassen werden können. Wir empfehlen deren Festlegung nur, wenn Ihnen spezielle Beispiele auffallen. | Sprache
 | InvoiceNumberWithDateLabels | Text, der einer Rechnungsnummer voranstehen kann, wenn der Name in der gleichen Zeile steht wie das Datum und diese durch einen Schrägstrich oder ein anderes Zeichen getrennt sind. Beispiele: Rechnungsnummer / Datum 23061336 / 07.07.2013 Rechnungsnr./-datum 23061336 / 07.07.2013 | Sprache
 | InvoiceNumberHighConfidenceLabels InvoiceNumberLowConfidenceLabels | Die Liste InvoiceNumberHighConfidenceLabels enthält Textfragmente, die das Feld eindeutig identifizieren, wie z. B. "Rechnungsnummer" und "Dokumentnummer": Eher mehrdeutige Textfragmente, wie z. B. "Nr." oder "Re.", werden unter InvoiceNumberLowConfidenceLabels aufgelistet. | Sprache
 | DueDateLabels | Die möglichen Namen des Feldes DueDate in der Sprache. | Sprache
 | DeliveryDateLabels | Die möglichen Namen des Feldes DeliveryDate in der Sprache. | Sprache
 | InvoiceDateLabelsNearCity | Alle Textfragmente, die für das Trennen von Stadtname und Datum verwendet werden, wenn sie sich in der gleichen Zeile befinden, wie z. B. ein Komma. | Sprache
 | InvoiceDateLabelsNearInvoiceNumber | Alle Textfragmente, die für das Trennen von Rechnungsnummer und Datum verwendet werden, wenn sich beide in der gleichen Zeile befinden, wie z. B. ein Komma. | Sprache
 | InvoiceDateHighConfidenceLabels InvoiceDateLowConfidenceLabels | Die Liste InvoiceDateHighConfidenceLabels enthält Textfragmente, die das Feld eindeutig identifizieren, wie z. B. "Rechnungsdatum" und "Dokumentdatum": Eher mehrdeutige Textfragmente, wie z. B. "Steuerdatum" und "Steuerpunkt", werden unter InvoiceDateLowConfidenceLabels aufgelistet. | Sprache

Schlüsselwörter für die Feldergruppen "Beträge"

ABBYY FlexiCapture kann bestimmen, ob ein Wort Teil einer Wortkombination ist. Fügen Sie beispielsweise die Schlüsselwörter Gesamt und Netto gesamt hinzu und das Bild enthält Netto gesamt, wird es identifiziert als Netto gesamt und nicht Gesamt.

  • Das Programm erlaubt bis zu 3 Erkennungsfehler in Schlüsselwörtern.
  • Diese Einschränkung kann zu Fehlern führen. Das Programm kann beispielsweise die Wörter Brutto und Netto verwechseln. Um diese Fehler zu vermeiden, fügen Sie bei Hinzufügen eines Werts (wie z. B. Netto gesamt) zu AmountTotalNettoLabels den entsprechenden Wert hinzu, (wie z. B. Brutto gesamt) zu AmountTotalLabels.
Feldgruppe | Gefundene Elemente | Beschreibung | Festgelegt in den Eigenschaften von
Beträge | AmountTotalLabels | Das Schlüsselwort links oder oberhalb des Feldes "Gesamtsumme" | Sprache, Land (die Registerkarte Schlüsselwörter)
 | AmountTotalNettoLabels | Das Schlüsselwort links oder oberhalb des Feldes "Nettogesamtsumme" | Sprache
 | AmountTotalTaxLabels | Das Schlüsselwort links oder oberhalb des Feldes "Steuergesamtsumme" | Sprache, Land (die Registerkarte Schlüsselwörter)
 | ReversedChargeKeywords | Wörter, die als Hinweis für die "Steuerschuldumkehr" in der Sprache verwendet werden können | Sprache
 | Steuersätze | Schlüsselwörter für Steuersätze | Land (die Registerkarte Steuersätze)
 | Währung | Schlüsselwörter oder Zeichen, die auf Währungen hinweisen. | Land (die Registerkarte Currency)

Hinweis: Es ist im Allgemeinen keine gute Idee, das gleiche Wort zu Nettogesamtsumme und Gesamtsumme hinzuzufügen.

Schlüsselwörter für die Feldergruppen "Artikel"

Schlüsselwörter dienen der Suche nach Tabellentiteln, die Rechnungsfelder enthalten, und für die Suche nach bestimmten Spalten in Tabellen. Wörter, die in Spaltentiteln, die Gefundenen Elemente entsprechen, regelmäßig verwendet werden, funktionieren hierbei am besten.
Wird das gleiche Wort in Titeln verschiedener Spalten gefunden, empfehlen wir das Hinzufügen zu den Gefundenen Elementen dieser Spalten. In diesem Fall kann das Programm die Spalten erkennen, unabhängig von den Inhalten der Zellen dieser Spalten.

Kann das Programm die Spalten jetzt immer noch nicht unterscheiden oder wird das Wort regelmäßig in einer Spalte und eher seltener in anderen Spalten verwendet, belassen Sie das Wort in den Gefundenen Elementen der Spalte, wo es am häufigsten verwendet wird und entfernen es aus den Gefundenen Elementen der anderen Spalten.

  • Das Programm erlaubt bis zu 3 Erkennungsfehler in Schlüsselwörtern.
  • Die Schlüsselwörter dürfen nur eine Zeile lang sein.
  • Die Inhalte einer Spalte müssen sich direkt unterhalb der Spaltenüberschrift befinden.
  • Schlüsselwörter in Bildern müssen von Leerzeichen, Kommas oder Punkten umgeben sein. So ist daher Quantity/Anzahl ein Schlüsselwort und Quantity / Anzahl sind zwei.

    Kann ein Schlüsselwort auf verschiedene Weise geschrieben werden, fügen Sie alle möglichen Schreibweisen hinzu, wie z. B. Quantity/Anzahl, Quantity und Anzahl.

Feldgruppe | Gefundene Elemente | Beschreibung | Festgelegt in den Eigenschaften von
Artikel | LineItemsArticleNumberLabels | Schlüsselwort für die Spalte ArticleNumber | Sprache
 | LineItemsDeliveryDateLabels | Schlüsselwort für die Spalte DeliveryDate | Sprache
 | LineItemsDescriptionLabels | Schlüsselwort für die Spalte Beschreibung | Sprache
 | LineItemsDiscountPercentageLabels | Schlüsselwort für die Spalte Rabatt in Prozent | Sprache
 | LineItemsMaterialNumberLabels | Schlüsselwort für die Spalte Materialnummer | Sprache
 | LineItemsOrderDateLabels | Schlüsselwort für die Spalte Bestelldatum | Sprache
 | LineItemsOrderNumberLabels | Schlüsselwort für die Spalte Bestellnummer | Sprache
 | LineItemsPositionLabels | Schlüsselwort für die Spalte Position | Sprache
 | LineItemsQuantityLabels | Schlüsselwort für die Spalte Menge | Sprache
 | LineItemsTotalPriceBruttoLabels | Schlüsselwort für die Spalte Bruttogesamtpreis | Sprache
 | LineItemsTotalPriceNettoLabels | Schlüsselwort für die Spalte Nettogesamtpreis | Sprache
 | LineItemsUnitsOfMeasureLabels | Schlüsselwort für die Spalte Maßeinheit | Sprache
 | LineItemsUnitPriceLabels | Schlüsselwort für die Spalte Artikelpreis | Sprache
 | LineItemsVATCodeLabels | Schlüsselwort für die Spalte MwSt.-Code | Sprache
 | LineItemsVATPercentageLabels | Schlüsselwort für die Spalte MwSt. in Prozent | Sprache

Hinweis: Die Qualität der Schlüsselworterkennung ist von der Qualität der Volltexterkennung abhängig

Der Vorerkennungsmodus kann in der Registerkarte FlexiLayout im Dialogfeld Eigenschaften der Dokumentdefinition geändert werden. Je höher die Qualität der Vorerkennung, desto mehr Zeit wird benötigt.


Erweiterte reguläre Ausdrücke

Formate werden mithilfe erweiterter regulärer Ausdrücke festgelegt.

Erweiterte reguläre Ausdrücke beinhalten die folgenden Ergänzungen:

  1. Spezialklammern [% und %]. Die Zeichen innerhalb der Klammern werden durch gängige OCR-Fehler ergänzt.

Beispiel: [%S%] erlaubt S, $ und 5.

  2. Spezielle Wörter innerhalb von [%...%] für allgemeine Zeichensätze und OCR-Fehler:
    1. LETTERS — Lateinische Großbuchstaben und Zeichen, die im Allgemeinen als lateinische Großbuchstaben erkannt werden
    2. DIGITS — Ziffern und Zeichen, die im Allgemeinen als Ziffern erkannt werden
    3. LETERSANDDIGITS — Lateinische Großbuchstaben, Ziffern und Zeichen die im Allgemeinen als lateinische Großbuchstaben und Ziffern erkannt werden

Beispiel: [%DIGITS%]{9} legt neun aufeinanderfolgende Ziffern oder allgemeine OCR-Fehler für Ziffern fest, wie z. B. "OI234Sb7B9".


Glossar

ABBYY FlexiCapture for Invoices

Eine Komponente von ABBYY FlexiCapture, die Daten aus Rechnungen erfasst.

Zusätzliches FlexiLayout

Ein zusätzliches FlexiLayout, wird zusammen mit dem Haupt-FlexiLayout für die Erfassung zusätzlicher Dokumentfelder verwendet.

Geschäftseinheit

Eine fakturierte juristische Person.

Gutschrift

Eine vom Lieferanten ausgestellte "Negativrechnung" mit dem Ziel der Korrektur von Betrag oder Menge einer zuvor ausgestellten Rechnung. Eine Gutschrift wird beispielsweise im Falle ungelieferter, unvollständiger, beschädigter oder falscher Waren ausgestellt oder wenn einem Käufer zu viel berechnet wurde. Ein Lieferant kann das Geld dem Käufer entweder zurückzahlen oder bei zukünftigen Zahlungen anrechnen.

Datenbanksuche

Vergleich erfasster Daten mit den Datenbankeinträgen.

Dokumentvariante

Rechnungen mit Feldern an ungewöhnlichen Positionen, die der gleichen Klasse angehören, z. B. Rechnungen vom gleichen Lieferanten.

FlexiLayout-Variante

Ein FlexiLayout für eine Dokumentvariante, die entweder speziell für diese Dokumentvariante entwickelt oder mit dieser Dokumentvariante trainiert wurde. Wird in Verbindung mit einem allgemeinen FlexiLayout verwendet.

Allgemeines FlexiLayout

Das Standard-FlexiLayout, das für die Verarbeitung aller Dokumente eines vorgegebenen Typs verwendet wird. Für Dokumentvarianten können FlexiLayout-Varianten verwendet werden.

Rechnung

Ein Dokument, dass die gelieferten Waren, deren Menge, Preis, Eigenschaften (wie z. B. Farbe, Gewicht usw.), Versandbedingungen und Details der beteiligten Parteien enthält.

Funktionen für Rechnungsbearbeitung

Zusätzliche Funktionen zur Rechnungsverarbeitung, wie z. B. die Erfassung von Zusatzfeldern und von für solche Felder durchgeführten Datenüberprüfungen.

Rechnungsposition

Eine Zeile in einer Rechnung, die ein Produkt oder eine Dienstleistung beschreibt und deren Preis und Menge angibt.

Schlüsselwörter

Wörter, die mit bestimmten Rechnungsfeldern in Bezug stehen, und die für das Erkennen von Rechnungsfeldern verwendet werden können. Verschiedene Sprachen und Länder haben evtl. unterschiedliche Schlüsselwörter.

Gefundene Elemente

Ein FlexiLayout-Element für die Lokalisierung von Rechnungsfeldern.

Haupt-FlexiLayout

Ein FlexiLayout für die Erfassung der Hauptfelder eines Dokuments.

Normalisierung

Die Konvertierung verschieden formatierter, aber im Wesentlichen identischer Werte in ein "normales" Format für nachfolgende Vergleiche. Beispielsweise kann das Programm so eingerichtet werden, Leerzeichen und Groß-/Kleinschreibung zu ignorieren, sodass "Rechnungsnummer" und "rechnungsnummer" als ein und derselbe Wert behandelt werden.

Bestellung

Ein offizielles Angebot für den Kauf von Waren oder Dienstleistungen, das die Art der Waren und Dienstleistungen, deren Menge und den vereinbarten Preis enthält.

Kontrolle von Rechnungspositionen

Eine Funktion in ABBYY FlexiCapture for Invoices, die die Operatoren bei der Überprüfung von Rechnungen unterstützt, indem diese mit ihren entsprechenden Bestellungen verglichen werden.

Status

Der einer Rechnung zugewiesene Status nach Anwendung der Validierungsregeln für die erfassten Daten. Eine der drei folgenden Statusarten kann zugewiesen werden

  • Gültig — Bedeutet, dass die Rechnung den Anforderungen entspricht und zu einem Datenverarbeitungssystem exportiert werden kann.
  • Abgelehnt — Bedeutet, dass die Rechnung nicht den Anforderungen entspricht.
  • Ausnahme — Bedeutet, dass die Rechnung den Anforderungen entspricht, aber aus einem bestimmten Grund nicht als "Gültig" behandelt werden kann. Ausnahmen erfordern eine Spezialbehandlung durch ein Datenverarbeitungssystem.

Trainingsstapel

Ein Dokumentstapel für das Trainieren und Testen einer Dokumentdefinition für eine bestimmte Dokumentvariante. Das Training einer Dokumentdefinition mit einem Trainingsstapel erstellt eine FlexiLayout-Variante. Für weitere Informationen siehe auch Dokumentstapel, Dokumentvariante, FlexiLayout-Variante.

Training [eine Dokumentdefinition]

Eine Funktion in ABBYY FlexiCapture for Invoices, die es den Benutzern ermöglicht, dem Programm die Erfassung von Daten aus bestimmten Rechnungsarten beizubringen. Das Training verbessert die Qualität der Datenerfassung und kann entweder bei der Einrichtung des Programms oder während der Verarbeitung von Rechnungen durchgeführt werden.

Lieferant

Eine juristische oder natürliche Person, die Waren oder Dienstleistungen verkauft. Lieferanten stellen Rechnungen für ihre Waren und Dienstleistungen aus. Daten aus Rechnungen können mithilfe von ABBYY FlexiCapture for Invoices erfasst werden.


Anhang

Verwenden von Skripten in FlexiCapture
Erstellen von maschinenlesbaren Formularen
Tastaturbefehle
Vergleich von Regeln in FormReader 6.5 und FlexiCapture
Unterstützte Erkennungssprachen
Schriftarten für die korrekte Darstellung von Zeichen
Unterstützte Texttypen
Unterstützte Barcodetypen
Unterstützte Grafikformate
Exportdateiformate
Alphabet in regulären Ausdrücken
Patente
Technologien anderer Unternehmen


Verwenden von Skripten in ABBYY FlexiCapture

In diesem Abschnitt wird beschrieben, wie Sie in ABBYY FlexiCapture Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen und die Schnittstelle der Verarbeitungsstation verwenden.

Unterstützte Skriptsprachen

ABBYY FlexiCapture unterstützt die folgenden Skriptsprachen: C#.Net, VisualBasic.Net, JScript.Net, JScript®, JScript.Compact und VBScript.

Besonderheiten von in .Net-Sprachen geschriebenen Skripten

Besonderheiten bei der Verwendung

In VBScript muss bei der Weitergabe eines NULL-Wertes (die Alternative von "this" in JScript) das Schlüsselwort "Me" verwendet werden, während mit .Net-Sprachen der NULL-Wert als gewöhnlicher Parameter weitergegeben wird.

Für jedes Skript sind die Zugriffsberechtigungen für alle Parameter im Voraus bekannt. Die Zugriffsberechtigungen bestimmen die Teilmenge an Methoden, die über Skripte zur Verfügung stehen. Bei der Adressierung der Objektmethoden werden die Berechtigungen für zurückgegebene Objekte immer vom Quellobjekt vererbt (Ausnahmen dieser Regel werden in Kommentaren der entsprechenden Methoden beschrieben).

Hinweis: Skriptobjekte können aufgrund des unbestimmten Objektverhaltens nach Abschluss des Skripts nicht verwendet werden.

Hinweis: Für das Debugging von Skripten, die mit dem ABBYY FlexiCapture Skripteditor geschrieben wurden, kann die Methode MessageBox verwendet werden.

Benutzerdefinierte Funktionen

Mithilfe des Skripteditors können Benutzer eigene Funktionen und Prozeduren schreiben und diese dann aus den Codes des Skripts aufrufen.

Benutzerdefinierte Funktionen und Prozeduren sollten in das globale Modul geschrieben werden, auf das vom Skripteditor aus zugegriffen werden kann. Wählen Sie dafür aus der Dropdownliste des Skripteditors ein verfügbares globales Modul: Regel für globales Skriptmodul, Globales Skriptmodul exportieren, Events oder NonInteractiveProcessor.

Alle Funktionen innerhalb eines Moduls müssen in derselben Sprache geschrieben sein. Der Kerncode eines Skripts kann in einer anderen Sprache geschrieben sein als in derjenigen, die im entsprechenden globalen Modul verwendet wird.

In den Skriptsprachen JScript®, JScript.Compact und VBScript geschriebene globale Funktionen können von Skripten aufgerufen werden, die auch in einer diese Sprachen geschrieben wurden. Sie können zum Beispiel von dem Code einer Regel aus, die in VBScript geschrieben ist, eine im globalen Modul enthaltene Funktion aufrufen, die in JScript geschrieben ist.

Alle Funktionen aller globalen Module stehen in allen Skripten zur Verfügung, mit Ausnahme der Skripts, die in .Net-Sprachen geschrieben wurden (C#.Net, VisualBasic.Net oder JScript.Net).

Um eine Funktion von dessen globalem Modul aufzurufen, muss ein entsprechender Präfix verwendet werden (Rules, Export, Events oder NonInteractiveProcessor). Beispiel: Die Funktion DoSomething aus dem Modul Regel für globales Skriptmodul muss folgendermaßen aufgerufen werden: Rules.DoSomething ().

Hinweis: Für Skripte in .Net-Sprachen werden die Funktionen globaler Module mit ihrem Namen und ohne Präfixe aufgerufen.

Zeitüberschreitung bei Skriptausführung

Der Standardwert für Zeitüberschreitungen beträgt 30 Sekunden für den Export und 10 Sekunden für andere Skripte.

Zum Ändern des Standardwerts für Zeitüberschreitungen passen Sie den Wert in der Registry an.

HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\DefaultScriptTimeout

Der Wert für Zeitüberschreitungen wird in der Registry in Millisekunden angegeben. Dauert die Ausführung eines Skripts länger als der angegebene Wert für die Zeitüberschreitung, wird das Skript beendet und eine Fehlermeldung "Zeitüberschreitung bei Skriptausführung" zurückgegeben. Handelt es sich bei dem Skript um den Teil eines Imports, einer Erkennung oder eines Exporttasks, wird eine ähnliche Fehlermeldung im Protokoll aufgezeichnet.

Wichtig! Zeitüberschreitung bei Skriptausführung gilt nur für in JScript und VBScript geschriebene Skripte.

Wichtig! Um die Standardwerte für Zeitüberschreitungen von Skripten zu ändern, die unter dem NetworkService ausgeführt werden, müssen Sie den Registryeintrag für das entsprechende Benutzerprofil bearbeiten.

Objektmodell

Das Objektmodell ist kompatibel zu Skripten, die mit älteren Versionen von ABBYY FlexiCapture erstellt wurden.

Weitere Informationen über das Objektmodell


Besonderheiten von in .Net-Sprachen geschriebenen Skripten

Dieser Abschnitt beschreibt Besonderheiten von in .Net-Sprachen geschriebenen Skripten.

  • Skriptparameter, die an andere Skripte mit dem Schlüsselwort "this" übergeben werden, werden an .Net-Skripte als gewöhnliche Parameter weitergegeben. Beispiel: In Regeln, die in .Net-Sprachen geschrieben wurden, wird der Kontext der Regel als ein Parameter mit dem Namen "Context" weitergegeben.

  • FlexiCapture 10 unterstützt Microsoft .Net Framework bis Version 3.5. Daher muss das Projekt mit Microsoft .Net Framework 3.5 oder älter kompiliert werden. Die Version von .Net Framework kann unter den Projekteinstellungen in Visual Studio angegeben werden.

  • Es kann außerdem eine externe Assembly hinzugefügt werden, die in Skripten und globalen Modulen verwendet werden kann. Es können sowohl Standard- als auch kompilierte Benutzerassemblys verwendet werden. Alle Klassen der hinzugefügten Assemblys sind dann in Skripten und globalen Modulen verfügbar. Einzelheiten finden Sie unter Externe Assemblys.

  • Nachdem das Skript kompiliert wurde, wird ein kompilierter Skriptinhalt am selben Speicherort abgelegt, an dem auch das Skript definiert wurde. Daher kann ein .Net-Skript mehr Platz benötigen als andere Skripte.

  • Alle FlexiCapture-Objekte werden als COM-Objekte definiert, daher kann beim häufigen Adressieren der Objektfelder die Funktion der .Net-Skripte aufgrund der verwalteten-nicht verwalteten Übergänge verlangsamt sein.

  • Objekte in FlexiCapture unterstützen kein Multithreading.

  • Für das Debugging von .Net-Skripten wird die Methode System.Diagnostics.Debugger.Break verwendet.
  • Außerdem benötigen Sie für das Debugging von .Net-Skripten eine *.pdb-Datei mit Debugging-Informationen. Diese Datei kann sehr groß sein und wir raten deshalb davon ab, sie gemeinsam mit Ihren Skripts im Projekt zu speichern. Beim Debugging eines .Net-Skripts müssen Sie jedoch angeben, dass das Skript mit bestimmten Debugging-Informationen kompiliert werden soll.
    Wenn Sie Microsoft Visual Studio 2010 verwenden, können Sie Prozess anhängen bei dem der .Net-Code ausgeführt wird.
  • ControllerInterop interfaces werden im Assembly ControllerInterop.dll gespeichert und gehören zum Namensraum ABBYY.FlexiCapture.
    Die Assemblydatei ControllerInterop.dll befindet sich im Stammverzeichnis des Programms.
  • ShellInterop interfaces werden im Assembly ShellInterop.dll gespeichert und gehören zum Namensraum ABBYY.FlexiCapture.ClientUI.
    Die Assemblydatei ShellInterop.dll befindet sich im Stammverzeichnis des Programms.
  • .Net-Skripte können unter ihren eigenen Namen als Klassen von den Namensräumen ABBYY.FlexiCapture und ABBYY.FlexiCapture.ClientUI aus auf alle ABBYY FlexiCapture-Klassen zugreifen. Beispiel:

    ABBYY.FlexiCapture.IDocument document = Batch.Documents[i];>

    ABBYY.FlexiCapture.ClientUI.IToolbars toolbars = TaskWindow.MainWindow.Toolbars;

  • Die Using-Direktiven können zusammen mit den Kommentaren und leeren Zeichenfolgen in den Beginn des Skriptinhalts geschrieben werden. Es wird die gleiche Syntax wie in der Programmiersprache verwendet (using für C#.Net, Import für JScript.Net und Imports für VisualBasic.Net). Beispiel:

    using System.Drawing;

    Image img = Image.FromFile( @"D:\2.png" );

    FCTools.ShowMessage( img.VerticalResolution.ToString(), false );

    Hinweis: Die Anwendung von Using-Direktiven auf diese Art ist eine Funktion der FlexiCapture-Skripte. Entsprechend dem Standard von C#.Net können nur Using-Statements und keine Using-Direktiven in den Codetext geschrieben werden. Using- Statements im Codetext werden als Using-Direktiven behandelt und als Ergebnis tritt während der Kompilierung ein Syntaxfehler auf.

    using ABBYY.FlexiCapture;

    using ABBYY.FlexiCapture.ClientUI;

  • Innerhalb von .Net-Skripten werden die Funktionen von allen globalen Modulen aus direkt ohne die Verwendung des Namens des globalen Moduls aufgerufen.
    Hinweis: Die in Globale Regelskriptmodul und in Globales Exportskriptmodul definierten Klassen müssen unterschiedliche Namen haben. Sonst tritt bei der Erstellung einer Instanz der Klasse im Regelcode ein Fehler auf.
  • Wenn der Wert eines optionalen Parameters der Funktion nicht angegeben werden soll (für Funktionen mit optionalen Parametern), müssen Sie stattdessen System.null oder System.Type.Missing übermitteln.

Hinweis: Für Skripte, die nicht-interaktiv ausgeführt werden (d.h. vom Prozess FlexiEx.exe anstatt von FlexiCapture.exe), wird die Schaltfläche Debug für den Prozess FlexiEx.exe im Fenster "Überprüfe auf Lösung" standardmäßig (für Skripte, die einen Haltepunkt enthalten) nicht angezeigt . Damit die Schaltfläche angezeigt wird, klicken Sie auf das Symbol Action Center (Wartungscenter) in Ihrer Taskleiste und wählen Change Action Center settings > Problem reporting settings > Never check for solutions (Wartungscentereinstellungen ändern > Einstellungen für Problemberichterstattung > Nie nach Lösungen suchen).


Externe Assemblys

In Skripten und globalen Modulen können externe Assemblys verwendet werden. Es können sowohl Standard- als auch kompilierte Benutzerassemblys verwendet werden.

Hinzufügen externer Assemblys

Eine Assembly kann über die Registerkarte .Net-Referenzen der Stapeltyp-Eigenschaften, Projekteigenschaften oder über die Eigenschaften der Dokumentdefinition. Alle Klassen der hinzugefügten Assemblys sind dann in Skripten und globalen Modulen verfügbar.

Assemblys, die in den Eigenschaften des Stapeltyps und in den Eigenschaften der Dokumentdefinition hinzugefügt wurden, stehen für einen bestimmten Stapeltyp oder eine bestimmte Dokumentdefinition zur Verfügung. Die den Projekteigenschaften hinzugefügten Assemblys sind freigegeben und für alle Stapeltypen und Dokumentdefinitionen eines gegebenen Projekts verfügbar. Wenn Sie dieselbe Assembly für verschiedene Stapeltypen und Dokumentdefinitionen benötigen, können Sie eine freigegebene Assembly nutzen. Muss eine freigegebene Assembly aktualisiert werden, brauchen Sie sie nur in den Projekteigenschaften aktualisieren.
Um eine Assembly zu den Projekteigenschaften hinzuzufügen, gehen Sie folgendermaßen vor:

  1. Klicken Sie unter .Net-Referenzen der Projekteigenschaften auf Hinzufügen…
  2. Im daraufhin geöffneten Dialogfeld Zusammenstellung hinzufügenwählen Sie den Typ: Standardname für Assembly oder Angehängte Datei.

  3. Je nach ausgewähltem Typ wählen Sie entweder den Standardnamen der Assembly oder suchen Sie nach der Assemblydatei.

Eine freigegebene Assembly wird automatisch zu neu erstellten Stapeltypen hinzugefügt. Um eine freigegebene Assembly zu Dokumentdefinitionen und vorhandenen Stapeltypen hinzuzufügen, gehen Sie wie folgt vor:

  1. Klicken Sie unter .Net-Referenzen der Eigenschaften des Stapeltyps oder der Dokumentdefinition auf Hinzufügen…
  2. Im daraufhin angezeigten Dialogfeld Zusammenstellung hinzufügen wählen Sie Freigegebene Zusammenstellung.
  3. Wählen Sie aus der Liste Referenz den Namen der Assembly aus.

    4. Hinweis: Eine freigegebene Assembly mit einem ähnlichen Namen wie der einer vorhandenen Standard-Assembly kann nicht hinzugefügt werden.

Nachfolgend sehen Sie einen Beispielcode einer Benutzerassembly, die einen Namensraum, eine Klasse und eine Methode dieser Klasse enthält:

namespace TestNameSpace

{

public class Test

{

public void Show(string text)

{

// will show text by standard FlexiCapture means – static method void ShowMessage(string text, bool IsError) from static class FCTools ABBYY.FlexiCapture.FCTools.ShowMessage(text, false);

}

}

}

Sollen Klassen und Methoden einer hinzugefügten Assembly über Eventsteuerungsskripte zugänglich sein, muss sie auf der Registerkarte .Net-Referenzen der Stapeltyp-Eigenschaften (für einen bestimmten Stapeltyp) oder Projekteigenschaften (für den Stapeltyp Unbekannt) hinzugefügt werden.

Für die folgenden Skripte werden externe Assemblys auf der Registerkarte .Net-Referenzen der Eigenschaften der Dokumentdefinition hinzugefügt:

  • Skriptregel
  • Autokorrekturskript
  • Exportskript
  • Benutzerskript
  • Skript für Dokumentzusammenstellung
  • Benutzerdefiniertes Erkennungsskript

Das Skript, das die Klassen und Methoden aus der externen Assembly nutzt, muss den folgenden Code enthalten:

TestNameSpace.Test test = new TestNameSpace.Test(); // creates an object of Test class

test.Show(“hello world”); // calls void Show() method from Test class

Debugging externer Assemblys

Beim Debugging externer Assemblys sind sowohl die Assemblydatei als auch eine .pdb-Datei mit symbolischen Informationen erforderlich. Nur Assemblys mit geladenen .pdb-Dateien können debugged werden. Da die pdb-Dateien eher groß sind, sollten das Laden von symbolischen Informationen im Arbeitsprojekt deaktiviert werden.

Registrierungsschlüssel, die das Laden von symbolischen Informationen steuern

Sie können die folgenden Registrierungsschlüssel verwenden (in Controller\ScriptSupport), um zu steuern, ob die .pdb-Dateien geladen werden sollen:

  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\ [LoadSymbolsFromOriginalPath] - gibt an, ob die .pdb-Dateien aus den Originalordnern der Assemblydateien geladen werden sollen (legen Sie den Schlüsselwert auf "True" fest, um .pdb-Dateien zu laden);
  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\ [PDBSearchLocations] = <Pfad zum Ordner mit PDB-Dateien> - bestimmt die Suchpfade für .pdb-Dateien (Pfade müssen separat und durch ein Semikolon getrennt aufgelistet werden; das Suchergebnis ist eine .pdb-Datei mit symbolischen Informationen, deren Name mit dem Assemblynamen übereinstimmt.

Diese Schlüssel werden nicht standardmäßig in der Registrierung erstellt. Der Administrator kann diese Schlüssel gegebenenfalls zur Registry des Betriebssystems auf dem Rechner des Benutzers hinzufügen.

Damit die Änderungen in der Registry übernommen werden, müssen Sie das Programm neu starten.

Für das Debugging einer Assembly muss die Verbindung zum verwalteten Code verwendet werden.


Objektmodell

Genaue Angaben über das verwendete Objektmodell sind nachfolgend beschrieben.

Arbeiten mit Sammlungen

Alle Sammlungen im Objektmodell unterstützen die folgenden Methoden:

Name | Typ | Zugriff | Beschreibung
Count | int | Schreibgeschützt | Anzahl der Objekte in der Sammlung
Item( index : int ) | ItemInterface | Schreibgeschützt | Ruft ein Objekt der Sammlung mit dem angegebenen Index ab. Die Zählung beginnt mit "0".

Hinweis: Anstatt die Methode Item zu verwenden, können Sie Objekte der Sammlung auch ansprechen, indem Sie abhängig von der ausgewählten Sprache runde Klammern oder eckige Klammern verwenden. In den Sprachen JScript, VBScript und Visual Basic.Net werden runde Klammern verwendet. In C#.Net können nur eckige Klammern verwendet werden. In JScript.Net können sowohl runde als auch eckige Klammern verwendet werden.

Beispiel: Items( 1 ).Text = "Hallo" oder Items[ 1 ].Text = "Hallo".

Alle Sammlungen können in "for each" und ähnlichen Konstruktionen verwendet werden.

Arbeiten mit sich wiederholenden Feldern und Tabellen

Alle Dokumentfelder, mit Ausnahme von Tabellen, können sich wiederholen.

In der Dokumentstruktur werden sich wiederholende Felder durch ein spezielles Prototypfeld repräsentiert, das eine nichtleere Items-Sammlung enthält.

Ein Prototypfeld hat weder untergeordnete Elemente noch einen Wert. Es wird nur für die Speicherung der Gruppe von Felditerationen verwendet. Untergeordnete Felder und/oder Feldwerte können nur Attribute der Feldinstanzen sein, die über die Methode Items des Objektes IField verfügbar sind.

Tabellen enthalten immer die Sammlung Rows (Rows ist das Synonym für Items). Die Sammlung Rows enthält nur die Zeilen der Tabelle, auf deren Zellen über die Methode Children der Zeilen zugegriffen werden kann.

Zusammensetzen von Pfaden zu Feldern

Die Methoden Field, HasField und IndexedItemValue des Objekts IDocument verwenden Pfade zu den Feldern auf dem Formular als ihre Parameter. Der formale Weg zur Darstellung des Pfades über die BNF (Backus-Naur-Form) lautet wie folgt:

<Path> ::= <Path_component> | <Path> "\" <Path_component>

<Path_component> ::= <Field_name> | <Field_name> "["<Field_iteration_number>"]"

Wobei Field_name die Namen der Dokumentfelder angibt, wie sie in der Dokumentdefinition angegeben wurden und Field_iteration_number die Iterationsnummer des sich wiederholenden Feldes ist (die Zeilennummer für Tabellen), beginnend mit "0".

Der Pfad kann vollständig oder relativ sein. Der vollständige Pfad beginnt dem Namen des Dokumentbereichs, während relative Pfade mit dem Namen des untergeordneten Objekts in der Gruppe beginnen.

Beispiel: Für die dritte Zeile der Spalte "Total" in der Tabelle "Table", die sich im Bereich "Section" befindet, müsste folgendes angegeben werden:

"Section\Table[2]\Total"

Ein solcher vollständiger Name kann über die Methode FullName des Objekts IField zusammengestellt werden.


Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen

In diesem Abschnitt wird beschrieben, wie Sie in ABBYY FlexiCapture mithilfe von Skripten benutzerdefinierte Regeln schreiben, Exporte ausführen oder Event-Handler erstellen.

Skripttypen
Objekte
Beispielskripte


Skripttypen

Mithilfe von ABBYY FlexiCapture können Sie folgende Skripttypen erstellen:

Skriptregel

Autokorrekturskript

Exportskript

Benutzerskript (benutzerdefinierte Aktion)

Skript für Dokumentzusammenstellung

Benutzerdefiniertes Erkennungsskript

Event-Handler

Beispielskripte für die oben genannten Typen finden Sie im Abschnitt Beispielskripte.


Skriptregel

Auf Skripten basierende Regeln ermöglichen Ihnen die Erstellung komplexer, benutzerdefinierter Algorithmen für die Überprüfung und Normalisierung von Dokumenten.

Die Skriptregel wird auf der Registerkarte Regeln der Eigenschaften der Dokumentdefinition konfiguriert.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IRuleContext | Entsprechend den Regeleinstellungen | Der Kontext der Regel

Prozeduren, die in mehr als einer Regel verwendet werden sollen, sollten in das Modul für globale Regeln geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste des Skripteditors die Option Regel für globales Skriptmodul. Sie können auch über den Dokumentdefinitionseditor auf das Modul für globale Regeln zugreifen (Dokumentdefinition>Skriptmodule>Regelskript…).

Werden Klassen und Methoden einer externen Assembly im Skript oder im globalen Modul verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

Weitere Informationen finden Sie unter Festlegen einer Regel mithilfe eines Skripts.


Autokorrekturskript

Dieses Skript ermöglicht Ihnen die Konvertierung von Feldwerten und die Ausführung kontextunabhängiger Formatüberprüfungen.

Das Skript wird auf der Registerkarte Daten des Feldeigenschaften-Dialoges konfiguriert.

Parameter

Name | Typ | Zugriff | Beschreibung
Value | IValue | Lesen/Schreiben | Feldwert

Hinweis: Wurde die Option AutoCorrect nur unmittelbar nach Erkennung anwenden ausgewählt, wird eine Formatfehlermeldung, die unter IValue.ErrorMessagefestgelegt wurde, nicht angezeigt, da solche Fehler nicht behoben werden können.

Wenn diese Option nicht ausgewählt wurde, kann das Skript mehrere Male ausgeführt werden, sogar innerhalb einer Phase.

Hinweis: Wird ein Feld in der Datenüberprüfungsstation bestätigt, wird das Skript gestartet. Wird ein Feld in der Web-Datenüberprüfungsstation bestätigt, wird das Skript nicht gestartet.

Werden Klassen und Methoden einer externen Assembly im Skript verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

Siehe auch Verarbeiten eingegebener Werte.


Exportskript

Mit diesem Skript können Sie den Export benutzerdefiniert anpassen.

Die Skriptregel wird auf der Registerkarte Exportziele der Eigenschaften der Dokumentdefinition konfiguriert.

Parameter

Name | Typ | Zugriff | Beschreibung
Document | IDocument | Schreibgeschützt | Das zu exportierende Dokument
Processing | IProcessingCallback | Schreibgeschützt | Das Objekt für die Protokollierung der Informationen über die Verarbeitung

Hinweis: Informationen über die Exportergebnisse müssen in das Feld Document.Action geschrieben werden.

Prozeduren, die in mehr als einem Exportskript verwendet werden sollen, sollten in das Modul für globale Exporte geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste in der Symbolleiste des Skripteditors die Option Globales Skriptmodul exportieren. Auf das Modul für globale Exportskripte können Sie auch vom Dokumentdefinitionseditor aus zugreifen (Dokumentdefinition>Skriptmodule>Exportskript…).

Werden Klassen und Methoden einer externen Assembly im Skript oder im globalen Modul verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

Einzelheiten über die Konfiguration eines Exportskripts finden Sie unter Export mithilfe eines Skripts.


Benutzerskript (benutzerdefinierte Aktion)

Ein Benutzerskript ist eine benutzerdefinierte Skriptregel, die vom Benutzer bei der Ansicht eines Felds während der Feldüberprüfung oder im Dokumenteditor ausgelöst wird.

Das Skript wird auf der Registerkarte Benutzerdefinierte Aktion des Feldeigenschaften-Dialoges konfiguriert.

Parameter

Name | Type | Zugriff | Beschreibung
Context | IRuleContext | Entsprechend den Regeleinstellungen | Der Kontext der Regel

Werden Klassen und Methoden einer externen Assembly im Skript verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

Siehe auch Benutzerskript.


Skript für Dokumentzusammenstellung

Mit diesem Skript kann bestimmt werden, ob die in einem Array an den Benutzer übergebenen Dokumente in einem Dokument zusammengeführt werden können.

Dafür werden für das Ergebnisdokument Zusammenstellungsfehler generiert. Die Bedingung für eine erfolgreiche Zusammenstellung lautet wie folgt: zwei Dokumente werden in eins zusammengeführt, wenn das Ergebnisdokument nicht mehr Zusammenstellungsfehler enthält als jedes der Quelldokumente.

Das Skript wird auf der Registerkarte Zusammenstellung der Eigenschaften der Dokumentdefinition konfiguriert. Um das Fenster Skripteditor zu öffnen, klicken Sie auf die Schaltfläche Zusammenstellungsskript bearbeiten… unter der Option Benutzerdefinierte Zusammenstellungsregeln verwenden.

Dieses Skript wird entweder automatisch nach der Erkennung ausgeführt oder es kann manuell gestartet werden, um die Zusammenstellung zu aktualisieren (wählen Sie dafür den Befehl Extras > Zusammenstellung aktualisieren).
Im ersten Fall enthält das Skript eine Reihe der Zusammenstellungsfehler, die während der Standardüberprüfung generiert wurden.

Parameter

Name | Typ | Zugriff | Beschreibung
AssemblingErrors | IAssemblingErrors | Vollständige Kontrolle | Resultierende Zusammenstellungsfehler
Documents | IDocuments | Schreibgeschützt | Eine Gruppe von Dokumenten, deren Seiten kombiniert wurden

Hinweis: Für eine bessere Optimierung des Zusammenstellungsvorgangs wird empfohlen, die internen Felder der Dokumente nicht zu adressieren. Beim Adressieren interner Felder wird das gesamte Dokument geladen, was eine Verlangsamung des Zusammenstellungsvorgangs zur Folge haben kann. Müssen die Dokumentfelder adressiert werden, wird empfohlen, die Indexfelder zu verwenden (soweit möglich).

Hinweis: Der Parameter AssemblingErrors des Skripts kann verschiedene Zusammenstellungsfehler enthalten, je nachdem, wie dieser Parameter erhalten wird:

  1. AssemblingErrors kann als einer der Eingabeparameter an das Skript übergeben werden. In diesem Fall enthält es den Fehler der aktuellen Überprüfung.
  2. Einer der Eingabeparameter des Skripts ist eine Sammlung von Dokumenten, für die das Zusammenstellungsskript gestartet wird. Jedes Dokument enthält seine eigenen Zusammenstellungsfehler, die auf die folgende Art und Weise abgerufen werden können: document.AssemblingErrors. In diesem Fall enthält der Parameter AssemblingErrors die Fehler der letzten Überprüfung, die für das gegebene Dokument ausgeführt wurde.

Prozeduren, die in mehr als einer Regel verwendet werden sollen, sollten in das Modul für globale Regeln geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste des Skripteditors die Option Regel für globales Skriptmodul. Sie können auch über den Dokumentdefinitionseditor auf das Modul für globale Regeln zugreifen (Dokumentdefinition>Skriptmodule>Regelskript…).

Werden Klassen und Methoden einer externen Assembly im Skript oder im globalen Modul verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

Einzelheiten finden Sie auch unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente.


Benutzerdefiniertes Erkennungsskript

Mithilfe dieses Skripts können Sie einen benutzerdefinierten Erkennungs- (oder Initialisierungs-)algorithmus für Felder mit Bereichen definieren.

Das benutzerdefinierte Erkennungsskript wird auf der Registerkarte Erkennung des Feldeigenschaften-Dialoges konfiguriert.

Das Skript wird gestartet, sobald ein Feldwert aus den Ergebnissen des Recognizers initialisiert wird. Der erkannte Bildbereich wird als Eingabeparameter an das Skript übergeben. Das Dokumentlayout ist in diesem Moment nicht initialisiert, daher ist der Zugriff auf die Dokumentfelder gesperrt (der Zugriff auf die Registrierung und andere Parameter ist jedoch erlaubt).

Mit dem Skript können Sie bestimmen, welche Symbole kritisch sind und überprüft werden müssen (Eigenschaften IsSuspicious und NeedVerification).

Parameter

Name | Typ | Zugriff | Beschreibung
FieldRegion | IFieldRegion | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. (Gilt auch für alle übergeordneten Daten). | Der zu erkennende Bereich
Result IValue / ICheckmarkValue / ICheckmarkGroupValue Komplette Steuerung. Der Zugriff auf das Flag CharacterParams.NeedVerification wird verweigert.
Das Flag CharacterParams.IsSuspicious ist mit Lese-/Schreibberechtigungen verfügbar. 		Der resultierende erkannte Wert. Je nach Feldtyp können die erhaltenen Parameter von einem des folgenden Typs sein:
  • IValue - für Textfelder
  • ICheckmarkValue - für Auswahlfelder
  • ICheckmarkGroupValue - für Gruppen von Auswahlfeldern

Werden Klassen und Methoden einer externen Assembly im Skript verwendet, muss zuerst die Assemblydatei auf der Registerkarte .Net-Referenzen in den Dokumentdefinitionseigenschaften angehängt werden.

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.

Weitere Informationen finden Sie unter Erkennungsoptionen für Textfelder.


Event-Handler

Mit FlexiCapture können Sie Handler für Ereignisse (Events) erstellen, die Stapel, Dokumente und Felder betreffen.

Event-Handler werden in Stapeltypen und in Dokumentdefinitionen gespeichert. Sie finden die Einstellungen auf der Registerkarte Event-Handler im Dialogfeld Eigenschaften von:

  • Stapeltypen (für bestimmte Stapeltypen).
  • Projekte (für alle Stapeltypen des Projekts außer denjenigen, für die Event-Handler in den Stapeltypeigenschaften festgelegt wurden).
  • Dokumentdefinitionen (für Dokumente des aktuellen Typs).

Stapel-Events

Nach Stapelerstellung
Vor dem Löschen des Stapels
Vor der Änderung des Stapelparameters
Nach dem Hinzufügen der Seite
Vor dem Löschen der Seite
Nach der Erstellung des Dokuments
Vor dem Löschen des Dokuments
Vor dem Verschieben der Seiten
Nach dem Öffnen des Stapels
Vor dem Schließen des Stapels
Stapelintegritätsprüfung

Dokument-Events für Stapeltypen

Diese Event-Handler werden in den Eigenschaften eines Stapels oder in den Stapeltypeigenschaften festgelegt.

Vor der Änderung des Dokumentparameters
Nach der Änderung des Dokumentstatus
Nach erfolgtem Export
Vor der Zuordnung

Dokument-Event für den aktuellen Stapeltyp

Diese Event-Handler werden in den Eigenschaften der Dokumentdefinition festgelegt.

Vor der Änderung des Dokumentparameters
Nach der Änderung des Dokumentstatus
Nach Überprüfung der Dokumentregeln

In den Eigenschaften der Dokumentdefinition können auch die Event-Handler für Felder eingerichtet werden (siehe unten).

Feld-Events

Feldüberprüfungsanforderung

Hinweis: Wird derselbe Event-Handler für Stapeltypen und für den aktuellen Dokumenttyp eingerichtet, wird der Event-Handler für das Dokument zuerst ausgeführt, gefolgt vom Event-Handler für Stapeltypen.

Collapsed Prozesse in globalen Modulen speichern

Wir empfehlen, Prozesse, die Sie in mehreren Event-Handlern nutzen möchten, zu einem globalen Modul hinzuzufügen. Wählen Sie dazu Events aus der Dropdownliste auf der Symbolleiste des Skripteditors.

Hinweis: Im Dokumentdefinitionseditor stehen keine globalen Module für Event-Handler zur Verfügung.

Collapsed Hinzufügen externer Assemblys

Verwendet ein Skript oder ein globales Modul Methoden aus einer externen Assembly, können Sie diese externe Assembly auf der Registerkarte .Net-Referenzen des Dialogfelds Eigenschaften eines Objekts (eines Stapeltyps, eines Projekts oder einer Dokumentdefinition) hinzufügen.


Stapel erstellt

Worum geht es

Der Handler dieses Events wird verwendet, wenn Sie Veränderungen am Stapel vornehmen müssen, wie z. B. die Speicherung von Daten der Registrierungsparameter des Stapels.

Wann wird es gestartet

Das Skript wird gestartet, nachdem ein Stapel dem Projekt hinzugefügt wurde.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Schreibgeschützt. Dokument und interne* Felder der Seite sind verfügbar. | Neu hinzugefügter Stapel

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Stapel gelöscht

Worum geht es

Der Handler dieses Events wird verwendet, wenn Sie Daten mit Bezug zum Stapel löschen möchten.

Wann wird es gestartet

Das Skript wird vor dem Löschen des Stapels gestartet.

Hinweis: Durch das Löschen eines Stapels wird nicht das Ereignis des Löschens von Stapeldokumenten und Seiten gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Zu löschender Stapel

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Stapelparameteränderung

Worum geht es

Der Handler dieses Events kann für die Formatierung einiger Stapeleigenschaften verwendet werden.

Eigenschaften

  • Stapeltyp (Name des Stapeltyps)

  • Stapelname

  • Stapelbeschreibung

  • Wert des Registrierungsparameters

  • Stapelpriorität (in Form einer Zeichenfolge). Eine Liste der zulässigen Werte finden Sie in der Beschreibung des Objekts TProcessingPriority.

Wann wird es gestartet

Das Skript wird vor der Änderung einer Stapeleigenschaft gestartet.

Hinweis: Dieses Skript erlaubt nicht die Angabe eines neuen Werts für den Stapeltyp.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Der Stapel, dessen Eigenschaft geändert wird
PropertyModification | IPropertyModificationInfo | Vollständige Kontrolle | Speichert die Informationen der veränderten Eigenschaft. Erlaubt das Ersetzen des festgelegten Werts.

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > Änderung der Stapelstruktur (Seite hinzugefügt/Seite gelöscht/Dokument hinzugefügt/Dokument gelöscht)

Änderung der Stapelstruktur (Seite hinzugefügt/Seite gelöscht/Dokument hinzugefügt/Dokument gelöscht)

Worum geht es

Der Handler dieses Events kann verwendet werden, wenn in Abhängigkeit von einem neuen Bild Änderungen am Stapel, am Dokument oder an der Seite vorgenommen werden müssen. Beispiel: Zählen der dem Stapel hinzugefügten Seiten, um das Fehlen von Seiten auszuschließen.

Wann wird es gestartet

Das Skript wird nach dem Hinzufügen der Seiten (oder Dokumente) oder vor dem Löschen der Seiten/Dokumente gestartet.

Hinweis: Durch das Löschen eines Dokuments wird nicht das Event des Löschens von Dokumentseiten gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Interne* Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Zu ändernder Stapel
Document (oder Page) | IDocument (oder IPage) | Externe Felder des geänderten Dokuments (oder der Seite) können geändert werden. Zugriff auf das gelöschte Dokument (oder Seite) und andere Dokumente und Seiten des Stapels besteht nur zum Lesen. | Gelöschtes (oder hinzugefügtes) Element.

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Seiten verschoben

Hinweis: Seiten können auch während der Dokumentzusammenstellung verschoben werden.

Worum geht es

Die Steuerung dieses Events kann verwendet werden, wenn auf der Basis der Quelldokumente Änderungen an dem neuen Dokument durchgeführt werden sollen, wie z. B. die Speicherung zusammengeführter Registrierungsparameter.

Wurde ein Dokument vollständig in ein anderes Dokument eingebettet, werden dessen Seiten im Array Pages hintereinander und in der gleichen Reihenfolge wie auch im Zieldokument angeordnet.

Hinweis: Nach Zusammenführung der Seiten kann sich das Layout des Zieldokuments ändern.

Wann wird es gestartet

Das Skript wird vor der Verschiebung der Seiten von einem Dokument zum anderen gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Interne* Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Der Stapel
InsertionPosition | int | Schreibgeschützt | Die Position im Dokument, wo die Seiten eingefügt werden
Seiten | IPages | Schreibgeschützt | Das zu verschiebende Array an Seiten
TargetDocument | IDocument | Vollständige Kontrolle | Hierhin werden die Zieldokumentseiten verschoben

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Stapel geöffnet/geschlossen

Wann wird es gestartet

Das Skript wird vor dem Öffnen oder Schließen des Stapels gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Stapel | IBatch | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Der Stapel

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Stapelintegritätsprüfung

Worum geht es

Überprüft die Stapelstruktur. Sie können beispielsweise überprüfen, ob der Stapel die erforderlichen Dokumente enthält und ob die auf der Kontrollseite angegebene Anzahl von Dokumenten mit der Anzahl der tatsächlich verarbeiteten Dokumente übereinstimmt.

Wann wird es gestartet

Das Skript wird vor dem Exportieren (falls die entsprechende Option in den Workflow-Einstellungen ausgewählt wurde) oder durch einen expliziten Benutzerbefehl gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
CheckResults | IBatchCheckResults | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Das Objekt, das Zugriff auf den überprüften Stapel bietet. Wird auch zum Anwählen der Überprüfungsergebnisse verwendet.

Hinweis: In diesem Skript sind die folgenden Methoden nicht verfügbar: HasField, Field, SaveAs, ExcludedFromDocumentImage, Page.Rect, Document.Children (für die Adressierung von Dokumentfeldern, muss IndexedItemValue verwendet werden).

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Dokumentparameter geändert

Worum geht es

Der Handler dieses Events kann für die Formatierung einiger Dokumenteigenschaften verwendet werden.

Dokumenteigenschaften

  • Kommentar

  • Wert des Registrierungsparameters

  • ExternalID

  • Dokumentpriorität (angegeben in Form einer Zeichenfolge). Eine Liste der zulässigen Werte finden Sie in der Beschreibung des Objekts TProcessingPriority.

Wann wird es gestartet

Das Skript wird vor der Änderung einer Dokumenteigenschaft gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Dokument | IDocument | Interne* Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Das Dokument
PropertyModification | IPropertyModificationInfo | Vollständige Kontrolle | Speichert die Informationen der geänderten Eigenschaft

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Dokumentstatus geändert

Worum geht es

Der Dokumentstatus kann zu jeder Zeit durch ein Array von Markierungen (Flags) beschrieben werden. Der Event tritt jedes Mal auf, wenn sich der Status ändert. Ein Satz von Flags, der die Änderungen des Dokumentstatus' beschreibt, wird als Eingabeparameter an das Event weitergeleitet.

Flags, die den Dokumentstatus bestimmen

  • Vorverarbeitet
  • Analysiert
  • Erkannt
  • Enthält Fehler
  • Zusammengestellt
  • Überprüft
  • Exportiert
  • Enthält Layout

Wann wird es gestartet

Das Skript wird beim Dokumentexport unter der Voraussetzung gestartet, dass sich der Dokumentstatus seit dem Lesen geändert hat.

Parameter

Name | Typ | Zugriff | Beschreibung
Dokument | IDocument | Vollständige Kontrolle | Das Dokument
ChangedStates | IScriptBinaryAttributes <TStateType> | Schreibgeschützt | Speichert Informationen über die Änderungen des Dokumentstatus


Export abgeschlossen

Die Exportergebnisse werden als Eingabeparameter an dieses Skript übergeben.

Wann wird es gestartet

Das Skript wird gestartet, nachdem der Exporttask abgeschlossen ist. Wurde die Option Ganze Stapel verarbeiten für die Exportphase ausgewählt, enthält der Task alle Dokumente des Stapels. Wurde die Option nicht ausgewählt, kann die Anzahl der Dokumente in dem Task variieren: von einem Dokument bis hin zu allen Dokumenten des Stapels. Das Skript wird unabhängig von den Exportergebnissen gestartet (egal ob erfolgreich oder nicht). Darin liegt der Hauptunterschied dieses Skripts vom Event "Dokumentstatus geändert".

Wurden einige Exportziele ausgelassen (da das Dokument bereits zuvor zu diesen Zielen exportiert wurde), lautet der Wert des Flags Applied für die entsprechenden Exportergebnisse false.

Parameter

Name | Typ | Zugriff | Beschreibung
ExportResults | IDocumentsExportResults | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Exportiert Ergebnisse für alle Dokumente und alle Exportziele
Verarbeitung | IProcesingCallback | Vollständige Kontrolle | Das Objekt für die Protokollierung der Informationen über die Verarbeitung

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Skript, das nach Regelprüfungen ausgeführt wird

Worum geht es

Der Handler dieses Events wird nach Regelprüfungen verwendet.

Parameter

Name | Typ | Zugriff | Description
Document | IDocument | Schreibgeschützt | Repräsentiert das Dokument.


Vor der Zuordnung

Worum geht es

Der Handler dieses Events ermöglicht Ihnen die Kontrolle darüber, welche Bereiche oder Dokumentdefinitionen auf jeder folgenden Seite zugeordnet werden, und bestimmt die Zuordnungsreihenfolge.

Mit diesem Skript können Sie die Zuordnung der Dokumentdefinition beschleunigen, wenn die zuzordnenden Bereiche im Voraus bekannt sind. Beispiel:

  • es ist bekannt, dass nur die erste Seite des Stapels die Dokumentdefinition "Inhalte" enthält;
  • es ist bekant, dass die gegebene Seite zu einem bestimmten Bereichstyp gehört;
  • die Reihenfolge der Bereiche in den Dokumenten ist bekannt.

Das Skript ermöglicht Ihnen die Deaktivierung der Erkennung des Dokuments, nachdem eine Dokumentdefinition zugeordnet wurde. Dafür setzen Sie den Parameter IMatchingInfo.NeedRecognition auf false. Das kann hilfreich sein, wenn die Feldwerte manuell eingegeben werden müssen.

Die Seite kann auch als Anhangseite markiert werden, die keine Erkennung erfordert. Dafür muss eine leere Liste von Bereichen angegeben und der Parameter IMatchingInfo.ForceMatch auf true gesetzt werden.

Wann wird es gestartet

Das Skript wird vor der Zuordnung der Bereiche auf jeder nachfolgenden Seite gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Dokument | IDocument | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Das Dokument, dessen Seiten analysiert werden
Zuordnung | IMatchingInfo | Vollständige Kontrolle | Das Objekt, das einige der Zuordnungsparameter angibt
PageIndex | int | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar.. | Index der Dokumentseite, die analysiert werden soll

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.

Hinweis: Es können auch Dokumentdefinitionen und Bereiche für die Zuordnung festgelegt werden, indem benannte Registrierungsparameter ausgewählt werden. Weitere Informationen finden Sie unter Registrierungsparameter.


Feldüberprüfungsanforderung

Worum geht es

Mit diesem Skript bestimmen Sie die Felder, die nicht an die Kontextüberprüfung übertragen werden. Es kann zur Überprüfung verschiedener Felder während unterschiedlicher Verarbeitungsphasen verwendet werden.

Die Eingabeparameter für das Skript sind ein Feld und ein Dokument.

Wann wird es gestartet

Das Skript wird für alle Felder ausgelöst, bevor sie zur Kontextüberprüfung übertragen werden. Für die Felder, für die die Kontextüberprüfung übersprungen wird, wird das Skript nicht ausgeführt.

Parameter

Name | Typ | Zugriff | Beschreibung
Feld | IField | Schreibgeschützt | Das überprüfte Feld
Dokument | IDocument | Schreibgeschützt | Das das Feld enthaltende Dokument
NeedVerification | IBoxedBoolean | Vollständige Kontrolle | Gibt an, ob das Feld überprüft werden soll. Wurde der Wert auf "false" festgelegt, wird das Feld nicht überprüft.


Objekte

Dieser Abschnitt enthält die Beschreibung der in Skripten verwendeten Objekte, deren Eigenschaften und Methoden

Hinweis: Einige der Methoden erweitern die in der vorherigen Version verfügbare Funktionalität der Methoden. Die alten Methoden wurden jedoch aus Gründen der Abwärtskompatibilität beibehalten.
Die Namen solcher Methoden beginnen mit dem Wort [Obsolete] in eckigen Klammern.

IActionResult
IAssemblingError
IAssemblingErrors
IBatch
IBatchCheckResults
IBoxedBoolean
ICharacterParams
ICharactersParams
ICheckmarkGroupValue
ICheckmarkValue
IDocument
IDocumentDefinitionInfo
IDocumentDefinitionInfoArray
IDocumentExportResults
IDocuments
IDocumentsExportResults
IEditablePictureObject
IExportFieldsToRedact
IExportImageSavingOptions
IField
IFieldRegion
IFieldRegions
IFields
IFlexiCaptureTools
IMatchedSectionInfo
IMatchingInfo
IPage
IPageClassificationResult
IPages
IPictureObject
IPictureObjectsInfo
IPrincipal
IPrincipals
IProcessingCallback
IProject
IProperties
IProperty
IPropertyModificationInfo
IRect
IRects
IRuleContext
IRuleError
IRuleErrors
IScriptBinaryAttributes
IScriptDefinitionContext
ISectionDefinitionInfo
ISectionDefinitionInfoArray
IStageInfo
IUserAttachment
IUserAttachments
IValue
IVARIANTArray
TAssemlingErrorType
TExportFieldType
TExportType
TPageClassificationType
TPrincipalType
TProcessingPriority
TPropertyType
TRuleErrorType
TStateType


IActionResult

Worum geht es

Ein spezielles Objekt, das für die Beschreibung verwendet wird, ob der Export (oder ein Event nach dem Export) eines bestimmten Dokuments erfolgreich war.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Applied bool Schreibgeschützt Gibt an, ob das Dokument während der aktuellen Exportsitzung zum Ziel exportiert wurde. Für den Wert false des Flags:
  • lautet der Wert von Succeeded true, bedeutet das, das Dokument wurde zuvor zum Ziel exportiert;
  • lautet der Wert von Succeeded false, bedeutet das, dass das Dokument für den Export zu diesem Ziel nicht geeignet ist (z. B. aufgrund von Fehlern).
ErrorMessage | string | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Eine Fehlermeldung
Name | string | Schreibgeschützt | Der Name des Exportprofils
Result | string | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Eine formale Beschreibung des Operationsergebnisses. Im Falle eines Exports eine Beschreibung des Pfads, wohin das Dokument exportiert wurde (z. B. ein Pfad zur Datei).
Type | TExportType | Schreibgeschützt | Der Typ des Exportprofils (gilt für das Skript Export abgeschlossen)
Succeeded | bool | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Gibt an, ob die Operation erfolgreich war


IAssemblingError

Worum geht es

Repräsentiert einen Dokumentzusammenstellungsfehler.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Beschreibung | string | Schreibgeschützt | Die Beschreibung
Position | int | Schreibgeschützt | Die Position im Dokument
Typ | TAssemblingErrorType | Schreibgeschützt | Der Typ des Zusammenstellungsfehlers
SectionName | string | Schreibgeschützt | Der Name eines fehlenden Bereichs (im Fall eines Fehlers AET_ObligatoryItemOmitted ). Für Anhangseiten ist der Bereichsname leer.
Weight | string | Schreibgeschützt | Die Gewichtung des Fehlers


IAssemblingErrors

Worum geht es

Eine Sammlung von IAssemblingError-Objekten.

Kann nur im Skript Dokumentzusammenstellung geändert werden.

Methoden

Definition | Beschreibung
AddCustomError( descriotion : string, [optional] weight : int ) | Fügt einen benutzerdefinierten Zusammenstellungsfehler hinzu.
AddRedundantPageError( int position, [optional] description ) | Fügt einen Fehler bezüglich einer Zusatzseite hinzu.
AddSectionOmittedError( int position, sectionName : string, [optional] description ) | Fügt einen Fehler bezüglich eines fehlenden Bereichs hinzu.

Wichtig! Die Methode AddCustomError sollte mit Vorsicht und nur dann verwendet werden, wenn keine andere geeignete Methode zur Verfügung steht. Da die Dokumentzusammenstellung vollständig von der Anzahl der Fehler bestimmt wird, muss die Fehlergewichtung beim Hinzufügen solcher Fehler sorgfältig festgelegt werden. Und die korrekte Einstellung der Gewichtung kann zu Schwierigkeiten führen.

Die Kombination mehrerer Standardfehler in einem CustomError, der eine allgemeine Fehlermeldung ausgibt, wird nicht empfohlen.


IBatch

Worum geht es

Repräsentiert den Stapel.

Methoden

Wichtig! Für die untenstehenden Methoden sind Berechtigungen zum Ändern der Stapelstruktur erforderlich. Diese Methoden können nur über das Skript Stapelverarbeitung aufgerufen werden.

Definition | Beschreibung
CleanRecognitionResults( document : IDocument ) | Löscht die Erkennungsergebnisse des Dokuments.
CreateDocumentFromPage( targetPosition : int, page : IPage ): IDocument | Ruft eine Seite von einem Dokument ab, um daraus ein neues Dokument zu erstellen.
CreatePageFromImage( page : IPictureObject, [optional] target : IDocument, [optional] position : int, [optional] sourceInfo : string ) : IPage

Erstellt eine Seite aus dem Objekt IPictureObject und gibt die erstellte Seite zurück.

Wurde ein Zieldokument angegeben, wird die Seite diesem Dokument hinzugefügt. Um ein aus einer Seite bestehendes Dokument zu erstellen, geben Sie "Null" als ein Zieldokument an.

Wird eine Position angegeben, wird die Seite der angegebenen Position des Dokuments hinzugefügt. Anderenfalls wird bei der angegebenen Position des Stapels ein aus einer Seite bestehendes Dokument hinzugefügt. Die Anfangsposition entspricht dem Wert "0" und das Ende des Dokuments oder Stapels entspricht "-1".

Wird der Parameter "sourceInfo" angegeben, wird das in die Informationen der Seitenquelle geschrieben. Anderenfalls erhält man die Informationen über die Seitenquelle von IPictureObject.
DeleteDocument( document : IDocument ) | Löscht das Dokument.
DeletePage( page : IPage ) | Löscht die Seite.
MoveDocument( source : IDocument, targetPosition : int ) | Verschiebt das Dokument zu einer bestimmten Position im Stapel.
MovePage( source : IDocument, target : IDocument, sourcePageIndex : int, int targetPageIndex : int ) | Verschiebt die Seite mit dem Index "sourcePageIndex" vom Dokument "source" zum Dokument "target" an die Position "targetPageIndex".
[Obsolete] RegistrationProperty( name : string ) : string | Ruft einen Registrierungsparameter nach dem Namen ab. Aus Gründen der Abwärtskompatibilität beibehalten worden.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Attachments | IUserAttachments | Schreibgeschützt | Benutzeranhänge
BatchTypeName | string | Schreibgeschützt | Der Name des Stapeltyps
Comment | string | Lesen/Schreiben | Der Kommentar
CreatedBy | IPrincipal | Schreibgeschützt | Der Autor des neu erstellten Stapels. Für die Einzelplatzversion des ABBYY FlexiCapture, gibt Null zurück.
Documents | IDocuments | Schreibgeschützt | Dokumente, aus denen der Stapel besteht
Id | int | Schreibgeschützt | Die Stapelkennung. Der Parameter ist innerhalb des Stapels einzigartig.
Name | string | Lesen/Schreiben | Der Name des Stapels
Priority | TProcessingPriority | Lesen/Schreiben | Priorität des Stapels
Properties | IProperties | Schreibgeschützt | Benannte Parameter des Stapels
Project | IProject | Schreibgeschützt | Das Projekt, das den Stapel enthält
[Obsolete] RegistrationProperties | IProperties | Lesen/Schreiben | Registrierungsparameter des Stapels. Aus Gründen der Abwärtskompatibilität beibehalten worden.


IBatchCheckResults

Worum geht es

Repräsentiert den Kontext der Überprüfung der Stapelintegrität.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Batch | IBatch | Schreibgeschützt | Der Stapel
CheckSucceeded | bool | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Gibt an, ob die Überprüfung erfolgreich war
ErrorMessage | string | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Die Fehlermeldung


IBoxedBoolean

Worum geht es

Weitergabe boolescher Werte an die Skripte.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Value | bool | Lesen/Schreiben | Der Wert


ICharacterParams

Worum geht es

Speichert Informationen über die Zeicheneigenschaften.

Methoden

Definition | Beschreibung
SetRect( newRect : string, [optional] pageId : int ) | Legt ein neues Rechteck des Zeichens fest. Der Parameter newRect muss in Form der Zeichenfolge "[left, top, right, bottom]" übermittelt werden. Das festgelegte Rechteck muss sich vollständig innerhalb des Bereichs des Feldes befinden, welches das Zeichen enthält. Hinweis: Die Methode ist im Skript autocorrection nicht verfügbar.

Properties

Name | Typ | Zugriff | Beschreibung
Confidence int Schreibgeschützt Zuverlässigkeitsgrad für einen Stapeltyp. Gibt einen Wert von 0 bis 100 zurück.

Wichtig! Für die Verwendung dieser Eigenschaft müssen zusätzliche Daten gespeichert werden, welche die Größe eines Dokument erhöhen und zusätzlichen Speicherplatz erfordern. Standardmäßig werden keine zusätzlichen Daten gespeichert und die Eigenschaft ist deaktiviert. Damit die Eigenschaft ordnungsgemäß funktioniert, setzen Sie den Registrierungsschlüssel [HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller] “ForceSaveConfidenceLevel” = “true”. Wählen Sie anstelle von HKEY_CURRENT_USER die Teilstruktur des Benutzerkontos, das die Dokumente erkennt.
IsSuspicious | bool | Lesen/Schreiben | Gibt an, ob das Zeichen sicher erkannt wurde. Dieses Flag ist nur im Skript custom recognition gültig.
NeedVerification bool Lesen/Schreiben

Bestimmt, ob eine zusätzliche Überprüfung für das Zeichen erforderlich ist. Der Wert dieses Flags bestimmt, ob das Zeichen im Dokumenteditor hervorgehoben wird.

Wurde die Option An Feldüberprüfung senden in den Feldeigenschaften ausgewählt und enthält das Feld Zeichen mit diesem Flag, die auf True gesetzt sind, wird das Feld zur Phase Datenüberprüfung weitergleitet.
Um festzulegen, ob das gesamte Feld (nicht bestimmte Zeiten) eine Überprüfung benötigt, verwenden Sie die Eigenschaft NeedVerification vom Interface IField.
PageId | int | Schreibgeschützt | Identifiziert die Seite, auf der sich das Rechteck des Zeichens befindet. Erforderlich für mehrseitige Felder.
Rect | IRect | Schreibgeschützt | Ein Rechteck, in dem das Zeichen enthalten ist. Wurde das Rechteck nicht festgelegt, wird Null zurückgegeben.
Symbol | string | Lesen/Schreiben | Ein Zeichen (eine Zeichenfolge, bestehend aus einem Zeichen).


ICharactersParams

Worum geht es

Ein Array aus ICharacterParams-Objekten.

Methoden

Definition | Beschreibung
Add( value : Object, [optional] position : int ) | Fügt an der angegebenen Position das Element value in den Text ein. Wurde die Position nicht festgelegt, wird der Wert am Textende eingefügt. Hinweis: Bei dem Parameter value kann es sich um ein Zeichen, eine Zeichenfolge, ein ICharacterParams-Objekt oder ein ICharactersParams-Objekt handeln. Daher können Zeichen oder Text von anderen Feldern mit beibehaltenen Layouts und Markierungen kopiert werden. Sind die Zeichenbereiche größer als die Region des neuen Feldes, werden sie nicht kopiert.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > ICheckmarkGroupValue

ICheckmarkGroupValue

Worum geht es

Eine Sammlung von ICheckmarkValue-Objekten.


ICheckmarkValue

Worum geht es

Repräsentiert den Wert eines Auswahlfelds.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Auswahlfeldname (Feldname in Dokumentdefinition)
Value | bool | Lesen/Schreiben | Wert eines Auswahlfeldes
IsSuspicious | bool | Lesen/Schreiben | Ob der Wert eines Auswahlfeldes eindeutig erkannt wurde. Standardmäßig werden alle Werte von Auswahlfeldern als nicht eindeutig angesehen.
Rect | IRect | Schreibgeschützt | Ein Rechteck des Auswahlfeldes


IDocument

Worum geht es

Repräsentiert das Dokument.

Methoden

Definition | Beschreibung
CheckRules( ) | Überprüft alle Regeln im Dokument. Es sind Schreibrechte für das Dokument erforderlich.
Field( name : string ) : IField Eröffnet Zugriff auf ein Dokumentenfeld durch den vollständigen Pfad zu dem Feld. Es werden Vollständige Pfade verwendet.
Ist ein internes* Feld. Kann nicht in Regeln verwendet werden.
HasField( name : string ) : bool Überprüft, ob ein Feld mit dem angegebenen Pfad vorhanden ist. Es werden Relative Pfade verwendet.
Ist ein internes* Feld. Kann nicht in Regeln verwendet werden.
IndexedItemValue( name : string ) : VARIANT | Ruft den Feldwert anhand des Namens oder des Pfades zu dem Feld ab. Verfügbar von externen Feldern von Dokumenten und Seiten aus. Sowohl ein Feldname als auch der vollständige Pfad zu dem Feld können verwendet werden. Kann nicht in Regeln verwendet werden.
IndexedItemValues( name : string ) : IVARIANTArray | Ruft einen Satz von Indexwerten korrespondierend zu einem Feld in der Dokumentdefinition nach Name oder Pfad des Feldes ab. Wurde ein Feld in den mehrfach vorkommenden Bereichen als Indexfeld markiert, gibt die Methode alle Werte des Feldes aus allen Bereichen zurück. Verfügbar von externen Feldern von Dokumenten und Seiten aus. Sowohl ein Feldname als auch der vollständige Pfad zu dem Feld können verwendet werden. Kann nicht in Regeln verwendet werden.
Property( name : string ) : VARIANT Ruft den Wert einer vorgegebenen Eigenschaft nach ihrem Namen ab. Der zurückgegebene Wert kann die Form einer Zeichenfolge, einer Zahl oder Uhrzeit haben.

Namen der Eigenschaften und zurückgegebene Werte:
  • Exported - wann das Dokument exportiert wurde
  • ExportedBy - wer das Dokument exportiert hat
  • Created - wann das Dokument erstellt wurde
  • CreatedBy - wer das Dokument erstellt hat
  • Recognized - wann das Dokument erkannt wurde
  • RecognizedBy - wer das Dokument erkannt hat
  • Modified - wann das Dokument zuletzt bearbeitet wurde
  • ModifiedBy - wer das Dokument bearbeitet hat
  • TotalSymbolsCount - die Gesamtanzahl der Symbole
  • UncertainSymbolsCount - die Gesamtanzahl nicht eindeutiger Symbole
  • RecognizedSymbolsCount - die Anzahl erkannter Symbole
  • Comment - der Kommentar zum Dokument
  • ProcessingErrors - die Dokumentverarbeitungsfehler
  • ProcessingWarnings - die Warnungen der Dokumentverarbeitung
Repair( [optional] Object reserved ) : IDocument Aktualisiert die ausgewählte Dokumentdefinition auf die neueste Version. Bei einem Update bleiben alle bearbeiteten und überprüften Daten in den Dokumenten erhalten. Die Aktualisierung der Dokumentdefinition kann beispielsweise aufgrund der geänderten Exporteinstellungen erforderlich sein.
Hinweis: Diese Methode ist ausgeblendet, sie wird in Visual Studio nicht angezeigt.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions )

Speichert das Bild eines ein- oder mehrseitigen Dokuments. Wurde in den Speicheroptionen kein Speicherformat angegeben, wird das Bild in einer *.tif-Datei gespeichert. Dies ist ein internes* -Feld.
SaveAsStream( [optional ]options: IExportImageSavingOptions ) : byte[] Speichert das Dokument in einen Speicherstream und gibt es als Byte-Array (COM SafeArray) zurück.

Hinweis: JScript und VBScript unterstützen die Iteration über diesen Array nicht.

Wichtig! Die Methode Property sollte nicht verwechselt werden mit der Sammlung Properties die vom Benutzer angegebene Dokumenteigenschaften enthält.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Action | IActionResult | Schreibgeschützt | Ist nur in Export- und Nach-Exportskripten wirksam.
AssemblingErrors | IAssemblingErrors | Schreibgeschützt | Eine Sammlung von Zusammenstellungsfehlern. Der Zugriff auf die Sammlung erfolgt immer nur lesend.
Attachments | IUserAttachments | Schreibgeschützt | Benutzeranhänge
Batch | IBatch | Schreibgeschützt | Der Stapel. Unabhängig von den Berechtigungen des Skripts für das Dokument ist der Zugriff auf den Stapel nur lesend, und interne* Felder von Dokumenten und Seiten sind nicht verfügbar.
BatchName | string | Schreibgeschützt | Der Stapelname.
Children | IFields | Schreibgeschützt | Untergeordnete Felder (Dokumentbereiche). Anders als bei der Eigenschaft Sections entspricht die Bereichsreihenfolge der Reihenfolge in der Dokumentdefinition. Die mehrfach vorkommenden Bereiche werden als ein Objekt angezeigt und die Instanzen sind über die Methode Items dieses Objekts verfügbar. Ist ein internes* Feld. Kann nicht in Regeln verwendet werden.
Comment | string | Schreibgeschützt | Ein Kommentar des Dokuments.
DefinitionName | string | Schreibgeschützt | Der Name der Dokumentdefinition.
DocumentDefinition | IDocumentDefinitionInfo | Schreibgeschützt | Detaillierte Informationen über die Dokumentdefinition, die dem Dokument zugeordnet ist. Für nicht verarbeitete und nicht erkannte Dokumente gibt die Eigenschaft eine leere Zeichenfolge zurück.
HasErrors | bool | Schreibgeschützt | Bestimmt, ob das Dokument Regel- oder Formatfehler enthält.
HasUnpreparedImages | bool | Schreibgeschützt | Bestimmt, ob das Dokument nicht vorverarbeitete Seiten enthält.
HasWarnings | bool | Schreibgeschützt | Bestimmt, ob das Dokument Regel- oder Formatwarnungen enthält.
MarkedNextStage | IStageInfo | Schreibgeschützt | Gibt das Objekt IStageInfo zurück, d. h. die Verarbeitungsphase des Dokuments. Wurde das Dokument nicht markiert, ist die Eigenschaft IStageInfo.StageName null..
Id | string | Schreibgeschützt | Dokumentkennung (externe ID).
Index | int | Schreibgeschützt | Der Index des Dokuments im Stapel.
IsAnalyzed | bool | Schreibgeschützt | Bestimmt, ob das Dokument analysiert ist. Das Dokument wird als analysiert angesehen, wenn alle Seiten des Dokuments analysiert werden.
IsAssembled | bool | Schreibgeschützt | Bestimmt, ob das Dokument zusammengestellt ist.
IsExcludedFromAutomaticAssembling | bool | Schreibgeschützt | Überprüft, ob das Dokument in die automatische Zusammenstellung eingeschlossen ist.
IsExported | bool | Schreibgeschützt | Bestimmt, ob das Dokument exportiert ist.
IsRecognized | bool | Schreibgeschützt | Bestimmt, ob das Dokument erkannt ist. Das Dokument wird als erkannt angesehen, wenn entweder jede Seite des Dokuments erkannt wurde oder wenn es sich um eine Anhangseite handelt.
IsVerified | bool | Schreibgeschützt | Bestimmt, ob das Dokument überprüft ist.
Pages | IPages | Schreibgeschützt | Dokumentseiten.
Priority | TProcessingPriority | Schreibgeschützt | Eine Priorität des Dokuments.
ProcessingErrors | string | Schreibgeschützt | Verarbeitungsfehler, unterteilt durch Zeilenumbrüche.
ProcessingWarnings | string | Schreibgeschützt | Verarbeitungswarnungen, unterteilt durch Zeilenumbrüche.
ProhibitedUserId | int | Schreibgeschützt | Ein aus dem Dokument erstellter Task steht für den Benutzer mit der vorgegebenen Kennung nicht zur Verfügung. Standardmäßig lautet der Wert "0", was bedeutet, dass der Task für alle Benutzer verfügbar ist.
Properties | IProperties | Schreibgeschützt | Registrierungsparameter des Dokuments.
RecognizedSymbolsCount | int | Schreibgeschützt | Die Anzahl erkannter Symbole.
RuleErrors | IRuleErrors | Schreibgeschützt | Eine Sammlung von Dokumentfehlern (Formatfehler, Regelfehler, Fehler bei der Zusammenführung von Ergebnissen der Doppelüberprüfung). Nur verfügbar für offene Dokumente.
Sections | IFields | Schreibgeschützt | Eine einfache Liste der Dokumentbereiche. Sind mehrfach vorkommende Bereiche vorhanden, enthält die Liste alle Wiederholungen des Bereichs. Die Bereiche in der Liste werden in der gleichen Reihenfolge angeordnet wie die ersten Seiten der Dokumentbereiche. Bereiche ohne Seiten schließen die Liste. Ist ein internes* Feld. Kann nicht in Regeln verwendet werden.
StageInfo | IStageInfo | Schreibgeschützt | Information über die Verarbeitungsphase auf dem Anwendungsserver.
SymbolsForVerificationCount | int | Schreibgeschützt | Die Anzahl der Symbole, die eine Überprüfung benötigen.
TotalSymbolsCount | int | Schreibgeschützt | Die Gesamtanzahl der Symbole.
UncertainSymbolsCount | int | Schreibgeschützt | Die Anzahl nicht eindeutiger Symbole.
[Obsolete]TemplateName | string | Schreibgeschützt | Der Name der Dokumentdefinition. Aus Gründen der Abwärtskompatibilität beibehalten worden.
[Obsolete]RegistrationProperty( name : string ) | string | Schreibgeschützt | Ruft einen Registrierungsparameter nach dem Namen ab. Aus Gründen der Abwärtskompatibilität beibehalten worden.
[Obsolete]RegistrationProperties | IProperties | Schreibgeschützt | Registrierungsparameter des Stapels. Aus Gründen der Abwärtskompatibilität beibehalten worden.

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


IDocumentDefinitionInfo

Worum geht es

Enthält detaillierte Informationen über die Dokumentdefinition, die dem Dokument zugeordnet ist.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Der Name der Dokumentdefinition.
SectionsInDefinition | ISectionDefinitionInfoArray | Schreibgeschützt | Ein Array von Bereichen in der Dokumentdefinition. Gibt nur eingeschlossene Bereiche zurück.
Version | int | Schreibgeschützt | Die Version der Dokumentdefinition.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IDocumentDefinitionInfoArray

IDocumentDefinitionInfoArray

Worum geht es

Eine Sammlung von Objekten des Typs IDocumentDefinitionInfo.


IDocumentExportResults

Beschreibung

Das Objekt repräsentiert eine Reihe von Exportergebnissen eines Dokuments für verschiedene Ziele. Das ist eine Sammlung der IActionResult -Objekte, die Informationen über den Export für bestimmte Ziele enthalten.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Document | IDocument | Schreibgeschützt | Das exportierte Dokument mit den erhaltenen Ergebnissen
ErrorMessage | string | Schreibgeschützt | Die Nachricht, die beschreibt, warum der Export fehlgeschlagen ist.
Succeeded | bool | Schreibgeschützt | Gibt an, ob das Dokument erfolgreich exportiert wurde


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IDocuments

IDocuments

Worum geht es

Eine Sammlung von IDocument-Objekten.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IDocumentsExportResults

IDocumentsExportResults

Worum geht es

Eine Sammlung von IDocumentExportResults-Objekten.

Das Objekt repräsentiert die Exportergebnisse für eine Reihe von Dokumenten.


IEditablePictureObject

Worum geht es

Repräsentiert ein Bild, das in ABBYY FlexiCapture bearbeitet werden kann. Das Objekt ist eine Erweiterung der Schnittstelle IPictureObject.

Methoden

Definition | Beschreibung
ConvertToBW( [optional] threshold : int ) | Konvertiert das Bild in Schwarz-weiß. Sie können den Schwellenwert für die Helligkeit angeben, Werte über diesem Grenzwert werden als Weiß und diejenigen unter diesem Grenzwert als Schwarz angesehen. Der Grenzwert für die Helligkeit kann von 0 bis 255 reichen.
Crop( rect : string ) | Beschneidet das Bild auf das angegebene Rechteck.
CutOut( rect : string ) : IEditablePictureObject | Schneidet ein festgelegtes Rechteck aus dem Bild aus und gibt dieses Rechteck zurück.
Deskew( [optional] byLines : bool, [optional] byBlackSquares : bool, [optional] byText : bool ) | Entzerrt das Bild. Bildverzerrungen können auf Basis gerader Linien, schwarzer Quadrate oder Text korrigiert werden. Standardmäßig ist der Parameter byText auf true festgelegt.
Despeckle( [optional] garbageSize : int ) | Entfernt Störungen aus Schwarz-Weiß-Bildern. Flecken bis zu der angegebenen Größe werden entfernt. Wird der Parameter garbageSize nicht angegeben, wird die Größe automatisch erkannt. Wichtig! Die Methode gilt nur für Schwarz-Weiß-Bilder.
Erase( rectangle : string, [optional] red : int, [optional] green : int, [optional] blue : int ) | Löscht einen Bereich des Bildes. Sie können die Farbe angeben, mit der der Bereich gelöscht wird. Standardmäßig ist die Farbe Schwarz ausgewählt.
FlipHorizontal() | Spiegelt das Bild horizontal.
FlipVertical() | Spiegelt das Bild vertikal.
FreeScale( newWidth : int, newHeight : int, newResolution : int ) | Ändert die Seitengröße entsprechend der neuen Werte.
Invert( [optional] rectString : string ) | Invertiert das Bild. Sie können eine Zeichenfolge mit den Koordinaten des Rechtecks eingeben, das invertiert werden soll.
Rotate( angle : int ) | Dreht das Bild im Uhrzeigersinn anhand eines vorgegebenen Winkels.
Scale( ratio : int ) | Dehnt oder staucht das Bild relativ zur Basisgröße von 100 %. Die Methode gilt nur für Bildpixelgröße. Die physische Größe des Bildes bleibt unverändert.

Hinweis: Der Parameter rect, der an die Methoden CutOut und Crop übergeben wird, ist eine Zeichenfolge der Form «[left, top, right, bottom]». Um diese Zeichenfolge zu erhalten, können Sie entweder die Methode ToString für jedes Objekt des Typs IRect aufrufen oder die Methode FCTools::Rect verwenden.


IExportFieldsToRedact

Worum geht es

Die Liste der Felder, die im resultierenden Bild geschwärzt werden sollen.

Methoden

Definition | Beschreibung
Add( field : IField ) | Fügt der Liste ein Feld hinzu.
Clean() | Löscht die Liste.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
PlainList | string | Schreibgeschützt | Die Liste der Felder, die im resultierenden Bild geschwärzt werden sollen. Felder sollten in einer Zeile und durch Semikolons getrennt aufgelistet werden.


IExportImageSavingOptions

Worum geht es

Beschreibt die Bildspeicheroptionen.

Methoden

Definition Beschreibung
Add( value : Object, [optional] position : int ) Positioniert das Element „Wert“ an einer bestimmten Position im Text. Ist keine Position angegeben, wird das Element am Textende platziert.
Hinweis: Der Parameter „Wert“ kann ein Zeichen, eine Zeichenfolge ein ICharacterParams -Objekt oder ein ICharakterParams-Objekt sein. Auf diese Weise können Sie Zeichen oder Text unter Beibehaltung der Markierung und der Hervorhebung aus anderen Feldern kopieren. Entsprechen die Zeichenbereiche, die Sie zu kopieren versuchen, nicht dem Bereich des neuen Felds, werden sie nicht kopiert.
SetPdfDocumentInfo( type: TPdfDocumentInfoType, value: string ) Die Metadaten der PDF-Datei.

TPdfDocumentInfoType – die Feldtypen im PDF-Dokument.

PDIT_Author = 0 – der Autor des Dokuments.

PDIT_Title = 1 – der Titel des Dokuments

PDIT_Subject = 2 – der Betreff des Dokuments

PDIT_KeyWords = 3 – die Schlüsselwörter des Dokuments

Eigenschaften

Name | Typ | Zugriff | Description
AddProperFileExt | bool | Lesen/Schreiben | Ist der Wert auf "true" gesetzt, wird die Erweiterung entsprechend dem Bildformat bei der Bildspeicherung festgelegt. Standardmäßig ist der Wert auf "false" gesetzt.
ColorType | string | Lesen/Schreiben | Farbschema. Zulässige Werte: "FullColor", "GrayScale", "BlackAndWhite". In den Zeichenfolgen spielt die Groß-/Kleinschreibung keine Rolle.
FieldsToRedact | IExportFieldsToRedact | Lesen/Schreiben | Die Liste der Felder, die im resultierenden Bild geschwärzt werden sollen.
Format | string | Lesen/Schreiben | Bildspeicherformat. Zulässige Ausdrücke: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf" sowie "-s" (für durchsuchbare PDF) und "-a" (für PDF/A) Parameter. In den Zeichenfolgen spielt die Groß-/Kleinschreibung keine Rolle. Parameter beginnen mit "-". Sie können durch Leerzeichen oder Tabulatoren getrennt oder direkt hintereinander angegeben werden. Beispiel: "pdf -s", "pdf-a-s".
ImageCompressionType TImageCompressionType Lesen/Schreiben Legt ein Komprimierungsverfahren für das exportierte Bild fest. Standardmäßig wird das Komprimierungsverfahren automatisch auf der Grundlage des Formats und der Farbe gewählt.

Mögliche Werte:

ICT_Auto = -1. Der Komprimierungstyp wird automatisch gewählt.

IFC_Lzw = 1

IFC_Jpeg = 2

IFC_PackBits = 3

IFC_Png = 4

IFC_Uncompressed = 5

IFC_Zip = 6

IFC_CcittGroup4 = 7

Hinweis: Die Wahl eines nicht kompatiblen Komprimierungsverfahrens hat zur Folge, dass der Task im Ausnahmenordner abgelegt wird.
Quality | int | Lesen/Schreiben | Bildqualität für JPEG-Kompression (in Prozentwerten)
RecognitionLanguages string Lesen/Schreiben

Die Liste der Sprachen kann für die Erkennung der Dokumente verwendet werden, die für das Exportieren in durchsuchbare PDF vorgesehen sind. Sie besteht aus den internen Namen der Sprachen in Englisch, unterteilt durch Semikolons ohne Leerzeichen. Ist die Liste leer, wird die Sprache der Dokumentdefinition verwendet, die für das Dokument angewendet wurde.

Gilt nur für Anhangseiten, da für Seiten mit zugeordneten Bereichen nur erkannte Felder eine Textebene besitzen. Da solche Felder während der Erkennungsphase erkannt werden (nicht während der Exportphase), werden die Erkennungsergebnisse durch die Angabe der Eigenschaft nicht beeinflusst.
Resolution | int | Lesen/Schreiben | Bildauflösung (gemessen in DPI).
ShouldOverwrite | bool | Lesen/Schreiben | Gibt an, ob die vorhandene Datei überschrieben werden kann.
UseMRC bool Lesen/Schreiben Aktiviert die Kompression anhand der Mixed Raster Content (MRC)-Technologie beim Export von PDF in PDF/A. MRC bietet für manche Bilder eine bessere Komprimierung als die im Allgemeinen verwendete JPEG-Methode, wie z. B. für qualitativ hochwertige Bilder mit kontrastreichem Text auf einheitlichem Hintergrund. Verwenden Sie MRC zur Reduzierung der Größe der resultierenden PDF-Datei.
Hinweis: Standardmäßig ist das Flag beim Export in PDF true und beim Export in PDF/A false.


IField

Worum geht es

Ein Dokumentfeld. Der Feldtyp kann über die Eigenschaft Type bestimmt werden. Für Tabellenfelder stehen die Objektmethoden Rows und Cell zur Verfügung.

Methoden

Definition | Beschreibung
Cell( columnName : string, rowNum : int ) : IField | Ruft eine Tabellenzelle nach Spaltenname und Zeilennummer ab. Nur für Tabellen verfügbar. Nicht verfügbar in Skriptregeln.
CheckRules( ) | Überprüft die Regeln für das vorgegebene Feld und dessen untergeordnete Felder. Kann nicht in Regeln verwendet werden.
Field( Path : string) : IField | Suche nach dem untergeordneten Element in Bezug auf das vorgegebene Element. Es werden Relative Pfade verwendet. Nur Synonyme der Feldnamen, wie sie in den Regeleinstellungen definiert wurden, können in Regeln verwendet werden.
HasField( parameter : string) : bool | Überprüft, ob das Feld mit dem angegebenen Pfad vorhanden ist. Es werden Relative Pfade verwendet. Nur Synonyme der Feldnamen, wie sie in den Regeleinstellungen definiert wurden, können in Regeln verwendet werden.
Suggest( VARIANT newSuggest )

Fügt dem Feld eine Aufforderung hinzu.
Hinweis: Das kann in der Form eines Werts oder Zeichenfolge sein. Die hinzugefügten Werte werden mit vier Dezimalstellen geschrieben.

Die Methode field.Suggest( "12.90" ) beispielsweise fügt die Aufforderung in der Form von "12.90" hinzu, während field.Suggest( 12.90 ) die Aufforderung als 12.9000 hinzufügt.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Caption | string | Schreibgeschützt | Der im Formular angezeigte Feldname. Der Wert dieser Eigenschaft kann mit der Eigenschaft Name identisch sein.
Children | IFields | Schreibgeschützt | Untergeordnete Objekte des Feldes (Zellen für Tabellen). Nicht verfügbar in Skriptregeln.
FullName | string | Schreibgeschützt | Ein vollständiger Feldname in Bezug auf das Dokument. Ein einzigartige Kennung des Feldes im Dokument. Kann für die Suche nach Dokumentfeldern über die Methode Field verwendet werden. In den Skriptregeln stimmt der zurückgegebene Wert mit dem Namen überein und ist nicht eindeutig.
HasRuleError bool Lesen/Schreiben Legt fest, ob eine Regelwarnung oder ein Fehler mit dem Feld in Bezug steht.
Hinweis: In den Skriptregeln legt diese Eigenschaft fest, ob das Feld in der Fehlermeldung angezeigt werden soll. Eine Regel enthält eine Sammlung von Feldern, die im Dialogfeld Regeleigenschaften festgelegt werden. Schlägt die Regelüberprüfung fehl, wird eine Fehlermeldung angezeigt (festgelegt in IRuleContext.ErrorMessage) und Links zu den Feldern von der Auflistung werden im Dokumenteditor angezeigt. Durch die Einstellung dieser Eigenschaft auf False wird das Feld von der Linkliste ausgeschlossen, die mit dem Fehler in Verbindung steht.
IsExportable | bool | Schreibgeschützt | SGibt an, ob das Feld für den Export vorgesehen ist (entsprechend den Einstellungen in der Dokumentdefinition).
IsIndexed | bool | Schreibgeschützt | Gibt an, ob das Feld indexierbar ist. Falls ja, steht der Feldwert über die Dokument- und externen Seitenfelder der Dokumentdefinition zur Verfügung.
IsMatched | bool | Schreibgeschützt | Bestimmt, ob das Feld zugeordnet wurde.
IsSuspicious | bool | Schreibgeschützt | Bestimmt, ob der Feldwert eindeutig erkannt wurde.
IsValid | bool | Schreibgeschützt | Bestimmt, ob das Feld keine Formatfehler hat.
IsVerified bool Schreibgeschützt Bestimmt, ob das Feld überprüft wird. Die Eigenschaft kann auch ohne "Schreibberechtigung" für das Feld in den Regeln auf True gesetzt werden. Um die Auswahl des Flags aufzuheben, ist eine "Schreibberechtigung" erforderlich. Lautet der Wert des Flags True, wird das Feld im Dokumenteditor grau angezeigt, als ob es bereits bestätigt wurde. Lautet der Wert des Flags False, wird das Feld weiß angezeigt und muss bestätigt werden. Nachdem das Feld überprüft wurde, wird das Flag auf False festgelegt.
Hinweis: Die Einstellung dieses Flags auf False stellt keine Weiterleitung des Feldes zur Phase Datenüberprüfung bereit. Verwenden Sie dafür die Eigenschaft NeedVerification der Schnittstellen IField oder ICharacterParams.
IsVisible | bool | Schreibgeschützt | Gibt an, ob das Feld im Dokumentlayout wiedergegeben werden soll (entsprechend den Einstellungen in der Dokumentdefinition).
Items | IFields | Schreibgeschützt | Instanzen des Feldes (Zeilen von Tabellenfeldern).
Name | string | Schreibgeschützt | Der Feldname in der Dokumentdefinition.
NeedVerification bool Lesen/Schreiben

Gibt an, ob das Feld selbst (nicht dessen Zeichen) eine Überprüfung benötigt.

Lautet der Wert des Flags True, wird das Feld im Dokumenteditor mit einem roten Hintergrund angezeigt, was bedeutet, dass das Feld eine Überprüfung benötigt. Ist die Option An Feldüberprüfung senden in den Feldeigenschaften ausgewählt, wird das Feld zur Phase Datenüberprüfung weitergeleitet. Nachdem das Feld überprüft wurde, wird das Flag auf False festgelegt.

Um festzulegen, ob bestimmte Zeichen oder das gesamte Feld eine Überprüfung benötigen, verwenden Sie die Eigenschaft

NeedVerification vor Schnittstelle ICharacterParams.
ReadOnly | bool | Schreibgeschützt | Gibt an, ob das Feld "schreibgeschützt" ist (entsprechend den Einstellungen in der Dokumentdefinition). Zeigt bei der Verwendung in Regeln, dass die Regel über eine "Schreibberechtigung" für das Feld verfügt.
ReadOnlyInForm | bool | Lesen/Schreiben | Gibt an, ob das Feld im Formular „schreibgeschützt“ ist (entsprechend den Einstellungen in der Dokumentdefinition).
Regions* | IFieldRegions | Schreibgeschützt | Ein Array von Feldbereichen. Überlaufende Felder können mehrere Regionen besitzen.
Rows | IFields | Schreibgeschützt | Eine Gruppe von Tabellenzeilen. Nicht verfügbar für Felder außerhalb von Tabellen.
Symbols | ICharactersParams | Schreibgeschützt | Detaillierte Informationen über die Symboleigenschaften.
Text | string | Lesen/Schreiben | Die Textdarstellung eines Feldwerts.
Type | TExportFieldType | Schreibgeschützt | Der Feldtyp.
Value | VARIANT | Lesen/Schreiben | Der Feldwert in Form von VARIANT. Die Eigenschaft gibt ein Objekt des Typs Int32 zurück, wenn die Einstellungen des Feldstatus eine ganze Zahl enthalten und der absolute Wert nicht größer als 2147483647 ist. Ist der absolute Feldwert größer als 2147483647, gibt die Eigenschaft ein Objekt des Typs „doppelt“ zurück.
[Obsolete]IsCertain | bool | Lesen/Schreiben | Bestimmt, ob das Feld überprüft wird (ähnlich der Eigenschaft IsVerified). Die Eigenschaft wird aus Gründen der Abwärtskompatibilität beibehalten.
[Obsolete]SuspiciousSymbols* | string | Schreibgeschützt | Eine Zeichenfolge aus "0" und "1", die zeigt, welche Symbole eindeutig erkannt wurden. Die Eigenschaft wird aus Gründen der Abwärtskompatibilität beibehalten.

* - Die Eigenschaft ist nicht verfügbar, wenn die Option Advanced Xml Export in den Lizenzeigenschaften deaktiviert wurde.


IFieldRegion

Worum geht es

Repräsentiert einen Bereich des Dokumentfelds.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Feld | IField | Schreibgeschützt | Das Dokumentfeld, das dem Bereich entspricht. Der Eigenschaftswert kann "0" sein.
IsMatched | bool | Schreibgeschützt | Bestimmt, ob der Bereich zugeordnet wurde
Seite | IPage | Schreibgeschützt | Die Seite, die den Bereich enthält
PageIndex | int | Read/write | Die Nummer der Seite im Dokument, auf der sich der Bereich befindet
Bild | IPictureObject | Schreibgeschützt | Das Bild, das dem Bereich entspricht
Rects | IRects | Schreibgeschützt | Das Array aus Rechtecken, aus denen der Bereich besteht
SurroundingRect | IRect | Schreibgeschützt | Das Rechteck, das den gesamten Bereich beschreibt

Hinweis: Im Skript Benutzerdefinierte Erkennung lautet der Wert der Eigenschaft Field immer "0", da das Feld zum Zeitpunkt der Erkennung nicht vorhanden ist.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IFieldRegions

IFieldRegions

Worum geht es

Eine Sammlung von IFieldRegion-Objekten.


IFields

Worum geht es

Eine Sammlung von IField-Objekten.

Methoden

Definition | Beschreibung
AddNew( insertAt : int ) | Fügt eine neue Instanz eines sich wiederholenden Feldes ein. Der Parameter insertAt gibt die Position der neuen Instanz in der Auflistung an. Die Methode ermöglicht die Erstellung von Zeichenfolgen für einen Tabellenblock ohne Region. Kann nicht in Skriptregeln verwendet werden. Beispielcode: Document.Field( "Page 1\\Address" ).Items.AddNew( 0 );
Delete( what : Object ) | Löscht die Instanz eines Feldes oder einer Tabellenzeile. Der Parameter what kann das zu löschende Element aus der Sammlung oder deren Index sein. Kann nicht in Skriptregeln verwendet werden.


IFlexiCaptureTools

Worum geht es

Die Schnittstelle IFlexiCaptureTools ist in ein globales FCTools-Objekt implementiert, das in Skripten verfügbar ist. Alle Methoden des globalen FCTools-Objekts können als statische Methoden aufgerufen werden, wie z. B.:

FCTools.ShowMessage( “Test” );

Methoden

Definition | Beschreibung
ClassifyPage( page : IPage, [optional] callback : IProcessingCallback, [optional] detectClassesWithoutLayout : bool ) : IPageClassificationResult

Klassifiziert die Seite und gibt im Fall einer erfolgreichen Klassifizierung das Klassifizierungsergebnis zurück. Das Klassifizierungsergebnis kann der Name der Klasse eines Stapeltypenklassifikators oder Null sein.

Diese Methode kann in folgenden Fällen verwendet werden:

  • die Seiten müssen entsprechend der Klassifizierungsergebnisse als durchsuchbare PDF klassifiziert und exportiert werden; die Erkennung und Zuordnung der Dokumentdefinitionen ist nicht erforderlich;
  • Je nach Klassifizierungsergebnis sollten manche Schritte mit dem Dokument vor der Erkennung durchgeführt werden (z. B. korrekte Seitenausrichtung).

Hinweis: Wurde der Parameter detectClassesWithoutLayout nicht angegeben, wird sein Wert auf false festgelegt. Ist der Wert true, basiert die Klassifizierung nur auf Klassen eines Klassifikators, und verfügbare Dokumentdefinitionen werden für die Klassifizierung nicht verwendet.
Hinweis: Sie können entweder die Benutzeroberfläche IProcessingCallback verwenden oder Sie implementieren Ihre eigene Benutzeroberfläche.
IsModuleAllowedByLicense( authorId : string, moduleName : string ) : bool | Überprüft, ob das angegebene Modul durch die Lizenz erlaubt ist.
LoadImage( filePath : string, [optional] pageNumber : int ) : IEditablePictureObject | Lädt ein Bild aus einer Datei. Das geladene Bild kann dann bearbeitet werden. Wurde der Parameter pageNumber nicht festgelegt, wird sein Wert auf "1" gesetzt.
NewImageSavingOptions() : IExportImageSavingOptions | Erstellt ein neues Objekt der Klasse IExportImageSavingOptions.
PictureFromHBitmap( bitmap : HBITMAP, [optional] resolution : int ) : IEditablePictureObject

Erzeugt ein Bild von einem HBITMAP-Objekt mit der angegebenen Auflösung. Wird der Parameter resolution nicht angegeben, wird die Bildauflösung automatisch erkannt. Das generierte Bild kann dann bearbeitet werden.

Beispielcode:
System.Drawing.Bitmap bitmap = System.Drawing.Image.FromHbitmap( handle );
<do something>
IPictureObject FinalPicture = FCTools.PictureFromHBitmap( bitmap.GetHbitmap().ToInt32(), 300 );
Hinweis: Sobald ein HBITMAP in Besitz genommen wurde, ist der Aufruf der Methode CloseHandle nach der Generierung des Bildes nicht erforderlich.
Rect( left : int, right : int, top : int, bottom : int ) : string | Erzeugt eine Zeichenfolge in der Form eines Rechtecks mit angegebenen Koordinaten.
ShowMessage( text : string, [optional] isError : bool )

Zeigt dem Benutzer die Nachricht. Wurde das Flag isError nicht festgelegt, wird sein Wert auf false gesetzt.

Ist das Flag isError auf true gesetzt, handelt es sich bei der Nachricht um einen Fehler, ansonsten um eine Benachrichtigung. Wird das Skript innerhalb eines Handlingsvorgangs ausgeführt, wird die Nachricht in das Verarbeitungsprotokoll geschrieben.

Hinweis: Im Gegensatz zu einem Klassifikator wird die Methode ClassifyPage zur Analyse der Seitenklasse eingesetzt, aber das Klassifizierungsergebnis wird nicht zugeordnet. Enthält ein Klassifikator beispielsweise nicht die Definition Banking_eng, kann die für die Seite angewendete Methode ClassifyPage einen Bereich dieser Dokumentdefinition zurückgeben.

Eigenschaften

Name | Typ | Zugriff | Description
CurrentUserSession | IUserSessionInfo | Schreibgeschützt | Gibt Informationen über die aktuelle Benutzersitzung zurück. Erfolgt das Routing nach der Verarbeitung eines Dokuments auf einer Webstation, ist der aktuelle Benutzer derjenige Benutzer, der das Dokument in dieser Phase verarbeitet hat.
ScriptContext | IScriptDefinitionContext | Schreibgeschützt | Ermöglicht den Zugriff auf das Objekt, in dem das Skript erstellt wurde. Diese Eigenschaft erlaubt Ihnen den Zugriff auf das Projekt unabhängig von den mit dem Skript empfangenen Parametern.


IMatchedSectionInfo

Worum geht es

Enthält detaillierte Informationen über den Bereich Dokumentdefinition, der auf der Seite zugeordnet ist.

Definition | Beschreibung
FlexibleAlternativeName( ) : string | Gibt den Namen des FlexiLayouts zurück. Diese Funktion ist nur für bereits geöffnete Dokumente verfügbar.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
DocumentDefinition | IDocumentDefinitionInfo | Schreibgeschützt | Information über die Dokumentdefinition, zu der dieser Bereich gehört.
FlexibleInstanceId int Schreibgeschützt

Index eines flexiblen Bereichs. Eine Gruppe von Seiten mit dem gleichen Index des flexiblen Bereichs bildet einen Dokumentbereich.

Das Feld ist nur für flexible Bereiche wirksam. Unterscheidet sich der Wert von FlexibleInstanceId für zwei Seiten, auf denen eine Übereinstimmung der gleichen Definition des flexiblen Bereichs besteht, bedeutet das, dass die Seiten zu unterschiedlichen Bereichen gehören.
IsFlexible | bool | Schreibgeschützt | Bestimmt, ob der Bereich flexibel ist.
Name | string | Schreibgeschützt | Der Name des Bereichs.
SectionDefinitionPageNumber int Schreibgeschützt

Die Seitenzahl in der Definition des auf der Seite zugeordneten statischen Bereiches.

Das Feld ist nur für statische Bereiche wirksam.


IMatchingInfo

Worum geht es

Speichert die Parameter zugeordneter Dokumentdefinitionen und Bereiche auf einer Seite.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
DefinitionsList | string | Lesen/Schreiben | Die Liste der einander zuzuordnenden Bereiche und Dokumentdefinitionen auf der Seite, unterteilt durch ein Semikolon. Die Namen der Dokumentdefinitionen und Bereiche können in der Form <DefinitionName>\<SectionName> angegeben werden. Nur existierende Bereiche und Dokumentdefinitionen können verwendet werden. Beispiel: der erste Bereich des Beispiels Banking_eng wird wie folgt angegeben: Banking_eng\Page 1.
ForceMatch | bool | Lesen/Schreiben | Gibt an, ob die Zuordnung von Bereichen erzwungen werden soll. Das Flag kann nur auf "true" gesetzt werden, wenn nicht mehr als ein Bereich festgelegt wurde. Ist die Bereichsliste leer und das Flag auf "true" gesetzt, wird die Seite als Anhangseite markiert, die keine Erkennung benötigt.
MaxPagesToMatch | int | Lesen/Schreiben | Gibt die Höchstzahl der Seiten an, die mehrseitigen Bereichen zugeordnet werden können. 0 bedeutet, dass es keine Einschränkungen gibt.
NeedRecognition | bool | Lesen/Schreiben | Gibt an, ob Felder innerhalb des Bereichs eine Erkennung benötigen. Wurde das Flag auf "false" gesetzt, werden die Felder nach der Zuordnung keiner Erkennung unterzogen.

Hinweis: Für eine Seite, die mit allen Bereichen erkannt werden soll, darf die Eigenschaft DefinitionsList nicht geändert werden. Ist die Eigenschaft DefinitionsList leer und das Flag ForceMatch nicht gesetzt, wird die Seite nicht erkannt und die Fehlermeldung "Keine Dokumentdefinitionen zum Zuordnen" protokolliert. Ist das Flag ForceMatch auf "true" gesetzt, wird die Seite als eine Anhangseite markiert.


IPage

Worum geht es

Repräsentiert eine Seite.

Methoden

Definition | Beschreibung
ReplaceImage( newPicture : IPictureObject ) | Ersetzt das Seitenbild durch ein neues. Das neue Bild kann durch die Bearbeitung eines anderen IPictureObject-Objekts erstellt, von einer Datei mithilfe der Methode FCTools.LoadImage geladen oder von einer im Speicher abgelegten Bitmapdatei (z. B., .NET System.Drawing.Image) aus mithilfe der Methode FCTools.PictureFromHBitmap erstellt werden.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Speichert das Seitenbild in Abhängigkeit von den Speicheroptionen. Sind keine Optionen angegeben, wird das Bild als *.tif gespeichert. Ist ein internes* Feld.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Anhänge | IUserAttachments | Schreibgeschützt | Benutzeranhänge
Dokument | IDocument | Schreibgeschützt | Das Dokument, das die Seite enthält
ExcludedFromDocumentImage bool Read/write, Mutable (can be modified even in scripts with read-only permissions)

Findet Anwendung während des Exports des Dokumentbildes. Zeigt an, dass das aktuelle Seitenbild beim Export des gesamten Dokuments nicht exportiert werden soll.

Ist ein internes* Feld.
Id | string | Schreibgeschützt | Die Seitenkennung
ImageSource | string | Schreibgeschützt | Ein vollständiger Pfad zur Datei (für Dateien) oder zur Quelle, angegeben in ImageSourceDetails für andere Quellen.
ImageSourceFileSubPath | string | Schreibgeschützt | Der Pfad des Quellbildes in Bezug zum Stammverzeichnis des Hot Folder oder des Ordners, aus dem sie importiert wurden.
ImageSourcePageNumber | int | Schreibgeschützt | Die Nummer der Quellseite in der Datei.
ImageSourceType | string | Schreibgeschützt | String "File", "Scanner" oder "Custom", je nach Quelle
Index | int | Schreibgeschützt | Der Index der Seite im Dokument
IsAnalyzed | bool | Schreibgeschützt | Bestimmt, ob die Seite analysiert ist.
MatchedSection | IMatchedSectionInfo | Schreibgeschützt | Detaillierte Informationen über den Bereich, der der Seite zugeordnet ist. Befinden sich keine zugeordneten Bereiche auf der Seite, beträgt der Wert Null.
Bild IPictureObject Schreibgeschützt

Das Seitenbild.

Ist ein internes* Feld.
Rect IRect Schreibgeschützt

Das Rechteck der Seite.

Ist ein internes* Feld.
SectionName | string | Schreibgeschützt | Der Name des Dokumentbereichs.
SourceImageRotation int Schreibgeschützt

Der Winkel (in Grad), auf den das Quellseitenbild gedreht wurde. Mögliche Werte: 0, 90, 180, 270. Für gegen den Uhrzeigersinn gedrehte Seiten wird der Wert der Drehung im Uhrzeigersinn angegeben (bei einer Drehung um 90˚ gegen den Uhrzeigersinn wird 270 zurückgegeben). Die Eigenschaft ist nur dann verfügbar, wenn das die Seite enthaltende Dokument geöffnet ist.

Ist ein internes* Feld.

Gibt den Drehwinkel für Bilder zurück:

  1. importiert von einem Hot Folder;
  2. geladen in die Projektkonfigurationsstation oder in die Rich-Überprüfungsstation;
  3. gedreht während der Erkennung;
  4. manuell gedreht in Rich- und Remotestationen;
  5. manuell gedreht in der Web-Überprüfungsstation oder während der Überprüfung in der Web-Erfassungsstation.
Ignoriert den Drehwinkel für die Bilder:
  1. gedreht durch Skripte;
  2. gedreht in der (Web-)Scanstation oder während des Scannens in der Web-Erfassungsstation;
  3. automatisch gedreht bei der Korrektur der Bildverzerrung.
[Obsolete] TemplateName string Schreibgeschützt

Name des Dokumentbereichs (gleich wie SectionName).

Die Eigenschaft wird aus Gründen der Abwärtskompatibilität beibehalten.

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


IPageClassificationResult

Worum geht es

Speichert Informationen über die Ergebnisse der Klassifizierung der Seite.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
MatchedSections string Schreibgeschützt Die Liste der Bereiche, die zugeordnet werden können. Enthält Einträge der Form <Document Definition Name>\<Section Name>, getrennt durch ein Semikolon. Diese unveränderte Liste kann an das Objekt IMatchingInfo als DefinitionsList-Parameter übergeben werden (IMatchingInfo::DefinitionsList). Um die Ergebnisse weiterzugeben, gehen Sie folgendermaßen vor:

  1. Erstellen Sie auf der Basis eines Skripts eine benutzerdefinierte Phase.

  2. In dieser Phase schreiben Sie ein Skript, das die Seiten klassifiziert und die Klassifizierungsergebnisse in die Registrierungsparameter schreibt.

  3. In das Skript Vor der Zuordnung schreiben Sie den Code, der die Klassifizierungsergebnisse aus dem Registrierungsparameter verwendet, falls der Registrierungsparameter festgelegt wurde.
Hinweis: Bei der Übergabe der Klassifizierungsergebnisse an das Skript Before matching setzen Sie das Flag IMatchingInfo.ForceMatch auf false, damit die Seiten nicht wiederholt durch ein Skript klassifiziert werden.
PageType | TPageClassificationType | Schreibgeschützt | Der Typ der Seite


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IPages

IPages

Worum geht es

Eine Sammlung von IPage-Objekten.


IPictureObject

Worum geht es

Repräsentiert das Bild einer Seite oder eines Bereichs.

Das Objekt implementiert die IPicture-Schnittstelle und stellt über die IDispatch-Schnittstelle den Zugriff auf einige der Schnittstelleneigenschaften bereit.

Eine detaillierte Beschreibung der IPicture-Schnittstelle finden Sie im entsprechenden Artikel bei MSDN.

Methoden

Definition | Beschreibung
AnalyzePageObjects( [optional] reserved: Object ) : IPictureObjectsInfo | Definiert Objekte auf der Seite und gibt die Seitenparameter so zurück, wie sie im Erfassungsmodul gesehen werden. Die Ausführung kann sich etwas verzögern.
CreateEditableCopy() : IEditablePictureObject | Erstellt eine bearbeitungsfähige Kopie des Bildes.
DetectPageOrientation( [optional] language: string ) : int | Erkennt die Seitenausrichtung anhand des Textes. Der interne Name der Sprache wird an den Eingangsparameter übergeben. Wird die Sprache nicht angegeben, wird die Sprache des aktuellen Gebietsschemas verwendet. Gibt den Winkel zurück (in Grad), um den die Seite gedreht werden muss. Die folgenden Werte können zurückgegeben werden: 0, 90, 180 und 270.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Speichert das Bild. Sind keine Optionen angegeben, wird das Bild als *.tif gespeichert.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | OLE_HANDLE | Schreibgeschützt | Der Windows GDI-Handle des Bildes. In .Net kann diese Eigenschaft in der Methode System.Drawing.Image.FromHbitmap für das Abrufen des Bildobjekts verwendet werden.
Height | int | Schreibgeschützt | Die Höhe des Bildes in Pixeln
hPal | OLE_HANDLE | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Das vom Bild verwendete Windows-Handle der Palette. Diese Eigenschaft kann in System.Drawing.Image.FromHbitmap als zweiter Parameter verwendet werden.
IsBlackWhite | bool | Schreibgeschützt | Ob das Bild Schwarz-Weiß ist
Type | SHORT | Schreibgeschützt | Der Typ des Bildes.
Width | int | Schreibgeschützt | Die Breite des Bildes in Pixeln
XResolution | int | Schreibgeschützt | Die horizontale Bildauflösung
YResolution | int | Schreibgeschützt | Die vertikale Bildauflösung


IPictureObjectsInfo

Worum geht es

Ein Objekt, das die Resultate der Objekterkennung speichert.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
BarcodesCount | int | Schreibgeschützt | Die Anzahl der auf dem Bild erkannten Barcodes (2-D-Barcodes werden nicht mitgezählt).
BlacknessPercentage | int | Schreibgeschützt | Der Prozentsatzes mit schwarzer Farbe auf der Seite.
BlackSquaresCount | int | Schreibgeschützt | Die Anzahl der erkannten schwarzen Quadrate.
TextObjectsCount | int | Schreibgeschützt | Die Anzahl der Textobjekte.


IPrincipal

Worum geht es

Repräsentiert einen Benutzer oder eine Benutzergruppe in Skripten.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Id | int | Schreibgeschützt | Eine eindeutige Kennung
Name | string | Schreibgeschützt | Der Name eines Benutzers oder einer Gruppe
Typ | TPrincipalType | Schreibgeschützt | Der Typ des Principal


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IPrincipals

IPrincipals

Worum geht es

Eine allgemeine Sammlung von Benutzern und Benutzergruppen (eine Sammlung von IPrincipal-Objekten).


IProcessingCallback

Worum geht es

Gibt Informationen über den Verarbeitungsfortschritt weiter.

Methoden

Definition | Beschreibung
ReportError( error : string ) | Schreibt eine Fehlermeldung in das Protokoll. Der Vorgang, der eine Fehlermeldung enthält, wird als fehlgeschlagen betrachtet.
ReportMessage( message : string ) | Schreibt eine informative Nachricht in das Protokoll.
ReportWarning( warning : string ) | Schreibt eine Warnmeldung in das Protokoll.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
ShouldStop | bool | Schreibgeschützt | Überprüft, ob der Task abgebrochen wurde oder nicht (ob der Benutzer auf "Abbrechen" geklickt hat).


IProject

Worum geht es

Repräsentiert das Projekt in Skripten.

Methods

Definition | Beschreibung
GetDocumentDefinitions( [optional] reserved :object ) : IDocumentDefinitionInfoArray | Gibt Informationen über die im Projekt enthaltenen Dokumentdefinitionen zurück. Die reservierten Parameter müssen Null sein oder dürfen nicht festgelegt sein.

Properties

Eigenschaften

Name | Typ | Zugriff | Beschreibung
EnvironmentVariables | IProperties | Schreibgeschützt | Gibt ein Array von Umgebungsvariablen zurück, die im Projekt verwendet werden.
ExportRootPath | string | Schreibgeschützt | Stammpfad für den Export, wie in den Projekteinstellungen definiert. Kann eine leere Zeichenfolge sein.
Name | string | Schreibgeschützt | Name des Projekts
Principals | IPrincipals | Schreibgeschützt | Ein Array aus Benutzern oder Gruppen


IProperties

Worum geht es

Eine Sammlung von IProperty-Objekten.

Methoden

Definition | Beschreibung
Delete (name : string) | Löscht die Eigenschaft mit dem angegebenen Namen.
Get (name : string) : string | Abruf des Eigenschaftswertes nach dem Namen.
Has (name : string) : bool | Überprüft, ob die Gruppe die Eigenschaft mit dem angegebenen Namen enthält.
Set (name : string, value : string) | Bestimmt den Wert einer benannten Eigenschaft. Erstellt eine Eigenschaft, falls diese nicht vorhanden ist. Hinweis: Informationen über die Änderung des Dokumentstatus finden Sie in der Schnittstelle ITaskWindow.


IProperty

Worum geht es

Repräsentiert eine benannte Eigenschaft eines Dokuments oder eines Stapels.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Der Name der Eigenschaft
Value | string | Schreibgeschützt | Der Eigenschaftswert


IPropertyModificationInfo

Worum geht es

Speichert Informationen über die Änderung einer Dokument- oder Stapeleigenschaft.

Ein festgelegter Wert kann korrigiert werden.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Der Name des benannten Parameters (nur für den Typ PT_NamedPropertyValue)
NewValue | string | Lesen/Schreiben | Ein neuer Wert der Eigenschaft. Das Skript erlaubt die Festlegung des Werts in anderer Form, z. B. zur Normalisierung des Werts..
PropertyType | TPropertyType | Schreibgeschützt | Der Typ der Eigenschaft, die bearbeitet wird


IRect

Worum geht es

Repräsentiert ein Rechteck.

Methoden

Definition | Beschreibung
ToString() : string | Repräsentiert ein Rechteck als eine Zeichenkette der Form "[left,top,right,bottom]".

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Bottom | int | Schreibgeschützt | Untere Koordinate
Left | int | Schreibgeschützt | Linke Koordinate
Right | int | Schreibgeschützt | Rechte Koordinate
Top | int | Schreibgeschützt | Obere Koordinate


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IRects

IRects

Worum geht es

Eine Sammlung von IRect-Schnittstellen.


IRuleContext

Worum geht es

Ein Kontextobjekt von Regeln. Repräsentiert das Objekt, auf dessen Ebene die Regel erstellt wurde.

Das Objekt implementiert die IField-Interface (indem Zugriff auf das Kontextfeld der Regel bereitgestellt wird) und enthält außerdem zusätzliche Methoden.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
CheckSucceeded | bool | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Gibt an, ob die Überprüfung erfolgreich war
Document | IDocument | Schreibgeschützt | Zugriff auf das Dokument
Felder | IFields | Schreibgeschützt | Eine Sammlung von Feldern der Regel Angegeben in den Regeleinstellungen.
FocusedField | IField | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Das Feld, das bei Anklicken eines Regelfehlers fokussiert werden soll (das Feld, das einen Regelfehler verursacht hat).
FocusRect | IRect | Schreibgeschützt | Ein Rechteck in Bildschirmkoordinaten, auf das sich die ausgeführte Aktion bezieht (ein Rechteck des Fensters) Gilt nur für Custom Action-Skripte.
ErrorMessage | string | Lesen/Schreiben, Variabel (kann auch in Skripten mit Nur-Leseberechtigung geändert werden) | Eine Nachricht bezüglich eines Regelfehlers
ParentWindow | int | Schreibgeschützt | Ein Handle des übergeordneten Fensters. Gilt nur für Custom Action-Skripte.
[Obsolete] FieldsObject | IFR65Fields | Schreibgeschützt | Eine veraltete Eigenschaft. Beibehalten aus Kompatibilitätsgründen für Skripte, die mit FormReader 6.5 erstellt wurden.
[Obsolete] ErrorObjectObject | IFR65Errors | Schreibgeschützt | Eine veraltete Eigenschaft. Beibehalten aus Kompatibilitätsgründen für Skripte, die mit FormReader 6.5 erstellt wurden.


IRuleError

Worum geht es

Repräsentiert einen Regelfehler, Formatfehler oder Zusammenführungsfehler im Dokument.

Methoden

Definition | Beschreibung
GetFields() : IFields | Gibt die Felder zurück, die dem angegebenen Feldfehler zugeordnet sind.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
IsWarning | bool | Schreibgeschützt | Gibt an, ob es sich bei der Meldung um eine Warnung handelt.
Meldung. | string | Schreibgeschützt | Der Text der Fehlermeldung.
RuleName | string | Schreibgeschützt | Der Name der Regel, die den Fehler verursacht hat. Bei Format- und Zusammenführungsfehlern wird eine leere Zeichenfolge zurückgegeben.
Typ | TRuleErrorType | Schreibgeschützt | Der Fehlertyp.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IRuleErrors

IRuleErrors

Worum geht es

Eine Sammlung von IRuleError-Schnittstellen.


IScriptBinaryAttributes

Beschreibung

Eine Gruppe von booleschen Flags.

Methoden

Definition | Beschreibung
Has( TStateType : int ) : bool | Überprüft, ob das angeforderte Flag gesetzt ist


IScriptDefinitionContext

Worum geht es

Ermöglicht den Zugriff auf einige Eigenschaften der Objekte, die in Skripten verwendet werden können.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Project | IProject | Schreibgeschützt | Ermöglicht den Zugriff auf Informationen über das Projekt.


ISectionDefinitionInfo

Worum geht es

Beschreibt einen Bereich in einer Dokumentdefinition.

Properties

Name | Type | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Name des Bereichs.
IsFlexible | bool | Schreibgeschützt | Ob der Bereich flexibel ist oder nicht.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > ISectionDefinitionInfoArray

ISectionDefinitionInfoArray

Worum geht es

Eine Sammlung von Objekten des Typs ISectionDefinitionInfo.


IStageInfo

Worum geht es

Speichert Informationen über die Verarbeitungsphase des Dokuments.

Eigenschaften

Name | Typ | Zugriff | Description
PrincipalId | int | Schreibgeschützt | Die Kennung eines Benutzers oder einer Gruppe, welche einen Task mit dem angegebenen Dokument erhalten können. "0" zeigt an, dass der Task keinem Principal zugewiesen wurde (Benutzer oder Gruppe). Ausführliche Informationen finden Sie unter IPrincipal.
StageId | int | Schreibgeschützt | Die Kennung der aktuellen Verarbeitungsphase
StageName | string | Schreibgeschützt | Der Name der aktuellen Verarbeitungsphase
TaskId | int | Schreibgeschützt | Die Kennung des Tasks. Ist kein Task vorhanden, lautet der Wert "0".


IUserAttachment

Worum geht es

Die Schnittstelle wird für die Arbeit mit dem Inhalt des Benutzeranhangs verwendet. Das Objekt repräsentiert ein Array aus Bytes. Auf die Bytes kann innerhalb der Sammlung als Objekte zugegriffen werden. Der Bytewert jeder Position kann geändert werden.

Methoden

Definition | Beschreibung
FromFile( fileName : string) | Ersetzt den Anhangsinhalt mit einer Datei aus dem angegebenen Pfad.
SetSize( newSize : int) : bool | Ändert die Größe der Datei. Dateien mit einer Größe kleiner als der angegebene Wert werden vergrößert, größere Dateien werden beschnitten.
ToFile( fileName : string) | Speichert die Datei in dem angegebenen Pfad auf der Festplatte.
UploadAttachment( ) | Speichert die am Anhang durchgeführten Änderungen.

Properties

Name | Typ | Zugriff | Beschreibung
AsString | string | Lesen/Schreiben | Darstellung der Datei als Unicode-Zeichenfolge. Die Dateien können als Unicode-Zeichenfolgen geschrieben und gelesen werden.
Name | string | Schreibgeschützt | Der Name der Datei


IUserAttachments

Worum geht es

Eine Sammlung von IUserAttachment-Objekten.

Methoden

Definition | Beschreibung
AddNew( name : string) : IUserAttachment | Erstellt einen neuen Dateianhang und beginnt mit seiner Bearbeitung. Wichtig! TDie Methode erstellt ein neues IUserAttachment-Element, ohne es der Sammlung hinzuzufügen. Um das Element der Sammlung hinzuzufügen und es für die Bearbeitung verfügbar zu machen, muss die Methode UploadAttachment( ) aufgerufen werden. Hinweis: Ist ein von Null verschiedener Anhang mit diesem Namen bereits vorhanden, wird eine Ausnahme zurückgegeben.
Delete( name : string) | Löscht den Dateianhang mit dem angegebenen Namen. Hinweis: Beim Löschen eines Elements wird dessen Existenz nicht überprüft. Daher fährt die Methode fort, auch wenn sich das gelöschte Element nicht in der Sammlung befindet.
Get( name : string) : IUserAttachment | Zugriff auf den Dateianhang mit dem angegebenen Namen
Has( name : string) : bool | Überprüft, ob der Dateianhang mit dem angegebenen Namen vorhanden ist

Eigenschaften

Name | Typ | Zugriff | Beschreibung
IsEmpty | bool | Schreibgeschützt | Überprüft, ob das Array Dateianhänge enthält
Names | IVariantArray | Schreibgeschützt | Das Array mit den Namen der Dateianhänge


IUserSessionInfo

Worum geht es

Informationen über die Sitzung des aktuellen Benutzers der Verarbeitungsstation.

Gibt während der Überprüfung Informationen über die Sitzung des Benutzers an, der die Überprüfung ausführt (einschließlich Remote-Überprüfung).

Eigenschaften

Name | Typ | Zugriff | Beschreibung
PrincipalId | int | Schreibgeschützt | Die Kennung des Benutzers im AnABBYY FlexiCapturewendungsserver. Für die Einzelplatzversion des ABBYY FlexiCapture, gibt Null zurück.
RoleId | int | Schreibgeschützt | Die ID der Benutzerrolle. Für die Einzelplatzversion des ABBYY FlexiCapture, gibt Null zurück.
SessionId | int | Schreibgeschützt | Die Kennung der Verbindung zum Anwendungsserver. Für die Einzelplatzversion des ABBYY FlexiCapture, gibt Null zurück.
UserName | string | Schreibgeschützt | Der Benutzername. Bei der Arbeit ohne den Anwendungsserver wird der Name des Benutzers, unter dem der Prozess ausgeführt wird, zurückgegeben. Bei der Verbindung zum Anwendungsserver wird versucht, den Namen des beim Anwendungsserver angemeldeten Benutzers abzurufen.


IValue

Worum geht es

Repräsentiert einen Feldwert.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
ErrorMessage | string | Lesen/Schreiben | Nachricht bezüglich eines Formatierungsfehlers des Wertes
Symbols | ICharactersParams | Schreibgeschützt | Detaillierte Informationen über die Symboleigenschaften
Text | string | Lesen/Schreiben | Textdarstellung des Werts
[Obsolete] SuspiciousSymbols | string | Lesen/Schreiben | Beschreibt, welche Symbole für die Erkennung kritisch sind, besteht aus "0" und "1". Aus Gründen der Abwärtskompatibilität beibehalten worden.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > IVARIANTArray

IVARIANTArray

Worum geht es

Repräsentiert eine Sammlung von Objekten des Typs Variant.


TAssemlingErrorType

Beschreibung

Der Typ des Zusammenstellungsfehlers.

Zulässige Werte:

  • AET_ObligatoryItemOmitted = 0 - Ein fehlender Bereich
  • AET_RubbishItem = 1 - Eine zusätzliche Seite
  • AET_AssemblingRuleError = 2 - Ein benutzerdefinierter Zusammenstellungsfehler
  • AET_KeyValuesMismatch = 3 - Werte der Schlüsselfelder-Nichtübereinstimmung (es kann nicht mehr als ein Fehler dieses Typs im Dokument auftreten)


TExportFieldType

Worum geht es

Aufzählung des Typs int. Definiert den Typ der Dokumentfelder.

Zulässige Werte:

  • EFT_TextField = 0 - Ein Textfeld

  • EFT_DateTimeField = 1 - Ein Datumsfeld

  • EFT_NumberField = 2 - Ein Zahlenfeld

  • EFT_PictureField = 3 - Ein Bildfeld

  • EFT_CurrencyField = 4 - Ein Währungsfeld

  • EFT_Checkmark = 5 - Ein Auswahlfeld

  • EFT_CheckmarkGroup = 6 - Eine Auswahlfeldgruppe

  • EFT_Group = 7 - Eine gewöhnliche Gruppe

  • EFT_Table = 8 - - Eine Tabelle. Sie können über die Methoden Items oder Rows des Objekts IField auf Tabellenzeilen zugreifen.

  • EFT_Section = 9 - Ein Dokumentbereich

  • EFT_Document = 10 - Ein Dokument. Felder dieses Typs können nur in Regeln auftreten, die für die Ebene eines Dokuments geschrieben wurden. Die meisten Parameter solcher Felder sind nicht verfügbar.

  • EFT_TableRow = 11 - Eine Tabellenzeile. Tabellenzellen sind die untergeordneten Felder der Zeile. Sie sind verfügbar über die Methode Children.

  • EFT_TimeField = 12 - Ein Zeitfeld


TExportType

Beschreibung

Der Typ des Exportziels.

Zulässige Werte:

  • ET_File = 1 - Exportieren in Datei
  • ET_Database = 2 - Exportieren in Datenbank
  • ET_Script = 3 - Skriptexport
  • ET_SharePoint = 4 - Exportieren in SharePoint
  • ET_Unknown = 5 - Der Typ wurde nicht angegeben für den Fall eines Fehlers, der keinen bestimmten Export betrifft


TPageClassificationType

Beschreibung

Der vom Klassifikator bestimmte Seitentyp. Gilt für die IPageClassificationResult-Schnittstelle.

Typen:

  • PCT_Unknown = 0 - Ein unbekannter Seitentyp.

  • PCT_Empty = 1 - Eine leere Seite.

  • PCT_FixedForm = 2 - Eine Seite mit festgelegtem Layout.

  • PCT_FlexibleMultiPageFormHeader = 3 - Eine Kopfzeile eines mehrseitigen, flexiblen Bereichs.

  • PCT_FlexibleMultiPageFormNonHeader = 4 - Eine Seite eines mehrseitigen, flexiblen Bereichs, der keine Kopfzeile ist.

  • PCT_FlexibleSinglePageForm = 5 - Ein einseitiger, flexibler Bereich.

  • PCT_ClassWithoutDefinition = 6 - Eine Seite der Klasse ohne Dokumentdefinition.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > TPrincipalType

TPrincipalType

Beschreibung

Typen von Principals.

Zulässige Werte:

  • PT_User = 0 - Ein regulärer Benutzer
  • ST_Group = 1 - Eine Benutzergruppe


TProcessingPriority

Beschreibung

Die Verarbeitungspriorität eines Dokuments oder eines Stapels.

Hinweis: Der Wert wird an das Event "Dokumentpriorität ändern" (oder "Stapelpriorität ändern") in Form einer Zeichenfolge weitergegeben. Es muss außerdem ein neuer Wert in Form einer Zeichenfolge angegeben werden.

Zulässige Werte:

  • PP_Lowest = -2 - Niedrigste Priorität Übergeben in Form der Zeichenfolge "lowest".
  • PP_Low = -1 - Niedrige Priorität. Übergeben in Form der Zeichenfolge "low".
  • PP_Normal = 0 - Normale Priorität. Übergeben in Form der Zeichenfolge "normal".
  • PP_High = 1 - Hohe Priorität. Übergeben in Form der Zeichenfolge "high".
  • PP_Highest = 2 - Höchste Priorität. Übergeben in Form der Zeichenfolge "highest".


TPropertyType

Beschreibung

Der Typ der Dokument- oder Stapeleigenschaften. Gilt für die Schnittstelle IPropertyModificationInfo.

Typen:

  • PT_Name = 0 - Der Name. Gilt nur für Stapel.
  • PT_Comment = 1 - Der Kommentar.
  • PT_BatchType = 2 - Der Stapeltyp. Gilt nur für Stapel.
  • PT_NamedPropertyValue = 3 - Eine benannte Eigenschaft (vorher ein Registrierungsparameter)
  • PT_Id = 4 - Die Kennung (die ExternalID des Dokuments). Diese Werte ändern sich gelegentlich und nur für Dokumente. Der Wert ändert sich meistens während des Imports.


TRuleErrorType

Beschreibung

Der Fehlertyp. Gilt für die Schnittstelle IRuleError.

Typen:

  • ET_RuleError = 0 - Ein Regelfehler.
  • ET_FormatError = 1 - Ein Formatfehler.
  • ET_MergeVersionError = 2 - Ein Fehler bei Zusammenführung verschiedener Versionen des Dokuments.


TStateType

Beschreibung

Typen von Dokumentzuständen. Verwendet bei dem Event "Dokumentstatus geändert". Der Parameter ChangedState dieses Events kann für das Auslesen von Informationen über mögliche Änderungen der einzelnen Zustandstypen verwendet werden.

Zulässige Werte:

  • ST_Preprocessed = 0 - Ob das Dokument vorverarbeitet wurde. Der Wert kann nur von "false" auf "true" geändert werden.
  • ST_Analyzed = 1 - Ob das Dokument analysiert ist
  • ST_Recognized = 2 - Ob das Dokument erkannt ist (ein Dokument wird als erkannt betrachtet, wenn sich mindestens ein erkannter Bereich darin befindet)
  • ST_HasErrors = 3 - Ob das Dokument Fehler enthält (einschließlich Formatfehler)
  • ST_Assembled = 4 - Ob das Dokument zusammengestellt ist
  • ST_Verifyed = 5 - Ob das Dokument vollständig überprüft ist
  • ST_Exported = 6 - Ob das Dokument exportiert ist
  • ST_HasLayout = 7 - Ob das Dokument ein Layout enthält (In einem analysierten Dokument kann ein Layout auch fehlen, z.B. wenn die Seite unbekannten Typs ist.)


Beispielskripte

Dieser Abschnitt enthält Beispielskripte, geschrieben in den Skriptsprachen JScript® und VBScript.

Beispielskripte zum Erstellen benutzerdefinierter Regeln
Beispielskripte für die Exportbeschreibung
Andere Beispielskripte


Beispielskripte zum Erstellen benutzerdefinierter Regeln

Collapsed Automatisierungsregel

In diesem Beispiel wird die Überprüfung von Tabellendaten veranschaulicht. Die Regel überprüft, ob die Tabellendaten dem Wert im Ergebnisfeld entsprechen. Die Tabelle enthält Spalten mit Preisen und Mengen bestimmter Waren. Die Regel wurde auf der Ebene eines Bereichs erstellt, der die Tabelle und das Ergebnisfeld enthält.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Code einer ActiveX-Komponente

Der angegebene Code entstammt einer CheckDoc-Klasse aus dem Projekt AutomationRule, das in den oben genannten Skripten verwendet wird.

Explizite Option

' Überprüft, ob die Tabellendaten mit dem Ergebnis übereinstimmen

' column1 - Preisspalte

' column2 - Mengenspalte

' resultField - Ergebnisfeld (<Total> oder Entsprechung)

' docObj - der überprüfte Dokumentknoten

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems AsObject, numItems AsObject

Dim curCost AsDouble, curNum AsLong, sum AsDouble

Dim result AsDouble

Dim i AsLong

Set costItems = column1.Items

Set numItems = column2.Items

' summing up table data

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' Genauigkeit des Vergleichs: das Ergebnis wird auf 2 Nachkommastellen gerundet

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Table data does not match the resulting value"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Collapsed Durchsuchen der Liste von Varianten

Mit dem unten angegebenen Regelcode wird geprüft, ob der Feldwert einem der Werte in der Liste entspricht. Trifft dies nicht zu, wird ein Fehlerflag angezeigt, und dem Feld wird eine Liste von vorgeschlagenen Werten zugeordnet. Das Feld wird in Abhängigkeit vom Prüfergebnis als eindeutig oder nicht eindeutig erkannt gekennzeichnet.

[VBScript]

' Feldwert speichern

Dim fieldValue

fieldValue = me.Field("Field6").Value

' Liste von Werten für die Überprüfung erstellen

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

' Überprüfen, ob der Feldwert Werten in der Liste entspricht

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

' Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

me.Field("Field6").IsVerified = success

' Liste der Vorschläge für das Feld erstellen – Vorschläge können alle

' passenden Werte sein

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

' Ein Fehlerflag setzen

me.CheckSucceeded = success

[JScript]

// Feldwert speichern

var fieldValue = Field("Field6").Value;

// Liste von Werten für die Überprüfung erstellen

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// Feldwert mit Werten in der Liste vergleichen

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

Field("Field6").IsVerified = success;

// fListe der Vorschläge für das Feld erstellen – Vorschläge können alle

// passenden Werte sein

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// Fehlerflag setzen

CheckSucceeded = success;

Collapsed Überprüfung von Feldzuordnungen

Mit dem unten angegebenen Regelcode wird überprüft, ob das überprüfte Feld zugeordnet werden konnte.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Field InvoiceNumber is not matched"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Field InvoiceNumber is not matched";

}

Collapsed Überprüfung von Auswahlfeldern

Mit dem unten stehenden Regelcode wird überprüft, ob das Auswahlfeld markiert wurde oder nicht

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Page status is not checked"

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Page status is not checked";

}

Collapsed Überprüfung einer Auswahlfeldgruppe

Mit dem unten stehenden Regelcode werden alle Auswahlfelder in der Gruppe durchlaufen. Wenn kein Auswahlfeld markiert wurde, wird das erste Feld ausgewählt. Die Regel wurde für die Ebene mit den Gruppen von Auswahlfeldern geschrieben. Alle Auswahlfelder in der Gruppe wurden der Liste von Feldern hinzugefügt, die in die Regel einbezogen werden sollen. Die Gruppe selbst wurde von der Liste ausgeschlossen. Für das Standardauswahlfeld (das erste Feld) wurde der Schreibschutz deaktiviert. Wenn die Gruppe keine Auswahlfelder enthält, wird das Kennzeichen für einen Regelfehler aktiviert.

Mit diesem Beispielcode werden sämtliche Felder der Regel durchlaufen. Da die Feldnamen nicht im Code angegeben sind, kann der Code für beliebige Gruppen von Auswahlfeldern verwendet werden.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "No checkmarks in group"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "No checkmarks in group";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}

Collapsed Zuverlässigkeitsüberprüfung des Feldes

Mit dem unten angegebenen Regelcode wird die Anzahl der nicht eindeutigen Zeichen im Feld überprüft. Das Feld wird gelöscht, wenn die Anzahl der nicht eindeutigen Zeichen größer oder gleich drei ist. Dies ist ein Autokorrekturskript.

[VBScript]

Dim totQty, suspQty

Dim i

totQty = me.Symbols.Count

suspQty = 0

for i = 0 to totQty - 1

if me.Symbols.Item(i).IsSuspicious = true then

suspQty = suspQty + 1

end if

next

if suspQty >= 3 then

me.Text = ""

end if

[JScript]

var susp, qty, strpos, i, SC, strposPrev

strposPrev = 1

qty = 0

SC = "1"

susp = SuspiciousSymbols

for ( i = 0; i < susp.length; i++) {

strpos = susp.indexOf (SC,i)

if ((strpos != strposPrev) && (strpos != -1)) {

qty = qty + 1

strposPrev = strpos

}

}

if (qty >= 3) {

text = ""

}

Collapsed Zeichenersetzung ohne den Verlust von Bereichen und Überprüfungsflags

Das Skript ersetzt "+" mit "&", ohne dass Informationen über Bereiche und Überprüfungsflags verloren gehen. Dies ist ein Autokorrekturskript.

[VBScript]

Dim totQty

Dim i

totQty = me.Symbols.Count

for i = 0 to totQty - 1

if me.Symbols(i).Symbol = "+" then

me.Symbols(i).Symbol = "&"

end if

next

Collapsed Stapelintegritätsprüfung

Überprüft, ob die auf der Kontrollseite bestimmte Anzahl von Dokumenten mit der Zahl im Stapel und der Anzahl der aktuell verarbeiteten Dokumente übereinstimmt. Wenn die Anzahl nicht übereinstimmt, wird ein Fehler zurückgegeben.

[VBScript]

dim DQty

dim i

for i = 0 to me.Batch.Documents.Count - 1

if me.Batch.Documents.Item(i).DefinitionName = "Inv" then

DQty = me.Batch.Documents.Item(i).IndexedItemValue("DocQty")

exit for

end if

next

dim AcQty

AcQty = me.Batch.Documents.Count

if acqty <> DQty then

me.CheckSucceeded = false

me.ErrorMessage = "Incorrect number of documents in the batch:" & " " & AcQty& ". " & "Expected number:" & " " & DQty & "!"

end if

[JScript]

for ( i = 0; i < [Batch.Documents.Count - 1]; i++ ) {

var TemplName = Batch.Documents.Item(0).DefinitionName;

if (TemplName = "Inv") {

var DQty = Batch.Documents.Item(i).IndexedItemValue("DocQty");

break ;

}

}

var AcQty = Batch.Documents.Count -1

if (AcQty != DQty) {

CheckSucceeded = false;

ErrorMessage = "Incorrect number of documents in the batch:" + " " + AcQty + "." + "Expected number:" + " " + DQty +"!" ;

}


Beispielskripte für die Exportbeschreibung

Collapsed Abrufen von Feldwerten beim Export

Dieser Beispielcode veranschaulicht, wie Sie den Wert eines Felds beim Export abrufen. Sie können mit diesem Wert die Dateien benennen, in die die Bilder oder Daten exportiert werden. Ist kein entsprechendes Feld im Dokument enthalten, tritt ein Fehler auf.

Die Struktur des in diesem Beispiel exportierten Dokuments sieht wie folgt aus:

Section 1

Field1

…

Group1

Field2

…

…

FieldN

Section 2

Field1

…

FieldK

[VBScript]

Dim field1Value, field2Value

' Gets the value of Field1 in Section 1

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Gets the value of Field2 in Group1 in Section 1

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Gets the value of Field1 in Section 1 if the section has multiple instances

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Gets the value of Field1 in Section 1

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Gets the value of Field2 in Group1 in Section 1

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Gets the value of Field1 in Section 1 if the section has multiple instances

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Collapsed Exportieren von Seitenbildern

Anhand des Codes in diesem Beispiel wird das Exportieren von Bildern aller Dokumentseiten mit dem erforderlichen Dateiformat, dem Farbschema und der Auflösung veranschaulicht. Die Bilder werden seitenweise gespeichert, so dass jede Seite in einer eigenen Datei gespeichert wird.

Die Dateien in diesem Beispiel werden mit "page1.tif", "page2.tif" usw. bezeichnet, Sie können das Benennungsschema für die Dateien aber ggf. ändern, indem Sie beispielsweise die Dateinamen auf Grundlage des Werts eines Felds erstellen.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = FCTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = FCTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Collapsed Exportieren einer Tabelle

In diesem Beispiel wird das Exportieren einer Tabelle in eine TXT-Datei veranschaulicht.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject")

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Collapsed Exportieren eines Dokuments mit beliebiger Verschachtelungstiefe

Dieses Beispiel zeigt, wie Felder eines Dokuments mit beliebiger Verschachtelungstiefe mithilfe benutzerdefinierter Funktionen aus dem globalen Exportmodul exportiert werden. Wenn Sie Dokumentfelder mit variabler Verschachtelung exportieren möchten, sollten Sie eine externe COM-Komponente verwenden. (Weitere Informationen finden Sie im nächsten Beispiel.)

Kerncode für den Export

[VBScript]

Export.ExportDocument me, FCTools

[JScript]

Export.ExportDocument( this, FCTools );

Der Code der Funktionen des globalen Exportmoduls

[VBScript]

' Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

Sub ExportDocument(ByRef docObj, ByRef FCTools)

    Dim folderNameme

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject")

    ' Erstellen des Exportordners

    folderName = CreateExportFolder(docObj.DefinitionName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during create export folder: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' Bilder exportieren

    ExportImages docObj, FCTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export images: " + Err.Description

        Err.Clear

        Exit Subub

    End if

    ' Die Textdatei erstellen

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

' Informationen über das Dokument exportieren

    ExportDocInfo docObj, txtFile

' Felder exportieren

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export data: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Bildexportfunktion

Function ExportImages( ByRef docObj, ByRef FCTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, , , , , , , , , imageOptions

    Dim fileName, pageNum

    ' Spezifizierung der Exporteinstellungen

    Set imageOptions = FCTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' Seitenweiser Export

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pageses

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Prozedur zum Exportieren der Informationen über das Dokument

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next t t

End Sub

' Überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die Überprüfung auf NULL) kann eine Ausnahme auslösen

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Feldexportprozedur

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' Feldnamen speichern

    txtFile.Write (indent & field.Name)

' Feldwert, sofern verfügbar, speichern

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("    " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' untergeordnete Felder exportieren

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' Feldinstanzen exportieren

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

Function CreateExportFolder(ByVal definitionName, ByRef fso)

    Dim docFolder, folderName

    ' Hauptordner

    exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' der Ordner der spezifizierten Dokumentdefinition

    docFolder = fso.BuildPath(exportFolder, definitionName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End If

    ' der Ordner für das exportierte Dokument

    Dim i

    i = 1

    folderName = fso.BuildPath(docFolder, i)

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath(docFolder, i)

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

// und Informationen über das Dokument

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // creating export folders

    try {

        folderName = CreateExportFolder(docObj.DefinitionName, fso);

    } catch( e ) { {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during create export folder: " + e.description;

        return;

    }

    // Bilder exportieren

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export images: " + e.description;

        return;

    }

    // Die Textdatei erstellen

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile(fileName, true);

// Informationen über das Dokument exportieren

    ExportDocInfo( docObj, txtFile );

// Felder exportieren

    txtFile.WriteLine( "Fields:" );

    try { {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export data: " + e.description;

        txtFile.Close();

        return;n;

    }

    txtFile.Close();

    txtFile = 0;

    fso = 0;

}

// Bildexportfunktion

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // Spezifizierung der Exporteinstellungen

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // Seitenweiser Export

    var pages = docObj.Pages;

    var i i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Prozedur zum Exportieren der Informationen über das Dokument

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount););

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Überprüft, ob der Wert des Felds NULL ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die Überprüfung auf NULL) eine Ausnahme auslösen

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Feldexportprozedur

function ExportField(field, txtFile, indent)

{

    // Feldnamen speichern

    txtFile.Write(indent + field.Name);

// Feldwert, sofern verfügbar, speichern

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // untergeordnete Felder exportieren

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // Export von Feldinstanzen

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

function CreateExportFolder(definitionName, fso)

{

    var docFolder, folderName

    // Hauptordner

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // der Ordner der spezifizierten Dokumentdefinition

    docFolder = fso.BuildPath(exportFolder, definitionName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder););

    }

    // der Ordner für das exportierte Dokument

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder(folderName);

    return folderName;

}

Collapsed Verwenden einer externen COM-Komponente

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, FCTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, FCTools );

Code einer ActiveX-Komponente in VisualBasic

Im Folgenden sehen Sie Code einer Exporter-Klasse aus dem Projekt "AutomationExport", das bereits in den oben beschriebenen Skripten verwendet wurde.

ExpliziteOption

Dim mFso AsNew Scripting.FileSystemObject

' Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

PublicSub Export(ByRef docObj As Object, ByRef FCTools As Object)

OnErrorGoTo err_h

    Dim folderName AsString

    Dim txtFile As TextStream, fileName AsString

    Dim imageExportResult AsString, errMessage AsString

' Exportordner erstellen

    folderName = createExportFolder(docObj.definitionName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Cannot create export folder"

        ExitSub

    EndIf

' Bilder exportieren

    imageExportResult = exportImages(docObj, FCTools, folderName)

' Die Textdatei erstellen

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

Informationen über Probleme beim Bildexport speichern

    If imageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    EndIf

' Informationen über das Dokument exportieren

    exportDocInfo docObj, txtFile

' Felder exportieren

    txtFile.WriteLine "Fields:"

    IfNot exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Error during export data"

    EndIf

    txtFile.Close

' Wenn Fehler während des Exports auftreten,

' das Flag für erfolgreichen Export auf False zurücksetzen

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    EndIf

    Set txtFile = Nothing

    Set mFso = Nothing

ExitSub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

EndSub

' Bildexportfunktion. Wenn während des Bildexports ein Fehler auftritt,

' dann wird eine Meldung über den Fehler zurückgegeben, andernfalls eine leere Zeichenfolge

PrivateFunction exportImages(ByRef docObj As Object, ByRef FCTools As Object, _

    ByVal exportFolder AsString) AsString

OnErrorGoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName AsString, pageNum AsLong

    exportImages = ""

' Spezifizierung der Exporteinstellungen

    Set imageOptions = FCTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

' Seitenweiser Export

    Set pages = docObj.pages

    pageNum = 1

    ForEach page In pages

        fileName = mFso.BuildPath(exportFolder, page.definitionName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

ExitFunction

err_h:

    exportImages = Err.Description

EndFunction

' Prozedur zum Exportieren der Informationen über das Dokument

PrivateSub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

OnErrorGoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

ExitSub

err_h:

    txtFile.WriteLine Err.Description

EndSub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

PrivateFunction exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

OnErrorGoTo err_h

    Dim curField As Object

    exportFields = True

    ForEach curField In fields

        IfNot exportField(curField, txtFile, indent) Then

            exportFields = False

        EndIf

    Next curField

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

EndFunction

' Überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die Überprüfung auf NULL) eine Ausnahme auslösen

Function IsNullFieldValue(ByRef field As Object) AsBoolean

OnErrorGoTo err_h

    IsNullFieldValue = IsNull(field.Value)

ExitFunction

err_h:

    IsNullFieldValue = True

EndFunction

' Feldexportfunktion

PrivateFunction exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent AsString) AsBoolean

OnErrorGoTo err_h

    Dim result AsBoolean

    result = True

' Feldnamen speichern

    txtFile.Write (indent & field.Name)

' Feldwert, sofern verfügbar, speichern

    IfNot IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    EndIf

    IfNot field.Children Is NothingThen

' untergeordnete Felder exportieren

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIfNot field.Items IsNothingThen

' Feldinstanzen exportieren

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    EndIf

    exportField = result

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

EndFunction

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

PrivateFunction createExportFolder(ByVal definitionName AsString) AsString

OnErrorGoTo err_h

    Dim docFolder AsString, folderName AsString

' Hauptordner

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = FalseThen

        mFso.CreateFolder (exportFolder)

    EndIf

' der Ordner der spezifizierten Dokumentdefinition

    docFolder = mFso.BuildPath(exportFolder, definitionName)

    If mFso.FolderExists(docFolder) = FalseThen

        mFso.CreateFolder (docFolder)

    EndIf

' Ordner für das exportierte Dokument

    Dim i AsLong

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

ExitFunction

err_h:

    createExportFolder = ""

EndFunction

Verwenden einer externen Komponente, die in .Net (C#) geschrieben ist

So verwenden Sie eine externe Komponente, die in .Net (C#) geschrieben ist:

  1. Erstellen Sie ein Projekt des Typs ClassLibrary.
  2. Fügen Sie die ControllerInterop.dll zu den Referenzen des Projekts hinzu. ABBYY FlexiCapture wird in der Liste References aufgeführt, und alle Schnittstellen der Skriptobjekte werden im Projekt verfügbar.
  3. Definieren Sie die Schnittstelle disp und die Klasse, die diese Schnittstelle implementiert, sowie ProgId (dadurch wird es möglich, im Code des Skripts mit der .Net-Komponente so zu arbeiten wie mit ActiveX).
  4. Registrieren Sie nach dem Aufbau des Projekts die Library der generierten Typen (das kann auch automatisch durch das Aktivieren der entsprechenden Option in den Projekteigenschaften erfolgen).
  5. Rufen Sie vom Exportcode aus die Methode der Komponente auf die übliche Weise auf:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, FCTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, FCTools );

Below follows the code of such a component:

using System;

using System.Runtime.InteropServices;

using System.IO;

using ABBYY.FlexiCapture;

namespace ExportLibrary1

{

// Die Schnittstelle der Exportkomponente, auf die vom Skript aus zugegriffen werden kann

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref FCTools Tools);

}

// Die Klasse, die die Funktion der Exportkomponente implementiert

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

// und Ihre ProgId festlegen

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien,

// die Textdatei mit Dokumentfeldern und Informationen über das Dokument

public void ExportDocument( ref IExportDocument docRef, ref FCTools FCTools )

{

try

{

string exportFolder = createExportFolder( docRef.DefinitionName );

exportImages( docRef, FCTools, exportFolder );

// Die Textdatei erstellen

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// Informationen über das Dokument exportieren

exportDocInfo( docRef, sw );

// Felder exportieren

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

privatestring createExportFolder( string definitionName )

{

string docFolder, folderName;

// Hauptordner

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// tder Ordner der spezifizierten Dokumentdefinition

docFolder = exportFolder + "\\" + definitionName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// Ordner für das exportierte Dokument

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

return folderName;

}

// Bildexportfunktion

privatevoid exportImages( IExportDocument docRef, FCTools FCTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = FCTools.NewImageSavingOptions(); ;

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Informationen über das Dokument exportieren

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Auflistung von Feldern exportieren

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Überprüft, ob der Wert des Felds Null ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die Überprüfung auf NULL) eine Ausnahme auslösen

privatebool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

returntrue;

}

}

// Angegebenes Feld exportieren

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// Feldnamen speichern

sw.Write( indent + field.Name );

// Feldwert, sofern verfügbar, speichern

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// untergeordnete Felder exportieren

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// Feldinstanzen exportieren

exportFields( field.Items, sw, indent + " " );

}

}

}

}
Collapsed Exportsteuerung

Dieser Beispielcode zeigt eine einfache Exportsteuerung, die Informationen über die exportierten Dokumente und Exportergebnisse in Textdateien speichert. In diesem Beispiel werden zwei Textdateien verwendet: Eine Datei enthält die Liste der erfolgreich exportierten Dokumente und die andere die Liste der Dokumente, bei denen während des Exports Fehler aufgetreten sind.

[VBScript]

dim curDoc

dim fso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

set fso = CreateObject("Scripting.FileSystemObject")

' Datei mit der Liste fehlgeschlagener Dokumente erstellen

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

set txtErrorFile = fso.CreateTextFile( fileErrorName, true )

' Datei mit der Liste erfolgreich exportierter Dokumente erstellen

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

set txtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

dim i, exprortResult, docInfo

' Auflistung der exportierten Dokumente durchlaufen

for i = 0 Tome.Count - 1

    set exportResult = me.Item(i)

    docInfo = "DocumentId:" & exportResult.Document.Id

    if exportResult.Succeeded then

        docInfo = docInfo & " - Exported successfully."

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & " - Export error: " & exportResult.ErrorMessage

        txtErrorFile.WriteLine docInfo

    endif

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

// Datei mit der Liste fehlgeschlagener Dokumente erstellen

var fileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

var txtErrorFile = fso.CreateTextFile( fileErrorName, true );

// Datei mit der Liste erfolgreich exportierter Dokumente erstellen

var fileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

var txtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

var i

// Auflistung der exportierten Dokumente durchlaufen

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Exported successfully.  Result:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Export error: " + curDoc.Action.ErrorMessage + "  Result:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Andere Beispielskripte

Collapsed Feldwertzusammenstellung

Typ: Skript für Dokumentzusammenstellung

Dieser Beispielcode demonstriert, wie ein Dokument mit mehrfach vorkommenden Bereichen auf einer Seite ohne Anhangseiten zusammengestellt wird. Die Seiten werden in ein Dokument in aufsteigender Reihenfolge des Feldwertes "PageIndex" zusammengeführt.

[VBScript]

dim lastValue, pageIndex, sections, field, validPages(), validPagesSize, pageIsValid

lastValue = ""

pageIndex = 0

for i = 0 to me.Count - 1

set sections = me.Item( i ).Sections

redim validPages( 0 )

validPagesSize = 0

' Check fields in sections

for j = 0 to sections.Count - 1

if sections.Item( j ).HasField( " PageIndex " ) then

set field = sections.Item( j ).Field( " PageIndex " )

if not( field.Text = "" ) then

if lastValue = "" or field.Text > lastValue then

' Valid page order

' Mark all pages of the section as valid

for k = 0 to sections.Item( j ).Regions.Count - 1

validPagesSize = validPagesSize + 1

redim preserve validPages( validPagesSize )

validPages(validPagesSize - 1) = sections.Item( j ).Regions.Item( k ).PageIndex

next

end if

lastValue = field.Text

end if

end if

next

' Now mark all invalid pages

for j = 0 to me.Item( i ).Pages.Count - 1

pageIsValid = false

' Check if this page is valid

for k = 0 to validPagesSize - 1

if validPages(k) = j then

pageIsValid = true

exit for

end if

next

if not pageIsValid then

AssemblingErrors.AddRedundantPageError( pageIndex )

end if

pageIndex = pageIndex + 1

next

next

[JScript]

var lastValue = "";

var pageIndex = 0;

for( i = 0; i < this.Count; i++ ) {

var sections = this.Item( i ).Sections;

var validPages = new Array();

// Check fields in sections

for( j = 0; j < sections.Count; j++ ) {

if( sections.Item( j ).HasField( "PageIndex" ) ) {

var field = sections.Item( j ).Field( " PageIndex " )

if( field.Text != "" ) {

if( lastValue == "" || field.Text > lastValue ) {

// Valid page order

// Mark all pages of the section as valid

for( k = 0; k < sections.Item( j ).Regions.Count; k++ ) {

validPages.push( sections.Item( j ).Regions.Item( k ).PageIndex );

}

}

lastValue = field.Text;

}

}

}

// Now mark all invalid pages

for( j = 0; j < this.Item( i ).Pages.Count; j ++ ) {

var pageIsValid = false;

// Check if this page is valid

for( k = 0; k < validPages.length; k++ ) {

if( validPages[k] == j ) {

pageIsValid = true;

break;

}

}

if( !pageIsValid ) {

AssemblingErrors.AddRedundantPageError( pageIndex );

}

pageIndex ++;

}

}

Collapsed Event Dokument zusammenführen

Typ: ein Handler des Events Seiten verschoben

TDieser Beispielcode demonstriert, wie das Event "Seiten verschoben" in das Event "Dokument zusammenführen" umgewandelt werden kann. Die Logik dieses Skripts ist folgende: wurden alle Seiten des Dokuments verschoben, ist dieses Dokument vollständig in das Zieldokument eingebettet.

Das Skript wird beim Event Seiten verschoben gestartet. Die Prozedur Events.OnDocumentsMerge ist eine Prozedur, die das Event "Dokument zusammenführen" steuert.

[VBScript]

dim currentDocument, currentDocumentPagesMoved

set currentDocument = Pages( 0 ).Document

currentDocumentPagesMoved = 0

for i = 0 to Pages.Count - 1

if Pages( i ).Document.Id <> currentDocument.Id then

' Nächstes Dokument

if currentDocument.Pages.Count = currentDocumentPagesMoved then

' Alle Seiten vom vorigen Dokument wurden verschoben. Das Event ist ausgelöst.

Events.OnDocumentsMerge TargetDocument, currentDocument

end if

Set currentDocument = Pages( i ).Document

else

next

if currentDocument.Pages.Count = currentDocumentPagesMoved Then

' Alle Seiten vom letzten Dokument wurden verschoben. Das Event ist aufgerufen.

Events.OnDocumentsMerge TargetDocument, currentDocument

end if

[JScript]

var currentDocument = Pages( 0 ).Document;

var currentDocumentPagesMoved = 0;

for( i = 0; i < Pages.Count - 1; i++ ) {

if( Pages( i ).Document.Id != currentDocument.Id ) {

// Nächstes Dokument

if( currentDocument.Pages.Count == currentDocumentPagesMoved ) {

// Alle Seiten vom vorigen Dokument wurden verschoben. Das Event ist aufgerufen.

Events.OnDocumentsMerge( TargetDocument, currentDocument );

}

currentDocument = Pages( i ).Document;

} else {

currentDocumentPagesMoved = currentDocumentPagesMoved + 1;

}

}

if( currentDocument.Pages.Count == currentDocumentPagesMoved ) {

// Alle Seiten vom letzten Dokument wurden verschoben. Das Event ist aufgerufen.

Events.OnDocumentsMerge( TargetDocument, currentDocument )

}

Collapsed Zusammenführen der Dokumentregistrierungsparameter bei Dokument zusammenführen

Typ: ein Handler des Events Dokument zusammenführen

Dieser Beispielcode demonstriert den einfachsten Weg zur Zusammenführung der Dokumentregistrierungsparameter beim Event Dokument zusammenführen. Bei der Zusammenführung von Dokumenten in ein Zieldokument werden nur die Parameter des neuen Dokuments hinzugefügt, die darin gefehlt haben.

Der Code sollte in einem gemeinsam benutzten Modul gespeichert werden. Die Prozedur OnDocumentsMerge muss in dem Moment der Zusammenführung der Dokumente aufgerufen werden. Einzelheiten finden Sie in der Beschreibung des Events Dokument zusammenführen.

[VBScript]

Sub MergeProperty(ByVal TargetDocument, ByVal propertyName, ByVal propertyValue)

If TargetDocument.Properties.Get(propertyName) = "" Then

' Kein solcher Parameter im Dokument.

TargetDocument.Properties.Set(propertyName, propertyValue)

End If

End Sub

Sub OnDocumentsMerge(ByVal Target, ByVal Document)

' Führe Registrierungsparameter zusammen.

For i = 0 To Document.Properties.Count - 1

MergeProperty(Target, Document.Properties(i).Name,

Document.Properties(i).Value)

Next

End Sub

[JScript]

function MergeProperty( TargetDocument, propertyName, propertyValue )

{

if( TargetDocument.Properties.Get( propertyName ) == "" ) {

// Kein solcher Parameter im Dokument.

TargetDocument.Properties.Set( propertyName, propertyValue );

}

}

function OnDocumentsMerge( Target, Document )

{

// Führe Registrierungsparameter zusammen.

for( i = 0; i < Document.Properties.Count - 1; i++ ) {

MergeProperty( Target, Document.Properties(i).Name, Document.Properties(i).Value );

}

}


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripte für die benutzerdefinierte Anpassung der Verarbeitungsphasen > Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture-Skripte

Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture-Skripte

Migrieren von FormReader-Regeln in FlexiCapture-Skriptregeln

If-Then-Regeln

Änderungen bei Funktionen und Methoden:

  1. Error(field, message). Verwenden Sie anstelle dieser Funktion eine Kombination aus folgenden Eigenschaften der zu überprüfenden Einheit: CheckSucceeded, ErrorMessage und FocusedField.

    Der folgende Code aus FormReader 6.5

    if [City].IsEmpty() then Error( [City] , "the city name should be filled")

    muss geändert werden in:

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "the city name should be filled"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "the city name should be filled";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Zeichenfolgenoperationen. Im Folgenden finden Sie Anweisungen zum Implementieren von Zeichenfolgenoperationen in FlexiCapture, die über If-Then-Regeln verfügbar waren.

    [VBScript]

    .Length() – Verwenden Sie die entsprechende Funktion "Len(string)"

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Funktion "LCase(string)" oder "UCase(string)"

    .Mid(position, count) – Verwenden Sie die entsprechende Funktion "Mid(string, pos, count)"

    [JScript]

    .Length() – Verwenden Sie die entsprechende Längenfunktion der Zeichenfolgenvariablen

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Methode "toLowerCase()" oder "toUpperCase()" der Zeichenfolgenvariablen

    .Mid(position, count) – Verwenden Sie die entsprechende Methode "substr(start, [length])" der Zeichenfolgenvariablen

  3. Operationen mit reellen Zahlen

    [VBScript]

    Floor(d), Ceil(d) – Es sind keine vordefinierten Entsprechungen in VBScript vorhanden, Sie können bei Bedarf aber eigene Implementierungen erstellen

    Round(d),Round(d, i) – Verwenden Sie die entsprechende Funktion "Round(d, [i])"

    [JScript]

    Floor(d), Ceil(d) – Verwenden Sie die Methoden "floor(d)" und "ceil(d)" des Math-Objekts

    Round(d) – Verwenden Sie die round(d)-Methode des Math-Objekts

    Round(d, i) – Es ist keine vordefinierte Entsprechung in JScript vorhanden, Sie können bei Bedarf aber eine eigene Implementierung erstellen

  4. Operationen mit Textfeldern

    IsEmpty() – Vergleichen Sie den Wert des Felds "Field("fieldName").Text" mit einer leeren Zeichenfolge.

    Text() – Verwenden Sie "Field("fieldName").Text".

    Length() – Rufen Sie den Wert des Felds ab, und bestimmen Sie anschließend die Länge der resultierenden Zeichenfolge wie oben unter Punkt 2 beschrieben.

    SetText(text) – Verwenden Sie "Field("fieldName").Text = text".

  5. Operationen mit Auswahlfeldern

    IsValid() – Verwenden Sie die IsVerified-Eigenschaft

    Value() – "Field("fieldName").Value" gibt jetzt einen booleschen Wert zurück und nicht mehr 0 oder 1 wie in FormReader 6.5.

    SetValue(newValue) – Verwenden Sie "Field("fieldName").Value = newValue".

  6. Operationen mit Gruppen von Auswahlfeldern

    IsValid() – Sie können mithilfe der IsVerified-Eigenschaft die Bestimmtheit eines Felds in einer Gruppe bestimmen. Wenn Sie die Anzahl der markierten Auswahlfelder ermitteln möchten, durchlaufen Sie die Auswahlfelder in der Gruppe wie im Beispiel "Überprüfung von Gruppen von Auswahlfeldern" beschrieben (siehe Beispielskripte zum Erstellen benutzerdefinierter Regeln).

    Value() – Für das Abrufen der Anzahl markierter Auswahlfelder können Sie eine der beiden unten stehenden Methoden verwenden:

    1. Weisen Sie den Auswahlfeldern in der Gruppe Zahlennamen zu: 0, 1 usw. Anschließend enthält "Field("groupName").Value" entweder die Anzahl der markierten Auswahlfelder, die Liste der Zahlen (bei mehreren Markierungen) oder eine leere Zeichenfolge (bei keiner Markierung).
    2. Fügen Sie der Regel nur die Auswahlfelder in der angegebenen Gruppe in der richtigen Reihenfolge zu. Durchlaufen Sie anschließend die Auswahlfelder in der Gruppe wie im Beispiel "Überprüfung von Gruppen von Auswahlfeldern" beschrieben.

    Text() – Verwenden Sie "Field("groupName").Value".

    SetValue(newValue) – Um den Wert einer Gruppe von Auswahlfeldern zu ändern, müssen Sie die entsprechenden Auswahlfelder in der Gruppe festlegen oder zurücksetzen. Die Auswahlfelder müssen in der Regel enthalten sein, und das Flag für den Schreibschutz muss aktiviert sein.

Automatisierungsregeln

Um in FlexiCapture Automatisierungskomponenten verwenden zu können, die in FormReader 6.5 erstellt wurden, müssen Sie an diesen Automatisierungsregeln die folgenden Änderungen vornehmen.

  1. Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

    Public Sub Check(ByRef docObj As Object)

    2. docObj – Dies ist ein Verweis auf die zu überprüfende Dokumenteinheit.

  2. Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture 10 unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des fieldsObj-Objekts aufgeführt.

fieldsObj method | Beispiele für neuen Code in VisualBasic
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Für die Arbeit mit Tabellenspalten fügen Sie der Regel die Spaltenfelder hinzu. Die Überprüfung der richtigen Zuordnung der Spalte funktioniert wie bei allen anderen Feldern auch:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String)

Für die Arbeit mit Tabellenzellen fügen Sie der Regel die Spaltenfelder hinzu. Die Operationen mit diesen Feldern sind von der Ebene der Regel abhängig. Wenn die Regel für die Spalten- oder Tabellenebene erstellt wurde, gilt sie für jede Zeile. Dabei werden die Werte der Spalten in der überprüften Zeile verwendet (also zellenweise):

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Sie können daher eine Regel erstellen, die beispielsweise die Daten in den ersten beiden Spalten einer Tabelle verwendet, um eine dritte Spalte auszufüllen:

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Wenn die Regel für die Ebene einer Einheit erstellt wurde, die eine Tabelle enthält (Gruppe, Bereich, Dokument), müssen Sie die Spalte wie im Abschnitt "Automatisierungsregel" beschrieben durchlaufen, um auf die enthaltenen Zellen zuzugreifen.
SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' suggestions for the field

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' suggestions for the field

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String)

Auf Zellenfelder kann so wie im Abschnitt zur SetTableCellValue-Methode beschrieben zugegriffen werden.

Sie können anschließend mit den Zellen, auf die Sie zugegriffen haben, wie mit jedem anderen Feld arbeiten. Das Festlegen eines Vorschlags erfolgt z. B. folgendermaßen:

cell.Suggest cellSuggest

Die Methoden des errors Obj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des errorsObj-Objekts aufgeführt.

errorsObj method Beispiele für neuen Code in VisualBasic
SendFieldError( ErrMsg As String, Index As Integer) docObj.ErrorMessage = ErrMsg

docObj.CheckSucceeded = false

docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant )

docObj.ErrorMessage = ErrMsg
docObj.CheckSucceeded = false

Wenn die Regel für die Tabellen- oder Spaltenebene erstellt wurde, kennzeichnet das Programm alle Zellen in der überprüften Zeile als fehlerhaft, deren Felder (Spalten) der Regel hinzugefügt wurden. Um den Fokus auf eine bestimmte Zelle festzulegen, verwenden Sie folgenden Code:

docObj.FocusedField = docObj.Field("ColumnName")

Wenn die Regel für eine höhere Ebene geschrieben wurde, kennzeichnet das Programm keine Zellen und legt auch nicht den Fokus auf Zellen fest.

Migrieren des FormReader-Automatisierungsexports in den FlexiCapture-Skriptexport

Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – Dies ist ein Verweis auf das zu exportierende Dokument.

exportTools – Dies ist ein Verweis auf das ExportTools-Objekt.

Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die von der aktuellen Programmversion unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen des fieldsObj-Objekts und die neue Bedeutung für die Arbeit mit zu exportierenden Dokumenten aufgeführt:

Methods of the fieldsObj object | Mögliche Implementierungen im neuen Objektmodell
GetFieldsCount As
Integer 		Um die Anzahl der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und nehmen die Berechnung vor.
GetFieldsNames(Names As Variant) | Um die Namen der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und füllen das Array mit den Namen des Felds auf.
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant)

Der Zugriff über den Index ist nicht sinnvoll, da das neue Dokumentmodell über eine andere hierarchische Struktur verfügt.

Die Struktur der Felder kann ganz einfach durchlaufen werden (eine Beschreibung finden Sie im Beispiel "Verwenden einer externen COM-Komponente"), um das Array mit den Namen des Felds aufzufüllen.
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


Skripts für die Verarbeitung von Schnittstellenevents

In ABBYY FlexiCapture können Sie Schnittstellenevents mit Hilfe von Skripten verarbeiten. So können Sie den Betrieb der Station konfigurieren, dessen Oberfläche benutzerspezifisch einrichten, das Verhalten der Station unter bestimmten Bedingungen ändern, Benutzerbefehle implementieren usw.

Diese Skripte werden für Stapeltyptools eingesetzt.

Alle Skript-Objekte können gelesen und geschrieben werden.

Die Zugriffsrechte auf in Skripten verwendete Objekte von ControllerInterop richten sich nach dem Objektzustand. Der aktuelle Dokumentzustand wird von der Methode DocumentState() der Schnittstelle ITaskWindow zurückgegeben. Hat das Dokument den Zustand DS_Opened, dann können die ControllerInterop-Objekte des Dokuments gelesen und geschrieben werden. In anderen Zuständen sind die Objekte von ControllerInterop schreibgeschützt.

Events, die mit Hilfe von Skripten verarbeitet werden können, sowie ihre Parameter werden im Folgenden beschrieben.

Events
Objekte

Hinweis: Alle Veränderungen, die Sie an der Schnittstelle mithilfe von Skripten vornehmen, werden in folgenden Fällen verworfen: wenn Sie einen Stapeltyp eingeben, der nicht der Standardstapeltyp ist, wenn Sie einen Stapeltyp verlassen, der nicht der Standardstapeltyp ist, wenn Sie ein Projekt öffnen oder schließen, wenn Sie die Station schließen.


Event-Handler

Im Folgenden sind Events der Programm-Shell, die über Skripte gesteuert werden können, aufgeführt:

Bei Aktivierung des Dokuments
Bei Schließen des Dokuments
Bei Schließen des Projekts
Bei Schließen des Dokuments
Bei Steuerelement des Feldes aktivieren
Bei Steuerlement des Felds deaktivieren
Bei Öffnen des Dokuments
Bei Schließen des Projekts
Bei Bereichsänderung
Bei Bereichssteuerung zeichnen
Bei Textfeld Überprüfung
Bei Benutzerbefehl


Bei Aktivierung des Dokuments

Wann wird es gestartet

Das Skript wird vor Aktivierung des Dokuments im Taskfenster (durch Doppelklick, durch Auswahl von Menübefehlen usw.) gestartet.

Ist der Parameter CanOpen auf true gesetzt, wird das Dokument nach der Ausführung des Skripts im Dokumenteditor geöffnet. Ist der Parameter CanOpen auf false gesetzt, wird das Dokument nicht geöffnet.

Standardmäßig hat der Parameter CanOpen den Wert true.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | ITaskWindow | Lesen/Schreiben | Das Taskfenster
DocumentItem | IDocumentItem | Lesen/Schreiben | Das zu verarbeitende Dokument
CanOpen | IBoolean | Lesen/Schreiben | Gibt an, ob das Dokument geöffnet werden soll


Bei Schließen des Dokuments

Wann wird es gestartet

Das Skript wird gestartet, wenn das Dokument im Dokumenteditor geschlossen wird (beim Wechsel zu einem neuen Dokument oder beim Schließen des Dokumenteditors) und bevor die Änderungen bestätigt wurden.

Ist der Parameter CanClose auf false gesetzt, bleibt das Dokument geöffnet. Ist der Parameter CanClose auf true gesetzt, wird das Dokument nach der Ausführung des Skripts geschlossen.

Standardmäßig hat der Parameter CanClose den Wert true.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IDocumentEditor | Lesen/Schreiben | Der Dokumenteditor
CanClose | IBoolean | Lesen/Schreiben | Gibt an, ob das Dokument geschlossen werden soll


Bei Schließen des Projekts

Wann wird es gestartet

Das Skript wird beim Schließen des Projekts gestartet, bevor ein Abfragedialogfeld angezeigt wird. Das Abfragedialogfeld wird angezeigt, wenn der Benutzer den Vorgang vor dem Fortfahren bestätigen muss.

Ist der Parameter CanClose auf false gesetzt, bleibt das Hauptfenster geöffnet. Ist der Parameter CanClose auf true gesetzt, wird das Hauptfenster geschlossen.

Standardmäßig hat der Parameter CanClose den Wert true.

Parameter

Name | Typ | Zugriff | Description
Context | IMainWindow | Lesen/Schreiben | Das Hauptfenster
CanClose | IBoolean | Lesen/Schreiben | Gibt an, ob das Hauptfenster geschlossen werden soll


Bei Schließen des Dokuments

Wann wird es gestartet

Das Skript wird gestartet, nachdem beim Schließen eines Dokuments im Dokumenteditor die Änderungen bestätigt wurden.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IDocumentEditor | Lesen/Schreiben | Der Dokumenteditor


Bei Steuerelement des Feldes aktivieren

Wann wird es gestartet

Das Skript wird beim Aktivieren eines Felds gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IFieldControl | Lesen/Schreiben | Das aktivierte Feld

Hinweis: Sie können über dieses Skript kein anderes Feld aktivieren.


Bei Steuerlement des Felds deaktivieren

Wann wird es gestartet

Das Skript wird gestartet, bevor ein Feld aufhört, aktiv zu sein.

Das Feld, das als nächstes aktiviert wird, wird dem Skript als Eingangsparameter übergeben. Dieser Parameter ist änderbar.

Parameter

Name | Typ | Zugriff | Description
Context | IFieldControl | Lesen/Schreiben | Das Feld, das deaktiviert wird
WasModified | bool | Lesen/Schreiben | Gibt an, ob das Feld geändert wurde
NewActiveControl | IBoxedFieldControl | Lesen/Schreiben | Das Feld, das aktiviert wird. Hinweis: Die Eigenschaft hat den Wert null, wenn das Feld, das aktiviert werden soll, zu einem anderen Dokument gehört.


Bei Öffnen des Dokuments

Wann wird es gestartet

Das Skript wird beim Öffnen eines Dokuments im Dokumenteditor (beim Öffnen eines neuen Dokumentfensters oder beim Wechseln zu einem neuen Dokument) gestartet.

Wenn das Skript gestartet wird, sind alle Fenster innerhalb des Dokumenteditors bereits erstellt.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IDocumentEditor | Lesen/Schreiben | Der Dokumenteditor

Hinweis: Das Schließen des Dokuments über dieses Skript ist nicht zulässig. Die Verwendung des Befehls DocumentEditor.TaskWindow.CloseEditorWindow(); verursacht die Fehlermeldung: "System.Runtime.InteropServices.COMException (0x80004005): Dokumenteditor kann nicht geschlossen werden."


Bei Schließen des Projekts

Wann wird es gestartet

Das Skript wird gestartet, wenn das Schließen des Projekts nach der Bestätigung des Vorgangs durch den Benutzer im Abfragedialogfeld (sofern angezeigt) abgeschlossen ist.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IMainWindow | Lesen/Schreiben | Das Hauptfenster


Bei Bereichsänderung

Wann wird es gestartet

Das Skript wird vor dem Ändern eines Bereichs im Bildfenster gestartet.

Ist der Parameter AllowChangeRegion auf true gesetzt, wird der Bereich nach der Ausführung des Skripts geändert. Ist der Parameter AllowChangeRegion auf false gesetzt, wird der Bereich nicht geändert.

Standardmäßig hat der Parameter AllowChangeRegion den Wert true.

Parameter

Name | Typ | Zugriff | Description
Context | IFieldRegionControl | Lesen/Schreiben | Der Bereich
NewRegionParam | IShellRects | Lesen/Schreiben | Rechtecke des Bereichs. Bei Tabellen wird der gesamte Tabellenbereich übergeben. Hinweis: Beim Ändern eines Containers des Bereichs wird ein neuer Bereich dieses Containers zurückgegeben, und neue Bereiche der untergeordneten Elemente werden nicht zurückgegeben. Beim Ändern des Bereichs eines untergeordneten Elements wird nur der neue Bereich dieses untergeordneten Elements zurückgegeben. Bei Tabellen wird der Tabellenbereich immer zurückgegeben, auch wenn ein Spalten- oder Zeilenbereich geändert wird.
AllowChangeRegion | IBoolean | Lesen/Schreiben | Gibt an, ob der Bereich geändert werden soll.


Bei Bereichssteuerung zeichnen

Wann wird es gestartet

Das Skript wird vor dem erneuten Zeichnen des Bereichs gestartet.

Ist der Parameter DrawDefault auf true gesetzt, wird das Zeichnen des Bereichs abgebrochen. Ist der Parameter DrawDefault auf false gesetzt, wird der Bereich neu gezeichnet.

Standardmäßig hat der Parameter DrawDefault den Wert false.

Parameter

Name | Typ | Zugriff | Description
Context | IFieldRegionControl | Lesen/Schreiben | Der Bereich
DrawContext | IDrawContext | Lesen/Schreiben | Der Kontext für das Zeichnen
DrawDefault | IBoolean | Lesen/Schreiben | Gibt an, ob das Zeichnen des Bereichs fortgesetzt werden soll


Bei Rückgabe von Task

Wann wird es gestartet

Das Skript wird gestartet, wenn die Verarbeitung des aktuellen Tasks nach Bestätigung der Änderungen beendet ist.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | ITaskWindow | Lesen/Schreiben | Das Taskfenster


Bei Taskfenster erstellen

Wann wird es gestartet

Das Skript wird beim Erstellen eines Taskfensters gestartet.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | ITaskWindow | Lesen/Schreiben | Das Taskfenster


Bei Änderung des Taskfenstermodus

Wann wird es gestartet

Das Skript wird beim Ändern der Ansicht des Taskfensters gestartet (wenn der Benutzer in einen anderen Ansichtsmodus wechselt).

Parameter

Name | Typ | Zugriff | Beschreibung
Context | ITaskWindow | Lesen/Schreiben | Das Taskfenster


Bei Textfeld Überprüfung

Wann wird es gestartet

Das Skript wird gestartet, wenn das Steuerelement die Benutzerbearbeitung eines Textfelds überprüft, z. B. ein Wert aus den Vorschlägen ausgewählt wird oder wenn das Steuerelement den Fokus verliert.

Ist der Parameter CanApply auf true gesetzt, wird die Benutzereingabe nach der Ausführung des Skripts überprüft. Ist der Parameter CanApply auf false gesetzt, wird die Benutzerbearbeitung rückgängig gemacht.

Standardmäßig hat der Parameter CanApply den Wert true.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | ITextEditor | Lesen/Schreiben | Der Dokumentfeldeditor
CanApply | IBoolean | Lesen/Schreiben | Gibt an, ob Änderungen gespeichert werden sollen


Bei Benutzerbefehl

Wann wird es gestartet

Das Event tritt auf, wenn ein Benutzerbefehl aufgerufen wird (vorausgesetzt, ein entsprechendes Element wurde zum Hauptmenü oder zur Werkzeugleiste hinzugefügt).

Benutzerbefehlskennungen können im Format CI_UserCommand + <nonnegative integer> dargestellt werden.

Parameter

Name | Typ | Zugriff | Beschreibung
Context | IMainWindow | Lesen/Schreiben | Das Hauptfenster der Anwendung
CommandId | TCommandID | Lesen/Schreiben | Die Kennung des Benutzerbefehls

Hinweis: Um einen Benutzerbefehl zum Hauptmenü oder zur Werkzeugleiste hinzuzufügen, müssen Sie die entsprechenden Methoden AppendItem/InsertItem und AppendButton/InsertButton der IMenu-Schnittstelle bzw. der IToolbar-Schnittstelle verwenden. Dabei sind die Befehlskennungen CI_UserCommand oder CI_UserCommand + <nonnegative integer> zu verwenden.

Der folgende Beispielcode zeigt, wie Sie für einen Benutzerbefehl mit der Befehlskennung CI_UserCommand + 1 ein Menüelement hinzufügen.

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

IMenu menu = MainWindow.MainMenu[0].Submenu;

menu.AppendItem( userCommand1, “User command” );

Eine für einen Benutzerbefehl hinzugefügte Schaltfläche in der Werkzeugleiste bzw. ein für einen Benutzerbefehl hinzugefügtes Menüelement wird solange deaktiviert, bis ein Handler für das Event Bei Benutzerbefehl ergänzt wird.

Der folgende Beispielcode zeigt die Verarbeitung des Events On User Command.

ABBYY.FlexiCapture.ClientUI.TCommandID commandID = ( ABBYY.FlexiCapture.ClientUI.TCommandID )( CommandId );

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

if( commandID == userCommand1 ) {

<… call necessary methods here …>


Objekte

Dieser Abschnitt enthält die Beschreibung der in Skripten verwendeten Objekte, deren Eigenschaften und Methoden.

IBoolean
IBoxedFieldControl
IDocumentEditor
IDocumentItem
IDocumentItems
IDocumentsCollection
IDocumentsWindow
IDrawContext
IErrorControl
IErrorControls
IErrorsWindow
IFieldControl
IFieldRegionControl
IFieldRegionControls
IFormWindow
IImageWindow
IMainMenu
IMainWindow
IMenu
IMenuItem
IPageControl
IPageItem
IPageItems
IPagesCollection
IPoint
ISelection
IShellRational
IShellRect
IShellRects
ITaskWindow
ITextEditor
IToolbar
IToolbarButton
IToolbars
TCommandBarType
TCommandID
TDockingType
TErrorType
TSelectionType
TTaskWindowMode
TTextSize
TUserRole
TWorkWindowType


IBoolean

Worum geht es

Weitergabe boolescher Werte an die Skripte.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Value | bool | Lesen/Schreiben | Der Wert

Hinweis: Um einem Objekt vom Typ IBoolean einen Wert zuzuweisen, müssen Sie die Eigenschaft Value verwenden. Beispiel: Um dem Objekt A vom Typ IBoolean den Wert true zuzuweisen, müssen Sie A.Value = true schreiben, und nicht A = true.


IBoxedFieldControl

Worum geht es

Speichert das Steuerelement des Dokumentfelds.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Value | IFieldControl | Lesen/Schreiben | Das Feld


IDocumentEditor

Worum geht es

Repräsentiert den Dokumenteditor.

Methoden

Definition | Beschreibung
Save() : bool | Speichert das Dokument

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
Document | IDocument | Schreibgeschützt | Das zu bearbeitende Dokument
Modified | bool | Schreibgeschützt | Gibt an, ob das Dokument geändert wurde
TaskWindow | ITaskWindow | Schreibgeschützt | Das Taskfenster
ImageWindow | IImageWindow | Schreibgeschützt | Das Bildfenster
FormWindow | IFormWindow | Schreibgeschützt | Das Formularfenster
ErrorsWindow | IErrorsWindow | Schreibgeschützt | Das Fehlerfenster
FormMode | bool | Lesen/Schreiben | Gibt an, ob der Datenanzeigemodus aktiviert ist


IDocumentItem

Worum geht es

Repräsentiert ein Dokument im Dokumentfenster.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Collection | IDocumentItems | Schreibgeschützt | Die Sammlung, in der das Dokument enthalten ist
Document | IDocument | Schreibgeschützt | Das Dokument
Expanded | bool | Lesen/Schreiben | Gibt an, ob das Dokument erweitert ist
MarkedNextStage | IStageInfo | Schreibgeschützt | Die nächste Phase, an die das Dokument gesendet wird, nachdem der Task beendet wurde.
TaskWindow | ITaskWindow | Schreibgeschützt | Das Taskfenster
TaskDocument | bool | Schreibgeschützt | Gibt an, ob das Dokument zum aktuellen Task gehört
Rect | IShellRect | Schreibgeschützt | Das Rechteck des Dokuments im IDocumentsWindow
Selected | bool | Lesen/Schreiben | Gibt an, ob das Dokument ausgewählt ist
PageItems | IPageItems | Schreibgeschützt | Die Sammlung der im Dokument enthaltenen Seiten

Hinweis: Im Ansichtsmodus Miniaturansicht ist der Wert der Eigenschaft Expanded immer true. Wird die Eigenschaft auf false gesetzt, führt dies nicht zu Fehlern, doch der Wert bleibt auf true.

Hinweis: Ist das Dokument ausgeblendet (minimiert), geben die Eigenschaften DocumentItem.PageItems.Count den Wert "0" zurück.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IDocumentItems

IDocumentItems

Worum geht es

Eine Sammlung von IDocumentItem-Objekten. Repräsentiert Dokumente im Dokumentfenster.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IDocumentsCollection

IDocumentsCollection

Worum geht es

Eine Sammlung von IDocument-Objekten.


IDocumentsWindow

Worum geht es

Das Fenster zum Anzeigen von Dokumenten in der Miniaturansicht oder in der Detailansicht.

Methoden

Definition | Beschreibung
EnsureRectVisible( imageRect : IShellRect ) | Verschiebt die Bildlaufleiste, damit das angegebene Rechteck sichtbar wird
FindDocumentItem( document : IDocument ) : IDocumentItem | Ruft IDocumentItem mittels IDocument object of ControllerInterop ab
FindPageItem( page : IPage ) : IPageItem | Ruft IPageItem durch das IPage object of ControllerInterop ab

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
ClientRect | IShellRect | Schreibgeschützt | Das Rechteck des Clientbereichs (in Fensterkoordinaten). Die Koordinaten der linken oberen Ecke des Hauptfensters sind (0, 0).
TotalRect | IShellRect | Schreibgeschützt | Das Rechteck des gesamten Fensters
ScrollPos | IPoint | Lesen/Schreiben | Die Position der Bildlaufleiste
Docking | TDockingType | Lesen/Schreiben | Die Position von IDocumentsWindow im Dokumenteditor
Ratio | IShellRational | Lesen/Schreiben | Das Verhältnis der Fenstergröße zur Größe des übergeordneten Fensters
TaskWindow | ITaskWindow | Schreibgeschützt | Das Taskfenster
Items | IDocumentItems | Schreibgeschützt | Die Sammlung von Dokumenten
SelectedItems | IDocumentItems | Schreibgeschützt | Die ausgewählten Dokumente
FocusedItem | IDocumentItem | Schreibgeschützt | Die Dokumente im Fokus


IDrawContext

Worum geht es

Repräsentiert den Kontext der Zeichnung. Ermöglicht das Zeichnen elementarer geometrischer Objekte anhand von Skripts. Die Farbe wird als eine aus vier Bytes bestehende Folge angegeben: 0x00BBGGRR. Dabei stellt das Byte "BB" die Farbe Blau, das Byte "GG" die Farbe Grün und das Byte "RR" die Farbe Rot dar.

Methoden

Definition | Beschreibung
GetPixel( x : int, y : int ) : int | Ruft die Pixelfarbe (als RGB-Wert) anhand der Koordinaten ab.
SetPixel( x : int, y : int, rgbColor : int ) : int | Legt die Farbe (als RGB-Wert) des Pixels mit angegebenen Koordinaten fest. Gibt die vorherige Farbe des Pixels (als RGB-Wert) zurück.
Line( start : IPoint, end : IPoint, rgbColor : int ) | Zieht eine Linie in der angegebenen Farbe und verbindet damit die Punkte "start" und "end".
Rect( rect : IShellRect, rgbColor : int ) | Zeichnet ein Rechteck mit einem Rahmen in der angegebenen Farbe.
FillRect( rect : IShellRect, rgbColor : int ) | Zeichnet ein gefülltes Rechteck in der angegebenen Farbe.
FillAlphaRect( rect : IShellRect, rgbColor : int, alpha : int ) | Zeichnet ein gefülltes Rechteck mit einer angegebenen Transparenzstufe.

Eigenschaften

Name | Typ | Access | Beschreibung
Handle | int | Schreibgeschützt | Das Handle für den Kontext (HDC)


IErrorControl

Worum geht es

Repräsentiert ein Element in der IErrorsWindow-Liste.

Methoden

Definition | Beschreibung
Field( index : int ) : IField | Ruft das zum Fehler gehörige Feld anhand des Index des Fehlers ab

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Type | TErrorType | Schreibgeschützt | Der Typ des Fehlers
Error | string | Schreibgeschützt | Der Text des Fehlers
IsWarning | bool | Schreibgeschützt | Gibt an, ob es sich bei dem Fehler um eine Warnung handelt
FieldsCount | int | Schreibgeschützt | Die Anzahl der zum Fehler gehörenden Felder
Index | int | Schreibgeschützt | Der Index des Fehlers im Fehlerfenster


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IErrorControls

IErrorControls

Worum geht es

Eine Sammlung von IErrorControl-Objekten.


IErrorsWindow

Worum geht es

Repräsentiert das Fehlerfenster.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
DocumentWindow | IDocumentEditor | Schreibgeschützt | Der Dokumenteditor
Controls | IErrorControls | Schreibgeschützt | Die Sammlung von Steuerelementen
FocusedControl | IErrorControl | Lesen/Schreiben | Der Fehler, der gegenwärtig im Fokus ist
Docking | TDockingType | Lesen/Schreiben | Die Position von IErrorsWindow relativ zu IFormWindow im Dokumenteditor.
Ratio | IShellRational | Lesen/Schreiben | Das Verhältnis der Größe von IErrorsWindow (dies ist der Zähler) zur Gesamtgröße der Fenster IFromWindow plus IErrorsWindow (dies ist der Nenner).
ShowAssemblingErrors | bool | Lesen/Schreiben | Gibt an, ob Zusammenstellungsfehler angezeigt werden sollen
ShowRuleErrors | bool | Lesen/Schreiben | Gibt an, ob Regelfehler angezeigt werden sollen
ShowFormatErrors | bool | Lesen/Schreiben | Gibt an, ob Formatfehler angezeigt werden sollen
ShowUnmatchedRegionErrors | bool | Lesen/Schreiben | Bestimmt, ob die Fehler angezeigt werden sollen, die mit nicht zugeordneten Bereichen in Bezug stehen.


IFieldControl

Worum geht es

Repräsentiert ein Steuerelement des Dokumentfelds.

Wichtig! Das Objekt gibt für Felder, die nicht an der verteilten Überprüfung beteiligt sind, Null zurück.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
DeviceRect | IShellRect | Schreibgeschützt | Das Rechteck des Steuerelements
Field | IField | Schreibgeschützt | Das Dokumentfeld
FieldFullName | string | Schreibgeschützt | Der vollständige Name des Felds
FieldRegionControls | IFieldRegionControls | Schreibgeschützt | Die Sammlung der Feldbereiche des Dokuments. Bei Feldern ohne Bereiche wird der Wert null zurückgegeben.
First | IFieldControl | Schreibgeschützt | Das erste untergeordnete Steuerelement
FormWindow | IFormWindow | Schreibgeschützt | Das Formularfenster
IsExpandable | bool | Schreibgeschützt | Ist die Eigenschaft auf true gesetzt, kann das Feld im Formular erweitert und reduziert werden. Mithilfe dieser Eigenschaft können Sie überprüfen, ob das Feld erweiterbar ist, bevor Sie die Eigenschaft IsExpanded darauf anwenden. Für Gruppenfelder lautet die Eigenschaft true.
IsExpanded | bool | Lesen/Schreiben | Abruf von Informationen darüber, ob das Gruppenfeld erweitert ist. Hiermit können Sie das Feld reduzieren/erweitern.
IsUserReadOnly | bool | Lesen/Schreiben | Gibt an, ob das Feld bearbeitbar ist. Ist die Eigenschaft auf true gesetzt, ist die Bearbeitung des Felds nicht zulässig. Ist die Eigenschaft auf false gesetzt, richtet sich die Möglichkeit der Bearbeitung des Felds nach den Einstellungen in der Dokumentdefinition.
Last | IFieldControl | Schreibgeschützt | Das letzte untergeordnete Steuerelement
Parent | IFieldControl | Schreibgeschützt | Das übergeordnete Steuerelement
Prev | IFieldControl | Schreibgeschützt | Das vorherige Steuerelement
Next | IFieldControl | Schreibgeschützt | Das nächste Steuerelement
TextEditor | ITextEditor | Schreibgeschützt | Der Feldeditor. Bei inaktiven Feldern wird Null zurückgegeben.


IFieldRegionControl

Worum geht es

Repräsentiert einen Bereich des Dokumentfelds.

Wichtig! Das Objekt gibt für Felder, die nicht an der verteilten Überprüfung beteiligt sind, Null zurück.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
FieldRegion | IFieldRegion | Schreibgeschützt | Der Bereich eines Dokumentfelds
Page | IPageControl | Schreibgeschützt | Die Seite, die den Bereich enthält
Window | IImageWindow | Schreibgeschützt | Das Bildfenster
DeviceRect | IShellRect | Schreibgeschützt | Das Rechteck des Fensters
Visible | bool | Lesen/Schreiben | Gibt an, ob der Bereich sichtbar ist
FieldControl | IFieldControl | Schreibgeschützt | Das Steuerelement des Dokumentfelds, das dem Bereich zugeordnet ist
Parent | IFieldRegionControl | Schreibgeschützt | Der übergeordnete Bereich
First | IFieldRegionControl | Schreibgeschützt | Der erste untergeordnete Bereich
Last | IFieldRegionControl | Schreibgeschützt | Der letzte untergeordnete Bereich
Prev | IFieldRegionControl | Schreibgeschützt | Der vorherige Bereich
Next | IFieldRegionControl | Schreibgeschützt | Der nächste Bereich


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IFieldRegionControls

IFieldRegionControls

Worum geht es

Eine Sammlung von IFieldRegionControl-Objekten.


IFormWindow

Worum geht es

Repräsentiert das Formularfenster.

Methoden

Definition | Beschreibung
EnsureRectVisible( imageRect : IShellRect ) | Verschiebt die Bildlaufleiste, damit das angegebene Rechteck sichtbar wird
FindControl( field : IField ) : IFieldControl | Sucht anhand des Werts des Feldbereichs von ControllerInterop nach einem Feldsteuerelement

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
DocumentWindow | IDocumentEditor | Schreibgeschützt | Der Dokumenteditor
Control | IFieldControl | Schreibgeschützt | Das Hauptsteuerelement des Formulars
ClientRect | IShellRect | Schreibgeschützt | Das Rechteck des Clientbereichs (in Fensterkoordinaten). Die Koordinaten der linken oberen Ecke des Hauptfensters sind (0, 0).
TotalRect | IShellRect | Schreibgeschützt | Das Rechteck des gesamten Formulars. Wenn die Größe des Clientbereichs kleiner ist als die Größe des Formulars, hat das Formularfenster Bildlaufleisten.
ScrollPos | int | Lesen/Schreiben | Die Position der Bildlaufleiste
ActiveControl | IFieldControl | Lesen/Schreiben | Das aktive Steuerelement im Formular. Der Wert dieser Eigenschaft kann nicht über die Events On Field Control Activate und On Field Control Deactivate verändert werden.
TextSize | TTextSize | Lesen/Schreiben | Die Größe des Texts
Docking | TDockingType | Lesen/Schreiben | Die Position von IFormWindow relativ zu IImageWindow im Dokumenteditor.
Ratio | IShellRational | Lesen/Schreiben | Das Verhältnis der Gesamtgröße der Fenster IFormWindow plus IErrorsWindow (dies ist der Zähler) zur Größe von IDocumentEditor (dies ist der Nenner). Wenn die Eigenschaft Docking den Wert DT_Top oder DT_Bottom hat, wird das Verhältnis der y-Ausdehnungen gemessen. Ansonsten wird das Verhältnis der x-Ausdehnungen gemessen.


IImageWindow

Worum geht es

Repräsentiert das Bildfenster.

Methoden

Definition | Beschreibung
EnsureRectVisible( imageRect : IShellRect ) | Verschiebt die Bildlaufleiste, damit das angegebene Rechteck sichtbar wird

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
DocumentEditor | IDocumentEditor | Schreibgeschützt | Der Dokumenteditor
First | IPageControl | Schreibgeschützt | Die erste Seite
Last | IPageControl | Schreibgeschützt | Die letzte Seite
ClientRect IShellRect Schreibgeschützt

Das Rechteck des Clientbereichs (in Fensterkoordinaten).

Die Koordinaten der linken oberen Ecke des Hauptfensters sind (0, 0).

Wenn die Größe des Clientbereichs kleiner ist als die Größe von TotalRect, hat das Bildfenster Bildlaufleisten..

TotalRect | IShellRect | Schreibgeschützt | Das Rechteck des Bereichs, der von allen Seitenbildern belegt wird
ScrollPos | IPoint | Lesen/Schreiben | Die Position der Bildlaufleiste
Docking | TDockingType | Lesen/Schreiben | Die Position von IImageWindow relativ zu IFormWindow im Dokumenteditor
Ratio IShellRational Lesen/Schreiben

Das Verhältnis der Größe von IImageWindow (dies ist der Zähler) zur Größe von IDocumentEditor (dies ist der Nenner).

Wenn die Eigenschaft Docking den Wert DT_Top oder DT_Bottom hat, wird das Verhältnis der y-Ausdehnungen gemessen.

Anderenfalls wird das Verhältnis der x-Ausdehnungen gemessen.

ShowBWImages | bool | Lesen/Schreiben | Gibt an, ob ein Schwarzweiß-Bild gezeigt werden soll
ImageScale | IShellRational | Lesen/Schreiben | Die Bildskalierung. Der Bereich der zulässigen Werte reicht von 1/8 bis 8.
ShowToolbar | IShellRational | Lesen/Schreiben | Gibt an, ob die Werkzeugleiste angezeigt werden soll
IsDocked | bool | Lesen/Schreiben | Legt fest, ob das Fenster angedockt wird.


IMainMenu

Worum geht es

Eine Sammlung von IMenuItem-Interfaces. Repräsentiert das Menü des Hauptfensters.

Die Eigenschaft TCommandID gibt für alle Elemente dieses Menüs den Wert CI_SubMenu zurück.

Methoden

Definition | Beschreibung
Reset() | Setzt das Menü zurück (stellt die ursprüngliche Ansicht wieder her).

Wichtig! Nach Ausführung der Methode Reset wird das aktuelle Objekt vom Typ IMainMenu zerstört und ein neues Objekt generiert. Im Ergebnis werden alle Verweise auf das aktuelle Objekt ungültig, und Versuche, es zu verwenden, erzeugen einen Ausnahmefehler. Sie müssen entweder ein neues Objekt definieren oder das vorhandene Objekt neu initialisieren.

Der folgende Beispielcode zeigt die Anwendung der Methode Reset für ein Objekt. Als Resultat wird das Objekt menu ungültig, und Verweise auf das Objekt sind nicht mehr möglich.

// Neues Objekt IMainMenu definieren und initialisieren

IMainMenu menu = TaskWindow.MainWindow.MainMenu;

// Methode Reset aufrufen

menu.Reset();


IMainWindow

Worum geht es

Repräsentiert das Hauptfenster.

Methoden

Definition | Beschreibung
CommandIsEnabled( commandId: TCommandID ) : bool | Gibt für einen aktivierten Befehl „true“ und für einen deaktivierten Befehl „false“ zurück.
EnableCommand( commandId: TCommandID, bool) | Macht einen Befehl in der GUI verfügbar oder nicht verfügbar.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
MainMenu | IMainMenu | Schreibgeschützt | Das Hauptmenü
Toolbars | IToolbars | Schreibgeschützt | Die Sammlung von Werkzeugleisten
WorkWindowType | TWorkWindowType | Schreibgeschützt | Der Typ des Arbeitsfensters
TaskWindow | ITaskWindow | Schreibgeschützt | Das Taskfenster
UserRole | TUserRole | Schreibgeschützt | Die Benutzerrolle
Selection | ISelection | Schreibgeschützt | Die Auswahl


IMenu

Worum geht es

Eine Sammlung von IMenuItem-Objekten. Repräsentiert ein Menü oder ein Untermenü.

Methoden

Definition | Beschreibung
AppendItem( commandId : TCommandID, text : string ) : IMenuItem | Gibt das Objekt IMenuItem des entsprechenden Elements zurück. Alle Kennungen der Zählung TCommandID können verwendet werden (einschließlich CI_SubMenu und CI_Separator) außer bei CI_Undefined. Bei der Kennung CI_Separator wird der Parameter Text ignoriert.
Delete( index : int ) | Löscht ein Element anhand seines Index in der Sammlung.
Find( commandId : TCommandID ) : int | Findet den Index des ersten Objekts mit der angegebenen Befehls-ID in der Sammlung.
InsertItem( index : int, commandId : TCommandID, text : string ) : IMenuItem | Gibt das Objekt IMenuItem es entsprechenden Elements zurück. Alle Kennungen der Zählung TCommandID können verwendet werden (einschließlich CI_SubMenu und CI_Separator) außer bei CI_Undefined. Bei der Kennung CI_Separator wird der Parameter Text ignoriert.


IMenuItem

Worum geht es

Repräsentiert ein Menüelement.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Command | TCommandID | Schreibgeschützt | Die Befehlskennung. Bei dem Titel eines Untermenüs wird CI_SubMenu zurückgegeben. Bei einer Trennlinie wird CI_Separator zurückgegeben. Ist unter den TCommandID-Werten keine Kennung für einen Befehl vorhanden, wird CI_Undefined zurückgegeben.
Enable bool Lesen/Schreiben

Gibt an, ob Menüelemente aktiviert werden sollen.

Ist die Eigenschaft auf false gesetzt, werden alle Menüelemente mit der angegebenen Kennung (Eigenschaft Command) deaktiviert.

Ist die Eigenschaft auf true gesetzt, richtet sich die Aktivierung der Menüelemente nach der internen Logik des Programms.

Bei Trennlinien und Untermenütiteln ist die Eigenschaft immer true.

Text string Lesen/Schreiben Der Text des Menüelements.
Hinweis: Die Eigenschaft ermöglicht es nicht, den Text der Elemente in der Menüleiste zu ändern: Datei, Bearbeiten, Ansicht usw.
Submenu | IMenu | Schreibgeschützt | Das Untermenü. Wenn ein Untermenü fehlt, wird der Wert null zurückgegeben.


IPageControl

Worum geht es

Repräsentiert eine Seite im Bildfenster.

Methoden

Definition | Beschreibung
ImageToDevice( imageRect : IShellRect ) : IShellRect | Wandelt die Bildkoordinaten in Fensterkoordinaten um

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Page | IPage | Schreibgeschützt | Die Seite
ImageWindow | IImageWindow | Schreibgeschützt | Das Bildfenster
DeviceRect | IShellRect | Schreibgeschützt | Das Rechteck der Seite
First | IFieldRegionControl | Schreibgeschützt | Der erste untergeordnete Bereich
Last | IFieldRegionControl | Schreibgeschützt | Der letzte untergeordnete Bereich
Prev | IPageControl | Schreibgeschützt | Die vorherige Seite
Next | IPageControl | Schreibgeschützt | Die nächste Seite


IPageItem

Worum geht es

Repräsentiert eine Seite im Dokumentfenster.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
TaskWindow | ITaskWindow | Schreibgeschützt | Das Taskfenster
DeviceRect | IShellRect | Schreibgeschützt | Das von der Seite belegte Rechteck im IDocumentsWindow
Selected | bool | Lesen/Schreiben | Gibt an, ob die Seite ausgewählt ist
DocumentItem | IDocumentItem | Schreibgeschützt | Das Dokument, das die Seite enthält
Page | IPage | Schreibgeschützt | Die Seite


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IPageItems

IPageItems

Worum geht es

Eine Sammlung von IPageItem-Objekten.


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IPagesCollection

IPagesCollection

Worum geht es

Eine Sammlung von IPage-Objekten.


IPoint

Worum geht es

Repräsentiert einen Punkt.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
X | int | Lesen/Schreiben | X-Koordinate
Y | int | Lesen/Schreiben | Y-Koordinate


ISelection

Worum geht es

Repräsentiert die Auswahl von Dokumenten oder Seiten.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Type | TSelectionType | Schreibgeschützt | Der Auswahltyp
DocumentItems | IDocumentItems | Schreibgeschützt | Die ausgewählten Dokumente
Documents | IDocumentsCollection | Schreibgeschützt | Objekte vom Typ IDocument, die den ausgewählten Dokumenten entsprechen
PageItems | IPageItems | Schreibgeschützt | Die ausgewählten Seiten
Pages | IPagesCollection | Schreibgeschützt | Objekte vom Typ IPage, die den ausgewählten Seiten entsprechen

Hinweis: Ist das Dokument ausgeblendet (minimiert), geben die Eigenschaften DocumentItem.PageItems.Count und TaskWindow.MainWindow.Selection den Wert "0" zurück.


IShellRational

Worum geht es

Repräsentiert einen Bruch.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Numerator | int | Lesen/Schreiben | Zähler
Denominator | int | Lesen/Schreiben | Nenner


IShellRect

Worum geht es

Repräsentiert ein Rechteck.

Methoden

Definition | Beschreibung
ToString() : string | Repräsentiert ein Rechteck als eine Zeichenkette der Form "[left,top,right,bottom]"

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Left | int | Lesen/Schreiben | Linke Koordinate
Right | int | Lesen/Schreiben | Rechte Koordinate
Top | int | Lesen/Schreiben | Obere Koordinate
Bottom | int | Lesen/Schreiben | Untere Koordinate


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IShellRects

IShellRects

Worum geht es

Eine Sammlung von IShellRect-Objekten.


ITaskWindow

Worum geht es

Repräsentiert das Taskfenster.

Methoden

Definition | Beschreibung
CloseDocument( document : IDocument ) | Schließt das Dokument zur Bearbeitung vom Skript. Beim Aufruf dieser Methode wird der Dokumentstatus geändert.
CloseEditorWindow() | Schließt den geöffneten Dokumenteditor. Wichtig! Beim Schließen des Dokumenteditors gehen alle nicht gespeicherten Änderungen verloren. Beim Aufruf dieser Methode wird der Dokumentstatus geändert.
CloseTask( bool ) | Beendet den Task mit der Warnung, dass der Prozess abgebrochen wird (wenn das Argument „true“ lautet), oder ohne Warnung (wenn das Argument „false“ lautet).
DocumentState( document : IDocument ) : TDocumentState | Ruft den Zustand des Dokuments im Taskfenster ab. Hinweis: Die Methode kann nicht aus einem Sekundär-Thread aufgerufen werden.
EditDocument( document : IDocument, page : IPage ) : IDocumentEditor | Öffnet das Dokument zur Bearbeitung im Dokumenteditor. Hinweis: Wird das Dokument erfolgreich geöffnet, wird das Objekt vom Typ IDocumentEditor zurückgegeben. Anderenfalls wird der Wert null zurückgegeben. Beim Aufruf dieser Methode wird der Dokumentstatus geändert.
OpenDocument( document : IDocument ) | Öffnet das Dokument zur Bearbeitung vom Skript. Diese Methode kann auch dann aufgerufen werden, wenn das Dokument im Dokumenteditor mit Nur-Leseberechtigung geöffnet wurde. Beim Aufruf dieser Methode wird der Dokumentstatus geändert.
RejectTask( bool ) | Lehnt den Task ab mit der Warnung, dass der Prozess abgebrochen wird (wenn das Argument „true“ lautet), oder ohne Warnung (wenn das Argument „false“ lautet).

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Handle | int | Schreibgeschützt | Das Handle des Fensters
MainWindow | IMainWindow | Schreibgeschützt | Das Hauptfenster
Batch | IBatch | Schreibgeschützt | Der Stapel
Mode | TTaskWindowMode | Lesen/Schreiben | Der Ansichtsmodus
DocumentsWindow | IDocumentsWindow | Schreibgeschützt | Das Dokumentfenster
EditorWindow | IDocumentEditor | Schreibgeschützt | Der Dokumenteditor


ITextEditor

Worum geht es

Repräsentiert einen Dokumentfeldeditor.

Methoden

Definition | Beschreibung
GetSelection( startPos : int, endPos : int ) | Ruft Anfang und Ende der Auswahl ab. Ist kein Feld ausgewählt, wird den Parametern startPos und endPos der Wert "0" zugewiesen.
SetSelection( startPos : int, endPos : int ) | Legt eine neue Auswahl fest.
ApplyChanges() : bool | Übernimmt vorgenommene Änderungen.
ResetChanges() | Setzt vorgenommene Änderungen zurück.
ShowSuggestList() | Zeigt, sofern vorhanden, die Liste der Vorschläge an. Ansonsten geschieht nichts.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Control | IFieldControl | Schreibgeschützt | Das Steuerelement des Felds
Modified | bool | Schreibgeschützt | Gibt an, ob das Feld geändert wurde
Text | string | Schreibgeschützt | Der Text im Feld
FormWindow | IFormWindow | Schreibgeschützt | Das Formularfenster


IToolbar

Worum geht es

Eine Sammlung von IToolbarButton-Objekten. Repräsentiert eine Werkzeugleiste.

Methoden

Definition | Beschreibung
AppendButton( commandId : TCommandID, text : string ) : IToolbarButton

Fügt ein Werkzeugleistenelement mit der Befehlskennung commandId und dem Text Text am Ende des Menüs ein.

Jede Befehlskennung (auch CI_Separator) kann verwendet werden, mit Ausnahme von CI_SubMenu und CI_Undefined. Bei der Kennung CI_Separator wird der Parameter Text ignoriert.

Delete( Index : int ) | Löscht ein Element anhand seines Index in der Sammlung.
InsertButton( index : int, commandId : TCommandID, text : string ) : IToolbarButton

IFügt ein Werkzeugleistenelement mit der Befehlskennung commandId und dem Text Text an der Position Index der Werkzeugleiste ein.

Jede Befehlskennung (auch CI_Separator) kann verwendet werden, mit Ausnahme von CI_SubMenu und CI_Undefined. Bei der Kennung CI_Separator wird der Parameter Text ignoriert.

Find( commandId : TCommandID ) : int | Sucht nach dem Index der Schaltfläche mit einer angegebenen Kennung in der Sammlung.
Reset() | Setzt alle Änderungen zurück und stellt die ursprüngliche Ansicht der Werkzeugleiste wieder her.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Name | string | Schreibgeschützt | Der Name der Werkzeugleiste
Type | TCommandBarType | Schreibgeschützt | Der Typ der Werkzeugleiste
Visible | bool | Lesen/Schreiben | Gibt an, ob die Werkzeugleiste sichtbar ist


IToolbarButton

Worum geht es

Repräsentiert eine Werkzeugleisten-Schaltfläche.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
Command | TCommandID | Schreibgeschützt | Die Befehlskennung. Der zurückgegebene Wert darf nicht CI_SubMenu sein. Ist unter den TCommandID-Werten keine Kennung für einen Befehl vorhanden, wird CI_Undefined zurückgegeben.
Enable | bool | Lesen/Schreiben | Gibt an, ob Schaltflächen in der Werkzeugleiste aktiviert werden sollen. Ist die Eigenschaft auf false gesetzt, werden alle Schaltflächen in der Werkzeugleiste mit der angegebenen Kennung (Eigenschaft Command) deaktiviert. Ist die Eigenschaft auf true gesetzt, richtet sich die Aktivierung der Schaltflächen in der Werkzeugleiste nach der internen Logik des Programms.
Visible | bool | Lesen/Schreiben | Gibt an, ob eine Schaltfläche in der Werkzeugleiste oder eine Trennlinie sichtbar ist
Text | string | Lesen/Schreiben | Der Text auf der Schaltfläche in der Werkzeugleiste


You are here: Anhang > Verwenden von Skripten in ABBYY FlexiCapture > Skripts für die Verarbeitung von Schnittstellenevents > IToolbars

IToolbars

Worum geht es

Eine Sammlung von IToolbar-Objekten.


TCommandBarType

Beschreibung

Der Typ der Werkzeugleiste. Gilt für die IToolbar-Schnittstelle.

Typen:

  • CBT_Undefined = 0 - Nicht definierte Werkzeugleiste
  • CBT_GroupVerification = 1 - Werkzeugleiste mit Befehlen für die Gruppenüberprüfung.
  • CBT_FieldVerification = 2 - Werkzeugleiste mit Befehlen für die Feldüberprüfung.
  • CBT_Standard = 3 - Standardwerkzeugleiste.
  • CBT_Navigation = 4 - Werkzeugleiste für die Navigation, enthält Schaltflächen wie Vorheriges Dokument, Nächstes Dokument, Vorheriges zu überprüfendes Element usw.

  • CBT_Views = 5 - Werkzeugleiste zum Umschalten zwischen der Detailansicht und der Miniaturansicht.

  • CBT_Tasks = 6 - Werkzeugleiste mit Tools für die Handhabung von Tasks.

  • CBT_Setup = 7 - Werkzeugleiste mit grundlegenden Tools für die Projektverwaltung, enthält Schaltflächen wie Dokumentdefinitionen…, Stapeltypen…, Projekteigenschaften… usw.

  • CBT_ScanAndRead = 8 - Werkzeugleiste mit Tools für die Handhabung von Bildern (Import, Erkennung und andere an Bildern durchgeführte Vorgänge).

  • CBT_UserToolbar = 9 - Vom Benutzer beim Angeben von Designeinstellungen für eine Phase hinzugefügte Werkzeugleiste.


TCommandID

Beschreibung

Die Befehlskennung.

Zulässige Werte:

Collapsed Allgemein
  • CI_SubMenu - Titel eines Untermenüs
  • CI_Separator - Trennlinie
  • CI_Undefined - nicht definierte Befehlskennung
Collapsed Befehle im Menü "Datei"
  • CI_NewProject - Neues Projekt…
  • CI_BrowseProject - Projekt öffnen…
  • CI_BrowseWebProject - Projekt von Server öffnen…
  • CI_CloseProject - Projekt schließen
  • CI_UploadProject - Projekt auf Server hochladen…
  • CI_Save - Speichern
  • CI_NewBatch - Neuer Stapel…
  • CI_LoadImage - Bilder laden…
  • CI_ScanImages - Bilder scannen…
  • CI_ImportImage - Bilder importieren…
  • CI_Export - Exportieren
  • CI_ExportToFile - Exportieren von Daten in Dateien
  • CI_ExportImages - Exportieren von Bildern in Dateien
  • CI_ExportToDB - In Datenbank exportieren
  • CI_RecentFiles - Letztes Projekt öffnen
  • CI_Exit - ABBYY FlexiCapture 11 beenden
Collapsed Befehle im Menü "Bearbeiten"
  • CI_EditUndo - Rückgängig
  • CI_EditRedo - Wiederholen
  • CI_EditCut - Ausschneiden
  • CI_EditCopy - Kopieren
  • CI_EditPaste - Einfügen
  • CI_EditClear - Löschen
  • CI_MergeDocuments - Dokumente verbinden
  • CI_SplitDocuments - Dokument aufteilen
  • CI_EditSelectAll - Alles auswählen
  • CI_EditFind - Suchen…
  • CI_EditFindNext - Weitersuchen
  • CI_MoveToNextItem - Nächstes Dokument
  • CI_MoveToPreviousItem - Vorheriges Dokument
  • CI_ImageClean - Bildstörungen entfernen
  • CI_ImageInvert - Bild invertieren
  • CI_ImageMirrorHorizontal - Horizontal spiegeln
  • CI_ImageMirrorVertical - Vertikal spiegeln
  • CI_ImageRotate90 - Drehen 90° im Uhrzeigersinn
  • CI_ImageRotate270 - Drehen 90° gegen Uhrzeigersinn
  • CI_ImageRotate180 - Drehen 180°
  • CI_ImageChangeResolution - Auflösung ändern
  • CI_ExportImage - Bild speichern

Zusätzliche Befehle für eine Remote-Überprüfungsstation (Feldüberprüfung):

  • CI_EditDeleteAll - Alle Zeichen löschen
  • CI_EditInsertLineBreak - Zeilenumbruch einfügen
  • CI_VerificationMergeSymbols - Zeichen verbinden
Collapsed Befehle im Menü "Ansicht"
  • CI_ShowTestBatches - Teststapel anzeigen
  • CI_ShowWorkBatches - Stapel anzeigen
  • CI_ShowQueues - Warteschlangen anzeigen
  • CI_ShowDetails - Details einblenden
  • CI_ShowThumbnails - Miniaturansichten anzeigen
  • CI_SetupDetailsView - Details für Ansicht wählen
  • CI_DocModeImage - Dokumenteditor im Bildmodus
  • CI_DocModeForm - Dokumenteditor im Datenmodus
  • CI_DockImageOnTop - Bild oben im Dokumenteditor
  • CI_DockImageOnBottom - Bild unten im Dokumenteditor
  • CI_DocImageOnLeft - Bild links im Dokumenteditor
  • CI_DocImageOnRight - Bild rechts im Dokumenteditor
  • CI_DocImageUndocked - Abgekoppelt
  • CI_DocErrorsOnTop - Fehler oben im Dokumenteditor
  • CI_DocErrorsOnBottom - Fehler unten im Dokumenteditor
  • CI_DocErrorsOnLeft - Fehler links im Dokumenteditor
  • CI_DocErrorsOnRight - Fehler rechts im Dokumenteditor
  • CI_ImageScalePageWidth - Bild an Breite anpassen
  • CI_ImageScalePageHeight - Bild an Höhe anpassen
  • CI_ImageScaleWholePage - Optimale Bildgröße
  • CI_ImageScale400 - Bildanzeige auf 400%
  • CI_ImageScale200 - Bildanzeige auf 200%
  • CI_ImageScale100 - Bildanzeige auf 100%
  • CI_ImageScale75 - Bildanzeige auf 75%
  • CI_ImageScale50 - Bildanzeige auf 50%
  • CI_ImageScale25 - Bildanzeige auf 25%
  • CI_ImageScaleCustom - Benutzerdefinierte Bildanzeige
  • CI_ImageScaleZoomIn - Bild vergrößern
  • CI_ImageScaleZoomOut - Bild verkleinern
  • CI_TextSizeLargest - Größter Datentext
  • CI_TextSizeLarger - Großer Datentext
  • CI_TextSizeMedium - Mittlerer Datentext
  • CI_TextSizeSmaller - Kleiner Datentext
  • CI_TextSizeSmallest - Kleinster Datentext
  • CI_ViewToolbarsLayout - Werkzeugleiste im Dokumenteditor anzeigen
  • CI_ShowFormatErrorInBallon - Formatfehler im Ballon anzeigen
  • CI_ShowFormatErrorInErrorView - Formatfehler oben anzeigen
  • CI_ShowFormatErrorInFormView - Formatfehler unten anzeigen
  • CI_BWImageMode - Bilder schwarz-weiß anzeigen
  • CI_ThumbnailSizeSmallest - Kleinste Miniaturansicht
  • CI_ThumbnailSizeDefault - Standardminiaturansicht
  • CI_ThumbnailSizeLargest - Größte Miniaturansicht
  • CI_ThumbnailSizeIncrease - Miniaturansicht vergrößern
  • CI_ThumbnailSizeDecrease - Miniaturansicht verkleinern
  • CI_ViewToolbarsStandard - Werkzeugleiste 'Standard' anzeigen/ausblenden
  • CI_ViewToolbarsDocuments - Werkzeugleiste 'Anzeige' anzeigen/ausblenden
  • CI_ViewToolbarsNavigation - Werkzeugleiste 'Navigation' anzeigen/ausblenden
  • CI_ViewToolbarsScanAndRead - Werkzeugleiste 'Scannen' anzeigen/ausblenden
  • CI_ViewToolbarsProjectSetup - Werkzeugleiste 'Projektkonfiguration' anzeigen/ausblenden
  • CI_ViewToolbarsTasks - Werkzeugleiste 'Warteschlangen und Tasks' anzeigen/ausblenden
  • CI_ShowToolbar1 - Werkzeugleisten anzeigen
  • CI_ViewStatusbar - Statusleiste anzeigen/ausblenden
  • CI_ViewFullScreen - Zu Vollbild/Fenster umschalten
  • CI_Refresh - Aktualisieren
  • CI_ViewProperties - Eigenschaften anzeigen

Zusätzliche Befehle für eine Remote-Überprüfungsstation (Gruppenüberprüfung):

  • CI_ShowFieldImage - Feldbild anzeigen/ausblenden
  • CI_ShowFieldImageOnTop - Feldbild oben anzeigen
  • CI_ShowFieldImageOnBottom - Feldbild unten anzeigen
  • CI_ShrinkToFit - Feldbild auf Fenstergröße verkleinern
  • CI_ContextImageScale400 - Bildanzeige Feldbild auf 400%
  • CI_ContextImageScale200 - Bildanzeige Feldbild auf 200%
  • CI_ContextImageScale150 - Bildanzeige Feldbild auf 150%
  • CI_ContextImageScale100 - Bildanzeige Feldbild auf 100%
  • CI_ContextImageScale75 - Bildanzeige Feldbild auf 75%
  • CI_ContextImageScale50 - Bildanzeige Feldbild auf 50%
  • CI_ShowCharacterImage - Zeichenbild anzeigen
  • CI_ShowActionsToolBar - Werkzeugleiste 'Aktionen' anzeigen/ausblenden
  • CI_ShowVerInfoBar - Infoleiste 'Überprüfung' anzeigen/ausblenden
  • CI_VerificationOptions - Überprüfungseinstellungen anzeigen

Zusätzliche Befehle für eine Remote-Überprüfungsstation (Feldüberprüfung):

  • CI_ShowRecognizedText - Erkannten Text anzeigen
  • CI_ShowSymbolImagesCutting - Zeichenausschnitt anzeigen/ausblenden
  • CI_ShowSpecialSymbols - Sonderzeichen anzeigen/ausblenden
  • CI_ShowAnalogousFields - Analoge Felder anzeigen/ausblenden
Collapsed Befehle im Menü "Task"
  • CI_GetTask - Task abrufen
  • CI_ReturnTask - Task schließen
  • CI_ShowTaskComment - Taskkommentar anzeigen
  • CI_CancelTask - Task ablehnen
  • CI_DeferTask - Task aufschieben
  • CI_SendTaskToException - Sende Task zur Ausnahme
  • CI_SendTaskToRescan - Task zum erneuten Scannen senden
  • CI_SendTaskToStage - Sende Task zu Schritt
  • CI_AutoTaskReceive - Automatischer Taskempfang ein/aus
  • CI_AddDocsToMarked - Dokumente zu Markiert hinzufügen
  • CI_UnmarksDocs - Markierungen von Dokumenten entfernen
  • CI_MarkDocsToException - Dokumente als Ausnahme markieren
  • CI_MarkDocsToRescan -Dokumente für erneutes Scannen markieren
  • CI_MarkDocsToStage - Dokumente für Schritt markieren
  • CI_ViewMarkedGroupList - Liste markierter Gruppen anzeigen
Collapsed Befehle im Menü "Erkennung"
  • CI_ApplyTemplate - Analyse
  • CI_SetDocTemplate - Dokumentdefinition zuordnen
  • CI_ReadActive - Erkennung
Collapsed Befehle im Menü "Überprüfung"
  • CI_VerifyAll - Überprüfung ausführen
  • CI_GotoNextError - Nächstes zu überprüfendes Element
  • CI_GotoPrevError - Vorheriges zu überprüfendes Element
  • CI_GotoNextAssembleError - Nächstes Dokument mit Zusammenstellungsfehler(n)
  • CI_GotoPrevAssembleError - Vorheriges Dokument mit Zusammenstellungsfehler(n)
  • CI_GotoNextUnkCharacher - Nächstes nicht eindeutiges Zeichen
  • CI_GotoPrevUnkCharacher - Vorheriges nicht eindeutiges Zeichen
  • CI_GotoNextRuleError - Nächster Regelfehler
  • CI_GotoPrevRuleError - Vorheriger Regelfehler

Zusätzliche Befehle für eine Remote-Überprüfungsstation (Gruppenüberprüfung):

  • CI_VerificationConfirmAll - Alle bestätigen
  • CI_VerificationPostponeAll - Alle aufschieben
  • CI_VerificationToggleSelected - Status des ausgewählten Elements ändern
  • CI_VerificationNextPage - Nächste Überprüfungsseite
  • CI_VerificationPrevPage - Vorherige Überprüfungsseite
  • CI_VerificationClose - Überprüfung schließen

Zusätzliche Befehle für eine Remote-Überprüfungsstation (Feldüberprüfung):

  • CI_VerificationConfirmField - Feld bestätigen
  • CI_VerificationNextUncertain - Nächstes nicht eindeutiges Zeichen
  • CI_VerificationPrevUncertain - Vorheriges nicht eindeutiges Zeichen
  • CI_VerificationNextField - Nächstes Feld
  • CI_VerificationPrevField - Vorheriges Feld
Collapsed Befehle im Menü "Projekt"
  • CI_ShowTemplatesList - Liste der Dokumentdefinitionen anzeigen
  • CI_ShowBatchTypes - Liste der Stapeltypen anzeigen
  • CI_ShowImportProfiles - Liste der Importprofile anzeigen
  • CI_SwitchToAdminMode - In Administratormodus wechseln
  • CI_ProtectProject - Projekt mit Kennwort schützen
  • CI_UnprotectProject - Kennwortschutz für Projekt aufheben
  • CI_ExportProject - Projekt exportieren
  • CI_ImportProject - Projekt aktualisieren
  • CI_ViewProjectProperties - Projekteigenschaften anzeigen
  • CI_CreateTestCopy - Testkopie erstellen
  • CI_CommitTestCopy - Testkopie bestätigen
  • CI_DeleteTestCopy - Testkopie löschen
Collapsed Befehle im Menü "Extras"
  • CI_DocPriorityLowest - Niedrigste Dokumentpriorität festlegen
  • CI_DocPriorityLow - Niedrige Dokumentpriorität festlegen
  • CI_DocPriorityNormal - Normale Dokumentpriorität festlegen
  • CI_DocPriorityHigh - Hohe Dokumentpriorität festlegen
  • CI_DocPriorityHighest - Höchste Dokumentpriorität festlegen
  • CI_UpdateDocToLatestVersion - Dokumente auf neueste Version des Projekts aktualisieren
  • CI_Reanalize - Neu analysieren
  • CI_Reread - Neu erkennen
  • CI_AssembleDocuments - Dokumentzusammenstellung aktualisieren
  • CI_RecheckRules - Regeln erneut überprüfen
  • CI_CheckBatchIntegrity - Stapelintegritätsprüfung
  • CI_BatchPriorityLowest - Niedrigste Stapelpriorität festlegen
  • CI_BatchPriorityLow - Niedrige Stapelpriorität festlegen
  • CI_BatchPriorityNormal - Normale Stapelpriorität festlegen
  • CI_BatchPriorityHigh - Hohe Stapelpriorität festlegen
  • CI_BatchPriorityHighest - Höchste Stapelpriorität festlegen
  • CI_ChangeBatchType - Stapeltyp ändern
  • CI_ViewOptions - Optionen anzeigen
Collapsed Befehle im Kontextmenü eines Felds
  • CI_ExecuteCustomAction - Benutzerdefinierte Aktion ausführen
Collapsed Benutzerbefehle
  • CI_UserCommand - Benutzerbefehle
Collapsed Befehle im Menü "Hilfe"
  • CI_HelpAbbyyWebSite - ABBYY-Website
  • CI_HelpAbout - Info zu ABBYY FlexiCapture
  • CI_HelpContent - Hilfethemen
  • CI_HelpPurchaseInfo - ABBYY-Produkte erwerben
  • CI_HelpSendFeedback - Feedback senden…
  • CI_HelpTechSupport - Technischer Support


TDockingType

Beschreibung

Die Seite des Hauptfensters neben dem angegebenen Fenster.

Zulässige Werte:

  • DT_Undefined = 0 - Die Seite ist nicht definiert oder die Fenster grenzen nicht aneinander an.
  • DT_Left = 1 - Linke Seite
  • DT_Right = 2 - Rechte Seite
  • DT_Top = 3 - Obere Seite
  • DT_Bottom = 4 - Untere Seite


TDocumentState

Beschreibung

Der Status des Dokuments im Taskfenster. Gilt für die ITaskWindow-Schnittstelle.

Zulässige Werte:

  • DS_Locked = 0 - Das Dokument ist gesperrt. Es sind keine Bearbeitungsschritte im Dokument zulässig.
  • DS_Edited =1 - Das Dokument wird im Dokumenteditor bearbeitet.
  • DS_Closed = 2 - Das Dokument ist geschlossen. Es kann geöffnet und bearbeitet werden.
  • DS_Opened = 3 - Das Dokument ist geöffnet. Es kann mit Hilfe eines Skripts bearbeitet werden.
  • DS_EditedAndOpened = 4 - Das Dokument wird im Dokumenteditor bearbeitet und kann mittels eines Skripts bearbeitet werden.
  • DS_EditedAndLocked = 5 - Das Dokument wurde im Dokumenteditor geöffnet und Vorgänge dafür wurden gesperrt.

Hinweis: Wird das Dokument im Dokumenteditor bearbeitet, ändert sich sein Status zu DS_EditedAndOpened.


TErrorType

Beschreibung

Der Typ eines Fehlers. Gilt für die IErrorControl-Schnittstelle.

Zulässige Werte:

  • ET_Assembling = 0 - Zusammenstellungsfehler
  • ET_Rule =1 - Regelfehler
  • ET_Format = 2 - Formatfehler


TSelectionType

Beschreibung

Typen der Auswahl. Gilt für die ISelection-Schnittstelle.

Zulässige Werte:

  • ST_Undefined = 0 - Auswahl ist nicht definiert
  • ST_Documents = 1 - Ausgewählte Dokumente
  • ST_Pages = 2 - Ausgewählte Seiten


TTaskWindowMode

Beschreibung

Die Ansichtsmodi. Gilt für die ITaskWindow-Schnittstelle.

Zulässige Werte:

  • TWM_Undefinied = 0 - Ansicht ist nicht definiert
  • TWM_ListView = 1 - Detailansicht
  • TWM_ThumbnailView = 2 - Miniaturansicht


TTextSize

Beschreibung

Die Textgröße. Gilt für die IFormWindow-Schnittstelle.

Zulässige Werte:

  • TS_Undefined = 0 - Textgröße ist nicht definiert
  • TS_Smallest = 1 - Kleinste Textgröße
  • TS_Smaller = 2 - Kleine Textgröße
  • TS_Medium = 3 - Mittlere Textgröße
  • TS_Larger = 4 - Große Textgröße
  • TS_Largest = 5 - Größte Textgröße


TUserRole

Beschreibung

Die Rolle des Benutzers. Gilt für die IMainWindow-Schnittstelle.

Zulässige Werte:

  • UR_Undefined = 0 - Rolle ist nicht definiert
  • UR_VerificationOperator =1 - Überprüfungsoperator
  • UR_SeniorVerificationOperator = 2 - Leitender Überprüfungsoperator


TWorkWindowType

Beschreibung

Die Typen der Arbeitsfenster.

Typen:

  • WWT_Undefinied = 0 - Fenstertyp ist nicht definiert
  • WWT_Task = 1 - Taskfenster


Erstellen von maschinenlesbaren Formularen

Fragebögen, Sozialversicherungsformulare, Umfragebögen und Garantiekarten sind verschiedene Formulartypen, die zur Erfassung unterschiedlicher Informationstypen verwendet werden.

Wie unterscheiden sich Formulare von anderen Dokumenttypen?

  1. Ein Formular enthält immer eine festgelegte Anzahl Felder.
  2. Jedes Feld kann nur einen bestimmten Informationstyp enthalten. Beispielsweise enthält ein Feld "Nachname" nur Nachnamen (sofern es richtig ausgefüllt wurde), und ein Feld "Datum" enthält nur Datumsangaben.

Formulare werden verwendet, wenn Daten von einer großen Anzahl von befragten Personen erfasst werden müssen. Die manuelle Erfassung von Informationen ist langwierig und mühselig; dabei sind Tippfehler und Fehler fast unvermeidlich. Zur Automatisierung dieses Vorgangs werden maschinenlesbare Formulare verwendet.

Die automatisierte Verarbeitung von Formularen besteht aus den folgenden Stufen:

  1. Einrichten der Anwendung zur Formularverarbeitung (Erstellen einer Dokumentdefinition und Festlegen der zu erkennenden Felder).
  2. Erfassen von Formularbildern (Scannen).
  3. Verarbeiten der Formularbilder (Erkennen der Bilder und Überprüfen der extrahierten Daten).
  4. Exportieren der extrahierten Daten an ein externes Informationssystem.

Am effektivsten ist die automatische Verarbeitung von Formularen für Formulare, welche die in diesem Kapitel beschriebenen Anforderungen erfüllen.

Maschinenlesbare Formulare
Elemente maschinenlesbarer Formulare
Methoden zum Ausfüllen von Formularen
Maschinenlesbare Formulartypen
Wahl des richtigen Formulartyps
Allgemeine Anforderungen für maschinenlesbare Formulare


Maschinenlesbare Formulare

Um Informationen auf Formularen lesen zu können, muss eine Anwendung zur Formularverarbeitung:

  1. Die Position der Formularelemente bestimmen.
  2. Feldinhalte von Feldbegrenzungen, Textmarkierungen, Hintergründen und erklärenden Texten abtrennen.

Maschinenlesbare Formulare ermöglichen es dem Programm, diese Tasks auszuführen.

Um den ersten Task erfolgreich ausführen zu können, müssen die Formulare den Formularmustern oder Dokumentdefinitionen entsprechen, d. h. die Position aller Formularelemente muss auf allen Formularen desselben Typs identisch sein.

Um den zweiten Task erfolgreich ausführen zu können, müssen die Formulare für die automatische Datenerfassung gestaltet sein, so dass das Programm leicht zwischen den zu verarbeitenden Daten und nicht der Erkennung unterliegenden Formularelementen wie Feldbegrenzungen, Textmarkierungen, Hintergründen oder erklärendem Text unterscheiden kann.


Elemente maschinenlesbarer Formulare

Die folgenden Elemente können in einem Formular vorkommen:

Text
Eingabefeld
Auswahlfeld
Auswahlfeldgruppe
Anker
Zeilentrennzeichen
Formularkennung
Bild
Tabelle
Elementgruppe


Erstellung maschinenlesbarer Formulare/Text

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Text

Text

Als Text werden die beschreibenden Elemente eines maschinenlesbaren Formulars bezeichnet: Formulartitel, Feldnamen, Erklärungen usw.


Erstellung maschinenlesbarer Formulare/Eingabefeld

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Eingabefeld

Eingabefeld

Eingabe- oder Eintragsfelder sind Elemente maschinenlesbarer Formulare, in welche die ausfüllende Person Text eintragen kann. Zur Erleichterung der Eintragung können diese Felder besondere Textmarkierungen enthalten. Eingabefelder werden meist von Text zur Erläuterung der gewünschten Informationen begleitet.

Collapsed Beispiel eines Eingabefelds zeigen

PDie folgende Tabelle zeigt einige mögliche Textmarkierungsarten.

Text über einer Linie | Text wird über einer Linie eingetragen.
Buchstaben in Rahmen | Die Buchstaben werden in miteinander verbundene Rahmen eingetragen.
Buchstaben in getrennten Rahmen | Die Buchstaben werden in voneinander getrennte Rahmen eingetragen.
Buchstaben auf Kamm | Die Buchstaben werden über einem Kamm eingetragen.
Text im Rahmen | Der Text wird in einen Rahmen eingetragen.
Text im Rahmen mit Kamm | Der Text wird in einen Rahmen mit Kamm eingetragen.


Erstellung maschinenlesbarer Formulare/Auswahlfeld

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Auswahlfeld

Auswahlfeld

Auswahlfelder sind Elemente maschinenlesbarer Formulare (meistens in Form eines quadratischen Ankreuzfelds), die von der ausfüllenden Person markiert werden können.

Auswahlfelder werden normalerweise von erklärendem Text begleitet, der die Verwendung des Auswahlfelds beschreibt.

Collapsed Beispiel eines Auswahlfelds zeigen

Einige mögliche Formen von Auswahlfeldern werden in der folgenden Tabelle gezeigt.

Quadrat
Kreis
Unterstrich

Es sind auch andere Formen möglich, z.B. Polygone, Ovale u.ä.


Erstellung maschinenlesbarer Formulare/Auswahlfeldgruppe

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Auswahlfeldgruppe

Auswahlfeldgruppe

Auswahlfeldgruppen sind Elemente maschinenlesbarer Formulare, die mehrere Auswahlfelder vereinigen, von denen nur eines ausgewählt werden muss. Auswahlfeldgruppen werden normalerweise von erklärendem Text begleitet, der die Art der zu treffenden Auswahl beschreibt.

Collapsed Beispiel einer Auswahlfeldgruppe zeigen


Erstellung maschinenlesbarer Formulare/Anker

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Anker

Anker

Anker sind Elemente maschinenlesbarer Formulare, die die Zuordnung der Bilder zu Dokumentdefinitionen erleichtern und die Ausrichtung der Formulare für die automatische Verarbeitung festlegen.

Bevor das Programm mit der Erkennung des Formularinhalts beginnen kann, muss es das Formular mit seiner Dokumentdefinition abgleichen. Alle maschinenlesbaren Formulare gleichen Typs müssen einer bestimmten Dokumentdefinition entsprechen, d.h. die Position aller Formularelemente muss auf allen Formularen identisch sein. Das Programm versucht, das Formular mit Hilfe von Anzahl und Position seiner Anker mit der Dokumentdefinition abzugleichen. Falls es dem Programm gelingt, die Anker des Formulars mit den Ankern der Dokumentdefinition abzugleichen, kann es daraus die genaue Position der Felder ableiten, die die zu erkennenden Daten enthalten.

Die folgende Tabelle zeigt einige Standardanker.

.

Schwarzes Quadrat
Ecke
Kreuz
Zeitmarkierung

Um die bestmögliche Erkennungsqualität zu erreichen, empfiehlt es sich, auf Formularen Standardanker zu nutzen. In manchen Fällen können aber auch Zeilentrennzeichen, erklärender Text oder Barcodes als Anker benutzt werden. Standardanker sind jedoch zuverlässiger und sollten daher immer Ihre erste Wahl sein.


Erstellung maschinenlesbarer Formulare/Zeilentrennzeichen

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Zeilentrennzeichen

Zeilentrennzeichen

Ein Zeilentrennzeichen ist ein Element eines maschinenlesbaren Formulars, das die Gestalt einer vertikalen oder horizontalen schwarzen Linie hat.

Zeilentrennzeichen werden verwendet, um Formulare in verschiedene logische Abschnitte zu unterteilen.


Erstellung maschinenlesbarer Formulare/Formularkennung

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Formularkennung

Formularkennung

Die Formularkennung ist ein Element eines maschinenlesbaren Formulars, das zur Auswahl der richtigen Dokumentdefinition verwendet wird, falls mehrere Dokumentdefinitionen über die gleiche Ankeranordnung verfügen.

Wir empfehlen die Verwendung von Barcodes als Formularkennung

Barcodes bestehen aus vertikalen schwarzen und weißen Balken verschiedener Breite, die codierte Informationen enthalten.

Collapsed Beispiel eines Barcodes zeigen

Auch andere Elemente auf dem Formular können als Formularkennung benutzt werden.


Erstellung maschinenlesbarer Formulare/Bild

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Bild

Bild

Bilder sind Elemente maschinenlesbarer Formulare, für die kein Erkennungsprozess durchgeführt wird und die als Bilddatei exportiert werden.

Der Bereich des Formulars, wo Stempel oder Unterschrift hingehören, ist z.B. ein Bild.


Erstellung maschinenlesbarer Formulare/Tabelle

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Tabelle

Tabelle

Eine Tabelle enthält Spalten mit Elementen gleichen Typs.

Tabellenspalten können folgende Typen von Elementen enthalten:

  • Text
  • Eingabefeld
  • Datum
  • Zahl
  • Auswahlkästchen

Tabellen können eine Zeile mit Spaltenüberschriften enthalten.


Erstellung maschinenlesbarer Formulare/Elementgruppe

You are here: Anhang > Erstellen von maschinenlesbaren Formularen > Elemente maschinenlesbarer Formulare > Elementgruppe

Elementgruppe

Elementgruppe – Element eines maschinenlesbaren Formulars, das dazu dient, mehrere logisch verknüpfte Elemente in einer Gruppe zusammenzufassen.


Methoden zum Ausfüllen von Formularen

Ein Formular kann auf eine der folgenden Arten ausgefüllt werden:

  • Von Hand
  • Durch Verwendung eines Punktmatrixdruckers
  • Durch Verwendung einer Schreibmaschine
  • In einer Druckerei (dies beinhaltet Formulare, die mithilfe von Tintenstrahl- oder Laserdruckern mit einer Auflösung von mindestens 300 dpi ausgefüllt wurden)
  • Durch eine Kombination der oben genannten Möglichkeiten


Maschinenlesbare Formulartypen

Maschinenlesbare Formulare werden für die automatische Datenerfassung entwickelt, d. h. das Programm sollte leicht zwischen den zu verarbeitenden Daten und solchen nicht der Erkennung unterliegenden Formularelementen, wie Feldbegrenzungen, Textmarkierungen, Hintergründen oder erklärendem Text, unterscheiden können.

Dies kann auf zwei Arten erreicht werden:

  1. Das Formular muss so gestaltet sein, dass die Feldbegrenzungen, der Hintergrund und die Textmarkierung nach dem Scannen verschwinden oder
  2. Das Formular muss so gestaltet sein, dass die Feldbegrenzungen, der Hintergrund und die Textmarkierung nach dem Scannen klar zu erkennen sind.

Wenn die erste Möglichkeit verwendet wird, verbleiben nach dem Scannen nur die Anker, erklärender Text und die eingetragenen Daten auf dem Formular. Dadurch muss das Programm nicht die Daten von den Formularelementen trennen, was die Erkennung einfacher und zuverlässiger gestaltet.

In diesem Fall werden folgende Formulartypen verwendet: Formulare mit Blindfarben, Schwarz-Weiß-Formulare mit gerastertem Hintergrund, Schwarz-Weiß-Formulare mit gerasterten Rändern und lineare Schwarz-Weiß-Formulare.

Wenn die zweite Möglichkeit verwendet wird, verbleiben nach dem Scannen die Anker, erklärender Text und die eingetragenen Daten sowie Textmarkierungen und Feldbegrenzungen auf dem Formular. Das Programm wird nach Informationen suchen, die von Feldbegrenzungen und Textmarkierungen umgeben sind. Wenn diese Formularelemente fehlen, wird die Erkennungsqualität erheblich beinträchtigt.

In diesem Fall werden lineare Schwarz-Weiß-Formulare verwendet.


Blindfarbformulare (Color Dropout)

Blindfarbformulare haben einen hellfarbigen Hintergrund, wobei weiße Rechtecke als Zeichenfelder, Auswahlfelder usw. dienen.

Ein Beispiel sind graue Blindfarbformulare, deren Hintergrund grau ist.

Zu den Blindfarbformularen gehören auch solche Formulare, bei denen nur die Ränder der Elemente farbig sind.

Zeichenfelder sind kleine Rechtecke, in die nur ein Zeichen eingegeben wird (z.B. ein Buchstabe oder eine Zahl). Die Farbe des Hintergrunds ist von großer Bedeutung, da sie beim Scannen verschwinden soll. Meistens ist der Hintergrund ein helles Rot-Orange oder Grün. Die Liste der empfohlenen Farben finden Sie unter Empfohlene Farben für Blindfarbformulare.

Collapsed Beispiel eines Blindfarbformulars zeigen

Idealerweise sollten alle Formularelemente mit Ausnahme der Anker beim Scannen verschwinden, so dass nur die zu erkennenden Feldinhalte auf dem Formularabbild zurückbleiben.

Erklärende Texte können entweder beibehalten (bei schwarzem Druck) oder zusammen mit dem Hintergrund herausgefiltert werden. Wenn die erklärenden Texte beim Scannen verschwinden sollen, müssen Sie dieselbe Farbe wie der Hintergrund des Formulars haben, aber einen höheren Sättigungsgrad.

Bei der Entscheidung, ob die erklärenden Texte in Schwarz oder in der Hintergrundfarbe gedruckt werden sollen, ist zu berücksichtigen:

  • Die Bilddatei wird größer, wenn die erklärenden Texte beibehalten werden.
  • Zwischen schwarz gedruckten erklärenden Texten und anderen Elementen des Formulars sollte ein Abstand von wenigstens 1,5-2 mm bestehen. Der Abstand zwischen erklärendem Text und dem entsprechenden Auswahlfeld muss mindestens 2/3 der Auswahlfeldgröße betragen. Falls die erklärenden Texte in der Hintergrundfarbe gedruckt werden, sind die Abstände zu anderen Elementen des Formulars von geringerer Bedeutung.

Formulare mit schwarz gedruckten erklärenden Texten sind besser lesbar. Wir empfehlen, erklärende Texte in Schwarz zu drucken, besonders dann, wenn das Formular keine Anker enthält.

Tipp. Beachten Sie bei der Erstellung einer Dokumentdefinition für ein Formular, bei dem die erklärenden Texte in der Hintergrundfarbe gedruckt sind, dass dieses als Farb- oder Graustufenbild gescannt werden sollte, damit erklärende Texte und Elemente deutlich erkennbar sind.

Blindfarbformulare müssen mit einer Farblichtlampe oder einem Filter gescannt werden. Die Farbe der Lampe wird in Abhängigkeit von der Hintergrundfarbe ausgewählt.

Formulare mit rotem oder grünem Hintergrund müssen mit einer der folgenden Methoden gescannt werden:

  • Verwendung von Farbfiltersoftware mit einem Farbscanner
  • Verwendung einer Rot- oder Grünlichtlampe (Hardware-Farbfilter) mit einem Schwarzweiß-Scanner
  • Verwendung einer weißen Lampe und eines roten oder grünen Filters mit einem Schwarzweiß-Scanner (die Filterqualität ist in diesem Fall wesentlich geringer: Der Hintergrund wird u.U. nicht vollständig beseitigt, oder es gehen Feldinhalte verloren), oder
  • Verwendung einer weißen Lampe ohne Filter mit einem Schwarzweiß-Scanner

    Beim Scannen mit einer weißen Lampe können manche hellen Hintergründe auch ohne Filter entfernt werden: die geringe Sättigung des Hintergrunds sorgt dafür, dass er beim Scannen verschwindet. In diesem Fall muss durch Probieren für jeden Scanner eine geeignete Farbe und Sättigung ermittelt werden.

Hinweis: Manche Farbscanner verfügen auch über Software-Filterung zur Beseitigung blauer Farbtöne. Von der Verwendung von Blautönen wird jedoch abgeraten, da die Formulare vermutlich nicht nur mit schwarzer, sondern auch blauer Tinte ausgefüllt werden. Mit blauer Tinte geschriebene Feldinhalte würden dann verschwinden.

Wahl der richtigen Farbe

Rot-orange Farben sind gegenüber Grün zu bevorzugen, da sie im größtmöglichen Kontrast zu Blau stehen. Dies gewährleistet bei mit blauer Tinte ausgefüllten Formularen eine bessere Scan- und Erkennungsqualität.

Unter Empfohlene Farben für Blindfarbformulare sind die für die Formularverarbeitung empfohlenen Farben zusammengestellt, d.h. diejenigen, die mit fast jedem Scanner ausgeblendet werden können. Eine Liste geeigneter Blindfarben für ein bestimmtes Scannermodell (im Pantone- oder einem anderen Format) kann auch über den Hersteller oder Verkäufer des Geräts bezogen werden.


Schwarz-Weiß-Formulare mit gerastertem Hintergrund

Felder auf solchen Formularen sind einfache leere Flächen (normalerweise Rechtecke) vor einem gerastertem Hintergrund. Der Hintergrund wird aus einzelnen Punkten zusammengesetzt. Die empfohlene Größe der Punkte beträgt nicht mehr als 0,1 mm und der Abstand zwischen den Punkten beträgt ca. 1 mm. Die Größe der Punkte und der Abstand zwischen den Punkten ist sehr wichtig, da ein gerasterter Hintergrund vor allem während des Entfernens von Störungen entfernt wird und nicht während des Scannens. Das Programm behandelt die Punkte als überflüssige Elemente und löscht sie. Die Punkte dürfen daher auf den gescannten Bildern nicht verschmelzen.


Schwarz-Weiß-Formulare mit gerasterten Rändern

Diese Formulare haben keinen Hintergrund. Alle Feldränder (Zeichen- und Auswahlfelder sowie andere Elemente) bestehen aus gerasterten Linien, d.h Reihen kleiner schwarzer Punkte. Die Rasterpunktgröße liegt meist im Bereich 0,39-0,5 pt. Die empfohlene Größe ist 0,39 pt, wobei der Abstand der Rasterpunkte mindestens das Fünffache der Punktgröße betragen sollte. Die Größe der Punkte und Abstände ist von entscheidender Bedeutung, da gerasterter Hintergrund nicht beim Scannen, sondern vorwiegend beim Entfernen von Störungen beseitigt wird: Das Programm behandelt die Punkte als überflüssige Elemente und löscht sie. Die Punkte dürfen daher auf den gescannten Bildern nicht verschmelzen.


Lineare Schwarz-Weiß-Formulare

Diese Formulare haben normalerweise keinen Hintergrund. Alle Feldränder (Zeichen- und Auswahlfelder sowie andere Elemente) bestehen aus durchgängigen schwarzen Linien. Die Feldränder verschwinden beim Scannen und Entfernen von Störungen nicht.

Hinweis: Formulare dieses Typs müssen sehr ordentlich ausgefüllt werden. Falls die Formulare achtlos ausgefüllt werden, können sich Buchstaben und Feldränder überlappen, was die Erkennungsqualität reduziert. Grund dafür ist, dass es für das Programm äußerst schwierig ist, Text und Ränder zu unterscheiden, die sich überlappen. Am besten ist es, wenn der eingetragene Text die Felder nicht berührt.


Wahl des richtigen Formulartyps

Zusätzlich zu den Anforderungen an Layout und Verarbeitung, die jeder Formulartyp stellt, sind bei der Wahl eines Formulartyps weitere Kriterien zu berücksichtigen. Dazu gehören Druckkosten und Druckverfahren, die Anzahl der erforderlichen Kopien, die resultierende Bildgröße, Scanmodi, der erforderliche Grad der Erkennungsgenauigkeit, die Geschwindigkeit der Formularverarbeitung, das gesamte Aussehen der Formulare, wie ordentlich sie ausgefüllt werden usw. Die Vor- und Nachteile eines jeden Formulartyps sind in der nachfolgenden Tabelle aufgeführt.

Kriterien | Blindfarbformular (Color Dropout) |  | Schwarz-Weiß-Rasterformular |  | Lineares Schwarz-Weiß-Formular
 | Nachteil | Vorteil | Nachteil | Vorteil | Nachteil | Vorteil
Kompliziertheit des Layouts |  | Mit jedem beliebigen Grafikeditor leicht zu entwerfen. | Texteditoren bieten nur in eingeschränktem Maß Funktionen zum Entwurf dieses Formulartyps an. Ausschlaggebend ist die Größe der Rasterpunkte. |  |  | Mit jedem beliebigen Grafikeditor leicht zu entwerfen
Druck | Große Mengen an qualitativ hochwertigen Formularen können hausintern nur schwierig gedruckt werden. |  |  | Hausintern leicht auszudrucken. |  | Hausintern leicht auszudrucken.
Druckkosten | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Schwarz-Weiß-Formularen höher. |  |  | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Blindfarbformularen geringer. |  | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Blindfarbformularen geringer
Bildgröße |  | Die Bilddateien sind kleiner. | Die Bilddateien sind größer. |  | Die Bilddateien sind größer. |
Scanmodus | Nur spezielle Scanmodi (Farbfilter) können verwendet werden. |  | Der Bereich von Helligkeits- und Kontrasteinstellungen ist eingeschränkt. |  | Der Bereich von Helligkeits- und Kontrasteinstellungen ist eingeschränkt. |
Verarbeitungsgeschwindigkeit |  | Die mittlere Verarbeitungsgeschwindigkeit ist höher. | Die mittlere Verarbeitungszeit ist länger, weil Störungen aus den Bildern entfernt werden müssen. |  | Fehler sind wahrscheinlicher, wenn Buchstaben verschmolzen sind oder Feldränder überlappen. |
Erkennungsqualität |  | Hohe Erkennungsqualität. |  | Hohe Erkennungsqualität. | Die Erkennungsqualität hängt größtenteils davon ab, wie ordentlich das Formular ausgefüllt wurde. | Wenn das Formular richtig ausgefüllt wurde, ist die Erkennungsqualität hoch.
Position von erklärendem Text |  | Erklärender Text kann beliebig, beispielsweise innerhalb von Feldern, angeordnet werden (solange er mit derselben Farbe wie der Formularhintergrund gedruckt wird). | Erklärender Text und andere Formularelemente müssen auf dem Formular sorgfältig angeordnet werden. |  | Erklärender Text und andere Formularelemente müssen auf dem Formular sorgfältig angeordnet werden. |
Aussehen und Lesbarkeit des Formulars | Niedriger Kontrast des Hintergrundes und des erklärenden Textes können die Lesbarkeit beeinträchtigen. | Ästhetisch ansprechend | Weniger auffälliges Design. Geringere Lesbarkeit. |  | Weniger auffälliges Design. | Gute Lesbarkeit.
Genauigkeit beim Ausfüllen |  | Weniger empfindlich gegen ein Überlappen von Text und Feldrändern. | Kleine Buchstaben müssen sehr sorgfältig geschrieben werden und groß genug sein, um nicht als überflüssige Elemente entfernt zu werden. | Weniger empfindlich gegen ein Überlappen von Text und Feldrändern. | Sehr empfindlich gegen ein Überlappen von Text und Feldrändern. |


Allgemeine Anforderungen für maschinenlesbare Formulare

Wir wollen jetzt einen Blick auf die allgemeinen Anforderungen werfen, die ein Formular erfüllen muss, um maschinenlesbar zu sein.

Anforderungen an den Formularhintergrund
Ankeranforderungen
Anforderungen für Auswahlfelder
Anforderungen für die Textmarkierung
Anforderungen an die Elementanordnung
Anforderungen an die Druckqualität
Anforderungen für das Ausfüllen der Formulare


Anforderungen an den Formularhintergrund

  1. Verwenden Sie nach Möglichkeit Formulare mit Blindfarben (Color Dropout) oder mit gerasterten Feldrändern.

  2. Wählen Sie bei der Erstellung eines Formulars eine Farbe, die beim Scannen entfernt wird. Siehe Liste der empfohlenen Farben unter Empfohlene Farben für Blindfarbformulare.

  3. Achten Sie darauf, dass zwischen Erklärungstext und Feldinhalt immer ein Freiraum besteht. Bei Blindfarbformularen empfehlen wir, alle Informationen in der Farbe des Formularhintergrunds zu drucken (außer, wenn der Erklärungstext als Anker anstatt von oder zusammen mit schwarzen Quadraten verwendet wird). Wenn Sie Informationen in der Hintergrundfarbe drucken, können Sie sie überall auf dem Formular positionieren, auch innerhalb der Formularfelder.
  4. Verwenden Sie keine Blautöne für Formulare, die von Hand ausgefüllt werden sollen. Ein blauer Hintergrund könnte nur schwer von blauer Tinte unterschieden werden, die gewöhnlich zum Ausfüllen der Formulare verwendet wird. Dies würde die Erkennungsqualität beeinträchtigen.


Ankeranforderungen

  1. Zur Verwendung in maschinenlesbaren Formularen werden Standardanker empfohlen (d. h. schwarze Quadrate, Ecken, Kreuze). Die empfohlene Anzahl der Anker beträgt fünf: vier Anker in jeder Ecke des Formulars (sie sollten ein Rechteck bilden, wenn imaginäre Linien zwischen jedem Paar gezeichnet werden) und ein quadratischer Anker auf einer der Seiten des imaginären Rechtecks.

  2. Wenn aus irgendwelchen Gründen keine Standardanker verwendet werden können, empfehlen wir die folgenden Elementkombinationen zur Verwendung als Anker:
    a) mindestens zwei senkrechte Zeilentrennzeichen und zwei waagerechte Zeilentrennzeichen
    b) mindestens vier Textelemente und ein Formularidentifizierungselement
    c) es sind auch andere Kombinationen möglich

  3. Der Abstand zwischen dem Rand eines Ankers und dem nächstgelegenem Formularelement sollte mindestens 3 mm betragen.

  4. Der Abstand zwischen einem Anker und dem Seitenrand sollte mindestens 8 mm betragen.

  5. Anker sollten mit einer dunklen Farbe gedruckt werden (es wird schwarz empfohlen), so dass diese während des Scannes nicht verschwinden

Zusätzlich zu den oben gelisteten allgemeinen Anforderungen hat jeder Ankertyp seine eigenen spezifischen Anforderungen:

Anforderungen für schwarze Quadrate

Schwarze Quadrate auf demselben Formulartyp sollten alle dieselbe Größe haben, d. h. zwischen 4 × 4 mm und 8 × 8 mm. Die empfohlene Größe beträgt 5 × 5 mm. Rechtecke sind nicht erlaubt.

Anforderungen für Kreuze und Ecken

  1. Die Größe eines imaginären Quadrats, das um diesen Ankertyp gezeichnet werden könnte, muss zwischen 4 × 4 und 8 × 8 mm betragen. Die empfohlene Größe beträgt 5 × 5 mm.
  2. Die Ankergröße eines Typs muss innerhalb eines Formulars dieselbe sein.
  3. Alle Ankerseiten müssen dieselbe Größe haben.
  4. Die für Anker auf demselben Formular verwendete Linienbreite muss einheitlich sein und zwischen 0,3 und 1 mm liegen. Die empfohlene Breite beträgt 0,5 mm.

Anforderungen für Text (wenn als Anker verwendet)

Die Schriftgröße sollte mindestens 7 pt betragen (Titelzeilen – mindestens 14 pt).

Anforderungen für Zeilentrennzeichen (wenn als Anker verwendet)

Die Linienbreite sollte mindestens 1 pt betragen. Die empfohlene Breite beträgt 1 – 1,5 pt.

Anforderungen für Barcodes (wenn als Anker verwendet)

  1. Die Breite des Barcodes (der Abstand zwischen den äußeren Strichen) sollte mindestens 47-50 mm betragen.
  2. Die Höhe des Barcodes sollte mindestens 12-15 mm betragen (ohne Ziffern).
  3. Die Ausrichtung des Barcodes (Richtung der Striche) sollte mit der Seitenausrichtung übereinstimmen (es wird empfohlen, die Seiten in der Richtung der Striche zu scannen).
  4. Es wird das Barcodeformat EAN 13 empfohlen.
  5. Der empfohlene Abstand zwischen einem Barcode und einem anderen Formularelement muss mindestens 10 mm betragen.


Anforderungen für Auswahlfelder

  1. Als Feldgrößen werden 3,5×3,5 mm, 4×4 mm, 4,5×4,5 mm und 5×5 mm empfohlen (falls kreisförmige Auswahlfelder benutzt werden, müssen sie in das Quadrat einer der empfohlenen Größen passen).
  2. Als Linienstärke für den Rand der Auswahlfelder empfehlen wir 0,4 mm (unabhängig von der Feldgröße).


Anforderungen für die Textmarkierung

Rasterpunktgröße:

  1. Falls die Feldränder aus Rasterpunkten bestehen, muss die Stärke der Rasterlinie (d.h. die Rastergröße) 0,39 pt sein.

  2. Der optimale Abstand der Rasterpunkte beträgt das Fünffache ihrer Größe.

    Wichtig! Die Punkte, die am wahrscheinlichsten miteinander verschmelzen, sind diejenigen in den Ecken der Zeichenfelder.

    Tipp. Falls Ihre Software keine Möglichkeit zur Einstellung des Rasterpunktabstands bietet, müssen Sie einen Linienstil wählen, bei dem zwischen den Punkten ausreichender Abstand besteht. Ansonsten können die Punkte auf dem gescannten Bild verschmelzen und nach der Störungsbeseitigung zurückbleiben. Dies liegt daran, dass große Punkte vom OCR-System nicht als überflüssige Elemente interpretiert und folglich nicht bereinigt werden.

Zeichenfeldgröße:

  1. Die empfohlene Größe der Zeichenfelder ist 4×5 mm; bei Verwendung kleinerer Felder wird von der ausfüllenden Person eine sehr genaue Schreibweise verlangt, die nicht leicht zu erreichen ist. Zu große Zeichenfelder sind ebenfalls nicht zu empfehlen, da sie zur Verwendung übergroßer Buchstaben ermutigen würden. Idealerweise sollte die Zeichenfeldgröße auf die durchschnittliche Buchstabengröße abgestimmt sein.

  2. Der Abstand zwischen den Feldlinien sollte nicht weniger als 2,5-3 mm betragen und der Abstand zwischen benachbarten Zeichenfeldern derselben Linie nicht weniger als 1-1,2 mm.

    Collapsed Beispiel von Zeichenfeldern zeigen

Linienstärke:

  1. Falls die Feldränder aus schwarzen Linien bestehen („Text im Rahmen“, „Buchstaben in getrennten Rahmen“ oder „Buchstaben in Rahmen“), sollte die Linienstärke 1 pt sein.

    Collapsed Beispiel schwarzer Linien zeigen

Kämme:

  1. Der empfohlene Abstand zwischen den Kammzinken beträgt 5 mm.

  2. Wenn zwei Kämme untereinander positioniert sind, sollte der Abstand zwischen ihren horizontalen Linien nicht weniger als 7,5-8 mm betragen.

  3. Die Zinkenhöhe sollte etwa 0,9-1,2 mm betragen.

  4. Die Stärke sowohl der Kammzinken als auch der horizontalen Linie sollte 1 pt betragen.

  5. Falls Rahmen mit Kamm verwendet werden, sollte ein Mindestabstand zwischen den Rahmen von 2,5-3 mm bestehen.

Collapsed Beispiel eines Kamms zeigen


Anforderungen an die Elementanordnung

  1. Achten Sie darauf, ausreichend große Ränder auf Ihrem Formular zu lassen. Andernfalls könnten Elemente, die sich zu nahe am Seitenrand befinden, beim Scanvorgang ausgelassen werden und Daten verloren gehen.
  2. Der Abstand zwischen benachbarten Formularelementen sollte nicht weniger als 2 mm betragen.
  3. Der Abstand zwischen Auswahlfeldern und erklärendem Text sollte mindestens 2/3 der Auswahlfeldgröße betragen.
  4. Achten Sie darauf, dass der erklärende Text nicht die Ränder der Eintragsfelder überschneidet.
  5. Falls der erklärende Text in schwarzer Tinte gedruckt wird, sollten Sie darauf achten, dass ein Abstand von wenigstens 1,5-2 mm zwischen dem erklärenden Text und anderen Elementen besteht. Dieser Abstand ist weniger wichtig, wenn der erklärende Text in der Hintergrundfarbe gedruckt wird.


Anforderungen an die Druckqualität

Beachten Sie beim Drucken leerer Formulare die folgenden Anforderungen:

  1. Die Formulare müssen entweder professionell oder mit einem Drucker gedruckt werden. Bei Farbformularen empfehlen wir Ihnen professionellen Druck. Falls dies nicht möglich ist, testen Sie die Formularfarbe mit einem Scanner, bevor Sie eine größere Anzahl drucken.
  2. Alle Exemplare des Formulars müssen vom selben Quelldokument gedruckt werden, damit sich die Felder auf jedem Formular an derselben Position befinden.
  3. Der Rand (d.h. der Abstand zwischen Blattrand und nächsten Formularelement) muss mindestens 8 mm breit sein (12 mm empfohlen).
  4. Die lineare Abweichung der Formularelemente darf 0,15 % nicht übersteigen (d.h. 0,5 mm bei A4-Seiten).
  5. Verwenden Sie eine Auflösung von mindestens 600 dpi, falls Sie Ihre Formulare mit einem Drucker drucken.
  6. Es empfiehlt sich, alle Formulare mit demselben Drucker oder mit mehreren Druckern desselben Modells zu drucken.

Tipp. Wir raten davon ab, für die maschinelle Verarbeitung bestimmte Dokumente mit Kopiergeräten zu vervielfältigen. Bei Verwendung solcher Geräte kann es zu leichten Abweichungen der Größe der Elemente oder ihrer Anordnung kommen. Z.B. können die Ränder von Tabellen und Eintragsfeldern breiter ausfallen oder die Farbtiefe verändert und so die Erkennungsqualität beeinträchtigt werden.


Anforderungen für das Ausfüllen der Formulare

Schreibgeräte und Tinte

Formulare werden am besten ordentlich in Großbuchstaben mit einem schwarzen Kugelschreiber, Gelstift oder Kapillarfüller ausgefüllt (dunkles Blau und Violett sind auch akzeptabel). Filzstifte und andere Stifte mit weichem Kopf sind nicht zu empfehlen, da breite Schreiblinien die Erkennung erschweren. Am schwierigsten ist die Erkennung bei Formularen, die mit Bleistift oder heller Tinte ausgefüllt wurden.

Buchstabengröße und -stil

Für optimale Erkennungsresultate sollte ein Formular mit großen Druckbuchstaben ausgefüllt werden. Die Buchstaben müssen alle Zeichenfelder ausfüllen, dürfen aber nicht über die Feldränder hinausgehen.

Falls die Zeichenfelder auf dem Formular visuell kenntlich gemacht werden (d.h. eine der folgenden Textmarkierungsarten verwendet wird: Buchstaben in Rahmen, Buchstaben in getrennten Rahmen), wird die ausfüllende Person die Buchstaben mit geringerer Wahrscheinlichkeit miteinander verbinden.

Die folgenden Textmarkierungsarten stellen größere Anforderungen an das Erkennungsverfahren: Text im Rahmen mit Kamm, Buchstaben auf einem Kamm. In diesen Fällen wird nur die Breite des Zeichenfelds vorgegeben. Das Fehlen von Seitenrändern erlaubt das Verbinden der einzelnen Buchstaben. Im Fall des Kamms ohne Rahmen können die Buchstaben zu groß oder zu klein geschrieben werden.

Falls Text in Rahmen oder Text über Linien verwendet wird, liegt keine erkennbare Beschränkung der Schriftzeichenbreite vor. Die Buchstaben können miteinander verbunden werden, was die Erkennungsqualität beeinträchtigt. Im Fall von Text über einer Linie gibt es auch keine Beschränkung der Schriftzeichenhöhe. Diese Markierungsart wird daher nicht für Formulare empfohlen, die eine hohe Erkennungsgenauigkeit verlangen.

Eine weitere wichtige Anforderung ist, dass die Buchstaben nicht die Feldränder überlappen. Dies ist weniger entscheidend bei Blindfarben- und Schwarzweißraster-Formularen, bei denen die Feldränder während des Scannens und Entfernens von Störungen verschwinden. Wenn sich die Buchstaben jedoch auf linearen Schwarzweiß-Formularen mit den Rändern überlappen, kann dies zu einer erheblichen Verschlechterung der Erkennungsqualität führen.

Beispiel

Wir empfehlen, einen Hinweis ähnlich dem Folgenden auf dem Formular anzubringen, um das korrekte Ausfüllen zu unterstützen.


Empfohlene Farben für Blindfarbformulare

Die folgende Tabelle zeigt Beispiele zu filternder Farben und die entsprechenden Pantone-Nummern. Diese Hintergrundfarben verschwinden beim Scannen der Formulare:

  • Verwendung eines beliebigen Scanners

  • Verwendung eines Farbscanners mit softwaregesteuertem Rotfilter oder eines Schwarzweiß-Scanners zusammen mit einer Rotlichtlampe oder einem Rotfilter.


Tastaturbefehle

You are here: Anhang > Tastaturbefehle

Tastenkombinationen

In diesem Abschnitt werden die Tastenkombinationen aufgeführt, die in verschiedenen Fenstern des Programms verwendet werden können. Das Arbeiten mit Tastenkombinationen ist zeitsparend und vereinfacht die Arbeit.

Tastenkombinationen für die Projektkonfigurationsstation
Tastenkombinationen für die Verifizierungsstation
Tastenkombinationen für die Datenverifizierungsstation
Tastenkombinationen im Hauptfenster
Tastenkombinationen für den Dokumentdefinitionseditor
Tastenkombinationen für die Gruppenüberprüfung
Tastenkombinationen für die Feldüberprüfung


Tastenkombinationen im Hauptfenster

You are here: Anhang > Tastaturbefehle > Tastaturbefehle im Hauptfenster

Tastenkombinationen im Hauptfenster von ABBYY FlexiCapture

Menü | Option | Tastenkombination
Datei | Neues Projekt… | Strg+Umschalt+N
 | Projekt öffnen… | Strg+Umschalt+O
 | Speichern | Strg+S
 | Neuer Stapel… | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Bilder importieren… | Strg+I
 | Exportieren | Strg+U
 | Exportieren in Daten in Dateien… | Alt+Umschalt+S
 | Exportieren in Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Teststapel | Strg+Umschalt+B
 | Arbeitsstapel | Strg+B
 | Details | Alt+1
 | Miniaturansichten | Alt+2
 | Bildmodus | Strg+1
 | Datenmodus | Strg+2
 | Vergrößern | Strg+Num+
 | Verkleinern | Strg+Num-
 | Miniaturansicht: Vergrößern | Strg+Umschalt+Num+
 | Miniaturansicht: Verkleinern | Strg+Umschalt+Num-
 | Vollbild | F11
 | Aktualisieren | F5
 | Objekteigenschaften | Alt+Eingabetaste
Erkennung | Analyse | Strg+E
 | Dokumentdefinition zuordnen… | Alt+Umschalt+E
 | Erkennung | Strg+R
Überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächstes Dokument mit Zusammenstellungsfehler(n) | F9
 | Vorheriges Dokument mit Zusammenstellungsfehler(n) | Umschalt+F9
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Projekt | Dokumentdefinitionen… | Strg+T
 | Stapeltypen… | Strg+Umschalt+T
 | Bildimportprofile… | Strg+Umschalt+I
Extras | Auf neueste Version aktualisieren | Alt+Umschalt+U
 | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
 | Stapelintegritätsprüfung | Strg+Umschalt+E
Hilfe | Hilfethemen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste
 | Registrierungsparameter | Strg+P


Tastenkombinationen für den Dokumentdefinitionseditor

Menü | Option | Tastenkombination
Dokumentdefinition | Seiten hinzufügen… | Strg+P
 | Dokumentbereich hinzufügen… | Strg+Alt+S
 | Eigenschaften der Dokumentdefinition… | Strg+T
 | Speichern | Strg+S
 | Schließen | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Bereich löschen | Shift+Entf
 | Alles auswählen | Strg+A
 | Bereiche nach Typ auswählen… | Strg+Umschalt+A
 | Felder nach Typ auswählen… | Strg+Umschalt+F
 | Feld erstellen - Text | Alt+Umschalt+T
 | Feld erstellen - Auswahlfeld | Alt+Umschalt+C
 | Feld erstellen - Auswahlfeldgruppe | Alt+Umschalt+M
 | Feld erstellen - Barcode | Alt+Umschalt+B
 | Feld erstellen - Bild | Alt+Umschalt+P
 | Feld erstellen - Tabelle | Alt+Umschalt+L
 | Feld erstellen - Gruppe | Alt+Umschalt+G
 | Gruppe | Strg+G
 | Gruppierung aufheben | Strg+Umschalt+G
 | Text aus Bild kopieren… | Strg+Alt+C
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Statische Elemente | Strg+1
 | Feldbereiche | Strg+2
 | Dokumentstruktur anzeigen | Alt+F1
 | Dokumentstruktur - Felder | Alt+1
 | Dokumentstruktur - Seiten | Alt+2
 | Datenformular | Alt+F2
 | Bild skalieren - Vergrößern | Strg+Num+
 | Bild skalieren - Verkleinern | Strg+Num-
 | Eigenschaften | Alt+Eingabetaste
Dokument | Test ausführen. | Strg+R
Extras | Objekte automatisch nach Typ erkennen… | Strg+D
 | Dokumentdefinition überprüfen | F9
 | Bereich zuordnen | Strg+E
Hilfe | Hilfethemen | F1

Bildfenster

Option | Tastenkombination
Bereiche auswählen | Esc
Objekte automatisch erkennen | Strg+Umschalt+D
Anker erstellen | A
Trennlinie erstellen | S
Ankertext erstellen | X
Ankerbarcode erstellen | D
Text erstellen | T
Auswahlfeld erstellen | C
Auswahlfeldgruppe erstellen | M
Barcode erstellen | B
Bild erstellen | P
Tabelle erstellen | L
Gruppe erstellen | G
Bereich für Feld ohne Bereich erstellen | R
Unerkannten Bereich erstellen | O
Spaltenfeld erstellen | U
Tabellentrennlinie zeichnen | F
Trennlinie aus Tabelle löschen | E
Bereich anpassen | Strg+Alt+A
Name vorschlagen | Strg+Alt+N
Name aus Bild abrufen… | Strg+Alt+I
Markierungstyp erkennen | Strg+Alt+D

Fenster "Dokumentstruktur"

Option | Tastenkombination
Feldbild anzeigen | Eingabetaste
Feld umbenennen | F2
Wenn ein Feld ausgewählt ist: |
Hinzufügen einer Spalte mit Textfeldern | Alt+Umschalt+T
Hinzufügen einer Spalte mit Auswahlfeldern | Alt+Umschalt+C
Hinzufügen einer Spalte mit Barcodes | Alt+Umschalt+B
Hinzufügen einer Spalte mit Bildern | Alt+Umschalt+P
Wenn eine Auswahlfeldgruppe ausgewählt ist: |
Auswahlfeld hinzufügen | Alt+Umschalt+C


Tastenkombinationen für das Gruppenüberprüfungsfenster

Menü | Option | Hot Tastaturbefehle
Überprüfung | Alle bestätigen | Eingabetaste
 | Alle aufschieben | Ctrl+Eingabetaste
 | Status ändern | Leertaste
 | Nächste Seite | Bild ab
 | Vorherige Seite | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Alles auswählen | Strg+A
Ansicht | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Bildanzeige > Vergrößern | Strg+Num+
 | Feldbild > Bildanzeige > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfethemen | F1
Lokales Symbolmenü | Zeichenbild anzeigen | F2
 | Bestätigen | Strg+E
 | Aufschieben | Strg+R
 | Zurücksetzen | Esc


Tastaturbefehle im Fenster für die Feldüberprüfung

Menü | Option | Tastaturbefehle
Überprüfung | Feld bestätigen | Eingabetaste
 | Aufschieben | Strg+Eingabetaste
 | Nächstes nicht eindeutiges Zeichen | F4
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F4
 | Nächstes Feld | Bild ab
 | Vorheriges Feld | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Zeilenumbruch einfügen | Umschalt+Eingabetaste
 | Zeichen verbinden | Strg+M
Ansicht | Felddaten > Erkannter Text | Alt+F1
 | Felddaten > Zeichenausschnitt | Alt+F2
 | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Image Scale > Vergrößern | Strg+Num+
 | Feldbild > Image Scale > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfe anzeigen | F1


Tastenkombinationen

Sie können die Tastenkombinationen für den Zugriff auf oft verwendete Befehle anpassen. Wählen Sie im Hauptmenü Extras>Optionen… und öffnen Sie dann die Registerkarte Tastenkombinationen.

Sie konfigurieren die Tastenkombinationen folgendermaßen:

  1. Wählen Sie in der Dropdownliste Kategorien eine Kategorie aus. Wählen Sie Alle Befehle, wenn Sie sich nicht sicher darüber sind, welche Kategorie Sie benötigen.
  2. Wählen Sie in der Liste Befehle einen Befehl aus. Die Liste Aktuelle Verknüpfung enthält Tastenkombinationen für den ausgewählten Befehl.
  3. Um eine neue Tastenkombination zuzuweisen, klicken Sie auf das Feld Neue Tastenkombination und drücken dann eine Tastenkombination. Die neue Kombination wird im Feld angezeigt. Klicken Sie auf die Schaltfläche Zuweisen , um die neue Tastenkombination zu speichern. Wird diese Tastenkombination für den Zugriff auf einen anderen Befehl verwendet, wird eine Informationsmeldung angezeigt. Klicken Sie auf die Schaltfläche Ja, um den Befehl zu ändern, oder auf die Schaltfläche Nein, um Ihre Änderungen zu verwerfen.
  4. Um eine vorhandene Tastenkombination für einen Befehl zu entfernen, wählen Sie in der Liste Aktuelle Verknüpfung und klicken dann auf die Schaltfläche Verknüpfung löschen.
  5. Um die Tastenkombinationen für einen ausgewählten Befehl auf seine Standardeinstellungen zurückzusetzen, klicken Sie auf die Schaltfläche Zurücksetzen. Wenn Sie die Tastenkombinationen für alle Befehle wiederherstellen möchten, klicken Sie auf die Schaltfläche Alles zurücksetzen.


Vergleich von Regeln in FormReader 6.5 und FlexiCapture

FormReader 6.5

 Entsprechung in FlexiCapture Automatische Konvertierung

Datenbanküberprüfung

Regel für die Datenbanküberprüfung

Nein

Summenüberprüfung

Regel für die Summenüberprüfung

Nein

Verbinden von Blöcken

Regel für das Verbinden von Feldern

Ja

VBScript-Regeln

Skriptregel

Nein

Suchen in einer Liste von Vorschlägen

Feldeigenschaften, Registerkarte Daten. Liste der Varianten im Feld Einschränkungen. Funktioniert bei allen Typen außer Datum and Zahl. Siehe Datentypen für Texteingabefelder.

 Ja

Zuordnen von Blöcken

Implementierung über eine Skriptregel.

 Nein

If-Then-Regeln

Skriptregel

Nein

Ersetzen von Werten in der Liste

Feldeigenschaften, Registerkarte Daten. Typ Text, Feld Verarbeitung. Siehe Datentypen für Texteingabefelder.

 Ja

Ersetzen von Zeichen in der Liste

Feldeigenschaften, Registerkarte Daten. Typ Text, Feld Processing. Siehe Datentypen für Texteingabefelder.

 Ja

Normalisieren und Überprüfen von Datumsangaben

Feldeigenschaften, Registerkarte Daten. Wählen Sie in der Liste Kategorie die Option Datumaus. Wählen Sie in der Formatliste die gewünschten Formate aus und geben Sie dann im Feld Einschränkungen die Einschränkungen ein. Siehe Datentypen für Texteingabefelder.

 Nein

Reguläre Ausdrücke

Feldeigenschaften, Registerkarte Daten. Geben Sie den gewünschten regulären Ausdruck im Feld Einschränkungen ein. Funktioniert bei allen Typen außer Datum und Zahl. Siehe Datentypen für Texteingabefelder.

 Ja

Automatisierungsüberprüfung

In der früheren Version der Anwendung mussten für die Verwendung von Automatisierungsobjekten Komponenten auf dem Zielcomputer registriert werden, wodurch die Übertragung von Stapeln auf einen anderen Computer erschwert wurde. In der neuen Version implementieren Sie die Logik der meisten Regeln dieser Art mithilfe von Scripten.

Wenn die Logik einer Regel zu komplex ist und die Verwendung externer Komponenten erfordert, sollte diese Komponente im Code einer Skriptregel aufgerufen werden. Anschließend sollte ein Verweis auf das Objekt im überprüften Dokument an die Komponente übergeben werden.

 Nein

Normalisieren von Preisen

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

 Nein

Validieren von Passserie und -nummer

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

 Nein

Summe in Zahlen – Summe in Worten

 Summe in Zahlen und Summe in Worten Nein

Preis in Zahlen – Preis in Worten

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

 Nein


Zusätzliche Optionen

Sie haben die Möglichkeit, die Dokumentverarbeitung und die Benutzeroberfläche des Programms Ihren Bedürfnissen anzupassen. Wählen Sie im Hauptfenster des Programms Extras>Optionen…. Das daraufhin angezeigte Dialogfeld enthält Registerkarten Farben, Dialogfelder, Tastenkombinationen, Taskstatus und Dokumentverarbeitung:

  • Taskstatus

    Wenn Tasks im background mode ausgeführt werden, dann können Sie den Fortschritt im Fenster Taskstatus, in der Protokolldatei und mithilfe der Popup-Meldungen überwachen und verfolgen. In dieser Registerkarte können Sie auswählen, welche Informationen in die Protokolldatei geschrieben und in welchen Fällen die Popup-Meldungen angezeigt werden sollen.

  • Farben

    Sie können die Farben der Elemente der Benutzeroberfläche ändern (z. B. die Rahmen, die ausgewählte Felder im Dokumentdefinitionseditor umschließen oder die Rahmen- und die Füllfarbe von Feldern mit Fehlern und Warnungen). Wählen Sie das gewünschte Element aus, und klicken Sie auf die Schaltfläche Farbe.

  • Dokumentverarbeitung

    Bilder können direkt nach dem Hinzufügen zu einem Stapel automatisch erkannt werden, wenn Sie die Option Hinzugefügte Bilder automatisch erkennen.

    Die Erkennung kann im Hintergrundmodus durchgeführt werden (wählen Sie Erkennungsprozess im Hintergrundmodus ausführen).

    Wenn die Option Fehlerhafte Dokumente beim Export auslassen ausgewählt wird, werden sowohl erfolgreich verarbeitete Dokumente als auch Dokumente mit Fehlern exportiert.

    Wenn ein Skriptfehler erkannt wurde, wird der Debugger von Visual Studio aufgerufen. Für Active Scripting-Skripte können Sie Debugging externer Skripte deaktivieren, wenn Sie nicht möchten, dass der Debugger aufgerufen wird. In diesem Fall wird dann nur eine Fehlermeldung angezeigt.

  • Dialogfelder

    Standardmäßig wird beim Aufrufen des Programms das Dialogfeld Projekt öffnen angezeigt, in dem Sie ein vorhandenes Projekt auswählen können. Sie können die Anzeige dieses Dialogfelds verhindern, indem Sie die Option Startdialogfeld 'Projekt öffnen…' anzeigenin der Registerkarte Dialogfelder deaktivieren (alternativ können Sie die erneute Anzeige auch verhindern, indem Sie dieselbe Option im angezeigten Dialogfeld selbst deaktivieren).

    Wenn Sie eine Dokumentdefinitionsliste schließen, gibt das Programm gegebenenfalls eine Warnmeldung zu vorhandenen, nicht veröffentlichten Dokumentdefinitionen aus. Wenn Sie nicht möchten, dass die Warnmeldung angezeigt wird, deaktivieren Sie die Option Bei nicht veröffentlichter Dokumentdefinition Warnmeldung anzeigen (alternativ können Sie eine erneute Anzeige auch verhindern, indem Sie dieselbe Option im Dialogfeld selbst deaktivieren).

    Wenn Sie möchten, dass Meldungen beim Exportieren von Dokumenten mit Fehlern angezeigt werden, wählen Sie Bei fehlerhaftem Dokumentexport Warnmeldung anzeigen.

    Wählen Sie Beim Wechseln zwischen Dokumenten Aufforderung zum Speichern anzeigen , um keine Änderungen beim Umschalten zwischen Dokumenten zu verlieren.

  • Tastenkombinationen

    Sie können auf dieser Registerkarte die Tastenkombinationen anpassen.


ABBYY FlexiCapture-Beispielprojekte

Um die Arbeitsweise und die Funktionen ABBYY FlexiCapturebesser zu verstehen, können Sie die Beispielprojekte verwenden, die im Programm enthalten sind. Diese vordefinierten Projekte enthalten fertig eingerichtete Dokumentdefinitionen und Dokumentbilder für die Verarbeitung.

Sie finden die Beispielprojekte unter %allusersprofile%\Application Data\ABBYY\FlexiCapture\11.0\Samples.

Hinweis: Unter Microsoft Windows Vista, Windows 7, Windows Server 2008 und Windows Server 2008 R2 finden Sie die Beispielprojekte unter %public%\ABBYY\FlexiCapture\11.0\Samples.

Das Verzeichnis Samples enthält folgende Ordner:

  1. FlexiCapture: Dieser Ordner enthält die Beispielprojekte für FlexiCapture.
  2. FlexiLayoutStudio: Dieser Ordner enthält die Beispielprojekte für FlexiLayout Studio. Diese Beispielprojekte illustrieren die Verarbeitung von teilweise strukturierten Dokumenten und sollten in ABBYY FlexiLayout Studio 10 geöffnet werden. Ausführliche Beschreibungen einiger dieser Projekte sind in der Hilfedatei von FlexiLayout Studio verfügbar (siehe dazu die Abschnitte Lernprogramm und Tipps and Tricks).
  3. FormDesigner: Dieser Ordner enthält statische Formulare, die in ABBYY FormDesigner entwickelt wurden. Die Dateien mit der Endung *.fdd sollten in ABBYY FormDesigner 10 geöffnet werden. Diese Formulare werden in folgenden FlexiCapture-Projekten verwendet: Bankkartenanwendung, Fragebogen.
  4. Images: Dieser Ordner enthält die gescannten Dokumentbilder für die Beispielprojekte in FlexiCapture.

Nachstehend werden die FlexiCapture-Beispielprojekte aufgeführt und kurz beschrieben.

Ein Beispielprojekt mit Dokumenten unterschiedlichen Typs

Die Projektordner enthalten Beispielprojekte für FlexiCapture.

  1. Zentraler Einstieg

    Dieses Projekt zeigt, wie Dokumente unterschiedlichen Typs verarbeitet werden können. Es ist keine vorherige Sortierung der Dokumente erforderlich, statische Formulare und flexible Dokumente können zusammen verarbeitet werden. Die in diesem Projekt verwendeten Dokumentdefinitionen werden auch in den unten beschriebenen Projekten verwendet.

    Das Projekt enthält alle Arten von Dokumenten: Bankkartenanwendungen, Rechnungen, Verträge, Briefe, Preise.

Beispielprojekte mit statischen Formularen

Die Projektordner enthalten Formulare, die in ABBYY FormDesigner- und FlexiCapture-Projekten erstellt wurden.

  2. Bankkartenanwendung

    Dieses Beispielprojekt stellt die folgenden Funktionen heraus:

    • Automatische Erkennung von Feldern auf statischen Formularen (wenn Sie die Funktionsweise der automatischen Erkennung testen möchten, löschen Sie alle Felder aus der Dokumentvorlage, und wählen Sie Extras >Objekte automatisch nach Typ erkennen…)
    • Unterstützung von Dokumenten mit komplexen Strukturen:
      1. Mehrseitige Dokumente (im Beispielprojekt werden dreiseitige Anwendungen verwendet)
      2. Arbeit mit Dokumentbereichen (im Beispielprojekt ist jede Seite ein separater Bereich)
      3. Dokumentzusammenstellungsregeln
      4. Verarbeitung von Anhängen

    • Unterstützung von komplexen Feldern:

      1. Arbeit mit Tabellen auf statischen Formularen (Tabelle "Eröffnete Konten")
      2. Wiederholte Feldgruppen (die Gruppen "Adresse" und "Angeforderte Konten")
    • Überprüfung der Datenformate (die Formate aller Zahl- und Datumsfelder sind festgelegt)

    • Anpassung des Datenformulars

    • Exportieren in mehrere Zielorte.

    • Bearbeitung von vertraulichen Informationen (Schwärzung).

  3. Fragebogen

    Eine ausführliche Beschreibung dieses Beispielprojekts finden Sie im Benutzerhandbuch. Das Projekt zeigt, wie eine Dokumentdefinition schrittweise eingerichtet wird. Mehrere einfache Formulare werden dabei verwendet, um die grundlegenden Funktionen von ABBYY FlexiCapture zu verdeutlichen. Sie können den Fragebogen dieses Beispielprojekts vervollständigen, ihn in ABBYY FlexiCapture verarbeiten und die exportierten Daten an ABBYY senden.

Beispielprojekte mit flexiblen Formularen

Die Projektordner enthalten Beispielprojekte für FlexiLayout Studio und FlexiCapture.

  4. Rechnung

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 3)
    • Tabellen, die sich über mehrere Seiten erstrecken
    • Verwendung eines externen Wörterbuchs mit Schlüsselwörtern (eine Textdatei)
    • Es wird eine JScript-Regel verwendet, um die Summe im Feld "Total" (Gesamt) mit der durch Addition der einzelnen Gesamtwerte aller Tabellenzeilen ermittelten Summe zu vergleichen.
  5. Preise

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Unterstützung wiederholter Gruppen. Dieses Beispielprojekt zeigt, wie wiederholt auftretende Gruppen verwendet werden können, um verschachtelte Tabellen (Tabellen mit untergeordneten Überschriften) zu beschreiben.
  6. Briefe und Verträge

    Dieses Beispielprojekt zeigt die Verarbeitung unstrukturierter Dokumente, aus denen zwei oder drei Felder erfasst werden. Dabei kommen im Projekt vor allem die folgenden Funktionen zur Geltung:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 4)
    • Einrichtung des Exports in eine durchsuchbare PDF-Datei


Unterstützte Erkennungssprachen

ABBYY FlexiCapture bietet die folgenden Erkennungssprachen mit Wörterbuchunterstützung:

Sprache | OCR* | ICR**
Altdeutsch | ü | ü
Altenglisch | ü |
Altfranzösisch | ü | ü
Altitalienisch | ü | ü
Altspanisch | ü | ü
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | ü |
Baschkirisch | ü |
Bulgarisch | ü | ü
Dänisch | ü |
Deutsch (alte und neue Rechtschreibung) | ü | ü
Englisch | ü | ü
Estnisch | ü | ü
Finnisch | ü | ü
Französisch | ü | ü
Griechisch | ü | ü
Hebräisch | ü |
Indonesisch | ü | ü
Italienisch | ü | ü
Katalanisch | ü |
Kroatisch | ü | ü
Lettisch | ü | ü
Litauisch | ü | ü
Niederländisch (Niederlande und Belgien) | ü | ü
Norwegisch (Nynorsk und Bokmål) | ü |
Polnisch | ü | ü
Portugiesisch (Portugal und Brasilien) | ü |
Rumänisch | ü | ü
Russisch | ü | ü
Schwedisch | ü |
Slowakisch | ü | ü
Slowenisch | ü | ü
Spanisch | ü | ü
Tatarisch | ü |
Thai | ü |
Tschechisch | ü | ü
Türkisch | ü | ü
Ukrainisch | ü | ü
Ungarisch | ü | ü

Weitere Informationen über Schriftarten der unterstützten Sprachen finden Sie im Abschnitt "Benötigte Schriftarten für die korrekte Darstellung von Zeichen der unterstützten Sprachen im ABBYY FlexiCapture-Editor".

Eine vollständige und aktualisierte Liste der unterstützten Datentypen mit den zugehörigen Einzelheiten finden Sie unter http://www.abbyy.com.

* - OCR - Englische Abkürzung für "Optical Character Recognition" (optische Zeichenerkennung). Optische Erkennung gedruckter Texte.

** - ICR - Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Erkennung handschriftlicher Texte.


Schriftarten für die korrekte Darstellung von Zeichen der im ABBYY FlexiCapture-Editor unterstützten Sprachen

Sprache | Schriftart
Mit Wörterbuchunterstützung |
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | Arial Unicode MS(2)
Tatarisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ohne Wörterbuchunterstützung |
Abchasisch | Arial Unicode MS(2)
Adygeisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aghulisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Altaisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Awarisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aserbaidschanisch (Kyrillisch), Aserbaidschanisch (Lateinisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Baschkirisch | Arial Unicode MS(2), Palatino Linotype(2)
Burjatisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Tschetschenisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuktschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuwaschisch | Arial Unicode MS(2)
Darginisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Dunganisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Gagausisch | Arial Unicode MS(2)
Haussa | Arial Unicode MS(2), Lucida Sans Unicode(3)
Inguschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kabardinisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kalmückisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Karakalpakisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Kasachisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Chakassisch | Arial Unicode MS(2)
Chantisch | Arial Unicode MS(2)
Korjakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kirgisisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Lakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Lesgisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mansisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mari | Arial Unicode MS(2)
Mongolisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Nenzisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ossetisch | Arial Unicode MS(2)
Russisch (alte Rechtschreibung) | Arial Unicode MS(2), Palatino Linotype(2)
Tabassaranisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tadschikisch | Arial Unicode MS(2), Palatino Linotype(2)
Turkmenisch | MS Core Fonts 2.82(1) (Arial, Courier New und Times New Roman)
Tuwinisch | MS Core Fonts 2.82(1) (Arial, Courier New und Times New Roman)
Udmurtisch | Arial Unicode MS(2)
Usbekisch (Kyrillisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Jakutisch | Arial Unicode MS(2)
Zulu | Arial Unicode MS,(2), Lucida Sans Unicode(3)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Unterstützte Texttypen

ABBYY FlexiCapture unterstützt die folgenden Texttypen:

Texttyp | Beschreibung
Professionelle, Laser- und Ink-Jet-Drucker | Die Texte wurden in einer Druckerei, auf einem Laserdrucker oder einem Ink-Jet-Drucker gedruckt.
Schreibmaschine | Auf einer Schreibmaschine geschriebene Texte.
Matrixdrucker | Die Texte wurden auf einem Punktmatrixdrucker gedruckt.
Index | Ein spezieller Zeichensatz, der nur Ziffern im PLZ-Format enthält. Diese werden folgendermaßen dargestellt:
OCR-A | Eine Konstantschriftart für die optische Zeichenerkennung. Sie wird häufig von Banken, Kreditkarteninstituten und ähnlichen Firmen verwendet. Die Darstellung ähnelt folgender:
OCR-B | Eine Schriftart für die optische Zeichenerkennung. Die Darstellung ähnelt folgender:
MICR E-138 | Ein spezieller Satz numerischer Zeichen, die mit einer magnetischen Spezialtinte gedruckt werden. MICR-Zeichen (Magnetic Ink Character Recognition) finden sich an verschiedenen Stellen, unter anderem auf Barschecks. Die Darstellung ähnelt folgender:
MICR CMC-7 | Eine spezielle MICR-Schriftart für Barcodes (CMC-7). Die Darstellung ähnelt folgender:


Unterstützte Barcodetypen

ABBYY FlexiCapture unterstützt die folgenden Barcodeformate:

  • EAN 13
  • EAN 8
  • Code 39
  • Code 39 without asterisk
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Check CodaBar
  • Aztec
  • Datamatrix
  • QR code

Hinweis: Für das Erkennen von Barcodes in kyrillischer Kodierung sollte das Datamatrix-Format verwendet werden.


Unterstützte Grafikformate

Typ | Farbe
BMP | S/W, Grau, Farbe
PCX, DCX | S/W, Grau
PNG | S/W, Grau, Farbe
JPEG | Grau, Farbe
JPEG-2000* | Grau, Farbe
TIFF S/W – unkomprimiert, CCITT3, CCITT4, Packbits, ZIP;
Grau – unkomprimiert, Packbits, JPEG, ZIP;
Farbe – unkomprimiert, JPEG, ZIP.
JBIG2 | S/W
GIF | Farbe
PDF, PDF/A**
PDF, PDF/A** durchsuchbar
DjVu | S/W, Grau, Farbe

* - Für JPEG-2000-Bilder wird eine verlustreiche Kompression verwendet.

** - Mit ABBYY FlexiCapture 10 erstellte PDF/A-Dateien sind kompatibel mit PDF/A-1a und PDF/A-1b. Standardmäßig werden PDF/A-1_Dateien erstellt. Um das Exportieren als PDF/A-1b zu ermöglichen, geben Sie in der Registrierung die folgenden Werte an:

HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Export\UseTaggedPdfExport = false

Hinweis: Bei der Verarbeitung von PDF-Dateien, die Vektorgrafiken enthalten, kann sich die visuelle Qualität verschlechtern, da die PDF-Datei gerastert wird und die Ausgabedatei ein Bitmapbild enthält.


Exportdateiformate

You are here: Anhang > Exportdateiformate

Dateiformate für den Datenexport aus Dokumenten in ABBYY FlexiCapture

  • Microsoft Office Excel-Arbeitsmappe (*.xls)

  • DBase-Datei (*.dbf)

  • Kommagetrennte Datei (*.csv). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).

  • Kommagetrennte Datei (*.csv) im Unicode-Format (UTF-8, UTF-16)

  • Textdatei (*.txt). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).

  • Textdatei (*.txt) im Unicode-Format (UTF-8, UTF-16)

  • XML-Dokument (*.xml)


Alphabet in regulären Ausdrücken

Name | Verwendete Bezeichnung | Beispiel für die Verwendung
Beliebiges Zeichen | * | "c"*"t" – lässt die Wörter cat, cot usw. zu.
Buchstabe | C | C"ot" – lässt die Wörter Rot, pot, cot, Dot, mot usw. zu.
Großbuchstabe | A | A"ot" – lässt die Wörter Rot, Cot, Mot, Dot usw. zu.
Kleinbuchstabe | a | a"ot" – lässt die Wörter rot, cot, mot, dot usw. zu.
Ziffer oder Buchstabe | X | X – lässt jedes einzelne Vorkommen eines Buchstabens oder einer Ziffer zu.
Nummer | N | N"." – lässt die Kombinationen 5., 4., 6. usw. zu.
Zeichenfolge | " " | "cot"
Oder | | | "pl"("o"|"a")"t" – lässt die Wörter "plot" und "plat" zu.
Zeichen aus Gruppe | [] | [tm]"ot" – lässt die Wörter "tot" und "mot" zu.
Zeichen nicht aus Gruppe | [^] | [^t]"ot" – lässt die Wörter "cot", "lot" usw. zu, aber nicht das Wort "tot".
Leerzeichen (in Gruppe) | \s | [A\s] lässt nur den Buchstaben A oder ein Leerzeichen zu.
Eine beliebige Anzahl von Wiederholungen (gilt für den davor stehenden Ausdruck oder Unterausdruck) | {-} | [AB74]{-} – lässt beliebige Kombinationen der Zeichen A, B, 7 und 4 beliebiger Länge zu.
n Wiederholungen | {n} | N{2}"." – lässt die Kombinationen 25., 84., 11. usw. zu.
n bis m Wiederholungen | {n-m} | N{1-3}"." – lässt die Kombinationen 5., 84., 111. usw. zu.
0 bis n Wiederholungen | {-n} | N{-2}"." – lässt die Kombinationen 84., 5. usw. zu.
n und mehr Wiederholungen | {n-} | N{2-}"." – lässt die Kombinationen 25., 834., 311., 34576. usw. zu.
Unterausdruck | () |
Bindestrich | [\-] |
Umgekehrter Schrägstrich | [\\] |

Beispiele für reguläre Ausdrücke:

  1. Postleitzahl: [0-9]{6}

    Ein Beispielwert: "142172"

  2. Postleitzahl (USA): [0-9]{5}("-"[0-9]{4}){-1}

    Beispielwerte: "55416", "33701-4313"

  3. Einkommen: N{4-8}[,]N{2}

    Beispielwerte: "15000,00", "4499,00"

  4. Monat in numerischer Form: ((|"0")[1-9])|("10")|("11")|("12")

    Beispielwerte: "4", "05", "12"

  5. Bruch: ("-"|)([0-9]{1-})(|(("."|",")([0-9]{1-})))

    Beispielwerte: "1234,567", "0.99", "100,0", "-345.6788903"

  6. E-Mail: [A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-3}"@"[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-4}"."([A-Za-z]{2-4}|"asia"|"museum"|"travel"|"example"|"localhost")

    Beispielwerte: "support@abbyy.com", "my-name@company.org.ru", "info@gallery.museum"


Patente

US-Patentnummern 5,490,216, 5,625,465, 5,768,416 und 6,094,505


Drittpartei-Technologien

© 1984-2011 Adobe Systems Incorporated und seine Lizenzgeber. Alle Rechte vorbehalten.

Geschützt durch die US-Patente 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patente anhängig.

Adobe, das Adobe-Logo, Acrobat, das Adobe PDF-Logo, Distiller und Reader sind entweder eingetragene Marken oder Marken von Adobe Systems Incorporated in den USA und/oder anderen Ländern.

Teile dieses Computerprogramms unterliegen dem Urheberrecht von © 2008 Celartem, Inc. Alle Rechte vorbehalten.

Teile dieses Computerprogramms unterliegen dem Urheberrecht von © 2011 Caminova, Inc. Alle Rechte vorbehalten.

Teile dieses Computerprogramms unterliegen dem Urheberrecht von © 2013 Cuminas, Inc. Alle Rechte vorbehalten.

DjVu ist durch das US-Patent 6,058,214 geschützt. Ausländische Patente ausstehend.

Betrieben mit AT&T Labs-Technologie.

PixTools © 1994-2007 EMC Corporation. Alle Rechte vorbehalten.

WIBU, CodeMeter, SmartShelter, SmartBind sind eingetragene Marken von Wibu-Systems.

Teile dieser Software unterliegen dem Urheberrecht von (c) 2012 University of New South Wales. Alle Rechte vorbehalten.

© 2001-2006 Michael David Adams

© 1999-2000 Image Power, Inc.

© 1999-2000 The University of British Columbia

Diese Software basiert teilweise auf der Arbeit der Independent JPEG Group.

© 1991-2013 Unicode, Inc. Alle Rechte vorbehalten.

Die Unicode-Wortmarke und das Unicode-Logo sind Marken von Unicode, Inc.

Teile dieser Software unterliegen dem Urheberrecht © 1996-2002, 2006 The FreeType Project (www.freetype.org). Alle Rechte vorbehalten.

© ParaType, 2003

EMC2, EMC, Captiva, ISIS und PixTools sind eingetragene Marken, und QuickScan ist eine Marke der EMC Corporation.

KODAK ist eine Marke der Eastman Kodak Company.

.NET, Access, Active Directory, ActiveX, Aero, Excel, Hyper-V, InfoPath, Internet Explorer, JScript, Microsoft, Office, Outlook, PowerPoint, SharePoint, Silverlight, SQL Azure, SQL Server, Visual Basic, Visual C++, Visual C#, Visual Studio, Windows, Windows Azure, Windows Power Shell, Windows Server, Windows Vista, Word sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Oracle und Java sind eingetragene Marken von Oracle und/oder deren Tochtergesellschaften.

Alle anderen Marken sind das Eigentum der entsprechenden Inhaber.

Das TWAIN Toolkit wird wie gesehen vertrieben. Der Entwickler und die Vertreiber des TWAIN Toolkits lehnen ausdrücklich jegliche implizierten, expliziten oder gesetzlichen Garantien bzw. Gewährleistungen ab. Dazu gehören ohne Einschränkung die implizierten Garantien der Marktgängigkeit, der Verhinderung einer Verletzung der Rechte dritter Parteien sowie der Eignung für einen bestimmten Zweck. Weder die Entwickler noch die Vertreiber sind haftbar für Schäden, ob direkte, indirekte, besondere/zusätzliche Schäden, Nebenschäden oder Folgeschäden infolge der Vervielfältigung, Modifizierung, des Vertriebs oder einer anderen Nutzung des TWAIN Toolkits.

JasPer License Version 2.0

© 2001-2006 Michael David Adams

© 1999-2000 Image Power, Inc.

© 1999-2000 The University of British Columbia

Alle Rechte vorbehalten.

Hiermit wird die Erlaubnis gewährt, jeder Person (dem "Nutzer") kostenlos eine Kopie dieser Software und die entsprechenden Dokumentationsdateien (die "Software") zur Verfügung zu stellen, ohne Einschränkung mit der Software zu verfahren, einschließlich, ohne Einschränkung, der Nutzungs-, Kopier-, Modifizierungs-, Zusammenfassungs-, Veröffentlichungs-, Vertriebs-, und/oder der Verkaufsrechte der Kopien der Software, und dies auch den Personen, denen die Software bereitgestellt wird, zu gestatten, falls die folgenden Bedingungen gegeben sind:

  1. Die oben genannten Bestimmungen zum Urheberrecht und diese Genehmigung (welche den folgenden Haftungsausschluss beinhaltet) müssen in allen Kopien oder größeren Teilen der Software enthalten sein.
  2. Der Name eines Urheberrechtsinhabers darf nicht verwendet werden, um Produkte zu befürworten oder zu bewerben, die ohne vorherige schriftliche Genehmigung auf Grundlage der Software entwickelt wurden.

DIESER GARANTIEAUSSCHLUSS IST EIN UNTRENNBARER BESTANDTEIL DIESER LIZENZ. AUSSER UNTER DIESEM GARANTIEAUSSCHLUSS WIRD HIERMIT KEINE NUTZUNG DER SOFTWARE GENEHMIGT. DIE SOFTWARE WIRD VON DEN URHEBERRECHTSINHABERN "WIE GESEHEN" BEREITGESTELLT, OHNE GARANTIE JEGLICHER ART; SEI ES AUSDRÜCKLICH ODER STILLSCHWEIGEND; EINSCHLIESSLICH, ABER NICHT BEGRENZT AUF DIE GARANTIEN DER MARKTFÄHIGKEIT, DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK UND DER VERHINDERUNG EINER VERLETZUNG DER RECHTE DRITTER PARTEIEN. IN KEINEM FALL HAFTEN DIE URHEBERRECHTSINHABER FÜR ANSPRÜCHE, ODER BESONDERE INDIREKTE ODER FOLGESCHÄDEN ODER JEGLICHE SCHÄDEN INFOLGE DES VERLUSTS DER NUTZUNG, DATEN ODER GEWINNE, OB BEI EINER VERTRAGSVERLETZUNG, DURCH FAHRLÄSSIGKEIT ODER ANDERE UNERLAUBTE HANDLUNGEN INFOLGE ODER IN VERBINDUNG MIT DER NUTZUNG ODER DER AUSFÜHRUNG DIESER SOFTWARE. DIE URHEBERRECHTSINHABER GEBEN KEINE GEWÄHRLEISTUNG, DASS DIE SOFTWARE NICHT GEGEN PATENTRECHTE ODER ANDERE RECHTE AM GEISTIGEN EIGENTUM EINER ANDEREN NATÜRLICHEN ODER JURISTISCHEN PERSON VERSTÖSST. JEDER URHEBERRECHTSINHABER LEHNT DIE HAFTUNG GEGENÜBER EINEM NUTZER FÜR JEGLICHE ANSPRÜCHE EINER ANDEREN NATÜRLICHEN ODER JURISTISCHEN PERSON AB, DIE AUF DER VERLETZUNG DER RECHTE AM GEISTIGEN EIGENTUM ODER ANDERER BASIEREN. ALS VORAUSSETZUNG DER NUTZUNG DER HIERIN GEWÄHRTEN RECHTE AKZEPTIERT JEDER NUTZER DIE ALLEINIGE VERANTWORTUNG ZUM ERWERB JEGLICHER BENÖTIGTER RECHTE AM GEISTIGEN EIGENTUM, FALLS SOLCHE BESTEHEN. DIE SOFTWARE IST NICHT FEHLERTOLERANT UND IST NICHT GEDACHT FÜR DEN EINSATZ IN MISSIONSKRITISCHEN SYSTEMEN WIE SIE BEIM BETRIEB VON NUKLEARKRAFTWERKEN; BEI DER LUFTFAHRTNAVIGATION ODER IN KOMMUNIKATIONSSYSTEMEN; VERKEHRSSTEUERUNGSSYSTEMEN, MASCHINEN ZUR DIREKTEN LEBENSERHALTUNG ODER WAFFENSYSTEMEN VERWENDET WERDEN; BEI DENEN EIN FEHLER DER SOFTWARE ODER DES SYSTEMS DIREKT ZUM TOD, VERLETZUNGEN ODER SCHWEREN PHYSISCHEN ODER UMWELTSCHÄDEN FÜHREN KÖNNTE ("AKTIVITÄTEN MIT HOHEM RISIKO"). DIE URHEBERRECHTSINHABER SCHLIESSEN IM BESONDEREN JEGLICHE EXPLIZITE ODER STILLSCHWEIGENDE GARANTIE DER EIGNUNG FÜR AKTIVITÄTEN MIT HOHEM RISIKO AUS.


Glossar

You are here: Anhang > Glossar

A

ABBYY FlexiCapture

Eine Softwarelösung für die Erfassung von Daten aus unterschiedlichen Dokumenttypen – z. B. strukturierter (statischer Formulare), teilweise strukturierter (flexibler Formulare und Dokumente) und nicht strukturierter Dokumente – in einem Durchgang.

ABBYY FlexiLayout Studio

Ein Programm, mit dem Sie eine flexible Beschreibung (FlexiLayout) der Dokumentstruktur erstellen können, die anschließend für die automatische Dokumenterkennung verwendet werden kann.

ABBYY FormDesigner

Mithilfe von ABBYY FormDesigner können Sie Layouts für maschinenlesbare Formulare entwerfen. Nach der Vervielfältigung und dem Ausfüllen können diese Formulare mit dem automatisierten Formulareingabesystem von ABBYY FlexiCapture verarbeitet werden. Das Entwerfen eines Formularlayouts ist ein für die weitere Dokumentverarbeitung wichtiger Schritt, da die Qualität des Layouts (seine Lesbarkeit für die Software) die Effizienz aller nachfolgenden Schritte (Scannen, Erkennen, Überprüfen und Exportieren) wesentlich beeinflusst.

ABBYY FlexiCapture for Invoices

Eine ABBYY FlexiCapture Komponente, die Daten aus Rechnungen erfasst.

ADF

Englische Abkürzung für "Automatic Document Feeder" (automatische Dokumentzufuhr). Eine Vorrichtung zur automatischen Dokumentzufuhr, mit der Sie mehrere Dokumente scannen können, ohne zwischenzeitlich eingreifen zu müssen.

Administrator

Ein Benutzer von ABBYY FlexiCapture, der berechtigt ist, das Programm für die Dokumenterfassung zu konfigurieren. Die Konfiguration umfasst das Erstellen und Bearbeiten von Dokumentdefinitionen sowie das Importieren von Profilen.

Alphabet

Ein in der beschriebenen Sprache verwendeter Zeichensatz.

Anhang

Seiten, die keine Felder enthalten, aber in die Dokumentzusammenstellung einbezogen werden. Aus diesen Seiten werden zwar keine Daten extrahiert, sie können aber als Bilder oder durchsuchbare PDF-Dateien gespeichert werden. Siehe Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Anker

Ein statisches Element in Form eines schwarzen Quadrats, Rechtecks, Kreuzes oder einer Ecke, das für die Zuordnung von Dokumentdefinitionen verwendet wird. Details... Collapsed Anker sind spezielle Elemente des Formularlayouts, auf deren Grundlage das System nach dem Scannen Zuordnungen trifft (Entfernen von Verzerrungen, Korrigieren linearer und nicht linearer Scanfehler, Berechnen der Position von Blöcken). Die zuverlässigsten Anker sind schwarze Quadrate, die i. d. R. in den Ecken eines Formulars platziert werden. Wenn das Bild keine speziellen Anker enthält, können für die Zuordnung von Dokumentdefinitionen andere statische Elemente verwendet werden: Trennlinien, also vertikale oder horizontale Linien wie Tabellenlinien, Rahmen usw., oder deutlich erkennbarer statischer Text wie Kopfzeile des Formulars, Feldsignaturen oder erklärender Text. Statische Elemente können für die Zuordnung von Dokumentdefinitionen nur verwendet werden, wenn die Option Für Zuordnung von Dokumentdefinitionen verwenden aktiviert ist. matching.

Ankerbarcode

Statisches Element in Form eines Barcodes, der nicht für das Extrahieren von Daten vorgesehen ist. Ankerbarcodes können für die Zuordnung oder Identifizierung von Dokumentdefinitionen verwendet werden.

Ankertext

Statisches Element, das Text auf einem leeren Formular darstellt, der nicht zum Extrahieren von Daten vorgesehen ist. Dabei kann es sich um erklärenden Text oder eine Kopfzeile handeln. Ankertexte können für die Zuordnung oder Identifizierung von Dokumentdefinitionen verwendet werden.

Arbeitsstapel

Dokumentstapel für die Dateneingabe. Für die Verarbeitung von Arbeitsstapeln werden nur veröffentliche Dokumentdefinitionen verwendet. Siehe Document batches.

Auflösung

Bildparameter. Die Auflösung wird in dpi (Dots Per Inch, Punkten pro Zoll) angegeben.

Auswahlfeld

Ein Dokumentdefinitionsfeld, das ein Auswahlkästchen enthält.

Auswahlfeldgruppe

Ein Element eines maschinenlesbaren Formulars, in dem mehrere nahe beieinander stehende Auswahlkästchen zusammengefasst werden. In einer Gruppe von Auswahlkästchen können eine oder mehrere Möglichkeiten markiert werden.

Auswahlgruppenfeld

Ein Dokumentdefinitionsfeld, das eine Auswahlfeldgruppe enthält.

Auswahlkästchen

Ein maschinenlesbares Formularelement, das von der Person, die das Formular ausfüllt, mit einer Markierung (Häkchen, Kreuz, Punkt usw.) versehen werden soll.

B

Barcode

Ein maschinenlesbares Formularelement, das durch abwechselnde weiße und schwarze Streifen gleicher Länge dargestellt wird und der Kodierung digitaler Informationen dient. Barcodes können in einem Dokument für das Extrahieren von Informationen (Barcodefeld) oder das Zuordnen und Identifizieren einer Dokumentdefinition (Ankerbarcode) verwendet werden.

Barcodeerkennung

Konvertierung eines grafischen Barcodebilds in Zahlen oder Text.

Barcodefeld

Ein Dokumentdefinitionsfeld, das einen für die Erkennung vorgesehenen Barcode enthält.

Benutzerdefinierter Datentyp

Ein vom Benutzer festgelegter Datentyp. Siehe Erstellen benutzerdefinierter Datentypen.

Benutzerwörterbuch

Ein Hilfswörterbuch, das der Benutzer erstellt und das Wörter enthält, die nicht in den integrierten Wörterbüchern enthalten sind. Benutzerwörterbücher können die integrierten Wörterbücher ergänzen, um die Qualität der Datenerfassung zu verbessern. Ein typisches Benutzerwörterbuch enthält Fachtermini, Abkürzungen, Firmennamen usw.

Bereich einer Dokumentdefinition

Eine Reihe von Seiten (oder eine einzelne Seite) und alle Felder auf diesen Seiten, die einen logisch zusammenhängenden Teil eines Dokuments bilden. Dokumentbereiche können mit einer statischen oder einer flexiblen Dokumentdefinition beschrieben werden. Einzelheiten finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente.

Beschreibungsdatei

Eine Zusatzdatei, in der definiert ist, wie ein Stapel zusammengesetzt wird, wenn Bilder aus einem Hot Folder hinzugefügt werden. Ausführliche Informationen finden Sie unter Beschreibungsdatei.

Bild

Ein elektronisches Abbild einer gescannten Seite eines Papierdokuments.

Bilddrehung

Vorgang, bei dem ein Bild um seinen Mittelpunkt gedreht wird.

Bildersetzung

Vorgang während der Bearbeitung einer Dokumentdefinition, bei dem ein Bild durch ein anderes ersetzt wird.

Bildfeld

Ein Dokumentdefinitionsfeld, das ein Bild enthält.

Bildimport

Vorgang, bei dem Bilder einem Verarbeitungsstapel hinzugefügt werden. Die Bilder können aus Dateien, von einem Scanner oder mit Importprofilen. Siehe Hinzufügen von Seitenbildern.

Bildstörungen entfernen

Das Entfernen von Störungen aus einem Bild. Diese Störungen können beim Scannen auftreten und sollten entfernt werden, um die Datenerkennung zu verbessern. Beim Entfernen von Störungen löscht die Software auch Punkte aus dem Hintergrund sowie Rahmenlinien aus Rasterformularen.

Buchstaben auf Kamm

Texttyp, bei dem der Text durch einen "Kamm" begrenzt ist. Anzeigen... Collapsed

Buchstaben in Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei nicht voneinander getrennt.. Anzeigen... Collapsed

Buchstaben in separaten Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei voneinander getrennt. Anzeigen... Collapsed

D

Datenbanksuche

Zuordnung erkannter Daten zu den entsprechenden Datenbankeinträgen.

Datenerfassung in einem Durchgang

Automatisches Extrahieren von Daten aus analogen (gedruckten) und digitalen Dokumenten (gescannte Bilder).

Datensatz

Daten, die für automatisierte Dokumentüberprüfungen verwendet werden. Ein Datensatz kann als Tabelle in ABBYY FlexiCapture gespeichert und entsprechend eines Zeitplans synchronisiert oder von einer externen Quelle abgerufen werden.

Datentyp

Ein Feldattribut, das bekannte Einschränkungen für die möglichen Feldwerte beschreibt. Mit dem Datentyp wird während der Felderkennung die Anzahl der möglichen Erkennungsvarianten reduziert. Details... Collapsed Eines der wesentlichen Merkmale eines Felds ist der Datentyp ( z. B. Zahl, Datum, Text, Nachname, Vorname oder Adresse). Anhand des Datentyps wird die Gruppe von Wörtern definiert, die in diesem Feld vorkommen können. Der Datentyp ist ein wichtiger Erkennungsparameter, der Einfluss auf die Erkennungsqualität hat. Durch einen korrekt angegebenen Datentyp können Sie die Anzahl der falsch erkannten Zeichen deutlich reduzieren.

Dokument

Eine Kombination aus mehreren Seitenbildern und den Daten, die aus den Seiten extrahiert wurden.

Dokumentdaten

Daten, die nach der Verarbeitung (Erkennung, Überprüfung und Bearbeitung der Erkennungsergebnisse) der Seitenbilder eines Dokuments erfasst werden.

Dokumentdefinition

Mit einer Dokumentdefinition werden die Verfahren für das Erkennen und Verarbeiten eines bestimmten Dokumenttyps definiert. Sie enthält folgende Angaben:

  • Die Dokumentstruktur, also eine Beschreibung der zulässigen Seitenreihenfolge für ein Dokument dieses Typs. Die Dokumentstruktur definiert auch die Regel für die Dokumentzusammenstellung.
  • Definitionen von Dokumentbereichen.
  • Eine Liste der Regeln für Felddaten.
  • Die Position von Feldern und ihrer Signaturen im Datenfenster (Datenformularansicht)
  • Exporteinstellungen für diesen Dokumenttyp.
  • Verarbeitungseinstellungen für diesen Dokumenttyp.

Dokumentdefinitionsbereich

Komponente einer Dokumentdefinition. Der Dokumentdefinitionsbereich entspricht einer oder mehreren Seiten, die einen logisch verknüpften Satz von Feldern enthalten. Die Felder innerhalb eines Bereichs können sich auch über mehrere Seiten erstrecken (z. B. mehrseitige Tabellen), sofern sich die Feldsätze der unterschiedlichen Bereiche nicht überschneiden.

Dokumentdefinitionsbereiche können flexible oder statisch sein.

Dokumenterfassung in einem Durchgang

Die automatisierte Konvertierung von Papierdokumenten in ein elektronisches Format.

Dokumentfehler

Wenn sich bei der Dokumentverarbeitung herausstellt, dass die Dokumentdaten entweder der Dokumentstruktur und den angegebenen Einschränkungen für den Feldwert oder den Steuerregeln nicht entsprechen, werden alle falschen Zuordnungen in der Fehlerliste des Dokuments erfasst.

Dokumentstapel

Eine Kombination aus Dokumenten, die vom Benutzer zusammengestellt wurden. Normalerweise enthält ein Stapel Dokumente, die in einem Durchgang gescannt oder aus einem bestimmten Ordner importiert wurden. Siehe .

dpi

Englische Abkürzung für "Dots per inch" (Punkte pro Zoll). Eine Maßeinheit für die Bildauflösung.

E

Einfacher Text

Eine Form der Textmarkierung, bei der der Text ohne Trennzeichen in einen Block eingefügt wird.

Erkennung

Vorgang, bei dem Bildelemente bestimmten Zeichen zugeordnet werden.

Erkennung

Sprache, auf der die Erkennung von ABBYY FlexiCapture beruht.

Erklärender Text

Ein maschinenlesbares Formularelement, das einen beschreibenden Text (Formularname, Feldnamen, Erläuterungen von Feldern usw.) enthält.

Export

Vorgang, bei dem verarbeitete Daten an ein externes Informationssystem oder in eine Datei übertragen werden.

Exportprofil

Ein Satz von Einstellungen, der festlegt, was mit den verarbeiteten Daten geschieht: das Format der Ausgabedateien, den Ausgabepfad, die Exportbedingungen usw.

F

Falsch erkanntes Zeichen

Status, der einem Zeichen bei der Erkennung automatisch zugeordnet wird, wenn es einem bestimmten Grad der Eindeutigkeit nicht entspricht.

Feld

Ein Dokumentelement, das zum Extrahieren von Daten vorgesehen ist. Felder können einfach (ohne interne Struktur) oder zusammengesetzt sein. Ein zusammengesetztes Feld ist z. B. ein Tabellenfeld, das sowohl als einzelne Zelle als auch als untergeordnetes Feld der Tabelle angesehen werden kann. Siehe Erstellen von Feldern einer Dokumentdefinition.

Feld für die manuelle Eingabe

Ein Dokumentdefinitionsfeld mit nicht erkennbarem Text (z. B. Text mit verschwommenen Buchstaben), der über die Tastatur eingegeben werden muss.

Feld mit mehreren Bereichen

Ein Feld, das mehrere Bereiche im Bild umfasst. Diese Bereiche können voneinander entfernt und sogar auf verschiedenen Seiten positioniert werden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert. Felder mit mehreren Bereichen werden meist für Objekte verwendet, die sich über mehrere Seiten erstrecken (z. B. große Tabellen). Siehe Felder mit mehreren Bereichen.

Feld mit mehreren Instanzen

Ein Feld zur Beschreibung mehrerer Objekte desselben Typs (sich wiederholende Objekte). Im Grunde sind diese Objekte als dasselbe Feld anzusehen, da sie dieselben Eigenschaften besitzen. Felder mit mehreren Instanzen sind eine ideale Alternative zum Erstellen mehrerer identischer Felder. Der Export von Feldern mit mehreren Instanzen erfolgt in getrennte Dateien oder Datenbanktabellen. Siehe Felder mit mehreren Instanzen.

Feld ohne Bereich

Ein in einer Dokumentdefinition erkanntes Feld, das über keinen Bereich im Bild verfügt. Siehe Felder ohne Bereich.

Feldbereich

Ein in der Dokumentdefinition hervorgehobener Bildbereich, der für die Datenextraktion vorgesehen ist.

Feldüberprüfung

Ein Überprüfungsmodus, bei dem die erkannten Zeichen im Kontext eines Felds zur Überprüfung übermittelt werden. Details... Collapsed Im Feldüberprüfungsmodus werden nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds überprüft. Grundsätzlich werden alle Felder an die Feldüberprüfung übermittelt, für die die Option An Feldüberprüfung senden aktiviert wurde. Es wird empfohlen, grundsätzlich jene Felder an die Feldüberprüfung zu übermitteln, deren Wertebereich bekannt ist oder einfach ermittelt werden kann. Beispiele für Felder dieser Art sind Länder- oder Städtenamen, da die Werte dieser Felder im Voraus bekannt sind.

FlexiLayout

Beschreibung der Struktur eines flexiblen Dokuments. Diese Beschreibung wird mit ABBYY FlexiLayout Studio erstellt und kann nach ABBYY FlexiCapture exportiert werden. FlexiLayouts stellen die Anweisungen für das Erkennen und Identifizieren von Feldern in einem flexiblen Formular bereit.

Flexible Beschreibung

Eine formalisierte Beschreibung der Dokumentstruktur zur Verbesserung der Felderkennung. Die Erstellung erfolgt in ABBYY FlexiLayout Studio. Das Dateiformat lautet: *.afl. Siehe FlexiLayout.

Flexible Dokumentdefinition

Definition eines Dokuments oder eines Bereichs davon, die für das Verarbeiten flexibler Dokumente vorgesehen ist. Die Erstellung erfolgt durch Anfügen eines FlexiLayouts. Die Felder in diesen Dokumentdefinitionen haben keine feste Position. Sie werden stattdessen mithilfe eines FlexiLayouts erkannt. Siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Formatfehler / Warnung

Dieser Fehler tritt auf, wenn der aus einem Feld extrahierte Wert nicht dem vorgegebenen Format entspricht, z. B. enthält ein Zahlenfeld Buchstaben oder der Wert ist nicht in der Liste der zulässigen Werte enthalten.

Formular

Dokument mit einer oder mehreren Seiten, das von einer Person handschriftlich oder mit einem Druckverfahren ausgefüllt werden soll.

Formularerfassung

Datenerfassung aus den Informationsfeldern von Formularen.

Formular mit farbigem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem farbigen Hintergrund erscheinen, der beim Scannen verschwindet.

Formular mit grauem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem grauen Hintergrund erscheinen, der beim Scannen verschwindet.

G

Gedruckter Text

Ein Texttyp für die Erkennung von Text, der mit einer Druckmaschine oder einem Laser- bzw. Ink-Jet-Drucker mit einer Mindestauflösung von 300 dpi gedruckt wurde.

Gruppenüberprüfung

Ein Überprüfungsmodus, bei dem als gleich erkannte Zeichen in Gruppen zur Überprüfung übermittelt werden. Details... Collapsed Grundsätzlich werden alle Felder an die Gruppenüberprüfung übertragen, für die die Option An Gruppenüberprüfung senden aktiviert wurde. Im Allgemeinen empfiehlt es sich, Zeichen aus Zahlenfeldern sowie Auswahlfelder zur Gruppenüberprüfung zu übermitteln.

H

Handschrifttext

Ein Texttyp für die Erkennung, der einen handschriftlichen Text darstellt.

Helligkeit

Ein Schwellenwert für die Lichtempfindlichkeit, der angibt, ab welchem Wert der Scanner Halbtöne von Graustufen als Weiß wiedergibt.

Hot folder

Ein Ordner auf der Festplatte des lokalen oder eines Remotecomputers, der zum Importieren von Bildern verwendet wird. Er wird meist für das regelmäßig wiederholte Laden von Bildern ohne Benutzerbeteiligung verwendet. Siehe Bildimportprofile.

I

Identifizierung von Dokumentdefinitionen

Vorgang, bei dem die passende Dokumentdefinition mithilfe von Kennungen ausgewählt wird.

Ignoriertes Zeichen

Ein Zeichen innerhalb von Wörtern (z. B. ein Aufzählungszeichen) oder ein weiches Trennzeichen (Tabulator usw.), das die Software nicht daran hindert, das Wort als erkennbaren Datentyp zu kennzeichnen. Details... Collapsed Diese Zeichen werden aus den Wörtern ausgeblendet, d. h. die Wörter werden ohne diese Zeichen einem bestimmten Datentyp zugeordnet.

Importprofil

Eine Kombination von Einstellungen, auf deren Grundlage Bilder einem Stapel hinzugefügt werden können. Zu den Einstellungen gehören die Bildquelle, Bildverarbeitungsoptionen und Bereinigungsoptionen für Hot Folder. Siehe Bildimportprofile.

Indexfeld

Ein Feld, mit dessen Wert Dokumente für die Sortierung und Suche indiziert werden. Siehe Indexfelder.

Invertiertes Bild

Ein Bild mit hellem Text auf dunklem Hintergrund.

ICR

Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Dieser Begriff bezieht sich auf Technologien oder Systeme für die Massenverarbeitung von Dokumenten, die mit handgeschriebenen Buchstaben und Ziffern ausgefüllt wurden.

K

Kennung

Ein statisches Element, das für die Auswahl einer Dokumentdefinition verwendet wird, wenn mehrere Dokumentdefinitionen über identisch positionierte Anker verfügen. In den Eigenschaften solcher statischen Elemente muss dazu die Option Für Identifizierung von Dokumentdefinitionen verwenden aktiviert sein.

Klassifikator

Ein in FlexiLayout Studio erstelltes Projekt zur vorläufigen Identifizierung von Seiten vor der Anwendung von Dokumentdefinitionen sowie zur Auswahl der zuzuordnenden FlexiLayout- oder Layoutalternative.

Konstantschrift

Texttyp, bei dem sich die einzelnen Buchstaben in einem Rahmen mit konstanter Höhe und Breite befinden, der dann beim Scannen verschwindet.

Kontrast

Das Verhältnis zwischen der Helligkeit des dunkelsten und hellsten Bereichs eines Bilds.

Korrigiertes Auswahlkästchen

Ein Auswahlkästchen, das fälschlicherweise markiert und anschließend durchgestrichen wurde. Wenn für das Auswahlfeld die Option Korrekturen zulassen aktiviert wurde, erkennt die Software das durchgestrichene Auswahlkästchen als nicht markiert.

Kreuz

Ein Anker in Form eines Kreuzes.

L

Lieferant

Eine juristische oder natürliche Person, die Waren oder Dienstleistungen verkauft. Der Lieferant stellt für die Waren und Dienstleistungen Rechnungen aus. Die Rechnungsinformationen können mithilfe von erfasst werden.

Lineares Schwarz-Weiß-Formular

Ein Formular, auf dem Informationsfelder durch Ränder aus einfachen Linien begrenzt sind, die beim Scannen nicht verschwinden.

M

Maschinenlesbares Formular

Ein Formular, das speziell für die automatische Datenerfassung entworfen wurde. Es enthält Arbeitselemente (Anker, Barcodes, Linien usw.), die für die ordnungsgemäße Verarbeitung erforderlich sind.

Mehrseitiges Dokument

Ein Dokument, das mehrere Seiten umfasst.

MRC

Mixed Raster Content. Ein Prozess, bei dem Segmentierungsmethoden für Bilder verwendet werden, um so die Kontrastauflösung eines aus Pixeln zusammengesetzten Rasterbildes zu verbessern.

N

Nicht strukturiertes Dokument

Ein Dokument mit Informationen, die ohne feste Struktur dargestellt werden. Zu diesen Dokumenten gehören z. B. Verträge, Briefe, Aufträge und Diagramme. Siehe Verarbeiten nicht strukturierter Dokumente.

O

OCR

Englische Abkürzung für "Optical Character Recognition". Optische Erkennung gedruckter Texte.

Operator

Ein Benutzer von ABBYY FlexiCapture, der für die Dokumenterfassung zuständig ist, also das Hinzufügen von Bildern, das Durchführen der Erkennung und Überprüfung und das Exportieren der erkannten Daten.

Optische Erkennung von Markierungen (Optical Mark Recognition, OMR)

Englische Abkürzung für "Optical Mark Recognition". Optische Erkennung von Markierungen. Mithilfe dieser Technologie kann ABBYY FlexiCapture einfache Markierungen (Häkchen, Kreuze usw.) auf Formularen mit einer hohen Genauigkeit erkennen und gleichzeitig auch zunächst falsch ausgefüllte und später durchgestrichene Markierungen ermitteln.

P

Projekt

In einem Projekt sind verschiedene Dokumentstapel gebündelt und die zur Verarbeitung erforderlichen Einstellungen (Dokumentdefinitionen oder Importprofile) festgelegt. Einzelheiten finden Sie unter Erstellen eines Projekts.

Punktmatrixdrucker

Ein Texttyp für die Erkennung, der mit einem Punktmatrixdrucker gedruckten Text darstellt.

R

Rasterformular

Ein Formular, in dem Informationsfelder als weiße Rechtecke auf grauem Hintergrund dargestellt werden, der entweder Rasterlinien oder durch Rasterlinien getrennte Rechtecke enthält.

Rasterlinie

Eine Linie aus Punkten in einheitlichem Abstand.

Rechnung

Ein Dokument, in dem die gelieferten Waren, deren Menge, Preis, Eigenschaften (wie Farbe, Gewicht usw.), die Versandbedingungen und Informationen über die Vertragsparteien aufgeführt sind.

Regelfehler / Warnung

Dieser Fehler tritt auf, wenn die aus einem oder mehreren Feldern extrahierten Daten nicht den Regeln der automatischen Prüfungen entsprechen, beispielsweise, wenn die Summe aller Werte einer Spalte nicht der im Feld mit dem Gesamtbetrag angezeigten Summe entspricht.

Regeln

Bedingungen für Datenfelder, die vom Programm automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regelbasierte Validierung

Vorgang, bei dem erkannte Daten anhand vordefinierter Regeln automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regulärer Ausdruck

Beschreibung der Struktur eines Worts oder eines Eingabewerts mithilfe einer speziellen Sprache. Die Software ermöglicht nicht nur die Angabe der zulässigen Zeichen, sondern auch der Struktur des Feldinhalts. Sie können die Struktur beim Festlegen von Einschränkungen für ein Textfeld und beim Erstellen benutzerdefinierter Datentypen mit einem regulären Ausdruck beschreiben. Siehe Alphabet in regulären Ausdrücken.

S

Scannen

Vorgang, bei dem ein Papierformular mithilfe eines Scanners in ein elektronisches Bild umgewandelt wird.

Schlüsselfeld

Ein Feld, das die automatische Überprüfung der Zusammenstellung von Seiten zu Dokumenten ermöglicht. Die Werte der Schlüsselfelder müssen auf allen Seiten des Dokuments gleich sein.

Schreibmaschine

Ein Texttyp für die Erkennung, der mit einer Schreibmaschine geschriebenen Text darstellt.

Schreibstil

Schreibweise, die für eine spezielle Gruppe kennzeichnend ist. Ein Beispiel ist die amerikanische Schreibweise von Zahlen. Details... Collapsed Diese Option wird für das Konfigurieren des Schreibstils handschriftlicher Zeichen in Formularen verwendet. Die Auswahl eines Schreibstils richtet sich nach dem Ort, an dem die Dokumente verarbeitet werden (Russland, Deutschland, Tschechische Republik, USA usw.).

Schwarzes Quadrat

Ein Anker in Form eines schwarzen Quadrats.

Seite

Abbild einer Papierseite mit dem Ergebnis der Dokumentverarbeitung.

Seitenausrichtung

Position der Seite in Bezug auf die Standardausrichtung: von oben nach unten und von links nach rechts. Die Seitenausrichtung kann automatisch bei der Erkennung des Seitenbilds bestimmt werden. Sie können dazu in ABBYY FlexiCapture die möglichen Ausrichtungen angeben.

Seitenlayout

Ein Schema mit den Positionen der Felder auf einem Bild.

Sprache (Gebietsschema)

Eine Feldeigenschaft, die die Schriftsprache und wichtige regionale Parameter (z. B. Datumsformat oder Adressenschreibweise) festlegt.

Stapeltyp

Die Eigenschaft eines Stapels, die definiert, wie Dokumente in den entsprechenden Stapeln verarbeitet werden müssen. Siehe Stapeltypen

Statische Dokumentdefinition

Definition eines Dokuments oder eines Bereichs davon, die für das Verarbeiten statischer Formulare vorgesehen ist. Die Felder in einer statischen Dokumentdefinition haben eine feste Position.

Statische Elemente

Nicht erkennbare Zeichen, die der Zuordnung und Identifizierung der Dokumentdefinition dienen. Zu diesen Zeichen gehören: Anker, Ankertext, Trennlinien, Ankerbarcodes.

Statisches Formular

Ein Dokument mit statischen Informationsfeldern, deren Formatierung, Anzahl und Layout fest definiert sind und die auch bei unterschiedlichen Dokumentinstanzen unveränderlich bleiben.

T

Tabelle

Daten, die in einem (nicht notwendigerweise sichtbaren) zweidimensionalen Raster angeordnet sind. Die Software verarbeitet Tabellen, die aus Spalten mit gleichen Datentypen und sich wiederholenden Zeilen bestehen.

Tabellenfeld

Tabellenfeld

Ein Dokumentdefinitionsfeld, das eine Tabelle enthält. Dabei handelt es sich um ein zusammengesetztes Feld, bei dem jede Tabellenspalte einen Satz von Feldern desselben Typs darstellt: Textfelder, Auswahlkästchen, Barcodes oder Bilder.

Teilweise strukturiertes Dokument

Ein Dokument mit einer Reihe von Informationsfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Einzelheiten finden Sie unter Unterstützte Dokumenttypen in ABBYY FlexiCapture.

Teststapel

Dokumentstapel, die für das Testen und Konfigurieren von Dokumentdefinitionen vorgesehen sind. Für die Verarbeitung von Teststapeln werden lokale Kopien von Dokumentstapeln verwendet. Siehe .

Text des Dokuments

Der gesamte Text eines Dokuments, der bei der vorläufigen Erkennung erfasst wurde, bevor das FlexiLayout angewandt wird. Sie können diesen Text speichern (erfordert zusätzlichen Speicherplatz auf der Festplatte), damit er während der Überprüfung zur Verfügung steht.

Text im Rahmen

Texttyp, der anzeigt, wo der Text durch einen Rahmen begrenzt wird. Anzeigen... Collapsed

Text im Rahmen mit Kamm

Texttyp, der anzeigt, wo Text durch einen Rahmen begrenzt wird, dessen unterer Rand wie ein Kamm geformt ist. Anzeigen... Collapsed

Textausrichtung

Ausrichtung des Texts in einem Feld in Bezug auf die Seite.

Textbeispiel

Eine Datei mit Beispielen aller alphabetischen Zeichen.

Texterkennung (OCR, ICR)

Umwandlung eines grafischen Bilds in Text.

Textfeld

Element eines maschinenlesbaren Formulars, das beim Ausfüllen dieses Formulars der Eingabe von Text dient.

Textfeldmarkierung

Ein Grafikelement, das ein Textfeld begrenzt, z. B. Rahmen, Kamm oder Linie.

Textmarkierung

Das Layout eines Seitenbereichs, der für die Texteingabe vorgesehen ist. Beispiele für die Textformatierung finden Sie unter Entry field.

Training [Dokumentdefinition]

Eine Funktion in ABBYY FlexiCapture for Invoices, mit der Benutzer dem Programm vermitteln können, wie Informationen aus bestimmten Rechnungstypen zu erfassen sind. Das Training verbessert die Qualität der Datenerfassung und kann entweder bei der Einrichtung des Programms oder während der Verarbeitung erfolgen.

Trennzeichen

Element eines maschinenlesbaren Formulars, das durch eine vertikale oder horizontale Linie dargestellt wird.

U

Überprüfung

Bei der Überprüfung wird festgestellt, ob die Daten erkannt wurden, die Seiten korrekt in Dokumente zusammengefasst wurden und die Regeln keine Fehler zurückgegeben haben. Überprüfung auf der Operator Station gemacht. Siehe Überprüfung.

Umgebungsvariable

Eine Zeichenkette, die dazu dient, Text wie beispielsweise Systemeinstellungen zu speichern. Umgebungsvariablen dienen dazu, die Verbindungszeichenketten der Datenbank und Variablen zu speichern, die bei der Festlegung der Namen von exportierten Dateien verwendet werden.

Unerkennbarer Bereich

Ein Bildbereich, der von der Erkennung ausgeschlossen ist. Auf diese Weise können Sie einen Bereich mit erklärendem Text oder einem Bild ausschließen, der die Felderkennung erschweren würde. Siehe Ausschließen eines Bereichs von der Erkennung.

Unterstrichener Text

Art der Hervorhebung, bei der Zeichen unterstrichen sind. Anzeigen... Collapsed

Unzulässiges Zeichen

Ein Zeichen, von dem Sie mit Sicherheit wissen, dass es nicht in den zu erkennenden Daten enthalten sein wird. Details... Collapsed Die Angabe solcher Zeichen kann zu einer deutlich höheren Geschwindigkeit und Qualität bei der Erkennung führen. Wenn erkannter Text z. B. nur Großbuchstaben enthält, können Sie sämtliche Kleinbuchstaben als unzulässige Zeichen kennzeichnen.

V

Veröffentlichung von Dokumentdefinitionen

Freigabe einer neuen Dokumentdefinitionsversion nach deren Bearbeitung. Während veröffentlichte Versionen bei der Verarbeitung von Dokumenten aus Arbeitsstapeln zum Einsatz kommen, können nicht veröffentlichte, lokale Versionen nur bei der Verarbeitung von Dokumentdefinitionen aus Teststapeln verwendet werden. Siehe Bearbeitung und Veröffentlichung einer Dokumentdefinition.

W

Winkel

Ein Anker in Form eines Winkels.

Wörterbuch

Eine Liste von Wörtern, mit denen ein bestimmter Datentyp bestimmt wird. Details... Collapsed Das Wörterbuch wird beim Erstellen des Datentyps angegeben. Dadurch ist bereits mit dem Datentyp eines Felds das Wörterbuch festgelegt, das bei der Erkennung und Überprüfung verwendet wird. Die Software unterstützt nicht nur vordefinierte Datentypen mit fertigen Wörterbüchern, sondern ermöglicht es dem Benutzer auch, Datentypen mit individuellen Wörterbüchern zu erstellen. Sie können die Wörterbuchdaten manuell eingeben oder aus einer Datei laden.

X

XFD

Abkürzung für XML-Formulardefinition (*.xfd). Hierbei handelt es sich um ein spezielles Dateiformat für Formulare, die mit ABBYY FormDesigner erstellt wurden. Mithilfe von XFD-Dateien können in ABBYY FlexiCapture.

Z

Zeichenkodierung

Eine Tabelle mit Werten, die den Zeichensatz einer bestimmten Sprache beschreiben.

Zulässiger Zeichensatz

Eine Gruppe von Zeichen, die im zu erkennenden Datentyp vorkommt.

Collapsed Details

Dieser Satz wird durch den Datentyp definiert. Das bedeutet, dass durch den an ein Feld angefügten Datentyp festgelegt wird, welcher Zeichensatz bei der Erkennung verwendet wird.

Neben der Auswahl der Zeichen in diesem Zeichensatz können Sie zusätzliche Parameter konfigurieren, die diesen Satz einschränken. Beispielsweise könnten Sie folgende Zeichen ausschließen:

  • Zeichen, von denen Sie wissen, dass sie nicht im zu erkennenden Feld vorkommen (z. B. sämtliche Kleinbuchstaben in einem Feld, wenn in diesem Feld nur Großbuchstaben zulässig sein sollen).
  • Zeichen, die in Wörtern auftreten können, aber die Überprüfung dieser Wörter nicht beeinträchtigen sollen (z. B. Bindestriche, Betonungszeichen usw.).

Zuordnung von Dokumentdefinitionen

Vorgang, bei dem eine Dokumentdefinition ausgewählt wird und ihre Felder einem Bild zugeordnet werden.

Zusammenstellungsfehler

Dieser Fehler tritt auf, wenn ein Dokument, das in der Dokumentzusammenstellung erstellt wurde, Seiten aus anderen Dokumente enthält oder wenn die Reihenfolge der Seiten dieses Dokuments falsch ist oder wenn die Werte der Schlüsselfelder auf den Seiten eines Dokuments nicht identisch sind.


Technischer Support

Wenn Sie Fragen zur Verwendung von ABBYY FlexiCapture haben, finden Sie in den Hilfethemen und im Benutzerhandbuch von ABBYY FlexiCapture eine ausführliche Beschreibung der Funktionen. Auch im Bereich des Technischen Supports auf unserer Website unter www.abbyy.com finden Sie Antworten zu bestimmten Fragen.

Damit der Technische Support Ihre Fragen beantworten kann, sind folgende Informationen erforderlich:

  • Nachname, Vorname

  • Name der Organisation

  • Telefonnummer (Fax, E-Mail-Adresse)

  • Seriennummer Ihres Installationspakets

  • Build (siehe Hilfe/Info zu ABBYY FlexiCapture)

  • Allgemeine Beschreibung des Problems mit dem vollständigen Text der Fehlermeldung (sofern vorhanden)

  • Typ des Computers und Prozessors

  • Windows-Version

  • Weitere Informationen, die Sie für wichtig erachten

Adressen und Kontaktinformationen der Niederlassungen von ABBYY


Informationen zum Kauf von ABBYY FlexiCapture

Wenn Sie ABBYY FlexiCapture bestellen möchten oder eine Frage zum Kauf haben, wenden Sie sich bitte an eine der regionalen ABBYY-Niederlassungen.


ABBYY-Vertretungen

USA, Mexiko und Zentralamerika | ABBYY USA Telefon: +1 408-457-9777 Fax: +1 408-457-9778 Addresse: 880 North McCarthy Blvd., Suite 220 Milpitas, CA 95035, USA E-mail: sales@abbyyusa.com Support e-mail: support@abbyyusa.com Website: http://www.abbyy.com
Kanada | ABBYY Canada Telefon: +1 408 457 9777 Fax: +1 408 457 9778 Addresse: 555 Legget Dr., Suite 304 Kanata, Ontario K2k 2X3, Canada E-mail: info_canada@abbyyusa.com Support e-mail: support_canada@abbyyusa.com Website: http://www.abbyy.com
Taiwan | ABBYY Taiwan Addresse: 3F., No.156, Jiankang Rd., Songshan Dist., Taipei City 105, Taiwan (R.O.C.) E-mail: info_taiwan@abbyyusa.com Support e-mail: support_taiwan@abbyyusa.com Website: http://www.abbyy.com
Westeuropa | ABBYY Europe GmbH Telefon: +49 (0)89 511 159 0 Fax: +49 89 (0)511 159 59 Addresse: Elsenheimerstraße 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Support e-mail: support_eu@abbyy.com Website: http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
Osteuropa und Mittelmeerraum | ABBYY Ukraine Telefon: +380 44 490 9999 Fax: +380 44 490 9461 Addresse: P.O. Box 23, 02002 Kiev, Ukraine E-mail: sales@abbyy.ua Support-Telefon: +380 44 490 9463 Support e-mail: support@abbyy.ua Website: http://www.abbyy.ua
Afrika, Asien, Südamerika, Griechenland und die Baltischen Staaten | ABBYY 3A Telefon: +7 495 783 3700 Fax: +7 495 783 2663 Addresse: P.O. Box 32, Moscow 127273, Russia E-mail: sales_3A@abbyy.com Support e-mail: support@abbyy.com Website: http://www.abbyy.cn http://www.abbyy.com.br http://latam.abbyy.com
Großbritannien | ABBYY UK Ltd. Telefon:+0870 600 0231 Fax: +01344 392 611 Addresse: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-mail: sales_UK@abbyy.com Support E-mail: support_eu@abbyy.com Website: http://www.abbyy.co.uk
Japan | ABBYY Japan Telefon:+81-42-795-1901 Fax: +81-42-795-1901 Addresse: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Support E-mail: support@abbyyusa.com Website: http://www.abbyy.com
Australien und Neuseeland | ABBYY Australia Addresse: Citigroup Building, level 39, 2 Park Street, Sydney, NSW, 2000, Australia E-mail: sales_au@abbyy.com Support e-mail: support@abbyy.com Website: http://www.abbyy.com
Alle anderen Regionen | ABBYY Russia Telefon: +7 495 783 3700 Fax: +7 495 783 2663 Postanschrift: Russia, 127273, Moscow, P.O. box 32, ABBYY Firmenanschrift:: Moscow, ul. Otradnaya 2B, str. 6, Otradny Business Centre E-mail: sales@abbyy.ru Support e-mail: support@abbyy.ru Website: http://www.abbyy.ru KARTE


Endbenutzer-Lizenzvertrag

You are here: Anhang > Endbenutzer-Lizenzvertrag

Endbenutzer-Lizenzvertrag (EULA)

ABBYY® FlexiCapture®

Wichtig: Lesen Sie die nachstehenden Bedingungen sorgfältig durch, bevor Sie ABBYY FlexiCapture (nachstehend die SOFTWARE genannt) installieren, kopieren und/oder anderweitig nutzen. Indem Sie die SOFTWARE installieren, kopieren oder anderweitig nutzen, erklären Sie sich mit diesen Bedingungen einverstanden. Dieser Endbenutzer-Lizenzvertrag (nachstehend “EULA” genannt) ist ein rechtsgültiger Vertrag zwischen Ihnen, dem Endbenutzer, der diese SOFTWARE erworben hat, und ABBYY.

Dieser EULA tritt in Kraft, wenn Sie Ihr Einverständnis erklären, daran gebunden zu sein, indem Sie die Taste “Ich akzeptiere die Bedingungen dieses Lizenzvertrags” und danach die Taste “Weiter” drücken und die SOFTWARE installieren bzw. wenn Sie die SOFTWARE auf irgendeine Weise installieren, kopieren oder starten. Durch jegliche derartige Handlung bestätigen Sie, diesen EULA gelesen und zur Kenntnis genommen zu haben, und verpflichten sich zur Einhaltung der hierin festgelegten Bedingungen. Wenn Sie den Bedingungen dieses EULA nicht zustimmen, dürfen Sie diese SOFTWARE nicht verwenden. Deaktivieren Sie diese und entfernen Sie sie von Ihrem Computer und zerstören Sie Ihre Kopien der SOFTWARE. Der EULA ist bis zum Ablauf des Urheberrechts für die SOFTWARE rechtsverbindlich, es sei denn, es wurden in diesem EULA oder zwischen Ihnen und ABBYY oder ABBYYs Partner in einem getrennten schriftlichen Vertrag andere Vereinbarungen getroffen, und ist unter Umständen abhängig vom Lizenzumfang, wie er in diesem EULA beschrieben ist.

Die SOFTWARE ist durch Urheberrechte und internationale Vertragsbedingungen geschützt und einige Teile sind durch Patentgesetze und Gesetze über den Schutz von Geschäftsgeheimnissen geschützt. Sie erkennen an, dass dieser Endbenutzer-Lizenzvertrag – wie jeder andere schriftliche und von Ihnen unterzeichnete Vertrag – einklagbar ist. Dieser EULA ist gegenüber IHNEN einklagbar.

Falls der SOFTWARE eine separate, gedruckte Vereinbarung mit ABBYY oder ABBYYs Partner über Ihre Verwendung der SOFTWARE beiliegt und inhaltliche Abweichungen zwischen dem Text dieses EULA und dem Text der gedruckten Vereinbarung bestehen, ist der Text in der gedruckten Fassung einer solchen separaten Vereinbarung maßgebend.

Der EULA kann in verschiedenen Sprachen verfügbar sein. Es kann sein, dass Abweichungen oder Unterschiede bei der Interpretation der englischen Version des EULA und den in anderen Sprachen vorliegenden EULA bestehen. Zum Zweck der Einheitlichkeit und zur Vermeidung jeglicher Zweideutigkeit ist die englische Version des EULA bei sämtlichen Streitigkeiten, Forderungen oder Gerichtsverfahren zur Interpretation, Durchsetzung oder anderen Handlungen bezüglich des EULA maßgeblich.

Definitionen

“ABBYY” bezieht sich auf:

ABBYY USA Software House Inc., registriert in 880 North McCarthy Boulevard, Suite 220, Milpitas, Kalifornien 95035, USA, wenn Paragraph 13.1 dieses EULA angewandt wird;

ABBYY Europe GmbH registriert in der Elsenheimerstrstraße 49, 80687 München, Deutschland, wenn Paragraph 13.2 dieses EULA angewandt wird;

ABBYY UK Ltd. Eingetragen unter Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, Großbritannien, wenn Paragraph 13.3 dieses EULA angewandt wird;

ABBYY Production LLC eingetragen unter 1-ya ul. Tekstilshikov, d. 12/9, office 2, 109390, Moskau, Russland, wenn Paragraph 13.4 dieses EULA angewandt wird;

ABBYY Software House Ukraine registriert unter 31, Degtyarevskaya st., Kiev, Ukraine, 03680, wenn Paragraph 13.5 dieses EULA angewandt wird;

und ABBYY Solutions Ltd., registriert unter Michail Karaoli 2, Egkomi, CY 2404, Nicosia, Cyprus in allen anderen Fällen

“ABBYY Partner” steht für eine Körperschaft oder eine Einzelperson, die von ABBYY ermächtigt wurde, die SOFTWARE an Endbenutzer weiterzuverkaufen und zu vertreiben, entweder direkt oder durch einen oder mehrere Wiederverkäufer oder -vertriebe.

“Aktivierung” steht für das Verfahren, durch das die Gültigkeit der Seriennummer geprüft und die vollständige Funktionsfähigkeit der installierten SOFTWARE gemäß den Anweisungen in der SOFTWARE-Dokumentation und laut Ihrer Lizenz hergestellt wird.

“Computer” steht für ein spezifisches physisches Gerät oder eine virtuelle Maschine, die aus einem oder mehreren CPU-Kernen (Prozessorkernen) besteht und ein spezifisches Betriebssystem ausführt. Jegliche Änderungen an der Konfiguration oder der Zusammensetzung des Computers könnten dazu führen, dass der Computer für Lizenzzwecke als ein anderer Computer erachtet wird. “Rechte am geistigen Eigentum” stehen für sämtliche Rechte am geistigen Eigentum und dem Eigentum an Patenten und Gebrauchsmustern und umfassen Rechte an (i) Erfindungen, Entdeckungen und Patentbriefe einschließlich der entsprechenden Anträge, Abänderungen, Fortsetzungen und Fortsetzungen mit hinzugefügtem neuem Material, (ii) Urheberrechte; (iii) Designs und Produktdesigns; (iv) Marken, Dienstleistungsmarken, Handelsaufmachungen und ähnlichen Rechten; (v) Know-how, Geschäftsgeheimnisse und vertrauliche Informationen; (vi) Rechte an integrierter Schaltungstopographie und Halbleiterschutzrechte; und (vii) sonstigen proprietäre Rechte.

“Lizenz” bezeichnet das Ihnen von ABBYY gewährte nicht exklusive Recht zur Installation und Nutzung der Funktionalität der SOFTWARE gemäß den Bedingungen des vorliegenden Endbenutzer-Lizenzvertrags.

“Seriennummer” steht für eine eindeutige Kennzeichnung der Lizenz oder einer Gruppe von Lizenzen mit ähnlichen Parametern, die dem Endbenutzer von ABBYY oder einem ABBYY-Partner übergeben wird.

“SOFTWARE” steht für jede Version oder Ausgabe des ABBYY FlexiCapture, einschließlich jeglicher und aller Software-Komponenten (Add-ons, benutzerdefinierte Komponenten und Module usw.), die in die Software eingebettet sind oder online oder auf andere Weise bereitgestellt werden, wie: Programm-, Hilfe-, Demo-, Muster- und andere Dateien; Bibliotheken, Datenbanken, Muster, assoziierte Medien (Bilder, Fotos, Animation, Audio-Video-Komponenten, Musik usw.), gedruckte Materialien und andere Softwarekomponenten.

“Sie”, “Ihr(e)” und “Endbenutzer” bezieht sich auf und umfasst jede natürliche Person oder Körperschaft, die diese SOFTWARE zur eigenen Nutzung erworben hat, und nicht zu dem Zweck des Weiterverkaufs, und jeden tatsächlichen Benutzer der SOFTWARE.

1. Lizenzgewährung

1.1. Unter den allgemeinen Geschäftsbedingungen dieses EULA gewährt Ihnen ABBYY eine eingeschränkte, nicht exklusive Lizenz zur Installation und Nutzung der Funktionalität der SOFTWARE, gemäß aller Einschränkungen und dem Umfang der Lizenz wie durch diesen EULA gewährt, der Software- und/oder der Hardware-Lizenzschlüssel, die von ABBYY bereitgestellt werden (“Lizenzschlüssel”), der SOFTWARE, und/oder einer separaten, schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY. Alle hierin aufgeführten Bedingungen gelten sowohl für die SOFTWARE als Ganzes als auch für deren einzelne Komponenten und die Endbenutzer-Dokumentation.Alle Fragen bezüglich des Umfangs der Lizenz werden zugunsten der Einschränkungen des Umfangs der Lizenz ausgelegt. Technisch betrachtet definiert der Lizenzschlüssel also den Umfang der von Ihnen erworbenen Lizenz und schränkt die Nutzung der SOFTWARE entsprechend ein. Die Einschränkungen Ihrer Nutzung der SOFTWARE und des Umfangs Ihrer Lizenz können Folgendes umfassen, sind jedoch nicht darauf beschränkt:

1.1.1. Anzahl der Plätze, SOFTWARE-Komponenten und Netzwerkzugriff. Sie dürfen die SOFTWARE auf mehr als einem Computer in einem Netzwerk installieren und festgelegte Komponenten der SOFTWARE auf einer festgelegten Anzahl von Computern eines Netzwerks gleichzeitig nutzen („Gleitlizenz“). Informationen zur Anzahl der SOFTWARE-Komponenten und Computer in einem Netzwerk, die gleichzeitig mit der SOFTWARE arbeiten dürfen, sind in Ihrem Lizenzschlüssel und/oder der schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY festgelegt.

1.1.2. Verarbeitungsvolumen. Die Anzahl der Seiten, die von der SOFTWARE verarbeitet werden kann, ist möglicherweise auf eine oder mehrere Arten beschränkt, z. B. durch Einschränkungen der Anzahl der Seiten, die innerhalb eines bestimmten Zeitraums verarbeitet werden können, etwa monatlich oder jährlich, oder durch die Gesamtzahl der Seiten, die verarbeitet werden können. Die Seitengröße und die Anzahl der Datenfelder pro Dokument können ebenfalls eingeschränkt sein. Die Einschränkungen des Verarbeitungsvolumens sind in Ihrem Lizenzschlüssel und/oder der schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY aufgeführt.

1.1.3. Dauer. Die Nutzung der SOFTWARE kann auf einen bestimmten Zeitraum beschränkt werden und die Software darf nach Ablauf dieses Zeitraums nicht mehr verwendet werden. Die Einschränkungen des Zeitraums sind in Ihrem Lizenzschlüssel und/oder der schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY dargelegt.

1.1.4. Funktionen, Add-ons und benutzerdefinierte Komponenten. Die Verwendung bestimmter Funktionen, Add-ons und/oder benutzerdefinierter Komponenten der SOFTWARE kann durch Ihren Lizenzschlüssel und/oder eine schriftliche Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY eingeschränkt werden.

1.2. Bearbeitungsleistung. Die Anzahl der CPU-Kerne auf dem Computer, die gleichzeitig von der SOFTWARE an den Bearbeitungsstationen verwendet werden, darf die Anzahl, die in Ihrem Lizenzschlüssel und/oder einer schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY spezifiziert wurde, nicht überschreiten. Alle Ihnen nicht ausdrücklich im EULA gewährten Rechte sind ABBYY vorbehalten. Dieser EULA gewährt Ihnen keinerlei Rechte in Verbindung mit Marken von ABBYY.

1.3. Wenn Artikel 13.4 zutrifft und Sie eine individuelle, natürliche Person sind, dürfen Sie die SOFTWARE weltweit verwenden. Wenn Artikel 13.4 zutrifft und Sie eine Körperschaft sind, darf die SOFTWARE nur in dem Land erworben (gekauft) werden, in dem die Körperschaft oder ihre Filiale und Geschäftsbüros eingetragen sind, es sei denn, es wurden zwischen Ihnen und ABBYY oder einem Partner von ABBYY in einem getrennten Vertrag andere Vereinbarungen getroffen. Die Angestellten der Körperschaft oder ihrer Zweigstelle und Geschäftsbüros dürfen die SOFTWARE weltweit verwenden, sofern die SOFTWARE in dem Land erworben und installiert wurde, in dem die Körperschaft oder ihre Zweigstelle und Geschäftsbüros eingetragen sind, es sei denn, es wurden zwischen Ihnen und ABBYY oder einem Partner von ABBYY in einem getrennten Vertrag andere Vereinbarungen getroffen.

1.4. Jegliche Verwendung der SOFTWARE oder ihrer Komponenten außerhalb der oder unter Zuwiderhandlung gegen die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags stellt einen Verstoß gegen die Rechte am geistigen Eigentum von ABBYY und/oder Dritten dar und hat den Entzug aller Rechte zur Nutzung der SOFTWARE zur Folge, die Ihnen in diesem Endbenutzer-Lizenzvertrag gewährt werden.

1.5. Wenn Sie die SOFTWARE in einer virtuellen Umgebung einsetzen, darf der Zugang oder die Nutzung der SOFTWARE zu keiner Zeit die Einschränkungen bezüglich der SOFTWARE oder den Umfang der gewährten Lizenz überschreiten. Zum Beispiel darf nicht derselbe Lizenzschlüssel verwendet werden, um Zugriff auf die SOFTWARE oder ihre Verwendung in einer virtuellen Umgebung durch eine Anzahl an Computern zu gestatten, die höher ist als die Anzahl an Computern, für die eine Lizenz ordnungsgemäß erworben wurde. Ebenfalls darf die SOFTWARE nicht eingesetzt werden, um mehr Seiten als erlaubt zu verarbeiten.

1.6. Wenn Sie auf die SOFTWARE mittels Terminal-Services zugreifen, die den Zugang zur SOFTWARE auf einem Remote-Computer über ein Netzwerk ermöglichen, darf die Anzahl der simultan ausgeführten Instanzen der SOFTWARE nicht die Anzahl an Computern übersteigen, für die eine Lizenz erworben wurde.

1.7. Wenn Sie die SOFTWARE über einen Webbrowser verwenden, dürfen Sie auf die SOFTWARE gleichzeitig mit so vielen Computern zugreifen, wie durch den Umfang Ihrer Lizenz erlaubt und in Ihrem Lizenzschlüssel und/oder der schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY angegeben.

1.8. Sie erhalten die SOFTWARE möglicherweise auf mehreren Datenträgern, wozu auch Downloads über das Internet gehören können. Ungeachtet der Menge oder des Typs der Datenträger, die Sie erhalten, wird Ihnen lediglich die Lizenz zur Nutzung der SOFTWARE entsprechend der SOFTWARE-Lizenz gewährt

2. Nutzungseinschränkungen

2.1. Um die SOFTWARE zu verwenden, müssen Sie die SOFTWARE nach der Installation aktivieren.

2.2. Alle Nutzungsbedingungen und -einschränkungen zur Nutzung der SOFTWARE sind in diesem EULA niedergelegt, es sei denn, dies wurde in einer separaten, schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY oder in einer anderen Dokumentation, die der SOFTWARE beiliegt, anderweitig ausgeführt.

2.3. Sie dürfen keine der unten aufgeführten Vorgänge durchführen und auch Dritten nicht ermöglichen, diese durchzuführen:

2.3.1. Rückentwicklung (Reverse Engineering), Demontage, Dekompilierung (d. h. Vervielfältigung und Transformation des Objektcodes in Quellcode) oder andere Versuche, den Quellcode für die SOFTWARE oder jeglicher Teile abzuleiten, außer und nur in dem Umfang, in dem eine solche Aktivität ausdrücklich vom geltenden Recht, abweichend von dieser Einschränkung, erlaubt ist. Sollte die Einschränkung solcher Aktivitäten nach geltendem Recht verboten sein, dürfen die entsprechenden Informationen dritten Parteien nicht mitgeteilt werden, es sei denn, eine solche Mitteilung wird vom Gesetz gefordert und solche Informationen müssen ABBYY unverzüglich mitgeteilt werden. Alle diese Informationen müssen als vertrauliche Daten und als Eigentum von ABBYY behandelt werden.

2.3.2. Die SOFTWARE modifizieren, anpassen (einschließlich Änderungen mit dem Zweck, die SOFTWARE auf Ihrer Hardware ausführen zu können), beliebige Änderungen des Objektcodes der SOFTWARE, in der SOFTWARE enthaltenen Anwendungen und Datenbanken ausführen, außer den in der SOFTWARE vorgesehenen und in der Dokumentation beschriebenen.

2.3.3. Fehler in der SOFTWARE beseitigen oder die SOFTWARE übersetzen ohne vorherige schriftliche Genehmigung von ABBYY.

2.3.4. Rechte, die Ihnen durch diesen EULA gewährt wurden, oder andere Rechte im Zusammenhang mit dieser SOFTWARE an Dritte vermieten, verleihen, vermieten, unterlizenzieren, abtreten oder übertragen oder diesen die Erlaubnis erteilen, die SOFTWARE über den in Artikel 2.6 beschriebenen Rahmen hinaus teilweise oder vollständig auf andere Computer zu kopieren (außer wie in Artikel 2.6 beschrieben).

2.3.5. Jeglicher Person, die nicht zur Nutzung der SOFTWARE befugt ist, den Zugang zur/die Nutzung der SOFTWARE ermöglichen, einschließlich, ohne Einschränkung, in einem System mit mehreren Benutzern, einer virtuellen Umgebung oder über das Internet.

2.3.6. Hinweise zu Copyright, Marken und Patenten, die sich bei Lieferung auf der SOFTWARE befinden, beseitigen, ändern oder unleserlich machen.

2.4. Sie dürfen die SOFTWARE nicht verwenden, um Dritten bezahlte oder kostenlose Erkennungs- und Konvertierungsdienstleistungen anzubieten und/oder Ergebnisse oder eine Zugriffsmöglichkeit auf Ergebnisse verfügbar zu machen, die durch Benutzung der SOFTWARE als Teil eines anderen Dienstes mit Erkennungs- oder Konvertierungsverfahren als Komponente erhalten wurden, es sei denn, Sie haben mit ABBYY eine separate schriftliche Vereinbarung abgeschlossen und in Ihrem Lizenzschlüssel ist der Parameter „BPO services“ aktiviert.

2.5. Sie dürfen ohne eine zusätzliche, schriftliche Vereinbarung mit ABBYY die Benutzerschnittstelle der SOFTWARE, die im Lieferumfang der SOFTWARE enthalten ist, nicht umgehen.

2.6. Sie können diese SOFTWARE lediglich einmal dauerhaft und nur direkt an einen anderen Endbenutzer übertragen. Wenn Sie eine juristische Person sind, ist für eine solche Übertragung eine schriftliche Genehmigung von ABBYY erforderlich. Diese Übertragung muss die gesamte SOFTWARE (einschließlich aller Kopien, SOFTWARE-Komponenten, Datenträger, gedruckten Materialien, sämtlicher Updates sowie dieses Endbenutzer-Lizenzvertrags) umfassen. Eine solche Übertragung darf nicht per Versand oder auf anderem indirekten Weg erfolgen. Der Empfänger der Übertragung muss sich zur Einhaltung der Bestimmungen dieses EULA verpflichten, einschließlich der Verpflichtung, diese SOFTWARE nicht seinerseits weiterzugeben. Sie müssen die SOFTWARE im Falle einer solchen Übertragung der SOFTWARE von all Ihren Computern oder Ihrem Local Area Network deinstallieren.

3. Vorabversion, Test- oder Demo-SOFTWARE

3.1. Wenn es sich bei der SOFTWARE, die Sie mit dieser Lizenz erhalten haben, um eine vorkommerzielle Veröffentlichung oder um Beta-Software handelt, die zu Demonstrations-, Verifikations- oder Testzwecken bereitgestellt wurde, die eine eingeschränkte oder keine volle Funktionalität aufweist und eine der Bezeichnungen “Try&Buy” “Test”, “Demo” trägt oder kostenlos zur Verfügung gestellt wurde (“eingeschränkte Software”), gilt dieser Artikel 3, bis Sie eine Lizenz für die Vollversion der SOFTWARE erwerben. Wenn eine Bestimmung in diesem Abschnitt nicht mit einer anderen Bestimmung oder Bedingung in diesem EULA übereinstimmt, ersetzt dieser Abschnitt diese andere(n) Bestimmung(en) und Bedingung(en) in Bezug auf die eingeschränkte Software, jedoch nur in dem zur Lösung des Problems erforderlichen Maß.

3.2. DIE EINGESCHRÄNKTE SOFTWARE WIRD IHNEN “WIE GESEHEN” BEREITGESTELLT UND OHNE GARANTIE ODER SCHADENSERSATZ (AUSDRÜCKLICH, IMPLIZIERT ODER RECHTLICH) JEGLICHER ART. DIE EINGESCHRÄNKTE SOFTWARE STELLT KEINE ENDGÜLTIGE SOFTWARE VON ABBYY DAR UND KANN DEFEKTE, FEHLER UND ANDERE PROBLEME ENTHALTEN, DIE ZU SYSTEMVERSAGEN ODER ANDEREN AUSFÄLLEN UND DATENVERLUSTEN FÜHREN KÖNNEN. SOWEIT DIES DIE GELTENDEN GESETZE ZULASSEN, BESTEHT FÜR DIE EINGESCHRÄNKTE SOFTWARE KEINE GARANTIE, UND SIE BESTÄTIGEN, DASS ABBYY KEINERLEI GARANTIE ODER HAFTUNG IHNEN GEGENÜBER ÜBERNIMMT, EINSCHLIESSLICH STILLSCHWEIGENDER GARANTIEN AUF VERKEHRSFÄHIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, OHNE DARAUF BESCHRÄNKT ZU SEIN. IN DEN FÄLLEN, IN DENEN DIE HAFTUNG NICHT AUSGESCHLOSSEN, WOHL ABER BESCHRÄNKT WERDEN KANN, BLEIBT DIE GESAMTHAFTUNG VON ABBYY UND SEINEN PARTNERN AUF EINEN BETRAG VON FÜNFZIG US-DOLLAR (U.S. $ 50) ODER DEN GESAMTBETRAG BEGRENZT, DEN SIE FÜR DIE SOFTWARE BEZALT HABEN, JE NACHDEM, WELCHER BETRAG HÖHER IST.

3.3. Die eingeschränkte Software kann eine eingeschränkte Funktionalität aufweisen, wie eine zeitlich begrenzte Nutzung, und nach Ablauf der erlaubten Funktionalität (“Ablauf”) kann der Zugriff auf die und die Verwendung der beschränkten Software deaktiviert werden. Bei einer beschränkten Laufzeit enden Ihre Rechte gemäß dem EULA nach Ablauf der Zeit, sofern Sie keine neue Lizenz von ABBYY erwerben

3.4. Eingeschränkte Software, für die es keine kommerzielle Version gibt.

3.4.1. Eingeschränkte Software, für die es keine kommerzielle Version gibt, fällt unter die vertraulichen Informationen von ABBYY.

3.4.2. Was eingeschränkte Software angeht, für die es keine kommerzielle Version gibt, gewährt ABBYY keine Zusicherung und keine Garantie und hat keine ausdrücklichen oder stillschweigenden Verpflichtungen und Sie erklären, dass ABBYY weder versprochen noch garantiert hat, dass eine solche Software weiterentwickelt wird oder dass eine kommerzielle Version in Zukunft bekannt gegeben oder bereitgestellt wird. ABBYY bringt unter Umständen kein Softwareprodukt auf den Markt, das einer solchen Software ähnlich ist oder mit dieser kompatibel. Sie erklären sich entsprechend damit einverstanden, dass jede Verwendung, Forschung oder Entwicklung, die Sie im Zusammenhang mit der Software durchführen, vollständig auf eigenes Risiko geschieht.

3.4.3. Sie erklären sich damit einverstanden, ABBYY ein Feedback zur Prüfung und Verwendung der eingeschränkten Software, einschließlich Berichte über Fehler oder Bugs (“Feedback”), zu geben und ABBYY vollständig alle Rechte an diesem Feedback zu übertragen, einschließlich und ohne Einschränkung des Rechts an Verwendung, Veröffentlichung und Verbreitung des Feedback. Alle Feedback sind vertrauliche Informationen von ABBYY.

3.4.4. Vertraulichkeit der eingeschränkten Software, für die es keine kommerzielle Version gibt und die Ergebnisse;

3.4.4.1. Sie erklären Ihr Einverständnis, keinerlei begleitende schriftliche, mündliche oder elektronische Informationen, die Ihnen von ABBYY bezüglich der eingeschränkten Software, für die es keine kommerzielle Version gibt, übermittelt wurden, zu offenbaren und Sie erkennen an, dass jegliche Informationen zur Qualität einer solchen eingeschränkten Software oder zur Qualität der Ergebnisse, die durch die Nutzung einer solchen eingeschränkten Software gewonnen wurden, Feedback, und jegliche Informationen zu Defekten, Fehlern und anderen Problemen, welche Sie bei der eingeschränkten Software festgestellt haben, für die es keine kommerzielle Version gibt, vertrauliche Informationen von ABBYY sind.

3.4.4.2. Sie dürfen keine vertraulichen Informationen offenlegen. Der Begriff „offenlegen“ steht für das Zeigen, Beschreiben, Kopieren, Leasen, Ausleihen, Vermieten, Abtreten oder Übertragen von vertraulichen Informationen oder die Zugriffsgewährung über ein Netzwerk oder auf andere Weise und schließt die Reproduktion in beliebiger Form einschließlich mündlicher Kommunikation mit Dritten ein.

3.4.4.3. Sie sind verpflichtet, durch angemessene Maßnahmen jegliche Offenlegung vertraulicher Informationen zu verhindern und die Vertraulichkeit der Informationen zu wahren.

3.4.4.4. Sie müssen ABBYY sofort informieren, wenn Ihnen eine Offenlegung vertraulicher Informationen bekannt wird.Wenn Sie gegen die Bedingungen verstoßen, die in den Artikeln 3.4.4.1- 3.4.4.3 oben aufgeführt sind, müssen Sie ABBYY für jeden Verlust infolge eines solchen Verstoßes entschädigen.

3.5. Nach Erhalt einer späteren Version der eingeschränkten Software oder einer veröffentlichten kommerziellen Version der Software, ob als eigenständiges Produkt oder als Teil eines größeren Produkts, verpflichten Sie sich dazu, die gesamte von ABBYY früher erhaltene eingeschränkte Software zurückzugeben oder zu zerstören.

3.6. Wenn Sie die eingeschränkte Software infolge einer separaten, schriftlichen Vereinbarung erhalten, unterliegt auch Ihre Nutzung der SOFTWARE einer solchen Vereinbarung. Wenn eine Bestimmung oder Bedingung einer getrennten schriftlichen Vereinbarung, wie der gemeinsamen Vertraulichkeitsvereinbarung, nicht mit diesem EULA übereinstimmt, ersetzt eine getrennte schriftliche Vereinbarung diese andere(n) Bestimmung(en) und Bedingung(en) in Bezug auf die SOFTWARE, jedoch nur in dem zur Lösung des Problems erforderlichen Maß.

4. Vom Weiterverkauf ausgeschlossene SOFTWARE

4.1. Wenn die SOFTWARE als “Nicht zum Weiterverkauf” oder “NFR” (Not for Resale) gekennzeichnet ist, dürfen Sie solche SOFTWARE, ungeachtet anderer Abschnitte dieses EULA lediglich zu Demonstrations-, Verifikations- oder Testzwecken nutzen.

5. Updates

5.1. Wenn die SOFTWARE als ein Update gekennzeichnet ist, müssen Sie im Besitz einer Lizenz für die frühere Version der SOFTWARE sein, für die ABBYY dieses Update gestattet, um die SOFTWARE zu nutzen.

5.2. Die SOFTWARE, die als Update gekennzeichnet ist, ersetzt und/oder ergänzt das Produkt, das die Grundlage für Ihre Berechtigung zum Empfang des Updates bildet.

5.3. Sie dürfen das aktualisierte Produkte nur gemäß der Bedingungen des EULA nutzen, der mit diesem Update zur Verfügung gestellt wurde.

5.4. Sie erkennen an, dass jegliche eventuelle Verpflichtung seitens ABBYY zum Support der Version der SOFTWARE, die aktualisiert wird, zum Zeitpunkt der Verfügbarkeit des Updates endet.

6. Technischer Support und Wartung

6.1. Aufgrund der aktuellen Support-Richtlinien von ABBYY können Sie technischen Support und Wartung für die SOFTWARE (“Support-Leistungen”) erhalten. Allerdings können Sie infolge einer schriftlichen Vereinbarung zwischen Ihnen und ABBYY oder einem Partner von ABBYY bezüglich solcher Support-Leistungen das Recht auf ein anderes Niveau an Support-Leistungen haben, als in den Support-Richtlinien von ABBYY angegeben.

6.2. Allgemeine Bedingungen und Bestimmungen der Support-Richtlinien von ABBYY wurden auf ABBYYs Website www.abbyy.com veröffentlicht. ABBYY behält sich das Recht vor, die Support-Richtlinien jederzeit und ohne vorherige Ankündigung zu ändern.

6.3. Zusätzlich zu den allgemeinen Bedingungen und Bestimmungen hat ABBYY eventuell spezifische Support-Richtlinien für bestimmte Regionen, die von separaten Vereinbarungen geregelt sind.

6.4. Jeder zusätzliche Software-Code und jede SOFTWARE-Komponente, die Ihnen im Rahmen der Support-Leistungen zur Verfügung gestellt werden, gelten als Bestandteil der SOFTWARE und unterliegen den Bedingungen und Bestimmungen dieses EULA.

6.5. Um Support-Leistungen in Anspruch nehmen zu können, ist es unter Umständen erforderlich, dass Sie ABBYY Informationen über die Eigenschaften Ihrer Hardware, die Seriennummer Ihrer SOFTWARE sowie bestimmte persönliche Angaben wie Ihren Namen, den Namen Ihres Unternehmens (falls zutreffend), Adresse, Telefonnummer und E-Mail-Adresse mitteilen. ABBYY darf die oben genannten Informationen wie in Artikel 15.1 des EULA beschrieben verwenden.

7. Eigentum.

7.1. Es wird kein Rechtstitel an geistigem Eigentum von ABBYY (einschließlich SOFTWARE, Patente, Marken oder Urheberrechte von ABBYY) an Sie übertragen. Sie dürfen auf keinerlei Weise, während oder nach der Dauer der Vereinbarung Namen, Logos, Marken, Muster oder Design im Eigentum von ABBYY oder ähnliche Namen, Logos, Marken, Muster oder Designs nutzen oder darauf Anspruch erheben.

7.2. Es wird kein Rechtstitel an geistigem Eigentum von Ihnen (einschließlich Ihrer Patente, Marken oder Urheberrechte) auf ABBYY übertragen.

7.3. Die SOFTWARE beinhaltet wertvolle Geschäftsgeheimnisse und vertrauliche Informationen von ABBYY und Dritten und ist urheberrechtlich geschützt, einschließlich, aber nicht nur durch das Urheberrechtsgesetz der USA, durch Gesetze der Russischen Föderation, internationale Verträge und die in dem Land, in dem die SOFTWARE genutzt oder erworben wird, geltenden Gesetze.

7.4. Alle Rechtsansprüche und Rechte an und auf Inhalte, die nicht in der SOFTWARE enthalten sind, aber auf die durch die Nutzung der SOFTWARE eventuell zugegriffen werden kann, sind das Eigentum der jeweiligen Eigentümer und sind unter Umständen durch geltende Urheberrechte oder andere Gesetze über geistigen Eigentum sowie internationale Verträge geschützt. Dieser EULA gewährt Ihnen keinerlei Rechte an solchem geistigen Eigentum.

8. Eingeschränkte Garantie. Haftungsausschlüsse.

8.1. Sofern von der Gesetzgebung des Landes, in dem Sie die SOFTWARE erworben (gekauft) haben, gefordert, garantiert ABBYY, dass die Datenträger, auf denen die SOFTWARE bereitgestellt wird, bei sachgemäßer Behandlung für den von den Gesetzen des Landes, in dem Sie die SOFTWARE erworben (gekauft) haben, festgesetzten Mindestgewährleistungszeitraum, gerechnet ab dem Kaufdatum und nur für diesen Zeitraum frei von Material- und Verarbeitungsfehlern sind. Wenn die SOFTWARE in den Ländern erworben (gekauft) wurde, die in Artikel 13.4 definiert sind, beträgt dieser Zeitraum dreißig (30) Tage ab Erwerbsdatum (Kaufdatum).

8.2. FALLS NICHT AUSDRÜCKLICH AUFGEFÜHRT IN DIESEM ARTIKEL 8 (EINGESCHRÄNKTE GARANTIE, HAFTUNGSAUSSCHLÜSSE), UND AUSSER JEGLICHER GARANTIE, BEDINGUNG, AUSSAGE, BESTIMMUNG IM AUSMASS, IN DEM DIESE GEMÄSS DES IN IHREM GERICHTSBEREICH GELTENDEN RECHTS NICHT AUSGESCHLOSSEN WERDEN KÖNNEN ODER DÜRFEN, WIRD IHNEN DIE SOFTWARE, EINSCHLIESSLICH; ABER NICHT BESCHRÄNKT AUF JEGLICHE SOFTWARE-DOKUMENTATION, UPGRADES UND UPDATES “WIE GESEHEN” ZUR VERFÜGUNG GESTELLT UND ABBYY GIBT KEINE GARANTIEN, BEDINGUNGEN, AUSSAGEN ODER BESTIMMUNGEN (OB AUSDRÜCKLICH ODER IMPLIZIERT, OB AUF GRUNDLAGE DER GESETZE, DES BÜRGERLICHEN RECHTS, GEPFLOGENHEITEN, HANDELSBRAUCH ODER SONSTIGE) BEZÜGLICH JEGLICHER ANGELEGENHEITEN, EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE VERHINDERUNG DER VERLETZUNG DER RECHTE DRITTER PARTEIEN, MARKTGÄNGIGKEIT, INTEGRATION, ZUFRIEDENSTELLENDE QUALITÄT ODER DIE EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, ODER DASS DIE SOFTWARE KEINE FEHLER ENTHÄLT, IHREN ANFORDERUNGEN ENTSPRICHT ODER DASS DIE SOFTWARE IN KOMBINATION MIT JEGLICHER ANDERER SOFTWARE ODER HARDWARE ORDNUNGSGEMÄSS FUNKTIONIERT. ABBYY ÜBERNIMMT KEINE GEWÄHR FÜR DIE LEISTUNGSFÄHIGKEIT DER SOFTWARE ODER DIE DURCH IHRE NUTZUNG ERZIELTEN ERGEBNISSE. DAS GESAMTRISIKO BEZÜGLICH DER QUALITÄT UND PERFORMANCE DER SOFTWARE LIEGT BEI IHNEN. DESWEITEREN ÜBERNIMMT ABBYY KEINE GARANTIEN FÜR JEGLICHE SOFTWAREPRODUKTE DRITTER, DIE IM LIEFERUMFANG DER SOFTWARE ENTHALTEN SIND.

9. Beschränkung der Haftung

9.1. IN KEINEM FALL ÜBERNIMMT ABBYY IHNEN GEGENÜBER DIE HAFTUNG FÜR SCHÄDEN, BETRIEBSUNTERBRECHUNGEN, DATENVERLUSTE ALLER ART (GESCHÄFTLICH ODER ANDERWEITIG), ANSPRÜCHE ODER KOSTEN ODER FÜR FOLGESCHÄDEN, INDIREKTE, ZUFÄLLIGE, BESONDERE SCHÄDEN, SCHADENSERSATZVERPFLICHTUNGEN ODER STRAFZAHLUNGEN ODER FÜR ENTGANGENEN GEWINN ODER ENTGANGENE ERTRÄGE AUS DER/ODER BEZÜGLICH DER NUTZUNG DER SOFTWARE ODER SCHÄDEN, DIE DURCH MÖGLICHE FEHLER ODER DRUCKFEHLER IN DER SOFTWARE ENTSTEHEN. DIES GILT AUCH, WENN EIN VERTRETER VON ABBYY AUF DIE MÖGLICHKEIT SOLCHER VERLUSTE, SCHÄDEN, ANSPRÜCHE ODER KOSTEN ODER AUF ANSPRÜCHE DRITTER HINGEWIESEN WURDE. DIE OBEN GENANNTEN EINSCHRÄNKUNGEN UND AUSSCHLÜSSE GELTEN IM AUSMASS, IN DEM DAS IN IHREM GERICHTSBEREICH GELTENDE RECHT DIES GESTATTET. ABBYYS ALLEINIGE UND GESAMTE HAFTUNG GEMÄSS ODER IN VERBINDUNG MIT DIESEM ENDBENUTZER-LIZENZVERTRAG IST AUF DEN KAUFPREIS BEGRENZT, DER URSPRÜNGLICH FÜR DIE SOFTWARE GEZAHLT WURDE, FALLS ZUTREFFEND.

10. Garantieausschluss und Einschränkungen für Benutzer mit Wohnsitz in Deutschland und Österreich

10.1. Wenn Sie Ihre Kopie der SOFTWARE in Deutschland oder Österreich erworben haben und wenn sich Ihr Wohnsitz überwiegend in einem der beiden Länder befindet, dann garantiert ABBYY in Übereinstimmung mit der deutschen Rechtsprechung, dass die SOFTWARE für den Zeitraum der beschränkten Garantie ab Erhalt der SOFTWARE-Kopie die in ihrer Dokumentation beschriebenen Funktionen (die „vereinbarten Funktionen“) aufweist, wenn sie auf der empfohlenen Hardwarekonfiguration betrieben wird. Im Sinne dieses Artikels bedeutet „Zeitraum der beschränkten Garantie“ ein (1) Jahr, wenn Sie ein kommerzieller Benutzer oder eine Körperschaft sind, und zwei (2) Jahre, wenn Sie kein kommerzieller Benutzer sind. Geringfügige Abweichungen von den vereinbarten Funktionen werden nicht berücksichtigt und begründen keinerlei Gewährleistungsansprüche. Diese eingeschränkte Garantie gilt nicht für SOFTWARE, die Ihnen kostenlos zur Verfügung gestellt wird, wie zum Beispiel Updates, Vorabversionen, Testversionen (“Trial”), Produktwerbeexemplare, SOFTWARE-Kopien mit der Beschriftung „Nicht für den Weiterverkauf bestimmt“ oder für SOFTWARE, die von Ihnen so verändert wurde, dass dadurch ein Fehler entstand. Um die Garantie im eingeschränkten Garantiezeitraum in Anspruch zu nehmen, müssen Sie die SOFTWARE zusammen mit dem Zahlungsbeleg auf unsere Kosten an Ihren Händler zurückschicken. Wenn die Funktionen der SOFTWARE wesentlich von den vereinbarten Funktionen abweichen, ist ABBYY dazu berechtigt (durch Neuerbringung der Leistung und nach freiem Ermessen), die SOFTWARE zu reparieren oder zu ersetzen. Wenn dies erfolglos bleibt, haben Sie Anrecht auf eine Minderung des Warenpreises (Preisnachlass) oder auf die Aufhebung des Verkaufsvertrags (Rücktritt). Für weitere Informationen zur Garantie kontaktieren Sie den ABBYY Customer Support in Deutschland: ABBYY Europe GmbH, Elsenheimerstraße 49, 80687 München, Tel.: +49 (0)89 51 11 590, Fax: +49 (0)89 51 11 5959.

10.2. Wenn Sie Ihre Kopie der SOFTWARE in Deutschland oder Österreich erworben haben und wenn sich Ihr Wohnsitz überwiegend in einem der beiden Länder befindet, dann gilt Folgendes:

10.2.1. Gemäß den Bestimmungen in Artikel 10.2.2, ist die gesetzlich festgelegte Haftung von ABBYY und seinen Partnern für Schäden folgendermaßen eingeschränkt: (i) ABBYY ist nur für eine Schadenshöhe haftbar, die zum Zeitpunkt des Verkaufsvertragsabschlusses unter normalen Umständen absehbar ist, und in Bezug auf Schäden, die durch geringfügige Verletzung einer wesentlichen Vertragspflicht entstehen, und (ii) ABBYY ist nicht für Schäden haftbar, die durch geringfügige Verletzung einer nicht wesentlichen Vertragspflicht entstehen.

10.2.2. Die in Paragraph 10.2.1 ausgeführte Haftungsbeschränkung ist nicht anwendbar bei jeglicher verbindlicher, gesetzlich festgelegter Haftung, insbesondere bei Haftung nach dem deutschen Produkthaftungsgesetz, Haftung für die Übernahme einer besonderen Garantie oder Haftung für schuldhaft verursachte Personenschäden.

10.2.3. Sie sind dazu verpflichtet, alle zumutbaren Maßnahmen zu ergreifen, um Schäden zu vermeiden und gering zu halten, insbesondere dadurch, dass Sie Sicherungskopien der SOFTWARE und Ihrer Computerdaten, die den Bestimmungen dieses Endbenutzer-Lizenzvertrags unterliegen, erstellen.

11. Zusätzliche Einschränkungen für SOFTWARE, die in den USA erworben wurde

11.1. Nutzung durch Regierungsstellen. Wird die SOFTWARE durch die Regierung der USA oder eine Regierungsbehörde der USA genutzt, gelten die folgenden zusätzlichen Bestimmungen: (1) Restricted Computer Software, wie im Abschnitt Rights in Data-General der Federal Acquisition Regulations 52.227-14 definiert; und (2) jegliche Verwendung, Vervielfältigung oder Offenlegung durch die US-Regierung unterliegt den im Unterabsatz (c)(1)(ii) des Abschnitts Rights in Technical Data and Computer Software von DFARS 252.227-7013 festgelegten Beschränkungen.

11.2. Regeln für den Export.Sie akzeptieren, dass Sie die SOFTWARE nicht entgegen den Exportbestimmungen gemäß der Gesetzgebung des Landes, in dem die SOFTWARE gekauft oder auf andere Weise erworben wurde, ausführen bzw. reexportieren. Außerdem erklären und versichern Sie, dass es Ihnen nach gültigem Recht nicht untersagt ist, die SOFTWARE zu erhalten.

12. Drittpartei-Technologien

12.1. Eingebettete Schriftarten. Schriftprogramme unterliegen dem Urheberrecht, und dessen Eigentümer kann Bedingungen zur Benutzung eines Schriftprogramms auferlegen. Eine dieser Bedingungen kann sein, dass Sie eine lizenzierte Kopie des Schriftprogramms benötigen, damit die Schriftart in eine PDF-Datei eingebettet werden kann. In keinem Fall kann ABBYY für Schäden, die aus oder in Zusammenhang mit Ihrer Nutzung eingebetteter Schriftarten entstehen, haftbar gemacht werden.

12.2. Adobe® PDF Library

12.2.1. Der Begriff “Adobe-Software” umfasst Adobe-Technologie und damit verbundene Dokumentation sowie jegliche Upgrades, modifizierte Versionen, Updates, Ergänzungen und Kopien davon.

12.2.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet Ihnen ein nicht exklusives Recht zur Nutzung der Adobe-Software zu den Bedingungen dieses EULA. Die Erstellung einer Sicherungskopie der Adobe-Software ist erlaubt, sofern die Sicherungskopie auf keinem anderen Computer installiert oder benutzt wird.

12.2.3. Urheberrechte. Die in die SOFTWARE integrierte Adobe-Software ist Eigentum von Adobe und seiner Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von Adobe und seiner Lieferanten. Darüber hinaus ist die Adobe-Software durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Sie dürfen die Adobe-Software nicht kopieren, außer in dem Umfang, in dem es dieser EULA gestattet. Kopien, deren Anfertigung nach Maßgabe dieses EULA erlaubt ist, müssen exakt dieselben Angaben zu Urheber- und anderen Eigentumsrechten enthalten, wie sie in oder auf der Adobe-Software erscheinen. Sie erkennen an, dass es Ihnen nicht gestattet ist, den Quellcode der Software zu modifizieren, anzupassen, zurückzuentwickeln (Reverse Engineering), zu dekompilieren, zu disassemblieren oder anderweitig zu versuchen, den Quellcode der Adobe-Software zu erschließen. Mit Ausnahme des oben gesagten gewährt Ihnen dieser EULA keinerlei geistige Eigentumsrechte an der Adobe-Software.

12.2.4. Lizenzen für Schriftarten. Wenn die Adobe-Software Schriftarten-Software enthält, sind Sie grundsätzlich dazu berechtigt, diese Schriftarten-Software oder Typen dieser Schriftarten-Software in Ihre elektronischen Dokumente einzubetten, sofern dies vom Inhaber des Urheberrechts bzw. vom Händler genehmigt wurde. Die Schriftarten in diesem Paket können sowohl Adobe-eigene als auch andere Schriftarten enthalten. Adobe-eigene Schriftarten dürfen vollständig eingebettet werden.

12.2.5. Garantie. ABBYY UND SEIN LIEFERANT ÜBERNEHMEN KEINERLEI GEWÄHR FÜR DIE DURCH DIE NUTZUNG DER SOFTWARE ERZIELTEN ERGEBNISSE.

12.2.6. Regeln für den Export. Sie sind damit einverstanden, dass die Adobe-Software in kein Land versandt, übermittelt oder ausgeführt oder auf irgendeine Weise genutzt wird, die durch den United States Export Administration Act oder jegliche andere Exportgesetze, Einschränkungen oder Bestimmungen (insgesamt die “Exportgesetze”) verboten sind. Darüber hinaus unterliegt die Adobe-Software gemäß den Exportgesetzen der Ausfuhrkontrolle. Sie erklären und garantieren, dass Sie kein Bürger eines Landes sind, das unter einem Embargo steht bzw. sich auf sonstige Weise in diesem Land aufhalten, und dass es Ihnen die Exportgesetze nicht verbieten, Adobe-Software zu erhalten. Alle Benutzerrechte der Adobe-Software werden unter der Bedingung gewährleistet, dass sie bei Nicht-Einhaltung der Bedingungen dieses EULA hinfällig werden.

12.2.7. Marken. Adobe und Adobe PDF Library sind entweder eingetragene Marken oder Marken der Adobe Systems Incorporated in den Vereinigten Staaten und/oder anderen Ländern.

12.3. PixTools® Scan-Laufzeitbibliotheken

12.3.1. “EMC Software” bezieht sich auf die PixTools Scan-Laufzeitbibliotheken, Level-1-ISIS-Treiber, Level-2-ISIS-Treiber und Level-3-ISIS-Treiber. Die SOFTWARE kann die EMC-Software zur Kommunikation zwischen Scanner und SOFTWARE über die ISIS-Schnittstelle verwenden.

12.3.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet ein nicht exklusives Recht zur Nutzung der in die SOFTWARE integrierten EMC-Software zu den Bedingungen des EULA.

12.3.3. Urheberrechte. Die in die SOFTWARE integrierte EMC-Software ist Eigentum von EMC Corporation und seinen Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von EMC Corporation und seinen Lieferanten. Die EMC-Software ist durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Das Kopieren der in die SOFTWARE integrierten EMC-Software ist untersagt. Sie nehmen zur Kenntnis, dass es Ihnen nicht gestattet ist, den Quellcode der in die SOFTWARE integrierten EMC-Software zu modifizieren, anzupassen, zurückzuentwickeln (reverse engineering), zu dekompilieren, zu disassemblieren oder anderweitig zu versuchen, den Quellcode der in die SOFTWARE integrierten EMC-Software zu erschließen. Mit Ausnahme des oben gesagten gewährt Ihnen dieser EULA keinerlei geistige Eigentumsrechte an der EMC-Software.

12.3.4. Garantie. ABBYY ÜBERNIMMT KEINE GEWÄHR (UND KANN DIES AUCH NICHT) FÜR DIE ERGEBNISSE, DIE DURCH DIE NUTZUNG DER IN DER SOFTWARE INTEGRIERTEN EMC-SOFTWARE ERZIELT WERDEN.

IN KEINEM FALL HAFTEN DIE EMC CORPORATION ODER IHRE LIEFERANTEN FÜR JEGLICHE FOLGE-, NEBEN-, ODER SONDERSCHÄDEN, EINSCHLIESSLICH SÄMTLICHER ENTGANGENER GEWINNE ODER ENTGANGENER ERSPARNISSE ODER FÜR JEDEN ANSPRUCH EINER DRITTEN PARTEI.

Einige Staaten und Rechtssysteme gestatten keinen Ausschluss der konkludenten Gewährleistung bzw. keine Einschränkungen des Geltungszeitraums von konkludenten Gewährleistungen, sodass die obige Einschränkung unter Umständen für Sie nicht zutrifft. Außerdem können Ihnen je nach Land oder Rechtsprechung möglicherweise weitere Rechte zustehen.

12.3.5. Marken. ISIS und PixTools sind Marken oder eingetragene Marken von EMC Corporation in den USA und/oder anderen Ländern.

12.4. Cuminas DjVu® SDK.

12.4.1. Sie haben als Endbenutzer das Recht zur Nutzung von DjVu SDK als Teil der SOFTWARE für den gesamten Zeitraum, in dem das Urheberrecht einer solchen SOFTWARE gilt oder für einen kürzeren Nutzungszeitraum, wie im EULA dargelegt.

12.4.2. Lizenzbestimmungen: Sie dürfen die folgenden Aktivitäten weder selbst ausführen noch diese anderen Personen ermöglichen: Rückentwicklung (Reverse Engineering), Demontage, Dekompilierung (d. h. Vervielfältigung und Transformierung des Objektcodes in Quellcode) oder andere Versuche, den Quellcode für die SOFTWARE** oder jeglicher Teile abzuleiten, außer und nur in dem Umfang, in dem eine solche Aktivität ausdrücklich vom geltenden Recht, abweichend von dieser Einschränkung, erlaubt ist. Wenn geltende Gesetze derlei Vorgehen erlauben, dürfen keine der auf diese Art gefundenen Daten an Dritte weitergegeben werden, soweit eine derartige Nicht-Weitergabe durch das Gesetz gestattet ist, sondern müssen umgehend an ABBYY weitergegeben werden. Alle diese Informationen müssen als vertrauliche Daten und als Eigentum von ABBYY betrachtet werden.

12.4.3. ABBYY GIBT KEINE GARANTIEN, BEDINGUNGEN, AUSSAGEN ODER BESTIMMUNGEN (OB AUSDRÜCKLICH ODER STILLSCHWEIGEND, OB AUF GRUNDLAGE DER GESETZE, DES BÜRGERLICHEN RECHTS, GEPFLOGENHEITEN, HANDELSBRAUCH ODER SONSTIGE) BEZÜGLICH JEGLICHER ANGELEGENHEITEN, EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE VERHINDERUNG DER VERLETZUNG DER RECHTE DRITTER PARTEIEN, MARKTGÄNGIGKEIT, INTEGRATION, ZUFRIEDENSTELLENDE QUALITÄT ODER DIE EIGNUNG FÜR EINEN BESTIMMTEN ZWECK, ODER DASS DIE SOFTWARE KEINE FEHLER ENTHÄLT, IHREN ANFORDERUNGEN ENTSPRICHT ODER DASS DIE SOFTWARE IN KOMBINATION MIT JEGLICHER ANDERER SOFTWARE ODER HARDWARE ORDNUNGSGEMÄSS FUNKTIONIERT. ABBYY ÜBERNIMMT KEINE GEWÄHR FÜR DIE LEISTUNGSFÄHIGKEIT DER SOFTWARE ODER DIE DURCH IHRE NUTZUNG ERZIELTEN ERGEBNISSE. DAS GESAMTRISIKO BEZÜGLICH DER QUALITÄT UND PERFORMANCE DER SOFTWARE LIEGT BEI IHNEN. DES WEITEREN ÜBERNIMMT ABBYY KEINE GARANTIEN FÜR JEGLICHE SOFTWAREPRODUKTE DRITTER, DIE IM LIEFERUMFANG DER SOFTWARE ENTHALTEN SIND.

12.4.4. IN KEINEM FALL ÜBERNIMMT ABBYY IHNEN GEGENÜBER DIE HAFTUNG FÜR SCHÄDEN, BETRIEBSUNTERBRECHUNGEN, DATENVERLUSTE ALLER ART (GESCHÄFTLICH ODER ANDERWEITIG), ANSPRÜCHE ODER KOSTEN ODER FÜR FOLGESCHÄDEN, INDIREKTE, ZUFÄLLIGE, BESONDERE SCHÄDEN, SCHADENSERSATZVERPFLICHTUNGEN ODER STRAFZAHLUNGEN ODER FÜR ENTGANGENEN GEWINN ODER ENTGANGENE ERTRÄGE AUS DER/ODER BEZÜGLICH DER NUTZUNG DER SOFTWARE ODER SCHÄDEN, DIE DURCH MÖGLICHE FEHLER ODER DRUCKFEHLER IN DER SOFTWARE ENTSTEHEN. DIES GILT AUCH, WENN EIN VERTRETER VON ABBYY AUF DIE MÖGLICHKEIT SOLCHER VERLUSTE, SCHÄDEN, ANSPRÜCHE ODER KOSTEN ODER AUF ANSPRÜCHE DRITTER HINGEWIESEN WURDE. DIE OBEN GENANNTEN EINSCHRÄNKUNGEN UND AUSSCHLÜSSE GELTEN IM AUSMASS, IN DEM DAS IN IHRER GERICHTSBARKEIT GELTENDE RECHT ES GESTATTET. ABBYYS ALLEINIGE UND GESAMTE HAFTUNG GEMÄSS ODER IN VERBINDUNG MIT DIESEM EULA IST AUF DEN KAUFPREIS BEGRENZT, DER URSPRÜNGLICH FÜR DIE SOFTWARE GEZAHLT WURDE, FALLS ZUTREFFEND.

12.4.5. Einschränkungen für SOFTWARE, die in den USA erworben wurde.

a. Nutzung durch Regierungsstellen. Wird die SOFTWARE durch die Regierung der USA oder eine Regierungsbehörde der USA genutzt, gelten die folgenden zusätzlichen Bestimmungen: (1) Restricted Computer Software, wie im Abschnitt Rights in Data-General der Federal Acquisition Regulations 52.227-14 definiert; und (2) jegliche Verwendung, Vervielfältigung oder Offenlegung durch die US-Regierung unterliegt den im Unterabsatz (c)(1)(ii) des Abschnitts Rights in Technical Data and Computer Software von DFARS 252.227-7013 festgelegten Beschränkungen.

b. Regeln für den Export. Sie akzeptieren, dass Sie die SOFTWARE nicht entgegen den Exportbestimmungen gemäß der Gesetzgebung des Landes, in dem die SOFTWARE gekauft oder auf andere Weise erworben wurde, ausführen bzw. reexportieren. Außerdem erklären und versichern Sie, dass es Ihnen nach gültigem Recht nicht untersagt ist, die SOFTWARE zu erhalten.

12.4.6. Code einer dritten Partei:

12.4.6.1. Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp> Alle Rechte vorbehalten. Die Verbreitung und Nutzung der Quelle und binärer Formen, mit oder ohne Modifizierung, sind unter den folgenden Bedingungen gestattet: Die Verbreitung des Quellcodes muss den oben genannte Urheberrechtshinweis, diese Liste der Bedingungen und den folgenden Haftungsausschluss enthalten. Die Verbreitung in binärer Form muss den oben genannten Urheberrechtshinweis, diese Liste der Bedingungen und den folgenden Haftungsausschluss in der Dokumentation und/oder anderen Materialien enthalten, die im Lieferumfang enthalten sind, wiedergeben.

DIESE SOFTWARE WIRD VOM AUTOR UND DEN MITWIRKENDEN “WIE GESEHEN” BEREITGESTELLT UND ES WERDEN KEINERLEI AUSDRÜCKLICHEN ODER STILLSCHWEIGENDE GARANTIEN, EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE STILLSCHWEIGENDEN GARANTIEN DER MARKTGÄNGIGKEIT UND DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK GEWÄHRT. IN KEINEM FALL TRAGEN DER AUTOR ODER DIE MITWIRKENDEN DIE HAFTUNG FÜR JEGLICHE DIREKTEN, INDIREKTEN, NEBEN-, SONDER-, FOLGESCHÄDEN ODER SCHADENSERSATZANSPRÜCHE (EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE BESCHAFFUNG VON ERSATZGÜTERN ODER -DIENSTLEISTUNGEN; VERLUST DER NUTZUNG, VON DATEN ODER GEWINNEN; ODER GESCHÄFTSUNTERBRECHUNG), WIE AUCH IMMER DIESE VERURSACHT WURDEN, UND UNABHÄNGIG DAVON, UM WELCHE ART DER HAFTUNG ES SICH HANDELT, OB AUS EINEM VERTRAG, ERFOLGSHAFTUNG (VERSCHULDENSUNABHÄNGIGE HAFTUNG) ODER DIE HAFTUNG AUS UNERLAUBTEN HANDLUNGEN (EINSCHLIESSLICH FAHRLÄSSIGKEIT ODER SONSTIGES), DIE SICH AUF IRGENDEINE WEISE AUS DER NUTZUNG DIESER SOFTWARE ERGEBEN, AUCH WENN AUF DIE MÖGLICHKEIT EINES SOLCHEN SCHADENS HINGEWIESEN WURDE.

12.4.6.2. Ein Teil dieser Software stammt aus dem RSA Data Security, Inc. MD5 Message-Digest-Algorithmus. Mersenne Twister Copyright © 2006, 2007 Mutsuo Saito, Makoto Matsumoto und Hiroshima University. Alle Rechte vorbehalten.

Die Verbreitung und Nutzung der Quelle und binärer Formen, mit oder ohne Modifizierung, sind unter den folgenden Bedingungen gestattet: Die Verbreitung des Quellcodes muss den oben genannte Urheberrechtshinweis, diese Liste der Bedingungen und den folgenden Haftungsausschluss enthalten. Die Verbreitung in binärer Form muss den oben genannten Urheberrechtshinweis, diese Liste der Bedingungen und den folgenden Haftungsausschluss in der Dokumentation und/oder anderen Materialien enthalten, die im Lieferumfang enthalten sind, wiedergeben. Weder der Name der Hiroshima University noch die Namen der Mitwirkenden dürfen verwendet werden, um Produkte zu befürworten oder zu bewerben, die von dieser Software abgeleitet wurden, es sei denn, es wurde vorab eine schriftliche Genehmigung eingeholt.

DIESE SOFTWARE WIRD VOM AUTOR UND DEN MITWIRKENDEN “WIE GESEHEN” BEREITGESTELLT UND ES WERDEN KEINERLEI AUSDRÜCKLICHEN ODER STILLSCHWEIGENDE GARANTIEN, EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE STILLSCHWEIGENDEN GARANTIEN DER MARKTGÄNGIGKEIT UND DER EIGNUNG FÜR EINEN BESTIMMTEN ZWECK GEWÄHRT. IN KEINEM FALL HAFTEN DER URHEBERRECHTSINHABER ODER DIE MITWIRKENDEN FÜR DIREKTE, INDIREKTE, NEBEN-, SONDER-, FOLGESCHÄDEN ODER SCHADENSERSATZANSPRÜCHE (EINSCHLIESSLICH, ABER NICHT BESCHRÄNKT AUF DIE BESCHAFFUNG VON ERSATZGÜTERN ODER -DIENSTLEISTUNGEN; VERLUST DER NUTZUNG, VON DATEN ODER GEWINNEN; ODER GESCHÄFTSUNTERBRECHUNG), WIE AUCH IMMER DIESE VERURSACHT WURDEN, UND UNABHÄNGIG DAVON, UM WELCHE ART DER HAFTUNG ES SICH HANDELT, OB AUS EINEM VERTRAG, GEFÄHRDUNGSHAFTUNG (VERSCHULDENSUNABHÄNGIGE HAFTUNG) ODER DIE HAFTUNG AUS UNERLAUBTEN HANDLUNGEN (EINSCHLIESSLICH FAHRLÄSSIGKEIT ODER SONSTIGES), DIE SICH AUF IRGENDEINE WEISE AUS DER NUTZUNG DIESER SOFTWARE ERGEBEN, AUCH WENN AUF DIE MÖGLICHKEIT EINES SOLCHEN SCHADENS HINGEWIESEN WURDE.

12.5. Wibu-Systems

12.5.1. WIBU, CodeMeter, SmartShelter, SmartBind sind eingetragene Marken von Wibu-Systems.

12.6. Andere lizenzierte Technologien. Diese SOFTWARE wird verwendet unter Lizenz der folgenden US-Patentnummern: 5,625,465 und 5,768,416.

13. Geltendes Recht

13.1. Wenn die SOFTWARE in den USA, in Kanada, Mexiko, Belize, Costa Rica, El Salvador, Guatemala, Honduras, Montserrat, Nicaragua, Panama, Turks- und Caicosinseln, Jungferninseln, Japan oder Taiwan erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte des Bundesstaates Kalifornien (USA). Hinsichtlich eventueller Streitfragen, die im Zusammenhang mit diesem Endbenutzer-Lizenzvertrag und/oder dieser SOFTWARE entstehen, stimmen Sie als ausschließlicher Gerichtsbarkeit und Gerichtsstand den Bundesgerichten und/oder einzelstaatlichen Gerichten in Santa Clara (US-Bundesstaat Kalifornien) zu. Sollten Sie Zweifel haben, ob die SOFTWARE in den USA erworben (gekauft) wurde, erkennen Sie das, wenn die SOFTWARE von ABBYY USA Software House Inc. erworben (gekauft) wurde.

13.2. Wenn die SOFTWARE in Österreich, Belgien, Dänemark, Finnland, Frankreich, Deutschland, Italien, Luxemburg, den Niederlanden, Portugal, Spanien, Schweden oder einem anderen Mitgliedsstaat der Europäischen Union, außer in Malta, Griechenland und Zypern erworben wurde, der nicht direkt in Artikel 13.3, 13.4 oder 13.5 dieses EULA erwähnt wurde, oder in der Schweiz, Norwegen, Island oder Liechtenstein, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung in München, Bundesrepublik Deutschland, und wird nach diesem ausgelegt. Der Gerichtsstand ist München. Die Bundesrepublik Deutschland ist die ausschließliche Gerichtsbarkeit bei allen Streitigkeiten in Bezug auf diesen EULA.

13.3. Falls die SOFTWARE im Vereinigten Königreich von Großbritannien und Nordirland oder in der Republik Irland erworben wurde, unterliegt dieser EULA den Gesetzen von England und Wales, und die Parteien akzeptieren die ausschließliche Gerichtsbarkeit der Gerichte von England und Wales.

13.4. Wenn die SOFTWARE in Russland, Weißrussland, Kasachstan oder irgendeinem anderen Land der GUS, mit Ausnahme der Ukraine und Moldawien, erworben wurde, oder wenn die SOFTWARE in Georgien, Lettland, Litauen oder Estland erworben (gekauft) wurde, unterliegt dieser EULA der Rechtsprechung der Gerichte der Russischen Föderation.

13.5. Wenn die SOFTWARE in Albanien, Bosnien und Herzegowina, Bulgarien, Kroatien, der Tschechischen Republik, Ungarn, Israel, Mazedonien, Polen, Rumänien, der Slowakei, Slowenien, der Türkei, Serbien, Montenegro, Ukraine oder Moldawien erworben wurde, unterliegt dieser EULA den Gesetzen der Ukraine und wird nach diesen ausgelegt, es sei denn, die SOFTWARE wurde von einer Person erworben, die einen Verbraucherstatus gemäß dem polnischen bürgerlichen Recht. Für diese Verbraucher gilt polnisches Recht.

13.6. Sofern Artikel 13.5 angewandt wird und Sie eine Körperschaft oder ein Einzelhändler (eine Person, die eigenständig ohne Verwendung einer Firmenstruktur oder Partner arbeitet und volle Verantwortlichkeit für die Geschäftstransaktionen trägt) sind, sollen alle Streitigkeiten im Zusammenhang mit dem EULA durch ein Schiedsverfahren gemäß den Verfahrensweisen des Internationalen Handelsschiedsgerichts (International Commercial Arbitration Court) der Industrie- und Handelskammer der Ukraine (Ukrainian Chamber of Commerce and Industry) endgültig entschieden werden. Das Urteil des oben genannten Gerichts ist endgültig und muss von beiden Parteien befolgt werden. Falls Artikel 13.5 zur Anwendung kommt und Sie eine Privatperson sind, liegt die ausschließliche Gerichtsbarkeit für alle Streitfragen bezüglich dieses EULA beim Kreisgericht Shevchenkovsky in Kiew, Ukraine.

13.7. Sofern Artikel 13.4 angewandt wird und Sie eine Körperschaft oder ein Einzelhändler (eine Person, die eigenständig ohne Verwendung einer Firmenstruktur oder Partner arbeitet und volle Verantwortlichkeit für die Geschäftstransaktionen trägt) sind, hat die ausschließliche Gerichtsbarkeit über jegliche Streitfragen gemäß des EULA das Handels-(Arbitrazh-)Gericht in Moskau, Russische Föderation. Falls Artikel 13.4 zur Anwendung kommt und Sie eine Privatperson sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses EULA beim Kreisgericht Kuzminsky in Moskau, Russische Föderation.

13.8. In den in den Artikeln 13.1- 13.5 beschriebenen Fällen, unterliegt dieser EULA nicht den Vorschriften des internationalen Privatrechts der einzelnen Staaten oder dem Übereinkommen der Vereinten Nationen über Verträge über den internationalen Warenkauf, deren Anwendung ausdrücklich ausgeschlossen wird.

13.9. Wenn die SOFTWARE in einem anderen als den in den Artikeln 13.1- 13.5, aufgeführten Ländern erworben wurde, unterliegt dieses Endbenutzer-Lizenzvertrags dem materiellen Recht der Gerichte des Lands, in dem Sie die SOFTWARE gekauft haben.

14. Erlöschen des Vertrags

14.1. Wenn nicht anderweitig zwischen Ihnen und ABBYY oder einem Partner von ABBYY in einer separaten, schriftlichen Vereinbarung niedergelegt oder anderweitig durch den EULA oder die Dokumentation für die SOFTWARE niedergelegt, tritt dieser EULA am Tag, an dem Sie das erste Mal den Bedingungen zustimmen, wie am Anfang des EULA aufgeführt, und bleibt dauerhaft in Kraft oder solange das geltende Recht dies gestattet. Im Umfang, in dem das geltende Recht die Bestimmung eines Ablaufzeitraums für diesen EULA erfordert, bleibt dieser EULA solange wie möglich in Kraft, aber in jedem Fall mindestens so lange, wie das Urheberrecht der SOFTWARE gilt und erlischt automatisch und ohne weitere Benachrichtigung mit dem Ablauf eines solchen Zeitraums.

14.2. Ungeachtet anderer Rechte kann ABBYY diesen EULA kündigen, wenn Sie gegen seine Bestimmungen verstoßen. In einem solchen Fall müssen Sie alle Kopien der SOFTWARE sowie alle ihre Komponenten zerstören und die SOFTWARE von Ihren Computern entfernen.

14.3. Sie können diesen EULA kündigen, indem Sie alle Kopien der SOFTWARE und alle Ihre Komponenten zerstören und die SOFTWARE entfernen.

14.4. Eine solche Kündigung befreit Sie nicht von Ihrer Verpflichtung zur Zahlung der SOFTWARE. Die Artikel 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 und Artikel 3.4.4 haben nach Kündigung oder Ablauf des Endbenutzer-Lizenzvertrags Bestand, wie immer dieser beendet wird, in Kraft. Dies bedeutet jedoch nicht, dass weiterhin ein Recht besteht oder dieses neu geschaffen wird, die SOFTWARE nach der Kündigung oder dem Ablauf dieses EULA weiterhin zu nutzen.

15. Verschiedenes

15.1. Während der Aktivierung, Installation, des Betriebs und/oder beim technischen Support und bei der Wartung der SOFTWARE, ist es unter Umständen erforderlich und Sie erklären sich hiermit dazu bereit, ABBYY bestimmte persönlichen Angaben von Ihnen mitzuteilen. (Diese können Folgende umfassen, sind aber nicht darauf beschränkt: Ihr Name, Ihre Adresse, Ihre E-Mail-Adresse und Telefonnummer). Sie können sich entscheiden, uns keine personenbezogene Daten zur Verfügung zu stellen. In diesem Fall werden Sie in Zukunft möglicherweise keinen Support oder Instandhaltungsdienstleistungen für die SOFTWARE erhalten, die denjenigen Kunden von ABBYY zur Verfügung stehen, die personenbezogene Daten angeben, wenn diese essentiell sind, um Ihnen technischen Support oder Instandhaltungsdienstleistungen zu Verfügung zu stellen, und dies nicht gegen geltendes Recht verstößt. Sie erklären, dass Sie nicht mehr persönliche Angaben zur Verfügung stellen, als dies für ABBYY oder einen Partner von ABBYY notwendig wäre, undSie erklären, dass Ihre persönlichen Angaben von ABBYY und/oder seinen Konzerngesellschaften oder ABBYYs Partnernbearbeitet werden können (einschließlich, aber nicht beschränkt auf gesammelte und/oder auf andere Weise genutzte Daten), gemäß dem geltenden Recht, vorausgesetzt, dass die Vertraulichkeit der Daten und die Datensicherheit gewahrt bleiben, falls das geltende Recht dies erfordert. Alle persönlichen Angaben, die Sie ABBYY oder seinen Konzerngesellschaften oder seinen Partnern zur Verfügung stellen, werden streng innerhalb der Unternehmen von ABBYY und seinen Konzerngesellschaftenoder Partnern von ABBYY verarbeitet und werden keiner dritten Partei offengelegt, es sei denn, dies wird vom geltenden Recht verlangt, und werden im Falle von ABBYY USA Software House Inc. gemäß dessen Datenschutzrichtlinien gepflegt. Diese Richtlinien finden Sie unter http://abbyy.com/privacy_policy. Sämtliche persönlichen Daten werden nur unter Erfüllung der Auflagen entsprechend dieses EULA von ABBYY verarbeitet. Falls Artikel 13.5 gilt, werden Ihre persönlichen Angaben in der Datenbank namens “Natürliche Personen, deren persönliche Angaben während der Geschäftsaktivität verarbeitet werden” verarbeitet.

15.2. Sie erkennen an, dass es bei der SOFTWARE erforderlich sein kann, während der Aktivierung, Deaktivierung oder Aktualisierung der SOFTWARE eine Verbindung über das Internet oder via E-Mail mit einem ABBYY-Server herzustellen. ABBYY unternimmt vernünftige Schritte mit dem Ziel, dass keine Ihrer persönlichen Angaben während solcher Verbindungen übertragen werden.

15.3. ABBYY kann Ihnen E-Mails mit Neuigkeiten zu Produkten und zum Unternehmen, Informationen zu Sonderangeboten, Ratschläge zur Verwendung von Produkten sowie firmen- und produktbezogene Informationen zuschicken, falls Sie dem Empfang solcher Informationen zustimmen. Sie können Ihre E-Mail-Adresse jederzeit aus der Mailingliste von ABBYY entfernen.

15.4. Falls Ihnen gegenüber Rechtsansprüche geltend gemacht oder gerichtliche Verfahren gegen Sie angestrengt werden, die in Zusammenhang mit Ihrer Benutzung der SOFTWARE stehen, müssen Sie ABBYY über diese Rechtsansprüche oder Verfahren sofort schriftlich und falls möglich innerhalb von drei (3) Tagen, nachdem Sie davon erfahren haben, in Kenntnis setzten. Sie sind verpflichtet, alle notwendigen Schritte zu unternehmen, um es ABBYY zu ermöglichen, an den Verfahren oder Anhörungen teilzunehmen bzw. die Verteidigung solcher Ansprüche oder Klagen vor Gericht oder einem Schiedsgericht zu übernehmen, und Sie müssen mit ABBYY stets zusammenarbeiten und sämtliche Informationen, die ABBYY als nützlich oder notwendig erachtet, um die Verteidigung der entsprechenden Ansprüche oder Klagen zu übernehmen, unverzüglich und möglichst vor dem Ablauf von sieben (7) Tagen, nachdem ABBYY diese angefordert hat, zur Verfügung stellen.

15.5. Das Entgelt gemäß dieser EULA ist der Preis für die von ABBYY oder einem ABBYY-Partner gewährte Lizenz und ist unter Einhaltung der von ABBYY oder dem ABBYY-Partner festgelegten Zahlungsmodalitäten zahlbar oder kann im Wert des Gerätes oder der Hardware enthalten sein, das bzw. die von Ihnen erworben wurde, oder ist Bestandteil des Entgelts, das von Ihnen für die Vollversion der SOFTWARE zu zahlen ist. Wenn Sie eine natürliche Person sind, kann dieser EULA gratis sein.

15.6. Sollte sich ein Teil dieses EULA als nichtig und nicht einklagbar erweisen, berührt dies in keiner Weise die übrigen Bestimmungen des vorliegenden EULA, welche weiterhin Geltung behalten und einklagbar sind.

Collapsed End-User License Agreement (EULA)

End-User License Agreement (EULA)

ABBYY® FlexiCapture®

Important! Read the following terms carefully before installing, copying and/or otherwise using ABBYY FlexiCapture (hereinafter referred to as “the SOFTWARE”). Installing, copying or otherwise using the SOFTWARE indicates Your acceptance of these terms. This End-User License Agreement (hereinafter referred to as the “EULA”) is a legal agreement between you, the end user, who obtained or is using the SOFTWARE, and ABBYY.

This EULA comes into force when You demonstrate your consent to be bound by its terms by selecting the “I accept the terms of the license agreement” button followed by selecting the “next” button and installing the SOFTWARE or when You install, copy or start using the SOFTWARE in any manner. Any such act is deemed to demonstrate Your acknowledgment that you have read this EULA, that You understand it and agree to be bound by its terms. If You do not agree to the terms of this EULA, do not use the SOFTWARE and disable, remove it from Your system and destroy Your copies of the SOFTWARE. This EULA is binding for the entire period of the SOFTWARE copyright unless otherwise stated in this EULA or in a separate written agreement between You and ABBYY or ABBYY’s Partner and may depend on the scope of the License as it is described in the EULA.

The SOFTWARE is protected by copyright laws and international treaty provisions and some portions are protected by patent and trade secret laws. You agree that this EULA is enforceable like any written negotiated agreement signed by you. This EULA is enforceable against You.

If the SOFTWARE is accompanied by a hard copy of separate agreement with ABBYY or an ABBYY Partner, governing terms of Your use of the SOFTWARE, then, in the case of any discrepancies in content between the text of this EULA and the text in the hard copy of such separate agreement, the text in the hard copy of the separate agreement shall prevail.

The EULA may be available in different languages. There may be inconsistencies or differences in interpretation between the English version of the EULA and those EULAs made available in other languages. For the sake of uniformity and to avoid any ambiguity, the English version of the EULA shall govern in all disputes, claims or proceedings to interpret, enforce or otherwise relating to the EULA.

Definitions

“ABBYY” means

ABBYY USA Software House Inc. registered at 880 North McCarthy Boulevard, Suite 220, Milpitas, California, 95035, USA, when article 13.1 of this EULA applies;

ABBYY Europe GmbH registered at Elsenheimerstrasse, 49, 80687, Munich, Germany, when article 13.2 of this EULA applies;

ABBYY UK Ltd. Registered at Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, United Kingdom, when article 13.3 of this EULA applies;

ABBYY Production LLC registered at 1-ya ul. Tekstilshikov, d. 12/9, office 2, 109390, Moscow, Russia, when article 13.4 of this EULA applies;

ABBYY Software House Ukraine registered at 31, Degtyarevskaya st., Kiev, Ukraine, 03680, when article 13.5 of this EULA applies;

and ABBYY Solutions Ltd., registered at Michail Karaoli 2, Egkomi, CY 2404, Nicosia, Cyprus, in all other cases.

“ABBYY Partner” means an entity or individual who is licensed by ABBYY to resell and distribute licensed copies of the SOFTWARE to End Users, either directly or through one or more sub-resellers or sub-distributors.

“Activation” means the procedure whereby the Serial number is checked for validity and the installed SOFTWARE is made fully operational in accordance with the SOFTWARE documentation and the scope of Your License.

“Computer” means a specific physical device or virtual machine that may consist of one or more CPU (central processing unit) cores and running specified operating system. Any changes to the configuration or composition of the Computer could result in the Computer being considered a different Computer for licensing purposes.“Intellectual Property Rights” means all intellectual and industrial property rights and includes rights to (i) inventions, discoveries, and letters patent including applications therefor, reissues thereof, and continuation and continuations in part; (ii) copyrights; (iii) designs and industrial designs; (iv) trademarks, service marks, trade dress and similar rights; (v) know-how, trade secrets and confidential information; (vi) integrated circuit topography rights and rights in mask works; and (vii) other proprietary rights.

“License” means the non-exclusive limited right granted to You by ABBYY to install and use the functionality of the SOFTWARE in accordance with the terms and conditions of this EULA.

“Serial number” means a unique identifier of License or License group with similar parameters that is being given by ABBYY or an ABBYY Partner to the End User.

“SOFTWARE” means any version or edition of ABBYY FlexiCapture including any and all software components (add-ons, custom components and modules, etc.) embedded in the software or made available online or by other ways such as: executable, help, demo, sample and other files; libraries, databases, samples, associated media (images, photos, animation, audio-video components, music etc.), printed materials, and other software components.

“You”, “Your” and “End User” refer to and include any person and/or any entity that obtained this SOFTWARE for its own use and not for purposes of further resale and any actual user of the SOFTWARE.

1. License Grant

1.1 Subject to the terms and conditions of the EULA ABBYY grants to You a limited, non-exclusive License to install and use functionality of the SOFTWARE subject to all restrictions and the scope of the License as may be provided by: this EULA, the software and/or hardware license keys provided by ABBYY (“License Key”), the SOFTWARE, and/or a separate written agreement between You and ABBYY or an ABBYY Partner. All provisions stated herein apply both to the SOFTWARE as a whole and to all of its separate components. Any issue with respect to the scope of the license shall be construed in favour of restrictions on the scope of the license. The License Key technically restricts the use of the SOFTWARE and reflects the scope of the License You obtained. Restrictions on Your use of the SOFTWARE and the scope of Your License may include but are not limited to the following:

1.1.1 Number of seats, SOFTWARE components and network access. You may install the SOFTWARE on more than one Computer on a Network and simultaneously use specified components of the SOFTWARE on a specified number of Computers on a Network (“concurrent licensing”). Information about the available SOFTWARE components and the number of Computers on a Network allowed for simultaneous work with the SOFTWARE is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.2 Processing volume. The number of pages that may be processed by the SOFTWARE may be limited in one or more ways, such as limitations on the number of pages that may be processed within particular time periods, such as monthly or annually, or on the overall number of pages that may be processed. The size of the page and the number of data fields per document may also be limited. Processing volume limitations are specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner

1.1.3 Duration. Use of the SOFTWARE may be limited by a fixed period of time, and the SOFTWARE may not be used beyond the expiration of such time period. Limitation of the duration is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.4 Features, add-ons and custom components. The use of particular features, add-ons and/or custom components of the SOFTWARE may be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.2 Processing power. The number of CPU (central processing unit) cores of the Computers which can be utilized by the SOFTWARE may also be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner. All rights not expressly granted to You by the EULA are reserved by ABBYY. This EULA does not grant You any rights in connection with any trademarks of ABBYY.

1.3 If Article 13.4 applies and You are an individual human being person, You may use the SOFTWARE worldwide. If Article 13.4 applies and You are an entity, the SOFTWARE may be obtained (purchased) only in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner. The employees of the entity or of its branch and representative offices may use the SOFTWARE worldwide, provided the SOFTWARE has been obtained and installed in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner.

1.4 Any use of the SOFTWARE or component parts outside of or in contravention of the terms and conditions of this EULA shall constitute a breach of ABBYY’s and/or third parties’ intellectual property rights and shall give cause for the revocation of all rights to use the SOFTWARE granted to You under this EULA.

1.5 If You deploy or use the SOFTWARE in a virtual environment, at no time may access or use of the SOFTWARE exceed the restrictions on the SOFTWARE, or the scope of the license that has been granted. For instance, the same License Key may not be used to permit use or access to the SOFTWARE in a virtual environment by a number of Computers that is greater than the number of Computers for which a license has been properly obtained, nor may the SOFTWARE be used to process more than the total number of pages that has been permitted.

1.6 If You deploy the SOFTWARE by using terminal services which allow accessing the SOFTWARE on a remote computer over a network, the amount of simultaneously running instances of the SOFTWARE may not exceed the number of Computers for which a License has been obtained.

1.7 If You use the SOFTWARE by means of a web browser, You may simultaneously access the SOFTWARE by as many Computers as permitted by the scope of Your License and specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.8 You may receive the SOFTWARE on more than one medium (multiple-media SOFTWARE), including downloads over the Internet. Regardless of the quantity or type of media You receive, You are only licensed to use the SOFTWARE in accordance with the scope of the SOFTWARE License.

2. Limitations of Use

2.1 In order to use the SOFTWARE You should perform Activation of the SOFTWARE after installation.

2.2 All terms of use and limitations governing the use of the SOFTWARE are stated in this EULA, unless otherwise stipulated in a separate written agreement between You and ABBYY or an ABBYY Partner or in other documentation accompanying the SOFTWARE.

2.3 You may not perform or make it possible for other persons to perform any activities included in the list below:

2.3.1 Reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

2.3.2 Modify, adapt (including any changes for the purpose of enabling the SOFTWARE to run on Your hardware), or make any changes to the object code of the Software, applications and databases contained in the SOFTWARE other than those provided for by the SOFTWARE and described in the documentation.

2.3.3 Correct errors in the SOFTWARE or translate the SOFTWARE without the prior written consent of ABBYY.

2.3.4 Rent, lease, sublicense, assign or transfer any rights granted to You by this EULA and other rights related to the SOFTWARE to any other person or authorize all or any portion of the SOFTWARE to be copied onto another computers (except as described in article 2.6)

2.3.5 Make it possible for any person not entitled to use the SOFTWARE to access and/or use the SOFTWARE, including without limitation in a multi-user system, virtual environment, or via the Internet.

2.3.6 Remove, change or obscure any copyright, trademark or patent notices that appear on the SOFTWARE as delivered to You.

2.4 You may not use the SOFTWARE to provide paid or free recognition or conversion services and/or to provide the results or access to the results acquired through the use of the SOFTWARE as a part of another service that has recognition or conversion as its component to any third party unless You have signed a separate written agreement with ABBYY and Your License Key has the parameter “BPO services” enabled.

2.5 You may not bypass the SOFTWARE’s user interface that is provided with the SOFTWARE, without an additional written agreement with ABBYY.

2.6 You may only make a one-time permanent transfer of this SOFTWARE only directly to another end user. If you are an entity, such a transfer requires written approval by ABBYY. This transfer must include all of the SOFTWARE (including all copies, SOFTWARE Components, the media and printed materials, any updates) and this EULA. Such transfer may not be by way of consignment or any other indirect transfer. The transferee of such one-time transfer must agree to comply with the terms of this EULA, including the obligation not to further transfer this SOFTWARE. You must uninstall the SOFTWARE from all of Your Computers or from Your Local Area Network in the case of such SOFTWARE transfer.

3. Pre-release, Trial or Demo SOFTWARE

3.1 If the SOFTWARE You have received with this License is a pre-commercial release or Beta-Release Software, provided for a trial or for demonstration, verification or testing purposes, has limited or less than full functionality, labeled “Try&Buy” “Trial”, “Demo” or was provided at no charge (“Restricted Software”), then this article 3 shall apply until such time that You obtain (purchase) a license for the full version of the SOFTWARE. To the extent that any provision in this is in conflict with any other term or condition in this EULA, this article shall supersede such other term(s) and condition(s) with respect to the Restricted Software, but only to the extent necessary to resolve the conflict.

3.2 THE RESTRICTED SOFTWARE IS PROVIDED TO YOU “AS IS” AND WITHOUT WARRANTY OR INDEMNITY (EXPRESS, IMPLIED OR STATUTORY) OF ANY KIND. THE RESTRICTED SOFTWARE DOES NOT REPRESENT FINAL SOFTWARE FROM ABBYY, AND MAY CONTAIN BUGS, ERRORS AND OTHER PROBLEMS THAT COULD CAUSE SYSTEM OR OTHER FAILURES AND DATA LOSS. TO THE GREATEST EXTENT ALLOWABLE UNDER APPLICABLE LAWS, NO WARRANTY SHALL APPLY TO THE RESTRICTED SOFTWARE, AND FOR CLARITY YOU ACKNOWLEDGE THAT ABBYY DISCLAIMS ANY WARRANTY OR LIABILITY OBLIGATIONS TO YOU OF ANY KIND, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF TITLE, MERCHANTABILITY, NON-INFRINGEMENT, QUIET ENJOYMENT, AND FITNESS FOR A PARTICULAR PURPOSE. WHERE LIABILITY CANNOT BE EXCLUDED BUT MAY BE LIMITED, ABBYY’S TOTAL LIABILITY AND THAT OF ITS PARTNERS SHALL BE LIMITED TO THE SUM OF FIFTY UNITED STATES DOLLARS (U.S. $50) OR THE TOTAL AMOUNT YOU PAID FOR THE SOFTWARE, WHICHEVER IS GREATER.

3.3 Restricted Software may have limited functionality, such as having functionality for a limited period of time, and upon expiration of permitted functionality (“time-out”), Your access and ability to use the Restricted Software may be disabled. Upon a time-out, Your rights under the EULA shall terminate, unless You obtain a new license from ABBYY.

3.4 Restricted Software for which there has not been a commercial release.

3.4.1 Restricted Software for which there has not been a commercial release constitutes the Confidential Information of ABBYY.

3.4.2 As to Restricted Software for which there has not been a commercial release, ABBYY does not promise or guarantee, has no express or implied obligation, and You acknowledge that ABBYY has not promised or guaranteed, that such software will be further developed, or that a commercial version will be announced or made available in the future. ABBYY may not introduce a software product similar to or compatible with such software. Accordingly, You acknowledge that any use, research or development that You perform regarding such software is done entirely at Your own risk.

3.4.3 You agree to provide feedback to ABBYY regarding testing and use of the Restricted Software, including error or bug reports (“Feedback”), and to entirely transfer and grant to ABBYY all rights in such Feedback, including without limitation, the rights to use, publish and disseminate the Feedback. All Feedback constitutes the Confidential Information of ABBYY.

3.4.4 Confidentiality of Restricted Software for which there has not been a commercial release and its Results;

3.4.4.1 You agree not to disclose accompanying written, oral or electronic information divulged to You by ABBYY related to the Restricted Software for which there has not been a commercial release, any information about the quality of such Restricted Software or the quality of the results acquired through the use of such Restricted Software, Feedback, and any information about bugs, errors and other problems discovered by You in the Restricted Software for which there has not been a commercial release are the Confidential Information of ABBYY.

3.4.4.2 You shall not disclose Confidential Information. The term “disclose” means to display, describe, copy, lease, loan, rent, assign, transfer or provide access, over a network or otherwise, to Confidential Information reproduced in any form, including oral communications, to any third party.

3.4.4.3 You shall take all reasonable steps to prevent the disclosure of Confidential Information and to keep it confidential.

3.4.4.4 You shall promptly inform ABBYY if You become aware of any disclosure of Confidential Information. If You are in breach of the terms and conditions set forth in articles 3.4.4.1 - 3.4.4.3 above, You shall compensate ABBYY for any loss resulting from such breach.

3.5 Upon receipt of a later version of Restricted Software or a commercial release of such software, whether as a stand-alone product or as part of a larger product, You agree to return or destroy all earlier versions of the Restricted Software received from ABBYY.

3.6 If You have been provided the Restricted Software pursuant to a separate written agreement Your use of the SOFTWARE is also governed by such agreement. To the extent that any term or condition of a separate written agreement are in conflict with any term or condition of this EULA, a separate written agreement shall supersede such other term(s) and condition(s) with respect to the SOFTWARE, but only to the extent necessary to resolve the conflict.

4. Not-for-resale SOFTWARE

4.1 If the SOFTWARE is labeled “Not for Resale” or “NFR,” then, notwithstanding other articles of this EULA, You may only use such SOFTWARE for demonstration, verification or testing purposes.

5. Updates

5.1 If the SOFTWARE is labeled as an update, You must own a license for the previous version of the SOFTWARE identified by ABBYY as being eligible for this update in order to use the SOFTWARE.

5.2 The SOFTWARE labeled as an update replaces and/or supplements the product that formed the basis for Your eligibility for the update.

5.3 You may only use the resulting updated product in accordance with the terms of the EULA supplied with this update.

5.4 You acknowledge that any obligation ABBYY may have to support the version of the SOFTWARE being updated shall end upon the availability of the update.

6. Technical Support and Maintenance

6.1 You may be provided with technical support and maintenance related to the SOFTWARE (“Support Services”) subject to the current ABBYY support policy. However, You may be entitled to a different level of Support Services than is stated in the ABBYY support policy in accordance with a written agreement executed between You and ABBYY or an ABBYY Partner with respect to such Support Services.

6.2 General terms and conditions of the ABBYY support policy are published on the ABBYY Web site www.abbyy.com. ABBYY reserves the right to change the support policy any time without any prior notice.

6.3 In addition to the general terms and conditions, ABBYY may have specific support policies in specific regions which may be regulated by separate agreements.

6.4 Any supplementary software code and any SOFTWARE component provided to You as part of Support Services is to be considered a part of the SOFTWARE and subject to the terms and conditions of this EULA.

6.5 To be eligible for Support Services, You may be required to provide ABBYY with information about the characteristics of Your hardware, Serial Number of Your SOFTWARE as well as certain personal information, such as Your name, company name (if applicable), address, phone number and e-mail address. ABBYY may use the above-mentioned information as described in article 15.1 of the EULA.

7. Ownership.

7.1 No title to any of ABBYY’s Intellectual Property Rights (including the SOFTWARE and any ABBYY patents, trademarks, or copyrights) is transferred to You. You shall not, in any way, during or after the term of the Agreement, make any use of or claim any right to any name, logo, trademark, pattern, or design owned by ABBYY, or any name, logo, trademark, pattern, or design resembling them.

7.2 No title to any of Your Intellectual Property Rights (including the application and any of Your patents, trademarks, or copyrights) is transferred to ABBYY.

7.3 The SOFTWARE contains valuable trade secrets and confidential information belonging to ABBYY and third parties and is protected by copyright laws, including, without limitation, by United States Copyright Law, laws of Russian Federation, international treaty provisions, and the applicable laws of the country in which it is being used or obtained.

7.4 All title and rights in and to the content that is not contained in the SOFTWARE, but may be accessible through the use of the SOFTWARE, are the property of the respective content owners and may be protected by applicable copyright or other intellectual property laws and international treaties. This EULA does not grant You any rights to such intellectual property.

8. Limited Warranty. Disclaimers.

8.1 If required by the legislation of the country in which You obtained (purchased) the SOFTWARE, ABBYY warrants that the media on which the SOFTWARE is furnished will be free from defects in materials and workmanship under normal use only and only for the minimal guarantee term determined by the legislation of the country in which You obtained (purchased) the SOFTWARE starting from the date of purchase. If the SOFTWARE was obtained (purchased) in the countries defined in article 13.4 this period will constitute thirty (30) days starting from the date of obtain (purchase).

8.2 EXCEPT AS EXPPRESSLY PROVIDED IN THIS ARTICLE 8 (LIMITED WARRANTY. DISCLAIMERS), AND EXCEPT FOR ANY WARRANTY, CONDITION, REPRESENTATION, OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE SOFTWARE, INCLUDING WITHOUT LIMITATION ANY SOFTWARE DOCUMENTATION, UPGRADES AND UPDATES IS BEING DELIVERED TO YOU “AS IS” AND ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

9. Limitation of Liability

9.1 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL, SPECIAL OR PUNITIVE DAMAGES, OR ANY LOST PROFITS OR LOST REVENUE RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

10. Warranty Exclusion and Limitations for Users Residing in Germany or Austria

10.1 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then, in accordance with German law, ABBYY warrants that the SOFTWARE provides the functionalities set forth in its documentation included in the SOFTWARE (the “agreed upon functionalities”) for the limited warranty period following receipt of the SOFTWARE copy when used on the recommended hardware configuration. As used in this article, “limited warranty period” means one (1) year if You are a business user or legal entity, and two (2) years if You are not a business user. Non-substantial variation from the agreed upon functionalities shall not be considered and does not establish any warranty rights. This limited warranty does not apply to the SOFTWARE provided to You free of charge, for example, updates, pre-release versions, “Trial” versions, product samples, “Not for resale” (“NFR”) copies of the SOFTWARE, or the SOFTWARE that has been altered by You, to the extent such alterations caused a defect. To make a warranty claim, during the limited warranty period You must return, at our expense, the SOFTWARE and proof of purchase to the location where You obtained it. If the functionalities of the SOFTWARE vary substantially from the agreed upon functionalities, ABBYY is entitled (by way of re-performance and at its own discretion) to repair or replace the SOFTWARE. If this fails, You are entitled to a reduction of the purchase price (reduction) or to cancel the purchase agreement (rescission). For further warranty information, please contact ABBYY’s Customer Support Department in Germany: ABBYY Europe GmbH, Elsenheimerstrasse 49, 80687 Munich, tel.: +49 (0)89 51 11 590, fax: +49 (0)89 51 11 5959.

10.2 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then:

10.2.1 Subject to the provisions in article 10.2.2, ABBYY’s statutory liability for damages shall be limited as follows: (i) ABBYY shall be liable only up to the amount of damages as typically foreseeable at the time of entering into the purchase agreement in respect of damages caused by a slightly negligent breach of a material contractual obligation and (ii) ABBYY shall not be liable for damages caused by a slightly negligent breach of a non-material contractual obligation.

10.2.2 The limitation of liability set forth in 10.2.1 shall not apply to any mandatory statutory liability, in particular, to liability under the German Product Liability Act, liability for assuming a specific guarantee or liability for culpably caused personal injuries.

10.2.3 You are required to take all reasonable measures to avoid and reduce damages, in particular to make backup copies of the SOFTWARE and Your computer data subject to the provisions of this EULA.

11. Additional Limitations for SOFTWARE obtained in the USA

11.1 Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

11.2 Export rules. You agree that you shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12. Third-party technologies

12.1 Embedded Fonts. Font programs are subject to copyright, and the copyright owner may impose conditions under which a font program can be used. One of the conditions may be that You need a licensed copy of the font program to embed the font into a PDF file. In no event shall ABBYY be liable for any damages arising out of or in connection with Your use of embedded fonts.

12.2 Adobe® PDF Library.

12.2.1 The term “Adobe Software” includes Adobe Technology and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

12.2.2 License Grant and Restrictions. ABBYY grants You a non-exclusive right to use the Adobe Software under the terms of this EULA. You may make one backup copy of the Adobe Software, provided the backup copy is not installed or used on any computer.

12.2.3 Intellectual Property Rights. The Adobe Software incorporated into the SOFTWARE is owned by Adobe and its suppliers, and its structure, organization and code are the valuable trade secrets of Adobe and it suppliers. The Adobe Software is also protected by United States Copyright law and International Treaty provisions. You may not copy the Adobe Software, except as provided in this EULA. Any copies that You are permitted to make pursuant to this EULA must contain the same copyright and other proprietary notices that appear on or in the Adobe Software. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the Adobe Software. Except as stated above, this EULA does not grant You any intellectual property rights in the Adobe Software.

12.2.4 Font License. If the Adobe Software includes font software You may embed the font software, or outlines of the font software, into Your electronic documents to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. You may fully embed any font owned by Adobe.

12.2.5 Warranty. ABBYY AND ITS SUPPLIER DO NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE SOFTWARE.

12.2.6 Export Rules. You agree that the Adobe Software will not be shipped, transferred or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations (collectively the “Export Laws”) - In addition, if the Adobe Software is identified as export controlled items under the Export Laws, You represent and warrant that You are not a citizen, or otherwise located within, an embargoed nation and that You are not otherwise prohibited under the Export Laws from receiving the Adobe Software. All rights to use the Adobe Software are granted on condition that such rights are forfeited if You fail to comply with the terms of this EULA.

12.2.7 Trademarks. Adobe and Adobe PDF Library are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

12.3 PixTools® Scan Runtime Libraries.

12.3.1 “EMC Software” shall mean PixTools Scan runtime libraries, Level 1 ISIS Drivers, Level 2 ISIS Drivers, and Level 3 ISIS Drivers. The SOFTWARE may use the EMC Software for communicating between scanner and SOFTWARE through the ISIS interface.

12.3.2 License Grant and Restrictions. ABBYY grants you a non-exclusive right to use the EMC Software incorporated into the SOFTWARE under the terms of this EULA.

12.3.3 Intellectual Property Rights. The EMC Software incorporated into the SOFTWARE is owned by EMC Corporation and its suppliers, and its structure, organization and code are the valuable trade secrets of EMC Corporation and its suppliers. The EMC Software is protected by United States Copyright Law and International Treaty provisions. You may not copy the EMC Software incorporated into the SOFTWARE. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the EMC Software incorporated into the SOFTWARE. Except as stated above, this EULA does not grant you any intellectual property rights in the EMC Software.

12.3.4 Warranty. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE EMC SOFTWARE INCORPORATED INTO THE SOFTWARE. IN NO EVENT WILL EMC CORPORATION OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS OR FOR ANY CLAIM BY ANY THIRD PARTY.

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, so the above limitations may not apply to you. You may have other rights, which vary from state to state or jurisdiction to jurisdiction.

12.3.5 Trademarks. ISIS and PixTools are either registered trademarks or trademarks of EMC Corporation in the United States and/or other countries.

12.4 Cuminas DjVu® SDK.

12.4.1 You, as the End-User, have the right to use DjVu SDK as part of the SOFTWARE for the entire period of such SOFTWARE copyright or for another lesser term of use, stated in the EULA.

12.4.2 License terms: You may not perform or make it possible for other persons to perform reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

12.4.3 ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

12.4.4 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGE, OR ANY LOST PROFITS OR LOST SAVINGS RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

12.4.5 Limitations for SOFTWARE obtained at the USA.

a) Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

b) Export rules. You agree that You shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12.4.6 Third-Party Code:

12.4.6.1 Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.4.6.2 A portion of this software is derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Hiroshima University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.5 Wibu-Systems

12.5.1 WIBU, CodeMeter, SmartShelter, SmartBind are registered trademarks of Wibu-Systems.

12.6 Other licensed technologies. This SOFTWARE is used under license to the following U.S. Patent Nos.: 5,625,465 and 5,768,416.

13. Governing Law

13.1 If the SOFTWARE was obtained in the United States, Canada, Mexico, Belize, Costa Rica, El Salvador, Guatemala, Honduras, Montserrat, Nicaragua, Panama, Turks and Caicos Islands, Virgin Islands, Japan, or Taiwan, this EULA shall be governed by and construed in accordance with the laws of the State of California, United States of America. With respect to any dispute which may arise in connection with this EULA and/or this SOFTWARE, You consent to the exclusive jurisdiction and venue of the federal and/or state courts in the county of Santa Clara in the State of California. For the avoidance of doubt if the SOFTWARE was obtained in the United States, You obtained (purchased) the SOFTWARE from ABBYY USA Software House, Inc.

13.2 If the SOFTWARE was obtained in Austria, Belgium, Denmark, Finland, France, Germany, Italy, Luxembourg, the Netherlands, Portugal, Spain, Sweden, or any other member state of the European Union, except for Malta, Greece and Cyprus, that is not directly mentioned in article 13.3, 13.4 or 13.5 of this EULA, or in Switzerland, Norway, Iceland or Liechtenstein, this EULA shall be governed by and construed in accordance with the substantive law in force in Munich, the Federal Republic of Germany and the competent court of Munich, the Federal Republic of Germany shall have exclusive jurisdiction over all disputes relating to this EULA.

13.3 If the SOFTWARE was obtained in the United Kingdom of Great Britain and Northern Ireland, and Republic of Ireland this EULA shall be governed by and construed in accordance with the laws of England and Wales and the parties accept the exclusive jurisdiction of the courts of England and Wales.

13.4 If the SOFTWARE was obtained in Russia, Byelorussia, Kazakhstan, or any other country of the CIS, except for Ukraine and Moldova, or if the SOFTWARE was obtained (purchased) in Georgia, Latvia, Lithuania or Estonia, this EULA shall be governed by and construed in accordance with the substantive law in force in the Russian Federation.

13.5 If the SOFTWARE was obtained in Albania, Bosnia and Herzegovina, Bulgaria, Croatia, the Czech Republic, Hungary, Israel, Macedonia, Poland, Romania, Slovakia, Slovenia, Turkey, Serbia, Montenegro, Ukraine or Moldova, this EULA shall be governed by and construed in accordance with the substantive law of Ukraine, unless the SOFTWARE has been acquired by the person that has a status of consumer according to the Polish Civil Code. Polish law shall apply to such consumers.

13.6 If article 13.5 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business), any and all disputes, controversies or differences in opinion arising out of or relating to the EULA shall be finally resolved through arbitration in accordance with the arbitration rules and procedures of the International Commercial Arbitration Court at the Ukrainian Chamber of Commerce and Industry according to its Order. Judgment of the Court mentioned above is final and obligatory for execution by both Parties. If Section 13.5 is applied and You are an individual person, the Shevchenkovsky District Court of Kiev, Ukraine, shall have exclusive jurisdiction over all disputes relating to this EULA.

13.7 If article 13.4 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business) the Arbitrazh Court of Moscow, the Russian Federation, shall have exclusive jurisdiction over all disputes relating to this EULA. If article 13.4 is applied and You are an individual person, the Kuzminsky District Court of Moscow, the Russian Federation, shall have jurisdiction over all disputes relating to this EULA.

13.8 In the cases described in articles 13.1-13.5, this EULA will not be governed by the conflict of law rules of any jurisdiction or the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly excluded.

13.9 If the SOFTWARE was obtained (purchased) in a country other than the countries specified in articles 13.1-13.5, this EULA shall be governed by and construed in accordance with the substantial laws of the country in which You obtained (purchased) the SOFTWARE.

14. Termination

14.1 Unless otherwise agreed by You and ABBYY or an ABBYY Partner in a separate written agreement or except as otherwise provided by the EULA or the documentation for the SOFTWARE, this EULA is effective in perpetuity from the date which You first demonstrated your acceptance as provided at the beginning of the EULA or as long as it is permitted under applicable law. To the extent that applicable law requires the statement of an expiration period for this EULA, this EULA will last as long as permitted, but in any event, at least as long as the duration of the SOFTWARE copyright and shall automatically expire without further notice when such time period elapses.

14.2 Without prejudice to any other rights, ABBYY may terminate this EULA if You fail to comply with the terms and conditions of this EULA. In such an event, You must destroy all copies of the SOFTWARE, all of its component parts and remove the SOFTWARE from your Computers.

14.3 You may terminate this EULA by destroying all copies of the SOFTWARE, all of its component parts and removing the SOFTWARE.

14.4 Such termination does not relieve You of Your obligation to pay for the SOFTWARE. Articles 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 and article 3.4.4 shall survive the termination or expiration of this EULA, howsoever caused, but this shall not imply or create any continued right to use the SOFTWARE after termination or expiration of this EULA.

15. Miscellaneous

15.1 In the course of Activation, installation, operation and/or technical support and maintenance of the SOFTWARE You may be required and You hereby agree to provide ABBYY with certain personal information of Yours (such as but not limited to Your name, address, email address, phone number). You may choose not to provide us with your personal information, in which case You may be refused in future to obtain technical support or maintenance of the SOFTWARE available to ABBYY customers who provided their personal information, if provision of personal information is essential to provide You with technical support or maintenance of the SOFTWARE or is requirement of such technical support or maintenance of the SOFTWARE and it does not contradict applicable law. You agree not to provide more personal information than ABBYY or ABBYY’s Partner require, and agree that Your personal information may be processed (including but not limited to collected and/or otherwise used) by ABBYY and/or its affiliates or ABBYY Partners in compliance with applicable law provided that the confidentiality of the data and data security is maintained if it is required by applicable law. Any personal information You provide to ABBYY or its affiliates or ABBYY Partners will be processed, stored and used strictly within ABBYY and its affiliates or ABBYY Partners and will not be disclosed to any third party, except as may be required by applicable law, and, in case of ABBYY Software House Inc., will be maintained in accordance with its privacy policy found at http://abbyy.com/privacy_policy. All personal records will be processed solely for purposes of fulfillment obligations under this EULA by ABBYY. If article 13.5. applies Your personal information will be processed in the database named «Physical persons whose personal information is processed during business activity».

15.2 You agree that the SOFTWARE may require connections via Internet or via e-mail with an ABBYY server during Activation, deactivation or update of the SOFTWARE. ABBYY will take reasonable steps with the goal that no personal information about You will be transferred during such connections.

15.3 ABBYY may send You e-mails containing product and company news, information about special offers, advices on product usage and other product and company-related information provided You agree to receive such information. You may remove Your e-mail address from ABBYY’s mailing list at any time.

15.4 If any claims or lawsuits are brought against You in connection with Your use of the SOFTWARE, You shall inform ABBYY in writing about them promptly and whenever practicable within three (3) days from the moment You learn of them. You shall take all necessary actions to enable ABBYY to take part in the proceedings or hearings of or take over the defense of said claims or lawsuits in court or arbitration, and shall provide ABBYY with Your full cooperation and all information ABBYY deems useful or necessary for the defense of settlement of the corresponding claims or lawsuits, promptly upon (and whenever practicable no later than seven (7) days from the moment of) the receipt of an inquiry from ABBYY.

15.5 Consideration under this EULA is the price of the License established by ABBYY or an ABBYY Partner and payable in accordance with the payment procedures established by them, or may be included in value of equipment or hardware obtained by You or is part of the consideration payable by You for the full version of the SOFTWARE. If You are a natural person, this EULA may be gratuitous.

15.6 If any part of this EULA is found void or unenforceable, it will not affect the validity of the balance of the EULA, which shall remain valid and enforceable according to its terms.


Tastenkombinationen für die Datenverifizierungsstation

Menü | Option | Tastenkombination
Datei | Beenden | Alt+F4
Ansicht | Vollbild | F11
 | Aktualisieren | F5
Tasks | Task abrufen | Strg+G
Hilfe | Hilfethemen | F1


Tastenkombinationen für die Projektkonfigurationsstation

Menü | Option | Tastenkombination
Datei | Neues Projekt… | Strg+Umschalt+N
 | Projekt öffnen… | Strg+Umschalt+O
 | Speichern | Strg+S
 | Neuer Stapel… | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Bilder importieren… | Strg+I
 | Exportieren Daten in Dateien… | Alt+Umschalt+S
 | Exportieren in Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Teststapel | Strg+Umschalt+B
 | Arbeitsstapel | Strg+B
 | Details | Alt+1
 | Miniaturansichten | Alt+2
 | Bildmodus | Strg+1
 | Datenmodus | Strg+2
 | Vergrößern | Strg+Num+
 | Verkleinern | Strg+Num-
 | Miniaturansicht: Vergrößern | Strg+Umschalt+Num+
 | Miniaturansicht: Verkleinern | Strg+Umschalt+Num-
 | Vollbild | F11
 | Aktualisieren | F5
 | Objekteigenschaften | Alt+Eingabetaste
Erkennung | Analyse | Strg+E
 | Dokumentdefinition zuordnen… | Alt+Umschalt+E
 | Erkennung | Strg+R
Überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächstes Dokument mit Zusammenstellungsfehler(n) | F9
 | Vorheriges Dokument mit Zusammenstellungsfehler(n) | Umschalt+F9
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Projekt | Dokumentdefinitionen… | Strg+T
 | Stapeltypen… | Strg+Umschalt+T
 | Bildimportprofile… | Strg+Umschalt+I
Extras | Auf neueste Version aktualisieren | Alt+Umschalt+U
 | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
 | Stapelintegritätsprüfung | Strg+Umschalt+E
Hilfe | Hilfethemen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste


Tastenkombinationen für die Überprüfungsstation

Menü | Option | Tastenkombination
Datei | Speichern | Strg+S
 | Neuer Stapel… | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Exportieren in Daten in Dateien… | Alt+Umschalt+S
 | Exportieren in Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Arbeitsstapel | Strg+B
 | Warteschlangen | Strg+Q
 | Details | Alt+1
 | Miniaturansichten | Alt+2
 | Bildmodus | Strg+1
 | Datenmodus | Strg+2
 | Vergrößern | Strg+Num+
 | Verkleinern | Strg+Num-
 | Miniaturansicht: Vergrößern | Strg+Umschalt+Num+
 | Miniaturansicht: Verkleinern | Strg+Umschalt+Num-
 | Vollbild | F11
 | Aktualisieren | F5
 | Objekteigenschaften | Alt+Eingabetaste
Task | Task abrufen | Strg+G
Erkennung | Analyse | Strg+E
 | Dokumentdefinition zuordnen… | Alt+Umschalt+E
 | Erkennung | Strg+R
Überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächstes Dokument mit Zusammenstellungsfehler(n) | F9
 | Vorheriges Dokument mit Zusammenstellungsfehler(n) | Umschalt+F9
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Extras | Auf neueste Version aktualisieren | Alt+Umschalt+U
 | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
 | Stapelintegritätsprüfung | Strg+Umschalt+E
Hilfe | Hilfethemen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste
 | Registrierungsparameter | Strg+P


IRoutingRuleResult

Worum geht es

Repräsentiert das Ergebnis der Ausführung des Routing-Skripts.

Eigenschaften

Name | Typ | Zugriff | Beschreibung
CheckSucceeded | bool | Lesen/Schreiben | Gibt an, ob die Überprüfung erfolgreich war
DocumentComment | string | Lesen/Schreiben | Ein Kommentar, der im Fall eines erfolgreichen Routings zum Dokument hinzugefügt wird
PrincipalId | int | Lesen/Schreiben | Eine Benutzer- oder Benutzergruppenkennung, die dem Dokument bei erfolgreichem Routing zugeordnet wird. Wurde das Dokument im Routing-Skript keinem Principal zugeordnet, lautet der PrincipalId-Wert "0". Der Wert "0" zeigt an, dass das Dokument von jedem Benutzer verarbeitet werden kann. Ausführliche Informationen finden Sie unter IPrincipal.
Priorität | TProcessingPriority | Lesen/Schreiben | Die dem Dokument zugewiesene Priorität, wenn das Routing-Skript "true" zurückgibt.
ProhibitedUserId | int | Lesen/Schreiben | Ermöglicht Ihnen, die Kennung eines Benutzers, der nicht berechtigt ist, den Task in der folgenden Phase zu verarbeiten, festzulegen oder abzurufen. Standardmäßig lautet der Wert „0“, was bedeutet, dass der Task von allen Benutzer verarbeitet werden darf. Hinweis: Diese Eigenschaft gilt nur für die Tasks, die gemäß einem Workflow-Schema automatisch an eine Phase gesendet werden. Wird der Task manuell an eine Phase gesendet, wird der Eigenschaftswert ignoriert.


Verarbeitungsskripte

Skripte für die Dokument- und Stapelverarbeitung ermöglichen Ihnen die Änderung der Dokument- oder Stapelstruktur, bestimmen eine benutzerdefinierte Reihenfolge der Bereiche im Dokument oder der Reihenfolge von Dokumenten im Stapel. Die Verarbeitung von Skripten kann bei der Erstellung einer benutzerdefinierten Phase im Modus Erweitert der Workflow-Konfiguration hinzugefügt werden.

Beide Skripte werden für die Verarbeitung mehrerer Dokumente verwendet und bieten die Möglichkeit der Protokollierung des Verarbeitungsfortschritts.

Skript für Dokumentverarbeitung

Alle zu verarbeitenden Dokumente werden der Reihe nach an dieses Skript übergeben.

Parameter

Name | Typ | Zugriff | Beschreibung
Document | IDocument | Vollständige Kontrolle | Das zu verarbeitende Dokument
Processing | IProcessingCallback | Vollständige Kontrolle | Das Objekt für die Protokollierung der Informationen über die Verarbeitung

Hinweis: Wird der Task abgebrochen, ändert sich der Verarbeitungsstatus auf false (ähnlich wie bei der Methode IProcessingCallback.ReportError).

Skript zur Stapelverarbeitung

Die Eingabeparameter des Skripts sind ein Stapel und eine Gruppe von zu verarbeitenden Dokumenten. Die Iteration über die Dokumente wird vom Benutzer implementiert.

Der Vorteil der Skripte zur Stapelverarbeitung ist, dass die Methoden, die eine Stapelstruktur verändern können, darin verfügbar sind. Durch diese Methoden wird es möglich, Dokumente und Seiten zu verschieben oder zu löschen.

Parameter

Name | Typ | Zugriff | Beschreibung
Batch | IBatch | Schreibgeschützt. Interne * Felder der Stapeldokumente und Seiten sind nicht verfügbar. | Der Stapel
Documents | IDocuments | Vollständige Kontrolle. Bei diesen Dokumenten kann die Stapelstruktur bearbeitet werden. | Die zu verarbeitenden Dokumente
Processing | IProcessingCallback | Vollständige Kontrolle | Das Objekt für die Protokollierung der Informationen über die Verarbeitung

* - Das interne Feld erfordert das Laden des Objekts in den Speicher.


Verarbeitungsserver

Der Verarbeitungsserver verteilt alle Arbeiten auf die Verarbeitungsstationen. Zusammen mit dem Verarbeitungsserver wird ein Verarbeitungsserver-Monitor installiert, der zur Überwachung des Servers und zum Festlegen von Taskprioritäten dient. Die eigentliche Verarbeitung von Dokumenten erfolgt auf der Verarbeitungsstation.

Konfigurieren Sie den Verarbeitungsserver, sobald er installiert ist: Starten Sie den Server, fügen Sie die Verarbeitungsstationen hinzu, richten Sie sie ein und starten Sie sie, und aktivieren Sie Hot Folders.

Hinweis: Achten Sie darauf, dass vor dem Start des Verarbeitungsservers dem Konto, unter dem der Server ausgeführt wird, Zugriffsrechte für den Verarbeitungsserver zugewiesen wurden (<Domänenname\Computername>$).

Eine Beschreibung des Verfahrens zur Einrichtung ist unten aufgeführt.

Collapsed Starten des Verarbeitungsservers

So starten Sie den Verarbeitungsserver:

  1. Starten Sie den Verarbeitungsserver-Monitor, indem Sie Start>Programme>ABBYY FlexiCapture Server> Verarbeitungsserver wählen.

  2. Im Serverbaum wählen Sie ABBYY FlexiCapture Server, klicken mit der rechten Maustaste darauf und wählen Server hinzufügen…

  3. Im Dialogfeld Verarbeitungsserver hinzufügen geben Sie den Speicherort des Servers (Netzwerkhost oder Lokaler Host) an.

  4. Wählen Sie Aktionen>Eigenschaften und geben Sie den Pfad zum Anwendungsserver (http://server) an. Wenn der Verarbeitungsserver und der Anwendungsserver auf demselben Computer installiert werden, geben Sie dessen Namen direkt an, weil die Verwendung der IP-Adresse 127.0.0.1 oder des Ausdrucks localhost die Verarbeitungsstationen funktionsunfähig macht.

    Hinweis: Starten Sie auf dem Anwendungsserver die Administrations- und Überwachungskonsole, und weisen Sie dem Computer, auf dem der Verarbeitungsserver installiert wird, die entsprechende Rolle zu.

  5. Klicken Sie auf [image], um den Anwendungsserver zu starten.

    Hinweis: Der Verarbeitungsserver kann hart oder "weich" angehalten werden. Muss der Verarbeitungsserver beispielsweise aufgrund eines Upgrades oder für das Verschieben einer Datenbank angehalten werden, können Sie das "weiche" Anhalten verwenden. Dafür wählen Sie Aktionen>Anhalten. In diesem Fall werden alle aktuellen Tasks abgeschlossen und der Verarbeitungsserver wird danach angehalten. Es werden keine neuen Tasks in die Verarbeitung aufgenommen.

    Für ein sofortiges Anhalten des Verarbeitungsservers wählen Sie Aktionen>Sofort anhalten. In diesem Fall werden alle aktuellen Tasks fehlschlagen.

Collapsed Starten der Verarbeitungsserver

Um die Verarbeitungsstationen einzurichten:

  1. Wählen Sie im Serverbaum Stationen aus und klicken Sie auf [image]. Das Dialogfeld Stationen hinzufügen wird angezeigt. Wählen Sie aus der Gesamtliste die gewünschten Stationen aus. Sie können auch den Namen des Computers oder seine IP-Adresse angeben. Sie können den Namen des Computers sogar dann angeben, wenn dynamische IP-Adressen verwendet werden. Verwenden Sie IP-Adressen, wenn beim Zugriff auf das DNS-Netzwerk Probleme auftreten.
  2. Wählen Sie Aktionen>Eigenschaften und geben Sie im Dialogfeld Stationseigenschaften die Parameter der Station an:
    • Name - der angezeigte Name der Station
    • Start automatisch - dieses Flag bedeutet, dass die Station vom Verarbeitungsserver automatisch gestartet wird.

      Hinweis: Häufige Versuche, zu viele Stationen zu starten, können den Verarbeitungsserver beträchtlich verlangsamen.

    • Erforderlicher Festplattenspeicherplatz -der minimale Festplattenspeicherplatz, der für den Betrieb der Verarbeitungsstationen benötigt wird; wenn nicht genügend freier Festplattenspeicherplatz verfügbar ist, wird die Station gestoppt. Der in das Feld eingegebene Platz sollte dreimal höher sein, als die maximale Größe eines Bildes, das verarbeitet werden kann. Der optimale Wert für den minimalen Festplattenspeicherplatz ist die doppelte Maximalgröße eines Stapels, der verarbeitet werden kann.
    • Maximale Anzahl von Prozessen (CPU-Cores) - die maximale Anzahl an CPU-Kernen, die für die Taskverarbeitung verwendet werden können
    • Zulässige Anzahl von Prozessen (CPU-Cores) - die zulässige Anzahl an CPU-Kernen für die Taskverarbeitung; dieser Parameter wird basierend auf Ihrer Hardware und den Parametern Ihrer Lizenz berechnet und kann nicht geändert werden.
    • Prozesspriorität - die Priorität des Prozesses
    • Acceptable task types - die Tasktypen, die von der Station verarbeitet werden können:
      • Bilder importieren - Tasks importieren
      • Seiten erkennen - vorverarbeitende Tasks exportieren
      • Überprüfungssupport - Zusammenführung von Ergebnissen der Doppelüberprüfung sowie Vor- und Nachverarbeitung von Tasks für die Web-Datenüberprüfung und Web-Datenüberprüfungsstationen.
      • Benutzerdefinierte Verarbeitung - Verarbeitung von Skripten für die Stapel- und Dokumentverarbeitung
      • Dokumente exportieren - Tasks für den Dokumentexport
  3. Starten Sie die Station durch Klicken auf [image] manuell oder warten Sie, bis die Station automatisch startet (wurde die Option Start automatisch gewählt, startet die Station innerhalb einer Minute automatisch).

    Hinweis: Die Verarbeitungsstation kann hart oder "weich" angehalten werden. Muss die Verarbeitungsstation beispielsweise aufgrund eines Upgrades angehalten werden, können Sie das "weiche" Anhalten verwenden. Dafür wählen Sie Aktionen>Anhalten. In diesem Fall werden alle aktuellen Tasks abgeschlossen und die Verarbeitungsstation wird danach angehalten. Es werden keine neuen Tasks in die Verarbeitung aufgenommen.

    Für ein sofortiges Anhalten der Verarbeitungsstation wählen Sie Aktionen>Sofort anhalten. In diesem Fall werden alle aktuellen Tasks fehlschlagen.

    Hinweis: Die Stationen erhalten die Rechte für das Verarbeiten von Dokumenten vom Verarbeitungsserver, wenn sie mit dem Server verbunden werden.

Collapsed Aktivieren von Hot Folder

So aktivieren Sie Hot Folder:

  1. Wählen Sie im Baum des Verarbeitungsservers Hot Folder.

  2. Wählen Sie in der Gesamtliste der Projekte das gewünschte Projekt aus.

  3. Wählen Sie im Kontextmenü die Option Aktivieren aus.

Hinweis: Die Option Hot Folder alle N Sekunden muss für dieses Projekt ausgewählt sein.

Collapsed Einrichten des Verarbeitungsserverprotokolls

Um das Verarbeitungsserverprotokoll anzupassen:

  1. Öffnen Sie das Dialogfeld Verarbeitungsserver-Monitoreinstellungen, indem Sie Datei>Einstellungen… wählen.
  2. Geben Sie an, welche Meldungen protokolliert werden sollen (Fehler, Warnungen, Informationsmeldungen).
  3. Geben Sie an, ob Informationen zu abgeschlossenen Tasks gelöscht werden sollen (Abgeschlossenen Task von Liste streichen).
  4. Geben Sie an, welche Meldungen Protokollierungsinformationen über den Task auslösen.

    Hinweis: Wir raten davon ab, die Option Abgeschlossenen Task von Liste streichen während des normalen Betriebs des Systems zu deaktivieren, weil dies zu einer Anhäufung von Daten und einer Verlangsamung des Verarbeitungsserver-Monitors führen kann. Deaktivieren Sie diese Option nur beim Einrichten und Abstimmen des Systems.

  5. Klicken Sie für die Anzeige des Taskprotokolls auf [image]. Um ein Taskprotokoll als *.txt-Datei zu speichern, klicken Sie im sich öffnenden Dialogfeld auf die Schaltfläche Protokoll exportieren….
Collapsed Ansicht der Taskinformationen

Für die Anzeige der Taskdetails wählen Sie im Baum des Verarbeitungsservers Tasks. Für jeden Task werden die folgenden Parameter angezeigt: Taskname, Startzeit, Fortschritt, Status, Priorität und der Stationsname. Fehlgeschlagene Tasks sind mit einem [image]. markiert. Enthält der Task neben der Fehlermeldung außerdem informative Meldungen, wird der Task mit einem [image] markiert.

Collapsed Dienstprotokoll

Neben dem regulären Taskverarbeitungsprotokoll können der Verarbeitungsserver und die Verarbeitungsstation ein Dienstprotokoll erstellen. Unter Umständen benötigt das Personal des technischen Supports von ABBYY Informationen dieses Protokoll, um Ihre Supportanfragen zu bearbeiten. Dienstprotokolle verringern die Geschwindigkeit des Verarbeitungsservers oder der Verarbeitungsstation nicht. Die darin enthaltenen Informationen sind jedoch nur für die Mitarbeiter des technischen Supports von ABBYY von Nutzen. Deshalb empfehlen wir, die Protokolle nicht dauerhaft zu aktivieren. Wenn ein Mitarbeiter des technischen Supports Sie um ein Dienstprotokoll bittet, gehen Sie folgendermaßen vor:

  1. Öffnen Sie je nachdem, welches Protokoll benötigt wird, das Dialogfeld Eigenschaften des Verarbeitungsservers (wählen Sie Eigenschaften aus dem Kontextmenü des Verarbeitungsservers) oder das Dialogfeld Eigenschaften der Station (wählen Sie Eigenschaften im Kontextmenü der Verarbeitungsstation).

  2. Wählen Sie die Option Verarbeitungsprotokoll schreiben und klicken Sie auf OK.

  3. Sind die Protokolldateien erstellt, sind Sie in %programdata%\ABBYY\FlexiCapture\11.0\FlexiBrSvc\Logs zu finden. Senden Sie Kopien dieser Dateien an den technischen Support von ABBYY.

  4. Deaktivieren Sie das Dienstprotokoll durch Deaktivieren der Option Verarbeitungsprotokoll schreiben und klicken Sie auf OK.

Collapsed Verwaltung des Verarbeitungsservers mithilfe der Befehlszeile

Der Verarbeitungsserver kann über die Befehlszeile bedient werden. Zur Bedienung über die Befehlszeile gehen Sie wie folgt vor:

  • Geben Sie im Windows-Menü Start -> Ausführen 'cmd' ein und klicken Sie auf OK. Es erscheint ein Befehlszeilenfenster mit einer Eingabeaufforderung;
  • Geben Sie den Pfad zur Datei FlexiBRSvc.exe (standardmäßiger Pfad "C:\Programme\ABBYY FlexiCapture Capture 11 Servers");
  • Geben Sie "FlexiBRSvc.exe bitte befolgen" ein, um in den Befehlsmodus zu gelangen. Die Befehle werden in der Form 'FlexiBRSvc Bitte <Befehl>' eingegeben. Mit den Befehlen können Sie eine Station starten oder anhalten, die Stationsliste anzeigen, den Verarbeitungsserver starten oder anhalten, Stationen hinzufügen oder entfernen, Hot Folder aktivieren oder deaktivieren sowie Server- und Stationsparameter einstellen;
  • Möchten Sie sich die Liste aller zulässigen Befehle und andere Hilfeinformationen anzeigen lassen, geben Sie 'FlexiBRSvc.exe /?' ein.


Remote-Überprüfungsstation

Ähnlich wie mit der lokalen Überprüfungsstation kann man mit der Remote-Überprüfungsstation die Daten überprüfen, problematische Stapel oder Dokumente verarbeiten, Zusammenstellungsfehler korrigieren, Datenregeln anwenden und Stapel auf Integrität überprüfen.

Der Unterschied zwischen den Lokal- und den Remotestationen besteht darin, dass die Remote-Überprüfungsstation keine Hintergrundprozesse unterstützt, wie z. B. Import, Erkennung und Export. Daher sind Operationen, die Hintergrundprozesse beinhalten, nur in der lokalen Überprüfungsstation verfügbar.

Die Remote-Überprüfungsstation ermöglicht es Ihnen, Dokumentdefinitionen auf Dokumenten und Seiten zuzuordnen. Möchten Sie die Dokumentdefinition ändern, wählen Sie im lokalen Dokument- oder Seitenmenü Dokumentdefinition zuordnen. Das Dokument wird für die Verarbeitung markiert und der Name der neuen Dokumentdefinition in der Spalte Hinweis wird gesendet angezeigt. Möchten Sie die Zuordnung einer neuen Dokumentdefinition löschen, wählen Sie im lokalen Menü des Dokuments oder der Seite das Element Dokumentdefinition zuordnen und die ursprüngliche Dokumentdefinition aus.

Falls erforderlich, können Sie auch eine Seite als Anhangseite markieren. Wählen Sie dazu im lokalen Seitenmenü Seite als Anhang einstellen.

Möchten Sie die Erkennungsergebnisse für ein Dokument oder eine einzelne Seite löschen, verwenden Sie dazu das Element Analyseergebnisse löschen auf dem lokalen Menü der Seite oder des Dokuments.

Wenn der Task geschlossen wird, werden alle Dokumente, deren Dokumentdefinition geändert wurde (oder wo einer Dokumentseite eine neue Dokumentdefinition zugeordnet wurde), zur erneuten Erkennung gesandt. Nach der erneuten Erkennung werden diese Dokumente entsprechend dem standardmäßigen Workflow-Schema weitergeleitet (das gilt auch für Dokumente, die zuvor für den Versand an eine bestimmte Phase markiert oder manuell an die Phase geschickt worden waren).

Hinweis: Dokumente, deren Dokumentdefinition geändert wurde und die danach die ursprüngliche Dokumentdefinition wiedererhalten haben, werden nicht zur erneuten Erkennung gesandt, und ihre weitere Verarbeitung erfolgt entsprechend dem zuvor festgelegten Workflow-Schema.


Überprüfungsstation

Mit der Überprüfungsstation können komplexere Überprüfungen als mit der Datenüberprüfungsstation vorgenommen werden. Außer der Überprüfung der Daten kann der Operator mit der Station problematische Stapel oder Dokumente verarbeiten, Zusammenstellungsfehler korrigieren, Datenregeln anwenden und Stapel auf Integrität überprüfen. Die Überprüfungsstation kann sowohl in einem lokalen als auch in einem dezentralen Netzwerk (über das Internet) genutzt werden. Die Autorisierung wird mittels Benutzername und Passwort durchgeführt. Weitere Informationen finden Sie unter Remote-Überprüfungsstation.

Die Überprüfungsstation kann von den folgenden Operatoren betrieben werden: Datenüberprüfungsoperatoren, Überprüfungsoperatoren und leitende Überprüfungsoperatoren. Abhängig von der bei der Anmeldung auf die Station vom Operator ausgewählten Rolle kann er Tasks von verschiedenen Warteschlangen sehen und verarbeiten:

  • Der Datenüberprüfungsoperator kann nur Tasks aus der Warteschlange für die Datenüberprüfung verarbeiten
  • Ein Überprüfungsoperator kann Tasks aus jeder Phase verarbeiten, mit Ausnahme der Phasen Ausnahmen und Exportbestätigung
  • Ein leitender Überprüfungsoperator kann Tasks von jeder Warteschlange verarbeiten. Außer auf die Warteschlangenliste kann der leitende Überprüfungsoperator außerdem auf die Stapelliste (Einzelheiten siehe unten) und auf den Ansichtsmodus für die einzelnen Phasen zugreifen, wo ein bestimmter Task aus der Warteschlange ausgewählt werden kann.

Hinweis: Der Administrator kann weitere Verarbeitungsphasen und die entsprechenden Warteschlangen erstellen. Ob ein Operator auf diese Warteschlangen zugreifen kann, hängt von der Rolle des Operators und den erforderlichen Berechtigungen für diese Warteschlangen ab (diese Berechtigungen werden vom Administrator festgelegt).

Hinweis: Die Liste der verfügbaren Rollen ist von den Zugriffsrechten des Operators abhängig. Steht dem Operator nur eine Rolle zur Verfügung, wird die Rollenliste nicht angezeigt.

Folgende Warteschlangen sind auf der Überprüfungsstation verfügbar:

  • <Alle>

    Diese Warteschlange beinhaltet in allen anderen Warteschlangen erstellte Tasks. Die für einen Operator verfügbaren Warteschlangen sind abhängig von der vom Operator ausgewählten Rolle bei der Anmeldung auf der Station. Die Tasks werden in der Reihenfolge ihrer Priorität angenommen.

  • Datenüberprüfung

    Der Datenüberprüfungsvorgang startet mit der Gruppenüberprüfung, danach folgt die Feldüberprüfung. Wenn eine Dokumentdefinition keine in Gruppen oder Feldüberprüfung enthaltenen Felder beinhaltet, wird das Dokument nicht in der Datenüberprüfungswarteschlange positioniert.

  • Überprüfen der Dokumentzusammenstellung

    Bei mehrseitigen Dokumenten müssen fehlerhafte Dokumentzusammenstellungen unter Umständen korrigiert werden. Dokumentzusammenstellungsregeln werden zusammen mit den Dokumentdefinitionen erstellt und definieren die Reihenfolge der Seiten und Anzahl der Seitenwiederholungen. Zusätzlich kann eine Überprüfung der Dokumentzusammenstellung anhand von Schlüsselfeldern notwendig sein. In diesem Fall müssen die Werte der Schlüsselfelder auf sämtlichen Seiten des Dokuments gleich sein. Wenn die Werte unterschiedlich sind, wird eine Fehlermeldung angezeigt und die Werte werden rot markiert. Zusammenstellungsfehler können am Besten in der Miniaturansicht der Seite korrigiert werden, da sie eine übersichtliche Ansicht der Seiten bietet und es sofort klar wird, zu welchem Dokument die Fehler gehören.

  • Überprüfung

    Wenn durch die Verarbeitungsparameter keine speziellen Warteschlangen bestimmt sind, enthält die Überprüfungswarteschlange alle Tasks mit fehlerhaften Dokumentzusammenstellungen, Datenüberprüfungsfehlern und Regelfehlern.

  • Stapelintegritätsprüfung

    Die für die Datenintegritätsüberprüfung verwendeten Regeln stellen Links zwischen den Daten in den Dokumenten eines Stapel her.

  • Exportbestätigung

    Daten können manuell oder automatisch exportiert werden. Wenn die Verarbeitungsparameter keine separate Exportbestätigungs-Warteschlange definieren, werden die Dokumente automatisch exportiert. Wenn die Verarbeitungsparameter eine separate Exportbestätigungs-Warteschlange enthalten, muss der leitende Überprüfungsoperator zuerst die Dokumente des Tasks überprüfen und diesen dann wieder an die Exportwarteschlange zurücksenden. Wenn in der Exportphase ein Fehler auftritt, werden die Dokumente automatisch an die Ausnahmenwarteschlange gesendet.

  • Ausnahmen

    Problematische Stapel oder Dokumente, die vom Operator oder den Stationen nicht verarbeitet werden konnten, werden an die Ausnahmenwarteschlange gesendet.

Hinweis: Die Verarbeitungsparameter des Dokuments (z. B. separate Warteschlangen) werden für Stapeltypen oder - wenn keine Stapeltypen verwendet werden - für das gesamte Projekt bestimmt.

Um einen Task auszuführen, wählen Sie die gewünschte Warteschlange in der Liste aus und klicken auf [image].

Sie können den automatischen Taskempfangsmodus durch Anklicken von [image] oder Task>Automatischer Taskempfang aktivieren.

Die Vorschau der Taskdokumente ist in den Ansichtsmodi Details und Miniaturansichten verfügbar. In der Ansicht Details werden die Dokumente des aktiven Tasks angezeigt. In der Ansicht Miniaturansichten werden alle Dokumente des Stapels angezeigt und die Seiten, die nicht Teil des aktiven Tasks sind, werden grau markiert.

Außer auf die Warteschlangenliste kann der leitende Überprüfungsoperator außerdem auf die Stapelliste des aktuellen Projekts zugreifen. Dafür wählen Sie im Menü die Option Ansicht>Stapel oder klicken auf die entsprechende Schaltfläche auf der Symbolleiste.

Im Stapelansichtsmodus erhält der Operator Zugriff auf Informationen über den Vertrauensgrad des Stapels, die Anzahl der Seiten und Dokumente, den Stapeltyp usw. Per Mausklick auf einen Stapel in der Liste können Sie den ausgewählten Stapel zu jeder Arbeitsphase senden, die Stapelpriorität bestimmen, einen bestimmten Benutzer wählen und Kommentare hinzufügen. Dadurch können Sie Dokumente von verschiedenen Verarbeitungswarteschlangen sammeln, die zu einem Stapel gehören, und sie an eine Phase übergeben.

Mit einem Doppelklick können Sie den Stapel aufklappen und sich die Liste der Dokumente ansehen, Daten überprüfen, eventuelle Regel- und Zusammenstellungsfehler korrigieren usw. Mit einem Mausklick auf eines oder mehrere Dokumente senden Sie die ausgewählten Dokumente an eine Arbeitsphase und erstellen einen separaten Task für sie.

Möchten Sie ausgewählte Dokumente für die Übergabe an Ausnahmen, Re-scan oder andere Verarbeitungsphasen markieren, wählen Sie es im Menü Task oder im lokalen Menü des Dokuments aus. Im daraufhin angezeigten Dialogfeld können Sie ihren Kommentar eingeben oder aus der Liste Letzte Kommentare einen Kommentar auswählen. Sie können eine Auswahl aus den 10 letzten Kommentaren zu versandten Tasks treffen. Möchten Sie den Text eines Kommentars aus der Liste bearbeiten, wählen Sie den gewünschten Kommentar, klicken Sie auf OK und bearbeiten Sie den Kommentar im Eingabefeld. Befindet sich in der Liste ein selten benutzter Kommentar, können Sie ihn löschen.

Die Liste der Kommentare wird in der Registrierungs-Teilstruktur

[HKСU\Software\ABBYY\FlexiCapture\11.0\Shell\Stages\RecentStageCommentList]

Die Kommentare in der Zeichenfolge werden durch Komma getrennt. Enthält der Kommentartext ein Komma, gibt man dieses als «/,» ein. Das Symbol für eine neue Zeile, «/», wird als «//» eingegeben. Ein mehrzeiliger Kommentar wird als eine Zeile, unterteilt durch Leerzeichen, dargestellt. In einem Kommentartext dürfen alle Zeichen verwendet werden.

Somit verwenden verschiedene FlexiCapture-Benutzer, die in der lokalen Überprüfungsstation innerhalb einer Windows-Benutzersitzung arbeiten, dieselbe Liste.

Für Dokumente, die an "Re-scan" gesendet werden, können Sie auch den Operator festlegen, dem der Task zugeordnet wird. Standardmäßig wird der Operator ausgewählt, der das Dokument gescannt hat. Hat dieser Operator nicht die erforderlichen Berechtigungen oder wurden die Bilder aus einem Hot Folder importiert, wird der Benutzer "Alle" als Scan-Operator festgelegt.

Ist der Task geschlossen, werden für das Versenden markierte Dokumente an die jeweiligen Verarbeitungsphasen gesendet.

Hinweis: Beim Senden von Stapeln an Phasen dürfen die Dokumente des Stapels nicht zu bereits erstellten Tasks gehören, da sonst leere Tasks erstellt werden. Sie können anhand der Spalte Task-ID überprüfen, ob das Dokument zu einem Task gehört.


Arbeitsablauf

Es können sowohl vorkonfigurierte als auch benutzerdefinierte Abläufe für die Verarbeitung von Dokumenten verwendet werden. Vorkonfigurierte Verarbeitungsschemen können entweder unbeaufsichtigt (Modus Unbeaufsichtigt) sein oder menschliche Operatoren einbeziehen (Modus Einfach). Ein benutzerdefiniertes Verarbeitungsschema ist im Modus Erweitert konfiguriert. Es gibt außerdem einen Spezialmodus für Web-Erfassungsstation.

Besonderheiten der Modi Einfach, Erweitert, Unbeaufsichtigt und für Web-Erfassungsstation:

Im Modus Einfach sind menschliche Operatoren einbezogen. In diesem Modus können separate Phasen für Neuscannen, Datenüberprüfung, Dokumentzusammenstellungsprüfung, Überprüfung, Stapelintegritätsprüfung und Exportbestätigung verwendet werden. Für die Phasen Datenüberprüfung, Dokumentzusammenstellungsprüfung, Überprüfung, Stapelintegritätsprüfung und Exportbestätigung können auch Webstationen verwendet werden. Dokumente (oder ganze Stapel) können diese Arbeitsgänge entweder automatisch durchlaufen (wenn keine Fehler auftreten) oder nach Prüfung und Korrektur durch einen Operator. Sollte ein Fehler auftreten, wird das Dokument zur Phase Ausnahmen gesendet. Auch ein Operator kann Dokumente in die Ausnahmen-Phase einreihen.

Im Modus Erweitert können komplexe Workflow-Schemas konfiguriert werden. In diesem Modus können die Einstellungen der Basisphasen geändert sowie benutzerdefinierte Phasen erstellt und in das Verarbeitungsschema integriert werden. Sie können außerdem die Doppelüberprüfung aktivieren, womit Dokumente durch zwei verschiedene Operatoren in der Datenüberprüfungsstation überprüft werden. In diesem Modus können Sie außerdem Skripte zur Verarbeitung von Dokumenten oder gesamten Stapeln verwenden.

Im Modus Unbeaufsichtigt laufen Verarbeitung und Export von Dokumenten ohne Zutun eines Operators ab. Falls ein Fehler auftritt, kann das betreffende Bild in einem speziellen über die Registerkarte Export festgelegten Ordner gespeichert werden. Erfolgreich verarbeitete Dokumente werden automatisch exportiert. Im Modus Unbeaufsichtigt werden Stapel als Ganzes verarbeitet.

In für Web-Erfassungsstation können Sie die Bedingung angeben, unter der Dokumente zur Überprüfung gesendet werden. Dieser Modus gilt für alle Dokumente, die in der Web-Erfassungsstation verarbeitet werden.

Die Verarbeitungsreihenfolge wird für jeden Stapeltyp einzeln festgelegt. Neu erstellten Stapeln wird ein Typ zugewiesen, der über die Verarbeitungsreihenfolge entscheidet.

Falls keine Stapeltypen erstellt werden, werden alle Stapel mit den für das gesamte Projekt festgelegten <default>-Einstellungen verarbeitet.


Menü der Datenüberprüfungsstation

Collapsed Datei
Menü | Beschreibung
Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Recent Projects | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture
Collapsed Ansicht
Menü | Beschreibung
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Collapsed Tasks
Menü | Beschreibung
Task abrufen | Ruft einen Task aus der ausgewählten Warteschlange ab
Taskkommentar anzeigen | Zeigt Kommentare zu dem Task an
Task ablehnen | Weist den aktuellen Task ab und gibt ihn an den Anwendungsserver zurück
Task zu Ausnahmen senden… | Sendet den aktuellen Task an die Ausnahmen
Automatischer Taskempfang | Aktiviert/deaktiviert den automatischen Taskempfangsmodus
Collapsed Extras
Menü | Beschreibung
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit einer kurzen Beschreibung des Programms.


Symbolleisten der Datenüberprüfungsstation

Collapsed Warteschlangen und Tasks

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Öffnet einen Task aus der ausgewählten Warteschlange
Task ablehnen |  | Weist den Task ab (er wird später vom Server an einen anderen Operator gesendet).
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Automatischer Taskempfang |  | Aktiviert/deaktiviert den automatischen Taskempfangsmodus.


Hauptfenster der Datenüberprüfungsstation

Datenüberprüfungsstation

Das Hauptfenster des Programms zeigt die Namen der Warteschlangen, aus denen die Tasks stammen (Warteschlangen für die Datenüberprüfung).

Nachdem Sie einen Task erhalten haben, werden nacheinander die Überprüfungsfenster Gruppe und Feld geöffnet.

Das Hauptmenü mit den darunter liegenden Symbolleisten befindet sich am oberen Rand des Fensters.

Die Statusleiste befindet sich am unteren Rand des Fensters. Die Statusleiste zeigt den Status des Programms und die Operationen, die gerade durchgeführt werden. Wenn Sie den Mauszeiger auf einem Menübefehl oder einer Schaltfläche positionieren, zeigt die Statusleiste eine kurze Beschreibung dazu an.

Menü der Datenüberprüfungsstation
Symbolleisten der Datenüberprüfungsstation


Menü der Projektkonfigurationsstation

Collapsed Datei
Menü | Beschreibung
Neues Projekt… | Erstellt ein neues Projekt
Projekt öffnen… | Öffnet ein vorhandenes Projekt
Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert die Änderungen
Neuer Stapel… | Erstellt einen neuen Stapel
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt gescannte Bilder hinzu
Bilder importieren… | Importiert Bilder mit einem der konfigurierten Importprofile
Exportieren in |
Daten in Dateien… | Exportiert die Daten in eine Datei
Bilder in Dateien… | Exportiert Bilder in Dateien
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzliche Projekte | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture
Collapsed Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Verbinden | Verbindet die ausgewählten Seiten zu einem Dokument
Teilen | Teilt das ausgewählte Dokument in Seiten auf
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht den vorgegebenen Text
Weitersuchen | Sucht den nächsten zuvor angegebenen Text
Gehe zu |
Nächstes Dokument | Geht zum nächsten Dokument im Stapel
Vorheriges Dokument | Geht zum vorherigen Dokument im Stapel
Bild |
Störungen entfernen | Entfernt Flecken im Bild
Invertieren | Invertiert das Bild
Horizontal spiegeln | Spiegelt das Bild horizontal (in Bezug auf die vertikale Achse)
Vertikal spiegeln | Spiegelt das Bild vertikal (in Bezug auf die horizontale Achse)
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern… | Ändert die Auflösung des Bilds
Speichern unter… | Speichert das Bild unter dem angegebenen Namen
Collapsed Ansicht
Menü | Beschreibung
Teststapel | Öffnet die Liste der Teststapel
Arbeitsstapel | Öffnet die Liste der Stapel
Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Dokumentbilder als Miniaturansichten an
Spalten auswählen… | Ermöglicht die Konfiguration der Liste von Spalten, die in der Detailansicht angezeigt werden
Dokumenteditor |
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Positionierung des Bilds im Dokumentfenster
Fehlerfenster | Ermöglicht die Positionierung des Fehlerfensters im Dokumentfenster
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Datentextanzeige | Ermöglicht die Auswahl der Schriftgröße für die Anzeige erkannter Daten
Symbolleiste anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. Über diese Symbolleiste können Sie einige der Zuordnungsfehler korrigieren, z.B. können Sie ein nicht gefundenes Feld hinzufügen oder eine Tabellentrennlinie hinzufügen bzw. löschen. Diese Funktionen werden im Wesentlichen bei der Arbeit mit FlexiLayouts verwendet.
Formatfehler des aktiven Felds anzeigen | Ermöglicht die Angabe des Anzeigemodus für Formatfehler
Bild schwarz-weiß anzeigen | Zeigt Farb- und Graustufenbilder als Schwarz-Weiß-Bilder an
Miniaturgröße | Ermöglicht die Auswahl der Größe für Miniaturansichten von Seiten
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Eigenschaften… | Öffnet das Dialogfeld für die Dokument- oder Seiteneigenschaften
Collapsed Erkennung
Menü | Beschreibung
Analyse | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
Erkennung | Startet die Erkennung
Collapsed Überprüfung
Menü | Beschreibung
Überprüfung ausführen… | Startet die Überprüfung
Nächstes zu überprüfendes Element | Wechselt zum nächsten Überprüfungsobjekt
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen Überprüfungsobjekt
Nächstes Dokument mit Zusammenstellungsfehler(n) | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriges Dokument mit Zusammenstellungsfehler(n) | Wechselt zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler
Collapsed Projekt
Menü | Beschreibung
Dokumentdefinitionen… | Öffnet das Dialogfeld mit der Liste der Dokumentdefinitionen, in dem Definitionen erstellt, bearbeitet, importiert und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Stapeltypen… | Öffnet das Dialogfeld mit der Liste der Stapeltypen, in dem Stapeltypen erstellt, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Bildimportprofile… | Öffnet das Dialogfeld mit der Liste der Bildimportprofile, in dem Profile erstellt, kopiert, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Mit Kennwort schützen… | Ermöglicht den Schutz des aktuellen Projekts durch ein Passwort (dieses Menü steht nur dem Administrator zur Verfügung)
Kennwortschutz aufheben… | Ermöglicht die Deaktivierung des Passwortschutzes für das Projekt (dieses Menü steht nur dem Administrator zur Verfügung)
Projekt exportieren… | Exportiert das Projekt in den angegebenen Ordner. Bilder werden aus dem aktuellen Projekt genommen.
Projekt aktualisieren… | Konfiguriert die Projektaktualisierung. Meldungen und Fehler, die während des Exports auftreten, können in einer Datei gespeichert werden (klicken Sie mit der rechten Maustaste und wählen Sie "In Datei exportieren").
Projekteigenschaften… | Öffnet das Dialogfeld für die Projekteigenschaften
Collapsed Extras
Menü | Beschreibung
Auf neueste Version aktualisieren | Wendet die Projektänderungen auf die Dokumente an, die gerade verarbeitet werden
Neu analysieren | Wiederholt die Analyse des Dokuments
Neu erkennen | Wiederholt die Erkennung des Dokuments
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung der Seiten zu Dokumenten
Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
Stapelintegritätsprüfung | Prüft die Stapelintegrität
Stapelpriorität ändern | Ermöglicht die Auswahl der Stapelpriorität
Stapeltyp ändern… | Ändert den Stapeltyp
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Technischer Support | Öffnet den Bereich Technischer Support in der Programmhilfe
ABBYY-Produkte erwerben | Öffnet den Bereich ABBYY FlexiCapture erwerben in der Programmhilfe
ABBYY-Website | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit einer kurzen Beschreibung des Programms


Symbolleisten der Projektkonfigurationsstation

Collapsed Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Projekt öffnen |  | Öffnet ein Projekt
Änderungen speichern |  | Speichert die Änderungen
Ausschneiden |  | Bei der Arbeit mit Daten im Dokumentbild: schneidet das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt in die Zwischenablage
Einfügen |  | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen |  | Löscht das ausgewählte Objekt
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Collapsed Dokumentansicht

Funktion | Schaltfläche | Beschreibung
Detailansicht |  | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansicht |  | Zeigt die Dokumentseiten als Miniaturansichten an
Liste der Teststapel |  | Zeigt die Liste der Teststapel
Liste der Arbeitsstapel |  | Zeigt die Liste der Arbeitsstapel
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Collapsed Navigation

Funktion | Schaltfläche | Beschreibung
Vorheriges zu überprüfendes Element |  | Geht zum vorherigen Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element |  | Geht zum nächsten Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument |  | Wechselt zum vorherigen Dokument.
Nächstes Dokument |  | Wechselt zum nächsten Dokument.
Collapsed Projektkonfiguration

Funktion | Schaltfläche | Beschreibung
Dokumentdefinitionen… |  | Öffnet das Fenster mit der Liste der Dokumentdefinitionen im Projekt.
Stapeltypen… |  | Öffnet das Fenster mit der Liste der Stapeltypen im Projekt.
Projekteigenschaften… |  | Öffnet das Fenster für die Projekteigenschaften.
Bildimportprofil zeigen |  | Öffnet das Fenster mit der Liste der Bildimportprofile im Projekt.
Projekt auf Server hochladen… |  | Öffnet das Fenster zum Hochladen des Projekts auf den Anwendungsserver.


Fenster der Projektkonfigurationsstation

Das Hauptfenster der Projektkonfigurationsstation enthält eine Liste der Dokumentstapel des aktuellen Projekts. Standardmäßig werden bis auf die verarbeiteten Stapel alle Stapel angezeigt.

Filtern von Stapeln

Sie können die Stapel der Projekte, die auf dem Verarbeitungsserver gespeichert sind, filtern. Dazu wählen Sie einen Filter in der Dropdownliste Anzeigen und geben die Filtereinstellungen ein.

  • Alle Stapel mit Ausnahme des verarbeiteten;
  • Stapel in Phasen…
    Filtert Stapel nach Verarbeitungsphasen.
  • Stapel mit Namenspräfix…
    Filtert Stapel nach dem Präfix ihrer Namen.
  • Stapel mit ID…
    Filtert Stapel nach ihrer ID.
  • Stapel enthält Dokument mit ID…
    Filtert Stapel nach der ID der Dokumente, die sie enthalten.
  • Erstellte Stapel im Zeitraum…
    Filtert Stapel nach dem Zeitraum ihrer Erstellung. Daten vor 01/02/1753 und nach 31/12/2100 sind nicht erlaubt.
  • Stapel mit Stapeltyp…
    Filtert Stapel nach ihrem Typ.
  • Stapel mit bestimmten Registrierungsparametern…
    Filtert Stapel nach dem Namen und dem Wert des Registrierungsparameters. Der Filter kann bis zu drei Parameter enthalten.
    Collapsed Tipp

    Sie können den Namen und den Wert eines Registrierungsparameters manuell eingeben oder aus der Dropdownliste Parameter auswählen. Die Liste enthält die Registrierungsparameter aller Stapeltypen und die letzten zehn Parameternamen, die Sie eingegeben haben. Die Dropdownliste Wert enthält zehn Registrierungsparameter, die vom Benutzer eingegeben wurden.

  • Stapel gefiltert nach…
    Erweiterte Suche nach Namenspräfixen der Stapel, Stapeltypen, Erstellungsdatumsangaben, Registrierungsparameter und Phasen.

Ist ein Filter aktiviert wird neben der Dropdownliste Anzeigen eine kurze Zusammenfassung der Einstellungen angezeigt. Klicken Sie auf die Schaltfläche [image], um die gegenwärtig verwendeten Filtereinstellungen zu ändern.

Das Stapelfenster

Auf dem oberen Teil des Fensters werden die Menüleiste und die Symbolleiste angezeigt. Der untere Teil enthält die Statusleiste, auf der Meldungen über den Status des Programms und die von ihm ausgeführten Operationen sowie kurze Beschreibungen der ausgewählten Menüelemente und Schaltflächen anzeigt werden.

Den Rest des Fenster belegt der Detailbereich des Fensters Stapel, der eine Liste der Stapel enthält.

Collapsed Screenshot des Hauptfensters mit der Stapelliste

Eine Seite kann bis zu 500 Stapel enthalten. Verwenden Sie die Pfeilschaltflächen auf der rechten Seite, um in den Seiten zu blättern.

Doppelklicken Sie auf einen Stapel, um die darin enthaltenen Dokumente anzuzeigen.

Collapsed Screenshot des Hauptfensters mit einer Dokumentenliste eines geöffneten Stapels

Um zu Stapelliste zurückzukehren, klicken Sie auf Ansicht > Arbeitsstapel (oder auf Teststapel, wenn Sie mit Teststapeln arbeiten).

Das Dokumentfenster

TBeginnen Sie die Überprüfung der Daten, indem Sie das Fenster Dokument öffnen. Doppelklicken Sie dazu auf den Namen des Dokuments oder eine seiner Seiten. Das Fenster ist in drei Bereiche aufgeteilt:

  • ein Fenster enthält das Bild des Dokuments,
  • ein Fenster die erkannten Informationen und
  • ein Fenster die Regelfehler (dieses Fenster wird nur angezeigt, wenn Regelfehler vorliegen)
Collapsed Screenshot des Dokumentfensters

Wenn Sie den Mauszeiger auf einem Feld positionieren, das ein Datum oder eine Nummer enthält, wird ein Tooltipp angezeigt. Das Datumsformat des Tooltipps hängt von den regionalen Einstellungen auf Ihrem Computer ab. Das Datumsformat im Feld und das Datumsformat im Tooltipp können unterschiedlich sein. Der Tooltipp zeigt auch entsprechend Ihrer Zeitzone die Zeit an, zu der das Formular ausgefüllt wurde.

Weitere Informationen finden Sie unter Überprüfung im Dokumentfenster.

Kopieren und Verschieben von Dokumenten

Dokumente können kopiert und von einem Stapel in einen anderen verschoben werden. Wurde das Dokument kopiert oder verschoben, bleiben alle Informationen über das Dokument einschließlich der angewandten Dokumentdefinition und aller erkannten Daten erhalten. Wenn Sie Dokumente verschieben möchten (zum Beispiel aus einem regulären Stapel in einen Teststapel, um ein Training durchzuführen), wählen Sie die Dokumente in der Dokumentenliste aus und drücken Sie Strg+C, um sie zu kopieren, und Strg+X, um sie auszuschneiden. Sie können dazu auch die Schaltflächen [image] und [image] verwenden sowie die Befehle Kopieren und Ausschneiden im Menü Bearbeiten. Öffnen Sie anschließend den Stapel, von dem Sie Dokumente kopieren möchten, und drücken Sie Strg+V, klicken Sie auf die Schaltfläche [image] oder wählen Sie Bearbeiten > Einfügen, um zu kopieren.

Menü der Projektkonfigurationsstation
Symbolleisten der Projektkonfigurationsstation


Menü der Überprüfungsstation

Collapsed Datei
Menü | Beschreibung
Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert die Änderungen
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt gescannte Bilder hinzu
Exportieren in |
Daten in Dateien… | Exportiert die Daten in eine Datei
Bilder in Dateien… | Exportiert Bilder in Dateien
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzliche Projekte | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture
Collapsed Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Verbinden | Verbindet die ausgewählten Seiten zu einem Dokument
Teilen | Teilt das ausgewählte Dokument in Seiten auf
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht vorgegebenen Text
Weitersuchen | Sucht den nächsten zuvor angegebenen Text
Gehe zu |
Nächstes Dokument | Geht zum nächsten Dokument im Stapel
Vorheriges Dokument | Geht zum vorherigen Dokument im Stapel
Bild |
Störungen entfernen | Entfernt Flecken im Bild
Invertieren | Invertiert das Bild
Horizontal spiegeln | Spiegelt das Bild horizontal (in Bezug auf die vertikale Achse)
Vertikal spiegeln | Spiegelt das Bild vertikal (in Bezug auf die horizontale Achse)
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern… | Ändert die Auflösung des Bilds
Speichern unter… | Speichert das Bild unter dem angegebenen Namen
Collapsed Ansicht
Menü | Beschreibung
Arbeitsstapel | Öffnet die Liste der Stapel
Warteschlangen | Öffnet die Liste der Warteschlangen
Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Dokumentbilder als Miniaturansichten an
Spalten auswählen… | Ermöglicht die Konfiguration der Liste von Spalten, die in der Detailansicht angezeigt werden
Dokumenteditor |
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Positionierung des Bilds im Dokumentfenster
Fehlerfenster | Ermöglicht die Positionierung des Fehlerfensters im Dokumentfenster
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Datentextanzeige | Ermöglicht die Auswahl der Schriftgröße für die Anzeige erkannter Daten
Symbolleiste anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. Über diese Symbolleiste können Sie einige der Zuordnungsfehler korrigieren, z.B. können Sie ein nicht gefundenes Feld hinzufügen oder eine Tabellentrennlinie hinzufügen bzw. löschen. Diese Funktionen werden im Wesentlichen bei der Arbeit mit FlexiLayouts verwendet.
Formatfehler des aktiven Felds anzeigen | Ermöglicht die Angabe des Anzeigemodus für Formatfehler
Bild schwarz-weiß anzeigen | Zeigt Farb- und Graustufenbilder als Schwarz-Weiß-Bilder an
Miniaturgröße | Ermöglicht die Auswahl der Größe für Miniaturansichten von Seiten
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Collapsed Erkennung
Menü | Beschreibung
Analyse | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
Erkennung | Startet die Erkennung
Collapsed Tasks
Menü | Beschreibung
Task abrufen | Ruft einen Task aus der ausgewählten Warteschlange ab
Task schließen | Schließt den aktuellen Task und gibt ihn an den Anwendungsserver als beendet zurück
Taskkommentar anzeigen | Zeigt Kommentare zu dem Task an
Task ablehnen | Weist den aktuellen Task ab und gibt ihn an den Anwendungsserver zurück
Task aufschieben… | Verschiebt die Verarbeitung des aktuellen Tasks auf später
Senden an |
Ausnahme... | Sendet den aktuellen Task an die Phase Ausnahmen
Re-scan... | Sendet den aktuellen Task an die Phase Re-scan
Phase... | Sendet den aktuellen Task an eine ausgewählte Phase. Das Senden von Dokumenten an andere Phasen als Ausnahmen und Re-scan ist nur für den Rollentyp des leitenden Überprüfungsoperators verfügbar.
Dokumente markieren für Senden an |
Exception... | Markiert ausgewählte Dokumente für das Senden zur Phase Ausnahmen. Beim Schließen des Tasks werden die markierten Dokumente zur Phase gesendet.
Re-scan... | Markiert ausgewählte Dokumente für das Senden zur Phase Re-scan. Beim Schließen des Tasks werden die markierten Dokumente zur Phase gesendet.
Phase... | Markiert ausgewählte Dokumente für das Senden zu einer ausgewählten Phase. Beim Schließen des Tasks werden die markierten Dokumente zur Phase gesendet. Das Senden von Dokumenten an andere Phasen als Ausnahmen und Re-scan ist nur für den Rollentyp des leitenden Überprüfungsoperators verfügbar.
Dokumente zu Markiert hinzufügen… | Fügt Dokumente zu bereits markierten Dokumenten hinzu. Wählen Sie im dann angezeigten Dialogfeld die gewünschte Phase aus der Liste früher ausgewählter Phasen.
Sendemarkierung löschen | Löscht ausgewählte Dokumente aus der Liste der zum Senden markierten Dokumente
Senden von Zeichen… | Öffnet das Dialogfeld Senden von Zeichen, in dem Sie die Liste von Zeichen anzeigen, ein Zeichen löschen oder den zugehörigen Kommentar bearbeiten können
Automatischer Taskempfang | Aktiviert/deaktiviert den automatischen Taskempfang
Gesamten Stapel abrufen | Wird dem Operator die Rolle zugewiesen, deren Zugriffsrechte die Bearbeitung von Stapeln ermöglichen, kann der Operator in der Stapelansicht einen geöffneten Stapel bearbeiten. Der Befehl ist dann verfügbar, wenn mindestens ein Dokument aus dem Stapel zum Task gehört. Gehören alle Dokumente zum gleichen Task, wird dieser Task geöffnet. Gehören die Dokumente zu anderen Tasks, wird in der Phase Ausnahmen ein Task für den Stapel erstellt.
Edit document | Wird dem Operator die Rolle zugewiesen, deren Zugriffsrechte die Bearbeitung von Dokumenten ermöglichen, kann der Operator in der Dokumentansicht ein geöffnetes Dokument bearbeiten. Der Befehl ist dann verfügbar, wenn mindestens eines der ausgewählten Dokumente zum Task gehört. Gehören alle ausgewählten Dokumente zum gleichen Task, wird dieser Task geöffnet. Gehören die Dokumente zu anderen Tasks, wird der gesamte Stapel bearbeitet und es wird in der Phase Ausnahmen ein Task für den Stapel erstellt.
Taskeigenschaften… | Öffnet das Dialogfeld Taskeigenschaften, in dem Sie die Taskinformationen anzeigen können: Task-ID, Erstellungszeit, Priorität usw.
Collapsed Überprüfung
Menü | Beschreibung
Überprüfung ausführen… | Startet die Überprüfung
Nächstes zu überprüfendes Element | Wechselt zum nächsten Überprüfungsobjekt
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen Überprüfungsobjekt
Nächstes Dokument mit Zusammenstellungsfehler(n) | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriges Dokument mit Zusammenstellungsfehler(n) | Wechselt zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler
Collapsed Extras
Menü | Beschreibung
Dokumentpriorität ändern | Ermöglicht das Ändern der Priorität gerade verarbeiteter Dokumente. Mögliche Werte: Am niedrigsten, Gering, Normal, Hoch, Am höchsten.
Auf neueste Version aktualisieren | Wendet die Projektänderungen auf die Dokumente an, die gerade verarbeitet werden
Neu analysieren | Wiederholt die Analyse des Dokuments
Neu erkennen | Wiederholt die Erkennung des Dokuments
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung der Seiten zu Dokumenten
Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
Stapelintegritätsprüfung | Prüft die Stapelintegrität
Stapelpriorität ändern | Ermöglicht die Auswahl der Stapelpriorität
Stapeltyp ändern… | Ändert den Stapeltyp
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Collapsed Hilfe
Menü | Beschreibung
Hilfethemen | Öffnet die Hilfedatei von ABBYY FlexiCapture
Technischer Support | Öffnet den Bereich Technischer Support in der Programmhilfe
ABBYY-Produkte erwerben | Öffnet den Bereich ABBYY FlexiCapture erwerben in der Programmhilfe
ABBYY-Website | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info zu ABBYY FlexiCapture | Öffnet das Dialogfeld Über ABBYY FlexiCapture 11 mit einer kurzen Beschreibung des Programms


Symbolleisten der Überprüfungsstation

Collapsed Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Projekt von Server öffnen… |  | Öffnet ein Projekt vom Server.
Änderungen speichern |  | Speichert die Änderungen.
Ausschneiden |  | Schneidet das ausgewählte Objekt bei der Arbeit mit Daten im Dokumentfenster aus.
Kopieren |  | Kopiert das ausgewählte Objekt.
Einfügen |  | Fügt das kopierte Objekt aus der Zwischenablage ein.
Löschen |  | Löscht das ausgewählte Objekt.
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig.
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her.
Collapsed Dokumentansicht

Funktion | Schaltfläche | Beschreibung
Details |  | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an.
Miniaturansichten |  | Zeigt Miniaturansichten der Dokumentbilder.
Teststapel |  | Zeigt die Liste der Teststapel.
Arbeitsstapel |  | Zeigt die Liste der Arbeitsstapel.
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Collapsed Navigation

Extras | Schaltfläche | Beschreibung
Vorheriges zu überprüfendes Element |  | Geht zum vorherigen Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element |  | Geht zum nächsten Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument |  | Wechselt zum vorherigen Dokument.
Nächstes Dokument |  | Wechselt zum nächsten Dokument.
Collapsed Warteschlangen und Tasks

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Öffnet einen Task aus der ausgewählten Warteschlange
Task schließen |  | Gibt den Task zum Server zurück.
Für Senden an Ausnahme markieren |  | Markiert das Dokument für das Senden zu den Ausnahmen (für den leitenden Überprüfungsoperator: zur ausgewählten Verarbeitungsphase) Beim Schließen oder Ablehnen des Tasks werden Sie aufgefordert, die markierten Dokumente zu den Ausnahmen zu senden
Für Senden an Neuscannen markieren |  | Markiert das Dokument für das Senden zum erneuten Scannen. Beim Schließen oder Ablehnen des Tasks werden Sie aufgefordert, die markierten Dokumente zum erneuten Scannen zu senden.
Markierungen von Dokumenten entfernen |  | Entfernt die Markierungen ausgewählter Dokumente für das Senden zu den Ausnahmen oder zum Neuscannen.
Task aufschieben… |  | Schiebt den Task auf
Task ablehnen |  | Bricht den Task ab (er wird vom Server an einen anderen Operator gesendet).
Automatischer Taskempfang |  | Aktiviert/deaktiviert den automatischen Taskabruf.


Überprüfungsstation

Auf dem oberen Teil des Fensters werden die Menüleiste und die Symbolleiste angezeigt. Der untere Teil enthält die Statusleiste, auf der Meldungen über den Status des Programms und die von ihm ausgeführten Operationen sowie kurze Beschreibungen der ausgewählten Menüelemente und Schaltflächen anzeigt werden. Im übrigen Bereich des Hauptfensters wird ein Fenster angezeigt, das entweder eine Warteschlangenliste oder eine Dokumentenliste anzeigt.

Es gibt zwei Ansichten: den Warteschlangenmodus und den Stapelmodus. Der Inhalt des Hauptfensters ändert sich in Abhängigkeit vom gewählten Modus.

Warteschlangen

Das Hauptfenster enthält eine Warteschlangenliste, aus der Sie einen Task für die Verarbeitung auswählen können.

Der Überprüfungsoperator und der leitende Überprüfungsoperator haben Zugriff auf mehrere Taskwarteschlangen

Das Taskfenster enthält folgende Informationen:

Anzahl aller Tasks
Die Anzahl der in der Warteschlange verfügbaren Tasks. Dazu zählen automatisierte Tasks und vom Operator erstellte Tasks.

Höchste Priorität
Die Task mit der höchsten Priorität in der Warteschlange.

Anzahl persönlicher Tasks

Die Anzahl der Task, die dem aktuellen Benutzer zugeordnet sind.

Dokumentenanzahl außerhalb der Verarbeitung
Die Gesamtzahl der Dokumente in allen Tasks, die automatisch generiert wurden.

Anzahl gestalteter Tasks
Die Anzahl der manuell von Operatoren erstellten Tasks, zum Beispiel, wenn Dokumente hinzugefügt wurden, während die Option Task erstellen aktiviert war.

Stapelanzahl außerhalb der Verarbeitung
Die Anzahl der Stapel, die vom Operator ohne Erstellung eines gesonderten Tasks zur Warteschlange hinzugefügt wurden.

Collapsed Das Hauptfenster anzeigen

Eine Liste mit den Dokumenten in einem Task wird angezeigt, wenn ein Task empfangen wird.

Collapsed Zeigt das Hauptfenster mit der Liste der Dokumente

Stapel

IIn diesem Modus enthält das Hauptfenster stapelbezogene Informationen, einschließlich der Anzahl der Dokumente und Seiten in den Stapeln, der Priorität der Stapel, der Menge der erkannten, überprüften und exportierten Zeichen der Stapel.

Standardmäßig werden bis auf die verarbeiteten Stapel alle Stapel angezeigt. Eine Seite kann bis zu 500 Stapel enthalten. Verwenden Sie die Pfeilschaltflächen auf der rechten Seite, um in den Seiten zu blättern.

Filtern von Stapeln

Sie können die Stapel der Projekte, die auf dem Verarbeitungsserver gespeichert sind, filtern. Dazu wählen Sie einen Filter in der Dropdownliste Anzeigen und geben die Filtereinstellungen ein.

  • Alle Stapel mit Ausnahme des verarbeiteten;
  • Stapel in Phasen…
    Filtert Stapel nach Verarbeitungsphasen.
  • Stapel mit Namenspräfix…
    Filtert Stapel nach dem Präfix ihrer Namen.
  • Stapel mit ID…
    Filtert Stapel nach ihrer ID.
  • Stapel enthält Dokument mit ID…
    Filtert Stapel nach der ID der Dokumente, die sie enthalten.
  • Erstellte Stapel im Zeitraum…
    Filtert Stapel nach dem Zeitraum ihrer Erstellung. Daten vor 01/02/1753 und nach 31/12/2100 sind nicht erlaubt.
  • Stapel mit Stapeltyp…
    Filtert Stapel nach ihrem Typ.
  • Stapel mit bestimmten Registrierungsparametern…
    Filtert Stapel nach dem Namen und dem Wert des Registrierungsparameters. Der Filter kann bis zu drei Parameter enthalten.
    Collapsed Tipp

    Sie können den Namen und den Wert eines Registrierungsparameters manuell eingeben oder aus der Dropdownliste Parameter auswählen. Die Liste enthält die Registrierungsparameter aller Stapeltypen und die letzten zehn Parameternamen, die Sie eingegeben haben. Die Dropdownliste Wert enthält zehn Registrierungsparameter, die vom Benutzer eingegeben wurden.

  • Stapel gefiltert nach…
    Erweiterte Suche nach Namenspräfixen der Stapel, Stapeltypen, Erstellungsdatumsangaben, Registrierungsparameter und Phasen.

Ist ein Filter aktiviert wird neben der Dropdownliste Anzeigen eine kurze Zusammenfassung der Einstellungen angezeigt. Klicken Sie auf die Schaltfläche [image], um die gegenwärtig verwendeten Filtereinstellungen zu ändern.

Menü der Überprüfungsstation
Symbolleisten der Überprüfungsstation


Symbolleisten im Fenster für die Feldüberprüfung

Collapsed Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Vorheriges Feld |  | Wechselt zum vorherigen Feld
Nächstes Feld |  | Wechselt zum nächsten Feld
Feld bestätigen/Feld überspringen |  | Bestätigt die korrekte Erkennung aller Zeichen im Feld und wechselt zum nächsten Feld. Wenn der Feldwert nicht dem Feldformat entspricht, ändert sich die Beschriftung der Schaltfläche in Feld überspringen. Wenn der Feldwert nicht korrigiert werden kann, kann das Feld übersprungen oder aufgeschoben werden.
Feld aufschieben |  | Schiebt die Überprüfung des Felds auf, wenn das Feld nicht korrigiert werden kann
Vorheriges nicht eindeutiges Zeichen |  | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes nicht eindeutiges Zeichen |  | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her


Verteilte Überprüfung

Mit der verteilten Überprüfung können Sie den Satz von Feldern beschränken, der in der Phase eine Überprüfung erfordert. Die verteilte Überprüfung kann in der Überprüfungs- und Datenüberprüfungsphase erfolgen. Die Erstellung benutzerdefinierter Verarbeitungsphasen auf Basis dieser Phasen ermöglicht die Verarbeitung unterschiedlicher Dokumentfelder in unterschiedlichen Phasen (die Regel zum Senden von Dokumenten zu einer Phase wird mithilfe eines Scripts) erstellt. Die Liste der in der Phase verfügbaren Felder ist im Dialogfeld Phaseneinstellungen auf der Registerkarte Feld einrichten anzugeben.

Es wird empfohlen, bei Verwendung der verteilten Überprüfung Folgendes zu beachten:

  • Informationen über den Fehler werden nur dann im Fehlerfenster angezeigt, wenn mindestens ein mit dem Fehler im Zusammenhang stehendes Feld in dem Datensatz enthalten ist, der dem Operator zur Verfügung steht. Ist keines der mit dem Fehler verbundenen Felder im Datensatz enthalten, werden dem Operator keine Informationen darüber angezeigt, dass das Dokument Fehler enthält.
  • Sind einige der mit dem Fehler verbundenen Felder nicht im angegebenen Datensatz enthalten, werden im Fehlerfenster zwar Angaben zum Fehler angezeigt, der Operator kann jedoch nicht auf das Feld außerhalb des Datensatzes zugreifen, um den Fehler zu beheben.
  • Wenn Sie in der Phase Datenüberprüfung eine hohe Sicherheitsstufe gewährleisten müssen, wählen Sie die Option Seitenbild außerhalb ausgewählter Felder ausblenden. Wird diese Option ausgewählt, stehen dem Operator nur Felder aus der angegebenen Datengruppe zur Verfügung. Alle anderen Felder werden ausgeblendet.

    Hinweis: Ist diese Option ausgewählt, wurde der Feldbereich jedoch während der Zuordnung einer Dokumentdefinition falsch oder mit einer Verschiebung erkannt, kann die Überprüfung des Feldes durch den Operator fehlschlagen. In diesem Fall sollte der Operator das Bild an die Phase Ausnahmen senden.


Doppelüberprüfung

Doppelüberprüfung ist ein Datenüberprüfungsmodus, bei dem Felder durch zwei verschiedene Operatoren überprüft werden.

So wird die Doppelüberprüfung aktiviert:

  1. Wählen Sie in den Feldeigenschaften die Option Erfordert doppelte Überprüfung.
  2. Wählen Sie die Option Doppelüberprüfung auf der Registerkarte Feld einrichten im Dialogfeld Phaseneinstellungen.

Die Zusammenführung der Ergebnisse der Doppelüberprüfung wird über den Verarbeitungsserver durchgeführt. Stimmen die Überprüfungsergebnisse überein, wird das Dokument zur nächsten Phase gesendet. Ansonsten wird die Überprüfung manuell durch Entscheidung des Operators ausgeführt.

Die Doppelüberprüfung kann auf der Web-Datenüberprüfungsstation ausgeführt werden.


Workflow

Dokumente werden in mehreren Arbeitsphasen verarbeitet. In der Verarbeitungsphase, die automatisiert oder unter Mitwirkung eines Operators ablaufen kann, werden die Dokumente konvertiert. Die Phasen sind in einer fest vorgegebenen Reihenfolge angeordnet: Bevor ein Dokument eine bestimmte Phase erreicht, muss es alle früheren Phasen erfolgreich durchlaufen haben. Allgemein gesprochen umfasst die Dokumentverarbeitung die folgenden Phasen: Hinzufügen von Bildern, Erkennung, Überprüfung und Export. Die Überprüfungsphase muss nicht unbedingt stattfinden. Die anderen Phasen sind obligatorisch.

In jeder Phase wird eine Taskwarteschlange gebildet, die eine Liste der zu verarbeitenden Dokumente enthält. Im weiteren Verlauf der Verarbeitung wandern die Dokumente von der ersten Warteschlange (Erkennung) bis zur letzten (Export). In der Regel entsprechen die Warteschlangen den Verarbeitungsphasen. Es gibt jedoch auch gesonderte Warteschlangen, z.B. die Ausnahmenwarteschlange.

Phasen

  1. Import von Bildern.

    Die Bilder können automatisch aus Hot Foldern geladen oder vom Operator der Scanstation hinzugefügt werden. Der Scanoperator kann entweder Dokumente einscannen oder die Abbilder bereits gescannter Dokumente importieren. Zur Automatisierung dieses Vorgangs kann der Scanoperator Scanprofile erstellen (Hinzufügen der Bilder mit vordefinierten Einstellungen mit nur einem Mausklick).

  2. Erkennung. Die Erkennungswarteschlange wird automatisch von der Verarbeitungsstation abgearbeitet.

  3. Überprüfung. Die Überprüfungswarteschlange wird vom Operator der Verifizierungsstation abgearbeitet.

  4. Export. Die Exportwarteschlange wird automatisch von der Verarbeitungsstation abgearbeitet.

Wenn große Mengen verarbeitet werden müssen, kann der Überprüfungsschritt in kleinere Schritte unterteilt werden. Jeder Schritt wird dann von seinem eigenen Operator ausgeführt.

Die folgenden separaten Warteschlangen können erstellt werden:

  • Überprüfen der Dokumentzusammenstellung
  • Datenüberprüfung: Gruppen- und Feldüberprüfung uneindeutiger Zeichen und Korrektur von Formatierungsfehlern
  • Verifizierung: Prüfung von Regeln und Dokumentfenstern
  • Stapelintegritätsprüfung
  • Exportbestätigung

Hinweis: Die Warteschlangen werden für jeden Stapeltyp einzeln festgelegt.

Die Tasks aus den Warteschlangen werden von den Operatoren abgearbeitet, die über die notwendigen Zugriffsrechte verfügen:

  • Datenüberprüfungsoperator – nur die Datenüberprüfungswarteschlange
  • Überprüfungsoperator – Datenüberprüfung, Verifizierung, Prüfung der Dokumentzusammenstellung, Stapelintegritätsprüfung
  • Leitender Überprüfungsoperator – alle Warteschlangen

Hinweis: Die Datenverifizierungsstation lässt ihre Operatoren nur die Tasks aus der Datenüberprüfungswarteschlange bearbeiten, unabhängig von den Rechten des jeweiligen Operators.


Verbieten, dass Dokumente von einer Phase zu einer anderen als der festgelegten Phase gesandt werden

Dieser Abschnitt beschreibt, wie Sie Rollen benutzen können, um zu verhindern, dass ein Operator Dokumente von Phase A zu anderen Phasen als B schickt.

Collapsed Wenn Phase B "Ausnahmen" ist

Möchten Sie erlauben, dass ein Operator Dokumente in die Phase Ausnahmen schickt, nehmen Sie diese Phase einfach in das Routing-Schema auf der Registerkarte Workflow des Dialogfeldes Projekteigenschaften auf (wählen Sie Projekt>Projekteigenschaften…) oder wählen Sie auf der Registerkarte Workflow des Dialogfeldes Stapeltypeigenschaften (wählen Sie Projekt>Stapeltypen… den gewünschten Stapeltyp und klicken Sie auf Bearbeiten…).

Collapsed Wenn Phase B "Re-scan" ist

Benutzen Sie das Routing-Schema Erweitert. Öffnen Sie als erstes die Eigenschaften der Phase A und wählen Sie das Element, das es erlaubt, Dokumente an die Phase Re-scan zu senden:

  1. Bei Stapeln vom Typ Standard wählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Klicken Sie auf die Registerkarte Workflow.
  3. Im Feld Schema wählen Sie Erweitert.

  4. Wählen Sie aus der Liste die Phase, aus der Dokumente versendet werden sollen.

  5. Klicken Sie auf Bearbeiten….
  6. Klicken Sie im Dialogfeld Eigenschaften von Workflow-Phasen auf die Registerkarte Exit-Routen.
  7. Wählen Sie das Element Dem Operator das Senden von Tasks für das Neuscannen erlauben.

  8. Klicken Sie auf OK, um die Änderungen zu speichern.

Jetzt müssen Sie verbieten, dass ein Operator Dokumente an irgendeine Phase versendet. Erzeugen Sie eine entsprechende Phase und ordnen Sie diese dem Operator in der Verwaltungs- und Überwachungskonsole zu:

  1. Wählen Sie Projekt>Projekteigenschaften…
  2. Klicken Sie auf die Registerkarte Benutzerrollen.
  3. Klicken Sie auf Neu…
  4. Geben Sie in dem entsprechenden Feld einen Namen für die Rolle ein..
  5. Löschen Sie das Element Tasks an eine verfügbare Phase senden. Löschen oder wählen Sie weitere Elemente, je nachdem, welche Rechte Sie dem Operator gewähren möchten.
  6. Klicken Sie auf OK, um die Änderungen zu speichern .

  7. Weisen Sie die Rolle dem Operator für den entsprechenden Stapeltyp in der Verwaltungs- und Überwachungskonsole zu.

Collapsed Wenn Phase B weder "Ausnahmen" noch "Re-scan" ist

In diesem Fall müssen Sie eine Rolle ohne Berechtigungen für einen Versand von Dokumenten an irgendeine Phase erzeugen. Danach erlauben Sie in den Eigenschaften der Phase A ausdrücklich, dass der Operator Dokumente an Phase B senden darf.

Möchten Sie dem Operator verbieten, Dokumente an irgendeine Phase zu senden, erzeugen Sie eine entsprechende Rolle und weisen Sie sie dem Operator in der Verwaltungs- und Überwachungskonsole zu:

  1. Wählen Sie Projekt>Projekteigenschaften…
  2. Klicken Sie auf die Registerkarte Benutzerrollen.
  3. Klicken Sie auf Neu…

  4. Geben Sie in dem entsprechenden Feld einen Namen für die Rolle ein.

  5. Löschen Sie das Element Tasks an eine verfügbare Phase senden. Löschen oder wählen Sie weitere Elemente, je nachdem, welche Rechte Sie dem Operator gewähren möchten.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.

  7. Weisen Sie die Rolle dem Operator für den entsprechenden Stapeltyp in der Verwaltungs- und Überwachungskonsole zu.

So lassen Sie zu, dass der Operator Dokumente an Phase B sendet:

  1. Bei Stapeln vom Typ Standard wählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Klicken Sie auf die Registerkarte Workflow.
  3. Im Feld Schema wählen Sie Erweitert.

  4. Wählen Sie aus der Liste die Phase A, von der Dokumente versendet werden sollen.

  5. Klicken Sie auf Bearbeiten…
  6. Klicken Sie im Dialogfeld Eigenschaften von Workflow-Phasen auf die Registerkarte Exit-Routen.
  7. Fügen Sie die Phase hinzu, indem Sie auf die Schaltfläche Phase… klicken, oder wählen Sie den Namen der Phase aus der Liste und klicken Sie auf Bearbeiten…
  8. Im Dialogfeld Nächste Phase wählen Sie das Element Dem Operator das Senden von Tasks zu dieser Phase erlauben.

  9. Klicken Sie auf OK, um die Änderungen an den Sendeoptionen zu speichern.

  10. Klicken Sie auf OK, um die Änderungen an Phase A zu speichern.

Hinweis: Wird die Option Task erstellen nicht gewählt, wenn ein Dokument vom Operator versandt wird, werden die Bedingungen für den Eintritt in Phase B überprüft. Sind diese Bedingungen nicht erfüllt, wird das Dokument an die Phase gesandt, die im Routing-Schema auf Phase A folgt.


Benutzerdefinierte Operatorrollen

Außer den im System vorhanden Standard-Operatorrollen (d. h. Datenüberprüfungsoperator, Überprüfungsoperator, Leitender Überprüfungsoperator) können Sie eigene benutzerdefinierte Rollen erzeugen, die den Zugang der Operatoren zu Daten und Warteschlangen in den Verarbeitungsphasen steuern.

Sind beispielsweise an einem Projekt viele Benutzer beteiligt, können Sie benutzerdefinierte Rollen erzeugen, die es ermöglichen, dass unterschiedliche Benutzergruppen Zugang zu verschiedenen Überprüfungsphasen haben, in denen verschiedene Arten von Feldern für denselben Stapeltyp verifiziert sind. Sie können mit benutzerdefinierten Rollen auch steuern, was die Operatoren tun dürfen und was nicht. Sie können beispielsweise einer Rolle verbieten, Dokumente zu löschen, einer Rolle verbieten, Tasks von einer Phase zu einer anderen zu senden oder, ihr im Gegenteil erlauben, Dokumente nur an eine bestimmte Phase zu senden.

Hinweis: Sie können auch andere Methoden als Rollen wählen, um Operatoren zu verbieten, Tasks an bestimmte Phasen zu schicken. Weitere Informationen dazu finden Sie in diesem Beispiel.

Sie können auf der Registerkarte Benutzerrollendes Dialogfeldes Projekteigenschaften eine neue Rolle erstellen und einrichten (indem Sie Projekt>>Projekteigenschaften…) wählen). Auf dieser Registerkarte eingerichtete Rollen werden dann auf der Verwaltungs- und Überwachungskonsole Operatoren zugewiesen.

Hinweis: Sie können eine neue Rolle erstellen, indem Sie die Eigenschaften einer Phase bearbeiten, zu der diese Rolle Zugang hat. Das erfolgt über die Registerkarte Rollen des Dialogfeldes Eigenschaften von Workflow-Phasen (wählen Sie Projekt>Projekteigenschaften… oder Projekt>Stapeltypen…, wählen Sie dann den Stapeltyp, den Sie ändern möchten, klicken Sie auf die Registerkarte Workflow, und, wenn Sie die Verarbeitungsschemata Erweitert oder Erweitert für Web-Erfassungsstation benutzen, richten Sie eine interaktive Phase ein oder wählen Sie eine vorhandene und klicken Sie auf Bearbeiten…). Sie müssen jedoch noch zur Registerkarte Benutzerrollen gehen und für die so erzeugte Rolle Zugangsrechte festlegen.

Zusätzlich zum Erstellen (Neu…) und Löschen (Löschen) einer Rolle können Sie eine neue Rolle aus einer vorhanden erzeugen (Duplizieren…) oder eine vorhandene Rolle bearbeiten (Bearbeiten…). Wenn Sie auf Bearbeiten… klicken, öffnet sich ein Dialogfeld Rolleneigenschaften.

Hinweis: Sie können die Standard-Operatorrollen (d. h. Datenüberprüfungsoperator, Überprüfungsoperator, Leitender Überprüfungsoperator) nicht ändern.

Sie können im Dialogfeld Rolleneigenschaften die folgenden Zugriffsrechte für eine Rolle festlegen.

  • Die Liste der Phasen, von denen die Rolle Tasks erhalten darf. So legen Sie die Liste der Phasen fest:

    1. Klicken Sie auf Phasen für den Erhalt von Tasks… .
    2. Wählen Sie zweckmäßige Elemente neben den Phasen aus, auf die die Rolle Zugriff haben soll. Möchten Sie den Zugang zu allen Phasen eines bestimmten Stapeltyps freischalten, wählen Sie ein Element neben diesem Stapeltyp. Wenn Sie auf Alle Phasen auswählen/keine wählen klicken, werden alle Stufen ausgewählt bzw. nicht ausgewählt.
    3. Klicken Sie auf OK, um die Änderungen zu speichern und zum Dialogfeld Rolleneigenschaften zurückzukehren.
  • Zugriff auf Datenoperationen.

    Element

    Zugriffsrechte

    Liste der Projektstapel lesen
    • Ansicht der Liste der Stapel.
    Stapel erstellen/löschen
    • Erzeugen und Löschen von Stapeln
    • Arbeiten mit Stapelanhängen
    • Arbeiten mit Stapelregistrierung-Parametern
    • Ändern von Stapeltypen
    Stapelinhalt ändern
    • Arbeiten mit Dokumentanhängen
    • Arbeiten mit Dokument-Registrierungsparametern
    • Hinzufügen / Löschen / Verschieben von Seiten / Dokumenten
    • Ändern von Bildern
    • Speichern von Bildern auf die Festplatte.
    Dokumentlayout ändern
    • Ändern der Definition eines Bereichs / Dokuments, Markieren von Seiten als Anhänge
    • Wechsel des Feldbereichs
    Dokumentinhalt ändern
    • Ändern des Feldinhalts
    • Hinzufügen und Entfernen von Feldinstanzen
    • Bestätigen von Feldern
    • Arbeiten mit Dokument-Registrierungsparametern
    • Starten der Verifizierung (F7)
  • Zugriff auf Operationen an Tasks

    Element

    Zugriffsrechte

    Tasks oder Teiltasks erstellen
    • Senden von Stapeln oder Dokumenten zur Verarbeitungsphase
    Tasks aufschieben
    • Aufschieben eines Tasks
    Liste der Warteschlangentasks lesen
    • Anzeigen der Taskwarteschlage in der Verarbeitungsphase, auf die die Rolle Zugriff hat, Abrufen von Tasks daraus

    Hinweis: Wenn der Rolle dieser Zugriff gewährt wird, darf der Benutzer unabhängig von weiteren Berechtigungen Tasks handhaben, welche die Datenüberprüfungsstation benutzen

    Tasks an eine verfügbare Phase senden
    • Senden von Tasks / Teiltasks zu jeder Verarbeitungsphase, auf die die Rolle für den betreffenden Stapeltyp Zugriff hat

    Hinweis: Wird das Element gelöscht, kann der Operator Tasks nur an die Warteschlagen für Ausnahmen und Re-scan (wenn die Einstellungen dies erlauben) und an alle interaktiven Phasen schicken, die vom Routing-Schema erlaubt werden.

    Verarbeitungspriorität ändern
    • Ändern der Priorität einer Task / eines Dokumentes / eines Stapels

Eine Rolle begrenzt den Satz der Verarbeitungsphasen, aus denen ihre Operatoren Tasks erhalten. Aus diesem Grunde können Sie auch einer bestimmten Verarbeitungsphase Zugriffsrechte gewähren, und zwar über die Registerkarte Rollen des Dialogfeldes Eigenschaften von Workflow-Phasen:

  1. Bei Stapeln vom Typ Standard wählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Gehen Sie zur Registerkarte Workflow.
  3. wenn Sie die Verarbeitungsschemata Erweitert oder Erweitert für Web-Erfassungsstation benutzen, erstellen Sie eine interaktive Phase oder wählen Sie eine vorhandene Phase und klicken Sie auf Bearbeiten…
  4. Klicken Sie im Dialogfeld Eigenschaften von Workflow-Phasen auf die Registerkarte Rollen.

  5. Wählen Sie die entsprechenden Elemente für die Rollen aus, die Zugriff auf die betreffende Verarbeitungsphase erhalten werden.

  6. Müssen sie eine neue Rolle hinzufügen, klicken Sie auf Neue Rolle…, geben Sie der neuen Rolle einen Namen und klicken Sie auf OK.

    Hinweis: Um für die so erzeugte Rolle weitere Zugangsrechte festzulegen, müssen Sie noch die Registerkarte Benutzerrollen aufrufen.

Beispiele:

Verbieten, dass Dokumente zu einer Verarbeitungsphase gesandt werden

Verbieten, dass Dokumente von einer Verarbeitungsphase zu einer anderen gesandt werden

Verbieten, dass Dokumente von einer Phase zu einer anderen als der festgelegten Phase gesandt werden


Verbieten, dass Dokumente von einer Verarbeitungsphase zu einer anderen gesandt werden

Dieser Abschnitt beschreibt, wie Sie Rollen benutzen können, um zu verhindern, dass ein Operator Dokumente von Phase A zu Phase B sendet.

Collapsed Wenn Phase B "Ausnahmen" ist

Der einzige Weg zu verbieten, dass ein Operator Dokumente zur die Phase Ausnahmen schickt, besteht darin, diese Phase vollständig aus dem Routing-Schema auf der Registerkarte Workflow des Dialogfeldes Projekteigenschaften auszuschließen (wählen Sie Projekt>Projekteigenschaften…) oder wählen Sie auf der Registerkarte Workflow des Dialogfeldes Stapeltypeigenschaften (wählen Sie Projekt>Stapeltypen… den gewünschten Stapeltyp und klicken Sie auf Bearbeiten…).

Collapsed Wenn Phase B "Re-scan" ist

Benutzen Sie das Routing-Schema Erweitert. Öffnen Sie zunächst die Eigenschaften der Phase A und löschen Sie das Element, das es erlaubt, Dokumente an die Phase Re-Scan zu schicken: Danach erzeugen Sie eine neue Rolle ohne Berechtigungen für das Senden von Dokumenten an eine Phase. Schließlich ordnen Sie diese Rolle dem Operator der Verwaltungs- und Überwachungskonsole zu.

Verbieten, dass Dokumente zur Phase Re-Scan gesandt werden:

  1. Bei Stapeln vom Typ Standard wählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Klicken Sie auf die Registerkarte Workflow.
  3. Im Feld Schema wählen Sie Erweitert.

  4. Wählen Sie aus der Liste die Phase, aus der Dokumente nicht versendet werden dürfen.

  5. Klicken Sie auf Bearbeiten….
  6. Klicken Sie im Dialogfeld Eigenschaften von Workflow-Phasen auf die Registerkarte Exit-Routen.
  7. Löschen Sie das Element Dem Operator das Senden von Tasks für das Neuscannen erlauben.

  8. Klicken Sie auf OK, um die Änderungen zu speichern.

Jetzt müssen Sie verbieten, dass ein Operator Dokumente an irgendeine Phase versendet. Erzeugen Sie eine entsprechende Phase und ordnen Sie diese dem Operator in der Verwaltungs- und Überwachungskonsole zu:

  1. Wählen Sie Projekt>Projekteigenschaften…
  2. Klicken Sie auf die Registerkarte Benutzerrollen.
  3. Klicken Sie auf Neu…

  4. Geben Sie in dem entsprechenden Feld einen Namen für die Rolle ein.

  5. Löschen Sie das Element Tasks an eine verfügbare Phase senden. Löschen oder wählen Sie weitere Elemente, je nachdem, welche Rechte Sie dem Operator gewähren möchten.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.

  7. Weisen Sie die Rolle dem Operator für den entsprechenden Stapeltyp in der Verwaltungs- und Überwachungskonsole zu.

Collapsed Wenn Phase B weder "Ausnahmen" noch "Re-scan" ist

In diesem Fall müssen Sie eine Rolle ohne Berechtigungen für einen Versand von Dokumenten an irgendeine Phase erzeugen. Danach verbieten Sie in den Eigenschaften der Phase A ausdrücklich, dass der Operator Dokumente an Phase B schickt. Das kann dadurch erreicht werden, dass Sie entweder Phase B von den erlaubten Adressen löschen oder indem Sie zulassen, dass die Dokumente im automatischen, aber nicht im manuellen Modus versandt werden.

Möchten Sie dem Operator verbieten, Dokumente an irgendeine Phase zu senden, erzeugen Sie eine entsprechende Rolle und weisen Sie sie dem Operator in der Verwaltungs- und Überwachungskonsole zu:

  1. Wählen Sie Projekt>Projekteigenschaften…
  2. Klicken Sie auf die Registerkarte Benutzerrollen.
  3. Klicken Sie auf Neu…

  4. Geben Sie in dem entsprechenden Feld einen Namen für die Rolle ein.

  5. Löschen Sie das Element Tasks an eine verfügbare Phase senden. Löschen oder wählen Sie weitere Elemente, je nachdem, welche Rechte Sie dem Operator gewähren möchten.

  6. Klicken Sie auf OK, um die Änderungen zu speichern.

  7. Weisen Sie die Rolle dem Operator für den entsprechenden Stapeltyp in der Verwaltungs- und Überwachungskonsole zu.

So verbieten Sie, dass der Operator Dokumente an Phase B sendet:

  1. Bei Stapeln vom Typ Standard wählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Klicken Sie auf die Registerkarte Workflow.
  3. Im Feld Schema wählen Sie Erweitert.

  4. Wählen Sie aus der Liste die Phase A, aus der Dokumente nicht versendet werden dürfen.

  5. Klicken Sie auf Bearbeiten….
  6. Klicken Sie im Dialogfeld Eigenschaften von Workflow-Phasen auf die Registerkarte Exit-Routen.
  7. Um vollständig zu verbieten, dass der Operator Dokumente an Phase B schickt, deaktivieren Sie diese Phase, indem Sie auf das Element neben der Phase klicken oder die Phase entfernen, indem Sie sie aus der Liste auswählen und auf Löschen klicken.

  8. Wenn Sie dem Operator verbieten müssen, Dokumente zu versenden, dem System aber erlauben müssen, Dokumente automatisch zu versenden:

    1. Wählen Sie den Namen der Phase aus der Liste aus.

    2. Klicken Sie auf Bearbeiten….
    3. Löschen Sie im Dialogfeld Nächste Phase das Element Dem Operator das Senden von Tasks zu dieser Phase erlauben.

    4. Klicken Sie auf OK, um die Änderungen an den Sendeoptionen zu speichern.

  9. Klicken Sie auf OK, um die Änderungen an Phase A zu speichern.


Verbieten, dass Dokumente zu einer Verarbeitungsphase gesandt werden

Sie können einem Operator verbieten, Dokumente an eine Verarbeitungsphase zu senden, ohne auf Rollen zurückzugreifen. Wählen Sie für die Verarbeitungsphase einfach das Element Verlinkt mit vorherigen (Operatoren wird es nicht möglich sein, Tasks manuell zu dieser Phase zu senden)aus. Sie haben die Möglichkeit, dieses Element für Phasen auszuwählen, für die eine Vorverarbeitung erforderlich ist. Sie können einem Operator nicht verbieten, Dokumente an die Phasen Ausnahmen und Verarbeitet zu schicken. Daher ist dieses Element für diese Phasen nicht verfügbar.

So verbieten Sie einem Operator, Dokumente an eine Verarbeitungsphase zu senden:

  1. Bei Stapeln vom Typ Standardwählen Sie Projekt>Projekteigenschaften… Bei anderen Stapeltypen:
    • Wählen Sie Projekt>Stapeltypen…

    • Wählen Sie den Stapeltyp aus, für den Sie den Zugriff gewähren oder verbieten möchten

    • Klicken Sie auf Bearbeiten…
  2. Klicken Sie auf die Registerkarte Workflow.
  3. Nutzen Sie das Verarbeitungsschema Erweitert, wählen Sie die Verarbeitungsphase aus und klicken Sie auf Bearbeiten…
  4. Wählen Sie das Element Verlinkt mit vorherigen (Operatoren wird es nicht möglich sein, Tasks manuell zu dieser Phase zu senden) aus.

  5. Klicken Sie auf OK, um die Änderungen zu speichern.


Hochladen eines Projekts zum Anwendungsserver

Nach der Erstellung eines Projekts müssen Sie es zum Anwendungsserver hochladen. Dadurch werden Projekteinstellungen, Dokumentdefinitions-Dateien, Wörterbücher und andere Servicedaten auf den Anwendungsserver kopiert.

Wichtig! Im Projekt erstellte Stapel werden beim Hochladen nicht auf den Anwendungsserver kopiert.

Um ein Projekt zum Anwendungsserver hochzuladen, wählen Sie aus dem Hauptmenü der Projektkonfigurationsstation Datei>Projekt auf Server hochladen….

Hinweis: Neue Projekte können nur vom Administrator erstellt werden. Ein Projektkonfigurationsoperator kann nur bereits erstellte Projekte konfigurieren. Nachdem das Projekt zum Anwendungsserver hochgeladen wurde und der Administrator den Operatoren der Stationen die erforderlichen Berechtigungen erteilt hat (über die Verwaltungs- und Überwachungskonsole), muss der Projektkonfigurator daher das Projekt auf dem Anwendungsserver durch Wahl von Datei>Projekt von Server öffnen…öffnen und die notwendigen Einstellungen vornehmen (d.h. Dokumentdefinitionen und Importprofile erstellen, Exporteinstellungen festlegen usw.).

Wichtig! Um den Export erfolgreich abzuschließen, muss nach dem Hochladen des Projekts auf den Server (\\computer_name\share_name[\pfad] der Pfad zum Projektordner im UNC-Format angegeben werden. Vergewissern Sie sich, dass alle am Export beteiligten Stationen Zugriff auf den angegebenen Ordner haben.

Die Angabe des Pfads des hochgeladenen Projekts im Format " \[pfad]" führt zu Exportfehlern. Wenn Sie einen relativen Exportpfad angeben, kann nur über die Anwendungsprogrammierschnittstelle (API) auf die Daten zugegriffen werden. Um auf andere Weise auf die Daten zugreifen zu können, müssen Sie das Stammverzeichnis für relative Pfade im UNC-Format angeben (dies kann beim Anpassen der Projekteigenschaften erfolgen).


Dialogfeld Regeleinstellungen

Dialogfeld Regeldefinitionen

Im Modus Erweitert der Workflow-Konfiguration können Sie Exit-Routen und Eintrittsbedingungen für eine Phase mithilfe von Regeln festlegen.

Sie können die Bedingungen festlegen, unter denen ein Task an nachfolgende Phasen gesendet wird, sowie die Bedingungen, unter denen Dokumente zu der Phase zugelassen werden.

Senderegeln werden im Dialogfeld Nächste Phase konfiguriert, das erscheint, wenn Sie in der Registerkarte Exit-Routen im Dialogfeld Eigenschaften von Workflow-Phasen eine Phase hinzufügen oder bearbeiten.

Regeln, die die Bedingungen festlegen, unter denen Dokumente zu einer Phase zugelassen werden, werden in der Registerkarte Eintragsbedingungen im Dialogfeld Eigenschaften von Workflow-Phasen konfiguriert.

Exit-Routen und Eintrittsbedingungen können entweder über Standardregeln oder über ein Phasenregel-Skript festgelegt werden.

Um eine neue Regel hinzuzufügen, klicken Sie auf die Schaltfläche Regel…. Um eine Regel zu bearbeiten, klicken Sie auf Bearbeiten….

Das Dialogfeld Regeldefinitionen enthält die folgenden Felder:

Feld | Beschreibung
Name | Name der Regel
Bedingungstyp Folgende Typen stehen zur Auswahl:
  • Standardregel
  • Skript

Bedingungstyp Standardregel:
Regel wird implementiert, wenn Wählen Sie eine der folgenden Optionen:
  • Die Bedingung ist erfüllt
  • Die Bedingung ist nicht erfüllt
Bedingung Wählen Sie eine der folgenden Bedingungen:
  • Der Task wurde erfolgreich verarbeitet.
  • Anzahl der Zeichen der Überprüfung erfüllt den Ausdruck
  • Prozentsatz der Zeichen der Überprüfung erfüllt den Ausdruck
  • Anzahl der Felder der obligatorischen Überprüfung erfüllt den Ausdruck
  • Anzahl der Zeichen der doppelten Überprüfung erfüllt den Ausdruck
  • Hat Regelfehler
  • Hat Zusammenstellungsfehler
  • Hat Stapelintegritätsfehler
  • Feldwert erfüllt den Ausdruck
Bei Bedingungen, die Ausdrücke enthalten, geben Sie den Referenzwert ein und wählen aus, ob der zu prüfende Wert im Vergleich zum eingegebenen Wert gleich, ungleich, kleiner, kleiner gleich, größer oder größer gleich sein muss.

Bei der Bedingung Feldwert erfüllt den Ausdruck wählen Sie auch ein Feld aus, dessen Wert mit dem Referenzwert verglichen werden soll. Hierfür klicken Sie auf die Schaltfläche Auswählen… und wählen das gewünschte Feld aus der Liste aus.

Für den Bedingungstyp Skript:
Skript… | Öffnet den Skripteditor, in dem Sie die Phasenregel bearbeiten können. Nach dem Schließen des Skripteditors wird der gespeicherte Skriptcode im Fenster Regeldefinitionen links von der Schaltfläche Skript… angezeigt.


Phaseneigenschaften bearbeiten

Im Modus Erweitert der Workflow-Konfiguration können Sie sowohl beim Erstellen einer neuen Phase deren Eigenschaften angeben als auch Eigenschaften von grundlegenden oder zuvor erstellten benutzerdefinierten Phasen bearbeiten.

Phaseneigenschaften werden im Dialogfeld Eigenschaften von Workflow-Phasen angegeben und bearbeitet. Um dieses Dialogfeld für eine ausgewählte Phase aufzurufen, klicken Sie auf der rechten Seite auf die Schaltfläche Bearbeiten….
Die Eigenschaften sind in Registerkarten unterteilt. Die Anzahl der Registerkarten und der für die Bearbeitung verfügbare Satz Eigenschaften richtet sich nach dem Basistyp der ausgewählten Phase.

Option

Beschreibung

Phase

Registerkarte Allgemein

Name

In diesem Feld können Sie einen anderen Namen für die Phase eingeben.

Die Eigenschaft steht bei allen Phasen zur Verfügung.

Tool

Wählen Sie in der Dropdown-Liste ein gewünschtes Tool des jeweiligen Basistyps aus. Tools richten Sie in der Registerkarte Phasentools im Dialogfeld Projekteigenschaften ein.
Hinweis: Für die Phase Interaktiv kann jedes Tool ausgewählt werden. Der der Phase zugewiesene Basistyp richtet sich nach dem ausgewählten Tool.

Die Eigenschaft steht bei den folgenden Phasen zur Verfügung:

  • Interaktiv
  • Überprüfen der Dokumentzusammenstellung
  • Datenüberprüfung
  • Überprüfung
  • Stapelintegritätsprüfung
  • Exportbestätigung

Dokumente pro Task

Legt die maximale Anzahl von Dokumenten fest, die ein Task enthalten darf.
Hinweis: Liegt das festgelegte Limit unter dem Limit für die vorherige Phase, werden die Tasks entsprechend des Limits der gegebenen Phase gebildet. Sie sollten für die nachfolgenden Phasen entweder die gleichen Werte bestimmen oder wählen die Option Ganze Stapel verarbeiten.

Die Eigenschaft kann bei allen Phasen bearbeitet werden, außer bei den Phasen Stapelintegritätsprüfung und Verarbeitet

Auf alle Dokumente eines Stapels warten

Gibt an, ob der gesamte Stapel verarbeitet wird oder ob jedes Dokument aus dem Stapel direkt nach seiner Verarbeitung an die nächste Phase gesendet wird.

Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Stapelintegritätsprüfung und Verarbeitet

Satz verwendeter Dokumentdefinitionen einschränken

Ermöglicht Ihnen festzulegen, welche Dokumente zur Phase zugelassen werden. Bei Dokumenten, die in die Phase eintreten, wird geprüft, ob sie den festgelegten Dokumentdefinitionen entsprechen, Dokumente, bei denen diese Dokumentdefinitionen erkannt worden sind, werden für die Phase zugelassen.
Hinweis: Wenn die Gruppe der Dokumentdefinitionen begrenzt ist und die Option Auf alle Dokumente eines Stapels warten ausgewählt ist, werden in der Phase nur die Dokumente der angegebenen Gruppe verarbeitet, wobei der an die nächste Phase gesendete Task jedoch alle Dokumente des Stapels enthält.
Hinweis: Mit einem Skript können Sie die Gruppe der für die Erkennung verwendeten Dokumentdefinitionen einschränken.

Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Ausnahmen und Verarbeitet

Webstationen aktivieren

Gibt an, ob die Webstationen für die Verarbeitung verwendet werden dürfen

Die Eigenschaft steht bei den folgenden Phasen zur Verfügung:

  • Ausnahmen
  • Datenüberprüfung
  • Überprüfung
  • Stapelintegritätsprüfung
  • Exportbestätigung
Verlinkt mit vorherigen (Operatoren wird es nicht möglich sein, Tasks manuell zu dieser Phase zu senden) Erlaubt oder verbietet den Eintritt in eine Phase aus der im Routingschema direkt vor ihr liegenden Phase. Ist dieses Element ausgewählt, ist der Eintritt in diese Phase nur aus der im Routingschema vor ihr liegenden Phase möglich. Dies kann erforderlich sein, wenn die Phase sich nach den Ergebnissen der vor ihr liegenden Phase richtet und das Senden von Tasks an diese Phase unter Auslassung der vor ihr liegenden Phase nicht zulässig ist. Möchten Sie zulassen, dass Operatoren aus anderen Verarbeitungsphasen Tasks manuell an diese Phase senden, müssen Sie dieses Element deaktivieren. Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Ausnahmen und Verarbeitet

Registerkarte Feld einrichten (nur bei den Phasen Datenüberprüfung und Überprüfung)

In der Phase zu verarbeitende Daten

Ermöglicht Ihnen, die Gruppe der in der Phase vorhandenen Felder zu beschränken (bei der verteilten Überprüfung).
Wählen Sie aus der Liste Verfügbare Felder die zu verarbeitenden Felder aus. Diese Liste enthält die in der Registerkarte Allgemein angegebenen Dokumentdefinitionen.

Mit den Schaltflächen ">" und ">>" fügen Sie die gewünschten Felder der Liste Ausgewählte Felder hinzu.

Mit der Schaltfläche ">" fügen Sie ein ausgewähltes Element (eine Dokumentdefinition, eine Seite, eine Gruppe von Feldern oder ein Feld) der Liste hinzu.

Mit der Schaltfläche ">>" fügen Sie alle unter Verfügbare Felder aufgeführten Dokumentdefinitionen der Liste Ausgewählte Felder hinzu.

Mit den Schaltflächen"<" und "<<" entfernen Sie ein ausgewähltes Element bzw. alle Elemente aus dem Bereich Ausgewählte Felder.

Die Eigenschaft ist nur bei den Phasen Datenüberprüfung und Überprüfung verfügbar.

Seitenbild außerhalb ausgewählter Felder ausblenden

Gibt an, ob die im Feld einrichten nicht enthaltenen Felder ausgeblendet werden sollen. Bei der Auswahl dieser Option muss während der verteilten Überprüfung ein hoher Sicherheitsgrad sichergestellt werden.

Die Eigenschaft ist nur in der Phase Datenüberprüfung verfügbar.

Doppelüberprüfung

Gibt an, ob die doppelte Überprüfung für die Phase aktiviert werden soll. Ist die Option ausgewählt, wird das Dokument von zwei verschiedenen Operatoren überprüft.

Die Eigenschaft ist nur in der Phase Datenüberprüfung verfügbar.

Registerkarte Skript (nur bei der Phase Automatisch vorhanden)

Typ

Wählen Sie aus der Dropdownliste eines der Verarbeitungsskripte aus: das Skript für die Dokumentverarbeitung oder das für die Stapelverarbeitung.

Die Eigenschaft ist nur in der Phase Automatisch verfügbar.

Skript bearbeiten…

Öffnet das Fenster Skripteditor.

Die Eigenschaft ist nur in der Phase Automatisch stage verfügbar.

Registerkarte Exit-Routen (fehlt bei den Phasen Ausnahmen, Erneutes Scannen und Verarbeitet)

Nächste Phase

Wählen Sie aus, wie die nächste Phase definiert wird:

  • Durch ein Routing-Schema
  • Benutzerdefiniert (die Phase wird in der Dropdown-Liste ausgewählt)

Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Ausnahmen, Erneutes Scannen und Verarbeitet

Bedingungen für das Senden von Dokumenten zum erneuten Scannen senden

Enthält die Liste der Phasen, an die ein Task gesendet wird, wenn die gewünschten Bedingungen erfüllt sind.

Um eine Phase hinzuzufügen, klicken Sie auf die Schaltfläche Phase…. Das Dialogfeld Nächste Phase wird geöffnet. In diesem Dialogfeld können Sie eine Phase auswählen und Bedingungen angeben, unter denen der Task an diese Phase gesendet wird. Mit den Schaltflächen rechts konfigurieren Sie die Phaseneinstellungen:

  • Regel… - Öffnet das Dialogfeld Regeldefinitionen, in dem Sie eine neue Regel hinzufügen können.
  • Bearbeiten… - Öffnet das Dialogfeld Regeldefinitionen, in dem Sie die Einstellungen der ausgewählten Regel bearbeiten können.
  • Löschen - Löscht das ausgewählte Element (eine Regel oder eine Gruppe von Regeln).
  • Gruppe… - Öffnet das Dialogfeld Regelgruppein dem Sie eine Gruppe von Regeln hinzufügen können. Geben Sie einen Namen für die Gruppe ein und wählen Sie die Bedingung aus, unter der die Gruppe von Regeln implementiert wird: Entweder, wenn eine beliebige Regel implementiert ist oder wenn alle Regeln implementiert sind.
  • Nach oben - Verschiebt eine ausgewählte Regel oder eine Gruppe von Regeln eine Position aufwärts.
  • Nach unten - Verschiebt eine ausgewählte Regel oder eine Gruppe von Regeln eine Position abwärts.

Um die ausgewählte Phase zu bearbeiten, klicken Sie auf die Schaltfläche Bearbeiten…. Daraufhin wird das Dialogfeld Nächste Phase mit den Einstellungen für die ausgewählte Phase aufgerufen.

Um die ausgewählte Phase zu löschen, klicken Sie auf die Schaltfläche Löschen.
Um die Reihenfolge der Phasen zu ändern, verwenden Sie die Schaltflächen Nach oben und Nach unten.

Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Ausnahmen, Erneutes Scannen und Verarbeitet

Registerkarte Eintragsbedingungen (fehlt bei den Phasen Ausnahmen und Verarbeitet)

Dokumente für die Phase zulassen

Geben Sie an, ob Dokumente immer für die Phase zugelassen werden oder nur unter bestimmten Bedingungen. Wenn die Option Unter diesen Bedingungen aktiviert ist, konfigurieren Sie die Regeln über die Schaltflächen rechts.
Um eine Regel hinzuzufügen, klicken Sie auf die Schaltfläche Regel…. Das Dialogfeld Regeldefinitionen wird geöffnet.
Um die ausgewählte Regel zu bearbeiten, klicken Sie auf Bearbeiten…. Daraufhin wird das Dialogfeld Regeldefinitionen mit den Einstellungen für die ausgewählte Regel aufgerufen.
Um das ausgewählte Element (eine Regel oder eine Gruppe von Regeln) zu löschen, klicken Sie auf Löschen.
Um eine Gruppe von Regeln hinzuzufügen, klicken Sie auf die Schaltfläche Gruppe…. Geben Sie daraufhin geöffneten Dialogfeld Regelgruppe einen Namen für die Gruppe ein und wählen Sie die Bedingung aus, unter der die Gruppe von Regeln implementiert wird:

  • wenn eine beliebige Regel implementiert ist
  • wenn alle Regeln implementiert sind
Um die Reihenfolge der Regeln in einer Gruppe zu ändern, verwenden Sie die Schaltflächen Nach oben und Nach unten.

Hinweis: Wenn die Bedingung nicht erfüllt wird, wird das Dokument zur nächsten im Workflow-Schema angegebenen Phase weitergeleitet.

Die Eigenschaft ist bei allen Phasen verfügbar, außer bei den Phasen Ausnahmen und Verarbeitet

Hinweis: Informationen zur ausgewählten Exit-Route und den abgefragten Eintrittsbedingungen werden in das Ereignisprotokoll geschrieben.


Phasentools

In der Registerkarte Phasentools im Dialogfeld Projekteigenschaften können Sie die Tools für die Verarbeitungsphasen konfigurieren. In dieser Registerkarte können Sie benutzerspezifische Tools hinzufügen und löschen und die Eigenschaften der Tools bearbeiten.

Um ein neues Tool für die Verarbeitungsphase hinzuzufügen, klicken Sie auf die Schaltfläche Hinzufügen.... Im daraufhin geöffneten Dialogfeld Neues Tool für die Verarbeitungsphase erstellen geben Sie einen Namen für das Tool und eine Beschreibung ein und wählen den Typ der Phase in der Dropdown-Liste Typ aus. Das neue Phasentool wird der Liste der Tools hinzugefügt.

Um eine ausgewählten Phase zu bearbeiten, klicken Sie auf die Schaltfläche Bearbeiten.... Das daraufhin geöffnete Dialogfeld Einstellungen der Tools für die Verarbeitungsphase enthält die folgenden Einstellungen:

Option | Beschreibung
Gruppe Eventeinstellungen
Schaltfläche Ereignis hinzufügen…

Öffnet das Dialogfeld Event hinzufügen, in dem Sie ein Ereignis auswählen, das in der Phase verarbeitet werden soll.

Um das Skript für die Verarbeitung dieses Ereignisses zu schreiben, klicken Sie auf die Schaltfläche Skript bearbeiten….Der Skripteditor wird geöffnet.
Schaltfläche Skript bearbeiten… | Öffnet den Skripteditor, in dem Sie das Skript für die Verarbeitung des ausgewählten Ereignisses bearbeiten können.
Schaltfläche Delete | Entfernt das ausgewählte Ereignis aus der Liste.
Gruppe Designeinstellungen
Schaltfläche Design bearbeiten… | Öffnet das Dialogfeld Designeinstellungen, in dem Sie das Erscheinungsbild der Phase einrichten können.
Schaltfläche Design zurücksetzen | Stellt die Design-Standardeinstellungen wieder her.


Workflow-Konfiguration

Die Reihenfolge, in der ein Stapel verarbeitet werden sollte, wird für jeden Stapeltyp bestimmt. Beim Erstellen eines Stapels wird sein Typ bestimmt, und der Stapel wird gemäß den Einstellungen für diesen Stapeltyp verarbeitet.

Wenn keine Stapeltypen erstellt werden, werden alle Stapel mit den <default>-Einstellungen, die für das gesamte Projekt bestimmt wurden, verarbeitet (Projekt >Projekteigenschaften…, Registerkarte Workflow ).

Workflows werden auf der Registerkarte Workflow im Dialogfeld Stapeltypeigenschaften konfiguriert.

Folgende Workflow-Modi sind verfügbar: Einfach, Erweitert, Unbeaufsichtigt, für Web-Erfassungsstation und Erweitert für Web-Erfassungsstation.

Collapsed Der Modus "Einfach"

Der Modus Einfach umfasst die folgenden Phasen: Scannen, Erneutes Scannen, Erkennung, Datenüberprüfung, Überprüfen der Dokumentzusammenstellung, Überprüfung, Stapelintegritätsprüfung, Exportbestätigung, Ausnahmen, Export und Verarbeitet.

Sie können die folgenden Verarbeitungsoptionen angeben:

  1. Ganze Stapel verarbeiten

    • Wenn diese Option ausgewählt wird, wird der gesamte Stapel verarbeitet (d. h. der Stapel wird nicht weitergeleitet, bis alle seine Dokumente verarbeitet wurden).

    • Wenn diese Option nicht ausgewählt wird, wird jedes Dokument aus diesem Stapel zur nächsten Phase gesendet, sobald es verarbeitet wurde.

  2. Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als - Das Dokument wird nur dann zur Überprüfung gesendet, wenn Fehler vorliegen oder wenn die Anzahl der markierten Zeichen größer ist als der im Feld % pro Dokument angegebene Wert.
    Hinweis: Wenn Sie für eines der Felder in Feldüberprüfungseinstellungen die Option Immer ausgewählt haben, wird das Dokument in jedem Fall zur Überprüfung gesendet.
  3. Verwenden Sie separate Phasen für:
    • Erneutes Scannen
    • Datenüberprüfung
    • Überprüfen der Dokumentzusammenstellung
    • Überprüfung
    • Stapelintegritätsprüfung
    • Exportbestätigung
    • Ausnahmen

    Alle Phasen außer Überprüfung sind optional.

    Das Erstellen von separaten Überprüfungsphasen unterteilt die Phase Überprüfung in Teilschritte, die alle von ihrem eigenen Operator durchgeführt werden. Somit ist jeder Operator nur für eine Aufgabe zuständig: Datenüberprüfung, Überprüfen der Dokumentzusammenstellung usw.

    Wenn alle oben genannten Schritte von einem Operator gehandhabt werden, wird er/sie alle Tasks der Reihe nach ausführen müssen: das Dokument aus der Phase Überprüfung der Dokumentzusammenstellung nehmen, die Zusammenstellung überprüfen, die Daten aus der Phase Datenüberprüfung nehmen und diese überprüfen, etc.

    Sie können für alle Phasen außer für die Phase Erneutes Scannen auch Webstationen nutzen. Hierfür setzen Sie in der Spalte Webstationen zulassen neben der entsprechenden Phase ein Häkchen. Die Datenüberprüfung wird auf der Webstation für die Datenüberprüfung oder Überprüfung ausgeführt, während andere Phasen auf der Webstation für die Überprüfung ausgeführt werden.

Collapsed Der Modus "Erweitert"

Im Modus Erweitert können Sie komplexe Workflow-Schemata konfigurieren. In diesem Modus können Sie sowohl die grundlegenden Phasen bearbeiten als auch benutzerdefinierte Phasen erstellen.

Hinweis: Zwischen dem Zeitpunkt, zu dem die Erweitert Workflow-Einstellungen in der Projektkonfigurationsstation gültig werden, und dem Zeitpunkt, zu dem sie in der Verifizierungsstation angezeigt werden, besteht eine Zeitverzögerung.

Das Schema Erweitert besteht aus den folgenden Basisphasen:

  • Ausnahmen
  • Scannen
  • Erneutes Scannen
  • Erkennung
  • Unbeaufsichtigte Verarbeitung
  • Datenüberprüfung
  • Überprüfung
  • Überprüfen der Dokumentzusammenstellung
  • Stapelintegritätsprüfung
  • Exportbestätigung
  • Export
  • Verarbeitet

Wählen Sie die gewünschten Phasen für das Workflow-Schema aus. Alle Phasen außer Scannen und Verarbeitet sind optional.
Um die Reihenfolge der Phasen zu ändern, verwenden Sie die Schaltflächen Nach oben und Nach unten auf der rechten Seite. Bei Phasen, die weder früher noch später ausgeführt werden können, sind die entsprechenden Schaltflächen grau dargestellt.

Für jeden Phase kann die maximale Anzahl Dokumente, die ein Task enthalten darf, in der Spalte Dokumente pro Task angegeben werden. Um die Anzahl der Dokumente pro Task für eine Phase zu ändern, klicken Sie auf die Zahl und geben einen neuen Wert ein.
Hinweis: Bei den Phasen Stapelintegritätsprüfung und Verarbeitet werden die Stapel als Ganzes verarbeitet und nicht in Tasks unterteilt, deshalb kann die Anzahl der Dokumente pro Task bei diesen Phasen nicht geändert werden.

Der Basistyp für jede Phase wird in der Spalte Basistyp angegeben. Der Basistyp gibt den Typ an, dessen Grundeinstellungen beim Erstellen der Phase verwendet wurden.

Für jede Phase können Sie die Eigenschaften anzeigen und bearbeiten. Um das Dialogfeld "Phaseneigenschaften" aufzurufen, wählen Sie eine Phase aus und klicken auf der rechten Seite auf die Schaltfläche Bearbeiten…. Weitere Informationen finden Sie unter Phaseneigenschaften bearbeiten.

Abgesehen von den Basisphasen können Sie auch benutzerdefinierte Phasen erstellen und in das Workflow-Schema einfügen. Benutzerdefinierte Phasen können auf Phasentools beruhen. Sie können damit Phasen des gleichen Basistyps, doch mit unterschiedlichen Phaseneigenschaften erstellen.

Um eine Phase hinzuzufügen, klicken Sie rechts auf die Schaltfläche Phase…. Im daraufhin geöffneten Fenster wählen Sie eine Basisphase aus, auf deren Grundlage die neue Phase erstellt wird. Legen Sie dann die Phaseneigenschaften fest. Die neue Phase wird dem Schema hinzugefügt. Nähere Informationen hierzu finden Sie unter Verarbeitungsphasen erstellen.
Um eine benutzerdefinierte Phase zu löschen, wählen Sie die Phase aus und Sie klicken rechts auf die Schaltfläche Löschen.

Wenn die Übertragung an die Phase von Bedingungen abhängig ist, ist die Phase durch das Symbol [image] gekennzeichnet. Wenn Dokumente immer für die Phase zugelassen werden, zeigt diese das Symbol [image].

Collapsed Der Modus "Unbeaufsichtigt"

Im Modus Unbeaufsichtigt werden die Dokumente ohne Einwirken des Operators verarbeitet und exportiert. Wenn Verarbeitungsfehler auftreten, kann das nicht erkannte Bild in einen angegebenen Ordner gespeichert werden (dies wird auf der Registerkarte Export bestimmt) und die erfolgreich verarbeiteten Dokumente werden automatisch exportiert. In diesem Modus werden die Stapel als Ganzes verarbeitet.

Für die Web-Erfassungsstation kann der Workflow mittels der Modi für Web-Erfassungsstation und Erweitert für Web-Erfassungsstation konfiguriert werden.

Collapsed Der Modus "Für die Web-Erfassungsstation"

In für Web-Erfassungsstation können Sie die Bedingung angeben, bei der Dokumente zur Überprüfung gesendet werden. Wird die Option Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als ausgewählt, werden die ausgewählten Dokumente nur zur Überprüfung gesendet, wenn sie Fehler enthalten oder wenn die Anzahl hervorgehobener Zeichen höher ist als im Feld % pro Dokument festgelegt wurde.

Collapsed Der Modus "Erweitert für Web-Erfassungsstation"

Der Modus Erweitert für Web-Erfassungsstation ermöglicht Ihnen ähnlich wie der Modus Erweitert die Konfiguration komplexer Workflow-Schemas durch die Bearbeitung bestehender und das Hinzufügen neuer Phasen. Im Unterschied zum Modus Erweitert gelten für den Modus Erweitert für Web-Erfassungsstation folgende Einschränkungen:

  • Der Satz vordefinierter Phasen kann nicht geändert werden.

  • Eine benutzerdefinierte Phase kann nur auf der Phase Automatisch basieren.
  • In den Phaseneigenschaften können nur der Phasenname, Exit-Routen und Eintrittsbedingungen bearbeitet werden.

Hinweis: Beim Umschalten vom Modus Erweitert für Web-Erfassungsstation zum Modus Erweitert und umgekehrt werden alle vorgenommenen Einstellungen auf die Standardwerte zurückgesetzt.


Verarbeitungsphasen erstellen

Benutzerdefinierte Phasen werden im Modus Erweitert in der Workflow-Konfiguration erstellt.
Um eine benutzerdefinierte Phase hinzuzufügen, klicken Sie rechts auf die Schaltfläche Phase…. Das daraufhin geöffnete Fenster Neue Verarbeitungsphase erstellen enthält die Liste der grundlegenden und zuvor erstellten benutzerdefinierten Phasen, auf deren Basis eine neue Phase erstellt werden kann. Die Eigenschaften der ausgewählten Phase werden im unteren Bereich des Dialogfelds unter der Überschrift Ausgewählte Einstellungen angezeigt.

Im Modus Erweitert gibt es drei Typen von Phasen:

  1. Automatisch - Tasks dieses Typs werden auf der Verarbeitungsstation ohne Bedienereingriff ausgeführt.
    Die Phase vom Typ Automatisch umfasst die folgenden Teile:
    • Erkennung
    • Unbeaufsichtigte Verarbeitung
    • Export
  2. Interaktiv - Tasks dieses Typs werden von Operatoren an der Überprüfungsstation, Datenüberprüfungsstation oder Scanstation verarbeitet.
    Die Phase vom Typ Interaktiv umfasst die folgenden Teile:
    • Scannen
    • Datenüberprüfung
    • Überprüfen der Dokumentzusammenstellung
    • Überprüfung
    • Stapelintegritätsprüfung
    • Exportbestätigung
  3. Benutzertyp - Tasks dieses Typs werden von externen Clients über die Webservice-API angenommen, ausgeführt und zurückgegeben.

Hinweis: Um dem Workflow-Schema ein Verarbeitungsskript hinzuzufügen, wählen Sie die Phase Automatisch aus.

Wählen Sie eine Basisphase aus, auf deren Grundlage Sie eine neue Phase erstellen möchten, und klicken Sie auf OK. Das Dialogfeld Eigenschaften von Workflow-Phasen wird geöffnet. Das Dialogfeld enthält die folgenden Registerkarten:

  • Allgemein
  • Feld einrichten (nur bei den Phasen Datenüberprüfung und Überprüfung)
  • Skript (nur bei Automatisch)
  • Exit-Routen (bei allen Phasen außer Ausnahmen, Erneutes Scannen und Verarbeitet)
  • Eintragsbedingungen (bei allen Phasen außer Ausnahmen und Verarbeitet)
  • Rollen (für Phasen auf der Grundlage von benutzerdefinierten Phasentools)

Die Liste der Optionen in jeder Registerkarte hängt von der ausgewählten Phase bzw. dem Typ ab. Eine ausführliche Beschreibung der Eigenschaften von Phasen finden Sie unter Eigenschaften von Phasen bearbeiten.