О программе Станция сканирования ABBYY

Станция сканирования ABBYY — это программное решение для поточного сканирования большого объема документов. Станция сканирования позволяет:

  • осуществлять управление сканером: запускать и останавливать процесс сканирования, настраивать параметры сканирования;
  • контролировать качество сканируемых изображений;
  • подготовить изображения к дальнейшей обработке: извлечению данных с использованием ABBYY FlexiCapture 10.

Чтобы запустить программу Станция сканирования выберите меню Пуск > Программы > ABBYY FlexiCapture 10 Станции > Станция Cканирования или Пуск > Программы > Станция Cканирования ABBYY FlexiCapture 10 > Станция Cканирования.

Информацию об основных этапах работы со Станцией сканирования вы можете найти в разделе Как работать со Станцией сканирования.

Подробное описание интерфейса программы содержится в разделе Интерфейс программы.


Новые возможности Станции сканирования ABBYY

Clickonce установка

Clickonce позволяет установить Станцию сканирования ABBYY одним нажатием по соответствующей ссылке. Программа будет установлена автоматически. Станция сканирования ABBYY, установленная с помощью Clickonce установки, может запускаться только тем пользователем, под учетной записью которого проводилась установка.
Задания пересканирования

Если требуется пересканировать какие-либо изображения, оператор Станции верификации ABBYY может отправить задание на Станцию сканирования ABBYY. Указанные страницы будут пересканированы и заменены в пакете.

Задания пересканирования
Использование скриптов

Работа со Станцией сканирования ABBYY теперь может быть реализована с помощью скриптов.

Использование скриптов
Новый интерфейс

Добавлено окно Регистрационные параметры. Теперь вы можете работать с регистрационными параметрами пакетов и документов непосредственно в главном окне.

Добавлена панель Скрипты. С ее помощью вы можете запускать выполнение скрипта нажатием соответствующей кнопки на панели. Вы также можете настроить панель Скрипты и сделать ее более наглядной.

Окно Регистрационные параметры
Настройка панели инструментов


Как работать со Станцией сканирования

Станция сканирования предоставляет два основных сценария работы:

  • Обработка типовых пакетов документов с заранее установленными настройками
    Этот сценарий работы подходит для сканирования больших объемов однотипных документов. Данный сценарий работы предусматривает создание типа пакета, задающего настройки сканирования изображений, разделения их на пакеты и документы, обработки отсканированных изображений, экспорта пакетов заданного типа.
  • Обработка пакета документов с установкой настроек вручную
    Этот сценарий работы подходит для разового сканирования небольшого объема документов. Данный сценарий не требует обязательной установки дополнительных настроек. Если настройки не заданы, изображения обрабатываются с настройками по умолчанию.


Обработка типовых пакетов документов

Обработка типовых пакетов документов состоит из следующих основных шагов:

  1. Создание нового пакета
    В поле Текущий тип пакета на панели инструментов выберите тип создаваемого пакета. Для создания пакета выбранного типа выберите в меню Файл пункт Новый пакет или нажмите клавиши Ctrl+N. Также в зависимости от настроек типа пакета новый пакет может быть создан автоматически при начале сканирования или после определенного количества отсканированных страниц. Если настройки типа пакета предусматривают заполнение регистрационных параметров, то вам будет предложено заполнить регистрационные параметры.
  2. Запуск процесса сканирования
    На панели инструментов выберите созданный тип пакета в качестве текущего. Для того чтобы начать сканирование, нажмите на кнопку Сканировать на панели инструментов.
  3. Экспорт отсканированных документов
    После завершения сканирования, экспортируйте документы. Для этого нажмите на кнопку Отправить на панели инструментов. Если настройки типа пакета предусматривают обязательное заполнения регистрационных параметров, то вы не сможете экспортировать пакет, пока параметры не будут заполнены.

Если вы хотите изменить некоторые настройки обработки отдельного пакета документов, смотрите раздел Обработка пакета документов с установкой настроек вручную.

Для изменения настроек обработки типовых пакетов вы можете воспользоваться рекомендациями в разделе Как работать с типами пакетов.


Обработка пакета документов с установкой настроек вручную

Вы можете устанавливать настройки обработки отдельного пакета документов прямо перед началом того или иного этапа обработки. Обработка пакета документов на Станции сканирования ABBYY включает в себя следующие этапы:

  1. Сканирование
    Для того чтобы начать сканирование, нажмите на кнопку Сканировать на панели инструментов. В результате будет запущен процесс сканирования с использованием последнего выбранного источника сканирования. Вы можете выбрать один из источников сканирования, нажав на стрелку справа от кнопки. Более подробную информацию о сканировании и импорте изображений вы найдете в разделе Как сканировать изображения.
    Внимание! Сканер должен быть подключен. Чтобы правильно подключить сканер, обратитесь к документации, прилагаемой к сканеру. Если сканер не подключен, вы можете использовать только виртуальный сканер для импорта изображений из папки.
  2. Распределение страниц по документам и пакетам
    Отсканированные страницы можно перераспределить по документам и пакетам в окне Пакеты или в окне изображений. Более подробную информацию вы можете найти в разделе Как работать с пакетами, документами и страницами.
  3. Редактирование изображений
    Вы можете дополнительно обработать изображения перед экспортом. Информацию о работе с изображениями вы можете найти в разделе Как редактировать изображения.
  4. Отправка отсканированных документов
    После завершения работы с пакетом, сохраните его в локальной папке, папке на FTP-сервере, экспортируйте в ABBYY FlexiCapture или сохраните с помощью скрипта. Чтобы выбрать одно из направлений экспорта, нажмите на стрелку справа от кнопки Отправить на панели инструментов главного окна программы. Выберите нужное направление экспорта, в открывшемся диалоге настройте нужные параметры и нажмите OK для запуска процесса экспорта. Подробнее об экспорте вы можете прочитать в разделе Как экспортировать пакет.

Если вы хотите настроить параметры обработки для серии типовых пакетов, смотрите раздел Обработка типовых пакетов документов.


Как работать с пакетами, документами и страницами

Отсканированные изображения добавляются в пакеты. Как правило, один пакет соответствует одной пачке отсканированных страниц.

Пакет может содержать документы и отдельные страницы изображений. При первом запуске программы создается пустой пакет с именем по умолчанию.

Пакеты и документы могут создаваться автоматически при сканировании. Для того чтобы настроить автоматическое разделение изображений на пакеты и/или документы, а также схемы именования, укажите нужные настройки на закладке Свойства пакета диалога Настройки. Автоматическое разделение на пакеты и документы и схемы именования для типовых пакетов вы можете настроить при создании типа пакета в Мастере создания типа пакета или после создания типа пакета в диалоге Свойства типа пакета на закладке Свойства пакета.

Чтобы создать новый документ или пакет или изменить организацию изображений в пакете вручную, следуйте предложенным ниже инструкциям:

Как создать новый пустой пакет
В окне Пакеты:
  • нажмите кнопку [image] на панели инструментов, или
  • нажмите правую кнопку мыши и в меню быстрого доступа выберите Новый пакет, или
  • нажмите Ctrl+N.
Как изменить имя пакета или документа
  1. Выделите пакет (документ) в окне Пакеты.
  2. Нажмите левую кнопку мыши или кнопку F2.
  3. Введите новое имя пакета (документа).
Как создать новый документ
В окне Пакеты или в окне изображений выделите страницы, которые должны быть объединены в документ. Затем
  • нажмите кнопку [image] на панели инструментов окна Пакеты, или
  • нажмите правую кнопку мыши и в меню быстрого доступа выберите Создать документ, или
  • нажмите Ctrl+Shift+C.
Как расформировать документ
В окне Пакеты или в окне изображений выделите документ, который должен быть расформирован. Затем
  • нажмите кнопку [image] на панели инструментов окна Пакеты, или
  • нажмите правую кнопку мыши и в меню быстрого доступа выберите Расформировать документ, или
  • нажмите Ctrl+Shift+D.

При этом страницы, содержащиеся в документе, будут помещены в текущий пакет, а документ удален.

Как автоматически разделить пакет на документы после сканирования
  1. В меню Сервис выберите Настройки…, в открывшемся диалоге Настройки перейдите на закладку Свойства пакета и установите необходимые параметры разделения документов.
  2. В окне Пакеты выберите пакет, который нужно разделить на документы.
  3. В меню Правка выберите Делить на документы.
Как переместить страницу
В окне Пакеты или в окне изображений наведите курсор на страницу, которую нужно переместить. Нажмите левую кнопку мыши и, не отпуская кнопку, перетащите страницу в нужный документ или пакет. Вы также можете использовать команды меню Правка: Вырезать, Копировать, Вставить.
Как удалить пакет, документ или страницу
В окне Пакеты или в окне изображений выделите элементы, которые нужно удалить. Затем:
  • нажмите кнопку [image] на панели инструментов окна Пакеты, или
  • нажмите правую кнопку мыши и в меню быстрого доступа выберите Удалить, или
  • нажмите Del.


Как сканировать изображения

Программа может получать изображения непосредственно со сканера или загружать изображения из папки (виртуальный сканер). Чтобы изображения появились в программе, нужно выбрать источник сканирования и запустить процесс сканирования. Во время сканирования вы можете осуществлять контроль качества сканируемых изображений и в случае необходимости прервать сканирование или повторно отсканировать страницы.

Источник сканирования

Перед сканированием изображений нужно выбрать источник сканирования: реальный или виртуальный сканер. Чтобы выбрать источник сканирования:

  1. Выберите пункт меню Сервис > Настройки…, в открывшемся диалоге Настройки перейдите на закладку Сканирование.
  2. Выберите источник сканирования и укажите необходимые настройки.

Внимание! Сканер должен быть подключен. Чтобы правильно подключить сканер, обратитесь к документации, прилагаемой к сканеру. Если сканер не подключен, вы можете использовать только виртуальный сканер для импорта изображений из папки.

Замечание. Если вы сканируете типовой пакет, то все настройки сканирования, в том числе источник сканирования, задаются в свойствах типа пакета при создании типа пакета в Мастере создания типа пакета или после создания типа пакета в диалоге Свойства типа пакета на закладке Сканирование.

Запуск процесса сканирования

После того как выбран источник сканирования вы можете запустить процесс сканирования удобным для вас способом:

  • при помощи кнопки Сканировать панели инструментов главного окна, или
  • через меню Файл > Сканировать страницы, или
  • нажатием Ctrl+S.

Если вы хотите выбрать источник сканирования и сразу запустить процесс сканирования из этого источника, сделайте следующее:

  1. Нажмите на стрелку справа от кнопки Сканировать панели инструментов и выберите пункт Выбрать и сканировать…, или
    выберите меню Файл > Выбрать и сканировать…, или
    нажмите Ctrl+Shift+S.
  2. В открывшемся диалоге Выбрать и сканировать выберите один из доступных источников, укажите нужные настройки и нажмите кнопку Сканировать.

Вы также можете сразу загрузить изображения из папки. Для этого в окне Пакеты или в окне изображений выделите пакет или документ, в который нужно загрузить изображения, затем:

  • нажмите правую кнопку мыши и в контекстном меню выберите Загрузить изображения…, в открывшемся диалоге укажите нужные изображения
  • или выберите меню Файл > Загрузить изображения…, в открывшемся диалоге укажите нужные изображения.
Остановка сканирования

Вы можете в любой момент остановить сканирование, нажав на кнопку Остановить сканирование панели инструментов главного окна, комбинацию клавиш Shift+S или выбрав меню Файл > Остановить.

Вставка сканируемых страниц в пакет

Перед началом сканирования вы можете выбрать страницу, после которой следует поместить сканируемые изображения. Для этого выделите нужную страницу в окне Пакеты или в окне изображений и выберите меню Файл > Вставить страницы или нажмите кнопку [image] в окне изображений.

Повторное сканирование

Вы также можете заменить страницы в пакете (например, из-за неудовлетворительного качества сканирования), для этого выделите нужные страницы и выберите меню Файл > Повторно сканировать страницы или нажмите кнопку [image] в окне изображений.


Задания пересканирования

Если какие-то страницы были отсканированы с недостаточно хорошим качеством, Оператор Верификации может отправить на Станцию Сканирования ABBYY задание пересканировать пакет или отдельные документы. Задание будет добавлено в Задания пересканирования на Станции Сканирования ABBYY. Как только информация о новом задании получена, на панели инструментов главного окна появляется сообщение "Доступны новые задания на пересканирование…". Информация о новых заданиях пересканирования загружается с сервера при запуске станции и при открытии диалога Задания пересканирования. Если станция сканирования ABBYY запущена, информация о заданиях пересканирования обновляется каждые 10 минут.

Замечание. Для того чтобы можно было отправлять задания на пересканирование, необходимо отметить опцию Use a separate queue for Rescanning на закладке Project Properties... > Workflow станции Настройки Проекта.

Вы можете открыть диалог Задания пересканирования удобным для вас способом:

  • при помощи кнопки Задания пересканирования панели инструментов главного окна или
  • выбрав пункт меню Сервис > Задания пересканирования или
  • нажав на ссылку "Доступны новые задания на пересканирование…" или
  • нажатием Alt+G

Для того чтобы начать работу с заданием, нажмите кнопку Выбрать в окне Задания пересканирования. При этом выбранное задание добавится на панель Пересканирование окна Пакеты, а документы задания откроются в окне изображения. Задания пересканирования сгруппированы в порядке понижения приоритета.

По умолчанию эскизы страниц при открытии задания не загружаются. Чтобы загрузить изображения выбранных страниц, выберите в контекстном меню пункт Загрузить полноразмерный эскиз или используйте команду Загрузить полноразмерный эскиз в меню Страница. Для того чтобы автоматически загружать эскизы страниц при открытии задания, снимите флажок Загружать пересканируемые страницы без эскизов на закладке Сервер FlexiCapture меню Сервис > Настройки…

Вы можете изменить порядок документов в задании на закладке Пересканирование окна Пакеты, перетаскивая документы с помощью мыши. Вы также можете удалять документы и страницы из задания. Изменять порядок страниц внутри документа не разрешается.

Для того чтобы пересканировать выбранные страницы:

  • Выберите в контекстном меню Повторно сканировать страницы или
  • Воспользуйтесь меню Файл > Повторно сканировать страницы или
  • Нажмите кнопку Rescan Pages на панели инструментов главного окна.

Эскизы пересканированных страниц отмечены значком [image] в левом нижнем углу.

Для перехода по документам внутри задания используйте кнопки Предыдущий документ для пересканирования и Следующий документ для пересканирования на панели инструментов главного окна или выберите соответствующие команды в меню Правка.

Для подтверждения результатов пересканирования документа нажмите кнопку Подтвердить пересканированный документ на панели инструментов главного окна или выберите соответствующий пункт в меню Правка. Эскизы страниц подтвержденных документов отмечены значком [image] в левом нижнем углу.

Замечание. При изменении расположения документов в задании подтверждение пересканирования сбрасываются и требуется заново подтверждать пересканированные документы.

После подтверждения всех документов задания нажмите кнопку Отправить в диалоге Задания пересканирования для отправки документов на Станцию Верификации ABBYY.


Как редактировать изображения

Вы можете редактировать изображения вручную после загрузки. Для этого используйте панель инструментов, меню Страница главного окна программы или контекстное меню страницы:

Как повернуть изображение
При стандартной ориентации страницы текст читается сверху вниз, а строки горизонтальны. Если ориентация страницы отличается от стандартной, поверните изображение. Для этого в окне изображений выделите страницы, которые нужно повернуть, затем:
  • чтобы повернуть изображение на 90° по часовой стрелке, нажмите кнопку [image] или выберите пункт Повернуть на 90° по часовой стрелке в меню Страница главного окна программы или контекстного меню;
  • чтобы повернуть изображение на 90° против часовой стрелки, нажмите кнопку [image] или выберите пункт Повернуть на 90° против часовой стрелки в меню Страница главного окна программы или контекстного меню;
  • чтобы повернуть изображение на 180°, нажмите кнопку [image] или выберите пункт Повернуть на 180° в меню Страница главного окна программы или контекстного меню.
Как зеркально отразить изображение
В окне изображений выделите страницы, которые нужно зеркально отразить, затем:
  • чтобы отразить изображение относительно вертикали, нажмите кнопку [image] или выберите пункт Зеркально отразить относительно вертикали в меню Страница главного окна программы или контекстного меню;
  • чтобы отразить изображение относительно горизонтали, нажмите кнопку [image] или выберите пункт Зеркально отразить относительно горизонтали в меню Страница главного окна программы или контекстного меню.
Как обрезать изображение
  1. В окне изображений выделите страницу, которую нужно обрезать.
  2. Нажмите кнопку [image] или выберите пункт Обрезать в меню Страница главного окна программы или контекстного меню.
  3. Установите курсор мыши в угол области, которую вы хотите оставить на изображении, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол. Область будет обведена прямоугольником, цвет которого можно изменить на закладке Общие диалога Настройки.
  4. При нажатии кнопки Enter края изображения, находящиеся за пределами выделенной области, обрезаются.
Как инвертировать цвета изображения
Если изображение содержит светлый текст на темном фоне, для последующего распознавания инвертируйте цвета изображения. Для этого в окне изображений выделите страницы, цвета которых нужно инвертировать, и нажмите кнопку [image] или выберите пункт Инвертировать в меню Страница главного окна программы или контекстного меню.
Как конвертировать цветные и серые изображения в черно-белые
Если вам не нужно сохранять цвета исходного изображения, конвертируйте изображение в черно-белое. Для этого в окне изображений выделите страницы, которые нужно конвертировать, и нажмите кнопку [image] или выберите пункт Конвертировать в черно-белое в меню Страница главного окна программы или контекстного меню.
Как исправить перекос изображения
В окне изображений выделите страницы, для которых нужно исправить перекос, и нажмите кнопку [image] или выберите пункт Исправить перекос в меню Страница главного окна программы или контекстного меню.
Как очистить изображение от «мусора»
Изображение может быть сильно «замусорено», т.е. содержать много лишних точек, возникших в результате сканирования документов среднего или низкого качества. Чтобы уменьшить количество лишних точек, в окне изображений выделите страницы, которые нужно очистить от мусора, и нажмите кнопку [image] или выберите пункт Очистить от мусора в меню Страница главного окна программы или контекстного меню.

Внимание! Если исходный текст был очень светлым или в исходном тексте использовался очень тонкий шрифт, то применение функции Очистить от мусора может привести к исчезновению точек, запятых или тонких элементов букв.

Как редактировать изображение с помощью заливки
  1. В окне изображений выделите страницу, которую нужно редактировать.
  2. Нажмите кнопку [image] или выберите пункт Скрыть данные в меню Страница главного окна программы или контекстного меню.
  3. Установите курсор мыши в угол области, которую вы хотите залить цветом, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол. Область будет залита цветом. Цвет заливки вы можете задать в диалоге Настройки (Сервис > Настройки… > Общие > Цвет для скрытия данных).
Как изменить масштаб изображения в окне изображений
Вы можете изменять масштаб изображений в окне изображений различными способами:
  • при помощи выпадающего списка в строке состояния главного окна,
  • нажмите Ctrl+Num+ для увеличения масштаба изображения или Ctrl+Num- для уменьшения масштаба,
  • нажмите Ctrl и, не отпуская клавиши, поверните колесико мыши,
  • выберите в меню Вид > Масштаб нужный масштаб,
  • для перехода в режим показа одной страницы щелкните дважды по странице в окне изображений или в окне Пакеты.
Как изменить разрешение изображения
  1. В окне изображений или окне Пакеты выделите страницы, разрешение которых нужно изменить.
  2. Выберите пункт Изменить разрешение… в меню Страница главного окна программы или в контекстном меню.
  3. В открывшемся диалоге Установите разрешение укажите нужное разрешение.


Как экспортировать пакет

После завершения сканирования и распределения страниц по документам и пакетам, пакеты могут быть сохранены в локальной папке, папке на FTP-сервере, отправлены для дальнейшей обработки в ABBYY FlexiCapture 10 или сохранены с помощью скрипта. При экспорте вместе в локальную папку или в папку на FTP-сервере вместе с файлами изображений создается файл описания вида <Название пакета>.xml, содержащий информацию о пакете (название, тип, регистрационные параметры и список документов).

Для каждого направления экспорта предусмотрены свои настройки. Чтобы настроить параметры экспорта, выберите меню Файл > Настройки отправки…. В открывшемся диалоге перейдите на закладку нужного направления экспорта:

  • Настройки отправки в папку
  • Настройки отправки в папку на FTP-сервере
  • Настройки отправки в ABBYY FlexiCapture
  • Настройки отправки скриптом

Настройки экспорта также настраиваются для каждого типа пакета.

Чтобы запустить процесс экспорта с последним выбранным направлением нажмите кнопку Отправить на панели инструментов главного окна программы.

Чтобы выбрать одно из направлений перед экспортом, нажмите на стрелку справа от кнопки Отправить на панели инструментов. Выберите нужное направление экспорта, в открывшемся диалоге настройте нужные параметры и нажмите OK для запуска процесса экспорта. Вы также можете воспользоваться меню Файл > Экспортировать пакет.

Экспортированный пакет может быть удален сразу после экспорта. Для этого выберите опцию Удалять пакет автоматически после отправки на закладке Общие диалога Настройки (Сервис > Настройки…).

Вы можете настроить параметры экспорта пакета в фоне. Для этого на закладке Задания на отправку диалога Настройки выберите нужные опции.

Чтобы отменить отправку пакета, в контекстном меню пакета выберите Отменить отправку.


Как работать с типами пакетов

Обработка пакета зависит от того, какой тип ему присвоен. Приложение позволяет создавать, изменять и удалять типы пакетов, содержащие информацию о параметрах сканирования, обработки и экспорта изображений. Созданные типы пакетов могут быть экспортированы в xml-файл для передачи другим пользователям. Для использования типов пакетов другими пользователями необходимо передать им файл с типами пакетов, который они должны импортировать в приложении.

По умолчанию в приложении существует предопределенный тип пакета с названием «Разное». Параметры предопределенного типа пакетов указываются в окне Настройки (пункт меню Серсис > Настройки…).

Приложение может работать в режимах администратора и оператора. В режиме администратора доступны все действия с типами пакетов: создание, изменение, экспорт и импорт. В режиме оператора возможен только импорт типов пакетов. Также в режиме оператора недоступен предопределенный тип пакетов "Разное".

Режим работы определяется при импорте типов пакета из файла. Если типы пакета защищены паролем, то для перехода в режим администратора необходимо ввести пароль. Для работы в режиме оператора пароль вводить не требуется.

Работа с пакетами документов состоит из следующих основных шагов:

  1. Создание типа пакета
    В меню Сервис выберите пункт Типы пакетов…. В открывшемся диалоге Типы пакетов нажмите на кнопку Новый…. Откроется Мастер создания типа пакета. Последовательно укажите необходимые настройки. Более подробную информацию о настройках вы найдете в описании Мастера создания типа пакета.
    Также вы можете создать копию имеющегося типа, выбрав его в списке и нажав кнопку Копировать. В дальнейшем созданный пакет можно отредактировать, изменив те или иные свойства.
  2. Редактирование типа пакета
    Для редактирования типа пакета выберите его в списке диалога Типы пакетов и нажмите кнопку Изменить…. Измените свойства пакета в открывшемся диалоговом окне Свойства типа пакета. Для сохранения изменений нажмите кнопку ОК.
  3. Удаление типа пакета
    Для удаления типа пакета выберите его в списке диалога Типы пакетов и нажмите кнопку Удалить. Пакетам удаленных типов присваивается тип «Разное».
  4. Экспорт типов пакетов
    Для экспорта типов пакетов выберите типы, которые необходимо экспортировать, в списке диалогового окна Типы пакетов и нажмите кнопку Экспорт…. В открывшемся диалоговом окне Экспорт типов пакетов укажите, какие типы необходимо экспортировать (все или только выбранные в списке). При необходимости защитить типы пакетов от изменения отметьте опцию Запретить изменение типов пакетов и дважды введите пароль. Нажмите кнопку ОК и в открывшемся диалоге Выбор хранилища типов пакетов выберите место хранения XML-файла с описанием типов пакетов.
  5. Импорт типов пакетов
    Для импорта типов пакетов откройте диалоговое окно Типы пакетов (пункт меню Сервис > Типы пакетов…) и нажмите кнопку Импорт…. Если ранее в приложении были созданы или импортированы типы пакетов, будет отображено предупреждение о том, что они будут удалены. В открывшемся диалоге Выбор хранилища типов пакетов укажите путь к XML-файлу с описанием типов пакетов.
    При импорте типы пакетов, которые до того были в приложении, удаляются. Пакетам удаленных типов присваивается тип «Разное».
  6. Работа с типами пакетов, защищенными паролем
    При импорте типов пакетов, защищенных паролем, а также при попытке редактировать тип пакета, защищенный паролем, если пароль не был введен ранее, приложение предложит вам ввести пароль для перехода в режим администратора. Для продолжения работы в режиме оператора нажмите кнопку Отмена.

Типичный сценарий работы с типами пакетов следующий:

  1. Администратор создает типа пакетов и экспортирует их на сервер, указав следующие настройки:
    • если параметры типа пакета не должны быть доступны для редактирования операторами, выбирается опция Запретить изменение типов пакетов;
    • если данные типа пакета должны загружаться на все Станции сканирования, привязанные к серверу, выбирается опция Разослать эти типы пакетов на остальные станции сканирования.
  2. При запуске Станции сканирования операторы либо получают данные типа пакета автоматически (если администратором была выбрана опция Разослать эти типы пакетов на остальные станции сканирования), либо загружают типы пакетов с сервера, используя кнопку Импорт…

Замечание. При запуске приложения из командной строки можно автоматически импортировать типы пакетов из файла. Для этого используйте ключ /BatchFiles:<FilePath>\<Filename>.xml.


Интерфейс программы

Этот раздел содержит обзор основных элементов интерфейса программы:

Главное окно программы
Меню главного окна
Панели инструментов главного окна
Окно Пакеты
Окно изображений
Окно Регистрационные параметры
Диалоги


Главное окно

Главное окно программы содержит:

  • Меню главного окна
  • Панели инструментов главного окна. Позволяет полностью провести процесс сканирования документов.
  • Окно Пакеты. Отображает структуру пакетов: входящие в пакет документы и страницы.
  • Окно изображений. Отображает отсканированные изображения.
  • Окно Регистрационные параметры. Отображает регистрационные параметры пакетов и документов.


Меню главного окна Станции сканирования

Файл
Пункт меню | Описание
Новый пакет | Позволяет создать новый пакет.
Создать документ | Позволяет объединить выбранные страницы в документ.
Расформировать документ | Позволяет расформировать существующий документ: страницы, содержащиеся в документе, будут помещены в текущий пакет, а документ удален.
Сканировать страницы | Позволяет отсканировать изображения и поместить их в пакеты текущего типа.
Выбрать и сканировать… | Открывает диалог Выбрать и сканировать, в котором вы можете запустить сканирование, предварительно выбрав один из доступных источников сканирования.
Повторно сканировать страницы | Производит повторное сканирование выделенных страниц.
Вставить страницы | Позволяет выполнить сканирование изображений и поместить их в пакет после выбранной страницы.
Остановить | Позволяет остановить процесс сканирования или импорта изображений.
Загрузить изображения… | Позволяет импортировать изображения из файлов.
Экспортировать пакет |
в локальную папку… | Позволяет экспортировать пакет в локальную папку. В открывшемся диалоге Настройки отправки в папку вы можете настроить параметры экспорта.
в папку на FTP-сервере… | Позволяет экспортировать пакет в папку на FTP-сервере. В открывшемся диалоге Настройки отправки в папку на FTP-сервере вы можете настроить параметры экспорта.
в ABBYY FlexiCapture… | Позволяет экспортировать пакет в ABBYY FlexiCapture 10. В открывшемся диалоге Настройки отправки в ABBYY FlexiCapture вы можете настроить параметры экспорта.
скриптом | Позволяет экспортировать пакет с помощью скрипта. В открывшемся диалоге Настройки отправки скриптом вы можете настроить параметры экспорта.
Настройки отправки… | Открывает диалог Настройки отправки, в котором вы можете настроить параметры экспорта пакета.
Выход | Закрывает Станцию сканирования.
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие.
Восстановить | Восстанавливает отмененное действие.
Вырезать | Вырезает выделенные объекты.
Копировать | Копирует выделенные объекты в буфер обмена.
Вставить | Вставляет содержимое из буфера обмена.
Удалить | Удаляет выделенные объекты.
Выделить все | Выделяет все.
Следующий документ для пересканирования | Открывает следующий документ из задания пересканирования.
Предыдущий документ для пересканирования | Открывает предыдущий документ из задания пересканирования.
Подтвердить пересканированный документ | Подтверждает результат пересканирования документа.
Удалить пустые страницы | Позволяет удалить все пустые страницы в пакете.
Делить на документы | Позволяет выполнить разделение документов в пакете после сканирования. Разделение документов производится в соответствии с настройками, указанными в диалоге Настройки на закладке Свойства пакета, а также с настройками типа пакета, указанными при создании в Мастере создания типа пакета либо в диалоге Свойства типа пакета на закладке Пакет.
Выполнить скрипт | Запускает выполнение выбранного скрипта.
Вид
Пункт меню | Описание
Показывать пакеты | Показывает/скрывает окно Пакеты.
Показывать регистрационные параметры | Показывает/скрывает окно Регистрационные параметры.
Регистрационные параметры пакета | Переключается на закладку Пакет окна Регистрационные параметры.
Регистрационные параметры документа | Переключается на закладку Документ окна Регистрационные параметры.
Панели инструментов |
Обработка | Показывает/скрывает панель Обработка.
Редактирование пакета | Показывает/скрывает панель Редактирование пакета.
Редактирование изображения | Показывает/скрывает панель Редактирование изображения.
Навигация в документе | Показывает/скрывает панель Навигация в документе.
Повторное сканирование | Показывает/скрывает панель Повторное сканирование.
Скрипты | Показывает/скрывает панель Скрипты.
Настройка… | Открывает диалог Настройка панели инструментов.
Строка состояния | Показывает/скрывает строку состояния.
Показывать пакеты только выбранного типа | Включает/выключает режим отображения пакетов только того типа, который выбран на панели инструментов Тип пакета.
Свернуть дерево пакетов | Сворачивает дерево пакетов в окне Пакеты.
Перейти к предыдущей странице | Переводит выделение с текущей страницы на предыдущую.
Перейти к следующей странице | Переводит выделение с текущей страницы на следующую.
Перейти к предыдущему документу | Переводит выделение с текущего документа на предыдущий.
Перейти к следующему документу | Переводит выделение с текущего документа на следующий.
Масштаб | Позволяет выбрать способ отображения страниц в окне изображений.
Увеличить | Позволяет увеличить масштаб изображения в два раза.
Уменьшить | Позволяет уменьшить масштаб изображения в два раза.
В увеличенном масштабе | Показывает одну страницу в увеличенном масштабе.
Одна страница | Показывает одну страницу.
Крупные эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий крупного размера.
Средние эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий среднего размера.
Маленькие эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий малого размера.
Очень маленькие эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий особо малого размера.
Страница
Пункт меню | Описание
Повернуть на 90° по часовой стрелке | Позволяет повернуть выделенные страницы на 90° по часовой стрелке.
Повернуть на 90° против часовой стрелки | Позволяет повернуть выделенные страницы на 90° против часовой стрелки.
Повернуть на 180° | Позволяет повернуть выделенные страницы на 180°.
Зеркально отразить относительно вертикали | Позволяет отобразить выделенные страницы относительно вертикальной оси.
Зеркально отразить относительно горизонтали | Позволяет отобразить выделенные страницы относительно горизонтальной оси.
Обрезать | Позволяет обрезать выделенную страницу.
Инвертировать | Позволяет инвертировать цвета выделенных страниц.
Конвертировать в черно-белое | Позволяет конвертировать выделенные страницы в черно-белые.
Исправить перекос | Позволяет исправить перекос на выделенных страницах.
Очистить от мусора | Позволяет очистить от «мусора» изображения выделенных страниц.
Скрыть данные | Позволяет выполнить заливку цветом выделенного прямоугольника на заданной странице. Цвет заливки вы можете задать, выбрав Сервис > Настройки… > Общие > Цвет для скрытия данных.
Изменить разрешение… | Устанавливает новое разрешение (в DPI) для выбранных страниц.
Загрузить полноразмерный эскиз | Загружает эскизы выбранных страниц задания пересканирования.
Свойства | Показывает свойства выбранного элемента. Если выбрана страница, открывает диалог Свойства страницы, если выбран документ — диалог Свойства документа, если выбран пакет — диалог Свойства пакета.
Сервис
Пункт меню | Описание
Типы пакетов… | Открывает диалог Типы пакетов, который позволяет управлять типами пакетов: создавать новые типы и редактировать уже существующие, импортировать и экспортировать типы пакетов.
Задания пересканирования… | Открывает диалог Задания пересканирования, который позволяет управлять заданиями пересканирования: выбирать, отсылать, прекращать задание, а также получать информацию о пакете по его регистрационным параметрам.
Настройки… | Открывает диалог Настройки, в котором вы можете задать различные настройки такие, как параметры создания и экспорта пакета, фоновой обработка заданий и т.д.
Справка
Пункт меню | Описание
Вызов справки | Открывает справку Станции сканирования.
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы.
Как купить продукты ABBYY | Открывает страницу Как купить программу Станция сканирования ABBYY в справке программы.
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY.
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе | Открывает диалог О программе, содержащий краткую информацию о программе.


Панели инструментов главного окна

Главное окно программы содержит 7 панели инструментов:

Обработка

Позволяет провести весь процесс сканирования документов. Кнопки этой панели инструментов представляют базовые операции: сканирование, остановка сканирования и экспорт отсканированных документов.

Кнопка Описание
Позволяет начать сканирование документов из последнего выбранного источника сканирования.

Чтобы выбрать один из доступных источников сканирования, нажмите на стрелку справа от кнопки и выберите пункт Выбрать и сканировать…. В открывшемся диалоге Выбрать и сканировать выберите один из доступных источников.
Останавливает процесс сканирования. Эта кнопка заменяет кнопку Сканировать во время сканирования.
Экспортирует документы, используя выбранное направление экспорта. Название используемого направления отображается при наведении курсора на кнопку.

Нажмите на стрелку справа от кнопки, чтобы выбрать одно из следующих направлений:

  • Отправить в папку…
    Позволяет экспортировать пакет в локальную папку.
  • Отправить в папку на FTP-сервере…
    Позволяет экспортировать пакет в папку на FTP-сервере.
  • Отправить в FlexiCapture…
    Позволяет экспортировать пакет в ABBYY FlexiCapture.
  • Отправить скриптом…
    Позволяет экспортировать пакет с помощью скрипта.

При выборе профиля открывается диалог настроек экспорта для выбранного профиля. Укажите необходимые параметры, затем нажмите OK для запуска процесса экспорта.

Тип пакета

Позволяет выбрать текущий тип пакета, посмотреть его свойства и выбрать режим отображения пакетов в окне Пакеты.

Кнопка | Описание
Current Batch Type (выпадающий список) | Позволяет выбрать текущий тип пакета. Изначально в программе задан один тип пакета Разное, настройки которого используются по умолчанию.
 | Открывает диалог Свойства типа пакета, в котором вы можете посмотреть и отредактировать настройки выбранного типа пакета. Эта кнопка недоступна для пакетов типа Разное. Чтобы посмотреть настройки, используемые по умолчанию, выберите меню Сервис > Настройки…
 | Нажмите эту кнопку, чтобы в окне Пакеты отображались только пакеты текущего типа.

Замечание: Эта панель инструментов скрыта, если в программе не задано ни одного пользовательского типа пакета.

Редактирование пакета

Предоставляет основные инструменты для работы со структурой пакетов.

Название | Кнопка | Описание
Создать новый пакет |  | Создает новый пакет текущего типа. Имя пакета определяется схемой именования пакетов, указанной в настройках типа пакета. Чтобы изменить имя пакета выделите пакет в окне Пакеты, затем нажмите левую кнопку мыши или кнопку F2.
Создать новый документ |  | Создает в текущем пакете новый документ, содержащий выбранные страницы. Имя документа определяется схемой именования пакетов, указанной в настройках типа пакета. Чтобы изменить имя документа, выделите его в окне Пакеты, затем нажмите левую кнопку мыши или кнопку F2.
Расформировать документ |  | Позволяет расформировать существующий документ: страницы, содержащиеся в документе, будут помещены в текущий пакет, а документ удален.
Удалить |  | Удаляет выделенные объекты.
Обработка страниц

Предоставляет основные инструменты для работы с изображениями.

Название | Кнопка | Описание
Повторно отсканировать |  | Производит повторное сканирование выделенных страниц.
Вставить страницы |  | Выполняет сканирование изображений и помещает их в пакет после выбранной страницы.
Повернуть на 90° по часовой стрелке |  | Поворачивает выделенные страницы на 90° по часовой стрелке.
Повернуть на 90° против часовой стрелки |  | Поворачивает выделенные страницы на 90° против часовой стрелки.
Повернуть на 180° |  | Поворачивает выделенные страницы на 180°.
Отразить относительно вертикальной оси |  | Отображает выделенные страницы относительно вертикальной оси.
Отразить относительно горизонтальной оси |  | Отображает выделенные страницы относительно горизонтальной оси.
Обрезать |  | Позволяет обрезать выделенную страницу.
Инвертировать |  | Инвертирует цвета выделенных страниц.
Конвертировать в черно-белое |  | Конвертирует выделенные страницы в черно-белые.
Исправить перекос |  | Исправляет перекос на выделенных страницах
Очистить от мусора |  | Очищает от «мусора» изображения выделенных страниц.
Скрыть данные |  | Позволяет выполнить заливку цветом выделенного прямоугольника на заданной странице. Цвет заливки вы можете задать, выбрав Сервис > Настройки… > Общие > Цвет для скрытия данных.
Навигация в документе

Предоставляет инструменты для навигации в документе.

Название | Кнопка | Описание
Перейти к предыдущему документу |  | Переводит выделение с текущего документа на предыдущий.
Перейти к следующему документу |  | Переводит выделение с текущего документа на следующий.
Пересканирование

Предоставляет инструменты для обработки заданий пересканирования.

Название | Кнопка | Описание
Задания пересканирования |  | Открывает диалог Задания пересканирования.
Предыдущий документ для пересканирования |  | Переводит выделение на предыдущий документ в задании пересканирования.
Следующий документ для пересканирования |  | Переводит выделение на следующий документ в задании пересканирования.
Подтвердить пересканированный документ |  | Подтверждает результат пересканирования документа.

Сообщение Доступны новые задания на пересканирование… появляется при получении с сервера информации о новых заданиях пересканирования. При нажатии на ссылку открывается диалог Задания пересканирования.

Скрипты

Позволяте запускать скрипты, соответствующие кнопкам на панели.

Вы можете настроить панель Скрипты в диалоге Настройка панели инструментов.


Окно: Пакеты

Окно «Пакеты»

Окно Пакеты позволяет просматривать структуру пакетов и управлять ею. Используйте кнопки панели инструментов.

Более подробную информацию о работе с пакетами и документами вы можете найти в разделе Как работать с пакетами и документами.

Страницы в окне Пакеты могут быть помечены желтым треугольником. Это означает, что разрешение, высота или ширина страницы не удовлетворяет настройкам, заданным в пакете. Посмотреть предупреждение для выбранной страницы можно в диалоге Свойства страницы. Информацию о том, как изменить разрешение страницы, вы найдете в разделе Как редактировать изображения.

Вы можете изменить размер окна Пакеты. Для этого наведите курсор на правую границу окна, нажмите левую кнопку мыши и, не отпуская кнопки, передвиньте границу. Чтобы скрыть окно, наведите курсор на правую границу окна и дважды щелкните левой кнопкой мыши. Чтобы восстановить исходное положение, дважды щелкните левой кнопкой мыши по левой границе окна изоабражений. Вы также можете использовать меню Вид > Показывать пакеты.


Окно изображений

Окно изображений показывает страницы выбранного пакета. Управлять режимом отображения страниц в окне вы можете при помощи выпадающего списка в строке состояния главного окна. Чтобы редактировать изображения, используйте кнопки панели инструментов.

Более подробную информацию о работе с изображениями вы можете найти в разделе Как редактировать изображения.


Окно Регистрационные параметры

Окно Регистрационные параметры отображает регистрационные параметры пакетов и документов. Вы можете переключаться между закладками Пакет и Документ, чтобы просматривать регистрационные параметры пакета или документа. На закладке Документ вы также можете изменять регистрационные параметы документа.

Вы можете изменить размер окна Регистрационные параметры. Для этого наведите курсор на левую границу окна, нажмите левую кнопку мыши и, не отпуская кнопки, передвиньте границу. Чтобы скрыть окно, наведите курсор на левую границу окна и дважды щелкните левой кнопкой мыши. Чтобы восстановить исходное положение, дважды щелкните левой кнопкой мыши по левой границе окна изоабражений. Вы также можете использовать меню Вид > Показывать регистрационные параметры.

Более подробную информацию о работе с регистрационными параметрами вы можете найти в разделе Указание регистрационных параметров.


Диалоги Станции сканирования

Этот раздел содержит описание диалогов Станции сканирования:

Диалоги настроек сканирования и экспорта
Диалог «Выбрать и сканировать»
Настройки сканера
Диалог «Настройки отправки в папку»
Диалог «Настройки отправки в папку на FTP-сервере»
Диалог «Настройки отправки в ABBYY FlexiCapture»
Диалог «Настройки отправки скриптом»
Обработка заданий отправки
Диалоги настроек для обработки типовых пакетов
Мастер создания типа пакета
Свойства типа пакета
Диалог «Типы пакетов»
Общие настройки типа пакета
Настройки сканирования типового пакета
Параметры разделения типового пакета
Диалог «Настройка определения пустой страницы»
Настройка параметров обработки изображений
Настройка параметров отправки
Диалог «Настройка формата изображений»
Настройка скриптов
Контроль параметров страниц
Настройка регистрационных параметров
Диалог «Указание регистрационных параметров»
Диалог «Регистрационный параметр»
Настройки типов пакетов
Хранилище типов пакетов
Другие диалоги
Настройки
Общие параметры обработки
Диалог «Настройка панели инструментов»
Диалог «Редактор скрипта»
Диалог «Свойства пакета»
Диалог «Свойства документа»
Диалог «Свойства страницы»
Диалог "Задания отправки"


Диалог: Выбрать и сканировать

Диалог «Выбрать и сканировать»

В этом диалоге вы можете выбрать источник сканирования: реальный или виртуальный сканер. В зависимости от выбранного источника сканирования изменяется вид диалога. Этот диалог открывается при сканировании с выбором источника сканирования: нажмите на стрелку слева от кнопки Сканировать на панели инструментов и выберите пункт Выбрать и сканировать….

В выпадающем списке Сканер выберите один из доступных сканеров и укажите необходимые настройки.

Для реального сканера...
Опция | Описание опции
Использовать интерфейс сканера | Выберите эту опцию, чтобы использовать интерфейс сканера при сканировании. Замечание. Если используется интерфейс сканер, следует также отметить опцию Показывать настройки сканера перед сканированием. Иначе, если настройки сканирования в интерфейсе сканера изначально не заданы, при сканировании будет возникать сообщение об ошибке.
Использовать интерфейс программы | Выберите эту опцию, если вы хотите использовать интерфейс программы при сканировании.
Настройки сканера… | Открывает диалог настроек сканера. В случае выбора интерфейса сканера для настройки опций сканирования будет использоваться диалог соответствующего драйвера сканера. Если выбран программный интерфейс, для настройки опций сканирования используется диалог программы.
Показывать настройки сканера перед сканированием | Если выбрана эта опция, каждый раз перед началом сканирования программа будет показывать диалог настроек сканера.
Для виртуального сканера...

Опция | Описание опции
Папка | Укажите путь к папке, из которой должны быть импортированы изображения. Вы можете выбрать нужную папку при помощи кнопки Обзор….
Обзор… | Используйте эту кнопку для поиска нужной папки с изображениями.
Удалять успешно загруженные файлы | Выберите эту опцию, если изображения должны быть удалены из исходной папки после загрузки.

Нажмите Сканировать для запуска процесса сканирования. Нажмите Отмена для выхода из диалога.


Диалог настроек сканера

Этот диалог позволяет настроить сканер перед сканированием, если выбран интерфейс сканирования станции сканирования.

Настройте разрешение, цветовой тип и яркость поступающих изображений, используемые сжатие и поворот, выберите нужный размер бумаги. Настройте параметры многостраничного сканирования, если требуется. Нажмите Предварительный просмотр для пробного сканирования страницы. После завершения сканирования в окне над кнопкой появится изображение отсканированной страницы. Отредактируйте выбранные настройки, если требуется. Нажмите Закрыть для возвращения к настройкам сканирования.

Замечание. Пробное сканирование страницы и предварительный просмотр отсканированного изображения недоступны для сканеров с поддержкой ISIS.
Опция | Описание опции
Группа «Настройки сканера»
Разрешение (выпадающий список) | Позволяет установить разрешение отсканированных изображений. Выбирайте более высокое значение разрешения для текстов с небольшим размером шрифта.
Цвет (выпадающий список) | Позволяет выбрать цветовой тип отсканированных изображений. Для последующего распознавания изображений наиболее подходит сканирование в сером.
Сжатие (выпадающий список) | Позволяет выбрать режим сжатия отсканированных изображений.
Поворот (выпадающий список) | Позволяет поворачивать отсканированные изображения на заданный угол.
Яркость (выпадающий список) | Выберите автоматическую настройку яркости изображения или настройте яркость вручную. Для изменения яркости при ручной настройке передвигайте индикатор, расположенный под выпадающим списком.
Группа «Формат бумаги»
Размер (выпадающий список) | Позволяет выбрать размер бумаги. Замечание. Если вы не нашли нужный размер бумаги в списке, вы можете создать свой – пользовательский – размер бумаги. Для этого выберите пункт Пользовательский… из списка, в открывшемся диалоге Размер бумаги укажите высоту и ширину пользовательского размера бумаги.
Группа «Многостраничное сканирование»
Использовать автоподатчик | Выберите эту опцию, если используется сканер с автоподатчиком.
Двустороннее сканирование | Выберите эту опцию при двустороннем сканировании.
Остановка на N секунд после каждой страницы | Выберите эту опцию, если вы хотите, чтобы сканирование останавливалось на N секунд после каждой страницы. Укажите нужное количество секунд. Опция активна только для планшетных сканеров.
Предварительный просмотр (кнопка) | Нажмите на эту кнопку для запуска пробного процесса сканирования. После завершения сканирования в окне над кнопкой появится изображение отсканированной страницы. Эта кнопка и изображение отсканированной страницы недоступны для сканеров с поддержкой ISIS.


Диалог: Настройки отправки в папку

Диалог «Настройки отправки в папку»

В этом диалоге вы можете настроить параметры экспорта пакетов в папку. Чтобы настроить необходимые параметры, выберите меню Файл > Настройки отправки…, в открывшемся диалоге перейдите на закладку Папка. Этот диалог также может быть открыт при выборе направления экспорта Отправить в папку… при нажатии на стрелку справа от кнопки Отправить панели инструментов главного окна программы.

Укажите путь к папке, в которой должны быть сохранены пакеты документов, а также выберите нужный формат выходных файлов.

Опция | Описание опции
Группа «Выходная папка»
Папка | Укажите путь к папке, в которой должны быть сохранены пакеты документов. Вы можете выбрать существующую папку при помощи кнопки Обзор….
Обзор…
(кнопка) 		Позволяет выбрать существующую папку для экспорта.
Группа «Настройки формата»
Формат
(выпадающий список) 		Определяет формат файлов:
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
Цвет
(выпадающий список) 		Определяет цветовой тип изображения:
  • Цветной
  • Серый
  • Черно-белый
Качество
(выпадающий список) 		Определяет качество сохраняемого изображения:
  • Наилучшее
  • Высокое
  • Среднее
  • Низкое
Настройки для многостраничных форматов Выберите режим сохранения документов в пакете:
  • Сохранять документы в виде многостраничных файлов
    Позволяет сохранять документы в виде многостраничных файлов. Эта опция доступна только для форматов TIFF, DCX packbits и PDF.
  • Сохранять документы в виде папок
    Позволяет сохранять документы в виде папок. В этом случае страницы документа будут представлены отдельными файлами выбранного формата.
Показывать настройки перед отправкой | Если вы хотите использовать те же настройки при следующем экспорте пакетов в локальную папку, отключите эту опцию. В этом случае данный диалог не будет показан при следующем запуске процесса экспорта.


Диалог: Настройки отправки в папку на FTP-сервере

Диалог «Настройки отправки в папку на FTP-сервере»

В этом диалоге вы можете настроить параметры экспорта пакетов в папку на FTP-сервере. Чтобы настроить необходимые параметры, выберите меню Файл > Настройки отправки…, в открывшемся диалоге перейдите на закладку FTP. Этот диалог также может быть открыт при выборе направления экспорта Отправить в папку на FTP-сервере… при нажатии на стрелку справа от кнопки Отправить панели инструментов главного окна программы.

Укажите имя папки на FTP-сервере, в которой должны быть сохранены пакеты изображений, имя пользователя и пароль или выберите опцию Анонимный вход. Укажите нужный формат выходных файлов.

Опция | Описание опции
Группа «Настройки FTP-вервера»
URL | Укажите адрес FTP-сервера, на которой должны быть сохранены пакеты изображений.
Имя | Укажите имя пользователя.
Пароль | Введите пароль.
Анонимный вход | Используйте эту опцию для анонимного доступа к FTP-серверу.
Группа «Настройки формата»
Формат
(выпадающий список) 		Определяет формат файлов:
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
Цвет
(выпадающий список) 		Определяет цвет изображения:
  • Цветной
  • Серый
  • Черно-белый
Качество
(выпадающий список) 		Определяет качество сохраняемого изображения:
  • Наилучшее
  • Высокое
  • Среднее
  • Низкое
Настройки для многостраничных форматов Выберите режим сохранения документов в пакете:
  • Сохранять документы в виде многостраничных файлов
    Позволяет сохранять документы в виде многостраничных файлов. Эта опция доступна только для форматов TIFF, DCX packbits и PDF.
  • Сохранять документы в виде папок
    Позволяет сохранять документы в виде папок. В этом случае страницы документа будут представлены отдельными файлами выбранного формата.
Показывать настройки перед отправкой | Если вы хотите использовать те же настройки при следующем экспорте пакетов в папку на FTP-сервере, отключите эту опцию. В этом случае данный диалог не будет показан при следующем запуске процесса экспорта.


Диалог: Настройки отправки в FlexiCapture

Диалог «Настройки отправки в ABBYY FlexiCapture»

В этом диалоге вы можете настроить параметры экспорта пакетов в ABBYY FlexiCapture. Чтобы настроить необходимые параметры, выберите меню Файл > Настройки отправки…, в открывшемся диалоге перейдите на закладку FlexiCapture. Этот диалог также может быть открыт при выборе профиля экспорта Отправить в FlexiCapture… при нажатии на стрелку справа от кнопки Отправить панели инструментов главного окна приложения.

Диалог позволяет выбрать проект ABBYY FlexiCapture и пакет в нем, в который будет осуществляться экспорт.

  1. На закладке Проект FlexiCapture в поле Проект выберите файл проекта. Используйте кнопку Выбрать проект… для поиска проекта. В открывшемся диалоге диалоге Выберите удаленный проект FlexiCapture:
    Показать диалог
    • В поле Сервер укажите путь к серверу в формате http://server.
    • В диалоге Аутентификация укажите настройки подключения. Вы можете использовать аутентификацию Windows или ввести имя пользователя и пароль.

      Замечание. Для аутентификации по имени и паролю необходимо соответствующим образом настроить Internet Information Server на компьютере, на котором установлен Сервер приложений: разрешить basic-аутентификацию для папки FlexiCapture\Server. Обратитесь к администратору.

    • Нажмите кнопку Обновить проекты. В списке Проекты появятся все доступные проекты ABBYY FlexiCapture. Выберите нужный проект из списка и нажмите ОК.
  2. Укажите тип пакета и приоритет его обработки.

  3. Если вы хотите использовать те же настройки при следующем экспорте в ABBYY FlexiCapture, отключите опцию Показывать настройки перед отправкой. В этом случае данный диалог не будет показан при следующем запуске процесса экспорта.

  4. Нажмите кнопку Формат изображений…, чтобы указать настройки отправки изображений. В диалоге Формат изображений вы можете выбрать следующие настройки:
    • Формат: TIFF, BMP, JPG, JPEG2000, DCX packbits, PCX packbits, PNG, PDF
    • Цвет: Цветной, Серый, Черно-белый
    • Качество: Наилучшее, Высокое, Среднее, Низкое

    Изменение формата отправки изображений позволяет при необходимости снизить нагрузку на сеть, возникающую при передаче изображений.

  5. В случае, если для выбранного вами пакета необходимо указать регистрационные параметры, соответствующая подсказка появится на закладке Проект FlexiCapture. Чтобы указать регистрационные параметры, перейдите на закладку Регистрационные параметры. Заполните необходимые поля.
    Чтобы использовать указанные регистрационные параметры по умолчанию, выберите опцию Запомнить текущие регистрационные параметры по умолчанию.
  6. На закладке Настройки пакета укажите имя пакета и описание.


Диалог: Настройки отправки скриптом

Диалог «Настройки отправки скриптом»

В этом диалоге вы можете настроить параметры экспорта пакетов с помощью скрипта. Чтобы настроить необходимые параметры, выберите меню Файл > Настройки отправки…, в открывшемся диалоге перейдите на закладку Скрипт. Этот диалог также может быть открыт при выборе профиля экспорта Отправить скриптом… при нажатии на стрелку справа от кнопки Отправить панели инструментов главного окна приложения.

Выберите язык скрипта: JScript® или VBScript и нажмите кнопку Правка…, чтобы открыть Редактор скрипта.

Отключите опцию Показывать настройки перед отправкой, если вы хотите использовать те же настройки при следующем экспорте с помощью скрипта. В этом случае данный диалог не будет показан при следующем запуске процесса экспорта.


Закладка "Задания на отправку" диалога "Настройки"

Закладка «Задания на отправку» диалога «Настройки»

На этой закладке вы можете настроить параметры обработки заданий экспорта. Чтобы настроить необходимые параметры, выберите меню Сервис > Настройки…, в открывшемся диалоге перейдите на закладку Задания на отправку.

Опция | Описание опции
Удалять завершенные задания из списка | Позволяет удалять успешно завершенные задания из списка в диалоге заданий экспорта. В этом диалоге содержится информация о пакетах, которые отправлены на экспорт, состоянии задания, времени его запуска и проценте выполненной работы. Диалог можно открыть во время экспорта или после его окончания, щелкнув ярлык, расположенный в зоне уведомлений панели заданий Windows.
Показывать подсказку, когда задание... Позволяет включить показ всплывающих сообщений в случае, если:
  • Запущено
    Выполнение задания началось.
  • Остановлено из-за ошибки
    При выполнении задания возникла ошибка.
  • Завершено
    Выполнение задания завершено.
Время отправки | Позволяет указать время, когда будет осуществляться ежедневная отправка пакетов в ABBYY FlexiCapture. После того как задано время отравки, выберите пакет, который вы хотите отправить, и нажмите кнопку Отправить на главной панели либо выберите соответствующий пункт в меню. Пакеты, ожидающие отравки, отмечены значком [image].
При ошибках повторять отправку задания по сети каждые... Позволяет указать параметры повторной отправки задания по сети в случае ошибки:
  • n мин
    Повторная отправка задания по сети будет произведена через n минут.
  • Количество попыток
    Сколько попыток отправить задание будет сделано.


Мастер создания типа пакета

Мастер создания типа пакета открывается при нажатии на кнопку Новый… в диалоге Типы пакетов.

Мастер создания типа пакета последовательно предлагает вам настроить следующие параметры создания типового пакета:

  • Источник сканирования
  • Настройки разделения документов и пакетов
  • Настройки обработки изображений
  • Настройки экспорта
  • Скрипты
  • Регистрационные параметры пакета
  • Регистрационные параметры документов
  • Контроль параметров страниц
  • Имя типа пакета и комментарий

После завершения настройки типа пакета он может быть выбран в качестве текущего. Для редактирования типа пакета откройте диалог Типы пакетов, выберите пакет и нажмите кнопку Изменить….


Диалог: Свойства типа пакета

Диалог «Свойства типа пакета»

Этот диалог позволяет редактировать настройки типа пакета:

  • общие настройки (закладка Общие);
  • настройки сканера (закладка Сканирование);
  • настройки разделения документов и пакетов (закладка Свойства пакета);
  • настройки обработки изображений (закладка Обработка изображений);
  • настройки экспорта (закладка Отправка);
  • настройки контроля параметров отсканированных страниц (закладка Контроль параметров страниц);
  • регистрационные параметры (закладка Регистрационные параметры пакета);
  • регистрационные параметры документов (закладка Регистрационные параметры документа).
  • скрипты (закладка Скрипты)

Чтобы изменить настройки типа пакета, выберите нужный тип в выпадающем списке Текущий тип пакета на панели инструментов и нажмите кнопку Настройки типа пакета.


Диалог: Типы пакетов

Диалог «Типы пакетов»

В этом диалоге вы можете управлять типами пакетов: создавать новые пакеты, копировать их, редактировать, удалять, экспортировать и импортировать. Чтобы открыть этот диалог, выберите меню Сервис > Типы пакетов….

В списке указаны имя типа пакетов и источник сканирования, который он использует. Используйте кнопки справа от списка для управления типами пакетов.

Опция | Описание опции
Новый… | Запускает Мастер создания типа пакета, который позволяет создать новый тип пакета.
Копировать Копирует выделенный тип пакета.
Изменить… | Позволяет редактировать существующий тип пакета.
Удалить | Удаляет выделенный тип пакета.
Экспорт… Открывает диалог Экспорт типов пакетов, в котором вы можете настроить параметры экспорта типов пакетов.

Выберите какие типы пакетов вы хотите экспортировать (Экспортировать все типы пакетов или Экспортировать выбранные типы пакетов).

Вы можете запретить изменение типов пакетов, для этого выберите Запретить изменение типов пакетов, введите пароль и подтвердите его. В этом случае при импорте этих типов пакетов или попытке их редактировать после импорта будет запрошен пароль.

Нажмите OK и в открывшемся диалоге Выбор хранилища типов пакетов выберите место хранения XML-файла с описанием типов пакетов.
Импорт… Позволяет импортировать типы пакетов из XML-файла. В открывшемся диалоге Выбор хранилища типов пакетов укажите путь к XML-файлу с описанием типов пакетов.
Внимание! При импорте типов пакетов все существующие типы пакетов удаляются.
Закрыть | Закрывает диалог.


Имя типа пакета и комментарий

Имя типа и комментарий могут быть заданы при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа пакета на закладке Общие диалога Свойства типа пакета.

Укажите имя типа пакета и, если необходимо, комментарий.


Выбор источника сканирования

Источник сканирования может быть выбран как для отдельного пакета, так и для группы пакетов определенного типа. В первом случае, настройки могут быть указаны на закладке Сканирование диалога Настройки. Источник сканирования для типового пакета может быть задан при создании типа пакета при помощи Мастера создания типа пакета, а также может быть изменен после создания типа пакета на закладке Сканирование диалога Свойства типа пакета.

Чтобы настроить необходимые параметры:

  1. Выберите один из доступных сканеров. Вы также можете выбрать виртуальный сканер для импорта изображений из папки.
  2. В зависимости от выбранного источника сканирования, укажите нужные настройки:
    • Для реального сканера
      Выберите интерфейс, который будет использоваться для сканирования. Вы можете выбрать интерфейс сканера или интерфейс программы. Настройки сканирования доступны при нажатии на кнопку Настройки сканера…. В случае выбора интерфейса сканера для настройки опций сканирования будет использоваться диалог соответствующего драйвера сканера. Если выбран интерфейс программы, для настройки опций сканирования используется диалог программы.
      Укажите, следует ли показывать диалог настроек сканера каждый раз перед началом сканирования. Используйте опцию Показывать настройки сканера перед сканированием.

    • Для виртуального сканера
      Укажите путь к папке, из которой должны быть импортированы изображения. Вы можете выбрать нужную папку при помощи кнопки Обзор….
      В случае если изображения должны быть удалены из исходной папки после загрузки, выберите опцию Удалять успешно загруженные файлы.

  3. Отметьте опцию Использовать указанные параметры сканирования, для того чтобы автоматически запускать процесс сканирования при нажатии кнопки Сканировать страницы или выборе соответствующей команды в меню Файл. Изображения будут отсканированы с указанными настройками.
    Если опция не отмечена, программа будет предлагать вам выбрать сканер и указать настройки сканирования каждый раз при запуске сканирования.


Настройка параметров разделения документов и пакетов

Настройки разделения и именования пакетов и документов могут быть выбраны как для отдельного пакета, так и для группы пакетов определенного типа. В первом случае, настройки могут быть указаны на закладке Пакет диалога Настройки. Настройки для определенного типа пакета могут быть заданы при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа пакета на закладке Свойства пакета диалога Свойства типа пакета.

Укажите параметры разделения и именования пакетов и документов.
Опция | Описание опции
Группа «Разделение пакетов»
Схема именования… Открывает диалог Имя пакета, в котором вы можете настроить параметры именования пакетов для выбранного типа пакетов.

Укажите правило именования пакетов в поле Схема именования пакетов. Введенный шаблон будет использоваться при создании новых пакетов.

В правило могут быть включены текущее время, дата, тип пакета, автоматическая нумерация и регистрационные параметры. Чтобы включить в схему эти элементы, отметьте опции Время, Дата, Тип пакета, Номер пакета, соответственно. Эти элементы помещаются в угловые скобки <>. Остальные элементы должны быть напечатаны без угловых скобок. Элементы без угловых скобок используются в имени пакета без изменений.
Например: Batch_<T> – имя нового пакета будет содержать префикс «Batch_» и текущее время.

Создавать новый пакет Позволяет выбрать условие, при котором будет создаваться новый пакет при сканировании:
  • Никогда
    Все отсканированные изображения помещаются в один пакет.
  • Каждый раз при запуске процесса сканирования
    Новый пакет создается при каждом запуске процесса сканирования.
  • Каждые N страниц
    Каждый пакет содержит N страниц.
Группа «Разделение документов»
Схема именования… Открывает диалог Имя документа, где вы можете настроить параметры именования документов для выбранного типа пакетов.

Укажите правило именования документов в поле Схема именования документов. Введенный шаблон будет использоваться при создании новых документов.

В правило могут быть включены текущее время, дата, значение разделительного штрих-кода, автоматическая нумерация и имя пакета. Чтобы включить в схему эти элементы, отметьте опции Время, Дата, Значение штрих-кода, Номер, Имя пакета, соответственно. Эти элементы помещаются в угловые скобки <>. Остальные элементы должны быть напечатаны без угловых скобок. Элементы без угловых скобок используются в имени пакета без изменений.
Например: Document_<T> – имя нового документа будет содержать префикс «Document_» и текущее время.

Создавать новый документ Позволяет выбрать условие, при котором будет создаваться новый документ при сканировании:
  • Никогда
    Все отсканированные изображения помещаются в пакет, новые документы не создаются.
  • Каждые N страниц
    Каждый документ содержит N страниц.
  • Для страниц, разделенных...
    Новый документ создается при обнаружении в пакете пустой страницы или страницы со штрих-кодом (выберите нужную опцию в выпадающем списке).
    Если вы выбрали разделение документов при помощи пустых страниц, вы можете настроить параметры определения пустой страницы в диалоге Настройка определения пустой страницы, открывающемся при нажатии на кнопку Настройки….
    Если вы выбрали разделение документов при помощи штрих-кодов, вы можете указать тип и значение штрих-кода в диалоге Параметры штрих-кода, открывающемся при нажатии на кнопку Настройки… Значение штрих-кода можно указать также с помощью маски, где символ "?" обозначает один произвольный символ, а символ "*" - любое количество символов.
    Если выбран тип штрих-кода Определять автоматически, новый документ будет создаваться при обнаружении штрих-кода любого поддерживаемого типа.
    Замечание. Типы штрих-кодов QR Code, Aztec и DataMatrix нужно указывать явно. При выборе типа Определять автоматически штрих-коды данных типов обнаруживаться не будут.
Удалять страницы-разделители | Позволяет удалять пустые страницы или страницы со штрих-кодами, использованные для разделения документов.


Настройка параметров обработки изображений

Параметры обработки изображения могут быть настроены как для отдельного пакета, так и для группы пакетов определенного типа. В первом случае, настройки могут быть указаны на закладке Обработка изображений диалога Настройки. Для пакетов определенного типа настройки могут быть указаны при создании типа пакета в Мастере создания типа пакета или после создания типа пакета на закладке Обработка изображений диалога Свойства типа пакета. Предварительная обработка может значительно замедлять процесс импорта изображений.

Выберите настройки обработки изображений.
Опция | Описание опции
Очищать от мусора | Позволяет очищать изображения от мусора. Выберите эту опцию, если изображения сильно «замусорены», т.е. содержат много лишних точек, возникших в результате сканирования документов среднего или низкого качества.
Конвертировать в черно-белые | Конвертирует изображения в черно-белые.
Поворачивать изображения на Позволяет поворачивать изображения на:
  • 90° по часовой стрелке
  • 90° против часовой стрелки
  • 180°
Исправлять перекос | Позволяет выравнивать перекос изображений. Выберите способ выравнивания: по разделителям, по черным квадратам, или оба способа одновременно.


Настройка параметров экспорта типового пакета

Настройки экспорта для выбранного типа пакета могут быть заданы при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа пакета на закладке Отправка диалога Свойства типа пакета.

Выберите следует ли экспортировать пакеты данного типа всегда в выбранное направление экспорта и настройте необходимые параметры.
Опция | Описание опции
Отправлять по указанному направлению | Отметьте эту опцию, если вы хотите экспортировать пакеты данного типа в одном и том же направлении экспорта.
Направление отправки | Выберите направление экспорта: папку, папку на FTP-сервере, ABBYY FlexiCapture или скриптовый экспорт.
Опции экспорта Эта группа содержит настройки для выбранного направления экспорта. Подробное описание настроек вы можете найти в диалогах:
  • Настройки отправки в папку
  • Настройки отправки в папку на FTP-сервере
  • Настройки отправки в ABBYY FlexiCapture
  • Настройки отправки скриптом

Замечание. При настройке экспорта в ABBYY FlexiCapture регистрационные параметры пакетов данного типа можно импортировать непосредственно оттуда. Для этого после выбора проекта ABBYY FlexiCapture и типа пакета в нем нажмите кнопку Импорт регистрационных параметров.


Настройка скриптов

Добавление, удаление и редактирование скриптов может осуществляться как для отдельного пакета, так и для группы пакетов определенного типа. В первом случае настройка осуществляется на закладке Скрипты диалога Настройки. Настройки для определенного типа пакета могут быть заданы при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть после создания типа пакета на закладке Скрипты диалога Свойства типа пакета.

В окне отображается имя скрипта и событие, по которому он запускается.

Для добавления скрипта нажмите Новый….

Чтобы отредактивать скрипт, нажмите Правка…. Откроется Редактор скрипта.

Для удаления выделенного скрипта нажмите Удалить.

Нажмите кнопку Настроить панель инструментов…, чтобы открыть диалог Настройка панели инструментов.

Замечание: Кнопка неактивна, если для данного типа пакета не добален ни один скрипт.

Добавленные скрипты можно запустить, выбрав команду Выполнить скрипт в меню Правка. В открывшемся диалоге Выполнить скрипт выберите скрипт из списка скриптов, доступных для данного типа пакета, и нажмите OK. Вы также можете запустить скрипт нажатием соответствующей кнопки на панели Скрипты.

Более подробную информацию о скриптах в Станции Сканирования ABBYY вы можете найти в разделе Использование скриптов.


Контроль параметров страниц

Вы можете настроить желаемые разрешение, высоту и ширину страниц в пакете. Если параметры страницы не соответствуют указанным в настройках, данная страница будет помечена желтым треугольником предупреждения в окне Пакеты. Посмотреть предупреждение можно в диалоге Свойства страницы.

Вы можете контролировать параметры страниц как для отдельного пакета, так и для группы пакетов определенного типа. В первом случае, настройки могут быть указаны на закладке Контроль параметров страниц диалога Настройки. Для пакетов определенного типа настройки могут быть указаны при создании типа пакета в Мастере создания типа пакета или после создания типа пакета на закладке Контроль параметров страниц диалога Свойства типа пакета.

Отметьте необходимые параметры и выберите пределы, в которых они могут изменяться.
Опция | Описание опции
Разрешение | Позволяет контролировать разрешение изображения в точках на дюйм (dpi).
Высота | Позволяет контролировать высоту изображения в пикселях.
Ширина | Позволяет контролировать ширину изображения в пикселях.


Настройка регистрационных параметров

Регистрационные параметры могут быть настроены для пакетов и документов.

Регистрационные параметры типового пакета и его документов могут быть настроены при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа пакета на закладках Регистрационные параметры и Регистрационные параметры документа диалога Свойства типа пакета.

В диалоге доступна следующая информация о регистрационных параметрах:

  • имя параметра
  • является ли он обязательным
  • является ли он доступным только для чтения
  • значение параметра
  • комментарий

Чтобы создать новый параметр, нажмите на кнопку Новый…. В открывшемся диалоге Регистрационный параметр укажите нужные параметры.

Чтобы изменить параметр нажмите кнопку Правка…. Вы можете удалить параметр, нажав Удалить.

Указанные регистрационные параметры пакета будут предложены оператору для заполнения или проверки при создании нового пакета. Регистрационные параметры пакета также могут быть заполнены после создания пакета в диалоге Свойства пакета. Регистрационные параметры документа заполняются после создания документа в диалоге Свойства документа.


Закладка «Сервер FlexiCapture» диалога «Настройки»

На этой закладке вы можете указать адрес сервера FlexiCapture, на котором хранятся настройки типов пакетов. Чтобы настроить необходимые параметры, выберите меню Сервис > Настройки…, в открывшемся диалоге перейдите на закладку Сервер FlexiCapture.

Опция | Описание опции
Сервер: [http://server] | Укажите путь к серверу в формате http://server.
Аутентификация… | Открывает диалог Аутентификация, в котором вы можете указать информацию, необходимую для подключению к серверу. Вы можете использовать аутентификацию Windows или ввести имя пользователя и пароль. Для аутентификации по имени и паролю необходимо соответствующим образом настроить Internet Information Server на компьютере, на котором установлен Сервер приложений: разрешить basic-аутентификацию для папки FlexiCapture\Server. Обратитесь к администратору.
Проверить cоединение | Позволяет проверить соединение с сервером.
Автоматически обновлять типы пакетов при запуске | Выберите эту опцию, если вы хотите, чтобы список типов пакетов автоматически обновлялся всякий раз при запуске Станции сканирования. Укажите файл, который следует использовать для обновления списка, в поле Источник: ([http://server][/file.xml]).
Загружать пересканируемые страницы без эскизов | Отметьте эту опцию, чтобы загружать пересканируемые страницы без эскизов.


Диалог Выбор хранилища типов пакетов

Диалог «Выбор хранилища типов пакетов»

Этот диалог позволяет выбрать место хранения XML-файла с описанием типов пакетов. Этот диалог открывается при импорте или экспорте типов пакетов (подробнее смотрите в описании диалога Типы пакетов).

XML-файл с описанием типов пакетов может храниться локально на том же компьютере, на котором установлена Станция сканирования ABBYY, или на удаленном сервере. Выберите место хранения файла Локальный файл или Удаленное.

Для локального файла укажите путь к нему в поле Путь. Используйте кнопку Обзор… для поиска нужного файла.

Для удаленного файла укажите путь в формате http://server[/file.xml].

При экспорте типа пакетов можно отметить опцию Разослать эти типы пакетов на остальные станции сканирования. При включении этой опции все станции сканирования, привязанные к данному серверу, при запуске будут обращаться на сервер для скачивания данных типов пакетов. Если опция отключена, то станции сканирования не будут обращаться на сервер для получения типов пакетов.


Диалог: Настройки

Диалог «Настройки»

Этот диалог позволяет редактировать общие настройки программы:

  • цвет линии обрезки, цвет заливки и поведение программы при нажатии на кнопку сканера (закладка Общие);
  • параметры сканирования (закладка Сканирование);
  • параметры создания и именования пакетов и документов (закладка Свойства пакета);
  • параметры обработки изображений (закладка Обработка изображений);
  • параметры отсканированных страниц (закладка Контроль параметров страниц);
  • параметры конфигурации скриптов (закладка Скрипты)
  • параметры обработки заданий экспорта (закладка Задания на отправку);
  • адрес сервера FlexiCapture ( закладка Сервер FlexiCapture).

Чтобы открыть этот диалог, выберите меню Сервис > Настройки….


Закладка «Общие» диалога «Настройки»

На этой закладке вы можете настроить общие параметры обработки. Чтобы настроить необходимые параметры, выберите меню Сервис > Настройки…, в открывшемся диалоге перейдите на закладку Общие.

Опция | Описание опции
Идентификатор станции | Идентификатор станции.
Цвет линии обрезки | Позволяет установить цвет линии обрезки изображения. Нажмите на кнопку с изображением цвета для выбора нужного цвета.
Цвет для скрытия данных | Позволяет установить цвет заливки, используемый для редактирования изображения (меню Страница > Скрыть данные). Нажмите на кнопку с изображением цвета для выбора нужного цвета.
Группа «Другие настройки»
Удалять пакеты после отправки автоматически | Выберите эту опцию, если вы хотите, чтобы после экспорта пакеты были автоматически удалены.


Диалог: Свойства пакета

Диалог «Свойства пакета»

Этот диалог позволяет посмотреть свойства выбранного пакета.

Чтобы открыть этот диалог, в меню быстрого доступа пакета выберите Свойства, или выберите меню Страница > Свойства, или нажмите Alt+Enter.

Закладка Описание
Общие Отображает общие свойства пакета: имя, приоритет, тип, количество документов и страниц в пакете, место назначения при экспорте и время экспорта (для экспортированных пакетов). Имя, приоритет и тип пакета могут быть изменены.

Чтобы изменить тип пакета, нажмите на кнопку Изменить… и в открывшемся диалоге Выбор типа пакета выберите один из доступных типов.
Сканирование Отображает свойства прерванных заданий экспорта:
  • Назначение
    Назначение задания
  • Время
    Время начала выполнения задания
  • Прогресс
    Процент выполнения задания
  • Причина
    Причина остановки выполнения задания

Вы можете продолжить выполнение задания или удалить задание с помощью кнопок Продолжить и Удалить соответственно.
Регистрационные параметры Отображает регистрационные параметры выбранного пакета:
  • Имя
    Регистрационные параметры, обязательные для заполнения, помечены звездочкой (*).
    Пока обязательные регистрационные параметры пакета или документа не заполнены, пакет не может быть экспортирован.
  • Значение
    В этом столбце вы можете ввести значение нужного параметра.
  • Комментарий
    Комментарий может помочь при заполнении значений параметров.


Диалог: Свойства документа

Диалог «Свойства документа»

Этот диалог позволяет посмотреть и отредактировать свойства выбранного документа.

Чтобы открыть этот диалог, в меню быстрого доступа пакета выберите Свойства, или выберите меню Страница > Свойства, или нажмите Alt+Enter.

Закладка | Описание
Общие | Отображает общие свойства документа: имя, приоритет, пакет, в котором содержится документ, номер документа в пакете и число страниц. Имя и приоритет документа могут быть изменены.
Регистрационные параметры Отображает регистрационные параметры выбранного документа:
  • Имя
    Регистрационные параметры, обязательные для заполнения, помечены звездочкой (*).
    Пока обязательные регистрационные параметры пакета или документа не заполнены, пакет не может быть экспортирован.
  • Значение
    В этом столбце вы можете ввести значение нужного параметра.
  • Комментарий
    Комментарий может помочь при заполнении значений параметров.


Диалог: Задания отправки

Диалог Задания отправки позволяет просматривать свойства задания отправки. Если отправка пакета была преравана, вы можете продолжить выполнение задания либо удалить задание, нажав на кнопку Продолжить и Удалить соответственно. Вы также можете отменить задание в процессе выполнения. Для этого нажмите кнопку Отмена.

Чтобы открыть диалог Задания отправки, нажмите на иконку [image] на панели задач.

Свойство | Описание
Номер # | Номер задания
Пакет | Имя пакета
Статус | Статус выполнения задания
Время запуска | Время начала выполнения задания
Прогресс | Процент выполнения задания
Назначение | Назначение задания
Примечание | Примечание к выполнению задания


Использование скриптов в Cтанции сканирования ABBYY

С помощью скриптов вы можете создавать собственные сценарии работы со Станцией сканирования ABBYY. Некоторые из типичных сценариев работы приведены ниже:

  • Автоматически расположить страницы в правильном порядке после двустороннего сканирования
  • Автоматически разрезать крупноформатные страницы на нужное количество частей после сканирования
  • Автоматическое заполнение регистрационных параметров создаваемых пакетов и документов
  • Проверка качества страниц внешней компонентой
  • Возможность сохранять изображения в два места одновременно для хранения резервной копии

Скрипты можно выполнять как по явной команде пользователя, так и автоматически, реагируя на определенные события.

Поддерживаемые языки

Скрипты в Станции сканирования можно писать на языках JScript® и VBScript.

Особенности использования

В VBScript обязательно использование ключевого слова Me для обращения к методам и полям текущего объекта (аналог this в Java). В скриптах экспорта ключевое слово Me (VBScript) или this (Java) реализует интерфейс IExportBatch, в событийных скриптах ключевое слово Me или this реализует интерфейс IWorkSpace.

Работа с коллекциями

Все коллекции в используемой объектной модели поддерживают следующие методы:

Название | Тип | Доступ | Описание
Count | int | Read only | Число элементов коллекции
Item( index : int ) | ItemInterface | Read only | Получение элемента коллекции с заданным индексом. Нумерация начинается с нуля.

Замечание: К методам коллекции можно обращаться без метода Item, используя вместо этого круглые скобки.

Например, Items( 1 ).Text = "Hello".

Все коллекции могут использоваться в конструкциях типа for each.

Настройки в реестре

К скриптам на станции сканирования применяются следующие опции в реестре:

HKEY_CURRENT_USER\Software\ABBYY\ScanStationFC\2.0\Shell\Script\DisableDebugging

HKEY_CURRENT_USER\Software\ABBYY\ScanStationFC\2.0\Shell\Script\DisableEventScripts

По умолчанию оба ключа имеют значение "false".

Изменение значения ключа "DisableEventScripts" на true запрещает запуск новых скриптов. Прерывания ранее запущенных скриптов при этом не происходит.

Пользовательские функции

Редактор скрипта позволяет создавать собственные функции и процедуры и вызывать их в дальнейшем из кода обработчиков событий и скриптов экспорта.

Пользовательские функции создаются в одном из глобальных модулей – глобальном модуле экспорта или глобальном модуле событий. Чтобы добавить пользовательскую функцию, в редакторе скрипта нажмите на стрелочку справа от имени скрипта и выберите GlobalModule.

Все функции внутри одного модуля должны быть написаны на одном языке. Основной код скрипта отправки или обработчика события может быть написан на языке, отличном от используемого в соответствующем глобальном модуле.

Например, можно из кода обработчика события, написанного на VBScript, вызывать функцию из глобального модуля, написанного на JScript.

Функции можно вызывать только из «своего» модуля. Т.е. из кода событийного скрипта можно вызывать только функции из глобального модуля событий, а из кода скрипта экспорта – функции из глобального модуля экспорта. В противном случае возникнет ошибка во время выполнения.


События

Ниже перечислены события на станции сканирования, для которых могут вызываться скрипты.
Скрипты могут вызываться автоматически либо по явной команде пользователя. Автоматические скрипты настраиваются на тип пакета.
Для операций, отменяющих действие, скрипты не выполняются.

Автоматический вызов после старта станции

Выполняется после запуска станции.

Автоматический вызов перед закрытием станции

Выполняется перед закрытием станции.

Автоматический вызов после завершения сессии сканирования

Выполняется после завершения сессии сканирования страниц. Такие скрипты предназначены для модификации отсканированного пакета в соответствии с пользовательскими правилами.

Автоматический вызов после добавления страницы

Выполняется после добавления в пакет страницы. Предназначены для модификации страницы.

Автоматический вызов после создания пакета

Выполняется после создания пакета вручную или автоматически при сканировании. Такие скрипты предназначены для заполнения регистрационных параметров пакета, переименования его согласно пользовательским правилам и т.п.

Автоматический вызов после формирования документа

Выполняется после формирования документа вручную или автоматически при сканировании. Такие скрипты предназначены для заполнения регистрационных параметров документа, переименования его согласно пользовательским правилам, нахождения значения штрих-кода внешней компонентой и т.п.

Автоматический вызов перед удалением элемента рабочей среды

Выполняется перед удалением элемента пользователем. Такие скрипты предназначены для предотвращения удаления важных элементов.

Автоматический вызов перед операцией над страницей

Выполняется перед применением пользователем операции модификации страницы. Такие скрипты предназначены для предотвращения модификации уже модифицированных страниц. В скрипте доступна информация о производимой операции.

Автоматический вызов после операции над страницей

Выполняется после применения пользователем операции модификации страницы. Такие скрипты предназначены для запоминания модифицированных страниц. В скрипте доступна информация о произведенной операции.

Автоматический вызов перед экспортом

Выполняется до отправки задачи в фоновый режим, но после определения регистрационных параметров пакета. Если при вызове возникает ошибка, то задача экспорта не ставится, а пользователю показывается установленное сообщение. Такие скрипты могут модифицировать пакет.

Автоматический вызов после экспорта

Выполняется после завершения в фоновом режиме задачи экспорта. Сам скрипт выполняется не в фоновом режиме, а в основном приложении. Если на момент завершения экспорта основное приложение закрыто, скрипт выполнится при повторном запуске станции. Такие скрипты могут модифицировать пакет.
С помощью параметров "IsExported" и "ExportError" можно проверить, был ли экспорт успешным.

Дополнительный вид экспорта

Выполняется в фоновом режиме, как и прочие виды экспорта. Такие скрипты не могут модифицировать пакет. Могут только возвращать результирующий приемник экспорта и/или причину возникновения ошибки, а также список проэкспортированных элементов пакета. Этот список и результирующий приемник будут доступны скрипту при продолжении экспорта.

Скриптовый экспорт настраивается в типе пакета на закладке экспорта.

Вызов по явной команде пользователя

В типе пакета заводится именованный список скриптов. При вызове соответствующей команды для открытого пакета можно выбрать из этого списка нужный скрипт для исполнения.

Скрипты из списков любого типа можно добавить как отдельную кнопку на дополнительную панель инструментов пользовательских скриптов.

Замечание. Настройку панели инструментов можно вызвать как из списка скриптов, так и из главного меню.

Так же в списке скриптов им можно назначить одно из событий, по которому будет вызываться скрипт.


Объекты

Этот раздел содержит описание используемых в скриптах объектов, их методов и свойств.

Объекты скриптов экспорта
Объекты событийных скриптов


Объекты скриптов экспорта

В скриптах экспорта доступны следующие объекты:

IBatchType
IExportAttachmentByteArray
IExportAttachments
IExportBatch
IExportBatchItem
IExportBatchItems
IExportDocumentInfo
IExportPageSourceInfo
IExportRegistrationProperties
IExportRegistrationProperty
IImageSavingOptions
IPageInfo
IPageRect
IScriptProperties
IScriptResult


IBatchType

Назначение

Служит для представления типа пакета.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя типа пакета
UID | string | Только чтение | Уникальный идентификатор типа пакета


IExportAttachmentByteArray

Назначение

Бинарные данные вложения.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя массива


IExportAttachments

Назначение

Предназначен для ассоциации пользовательских бинарных данных и файлов с элементами рабочей среды.

Методы

Определение | Описание
Has (name: string): bool | Проверяет, содержит ли массив вложение с указанным именем
SaveToFile (name: string, path: string) | Сохряняет вложение с заданным именем по указанному пути

Свойства

Имя | Тип | Права | Значение
Names | VARIANT | Только чтение | Массив с именами вложений
IsEmpty | bool | Только чтение | Является ли массив пустым
ByteArray (name: string) | IAttachmentByteArray | Только чтение | Позволяет получить бинарные данные вложения по его имени


IExportBatch

Назначение

Служит для представления экспортируемого пакета. Виден в скриптах как "this".

Методы

Определение | Описание
CalcExportedPageCount () : int | Вычисляет количество проэкспортированных страниц
NotifyProcessingProgress (itemsProcessed: int, itemsRemained: int) | Показывает текущее состояние экспорта
CheckCanceled () | Проверят, не был ли экспорт отменен. Если экспорт был прерван, возвращается специальное исключение
NewPageRect () : IPageRect | Создает прямоугольник для страницы
NewImageSavingOptions () : IImageSavingOptions | Создает опции сохранения изображений

Свойства

Имя | Тип | Права | Значение
ScriptEnvInfo | string | Только чтение | Вспомогательная информация об условиях вызова скрипта. Для экспорта - идентификатор задачи экспорта.
Result | IScriptResult | Только чтение | Результаты работы скрипта
Type | IBatchType | Только чтение | Тип пакета
SourceID | string | Только чтение | Идентификатор станции
Name | string | Только чтение | Название пакета
Priority | int | Только чтение | Приоритет пакета
PageCount | int | Только чтение | Общее количество страниц в пакете
Children | IExportBatchItems | Только чтение | Дочерние элементы
RegistrationProperties | IExportRegistrationProperties | Только чтение | Регистрационные параметры пакета
ResultPath | string | Чтение/запись | Результирующий приемник экспорта
ScriptProperties | IScriptProperties | Только чтение | Скриптовые параметры
Attachments | IExportAttachments | Только чтение | Вложения


IExportBatchItem

Назначение

Элемент пакета. Может быть документом или страницей.

Методы

Определение | Описание
SaveAs (fileName: string, [optional] options: VARIANT) | Сохраняет изображение страницы/страницы документа в файл. При попытке записи многостраничного документа в одностраничный формат, возвращается исключение.

Свойства

Имя | Тип | Права | Значение
IsDocument (or IsPage) | bool | Только чтение | Определение типа элемента (документ или страница).
DocumentInfo (or PageInfo) | IExportDocumentInfo (or IExportPageInfo) | Только чтение | Свойства конкретного элемента. Если свойство не соответствует типу элемента, выполняется проверка IsDocument/IsPage.
Children | IExportBatchItems | Только чтение | Дочерние элементы
Parent | IExportBatchItem | Только чтение | Родительский элемент
Prev | IExportBatchItem | Только чтение | Предыдущий элемент
Next | IExportBatchItem | Только чтение | Следующий элемент
Index | int | Только чтение | Индекс элемента в родительской коллекции
Name | string | Только чтение | Название элемента
ScriptProperties | IScriptProperties | Только чтение | Скриптовые параметры
Attachments | IExportAttachments | Только чтение | Вложения
IsExported | bool | Чтение/запись | Проэкспротирован ли элемент


IExportBatchItems

Назначение

Коллекция объектов IExportBatchItem.

Для обращения к определенному пакету используйте метод Item: IExportBatchItems.Item( i ).

Для определения числа элементов в коллекции используется метод Count.


IExportDocumentInfo

Назначение

Содержит свойства документа.

Свойства

Имя | Тип | Права | Значение
Priority | int | Только чтение | Приоритет документа
Barcode | string | Только чтение | Значение штрихкода документа
RegistrationProperties | IExportRegistrationProperties | Только чтение | Регистрационные параметры документа


IExportPageSourceInfo

Назначение

Содержит информацию об источнике страницы.

Свойства

Имя | Тип | Права | Значение
Details | string | Только чтение | Название сканера. Пустая строка для изображений, полученных из файла.
Path | string | Только чтение | Путь к файлу (без названия файла). Пустая строка для изображений, полученных со сканера.
File | string | Только чтение | Имя файла.
FilePageIndex | int | Только чтение | Индекс страницы в исходном файле. "-1" для изображений, полученных со сканера.


IExportRegistrationProperties

Назначение

Коллекция объектов IExportRegistrationProperty.

Для обращения к элементу коллекции используйте метод Item: IExportRegistrationProperties.Item( i ).

Для определения числа элементов в коллекции используется метод Count.

Методы

Определение | Описание
Has (name: string) : bool | Проверяет, существует ли указанный параметр
Value (name: string) : string | Позволяет получить значение регистрационного параметра по имени


IExportRegistrationProperty

Назначение

Служит для представления регистрационного параметра.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя регистрационного параметра
Value | string | Только чтение | Значение регистрационного параметра


IImageSavingOptions

Назначение

Содержит опции сохранения изображений.

Свойства

Имя | Тип | Права | Значение
Format | string | Чтение/запись | Формат сохранения изображений. Допустимые выражения: "tif", "dcx", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf". Строки не чувствительны к регистру.
ColorType | string | Чтение/запись | Цветовая схема. Допустимые значения: "FullColor", "GrayScale", "BlackAndWhite". Строки не чувствительны к регистру.
Quality | int | Чтение/запись | Качество изображения для jpeg-сжатия (в процентах).
Rect | IPageRect | Чтение/запись | Сохраняемая область
ShouldOverwrite | bool | Чтение/запись | Разрешается ли перезапись существующего файла.
AddProperFileExt | bool | Чтение/запись | Если выставлено значение "true", то при сохранении изображения его расширение будет задано в соответствии с форматом.
Codec | string | Чтение/запись | Кодек. Свойство может быть задано только при сохранении в TIFF и не черно-белый PDF. Допустимые значения: "CCITT4Fax", "Zip", "Lzw", "Packbits", "Jpg", "J2k", "None". Строки не чувствительны к регистру.


IPageInfo

Назначение

Служит для представления свойств страниц.

Свойства

Имя | Тип | Права | Значение
Height | int | Только чтение | Высота страницы
Width | int | Только чтение | Ширина страницы
Resolution | int | Только чтение | Разрешение страницы
SourceInfo | IExportPageSourceInfo | Только чтение | Информация об источнике страницы


IPageRect

Назначение

Служит для представления прямоугольника страницы.

Свойства

Имя | Тип | Права | Значение
Left | int | Чтение/запись | Левая координата
Right | int | Чтение/запись | Правая координата
Top | int | Чтение/запись | Верхняя координата
Bottom | int | Чтение/запись | Нижняя координата


IScriptProperties

Назначение

Набор скриптовых параметров. Предназначен для запоминания произведенных скриптом действий для последующих вызовов.

Методы

Определение | Описание
Has (name: string): bool | Проверяет, содержится ли указанный параметр в массиве пользовательских параметров
Set (name: string, value: string) | Задает название и значение параметра
Delete (name: string) | Удаляет указанный параметр
DeleteAll ( ) | Удаляет все параметры

Свойства

Имя | Тип | Права | Значение
Names | VARIANT | Только чтение | Массив с именами заданных пользовательских параметров
IsEmpty | bool | Только чтение | Является ли массив пустым
Value (name: string) | bool | Чтение/запись | Значение параметра. К параметру свойства "Name" можно обращаться без слова "Value", используя вместо этого круглые скобки. Таким образом, записи params.Value( "Name" ) = "newValue" и params( "Name" ) = "newValue" равносильны.


IScriptResult

Назначение

Содержит результат выполнения скрипта.

Свойства

Имя | Тип | Права | Значение
Succeeded | bool | Чтение/запись | Успешно ли прошла операция
ErrorMessage | string | Чтение/запись | Сообщение об ошибке


Объекты событийных скриптов

В скриптах-обработчиках событий доступны следующие объекты:

IAttachmentByteArray
IAttachments
IBarcodeFindingOptions
IBatchInfo
IBatchType
IBatchTypes
IDocumentInfo
IEmptyPageDetectionOptions
IImageSavingOptions
IPageInfo
IPageRect
IPageSourceInfo
IRegistrationProperties
IRegistrationProperty
IWorkspace
IWorkspaceItem
IWorkspaceItems
IScriptFoundBarcode
IScriptFoundBarcodes
IScriptProperties
IScriptResult
IScriptValues


IAttachmentByteArray

Назначение

Бинарные данные вложения.

Методы

Определение | Описание
Add (value: BYTE) | Добавляет в массив новый байт.
InsertAt (value: BYTE, pos: int) | Вставляет новый байт на указанную позицию массива.
DeleteAt (pos: int) | Удяляет элемент массива с указанной позицией.
DeleteAll ( ) | Удаляет все элементы массива.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя массива


IAttachments

Назначение

Предназначен для ассоциации пользовательских бинарных данных и файлов с элементами рабочей среды. Вложения передаются при отправке пакета на сервер FlexiCapture. При отправке в папку или FTP-папку вложения помещаются в папку пакета и в XML-файл описания добавляются соответствующие записи.

Методы

Определение | Описание
Has (name: string): bool | Проверяет, содержит ли массив вложение с указанным именем
AddNew (name: string) : IAttachmentByteArray | Добавляет новое вложение с заданным именем
AddFromFile (name: string, path: string) | Добавляет новое вложение, расположенное по указанному пути
SaveToFile (name: string, path: string) | Сохряняет вложение с заданным именем по указанному пути
Delete (name: string) | Удаляет вложение с указанным именем
DeleteAll ( ) | Удаляет все вложения

Свойства

Имя | Тип | Права | Значение
Names | VARIANT | Только чтение | Массив с именами вложений
IsEmpty | bool | Только чтение | Является ли массив пустым
ByteArray (name: string) | IAttachmentByteArray | Только чтение | Позволяет получить бинарные данные вложения по его имени


IBarcodeFindingOptions

Назначение

Содержит опции детектирования штрих-кодов.

Свойства

Имя | Тип | Права | Значение
Rect | IPageRect | Чтение/запись | Прямоугольник, ограничивающий область на странице. Если все размеры равны нулю, область считается равной всей странице.
Types | IScriptValues | Только чтение | Типы штрих-кодов. Допустимы значения перечислены в описании объекта IScriptFoundBarcode.
Orientations | IScriptValues | Только чтение | Ориентация искомых штрихкодов. Допустимы значения перечислены в описании объекта IScriptFoundBarcode.


IBatchInfo

Назначение

Содержит информацию о свойствах пакета.

Свойства

Имя | Тип | Права | Значение
Type | IBatchType | Только чтение | Тип пакета
Priority | int | Чтение/запись | Приоритет пакета
PageCount | int | Только чтение | Общее количество страниц в пакете
RegistrationProperties | IRegistrationProperties | Только чтение | Регистрационные параметры пакета
ResultPath | string | Чтение/запись | Результирующий приемник экспорта. Свойство можно изменять только в скрипте, выполняемом до экспорта.
ExportError | string | Только чтение | Ошибка экспорта пакета


IBatchTypes

Назначение

Коллекция объектов IBatchType.

Методы

Определение | Описание
Has (name: string) : bool | Проверяет, есть ли в коллекции указанный тип пакета
UID (name: string) : string | Позволяет получить уникальный идентификатор пакета по имени пакета


IDocumentInfo

Назначение

Содержит информацию о свойствах документа.

Свойства

Имя | Тип | Права | Значение
Priority | int | Чтение/запись | Приоритет документа
Barcode | string | Чтение/запись | Значение штрихкода документа
RegistrationProperties | IRegistrationProperties | Только чтение | Регистрационные параметры документа


IEmptyPageDetectionOptions

Назначение

Содержит опции детектирования пустых страниц.

Свойства

Имя | Тип | Права | Значение
KernelRect | IPageRect | Чтение/запись | Относительный прямоугольник ядра страницы (измеряется в твипах). Если все размеры равны нулю, прямоугольник определяется автоматически.
MaxBarcodesCount | int | Чтение/запись | Максимальное количество штрихкодов на пустой странице. Значение "-1"означает, что этот параметр не используется.
MaxBlackSquaresCount | int | Чтение/запись | Максимальное количество чёрных квадратов на пустой странице. Значение "-1"означает, что этот параметр не используется.
MaxTextObjectsCount | int | Чтение/запись | Максимальное количество текстовых объектов на пустой странице. Значение "-1"означает, что этот параметр не используется.
MaxBlacknessPercentage | int | Чтение/запись | Максимальное относительное количество чёрного в процентах на пустой странице. Значение "-1"означает, что этот параметр не используется.


IImageSavingOptions

Назначение

Содержит опции сохранения изображений.

Свойства

Имя | Тип | Права | Значение
Format | string | Чтение/запись | Формат сохранения изображений. Допустимые значения: "tif", "dcx", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf". Строки не чувствительны к регистру.
ColorType | string | Чтение/запись | Цветовая схема. Допустимые значения: "FullColor", "GrayScale", "BlackAndWhite". Строки не чувствительны к регистру.
Quality | int | Чтение/запись | Качество изображения для jpeg-сжатия (в процентах)
Rect | IPageRect | Чтение/запись | Сохраняемая область
ShouldOverwrite | bool | Чтение/запись | Разрешается ли перезапись существующего файла
AddProperFileExt | bool | Чтение/запись | Если выставлено значение "true", то при сохранении изображения его расширение будет задано в соответствии с форматом.
Codec | string | Чтение/запись | Кодек. Свойство может быть задано только при сохранении в TIFF и не черно-белый PDF. Допустимые значения: "CCITT4Fax", "Zip", "Lzw", "Packbits", "Jpg", "J2k", "None". Строки не чувствительны к регистру.


IPageInfo

Назначение

Содержит информацию о свойствах страницы.

Свойства

Имя | Тип | Права | Значение
Height | int | Только чтение | Высота страницы
Width | int | Только чтение | Ширина страницы
Resolution | int | Только чтение | Разрешение страницы
SourceInfo | IPageSourceInfo | Только чтение | Информация об источнике страницы


IPageSourceInfo

Назначение

Содержит информацию об источнике страницы.

Свойства

Имя | Тип | Права | Значение
Details | string | Чтение/запись | Название сканера. Пустая строка для изображений, полученных из файла.
Path | string | Чтение/запись | Путь к файлу (без названия файла). Пустая строка для изображений, полученных со сканера.
File | string | Чтение/запись | Имя файла.
FilePageIndex | int | Чтение/запись | Индекс страницы в исходном файле. "-1" для изображений, полученных со сканера.


IRegistrationProperties

Назначение

Коллекция объектов IRegistrationProperty.

Для обращения к элементу коллекции используйте метод Item: IRegistrationProperties.Item( i ).

Для определения числа элементов в коллекции используется метод Count.

Методы

Определение | Описание
Has (name: string) : bool | Проверяет, существует ли указанный параметр
Add (name: string) : IRegistrationProperty | Добавляет новый регистрационный параметр
InsertAt (name: string, pos: int) : IRegistrationProperty | Вставляет указанный параметр на заданную позицию
Delete (name: string) | Удаляет параметр с указанным именем
DeleteAt (pos: int) | Удаляет параметр с указанной позиции
DeleteAll ( ) | Удаляет все параметры

Свойства

Имя | Тип | Права | Значение
Value (name: string) | bool | Чтение/запись | Значение регистрационного параметра


IRegistrationProperty

Назначение

Служит для представления регистрационного параметра.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя регистрационного параметра
Value | string | Чтение/записьe | Значение регистрационного параметра
Comment | string | Чтение/записьe | Комментарий
IsReadOnly | bool | Чтение/записьe | Является ли параметр доступным только для чтения
IsRequired | bool | Чтение/записьe | Является ли параметр обязательным
PossibleValues | IScriptValues | Только чтение | Значения, которые могут быть выбраны в выпадающем списке. Если значения отсутствуют, параметр задается в окне редактирования.


IScriptFoundBarcode

Назначение

Служит для представления найденного штрих-кода.

Properties

Name | Type | Access | Description
Rect | IPageRect | Только чтение | Прямоугольная область штрих-кода на странице
Value | string | Только чтение | Значение штрих-кода
Type | string | Только чтение | Тип штрих-кода. Допустимые значения: "Code39", "CheckCode39", "Interleaved25", "CheckInterleaved25", "EAN13", "Code128", "EAN8", "PDF417", "Codabar", "CheckCodabar", "UPCA", "UPCE", "Industrial25", "IATA25", "Matrix25", "Code93", "Postnet", "UCC128", "Patch", "Code39WithoutAsterisk", "Aztec", "Datamatrix", "QRCode". Строки не чувствительны к регистру.
Orientation | string | Только чтение | Ориентация штрих-кода. Допустимые значения: "LeftToRight", "DownToTop", "RightToLeft", "TopToDown". Строки не чувствительны к регистру.


IScriptFoundBarcodes

Назначение

Коллекция объектов IScriptFoundBarcodes.

Для обращения к элементу коллекции используйте метод Item: IScriptFoundBarcodes.Item( i ).

Для определения числа элементов в коллекции используется метод Count.


IScriptValues

Назначение

Массив уникальных строковых значений. Из объекта доступны методы Item и Count.

Методы

Определение | Описание
Has (name: string) : bool | Проверяет, существует ли указанное значение
Add (name: string) | Добавляет новое значение с указанным именем
Delete (name: string) | Удаляет значение с указанным именем
DeleteAll ( ) | Удаляет все значения


IWorkSpace

Назначение

Служит для представления рабочей среды станции. Виден в скриптах как "this".

Методы

Определение | Описание
ClearSelection () | Очищает текущую выборку
AddBatch (target: IWorkspaceItem, name: string, type: IBatchType): IWorkspaceItem | Добавляет пакет. Если параметр name пустой, имя задается в соответствии с настройками пакета.
AddDocument (page: IWorkspaceItem, name: string): IWorkspaceItem | Оборачивает страницу в документ. Если страница уже содержится в документа, будет создано 3 документа: с предыдущими, указанной и последующими страницами. Если значение свойства IWorkspaceIteme.Name пустое, имя задается в соответствии с настройками пакета.
AddPages (fileName: string, target: IWorkspaceItem, [optional] inside: bool): IWorkspaceItems | Добавляет страницы из файла
DeleteItem (item: IWorkspaceItem) | Удаляет заданный элемент
Wait (millisecond: int) | Откладывает выполнение скрипта на заданное время (в милисекундах)
FindPageBarcodes (page: IWorkspaceItem, [optional] options: IBarcodeFindingOptions): IScriptFoundBarcodes | Ищет штрих-коды на странице
DetectPageEmpty (page: IWorkspaceItem, [optional] options: IEmptyPageDetectionOptions): bool | Детектирует пустую страницу
SetPageImage (page: IWorkspaceItem, fileName: string, [optional] filePageIndex: int) | Меняет изображение у страницы
Scan ([optional] folder: string) | Запускает сканирование с настройками, определенными в текущем типе пакета
RunScript (scriptName: string, [optional] info: string, [optional] skipShowError: bool): IScriptResult | Запускает выполнение скрипта
Send (batch: IWorkspaceItem) | Вызывает экспорт пакета с настройками, определенными в текущем типе пакета
SendToFolder (batch: IWorkspaceItem, skipShowExportOptions: bool) | Вызывает экспорт пакета в папку с настройками, определенными в текущем типе пакета. Параметр skipShowExportOptions определяет, показывать ли диалог настроек отправки перед отправкой пакета.
SendToFTP (batch: IWorkspaceItem, skipShowExportOptions: bool) | Вызывает экспорт пакета в FTP-папку с настройками, определенными в текущем типе пакета. Параметр skipShowExportOptions определяет, показывать ли диалог настроек отправки перед отправкой пакета.
SendToFC (batch: IWorkspaceItem, skipShowExportOptions: bool) | Экспортирует пакет в ABBYY FlexiCapture с настройками, определенными в текущем типе пакета. Параметр skipShowExportOptions определяет, показывать ли диалог настроек отправки перед отправкой пакета.
SendByScript (batch: IWorkspaceItem, skipShowExportOptions: bool) | Экспортирует пакет с помощью скриптпа с настройками, определенными в текущем типе пакета. Параметр skipShowExportOptions определяет, показывать ли диалог настроек отправки перед отправкой пакета.
Exit ( ): bool | Завершает работу станции
NewPageRect ( ): IPageRect | Создает прямоугольник для страницы
NewImageSavingOptions ( ): IImageSavingOptions | Создает опций сохранения изображений
NewEmptyPageDetectionOptions ( ): IEmptyPageDetectionOptions | Создает опции детектирования пустых страниц
NewBarcodeFindingOptions ( ): IBarcodeFindingOptions | Создает опции поиска штрих-кодов

Свойства

Имя | Тип | Права | Значение
ScriptEnvInfo | string | Только чтение | Вспомогательная информация об условиях вызова скрипта. В скриптах, автоматически вызываемых до и после экспорта, принимает значение "<exportType> <taskID>", где "exportType" - "Folder", "FTP", "FC", "RS" или "Script" а "taskID" - идентификатор задания экспорта. В скриптах, автоматически вызываемых до и после транформации страницы, свойство принимает одно из следующих значений: "Rotate <angle>", "FlipHorizontal", "FlipVertical", "Invert", "ConvertToBW", "Descew", "Despeckle", "Erase <rectLeft> <rectTop> <rectRight> <rectBottom>", "Crop <rectLeft> <rectTop> <rectRight> <rectBottom>", "SplitHorizontal <pos>", "SplitVertical <pos>", "ChangeResolution <newRes>", "Scale <ratio>", "FreeScale <newWidth>, <newHeight>, <newRes>".
Result | IScriptResult | Только чтение | Результаты работы скрипта
SourceID | string | Только чтение | Идентификатор станции
BatchTypes | IBatchTypes | Только чтение | Типы пакетов
CurrentBatchType | IBatchType | Чтение/запись | Текущий тип пакета
Batches | IWorkspaceItems | Только чтение | Пакеты
ActiveBatch | IWorkspaceItem | Чтение/запись | Активный пакет. Для некоторых событийных скриптов (например, Перед отправкой пакета и После отправки пакета) возвращает null.
Selection | IWorkspaceItems | Только чтение | Текущая выборка. Содержит либо только страницы, либо только документы, либо только пакеты.
ScriptProperties | IScriptProperties | Только чтение | Скриптовые параметры
ScriptItems | IWorkspaceItems | Только чтение | Элементы, для которых вызывается скрипт. В зависимости от события, по котому был вызван скрипт, свойство возвращает различные значения. Для событий "После запуска станции" и "Перед закрытием станции" возвращаемое значение отсутствует. Для события "После окончания сканирования" свойство возвращает список страниц, добавленных за сессию сканирования. Для прочих событий свойство возвращает пакет, документ или страницу в зависимости от события. При выполнении скрипта по явной команде пользователя свойство возвращает коллекцию текущих выбранных элементов.


IWorkspaceItem

Назначение

Служит для представления элемента рабочей среды. Может быть пакетом, документом или страницей.

Методы

Определение | Описание
SaveAs (fileName: string, [optional] options: IImageSavingOptions) | Сохраняет изображение страницы/страницы документа/пакет в файл. При попытке записи многостраничного документа в одностраничный формат, возвращается исключение.
Move (target: IWorkspaceItem, [optional] inside: bool) | Перемещает страницу или документ после или внутрь заданного элемента.
Copy (target: IWorkspaceItem, [optional] inside: bool): IWorkspaceItem | Копирует страницу или документ после или внутрь заданного элемента.
Rotate (angle: int) | Поворачивает страницу (все страницы) документа или пакета на заданный угол.
FlipHorizontal ( ) | Отображает страницу (все страницы) документа или пакета вертикально.
FlipVertical ( ) | Отображает страницу (все страницы) документа или пакета горизонтально.
Invert ([optional] rect: IPageRect) | Инвертирует страницу (все страницы) документа или пакета.
ConvertToBW ( ) | Преобразует цвета на странице (всех страницах) документа или пакета в черно-белые.
Descew ([optional] byLines: bool, [optional] byBlackSquares: bool, [optional] byText: bool) | Устраняет перекос изображения на странице (всех страницах) документа или пакета. По умолчанию параметры byLines и byBlackSquares имеют значение "false" а параметр byText имеет значение "true".
Despeckle ([optional] garbageSize: VARIANT) | Очищает от мусора изображение на странице (всех страницах) документа или пакета.
Erase (rect: IPageRect, [optional] rColor: int, [optional] gColor: int, [optional] bColor: int) | Стирает область на странице (всех страницах) документа или пакета.
Crop (rect: IPageRect) | Вырезает область на странице (всех страницах) документа или пакета.
SplitHorizontal (pos: int) | Разбивает страницу (все страницы) документа или пакета горизонтально.
SplitVertical (pos: int) | Разбивает страницу (все страницы) документа или пакета вертикально.
ChangeResolution (int) | Меняет разрешение изображения на странице (всех страницах) документа или пакета на заданное значение.
Scale (ratio: int) | Масштабирует страницу (все страницы) документа или пакета относительно базового значения 100.
FreeScale (newWidth: int, newHeight: int, newResolution: int) | Масштабирует страницу (все страницы) документа или пакета в соответствии с заданными значениями.

Свойства

Имя | Тип | Права | Значение
IsBatch (IsDocument or IsPage) | bool | Только чтение | Определение типа элемента (пакет/документ/страница)
BatchInfo (DocumentInfo or PageInfo) | IBatchInfo/IDocumentInfo/IPageInfo | Только чтение | Свойства конкретного элемента. Если свойство не соответствует типу элемента, выполняется проверка IsBatch, IsDocument или IsPage.
Children | IWorkspaceItems | Только чтение | Дочерние элементы
Parent | IWorkspaceItem | Только чтение | Родительский элемент
Prev | IWorkspaceItem | Только чтение | Предыдущий элемент
Next | IWorkspaceItem | Только чтение | Следующий элемент
Index | int | Только чтение | Индекс элемента в родительской коллекции
Name | string | Read/write | Название элемента
ScriptProperties | IScriptProperties | Только чтение | Скриптовые параметры
Attachments | IAttachments | Только чтение | Вложения
IsSelected | bool | Read/write | Выбран ли элемент. Изменение значения одного элемента не влияет на значение этого свойства для других элементов. Применение этого свойства не работает, если текущая выборка состоит из элементов другого типа.
IsExported | bool | Read/write | Проэкспротирован ли элемент. Менять значение свойства можно только для элементов пакета в скрипте, выполняющемся перед экспортом.


IWorkspaceItems

Назначение

Коллекция объектов IWorkspaceItem.

Для обращения к элементу коллекции используйте метод Item: IWorkspaceItems.Item( i ).

Для определения числа элементов в коллекции используется метод Count.


Примеры скриптов

Автоматическая станция

После запуска автоматическая станция сканирует изображения, экспортирует полученный пакет и закрывается.

[JScript]

Scan();

var batch = Batches( Batches.Count - 1 );

Send( batch );

while( !batch.IsExported ) {

Wait( 100 );

}

Exit();

Полноценный экспорт

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

if( ResultPath == "" ) {

ResultPath = "C:\\Export";

}

if( !fso.FolderExists( ResultPath ) ) {

fso.CreateFolder( ResultPath );

}

var params = NewImageSavingOptions();

params.AddProperFileExt = true;

params.Format = "bmp";

var exportedPageCount = CalcExportedPageCount();

NotifyProcessingProgress( exportedPageCount , PageCount - exportedPageCount );

for( i = 0; i < Children.Count; i++ ) {

var item = Children.Item( i );

if( item.IsDocument ) {

if( !item.IsExported ) {

var docDir = ResultPath + "\\" + item.Name;

if( !fso.FolderExists( docDir ) ) {

fso.CreateFolder( docDir );

}

for( j = 0; j < item .Children.Count; j++ ) {

CheckCanceled();

var page = item.Children.Item( j );

if( !page.IsExported ) {

page.SaveAs( docDir + "\\" + page.Name, params );

exportedPageCount++;

NotifyProcessingProgress( exportedPageCount , PageCount - exportedPageCount );

page.IsExported = true;

}

}

item.IsExported = true;

}

} else {

CheckCanceled();

if( !item.IsExported ) {

item.SaveAs( ResultPath + "\\" + item.Name, params );

exportedPageCount++;

NotifyProcessingProgress( exportedPageCount, PageCount - exportedPageCount );

item.IsExported = true;

}

}

}


Приложения

Программные и аппаратные требования
Горячие клавиши
Поддерживаемые типы штрих-кодов
Патенты
Защита программы
Техническая поддержка
Как купить программу
Координаты офисов компании ABBYY
Лицензионное соглашение с конечным пользователем


Программные и аппаратные требования

Аппаратные требования

  1. ПК с процессором семейств Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™, AMD K6/Turion™/Athlon™/Duron™/Sempron™, тактовая частота 2ГГц и более.
  2. Оперативная память: 1Гб.
  3. Место на диске: 1 Гб, из них 50 Мб для установки.
  4. Сканер с поддержкой TWAIN, WIA или ISIS.
  5. Видеоплата и монитор с разрешением не менее 1024×768.
  6. Клавиатура, мышь или другое указательное устройство.

Программные требования

Операционная система:

  • Windows XP SP3;
  • Windows Server 2003 SP2;
  • Windows Vista SP2;
  • Windows Server 2008 SP2 + Desktop Expirience;
  • Windows 7;
  • Windows Server 2008 R2 + Desktop Expirience.

На 64-битных операционных системах программа работает в режиме эмуляции.

Для работы с локализованным интерфейсом операционная система должна обеспечивать необходимую языковую поддержку.

Прочее программное обеспечение:

  • .Net FrameWork версии 3.5 или выше;
  • Microsoft Internet Explorer 6, 7, 8, 9 или любой другой браузер с дополнением для ClickOnce-установки (для установки Станции Сканирования).


Горячие клавиши

Меню | Команда | Горячие клавиши
Файл | Новый пакет | Ctrl+N
 | Создать документ | Ctrl+Shift+C
 | Расформировать документ | Ctrl+Shift+D
 | Сканировать страницы | Ctrl+S
 | Выбрать и сканировать… | Ctrl+Shift+S
 | Остановить | Ctrl+Alt+S
 | Загрузить изображения… | Ctrl+L
 | Экспортировать пакет | Ctrl+E
 | Настройки отправки… | Ctrl+Shift+E
 | Выход | Alt+F4
Правка | Отменить | Ctrl+Z
 | Восстановить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Следующий документ для пересканирования | F4
 | Предыдущий документ для пересканирования | Shift+F4
 | Подтвердить пересканированный документ | F7
Правка | Регистрационные параметры пакета | Ctrl+B
 | Регистрационные параметры документа | Ctrl+Shift+B
 | Перейти к предыдущей странице | Ctrl+Shift+P
 | Перейти к следующей странице | Ctrl+P
 | Перейти к предыдущему документу | Ctrl+Shift+D
 | Перейти к следующему документу | Ctrl+D
 | Масштаб > Увеличить | Ctrl+Num+
 | Масштаб > Уменьшить | Ctrl+Num-
Страница | Загрузить полноразмерный эскиз | F9
 | Свойства | Alt+Enter
Сервис | Типы пакетов… | Ctrl+Shift+T
 | Задания пересканирования… | Alt+G
Справка | Вызов справки | F1


Поддерживаемые типы штрих-кодов

Программа поддерживает штрих-коды следующих форматов:

  • EAN 13
  • EAN 8
  • Code 39
  • Code 39 without asterisk
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Aztec
  • Datamatrix
  • QR Code

Замечание. Для распознавания штрих-кодов с кириллической кодировкой нужно использовать штрих-код в формате Datamatrix.


Патенты

Патенты США № 5,490,216, 5,625,465, 5,768,416 и 6,094,505


Техническая поддержка

Если при использовании программы у вас возникли вопросы, то вы можете воспользоваться детальным описанием функциональности этой программы, приведенном в Справке, а также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать вам квалифицированные рекомендации, сотрудникам службы технической поддержки необходимо иметь следующую информацию:

  • Фамилия, имя, отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер вашей копии программы
  • Номер сборки (чтобы узнать номер сборки, откройте в меню Справка выберите О программе)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия операционной системы Windows (для получения информации о системе вы можете воспользоваться меню Справка/О программе: в открывшемся диалоге нажмите кнопку О системе… и выберите Отправить)
  • Другая информация, которую вы считаете важной
Координаты офисов ABBYY


Как купить программу Станция сканирования ABBYY

Чтобы оформить заказ на покупку Станции сканирования и задать любые сопутствующие вопросы, обращайтесь в региональные офисы ABBYY.


ABBYY Offices

Координаты офисов компании ABBYY

ABBYY Россия | Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: 127273, Россия, Москва, а/я 32 Физический адрес: Москва, ст. м. Отрадное, ул. Отрадная, 2Б, строение 6, бизнес-цент "Отрадный" E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru http://www.abbyy.ru Схема проезда
ABBYY USA | Тел.: +1 408-457-9777 Факс: +1 408-457-9778 Адрес: 880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com
ABBYY Ukraine | Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: P.O. Box 23, 02002 Kiev, Ukraine E-mail: forms@abbyy.ua Техническая поддержка Тел.: +380 44 490 9463 E-mail: formsupport@abbyy.ua http://www.abbyy.ua
ABBYY Europe GmbH | Тел.: +49 (0)89 511 159 0 Факс: +49 89 (0)511 159 59 Адрес: Elsenheimerstraße 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
ABBYY UK Ltd. | Тел.:+0870 600 0231 Факс: +01344 392 611 Адрес: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-mail: sales_UK@abbyy.com Техническая поддержка: support_eu@abbyy.com http://www.abbyy.co.uk
ABBYY Japan | Тел.:+81-42-795-1901 Факс: +81-42-795-1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com
ABBYY Taiwan | Тел.:+886-2-2655-0556 Факс: +886-2-2655-2339 Адрес: Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com


Лицензионный договор с конечным пользователем

ABBYY FlexiCapture 10

Важно! Внимательно прочитайте нижеследующие условия перед установкой, копированием или иным использованием ABBYY FlexiCapture 10. Установка, копирование или иное использование ABBYY FlexiCapture 10 означает ваше согласие с нижеследующими условиями.

Настоящий лицензионный договор с конечным пользователем (далее – Лицензионный договор) является юридически обязательным соглашением между компанией ABBYY и вами, конечным пользователем программы для ЭВМ ABBYY FlexiCapture 10, которая предоставляется вместе с настоящим Лицензионным договором, включая все носители, печатные материалы, а также «он-лайн» или электронную документацию (далее по тексту – «программное обеспечение» и/или «ПО»).

Устанавливая, копируя или иным способом используя ПО, вы подтверждаете, что настоящий Лицензионный договор был вами прочитан, условия его вам понятны, и вы согласны использовать ПО в соответствии с этими условиями.

Права на ABBYY FlexiCapture 10 охраняются действующим законодательством и международными соглашениями. Вы подтверждаете свое согласие с тем, что настоящий Договор имеет такую же юридическую силу, как и любой другой письменный договор, заключенный вами.

Настоящий Лицензионный договор считается заключенным с момента, когда вы примете его условия, выбрав в процессе установки ПО пункт «Я принимаю условия лицензионного договора» на экране вашего компьютера, и нажмете на кнопку «Далее» в программе установки, либо с момента, когда вы начнете использовать ПО любым способом (далее – «Дата заключения договора»).

Если ПО сопровождается Лицензионным договором и в электронной, и в письменной форме, то в случае расхождений в содержании между настоящим текстом и текстом в письменной форме преимущественную силу имеет текст подписанного лицензионного договора в письменной форме.

В случае если вы не согласны с условиями настоящего Лицензионного договора, не устанавливайте и не используйте ПО, отметьте пункт «Я не принимаю условия лицензионного договора» и затем нажмите на кнопку «Отмена» для выхода из программы установки.

Определения:

«ПО» означает программу для ЭВМ ABBYY FlexiCapture 10, представляющую собой набор программ, баз данных и сопроводительной документации (как в письменной, так и в электронной форме). ПО охраняется законами об авторском праве.

«Компонент ПО» означает любую составную часть ПО, включая любые программы для ЭВМ в составе ПО.

«Компьютер» означает электронное устройство с одним или более центральным процессорным устройством, которое получает информацию в цифровой или аналогичной цифровой форме и обрабатывает её в соответствии с набором инструкций для получения определенного результата.

«Виртуальная машина» означает устройство в виртуальной (или иным образом эмулированной) аппаратной системе.

«Вы» означает любое физическое лицо (в том числе индивидуальный предприниматель) или юридическое лицо, которые получили ПО и/или от имени которых используется ПО.

«Лицензия» означает предоставляемое Вам Компанией ABBYY право на установку ПО и использование функциональности ПО на условиях простой (неисключительной) лицензии, в соответствии с условиями настоящего Лицензионного договора.

«Серийный номер» означает уникальный идентификатор лицензии или группы лицензий со сходными параметрами, предоставленный Конечному пользователю.

«Активация ПО» означает процесс, при помощи которого установленное ПО переводится в полнофункциональный режим и начинает выполнять все функции в соответствии с сопроводительной документацией и объемом приобретенной Вами Лицензии.

«Компания ABBYY» означает:

компанию ABBYY USA Software House Inc., зарегистрированную по адресу 880 США, 95035 Калифорния, г. Мильпитас, Норт Маккарти бульвар 220, когда применяется п. 17.1 настоящего Лицензионного договора;

компанию ABBYY Europe GmbH, зарегистрированную по адресу 80687, Германия, г. Мюнхен, Эльзенхаймерштрассе 49, когда применяется п. 17.2 настоящего Лицензионного договора;

компанию ABBYY UK Ltd., зарегистрированную по адресу Великобритания, TW20 9EY графство Суррей, г. Эгхэм, Хай-стрит 65, «Хитроу бизнес сентер», когда применяется п. 17.3 настоящего Лицензионного договора;

ООО «Аби», зарегистрированное по адресу Россия, 111398, Москва, ул. Перовская, дом 22, корпус 1, когда применяется п. 17.4 настоящего Лицензионного договора;

компанию ABBYY Software House Ukraine, зарегистрированную по адресу Украина, 03680, ул. Дегтяревская, дом 31, когда применяется п. 17.5 настоящего Лицензионного договора;

и компанию ABBYY Solutions Ltd., зарегистрированную по адресу CY 2404, Республика Кипр, г. Никосия, Энгоми, Михаил Караоли 2, во всех остальных случаях.

«Партнер Компании ABBYY» означает юридическое лицо или индивидуального предпринимателя, которое предоставляет Вам ПО и/или право на его использование на основании договора с Компанией ABBYY, предоставляющего для такой деятельности необходимый объем прав.

1. Предмет договора

1.1. При условии соблюдения Вами условий настоящего Лицензионного договора Компания ABBYY предоставляет Вам Лицензию на установку и использование функциональности ПО, включая любые изображения, фотографии, анимированные изображения, аудио- и видеокомпоненты, музыку, текст и дополнительные программы, входящие в состав ПО, а также сопроводительные материалы и копии ПО в соответствии с условиями, указанными ниже. Все условия, оговоренные далее, относятся как к ПО в целом, так и к Компонентам ПО в отдельности.

1.2. В случае если применяется п. 17.4 Лицензионного договора и Вы являетесь физическим лицом, то территория, на которой допускается использование ПО, включает в себя весь мир. В случае если применяется п. 17.4 Лицензионного договора и Вы являетесь юридическим лицом (либо обособленным подразделением юридического лица), то территория, на которой допускается приобретение и использование ПО, ограничена страной регистрации юридического лица (либо обособленного подразделения данного юридического лица), если иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY.

2. Права на ПО

2.1. Компания ABBYY гарантирует, что имеет все необходимые права на лицензирование и распространение ПО (в том числе любых включенных в него графических изображений, фотографий, текстов, анимированных изображений, аудио- и видеокомпонентов, музыки и дополнительных программ), а также сопровождающих ПО печатных материалов и всех копий ПО.

2.2. Все права на любые объекты интеллектуальной собственности, не содержащиеся в ПО, но доступные посредством использования ПО, принадлежат своим законным владельцам (правообладателям) и охраняются применимыми законами об авторском праве или иными законами и соглашениями об интеллектуальной собственности. Настоящий Лицензионный договор не предоставляет Вам никаких прав на такую интеллектуальную собственность.

2.3. ПО содержит коммерческую тайну и конфиденциальную информацию, принадлежащую Компании ABBYY и/или третьим лицам, которая охраняется применимыми законами об авторском праве и международными соглашениями.

2.4. Любое использование ПО в нарушение условий настоящего Лицензионного договора рассматривается как нарушение прав Компании ABBYY и/или третьих лиц и является достаточным основанием для лишения Вас предоставленных по настоящему Лицензионному договору прав.

2.5. Вы согласны с тем, что ПО защищено от копирования и неограниченного использования и может сопровождаться программными и аппаратными ключами (далее – «Лицензионный ключ») для обеспечения такой защиты.

2.6. Объем Лицензии зависит от ряда факторов, определяемых при заказе/приобретении ПО: набора функций, разрешенного количества работающих в сети копий ПО, разрешенного количества используемых ЦПУ, разрешенного для обработки количества страниц, окончания срока действия Лицензии и других. Вся эта и другая информация записана в Лицензионном ключе. Лицензионный ключ техническими средствами ограничивает использование ПО объемом Лицензии, которую Вы приобрели.

2.7. Вы имеете право один раз передать данное ПО непосредственно другому конечному пользователю. В случае если Вы являетесь юридическим лицом, Вы не имеет права передавать ПО другому конечному пользователю без предварительного письменного согласия Компании ABBYY. Такая передача должна включать все ПО (все Компоненты ПО, носители и печатные материалы, а также любые полученные Вами новые версии) и настоящий Лицензионный договор. Такая передача не может быть осуществлена косвенно или через какое-либо третье лицо. Лицо, получающее ПО в результате такой единовременной передачи, должно согласиться со всеми условиями настоящего Лицензионного договора, включая обязательство более никому не передавать ПО. В случае такой передачи ПО Вы обязуетесь удалить ПО и его Компоненты, установленные на всех Ваших Компьютерах или в локальной вычислительной сети.

2.8. За исключением случая, описанного в п. 2.7, Вы не имеете права передавать, продавать или сублицензировать ПО третьим лицам, равно как и права, предоставленные Вам по настоящему Лицензионному договору, и/или любые другие права на ПО. Компания ABBYY имеет право в одностороннем порядке расторгнуть настоящий Лицензионный договор в случае такой передачи или продажи.

2.9. Настоящий Лицензионный договор не предоставляет Вам никаких прав на товарные знаки, принадлежащие Компании ABBYY.

2.10. Компания ABBYY сохраняет за собой все права, которые не предоставлены явным образом настоящим Лицензионным договором.

3. Условия использования

3.1. Вы имеете право использовать ПО в соответствии с объемом Лицензии.

3.2. Вы имеете право установить ПО на неограниченном количестве Компьютеров или Виртуальных машин.

3.3. Функциональность ПО и количество Компьютеров или Виртуальных машин (если использование Виртуальных машин разрешено вашей Лицензией), которое Вы можете запускать одновременно определяется серийным номером, предоставляемым Вам вместе с ПО.

3.4. В случае если ПО или Компоненты ПО используются в виртуальной среде (например, VMware, Citrix, или «ghosting»), одна и та же Лицензия не должна использоваться несколькими машинами одновременно, если только это не разрешено Вашей лицензией. Вы обязуетесь не обрабатывать при помощи ПО больше страниц, чем общее количество страниц, которое разрешено Вашей Лицензией.

3.5. Если Вы получаете доступ к ПО через терминальные службы (Terminal Services), которые разрешают доступ к ПО на удаленном компьютере с помощью сети, Вы имеете право одновременно запускать и использовать такое количество копий ПО, которое разрешено объемом Вашей Лицензией и настоящим Лицензионным договором.

3.6. Если Вы получаете доступ к ПО через сеть интернет с удаленного Компьютера при помощи веб-браузера, Вы имеете право одновременно запускать и использовать такое количество копий ПО, которое разрешено объемом приобретенной Вами Лицензии и настоящим Лицензионным договором.

3.7. Вы имеете право использовать ПО для предоставления услуг по распознаванию и конвертации и/или предоставлять третьим лицам результаты, полученные посредством ПО, только если в Вашем Лицензионном ключе есть параметр «BPO services enabled».

3.8. Вы не имеете права использовать ПО для предоставления третьим лицам платных или бесплатных услуг по распознаванию или конвертированию и/или предоставлять результаты или доступ к результатам, полученным при помощи ПО, в составе другой услуги, одним из компонентов которой является распознавание или конвертирование, без предварительного заключения письменного договора с Компанией ABBYY.

3.9. Если версия ПО обозначена как «испытательная» или «демонстрационная» («Try&Buy», «Trial» или «Demo»), то независимо от остальных условий настоящего Лицензионного договора Вы имеете право использовать ПО только в тестовых или демонстрационных целях. Вы согласны с тем, что ПО может иметь ограниченную функциональность и/или ограниченное время работы. Если срок использования ПО является ограниченным по времени, то по истечении определенного периода времени, указанного в Лицензии, оно прекратит работать.

3.10. Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:

3.10.1. Восстанавливать структурную схему, деассемблировать, декомпилировать (преобразовывать объектный код в исходный текст) ПО (включая программы, базы данных и любые Компоненты ПО), за исключением случаев, разрешенных применимым законодательством, и только в объеме, явным образом разрешенном применимым законодательством. Если применимое законодательство разрешает подобные действия, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть незамедлительно сообщена Компании ABBYY. Вся такая информация является конфиденциальной и принадлежит Компании ABBYY.

3.10.2. Модифицировать, адаптировать или переводить ПО, в том числе вносить изменения в объектный код программ или баз данных к ним, за исключением тех изменений, которые вносятся средствами, включенными в комплект ПО и описаны в сопроводительной документации.

3.10.3. Исправлять ошибки в ПО без предварительного письменного согласия Компании ABBYY.

3.10.4. Сдавать в аренду, сублицензировать, передавать или уступать права, предоставленные Вам по настоящему Лицензионному договору, и любые другие права, связанные с ПО, третьим лицам, а также разрешать копировать ПО целиком или его части на Компьютеры других пользователей, если иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

3.10.5. Создавать условия для использования ПО лицами, не имеющими прав на использование ПО и работающими с Вами в одной многопользовательской системе.

3.10.6. Удалять, менять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

4. Носители

4.1. ПО может предоставляться на нескольких носителях, в том числе через сеть интернет. Независимо от количества носителей, на которых Вы получили ПО, Вы имеете право использовать ПО только в соответствии с условиями настоящего Лицензионного договора.

5. Ограничения

5.1. Вы не сможете использовать предоставленные Вам настоящим Лицензионным договором права в отношении ПО до тех пор, пока не будет произведена Активация ПО.

5.2. Все условия и ограничения использования, поддержки и сопровождения ПО указаны в настоящем Лицензионном договоре, если иное не оговорено в отдельном письменном соглашении между Вами и Компанией ABBYY или Партнером Компании ABBYY.

6. Базы данных конечного пользователя

6.1. Вы имеете право создавать свои базы данных к программам, входящим в комплект ПО, если такая возможность предусмотрена ПО и описана в сопроводительной документации.

7. Распространение ПО

7.1. Распространение ПО любыми способами, за исключением способа, описанного в п. 2.7, запрещено. Распространение включает в себя в том числе предоставление доступа к ПО третьим лицам, сублицензирование, продажу ПО, прокат, сдачу ПО в аренду или предоставление ПО взаймы.

8. Сопровождение и техническая поддержка

8.1. Компания ABBYY или Партнер Компании ABBYY может предоставить Вам сопровождение и техническую поддержку ПО на условиях, изложенных в Приложении А к настоящему Лицензионному договору, если иное не оговорено в отдельном письменном соглашении между Вами и Компанией ABBYY или Партнером Компании ABBYY.

9. Ограниченная гарантия

9.1. Компания ABBYY гарантирует удовлетворительное качество носителей, входящих в комплект ПО (если ПО поставляется на материальных носителях), и их работоспособность при обычных условиях использования в течение минимального гарантийного срока, установленного законодательством страны приобретения ПО, начиная с даты приобретения ПО. В случае если ПО было приобретено в одной из стран, указанных в п. 17.4, гарантийный срок составляет 30 (тридцать) дней с даты покупки.

9.2. ПО, обновления, новые версии и сопровождение ПО предоставляются «как есть», и Компания ABBYY не предоставляет на них никаких гарантий. Компания ABBYY и Партнеры Компании ABBYY не гарантируют и не могут гарантировать производительность и результаты, которые Вы можете получить посредством использования ПО. За исключением гарантий и условий, которые не могут быть исключены или ограничены в соответствии с применимым законодательством, Компания ABBYY и Партнеры Компании ABBYY не предоставляют никаких гарантий (явно выраженных или подразумевающихся в статутном или общем праве, или обычаями делового оборота или иначе) ни на что, включая, без ограничения, гарантии о соблюдении прав третьих лиц, товарной пригодности, интегрируемости, удовлетворительного качества, годности к использованию для выполнения частных задач. Компания ABBYY также не гарантирует, что ПО не содержит ошибок, будет удовлетворять Вашим требованиям или что ПО будет нормально функционировать при использовании совместно с программным обеспечением и оборудованием других производителей. Все риски, связанные с качеством работы и производительностью ПО, возлагаются на Вас.

9.3. Компания ABBYY не предоставляет никаких гарантий относительно программного обеспечения других производителей, которое поставляется вместе или в составе ПО.

10. Ограничение ответственности

10.1. Компания ABBYY ни при каких обстоятельствах не несет перед Вами никакой ответственности за ущерб, вынужденные перерывы в деловой активности, потерю деловых либо иных данных или информации, претензии или расходы, косвенные или случайные убытки, а также упущенную выгоду и утерянные сбережения, вызванные использованием или связанные с использованием ПО, а также за ущерб, вызванный возможными ошибками и опечатками в ПО, даже если представителю Компании ABBYY стало известно о возможности такого ущерба, потерь, претензий или расходов, равно как и за любые претензии со стороны третьих лиц. Вышеперечисленные ограничения и исключения действуют в той степени, насколько это разрешено применимым законодательством. Единственная ответственность Компании ABBYY по настоящему Лицензионному договору ограничивается суммой, которую Вы уплатили за ПО.

10.2. Ограниченная ответственность перед пользователями, проживающими в Германии и Австрии.

Если Вы приобрели ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то

10.2.1. С учетом условий п. 10.2.2, ответственность Компании ABBYY за убытки ограничивается следующим: (i) Компания ABBYY несет ответственность только в том размере, который можно предвидеть в момент заключения договора купли-продажи для убытков в результате незначительного нарушения существенного контрактного обязательства и (ii) Компания ABBYY не несет ответственности за убытки в результате незначительного нарушения несущественного контрактного обязательства.

10.2.2. Ограничение ответственности, изложенное в п. 10.2.1, не распространяется на обязательную ответственность, предусмотренную законом, в частности, на ответственность по Закону ФРГ об ответственности производителя, на ответственность за предоставление конкретной гарантии и на ответственность за причиненные увечья.

10.2.3. Вы обязуетесь предпринять все разумные меры с целью избежать ущерба и сократить ущерб, в частности, делать резервные копии ПО и данных на Вашем компьютере в соответствии с условиями настоящего Лицензионного договора.

11. Встроенные шрифты

11.1. Шрифтовые программы охраняются авторским правом, и их владельцы могут налагать условия на использование шрифтов. Одним из условий может быть необходимость наличия лицензионной версии шрифтовой программы для встраивания шрифтов при создании новых PDF-файлов. Компания ABBYY не несет никакой ответственности за любые убытки, вызванные использованием Вами встраиваемых шрифтов.

12. Библиотека Adobe® PDF Library

12.1. «ПО Adobe» означает библиотеку Adobe® PDF Library для Windows 2000, и Windows XP и сопутствующую документацию, а также любые обновления, измененные версии, дополнения или копии вышеперечисленного. ПО использует ПО Adobe для конвертирования PDF-файлов в файлы изображений.

12.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Adobe, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора. Вы имеете право сделать одну резервную копию ПО Adobe, входящего в состав ПО, при условии, что резервная копия не устанавливается на другой Компьютер и не используется на другом Компьютере.

12.3. Права на интеллектуальную собственность. ПО Adobe, входящее в состав ПО, является собственностью Adobe и поставщиков Adobe, а его структура, организация и программный код являются производственным секретом Adobe и поставщиков Adobe. ПО Adobe также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО Adobe, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Все копии, которые Вы имеете право сделать в соответствии с настоящим Лицензионным договором, должны включать в себя те же уведомления об авторских правах и о правах собственности, которые содержатся в или на ПО. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Adobe, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО Adobe.

12.4. Лицензия на использование шрифтов. В случае если само ПО или ПО Adobe, входящее в состав ПО, включает шрифты, Вы можете встраивать шрифты или контуры шрифтов в Ваши электронные документы, если такое встраивание разрешено правообладателем шрифтов. Данный комплект может содержать как шрифты, принадлежащие Adobe, так и шрифты, не принадлежащие Adobe. Вы имеете право встраивать любые шрифты, принадлежащие Adobe.

12.5. Гарантия. Компания ABBYY не МОЖЕТ гарантировать и не гарантируЕт результаты, которые Вы можете получить путем использования ПО Adobe, входящего в состав ПО.

12.6. Экспортные ограничения. Вы признаете, что ПО Adobe, входящее в состав ПО, не будет поставляться, передаваться, экспортироваться или использоваться в нарушение Закона США о контроле над экспортом (The United States Export Administration Act) или иных нормативно-правовых актов, накладывающих экспортные ограничения (далее все вместе – экспортные ограничения). Кроме того, в случае если ПО Adobe, входящее в состав ПО, в экспортных ограничениях определено как продукт, подлежащий экспортному контролю, Вы гарантируете, что не являетесь гражданином страны, на которую наложено эмбарго, не находитесь в такой стране и что экспортными ограничениями Вам не запрещено приобретать ПО Adobe, входящее в состав ПО. В случае несоблюдения Вами условий настоящего Лицензионного договора Вы лишаетесь всех прав на использование ПО Adobe, входящего в состав ПО, предоставленных Вам настоящим Лицензионным договором.

12.7. Товарные знаки. Adobe и Adobe PDF Library являются товарными знаками или зарегистрированными товарными знаками Adobe Systems Incorporated в США и/или в других странах.

13. Библиотеки PixTools® Scan

13.1. «ПО EMC Software» означает библиотеки Scan, драйверы Level 1 ISIS Drivers, драйверы Level 2 ISIS Drivers, и драйверы Level 3 ISIS Drivers. ПО использует ПО EMC Software для осуществления обмена данными между сканером и ПО через интерфейс ISIS.

13.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО EMC Software, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора.

13.3. Права на интеллектуальную собственность. ПО EMC Software, входящее в состав ПО, является собственностью EMC Corporation и поставщиков EMC Corporation, а его структура, организация и программный код являются производственным секретом EMC Corporation и поставщиков EMC Corporation. ПО EMC Software также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО EMC Software, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО EMC Software, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО EMC Software.

13.4. ГАРАНТИЯ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО EMC SOFTWARE, ВХОДЯЩЕГО В СОСТАВ ПО. EMC CORPORATION И ПОСТАВЩИКИ EMC CORPORATION НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ УПУЩЕННУЮ ВЫГОДУ ИЛИ ПОТЕРЯННЫЕ СБЕРЕЖЕНИЯ, РАВНО КАК И ЗА ПРЕТЕНЗИИ, ПРЕДЪЯВЛЕННЫЕ ТРЕТЬИМИ ЛИЦАМИ.

Некоторые штаты и юрисдикции запрещают исключение или ограничение ответственности за косвенные или специальные убытки, поэтому вышеперечисленные ограничения могут на Вас не распространяться. У Вас могут быть и другие права, которые зависят от штата и юрисдикции.

13.5. Товарные знаки. ISIS и PixTools являются товарными знаками или зарегистрированными товарными знаками EMC Corporation в Соединенных Штатах Америки и/или в других странах.

14. Программное Обеспечение LIZARDTECH

14.1. «ПО LIZARDTECH» означает инструментарий разработчика DjVu Decoder Software Development Kit производства LIZARDTECH, а также любые сопровождающие его носители, печатные материалы и электронную документацию. Вы приобрели ПО, которое включает в себя ПО LIZARDTECH, лицензированное ABBYY у компании LIZARDTECH, INC. ПО использует ПО LIZARDTECH для конвертирования файлов в формате DjVu в файлы изображений.

14.2. ПО LIZARDTECH охраняется законами об авторском праве и международными соглашениями. ПО LIZARDTECH лицензируется, а не продается.

14.3. Лицензия. Вам предоставляется персональная, не подлежащая сублицензированию, не подлежащая передаче другому лицу, неисключительная лицензия на использование ПО LIZARDTECH, интегрированного в ПО (включая сопроводительную документацию). Вы не имеете права сдавать в аренду, продавать или иным образом распространять ПО LIZARDTECH или любую его часть.

14.4. ОТСУТСТВИЕ ГАРАНТИЙ НА ПО LIZARDTECH. ПО LIZARDTECH поставляется таким, каково оно есть, со всеми ошибками. ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВСЕ РИСКИ, СВЯЗАННЫЕ С УДОВЛЕТВОРИТЕЛЬНЫМ КАЧЕСТВОМ, ПРОИЗВОДИТЕЛЬНОСТЬЮ, ТОЧНОСТЬЮ И НЕОБХОДИМЫМИ УСИЛИЯМИ (ВКЛЮЧАЯ ОТСУТСТВИЕ НЕБРЕЖНОСТИ). ТАКЖЕ ВАМ НЕ ПРЕДОСТАВЛЯЕТСЯ НИКАКИХ ГАРАНТИЙ НА ТО, ЧТО НИКТО НЕ ПОМЕШАЕТ ВАШЕМУ ВЛАДЕНИЮ ПО LIZARDTECH, И НА ТО, ЧТО ПО LIZARDTECH НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ЕСЛИ ВЫ ПОЛУЧИЛИ КАКИЕ-ЛИБО ГАРАНТИИ НА ПО ИЛИ НА ПО LIZARDTECH, ТАКИЕ ГАРАНТИИ БЫЛИ ПРЕДОСТАВЛЕНЫ НЕ КОМПАНИЕЙ LIZARDTECH, И КОМПАНИЯ LIZARDTECH НЕ БЕРЕТ НА СЕБЯ НИКАКИХ ОБЯЗАТЕЛЬСТВ В СВЯЗИ С ТАКИМИ ГАРАНТИЯМИ.

14.5. ИСКЛЮЧЕНИЕ ОТВЕТСТВЕННОСТИ ЗА ОПРЕДЕЛЕННЫЕ ВИДЫ УЩЕРБА. ЕСЛИ НЕ ЗАПРЕЩЕНО ЗАКОНОМ, КОМПАНИЯ LIZARDTECH НЕ НЕСЕТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА КАКИЕ-ЛИБО КОСВЕННЫЕ, ФАКТИЧЕСКИЕ ЛИБО СЛУЧАЙНЫЕ УБЫТКИ, ВОЗНИКАЮЩИЕ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ПО LIZARDTECH ЛИБО ЕГО ФУНКЦИОНИРОВАНИЕМ. НАСТОЯЩЕЕ ОГРАНИЧЕНИЕ ПРИМЕНЯЕТСЯ, ДАЖЕ ЕСЛИ КАКОЕ-ЛИБО СРЕДСТВО СУДЕБНОЙ ЗАЩИТЫ НЕ ДОСТИГНЕТ СВОЕЙ ОСНОВНОЙ ЦЕЛИ.

14.6. Ограничения на обратную разработку, декомпиляцию и деассемблирование. Вы не имеете права восстанавливать структурную схему и алгоритм работы, декомпилировать или деассемблировать ПО LIZARDTECH, за исключением случаев и только в объеме, явным образом разрешенном применимым законодательством.

14.7. Экспортные ограничения. Вы признаете, что ПО LIZARDTECH, любая его часть, любой процесс или служба, которые являются непосредственным продуктом ПО LIZARDTECH («компоненты с экспортными ограничениями»), произведены в США. Вы обязуетесь соблюдать все применимые международные и национальные законы, которые распространяются на такие продукты, включая Правила Экспортного управления США, а также ограничения на конечных пользователей, на конечное использование и на страны или регионы конечного использования, налагаемые правительством США и правительствами других стран.

15. Другие лицензируемые технологии

15.1. Настоящее ПО используется согласно лицензиям на патенты США № 5 490 216, 5 625 465, 5 768 416 и 6 094 505.

16. Экспортные ограничения

16.1. Настоящее ПО не должно экспортироваться или реэкспортироваться в нарушение экспортных ограничений, имеющихся в законодательстве страны, в которой ПО приобретено или получено. Вы также подтверждаете, что применимое законодательство не запрещает Вам приобретать или получать ПО.

17. Применимое право

17.1. В случае если Вы приобрели ПО на территории США, Канады, Мексики, стран Центральной Америки (Белиза, Коста-Рики, Сальвадора, Гватемалы, Гондураса, Монтсеррата, Никарагуа, Панамы, островов Теркс и Кайкос, Виргинских островов США), Тайваня или Японии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство штата Калифорния (Соединенные Штаты Америки). Все споры в отношении настоящего Лицензионного договора и/или ПО подлежат разрешению в федеральном суде и/или суде штата в округе Санта-Клара (штат Калифорния). Во избежание споров Вы согласны с тем, что в случае приобретения Вами ПО на территории Соединенных Штатов Америки, считается, что Вы приобрели ПО у ABBYY USA Software House Inc.

17.2. В случае если Вы приобрели ПО на территории Австрии, Бельгии, Германии, Дании, Испании, Италии, Люксембурга, Нидерландов, Португалии, Финляндии, Франции, Швеции, или на территории любого другого государства, являющегося членом Европейского Союза и не указанного явно в п. 17.3 - 17.5 настоящего Лицензионного договора (исключая Грецию, Кипр и Мальту) а также на территории Исландии, Лихтенштейна, Норвегии, Нормандских островов или Швейцарии, к отношениям по настоящему Лицензионному договору применяется законодательство, действующее в г. Мюнхене (Германия). Все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в суде г. Мюнхена, Германия.

17.3. В случае если Вы приобрели ПО на территории Соединенного Королевства Великобритании и Северной Ирландии или Республики Ирландия, к отношениям по настоящему Лицензионному договору применяется законодательство, действующее на территории Англии и Уэльса. Стороны принимают юрисдикцию судов Англии и Уэльса.

17.4. В случае если Вы приобрели ПО на территории России, Белоруссии, Казахстана, или другого государства, являющегося членом Содружества Независимых Государств (СНГ), за исключением Украины и Молдовы, а также на территории Грузии, Латвии, Литвы и Эстонии, к отношениям по настоящему Лицензионному договору применяется материальное право Российской Федерации.

17.5. В случае если Вы приобрели ПО на территории Албании, Болгарии, Боснии и Герцеговины, Венгрии, Израиля, Македонии, Польши, Румынии, Словакии, Словении, Турции, Хорватии, Чехии, Сербии, Черногории, Украины или Молдовы, к отношениям по настоящему Лицензионному договору применяется материальное право Украины.

17.6. В случае если Вы приобрели ПО в стране, указанной в п. 17.4, и являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Арбитражном суде г. Москвы, Российская Федерация. В случае если Вы приобрели ПО в стране, указанной в п. 17.4, и являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Перовском районном суде г. Москвы, Российская Федерация.

17.7. В случае если Вы приобрели ПО в стране, указанной в п. 17.5, и являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Международном коммерческом арбитражном суде при Украинской торгово-промышленной палате в соответствие с ее регламентом. Решение данного суда является окончательным и обязательным к исполнению обеими сторонами. В случае если Вы приобрели ПО в стране, указанной в п. 17.5, и являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Шевченковском районном суде г. Киева, Украина.

17.8. К настоящему Лицензионному договору не применяются никакие коллизионные нормы любой юрисдикции, а также Конвенция ООН о договорах международной купли-продажи.

17.9. В случае если Вы приобрели ПО в стране, не указанной в пп. 17.1-17.5, к отношениям по настоящему Лицензионному договору применяется действующее законодательство страны, в которой Вы приобрели ПО.

18. Срок действия и расторжение договора

18.1. Настоящий Лицензионный договор вступает в силу с Даты заключения договора. Настоящий Лицензионный договор действует в течение всего срока действия исключительного права на ПО, если иное не оговорено в настоящем Лицензионном договоре или в отдельном письменном договоре между Вами и Компанией ABBYY.

18.2. Вы имеете право расторгнуть Лицензионный договор, удалив ПО, сопроводительную документацию и все их копии.

18.3. Без ущерба для каких-либо иных прав Компания ABBYY имеет право расторгнуть настоящий Лицензионный договор в случае нарушения Вами каких-либо условий настоящего Лицензионного договора. В этом случае Вы обязаны удалить все копии ПО и Компонентов ПО. Такое расторжение настоящего Лицензионного договора не освобождает Вас от обязательств по оплате ПО и/или Сопровождения ПО.

18.4. Пп. 2.2 - 2.5, 2.9 – 2.10, 3.1, 7, 9.2, 9.3, 10, 17, 20.2 и 20.3 сохраняют свою силу и после расторжения настоящего Лицензионного договора, однако это не дает Вам права продолжать использовать ПО после расторжения настоящего Лицензионного договора.

19. Использование ПО правительственными учреждениями

19.1. В случае если ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных - Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

20. Общие положения

20.1. В случае если какая-либо часть настоящего Лицензионного договора будет признана утратившей юридическую силу (недействительной) и не подлежащей исполнению, остальные части Лицензионного договора сохраняют свою юридическую силу и подлежат исполнению.

20.2. Вы соглашаетесь на добровольную передачу Компании ABBYY своих персональных данные в ходе установки ПО, Активации ПО, регистрации ПО и использования ПО. Вы соглашаетесь с тем, что Компания ABBYY имеет право собирать, обрабатывать и использовать Ваши персональные данные в соответствии с применимым законодательством и при условии сохранения их конфиденциальности. Предоставленные Вами персональные данные будут храниться и использоваться только Компанией ABBYY и ее аффилированными лицами и не будут раскрываться третьим лицам, за исключением случаев, предусмотренных действующим законодательством.

20.3. Компания ABBYY имеет право отправлять Вам письма, в том числе по электронной почте, с информацией о Компании ABBYY, продуктах и специальных предложениях Компании ABBYY, с советами по использованию продуктов Компании ABBYY и другой информацией, имеющей отношение к Компании ABBYY и продуктам Компании ABBYY, в случае если Вы явно согласились получать такого рода информацию от Компании ABBYY. Вы можете в любой момент удалить свой адрес электронной почты из списка рассылок Компании ABBYY.

20.4. Компания ABBYY может предоставить Вам печатные материалы, включая руководство пользователя.

20.5. Вознаграждением по настоящему Лицензионному договору признается стоимость Лицензии на ПО, установленная Компанией ABBYY или Партнерами Компании ABBYY, и подлежащая уплате в соответствии с определяемым ими порядком, либо стоимость Лицензии на ПО, которая входит в стоимость приобретаемого Вами оборудования или полной версии ПО. Если Вы являетесь физическим лицом, данный Лицензионный договор может быть безвозмездным.

20.6. В случае предъявления любых претензий или исков, связанных с использованием Вами ПО Вы обязуетесь сообщить Компании ABBYY о таких фактах в течение трех (3) дней с момента, когда Вам стало известно об их возникновении. Вы обязуетесь совершить необходимые действия для предоставления Компании ABBYY возможности участвовать в рассмотрении таких претензий или исков, а также предоставлять необходимую информацию для урегулирования соответствующих претензий и/или исков в течение семи (7) дней с даты получения запроса от Компании ABBYY.

Приложение A

Соглашение о сопровождении ПО

Настоящее Приложение А является неотъемлемой частью Лицензионного договора, если только иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY.

1. Определения

1.1. «Обновление» – улучшения текущей версии ПО, обычно включающие в себя исправления ошибок.

1.2. «Новая версия» – следующая по порядку версия ПО, которая выпускается взамен основной версии используемой Вами на основании Лицензионного договора (например, версия 1.5 заменит собой версию 1.0, версия 2.x заменит собой версию 1.x).

1.3. «Ошибка» – любая неспособность ПО выполнять функции, перечисленные в документации. Возможны следующие три типа ошибок:

1.3.1. Ошибка с приоритетом 1 – ошибка, при которой нет способа обойти проблему, в результате чего производственный процесс на Вашем предприятии останавливается, в том числе ошибка сопровождающаяся сообщением «Внутренняя программная ошибка», «Нехватка памяти», «Нарушение прав доступа», «Общее нарушение защиты», «Общая ошибка защиты» или «Деление на ноль»;

1.3.2. Ошибка с приоритетом 2 – ошибка, которую можно обойти;

1.3.3. Ошибка с приоритетом 3 – незначительная проблема, не сказывающаяся на производственном процессе на Вашем предприятии.

1.4. «Поддержка ПО» означает

(i) предоставляемая Вам Компанией ABBYY Поддержка ПО в случае обнаружения Ошибки с целью восстановить работу ПО в соответствии со спецификацией. Такая поддержка может включать в себя предоставление Вам способа обхода обнаруженной Вами Ошибки или предоставление Вам Обновления для ПО, устраняющего Ошибку;

(ii) информацию, предоставленную Вам Компанией ABBYY в ответ на Ваши вопросы о функциональности, установке, Активации ПО и эксплуатации ПО.

1.5. «Подписка на Новые версии» – часть Сопровождения, которая дает Вам право на получение Новых версий.

2. Сопровождение ПО

2.1. Сопровождение ПО может включать в себя предоставление Обновлений, Подписки на Новые версии и Поддержку ПО или любой комбинации вышеперечисленного.

2.2. Минимальный первоначальный срок Сопровождения ПО после приобретения составляет двенадцать (12) месяцев с даты отправки ПО.

2.3. Для продления периода Сопровождения, необходимо оплатить Компании ABBYY или Партнеру Компании ABBYY продление периода Сопровождения. Если применяется статья 17.2 или 17.3, то срок Сопровождения ПО будет продлен на 12 месяцев без последующего уведомления, если Вы не откажетесь от Сопровождения ПО в течение 45 дней перед окончанием срока Сопровождения ПО. В случае Вашего решения об отказе, оно должно быть выполнено в письменной форме.

2.4. Компания ABBYY или Партнеры Компании ABBYY могут сообщать Вам дополнительные условия Сопровождения ПО.

2.5. Компания ABBYY сохраняет за собой право по своему усмотрению изменять форму и содержание Сопровождения ПО.

2.6. Любой дополнительный код ПО, предоставленный Вам как часть Сопровождения ПО, является частью ПО, и на него распространяются все условия настоящего Лицензионного договора.

3. Новые версии и Обновления

3.1. Новые версии и Обновления должны поставляться на компакт-дисках или по каналам передачи данных (посредством протокола FTP). Затраты на транспортировку, если таковые будут, должны оплачиваться Вами.

3.2. В случае если Вы приобрели Сопровождение в форме Обновлений, Вы имеете право на получение Обновлений от Компании ABBYY или Партнера Компании ABBYY. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Вам Обновления для ПО по мере их появления.

3.3. В случае если Вы приобрели Сопровождение в форме Новых версий, Вы имеете право на получение Новых версий от Компании ABBYY или Партнера Компании ABBYY. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Вам Новые версии ПО по мере их появления.

3.4. В случае если Вы разработаете приложение, которое включает в себя ПО, части ПО или интегрируется с ПО, любая новая главная версия такого приложения должна включать в себя последнее Обновление для ПО, предоставленное Вам Компанией ABBYY не ранее чем за три (3) месяца до выпуска такой главной версии (либо самой последнее Обновление, если последнее Обновление было выпущено более чем за три (3) месяца до выпуска такой главной версии).

4. Поддержка ПО

4.1. В случае если Вы приобрели Сопровождение в форме «Поддержка ПО», компания ABBYY или Партнеры Компании ABBYY обязуются предоставить Поддержку ПО в соответствии с действующими правилами оказания поддержки, опубликованными на веб-сайте Компании ABBYY по адресу http://www.abbyy.com/support/policy. Компания ABBYY сохраняет за собой право в любое время изменять правила оказания поддержки без предварительного уведомления.

4.2. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Поддержку ПО без дополнительной платы для исправления Ошибок с приоритетом 1.

4.3. В случае если Вы приобрели Сопровождение в форме «Поддержки ПО», Компания ABBYY или Партнер Компании ABBYY обязуется предоставить Поддержку ПО не более чем для восьми (8) запросов, касающихся Ошибок с приоритетами 2 и 3 в течение двенадцати (12) месяцев. Поддержка ПО для дополнительных запросов в связи с Ошибками с приоритетами 2 и 3 должны приобретаться дополнительно.

4.4. Компания ABBYY или Партнеры Компании предоставляют Поддержку ПО в течение рабочего дня по телефону или по электронной почте.

4.5. ABBYY или Партнеры Компании обязуются предпринимать разумные усилия для выпуска экстренных Обновлений для ПО, не предусмотренных планом выпуска, для устранения любых Ошибок с приоритетом 1, о которых им было сообщено. В остальных случаях Ошибки с приоритетами 2 и 3 могут исправляться по мере выхода Новых версий. Экстренные Обновления должны выпускаться только для текущей версии ПО с целью исправления Ошибок с приоритетом 1.

4.6. При сообщении об Ошибках Вы обязуетесь предоставлять Компании ABBYY или Партнерам Компании ABBYY информацию, которая необходима для идентификации Ошибки. Такая информация включает в себя описание проблемы, указание платформы и операционной системы, на которых произошла Ошибка, копию входных данных, которые вызвали Ошибку, копию файла формата, который использовался в момент обнаружения Ошибки, и все дампы, которые были сделаны в результате Ошибки. Компания ABBYY или Партнер Компании ABBYY может использовать вышеперечисленную информацию в своих коммерческих целях, в том числе для поддержки и разработки продуктов, при условии что Компания ABBYY или Партнер Компании не использует такую информацию в любой форме, которая позволяет идентифицировать Вашу личность.


Панель инструментов Обработка

Кнопка Описание
Позволяет начать сканирование документов из последнего выбранного источника сканирования.

Чтобы выбрать один из доступных источников сканирования, нажмите на стрелку справа от кнопки и выберите пункт Выбрать и сканировать…. В открывшемся диалоге Выбрать и сканировать выберите один из доступных источников.
Останавливает процесс сканирования. Эта кнопка заменяет кнопку Сканировать во время сканирования.
Экспортирует документы, используя выбранное направление экспорта. Название используемого направления отображается при наведении курсора на кнопку.

Нажмите на стрелку справа от кнопки, чтобы выбрать одно из следующих направлений:

  • Отправить в папку…
    Позволяет экспортировать пакет в локальную папку.
  • Отправить в папку на FTP-сервере…
    Позволяет экспортировать пакет в папку на FTP-сервере.
  • Отправить в FlexiCapture…
    Позволяет экспортировать пакет в ABBYY FlexiCapture.
  • Отправить скриптом…
    Позволяет экспортировать пакет с помощью скрипта.

При выборе профиля открывается диалог настроек экспорта для выбранного профиля. Укажите необходимые параметры, затем нажмите OK для запуска процесса экспорта.


Управление лицензиями

Управление лицензиями осуществляется с помощью окна Лицензии. Данное окно вызывается кнопкой Менеджер лицензий… диалогового окна О программе Станция сканирования ABBYY FlexiCapture 10 (пункт Справка > О программе главного меню).

Добавление новой лицензии

Чтобы добавить лицензию, в окне Лицензии нажмите кнопку Активировать... В открывшемся диалоге введите новый серийный номер и нажмите кнопку Далее. Далее выберите способ активации лицензии и активируйте ее.

Новая лицензия (лицензии) появится в списке окна Лицензии.

Обновление лицензии

Чтобы обновить лицензию, выберите ее в списке и нажмите на кнопку Обновить лицензию... Вам также потребуется активация по Интернет или по электронной почте. Следуйте инструкциям программы.

Параметры лицензии

В окне Лицензии можно просмотреть параметры лицензии.


Параметры лицензии

У каждой лицензии есть свой серийный номер. Лицензия состоит из набора параметров. Набор параметров лицензии определяет право пользователя на выполнение отдельных операций.

Параметры лицензии:

  • Общие - серийный номер, способ лицензирования, возможность работы на виртуальной машине.
  • Назначение лицензии – тип лицензии (стандартная, испытательная или не для продажи).
  • Ограничения по времени – ограничения при использовании системы.
  • Импорт – дополнительные возможности импорта.


Защита программы

Для корректной работы станции сканирования требуется наличие ключа защиты. Станция сканирования, входящая в состав комплекса ABBYY FlexiCapture 10, использует ключ защиты комплекса. Информация данного раздела и его подраздела относится к удаленной станции сканирования, которая использует свой собственный ключ защиты.

В поставку станции сканирования может входить один из двух видов ключа защиты:

  • аппаратный ключ защиты или
  • программный ключ защиты.

Защита аппаратным ключом

Защита аппаратным ключом представляет собой защиту с помощью ключа для USB-порта (USB-ключ). Работа с программой возможна только в том случае, если ваш ключ защиты подключен к USB-порту компьютера.

В аппаратном ключе записаны параметры лицензии.

Можно активировать пустой аппаратный ключ удаленно, имея на руках только серийный номер лицензии. Для этого используется приложение Менеджер лицензий, которое связывается с сервером активации (по интернету), запрашивает параметры этого серийного номера и записывает их в ключ.

Внимание! Для работы с USB-ключами защиты необходимо, чтобы запускалась стандартная служба Смарт-карты.

Защита программным ключом

Программный ключ представляет собой лицензионный файл.

Для корректной работы станции сканирования с программным ключом лицензионный файл должен быть активирован на сервере активации ABBYY. Это может быть сделано с помощью диалогового окна Лицензии, которое вызывается с помощью кнопки Менеджер лицензий… диалогового окна О программе Станция сканирования ABBYY FlexiCapture 10 (пункт Справка > О программе главного меню).

Информация для активации передается в виде кода (Product ID), который генерируется на основе информации о компьютере, на который установлена станция сканирования. При генерации кода не используется никакая персональная информация о пользователе или его компьютере и этот код не может быть использован для идентификации пользователя.

Способы активации:

  • Через интернет
    Активация через интернет производится автоматически и занимает всего несколько секунд. Для активации лицензионного файла этим способом требуется подключение компьютера к интернету. При активации через интернет, весь процесс происходит автоматически.
  • По электронной почте
    Для активации по электронной почте пользователь должен отправить автоматически сгенерированное сообщение, содержащее необходимую для активации информацию. Пожалуйста, не изменяйте текст и тему письма, в противном случае активации не произойдет. Полученный в ответ регистрационный файл необходимо загрузить в систему защиты с помощью пункта Выбрать активационный файл.
  • По электронной почте с другого компьютера

    Если на компьютере отсутствует доступ к электронной почте, необходимую информацию можно перенести на другой компьютер и отправить с него электронное письмо. Для этого выберите пункт По электронной почте с другого компьютера. Перенесите информацию, необходимую для регистрации, на другой компьютер и отправьте письмо на указанный программой адрес. Полученный в ответ регистрационный файл перенесите на компьютер, на который установлена программа, и загрузите в систему защиты с помощью пункта Выбрать активационный файл.

  • Выбрать активационный файл

    Данный пункт предназначен для загрузки регистрационного файла, полученного по электронной почте.

Повторная активация

Вы можете переустанавливать станцию сканирования на том же компьютере неограниченное число раз без повторной активации. Однако, если вы производили значительные обновления, форматировали жесткий диск или переустанавливали операционную систему, вам может понадобиться повторная активация.

Для каждого серийного номера ведется подсчет количества возможных активаций. После превышения этого лимита активация невозможна. Пользователь может освободить активированную лицензию используя деактивацию, при этом счетчик потраченных активаций уменьшится.

Внимание! Лицензионный файл, активированный для одного компьютера, не будет работать на другом компьютере, т.к. в нем прописываются параметры компьютера, на котором происходит его активация.


Указание регистрационных параметров

Регистрационные параметры могут быть указаны для пакетов и документов.

Если заполнение регистрационных параметров требуется для данного типа пакета, вы можете задать их при создании пакета в диалоге Указание регистрационных параметров, а также после создания пакета в диалоге Свойства пакета на закладке Регистрационные параметры.

Регистрационные параметры для документов могут быть заполнены в диалоге Свойства документа на закладке Регистрационные параметры.

В столбце Значение введите значение нужного параметра. При заполнении значений параметров вам могут помочь комментарии, указанные в графе Комментарий. Регистрационные параметры, обязательные для заполнения, помечены звездочкой (*). Пока обязательные регистрационные параметры пакета или документа не заполнены, пакет не может быть экспортирован.


Диалог: Настройка определения пустой страницы

Диалог «Настройка определения пустой страницы»

В этом диалоге вы можете указать параметры, по которым будет определяться пустая страница при разделении документов. Этот диалог открывается при нажатии кнопки Настройки… при выбранном разделении документов по пустым страницам на закладке Свойства пакета диалога Свойства типа пакета, а также при создании типа пакета при помощи Мастера создания типа пакета.

Опция | Описание опции
Обрезка (мм) | Отметьте эту опцию, если вы хотите, чтобы при определении, является ли страница пустой, страница была предварительно обрезана на указанное расстояние в миллиметрах сверху, снизу, слева, справа. Полученная после обрезки страница будет проверяться на соответствие остальным параметрам.
Макс. число черных квадратов | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число черных квадратов (специальных элементов дизайна форм), могла считаться пустой. Укажите допустимое число черных квадратов на странице.
Макс. число текстовых объектов | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число текстовых объектов, могла считаться пустой. Под текстовым объектом понимается любой отдельный фрагмент текста. Например, вы можете использовать эту опцию с ненулевым числом текстовых объектов для страниц, содержащих колонтитулы. Укажите допустимое число текстовых объектов на странице.
Макс. число штрих-кодов | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число штрих-кодов, считалась пустой. Укажите допустимое число штрих-кодов на странице.
Макс. процент черного | Отметьте эту опцию, если вы хотите, чтобы процентное содержание черного цвета на пустой странице не превосходило указанное. Процентное соотношение белого и черного цветов вычисляется на бинаризованном изображении.


Диалог: Настройка формата изображений

Диалог «Настройка формата изображений»

В этом диалоге вы можете настроить параметры экспорта изображений для выбранного типа пакетов. Эти параметры могут быть настроены при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа. Чтобы изменить настройки экспорта изображений, в диалоге Свойства типа пакета перейдите на закладку Отправка, выберите опцию Отправлять по указанному направлению и нажмите кнопку Опции формата… в разделе Опции экспорта.

Укажите нужный формат выходных файлов и способ сохранения многостраничных документов.

Опция Описание опции
Формат
(выпадающий список) 		Определяет формат файлов:
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
Цвет
(выпадающий список) 		Определяет цветовой тип изображения:
  • Цветной
  • Серый
  • Черно-белый
Качество
(выпадающий список) 		Определяет качество сохраняемого изображения:
  • Наилучшее
  • Высокое
  • Среднее
  • Низкое
  • Настройка
Кодек
(выпадающий список) 		Если в поле Качество указано Настройка, выберите используемый кодек:
  • Zip
  • Lzw
  • Packbits
  • Jpeg
  • Нет
Качество Jpeg
(полоса прокрутки) 		Если выбран кодек Jpeg, настройте качество Jpeg, перемещая ползунок.
Параметры многостраничных документов Выберите режим сохранения документов в пакете:
  • Сохранять документы в виде многостраничных файлов
    Позволяет сохранять документы в виде многостраничных файлов. Эта опция доступна только для форматов TIFF, DCX packbits и PDF.
  • Сохранять документы в виде папок
    Позволяет сохранять документы в виде папок. В этом случае страницы документа будут представлены отдельными файлами выбранного формата.


Диалог: Свойства страницы

Диалог «Свойства страницы»

В этом диалоге вы можете посмотреть свойства страницы:

  • пакет, в котором содержится страница,
  • ее номер в пакете,
  • источник получения изображения,
  • размер изображения в пикселях,
  • разрешение изображения,
  • размер изображения для печати в дюймах,
  • цветовой режим страницы,
  • предупреждения о качестве отсканированного изображения.

Чтобы открыть этот диалог, в окне Пакеты или окне изображений выделите нужную страницу, затем выберите меню Страница > Свойства, или нажмите правую кнопку мыши и в контекстном меню выберите Свойства, или нажмите Alt+Enter.


Диалог: Регистрационный параметр

Диалог «Регистрационный параметр»

В этом диалоге вы можете создать регистрационный параметр для пакета или документа. Регистрационные параметры могут быть указаны при создании типа пакета при помощи Мастера создания типа пакета, а также могут быть отредактированы после создания типа пакета. Чтобы изменить регистрационные параметры, нажмите кнопку Правка… на закладке Регистрационные параметры или Регистрационные параметры документа диалога Свойства типа пакета.

Введите имя регистрационного параметра и выберите его тип. В зависимости от выбранного типа, укажите необходимые настройки.

Опция | Описание опции
Имя | Имя регистрационного параметра.
Тип Тип регистрационного параметра:
  • Текст
    Параметр этого типа содержит текстовую строку. Вы можете указать значение, которое будет использовано для регистрационного параметра по умолчанию, в строке По умолчанию.
    В значение могут быть включены имя пользователя, запустившего станцию, имя компьютера, на котором установлено приложение, идентификатор станции, время и дата создания пакета. Чтобы включить в значение эти компоненты, отметьте опции Оператор, Станция, Идентификатор станции, Время, Дата, соответственно. Эти компоненты помещаются в угловые скобки <>. Остальные компоненты должны быть напечатаны без угловых скобок. Компоненты без угловых скобок используются в значении регистрационного параметра без изменений.
    Если вы не хотите, чтобы оператор мог изменять указанное по умолчанию значение, отметьте опцию Только чтение.
  • Выпадающий список
    Параметр этого типа может содержать один из элементов списка, указанного в поле Допустимые значения. Вы можете добавить элемент в список при помощи кнопки Новый…. При нажатии на эту кнопку открывается диалог, в котором вы можете ввести значение элемента списка.
    Элемент списка может содержать имя пользователя, запустившего станцию, имя компьютера, на котором установлено приложение, идентификатор станции, время и дату создания пакета. Чтобы включить в значение элемента списка эти компоненты, отметьте опции Оператор, Станция, Идентификатор станции, Время, Дата, соответственно. Эти компоненты помещаются в угловые скобки <>. Остальные компоненты должны быть напечатаны без угловых скобок. Компоненты без угловых скобок используются в значении параметра без изменений.
    Чтобы удалить элемент из списка, нажмите кнопку Удалить. Вы можете изменить порядок следования элементов в списке при помощи кнопок Выше, Ниже.
    Кнопка Импорт… позволяет импортировать список элементов из текстового файла. В качестве элементов списка рассматриваются отдельные строки.
Обязательный | Устанавливает, является ли параметр обязательным для заполнения. Если параметр помечен как обязательный, пакет не может быть экспортирован, пока не заполнено значение этого параметра.
Описание | Укажите комментарий к регистрационному параметру.


Диалог Задания пересканирования

Этот диалог позволяет работать с заданиями пересканирования: выбрать задание, отправить обработанные задания на верификацию, отказаться от выполнение задания, отправить задания в Исключения, а также указать имена регистрационных параметров, значения которых будут отображаться в столбце Информация о пакете. Чтобы открыть диалог, выберите меню Сервис > Задания пересканирования….

Диалог содержит сдедующую информацию о задаче: время создания, статус, приоритет, информация о пакете и комментарий. Комментарий может быть добавлен

оператором верификации при отправке задания на пересканирование.

Чтобы добавить информацию о пакете, нажмите кнопку Данные пакета… и введите имена регистрационных параметров пакета. Значения добавленных регистрационных параметров,разделенные точкой с запятой, будут отображаться в столбце Информация о пакете. Если указанные регистрационный параметр отсутсвует, его значение будет пустым.

Значения столбцов Информация о пакете и Комментарий помогают оператору различать задания.

Для работы с заданиями используйте кнопки справа:

Кнопка | Описание
Выбрать | Открывает задачу и меняет ее статус на "Выбрана".
Отправить | Отправляет обработанные задания на Станцию верификации.
Отказаться | Позволяет отказаться от выполнения задания.
В Исключения… | Отправляет выбранные задания в Исключения.
Данные пакета… | Открывает диалог Информация о пакете, в котором можно добавить/удалить имена регистрационных параметров.
Закрыть | Закрывает диалог.

О работе с заданиями пересканирования вы также можете прочитать в разделе Задания пересканирования.


Редактор скрипта

Редактор скрипта служит для написания и редактирования скриптов как для отдельного пакета, так и для группы пакетов определенного тип.

Чтобы открыть Редактор скрипта, нажмите Правка… на закладке Скрипты.

Выберите язык скрипта: JScript® или VBScript.

Используйте команды меню или кнопки на панели Редактора скриптов для редактирования кода.

Для проверки написанного кода:

  • нажмите Проверка на панели
  • или выберите команду Проверить скрипт в меню Сервис
  • или нажмите F9

Для добавления пользовательской функции нажмите на стрелочку рядом с названием скрипта и выберите GlobalModule, чтобы создать пользовательскую функцию в глобальном модуле событий или в глобальном модуле экспорта.

Чтобы закрыть Редактор скрипта, выберите Файл > Выход или нажмите на кнопку закрытия окна в правом верхнем углу.

Более подробную информацию о скриптах в Станции сканирования ABBYY вы можете найти в разделе Использование скриптов.


Панель инструментов: Редактирование пакета

Название | Кнопка | Описание
Создать новый пакет |  | Создает новый пакет текущего типа. Имя пакета определяется схемой именования пакетов, указанной в настройках типа пакета. Чтобы изменить имя пакета выделите пакет в окне Пакеты, затем нажмите левую кнопку мыши или кнопку F2.
Создать новый документ |  | Создает в текущем пакете новый документ, содержащий выбранные страницы. Имя документа определяется схемой именования пакетов, указанной в настройках типа пакета. Чтобы изменить имя документа, выделите его в окне Пакеты, затем нажмите левую кнопку мыши или кнопку F2.
Расформировать документ |  | Позволяет расформировать существующий документ: страницы, содержащиеся в документе, будут помещены в текущий пакет, а документ удален.
Удалить элементы |  | Удаляет выделенные объекты.


Настройка панели инструментов

В этом окне вы можете настроить вид панели Скрипты как для отдельного пакета, так и для группы пакетов определенного типа. Чтобы настроить панель для отдельного пакета, нажмите кнопку Настроить панель инструментов… на панели Скрипты меню Сервис > Настройки… Настроить панель для определенного типа пакета можно при создании типа пакета при помощи Мастера создания типа пакета, а после создания типа пакета на закладке Скрипты диалога Свойства типа пакета.

При нажатии на кнопку Настроить панель инструментов… откроется диалог Настройка панели инструментов.

Настраивать панель Скрипты можно следующим образом:

  • Добавлять на панель кнопки для запуска скриптов. Для этого нажмите Новая кнопка… и выберите скрипт из выпадающего списка скриптов, доступных для данного типа пакета.
  • Добавлять разделители между кнопками. Для этого выберите кнопку, после которой вы хотите добавить разделитель, и нажмите Новый разделитель.
  • Используйте кнопки Выше и Ниже для перемещения выбранной кнопки запуска скрипта на одну позицию вверх или вниз соответственно.
  • Для удаления кнопки нажмите Удалить.
  • Кнопка Загрузить изображения позволяет добавлять иконки для кнопок.

Замечание: Программа позволяет загрузить только один *.bmp файл для всех иконок. Чтобы добавить иконки для нескольких кнопок, нужно загрузить *.bmp файл, который содержит все требуемые изображения. Размер загружаемого файла должен быть 24*<количество иконок>x24 пикселя. После загрузки файл разобьется на отдельные иконки автоматически. Для того чтобы заменить кнопку иконкой, нажмите сначала на название скрипта и затем на иконку. Выбранная иконка появится напротив названия скрипта.


Панель инструментов: Обработка страниц

Название | Кнопка | Описание
Повторно отсканировать |  | Производит повторное сканирование выделенных страниц.
Вставить страницы |  | Выполняет сканирование изображений и помещает их в пакет после выбранной страницы.
Повернуть на 90° по часовой стрелке |  | Поворачивает выделенные страницы на 90° по часовой стрелке.
Повернуть на 90° против часовой стрелки |  | Поворачивает выделенные страницы на 90° против часовой стрелки.
Повернуть на 180° |  | Поворачивает выделенные страницы на 180°.
Отразить относительно вертикальной оси |  | Отображает выделенные страницы относительно вертикальной оси.
Отразить относительно горизонтальной оси |  | Отображает выделенные страницы относительно горизонтальной оси.
Обрезать |  | Позволяет обрезать выделенную страницу.
Инвертировать |  | Инвертирует цвета выделенных страниц.
Конвертировать в черно-белое |  | Конвертирует выделенные страницы в черно-белые.
Исправить перекос |  | Исправляет перекос на выделенных страницах.
Очистить от мусора |  | Очищает от «мусора» изображения выделенных страниц.
Скрыть данные |  | Позволяет выполнить заливку цветом выделенного прямоугольника на заданной странице. Цвет заливки вы можете задать, выбрав Сервис > Настройки… > Общие > Цвет для скрытия данных.


Панель инструментов: Тип пакета

Кнопка | Описание
Текущий тип пакета (выпадающий список) | Позволяет выбрать текущий тип пакета. Изначально в программе задан один тип пакета Разное, настройки которого используются по умолчанию.
 | Открывает диалог Свойства типа пакета, в котором вы можете посмотреть и отредактировать настройки выбранного типа пакета. Эта кнопка недоступна для пакетов типа Разное. Чтобы посмотреть настройки, используемые по умолчанию, выберите меню Сервис > Настройки…
 | Нажмите эту кнопку, чтобы в окне Пакеты отображались только пакеты текущего типа.

Замечание. Эта панель инструментов скрыта, если в программе не задано ни одного пользовательского типа пакета.


IPageRect

Назначение

Описывает прямоугольник страницы.

Свойства

Имя | Тип | Права | Значение
Left | int | Чтение/запись | Левая координата
Right | int | Чтение/запись | Правая координата
Top | int | Чтение/запись | Верхняя координата
Bottom | int | Чтение/запись | Нижняя координата