关于 ABBYY FormDesigner

关于 ABBYY FormDesigner 10

ABBYY FormDesigner 10 是一种用于创建机器可读表单的软件应用程序，这类表单使用表单处理应用程序 ABBYY FlexiCapture 10 进行处理。表单设计是表单创建的一个重要阶段，因为其他所有阶段 – 扫描、识别、校验、导出 – 均取决于初始表单的“正确性”以及表单对于机器处理的适合性。

ABBYY FormDesigner 10 和 MS Visio、CorelDRAW 或 MS Word 等其他编辑器不同，它专门开发用于创建机器可读表单。尽管上述应用程序具备扩展功能，但它们的用户需要另外采取措施来确保其表单满足机器可读性要求 – 测定表单要素、监控这些要素在表单上的形状和位置等等。

本程序有直观的用户友好的界面，它包含有易于使用且功能强大的机器可读表单上常见的标准要素。使用该应用程序可以创建黑白和彩色的表单。在 ABBYY FormDesigner 10 中创建的表单元素，将采用机器输入自动设计。此外，程序还会对创建的每个表单进行检查，以确保计算机成功处理该表单。所有这一切意味着您可以快速方便地创建机器可读表单，最单调乏味的工作将由程序替您完成。

一旦在 ABBYY FormDesigner 10 中创建好表单，实际上就表示您已准备好了用于在 ABBYY FlexiCapture 10 中创建模板的表单描述。（模板描述表单要素，并告知数据捕获应用程序在表单上的哪些位置查找特定类型的信息，因此可以确保程序准确可靠地识别输入的数据。）

因此 ABBYY FormDesigner 10 执行的任务有两项：简化表单的制作和 ABBYY FlexiCapture 10 设置过程，从而 ABBYY FormDesigner 10 在处理 ABBYY FormDesigner 10 中创建的表单时只需最低程度的人工干预。

ABBYY FormDesigner 10 允许您发布表单（即防止表单被误更改或误编辑），以及在将表单发送至印刷厂前以不同格式进行保存。


ABBYY FormDesigner 10 新增功能

ABBYY FormDesigner 10 包括以下新功能：

    表单创建

  • 添加了新的复选标记组元素。现在，您使用复选标记组创建向导可以轻松创建选定类型（矩阵、表格或列表）的复选标记组并添加已创建的复选标记组至表单。

  • 现在，您可以为新的空表单指定页面布局属性。空页面的设置在工具>选项...对话框的空白页面布局属性选项卡上指定。当创建新的空表单时，指定的设置将会生效。

  • 已添加了新的彩色表单样式。对于彩色表单，页面背景色和表单中的元素颜色可以从调色板中选择。不推荐打印彩色表单。表单样式可在页面属性对话框中及在指定空白页面布局属性时选择。

    • 表单编辑

  • 添加了为复选标记字段元素添加提示的能力。

  • 通过使用拖放操作，可以更改多页表单中的页面顺序。

    • 表单导出

  • 现在，可以从命令行打印已填写的表单。

  • 添加了通过使用元素 ID 用文件或数据库中的数据填写表单的能力。

    • 表单填写

  • 您可以对填写表单时可输入的值加以限制。限制可应用至输入字段、日期字段和数字字段元素。您可以通过使用规则为这些字段定义限制。


安装、运行和删除 FormDesigner

安装、运行和删除 ABBYY FormDesigner 10

ABBYY FormDesigner 10 和 ABBYY FlexiCapture 10 一同安装和删除。

要运行 ABBYY FormDesigner 10，请选择开始/程序/ABBYY FlexiCapture 10/工具中的 ABBYY FormDesigner 10 项目。


主应用程序窗口

当您启动 ABBYY FormDesigner 10 时，主窗口将会与快速启动对话框一起出现。快速启动对话框允许您立即开始工作，提示您从最常用命令中作出选择：打开文件、最近文件、创建新表单、模板中表单或启动表单向导。

您可以在选项对话框中自定义主应用程序窗口的外观。

显示主应用程序窗口

菜单栏包含以下菜单：文件、编辑、视图、表单、元素、工具和帮助。

您可以通过使用视图菜单显示/隐藏界面元素。

标准工具栏包含最常用任务的按钮。

设计工具工具栏包含编辑表单元素的按钮。

格式化工具栏包含格式化文本的按钮和命令。

表单元素工具栏包含向表单添加元素的按钮。

标尺是以测量单位标记的栏，它用于为表单元素的确切位置和对齐提供编辑帮助。

表单窗口显示当前的表单。在某一给定时刻只能显示一个表单。

文档结构。此窗格显示文档的字段的层级。每个字段都链接至一个或多个元素。

属性窗口。在此窗口，您可以查看和更改选定元素的属性。在此窗口显示的选项卡取决于当前选择的元素类型。要打开选项卡，请单击右侧它的名称。

状态栏显示有关当前元素的信息：以毫米计算的元素左上角的坐标、以毫米计算的元素的大小、有关元素的其他信息（元素类型）。页面类型和大小也显示在状态栏上。其他信息（每一行和列上的字符单元数）对输入字段、日期字段和数字字段可用。


主窗口菜单

文件
项目 | 描述
新建… | 打开快速启动对话框，其中包含在启动应用程序时的常用命令：打开文件，从最近打开的文件列表中打开文件；创建空白表单，使用模板创建表单或启动表单向导。
打开… | 打开表单
保存 | 保存表单
另存为… | 以新的名称保存表单，或将表单/页面保存为样本。
导出至 |
图像文件… | 导出表单至图像文件
带分色的图像文件… | 导出彩色表单至有彩色分隔的图像文件 - 黑白 TIFF 文件和彩色 TIFF 文件。
XML 表单定义… | 导出表单至 XML 表格定义格式（仅用于已发布表单）。
PDF 表单… | 导出 ABBYY FormDesigner 表单至 PDF 表单 （仅用于已发布表单）。您还可以向表单添加响应按钮作为电子邮件和/或网站响应，并设置导出参数。 要导出至 PDF 表单，您的表单必须有至少一个可编辑字段。
InfoPath 表单… | 导出 ABBYY FormDesigner 至 InfoPath 表单。 要导出至 InfoPath 表单，您的表单必须有至少一个可编辑字段。
Adobe Illustrator 文件… | 导出您的表单至 Adobe Illustrator 文件。
从可搜索 PDF 文件导入… | 从另一表单布局编辑器中创建的 PDF 文件导入表单。
发布表单 | 发布表单
将可编辑副本另存为… | 保存可随后进行编辑的表单副本。
发布表单… | 打开向导的形式分布，您可以在此选择表单发送和接收参数。
打印设置… | 打开打印设置对话框。
打印预览 | 显示当您打印时表单时的外观。
打印 | 打开打印对话框。
打印已填写的表单… | 打印出用文件或数据库的值填写的表格。
最新表单 | 显示最近打开的文件列表。选择任何最近的文件以打开它。
退出 | 关闭 ABBYY FormDesigner 10。
编辑
项目 | 描述
撤销 | 取消最后一次操作的结果
恢复 | 取消最后一次撤消操作的结果
剪切 | 剪切所选内容（元素或文本）并将其放在剪贴板上。
复制 | 复制所选内容（元素或文本）至剪贴板上。
粘贴 | 将剪贴板的内容粘贴至表单。
删除 | 删除所选元素。与这些元素有关联的文档结构中的字段也将删除。
复制 | 复制所选元素。
编辑文本 | 允许您在所选文本或复选标记字段元素中编辑文本。
重命名字段 | 重命名所选字段
删除区域 | 删除所选元素，但不删除它们在文本结构中有关联的字段。
全选 | 选择当前表单中的所有元素。
按类型选择… | 打开按类型选择对话框，您可以在此指定将要选择的元素类型。
视图
项目 | 描述
工具栏 |
标准 | 显示/隐藏标准工具栏。
格式化 | 显示/隐藏格式化工具栏。
表单元素 | 显示/隐藏表单元素工具栏。
设计工具 | 显示/隐藏设计工具工具栏。
大工具栏按钮 | 使工具栏上的按钮变大/变小。
状态栏 | 显示/隐藏状态栏。状态栏显示按钮和菜单项的解释和所选元素的大小、位置、类型以及页面属性。
文档结构 | 显示/隐藏文档结构窗格。
元素属性 | 显示/隐藏元素属性窗口。
网格 | 显示/隐藏网格。
主标尺 | 显示/隐藏主标尺。
边距 | 显示/隐藏边距。
快速移动至网格 | 将新创建元素的左上角与最近的网格节点对齐。当移动表单元素时，它也会与最近的网格节点对齐。
将对齐标尺快速移动至元素 | 开启/关闭元素到标尺的自动绑定 如果打开该模式，则当您在表单上移动标尺时，它会自动绑定到离它足够近的元素。
显示对齐标尺 | 显示/隐藏对齐标尺。
删除所有对齐标尺 | 除去所有对齐标尺。
缩放 |
200% | 缩放表单窗口至 200%。
150% | 缩放表单窗口至 150%。
100% | 缩放表单窗口至 100%。
75% | 缩放表单窗口至 75%。
50% | 缩放表单窗口至 50%。
适合宽度 | 使图像适合表单窗口的宽度。
适合高度 | 使图像适合表单窗口的高度。
最佳适合 | 使整个图像适合表单窗口。
缩小 | 使表单图像减半
放大 | 使表单图像加倍
表单
菜单项 | 描述
表单属性… | 打开表单属性对话框。
添加页面 |
空 | 将空页面添加至表单
基于页面样本… | 添加基于样本创建的页面。
删除页面 | 删除当前页面。
页面属性… | 打开页面属性对话框。
元素
项目 | 描述
绘制元素 |
选择工具 | 在表单元素工具栏上选择工具或在表单中选择元素。
输入字段 | 选择将输入字段元素添加至表单的输入字段工具。
日期字段 | 选择将数据字段元素添加至表单的日期字段工具。
数字字段 | 选择将数字字段元素添加至表单的数字字段工具。
复选标记字段 | 选择将复选标记字段元素添加至表单的复选标记字段工具。
元素组 | 选择将元素组添加至表单的元素组工具。
表格 | 选择将表格元素添加至表单的表格工具。
垂直分隔符 | 选择将垂直分隔符添加至表格的垂直分隔符工具。
水平分隔符 | 选择将水平分隔符添加至表格的水平分隔符工具。
删除分隔符 | 选择从表格中删除分隔符的删除分隔符工具。
垂直标尺 | 选择将垂直标尺添加至表单的垂直标尺工具。
水平标尺 | 选择将水平标尺添加至表单的水平标尺工具。
文本 | 选择将文本元素添加至表单的文本工具。
行分隔符 | 选择将行分隔符元素添加至表单的行分隔符工具。
矩形 | 选择将框架元素添加至表单的矩形工具。
图片 | 选择将图片元素添加至表单的图片工具。
定位点 | 选择将定位点元素添加至表单的定位点工具。
标识符 | 选择将标识符元素添加至表单的标识符工具。
填充模板… | 向表单添加已填写的样本
复选标记组… | 打开复选标记组创建向导，它允许您创建复选标记组元素并将其添加至表单。
对齐 |
左 | 将选定的元素与最后选定元素的左侧对齐。
水平居中 | 将选定元素的中央与最后选定元素的中央对齐而不更改它们的垂直位置。
右 | 将选定的元素与最后选定元素的右侧对齐。
顶部 | 将选定的元素与最后选定元素的顶部对齐。
垂直居中 | 将选定元素的中央与最后选定元素的中央对齐而不更改它们的水平位置。
底部 | 将选定的元素与最后选定元素的底部对齐。
至网格 | 将所有选定元素的左上角与最近的网格节点对齐。
以均匀的空格分布 | 将选定元素在页面水平方向均匀分隔。
以均匀的空格向下排列 | 将选定元素在页面垂直方向均匀分隔。
大小 |
绘制相同宽度 | 使所有选定元素的宽度与最后选定元素的宽度相同。
绘制相同高度 | 使所有选定元素的高度与最后选定元素的高度相同。
绘制相同宽度和高度 | 使所有选定元素的高度和宽度与最后选定元素的高度和宽度相同。
网格大小 | 将选定元素的边框展开至最近的网格线。
适合大小 | 展开或收缩选定元素的边框，使之符合内部数据的大小。
置于前面 | 将选定元素移至前台。
发送至后面 | 将选定元素移至后台。
合并 | 合并表格上选定的元素。
拆分 | 拆分表格上选定的元素。
添加至合并的元素 | 将元素添加至先前合并的元素。将添加的元素与以前合并的元素必须同时选定。
工具
项目 | 描述
核对表单 | 检查表单是否机器可读。
选项… | 打开选项对话框，您可以在此更改主窗口视图、导出参数和空白页面布局属性。
帮助
项目 | 描述
帮助主题 | 打开 ABBYY FormDesigner 帮助。
技术支持 | 打开帮助文件的技术支持页面。
发送反馈… | 将关于 ABBYY FormDesigner 反馈发送至 ABBYY。 公司页面将打开，您可在此找到 ABBYY FormDesigner 和 ABBYY FlexiCapture 的反馈表单。
关于 | 打开包含有关该程序简要信息的关于 ABBYY FormDesigner 10 窗口。


工具栏本地菜单

工具栏快捷菜单

项目 | 描述
标准 | 显示/隐藏标准工具栏。
格式化 | 显示/隐藏格式化工具栏。
表单元素 | 显示/隐藏表单元素工具栏。
设计工具 | 显示/隐藏设计工具栏。
大工具栏按钮 | 使工具栏上的按钮变大/变小。
选项… | 打开选项对话框。


表单元素本地菜单

表单元素快捷菜单

项目 | 描述
适合大小 | 展开或收缩选定元素的边框，使之符合内部数据的大小。
剪切 | 剪切所选内容（元素或文本）并将其放在剪贴板上。
复制 | 复制所选内容（元素或文本）至剪贴板上。
粘贴 | 将剪贴板的内容粘贴至表单。
删除 | 删除所选元素。与这些元素有关联的文档结构中的字段也将删除。
删除区域 | 删除所选元素，但不删除它们在文本结构中有关联的字段。
复制 | 复制所选元素。
编辑文本 | 允许您在所选文本或复选标记字段元素中编辑文本。
置于前面 | 将选定元素移至前台。
发送至后面 | 将选定元素移至后台。
合并 | 合并选定的元素。
拆分 | 拆分选定的元素。
属性… | 显示/隐藏元素属性面板。
页面属性… | 打开页面属性对话框。


选项菜单

要打开选项对话框，请在工具菜单中选择选项…项目。

在此对话框中，您可以更改主应用程序窗口的外观，为空页面指定导出设置和布局属性。

显示选项对话框

选项

描述

查看

界面语言：

选择界面语言。该语言将用于所有程序消息、对话框标题和菜单项。要使更改生效，请单击确定并重新运行 ABBYY FormDesigner 10。
默认情况下，界面语言与您在安装过程中选择的语言相同。

网格

显示网格

显示网格。

默认情况下该选项并未选中。

宽度：

设置以毫米计的网格单元宽度。

默认值为 2 毫米。

高度：

设置以毫米计的网格单元高度。

默认值为 2 毫米。

快速移动至网格

将新创建元素的左上角与最近的网格节点对齐。当移动表单元素时，它也会与最近的网格节点对齐。

彩色

将已编辑文本的边距、标尺和背景的颜色更改为屏幕上显示的颜色。在项目：窗格中，请选择元素并单击下面的颜色矩形。在随后出现的颜色对话框中，选择所需的颜色。

显示标尺

显示/隐藏标尺。

显示间距

显示/隐藏表单边距。

文本编辑器

制表符宽度：

设置当您按 Tab 键时在文本编辑器中插入的空格数。

导出

XFD

xfd 文件的图像存储格式

从下拉列表中，选择当导出为 XFD 文件时您表单图像的存储格式。您有两个选择：

  • EMF
  • TIFF

图像

TIFF 文件的分辨率：

设置表单将导出为的 TIFF 文件的分辨率。

空白页面布局属性

样式：

从下拉列表中，选择空页面的样式。以下样式可用：

  • 灰色丢弃表单
  • 黑白表单
  • 橙色 drop-out 表单
  • 红色 drop-out 表单
  • 绿色丢弃表单
  • 彩色表单（不建议打印）

默认值为黑白表单。

纸张大小

大小：

从下拉列表中，选择空页面的纸张大小：A3、A4、A5、自定义大小、US Legal 或 US Letter。

默认值是 A4。

宽度：

设置以毫米计的空页面宽度。

默认值为 210 毫米。

高度：

设置以毫米计的空页面高度。

默认值为 297 毫米。

边距

顶部

为空页面设置以毫米计的上边距大小。

默认值为 10 毫米。

底部

为空页面设置以毫米计的下边距大小。

默认值为 10 毫米。

左

为空页面设置以毫米计的左边距大小。

默认值为 10 毫米。

右

为空页面设置以毫米计算的右边距大小。

默认值为 10 毫米。

背景

颜色：

从下拉列表中为丢弃表单选择表单背景色，或从彩色表单的调色板中选择。

注：只有彩色和丢弃表单才能选择颜色。对于黑白表单，白色为默认颜色。

大小：

使用此列表选择用背景色覆盖的区域。您有两个选择：

  • 整个页面（除表单元素以外的所有页面都将填充）。
  • 内部边距（页面将填充，但页面边距和表单元素将留白）。

注：对于黑白表单，该选项不可用。

方向

为空页面选择方向。它可以是纵向或横向。

默认字体

从下拉列表* 中为空页面选择字体并指定字体大小。

重置为默认值

单击重置为默认值按钮将空页面设置重置为其默认值。

*- 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


工具栏

ABBYY FormDesigner 10 中有四个工具栏：标准、设计工具、格式化和表单元素。

通过在视图>工具栏上选择或取消选择工具栏，或通过选择快捷菜单（右键单击工具栏以显示其快捷菜单）上的相应命令，可以显示/隐藏工具栏。

工具栏包含的按钮可用于快速访问本程序的工具和命令。使用相应的菜单或按快捷键也可以访问同样的命令。

您可以自定义工具栏按钮的大小。默认为使用小按钮。要更改按钮的大小，请选择视图>工具栏>大工具栏按钮。

要查看按钮功能，请将指针放在按钮上面直至显示工具提示。


标准工具栏

标准工具栏包含启动标准工具和执行标准操作（例如创建新表单或打开现有表单、撤消或恢复上一操作等）的按钮，按相应按钮可以执行相应的命令。

向我显示标准工具栏

标准工具栏上的按钮：

按钮 | 描述
新建 | 创建带基本元素的新表单。
打开… | 打开表单。
保存 | 保存表单。
打印预览 | 显示表单的打印效果。
打印 | 打印表单。
剪切 | 剪切选择的内容并将其放入剪贴板。
复制 | 将选择的内容复制到剪贴板。
粘贴 | 将剪贴板内容粘贴到表单中。
撤消 | 取消上次操作的结果。
恢复 | 取消上次撤消操作的结果。
缩小 | 将表单图像缩小一半。
放大 | 将表单图像放大一倍。
比例 | 更改图像比例。
发布表单 | 打开向导的形式分布（只适用已发布的表单）。


设计工具工具栏

设计工具工具栏包含编辑表单元素的按钮。单击按钮可以启动相应的设计工具。

向我显示设计工具栏

设计工具栏上的按钮：

按钮 | 描述
显示网格 | 显示/隐藏网格。
显示主标尺 | 显示/隐藏主标尺。
对齐网格 | 将新建元素的左上角与最近的网格节点对齐。移动表单元素时，表单元素同时也会与最近的网格节点对齐。
左对齐 | 将选定元素对齐上次选定元素的左边。
水平居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的垂直位置。
右对齐 | 将选定元素对齐上次选定元素的右边。
上对齐 | 将选定元素对齐上次选定元素的上边。
垂直居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的水平位置。
下对齐 | 将选定元素对齐上次选定元素的下边。
对齐网格 | 将所有选定元素的左上角对齐最近的网格节点。
以均匀的空格分布 | 均匀跨页的选定的空间元素。
以均匀的空格向下排列 | 沿着页面向下均匀排列选定的空间元素。
绘制相同高度 | 使所有选定元素的高度与上次选定元素的高度相同。
绘制相同宽度 | 使所有选定元素的宽度与上次选定元素的宽度相同。
绘制相同宽度和高度 | 使所有选定元素的高度和宽度与上次选定元素的高度相同。
网格大小 | 将选定元素的边框扩展至最近的网格线。
合并 | 合并表单上选定的元素。
拆分 | 拆分表单上选定的元素。
添加至合并的元素 | 将元素添加至先前合并的元素。必须选择要添加的元素和先前已经合并的元素。
置于前面 | 将选定元素移至前景。
发送至后面 | 将选定元素移至背景。
将对齐标尺快速移动至元素 | 打开/关闭自动绑定元素至标尺。如果开启该模式，当您移动表单上的标尺时，会自动绑定充分靠近该标尺的元素。
显示所有标尺 | 显示/隐藏 所有标尺。
垂直标尺 | 创建垂直标尺。
水平标尺 | 创建水平标尺。
删除所有标尺 | 显示所有标尺。


格式化工具栏

格式化工具栏包含设置表单文本格式的按钮。单击按钮可以选择相应的格式化工具。

选择要设置格式的文本，然后单击相应按钮来从工具栏上选择工具。

向我显示格式化工具栏

格式化工具栏上的按钮：

按钮 | 描述
字体 | 更改选定元素中文本的字体
字体大小 | 更改选定元素中文本的字号。
粗体 | 将选定文本更改为粗体。
斜体 | 将选定文本更改为斜体。
下划线 | 为选定文本添加下划线。
左对齐 | 将选定元素中的文本对齐元素的左边缘。
水平居中 | 水平居中选定元素中的文本：
右对齐 | 将选定元素中的文本对齐元素的右边缘。
两端对齐 | 两端对齐选定元素中的文本。
下对齐 | 将选定元素中的文本对齐元素的下边缘。
垂直居中 | 垂直居中选定元素中的文本：
上对齐 | 将选定元素中的文本对齐元素的上边缘。
文本左侧 | 将复选标记字段放在说明性文本左侧。
文本上方 | 将复选标记字段放在说明性文本上方。
文本右侧 | 将复选标记字段放在说明性文本右侧。
文本下方 | 将复选标记字段放在说明性文本下方。

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


表单元素工具栏

在表单元素工具栏上，您将找到用于将新元素添加至表单的按钮。单击按钮以将相应的元素添加至表单。

显示表单元素工具栏

表单元素工具栏上的按钮：

按钮 | 描述
选择工具 | 在工具栏上选择工具，或在表单中选择元素。
输入字段 | 将输入字段元素添加至表单。
日期字段 | 将日期字段添加至表单。
数字字段 | 将数字字段添加至表单。
复选标记字段 | 将复选标记字段元素添加至表单。
元素组 | 添加元素组
表格 | 将表格元素添加至表单。
垂直分隔符 | 将垂直分隔符添加至表格。
水平分隔符 | 将水平分隔符添加至表格。
删除分隔符 | 从表格中删除分隔符。
文本 | 将文本元素添加至表单。
行分隔符 | 将行分隔符元素添加至表单。
矩形 | 将矩形元素添加至表单。
图片 | 将图片元素添加至表单。
定位点 | 将定位点元素添加至表单。
标识符 | 将标识符元素添加至表单。
复选标记组 | 将复选标记组元素添加至表单。


使用 ABBYY FormDesigner 9.0

使用 ABBYY FormDesigner 10

本节包含 ABBYY FormDesigner 的功能信息。

目录

  • 创建表单

  • 表单属性

  • 文档结构

  • 添加、编辑和删除表单元素

  • 选择和移动表单元素

  • 保存和发布表单；检查表单的机器可读性

  • 导出表单

  • 发布表单

  • 打印表单

  • 打印部分填好的表单


创建、保存和打开表单

创建表单

在启动本应用程序或选择文件>新建…时，会打开快速启动对话框。在该对话框中，可以从头创建新表单（空表单或含基本元素的表单），基于样本创建表单，或使用表单向导引导您完成表单创建进程的所有步骤。向导完成表单创建后，您只需添加所需的表单元素（使用表单元素工具栏）和保存表单。

有关详细信息，请参阅创建表单。

保存表单

要保存表单，请选择文件菜单上的标准保存命令或另存为…命令。

打开表单

要打开表单：

  • 选择文件菜单上的打开…项目，或

  • 单击标准工具栏上的打开图标。

  • 按 Ctrl+O。


发布表单

在发布表单时要为表单分配已发布状态，以防止更改表单。同时还会检查表单的机器可读性并为该表单分配一个唯一的标识数字。

要发布表单，请选择文件菜单上的发布表单 。

已发布表单的状态为只读。要启用对已发布表单的更改，请选择文件菜单上的将可编辑副本另存为…。应用程序将要求您在更改设计前，先以不同的名称另存该表单。

有关详细信息，请参考保存和发布表单；检查表单的机器可读性。


表单另存为图像

要将表单另存为图像，请选择图像文件…项目（表单>导出至>图像文件…）并在打开的将图像另存为对话框中选择所需的图像格式，指定该图像文件的名称，并浏览至要存储该文件的文件夹。

有关详细信息，请参阅将表单导出至图像文件。


创建 ABBYY FlexiCapture 的模板

ABBYY FormDesigner 10 有一个重要优点：一旦在 ABBYY FormDesigner 中创建表单，即可获得用于在 ABBYY FlexiCapture 10 中创建文档定义的表单描述。

要获得 ABBYY FlexiCapture 10 的描述：

  1. 在 ABBYY FormDesigner 10 中创建一个表单。
  2. 发布该表单（文件>发布表单）。
  3. 将已发布的表单导出至 XML 表单定义格式（文件>导出至>XML 表单定义…）。在打开的导出至 XML 表单定义对话框中，指定该文件的名称，并浏览至要存储该文件的文件夹。
  4. 运行 ABBYY FlexiCapture 10 并打开文档模板对话框（项目>文档定义..）。
  5. 单击导入并选择新建的的 *.xfd 文件。
有关详细信息，请参阅将表单导出至 XML 表单定义格式 (*.xfd)。


创建表单

表单创建进程由三个阶段组成：分析、设计和打印。

在分析阶段，设计师必须执行以下工作：

  1. 分析表单内容，确定字段名称和说明性文本。
  2. 选择最恰当的表单类型（带光栅边框的黑白表单、黑白线性表单、颜色滴定表单等）和打印方法（在印刷厂打印，在打印机上打印，使用 Xerox 机器、发布到因特网上等等）。
  3. 确保表单为机器可读表单。

在设计阶段，设计师必须执行以下工作：

  1. 在计算机上创建表单。

  2. 发布表单，即锁定表单的编辑，以防表单被更改（这样可以确保打印所有相同的表单时能使用完全相同的源表单）。

在发布阶段，表单要

  1. 做好发布准备
  2. 以硬拷贝或电子的方式进行发布

新建表单

多页表单

基于样本创建表单

添加、编辑和删除表单元素

选择和移动表单元素

保存和发布表单；检查表单的机器可读性

导出表单

发布表单

打印表单


新表单

您可以通过选择文件>新建…或通过在键盘上按 Ctrl+N 使用快速启动对话框（当您启动应用程序时打开）创建新表单。

快速启动对话框使您可以使用三种可用方法中的任一种创建新表单：

  • 创建空表单在对话框的右侧，请选择您想要创建的表单 - 空表单或带有基本元素的表单。通过单击标准工具栏上的新建按钮也可以带有基本元素的表单。
  1. 如果您选择空表单，ABBYY FormDesigner 10 将创建在其中没有任何元素的表单。

  2. 如果您选择带基本元素的空表单，ABBYY FormDesigner 10 将创建带有一些基本元素的黑白表单：
    定位点
    机器可读表单的元素，用于将表单与其模板匹配并在处理过程中决定其方向。
    （四个黑方块位于表单的角上，一个附加的黑方块在表单的任何位置，稍后当您编辑表单时，您可以用您选择的其他定位点替换黑方块），标识符元素
    机器可读表单的元素，允许表单处理程序识别表单。
    （带数字的条形码），及文本元素
    机器可读表单的元素，包含描述和解释性文本，例如，字段名称、有关如何填写表单的说明等。
    表单的标题应该位于此处。
  • 基于表单样本创建表单在对话框的右侧，请选择您想要作为样本为新表单使用的 *.dtf 文件。默认情况下，表单样本保存在 С:\Documents and Settings\<username>\My Documents\Templates\。
  • 使用表单创建向导创建表单。
  1. 指定表单的页面属性 - 页面大小和方向。
  2. 指定您的表单类型（黑白、灰色背景、彩色背景）、背景大小（对于背景表单：整个页面或仅内部间距）和定位点类型。
  3. 选择表单布局元素。您可以添加标题（提供标题文本）、标识符（指定其类型和位置）和模板（选择语言）。
  4. 从列表中添加标准元素至表单：名称、别名、联系信息。在对话框右侧，您将看到表单的预览。要添加/删除元素，请使用 >>/<><> 按钮。

    要退出向导，请单击完成。您创建的表单将在主窗口中自动打开。然后，您可以编辑和保存表单。

表单设置

页面设置


多页表单

在 ABBYY FormDesigner 10 中，您可以创建由多个页面组成的多页表单。对于每个页面，您可以在表单中指定名称及其副本数。多页表单描述导出为 XFD 格式，在 ABBYY FlexiCapture 10 中可用于创建多页文档定义。

创建多页表单

您可以创建基于表单样本的多页表单。

添加页面

新页面可添加至任何类型的表单。要添加新页面，请选择表单>添加页面，或右键单击在表单底部的页面名称并选择插入页面。您可以添加空页面或基于样本的页面。也可以通过单击表单底部的 [image] 图标添加新的空页面。对于空页面，其设置可在工具>选项菜单的空白页面布局属性选项卡上指定。

在表单中，页面可以出现任何次数。您可以在页面属性对话框（表单>页面属性…）中设置页面出现的最小和最大次数。您还可以在此对话框中为当前页面指定名称。

要更改页面顺序，请在表单底部选择页面并使用拖放操作移动该页面。

导出多页表单

多页表单图像可导出至任何支持的图像格式。您可以选择将每个页面保存在独立的图像文件中，或者将所有页面保存在一个图像文件中。


基于样本创建表单

可以使用样本来创建新表单或表单页面。

要创建表单（或页面）样本：

  1. 在 ABBYY Form Designer 中创建一个表单（或页面）
  2. 选择文件>另存为…
  3. 在保存类型下拉列表中，选择表单样本文件或页面样本文件
  4. 单击保存

表单样本的默认保存目录：С:\Documents and Settings\<username>\My Documents\Templates\。

表单样本是二进制文件，其扩展名为 *.dtf。页面样本保存为 *.ptf 格式，该格式是 *.fdd 格式的改良版。

要基于表单样本创建新表单，请选择模板中表单中的基于表单样本。

要向基于页面样本的多页表单添加新页面，请选择表单>添加页面>基于页面样本…。


表单设置

表单的主要属性可在表单属性对话框（表单>表单属性…）中查看。

显示表单属性对话框
项目 | 描述
作者： | 该表单的创建人的名字
状态： | 表单状态： 草稿，如果允许在表单上进行修改； 已发布，如果表单是只读的。
发布日期： | 表单的发布日期。
表单标识符： | 表单标识符的值。
文件： | 包含表单的文件的路径。


页面设置

页面设置决定页面的大小、其方向、缩进和样式。要更改页面设置，请选择表单>页面属性…，或者右键单击页面并在快捷菜单上选择页面属性…。

显示页面属性对话框

项目

描述

常规

名称：

设置页面名称。

最少出现次数：

设置当前页面在表单中的最少出现次数。

最大出现次数：

设置当前页面在表单中的最大出现次数。

页面标识符：

显示页面标识符的值。

布局

样式：

设置表单样式：

  • 灰色 drop-out 表单
  • 黑白表单
  • 橙色 drop-out 表单
  • 红色 drop-out 表单
  • 绿色 drop-out 表单
  • 彩色表单（不建议打印）

纸张大小

大小：

从下拉列表中选择标准的页面大小之一（A3、A4、A5、US Legal 或 US Letter），或设置您自己的自定义页面大小。要设置您自己的页面大小，请在列表中选择自定义大小项目并在相应字段指定所需的宽度和高度。

宽度：

设置页面宽度。

高度：

设置页面高度。

边距

顶部：

设置上边距的宽度。

底部：

设置下边距的宽度。

左 ：

设置左边距的宽度。

右 ：

设置右边距的宽度。

颜色：

从下拉列表中为丢弃表单选择表单背景色，或从彩色表单的调色板中选择。

注：只有彩色和丢弃表单才能选择颜色。对于黑白表单，白色为默认颜色。

大小：

使用此列表选择用背景色覆盖的区域。您有两个选择：

  • 整个页面（除表单元素以外的所有页面都将填充）。
  • 内部边距（页面将填充，但页面边距和表单元素将留白）。

注：对于黑白表单，该选项不可用。

方向

纵向

设置纵向页面方向。

横向

设置横向页面方向。

Default font

从下拉列表* 中为空页面选择字体并指定字体大小。

*- 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


添加、编辑和删除表单元素

一旦已经创建了新表单，您就可以向表单添加元素并编辑它们。

提示
在向表单添加元素之前，请务必与您的客户讨论表单设计和内容。

向表单添加元素的建议顺序：

  1. 设置间距
  2. 添加参考标记（定位点）
  3. 添加其他表单元素

要使表单成为机器可读表单，必须在其四周留有间距。默认的间距宽度是 10 毫米。您可以在页面属性对话框中更改默认宽度（表单 > 页面属性…>大小：）。

间距在屏幕上以虚线显示。如果您希望间距显示在表格中，请在选项对话框（工具选项…）的查看选项卡上选择显示间距项目。

您可以指定每个元素的属性。

定位点

文本

输入字段

日期字段

数字字段

复选标记字段

复选标记组

行分隔符

矩形

图片

表单标识符

表格

元素组


文档结构

添加表单元素时，ABBYY FormDesigner 10 自动构建一个文档结构，该结构即链接至表单图像上的一个或多个元素的表单字段的层次。您可以将文档结构和链接元素修改为任何适当类型的字段。

文档结构是作为 XFD 文件的一部分进行保存和导出。

查看文档结构

要查看当前文档的结构，请选择视图>文档结构。在右侧窗格中，将显示当前表单中的字段结构。您可以添加新字段，删除、移动现有字段或为现有字段重命名。要对字段进行操作，请右键单击一个字段，并从快捷菜单（添加字段、删除字段、重命名字段）上选择一个项目。要移动层次中的字段，请按 Ctrl+向上/向下箭头或选择上移字段/下移字段。如果一个字段有链接的元素，只能在层次中该字段的当前等级内进行移动，否则也可以在组与组之间移动字段。

添加新字段

向表单添加新元素时，ABBYY FormDesigner 10 自动在与新建元素同类型的文档结构中创建一个新字段。要手动创建新字段，选择添加字段，然后选择新字段的类型。

链接表单元素到字段

在添加新元素时，ABBYY FormDesigner 10 自动将该元素链接至自动为它创建的文档结构中的字段。要将元素链接至其他字段：

  • 选择表单图像上所需的元素
  • 右键单击该元素并选择快捷菜单上的属性…。
  • 在元素属性对话框中，单击链接的字段选项卡并从下拉列表中选择一个字段。您只能从类型符合选定元素的字段中进行选择。如果元素属于某个组，只能链接至属于相应的组字段的字段。

注：没有链接元素的字段的名称以斜体显示在结构窗格中。

删除字段和元素

要从文档结构中删除字段，请选择所需字段并按 Delete，或右键单击所需的元素并选择快捷菜单上的删除。

删除元素时，链接该元素的字段也被删除，除非还有其他元素链接该字段。要删除元素但是保留相应的字段，请按 Shift+Delete，或选择编辑菜单上的删除区域命令，或右键单击该元素并选择快捷菜单上的删除区域命令。


定位点

定位点是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

向表单添加定位点是表单设计的重要阶段。

ABBYY FormDesigner 10 允许您向表单中添加两类定位点：黑方块形和直角形。
类型 | 描述
黑方块形 | 定位点的形状为方块形。
直角形 | 定位点的形状为直角形。

只能对表单采用一种类型的定位点。在指定表单上要使用的定位点类型时，还需要设置定位点的属性：

  • 大小：黑方块形的每条边的长度或直角形的每条边的长度。
  • 线宽：直角形的每条边的线宽（此参数不适用黑方块形）

添加定位点元素

编辑定位点元素

删除定位点元素


添加定位点元素

您可以向表单中添加定位点。定位点的大小由用户定义。

要添加定位点：

  1. 在表单元素工具栏上，选择定位点工具。
  2. 单击表单上要添加定位点的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，定位点将被放至矩形左上角。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

向每个具备基本元素的新表单中添加的定位点的默认类型是黑方块形。如果要将定位点类型更改为直角形，请右键单击定位点并选择快捷菜单上的属性。在打开的对话框中更改定位点的类型。


编辑定位点元素

以下定位点属性将应用至整个表单：类型：、大小：和行宽：（对于十字形）。

对于每个定位点，可以指定以下属性：位置、大小和类型。定位点属性并不依赖于表单类型。

您可以在主窗口右下角的元素属性窗口更改定位点元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

定位点

ID

元素的唯一标识符。

位置和大小

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置定位点元素的宽度。

高度：

设置定位点元素的高度。

重要事项！

要更改定位点的大小，请选择定位点选项卡。

定位点

类型：

从下拉列表中，请选择希望在您的表单中使用的点位点类型 - 黑方形或十字形。

每个表单只可以包含一种类型的定位点。

大小：

设置定位点大小：
黑方形每一边的长度，或

十字形每一边的长度。

行宽：（仅适用于十字形）

设置十字形每一边的行宽度（从 0.3 毫米到 1 毫米）。


删除定位点元素

要删除定位点：

  1. 选择要删除的定位点。

  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


文本

文本是机器可读表单的一种元素，它包含字段名称、如何填写表单的操作指示等描述和说明性文本。

添加文本元素

编辑文本元素

删除文本元素

文本元素快捷菜单


添加文本元素

要添加文本元素：

  1. 在表单元素工具栏上，请选择文本工具。

  2. 在表单中单击您希望文本元素所添加的位置，按住鼠标左键并呈对角拖动鼠标。松开鼠标。

注：您也可以单击鼠标创建元素：当您选择了所需的工具时，只要在表单中单击您想要元素所添加的位置。将使用默认的元素大小。要在您的表单中放置几个相同类型的元素，请按下 Ctrl 键并重复单击您希望放置元素的位置。

注：您可以用鼠标修改文本区域：

  1. 按住 Alt 键。
  2. 将鼠标指针放在文本区域内并选择部分区域。此部分将从区域中删除。
  3. 如有必要，请调整区域边框。


编辑文本元素

对于每个文本元素，可指定以下属性：元素的大小和位置、文本、字体、文本颜色、自动换行、水平和垂直对齐、方向和元素背景色。

您可以在元素字段直接编辑元素文本。要启用文本编辑模式，请右键单击元素或在快捷菜单中选择文本>编辑文本。然后使用用于编辑的热键。

您可以在主窗口右下角的元素属性窗口更改文本元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

文本

ID

元素的唯一标识符。

位置和大小组

左：

 设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

 设置文本元素的宽度。

高度：

 设置文本元素的高度。

文本

文本：

显示元素的文本。
注：要编辑元素的文本，请在文本元素的快捷菜单中单击编辑文本。文本可直接在元素字段中编辑。

字体：

元素中文本使用的字体。
要更改字体、其大小和样式（斜体、粗体、下划线等），请单击更改…按钮并在随后出现的字体对话框中选择所需的字体、字体大小和样式。

颜色：

从下拉列表* 中为丢弃表单选择文本颜色，或从彩色表单的调色板中选择。

自动换行

在不拆分单词的情况下文本换行。

对齐

水平：

在元素内水平对齐文本：

  • 居中 - 文本水平居中

  • 左 - 将文本与元素的左边缘对齐

  • 右 - 将文本与元素的右边缘对齐

垂直：

在元素内垂直对齐文本：

  • 底部 - 将文本与元素的下边缘对齐

  • 居中 - 文本垂直居中

  • 顶部 - 将文本与元素的上边缘对齐

方向：

设置文本方向。

  • 正常（水平） - 文本将水平排列，从左到右
  • 垂直（从上至下） - 文本将垂直排列，从上至下
  • 垂直（从下至上） - 文本将垂直排列，从下至上

背景

与表单背景相同

使文本的背景与表单的背景颜色相同。

其它：

从下拉列表* 中为丢弃表单选择文本背景色，或从彩色表单的调色板中选择。

* - 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除文本元素

要删除文本元素：

  1. 选择要删除的文本元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目，或按键盘上的 Delete 键）。


文本元素快捷菜单

此菜单在编辑文本元素的内容时可用。

项目 | 描述
剪切 | 删除选定的元素或文本并将其复制至剪贴板。
复制 | 将选定的元素或文本复制至剪贴板。
粘贴 | 粘贴剪贴板中的元素或文本。
删除 | 删除选定元素。同时也会删除关联的结构字段。
字体… | 打开字体：对话框。
段落… | 打开段落属性对话框。


输入字段

输入字段是机器可读表单的一种元素，在表单中的该字段可以输入文本。

显示输入字段元素

添加输入字段元素

编辑输入字段元素

删除输入字段元素


添加输入字段元素

要添加输入字段元素：

  1. 在表单元素工具栏上，选择输入字段工具。

  2. 单击表单上要添加输入字段元素的位置，按住鼠标左键并成对角拖动鼠标。

  3. 屏幕上将显示一个矩形。调整添加的元素的大小*。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

*- 如果在元素属性中启用了多行，那么只能更改输入字段元素的垂直大小。


编辑输入字段元素

对于每个输入字段元素，可以指定以下属性：位置和大小、标记类型、单元大小、元素中文本行数、标记线宽度、标记线颜色、提示文本、提示文本颜色、提示字体、选择提示字体大小的模式和该元素的背景色和链接字段。

您可以在元素属性窗口中更改输入字段元素的属性，该窗口位于主窗口右下角。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

输入字段

ID

元素的唯一标识符。

位置和大小

左：

设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置输入字段元素的宽度。

高度：

设置输入字段元素的高度。

重要事项！
只有当您在标记选项卡上选择了多行复选框，您才可以在输入字段中更改行数。使用标记选项卡更改单元高度。

对齐

水平：

在元素内水平对齐文本：

  • 居中 - 文本水平居中
  • 左 - 将文本与元素的左边缘对齐
  • 右 - 将文本与元素的右边缘对齐

垂直：

在元素内垂直对齐文本：

  • 底部 - 将文本与元素的下边缘对齐
  • 居中 - 文本垂直居中
  • 顶部 - 将文本与元素的上边缘对齐

方向：

 设置文本方向。
  • 正常（水平） - 文本将水平排列，从左到右
  • 垂直（从上至下） - 文本将垂直排列，从上至下
  • 垂直（从下至上） - 文本将垂直排列，从下至上

标记

标记类型：

为文本选择标记类型：

  • 在单独虚线框中的字母

  • 在单独框中的字母

  • 在组合中的字母

  • 框中带有组合的文本

  • 框中的字母

单元大小：

设置字符单元大小：

  • 正常 – 标准单元大小（4x5 毫米）

  • 大 – 最大单元大小（5x6.5 毫米）

  • 小 – 最小单元大小（3x4 毫米）

粗体标记线（对于除在“单独虚线框中的字母”以外的所有标记类型)

将单元框更改为粗体

标记颜色：

从下拉列表* 中为丢弃表单选择标记颜色，或从彩色表单的调色板中选择。

多行

添加多行至输入字段。

提示

文本：

设置提示文本。提示将在表单的输入字段中输入：提示的每个字母将放在对应的单元中。

颜色：

从下拉列表* 中为丢弃表单选择提示颜色，或从彩色表单的调色板中选择。

字体：

选择提示字体。

自动调整字体大小

根据字段的字符单元高度自动为提示选择字体大小。

背景

与表单背景相同

使输入字段的背景和表单的背景颜色相同。

其它：

从下拉列表 * 中为丢弃表单选择输入字段背景颜色，或从彩色表单的调色板中选择。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

约束

不能为空

如果选择该选项，除非输入字段已填写，否则表单无法导出。

限制：

使用以下按钮配置输入字段的限制：

  • 添加... - 打开先前创建的规则列表。要添加新规则，请在允许值规则或正则表达式规则列表中双击创建新规则…项目。对应的对话框将打开。
  • 编辑... - 根据选定的规则打开允许值规则或正则表达式规则对话框。
  • 除去... - 除去选定规则。

* - 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除输入字段元素

要删除输入字段元素：

  1. 选择要删除的输入字段元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


为输入字段元素配置规则

通过使用规则，您可以为输入字段元素对容许值加以限制。

要添加规则，请在元素属性的约束选项卡上单击添加…按钮。在随后打开的校验规则：选择规则定义窗口，双击允许值规则或正则表达式规则列表中的创建新规则…项目以创建新的允许值或正则表达式规则。相应的对话框将打开。

显示允许值规则对话框

选项

描述

重命名…

单击此按钮重命名规则。在随后打开的对话框中，输入规则的新名称并单击确定。

文本：

  • 添加 - 将输入值添加至列表。
  • 除去 - 从列表中除去选定值。

允许自定义文本条目

如果您希望允许输入不在列表中的值，请选择该选项。如果取消选择该选项，您只可以从列表中选择值。
显示正则表达式规则对话框

选项

描述

重命名…

单击此按钮重命名规则。在随后打开的对话框中，输入规则的新名称并单击确定。

模式：

  • 添加 - 将输入的正则表达式添加至列表。另见正则表达式中使用的符号集。
  • 除去 - 从列表中除去选定表达式。

错误消息

自动生成

如果选择了该选项，错误消息文本将自动生成。如果您想输入自定义文本，请取消选择该选项。


日期字段

日期字段元素是机器可读表单的一种元素，它表示填入表单中的输入日期。

显示日期字段

添加日期字段

编辑日期字段

删除日期字段


添加日期字段元素

要添加日期字段

日期字段元素是机器可读表单的一种元素，在表单中的该字段可以输入日期。
填写表单时：
  1. 在表单元素工具栏上，选择日期字段工具。
  2. 单击表单上要添加日期字段元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，日期字段将被放到基准点的左上角。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑日期字段元素

对于每个日期字段元素

机器可读表单的元素，在填写表格时应在此输入日期。
已指定以下属性：元素的位置和大小、文本标记、字符单元大小、多行、粗体/正常标记线、标记颜色、日期格式、要记录日期的字符单元数、分隔符、分隔符颜色、提示颜色、提示字体、提示文本字体、自动选择提示字体高度、元素背景颜色、链接字段。

您可以在主窗口右下角元素属性窗口中更改日期字段元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

日期字段

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置日期字段元素的宽度。

高度：

设置日期字段元素的高度。

重要事项！

要更改字符单元高度，请转至标记选项卡。

对齐

水平：

在元素内水平对齐文本：

  • 居中 - 文本水平居中
  • 左 - 将文本与元素的左边缘对齐
  • 右 - 将文本与元素的右边缘对齐

垂直：

在元素内垂直对齐文本：

  • 底部 - 将文本与元素的下边缘对齐
  • 居中 - 文本垂直居中
  • 顶部 - 将文本与元素的上边缘对齐

方向：

设置文本方向。

  • 正常（水平） - 文本将水平排列，从左到右
  • 垂直（从上至下） - 文本将垂直排列，从上至下
  • 垂直（从下至上） - 文本将垂直排列，从下至上

标记

标记类型：

从列表中选择标记类型：

  • 在单独虚线框中的字母
  • 在单独框中的字母
  • 在组合中的字母
  • 框中带有组合的文本
  • 框中的字母

单元大小：

从列表中选择单元大小：

  • 标准 - 建议的标准单元大小（4х5 毫米）
  • 最大 - 建议的单元大小最大值（5х6.5 毫米）
  • 最小 - 建议的单元大小最小值（3х4 毫米）

粗体标记线（当选择了除在单独虚线框中的字母外的任何标记类型）

选择粗体文本标记行。

标记颜色：

从下拉列表* 中为丢弃表单选择标记颜色，或从彩色表单的调色板中选择。

日期

日期格式：

指定日期格式：

  • DD.MM.YYYY

  • MM.DD.YYYY

  • YYYY.MM.D

年份中的数字：

指定一年的单元数

  • 2（2 个单元可用）

  • 4（4 个单元可用）

分隔符：

为日期选择分隔符：

  • .

  • /

  • -

颜色：

从下拉列表* 中为丢弃表单选择分隔符颜色，或从彩色表单的调色板中选择。

提示文本：

从下拉列表中选择提示颜色。提示将在表单的日期字段中输入：提示的每个字母将放在对应的单元。

颜色：

从下拉列表* 中为丢弃表单选择提示颜色，或从彩色表单的调色板中选择。

字体：

选择提示字体。

自动调整字体大小

根据字段的字符单元高度自动为提示选择字体大小。

背景*

与表单背景相同*

使日期字段元素的背景与表单背景的颜色相同。

其它：

从下拉列表*中为丢弃表单选择日期字段背景颜色，或从彩色表单的调色板中选择。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

约束

不能为空

如果选择该选项，除非日期字段已填写，否则表单无法导出。

限制：

使用以下按键配置日期字段的限制：

  • 添加... - 打开先前创建的规则列表。要添加新规则，请在日期间隔列表中双击创建新规则…项目。日期间隔规则对话框将打开。
  • 编辑... - 打开日期间隔规则对话框，您可以在此为选定规则添加或除去日期间隔。
  • 除去... - 除去选定规则。

* - 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除日期字段元素

要删除日期字段元素：

  1. 选择日期字段元素；
  2. 选择删除项目（使用编辑>删除菜单或从快捷菜单中选择删除项目）。


为日期字段元素配置规则

通过使用规则，您可以为日期字段元素对容许值加以限制。

要添加规则，请在元素属性的约束选项卡上单击添加…按钮。在随后打开的校验规则：选择规则定义窗口中，双击日期间隔规则列表中的创建新规则…项目以创建新规则。日期间隔规则对话框将打开。

显示日期间隔规则对话框

选项

描述

重命名…

单击此按钮重命名规则。在随后打开的对话框中，输入规则的新名称并单击确定。

从 ... 至

  • 添加 - 将已输入的日期间隔添加到列表。
  • 除去 - 从列表中除去选定的间隔。

错误消息

自动生成

如果选择了该选项，错误消息文本将自动生成。如果您想输入自定义文本，请取消选择该选项。


数字字段

数字字段是机器可读表单的一种元素，它表示填入表单中的输入数字。

显示数字字段元素

添加数字字段元素

编辑数字字段元素

删除数字字段元素


添加数字字段元素

要添加数字字段

数字字段元素是机器可读表单的一种元素，在表单中的该字段可以输入数字。
表单上的元素：
  1. 在表单元素工具栏上，选择数字字段工具。
  2. 单击表单上要放置数字字段元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑数字字段元素

对于每个 数字字段

机器可读表单的元素，用于在填写表格时输入数字。
可指定元素的以下属性：元素位置和大小、文本标记、字符单元大小、多行、粗体/正常标记行、标记颜色、用来记录小数的小数部分的字符单元数、分隔符、分隔符颜色、提示颜色、提示字体、提示文本字体、自动选择提示字体高度、元素背景颜色和链接字段。

您可以在主窗口右下角的元素属性窗口更改数字字段元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

数字字段

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置数字字段元素的宽度。

高度：

设置数字字段元素的高度。

对齐

水平：

在元素内水平对齐文本：

  • 居中 - 文本水平居中
  • 左 - 将文本与元素的左边缘对齐
  • 右 - 将文本与元素的右边缘对齐

垂直：

在元素内垂直对齐文本：

  • 底部 - 将文本与元素的下边缘对齐
  • 居中 - 文本垂直居中
  • 顶部 - 将文本与元素的上边缘对齐

方向：

 设置文本方向。
  • 正常（水平） - 文本将水平排列，从左到右
  • 垂直（从上至下） - 文本将垂直排列，从上至下
  • 垂直（从下至上） - 文本将垂直排列，从下至上

标记

标记类型：

从列表中选择标记类型：

  • 在单独虚线框中的字母
  • 在单独框中的字母
  • 在组合中的字母
  • 框中带有组合的文本
  • 框中的字母

单元大小：

从列表中选择单元大小：

  • 标准 - 建议的标准单元大小（4х5 毫米）
  • 最大 - 建议的单元大小最大值（5х6.5 毫米）
  • 最小 - 建议的单元大小最小值（3х4 毫米）

粗体标记线（当选择了除在单独虚线框中的字母以外的任何标记类型）

选择粗体文本标记行。

标记颜色：

从下拉列表* 中为丢弃表单选择标记颜色，或从彩色表单的调色板中选择。

编号

小数位：

为小数选择小数位的数目。

分隔符：

为数字选择分隔符：

  • .

  • /

  • -

颜色：

从下拉列表* 中为丢弃表单选择分隔符颜色，或从彩色表单的调色板中选择。

提示文本：

选择提示颜色 提示将在表单的数字字段中输入：每个字母在相应的单元。

颜色：

从下拉列表* 中为丢弃表单选择提示颜色，或从彩色表单的调色板中选择。

字体：

选择提示字体。

自动调整字体大小

根据字段的字符单元高度自动为提示选择字体大小。

背景

与表单背景相同

使数字字段的背景与表单的背景颜色相同。

其它：

从下拉列表* 中为丢弃表单选择数字字段背景颜色，或从彩色表单的调色板中选择。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

约束

不能为空

如果选择了该选项，则除非填写了数字字段，否则无法导出表单。

限制：

使用以下按钮为数字字段配置限制：

  • 添加... - 打开先前创建的规则列表。要添加新规则，请在间隔规则列表中双击创建新规则…项目。间隔规则对话框将打开。
  • 编辑... - 打开间隔规则对话框，您可以在此为选定的规则添加或删除间隔。
  • 除去... - 除去选定规则。

* - 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除数字字段元素

要删除数字字段元素：

  1. 选择一个数字字段元素。
  2. 选择删除项目（使用编辑>删除菜单或从快捷菜单中选择删除项目）。


为数字字段元素配置规则

通过使用规则，您可以为数字字段元素对容许值加以限制。

要添加规则，请在元素属性的约束选项卡上单击添加...按钮。在随后打开的校验规则：选择规则定义窗口，双击间隔规则列表中的创建新规则…项目。间隔规则对话框将打开。

显示间隔规则对话框

选项

描述

重命名…

单击此按钮重命名规则。在随后打开的对话框中，输入规则的新名称并单击确定。

跨区：从 ... 至

  • 添加 - 向列表添加已输入的间隔。
  • 除去 - 从列表中除去选定的间隔。

错误消息

自动生成

如果选择了该选项，错误消息文本将自动生成。如果您想输入自定义文本，请取消选择该选项。


复选标记字段

复选标记字段是机器可读表单的一种元素（通常是一个复选框），在该框中可以填入一个标记（如勾或叉等）。

添加复选标记字段元素

编辑复选标记字段元素

删除复选标记字段元素


添加复选标记字段

要添加复选标记字段元素：

  1. 在表单元素工具栏上，选择复选标记字段工具。

  2. 单击表单上要添加复选标记字段元素的位置，按住鼠标左键并呈对角拖动鼠标。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑复选标记字段

对于每个复选标记字段元素，可指定以下属性：文本位置、字段大小、边框宽度、边框颜色、间隙、文本、字体、自动换行、文本颜色、背景色、链接字段。

您可以在位于主窗口右下角的元素属性窗口更改复选标记字段元素。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

要更改复选标记字段的解释性文本，请双击文本区域。

项目

描述

元素

类型：

复选标记字段

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置复选标记字段元素的宽度。

高度：

设置复选标记字段元素的高度。

文本

文本：

复选标记字段随附的解释性文本。

字体：

解释性文本的字体。
要更改字体、其大小和样式（斜体、粗体、下划线等），请单击更改…按钮并在随后出现的字体对话框中选择所需字体、字体大小和类型。

字体颜色 ：

从下拉列表* 中为丢弃表单选择文本背景色，或从彩色表单的调色板中选择。

自动换行

在不拆分单词的情况下文本换行。

复选标记字段

类型：

复选标记字段的形状：

  • 方形

  • 圆形

  • 下划线

位置：

设置与解释性文本相关的复选标记字段的位置：

  • 文本左侧 - 复选标记字段在文本左侧

  • 文本右侧 - 复选标记字段在文本右侧

  • 文本上方 - 复选标记字段在文本上方

  • 文本下方 - 复选标记字段在文本下方

大小：

下拉列表包含预定义的字段大小（3.5x3.5、4x4、4.5x4.5 或 5x5 mm）。

行宽：

设置字段边框的宽度（从 0.4 毫米到 0.8 毫米）。

平衡：

设置复选标记字段与解释性文本之间的空白（从 2 毫米到 7 毫米）。

颜色：

从下拉列表* 中为丢弃表单选择字段边框的颜色，或从彩色表单的调色板中选择。

背景

与表单背景相同

使复选标记字段的背景与表单背景颜色相同。

其它：

从下拉列表* 中为丢弃表单选择复选标记字段背景色，或从彩色表单的调色板中选择。

提示

文本

设置提示文本。提示将输入在复选框中。

字体：

选择提示字体。
要更改字体、其大小和样式（斜体、粗体、下划线等），请单击更改…按钮并在随后出现的字体对话框中选择所需字体、字体大小和类型。

颜色：

从下拉列表* 中为丢弃表单选择提示颜色，或从彩色表单的调色板中选择。

自动调整字体大小

根据字段的字符单元高度自动为提示选择字体大小。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

*- 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除复选标记字段元素

要删除复选标记字段元素：

  1. 选择要删除的复选标记字段元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


复选标记组

复选标记组是机器可读表单的元素，该表单在一个组中中连接几个复选标记字段。复选标记组是由一个文本字段（问题）和几个复选标记字段（回答）组成的表格。使用复选标记组创建向导，您可以创建选定类型的复选标记组（矩阵、表格或列表）并指定其属性。

添加复选标记组元素

编辑复选标记组元素

删除复选标记字段元素


添加复选标记组

要添加复选标记组元素，请使用复选标记组创建向导。

要打开复选标记组创建向导，请在表单元素工具栏中选择复选标记组工具并单击表单。将显示复选标记组创建向导。

创建复选标记组由两个步骤组成。

第一步，在类型窗口中指定以下选项：

  1. 选择复选标记组类型：矩阵、表格或列表。

  2. 从右侧图片，为所需类型选择复选标记组。复选标记组在问题和标签相对于复选标记的位置方面有所不同。黄色矩形显示问题的位置，而蓝色矩形显示标签。

  3. 选择复选标记类型：方块形或圆圈。

  4. 单击下一步。

问题和答案窗口将打开。窗口视图取决于上一步所指的复选标记组类型。

对于矩阵和表格复选标记类型，可使用以下选项：

  • 问题数
  • 问题文本
    选择添加编号选项以枚举问题。
  • 回答数
  • 回答视图
    如果选择了按列表选项，您可以为问题指定预定义的回答（所有回答或部分回答）。列表中的答案必须以分号分隔。
    如果选择了按文本选项，您可以更改标签的文本。
  • 在按文本输入字段下选择添加编号选项以枚举问题。
    对于按文本视图，数字将添加至那些未定义的回答。

对于列表复选类型，提供了以下选项：

  • 问题文本
    选择添加编号选项以枚举问题。
  • 回答文本
    选择添加编号选项以枚举回答。
  • 对于每个问题，请指定回答的数量及回答必须放置的列数。
    对此，请双击对应单元并输入所需的值，或者使用数字设定框增加/减少该值。
  • 请单击添加按钮添加问题。
  • 要删除选定的问题，请使用删除按钮。

如果您希望返回上一步，请单击上一步。

一旦所有选项都已指定，请单击完成按钮。已创建的复选标记组将显示在表单中。

您可以更改已添加元素的位置，只需用鼠标将其拖至表单中的另一位置。


编辑复选标记组

对于每个复选标记组元素，可以同时为元素本身及其字段指定属性。

复选标记组与表格字段有相同的属性：元素的坐标和大小；行的宽度、类型和颜色；单元间距；第一行是否包含列名；链接字段。详情请参阅编辑表格元素。

“问题”字段有与文本字段相同的属性：元素的大小和位置、文本、字体、文本颜色、自动换行、水平和垂直对齐、方向和元素的背景颜色。详情请参阅编辑文本元素。

回答表示复选标记字段且有相同的属性：文本位置、字段大小、边框宽度、边框颜色、间距、文本、字体、自动换行、文本颜色、背景色、提示、链接字段。详情请参见编辑复选标记字段。

您可以更改复选标记组或其元素的属性，属性可在主窗口右下角的元素属性窗口中进行选择。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。


删除复选标记组

要删除复选标记组元素：

  1. 请选择您想要删除的复选标记组。
  2. 在编辑菜单中，选择删除（或在快捷菜单选择删除项目）。


行分隔符

行分隔符是机器可读表单的一种元素，其形状为一条垂直或水平的黑线。

添加行分隔符元素

编辑行分隔符元素

删除行分隔符元素


添加行分隔符元素

要添加行分隔符元素：

  1. 在表单元素工具栏上，选择行分隔符工具。

  2. 单击表单上要添加行分隔符元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。默认为创建水平分隔符。按住 Shift 按钮可以创建垂直分隔符。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑行分隔符元素

对于每个行分隔符元素，可以指定以下属性：名称、位置和大小、样式、行宽度和颜色。

您可以在主窗口右下角的元素属性窗口更改行分隔符元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

行分隔符

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置行分隔符元素的宽度。

高度：

设置行分隔符元素的高度。

线条

宽度：

设置行分隔符宽度（从 0.1 毫米到 2.5 毫米）。

样式：

设置行样式：

  • 虚线

  • 点线

  • 实线

颜色：

 从下拉列表中为丢弃表单选择行分隔符颜色，或从彩色表格的调色板中选择。

注：可用的颜色范围取决于表单的类型（黑白或彩色）。在黑白表单的情况下，分隔符是黑色的。


删除行分隔符元素

要删除行分隔符元素：

  1. 选择要删除的行分隔符元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


矩形

矩形是机器可读表单的元素，它将表单上的某个区域围起来。

显示矩形元素

添加矩形元素

编辑矩形元素

删除矩形元素


添加矩形元素

要添加矩形元素：

  1. 在表单元素工具栏，请选择矩形工具。

  2. 在表单中单击您希望矩形元素所添加的位置，按下鼠标左键并呈对角拖动鼠标。矩形将出现在屏幕上。调整已添加元素的大小。松开鼠标。

注：您也可以单击鼠标创建元素：当您选择了所需的工具时，只要在表单中单击您想要元素所添加的位置。将使用默认的元素大小。要在您的表单中放置几个相同类型的元素，请按下 Ctrl 键并重复单击您希望放置元素的位置。


编辑矩形元素

对于每个矩形元素，都可指定以下属性：位置和大小、行宽度和颜色、样式、十字形、背景色。

您可以在位于主窗口右下角的元素属性窗口更改框元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

矩形

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置矩形元素的宽度。

高度：

设置矩形元素的高度。

线条

宽度：

设置框宽度（从 0.1 毫米到 2.5 毫米）。

样式：

设置框样式

  • 虚线

  • 点线

  • 实线

颜色：

从下拉列表中选择框颜色

注：可用的颜色范围取决于表单的类型（黑白或彩色）。

十字形：

从以下选项中选择十字形的类型：

  • 矩形十字形
  • 反转矩形十字形
  • 圆形十字形
  • 反转圆形十字形

对于除矩形十字形外的所有类型，十字形的半径可以用毫米设置。

背景*

与表单背景相同*

使矩形元素的背景与表单的背景颜色相同。

其它：

从下拉列表* 中为退出表单选择矩形背景色或从彩色表单的调色板中选择。

* - 可用的颜色范围取决于表单的类型（黑白或彩色）。


删除矩形元素

要删除矩形元素：

  1. 请选择您希望删除的矩形元素。

  2. 在编辑菜单中，请选择删除（或在快捷菜单中选择删除项目）。


图片

图片是机器可读表单的一种包含图像的元素。

添加图片元素

编辑图片元素

删除图片元素


添加图片元素

要添加图片元素：

  1. 在表单元素工具栏上，选择图片工具。

  2. 单击表单上要添加图片元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

  3. 在显示的打开图像对话框中，浏览至包含要添加至表单的图像的文件。


编辑图片元素

对于每个图片元素，都可以指定以下属性：位置和大小、大小更改模式、对齐、源图像文件和背景色。

图片元素的属性可在元素属性对话框中编辑（右键单击图片元素并在快捷菜单选择属性…）。

您可以在主窗口右下角的元素属性窗口更改图片元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

图片

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置图片元素的宽度。

高度：

设置图片元素的宽度。

图片

大小模式：

以三种模式之一更改元素的大小：

  • 片段 – 更改元素的大小但并不更改图片的大小及其比例。
    在此模式下无法放大图片本身。
    如果元素变得比图片小，图片的一部分在表单中将不可见。

  • 拉伸 – 更改元素的大小并根据元素的大小缩小或拉伸图片。始终将显示整个图像，但图像比例将不会保留。

  • 缩放 – 更改元素的大小并按元素大小的比例放大或缩小图片大小。始终将显示整个图像，而图像比例也将保留。

对齐：

在元素内对齐图像：

  • 左上角 – 将图片放在元素的左上角

  • 右上角 – 将图片放在元素的右上角

  • 居中 – 将图片放在元素的中央

  • 左下角 – 将图片放在元素的左下角

  • 右下角 – 将图片放在元素的右下角

来源：

指定源图像文件。

要指定图片加载的源文件：

  1. 请单击“…”按钮。

  2. 在随后出现的对话框中，浏览至包含您想要添加至表单的图片的文件。

支持以下图像格式：

  • Bitmap (*.bmp)
  • DCX (*.dcx)
  • DJVU (*. djvu)
  • GIF (*. gif)
  • JBIG2 (*. jbig2)
  • JPEG (*.jpg; *.jpeg; *.jfif)
  • JPEG-2000 (*.jp2; *.j2c)
  • PCX (*.pcx)
  • PNG (*.png)
  • TIFF (*.tif; *.tiff)
  • PDF (*.pdf)

背景

与表单背景相同

使图片背景与表单背景颜色相同。

其它：

从下拉列表中为丢弃表单选择图片背景色，或从彩色表单的调色板中选择。

注：可用的颜色范围取决于表单的类型（黑白或彩色）。


删除图片元素

要删除图片元素：

  1. 选择要删除的图片元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


表单标识符

标识符

标识符是机器可读表单的一种元素，它允许表单处理程序识别整个表单或表单中的某个页面。

建议您向表单添加标识符。这样可以帮助表单处理程序在处理过程中将每个表单作为某个给定表单组的一部分进行识别。

标识符元素可以识别整个表单，也可以识别表单上的某个特定页面。您也可以指定标识符的自定义值。

ABBYY FormDesigner 10 可以向表单中添加的标识符的类型有：只有条形码、带数字的条形码和只有数字。实际上，所有这些类型的标识符都表示一个在发布时指定给表单的唯一的十三位数。在发布表单前，表单标识符元素上面会显示“草稿”一词。

通过选择条形码类型（EAN13 或 EAN8），可以自定义只有条形码和带数字的条形码。

类型 | 描述
只有条形码 | 使用条形码识别表单。
带数字的条形码 | 使用带数字的条形码识别表单（可以将数字放在条形码的上面或下面）。
只有数字 1236489271602 | 使用一个十三位数识别表单。

添加标识符元素

编辑标识符元素

删除标识符元素


添加标识符元素

要添加标识符元素：

  1. 在表单元素工具栏上，选择标识符工具。

  2. 单击表单上要添加标识符元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，表单标识符将被放至矩形左上角，

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑标识符元素

标识符的标准大小是 46x12 毫米。

对于每个标识符元素，可以指定以下属性：位置和大小、类型、方向和值。

标识符元素属性并不依赖于表单类型。

您可以在位于主窗口右下角的元素属性窗口更改标识符元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

标识符

ID

元素的唯一标识符。

位置和大小组

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置标识符元素的宽度。

高度：

设置标识符元素的高度。

标识符

类型：

设置标识符类型

  • 仅条形码

  • 带数字的条形码

  • 仅数字

条形码类型：

如果标识符类型设置为仅条形码或带数字的条形码且如果选择了自定义值选项，请选择条形码类型。

可用的条形码类型：

  • EAN13
  • EAN8

如果未选择自定义值选项，条形码类型：将变成灰色。将使用 EAN13 条形码类型。

方向：

设置条形码方向：

  • 水平

  • 垂直

值：

标识符的值

只有在选择了自定义值选项的情况下，才可以更改标识符值。对于 EAN13，自定义值必须包含 12 位数；而对于 EAN8，自定义值必须包含 7 位数。不允许更长或更短的值或数字以外的字符。对于 EAN13，附加控制数字添加在字符串的开头（在条形码本身以外）；而对于 EAN8，附加控制数字添加在字符串末尾且在条形码内。

如果选择了表单标识符或页面标识符选项，则当表单发布时，标识符会自动分配一个值。在表单发布之前，它处于可编辑状态且尚未分配标识符值。

表单标识符

将元素用作表单标识符。

页面标识符

将元素用作当前页面的标识符。

自定义值

允许标识符使用自定义值。该选项对仅数字标识符不可用。


删除标识符元素

要删除标识符元素：

  1. 选择要删除的标识符元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


表格

表格是机器可读表单的一种元素，它包含多列类型相同的元素。

表格列可以包含的元素有：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段

表格可以包含带有列名的行。

在文档结构方面，每个表格字段有对应表格元素的列的子字段。

添加表格元素

编辑表格元素

删除表格元素


添加表格元素

要添加表格元素：

表格是机器可读表单的一种元素，它包含多列类型相同的元素（如文本字段或复选标记字段）；可以包含带有列名的行。
  1. 在表单元素工具栏上，选择表格工具。
  2. 单击表单上要添加表格元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

  3. 在打开的对话框中更改表格的类型。
    • 如果要将表格第一行作为标题，请选择使用第一行作为标题；
    • 在打开的对话框中心的表格中，将默认数据名称和数据类型修改为所需的名称和类型。可以选择的列数不限；
    • 在行数：字段中，键入表格中的行数。

添加分隔符

如果表单中含有表格，用于添加和移除分隔符的工具栏按钮将变为活动状态。您可以使用这些按钮来添加/移除分隔符，以更改表格的行数和列数。

选择添加分隔符工具，并执行下面的一项操作：

  • 单击表格以创建一个分隔符
  • 将鼠标指针放在现有分隔符上以移动该分隔符。将鼠标指针放在两个分隔符的交叉点处将同时移动这两个分隔符
  • 按住 Ctrl 键并将鼠标指针放到一个分隔符上以删除该分隔符
  • 按住 Shift 键并将鼠标指针放到一个分隔符上以将其类型由垂直分隔符变为水平分隔符（反之亦然）

创建列

表格列只能包含类型相同的元素。要创建表格列，请选择工具栏上所需的元素，并在列中单击。将向该列中的每个单元添加一个选定类型的元素。

可以创建的列的类型有：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段


编辑表格元素

对于每个表格

机器可读表单的元素，包含相同类型的元素列（例如，文本字段或复选标记字段），可能包括带有列名称的一行。
元素可以指定以下属性：元素的坐标和大小；宽度、样式和行的颜色、单元间距；第一行是否包含列名称；链接字段。

您可以在主窗口右下角的元素属性窗口更改表格元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

表格。

ID

元素的唯一标识符。

位置和大小

左：

设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置表格元素的宽度。

高度：

设置表格元素的高度。

线条

宽度：

设置行分隔符宽度（从 0.1 毫米到 2.5 毫米）。

样式：

设置行样式：

  • 虚线
  • 实线
  • 点线

颜色：

从下拉列表* 中为丢弃表单选择行分隔符颜色，或从彩色表单的调色板中选择。

背景

与表单背景相同

使表格的背景与表单的背景颜色相同。

其它：

从下拉列表* 中为丢弃表单选择表格背景色，或从彩色表单的调色板中选择。

表格

单元间距：

设置表格单元之间的距离

使用第一行作为标题

如果选择该选项，第一行将包含列名称。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

*- 可用的颜色范围取决于表单的类型（黑白或彩色）。


删除表格元素

要删除表格元素：

  1. 选择要删除的表格元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


元素组

元素组是机器可读表单的一种元素，它可以合并多个有逻辑关联的元素。

例如，可以使用组来创建复选标记字段组。也可以将多个元素分组到一起以快速复制这些元素并保留它们的所有属性。组有一种用途，就是创建多个有相似字段组的子表单。

组可以嵌套。

添加元素组

编辑元素组

删除元素组


添加元素组

要添加元素组：

元素组是机器可读表单上的一种元素，它可以合并多个有逻辑关联的元素
  1. 在表单元素工具栏上，选择元素组工具。
  2. 单击表单上要添加元素组元素的位置，按住鼠标左键并呈对角拖动鼠标。释放鼠标按键。屏幕上会出现一个矩形。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

向组中添加元素

向组中添加元素的方法有以下三种：
  1. 创建要作为组的一部分的元素。选择元素组工具，并使用鼠标包围住矩形中的元素。被完全包围的所有元素将成为这个组的一部分。
  2. 使用元素组工具创建组。在组中创建元素。
  3. 使用元素组工具创建组。将所需元素拖放到组中。
要复制一个组和该组中的所有元素，选择该组即可以选中其所有元素。现在如果复制该组，其所有元素也会被复制，并且会保留这些元素的属性。


编辑元素组

对于每个元素组

机器可读表单的元素，将几个逻辑上连接的元素连接到一起。

指定了以下属性：坐标、大小、行样式、背景色和链接字段。

您可以在位于主窗口右下角的元素属性窗口中更改元素组元素的属性。只有在主菜单中选择了视图>元素属性，元素属性窗口才会显示。

项目

描述

元素

类型：

元素组

ID

元素的唯一标识符。

位置和大小

左：

设置表单左边缘与元素之间的距离（无左缩进）。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置元素组的宽度。

高度：

 设置元素组的高度。

文本

文本：

编辑元素组的解释性文字。

字体：

元素中文本使用的字体。
要更改字体、其大小和样式（斜体、粗体、下划线等），请单击更改…按钮并在随后出现的字体：对话框中选择所需的字体、字体大小和样式。

颜色：

从下拉列表* 中为丢弃表单选择文本颜色，或从彩色表单的调色板中选择。

自动换行

在不拆分单词的情况下文本换行。

线条

宽度：

设置行宽度（从 0.1 毫米到 2.5 毫米）。

样式：

设置行样式：

  • 虚线
  • 点线
  • 实线

颜色：

从下拉列表* 中为丢弃表单选择行颜色，或从彩色表单的调色板中选择。

背景

与表单背景相同

使元素组的背景与表单背景颜色相同。

其它：

从下拉列表* 中为丢弃表单选择元素组的背景色，或从彩色表单的调色板中选择。

链接的字段

链接字段

默认情况下，无论您何时在表单中创建元素，该元素所链接的文档结构内都将创建字段。要使您的元素与同一类型的另一字段链接，请从下拉列表中选择字段的名称。

*- 可用的颜色范围取决于表单的类型（黑白或彩色）。

注：您可以在 www.paratype.com/shop/ 购买其他字体和多语言字体支持。


删除元素组

要删除元素组：

  1. 选择要删除的元素组。
  2. 选择删除命令（编辑>删除或快捷菜单）

重要事项！如果删除的元素属于某个组，该组也会被删除。要删除一个组但要保留该组的元素，确定只选择该组，不选择其元素。


限制

在填写表格时，您可以对将输入的值加以限制。可以通过使用规则对字段值加以限制。规则使您可以指定容许值列表、正则表达式、日期或数字间隔。

限制在元素属性的约束选项卡进行配置。

您可为以下元素设置限制：

  • 输入字段
  • 日期字段
  • 数字字段


调整表单元素大小

对于可以调整大小的表单元素，在选中该元素时其边框上的绿点将变为可见。

并非所有元素都能直接用鼠标调整大小。例如，定位点的大小就只能在定位点对话框的元素属性选项卡上更改。在选中可以调整大小的元素时，其边框上会显示绿点，不能调整大小的元素则显示白点。

要更改表单元素的大小：

  1. 选择要调整大小的元素。
  2. 将鼠标指针放在选定的元素大小调整方向对应的元素边框的任意绿点上，指针将变为箭头。
  3. 单击所需的绿点，在按住鼠标按键的同时在目标方向上移动鼠标。

可以对称地调整元素的大小。这表示元素的大小将在选定方向和反方向这两个方向上变化。

要对称地调整表单元素的大小：

  1. 选择要调整大小的元素。
  2. 按住 Ctrl 按钮。
  3. 将鼠标指针放在该元素边框的目标绿点上；指针将变为箭头。
  4. 单击所需的绿点，在按住鼠标按键的同时在目标方向上移动鼠标。

也可以通过绑定元素边框和平行标尺，来更改元素的大小。如果将多个元素绑定至平行标尺，您将可以以相同的更改幅度，同步更改所有绑定元素的垂直大小和水平大小。

要使用标尺更改元素的大小：

  1. 使用 [image] 或 [image] 工具以创建两个平行标尺。
  2. 移动标尺或所需的元素，使要调整大小的元素的边框与标尺重合。这样可以将边框绑定到标尺上。
  3. 单击其中一个标尺并按住鼠标左键拖动。所有元素的大小将随着您移动标尺而改变。在元素达到适当的大小时释放鼠标。

注：如果选择了多行，那么只能更改多行元素的垂直大小。


更改表单元素的背景颜色

您可以更改某些元素的颜色，而使其他元素仍旧保持黑白。

注意：您只可以设置和更改以下元素的颜色：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段
  • 矩形
  • 图片
  • 表格
  • 元素组
  • 复选标记组

要更改表单中某些元素的颜色：

  1. 在页面属性对话框（表单>页面属性…）的布局选项卡上，将表单类型更改为彩色表单
  2. 将所需元素的颜色更改为灰色：
    • 在表单上选择所需元素
    • 在右下角的元素元素属性对话框，请单击背景选项卡
    • 清除与表单背景相同框并单击其它：字段
    • 从调色板中选择所需的背景颜色

注意：建议不要打印彩色表单。


编辑表单字体元素

您可以使用字体对话框编辑表单中某些元素的文本（为此，请从元素快捷菜单中选择字体）。

您可以为以下元素指定字体设置：复选标记字段、组字段和文本。

显示字体对话框

项目

描述

字体选项卡

字体

为选定文本片段选择字体

字体样式

为选定文本片段选择字体样式

  • 正常
  • 斜体
  • 粗体
  • 粗斜体

大小

为选定文本片段选择字体大小

彩色

为选定文本片段* 选择颜色。

效果

选择文本效果 - 下划线或删除线。

字符间距选项卡

间距

更改选定文本片段的间距。

增量

增加或减少选定文本片段中字符之间的间隔（例如，拉伸或压缩文本）。

位置

设置选定文本片段的位置：正常、高于或低于其余文本。

*- 颜色列表取决于表单类型（黑白或彩色背景）。

注：各种语言的其他字体可在 http://www.paratype.com/shop/ 上购买。


选择和移动表单元素

必须先选中表单元素才能对表单元素进行移动或编辑。

要选择表单元素：

  1. 在表单元素工具栏上，选择选择工具。
  2. 单击所需的表单元素。

要移动表单元素：

  1. 选择要移动的元素。
  2. 将鼠标指针放在元素内部。箭头将变为 [image] 。
  3. 单击该元素，在按住鼠标按键的同时将该元素移至表单上的目标位置。

要同时移动多个元素：

  1. 选择要移动的元素（单击选择工具，按住 Shift 按钮并单击要移动的所有元素）。
  2. 将鼠标指针放在其中一个选定的元素内部。箭头将变为 [image] 。
  3. 单击其中一个选定的元素，在按住鼠标按键的同时将选定的这些元素移至表单上的目标位置。

创建输入字段（文本、数字或日期字段）时，该字段链接了其名称。移动此类字段同时也会移动字段名称。

在按住 Ctrl 键的同时移动一个（或多个）元素时将创建该元素（这些元素）的副本。

要选择属于元素组中的元素，请单击组的内部。移动一个组时，组中的所有元素也会被移动。

您可以查看和编辑选定元素的常用属性。

合并表单元素

使用标尺对齐表单元素


合并表单元素

合并表单元素对于移动表单元素时保留表单元素的位置关系十分有用。

要合并多个元素：

  1. 选择要组合的表单元素。
  2. 选择编辑工具栏上的合并工具。

要拆分元素：

  1. 选择要拆分的表单元素。
  2. 选择编辑工具栏上的拆分工具。

要向先前合并的元素添加一个元素：

  1. 选择先前合并的元素。
  2. 在按住 Shift 键的同时选择要添加至该组的元素。
  3. 选择编辑工具栏上的添加至合并的元素工具。


使用标尺对齐表单元素

标尺是一种用于在表单上对齐元素的便利工具。对于要垂直或水平地放至同一行的元素，可以与相应的标尺进行“绑定”。移动标尺时，会同时移动绑定到该标尺的所有元素，因此无需在每次移动时手动选择元素。

您可以将一个元素的两侧帮到到两个平行的标尺上。移动这两个标尺会同步更改该元素的大小。如果将多个元素绑定到两个平行的标尺上，可以同步更改这些元素的大小。

添加标尺

要向页面添加标尺：

  • 单击表单边上的主标尺。单击水平标尺将添加垂直标尺，单击垂直标尺将添加水平标尺。
  • 选择 [image] 工具添加水平标尺，或选择 [image] 工具添加垂直标尺，然后单击要定位新标尺的位置。

将元素绑定至标尺

要将一个元素绑定至一个标尺，需要将该元素的一个边框放到该标尺上。通过移动标尺或调整元素大小可以完成该操作。

如果开启自动绑定模式 ( [image])，当您移动标尺时，会自动绑定充分靠近该标尺的所有元素。该模式默认为关闭。

当您选择一个标尺时，会采用突出显示该标尺的颜色突出显示绑定该标尺的所有元素。当您选择某个绑定标尺的对象时，对象绑定边上的小方块变为红色，这样就可以知道元素绑定的是哪一个标尺以及特定标尺绑定了哪些元素。

移动标尺和元素

在按住鼠标左键的同时拖动鼠标，可以绕表单移动标尺。位于同一位置的两个标尺将合并为一个标尺。

移动标尺时，也会移动绑定该标尺的所有元素。如果某个元素被绑定至两个平行标尺，当移动其中一个标尺会改变该元素的大小（只要该元素允许更改其大小）。

解除元素绑定

要解除元素的绑定，请选择该元素并将其从标尺上移开。

删除标尺

要删除标尺，请选择该标尺并按 Delete 键或选择菜单上的删除命令。


保存和发布表单；检查表单的机器可读性

表单创建进程由表单设计、更改设计、打印等多个阶段组成。要保存工作过程中的工作成果，请使用标准保存命令。一旦设计好表单且其最终设计得到了批准，最好发布表单，即为表单分配已发布状态，以避免最终设计被意外更改。

保存表单

发布表单

确保机器可读性


保存表单

要保存表单，请使用标准保存命令或另存为…命令（文件>保存或文件>另存为…）。

另存为…命令将保存表单样本或页面样本。要选择保存格式，请使用保存类型下拉列表。

在 ABBYY FormDesigner 10 中创建的表单另存为 *.fdd 文件（表单定义文件）。

表单样本是二进制文件，其扩展名为 *.dtf。页面样本保存为 *.ptf 格式，该格式是 *.fdd 格式的改良版。


确保机器可读性

在表单设计阶段，可以随时检查表单以确保其为机器可读表单（工具>核对表单）。

如果未检测到任何错误，您会看到一条表明检查成功的消息。

如果检测到错误，完成检查后会在窗口下方显示这些错误信息。

报告中将包含可能导致计算机无法正确处理表单的所有故障情况，如没有定位点、没有表单标识符、表单元素太近或重叠表单边距等等。

按钮 | 描述
显示元素 | 显示不符合机器可读性要求的元素。选中报告中某一行时该按钮将变为可用状态。
核对表单 | 请在纠正错误后使用此按钮，以确保您的表单现在为机器可读表单。
保存报告… | 将检查结构报告保存至 .TXT 文件。


发布表单

发布表单时，要为表单分配已发布状态，这表示不能对表单的最终设计再作任何更改。在发布表单时，ABBYY FormDesigner 10 自动检查表单，以确保该表单为机器可读表单并为其指定一个唯一的表单标识符。

要发布表单，请使用发布表单命令（文件>发布表单）。已发布表单的状态为只读。所有表单标识符元素均分配有一个唯一的数值（与某个给定表单的所有表单标识符相同），并且表单的状态由已编辑变为已发布。

发布带有警告的表单

发布表单时，会对表单进行检查以确保其具有机器可读性。如果程序检测到您的表单非机器可读，屏幕上会打开“发布带有警告的表单”对话框。您可以使用该对话框以使该表单为机器可读表单，或在有警告的情况下仍然发布表单。

重要事项！

使用非机器可读的表单可能导致识别质量欠佳！

发布带有警告的表单对话框显示不符合机器可读性要求的所有失败情况的报告。

按钮 | 描述
仍要发布 | 忽略不符合机器可读性要求的警告，仍然发布表单。
编辑表单 | 在该窗口下方显示的报告中，指出了检查表单时检测到的任何错误信息。请使用该报告来纠正错误，并使您的表单为机器可读表单。

编辑已发布的表单

要对已发布表单进行更改，请选择文件菜单上的将可编辑副本另存为…命令。ABBYY FormDesigner 10 将提示您在更改设计前，先以不同的名称另存该表单。采用新名称的表单的状态将由已发布变为草稿，表单标识符的值被设为 0。

提示
建议您在完成表单设计后发布表单。这样有助于跟踪您对已完成的表单的更改情况，避免打印看是相似实则不同的表单。


导出表单

在创建表单后，可以将表单导出至各种各样的图像格式，如分色图像、特殊 XML 表单定义格式的图像、PDF 和 InfoPath 表单以及 Adobe Illustrator 文件。

某些导出类型只适用已发布的表单。

将表单发送至印刷厂时必须导出至图像格式。

导出至 XML 表单定义格式将会创建一个文件，ABBYY FlexiCapture 10 从该文件可以自动为表单创建文档定义。

将表单导出至图像文件

将表单导出至 带分色的图像文件…

将表单导出至 XML 表单定义格式 (*.xfd)

将表单导出至 PDF 表单…

将表单导出至InfoPath 表单…

将表单导出至 Adobe Illustrator 文件…


将表单导出至图像文件

在表单设计阶段，随时可以将表单导出至某种图像格式。如果表单的状态为草稿，表单标识符元素将在表单上注明“草稿”一词。如果表单的状态为已发布，表单标识符将显示其类型（只有条形码、带数字的条形码、只有数字）相应的标准外观。

要将表单导出至某个图像文件，请使用图像文件…命令（文件>导出至…>图像文件…）。

ABBYY FormDesigner 10 可以将表单导出至以下图像格式：
  • 位图，黑白 (*.bmp, *.dib, *.rle)
  • 位图，灰度 (*.bmp, *.dib, *.rle)
  • 位图，彩色 (*.bmp, *.dib, *.rle)
  • DCX，黑白 (*.dcx)
  • DCX，灰度 (*.dcx)
  • DCX，彩色 (*.dcx)
  • JBIG2 (*.jbig2, *.jb2)
  • JPEG，灰度 (*.jpg *.jpeg)
  • JPEG，彩色 (*.jpg *.jpeg)
  • JPEG-2000，灰度 (*.jp2, *.j2k)
  • JPEG-2000，彩色 (*.jp2, *.j2k)
  • PCX，黑白 (*.pcx)
  • PCX，灰度 (*.pcx)
  • PCX，彩色 (*.pcx)
  • PNG，黑白 (*.png)
  • PNG，灰度 (*.png)
  • PNG，彩色 (*.png)
  • TIFF，黑白，解压缩 (*.tif, *.tiff)
  • TIFF，黑白，Group4 (*.tif, *.tiff)
  • TIFF，黑白，Packbits (*.tif, *.tiff)
  • TIFF，黑白，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，黑白，LZW 压缩 (*.tif, *.tiff)
  • TIFF，灰度，解压缩 (*.tif, *.tiff)
  • TIFF，灰度，Packbits (*.tif, *.tiff)
  • TIFF，灰度，JPEG 压缩 (*.tif, *.tiff)
  • TIFF，灰度，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，灰度，LZW 压缩 (*.tif, *.tiff)
  • TIFF，彩色，解压缩 (*.tif, *.tiff)
  • TIFF，彩色，Packbits (*.tif, *.tiff)
  • TIFF，彩色，JPEG 压缩 (*.tif, *.tiff)
  • TIFF，彩色，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，彩色，LZW 压缩 (*.tif, *.tiff)
  • PDF (*.pdf)
  • EMF (*.emf)

导出分色图像

在打印店打印时，需要将彩色表单保存至两个独立的文件。其中一个文件包含以黑色打印的元素，另一个文件包含以彩色打印的元素。

选择文件>导出至>带分色的图像文件…。图像将被保存为 TIFF 文件，黑白文件的名称中包含 _bw，彩色文件的名称中包含 _color。

导出多页表单

可以将多页表单导出至任何一种受支持的图像格式。对于多页格式而言，可以将表单保存至多页文件。将表单导出至图像文件时，请选择多页文件选项。如果未选择该选项，将把每页保存至独立的文件。

以您选择的分辨率导出至 TIFF 文件

可以在选项对话框（工具>选项…）上的导出选项卡上选择 TIFF 文件的分辨率。

注：TIFF 分辨率的范围为 50 至 1200 dpi。


导出至分色图像

要以两种颜色打印表单，需要将表单保存至两个文件：一个文件包含要以黑色打印的日期信息，另一个文件包含要以彩色打印的数据。

任何阶段都可以将表单导出至带分色的图像文件。在已编辑表单中，图像的标识符上方将标注草稿。如果是已发布的表单，标识符的外观将取决于选择的标识符类型。

要将表单导出至带分色的图像文件，请选择文件>导出至>分色图像。

图像将另存为 TIFF 文件。黑白图像的名称会添加 postfix _bw，彩色文件的名称会添加 postfix _color。


将表单导出至 XML 表单定义格式 (*.xfd)

使用 ABBYY FormDesigner 10 不仅可以创建表单，而且可以自动生成表单描述，然后可以使用生成的表单描述在 ABBYY FlexiCapture 10 Professional 中创建文档定义（文档定义可以告知表单处理应用程序在文档中的哪个位置查找特定类型的信息，以确保可靠识别输入的数据）。

要创建表单描述，首先要将表单导出至 *.xfd 文件（XML 表单定义格式），然后在 ABBYY FlexiCapture 10 Professional 中打开该文件，当在 ABBYY FlexiCapture 中创建文档定义时，只需导入创建的 *.xfd 文件，ABBYY FlexiCapture 就会自动创建所需的文档定义。

已发布的表单只能导出至 XML 表单定义。

您可以选择 ABBYY FormDesigner 10 将表单图像保存至 XFD 文件中时使用的格式（TIFF 或 EMF）。

要将表单导出至 *.xfd 文件，请使用 XML 表单定义…命令（文件>导出至>XML 表单定义…）。在显示的导出至 XML 表单定义对话框中，指定 *.xfd 文件的名称，并浏览至要存储该文件的文件夹。


将表单导出至 PDF

在以电子形式发布表单前，建议将表单导出至 PDF。您可以向表单添加响应按钮。单击这些按钮将把完成的表单发送至指定地址。

将图像导出为 PDF 格式后，可以在 Adobe Acrobat Professional 等其他表单编辑程序中对导出的图像进行编辑。

要将表单导出为 PDF，请单击菜单上的文件>导出至>PDF 表单…。

1. 在选择 PDF 保存选项前，请在 获取响应的方法对话框中选择是否向表单添加响应按钮。响应按钮显示在第一页的右上角。请选择以下选项（可以从中选择一个选项，选择两个选项，或者不选择任何选项）

- 通过电子邮件发送响应（指定电子邮件地址）

- 通过 Internet 发送响应（指定 URL）

2. 在导出至 PDF 对话框中，指定文件名和保存该文件的文件夹。

3. 通过单击高级…，也可以选择其他保存选项。在 PDF 文件选项对话框中，可以定义以下项目：

- 保存模式（仅文本或仅图像）

- 字体设定（使用系统字体或标准字体）

- 嵌套字体（如果想在表单中嵌套字体，请选择此选项）

注：
如果表单中至少有一个字段进行过编辑，将把该表单导出至 PDF。


将表单导出至 InfoPath

在任何阶段都可以将表单导出至 Microsoft Office InfoPath。要获取 Microsoft Office InfoPath 的源文件项目，请单击菜单上的文件>导出至>InfoPath 表单…。在浏览文件夹对话框中，选择要保存该项目的文件夹并单击确定。屏幕上将显示与所保存的表单同名的子文件夹，该文件夹包含 InfoPath 所需的文件。在 InfoPath 中，打开文件 manifest.xsf。

注：
  • 要正确处理 InfoPath 中的表单，请确保计算机安装有 Microsoft Office 2007 Service Pack 1 (SP1)。
  • 如果表单中至少有一个字段进行过编辑，将把该表单导出至 InfoPath。


导出至 Adobe Illustrator 文件

任何阶段都可以将表单导出至 Adobe Illustrator 文件。

要将表单转换为 Adobe Illustrator 格式，请单击文件>导出至>Adobe Illustrator 文件…。在另存为 Adobe Illustrator 文件对话框中，输入文件名称并指定保存该文件的文件夹。


发布表单

您可以发送已创建的表单，并以硬拷贝或电子格式（作为 PDF 表单）发布到 ABBYY FormDesigner 中。

通过电子邮件可以发送电子表单，或者发布到网站上。您也可以选择响应方法（通过电子邮件或在网站上），以处理服务器上的结果。

向导的形式分布将帮助您选择正确的发送选项。单击文件>发布表单…或单击标准工具栏上的 [image] ，将启动该向导。

向导的形式分布会引导您完成发布表单的所有必需步骤：

  1. 选择是否希望以硬拷贝或电子格式发布表单（只选择一个选项）。 如果选择打印格式，向导会提示您打印表单，然后关闭。

    如果选择电子格式，向导会提示您提供发送和接收选项。

  2. 选择表单发布方法 （只选择一个选项）：
    • 发送给一组电子邮件收件人 - 如果选择本选项，请单击向导窗口下方的完成按钮。邮寄程序中会打开一个新的消息窗口。该消息会添加 PDF 表单作为附件，因此您只需指定地址和输入消息文本。发送电子邮件消息后，返回 ABBYY FormDesigner。
    • 保存稍后发送 - 如果选择本选项，请指定保存 PDF 表单的文件夹。默认为将表单保存在 My Documents中，且该文件采用表单的名称。要另外指定文件夹和文件名称，请单击该选项旁边的“...”按钮，然后单击窗口下方的完成按钮。
    • 发布到网络位置 - 如果选择本选项，请指定要发布 PDF 表单的 URL 地址。范例：http://www.example.com/form.pdf。单击向导窗口下方的完成以发布表单。
    重要事项！

    您必须具备对要发布表单的网站的写入权限。

  3. 选择响应方法（可以从中选择一个选项，选择两个选项，或者不选择任何选项）
    • 通过电子邮件发送响应 - 指定要对其发送完整表单的电子邮件地址。
    • 通过 Internet 发送响应 - 指定要在其中提交和处理完整表单的网站的 URL 地址。

    根据您选择的选项，表单第一页的右上角会显示一个按钮（或多个按钮）。单击该按钮将把表单发送至指定的网站或电子邮件地址。

    如果选择接收网站上的完整表单，可以将网站设置为自动处理提交的表单。


打印表单

要打印表单：

  1. 请在文件菜单选择打印…或

  2. 按 Ctrl+P。

  3. 在随后出现的打印对话框中，请设置所需的打印参数。

注：

要指定所需的打印参数，请选择文件>打印设置…。在打开的对话框中，请选择打印机并指定打印范围和副本数。单击属性...按钮指定页面大小和方向。


打印部分填写的表单

ABBYY FormDesigner 10 可以打印空白表单，也可以打印已包含某些字段数据的表单。例如，您可以打印名称字段已填写的表单，这样每个表单均针对特定的个人。实际名称可从文件或从数据库获取。

要用数据库中的数据填写空白表单并将它们打印出来：

  1. 从文件菜单中，选择打印已填写的表单…
  2. 在随后将打开的选择数据连接对话框中，选择先前已连接的数据库或单击添加…创建新连接。
  3. 选择数据库并单击选择…按钮以指定数据库连接参数。

重要事项！数据库中的相关字段必须与表单中相对应的字段具有相同的名称。可以使用元素 ID，而不是名称。使用元素 ID 使您可以填写未在文档结构中表示的字段，例如，条形码字段、图片字段等。当您将数据放入表单中的表格时，请按以下格式指定全名： <Table>|<Col>|<Row#>，其中 <Table> 是表格的名称，<Col> 是表格列的名称，而 <Row#> 是单元的编号（编号从 0 开始）。

您也可以用数据库的数据填写空白表单并从命令行打印它们。例如：

FormDesigner.exe /printDatabase D:\$temp\fillData.fdd Database:"connectionString:Provider=MSDASQL.1;Persist Security Info=False;Data Source=Xtreme Sample Database 2003;table:Credit"

要用文件的数据填写空白表单并将它们打印出来：

  1. 从文件菜单中，选择打印已填写的表单…
  2. 在随后打开的选择数据连接对话框中，选择先前已添加的文件或单击添加…添加新文件。
  3. 选择文件并单击浏览…以指定文件的路径。

重要事项！您必须使用 Unicode 编码的 *.csv 或 .txt 文件。文件的第一行必须包含字段名称，因为程序会将这一行当做页眉。文件中的字段名必须与表单中的字段名相同。 可以使用元素 ID，而不是名称。可以使用元素 ID，而不是名称。使用元素 ID 使您可以填写未在文档结构中表示的字段，例如，条形码字段、图片字段等。当您将数据放入表单中的表格时，请按以下格式指定全名： <Table>|<Col>|<Row#>，其中 <Table> 是表格的名称，<Col> 是表格列的名称，而 <Row#> 是单元的编号（编号从 0 开始）。

您也可以用文件的数据填写空白表单并从命令行打印它们。例如：

FormDesigner.exe /printDatabase D:\$temp\fillData.fdd File:"D:\$temp\fillData.txt"

当打印部分填写表单时，程序将识别文件或数据库中的数据类型并将它们相应地打印出来。例如，如果在希望为您的客户填写的表单中有复选标记字段，文件或数据库中的相应字段可能就具有值 True/False 或 1/0。对于单选组，请用每个选项的名称创建独立的列，并根据对应的选项是否必须进行选择，在列中提供值“是”或“否”。

所打印数据的字体将与在元素属性窗口指定的提示（提示选项卡）字体相关。


附录

  • 热键
  • 热键（文本编辑）
  • 术语表
  • 专利
  • 第三方技术


热键

菜单 | 命令 | 快捷键
文件 | 新建… | Ctrl+N
 | 打开… | Ctrl+O
 | 保存 | Ctrl+S
 | 打印 | Ctrl+P
编辑 | 撤销 | Ctrl+Z
 | 恢复 | Ctrl+Y
 | 剪切 | Ctrl+X
 | 复制 | Ctrl+C
 | 粘贴 | Ctrl+V
 | 删除 | Del
 | 复制 | Ctrl+D
 | 删除区域 | Shift+Del
 | 全选 | Ctrl+A
 | 按类型选择… | Ctrl+Shift+A
视图 | 按类型选择… | Alt+Enter
 | 缩放/最佳适合 | Ctrl+Shift+Num /
 | 缩放/缩小 | Ctrl+Shift+Num -
 | 缩放/放大 | Ctrl+Shift+Num +
元素 | 绘制元素/选择工具 | Esc
 | 绘制元素/输入字段 | E
 | 绘制元素/日期字段 | D
 | 绘制元素/数字字段 | N
 | 绘制元素/复选标记字段 | C
 | 绘制元素/元素组 | G
 | 绘制元素/表格 | T
 | 绘制元素/垂直分隔符 | V
 | 绘制元素/水平分隔符 | H
 | 绘制元素/文本 | S
 | 绘制元素/行分隔符 | L
 | 绘制元素/矩形 | F
 | 绘制元素/图片 | P
 | 绘制元素/定位点 | A
 | 绘制元素/标识符 | I
 | 对齐/左 | Alt+向左箭头
 | 对齐/水平居中 | Shift+F9
 | 对齐/右 | Alt+向右箭头
 | 对齐/顶部 | Alt+向上箭头
 | 对齐/垂直居中 | Ctrl+F9
 | 对齐/底部 | Alt+向下箭头
 | 大小/绘制相同宽度 | Shift+F8
 | 大小/绘制相同高度 | Ctrl+F8
 | 大小/绘制相同宽度和高度 | Ctrl+Shift+F8
 | 合并 | Ctrl+Shift+G
 | 拆分 | Ctrl+Shift+U
工具 | 核对表单 | F9
 | 选项… | Ctrl+Shift+O
帮助 | 帮助主题 | F1


热键（文本编辑）

要执行 | 请按
光标上移一行。 | 向上箭头
光标下移一行。 | 向下箭头
光标移至第一行。 | 向上翻页
光标移至最后一行。 | 向下翻页
光标右移一个符号。 | 向右箭头
光标左移一个符号。 | 向左箭头
将光标右移至后面一个单词的开头。 | Ctrl+ 向右箭头
将光标左移至此单词的开头。 | Ctrl+ 向左箭头
将光标移至此行的开头。 | Home
将光标移至此行的末尾。 | End
将光标移至文本开头。 | Ctrl+Home
将光标移至文本末尾。 | Ctrl+End
删除选定文本。 （如果未选择文本，将删除右侧的符号。） | Delete
删除光标前的符号。 | Backspace
退出文本编辑模式，不保存任何更改。 | Esc
保存所有更改并退出文本编辑模式。 | Enter
移至下一行。 | Ctrl+Enter


正则表达式中使用的符号集

名称 | 传统格式 | 用法示例
任意字符 | * | "c"*"t" – 允许 cat、cot 之类的单词。
字母 | C | C"ot" – 允许 Rot、pot、cot、Dot、mot 之类的单词。
大写字母 | A | A"ot" – 允许 Rot、Cot、Mot、Dot 之类的单词。
小写字母 | a | a"ot" – 允许 rot、cot、mot、dot 之类的单词。
字母或数字 | X | X – 允许任意单独的数字或字母。
数字 | N | N"th" 允许 5th、4th、6th 之类的单词。
字符串 | " " | "cot"
或 | | | "pl"("o"|"a")"t" – 允许单词 "plot" 和 "plat"。
组中的字符 | [] | [tm]"ot" – 允许单词 "tot" 和 "mot"。
不属于组中的字符 | [^] | [^t]"ot" – 允许单词 "cot"、"lot" 等，但不允许单词 "tot"。
空格（组内） | \s | [A\s] 仅允许字母 A 或空格。
任意重复的数字 （适用于左侧的表达式或子表达式） | {-} | [AB74]{-} – 允许任何长度的字符 A、B、7、4 组合。
重复数 n | {n} | N{2}"th" 允许 25th、84th、11th 之类的单词。
从 n 至 m 重复 | {n-m} | N{1-3}"th" 允许 5th、84th、111th 之类的单词。
从 0 到 n 重复 | {-n} | N{-2}"th" 允许 84th、5th 之类的单词。
从 n 重复及更多 | {n-} | N{2-}"th" 允许 25th、834th、311th、34576th 之类的单词。
子表达式 | () |
连字符符号 | [\-] |
斜线符号 | [\\] |

正则表达式示例：

  1. 邮政编码：[0-9]{6}
    样本值："142172"

  2. 邮编（美国）：[0-9]{5}("-"[0-9]{4}){-1}
    样本值："55416"、"33701-4313"

  3. 收入：N{4-8}[,]N{2}
    样本值："15000,00"、"4499,00"

  4. 用数字格式表示的月份：((|"0")[1-9])|("10")|("11")|("12")
    样本值："4"、"05"、"12"

  5. 小数：("-"|)([0-9]{1-})(|(("."|",")([0-9]{1-})))
    样本值："1234,567"、"0.99"、"100,0"、"-345.6788903"

  6. 电子邮件：[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-3}"@"[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-4}"."([A-Za-z]{2-4}|"asia"|"museum"|"travel"|"example"|"localhost")
    样本值："support@abbyy.com"、"my-name@company.org.ru"、"info@gallery.museum"


专利

美国专利号 5,490,216、5,625,465、5,768,416 和 6,094,505


第三方技术

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia.

保留所有权利。

更多

特此无偿授予获取该软件及相关文档的任何人（“用户”）无限制使用本软件的权利，包括使用、复制、修改、合并、发布、分发和/或出售本软件和相关文档文件（“软件”）副本的无限制权利，并允许本软件所提供给的任何人进行上述操作，前提是满足以下许可条件。

  1. 上述版权声明和该许可声明（包括下面的免责声明）将包括在本软件的所有副本或重要部分中。

  2. 未经事先书面同意，版权所有者的名称不得用于支持或促销从该软件衍生的产品。

该保证的免责声明是本许可证的关键部分。

只有在认可该免责声明的前提下对本软件的使用才能得到授权。本软件由版权所有者按“现状”提供，不做出任何明示或暗示的保证，包括但不限于表明本软件适销性和适合特定用途以及不侵犯第三方权利的保证。在任何情况下，对于因使用本软件或本软件性能导致的或与此有关的任何权利主张，任何直接、间接的或特殊性的损害，或任何因使用、数据或利润的损失而导致的损害，无论是否涉及合同、疏忽或其他侵权行为，版权所有者概不负责。版权所有者不作任何有关本软件不侵犯任何其他实体的专利或其他知识产权的保证。每个版权所有者不对用户承担其他实体基于侵犯知识产权或其他权利而提出的权利主张承担责任。作为行使下面授予的权利的一个条件，每个用户要承担遵守其他任何知识产权的全部责任。本软件不具有容错性，并且其并非旨在用于关键任务系统（如核设施、飞机导航或通讯系统、空中交通管制、直接生命维持系统或武器系统），在此类环境中本软件或系统如果出现故障，将直接导致死亡、人身伤害或严重的物理或环境损害（“高风险活动”）。版权所有者不对适合高风险活动做出任何明示或暗示的保证，并对此做出免责声明。

商标

QuickScan 是商标，Captiva 是 Captiva Software Corporation 的注册商标。

KODAK 是 Eastman Kodak Company 的商标。


如何购买 FormDesigner 10

如何购买 ABBYY FormDesigner 10

有关 ABBYY 的完整数据管理和捕获解决方案的详细信息，请访问 www.abbyy.com 和 www.FlexiCapture.com。

要订购 ABBYY FlexiCapture 10 的副本或了解该产品的其他信息，请联系我们：registration@abbyy.com

您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


ABBYY 办事处

北美洲/中美洲

美国、加拿大、墨西哥或中美洲国家的客户请联系：

ABBYY USA

电话：+ 1 510-226-6717
传真：+1 510 226 6069
地址：47221 Fremont Boulevard, Fremont, California 94538, USA
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyyusa.com

西欧

奥地利、比利时、荷兰、卢森堡、丹麦、法国、德国、希腊、意大利、爱尔兰、挪威、葡萄牙、西班牙、瑞典、瑞士、英国或其他西欧国家的客户请联系：

ABBYY Europe GmbH

电话：+49 89 511 159 0
传真：+49 89 511 159 59
地址：Elsenheimerstrasse 49, 80687 Munich, Germany
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyyusa.com

日本

日本的客户请联系：

ABBYY Japan

电话：+81 42 795 1901
传真：+81 42 795 1901
地址：658-1 Tsuruma, Machida-shi, Tokyo 194-8510
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyy.com

东欧与地中海地区

阿尔巴尼亚、波斯尼亚和黑塞哥维那、保加利亚、克罗地亚、捷克共和国、匈牙利、以色列、马其顿、摩尔多瓦、黑山、波兰、罗马尼亚、塞尔维亚、斯洛伐克、斯洛文尼亚、土耳其或乌克兰的客户请联系：

ABBYY Ukraine

电话：+ 38 044 490-9999
传真：38 044 490-9461
地址：P.O.Box 23, 02002 Kiev, Ukraine
电子邮件：forms@abbyy.ua
技术支持：
电话：+380 44 490 9463
电子邮件：formssupport@abbyy.ua
http://www.abbyy.com

所有其他地区

以上未提到的国家或地区的客户请联系：

ABBYY Russia

电话：+7 495 783-3700
传真：+7 495 783 2663
地址：P.O.Box 54, Moscow 129301, Russia, ABBYY
电子邮件：sales@abbyy.com
支持电子邮件：support@abbyy.com
http://www.abbyy.com

网上商店

俄罗斯：http://store.abbyy.ru
其他国家或地区：http://buy.abbyy.com/


技术支持

如果您有任何关于 ABBYY FormDesigner 10 如何使用的问题，请先参阅本软件随附的文档（用户指南和帮助）。您也可以浏览我们网站 www.abbyy.com/support 上的技术支持部分。

我们的技术支持服务专家需要以下信息才能有效回答您的问题：

  • 您的姓名

  • 您的公司名称

  • 您的电话号码（或传真、电子邮件）

  • ABBYY FlexiCapture 软件包的序列号

  • Build 号（请参阅帮助/关于/Build）

  • 对问题的总体描述以及错误消息的全文（如有）

  • 您的计算机和处理器类型

  • 您的 Windows 操作系统版本

您也可以向我们提供您认为重要的其他信息。

单击系统信息… 对话框（帮助菜单）中的关于 ABBYY FormDesigner 10按钮，可以自动获取部分信息。

重要事项！仅注册用户有资格获得技术支持。您可以在我们的网 站上注册您的应用程序副本。

ABBYY 办事处


术语表

A

ABBYY FormDesigner

ABBYY FormDesigner 是一种用于创建机器可读表单的软件应用程序，这类表单使用 ABBYY FlexiCapture 进行处理。表单设计是表单创建的一个重要阶段，因为其他所有阶段 — 扫描、识别、校验、导出 — 均取决于初始表单的“正确性”以及表单对于机器处理的适合性。

B

表单

文档由一页或多页组成，可以由手工填写，或使用打印机或打字机填写。

表单标识符

是机器可读表单的一种元素，该元素允许表单处理程序识别每个表单。

表单创建

由分析、设计和打印这三个阶段组成的过程。

表单发布

在发布表单时要为表单分配已发布状态，以防止更改表单。同时会检查表单的机器可读性，并为表单识别符分派唯一的编号（与其他所有标识符一样）。

表单样本

用于在 ABBYY FormDesigner 中创建新表单的样本。样本作为二进制文件进行存储，并且采用扩展名 *.dtf。

表格

是机器可读表单的一种元素，这种元素包含多列类型相同的元素。

D

带光栅背景的黑白表单

这类表单的字段一般为光栅背景上的空白空间（一般为矩形）。背景由单个的点组成。

带光栅边框的黑白表单

这类表单没有背景。所有字段边框（字符单元边框、复选标记字段和其他表单元素）组成了光栅线条，即小黑点序列。

滴定表单

这些表单有浅色背景，以白色矩形作为字符单元、复选标记字段等等。

定位点

是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

F

复选标记字段

复选标记字段是机器可读表单的一种元素（通常是一个复选框），在该框中可以填入一个标记（如勾或叉等）。

H

黑白线性表单

这些表单一般没有背景。所有字段边框（字符单元、复选标记字段和其他表单元素）组成了黑色实线。

J

机器可读表单

一种可以由计算机处理的表单。

机器可读表单的要求

对表单的类型和外观，以及表单元素的定位的要求。如果满足这些要求，可以达到最高识别质量。

机器可读性

表单对于自动处理的适合性。

K

框

是机器可读表单的一种元素，它可以包围表单上的某个区域。

S

输入字段

是机器可读表单的一种元素，在表单中的该字段可以输入文本。

T

图片

是机器可读表单的一种元素，这种元素包含有图像。

W

文本

是机器可读表单的一种元素，这种元素包含字段名称、如何填写表单的操作指示等描述和说明性文本。

X

XFD 格式

XML 表单定义 (*.xfd) 是 ABBYY FormDesigner 中创建的表单文件的格式。XML 表单定义文件可以自动转换为 ABBYY FlexiCapture 的模板。

行分隔符

是机器可读表单的一种元素，这种元素的形状为一条垂直或水平的黑线。

Y

页面标识符

是机器可读表单的一种元素，这种元素允许表单处理程序识别表单的每一页。

页面样本

用于在 ABBYY FormDesigner 中创建新页面的样本。样本作为二进制文件进行存储，并且采用扩展名 *.ptf。

引用标记

是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

元素组

是机器可读表单上的一种元素，这种元素可以合并多个有逻辑关联的元素。

Z

字符单元

只能在其中输入一个字符的小矩形（如一个字母或一位数）。


术语表

A B D F H J K S T W X Y Z


属性对话框：对齐

元素属性对话框：对齐

项目

描述

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中

  • 左对齐 - 将文本对齐元素左边缘

  • 右对齐 - 将文本对齐元素右边缘

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 将文本对齐元素下边缘

  • 居中 - 将文本垂直居中

  • 上对齐 - 将文本对齐元素上边缘

方向：

设置文本的方向。

  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。


Properties Dialog Box: Anchor

元素属性 Dialog Box: 定位点

Item | Description
类型： | Sets the type of anchor that will be used on the form. One form may contain anchors of only one type.
大小： | Sets the size of the anchor: the size of each side of the black square, or the size of each side of the corner.
行宽： (corners only) | Sets the line width of the sides of the corner.


属性对话框：背景

元素属性对话框：背景

项目 | 描述
与表单背景相同 | 使元素的背景色与表单的背景色相同。
其它： | 从下拉列表中选择元素背景色。* - 可用颜色的范围取决于表单类型（黑白或彩色）。


属性对话框：复选标记字段

元素属性对话框：复选标记字段

项目

描述

类型：

复选标记字段的形状：

  • 方块形

  • 圆圈

位置：

设置复选标记字段相对于说明性文本的位置：

  • 文本左侧 - 复选标记字段在文本左侧

  • 文本右侧 - 复选标记字段在文本右侧

  • 文本上方 - 复选标记字段在文本上方

  • 文本下方 - 复选标记字段在文本下方

大小：

包含预定义字段大小的下拉列表（3.5x3.5、4x4、4.5x4.5 或 5x5 mm）。

行宽：

设置字段边框的宽度（0.4 mm 至 0.8 mm）。

平衡：

设置复选标记字段和文本的说明性文本之间的间距（2 mm 至 7 mm）。

颜色：

从下拉列表中选择字段边框颜色*。


Диалог Свойства: Поле метки

元素属性对话框：日期

项目

描述

日期格式：

指定日期格式：

  • DD.MM.YYYY
  • MM.DD.YYYY
  • YYYY.MM.D

年份中的数字：

指定用于记录年份的单元数字：

  • 2（有 2 个单元）
  • 4（有 4 个单元）

分隔符：

选择用于记录日期的分隔符：

  • .
  • /
  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

选择提示颜色。提示将被输入至表单上的日期字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：各种语言的其他字体可从 http://www.paratype.com/shop/ 购买。


属性对话框：标记

元素属性对话框：标记

项目

描述

标记类型：

设置文本的标记类型：

  • 字母位于独立虚线框中

  • 字母位于独立框中

  • 字母位于梳形中

  • 文字位于梳形框中

  • 字母位于框中

单元大小：

设置字符单元的大小：

  • 正常 – 标准单元大小 (4x5 mm)

  • 大 – 最大单元大小 (5x6.5 mm)

  • 小 – 最小单元大小 (3x4 mm)

粗体标记线（适用“字母位于独立虚线框中”以外的所有标记类型）

将单元框更改为粗体框。

标记颜色：

从下拉列表中选择标记颜色*。

多行

向输入字段添加多行。（只适用输入字段元素）。


属性对话框：提示

元素属性对话框：提示

项目 | 描述
文本： | 设置提示文本。提示将被输入至表单上的输入字段：每个提示字母位于相应的单元。
颜色： | 从下拉列表中选择提示颜色*。
字体： | 选择提示字体。
自动调整字体大小 | 根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：链接的字段

元素属性对话框：链接的字段

项目 | 描述
链接的字段 | 默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。


属性对话框：文本

元素属性对话框：文本

项目 | 描述
文本： | 元素内的文本。
字体： | 元素中的文本使用的字体。 要更改字体、字号和样式（斜体、粗体、下划线等），请单击更改…按钮，并在显示的字体对话框中选择所需的字体、字号和样式。
字体颜色 ： | 从下拉列表中选择文本颜色。
自动换行 | 将文本换行，但不断字。

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：线条

元素属性对话框：线条

项目

描述

宽度：

设置线宽（0.3 mm 至 6 mm）。

样式：

设置线条样式：

  • 虚线

  • 点划线

  • 实线

颜色：

从下拉列表中选择线条的颜色。


属性对话框：元素

元素属性对话框：元素

项目 | 描述
类型： | 元素的类型。
位置和大小 |
左： | 设置左边距的宽度。
顶部： | 设置上边距的宽度。
宽度： | 设置页面宽度。
高度： | 设置页面高度。


属性对话框：标识符

元素属性对话框：标识符

项目

描述

类型：

设置表单标识符的类型：

  • 只有条形码

  • 带数字的条形码

  • 只有数字

条形码类型：

如果标识符类型被设为只有条形码或带数字的条形码，并且选择了自定义值选项，那么请选择条形码的类型。

可用的条形码类型有：

  • EAN13
  • EAN8

如果未选择自定义值选项，条形码类型：会显示为灰色。将使用 EAN13 条形码类型。

方向：

设置条形码的方向。

  • 水平
  • 垂直

值：

标识符的值

只能在选择了自定义值选项的情况下才能更改标识符的值。对于 EAN13，自定义值必须包含 12 位数；对于 EAN8，自定义值必须包含 7 位数。不允许使用比指定位数长或短的值或字符。对于 EAN13，会在字符串开头（在条形码以外）添加附加的控制位；对于 EAN8，会在条形码中字符串末尾添加附加控制位。

如果选择了表单标识符或页面标识符选项，将在发布表单时自动为标识符分配一个值。在发布表单前，表单的状态为可编辑，且尚未分配标识符值。

表单标识符

使用元素作为表单标识符。

页面标识符

使用元素作为当前页面的标识符。

自定义值

允许标识符采用自定义值。该选项不适用于只有数字标识符。


属性对话框：数字

元素属性对话框：编号

项目

描述

小数位：

选择记录小数位的位数。

分隔符：

选择用于记录数字的分隔符：

  • .
  • /
  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

选择提示颜色。提示将被键入至表单上的数字字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：图片

元素属性对话框：图片

项目

描述

大小模式：

更改元素大小的模式有以下三种：

  • 剪切 – 更改元素的大小，但不更改图片及其比例的大小。
    采用这种模式无法放大图片本身。
    如果元素变得比图片小，图片有一部分将在表单上不可见。

  • 扩展 – 更改元素的大小，并根据元素大小收缩或扩展图片。始终会显示整个图像，但不保留图像比例。

  • 缩放 – 更改元素的大小，并根据元素大小的比例放大或缩小图片。始终会显示整个图像，并保留图像比例。

对齐：

对齐元素中的图像：

  • 左上 – 将图片放在元素的左上角。

  • 右上 – 将图片放在元素的右上角。

  • 居中 – 将图片放在元素的中心。

  • 左下 – 将图片放在元素的左下角。

  • 右下 – 将图片放在元素的右下角。

来源：

指定源图像文件。

要指定加载图片的源文件：

  1. 单击 "…" 按钮。

  2. 在显示的对话框中，浏览至包含要添加至表单的图片的文件。

受支持的图像格式有：

  • 位图文件 (*.bmp)
  • DCX 文件 (*.dcx)
  • PEG 文件 (*.jpg; *.jpeg; *.jfif)
  • PCX 文件 (*.pcx)
  • PNG 文件 (*.png)
  • TIFF 文件 (*.tif; *.tiff)
  • Windows 增强媒体文件 (*.emf)


Диалог Свойства: Поле метки

元素属性对话框：表格

项目 | 描述
单元间距： | 设置表格单元的间距。
使用第一行作为标题 | 如果选择该选项，第一行将包含列名。


段落属性

可以在 段落属性 对话框（编辑模式中的文本快捷菜单>段落属性）中查看主要段落属性。

向我显示段落属性对话框

项目 | 描述
常规 |
对齐 | 将文本左对齐或右对齐、将文本居中或适合页面宽度对齐文本。
缩进 |
文本前 | 设置左缩进。
文本后 | 设置右缩进。
间距 |
段前 | 设置段前的间距。
段后 | 设置段后的间距。
行间距 ： | 更改文本行之间的行距。