О программе ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов Формы, созданные с учетом требований автоматизированного ввода машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка формы является важным этапом, так как от "правильности" разработанного макета формы (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

Если сравнивать ABBYY FormDesigner с другими известными редакторами, которые можно использовать для создания макетов форм (MS Visio, Corel Draw, MS Word), то последние, предоставляя широкий спектр возможностей для создания разнообразных форм, тем не менее, специально не предназначены для создания именно машиночитаемых форм. Поэтому создателю формы приходится внимательно отслеживать соответствие формы Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму требованиям машиночитаемости: вручную измерять размеры элементов, а также следить за их формой и расположением.

Программа ABBYY FormDesigner учитывает специфику разработки машиночитаемых форм, не требует дополнительного обучения операторов, имеет интуитивно-понятный пользовательский интерфейс и обладает широким спектром инструментов для создания и редактирования элементов машиночитаемой формы. Программа позволяет создавать как черно-белые, так и цветные фоновые формы. В программу встроена автоматическая Проверка пригодности формы для автоматизированного ввода и дальнейшей обработки распознанного текста проверка машиночитаемости создаваемой формы, а элементы формы обладают набором свойств, созданных с учетом требований машиночитаемости. Таким образом, с помощью ABBYY FormDesigner вы можете создавать формы, удовлетворяющие требованиям машиночитаемости, не тратя при этом времени на утомительные расчеты размеров и расположения элементов формы.

Важным преимуществом программы ABBYY FormDesigner является то, что разработав форму с помощью этой программы, вы автоматически получаете готовое описание формы, которое можно использовать для создания шаблона документа в программе ABBYY FlexiCapture.

Таким образом, использование программы ABBYY FormDesigner помогает не только упростить процесс разработки формы, но и минимизирует настройку системы автоматизированного ввода форм ABBYY FlexiCapture для работы с документами данного образца.

Программа ABBYY FormDesigner предоставляет возможность импортировать формы из PDF-файлов, полученных в других редакторах макетов форм; опубликовать разработанную форму (защитить её от случайных изменений), распечатать, а также экспортировать её в различные форматы, в том числе графические, что может понадобиться при передаче формы в типографию. Теперь непосредственно из программы можно отправить форму для заполнения в электронном виде (по списку электронных адресов, или выложить на сайт), а также выбрать способ получения заполненных форм (на электронный адрес или через сайт), с возможностью обработки результатов на сервере. О новых возможностях ABBYY FormDesigner можно посмотреть здесь.


Новые возможности ABBYY FormDesigner

В версии ABBYY FormDesigner появились следующие новые возможности:

    Создание форм

  • Добавлен элемент Группа меток. Вы можете быстро создать группу меток выбранного типа (Матрица, Таблица или Список), используя Мастер создания группы меток, и добавить созданную группу меток на форму.

  • Добавлена возможность указать свойства пустой страницы, используемые при создании новой пустой формы. Настройки для пустых страниц указываются на закладке Свойства пустой страницы меню Сервис > Настройки....

  • Добавлен новый стиль формы: цветная форма. Для цветных форм цвет фона страницы и цвет элементов формы можно выбрать из палитры цветов. Стиль формы можно выбрать в диалоговом окне Свойства страницы, а также на закладке Свойства пустой страницы меню Сервис > Настройки.... Печатать цветные формы не рекомендуется.

    • Редактирование форм

  • Теперь можно добавить подсказку для элемента поле метки.

  • Порядок страниц в многостраничных формах теперь можно изменить с помощью операции "drag and drop".

    • Экспорт форм

  • Добавлена возможность печатать заполненные формы с использованием командной строки.

  • Появилась возможность использовать ID элемента при заполнении формы данных из базы или файла.

    • Заполнение форм

  • Теперь вы можете накладывать ограничения на значения, которые можно вводить при заполнении формы. Ограничения могут быть наложены на значения элементов поле ввода, поле даты и числовое поле. Ограничения на значения полей задаются с помощью правил.


Установка, запуск и удаление программы ABBYY FormDesigner

Программа ABBYY FormDesigner устанавливается и удаляется вместе с программой ABBYY FlexiCapture.

Чтобы запустить программу ABBYY FormDesigner:

  • Выберите пункт ABBYY FormDesigner в меню Пуск/Программы/ABBYY FlexiCapture/Инструменты.


Главное окно программы

При запуске программы открывается главное окно программы ABBYY FormDesigner, а также диалог Быстрый старт. Диалог Быстрый старт поможет быстро приступить к работе, так как содержит команды, наиболее часто используемые при старте приложения: Открыть файл, Последние файлы (открыть файл из списка последних использованных файлов); Создать пустую форму, создать форму По образцу или запустить Мастер создания формы.

Вы можете настроить вид главного окна в меню Настройки.

Collapsed Показать главное окно программы

Строка меню. Содержит меню программы: Файл, Правка, Вид, Форма, Элементы, Сервис и Справка. Показать/скрыть элементы интерфейса можно при помощи меню Вид.

Панель инструментов Стандартная. Содержит кнопки наиболее часто используемых стандартных команд.

Панель инструментов Редактирование. Содержит кнопки наиболее часто используемых команд редактирования элементов.

Панель инструментов Форматирование. Содержит кнопки наиболее часто используемых команд форматирования текста.

Панель инструментов Элементы формы. Содержит кнопки команд добавления элементов на форму.

Линейка. Вспомогательный инструмент, применяемый при создании и редактировании формы для более точного расположения и выравнивания элементов формы.

Окно Форма. Содержит непосредственно форму, открытую в данный момент времени. Одновременно в главном окне может отражаться только одна форма.

Структура документа. В этом окне отображается иерархическая структура полей, к каждому из которых привязан один или несколько элементов формы.

Окно Свойства. Это окно предназначено для просмотра и редактирования свойств выделенного элемента. Окно содержит несколько вкладок (в зависимости от типа элемента, выделенного в данный момент); чтобы перейти на нужную вкладку, щелкните по ее названию справа.

Строка состояния. Содержит информацию о выбранном элементе формы (координаты верхнего левого угла элемента в мм, размер элемента в мм, дополнительная информация, тип элемента) и о форме в целом (вид формы, размер страницы в мм). Дополнительная информация выводится для элементов Поле для ввода, Поле даты, Числовое поле - количество строк поля и размер строк (количество знакомест). Для элемента Числовое поле выводится количество знакомест до и после запятой.


Главное меню

Collapsed Файл
Пункт меню | Описание
Новая… | Позволяет открыть диалог Быстрый старт, который содержит команды, наиболее часто используемые при старте приложения: открыть файл, открыть файл из списка последних использованных файлов; создать пустую форму, создать форму по образцу или запустить Мастер создания формы.
Открыть… | Позволяет открыть форму.
Сохранить | Позволяет сохранить форму.
Сохранить как… | Позволяет сохранить форму под другим именем, а также сохранить образец формы и страницы.
Экспортировать в
Файл изображения… | Позволяет экспортировать форму в файл изображения.
Изображения с цветоделением… | Позволяет экспортировать цветную форму в файлы изображения с разделением на цвета. В результате будут сохранены два файла в формате TIFF - черно-белый и цветной.
XML Form Definition… | Позволяет экспортировать форму в формат XML Form Definition. Только для опубликованных форм.
Форму PDF… | Позволяет экспортировать форму ABBYY FormDesigner в форму PDF. Только для опубликованных форм. При этом можно добавить на форму кнопки отправки ответов - на адрес электронной почты и/или веб-сайт, а также задать параметры экспорта. Чтобы выполнить экспорт в форму PDF, на форме должно быть хотя бы одно редактируемое поле.
Форму InfoPath… | Позволяет экспортировать форму ABBYY FormDesigner в форму InfoPath. Чтобы выполнить экспорт в форму InfoPath, на форме должно быть хотя бы одно редактируемое поле.
Файл Adobe Illustrator… | Позволяет экспортировать форму в файл Adobe Illustrator.
Импортировать из Searchable PDF-файла… | Позволяет импортировать форму из PDF-файла с возможностью поиска, созданного в другом редакторе макетов форм.
Опубликовать | Позволяет опубликовать форму.
Сохранить редактируемую копию как… | Позволяет сохранить и редактировать копию опубликованной формы.
Отправить форму для заполнения… | Открывает Мастер распространения формы, который позволяет задать параметры отправки формы для заполнения и получения заполненных форм.
Настройка печати… | Позволяет открыть диалог Настройка печати.
Просмотр | Позволяет просмотреть форму перед печатью.
Печать | Отправляет форму на печать с настройками по умолчанию.
Печать заполненных форм… | Позволяет распечатать формы, заполненные значениями из файла или базы данных.
Последние файлы | Позволяет выбрать из списка и открыть один из ранее открытых файлов.
Выход | Позволяет закрыть программу ABBYY FormDesigner.
Collapsed Правка
Пункт меню | Описание
Отменить | Позволяет отменить действие последней выполненной команды.
Повторить | Позволяет отменить действие последней команды Отменить.
Вырезать | Позволяет удалить выделенный элемент (или текст) и помещает его в буфер обмена.
Копировать | Позволяет скопировать выделенный элемент (или текст) в буфер обмена.
Вставить | Позволяет вставить элемент (или текст) из буфера обмена.
Удалить | Позволяет удалить выделенные элементы. Связанные с ними поля структуры документа также будут удалены.
Дублировать | Позволяет дублировать выделенные элементы.
Редактировать текст | Позволяет редактировать текст выделенного элемента Текст или Поле метки.
Переименовать поле | Позволяет переименовать выделенное поле структуры документа.
Удалить блок | Позволяет удалить выделенные элементы, не удаляя связанные поля структуры документа.
Выделить все | Позволяет выделить все элементы формы.
Выделить по типу… | Позволяет открыть диалог Выделить типы элементов, в котором можно указать типы выделяемых элементов.
Collapsed Вид
Пункт меню | Описание
Панели инструментов
Стандартная | Позволяет показать/скрыть панель инструментов Стандартная.
Форматирование | Позволяет показать/скрыть панель инструментов Форматирование.
Элементы формы | Позволяет показать/скрыть панель инструментов Элементы формы.
Редактирование | Позволяет показать/скрыть панель инструментов Редактирование.
Большие кнопки | Позволяет увеличить/уменьшить размер кнопок панелей инструментов.
Строка состояния | Позволяет показать/скрыть строку состояния. Строка состояния отображает подсказки для кнопок и пунктов меню программы; размер, положение и тип выделенного элемента; свойства страницы.
Структура документа | Позволяет показать/скрыть окно с иерархической структурой документа.
Свойства | Позволяет показать/скрыть окно свойств элемента.
Сетка | Позволяет показать/скрыть сетку разметки.
Основная линейка | Позволяет показать/скрыть основную линейку.
Отступы | Позволяет показать/скрыть разметку отступов по краям формы.
Привязать к сетке | Позволяет включить/отключить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
Привязывать линейки к элементам | Включает/выключает режим автоматической привязки линеек к элементам. Если режим включен, то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки.
Показывать линейки для выравнивания | Включает/выключает отображение линеек для выравнивания.
Удалить линейки для выравнивания | Удаляет все линейки для выравнивания.
Масштаб
200% | Позволяет установить масштаб 200% в окне Форма.
150% | Позволяет установить масштаб 150% в окне Форма.
100% | Позволяет установить масштаб 100% в окне Форма.
75% | Позволяет установить масштаб 75% в окне Форма.
50% | Позволяет установить масштаб 50% в окне Форма.
По ширине | Позволяет установить в окне Формы такой масштаб, при котором изображение умещается на экране по ширине.
По высоте | Позволяет установить в окне Формы такой масштаб, при котором изображение умещается на экране по высоте.
Форму целиком | Позволяет установить в окне Формы такой масштаб, при котором форма умещается на экране целиком.
Уменьшить | Позволяет уменьшить масштаб отображения формы в 2 раза.
Увеличить | Позволяет увеличить масштаб отображения формы в 2 раза.
Collapsed Форма
Пункт меню | Описание
Свойства формы… | Позволяет открыть диалог Свойства формы.
Добавить страницу
Пустую | Позволяет добавить в форму пустую страницу.
На основе образца… | Позволяет добавить в форму страницу, созданную на основе образца.
Удалить страницу | Позволяет удалить текущую страницу.
Свойства страницы… | Позволяет открыть диалог Вид
Collapsed Элементы
Пункт меню | Описание
Выбрать
Инструмент выбора | Позволяет выбрать один из инструментов для создания элементов формы или выделить уже созданный элемент формы.
Поле для ввода | Позволяет выбрать инструмент для создания элемента Поле для ввода.
Поле даты | Позволяет выбрать инструмент для создания элемента Поле даты.
Числовое поле | Позволяет выбрать инструмент для создания элемента Числовое поле.
Поле метки | Позволяет выбрать инструмент для создания элемента Поле метки.
Группа элементов | Позволяет выбрать инструмент для создания Группы элементов.
Таблица | Позволяет выбрать инструмент для создания элемента Таблица.
Вертикальный разделитель | Позволяет выбрать инструмент для создания в таблице вертикального разделителя.
Горизонтальный разделитель | Позволяет выбрать инструмент для создания в таблице горизонтального разделителя.
Удалить разделитель | Позволяет выбрать инструмент для удаления из таблицы разделителя.
Вертикальная линейка | Позволяет выбрать инструмент для создания Вертикальной линейки.
Горизонтальная линейка | Позволяет выбрать инструмент для создания Горизонтальной линейки.
Текст | Позволяет выбрать инструмент для создания элемента Текст.
Разделитель | Позволяет выбрать инструмент для создания элемента Разделитель.
Рамка | Позволяет выбрать инструмент для создания элемента Рамка.
Картинка | Позволяет выбрать инструмент для создания элемента Картинка.
Репер | Позволяет выбрать инструмент для создания элемента Репер.
Идентификатор | Позволяет выбрать инструмент для создания элемента Идентификатор.
Образец заполнения… | Добавляет на форму образец заполнения.
Группа меток | Открывает Мастер создания группы меток для добавления на форму элемента Группа меток.
Выравнивание
По левому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
Горизонтально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по вертикали.
По правому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
По верхнему краю | Позволяет выровнять выделенные элементы формы по верхнему краю последнего из выделенных элементов.
Вертикально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по горизонтали.
По нижнему краю | Позволяет выровнять выделенные элементы формы по нижнему краю последнего из выделенных элементов.
По сетке | Позволяет выровнять левый верхний угол выделенных элементов формы по сетке, сохранив при этом размеры элементов.
Равномерно по горизонтали | Распределяет выделенные элементы равномерно по горизонтали
Равномерно по вертикали | Распределяет выделенные элементы равномерно по вертикали.
Размер
Выровнять по ширине | Позволяет выровнять ширину выделенные элементы формы по ширине последнего из выделенных элементов.
Выровнять по высоте | Позволяет выровнять высоту выделенные элементы формы по высоте последнего из выделенных элементов.
Выровнять по ширине и высоте | Позволяет выровнять ширину и высоту выделенных элементов формы по ширине и высоте последнего из выделенных элементов.
Выровнять размер по сетке | Позволяет раздвинуть границы выделенных элементов формы до ближайших линий сетки.
По размеру данных | Позволяет выровнять границы выделенного элемента по размеру данных в нем.
На передний план | Позволяет поместить выделенный элемент формы на передний план формы.
На задний план | Позволяет поместить выделенный элемент формы на задний план формы.
Объединить | Позволяет объединить выделенные элементы формы.
Разъединить | Позволяет разъединить выделенные элементы.
Добавить к объединенным | Позволяет добавить элементы к ранее объединенным. При этом должны быть выделены и ранее объединенные, и добавляемые элементы.
Collapsed Сервис
Пункт меню | Описание
Проверить форму | Позволяет запустить процедуру проверки формы на машиночитаемость.
Настройки… | Позволяет открыть диалог Настройки вида главного окна программы и параметров экспорта.
Collapsed Справка
Пункт меню | Описание
Вызов справки | Позволяет открыть Справку программы.
Техническая поддержка | Позволяет открыть страницу Техническая поддержка в Справке программы.
Отправить отзыв… | Позволяет отправить отзыв о программе ABBYY FormDesigner в компанию ABBYY. Откроется страница сайта компании, содержащая форму отправки отзыва о программном продукте ABBYY FormDesigner&FlexiCapture.
О программе | Позволяет открыть диалог О программе ABBYY FormDesigner 11, содержащий краткую информацию о программе.


Локальное меню панели инструментов

Пункт меню | Описание
Стандартная | Позволяет показать/скрыть панель инструментов Стандартная.
Форматирование | Позволяет показать/скрыть панель инструментов Форматирование.
Элементы формы | Позволяет показать/скрыть панель инструментов Элементы формы.
Редактирование | Позволяет показать/скрыть панель инструментов Редактирование.
Большие кнопки | Позволяет увеличить/уменьшить размер кнопок панелей инструментов.
Настройки… | Позволяет открыть диалог Настройки.


Локальное меню элемента формы

Пункт меню | Описание
По размеру данных | Позволяет выровнять размер выделенного элемента по размеру данных в нем.
Вырезать | Позволяет удалить выделенный элемент (или текст) и помещает его в буфер обмена.
Копировать | Позволяет скопировать выделенный элемент (или текст) в буфер обмена.
Вставить | Позволяет вставить элемент (или текст) из буфера обмена.
Удалить | Позволяет удалить выделенные элементы. Связанные с ними поля структуры документа также будут удалены.
Удалить блок | Позволяет удалить выделенные элементы, не удаляя связанные поля структуры документа.
Дублировать | Позволяет дублировать выделенные элементы.
Редактировать текст | Позволяет редактировать текст выделенного элемента Текст или Поле метки.
На передний план | Позволяет поместить выделенный элемент формы на передний план формы.
На задний план | Позволяет поместить выделенный элемент формы на задний план формы.
Объединить | Позволяет объединить выделенные элементы.
Разъединить | Позволяет разъединить выделенные элементы.
Свойства… | Позволяет показать/скрыть панель свойств элемента.
Свойства страницы… | Позволяет открыть диалог Свойства страницы.


Меню Настройки

Для открытия диалога Настройки, выберите пункт Настройки… в меню Сервис.

В этом диалоге вы можете изменить вид главного окна, указать настройки экспорта и свойства пустой страницы.

Collapsed Показать диалог Настройки

Настройка | Описание
Вид
Язык интерфейса Позволяет выбрать язык интерфейса. Все сообщения, названия диалогов, кнопок и пунктов меню будут написаны на выбранном языке. Для того чтобы изменить язык интерфейса, выберите нужное значение из этого списка, нажмите кнопку OK, а затем перезапустите программу ABBYY FormDesigner.
По умолчанию язык интерфейса совпадает с языком, который был выбран для установки программы.
Группа Сетка
Показывать сетку Позволяет отобразить сетку разметки на экране.
По умолчанию пункт не выбран.
Ширина Позволяет задать ширину ячейки сетки разметки. Измеряется в миллиметрах (мм).
По умолчанию значение равно 1 мм.
Высота Позволяет задать высоту ячейки сетки разметки. Измеряется в миллиметрах (мм).
По умолчанию значение равно 1 мм.
Привязывать к сетке | Позволяет включить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
Группа Цвет Позволяет задать цвет фона редактируемого текста, линеек и границ отступов формы при отображении их на экране.
В окне Цвет выберите один из объектов формы. Затем выберите цвет, которым он будет отображаться на экране (щелкните мышью на цветном прямоугольнике, в открывшемся диалоге Цвет (Color) выберите необходимый цвет).
Показывать линейку | Позволяет отобразить на экране линейку.
Показывать отступы | Позволяет отобразить на экране отступы формы.
Группа Редактор текста
Размеры табуляции | Позволяет задать количество пробелов, которые вставляются в редакторе текста при нажатии табуляции.
Экспорт
Группа XFD
Сохранять изображения в формате Позволяет выбрать формат для сохранения изображений страниц при экспорте в XFD. Поддерживаются форматы:
  • TIFF;
  • EMF.
Группа Изображение
Разрешение TIFF-файлов | Позволяет задать разрешение для экспорта изображений в формат TIFF.
Свойства пустой страницы
Стиль Выберите вид страницы:
  • Серая фоновая форма
  • Черно-белая форма
  • Оранжевая фоновая форма
  • Красная фоновая форма
  • Зеленая фоновая форма
  • Цветная форма (не для печати)
По умолчанию выбрана Черно-белая форма.
Группа Размер
Размер Позволяет выбрать из списка один из стандартных размеров страницы формы, соответствующих размерам бумаги: A3, A4, A5, US Legal или US Letter или задать свой размер страницы. Для того чтобы задать свой размер страницы формы, выберите пункт Пользовательский и укажите ширину и высоту страницы формы в соответствующих полях.
По умолчанию выбран размер A4.
Ширина Позволяет задать ширину страницы (в мм).
Ширина по умолчанию - 210 мм.
Высота Позволяет задать высоту страницы (в мм).
Высота по умолчанию - 297 мм.
Группа Отступы
По верхнему краю Позволяет задать ширину отступа от верхнего края страницы.
Отступ по умолчанию - 10 мм.
По нижнему краю Позволяет задать ширину отступа от нижнего края страницы.
Отступ по умолчанию - 10 мм.
По левому краю Позволяет задать ширину отступа от левого края страницы.
Отступ по умолчанию - 10 мм.
По правому краю Позволяет задать ширину отступа от правого края страницы.
Отступ по умолчанию - 10 мм.
Группа Фон
Цвет Позволяет выбрать цвет фона страницы.
Замечание. Выбор цвета фона возможен только для фоновых форм, для черно-белых форм цвет по умолчанию белый.
Размер Позволяет выбрать размер площади залитой фоном:
  • Вся страница (фоном будет залита вся страница, за исключением выделенных на ней элементов).
  • Только внутри границ отступов формы (фоном будет залито все, что находится внутри границ отступов формы, за исключением выделенных на форме элементов).
Замечание. Для черно-белых форм эта опция недоступна.
Группа Ориентация
Книжная | Позволяет задать книжную ориентацию формы.
Альбомная | Позволяет задать альбомную ориентацию формы.
Группа Шрифт по умолчанию
Позволяет выбрать шрифт из списка* и указать размер шрифта.
Восстановить стандартные | При нажатии кнопки Восстановить стандартные выбранные настройки сбрасываются и восстанавливаются стандартные настройки.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Панели инструментов

Четыре панели инструментов программы ABBYY FormDesigner: Стандартная, Форматирование, Элементы формы и Редактирование.

Показать/скрыть панели инструментов можно при помощи пунктов меню Вид>Панели инструментов, или из локального меню панели инструментов). Чтобы отобразить панель инструментов на экране, отметьте название панели в меню, щелкнув на нем мышью.

Чтобы открыть локальное меню панели инструментов, щелкните правой кнопкой мыши на любой панели инструментов.

Кнопки на панелях инструментов - средство быстрого доступа к командам программы. Те же команды можно вызвать из меню программы или с помощью горячих клавиш.

Можно использовать большие или маленькие кнопки на панелях инструментов. По умолчанию кнопки маленькие, чтобы изменить их размер, выберите пункт меню Вид>Панели инструментов>Большие кнопки.

Если вы хотите узнать о назначении той или иной кнопки на инструментальной панели, установите на ней курсор мыши, рядом с кнопкой появится всплывающая подсказка.


Панель инструментов Стандартная

На панели инструментов Стандартная находятся кнопки вызова команд, выполняющих стандартные действия, например, создание или открытие формы, отмена и повтор команды и др. Нажатие нужной кнопки с помощью мыши приводит к выполнению соответствующей команды.

Collapsed Показать панель инструментов Стандартная

Описание кнопок панели инструментов Стандартная:

Кнопка | Описание
Новая | Позволяет создать новую форму с базовыми элементами.
Открыть | Позволяет открыть форму.
Сохранить | Позволяет сохранить форму.
Просмотр | Позволяет просмотреть форму перед печатью.
Печать | Позволяет напечатать форму.
Вырезать | Позволяет удалить выделенный текст и помещает его в буфер обмена.
Копировать | Позволяет скопировать выделенный текст в буфер обмена.
Вставить | Позволяет вставить текст из буфера обмена.
Отменить | Позволяет отменить действие последней выполненной команды.
Восстановить | Позволяет отменить действие последней команды Отменить.
Уменьшить | Позволяет уменьшить масштаб отображения формы в 2 раза.
Увеличить | Позволяет увеличить масштаб отображения формы в 2 раза.
Масштаб | Позволяет изменять текущий масштаб отображения формы.
Отправить форму для заполнения | Позволяет открыть Мастер распространения формы (только для опубликованных форм).


Панель инструментов Редактирование

На панели инструментов Редактирование находятся кнопки вызова команд, позволяющих редактировать элементы на форме. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего инструмента редактирования.

Collapsed Показать панель инструментов Редактирование

Описание кнопок панели инструментов Редактирование:

Кнопка | Описание
Показать сетку | Позволяет показывать/не показывать сетку разметки на экране
Показать основную линейку | Позволяет показывать/не показывать основную линейку на экране.
Привязать к сетке | Позволяет включить/отключить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
По левому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
Горизонтально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по вертикали.
По правому краю | Позволяет выровнять выделенные элементы формы по правому краю последнего из выделенных элементов.
По верхнему краю | Позволяет выровнять выделенные элементы формы по верхнему краю последнего из выделенных элементов.
Вертикально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по горизонтали.
По нижнему краю | Позволяет выровнять выделенные элементы формы по нижнему краю последнего из выделенных элементов.
Равномерно по горизонтали | Распределяет выделенные элементы равномерно по горизонтали.
Равномерно по вертикали | Распределяет выделенные элементы равномерно по вертикали.
По сетке | Позволяет выровнять левый верхний угол выделенных элементов формы по сетке, сохранив при этом размеры элементов.
По высоте | Позволяет выровнять высоту выделенных элементов формы по высоте последнего из выделенных элементов.
По ширине | Позволяет выровнять ширину выделенных элементов формы по ширине последнего из выделенных элементов.
По высоте и ширине | Позволяет выровнять ширину и высоту выделенных элементов формы по ширине и высоте последнего из выделенных элементов.
Размер по сетке | Позволяет раздвинуть границы выделенных элементов формы до ближайших линий сетки.
Объединить | Позволяет объединить выделенные элементы формы.
Разъединить | Позволяет разъединить выделенные элементы.
Добавить к объединенным | Позволяет добавить элементы к ранее объединенным. При этом должны быть выделены и ранее объединенные, и добавляемые элементы.
На передний план | Позволяет поместить выделенные элементы формы на передний план формы.
На задний план | Позволяет поместить выделенные элементы формы на задний план формы.
Привязывать линейки к элементам | Включает/выключает режим автоматической привязки линеек к элементам. Если режим включен, то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки.
Показать все линейки | Позволяет показать/скрыть все линейки.
Вертикальная линейка | Позволяет создать вертикальную линейку.
Горизонтальная линейка | Позволяет создать горизонтальную линейку.
Удалить все линейки | Позволяет удалить все линейки.


Панель инструментов Форматирование

На панели инструментов Форматирование находятся кнопки вызова команд, позволяющих форматировать текст на форме.

Выделите текст, который вы хотите отформатировать, затем выберите требуемый инструмент форматирования на панели инструментов. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего инструмента форматирования.

Collapsed Показать панель инструментов Форматирование

Описание кнопок панели инструментов Форматирование:

Кнопка | Описание
Шрифт | Позволяет изменять шрифт для текста выделенных элементов.
Размер шрифта | Позволяет изменять размер шрифта для текста выделенных элементов.
Жирный | Позволяет выделять текст жирным шрифтом.
Курсивный | Позволяет выделять текст курсивным шрифтом.
Подчеркнутый | Позволяет выделять текст подчеркнутым шрифтом.
По левому краю | Позволяет выровнять текст выделенного элемента формы по левому краю этого элемента.
Горизонтально по центру | Позволяет выровнять текст выделенного элемента формы горизонтально по центру этого элемента.
По правому краю | Позволяет выровнять текст выделенного элемента формы по правому краю этого элемента.
Выровнять по ширине | Позволяет выровнять текст выделенного элемента формы по ширине этого элемента.
По нижнему краю | Позволяет выровнять текст выделенного элемента формы по нижнему краю этого элемента.
Вертикально по центру | Позволяет выровнять текст выделенного элемента формы вертикально по центру этого элемента.
По верхнему краю | Позволяет выровнять текст выделенного элемента формы по верхнему краю этого элемента.
Метка слева | Позволяет поместить поле метки слева от пояснительной информации.
Метка сверху | Позволяет поместить поля метки сверху от пояснительной информации.
Метка справа | Позволяет поместить поле метки справа от пояснительной информации.
Метка снизу | Позволяет поместить поле метки снизу от пояснительной информации.

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Панель инструментов Элементы формы

На панели инструментов Элементы формы находятся кнопки вызова команд, позволяющих добавлять новые элементы на форму. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего элемента, который будет добавлен на форму.

Collapsed Показать панель инструментов Элементы формы

Описание кнопок панели инструментов Элементы формы:

Кнопка | Описание
Инструмент выбора | Позволяет выбрать один из инструментов для добавления элементов формы или выделить уже созданный элемент формы.
Поле для ввода | Позволяет добавить элемент Поле для ввода.
Поле даты | Позволяет добавить элемент Поле даты.
Числовое поле | Позволяет добавить элемент Числовое поле.
Поле метки | Позволяет добавить элемент Поле метки.
Группа элементов | Позволяет добавить Группу элементов.
Таблица | Позволяет добавить элемент Таблица.
Вертикальный разделитель | Позволяет добавить в таблицу вертикальный разделитель.
Горизонтальный разделитель | Позволяет добавить в таблицу горизонтальный разделитель.
Удалить разделитель | Позволяет удалить любой разделитель.
Текст | Позволяет добавить элемент Текст.
Разделитель | Позволяет добавить элемент Разделитель.
Рамка | Позволяет добавить элемент Рамка.
Картинка | Позволяет добавить элемент Картинка.
Репер | Позволяет добавить элемент Репер.
Идентификатор | Позволяет добавить элемент Идентификатор.
Группа меток | Позволяет добавить элемент Группа меток.


Работа с программой ABBYY FormDesigner

Данный раздел содержит информацию о возможностях программы ABBYY FormDesigner.

Содержание раздела:

  • Создание формы

  • Свойства формы

  • Структура документа

  • Добавление, удаление и редактирование элементов формы

  • Выделение и перемещение элементов формы

  • Сохранение и публикация формы. Проверка на машиночитаемость

  • Экспорт формы

  • Отправить форму для заполнения

  • Печать формы

  • Печать заполненных форм


Как создать, сохранить и открыть форму

Как создать форму

Диалог Быстрый старт, который открывается при старте приложения или из меню (Файл>Новая…), позволяет создать новую форму (пустую или с базовыми элементами), создать форму по образцу, а также использовать Мастер создания формы , который последовательно проведет вас по необходимым этапам создания формы. По окончании работы мастера останется только добавить необходимые для вашей формы элементы с помощью панели инструментов Элементы формы и сохранить форму.

Подробнее см. раздел Создание формы.

Как сохранить форму

Для того чтобы сохранить форму, воспользуйтесь стандартной командой Сохранить или Сохранить как… (меню Файл).

Как открыть форму

Чтобы открыть форму:

  • Выберите команду Открыть… (меню Файл>Открыть…), или
  • Выберите инструмент Открыть на панели инструментов Стандартная, или
  • Нажмите комбинацию клавиш Ctrl+O.


Как опубликовать форму

Публикация формы - это процесс, при котором форме присваивается статус (Опубликованная), не позволяющий вносить в форму изменения. Во время публикации форма проверяется на машиночитаемость и ей присваивается уникальный номер, который прописывается в идентификаторе.

Для того чтобы опубликовать форму, воспользуйтесь командой Опубликовать (меню Файл). Опубликованные формы доступны только для просмотра. Для того чтобы внести изменения в опубликованную форму, воспользуйтесь командой Сохранить редактируемую копию как… (меню Файл), при этом сначала будет предложено сохранить форму под другим именем, а потом вносить изменения.

Подробнее см. Сохранение и публикация формы. Проверка формы на машиночитаемость.


Как получить изображение формы

Для того чтобы получить изображение формы, воспользуйтесь командой Файл изображения… (меню Файл>Экспортировать в>Файл изображения…). В открывшемся диалоге Сохранить изображение как выберите формат файла изображения, укажите название файла и папку, куда файл будет сохранен.

Подробнее см. Экспорт в файл изображения.


Как получить описание формы для программы ABBYY FlexiCapture

Важным преимуществом программы ABBYY FormDesigner является то, что, разработав форму с помощью программы ABBYY FormDesigner, вы автоматически получаете готовое описание формы, которое можно использовать для создания определения документа в программе ABBYY FlexiCapture.

Для того чтобы получить описание формы и использовать его в программе ABBYY FlexiCapture:

  1. Создайте форму в программе ABBYY FormDesigner.
  2. Опубликуйте форму (меню Файл>Опубликовать).
  3. Экспортируйте опубликованную форму в формат XML Form Definition (меню Файл>Экспортировать в>XML Form Definition…). В открывшемся диалоге Экспорт в XML Form Definition укажите название файла и папку, куда файл будет сохранен.
  4. Откройте программу ABBYY FlexiCapture и выберите пункт меню Проект>Определения документов...
  5. Нажмите Импорт и укажите созданный файл *.xfd.

Подробнее см. Экспорт в XML Form Definition (*.xfd)


Создание формы

Процесс создания машиночитаемой формы можно разделить на следующие этапы: анализ формы, непосредственно создание новой формы, тиражирование формы.

На этапе анализа формы необходимо:

  1. определить содержание формы, согласовать со всеми заинтересованными лицами названий полей и пояснительную информацию;
  2. выбрать вид формы (черно-белая линейчатая или растровая, цветная фоновая) и способ тиражирования форм (печать в типографии, печать на принтере, копирование, размещение в Интернете).
  3. согласовать макет формы с требованиями к машиночитаемым формам.

На этапе создания новой формы необходимо:

  1. создать электронную версию формы;
  2. опубликовать форму, т.е. присвоить форме статус, по которому запрещается вносить изменения в дизайн формы (таким способом уменьшается вероятность того, что в разное время с одного и того же образца будут размножены отличающиеся друг от друга формы).

На этапе тиражирования формы необходимо:

  1. подготовить форму к тиражированию.
  2. тиражировать форму (в бумажном или электронном виде).

Новая форма

Многостраничные формы

Создание формы на основе образца

Добавление, удаление и редактирование элементов формы

Выделение и перемещение элементов формы

Сохранение и публикация формы. Проверка формы на машиночитаемость.

Экспорт формы

Отправить форму для заполнения

Печать формы


Новая форма

Новую форму можно создать при помощи диалога Быстрый старт, который открывается при запуске программы, при выборе пункта меню Файл>Новая…, или при нажатии комбинации клавиш Ctrl+N.

Диалог Быстрый старт позволяет создать новую форму одним из трёх способов:

  • Создать пустую форму. В правой части диалога выберите, какую форму вы хотите создать - пустую или с базовыми элементами. Форму с базовыми элементами также можно создать с помощью кнопки "Новая" Стандартной панели инструментов.
  1. В случае выбора варианта Создать пустую форму будет создана пустая форма без каких-либо элементов.
  2. В случае выбора варианта Создать форму с базовыми элементами будет создана черно-белая форма, на которой уже присутствуют базовые элементы формы: стандартные реперы Collapsed

    Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

     (4 черных квадрата по углам и пятый квадрат в произвольном месте; при редактировании формы черные квадраты можно заменить на другие реперы), элемент Идентификатор Collapsed

    Элемент машиночитаемой формы, однозначно характеризующий данную форму.

     (штрих-код с цифрами) и элемент Текст Collapsed

    Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

    , предназначенный для внесения заголовка формы.
  • Создать форму на основе образца. В правой части диалога выберите, какой файл формата *.dtf вы хотите использовать в качестве образца для новой формы. По умолчанию образцы форм сохраняются в папку %USERPROFILE%\Documents\Templates.
  • Создать форму с помощью Мастера создания формы.
  1. На первом шаге работы мастера укажите свойства страницы формы: размер страницы и ее ориентацию.
  2. На втором шаге укажите вид формы (черно-белая, серая фоновая, цветная фоновая), размер фона (для фоновых форм - фон на всю страницу или только внутри границ отступов) и тип реперов.
  3. На третьем шаге выберите элементы оформления формы. Можно добавить заголовок (указать какой), добавить идентификатор (указать его тип и расположение), добавить образец заполнения формы (укажите, на каком языке).
  4. Четвертый шаг позволяет добавить на форму стандартные элементы из списка (имя, фамилию, контактную информацию), и в правой части диалога сразу же отобразится, как это будет выглядеть на форме. Для добавления/удаления выделенного элемента используйте кнопки ">>"/"<<".

    Для завершения работы мастера нажмите кнопку Завершить (Finish). Созданная форма автоматически откроется в главном окне программы ABBYY FormDesigner. Далее вы можете редактировать и сохранить созданную форму.

Свойства формы

Свойства страницы


Многостраничные формы

Программа ABBYY FormDesigner позволяет создавать многостраничные формы. Такие формы состоят из нескольких страниц, для каждой из которых можно задать имя и количество вхождений данной страницы в форму. Описание такой формы экспортируется в формат XFD с учетом многостраничности, и, на основе описания многостраничной формы, в программе ABBYY FlexiCapture можно создать определение многостраничного документа.

Создание многостраничной формы

Создать многостраничную форму можно, используя многостраничный образец формы.

Добавление страниц

Добавить страницы можно в любую форму. Для этого выберите пункт меню Форма>Добавить страницу или щелкните правой кнопкой мыши на названии страницы внизу создаваемой формы. Вы можете добавить пустую страницу или создать страницу на основе образца. Также можно добавить страницу, нажав на иконку [image] внизу формы. Настройки для пустых страниц указываются на закладке Свойства пустой страницы меню Сервис > Настройки.

Каждая страница может входить в форму произвольное количество раз. Задать максимальное и минимальное число вхождений данной страницы в форму можно в диалоге Свойства страницы (меню Форма>Свойства страницы…). В этом же диалоге вы можете задать имя текущей страницы.

Чтобы изменить порядок расположения страниц на форме, в списке страниц визу формы выделите страницу, которую вы хотите переместить, и перетащите ее с помощью мыши.

Экспорт многостраничных форм

Изображение многостраничной формы можно экспортировать в любой из поддерживаемых графических форматов. Для многостраничных форматов есть возможность сохранить форму как постранично (каждая страница в отдельном файле), так и целиком (все страницы в одном файле).


Создание формы на основе образца

Для создания новых форм или страниц форм программа ABBYY FormDesigner позволяет использовать образцы форм и образцы страниц форм.

Для создания образца формы (страницы) нужно:

  1. Создать форму (страницу) в программе ABBYY FormDesigner;
  2. Выбрать команду меню Файл>Сохранить как…;
  3. В выпадающем списке Тип файла (Save as type) выбрать пункт Образец формы или Образец страницы;
  4. Нажать кнопку Сохранить (Save).

По умолчанию образцы форм сохраняются в папку %USERPROFILE%\Documents\Templates.

Образец формы сохраняется в двоичном файле с расширением dtf (Document Template File), а страницы - с расширением ptf (Page Template File), в формате, представляющем собой модифицированный формат fdd-файла.

Образцы форм используются для создания форм на основе образца (диалог Быстрый старт - Создать - По образцу.

Образцы страниц используются для добавления новых страниц в многостраничные формы, для этого при добавлении новой страницы нужно выбрать пункт меню Форма>Добавить страницу>На основе образца….


Свойства формы

Основные свойства формы можно посмотреть в диалоге Свойства формы (меню Форма>Свойства формы…).

Collapsed Показать диалог Свойства формы

Свойство | Описание
Автор | Указывается автор формы.
Статус Указывается статус формы:
  • Редактируемая - форма доступна для редактирования;
  • Опубликованная - форма доступна только для чтения.
Дата публикации | Указывается дата публикации формы.
Значение идентификатора | Указывается значение идентификатора.
Файл | Указывается путь к файлу формы.


Свойства страницы

Свойства страницы формы определяют размер страницы, ориентацию страницы, размер отступов, а также вид страницы формы. Свойства страницы формы можно настроить в диалоге Свойства страницы, который открывается при выборе пункта меню Форма>Свойства страницы… или при выборе пункта Свойства страницы… локального меню страницы.

Collapsed Показать диалог Свойства страницы

Свойство | Описание
Общие
Название | Позволяет задать название страницы.
Число вхождений страницы в документ
Минимум | Позволяет уменьшить или увеличить минимальное число вхождений текущей страницы в форму.
Максимум | Позволяет уменьшить или увеличить максимальное число вхождений текущей страницы в форму.
Идентификатор страницы | В данном поле отображается значение идентификатора страницы.
Макет
Стиль Позволяет задать вид страницы формы:
  • Серая фоновая форма
  • Черно-белая форма
  • Оранжевая фоновая форма
  • Красная фоновая форма
  • Зеленая фоновая форма
  • Цветная форма (не для печати)
Размер бумаги
Размер страницы | Позволяет выбрать из списка один из стандартных размеров страницы формы, соответствующих размерам бумаги A3, A4, A5, US Legal или US Letter или задать свой размер страницы формы. Для того чтобы задать свой размер страницы формы, выберите пункт Пользовательский и укажите ширину и высоту страницы формы в соответствующих полях.
Ширина | Позволяет задать ширину страницы формы.
Высота | Позволяет задать высоту страницы формы.
Отступы
Сверху | Позволяет задать ширину отступа от верхнего края страницы.
Снизу | Позволяет задать ширину отступа от нижнего края страницы.
Слева | Позволяет задать ширину отступа от левого края страницы.
Справа | Позволяет задать ширину отступа от правого края страницы.
Фон страницы
Цвет Позволяет выбрать цвет фона страницы формы.
Замечание. Выбор цвета фона возможен только для фоновых форм, для черно-белых форм цвет по умолчанию белый.
Размер Позволяет выбрать размер площади залитой фоном:
  • Вся страница (фоном будет залита вся страница, за исключением выделенных на ней элементов).
  • Только внутри границ отступов формы (фоном будет залито все, что находится внутри границ отступов формы, за исключением выделенных на форме элементов).
Замечание. Для черно-белых форм эта опция недоступна.
Ориентация
Книжная | Позволяет задать книжную ориентацию формы.
Альбомная | Позволяет задать альбомную ориентацию формы.
Шрифт по умолчанию | Позволяет выбрать шрифт из списка* и указать размер шрифта.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Добавление, удаление и редактирование элементов формы

После создания новой формы можно переходить к следующему этапу - добавлению элементов формы.

Совет. Рекомендуется определить и согласовать содержание формы и только после этого заниматься размещением элементов на форме.

Добавление элементов формы рекомендуется проводить в следующем порядке:

  1. Задать отступы от краев формы.
  2. Добавить реперы.
  3. Добавить другие элементы формы.

По Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму требованиям машиночитаемости по всему периметру формы должны обязательно присутствовать отступы. По умолчанию при создании формы заданы отступы шириной 10 мм. Можно изменить ширину отступов формы. Для этого необходимо изменить значения в группе Отступы диалога Свойства страницы (меню Форма>Свойства страницы…>закладка Размер).

Для того чтобы отступы отражались на экране, необходимо выбрать пункт Показывать отступы на закладке Вид диалога Настройки (меню Сервис>Настройки…). На экране отступы отражаются пунктирной линией.

Для каждого элемента формы можно задать свойства.

Элемент Репер

Элемент Текст

Элемент Поле для ввода

Элемент Поле даты

Элемент Числовое поле

Элемент Поле метки

Элемент Группа меток

Элемент Разделитель

Элемент Прямоугольник

Элемент Картинка

Элемент Идентификатор

Элемент Таблица

Группа элементов


Структура документа

При добавлении элементов на форму автоматически создается структура документа - иерархическая структура полей, к каждому из которых привязан один или несколько элементов на изображении формы. ABBYY FormDesigner позволяет редактировать структуру документа, привязывать элементы к любым полям соответствующего типа.

Структура документа сохраняется и экспортируется как часть XFD-файла.

Отображение структуры документа

Чтобы отобразить структуру документа выберите пункт меню Вид>Структура документа. В правой части основного окна отобразится иерархическая структура полей документа. Вы можете добавлять новые поля, а также удалять, переименовывать и перемещать вверх и вниз все поля. Для этого воспользуйтесь пунктами локального меню Добавить поле (Удалить поле, Переименовать поле). Перемещать поля в структуре можно также с помощью клавиш ctrl+стрелка вверх/вниз или с помощью пунктов локального меню Переместить вверх/Переместить вниз. Если к полям привязаны элементы, то эти поля можно перемещать только на том же уровне, где они сейчас находятся, а если элементы к полям не привязаны, то их можно перемещать также в группу или из группы.

Добавление полей

При создании нового элемента формы автоматически создается новое поле структуры документа. Это поле имеет тот же тип, что и созданный элемент. Для создания нового поля вручную, выберите пункт локального меню >Добавить поле и выберите тип нового поля.

Привязка элементов формы к полям

При создании нового элемента формы, он будет привязан к автоматически созданному полю структуры документа. Для того чтобы привязать элемент к другому полю, выполните следующие действия:

  • выделите элемент на изображении формы;
  • щелкните в области элемента правой кнопкой мыши и выберите пункт локального меню Свойства…;
  • в диалоге Свойства перейдите на закладку Связанное поле и выберите другое поле из выпадающего списка. Вы сможете выбирать только среди полей того типа, к которому относится выбранный элемент. Если элемент входит в группу, то он может быть привязан только к полям, принадлежащим соответствующему групповому полю.

Замечание. Названия полей, к которым не привязано ни одного элемента, выделяются курсивом в окне структуры документа.

Удаление полей и элементов

Чтобы удалить поле в структуре документа выделите его и нажмите клавишу Удалить либо воспользуйтесь командой локального меню Удалить. При удалении поля связанный с ним элемент будет удален с формы.

При удалении элемента формы связанное поле удаляется, если к нему не привязаны другие элементы. Чтобы удалить элемент, не удаляя поле, можно воспользоваться клавишами Shift+Delete или командой Удалить блок в меню Правка или в локальном меню элемента.


Элемент Репер

Репер - это элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

Добавление реперов вынесено в отдельный пункт, т.к. является важным моментом в создании формы. Правильное расположение разумного количества реперов увеличит машиночитаемость формы и тем самым улучшит качество распознавания.

С помощью программы ABBYY FormDesigner можно создать реперы 2-х типов: Черный квадрат и Уголок.

Тип репера | Описание
Черный квадрат | Репер в виде черного квадрата.
Уголок | Репер в виде уголка.

Тип репера устанавливается один на всю форму. При задании типа репера также задаются и свойства реперов формы:

  • Размер. В случае репера Черный квадрат в качестве размера репера указывается длина стороны квадрата, в случае Уголка - длина стороны уголка;
  • Толщина линии. Указывается только при выборе типа репера Уголок. Имеется в виду толщина линии репера.

Добавление элемента Репер

Редактирование элемента Репер

Удаление элемента Репер


Добавление элемента Репер

При добавлении элемент Репер помещается на белое поле, размеры которого высчитываются автоматически, исходя из заданных размеров репера.

Чтобы добавить на форму элемент Репер:

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
  1. На панели инструментов Элементы формы выберите инструмент Репер.
  2. Щелкните мышью на том месте формы, где вы хотите разместить репер, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Репер (на белом фоне) будет размещен в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

По умолчанию при создании новой формы с базовыми элементами добавляются реперы типа Черный квадрат. Если вы хотите изменить тип репера на Уголок, то выделите репер, щелкните правой кнопкой мыши и выберите пункт локального меню Свойства. В открывшемся диалоге измените тип репера.


Редактирование элемента Репер

Свойства Тип репера, Размер репера и Толщина линии (в случае репера Уголок) задаются на всю форму. Редактирование этих свойств приведет к изменению всех реперов на форме.

Для каждого элемента Репер Collapsed

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

 задаются координаты, тип и размер элемента. Свойства элемента Репер не зависят от вида формы.

Свойства элемента Репер можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Репер.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Указывает ширину элемента Репер.
Высота Указывает высоту элемента Репер.
Внимание! Изменить размер элемента Репер можно на закладке Репер.
Репер
Тип Позволяет выбрать из списка стандартных реперов репер, который будет использоваться на форме (Черный квадрат или Уголок).

Одновременно на форме могут быть размещены реперы только одного типа.
Размер Позволяет задать размер репера:
  • в случае Черного квадрата - длину стороны квадрата;
  • в случае Уголка - длину стороны уголка.
Толщина линии (только при выборе репера Уголок) | Позволяет задать толщину линии репера (от 0,3 мм до 1 мм).


Удаление элемента Репер

Для того чтобы удалить элемент Репер:

  1. Выделите элемент Репер;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Текст

Текст - элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

Добавление элемента Текст

Редактирование элемента Текст

Удаление элемента Текст

Локальное меню элемента Текст


Добавление элемента Текст

Чтобы добавить на форму элемент Текст Collapsed

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

 :

  1. На панели инструментов Элементы формы выберите инструмент Текст.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

Замечание. Вы можете изменять форму элемента с помощью мыши:

  1. Нажмите клавишу Alt.
  2. Установите курсор внутри текстовой области и выделите часть области в прямоугольник. Данный прямоугольник будет удален из области.
  3. При необходимости передвиньте границу области.


Редактирование элемента Текст

Для каждого элемента Текст Collapsed

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

 задаются свойства: координаты и размеры элемента, текст, шрифт, перенос по словам, цвет текста, горизонтальное и вертикальное выравнивание, ориентацию, цвет фона элемента. Также для каждого элемента Текст можно задать свойства абзаца(отступы и интервалы).

Текст элемента можно редактировать прямо в поле элемента. Для запуска режима редактирования текста щелкните на элементе правой кнопкой мыши или воспользуйтесь командой Редактировать текст… (локальное меню элемента Текст>Редактировать текст…). Для редактирования текста используйте горячие клавиши.

Свойства элемента Текст можно редактировать в окнеСвойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Текст.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Текст.
Высота | Позволяет задать высоту элемента Текст.
Текст
Текст Позволяет посмотреть текст элемента.
Замечание. Чтобы отредактировать текст элемента, в локальном меню элемента Текст выберите пункт Редактировать текст. Текст можно отредактировать прямо в поле элемента.
Шрифт Позволяет редактировать шрифт для набора текста элемента.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить… В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.
Цвет | Позволяет выбрать из списка цвет текста*.
Переносить по словам | Позволяет переносить текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.
Выравнивание
Горизонтальное Позволяет выравнивать текст элемента по горизонтали.
  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.
Вертикальное Позволяет выравнивать текст элемента по вертикали.
  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.
Ориентация Позволяет задать ориентацию текста.
  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Текст цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента Текст *.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Текст

Для того чтобы удалить элемент Текст:

  1. Выделите элемент Текст;
  2. Выберите команду Удалить (меню Правка>Удалить, или локальное меню элемента> Удалить, или нажмите кнопку Delete на клавиатуре).


Локальное меню элемента Текст

Данное меню доступно при редактировании содержимого элемента Текст.

Пункт меню | Описание
Вырезать | Позволяет удалить выделенный элемент (или текст) и помещает его в буфер обмена.
Копировать | Позволяет скопировать выделенный элемент (или текст) в буфер обмена.
Вставить | Позволяет вставить элемент (или текст) из буфера обмена.
Удалить | Позволяет удалить выделенные элементы. Связанные с ними поля структуры документа также будут удалены.
Шрифт… | Позволяет открыть диалог Шрифт.
Абзац… | Позволяет открыть диалог Свойства абзаца.


Элемент Поле для ввода

Поле для ввода - элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.

Collapsed Показать поле для ввода

Добавление элемента Поле для ввода

Редактирование элемента Поле для ввода

Удаление элемента Поле для ввода

Настройка правил для элемента Поле ввода


Добавление элемента Поле для ввода

Чтобы добавить на форму элемент Поле для ввода Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.

:

  1. На панели инструментов Элементы формы выберите инструмент Поле для ввода.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента*. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

* - размер элемента Поля для ввода по вертикали можно менять только если в свойствах элемента отмечена опция Многострочное поле.


Редактирование элемента Поле для ввода

Для каждого элемента Поле для ввода Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы

 задаются свойства: координаты и размер элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Поле для ввода можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид > Свойства.

Свойство | Описание
Элемент
Тип | Поле для ввода.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Поле для ввода.
Высота Позволяет задать высоту элемента Поле для ввода.
Внимание! Изменение количества строк в элементе Поле для ввода возможно только в случае если выбрано свойство Многострочное поле на закладке Разметка.Изменение высоты знакоместа также производится на закладке Разметка.
Выравнивание
Горизонтальное Позволяет выравнивать текст элемента по горизонтали.
  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.
Вертикальное Позволяет выравнивать текст элемента по вертикали.
  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.
Ориентация Позволяет задать ориентацию текста.
  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.
Разметка
Многострочное поле | Позволяет сделать поле для ввода многострочным.
Тип разметки текста Позволяет выбрать тип разметки текста из списка:
  • Буквы в гребенке;
  • Текст в рамке с гребенкой;
  • Буквы в рамках;
  • Буквы в изолированных рамках;
  • Буквы в изолированных растровых рамках.
Цвет разметки | Позволяет выбрать из списка цвет разметки*.
Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках) | Позволяет выбрать жирную линию разметки текста.
Размер знакоместа Позволяет выбрать предопределенный размер знакоместа из списка.
Для разметки Буквы в гребенке, Текст в рамке с гребенкой и Буквы в рамках:
  • Очень большой - (6,5 х 7,9) мм;
  • Большой - (6,5 х 7,4) мм;
  • Стандартный (по умолчанию) - (5,2 х 5,7) мм;
  • Минимальный - (4,0 х 4,6) мм;
  • Нестандартный - настраивается пользователем.Допустимый диапазон: ширина от 4,2 до 6,7 мм; высота от 4,7 до 8,2 мм. Шаг - 0,1 мм.
Для разметки Буквы в изолированных рамках и Буквы в изолированных растровых рамках:
  • Очень большой - (5,0 х 7,0) мм;
  • Большой - (5,0 х 6,5) мм;
  • Стандартный (по умолчанию) - (4,0 х 5,0) мм;
  • Минимальный - (3,0 х 4,0) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 3,0 до 5,5 мм; высота от 4,0 до 7,5 мм. Шаг - 0,1 мм.
Замечание. Размеры ячеек Очень большой и Нестандартный не совместимы с предыдущими версиями FormDesigner.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Поле для ввода цвет фона формы
Другой | Позволяет выбрать другой цвет фона для элемента Поле для ввода *.
Подсказка
Текст Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле для ввода: каждая буква подсказки в соответствующее знакоместо.
Для элемента типа Поле для ввода имеется возможность добавить разделитель в тексте подсказки. Символу разделителя предшествует символ "&".
Примеры:
  • _ _:_ _ (разделитель для времени) записывается в виде "__&:__";
  • _ _/_ _/_ _ (разделитель для даты) записывается в виде "__&/__&/__";
  • (_ _ _)_ _ _-_ _-_ _ (разделитель для телефонного номера) записывается в виде "&(___&)___&-__&-__".
Разделители всегда отображаются черным цветом, и, таким образом, остаются при сканировании.
В структуре документа поле с разделителями является единым.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.
Ограничения
Не может быть пустым | При выборе данной опции форма не может быть проэкспортирована, пока Числовое поле не заполнено.
Ограничения: Чтобы настроить необходимые ограничения для элемента Поле для ввода, воспользуйтесь следующими кнопками:
  • Новое... - открывает диалоговое окно со списком правил.
    Для создания нового правила дважды щелкните Создать новое правило… в списке Правило - допустимые значения или Правило - регулярное выражение. Откроется соответствующее диалоговое окно.
  • Правка... - открывает диалоговое окно Правило - допустимые значения или Правило - регулярное выражение, в зависимости от выбранного правила.
  • Удалить - удалить выбранное правило.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле для ввода

Для того чтобы удалить элемент Поле для ввода:

  1. Выделите элемент Поле для ввода;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Настройка правил для элемента Поле ввода

Вы можете накладывать ограничения на значения элемента поле ввода при помощи правил.

Чтобы добавить правило, нажмите кнопку Новое… на закладке Ограничения в окне свойств элемента. В открывшемся окне Правила проверки: Выбор определения правила, дважды щелкните мышью по пункту Создать новое правило… в списке Правило - допустимые значения или Правило - регулярное выражение, чтобы создать новое правило для допустимых значений или регулярных выражений. Откроется соответствующий диалог.

Collapsed Показать диалог Правило - допустимые значения

Опция Описание
Переименовать…
Нажмите эту кнопку, чтобы переименовать правило. В открывшемся окне введите новое имя правила и нажмите OK.
Текст
  • Добавить - добавляет введенное значение в список.
  • Удалить - удаляет значение из списка.
Разрешить ввод новых значений
Отметьте эту опцию, если вы хотите разрешить ввод значений не из списка. Если эта опция не отмечена, значения могут выбираться только из списка.
Collapsed Показать диалог Правило - регулярное выражение

Опция | Описание
Переименовать…
Нажмите эту кнопку, чтобы переименовать правило. В открывшемся окне введите новое имя правила и нажмите OK.
Выражение
  • Добавить - добавляет введенное регулярное выражение в список. Смотрите также Алфавит, используемый в регулярных выражениях.
  • Удалить - удаляет выбранное регулярное выражение из списка.
Сообщение об ошибке
Создать автоматически | Если эта опция отмечена, текст сообщения об ошибке формируется автоматически. Чтобы ввести другой текст, снимите галочку в этом поле.


Элемент Поле даты

Поле даты - это элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

Collapsed Показать поле даты

Добавление элемента Поле даты

Редактирование элемента Поле даты

Удаление элемента Поле даты

Настройка правил для элемента Поле даты


Добавление элемента Поле даты

Чтобы добавить на форму элемент Поле даты Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

:

  1. На панели инструментов Элементы формы выберите инструмент Поле даты.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Поле даты будет размещено в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Поле даты

Для каждого элемента Поле даты Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

 задаются свойства: координаты элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, формат даты, количество знакомест для записи года, разделитель, цвет разделителя, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Поле даты можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид > Свойства.

Свойство | Описание
Элемент
Тип | Поле даты.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Указывает ширину элемента Поле даты.
Высота Указывает высоту элемента Поле даты.
Внимание! Изменение высоты знакоместа производится на закладке Разметка.
Выравнивание
Горизонтальное Позволяет выравнивать текст элемента по горизонтали.
  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.
Вертикальное Позволяет выравнивать текст элемента по вертикали.
  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.
Ориентация Позволяет задать ориентацию текста.
  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.
Разметка
Тип разметки текста Позволяет выбрать тип разметки текста из списка:
  • Буквы в гребенке;
  • Текст в рамке с гребенкой;
  • Буквы в рамках;
  • Буквы в изолированных рамках;
  • Буквы в изолированных растровых рамках.
Цвет разметки | Позволяет выбрать из списка цвет разметки*.
Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках) | Позволяет выбрать жирную линию разметки текста.
Размер знакоместа Позволяет выбрать предопределенный размер знакоместа из списка.
Для разметки Буквы в гребенке, Текст в рамке с гребенкой и Буквы в рамках:
  • Очень большой - (6,5 х 7,9) мм;
  • Большой - (6,5 х 7,4) мм;
  • Стандартный (по умолчанию) - (5,2 х 5,7) мм;
  • Минимальный - (4,0 х 4,6) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 4,2 до 6,7 мм; высота от 4,7 до 8,2 мм. Шаг - 0,1 мм.
Для разметки Буквы в изолированных рамках и Буквы в изолированных растовых рамках:
  • Очень большой - (5,0 х 7,0) мм;
  • Большой - (5,0 х 6,5) мм;
  • Стандартный (по умолчанию) - (4,0 х 5,0) мм;
  • Минимальный - (3,0 х 4,0) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 3,0 до 5,5 мм; высота от 4,0 до 7,5 мм. Шаг - 0,1 мм.
Замечание. Размеры ячеек Очень большой и Нестандартный не совместимы с предыдущими версиями FormDesigner.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Поле даты цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента Поле даты *.
Дата
Цифр в годе Позволяет выбрать формат даты:
  • ДД.ММ.ГГГГ
  • ММ.ДД.ГГГГ
  • ГГГГ.ММ.ДД
Формат даты Позволяет выбрать количество знакомест для записи года:
  • 2 (под запись года будет отведено два знакоместа)
  • 4 (под запись года будет отведено два знакоместа)
Разделитель Позволяет выбрать разделитель для записи даты:
  • .
  • /
  • -
Цвет | Позволяет выбрать из списка цвет разделителя*.
Подсказка | Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле даты: каждая буква подсказки в соответствующее знакоместо.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.
Ограничения
Не может быть пустым | При выборе данной опции форма не может быть проэкспортирована, пока Числовое поле не заполнено.
Ограничения: Чтобы настроить необходимые ограничения для Поле даты, воспользуйтесь следующими кнопками:
  • Новое... - открывает диалоговое окно со списком правил.
    Для создания нового правила дважды щелкните Создать новое правило… в списке Интервал дат. В диалоге Правило - интервал дат задайте интервал.
  • Правка... - открывает диалоговое окно Правило - интервал дат, в котором можно добавить или удалить интервал дат для выбранного правила.
  • Удалить - удалить выбранное правило.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле даты

Для того чтобы удалить элемент Поле даты:

  1. Выделите элемент Поле даты;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Настройка правил для элемента Поле даты

Вы можете накладывать ограничения на значения элемента поле даты при помощи правил.

Чтобы добавить правило, нажмите кнопку Новое… на закладке Ограничения в окне свойств элемента. В открывшемся окне Правила проверки: Выбор определения правила, дважды щелкните мышью по пункту Создать новое правило… в списке Интервал дат, чтобы создать новое правило. Откроется диалог Правило - интервал дат.

Collapsed Показать диалог Правило - интервал дат

Опция | Описания
Переименовать…
Нажмите эту кнопку, чтобы переименовать правило. В открывшемся окне введите новое имя правила и нажмите OK.
С ... по
  • Добавить - добавляет указанный временной интервал в список.
  • Удалить - удаляет выбранный интервал из списка.
Сообщение об ошибке
Создать автоматически | Если эта опция отмечена, текст сообщения об ошибке формируется автоматически. Чтобы ввести другой текст, снимите галочку в этом поле.


Элемент Числовое поле

Числовое поле - элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.

Collapsed Показать числовое поле

Добавление элемента Числовое поле

Редактирование элемента Числовое поле

Удаление элемента Числовое поле

Настройка правил для элемента Числовое поле


Добавление элемента Числовое поле

Чтобы добавить на форму элемент Числовое поле Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.

:

  1. На панели инструментов Элементы формы выберите инструмент Числовое поле.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Числовое поле

Для каждого элемента Числовое поле Collapsed

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.

задаются свойства: координаты и размер элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, количество знакомест для записи дробной части десятичного числа, разделитель, цвет разделителя, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Числовое поле можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид > Свойства.

Свойство | Описание
Элемент
Тип | Числовое поле.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Числовое поле.
Высота Указывает высоту элемента Числовое поле.
Внимание! Изменение высоты знакоместа производится на закладке Разметка.
Выравнивание
Горизонтальное Позволяет выравнивать текст элемента по горизонтали.
  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.
Вертикальное Позволяет выравнивать текст элемента по вертикали.
  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.
Ориентация Позволяет задать ориентацию текста.
  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.
Разметка
Тип разметки текста Позволяет выбрать тип разметки текста из списка:
  • Буквы в гребенке;
  • Текст в рамке с гребенкой;
  • Буквы в рамках;
  • Буквы в изолированных рамках;
  • Буквы в изолированных растровых рамках.
Цвет разметки | Позволяет выбрать из списка цвет разметки*.
Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках) | Позволяет выбрать жирную линию разметки текста.
Размер знакоместа Позволяет выбрать предопределенный размер знакоместа из списка.
Для разметки Буквы в гребенке, Текст в рамке с гребенкой и Буквы в рамках:
  • Очень большой - (6,5 х 7,9) мм;
  • Большой - (6,5 х 7,4) мм;
  • Стандартный (по умолчанию) - (5,2 х 5,7) мм;
  • Минимальный - (4,0 х 4,6) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 4,2 до 6,7 мм; высота от 4,7 до 8,2 мм. Шаг - 0,1 мм.
Для разметки Буквы в изолированных рамках и Буквы в изолированных растовых рамках:
  • Очень большой - (5,0 х 7,0) мм;
  • Большой - (5,0 х 6,5) мм;
  • Стандартный (по умолчанию) - (4,0 х 5,0) мм;
  • Минимальный - (3,0 х 4,0) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 3,0 до 5,5 мм; высота от 4,0 до 7,5 мм. Шаг - 0,1 мм.
Замечание. Размеры ячеек Очень большой и Нестандартный не совместимы с предыдущими версиями FormDesigner.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Числовое поле цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента Числовое поле *.
Число
Кол-во знаков после разделителя | Позволяет задать количество знакомест для записи дробной части десятичного числа.
Разделитель | Задает разделитель для записи числа.
Цвет | Позволяет выбрать из списка цвет разделителя*.
Подсказка | Позволяет задать текст подсказки. Подсказка будет напечатана на форме в числовом поле: каждая буква подсказки в соответствующее знакоместо.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.
Ограничения
Не может быть пустым | При выборе данной опции форма не может быть проэкспортирована, пока Числовое поле не заполнено.
Ограничения: Чтобы настроить необходимые ограничения для Числового поля, воспользуйтесь следующими кнопками:
  • Новое... - открывает диалоговое окно со списком правил.
    Для создания нового правила дважды щелкните Создать новое правило… в списке Интервал. В диалоге Правило - интервал задайте ограничение.
  • Edit... - открывает диалоговое окно Правило - интервал, в котором можно добавить или удалить интервал для выбранного правила.
  • Удалить - удалить выбранное правило.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Числовое поле

Для того чтобы удалить элемент Числовое поле:

  1. Выделите элемент Числовое поле;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Настройка правил для элемента Числовое поле

Вы можете накладывать ограничения на значения элемента числовое поле при помощи правил.

Чтобы добавить правило, нажмите кнопку Новое… на закладке Ограничения в окне свойств элемента. В открывшемся окне Правила проверки: Выбор определения правила дважды щелкните мышью по пункту Создать новое правило… в списке Интервал для создания нового правила. Откроется диалоговое окно Правило - интервал.

Collapsed Показать диалог Правило - интервал

Опция | Описание
Переименовать…
Нажмите эту кнопку, чтобы переименовать правило. В открывшемся окне введите новое имя правила и нажмите OK.
Интервал: от ... до
  • Добавить - добавляет указанный интервал в список
  • Удалить - удаляет выбранный интервал из списка.
Сообщение об ошибке
Создать автоматически | Если эта опция отмечена, текст сообщения об ошибке формируется автоматически. Чтобы ввести другой текст, снимите галочку в этом поле.


Элемент Поле метки

Поле метки - элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

Добавление элемента Поле метки

Редактирование элемента Поле метки

Удаление элемента Поле метки


Добавление элемента Поле метки

Чтобы добавить на форму элемент Поле метки Collapsed

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

 :

  1. На панели инструментов Элементы формы выберите инструмент Поле метки.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Поле метки

Для каждого элемента Поле метки Collapsed

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

задаются свойства: координаты и размер элемента, тип ограничителя поля метки, расположение текста, размер поля метки, толщина линии ограничителя поля метки, расстояние до текста, текст, цвет текста, шрифт, перенос слов, цвет линии ограничителя, цвет фона элемента, связанное поле

Свойства элемента Поле метки можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Пояснительный текст метки можно также редактировать, щелкнув два раза в области текста.

Свойство | Описание
Элемент
Тип | Поле метки.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Поле метки.
Высота | Позволяет задать высоту элемента Поле метки.
Текст
Текст | Позволяет редактировать пояснительный текст к полю метки.
Шрифт Позволяет редактировать шрифт для набора пояснительного текста.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить… В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.
Цвет | Позволяет выбрать из списка цвет текста*.
Переносить по словам | Позволяет переносить пояснительный текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.
Поле метки
Тип Позволяет выбрать тип ограничителя поля метки:
  • Квадрат
  • Круг
Расположение Позволяет выбрать расположение поля метки относительно текста (пояснительной информации):
  • Метка слева - поле метки располагается слева от текста
  • Метка справа - поле метки располагается справа от текста
  • Метка сверху - поле метки располагается сверху от текста
  • Метка снизу - поле метки располагается снизу от текста
Размер | Позволяет выбрать предопределенный размер элемента Поле метки из списка (3,5х3,5 4х4 4,5х4,5 5х5 мм).
Толщина линии | Позволяет задать толщину линии ограничителя элемента Поле метки (от 0,4 мм до 0,8 мм).
Расстояние до текста | Позволяет задать расстояние от поля метки до текста пояснительной информации (от 2 мм до 7 мм).
Цвет | Позволяет выбрать из списка цвет линии ограничителя*.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Поле метки цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента Поле метки *.
Подсказка
Текст | Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле для ответа.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле метки

Для того, чтобы удалить элемент Поле метки:

  1. Выделите элемент Поле метки;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Группа меток

Группа меток - элемент машиночитаемой формы, объединяющий несколько полей меток в группу. Группа меток представляет собой таблицу, состоящую из текстового поля (вопросы) и нескольких полей меток (ответы). С помощью Мастера создания группы меток вы можете создать группу меток выбранного типа (Матрица, Таблица или Список) и указать ее свойства.

Добавление элемента Группа меток

Редактирование элемента Группа меток

Удаление элемента Группа меток


Добавление элемента Группа меток

Для добавления на форму элемента Группа меток используется Мастер создания группы меток. Чтобы открыть Мастер создания группы меток, на панели инструментов Элементы формы выберите инструмент Группа меток и щелкните мышью на форме. Появится окно Мастера создания группы меток.

Создание группы меток состоит из двух шагов.

На первом шаге укажите следующие опции в окне Тип:

  1. Выберите тип группы меток: Матрица, Таблица или Список.
    Замечание. При импорте описания формы в ABBYY FlexiCapture элементы Группа меток типа Матрица и Таблица конвертируются в табличные элементы, столбцы которых имеют тип Метка.
  2. Среди изображений справа выберите группу меток нужного типа. Группы меток различаются расположением вопросов и подписей относительно меток. Желтые прямоугольники показывают расположение вопросов, синие прямоугольники обозначают подписи.
  3. Выберите тип меток: Квадрат или Круг.
  4. Нажмите Далее.

Появится окно Вопросы и ответы. Вид этого окна зависит от типа группы меток, выбранного на предыдущем шаге.

Для типов Матрица и Таблица доступны следующие опции:

  • Число вопросов
  • Текст вопросов
    Отметьте опцию Добавить номер для нумерации вопросов.
  • Число ответов
  • Вид ответов
    Если выбрана опция Списком, вы можете указать варианты ответов (все или несколько). Введите список ответов, разделяя значения точкой с запятой.
    Если выбрана опция Текст, вы можете изменить текст подписи.
  • Отметьте опцию Добавить номер, находящуюся под полем Текст, для нумерации ответов.
    При задании списком будут пронумерованы только те варианты ответов, значения которых не заданы.

Для типа Список доступны следующие опции:

  • Текст вопросов
    Отметьте опцию Добавить номер для нумерации вопросов.
  • Текст ответов
    Отметьте опцию Добавить номер для нумерации ответов.
  • Для каждого вопроса укажите число ответов и число колонок, в которых будут расположены ответы.
    Для этого дважды щелкните по соответствующей ячейке и введите нужное значение или используйте окошко счетчика для увеличения/уменьшения значения.
  • Для добавления вопроса нажмите Добавить.
  • Чтобы удалить выбранный вопрос, нажмите кнопку Удалить.

Для возвращения к предыдущему шагу нажмите Назад.

Если все опции выбраны, нажмите Готово. Созданная группа меток появится на форме.

Вы можете изменить расположение элемента на форме, перетащив его в другое место с помощью левой клавиши мыши.


Редактирование элемента Группа меток

Для каждого элемента Группа меток свойства задаются как для самого элемента, так и для отдельных полей элемента.

Группа меток представляет собой таблицу и имеет аналогичный свойства: координаты и размер элемента, толщина, стиль и цвет линий, цвет фона, расстояние между ячейками, является ли первая строка заголовком, связанное поле. Подробнее смотрите Редактирование элемента Таблица.

Поле Вопросы является текстовым полем и имеет такие же свойства: координаты и размеры элемента, текст, шрифт, перенос по словам, цвет текста, горизонтальное и вертикальное выравнивание, ориентацию, цвет фона элемента. Подробнее смотрите Редактирование элемента Текст.

Поле Ответы представляет собой поле метки и имеет такие же свойства: координаты и размер элемента, тип ограничителя поля метки, расположение текста, размер поля метки, толщина линии ограничителя поля метки, расстояние до текста, текст, цвет текста, шрифт, перенос слов, цвет линии ограничителя, цвет фона элемента, подсказка, связанное поле. Подробнее смотрите Редактирование элемента Поле метки.

Свойства группы меток или выбранного элемента группы меток можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.


Удаление элемента Группа меток

Для того, чтобы удалить элемент Группа меток:

  1. Выделите элемент Группа меток;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Разделитель

Разделитель - это элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Добавление элемента Разделитель

Редактирование элемента Разделитель

Удаление элемента Разделитель


Добавление элемента Разделитель

Чтобы добавить на форму элемент Разделитель Collapsed

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

:

  1. На панели инструментов Элементы формы выберите инструмент Разделитель.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемой длины элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. По умолчанию будет создан горизонтальный разделитель, а при нажатой клавише Shift - вертикальный. Размеры элемента определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Разделитель

Для каждого элемента Разделитель Collapsed

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

 задаются свойства: координаты и размер элемента, тип линии разделителя, толщина и цвет линии разделителя.

Свойства элемента Разделитель можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Разделитель.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Разделитель (только для горизонтальных разделителей).
Высота | Позволяет задать высоту элемента Разделитель (только для вертикальных разделителей).
Линия
Толщина | Позволяет задать толщину линии разделителя (от 0.1 мм до 2,5 мм).
Стиль Позволяет выбрать стиль для линии разделителя:
  • Пунктир
  • Сплошная
  • Точки
Цвет Позволяет выбрать цвет разделителя.
Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная). Для черно-белых форм цвет разделителя - черный.


Удаление элемента Разделитель

Для того, чтобы удалить элемент Разделитель:

  1. Выделите элемент Разделитель;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Прямоугольник

Вы находитесь здесь: Работа с программой ABBYY FormDesigner > Добавление, удаление и редактирование элементов формы > Элемент Прямоугольник

Элемент Рамка

Рамка - элемент машиночитаемой формы, ограничивающий некоторую область формы.

Collapsed Показать прямоугольник

Добавление элемента Рамка

Редактирование элемента Рамка

Удаление элемента Рамка


Добавление элемента Прямоугольник

Вы находитесь здесь: Работа с программой ABBYY FormDesigner > Добавление, удаление и редактирование элементов формы > Элемент Прямоугольник > Добавление элемента Прямоугольник

Добавление элемента Рамка

Чтобы добавить на форму элемент Рамка Collapsed

Элемент машиночитаемой формы, ограничивающий некоторую область формы.

 :

  1. На панели инструментов Элементы формы выберите инструмент Рамка.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Прямоугольник

Вы находитесь здесь: Работа с программой ABBYY FormDesigner > Добавление, удаление и редактирование элементов формы > Элемент Прямоугольник > Редактирование элемента Прямоугольник

Редактирование элемента Рамка

Для каждого элемента Рамка Collapsed

Элемент машиночитаемой формы, ограничивающий некоторую область формы.

 задаются свойства: координаты и размеры элемента, толщина, стиль и цвет линии, углы, цвет фона.

Свойства элемента Рамка можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Рамка.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Рамка.
Высота | Позволяет задать высоту элемента Рамка.
Линия
Толщина | Позволяет задать толщину линии рамки (от 0,1мм до 2,5мм).
Стиль Позволяет выбрать стиль для линии рамки:
  • Пунктир
  • Сплошная
  • Точки
Цвет Позволяет выбрать цвет рамки.
Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная).
Углы Выберите тип углов:
  • Прямой угол
  • Инвертированный прямой угол
  • Скругленный угол
  • Инвертированный скругленный угол
Для всех типов углов, кроме прямого угла, можно указать радиус угла (в мм).
Фон*
Цвет фона формы* | Позволяет выбрать в качестве цвета фона для элемента Рамка цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента Рамка *.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная).


Удаление элемента Прямоугольник

Вы находитесь здесь: Работа с программой ABBYY FormDesigner > Добавление, удаление и редактирование элементов формы > Элемент Прямоугольник > Удаление элемента Прямоугольник

Удаление элемента Рамка

Для того чтобы удалить элемент Рамка:

  1. Выделите элемент Прямоугольник;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Картинка

Картинка - элемент машиночитаемой формы, представляющий собой графическое изображение.

Добавление элемента Картинка

Редактирование элемента Картинка

Удаление элемента Картинка


Добавление элемента Картинка

Чтобы добавить на форму элемент Картинка Collapsed

Элемент машиночитаемой формы, представляющий собой графическое изображение.

:

  1. На панели инструментов Элементы формы выберите инструмент Картинка.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента и отпустите мышь. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  3. В открывшемся диалоге Открыть (Open) укажите графический файл, из которого будет добавлено изображение.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Картинка

Для каждого элемента Картинка Collapsed

Элемент машиночитаемой формы, представляющий собой графическое изображение.

 задаются свойства: координаты и размеры элемента, режим изменения размера, выравнивание, файл, цвет фона элемента.

Свойства элемента Картинка можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Картинка.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Картинка.
Высота | Позволяет задать высоту элемента Картинка.
Картинка
Изменение размера Позволяет изменять размер элемента в нескольких режимах:
  • Исходный размер - режим изменения размера элемента, при котором размер и пропорции изображения не меняются.
    В данном режиме невозможно увеличить исходный размер изображения.
    Если размер элемента стал меньше, чем размер изображения, то часть изображения не будет видна на форме.
  • Растягивание - режим изменения размера элемента, при котором изображение сжимается или растягивается в зависимости от размера элемента. Видно все изображение.
  • Масштабирование - режим изменения размера элемента, при котором изображение масштабируется (уменьшается или увеличивается) пропорционально размерам элемента. Видно все изображение.
Выравнивание Позволяет выровнять изображение внутри разметки элемента.
  • Слева вверху - позволяет поместить изображение в левый верхний угол разметки элемента.
  • Справа вверху - позволяет поместить изображение в правый верхний угол разметки элемента.
  • В центре - позволяет поместить изображение в центр разметки элемента.
  • Слева внизу - позволяет поместить изображение в левый нижний угол разметки элемента.
  • Справа внизу - позволяет поместить изображение в правый нижний угол разметки элемента.
Файл Позволяет указать файл с изображением.
Для того, чтобы указать файл с изображением:
  1. нажмите кнопку Обзор…;
  2. в открывшемся диалоге укажите путь к файлу с изображением.
Поддерживаются следующие форматы изображений:
  • Bitmap (*.bmp)
  • DCX (*.dcx)
  • DJVU (*. djvu)
  • GIF (*. gif)
  • JBIG2 (*. jbig2)
  • JPEG (*.jpg; *.jpeg; *.jfif)
  • JPEG-2000 (*.jp2; *.j2c)
  • PCX (*.pcx)
  • PNG (*.png)
  • TIFF (*.tif; *.tiff)
  • PDF (*.pdf)
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Картинка цвет фона формы
Другой Позволяет выбрать другой цвет фона для элемента Картинка.
Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная).


Удаление элемента Картинка

Для того чтобы удалить элемент Картинка:

  1. Выделите элемент Картинка;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Идентификатор

Идентификатор - элемент машиночитаемой формы, однозначно характеризующий данную форму, либо одну из ее страниц.

Рекомендуется добавлять на форму элемент Идентификатор. Это необходимо для того, чтобы в процессе распознавания можно было безошибочно идентифицировать формы одного образца.

Элемент Идентификатор может быть либо идентификатором формы, тогда он будет идентифицировать всю форму, либо идентификатором страницы, тогда он будет идентифицировать страницу, на которой он расположен. Кроме того, можно задать пользовательское значение идентификатора.

С помощью программы ABBYY FormDesigner можно создать идентификаторы следующих типов: штрих-код, штрих-код с цифрами, цифры. Все они являются вариантами представления 13-ти значного уникального номера - значения идентификатора, которое присваивается форме при публикации. До публикации на форме поверх элемента Идентификатор будет написано "Проект формы".

Для типов Штрих-код и Штрих-код с цифрами можно задать пользовательское значение идентификатора, выбрав тип штрих-кода (EAN13 или EAN8).

Тип идентификатора | Описание
Штрих-код | Тип идентификатора, представляющий собой штрих-код.
Штрих-код с цифрами | Тип идентификатора, представляющий собой штрих-код с последовательностью цифр, расположенной под (или над) штриховыми знаками.
Цифры 1236489271602 | Тип идентификатора, представляющий собой последовательность из 13 цифр.

Добавление элемента Идентификатор

Редактирование элемента Идентификатор

Удаление элемента Идентификатор


Добавление элемента Идентификатор

Чтобы добавить на форму элемент Идентификатор Collapsed

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

 :

  1. На панели инструментов Элементы формы выберите инструмент Идентификатор.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Идентификатор будет размещен в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Идентификатор

Стандартный размер идентификатора - 46 х 12 мм.

Для каждого элемента Идентификатор Collapsed

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

 задаются свойства: координаты и размер элемента, тип, ориентация и значение.

Свойства элемента Идентификатор не зависят от вида формы.

Свойства элемента Идентификатор можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Идентификатор.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Указывает ширину элемента Идентификатор.
Высота | Указывает высоту элемента Идентификатор.
Идентификатор
Тип Позволяет выбрать тип Идентификатора:
  • Штрих-код
  • Штрих-код с цифрами
  • Цифры
Тип штрих-кода Позволяет выбрать тип штрих-кода, если тип идентификатора Штрих-код или Штрих-код с цифрами и если отмечена опция Пользовательское значение.
Штрих-код может относится к одному из типов:
  • EAN13
  • EAN8
Если не отмечена опция Пользовательское значение, то поле Тип штрих-кода недоступно для редактирования. Тип штрих-кода в этом случае - EAN13.
Ориентация Позволяет задать ориентацию штрих-кода:
  • Вертикальная
  • Горизонтальная
Значение Указывается значение идентификатора.
Значение идентификатора может быть введено пользователем, только если выбрана опция Пользовательское значение. Для EAN13 пользовательское значение должно содержать 12 цифр, для EAN8 - 7 цифр. Неправильная длина или символы, отличные от цифр, недопустимы. Для EAN13 дополнительная контрольная цифра добавляется в начале строки цифр (вне штрих-кода), для EAN8 - в конце строки, в теле штрих-кода.
Если выбрана одна из опций Идентификатор формы или Идентификатор страницы, значение идентификатору присваивается автоматически во время публикации формы. До публикации формы она имеет статус Редактируемая и уникальное значение идентификатору ещё не присвоено.
Идентификатор формы | Позволяет использовать элемент в качестве идентификатора формы.
Идентификатор страницы | Позволяет использовать элемент в качестве идентификатора текущей страницы.

Пользовательское значение

Позволяет задать пользовательское значение идентификатора. Опция недоступна, если задан тип идентификатора Цифры.


Удаление элемента Идентификатор

Для того чтобы удалить элемент Идентификатор:

  1. Выделите элемент Идентификатор;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Таблица

Таблица - элемент машиночитаемой формы. Таблица содержит столбцы с однотипными элементами.

Столбцы таблицы могут содержать элементы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.

Таблица может содержать строку с заголовками столбцов.

В структуре документа поле типа таблица содержит дочерние поля. Каждому дочернему полю соответствует столбец элемента Таблица.

Добавление элемента Таблица

Редактирование элемента Таблица

Удаление элемента Таблица


Добавление элемента Таблица

Чтобы добавить на форму элемент Таблица Collapsed

Элемент машиночитаемой формы содержащий столбцы с однотипными элементами, например, с полями для ввода текста или с метками. Может содержать строку с заголовками столбцов.

 :

  1. На панели инструментов Элементы формы выберите инструмент Таблица.
  2. Щелкните мышью на том месте формы, где вы хотите разместить таблицу, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.
  3. В открывшемся диалоге определите вид таблицы.
    • Отметьте опцию Использовать первую строку как заголовок, если вы хотите использовать первую строку в качестве заголовка;
    • Задайте название и тип данных для колонок таблицы. Для этого в таблице, расположенной в центральной части диалога, введите названия и типы данных вместо определенных по умолчанию. Вы можете добавить любое количество столбцов;
    • Введите количество строк таблицы в поле Количество строк.

Добавление разделителей

Если на форме есть таблица, то кнопки панели инструментов для добавления и удаления разделителей становятся активными. С помощью этих кнопок вы сможете добавлять и удалять разделители таблицы, тем самым изменяя количество строк и столбцов.

При выбранном инструменте Добавить разделитель доступны следующие возможности:

  • Если щелкнуть мышью внутри таблицы, будет создан разделитель;
  • Если навести курсор на уже существующий разделитель, то его можно переместить. Если навести курсор на пересечение разделителей, то можно переместить сразу два разделителя.
  • Нажав клавишу Ctrl и наведя курсор на существующий разделитель, можно его удалить.
  • Нажав клавишу Shift, можно изменить тип создаваемого разделителя (горизонтальный вместо вертикального и наоборот).

Создание столбцов

Столбцы таблицы могут быть заполнены только элементами одного типа. Чтобы заполнить столбцы таблицы, выберите нужный элемент на панели инструментов и щелкните в области столбца. В каждой ячейке столбца будет нарисован элемент выбранного типа.

Можно создать столбцы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.


Редактирование элемента Таблица

Для каждого элемента Таблица Collapsed

Элемент машиночитаемой формы содержащий столбцы с однотипными элементами, например, с полями для ввода текста или с метками. Может содержать строку с заголовками столбцов.

 задаются свойства: координаты и размер элемента, толщина, стиль и цвет линий, цвет фона, расстояние между ячейками, является ли первая строка заголовком, связанное поле.

Свойства элемента Таблица можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Таблица.
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Таблица.
Высота | Позволяет задать высоту элемента Таблица.

Линия

Толщина | Позволяет задать толщину линии ограничителя (от 0,1мм до 2,5мм).
Стиль Позволяет выбрать стиль для линий:
  • Пунктир
  • Сплошная
  • Точки
Цвет | Позволяет выбрать из списка цвет линий таблицы*.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для элемента Таблица цвет фона формы.
Другой | Позволяет выбрать другой цвет фона таблицы*.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.
Таблица
Расстояние между ячейками | Позволяет задать расстояние между ячейками таблицы.
Использовать первую строку как заголовок | Если эта опция отмечена, то первая строка будет использоваться в качестве заголовков столбцов таблицы.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная).


Удаление элемента Таблица

Для того, чтобы удалить элемент Таблица:

  1. Выделите элемент Таблица;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Группа элементов

Группа элементов - элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов. Группа элементов используется для объединения логически связанных элементов.

Объединение элементов в группу производится также для быстрого копирования этих элементов с сохранением всех свойств. Использовать группы элементов целесообразно, например, в случае, если на форме нужно создать несколько поданкет с одинаковым набором полей.

Допускается вложенная структура групп элементов.

Добавление Группы элементов

Редактирование Группы элементов

Удаление Группы элементов


Добавление Группы элементов

Чтобы добавить на форму Группу элементов Collapsed

Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов.

 :

  1. На панели инструментов Элементы формы выберите инструмент Группа элементов.
  2. Щелкните мышью на том месте формы, где вы хотите разместить группу, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

Добавление элементов в группу

Элементы можно добавить в группу тремя способами:

  1. Создайте элементы, которые должны войти в группу. Выберите инструмент Группа элементов и с помощью мыши обведите созданные элементы прямоугольником. Элементы формы, полностью оказавшиеся внутри прямоугольника, будут входить в группу.
  2. Создайте группу с помощью инструмента Группа элементов. Создайте элементы внутри области группы.
  3. Создайте группу с помощью инструмента Группа элементов. С помощью мыши перетащите нужные элементы формы внутрь группы.

Для того чтобы скопировать группу со всеми ее элементами, выделите группу так, чтобы были выделены все элементы группы. Тогда при копировании группы будут скопированы все элементы с сохранением их свойств.


Редактирование Группы элементов

Для каждой Группы элементов Collapsed

Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов.

 задаются свойства: координаты, размер, тип линий, цвет фона, связанное поле.

Свойства Группы элементов можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство | Описание
Элемент
Тип | Группа элементов
ID | Уникальный идентификатор элемента.
Группа Координаты и размеры
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Позволяет задать ширину элемента Группа элементов.
Высота | Позволяет задать высоту элемента Группа элементов.
Текст
Текст | Позволяет редактировать пояснительный текст к группе элементов.
Шрифт Позволяет редактировать шрифт для набора пояснительного текста.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить… В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.
Цвет | Позволяет выбрать из списка цвет текста*.
Переносить по словам | Позволяет переносить пояснительный текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.
Линия
Толщина | Позволяет задать толщину линии ограничителя (от 0,1мм до 2,5мм).
Стиль Позволяет выбрать стиль для линий:
  • Пунктир
  • Сплошная
  • Точки
Цвет | Позволяет выбрать из списка цвет линий ограничителя группы*.
Фон
Цвет фона формы | Позволяет выбрать в качестве цвета фона для Группы элементов цвет фона формы.
Другой | Позволяет выбрать другой цвет фона группы*.
Связанное поле
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление Группы элементов

Для того, чтобы удалить Группу элементов:

  1. Выделите Группу элементов;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).

Внимание! Если при выполнении команды удаления выделены элементы группы, то группа элементов удаляется вместе с ними. Чтобы удалить группу, но оставить все элементы, следите, чтобы при выполнении команды была выделена только сама группа.


Ограничения

Вы можете накладывать ограничения на значения полей, которые могут вводиться при заполнении формы. Ограничения наклыдываются с помощью правил. В правилах вы можете указать список допустимых значений, регулярных выражений, а также числовые и временные интервалы.

Ограничения задаются на закладке Ограничения свойств элемента.

Вы можете установить ограничения для следующих элементов:

  • Поле для ввода
  • Поле даты
  • Числовое поле


Изменение размера элемента формы

Изменение размера элемента формы возможно по направлениям, соответствующим зеленым квадратам границы элемента, которые видны при выделении элемента на форме.

Изменение размера возможно не для всех элементов, например, размер репера можно изменить только в диалоге Свойства на закладке Репер. Если изменение размера элемента возможно, то при выделении элемента на его сторонах появляются зеленые квадраты, если нет - белые.

Для того чтобы изменить размер элемента формы:

  1. Выделите элемент формы.
  2. Установите курсор на зеленый квадрат границы элемента, соответствующую выбранному направлению изменения размера; изображение курсора изменится на стрелочки специального вида.
  3. Щелкните на зеленом квадрате левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Возможно симметрично изменять размеры элемента, т.е. размеры элемента будут симметрично изменяться в выбранном направлении и направлении, противоположном выбранному.

Для того чтобы симметрично изменить размер элемента формы :

  1. Выделите элемент формы.
  2. Нажмите на клавиатуре и удерживайте кнопку Ctrl.
  3. Установите курсор на нужный зеленый квадрат границы элемента; изображение курсора изменится на стрелочки специального вида.
  4. Щелкните на зеленом квадрате левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Можно изменять размер элементов с помощью привязки двух сторон элемента к параллельным линейкам. Привязав к двум параллельным линейкам две стороны нескольких элементов, можно изменять горизонтальный или вертикальный размер сразу нескольких элементов. Таким образом вы можете изменять размер сразу нескольких элементов одинаковой высоты или ширины, при этом высота или ширина этих элементов останется равной.

Для того чтобы изменить размер элементов с помощью линеек:

  1. Создайте две параллельные линейки с помощью инструментов [image] или [image].
  2. Переместите линейки или элементы таким образом, чтобы противоположные стороны элементов были совмещены с линейками. При этом стороны элементов будут привязаны к линейкам.
  3. Щелкните на одной из линеек и, не отпуская кнопку мыши, переместите ее. Размер всех элементов, привязанных к параллельным линейкам, будет изменяться одновременно с перемещением линейки.

Замечание. Размер элемента Поле для ввода по вертикали можно менять только если в свойствах элемента отмечена опция Многострочное поле.


Изменение фона элемента формы

В программе существует возможность изменить цвет отдельных элементов формы, в то время как все остальные элементы формы останутся черно-белыми.

Замечание. Устанавливать и изменять цвет фона можно только для следующих элементов формы:

  • Текст
  • Поле для ввода
  • Поле даты
  • Поле метки
  • Числовое поле
  • Картинка
  • Прямоугольник
  • Таблица
  • Группа элементов
  • Группа меток

Для того чтобы изменить цвет отдельных элементов формы:

  1. Измените вид формы на цветную на закладке Макет диалога Свойства страницы (меню Форма>Свойства страницы…);
  2. Измените цвет нужных элементов формы. Для этого:
    1. Выделите нужные элементы формы;
    2. В диалоге Свойства… в правом нижнем углу перейдите на закладку Фон;
    3. Отмените выбор опции Цвет фона формы и щелкните по полю Другой;
    4. Выберите на палитре требуемый цвет.

Замечание. Печатать цветные формы не рекомендуется.


Изменение шрифта элемента формы

Отредактировать текст можно с помощью диалога Шрифт (для этого выберите Шрифт в локальном меню элемента).

Редактирование шрифта доступно для следующих элементов: Поле метки, Поле группы и Текст.

Collapsed Показать диалог Шрифт

Свойство | Описание
Закладка Шрифт
Шрифт | Позволяет выбрать шрифт выделенного текста из списка.
Стиль Позволяет выбрать стиль написания выделенного текста:
  • нормальный,
  • курсив,
  • полужирный,
  • полужирный курсив.
Размер | Позволяет указать размер выделенного текста.
Цвет | Позволяет выбрать из списка цвет текста*.
Эффекты | Позволяет выбрать способы выделения текста - подчеркнутый или зачеркнутый.
Закладка Интервал
Масштаб | Позволяет изменить текущий масштаб выделенного текста.
Интервал | Позволяет увеличить или уменьшить интервалы между буквами в выделенном тексте (растянуть или сжать текст).
Расположение | Позволяет выбрать расположение выделенной части текста: нормальное, выше остального текста, ниже остального текста.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Выделение и перемещение элементов формы

Прежде чем редактировать или перемещать элемент формы, его необходимо выделить.

Для того чтобы выделить элемент формы:

  1. Выберите на панели инструментов Элементы формы инструмент Инструмент выбора.
  2. Щелкните на нужном элементе формы.

Для того чтобы переместить элемент формы:

  1. Выделите элемент формы.
  2. Установите курсор внутри элемента; изображение курсора изменится на [image].
  3. Щелкните на элементе левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Для того чтобы одинаково переместить несколько элементов одновременно, необходимо:

  1. Выделить элементы (выберите инструмент Инструмент выбора и, удерживая клавишу Shift, последовательно щелкните мышью на всех необходимых элементах).
  2. Установите курсор внутри одного из выделенных элементов; изображение курсора изменится на [image].
  3. Щелкните на элементе левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

При создании поле ввода (текстовое, числовое, поле даты) связывается со своим заголовком. При перемещении такого поля его заголовок перемещается вместе с ним.

При перемещении элементов с нажатой клавишей Ctrl создается копия элемента (или нескольких элементов).

Для того чтобы выделить элементы, входящие в группу элементов, щелкните левой кнопкой мыши внутри контура группы. При перемещении группы элементов, будут перемещены все элементы, входящие в нее.

Для выделенных элементов формы возможен просмотр и редактирование общих свойств.

Объединение элементов формы

Выравнивание элементов с помощью линеек


Объединение элементов формы

Объединение элементов формы помогает сохранить взаимное расположение элементов относительно друг друга при перемещении элементов.

Чтобы объединить несколько элементов:

  1. Выделите элементы формы, которые вы хотите объединить;
  2. Выберите инструмент Объединить на панели Редактирование.

Чтобы разъединить элементы:

  1. Выделите объединенные элементы формы;
  2. Выберите инструмент Разъединить на панели Редактирование.

Чтобы добавить элемент к ранее объединенным:

  1. Выделите объединенные элементы;
  2. Нажмите клавишу Shift, и, удерживая ее, выделите элемент, который необходимо добавить к ранее объединенным;
  3. Выберите инструмент Добавить к объединенным на панели Редактирование.


Выравнивание элементов с помощью линеек

Линейки являются удобным графическим инструментом для выравнивания элементов формы. Элементы, которые должны находиться на одном уровне (вертикальном или горизонтальном) "привязываются" к соответствующей линейке. При перемещениях линейки все привязанные элементы перемещаются вместе с ней. Это избавляет от необходимости каждый раз вручную выделять все элементы, которые должны быть перемещены вместе.

Можно привязать две стороны элемента к двум параллельным линейкам, тогда при перемещении линеек будет изменяться размер элемента. Привязав две стороны нескольких элементов к двум линейкам, можно изменять горизонтальный или вертикальный размер сразу нескольких элементов.

Добавление линеек

Для того чтобы добавить линейки на страницу выполните одно из следующих действий:

  • Щелкните левой кнопкой мыши на одной из основных линеек, расположенных по краям формы. При клике на горизонтальной линейке будет добавлена вертикальная линейка и наоборот.
  • Выберите инструмент [image] для добавления горизонтальной линейки или [image] для добавления вертикальной линейки. Щелкните мышью в том месте страницы, куда нужно добавить линейку.

Привязка элементов к линейкам

Чтобы привязать элемент к линейке, нужно совместить одну из границ элемента с линейкой. Это можно сделать перемещая линейку, элемент или изменяя размер элемента.

Если включен режим автоматической привязки линеек к элементам ( [image]), то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки. По умолчанию, этот режим выключен.

При выделении линейки все привязанные к ней элементы также выделяются с помощью рамки того же цвета, что и линейка. При выделении объекта, привязанного к какой-либо линейке, квадрат в середине стороны, привязанной к линейке, окрашивается в красный цвет. Таким образом, всегда можно понять, к каким линейкам привязан выделенный элемент и какие элементы привязаны к выделенной линейке.

Перемещение линеек и элементов

Добавленные линейки можно перемещать по форме, нажав и удерживая кнопку мыши. Две линейки, оказавшиеся на одном и том же месте, сливаются в одну.

При перемещении линейки вместе с ней перемещаются все привязанные к ней элементы. У элементов, привязанных к двум параллельным линейкам, при перемещении одной из линеек изменяется размер (если изменение размера для этого элемента возможно).

Разрыв связи элемента с линейкой

Для того чтобы разорвать связь элемента с линейкой, достаточно выделить элемент и переместить его.

Удаление линеек

Для удаления линейки ее необходимо выделить и нажать клавишу Delete или выбрать команду Удалить в меню.


Сохранение и публикация формы. Проверка формы на машиночитаемость

Разработка формы предполагает несколько этапов, среди которых есть непосредственно создание формы, согласование, внесение изменений и т.д. Для сохранения промежуточных результатов разработки формы рекомендуется использовать стандартную команду сохранения.

После согласования и утверждения окончательного варианта разработанной формы рекомендуется опубликовывать форму, т.е. присваивать форме статус, не позволяющий вносить в форму никаких изменений. Это поможет избежать различных "окончательных" версий одной и той же формы.

Проверка формы на машиночитаемость

Публикация

Сохранение


Сохранение

Для сохранения изменений в форме воспользуйтесь командами Сохранить или Сохранить как… в меню Файл. Команда Сохранить (или Сохранить как…) - стандартная команда, позволяющая сохранить изменения, внесенные в файл.

Команда Сохранить как… позволяет сохранить как форму, так и образец формы или страницы формы. Для выбора формата используется выпадающий список поля Тип файла (Save as type).

Формы, созданные в программе ABBYY FormDesigner, сохраняются с расширением fdd (Form Definition Files).

Образец формы сохраняется в двоичном файле с расширением dtf, а страницы - с расширением ptf, в формате, представляющем собой модифицированный формат fdd-файла.


Проверка формы на машиночитаемость

Проверка формы на машиночитаемость запускается автоматически при публикации или вручную в любой момент разработки формы (меню Сервис>Проверить форму).

Если в ходе проверки ошибки не обнаружены, то на экран выводится сообщение о том, что проверка прошла успешно.

Если же в ходе поверки формы были обнаружены ошибки, то по окончанию проверки формы результаты проверки отобразятся в нижней части окна.

Отчет о проверке включает в себя все найденные программой несоответствия формы требованиям машиночитаемости: отсутствие реперов, отсутствие идентификатора, нарушение расстояний между элементами, неправильные отступы формы и т.д. Каждой строке соответствует ошибка.

Кнопка | Описание
Показать элементы | Позволяет показать элемент, не соответствующий требованиям машиночитаемости. Кнопка становится доступной при щелчке мышью по одной из строк отчета.
Проверить форму | Позволяет повторно запустить проверку формы на машиночитаемость.
Сохранить отчет… | Позволяет сохранить отчет о результатах проверки в *.TXT файл.


Публикация

Публикация формы - это процесс, при котором форме присваивается статус Опубликованная, не позволяющий вносить в форму изменения. Во время публикации автоматически запускается проверка формы на машиночитаемость, элементам Идентификатор Collapsed

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

 присваивается уникальное значение (одно для всех), а статус формы меняется с Редактируемая на Опубликованная. Опубликованные формы доступны только для просмотра.

Для того чтобы опубликовать форму, воспользуйтесь командой Опубликовать (меню Файл).

Публикация с предупреждением

Если при публикации формы были обнаружены несоответствия формы требованиям машиночитаемости (предупреждения), то открывается диалог Публикация с предупреждением, с помощью которого возможно исправить найденные несоответствия или опубликовать форму, несмотря на наличие предупреждений.

Внимание! Использование формы, несоответствующей требованиям машиночитаемости, может значительно снизить качество распознавания!

В диалоге Публикация с предупреждением содержится отчет, включающий в себя все найденные программой несоответствия формы требованиям машиночитаемости.

Кнопка | Описание
Опубликовать | Позволяет опубликовать форму, несмотря на наличие несоответствий формы требованиям машиночитаемости.
Редактировать | В нижней части окна появляется отчет о результатах проверки формы, с помощью которого возможно исправить найденные несоответствия формы требованиям машиночитаемости.

Редактирование опубликованной формы

Для того чтобы внести изменения в опубликованную форму, воспользуйтесь командой Сохранить редактируемую копию как… (меню Файл). При этом вам сначала будет предложено сохранить форму под другим именем, а потом вносить изменения. Статус формы с новым именем поменяется с Опубликованная на Редактируемая, значение элементов Идентификатор обнулится

Совет. Рекомендуется публиковать форму после окончания разработки. Это поможет отслеживать внесение изменений в форму и избежать несогласованности версий во время тиражирования формы.


Экспорт формы

После того как форма была разработана, она может быть экспортирована в различные графические форматы, в изображения с цветоделением, специальный формат XML Form Definition, форму PDF, форму InfoPath, файл Adobe Illustrator для последующей обработки в соответствующих приложениях.

Некоторые виды экспортирования доступны только для опубликованных форм.

Экспорт в графические форматы может понадобиться при передаче формы в типографию.

Экспорт в формат XML Form Definition позволяет получить файл описания, на основе которого в программе ABBYY FlexiCapture будет создано определение документа.

Экспорт в Файл изображения…

Экспорт в Изображения с цветоделением…

Экспорт в XML Form Definition… (*.xfd)

Экспорт в Форму PDF…

Экспорт в Форму InfoPath…

Экспорт в Файл Adobe Illustrator…


Экспорт в Файл изображения

Экспорт формы в файл изображения возможен в любой момент разработки формы. Если форма имеет статус Редактируемая, то на изображении формы поверх идентификатора будет написано "Черновик". Если форма имеет статус Опубликованная, то идентификатор будет иметь стандартный вид, в соответствии с выбранным типом идентификатора.

Для того чтобы получить изображение формы, воспользуйтесь командой Файл изображения… (меню Файл>Экспортировать в>Файл изображения…). В открывшемся диалоге Сохранить изображение как выберите формат файла изображения и укажите название файла и папку, куда файл будет сохранен.

Программа ABBYY FormDesigner поддерживает экспорт в следующие форматы изображений:

  • Bitmap, черно-белый (*.bmp, *.dib, *.rle)
  • Bitmap, серый (*.bmp, *.dib, *.rle)
  • Bitmap, цветной (*.bmp, *.dib, *.rle)
  • DCX, черно-белый (*.dcx)
  • DCX, серый (*.dcx)
  • DCX, цветной (*.dcx)
  • JBIG2 (*.jbig2, *.jb2)
  • JPEG, серый (*.jpg, *.jpeg)
  • JPEG, цветной (*.jpg, *.jpeg)
  • JPEG-2000, серый (*.jp2, *.j2k)
  • JPEG-2000, цветной (*.jp2, *.j2k)
  • PCX, черно-белый (*.pcx)
  • PCX, серый (*.pcx)
  • PCX, цветной (*.pcx)
  • PNG, черно-белый (*.png)
  • PNG, серый (*.png)
  • PNG, цветной (*.png)
  • TIFF, черно-белый, несжатый (*.tif, *.tiff)
  • TIFF, черно-белый, Group4 (*.tif, *.tiff)
  • TIFF, черно-белый, Packbits (*.tif, *.tiff)
  • TIFF, черно-белый, сжатие: ZIP (*.tif, *.tiff)
  • TIFF, черно-белый, сжатие: LZW (*.tif, *.tiff)
  • TIFF, серый, несжатый (*.tif, *.tiff)
  • TIFF, серый, Packbits (*.tif, *.tiff)
  • TIFF, серый, сжатие: JPEG (*.tif, *.tiff)
  • TIFF, серый, сжатие: ZIP (*.tif, *.tiff)
  • TIFF, серый сжатие: LZW (*.tif, *.tiff)
  • TIFF, цветной, несжатый (*.tif, *.tiff)
  • TIFF, цветной, Packbits (*.tif, *.tiff)
  • TIFF, цветной, сжатие: JPEG (*.tif, *.tiff)
  • TIFF, цветной, сжатие: ZIP (*.tif, *.tiff)
  • TIFF, цветной, сжатие: LZW (*.tif, *.tiff)
  • PDF (*.pdf)
  • EMF (*.emf)

Экспорт изображений многостраничных форм

Изображение многостраничной формы можно проэкспортировать в любой из поддерживаемых графических форматов. Для многостраничных форматов есть возможность сохранить форму в многостраничном файле. Для этого при сохранении файла изображения отметьте опцию Многостраничный файл. Если вы не отметите эту опцию, каждая страница будет сохранена в отдельном файле.

Экспорт в формат TIFF с произвольным разрешением

Изображения можно экспортировать в формат TIFF с произвольным разрешением. Значение разрешения для формата TIFF можно ввести на закладке Экспорт диалога Настройки (меню Сервис>Настройки…).

Замечание. Значение разрешения для формата TIFF должно быть не менее 50 и не более 1200 dpi.


Экспорт в Изображения с цветоделением

Для печати форм в типографии в 2 цвета может понадобиться сохранить цветную форму в два файла: в один записывается то, что должно быть напечатано черной краской, в другой - то, что должно печататься цветной краской.

Экспорт формы в файл изображения с цветоделением возможен в любой момент разработки формы. Если форма имеет статус Редактируемая, то на изображении формы поверх идентификатора будет написано "Черновик". Если форма имеет статус Опубликованная, то идентификатор будет иметь стандартный вид, в соответствии с выбранным типом идентификатора.

Для экспорта изображения формы с разделением на цвета выберите пункт меню Файл>Экспортировать в>Изображения с цветоделением….

Изображения будут сохранены в файлах формата TIFF, к названию черно-белого файла добавляется _bw, а к названию цветного - _color.


Экспорт в XML Form Definition (*.xfd)

С помощью программы ABBYY FormDesigner вы можете разработать не только саму форму, но и получить описание формы, которое может быть использовано для создания определения документа в программе ABBYY FlexiCapture (Определение документа - это описание элементов и правил в определенном формате, используемое для распознавания документов).

Для того чтобы получить описание формы, необходимо с помощью программы ABBYY FormDesigner экспортировать форму в файл специального формата XML Form Definition (*.xfd), а затем импортировать его в программе ABBYY FlexiCapture (при создании определения документа). Программа ABBYY FlexiCapture автоматически создаст определение на основе файла *.xfd.

Экспорт в формат XML Form Definition возможен только после публикации формы.

В программе ABBYY FormDesigner возможно выбрать формат (TIFF или EMF), в котором будет сохранено изображение формы при экспорте формы в файл формата *.xfd.

Для того чтобы получить файл с расширением *.xfd, воспользуйтесь командой XML Form Definition… (меню Файл>Экспортировать в>XML Form Definition…). В открывшемся диалоге Экспорт в XML Form Definition укажите название файла и папку, куда он будет сохранен.


Экспорт в Форму PDF

Для того чтобы отправить форму для заполнения в электронном виде, рекомендуется предварительно экспортировать форму ABBYY FormDesigner в форму PDF. При этом будет возможность добавить на форму кнопку(-ки) отправки ответа - на электронный адрес и/или сайт, по нажатию на которую(-ые) заполненная форма будет отправлена по указанному адресу.

Также экспорт в PDF-формат можно использовать для дальнейшего редактирования формы в других редакторах макетов форм, например, Adobe Acrobat Professional.

Для того чтобы экспортировать форму в форму PDF, воспользуйтесь командой меню Файл>Экспортировать в>Форму PDF….

  1. Прежде чем установить параметры сохранения в PDF-формат, в открывшемся диалоговом окне Способы получения ответов укажите, следует ли добавить на форму кнопку отправки ответа. Кнопки будут размещены на первой странице формы в верхнем левом углу. Возможные вариaнты (оба, любой или ни одного):
    • - Отправлять ответы по электронной почте (указать e-mail),
    • - Отправлять ответы через Internet (указать URL).
    • - Очистить данные формы (отметьте эту опцию для очистки формы от данных)

    2. Для каждой кнопки можно ввести новое название либо использовать предложенный вариант. Также можно указать расположение кнопок на форме:

    • Вверху - кнопка появится вверху первой страницы формы,
    • Внизу - кнопка появится внизу последней страницы формы,
    • Вверху и внизу - кнопка появится вверху первой и внизу последней страницы формы.

  2. Далее в диалоге Экспорт в PDF-форму укажите название файла и папку, в которую вы хотите сохранить файл.
  3. Можно указать дополнительные параметры сохранения, нажав кнопку Дополнительно… в нижней части диалогового окна Экспорт в PDF-форму. В открывшемся диалоге Параметры файла PDF вы можете указать следующие параметры:
    • - Способ сохранения (Только текст или Только изображение);
    • - Настройки шрифтов (Системные шрифты или Стандартные шрифты);
    • - Внедрять шрифты (поставить галочку, если вы хотите встроить шрифты в форму).

Замечание. Чтобы выполнить экспорт в форму PDF, на форме должно быть по хотя бы одно редактируемое поле.


Экспорт в Форму InfoPath

Экспорт в форму Microsoft Office InfoPath возможен в любой момент разработки формы. Для того чтобы получить пакет исходных файлов для Microsoft Office InfoPath, воспользуйтесь командой меню Файл>Экспортировать в>Форму InfoPath…. В открывшемся диалоге Выберите папку (Browse for Folder) следует выбрать папку, в которую вы хотите сохранить пакет, нажмите Ок. В этой папке будет создан подкаталог с именем сохраняемой формы, в котором будет содержаться набор файлов для программы InfoPath. В InfoPath следует открывать файл с именем manifest.xsf.

Замечания:

  • Для корректной работы с формами InfoPath необходимо, чтобы на вашем компьютере был установлен Microsoft Office 2007 Service Pack 1 (SP1);
  • Чтобы выполнить экспорт в форму InfoPath, на форме должно быть по хотя бы одно редактируемое поле.


Экспорт в Файл Adobe Illustrator

Экспорт формы в файл Adobe Illustrator возможен в любой момент разработки формы.

Для того чтобы получить форму в формате Adobe Illustrator, воспользуйтесь командой меню Файл>Экспортировать в>Файл Adobe Illustrator…. В открывшемся диалоге Сохранить как файл Adobe Illustrator укажите название файла и папку, куда файл будет сохранен.


Отправить форму для заполнения

Непосредственно из программы ABBYY FormDesigner разработанную и опубликованную форму можно отправить для заполнения как в бумажном, так и в электронном виде (как форму PDF).

В электронном виде форму можно отправить по списку электронных адресов, или выложить на сайт, а также выбрать способ получения заполненных форм (на электронный адрес или через сайт), с возможностью обработки результатов на сервере.

Указать параметры отправки формы для заполнения поможет Мастер распространения формы, который появляется на экране при выборе пункта меню Файл>Отправить форму для заполнения…, или по нажатию кнопки [image] панели инструментов "Стандартная".

Мастер распространения формы проведет вас последовательно по шагам и поможет задать все необходимые параметры:

  1. Выберите способ распространения формы. Вы можете распечатать форму или распространить ее в электронном виде. Для печати нажмите кнопку Печать формы… Мастер предложит распечатать форму, и на этом завершит свою работу. Если вы хотите распространить форму в электронном виде, укажите параметры отправки и получения результатов.
  2. Для электронный формы выберите способ рассылки (укажите только один вариант):
    • Отправить по электронной почте - если вы выбрали этот пункт, то нажмите кнопку Завершить (Finish) в нижней части окна мастера. В результате откроется окно отправки электронного сообщения в почтовой программе, которая установлена на вашем компьютере. Сообщение будет содержать в качестве прикрепленного файла форму в формате PDF, а вам останется только указать получателей и написать текст сообщения. После отправки этого письма вы сможете вернуться в программу ABBYY FormDesigner.
    • Сохранить и отправить позже - укажите папку, куда будет сохранена форма в формате PDF. По умолчанию сохранение производится с именем опубликованной формы в папку "Мои документы". Для выбора другой папки и другого имени файла нажмите кнопку "...", расположенную в строке этого пункта. Нажмите кнопку Завершить (Finish) в нижней части окна мастера, и файл будет сохранен.
    • Опубликовать в сети - укажите адрес сайта, на котором вы хотите разместить данную форму в формате PDF. Пример: http://www.example.com/form.pdf. Нажмите кнопку Завершить (Finish) в нижней части окна мастера, форма будет выложена на сайт.
      Внимание! Для размещения формы на сайте вы должны иметь право на запись для данного сайта.
  3. Выберите способы получения ответов (можно выбрать любой вариант, оба, или ни одного):
    • Отправлять ответы по электронной почте - укажите адрес электронной почты, на который будет отправлена заполненная форма
    • Отправлять ответы через Internet - укажите адрес (URL) сайта, на который поступит и будет обрабатываться заполненная форма

    Отметьте опцию Очистить данные формы для очистки формы от данных.

    В соответствии с выбранным вариантом(-ами) на первой странице формы в верхнем левом углу будет размещена кнопка(-ки) для отправки заполненной формы на указанный сайт и/или электронный адрес.

    Для каждой кнопки можно ввести новое название либо использовать предложенный вариант. Также можно указать расположение кнопок на форме:

    • Вверху - кнопка появится вверху первой страницы формы,
    • Внизу - кнопка появится внизу последней страницы формы,
    • Вверху и внизу - кнопка появится вверху первой и внизу последней страницы формы.

    При получении заполненных форм через сайт на сайте можно настроить автоматическую обработку результатов.


Печать формы

Для того чтобы распечатать текущую форму:

  1. Выберите команду Печать (меню Файл>Печать) или
  2. Нажмите Ctrl+P.
  3. Форма будет отправлена на печать с настройками по умолчанию.

Замечание. Для того чтобы задать свойства печати, выберите команду Файл > Настройка печати…. В открывшемся диалоге выберите принтер и укажите диапазон печати и число копий. Нажмите кнопку Properties..., чтобы указать размер и ориентацию страниц.


Печать заполненных форм

Вы находитесь здесь: Работа с программой ABBYY FormDesigner > Печать заполненных форм

Работа с предварительно заполненной формой

Программа ABBYY FormDesigner позволяет получить не только пустые формы, но и формы, у которых заполнены некоторые поля. Например, если необходимы именные бланки, в которые уже вписаны фамилии заполняющих, в готовую форму нужно подставить фамилии из файла или базы данных. Далее предварительно заполненную форму можно распечатать или экспортировать в PDF- файл.

Особенности предварительного заполнения форм

  • Названия полей в файле/базе данных должны совпадать с названиями полей в форме и структуре документа.
  • Вместо названия элемента можно использовать его идентификатор (ID). Использование идентификаторов позволяет заполнять значения элементов, не представленных в структуре документа, например, поле штрих-кода.
  • Поле или метку из группы можно указать как с помощью идентификатора, так и с помощью полного имени поля в формате <имя группы>|<имя поля>.
  • При подстановке значений из файла используются файлы формата CSV или TXT в кодировке Unicode. Верхняя строчка файла считается шапкой, в ней должны содержаться названия полей. В качестве разделителя допускаются следующие символы: запятая, точка с запятой, табуляция.
  • При подстановке данных в таблицу на форме необходимо указывать полное имя в следующем формате: <Table>|<Col>|<Row#>, где <Table> - название таблицы на форме, <Col> - название столбца таблицы, <Row#> - номер ячейки (начиная с нуля).
  • При печати заполненных форм типы данных преобразуются.
    Например, если на форме есть поле метки, которое вы хотите заполнить, то в соответствующем поле файла или базы данных могут быть значения True/False , 1/0 и yes/no.
  • Шрифт распечатанных данных соответствует шрифту подсказки, который задается в окне свойств элемента на вкладке Подсказка.

Печать предварительно заполненных форм

С подстановкой данных из базы данных:

  1. В меню Файл выберите команду Печать заполненных форм….
  2. В открывшемся окне Выбор подключения к данным выберите ранее подключенную базу данных или нажмите кнопку Новое… для создания нового подключения.
  3. Выберите База данных и нажмите кнопку Выбрать….
  4. Укажите параметры соединения с базой данных.

Также можно распечатать предварительно заполненную форму данных с подстановкой данных из базы данных с помощью команды FormDesigner.exe /printDatabase <путь к форме .fdd>. Например:

C:\Program Files (x86)\ABBYY FlexiCapture 11 Stations>FormDesigner.exe /printDatabase D:\$temp\fillData.fdd Database:"connectionString:Provider=MSDASQL.1;Persist Security Info=False;Data Source=Xtreme Sample Database 2003;table:Credit"

С подстановкой данных из файла:

  1. В меню Файл выберите команду Печать заполненных форм….
  2. В открывшемся окне Выбор подключения к данным выберите ранее добавленный файл или нажмите кнопку Новое… для добавления нового файла.
  3. Выберите Файл и нажмите Открыть…, чтобы указать путь к файлу.

Также можно распечатать предварительно заполненную форму данных с подстановкой данных из файла с помощью команды FormDesigner.exe /printDatabase <путь к форме .fdd>. Например:

C:\Program Files (x86)\ABBYY FlexiCapture 11 Stations>FormDesigner.exe /printDatabase D:\$temp\fillData.fdd File:"D:\$temp\fillData.txt"

Экспорт заполненных форм

Чтобы экспортировать предварительно заполненную форму, воспользуйтесь командой FormDesigner.exe /exportDataBase <путь к форме .fdd> File:<путь к файлу со значениями> DestinationFolder:<путь к папке экспорта> FormName:<имя файла с формой>.pdf.

Обязательные параметры команды:

  • Database:"connectionstring: …" – при подстановке данных из базы данных
  • File:<путь к файлу со значениями> – при подстановке данных из файла формата TXT или CSV
  • DestinationFolder:<путь к папке экспорта>
    Внимание! Укажите путь к уже существующей на диске папке.
  • FormName:<имя файла с формой>.pdf

С помощью необязательных параметров можно описать кнопки для отправки формы:

  • EmailButtonText:<имя кнопки>
  • SubmitEmail:<e-mail>
  • UrlButtonText:<имя кнопки>
  • SubmitUrl:<адрес сервера>
  • ClearButtonText:<имя кнопки>
  • ButtonsPosition:<позиция кнопки> (допустимые позиции: Top (по умолчанию), Bottom или TopAndBottom)

Замечание. Если названия кнопок содержат пробелы, их необходимо заключить в кавычки.

Пример команды экспорта формы с подстановкой данных из базы данных:

C:\Program Files (x86)\ABBYY FlexiCapture 11 Stations>FormDesigner.exe /exportDatabase D:\MyForm.fdd Database:"connectionString:Provider=MSDASQL.1;Persist Security Info=False;Extended Properties=\"DRIVER=SQL Server;SERVER=Serv\SQL2014\";Initial Catalog=FD;table:MyTable" DestinationFolder:D:\Forms FormName:MyPdfForm.pdf

Пример команды экспорта формы с подстановкой данных из файла:

C:\Program Files (x86)\ABBYY FlexiCapture 11 Stations>FormDesigner.exe /exportDatabase D:\MyForm.fdd File:D:\fd.txt DestinationFolder:D:\Forms FormName:MyPdfForm.pdf EmailButtonText:Complete SubmitEmail:Mail@abbyy.com ButtonsPosition:TopAndBottom.

Параметр Filter:<ИмяПоля>=<Значение1>[,<Значение2>[…]] служит для фильтрации записей базы данных. Условием может служить уникальный идентификатор поля (Id), значения параметра перечисляются через запятую. Параметр можно указывать несколько раз для разных полей.

Внимание! Предзаполненные поля недоступны для дальнейшего редактирования.

Замечание. Если выходной файл формы не публикуется, проверьте, что все параметры указаны правильно.

Диагностика команд печати и экспорта заполненных форм

При выполнении команд /printDatabase и /exportDatabse автоматически проводится диагностика следующих параметров:

  • Путь к файлу формы;
  • Подключение к базе данных или файлу;
  • Путь к папке экспорта;
  • Имя выходного файла;
  • Наличие соответствующих полей в источнике.

Сообщения диагностики записываются в журнал событий. Для просмотра сообщений в журнале событий (Панель управления>Администрирование>Журнал событий) задайте в ветке системного реестра [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog\Application\ABBYY FormDesigner 11] ключ EventMessageFile со значением C:\Program Files (x86)\ABBYY FlexiCapture 11 Stations\FObjEventSrc.dll. Если командная строка запущена от имени администратора, значение будет установлено автоматически.

Для дублирования сообщений диагностики в отдельный файл используется параметр LogFile:<имя-файла>. Чтобы отключить запись в журнал событий, воспользуйтесь ключом /noSystemLog. Пример команды с отключением записи в системный журнал событий и записью в отдельный файл:

FormDesigner.exe /exportDatabase D:\MyForm.fdd File:D:\file.txt DestinationFolder:D:\Forms FormName:MyPdfForm.pdf LogFile:D:\log.txt /noSystemLog


Глоссарий

Вы находитесь здесь: Приложение > Глоссарий

А

ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка макета формы является важным этапом, так как от "правильности" разработанного макета (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

Г

Группа элементов

Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов. Группа элементов используется для объединения логически связанных элементов, для создания групп меток.

З

Знакоместо

Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).

И

Идентификатор

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

Идентификатор страницы

Элемент машиночитаемой формы, однозначно характеризующий данную страницу формы.

К

Картинка

Элемент машиночитаемой формы, представляющий собой графическое изображение.

М

Машиночитаемая форма

Форма, созданная с учетом требований автоматизированного ввода.

Машиночитаемость

Пригодность формы для автоматизированного ввода и дальнейшей обработки распознанного текста.

O

Образец формы

Образец, на основе которого можно создавать новые формы в программе ABBYY FormDesigner. Образец формы сохраняется в двоичном файле с расширением dtf.

Образец страницы формы

Образец, на основе которого можно создавать новые станицы формы в программе ABBYY FormDesigner. Образец страницы сохраняется в двоичном файле с расширением ptf.

П

Поле даты

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

Поле для ввода

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.

Поле метки

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

Публикация формы

Процесс, при котором форме присваивается статус Опубликованная, не позволяющий вносить в форму изменения.
Во время публикации автоматически запускается проверка формы на машиночитаемость, элементам Идентификатор присваивается уникальное значение (одно для всех).

Р

Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Рамка

Элемент машиночитаемой формы, ограничивающий некоторую область формы.

Репер

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

С

Создание формы

Процесс создания машиночитаемой формы можно разделить на следующие этапы: анализ формы, непосредственно создание новой формы, тиражирование формы.

Т

Таблица

Элемент машиночитаемой формы, представляющий собой таблицу, которая содержит столбцы с однотипными элементами.

Текст

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

Требования к машиночитаемым формам

Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму.

Ф

Форма

Документ, состоящий из одной или нескольких страниц и предназначенный для заполнения человеком от руки или любым печатным способом.

Формат XFD

XML Form Definition (*.xfd) - специальный формат файла формы, созданной в программе ABBYY FormDesigner. Файл формата XML Form Definition используется для создания шаблона документа в программе ABBYY FlexiCapture.

Ц

Цветная фоновая форма

Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.

Ч

Черно-белая линейчатая форма

Форма без фона (как правило), на которых границы знакомест полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены черными линиями.

Черно-белая форма с растровыми границами

Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).

Черно-белая форма с растровым фоном

Форма с растровым фоном (растр - мелкие черные точки), на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др.), в которые при заполнении формы вносится информация. Фон должен состоять из отдельных точек.

Числовое поле

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.


Горячие клавиши

Меню | Команда | Горячие клавиши
Файл | Новая… | Ctrl+N
 | Открыть… | Ctrl+O
 | Сохранить | Ctrl+S
 | Печать | Ctrl+P
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Дублировать | Ctrl+D
 | Удалить блок | Shift+Del
 | Выделить все | Ctrl+A
 | Выделить по типу… | Ctrl+Shift+A
Вид | Свойства | Alt+Enter
 | Масштаб/Форму целиком | Ctrl+Shift+Num/
 | Масштаб/Уменьшить | Ctrl+Shift+Num-
 | Масштаб/Увеличить | Ctrl+Shift+Num +
Элемент | Выбрать/Инструмент выбора | Esc
 | Выбрать/Поле для ввода | E
 | Выбрать/Поле даты | D
 | Выбрать/Числовое поле | N
 | Выбрать/Поле метки | C
 | Выбрать/Группа элементов | G
 | Выбрать/Таблица | T
 | Выбрать/Вертикальный разделитель | V
 | Выбрать/Горизонтальный разделитель | H
 | Выбрать/Текст | S
 | Выбрать/Разделитель | L
 | Выбрать/Рамка | F
 | Выбрать/Картинка | P
 | Выбрать/Репер | A
 | Выбрать/Идентификатор | I
 | Выравнивание/По левому краю | Alt+Left Arrow
 | Выравнивание/Горизонтально по центру | Shift+F9
 | Выравнивание/По правому краю | Alt+Right Arrow
 | Выравнивание/По верхнему краю | Alt+Up Arrow
 | Выравнивание/Вертикально по центру | Ctrl+F9
 | Выравнивание/По нижнему краю | Alt+Down Arrow
 | Размер/Выровнять по ширине | Shift+F8
 | Размер/Выровнять по высоте | Ctrl+F8
 | Размер/Выровнять по ширине и высоте | Ctrl+Shift+F8
 | Объединить | Ctrl+Shift+G
 | Разъединить | Ctrl+Shift+U
Сервис | Проверить форму | F9
 | Настройки… | F12
Справка | Вызов справки | F1


Горячие клавиши (редактирование текста)

Чтобы: | Горячие клавиши
Переместить курсор на строку выше. | Стрелка вверх
Переместить курсор на строку ниже. | Стрелка вниз
Переместить курсор на первую строку текста. | Page Up
Переместить курсор на последнюю строку текста. | Page Down
Переместить курсор на один символ вправо. | Стрелка вправо
Переместить курсор на один символ влево. | Стрелка влево
Переместить курсор вправо в начало следующего слова. | Ctrl+Стрелка вправо
Переместить курсор влево в начало слова. | Ctrl+Стрелка влево
Переместить курсор в начало строки. | Home
Переместить курсор в конец строки. | End
Переместить курсор в начало текста. | Ctrl+Home
Переместить курсор в конец текста. | Ctrl+End
Удалить выделенный текст. (Если текст не выделен, то удалится символ справа от курсора.) | Delete
Удалить символ, находящийся перед курсором. | Backspace
Выйти из режима редактирования текста без сохранения изменений. | Esc
Выйти из режима редактирования текста, сохранив изменения. | Enter
Перейти на следующую строку. | Ctrl+Enter


Алфавит, используемый в регулярных выражениях

Название | Условное обозначение | Пример использования
Любой символ | * | "к"*"т" – допускает слова типа кит, кот и т.п.
Буква | С | С"от" – допускает слова типа Рот, рот, кот, Кот, мот и т.д.
Заглавная буква | А | A"от" – допускает слова типа Рот, Кот, Мот, Дот и т.п.
Строчная буква | а | а"от" – допускает слова типа рот, кот, мот, дот и т.п.
Буква или цифра | Х | X – допускает любую одиночную цифру или букву.
Цифра | N | N"-й" допускает слова типа 5-й, 4-й, 1-й и т.п.
Строка | " " | "кот"
Или | | | "пл"("о"|"а")"т" – допускает слова "плот" и "плат".
Символ из группы | [] | [тм]"от" – допускает слова тот и мот.
Символ не из группы | [^] | [^т]"от" – допускает слова "кот", "лот" и т.п., но не допускает слова "тот".
Пробел (в группе) | \s | [A\s] допускает только букву А либо пробел.
Любое число повторений (распространяется на стоящее слева выражение или подвыражение) | {-} | [АБ74]{-} – допускает любые комбинации символов А, Б, 7, 4 произвольной длины.
Количество повторений n | {n} | N{2}"-й" допускает слова типа 25-й, 84-й, 11-й и т.п.
От n до m повторений | {n-m} | N{1-3}"-й" допускает слова типа 5-й, 84-й, 111-й и т.п.
От 0 до n повторений | {-n} | N{-2}"-й" допускает слова типа -й, 84-й, 1-й и т.п.
От n и больше повторений | {n-} | N{2-}"-й" допускает слова типа 25-й, 834-й, 311-й, 34576-й и т.п.
Подвыражение | () |
Символ "дефис" | [\-] |
Символ "слеш" | [\\] |

Примеры регулярных выражений:

  1. Почтовый индекс: [0-9]{6}
    Пример значения: "142172"
  2. Zip код (США): [0-9]{5}("-"[0-9]{4}){-1}
    Примеры значений: "55416", "33701-4313"
  3. Доход: N{4-8}[,]N{2}
    Примеры значений: "15000,00", "4499,00"
  4. Месяц числом: ((|"0")[1-9])|("10")|("11")|("12")
    Примеры значений: "4", "05", "12"
  5. Дробное число: ("-"|)([0-9]{1-})(|(("."|",")([0-9]{1-})))
    Примеры значений: "1234,567", "0.99", "100,0", "-345.6788903"
  6. E-mail: [A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-3}"@"[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-4}"."([A-Za-z]{2-4}|"asia"|"museum"|"travel"|"example"|"localhost")
    Примеры значений: "support@abbyy.com", "my-name@company.org.ru", "info@gallery.museum"


ЛИЦЕНЗИОННЫЙ ДОГОВОР С КОНЕЧНЫМ ПОЛЬЗОВАТЕЛЕМ

ABBYY® FlexiCapture®

Важно! Внимательно прочитайте условия лицензионного договора прежде чем устанавливать, копировать, и/или иным образом использовать программу для ЭВМ ABBYY FlexiCapture (далее – ПО). Установка, копирование и использование ПО иным способом означает Ваше согласие с условиями приведенного ниже лицензионного договора.

Настоящий лицензионный договор с конечным пользователем (далее – Лицензионный договор) является юридически обязательным соглашением между Вами, конечным пользователем, приобретшим ПО, и Компанией ABBYY.

Настоящий Лицензионный договор вступает в силу после того, как Вы выразите свое согласие соблюдать изложенные в нем условия, нажав сначала кнопку «Я принимаю условия лицензионного договора», а затем кнопку «Далее», что приведет к установке ПО, либо после того, как Вы установите, скопируете или начнете каким-либо образом использовать ПО. Любое такое действие будет интерпретироваться как Ваше согласие с тем, что Вы прочитали настоящий Лицензионный договор, поняли его и согласны выполнять изложенные в нем условия. В случае если Вы не согласны с условиями настоящего Лицензионного договора, не используйте ПО, удалите ПО с Вашего компьютера и уничтожьте все имеющиеся у Вас копии ПО. Настоящий Лицензионный договор действует на протяжении всего срока действия авторских прав на ПО, если иное не оговорено в настоящем Лицензионном договоре или в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, и может зависеть от объема Лицензии, определенного в настоящем Лицензионном договоре.

ПО защищается законодательством об авторском праве и международными соглашениями, некоторые части ПО защищены патентным законодательством и законами о коммерческой тайне. Вы подтверждаете свое согласие с тем, что настоящий Лицензионный договор имеет такую же юридическую силу, как и любой другой письменный договор, заключенный Вами. В случае нарушения Лицензионного договора Вы можете быть привлечены в качестве ответчика.

Если ПО сопровождается договором, заключенным с Компанией ABBYY или Партнером Компании ABBYY, в бумажном виде, в том числе в письменной форме, и этот договор определяет условия использования Вами ПО, то в случае расхождений в содержании между текстом настоящего Лицензионного договора в электронном виде и текстом договора в бумажном виде, в том числе в письменной форме, преимущественную силу имеет текст договора в бумажном виде, в том числе в письменной форме.

Настоящий Лицензионный договор может быть доступен Вам на нескольких языках. Между английской версией Лицензионного договора и его версиями на других языках могут быть расхождения, а также могут быть различия в трактовке. Ради единообразия и предотвращения двусмысленности, английская версия Лицензионного договора будет иметь преимущественную силу, и все споры, претензии и судебные разбирательства, связанные с Лицензионным договором, в том числе с его толкованием или обеспечением его исполнения, должны разрешаться на основании английской версии Лицензионного договора.

Определения

«Компания ABBYY» означает

ABBYY USA Software House Inc. зарегистрированное по адресу 95035, США, Калифорния, г. Милпитас, бульвар Норс МакКарти, 880, офис 220, когда применяется статья 13.1 настоящего Лицензионного договора;

ABBYY Europe GmbH зарегистрированное по адресу: 80687, Германия, г. Мюнхен, Эльзенхаймер штрассе, 49, когда применяется статья 13.2 настоящего Лицензионного договора;

ABBYY UK Ltd. зарегистрированное по адресу: Соединенное Королевство, Эгхем, Суррей TW20 9EY, Хай-стрит, 65, Хитроу бизнес-центр, когда применяется статья 13.3 настоящего Лицензионного договора;

ООО «Аби Продакшн», зарегистрированное по адресу 109390, Москва, ул. 1-ая Текстильщиков, д. 12/9, офис 2., когда применяется статья 13.4 настоящего Лицензионного договора;

ООО «АБИ Украина», зарегистрированное по адресу 03680, Украина, г. Киев, ул. Дегтяревская, д. 31, когда применяется статья 13.5 настоящего Лицензионного договора;

и ABBYY Solutions Ltd., зарегистрированное по адресу: 2404, Кипр, г. Никосия, ул. Михаила Караоли, 2, Эгкоми - во всех остальных случаях.

«Партнер Компании ABBYY» означает физическое или юридическое лицо, которому Компания ABBYY предоставила право на перепродажу и распространение лицензионных копий ПО Конечным пользователям, либо напрямую, либо через одного или более посредника или дистрибьютора.

«Компьютер» означает физическое или виртуальное устройство с одним или более ядром ЦПУ (центрального процессорного устройства), и работающее под управлением определенной операционной системы. Любые изменения в конфигурации или в наборе комплектующих Компьютера могут привести к тому, что Компьютер будет считаться другим Компьютером для целей использования ПО.

«Права на интеллектуальную собственность» означает все права на интеллектуальную и промышленную собственность и включает в себя права на (i) изобретения, открытия и патенты, в том числе заявки на патенты, повторно выданные патенты, продолжения и частичные продолжения; (ii) авторские права; (iii) образцы и промышленные образцы; (iv) товарные знаки, знаки обслуживания, оформление товара и подобные права; (v) ноу-хау, коммерческую тайну и конфиденциальную информацию; (vi) права на топологию интегральных микросхем и права на шаблоны; и (vii) иные интеллектуальные права.

«Лицензия» – предоставляемое Вам Компанией ABBYY на условиях простой (неисключительной) лицензии ограниченное право на установку и использование функциональности ПО в соответствии с условиями Лицензионного договора.

«ПО» означает любую версию или издание программы для ЭВМ ABBYY FlexiCapture, включая все компоненты программы (расширения, пользовательские компоненты, модули, и т.д.) встроенные в программу или доступные в сети интернет или иным образом, такие как: исполняемый код, справка, демонстрационные, файлы для примера и другие файлы; библиотеки, базы данных, примеры, сопроводительные материалы (графические изображения, фотографии, анимированные изображения, аудио- и видео-компоненты, музыка, и т.д.), печатные материалы, и другие компоненты ПО.

«Вы», «Ваш», «Конечный пользователь» относится и подразумевает любое физическое и/или любое юридическое лицо, которое приобрело ПО для собственного использования и не для продажи, а также любого фактического пользователя ПО.

«Серийный номер» означает уникальный идентификатор лицензии или группы лицензий со сходными параметрами, предоставленный Компанией ABBYY или Партнером Компании ABBYY Конечному пользователю.

«Активация ПО» - процесс, при помощи которого осуществляется проверка Серийного номера на действительность и установленное ПО переводится в полнофункциональный режим и начинает выполнять все функции в соответствии с сопроводительной документацией и объемом приобретенной Вами Лицензии.

1. Предоставление лицензии

1.1 Согласно условиям и положениям настоящего Лицензионного договора, Компания ABBYY предоставляет Вам неисключительную, ограниченную Лицензию на установку и использование функциональности ПО, с учетом всех ограничений и объема Лицензии, которые могут содержаться: в Лицензионном договоре, программных и/или аппаратных лицензионных ключах, предоставленных Компанией ABBYY (далее - Лицензионный ключ), ПО, и/или отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY. Все условия Лицензионного договора относятся как к ПО в целом, так и ко всем компонентам ПО в отдельности. Любые разногласия по поводу объема Лицензии будут разрешаться в пользу ограничения объема Лицензии. Лицензионный ключ техническими средствами ограничивает использование ПО объемом Лицензии, которую Вы приобрели. Ограничения на использование ПО Вами и объем Вашей Лицензии могут включать следующие, но не ограничиваются таковыми:

1.1.1 Количество рабочих мест, компонентов ПО и сетевых подключений. Вы имеете право устанавливать ПО более чем на одном Компьютере в Сети и одновременно использовать определенные компоненты ПО на определенном количестве Компьютеров в Сети («конкурентное лицензирование»). Информация о доступных для использования компонентах ПО и количестве Компьютеров в Сети, разрешенных для одновременной работы с ПО, содержится в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.2 Обрабатываемый объем. Количество страниц, которое может быть обработано при помощи ПО, может быть ограничено одним или более способом, таким как ограничение на количество страниц, которое можно обработать за определенные отрезки времени, например каждый месяц или каждый год, или на суммарное количество обрабатываемых страниц. Размер страниц и количество полей в документе также могут быть ограничены. Ограничения на обрабатываемый объем содержатся в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.3 Срок. Использование ПО может быть ограниченно определенным сроком, после истечения которого Вы не можете использовать ПО. Ограничение срока содержится в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.4 Возможности, расширения и пользовательские компоненты. Использование определенных возможностей, расширений и/или пользовательских компонентов ПО может быть ограничена в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.2

Вычислительные мощности. Количество ядер ЦПУ (Центрального Процессора) Компьютеров, которые ПО может задействовать, могут быть также ограничены в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY. Компания ABBYY сохраняет все права, явным образом не предоставленные Вам согласно условиям настоящего Лицензионного договора. Лицензионный договор не предоставляет и не предает Вам никаких прав на товарные знаки Компании ABBYY.

1.3 Если применяется п. 13.4 Лицензионного договора и Вы являетесь физическим лицом, Вы можете использовать ПО на территории всего мира. Если применяется п. 13.4 Лицензионного договора и Вы являетесь юридическим лицом, Вы имеете право приобрести (купить) ПО только в стране регистрации юридического лица или его обособленных подразделений, если иное не указанно в отдельном письменном договоре между Вами или Компанией ABBYY. Сотрудники юридического лица или его обособленных подразделений могут использовать ПО на территории всего мира, при условии, что ПО было приобретено и установлено, на территории страны регистрации юридического лица или его обособленных подразделений, если иное не предусмотрено в отдельном соглашении, заключенном между Вами и Компанией ABBYY или Партнером Компании ABBY.

1.4 Любое использование ПО или его компонентов, не соответствующее условиям Лицензионного договора, является нарушением интеллектуальных прав Компании ABBYY и/или третьих лиц и служит основанием для лишения Вас прав использования ПО, предоставленных Вам по настоящему Лицензионному договору.

1.5 Если Вы используете ПО в виртуальной среде, использование и получение доступа к ПО не должно нарушать ограничения на ПО и объем предоставленной Вам лицензии. Например, Лицензионный Ключ не может быть использован для предоставления доступа и разрешения на использование ПО большему количеству Компьютеров, чем количество Компьютеров, для которых была надлежащим образом приобретена лицензия. Также ПО не может быть использовано для обработки большего количества страниц, чем количество, на которое было получено разрешение.

1.6 Если Вы развертываете ПО через терминальные службы, которые разрешают доступ к ПО на удаленном компьютере с помощью сети, количество одновременно запущенных экземпляров ПО не должно превышать количество Компьютеров, для которых была надлежащим образом приобретена лицензия.

1.7 Если Вы используете ПО при помощи веб-браузера, Вы имеете право одновременно запускать и использовать ПО таким количеством Компьютеров, которое разрешено объемом приобретенной Вами Лицензии и указано в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.8 Вы можете получить ПО на нескольких носителях (ПО на множественных носителях), включая загрузки с помощью сети интернет. Вне зависимости от количества и типа полученных Вами материальных носителей, Вы можете использовать ПО только в соответствии с объемом Лицензии на ПО.

2. Ограничения на использование

2.1 Чтобы использовать ПО, Вам необходимо осуществить Активацию ПО после его установки.

2.2 Все условия использования ПО и ограничения на использование ПО приведены в Лицензионном договоре, если иное не указанно в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, или в сопутствующей документации к ПО.

2.3 Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:

2.3.1 Осуществлять обратное проектирование, дизассемблировать, декомпилировать (воспроизводить и преобразовывать объектный код в исходный текст) или иным способом осуществлять попытку получить исходный текст ПО или любой части ПО за исключением случаев, разрешенных применимым законодательством, несмотря на данное ограничение, и только в объеме, разрешенном применимым законодательством. Если применимое законодательство запрещает ограничение подобных действий, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть немедленно сообщена Компании ABBYY. Вся такая информация является конфиденциальной и принадлежит Компании ABBYY.

2.3.2 Модифицировать, адаптировать (в том числе, вносить в ПО изменения исключительно в целях его функционирования на конкретных технических средствах Конечного пользователя или под управлением конкретных программ Конечного пользователя), вносить любые изменения в объектный код ПО, программы и базы данных, содержащиеся в ПО, за исключением тех изменений, которые предусмотрены ПО и описаны в документации.

2.3.3 Осуществлять исправление ошибок в ПО или переводить ПО без предварительного письменного согласия Компании ABBYY.

2.3.4 Сдавать в аренду, сдавать в наем, сублицензировать, передавать или уступать права, предоставленные Вам по Лицензионному договору, и любые другие права, связанные с ПО, любому другому лицу, а также разрешать копировать ПО целиком или его части на другие Компьютеры (за исключением того, как это описано в п. 2.6).

2.3.5 Создавать условия для доступа к ПО или использования ПО третьими лицами, не имеющими прав на использование данного ПО, включая, но не ограничиваясь этим: пользователей работающих с Вами в одной многопользовательской системе, в виртуальной среде или через сеть интернет.

2.3.6 Удалять, изменять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

2.4 Вы не имеете права использовать ПО для предоставления платных или бесплатных услуг по распознаванию или преобразованию, и/или предоставлять третьим лицам результаты, полученные посредством ПО, или доступ к результатам, полученным посредством ПО, как часть другой услуги, в которой распознавание или преобразование текста является частью услуги, если Вы не заключали отдельный письменный договор с Компанией ABBYY и в Вашем Лицензионном ключе не активирован параметр “BPO services enabled”.

2.5 Вы не имеете права обходить предоставленный вместе с ПО пользовательский интерфейс ПО, если это не оговорено в отдельном письменном договоре с Компанией ABBYY.

2.6 Вы имеете право передать ПО напрямую другому Конечному пользователю только один раз. Если Вы являетесь юридическим лицом, такая передача может быть осуществлена только после получения письменного согласия Компании ABBYY. ПО может быть передано только целиком (включая все копии, все Компоненты ПО, носители и печатные материалы, любые обновления ПО), а также Лицензионный договор. Такая передача не может быть осуществлена при помощи посредников или любым другим косвенным образом. Лицо, получающее ПО в результате такой передачи, обязано согласиться с условиями Лицензионного договора, включая обязанность не осуществлять дальнейшую передачу Лицензионного договора и ПО. В случае осуществления такой передачи Вы обязаны удалить ПО со всех Ваших Компьютеров или из Вашей локальной сети.

3. Ознакомительные, испытательные и демонстрационные версии ПО

3.1 Если ПО, которое Вы получили вместе с этой Лицензией, является предпродажной версией или бета-версией ПО, предоставленной для ознакомления, тестирования или проверки, имеет ограниченный или неполный набор функций, обозначено как «Испытательная версия» или «Демонстрационная версия» (“Try&Buy” “Trial” или “Demo”), или было предоставлено бесплатно (далее – «Ознакомительное Программное Обеспечение»), то до тех пор, пока Вы не приобретете (купите) лицензию на полную версию ПО, применяется статья 3 Лицензионного договора. В случае любых расхождений между текстом других статей и текстом статьи 3 Лицензионного договора, статья 3 будет иметь преимущественную силу во всех вопросах, касающихся Ознакомительного Программного Обеспечения, но только в мере, необходимой для разрешения расхождений.

3.2 ОЗНАКОМИТЕЛЬНОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ПРЕДОСТАВЛЯЕТСЯ ВАМ «КАК ЕСТЬ» И БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ ИЛИ ОБЯЗАТЕЛЬСТВ ПО ВОЗМЕЩЕНИЮ УБЫТКОВ (ВЫРАЖЕННЫХ, ПОДРАЗУМЕВАЕМЫХ ИЛИ УСТАНОВЛЕННЫХ ЗАКОНОДАТЕЛЬСТВОМ). ОЗНАКОМИТЕЛЬНОЕ ПО НЕ ЯВЛЯЕТСЯ ОКОНЧАТЕЛЬНОЙ ВЕРСИЕЙ ПО ОТ КОМПАНИИ ABBYY, И МОЖЕТ СОДЕРЖАТЬ ДЕФЕКТЫ, ОШИБКИ И ДРУГИЕ НЕИСПРАВНОСТИ, КОТОРЫЕ МОГУТ ВЫЗВАТЬ СБОЙ СИСТЕМЫ ИЛИ ИНОЙ СБОЙ И ПОТЕРЮ ДАННЫХ. В ТОЙ СТЕПЕНИ, В КОТОРОЙ ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ, НА ОЗНАКОМИТЕЛЬНОЕ ПО НЕ РАСПРОСТРАНЯЮТСЯ НИКАКИЕ ГАРАНТИИ, И ВЫ СОГЛАСНЫ С ТЕМ, ЧТО КОМПАНИЯ ABBYY ОТКАЗЫВАЕТСЯ ОТ ВСЕХ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ И ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ВАМИ, В ТОМ ЧИСЛЕ, НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ, ОТ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРАВОВОГО ТИТУЛА, ГОДНОСТИ ДЛЯ ПРОДАЖИ, ОТСУТСТВИЯ НАРУШЕНИЯ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, СПОКОЙНОГО ПОЛЬЗОВАНИЯ И ГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ. В СЛУЧАЯХ, КОГДА ОТ ОТВЕТСТВЕННОСТИ НЕВОЗМОЖНО ОТКАЗАТЬСЯ, НО ОТВЕТСТВЕННОСТЬ МОЖЕТ БЫТЬ ОГРАНИЧЕНА, ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY НЕ ДОЛЖНА ПРЕВЫШАТЬ НАИБОЛЬШУЮ ИЗ ДВУХ СУММ: ЛИБО ПЯТИДЕСЯТИ (50) ДОЛЛАРОВ США, ЛИБО СУММУ, УПЛАЧЕННУЮ ВАМИ ЗА ПО.

3.3 Ознакомительное Программное Обеспечение может иметь ограниченную функциональность. Например, функциональность может быть доступна в течение ограниченного срока, по истечении которого (далее – истечение срока действия) Ваш доступ к Ознакомительному Программному Обеспечению и возможность им пользоваться будут прекращены. По истечении срока действия Вы теряете предоставленные Вам Лицензионным договором права, при условии, что Вы не приобрели новую лицензию у Компании ABBYY.

3.4 Ознакомительное Программное Обеспечение, коммерческая версия которого не поступала в продажу

3.4.1 Ознакомительное Программное Обеспечение, коммерческая версия которого не поступала в продажу, является Конфиденциальной Информацией Компании ABBYY.

3.4.2 В отношении Ознакомительного Программного Обеспечения, коммерческая версия которого не поступала в продажу, Компания ABBYY не обещает и не гарантирует, не имеет выраженных или подразумеваемых обязательств, и Вы признаете, что Компания ABBYY не обещала или не гарантировала, что такое программное обеспечение будет разрабатываться в дальнейшем, или что его коммерческая версия будет анонсирована или доступна в будущем. Компания ABBYY не имеет обязательств выпускать продукт, похожий или совместимый с таким программным обеспечением. Вы признаете, что все риски, связанные с использованием, изучением или разработкой такого программного обеспечения возлагаются на Вас.

3.4.3 Вы согласны предоставить Компании ABBYY отзывы о тестировании и использовании Ознакомительного Программного Обеспечения, включая сообщения об ошибках или дефектах (далее – Отзывы), и передать Компании ABBYY все права на Отзывы, включая без ограничений права на использование, публикацию и распространение Отзывов. Все Отзывы являются Конфиденциальной Информацией Компании ABBYY.

3.4.4 Конфиденциальность Ознакомительного Программного Обеспечения, коммерческая версия которого не поступала в продажу и его Результатов.

3.4.4.1 Вы обязуетесь не разглашать сопроводительную информацию, относящуюся к Ознакомительному Программному Обеспечению, коммерческая версия которого не поступала в продажу, и переданную Вам Компанией ABBYY в письменном, устном или электронном виде, а также любую информацию о качестве Ознакомительного Программного Обеспечения или качестве результатов, полученных при помощи Ознакомительного Программного Обеспечения, Отзывы, и любую информацию об ошибках, дефектах и других проблемах, обнаруженных Вами в Ознакомительном Программном Обеспечении, коммерческая версия которого не поступала в продажу. Такая информация является Конфиденциальной Информацией Компании ABBYY.

3.4.4.2 Вы обязуетесь не разглашать Конфиденциальную Информацию. «Разглашать» означает демонстрировать, описывать, копировать, отдавать во временное пользование, сдавать в аренду, передавать или предоставлять сетевой или иной доступ к Конфиденциальной Информации, воспроизведенной в любом виде, в том числе в устном, любым третьим лицам.

3.4.4.3 Вы обязуетесь принять все разумные меры для предотвращения разглашения Конфиденциальной Информации.

3.4.4.4 Вы обязуетесь своевременно уведомлять Компанию ABBYY о ставших известными Вам фактах разглашения Конфиденциальной Информации. Если Вы нарушите условия, указанные в п. 3.4.4.1 - 3.4.4.3 Лицензионного договора, Вы обязаны возместить Компании ABBYY все убытки, понесенные в результате такого нарушения.

3.5 В случае получения Вами новой версии Ознакомительного Программного Обеспечения или коммерческой версии такого программного обеспечения в виде отдельного продукта или части другого продукта, Вы обязаны вернуть или удалить все предыдущие версии Ознакомительного Программного Обеспечения, полученные вами от Компании ABBYY.

3.6 Если Ознакомительное Программное Обеспечение было предоставлено Вам в соответствии с отдельным письменным договором, использование Вами Ознакомительного Программного Обеспечения также подпадает под действие такого договора. В случае расхождений между условиями отдельного письменного договора и настоящего Лицензионного договора, отдельный письменный договор будет иметь преимущественную силу, но только в мере, необходимой для разрешения таких расхождений.

4. ПО, обозначенное «не для продажи»

4.1 Если ПО обозначено как «не для продажи» («Not for Resale» или «NFR»), то, независимо от остальных условий Лицензионного договора, допускается использование такого ПО только в целях демонстрации, проверки или тестирования ПО.

5. Обновления

5.1 Если ПО обозначено как обновление, Вы имеете право использовать ПО только при условии, что у вас есть лицензия на предыдущую версию ПО, обозначенную Компанией ABBYY как подлежащую такому обновлению.

5.2 ПО, обозначенное как обновление, заменяет или дополняет продукт, который являлся основанием для получения Вами обновления.

5.3 Вы имеете право использовать получившийся обновленный продукт только в соответствии с лицензионным договором, предоставленным вместе с обновлением.

5.4 Вы согласны с тем, что любые обязанности Компании ABBYY по поддержке обновляемой версии ПО заканчиваются в тот момент, когда обновление становится доступным.

6. Техническая поддержка и сопровождение

6.1 Вам может быть предоставлена техническая поддержка или сопровождение ПО (далее – Техническая поддержка) на условиях действующих правил предоставления Технической поддержки Компании ABBYY. Однако в случае заключения отдельного письменного договора между Вами и Компанией ABBYY или Партнером Компании ABBYY Вы можете иметь право на уровень Услуг по поддержке, отличный от уровня, обозначенного в политике Компании ABBYY по предоставлению поддержки.

6.2 Общие правила предоставления поддержки Компании ABBYY опубликованы на веб-сайте Компании ABBYY по адресу www.abbyy.com. Компания ABBYY оставляет за собой право изменять действующие правила предоставления Технической поддержки в любое время без предварительного уведомления.

6.3 В дополнение к общим правилам предоставления поддержки у Компании ABBYY могут быть особые правила предоставления Технической поддержки для отдельных регионов, которые могут быть регламентированы отдельными договорами.

6.4 Любой дополнительный программный код и любой компонент ПО, предоставленные Вам в рамках Технической поддержки, считаются частью ПО и подлежат действию условий Лицензионного договора.

6.5 В рамках предоставления Технической поддержки Компания ABBYY может запросить у Вас информацию про характеристики Вашего оборудования, серийный номер Вашего ПО, а также некоторые персональные данные, такие как Ваше имя, название Вашей компании (если применимо), адрес, номер телефона и адрес электронной почты. Компания ABBYY имеет право использовать эту информацию в соответствии с п.15.1 Лицензионного договора.

7. Права на интеллектуальную собственность.

7.1 Вам не передаются никакие принадлежащие Компании ABBYY Права на интеллектуальную собственность, в том числе никакие права на ПО, патенты и товарные знаки Компании ABBYY и никакие авторские права Компании ABBYY. Вы обязуетесь на протяжении всего срока действия настоящего Лицензионного договора и после его окончания не использовать и не претендовать на права на какие-либо наименования, логотипы, товарные знаки, модели или образцы, принадлежащие Компании ABBYY, или наименования, логотипы, товарные знаки, модели или образцы похожие на них.

7.2 Компании ABBYY не передаются никакие принадлежащие Вам Права на интеллектуальную собственность, в том числе никакие принадлежащие Вам права на приложение, патенты, товарные знаки и никакие принадлежащие Вам авторские права.

7.3 ПО содержит значимую коммерческую тайну и конфиденциальную информацию, принадлежащую Компании ABBYY и третьим лицам, и охраняется законами об авторском праве, в том числе, без каких- либо ограничений, законами об авторском праве США, законами Российской Федерации, международными соглашениями и законами страны, в которой ПО используется или было приобретено.

7.4 Все правовые титулы и права на материалы, которые не содержатся в ПО, но могут быть доступны посредством использования ПО, принадлежат их законным владельцам и могут охраняться применимыми законами об авторском праве, иными законами об охране интеллектуальной собственности и международными соглашениями. Настоящий Лицензионный договор не предоставляет Вам никаких прав на такую интеллектуальную собственность.

8. Ограниченная гарантия. Отказ от ответственности

8.1 Если этого требует законодательство страны, в которой Вы приобрели (купили) ПО, Компания ABBYY гарантирует качество и работоспособность носителей, на которых предоставляется ПО, только при условии нормального использования и только в течение минимального гарантийного срока, установленного законодательством страны, в которой Вы приобрели (купили) ПО, начиная с даты приобретения ПО. Если ПО было приобретено в одной из стран, указанных в п. 13.4 Лицензионного договора, гарантийный срок на материальные носители составляет тридцать (30) дней, начиная с даты приобретения ПО.

8.2 ЗА ИСКЛЮЧЕНИЕМ СЛУЧАЕВ, ЯВНО ОПИСАННЫХ В НАСТОЯЩЕЙ СТАТЬЕ 8 (ОГРАНИЧЕННАЯ ГАРАНТИЯ. ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ), И ЗА ИСКЛЮЧЕНИЕМ ГАРАНТИЙ, УСЛОВИЙ И ЗАВЕРЕНИЙ, КОТОРЫЕ НЕ МОГУТ БЫТЬ ИСКЛЮЧЕНЫ ИЛИ ОГРАНИЧЕНЫ В СООТВЕТСТВИИ С ПРИМЕНИМЫМИ К ВАМ ЗАКОНОДАТЕЛЬСТВОМ, ПО, ВКЛЮЧАЯ БЕЗ ОГРАНИЧЕНИЙ ЛЮБУЮ ДОКУМЕНТАЦИЮ, ОБНОВЛЕНИЯ И ИСПРАВЛЕНИЯ, ПРЕДОСТАВЛЯЕТСЯ ВАМ ТАКИМ, КАКОВО ОНО ЕСТЬ, И КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ ВАМ НИКАКИХ ГАРАНТИЙ, УСЛОВИЙ И ЗАВЕРЕНИЙ (ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ НА ОСНОВАНИИ СТАТУТНОГО ПРАВА, ОБЩЕГО ПРАВА, ОБЫЧАЯ ИЛИ СУЩЕСТВУЮЩЕЙ ПРАКТИКИ) В ОТНОШЕНИИ ЧЕГО-ЛИБО, ВКЛЮЧАЯ ОТСУТСТВИЕ НАРУШЕНИЯ ПРАВ ТРЕТЬИХ ЛИЦ, ГОДНОСТИ ДЛЯ ПРОДАЖИ, ВОЗМОЖНОСТИ ИНТЕГРАЦИИ, УДОВЛЕТВОРИТЕЛЬНОГО КАЧЕСТВА ИЛИ ГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ, ОТСУТСТВИЯ ОШИБОК, СООТВЕТСТВИЯ ВАШИМ ТРЕБОВАНИЯМ И ПРАВИЛЬНОГО ФУНКЦИОНИРОВАНИЯ ПРИ ИСПОЛЬЗОВАНИИ СОВМЕСТНО С ДРУГИМ ПРОГРАММНЫМ ИЛИ АППАРАТНЫМ ОБЕСПЕЧЕНИЕМ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ ПРОИЗВОДИТЕЛЬНОСТЬ И РЕЗУЛЬТАТЫ РАБОТЫ ПО. ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВСЕ РИСКИ В СВЯЗИ С КАЧЕСТВОМ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПО. КОМПАНИЯ ABBYY ТАКЖЕ НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ НА ПРОГРАММНЫЕ ПРОДУКТЫ ТРЕТЬИХ ЛИЦ, КОТОРЫЕ МОГУТ ПОСТАВЛЯТЬСЯ В СОСТАВЕ ПО.

9. Ограничение ответственности

9.1 КОМПАНИЯ ABBYY НИ ПРИ КАКИХ ОБСТОЯТЕЛЬСТВАХ НЕ НЕСЕТ ПЕРЕД ВАМИ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА УБЫТКИ, ВЫНУЖДЕННЫЕ ПЕРЕРЫВЫ В ДЕЛОВОЙ АКТИВНОСТИ, ПОТЕРЮ ДЕЛОВЫХ ЛИБО ИНЫХ ДАННЫХ ИЛИ ИНФОРМАЦИИ, ПРЕТЕНЗИИ ИЛИ РАСХОДЫ, КОСВЕННЫЕ, НЕПРЯМЫЕ, СЛУЧАЙНЫЕ, СПЕЦИАЛЬНЫЕ ИЛИ ШТРАФНЫЕ УБЫТКИ, А ТАКЖЕ УПУЩЕННУЮ ВЫГОДУ И УТЕРЯННЫЕ ДОХОДЫ, ВЫЗВАННЫЕ ИСПОЛЬЗОВАНИЕМ ИЛИ СВЯЗАННЫЕ С ИСПОЛЬЗОВАНИЕМ ПО, А ТАКЖЕ ЗА УБЫТКИ, ВЫЗВАННЫЕ ВОЗМОЖНЫМИ ОШИБКАМИ И ОПЕЧАТКАМИ В ПО, ДАЖЕ ЕСЛИ ПРЕДСТАВИТЕЛЮ КОМПАНИИ ABBYY СТАЛО ИЗВЕСТНО О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ, ПОТЕРЬ, ПРЕТЕНЗИЙ ИЛИ РАСХОДОВ, РАВНО КАК И ЗА ЛЮБЫЕ ПРЕТЕНЗИИ СО СТОРОНЫ ТРЕТЬИХ ЛИЦ. ВЫШЕПЕРЕЧИСЛЕННЫЕ ОГРАНИЧЕНИЯ И ИСКЛЮЧЕНИЯ ДЕЙСТВУЮТ В ТОЙ СТЕПЕНИ, НАСКОЛЬКО ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ. ЕДИНСТВЕННАЯ ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY ПО НАСТОЯЩЕМУ ЛИЦЕНЗИОННОМУ ДОГОВОРУ ИЛИ В СВЯЗИ С НИМ ОГРАНИЧИВАЕТСЯ СУММОЙ, КОТОРУЮ ВЫ УПЛАТИЛИ ЗА ПО, ЕСЛИ ТАКОВАЯ БЫЛА УПЛАЧЕНА.

10. Исключение Гарантии и Ограничения для пользователей, проживающих в Германии и Австрии

10.1 Если Вы приобрели экземпляр ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то в соответствии с законодательством Германии, Компания ABBYY гарантирует, что ПО предоставляет функциональность, перечисленную в сопроводительной документации (далее – договорная функциональность) в течение ограниченного гарантийного срока, отсчитываемого с момента получения Вами экземпляра ПО, при условии использования ПО на оборудовании рекомендованной конфигурации. В настоящем пункте термин «ограниченный гарантийный срок» означает 1 (один) год в случае коммерческого использования ПО и для юридических лиц, и 2 (два) года в случае некоммерческого использования ПО. Незначительные отклонения от договорной функциональности во внимание не принимаются и не являются основанием для действия вышеуказанной гарантии. Настоящая ограниченная гарантия не распространяется на ПО, предоставленное Вам бесплатно, например, на обновления, испытательные версии, пробные версии и на ПО, которое было изменено Вами до такой степени, что в нем появился дефект. Для того чтобы воспользоваться предоставленной гарантией в течение ограниченного гарантийного периода, Вы должны вернуть (за счет Компании ABBYY) ПО продавцу вместе с документом, подтверждающим покупку. В случае если функциональность ПО значительно отличается от договорной функциональности, Компания ABBYY имеет право на выбор по своему усмотрению исправить или заменить ПО. Если проблема не будет устранена, Вы имеете право на скидку (уменьшение первоначальной цены) или на расторжение договора купли-продажи (аннулирование договора). Дополнительную информацию о гарантийных обязательствах можно получить в Службе поддержки пользователей в Германии по адресу: ABBYY Europe GmbH, 80687, Германия, г. Мюнхен, Эльзенхаймерштрассе, 49, тел.: +49 (0)89 51 11 590, факс: +49 (0)89 51 11 5959.

10.2 Если Вы приобрели экземпляр ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то:

10.2.1 С учетом условий п. 10.2.2, ответственность Компании ABBYY за убытки, предусмотренная законом, ограничивается следующим: (i) Компания ABBYY несет ответственность только в том размере, который можно предвидеть в момент заключения договора купли-продажи для убытков в результате незначительного нарушения существенного контрактного обязательства и (ii) Компания ABBYY не несет ответственности за убытки в результате незначительного нарушения несущественного контрактного обязательства.

10.2.2 Ограничение ответственности, изложенное в п. 10.2.1 не распространяется на обязательную ответственность, предусмотренную законом, в частности, на ответственность согласно Закону Германии об ответственности за качество выпускаемой продукции, на ответственность за предоставление особенной гарантии и на ответственность за причиненные увечья.

10.2.3 Вы обязуетесь принять все разумные меры для предотвращения и уменьшения убытков, в том числе создание резервных копий ПО и принадлежащих Вам компьютерных данных, на которые распространяется действие положений Лицензионного договора.

11. Дополнительные Ограничения, распространяющиеся на ПО, приобретенное в США

11.1 Использование ПО правительственными учреждениями. В случае если данное ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных – Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

11.2 Экспортные ограничения. Запрещается экспортировать или реэкспортировать данное ПО в нарушение экспортных ограничений, установленных законодательством страны, в которой ПО было приобретено или получено. Вы также подтверждаете и гарантируете, что применимое законодательство не запрещает Вам получать данное ПО.

12. Технологии третьих лиц

12.1 Встроенные Шрифты. Шрифтовые программы охраняются авторским правом, и их владельцы могут налагать условия на использование шрифтов. Одним из условий может быть необходимость наличия лицензионной версии шрифтовой программы для встраивания шрифтов при создании новых PDF-файлов. Компания ABBYY не несет никакой ответственности за любые убытки, вызванные использованием Вами встраиваемых шрифтов.

12.2 Библиотека Adobe® PDF Library.

12.2.1 «ПО Adobe» означает Технологию Adobe® и сопутствующую документацию, а также любые новые версии, измененные версии, обновления, дополнения или копии вышеперечисленного.

12.2.2 Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Adobe в соответствии с условиями настоящего Лицензионного договора. Вы имеете право сделать одну резервную копию ПО Adobe при условии, что резервная копия не устанавливается на другой Компьютер и не используется на другом Компьютере.

12.2.3 Права на интеллектуальную собственность. ПО Adobe, входящее в состав ПО, является собственностью Adobe и поставщиков Adobe, а его структура, организация и программный код являются значимой коммерческой тайной Adobe и поставщиков Adobe. ПО Adobe также защищено законами США об авторском праве и международными соглашениями. Вы не имеете права копировать ПО Adobe за исключением случаев, оговоренных в настоящем Лицензионном договоре. Все копии, которые Вы имеете право сделать в соответствии с настоящим Лицензионным договором, должны включать в себя те же уведомления об авторских правах и о правах собственности, которые содержатся в или на ПО Adobe. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Adobe. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких прав на интеллектуальную собственность в отношении ПО Adobe.

12.2.4 Лицензия на использование шрифтов. В случае если ПО Adobe включает шрифты, Вы можете встраивать шрифты или контуры шрифтов в Ваши электронные документы в той мере, в какой производитель шрифта, обладающий авторскими правами на него, допускает подобное встраивание. Данный комплект может содержать как принадлежащие, так и не принадлежащие Adobe шрифты. Вы имеете право полностью встраивать любые шрифты, принадлежащие Adobe.

12.2.5 Гарантия. КОМПАНИЯ ABBYY И ЕЕ ПОСТАВЩИКИ НЕ ГАРАНТИРУЮТ И НЕ МОГУТ ГАРАНТИРОВАТЬ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО ADOBE, ВХОДЯЩЕГО В СОСТАВ ПО.

12.2.6 Экспортные ограничения. Вы согласны с тем, что ПО Adobe не будет поставляться, передаваться или экспортироваться в другие страны или использоваться в нарушение Закона США о контроле над экспортом (The United States Export Administration Act) или иных нормативно-правовых актов, накладывающих экспортные ограничения (далее все вместе – «Экспортные ограничения»). Кроме того, в случае если ПО Adobe в экспортных ограничениях определено как продукт, подлежащий экспортному контролю, Вы гарантируете, что не являетесь гражданином страны, на которую наложено эмбарго, не находитесь в такой стране и что экспортными ограничениями Вам не запрещено приобретать ПО Adobe, входящее в состав ПО. В случае несоблюдения Вами условий настоящего Лицензионного договора Вы лишаетесь всех прав на использование ПО Adobe предоставленных Вам настоящим Лицензионным договором.

12.2.7 Товарные знаки. Adobe и Adobe PDF Library являются товарными знаками или зарегистрированными товарными знаками компании Adobe Systems Incorporated в США и/или в других странах.

12.3 Библиотеки PixTools® Scan Runtime.

12.3.1 «ПО EMC» означает библиотеки PixTools Scan, драйверы Level 1 ISIS, драйверы Level 2 ISIS, и драйверы Level 3 ISIS. ПО может использовать ПО EMC для осуществления обмена данными между сканером и ПО через интерфейс ISIS.

12.3.2 Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО EMC, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора.

12.3.3 Права на интеллектуальную собственность. ПО EMC, входящее в состав ПО, является собственностью EMC Corporation и поставщиков EMC Corporation, а его структура, организация и программный код являются производственным секретом EMC Corporation и поставщиков EMC Corporation. ПО EMC также защищено законами США об авторском праве и международными соглашениями. Вы не имеете права копировать ПО EMC, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО EMC, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких прав на интеллектуальную собственность в отношении ПО EMC.

12.3.4 ГАРАНТИЯ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО EMC, ВХОДЯЩЕГО В СОСТАВ ПО. EMC CORPORATION И ПОСТАВЩИКИ EMC CORPORATION НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ УПУЩЕННУЮ ВЫГОДУ ИЛИ ПОТЕРЯННЫЕ СБЕРЕЖЕНИЯ, РАВНО КАК И ЗА ПРЕТЕНЗИИ, ПРЕДЪЯВЛЕННЫЕ ТРЕТЬИМИ ЛИЦАМИ.

Некоторые штаты и юрисдикции запрещают исключение или ограничение ответственности за косвенные или специальные убытки, поэтому вышеперечисленные ограничения могут на Вас не распространяться. У Вас могут быть и другие права, которые зависят от штата и юрисдикции.

12.3.5 Товарные знаки. ISIS и PixTools являются товарными знаками или зарегистрированными товарными знаками EMC Corporation в Соединенных Штатах Америки и/или в других странах.

12.4 Программное обеспечение Cuminas DjV ® SDK.

12.4.1 Вы, являясь конечным пользователем, имеете право использовать DjVu SDK в составе ПО Компании ABBYY в течение всего срока действия исключительного права на такое ПО или в течение более короткого срока, указанного в Лицензионном соглашении с конечным пользователем.

12.4.2 Условия лицензии. Вы не имеете права осуществлять самостоятельно или предоставлять возможность третьим лицам изучать, исследовать или испытывать функционирование ПО в целях определения идей и принципов, лежащих в основе любого элемента или компонента ПО, дизассемблировать, декомпилировать (воспроизводить и преобразовывать объектный код в исходный текст) или иным способом осуществлять попытку получить исходный текст ПО или любой части либо компонента ПО любым другим образом, за исключением случаев, разрешенных применимым законодательством, несмотря на данное ограничение, и только в объеме, разрешенном применимым законодательством. Если применимое законодательство запрещает ограничение подобных действий, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть немедленно сообщена Компании ABBYY. Любая подобная информация является конфиденциальной и принадлежит Компании ABBYY.

12.4.3 КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ ИЛИ УСЛОВИЙ (ПРЯМЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ЗАКОНОДАТЕЛЬСТВОМ, ОБЩИМ ПРАВОМ, ОБЫЧНЫМ ПРАВОМ И ОБЫЧАЯМИ ДЕЛОВОГО ОБОРОТА) ОТНОСИТЕЛЬНО ЧЕГО БЫ ТО НИ БЫЛО, ВКЛЮЧАЯ БЕЗ ОГРАНИЧЕНИЯ ГАРАНТИИ О СОБЛЮДЕНИИ ПРАВ ТРЕТЬИХ ЛИЦ, ТОВАРНОЙ ПРИГОДНОСТИ, ИНТЕГРИРУЕМОСТИ, УДОВЛЕТВОРИТЕЛЬНОГО КАЧЕСТВА И ГОДНОСТИ К ИСПОЛЬЗОВАНИЮ ДЛЯ ВЫПОЛНЕНИЯ КОНКРЕТНЫХ ЗАДАЧ. КОМПАНИЯ ABBYY ТАКЖЕ НЕ ГАРАНТИРУЕТ, ЧТО ПО НЕ СОДЕРЖИТ ОШИБОК, БУДЕТ УДОВЛЕТВОРЯТЬ ВАШИМ ТРЕБОВАНИЯМ ИЛИ ЧТО ПО БУДЕТ ФУНКЦИОНИРОВАТЬ ДОЛЖНЫМ ОБРАЗОМ ПРИ ИСПОЛЬЗОВАНИИ СОВМЕСТНО С ЛЮБЫМ ДРУГИМ ПРОГРАММНЫМ ИЛИ АППАРАТНЫМ ОБЕСПЕЧЕНИЕМ. КОМПАНИЯ ABBYY НЕ ГАРАНТИРУЕТ И НЕ МОЖЕТ ГАРАНТИРОВАТЬ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО. ВСЕ РИСКИ, СВЯЗАННЫЕ С КАЧЕСТВОМ РАБОТЫ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПО, ВОЗЛАГАЮТСЯ НА ВАС. ТАКЖЕ, КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ ОТНОСИТЕЛЬНО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ ТРЕТЬИХ ЛИЦ, КОТОРОЕ МОЖЕТ БЫТЬ ПОСТАВЛЕНО ВМЕСТЕ С ПО.

12.4.4 КОМПАНИЯ ABBYY НИ ПРИ КАКИХ ОБСТОЯТЕЛЬСТВАХ НЕ ДОЛЖНА НЕСТИ ПЕРЕД ВАМИ НИКАКУЮ ОТВЕТСТВЕННОСТЬ ЗА УЩЕРБ, ВЫНУЖДЕННЫЕ ПЕРЕРЫВЫ В ДЕЛОВОЙ АКТИВНОСТИ, ПОТЕРЮ ДЕЛОВЫХ ЛИБО ИНЫХ ДАННЫХ ИЛИ ИНФОРМАЦИИ, ЗА ПРЕТЕНЗИИ ИЛИ РАСХОДЫ, КОСВЕННЫЕ, ОПОСРЕДОВАННЫЕ, СЛУЧАЙНЫЕ, ФАКТИЧЕСКИЕ ИЛИ ШТРАФНЫЕ УБЫТКИ, А ТАКЖЕ УПУЩЕННУЮ ВЫГОДУ И УТЕРЯННЫЕ СБЕРЕЖЕНИЯ, ВЫЗВАННЫЕ ИСПОЛЬЗОВАНИЕМ И/ИЛИ СВЯЗАННЫЕ С ИСПОЛЬЗОВАНИЕМ ПО, А ТАКЖЕ ЗА УЩЕРБ, ВЫЗВАННЫЙ ВОЗМОЖНЫМИ ОШИБКАМИ И ОПЕЧАТКАМИ В ПО, ДАЖЕ ЕСЛИ ПРЕДСТАВИТЕЛЮ КОМПАНИИ ABBYY СТАЛО ИЗВЕСТНО О ВОЗМОЖНОСТИ ТАКОГО УЩЕРБА, ПОТЕРЬ, ПРЕТЕНЗИЙ ИЛИ РАСХОДОВ, РАВНО КАК И ЗА ЛЮБЫЕ ПРЕТЕНЗИИ СО СТОРОНЫ ТРЕТЬИХ ЛИЦ. ВЫШЕПЕРЕЧИСЛЕННЫЕ ОГРАНИЧЕНИЯ И ИСКЛЮЧЕНИЯ ДЕЙСТВУЮТ В ТОЙ СТЕПЕНИ, НАСКОЛЬКО ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ. В ЛЮБОМ СЛУЧАЕ ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY В СВЯЗИ С ПО ОГРАНИЧИВАЕТСЯ СУММОЙ, КОТОРУЮ ВЫ УПЛАТИЛИ ЗА ЛИЦЕНЗИЮ НА ПО, ЕСЛИ ТАКОВАЯ БЫЛА УПЛАЧЕНА.

12.4.5 Ограничения на ПО, приобретенное в США:

a) Использование правительственными учреждениями. В случае если ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных - Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

b) Ограничения на экспорт. Запрещается экспортировать или реэкспортировать данное ПО в нарушение экспортных ограничений, установленных законодательством страны, в которой ПО было приобретено или получено. Вы подтверждаете и гарантируете, что применимое законодательство не запрещает Вам получать данное ПО.

12.4.6 Программный код третьих лиц:

12.4.6.1 Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Разрешается распространение и использование в исходном и двоичном формате при соблюдении следующих условий. В распространяемом исходном коде должно быть сохранено вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности. При распространении в двоичном формате вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности должны быть воспроизведены в документации и/или в иных материалах, поставляемых совместно с распространяемыми файлами.

АВТОР И СОАВТОРЫ ПРЕДОСТАВЛЯЮТ НАСТОЯЩЕЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ТАКИМ, КАКОВО ОНО ЕСТЬ, И ОТКАЗЫВАЮТСЯ ОТ ПРЕДОСТАВЛЕНИЯ КАКИХ БЫ ТО НИ БЫЛО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ КАКОЙ-ЛИБО КОНКРЕТНОЙ ЦЕЛИ. АВТОР И СОАВТОРЫ НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ, КОСВЕННЫЕ, СЛУЧАЙНЫЕ ЛИБО ФАКТИЧЕСКИЕ УБЫТКИ (ВКЛЮЧАЯ ПРИОБРЕТЕНИЕ ТОВАРОВ ИЛИ УСЛУГ-ЗАМЕНИТЕЛЕЙ, НЕВОЗМОЖНОСТЬ ДАЛЬНЕЙШЕГО ИСПОЛЬЗОВАНИЯ, ПОТЕРЮ ДАННЫХ, УПУЩЕННУЮ ВЫГОДУ И ВЫНУЖДЕННЫЙ ПЕРЕРЫВ В ХОЗЯЙСТВЕННОЙ ДЕЯТЕЛЬНОСТИ) НЕЗАВИСИМО ОТ ТОГО, ЧЕМ ОНИ ВЫЗВАНЫ, И НЕЗАВИСИМО ОТ ДОКТРИНЫ ОТВЕТСТВЕННОСТИ, БУДЬ ТО КОНТРАКТ, ОБЪЕКТИВНАЯ ОТВЕТСТВЕННОСТЬ ИЛИ ДЕЛИКТ (ВКЛЮЧАЯ ИЛИ НЕ ВКЛЮЧАЯ НЕБРЕЖНОСТЬ), КОТОРЫЕ ВОЗНИКЛИ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ НАСТОЯЩЕГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ, ДАЖЕ ЕСЛИ АВТОРЫ И СОАВТОРЫ БЫЛИ ПОСТАВЛЕНЫ В ИЗВЕСТНОСТЬ О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ.

12.4.6.2 Часть настоящего программного обеспечения основана на алгоритме MD5 Message-Digest Algorithm компании RSA Data Security, Inc. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. Все права защищены.

Разрешается распространение и использование в исходном и двоичном формате при соблюдении следующих условий. В распространяемом исходном коде должно быть сохранено вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности. При распространении в двоичном формате вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности должны быть воспроизведены в документации и/или в иных материалах, поставляемых совместно с распространяемыми файлами. Наименование университета Хиросимы и имена авторов не должны использоваться для рекламы или продвижения продуктов, созданных на основе настоящего программного обеспечения, без их предварительного письменного согласия.

ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ И СОАВТОРЫ ПРЕДОСТАВЛЯЮТ НАСТОЯЩЕЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ТАКИМ, КАКОВО ОНО ЕСТЬ, И ОТКАЗЫВАЮТСЯ ОТ ПРЕДОСТАВЛЕНИЯ КАКИХ БЫ ТО НИ БЫЛО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ КАКОЙ-ЛИБО КОНКРЕТНОЙ ЦЕЛИ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ И СОАВТОРЫ НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ, КОСВЕННЫЕ, СЛУЧАЙНЫЕ ЛИБО ФАКТИЧЕСКИЕ УБЫТКИ (ВКЛЮЧАЯ ПРИОБРЕТЕНИЕ ТОВАРОВ ИЛИ УСЛУГ-ЗАМЕНИТЕЛЕЙ, НЕВОЗМОЖНОСТЬ ДАЛЬНЕЙШЕГО ИСПОЛЬЗОВАНИЯ, ПОТЕРЮ ДАННЫХ, УПУЩЕННУЮ ВЫГОДУ И ВЫНУЖДЕННЫЙ ПЕРЕРЫВ В ХОЗЯЙСТВЕННОЙ ДЕЯТЕЛЬНОСТИ) НЕЗАВИСИМО ОТ ТОГО, ЧЕМ ОНИ ВЫЗВАНЫ, И НЕЗАВИСИМО ОТ ДОКТРИНЫ ОТВЕТСТВЕННОСТИ, БУДЬ ТО КОНТРАКТ, ОБЪЕКТИВНАЯ ОТВЕТСТВЕННОСТЬ ИЛИ ДЕЛИКТ (ВКЛЮЧАЯ ИЛИ НЕ ВКЛЮЧАЯ НЕБРЕЖНОСТЬ), КОТОРЫЕ ВОЗНИКЛИ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ НАСТОЯЩЕГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ, ДАЖЕ ЕСЛИ АВТОРЫ И СОАВТОРЫ БЫЛИ ПОСТАВЛЕНЫ В ИЗВЕСТНОСТЬ О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ.

12.5 Wibu-Systems

12.5.1 WIBU, CodeMeter, SmartShelter, SmartBind являются зарегистрированными товарными знаками Wibu-Systems.

12.6 Другие лицензируемые технологии. Настоящее ПО используется согласно лицензиям на патенты США № 5 625 465 и 5 768 416.

13. Применимое право

13.1 В случае если Вы приобрели ПО на территории США, Белиза, Виргинских Островов, Гватемалы, Гондураса, Канады, Коста-Рики, Мексики, Монтсеррата, Никарагуа, Панамы, Сальвадора, Тайваня, островов Теркс и Кайкос или Японии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство штата Калифорния Соединенных Штатов Америки. Вы согласны с тем, что, в случае, если Вы приобрели ПО на территории Соединенных Штатов Америки, то ПО продано Вам ABBYY USA Software House Inc. и все споры в отношении настоящего Лицензионного договора и/или ПО подлежат разрешению исключительно в федеральном суде и/или суде штата в округе Санта-Клара штата Калифорния.

13.2 В случае, если Вы приобрели ПО на территории Австрии, Бельгии, Германии, Дании, Испании, Италии, Люксембурга, Нидерландов, Португалии, Финляндии, Франции, Швеции или на территории любого другого государства, являющегося членом Европейского Союза, за исключением Греции, Кипра и Мальты, и не указанного явно в п.п.13.3, 13.4 или 13.5 настоящего Лицензионного договора, а также на территории Исландии, Лихтенштейна, Норвегии, или Швейцарии, к отношениям по настоящему Лицензионному договору применяется материальное право, действующее в г. Мюнхене, республика Германия. Все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в суде г. Мюнхена.

13.3 В случае, если Вы приобрели ПО на территории Великобритании или Республики Ирландии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство Англии и Уэльса. Все споры, вытекающие из настоящего Лицензионного договора подлежат разрешению исключительно в судах Англии и Уэльса.

13.4 В случае, если Вы приобрели ПО на территории России, Белоруссии, Казахстана или другого государства, являющегося членом Содружества Независимых Государств (СНГ), за исключением Украины и Молдавии, а также на территории Эстонии, Грузии, Латвии и Литвы, к отношениям по настоящему Лицензионному договору применяется материальное право Российской Федерации.

13.5 В случае, если Вы приобрели ПО на территории Албании, Болгарии, Боснии и Герцеговины, Греческой Республики, Венгрии, Израиля, Македонии, Польши, Румынии, Словакии, Словении, Турции, Хорватии, Чехии, Сербии, Черногории, Украины или Молдавии, к отношениям по настоящему Лицензионному договору применяется материальное право Украины, за исключением случаев, когда ПО было приобретено лицом, имеющим статус потребителя в соответствии с Гражданским кодексом Польши. Законодательство Польши применяется к таким потребителям.

13.6 В случае, если ПО было приобретено в стране, указанной в п. 13.5 и Вы являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в Международном Коммерческом Арбитражном суде при Торгово-промышленной палате Украины в соответствии с правилами и процедурами, установленными его Регламентом. Решение Международного Коммерческого Арбитражного суда при Торгово-промышленной палате Украины является окончательным и подлежит обязательному исполнению. В случае если ПО было приобретено в стране, указанной в п. 13.5 и Вы являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Шевченковском районном суде г. Киева.

13.7 В случае если ПО было приобретено в стране, указанной в п. 13.4 и Вы являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в Арбитражном суде г. Москвы, Российская Федерация. В случае если ПО было приобретено в стране, указанной в п.13.4 и Вы являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Кузьминском районном суде г. Москвы.

13.8 В случае если ПО было приобретено в стране, указанной в п.п. 13.1-13.5, к отношениям по настоящему Лицензионному договору не применяются никакие коллизионные нормы, а также нормы Конвенции ООН о договорах международной купли-продажи товаров.

13.9 В случае если ПО было приобретено в стране, не указанной в п.п. 13.1 - 13.5, к отношениям по настоящему Лицензионному договору применяется действующее законодательство страны, в которой Вы приобрели ПО.

14. Срок действия

14.1 Если иное не оговорено в настоящем Лицензионном договоре или в документации к ПО, либо в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, настоящий Лицензионный договор действует неограниченно, начиная с даты, когда Вы в первый раз выразили свое согласие с его условиями, как это описано в начале настоящего Лицензионного договора, или в течение всего срока, разрешенного применимым законодательством. В случае если в соответствии с применимым законодательством необходимо указать срока действия настоящего Лицензионного договора, настоящий Лицензионный договор действует в течение всего срока, разрешенного применимым законодательством, но не меньше, чем срок действия исключительного права на ПО, и без предварительного уведомления автоматически прекращает действие по истечении этого срока.

14.2 Без ущерба для каких-либо других прав Компания ABBYY имеет право расторгнуть Лицензионный договор в случае нарушения Вами положений и условий Лицензионного договора. В этом случае Вы обязаны уничтожить все экземпляры ПО и Компонентов ПО и удалить ПО с ваших Компьютеров.

14.3 Вы можете расторгнуть настоящий Лицензионный договор, уничтожив все экземпляры ПО, все Компоненты и удалив ПО.

14.4 Такое расторжение настоящего Лицензионного договора не освобождает Вас от обязательств оплатить приобретение ПО. Вне зависимости от причин расторжения или прекращения действия Лицензионного договора, Разделы 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 и п. 3.4.4 сохраняют свою силу и после расторжения или прекращения действия Лицензионного договора, однако это не дает Вам права продолжать использовать ПО после расторжения или прекращения действия настоящего Лицензионного договора.

15. Прочие условия

15.1 В процессе Активации, установки и работы, а также при оказании технической поддержки в отношении ПО Компания ABBYY может запросить у Вас определенные персональные данные (в частности, Ваше имя, адрес, адрес электронной почты, номер телефона). Настоящим Вы соглашаетесь предоставить Компании ABBYY такие персональные данные. Вы имеете право отказаться от предоставления Ваших персональных данных Компании ABBYY, что может привести к отказу со стороны Компании ABBYY оказать Вам техническую поддержку в отношении ПО, которая оказывается клиентам Компании ABBYY, предоставившим свои персональные данные, если предоставление персональных данных необходимо для оказания технической поддержки или является одним из условий оказания технической поддержки и не противоречит применимому законодательству. Вы согласны не предоставлять больше персональных данных, чем запрашивает Компания ABBYY или Партнер Компании ABBYY и согласны с тем, что Ваши персональные данные могут обрабатываться (в том числе собираться и/или иным образом использоваться) Компанией ABBYY, аффилированными лицами Компании ABBYY и/или Партнерами Компании ABBYY в соответствии с применимыми законами и при условии соблюдения конфиденциальности и обеспечения защиты предоставленных данных, если это предусмотрено применимым законодательством. Все персональные данные, которые Вы предоставите Компании ABBYY, аффилированным лицам Компании ABBYY или Партнерам Компании ABBYY будут обрабатываться, храниться и использоваться исключительно внутри Компании ABBYY, аффилированных лиц Компании ABBYY или Партнеров Компании ABBYY и не будут раскрываться третьим лицам, если только такое раскрытие не требуется применимым законодательством, а в случае хранения и обработки данных компанией ABBYY Software House Inc. на них распространяется политика конфиденциальности, текст которой находится по адресу http://abbyy.com/privacy_policy. Персональные данные будут обрабатываться исключительно с целью выполнения Компанией ABBYY своих обязательств по настоящему Лицензионному договору. В случае если Вы приобрели ПО в стране, указанной в п. 13.5, Ваши персональные данные будут обрабатываться в базе данных под названием «Физические лица, персональные данные которых обрабатываются при осуществлении деловых операций».

15.2 Вы согласны с тем, что ПО может соединяться с сервером Компании ABBYY через интернет или по электронной почте в процессе Активации, деактивации или обновления. Компания ABBYY предпримет разумные шаги с целью предотвратить передачу Ваших персональных данных во время таких соединений.

15.3 Компания ABBYY имеет право присылать Вам письма по электронной почте, содержащие новости о продуктах и о Компании ABBYY, информацию о специальных предложениях, советы по использованию продуктов и другую информацию, связанную с деятельностью и продуктами Компании ABBYY, при условии, что Вы явным образом согласились получать такую информацию от Компании ABBYY. Вы можете в любое время обратиться к Компании ABBYY с просьбой удалить адрес Вашей электронной почты из списка рассылки Компании ABBYY.

15.4 В случае предъявления Вам претензий или исков в связи с использованием Вами ПО, Вы обязуетесь сообщить Компании ABBYY о таких фактах в течение трех (3) календарных дней с момента, когда Вам стало известно об их возникновении. Вы обязуетесь совершить все необходимые действия для предоставления Компании ABBYY возможности участвовать в рассмотрении таких претензий или исков в суде, а также предоставлять необходимую информацию для урегулирования соответствующих претензий или исков не позднее семи (7) календарных дней с даты получения запроса от Компании ABBYY.

15.5 Вознаграждением по настоящему Лицензионному договору признается стоимость Лицензии на ПО, установленная Компанией ABBYY или Партнером Компании ABBYY, которая подлежит уплате в соответствии с определяемым Компанией ABBYY или Партнером Компании ABBYY порядком, либо входит в стоимость приобретенного Вами оборудования или аппаратных средств, либо является частью вознаграждения, которое подлежит уплате в случае приобретения Вами полной версии ПО. В случае если Вы являетесь физическим лицом, настоящий Лицензионный договор может быть безвозмездным.

15.6 В случае если какая-либо часть настоящего Лицензионного договора будет признана утратившей юридическую силу, недействительной или не подлежащей исполнению, остальные части Лицензионного договора сохраняют свою юридическую силу и подлежат исполнению.

Collapsed Лицензионный договор с конечным пользователем на английском языке

End-User License Agreement (EULA)

ABBYY® FlexiCapture®

Important! Read the following terms carefully before installing, copying and/or otherwise using ABBYY FlexiCapture (hereinafter referred to as “the SOFTWARE”). Installing, copying or otherwise using the SOFTWARE indicates Your acceptance of these terms. This End-User License Agreement (hereinafter referred to as the “EULA”) is a legal agreement between you, the end user, who obtained or is using the SOFTWARE, and ABBYY.

This EULA comes into force when You demonstrate your consent to be bound by its terms by selecting the “I accept the terms of the license agreement” button followed by selecting the “next” button and installing the SOFTWARE or when You install, copy or start using the SOFTWARE in any manner. Any such act is deemed to demonstrate Your acknowledgment that you have read this EULA, that You understand it and agree to be bound by its terms. If You do not agree to the terms of this EULA, do not use the SOFTWARE and disable, remove it from Your system and destroy Your copies of the SOFTWARE. This EULA is binding for the entire period of the SOFTWARE copyright unless otherwise stated in this EULA or in a separate written agreement between You and ABBYY or ABBYY’s Partner and may depend on the scope of the License as it is described in the EULA.

The SOFTWARE is protected by copyright laws and international treaty provisions and some portions are protected by patent and trade secret laws. You agree that this EULA is enforceable like any written negotiated agreement signed by you. This EULA is enforceable against You.

If the SOFTWARE is accompanied by a hard copy of separate agreement with ABBYY or an ABBYY Partner, governing terms of Your use of the SOFTWARE, then, in the case of any discrepancies in content between the text of this EULA and the text in the hard copy of such separate agreement, the text in the hard copy of the separate agreement shall prevail.

The EULA may be available in different languages. There may be inconsistencies or differences in interpretation between the English version of the EULA and those EULAs made available in other languages. For the sake of uniformity and to avoid any ambiguity, the English version of the EULA shall govern in all disputes, claims or proceedings to interpret, enforce or otherwise relating to the EULA.

Definitions

“ABBYY” means

ABBYY USA Software House Inc. registered at 880 North McCarthy Boulevard, Suite 220, Milpitas, California, 95035, USA, when article 13.1 of this EULA applies;

ABBYY Europe GmbH registered at Elsenheimerstrasse, 49, 80687, Munich, Germany, when article 13.2 of this EULA applies;

ABBYY UK Ltd. Registered at Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, United Kingdom, when article 13.3 of this EULA applies;

ABBYY Production LLC registered at 1-ya ul. Tekstilshikov, d. 12/9, office 2, 109390, Moscow, Russia, when article 13.4 of this EULA applies;

ABBYY Software House Ukraine registered at 31, Degtyarevskaya st., Kiev, Ukraine, 03680, when article 13.5 of this EULA applies;

and ABBYY Solutions Ltd., registered at Michail Karaoli 2, Egkomi, CY 2404, Nicosia, Cyprus, in all other cases.

“ABBYY Partner” means an entity or individual who is licensed by ABBYY to resell and distribute licensed copies of the SOFTWARE to End Users, either directly or through one or more sub-resellers or sub-distributors.

“Activation” means the procedure whereby the Serial number is checked for validity and the installed SOFTWARE is made fully operational in accordance with the SOFTWARE documentation and the scope of Your License.

“Computer” means a specific physical device or virtual machine that may consist of one or more CPU (central processing unit) cores and running specified operating system. Any changes to the configuration or composition of the Computer could result in the Computer being considered a different Computer for licensing purposes.“Intellectual Property Rights” means all intellectual and industrial property rights and includes rights to (i) inventions, discoveries, and letters patent including applications therefor, reissues thereof, and continuation and continuations in part; (ii) copyrights; (iii) designs and industrial designs; (iv) trademarks, service marks, trade dress and similar rights; (v) know-how, trade secrets and confidential information; (vi) integrated circuit topography rights and rights in mask works; and (vii) other proprietary rights.

“License” means the non-exclusive limited right granted to You by ABBYY to install and use the functionality of the SOFTWARE in accordance with the terms and conditions of this EULA.

“Serial number” means a unique identifier of License or License group with similar parameters that is being given by ABBYY or an ABBYY Partner to the End User.

“SOFTWARE” means any version or edition of ABBYY FlexiCapture including any and all software components (add-ons, custom components and modules, etc.) embedded in the software or made available online or by other ways such as: executable, help, demo, sample and other files; libraries, databases, samples, associated media (images, photos, animation, audio-video components, music etc.), printed materials, and other software components.

“You”, “Your” and “End User” refer to and include any person and/or any entity that obtained this SOFTWARE for its own use and not for purposes of further resale and any actual user of the SOFTWARE.

1. License Grant

1.1 Subject to the terms and conditions of the EULA ABBYY grants to You a limited, non-exclusive License to install and use functionality of the SOFTWARE subject to all restrictions and the scope of the License as may be provided by: this EULA, the software and/or hardware license keys provided by ABBYY (“License Key”), the SOFTWARE, and/or a separate written agreement between You and ABBYY or an ABBYY Partner. All provisions stated herein apply both to the SOFTWARE as a whole and to all of its separate components. Any issue with respect to the scope of the license shall be construed in favour of restrictions on the scope of the license. The License Key technically restricts the use of the SOFTWARE and reflects the scope of the License You obtained. Restrictions on Your use of the SOFTWARE and the scope of Your License may include but are not limited to the following:

1.1.1 Number of seats, SOFTWARE components and network access. You may install the SOFTWARE on more than one Computer on a Network and simultaneously use specified components of the SOFTWARE on a specified number of Computers on a Network (“concurrent licensing”). Information about the available SOFTWARE components and the number of Computers on a Network allowed for simultaneous work with the SOFTWARE is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.2 Processing volume. The number of pages that may be processed by the SOFTWARE may be limited in one or more ways, such as limitations on the number of pages that may be processed within particular time periods, such as monthly or annually, or on the overall number of pages that may be processed. The size of the page and the number of data fields per document may also be limited. Processing volume limitations are specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner

1.1.3 Duration. Use of the SOFTWARE may be limited by a fixed period of time, and the SOFTWARE may not be used beyond the expiration of such time period. Limitation of the duration is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.4 Features, add-ons and custom components. The use of particular features, add-ons and/or custom components of the SOFTWARE may be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.2 Processing power. The number of CPU (central processing unit) cores of the Computers which can be utilized by the SOFTWARE may also be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner. All rights not expressly granted to You by the EULA are reserved by ABBYY. This EULA does not grant You any rights in connection with any trademarks of ABBYY.

1.3 If Article 13.4 applies and You are an individual human being person, You may use the SOFTWARE worldwide. If Article 13.4 applies and You are an entity, the SOFTWARE may be obtained (purchased) only in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner. The employees of the entity or of its branch and representative offices may use the SOFTWARE worldwide, provided the SOFTWARE has been obtained and installed in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner.

1.4 Any use of the SOFTWARE or component parts outside of or in contravention of the terms and conditions of this EULA shall constitute a breach of ABBYY’s and/or third parties’ intellectual property rights and shall give cause for the revocation of all rights to use the SOFTWARE granted to You under this EULA.

1.5 If You deploy or use the SOFTWARE in a virtual environment, at no time may access or use of the SOFTWARE exceed the restrictions on the SOFTWARE, or the scope of the license that has been granted. For instance, the same License Key may not be used to permit use or access to the SOFTWARE in a virtual environment by a number of Computers that is greater than the number of Computers for which a license has been properly obtained, nor may the SOFTWARE be used to process more than the total number of pages that has been permitted.

1.6 If You deploy the SOFTWARE by using terminal services which allow accessing the SOFTWARE on a remote computer over a network, the amount of simultaneously running instances of the SOFTWARE may not exceed the number of Computers for which a License has been obtained.

1.7 If You use the SOFTWARE by means of a web browser, You may simultaneously access the SOFTWARE by as many Computers as permitted by the scope of Your License and specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.8 You may receive the SOFTWARE on more than one medium (multiple-media SOFTWARE), including downloads over the Internet. Regardless of the quantity or type of media You receive, You are only licensed to use the SOFTWARE in accordance with the scope of the SOFTWARE License.

2. Limitations of Use

2.1 In order to use the SOFTWARE You should perform Activation of the SOFTWARE after installation.

2.2 All terms of use and limitations governing the use of the SOFTWARE are stated in this EULA, unless otherwise stipulated in a separate written agreement between You and ABBYY or an ABBYY Partner or in other documentation accompanying the SOFTWARE.

2.3 You may not perform or make it possible for other persons to perform any activities included in the list below:

2.3.1 Reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

2.3.2 Modify, adapt (including any changes for the purpose of enabling the SOFTWARE to run on Your hardware), or make any changes to the object code of the Software, applications and databases contained in the SOFTWARE other than those provided for by the SOFTWARE and described in the documentation.

2.3.3 Correct errors in the SOFTWARE or translate the SOFTWARE without the prior written consent of ABBYY.

2.3.4 Rent, lease, sublicense, assign or transfer any rights granted to You by this EULA and other rights related to the SOFTWARE to any other person or authorize all or any portion of the SOFTWARE to be copied onto another computers (except as described in article 2.6)

2.3.5 Make it possible for any person not entitled to use the SOFTWARE to access and/or use the SOFTWARE, including without limitation in a multi-user system, virtual environment, or via the Internet.

2.3.6 Remove, change or obscure any copyright, trademark or patent notices that appear on the SOFTWARE as delivered to You.

2.4 You may not use the SOFTWARE to provide paid or free recognition or conversion services and/or to provide the results or access to the results acquired through the use of the SOFTWARE as a part of another service that has recognition or conversion as its component to any third party unless You have signed a separate written agreement with ABBYY and Your License Key has the parameter “BPO services” enabled.

2.5 You may not bypass the SOFTWARE’s user interface that is provided with the SOFTWARE, without an additional written agreement with ABBYY.

2.6 You may only make a one-time permanent transfer of this SOFTWARE only directly to another end user. If you are an entity, such a transfer requires written approval by ABBYY. This transfer must include all of the SOFTWARE (including all copies, SOFTWARE Components, the media and printed materials, any updates) and this EULA. Such transfer may not be by way of consignment or any other indirect transfer. The transferee of such one-time transfer must agree to comply with the terms of this EULA, including the obligation not to further transfer this SOFTWARE. You must uninstall the SOFTWARE from all of Your Computers or from Your Local Area Network in the case of such SOFTWARE transfer.

3. Pre-release, Trial or Demo SOFTWARE

3.1 If the SOFTWARE You have received with this License is a pre-commercial release or Beta-Release Software, provided for a trial or for demonstration, verification or testing purposes, has limited or less than full functionality, labeled “Try&Buy” “Trial”, “Demo” or was provided at no charge (“Restricted Software”), then this article 3 shall apply until such time that You obtain (purchase) a license for the full version of the SOFTWARE. To the extent that any provision in this is in conflict with any other term or condition in this EULA, this article shall supersede such other term(s) and condition(s) with respect to the Restricted Software, but only to the extent necessary to resolve the conflict.

3.2 THE RESTRICTED SOFTWARE IS PROVIDED TO YOU “AS IS” AND WITHOUT WARRANTY OR INDEMNITY (EXPRESS, IMPLIED OR STATUTORY) OF ANY KIND. THE RESTRICTED SOFTWARE DOES NOT REPRESENT FINAL SOFTWARE FROM ABBYY, AND MAY CONTAIN BUGS, ERRORS AND OTHER PROBLEMS THAT COULD CAUSE SYSTEM OR OTHER FAILURES AND DATA LOSS. TO THE GREATEST EXTENT ALLOWABLE UNDER APPLICABLE LAWS, NO WARRANTY SHALL APPLY TO THE RESTRICTED SOFTWARE, AND FOR CLARITY YOU ACKNOWLEDGE THAT ABBYY DISCLAIMS ANY WARRANTY OR LIABILITY OBLIGATIONS TO YOU OF ANY KIND, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF TITLE, MERCHANTABILITY, NON-INFRINGEMENT, QUIET ENJOYMENT, AND FITNESS FOR A PARTICULAR PURPOSE. WHERE LIABILITY CANNOT BE EXCLUDED BUT MAY BE LIMITED, ABBYY’S TOTAL LIABILITY AND THAT OF ITS PARTNERS SHALL BE LIMITED TO THE SUM OF FIFTY UNITED STATES DOLLARS (U.S. $50) OR THE TOTAL AMOUNT YOU PAID FOR THE SOFTWARE, WHICHEVER IS GREATER.

3.3 Restricted Software may have limited functionality, such as having functionality for a limited period of time, and upon expiration of permitted functionality (“time-out”), Your access and ability to use the Restricted Software may be disabled. Upon a time-out, Your rights under the EULA shall terminate, unless You obtain a new license from ABBYY.

3.4 Restricted Software for which there has not been a commercial release.

3.4.1 Restricted Software for which there has not been a commercial release constitutes the Confidential Information of ABBYY.

3.4.2 As to Restricted Software for which there has not been a commercial release, ABBYY does not promise or guarantee, has no express or implied obligation, and You acknowledge that ABBYY has not promised or guaranteed, that such software will be further developed, or that a commercial version will be announced or made available in the future. ABBYY may not introduce a software product similar to or compatible with such software. Accordingly, You acknowledge that any use, research or development that You perform regarding such software is done entirely at Your own risk.

3.4.3 You agree to provide feedback to ABBYY regarding testing and use of the Restricted Software, including error or bug reports (“Feedback”), and to entirely transfer and grant to ABBYY all rights in such Feedback, including without limitation, the rights to use, publish and disseminate the Feedback. All Feedback constitutes the Confidential Information of ABBYY.

3.4.4 Confidentiality of Restricted Software for which there has not been a commercial release and its Results;

3.4.4.1 You agree not to disclose accompanying written, oral or electronic information divulged to You by ABBYY related to the Restricted Software for which there has not been a commercial release, any information about the quality of such Restricted Software or the quality of the results acquired through the use of such Restricted Software, Feedback, and any information about bugs, errors and other problems discovered by You in the Restricted Software for which there has not been a commercial release are the Confidential Information of ABBYY.

3.4.4.2 You shall not disclose Confidential Information. The term “disclose” means to display, describe, copy, lease, loan, rent, assign, transfer or provide access, over a network or otherwise, to Confidential Information reproduced in any form, including oral communications, to any third party.

3.4.4.3 You shall take all reasonable steps to prevent the disclosure of Confidential Information and to keep it confidential.

3.4.4.4 You shall promptly inform ABBYY if You become aware of any disclosure of Confidential Information. If You are in breach of the terms and conditions set forth in articles 3.4.4.1 - 3.4.4.3 above, You shall compensate ABBYY for any loss resulting from such breach.

3.5 Upon receipt of a later version of Restricted Software or a commercial release of such software, whether as a stand-alone product or as part of a larger product, You agree to return or destroy all earlier versions of the Restricted Software received from ABBYY.

3.6 If You have been provided the Restricted Software pursuant to a separate written agreement Your use of the SOFTWARE is also governed by such agreement. To the extent that any term or condition of a separate written agreement are in conflict with any term or condition of this EULA, a separate written agreement shall supersede such other term(s) and condition(s) with respect to the SOFTWARE, but only to the extent necessary to resolve the conflict.

4. Not-for-resale SOFTWARE

4.1 If the SOFTWARE is labeled “Not for Resale” or “NFR,” then, notwithstanding other articles of this EULA, You may only use such SOFTWARE for demonstration, verification or testing purposes.

5. Updates

5.1 If the SOFTWARE is labeled as an update, You must own a license for the previous version of the SOFTWARE identified by ABBYY as being eligible for this update in order to use the SOFTWARE.

5.2 The SOFTWARE labeled as an update replaces and/or supplements the product that formed the basis for Your eligibility for the update.

5.3 You may only use the resulting updated product in accordance with the terms of the EULA supplied with this update.

5.4 You acknowledge that any obligation ABBYY may have to support the version of the SOFTWARE being updated shall end upon the availability of the update.

6. Technical Support and Maintenance

6.1 You may be provided with technical support and maintenance related to the SOFTWARE (“Support Services”) subject to the current ABBYY support policy. However, You may be entitled to a different level of Support Services than is stated in the ABBYY support policy in accordance with a written agreement executed between You and ABBYY or an ABBYY Partner with respect to such Support Services.

6.2 General terms and conditions of the ABBYY support policy are published on the ABBYY Web site www.abbyy.com. ABBYY reserves the right to change the support policy any time without any prior notice.

6.3 In addition to the general terms and conditions, ABBYY may have specific support policies in specific regions which may be regulated by separate agreements.

6.4 Any supplementary software code and any SOFTWARE component provided to You as part of Support Services is to be considered a part of the SOFTWARE and subject to the terms and conditions of this EULA.

6.5 To be eligible for Support Services, You may be required to provide ABBYY with information about the characteristics of Your hardware, Serial Number of Your SOFTWARE as well as certain personal information, such as Your name, company name (if applicable), address, phone number and e-mail address. ABBYY may use the above-mentioned information as described in article 15.1 of the EULA.

7. Ownership.

7.1 No title to any of ABBYY’s Intellectual Property Rights (including the SOFTWARE and any ABBYY patents, trademarks, or copyrights) is transferred to You. You shall not, in any way, during or after the term of the Agreement, make any use of or claim any right to any name, logo, trademark, pattern, or design owned by ABBYY, or any name, logo, trademark, pattern, or design resembling them.

7.2 No title to any of Your Intellectual Property Rights (including the application and any of Your patents, trademarks, or copyrights) is transferred to ABBYY.

7.3 The SOFTWARE contains valuable trade secrets and confidential information belonging to ABBYY and third parties and is protected by copyright laws, including, without limitation, by United States Copyright Law, laws of Russian Federation, international treaty provisions, and the applicable laws of the country in which it is being used or obtained.

7.4 All title and rights in and to the content that is not contained in the SOFTWARE, but may be accessible through the use of the SOFTWARE, are the property of the respective content owners and may be protected by applicable copyright or other intellectual property laws and international treaties. This EULA does not grant You any rights to such intellectual property.

8. Limited Warranty. Disclaimers.

8.1 If required by the legislation of the country in which You obtained (purchased) the SOFTWARE, ABBYY warrants that the media on which the SOFTWARE is furnished will be free from defects in materials and workmanship under normal use only and only for the minimal guarantee term determined by the legislation of the country in which You obtained (purchased) the SOFTWARE starting from the date of purchase. If the SOFTWARE was obtained (purchased) in the countries defined in article 13.4 this period will constitute thirty (30) days starting from the date of obtain (purchase).

8.2 EXCEPT AS EXPPRESSLY PROVIDED IN THIS ARTICLE 8 (LIMITED WARRANTY. DISCLAIMERS), AND EXCEPT FOR ANY WARRANTY, CONDITION, REPRESENTATION, OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE SOFTWARE, INCLUDING WITHOUT LIMITATION ANY SOFTWARE DOCUMENTATION, UPGRADES AND UPDATES IS BEING DELIVERED TO YOU “AS IS” AND ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

9. Limitation of Liability

9.1 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL, SPECIAL OR PUNITIVE DAMAGES, OR ANY LOST PROFITS OR LOST REVENUE RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

10. Warranty Exclusion and Limitations for Users Residing in Germany or Austria

10.1 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then, in accordance with German law, ABBYY warrants that the SOFTWARE provides the functionalities set forth in its documentation included in the SOFTWARE (the “agreed upon functionalities”) for the limited warranty period following receipt of the SOFTWARE copy when used on the recommended hardware configuration. As used in this article, “limited warranty period” means one (1) year if You are a business user or legal entity, and two (2) years if You are not a business user. Non-substantial variation from the agreed upon functionalities shall not be considered and does not establish any warranty rights. This limited warranty does not apply to the SOFTWARE provided to You free of charge, for example, updates, pre-release versions, “Trial” versions, product samples, “Not for resale” (“NFR”) copies of the SOFTWARE, or the SOFTWARE that has been altered by You, to the extent such alterations caused a defect. To make a warranty claim, during the limited warranty period You must return, at our expense, the SOFTWARE and proof of purchase to the location where You obtained it. If the functionalities of the SOFTWARE vary substantially from the agreed upon functionalities, ABBYY is entitled (by way of re-performance and at its own discretion) to repair or replace the SOFTWARE. If this fails, You are entitled to a reduction of the purchase price (reduction) or to cancel the purchase agreement (rescission). For further warranty information, please contact ABBYY’s Customer Support Department in Germany: ABBYY Europe GmbH, Elsenheimerstrasse 49, 80687 Munich, tel.: +49 (0)89 51 11 590, fax: +49 (0)89 51 11 5959.

10.2 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then:

10.2.1 Subject to the provisions in article 10.2.2, ABBYY’s statutory liability for damages shall be limited as follows: (i) ABBYY shall be liable only up to the amount of damages as typically foreseeable at the time of entering into the purchase agreement in respect of damages caused by a slightly negligent breach of a material contractual obligation and (ii) ABBYY shall not be liable for damages caused by a slightly negligent breach of a non-material contractual obligation.

10.2.2 The limitation of liability set forth in 10.2.1 shall not apply to any mandatory statutory liability, in particular, to liability under the German Product Liability Act, liability for assuming a specific guarantee or liability for culpably caused personal injuries.

10.2.3 You are required to take all reasonable measures to avoid and reduce damages, in particular to make backup copies of the SOFTWARE and Your computer data subject to the provisions of this EULA.

11. Additional Limitations for SOFTWARE obtained in the USA

11.1 Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

11.2 Export rules. You agree that you shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12. Third-party technologies

12.1 Embedded Fonts. Font programs are subject to copyright, and the copyright owner may impose conditions under which a font program can be used. One of the conditions may be that You need a licensed copy of the font program to embed the font into a PDF file. In no event shall ABBYY be liable for any damages arising out of or in connection with Your use of embedded fonts.

12.2 Adobe® PDF Library.

12.2.1 The term “Adobe Software” includes Adobe Technology and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

12.2.2 License Grant and Restrictions. ABBYY grants You a non-exclusive right to use the Adobe Software under the terms of this EULA. You may make one backup copy of the Adobe Software, provided the backup copy is not installed or used on any computer.

12.2.3 Intellectual Property Rights. The Adobe Software incorporated into the SOFTWARE is owned by Adobe and its suppliers, and its structure, organization and code are the valuable trade secrets of Adobe and it suppliers. The Adobe Software is also protected by United States Copyright law and International Treaty provisions. You may not copy the Adobe Software, except as provided in this EULA. Any copies that You are permitted to make pursuant to this EULA must contain the same copyright and other proprietary notices that appear on or in the Adobe Software. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the Adobe Software. Except as stated above, this EULA does not grant You any intellectual property rights in the Adobe Software.

12.2.4 Font License. If the Adobe Software includes font software You may embed the font software, or outlines of the font software, into Your electronic documents to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. You may fully embed any font owned by Adobe.

12.2.5 Warranty. ABBYY AND ITS SUPPLIER DO NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE SOFTWARE.

12.2.6 Export Rules. You agree that the Adobe Software will not be shipped, transferred or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations (collectively the “Export Laws”) - In addition, if the Adobe Software is identified as export controlled items under the Export Laws, You represent and warrant that You are not a citizen, or otherwise located within, an embargoed nation and that You are not otherwise prohibited under the Export Laws from receiving the Adobe Software. All rights to use the Adobe Software are granted on condition that such rights are forfeited if You fail to comply with the terms of this EULA.

12.2.7 Trademarks. Adobe and Adobe PDF Library are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

12.3 PixTools® Scan Runtime Libraries.

12.3.1 “EMC Software” shall mean PixTools Scan runtime libraries, Level 1 ISIS Drivers, Level 2 ISIS Drivers, and Level 3 ISIS Drivers. The SOFTWARE may use the EMC Software for communicating between scanner and SOFTWARE through the ISIS interface.

12.3.2 License Grant and Restrictions. ABBYY grants you a non-exclusive right to use the EMC Software incorporated into the SOFTWARE under the terms of this EULA.

12.3.3 Intellectual Property Rights. The EMC Software incorporated into the SOFTWARE is owned by EMC Corporation and its suppliers, and its structure, organization and code are the valuable trade secrets of EMC Corporation and its suppliers. The EMC Software is protected by United States Copyright Law and International Treaty provisions. You may not copy the EMC Software incorporated into the SOFTWARE. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the EMC Software incorporated into the SOFTWARE. Except as stated above, this EULA does not grant you any intellectual property rights in the EMC Software.

12.3.4 Warranty. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE EMC SOFTWARE INCORPORATED INTO THE SOFTWARE. IN NO EVENT WILL EMC CORPORATION OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS OR FOR ANY CLAIM BY ANY THIRD PARTY.

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, so the above limitations may not apply to you. You may have other rights, which vary from state to state or jurisdiction to jurisdiction.

12.3.5 Trademarks. ISIS and PixTools are either registered trademarks or trademarks of EMC Corporation in the United States and/or other countries.

12.4 Cuminas DjVu® SDK.

12.4.1 You, as the End-User, have the right to use DjVu SDK as part of the SOFTWARE for the entire period of such SOFTWARE copyright or for another lesser term of use, stated in the EULA.

12.4.2 License terms: You may not perform or make it possible for other persons to perform reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

12.4.3 ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

12.4.4 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGE, OR ANY LOST PROFITS OR LOST SAVINGS RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

12.4.5 Limitations for SOFTWARE obtained at the USA.

a) Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

b) Export rules. You agree that You shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12.4.6 Third-Party Code:

12.4.6.1 Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.4.6.2 A portion of this software is derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Hiroshima University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.5 Wibu-Systems

12.5.1 WIBU, CodeMeter, SmartShelter, SmartBind are registered trademarks of Wibu-Systems.

12.6 Other licensed technologies. This SOFTWARE is used under license to the following U.S. Patent Nos.: 5,625,465 and 5,768,416.

13. Governing Law

13.1 If the SOFTWARE was obtained in the United States, Canada, Mexico, Belize, Costa Rica, El Salvador, Guatemala, Honduras, Montserrat, Nicaragua, Panama, Turks and Caicos Islands, Virgin Islands, Japan, or Taiwan, this EULA shall be governed by and construed in accordance with the laws of the State of California, United States of America. With respect to any dispute which may arise in connection with this EULA and/or this SOFTWARE, You consent to the exclusive jurisdiction and venue of the federal and/or state courts in the county of Santa Clara in the State of California. For the avoidance of doubt if the SOFTWARE was obtained in the United States, You obtained (purchased) the SOFTWARE from ABBYY USA Software House, Inc.

13.2 If the SOFTWARE was obtained in Austria, Belgium, Denmark, Finland, France, Germany, Italy, Luxembourg, the Netherlands, Portugal, Spain, Sweden, or any other member state of the European Union, except for Malta, Greece and Cyprus, that is not directly mentioned in article 13.3, 13.4 or 13.5 of this EULA, or in Switzerland, Norway, Iceland or Liechtenstein, this EULA shall be governed by and construed in accordance with the substantive law in force in Munich, the Federal Republic of Germany and the competent court of Munich, the Federal Republic of Germany shall have exclusive jurisdiction over all disputes relating to this EULA.

13.3 If the SOFTWARE was obtained in the United Kingdom of Great Britain and Northern Ireland, and Republic of Ireland this EULA shall be governed by and construed in accordance with the laws of England and Wales and the parties accept the exclusive jurisdiction of the courts of England and Wales.

13.4 If the SOFTWARE was obtained in Russia, Byelorussia, Kazakhstan, or any other country of the CIS, except for Ukraine and Moldova, or if the SOFTWARE was obtained (purchased) in Georgia, Latvia, Lithuania or Estonia, this EULA shall be governed by and construed in accordance with the substantive law in force in the Russian Federation.

13.5 If the SOFTWARE was obtained in Albania, Bosnia and Herzegovina, Bulgaria, Croatia, the Czech Republic, Hungary, Israel, Macedonia, Poland, Romania, Slovakia, Slovenia, Turkey, Serbia, Montenegro, Ukraine or Moldova, this EULA shall be governed by and construed in accordance with the substantive law of Ukraine, unless the SOFTWARE has been acquired by the person that has a status of consumer according to the Polish Civil Code. Polish law shall apply to such consumers.

13.6 If article 13.5 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business), any and all disputes, controversies or differences in opinion arising out of or relating to the EULA shall be finally resolved through arbitration in accordance with the arbitration rules and procedures of the International Commercial Arbitration Court at the Ukrainian Chamber of Commerce and Industry according to its Order. Judgment of the Court mentioned above is final and obligatory for execution by both Parties. If Section 13.5 is applied and You are an individual person, the Shevchenkovsky District Court of Kiev, Ukraine, shall have exclusive jurisdiction over all disputes relating to this EULA.

13.7 If article 13.4 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business) the Arbitrazh Court of Moscow, the Russian Federation, shall have exclusive jurisdiction over all disputes relating to this EULA. If article 13.4 is applied and You are an individual person, the Kuzminsky District Court of Moscow, the Russian Federation, shall have jurisdiction over all disputes relating to this EULA.

13.8 In the cases described in articles 13.1-13.5, this EULA will not be governed by the conflict of law rules of any jurisdiction or the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly excluded.

13.9 If the SOFTWARE was obtained (purchased) in a country other than the countries specified in articles 13.1-13.5, this EULA shall be governed by and construed in accordance with the substantial laws of the country in which You obtained (purchased) the SOFTWARE.

14. Termination

14.1 Unless otherwise agreed by You and ABBYY or an ABBYY Partner in a separate written agreement or except as otherwise provided by the EULA or the documentation for the SOFTWARE, this EULA is effective in perpetuity from the date which You first demonstrated your acceptance as provided at the beginning of the EULA or as long as it is permitted under applicable law. To the extent that applicable law requires the statement of an expiration period for this EULA, this EULA will last as long as permitted, but in any event, at least as long as the duration of the SOFTWARE copyright and shall automatically expire without further notice when such time period elapses.

14.2 Without prejudice to any other rights, ABBYY may terminate this EULA if You fail to comply with the terms and conditions of this EULA. In such an event, You must destroy all copies of the SOFTWARE, all of its component parts and remove the SOFTWARE from your Computers.

14.3 You may terminate this EULA by destroying all copies of the SOFTWARE, all of its component parts and removing the SOFTWARE.

14.4 Such termination does not relieve You of Your obligation to pay for the SOFTWARE. Articles 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 and article 3.4.4 shall survive the termination or expiration of this EULA, howsoever caused, but this shall not imply or create any continued right to use the SOFTWARE after termination or expiration of this EULA.

15. Miscellaneous

15.1 In the course of Activation, installation, operation and/or technical support and maintenance of the SOFTWARE You may be required and You hereby agree to provide ABBYY with certain personal information of Yours (such as but not limited to Your name, address, email address, phone number). You may choose not to provide us with your personal information, in which case You may be refused in future to obtain technical support or maintenance of the SOFTWARE available to ABBYY customers who provided their personal information, if provision of personal information is essential to provide You with technical support or maintenance of the SOFTWARE or is requirement of such technical support or maintenance of the SOFTWARE and it does not contradict applicable law. You agree not to provide more personal information than ABBYY or ABBYY’s Partner require, and agree that Your personal information may be processed (including but not limited to collected and/or otherwise used) by ABBYY and/or its affiliates or ABBYY Partners in compliance with applicable law provided that the confidentiality of the data and data security is maintained if it is required by applicable law. Any personal information You provide to ABBYY or its affiliates or ABBYY Partners will be processed, stored and used strictly within ABBYY and its affiliates or ABBYY Partners and will not be disclosed to any third party, except as may be required by applicable law, and, in case of ABBYY Software House Inc., will be maintained in accordance with its privacy policy found at http://abbyy.com/privacy_policy. All personal records will be processed solely for purposes of fulfillment obligations under this EULA by ABBYY. If article 13.5. applies Your personal information will be processed in the database named «Physical persons whose personal information is processed during business activity».

15.2 You agree that the SOFTWARE may require connections via Internet or via e-mail with an ABBYY server during Activation, deactivation or update of the SOFTWARE. ABBYY will take reasonable steps with the goal that no personal information about You will be transferred during such connections.

15.3 ABBYY may send You e-mails containing product and company news, information about special offers, advices on product usage and other product and company-related information provided You agree to receive such information. You may remove Your e-mail address from ABBYY’s mailing list at any time.

15.4 If any claims or lawsuits are brought against You in connection with Your use of the SOFTWARE, You shall inform ABBYY in writing about them promptly and whenever practicable within three (3) days from the moment You learn of them. You shall take all necessary actions to enable ABBYY to take part in the proceedings or hearings of or take over the defense of said claims or lawsuits in court or arbitration, and shall provide ABBYY with Your full cooperation and all information ABBYY deems useful or necessary for the defense of settlement of the corresponding claims or lawsuits, promptly upon (and whenever practicable no later than seven (7) days from the moment of) the receipt of an inquiry from ABBYY.

15.5 Consideration under this EULA is the price of the License established by ABBYY or an ABBYY Partner and payable in accordance with the payment procedures established by them, or may be included in value of equipment or hardware obtained by You or is part of the consideration payable by You for the full version of the SOFTWARE. If You are a natural person, this EULA may be gratuitous.

15.6 If any part of this EULA is found void or unenforceable, it will not affect the validity of the balance of the EULA, which shall remain valid and enforceable according to its terms.


Патенты

Патенты США № 5,490,216, 5,625,465, 5,768,416 и 6,094,505


Технологии других компаний

© 1984-2011 Adobe Systems Incorporated и их лицензиары. Все права защищены.

Защищено патентами США 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Вопрос о выдаче патентов рассматривается.

Adobe, Acrobat, логотип Acrobat, логотип Adobe, логотип Adobe PDF и Adobe PDF Library являются зарегистрированными товарными знаками или товарными знаками компании Adobe Systems Incorporated в Соединенных Штатах Америки и/или других странах.

Авторское право на часть данной компьютерной программы принадлежит © 2008 Celartem, Inc. Все права сохранены.

Авторское право на часть данной компьютерной программы принадлежит © 2011 Caminova, Inc. Все права сохранены.

Авторское право на часть данной компьютерной программы принадлежит © 2013 Cuminas, Inc. Все права сохранены.

DjVu® охраняется патентами США No. 6.058.214. Заявки на патенты в других странах рассматриваются.

На основе AT&T Labs Technology.

PixTools © 1994-2007 EMC Corporation. Все права защищены.

WIBU, CodeMeter, SmartShelter, SmartBind являются зарегистрированными товарными знаками Wibu-Systems.

© 2012 В данном программном обеспечении частично использованы результаты работы Университета Нового Южного Уэльса. Все права защищены.

© 2001-2006 Michael David Adams

© 1999-2000 Image Power, Inc.

© 1999-2000 The University of British Columbia

В данном программном обеспечении частично использованы результаты работы Независимой группы JPEG.

© 1991-2013 Unicode, Inc. Все права защищены.

Словесный знак Unicode и логотип Unicode являются зарегистрированными товарными знаками Unicode, Inc.

© 1996-2002, 2006 The FreeType Project (www.freetype.org). Все права защищены.

© ParaType, 2003

EMC2, EMC, Captiva, ISIS и PixTools являются зарегистрированными товарными знаками, а QuickScan является товарным знаком EMC Corporation.

Kodak является зарегистрированным товарным знаком Eastman Kodak Company.

.NET, Access, Active Directory, ActiveX, Aero, Excel, Hyper-V, InfoPath, Internet Explorer, JScript, Microsoft, Office, Outlook, PowerPoint, SharePoint, Silverlight, SQL Azure, SQL Server, Visual Basic, Visual C++, Visual C#, Visual Studio, Windows, Windows Azure, Windows Power Shell, Windows Server, Windows Vista, Word являются товарными или зарегистрированными товарными знаками Microsoft Corporation в США и/или других странах.

Oracle и Java являются зарегистрированными товарными знаками Oracle и/или филиалов.

Другие товарные знаки являются собственностью соответствующих владельцев.

TWAIN Toolkit распространяется как есть. Разработчик и распространитель TWAIN Toolkit отказываются от любых подразумеваемых, явных или предусмотренных законодательством гарантий, включая, без ограничения, подразумеваемые гарантии пригодности для продажи, ненарушения прав третьих лиц и пригодности конкретной цели. Ни разработчики, ни распространители не несут ответственности за убытки, прямые, косвенные, специальные или случайные, возникшие в результате воспроизведения, изменения, распространения или иного использования TWAIN Toolkit.

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams

Copyright (c) 1999-2000 Image Power, Inc.

Copyright (c) 1999-2000 The University of British Columbia

Все права защищены.

Настоящей лицензией любому лицу (далее - "Пользователь"), получившему копию настоящего программного обеспечения и сопроводительную документацию к нему (далее - "ПО"), безвозмездно предоставляется право распоряжаться ПО без каких-либо ограничений, включая право использовать, копировать, изменять, встраивать, воспроизводить, публиковать, распространять и/или продавать копии ПО, а также разрешать лицам, которым передается ПО, совершать аналогичные действия при условии соблюдения нижеперечисленных условий:

  1. Любые копии или значительные части ПО должны содержать вышеприведенные уведомления об авторских правах, настоящую лицензию и нижеприведенный отказ от гарантий.
  2. Имя владельца авторских прав не должно использоваться для поддержки или рекламы продуктов, созданных на основе настоящего ПО, без предварительного письменного согласия владельца авторских прав.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ ЯВЛЯЕТСЯ НЕОТЪЕМЛЕМОЙ ЧАСТЬЮ НАСТОЯЩЕЙ ЛИЦЕНЗИИ.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ РАСПРОСТРАНЯЕТСЯ НА ЛЮБОЕ ИСПОЛЬЗОВАНИЕ ПО. ПО ПРЕДОСТАВЛЯЕТСЯ ВЛАДЕЛЬЦАМИ АВТОРСКИХ ПРАВ "ТАКИМ, КАКОВО ОНО ЕСТЬ" БЕЗ КАКИХ-ЛИБО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ (НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ) ГАРАНТИЙ ТОГО, ЧТО ПО ПРИГОДНО К ПРОДАЖЕ, ПРИГОДНО ДЛЯ КОНКРЕТНОГО ИСПОЛЬЗОВАНИЯ И НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ЛЮБЫЕ КОСВЕННЫЕ, ПРЯМЫЕ ИЛИ СЛУЧАЙНЫЕ УБЫТКИ, А ТАКЖЕ ЗА ЛЮБЫЕ УБЫТКИ ИЗ-ЗА НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПО, ПОТЕРИ ДАННЫХ ИЛИ УПУЩЕННОЙ ВЫГОДЫ В РЕЗУЛЬТАТЕ НЕВЫПОЛНЕНИЯ ОБЯЗАТЕЛЬСТВ ПО КОНТРАКТУ, НЕБРЕЖНОСТИ ИЛИ ИНЫХ ВРЕДОНОСНЫХ ДЕЙСТВИЙ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ИЛИ РАБОТОЙ ПО. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ ГАРАНТИРУЮТ, ЧТО ПО НЕ НАРУШАЕТ ПАТЕНТОВ И ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ТРЕТЬИХ ЛИЦ. КАЖДЫЙ ИЗ ВЛАДЕЛЬЦЕВ АВТОРСКИХ ПРАВ ОТКАЗЫВАЕТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ПОЛЬЗОВАТЕЛЯМИ ЗА ИСКИ ТРЕТЬИХ ЛИЦ В СВЯЗИ С НАРУШЕНИЕМ ИХ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ИЛИ ИНЫМИ НАРУШЕНИЯМИ. ДЛЯ ИСПОЛЬЗОВАНИЯ ПРАВ, ПРЕДОСТАВЛЯЕМЫХ НАСТОЯЩЕЙ ЛИЦЕНЗИЕЙ, КАЖДЫЙ ПОЛЬЗОВАТЕЛЬ ПРИНИМАЕТ НА СЕБЯ ЕДИНОЛИЧНОЕ ОБЯЗАТЕЛЬСТВО ПРИОБРЕСТИ НЕОБХОДИМЫЕ ПРАВА ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, ЕСЛИ ТАКОВЫЕ ПОТРЕБУЮТСЯ. ПО НЕ ОБЛАДАЕТ ОТКАЗОУСТОЙЧИВОСТЬЮ И НЕ ПРЕДНАЗНАЧЕНО ДЛЯ ИСПОЛЬЗОВАНИЯ В УСЛОВИЯХ, ТРЕБУЮЩИХ БЕЗОТКАЗНОЙ РАБОТЫ, ТАКИХ КАК ЯДЕРНЫЕ УСТАНОВКИ, АВИАЦИОННЫЕ НАВИГАЦИОННЫЕ ИЛИ КОММУНИКАЦИОННЫЕ СИСТЕМЫ, АВИАДИСПЕТЧЕРСКИЕ СИСТЕМЫ, АППАРАТЫ ПО ПОДДЕРЖАНИЮ ЖИЗНИ, ОРУЖИЕ ИЛИ СИСТЕМЫ, В КОТОРЫХ ОТКАЗ ПО ИЛИ СИСТЕМЫ МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, СЕРЬЕЗНОМУ УЩЕРБУ ЗДОРОВЬЮ ИЛИ ОКРУЖАЮЩЕЙ СРЕДЕ ("ДЕЯТЕЛЬНОСТЬ, СВЯЗАННАЯ С ПОВЫШЕННЫМ РИСКОМ"). ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НАСТОЯЩИМ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРИГОДНОСТИ ПО ДЛЯ ДЕЯТЕЛЬНОСТИ, СВЯЗАННОЙ С ПОВЫШЕННЫМ РИСКОМ.


Как купить программу ABBYY FormDesigner

Линейке продуктов FlexiCapture посвящен раздел на сайте компании ABBYY, расположенный по адресу http://www.abbyy.ru/flexicapture/.

Зайдя на сайт по этому адресу, вы можете:

  • Получить информацию по программным продуктам линейки FlexiCapture.
  • Прочитать об успешных проектах, реализованных с помощью продуктов ABBYY.
  • Узнать, как связаться с ближайшим офисом компании ABBYY или реселлером по продуктам линейки FlexiCapture.

Для оформления заказа на покупку, а также для выяснения любых связанных с этим вопросов вы можете связаться с нами по электронной почте: sales@abbyy.ru или обратиться в ближайший офис компании ABBYY.

Дополнительные программы поддержки языков и шрифты можно приобрести на http://www.paratype.com/shop.


ABBYY Offices

Вы находитесь здесь: Как купить программу ABBYY Form Designer > Офисы компании ABBYY

Координаты офисов компании ABBYY

ABBYY Россия | Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: 127273, Россия, Москва, а/я 32 Физический адрес: Москва, ст. м. Отрадное, ул. Отрадная, 2Б, строение 6, бизнес-центр "Отрадный" E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru http://www.abbyy.ru Схема проезда
ABBYY USA | Тел.: +1 408-457-9777 Факс: +1 408-457-9778 Адрес: 880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com
ABBYY Ukraine | Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: P.O. Box 23, 02002 Kiev, Ukraine E-mail: forms@abbyy.ua Техническая поддержка Тел.: +380 44 490 9463 E-mail: formsupport@abbyy.ua http://www.abbyy.ua
ABBYY Europe GmbH | Тел.: +49 (0)89 511 159 0 Факс: +49 89 (0)511 159 59 Адрес: Elsenheimerstraße 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
ABBYY UK Ltd. | Тел.:+0870 600 0231 Факс: +01344 392 611 Адрес: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-mail: sales_UK@abbyy.com Техническая поддержка: support_eu@abbyy.com http://www.abbyy.co.uk
ABBYY Japan | Тел.:+81-42-795-1901 Факс: +81-42-795-1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com
ABBYY Taiwan | Тел.:+886-2-2655-0556 Факс: +886-2-2655-2339 Адрес: Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com http://www.abbyy.com


Техническая поддержка

Если при использовании программы ABBYY FormDesigner у вас возникли вопросы, то, прежде чем обратиться в отдел технической поддержки пользователей, просмотрите всю имеющуюся у вас документацию (" Руководство пользователя", встроенную справку), а также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать квалифицированные рекомендации, работникам отдела технической поддержки пользователей необходимо иметь следующую информацию:

  • Фамилия, Имя, Отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер дистрибутива
  • Выпуск (см. меню Справка/О программе/Выпуск)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия системы Windows
  • Другая информация, которую вы считаете важной

Часть этой информации можно получить автоматически, нажав на кнопку О системе… в диалоге О программе ABBYY FormDesigner 11 (меню Справка/О программе).

Внимание! Техническая поддержка оказывается только зарегистрированным пользователям. Вы можете зарегистрироваться на нашем сайте.

Для выяснения любых вопросов, связанных с использованием программы ABBYY FormDesigner, вы можете обратиться в один из офисов компании ABBYY.


Диалог Свойства: Выравнивание

Свойство

Описание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.

  • По центру - позволяет выровнять текст горизонтально по центру элемента.

  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.


Диалог Свойства: Репер

Свойство | Описание
Тип | Позволяет выбрать из списка стандартных реперов репер, который будет использоваться на форме. Одновременно на форме могут быть размещены реперы только одного типа.
Размер | Позволяет задать размер репера: в случае черного квадрата - длину стороны квадрата; в случае уголка - длину стороны уголка.
Толщина линии (только при выборе репера Уголок) | Позволяет задать толщину линии репера.


Диалог Свойства: Фон

Свойство | Описание
Цвет фона формы | Позволяет выбрать в качестве цвета фона элемента цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента. Список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).


Диалог Свойства: Поле метки

Свойство

Описание

Тип

Позволяет выбрать тип ограничителя поля метки:

  • Квадрат
  • Круг

Расположение

Позволяет выбрать расположение поля метки относительно текста (пояснительной информации):

  • Метка слева - поле метки располагается слева от текста
  • Метка справа - поле метки располагается справа от текста
  • Метка сверху - поле метки располагается сверху от текста
  • Метка снизу - поле метки располагается снизу от текста

Размер

Позволяет выбрать предопределенный размер элемента Поле метки из списка (3,5х3,5 4х4 4,5х4,5 5х5 мм).

Толщина линии

Позволяет задать толщину линии ограничителя элемента Поле метки (от 0,4 мм до 0,8 мм).

Расстояние до текста

Позволяет задать расстояние от поля метки до текста (пояснительной информации).

Цвет

Позволяет выбрать из списка цвет линии ограничителя.


Диалог Свойства: Дата

Свойство

Описание

Цифр в годе

Позволяет выбрать формат даты:

  • ДД.ММ.ГГГГ
  • ММ.ДД.ГГГГ
  • ГГГГ.ММ.ДД

Формат даты

Позволяет выбрать количество знакомест для записи года:

  • 2 (под запись года будет отведено два знакоместа)
  • 4 (под запись года будет отведено два знакоместа)

Разделитель

Позволяет выбрать разделитель для записи даты:

  • .
  • /
  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле даты: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Разметка

Свойство

Описание

Многострочное поле

Позволяет сделать поле для ввода многострочным. (Только для элемента Поле для ввода).

Тип разметки текста

Позволяет выбрать тип разметки текста из списка:

  • Буквы в гребенке;
  • Текст в рамке с гребенкой;
  • Буквы в рамках;
  • Буквы в изолированных рамках;
  • Буквы в изолированных растровых рамках.

Цвет разметки

Позволяет выбрать из списка цвет разметки.

Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках)

Позволяет выбрать жирную линию разметки.

Размер знакоместа

Позволяет выбрать предопределенный размер знакоместа из списка.

Для разметки Буквы в гребенке, Текст в рамке с гребенкой и Буквы в рамках:

  • Очень большой - (6,5 х 7,9) мм;
  • Большой - (6,5 х 7,4) мм;
  • Стандартный (по умолчанию) - (5,2 х 5,7) мм;
  • Минимальный - (4,0 х 4,6) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 4,2 до 6,7 мм; высота от 4,7 до 8,2 мм. Шаг - 0,1 мм.

Для разметки Буквы в изолированных рамках и Буквы в изолированных растовых рамках:

  • Очень большой - (5,0 х 7,0) мм;
  • Большой - (5,0 х 6,5) мм;
  • Стандартный (по умолчанию) - (4,0 х 5,0) мм;
  • Минимальный - (3,0 х 4,0) мм;
  • Нестандартный - настраивается пользователем. Допустимый диапазон: ширина от 3,0 до 5,5 мм; высота от 4,0 до 7,5 мм. Шаг - 0,1 мм.

Замечание. Размеры ячеек Очень большой и Нестандартный не совместимы с предыдущими версиями FormDesigner.


Диалог Свойства: Подсказка

Свойство | Описание
Текст | Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле для ввода: каждая буква подсказки в соответствующее знакоместо.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Связанное поле

Свойство | Описание
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.


Диалог Свойства: Текст

Свойство | Описание
Текст | Позволяет редактировать текст элемента.
Шрифт | Позволяет редактировать шрифт для набора текста элемента. Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить… В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.
Цвет | Позволяет выбрать из списка цвет текста.
Переносить по словам | Позволяет переносить текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Линия

Свойство

Описание

Толщина

Позволяет задать толщину линии (от 0.1 мм до 2,5 мм).

Стиль

Позволяет выбрать стиль для линии:

  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать цвет линии.


Диалог Свойства: Элемент

Свойство | Описание
Тип | Указывается тип элемента.
Координаты и размер |
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Указывает или позволяет задать ширину элемента.
Высота | Указывает или позволяет задать высоту элемента.


Диалог Свойства: Число

Свойство

Описание

Кол-во знаков после разделителя

Позволяет задать количество знакомест для записи дробной части десятичного числа.

Разделитель

Позволяет выбрать разделитель для записи числа:

  • .
  • /
  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в числовом поле: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Картинка

Свойство

Описание

Изменение размера

Позволяет изменять размер элемента в нескольких режимах:

  • Исходный размер - режим изменения размера элемента, при котором размер и пропорции изображения не меняются.
    В данном режиме невозможно увеличить исходный размер изображения.
    Если размер элемента стал меньше, чем размер изображения, то часть изображения не будет видна на форме.
  • Растягивание - режим изменения размера элемента, при котором изображение сжимается или растягивается в зависимости от размера элемента. Видно все изображение.
  • Масштабирование - режим изменения размера элемента, при котором изображение масштабируется (уменьшается или увеличивается) пропорционально размерам элемента. Видно все изображение.

Выравнивание

Позволяет выровнять изображение внутри разметки элемента.

  • Слева вверху - позволяет поместить изображение в левый верхний угол разметки элемента.
  • Справа вверху - позволяет поместить изображение в правый верхний угол разметки элемента.
  • В центре - позволяет поместить изображение в центр разметки элемента.
  • Слева внизу - позволяет поместить изображение в левый нижний угол разметки элемента.
  • Справа внизу - позволяет поместить изображение в правый нижний угол разметки элемента.

Файл

Позволяет указать файл с изображением.
Для того, чтобы указать файл с изображением:

  1. нажмите кнопку "…";
  2. в открывшемся диалоге укажите путь к файлу с изображением.

Поддерживаются следующие форматы изображений:

  • Bitmap Files (*.bmp)
  • DCX Files (*.dcx)
  • PEG Files (*.jpg; *.jpeg; *.jfif)
  • PCX Files (*.pcx)
  • PNG Files (*.png)
  • TIFF Files (*.tif; *.tiff)
  • Windows Enhanced Metafiles (*.emf)


Диалог Свойства: Поле метки

Диалог Свойства: Таблица

Свойство | Описание
Расстояние между ячейками | Позволяет задать расстояние между ячейками таблицы.
Использовать первую строку как заголовок | Если эта опция отмечена, то первая строка будет использоваться в качестве заголовков столбцов таблицы.


Свойства абзаца

Основные свойства абзаца можно посмотреть в диалоге Свойства абзаца (локальное меню элемента Текст в режиме редактирования > Свойства абзаца).

Collapsed Показать диалог Свойства абзаца

Свойство | Описание
Общие
Выравнивание | Позволяет выравнивать текст по левому краю, по правому краю, по центру и по ширине.
Отступы
Слева | Позволяет задать ширину отступа от левого края страницы.
Справа | Позволяет задать ширину отступа от правого края страницы.
Интервалы
Перед | Позволяет задать интервал перед абзацем текста.
После | Позволяет задать интервал после абзаца текста.
Межстрочный | Позволяет изменить расстояние между строками текста.