О программе ABBYY FormDesigner

О программе ABBYY FormDesigner 8.0

Программа ABBYY FormDesigner 8.0 предназначена для создания макетов машиночитаемых форм,

Формы, созданные с учетом требований автоматизированного ввода.
которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture 8.0 Professional. Разработка формы является важным этапом, так как от "правильности" разработанного макета формы (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

Если сравнивать ABBYY FormDesigner с другими известными редакторами, которые можно использовать для создания макетов форм (MS Visio, Corel Draw, MS Word), то последние, предоставляя широкий спектр возможностей для создания разнообразных форм, тем не менее, специально не предназначены для создания именно машиночитаемых форм. Поэтому создателю формы приходится внимательно отслеживать соответствие формы требованиям машиночитаемости:

Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму.
вручную измерять размеры элементов, а также следить за их формой и расположением.

Программа ABBYY FormDesigner учитывает специфику разработки машиночитаемых форм, не требует дополнительного обучения, имеет интуитивно-понятный пользовательский интерфейс и обладает набором инструментов для создания стандартных элементов машиночитаемой формы. C помощью программы возможно создание как черно-белых, так и цветных фоновых форм. В программу встроена автоматическая проверка машиночитаемости

Проверка пригодности формы для автоматизированного ввода и дальнейшей обработки распознанного текста.
создаваемой формы, а элементы формы обладают набором свойств, созданных с учетом требований машиночитаемости. Перечисленные свойства программы позволяют создавать формы, удовлетворяющие требованиям машиночитаемости, не тратя при этом времени на утомительный расчет размеров и расположения элементов формы.

Важным преимуществом программы ABBYY FormDesigner является то, что, разработав форму с помощью программы ABBYY FormDesigner, вы автоматически получаете готовое описание формы, которое можно использовать для создания шаблона документа в программе ABBYY FlexiCapture 8.0 Professional.

Таким образом, использование программы ABBYY FormDesigner помогает не только упростить процесс разработки формы, но и минимизирует настройку системы автоматизированного ввода форм ABBYY FlexiCapture 8.0 Professional для работы с документами данного образца.

Программа ABBYY FormDesigner предоставляет возможность опубликовать разработанную форму (защитить её от случайных изменений), а также экспортировать её в графические форматы, что может понадобиться при передаче формы в типографию.


Как создать, сохранить и открыть форму

Как создать форму

Для создания новой формы в программе имеется Мастер создания формы (меню Файл>Новая…), который последовательно проведет вас по необходимым этапам создания формы. По окончании работы мастера вам останется добавить необходимые для вашей формы элементы с помощью панели инструментов Элементы формы и сохранить форму.

Подробнее см. раздел Создание формы.

Как сохранить форму

Для того чтобы сохранить форму, воспользуйтесь стандартной командой Сохранить или Сохранить как… (меню Файл).

Как открыть форму

Чтобы открыть форму:

  • Выберите команду Открыть… (меню Файл>Открыть…), или
  • Выберите инструмент Открыть на панели инструментов Стандартная, или
  • Нажмите комбинацию клавиш Ctrl+O.


Как опубликовать форму

Публикация формы - это процесс, при котором форме присваивается статус (Опубликованная), не позволяющий вносить в форму изменения. Во время публикации форма проверяется на машиночитаемость и ей присваивается уникальный номер, который прописывается в идентификаторе.

Для того чтобы опубликовать форму, воспользуйтесь командой Опубликовать (меню Файл). Опубликованные формы доступны только для просмотра. Для того чтобы внести изменения в опубликованную форму, воспользуйтесь командой Сохранить редактируемую копию как… (меню Файл), при этом сначала вам будет предложено сохранить форму под другим именем, а потом вносить изменения.

Подробнее см. Сохранение и публикация формы. Проверка формы на машиночитаемость.


Как получить изображение формы

Для того чтобы получить изображение формы, воспользуйтесь командой Файл изображения… (меню Файл>Экспортировать в>Файл изображения…). В открывшемся диалоге Сохранить изображение как выберите формат файла изображения, укажите название файла и папку, куда файл будет сохранен.

Подробнее см. Экспорт в файл изображения.


Как получить описание формы для программы ABBYY FlexiCapture

Важным преимуществом программы ABBYY FormDesigner 8.0 является то, что, разработав форму с помощью программы ABBYY FormDesigner 8.0, вы автоматически получаете готовое описание формы, которое можно использовать для создания шаблона документа в программе ABBYY FlexiCapture 8.0 Professional.

Для того чтобы получить описание формы и использовать его в программе ABBYY FlexiCapture 8.0 Professional:

  1. Создайте форму в программе ABBYY FormDesigner 8.0.
  2. Опубликуйте форму (меню Файл>Опубликовать).
  3. Экспортируйте опубликованную форму в формат XML Form Definition (меню Файл>Экспортировать в>XML Form Definition…). В открывшемся диалоге Экспорт в XML Form Definition укажите название файла и папку, куда файл будет сохранен.
  4. Откройте программу ABBYY FlexiCapture 8.0 Professional и выберите пункт меню Проект>Шаблоны документов...
  5. Нажмите Импорт и укажите созданный файл *.xfd.
Подробнее см. Экспорт в XML Form Definition (*.xfd)


Новые возможности ABBYY FormDesigner

Новые возможности ABBYY FormDesigner 8.0

В новой версии ABBYY FormDesigner 8.0 добавлены следующие новые возможности:

  • Поддержка многостраничных форм.

  • Создания форм на основе образца.

  • Создания цветных фоновых форм.

  • Добавлено два новых элемента формы: Таблица и Группа элементов.

  • Новая возможность графического редактора – линейки для выравнивания элементов.

  • Экспорт изображений в EMF-файл.

  • Возможность редактирования структуры документа.

  • Возможность печати заполненных форм.


Установка, запуск и удаление программы ABBYY FormDesigner

Установка, запуск и удаление программы ABBYY FormDesigner 8.0

Программа ABBYY FormDesigner 8.0 устанавливается и удаляется вместе с программой ABBYY FlexiCapture 8.0 Professional.

Чтобы запустить программу ABBYY FormDesigner 8.0:

  • Выберите пункт ABBYY FormDesigner 8.0 в меню Пуск/Программы/ABBYY FlexiCapture 8.0 Professional/Инструменты.


Главное окно программы

Сразу после запуска программы открывается главное окно программы ABBYY FormDesigner 8.0.

Показать главное окно программы

Строка меню. Содержит меню программы: Файл, Правка, Вид, Форма, Элементы, Сервис и Справка.

Панель инструментов Стандартная. Содержит кнопки наиболее часто используемых стандартных команд.

Панель инструментов Редактирование. Содержит кнопки наиболее часто используемых команд редактирования элементов.

Панель инструментов Форматирование. Содержит кнопки наиболее часто используемых команд форматирования текста.

Панель инструментов Элементы формы. Содержит кнопки команд добавления элементов на форму.

Линейка. Вспомогательный инструмент, применяемый при создании и редактировании формы для более точного расположения и выравнивания элементов формы.

Окно Форма. Содержит непосредственно форму, открытую в данный момент времени. Одновременно в главном окне может отражаться только одна форма.

Структура документа. В этом окне отображается иерархическая структура полей, к каждому из которых привязан один или несколько элементов формы.

Окно Свойства. Это окно предназначено для просмотра и редактирования свойств выделенного элемента. Окно содержит несколько вкладок (в зависимости от типа элемента); чтобы перейти на нужную вкладку, щелкните по ее названию справа.

Строка состояния. Содержит информацию о выбранном элементе формы (координаты верхнего левого угла элемента в мм, размер элемента в мм, дополнительная информация, тип элемента) и о форме в целом (вид формы, размер страницы в мм). Дополнительная информация выводится для элементов Поле для ввода, Поле даты, Числовое поле - количество строк поля и размер строк (количество знакомест). Для элемента Числовое поле выводится количество знакомест до и после запятой.


Настройка вида главного окна программы

Вид главного окна редактируется с помощью диалога Настройки (меню Сервис>Настройки…).

Показать диалог Настройки

Настройка

Описание

Вид

Язык интерфейса

Позволяет выбрать язык интерфейса. Все сообщения, названия диалогов, кнопок и пунктов меню будут написаны на выбранном языке. Для того чтобы изменить язык интерфейса, выберите нужное значение из этого списка, нажмите кнопку OK, а затем перезапустите программу ABBYY FormDesigner 8.0.
По умолчанию язык интерфейса совпадает с языком, который был выбран для установки программы.

Группа Сетка

Показывать сетку

Позволяет отобразить сетку разметки на экране.

По умолчанию пункт не выбран.

Ширина

Позволяет задать ширину ячейки сетки разметки. Измеряется в миллиметрах (мм).

По умолчанию значение равно 1 мм.

Высота

Позволяет задать высоту ячейки сетки разметки. Измеряется в миллиметрах (мм).

По умолчанию значение равно 1 мм.

Привязывать к сетке

Позволяет включить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.

Группа Цвет

Позволяет задать цвет фона редактируемого текста, линеек и границ отступов формы при отображении их на экране.
В окне Объекты выберите один из объектов формы. Затем выберите цвет, которым он будет отображаться на экране (щелкните мышью на цветном прямоугольнике, в открывшемся диалоге Цвет (Color) выберите необходимый цвет).

Показывать линейку

Позволяет отобразить на экране линейку.

Показывать отступы

Позволяет отобразить на экране отступы формы.

Группа Редактор текста

Размеры табуляции

Позволяет задать количество пробелов, которые вставляются в редакторе текста при нажатии табуляции.

Экспорт

Группа XFD

Сохранять изображения в формате

Позволяет выбрать формат для сохранения изображений страниц при экспорте в XFD. Поддерживаются форматы:

  • TIFF;
  • EMF.

Группа Изображение

Разрешение TIFF-файлов

Позволяет задать разрешение для экспорта изображений в формат TIFF.


Панели инструментов

В программе ABBYY FormDesigner 8.0 присутствуют четыре панели инструментов: Стандартная, Форматирование, Элементы формы и Редактирование.

Спрятать или показать инструментальные панели на экране можно с помощью команд меню (Вид>Панели инструментов или локальное меню панели инструментов). Чтобы отобразить панель инструментов на экране, отметьте название панели в меню, щелкнув на нем мышью.

Чтобы открыть локальное меню панели инструментов, щелкните правой кнопкой мыши на любой панели инструментов.

Кнопки на панелях инструментов - средство быстрого доступа к командам программы. Те же команды можно вызвать из меню программы или с помощью горячих клавиш.

Можно использовать большие или маленькие кнопки на панелях инструментов. По умолчанию кнопки маленькие, чтобы изменить их размер, выберите пункт меню Вид>Панели инструментов>Большие кнопки.

Если вы хотите узнать о назначении той или иной кнопки на инструментальной панели, установите на ней курсор мыши, под кнопкой появится всплывающая подсказка.


Панель инструментов Стандартная

На панели инструментов Стандартная находятся кнопки вызова команд, выполняющих стандартные действия, например, создание или открытие формы, отмена и повтор команды и др. Нажатие нужной кнопки с помощью мыши приводит к выполнению соответствующей команды.

Показать панель инструментов Стандартная

Описание кнопок панели инструментов Стандартная:

Кнопка | Описание
Новая | Позволяет создать новую форму с базовыми элементами.
Открыть | Позволяет открыть форму.
Сохранить | Позволяет сохранить форму.
Просмотр | Позволяет просмотреть форму перед печатью.
Печать | Позволяет напечатать форму.
Вырезать | Позволяет удалить выделенный текст и помещает его в Буфер обмена.
Копировать | Позволяет скопировать выделенный текст в Буфер обмена.
Вставить | Позволяет вставить текст из Буфера обмена.
Отменить | Позволяет отменить действие последней выполненной команды.
Восстановить | Позволяет отменить действие последней команды Отменить.
Уменьшить | Позволяет уменьшить масштаб отображения формы в 2 раза.
Увеличить | Позволяет увеличить масштаб отображения формы в 2 раза.
Масштаб | Позволяет изменять текущий масштаб отображения формы.


Панель инструментов Редактирование

На панели инструментов Редактирование находятся кнопки вызова команд, позволяющих редактировать элементы на форме. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего инструмента редактирования.

Показать панель инструментов Редактирование

Описание кнопок панели инструментов Редактирование:

Кнопка | Описание
Показать сетку | Позволяет показывать/не показывать сетку разметки на экране
Показать основную линейку | Позволяет показывать/не показывать основную линейку на экране.
Привязать к сетке | Позволяет включить/отключить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
По левому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
Горизонтально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по вертикали.
По правому краю | Позволяет выровнять выделенные элементы формы по правому краю последнего из выделенных элементов.
По верхнему краю | Позволяет выровнять выделенные элементы формы по верхнему краю последнего из выделенных элементов.
Вертикально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по горизонтали.
По нижнему краю | Позволяет выровнять выделенные элементы формы по нижнему краю последнего из выделенных элементов.
Равномерно по горизонтали | Распределяет выделенные элементы равномерно по горизонтали.
Равномерно по вертикали | Распределяет выделенные элементы равномерно по вертикали.
По сетке | Позволяет выровнять левый верхний угол выделенных элементов формы по сетке, сохранив при этом размеры элементов.
По высоте | Позволяет выровнять высоту выделенные элементы формы по высоте последнего из выделенных элементов.
По ширине | Позволяет выровнять ширину выделенные элементы формы по ширине последнего из выделенных элементов.
По высоте и ширине | Позволяет выровнять ширину и высоту выделенные элементы формы по ширине и высоте последнего из выделенных элементов.
Размер по сетке | Позволяет раздвинуть границы выделенных элементов формы до ближайших линий сетки.
Объединить | Позволяет объединить выделенные элементы формы.
Разъединить | Позволяет разъединить выделенные элементы.
Добавить к объединенным | Позволяет добавить элементы к ранее объединенным. При этом должны быть выделены и ранее объединенные, и добавляемые элементы.
На передний план | Позволяет поместить выделенные элементы формы на передний план формы.
На задний план | Позволяет поместить выделенные элементы формы на задний план формы.
Привязывать линейки к элементам | Включает/выключает режим автоматической привязки линеек к элементам. Если режим включен, то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки.
Вертикальная линейка | Позволяет создать вертикальную линейку.
Горизонтальная линейка | Позволяет создать горизонтальную линейку.


Панель инструментов Форматирование

На панели инструментов Форматирование находятся кнопки вызова команд, позволяющих форматировать текст на форме. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего инструмента форматирования.

Показать панель инструментов Форматирование

Описание кнопок панели инструментов Форматирование:

Кнопка | Описание
Шрифт | Позволяет изменять шрифт для текста выделенных элементов.
Размер шрифта | Позволяет изменять размер шрифта для текста выделенных элементов.
Жирный | Позволяет выделять текст жирным шрифтом.
Курсивный | Позволяет выделять текст курсивным шрифтом.
Подчеркнутый | Позволяет выделять текст подчеркнутым шрифтом.
По левому краю | Позволяет выровнять текст выделенного элемента формы по левому краю этого элемента.
Горизонтально по центру | Позволяет выровнять текст выделенного элемента формы горизонтально по центру этого элемента.
По правому краю | Позволяет выровнять текст выделенного элемента формы по правому краю этого элемента.
Выровнять по ширине | Позволяет выровнять текст выделенного элемента формы по ширине этого элемента.
По нижнему краю | Позволяет выровнять текст выделенного элемента формы по нижнему краю этого элемента.
Вертикально по центру | Позволяет выровнять текст выделенного элемента формы вертикально по центру этого элемента.
По верхнему краю | Позволяет выровнять текст выделенного элемента формы по верхнему краю этого элемента.
Метка слева | Позволяет поместить поле метки слева от пояснительной информации.
Метка сверху | Позволяет поместить поля метки сверху от пояснительной информации.
Метка справа | Позволяет поместить поле метки справа от пояснительной информации.
Метка снизу | Позволяет поместить поле метки снизу от пояснительной информации.

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Панель инструментов Элементы формы

На панели инструментов Элементы формы находятся кнопки вызова команд, позволяющих добавлять новые элементы на форму. Нажатие нужной кнопки с помощью мыши приводит к выбору соответствующего элемента, который будет добавлен на форму.

Показать панель инструментов Элементы формы

Описание кнопок панели инструментов Элементы формы:

Кнопка | Описание
Инструмент выбора | Позволяет выбрать один из инструментов для добавления элементов формы или выделить уже созданный элемент формы.
Поле для ввода | Позволяет добавить элемент Поле для ввода.
Поле даты | Позволяет добавить элемент Поле даты.
Числовое поле | Позволяет добавить элемент Числовое поле.
Поле метки | Позволяет добавить элемент Поле метки.
Группа элементов | Позволяет добавить Группу элементов.
Таблица | Позволяет добавить элемент Таблица.
Вертикальный разделитель | Позволяет добавить в таблицу вертикальный разделитель.
Горизонтальный разделитель | Позволяет добавить в таблицу горизонтальный разделитель.
Удалить разделитель | Позволяет удалить любой разделитель.
Текст | Позволяет добавить элемент Текст.
Разделитель | Позволяет добавить элемент Разделитель.
Рамка | Позволяет добавить элемент Рамка.
Картинка | Позволяет добавить элемент Картинка.
Репер | Позволяет добавить элемент Репер.
Идентификатор | Позволяет добавить элемент Идентификатор.


Создание формы

Процесс создания машиночитаемой формы можно разделить на следующие этапы: анализ формы, непосредственно создание новой формы, тиражирование формы.

На этапе анализа формы необходимо:

  1. определить содержание формы, согласовать со всеми заинтересованными лицами названий полей и пояснительную информацию;
  2. выбрать вид формы (черно-белая линейчатая или растровая, цветная фоновая) и способ тиражирования форм (печать в типографии, печать на принтере, копирование, размещение в Интернете).
  3. согласовать макет формы с требованиями к машиночитаемым формам.

На этапе создания новой формы необходимо:

  1. создать электронную версию формы;

  2. опубликовать форму, т.е. присвоить форме статус, по которому запрещается вносить изменения в дизайн формы (таким способом уменьшается вероятность того, что в разное время с одного и того же образца будут размножены отличающиеся друг от друга формы).

На этапе тиражирования формы необходимо:

  1. подготовить форму к тиражированию.
  2. тиражировать форму.

Новая форма

Многостраничные формы

Создание формы на основе образца

Добавление, удаление и редактирование элементов формы

Выделение и перемещение элементов формы

Сохранение и публикация формы. Проверка формы на машиночитаемость.

Печать формы


Новая форма

Новая форма создается при помощи Мастера создания формы, который запускается при выборе пункта меню Файл>Новая… или при нажатии комбинация клавиш Ctrl+N.

На первом шаге мастера нужно выбрать способ создания новой формы.

  1. В случае выбора опции Пустая будет создана пустая форма без каких-либо элементов. Если вы хотите создать многостраничную форму, введите количество страниц в поле Количество страниц.

  2. В случае выбора опции С базовыми элементами будет создана черно-белая форма, на которой уже присутствуют базовые элементы формы: стандартные реперы
    Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
     (4 черных квадрата по углам и пятый квадрат в произвольном месте; при редактировании формы черные квадраты можно заменить на другие реперы), элемент Идентификатор
    Элемент машиночитаемой формы, однозначно характеризующий данную форму.
     (штрих-код с цифрами) и элемент Текст,
    Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.
     предназначенный для внесения заголовка формы.

    Если вы выберите опцию С базовыми элементами и поставите галочку Расширенные настройки, мастер создания формы последовательно проведет вас по необходимым этапам создания: заданию заголовка, размера, ориентации и вида формы, выбору типа реперов, использованию идентификатора формы, размещению на форме образца заполнения формы. По окончанию работы мастера вам останется добавить необходимые для вашей формы элементы и сохранить форму.

    Для создания многостраничной формы с базовыми элементами, введите количество страниц в поле Количество страниц. Текст заголовка формы будет присутствовать только на первой странице.

  3. При выборе опции На основе образца, вы сможете создать форму на основе образца. Мастер создания формы предложит вам выбрать файл формата *.dtf, содержащий образец формы. Первая страница образца отобразится в окне мастера для предварительного просмотра.

Свойства формы


Многостраничные формы

Программа ABBYY FormDesigner 8.0 позволяет создавать многостраничные формы. Такие формы состоят из нескольких страниц, для каждой из которых можно задать имя и количество вхождений. Описание такой формы экспортируется в формат XFD с учетом многостраничности, и на основе описания многостраничной формы в программе ABBYY FlexiCapture можно создать шаблон для многостраничного документа.

Создание многостраничной формы

Для того, чтобы создать многостраничную форму, введите нужное количество страниц на первом шаге Мастера создания формы при создании новой формы. После завершения работы мастера будет создана форма с заданным числом пустых страниц или страниц с базовыми элементами. Многостраничную форму также можно создать, используя многостраничный образец формы.

Добавление страниц

Добавить страницы можно в любую форму. Для этого выберите пункт меню Форма>Добавить страницу или щелкните правой кнопкой мыши на названии страницы внизу создаваемой формы. Вы можете добавить пустую страницу или создать страницу на основе образца.

Каждая страница может входить в форму произвольное количество раз. Задать максимальное и минимальное число вхождений данной страницы в форму можно в диалоге Свойства страницы (меню Форма>Свойства страницы…). В этом же диалоге вы можете задать имя текущей страницы.

Экспорт многостраничных форм

Изображение многостраничной формы можно проэкспортировать в любой из поддерживаемых графических форматов. Для многостраничных форматов есть возможность сохранить форму как постранично (каждая страница в своем файле), так и целиком (все страницы в одном файле).


Создание формы на основе шаблона

Создание формы на основе образца

Для создания новых форм или страниц форм программа ABBYY FormDesigner 8.0 позволяет использовать образцы форм и образцы страниц форм.

Для создания образца формы (страницы) нужно:

  1. Создать форму (страницу) в программе ABBYY Form Designer;
  2. Выбрать команду меню Файл>Сохранить как…;
  3. В выпадающем списке Тип файла (Save as type) выбрать пункт Образец формы или Образец страницы;
  4. Нажать кнопку Сохранить (Save).

Образец формы сохраняется в двоичном файле с расширением dtf (Document Template File), а страницы - с расширением ptf (Page Template File), в формате, представляющем собой модифицированный формат fdd-файла.

Образцы форм используются для создания форм, для этого при создании новой формы на первом шаге Мастера создания формы нужно выбрать опцию На основе образца.

Образцы страниц используются для добавления новых страниц в многостраничные формы, для этого при добавлении новой страницы нужно выбрать пункт меню Форма>Добавить страницу>На основе образца….


Свойства формы

Основные свойства формы можно посмотреть в диалоге Свойства формы, который вызывается из меню Форма>Свойства формы…

Показать диалог Свойства формы

Свойство

Описание

Автор

Указывается автор формы.

Статус

Указывается статус формы:

  • Редактируемая - форма доступна для редактирования;

  • Опубликованная - форма доступна только для чтения.

Дата публикации

Указывается дата публикации формы.

Значение идентификатора

Указывается значение идентификатора.

Файл

Указывается путь к файлу формы.

Свойства страницы формы

Свойства страницы формы определяют размер страницы, ориентацию страницы, размер отступов, а также вид страницы формы. Свойства страницы формы можно настроить в диалоге Свойства страницы, который открывается при выборе пункта меню Форма>Свойства страницы… или при выборе пункта Свойства страницы… локального меню страницы.

Показать диалог Свойства страницы

Свойство

Описание

Общие

Название

Позволяет задать название страницы.

Число вхождений страницы в документ

Минимум

Позволяет уменьшить или увеличить минимальное число вхождений текущей страницы в форму.

Минимум

Позволяет уменьшить или увеличить максимальное число вхождений текущей страницы в форму.

Идентификатор страницы

В данном поле отображается значение идентификатора страницы.

Размер

Размер страницы

Позволяет выбрать из списка один из стандартных размеров страницы формы, соответствующих размерам бумаги А3, А4, А5, или задать свой размер страницы формы. Для того чтобы задать свой размер страницы формы, выберите пункт Пользовательский и укажите ширину и высоту страницы формы в соответствующих полях.

Ширина

Позволяет задать ширину страницы формы.

Высота

Позволяет задать высоту страницы формы.

Группа Ориентация

Книжная

Позволяет задать книжную ориентацию формы.

Альбомная

Позволяет задать альбомную ориентацию формы.

Группа Отступы

Сверху

Позволяет задать ширину отступа от верхнего края страницы.

Снизу

Позволяет задать ширину отступа от нижнего края страницы.

Слева

Позволяет задать ширину отступа от левого края страницы.

Справа

Позволяет задать ширину отступа от правого края страницы.

Цвет

Вид

Позволяет задать вид страницы формы:

  • Серая фоновая

  • Черно-белая

  • Оранжевая фоновая

  • Красная фоновая

  • Зеленая фоновая

Группа Фон страницы*

Цвет*

Позволяет выбрать цвет фона страницы формы.

Замечание. Выбор цвета фона возможен только для фоновых форм, для черно-белых форм цвет по умолчанию белый.

Размер*

Позволяет выбрать размер площади залитой фоном:

  • Вся страница (фоном будет залита вся страница, за исключением выделенных на ней элементов).

  • Только внутри границ отступов формы (фоном будет залито все, что находится внутри границ отступов формы, за исключением выделенных на форме элементов).

* - свойство формы, задаваемое только для фоновых форм.


Добавление, удаление и редактирование элементов формы

После создания новой формы можно переходить к следующему этапу - добавлению элементов формы.

Совет
Рекомендуется определить и согласовать содержание формы и только после этого заниматься размещением элементов на форме.

Добавление элементов формы рекомендуется проводить в следующем порядке:

  1. Задать отступы от краев формы.
  2. Добавить реперы.
  3. Добавить другие элементы формы.

По требованиям машиночитаемости

Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму.
по всему периметру формы должны обязательно присутствовать отступы. По умолчанию при создании формы заданы отступы шириной 10 мм. Можно изменить ширину отступов формы. Для этого необходимо изменить значения в группе Отступы диалога Свойства страницы (меню Форма>Свойства страницы…>закладка Размер).

Для того чтобы отступы отражались на экране, необходимо выбрать пункт Показывать отступы на закладке Вид диалога Настройки (меню Сервис>Настройки…). На экране отступы отражаются пунктирной линией.

Для каждого элемента формы можно задать свойства.

Элемент Репер

Элемент Текст

Элемент Поле для ввода

Элемент Поле даты

Элемент Числовое поле

Элемент Поле метки

Элемент Разделитель

Элемент Рамка

Элемент Картинка

Элемент Идентификатор

Элемент Таблица

Группа элементов


Элемент Репер

Репер - это элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

Добавление реперов вынесено в отдельный пункт, т.к. является важным моментом в создании формы. Правильное расположение разумного количества реперов увеличит машиночитаемость формы и тем самым улучшит качество распознавания.

С помощью программы ABBYY FormDesigner 8.0 можно создать реперы 2-х типов: Черный квадрат и Уголок.
Тип репера | Описание
Черный квадрат | Репер в виде черного квадрата.
Уголок | Репер в виде уголка.

Тип репера устанавливается один на всю форму. При задании типа репера также задаются и свойства реперов формы:

  • Размер. В случае репера Черный квадрат в качестве размера репера указывается длина стороны квадрата, в случае Уголка - длина стороны уголка;
  • Толщина линии. Указывается только при выборе типа репера Уголок. Имеется в виду толщина линии репера.

Добавление элемента Репер

Редактирование элемента Репер

Удаление элемента Репер


Добавление элемента Репер

При добавлении элемент Репер помещается на белое поле, размеры которого высчитываются автоматически, исходя из заданных размеров репера.

Чтобы добавить на форму элемент Репер:

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
  1. На панели инструментов Элементы формы выберите инструмент Репер.
  2. Щелкните мышью на том месте формы, где вы хотите разместить репер, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Репер (на белом фоне) будет размещен в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

По умолчанию при создании новой формы с базовыми элементами добавляются реперы типа Черный квадрат. Если вы хотите изменить тип репера на Уголок, то выделите репер, щелкните правой кнопкой мыши и выберите пункт локального меню Свойства. В открывшемся диалоге измените тип репера.


Редактирование элемента Репер

Свойства Тип репера, Размер репера и Толщина линии (в случае репера Уголок) задаются на всю форму. Редактирование этих свойств приведет к изменению всех реперов на форме.

Для каждого элемента Репер

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
задаются координаты, тип и размер элемента. Свойства элемента Репер не зависят от вида формы.

Свойства элемента Репер можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Репер.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Указывает ширину элемента Репер.

Высота

Указывает высоту элемента Репер.

Внимание!

Изменить размер элемента Репер можно на закладке Репер.

Репер

Тип

Позволяет выбрать из списка стандартных реперов репер, который будет использоваться на форме (Черный квадрат или Уголок).

Одновременно на форме могут быть размещены реперы только одного типа.

Размер

Позволяет задать размер репера:
в случае Черного квадрата - длину стороны квадрата;
в случае Уголка - длину стороны уголка.

Толщина линии (только при выборе репера Уголок)

Позволяет задать толщину линии репера (от 0,3 мм до 1 мм).


Удаление элемента Репер

Для того чтобы удалить элемент Репер:

  1. Выделите элемент Репер;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Текст

Текст - элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

Добавление элемента Текст

Редактирование элемента Текст

Удаление элемента Текст


Добавление элемента Текст

Чтобы добавить на форму элемент Текст:

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

  1. На панели инструментов Элементы формы выберите инструмент Текст.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Текст

Для каждого элемента Текст

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.
задаются свойства: координаты и размеры элемента, текст, шрифт, перенос по словам, цвет текста, горизонтальное и вертикальное выравнивание, ориентацию, цвет фона элемента.

Текст элемента можно редактировать прямо в поле элемента. Для запуска режима редактирования текста щелкните на элементе правой кнопкой мыши или воспользуйтесь командой Редактировать текст… (локальное меню элемента Текст>Редактировать текст…). Для редактирования текста используйте горячие клавиши.

Свойства элемента Текст можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Текст.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Текст.

Высота

Позволяет задать высоту элемента Текст.

Текст

Текст

Позволяет редактировать текст элемента.

Шрифт

Позволяет редактировать шрифт для набора текста элемента.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить … В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.

Цвет

Позволяет выбрать из списка цвет текста*.

Переносить по словам

Позволяет переносить текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.

Выравнивание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.

  • По центру - позволяет выровнять текст горизонтально по центру элемента.

  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Текст цвет фона формы.

Другой

Позволяет выбрать другой цвет фона для элемента Текст *.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Текст

Для того чтобы удалить элемент Текст:

  1. Выделите элемент Текст;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Поле для ввода

Поле для ввода - элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.

Показать поле для ввода

Добавление элемента Поле для ввода

Редактирование элемента Поле для ввода

Удаление элемента Поле для ввода


Добавление элемента Поле для ввода

Чтобы добавить на форму элемент Поле для ввода:

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.
  1. На панели инструментов Элементы формы выберите инструмент Поле для ввода.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента*. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.
* - размер элемента Поля для ввода по вертикали можно менять только если в свойствах элемента отмечена опция Многострочное поле.


Редактирование элемента Поле для ввода

Для каждого элемента Поле для ввода

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.
задаются свойства: координаты и размер элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Поле для ввода можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Поле для ввода.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Поле для ввода.

Высота

Позволяет задать высоту элемента Поле для ввода.

Внимание!

Изменение количества строк в элементе Поле для ввода возможно только в случае если выбрано свойство Многострочное поле на закладке Разметка.

Изменение высоты знакоместа также производится на закладке Разметка.

Выравнивание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.

Разметка

Тип разметки текста

Позволяет выбрать тип разметки текста из списка:

  • Буквы в изолированных растровых рамках
  • Буквы в изолированных рамках
  • Буквы в гребенке
  • Текст в рамке с гребенкой
  • Буквы в рамках

Размер знакоместа

Позволяет выбрать предопределенный размер знакоместа из списка:

  • Стандартный - стандартный рекомендуемый размер знакоместа (4х5мм)
  • Максимальный - максимальный из рекомендуемых размеров знакоместа (5х6.5мм)
  • Минимальный - минимальный из рекомендуемых размеров знакоместа (3х4мм)

Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках)

Позволяет выбрать жирную линию разметки текста.

Цвет разметки

Позволяет выбрать из списка цвет разметки*.

Многострочное поле

Позволяет сделать поле для ввода многострочным.

Подсказка

Текст

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле для ввода: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Поле для ввода цвет фона формы

Другой

Позволяет выбрать другой цвет фона для элемента Поле для ввода *.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле для ввода

Для того чтобы удалить элемент Поле для ввода:

  1. Выделите элемент Поле для ввода;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Поле даты

Поле даты - это элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

Показать поле даты

Добавление элемента Поле даты

Редактирование элемента Поле даты

Удаление элемента Поле даты


Добавление элемента Поле даты

Чтобы добавить на форму элемент Поле даты:

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.
  1. На панели инструментов Элементы формы выберите инструмент Поле даты.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Поле даты будет размещено в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Поле даты

Для каждого элемента Поле даты

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.
задаются свойства: координаты элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, формат даты, количество знакомест для записи года, разделитель, цвет разделителя, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Поле даты можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Поле даты.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Указывает ширину элемента Поле даты.

Высота

Указывает высоту элемента Поле даты.

Внимание!

Изменение высоты знакоместа производится на закладке Разметка.

Выравнивание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.

Разметка

Тип разметки текста

Позволяет выбрать тип разметки текста из списка:

  • Буквы в изолированных растровых рамках
  • Буквы в изолированных рамках
  • Буквы в гребенке
  • Текст в рамке с гребенкой
  • Буквы в рамках

Размер знакоместа

Позволяет выбрать предопределенный размер знакоместа из списка:

  • Стандартный - стандартный рекомендуемый размер знакоместа (4х5мм)
  • Максимальный - максимальный из рекомендуемых размеров знакоместа (5х6.5мм)
  • Минимальный - минимальный из рекомендуемых размеров знакоместа (3х4мм)

Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках)

Позволяет выбрать жирную линию разметки текста.

Цвет разметки

Позволяет выбрать из списка цвет разметки*.

Дата

Формат даты

Позволяет выбрать формат даты:

  • ДД.ММ.ГГГГ

  • ММ.ДД.ГГГГ

  • ГГГГ.ММ.ДД

Кол-во знакомест для записи года

Позволяет выбрать количество знакомест для записи года:

  • 2 (под запись года будет отведено два знакоместа)

  • 4 (под запись года будет отведено два знакоместа)

Разделитель

Позволяет выбрать разделитель для записи даты:

  • .

  • /

  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле даты: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Поле даты цвет фона формы.

Другой

Позволяет выбрать другой цвет фона для элемента Поле даты *.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле даты

Для того чтобы удалить элемент Поле даты:

  1. Выделите элемент Поле даты;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Числовое поле

Числовое поле - элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.

Показать числовое поле

Добавление элемента Числовое поле

Редактирование элемента Числовое поле

Удаление элемента Числовое поле


Добавление элемента Числовое поле

Чтобы добавить на форму элемент Числовое поле:

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.
  1. На панели инструментов Элементы формы выберите инструмент Числовое поле.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Числовое поле

Для каждого элемента Числовое поле

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.
задаются свойства: координаты и размер элемента, разметка текста, размер знакоместа, многострочное поле, ширина линии разметки, цвет разметки, количество знакомест для записи дробной части десятичного числа, разделитель, цвет разделителя, текст подсказки, цвет текста подсказки, шрифт подсказки, автоматический подбор высоты шрифта подсказки, цвет фона элемента, связанное поле.

Свойства элемента Числовое поле можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Числовое поле.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Числовое поле.

Высота

Указывает высоту элемента Числовое поле.

Внимание!

Изменение высоты знакоместа производится на закладке Разметка.

Выравнивание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.
  • По центру - позволяет выровнять текст горизонтально по центру элемента.
  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.

Разметка

Тип разметки текста

Позволяет выбрать тип разметки текста из списка:

  • Буквы в изолированных растровых рамках
  • Буквы в изолированных рамках
  • Буквы в гребенке
  • Текст в рамке с гребенкой
  • Буквы в рамках

Размер знакоместа

Позволяет выбрать предопределенный размер знакоместа из списка:

  • Стандартный - стандартный рекомендуемый размер знакоместа (4х5мм)
  • Максимальный - максимальный из рекомендуемых размеров знакоместа (5х6.5мм)
  • Минимальный - минимальный из рекомендуемых размеров знакоместа (3х4мм)

Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках)

Позволяет выбрать жирную линию разметки текста.

Цвет разметки

Позволяет выбрать из списка цвет разметки*.

Число

Кол-во знаков после разделителя

Позволяет задать количество знакомест для записи дробной части десятичного числа.

Разделитель

Позволяет выбрать разделитель для записи числа:

  • .

  • /

  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в числовом поле: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Числовое поле цвет фона формы.

Другой

Позволяет выбрать другой цвет фона для элемента Числовое поле *.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Числовое поле

Для того чтобы удалить элемент Числовое поле:

  1. Выделите элемент Числовое поле;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Поле метки

Поле метки - элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

Добавление элемента Поле метки

Редактирование элемента Поле метки

Удаление элемента Поле метки


Добавление элемента Поле метки

Чтобы добавить на форму элемент Поле метки:

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
  1. На панели инструментов Элементы формы выберите инструмент Поле метки.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Поле метки

Для каждого элемента Поле метки

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
задаются свойства: координаты и размер элемента, тип ограничителя поля метки, расположение текста, размер поля метки, толщина линии ограничителя поля метки, расстояние до текста, текст, цвет текста, шрифт, перенос слов, цвет линии ограничителя, цвет фона элемента, связанное поле.

Свойства элемента Поле метки можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Пояснительный текст метки можно также редактировать, щелкнув два раза в области текста.

Свойство

Описание

Элемент

Тип

Поле метки.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Поле метки.

Высота

Позволяет задать высоту элемента Поле метки.

Текст

Текст

Позволяет редактировать пояснительный текст к полю метки.

Шрифт

Позволяет редактировать шрифт для набора пояснительного текста.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить … В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.

Цвет

Позволяет выбрать из списка цвет текста*.

Переносить по словам

Позволяет переносить пояснительный текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.

Поле метки

Тип

 Позволяет выбрать тип ограничителя поля метки:
  • Квадрат
  • Круг

Расположение

 Позволяет выбрать расположение поля метки относительно текста (пояснительной информации):
  • Метка слева - поле метки располагается слева от текста
  • Метка справа - поле метки располагается справа от текста
  • Метка сверху - поле метки располагается сверху от текста
  • Метка снизу - поле метки располагается снизу от текста

Размер

Позволяет выбрать предопределенный размер элемента Поле метки из списка (3,5х3,5 4х4 4,5х4,5 5х5 мм).

Толщина линии

Позволяет задать толщину линии ограничителя элемента Поле метки (от 0,4 мм до 0,8 мм).

Расстояние до текста

Позволяет задать расстояние от поля метки до текста пояснительной информации (от 2 мм до 7 мм).

Цвет

Позволяет выбрать из списка цвет линии ограничителя*.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Поле метки цвет фона формы.

Другой

Позволяет выбрать другой цвет фона для элемента Поле метки *.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление элемента Поле метки

Для того, чтобы удалить элемент Поле метки:

  1. Выделите элемент Поле метки;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Разделитель

Разделитель - это элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Добавление элемента Разделитель

Редактирование элемента Разделитель

Удаление элемента Разделитель


Добавление элемента Разделитель

Чтобы добавить на форму элемент Разделитель:

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.
  1. На панели инструментов Элементы формы выберите инструмент Разделитель.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемой длины элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. По умолчанию будет создан горизонтальный разделитель, а при нажатой клавише Shift - вертикальный. Размеры элемента определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Разделитель

Для каждого элемента Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.
задаются свойства: координаты и размер элемента, тип линии разделителя, толщина и цвет линии разделителя.

Свойства элемента Разделитель можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Разделитель.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Разделитель (только для горизонтальных разделителей).

Высота

Позволяет задать высоту элемента Разделитель (только для вертикальных разделителей).

Линия

Толщина

Позволяет задать толщину линии разделителя (от 0.1 мм до 2,5 мм).

Стиль

 Позволяет выбрать стиль для линии разделителя:
  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать цвет разделителя.

Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая). Для черно-белых форм цвет разделителя - черный.


Удаление элемента Разделитель

Для того, чтобы удалить элемент Разделитель:

  1. Выделите элемент Разделитель;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Элемент Рамка

Рамка - элемент машиночитаемой формы, ограничивающий некоторую область формы.

Показать рамку

Добавление элемента Рамка

Редактирование элемента Рамка

Удаление элемента Рамка


Добавление элемента Рамка

Чтобы добавить на форму элемент Рамка:

Элемент машиночитаемой формы, ограничивающий некоторую область формы.
  1. На панели инструментов Элементы формы выберите инструмент Рамка.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента. Отпустите мышь.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Рамка

Для каждого элемента Рамка

Элемент машиночитаемой формы, ограничивающий некоторую область формы.
задаются свойства: координаты и размеры элемента, толщина, стиль и цвет линии.

Свойства элемента Рамка можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Рамка.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Рамка.

Высота

Позволяет задать высоту элемента Рамка.

Линия

Толщина

Позволяет задать толщину линии рамки (от 0,1мм до 2,5мм).

Стиль

 Позволяет выбрать стиль для линии рамки:
  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать цвет рамки.

Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).


Удаление элемента Рамка

Для того чтобы удалить элемент Рамка:

  1. Выделите элемент Рамка;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Картинка

Картинка - элемент машиночитаемой формы, представляющий собой графическое изображение.

Добавление элемента Картинка

Редактирование элемента Картинка

Удаление элемента Картинка


Добавление элемента Картинка

Чтобы добавить на форму элемент Картинка:

Элемент машиночитаемой формы, представляющий собой графическое изображение.

  1. На панели инструментов Элементы формы выберите инструмент Картинка.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Не отпуская мышь, растяните прямоугольник разметки до желаемого размера элемента и отпустите мышь. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  3. В открывшемся диалоге Открыть (Open) укажите графический файл, из которого будет добавлено изображение.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Картинка

Для каждого элемента Картинка

Элемент машиночитаемой формы, представляющий собой графическое изображение.
задаются свойства: координаты и размеры элемента, режим изменения размера, выравнивание, файл, цвет фона элемента.

Свойства элемента Картинка можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Картинка.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Картинка.

Высота

Позволяет задать высоту элемента Картинка.

Картинка

Изменение размера

Позволяет изменять размер элемента в нескольких режимах:

  • Исходный размер - режим изменения размера элемента, при котором размер и пропорции изображения не меняются.
    В данном режиме невозможно увеличить исходный размер изображения.
    Если размер элемента стал меньше, чем размер изображения, то часть изображения не будет видна на форме.
  • Растягивание - режим изменения размера элемента, при котором изображение сжимается или растягивается в зависимости от размера элемента. Видно все изображение.
  • Масштабирование - режим изменения размера элемента, при котором изображение масштабируется (уменьшается или увеличивается) пропорционально размерам элемента. Видно все изображение.

Выравнивание

Позволяет выровнять изображение внутри разметки элемента.

  • Слева вверху - позволяет поместить изображение в левый верхний угол разметки элемента.
  • Справа вверху - позволяет поместить изображение в правый верхний угол разметки элемента.
  • В центре - позволяет поместить изображение в центр разметки элемента.
  • Слева внизу - позволяет поместить изображение в левый нижний угол разметки элемента.
  • Справа внизу - позволяет поместить изображение в правый нижний угол разметки элемента.

Файл

Позволяет указать файл с изображением.
Для того, чтобы указать файл с изображением:

  1. нажмите кнопку Обзор…;
  2. в открывшемся диалоге укажите путь к файлу с изображением.

Поддерживаются следующие форматы изображений:

  • Bitmap (*.bmp)
  • DCX (*.dcx)
  • JPEG (*.jpg; *.jpeg; *.jfif)
  • JPEG-2000 (*.jp2; *.j2c)
  • PCX (*.pcx)
  • PNG (*.png)
  • TIFF (*.tif; *.tiff)
  • PDF (*.pdf)

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Картинка цвет фона формы

Другой

Позволяет выбрать другой цвет фона для элемента Картинка.

Замечание. Список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).


Удаление элемента Картинка

Для того чтобы удалить элемент Картинка:

  1. Выделите элемент Картинка;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Идентификатор

Идентификатор - элемент машиночитаемой формы, однозначно характеризующий данную форму, либо одну из ее страниц.

Рекомендуется добавлять на форму элемент Идентификатор. Это необходимо для того, чтобы в процессе распознавания можно было безошибочно идентифицировать формы одного образца.

Элемент Идентификатор может быть либо идентификатором формы, тогда он будет идентифицировать всю форму, либо идентификатором страницы, тогда он будет идентифицировать страницу, на которой он расположен. Кроме того, можно задать пользовательское значение идентификатора.

С помощью программы ABBYY FormDesigner 8.0 можно создать идентификаторы следующих типов: штрих-код, штрих-код с цифрами, цифры. Все они являются вариантами представления 13-ти значного уникального номера - значения идентификатора, которое присваивается форме при публикации. До публикации на форме поверх элемента Идентификатор будет написано "Проект формы".

Для типов Штрих-код и Штрих-код с цифрами можно задать пользовательское значение идентификатора, выбрав тип штрих-кода (EAN13 или EAN8).

Тип идентификатора | Описание
Штрих-код | Тип идентификатора, представляющий собой штрих-код.
Штрих-код с цифрами | Тип идентификатора, представляющий собой штрих-код с последовательностью цифр, расположенной под (или над) штриховыми знаками.
Цифры 1236489271602 | Тип идентификатора, представляющий собой последовательность 13 цифр.

Добавление элемента Идентификатор

Редактирование элемента Идентификатор

Удаление элемента Идентификатор


Добавление элемента Идентификатор

Чтобы добавить на форму элемент Идентификатор:

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

  1. На панели инструментов Элементы формы выберите инструмент Идентификатор.
  2. Щелкните мышью на том месте формы, где вы хотите разместить элемент, и, удерживая мышь в нажатом состоянии, сдвиньте мышь по диагонали. На экране появится разметка в виде прямоугольника. Идентификатор будет размещен в левом верхнем углу разметки после того, как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.


Редактирование элемента Идентификатор

Стандартный размер идентификатора - 46х12 мм.

Для каждого элемента Идентификатор

Элемент машиночитаемой формы, однозначно характеризующий данную форму.
задаются свойства: координаты и размер элемента, тип, ориентация и значение. Свойства элемента Идентификатор не зависят от вида формы.

Свойства элемента Идентификатор можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Идентификатор.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Указывает ширину элемента Идентификатор.

Высота

Указывает высоту элемента Идентификатор.

Идентификатор

Тип

 Позволяет выбрать тип Идентификатора:
  • Штрих-код
  • Штрих-код с цифрами
  • Цифры

Тип штрих-кода

Позволяет выбрать тип штрих-кода, если тип идентификатора Штрих-код или Штрих-код с цифрами и если отмечена опция Пользовательское значение.

Штрих-код может относится к одному из типов:

  • EAN13
  • EAN8

Если не отмечена опция Пользовательское значение, то поле Тип штрих-кода недоступно для редактирования. Тип штрих-кода в этом случае - EAN13.

Ориентация

 Позволяет задать ориентацию штрих-кода:
  • Вертикальная
  • Горизонтальная

Значение

Указывается значение идентификатора.

Значение идентификатора может быть введено пользователем, только если выбрана опция Пользовательское значение. Для EAN13 пользовательское значение должно содержать 12 цифр, для EAN8 - 7 цифр. Неправильная длина или символы, отличные от цифр, недопустимы. Для EAN13 дополнительная контрольная цифра добавляется в начале строки цифр (вне штрих-кода), для EAN8 - в конце строки, в теле штрих-кода.

Если выбрана одна из опций Идентификатор формы или Идентификатор страницы, значение идентификатору присваивается автоматически во время публикации формы. До публикации формы она имеет статус Редактируемая и уникальное значение идентификатору ещё не присвоено.

Идентификатор формы

Позволяет использовать элемент в качестве идентификатора формы.

Идентификатор страницы

Позволяет использовать элемент в качестве идентификатора текущей страницы.

Пользовательское значение

Позволяет задать пользовательское значение идентификатора. Опция недоступна, если задан тип идентификатора Цифры.


Удаление элемента Идентификатор

Для того чтобы удалить элемент Идентификатор:

  1. Выделите элемент Идентификатор;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента>Удалить).


Элемент Таблица

Таблица - элемент машиночитаемой формы. Таблица содержит столбцы с однотипными элементами.

Столбцы таблицы могут содержать элементы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.

Таблица может содержать строку с заголовками столбцов.

В структуре документа поле типа таблица содержит дочерние поля. Каждому дочернему полю соответствует столбец элемента Таблица.

Добавление элемента Таблица

Редактирование элемента Таблица

Удаление элемента Таблица


Добавление элемента Таблица

Чтобы добавить на форму элемент Таблица:

Элемент машиночитаемой формы содержащий столбцы с однотипными элементами, например, с полями для ввода текста или с метками. Может содержать строку с заголовками столбцов.
  1. На панели инструментов Элементы формы выберите инструмент Таблица.
  2. Щелкните мышью на том месте формы, где вы хотите разместить таблицу, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.
  3. В открывшемся диалоге определите вид таблицы.
    • Отметьте опцию Использовать первую строку как заголовок, если вы хотите использовать первую строку в качестве заголовка;
    • Задайте название и тип данных для колонок таблицы. Для этого в таблице, расположенной в центральной части диалога, введите названия и типы данных вместо определенных по умолчанию. Вы можете добавить любое количество столбцов;
    • Введите количество строк таблицы в поле Количество строк.

Добавление разделителей

Если на форме есть таблица, то кнопки панели инструментов для добавления и удаления разделителей становятся активными. С помощью этих кнопок вы сможете добавлять и удалять разделители таблицы, тем самым изменяя количество строк и столбцов.

При выбранном инструменте Добавить разделитель доступны следующие возможности:

  • Если щелкнуть мышью внутри таблицы, будет создан разделитель;
  • Если навести курсор на уже существующий разделитель, то его можно переместить. Если навести курсор на пересечение разделителей, то можно переместить сразу два разделителя.
  • Нажав клавишу Ctrl и наведя курсор на существующий разделитель, можно его удалить.
  • Нажав клавишу Shift, можно изменить тип создаваемого разделителя (горизонтальный вместо вертикального и наоборот).

Создание столбцов

Столбцы таблицы могут быть заполнены только элементами одного типа. Чтобы заполнить столбцы таблицы, выберите нужный элемент на панели инструментов и щелкните в области столбца. В каждой ячейке столбца будет нарисован элемент выбранного типа.

Можно создать столбцы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.


Редактирование элемента Таблица

Для каждого элемента Таблица

Элемент машиночитаемой формы содержащий столбцы с однотипными элементами, например, с полями для ввода текста или с метками. Таблица может содержать строку с заголовками столбцов.
задаются свойства: координаты и размер элемента, толщина, стиль и цвет линий, цвет фона, расстояние между ячейками, является ли первая строка заголовком, связанное поле.

Свойства элемента Таблица можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Таблица.

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Таблица.

Высота

Позволяет задать высоту элемента Таблица.

Линия

Толщина

Позволяет задать толщину линии ограничителя (от 0,1мм до 2,5мм).

Стиль

Позволяет выбрать стиль для линий:

  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать из списка цвет линий таблицы*.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для элемента Таблица цвет фона формы.

Другой

Позволяет выбрать другой цвет фона таблицы*.

Таблица

Расстояние между ячейками

Позволяет задать расстояние между ячейками таблицы.

Использовать первую строку как заголовок

Если эта опция отмечена, то первая строка будет использоваться в качестве заголовков столбцов таблицы.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).


Удаление элемента Таблица

Для того, чтобы удалить элемент Таблица:

  1. Выделите элемент Таблица;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).


Группа элементов

Группа элементов - элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов. Группа элементов используется для объединения логически связанных элементов, для создания групп меток.

Объединение элементов в группу производится также для быстрого копирования этих элементов с сохранением всех свойств. Использовать группы элементов целесообразно, например, в случае, если на форме нужно создать несколько поданкет с одинаковым набором полей.

Допускается вложенная структура групп элементов.

Добавление Группы элементов

Редактирование Группы элементов

Удаление Группы элементов


Добавление Группы элементов

Чтобы добавить на форму Группу элементов:

Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов.
  1. На панели инструментов Элементы формы выберите инструмент Группа элементов.
  2. Щелкните мышью на том месте формы, где вы хотите разместить группу, и, удерживая мышь в нажатом состоянии, сдвиньте ее по диагонали. На экране появится разметка в виде прямоугольника, после того как вы отпустите кнопку мыши.
  3. Вы можете создать элемент одним щелчком мыши, для этого после выбора инструмента просто щелкните в нужном месте страницы. Размеры элемента при этом определяются по умолчанию.
  4. Для создания нескольких элементов одного типа удерживайте нажатой клавишу Ctrl.

Добавление элементов в группу

Элементы можно добавить в группу тремя способами:
  1. Создайте элементы, которые должны войти в группу. Выберите инструмент Группа элементов и с помощью мыши обведите созданные элементы прямоугольником. Элементы формы, полностью оказавшиеся внутри прямоугольника, будут входить в группу.
  2. Создайте группу с помощью инструмента Группа элементов. Создайте элементы внутри области группы.
  3. Создайте группу с помощью инструмента Группа элементов. С помощью мыши перетащите нужные элементы формы внутрь группы.
Для того чтобы скопировать группу со всеми ее элементами, выделите группу так, чтобы были выделены все элементы группы. Тогда при копировании группы будут скопированы все элементы с сохранением их свойств.


Редактирование Группы элементов

Для каждой Группы элементов
Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов.
 задаются свойства: координаты, размер, тип линий, цвет фона, связанное поле.

Свойства Группы элементов можно редактировать в окне Свойства. Это окно расположено в нижней правой части главного окна. Элемент, свойства которого вы хотите просмотреть или отредактировать, должен быть выделен, а в главном меню должен быть отмечен пункт Вид>Свойства.

Свойство

Описание

Элемент

Тип

Группа элементов

Группа Координаты и размеры

Слева

Позволяет задать величину отступа: от левого края формы до элемента.

Сверху

Позволяет задать величину отступа: от верхнего края формы до элемента.

Ширина

Позволяет задать ширину элемента Группа элементов.

Высота

Позволяет задать высоту элемента Группа элементов.

Текст

Текст

Позволяет редактировать пояснительный текст к группе элементов.

Шрифт

Позволяет редактировать шрифт для набора пояснительного текста.
Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить … В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.

Цвет

Позволяет выбрать из списка цвет текста*.

Переносить по словам

Позволяет переносить пояснительный текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.

Линия

Толщина

Позволяет задать толщину линии ограничителя (от 0,1мм до 2,5мм).

Стиль

Позволяет выбрать стиль для линий:

  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать из списка цвет линий ограничителя группы*.

Фон

Цвет фона формы

Позволяет выбрать в качестве цвета фона для Группы элементов цвет фона формы.

Другой

Позволяет выбрать другой цвет фона группы*.

Связанное поле

Связанное поле

По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.

*- список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Удаление Группы элементов

Для того, чтобы удалить Группу элементов:

  1. Выделите Группу элементов;
  2. Выберите команду Удалить (меню Правка>Удалить или локальное меню элемента> Удалить).

Внимание! Если при выполнении команды удаления выделены элементы группы, то группа элементов удаляется вместе с ними. Чтобы удалить группу, но оставить все элементы, следите, чтобы при выполнении команды была выделена только сама группа.


Выделение и перемещение элементов формы

Прежде чем редактировать или перемещать элемент формы, его необходимо выделить.

Для того чтобы выделить элемент формы:

  1. Выберите на панели инструментов Элементы формы инструмент Инструмент выбора.
  2. Щелкните на нужном элементе формы.

Для того чтобы переместить элемент формы:

  1. Выделите элемент формы.
  2. Установите курсор внутри элемента; изображение курсора изменится на [image].
  3. Щелкните на элементе левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Для того чтобы одинаково переместить несколько элементов одновременно, необходимо:

  1. Выделить элементы (выберите инструмент Инструмент выбора и, удерживая клавишу Shift, последовательно щелкните мышью на всех необходимых элементах).
  2. Установите курсор внутри одного из выделенных элементов; изображение курсора изменится на [image].
  3. Щелкните на элементе левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

При создании поле ввода (текстовое, числовое, поле даты) связывается со своим заголовком. При перемещении такого поля его заголовок перемещается вместе с ним.

При перемещении элементов с нажатой клавишей Ctrl создается копия элемента (или нескольких элементов).

Для того чтобы выделить элементы, входящие в группу элементов, щелкните левой кнопкой мыши внутри контура группы. При перемещении группы элементов, будут перемещены все элементы, входящие в нее.

Для выделенных элементов формы возможен просмотр и редактирование общих свойств.

Объединение элементов формы

Выравнивание элементов с помощью линеек


Объединение элементов формы

Объединение элементов формы помогает сохранить взаимное расположение элементов относительно друг друга при перемещении элементов.

Чтобы объединить несколько элементов:

  1. Выделите элементы формы, которые вы хотите объединить;
  2. Выберите инструмент Объединить на панели Редактирование.

Чтобы разъединить элементы:

  1. Выделите объединенные элементы формы;
  2. Выберите инструмент Разъединить на панели Редактирование.

Чтобы добавить элемент к ранее объединенным:

  1. Выделите объединенные элементы;
  2. Нажмите клавишу Shift, и, удерживая ее, выделите элемент, который необходимо добавить к ранее объединенным;
  3. Выберите инструмент Добавить к объединенным на панели Редактирование.


Выравнивание элементов с помощью линеек

Линейки являются удобным графическим инструментом для выравнивания элементов формы. Элементы, которые должны находиться на одном уровне (вертикальном или горизонтальном) "привязываются" к соответствующей линейке. При перемещениях линейки все привязанные элементы перемещаются вместе с ней. Это избавляет от необходимости каждый раз вручную выделять все элементы, которые должны быть перемещены вместе.

Можно привязать две стороны элемента к двум параллельным линейкам, тогда при перемещении линеек будет изменяться размер элемента. Привязав две стороны нескольких элементов к двум линейкам, можно изменять горизонтальный или вертикальный размер сразу нескольких элементов.

Добавление линеек

Для того чтобы добавить линейки на страницу выполните одно из следующих действий:

  • Щелкните левой кнопкой мыши на одной из основных линеек, расположенных по краям формы. При клике на горизонтальной линейке будет добавлена вертикальная линейка и наоборот.
  • Выберите инструмент [image] для добавления горизонтальной линейки или [image] для добавления вертикальной линейки. Щелкните мышью в том месте страницы, куда вам нужно добавить линейку.

Привязка элементов к линейкам

Чтобы привязать элемент к линейке, нужно совместить одну из границ элемента с линейкой. Это можно сделать перемещая линейку, элемент или изменяя размер элемента.

Если включен режим автоматической привязки линеек к элементам ( [image]), то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки. По умолчанию, этот режим выключен.

При выделении линейки все привязанные к ней элементы также выделяются с помощью рамки того же цвета, что и линейка. При выделении объекта, привязанного к какой-либо линейке, квадрат в середине стороны, привязанной к линейке, окрашивается в красный цвет. Таким образом, всегда можно понять, к каким линейкам привязан выделенный элемент и какие элементы привязаны к выделенной линейке.

Перемещение линеек и элементов

Добавленные линейки можно перемещать по форме, нажав и удерживая кнопку мыши. Две линейки, оказавшиеся на одном и том же месте, сливаются в одну.

При перемещении линейки вместе с ней перемещаются все привязанные к ней элементы. У элементов, привязанных к двум параллельным линейкам, при перемещении одной из линеек изменяется размер (если изменение размера для этого элемента возможно).

Разрыв связи элемента с линейкой

Для того чтобы разорвать связь элемента с линейкой, достаточно выделить элемент и переместить его.

Удаление линеек

Для удаления линейки ее необходимо выделить и нажать клавишу Delete или выбрать соответствующую команду в меню.


Изменение размера элемента формы

Изменение размера элемента формы возможно по направлениям, соответствующим зеленым квадратам границы элемента, которые видны при выделении элемента на форме.

Изменение размера возможно не для всех элементов, например, размер репера можно изменить только в диалоге Свойства на закладке Репер. Если изменение размера элемента возможно, то при выделении элемента на его сторонах появляются зеленые квадраты, если нет - белые.

Для того чтобы изменить размер элемента формы:

  1. Выделите элемент формы.
  2. Установите курсор на зеленый квадрат границы элемента, соответствующую выбранному направлению изменения размера; изображение курсора изменится на стрелочки специального вида.
  3. Щелкните на зеленом квадрате левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Возможно симметрично изменять размеры элемента, т.е. размеры элемента будут симметрично изменяться в выбранном направлении и направлении, противоположном выбранному.

Для того чтобы симметрично изменить размер элемента формы :

  1. Выделите элемент формы.
  2. Нажмите на клавиатуре и удерживайте кнопку Ctrl.
  3. Установите курсор на нужный зеленый квадрат границы элемента; изображение курсора изменится на стрелочки специального вида.
  4. Щелкните на зеленом квадрате левой кнопкой мыши и, удерживая кнопку нажатой, переместите мышь в нужном направлении.

Можно изменять размер элементов с помощью привязки двух сторон элемента к параллельным линейкам. Привязав к двум параллельным линейкам две стороны нескольких элементов, можно изменять горизонтальный или вертикальный размер сразу нескольких элементов. Таким образом вы можете изменять размер сразу нескольких элементов одинаковой высоты или ширины, при этом высота или ширина этих элементов останется равной.

Для того чтобы изменить размер элементов с помощью линеек:

  1. Создайте две параллельные линейки с помощью инструментов [image] или [image].
  2. Переместите линейки или элементы таким образом, чтобы противоположные стороны элементов были совмещены с линейками. При этом стороны элементов будут привязаны к линейкам.
  3. Щелкните на одной из линеек и, не отпуская кнопку мыши, переместите ее. Размер всех элементов, привязанных к параллельным линейкам, будет изменяться одновременно с перемещением линейки.

Замечание. Размер элемента Поле для ввода по вертикали можно менять только если в свойствах элемента отмечена опция Многострочное поле.


Изменение фона элемента формы

В программе существует возможность изменить цвет отдельных элементов формы, в то время как все остальные элементы формы останутся черно-белыми.

Замечание. Устанавливать и изменять цвет фона можно только для следующих элементов формы:

  • Текст
  • Поле для ввода
  • Поле даты
  • Поле метки
  • Числовое поле
  • Картинка
  • Таблица
  • Группа элементов

Для того чтобы изменить цвет отдельных элементов формы:

  1. Измените вид формы на цветную фоновую на закладке Цвет диалога Свойства страницы (меню Форма>Свойства страницы…);
  2. Измените цвет формы на белый. Для этого:
    • Перейдите на закладку Цвет диалога Свойства страницы (меню Форма>Свойства страницы…);
    • В группе Фон формы в поле Цвет установите Белый;
  3. Измените цвет нужных вам элементов формы. Для этого:
    • Выделите нужные вам элементы формы;
    • Выберите команду Свойства… (локальное меню элемента);
    • Перейдите на закладку Фон диалога Свойства;
    • Отмените выбор опции Цвет фона формы и в поле Другой выберите нужный цвет;
  4. Для всех остальных элементов формы установите белый фон и черный цвет разметки.


Структура документа

При добавлении элементов на форму автоматически создается структура документа - иерархическая структура полей, к каждому из которых привязан один или несколько элементов на изображении формы. ABBYY FormDesigner 8.0 позволяет редактировать структуру документа, привязывать элементы к любым полям соответствующего типа.

Структура документа сохраняется и экспортируется как часть XFD-файла.

Отображение структуры документа

Чтобы отобразить структуру документа выберите пункт меню Вид>Структура документа. В правой части основного окна отобразится иерархическая структура полей документа. Вы можете добавлять новые поля, а также удалять, переименовывать и перемещать вверх и вниз все поля. Для этого воспользуйтесь пунктами локального меню Добавить поле (Удалить поле, Переименовать поле). Перемещать поля в структуре можно также с помощью клавиш ctrl+стрелка вверх/вниз или с помощью пунктов локального меню Переместить вверх/Переместить вниз. Если к полям привязаны элементы, то эти поля можно перемещать только на том же уровне, где они сейчас находятся, а если элементы к полям не привязаны, то их можно перемещать также в группу или из группы.

Добавление полей

При создании нового элемента формы автоматически создается новое поле структуры документа. Это поле имеет тот же тип, что и созданный элемент. Для создания нового поля вручную, выберите пункт локального меню >Добавить поле и выберите тип нового поля.

Привязка элементов формы к полям

При создании нового элемента формы, он будет привязан к автоматически созданному полю структуры документа. Для того чтобы привязать элемент к другому полю, выполните следующие действия:

  • выделите элемент на изображении формы;
  • щелкните в области элемента правой кнопкой мыши и выберите пункт локального меню Свойства…;
  • в диалоге свойства перейдите на закладку Связанное поле и выберите другое поле из выпадающего списка. Вы сможете выбирать только среди полей того типа, к которому относится выбранный элемент. Если элемент входит в группу, то он может быть привязан только к полям, принадлежащим соответствующему групповому полю.

Замечание. Названия полей, к которым не привязано ни одного элемента, выделяются курсивом в окне структуры документа.

Удаление полей и элементов

Чтобы удалить поле в структуре документа выделите его и нажмите клавишу Delete либо воспользуйтесь командой локального меню Удалить. При удалении поля связанный с ним элемент будет удален с формы.

При удалении элемента формы связанное поле удаляется, если к нему не привязаны другие элементы. Чтобы удалить элемент, не удаляя поле, можно воспользоваться клавишами Shift+Delete или командой Удалить блок в меню Правка или в локальном меню элемента.


Сохранение и публикация формы. Проверка формы на машиночитаемость

Разработка формы предполагает несколько этапов, среди которых есть непосредственно создание формы, согласование, внесение изменений и т.д. Для сохранения промежуточных результатов разработки формы рекомендуется использовать стандартную команду сохранения. После согласования и утверждения окончательного варианта разработанной формы рекомендуется опубликовывать форму, т.е. присваивать форме статус, не позволяющий вносить в форму никаких изменений. Это поможет вам избежать различных "окончательных" версий одной и той же формы.

Сохранение

Публикация

Проверка формы на машиночитаемость


Сохранение

Для сохранения изменений в форме воспользуйтесь командами Сохранить или Сохранить как… в меню Файл. Команда Сохранить (или Сохранить как…) - стандартная команда, позволяющая сохранить изменения, внесенные в файл.

Команда Сохранить как… позволяет сохранить как форму, так и образец формы или страницы формы. Для выбора формата используется выпадающий список поля Тип файла (Save as type).

Формы, созданные в программе ABBYY FormDesigner 8.0, сохраняются с расширением fdd (Form Definition Files).

Образец формы сохраняется в двоичном файле с расширением dtf, а страницы - с расширением ptf, в формате, представляющем собой модифицированный формат fdd-файла.


Проверка формы на машиночитаемость

Проверка формы на машиночитаемость запускается автоматически при публикации или вручную в любой момент разработки формы (меню Сервис>Проверить форму).

Если в ходе проверки ошибки не обнаружены, то на экран выводится сообщение о том, что проверка прошла успешно.

Если же в ходе поверки формы были обнаружены ошибки, то по окончанию проверки формы результаты проверки отобразятся в нижней части окна.

Отчет о проверке включает в себя все найденные программой несоответствия формы требованиям машиночитаемости: отсутствие реперов, отсутствие идентификатора, нарушение расстояний между элементами, неправильные отступы формы и т.д. Каждой строке соответствует ошибка.

Кнопка | Описание
Показать элементы | Позволяет показать элемент, не соответствующий требованиям машиночитаемости. Кнопка становится доступной при щелчке мышью по одной из строк отчета.
Проверить форму | Позволяет повторно запустить проверку формы на машиночитаемость.
Сохранить отчет… | Позволяет сохранить отчет о результатах проверки в *.TXT файл.


Публикация

Публикация формы - это процесс, при котором форме присваивается статус (Опубликованная), не позволяющий вносить в форму изменения. Во время публикации автоматически запускается проверка формы на машиночитаемость, элементам Идентификатор

Элемент машиночитаемой формы, однозначно характеризующий данную форму.
присваивается уникальное значение (одно для всех), а статус формы меняется с Редактируемая на Опубликованная. Опубликованные формы доступны только для просмотра.

Для того чтобы опубликовать форму, воспользуйтесь командой Опубликовать (меню Файл).

Публикация с предупреждением

Если при публикации формы были обнаружены несоответствия формы требованиям машиночитаемости (предупреждения), то открывается диалог Публикация с предупреждением, с помощью которого возможно исправить найденные несоответствия или опубликовать форму, несмотря на наличие предупреждений.

Внимание!

Использование формы, несоответствующей требованиям машиночитаемости, может значительно снизить качество распознавания!

В диалоге Публикация с предупреждением содержится отчет, включающий в себя все найденные программой несоответствия формы требованиям машиночитаемости.

Кнопка | Описание
Опубликовать | Позволяет опубликовать форму, несмотря на наличие несоответствий формы требованиям машиночитаемости.
Редактировать | В нижней части окна появляется отчет о результатах проверки формы, с помощью которого возможно исправить найденные несоответствия формы требованиям машиночитаемости.

Редактирование опубликованной формы

Для того чтобы внести изменения в опубликованную форму, воспользуйтесь командой Сохранить редактируемую копию как… (меню Файл). При этом вам сначала будет предложено сохранить форму под другим именем, а потом вносить изменения. Статус формы с новым именем поменяется с Опубликованная на Редактируемая, значение элементов Идентификатор обнулится.

Совет
Рекомендуется публиковать форму после окончания разработки. Это поможет вам отслеживать внесение изменений в форму и избежать несогласованности версий во время тиражирования формы.


Печать формы

Для того чтобы распечатать текущую форму:

  1. Выберите команду Печать… (меню Файл>Печать…);
  2. В открывшемся диалоге Печать (Print) задайте свойства печати.
Внимание!

Если форма не опубликована, то при печати по периметру формы печатается слово "Черновик".


Печать заполненных форм

Программа ABBYY FormDesigner 8.0 позволяет печатать не только пустые формы, но и формы, у которых заполнены некоторые поля. Например, если вы хотите напечатать именные бланки, то вы можете создать пустой бланк в программе FormDesigner, а затем распечатать бланки, в которые уже вписаны фамилии заполняющих. Фамилии можно взять из файла или из базы данных.

Для того чтобы распечатать заполненную форму с подстановкой данных из БД:

  1. Выберите команду Распечатать заполненные формы>Со значениями из базы данных… (меню Файл).
  2. Задайте параметры соединения с базой данных.

Внимание! В базе данных должны быть поля с теми же названиями, что и в форме.

Для того чтобы распечатать заполненную форму с подстановкой данных из файла:

  1. Выберите команду Распечатать заполненные формы>Со значениями из файла… (меню Файл).
  2. Укажите путь к файлу.

Внимание! Для подстановки значений используются файлы формата *. csv в кодировке Unicode. Верхняя строчка файла считается шапкой, в ней должны содержаться названия полей. В файле должны быть поля с теми же названиями, что и в форме.

При печати заполненных форм типы данных корректно преобразуются, например, если на форме есть поле метки, которое вы хотите заполнить, то в соответствующем поле файла или базы данных могут быть значения True/False или 1/0. Для радиогруппы нужно завести отдельную колонку с названием каждого пункта, в колонках проставить значения yes или no, в зависимости от того, должен ли быть отмечен соответствующий пункт.

Шрифт распечатанных данных соответствует шрифту подсказки, который задается в окне свойств элемента на вкладке Подсказка.


Экспорт формы

После того как форма разработана и опубликована, она может бы экспортирована в графический формат или специальный формат XML Form Definition.

Экспорт в графические форматы может понадобиться при передаче формы в типографию.

Экспорт в формат XML Form Definition позволяет получить файл описания, на основе которого в программе ABBYY FlexiCapture будет создан шаблон документа.

Экспорт в файл изображения

Экспорт в XML Form Definition format (*.xfd)


Экспорт в файл изображения

Экспорт формы в файл изображения возможен в любой момент разработки формы. Если форма имеет статус Редактируемая, то на изображении формы поверх идентификатора будет написано "Черновик". Если форма имеет статус Опубликованная, то идентификатор будет иметь стандартный вид, в соответствии с выбранным типом идентификатора.

Для того чтобы получить изображение формы, воспользуйтесь командой Файл изображения… (меню Файл>Экспортировать в>Файл изображения…). В открывшемся диалоге Сохранить изображение как выберите формат файла изображения и укажите название файла и папку, куда файл будет сохранен.

Программа ABBYY FormDesigner 8.0 поддерживает экспорт в следующие форматы изображений:
  • Bitmap, черно-белый (*.bmp)
  • Bitmap, серый (*.bmp)
  • Bitmap, цветной (*.bmp)
  • JPEG, серый (*.jpg)
  • JPEG, цветной (*.jpg)
  • JPEG-2000, серый (*.jpg)
  • JPEG-2000, цветной (*.jpg)
  • PCX, черно-белый (*.pcx)
  • PCX, серый (*.pcx)
  • PNG, черно-белый (*.png)
  • PNG, серый (*.png)
  • PNG, цветной (*.png)
  • TIFF, черно-белый, несжатый (*.tif)
  • TIFF, черно-белый, Group3 (*.tif)
  • TIFF, черно-белый, Group4 (*.tif)
  • TIFF, черно-белый, packbits (*.tif)
  • TIFF, черно-белый, сжатие: ZIP (*.tif)
  • TIFF, серый, несжатый (*.tif)
  • TIFF, серый, packbits (*.tif)
  • TIFF, серый, сжатие: JPEG (*.tif)
  • TIFF, серый, сжатие: ZIP (*.tif)
  • TIFF, цветной, несжатый (*.tif)
  • TIFF, цветной, сжатие: JPEG (*.tif)
  • TIFF, цветной, сжатие: ZIP (*.tif)
  • PDF (*.pdf)
  • EMF (*.emf)

Экспорт изображений с цветоделением

Для печати форм в типографии в 2 цвета вам может понадобиться сохранить цветную форму в два файла: в один записывается то, что должно быть напечатано черной краской, в другой - то, что должно печататься цветной краской.

Для экспорта изображения формы с разделением на цвета выберите пункт меню Файл>Экспортировать в>Изображения с цветоделением…. Изображения будут сохранены в файлах формата TIFF, к названию черно-белого файла добавляется _bw, а к названию цветного - _color.

Экспорт изображений многостраничных форм

Изображение многостраничной формы можно проэкспортировать в любой из поддерживаемых графических форматов. Для многостраничных форматов есть возможность сохранить форму в многостраничном файле. Для этого при сохранении файла изображения отметьте опцию Многостраничный файл. Если вы не отметите эту опцию, каждая страница будет сохранена в отдельном файле.

Экспорт в формат TIFF с произвольным разрешением

Изображения можно экспортировать в формат TIFF с произвольным разрешением. Значение разрешения для формата TIFF можно ввести на закладке Экспорт диалога Настройки (меню Сервис>Настройки…).

Замечание. Значение разрешения для формата TIFF должно быть не менее 50 и не более 1200 dpi.


Экспорт в XML Form Definition (*.xfd)

С помощью программы ABBYY FormDesigner 8.0 вы можете разработать не только саму форму, но и получить описание формы, которое может быть использовано для создания шаблона документа в программе ABBYY FlexiCapture 8.0 Professional (Шаблон документа - это описание элементов и правил в определенном формате, используемое для распознавания документов).

Для того чтобы получить описание формы, необходимо с помощью программы ABBYY FormDesigner 8.0 экспортировать форму в файл специального формата XML Form Definition (*.xfd), а затем импортировать его в программе ABBYY FlexiCapture 8.0 Professional (при создании шаблона документа). Программа ABBYY FlexiCapture автоматически создаст шаблон на основе файла *.xfd.

Экспорт в формат XML Form Definition возможен только после публикации формы.

В программе ABBYY FormDesigner 8.0 возможно выбрать формат (TIFF или EMF), в котором будет сохранено изображение формы при экспорте формы в файл формата *.xfd.

Для того чтобы получить файл с расширением *.xfd, воспользуйтесь командой XML Form Definition… (меню Файл>Экспортировать в>XML Form Definition…). В открывшемся диалоге Экспорт в XML Form Definition укажите название файла и папку, куда он будет сохранен.


Меню Файл

Пункт меню | Описание
Новая… | Позволяет запустить Мастер создания формы.
Открыть… | Позволяет открыть форму.
Сохранить | Позволяет сохранить форму.
Сохранить как… | Позволяет сохранить форму под другим именем, а также сохранить образец формы и страницы.
Экспортировать в |
Файл изображения… | Позволяет экспортировать форму в файл изображения.
Изображения с цветоделением… | Позволяет экспортировать цветную форму в файлы изображения с разделением на цвета. В результате будут сохранены два файла в формате TIFF - черно-белый и цветной.
XML Form Definition… | Позволяет экспортировать форму в формат XML Form Definition.
Опубликовать | Позволяет опубликовать форму.
Сохранить редактируемую копию как… | Позволяет сохранить и редактировать копию опубликованной формы.
Настройка печати… | Позволяет открыть диалог Настройка печати.
Просмотр | Позволяет просмотреть форму перед печатью.
Печать… | Позволяет открыть диалог Печать.
Распечатать заполненные формы |
Со значениями из базы данных… | Позволяет распечатать формы, заполненные значениями из базы данных.
Со значениями из файла… | Позволяет распечатать формы, заполненные значениями из файла.
Последние файлы | Позволяет выбрать из списка и открыть один из ранее открытых файлов.
Выход | Позволяет закрыть программу ABBYY FormDesigner 8.0.


Меню Правка

Пункт меню | Описание
Отменить | Позволяет отменить действие последней выполненной команды.
Повторить | Позволяет отменить действие последней команды Отменить.
Вырезать | Позволяет удалить выделенный элемент (или текст) и помещает его в Буфер обмена.
Копировать | Позволяет скопировать выделенный элемент (или текст) в Буфер обмена.
Вставить | Позволяет вставить элемент (или текст) из Буфера обмена.
Удалить | Позволяет удалить выделенные элементы. Связанные с ними поля структуры документа также будут удалены.
Дублировать | Позволяет дублировать выделенные элементы.
Редактировать текст… | Позволяет редактировать текст выделенного элемента Текст или Поле метки.
Переименовать поле | Позволяет переименовать выделенное поле структуры документа.
Удалить блок | Позволяет удалить выделенные элементы, не удаляя связанные поля структуры документа.
Выделить все | Позволяет выделить все элементы формы.
Выделить по типу… | Позволяет открыть диалог Выделить типы элементов, в котором можно указать типы выделяемых элементов.


Меню Вид

Пункт меню | Описание
Панели инструментов |
Стандартная | Позволяет отобразить/спрятать панель инструментов Стандартная.
Форматирование | Позволяет отобразить/спрятать панель инструментов Форматирование.
Элементы формы | Позволяет отобразить/спрятать панель инструментов Элементы формы.
Редактирование | Позволяет отобразить/спрятать панель инструментов Редактирование.
Большие кнопки | Позволяет увеличить/уменьшить размер кнопок панелей инструментов.
Строка состояния | Позволяет отобразить/спрятать строку состояния.
Структура документа | Позволяет отобразить/спрятать окно с иерархической структурой документа.
Свойства | Позволяет отобразить/спрятать окно свойств элемента.
Сетка | Позволяет отобразить/спрятать сетку разметки.
Основная линейка | Позволяет отобразить/спрятать основную линейку.
Отступы | Позволяет отобразить/спрятать разметку отступов по краям формы.
Привязать к сетке | Позволяет включить/отключить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
Привязывать линейки к элементам | Включает/выключает режим автоматической привязки линеек к элементам. Если режим включен, то при перемещении линейки по форме, она автоматически привязывается к элементам, граница которых оказывается достаточно близко к положению линейки.
Масштаб |
200% | Позволяет установить масштаб 200% в окне Форма.
150% | Позволяет установить масштаб 150% в окне Форма.
100% | Позволяет установить масштаб 100% в окне Форма.
75% | Позволяет установить масштаб 75% в окне Форма.
50% | Позволяет установить масштаб 50% в окне Форма.
По ширине | Позволяет установить в окне Формы такой масштаб, при котором изображение умещается на экране по ширине.
По высоте | Позволяет установить в окне Формы такой масштаб, при котором изображение умещается на экране по высоте.
Форму целиком | Позволяет установить в окне Формы такой масштаб, при котором форма умещается на экране целиком.
Уменьшить | Позволяет уменьшить масштаб отображения формы в 2 раза.
Увеличить | Позволяет увеличить масштаб отображения формы в 2 раза.


Меню Форма

Пункт меню | Описание
Свойства формы… | Позволяет открыть диалог Свойства формы.
Добавить страницу |
Пустую | Позволяет добавить в форму пустую страницу.
На основе образца… | Позволяет добавить в форму страницу, созданную на основе образца.
Удалить страницу | Позволяет удалить текущую страницу.
Свойства страницы… | Позволяет открыть диалог Свойства страницы


Меню Элементы

Пункт меню | Описание
Выбрать |
Инструмент выбора | Позволяет выбрать один из инструментов для создания элементов формы или выделить уже созданный элемент формы.
Поле для ввода | Позволяет выбрать инструмент для создания элемента Поле для ввода.
Поле даты | Позволяет выбрать инструмент для создания элемента Поле даты.
Числовое поле | Позволяет выбрать инструмент для создания элемента Числовое поле.
Поле метки | Позволяет выбрать инструмент для создания элемента Поле метки.
Группа элементов | Позволяет выбрать инструмент для создания Группы элементов.
Таблица | Позволяет выбрать инструмент для создания элемента Таблица.
Вертикальный разделитель | Позволяет выбрать инструмент для создания в таблице вертикального разделителя.
Горизонтальный разделитель | Позволяет выбрать инструмент для создания в таблице горизонтального разделителя.
Удалить разделитель | Позволяет выбрать инструмент для удаления из таблицы разделителя.
Горизонтальная линейка | Позволяет выбрать инструмент для создания Горизонтальной линейки.
Вертикальная линейка | Позволяет выбрать инструмент для создания Вертикальной линейки.
Текст | Позволяет выбрать инструмент для создания элемента Текст.
Разделитель | Позволяет выбрать инструмент для создания элемента Разделитель.
Рамка | Позволяет выбрать инструмент для создания элемента Рамка.
Картинка | Позволяет выбрать инструмент для создания элемента Картинка.
Репер | Позволяет выбрать инструмент для создания элемента Репер.
Идентификатор | Позволяет выбрать инструмент для создания элемента Идентификатор.
Образец заполнения… | Добавляет на форму образец заполнения.
Выравнивание |
По левому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
Горизонтально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по вертикали.
По правому краю | Позволяет выровнять выделенные элементы формы по левому краю последнего из выделенных элементов.
По верхнему краю | Позволяет выровнять выделенные элементы формы по верхнему краю последнего из выделенных элементов.
Вертикально по центру | Позволяет выровнять выделенные элементы формы по центру последнего из выделенных элементов, не смещая элементы по горизонтали.
По нижнему краю | Позволяет выровнять выделенные элементы формы по нижнему краю последнего из выделенных элементов.
По сетке | Позволяет выровнять левый верхний угол выделенных элементов формы по сетке, сохранив при этом размеры элементов.
Равномерно по горизонтали | Распределяет выделенные элементы равномерно по горизонтали
Равномерно по вертикали | Распределяет выделенные элементы равномерно по вертикали.
Размер |
Выровнять по ширине | Позволяет выровнять ширину выделенные элементы формы по ширине последнего из выделенных элементов.
Выровнять по высоте | Позволяет выровнять высоту выделенные элементы формы по высоте последнего из выделенных элементов.
Выровнять по ширине и высоте | Позволяет выровнять ширину и высоту выделенных элементов формы по ширине и высоте последнего из выделенных элементов.
Выровнять размер по сетке | Позволяет раздвинуть границы выделенных элементов формы до ближайших линий сетки.
По размеру данных | Позволяет выровнять границы выделенного элемента по размеру данных в нем.
На передний план | Позволяет поместить выделенный элемент формы на передний план формы.
На задний план | Позволяет поместить выделенный элемент формы на задний план формы.
Объединить | Позволяет объединить выделенные элементы формы.
Разъединить | Позволяет разъединить выделенные элементы.
Добавить к объединенным | Позволяет добавить элементы к ранее объединенным. При этом должны быть выделены и ранее объединенные, и добавляемые элементы.


Меню Сервис

Пункт меню | Описание
Проверить форму | Позволяет запустить процедуру проверки формы на машиночитаемость.
Настройки… | Позволяет открыть диалог Настройки


Меню Справка

Пункт меню | Описание
Вызов справки | Позволяет открыть Справку программы.
Техническая поддержка | Позволяет открыть страницу Техническая поддержка в Справке программы.
О программе… | Позволяет открыть диалог О программе ABBYY FormDesigner 8.0, содержащий краткую информацию о программе.


Локальное меню панели инструментов

Пункт меню | Описание
Стандартная | Позволяет отобразить/спрятать панель инструментов Стандартная.
Форматирование | Позволяет отобразить/спрятать панель инструментов Форматирование.
Элементы формы | Позволяет отобразить/спрятать панель инструментов Элементы формы.
Редактирование | Позволяет отобразить/спрятать панель инструментов Редактирование.
Большие кнопки | Позволяет увеличить/уменьшить размер кнопок панелей инструментов.
Настройки… | Позволяет открыть диалог Настройки.


Локальное меню элемента формы

Пункт меню | Описание
По размеру данных | Позволяет выровнять размер выделенного элемента по размеру данных в нем.
Вырезать | Позволяет удалить выделенный элемент (или текст) и помещает его в Буфер обмена.
Копировать | Позволяет скопировать выделенный элемент (или текст) в Буфер обмена.
Вставить | Позволяет вставить элемент (или текст) из Буфера обмена.
Удалить | Позволяет удалить выделенные элементы. Связанные с ними поля структуры документа также будут удалены.
Удалить блок | Позволяет удалить выделенные элементы, не удаляя связанные поля структуры документа.
Дублировать | Позволяет дублировать выделенные элементы.
Редактировать текст | Позволяет редактировать текст выделенного элемента Текст или Поле метки.
На передний план | Позволяет поместить выделенный элемент формы на передний план формы.
На задний план | Позволяет поместить выделенный элемент формы на задний план формы.
Объединить | Позволяет объединить выделенные элементы.
Разъединить | Позволяет разъединить выделенные элементы.
Свойства страницы… | Позволяет открыть диалог Свойства для редактирования или просмотра свойств выделенного элемента, либо Свойства страницы, если ни один элемент не выделен.


Горячие клавиши

Меню | Команда | Горячие клавиши
Файл | Новая… | Ctrl+N
 | Открыть… | Ctrl+O
 | Сохранить | Ctrl+S
 | Печать… | Ctrl+P
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Дублировать | Ctrl+D
 | Удалить блок | Shift+Del
 | Выделить все | Ctrl+A
 | Выделить по типу… | Ctrl+Shift+A
Вид | Масштаб/Форму целиком | Ctrl+Shift+Num /
 | Масштаб/Уменьшить | Ctrl+Shift+Num -
 | Масштаб/Увеличить | Ctrl+Shift+Num +
Элемент | Выбрать/Инструмент выбора | Esc
 | Выбрать/Поле для ввода | E
 | Выбрать/Поле даты | D
 | Выбрать/Числовое поле | N
 | Выбрать/Поле метки | C
 | Выбрать/Группа элементов | G
 | Выбрать/Таблица | T
 | Выбрать/Вертикальный разделитель | V
 | Выбрать/Горизонтальный разделитель | H
 | Выбрать/Текст | S
 | Выбрать/Разделитель | L
 | Выбрать/Рамка | F
 | Выбрать/Картинка | P
 | Выбрать/Репер | A
 | Выбрать/Идентификатор | I
 | Выравнивание/По левому краю | Alt+Left
 | Выравнивание/Горизонтально по центру | Shift+F9
 | Выравнивание/По правому краю | Alt+Right
 | Выравнивание/По верхнему краю | Alt+Up
 | Выравнивание/Вертикально по центру | Ctrl+F9
 | Выравнивание/По нижнему краю | Alt+Down
 | Размер/Выровнять по ширине | Shift+F8
 | Размер/Выровнять по высоте | Ctrl+F8
 | Размер/Выровнять по ширине и высоте | Ctrl+Shift+F8
Сервис | Проверить форму | F9
 | Настройки… | Ctrl+Shift+O
Справка | Вызов справки | F1


Горячие клавиши (редактирование текста)

Чтобы: | Горячие клавиши
Переместить курсор на строку выше. | Стрелка вверх
Переместить курсор на строку ниже. | Стрелка вниз
Переместить курсор на первую строку текста. | Page Up
Переместить курсор на последнюю строку текста. | Page Down
Переместить курсор на один символ вправо. | Стрелка вправо
Переместить курсор на один символ влево. | Стрелка влево
Переместить курсор вправо в начало следующего слова. | Ctrl+Стрелка вправо
Переместить курсор влево в начало слова. | Ctrl+Стрелка влево
Переместить курсор в начало строки. | Home
Переместить курсор в конец строки. | End
Переместить курсор в начало текста. | Ctrl+Home
Переместить курсор в конец текста. | Ctrl+End
Удалить выделенный текст. (Если текст не выделен, то удалится символ справа от курсора.) | Delete
Удалить символ, находящийся перед курсором. | Backspace
Выйти из режима редактирования текста без сохранения изменений. | Esc
Выйти из режима редактирования текста, сохранив изменения. | Enter
Перейти на следующую строку. | Ctrl+Enter


Как купить программу ABBYY FormDesigner 8.0

Линейке продуктов FlexiCapture посвящен раздел на сайте компании ABBYY, доступный по адресу www.FlexiCapture.ru

Зайдя на сайт по этому адресу, вы можете:

  • Получить информацию по программным продуктам линейки FlexiCapture.
  • Прочитать об успешных проектах, реализованных с помощью продуктов ABBYY.
  • Узнать, как связаться с ближайшим офисом компании ABBYY или реселлером по продуктам линейки FlexiCapture.

Для оформления заказа на покупку, а также для выяснения любых связанных с этим вопросов вы можете связаться с нами по электронной почте: sales@abbyy.ru или обратиться в ближайший офис компании ABBYY.

Дополнительные программы поддержки языков и шрифты можно приобрести на http://www.paratype.com/shop.


Техническая поддержка

Если при использовании программы ABBYY FormDesigner 8.0 у вас возникли вопросы, то вы можете воспользоваться детальным описанием функциональности этой программы, приведенном в Справке и Руководстве пользователя ABBYY FormDesigner 8.0. А также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать вам квалифицированные рекомендации, работникам отдела поддержки пользователей необходимо иметь следующую информацию:

  • Фамилия, Имя, Отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер дистрибутива
  • Выпуск (см. меню Справка/О программе…/Выпуск)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия системы Windows
  • Другая информация, которую вы считаете важной

Часть этой информации можно получить автоматически, нажав на кнопку О системе… в диалоге О программе ABBYY FormDesigner 8.0 (меню Справка/О программе…).

Внимание! Техническая поддержка оказывается только зарегистрированным пользователям. Вы можете зарегистрироваться на нашем сайте.

Координаты технической поддержки офисов ABBYY


Патенты

U.S. Patent Nos. 5,258,855, 5,369,508, 5,625,465, 5,768,416 и 6,094,505


Third-Party Technologies

Технологии других компаний

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

All rights reserved.

Подробнее

Настоящей лицензией любому лицу (далее - "Пользователь"), получившему копию настоящего программного обеспечения и сопроводительную документацию к нему (далее - "ПО"), безвозмездно предоставляется право распоряжаться ПО без каких-либо ограничений, включая право использовать, копировать, изменять, встраивать, воспроизводить, публиковать, распространять и/или продавать копии ПО, а также разрешать лицам, которым передается ПО, совершать аналогичные действия при условии соблюдения нижеперечисленных условий:

  1. Любые копии или значительные части ПО должны содержать вышеприведенные уведомления об авторских правах, настоящую лицензию и нижеприведенный отказ от гарантий.

  2. Имя владельца авторских прав не должно использоваться для поддержки или рекламы продуктов, созданных на основе настоящего ПО, без предварительного письменного согласия владельца авторских прав.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ ЯВЛЯЕТСЯ НЕОТЪЕМЛЕМОЙ ЧАСТЬЮ НАСТОЯЩЕЙ ЛИЦЕНЗИИ.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ РАСПРОСТРАНЯЕТСЯ НА ЛЮБОЕ ИСПОЛЬЗОВАНИЕ ПО. ПО ПРЕДОСТАВЛЯЕТСЯ ВЛАДЕЛЬЦАМИ АВТОРСКИХ ПРАВ "ТАКИМ, КАКОВО ОНО ЕСТЬ" БЕЗ КАКИХ-ЛИБО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ (НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ) ГАРАНТИЙ ТОГО, ЧТО ПО ПРИГОДНО К ПРОДАЖЕ, ПРИГОДНО ДЛЯ КОНКРЕТНОГО ИСПОЛЬЗОВАНИЯ И НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ЛЮБЫЕ КОСВЕННЫЕ, ПРЯМЫЕ ИЛИ СЛУЧАЙНЫЕ УБЫТКИ, А ТАКЖЕ ЗА ЛЮБЫЕ УБЫТКИ ИЗ-ЗА НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПО, ПОТЕРИ ДАННЫХ ИЛИ УПУЩЕННОЙ ВЫГОДЫ В РЕЗУЛЬТАТЕ НЕВЫПОЛНЕНИЯ ОБЯЗАТЕЛЬСТВ ПО КОНТРАКТУ, НЕБРЕЖНОСТИ ИЛИ ИНЫХ ВРЕДОНОСНЫХ ДЕЙСТВИЙ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ИЛИ РАБОТОЙ ПО. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ ГАРАНТИРУЮТ, ЧТО ПО НЕ НАРУШАЕТ ПАТЕНТОВ И ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ТРЕТЬИХ ЛИЦ. КАЖДЫЙ ИЗ ВЛАДЕЛЬЦЕВ АВТОРСКИХ ПРАВ ОТКАЗЫВАЕТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ПОЛЬЗОВАТЕЛЯМИ ЗА ИСКИ ТРЕТЬИХ ЛИЦ В СВЯЗИ С НАРУШЕНИЕМ ИХ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ИЛИ ИНЫМИ НАРУШЕНИЯМИ. ДЛЯ ИСПОЛЬЗОВАНИЯ ПРАВ, ПРЕДОСТАВЛЯЕМЫХ НАСТОЯЩЕЙ ЛИЦЕНЗИЕЙ, КАЖДЫЙ ПОЛЬЗОВАТЕЛЬ ПРИНИМАЕТ НА СЕБЯ ЕДИНОЛИЧНОЕ ОБЯЗАТЕЛЬСТВО ПРИОБРЕСТИ НЕОБХОДИМЫЕ ПРАВА ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, ЕСЛИ ТАКОВЫЕ ПОТРЕБУЮТСЯ. ПО НЕ ОБЛАДАЕТ ОТКАЗОУСТОЙЧИВОСТЬЮ И НЕ ПРЕДНАЗНАЧЕНО ДЛЯ ИСПОЛЬЗОВАНИЯ В УСЛОВИЯХ, ТРЕБУЮЩИХ БЕЗОТКАЗНОЙ РАБОТЫ, ТАКИХ КАК ЯДЕРНЫЕ УСТАНОВКИ, АВИАЦИОННЫЕ НАВИГАЦИОННЫЕ ИЛИ КОММУНИКАЦИОННЫЕ СИСТЕМЫ, АВИАДИСПЕТЧЕРСКИЕ СИСТЕМЫ, АППАРАТЫ ПО ПОДДЕРЖАНИЮ ЖИЗНИ, ОРУЖИЕ ИЛИ СИСТЕМЫ, В КОТОРЫХ ОТКАЗ ПО ИЛИ СИСТЕМЫ МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, СЕРЬЕЗНОМУ УЩЕРБУ ЗДОРОВЬЮ ИЛИ ОКРУЖАЮЩЕЙ СРЕДЕ ("ДЕЯТЕЛЬНОСТЬ, СВЯЗАННАЯ С ПОВЫШЕННЫМ РИСКОМ"). ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НАСТОЯЩИМ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРИГОДНОСТИ ПО ДЛЯ ДЕЯТЕЛЬНОСТИ, СВЯЗАННОЙ С ПОВЫШЕННЫМ РИСКОМ.

Товарные знаки

QuickScan является товарным знаком, а Captiva является зарегистрированным товарным знаком корпорации Captiva Software Corporation.

KODAK является товарным знаком компании Eastman Kodak Company.


Координаты офисов ABBYY

Координаты офисов компании ABBYY

Россия | ABBYY Poccuя Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: Россия, 129301, Москва, а/я 49, ООО "Аби" Физический адрес: Москва, ст. м. ВДНХ, ул. Касаткина, дом 11, строение 1 E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru Web: http://www.abbyy.ru СХЕМА ПРОЕЗДА
Северная /Центральная Америка | Для пользователей в США, Канаде, а также Мексике и странах Центральной Америки: ABBYY USA Тел.: +1 510 226 6717 Факс: +1 510 226 6069 Адрес: 47221 Fremont Boulevard, Fremont, California 94538, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Web: http://www.abbyy.com
Восточная Европа и страны Средиземноморья | Для пользователей в Албании, Боснии и Герцеговине, Болгарии, Хорватии, в Чехии, Венгрии, Израиле, Македонии, в Молдавии, Польше, Румынии, Сербии, Словакии, Словении, Турции, на Украине и в Черногории: ABBYY Украина Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: Украина, 02002 Киев, а/я 23 E-mail: forms@abbyy.ua Техническая поддержка: Тел.: +380 44 490 94 63 E-mail: formssupport@abbyy.ua Web: http://www.abbyy.ua
Западная Европа | Для пользователей в Австрии, странах Бенилюкса, Великобритании, Дании, во Франции, в Германии, Греции, Италии, Ирландии, Норвегии, Португалии, Испании, Швеции, Швейцарии и других странах этого региона: ABBYY Europe GmbH Тел.: +49-(0)89-511 159 0 Факс: +49-(0)89-511 159 59 Адрес: Elsenheimerstrasse 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com Web: http://www.abbyy.com
Япония | Для пользователей в Японии: ABBYY Japan Тел.: +81 42 795 1901 Факс: +81 42 795 1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Web: http://www.abbyy.com
Другие регионы | Для пользователей в других странах, не упомянутых выше: ABBYY Россия Тел.: +7 495 783-3700 Факс: +7 495 783-2663 Почтовый адрес: Россия, 129301, Москва, а/я 49, ООО "Аби" Физический адрес: Москва, ст. м. ВДНХ, ул. Касаткина, дом 11, строение 1 E-mail: sales@abbyy.com Техническая поддержка: support@abbyy.ru Web: http://www.abbyy.ru; http://www.abbyy.com


Глоссарий

А

ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка макета формы является важным этапом, так как от "правильности" разработанного макета (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

Г

Группа элементов

Элемент машиночитаемой формы, предназначенный для объединения в группу нескольких элементов. Группа элементов используется для объединения логически связанных элементов, для создания групп меток.

З

Знакоместо

Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).

И

Идентификатор

Элемент машиночитаемой формы, однозначно характеризующий данную форму.

Идентификатор страницы

Элемент машиночитаемой формы, однозначно характеризующий данную страницу формы.

К

Картинка

Элемент машиночитаемой формы, представляющий собой графическое изображение.

М

Машиночитаемая форма

Форма, созданная с учетом требований автоматизированного ввода.

Машиночитаемость

Пригодность формы для автоматизированного ввода и дальнейшей обработки распознанного текста.

O

Образец формы

Образец, на основе которого можно создавать новые формы в программе FormDesigner. Образец формы сохраняется в двоичном файле с расширением dtf.

Образец страницы формы

Образец, на основе которого можно создавать новые станицы формы в программе FormDesigner. Образец страницы сохраняется в двоичном файле с расширением ptf.

П

Поле даты

Элемент машиночитаемой формы, предназначенный для вписывания даты при заполнении формы.

Поле для ввода

Элемент машиночитаемой формы, предназначенный для вписывания текста при заполнении формы.

Поле метки

Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).

Публикация формы

Процесс, при котором форме присваивается статус Опубликованная, не позволяющий вносить в форму изменения.
Во время публикации автоматически запускается проверка формы на машиночитаемость, элементам Идентификатор присваивается уникальное значение (одно для всех).

Р

Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Рамка

Элемент машиночитаемой формы, ограничивающий некоторую область формы.

Репер

Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

С

Создание формы

Процесс создания машиночитаемой формы можно разделить на следующие этапы: анализ формы, непосредственно создание новой формы, тиражирование формы.

Т

Таблица

Элемент машиночитаемой формы, представляющий собой таблицу, которая содержит столбцы с однотипными элементами.

Текст

Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.

Требования к машиночитаемым формам

Требования к типу и внешнему виду формы, к типу и виду элементов формы, а также к расположению элементов формы. При соблюдении данных требований достигается максимальное качество распознавания текста, введенного в форму.

Ф

Форма

Документ, состоящий из одной или нескольких страниц и предназначенный для заполнения человеком от руки или любым печатным способом.

Формат XFD

XML Form Definition (*.xfd) - специальный формат файла формы, созданной в программе ABBYY FormDesigner. Файл формата XML Form Definition используется для создания шаблона документа в программе ABBYY FlexiCapture.

Ц

Цветная фоновая форма

Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.

Ч

Черно-белая линейчатая форма

Форма без фона (как правило), на которых границы знакомест полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены черными линиями.

Черно-белая форма с растровыми границами

Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).

Черно-белая форма с растровым фоном

Форма с растровым фоном (растр - мелкие черные точки), на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др.), в которые при заполнении формы вносится информация. Фон должен состоять из отдельных точек.

Числовое поле

Элемент машиночитаемой формы, предназначенный для вписывания чисел при заполнении формы.


Глоссарий

А Г З И К М О П Р С Т Ф Ц Ч


Диалог Настройки: Экспорт

Настройка

Описание

XFD

Сохранять изображения в формате

Позволяет выбрать формат для сохранения изображений страниц при экспорте в XFD. Поддерживаются форматы:

  • TIFF;
  • EMF.

Изображение

Разрешение TIFF-файлов

Позволяет задать разрешение для экспорта изображений в формат TIFF.


Диалог Свойства: Репер

Свойство | Описание
Тип | Позволяет выбрать из списка стандартных реперов репер, который будет использоваться на форме. Одновременно на форме могут быть размещены реперы только одного типа.
Размер | Позволяет задать размер репера: в случае черного квадрата - длину стороны квадрата; в случае уголка - длину стороны уголка.
Толщина линии (только при выборе репера Уголок) | Позволяет задать толщину линии репера.


Диалог Свойства формы

Свойство | Описание
Автор | Указывается автор формы.
Статус | Указывается статус формы: Редактируемая - форма доступна для редактирования; Опубликованная - форма доступна только для чтения.
Дата публикации | Указывается дата публикации формы.
Значение идентификатора | Указывается значение идентификатора.
Файл | Указывается путь к файлу формы.


Диалог Свойства страницы: Общие

Свойство | Описание
Название | Позволяет задать название страницы.
Число вхождений страницы в документ |
Минимум | Позволяет уменьшить или увеличить минимальное число вхождений текущей страницы в форму.
Минимум | Позволяет уменьшить или увеличить максимальное число вхождений текущей страницы в форму.
Идентификатор страницы | В данном поле отображается значение идентификатора страницы.


Диалог Свойства страницы: Размер

Свойство | Описание
Размер страницы | Позволяет выбрать из списка один из стандартных размеров страницы формы, соответствующих размерам бумаги А3, А4, А5, или задать свой размер страницы формы. Для того чтобы задать свой размер страницы формы выберите пункт Пользовательский и укажите ширину и высоту страницы формы в соответствующих полях.
Ширина | Позволяет задать ширину страницы формы.
Высота | Позволяет задать высоту страницы формы.
Группа Ориентация |
Книжная | Позволяет задать книжную ориентацию формы.
Альбомная | Позволяет задать альбомную ориентацию формы.
Группа Отступы |
Сверху | Позволяет задать ширину отступа от верхнего края страницы.
Снизу | Позволяет задать ширину отступа от нижнего края страницы.
Слева | Позволяет задать ширину отступа от левого края страницы.
Справа | Позволяет задать ширину отступа от правого края страницы.


Диалог Свойства страницы: Цвет

Свойство

Описание

Вид

Позволяет задать вид страницы формы:

  • Серая фоновая

  • Черно-белая

  • Оранжевая фоновая

  • Красная фоновая

  • Зеленая фоновая

Группа Фон страницы*

Цвет*

Позволяет выбрать цвет фона страницы формы.

Замечание. Выбор цвета фона возможен только для фоновых форм, для черно-белых форм цвет по умолчанию белый.

Размер

Позволяет выбрать размер площади залитой фоном:

  • Вся страница (фоном будет залита вся страница, за исключением выделенных на ней элементов).

  • Только внутри границ отступов формы (фоном будет залито все, что находится внутри границ отступов формы, за исключением выделенных на форме элементов).

* - свойство формы, задаваемое только для фоновых форм.


Диалог Свойства: Выравнивание

Свойство

Описание

Горизонтальное

Позволяет выравнивать текст элемента по горизонтали.

  • По левому краю - позволяет выровнять текст по левому краю элемента.

  • По центру - позволяет выровнять текст горизонтально по центру элемента.

  • По правому краю - позволяет выровнять текст по правому краю элемента.

Вертикальное

Позволяет выравнивать текст элемента по вертикали.

  • По верхнему краю - позволяет выровнять текст по верхнему краю элемента.
  • По центру - позволяет выровнять текст вертикально по центру элемента.
  • По нижнему краю - позволяет выровнять текст по нижнему краю элемента.

Ориентация

Позволяет задать ориентацию текста.

  • Нормальная (горизонтальная) - позволяет задать обычную ориентацию текста: он будет расположен горизонтально, слева направо.
  • Вертикальная (сверху вниз) - текст будет расположен вертикально, сверху вниз.
  • Вертикальная (снизу вверх) - текст будет расположен вертикально, снизу вверх.


Диалог Свойства: Фон

Свойство | Описание
Цвет фона формы | Позволяет выбрать в качестве цвета фона элемента цвет фона формы.
Другой | Позволяет выбрать другой цвет фона для элемента. Список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).


Диалог Свойства: Поле метки

Свойство

Описание

Тип

Позволяет выбрать тип ограничителя поля метки:

  • Квадрат
  • Круг

Расположение

Позволяет выбрать расположение поля метки относительно текста (пояснительной информации):

  • Метка слева - поле метки располагается слева от текста
  • Метка справа - поле метки располагается справа от текста
  • Метка сверху - поле метки располагается сверху от текста
  • Метка снизу - поле метки располагается снизу от текста

Размер

Позволяет выбрать предопределенный размер элемента Поле метки из списка (3,5х3,5 4х4 4,5х4,5 5х5 мм).

Толщина линии

Позволяет задать толщину линии ограничителя элемента Поле метки (от 0,4 мм до 0,8 мм).

Расстояние до текста

Позволяет задать расстояние от поля метки до текста (пояснительной информации).

Цвет

Позволяет выбрать из списка цвет линии ограничителя.


Диалог Свойства: Поле метки

Диалог Свойства: Дата

Свойство

Описание

Формат даты

Позволяет выбрать формат даты:

  • ДД.ММ.ГГГГ
  • ММ.ДД.ГГГГ
  • ГГГГ.ММ.ДД

Кол-во знакомест для записи года

Позволяет выбрать количество знакомест для записи года:

  • 2 (под запись года будет отведено два знакоместа)
  • 4 (под запись года будет отведено два знакоместа)

Разделитель

Позволяет выбрать разделитель для записи даты:

  • .
  • /
  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле даты: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Разметка

Свойство

Описание

Тип разметки текста

Позволяет выбрать тип разметки из списка:

  • Буквы в изолированных растровых рамках
  • Буквы в изолированных рамках
  • Буквы в гребенке
  • Текст в рамке с гребенкой
  • Буквы в рамках

Размер знакоместа

Позволяет выбрать предопределенный размер знакоместа из списка:

  • Стандартный - стандартный рекомендуемый размер знакоместа (4х5мм)
  • Максимальный - максимальный из рекомендуемых размеров знакоместа (5х6.5мм)
  • Минимальный - минимальный из рекомендуемых размеров знакоместа (3х4мм)

Жирная линия разметки (при всех типах разметки, кроме Буквы в изолированных растровых рамках)

Позволяет выбрать жирную линию разметки.

Цвет разметки

Позволяет выбрать из списка цвет разметки.

Многострочное поле

Позволяет сделать поле для ввода многострочным. (Только для элемента Поле для ввода).


Диалог Свойства: Поле метки

Диалог Свойства: Подсказка

Свойство | Описание
Текст | Позволяет задать текст подсказки. Подсказка будет напечатана на форме в поле для ввода: каждая буква подсказки в соответствующее знакоместо.
Цвет | Позволяет выбрать из списка цвет текста подсказки*.
Шрифт | Позволяет задать шрифт для подсказки.
Автоподбор размера шрифта | Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Связанное поле

Свойство | Описание
Связанное поле | По умолчанию при создании каждого элемента создается поле в структуре документа, к которому данный элемент привязывается. Чтобы связать элемент с другим полем того же типа, выберите название поля из выпадающего списка.


Диалог Свойства: Текст

Свойство | Описание
Текст | Позволяет редактировать текст элемента.
Шрифт | Позволяет редактировать шрифт для набора текста элемента. Для того чтобы изменить шрифт, способы выделения текста (наклонный, жирный, с подчеркиванием и т.д.), размер шрифта, нажмите кнопку Изменить … В открывшемся диалоге Шрифт (Font) выберите необходимый шрифт, размер, способ выделения.
Цвет | Позволяет выбрать из списка цвет текста.
Переносить по словам | Позволяет переносить текст на другую строку, не разрывая слово, в случае, когда текст не помещается на одной строке.

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Линия

Свойство

Описание

Толщина

Позволяет задать толщину линии (от 0.1 мм до 2,5 мм).

Стиль

Позволяет выбрать стиль для линии:

  • Пунктир
  • Сплошная
  • Точки

Цвет

Позволяет выбрать цвет линии.


Диалог Свойства: Элемент

Свойство | Описание
Тип | Указывается тип элемента.
Координаты и размер |
Слева | Позволяет задать величину отступа: от левого края формы до элемента.
Сверху | Позволяет задать величину отступа: от верхнего края формы до элемента.
Ширина | Указывает или позволяет задать ширину элемента.
Высота | Указывает или позволяет задать высоту элемента.


Диалог Свойства: Идентификатор

Свойство

Описание

Тип

Позволяет выбрать тип Идентификатора:

  • Штрих-код
  • Штрих-код с цифрами
  • Цифры

Тип штрих-кода

Позволяет выбрать тип штрих-кода, если тип идентификатора Штрих-код или Штрих-код с цифрами и если отмечена опция Пользовательское значение.

Штрих-код может относится к одному из типов:

  • EAN13
  • EAN8

Если не отмечена опция Пользовательское значение, то поле Тип штрих-кода недоступно для редактирования. Тип штрих-кода в этом случае - EAN13.

Ориентация

Позволяет задать ориентацию штрих-кода:

  • Вертикальная
  • Горизонтальная

Значение

Указывается значение идентификатора.

Значение идентификатора может быть введено пользователем, только если выбрана опция Пользовательское значение. Для EAN13 пользовательское значение должно содержать 12 цифр, для EAN8 - 7 цифр. Неправильная длина или символы, отличные от цифр, недопустимы. Для EAN13 дополнительная контрольная цифра добавляется в начале строки цифр (вне штрих-кода), для EAN8 - в конце строки, в теле штрих-кода.

Если выбрана одна из опций Идентификатор формы или Идентификатор страницы, значение идентификатору присваивается автоматически во время публикации формы. До публикации формы она имеет статус Редактируемая и уникальное значение идентификатору ещё не присвоено.

Идентификатор формы

Позволяет использовать элемент в качестве идентификатора формы.

Идентификатор страницы

Позволяет использовать элемент в качестве идентификатора текущей страницы.

Пользовательское значениее

Позволяет задать пользовательское значение идентификатора. Опция недоступна, если задан тип идентификатора Цифры.


Диалог Свойства: Поле метки

Диалог Свойства: Число

Свойство

Описание

Кол-во знаков после разделителя

Позволяет задать количество знакомест для записи дробной части десятичного числа.

Разделитель

Позволяет выбрать разделитель для записи числа:

  • .
  • /
  • -

Цвет

Позволяет выбрать из списка цвет разделителя*.

Подсказка

Позволяет задать текст подсказки. Подсказка будет напечатана на форме в числовом поле: каждая буква подсказки в соответствующее знакоместо.

Цвет

Позволяет выбрать из списка цвет текста подсказки*.

Шрифт

Позволяет задать шрифт для подсказки.

Автоподбор размера шрифта

Позволяет автоматически подобрать размер шрифта подсказки в зависимости от высоты знакомест поля.

* - список цветов для выбора зависит от вида формы (черно-белая или цветная фоновая).

Замечание. Дополнительные шрифты для различных языков можно приобрести на http://www.paratype.com/shop/.


Диалог Свойства: Картинка

Свойство

Описание

Изменение размера

Позволяет изменять размер элемента в нескольких режимах:

  • Исходный размер - режим изменения размера элемента, при котором размер и пропорции изображения не меняются.
    В данном режиме невозможно увеличить исходный размер изображения.
    Если размер элемента стал меньше, чем размер изображения, то часть изображения не будет видна на форме.
  • Растягивание - режим изменения размера элемента, при котором изображение сжимается или растягивается в зависимости от размера элемента. Видно все изображение.
  • Масштабирование - режим изменения размера элемента, при котором изображение масштабируется (уменьшается или увеличивается) пропорционально размерам элемента. Видно все изображение.

Выравнивание

Позволяет выровнять изображение внутри разметки элемента.

  • Слева вверху - позволяет поместить изображение в левый верхний угол разметки элемента.
  • Справа вверху - позволяет поместить изображение в правый верхний угол разметки элемента.
  • В центре - позволяет поместить изображение в центр разметки элемента.
  • Слева внизу - позволяет поместить изображение в левый нижний угол разметки элемента.
  • Справа внизу - позволяет поместить изображение в правый нижний угол разметки элемента.

Файл

Позволяет указать файл с изображением.
Для того, чтобы указать файл с изображением:

  1. нажмите кнопку "…";
  2. в открывшемся диалоге укажите путь к файлу с изображением.

Поддерживаются следующие форматы изображений:

  • Bitmap Files (*.bmp)
  • DCX Files (*.dcx)
  • PEG Files (*.jpg; *.jpeg; *.jfif)
  • PCX Files (*.pcx)
  • PNG Files (*.png)
  • TIFF Files (*.tif; *.tiff)
  • Windows Enhanced Metafiles (*.emf)


Диалог Свойства: Поле метки

Диалог Свойства: Таблица

Свойство | Описание
Расстояние между ячейками | Позволяет задать расстояние между ячейками таблицы.
Использовать первую строку как заголовок | Если эта опция отмечена, то первая строка будет использоваться в качестве заголовков столбцов таблицы.


Диалог Настройки: Вид

Настройка | Описание
Язык интерфейса | Позволяет выбрать язык интерфейса. Все сообщения, названия диалогов, кнопок и пунктов меню будут написаны на выбранном языке. Для того чтобы изменить язык интерфейса, выберите нужное значение из этого списка, нажмите кнопку OK, а затем перезапустите программу ABBYY FormDesigner 8.0. По умолчанию язык интерфейса совпадает с языком, который был выбран для установки программы.
Группа Сетка |
Показывать сетку | Позволяет отобразить сетку разметки на экране. По умолчанию пункт не выбран.
Ширина | Позволяет задать ширину ячейки сетки разметки. Измеряется в миллиметрах (мм). По умолчанию значение равно 2 мм.
Высота | Позволяет задать высоту ячейки сетки разметки. Измеряется в миллиметрах (мм). По умолчанию значение равно 2 мм.
Привязывать к сетке | Позволяет включить режим выравнивания элементов формы, при котором верхний левый угол создаваемых элементов привязывается к сетке и перемещение всех элементов формы осуществляется только по сетке.
Группа Цвет | Позволяет задать цвет фона редактируемого текста, линеек и границ отступов формы при отображении их на экране. В окне Объекты выберите один из объектов формы. Затем выберите цвет, которым он будет отображаться на экране (щелкните мышью на цветном прямоугольнике, в открывшемся диалоге Цвет (Color) выберите необходимый цвет).
Показывать линейку | Позволяет отобразить на экране линейку.
Показывать отступы | Позволяет отобразить на экране отступы формы.
Группа Редактор текста |
Размеры табуляции | Позволяет задать количество пробелов, которые вставляются в редакторе текста при нажатии табуляции.