关于 ABBYY FormDesigner

关于 ABBYY FormDesigner 9.0

ABBYY FormDesigner 9.0 是一种用于创建机器可读表单的软件应用程序，这类表单使用表单处理应用程序 ABBYY FlexiCapture 9.0 进行处理。表单设计是表单创建的一个重要阶段，因为其他所有阶段 – 扫描、识别、校验、导出 – 均取决于初始表单的“正确性”以及表单对于机器处理的适合性。

ABBYY FormDesigner 9.0 和 MS Visio、CorelDRAW 或 MS Word 等其他编辑器不同，它专门开发用于创建机器可读表单。尽管上述应用程序具备扩展功能，但它们的用户需要另外采取措施来确保其表单满足机器可读性要求 – 测定表单要素、监控这些要素在表单上的形状和位置等等。

本程序有直观的用户友好的界面，它包含有易于使用且功能强大的机器可读表单上常见的标准要素。使用该应用程序可以创建黑白和彩色的表单。在 ABBYY FormDesigner 9.0 中创建的表单元素，将采用机器输入自动设计。此外，程序还会对创建的每个表单进行检查，以确保计算机成功处理该表单。所有这一切意味着您可以快速方便地创建机器可读表单，最单调乏味的工作将由程序替您完成。

一旦在 ABBYY FormDesigner 9.0 中创建好表单，实际上就表示您已准备好了用于在 ABBYY FlexiCapture 9.0 中创建模板的表单描述。（模板描述表单要素，并告知数据捕获应用程序在表单上的哪些位置查找特定类型的信息，因此可以确保程序准确可靠地识别输入的数据。）

因此 ABBYY FormDesigner 9.0 执行的任务有两项：简化表单的制作和 ABBYY FlexiCapture 9.0 设置过程，从而 ABBYY FormDesigner 9.0 在处理 ABBYY FormDesigner 9.0 中创建的表单时只需最低程度的人工干预。

ABBYY FormDesigner 9.0 允许您发布表单（即防止表单被误更改或误编辑），以及在将表单发送至印刷厂前以不同格式进行保存。


ABBYY FormDesigner 8.0 中的新功能

ABBYY FormDesigner 9.0 中的新功能

ABBYY FormDesigner 9.0 包含以下新功能：

    表单创建

  • 启动本应用程序时会打开新的快速启动对话框。该对话框可以让您立即开始使用本应用程序，它会提示您选择最常用的命令，如打开文件、从最近使用的文件的列表中打开一个文件、创建新表单、基于表单样本创建表单或启动表单创建向导。

  • 表单向导 现已得到了改进，允许向表单中填入标准元素并进行预览。

  • 从 PDF 导入功能允许将其他程序（Adobe Acrobat Professional、Microsoft Visio、CorelDRAW、Microsoft Word）中创建的表单布局导入 ABBYY FormDesigner，并在 ABBYY FlexiCapture 中进行后续处理。

    表单编辑

  • 现在向设计工具工具栏中添加了新按钮：隐藏所有标尺和删除所有标尺。

  • 添加了新的文本编辑功能（可以通过文本字段的快捷菜单访问）：

    - 字符间距（水平拉伸/压缩文本）

    - 行间距（适用多行文本字段）

    - 一个文本字段中有不同的文本格式化选项（样式、字号等）

    表单导出

  • 现在可以将表单导出至 PDF（可以选择导出选项）、导出至 InfoPath和导出至 AI 格式 (Adobe Illustrator)。

    表单完成

  • 使用本程序的界面，现在可以通过电子邮件将表单作为 PDF 进行发布、保存表单或发布到网站上。也可以选择响应方法，邀请用户通过电子邮件提交完成的表单或邀请他们来访问您的网站。表单发布向导会引导您完成创建表单的所有必需步骤。

  • 网站收到已填好的表单时，会自动在服务器上进行处理。由不同用户输入至同一表单的数据保存在一个 CSV 文件中。

    杂项

  • 现在您可以从主窗口发送反馈。我们非常欢迎您提出您的反馈意见。

ABBYY FormDesigner 9.0 中还添加了以下这些功能：

  • 支持多页表单

  • 基于样本的表单创建

  • 创建颜色滴定表单

  • 添加了这两个新元素：表格和元素组

  • 用于调整元素的标尺

  • 以 ELF 格式保存图像

  • 编辑文档结构的功能

  • 打印部分填好的表单的功能


安装、运行和删除 FormDesigner

安装、运行和删除 ABBYY FormDesigner 9.0

ABBYY FormDesigner 9.0 和 ABBYY FlexiCapture 9.0 一同安装和删除。

要运行 ABBYY FormDesigner 9.0，请选择开始/程序/ABBYY FlexiCapture 9.0/工具中的 ABBYY FormDesigner 9.0 项目。


主应用程序窗口

启动 ABBYY FormDesigner 9.0 时会显示主窗口，一同显示的还有快速启动对话方块。快速启动对话框可以让您立即开始工作，会提示您选择最常用的命令，如打开文件、最新文件、创建新表单、模板中表单， 或启动表单创建向导。

向我显示主应用程序窗口

菜单栏包含的菜单有：文件、编辑、视图、表单、元素、工具和帮助。

您可以使用视图菜单显示/隐藏界面元素。

标准工具栏包含最常见任务的按钮。

设计工具工具栏包含编辑表单元素的按钮。

格式化工具栏包含设置文本格式的按钮和命令。

表单元素工具栏包含向表单添加元素的按钮。

标尺是一个以测量单位进行标记的栏目，可以用作精确定位和对齐表单元素的一个编辑辅助。

表单窗口显示当前表单。在指定的时刻只能显示一个表单。

文档结构。此窗格显示文档字段的层次。每个字段有一个或多个相链接的元素。

属性窗口。在这个窗口，可以查看和更改选定元素的属性。该窗口中显示的选项卡取决于当前选定元素的类型。要打开一个选项卡，请单击该选项卡右侧的名称。

状态栏显示当前元素的相关信息：元素左上角的坐标（单位为 mm）、元素大小（单位为 mm）、该元素的其他信息（元素类型）。另外状态栏上还显示页面类型和页面大小。其他信息（每行和每列的字符单元数）对输入字段、日期字段和数字字段可用。


自定义主应用程序窗口

选择工具菜单上的选项…项目，可以更改主应用程序窗口的外观。

向我显示选项对话框

选项

描述

查看

界面语言：

选择一种界面语言。所有程序消息、对话框标题和菜单项目，均采用这种语言。要使更改生效，请单击确定并重新运行 ABBYY FormDesigner 9.0。
界面语言默认为您在安装过程中选择的语言。

网格

显示网格

显示网格。

默认为不选中该选项。

宽度：

设置网格单元的宽度（单位为 mm）。

默认值为 2 mm。

高度：

设置网格单元的高度（单位为 mm）。

默认值为 2 mm。

快速移动至网格

将新建元素的左上角快速移动至最近的网格节点。移动表单元素时，表单元素同时也会快速移动至最近的网格节点。

颜色

根据屏幕上显示的颜色更改边距、标尺和已编辑文本的背景的颜色。在项目：窗格中，选择一个元素并单击下面的颜色矩形。在打开的颜色对话框中，选择目标颜色。

显示标尺

显示/隐藏标尺。

显示间距

显示/隐藏表单边距。

文本编辑器

制表符宽度：

设置按 TAB 键时要插入文本编辑器中的空格数。

导出

XFD

xfd 文件中的图像存储格式

导出至 XFD 文件时，从下拉列表中选择保存表单图像的格式。有两个选择：

  • EMF
  • TIFF

图像

TIFF 文件的分辨率：

设置要接受导出的表单的 TIFF 文件的分辨率。


文件菜单

项目 | 描述
新建… | 打开快速启动对话框，该对话框包含有启动本应用程序时的常用命令：打开文件，从最近打开的文件的列表打开一个文件；创建空白表单，使用模板或启动表单创建向导创建表单。
打开… | 打开表单。
保存 | 保存表单。
另存为… | 以新名称保存表单，或将表单/页面另存为样本。
导出至 |
图像文件… | 将表单导出至图像文件。
独立图像文件… | 将彩色表单导出至独立的图像文件 - 黑白 TIFF 文件和彩色 TIFF 文件。
XML 表单定义… | 将表单导出至 XML 表单定义格式（只适用已发布的表单）。
PDF 表单… | 将 ABBYY FormDesigner 表单导出至 PDF 表单（只适用已发布的表单）。您也可以向表单添加响应按钮：电子邮件和/或网站响应，并设置导出参数。 要导出至 PDF 表单，表单中至少要有一个可编辑字段。
InfoPath 表单… | 将 ABBYY FormDesigner 导出至 InfoPath 表单。 要导出至 InfoPath 表单，表单中至少要有一个可编辑字段。
Adobe Illustrator 文件… | 将表单导出至 Adobe Illustrator 文件。
从可搜索 PDF 文件导入… | 从其他形式的布局编辑器中创建的 PDF 文件中导入表单。
发布表单 | 发布表单。
将可编辑副本另存为… | 保存表单副本，然后可以对该表单进行编辑。
发布表单… | 打开表单分发向导，在这里可以选择表单发送和接收参数。
打印设置… | 打开打印设置对话框。
打印预览 | 显示表单的打印效果。
打印… | 打开打印对话框。
打印填好的表单 |
带有源自数据库的值… | 从数据库打印已填好值的表单。
带有源自文件的值… | 从文件打印已填好值的表单。
最新文件 | 显示最近打开的文件的列表。从最新文件中选择一个文件将其打开。
退出 | 关闭 ABBYY FormDesigner 9.0。


编辑菜单

项目 | 描述
撤销 | 取消上次操作的结果。
恢复 | 取消上次撤消操作的结果。
剪切 | 剪切选择的（元素或文本）并将其放入剪贴板。
复制 | 将选择的（元素或文本）复制到剪贴板。
粘贴 | 将剪贴板内容粘贴到表单中。
删除 | 删除选定元素。同时还会删除链接文档结构中链接这些元素的字段。
复制 | 复制选定元素。
编辑文本 | 允许编辑选定的文本字段或复选标记字段元素中的文本。
重命名字段 | 重命名选定字段。
删除区域 | 删除选定元素，但不删除文档结构中这些元素链接的字段。
全选 | 选择当前表单上的所有元素。
按类型选择… | 打开按类型选择对话框，在该对话框中可以指定要选择的元素的类型。


视图菜单

项目 | 描述
工具栏 |
标准 | 显示/隐藏标准工具栏。
格式化 | 显示/隐藏格式化工具栏。
表单元素 | 显示/隐藏表单元素工具栏。
设计工具 | 显示/隐藏设计工具栏。
大工具栏按钮 | 使工具栏上的按钮变大/变小。
状态栏 | 显示/隐藏状态栏。状态栏显示按钮、菜单项、选定元素的大小、位置和类型以及页面属性的说明。
文档结构 | 显示/隐藏文档结构窗格。
元素属性 | 显示/隐藏元素属性窗口。
网格 | 显示/隐藏网格。
主标尺 | 显示/隐藏主标尺。
边距 | 显示/隐藏边距。
快速移动至网格 | 将新建元素的左上角快速移动至最近的网格节点。移动表单元素时，表单元素同时也会快速移动至最近的网格节点。
将对齐标尺快速移动至元素 | 打开/关闭自动绑定元素至标尺。如果开启该模式，当您移动表单上的标尺时，会自动绑定完全靠近该标尺的元素。
显示对齐标尺 | 显示/隐藏 对齐标尺。
删除所有对齐标尺 | 删除所有对齐标尺。
缩放 |
200% | 将表单窗口缩放至 200%。
150% | 将表单窗口缩放至 150%。
100% | 将表单窗口缩放至 100%。
75% | 将表单窗口缩放至 75%。
50% | 将表单窗口缩放至 50%。
适合宽度 | 使图像适合表单窗口的宽度。
适合高度 | 使图像适合表单窗口的高度。
最佳适合 | 使整个图像适合表单窗口。
缩小 | 将表单图像缩小一半。
放大 | 将表单图像放大一倍。


表单菜单

菜单项 | 描述
表单属性… | 打开表单属性对话框。
添加页面 |
空 | 向表单中添加空页面。
基于页面样本… | 根据样本添加创建的页面。
删除页面 | 删除当前页面。
页面属性… | 打开页面设置对话框。


元素菜单

项目 | 描述
绘制元素 |
选择工具 | 选择表单元素工具栏上的一个工具或选择表单上的一个元素。
输入字段 | 选择输入字段工具，该工具可以向表单中添加输入字段元素。
日期字段 | 选择日期字段工具，该工具可以向表单中添加日期字段元素。
数字字段 | 选择数字字段工具，该工具可以向表单中添加数字字段元素。
复选标记字段 | 选择复选标记字段工具，该工具可以向表单中添加复选标记字段元素。
元素组 | 选择元素组 工具，该工具可以向表单中添加元素组。
表格 | 选择表格工具，该工具可以向表单中添加表格元素。
垂直分隔符 | 选择垂直分隔符工具，该工具可以向表单中添加垂直分隔符。
水平分隔符 | 选择水平分隔符工具，该工具可以向表单中添加水平分隔符。
删除分隔符 | 选择删除分隔符工具，该工具可以向表单中添加一个分隔符。
垂直标尺 | 选择垂直标尺工具，该工具可以向表单中添加垂直标尺。
水平标尺 | 选择水平标尺工具，该工具可以向表单中添加水平标尺。
文本 | 选择文本工具，该工具可以向表单中添加文本元素。
行分隔符 | 选择行分隔符工具，该工具可以向表单中添加行分隔符元素。
框 | 选择框工具，该工具可以向表单中添加框元素。
图片 | 选择图片工具，该工具可以向表单中添加图片元素。
定位点 | 选择定位点工具，该工具可以向表单中添加定位点元素。
标识符 | 选择标识符工具，该工具可以向表单中添加标识符元素。
填充模板… | 向表单中添加一个已填写好的样本。
对齐 |
左 | 将选定元素对齐上次选定元素的左边。
水平居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的垂直位置。
右 | 将选定元素对齐上次选定元素的右边。
顶部 | 将选定元素对齐上次选定元素的上边。
垂直居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的水平位置。
底部 | 将选定元素对齐上次选定元素的下边。
至网格 | 将所有选定元素的左上角对齐最近的网格节点。
以均匀的空格分布 | 均匀跨页的选定的空间元素。
以均匀的空格向下排列 | 沿着页面向下均匀排列选定的空间元素。
大小 |
绘制相同宽度 | 使所有选定元素的宽度与上次选定元素的宽度相同。
绘制相同高度 | 使所有选定元素的高度与上次选定元素的高度相同。
绘制相同宽度和高度 | 使所有选定元素的高度和宽度与上次选定元素的高度相同。
网格大小 | 将选定元素的边框扩展至最近的网格线。
适合大小 | 扩展或收缩选定元素的边框，以适合其中所含数据的大小。
置于前面 | 将选定元素移至前景。
发送至后面 | 将选定元素移至背景。
合并 | 合并表单上选定的元素。
拆分 | 拆分表单上选定的元素。
添加至合并的元素 | 将元素添加至先前合并的元素。必须选择要添加的元素和先前已经合并的元素。


工具菜单

项目 | 描述
核对表单 | 检查表单是否机器可读。
选项… | 打开选项对话框，在该对话框中可以更改主窗口视图和导出参数。


帮助菜单

项目 | 描述
帮助主题 | 打开 ABBYY FormDesigner 帮助。
技术支持 | 打开帮助文件中的技术支持页面。
发送反馈… | 向 ABBYY 发送 ABBYY FormDesigner 反馈。 屏幕上将打开公司页面，在该页面可以找到 ABBYY FormDesigner & ABBYY FlexiCapture 反馈表。
关于… | 打开关于 ABBYY FormDesigner 9.0 窗口，该窗口包含本程序的概要信息。


工具栏本地菜单

工具栏快捷菜单

项目 | 描述
标准 | 显示/隐藏标准工具栏。
格式化 | 显示/隐藏格式化工具栏。
表单元素 | 显示/隐藏表单元素工具栏。
设计工具 | 显示/隐藏设计工具栏。
大工具栏按钮 | 使工具栏上的按钮变大/变小。
选项… | 打开选项对话框。


表单元素本地菜单

表单元素快捷菜单

项目 | 描述
适合大小 | 扩展或收缩选定元素的边框，以适合其中所含数据的大小。
剪切 | 剪切选择的（元素或文本）并将其放入剪贴板。
复制 | 将选择的（元素或文本）复制到剪贴板。
粘贴 | 将剪贴板内容粘贴到表单中。
删除 | 删除选定元素。同时还会删除链接文档结构中链接这些元素的字段。
删除区域 | 删除选定元素，但不删除文档结构中这些元素链接的字段。
复制 | 复制选定元素。
编辑文本 | 允许编辑选定的文本字段或复选标记字段元素中的文本。
置于前面 | 将选定元素移至前景。
发送至后面 | 将选定元素移至背景。
合并 | 合并选定元素。
拆分 | 拆分选定元素。
属性… | 显示/隐藏元素属性面板。
页面属性… | 打开页面设置对话框


工具栏

ABBYY FormDesigner 9.0 中有四个工具栏：标准、设计工具、格式化和表单元素。

通过在视图>工具栏上选择或取消选择工具栏，或通过选择快捷菜单（右键单击工具栏以显示其快捷菜单）上的相应命令，可以显示/隐藏工具栏。

工具栏包含的按钮可用于快速访问本程序的工具和命令。使用相应的菜单或按快捷键也可以访问同样的命令。

您可以自定义工具栏按钮的大小。默认为使用小按钮。要更改按钮的大小，请选择视图>工具栏>大工具栏按钮。

要查看按钮功能，请将指针放在按钮上面直至显示工具提示。


标准工具栏

标准工具栏包含启动标准工具和执行标准操作（例如创建新表单或打开现有表单、撤消或恢复上一操作等）的按钮，按相应按钮可以执行相应的命令。

向我显示标准工具栏

标准工具栏上的按钮：

按钮 | 描述
新建 | 创建带基本元素的新表单。
打开… | 打开表单。
保存 | 保存表单。
打印预览 | 显示表单的打印效果。
打印 | 打印表单。
剪切 | 剪切选择的内容并将其放入剪贴板。
复制 | 将选择的内容复制到剪贴板。
粘贴 | 将剪贴板内容粘贴到表单中。
撤消 | 取消上次操作的结果。
恢复 | 取消上次撤消操作的结果。
缩小 | 将表单图像缩小一半。
放大 | 将表单图像放大一倍。
比例 | 更改图像比例。
发布表单 | 打开表单分发向导（只适用已发布的表单）。


设计工具工具栏

设计工具工具栏包含编辑表单元素的按钮。单击按钮可以启动相应的设计工具。

向我显示设计工具栏

设计工具栏上的按钮：

按钮 | 描述
显示网格 | 显示/隐藏网格。
显示主标尺 | 显示/隐藏主标尺。
对齐网格 | 将新建元素的左上角与最近的网格节点对齐。移动表单元素时，表单元素同时也会与最近的网格节点对齐。
左对齐 | 将选定元素对齐上次选定元素的左边。
水平居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的垂直位置。
右对齐 | 将选定元素对齐上次选定元素的右边。
上对齐 | 将选定元素对齐上次选定元素的上边。
垂直居中 | 沿上次选定元素的中心居中选定元素，不更改选定元素的水平位置。
下对齐 | 将选定元素对齐上次选定元素的下边。
对齐网格 | 将所有选定元素的左上角对齐最近的网格节点。
以均匀的空格分布 | 均匀跨页的选定的空间元素。
以均匀的空格向下排列 | 沿着页面向下均匀排列选定的空间元素。
绘制相同高度 | 使所有选定元素的高度与上次选定元素的高度相同。
绘制相同宽度 | 使所有选定元素的宽度与上次选定元素的宽度相同。
绘制相同宽度和高度 | 使所有选定元素的高度和宽度与上次选定元素的高度相同。
网格大小 | 将选定元素的边框扩展至最近的网格线。
合并 | 合并表单上选定的元素。
拆分 | 拆分表单上选定的元素。
添加至合并的元素 | 将元素添加至先前合并的元素。必须选择要添加的元素和先前已经合并的元素。
置于前面 | 将选定元素移至前景。
发送至后面 | 将选定元素移至背景。
将对齐标尺快速移动至元素 | 打开/关闭自动绑定元素至标尺。如果开启该模式，当您移动表单上的标尺时，会自动绑定充分靠近该标尺的元素。
显示所有标尺 | 显示/隐藏 所有标尺。
垂直标尺 | 创建垂直标尺。
水平标尺 | 创建水平标尺。
删除所有标尺 | 显示所有标尺。


格式化工具栏

格式化工具栏包含设置表单文本格式的按钮。单击按钮可以选择相应的格式化工具。

选择要设置格式的文本，然后单击相应按钮来从工具栏上选择工具。

向我显示格式化工具栏

格式化工具栏上的按钮：

按钮 | 描述
字体 | 更改选定元素中文本的字体
字体大小 | 更改选定元素中文本的字号。
粗体 | 将选定文本更改为粗体。
斜体 | 将选定文本更改为斜体。
下划线 | 为选定文本添加下划线。
左对齐 | 将选定元素中的文本对齐元素的左边缘。
水平居中 | 水平居中选定元素中的文本：
右对齐 | 将选定元素中的文本对齐元素的右边缘。
两端对齐 | 两端对齐选定元素中的文本。
下对齐 | 将选定元素中的文本对齐元素的下边缘。
垂直居中 | 垂直居中选定元素中的文本：
上对齐 | 将选定元素中的文本对齐元素的上边缘。
文本左侧 | 将复选标记字段放在说明性文本左侧。
文本上方 | 将复选标记字段放在说明性文本上方。
文本右侧 | 将复选标记字段放在说明性文本右侧。
文本下方 | 将复选标记字段放在说明性文本下方。

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


表单元素工具栏

表单元素工具栏包含向表单添加新元素的按钮。单击按钮可以向表单中添加相应元素。

向我显示表单元素工具栏

表单元素工具栏上的按钮：

按钮 | 描述
选择工具 | 选择表单元素工具栏上的一个工具或选择表单上的一个元素。
输入字段 | 向表单中添加输入字段元素。
日期字段 | 向表单中添加日期字段。
数字字段 | 向表单中添加数字字段。
复选标记字段 | 向表单中添加复选标记字段元素。
元素组 | 添加一个元素组
表格 | 向表单中添加表格元素。
垂直分隔符 | 向表格中添加一个垂直分隔符。
水平分隔符 | 向表格中添加一个水平分隔符。
删除分隔符 | 向表格中添加一个分隔符。
文本 | 向表单中添加文本元素。
行分隔符 | 向表单中添加行分隔符元素。
框 | 向表单中添加框元素。
图片 | 向表单中添加图片元素。
定位点 | 向表单中添加定位点元素。
标识符 | 向表单中添加标识符元素。


使用 ABBYY FormDesigner 9.0

本节包含 ABBYY FormDesigner 的功能信息。

目录

  • 创建表单

  • 表单属性

  • 文档结构

  • 添加、编辑和删除表单元素

  • 选择和移动表单元素

  • 保存和发布表单；检查表单的机器可读性

  • 导出表单

  • 发布表单

  • 打印表单

  • 打印部分填好的表单


创建、保存和打开表单

创建表单

在启动本应用程序或选择文件>新建…时，会打开快速启动对话框。在该对话框中，可以从头创建新表单（空表单或含基本元素的表单），基于样本创建表单，或使用表单创建向导引导您完成表单创建进程的所有步骤。向导完成表单创建后，您只需添加所需的表单元素（使用表单元素工具栏）和保存表单。

有关详细信息，请参阅创建表单。

保存表单

要保存表单，请选择文件菜单上的标准保存命令或另存为…命令。

打开表单

要打开表单：

  • 选择文件菜单上的打开…项目，或

  • 单击标准工具栏上的打开图标。

  • 按 Ctrl+O。


发布表单

在发布表单时要为表单分配已发布状态，以防止更改表单。同时还会检查表单的机器可读性并为该表单分配一个唯一的标识数字。

要发布表单，请选择文件菜单上的发布表单 。

已发布表单的状态为只读。要启用对已发布表单的更改，请选择文件菜单上的将可编辑副本另存为…。应用程序将要求您在更改设计前，先以不同的名称另存该表单。

有关详细信息，请参考保存和发布表单；检查表单的机器可读性。


表单另存为图像

要将表单另存为图像，请选择图像文件…项目（表单>导出至>图像文件…）并在打开的将图像另存为对话框中选择所需的图像格式，指定该图像文件的名称，并浏览至要存储该文件的文件夹。

有关详细信息，请参阅将表单导出至图像文件。


创建 ABBYY FlexiCapture 的模板

ABBYY FormDesigner 9.0 有一个重要优点：一旦在 ABBYY FormDesigner 中创建表单，即可获得用于在 ABBYY FlexiCapture 9.0 中创建文档定义的表单描述。

要获得 ABBYY FlexiCapture 9.0 的描述：

  1. 在 ABBYY FormDesigner 9.0 中创建一个表单。
  2. 发布该表单（文件>发布表单）。
  3. 将已发布的表单导出至 XML 表单定义格式（文件>导出至>XML 表单定义…）。在打开的导出至 XML 表单定义对话框中，指定该文件的名称，并浏览至要存储该文件的文件夹。
  4. 运行 ABBYY FlexiCapture 9.0 并打开文档模板对话框（项目>文档定义..）。
  5. 单击导入并选择新建的的 *.xfd 文件。
有关详细信息，请参阅将表单导出至 XML 表单定义格式 (*.xfd)。


创建表单

表单创建进程由三个阶段组成：分析、设计和打印。

在分析阶段，设计师必须执行以下工作：

  1. 分析表单内容，确定字段名称和说明性文本。
  2. 选择最恰当的表单类型（带光栅边框的黑白表单、黑白线性表单、颜色滴定表单等）和打印方法（在印刷厂打印，在打印机上打印，使用 Xerox 机器、发布到因特网上等等）。
  3. 确保表单为机器可读表单。

在设计阶段，设计师必须执行以下工作：

  1. 在计算机上创建表单。

  2. 发布表单，即锁定表单的编辑，以防表单被更改（这样可以确保打印所有相同的表单时能使用完全相同的源表单）。

在发布阶段，表单要

  1. 做好发布准备
  2. 以硬拷贝或电子的方式进行发布

新建表单

多页表单

基于样本创建表单

添加、编辑和删除表单元素

选择和移动表单元素

保存和发布表单；检查表单的机器可读性

导出表单

发布表单

打印表单


新建表单

使用快速启动对话框（启动本应用程序时打开）可以创建新表单，方法是选择文件>新建…，或按键盘上的 Ctrl+N。

快速启动对话框可以让您采用下面这三种方法创建新表单：

  • 创建空表单。在对话框右侧，选择要创建的表单 - 空表单或带基本元素的表单。也可以单击标准工具栏上的新建按钮，来创建带基本元素的表单。
  1. 如果选择空表单，ABBYY FormDesigner 9.0 将创建一个不含任何元素的表单。如果要创建一个多页表单，请在页数：字段中输入所需的页数。

  2. 如果选择带基本元素的表单，ABBYY FormDesigner 9.0 将创建一个带基本元素的黑白表单：
    定位点
    是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。
    （表单角有四个黑方块形，表单上的任意位置还有一个黑方块形；后续编辑该表单时可以将这些黑方块形替换为您选择的定位点），标识符元素
    是机器可读表单的一种元素，该元素允许表单处理程序识别每个表单。
    （带数字的条形码）和文本元素
    是机器可读表单的一种元素，这种元素包含字段名称、如何填写表单的操作指示等描述和说明性文本。
    放置表单标题的位置。
    • 基于表单样本创新表单。在对话框的右侧，选择要用作新表单样本的 *.dtf 文件。表单样本的默认保存目录：С:\Documents and Settings\<username>\My Documents\Templates\。
    • 使用表单创建向导创建表单。
    1. 指定表单页面属性 - 页面大小和页面方向。
    2. 指定表单类型（黑白、灰色背景、彩色背景）、背景大小（对于有背景的表单：整页或仅边距以内）和定位点类型。
    3. 选择表单布局元素。您可以添加标题（提供标题文本）、标识符（指定其类型和位置）和模板（选择语言）。
    4. 从列表向表单添加标准元素：姓名、联系信息。在对话框右侧，可以看到表单预览。要添加/删除元素，请使用 >>/<< 按钮。

      要退出向导，单击完成。将自动在主窗口中打开您创建的表单。然后可以编辑和保存该表单。

表单设置


多页表单

在 ABBYY FormDesigner 9.0 中，可以创建由多个页面组成的多页表单。对于每个页面，需要指定该页的名称及其在表单中的副本数。可以将多页表单描述导出为 XFD 格式，然后在 ABBYY FlexiCapture 9.0 中使用导出的表单描述创建多页文档定义。

创建多页表单

可以基于表单样本创建多页表单。

添加页面

可以向任意类型的表单添加新页面。要添加新页面，请选择表单>添加页面，或在要创建的表单下方右键单击页面名称。可以添加空白页面或基于样本的页面。

一个页面在表单中的出现次数不限。可以在页面设置对话框（表单>页面属性…）中设置页面出现的最大和最小次数。也可以在该对话框中指定当前页面的名称。

导出多页表单

可以将多页表单图像导出为任何一种受支持的图像格式。也可以将每个页面保存在独立的图像文件中，或将所有页面保存在同一个图像文件中。


基于样本创建表单

可以使用样本来创建新表单或表单页面。

要创建表单（或页面）样本：

  1. 在 ABBYY Form Designer 中创建一个表单（或页面）
  2. 选择文件>另存为…
  3. 在保存类型下拉列表中，选择表单样本文件或页面样本文件
  4. 单击保存

表单样本的默认保存目录：С:\Documents and Settings\<username>\My Documents\Templates\。

表单样本是二进制文件，其扩展名为 *.dtf。页面样本保存为 *.ptf 格式，该格式是 *.fdd 格式的改良版。

要基于表单样本创建新表单，请选择基于表单样本中的基于表单样本。

要向基于页面样本的多页表单添加新页面，请选择表单>添加页面>基于页面样本…。


表单设置

可以在表单属性对话框（表单>表单属性…）中查看表单的主要属性。

向我显示表单属性对话框
项目 | 描述
作者： | 表单创建者的名称。
状态： | 表单状态： 草稿，如果允许对表单进行更改； 已发布，如果表单为只读表单。
发布日期： | 发布表单的日期。
表单标识符： | 表单标识符的值。
文件： | 包含表单的文件的路径。

表单页面设置

页面设置确定页面的大小、方向、缩进和样式。要更改页面设置，选择表单>页面属性…，或右键单击该页面并选择快捷菜单上的页面属性…。

向我显示页面设置对话框

项目

描述

常规

名称：

设置页面名称。

最少出现次数：

设置当前页面在表单中出现的最小次数。

最大出现次数：

设置当前页面在表单中出现的最大次数。

页面标识符：

显示页面标识符的值。

大小

页面大小：

从下拉列表（A3、A4 或 A5）选择标准页面大小，或设置自定义页面大小。要自定义页面大小，请选择列表中的自定义大小项目，并在相应字段中指定所需的宽度和高度。

宽度：

设置页面宽度。

高度：

设置页面高度。

方向

纵向

页面方向设置为纵向。

横向

页面方向设置为横向。

边距

顶部：

设置上边距的宽度。

底部：

设置下边距的宽度。

左：

设置左边距的宽度。

右：

设置右边距的宽度。

彩色

样式：

设置表单样式：

  • 灰色表单
  • 黑白表单
  • 橙色表单
  • 红色表单
  • 绿色表单

页面背景*

颜色：*

从下拉列表中选择表单背景色。

注：只有颜色滴定表单可以选择颜色。黑白表单的默认色是白色。

颜色：*

使用此列表来选择背景色的覆盖区域。有两个选择：

  • 整页（填充除表单元素以外的所有页面）。
  • 边距以内（填充该页，但页面边距和表单元素保留白色）。

* - 只能对滴定表单指定这项属性。


添加、编辑和删除表单元素

创建新表单后，可以向该表单添加元素和编辑表单。

提示
请务必在向表单添加元素前同您的客户讨论表单设计和内容。

建议的向表单添加元素的顺序：

  1. 设置边距
  2. 添加引用标记（定位点）
  3. 添加其他表单元素

要使表单为机器可读表单，表单四边必须有边距。默认边距宽度为 10 mm。可以在页面设置对话框（表单>页面属性…>大小）上更改默认宽度。

边距以虚线显示在屏幕上。如果想在表单上显示边距，请选择显示间距对话框（工具>查看）上选项选项卡上的选项…项目。

您可以指定每个元素的属性。

定位点

文本

输入字段

日期字段

数字字段

复选标记字段

行分隔符

框

图片

表单标识符

表格

元素组


文档结构

添加表单元素时，ABBYY FormDesigner 9.0 自动构建一个文档结构，该结构即链接至表单图像上的一个或多个元素的表单字段的层次。您可以将文档结构和链接元素修改为任何适当类型的字段。

文档结构是作为 XFD 文件的一部分进行保存和导出。

查看文档结构

要查看当前文档的结构，请选择视图>文档结构。在右侧窗格中，将显示当前表单中的字段结构。您可以添加新字段，删除、移动现有字段或为现有字段重命名。要对字段进行操作，请右键单击一个字段，并从快捷菜单（添加字段、删除字段、重命名字段）上选择一个项目。要移动层次中的字段，请按 Ctrl+向上/向下箭头或选择上移字段/下移字段。如果一个字段有链接的元素，只能在层次中该字段的当前等级内进行移动，否则也可以在组与组之间移动字段。

添加新字段

向表单添加新元素时，ABBYY FormDesigner 9.0 自动在与新建元素同类型的文档结构中创建一个新字段。要手动创建新字段，选择添加字段，然后选择新字段的类型。

链接表单元素到字段

在添加新元素时，ABBYY FormDesigner 9.0 自动将该元素链接至自动为它创建的文档结构中的字段。要将元素链接至其他字段：

  • 选择表单图像上所需的元素
  • 右键单击该元素并选择快捷菜单上的属性…。
  • 在元素属性对话框中，单击链接的字段选项卡并从下拉列表中选择一个字段。您只能从类型符合选定元素的字段中进行选择。如果元素属于某个组，只能链接至属于相应的组字段的字段。

注：没有链接元素的字段的名称以斜体显示在结构窗格中。

删除字段和元素

要从文档结构中删除字段，请选择所需字段并按 Delete，或右键单击所需的元素并选择快捷菜单上的删除。

删除元素时，链接该元素的字段也被删除，除非还有其他元素链接该字段。要删除元素但是保留相应的字段，请按 Shift+Delete，或选择编辑菜单上的删除区域命令，或右键单击该元素并选择快捷菜单上的删除区域命令。


定位点

定位点是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

向表单添加定位点是表单设计的重要阶段。

ABBYY FormDesigner 9.0 允许您向表单中添加两类定位点：黑方块形和直角形。
类型 | 描述
黑方块形 | 定位点的形状为方块形。
直角形 | 定位点的形状为直角形。

只能对表单采用一种类型的定位点。在指定表单上要使用的定位点类型时，还需要设置定位点的属性：

  • 大小：黑方块形的每条边的长度或直角形的每条边的长度。
  • 线宽：直角形的每条边的线宽（此参数不适用黑方块形）

添加定位点元素

编辑定位点元素

删除定位点元素


添加定位点元素

您可以向表单中添加定位点。定位点的大小由用户定义。

要添加定位点：

  1. 在表单元素工具栏上，选择定位点工具。
  2. 单击表单上要添加定位点的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，定位点将被放至矩形左上角。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

向每个具备基本元素的新表单中添加的定位点的默认类型是黑方块形。如果要将定位点类型更改为直角形，请右键单击定位点并选择快捷菜单上的属性。在打开的对话框中更改定位点的类型。


编辑定位点元素

要对整个表单应用的定位点属性有：类型：、大小：和行宽：（对于直角形）。

每个定位点可以指定的属性有：位置、大小、类型。定位点属性与表单类型无关。

您可以在主窗口右下角的元素属性窗口中更改定位点的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

定位点。

位置和大小

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置定位点元素的宽度。

高度：

设置定位点元素的高度。

重要事项！

要更改定位点的大小，请选择定位点选项卡。

定位点

类型：

从下拉列表选择要在表单上使用的定位点的类型 - 黑方块形或直角形。

每个表单只能包含一种定位点。

大小：

设置定位点的大小：
黑方块形每条边的长度，或

直角形每条边的长度。

行宽：（仅适用直角形）

设置直角形的边的线宽（0.3 mm 至 1 mm）。


删除定位点元素

要删除定位点：

  1. 选择要删除的定位点。

  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


文本

文本是机器可读表单的一种元素，它包含字段名称、如何填写表单的操作指示等描述和说明性文本。

添加文本元素

编辑文本元素

删除文本元素

文本元素快捷菜单


添加文本元素

要添加文本元素：

  1. 在表单元素工具栏上，选择文本工具。

  2. 单击表单上要添加文本元素的位置，按住鼠标左键并呈对角拖动鼠标。 释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑文本元素

每个文本元素可以指定的属性有：元素的大小和位置、文本、字体、文本颜色、自动换行、水平对齐和垂直对齐、方向、元素背景色。

您可以在元素字段中直接编辑元素文本。要启用文本编辑模式，请右键单击该元素或选择快捷菜单上的文本>编辑文本。然后使用热键进行编辑。

您可以在主窗口右下角的元素属性窗口中更改文本元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

文本

位置和大小组

左：

 设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

 设置文本元素的宽度。

高度：

 设置文本元素的高度。

文本

文本：

显示元素的文本。
注：要编辑元素的文本，请单击文本元素的快捷菜单上的编辑文本。可以在元素字段中直接编辑文本。

字体：

元素中的文本使用的字体。
要更改字体、字号和样式（斜体、粗体、下划线等），请单击更改…按钮，并在显示的字体对话框中选择所需的字体、字号和样式。

颜色：

从下拉列表中选择文本颜色*。

自动换行

将文本换行，但不断字。

对齐

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中

  • 左对齐 - 将文本对齐元素左边缘

  • 右对齐 - 将文本对齐元素右边缘

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 将文本对齐元素下边缘

  • 居中 - 将文本垂直居中

  • 上对齐 - 将文本对齐元素上边缘

方向：

设置文本的方向。

  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。

背景

与表单背景相同

使文本的背景色与表单的背景色相同。

其它：

从下拉列表中选择文本背景色*。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除文本元素

要删除文本元素：

  1. 选择要删除的文本元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目，或按键盘上的 Delete 键）。


文本元素快捷菜单

此菜单在编辑文本元素的内容时可用。

项目 | 描述
剪切 | 删除选定的元素或文本并将其复制至剪贴板。
复制 | 将选定的元素或文本复制至剪贴板。
粘贴 | 粘贴剪贴板中的元素或文本。
删除 | 删除选定元素。同时也会删除关联的结构字段。
字体… | 打开字体：对话框。
段落… | 打开段落属性对话框。


输入字段

输入字段是机器可读表单的一种元素，在表单中的该字段可以输入文本。

显示输入字段元素

添加输入字段元素

编辑输入字段元素

删除输入字段元素


添加输入字段元素

要添加输入字段元素：

  1. 在表单元素工具栏上，选择输入字段工具。

  2. 单击表单上要添加输入字段元素的位置，按住鼠标左键并成对角拖动鼠标。

  3. 屏幕上将显示一个矩形。调整添加的元素的大小*。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

*- 如果在元素属性中启用了多行，那么只能更改输入字段元素的垂直大小。


编辑输入字段元素

对于每个输入字段元素，可以指定的属性有：位置和大小、标记类型、单元大小、元素中的文本行数、标记线的宽度、标记线的颜色、提示文本、提示文本颜色、提示字体、选择提示字号的模式、元素背景色、链接的字段。

您可以在主窗口右下角的元素属性窗口中更改输入字段元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

输入字段。

位置和大小

左：

设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置输入字段元素的宽度。

高度：

设置复输入字段元素的高度。

重要事项！
只能在选择了标记选项卡上的多行复选框时，才能更改标记中的行数。使用标记选项卡更改单元高度。

对齐

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中
  • 左对齐 - 对齐元素左边缘的文本
  • 右对齐 - 对齐元素右边缘的文本

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 对齐元素下边缘的文本
  • 居中 - 将文本垂直居中
  • 上对齐 - 对齐元素上边缘的文本

方向：

 设置文本的方向。
  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。

标记

标记类型：

设置文本的标记类型：

  • 字母位于独立虚线框中

  • 字母位于独立框中

  • 字母位于梳形中

  • 文字位于梳形框中

  • 字母位于框中

单元大小：

设置字符单元的大小：

  • 正常 – 标准单元大小 (4x5 mm)

  • 大 – 最大单元大小 (5x6.5 mm)

  • 小 – 最小单元大小 (3x4 mm)

粗体标记线（适用“字母位于独立虚线框中”以外的所有标记类型）

将单元框更改为粗体框。

标记颜色：

从下拉列表中选择标记颜色*。

多行

向输入字段添加多行。

提示

文本：

设置提示文本。提示将被输入至表单上的输入字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

背景

与表单背景相同

使输入字段的背景色与表单的背景色相同。

其它：

从下拉列表中选择输入字段背景色*。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除输入字段元素

要删除输入字段元素：

  1. 选择要删除的输入字段元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


日期字段

日期字段元素是机器可读表单的一种元素，它表示填入表单中的输入日期。

显示日期字段

添加日期字段

编辑日期字段

删除日期字段


添加日期字段元素

要添加日期字段

日期字段元素是机器可读表单的一种元素，在表单中的该字段可以输入日期。
填写表单时：
  1. 在表单元素工具栏上，选择日期字段工具。
  2. 单击表单上要添加日期字段元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，日期字段将被放到基准点的左上角。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑日期字段元素

对于每个日期字段元素

日期字段元素是机器可读表单的一种元素，它表示填入表单中的输入日期。
该元素可以指定的属性有：元素的位置和大小、文本标记、字符单元大小、多行、粗体/标准标记线、标记颜色、日期格式、记录日期的字符单元数、分隔符、分隔符颜色、提示颜色、提示字体、提示文本字体、自动选择提示字体高度、元素背景色、链接的字段。

您可以在主窗口右下角的元素属性窗口中更改日期字段元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

日期字段。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置日期字段元素的宽度。

高度：

设置日期字段元素的高度。

重要事项！

要更改字符单元高度，请转至标记选项卡。

对齐

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中
  • 左对齐 - 对齐元素左边缘的文本
  • 右对齐 - 对齐元素右边缘的文本

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 对齐元素下边缘的文本
  • 居中 - 将文本垂直居中
  • 上对齐 - 对齐元素上边缘的文本

方向：

设置文本的方向。

  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。

标记

标记类型：

从列表中选择标记类型：

  • 字母位于独立虚线框中
  • 字母位于独立框中
  • 字母位于梳形中
  • 文字位于梳形框中
  • 字母位于框中

单元大小：

从列表中选择单元大小：

  • 标准 - 建议的标准单元大小 (4х5мм)
  • 最大 - 建议的最大单元大小 (5х6.5мм)
  • 最小 - 建议的最小单元大小 (3х4мм)

粗体标记线（标记类型不限，但选择了字母位于独立虚线框中时。）

选择一种粗体标记线。

标记颜色：

从下拉列表中选择标记颜色*。

日期

日期格式：

指定日期格式：

  • DD.MM.YYYY

  • MM.DD.YYYY

  • YYYY.MM.D

年份中的数字：

指定年份的单元数：

  • 2（有 2 个单元）

  • 4（有 4 个单元）

分隔符：

选择日期的分隔符：

  • .

  • /

  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

从下拉列表中选择提示颜色。提示将被输入至表单上的日期字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

背景*

与表单背景相同*

使日期字段的背景色与表单的背景色相同。

其它：

从下拉列表中选择日期字段背景色*。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除日期字段元素

要删除日期字段元素：

  1. 选择日期字段元素；
  2. 选择删除项目（使用编辑>删除菜单或从快捷菜单中选择删除项目）。


数字字段

数字字段是机器可读表单的一种元素，它表示填入表单中的输入数字。

显示数字字段元素

添加数字字段元素

编辑数字字段元素

删除数字字段元素


添加数字字段元素

要添加数字字段

数字字段元素是机器可读表单的一种元素，在表单中的该字段可以输入数字。
表单上的元素：
  1. 在表单元素工具栏上，选择数字字段工具。
  2. 单击表单上要放置数字字段元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑数字字段元素

编辑日期字段元素

对于每个 数字字段

数字字段元素是机器可读表单的一种元素，它表示填入表单中的输入数字。
该元素可以指定的属性有：元素的位置和大小、文本标记、字符单元大小、多行、粗体/标准标记线、标记颜色、记录小数的小数部分的字符单元数、分隔符、分隔符颜色、提示颜色、提示字体、提示文本字体、自动选择提示字体高度、元素背景色、链接的字段。

您可以在主窗口右下角的元素属性窗口中更改数字字段元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

数字字段。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置数字字段元素的宽度。

高度：

设置数字字段元素的高度。

对齐

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中
  • 左对齐 - 对齐元素左边缘的文本
  • 右对齐 - 对齐元素右边缘的文本

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 对齐元素下边缘的文本
  • 居中 - 将文本垂直居中
  • 上对齐 - 对齐元素上边缘的文本

方向：

 设置文本的方向。
  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。

标记

标记类型：

从列表中选择标记类型：

  • 字母位于独立虚线框中
  • 字母位于独立框中
  • 字母位于梳形中
  • 文字位于梳形框中
  • 字母位于框中

单元大小：

从列表中选择单元大小：

  • 标准 - 建议的标准单元大小 (4х5мм)
  • 最大 - 建议的最大单元大小 (5х6.5мм)
  • 最小 - 建议的最小单元大小 (3х4мм)

粗体标记线（标记类型不限，但选择了字母位于独立虚线框中时。）

选择一种粗体标记线。

标记颜色：

从下拉列表中选择标记颜色*。

编号

小数位：

选择小数的小数位数。

分隔符：

选择数字的分隔符：

  • .

  • /

  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

选择提示颜色。提示将被键入至表单上的数字字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

背景

与表单背景相同

使数字字段的背景色与表单的背景色相同。

其它：

从下拉列表中选择数字字段背景色*。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除数字字段元素

要删除数字字段元素：

  1. 选择一个数字字段元素。
  2. 选择删除项目（使用编辑>删除菜单或从快捷菜单中选择删除项目）。


复选标记字段

复选标记字段是机器可读表单的一种元素（通常是一个复选框），在该框中可以填入一个标记（如勾或叉等）。

添加复选标记字段元素

编辑复选标记字段元素

删除复选标记字段元素


添加复选标记字段

要添加复选标记字段元素：

  1. 在表单元素工具栏上，选择复选标记字段工具。

  2. 单击表单上要添加复选标记字段元素的位置，按住鼠标左键并呈对角拖动鼠标。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑复选标记字段

对于每个复选标记字段元素，可以指定的属性有：文本位置、字段大小、边框宽度、边框颜色、间隔、文本、字体、自动换行、文本颜色、背景色、链接字段。

您可以在主窗口右下角的元素属性窗口中更改复选标记字段元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时才显示。

要更改复选标记字段的说明性文本，请双击文本区域。

项目

描述

元素

类型：

复选标记字段。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置复选标记字段元素的宽度。

高度：

设置复选标记字段元素的高度。

文本

文本：

复选标记字段附带的说明性文本。

字体：

说明性文本的字体。
要更改字体、字号和样式（斜体、粗体、下划线等），请单击更改…按钮，并在显示的字体对话框中选择所需的字体、字号和样式。

字体颜色 ：

从下拉列表中选择文本背景色*。

自动换行

将文本换行，但不断字。

复选标记字段

类型：

复选标记字段的形状：

  • 方块形

  • 圆圈

  • 下划线

位置：

设置复选标记字段相对于说明性文本的位置。

  • 文本左侧 – 复选标记字段在文本左侧

  • 文本右侧 – 复选标记字段在文本右侧

  • 文本上方 - 复选标记字段在文本上方

  • 文本下方 - 复选标记字段在文本下方

大小：

包含预定义字段大小的下拉列表（3.5x3.5、4x4、4.5x4.5 或 5x5 mm）。

行宽：

设置字段边框的宽度（0.4 mm 至 0.8 mm）。

平衡：

设置复选标记字段和文本的说明性文本之间的间距（2 mm 至 7 mm）。

颜色：

从下拉列表中选择字段边框颜色*。

背景

与表单背景相同

使复选标记字段的背景色与表单的背景色相同。

其它：

从下拉列表中选择复选标记字段背景色*。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除复选标记字段元素

要删除复选标记字段元素：

  1. 选择要删除的复选标记字段元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


行分隔符

行分隔符是机器可读表单的一种元素，其形状为一条垂直或水平的黑线。

添加行分隔符元素

编辑行分隔符元素

删除行分隔符元素


添加行分隔符元素

要添加行分隔符元素：

  1. 在表单元素工具栏上，选择行分隔符工具。

  2. 单击表单上要添加行分隔符元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。默认为创建水平分隔符。按住 Shift 按钮可以创建垂直分隔符。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑行分隔符元素

对于每个行分隔符元素，可以指定的属性有：名称、位置和大小、样式、线宽和颜色。

您可以在主窗口右下角的元素属性窗口中更改行分隔符元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

行分隔符。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置行分隔符元素的宽度。

高度：

设置行分隔符元素的高度。

线条

宽度：

设置行分隔符的宽度（0.1 mm 至 2.5 mm）。

样式：

设置线条样式：

  • 虚线

  • 点划线

  • 实线

颜色：

 从下拉列表中选择行分隔符的颜色。

注：可用颜色的范围取决于表单类型（黑白或彩色）。对于黑白表单，分隔符将为黑色。


删除行分隔符元素

要删除行分隔符元素：

  1. 选择要删除的行分隔符元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


框

框是机器可读表单的一种元素，它可以包围表单上的某个区域。

显示框元素

添加框元素

编辑框元素

删除框元素


添加框元素

要添加框元素：

  1. 在表单元素工具栏上，选择框工具。

  2. 单击表单上要添加框元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。释放鼠标按键。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑框元素

对于每个框元素，可以指定的属性有：位置和大小、线宽和颜色、样式。

您可以在主窗口右下角的元素属性窗口中更改框元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

框

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置框元素的宽度。

高度：

设置框元素的高度。

线条

宽度：

设置框的宽度（0.1 mm 至 2.5 mm）。

样式：

设置框的样式：

  • 虚线

  • 点划线

  • 实线

颜色：

从下拉列表中选择框的颜色。

注： * - 可用颜色的范围取决于表单类型（黑白或彩色）。


删除框元素

要删除框元素：

  1. 选择要删除的框元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


图片

图片是机器可读表单的一种包含图像的元素。

添加图片元素

编辑图片元素

删除图片元素


添加图片元素

要添加图片元素：

  1. 在表单元素工具栏上，选择图片工具。

  2. 单击表单上要添加图片元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

  3. 在显示的打开图像对话框中，浏览至包含要添加至表单的图像的文件。


编辑图片元素

对于每个图片元素，可以指定的属性有：位置和大小、大小更改模式、对齐、源图像文件和背景色。

可以在元素属性对话框（右键单击图片元素并选择快捷菜单上的属性…）上更改图片元素的属性。

您可以在主窗口右下角的元素属性窗口中更改图片元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

图片。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置图片元素的宽度。

高度：

设置图片元素的高度。

图片

大小模式：

更改元素大小的模式有以下三种：

  • 剪切 – 更改元素的大小，但不更改图片及其比例的大小。
    采用这种模式无法放大图片本身。
    如果元素变得比图片小，图片有一部分将在表单上不可见。

  • 扩展 – 更改元素的大小，并根据元素大小收缩或扩展图片。始终会显示整个图像，但不保留图像比例。

  • 缩放 – 更改元素的大小，并根据元素大小的比例放大或缩小图片。始终会显示整个图像，并保留图像比例。

对齐：

对齐元素中的图像：

  • 左上 – 将图片放在元素的左上角。

  • 右上 – 将图片放在元素的右上角。

  • 居中 – 将图片放在元素的中心。

  • 左下 – 将图片放在元素的左下角。

  • 右下 – 将图片放在元素的右下角。

来源：

指定源图像文件。

要指定加载图片的源文件：

  1. 单击“…”按钮。

  2. 在显示的对话框中，浏览至包含要添加至表单的图片的文件。

受支持的图像格式有：

  • 位图 (*.bmp)
  • DCX (*.dcx)
  • DJVU (*.dcx) djvu)
  • GIF (*.dcx) gif)
  • JBIG2 (*.dcx) jbig2)
  • JPEG (*.jpg; *.jpeg; *.jfif)
  • JPEG-2000 (*.jp2; *.j2c)
  • PCX（*.pcx）
  • PNG (*.dcx)
  • TIFF (*.tif; *.tiff)
  • PDF（*.PDF）

背景

与表单背景相同

使图片的背景色与表单的背景色相同。

其它：

从下拉列表中选择图片背景色。

注：可用颜色的范围取决于表单类型（黑白或彩色）。


删除图片元素

要删除图片元素：

  1. 选择要删除的图片元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


表单标识符

标识符

标识符是机器可读表单的一种元素，它允许表单处理程序识别整个表单或表单中的某个页面。

建议您向表单添加标识符。这样可以帮助表单处理程序在处理过程中将每个表单作为某个给定表单组的一部分进行识别。

标识符元素可以识别整个表单，也可以识别表单上的某个特定页面。您也可以指定标识符的自定义值。

ABBYY FormDesigner 9.0 可以向表单中添加的标识符的类型有：只有条形码、带数字的条形码和只有数字。实际上，所有这些类型的标识符都表示一个在发布时指定给表单的唯一的十三位数。在发布表单前，表单标识符元素上面会显示“草稿”一词。

通过选择条形码类型（EAN13 或 EAN8），可以自定义只有条形码和带数字的条形码。

类型 | 描述
只有条形码 | 使用条形码识别表单。
带数字的条形码 | 使用带数字的条形码识别表单（可以将数字放在条形码的上面或下面）。
只有数字 1236489271602 | 使用一个十三位数识别表单。

添加标识符元素

编辑标识符元素

删除标识符元素


添加标识符元素

要添加标识符元素：

  1. 在表单元素工具栏上，选择标识符工具。

  2. 单击表单上要添加标识符元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。释放鼠标按键后，表单标识符将被放至矩形左上角，

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。


编辑标识符元素

标识符的标准大小是 46x12 mm。

对于每个标识符元素，可以指定的属性有：位置和大小、类型、方向和值。

标识符元素属性与表单类型无关。

您可以在主窗口右下角的元素属性窗口中更改标识符元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

标识符。

位置和大小组

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置标识符元素的宽度。

高度：

设置标识符元素的高度。

标识符

类型：

设置标识符的类型：

  • 只有条形码

  • 带数字的条形码

  • 只有数字

条形码类型：

如果标识符类型被设为只有条形码或带数字的条形码，并且选择了自定义值，则要选择条形码的类型。

可用的条形码类型有：

  • EAN13
  • EAN8

如果未选择自定义值选项，条形码类型：会显示为灰色。将使用 EAN13 条形码类型。

方向：

设置条形码的方向。

  • 水平

  • 垂直

值：

标识符的值

如果选择了自定义值选项，可以更改标识符的值。对于 EAN13，自定义值必须包含 12 位数；对于 EAN8，自定义值必须包含 7 位数。不允许使用比指定位数长或短的值或字符。对于 EAN13，会在字符串开头（在条形码以外）添加附加的控制位；对于 EAN8，会在条形码中字符串末尾添加附加控制位。

如果选择了表单标识符或页面标识符选项，将在发布表单时自动为标识符分配值。在发布表单前，表单的状态为可编辑，且尚未分配标识符值。

表单标识符

使用元素作为表单标识符。

页面标识符

使用元素作为单签页面的标识符。

自定义值

允许标识符采用自定义值。该选项不适用于只有数字标识符。


删除标识符元素

要删除标识符元素：

  1. 选择要删除的标识符元素。

  2. 从编辑菜单中选择删除（或选择快捷菜单上的删除项目）。


表格

表格是机器可读表单的一种元素，它包含多列类型相同的元素。

表格列可以包含的元素有：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段

表格可以包含带有列名的行。

在文档结构方面，每个表格字段有对应表格元素的列的子字段。

添加表格元素

编辑表格元素

删除表格元素


添加表格元素

要添加表格元素：

表格是机器可读表单的一种元素，它包含多列类型相同的元素（如文本字段或复选标记字段）；可以包含带有列名的行。
  1. 在表单元素工具栏上，选择表格工具。
  2. 单击表单上要添加表格元素的位置，按住鼠标左键并呈对角拖动鼠标。屏幕上将显示一个矩形。调整添加的元素的大小。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

  3. 在打开的对话框中更改表格的类型。
    • 如果要将表格第一行作为标题，请选择使用第一行作为标题；
    • 在打开的对话框中心的表格中，将默认数据名称和数据类型修改为所需的名称和类型。可以选择的列数不限；
    • 在行数：字段中，键入表格中的行数。

添加分隔符

如果表单中含有表格，用于添加和移除分隔符的工具栏按钮将变为活动状态。您可以使用这些按钮来添加/移除分隔符，以更改表格的行数和列数。

选择添加分隔符工具，并执行下面的一项操作：

  • 单击表格以创建一个分隔符
  • 将鼠标指针放在现有分隔符上以移动该分隔符。将鼠标指针放在两个分隔符的交叉点处将同时移动这两个分隔符
  • 按住 Ctrl 键并将鼠标指针放到一个分隔符上以删除该分隔符
  • 按住 Shift 键并将鼠标指针放到一个分隔符上以将其类型由垂直分隔符变为水平分隔符（反之亦然）

创建列

表格列只能包含类型相同的元素。要创建表格列，请选择工具栏上所需的元素，并在列中单击。将向该列中的每个单元添加一个选定类型的元素。

可以创建的列的类型有：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段


编辑表格元素

对于每个表格

表格是机器可读表单的一种元素，它包含多列类型相同的元素（如文本字段或复选标记字段）；可以包含带有列名的行。
可以指定的属性有：坐标和元素的大小；线条的宽度、样式和颜色；单元间距；第一行是否包含列名；链接的字段。

您可以在主窗口右下角的元素属性窗口中更改表格元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

表格。

位置和大小

左：

设置表单左边缘与元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置表格元素的宽度。

高度：

设置表格元素的高度。

线条

宽度：

设置行分隔符的宽度（0.1 mm 至 2.5 mm）。

样式：

设置线条样式：

  • 虚线
  • 实线
  • 点划线

颜色：

从下拉列表中选择行分隔符颜色*。

背景

与表单背景相同

使表格的背景色与表单的背景色相同。

其它：

从下拉列表中选择表格背景色*。

表格

单元间距：

设置表格单元的间距。

使用第一行作为标题

如果选择该选项，第一行将包含列名。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）


删除表格元素

要删除表格元素：

  1. 选择要删除的表格元素。
  2. 在编辑菜单上，选择删除（或选择快捷菜单上的删除项目）。


元素组

元素组是机器可读表单的一种元素，它可以合并多个有逻辑关联的元素。

例如，可以使用组来创建复选标记字段组。也可以将多个元素分组到一起以快速复制这些元素并保留它们的所有属性。组有一种用途，就是创建多个有相似字段组的子表单。

组可以嵌套。

添加元素组

编辑元素组

删除元素组


添加元素组

要添加元素组：

元素组是机器可读表单上的一种元素，它可以合并多个有逻辑关联的元素
  1. 在表单元素工具栏上，选择元素组工具。
  2. 单击表单上要添加元素组元素的位置，按住鼠标左键并呈对角拖动鼠标。释放鼠标按键。屏幕上会出现一个矩形。

注：单击鼠标可创建元素：选择所需工具后，仅单击表单中想要添加元素的位置即可。将使用默认元素大小。要在表单中添加同类型的多个元素，按住 Ctrl 键，重复单击想要添加元素的位置。

向组中添加元素

向组中添加元素的方法有以下三种：
  1. 创建要作为组的一部分的元素。选择元素组工具，并使用鼠标包围住矩形中的元素。被完全包围的所有元素将成为这个组的一部分。
  2. 使用元素组工具创建组。在组中创建元素。
  3. 使用元素组工具创建组。将所需元素拖放到组中。
要复制一个组和该组中的所有元素，选择该组即可以选中其所有元素。现在如果复制该组，其所有元素也会被复制，并且会保留这些元素的属性。


编辑元素组

对于每个元素组

元素组是机器可读表单上的一种元素，它可以合并多个有逻辑关联的元素。

可以指定的属性有：坐标、大小、线型、背景色、链接的字段。

您可以在主窗口右下角的元素属性窗口中更改元素组元素的属性。元素属性窗口仅在从主菜单上选定视图>元素属性时显示。

项目

描述

元素

类型：

元素组。

位置和大小

左：

设置所需的表单左边缘与没有左缩进元素之间的距离。

顶部：

设置表单上边缘与元素之间的距离。

宽度：

设置元素组元素的宽度。

高度：

 设置元素组元素的高度。

文本

文本：

编辑元素组的说明性文本。

字体：

元素中的文本使用的字体。
要更改字体、字号和样式（斜体、粗体、下划线等），请单击更改…按钮，并在打开的字体：对话框中选择所需的字体、字号和样式。

颜色：

从下拉列表中选择文本颜色*。

自动换行

将文本换行，但不断字。

线条

宽度：

设置线宽（0.1 mm 至 2.5 mm）。

样式：

设置线条样式：

  • 虚线
  • 点划线
  • 实线

颜色：

从下拉列表中选择线条颜色*。

背景

与表单背景相同

使元素组的背景色与表单的背景色相同。

其它：

从下拉列表中选择元素组的背景色*。

链接的字段

链接的字段

默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


删除元素组

要删除元素组：

  1. 选择要删除的元素组。
  2. 选择删除命令（编辑>删除或快捷菜单）

重要事项！如果删除的元素属于某个组，该组也会被删除。要删除一个组但要保留该组的元素，确定只选择该组，不选择其元素。


调整表单元素大小

对于可以调整大小的表单元素，在选中该元素时其边框上的绿点将变为可见。

并非所有元素都能直接用鼠标调整大小。例如，定位点的大小就只能在定位点对话框的元素属性选项卡上更改。在选中可以调整大小的元素时，其边框上会显示绿点，不能调整大小的元素则显示白点。

要更改表单元素的大小：

  1. 选择要调整大小的元素。
  2. 将鼠标指针放在选定的元素大小调整方向对应的元素边框的任意绿点上，指针将变为箭头。
  3. 单击所需的绿点，在按住鼠标按键的同时在目标方向上移动鼠标。

可以对称地调整元素的大小。这表示元素的大小将在选定方向和反方向这两个方向上变化。

要对称地调整表单元素的大小：

  1. 选择要调整大小的元素。
  2. 按住 Ctrl 按钮。
  3. 将鼠标指针放在该元素边框的目标绿点上；指针将变为箭头。
  4. 单击所需的绿点，在按住鼠标按键的同时在目标方向上移动鼠标。

也可以通过绑定元素边框和平行标尺，来更改元素的大小。如果将多个元素绑定至平行标尺，您将可以以相同的更改幅度，同步更改所有绑定元素的垂直大小和水平大小。

要使用标尺更改元素的大小：

  1. 使用 [image] 或 [image] 工具以创建两个平行标尺。
  2. 移动标尺或所需的元素，使要调整大小的元素的边框与标尺重合。这样可以将边框绑定到标尺上。
  3. 单击其中一个标尺并按住鼠标左键拖动。所有元素的大小将随着您移动标尺而改变。在元素达到适当的大小时释放鼠标。

注：如果选择了多行，那么只能更改多行元素的垂直大小。


更改表单元素的背景色

您可以在保留某些元素的黑白色的同时，更改其他一些元素的颜色。

注：只能设置和更改以下元素的颜色：

  • 文本
  • 输入字段
  • 日期字段
  • 数字字段
  • 复选标记字段
  • 图片
  • 表格
  • 元素组

要更改表单上部分元素的颜色：

  1. 在彩色对话框（表单>页面设置）的页面属性…选项卡上，将表单样式更改为彩色表单
  2. 将表单颜色更改为白色：
    • 转至彩色对话框（表单>页面设置）的页面属性…选项卡
    • 在页面背景下方，从颜色下拉列表中选择颜色：
  3. 将所需元素的颜色更改为灰色：
    • 选择表单上所需的元素
    • 右键单击元素并选择属性…
    • 在元素属性对话框中，单击背景选项卡
    • 清除与表单背景相同方框，并在其它：字段中选择所需的颜色
  4. 对于其他表单元素，请为背景选择白色，为文本标记选择黑色。


选择和移动表单元素

必须先选中表单元素才能对表单元素进行移动或编辑。

要选择表单元素：

  1. 在表单元素工具栏上，选择选择工具。
  2. 单击所需的表单元素。

要移动表单元素：

  1. 选择要移动的元素。
  2. 将鼠标指针放在元素内部。箭头将变为 [image] 。
  3. 单击该元素，在按住鼠标按键的同时将该元素移至表单上的目标位置。

要同时移动多个元素：

  1. 选择要移动的元素（单击选择工具，按住 Shift 按钮并单击要移动的所有元素）。
  2. 将鼠标指针放在其中一个选定的元素内部。箭头将变为 [image] 。
  3. 单击其中一个选定的元素，在按住鼠标按键的同时将选定的这些元素移至表单上的目标位置。

创建输入字段（文本、数字或日期字段）时，该字段链接了其名称。移动此类字段同时也会移动字段名称。

在按住 Ctrl 键的同时移动一个（或多个）元素时将创建该元素（这些元素）的副本。

要选择属于元素组中的元素，请单击组的内部。移动一个组时，组中的所有元素也会被移动。

您可以查看和编辑选定元素的常用属性。

合并表单元素

使用标尺对齐表单元素


合并表单元素

合并表单元素对于移动表单元素时保留表单元素的位置关系十分有用。

要合并多个元素：

  1. 选择要组合的表单元素。
  2. 选择编辑工具栏上的合并工具。

要拆分元素：

  1. 选择要拆分的表单元素。
  2. 选择编辑工具栏上的拆分工具。

要向先前合并的元素添加一个元素：

  1. 选择先前合并的元素。
  2. 在按住 Shift 键的同时选择要添加至该组的元素。
  3. 选择编辑工具栏上的添加至合并的元素工具。


使用标尺对齐表单元素

标尺是一种用于在表单上对齐元素的便利工具。对于要垂直或水平地放至同一行的元素，可以与相应的标尺进行“绑定”。移动标尺时，会同时移动绑定到该标尺的所有元素，因此无需在每次移动时手动选择元素。

您可以将一个元素的两侧帮到到两个平行的标尺上。移动这两个标尺会同步更改该元素的大小。如果将多个元素绑定到两个平行的标尺上，可以同步更改这些元素的大小。

添加标尺

要向页面添加标尺：

  • 单击表单边上的主标尺。单击水平标尺将添加垂直标尺，单击垂直标尺将添加水平标尺。
  • 选择 [image] 工具添加水平标尺，或选择 [image] 工具添加垂直标尺，然后单击要定位新标尺的位置。

将元素绑定至标尺

要将一个元素绑定至一个标尺，需要将该元素的一个边框放到该标尺上。通过移动标尺或调整元素大小可以完成该操作。

如果开启自动绑定模式 ( [image])，当您移动标尺时，会自动绑定充分靠近该标尺的所有元素。该模式默认为关闭。

当您选择一个标尺时，会采用突出显示该标尺的颜色突出显示绑定该标尺的所有元素。当您选择某个绑定标尺的对象时，对象绑定边上的小方块变为红色，这样就可以知道元素绑定的是哪一个标尺以及特定标尺绑定了哪些元素。

移动标尺和元素

在按住鼠标左键的同时拖动鼠标，可以绕表单移动标尺。位于同一位置的两个标尺将合并为一个标尺。

移动标尺时，也会移动绑定该标尺的所有元素。如果某个元素被绑定至两个平行标尺，当移动其中一个标尺会改变该元素的大小（只要该元素允许更改其大小）。

解除元素绑定

要解除元素的绑定，请选择该元素并将其从标尺上移开。

删除标尺

要删除标尺，请选择该标尺并按 Delete 键或选择菜单上的删除命令。


保存和发布表单；检查表单的机器可读性

表单创建进程由表单设计、更改设计、打印等多个阶段组成。要保存工作过程中的工作成果，请使用标准保存命令。一旦设计好表单且其最终设计得到了批准，最好发布表单，即为表单分配已发布状态，以避免最终设计被意外更改。

保存表单

发布表单

确保机器可读性


保存表单

要保存表单，请使用标准保存命令或另存为…命令（文件>保存或文件>另存为…）。

另存为…命令将保存表单样本或页面样本。要选择保存格式，请使用保存类型下拉列表。

在 ABBYY FormDesigner 9.0 中创建的表单另存为 *.fdd 文件（表单定义文件）。

表单样本是二进制文件，其扩展名为 *.dtf。页面样本保存为 *.ptf 格式，该格式是 *.fdd 格式的改良版。


确保机器可读性

在表单设计阶段，可以随时检查表单以确保其为机器可读表单（工具>核对表单）。

如果未检测到任何错误，您会看到一条表明检查成功的消息。

如果检测到错误，完成检查后会在窗口下方显示这些错误信息。

报告中将包含可能导致计算机无法正确处理表单的所有故障情况，如没有定位点、没有表单标识符、表单元素太近或重叠表单边距等等。

按钮 | 描述
显示元素 | 显示不符合机器可读性要求的元素。选中报告中某一行时该按钮将变为可用状态。
核对表单 | 请在纠正错误后使用此按钮，以确保您的表单现在为机器可读表单。
保存报告… | 将检查结构报告保存至 .TXT 文件。


发布表单

发布表单时，要为表单分配已发布状态，这表示不能对表单的最终设计再作任何更改。在发布表单时，ABBYY FormDesigner 9.0 自动检查表单，以确保该表单为机器可读表单并为其指定一个唯一的表单标识符。

要发布表单，请使用发布表单命令（文件>发布表单）。已发布表单的状态为只读。所有表单标识符元素均分配有一个唯一的数值（与某个给定表单的所有表单标识符相同），并且表单的状态由已编辑变为已发布。

发布带有警告的表单

发布表单时，会对表单进行检查以确保其具有机器可读性。如果程序检测到您的表单非机器可读，屏幕上会打开“发布带有警告的表单”对话框。您可以使用该对话框以使该表单为机器可读表单，或在有警告的情况下仍然发布表单。

重要事项！

使用非机器可读的表单可能导致识别质量欠佳！

发布带有警告的表单对话框显示不符合机器可读性要求的所有失败情况的报告。

按钮 | 描述
仍要发布 | 忽略不符合机器可读性要求的警告，仍然发布表单。
编辑表单 | 在该窗口下方显示的报告中，指出了检查表单时检测到的任何错误信息。请使用该报告来纠正错误，并使您的表单为机器可读表单。

编辑已发布的表单

要对已发布表单进行更改，请选择文件菜单上的将可编辑副本另存为…命令。ABBYY FormDesigner 9.0 将提示您在更改设计前，先以不同的名称另存该表单。采用新名称的表单的状态将由已发布变为草稿，表单标识符的值被设为 0。

提示
建议您在完成表单设计后发布表单。这样有助于跟踪您对已完成的表单的更改情况，避免打印看是相似实则不同的表单。


导出表单

在创建表单后，可以将表单导出至各种各样的图像格式，如分色图像、特殊 XML 表单定义格式的图像、PDF 和 InfoPath 表单以及 Adobe Illustrator 文件。

某些导出类型只适用已发布的表单。

将表单发送至印刷厂时必须导出至图像格式。

导出至 XML 表单定义格式将会创建一个文件，ABBYY FlexiCapture 9.0 从该文件可以自动为表单创建文档定义。

将表单导出至图像文件

将表单导出至 独立图像文件…

将表单导出至 XML 表单定义格式 (*.xfd)

将表单导出至 PDF 表单…

将表单导出至InfoPath 表单…

将表单导出至 Adobe Illustrator 文件…


将表单导出至图像文件

在表单设计阶段，随时可以将表单导出至某种图像格式。如果表单的状态为草稿，表单标识符元素将在表单上注明“草稿”一词。如果表单的状态为已发布，表单标识符将显示其类型（只有条形码、带数字的条形码、只有数字）相应的标准外观。

要将表单导出至某个图像文件，请使用图像文件…命令（文件>导出至…>图像文件…）。

ABBYY FormDesigner 9.0 可以将表单导出至以下图像格式：
  • 位图，黑白 (*.bmp, *.dib, *.rle)
  • 位图，灰度 (*.bmp, *.dib, *.rle)
  • 位图，彩色 (*.bmp, *.dib, *.rle)
  • DCX，黑白 (*.dcx)
  • DCX，灰度 (*.dcx)
  • DCX，彩色 (*.dcx)
  • JBIG2 (*.jbig2, *.jb2)
  • JPEG，灰度 (*.jpg *.jpeg)
  • JPEG，彩色 (*.jpg *.jpeg)
  • JPEG-2000，灰度 (*.jp2, *.j2k)
  • JPEG-2000，彩色 (*.jp2, *.j2k)
  • PCX，黑白 (*.pcx)
  • PCX，灰度 (*.pcx)
  • PCX，彩色 (*.pcx)
  • PNG，黑白 (*.png)
  • PNG，灰度 (*.png)
  • PNG，彩色 (*.png)
  • TIFF，黑白，解压缩 (*.tif, *.tiff)
  • TIFF，黑白，Group4 (*.tif, *.tiff)
  • TIFF，黑白，Packbits (*.tif, *.tiff)
  • TIFF，黑白，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，黑白，LZW 压缩 (*.tif, *.tiff)
  • TIFF，灰度，解压缩 (*.tif, *.tiff)
  • TIFF，灰度，Packbits (*.tif, *.tiff)
  • TIFF，灰度，JPEG 压缩 (*.tif, *.tiff)
  • TIFF，灰度，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，灰度，LZW 压缩 (*.tif, *.tiff)
  • TIFF，彩色，解压缩 (*.tif, *.tiff)
  • TIFF，彩色，Packbits (*.tif, *.tiff)
  • TIFF，彩色，JPEG 压缩 (*.tif, *.tiff)
  • TIFF，彩色，ZIP 压缩 (*.tif, *.tiff)
  • TIFF，彩色，LZW 压缩 (*.tif, *.tiff)
  • PDF (*.pdf)
  • EMF (*.emf)

导出分色图像

在打印店打印时，需要将彩色表单保存至两个独立的文件。其中一个文件包含以黑色打印的元素，另一个文件包含以彩色打印的元素。

选择文件>导出至>独立图像文件…。图像将被保存为 TIFF 文件，黑白文件的名称中包含 _bw，彩色文件的名称中包含 _color。

导出多页表单

可以将多页表单导出至任何一种受支持的图像格式。对于多页格式而言，可以将表单保存至多页文件。将表单导出至图像文件时，请选择多页文件选项。如果未选择该选项，将把每页保存至独立的文件。

以您选择的分辨率导出至 TIFF 文件

可以在选项对话框（工具>选项…）上的导出选项卡上选择 TIFF 文件的分辨率。

注：TIFF 分辨率的范围为 50 至 1200 dpi。


导出至分色图像

要以两种颜色打印表单，需要将表单保存至两个文件：一个文件包含要以黑色打印的日期信息，另一个文件包含要以彩色打印的数据。

任何阶段都可以将表单导出至带分色的图像文件。在已编辑表单中，图像的标识符上方将标注草稿。如果是已发布的表单，标识符的外观将取决于选择的标识符类型。

要将表单导出至带分色的图像文件，请选择文件>导出至>分色图像。

图像将另存为 TIFF 文件。黑白图像的名称会添加 postfix _bw，彩色文件的名称会添加 postfix _color。


将表单导出至 XML 表单定义格式 (*.xfd)

使用 ABBYY FormDesigner 9.0 不仅可以创建表单，而且可以自动生成表单描述，然后可以使用生成的表单描述在 ABBYY FlexiCapture 9.0 Professional 中创建文档定义（文档定义可以告知表单处理应用程序在文档中的哪个位置查找特定类型的信息，以确保可靠识别输入的数据）。

要创建表单描述，首先要将表单导出至 *.xfd 文件（XML 表单定义格式），然后在 ABBYY FlexiCapture 9.0 Professional 中打开该文件，当在 ABBYY FlexiCapture 中创建文档定义时，只需导入创建的 *.xfd 文件，ABBYY FlexiCapture 就会自动创建所需的文档定义。

已发布的表单只能导出至 XML 表单定义。

您可以选择 ABBYY FormDesigner 9.0 将表单图像保存至 XFD 文件中时使用的格式（TIFF 或 EMF）。

要将表单导出至 *.xfd 文件，请使用 XML 表单定义…命令（文件>导出至>XML 表单定义…）。在显示的导出至 XML 表单定义对话框中，指定 *.xfd 文件的名称，并浏览至要存储该文件的文件夹。


将表单导出至 PDF

只能将已发布的表单导出至 PDF。

在以电子形式发布表单前，建议将表单导出至 PDF。您可以向表单添加响应按钮。单击这些按钮将把完成的表单发送至指定地址。

将图像导出为 PDF 格式后，可以在 Adobe Acrobat Professional 等其他表单编辑程序中对导出的图像进行编辑。

要将表单导出为 PDF，请单击菜单上的文件>导出至>PDF 表单…。

1. 在选择 PDF 保存选项前，请在 获取响应的方法对话框中选择是否向表单添加响应按钮。响应按钮显示在第一页的右上角。请选择以下选项（可以从中选择一个选项，选择两个选项，或者不选择任何选项）

- 通过电子邮件（指定电子邮件地址）

- 通过 HTTP（指定 URL）

2. 在导出至 PDF 对话框中，指定文件名和保存该文件的文件夹。

3. 通过单击高级…，也可以选择其他保存选项。在 PDF 文件选项对话框中，可以定义以下项目：

- 保存模式（仅文本或仅图像）

- 字体设定（使用系统字体或标准字体）

- 嵌套字体（如果想在表单中嵌套字体，请选择此选项）

注：
如果表单中至少有一个字段进行过编辑，将把该表单导出至 PDF。


将表单导出至 InfoPath

在任何阶段都可以将表单导出至 Microsoft Office InfoPath。要获取 Microsoft Office InfoPath 的源文件项目，请单击菜单上的文件>导出至>InfoPath 表单…。在浏览文件夹对话框中，选择要保存该项目的文件夹并单击确定。屏幕上将显示与所保存的表单同名的子文件夹，该文件夹包含 InfoPath 所需的文件。在 InfoPath 中，打开文件 manifest.xsf。

注：
  • 要正确处理 InfoPath 中的表单，请确保计算机安装有 Microsoft Office 2007 Service Pack 1 (SP1)。
  • 如果表单中至少有一个字段进行过编辑，将把该表单导出至 InfoPath。


导出至 Adobe Illustrator 文件

任何阶段都可以将表单导出至 Adobe Illustrator 文件。

要将表单转换为 Adobe Illustrator 格式，请单击文件>导出至>Adobe Illustrator 文件…。在另存为 Adobe Illustrator 文件对话框中，输入文件名称并指定保存该文件的文件夹。


发布表单

您可以发送已创建的表单，并以硬拷贝或电子格式（作为 PDF 表单）发布到 ABBYY FormDesigner 中。

通过电子邮件可以发送电子表单，或者发布到网站上。您也可以选择响应方法（通过电子邮件或在网站上），以处理服务器上的结果。

表单分发向导将帮助您选择正确的发送选项。单击文件>发布表单…或单击标准工具栏上的 [image] ，将启动该向导。

表单分发向导会引导您完成发布表单的所有必需步骤：

  1. 选择是否希望以硬拷贝或电子格式发布表单（只选择一个选项）：
    • 硬拷贝（纸质打印件）
    • 软拷贝（计算机文件）

    如果选择硬拷贝（纸质打印件），向导会提示您打印表单，然后关闭。

    如果选择软拷贝（计算机文件），向导会提示您提供发送和接收选项。

  2. 选择表单发布方法 （只选择一个选项）：
    • 发送至一组电子邮件收件人 - 如果选择本选项，请单击向导窗口下方的完成按钮。邮寄程序中会打开一个新的消息窗口。该消息会添加 PDF 表单作为附件，因此您只需指定地址和输入消息文本。发送电子邮件消息后，返回 ABBYY FormDesigner。
    • 保存并在以后发送 - 如果选择本选项，请指定保存 PDF 表单的文件夹。默认为将表单保存在 My Documents中，且该文件采用表单的名称。要另外指定文件夹和文件名称，请单击该选项旁边的“...”按钮，然后单击窗口下方的完成按钮。
    • 发布至网络位置 - 如果选择本选项，请指定要发布 PDF 表单的 URL 地址。示例：http://www.example.com/form.pdf。单击向导窗口下方的完成以发布表单。
    重要事项！

    您必须具备对要发布表单的网站的写入权限。

  3. 选择响应方法（可以从中选择一个选项，选择两个选项，或者不选择任何选项）
    • 通过电子邮件 - 指定要对其发送完整表单的电子邮件地址。
    • 通过 HTTP - 指定要在其中提交和处理完整表单的网站的 URL 地址。

    根据您选择的选项，表单第一页的右上角会显示一个按钮（或多个按钮）。单击该按钮将把表单发送至指定的网站或电子邮件地址。

    如果选择接收网站上的完整表单，可以将网站设置为自动处理提交的表单。


打印表单

要打印表单：

  1. 在文件菜单中选择打印...。

  2. 在打开的打印对话框中，设置所需的打印参数。

重要事项！

打印未发布的表单时，会连同表单边距显示“这是一份草稿表单”这几个字。


打印部分填好的表单

ABBYY FormDesigner 9.0 可以打印空白表单和其中部分字段填有数据的表单。例如，您可以打印填写了名称字段的表单，以将每个表单发送给特定的个人。实际的名称可以源自文件或数据库。

要使用源自数据库的数据填写空白表单并进行打印：

  1. 从文件菜单选择打印已填好的表单>带有源自数据库的值…
  2. 指定数据库连接参数。

重要事项！数据库中的相关字段必须与其表单上的对应部分的名称相同。将数据插入表单上的表格时，请采用以下格式填写完整的名称： <Table>|<Col>|<Row#>，其中 <Table> 是表格名称，<Col> 是表格的列的名称，<Row#> 是单元数（从 0 开始编号）。

要使用源自文件的数据填写空白表单并进行打印：

  1. 从文件菜单选择打印已填好的表单>带有源自文件的值…
  2. 指定文件路径。

重要事项！必须使用采用 Unicode 编码的 *.csv 或 .txt 文件。文件中的第一行必须包含字段名称，因为程序将视这一行为标题。文件中的字段名称必须与表单上的字段名称相同。将数据插入表单上的表格时，请采用以下格式填写完整的名称：<Table>|<Col>|<Row#>，其中 <Table> 是表格名称，<Col> 是表格的列的名称，<Row#> 是单元数（从 0 开始编号）。

打印部分填好的表单时，程序将识别文件或数据库中的数据类型，并相应进行打印。例如，如果表单上有一个您想用于填写您的客户的复选标记字段，文件或数据库中的相应字段的值可能为 True/False 或 1/0。对于选项按钮组，请创建一个含每个选项的名称的独立列，列中是插入 yes 还是 no 取决于相应的选项是选中还是未被选中。

打印输出的数据的字体与元素组视窗中指定的提示字体一致（提示选项卡）。


热键

菜单 | 命令 | 快捷键
文件 | 新建… | Ctrl+N
 | 打开… | Ctrl+O
 | 保存 | Ctrl+S
 | 打印… | Ctrl+P
编辑 | 撤销 | Ctrl+Z
 | 恢复 | Ctrl+Y
 | 剪切 | Ctrl+X
 | 复制 | Ctrl+C
 | 粘贴 | Ctrl+V
 | 删除 | Del
 | 复制 | Ctrl+D
 | 删除区域 | Shift+Del
 | 全选 | Ctrl+A
 | 按类型选择… | Ctrl+Shift+A
视图 | 按类型选择… | Alt+Enter
 | 缩放/最佳适合 | Ctrl+Shift+Num /
 | 缩放/缩小 | Ctrl+Shift+Num -
 | 缩放/放大 | Ctrl+Shift+Num +
元素 | 绘制元素/选择工具 | Esc
 | 绘制元素/输入字段 | E
 | 绘制元素/日期字段 | D
 | 绘制元素/数字字段 | N
 | 绘制元素/复选标记字段 | C
 | 绘制元素/元素组 | G
 | 绘制元素/表格 | T
 | 绘制元素/垂直分隔符 | V
 | 绘制元素/水平分隔符 | H
 | 绘制元素/文本 | S
 | 绘制元素/行分隔符 | L
 | 绘制元素/框 | F
 | 绘制元素/图片 | P
 | 绘制元素/定位点 | A
 | 绘制元素/标识符 | I
 | 对齐/左 | Alt+向左箭头
 | 对齐/水平居中 | Shift+F9
 | 对齐/右 | Alt+向右箭头
 | 对齐/顶部 | Alt+向上箭头
 | 对齐/垂直居中 | Ctrl+F9
 | 对齐/底部 | Alt+向下箭头
 | 大小/绘制相同宽度 | Shift+F8
 | 大小/绘制相同高度 | Ctrl+F8
 | 大小/绘制相同宽度和高度 | Ctrl+Shift+F8
 | 合并 | Ctrl+Shift+G
 | 拆分 | Ctrl+Shift+U
工具 | 核对表单 | F9
 | 选项… | Ctrl+Shift+O
帮助 | 帮助主题 | F1


热键（文本编辑）

要执行 | 请按
光标上移一行。 | 向上箭头
光标下移一行。 | 向下箭头
光标移至第一行。 | 向上翻页
光标移至最后一行。 | 向下翻页
光标右移一个符号。 | 向右箭头
光标左移一个符号。 | 向左箭头
将光标右移至后面一个单词的开头。 | Ctrl+ 向右箭头
将光标左移至此单词的开头。 | Ctrl+ 向左箭头
将光标移至此行的开头。 | Home
将光标移至此行的末尾。 | End
将光标移至文本开头。 | Ctrl+Home
将光标移至文本末尾。 | Ctrl+End
删除选定文本。 （如果未选择文本，将删除右侧的符号。） | Delete
删除光标前的符号。 | Backspace
退出文本编辑模式，不保存任何更改。 | Esc
保存所有更改并退出文本编辑模式。 | Enter
移至下一行。 | Ctrl+Enter


专利

美国专利号 5,258,855、5,369,508、5,625,465、5,768,416 和 6,094,505


第三方技术

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia.

保留所有权利。

更多

特此无偿授予获取该软件及相关文档的任何人（“用户”）无限制使用本软件的权利，包括使用、复制、修改、合并、发布、分发和/或出售本软件和相关文档文件（“软件”）副本的无限制权利，并允许本软件所提供给的任何人进行上述操作，前提是满足以下许可条件。

  1. 上述版权声明和该许可声明（包括下面的免责声明）将包括在本软件的所有副本或重要部分中。

  2. 未经事先书面同意，版权所有者的名称不得用于支持或促销从该软件衍生的产品。

该保证的免责声明是本许可证的关键部分。

只有在认可该免责声明的前提下对本软件的使用才能得到授权。本软件由版权所有者按“现状”提供，不做出任何明示或暗示的保证，包括但不限于表明本软件适销性和适合特定用途以及不侵犯第三方权利的保证。在任何情况下，对于因使用本软件或本软件性能导致的或与此有关的任何权利主张，任何直接、间接的或特殊性的损害，或任何因使用、数据或利润的损失而导致的损害，无论是否涉及合同、疏忽或其他侵权行为，版权所有者概不负责。版权所有者不作任何有关本软件不侵犯任何其他实体的专利或其他知识产权的保证。每个版权所有者不对用户承担其他实体基于侵犯知识产权或其他权利而提出的权利主张承担责任。作为行使下面授予的权利的一个条件，每个用户要承担遵守其他任何知识产权的全部责任。本软件不具有容错性，并且其并非旨在用于关键任务系统（如核设施、飞机导航或通讯系统、空中交通管制、直接生命维持系统或武器系统），在此类环境中本软件或系统如果出现故障，将直接导致死亡、人身伤害或严重的物理或环境损害（“高风险活动”）。版权所有者不对适合高风险活动做出任何明示或暗示的保证，并对此做出免责声明。

商标

QuickScan 是商标，Captiva 是 Captiva Software Corporation 的注册商标。

KODAK 是 Eastman Kodak Company 的商标。


如何购买 FormDesigner 8.0

如何购买 ABBYY FormDesigner 9.0

有关 ABBYY 的完整数据管理和捕获解决方案的详细信息，请访问 www.abbyy.com 和 www.FlexiCapture.com。

要订购 ABBYY FlexiCapture 9.0 的副本或了解该产品的其他信息，请联系我们：registration@abbyy.com

您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


ABBYY 办事处

北美洲/中美洲

美国、加拿大、墨西哥或中美洲国家的客户请联系：

ABBYY USA

电话：+ 1 510-226-6717
传真：+1 510 226 6069
地址：47221 Fremont Boulevard, Fremont, California 94538, USA
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyyusa.com

西欧

奥地利、比利时、荷兰、卢森堡、丹麦、法国、德国、希腊、意大利、爱尔兰、挪威、葡萄牙、西班牙、瑞典、瑞士、英国或其他西欧国家的客户请联系：

ABBYY Europe GmbH

电话：+49 89 511 159 0
传真：+49 89 511 159 59
地址：Elsenheimerstrasse 49, 80687 Munich, Germany
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyyusa.com

日本

日本的客户请联系：

ABBYY Japan

电话：+81 42 795 1901
传真：+81 42 795 1901
地址：658-1 Tsuruma, Machida-shi, Tokyo 194-8510
电子邮件：sales@abbyyusa.com
支持电子邮件：support@abbyyusa.com
http://www.abbyy.com

东欧与地中海地区

阿尔巴尼亚、波斯尼亚和黑塞哥维那、保加利亚、克罗地亚、捷克共和国、匈牙利、以色列、马其顿、摩尔多瓦、黑山、波兰、罗马尼亚、塞尔维亚、斯洛伐克、斯洛文尼亚、土耳其或乌克兰的客户请联系：

ABBYY Ukraine

电话：+ 38 044 490-9999
传真：38 044 490-9461
地址：P.O.Box 23, 02002 Kiev, Ukraine
电子邮件：forms@abbyy.ua
技术支持：
电话：+380 44 490 9463
电子邮件：formssupport@abbyy.ua
http://www.abbyy.com

所有其他地区

以上未提到的国家或地区的客户请联系：

ABBYY Russia

电话：+7 495 783-3700
传真：+7 495 783 2663
地址：P.O.Box 54, Moscow 129301, Russia, ABBYY
电子邮件：sales@abbyy.com
支持电子邮件：support@abbyy.com
http://www.abbyy.com

网上商店

俄罗斯：http://store.abbyy.ru
其他国家或地区：http://buy.abbyy.com/


技术支持

如果您有任何关于 ABBYY FormDesigner 9.0 如何使用的问题，请先参阅本软件随附的文档（用户指南和帮助）。您也可以浏览我们网站 www.abbyy.com/support 上的技术支持部分。

我们的技术支持服务专家需要以下信息才能有效回答您的问题：

  • 您的姓名

  • 您的公司名称

  • 您的电话号码（或传真、电子邮件）

  • ABBYY FlexiCapture 软件包的序列号

  • Build 号（请参阅帮助/关于…/Build）

  • 对问题的总体描述以及错误消息的全文（如有）

  • 您的计算机和处理器类型

  • 您的 Windows 操作系统版本

您也可以向我们提供您认为重要的其他信息。

单击系统信息… 对话框（帮助菜单）中的关于 ABBYY FormDesigner 9.0按钮，可以自动获取部分信息。

重要事项！仅注册用户有资格获得技术支持。您可以在我们的网 站上注册您的应用程序副本。

ABBYY 办事处


字体

使用 字体 对话框（编辑模式>字体中的文本快捷菜单）可以编辑文本。

向我显示字体对话框

项目

描述

字体选项卡

字体

为选定的文本片段选择字体。

字体样式

为选定的文本片段选择字体样式。

  • 常规
  • 斜体
  • 粗体
  • 加粗倾斜

大小

为选定的文本片段选择字号。

颜色

为选定的文本片段选择颜色*。

效果

选择文本效果 - 下划线或删除线。

字符间距选项卡

间距

更改选定文本片段的间距。

磅值

增大或减小选定文本片段中字符的间距（即展开或压缩文本）。

位置

设置选定文本片段的位置：标准、提升、降低。

*- 颜色清单取决于表单类型（黑白或彩色）。

注：各种语言的其他字体可从 http://www.paratype.com/shop/ 购买。


术语表

A

ABBYY FormDesigner

ABBYY FormDesigner 是一种用于创建机器可读表单的软件应用程序，这类表单使用 ABBYY FlexiCapture 进行处理。表单设计是表单创建的一个重要阶段，因为其他所有阶段 — 扫描、识别、校验、导出 — 均取决于初始表单的“正确性”以及表单对于机器处理的适合性。

B

表单

文档由一页或多页组成，可以由手工填写，或使用打印机或打字机填写。

表单标识符

是机器可读表单的一种元素，该元素允许表单处理程序识别每个表单。

表单创建

由分析、设计和打印这三个阶段组成的过程。

表单发布

在发布表单时要为表单分配已发布状态，以防止更改表单。同时会检查表单的机器可读性，并为表单识别符分派唯一的编号（与其他所有标识符一样）。

表单样本

用于在 ABBYY FormDesigner 中创建新表单的样本。样本作为二进制文件进行存储，并且采用扩展名 *.dtf。

表格

是机器可读表单的一种元素，这种元素包含多列类型相同的元素。

D

带光栅背景的黑白表单

这类表单的字段一般为光栅背景上的空白空间（一般为矩形）。背景由单个的点组成。

带光栅边框的黑白表单

这类表单没有背景。所有字段边框（字符单元边框、复选标记字段和其他表单元素）组成了光栅线条，即小黑点序列。

滴定表单

这些表单有浅色背景，以白色矩形作为字符单元、复选标记字段等等。

定位点

是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

F

复选标记字段

复选标记字段是机器可读表单的一种元素（通常是一个复选框），在该框中可以填入一个标记（如勾或叉等）。

H

黑白线性表单

这些表单一般没有背景。所有字段边框（字符单元、复选标记字段和其他表单元素）组成了黑色实线。

J

机器可读表单

一种可以由计算机处理的表单。

机器可读表单的要求

对表单的类型和外观，以及表单元素的定位的要求。如果满足这些要求，可以达到最高识别质量。

机器可读性

表单对于自动处理的适合性。

K

框

是机器可读表单的一种元素，它可以包围表单上的某个区域。

S

输入字段

是机器可读表单的一种元素，在表单中的该字段可以输入文本。

T

图片

是机器可读表单的一种元素，这种元素包含有图像。

W

文本

是机器可读表单的一种元素，这种元素包含字段名称、如何填写表单的操作指示等描述和说明性文本。

X

XFD 格式

XML 表单定义 (*.xfd) 是 ABBYY FormDesigner 中创建的表单文件的格式。XML 表单定义文件可以自动转换为 ABBYY FlexiCapture 的模板。

行分隔符

是机器可读表单的一种元素，这种元素的形状为一条垂直或水平的黑线。

Y

页面标识符

是机器可读表单的一种元素，这种元素允许表单处理程序识别表单的每一页。

页面样本

用于在 ABBYY FormDesigner 中创建新页面的样本。样本作为二进制文件进行存储，并且采用扩展名 *.ptf。

引用标记

是机器可读表单的一种元素，用于匹配带有其模板的表单和确定处理期间的方向。

元素组

是机器可读表单上的一种元素，这种元素可以合并多个有逻辑关联的元素。

Z

字符单元

只能在其中输入一个字符的小矩形（如一个字母或一位数）。


术语表

A B D F H J K S T W X Y Z


属性对话框：定位点

元素属性对话框：定位点

项目 | 描述
类型： | 设置表单上使用的定位点的类型。 一个表单只能包含一种类型的定位点。
大小： | 设置定位点的大小： 黑方块形每条边的大小，或 直角形每条边的大小。
行宽：（仅适用直角形） | 设置直角形的边的线宽。


表单属性对话框

项目 | 描述
作者： | 表单创建者的名称。
状态： | 表单状态： 草稿，如果允许对表单进行更改，以及 已发布，如果表单为只读表单。
发布日期： | 发布表单的日期。
表单标识符： | 表单标识符的值。
文件： | 包含表单的文件的路径。


页面设置对话框：常规

项目 | 描述
名称： | 设置页面名称。
最少出现次数 | 设置当前页面在表单中出现的最少次数。
最少出现次数： | 设置当前页面在表单中出现的最多次数。
页面标识符： | 显示页面标识符的值。


页面设置对话框：常规

页面设置对话框：大小

项目 | 描述
页面大小： | 从下拉列表（A3、A4 或 A5）选择标准页面大小，或设置自定义页面大小。要自定义页面大小，请选择列表中的自定义大小项目，并在相应字段中指定所需的宽度和高度。
宽度： | 设置页面宽度。
高度： | 设置页面高度。
方向 |
纵向 | 页面方向设置为纵向。
横向 | 页面方向设置为横向。
边距 |
顶部： | 设置上边距的宽度。
底部： | 设置下边距的宽度。
左： | 设置左边距的宽度。
右： | 设置右边距的宽度。


页面设置对话框：颜色

页面设置对话框：彩色

属性

描述

样式：

设置表单样式：

  • 灰色表单

  • 黑白表单

  • 橙色表单

  • 红色表单

  • 绿色表单

页面背景*

颜色：*

从下拉列表中选择页面背景色。

注：只有颜色滴定表单可以选择颜色。黑白表单的默认色是白色。

大小：*

使用此列表来选择背景色的覆盖区域。有两个选择：

  • 整页（填充除表单元素以外的所有页面）。

  • 边距以内（填充该页，但页面边距和表单元素保留白色）。

* - 只能对滴定表单指定这项属性。


属性对话框：对齐

元素属性对话框：对齐

项目

描述

水平：

水平对齐元素内的文本：

  • 居中 - 将文本水平居中

  • 左对齐 - 将文本对齐元素左边缘

  • 右对齐 - 将文本对齐元素右边缘

垂直：

垂直对齐元素内的文本：

  • 下对齐 - 将文本对齐元素下边缘

  • 居中 - 将文本垂直居中

  • 上对齐 - 将文本对齐元素上边缘

方向：

设置文本的方向。

  • 常规（水平） - 文本将从左到右水平排列
  • 垂直（从上到下） - 文本将从上到下垂直排列
  • 垂直（从下到上） - 文本将从下到上垂直排列。


属性对话框：背景

元素属性对话框：背景

项目 | 描述
与表单背景相同 | 使元素的背景色与表单的背景色相同。
其它： | 从下拉列表中选择元素背景色。* - 可用颜色的范围取决于表单类型（黑白或彩色）。


属性对话框：复选标记字段

元素属性对话框：复选标记字段

项目

描述

类型：

复选标记字段的形状：

  • 方块形

  • 圆圈

位置：

设置复选标记字段相对于说明性文本的位置：

  • 文本左侧 - 复选标记字段在文本左侧

  • 文本右侧 - 复选标记字段在文本右侧

  • 文本上方 - 复选标记字段在文本上方

  • 文本下方 - 复选标记字段在文本下方

大小：

包含预定义字段大小的下拉列表（3.5x3.5、4x4、4.5x4.5 或 5x5 mm）。

行宽：

设置字段边框的宽度（0.4 mm 至 0.8 mm）。

平衡：

设置复选标记字段和文本的说明性文本之间的间距（2 mm 至 7 mm）。

颜色：

从下拉列表中选择字段边框颜色*。


Диалог Свойства: Поле метки

元素属性对话框：日期

项目

描述

日期格式：

指定日期格式：

  • DD.MM.YYYY
  • MM.DD.YYYY
  • YYYY.MM.D

年份中的数字：

指定用于记录年份的单元数字：

  • 2（有 2 个单元）
  • 4（有 4 个单元）

分隔符：

选择用于记录日期的分隔符：

  • .
  • /
  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

选择提示颜色。提示将被输入至表单上的日期字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：各种语言的其他字体可从 http://www.paratype.com/shop/ 购买。


属性对话框：标记

元素属性对话框：标记

项目

描述

标记类型：

设置文本的标记类型：

  • 字母位于独立虚线框中

  • 字母位于独立框中

  • 字母位于梳形中

  • 文字位于梳形框中

  • 字母位于框中

单元大小：

设置字符单元的大小：

  • 正常 – 标准单元大小 (4x5 mm)

  • 大 – 最大单元大小 (5x6.5 mm)

  • 小 – 最小单元大小 (3x4 mm)

粗体标记线（适用“字母位于独立虚线框中”以外的所有标记类型）

将单元框更改为粗体框。

标记颜色：

从下拉列表中选择标记颜色*。

多行

向输入字段添加多行。（只适用输入字段元素）。


属性对话框：提示

元素属性对话框：提示

项目 | 描述
文本： | 设置提示文本。提示将被输入至表单上的输入字段：每个提示字母位于相应的单元。
颜色： | 从下拉列表中选择提示颜色*。
字体： | 选择提示字体。
自动调整字体大小 | 根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：链接的字段

元素属性对话框：链接的字段

项目 | 描述
链接的字段 | 默认情况下，只要您在表单上创建元素，就会在文档结构中创建一个与此元素相链接的字段。要将元素与同类型的另一个字段相链接，请从下拉列表中选择该字段的名称。


属性对话框：文本

元素属性对话框：文本

项目 | 描述
文本： | 元素内的文本。
字体： | 元素中的文本使用的字体。 要更改字体、字号和样式（斜体、粗体、下划线等），请单击更改…按钮，并在显示的字体对话框中选择所需的字体、字号和样式。
字体颜色 ： | 从下拉列表中选择文本颜色。
自动换行 | 将文本换行，但不断字。

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：线条

元素属性对话框：线条

项目

描述

宽度：

设置线宽（0.3 mm 至 6 mm）。

样式：

设置线条样式：

  • 虚线

  • 点划线

  • 实线

颜色：

从下拉列表中选择线条的颜色。


属性对话框：元素

元素属性对话框：元素

项目 | 描述
类型： | 元素的类型。
位置和大小 |
左： | 设置左边距的宽度。
顶部： | 设置上边距的宽度。
宽度： | 设置页面宽度。
高度： | 设置页面高度。


属性对话框：标识符

元素属性对话框：标识符

项目

描述

类型：

设置表单标识符的类型：

  • 只有条形码

  • 带数字的条形码

  • 只有数字

条形码类型：

如果标识符类型被设为只有条形码或带数字的条形码，并且选择了自定义值选项，那么请选择条形码的类型。

可用的条形码类型有：

  • EAN13
  • EAN8

如果未选择自定义值选项，条形码类型：会显示为灰色。将使用 EAN13 条形码类型。

方向：

设置条形码的方向。

  • 水平
  • 垂直

值：

标识符的值

只能在选择了自定义值选项的情况下才能更改标识符的值。对于 EAN13，自定义值必须包含 12 位数；对于 EAN8，自定义值必须包含 7 位数。不允许使用比指定位数长或短的值或字符。对于 EAN13，会在字符串开头（在条形码以外）添加附加的控制位；对于 EAN8，会在条形码中字符串末尾添加附加控制位。

如果选择了表单标识符或页面标识符选项，将在发布表单时自动为标识符分配一个值。在发布表单前，表单的状态为可编辑，且尚未分配标识符值。

表单标识符

使用元素作为表单标识符。

页面标识符

使用元素作为当前页面的标识符。

自定义值

允许标识符采用自定义值。该选项不适用于只有数字标识符。


属性对话框：数字

元素属性对话框：编号

项目

描述

小数位：

选择记录小数位的位数。

分隔符：

选择用于记录数字的分隔符：

  • .
  • /
  • -

颜色：

从下拉列表中选择分隔符颜色*。

提示文本：

选择提示颜色。提示将被键入至表单上的数字字段：每个提示字母位于相应的单元。

颜色：

从下拉列表中选择提示颜色*。

字体：

选择提示字体。

自动调整字体大小

根据字段字符单元的高度，自动选择提示字体大小。

* - 可用颜色的范围取决于表单类型（黑白或彩色）

注：您可在以下网站购买附加的字体和多语种字体支持：www.paratype.com/shop/。


属性对话框：图片

元素属性对话框：图片

项目

描述

大小模式：

更改元素大小的模式有以下三种：

  • 剪切 – 更改元素的大小，但不更改图片及其比例的大小。
    采用这种模式无法放大图片本身。
    如果元素变得比图片小，图片有一部分将在表单上不可见。

  • 扩展 – 更改元素的大小，并根据元素大小收缩或扩展图片。始终会显示整个图像，但不保留图像比例。

  • 缩放 – 更改元素的大小，并根据元素大小的比例放大或缩小图片。始终会显示整个图像，并保留图像比例。

对齐：

对齐元素中的图像：

  • 左上 – 将图片放在元素的左上角。

  • 右上 – 将图片放在元素的右上角。

  • 居中 – 将图片放在元素的中心。

  • 左下 – 将图片放在元素的左下角。

  • 右下 – 将图片放在元素的右下角。

来源：

指定源图像文件。

要指定加载图片的源文件：

  1. 单击 "…" 按钮。

  2. 在显示的对话框中，浏览至包含要添加至表单的图片的文件。

受支持的图像格式有：

  • 位图文件 (*.bmp)
  • DCX 文件 (*.dcx)
  • PEG 文件 (*.jpg; *.jpeg; *.jfif)
  • PCX 文件 (*.pcx)
  • PNG 文件 (*.png)
  • TIFF 文件 (*.tif; *.tiff)
  • Windows 增强媒体文件 (*.emf)


Диалог Свойства: Поле метки

元素属性对话框：表格

项目 | 描述
单元间距： | 设置表格单元的间距。
使用第一行作为标题 | 如果选择该选项，第一行将包含列名。


段落属性

可以在 段落属性 对话框（编辑模式中的文本快捷菜单>段落属性）中查看主要段落属性。

向我显示段落属性对话框

项目 | 描述
常规 |
对齐 | 将文本左对齐或右对齐、将文本居中或适合页面宽度对齐文本。
缩进 |
文本前 | 设置左缩进。
文本后 | 设置右缩进。
间距 |
段前 | 设置段前的间距。
段后 | 设置段后的间距。
行间距 ： | 更改文本行之间的行距。