Information zu ABBYY FlexiCapture 8.0 Professional

ABBYY FlexiCapture 8.0 Professional ist eine Softwarelösung, mit der Daten aus Papierdokumenten automatisch in Informationssysteme und Datenbanken erfasst werden können.

Durch den Einsatz moderner Technologien zur Erkennung gedruckter und handschriftlicher Zeichen, zur Bildverarbeitung und zur Dokumentanalyse können mit ABBYY FlexiCapture 8.0 Professional alle wichtigen Arten von Informationen automatisch aus Dokumenten extrahiert werden. Dabei können in einem Durchgang sowohl strukturierte (statische) Formulare als auch teilweise strukturierte (flexible) und nicht strukturierte Dokumente verarbeitet werden. Mit ABBYY FlexiCapture 8.0 Professional ersparen Sie sich den ineffizienten Arbeitsaufwand, der mit der manuellen Sortierung und Abschrift von Informationen aus Dokumenten entsteht.

Die Dokumentverarbeitung umfasst im Allgemeinen folgende Arbeitsschritte:

  1. Zunächst werden die Dokumente in die automatische Dokumentenzufuhr des Scanners eingelegt, und der Scanvorgang wird gestartet.
  2. Anschließend werden die gescannten Dokumentenbilder zur Erkennung weitergeleitet. Die Software erkennt auch mehrseitige Dokumente automatisch, sucht nach aussagekräftigen Feldern, extrahiert die Daten und lädt die überprüfungsregeln.
  3. Sofern erforderlich, werden die Daten dann visuell überprüft und auf mögliche Regelfehler hin untersucht.
  4. Abschließend werden die erkannten und geprüften Daten zusammen mit den elektronischen Kopien der Dokumente in einer Datenbank, einem Informationssystem oder einer Datei gespeichert.


Neue Funktionen in ABBYY FlexiCapture 8.0 Professional im Vergleich zu FormReader 6.5 Desktop

Unterstützte Dokumenttypen

Mehrseitige Dokumente mit komplexer Struktur

In ABBYY FlexiCapture 8.0 Professional können strukturierte, teilweise strukturierte und nicht strukturierte Dokumente unterschiedlicher Größe und mit sich wiederholenden Seiten sowie Dokumente mit Anhängen automatisch identifiziert und verarbeitet werden.
Unterstützte Dokumenttypen in ABBYY FlexiCapture 8.0
Erstellen von Vorlagen für mehrseitige Dokumente
Erstellen von Vorlagen für Dokumente mit Anhängen

Nicht strukturierte Dokumente

Nicht strukturierte Dokumente mit Text oder Bildern, die durch leere Blätter oder Seiten mit Barcodes oder Patchcodes getrennt sind, werden mithilfe einfacher Vorlagen indiziert, verarbeitet und in durchsuchbare PDF-Dateien oder Grafikdateien exportiert.
Verarbeiten nicht strukturierter Dokumente

Teilweise strukturierte mehrseitige Dokumente mit komplexen Tabellen oder Tabellen auf mehreren Seiten

Teilweise strukturierte mehrseitige Dokumente mit Tabellen, die sich über mehrere Seiten erstrecken, werden identifiziert, in Dokumenten zusammengestellt und mithilfe eines einfachen FlexiLayouts verarbeitet.
Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente

Statische Formulare mit Tabellen

Die Verarbeitung von Dokumenten mit Tabellen wurde vereinfacht, da nun Tabellen in statischen Formularen unterstützt werden.
Erstellen einer Tabelle

Wiederholt vorkommende Elemente

Wiederholt vorkommende Feldgruppen werden sowohl in strukturierten als auch in teilweise strukturierten Dokumenten unterstützt. Dadurch vereinfacht sich die Konfiguration der Verarbeitung von Dokumenten mit gleichen Elementgruppen, die sich mehrfach wiederholen, einschließlich komplexer Tabellen mit solchen Gruppen.
Erstellen einer Feldgruppe

Programmarchitektur

Operator- und Administratormodus

Der Operator- oder der Administratormodus wird jeweils über den entsprechenden Befehl im Startmenü aktiviert. Operator- und Administratorstation können auf verschiedenen Computern installiert werden. Im Administratormodus stehen alle Programmfunktionen zur Verfügung. Im Operatormodus können Benutzer dagegen weder Dokumentvorlagen bearbeiten noch Profile importieren oder auf Teststapel zugreifen.
Administrator- und Operatormodus

Arbeiten mit Projekten

In einem Projekt sind verschiedene Dokumentstapel und die zur Verarbeitung erforderlichen Einstellungen, z. B. Dokumentvorlagen oder Importprofile, vereint und festgelegt.

Ein Projekt kann von verschiedenen Kopien des Programms verwendet werden: Ein Projekt kann als einzelnes Objekt exportiert und importiert, aktualisiert und von einem Computer zu einem anderen übertragen werden. Benutzer an verschiedenen Workstations in einem Netzwerk können im Hinblick auf eine optimierte Dokumentverarbeitung an den gleichen Projekten arbeiten.
Erstellen eines Projekts
Projekteigenschaften

Benutzerfreundliche Tools für die Arbeit mit Hintergrundprozessen

Zeitintensive Operationen wie das Hinzufügen von Bildern, die Erkennung oder der Export können im Hintergrundmodus ausgeführt werden, wodurch die Verarbeitungszeit von Dokumenten erheblich gesenkt wird. Der Benutzer kann jederzeit den Status aller Hintergrundprozesse überprüfen, die Prioritäten der Tasks ändern und das Verarbeitungsprotokoll anzeigen.

Hintergrundmodus

Dokumentvorlageneditor

Vorlagen auf Dokumentebene

Vorlagen werden als Verarbeitungseinheiten für ein gesamtes Dokument erstellt und daher als Dokumentvorlagen bezeichnet. Mit einer Dokumentvorlage wird festgelegt, auf welche Weise Dokumente eines bestimmten Typs identifiziert und verarbeitet werden. Jede Dokumentvorlage enthält Seitenbilder, Zusammenstellungsregeln, Beschreibungen von Feldern und statischen Elementen, überprüfungsregeln, überprüfungseinstellungen, Beschreibungen von Datentypen sowie Einstellungen für den Datenexport.
Erstellen von Vorlagen für mehrseitige Dokumente

Wechseln zwischen zwei verschiedenen Bildmodi

Mithilfe des Vorlageneditors können Sie nun zwischen zwei Bildansichten wechseln. Unabhängig von dem Format, in dem Bilder zu einem Stapel hinzugefügt werden, können Sie sie entweder mit den Originalfarben oder schwarz-weiß anzeigen. Mithilfe von Farbbildern können Vorlagen für Farbformulare einfacher erstellt werden, da in dieser Ansicht Feldmarkierungen und erklärender Text angezeigt werden. Diese Elemente werden zum Zeichnen des Feldbereichs und zum Zuweisen eines Namens zum Feld benötigt. In Schwarz-Weiß-Bildern kann überprüft werden, ob Anker und statischer Text nach der Binärumwandlung während des Erkennungsvorgangs immer noch sichtbar sind.

Datenformulareditor

Im Datenformulareditor können Sie eine benutzerdefinierte Ansicht der extrahierten Daten definieren und deren Darstellung an die Anforderungen der Operatoren anpassen.
Konfigurieren der Datendarstellung im Dokumentfenster

Darstellung der Felder in einer Verzeichnisstruktur

Die Dokumentstruktur wird grafisch als Feldverzeichnisstruktur dargestellt. Durch diese Darstellungsform der Felder können Sie Felder schnell bearbeiten, kopieren, löschen und verschieben.
Darstellung der Dokumentstruktur in der Gliederungsansicht

Mehrseitige Dokumente werden mit der entsprechenden Seitengliederung angezeigt. Auf diese Weise können Vorlagen für mehrseitige Dokumente einfacher erstellt, angezeigt und bearbeitet werden.
Getrennte Anzeige von statischen Elementen und Feldern

Statische Elemente und Felder werden getrennt voneinander angezeigt. Dies vereinfacht die Erstellung von Vorlagen, die dann in zwei Schritten erfolgen kann. Statische Elemente (Anker, Trennlinien, Ankertext und Barcodes) werden getrennt erstellt und beeinträchtigen die Erstellung von Feldbereichen nicht.

Erstellen von Feldern einer Dokumentvorlage
Statische Elemente
Gruppieren von Feldern

Felder können in Gruppen zusammengefasst werden, sodass Dokumentstrukturen klar dargestellt sowie mehrfach vorkommende Feldgruppen erstellt werden können.

Erstellen einer Feldgruppe
Eigenschaften einer Feldgruppe
Tabellen in statischen Templates

In statischen Templates können jetzt Tabellenfelder erstellt werden. Dies trägt erheblich zur Vereinfachung der Konfiguration und Datenextraktion sowie des Datenexports aus Tabellen bei. Bei einem Tabellenfeld handelt es sich um eine Gruppe mit Spalten des gleichen Typs und mehreren Zeilen.

Erstellen einer Tabelle
Tabelleneigenschaften
Wiederholt vorkommende Elemente in statischen Templates

Bei wiederholt vorkommenden Elementen handelt es sich um Felder und Feldgruppen, die in einem Formular mehrfach vorkommen und ähnliche Objekte betreffen, z. B. die gleichen Details mehrerer Mitarbeiter, Kinder, Konten usw. Die Struktur dieser Elemente erinnert an die Struktur von Tabellen: Eine Feldgruppe entspricht dabei einer Tabellenspalte und jedes mehrfach vorkommende Feld einer Tabellenzeile. Mit dem Dokumentvorlageneditor kann die Konfiguration und Verarbeitung dieser Felder und Feldgruppen einfacher durchgeführt werden.

Felder mit mehreren Instanzen
Felder auf mehreren Seiten eines Formulars

Wenn ein Formular Felder enthält, deren Bereich sich über mehrere Seiten erstreckt, z. B. große Tabellen, können Sie diese Felder im Dokumentvorlageneditor als ein großes Feld anzeigen, wodurch die Konfiguration und Verarbeitung erheblich erleichtert wird.

Felder mit mehreren Bereichen
Automatische Erstellung statischer Templates

Mit den folgenden neuen Funktionen des Vorlageneditors kann die Erstellung statischer Templates automatisch durchgeführt werden und wird somit erleichtert.

  • Automatische Identifizierung von Textfeldern mit einem Bereich
  • Automatische Identifizierung vertikaler und horizontaler Trennlinien in Tabellen
  • Automatische Identifizierung eines Felds mit nur einem Klick der Maustaste auf den Bereich des Felds
  • Automatische Zuweisung eines Feldnamens, der dem nächsten erklärenden Text entspricht
  • Erkennung und Kopieren von statischem Text aus dem Vorlagenbild in die Feldeigenschaften
  • Automatische Anpassung der Feldränder
Automatische Erkennung von Feldern und statischen Elementen
ändern eines Feldnamens
Verbesserte Konfiguration von Datentypen

Die Einstellungen der Datentypen wurden weiter ausgearbeitet, um so die Erstellung von Dokumentvorlagen zu vereinfachen sowie die Extraktion und überprüfung von Felddaten zu optimieren. Die am häufigsten verwendeten Datentypen (Text, Datum und Uhrzeit, Währung, Anzahl) sind nun in der Gruppe vorkonfigurierter Datentypen integriert. Gleichzeitig wurden die am häufigsten verwendeten Formate der vorkonfigurierten Datentypen zur Gruppe vorkonfigurierter Formate hinzugefügt und können nun in der entsprechenden Liste ausgewählt werden, ohne dass komplexe Regeln für die Formatüberprüfung erstellt werden müssen.
Datentypen für Texteingabefelder
Erstellen benutzerdefinierter Datentypen

Beschreibung der überprüfungsregeln mit JScript®

überprüfungsregeln können jetzt (zusätzlich zu VBScript) auch mit JScript® als Skript definiert werden. Dadurch können Sie benutzerdefinierte Regeln zur überprüfung extrahierter Daten konfigurieren.
Festlegen einer Regel mithilfe eines Skripts
Erstellen von Regeln mithilfe von Skripten

Indexfelder

Wenn in den Eigenschaften eines Felds die Option Indexfeld aktiviert ist, können die Werte dieses Felds als zusätzliche Spalte im Fenster des Dokumentstapels angezeigt werden. Dokumente können dann anhand des Werts dieses Felds sortiert werden. Beim Export können die Werte der Indexfelder zum Dateinamen hinzugefügt werden, wodurch das Auffinden gesuchter Informationen vereinfacht wird.
Indexfelder
Regeln für das Benennen von Exportdateien

Zusätzliche Versionen von Dokumentvorlagen

Beim öffnen einer Dokumentvorlage im Vorlageneditor wird automatisch eine temporäre lokale Version der Vorlage erstellt. Diese bearbeitbare Version wird erst in die Verarbeitung von Dokumenten einbezogen, nachdem sie veröffentlicht wurde. Mit dieser Funktion können Vorlagen in Projekten von mehreren Benutzern bearbeitet werden.
Bearbeiten und Veröffentlichen einer Vorlage

Testen von Dokumentvorlagen auf speziellen Stapeln im Vorlageneditor

Um die Erstellung von Vorlagen zu vereinfachen und zu beschleunigen, können bearbeitbare Vorlagen während des Erstellungsvorgangs getestet werden, ohne dass dazu der Dokumentvorlageneditor geschlossen werden muss. Eine Vorlage kann beim Erstellen mit dem Bild getestet werden, das zum Erstellen der Vorlage verwendet wurde. Für diese Tests können spezielle Teststapel eingesetzt werden, die nicht für die tatsächliche Verarbeitung von Dokumenten verwendet werden.
Testen von Dokumentvorlagen
Dokumentstapel

Bildimport

Automatische Zusammenstellung von Seiten in Dokumenten

Die eingehenden Bilder vom Scanner oder Hot Folder können automatisch in Dokumente untergliedert werden, und zwar durch:

  • mehrseitige Bildformate, z. B. TIFF oder PDF
  • leere Seiten sowie Seiten mit Barcodes oder Patchcodes
Hinzufügen von Seitenbildern
Optionen zur Bildvorverarbeitung
Bildimportprofile

Mithilfe von Bildimportprofilen können Gruppen vorkonfigurierter Einstellungen für unterschiedliche Importquellen von Dokumenten (Scanner oder Ordner) erstellt werden. Importprofile werden gespeichert und mit einem Namen versehen, unter dem sie anschließend in der entsprechenden Liste ausgewählt werden können.
Bildimportprofile

Import mit nur einem Klick

Der Importvorgang von Bildern entsprechend den Einstellungen des zuletzt verwendeten Profils kann mit nur einem Mausklick durchgeführt werden.
Hinzufügen von Seitenbildern

Import im Hintergrundmodus

Bilder können im Hintergrundmodus importiert werden. Im Hot Folder wird in bestimmten Zeitabständen überprüft, ob der Ordner neue Bilder enthält.

Hintergrundmodus

Einordnung, Vorlagenzuordnung und Erkennung

Volltexterkennung für den Export in durchsuchbare PDF-Dateien

ABBYY FlexiCapture 8.0 Professional unterstützt die Volltexterkennung in Dokumenten mit anschließendem Export in durchsuchbare PDF- und PDF\A-Dateien. Dies ist insbesondere beim Archivieren nicht strukturierter und teilweise strukturierter Dokumente sehr hilfreich.
Neue Erkennungssprachen

Kirgisisch (OCR/ICR)

Kasachisch (OCR/ICR)

Thai (OCR)

Unterstützte Erkennungssprachen
Neue Barcodetypen

Matrix 25, Industrial 25, PostNet

Unterstützte Barcodetypen
Position korrigierter Zeichen in statischen Formularen

Wenn ein versehentlich eingegebenes Zeichen gelöscht wurde, wird es bei der überprüfung angezeigt, sodass Sie das korrekte Zeichen manuell eingeben können.
Möglichkeit zum Entfernen von Trennseiten

Seiten mit Barcodes, Seiten mit Patchcodes und leere Seiten, die als Trennseiten verwendet werden, können automatisch aus dem Stapel entfernt werden.

Optionen zur Bildvorverarbeitung
Möglichkeit zum Entfernen von Leerseiten

Leerseiten können während der Erkennung entfernt werden.

Projekteigenschaften

Datenüberprüfung

Verbesserte überprüfungsoberfläche
  • Vollbildmodus
  • In der Statusleiste wird der aktuelle Prozentsatz überprüfter Zeichen angezeigt.
überprüfung erkannter Daten
Neue Optionen zur Konfiguration der Benutzeroberfläche
  • Die Position des Fensters mit dem Feldbild kann jetzt geändert werden.
  • Die Größe des Fensters kann geändert werden. Zudem kann mit einer neuen Funktion automatisch die optimale Größe ausgewählt werden.
  • Der Benutzer kann die Schriftgröße der Zeichen ändern.
überprüfung erkannter Daten
Verbesserte Gruppenüberprüfung
  • Anzeige eines Popupfelds mit dem Kontext der Zeichen
  • Konfigurierbare Größen- und Kontrasteinstellung des angrenzenden Bereichs der Zeichen
Gruppenüberprüfung
Verbesserte Feldüberprüfung
  • Formatregeln können nun bei der Feldüberprüfung geprüft werden. Dabei werden eine Fehlerbeschreibung und eine Liste mit änderungsvorschlägen für den Wert angezeigt.
  • Es gibt einen neuen Modus zum Anzeigen eines Felds mit Zeichenausschnitt.
  • Mehrzeilige Felder werden unterstützt.
  • Zum besseren Verständnis werden bei Zeichen Popupfelder angezeigt, z. B. der Buchstabe "O" und die Ziffer "0".
Feldüberprüfung
Direkte Felderkennung

Während der überprüfung im Dokumentfenster wird nach jeder änderung der Ränder eines Feldbereichs automatisch eine erneute Erkennung des entsprechenden Bildbereichs durchgeführt. Diese Funktion vereinfacht und beschleunigt die Extraktion der Daten aus Feldern mit ungenau angegebenen Bereichen.
Verbesserte Benutzeroberfläche zum Korrigieren von Regelfehlern
  • Jede Regel in der Liste der Regelfehler wird mit einem Verweis auf das entsprechende Feld angezeigt. Anhand dieser Verweise können Sie schnell zu den Feldern mit möglichen Fehlern wechseln.
  • Die Liste der Regelfehler kann oben, unten, rechts oder links im Dokumentfenster angedockt werden.
Regelbasierte Validierung
Korrektur von Zusammenstellungsfehlern in der Gliederungsansicht

Für Stapeldokumente steht jetzt eine neue Gliederungsansicht zur Verfügung. Dieser Modus eignet sich vor allem für die Korrektur von Zusammenstellungsfehlern. Dazu können in dieser Ansicht folgende Aktionen ausgeführt werden:

  • Anzeigen von nach Dokumenten zusammengefassten Seitengliederungen
  • Anzeigen der Unstimmigkeiten zwischen den Schlüsselfeldwerten und den Beschreibungen der Zusammenstellungsfehler
  • Korrigieren der Zusammenstellungsfehler durch Verschieben von Seiten zwischen den Dokumenten mit dem Mauszeiger
  • ändern der Größe der Seitengliederung für eine Detailansicht (durch Drehen des Scrollrads der Maus bei gedrückter Strg-Taste)
Zusammenstellen von Seiten in Dokumenten
Kennwortgeschützte PDF-Dateien können jetzt geöffnet werden

DjVu-Dateien können jetzt hinzugefügt werden
Unterstützte Grafikformate

Export

Export nach Microsoft SharePoint

Sie können jetzt mithilfe der Programmoberfläche den Export nach Microsoft SharePoint einrichten.

Exportieren von Daten in eine SharePoint-Dokumentbibliothek
Export mit nur einem Klick

Wenn Exporteinstellungen konfiguriert wurden, kann ein Dokumentstapel mit nur einem Klick auf eine Schaltfläche exportiert werden. Dadurch müssen keine weiteren Vorgänge durchgeführt werden, was wiederum die Dokumenteingabe beschleunigt.

Exportieren erkannter Daten
Exportieren von Dokumentbildern mit den Daten

Beim Export von Daten können Sie nun auch gleichzeitig die Bilder der entsprechenden Dokumente exportieren.

Hilfreiche Regeln für das Benennen von Ergebnisdateien

Wenn Daten in eine Datei nach Microsoft SharePoint exportiert werden, dann werden die Dateinamen automatisch auf der Grundlage benutzerdefinierter Regeln erzeugt. Sie können die Werte der Indexfelder, die Werte der Barcodes von Trennseiten usw. an Dateinamen anhängen. Aussagekräftige Dateinamen erleichtern das Auffinden gesuchter Informationen erheblich.
Regeln für das Benennen von Exportdateien

Neue Dokument- und Bildformate

Durchsuchbare PDF- und PDF/A-Dateien

Unterstützte Grafikformate
Verknüpfen von Feldern beim Export in eine Datenbank

Bei der Konfiguration des Exports von Daten in eine Datenbank können Felder praktischerweise verknüpft werden, sodass Dokumentfelder schnell Datenbankfeldern zugeordnet werden können.

Export in eine Datenbank
Export mithilfe eines Skripts

Benutzer können Exportprozeduren mit der Skriptsprache VBScript oder JScript beschreiben.

Export mithilfe eines Skripts
Beschreibung von Exportprozeduren mithilfe von Skripten
ändern der Bildauflösung beim Exportieren

Die Auflösung exportierter Bilder kann zum Speichern geändert werden.

Konfigurieren des Datenexports
Bildexport in eine Datei

Bilder gesamter Dokumente oder auch einzelne Bildfelder können jeweils in separate Grafikdateien exportiert werden.
Entfernen exportierter Dokumente aus einem Stapel

Wenn Sie exportierte Dokumente in einem Stapel nicht speichern möchten, können Sie sie unmittelbar nach dem Exportvorgang löschen.

Exportieren erkannter Daten
Zusätzliche Optionen


Unterstützte Dokumenttypen in ABBYY FlexiCapture 8.0

ABBYY FlexiCapture 8.0 Professional ist ein Softwaresystem, mit dem Daten aus unterschiedlich aufgebauten Dokumenten erfasst werden können.

Dabei können verschiedene Dokumenttypen in einem Durchgang verarbeitet werden. Sie können das Programm zudem so konfigurieren, dass Dokumente mit einer Kombination verschiedener Dokumenttypen, z. B. Dokumente mit strukturierten und teilweise strukturierten Bereichen, verarbeitet werden. Die einzelnen Dokumenttypen wirken sich lediglich auf die Systemkonfiguration und dabei vor allem auf die Erstellung von Dokumentvorlagen aus. Sie haben keinerlei Einfluss auf die Arbeit der Operatoren.

ABBYY FlexiCapture kann für die automatische Erfassung der folgenden Dokumente in einem Durchgang konfiguriert werden:

Strukturierte Dokumente (statische Formulare):
Strukturierte Dokumente verfügen über eine Reihe markierter Informationsfelder, deren Formatierung, Anzahl und Layout bei den verschiedenen Instanzen des Dokuments unverändert bleiben. Diese Dokumente werden auch als statische Formulare bezeichnet. Die meisten Fragebogen und Antragsformulare können als statische Formulare betrachtet werden. Derartige Formulare werden in der Regel als leere Formulare verteilt und dann von Hand ausgefüllt.

Um ein statisches Formular innerhalb eines Dokumentstapels erkennen und Daten aus solch einem Formular extrahieren zu können, müssen Sie ein einheitliches statisches Layout erstellen, auf dessen Grundlage das Programm die Felder erkennen kann, aus denen Daten zu extrahieren sind.

Am effektivsten lassen sich statische Formulare verarbeiten, die auf die Anforderungen der automatischen Datenerfassung ausgerichtet sind. Diese Formulare werden auch als maschinenlesbare Formulare bezeichnet. Weitere Informationen über Anforderungen dieser Formulare sowie Hinweise zu ihrer Erstellung finden Sie im Abschnitt Erstellen von maschinenlesbaren Formularen.

Ein besonders effizientes Programm zum Erstellen maschinenlesbarer Formulare ist ABBYY FormDesigner 8.0, das im Lieferumfang von ABBYY FlexiCapture 8.0 Professional enthalten ist. Hinweise zum Entwerfen von Formularen finden Sie im Benutzerhandbuch und in der Online-Hilfe von of ABBYY FormDesigner 8.0.

Darin werden die wichtigsten Schritte zum Erstellen einer Vorlage für strukturierte Dokumente beschrieben.
Teilweise strukturierte Dokumente (flexible Formulare):
Hierbei handelt es sich um Dokumente mit einer Reihe von Informationsfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Diese Dokumente werden auch als flexibel bezeichnet. Ein gutes Beispiel für flexible Dokumente sind Rechnungen, da bei ihnen die Anzahl und das Format der Datenfelder je nach Unternehmen unterschiedlich sein können Natürlich verfügen alle Rechnungen über eine Rechnungsnummer und einen Zahlbetrag, allerdings können sich diese Felder an sehr unterschiedlichen Stellen im Dokument befinden.

Um flexible Dokumente zu erkennen und Daten daraus zu extrahieren, werden in ABBYY FlexiCapture 8.0 Professional sogenannte FlexiLayouts verwendet. FlexiLayouts können mithilfe von ABBYY FlexiLayout Studio erstellt werden. Ausführliche Informationen über dieses Programm finden Sie im Benutzerhandbuch und in der Online-Hilfe.

Die Verarbeitung flexibler Dokumente unterscheidet sich von der Verarbeitung statischer Dokumente nur im Hinblick auf das Erstellen und Laden der Layouts. Ausführliche Informationen finden Sie unter Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente.
Nicht strukturierte Dokumente:
Mithilfe von ABBYY FlexiCapture 8.0 Professional können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Diagramme. Das Programm kann nicht strukturierte Dokumente automatisch als Anlagen statischer bzw. flexibler Dokumente erkennen. Die Erkennung ist auch mithilfe eines FlexiLayouts möglich. Die Dokumente werden dann als durchsuchbare PDF-Dateien oder als Grafikdateien exportiert. Indexfelder können aus nicht strukturierten Dokumenten sowohl automatisch (mithilfe eines FlexiLayouts) als auch durch manuelle Eingaben extrahiert werden.

Beispiele für die Verarbeitung nicht strukturierter Dokumente sind die übertragung eines Papierarchivs in ein elektronisches Format und das Extrahieren mehrerer Indexfelder für die anschließende Schnellsuche nach Attributen.

Nähere Informationen hierzu finden Sie unter Verarbeiten nicht strukturierter Dokumente.


Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture 8.0 Professional

In diesem Abschnitt finden Sie eine allgemeine übersicht über die Verarbeitung von Dokumenten mit ABBYY FlexiCapture 8.0 Professional.

Die Programmverwendung wird in den Abschnitten Konfigurieren des Programms und Arbeiten mit einem konfigurierten Projekt genauer beschrieben.

übersicht über die Konfiguration des Programms für die Dokumentverarbeitung
übersicht über die Arbeit mit einem konfigurierten Programm


Kurzbeschreibung der Programmeinstellungen für die Dokumentverarbeitung

Das Programm wird durch die Administratoren für die Verarbeitung bestimmter Dokumenttypen konfiguriert. Um das Programm auf die Dokumentverarbeitung vorzubereiten, muss Folgendes erstellt werden:

  1. Ein Projekt

    Ein Projekt enthält alle Einstellungen für das Verarbeiten eines bestimmten Dokumenttyps: Bildimportprofile, Dokumentvorlagen und Dokumentstapel für die Verarbeitung.

  2. Eine oder mehrere Dokumentvorlagen

    Der wichtigste Schritt beim Konfigurieren eines Projekts ist das Erstellen einer Vorlage. Wenn Sie die Verarbeitung unterschiedlicher Dokumenttypen auf einmal planen, müssen Sie in einem Projekt mehrere Vorlagen erstellen.

  3. Bildimportprofile

    Durch Importprofile wird die Arbeit der Operatoren vereinfacht und optimiert. Wenn keine Importprofile konfiguriert wurden, müssen Sie jedes Mal, wenn Sie Bilder hinzufügen, die Importquelle auswählen und die Einstellungen konfigurieren. Mit Importprofilen können Sie Bilder mit nur einem Mausklick auf eine Schaltfläche hinzufügen und sehr schnell zwischen Importquellen wechseln.

  4. Ein Dokumentstapel

    Die zur Verarbeitung gesendeten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde. Wenn Sie Bilder hinzufügen, für die keine Stapel vorhanden sind, wird automatisch ein Stapel erstellt.

Weitere Informationen zum Konfigurieren des Programms


Erstellen eines Projekts

Damit Sie unterschiedliche Dokumente in einem Projekt verarbeiten können, muss dieses über mehrere Vorlagen verfügen. Wenn sich die Dokumente nicht überschneiden und sich ihre Verarbeitungseinstellungen deutlich unterscheiden, können Sie auch getrennte Projekte erstellen.

Dazu müssen Sie zunächst mindestens ein Projekt erstellen.

Beim Ausführen des Programms wird das Dialogfeld Projekt öffnen angezeigt, in dem Sie eines der vorhandenen Projekte auswählen oder ein neues Projekt erstellen können, indem Sie auf Neues Projekt… klicken.

Wenn ABBYY FlexiCapture 8.0 Professional bereits ausgeführt wird und ein Projekt geöffnet wurde, wählen Sie zum Erstellen eines neuen Projekts die Menüoptionen Datei > Neues Projekt… aus.

Weitere Informationen zum Erstellen eines Projekts


übersicht über das Erstellen einer Dokumentvorlage

Die Erstellung von Vorlagen ist der entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

In einer Vorlage sind die Pfade von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben.

Zum Erstellen einer Vorlage starten Sie den Vorlagenassistenten wie folgt:

  1. Wählen Sie im Hauptmenü von ABBYY FlexiCapture 8.0 Professional die Optionen Projekt > Dokumentvorlagen… aus.
  2. Klicken Sie im Dialogfeld Dokumentvorlagen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Vorlagenassistenten.

Die einzelnen Schritte bei der Vorlagenerstellung hängen vom verarbeiteten Dokumenttyp ab.

Die wichtigsten Schritte beim Erstellen einer Vorlage für statische Formulare
  1. Erstellen Sie mit dem Vorlagenassistenten eine neue Dokumentvorlage. öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, mit der die Vorlage markiert wird.
  2. Markieren Sie die statischen Elemente (Anker und Objekte zur Identifizierung), und konfigurieren Sie ihre Eigenschaften. Statische Elemente werden zur Vorlagenzuordnung und -identifizierung verwendet. Normalerweise werden statische Elemente automatisch erkannt und Standardeigenschaften zugeordnet.
  3. Markieren Sie die Felder auf dem Bild. Felder werden für die Datenextraktion verwendet.
  4. Konfigurieren Sie die Feldeigenschaften. Feldeigenschaften beeinflussen die Erkennungsqualität und legen fest, ob die Werte der Felder exportiert und zur überprüfung an den Operator gesendet werden. Sie geben die Datentypen und den Wertebereich eines Felds an.
  5. Erstellen Sie Vorlagen für mehrseitige Dokumente: Fügen Sie Seiten hinzu, und wiederholen Sie sämtliche Schritte für alle Seiten.
  6. Konfigurieren Sie den Datenexport.
  7. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.
  8. Testen Sie eine Vorlage mithilfe der Bilder verschiedener Dokumente.

Hinweis: Wenn Sie mit ABBYY FormDesigner maschinenlesbare Formulare erstellt haben, müssen Sie anstelle der ersten drei Schritte lediglich eine Datei mit der Dateinamenerweiterung *.xfd importieren. Daraufhin wird ein Seitenbild mit vorbereiteter Markierung geöffnet (bzw. Bilder mehrerer Seiten, wenn Sie mit ABBYY FormDesigner ein mehrseitiges Formular erstellt haben). Einzelheiten finden Sie unter Importieren einer Vorlage für mit ABBYY FormDesigner erstellte Formulare.

Die wichtigsten Schritte beim Erstellen einer Vorlage für flexible Dokumente
  1. Erstellen Sie mit ABBYY FlexiLayout Studio ein FlexiLayout (eine Datei mit der Dateinamenerweiterung *.afl). Einzelheiten finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.
  2. Erstellen Sie mit dem Vorlagenassistenten eine neue Dokumentvorlage. öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, und fügen Sie ein FlexiLayout an (die von Ihnen erstellte AFL-Datei). Nach Abschluss des Assistenten werden auf dem Bild die Feldmarkierungen angezeigt.
  3. Konfigurieren Sie die Feldeigenschaften. Befolgen Sie dabei die Schritte für das Konfigurieren der Vorlageneigenschaften für ein statisches Formular.
  4. Konfigurieren Sie den Datenexport.
  5. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.
  6. Testen Sie eine Vorlage mithilfe der Bilder verschiedener Dokumente.

Bei kombinierten Dokumenttypen, die Seiten mit statischen Formularen und teilweise strukturierte Bereiche enthalten, können Sie als einen der Vorlagenbereiche ein FlexiLayout anfügen. Erstellen Sie zunächst eine Vorlage für einen der Bereiche (flexibel oder statisch), und fügen Sie dann einen neuen Bereich eines anderen Typs hinzu.

Sie können in einem Durchgang Dokumente unterschiedlichen Typs verarbeiten: Sie können als Teil desselben Projekts sowohl Vorlagen für statische Formulare und flexible Dokumente als auch Vorlagen für kombinierte Dokumenttypen erstellen. Das Programm wählt dann automatisch eine Vorlage aus.

Für die Verarbeitung von Dokumenten mit Anhängen erstellen Sie eine Dokumentvorlage und aktivieren dann in den Vorlageneigenschaften die Option Anhangseiten berücksichtigen. Weitere Informationen finden Sie unter Erstellen von Vorlagen für Dokumente mit Anhängen.

Weitere Informationen zum Erstellen von Vorlagen


Erstellen von Importprofilen

Der Operator beginnt damit, dem Projekt neue Bilder hinzuzufügen: Dabei kann es sich um Papierdokumente handeln, die gescannt werden müssen, oder um vorhandene elektronische Bilder.

Häufig wiederholte Aktionen oder das Hinzufügen von Bildern aus derselben Quelle können automatisiert werden, damit der Import mit nur einem Mausklick auf eine Schaltfläche durchgeführt werden kann. Erstellen Sie dazu ein Bildimportprofil. Sie können darüber hinaus auch noch die Verarbeitung eingehender Bilder und das regelmäßige Hinzufügen von Bildern im Hintergrund konfigurieren. Nach dem Festlegen der erforderlichen Einstellungen können die Bilder mit nur einem Mausklick auf eine Schaltfläche gescannt oder aus einer zuvor definierten Quelle importiert und verarbeitet werden (z. B. das Entfernen von Störungen). Sie können bei Bedarf die Quelle für den Bildimport oder die Einstellungen ändern.

Werden die Importquellen häufig geändert, können Sie mehrere Importprofile erstellen und zwischen diesen wechseln, sodass Sie nicht jedes Mal die Einstellungen für die Importquelle ändern müssen.

Wählen Sie zum Hinzufügen eines Importprofils im Hauptfenster des Programms die Menüoption Projekt > Bildimportprofile… aus. Im daraufhin geöffneten Dialogfeld können Sie Importprofile erstellen, bearbeiten, löschen und kopieren.

Weitere Informationen zum Erstellen von Importprofilen


Erstellen von Dokumentstapeln

Die zur Verarbeitung gesendeten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde.

Wenn ein Projekt keine Stapel enthält, wird beim Hinzufügen von Bildern automatisch ein Stapel erstellt.

Wenn Sie einen neuen Stapel erstellen möchten, klicken Sie mit der rechten Maustaste in das Hauptfenster, und wählen Sie im Kontextmenü mit der Liste der Stapel die Option Neuer Stapel aus.

Weitere Informationen über das Erstellen von Dokumentstapeln


übersicht über die Arbeit von Operatoren mit einem konfigurierten Programm

Die Operatoren verwenden ein Programm, dass für die Verarbeitung bestimmter Dokumenttypen vorkonfiguriert wurde. Die Dokumentverarbeitung ist bei allen Dokumenttypen gleich und umfasst folgende Schritte:

  1. Hinzufügen von Bildern

    Sie können das Hinzufügen von Bildern der Dokumentseiten durch das Konfigurieren von Importprofilen deutlich vereinfachen. Außerdem können Sie Bilder hinzufügen, indem Sie diese scannen oder aus Dateien laden.

  2. Starten des Erkennungsvorgangs

    Die Erkennung läuft automatisch ab: Das Programm erkennt die Dokumentvorlage anhand der Position der statischen Elemente, die in der Vorlage vorkonfiguriert wurden, und wendet die Vorlage an, um die Daten in den in der Vorlage angegebenen Feldern zu erkennen. Vor dem Starten der Erkennung können Sie die Dokumente oder ihre Seiten analysieren und dem Bild eine entsprechende Vorlage zuordnen.

  3. überprüfung

    Die überprüfung der Daten ist der aufwändigste Teil der Arbeit von Operatoren. Er umfasst Folgendes:

    • überprüfung der Dokumentzusammenstellung – überprüfung der richtigen Zusammenstellung der Dokumentseiten
    • Gruppenüberprüfung – visuelle überprüfung von Gruppen von als gleich erkannten Zeichen
    • Feldüberprüfung – überprüfung von nicht eindeutig erkannten Zeichen im Kontext von Feldern mit einem bekannten Wertebereich
    • Regelbasierte Validierung – überprüfung auf Regelfehler

  4. Datenexport

    Der Export wird durch Klicken auf eine Schaltfläche entsprechend den Exporteinstellungen in der Vorlage durchgeführt. Sie können die Daten auch in eine Datei oder Datenbank exportieren, ohne die Exporteinstellungen einer Vorlage zu verwenden.

Weitere Informationen über die Arbeit von Operatoren mit konfigurierten Projekten


Hinzufügen von Bildern

Wählen Sie zum Hinzufügen von Bildern den entsprechenden Stapel aus, oder erstellen Sie einen neuen Stapel. über die Importschaltfläche können Sie Bilder auf verschiedene Weise importieren. Der Name der Schaltfläche ändert sich je nach ausgewählter Importmethode.

Sofern im Projekt Importprofile konfiguriert wurden, werden ihre Namen als Einträge im Menü der Importschaltfläche angezeigt. Um einen Import zu starten, müssen Sie lediglich eine Option auswählen.

Zum Laden von Bildern aus einer Datei klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche und wählen Bilder laden… aus. Wählen Sie Dateien mit Bildern aus, konfigurieren Sie die erforderlichen Optionen, und führen Sie den Import durch.

Zum Hinzufügen von Bildern von einem Scanner klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche und wählen Bilder scannen… aus.

Nachdem Sie im Menü Bilder importieren… ausgewählt haben, können Sie ein vorhandenes Bildimportprofil auswählen, um den Import zu starten, ein neues Profil erstellen oder ein vorhandenes Profil bearbeiten.

Weitere Informationen zum Hinzufügen von Bildern


Starten der Erkennung und Analysieren und Zuordnen einer Vorlage

Zum Starten der Erkennung klicken Sie auf Erkennen.

Wenn Sie zuvor eine Analyse der Bilder durchführen möchten, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen und wählen Vorlage zuordnen… aus. Wenn eine Vorlage zugeordnet werden kann, werden die Seite und das Dokument entsprechend benannt. Kann dem Bild keine der Projektvorlagen zugeordnet werden, wird die Seite nicht verarbeitet.

Sie können einer Seite oder einem vollständigen Dokument auch eine bestimmte Vorlage zuordnen. In den meisten Fällen ordnet das Programm den Seiten automatisch eine Vorlage zu, sofern diese ordnungsgemäß erstellt wurde. In einigen Fällen müssen Sie die Vorlage aber möglicherweise manuell zuordnen. Um eine Vorlage anzuwenden, markieren Sie ein Dokument oder eine Seite. Klicken Sie anschließend auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen, und klicken Sie dann auf Vorlage zuordnen….

Weitere Informationen über die Erkennung


überprüfung

Klicken Sie zum Starten des überprüfungsvorgangs auf Überprüfung ausführen…. Der Vorgang beginnt bei der Gruppenüberprüfung gefolgt von der Feldüberprüfung. Wenn eine Vorlage über keine Felder verfügt, die in die Gruppen- oder Feldüberprüfung einbezogen werden, wird der entsprechende überprüfungsschritt ausgelassen.

Bei mehrseitigen Dokumenten müssen Sie möglicherweise auch Zusammenstellungsfehler im Dokument korrigieren. Die Seiten werden automatisch in Dokumenten zusammengestellt. Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Eine Beschreibung des Fehlers finden Sie in roten Buchstaben unter dem Namen der Dokumentvorlage. Sie müssen beim Erstellen von Dokumentvorlagen eine Regel für die Dokumentzusammenstellung definieren. Diese umfasst Festlegungen zur Reihenfolge und Anzahl der Seitenwiederholungen. Außerdem können Sie die überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren: dabei müssen die Werte von Schlüsselfeldern auf sämtlichen Seiten des Dokuments gleich sein. Bei Abweichungen wird eine entsprechende Meldung angezeigt, und die Werte der Schlüsselfelder werden rot hervorgehoben. Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt.

Bei der Gruppenüberprüfung werden Gruppen von als gleich erkannten Zeichen für die überprüfung übermittelt. Der Operator muss dann abweichende Zeichen bestimmen, die falsch erkannt wurden. Nachdem der Operator das Feld mit diesem Zeichen angezeigt hat, kann er seine Werte berichtigen. Wenn ein Zeichen nicht korrigiert werden kann, können Sie es als nicht eindeutig markieren.

Bei der Feldüberprüfung werden Felder mit einem bekannten Wertebereich zur überprüfung übermittelt. Der Operator muss dann nicht eindeutig erkannte Zeichen im Kontext des vollständigen Felds überprüfen. Die Feldüberprüfung kann in zwei Modi durchgeführt werden: in der Einzelfeldansicht mit Zeichenausschnitten und in der Ansicht mehrerer gleichartiger Felder.

Nicht eingehaltene Regeln werden durch eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet. Der Operator muss Felder mit Regelfehlern überprüfen und ggf. korrigieren. Um die Regelfehler zu überprüfen, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche und wählen die Menüoption Regeln erneut überprüfen aus. Werden die Regeln nach der Korrektur der Feldwerte erfüllt, werden die Markierungen entfernt.

Die Datenüberprüfung kann auch im Dokumentfenster durchgeführt werden, das Sie durch Doppelklicken auf den Namen eines Dokuments oder einer Seite öffnen. Im Dokumentfenster werden nicht einzelne Felder, sondern das gesamte Dokument angezeigt. Außerdem enthält es alle nicht eindeutig erkannten Zeichen, Regelfehler usw.

Weitere Informationen über die überprüfung


Export

Zum Exportieren erkannter und überprüfter Dokumente klicken Sie auf Exportieren. Der Export wird anhand der Einstellungen in der Dokumentvorlage durchgeführt.

Wenn Sie einen Export in eine Datei durchführen möchten, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche und wählen In Datei exportieren… aus.

Wenn der Export in eine Datenbank erfolgen soll, wählen Sie stattdessen In Datenbank exportieren… aus.

ändern Sie ggf. die Exporteinstellungen, und führen Sie den Export durch.

Weitere Informationen über das Exportieren


Installieren und Ausführen des Programms

Dieser Abschnitt enthält grundlegende Informationen zum Installieren, Schützen und Ausführen von ABBYY FlexiCapture 8.0 Professional. Außerdem enthält er die Systemanforderungen für die Installation.

Programmschutz
Lizenzmanager für die Dongleverwaltung
Software- und Hardwareanforderungen
Installieren von ABBYY FlexiCapture 8.0 Professional
Ausführen der Software


Schutztypen

Für die Installation und Verwendung von ABBYY FlexiCapture 8.0 Professional ist ein gültiger Lizenzschlüssel erforderlich.

ABBYY FlexiCapture 8.0 Professional kann einen der beiden folgenden Typen von Lizenzschlüsseln enthalten:

  • Dongle
  • Softwareschlüssel

Dongle

Der Dongle wird an einen USB-Anschluss des Computers (USB-Dongle) angeschlossen.

Um ABBYY FlexiCapture 8.0 Professional mit einem Dongle ausführen zu können, müssen Sie den zugehörigen Treiber mit dem Installationsprogramm installieren. Für die Verwendung der Software muss der Dongle jederzeit angeschlossen sein.

Auf dem Dongle sind die Parameter Ihrer Lizenz gespeichert.

Sie können einen leeren Dongle per Fernzugriff aktivieren, wofür lediglich die Seriennummer der Lizenz erforderlich ist. Starten Sie einfach das Programm DongleUpdate (DongleUpdate.FlexiCapture.exe), klicken Sie auf die Schaltfläche Neue Lizenz, und geben Sie die Seriennummer ein. Das Programm stellt über das Internet eine Verbindung mit dem Aktivierungsserver her, fragt die Parameter zu der Seriennummer ab und schreibt diese auf den Dongle.

Wichtig: Für die Verwendung eines Dongles muss der Standarddienst für SmartCards ausgeführt werden.

Softwareschlüssel

Dies ist eine Lizenzdatei.

Wenn Sie ABBYY FlexiCapture 8.0 Professional mit einem Softwareschlüssel ausführen möchten, muss die Lizenzdatei auf dem Aktivierungsserver von ABBYY aktiviert werden. Sie können die Lizenzdatei über das Installationsprogramm oder mit dem Lizenzmanager aktivieren.

Die für das Aktivieren der Lizenz erforderlichen Informationen werden kodiert (Produkt-ID) an ABBYY gesendet, wobei der Code auf Informationen über den Computer beruht, auf dem ABBYY FlexiCapture 8.0 Professional installiert ist. Für die Generierung einer Produkt-ID werden keine persönlichen Informationen verwendet, auch ist es nicht möglich, mit diesem Code einen Benutzer zu identifizieren.

Aktivierungsmethoden:

  • über das Internet
    Die Aktivierung erfolgt automatisch über das Internet und dauert nur wenige Sekunden. Sie benötigen für diese Methode eine funktionierende Internetverbindung.
  • Per E-Mail
    Bei dieser Aktivierungsmethode wird automatisch eine E-Mail mit einer Aktivierungsanfrage erstellt. Senden Sie diese E-Mail-Nachricht an die angegebene Adresse. Damit das automatische E-Mail-Programm direkt antworten kann, dürfen Sie weder den Betreff noch den Text der E-Mail ändern.

Bei der Aktivierung über das Internet sind keine weiteren Schritte erforderlich. Bei der Aktivierung per E-Mail wird Ihnen vom Aktivierungsprogramm eine Aktivierungsdatei zugesendet. Speichern Sie diese Datei auf Ihrer Festplatte, führen Sie den Lizenzmanager oder den Aktivierungsassistenten aus, und geben Sie den Pfad zu der gespeicherten Datei an.

Wiederholen der Aktivierung

Sie können ABBYY FlexiCapture 8.0 Professional beliebig oft neu auf dem Computer installieren, auf dem die Software aktiviert wurde. Wenn Sie jedoch grundlegende änderungen vornehmen, die Festplatte formatieren oder das Betriebssystem neu installieren, müssen Sie die Software möglicherweise erneut aktivieren.

Der Aktivierungsserver speichert ein Protokoll mit der Anzahl der Aktivierungen der einzelnen Seriennummern. Wenn ein bestimmter Schwellenwert überschritten wurde, wird die Seriennummer gesperrt und kann nicht mehr verwendet werden.

Sie können Lizenzen deaktivieren und wieder aktivieren, um sie auf einem anderen Computer zu verwenden. Wenn Sie eine Lizenz deaktivieren, verringert der Aktivierungsserver den Aktivierungszähler für diese Lizenz um eins.

Wichtig: Sie können das aktivierte Programm nur auf dem Computer verwenden, auf dem die Produkt-ID generiert wurde. Wenn Sie die Software auf einem anderen Computer verwenden möchten, müssen Sie die Lizenz zunächst deaktivieren.


Lizenzmanager

Mit dem Lizenzmanager werden die Dongle verwaltet und Informationen über den Status von ABBYY FlexiCapture-Lizenzen gesammelt.

Wichtig: Der Lizenzmanager ist ein Administratorprogramm. Zur Verwendung des Lizenzmanagers benötigen Sie lokale Administratorrechte.

Der Lizenzmanager wird auf folgenden Computern installiert:

  • auf dem Computer mit ABBYY FlexiCapture 8.0 Professional (lokale Installation) oder
  • auf dem Server mit ABBYY FlexiCapture 8.0 Professional (Netzwerkinstallation)

So starten Sie den Lizenzmanager:

  • Zeigen Sie auf Start > Programme > ABBYY FlexiCapture 8 > Extras, und wählen Sie ABBYY FlexiCapture 8.0 Professional Lizenzmanager aus.

Verwalten von Lizenzen

Hinzufügen einer neuer Lizenz

Klicken Sie zum Hinzufügen einer neuen Lizenz im Hauptfenster des Lizenzmanagers auf die Schaltfläche Neue Lizenz hinzufügen.... Geben Sie im daraufhin geöffneten Dialogfeld eine neue Seriennummer ein, und klicken Sie auf Hinzufügen. Sie können auch auf Aus Datei... klicken und die Textdatei mit den Seriennummern auswählen.

Die neuen Lizenzen werden im Hauptfenster des Lizenzmanagers angezeigt.

Aktivieren einer Lizenz

Nachdem Sie eine Lizenz hinzugefügt haben, müssen Sie diese aktivieren. Klicken Sie auf die Schaltfläche Lizenz aktivieren..., um eine zuvor hinzugefügte Lizenz zu aktivieren. Sie können Ihre Lizenzen über das Internet (empfohlen) oder per E-Mail aktivieren. Folgen Sie den Anweisungen des Aktivierungsassistenten.

Aktualisieren einer Lizenz

Um eine Lizenz zu aktualisieren, wählen Sie sie im Fenster des Lizenzmanagers aus und klicken auf die Schaltfläche Lizenz aktualisieren.... Eine Aktivierung über Internet oder per E-Mail ist ebenfalls erforderlich. Folgen Sie den Anweisungen des Aktivierungsassistenten.

Lizenzparameter

Sie können im Lizenzmanager auch die Lizenzparameter überprüfen. Wählen Sie die Lizenz aus, deren Parameter Sie anzeigen möchten, und klicken Sie auf Lizenzeigenschaften....


Lizenztypen und -parameter

Lizenzparameter

Jede Lizenz verfügt über eine eigene Seriennummer und enthält einen Satz von Parametern. Der Satz von Lizenzparametern legt fest, welche Produktfunktionen verwendet werden dürfen.

Es gibt zwei Arten von Lizenzen:

  • Die Volllizenz erlaubt die Ausführung der Administratorstation und aller Tools (FormDesigner und FlexiLayout Studio). Sofern keine freien Operatorlizenzen zur Verfügung stehen, erlaubt diese Lizenz auch die Ausführung der Operatorstation.
  • Die Operatorlizenz ermöglicht die Ausführung der Operatorstation.

Lizenzen geben immer an, wie viele Administrator- und Operatorstations gleichzeitig ausgeführt werden dürfen. Die Parameter 2 Vollversionen und 5 Operatorlizenzen geben beispielsweise an, dass gleichzeitig zwei Administratorstations (auf unterschiedlichen Computern oder auf demselben Computer durch unterschiedliche Benutzer) und fünf Operatorstations ausgeführt werden dürfen.

Wenn auf einem Computer mehrere Instanzen der Software mit denselben Anmeldeinformationen gestartet werden, wird nur eine Lizenz verwendet. Wenn bereits 5 Operatorlizenzen verwendet werden, wird zum Starten einer weiteren Operatorstation die Volllizenz verwendet.

Lizenzparameter:

  • Ablaufdatum: Gibt an, wann die Lizenz abläuft
  • Seitenbeschränkung: Gibt an, wie viele Seiten innerhalb eines bestimmten Zeitraums erkannt werden dürfen
  • öffnen von PDF-Dateien: Gibt an, ob das öffnen von PDF-Dokumenten erlaubt ist
  • Durchsuchbare PDF: Gibt an, ob das Exportieren von Daten in PDF-Dateien mit einer Funktion für die Volltextsuche zulässig ist
  • FlexiLayouts: Gibt an, ob die Verwendung flexibler Templates (FlexiLayouts) erlaubt ist
  • Maximale Anzahl von Feldern: Gibt die maximal zulässige Anzahl von Feldern in einer Dokumentvorlage an
  • FlexiLayout Studio: Gibt an, ob die Ausführung von FlexiLayout Studio zulässig ist
  • FormDesigner: Gibt an, ob FormDesigner ausgeführt werden darf


Software- und Hardwareanforderungen

  1. PC mit Intel® Pentium®-/Celeron®-/Xeon™-/Athlon™-/Duron™-/Sempron™-Prozessor oder kompatiblem Prozessor,
    • 500 MHz oder höher (2 GHz oder höher empfohlen) - für Microsoft Windows Vista;
    • 350 MHz oder höher (2 GHz oder höher empfohlen) - für Windows 2000/XP/2003.
  2. Betriebssystem:
    • Microsoft ® Windows Vista™;
    • Microsoft Windows Server 2003;
    • Microsoft Windows XP Service Pack 2 oder höher;
    • Microsoft Windows 2000 Service Pack 3 oder höher;
    • Microsoft Windows Server 2000 Service Pack 3 oder höher.

    Damit das Programm mit einer lokalisierten Benutzeroberfläche ausgeführt werden kann, muss das Betriebssystem die gewünschte Sprache unterstützen.

  3. RAM:
    • 512 MB (minimal)/1024 MB (empfohlen) - für Windows Vista;
    • 128 MB (minimal)/512 MB (empfohlen) - für Windows ХР/2003;

    In einem Mehrprozessorsystem werden zusätzlich 16 MB RAM für jeden weiteren Prozessor benötigt.

  4. Freier Speicherplatz auf der Festplatte: 420 MB für die Minimalkonfiguration (nur Operatorstation), 450 MB für die Standardinstallation (Operator- und Administratorstations, FlexiLayout und FormDesigner) und 200 MB für die Programmausführung (1 GB empfohlen).
  5. Scanner mit TWAIN- oder ISIS-Unterstützung.
  6. Eine Internetverbindung für die Aktivierung der Seriennummer (bei Verwendung eines Softwareschlüssels) bzw. einen USB-Anschluss (bei Verwendung eines Dongles).
  7. Grafikkarte und Monitor mit Mindestauflösung 800 x 600.
  8. Tastatur, Maus oder anderes Zeigegerät.


Installieren von ABBYY FlexiCapture 8.0 Professional

Schließen Sie vor der Installation von ABBYY FlexiCapture 8.0 Professional alle anderen Anwendungen (z. B. Microsoft Outlook oder Microsoft Word).

So installieren Sie ABBYY FlexiCapture 8.0 Professional:

  1. Legen Sie die CD-ROM für ABBYY FlexiCapture 8.0 Professional in das CD-ROM-Laufwerk ein.
  2. Wählen Sie im Autorun-Menü die Option Lokale Installation aus, und befolgen Sie die Anweisungen im Installationsprogramm. (Wenn die Autorun-Funktion auf Ihrem Computer deaktiviert ist, doppelklicken Sie auf die Datei setup.exe auf der CD-ROM.)
  3. Wählen Sie eine Installationssprache aus (Englisch oder Deutsch). Im Installationsprogramm wird das Gebietsschema Ihres Computers mit der ausgewählten Sprache verglichen. Wenn die Sprachen nicht kompatibel sind, wird eine Warnmeldung angezeigt.
  4. Anschließend werden die Version des Betriebssystems und die Verfügbarkeit der administrativen Berechtigungen überprüft. Wenn die Version des Betriebssystems nicht unterstützt wird oder Sie über keine administrativen Berechtigungen verfügen, wird eine Warnmeldung angezeigt und das Installationsprogramm beendet.
  5. Wenn alle überprüfungen erfolgreich abgeschlossen wurden, wird der Endbenutzer-Lizenzvertrag angezeigt. Lesen Sie den Lizenzvertrag sorgfältig durch, und aktivieren Sie die entsprechende Option, wenn Sie den Vertragsbedingungen zustimmen. Klicken Sie anschließend auf Weiter.
  6. Im daraufhin geöffneten Dialogfeld werden Sie aufgefordert, einige Angaben zu Ihrer Person zu machen. Geben Sie die erforderlichen Informationen ein, und setzen Sie den Installationsvorgang fort.
  7. Wählen Sie im nächsten geöffneten Dialogfeld eine der verfügbaren Installationsmethoden aus:
    • Vollversion – Das Programm wird vollständig installiert. Sie können zwischen dem Administrator- und dem Operatormodus wechseln sowie FormDesigner 8.0 und FlexiLayout Studio 8.0 verwenden.
    • Operatorstation – Es wird nur die Operatorversion installiert. (Die Administratorstation, FormDesigner 8.0 und FlexiLayout Studio 8.0 werden nicht installiert.)
  8. Wählen Sie dann einen Zielordner aus. In der Standardeinstellung wird das Programm im folgenden Verzeichnis installiert: <Laufwerksbezeichnung>:\Programme\ABBYY FlexiCapture 8.0 Professional. Wenn auf der ausgewählten Festplatte nicht genügend Speicherplatz zur Verfügung steht, wird ein Fenster geöffnet, in dem alle Festplatten, der jeweils verfügbare Speicherplatz und der für die Installation erforderliche Speicherplatz angezeigt werden. Wählen Sie eine Festplatte mit ausreichend freiem Speicherplatz aus, und setzen Sie den Installationsvorgang fort.
  9. Die Programmdateien werden auf den Computer kopiert. Nach Abschluss der Installation wird in einer Meldung angezeigt, dass die Anwendung erfolgreich installiert wurde.
  10. FlexiCapture 8.0 Professional Lizenzmanager wird automatisch gestartet, sodass Sie die Anwendung aktivieren können. Geben Sie Ihre Seriennummer ein, und aktivieren Sie die Anwendung.


Installieren von ABBYY FlexiCapture 8.0 Professional in einem lokalen Netzwerk

ABBYY FlexiCapture 8.0 Professional kann in einem lokalen Netzwerk installiert und verwendet werden.

Um die Software in einem Netzwerk zu installieren, wählen Sie im Autorun-Menü die Option Netzwerkinstallation aus, und befolgen Sie die Anweisungen im Installationsprogramm.

Mithilfe der Netzwerkinstallation können Sie ABBYY FlexiCapture 8.0 Professional auf mehreren Computern bereitstellen. Die Netzwerkinstallation erfolgt in zwei Schritten. Zuerst werden der Lizenzmanager und der Lizenzschlüssel auf einem der Computer im LAN (dem Server) installiert. Bei Bedarf kann auch die gesamte Software von ABBYY FlexiCapture 8.0 Professional auf den Server kopiert werden. Im zweiten Schritt wird ABBYY FlexiCapture 8.0 Professional auf den LAN-Workstations installiert.

Weitere Informationen zum Installieren der Software in einem lokalen Netzwerk finden Sie im Handbuch für Systemadministratoren, das ebenfalls im Autorun-Menü verfügbar ist.


ändern des Installationsverfahrens, Reparieren und Deinstallieren von ABBYY FlexiCapture 8.0 Professional

So ändern Sie das Installationsverfahren (wählen Sie entweder die vollständige Installation oder die Operatorstation aus):

  1. Zeigen Sie auf Start > Systemsteuerung > Software, wählen Sie in der Liste der installierten Programme ABBYY FlexiCapture 8.0 Professional aus, und klicken Sie dann auf ändern.

  2. Wählen Sie ändern aus, und klicken Sie auf Weiter.

  3. Wählen Sie im angezeigten Dialogfeld das gewünschte Installationsverfahren aus.

So reparieren Sie beschädigte oder gelöschte Dateien:

  1. Zeigen Sie auf Start > Systemsteuerung > Software, wählen Sie in der Liste der installierten Programme ABBYY FlexiCapture 8.0 Professional aus, und klicken Sie dann auf ändern.

  2. Wählen Sie Reparieren aus, und klicken Sie auf Weiter.

So entfernen Sie ABBYY FlexiCapture 8.0 Professional vom Computer:

  1. Zeigen Sie auf Start > Systemsteuerung > Software, wählen Sie in der Liste der installierten Programme ABBYY FlexiCapture 8.0 Professional aus, und klicken Sie dann auf Entfernen.

  2. Bestätigen Sie, dass das Programm entfernt werden soll.


Ausführen der Software

So starten Sie ABBYY FlexiCapture 8.0 Professional:

  • In Administratormodus: Zeigen Sie auf Start > Programme > ABBYY FlexiCapture 8.0, und wählen Sie ABBYY FlexiCapture 8.0 Professional > Administrator Station.
  • Im Operatormodus: Zeigen Sie auf Start>Programme>ABBYY FlexiCapture 8.0, und wählen Sie ABBYY FlexiCapture 8.0 Professional > Operator Station.

Wichtig: Stellen Sie vor dem Programmstart Folgendes sicher:

  • Prüfen Sie, ob der Scanner eingeschaltet und mit dem Rechner verbunden ist.
    Wenn der Scanner nicht angeschlossen ist, lesen Sie im Handbuch des Scanners nach.
    Damit der Scanner ordnungsgemäß funktioniert, muss er vor dem Computer eingeschaltet werden.
  • Auf dem Computer wurde ein Lizenzschlüssel installiert. Sie können die Software nur mit diesem Schlüssel ausführen.

Registrierungsschlüssel, die den Anwendungsstart steuern

Sie können die folgenden Registrierungsschlüssel (unter Shell\StartUp) verwenden, um den Start der Anwendung zu steuern:

  • AdminMode: Legt fest, ob die Anwendung im Operatormodus oder im Administratormodus gestartet wird

  • Project: Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird

  • Batch: Bestimmt den Stapel, der beim Start der Anwendung automatisch geöffnet wird (der Stapel muss angegeben werden)

  • ProhibitChangePath: Unterbindet das Ändern von Stapel und Projekt, die automatisch im Operatormodus geöffnet werden (setzen Sie den Schlüsselwert dazu auf „True“)

Diese Schlüssel werden nicht standardmäßig in der Registrierung erstellt. Falls erforderlich, kann der Administrator diese Schlüssel zur Registrierung des Benutzerbetriebssystems hinzufügen.

Die Registrierungsschlüssel können von den entsprechenden Startparametern in der Befehlszeile überschrieben werden.

Befehlszeilen-Startparameter

Die folgenden Parameter können beim Aufruf der Anwendung über die Befehlszeile verwendet werden:

FlexiCapture.exe [/Station:(Admin,Operator)] [/Project:"Projektpfad"] [/Batch:"Stapelname"] [/ProhibitChangePath].

  • [/Station:(Admin,Operator)]: Legt fest, ob die Anwendung im Operatormodus oder im Administratormodus gestartet wird. Ist kein Modus angegeben, wird beim Anwendungsstart ein Dialogfeld angezeigt, in dem der Benutzer aufgefordert wird, den gewünschten Modus auszuwählen.

  • [/Project:"path to project"]: Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird

  • [/Batch:"batch name"]: Legt den Stapel fest, der beim Start der Anwendung automatisch geöffnet wird

  • [/ProhibitChangePath]: Unterbindet das Ändern von Stapel und Projekt, die automatisch im Operatormodus geöffnet werden


Verwenden von Vorlagen, die mit älteren Versionen von ABBYY FormReader erstellt wurden

Vorlagen, die in ABBYY FormReader 6.5 und 6.0 erstellt wurden, können in ABBYY FlexiCapture 8.0 Professional importiert werden.

Wenn Sie eine Vorlage importieren, die mit einer älteren Version erstellt wurde, werden die Seitenmarkierungen (mit Ausnahme der Dienstfelder) und die Datentypen importiert. Die Datentypen werden in den Ordner Benutzerdefiniert der Dokumentvorlage kopiert. Weitere Informationen finden Sie unter Datentypen für Texteingabefelder.

Wichtig: Exporteinstellungen, überprüfungsregeln und Bilder aus dem Stapel werden nicht importiert.

So importieren Sie eine in ABBYY FormReader 6.5 oder 6.0 erstellte Vorlage:

  1. Starten Sie ABBYY FlexiCapture 8.0 Professional im Administratormodus.
  2. Erstellen Sie ein neues Projekt, oder öffnen Sie ein vorhandenes Projekt, in das Sie eine Vorlage importieren möchten, die mit einer älteren Programmversion erstellt wurde.
  3. Wählen Sie im Hauptmenü Projekt > Dokumentvorlagen… aus.
  4. Klicken Sie im Dialogfeld Dokumentvorlagen auf Importieren….
  5. Wählen Sie aus der Dropdownliste Dateityp FormReader 6.5-Stapel (*.frm) aus, und wählen Sie dann den Stapel aus, dessen Vorlagen Sie importieren möchten.

Die importierte Vorlage wird der Vorlagenliste hinzugefügt. Wenn der Stapel mehrere Listen enthält, werden alle Vorlagen importiert. Wenn Sie in ABBYY FormReader 6.5 eine Struktur für mehrseitige Dokumente ausgewählt haben, werden die durch diese Struktur beschriebenen Vorlagen in einer mehrseitigen Vorlage zusammengeführt.

Tipps:
  1. Einzelheiten zu den Unterschieden zwischen den Regeln der beiden Versionen finden Sie unter Vergleich von Regeln in FormReader 6.5 und FlexiCapture 8.0 Professional.
  2. Empfehlungen zur Migration von If-Then-Regeln, Automatisierungsregeln und Automatisierungsexports aus FormReader 6.5 in FlexiCapture 8.0-Skripte finden Sie unter Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture 8.0 Professional-Skripte.


Benutzeroberfläche von ABBYY FlexiCapture 8.0 Professional

In diesem Abschnitt finden Sie eine übersicht über die Hauptelemente der Benutzeroberfläche von ABBYY FlexiCapture 8.0 Professional, d. h. die Hauptfenster, Menüs und Symbolleisten.

Hauptfenster des Programms
Menü des Hauptfensters
Symbolleisten im Hauptfenster
Dokumentvorlageneditor
Menü des Dokumentvorlageneditors
Symbolleisten im Dokumentvorlageneditor
Fenster für die Gruppenüberprüfung
Menü
Symbolleiste
Fenster für die Feldüberprüfung
Menü
Symbolleiste


Hauptfenster von ABBYY FlexiCapture 8.0 Professional

Im Hauptfenster des Programms wird die Liste der Dokumentstapel angezeigt, die zum geöffneten Projekt gehören.

Hauptfenster mit Stapelliste anzeigen

Doppelklicken Sie auf einen Stapel. Daraufhin wird eine Liste der zum Stapel gehörenden Dokumente angezeigt.

Wenn Sie zurück zur Liste der Stapel wechseln möchten, wählen Sie im Menü die Optionen Projekt > Liste der Arbeitsstapel (oder Liste der Teststapel bei Verwendung von Teststapeln) aus.

Hauptfenster mit einem geöffneten Dokumentstapel anzeigen

Das Menü befindet sich im oberen Bereich des Fensters. Unterhalb des Menüs befinden sich die Symbolleisten.

Der mittlere Bereich des Hauptfensters umfasst das Arbeitsstapelfenster mit einer Liste von zugehörigen Dokumenten.

Im unteren Bereich des Fensters befindet sich eine Statusleiste. In dieser Leiste werden Details zum Status und den Vorgängen im Programm sowie kurze Hinweise zu den ausgewählten Menüoptionen und Schaltflächen angezeigt.

Sie müssen das Dokumentfenster öffnen, um erkannte Daten zu überprüfen. Doppelklicken Sie dazu auf ein Dokument oder eine der Dokumentseiten. Das Dokumentfenster besteht aus drei Bereichen:

  • Bild der Dokumentseite
  • Erkannte Daten
  • Regelfehler (dieser Bereich wird nur angezeigt, wenn tatsächlich Regelfehler aufgetreten sind)

Weitere Informationen finden Sie unter überprüfung im Dokumentfenster.

Dokumentfenster anzeigen

Menü des Hauptfensters
Symbolleisten im Hauptfenster


Menü des Hauptfensters von ABBYY FlexiCapture 8.0 Professional

Datei
Menüoption | Beschreibung
Neues Projekt… | Erstellt ein neues Projekt
Projekt öffnen… | öffnet ein vorhandenes Projekt
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert änderungen
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt Bilder vom Scanner hinzu
Bilder importieren… | Importiert Bilder mit einem der konfigurierten Importprofile
Exportieren | Exportiert Daten mithilfe der Exporteinstellungen von Dokumentvorlagen
Exportieren in |
Datei… | Exportiert die Daten in eine Datei
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzliche Projekte | öffnet eines der kürzlich geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture 8.0
Bearbeiten
Menüoption | Beschreibung
Rückgängig | Macht die vorherige Aktion rückgängig
Wiederherstellen | Stellt die rückgängig gemachte Aktion wieder her
Ausschneiden | Schneidet die markierten Objekte aus
Kopieren | Kopiert die markierten Objekte in die Zwischenablage
Einfügen | Fügt den Inhalt der Zwischenablage ein
Löschen | Löscht die markierten Objekte
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht den angegebenen Text
Weitersuchen | Sucht nach dem nächsten Vorkommen des angegebenen Texts
Gehe zu |
Nächstes Dokument | Wechselt zum nächsten Dokument
Vorheriges Dokument | Wechselt zurück zum vorherigen Dokument
Bild |
Störungen entfernen | Entfernt Verzerrungen im Bild
Invertieren | Invertiert das Bild
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Ansicht
Menüoption | Beschreibung
Dokumente |
Details | Zeigt Dokumente und zugehörige Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Seitenbilder eines Dokuments als Miniaturansichten an
Dokumenteditor |
Bildmodus | Zeigt ein Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Auswahl der Bildposition im Dokumentfenster
Fehlerfenster | Ermöglicht die Auswahl der Position des Fehlerfensters im Dokumentfenster
Symbolleiste im Datenmodus anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. über diese Symbolleiste können Sie einige Ausführungsfehler korrigieren, z. B. Hinzufügen eines nicht gefundenen Felds sowie Hinzufügen oder Löschen einer Tabellentrennlinie. Diese Option wird am häufigsten bei FlexiLayouts verwendet.
Symbolleisten | Blendet die Symbolleisten im Hauptfenster ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Bild schwarz-weiß anzeigen | Zeigt die Farb- und Graustufenbilder von Dokumentseiten im Schwarz-Weiß-Modus an
Bildanzeige | Legt die geeignete Bildgröße für Dokumentseiten fest
Datentextgröße | Ermöglicht die Auswahl der Schriftgröße zum Anzeigen erkannter Daten
Vollbild | Wechselt in den Vollbildmodus
Eigenschaften… | öffnet das Eigenschaftendialogfeld für ein Dokument oder eine Seite
Import & Erkennung
Menüoption | Beschreibung
Bilder importieren… | Importiert Bilder mit einem der konfigurierten Importprofile
Analysieren | Analysiert Dokumentseiten durch Auswahl einer geeigneten Vorlage
Vorlage zuordnen… | Ordnet dem markierten Dokument oder der markierten Seite die ausgewählte Vorlage zu
Erkennen | Führt den Erkennungsvorgang durch
überprüfung
Menüoption | Beschreibung
Überprüfung ausführen… | Führt den überprüfungsvorgang durch
Nächster Zusammenstellungsfehler | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriger Zusammenstellungsfehler | Wechselt zurück zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zurück zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zurück zum vorherigen Regelfehler
Projekt
Menüoption | Beschreibung
Liste der Arbeitsstapel | Schließt den aktuellen Stapel und öffnet die Liste der Arbeitsdokumentstapel
Liste der Teststapel | Schließt den aktuellen Stapel und öffnet die Liste der Testdokumentstapel. Diese Menüoption ist nur im Administratormodus verfügbar.
Dokumentvorlagen… | öffnet ein Dialogfeld mit einer Liste von Dokumentvorlagen, über die Sie Vorlagen erstellen, bearbeiten, importieren oder löschen können. Diese Menüoption ist nur im Administratormodus verfügbar.
Bildimportprofile… | öffnet ein Dialogfeld mit einer Liste von Bildimportprofilen, über die Sie neue Profile erstellen sowie vorhandene Profile kopieren, bearbeiten und löschen können. Diese Menüoption ist nur im Administratormodus verfügbar.
In Administratormodus wechseln… | Wechselt in den Administratormodus. Diese Menüoption ist nur im Operatormodus verfügbar.
Mit Kennwort schützen… | Schützt das aktuelle Projekt durch ein Kennwort. Diese Menüoption ist nur im Administratormodus verfügbar.
Kennwortschutz aufheben… | Hebt den Kennwortschutz für ein Projekt auf. Diese Menüoption ist nur im Administratormodus verfügbar.
Projekt exportieren… | Exportiert das Projekt in den vom Benutzer angegebenen Ordner. Die Bilder werden aus dem aktuellen Projekt genommen.
Projekt aktualisieren… | Aktualisiert das Projekt. Meldungen und Fehler, die während des Exports möglicherweise auftreten, können in einer Datei gespeichert werden (klicken Sie mit der rechten Maustaste, und wählen Sie In Datei exportieren).
Projekteigenschaften… | öffnet das Eigenschaftendialogfeld eines Projekts
Extras
Menüoption | Beschreibung
Neu analysieren | Wiederholt die Analyse von Dokumenten
Neu erkennen | Wiederholt die Erkennung von Dokumenten
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung von Seiten in einem Dokument
Regeln erneut überprüfen | Wiederholt die überprüfung von Regeln
Optionen… | öffnet das Dialogfeld Optionen zum Konfigurieren verschiedener Einstellungen, z. B. Verarbeitung von Hintergrundtasks oder Fensteransichten.
Hilfe
Menüoption | Beschreibung
Hilfethemen… | öffnet die Hilfethemen von ABBYY FlexiCapture 8.0 Professional
Technischer Support… | öffnet die Seite Technischer Support in den Hilfethemen
ABBYY-Produkte erwerben… | öffnet die Seite Informationen zum Kauf von ABBYY FlexiCapture 8.0 Professional in den Hilfethemen
ABBYY-Website… | öffnet die ABBYY-Website
Feedback senden | über diesen Link können Benutzer ihre Kommentare und Anregungen an ABBYY senden.
Info… | öffnet das Dialogfeld Info mit einer kurzen Beschreibung des Programms.


Symbolleisten im Hauptfenster von ABBYY FlexiCapture 8.0 Professional

Symbolleiste "Standard"

Name | Schaltfläche | Beschreibung
Projekt öffnen |  | öffnet ein Projekt
änderungen speichern |  | Speichert änderungen
Ausschneiden |  | Schneidet beim Bearbeiten der Daten im Dokumentfenster das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt ein zuvor kopiertes Objekt aus der Zwischenablage ein
Löschen |  | Löscht ein markiertes Objekt
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Miniaturansicht |  | Zeigt die Seitenbilder eines Dokuments als Miniaturansichten an
Detailansicht |  | Zeigt Dokumente und zugehörige Seiten in einer detaillierten Liste an
Vorheriges zu überprüfendes Element |  | Wechselt zurück zum vorherigen zu überprüfenden Element. über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element |  | Wechselt zum nächsten zu überprüfenden Element. über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument |  | Wechselt zurück zum vorherigen Dokument
Nächstes Dokument |  | Wechselt zum nächsten Dokument
Symbolleiste "Verarbeitung"

über die Symbolleiste Verarbeitung können Sie alle Vorgänge zur Verarbeitung von Dokumenten durchführen. Die Schaltflächen in dieser Symbolleiste sind multifunktional und können in mehreren Modi verwendet werden.

Die Beschriftung der ersten Schaltfläche zum Hinzufügen von Bildern ändert sich je nach ausgewähltem Modus. Wenn Sie auf die Schaltfläche klicken, wird jeweils der der Beschriftung entsprechende Vorgang durchgeführt.

Wenn Sie einen bestimmten Modus auswählen möchten, klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche, und wählen Sie die gewünschte Menüoption aus.

Schaltfläche | Modus | Beschreibung
 | Bilder laden… | Lädt Bilder aus Dateien und fügt sie dem aktuellen Stapel hinzu
 | Bilder scannen… | Fügt dem Stapel Bilder vom Scanner hinzu
 | Bilder importieren… | Importiert Bilder mit einem der konfigurierten Bildimportprofile
 | Liste der vorhandenen Importprofile | Wählen Sie zum Importieren von Bildern einfach eines der konfigurierten Importprofile in der Liste aus.
 | Erkennen | Führt den Erkennungsvorgang durch
 | Analysieren | Analysiert Dokumentseiten durch Auswahl einer geeigneten Vorlage
 | Vorlage zuordnen… | Ordnet dem markierten Dokument oder der markierten Seite die ausgewählte Vorlage zu
 | Überprüfung ausführen… | Führt den überprüfungsvorgang durch
 | Regeln erneut überprüfen | Wiederholt die überprüfung von Regeln
 | Exportieren | Exportiert Daten entsprechend dem in den Dokumentvorlagen konfigurierten Exportprofil
 | In Datei exportieren… | Exportiert die Daten in eine Datei
 | In Datenbank exportieren… | Exportiert die Daten in eine Datenbank


Fenster des Dokumentvorlageneditors

Im Fenster des Dokumentvorlageneditors können Vorlagen erstellt und bearbeitet werden.

So öffnen Sie den Dokumentvorlageneditor im Hauptfenster des Programms:

  1. Wählen Sie die Menüoptionen Projekt > Dokumentvorlagen… aus.
  2. Markieren Sie im daraufhin geöffneten Dialogfeld Dokumentvorlagen den Namen einer Vorlage, und klicken Sie auf Bearbeiten….

Das Fenster des Dokumentvorlageneditors wird zudem nach dem Beenden des Vorlagenassistenten geöffnet.

Fenster des Dokumentvorlageneditors anzeigen

Das Fenster des Dokumentvorlageneditors besteht aus drei Bereichen:

  1. Bild der Seite mit der Kennzeichnung der Felder und statischen Elemente links oben im Fenster.

    Zur Bearbeitung der Felder und statischen Elemente verfügt das Programm über zwei Modi:

    • Modus für Feldbereiche: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert.
    • Modus für statische Elemente: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert.
  2. Editor zum Konfigurieren der Darstellung erkannter Daten links unten im Fenster.
  3. Dokumentstruktur mit einer Liste aller Vorlagenfelder (Registerkarte Felder) im rechten Bereich des Fensters. Sie können darüber hinaus in die Gliederungsansicht (Registerkarte Seiten) wechseln.

Menü des Dokumentvorlageneditors
Symbolleisten im Dokumentvorlageneditor


Menü des Dokumentvorlageneditors

Vorlage
Menüoption | Beschreibung
Seite hinzufügen… | Fügt ein neues Seitenbild in einer Vorlage ein
Dokumentbereich hinzufügen… | Fügt einen neuen Bereich in einem Stapel ein
Skriptmodule |
Regelskript… | Öffnet das Regel für globales Skriptmodul im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter Verwenden von Skripten in FlexiCapture 8.0.
Skript exportieren… | Öffnet das Globales Skriptmodul exportieren im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter Verwenden von Skripten in FlexiCapture 8.0.
Exporteinstellungen… | öffnet das Dialogfeld Exporteinstellungen zum Konfigurieren der Optionen für den Datenexport
Eigenschaften von Dokumentvorlage… | öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der Eigenschaften einer Dokumentvorlage
Speichern | Speichert änderungen
Schließen | Schließt den Dokumentvorlageneditor
Bearbeiten
Menüoption | Beschreibung
Rückgängig | Macht die vorherige Aktion rückgängig
Wiederherstellen | Stellt die rückgängig gemachte Aktion wieder her
Ausschneiden | Schneidet die markierten Objekte aus
Kopieren | Kopiert die markierten Objekte in die Zwischenablage
Einfügen | Fügt den Inhalt der Zwischenablage ein
Löschen | Löscht die markierten Objekte
Bereich löschen | Entfernt Bereiche aus den Bildern der markierten Objekte
Alles auswählen | Wählt alle Objekte aus
Nach Typ auswählen… | Erkennt bestimmte Objekttypen
Feld erstellen |
Text | Fügt der Dokumentstruktur ein Texteingabefeld hinzu (im Bild ohne Bereich)
Auswahlfeld | Fügt der Dokumentstruktur ein Auswahlfeld hinzu (im Bild ohne Bereich)
Auswahlfeldgruppe | Fügt der Dokumentstruktur eine Gruppe von Auswahlfeldern hinzu (im Bild ohne Bereich)
Barcode | Fügt der Dokumentstruktur ein Barcodefeld hinzu (im Bild ohne Bereich)
Bild | Fügt der Dokumentstruktur ein Bildfeld hinzu (im Bild ohne Bereich)
Tabelle | Fügt der Dokumentstruktur ein Tabellenfeld hinzu (im Bild ohne Bereich)
Gruppe | Fügt der Dokumentstruktur eine Gruppe von Feldern hinzu (im Bild ohne Bereich)
Gruppieren | Gruppiert die markierten Objekte
Gruppierung aufheben | Hebt die Gruppierung der markierten Objekte auf
Text aus Bild kopieren… | Kopiert Text aus einem Bereich des Bilds und speichert ihn in der Zwischenablage. Markieren Sie nach der Auswahl dieses Befehls den Bereich, in dem sich der gewünschte Text befindet.
Bild |
Störungen entfernen | Entfernt Verzerrungen im Bild
Invertieren | Invertiert das Bild
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Speichern unter… | Speichert das Bild der Vorlagenseite in der angegebenen Datei
Ersetzen… | Ersetzt das Bild der Vorlagenseite
Ansicht
Menüoption | Beschreibung
Bildlayout |
Statische Elemente | Wechselt in den Modus für statische Elemente
Feldbereiche | Wechselt in den Modus für Feldbereiche
Dokumentstruktur |
Dokumentstruktur anzeigen | Blendet das Fenster Dokumentstruktur ein oder aus
Felder | Schaltet das Fenster Dokumentstruktur in den Feldmodus um
Seiten | Schaltet das Fenster Dokumentstruktur in den Seitenmodus um
Datenformular | Blendet das Fenster des Dateneditors ein oder aus
Symbolleiste "Layout" |
Horizontal | Dockt die Symbolleiste horizontal im Bildlayoutfenster an
Vertikal | Dockt die Symbolleiste vertikal im Bildlayoutfenster an
Bild schwarz-weiß anzeigen | Zeigt die Farb- und Graustufenbilder von Seiten im Schwarz-Weiß-Modus an
Bildanzeige | Legt die geeignete Bildgröße fest
Eigenschaften… | öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der markierten Objekteigenschaften
Dokument
Menüoption | Beschreibung
Test ausführen | Startet das Testen der Vorlage anhand des Dokumentbilds.
Test beenden | Beendet das Testen der Vorlage.
Bildmodus | Zeigt ein Seitenbild im Dokumentfenster an.
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an.
Ansicht |
Bildfenster | Ermöglicht die Auswahl der Bildposition im Dokumentfenster.
Fehlerfenster | Ermöglicht die Auswahl der Position des Fehlerfensters im Dokumentfenster.
Symbolleiste im Datenmodus anzeigen | Shows/hides the toolbar in data mode. In the image mode, the toolbar is always displayed and cannot be hidden.
Überprüfung |
Nächstes zu überprüfendes Element | Wechselt zum nächsten zu überprüfenden Element. Über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges zu überprüfendes Element | Wechselt zurück zum vorherigen zu überprüfenden Element. Über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zurück zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zurück zum vorherigen Regelfehler
Extras
Menüoption | Beschreibung
Objekte automatisch erkennen… | Erkennt und markiert automatisch Felder und statische Elemente eines bestimmten Typs (je nach Modus)
Dokumentvorlage überprüfen | überprüft die Dokumentvorlage
Bereich zuordnen | überprüft die Zuordnung eines Vorlagenbereichs
Zu Stapeltest wechseln… | Wechselt in den Stapeltestmodus
Hilfe
Menüoption | Beschreibung
Hilfethemen… | öffnet die Hilfethemen von ABBYY FlexiCapture 8.0 Professional
Feedback senden | über diesen Link können Benutzer ihre Kommentare und Anregungen an ABBYY senden.


Symbolleisten im Dokumentvorlageneditor

Symbolleiste "Standard"

Name | Schaltfläche | Beschreibung
änderungen speichern |  | Speichert änderungen
Ausschneiden |  | Schneidet beim Bearbeiten der Daten im Dokumentfenster das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt ein zuvor kopiertes Objekt aus der Zwischenablage ein
Löschen |  | Löscht ein markiertes Objekt
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Dokumentvorlage überprüfen |  | überprüft eine Dokumentvorlage. Sie können die unten im Fenster des Dokumentvorlageneditors angezeigten Ergebnisse überprüfen.
Symbolleiste im Bildlayoutfenster

über die Symbolleiste im Bildlayoutfenster können statische Elemente und Vorlagenfelder erstellt werden. Die Symbolleiste enthält je nach dem ausgewählten Modus unterschiedliche Schaltflächen.

Modus für statische Elemente:

Modus für Feldbereiche:

Die Symbolleiste kann horizontal oder vertikal im Fenster angedockt werden. Die Ausrichtung der Symbolleiste kann unter Ansicht > Symbolleiste "Layout" geändert werden.
Name | Schaltfläche | Beschreibung
Allgemein
Modus für statische Elemente |  | Wechselt in den Modus für statische Elemente
Modus für Feldbereiche |  | Wechselt in den Modus für Feldbereiche
Zoom |  | Vergrößert die Bildanzeige
Objekte automatisch erkennen |  | Erkennt automatisch Objekte im Bild. Klicken Sie auf dieses Tool und anschließend in den Objektbereich.
Bereiche auswählen |  | Markiert die Objektbereiche, die im Bild markiert wurden. Klicken Sie zum Markieren eines Bereichs auf dieses Tool und anschließend in den Objektbereich.
Modus für statische Elemente
Anker erstellen |  | Erstellt einen Anker. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Anker.
Trennlinie erstellen |  | Erstellt eine Trennlinie. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Trennlinie.
Ankertext erstellen |  | Erstellt einen Ankertext. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Text.
Ankerbarcode erstellen |  | Erstellt einen Ankerbarcode. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Modus für Feldbereiche
Text erstellen |  | Erstellt ein Texteingabefeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Texteingabebereich.
Auswahlfeld erstellen |  | Erstellt ein Auswahlfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Auswahlfeldbereich.
Auswahlgruppenfeld erstellen |  | Erstellt eine Gruppe von Auswahlfeldern. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Gruppe von Auswahlfeldern.
Barcode erstellen |  | Erstellt ein Barcodefeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Bild erstellen |  | Erstellt ein Bildfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um das Bild.
Tabelle erstellen |  | Erstellt ein Tabellenfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Tabelle. In der Symbolleiste werden weitere Schaltflächen zum Markieren von Tabellen angezeigt.
Gruppe erstellen |  | Erstellt eine Feldgruppe. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Feldgruppe.
Bereich für Feld ohne Bereich erstellen |  | Erstellt einen Bereich für ein Feld, das in der Dokumentstruktur enthalten ist, dem jedoch im Bild kein Bereich zugewiesen ist. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Bereich des Felds. Wählen Sie in der Dropdownliste einen Namen aus. (In der Liste sind die Felder aufgeführt, denen im Bild kein Bereich zugeordnet ist.)
Unerkennbaren Bereich erstellen |  | Markiert ein Feld, das beim Erkennungsvorgang ausgeschlossen werden soll.
Schaltflächen zum Markieren von Tabellen Diese Schaltflächen werden angezeigt, wenn in einem Vorlagenbereich mindestens eine Tabelle erstellt wurde.
Spalte erstellen |  | über diese Schaltfläche können Sie eine Tabellenspalte erstellen und den entsprechenden Spaltentyp angeben. Klicken Sie dazu auf dieses Tool und anschließend in den Bereich, in dem die Spalte erstellt werden soll. Wählen Sie in der Dropdownliste einen Spaltentyp aus.
Tabellentrennlinie zeichnen |  | Fügt horizontale und vertikale Trennlinien in die Tabelle ein
Trennlinie löschen |  | Löscht eine Trennlinie


Fenster für die Gruppenüberprüfung

Das Fenster für die Gruppenüberprüfung wird beim Ausführen des überprüfungsvorgangs (überprüfung > Überprüfung ausführen… im Menü des Hauptfensters) geöffnet, sofern die Vorlage Felder enthält, für die die Option Bei Gruppenüberprüfung einschließen aktiviert ist. Weitere Informationen finden Sie unter Feldüberprüfungseigenschaften.

In diesem Fenster können Sie als identisch erkannte Zeichen auf ihre Richtigkeit überprüfen. Siehe Gruppenüberprüfung.

Menü im Fenster für die Gruppenüberprüfung
Symbolleiste im Fenster für die Gruppenüberprüfung


Menü im Fenster für die Gruppenüberprüfung

überprüfung
Menüoption | Beschreibung
Alle bestätigen | Bestätigt die korrekte Erkennung aller Zeichen und wechselt zum nächsten Fenster
Alle ablehnen | Lehnt alle Zeichen ab und markiert sie als nicht eindeutig
Status ändern | ändert den Status des ausgewählten Zeichens
Nächste Seite | Wechselt zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Vorherige Seite | Wechselt zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Schließen | Schließt das überprüfungsfenster
Bearbeiten
Menüoption | Beschreibung
Rückgängig | Macht die vorherige Aktion rückgängig
Wiederherstellen | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Alles auswählen | Wählt alle Zeichen aus
Ansicht
Menüoption | Beschreibung
Feldbild |
Feldbild anzeigen | Blendet ein Feldbild mit dem aktuellen Zeichen ein oder aus
Oben | Positioniert das Feldbild im oberen Bereich des überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des überprüfungsfensters
Bildanzeige | Wählt eine geeignete Größe für das Feldbild aus
Zeichenbild anzeigen | Zeigt das Zeichenbild an
Symbolleiste | Blendet die Symbolleiste ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Zeichengröße | Dient zum Auswählen einer geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Voreinstellungen… | Dient zum Konfigurieren der Ansicht des angrenzenden Bereichs von Zeichen
Hilfe
Menüoption | Beschreibung
Hilfethemen… | öffnet die Hilfethemen von ABBYY FlexiCapture 8.0 Professional
Info… | öffnet das Dialogfeld Info mit einer kurzen Beschreibung des Programms


Symbolleiste im Fenster für die Gruppenüberprüfung

Name | Schaltfläche | Beschreibung
Vorherige Seite |  | Wechselt zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Nächste Seite |  | Wechselt zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Bildschirm bestätigen |  | Bestätigt die korrekte Erkennung aller Zeichen und wechselt zum nächsten Fenster
Zeichenstatus ändern |  | ändert den Zeichenstatus (abgelehnt oder bestätigt)
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her


Fenster für die Feldüberprüfung

Das Fenster für die Feldüberprüfung wird angezeigt, nachdem die Gruppenüberprüfung beendet wurde, sofern die Vorlage Felder enthält, für die die Option Bei Feldüberprüfung einschließen aktiviert ist. Weitere Informationen finden Sie unter Feldüberprüfungseigenschaften.

In diesem Fenster können Sie nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds überprüfen. Siehe Feldüberprüfung.

Menü im Fenster für die Feldüberprüfung
Symbolleiste im Fenster für die Feldüberprüfung


Menü im Fenster für die Feldüberprüfung

überprüfung
Menüoption | Beschreibung
Feld bestätigen | Bestätigt ein Feld
Aufschieben | Verschiebt die überprüfung eines Felds auf einen späteren Zeitpunkt
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zurück zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes Feld | Wechselt zum nächsten Feld
Vorheriges Feld | Wechselt zurück zum vorherigen Feld
Schließen | Schließt das überprüfungsfenster
Bearbeiten
Menüoption | Beschreibung
Rückgängig | Macht die vorherige Aktion rückgängig
Wiederherstellen | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Ausschneiden | Schneidet die markierten Objekte aus
Kopieren | Kopiert die markierten Objekte in die Zwischenablage
Einfügen | Fügt den Inhalt der Zwischenablage ein
Löschen | Löscht die markierten Objekte
Alles auswählen | Wählt alle Objekte aus
Zeilenumbruch einfügen | Fügt einen Zeilenumbruch ein
Zeichen verbinden | Verbindet die markierten Zeichen, wenn bei der Erkennung ein Zeichen fälschlicherweise in mehrere Zeichen geteilt wurde
Ansicht
Menüoption | Beschreibung
Felddaten |
Erkannter Text | Blendet den erkannten Text ein oder aus
Zeichenausschnitt | Wechselt in den Feldansichtsmodus mit Zeichenausschnitt
Sonderzeichen anzeigen | Blendet Sonderzeichen ein oder aus
Feldbild |
Feldbild anzeigen | Blendet ein Feldbild mit dem aktuellen Zeichen ein oder aus
Oben | Positioniert das Feldbild im oberen Bereich des überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des überprüfungsfensters
Bildanzeige | Legt die geeignete Bildgröße für Dokumentseiten fest
Angrenzende Felder | Blendet die angrenzenden Felder ein oder aus
Zeichenbild anzeigen | Blendet das Bild des Zeichens ein oder aus
Symbolleiste | Blendet die Symbolleisten im Hauptfenster ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Zeichengröße | Dient zum Auswählen einer geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Voreinstellungen… | Dient zum Konfigurieren der Ansicht des überprüfungsfensters
Hilfe
Menüoption | Beschreibung
Hilfethemen… | öffnet die Hilfethemen von ABBYY FlexiCapture 8.0 Professional
Info… | öffnet das Dialogfeld Info mit einer kurzen Beschreibung des Programms


Symbolleiste im Fenster für die Feldüberprüfung

Name | Schaltfläche | Beschreibung
Vorheriges Feld |  | Wechselt zurück zum vorherigen Feld
Nächstes Feld |  | Wechselt zum nächsten Feld
Feld bestätigen/Feld überspringen |  | Bestätigt die korrekte Erkennung aller Zeichen in einem Feld und wechselt zum nächsten Feld. Wenn der Feldwert nicht dem Feldformat entspricht, ändert sich die Beschriftung der Schaltfläche in Feld überspringen. Wenn der Feldwert nicht korrigiert werden kann, kann die überprüfung abgelehnt oder übersprungen werden.
Ablehnen |  | Lehnt die Feldüberprüfung ab, wenn der Wert des Felds nicht korrigiert werden kann
Vorheriges nicht eindeutiges Zeichen |  | Wechselt zurück zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes nicht eindeutiges Zeichen |  | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her


Konfigurieren des Programms

Vor der Masseneingabe von Dokumenten muss das Programm für die Verarbeitung der Dokumente des gewünschten Typs konfiguriert werden. Der Administrator konfiguriert alle erforderlichen Einstellungen.

Erstellen Sie zum Konfigurieren der Dokumentverarbeitung ein Projekt mit folgenden Elementen:

  • Bildimportprofile
  • eine oder mehrere Dokumentvorlagen
  • Dokumentstapel zur Verarbeitung

Sie können verschiedene Vorlagen in das Projekt einbinden. In diesem Fall werden je nach zugeordneter Vorlage verschiedene Dokumente im gleichen Projekt verarbeitet. Wenn sich die verschiedenen Dokumente jedoch nicht überschneiden, können Sie jeweils separate Projekte erstellen.

Administrator- und Operatormodus
Erstellen eines Projekts
Dokumentvorlagen
Bildimportprofile
Standardexporteinstellungen
Dokumentstapel
Indexfelder


Administrator- und Operatormodus

Für die Dateneingabe in einem Durchgang mithilfe von ABBYY FlexiCapture 8.0 Professional müssen Sie das System für die Verarbeitung bestimmter Dokumenttypen konfigurieren. Alle Einstellungen werden vom Administrator konfiguriert, die Eingabe der Dokumente wird dagegen von Operatoren durchgeführt. Die Anzahl der Workstations hängt von der Anzahl und dem Volumen der zu verarbeitenden Dokumente ab.

Administratoren konfigurieren das System und steuern den Systembetrieb. Administratoren führen folgende Tasks durch:

  • Entwerfen neuer Formulare (dieser Task kann auch von Entwicklern durchgeführt werden)
  • Konfigurieren des Bildimports und der Scanoptionen
  • Vorbereiten von Dokumentvorlagen
  • überwachen der Dateneingabe im konfigurierten System und Anleiten der Operatoren

Operatoren sind für die Dokumenterfassung zuständig. Sie arbeiten in einem durch Administratoren vordefinierten System, in dem bestimmte Dokumenttypen verarbeitet werden können. Operatoren führen folgende Tasks durch:

  • Scannen oder Importieren von Dokumenten
  • überprüfen der Daten
  • Exportieren der Daten

Die Dokumenterkennung erfolgt automatisch.

Das Programm verfügt über zwei Betriebsmodi: Administrator- und Operatormodus. Der Administrator hat vollständigen Zugriff auf sämtliche Programmfunktionen. Der Administratormodus kann durch ein Kennwort geschützt werden. Operatoren sind nicht berechtigt, Vorlagen zu erstellen oder zu bearbeiten bzw. Importprofile zu erstellen, und sie können jeweils nur an einem Projekt oder Stapel gleichzeitig arbeiten.

Beim Installieren des Programms können Sie festlegen, ob nur die Operatorstation oder das vollständige Programm installiert wird. Wenn Sie die vollständige Installation auswählen, können Sie zwischen Administrator- und Operatormodus wechseln. Zur Auswahl eines Modus wählen Sie entweder Start > Alle Programme > ABBYY FlexiCapture 8.0 > ABBYY FlexiCapture 8.0 Professional Administrator Station oder Start > Alle Programme > ABBYY FlexiCapture 8.0 > ABBYY FlexiCapture 8.0 Professional Operator Station aus. (Detaillierte Informationen finden Sie unter Ausführen der Software).

Sie können die Optionen zum Ausführen von FlexiCapture so konfigurieren, dass der Betriebsmodus des Programms, das automatisch geöffnete Projekt und der automatisch geöffnete Stapel (im Operatormodus können Sie mithilfe der ProhibitChangePath-Markierung festlegen, dass Projekt und Stapel nicht geändert werden können) sowie das folgende Standardkennwort gesteuert werden:

FlexiCapture.exe [/Station:(Admin,Operator)] [/Project:"Projektpfad"] [/Batch:"Stapelname"] [/ProhibitChangePath].

Wenn der Modus nicht angegeben wurde, wird beim Ausführen des Programms ein Dialogfeld angezeigt, in dem Sie aufgefordert werden, den gewünschten Modus auszuwählen.

Im Administratormodus enthält das Menü Projekt die Menüoptionen Liste der Teststapel, Dokumentvorlagen…, Bildimportprofile…, Mit Kennwort schützen… und Kennwortschutz aufheben…. Diese Optionen sind im Operatormodus nicht verfügbar. Teststapel, Dokumentvorlagen und Importprofile können somit nur im Administratormodus verwendet werden. Administratoren können zudem Projekte durch ein Kennwort schützen sowie den Kennwortschutz aufheben. Wenn Sie ein kennwortgeschütztes Projekt im Administratormodus öffnen möchten, werden Sie zur Eingabe des Kennworts aufgefordert.

Im Operatormodus enthält das Menü Projekt die Menüoption In Administratormodus wechseln…. Wenn Sie diese Menüoption auswählen, werden das aktuelle Projekt und der aktuelle Stapel geöffnet (nach Eingabe des entsprechenden Kennworts, falls der Stapel kennwortgeschützt ist). Wenn Sie nicht über die Berechtigung verfügen, das aktuelle Projekt oder den aktuellen Stapel im Operatormodus zu ändern, werden die entsprechenden Menüoptionen und Symbolleisten nicht angezeigt.


Erstellen eines Projekts

Zur Vorbereitung der Arbeit müssen Sie ein Projekt erstellen. Ein Projekt umfasst folgende Elemente:

  • Bildimportprofile
  • eine oder mehrere Dokumentvorlagen
  • Dokumentstapel zur Verarbeitung

Nach dem Ausführen des Programms wird das Dialogfeld Projekt öffnen angezeigt, in dem Sie eines der vorhandenen Projekte auswählen oder ein neues Projekt erstellen können.

So erstellen Sie ein neues Projekt:

  1. Klicken Sie auf die Schaltfläche Neues Projekt….
  2. Geben Sie einen Ordner zum Speichern des Projekts sowie den Namen des Projekts an.
  3. Klicken Sie auf Erstellen.

Wenn ABBYY FlexiCapture 8.0 Professional bereits ausgeführt wird und ein Projekt geöffnet wurde, wählen Sie zum Erstellen eines neuen Projekts die Menüoptionen Datei > Neues Projekt… aus.

Projekteigenschaften
Dokumentvorlagen
Bildimportprofile
Dokumentstapel


Projekteigenschaften

Die Eigenschaften eines Projekts können in einem separaten Dialogfeld angezeigt und geändert werden, wenn Sie im Hauptfenster die Option Projekt>Projekteigenschaften… auswählen.

Die Registerkarte Allgemein zeigt den Namen des Projekts, den Pfad zu den Projektdateien und eine Beschreibung des Projekts an.

Die Registerkarte Bildvorverarbeitung zeigt die Optionen für die Bildvorverarbeitung an. Sie können diese Optionen gegebenenfalls ändern. Einzelheiten finden Sie unter Optionen für die Bildvorverarbeitung.

Die Registerkarte Erkennung enthält die Option Während Erkennung leere Seiten löschen. Aktivieren Sie diese Option, wenn Sie möchten, dass leere Seiten während des Erkennungsvorgangs gelöscht werden.

Auf der Registerkarte Export werden die Standardexporteinstellungen angezeigt. Sie können diese Einstellungen gegebenenfalls ändern. Mit der Option Skript nach Export ausführen wird die Exportsteuerung aktiviert. Weitere Informationen über die Exportsteuerung finden Sie unter Beschreibung von Exportprozeduren mithilfe von Skripten und Beispielskripte für die Exportbeschreibung.


Dokumentvorlagen

Das Erstellen von Vorlagen ist der hauptsächliche und entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

Vorlagen können nur im Administratormodus erstellt werden.

In einer Vorlage sind die Pfade von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben. Beim Erstellen einer Vorlage werden Feldeigenschaften und deren Wertebereiche festgelegt. Darüber hinaus werden Exporteinstellungen für die Daten konfiguriert.

Zum Erstellen einer Dokumentvorlage starten Sie wie folgt den Vorlagenassistenten:

  1. Wählen Sie im Hauptmenü von ABBYY FlexiCapture 8.0 Professional die Optionen Projekt > Dokumentvorlagen… aus.
  2. Klicken Sie im daraufhin geöffneten Dialogfeld Dokumentvorlagen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Vorlagenassistenten.

Vorlagenassistent
Automatische Erkennung von Feldern und statischen Elementen
Statische Elemente
Erstellen von Feldern einer Dokumentvorlage
Feldeigenschaften
Regelbasierte Validierung
Konfigurieren des Datenexports
Konfigurieren der Datendarstellung im Dokumentfenster
Eigenschaften von Dokumentvorlagen
Importieren einer Vorlage für mit ABBYY FormDesigner erstellte Formulare
Erstellen von Vorlagen für mehrseitige Dokumente
Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente
Erstellen von Vorlagen für Dokumente mit Anhängen
Verarbeiten nicht strukturierter Dokumente
Bearbeiten und Veröffentlichen einer Vorlage
Testen einer Vorlage


Vorlagenassistent

Wenn Sie eine neue Vorlage erstellen möchten, wählen Sie im Hauptmenü die Optionen Projekt > Dokumentvorlagen… aus, und klicken Sie dann im Dialogfeld Dokumentvorlagen auf die Schaltfläche Neu…. Daraufhin wird der Assistent zum Erstellen neuer Vorlagen geöffnet.

  1. Geben Sie im Dialogfeld Neue Dokumentvorlage erstellen die hauptsächlichen Vorlageneinstellungen ein: Name und Kommentar, verwendete Sprache [Sprache (Gebietsschema)] und Schreibstil (Schreibstil). Die Dropdownliste enthält standardmäßig nur Sprachen mit Wörterbuchunterstützung. Wenn Sie eine Sprache ohne Wörterbuchunterstützung auswählen möchten, aktivieren Sie die Option Alle Sprachen anzeigen. Es ist sehr wichtig, die Sprache korrekt anzugeben, da die Dokumenterkennung davon abhängt. Der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, sodass im Programm der jeweils typische Schreibstil ausgewählt wird.

    Beispiele für unterschiedliche Schreibstile von Zahlen anzeigen
    – russische Zwei
    – amerikanische Zwei
    – "normale" Fünf in jedem Schreibstil
    – japanische Fünf
    – russische Eins
    – deutsche Eins
    – "normale" Neun in jedem Schreibstil
    – tschechische Neun mit Kreis rechts
    – amerikanische Neun ohne "Bogenabschluss"

    Geben Sie den Texttyp an:

    • ICR (Handschrift): Aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden.
    • OCR (Druck): Aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis: Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

    Klicken Sie auf Weiter, um mit dem nächsten Schritt fortzufahren.

  2. Im zweiten Schritt laden Sie das Bild der Dokumentseite, um die Vorlage zu erstellen. Sie können das Bild einer unvollständigen Seite scannen oder aus einer Datei laden.

    Hinweis: Die Vorlage für statische Formulare wird mithilfe eines Bilds erstellt, das durch Scannen eines unvollständigen Formulars entsteht. Dabei sollte es sich um ein Bild mit guter Qualität ohne Verzerrungen (ohne Schrägstellen, Fehlstellen usw.) handeln. Beim Erstellen von Vorlagen von Formularen mit farbigem Hintergrund sollten die Seiten ohne Filter gescannt werden, sodass der Hintergrund beim Scannen nicht ausgeblendet wird. (Wählen Sie später beim Scannen von Seitenbildern zur Datenerkennung einen Scanmodus aus, bei dem der Hintergrund ausgeblendet wird.)

    Wenn Dokumente mehrere Seiten umfassen, laden Sie die erste Seite, und fügen Sie die restlichen Seiten entsprechend den Empfehlungen im Abschnitt Erstellen von Vorlagen für mehrseitige Dokumente hinzu.

    Wenn Sie ein FlexiLayout verwenden möchten, das mit ABBYY FlexiLayout Studio erstellt wurde, aktivieren Sie die Option FlexiLayout laden, und geben Sie den Pfad der FlexiLayout-Datei an. Ausführliche Informationen finden Sie unter Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente.

    Klicken Sie auf die Schaltfläche Weiter.

  3. Im nächsten Schritt wählen Sie Feldtypen aus, die automatisch im Bild erkannt werden sollen. Sie können Auswahlfelder und Texteingabefelder auswählen. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

    Hinweis: Die automatische Ankersuche wird immer durchgeführt. Wenn ein Formular Anker enthält, werden diese erkannt und im Bild gekennzeichnet.

    Klicken Sie auf die Schaltfläche Fertig stellen.

Nach Beenden des Vorlagenassistenten wird das Fenster des Dokumentvorlageneditors geöffnet, in dem Sie weitere Vorgänge zum Erstellen einer Vorlage durchführen können. Im nächsten Schritt der Vorlagenerstellung kennzeichnen Sie Felder und statische Elemente im Seitenbild und konfigurieren die zugehörigen Eigenschaften.


Automatische Erkennung von Feldern und statischen Elementen

Automatische Erkennung beim Hinzufügen eines Bilds:

Beim Hinzufügen eines Seitenbilds werden Anker im Programm immer erkannt. Wenn das Bild Standardanker enthält (z. B. schwarze Quadrate) werden diese erkannt und markiert. Wenn die Optionen Text und Auswahlfelder aktiviert sind, werden Textfelder und Auswahlfelder gesucht. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

Automatische Erkennung im Fenster des Dokumentvorlageneditors:

Wenn Sie die automatische Erkennung im Fenster des Dokumentvorlageneditors festlegen möchten, wählen Sie den entsprechenden Modus (Feldmodus oder Modus für statische Elemente) und anschließend die Menüoptionen Extras > Objekte automatisch erkennen… aus. Markieren Sie die Typen der Felder oder statischen Elemente, die automatisch erkannt werden sollen.

Wenn spezifische Objekte im Bild automatisch erkannt werden sollen, wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus, und klicken Sie in der Symbolleiste auf [image]. Wenn Sie auf das betreffende Element klicken, wird es mit einem Rechteck markiert. Der Elementtyp wird automatisch erkannt.

Automatische Erkennung eines Bereichs:

Führen Sie folgende Schritte aus, damit der Bereich eines Felds oder eines statischen Elements eines bestimmten Typs automatisch erkannt wird:

  1. Wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus.
  2. Wählen Sie den Typ des Felds oder statischen Elements über die entsprechende Schaltfläche in der Symbolleiste aus.
  3. Drücken Sie die Umschalttaste.
  4. Klicken Sie mit der linken Maustaste in den Bereich des Felds oder des statischen Elements.


Statische Elemente

Statische Elemente werden zur Vorlagenzuordnung und -identifizierung verwendet. Aus statischen Elementen werden keine Daten extrahiert.

Klicken Sie auf die Schaltfläche [image], um in den Modus für statische Elemente zu wechseln und statische Elemente im Dokumentvorlageneditor bearbeiten zu können.

Statische Elemente können zur Vorlagenzuordnung und -identifizierung verwendet werden. Die entsprechende Verwendung wird beim Konfigurieren der Eigenschaften der Elemente festgelegt. Mithilfe von Ankern wird die Vorlage dem Formularbild zugeordnet. Objekte zur Identifizierung sind erforderlich, um beim Verarbeiten mehrerer Formulare in einem Durchgang ermitteln zu können, zu welchen Formularen die entsprechenden Seiten jeweils gehören. Weitere Informationen finden Sie unter Erstellen von maschinenlesbaren Formularen.

Statischen Elementen sind keine Namen, sondern nur Bereiche im Bild zugewiesen.

Wenn eine Vorlage einem Dokumentbild zugeordnet wird, werden im Programm statische Elemente gesucht. Anhand ihrer Position wird dann eine Dokumentvorlage ausgewählt. Die Erkennung der Werte statischer Elemente (Text und Barcode) wird nur dann durchgeführt, wenn dies zur Identifizierung erforderlich ist. Siehe Angeben von Werten für Objekte zur Identifizierung.

Im Programm werden folgende statische Elemente verwendet:

Statisches Element | Schaltfläche in der Symbolleiste
Anker |
Trennlinie |
Ankertext |
Ankerbarcode |

Beim Hinzufügen eines Bilds wird im Programm automatisch nach Ankern gesucht.

So erstellen Sie ein statisches Element manuell:

  1. Wählen Sie den Modus für statische Elemente aus.
  2. Wählen Sie das Tool zum Erstellen des gewünschten Elementtyps aus.
  3. Setzen Sie den Mauszeiger in die Ecke des Elements, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Bereich des Elements.

Der Bereich des statischen Elements wird in einem Rechteck eingerahmt. Je nach Elementtyp wird der Rahmen in einer anderen Farbe angezeigt. Dem statischen Element werden Standardeigenschaften zugewiesen.

So ändern Sie die Eigenschaften eines statischen Elements:

  1. Markieren Sie den Bereich des statischen Elements im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. ändern Sie die Eigenschaften des statischen Elements im daraufhin geöffneten Dialogfeld.

Weitere Informationen zu statischen Elementen:

  • Anker
  • Trennlinien
  • Ankertext
  • Ankerbarcode


Anker

Anker sind statische Elemente, die im Bild automatisch markiert werden.

So markieren Sie Anker manuell:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].

  3. Setzen Sie den Mauszeiger in die Ecke eines Ankers, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankerbereich.

Ankereigenschaften

So ändern Sie die Ankereigenschaften:

  1. Markieren Sie den entsprechenden Anker.
  2. Klicken Sie mit der rechten Maustaste in den Ankerbereich, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:
    • Für Vorlagenzuordnung verwenden: Diese Option muss aktiviert sein, damit der Anker zur Vorlagenzuordnung verwendet wird (empfohlen).
    • Für Vorlagenidentifizierung verwenden: Aktivieren Sie diese Option, um den Anker zur Vorlagenidentifizierung zu verwenden.
    • Ankertyp: Es ist wichtig, für eine korrekte Vorlagenzuordnung den Ankertyp anzugeben. Folgende Optionen sind verfügbar: Schwarzes Quadrat, Kreuz oder Ecke.


Ankertext

Ankertext ist ein statisches Element. Dabei kann es sich um einen beliebigen statischen Text in einem Bild handeln, beispielsweise eine Kopfzeile oder Signatur.

So markieren Sie Ankertext:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke des Ankertexts, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankertextbereich.

Ankertexteigenschaften

So ändern Sie die Ankertexteigenschaften:

  1. Markieren Sie den Text.
  2. Klicken Sie mit der rechten Maustaste in den Ankertextbereich, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Vorlagenzuordnung verwenden: Diese Option muss aktiviert sein, damit der Ankertext zur Vorlagenzuordnung verwendet wird.
    • Für Vorlagenidentifizierung verwenden: Aktivieren Sie diese Option, um den Ankertext zur Vorlagenidentifizierung zu verwenden.
    • Wert: Wenn Sie Ankertext als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Wenn automatisch ein Wert eingefügt werden soll, klicken Sie auf die SchaltflächeTipp.
    • Maximale Anzahl von Fehlern: Hier können Sie die maximal zulässige Anzahl von Fehlern für die Ankertextzeichenfolge festlegen.

    Legen Sie auf der Registerkarte Erkennung Erkennungsoptionen für den statischen Text mit maximaler Genauigkeit fest:

    • ICR (Handschrift): Aktivieren Sie diese Option, wenn statischer Text handschriftlich vorliegt.

    • OCR (Druck): Aktivieren Sie diese Option, wenn statischer Text gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (typografischer Text, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

    • Erweitert: über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben.

    • Datentyp: Wählen Sie die Sprache des Texts aus. Verwenden Sie dazu die Schaltfläche Auswählen….

    • Groß-/Kleinschreibung: Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im statischen Text aus. Wenn der Text Groß- und Kleinschreibung enthält, ändern Sie den Wert Automatisch nicht.

    • Ausrichtung: Geben Sie die Ausrichtung des Texts an.

    • Aktivieren Sie bei einzeiligem Text die Option Eine Zeile.

    • Wenn der Text keine Leerzeichen enthält, z. B. nur aus einem Wort besteht, aktivieren Sie die Option Ein Wort.

    • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:
    • Invertieren: Das Bild wird invertiert.
    • Textur entfernen: Die Textur wird entfernt.
    • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Trennlinien

Trennlinien sind statische Elemente. Dabei handelt es sich um horizontale oder vertikale Linien in einem Bild.

So markieren Sie Trennlinien:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke einer Trennlinie, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Bereich der Trennlinie.

Eigenschaften von Trennlinien

So ändern Sie die Eigenschaften von Trennlinien:

  1. Markieren Sie die Trennlinie.
  2. Klicken Sie mit der rechten Maustaste in den Bereich der Trennlinie, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:
    • Für Vorlagenzuordnung verwenden: Diese Option muss aktiviert sein, damit die Trennlinie zur Vorlagenzuordnung verwendet werden kann.
    • Für Vorlagenidentifizierung verwenden: Aktivieren Sie diese Option, um die Trennlinie zur Vorlagenidentifizierung zu verwenden.


Ankerbarcode

Der Ankerbarcode ist ein statisches Element.

Wichtig: Ein Barcode kann sowohl als Feld als auch als statisches Element hervorgehoben werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Vorlagenzuordnung oder -identifizierung vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Eigenschaften eines statischen Elements, eines Ankerbarcodes, erläutert. Siehe auch Barcodefeld.

So markieren Sie einen Ankerbarcode:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke eines Barcodes, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Barcodebereich.

Eigenschaften eines Ankerbarcodes

So ändern Sie die Eigenschaften eines Ankerbarcodes:

  1. Markieren Sie den Barcode.
  2. Klicken Sie mit der rechten Maustaste in den Barcodebereich, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Vorlagenzuordnung verwenden: Diese Option muss aktiviert sein, damit der Barcode zur Vorlagenzuordnung verwendet wird.
    • Für Vorlagenidentifizierung verwenden: Aktivieren Sie diese Option, um den Barcode zur Vorlagenidentifizierung zu verwenden.
    • Wert: Wenn Sie einen Ankerbarcode als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Um einen Wert automatisch einzufügen, klicken Sie auf die Schaltfläche Tipp.
    • Für Vorlagenzuordnung erforderlich: Wenn diese Option aktiviert ist, wird die Vorlage nur zugeordnet, wenn der Barcode zugeordnet wird. Aktivieren Sie diese Option, wenn ein Stapel zahlreiche ähnliche Vorlagen enthält, die nur durch die Werte der Barcodes oder die Werte eines von mehreren Barcodes unterschieden werden können. Dies beschleunigt die Vorlagenauswahl. Aktivieren Sie diese Option nicht, wenn die Vorlage zugeordnet werden soll, obwohl kein Barcode vorliegt oder der Barcode zu undeutlich ist.

    Registerkarte Erkennung:

    • Codetyp: Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt).
    • Ausrichtung: Geben Sie die Ausrichtung des Barcodes an.

    Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

    • Invertieren: Das Bild wird invertiert.
    • Textur entfernen: Die Textur wird entfernt.
    • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Angeben von Werten für Objekte zur Identifizierung

Mithilfe von Objekten zur Identifizierung kann festgestellt werden, zu welchem Formular eine Seite gehört, und eine Vorlage ausgewählt werden, bei der der Stapel mehrere Vorlagen mit der anfänglichen Ankergruppe enthält. Bei der gleichzeitigen Verarbeitung mehrerer Formulare in einem Durchgang wird anhand der Position der Objekte zur Identifizierung ermittelt, zu welchem Formular die betreffende Seite gehört.

Wenn ein Ankerbarcode oder Ankertext als Objekt zur Identifizierung verwendet wird, können Sie die Werte dieser Objekte zur Identifizierung angeben. In diesem Fall werden beim Zuordnen einer Vorlage die im Bild erkannten Daten mit dem Wert des Objekts zur Identifizierung verglichen. Die Zuordnung der Vorlage ist dann nur bei übereinstimmung der Werte möglich.

Die Werte von Objekten zur Identifizierung können im Eigenschaftendialogfeld für statische Elemente auf der Registerkarte Allgemein festgelegt werden. Die Werte für Text und Barcodes können automatisch eingetragen werden. Dies erfolgt über die Schaltfläche Tipp.

Hinweis: Wenn es möglich ist, eine Seite nur anhand der Position der Elemente mit absoluter Sicherheit zu identifizieren, müssen Sie diese Werte nicht festlegen. Sie sollten diese Funktion nur einsetzen, wenn dies absolut notwendig ist, da durch die Zuweisung des Werts für das Objekt zur Identifizierung das Erkennungsmodul bei der Vorlagenanwendung gestartet wird, wodurch sich die Zuordnung von Vorlagen mit Bildern verlangsamt.


Erstellen von Feldern einer Dokumentvorlage

Felder sind zur Datenextraktion vorgesehen.

Klicken Sie auf die Schaltfläche [image], um in den Modus für Feldbereiche zu wechseln und Felder im Dokumentvorlageneditor bearbeiten zu können.

Alle Bereiche im Bild, die zur Datenerfassung eingesetzt werden sollen, müssen als Felder markiert sein. Die Daten in diesen Feldern werden erkannt, und die zugehörigen Werte können exportiert werden.

Feldern sind Namen zugewiesen, deren Listen im Fenster Dokumentstruktur angezeigt werden. Normalerweise verfügen Felder über einen Bereich im Bild. Sie können jedoch auch Felder ohne Bereich erstellen, z. B. zum Speichern von Zwischenergebnissen.

Folgende Feldtypen werden im Programm erkannt:

Feld | Schaltfläche in der Symbolleiste
Texteingabefeld |
Auswahlfeld |
Gruppe von Auswahlfeldern |
Barcode |
Bild |
Tabelle |
Feldgruppe |

So erstellen Sie ein Feld:

  1. Wählen Sie den Modus für Feldbereiche aus.
  2. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.
  3. Setzen Sie den Mauszeiger in die Ecke des Felds, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Feldbereich.

Der Feldbereich wird in einem Rechteck eingerahmt. Je nach Feldtyp wird der Rahmen in einer anderen Farbe angezeigt.

Dem erstellten Feld wird ein Standardname zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt. Der Name wird im Fenster Dokumentstruktur auf der Registerkarte Felder in der Liste der Felder angezeigt.

Dem Feld werden Standardeigenschaften zugewiesen.

  • Erstellen von Gruppen von Auswahlfeldern
  • Erstellen von Tabellen
  • Erstellen einer Feldgruppe
  • ändern eines Feldnamens
  • Kopieren, Verschieben und Löschen von Feldern
  • Felder ohne Bereich
  • Feldeigenschaften


Erstellen einer Gruppe von Auswahlfeldern

In einer Gruppe von Auswahlfeldern werden logisch verknüpfte Auswahlfelder zusammengefasst, die normalerweise sich gegenseitig ausschließenden Antworten auf eine Frage entsprechen. In diesem Fall wird ein Auswahlfeld aus der Gruppe ausgewählt und der zugehörige Wert exportiert. Dabei handelt es sich jedoch nicht um eine zwingende Bedingung. Sie können im Programm festlegen, dass mehrere Auswahlfelder einer Gruppe aktiviert werden können (die entsprechende Option wählen Sie in den Eigenschaften für Gruppen von Auswahlfeldern aus).

Erste Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

So erstellen Sie eine Gruppe von Auswahlfeldern:

  1. Klicken Sie auf das Tool [image], und erstellen Sie Auswahlfelder für die entsprechende Gruppe.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Auswahlfelder der Gruppe einen Auswahlrahmen.
  3. Die innerhalb des Rechtecks liegenden Auswahlfelder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Gruppe positioniert. Die Eigenschaften der Auswahlfelder in einer Gruppe sind identisch und können nicht einzeln bearbeitet werden.

Zweite Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

Sie müssen nicht jedes Auswahlfeld in der Gruppe markieren.

  1. Klicken Sie auf das Tool [image], und markieren Sie stattdessen alle Auswahlfelder, die ein und derselben Gruppe angehören sollen, mit einem Rechteck.
  2. Die Auswahlfelder innerhalb des Rechtecks werden automatisch erkannt, benannt und in einer Gruppe zusammengefasst.


Erstellen einer Feldgruppe

Felder können in Gruppen zusammengefasst werden, sodass Dokumentstrukturen klar dargestellt sowie mehrfach vorkommende Feldgruppen erstellt werden können. So können z. B. Ort, Straße und Hausnummer als "Anschrift" zusammengefasst werden. Sie können dann Felder für die Gruppe "Firmenanschrift" einfach durch Kopieren der Feldgruppe "Anschrift" erstellen.

So erstellen Sie eine Feldgruppe:

  1. Erstellen Sie Felder, die der Gruppe angehören sollen.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Felder der Gruppe einen Auswahlrahmen.
  3. Die innerhalb des Rechtecks liegenden Felder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Feldgruppe positioniert.

Wenn in einem Formular bestimmte Feldgruppen mehrfach vorkommen, können Sie nach dem Erstellen einer Gruppe mehrere Instanzen dieser Gruppe erstellen. Alle Feldeigenschaften und Regeln der Gruppe gelten jeweils für alle Instanzen der Gruppe. Siehe Felder mit mehreren Instanzen.

Sie können eine Feldgruppe auch kopieren. Dadurch wird jedoch eine neue unabhängige Gruppe erstellt.


Erstellen einer Tabelle

Mit ABBYY FlexiCapture 8.0 Professional können Sie Vorlagen für Dokumente mit Tabellen erstellen. Durch Erstellen von Tabellenfeldern können die Konfiguration und Datenextraktion von Tabellen sowie der Datenexport aus Tabellen erheblich vereinfacht werden. Bei einem Tabellenfeld handelt es sich um eine Gruppe mit Spalten des gleichen Typs und mehreren Zeilen.

Es stehen folgende Typen von Tabellenspalten zur Verfügung:

  • Text
  • Auswahlfeld
  • Barcode
  • Bild

So erstellen Sie eine Tabelle:

  1. Wählen Sie das Tool [image] aus, und ziehen Sie um den Tabellenbereich einen Auswahlrahmen. Die Tabellenkopfzeile muss außerhalb des ausgewählten Bereichs liegen. In der Symbolleiste werden weitere Tools zur Tabellenverarbeitung angezeigt:
    Erstellen einer Tabellenspalte
    Erstellen von Trennlinien
    Entfernen von Trennlinien
  2. Grenzen Sie Tabellenzellen ab, indem Sie die erforderliche Anzahl Trennlinien erstellen. Wählen Sie zum Erstellen von Trennlinien das Tool [image] aus, und klicken Sie auf die Stelle, an der die Trennlinien eingefügt werden sollen. Setzen Sie zum Erstellen einer vertikalen Trennlinie den Mauszeiger in den Tabellenbereich, ziehen Sie den gepunkteten Zeiger bis zur gewünschten Stelle, und klicken Sie einmal mit der linken Maustaste. Führen Sie zum Erstellen einer horizontalen Trennlinie den gleichen Vorgang bei gedrückter Alt-Taste aus. Sie können Trennlinien auch automatisch erkennen lassen. Sie können auch festlegen, dass Trennlinien automatisch erkannt werden. Markieren Sie die erstellte Tabelle, und wählen Sie dann im Menü die Optionen Vertikale Trennlinien automatisch erkennen und Horizontale Trennlinien automatisch erkennen aus.
  3. Erstellen Sie Tabellenspalten. Wählen Sie dazu das Tool [image] aus, und klicken Sie in den Spaltenbereich. Wählen Sie in der Dropdownliste einen Spaltentyp aus.


ändern eines Feldnamens

So benennen Sie ein Feld um:

  • Klicken Sie in der Dokumentstruktur auf den entsprechenden Feldnamen, klicken Sie mit der rechten Maustaste, wählen Sie im Kontextmenü die Option Umbenennen aus, und geben Sie einen neuen Namen ein.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Name vorschlagen aus. Dem Feld wird ein Name zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Name aus Bild abrufen… aus. Markieren Sie anschließend mit dem Mauszeiger den erklärenden Text, der als Feldname verwendet werden kann. Daraufhin wird der ausgewählte Text als Feldname angezeigt.

Oder

  • öffnen Sie das Dialogfeld für die Feldeigenschaften, und ändern Sie den Namen auf der Registerkarte Allgemein.


Kopieren, Verschieben und Löschen von Feldern

Felder können kopiert, gelöscht, verschoben und geändert werden. Die Namen kopierter Felder sind durch eine unterschiedliche Nummerierung gekennzeichnet. Mehrere Felder können Sie durch Klicken bei gedrückter Strg-Taste markieren. Die ausgewählte Aktion wird dann auf alle markierten Felder angewendet.

Wenn Sie ein Feld löschen möchten, markieren Sie es, und drücken Sie Entf, oder wählen Sie im Kontextmenü die Option Löschen aus. Wenn Sie nur den Bereich löschen und das Feld in der Dokumentstruktur beibehalten möchten, drücken Sie Umschalt+Entf, oder wählen Sie im Kontextmenü des entsprechenden Felds die Option Bereich löschen aus. Siehe Felder ohne Bereich.


Felder ohne Bereich

Felder haben im Bild möglicherweise keinen Bereich. Die Namen der Felder ohne Bereich sind in der Liste durch ein rotes Sternchen gekennzeichnet. In diesen Feldern können beispielsweise Zwischenergebnisse aus Berechnungen gespeichert werden, die anhand der Werte der erkannten Felder durchgeführt werden. Sie können z. B. die Werte mehrerer Felder mithilfe der Regel zum Verbinden von Feldwerten kombinieren und das Ergebnis in einem Feld ohne Bereich speichern.

Felder ohne Bereich haben alle Eigenschaften des entsprechenden Feldtyps. Die Werte dieser Felder können ebenfalls exportiert werden.

Felder ohne Bereich können folgendermaßen erstellt werden:

  1. Klicken Sie im Dokumentvorlageneditor auf die Menüoption Einfügen, und erstellen Sie ein Feld mit dem gewünschten Feldtyp. Der Feldname wird in der Liste mit einem Sternchen angezeigt. Damit wird in der Dokumentstruktur ein Feld, jedoch kein Bereich im Bild erstellt.
  2. Die andere Möglichkeit besteht darin, den Bereich eines regulären Felds zu löschen. Markieren Sie das gewünschte Feld im Bild oder in der Liste, und wählen Sie im Kontextmenü die Option Bereich löschen aus. Der Bereich wird gelöscht, und der Name des Felds wird durch ein rotes Sternchen gekennzeichnet.

Wenn Sie einen Bereich für Felder erstellen möchten, die im Bild keinen Bereich haben, klicken Sie in der Symbolleiste auf [image], und markieren Sie den gewünschten Bereich mit dem Mauszeiger. Wenn die Liste Felder mit Sternchen enthält, werden Sie aufgefordert, ein Feld mit dieser Kennzeichnung auszuwählen.


Ausschließen eines Bereichs von der Erkennung

Manchmal ist es erforderlich, einen bestimmten Bereich von der Erkennung auszuschließen, z. B. einen Bereich mit erklärendem Text, der die Extraktion der Daten aus einem Feld erschwert.

Wenn Sie einen Bereich von der Erkennung ausschließen möchten, klicken Sie auf das Tool [image], und markieren Sie den auszuschließenden Bereich mit dem Mauszeiger.


Erstellen eines Felds mit einem nicht rechteckigen Bereich

Manchmal ist es notwendig, Felder mit nicht rechteckigen Bereichen zu erstellen, z. B. im folgenden Fragebogen:

So erstellen Sie einen nicht rechteckigen Feldbereich:

  1. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.
  2. Wählen Sie einen rechteckigen Bereich aus, in dem Sie Bereichsteile in der gewünschten Form hinzufügen oder entfernen können.
  3. Wählen Sie das Tool [image] aus, und markieren Sie den rechteckigen Bereich.
  4. So fügen Sie ein Bereichsfragment in den Bereich ein: Drücken Sie die Umschalttaste (der Mauszeiger wird als Pluszeichen angezeigt), und markieren Sie das entsprechende Fragment.
  5. So entfernen Sie ein Bereichsfragment: Drücken Sie Alt (der Mauszeiger wird als Minuszeichen angezeigt), und markieren Sie das entsprechende Fragment.


Felder mit mehreren Bereichen

Ein Feld kann mehrere Bereiche im Bild umfassen. Diese Bereiche können sich voneinander entfernt und auch auf verschiedenen Seiten befinden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert.

Es empfiehlt sich, bei Feldern, die sich auf mehreren Seiten befinden, mehrere Bereiche zu erstellen, z. B. bei großen Tabellen.

Beispiel anzeigen

So erstellen Sie ein Feld mit mehreren Bereichen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Bereich fortsetzen… aus.
  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Felder mit mehreren Instanzen

In Feldern können manche Elemente wiederholt auftreten. Dabei handelt es sich um Felder und Feldgruppen, die in einem Formular mehrfach vorkommen und ähnliche Objekte betreffen, z. B. die gleichen Details mehrerer Mitarbeiter, Kinder, Konten usw. Für diese Objekte werden Felder mit mehreren Instanzen erstellt.

Für jedes Feld können mehrere Instanzen festgelegt werden. Die zugehörigen Bereiche können voneinander entfernt und auch auf verschiedenen Seiten positioniert werden. Feldinstanzen weisen die gleichen Eigenschaften auf. Sie werden in separate Dateien oder Datenbanktabellen exportiert.

Sie können mehrere Instanzen einer Feldgruppe erstellen, wenn in einem Feld Gruppen mehrfach vorkommen.

Beispiel anzeigen

So erstellen Sie ein Feld mit mehreren Instanzen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Neue Instanz… aus.
  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Feldeigenschaften

Es ist sehr wichtig, dass die Eigenschaften jedes Felds korrekt konfiguriert werden. Feldeigenschaften wirken sich auf die Qualität beim Erkennen der Felder sowie darauf aus, ob die Werte der Felder exportiert und zur überprüfung an den Operator gesendet werden können. Einige Eigenschaften spielen bei der Datenerkennung eine große Rolle. Dies betrifft beispielsweise die Markierungsmethode eines Texteingabefelds. Wenn das Texteingabefeld falsch konfiguriert ist, wird die beim Scannen nicht ausgeblendete Markierung nicht von den Zeichen getrennt. Die Erkennung ist dadurch möglicherweise nicht zufriedenstellend.

Die verschiedenen Feldtypen verfügen jeweils über andere Eigenschaften. Wenn Sie in einem Bild ein Feld eines bestimmten Typs erstellen, werden dem Feld die entsprechenden Standardeigenschaften zugewiesen.

So können Sie Feldeigenschaften ändern:

  1. Markieren Sie den Feldnamen in der Dokumentstruktur oder den Feldbereich im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld.

über die folgenden Links erhalten Sie weitere Informationen zu den Feldeigenschaften:

Texteingabefelder
Auswahlfelder
Gruppen von Auswahlfeldern
Barcodes
Bilder
Tabellen
Feldgruppen


Texteingabefeld

Wenn Sie ein Textfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Datentypen
Erkennungseigenschaften
überprüfungseigenschaften
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem erklärenden Text für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch ändern des Feldnamens.
  • Beschriftung: Der Name des Felds, der im Datenformular angezeigt wird
  • Feldwert exportieren: Diese Option muss aktiviert sein, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z. B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Diese Option muss aktiviert sein, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Kann nicht leer sein: Aktivieren Sie diese Option, wenn es sich um ein erforderliches Feld handeln soll.
  • Schreibgeschützt: Aktivieren Sie diese Option, wenn das Feld nur zur Ansicht verfügbar sein soll, d. h. der Feldwert nicht geändert werden kann. Sie können diese Option für Felder aktivieren, deren Werte mithilfe einer Regel automatisch berechnet werden, z. B. Felder, in denen eine Summe gespeichert wird oder andere Felder zusammengefasst werden (siehe Regelbasierte Validierung).
  • Indexfeld: Aktivieren Sie diese Option, wenn Sie ein Feld zur Dokumentindizierung verwenden möchten. Beim Verarbeiten von Dokumenten können Sie dann den Wert des Felds für jedes Dokument anzeigen und Dokumente anhand des Feldwerts sortieren und suchen.
  • Kommentar: Hier können Sie Kommentare eingeben.


Datentypen für Texteingabefelder

Es ist sehr wichtig, dass Sie einem Texteingabefeld einen Datentyp zuweisen, sodass im Programm festgelegt wird, welche Daten im entsprechenden Feld angezeigt werden sollen: ausschließlich Zahlen, Buchstaben eines bestimmten Alphabets, Zeichen eines bestimmten Zeichensatzes oder ein Datum. Datentypen können äußerst flexibel festgelegt werden. Benutzer können in einer Liste verfügbarer Datentypen einen Datentyp auswählen sowie benutzerdefinierte Datentypen für bestimmte Tasks erstellen.

Bei der Angabe der Datentypen können Sie auch die Formatüberprüfung des Eingabewerts konfigurieren sowie Einschränkungen für den Wert festlegen, z. B. die Länge des Texts, Mindest- und Höchstwert für die Zahl, Zeitintervall und Datum.

Wenn der erkannte Feldwert während der Dokumentverarbeitung nicht mit dem festgelegten Datentyp übereinstimmt, wird eine Fehlermeldung angezeigt.

Der Datentyp für ein Texteingabefeld kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Text
  1. Wenn dieses Feld Text enthalten wird, wählen Sie die Option Text aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache oder die Verwendung von Wörterbüchern ändern oder einen genauer eingegrenzten Datentyp angeben möchten, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Für den Standardtexttyp (d. h., wenn die Option Allgemein in der Liste Inhaltseinstellungen ausgewählt ist) können Sie ein integriertes Wörterbuch und/oder ein benutzerdefiniertes Wörterbuch verwenden. In diesem Fall wird der Wert des Felds mithilfe dieser Wörterbücher überprüft.
      Wenn Sie ein integriertes Wörterbuch verwenden möchten, wählen Sie die Option Integriertes Wörterbuch verwenden.
      Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Texttyp für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Zahl
  1. Wenn dieses Feld einen Zahlenwert enthalten wird, wählen Sie die Option Zahl aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache oder die Ganzzahl in einen Bruch ändern oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. eine nur zweistellige Zahl oder eine römische Zahl), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie Ganzzahl, wenn das Feld eine Ganzzahl enthalten muss. Deaktivieren Sie diese Option, wenn das Feld einen Bruch enthalten muss.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für eine Ganzzahl oder einen Bruch wählen.
    • Der Typ für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich von Zahlen.
Wichtig: Verwenden Sie den Datentyp Zahl nicht für Felder mit Zahlen, bei denen es sich zwar formal um Zahlen handelt, die aber eigentlich als Codes verwendet werden (z. B. Kartennummern, Reisepassnummern usw.). Die Auswahl des Datentyps Zahl für diese Felder hat möglicherweise Fehler zur Folge (z. B. werden die Nullen am Anfang der Zeichenfolge entfernt). Erstellen Sie in solchen Fällen stattdessen einen benutzerdefinierten Texttyp, und legen Sie ein Alphabet von 0-9 fest (und fügen Sie ggf. einen regulären Ausdruck hinzu). Oder Sie verwenden trotzdem den Datentyp Zahl, stellen aber sicher, dass die Option Wert als Text verarbeiten aktiviert ist. Im letztgenannten Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur überprüfung des Werts verwendet werden und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Datum
  1. Wenn dieses Feld ein Datum enthalten wird, wählen Sie die Option Datum aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache oder die Reihenfolge der Datumskomponenten ändern, die Uhrzeit oder Wochentage hinzufügen oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. dass Monate als römische Zahlen dargestellt werden), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie die gewünschte Reihenfolge aus der Liste Reihenfolge der Datumskomponenten aus.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für Datumseinträge in Standardformaten wählen. Für den Standarddatentyp stehen folgende zusätzliche Optionen zur Verfügung:
      Kann Monate in Worten enthalten: Verwenden Sie diese Option, wenn die Monate auch in Wörtern geschrieben sein können, nicht nur in Zahlen.
      Kann Wochentag enthalten: Verwenden Sie diese Option, wenn Datumsangaben auch Wochentage enthalten können.
      Kann Uhrzeit enthalten: Verwenden Sie diese Option, wenn Datumsangaben auch die Uhrzeit enthalten können.
    • Der Datumstyp für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich von Datum.
Wichtig: Wenn das Datum nicht auf ein Standardformat reduziert werden kann oder Sie die Werte dieses Felds nicht als Datumsangaben verarbeiten werden, dann wählen Sie die Option Wert als Text verarbeiten. Im diesem Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur überprüfung des Werts verwendet und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Geldbetrag
  1. Wenn dieses Feld einen Geldbetrag enthalten wird, wählen Sie die Option Geldbetrag aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. einen Währungscode), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den Geldbetrag, wenn der Wert des Felds nur eine Zahl oder eine Zahl mit einem Standardwährungssymbol oder -code ist.
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Wichtig: Wenn der Geldbetrag nicht auf ein Standardformat reduziert werden kann oder Sie die Werte dieses Felds nicht als Geldbeträge verarbeiten werden, dann wählen Sie die Option Wert als Text verarbeiten. Im diesem Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur überprüfung des Werts verwendet und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Adresse
  1. Wenn dieses Feld eine Adresse enthalten wird, wählen Sie die Option Adresse aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. E-Mail-Adresse oder Postleitzahl), dann klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für die Adresse wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Name
  1. Wenn dieses Feld einen Namen enthalten wird, wählen Sie die Option Name aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. Nachname oder Vorname), dann klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den Namen wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Code
  1. Wenn dieses Feld einen Code aus Buchstaben und Ziffern enthalten wird, wählen Sie die Option Code aus der Liste Inhalt.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. eine Sozialversicherungsnummer), dann klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • änderung der Erkennungssprache für dieses Feld. Klicken Sie zum ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den alphanumerischen Code wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld AutoCorrect-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".


Erstellen benutzerdefinierter Datentypen

Wählen Sie zum Erstellen eines neuen Datentyps in den Feldeigenschaften auf der Registerkarte Datentyp das gewünschte Element aus der Liste Inhalt. Sie können jedes Element aus der Liste wählen, das der Semantik Ihres benutzerdefinierten Datentyps entspricht. Das hat zwar keinen Einfluss auf die Art des neuen Datentyps, aber er wird in der ausgewählten Kategorie gespeichert.

Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details.

Wählen Sie in dem daraufhin angezeigten Dialogfeld die Option Sonderformat im Feld Inhaltseinstellungen.

Klicken Sie auf die Schaltfläche Neu… rechts neben dem Feld Datentypen für ausgewählte Sprache.

Befolgen Sie die Anweisungen im Assistenten für neue Datentypen.

Im ersten Fenster des Assistenten wählen Sie aus, wie Ihre Daten erstellt werden sollen. Sie können einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks, eines Alphabets oder eines vorhandenen Datentyps erstellen (z. B., indem Sie gewünschte Zeichen zu seinem Alphabet hinzufügen oder sein Wörterbuch erweitern).

So erstellen Sie einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks oder eines Alphabets:

  1. Wählen Sie Neuer Datentyp beruht auf und dann die Grundlage, die für Ihren neuen Datentyp verwendet werden soll: ein Wörterbuch, ein regulärer Ausdruck oder ein Alphabet. Wählen Sie dann die Sprache (Gebietsschema) für Ihren Datentyp, und klicken Sie auf Weiter.
  2. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Wörterbuchs zu erstellen, dann fordert Sie der Assistent im nächsten Fenster dazu auf, die Art des Wörterbuchs auszuwählen, das verwendet werden soll.
    Wählen Sie Integriertes Wörterbuch verwenden, wenn Sie das integrierte Wörterbuch für die Sprache verwenden möchten, die Sie im Fenster zuvor ausgewählt haben. Wenn Sie prüfen möchten, ob das Wörterbuch ein bestimmtes Wort enthält, dann klicken Sie auf Anzeigen…, und geben Sie das Wort ein. Durch Klicken auf die Schaltfläche Anzeigen werden entweder die gebeugten Formen des Worts angezeigt oder eine Warnmeldung, die besagt, dass es dieses Wort im Wörterbuch nicht gibt.
    Wählen Sie Benutzerdefinierte Wörterbücher verwenden, wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, und klicken Sie auf Bearbeiten…, um das entsprechende Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an). Klicken Sie auf Weiter.
  3. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines regulären Ausdrucks zu erstellen, wird der Assistent Sie dazu auffordern, einen regulären Ausdruck einzugeben. Verwenden Sie die Schaltfläche [image] rechts neben dem Feld für den regulären Ausdruck, um Ihren regulären Ausdruck zusammenzusetzen. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken. Klicken Sie auf Weiter.
  4. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Alphabets zu erstellen, oder wenn Sie in Ihrem regulären Ausdruck Zeichen verwendet haben, die nicht Teil des Alphabets der gewählten Sprache sind, dann werden Sie vom Assistenten aufgefordert, ein Alphabet für Ihren Datentyp anzugeben. Sie können die gewünschten Zeichen entweder direkt über die Tastatur eingeben oder auf Anpassen… klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Wenn Sie Satzzeichen und ausgeschlossene (unzulässige) Zeichen einfügen möchten, klicken Sie auf Erweiterte Parameter…. Sie können die unzulässigen Zeichen entweder direkt über die Tastatur eingeben oder auf die Schaltfläche auf der rechten Seite klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Klicken Sie auf Weiter.

  5. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

So erstellen Sie einen neuen Datentyp auf der Grundlage eines vorhandenen Datentyps:

  1. Wählen Sie im ersten Fenster des Assistenten Datentyp beruht auf vorhandenen Typen. Wählen Sie die gewünschte(n) Sprache(n) aus, und klicken Sie auf Weiter.
  2. Wählen Sie im nächsten Fenster den oder die Quelldatentypen aus, welche die Grundlage für Ihren neuen Datentyp bilden sollen. Diejenigen Datentypen, die den ausgewählten Sprachen entsprechen, werden auf der linken Seite des Dialogfelds in der Liste Verfügbare Datentypen aufgeführt. Der Ordner Text enthält die natürlichen Sprachen, die im ersten Fenster ausgewählt wurden. Der Ordner Benutzerdefiniert enthält die Datentypen, die von Benutzern erstellt wurden. Die anderen Ordner enthalten die Datentypen entsprechend der Kategorie und den Sonderformaten für spezielle Inhalte.
    Sie wählen einen Quelldatentyp aus, indem Sie ihn im Feld Verfügbare Datentypen markieren (halten Sie die Strg-Taste gedrückt, um mehrere Typen zu markieren) und dann auf Hinzufügen -> klicken, um ihn in den rechten Bereich zu übertragen. Klicken Sie auf Weiter.
  3. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

Der neu erstellte Datentyp wird in der Liste der vordefinierten Datentypen angezeigt, wenn Sie den Inhalt auswählen, der beim Erstellen des Datentyps gewählt wurde.

So legen Sie den neu erstellten Datentyp für Ihr Feld fest:

  1. Wählen Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp das gewünschte Element in der Liste Inhalt aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details.
  3. Wählen Sie in der Liste Inhaltseinstellungen die Option Sonderformat.
  4. Wählen Sie in der nun angezeigten Liste den Datentyp aus, den Sie erstellt haben (benutzerdefinierte Datentypen sind mit einem speziellen Symbol gekennzeichnet), und klicken Sie auf OK.


Einschränkungen für den Wertebereich des Datentyps "Text"

Im Dialogfeld Validierungseinstellungen können Sie Einschränkungen für den Wertebereich von Text festlegen, der in diesem Feld eingegeben wird.

Hinweis: Das Programm behandelt nicht nur Datentypen mit Textinhalten als Texttyp, sondern auch alle Datentypen mit anderen Inhalten, für die die Option Wert als Text verarbeiten aktiviert wurde.

  • Maximale Länge: Geben Sie die maximale Länge für Text in diesem Feld an.
  • Regulärer Ausdruck: Aktivieren Sie diese Option, wenn Sie die Feldwerte mit einem regulären Ausdruck überprüfen möchten.

    über die Schaltfläche [image] können Sie einen regulären Ausdruck korrekt festlegen. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken.

  • Zulässige Werte: Wählen Sie diese Option aus, wenn Sie eine Liste zulässiger Werte für dieses Feld angeben möchten. Wenn Sie einen Wert hinzufügen möchten, klicken Sie auf Hinzufügen…, und geben Sie im daraufhin geöffneten Dialogfeld den entsprechenden Wert ein. Wenn Sie einen Wert bearbeiten möchten, klicken Sie auf Bearbeiten… Wenn Sie einen Wert löschen möchten, klicken Sie auf Löschen.
  • Validierungsfehler als Warnung behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.


Einschränkungen für den Wertebereich von Zahlen

So geben Sie Einschränkungen für den Wertebereich von Zahlen an:

  1. Aktivieren Sie die Option Einschränkungen verwenden.
  2. Geben Sie die Höchst- und Mindestwerte für die Zahlen an.
  3. Validierungsfehler als Warnung behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.

Bei der Dokumentverarbeitung überprüft die Software, ob der eingegebene Wert im angegebenen Intervall liegt.


Einschränkungen für den Wertebereich von Datum

Im Dialogfeld Validierungseinstellungen können Sie das Intervall für das in diesem Feld eingegebene Datum festlegen.

  1. Aktivieren Sie die Option Datum muss im folgenden Intervall liegen.
  2. Wählen Sie Fest um ein festes Zeitintervall festzulegen, oder wählen Sie Relativ zum Verifizierungsdatum, um ein Zeitintervall einzurichten, das sich relativ zum Datum der Dokumentüberprüfung verhält.
  3. Geben Sie den Beginn und das Ende des Zeitraums ein.
  4. Validierungsfehler als Warnung behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.


Verarbeiten der eingegebenen Werte

Für jeden Datentyp können Sie festlegen, dass die eingegebenen Werte automatisch verarbeitet und dabei folgende Schritte ausgeführt werden: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben, automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung von Feldwerten auf der Registerkarte Datentyp des Dialogfelds für die Feldeigenschaften auf die Schaltfläche Bearbeiten… rechts neben dem Feld AutoCorrect-Optionen.

Wählen Sie die gewünschten Optionen für die automatische Verarbeitung aus.

Wenn die Option AutoCorrect erst nach Erkennung anwenden ausgewählt ist, wird die automatische Verarbeitung nur einmal ausgeführt, nachdem der Feldwert erkannt worden ist. Andernfalls wird die automatische Verarbeitung jedes Mal ausgeführt, wenn der Wert des Felds geändert wird
  • Um die Zeichen im erkannten Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Zeichen ersetzen. Im daraufhin angezeigten Dialogfeld können Sie Zeichen für die automatische Ersetzung hinzufügen. Sofern die angegebenen Zeichen in den erkannten Feldwerten auftreten, werden sie automatisch ersetzt.
  • Um den gesamten erkannten Feldwert oder einzelne Wörter im Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Text ersetzen.

    Im angezeigten Dialogfeld können Sie Wörter und Ausdrücke für die automatische Ersetzung hinzufügen. Um den gesamten Feldwert zu ersetzen, aktivieren Sie die Option Gesamten Feldwert ersetzen. In diesem Fall wird die automatische Ersetzung nur dann durchgeführt, wenn das angegebene Wort oder der Ausdruck dem Wert des gesamten Felds entspricht. Zur Ersetzung einzelner Wörter aktivieren Sie die Option Gefundene Wörter ersetzen.

    Wenn Sie die Option Genau aktivieren, sucht das Programm nach genau dem eingegebenen Wort oder Ausdruck und ersetzt diesen. Wenn Sie jedoch Annähernd aktivieren, sucht das Programm nach einem dem eingegebenen Wort oder Ausdruck ähnelnden Wert und ersetzt diesen. Die Anzahl der zulässigen Fehler hängt von der Länge des Worts ab.

    Aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung, damit bei der Ersetzung von Wörtern oder Ausdrücken die Groß- und Kleinschreibung berücksichtigt wird.

  • Wählen Sie in der Dropdownliste Groß-/Kleinschreibung ändern eines der Verfahren für die Buchstabenumwandlung aus:

    Keine Festlegung: Es erfolgt keine Umwandlung.

    GROSSSCHREIBUNG: Alle Buchstaben werden in Großschreibung geändert.

    kleinschreibung: Alle Buchstaben werden in Kleinschreibung geändert.

    Erster Buchstabe groß: Der erste Buchstabe wird in einen Großbuchstaben und die übrigen werden in Kleinbuchstaben geändert.

  • Überschüssige Leerzeichen entfernen: Aktivieren Sie diese Option, wenn Leerzeichen entfernt werden sollen.


Erkennungsoptionen für Textfelder

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte werden die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Keine Erkennung (Manueller Eingabeblock - wird manuell eingegeben): Aktivieren Sie diese Option, wenn das Feld aus einem bestimmten Grund nicht erkannt wird (z. B. wenn der Text im Feld verschwommene Zeichen enthält) und der Operator den Wert manuell eingeben muss. In diesem Fall müssen Sie die anderen Erkennungseigenschaften nicht konfigurieren, da das Feld nicht erkannt wird. Der Operator wird während der überprüfung aufgefordert, den Feldwert einzugeben.

  • ICR (Handschrift): Aktivieren Sie diese Option, wenn statischer Text in diesem Feld handschriftlich vorliegt.

  • OCR (Druck): Aktivieren Sie diese Option, wenn statischer Text in diesem Feld gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (typografischer Text, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

  • Erweitert: über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben.

  • Markierungstyp: Wählen Sie den Markierungstyp aus. Zur Vereinfachung können Sie in der Dropdownliste Beispiele auswählen. Wenn die Markierung beim Scannen verschwindet, wird für die Markierung ein gleicher Abstand zwischen den Zeichen verwendet (graue Felder). Wenn die Markierung beim Scannen nicht verschwindet und für die Leerzeichen zwischen den Zeichen in Zellen unterteilt wird, müssen Sie die Gesamtanzahl der Zellen eingeben. Wenn Felder mit dieser Markierung im Programm automatisch erkannt werden, wird auch die Anzahl der Zellen automatisch festgelegt.

  • Groß-/Kleinschreibung: Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im Feld aus. Wenn sowohl Groß- als auch Kleinschreibung möglich ist, lassen Sie die Option Automatisch aktiviert.

  • Ausrichtung: Geben Sie die Ausrichtung des Texts an.

  • Aktivieren Sie bei einzeiligen Feldern die Option Eine Zeile.

  • Aktivieren Sie bei Feldern, die immer nur ein Wort enthalten, die Option Ein Wort.

  • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Bei der überprüfung handelt es sich um den Vorgang, bei dem erkannte Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, sodass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Vorlage können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene überprüfungsoptionen festlegen.

Wählen Sie in der Dropdownliste die entsprechende Option aus:

  • Überprüfen nicht eindeutig erkannte Zeichen: Die Zeichen im Feld werden zur überprüfung weitergeleitet, wenn sie nicht eindeutig erkannt wurden. Dieser Wert wird allen Feldern standardmäßig zugewiesen.
  • Überprüfen alle Zeichen: Die Zeichen im Feld werden zur überprüfung weitergeleitet. Sie können den Wert alle auswählen, wenn bei den Werten in einem Feld keine Fehler zugelassen sind.
  • Überprüfen kein Zeichen: Die Zeichen im Feld werden nicht zur überprüfung weitergeleitet.

Folgende Optionen sind verfügbar:

  • Bei Gruppenüberprüfung einschließen: Aktivieren Sie diese Option, um die Zeichen in einem Feld bei der Gruppenüberprüfung einzubinden. Obwohl alle Felder in die Gruppenüberprüfung eingebunden werden können, sollten nur Auswahlfelder und Felder mit Zahlen zur Gruppenüberprüfung gesendet werden. Im Gegensatz dazu empfiehlt es sich, Buchstaben im Kontext des entsprechenden Feldwerts zu überprüfen.
  • Bei Feldüberprüfung einschließen: Aktivieren Sie diese Option, um das Feld in die Feldüberprüfung einzubinden.


Auswahlfelder

Wichtig: Die Eigenschaften von Auswahlfeldern, die in Gruppen zusammengefasst werden, werden für die gesamte Gruppe von Auswahlfeldern konfiguriert. Wenn Sie die Eigenschaften eines Auswahlfelds bearbeiten, das einer Gruppe angehört, wird ein Dialogfeld zum Bearbeiten der Eigenschaften der Gruppe geöffnet.

Wenn Sie ein Auswahlfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
überprüfungseigenschaften
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem erklärenden Text für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch ändern des Feldnamens.
  • Beschriftung: Der Name des Felds, der im Datenformular angezeigt wird
  • Feldwert exportieren: Diese Option muss aktiviert sein, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z. B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Diese Option muss aktiviert sein, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Schreibgeschützt: Aktivieren Sie diese Option, wenn das Feld nur zur Ansicht verfügbar sein soll, d. h. der Feldwert nicht geändert werden kann. Sie können diese Option für Felder aktivieren, deren Werte mithilfe einer Regel automatisch berechnet werden, z. B. Felder, in denen eine Summe gespeichert wird oder andere Felder zusammengefasst werden (siehe Regelbasierte Validierung).
  • Kommentar: Hier können Sie Kommentare eingeben.


Datentypen für Auswahlfelder

Der Datentyp für Auswahlfelder kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Mit dem Datentyp für Auswahlfelder werden die Werte festgelegt, die dem Auswahlfeld zugewiesen werden, wenn das Auswahlkästchen aktiviert oder deaktiviert ist.

Wählen Sie die entsprechenden Optionen für die Werte des Auswahlfelds aus:

  • Ja/Nein: Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "Ja". Wenn es deaktiviert ist, lautet der Wert "Nein".
  • 1/0: Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "1". Wenn es deaktiviert ist, lautet der Wert "0".
  • <Auswahlfeldname>/Leer: Wenn das Auswahlkästchen aktiviert ist, entspricht der Feldwert dem Namen des Auswahlfelds. Wenn das Auswahlkästchen deaktiviert ist, wird dem Feld ein leerer Wert zugewiesen.
  • Benutzerdefiniert: Durch Aktivieren dieser Option können Sie benutzerdefinierte Werte eingeben. Ausgewählt: Aktiviertes Auswahlkästchen. Nicht ausgewählt: Deaktiviertes Auswahlkästchen.


Erkennungseigenschaften für Auswahlfelder

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte werden die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Auswahlfeldtyp: Wählen Sie den Auswahlfeldtyp aus. Diese Eigenschaft ist sehr wichtig für die korrekte Erkennung von Auswahlfeldern.

    Quadrat: Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder in begrenzten quadratischen Rahmen positioniert werden.

    Ohne Rahmen: Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder ohne Rahmen vor einem weißen Hintergrund positioniert werden.

    Automatisch: Wenn Sie diesen Typ auswählen, wird der Auswahlfeldtyp automatisch festgelegt.
    Wichtig: Beachten Sie, dass in diesem Fall das Auswahlfeld im Formular nicht ausgewählt werden muss. Das Programm erkennt, ob das Auswahlfeld ausgewählt wird oder nicht, indem es das Abbild des Auswahlfelds in einem verarbeiteten Dokument mit dem Abbild des leeren, zum Erstellen der Vorlage verwendeten Formulars vergleicht.

  • Korrekturen zulassen: Aktivieren Sie diese Option, wenn Sie Korrekturen an den Auswahlfeldern zulassen möchten. In diesem Fall werden durchgestrichene Auswahlfelder als nicht ausgewählt eingestuft. Wenn Sie jedoch den Auswahlfeldtyp Automatisch ausgewählt haben, können Sie keine Korrekturen der entsprechenden Auswahlfelder zulassen.

    • Sie können folgende Optionen für die Verarbeitung des Feldbilds festlegen:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Bei der überprüfung handelt es sich um den Vorgang, bei dem erkannte Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, sodass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Vorlage können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene überprüfungsoptionen festlegen.

Wählen Sie in der Dropdownliste die entsprechende Option aus:

  • Überprüfen nicht eindeutig erkannte Zeichen: Die Zeichen im Feld werden zur überprüfung weitergeleitet, wenn sie nicht eindeutig erkannt wurden. Dieser Wert wird allen Feldern standardmäßig zugewiesen.
  • Überprüfen alle Zeichen: Die Zeichen im Feld werden zur überprüfung weitergeleitet. Sie können den Wert alle auswählen, wenn bei den Werten in einem Feld keine Fehler zugelassen sind.
  • Überprüfen kein Zeichen: Die Zeichen im Feld werden nicht zur überprüfung weitergeleitet.

Folgende Optionen sind verfügbar:

  • Bei Gruppenüberprüfung einschließen: Aktivieren Sie diese Option, um die Zeichen in einem Feld bei der Gruppenüberprüfung einzubinden. Obwohl alle Felder in die Gruppenüberprüfung eingebunden werden können, sollten nur Auswahlfelder und Felder mit Zahlen zur Gruppenüberprüfung gesendet werden. Im Gegensatz dazu empfiehlt es sich, Buchstaben im Kontext des entsprechenden Feldwerts zu überprüfen.


Gruppen von Auswahlfeldern

Wichtig: Gruppeneigenschaften gelten für alle Auswahlfelder, die einer Gruppe von Auswahlfeldern angehören.

Der Wert einer Gruppe von Auswahlfeldern ist eine Liste mit den Namen der ausgewählten Auswahlfelder, die durch ein Semikolon (;) getrennt sind, oder eine leere Zeichenfolge, wenn keine Auswahlfelder ausgewählt wurden.

Wenn Sie eine Gruppe von Auswahlfeldern erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
überprüfungseigenschaften
Regelbasierte Validierung


Datentypen für Gruppen von Auswahlfeldern

Der Datentyp für eine Gruppe von Auswahlfeldern kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Leere Auswahl zulassen: Aktivieren Sie diese Option, wenn mindestens ein Auswahlkästchen in der Gruppe aktiviert sein muss. Wenn kein Auswahlkästchen in der Gruppe aktiviert ist, wird eine entsprechende Warnmeldung angezeigt.

Mehrfachauswahl zulassen: Aktivieren Sie diese Option, damit mehrere Auswahlkästchen in der Gruppe aktiviert werden können. Wenn die Option deaktiviert ist, wird eine Warnmeldung angezeigt, wenn mehrere Auswahlkästchen in der Gruppe aktiviert wurden.

Wenn Sie den Namen eines Auswahlfelds ändern möchten, markieren Sie die entsprechende Zeile, und klicken Sie auf Bearbeiten…. Geben Sie im daraufhin geöffneten Dialogfeld einen neuen Namen für das Auswahlfeld sowie einen neuen Namen ein, der dem Auswahlkästchen beim Exportieren zugewiesen wird.

Sie können die zu exportierenden Werte für Fälle auswählen, in denen keine Auswahlfelder aktiviert sind, und für Fälle, in denen mehrere Auswahlfelder aktiviert sind. Wählen Sie hierzu <Es wurde kein Objekt ausgewählt.> bzw. <Mehrere Objekte…> aus der Liste, klicken Sie auf Bearbeiten…, geben Sie in dem dann angezeigten Dialogfeld den gewünschten Wert in das Feld Exportierter Wert ein. Wenn keine Exportwerte festgelegt wurden, passiert Folgendes: a) Es wird eine leere Zeichenfolge exportiert, wenn keine Auswahlfelder aktiviert wurden, oder b) die Werte der aktivierten Auswahlfelder werden angegeben (getrennt durch Kommas), wenn mehrere Auswahlfelder aktiviert sind.

Erstellen einer Gruppe von Auswahlfeldern


Barcode

Wenn Sie ein Barcodefeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften.

Wichtig: Ein Barcode kann sowohl als Feld als auch als statisches Element hervorgehoben werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Vorlagenzuordnung oder -identifizierung vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Feldeigenschaften beschrieben. Siehe auch Ankerbarcode.

Allgemeine Eigenschaften
Erkennungseigenschaften
überprüfungseigenschaften
Regelbasierte Validierung


Barcodeerkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte werden die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Keine Erkennung (Manueller Eingabeblock - wird manuell eingegeben): Aktivieren Sie diese Option, wenn der Barcodewert vom Operator manuell eingegeben wird. In diesem Fall müssen Sie die restlichen Erkennungseigenschaften nicht festlegen.
  • Codetyp: Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt).
  • Ausrichtung: Geben Sie die Ausrichtung des Barcodes an.

Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Die überprüfung ist der Vorgang, bei dem die erkannten Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, sodass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Vorlage können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene überprüfungsoptionen festlegen.

Wählen Sie in der Dropdownliste die entsprechende Option aus:

  • Überprüfen nicht eindeutig erkannte Zeichen: Die Zeichen im Feld werden zur überprüfung weitergeleitet, wenn sie nicht eindeutig erkannt wurden. Dieser Wert wird allen Feldern standardmäßig zugewiesen.
  • Überprüfen alle Zeichen: Alle Zeichen im Feld werden zur überprüfung weitergeleitet. Sie können den Wert alle auswählen, wenn bei den Werten in einem Feld keine Fehler zugelassen sind.
  • Überprüfen kein Zeichen: Die Zeichen im Feld werden nicht zur überprüfung weitergeleitet.

Aktivieren Sie die folgende Option:

  • Bei Feldüberprüfung einschließen: Damit wird das Feld in die Feldüberprüfung eingebunden.


Bilder

Bei der Erstellung werden einem Bild Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst vier Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Erkennungseigenschaften
Exportieren von Bildern
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem erklärenden Text für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch ändern des Feldnamens.
  • Beschriftung: Der Name des Felds, der im Datenformular angezeigt wird
  • Feldwert exportieren: Aktivieren Sie diese Option, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z. B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Aktivieren Sie diese Option, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Kommentar: Hier können Sie Kommentare eingeben.


Bilderkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt.

  • Von Erkennung ausschließen: Aktivieren Sie diese Option, wenn der Bereich eines Bildfelds von den Erkennungsbereichen der anderen Felder ausgeschlossen werden soll. (Diese Option ist nur bei Bildfeldern verfügbar, um die Kompatibilität mit Vorlagen von FormReader 6.5 sicherzustellen.)


Exportieren von Bildern

In einer Dokumentvorlage können Sie für jedes Bild die Exportoptionen auswählen. Klicken Sie zum Auswählen der Bildexportoptionen mit der rechten Maustaste in das gewünschte Feld, wählen Sie Eigenschaften…, und klicken Sie auf die Registerkarte Exportieren. Folgende Optionen stehen zur Auswahl:

  • Dateityp: (TIFF, JPEG, BMP, JPEG2000, PCX Packbits, PNG).
  • Qualität: Für TIFF-, JPEG-, und JPEG2000-Dateien können Sie die Qualität der erzeugten Datei auswählen: von "Beste" bis "Gering".
  • Farbtyp: Farbe, Graustufen, Raster (S/W).

Sie können auch die Auflösung des resultierenden Bildes ändern: Aktivieren Sie die Option Auflösung ändern in, und geben Sie entweder die entsprechende Auflösung ein, oder wählen Sie eine in der Liste aus.


Tabellen

Wenn Sie eine Tabelle erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Spalten
Regelbasierte Validierung


Tabellenspalten

Auf der Registerkarte Spalten sind die Spalten der entsprechenden Tabelle aufgeführt. Jede Tabellenspalte ist einem bestimmten Feldtyp zugewiesen (siehe Erstellen einer Tabelle) und verfügt über für diesen Feldtyp spezifische Eigenschaften.

So bearbeiten Sie die Eigenschaften einer Tabellenspalte:

  1. Wählen Sie die entsprechende Spalte in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….


Feldgruppe

Wenn Sie eine Feldgruppe erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Felder
Regelbasierte Validierung


Gruppenfelder

Auf der Registerkarte Felder wird eine Liste der Felder der entsprechenden Gruppe angezeigt.

So bearbeiten Sie die Eigenschaften eines dieser Felder:

  1. Wählen Sie den Namen des entsprechenden Felds in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….

Erstellen einer Feldgruppe


Regelbasierte Validierung

Regeln erweitern die Möglichkeiten der automatischen Ergebnisüberprüfung. Mit Regeln können Einschränkungen für Daten festgelegt werden, z. B. Bedingungen, die Werte in bestimmten Feldern erfüllen müssen.

Wenn die Werte in Dokumenten die jeweiligen Bedingungen nicht erfüllen, werden die entsprechenden Seiten durch eine Warnung gekennzeichnet. Regeln werden hauptsächlich zur überprüfung der Datenintegrität in Dokumenten eingesetzt.

Sie können zudem eingegebene Werte mithilfe von Regeln verarbeiten, z. B. Verbinden von Werten mehrerer Felder oder Ersetzen erkannter Werte durch entsprechende Werte aus der Datenbank.

Mithilfe von ABBYY FlexiCapture 8.0 Professional können Sie folgende Regeltypen erstellen:

  • Summenüberprüfung: überprüfen der Summe mehrerer Felder. Die Summe der Werte bestimmter Felder wird mit einer festgelegten Zahl oder dem Wert in einem anderen Feld verglichen.
  • Felder vergleichen: Vergleichen der Werte mehrerer Felder.
  • Datenbanküberprüfung: überprüfen eingegebener Werte durch den Vergleich mit Werten aus einer bestimmten Datenbank.
  • Felder verbinden: Zusammenführen der Werte mehrerer Felder. Beim Verbinden von Feldern können beliebige Trennzeichen hinzugefügt werden.
  • Skript: Der Benutzer kann Einschränkungen mithilfe eines Skripts festlegen.
  • Summe in Zahlen und Summe in Worten (Russisch): Vergleicht eine Zahlensumme mit der Summe der geschriebenen Wörter (nur für die russische Sprache)

Regeln kann ein Fehler- oder Warnstatus zugewiesen werden. Wenn eine Bedingung nicht erfüllt wird, wird das entsprechende Feld durch eine rote Markierung (Fehler) oder eine gelbe Markierung (Warnung) gekennzeichnet. Siehe Regelbasierte Validierung.

Regeln können auf der Registerkarte Regeln des Dialogfelds für die Objekteigenschaften (Feld, Bereich, Dokument usw.) definiert werden.

In der hierarchischen Struktur werden Regeln auf der Ebene des Objekts gespeichert, in dem sie erstellt wurden. Dabei kann es sich um ein Feld, einen Vorlagenbereich oder eine Vorlage handeln. In den meisten Fällen spielt die Ebene, in der Regeln gespeichert sind, keine Rolle. Wenn Sie jedoch eine Vorlage mit einer komplexen Struktur, d. h. mit Feldgruppen oder wiederholt vorkommenden Elementen, erstellen, müssen Sie auf den Speicherort der Regeln achten. Wenn Sie beispielsweise bei einer Vorlage mit einer Feldgruppe, bei der bestimmte Felder mit einer Regel verknüpft sind, eine neue Instanz der Gruppe erstellen, wird die Regel im neuen Objekt nur kopiert und erfüllt, wenn sie in der Gruppe oder einem der zugehörigen Felder und nicht auf einer höheren Ebene gespeichert ist. Im Dialogfeld für die Objekteigenschaften können Sie Regeln anzeigen, die mit dem entsprechenden Objekt verwendet werden oder in diesem Objekt und den untergeordneten Objekten gespeichert sind. Sie können die Regeln angeben, die angezeigt werden sollen, indem Sie in der Dropdownliste Anzeigen in Liste eine der folgenden Optionen auswählen:

  • Regeln zur Verarbeitung des Objekts: Die für das aktuelle Objekt geltenden Regeln werden angezeigt (d. h. das Objekt, dessen Eigenschaftendialogfeld geöffnet ist).
  • Gespeicherte Regeln im Objekt: Die im aktuellen Objekt gespeicherten Regeln werden angezeigt.
  • Gespeicherte Regeln im Objekt und den zugehörigen untergeordneten Objekten: Die im aktuellen Objekt und den zugehörigen untergeordneten Objekten gespeicherten Regeln werden angezeigt (dies sind bei einer Feldgruppe die in der Gruppe und allen zugehörigen Feldern gespeicherten Regeln).

Hinweis: Neue Regeln können nur im Anzeigemodus Regeln zur Verarbeitung des Objekts oder Gespeicherte Regeln im Objekt und den zugehörigen untergeordneten Objekten erstellt werden. Im Anzeigemodus Regeln zur Verarbeitung des Objekts kann hingegen keine neue Regel erstellt werden.

Jede Regel verfügt über einen Fehler- oder Warnstatus. Wenn Sie Dokumente mit Regelfehlern exportieren, wird eine Fehlermeldung angezeigt. Regelwarnungen haben keine Auswirkungen auf den Exportvorgang.

Summenüberprüfung
Felder vergleichen
Datenbanküberprüfung
Felder verbinden
Summe in Zahlen und Summe in Worten

Festlegen einer Regel mithilfe eines Skripts


Regel zum überprüfen von Wertsummen

Mit dieser Regel wird die Summe der Werte mehrerer Felder überprüft. Die Summe der Werte bestimmter Felder wird mit einer festgelegten Zahl oder dem Wert in einem anderen Feld verglichen. Wenn ein Dokument beispielsweise Felder für Gehalt, Zulage und andere Ausgleichszahlungen sowie ein Feld für die Gesamtsumme enthält, können Sie eine Regel definieren, mit der überprüft wird, ob die Summe der Feldwerte mit der Gesamtsumme im Ergebnisfeld übereinstimmt. Wenn dies nicht der Fall ist, wird eine Fehlermeldung angezeigt.

So erstellen Sie eine Regel für die Summenüberprüfung:

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summenüberprüfung aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Fügen Sie in der Liste Feldwerte zusammenfassen die Felder ein, für die die Summe der entsprechenden Werte überprüft werden soll. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein.
  7. Aktivieren Sie eine der folgenden Optionen:
    • Feld: Vergleich der Summe mit dem Wert des Ergebnisfelds. Wählen Sie den Namen des Felds über die Schaltfläche Auswählen… aus.
    • Nummer: Vergleich der Summe mit der angegebenen Zahl. Geben Sie die entsprechende Zahl ein.
  8. Dezimalwert der Vergleichswerte: Geben Sie die Anzahl der Dezimalstellen nach dem Dezimalzeichen der Zahl ein, um die Vergleichsgenauigkeit festzulegen.
  9. Aktivieren Sie die Option Mindestens zwei zu addierende Elemente ungleich Null, wenn mindestens zwei nicht leere Elemente addiert werden sollen.
  10. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel zum Vergleichen mehrerer Feldwerte

Diese Regel dient zur überprüfung von Werten mehrerer Felder. Mithilfe der Regel kann ein Dokument mit mehreren Feldern überprüft werden, deren Felder identisch sein müssen. Wenn die Werte nicht übereinstimmen, wird für das Dokument eine Regelfehlermeldung angezeigt.

So erstellen Sie eine Regel zum Vergleichen von Werten:

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder vergleichen aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Fügen Sie in der Liste Zu vergleichende Felder die Felder ein, deren Werte verglichen werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein.
  7. Wählen Sie den übereinstimmungstyp aus:
    • Genau: Exakte übereinstimmung der Werte.
    • Annähernd: Annähernde übereinstimmung der Werte. In diesem Fall werden die Felder verglichen, ohne dass die Groß- und Kleinschreibung oder Leerzeichen berücksichtigt werden. Fehler sind für Feldwerte mit mehr als vier Zeichen zulässig.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel für die Datenbanküberprüfung

Bei der Datenbanküberprüfung von Feldwerten werden die erkannten Feldwerte mit Werten in der Datenbanktabelle verglichen. Die überprüfung gilt als erfolgreich, wenn zwei Werte übereinstimmen. Bei einer Nichtübereinstimmung wird eine Regelfehlermeldung angezeigt.

So erstellen Sie eine Regel für die Datenbanküberprüfung:

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Datenbanküberprüfung aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Stellen Sie eine Verbindung mit einer Datenbank her. Die entsprechenden Einstellungen können im Dialogfeld Eigenschaften von Datenverbindung festgelegt werden. Dieses Dialogfeld wird durch Klicken auf die Schaltfläche Festlegen… geöffnet.
  7. Wählen Sie in der Liste ein Datenbankschema und eine Datenbanktabelle aus.
  8. Ordnen Sie die Felder in der Dokumentvorlage den Feldern in der Datenbanktabelle zu. Klicken Sie dazu auf die Schaltfläche Hinzufügen…. Das Dialogfeld Feldverknüpfung wird geöffnet. Wählen Sie in der Liste ein Feld in der Dokumentvorlage und das entsprechende Feld in der Datenbanktabelle aus. Wählen Sie den übereinstimmungstyp aus:
    • Genau: Die Feldwerte müssen genau übereinstimmen.
    • Annähernd: Die Feldwerte müssen teilweise übereinstimmen. Hier wird nach ähnlichen Wörtern gesucht, bei denen im Verhältnis zum gesuchten Begriff die wenigsten Buchstaben hinzugefügt, entfernt oder ersetzt werden müssen. Die Anzahl der zulässigen Fehler hängt von der Länge des gesuchten Begriffs ab. Aktivieren Sie die Option Feldwert aus Datenbank kopieren, wenn der Feldwert im Dokument durch den entsprechenden Wert aus der Datenbank ersetzt werden soll.
    • Nicht vergleichen: Die Werte werden nicht verglichen. Der Feldwert wird durch einen Wert aus der Datenbank ersetzt (Option Feldwert aus Datenbank kopieren ist aktiviert).
  9. über die Schaltflächen Hinzufügen…, Bearbeiten… und Löschen können die Verknüpfungen von Feldern hinzugefügt, bearbeitet oder entfernt werden.


Regel zum Verbinden von Feldwerten

Diese Regel dient zum Verbinden von Werten mehrerer Felder. Verbundene Feldwerte können durch einen Punkt, ein Leerzeichen oder andere Trennzeichen getrennt werden.

So erstellen Sie eine Regel zum Verbinden von Werten:

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder verbinden aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter. Für diese Regel wird eine Fehlermeldung angezeigt, wenn beispielsweise eines der Felder aus der Vorlage entfernt wurde.
  6. Fügen Sie in der Liste Zu verbindende Felder die Felder ein, die verbunden werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein. Wählen Sie Ergebnisfeld aus, d. h. ein Feld, in dem das Ergebnis der verbundenen Feldwerte angezeigt wird. Geben Sie im Fenster Trennzeichen das gewünschte Trennzeichen ein.
  7. Trennzeichen werden automatisch bei nicht leeren Werten eingefügt. Wenn Trennzeichen immer, d. h. auch bei leeren Feldwerten, eingefügt werden sollen, aktivieren Sie die Option Trennzeichen für leere Feldwerte einsetzen.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.

Das Ergebnis kann in jedem beliebigen Vorlagenfeld gespeichert werden. Es empfiehlt sich die Verwendung von Feldern ohne Bereich.

Wenn Sie nur den Wert des Ergebnisfelds und nicht die Werte der verbundenen Felder exportieren möchten, deaktivieren Sie die Option Feldwert exportieren der entsprechenden Felder.


Festlegen einer Regel mithilfe eines Skripts

Mithilfe von ABBYY FlexiCapture 8.0 Professional können Sie die Regel zum überprüfen von Daten mithilfe eines Skripts konfigurieren.

So erstellen Sie diese Regel:

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Skript aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. In der Liste Verfügbare Felder sind die verfügbaren Objekte aufgeführt. über die Schaltfläche Hinzufügen… oder Löschen können Sie Felder hinzufügen bzw. löschen. Die Werte der Felder, bei denen die Option Schreibgeschützt aktiviert ist, können nur gelesen werden, während die Werte der Felder, bei denen diese Option deaktiviert ist, mithilfe eines Skripts überschrieben werden können.
  7. Wählen Sie die Skriptsprache aus, und geben Sie den Skripttext ein. Durch Klicken auf Bearbeiten… können Sie ein spezielles Fenster zur Skriptbearbeitung öffnen. Das Skript kann durch Klicken auf die Schaltfläche Überprüfen geprüft werden.
  8. Klicken Sie auf Fertig stellen. Die erstellte Regel wird in der Liste auf der Registerkarte Regeln angezeigt.

Hinweis: Prozeduren, die in mehr als einer Regel verwendet werden sollen, sollten in das Modul für globale Regeln geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste des Skripteditors die Option Regel für globales Skriptmodul. Auf das Modul für globale Skripte können Sie auch vom Vorlageneditor aus zugreifen (Vorlage>Skriptmodule>Regelskript…).

Weitere Informationen zum Erstellen von Regeln mithilfe eines Skripts finden Sie unter Verwenden von Skripten in FlexiCapture 8.0


Summe in Zahlen und Summe in Worten

Wichtig: Diese Regel kann nur eingerichtet werden, wenn Sie für Ihre Vorlage die Erkennungssprache Russisch wählen (Vorlage>Eigenschaften von Dokumentvorlage…).

Der Zweck dieser Regel ist es, eine Zahlensumme mit der entsprechenden Summe von in Russisch geschriebenen Wörtern zu vergleichen. Wenn diese beiden Summen nicht identisch sind, dann wird die Meldung angezeigt, dass die Regel einen Fehler zurückgegeben hat.

So erstellen Sie die Regel "Summe in Zahlen und Summe in Worten":

  1. öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld für die Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Dokumentvorlageneditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summe in Zahlen und Summe in Worten (Russisch) aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Zahlen, und wählen Sie dann das Feld der Vorlage aus, das die Summe in Zahlen enthält.
  7. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Worten, und wählen Sie dann das Feld der Vorlage aus, das dieselbe Summe in Wörtern enthält.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Konfigurieren des Datenexports

Um das Verfahren zum Speichern der während der Verarbeitung von Papierdokumenten erfassten Daten festzulegen, konfiguriert der Administrator die Exporteinstellungen für jede Vorlage. Vier Exporttypen sind möglich: Export in eine Datei mit einem bestimmten Format, Export in eine Datenbank, Export in eine Microsoft SharePoint-Bibliothek oder Export mithilfe eines Skripts.

Wählen Sie zum Konfigurieren des Exports im Dokumentvorlageneditor die Optionen Vorlage > Exporteinstellungen… aus, und legen Sie im Dialogfeld Exporteinstellungen die gewünschten Einstellungen fest.

Geben Sie im Feld Exporttyp den Exporttyp (Datei, Datenbank,SharePoint-Bibliothek oder Skript) an. Die nachfolgenden Einstellungen hängen jeweils von der in diesem Feld ausgewählten Option ab.

Export in eine Datei
Export in eine Datenbank
Export in eine SharePoint-Dokumentbibliothek
Export mithilfe eines Skripts


Datenexport in eine Datei

So legen Sie den Export in eine Datei fest:

  1. Wählen Sie im Fenster des Dokumentvorlageneditors die Menüoptionen Vorlage > Exporteinstellungen… aus.
  2. Wählen Sie im Feld Exporttyp die Option In Dateien exportieren aus.

  3. Registerkarte Ziel:

    • Pfad: Klicken Sie auf Durchsuchen…, um den Zielordner zum Speichern exportierter Dateien auszuwählen.

    Wichtig: Wenn sich der Pfad zum Zielordner auf ein Netzlaufwerk bezieht, stellen Sie sicher, dass alle am Projekt arbeitenden Operatoren Zugriff auf dieses Laufwerk haben.

    • Für jeden Stapel separaten Ordner erstellen: Aktivieren Sie diese Option, wenn die Exportergebnisse eines Dokumentstapels in einem gesonderten Ordner gespeichert werden sollen.
    • Für jeden Ordner separate Datei erstellen: Aktivieren Sie diese Option, wenn die Exportergebnisse eines Dokuments in einer gesonderten Datei gespeichert werden sollen. Andernfalls werden alle Dokumente in ein und dieselbe Datei exportiert.
    • Aktivieren Sie die Option Vorhandene Dateien überschreiben, wenn Exportdateien überschrieben werden sollen.
    • Legen Sie die zu verwendenden Regeln für die Benennung der Exportdateien fest. Klicken Sie auf die Schaltfläche Dateinamenoptionen…, und wählen Sie die gewünschten Optionen im angezeigten Dialogfeld aus. Ausführliche Informationen finden Sie unter Regeln für das Benennen von Exportdateien.

  4. Wählen Sie auf der Registerkarte Format den Dateityp aus (unterstützte Formate: CSV, DBF, TXT, XLS, XML), und legen Sie für den ausgewählten Dateityp weitere Exporteigenschaften fest. Sie können auch die Textkodierung angeben.

Microsoft Office Excel-Arbeitsmappe (*.xls):
  • Wählen Sie die gewünschte Version von Microsoft Excel (5.0/95; 97-2003; 97-2003 (kompatibel mit 5.0/95)).
  • Wählen Sie Werttyp beim Exportieren beibehalten, um die Daten nach Typ zu exportieren. Wenn Sie diese Option deaktivieren, werden alle Daten als Allgemein exportiert.
  • Aktivieren Sie Separate Dateien für wiederholbare Elemente erstellen, wenn Sie möchten, dass mehrfach vorkommende Felder und Tabellen in verschiedene Dateien exportiert werden sollen. Siehe Hinweise.
  • Wählen Sie im Fall von Microsoft Excel 5.0/95 die gewünschte Zeichencodierung.
XML-Dokument (*.xml):
  • Wählen Sie die zusätzlichen Daten aus, die exportiert werden sollen (Position von Feldern, Feldtypen, Fehler, Informationen über die Erkennungsqualität).
  • Wenn Sie die Option Werttyp beim Exportieren beibehalten aktivieren, wird das XML-Schema beibehalten, in dem die Feldtypen beschrieben werden.
  • Wählen Sie die gewünschte Codierung aus.
Kommagetrennte Datei (*.csv):
  • Wählen Sie Spaltentrennlinie aus.
  • Aktivieren Sie Separate Dateien für wiederholbare Elemente erstellen, wenn Sie möchten, dass mehrfach vorkommende Felder und Tabellen in verschiedene Dateien exportiert werden sollen. Siehe Hinweise.
  • Wählen Sie die gewünschte Codierung aus.
Textdatei (*.txt):
  • Wählen Sie das Spaltentrennlinie aus.
  • Aktivieren Sie Separate Dateien für wiederholbare Elemente erstellen, wenn Sie möchten, dass mehrfach vorkommende Felder und Tabellen in verschiedene Dateien exportiert werden sollen. Siehe Hinweise.
  • Wählen Sie die gewünschte Codierung aus.
DBase-Datei (*.dbf):
  • Wählen Sie Werttyp beim Exportieren beibehalten, um die Daten nach Typ zu exportieren. Wenn Sie diese Option deaktivieren, werden alle Felder zu Feldern des Typs Text.
  • Aktivieren Sie Separate Dateien für wiederholbare Elemente erstellen, wenn Sie möchten, dass mehrfach vorkommende Felder und Tabellen in verschiedene Dateien exportiert werden sollen. Siehe Hinweise.

  5. Auf der Registerkarte Bilder können Sie die Parameter zum Speichern der Bilder festlegen.

    • Aktivieren Sie die Option Dokumentbilder speichern, wenn Sie die Bilder der Dokumentseiten speichern möchten.

    • Aktivieren Sie die Option in Datenordner, wenn die Bilder im gleichen Ordner gespeichert werden sollen, in den die Daten exportiert werden.

    • Aktivieren Sie die Option in Ordner, und geben Sie den Pfad des Ordners an, wenn Sie die Bilder in einem anderen Ordner speichern möchten.

    • Wählen Sie Bildspeicherformat, Qualität und Farbe.
    • Wenn Sie die Auflösung der Ursprungsbilder ändern möchten, aktivieren Sie die Option Auflösung ändern in, und geben Sie entweder die entsprechende Auflösung ein, oder wählen Sie eine in der Liste aus.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, dann können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbare PDF-Datei erstellen wählen. Sie können eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentvorlage festgelegten Sprache unterscheidet. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Sprache, und fügen Sie die gewünschten Sprachen hinzu. Wenn Sie die in der Dokumentvorlage festgelegte Sprache verwenden möchten, wählen Sie im Feld Sprache die Option Wie in der Vorlage.

Die Werte aller Dokumentfelder werden in eine oder mehrere Dateien des angegebenen Formats exportiert.

Hinweise:

  1. Mehrfach vorkommende Felder (d. h. Felder mit mehreren Instanzen und Tabellen) werden jeweils in separate Dateien exportiert, für die ein neuer Ordner erstellt wird. Der Name des Ordners besteht aus dem Namen der Exportdatei. Wenn mehrfach vorkommende Felder nicht in separate Dateien exportiert werden sollen, deaktivieren Sie auf der Registerkarte Format die Option Separate Dateien für wiederholbare Elemente erstellen (die Option ist für alle Formate mit Ausnahme von XML verfügbar). In diesem Fall werden mehrfach vorkommende Felder in eine Exportdatei exportiert und es wird eine neue Zeile für jede Elementinstanz hinzugefügt.
  2. Bilder werden in separate Dateien exportiert und in dem Ordner gespeichert, in dem auch die mehrfach vorkommenden Felder gespeichert werden. Der Name des Bildes besteht aus dem Namen des Felds und der Nummer des Dokuments. Sie können das Bilddateiformat auf der Registerkarte für den Export im Dialogfeld für die Bildeigenschaften festlegen. Einzelheiten finden Sie unter Exportieren von Bildern.


Export in eine Datenbank

So konfigurieren Sie den Export in eine Datenbank:

  1. Wählen Sie im Fenster des Dokumentvorlageneditors die Menüoptionen Vorlage > Exporteinstellungen… aus.
  2. Wählen Sie im Feld Exporttyp die Option In ODBC-kompatible Datenbank exportieren aus.

  3. Registerkarte Verbindung:

    • Stellen Sie eine Verbindung mit einer Datenbank her. Geben Sie im Fenster Verbindungszeichenfolge die Verbindungsparameter ein, oder klicken Sie auf die Schaltfläche Verbindung einrichten…, und legen Sie im Dialogfeld Eigenschaften von Datenverbindung die Verbindungsparameter fest.
    • Wählen Sie in der Dropdownliste ein Datenbankschema aus.
    • Sie können die Verbindung mit der Datenbank überprüfen, indem Sie auf die Schaltfläche Verbindung testen klicken.

      Tipp: Als OLE DB-Anbieter wird ein OLE DB-Anbieter für ODBC-Treiber empfohlen. Die Auswahl des OLE DB-Anbieters für SQL Server führt bei der Verwendung bestimmter Datentypen und langer Felder möglicherweise zu Fehlern.

    • Ordnen Sie die Felder der Dokumentvorlage den Spalten der Datenbanktabellen zu. Klicken Sie dazu auf Feldzuordnung einrichten…
    • Geben Sie im Dialogfeld Feldzuordnung an, in welche Tabellen und Tabellenspalten der Datenbank die Feldwerte der Dokumentvorlage exportiert werden sollen.
      Details...

      Im linken Bereich des Dialogfelds Feldzuordnung sind Dokumentbereiche und -felder aufgeführt. Im rechten Bereich müssen Sie diese Bereiche und Felder den Tabellen und Feldern in der Datenbank zuordnen. Wenn die Datenbank bereits Tabellen für den Datenexport enthält, müssen Sie im Dialogfeld Feldzuordnung eine Datenbanktabelle für jeden Dokumentbereich und eine Tabellenspalte für jedes Dokumentfeld auswählen.

      Wenn die Datenbank keine Tabelle für den Export enthält, können Sie Datenbanktabellen automatisch erstellen. Klicken Sie dazu auf die Schaltfläche Tabellen automatisch erstellen. Damit werden Tabellen mit der für den Export erforderlichen Struktur erstellt. Die Dokumentfelder werden Tabellenspalten zugeordnet.

      Feldgruppen, Felder mit mehreren Instanzen, Dokumenttabellen und Bereiche werden jeweils in separate Datenbanktabellen exportiert. Die Haupttabelle wird mithilfe eines primären Schlüssels und eines Fremdschlüssels mit untergeordneten Tabellen verknüpft. In der Haupttabelle wird jedem Eintrag ein primärer Schlüssel hinzugefügt. In der untergeordneten Tabelle wird jedem Eintrag ein Fremdschlüssel zugewiesen, mit dem der Wert des primären Schlüssels des entsprechenden Eintrags in der Haupttabelle erfasst wird. Die primären und Fremdschlüssel werden an den entsprechenden Stellen automatisch hinzugefügt. Sie müssen lediglich das Feld angeben, in das der Schlüssel exportiert werden soll.

      Die Option Verknüpfte Spalten anzeigen ist standardmäßig aktiviert. Wenn Sie die Option deaktivieren, werden im rechten Bereich in der Liste der verfügbaren Tabellenspalten die Spalten nicht angezeigt, für die der Export bereits definiert wurde.

  4. Auf der Registerkarte Bilder können Sie die Parameter zum Speichern der Bilder festlegen.

    • Sie können Bilder in einer Datenbank oder Datei speichern (geben Sie in diesem Fall den Zielordner an).

    • Wählen Sie Bildspeicherformat, Qualität und Farbe.

    • Wenn Sie die Auflösung der Ursprungsbilder ändern möchten, aktivieren Sie die Option Auflösung ändern in, und geben Sie entweder die entsprechende Auflösung ein, oder wählen Sie eine in der Liste aus.

    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, dann können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbare PDF-Datei erstellen wählen. Sie können eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentvorlage festgelegten Sprache unterscheidet. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Sprache, und fügen Sie die gewünschten Sprachen hinzu. Wenn Sie die in der Dokumentvorlage festgelegte Sprache verwenden möchten, wählen Sie im Feld Sprache die Option Wie in der Vorlage.

Hinweise:

  1. Wenn Sie festlegen möchten, dass beim Exportieren der Daten in eine Datenbank keine Bilder gespeichert werden, wählen Sie im Dialogfeld Feldzuordnung für den Knoten mit dem Dokumentbild den Wert NotExported aus.
  2. Bilder werden in separate Dateien exportiert, deren Format im Dialogfeld für die Bildfeldeigenschaften auf der Registerkarte Exportieren ausgewählt werden können. Siehe dazu Exportieren von Bildern. Name und Pfad des Bilds können in dem entsprechenden Feld der Datenbank gespeichert werden (dieses kann beim Zuordnen der Felder eingerichtet werden).
  3. Wenn sich der Pfad zum Zielordner für Dokumente, Bilder usw. auf ein Netzlaufwerk bezieht, stellen Sie sicher, dass alle am Projekt arbeitenden Operatoren Zugriff auf dieses Laufwerk haben.


Exportieren von Daten in eine SharePoint-Dokumentbibliothek

ABBYY FlexiCapture 8.0 ermöglicht Ihnen das Exportieren von Dokumenten in eine MicrosoftTM SharePoint-Dokumentbibliothek. Als Ergebnis erhalten Sie eine Bibliothek Ihrer Dokumentbilder mit zusätzlichen Spalten für jedes Dokument, die mit Werten bestimmter Felder ausgefüllt sind.

Hinweis:

  1. Zum Einrichten des Exports von Daten nach SharePoint sind Administratorrechte erforderlich. Für den eigentlichen Export nach SharePoint sind Mitarbeiterrechte ausreichend.
  2. Die SharePoint-Spalten, in denen die Daten erfasst werden sollen, müssen vom Typ Eine Textzeile oder Mehrere Textzeilen sein.

So richten Sie den Export nach SharePoint ein:

  1. Wählen Sie im Dokumentvorlageneditor die Optionen Vorlage > Exporteinstellungen… aus.
  2. Wählen Sie in der Dropdownliste Exporttyp die Option Nach SharePoint exportieren.

  3. Registerkarte SharePoint-Verbindung:

    • Server-URL (z. B. http://myserver): Geben Sie die Adresse des Servers ein, auf dem sich Ihre SharePoint-Bibliotheken befinden. Verwenden Sie die Schaltfläche Verbindungseinstellungen…, um gegebenenfalls die Authentifizierungsparameter (standardmäßig werden die Windows-Authentifizierungsparameter verwendet) und die Proxy-Einstellungen einzurichten.
    • Unter der Serveradresse wird der Verbindungsstatus angezeigt. Wenn die Serververbindung getrennt ist, klicken Sie auf Verbinden, um die Verbindung wiederherzustellen.
    • Wenn Sie mit dem SharePoint-Server verbunden sind, wählen Sie aus der Liste SharePoint-Bibliothek auswählen eine Bibliothek aus.
    • Wählen Sie im Feld Inhaltstyp den Inhaltstyp Ihres Dokuments aus (unterstützt ab SharePoint 2007). In diesem Fall haben Sie die Möglichkeit, Werte in die Felder zu exportieren, die dem ausgewählten Inhaltstyp entsprechen.
    • Legen Sie nun fest, welche Vorlagenfelder wohin exportiert werden sollen. Klicken Sie auf die Schaltfläche Felderzuordnung einrichten…, und wählen Sie die gewünschten Optionen im Dialogfeld Feldzuordnung aus. In diesem Dialogfeld müssen Sie die Entsprechungen zwischen den Dokumentfeldern und den SharePoint-Dokumentspalten herstellen. Die Vorlagenfelder werden auf der linken Seite angezeigt. Für jedes zu exportierende Vorlagenfeld (mit Ausnahme von Gruppen und Tabellen) können Sie eine freie SharePoint-Spalte auswählen.
    • Legen Sie die Dateibenennungsregeln für die Exportdateien fest. Wenn nach SharePoint exportiert wird, handelt es sich um Dokumentbilddateien. Klicken Sie auf die Schaltfläche Dateinamenoptionen…, und wählen Sie die gewünschten Dateinamenoptionen aus. Ausführliche Informationen finden Sie unter Regeln für das Benennen von Exportdateien.

  4. Wählen Sie auf der Registerkarte Bilder die Optionen zum Speichern der Bilder aus.
    • Wählen Sie aus der Dropdownliste Dateityp das Format aus, in der die Dokumentbilder gespeichert werden sollen.
    • Wählen Sie im Feld Qualität die gewünschte Bildqualität aus.
    • Wählen Sie im Feld Farbtyp den gewünschten Farbtyp für Ihre Bilder aus.
    • Wenn Sie die Auflösung der Ursprungsbilder ändern möchten, aktivieren Sie die Option Auflösung ändern in, und geben Sie entweder die entsprechende Auflösung ein, oder wählen Sie eine in der Liste aus.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, dann können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbare PDF-Datei erstellen wählen. Sie können eine Sprache auswählen (oder mehrere Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentvorlage festgelegten Sprache unterscheidet. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Sprache, und fügen Sie die gewünschten Sprachen hinzu. Wenn Sie die in der Dokumentvorlage festgelegte Sprache verwenden möchten, wählen Sie im Feld Wie in der Vorlage die Option Sprache.

Nachdem der Export abgeschlossen worden ist, werden die Dokumente in der angegebenen SharePoint-Bibliothek gespeichert. Jedes Dokument verfügt dann über eine entsprechende Spalte, die mit den Werten der festgelegten Felder ausgefüllt ist. Diese Werte können für Suchvorgänge und zur Dokumentindizierung verwendet werden.


Export mithilfe eines Skripts

So konfigurieren Sie den Export mithilfe eines Skripts:

  1. Wählen Sie im Fenster des Dokumentvorlageneditors die Optionen Vorlage > Exporteinstellungen… aus.
  2. Wählen Sie im Feld Exporttyp den Wert Benutzerdefinierter Export (Skript) aus.
  3. Wählen Sie die Skriptsprache (JScript(r) oder VBScript) aus.
  4. Klicken Sie auf die Schaltfläche Skript bearbeiten…, und geben Sie im daraufhin geöffneten Editorfenster den Skripttext ein.

Hinweis: Prozeduren, die in mehr als einem Exportskript verwendet werden sollen, sollten in das Modul für globale Exporte geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste des Skripteditors die Option Globales Skriptmodul exportieren. Auf das Modul für globale Exportskripte können Sie auch vom Vorlageneditor aus zugreifen (Vorlage>Skriptmodule>Skript exportieren…).

Weitere Informationen zum Definieren des Exports mithilfe eines Skripts finden Sie unter Verwenden von Skripten in FlexiCapture 8.0.


Regeln für das Benennen von Exportdateien

Beim Export werden die Dateinamen automatisch auf der Grundlage von benutzerdefinierten Regeln erzeugt. Sie können die Dateibenennungsregeln bei der Einrichtung des Exports in eine Datei oder nach SharePoint festlegen. Klicken Sie beim Einrichten des Exports in eine Datei in der Registerkarte Ziel bzw. beim Einrichten des Exports nach SharePoint in der Registerkarte SharePoint-Verbindung auf die Schaltfläche Dateinamenoptionen…. Das Dialogfeld Dateibenennungsoptionen wird geöffnet, in dem Sie die Optionen zur Dateibenennung auswählen müssen.

Folgende Bestandteile können automatisch an den Namen einer Exportdatei angehängt werden:

  • Projektname (wählen Sie die Option Projekttitel aus)
  • Stapelname (wählen Sie die Option Projekttitel aus)
  • Name der Dokumentvorlage (wählen Sie die Option Dokumentvorlagenname aus)
  • Dokumentkennung, z. B. der Wert des Barcodes der Trennseite, wenn beim Hinzufügen der Bilder Barcode-Trennseiten verwendet werden. Einzelheiten finden Sie unter Optionen für die Bildverarbeitung. Wählen Sie die Option Dokument-ID, um die Dokumentkennung anzuhängen.
  • Werte der Indexfelder. Einzelheiten finden Sie unter Indexfelder. Wählen Sie Indexfeldwert, und klicken Sie auf Auswählen…, um das gewünschte Indexfeld auszuwählen.

Unter Dateinamenvorlage wird die Vorlage angezeigt, die für das Erzeugen der Dateinamen verwendet wird. Wenn Sie eine Textzeichenfolge zu den zu erzeugenden Dateinamen hinzufügen möchten, können Sie in dieses Feld den gewünschten Text eingeben.

Damit die Dateinamen korrekt erzeugt werden können, stellen Sie sicher, dass die von Ihnen ausgewählten Dateinamenoptionen nicht zu leeren Dateinamen führen. Tritt dieser Fall ein, zeigt das Programm eine Warnmeldung an.


Konfigurieren der Datendarstellung im Dokumentfenster

Nach der Erkennung werden die Daten im Dokumentfenster angezeigt. Die Daten werden standardmäßig der Reihe nach angeordnet. Die zugehörigen Signaturen entsprechen jeweils den Namen der Vorlagenfelder.

Sie können jedoch die Darstellung der Daten ändern, die Anordnung nach Bedarf anpassen oder Elemente umbenennen. Die Datendarstellung kann in der rechten unteren Ecke des Dokumentvorlageneditors bearbeitet werden.

Sie können die Beschriftung eines Felds im Datenformular ändern, ohne den Namen des Felds in der Dokumentstruktur zu verändern. Öffnen Sie zum Ändern einer Beschriftung das Dialogfeld für die Feldeigenschaften, klicken Sie auf die Registerkarte Beschriftung, und geben Sie einen neuen Namen in das Feld Allgemein ein. Dieser Name wird nun für die Beschriftung des Felds im Datenformular verwendet. Diese Funktion kann hilfreich sein bei der Anpassung von Spaltennamen, insbesondere bei FlexiLayouts, bei denen Sie die Namen der Felder nicht ändern können.

Die Textschrift und -größe von Feldnamen und Werten erkannter Daten können auf der Registerkarte Datenformular des Dialogfelds Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage…) geändert werden. Sie können die Größe auch ändern, indem Sie mit der rechten Maustaste in das Fenster Datenformular klicken und die gewünschte Größe auswählen (Menü Textgröße im Kontextmenü).

Sie können Felder verschieben, bearbeiten und umbenennen sowie andere Feldeigenschaften ändern. Wählen Sie im Kontextmenü die entsprechende Option aus, um wieder zur anfänglichen Felddarstellung zu wechseln.

Sie können Text hinzufügen, beispielsweise Erläuterungen. Klicken Sie dazu mit der rechten Maustaste in das Fenster Datenformular, und wählen Sie im Kontextmenü die Option Beschriftungsfeld einfügen aus. Ersetzen Sie den Beschriftungstext durch den gewünschten Text.


Eigenschaften von Dokumentvorlagen

Die allgemeinen Vorlageneigenschaften, z. B. Name, Sprache und Schreibstil, werden mithilfe des Vorlagenassistenten festgelegt. Andere Eigenschaften werden automatisch konfiguriert.

Sie können die Eigenschaften einer Dokumentvorlage im entsprechenden Eigenschaftendialogfeld anzeigen und ändern. Dieses Dialogfeld wird geöffnet, wenn Sie im Fenster des Dokumentvorlageneditors die Menüoptionen Vorlage > Eigenschaften von Dokumentvorlage… auswählen.

Das Dialogfeld enthält sechs Registerkarten.

Registerkarte Allgemein

Auf dieser Registerkarte können Sie die Vorlage umbenennen und die entsprechende Beschreibung eingeben oder bearbeiten. über die Option Aktiviert wird die Vorlage in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen.

Registerkarte Erkennung

Auf dieser Registerkarte können Sie die allgemeinen Eigenschaften zur Erkennung einer Dokumentvorlage ändern.

  • Sprache (Gebietsschema): Für eine korrekte Erkennung ist es wichtig, die verwendete Sprache einzugeben. Diese Eigenschaft legt die Eingabesprache und andere lokale Einstellungen fest, z. B. Datumsformat, Währung usw.
  • Schreibstil: Der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, sodass im Programm der jeweils typische Schreibstil ausgewählt wird.

  • Geben Sie den Texttyp an:

    ICR (Handschrift): Aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden.

    OCR (Druck): Aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis: Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

  • Sie können in der Gruppe Mögliche Seitenausrichtung eine oder mehrere Optionen aktivieren, sodass die Seite bei der automatischen Seitenausrichtung um 180° oder um 90° im Uhrzeigersinn bzw. gegen den Uhrzeigersinn gedreht wird.
  • Klicken Sie auf Erweiterte Optionen…, um die Korrektur linearer oder nicht linearer Bildverzerrungen festzulegen.

Registerkarte Zusammenstellung

Auf dieser Registerkarte können Zusammenstellungsregeln für mehrseitige Dokumente konfiguriert werden.

Im einfachsten Fall enthält die Vorlage einen Bereich, der einmal vorkommt. Wenn eine Vorlage mehrere Bereiche umfasst, wird auf dieser Registerkarte eine Liste mit den zugehörigen Namen angezeigt. Sie können die Anzahl der Wiederholungen jedes Bereichs angeben, indem Sie jeweils die Zahl in den Spalten Mindestanzahl und Maximalanzahl ändern.

  • Gleichwertigkeit der Schlüsselfelder überprüfen: Aktivieren Sie diese Option, wenn eine überprüfung der Dokumentzusammenstellung anhand von Schlüsselfeldern durchgeführt werden soll. Wählen Sie dann in der Spalte Schlüsselfeld für jeden Bereich ein Schlüsselfeld aus. Bei der Eingabe von Dokumenten werden nur Dokumente mit übereinstimmenden Schlüsselfeldwerten in jedem Bereich als korrekt zusammengestellt eingestuft. Wenn die Werte nicht übereinstimmen, wird eine Zusammenstellungsfehlermeldung angezeigt.
  • Anhangseiten berücksichtigen: Aktivieren Sie diese Option, wenn Dokumente mit Anhängen verarbeitet werden sollen.
  • Es kann vorkommen, dass Sie die Überprüfung der Reihenfolge der Bereiche im Dokument deaktivieren möchten (z. B., wenn die Reihenfolge der Bereiche keinen Einfluss auf die Dokumentzusammenstellung hat). Wählen Sie Prüfung der Bereichsreihenfolge deaktivieren, um die Überprüfung zu deaktivieren. Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.

Weitere Informationen finden Sie unter Erstellen von Vorlagen für mehrseitige Dokumente, Zusammenstellen von Seiten in Dokumenten und Erstellen von Vorlagen für Dokumente mit Anhängen.

Registerkarte Regeln

Auf dieser Registerkarte können Sie Vorgänge mithilfe von Regeln für Vorlagen durchführen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.

Registerkarte Export

Auf dieser Registerkarte werden die aktuellen Exporteinstellungen der entsprechenden Vorlage angezeigt. Wenn Sie die Exporteinstellungen ändern möchten, klicken Sie auf die Schaltfläche Exporteinstellungen ändern….

Ausführliche Informationen finden Sie unter Konfigurieren des Datenexports.

Registerkarte Datenformular

Auf dieser Registerkarte können Sie die Schriftkontur und Schriftgröße zum Anzeigen erkannter Daten ändern.

Die Gruppe Einstellungen für Datentext enthält Schrifteinstellungen zum Anzeigen erkannter Werte.

Die Gruppe Einstellungen für Beschriftungstext enthält Einstellungen zum Anzeigen des erklärenden Texts (Feldnamen).

Weitere Informationen finden Sie unter Konfigurieren der Datendarstellung im Dokumentfenster.


Eigenschaften eines Dokumentvorlagenbereichs

Sie können die Eigenschaften eines Dokumentvorlagenbereichs im entsprechenden Eigenschaftendialogfeld anzeigen und ändern. Wählen Sie dazu im Kontextmenü des Bereichs die Option Eigenschaften… aus.

Das Dialogfeld enthält drei Registerkarten.

Registerkarte Allgemein

Auf dieser Registerkarte können Sie den Namen eines Dokumentbereichs ändern, die Beschreibung eingeben oder bearbeiten sowie die Mindest- oder Maximalanzahl der Bereichswiederholungen im Dokument eingeben oder ändern. über die Option Aktiviert wird die Bereichsvorlage in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen. Ausführliche Informationen zu mehrseitigen Dokumenten und zum Verwenden von Vorlagenbereichen finden Sie unter Erstellen von Vorlagen für mehrseitige Dokumente.

Registerkarte FlexiLayout

Wenn einem Bereich ein FlexiLayout zugewiesen wurde, werden auf dieser Registerkarte Name, Version und Kommentar angezeigt. Sie können ein FlexiLayout anfügen, indem Sie auf die Schaltfläche Laden… klicken, und das vorhandene FlexiLayout entfernen, indem Sie auf die Schaltfläche Entfernen klicken.

Ausführliche Informationen finden Sie unter Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente.

Registerkarte Bilder
Auf dieser Registerkarte werden die Parameter für die Seitenbilder eines Bereichs angezeigt. Folgende Parameter sind verfügbar: Größe, Auflösung, Druckgröße und Farbmodus.

Registerkarte Regeln

Auf dieser Registerkarte können Sie Vorgänge mithilfe von Regeln für Vorlagen durchführen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.


Importieren einer Vorlage für mit ABBYY FormDesigner erstellte Formulare

ABBYY FormDesigner ist ein benutzerfreundliches Tool, das speziell zum Erstellen maschinenlesbarer Formulare entwickelt wurde. Mit ABBYY FormDesigner können Sie nicht nur Formulare erstellen, die allen Anforderungen für die automatische Dokumentverarbeitung entsprechen, das Tool enthält darüber hinaus eine nahezu vollständige Vorlage zum Verarbeiten dieser Formulare in ABBYY FlexiCapture 8.0 Professional.

So erstellen Sie eine Dokumentvorlage zum Verarbeiten von Formularen, die mit ABBYY FormDesigner erstellt wurden:

In ABBYY FormDesigner:

  1. Erstellen Sie ein Formular.
  2. Veröffentlichen Sie das Formular.
  3. Exportieren Sie es in das XML-Formulardefinitionsformat. So erstellen Sie eine Datei mit der Dateierweiterung "xfd".

Ausführliche Informationen zum Erstellen, Veröffentlichen und Exportieren von Formularen finden Sie in den Hilfethemen und im Benutzerhandbuch für ABBYY FormDesigner 8.0.

In ABBYY FlexiCapture:

  1. Wählen Sie im Hauptmenü die Menüoptionen Projekt > Dokumentvorlagen… aus.
  2. Klicken Sie im Dialogfeld Dokumentvorlagen auf die Schaltfläche Importieren….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Datei zum Importieren öffnen in der Dropdownliste Dateityp die Option XML-Formulardefinitionsdateien (*.xfd) aus, und geben Sie den Pfad der XFD-Datei an.
  4. Der Name der neuen Dokumentvorlage wird dann in der Vorlagenliste des Dialogfelds Dokumentvorlagen angezeigt.

Nach dem öffnen einer importierten Vorlage, die Sie bearbeiten möchten, sind die Felder und statischen Elemente im Bild bereits gekennzeichnet. Sie müssen lediglich die Feldeigenschaften bearbeiten und den Export konfigurieren.


Erstellen von Vorlagen für mehrseitige Dokumente

Mit ABBYY FlexiCapture 8.0 Professional können Sie Vorlagen für mehrseitige Dokumente erstellen. Eine Vorlage kann beliebig viele Bereiche enthalten, die wiederum eine oder mehrere Seiten umfassen können. Bei Vorlagen für mehrseitige Dokumente müssen Sie die Reihenfolge der Bereiche, die Anzahl der Bereiche und die Regeln angeben, anhand derer Seiten in Dokumenten zusammengestellt werden.

Im Assistenten wird eine neue einfache Vorlage ohne Bereiche erstellt. Sie können dieser Vorlage Seiten hinzufügen. Beim Hinzufügen einer Seite wird das entsprechende Bild zur Bildregion im Fenster des Vorlageneditors hinzugefügt. Die in diesem Bereich erstellten Felder sind dagegen in der Liste der allgemeinen Felder aufgeführt. Das Dokument umfasst dann einen Bereich, obwohl es mehrere Seiten enthalten kann.

Sie sollten einem Bereich Seiten hinzufügen, wenn das Dokument Bereichsblöcke enthält, die sich über mehrere Seiten oder über Tabellen auf mehreren Seiten erstrecken oder auf mehreren Seiten mehrfach vorkommen. Das gleiche Verfahren wird zum Laden eines FlexiLayouts für mehrseitige Dokumente angewendet (siehe Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente). Alle Felder in einem FlexiLayout müssen ein und demselben Bereich einer Dokumentvorlage zugewiesen sein.

Eine andere Möglichkeit besteht darin, der Vorlage Bereiche hinzuzufügen. Im einfachsten Fall enthält ein Bereich genau eine Seite. Sie können festlegen, ob Feldgruppen auf Seiten voneinander unabhängig sind. Dieses Verfahren ist anschaulicher: In der Dokumentstruktur wird angezeigt, welchem Bereich die Felder zugewiesen sind. Sie können zudem eine benutzerdefinierte Struktur der Dokumentzusammenstellung definieren. Beispiel: Ein Dokument umfasst 3 Seiten. Die erste und dritte Seite kommen im Dokument nur einmal vor, während die zweite Seite zwischen 2- und 5-mal vorkommen kann. Erstellen Sie in diesem Fall für jede Seite einen separaten Bereich, und geben Sie dann die Dokumentstruktur an, d. h. die Reihenfolge und Anzahl der Wiederholungen der Bereiche.

Ein komplexeres Beispiel ist eine Vorlage mit mehreren Bereichen, von denen einige mehrere Seiten umfassen. Dabei handelt es sich beispielsweise um eine Vorlage mit statischen Bereichen und einem flexiblen mehrseitigen Bereich oder um eine Vorlage für Dokumente mit einem doppelseitigen Bogen, der mehrfach vorkommen kann. Beispiel: Sie möchten eine Vorlage für ein Dokument mit einer Titelseite (Seite A) und einer bestimmten Anzahl doppelseitiger Blätter (Seitenfolge BCBC...) erstellen. Sie erstellen dann den Bereich A mit der Seite A sowie den Bereich BC mit den zwei Seiten B und C. Die Dokumentstruktur wird folgendermaßen definiert: Bereich A wird einmal wiederholt, gefolgt von Bereich BC, der 3- bis 7-mal wiederholt wird.

Bei einer Vorlage mit mehreren Bereichen können Sie neben der Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche die überprüfung von Schlüsselfeldern festlegen. Dazu müssen Sie die Schlüsselfelder in jedem Dokumentbereich identifizieren. Die entsprechenden Werte müssen in verschiedenen Bereichen identisch sein. Ein Beispiel für ein Schlüsselfeld ist der Nachname einer Person, die ein Dokument ausfüllt, der auf jeder Seite eingetragen werden muss, oder eine bestimmte Identifikationsnummer.

Beim Verarbeiten eines Stapels wird im Programm eine Folge von Seiten in Dokumenten zusammengestellt. Dabei werden die Zusammenstellungsregeln überprüft. Zudem wird eine überprüfung der Schlüsselfeldwerte durchgeführt. Wenn Schlüsselfelder auf den Seiten eines Dokuments nicht übereinstimmen, wird eine Fehlermeldung angezeigt. Die Schlüsselfelder stimmen manchmal nicht überein, da die Seiten eines Dokuments beim Scannen in falscher Reihenfolge angeordnet wurden. Nach dem ändern der Reihenfolge der Seiten sind die Zusammenstellungsregeln dann wieder erfüllt. Siehe Zusammenstellen von Seiten in Dokumenten.

Wenn Sie einem Bereich eine Seite hinzufügen möchten, wählen Sie im Vorlageneditor die Menüoptionen Vorlage > Seite hinzufügen… oder im Kontextmenü des Bilds die Option Seite hinzufügen… aus. Laden Sie dann das Bild einer neuen unvollständigen Seite, und wählen Sie Objekttypen aus, die in der Seite automatisch markiert werden sollen.

Wenn Sie einen neuen Bereich hinzufügen möchten, wählen Sie im Fenster des Vorlageneditors die Menüoptionen Vorlage > Dokumentbereich hinzufügen… aus. Daraufhin wird der Assistent zum Erstellen von Bereichen geöffnet, in dem Sie alle erforderlichen Parameter festlegen können. Befolgen Sie die Anweisungen des Assistenten, und führen Sie folgende Schritte aus:

  • Geben Sie den Namen des Bereichs an.
  • Laden Sie das Bild einer unvollständigen Seite (Scannen oder Laden aus Datei) oder eine FlexiLayout-Datei.
  • Wählen Sie Objekttypen aus, die automatisch markiert werden sollen.

Damit wird im Fenster Dokumentstruktur ein neuer Bereich mit den zugehörigen Feldern angezeigt.

Wenn Sie beim Erstellen einer Vorlage die entsprechende Dokumentstruktur anzeigen möchten, klicken Sie im rechten Bereich des Dokumentvorlageneditors im Fenster Dokumentstruktur auf die Registerkarte Seiten. Auf dieser Registerkarte wird die Dokumentstruktur in der Gliederungsansicht angezeigt. Auf dieser Registerkarte können Sie die Anzahl der Bereichswiederholungen in einem Dokument ändern (geben Sie dazu im Feld rechts neben dem Namen des Bereichs einen neuen Wert ein, d. h. eine Anzahl oder einen Bereich), Seiten eines Anhangs anfügen, die Reihenfolge der Seiten im Bereich ändern und Seiten per Drag&Drop zwischen verschiedenen Bereichen verschieben.

Fenster Dokumentstruktur anzeigen

über die Menüoptionen Vorlage > Eigenschaften von Dokumentvorlage… im Fenster des Vorlageneditors können Sie die Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche sowie die Zusammenstellungsregel festlegen. Geben Sie auf der Registerkarte Zusammenstellung für jeden Bereich im Dokument die Mindest- und Höchstanzahl der Wiederholungen an (Standardwert: 1). Wenn die Werte der Schlüsselfelder überprüft werden sollen, aktivieren Sie die Option Gleichwertigkeit der Schlüsselfelder überprüfen, und wählen Sie in jedem Bereich ein Schlüsselfeld aus.

Es kann vorkommen, dass Sie die Überprüfung der Reihenfolge der Bereiche im Dokument deaktivieren möchten (z. B., wenn die Reihenfolge der Bereiche keinen Einfluss auf die Dokumentzusammenstellung hat). Wählen Sie Prüfung der Bereichsreihenfolge deaktivieren, um die Überprüfung zu deaktivieren. Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.

Registerkarte Zusammenstellung anzeigen


Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente

Für Rechnungen, Zahlungsaufträge und ähnliche Dokumente können Sie keine Vorlagen (bzw. Templates) mit statischen Feldern erstellen. Die Position, Größe und Anzahl der Felder ist möglicherweise nicht immer identisch, sodass ein statisches Template nicht auf alle Dokumente angewendet werden kann. In diesen Dokumenten wird nach einer Ersterkennung der gesamten Seite nach Feldern gesucht und anhand von Schlüsselwörtern und der relativen Position der Felder ein FlexiLayout erstellt. Ein spezielles Programmmodul, ABBYY FlexiLayout Studio 8.0, wurde für die Festlegung von FlexiLayouts konzipiert (dieses Modul ist im Lieferumfang von ABBYY FlexiCapture 8.0 Professional enthalten). Ausführliche Anweisungen zum Erstellen eines FlexiLayouts finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio 8.0.

FlexiLayouts werden in eine AFL-Datei exportiert und dann in ABBYY FlexiCapture 8.0 Professional geladen. Sie können ein FlexiLayout für die gesamte Vorlage oder einen zugehörigen Vorlagenbereich verwenden. FlexiLayouts können mehrseitig sein.

Anfügen eines FlexiLayouts

Ein FlexiLayout kann beim Erstellen einer Dokumentvorlage angefügt werden. Fügen Sie dazu im zweiten Schritt im Vorlagenassistenten das Dokumentbild hinzu, aktivieren Sie dann die Option FlexiLayout laden, und geben Sie den Pfad der AFL-Datei ein.

über das Fenster des Dokumentvorlageneditors können Sie ein FlexiLayout im Dialogfeld des Dokumentvorlagenbereichs anfügen.

  1. Wählen Sie einen Dokumentbereich aus. (Wenn das Dokument nur einen Bereich umfasst, klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten, und wählen Sie den Namen des Bereichs aus.) Klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Klicken Sie auf die Registerkarte FlexiLayout.
  3. Klicken Sie auf Laden….
  4. Wählen Sie die entsprechende AFL-Datei aus.

Nach dem Anfügen eines FlexiLayouts wird im Bild das geometrische Layout der Felder angezeigt. Sie müssen dann die Feldeigenschaften wie bei einem statischen Template festlegen. Geben Sie die Erkennungs-, überprüfungs- und Exporteigenschaften an, und legen Sie die gewünschten Regeln fest.


Erstellen von Vorlagen für Dokumente mit Anhängen

Mit ABBYY FlexiCapture 8.0 Professional können Sie Vorlagen für Dokumente mit Anhängen erstellen. Anhänge sind zusätzliche Seiten, die jedem Formular beigefügt werden können. Diesen Seiten wird keine Vorlage zugeordnet. Sie werden jedoch bei der Dokumentzusammenstellung berücksichtigt. Ein Darlehensantrag (statisches Formular) wird beispielsweise zusammen mit einem Einkommensnachweis ohne feste Struktur übermittelt. Dieser Einkommensnachweis kann als Anhang verarbeitet werden.

So erstellen Sie eine Vorlage für ein Dokument mit Anhang:

Erste Methode:

  1. Klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten (erster Teil des Vorlageneditors).
  2. Aktivieren Sie die Option Anhangseiten im Dokument berücksichtigen.
  3. Geben Sie die Anzahl oder den Bereich der Anhangseiten in dem Feld ein, das rechts neben dem Namen des Bereichs angezeigt wird.
Fenster Dokumentstruktur anzeigen

Alternative Methode:
  1. öffnen Sie das Dialogfeld Eigenschaften von Dokumentvorlage (Vorlage > Eigenschaften von Dokumentvorlage… im Fenster des Dokumentvorlageneditors).
  2. Klicken Sie auf die Registerkarte Zusammenstellung.
  3. Aktivieren Sie die Option Anhangseiten berücksichtigen. Die Zeile Anhangseiten wird in der Liste der Bereiche angezeigt.
  4. Geben Sie die Mindest- und Höchstanzahl für die Anhangseiten an.
Dialogfeld anzeigen

Wenn Sie den Text eines Anhangs speichern möchten, müssen Sie beim Konfigurieren des Datenexports Optionen zum Speichern von Bildern angeben (auf der Registerkarte Bilder des Dialogfelds Exporteinstellungen). Wenn Sie Durchsuchbare PDF zum Speichern der Bilder auswählen, wird der Text erkannt und in einer durchsuchbaren PDF-Datei gespeichert.


Verarbeiten nicht strukturierter Dokumente

Mithilfe von ABBYY FlexiCapture 8.0 Professional können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Anhänge. Nicht strukturierte Dokumente mit Text oder Bildern, die durch leere Blätter oder Seiten mit Barcodes getrennt sind, werden verarbeitet und in durchsuchbare PDF-Dateien oder Grafikdateien exportiert.

Die Verarbeitung dieser Dokumente umfasst normalerweise das Konvertieren der Dokumente in elektronische Formate sowie das Durchführen einer Suche nach Schlüsselfeldwerten.

Die Suche nach Schlüsselfeldern (z. B. einer Vertragsnummer) in diesen Dokumenten wird möglichst anhand eines in ABBYY FlexiLayout Studio erstellten FlexiLayouts durchgeführt. Siehe Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente.

Wenn die automatische Suche nach Schlüsselfeldern nicht möglich ist, können Sie die Werte manuell eingeben. Erstellen Sie dazu eine Dokumentvorlage mit einem Feld (oder gegebenenfalls mit mehreren Feldern), und aktivieren Sie in den Erkennungseigenschaften dieses Felds die Option Keine Erkennung (Manueller Eingabeblock - wird manuell eingegeben). Beim Durchführen des überprüfungsvorgangs können Sie dann die Schlüsselfeldwerte manuell eingeben.

Zum Aktivieren der Datenspeicherung müssen Sie den Export konfigurieren. Sie können Schlüsselfeldwerte in Dateien oder Datenbanken exportieren und Dokumentbilder in einem benutzerfreundlichen Format speichern. Aktivieren Sie dazu auf der Registerkarte Bilder des Dialogfelds Exporteinstellungen die Option Dokumentbilder speichern, und konfigurieren Sie Parameter zum Speichern von Bildern. Sie können Dokumentbilder in Grafikdateien oder durchsuchbaren PDF-Dateien speichern.

Geben Sie Acht beim Zusammenstellen von Seiten in Dokumenten. Bei nicht strukturierten Dokumenten kann definiert werden, dass festgestellt wird, zu welchem Dokument eine bestimmte Seite gehört. Für die automatische Zusammenstellung nicht strukturierter Dokumente wird empfohlen, Dokumente durch leere Blätter oder Seiten mit Barcodes zu trennen. Beim Hinzufügen von Bildern zu einem Stapel (durch Scannen, Hinzufügen aus einer Datei oder Erstellen eines Importprofils) müssen Sie dann die Option Für Bilder getrennt durch aktivieren und in der Dropdownliste den Wert Leere Seiten oder Seiten mit Barcode auswählen, je nachdem, welche Seiten als Trennseiten verwendet werden sollen. Die Seiten werden automatisch in Dokumenten zusammengestellt. Sie werden bis zur nächsten Trennseite dem aktuellen Dokument hinzugefügt. Ausführliche Informationen hierzu finden Sie unter Hinzufügen von Seitenbildern.


Bearbeiten und Veröffentlichen einer Vorlage

Vorlagen können im Fenster des Dokumentvorlageneditors bearbeitet werden. In diesem Fenster können Sie das Layout von Feldern und statischen Elementen ändern, die zugehörigen Eigenschaften, Regeln oder Exporteinstellungen ändern usw.

Damit sich änderungen nicht auf die Arbeit anderer Projektmitarbeiter auswirken, können Sie eine lokale Vorlagenkopie bearbeiten, während die zuletzt veröffentlichte Version der Vorlage zur Erkennung verwendet wird. In diesem Modus können Administratoren Vorlagen lokal ändern und testen, während Operatoren erkannte Dokumente weiterhin mit der alten Version überprüfen und exportieren können, auch wenn die Vorlage erheblich geändert oder gelöscht wurde. Andere Benutzer können nicht auf die bearbeitete Vorlage zugreifen und daran änderungen vornehmen. Nach dem Bearbeiten kann der Administrator die Vorlage entweder veröffentlichen – die neue Version steht dann zur Dokumenterkennung zur Verfügung – oder alle änderungen rückgängig machen.

So bearbeiten Sie eine Vorlage:

  1. Wählen Sie im Hauptmenü die Menüoptionen Projekt > Dokumentvorlagen… aus.
  2. Wählen Sie die zu bearbeitende Vorlage aus.
  3. Klicken Sie im Dialogfeld Dokumentvorlagen auf die Schaltfläche Bearbeiten…, um die Bearbeitung der Vorlage zu starten. Eine lokale Version der Vorlage wird auf Ihren Computer kopiert. Andere Benutzer können auf diese Vorlage nicht zugreifen.
  4. Nehmen Sie im Dokumentvorlageneditor die gewünschten änderungen an der Vorlage vor. Speichern Sie die Vorlage.
  5. Testen Sie die Vorlage mit mehreren Bildern. Mithilfe von Teststapeln, bei denen die lokale Version der Vorlage verwendet wird, können Sie Vorlagenanpassungen vornehmen.
  6. Klicken Sie im Dialogfeld Dokumentvorlagen auf die Schaltfläche Veröffentlichen, um die Vorlage zu veröffentlichen. Nach dem Veröffentlichen wird die neue Vorlagenversion zum Erkennen der Dokumente in den Arbeitsstapeln verwendet. Die Vorlage kann nun von anderen Administratoren bearbeitet werden. Wenn Sie die ursprüngliche Vorlage wiederherstellen möchten, klicken Sie auf Änderungen rückgängig machen.


Testen von Dokumentvorlagen

Vor der Masseneingabe von Dokumenten müssen die Vorlagen getestet werden. Beim Testen werden Dokumente zu Teststapeln hinzugefügt, da diese Stapel mit der lokalen Vorlagenversion verwendet werden. Diese Stapel sind im Hauptfenster des Programms über Projekt > Liste der Teststapel verfügbar. Sie können auf die Teststapel auch vom Fenster des Vorlageneditors aus zugreifen, indem Sie Extras>Zu Stapeltest wechseln… wählen.

Wichtig: Nur der Benutzer, der einen bestimmten Teststapel erstellt hat, kann diesen Teststapel verwenden. Gegebenenfalls kann ein Arbeitsstapel als Teststapel verwendet werden. Er dient dann als Bildquelle für den Teststapel.

Eine Vorlage kann direkt im Vorlageneditor mit dem Bild getestet werden, das zum Erstellen der Vorlage verwendet wurde. Wählen Sie zum Starten des Tests Dokument>Test ausführen. Wie bei einer Dokumentverarbeitung wird das Datenformular angezeigt werden und Formatfehler, nicht eindeutige Zeichen und Regelfehler, ausgegeben.

Sie können das Menü Dokument>Ansicht verwenden, um die Anordnung der Fenster zu verändern, und das Menü Dokument>Überprüfung, um die einzelnen Elemente der Überprüfung, nicht eindeutige Zeichen und Regelfehler durchzugehen. Klicken Sie auf die Schaltfläche Dokumenttest beenden, oder wählen Sie Dokument>Test beenden, um den Test zu beenden.

Hinweis: Im Testmodus führt eine Veränderung der Feldränder nicht dazu, dass das Programm das Feld erneut erfasst. Im Gegensatz dazu ist dies bei einer Änderung der Feldränder im Dokumentfenster der Fall.

Um Ihre Vorlage mit anderen Bildern zu testen, wählen Sie einen Teststapel aus (Sie können dies tun, indem Sie im Vorlageneditor Extras>Zu Stapeltest wechseln… wählen). Bevor das Dialogfeld zur Stapelauswahl angezeigt wird, prüft das Programm die aktuelle Vorlage auf Fehler. Wenn die Vorlage fehlerfrei ist, wird sie gespeichert und das Dialogfeld zur Stapelauswahl wird angezeigt. Wenn Sie in diesem Dialogfeld einen Stapel auswählen, wird das Programmfenster aktiviert und wechselt automatisch zum neu gewählten Stapel.

Es wird empfohlen, jede Vorlage mit mindestens 20 Dokumentbildern zu überprüfen (wenn Dokumente von Hand ausgefüllt werden, empfiehlt es sich, Dokumente mit verschiedenen Handschriften zu testen).

Beim Testen muss Folgendes überprüft werden:

  1. Ist eine ausreichende Anzahl markierter Anker und Objekte zur Identifizierung für eine bestimmte Anwendung einer Vorlage auf ein Bild vorhanden?
  2. Wurden die Feldeigenschaften korrekt konfiguriert?
  3. Wurden die Regeln korrekt konfiguriert?
  4. Wurde der Export korrekt konfiguriert?

Beim Testen müssen Sie die gesamten Vorgänge durchführen, die beim Verarbeiten von Dokumenten anfallen.

Wenn beim Testen Regelfehler, falsche Feldwerte o. ä. erkannt werden, müssen Sie die Vorlage bearbeiten, um die Fehler zu korrigieren.

Sie können die Vorlage nur nach Beheben aller Fehler veröffentlichen und dann die Masseneingabe von Dokumenten beginnen.

Arbeiten mit einem konfigurierten Projekt


Bildimportprofile

Der Operator startet den Vorgang durch Hinzufügen neuer Bilder. Dabei kann es sich um Papierdokumente handeln, die gescannt werden müssen, oder um vorhandene elektronische Bilder.

Häufig durchgeführte Vorgänge zum Hinzufügen von Bildern gleichen Ursprungs können automatisiert werden, sodass der Importvorgang mit nur einem Klick durchgeführt werden kann. Dazu müssen Sie ein Bildimportprofil erstellen. Sie können darüber hinaus auch noch die Verarbeitung eingehender Bilder und das regelmäßige Hinzufügen von Bildern im Hintergrund konfigurieren. Nach dem Festlegen der erforderlichen Einstellungen können die Bilder durch Klicken auf nur eine Schaltfläche gescannt oder aus einer zuvor definierten Quelle importiert und verarbeitet werden (z. B. Entfernen von Störungen). Sie können bei Bedarf die Quelle für den Bildimport oder die entsprechenden Einstellungen ändern.

Wenn sich die Importquellen häufig ändern, können Sie mehrere Importprofile erstellen und zwischen diesen Profilen wechseln, sodass Sie nicht jedes Mal die Einstellungen für die Importquelle ändern müssen.

Erstellen eines Importprofils

Wählen Sie zum Hinzufügen eines Importprofils im Hauptfenster des Programms die Menüoptionen Projekt > Bildimportprofile… aus. Im daraufhin geöffneten Dialogfeld können Sie Importprofile erstellen, bearbeiten, löschen und kopieren.

Sie können neue Importprofile mithilfe des Assistenten für Importprofile erstellen. Der Assistent kann durch Klicken auf Neu… im Dialogfeld Bildimportprofile ausgeführt werden. Wählen Sie im ersten Schritt des Assistenten eine Importquelle aus, z. B. einen Scanner oder Hot Folder.

Erstellen eines Importprofils mit einem Scanner
  1. Wählen Sie als Importquelle die Option Scanner aus.

    Wichtig: Der Scanner muss angeschlossen sein. Anweisungen zum ordnungsgemäßen Anschluss des Scanners finden Sie in der zugehörigen Dokumentation. Vergewissern Sie sich, dass alle mit dem Scanner gelieferten Softwarekomponenten installiert sind.

  2. Im zweiten Schritt können Sie die Optionen zum Scannen und Verarbeiten der Bilder festlegen:
    • Stil des Dialogfelds 'Scannereinstellungen': Wählen Sie die Verbindung zwischen Programm und Scanner aus.
      • FlexiCapture-Scannereinstellungen: Das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture wird zum Konfigurieren der Scanoptionen verwendet. Klicken Sie auf die Schaltfläche Einstellungen…, um Scanoptionen zu konfigurieren. Wenn Sie die Option Scannereinstellungen vor dem Scannen anzeigen auswählen, wird bei der Auswahl des entsprechenden Importprofils vor dem Scannen das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture angezeigt.
      • Scanoptionen: Das Dialogfeld des entsprechenden Scannertreibers wird zum Konfigurieren der Scanoptionen verwendet. In diesem Fall können Sie beim Erstellen eines Importprofils die Scanoptionen nicht ändern. Das Dialogfeld für die Einstellungen des Scanners wird jedoch jedes Mal vor dem Scannen von Bildern angezeigt.
    • Geben Sie an, ob ein Bild oder mehrere Bilder in einem Durchgang gescannt werden sollen.
  3. Konfigurieren Sie die Optionen für die Bildverarbeitung. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.
  4. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.

    5. Wichtig: Wenn der Administrator, der das Importprofil mithilfe eines Scanners erstellt hat, anderen Benutzern dieses Computers mit den üblichen Benutzerrechten (Mitglieder der Gruppe Benutzer) das Erstellen oder Bearbeiten von Importprofilen ermöglichen möchte, dann muss er diesen Benutzern das Recht zum Ändern der Datei %allusersprofile%\Application Data\ABBYY\FlexiCapture\Scanning\Profiles gewähren.

Erstellen eines Importprofils mit einem Hot Folder
  1. Wählen Sie als Importquelle die Option Hot Folder aus. Klicken Sie auf die Schaltfläche Durchsuchen…, um den Pfad für den Hot Folder anzugeben.

    Wichtig: Zum Hinzufügen von Bildern zum Hot Folder müssen Sie über Lese- und Schreibzugriff für diesen Ordner verfügen.

  2. Legen Sie im zweiten Schritt die Optionen zum Laden von Bildern fest:
    • Hot Folder alle: Aktivieren Sie diese Option, und geben Sie ein Zeitintervall ein, in dem automatisch überprüft wird, ob der Hot Folder neue Bilder enthält.

      Hinweis: Die überprüfung des Hot Folders wird gestartet, wenn Sie Bilder mithilfe eines Profils importieren, bei dem die Option Hot Folder alle aktiviert ist. Die überwachung des Hot Folders wird beendet, wenn Sie das Projekt beenden oder in den Eigenschaften des Profils die Option Hot Folder alle deaktivieren.

    • Aktivieren Sie unter Stapeleinstellungen eine der Optionen zum Festlegen des Stapels, dem neue Bilder hinzugefügt werden.
      • Bilder zum aktuellen Stapel hinzufügen: Aktivieren Sie diese Option, um Bilder aus dem Hot Folder zum aktuellen Stapel hinzuzufügen.
      • Bilder zum angegebenen Stapel hinzufügen: Aktivieren Sie diese Option, und wählen Sie in der Dropdownliste den Stapel aus, dem Bilder hinzugefügt werden sollen.
      • Neue Stapel für importierte Bilder automatisch erstellen: Aktivieren Sie diese Option, damit für neue Bilder automatisch Stapel erstellt werden.
    • Wählen Sie in der Dropdownliste Anzahl der hinzuzufügenden Dateien einen Wert aus, um die Anzahl der Dateien festzulegen, die dem angegebenen oder neu erstellten Stapel hinzugefügt werden sollen.
      • Entsprechend Beschreibungsdatei: Dateien werden entsprechend der Beschreibung hinzugefügt. Klicken Sie auf die Schaltfläche Einstellungen…, um den Namen und den Typ der Beschreibungsdatei anzugeben. Ausführliche Informationen finden Sie unter Beschreibungsdatei.
      • Alle Dateien: Alle Dateien aus dem Hot Folder werden hinzugefügt.
      • Mehrere Dateien: Mehrere Dateien werden hinzugefügt. Klicken Sie zum Angeben der Anzahl der Dateien auf die Schaltfläche Einstellungen…, und geben Sie die Anzahl oder den Wertebereich ein.
      • Hinweis: Wenn Sie eine bestimmte Anzahl von Dateien, z. B. 5, angeben und sich im Hot Folder nur 4 Dateien befinden, werden diese Dateien nicht importiert. Wenn Sie einen Bereich festlegen, z. B. 1-5, werden die restlichen 5 Dateien importiert.
      • Einzelne Datei: Es wird nur eine Datei hinzugefügt.
  3. Im nächsten Schritt können Sie Optionen zum Hinzufügen von Bildern zu Dokumenten sowie Optionen für die Bildverarbeitung festlegen. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.

  4. Im vierten Schritt werden Sie im Assistenten für Importprofile aufgefordert, Optionen zur Handhabung der Dateien im Hot Folder nach dem Import anzugeben: Erfolgreich importierte Bilder können gelöscht oder in einen bestimmten Ordner verschoben werden. Bilder, die mit Fehlern verarbeitet wurden, können im Hot Folder verbleiben oder ebenfalls in einen bestimmten Ordner verschoben werden. Wenn Bilder verschoben werden sollen, geben Sie die entsprechenden Ordner an.

  5. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.

Der Name des erstellten Bildimportprofils wird im Dropdownmenü der Importschaltfläche angezeigt. Wenn Sie einen Bildimport mit diesem Profil durchführen möchten, müssen Sie lediglich auf das Pfeilsymbol rechts neben der Schaltfläche klicken und dann das Profil auswählen.

Sie können darüber hinaus im Dialogfeld Importprofil auswählen Importprofile erstellen und bearbeiten. Wählen Sie im Dropdownmenü der Importschaltfläche die Option Bilder importieren… aus, um dieses Dialogfeld zu öffnen.

Hinzufügen von Seitenbildern


Optionen zur Bildvorverarbeitung

Wenn neue Bilder zu einem Stapel hinzugefügt werden, führt das Programm eine Bildvorverarbeitung durch: Die Bilder werden in Dokumente unterteilt, Störungen werden beseitigt, sie werden gedreht usw.

Die Optionen zur Bildvorverarbeitung können Sie in der Registerkarte Bildvorverarbeitung auswählen. Die Optionen für die Bildvorverarbeitung können für folgende Programmbereiche ausgewählt werden:

  1. Ein Projekt. In diesem Fall werden die ausgewählten Optionen standardmäßig verwendet, wenn neue Bilder manuell zu Projektstapeln hinzugefügt werden. Wählen Sie im Hauptfenster Projekt>Projekteigenschaften…, und klicken Sie auf die Registerkarte Bildvorverarbeitung.
  2. Ein Importprofil. Diese Optionen werden verwendet, wenn das entsprechende Importprofil zum Hinzufügen neuer Bilder verwendet wird. Wählen Sie beim Erstellen eines neuen Importprofils die gewünschten Optionen zur Bildvorverarbeitung im Schritt Bildvorverarbeitung aus.
  3. Manuell hinzugefügte Bilder. Klicken Sie beim Hinzufügen von Bildern aus einer Datei auf die Schaltfläche Einstellungen für die Bildverarbeitung… im Dialogfeld Bilder laden.

Hinweis: Wenn Bilder manuell gescannt werden, findet keine Bildvorverarbeitung statt. Bilder durchlaufen nur dann die Bildvorverarbeitung, wenn zum Hinzufügen ein Importprofil verwendet wird.

Die Benutzer können aus den folgenden Vorverarbeitungsoptionen beliebig auswählen:

  • Optionen, welche die Vorgehensweise beim Hinzufügen von Bildern zu Dokumenten festlegen:
    • Automatisch bei Zuweisung der Vorlage: Wählen Sie diese Option aus, wenn Sie möchten, dass die Bilder während der Zuordnung (bei der Erkennung) in Dokumente aufgeteilt werden. In diesem Fall werden die Bilder nicht sofort beim Hinzufügen in Dokumente aufgeteilt, und die Dokumente werden erst zusammengestellt, wenn die Seiten auf der Grundlage der in der entsprechenden Vorlage beschriebenen Struktur analysiert und erkannt wurden. Ausführliche Informationen hierzu finden Sie unter Erstellen von Vorlagen für mehrseitige Dokumente und Zusammenstellen von Seiten in Dokumenten.
    • Für jede Bilddatei: Wenn Sie diese Option auswählen, wird die Einstellung auf jede Bilddatei angewendet.
    • Für Bilder getrennt durch: Beim Vorliegen eines Trennblatts wird ein neues Dokument erstellt.

    • Wenn Sie leere Seiten als Trennblätter verwenden möchten, wählen Sie in der Dropdownliste die Option Leere Seiten aus.
      Wenn Sie Seiten mit Barcodes als Trennblätter verwenden möchten, wählen Sie in der Dropdownliste die Option Seiten mit Barcode aus. Sie können den Barcodetyp und/oder Barcodewert durch Klicken auf die Schaltfläche Einstellungen… festlegen. Wenn kein Barcodetyp oder -wert angegeben ist, wird jede Seite mit einem Barcode als Trennseite verwendet. Andernfalls werden nur Seiten mit den angegebenen Barcodetypen oder -werten verwendet. Wenn keine Trennseiten zum Stapel hinzugefügt werden sollen, wählen Sie Trennseiten löschen. Wenn diese Option nicht aktiviert ist, werden die Trennseiten dem Stapel hinzugefügt und in den einzelnen Dokumenten jeweils als erste Seite verwendet.

    Hinweis: Sie müssen die Seiten zwischen Dokumenten nicht mithilfe von Trennseiten aufteilen. Trennseiten müssen nur verwendet werden, wenn es aufgrund der Darstellung einer Seite nicht möglich ist zu ermitteln, ob sie zum vorherigen oder nächsten Dokument gehört. Dies ist beispielsweise der Fall, wenn ein Dokument mehrere identische Seiten und der Stapel mehrere solcher Dokumente enthält.

  • Konfigurieren Sie die Optionen für die Bildverarbeitung:
    • Störungen in Bildern entfernen: Störungen in Bildern werden entfernt.
    • Farb- und Graustufenbilder in Schwarz-Weiß-Bilder konvertieren: Die Bilder werden in Schwarz-Weiß-Bilder umgewandelt.
    • Bilder drehen um: Die Bilder werden in die angegebene Richtung gedreht.
  • Entzerrungsoptionen. Standardmäßig sind diese Optionen aktiviert, und das Programm entzerrt neu hinzugefügte Bilder auf der Grundlage von schwarzen Quadraten und/oder vertikalen und horizontalen Trennlinien. Es ist nicht zu empfehlen, die Entzerrungsoptionen auszuschalten, solange kein Fehler bei der Entzerrung auftritt (z. B., wenn das Programm einen Stempel oder eine Grafik als Trennlinie interpretiert und versucht, das Bild auf der Grundlage dieser falschen Daten zu entzerren).
    • Verzerrung durch schwarze Trennlinien korrigieren: Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von Trennlinien entzerrt.
    • Verzerrung durch schwarze Quadrate korrigieren: Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von schwarzen Quadraten entzerrt.


Standardexporteinstellungen

Standardexporteinstellungen werden beim Exportieren von Daten in eine Datei oder Datenbank ohne Vorlageneinstellungen sowie für Vorlagen verwendet, in denen keine Exporteinstellungen konfiguriert wurden.

Exporteinstellungen sind normalerweise für jede Dokumentvorlage konfiguriert. Es kann jedoch vorkommen, dass Sie die Daten in einen anderen Speicherort exportieren möchten, z. B. bei einem Testexport. In diesem Fall können Sie die Daten über die Exportschaltfläche mit Einstellungen, die von den Vorlageneinstellungen abweichen, in eine Datei oder Datenbank exportieren. Siehe dazu Exportieren erkannter Daten. Beim erstmaligen Export werden die Standardeinstellungen verwendet. Wenn die Exporteinstellungen geändert werden, werden jeweils die zuletzt verwendeten Einstellungen gespeichert.

Die Standardeinstellungen zum Exportieren von Daten in eine Datei oder Datenbank können auf der Registerkarte Export des Dialogfelds Projekteigenschaften (Menüoption Projekt > Projekteigenschaften… im Hauptfenster) konfiguriert werden. Auf dieser Registerkarte werden die aktuellen Standardexporteinstellungen angezeigt. Sie können Einstellungen für den Export in eine Datei oder in eine Datenbank konfigurieren. Wenn Sie die Standardexporteinstellungen ändern möchten, klicken Sie auf Exporteinstellungen ändern…, und legen Sie Exporteinstellungen fest, die den Exporteinstellungen in der Vorlage ähneln (siehe Konfigurieren des Datenexports).


Dokumentstapel

Die zur Verarbeitung gesendeten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde.

Wenn Sie Stapel zu einem Projekt hinzufügen möchten, klicken Sie mit der rechten Maustaste in das Hauptfenster, und wählen Sie im Kontextmenü mit der Liste der Stapel die Option Neuer Stapel aus.

Wenn ein Projekt keine Stapel enthält, wird beim Hinzufügen von Bildern automatisch ein Stapel erstellt.

Die Seitenbilder eines Dokuments werden während der Eingabe in einem Durchgang hinzugefügt. Ausführliche Informationen hierzu finden Sie unter Hinzufügen von Seitenbildern.

Wenn Sie Dokumente anzeigen möchten, die einem Stapel hinzugefügt wurden, öffnen Sie den entsprechenden Stapel durch Doppelklicken. über das Dokumentfenster können Sie wieder zur Liste der Stapel wechseln, indem Sie im Hauptmenü die Optionen Projekt > Liste der Arbeitsstapel auswählen.

Arbeits- und Teststapel

Arbeitsstapel werden zum Verarbeiten von Dokumenten verwendet. Im Operatormodus sind nur Arbeitsstapel verfügbar. Administratoren verwenden Teststapel beim Konfigurieren von Vorlagen. Der Unterschied zwischen diesen Stapeln besteht darin, dass Dokumente aus Teststapeln mit einer lokalen Vorlage verarbeitet werden, während die Verarbeitung von Dokumenten aus Arbeitsstapeln mit einer veröffentlichten Vorlage erfolgt. Siehe auch Administrator- und Operatormodus und Bearbeiten und Veröffentlichen einer Vorlage.

Sie können die Liste der Dokumentstapel im Hauptfenster über Projekt öffnen. Arbeitsstapel: Liste der Arbeitsstapel, Teststapel: Liste der Teststapel.


Indexfelder

Um die Suche und Verarbeitung von Dokumenten zu vereinfachen, können Sie Dokumente mit den Werten von Feldern in einer Vorlage indizieren. Sie können dann zusätzlich zu den allgemeinen Informationen in den Dokumentlisten im Hauptfenster des Programms für jedes Dokument die Werte der Indexfelder ausgeben, die Dokumente nach diesen Werten sortieren und die gewünschten Dokumente auf einfache Weise suchen.

Aktivieren Sie für die Indizierung nach Feldwerten für das entsprechende Feld die Option Indexfeld (Registerkarte Allgemein im Dokumentvorlageneditor).

So zeigen Sie den Wert des Indexfelds in der Dokumentliste an:

  • öffnen Sie im Hauptfenster des Programms einen Dokumentstapel, und aktivieren Sie den Modus für die detaillierte Dokumentliste (Schaltfläche [image] in der Symbolleiste).
  • Klicken Sie mit der rechten Maustaste in den Bereich der Tabellenkopfzeile (Spaltennamen), und wählen Sie in der Dropdownliste die Option Anpassen… aus.
  • Klicken Sie im Dialogfeld Dokumenttabelle anpassen auf die Schaltfläche Neu….
  • Klicken Sie im Dialogfeld Spalte bearbeiten auf die Schaltfläche Auswählen… rechts neben dem Indexfeld. Wählen Sie im daraufhin geöffneten Dialogfeld eines der Felder aus, bei denen die Indexfeld aktiviert ist. Sie können auch einen Spaltennamen eingeben und die entsprechende Indizierungsmethode festlegen.
  • In der Tabelle wird eine neue Spalte mit dem Wert des Indexfelds angezeigt. Klicken Sie auf diese Spalte, um Dokumente nach dem Wert des Indexfelds zu sortieren.


Arbeiten mit einem konfigurierten Projekt

Damit Operatoren Dokumente verarbeiten können, muss ein Administrator zunächst Projekteinstellungen vornehmen. Die Dokumentverarbeitung kann so konfiguriert werden, dass sich die Arbeit der Operatoren beim Scannen und dem Import von Bildern sowie bei der Erkennung und dem Export von Daten auf ein Minimum beschränkt. In diesem Fall besteht die wesentliche Aufgabe von Operatoren darin, die erkannten Daten zu überprüfen und gegebenenfalls zu korrigieren. Dies erfolgt in der Phase der überprüfung.

Die jeweils verwendeten Dokumenttypen haben keine Auswirkungen auf die Arbeit der Operatoren.

Die Dokumentverarbeitung erfolgt in vier Schritten. Jeder Phase entspricht dabei eine Schaltfläche in der Symbolleiste.

1. Hinzufügen von Bildern

über das Pfeilsymbol rechts neben der Schaltfläche können Sie eine der folgenden Optionen für den Bildimport auswählen: Bilder laden…, Bilder scannen… oder Bilder importieren... mit einem der konfigurierten Bildprofile. Die Beschriftung der Schaltfläche ändert sich je nach der ausgewählten Aktion.

2. Erkennung

über diese Schaltfläche wird die Erkennung von Dokumenten durchgeführt. über das Pfeilsymbol rechts neben der Schaltfläche können Sie zudem Dokumente analysieren oder eine Vorlage zuordnen.

3. überprüfung

über diese Schaltfläche wird der überprüfungsvorgang durchgeführt. über das Pfeilsymbol können Sie darüber hinaus eine regelbasierte Validierung durchführen.

4. Export

über diese Schaltfläche wird der Datenexport entsprechend den Einstellungen in der Vorlage gestartet. Durch Klicken auf das Pfeilsymbol können die Daten in eine Datei oder Datenbank exportiert werden.


Hinzufügen von Seitenbildern

Die Verarbeitung von Dokumenten beginnt mit dem Bildimport, d. h. dem Hinzufügen von Seitenbildern der Dokumente zu einem Projekt. Wählen Sie einen Arbeitsstapel aus, oder erstellen Sie einen neuen Arbeitsstapel, dem die Bilder hinzugefügt werden sollen. Klicken Sie zum Erstellen eines Stapels mit der rechten Maustaste in das Hauptfenster des Programms, und wählen Sie Neuer Stapel aus. öffnen Sie den entsprechenden Stapel durch Doppelklicken, oder markieren Sie ihn in der Liste.

Hinweis: Beim Hinzufügen von Bildern zu einem Projekt ohne Stapel wird automatisch ein Dokumentstapel erstellt.

Bilder können folgendermaßen zu Stapeln hinzugefügt werden:

  1. Laden zuvor gespeicherter Bilder aus Dateien
  2. Scannen der Bilder
  3. Importieren der Bilder mit einem der Bildimportprofile, die zuvor von einem Administrator erstellt wurden (siehe Bildimportprofile)

Klicken Sie auf das Pfeilsymbol rechts neben der Importschaltfläche, und wählen Sie eine der Optionen zum Hinzufügen von Bildern aus.

Hinzufügen von Bildern aus einer Datei

Wenn Sie Bilder aus einer Datei laden möchten, wählen Sie die Option Bilder laden… aus, oder drücken Sie Strg+O auf der Tastatur. Wählen Sie im daraufhin geöffneten Dialogfeld die gewünschte Bilddatei aus, und konfigurieren Sie die folgenden Optionen für den Bildimport:

  • Neues Dokument erstellen: Für die hinzugefügten Bilder werden neue Dokumente erstellt.
  • Zum aktuellen Dokument hinzufügen: Die Bilder werden zum aktuellen markierten Dokument hinzugefügt.
  • Sie können zudem Optionen für die Vorverarbeitung eines Bilds auswählen. Klicken Sie im Dialogfeld für die Bildvorverarbeitung auf die Schaltfläche Einstellungen für die Bildverarbeitung…, und wählen Sie die gewünschten Optionen im angezeigten Dialogfeld aus. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung

Scannen von Bildern

Wählen Sie zum Hinzufügen von Bildern von einem Scanner die Option Bilder scannen… aus. Wählen Sie einen Scanner aus, konfigurieren Sie die Scanoptionen, und scannen Sie anschließend die Bilder.

Hinzufügen von Bildern mithilfe von Importprofilen

Wenn vom Administrator Importprofile konfiguriert wurden, werden sie im Menü der Importschaltfläche angezeigt. Um Bilder zu importieren, müssen Sie lediglich eines der Importprofile auswählen.

Wenn Sie Bilder importieren… auswählen, wird das Dialogfeld Importprofil auswählen geöffnet. Wählen Sie in der Liste ein Importprofil aus, und klicken Sie auf die Schaltfläche Importieren, um den Importvorgang zu starten. Im Administratormodus können Sie in diesem Dialogfeld darüber hinaus ein neues Importprofil erstellen oder vorhandene Profile bearbeiten.

Bildimport im Hintergrund

Bildimporte können im Hintergrund durchgeführt werden, wenn ein entsprechendes Importprofil konfiguriert wurde. Bilder aus dem Hot Folder werden automatisch in das System importiert. In dem in den Einstellungen festgelegten Zeitintervall wird automatisch überprüft, ob der Hot Folder neue Bilder enthält.

Die überwachung des Hot Folders wird gestartet, wenn Sie Bilder mithilfe eines Profils importieren, bei dem die Option Hot Folder alle aktiviert ist. Sie wird beendet, wenn Sie das Projekt beenden oder in den Eigenschaften des Profils die Option Hot Folder alle deaktivieren. Detaillierte Informationen finden Sie unter Bildimportprofile.

Hinweis: Um Bilder zum Hot Folder hinzufügen zu können, müssen Sie über Lese- und Schreibzugriff für diesen Ordner verfügen.


Konfigurieren von Scanoptionen

Die Qualität der Erkennung hängt größtenteils von der Qualität der gescannten Bilder ab. Die Qualität der Bilder kann durch Konfigurieren der allgemeinen Scaneinstellungen für den Bildtyp, die Auflösung und die Helligkeit reguliert werden.

Beim Scannen von Bildern mit ABBYY FlexiCapture kann auf zweierlei Weise eine Verbindung zwischen dem Programm und den Scannern über den TWAIN- oder ISIS-Treiber hergestellt werden:

  • über die Schnittstelle von ABBYY FlexiCapture:
    In diesem Fall werden die Scanoptionen im ABBYY FlexiCapture-Dialogfeld Scannereinstellungen konfiguriert. Die Scanoptionen können beim Erstellen eines Importprofils festgelegt werden, bei dem Scanner als Importquelle angegeben ist.
  • über die Schnittstelle des TWAIN- oder ISIS-Treibers des Scanners:
    Dabei werden die Scanoptionen im Dialogfeld des entsprechenden Scannertreibers konfiguriert. Dieses Dialogfeld wird automatisch geöffnet, wenn Sie im Dropdownmenü der Importschaltfläche die Option Bilder scannen… auswählen.

Allgemeine Scanoptionen

  • Bildtyp: Das Scannen in Graustufen (256 Grautöne) ist der optimale Modus für das Erkennungssystem. Wenn Sie im Graustufenmodus scannen, wird der Grad derHelligkeit automatisch ausgewählt.

    Durch den Bildtyp Schwarz-weiß erhöht sich die Scangeschwindigkeit auf Kosten einiger Buchstabeninformationen. Dies wirkt sich möglicherweise auf die Erkennungsqualität von Dokumenten mit mittlerer und schlechter Druckqualität aus.
    Wenn Farbelemente eines Dokuments (Bilder, farbige Buchstaben oder Farbhintergrund) im elektronischen Dokument farbig dargestellt werden sollen, muss dagegen der Bildtyp Farbe ausgewählt werden. In anderen Fällen eignet sich wiederum der Bildtyp Graustufen besser.

  • Die Werte für Helligkeit und Kontrast müssen so ausgewählt werden, dass erstens die Ankerblöcke beibehalten werden und zweitens die zur Erkennung vorgesehenen Bilder der Blöcke möglichst klar und eindeutig dargestellt werden.
    In den meisten Fällen eignet sich hierfür der mittlere Helligkeitswert von 50 %.
    Unter Umständen müssen Sie beim Scannen bestimmter Dokumente im Schwarz-Weiß-Modus den Helligkeitsgrad ändern.
  • Auflösung: Für die Verarbeitung von Formularen, die von Hand ausgefüllt werden, empfiehlt sich im Schwarz-Weiß-Modus eine Auflösung von 300 dpi und im Graustufenmodus eine Auflösung von 200 dpi. Die Auflösung gescannter Formulare muss mit der Auflösung des Vorlagenbilds übereinstimmen.

Hinweise:

  1. Scanvorgänge mit einer Auflösung von 400 bis 600 dpi anstelle von 300 dpi sowie im Graustufen- oder Farbmodus anstelle des Schwarz-Weiß-Modus dauern unter Umständen erheblich länger. Bei einigen Scannermodellen dauern Scanvorgänge mit einer Auflösung von 600 dpi viermal so lange wie Scanvorgänge mit einer Auflösung von 300 dpi. Vom Scannen mit einer Auflösung unter 200 dpi wird abgeraten.
  2. Wenn Sie die Scanoptionen im Dialogfeld des Scannertreibers konfigurieren, können die entsprechenden Optionen je nach Scannermodell abweichende Bezeichnungen tragen. Die Helligkeit wird beispielsweise als Schwellenwert bezeichnet oder mit einer Sonne oder einem schwarz-weißen Kreis angezeigt. Erklärungen zu den einzelnen Einstellungen finden Sie in der Dokumentation des jeweiligen Scanners.
Tipps zum Scanmodus
  1. Scannen von Formularen mit Farbhintergrund mit einem Schwarz-Weiß-Scanner: Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie den Scanner mit einer entsprechenden Lampe zum Filtern des Lichts ausrüsten. Verwenden Sie bei rosafarbenen Formularen eine rote Lampe und bei grünen Formularen eine grüne Lampe.
  2. Scannen von Formularen mit Farbhintergrund mit einem Farbscanner: Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie in den Scannereinstellungen den Filtermodus für die entsprechende Farbe konfigurieren.
  3. Scannen von Formularen mit Farbhintergrund in hellen Farbtönen: Wenn Sie Formulare mit hellen Farbtönen verarbeiten, wird der Hintergrund aufgrund der geringen Farbstärke beim Scannen mit einer weißen Lampe möglicherweise auch ausgeblendet, wenn in den Scaneinstellungen keine Farbfilter ausgewählt sind. In der Regel wird das Verfahren zum Scannen von Formularen beim Entwerfen der Formulare gewählt.
Tipps zur Auswahl des Helligkeitsgrads
  1. Ein gescanntes Bild muss lesbar sein (öffnen Sie das gescannte Bild im Dokumentfenster).
  2. Wenn Buchstaben im gescannten Bild unvollständig, hell oder ausgebrochen angezeigt werden, gehen Sie folgendermaßen vor:
    • Verringern Sie den Helligkeitsgrad, und erhöhen Sie den Kontrast (das Bild wird dunkler).
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).
  3. Wenn das gescannte Bild einen fleckigen Hintergrund, verzerrte, verschmierte oder verschwommene Zeichen oder dunkle bzw. fette Buchstaben aufweist, gehen Sie wie folgt vor:
    • Erhöhen Sie den Helligkeitsgrad (das Bild wird heller).
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).


Erkennung

Klicken Sie zum Aktivieren der Erkennung auf die Schaltfläche Erkennen. Im Programm wird eine Vorlage anhand von Ankern und Objekten zur Identifizierung ausgewählt und zugeordnet. Anschließend wird die Datenerkennung in den Dokumentbereichen durchgeführt, die mit Feldbereichen der ausgewählten Vorlage übereinstimmen.

Die Bilderkennung kann beim Hinzufügen von Bildern zum Stapel automatisch durchgeführt werden. Aktivieren Sie dazu die Option Hinzugefügte Bilder automatisch erkennen (Menü Extras im Hauptfenster, Registerkarte Dokumentverarbeitung unter Optionen…).

In der Spalte Grad der Zuverlässigkeit wird das Verhältnis von eindeutig erkannten Zeichen und zur Gesamtanzahl der Zeichen angezeigt. Nach der Erkennung können Sie die Dokumentüberprüfung ausführen.

Vor der Erkennung können Sie bei Bedarf eine Voranalyse von Bildern und Vorlagenzuordnung ausführen.


Voranalyse von Bildern und Vorlagenzuordnung

Vor der Erkennung können Sie eine Analyse durchführen, in der festgestellt wird, welche Vorlage einer bestimmten Seite zugeordnet werden kann. Wählen Sie dazu im Hauptmenü die Optionen Import & Erkennung > Analysieren aus, oder klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen, und wählen Sie Analysieren aus. Wenn eine Vorlage zugeordnet werden kann, werden die Seite und das Dokument entsprechend benannt. Wenn dem Bild keine Projektvorlage zugeordnet werden kann, wird die Seite nicht verarbeitet.

Sie können einer Seite oder einem vollständigen Dokument auch eine bestimmte Vorlage zuordnen. Größtenteils werden Seiten ordnungsgemäß erstellte Vorlagen automatisch zugeordnet. In einigen Fällen müssen Sie jedoch möglicherweise Vorlagen manuell zuordnen.

So ordnen Sie eine Dokumentvorlage zu:

  1. Markieren Sie das entsprechende Dokument.
  2. Wählen Sie im Kontextmenü des Dokuments die Option Vorlage zuordnen… oder im Hauptmenü die Optionen Import & Erkennung> Vorlage zuordnen… aus, oder klicken Sie auf das Pfeilsymbol rechts neben der Schaltfläche Erkennen, und wählen Sie Vorlage zuordnen… aus.
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Dokumentvorlage eine der Vorlagen aus, und klicken Sie dann auf OK.

Nachdem die ausgewählte Vorlage erfolgreich zugeordnet wurde, wird dem Dokument und den zugehörigen Seiten der Name der entsprechenden Vorlage und der zugehörigen Bereiche zugewiesen.

So ordnen Sie eine Vorlage einer Seite zu:

  1. Markieren Sie die entsprechende Seite.
  2. Wählen Sie im Kontextmenü der Seite die Option Vorlage zuordnen… oder im Hauptmenü die Option Import & Erkennung > Vorlage zuordnen… aus.
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Zuzuordnende Vorlage auswählen eine der Vorlagen aus, und klicken Sie dann auf OK.

Wenn die Vorlage erfolgreich zugeordnet wird, wird der ausgewählten Seite der Name des entsprechenden Vorlagenbereichs zugeordnet.


überprüfung erkannter Daten

Die überprüfung der erkannten Daten ist die arbeitsintensivste Aufgabe von Operatoren. Aus diesem Grund wurde der überprüfungsprozess in ABBYY FlexiCapture 8.0 Professional so konzipiert, dass einerseits die Benutzerfreundlichkeit für Operatoren im Vordergrund steht und sich die Anzahl möglicher Fehler andererseits auf ein Minimum reduziert.

Wenn bestimmte Zeichen nicht mit absoluter Sicherheit erkannt werden können, werden sie im Programm als nicht eindeutig erkannt gekennzeichnet. Bei der überprüfung wird geprüft, ob diese Zeichen richtig erkannt wurden. Bei Bedarf werden dann eventuelle Korrekturen vorgenommen.

Die regelbasierte Validierung wird automatisch durchgeführt. Wenn Feldwerte den festgelegten Regeln entsprechen, können die entsprechenden Felder als eindeutig erkannt gekennzeichnet und aus dem Validierungsvorgang ausgenommen werden. Felder, deren Werte nicht den Regeln entsprechen, werden zur überprüfung weitergeleitet.

Bei mehrseitigen Dokumenten muss zunächst die Zusammenstellung der Seiten in Dokumenten überprüft werden.

Starten Sie dann den überprüfungsvorgang. Klicken Sie dazu auf die Schaltfläche Überprüfung ausführen…, oder wählen Sie überprüfung > Überprüfung ausführen… aus. Die überprüfung erfolgt in zwei Schritten: Zunächst wird eine Gruppen- und anschließend eine Feldüberprüfung durchgeführt. Wenn eine Vorlage keine Felder zur Gruppen- oder Feldüberprüfung enthält (siehe Feldüberprüfungseigenschaften), wird der entsprechende überprüfungsschritt übersprungen.

Nach der Gruppen- und Feldüberprüfung können Sie die Zeichen im Dokumentfenster überprüfen. Die Zeichen, die in früheren Schritten nicht bestätigt wurden, werden weiterhin rot angezeigt.

Durch Klicken auf die Schaltfläche [image] oder [image] in der Symbolleiste des Hauptfensters können Sie durch die einzelnen Fehler navigieren. Dabei werden alle Fehlerkategorien angezeigt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler usw.

Zusammenstellen von Seiten in Dokumenten
Gruppenüberprüfung
Feldüberprüfung
überprüfung im Dokumentfenster
Regelbasierte Validierung


Zusammenstellen von Seiten in Dokumenten

Seiten werden automatisch in Dokumenten zusammengestellt. Beim Erstellen von Vorlagen für mehrseitige Dokumente müssen Sie hierfür die entsprechenden Zusammenstellungsregeln definieren. Sie können zudem die überprüfung von Schlüsselfeldern festlegen.

Operatoren müssen eventuelle Fehler bei der Dokumentzusammenstellung identifizieren und korrigieren.

Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt. Klicken Sie auf die Schaltfläche [image], um in die Gliederungsansicht zu wechseln.

Hinweis: Sie können die Größe der Seitengliederung ändern, um Details anzuzeigen. Drehen Sie dazu bei gedrückter Strg-Taste das Scrollrad der Maus in die gewünschte Richtung.

Hinweis: Die Reihenfolge der Bereiche wird beim Erstellen der Dokumentvorlage nicht überprüft, wenn die Option Prüfung der Bereichsreihenfolge deaktivieren auf der Registerkarte Zusammenstellung ausgewählt wurde. Das Programm wird weiterhin überprüfen, ob alle Bereiche im Dokument vorhanden sind, aber die Reihenfolge wird dabei ignoriert..

Sie müssen beim Erstellen von Dokumentvorlagen eine Regel für die Dokumentzusammenstellung definieren, d. h. Reihenfolge und Anzahl wiederholter Dokumentbereiche. Zudem können Sie die überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren. Dabei müssen die Werte der Schlüsselfelder auf allen Seiten des Dokuments gleich sein.

Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Die entsprechende Fehlerbeschreibung wird unterhalb der Dokumentvorlage rot angezeigt.

Korrigieren von Zusammenstellungsfehlern

  1. Falsche Reihenfolge der Seiten in einem Dokument

    Möglicherweise enthält das Dokument zu viele oder zu wenige Seiten, oder die Dokumentseiten sind nicht in der richtigen Reihenfolge angeordnet. Wenn Sie den entsprechenden Tipp lesen möchten, setzen Sie den Mauszeiger auf die Seite mit dem roten Kreuz.

    Diese Fehler können Sie korrigieren, indem Sie die entsprechende Seite mit dem Mauszeiger in einem Dokument oder zwischen verschiedenen Dokumenten verschieben.

    Seiten mehrerer Dokumente können wie folgt in einem Dokument zusammengeführt werden:

    • Markieren Sie die entsprechenden Dokumente (durch Klicken bei gedrückter Strg-Taste können Sie mehrere Dokumente markieren).
    • Klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Verbinden aus.

    So trennen Sie Seiten in einem Dokument und positionieren sie jeweils in einem separaten Dokument:

    • Markieren Sie das Dokument, in dem Seiten getrennt werden sollen.
    • Wählen Sie im Kontextmenü die Option Teilen aus.

  2. Wenn in einer Vorlage festgelegt ist, dass die Zusammenstellung von Seiten anhand von Schlüsselfeldern überprüft wird, werden die Schlüsselfeldwerte jeweils unterhalb der Seitenbilder angezeigt.

    • Bei übereinstimmung werden die Werte grau angezeigt.
    • Bei Nichtübereinstimmung werden sie rot angezeigt.

    Schlüsselfelder stimmen möglicherweise nicht überein, wenn sie erkannt oder falsch ausgefüllt wurden. überprüfen Sie die Werte der Schlüsselfelder. Wenn die Werte weiterhin nicht übereinstimmen, handelt es sich wahrscheinlich nicht um die Seiten ein und desselben Dokuments. Wenn die Seiten in der falschen Reihenfolge angeordnet sind, suchen Sie Seiten mit identischen Schlüsselfeldern, und stellen Sie sie in Dokumenten zusammen (siehe Punkt 1).


Gruppenüberprüfung

Bei der Gruppenüberprüfung werden Zeichenbilder, die mit identischen Werten erkannt wurden, gruppiert und im überprüfungsfenster angezeigt, sodass der Operator die von der Gruppe abweichenden Zeichen einfach identifizieren und korrigieren kann.

Fenster für die Gruppenüberprüfung anzeigen

Während der Gruppenüberprüfung können Sie den Kontext des überprüften Zeichens anzeigen, indem Sie im Kontextmenü des markierten Zeichens die Option Zeichenbild anzeigen auswählen oder die Taste F2 drücken.

Sie können zudem einen Modus aktivieren, in dem das Feld des überprüften Zeichens angezeigt wird, wenn Sie den Mauszeiger auf das Zeichen setzen. Wählen Sie dazu im überprüfungsfenster die Menüoptionen Ansicht >Feldbild > Feldbild anzeigen aus, oder drücken Sie Strg+I auf der Tastatur.

Falsch erkannte Zeichen können wie folgt korrigiert werden: Markieren Sie das Zeichen, das nicht mit der Zeichengruppe übereinstimmt, und geben Sie das richtige Zeichen ein. Dieser Wert wird links oben im Zeichenbild grün angezeigt.

Wenn selbst nach der Anzeige eines Zeichens in seinem Kontext Zweifel bestehen, klicken Sie mit der linken Taste auf das Zeichen. Es wird dann mit einem roten Fragezeichen gekennzeichnet.

Der Status von Zeichen kann darüber hinaus über die Schaltfläche Status ändern in der Symbolleiste geändert werden.

Durch Auswählen von Bestätigen im Kontextmenü können Sie richtig erkannte Zeichen bestätigen. Wenn Sie alle Zeichen auf einmal bestätigen möchten, klicken Sie in der Symbolleiste auf die Schaltfläche Alle bestätigen.

Hinweis: Beim Erstellen einer Vorlage können Sie beim Festlegen der Feldeigenschaften die überprüfungsoptionen ändern. Bei Zeichen, für die im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung die Option Bei Gruppenüberprüfung einschließen aktiviert ist, wird eine Gruppenüberprüfung durchgeführt. Siehe Feldüberprüfungseigenschaften. Es empfiehlt sich, die Gruppenüberprüfung nur bei Auswahlfeldern und Feldern durchzuführen, in denen nur Zahlen eingegeben werden können. Buchstaben sollten dagegen im Kontext eines Felds überprüft werden.


Feldüberprüfung

Die Feldüberprüfung dient zur effektiven Korrektur von Formatfehlern bei leicht erkennbaren Feldern, d. h. Feldern, deren Wertebereich bekannt ist oder einfach identifiziert werden kann. Beispiele für diese Felder sind Länder oder Orte. Die Werte dieser Felder sind im Vorfeld bekannt.

Um zu entscheiden, wie der Fehler in einem Feld korrigiert werden muss, muss der Benutzer lediglich das Feld anzeigen und den entsprechenden Wertebereich kennen. Sowohl Eingabefehler als auch Fehler beim Feldformat können berichtigt werden.

Fenster für die Feldüberprüfung anzeigen

Sie können falsch erkannte Zeichen mit den Standardmodi von Texteditoren korrigieren, d. h. Einfügen oder Ersetzen von Zeichen. Durch Drücken der Einfg-Taste auf der Tastatur können Sie zwischen den beiden Modi wechseln.

Sie können die Erkennungsergebnisse der einzelnen Felder überprüfen, sie gegebenenfalls korrigieren und durch Klicken auf die Schaltfläche Feld bestätigen bestätigen.

Die Werte dieser Felder müssen berichtigt werden. Wenn sie nicht korrigiert werden können, können Sie das entsprechende Feld überspringen oder ablehnen, um es zu einem späteren Zeitpunkt zu korrigieren. Klicken Sie dazu auf die Schaltfläche Aufschieben.

Hinweis: Bei Feldern, für die im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung die Option Bei Feldüberprüfung einschließen aktiviert ist, wird eine Feldüberprüfung durchgeführt. Siehe Feldüberprüfungseigenschaften. Es empfiehlt sich, bei einzeiligen Feldern mit einem bekannten Wertebereich eine Feldüberprüfung durchzuführen.


überprüfung im Dokumentfenster

Im Dokumentfenster können Sie die Genauigkeit der Erkennung überprüfen und falsch erkannte Zeichen korrigieren. Das Dokumentfenster wird geöffnet, wenn Sie auf den Namen der Seite doppelklicken. Das Dokumentfenster umfasst den Datenbereich, das Seitenbild und den Bereich für Regelfehler (sofern Fehler aufgetreten sind). Durch Klicken auf die Schaltfläche Layout können Sie das Layout des Fensters festlegen. Im Dokumentfenster können nicht nur Zeichengruppen oder einzelne Felder, sondern das gesamte Dokument angezeigt werden.

Dokumentfenster anzeigen

Im Datenbereich werden nicht eindeutig erkannte und fragliche Zeichen farbig angezeigt. Felder mit falschen Datentypen oder nicht eingehaltenen Regeln werden hervorgehoben.

Wenn Sie ein Feld mit nicht eindeutig erkannten Zeichen bestätigen möchten, setzen Sie den Mauszeiger in das Feld, und drücken Sie die Eingabetaste.

Felder zum Anzeigen und Bearbeiten erkannter Daten können nicht nur nacheinander, sondern in jeder gewünschten Weise angeordnet werden. Sie können die Anordnung der Felder im Dokumentvorlageneditor ändern. Siehe dazu Konfigurieren der Datendarstellung im Dokumentfenster.

Sie können zum nächsten Fehler im Dokumentfenster wechseln, indem Sie in der Symbolleiste des Hauptfensters auf die Schaltfläche [image] oder [image] klicken. über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.


Regelbasierte Validierung

Nicht eingehaltene Regeln sind durch eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet.

Regelfehler werden im Dokumenteditor in einem separaten Fenster angezeigt. Dokumente mit nicht eingehaltenen Regeln sind durch rote Markierungen gekennzeichnet.

Bei Dokumenten mit nicht eingehaltenen Regeln muss der Operator die Qualität der Datenerkennung überprüfen. Wenn es sich um einen Erkennungsfehler handelt, muss dieser behoben werden. Wenn es sich um einen Fehler beim Ausfüllen eines Formulars handelt, der nicht korrigiert werden kann, sollte das Dokument nicht exportiert werden. Dokumente mit Fehlern können zu einem späteren Zeitpunkt überprüft werden, indem sie mit Papierdokumenten oder anderen verfügbaren Quellen verglichen werden.

Klicken Sie zum erneuten überprüfen der Regeln auf das Pfeilsymbol rechts neben der Schaltfläche Überprüfung ausführen…, und wählen Sie die Menüoption Regeln erneut überprüfen aus. Wenn die Dokumente nach dem ändern der Feldwerte den Regeln entsprechen, werden die Markierungen entfernt.


Exportieren erkannter Daten

Nach der überprüfung der erkannten Daten exportiert der Operator den Stapel durch Klicken auf die Schaltfläche Exportieren. Der Export erfolgt entsprechend den Einstellungen der Dokumentvorlage.

Sie können die Daten zudem in eine Datei oder Datenbank exportieren, ohne die Exporteinstellungen einer Vorlage zu verwenden.

Hinweis: Beim Exportieren der Daten in eine Datei oder Datenbank können Sie die Standardeinstellungen beibehalten oder bei Bedarf ändern. Die Standardeinstellungen sind im Eigenschaftendialogfeld des Projekts (Projekt > Projekteigenschaften…) auf der Registerkarte Export festgelegt. Siehe Standardexporteinstellungen.

Export in eine Datei

  1. Wenn Sie Daten in eine Datei exportieren möchten, klicken Sie auf das Pfeilsymbol rechts neben der Exportschaltfläche, und wählen Sie die Option In Datei exportieren… aus.
  2. Wählen Sie den Speicherort und das Präfix für den Dateinamen aus. Der Name beginnt mit diesem Präfix, gefolgt vom Namen der Dokumentvorlage, dem Namen des Stapels und der Dokumentnummer, wenn Sie die einzelnen Dokumente jeweils als separate Datei speichern (siehe Punkt 3).
  3. Folgende Optionen sind verfügbar:
    • Für jedes Dokument eine Datei erstellen: Die Daten von Dokumenten werden jeweils in separaten Dateien gespeichert.
    • Vorhandene Dateien überschreiben: Die Exportdatei wird überschrieben.
    • Dokumentbilder speichern: Die Dokumentbilder werden gespeichert.
  4. Wenn Sie andere Exporteinstellungen ändern möchten, klicken Sie auf die Schaltfläche Einstellungen…. Ausführliche Informationen zur Exportkonfiguration finden Sie unter Konfigurieren des Datenexports.
  5. Wenn Sie die geänderten Exporteinstellungen speichern möchten, klicken Sie im Dialogfeld Exporteinstellungen für Datei auf die Schaltfläche In Dokumentvorlage speichern, und wählen Sie die Dokumentvorlage aus, in der die aktuellen Einstellungen gespeichert werden sollen.

Export in eine Datenbank

  1. Wenn Sie Daten in eine Datenbank exportieren möchten, klicken Sie auf das Pfeilsymbol rechts neben der Exportschaltfläche, und wählen Sie die Option In Datenbank exportieren… aus.
  2. Stellen Sie eine Verbindung mit einer Datenbank her. Ausführliche Informationen finden Sie unter Export in eine Datenbank.
  3. Klicken Sie auf die Registerkarte Bilder, und legen Sie die Einstellungen zum Speichern der Bilder fest.

Hinweise:

  1. Dokumente, deren Daten erfolgreich exportiert wurden, können anschließend automatisch im Stapel gelöscht werden. Aktivieren Sie dazu im Dialogfeld Optionen auf der Registerkarte Dokumentverarbeitung die Option Verarbeitete Dokumente nach Export löschen.
  2. Wenn Sie Dokumente mit Regelfehlern exportieren, wird eine Fehlermeldung angezeigt. Regelwarnungen haben keine Auswirkungen auf den Exportvorgang.


Hintergrundmodus

Wenn keinerlei Interaktion mit dem Operator erforderlich ist, dann kann das Importieren, Erkennen und Exportieren von Dokumenten im Hintergrundmodus ausgeführt werden.

Klicken Sie zum übertragen eines Tasks in den Hintergrundmodus auf die Schaltfläche Hintergrundmodus im Dialogfeld Bilder werden hinzugefügt… (oder in den Dialogfeldern Erkennungsvorgang wird durchgeführt… oder Export wird durchgeführt…).

Folgende Tasks können im Hintergrundmodus ausgeführt werden:

  • Das Laden von Bildern aus einem Hot Folder mithilfe des entsprechenden Importprofils
  • Die Dokumenterkennung, sofern die Option Hinzugefügte Bilder automatisch erkennen aktiviert ist (Extras > Optionen…, Registerkarte Dokumentverarbeitung)

Wenn in den Hintergrundmodus umgeschaltet wird, dann wird in der Taskleiste das Symbol [image] angezeigt. Durch Klicken auf dieses Symbol wird das Dialogfeld Hintergrundtasks aufgerufen, in dem die Liste der Tasks angezeigt wird.

  • Die Tasks werden entweder in der Reihenfolge ihres Aufrufs oder auf der Grundlage der vom Benutzer (mithilfe der Schaltfläche Priorität festlegen…) angegebenen Prioritäten ausgeführt.
  • Die Ausführung der Tasks wird in einer Protokolldatei protokolliert, die vom Benutzer angepasst werden kann (Extras > Optionen…, Registerkarte Taskstatus). Klicken Sie auf die Schaltfläche Protokoll anzeigen, um das Protokoll anzuzeigen.
  • Sie können einen Task unterbrechen, indem Sie auf die Schaltfläche Task beenden klicken.

Das Programm informiert Sie gegebenenfalls über den Fortschritt eines Hintergrundtasks mithilfe von Popup-Meldungen, die in der rechten unteren Ecke angezeigt werden. Die Meldungen werden beim Start, bei einem Fehler und bei der Fertigstellung eines Tasks angezeigt. Einzelheiten finden Sie unter Zusätzliche Optionen.


Anhang

Erstellen von maschinenlesbaren Formularen
Tastaturbefehle
Verwenden von Skripten in FlexiCapture 8.0
Vergleich von Regeln in FormReader 6.5 und FlexiCapture 8.0 Professional
Unterstützte Erkennungssprachen
Schriftarten für die korrekte Darstellung von Zeichen
Unterstützte Texttypen
Unterstützte Barcodetypen
Unterstützte Grafikformate
Exportdateiformate
Alphabet in regulären Ausdrücken
Patente
Technologien anderer Unternehmen


Erstellen eines maschinenlesbaren Formulars

Fragebögen, Versicherungs- und Umfragebögen oder Garantiekarten sind verschiedene Formulararten, mit denen unterschiedliche Informationen und Daten eingeholt werden.

Wie unterscheiden sich Formulare von anderen Dokumenttypen?

  1. Ein Formular weist immer eine bestimmte Anzahl von Feldern auf.
  2. Jedes Feld enthält dabei nur eine bestimmte Art von Information. So sollte z. B. im Feld "Nachname" nur der Nachname eingetragen sein und im Feld "Datum" nur das Datum.

Formulare werden verwendet, wenn Sie von einer großen Anzahl von Personen Informationen einholen müssen. Die Zusammenstellung dieser Daten von Hand ist in der Regel ein langwieriger und zeitaufwändiger Vorgang, bei dem sich Tippfehler und andere Fehler kaum vermeiden lassen. Durch maschinenlesbare Formulare lässt sich dieser Prozess automatisieren.

Die automatisierte Formularverarbeitung umfasst die folgenden Schritte:

  1. Einrichten einer Anwendung zur Formularverarbeitung (erstellen einer Vorlage und Bestimmen der zu erkennenden Felder)
  2. Erfassen von Formularbildern (durch Scannen)
  3. Verarbeiten der Formularbilder (Erkennung der Bilder und Überprüfung der extrahierten Daten)
  4. Exportieren der extrahierten Daten in eine externes Informationssystem
Nicht alle Formulare eignen sich für die automatische Eingabe. Damit ein Formular maschinell verarbeitet werden kann, müssen bestimmte Voraussetzungen erfüllt sein. Diese Voraussetzungen werden in diesem Kapitel besprochen.

Maschinenlesbares Formular
Elemente auf maschinenlesbaren Formularen
Methoden zum Ausfüllen des Formulars
Arten von maschinenlesbaren Formularen
Auswählen der richtigen Formularart
Allgemeine Voraussetzungen für maschinenlesbare Formulare


Maschinenlesbares Formular

Um die Informationen auf einem Formular lesen zu können, muss eine Anwendung zur Formularverarbeitung zu Folgendem in der Lage sein:

  1. Bestimmen der Position der Formularelemente
  2. Trennen des Feldinhalts von Feldrändern, Textmarkierungen, Hintergrund, erklärendem Text usw.

Maschinenlesbare Formulare ermöglichen dem Programm die Durchführung dieser Aufgaben.

Damit die Positionsbestimmung ordnungsgemäß durchgeführt werden kann, muss das Formular einem Musterformular bzw. einer Vorlage entsprechen, d. h. die Formularelemente müssen auf allen Formularen eines Typs gleich angeordnet sein.

Um den zweiten Schritt ordnungsgemäß durchführen zu können, müssen die Formulare bereits für die maschinelle Verarbeitung entworfen worden sein, damit das Programm problemlos zwischen den zu erfassenden Daten und den nicht zu erkennenden Elementen wie Feldgrenzen, Textmarkierungen, Hintergrund und erklärenden Informationen unterscheiden kann.


Elemente auf maschinenlesbaren Formularen

Sie können die folgenden Elemente in einem Formular verwenden:

Text
Eingabefeld
Markierungsfeld
Markierungsgruppe
Referenzzeichen
Trennlinie
Formularkennzeichnung
Bild
Tabelle
Elementgruppe


Erstellen eines maschinenlesbaren Formulars und von Text

Text

Text ist ein Element auf einem maschinenlesbaren Formular mit beschreibendem Text: Formularname, Feldnamen, Erläuterungen usw.


Eingabefeld

Ein Eingabefeld ist ein Element auf einem maschinenlesbaren Formular, in das die Person, die das Formular ausfüllt, Text eingibt. Um die Texteingabe zu erleichtern, können Sie die Eingabefelder mit einer speziellen Textmarkierung versehen. Zu den Eingabefeldern gehört in der Regel noch weiterer Text, der die Art der einzugebenden Daten erklärt.

Beispiel für ein Eingabefeld anzeigen

Die folgende Tabelle enthält mögliche Arten von Textmarkierungen:

Text über Linie | Text wird auf einer Linie eingetragen.
Buchstaben in Rahmen | Buchstaben werden in Feldern mit angrenzenden Rahmen eingetragen.
Buchstaben in separaten Rahmen | Buchstaben werden in einzeln eingerahmte Felder eingetragen.
Buchstaben auf Kamm | Buchstaben werden in Kammfelder eingetragen.
Text in Rahmen | Text wird in einen Rahmen eingetragen.
Text im Rahmen mit Kamm | Text wird in einen Rahmen mit Kamm eingetragen.


Markierungsfelds

Markierungsfeld

Bei einem Markierungsfeld handelt es sich um ein Element auf einem maschinenlesbaren Formular (in der Regel ein als 'Ankreuzfeld' bezeichnetes Kästchen), in das die Person, die das Formular ausfüllt, eine Markierung einfügen sollte.

Die folgende Tabelle zeigt mögliche Formen für Markierungsfelder.

Quadrat
Kreis
Unterstrich

Sie können jedoch auch andere Formen wie Polygone, Ovale usw. verwenden.


Markierungsgruppe

Bei einer Markierungsgruppe handelt es sich um ein Element auf einem maschinenlesbaren Formular, das mehrere Markierungsfelder zusammenfasst, von denen nur eines ausgefüllt werden muss. Markierungsgruppen verfügen in der Regel noch über weiteren Text, der die Art der Auswahl erklärt.

Beispiel für eine Markierungsgruppe anzeigen


Anker

Bei einem Referenzzeichen handelt es sich um ein Element auf einem maschinenlesbaren Formular, das die Zuordnung von Formularbildern zu Vorlagen sowie die Bestimmung der Ausrichtung der Formulare während der automatischen Verarbeitung ermöglicht.

Vor der Erkennung des Formularinhalts muss das Formular der entsprechenden Vorlage zugeordnet werden. Alle maschinenlesbaren Formulare eines Typs müssen derselben Vorlage zugeordnet werden, d. h. die Formularelemente müssen sich auf allen Formularen an genau derselben Stelle befinden. Das Programm gleicht das Formular mit der Vorlage ab und bezieht sich dabei auf die Anzahl und Position der Referenzzeichen auf dem Formular. Stimmen die Referenzzeichen auf dem Formular mit den Referenzzeichen auf der Vorlage überein, weiß das Programm genau, an welcher Stelle es die Felder mit den zu erkennenden Daten finden kann.

Die folgende Tabelle enthält eine Übersicht über die standardmäßigen Referenzzeichen.

Schwarzes Quadrat
Ecke
Kreuz
Zeitmarkierung

Für gute Erkennungsergebnisse sollte das Formular standardmäßige Referenzzeichen enthalten. Gelegentlich können jedoch auch Trennlinien, erklärender Text oder Strichcodes als Referenzzeichen verwendet werden. Die standardmäßigen Referenzzeichen sind jedoch zuverlässiger und sollten vorzugsweise verwendet werden.


Erstellen eines maschinenlesbaren Formulars und einer Trennlinie

Trennlinie

Bei einer Trennlinie handelt es sich um ein Element auf einem maschinenlesbaren Formular, das die Form einer vertikalen oder horizontalen schwarzen Linie hat.

Sie können mithilfe von Trennlinien Formulare in logische Abschnitte unterteilen.


Erstellen eines maschinenlesbaren Formulars und einer Formularkennzeichnung

Formularkennzeichnung

Bei einer Formularkennzeichnung handelt es sich um ein Element auf einem maschinenlesbaren Formular, mit dem die richtige Vorlage ausgewählt wird, sollten mehrere Vorlagen mit der gleichen Referenzzeichenanordnung vorhanden sein.

ABBYY empfiehlt, Strichcodes als Formularkennzeichnung zu verwenden.

Ein Strichcode besteht aus einer Reihe schwarzer und weißer vertikaler Linien mit unterschiedlicher Breite, die zur Kodierung von Informationen dienen.

Beispiel für einen Strichcode anzeigen
Sie können jedoch auch noch andere Elemente auf dem Formular als Formularkennzeichnung verwenden.


Erstellen eines maschinenlesbaren Formulars und eines Bilds

Bild

Bei einem Bild handelt es sich um ein Element auf einem maschinenlesbaren Formular, das nicht erkannt und als Bilddatei exportiert werden sollte (nicht zu verwechseln mit dem Bild einer Seite, siehe oben).

So handelt es sich z. B. bei dem Teil des Formulars, der für einen Stempel oder eine Unterschrift vorgesehen ist, um ein Bild.


Tabelle

Eine Tabelle enthält Spalten mit Elementen gleichen Typs.

Tabellenspalten können folgende Typen von Elementen enthalten:

  • Text
  • Eingabefeld
  • Datum
  • Zahl
  • Auswahlfeld

Tabellen können eine Zeile mit Spaltenüberschriften enthalten.


Elementgruppe

Elementgruppe: Element eines maschinenlesbaren Formulars, das dazu dient, mehrere logisch verknüpfte Elemente in einer Gruppe zusammenzufassen.


Methoden zum Ausfüllen des Formulars

Sie können ein Formular auf eine der folgenden Weisen ausfüllen:

  • von Hand

  • mit einem Matrixdrucker

  • mit einer Schreibmaschine

  • in einer Druckerei (hierzu gehören auch mit Tinten- und Laserdruckern ausgefüllte Formulare mit einer Auflösung von mindestens 300 DPI)

  • eine Kombination der oben angeführten Methoden


Arten von maschinenlesbaren Formularen

Maschinenlesbare Formulare werden bereits mit Blick auf die automatische Verarbeitung entworfen, d. h. das Programm sollte problemlos zwischen den zu erfassenden Daten und nicht zu erkennenden Formularelementen wie z. B. Feldgrenzen, Textmarkierungen, Hintergrund und erklärendem Text unterscheiden können.

Es stehen dabei die folgenden beiden Möglichkeiten zur Verfügung:

  1. Das Formular wird so entworfen, dass Feldgrenzen, Hintergrund und Textmarkierungen beim Scannen verschwinden ODER

  2. Das Formular wird so entworfen, dass Feldgrenzen, Hintergrund und Textmarkierungen nach dem Scannen deutlich hervorgehoben sind.

Wenn Sie den ersten Ansatz verwenden, bleiben nach dem Scannen lediglich Referenzzeichen, erklärender Text und die eingetragenen Daten erhalten. Daher muss das Programm die relevanten Daten nicht von den Formularelementen trennen, was die Erkennung erleichtert und somit zuverlässiger macht.

Verwenden Sie für den ersten Ansatz die folgenden Formulartypen: Blindfarbenformulare, Schwarzweißformulare mit Rasterhintergrund, Schwarzweißformulare mit Rasterrahmen und lineare Schwarzweißformulare.

Wenn Sie den zweiten Ansatz verwenden, bleiben erklärender Text, die eingegebenen Daten sowie Textmarkierungen und Feldgrenzen nach dem Scannen auf dem Formular erhalten. Das Programm sucht in diesem Fall nach Daten, die von einem Feldrahmen und einer Textmarkierung eingeschlossen sind. Sind diese Formularelemente nicht vorhanden, wirkt sich dies negativ auf die Erkennungsqualität aus.

Verwenden Sie beim zweiten Ansatz lineare Schwarzweißformulare.


Blindfarbenformular

Blindfarbenformulare haben einen hellen Hintergrund mit weißen Rechtecken, die als Zeichenzellen dienen, sowie Markierungsfeldern usw. Bei einer Zeichenzelle handelt es sich um ein kleines Rechteck, in das nur ein Zeichen eingetragen werden sollte (z. B. ein Buchstabe oder eine Ziffer). Die Farbe des Hintergrunds ist von großer Bedeutung, da sie während des Scannes eliminiert werden muss. Der Hintergrund bei solchen Formularen ist in der Regel hellgrün oder ein helles Rotorange. Eine Liste der empfohlenen Farben finden Sie unter Empfohlene Farben für Blindfarbenformulare.

Beispiel für ein Blindfarbenformular

Beim Scannen sollten idealerweise alle Formularelemente außer den Referenzzeichen eliminiert werden, sodass danach lediglich die Feldinhalte auf dem Formularbild erkannt werden müssen.

Erklärende Informationen können entweder erhalten bleiben (wenn sie schwarz gedruckt sind) oder gemeinsam mit dem Hintergrund herausgefiltert werden. Damit erklärender Text während des Scannens eliminiert wird, muss er in der Farbe des Hintergrunds, jedoch mit einer größeren Sättigung gedruckt werden.

Ziehen Sie bei der Entscheidung, ob erklärender Text schwarz oder in der Hintergrundfarbe gedruckt werden soll, Folgendes in Betracht:

  • Die Bilddatei wird größer, wenn erklärender Text erhalten bleibt.

  • Zwischen dem schwarzgedruckten erklärenden Text und den übrigen Formularelementen sollte mindestens ein Abstand von 1,5 mm - 2 mm gewahrt sein. Der Abstand zwischen dem erklärenden Text und dem zugehörigen Markierungsfeld sollte mindestens 2/3 der Größe des Markierungsfelds betragen. Wenn Sie den erklärenden Text in der Farbe des Hintergrunds drucken, ist der Abstand zwischen dem Text und den übrigen Formularelementen nicht so wichtig.

Formulare, bei denen erklärender Text schwarz gedruckt wurde, sind einfacher zu lesen. Wir empfehlen, erklärenden Text schwarz zu drucken, insbesondere wenn das Formular keine Referenzzeichen enthält.

Tipp
Wenn Sie eine Vorlage erstellen, bei der erklärender Text in der Farbe des Hintergrunds gedruckt wird, sollten Sie sicherstellen, dass das Formular in Farbe oder im Graustufenmodus gescannt wird, sodass der erklärende Text und die Formularelemente auf dem Formular gut zu sehen sind.

Blindfarbenelemente müssen mit einer Farbleuchte oder einem Filter gescannt werden. Die Farbe der Leuchte wird anhand der Hintergrundfarbe ausgewählt.

Formulare mit rotem oder grünen Hintergrund müssen auf eine der folgenden Weisen gescannt werden:

  • mit einem Farbscanner mit Farbfiltersoftware

  • mit einem Schwarzweißscanner mit roter oder grüner Lampe (Hardwarefarbfilterung)

  • mit einem Schwarzweißscanner mit weißer Leuchte und einem Filter für Rot oder Grün. (Die Filterqualität ist in diesem Fall erheblich niedriger, sodass der Hintergrund u. U. nicht ganz eliminiert oder Feldinhalt versehentlich entfernt wird.)

  • mit einem Schwarzweißscanner mit einer weißen Leuchte ohne jegliche Filter.
    Wenn Sie mit einer weißen Leuchte scannen, kann hellerer Hintergrund ohne Filterung entfernt werden: der Hintergrund verschwindet aufgrund der geringen Sättigung während des Scannens. In diesem Fall müssen Sie für den jeweiligen Scanner einzeln ausprobieren, welche Farbe und Sättigung am besten für den Hintergrund geeignet sind.

Hinweis: Viele Farbscanner verfügen zudem über Filtersoftware, mit der blaue Farben gefiltert werden können. Wir raten jedoch davon ab, blaue Farben auf einem Formular zu verwenden, da Formulare in der Regel mit einem schwarzen oder blauen Stift ausgefüllt werden. Mit Blau geschriebener Feldinhalt geht in diesem Fall verloren.

Auswahl der richtigen Farbe

Rotorange Farben sind besser geeignet als Grün, da sie den größten Kontrast zu Blau bieten und so die besten Ergebnisse beim Scannen und der Erkennung erzielt werden, falls das Formular mit einem blauen Stift ausgefüllt wurde.

Der Abschnitt Empfohlene Farben für Blindfarbenformulare enthält weitere Informationen zu den für die Formularverarbeitung empfohlenen Farben, d. h. den Farben, die beim Scannen mit einem beliebigen Scanner am wahrscheinlichsten eliminiert werden. Darüber hinaus können Sie in der Regel vom Händler oder Hersteller Ihres Scanners eine Übersicht über die bei diesem Scanner am besten verwendeten Farben für Blindfarbenformulare (Pantone oder andere Formate) erhalten.


Schwarzweißformulare mit Rasterhintergrund

Bei den Feldern auf diesen Formularen handelt es sich um einfache weiße Rechtecke auf einem Rasterhintergrund. Der Hintergrund wird aus einer Vielzahl einzelner Punkte aufgebaut. Die Größe der Punkte sollte möglichst nicht über 0,1 mm liegen und der Abstand zwischen den einzelnen Punkten sollte etwa 1 mm betragen. Die Punktgröße sowie der Abstand zwischen den Punkten sind von ausschlaggebender Bedeutung, da der Rasterhintergrund nicht beim Scannen, sondern während der Fleckenentfernung eliminiert wird: Das Programm betrachtet die Punkte als überflüssige Elemente und beseitigt sie. Daher sollten die Punkte auf dem gescannten Bild nicht zusammenkleben.


Schwarzweißformulare mit Rasterrahmen

Diese Formulare verfügen über keinen Hintergrund. Alle Feldgrenzen (für Zeichenzellen, Markierungsfelder und andere Formularelemente) werden anhand von Rasterlinien, d. h. Reihen von kleinen schwarzen Punkten, angezeigt. Die Größe der Rasterpunkte sollte zwischen 0,39 Punkt und 0,5 Punkt liegen. Wir empfehlen 0,39 Punkt, wobei der Abstand zwischen den Rasterpunkten mindestens das Fünffache der Punktgröße betragen muss. Die Punktgröße und der Abstand zwischen den Punkten sind von größter Bedeutung, da der Rasterhintergrund nicht beim Scannen, sondern während der Entfernung von Flecken eliminiert wird: Das Programm betrachtet die Punkte als überflüssige Elemente und beseitigt sie. Daher sollten die Punkte auf dem gescannten Bild nicht zusammenkleben.


Lineare Schwarzweißformulare

Dieser Formulare verfügen in der Regel über keinen Hintergrund. Alle Feldgrenzen (für Zeichenzellen, Markierungsfelder und andere Formularelemente) werden anhand von durchgezogenen schwarzen Linien angezeigt. Die Feldgrenzen bleiben auch nach dem Scannen und Entfernen von Flecken erhalten.

Hinweis: Diese Art von Formularen muss sehr sorgfältig ausgefüllt werden. Werden die Formulare nachlässig ausgefüllt, gehen die Buchstaben möglicherweise über die Feldgrenzen hinaus, wodurch die Erkennungsqualität beeinträchtigt wird. Dies liegt daran, dass das Programm den Text kaum von der Feldgrenze unterscheiden kann, wenn dieser durch den Feldinhalt überlagert wird. Der eingegebene Text sollte die Feldgrenzen nach Möglichkeit überhaupt nicht berühren.


Auswählen der richtigen Formularart

Sie müssen neben dem Design und der Verarbeitung noch einige weitere Kriterien bei der Auswahl der richtigen Formularart in Betracht ziehen: Druckkosten und -methoden, Anzahl der erforderlichen Exemplare, Bildgröße, Scanmodi, die erforderliche Genauigkeit bei der Erkennung, Geschwindigkeit bei der Formularverarbeitung, allgemeines Erscheinungsbild des Formulars, wie ordentlich die Formulare ausgefüllt werden usw. Die folgende Tabelle führt die Vor- und Nachteile der einzelnen Arten auf.

Merkmal | Blindfarbenformular |  | Schwarzweiß-Rasterformulare |  | Lineare Schwarzweißformulare
 | Nachteil | Vorteil | Nachteil | Vorteil | Nachteil | Vorteil
Komplexität des Entwurfs |  | Leicht mit jedem Grafikeditor zu erstellen. | Texteditoren bieten nur eine begrenzte Anzahl von Werkzeugen für die Erstellung dieser Formularart. Ausschlaggebend ist die Größe der Rasterpunkte. |  |  | Leicht mit jedem Grafikeditor zu erstellen.
Drucken | Es ist problematisch, große Mengen qualitativ hochwertiger Formulare selbst zu drucken. |  |  | Können problemlos vom Benutzer selbst gedruckt werden. |  | Können problemlos vom Benutzer selbst gedruckt werden.
Druckkosten | Wenn Sie die Formulare in einer Druckerei drucken lassen, entstehen höhere Kosten als bei Schwarzweißformularen. |  |  | Wenn Sie die Formulare in einer Druckerei drucken lassen, entstehen hier weniger Kosten als bei Blindfarbenformularen. |  | Wenn Sie die Formulare in einer Druckerei drucken lassen, entstehen hier weniger Kosten als bei Blindfarbenformularen.
Bildgröße |  | Die Bilddateien sind kleiner. | Die Bilddateien sind größer. |  | Die Bilddateien sind größer. |
Scanmodus | Sie können nur bestimmte Scanmodi (Farbfilterung) verwenden. |  | Es steht nur eine beschränkte Anzahl an Helligkeits- und Kontrasteinstellungen zur Verfügung. |  | Es steht nur eine beschränkte Anzahl an Helligkeits- und Kontrasteinstellungen zur Verfügung. |
Verarbeitungsgeschwindigkeit |  | Bietet eine schnellere Verarbeitungsgeschwindigkeit. | Die Verarbeitung dauert in der Regel länger, da Flecken aus den Bildern entfernt werden müssen. |  | Fehler sind wahrscheinlicher, wenn Zeichen zusammenkleben oder über die Feldgrenzen hinausgehen. |
Erkennungsqualität |  | Sehr gute Erkennungsqualität |  | Gute Erkennungsqualität | Die Erkennungsqualität hängt davon ab, wie ordentlich das Formular ausgefüllt wurde. | Gute Erkennungsqualität, wenn das Formular ordentlich ausgefüllt wurde.
Position von erklärenden Informationen |  | Erklärende Informationen können an einer beliebigen Stelle eingefügt werden, auch innerhalb eines Felds (sofern sie mit derselben Farbe wie der Formularhintergrund gedruckt werden). | Erklärende Informationen und andere Formularelemente müssen sorgfältig auf dem Formular platziert werden. |  | Erklärende Informationen und andere Formularelemente müssen sorgfältig auf dem Formular platziert werden. |
Erscheinungsbild des Formulars und Leserlichkeit | Geringe Kontraste beim Hintergrund und den erklärenden Informationen können die Leserlichkeit des Formulars beeinträchtigen. | Ansprechende Gestaltung | Weniger ansprechendes Design. Verminderte Leserlichkeit. |  | Weniger ansprechendes Design | Gute Leserlichkeit
Sorgfalt bei der Ausfüllung |  | Weniger Probleme, wenn Text über die Feldgrenzen hinausgeht. | Kleine Zeichen müssen sehr sorgfältig geschrieben werden, gleichzeitig jedoch groß genug sein, damit sie nicht als überflüssige Elemente erachtet und daher entfernt werden. | Weniger Probleme, wenn Text über die Feldgrenzen hinausgeht. | Viele Probleme, wenn Text über die Feldgrenzen hinausgeht. |


Allgemeine Voraussetzungen für maschinenlesbare Formulare

Maschinenlesbare Formulare müssen einige allgemeine Voraussetzungen erfüllen.

Voraussetzungen für den Formularhintergrund
Voraussetzungen für Referenzzeichen
Voraussetzungen für Markierungsfelder
Voraussetzungen für Textmarkierungen
Voraussetzungen für die Elementposition
Voraussetzungen für die Druckqualität
Voraussetzungen für das Ausfüllen des Formulars


Voraussetzungen für den Formularhintergrund

  1. Verwenden Sie wenn möglich Blindfarbenformulare oder Formulare mit Rasterfeldgrenzen.
  2. Verwenden Sie beim Erstellen eines Blindfarbenformulars eine Farbe, die beim Scannen "verschwindet". Eine Liste der empfohlenen Farben finden Sie unter Empfohlene Farben für Blindfarbenformulare.
  3. Stellen Sie sicher, dass zwischen dem Feldinhalt und dem erklärenden Text ein gewisser Abstand vorhanden ist. Bei Blindfarbenformularen empfehlen wir, dass erklärender Text in der gleichen Farbe wie der Formularhintergrund gedruckt wird (ausgenommen, der erklärende Text wird anstelle von bzw. zusammen mit den schwarzen Quadraten als Referenzzeichen verwendet). Wenn Sie den erklärenden Text in der Farbe des Hintergrunds drucken, können Sie ihn anschließend überall auf dem Formular platzieren, einschließlich innerhalb der Formularfelder.
  4. Verwenden Sie für Formulare, die von Hand ausgefüllt werden, keine blauen Farben. Wird ein Formular mit blauem Hintergrund mit einem blauen Stift ausgefüllt, kann dies die Erkennungsqualität beeinträchtigen.


Voraussetzungen für Referenzzeichen

  1. Sie sollten auf maschinenlesbaren Formularen möglichst standardmäßige Referenzzeichen verwenden (d. h. schwarze Quadrate, Ecken oder Kreuze). Die empfohlene Anzahl von Referenzzeichen ist fünf: vier Referenzzeichen in den vier Ecken des Formulars (wodurch ein Rechteck mit imaginären Linien zwischen den einzelnen Paaren gebildet wird) sowie ein Quadrat auf einer Seite des imaginären Rechtecks.
  2. Sollten Sie aus irgendeinem Grund keine standardmäßigen Referenzzeichen verwenden können, empfehlen wir, ersatzweise die folgenden Elementkombinationen als Referenzzeichen einzusetzen:
    a) mindestens zwei vertikale und zwei horizontale Trennlinien
    b) mindestens vier Textelemente und eine Formularkennzeichnung ODER
    c) eine andere mögliche Kombination.
  3. Der Abstand zwischen dem Rand eines Referenzzeichens und dem nächstgelegenen Formularelement sollte mindestens 3 mm betragen.
  4. Der Abstand zwischen dem Referenzzeichen und dem Seitenrand sollte mindestens 8 mm betragen.
  5. Drucken Sie die Referenzzeichen in einer dunklen Farbe (vorzugsweise Schwarz), sodass sie während des Scanvorgangs nicht verloren gehen.

Zusätzlich zu den oben aufgeführten allgemeinen Voraussetzungen gibt es für jeden Referenzzeichentyp spezielle Voraussetzungen:

Voraussetzungen für schwarze Quadrate

Alle schwarzen Quadrate sollten bei einem Formulartyp dieselbe Größe aufweisen, z. B. 4 x 4 mm oder 8 x 8 mm. Die empfohlene Größe ist 5 x 5 mm. Rechtecke sind nicht zulässig.

Voraussetzungen für Kreuze und Ecken

  1. Die Größe des imaginären Quadrats, das Sie um ein Referenzzeichen dieses Typs ziehen könnten, muss in einem Bereich von 4 x 4 mm bis 8 x 8 mm liegen. Die empfohlene Größe ist 5 x 5 mm.

  2. Die Größe der Referenzzeichen eines Typs muss bei allen Referenzzeichen auf dem Formular gleich sein.

  3. Die Seiten des Referenzzeichens müssen gleich lang sein.

  4. Die Linienstärke muss für alle Referenzzeichen auf dem Formular gleich sein und in einem Bereich von 0,3 mm bis 1 mm liegen. Wir empfehlen eine Linienstärke von 0,5 mm.

Voraussetzungen für Text (wenn Text als Referenzzeichen verwendet wird)

Die Schriftgröße muss mindestens 7 Punkt (bei Überschriften mindestens 14 Punkt) betragen.

Voraussetzungen für Trennlinien (wenn Trennlinien als Referenzzeichen verwendet werden)

Die Linienstärke sollte mindestens 1 Punkt betragen. Wir empfehlen eine Linienstärke von 1 - 1,5 Punkt.

Voraussetzungen für Strichcode (wenn Strichcode als Referenzzeichen verwendet wird)

  1. Die Strichcodebreite (der Abstand zwischen dem ersten und dem letzten Balken im Code) muss mindestens 47 mm - 50 mm betragen.
  2. Die Höhe des Strichcodes sollte mindestens 12 mm - 15 mm (ohne Ziffern) betragen.
  3. Die Ausrichtung des Strichcodes (d. h. die Richtung der Balken) sollte sich nach der Seitenausrichtung richten. (Wir empfehlen, die Seiten in Richtung der Balken zu scannen.)
  4. Wir empfehlen, dass Sie für den Strichcode das EAN 13-Format verwenden.
  5. Der Abstand zwischen einem Strichcode und den anderen Formularelementen sollte mindestens 10 mm betragen.


Voraussetzungen für Markierungsfelder

  1. Die empfohlenen Feldgrößen sind 3,5 x 3,5 mm, 4 x 4 mm, 4,5 x 4,5 mm oder 5 x 5 mm. (Wenn Sie runde Markierungsfelder verwenden, müssen diese in die empfohlenen Größen für die eckigen Felder passen).
  2. Die empfohlene Linienstärke für die Markierungsfeldrahmen beträgt 0,4 mm (unabhängig von der Feldgröße).


Voraussetzungen für Textmarkierungen

Rasterpunktgröße:

  1. Werden die Feldgrenzen als Rasterpunkte dargestellt, muss die Stärke der Rasterlinie (d. h. die Rastergröße) 0,39 Punkt betragen.

  2. Der optimale Abstand zwischen den Rasterpunkten ist das Fünffache der Punktgröße.

    Wichtig! Die Punkte in den Ecken von Zeichenzellen kleben mit relativ großer Wahrscheinlichkeit zusammen.

Tipp
Wenn Sie in Ihrer Software den Abstand zwischen den Rasterpunkten nicht festlegen können, müssen Sie einen Linienstil wählen, bei dem die Punkte so weit auseinander liegen, dass sie auf dem gescannten Bild nicht als zusammengeklebt erscheinen und beim Entfernen von Flecken auf dem Bild gelöscht werden, da das OCR-System große Punkte als bedeutungstragende Elemente interpretiert und sie daher beim Entfernen von Flecken im Bild belässt.

Größe der Zeichenzellen:

  1. Die empfohlene Größe von Zeichenzellen beträgt 4 x 5 mm. Werden kleinere Zeichenzellen verwendet, muss das Formular sehr präzise ausgefüllt werden, was häufig sehr schwierig ist. Verwenden Sie jedoch auch keine zu großen Zeichenzellen, da das Formular sonst unter Umständen mit übergroßen Buchstaben ausgefüllt wird. Die Größe der Zeichenzellen sollte möglichst der durchschnittlichen Größe eines Buchstabens entsprechen.
  2. Der Abstand zwischen den Feldlinien sollte mindestens 2,5 mm - 3 mm betragen und der Abstand zwischen zwei nebeneinander liegenden Zeichenzellen mindestens 1 mm - 1,2 mm.

Beispiel für Zeichenzellen anzeigen

Linienstärke:

  1. Werden die Rahmen durch schwarze Linien angezeigt (bei "Text in Rahmen", "Buchstaben in separaten Rahmen" oder "Buchstaben in Rahmen"), sollte die Linienstärke 1 Punkt betragen.
Beispiel für durch eine schwarze Linie angezeigte Rahmen

Kämme:

  1. Der empfohlene Abstand zwischen den vertikalen Linien in einem Formularfeld mit Kamm beträgt 5 mm.
  2. Wenn zwei Felder mit Kamm untereinander platziert werden, sollte der Abstand zwischen den horizontalen Linien mindestens 7,5 mm - 8 mm betragen.
  3. Die Höhe der vertikalen Linien muss zwischen 0,9 mm und 1,2 mm betragen.
  4. Die Linienstärke der vertikalen Linien und des Rahmens sollte 1 Punkt betragen.
  5. Bei Verwendung von Rahmen mit Kamm muss der Abstand zwischen zwei untereinander platzierten Rahmen mindestens 2,5 mm - 3 mm betragen.
Beispiel für einen Kamm anzeigen


Voraussetzungen für die Elementposition

  1. Lassen Sie auf den Formularen einen ausreichend großen Rand frei. Formularelemente, die sich zu nahe am Seitenrand des Formulars befinden, werden unter Umständen nicht gescannt und die darin enthaltenen Daten gehen somit verloren.
  2. Bewahren Sie einen Abstand zwischen benachbarten Elementen von mindestens 2 mm.
  3. Der Abstand zwischen einem Markierungsfeld und erklärendem Text sollte mindestens 2/3 der Größe des Markierungsfelds betragen.
  4. Stellen Sie sicher, dass der erklärende Text nicht über die Ränder des Eingabefelds hinausgeht.
  5. Werden erklärende Informationen mit schwarzer Tinte gedruckt, stellen Sie sicher, dass zwischen dem erklärenden Text und den anderen Elementen ein Abstand von mindestens 1,5 mm - 2 mm besteht. Wird der erklärende Text in der Farbe des Hintergrunds gedruckt, ist die Einhaltung dieses Abstands von nicht so großer Bedeutung.


Voraussetzungen für die Druckqualität

Beachten Sie beim Drucken leerer Formulare die folgenden Voraussetzungen:

  1. Drucken Sie die Formulare entweder in einer Druckerei oder mit einem Drucker. Farbformulare sollten vorzugsweise von einer Druckerei gedruckt werden. Sollte dies nicht möglich sein, überprüfen Sie die Formularfarbe zuerst mit einem Scanner, bevor Sie den Ausdruck starten.
  2. Alle Exemplare des Formulars müssen anhand desselben Quelldokuments gedruckt werden, da die Feldpositionen auf allen Formularen identisch sein müssen.
  3. Die Randgröße (d. h. der Abstand zwischen dem Seitenrand und dem am nächsten gelegenen Formularelement) sollte mindestens 8 mm betragen (Ränder mit einem Abstand von 12 mm werden jedoch empfohlen).
  4. Die erlaubte lineare Abweichung von Formularelementen darf höchstens 0,15 % betragen (d. h. 0,5 mm bei einem A4-Papierformat).
  5. Wenn Sie die Formulare auf einem Drucker ausdrucken, sollten Sie mindestens eine Auflösung von 600 DPI verwenden.

Verwenden Sie zum Drucken der Formulare eines Stapels immer denselben Drucker. Sollte dies nicht möglich sein, versuchen Sie, zumindest dasselbe Druckermodell zu verwenden.


Voraussetzungen für das Ausfüllen des Formulars

Farbige Stifte und Tinte

Formulare sollten vorzugsweise sorgfältig in Großbuchstaben mit einem schwarzen Kugelschreiber, Füllfederhalter oder Gelstift ausgefüllt werden. (Dunkelblau und Violett können ebenfalls verwendet werden.) Filzstifte sollten möglichst nicht verwendet werden, da hier die Buchstaben in der Regel sehr dick ausfallen und somit Probleme bei der Erkennung verursachen können. Am schwierigsten gestaltet sich die Erkennung von Formularen, die mit Bleistift oder sehr heller Tinte ausgefüllt wurden.

Buchstabengröße und Stil

Um gute Erkennungsergebnisse zu erzielen, sollten Formulare vorzugsweise in Großbuchstaben ausgefüllt werden. Die Buchstaben müssen die Zeichenzellen ausfüllen, dürfen jedoch nicht über die Zellgrenzen hinausgehen.

Sind die Zeichenzellen auf dem Formular sichtbar dargestellt (d. h. wenn die folgenden Textmarkierungsarten verwendet werden: Buchstaben in Rahmen oder Buchstaben in separaten Rahmen), ist es weniger wahrscheinlich, dass die Buchstaben nach dem Ausfüllen des Formulars zusammenkleben.

Die folgenden Textmarkierungstypen werfen bei der Erkennung größere Probleme auf: Text in Rahmen mit Kamm und Buchstaben auf Kamm. Hier ist nur die Breite der Zeichenzellen festgelegt. Da jedoch keine seitlichen Ränder vorhanden sind, kommt es eher vor, dass Buchstaben nach dem Ausfüllen des Formulars zusammenkleben. Bei Buchstaben auf einem Kamm ohne Rahmen werden die Buchstaben häufig entweder zu groß oder zu klein geschrieben.

Wird Text in einem Rahmen bzw. Text über einer Linie verwendet, bestehen keine Einschränkungen für die Breite der Zeichenzellen. Kleben die Buchstaben zusammen, beeinträchtigt dies die Erkennungsqualität. Bei Text über einer Linie gibt es zudem keine Einschränkung für die Zeichenhöhe. Sie sollten diesen Markierungstyp daher nicht für Formulare verwenden, bei denen eine sehr genaue Erkennung erforderlich ist.

Des Weiteren sollten die Buchstaben nicht über die Feldgrenzen hinausgehen. Dies hat bei Blindfarbenformularen und schwarzweißen Rasterformularen keine große Bedeutung, da hier die Feldgrenzen beim Scannen und der Fleckenbeseitigung entfernt werden. Gehen die Buchstaben jedoch bei linearen Schwarzweißformularen über die Feldgrenzen hinaus, kann dies die Erkennungsqualität erheblich beeinträchtigen.

Beispiel

Damit das Formular möglichst sorgfältig ausgefüllt wird, sollten Sie dem Formular eine Anmerkung ähnlich der folgenden hinzufügen:


Empfohlene Farben für Blindfarbenformulare

Die folgende Tabelle enthält Beispiele für Farben, die in Blindfarbenformularen verwendet werden können, und die entsprechenden Pantone-Nummern. Die folgenden Hintergrundfarben verschwinden bei Scannen des Formulars:

  • Mit einem beliebigen Scanner:
    • Tabelle für Scannen mit weißer Leuchte anzeigen
  • Mit einem Farbscanner mit Filtersoftware für Rot oder mit einem Schwarzweißscanner mit roter Leuchte oder einem Filter für Rot
    • Tabelle für Scannen mit roter Leuchte anzeigen


Tastaturbefehle

In diesem Abschnitt finden Sie eine Liste der Tastaturbefehle in den einzelnen Programmfenstern. Tastaturbefehle helfen, Zeit zu sparen, und vereinfachen die Programmnutzung.

Tastaturbefehle im Hauptfenster
Tastaturbefehle im Fenster des Vorlageneditors
Tastaturbefehle im Fenster für die Gruppenüberprüfung
Tastaturbefehle im Fenster für die Feldüberprüfung


Tastaturbefehle im Hauptfenster

Menü | Option | Tastaturbefehle
Datei | Neues Projekt… | Strg+Umschalt+N
 | Projekt öffnen… | Strg+Umschalt+O
 | Speichern | Strg+S
 | Neuer Stapel | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Bilder importieren… | Strg+I
 | Exportieren | Strg+U
 | Datei… | Alt+Umschalt+S
 | Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Details zu Dokumenten anzeigen | Alt+1
 | Dokumente als Miniaturansichten anzeigen | Alt+2
 | Dokumentfenster im Bildmodus anzeigen | Strg+1
 | Dokumentfenster im Datenmodus anzeigen | Strg+2
 | Bildanzeige > Vergrößern | Strg+Num+
 | Bildanzeige > Verkleinern | Strg+Num-
 | Vollbild | F11
 | Eigenschaftendialogfeld des markierten Objekts öffnen | Alt+Eingabetaste
Import & Erkennung | Bilder importieren… | Strg+I
 | Analysieren | Strg+E
 | Vorlage zuordnen… | Alt+Umschalt+E
 | Erkennen | Strg+R
überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächster Zusammenstellungsfehler | F5
 | Vorheriger Zusammenstellungsfehler | Umschalt+F5
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Projekt | Liste der Arbeitsstapel | Strg+B
 | Liste der Teststapel | Strg+Umschalt+B
 | Dokumentvorlagen… | Strg+T
 | Bildimportprofile… | Strg+Umschalt+I
Dienst | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
Hilfe | Hilfe anzeigen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste


Tastaturbefehle im Fenster des Vorlageneditors

Menü | Option | Tastaturbefehle
Vorlage | Seite hinzufügen… | Strg+P
 | Dokumentbereich hinzufügen… | Strg+Alt+S
 | Eigenschaften von Dokumentvorlage… | Strg+T
 | Speichern | Strg+S
 | Schließen | Alt+F4
Bearbeiten | Rückgängig | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Bereich löschen | Umschalt+Entf
 | Alles auswählen | Strg+A
 | Nach Typ auswählen… | Strg+Umschalt+A
 | Feld erstellen > Text | Alt+Umschalt+T
 | Feld erstellen > Auswahlfeld | Alt+Umschalt+C
 | Feld erstellen > Auswahlfeldgruppe | Alt+Umschalt+M
 | Feld erstellen > Barcode | Alt+Umschalt+B
 | Feld erstellen > Bild | Alt+Umschalt+P
 | Feld erstellen > Tabelle | Alt+Umschalt+L
 | Feld erstellen > Gruppe | Alt+Umschalt+G
 | Gruppieren | Strg+G
 | Gruppierung aufheben | Strg+Umschalt+G
 | Text aus Bild kopieren… | Strg+Alt+C
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Wechseln in den Modus für statische Elemente | Strg+1
 | Wechseln in den Modus für Feldbereiche | Strg+2
 | Anzeigen/Ausblenden des Fensters "Dokumentstruktur" | Alt+F1
 | Schaltet das Fenster Dokumentstruktur in den Feldmodus um | Alt+1
 | Schaltet das Fenster Dokumentstruktur in den Seitenmodus um | Alt+2
 | öffnen/Schließen des Fensters Datenformular | Alt+F2
 | Bildanzeige > Vergrößern | Strg+Num+
 | Bildanzeige > Verkleinern | Strg+Num-
 | Eigenschaftendialogfeld des markierten Objekts öffnen | Alt+Eingabetaste
Dokument | Test ausführen. | Strg+R
Dienst | Objekte automatisch erkennen… | Strg+D
 | Dokumentvorlage überprüfen | F9
 | Bereich zuordnen | Strg+E
Hilfe | Hilfe anzeigen | F1

Bildmarkierungsfenster

Option | Tastaturbefehle
Aktivieren des Auswahlwerkzeugs | Esc
Automatische Erkennung von Objekten | Strg+Umschalt+D
Anker erstellen | A
Trennlinie erstellen | S
Ankertext erstellen | X
Ankerbarcode erstellen | D
Text erstellen | T
Auswahlfeld erstellen | C
Auswahlgruppenfeld erstellen | M
Barcode erstellen | B
Bild erstellen | P
Tabelle erstellen | L
Gruppe erstellen | G
Bereich für Feld ohne Bereich erstellen | R
Unerkennbaren Bereich erstellen | O
Spalte erstellen | U
Tabellentrennlinie zeichnen | F
Trennlinie löschen | E
Bereich anpassen | Strg+Alt+A
Name vorschlagen | Strg+Alt+N
Name aus Bild abrufen… | Strg+Alt+I
Markierungstyp erkennen | Strg+Alt+D

Fenster "Dokumentstruktur"

Option | Tastaturbefehle
Anzeigen des Bilds eines erkannten Felds | Eingabetaste
Umbenennen eines erkannten Felds | F2
Bei markiertem Tabellenfeld: |
Hinzufügen einer Spalte mit Textfeldern | Alt+Umschalt+T
Hinzufügen einer Spalte mit Auswahlfeldern | Alt+Umschalt+C
Hinzufügen einer Spalte mit Barcodes | Alt+Umschalt+B
Hinzufügen einer Spalte mit Bildern | Alt+Umschalt+P
Bei markierter Gruppe von Auswahlfeldern: |
Hinzufügen eines Auswahlfelds zur Gruppe | Alt+Umschalt+C


Tastaturbefehle im Fenster für die Gruppenüberprüfung

Menü | Option | Tastaturbefehle
überprüfung | Alle bestätigen | Eingabetaste
 | Alle ablehnen | Strg+Eingabetaste
 | Status ändern | Leerzeichen
 | Nächste Seite | Bild ab
 | Vorherige Seite | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig | Strg+Z
 | Wiederherstellen | Strg+Y
 | Alles auswählen | Strg+A
Ansicht | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Bildanzeige > Vergrößern | Strg+Num+
 | Feldbild > Bildanzeige > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfe anzeigen | F1
Lokales Symbolmenü | Zeichenbild anzeigen | F2
 | Bestätigen | Strg+E
 | Ablehnen | Strg+R
 | Zurücksetzen | Esc


Tastaturbefehle im Fenster für die Feldüberprüfung

Menü | Option | Tastaturbefehle
überprüfung | Feld bestätigen | Eingabetaste
 | Aufschieben | Strg+Eingabetaste
 | Nächstes nicht eindeutiges Zeichen | F4
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F4
 | Nächstes Feld | Bild ab
 | Vorheriges Feld | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Zeilenumbruch einfügen | Umschalttaste+Eingabetaste
 | Zeichen verbinden | Strg+M
Ansicht | Felddaten > Erkannter Text | Alt+F1
 | Felddaten > Zeichenausschnitt | Alt+F2
 | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Bildanzeige > Vergrößern | Strg+Num+
 | Feldbild > Bildanzeige > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfe anzeigen | F1


Verwenden von Skripten in FlexiCapture 8.0

In diesem Abschnitt wird beschrieben, wie Sie in FlexiCapture 8.0 mithilfe von Skripten benutzerdefinierte Regeln schreiben, Exporte ausführen oder Exportsteuerungen erstellen.

Grundsätzlich werden zwei Skriptsprachen unterstützt: JScript® und VBScript.

Besonderheiten bei der Verwendung

In VBScript muss das Schlüsselwort "Me" verwendet werden, um auf Methoden und Felder im aktuellen Objekt zu verweisen (die Entsprechung in C++ und Java lautet "this"). Als aktuelle Objekte gelten bei Regeln verifizierbare Dokumenteinheiten (Einheiten mit einer Regel) und beim Export exportierbare Dokumente.

Me.CheckSucceeded = False

In JScript können Sie in derselben Situation das Schlüsselwort "this" auslassen:

this.CheckSucceeded = false; CheckSucceeded = false;

Fehler zu nicht gefundenen Methoden oder Eigenschaften werden zur Laufzeit des Skripts ausgegeben:

ChecckSucceeded = false; // Laufzeitfehler

Syntaxfehler werden beim Speichern des Skripts ausgegeben:

CheckSucceeded +++ false; // Syntaxfehler

Benutzerdefinierte Funktionen

Mithilfe des Skripteditors können Benutzer eigene Funktionen und Prozeduren schreiben und diese dann aus den Codes von Regeln oder Codes von Exporten aufrufen.

Benutzerdefinierte Funktionen können in einem der globalen Module erstellt werden, entweder im Exportmodul oder im Regelmodul. Sie können das gewünschte Modul im Skripteditor auswählen.

Alle Funktionen innerhalb eines Moduls müssen in derselben Sprache geschrieben sein. Der Kerncode einer Regel oder eines Exports kann in einer anderen Sprache geschrieben sein als in derjenigen, die im entsprechenden globalen Modul verwendet wird.

Sie können zum Beispiel von dem Code einer Regel aus, die in VBScript geschrieben ist, eine im globalen Modul enthaltene Funktion aufrufen, die in JScript geschrieben ist.

Funktionen können nur von „ihren eigenen“ Modulen aufgerufen werden. Das bedeutet, dass Sie aus dem Code für Regeln nur Funktionen aufrufen können, die im globalen Regelmodul enthalten sind, und aus dem Code für Exporte nur Funktionen, die im globalen Modul für Exporte enthalten sind. Andernfalls tritt während der Ausführung ein Fehler auf.

Funktionen werden folgendermaßen aufgerufen:

[VBScript]

result = Rules.SomeFunction( param1, param2 ... )

Export.SomeFunction param1, param2 ...

[JScript]

result = Rules.SomeFunction( param1, param2 ... );

Export.SomeFunction( param1, param2 ... );

Zeitüberschreitung bei Skriptausführung

Der Standardwert für Zeitüberschreitungen beträgt 10 Sekunden für Regeln und 1 Minute für den Export.

Zum ändern des Standardwerts für Zeitüberschreitungen passen Sie die entsprechenden Werte in der Registrierung an.

Für Regeln:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\DefaultScriptTimeout

Für den Export:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\ExportScriptTimeout

Die Werte für Zeitüberschreitungen werden in der Registrierung in Millisekunden angegeben. Dauert die Ausführung eines Skripts länger als der angegebene Wert für die Zeitüberschreitung, wird das Skript beendet. Bei Regeln wird die Fehlermeldung "Zeitüberschreitung bei Skriptausführung." zurückgegeben. Beim Exportieren wird eine ähnliche Meldung im Fenster Stapel in der Spalte Hinweise zur Verarbeitung angezeigt.

Erstellen von Regeln mithilfe von Skripten
Beschreibung von Exportprozeduren mithilfe von Skripten
Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture 8.0 Professional-Skripte


Erstellen von Regeln mithilfe von Skripten

Mit auf Skripten basierenden Regeln (ScriptRule) können Benutzer komplexe benutzerdefinierte Algorithmen für die Dokumentüberprüfung und Normalisierung erstellen. Dabei kommen die Standardskriptsprachen JScript® und VBScript zum Einsatz.

Hinweis: Einige der im ersten Release von ABBYY FlexiCapture erstellten Skripts funktionieren im zweiten Release möglicherweise nicht. Das liegt daran, dass die im zweiten Release typisierten Feldwerte im ersten Release noch als Textwerte verwendet wurden. Sie können dieses Problem beheben, indem Sie a) die Eigenschaft "Value" für Skripte, die im Zusammenhang mit Feldtext verwendet werden, auf "Text" setzen oder b) die Eigenschaft "Value" so ändern, dass sie der aktuellen Beschreibung entspricht. Siehe auch Eigenschaften des Objekts "Feld".

Objektmodell

Regeln können als Methode überprüfter Dokumenteinheiten angesehen werden, d. h., dass "this" oder "Me" auf das Objekt [überprüfte Dokumenteinheit] verweisen, für das diese Regel derzeit gilt.

Mit einer Regel kann eine Dokumentüberprüfung basierend auf den Werten eines oder mehrerer Felder durchgeführt werden. Bei der Ausgabe eines Fehlers muss ein Fehlerkennzeichen gesetzt werden, und ggf. müssen die Fehlerbeschreibung, das Fokusfeld und Vorschläge für Ersetzungen angegeben werden. Außerdem können Sie mit einer Regel Felder als eindeutig erkannt kennzeichnen.

Sie können Dokumente mithilfe einer Regel normalisieren, indem Sie die Feldwerte in eine normale Darstellung ändern oder Informationen hinzufügen (beispielsweise das Datum der letzten Verarbeitung).

überprüfte Dokumenteinheit

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
CheckSucceeded | Boolescher Wert | Lesen/Schreiben | Fehlerkennzeichen. True: Es ist kein Regelfehler aufgetreten. False: Es ist ein Regelfehler aufgetreten.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Fehlermeldung
FocusedField | [[Feld] | Lesen/Schreiben | Fokusfeld
Field("AliasName") [Feld] Schreibgeschützt Feld mit dem Alias "AliasName".

Ein Alias ist ein spezieller Name für ein Feld, der verwendet wird, wenn as Feld aus dem Code einer Regel aus aufgerufen wird. Dadurch wirkt sich die Umbenennung eines Felds nicht auf die Verwendung des Felds im Regelcode aus.

Aliase ermöglichen außerdem die Verwendung von Feldern mit identischen Namen in derselben Regel (z. B. Felder mit identischen Namen aus verschiedenen Bereichen).

Ein Alias kann mit dem Namen des Felds übereinstimmen, kann sich aber auch davon unterscheiden.

Wenn Sie ein Feld zu einer Regel hinzufügen, wird für dieses Feld automatisch ein Alias erzeugt. Diese vom Programm erzeugten Aliase können Sie jedoch immer ändern.
Fields | [Auflistung von Feldern] | Schreibgeschützt | Eine Auflistung von Feldern der Regel
Document | [Dokument] | Schreibgeschützt | Ein Dokument mit einer überprüften Einheit

Wenn die überprüfte Dokumenteinheit ein Feld ist, unterstützt sie alle Eigenschaften und Methoden des Objekts [Feld]. Ist die überprüfte Einheit kein Feld, können Sie nicht auf die entsprechenden Eigenschaften und Methoden verweisen, da andernfalls ein Fehler auftritt.

Feld

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Value Variable Lesen/Schreiben Typabhängiger Wert des Felds.

Bei Zahlfeldern ist eine Fließkommazahl enthalten.

Bei Feldern des Typs "Datum/Uhrzeit" ist der Wert des Datums enthalten (VT_DATE).

Bei Feldern des Typs "Währung" ist ein Summenwert enthalten (VT_CY).

Bei Auswahlfeldern ist ein boolescher Wert enthalten. Wenn Sie einem Auswahlfeld Werte zuweisen, können Sie sowohl die booleschen Werte true/false als auch die Textwerte "True"/"False" (unter Berücksichtigung der Groß-/Kleinschreibung) verwenden.
Der Wert einer Gruppe von Auswahlfeldern ist eine Liste mit den Namen der ausgewählten Auswahlfelder getrennt durch Semikola (;). Wenn keine Auswahlfelder ausgewählt wurden, ist die Zeichenfolge leer. Um den Wert einer Gruppe von Auswahlfeldern zu ändern, weisen Sie den zu markierenden Auswahlfeldern "true" und den nicht zu markierenden Feldern "false" zu. Außerdem müssen alle diese Auswahlfelder in der Regel enthalten sein.
Bei Gruppen, Tabellen und Bildern eine leere Zeichenfolge.
Sie können Gruppen, Gruppen von Auswahlfeldern und Tabellen keine Werte zuordnen. Wenn Sie versuchen, einem dieser Feldtypen einen Wert zuzuordnen, wird ein Fehler ausgelöst.

Text Zeichenfolge Schreibgeschützt Der Textwert eines Felds. Ist bei allen Typen außer Auswahlfeldern mit "Value" identisch.
Bei Auswahlfeldern wird der Wert dieser Eigenschaft anhand der Feldeigenschaften bestimmt, die auf der Registerkarte Datentyp ausgewählt wurden.
Wichtig: Der Wert der Eigenschaft "Text" wird bei Anwendung der Regel nicht geändert, d. h., dass Sie nicht durch ändern der Eigenschaft "Value" im Code gleichzeitig die Eigenschaft "Text" ändern können.
Im folgenden Beispiel sind die Werte von "oldText" und "newText" identisch:

Dim oldText, newText
oldText = me.Field("FieldName").Text
me.Field("FieldName").Value = newValue
newText = me.Field("FieldName").Text

Name | Zeichenfolge | Schreibgeschützt | Feldname
IsVerified Boolescher Wert Lesen/Schreiben Ein Kennzeichen gibt an, ob das Feld überprüft wurde. Ein Feld, das als geprüft gekennzeichnet ist, wird sowohl bei der Überprüfung als auch beim Zählen der Zeichen ignoriert, für das eine Überprüfung erforderlich ist.

Die Eigenschaft ist auf "True" gesetzt, wenn der Benutzer das Feld während der Überprüfung bestätigt hat oder wenn eine Regel die Eigenschaft auf "True" gesetzt hat.

Andernfalls ist der Wert der Eigenschaft "False".
IsCertain Boolescher Wert Lesen/Schreiben Kennzeichen zur Eindeutigkeit des Felds. Ein als eindeutig erkanntes Feld wird bei der überprüfung und der Berechnung der Zeichen, für die eine überprüfung erforderlich ist, ignoriert.

Diese Eigenschaft ist überholt und wurde nur aus Gründen der Abwärtskompatibilität erhalten. Bitte verwenden Sie stattdessen die Eigenschaft IsVerified.

IsMatched | Boolescher Wert | Schreibgeschützt | Ein Kennzeichen, das angibt, ob ein Feld übereinstimmt.
Items | [Auflistung von Feldern] | Schreibgeschützt | Bei einem mehrfach auftretenden Feld eine Auflistung aller seiner Instanzen. Wenn das Feld nicht mehrfach vorkommt: 0.

Methoden:

Name | Parameter | Beschreibung
Suggest (Text) | Text: Zeichenfolge | Fügt einen Hinweis mit einem Vorschlag für den Feldwert hinzu. Wenn Sie mehrere Varianten angeben möchten, rufen Sie die Methode nacheinander auf, bis die gewünschte Anzahl von Vorschlägen erreicht ist. Der Wert des von Ihnen hinzugefügten Hinweises muss dem Typ des Felds entsprechen (d. h., bei Zahlenfeldern muss es sich um eine Zahl handeln, bei Feldern des Typs "Datum/Uhrzeit" um ein Datum usw.).

Auflistung von Feldern

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Felder in einer Auflistung
Item(Index) | [Feld] | Schreibgeschützt | Indexfeld. Für den Index sind Werte zwischen 0 und 1 möglich.

Dokument

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Pages | [Sammlung von Seiten] | Schreibgeschützt | Sammlung von Dokumentseiten.

Methoden:

Name | Parameter | Beschreibung
Property (Name) | Name: Eigenschaftenname | Gibt den Wert der abgefragten Eigenschaft zurück. Der Rückgabewert ist vom Typ Variable.

Dokumenteigenschaften, die mit der Methode "Property" festgelegt werden können (die von dieser Eigenschaft abgerufenen Dokumenteigenschaften sind schreibgeschützt):

Wert | Typ | Beschreibung
"TemplateName" | Zeichenfolge | Vorlagenname
"TotalSymbolsCount" | Ganzzahl | Anzahl von Zeichen
"UncertainSymbolsCount" | Ganzzahl | Anzahl von nicht eindeutig erkannten Zeichen
"RecognizedSymbolsCount" | Ganzzahl | Anzahl von erkannten Zeichen
"Comment" | Zeichenfolge | Kommentar
"Created" | Datum | Erstellungsdatum
"CreatedBy" | Zeichenfolge | Erstellt von
"Recognized" | Datum | Erkennungsdatum
"RecognizedBy" | Zeichenfolge | Erkannt von
"Modified" | Datum | Datum der letzten änderung
"ModifiedBy" | Zeichenfolge | Geändert von
"ProcessingErrors" | Zeichenfolge | Fehler
"ProcessingWarnings" | Zeichenfolge | Warnungen

Sammlung von Seiten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Seiten in der Sammlung.
Item(index) | [Seite] | Schreibgeschützt | Die Art der Bildquelle. Mögliche Werte: "Datei" oder "Scanner".

Page

Enthält Informationen über die Seiten des zu prüfenden Dokuments.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
ImageSourceType | Zeichenfolge | Schreibgeschützt | Die Art der Bildquelle. Mögliche Werte: "Datei" oder "Scanner".
ImageSource | Zeichenfolge | Schreibgeschützt | Bildquelle. Im Falle einer Dateie ist dies der Name der Datei mit dem vollständigen Pfad. Im Falle eines Scanners ist dies der Name des Scanners.
ImageSourcePageNumber | Ganzzahl | Schreibgeschützt | Die Anzahl der Seiten innerhalb der Bildquelle. Seitennummerierung beginnt bei 0. Nur für Dateien.

Beispielskripte zum Erstellen benutzerdefinierter Regeln


Beispielskripte zum Erstellen benutzerdefinierter Regeln

Automatisierungsregel

In diesem Beispiel wird die überprüfung von Tabellendaten veranschaulicht. Die Regel überprüft, ob die Tabellendaten dem Wert im Ergebnisfeld entsprechen. Die Tabelle enthält Spalten mit Preisen und Mengen bestimmter Waren. Die Regel wurde auf der Ebene eines Bereichs erstellt, der die Tabelle und das Ergebnisfeld enthält.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Code einer ActiveX-Komponente

Der angegebene Code entstammt einer CheckDoc-Klasse aus dem Projekt AutomationRule, das in den oben genannten Skripten verwendet wird.

Explizite Option

' überprüft, ob die Tabellendaten mit dem Ergebnis übereinstimmen

' column1 - Preisspalte

' column2 - Mengenspalte

' resultField - Ergebnisfeld (<Total> oder Entsprechung)

' docObj - der überprüfte Dokumentknoten

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' Summieren der Tabellendaten

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' Genauigkeit des Vergleichs: das Ergebnis wird auf 2 Nachkommastellen gerundet

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Table data does not match the resulting value"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Durchsuchen der Liste von Varianten

Mit dem unten angegebenen Regelcode wird geprüft, ob der Feldwert einem der Werte in der Liste entspricht. Trifft dies nicht zu, wird ein Fehlerkennzeichen angezeigt, und dem Feld wird eine Liste von vorgeschlagenen Werten zugeordnet. Das Feld wird in Abhängigkeit vom Prüfergebnis als eindeutig oder nicht eindeutig erkannt gekennzeichnet.

[VBScript]

' Feldwert speichern

Dim fieldValue

fieldValue = me.Field("Field6").Value

' Liste von Werten für die überprüfung erstellen

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

' überprüfen, ob der Feldwert Werten in der Liste entspricht

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

' Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

me.Field("Field6").IsCertain = success

' Liste der Vorschläge für das Feld erstellen – Vorschläge können alle

' passenden Werte sein

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

' Ein Fehlerkennzeichen setzen

me.CheckSucceeded = success

[JScript]

// Feldwert speichern

var fieldValue = Field("Field6").Value;

// Liste von Werten für die überprüfung erstellen

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// Feldwert mit Werten in der Liste vergleichen

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

Field("Field6").IsCertain = success;

// Liste der Vorschläge für das Feld erstellen – Vorschläge können alle

// passenden Werte sein

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// Fehlerkennzeichen setzen

CheckSucceeded = success;

überprüfung von Feldzuordnungen

Mit dem unten angegebenen Regelcode wird überprüft, ob das überprüfte Feld zugeordnet werden konnte.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Field InvoiceNumber is not matched"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Field InvoiceNumber is not matched";

}

überprüfung von Auswahlfeldern

Mit dem unten stehenden Regelcode wird überprüft, ob das Auswahlfeld markiert wurde.

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Page status is not checked"

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Page status is not checked";

}

überprüfung von Gruppen von Auswahlfeldern

Mit dem unten stehenden Regelcode werden alle Auswahlfelder in der Gruppe durchlaufen. Wenn kein Auswahlfeld markiert wurde, wird das erste Feld ausgewählt. Die Regel wurde für die Ebene mit den Gruppen von Auswahlfeldern geschrieben. Alle Auswahlfelder in der Gruppe wurden der Liste von Feldern hinzugefügt, die in die Regel einbezogen werden sollen. Für das Standardauswahlfeld (das erste Feld) wurde der Schreibschutz deaktiviert. Wenn die Gruppe keine Auswahlfelder enthält, wird das Kennzeichen für einen Regelfehler aktiviert.

Mit diesem Beispielcode werden sämtliche Felder der Regel durchlaufen. Da die Feldnamen nicht im Code angegeben sind, kann der Code für beliebige Gruppen von Auswahlfeldern verwendet werden.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "No checkmarks in group"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "No checkmarks in group";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}


Beschreibung von Exportprozeduren mithilfe von Skripten

Objektmodell

Dieses Modell wird sowohl in Exportskripten als auch in Exportsteuerungsskripten verwendet.

Bei der Exportsteuerung handelt sich um ein spezielles Skript, das nach dem Abschluss des Exports ausgeführt wird (vorausgesetzt, dass die Option Skript nach Export ausführen auf der Registerkarte Export des Dialogfelds für die Projekteigenschaften aktiviert und der Inhalt des Skripts nicht leer ist).

Der Export ist als Methode eines exportierbaren Dokuments anzusehen, d. h., dass "this" oder "Me" auf ein Objekt vom Typ [Exportierbares Dokument] verweist, das derzeit exportiert wird.

Bei einer Exportsteuerung zeigen die Zeiger this oder Me auf ein Objekt des Typs [Exportergebnisse].

Feldwerte können während des Exports nicht geändert werden.

Exportierbares Dokument

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
IsAssembled | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument zusammengestellt wurde.
IsVerified | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument überprüft wurde.
IsExported | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument exportiert wurde.
TemplateName | Zeichenfolge | Schreibgeschützt | Name der Dokumentvorlage
ProcessingErrors | Zeichenfolge | Schreibgeschützt | Meldung über Verarbeitungsfehler
ProcessingWarnings | Zeichenfolge | Schreibgeschützt | Hinweise und/oder Warnungen, die während der Verarbeitung angezeigt wurden
TotalSymbolsCount | Ganzzahl | Schreibgeschützt | Summe der Zeichen (enthält neben den erkannten Zeichen auch vom Benutzer und durch Regeln hinzugefügte Zeichen)
RecognizedSymbolsCount | Ganzzahl | Schreibgeschützt | Anzahl erkannter Zeichen
UncertainSymbolsCount | Ganzzahl | Schreibgeschützt | Anzahl nicht eindeutig erkannter Zeichen
Id | Zeichenfolge | Schreibgeschützt | Dokumentkennung
BatchName | Zeichenfolge | Schreibgeschützt | Stapelname
Field(FieldName) | [Dokumenteinheit] | Schreibgeschützt | Einheit mit dem Namen "FieldName". Gibt ein Feld oder einen Bereich zurück. "FieldName" ist der Name einer Einheit zusammen mit dem vollständigen Pfad, beginnend beim Bereich. Beispiel: "Bereich 1\Gruppe\Feld 1" Wichtig: Wenn es sich bei einem Bestandteil des Pfads zu dem Feld um eine Mehrfachkomponente handelt, müssen Sie den Index dieser Komponente angeben. Bei einer Mehrfachgruppe müsste der Pfad beispielsweise wie folgt aussehen: "Bereich 1\Gruppe[Index]\Feld 1" Beim Index wird von einem Wert zwischen 0 und Count-1 ausgegangen, wobei "Count" für die Anzahl der Instanzen der Mehrfachkomponente steht.
Children | [Auflistung von Dokumentbereichen] | Schreibgeschützt | Auflistung von Dokumentbereichen
Pages | [Auflistung von Seiten] | Schreibgeschützt | Auflistung von Dokumentseiten
IndexedItemValue | Variant | Schreibgeschützt | Der Wert des Indexfeldes mit dem angegebenen Namen: IndexedItemValue(fieldName).
Action | [Ergebnis der Operation] | Schreibgeschützt | Ein spezielles Objekt, das Daten zu den Ergebnissen der Exportoperation enthält. Das Programm schreibt die Daten während des Exports in dieses Objekt. Diese Daten können im Bedarfsfall von der Steuerung verwendet werden, die nach dem Abschluss des Exports ausgeführt wird.

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert die Bilder aller Dokumentseiten in eine Datei.

Dokumenteinheit

Eine Dokumenteinheit ist ein Bereich oder ein Feld.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Value Variable Schreibgeschützt Typabhängiger Wert der Einheit.

Bei Zahlfeldern wird eine Fließkommazahl zurückgegeben.

Bei Feldern des Typs "Datum/Uhrzeit" wird der Wert des Datums zurückgegeben (VT_DATE).

Bei Feldern des Typs "Währung" wird ein Summenwert zurückgegeben (VT_CY).

Bei Auswahlfeldern wird ein boolescher Wert zurückgegeben.

Wert der Einheit. Dies ist immer ein Textwert.
Gibt bei Auswahlfeldern die Werte "Yes" (Ja) oder "No" (Nein) zurück. Bei Gruppen von Auswahlfeldern gibt diese Eigenschaft eine Liste der markierten Auswahlfelder oder, wenn keine Auswahlfelder markiert wurden, eine leere Zeichenfolge zurück. Gibt bei einem Bild eine leere Zeichenfolge zurück.
Gibt NULL zurück, wenn eine Einheit keinen Wert enthält. Stellen Sie vor dem Lesen eines Einheitenwerts immer sicher, dass dieser nicht NULL ist (weitere Informationen finden Sie in den Skriptbeispielen). Das Lesen eines Werts gleich NULL löst einen Fehler aus.
In Bereichen, Tabellen und Gruppenfeldern ist der Wert beispielsweise NULL.

Der Wert kann auch NULL sein, wenn der Feldinhalt (erkannter oder vom Benutzer eingegebener Text) nicht mit dem Feldtyp übereinstimmt.

Text Zeichenfolge Schreibgeschützt

Der Textwert einer Einheit.

Bei Auswahlfeldern werden die Werte Yes/No (Ja/Nein) zurückgegeben.

Bei Gruppen von Auswahlfeldern wird eine Liste der markierten Auswahlfelder oder, wenn keine Auswahlfelder markiert wurden, eine leere Zeichenfolge zurückgegeben.

Bei leeren Einheiten ohne Wert (z. B. Bildern, Gruppen, Bereichen) wird eine leere Zeichenfolge zurückgegeben.
Name | Zeichenfolge | Schreibgeschützt | Name der Einheit
IsExportable | Boolescher Wert | Schreibgeschützt | Zeigt an, ob die Einheit exportiert werden soll
IsIndexed | Boolescher Wert | Schreibgeschützt | Gibt an, ob es sich um ein Indexfeld handelt.
SuspiciousSymbols Zeichenfolge Schreibgeschützt

Eine Zeichenfolge aus den Zeichen 0 und 1, wobei die 1 für nicht eindeutige Zeichen steht.

Bei Auswahlfeldern wird eine Zeichenfolge mit nur einem Symbol zurückgegeben.

Für leere Einheiten ohne Wert wird eine leere Zeichenfolge zurückgegeben.
Children [Auflistung von Dokumenteinheiten] Schreibgeschützt Auflistung der untergeordneten Einheiten. Wenn keine untergeordneten Einheiten vorhanden sind, ist der Wert 0.
Eine Gruppe, eine Gruppe von Auswahlfeldern und eine Tabellenzeile verfügen z. B. über untergeordnete Einheiten.
Items | [Auflistung von Dokumenteinheiten] | Schreibgeschützt | Bei einer mehrfach auftretenden Einheit eine Auflistung aller seiner Instanzen. Wenn die Einheit nicht mehrfach vorkommt: 0.
Regions | [Auflistung von Bereichen] | Schreibgeschützt | Eine Liste der Feldbereiche.

Bild

Hier ist ein Bild gemeint, das in eine Datei auf der Festplatte gespeichert werden kann.

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert das Bild eines Felds in eine Datei.

Auflistung von Dokumenteinheiten

Eine Auflistung von Dokumenteinheiten ist eine Auflistung von Feldern oder Bereichen.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Einheiten in einer Auflistung
Item(Index) | [Einheit] | Schreibgeschützt | Instanz einer Einheit. Der Index kann Werte zwischen 0 und Count – 1 annehmen.

Auflistung von Seiten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Seiten in einer Auflistung
Item(Index) | [Seite] | Schreibgeschützt | Seite mit dem Index. Der Index kann Werte zwischen 0 und Count – 1 annehmen.

Seite

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
TemplateName | Zeichenfolge | Schreibgeschützt | Name des Bereichs
ImageSourceType | Zeichenfolge | Schreibgeschützt | Typ der Bildquelle. Kann die Werte Datei oder Scanner annehmen.
ImageSource | Zeichenfolge | Schreibgeschützt | Bildquelle Im Fall einer Datei ist dies der Name der Datei mit dem vollständigen Dateipfad. Im Fall eines Scanners ist dies der Name des Scanners.
ImageSourcePageNumber | Ganzzahl | Schreibgeschützt | Die Anzahl der Seiten innerhalb der Bildquelle. Seitennummerierung beginnt bei 0. Nur für Dateien.

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: der Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert das Seitenbild.

Auflistung von Bereichen

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Bereiche in der Auflistung
Item(Index) | [Bereich] | Schreibgeschützt | Der Bereich mit dem Indexwert index. Der Index kann Werte zwischen 0 und Count – 1 annehmen.

Bereich

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
PageIndex | Ganzzahl | Schreibgeschützt | Der Index der Seite, auf der sich der angegebene Bereich befindet.
Rects | [Auflistung von Rechtecken] | Schreibgeschützt | Die Auflistung der Rechtecke, aus der der angegebene Bereich zusammengesetzt ist. Im Fall eines rechteckigen Bereichs enthält die Auflistung der Rechtecke nur ein Rechteck.
SurroundingRect | [Rechteck] | Schreibgeschützt | Das Rechteck, das den Bereich umschließt.
Picture | [Bild] | Schreibgeschützt | Das Bild für den angegebenen Bereich.

Auflistung von Rechtecken

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Rechtecke in der Auflistung
Item(Index) | [Rechteck] | Schreibgeschützt | Das Rechteck mit dem Indexwert Index. Index kann Werte zwischen 0 und Count – 1 annehmen.

Rechteck

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Left | Ganzzahl | Schreibgeschützt | Die Koordinate für die linke Kante des Rechtecks auf der Seite.
Top | Ganzzahl | Schreibgeschützt | Die Koordinate für die obere Kante des Rechtecks auf der Seite.
Right | Ganzzahl | Schreibgeschützt | Die Koordinate für die rechte Kante des Rechtecks auf der Seite.
Bottom | Ganzzahl | Schreibgeschützt | Die Koordinate für die untere Kante des Rechtecks auf der Seite.

ExportTools

Ein globales Objekt, das zum Abrufen eines Objekts vom Typ [Bildspeicheroptionen] verwendet wird.

Methoden:

Name | Parameter | Beschreibung
NewImageSavingOptions |  | Erstellt ein Objekt vom Typ [Bildspeicheroptionen]

Bildspeicheroptionen

Optionen für das Speichern von Seitenbildern.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Format | Zeichenfolge | Lesen/Schreiben | Bildformat. Diese Eigenschaft kann folgende Werte annehmen: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf", "pdf-s", "pdf-a", "pdf-a-s", "pdf-s-a". Die Groß- und Kleinschreibung wird nicht berücksichtigt.
ColorType | Zeichenfolge | Lesen/Schreiben | Typ des verwendeten Farbschemas. Diese Eigenschaft kann folgende Werte annehmen: "FullColor", "GrayScale", "BlackAndWhite". Die Groß- und Kleinschreibung wird nicht berücksichtigt.
Resolution | Ganzzahl | Lesen/Schreiben | Die Auflösung des Bilds in dpi
ShouldOverwrite | Boolescher Wert | Lesen/Schreiben | Dieses Kennzeichen gibt an, ob beim Speichern eine vorhandene Datei überschrieben werden soll. Wenn das Kennzeichen auf false gesetzt ist, dann führt der Aufruf der Methode "SaveAs" zu einem Fehler, wenn bereits eine Datei mit demselben Namen vorhanden ist.

Ergebnisse der Operation

Enthält Daten zu den Ergebnissen der Exportoperation.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Succeeded | Boolescher Wert | Lesen/Schreiben | Enthält true, wenn der Export erfolgreich war, andernfalls false.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Eine Fehlermeldung zu dem Fehler, der während des Exports aufgetreten ist.
Result | Zeichenfolge | Lesen/Schreiben | Eine formale Beschreibung des Ergebnisses. Bei einem Export in eine Datei ist hier der Name der Datei mit dem vollständigen Dateipfad enthalten. Bei einem Export in eine Datenbank ist hier der Name der Haupttabelle des Exports enthalten. Bei einem Export nach SharePoint ist hier die URL des exportierten Dokuments enthalten.

Exportergebnisse

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Documents | [Auflistung von exportierten Dokumenten] | Schreibgeschützt | Die Auflistung der während einer Exportsitzung exportierten Dokumente.
Typ | Ganzzahl | Schreibgeschützt | Exporttyp. Kann folgende Werte annehmen: ET_File: Export in ein Dateiformat ET_Database: Export in eine Datenbank ET_Script: Benutzerdefinierter Export auf Grundlage eines Skripts ET_SharePoint: Export nach SharePoint

Auflistung von exportierten Dokumenten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Dokumente in der Auflistung
Item(Index) | [Exportiertes Dokument] | Schreibgeschützt | Das Dokument mit dem Indexwert Index. Index kann Werte zwischen 0 und Count – 1 annehmen.

Beispielskripte für die Exportbeschreibung


Beispielskripte für die Exportbeschreibung

Abrufen von Feldwerten beim Export
Dieser Beispielcode veranschaulicht, wie Sie den Wert eines Felds beim Export abrufen. Sie können mit diesem Wert die Dateien benennen, in die die Bilder oder Daten exportiert werden. Ist kein entsprechendes Feld im Dokument enthalten, tritt ein Fehler auf.

Die Struktur des in diesem Beispiel exportierten Dokuments sieht wie folgt aus:

Section 1

Field1

...

Group1

Field2

...

...

FieldN

Section 2

Field1

...

FieldK

[VBScript]

Dim field1Value, field2Value

' Ruft den Wert von Field1 in Section 1 ab

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Ruft den Wert von Field2 in Group1 in Section 1 ab

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Ruft den Wert von Field1 in Section 1 ab, wenn der Bereich über mehrere Instanzen verfügt

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Ruft den Wert von Field1 in Section 1 ab

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Ruft den Wert von Field2 in Group1 in Section 1 ab

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Ruft den Wert von Field1 in Section 1 ab, wenn der Bereich über mehrere Instanzen verfügt

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Exportieren von Seitenbildern

Anhand des Codes in diesem Beispiel wird das Exportieren von Bildern aller Dokumentseiten mit dem erforderlichen Dateiformat, dem Farbschema und der Auflösung veranschaulicht. Die Bilder werden seitenweise gespeichert, sodass jede Seite in einer eigenen Datei gespeichert wird.

Die Dateien in diesem Beispiel werden mit "page1.tif", "page2.tif" usw. bezeichnet, Sie können das Benennungsschema für die Dateien aber ggf. ändern, indem Sie beispielsweise die Dateinamen auf Grundlage des Werts eines Felds erstellen.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Exportieren einer Tabelle

In diesem Beispiel wird das Exportieren einer Tabelle in eine TXT-Datei veranschaulicht.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject")

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Exportieren eines Dokuments mit beliebiger Verschachtelungstiefe

Dieses Beispiel zeigt, wie Felder eines Dokuments mit beliebiger Verschachtelungstiefe mithilfe benutzerdefinierter Funktionen aus dem globalen Exportmodul exportiert werden. Wenn Sie Dokumentfelder mit variabler Verschachtelung exportieren möchten, sollten Sie eine externe COM-Komponente verwenden. (Weitere Informationen finden Sie im nächsten Beispiel.)

Kerncode für den Export

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Der Code der Funktionen des globalen Exportmoduls

[VBScript]

' Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject")

    ' Den Exportordner erstellen

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during create export folder: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' Bilder exportieren

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export images: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' Die Textdatei erstellen

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' Informationen über das Dokument exportieren

    ExportDocInfo docObj, txtFile

    ' Felder exportieren

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export data: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Bildexportfunktion

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' Exportoptionen konfigurieren

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' Seitenweiser Export

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pages

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Prozedur zum Exportieren der Informationen über das Dokument

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next

End Sub

' überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die überprüfung auf NULL) eine Ausnahme auslösen

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Feldexportprozedur

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' Feldnamen speichern

    txtFile.Write (indent & field.Name)

    ' Feldwert, sofern verfügbar, speichern

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("    " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' untergeordnete Felder exportieren

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' Feldinstanzen exportieren

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderNameme

    ' ' Hauptordner

    Const exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' der Ordner für die angegebene Dokumentvorlage

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End If

    ' der Ordner für das exportierte Dokument

    Dim i

    i = 1

    folderName = fso.BuildPath(docFolder, i)

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath(docFolder, i)

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// Die Funktion führt den Export durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

// und Informationen über das Dokument

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // Exportordner erstellen

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during create export folder: " + e.description;

        return;

    }

    // Bilder exportieren

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export images: " + e.description;

        return;

    }

    // Die Textdatei erstellen

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile(fileName, true);

    // Informationen über das Dokument exportieren

    ExportDocInfo( docObj, txtFile);

    // Felder exportieren

    txtFile.WriteLine( "Fields:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export data: " + e.description;

        txtFile.Close();

        return;

    }

    txtFile.Close();

    txtFile= 0;

    fso= 0;

}

// Bildexportfunktion

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // Exportoptionen konfigurieren

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // Seitenweiser Export

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    } } }

}

// Prozedur zum Exportieren der Informationen über das Dokument

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// überprüft, ob der Wert des Felds NULL ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die überprüfung auf NULL) eine Ausnahme auslösen

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Feldexportprozedur

function ExportField(field, txtFile, indent)

{

    // Feldnamen speichern

    txtFile.Write(indent + field.Name);

    // Feldwert, sofern verfügbar, speichern

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // untergeordnete Felder exportieren

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // / Feldinstanzen exportieren

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // Hauptordner

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // der Ordner für die angegebene Dokumentvorlage

    docFolder = fso.BuildPath(exportFolder, templateName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder);

    }

    // der Ordner für das exportierte Dokument

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder(folderName);

    return n folderName;

}

Verwenden einer externen COM-Komponente

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Code einer ActiveX-Komponente in VisualBasic

Im Folgenden sehen Sie Code einer Exporter-Klasse aus dem Projekt "AutomationExport", das bereits in den oben beschriebenen Skripten verwendet wurde.

Option Explicit

Dim mFso As New Scripting.FileSystemObject

' Die Prozedur führt den Dokumentexport durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

Public Sub Export(ByRef docObj As Object, ByRef exportTools As Object)

On Error GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' Exportordner erstellen

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Cannot create export folder"

        ExitSub

    End If

    ' Bilder exportieren

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' Die Textdatei erstellen

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' Informationen über Probleme beim Bildexport speichern

    If imageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' Informationen über das Dokument exportieren

    exportDocInfo docObj, txtFile

    ' Felder exportieren

    txtFile.WriteLine "Fields:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Error during export data"

    End If

    txtFile.Close

    ' Wenn Fehler während des Exports auftreten,

    ' das Kennzeichen für erfolgreichen Export auf False zurücksetzen

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

Exit Sub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

End Sub

' Bildexportfunktion. Wenn während des Bildexports ein Fehler auftritt,

' dann wird eine Meldung über den Fehler zurückgegeben, andernfalls eine leere Zeichenfolge

Private Function exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

On Error GoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' Exportoptionen konfigurieren

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' Seitenweiser Export

    Set pages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

Exit Function

err_h:

    exportImages = Err.Description

End Function

' Prozedur zum Exportieren der Informationen über das Dokument

Private Sub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

On Error GoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

Exit Sub

err_h:

    txtFile.WriteLine Err.Description

End Sub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

Private Function exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim curField As Object

    exportFields = True

    For Each curField In fields

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

        End If

    Next curField

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

End Function

' überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die überprüfung auf NULL) eine Ausnahme auslösen

Function IsNullFieldValue(ByRef field As Object) As Boolean

On Error GoTo err_h

    IsNullFieldValue = IsNull(field.Value)

Exit Function

err_h:

    IsNullFieldValue = True

End Function

' Feldexportfunktion

Private Function exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim result As Boolean

    result = True

    ' Feldnamen speichern

    txtFile.Write (indent & field.Name)

    ' Feldwert, sofern verfügbar, speichern

    If Not IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' untergeordnete Felder exportieren

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' Feldinstanzen exportieren

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

End Function

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

Private Function createExportFolder(ByVal templateName As String) As String

On Error GoTo err_h

    Dim docFolder As String, folderName As String

    ' Hauptordner

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' der Ordner für die angegebene Dokumentvorlage

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' der Ordner für das exportierte Dokument

    Dim i As Long

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

Exit Function

err_h:

    createExportFolder = ""

End Function

Verwenden einer externen Komponente, die in .Net (C#) geschrieben ist

So verwenden Sie eine externe Komponente, die in .Net (C#) geschrieben ist:

  1. Erstellen Sie ein Projekt des Typs ClassLibrary.
  2. Fügen Sie die Controller.dll zu den Referenzen des Projekts hinzu. FlexiCaptureScriptingObjects wird in der Liste References aufgeführt, und alle Schnittstellen der Skriptobjekte werden im Projekt verfügbar.
  3. Definieren Sie die Schnittstelle disp und die Klasse, die diese Schnittstelle implementiert, sowie ProgId (dadurch wird es möglich, im Code des Skripts mit der .Net-Komponente so zu arbeiten wie mit ActiveX).
  4. Registrieren Sie nach dem Aufbau des Projekts die Library der generierten Typen (das kann auch automatisch durch das Aktivieren der entsprechenden Option in den Projekteigenschaften erfolgen).
  5. Rufen Sie vom Exportcode aus die Methode der Komponente auf die übliche Weise auf:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

Nachstehend der Code einer solchen Komponente:

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// Die Schnittstelle der Exportkomponente, auf die vom Skript aus zugegriffen werden kann

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// Die Klasse, die die Funktion der Exportkomponente implementiert

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

// und Ihre ProgId festlegen

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// Die Funktion führt den Dokumentexport durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien,

// die Textdatei mit Dokumentfeldern und Informationen über das Dokument

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// Die Textdatei erstellen

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// Informationen über das Dokument exportieren

exportDocInfo( docRef, sw );

// Felder exportieren

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

private string createExportFolder( string templateName )

{

string docFolder, folderName;

// Hauptordner

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// Ordner für die angegebene Dokumentvorlage

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// Ordner für das exportierte Dokument

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

return folderName;

}

// Bildexportfunktion

private void exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions(); ;

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

for each( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Informationen über das Dokument exportieren

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Auflistung von Feldern exportieren

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

for each( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// überprüft, ob der Wert des Felds NULL ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die überprüfung auf NULL) eine Ausnahme auslösen

private bool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// angegebenes Feld exportieren

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// Feldnamen speichern

sw.Write( indent + field.Name );

//Feldwert, sofern verfügbar, speichern

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// untergeordnete Felder exportieren

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// Feldinstanzen exportieren

exportFields( field.Items, sw, indent + " " );

}

}

}

}
Exportsteuerung
Dieser Beispielcode zeigt eine einfache Exportsteuerung, die Informationen über die exportierten Dokumente und Exportergebnisse in Textdateien speichert. In diesem Beispiel werden zwei Textdateien verwendet: Eine Datei enthält die Liste der erfolgreich exportierten Dokumente und die andere die Liste der Dokumente, bei denen während des Exports Fehler aufgetreten sind.

[VBScript]

dim curDoc

dim fso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

set fso = CreateObject("Scripting.FileSystemObject")

' Datei mit der Liste fehlgeschlagener Dokumente erstellen

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

set txtErrorFile = fso.CreateTextFile( fileErrorName, true )

' Datei mit der Liste erfolgreich exportierter Dokumente erstellen

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

set txtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

Dim docInfo

' Auflistung der exportierten Dokumente durchlaufen

for each curDoc in me.Documents

    docInfo = "DocumentId:" & curDoc.Id

    if curDoc.Action.Succeeded then

        docInfo = docInfo & ". Exported successfully.  Result:" & curDoc.Action.Result

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & ". Export error: " & curDoc.Action.ErrorMessage & "  Result:" & curDoc.Action.Result

        txtErrorFile.WriteLine docInfo

    end if

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

// Datei mit der Liste fehlgeschlagener Dokumente erstellen

var fileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

var txtErrorFile = fso.CreateTextFile( fileErrorName, true );

// Datei mit der Liste erfolgreich exportierter Dokumente erstellen

var fileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

var txtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

var i

// Auflistung der exportierten Dokumente durchlaufen

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Exported successfully.  Result:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Export error: " + curDoc.Action.ErrorMessage + "  Result:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture 8.0 Professional-Skripte

Migrieren von FormReader-Regeln in FlexiCapture-Skriptregeln

If-Then-Regeln

änderungen bei Funktionen und Methoden:

  1. Error(field, message). Verwenden Sie anstelle dieser Funktion eine Kombination aus folgenden Eigenschaften der zu überprüfenden Einheit: CheckSucceeded, ErrorMessage und FocusedField.

    Der folgende Code aus FormReader 6.5

    if [City].IsEmpty() then Error( [City] , "the city name should be filled")

    muss geändert werden in:

    [VBScript]

    if me.Field("City").Value = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "the city name should be filled"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Value == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "the city name should be filled";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Zeichenfolgenoperationen. Im Folgenden finden Sie Anweisungen zum Implementieren von Zeichenfolgenoperationen in FlexiCapture 8.0, die über If-Then-Regeln verfügbar waren.

    [VBScript]

    .Length() – Verwenden Sie die entsprechende Funktion "Len(string)".

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Funktion "LCase(string)" oder "UCase(string)".

    .Mid(position, count) – Verwenden Sie die entsprechende Funktion "Mid(string, pos, count)".

    [JScript]

    .Length() – Verwenden Sie die entsprechende Längenfunktion der Zeichenfolgenvariablen.

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Methode "toLowerCase()" oder "toUpperCase()" der Zeichenfolgenvariablen.

    .Mid(position, count) – Verwenden Sie die entsprechende Methode "substr(start, [length])" der Zeichenfolgenvariablen.

  3. Operationen mit reellen Zahlen

    [VBScript]

    Floor(d), Ceil(d) – Es sind keine vordefinierten Entsprechungen in VBScript vorhanden, Sie können bei Bedarf aber eigene Implementierungen erstellen.

    Round(d),Round(d, i) – Verwenden Sie die entsprechende Funktion "Round(d, [i])".

    [JScript]

    Floor(d), Ceil(d) – Verwenden Sie die Methoden "floor(d)" und "ceil(d)" des Math-Objekts.

    Round(d) – Verwenden Sie die round(d)-Methode des Math-Objekts.

    Round(d, i) – Es ist keine vordefinierte Entsprechung in JScript vorhanden, Sie können bei Bedarf aber eine eigene Implementierung erstellen.

  4. Operationen mit Textfeldern

    IsEmpty() – Vergleichen Sie den Textwert des Felds Field("fieldName").Value" mit einer leeren Zeichenfolge.

    Text() – Verwenden Sie "Field("fieldName").Value".

    Length() – Rufen Sie den Textwert des Felds ab, und bestimmen Sie anschließend die Länge der resultierenden Zeichenfolge wie unter Punkt 2 beschrieben.

    SetText(text) – Verwenden Sie "Field("fieldName").Value = text".

  5. Operationen mit Auswahlfeldern

    IsValid() – Verwenden Sie die IsCertain-Eigenschaft

    Value() – "Field("fieldName").Value" gibt jetzt einen booleschen Wert zurück und nicht mehr 0 oder 1 wie in FormReader 6.5.

    SetValue(newValue) – Verwenden Sie "Field("fieldName").Value = newValue".

  6. Operationen mit Gruppen von Auswahlfeldern

    IsValid() – Sie können mithilfe der IsCertain-Eigenschaft die Eindeutigkeit eines Felds in einer Gruppe bestimmen. Wenn Sie die Anzahl der markierten Auswahlfelder ermitteln möchten, durchlaufen Sie die Auswahlfelder in der Gruppe wie im Beispiel "überprüfung von Gruppen von Auswahlfeldern" beschrieben (siehe Beispielskripte zum Erstellen benutzerdefinierter Regeln).

    Value() – Für das Abrufen der Anzahl markierter Auswahlfelder können Sie eine der beiden unten stehenden Methoden verwenden:

    1. Weisen Sie den Auswahlfeldern in der Gruppe Zahlennamen zu: 0, 1 usw. Anschließend enthält "Field("groupName").Value" entweder die Anzahl der markierten Auswahlfelder, die Liste der Zahlen (bei mehreren Markierungen) oder eine leere Zeichenfolge (bei keiner Markierung).
    2. Fügen Sie der Regel nur die Auswahlfelder in der angegebenen Gruppe in der richtigen Reihenfolge zu. Durchlaufen Sie anschließend die Auswahlfelder in der Gruppe wie im Beispiel "überprüfung von Gruppen von Auswahlfeldern" beschrieben.

    Text() – Verwenden Sie "Field("groupName").Value".

    SetValue(newValue) – Um den Wert einer Gruppe von Auswahlfeldern zu ändern, müssen Sie die entsprechenden Auswahlfelder in der Gruppe festlegen oder zurücksetzen. Die Auswahlfelder müssen in der Regel enthalten sein, und das Kennzeichen für den Schreibschutz muss aktiviert sein.

Automatisierungsregeln

Um in FlexiCapture 8.0 Automatisierungskomponenten verwenden zu können, die in FormReader 6.5 erstellt wurden, müssen Sie an diesen Automatisierungsregeln die folgenden änderungen vornehmen.

  1. Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

    Public Sub Check(ByRef docObj As Object)

    2. docObj – Dies ist ein Verweis auf die zu überprüfende Dokumenteinheit.

  2. Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture 8.0 unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des fieldsObj-Objekts aufgeführt.
Methode von fieldsObj | Beispiele für neuen Code in VisualBasic
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Für die Arbeit mit Tabellenspalten fügen Sie der Regel die Spaltenfelder hinzu. Die überprüfung der richtigen Zuordnung der Spalte funktioniert wie bei allen anderen Feldern auch:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Für die Arbeit mit Tabellenzellen fügen Sie der Regel die Spaltenfelder hinzu.

Die Operationen mit diesen Feldern sind von der Ebene der Regel abhängig. Wenn die Regel für die Spalten- oder Tabellenebene erstellt wurde, gilt sie für jede Zeile. Dabei werden die Werte der Spalten in der überprüften Zeile verwendet (also zellenweise):

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Sie können daher eine Regel erstellen, die beispielsweise die Daten in den ersten beiden Spalten einer Tabelle verwendet, um eine dritte Spalte auszufüllen:

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Wenn die Regel für die Ebene einer Einheit erstellt wurde, die eine Tabelle enthält (Gruppe, Bereich, Dokument), müssen Sie die Spalte wie im Abschnitt "Automatisierungsregel" beschrieben durchlaufen, um auf die enthaltenen Zellen zuzugreifen.

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As String

' Vorschläge für das Feld

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As String

' Vorschläge für das Feld

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Auf Zellenfelder kann so wie im Abschnitt zur SetTableCellValue-Methode beschrieben zugegriffen werden.

Sie können anschließend mit den Zellen, auf die Sie zugegriffen haben, wie mit jedem anderen Feld arbeiten. Das Festlegen eines Vorschlags erfolgt z. B. folgendermaßen:

cell.Suggest cellSuggest

  3. Die Methoden des errorsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture 8.0 unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des errorsObj-Objekts aufgeführt.
Methode von errorsObj Beispiele für neuen Code in VisualBasic
SendFieldError( ErrMsg As String, Index As Integer) docObj.ErrorMessage = ErrMsg

docObj.CheckSucceeded = false

docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant )

docObj.ErrorMessage = ErrMsg
docObj.CheckSucceeded = false

Wenn die Regel für die Tabellen- oder Spaltenebene erstellt wurde, kennzeichnet das Programm alle Zellen in der überprüften Zeile als fehlerhaft, deren Felder (Spalten) der Regel hinzugefügt wurden. Um den Fokus auf eine bestimmte Zelle festzulegen, verwenden Sie folgenden Code:

docObj.FocusedField = docObj.Field("ColumnName")

Wenn die Regel für eine höhere Ebene geschrieben wurde, kennzeichnet das Programm keine Zellen und legt auch nicht den Fokus auf Zellen fest.

Migrieren des FormReader-Automatisierungsexports in den FlexiCapture-Skriptexport

Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – Dies ist ein Verweis auf das zu exportierende Dokument.

exportTools – Dies ist ein Verweis auf das ExportTools-Objekt.

Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die von der aktuellen Programmversion unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen des fieldsObj-Objekts und die neue Bedeutung für die Arbeit mit zu exportierenden Dokumenten aufgeführt:

Methoden des fieldsObj-Objekts | Mögliche Implementierungen im neuen Objektmodell
GetFieldsCount As
Integer 		Um die Anzahl der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und nehmen die Berechnung vor.
GetFieldsNames(Names As Variant) | Um die Namen der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und füllen das Array mit den Namen des Felds auf.
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant) Der Zugriff über den Index ist nicht sinnvoll, da das neue Dokumentmodell über eine andere hierarchische Struktur verfügt.
Die Struktur der Felder kann ganz einfach durchlaufen werden (eine Beschreibung finden Sie im Beispiel "Verwenden einer externen COM-Komponente"), um das Array mit den Namen des Felds aufzufüllen.
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


Vergleich von Regeln in FormReader 6.5 und FlexiCapture 8.0 Professional

FormReader 6.5

Entsprechung in FlexiCapture 8.0 Professional

Datenbanküberprüfung

Regel für die Datenbanküberprüfung

Summenüberprüfung

Regel für die Summenüberprüfung

Verbinden von Blöcken

Regel für das Verbinden von Feldern

VBScript-Regeln

Skriptregel

Suchen in einer Liste von Vorschlägen

Feldeigenschaften, Registerkarte Datentyp. Liste der Varianten im Feld Einschränkungen. Funktioniert bei allen Typen außer Datum und Zahl. Siehe Datentypen für Texteingabefelder.

Zuordnen von Blöcken

Implementierung über eine Skriptregel.

If-Then-Regeln

Skriptregel

Ersetzen von Werten in der Liste

Feldeigenschaften, Registerkarte Datentyp. Typ Text, Feld Verarbeitung. Siehe Datentypen für Texteingabefelder.

Ersetzen von Zeichen in der Liste

Feldeigenschaften, Registerkarte Datentyp. Typ Text, Feld Verarbeitung. Siehe Datentypen für Texteingabefelder.

Normalisieren und überprüfen von Datumsangaben

Feldeigenschaften, Registerkarte Datentyp. Wählen Sie in der Liste Kategorie die Option Datum aus. Wählen Sie in der Formatliste die gewünschten Formate aus, und geben Sie dann im Feld Einschränkungen die Einschränkungen ein. Siehe Datentypen für Texteingabefelder.

Reguläre Ausdrücke

Feldeigenschaften, Registerkarte Datentyp. Geben Sie den gewünschten regulären Ausdruck im Feld Einschränkungen ein. Funktioniert bei allen Typen außer Datum und Zahl. Siehe Datentypen für Texteingabefelder.

Automatisierungsüberprüfung

In der früheren Version der Anwendung mussten für die Verwendung von Automatisierungsobjekten Komponenten auf dem Zielcomputer registriert werden, wodurch die übertragung von Stapeln auf einen anderen Computer erschwert wurde. In der neuen Version implementieren Sie die Logik der meisten Regeln dieser Art mithilfe von Skripten.

Wenn die Logik einer Regel zu komplex ist und die Verwendung externer Komponenten erfordert, sollte diese Komponente im Code einer Skriptregel aufgerufen werden. Anschließend sollte ein Verweis auf das Objekt im überprüften Dokument an die Komponente übergeben werden.

Normalisieren von Preisen

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

Validieren von Passserie und -nummer

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

Summe in Zahlen – Summe in Worten

Summe in Zahlen und Summe in Worten

Preis in Zahlen – Preis in Worten

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.


Zusätzliche Optionen

Sie haben die Möglichkeit, die Dokumentverarbeitung und die Benutzeroberfläche des Programms Ihren Bedürfnissen anzupassen. Wählen Sie im Hauptfenster Extras>Optionen…. Das daraufhin angezeigte Dialogfeld enthält vier Registerkarten:

  • Taskstatus

    Wenn Tasks im Hintergrundmodus ausgeführt werden, dann können Sie den Fortschritt im Fenster Taskstatus, in der Protokolldatei und mithilfe der Popup-Meldungen überwachen und verfolgen. In dieser Registerkarte können Sie auswählen, welche Informationen in die Protokolldatei geschrieben und in welchen Fällen die Popup-Meldungen angezeigt werden sollen.

  • Farben

    Sie können die Farben der Elemente der Benutzeroberfläche ändern (z. B. die Rahmen, die ausgewählte Felder im Vorlageneditor umschließen, oder die Rahmen und die Flächenfarbe von Feldern mit Fehlern und Warnungen). Wählen Sie das gewünschte Element aus, und klicken Sie auf die Schaltfläche Farbe.

  • Dokumentverarbeitung

    Bilder können direkt nach dem Hinzufügen zu einem Stapel automatisch erkannt werden, wenn Sie die Option Hinzugefügte Bilder automatisch erkennen aktivieren.

    Durch Auswahl der Option Verarbeitete Dokumente nach Export löschen werden die schon erfolgreich exportierten Dokumente aus dem Stapel gelöscht.

    Wenn ein Skriptfehler erkannt wurde, wird der Debugger von Visual Studio aufgerufen. Aktivieren Sie Debugging externer Skripte deaktivieren, wenn Sie nicht möchten, dass der Debugger aufgerufen wird. In diesem Fall wird dann nur eine Fehlermeldung angezeigt.

  • Dialogfelder

    Standardmäßig wird beim Aufrufen des Programms das Dialogfeld Projekt öffnen anzeigt, in dem Sie ein vorhandenes Projekt auswählen können. Sie können die Anzeige dieses Dialogfelds verhindern, indem Sie die Option Startdialogfeld anzeigen in der Registerkarte Dialogfelder deaktivieren (alternativ können Sie die erneute Anzeige auch verhindern, indem Sie dieselbe Option im angezeigten Dialogfeld selbst deaktivieren).

    Wenn Sie eine Vorlagenliste schließen, gibt das Programm gegebenenfalls eine Warnmeldung zu vorhandenen, nicht veröffentlichten Dokumentvorlagen aus. Wenn Sie nicht möchten, dass die Warnmeldung angezeigt wird, deaktivieren Sie die Option Bei nicht veröffentlichter Vorlage Warnmeldung anzeigen (alternativ können Sie eine erneute Anzeige auch verhindern, indem Sie dieselbe Option im Dialogfeld selbst deaktivieren).


Unterstützte Erkennungssprachen

ABBYY FlexiCapture 8.0 Professional bietet für die folgenden Erkennungssprachen eine Wörterbuchunterstützung an:

Sprache | OCR* | ICR**
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | ü |
Baschkirisch | ü |
Bulgarisch | ü | ü
Dänisch | ü |
Deutsch | ü | ü
Deutsch (alte und neue Rechtschreibung) | ü | ü
Estnisch | ü | ü
Finnisch | ü | ü
Französisch | ü | ü
Griechisch | ü | ü
Indonesisch | ü | ü
Italienisch | ü | ü
Kasachisch | ü | ü
Katalanisch | ü |
Kirgisisch | ü | ü
Kroatisch | ü | ü
Lettisch | ü | ü
Litauisch | ü | ü
Niederländisch (Niederlande und Belgien) | ü | ü
Norwegisch (Nynorsk und Bokmål) | ü |
Polnisch | ü | ü
Portugiesisch (Portugal und Brasilien) | ü |
Rumänisch | ü | ü
Russisch | ü | ü
Schwedisch | ü |
Slowakisch | ü | ü
Slowenisch | ü | ü
Spanisch | ü | ü
Tatarisch | ü |
Thai | ü |
Tschechisch | ü | ü
Türkisch | ü | ü
Ukrainisch | ü | ü
Ungarisch | ü | ü

Weitere Informationen über Schriftarten der unterstützten Sprachen finden Sie im Abschnitt Schriftarten für die korrekte Darstellung von Zeichen der in FormReader-Editor unterstützten Sprachen.

Eine vollständige und aktualisierte Liste der unterstützten Datentypen mit den zugehörigen Einzelheiten finden Sie unter http://www.abbyy.com.

* - OCR: Englische Abkürzung für "Optical Character Recognition" (optische Zeichenerkennung). Optische Erkennung gedruckter Texte.

** - ICR : Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Erkennung handschriftlicher Texte.


ABBYY FlexiCapture-Beispielprojekte

Um die Arbeitsweise und die Funktionen von ABBYY FlexiCapture 8.0 besser zu verstehen, können Sie die Beispielprojekte verwenden, die im Programm enthalten sind. Diese vordefinierten Projekte enthalten fertig eingerichtete Dokumentvorlagen und Dokumentbilder für die Verarbeitung.

Die Beispielprojekte finden Sie im Verzeichnis <Laufwerksbezeichnung>:\\Dokumente und Einstellungen\All Users\Anwendungsdaten\ABBYY\FlexiCapture\8.0\Samples.

Hinweis: Unter Microsoft Windows Vista finden Sie die Beispielprojekte im Verzeichnis <Laufwerksbezeichnung>:\\Users\Public\ABBYY\FlexiCapture\8.0\Samples.

Das Verzeichnis Samples enthält folgende Ordner:

  1. FlexiCapture: Dieser Ordner enthält die Beispielprojekte für FlexiCapture.
  2. FlexiLayoutStudio: Dieser Ordner enthält die Beispielprojekte für FlexiLayout Studio. Diese Beispielprojekte illustrieren die Verarbeitung von teilweise strukturierten Dokumenten und sollten in ABBYY FlexiLayout Studio 8.0 geöffnet werden. Ausführliche Beschreibungen einiger dieser Projekte sind in der Hilfedatei von FlexiLayout Studio verfügbar (siehe dazu die Abschnitte Lernprogramm und Tipps und Tricks).
  3. FormDesigner: Dieser Ordner enthält statische Formulare, die in ABBYY FormDesigner entwickelt wurden. Die Dateien mit der Endung *.fdd sollten in ABBYY FormDesigner 8.0 geöffnet werden. Diese Formulare werden in folgenden FlexiCapture-Projekten verwendet: Bankkartenanwendung, Fragebogen.
  4. Images: Dieser Ordner enthält die gescannten Dokumentbilder für die Beispielprojekte in FlexiCapture.

Nachstehend werden die FlexiCapture-Beispielprojekte aufgeführt und kurz beschrieben.

Ein Beispielprojekt mit Dokumenten unterschiedlichen Typs

Die Projektordner enthalten Beispielprojekte für FlexiCapture.

  1. Zentraler Einstieg

    Dieses Projekt zeigt, wie Dokumente unterschiedlichen Typs verarbeitet werden können. Es ist keine vorherige Sortierung der Dokumente erforderlich, statische Formulare und flexible Dokumente können zusammen verarbeitet werden. Die in diesem Projekt verwendeten Vorlagen werden auch in den unten beschriebenen Projekten verwendet.

    Das Projekt enthält alle Arten von Dokumenten: Bankkartenanwendungen, Rechnungen, Verträge, Briefe, Preise.

Beispielprojekte mit statischen Formularen

Die Projektordner enthalten Formulare, die in ABBYY FormDesigner- und FlexiCapture-Projekten erstellt wurden.

  2. Bankkartenanwendung

    Dieses Beispielprojekt stellt die folgenden Funktionen heraus:

    • Automatische Erkennung von Feldern auf statischen Formularen (wenn Sie die Funktionsweise der automatischen Erkennung testen möchten, löschen Sie alle Felder aus der Dokumentvorlage, und wählen Sie Extras >Objekte automatisch erkennen…).
    • Unterstützung von Dokumenten mit komplexen Strukturen:
      1. Mehrseitige Dokumente (im Beispielprojekt werden dreiseitige Anwendungen verwendet)
      2. Arbeit mit Dokumentbereichen (im Beispielprojekt ist jede Seite ein separater Bereich)
      3. Dokumentzusammenstellungsregeln
      4. Verarbeitung von Anhängen
    • Unterstützung von komplexen Feldern:
      1. Arbeit mit Tabellen auf statischen Formularen (Tabelle "Eröffnete Konten")
      2. Wiederholte Feldgruppen (die Gruppen "Adresse" und "Angeforderte Konten")
    • überprüfung der Datenformate (die Formate aller Zahl- und Datumsfelder sind festgelegt)
    • Anpassung des Datenformulars

  3. Fragebogen

    Eine ausführliche Beschreibung dieses Beispielprojekts finden Sie im Benutzerhandbuch. Das Projekt zeigt, wie eine Dokumentvorlage schrittweise eingerichtet wird. Mehrere einfache Formulare werden dabei verwendet, um die grundlegenden Funktionen von ABBYY FlexiCapture zu verdeutlichen. Sie können den Fragebogen dieses Beispielprojekts vervollständigen, ihn in ABBYY FlexiCapture verarbeiten und die exportierten Daten an ABBYY senden.

Beispielprojekte mit flexiblen Formularen

Die Projektordner enthalten Beispielprojekte für FlexiLayout Studio und FlexiCapture.

  4. Rechnung

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 3)
    • Tabellen, die sich über mehrere Seiten erstrecken
    • Verwendung eines externen Wörterbuchs mit Schlüsselwörtern (eine Textdatei)
    • Es wird eine JScript-Regel verwendet, um die Summe im Feld "Total" (Gesamt) mit der durch Addition der einzelnen Gesamtwerte aller Tabellenzeilen ermittelten Summe zu vergleichen.

  5. Preise

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Unterstützung wiederholter Gruppen. Dieses Beispielprojekt zeigt, wie wiederholt auftretende Gruppen verwendet werden können, um verschachtelte Tabellen (Tabellen mit untergeordneten überschriften) zu beschreiben.

  6. Briefe und Verträge

    Dieses Beispielprojekt zeigt die Verarbeitung unstrukturierter Dokumente, aus denen zwei oder drei Felder erfasst werden. Dabei kommen im Projekt vor allem die folgenden Funktionen zur Geltung:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 4)
    • Einrichtung des Exports in eine durchsuchbare PDF-Datei


Schriftarten für die korrekte Darstellung von Zeichen der in FormReader-Editor unterstützten Sprachen

Schriftarten für die korrekte Darstellung von Zeichen der in ABBYY FlexiCapture-Editor unterstützten Sprachen

Sprache | Schriftart
Mit Wörterbuchunterstützung |
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | Arial Unicode MS(2)
Tatarisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ohne Wörterbuchunterstützung |
Abchasisch | Arial Unicode MS(2)
Adygeisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aghulisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Altaisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Awarisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aserbaidschanisch (Kyrillisch), Aserbaidschanisch (Lateinisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Baschkirisch | Arial Unicode MS(2), Palatino Linotype(2)
Burjatisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Tschetschenisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuktschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuwaschisch | Arial Unicode MS(2)
Darginisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Dunganisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Gagausisch | Arial Unicode MS(2)
Haussa | Arial Unicode MS(2), Lucida Sans Unicode(3)
Inguschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kabardinisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kalmückisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Karakalpakisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Kasachisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Chakassisch | Arial Unicode MS(2)
Chantisch | Arial Unicode MS(2)
Korjakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kirgisisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Lakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Lesgisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mansisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mari | Arial Unicode MS(2)
Mongolisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Nenzisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ossetisch | Arial Unicode MS(2)
Russisch (alte Rechtschreibung) | Arial Unicode MS(2), Palatino Linotype(2)
Tabassaranisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tadschikisch | Arial Unicode MS(2), Palatino Linotype(2)
Turkmenisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Tuwinisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Udmurtisch | Arial Unicode MS(2)
Usbekisch (Kyrillisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Jakutisch | Arial Unicode MS(2)
Zulu | Arial Unicode MS(2), Lucida Sans Unicode(3)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Unterstützte Texttypen

ABBYY FlexiCapture 8.0 Professional unterstützt die folgenden Texttypen:

Texttyp | Beschreibung
Satz-, Laser- und Ink-Jet-Drucker | Die Texte wurden in einer Druckerei, auf einem Laserdrucker oder einem Ink-Jet-Drucker gedruckt.
Schreibmaschine | Auf einer Schreibmaschine geschriebene Texte.
Matrixdrucker | Die Texte wurden auf einem Punktmatrixdrucker gedruckt.
Index | Ein spezieller Zeichensatz, der nur Ziffern im PLZ-Format enthält. Diese werden folgendermaßen dargestellt:
OCR-A | Eine Konstantschriftart für die optische Zeichenerkennung. Sie wird häufig von Banken, Kreditkarteninstituten und ähnlichen Firmen verwendet. Die Darstellung ähnelt folgender:
OCR-B | Eine Schriftart für die optische Zeichenerkennung. Die Darstellung ähnelt folgender:
MICR E-138 | Ein spezieller Satz numerischer Zeichen, die mit einer magnetischen Spezialtinte gedruckt werden. MICR-Zeichen (Magnetic Ink Character Recognition) finden sich an verschiedenen Stellen, unter anderem auf Barschecks. Die Darstellung ähnelt folgender:
MICR CMC-7 | Eine spezielle MICR-Schriftart für Barcodes (CMC-7). Die Darstellung ähnelt folgender:


Unterstützte Barcodetypen

ABBYY FlexiCapture 8.0 Professional unterstützt die folgenden Barcodeformate:

  • EAN 13
  • EAN 8
  • Code 39
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF -417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patchcode


Unterstützte Grafikformate

Typ | Farbe
BMP | S/W, Grau, Farbe
PCX | S/W, Grau
PNG | S/W, Grau, Farbe
JPEG | Grau, Farbe
JPEG-2000 | Grau, Farbe
TIFF | S/W: unkomprimiert, CCITT3, CCITT4, Packbits, ZIP Grau: unkomprimiert, Packbits, JPEG, ZIP Farbe: unkomprimiert, JPEG, ZIP
PDF, PDF/A |
PDF, PDF/A durchsuchbar |
DjVu | S/W, Grau, Farbe


Exportdateiformate

Dateiformate für das Exportieren aus Dokumenten in ABBYY FlexiCapture 8.0 Professional

  • Microsoft Office Excel-Arbeitsmappe (*.xls)
  • DBase-Datei (*.dbf)
  • Kommagetrennte Datei (*.csv). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).
  • Kommagetrennte Datei (*.csv) im Unicode-Format (UTF-8, UTF-16)
  • Textdatei (*.txt). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).
  • Textdatei (*.txt) im Unicode-Format (UTF-8, UTF-16)
  • XML-Dokument (*.xml)


Alphabet in regulären Ausdrücken

Name | Verwendete Bezeichnung | Beispiel für die Verwendung
Beliebiges Zeichen | * | "c"*"t" – lässt die Wörter cat, cot usw. zu.
Buchstabe | C | C"ot" – lässt die Wörter Rot, pot, cot, Dot, mot usw. zu.
Großbuchstabe | A | A"ot" – lässt die Wörter Rot, Cot, Mot, Dot usw. zu.
Kleinbuchstabe | a | a"ot" – lässt die Wörter rot, cot, mot, dot usw. zu.
Ziffer oder Buchstabe | X | X – lässt jedes einzelne Vorkommen eines Buchstabens oder einer Ziffer zu.
Zahl | N | N"." – lässt die Kombinationen 5., 4., 6. usw. zu.
Zeichenfolge | " " | "cot"
Oder | | | "pl"("o"|"a")"t" – lässt die Wörter "plot" und "plat" zu.
Zeichen aus Gruppe | [] | [tm]"ot" – lässt die Wörter "tot" und "mot" zu.
Zeichen nicht aus Gruppe | [^] | [^t]"ot" – lässt die Wörter "cot", "lot" usw. zu, aber nicht das Wort "tot".
Leerzeichen (in Gruppe) | \s | [A\s] – lässt nur den Buchstaben A oder ein Leerzeichen zu.
Eine beliebige Anzahl von Wiederholungen (gilt für den davor stehenden Ausdruck oder Unterausdruck) | {-} | [AB74]{-} – lässt beliebige Kombinationen der Zeichen A, B, 7 und 4 beliebiger Länge zu.
n Wiederholungen | {n} | N{2}"." – lässt die Kombinationen 25., 84., 11. usw. zu.
n bis m Wiederholungen | {n-m} | N{1-3}"." – lässt die Kombinationen 5., 84., 111. usw. zu.
0 bis n Wiederholungen | {-n} | N{-2}"." – lässt die Kombinationen 84., 111. usw. zu.
n und mehr Wiederholungen | {n-} | N{2-}"." – lässt die Kombinationen 25., 834., 311., 34576. usw. zu.
Unterausdruck | () |
Bindestrich | [\-] |
Umgekehrter Schrägstrich | [\\] |


Patente

US-Patentnummern: 5.258.855, 5.369.508, 5.625.465, 5.768.416 und 6.094.505


Technologien von Drittanbietern

JasPer-Lizenz Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

Alle Rechte vorbehalten.

Sonstiges

Vorbehaltlich der nachstehenden Bedingungen erhalten Personen (die "Benutzer"), die eine Kopie dieser Software sowie der dazugehörigen Dokumentationsdateien (die "Software") erworben haben, hiermit die uneingeschränkte Genehmigung, die Software gebührenfrei weiterzugeben, einschließlich des Rechts, Kopien dieser Software zu verwenden, sie zu kopieren, zu ändern, zusammenzuführen, zu veröffentlichen, zu verteilen und/oder zu verkaufen, und diese Genehmigung auch Dritten zu erteilen, denen die Software bereitgestellt wird:

  1. Die oben stehenden Copyright-Hinweise und sowie diese Genehmigung (einschließlich des folgenden Haftungsausschlusses) müssen in allen wichtigen Teilen der Software enthalten sein.

  2. Der Name des Copyright-Inhabers darf nicht ohne vorherige schriftliche Genehmigung des Copyright-Inhabers zur Werbung oder für den Vertrieb von Produkten, die aus der Software abgeleitet wurden, verwendet werden.

DIESER GEWäHRLEISTUNGSAUSSCHLUSS STELLT EINEN WESENTLICHEN TEIL DIESER LIZENZ DAR.

DIE NUTZUNG DER SOFTWARE IST NUR UNTER BEACHTUNG DIESES AUSSCHLUSSES ZULäSSIG. DIE SOFTWARE WIRD VOM COPYRIGHT-INHABER OHNE MäNGELGEWäHR UND OHNE AUSDRüCKLICHE ODER STILLSCHWEIGEND EINGESCHLOSSENE GARANTIE AUSGELIEFERT, EINSCHLIESSLICH, ABER NICHT BEGRENZT AUF DIE GEWäHRLEISTUNG, DASS DIE SOFTWARE VON MARKTGäNGIGER QUALITäT UND FüR EINEN BESTIMMTEN ZWECK GEEIGNET IST UND DIE RECHTE DRITTER NICHT VERLETZT WERDEN. UNTER KEINEN UMSTäNDEN SIND DIE IN DIESEM HINWEIS ERWäHNTEN COPYRIGHT-INHABER HAFTBAR FüR INDIREKTE, SONDER- ODER FOLGESCHäDEN, ODER SCHäDEN, DIE DURCH DIE NICHTVERWENDBARKEIT, DEN VERLUST VON DATEN ODER GEWINNVERLUST, AUF DER GRUNDLAGE EINES VERTRAGS, AUFGRUND VON FAHRLäSSIGKEIT ODER ANDERER UNERLAUBTER HANDLUNGEN, AUS DEM GEBRAUCH ODER IN ZUSAMMENHANG MIT DEM GEBRAUCH ODER DER LEISTUNG DIESER SOFTWARE ENTSTEHEN. ES WERDEN VOM COPYRIGHT-INHABER KEINERLEI GARANTIEN DAFüR üBERNOMMEN, DASS DURCH DIE SOFTWARE KEINE PATENTE ODER ANDERE RECHTE AN GEISTIGEM EIGENTUM ANDERER RECHTSPERSONEN VERLETZT WERDEN. DIE COPYRIGHT-INHABER üBERNEHMEN KEINERLEI HAFTUNG FüR ETWAIGE RECHTSANSPRüCHE DRITTER, DIE AUF DER GRUNDLAGE VON VERLETZUNGEN DES RECHTS AN GEISTIGEM EIGENTUM ODER ANDEREN RECHTEN DURCH DIE NUTZUNG DER SOFTWARE DURCH DEN BENUTZER ENTSTEHEN. ALS BEDINGUNG ZUR INANSPRUCHNAHME DER HIERMIT GEWäHRTEN RECHTE ERKLäRT JEDER BENUTZER HIERMIT SEINE EIGENE VERANTWORTUNG IM UMGANG MIT DEN RECHTEN DRITTER AM GEISTIGEN EIGENTUM UND VERSICHERT, DIESE ZU ACHTEN. DIE SOFTWARE KANN FEHLER AUFWEISEN UND IST NICHT FüR DIE BENUTZUNG IN RISIKO-UMGEBUNGEN ENTWICKELT ODER VORGESEHEN, DIE FEHLERFREIEN BETRIEB VORAUSSETZEN, Z. B. BEIM BETRIEB VON KERNKRAFT-EINRICHTUNGEN, LUFTFAHRTNAVIGATIONS- ODER KOMMUNIKATIONSSYSTEMEN, LUFTVERKEHRSKONTROLLEINRICHTUNGEN, WAFFENSYSTEMEN, LEBENSERHALTENDEN MASCHINEN ODER SäMTLICHEN ANDEREN ANWENDUNGEN, BEI DENEN SOFTWAREFEHLER UNMITTELBARE GEFAHR FüR LEIB ODER LEBEN ODER ERHEBLICHE SACHSCHäDEN NACH SICH ZIEHEN KöNNEN ("HOCHRISIKOAKTIVITäTEN"). DIE COPYRIGHT-INHABER LEHNEN DESHALB JEDE AUSDRüCKLICHE ODER KONKLUDENTE GEWäHRLEISTUNG DER EIGNUNG FüR MIT EINEM HOHEN RISIKO BEHAFTETE AKTIVITäTEN AB.

MARKEN

QuickScan ist eine Marke und Captiva ist eine eingetragene Marke der Captiva Software Corporation.

KODAK ist eine Marke der Eastman Kodak Company.


Technischer Support

Wenn Sie Fragen zur Verwendung von ABBYY FlexiCapture 8.0 Professional haben, finden Sie in den Hilfethemen und im Benutzerhandbuch von ABBYY FlexiCapture 8.0 Professional eine ausführliche Beschreibung der Funktionen. Auch im Bereich des Technischen Supports auf unserer Website unter http://www.abbyy.com finden Sie Antworten zu bestimmten Fragen.

Damit der Technische Support Ihre Fragen beantworten kann, sind folgende Informationen erforderlich:

  • Nachname, Vorname
  • Name der Organisation
  • Telefonnummer (Fax, E-Mail-Adresse)
  • Seriennummer Ihres Installationspakets
  • Build (siehe Hilfe > Info…)
  • Allgemeine Beschreibung des Problems mit dem vollständigen Text der Fehlermeldung (sofern vorhanden)
  • Typ des Computers und Prozessors
  • Windows-Version
  • Weitere Informationen, die Sie für wichtig erachten
Adressen und Kontaktinformationen der Niederlassungen von ABBYY


Informationen zum Kauf von ABBYY FormDesigner 8.0 Professional

Informationen zum Kauf von ABBYY FlexiCapture 8.0 Professional

Wenn Sie ABBYY FlexiCapture bestellen möchten oder eine Frage zum Kauf haben, wenden Sie sich bitte an die autorisierten Partner von ABBYY oder an eine der regionalen ABBYY-Niederlassungen.


Adressen und Kontaktinformationen der Niederlassungen von ABBYY

Russland | ABBYY Russland Telefon: +7 495 783 3700 Fax: +7 495 783 2663 Adresse: P.O. Box 49, Moskau 129301, Russland, ABBYY Software LLC Firmenanschrift: Moscow, VDNKh subway station 11 Kasatkina St., building 1 E-Mail: sales@abbyy.ru Technischer Support: support@abbyy.ru Website: http://www.abbyy.ru WEGBESCHREIBUNG
Nord-/ Mittelamerika | Kunden aus den USA, Kanada, Mexiko und Ländern Mittelamerikas wenden sich an: ABBYY USA Telefon: +1 510 226 6717 Fax: +1 510 226 6069 Adresse: 47221 Fremont Boulevard, Fremont, California 94538, USA E-Mail: sales@abbyyusa.com Technischer Support: support@abbyyusa.com Website: http://www.abbyy.com
Osteuropa und Mittelmeerraum | Kunden aus Albanien, Bosnien-Herzegowina, Bulgarien, Israel, Kroatien, Mazedonien (ehemalige Jugoslawische Republik), Moldawien, Montenegro, Polen, Rumänien, Serbien, der Slowakei, Slowenien, der Tschechischen Republik, der Türkei, der Ukraine, Ungarn und Zypern wenden sich an: ABBYY Ukraine Telefon: +380 44 490 9999 Fax: +380 44 490 9461 Adresse: P.O. Box 23, 02002 Kiew, Ukraine E-Mail: forms@abbyy.ua Technischer Support: Telefon: +380 44 490 94 63 E-Mail: formssupport@abbyy.ua Website: http://www.abbyy.ua
Westeuropa | Kunden aus den Benelux-Staaten, Dänemark, Deutschland, Frankreich, Griechenland, Großbritannien, Irland, Italien, Norwegen, Österreich, Portugal, Schweden, Spanien, der Schweiz oder anderen westeuropäischen Ländern wenden sich an: ABBYY Europe GmbH Telefon: +49 89 511 159 0 Fax: +49 89 511 159 59 Adresse: Elsenheimerstrasse 49, 80687 München, Deutschland E-Mail: sales_eu@abbyy.com Technischer Support: support_eu@abbyy.com Website: http://www.abbyy.com
Japan | Kunden aus Japan wenden sich an: ABBYY Japan: Telefon:+81-42-795-1901 Fax: +81-42-795-1901 Adresse: 658-1 Tsuruma, Machida-shi, Tokio 194-8510 E-Mail: sales@abbyyusa.com Technischer Support: support@abbyyusa.com Website: http://www.abbyy.com
Andere Regionen | Kunden aus Ländern, die oben nicht aufgeführt wurden, wenden sich an: ABBYY Russland Telefon: +7 495 783 3700 Fax: +7 495 783 2663 Adresse: P.O. Box 49, Moskau 129301, Russland, ABBYY Software LLC E-Mail: sales@abbyy.com Technischer Support: support@abbyy.ru Website: http://www.abbyy.ru, http://www.abbyy.com


Endbenutzer-Lizenzvertrag

ABBYY FlexiCapture 8.0 Professional

Wichtig: Lesen Sie die nachstehenden Bedingungen sorgfältig durch, bevor Sie das Produkt installieren, kopieren und/oder verwenden. Indem Sie das Produkt installieren, kopieren oder verwenden, erklären Sie sich mit diesen Bedingungen einverstanden.

Dieser ABBYY-Endbenutzer-Lizenzvertrag ist ein rechtsgültiger Vertrag zwischen Ihnen, dem Endbenutzer (einschließlich jeder juristischen Person, für die diese Software erworben wurde), und ABBYY in Bezug auf das oben genannte Softwareprodukt von ABBYY, zu dem dieser Endbenutzer-Lizenzvertrag gehört, einschließlich sämtlicher dazugehöriger Datenträger, gedruckter Materialien sowie der Online- oder elektronischen Dokumentation (gemeinsam als die "SOFTWARE" bezeichnet).

Indem Sie die SOFTWARE installieren, kopieren oder anderweitig nutzen, bestätigen Sie, diesen Endbenutzer-Lizenzvertrag gelesen und zur Kenntnis genommen zu haben, und verpflichten sich zur Einhaltung der hierin festgelegten Bedingungen.

Die SOFTWARE ist durch Urheberrechte sowie internationale Verträge geschützt. Sie erkennen an, dass dieser Endbenutzer-Lizenzvertrag – wie jeder andere schriftliche, ausgehandelte und von Ihnen unterzeichnete Vertrag – einklagbar ist.

Falls der SOFTWARE ein Endbenutzer-Lizenzvertrag in Papierformat beiliegt und Abweichungen zwischen der vorliegenden Version und der Papierversion bestehen, ist der Text in der Papierversion maßgebend.

Dieser Endbenutzer-Lizenzvertrag tritt in Kraft, sobald Sie alle hierin genannten Bedingungen durch Auswählen der Option "Ich akzeptiere die Bedingungen der Lizenzvereinbarung" und anschließendes Klicken auf "Weiter" im Installationsprogramm der SOFTWARE akzeptiert haben, und bleibt bis zum Ablauf des Urheberrechts für die SOFTWARE rechtsverbindlich.

Wenn Sie den Bestimmungen dieses Endbenutzer-Lizenzvertrags nicht zustimmen, dürfen Sie die SOFTWARE nicht verwenden. Wählen Sie in diesem Fall im Installationsprogramm der SOFTWARE die Option "Ich lehne die Bedingungen der Lizenzvereinbarung ab", und klicken Sie anschließend auf "Abbrechen". Unter folgenden Bedingungen wird Ihnen der Kaufpreis vollständig zurückerstattet:

(i) Sie verwenden die SOFTWARE nicht und
(ii) Sie geben die SOFTWARE einschließlich der oben genannten Dokumentation, Datenträger und Verpackung unter Vorlage des Kaufbelegs innerhalb von dreißig (30) Tagen ab Kaufdatum zurück, wenn nicht durch die Gesetze des Landes und die Rückgabebestimmungen des Händlers, von dem Sie die SOFTWARE erworben haben, etwas anderes festgelegt wird.

1. Definitionen:

Als SOFTWARE wird die ABBYY FlexiCapture 8.0 Professional-Software bezeichnet, bei der es sich um ein Paket handelt aus Computerprogrammen, Datenbanken und (in einem gedruckten oder elektronischen Format vorliegender) Dokumentation, die urheberrechtlich geschützt sind.

Eine SOFTWARE-Komponente ist ein beliebiger Bestandteil der SOFTWARE, einschließlich, aber nicht beschränkt auf sämtliche Computerprogramme, die im Lieferumfang der SOFTWARE enthalten sind.

Ein Computer ist ein elektronisches Gerät mit mindestens einer CPU, das Daten in digitaler oder ähnlicher Form erfasst und für ein bestimmtes Ergebnis auf der Grundlage einer Befehlsfolge verarbeitet.

Als SOFTWARE-Kopie gilt eine lizenzierte Kopie der SOFTWARE oder einer SOFTWARE-Komponente, die auf dem Computer installiert ist und entsprechend den Beschreibungen in der SOFTWARE-Dokumentation funktioniert.

Als Entwurfstool werden die SOFTWARE-Module ABBYY FlexiLayout Studio und ABBYY FormDesigner bezeichnet.

Lizenz bezeichnet das Ihnen von ABBYY gewährte nicht exklusive Recht zur Nutzung der SOFTWARE gemäß den Bedingungen des vorliegenden Endbenutzer-Lizenzvertrags.

Aktivierung der SOFTWARE bezeichnet das Verfahren, bei dem die vollständige Funktionsfähigkeit der SOFTWARE gemäß den Anweisungen in der SOFTWARE-Dokumentation hergestellt wird.

Verwendung der SOFTWARE bezeichnet die Ausführung der in der SOFTWARE-Dokumentation beschriebenen Aktionen sowie die Nutzung des Funktionsumfangs der SOFTWARE.

Support bezeichnet Serviceleistungen, die Ihnen von ABBYY oder seinen Lieferanten zur Verfügung gestellt werden: Upgrades und/oder Updates für die SOFTWARE und/oder technischer Support.

Ein Lieferant ist eine natürliche oder juristische Person, die von ABBYY autorisiert ist, die SOFTWARE und/oder den Support anzubieten.

ABBYY bezieht sich auf:

ABBYY USA Software House Inc. mit Sitz in 47221 Fremont Boulevard, Fremont, California 94538, USA, für den Fall, dass Artikel 21.1 des vorliegenden Endbenutzer-Lizenzvertrags zur Anwendung kommt;

ABBYY Europe GmbH mit Sitz in 80687 München, Elsenheimerstr. 49, für den Fall, dass Artikel 21.2 des vorliegenden Endbenutzer-Lizenzvertrags zur Anwendung kommt;

ABBYY LLC mit Sitz in 21 building 1 Bratislavskaya Ulitsa, 109451, Moskau, Russland, für den Fall, dass Artikel 21.3 des vorliegenden Endbenutzer-Lizenzvertrags zur Anwendung kommt;

ABBYY Software House Ukraine mit Sitz in 31, Degtyarevskaya st., Kiew, Ukraine 03680, für den Fall, dass Artikel 21.4 des vorliegenden Endbenutzer-Lizenzvertrags zur Anwendung kommt;

und ABBYY Solutions Ltd. mit Sitz in Kastoros 2, CY 1087, Nikosia, Zypern, für alle anderen Fälle.

ABBYY Group bezieht sich auf ABBYY und alle seine Tochtergesellschaften.

ABBYY-Tochtergesellschaft bezieht sich auf eine juristische Person, die direkt oder indirekt über eine oder mehrere Zwischenstufen von ABBYY kontrolliert wird, unter allgemeiner Kontrolle von ABBYY steht oder ABBYY kontrolliert.

"Sie und Ihr bezieht sich auf und umfasst jede natürliche und/oder juristische Person, die diese SOFTWARE erworben hat und für die diese SOFTWARE benutzt wird.

2. Lizenzgewährung

2.1. Unter der Voraussetzung Ihrer Einhaltung der Bestimmungen dieses Vertrags garantiert Ihnen ABBYY ein nicht exklusives beschränktes Recht (die "Lizenz"), das Sie zur Nutzung der SOFTWARE einschließlich aller darin integrierten Bilder, Fotos, Animationen, Audio-Video-Komponenten, Musik, Texte und Applets sowie der begleitenden gedruckten Materialien und sämtlicher Kopien der SOFTWARE berechtigt. Alle im Folgenden angeführten Bedingungen beziehen sich sowohl auf die SOFTWARE als Ganzes als auch auf alle Softwarekomponenten.

3. Lizenz

3.1. ABBYY verbürgt sich dafür und garantiert, dass es in vollem Umfang über die Berechtigung, Befugnis, Rechtsfähigkeit, Fähigkeit und Autorisierung zur Lizenzierung und Verteilung der SOFTWARE einschließlich aller darin integrierten Bilder, Fotos, Animationen, Audio-Video-Komponenten, Musik, Texte und Applets sowie der begleitenden gedruckten Materialien und sämtlicher Kopien der SOFTWARE verfügt.

3.2. Alle Rechte an Titeln und geistigem Eigentum, die nicht Bestandteil der SOFTWARE sind, auf die aber durch die Softwarenutzung zugegriffen wird, liegen beim jeweiligen Eigentümer und sind möglicherweise durch das Urheberrecht und/oder andere Gesetze und Verträge für geistiges Eigentum geschützt. Dieser Endbenutzer-Lizenzvertrag überträgt keinesfalls das Eigentum derartigen geistigen Eigentums.

3.3. Sie erkennen an, dass die SOFTWARE gegen unbefugtes Kopieren und/oder unbefugte Nutzung geschützt ist und zu diesem Schutz einen Softwareschlüssel oder Dongle umfassen kann (nachstehend als "Lizenzschlüssel" bezeichnet), und verpflichten sich in diesem Zusammenhang zur Einhaltung dieser Schutzmaßnahmen in Bezug auf die SOFTWARE.

3.4. Der genaue Umfang der Lizenz kann von verschiedenen beim Kauf anzugebenden Faktoren abhängen, wie z. B. dem Funktionsumfang, der zulässigen Anzahl Softwarekopien im Netzwerk, der Anzahl der für die Verarbeitung verwendeten CPUs, der Anzahl Seiten, die verarbeitet werden können, sowie dem Ablaufdatum. Diese und weitere Informationen sind im Lizenzschlüssel kodiert gespeichert. Technisch betrachtet definiert der Lizenzschlüssel also den Umfang der von Ihnen erworbenen Lizenz und schränkt die Nutzung der SOFTWARE entsprechend ein.

3.5. Die SOFTWARE beinhaltet wertvolle Geschäftsgeheimnisse und vertrauliche Informationen von ABBYY und ist durch (einschließlich, aber nicht beschränkt auf) das Urheberrechtsgesetz der USA, internationale Verträge und die in dem Bestimmungsland geltenden Gesetze urheberrechtlich geschützt. Jegliche Verwendung der SOFTWARE außerhalb der oder unter Zuwiderhandlung gegen die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags stellt einen Verstoß gegen die Rechte am geistigen Eigentum von ABBYY dar und hat den Entzug aller Rechte zur Nutzung der SOFTWARE zur Folge, die Ihnen in diesem Endbenutzer-Lizenzvertrag gewährt werden.

3.6. Sie können diesen Endbenutzer-Lizenzvertrag und die SOFTWARE lediglich einmal dauerhaft an einen anderen Endbenutzer übertragen. Diese übertragung muss die gesamte SOFTWARE (einschließlich aller SOFTWARE-Komponenten, Datenträger, gedruckten Materialien, sämtlicher Upgrades sowie dieses Endbenutzer-Lizenzvertrags) umfassen. Eine solche übertragung darf nicht per Zusendung oder auf anderem indirekten Weg erfolgen. Der Empfänger der übertragung muss sich zur Einhaltung der Bestimmungen dieses Endbenutzer-Lizenzvertrags verpflichten, einschließlich der Verpflichtung, diesen Endbenutzer-Lizenzvertrag und die SOFTWARE nicht seinerseits weiterzugeben. Sie müssen die SOFTWARE-Komponenten im Falle einer solchen übertragung der SOFTWARE von Ihrem Computer oder Ihrem Local Area Network deinstallieren.

3.7. Sie sind nicht berechtigt, die SOFTWARE, einschließlich sämtlicher Ihnen hierin gewährten Rechte und/oder anderer Rechte in Bezug auf die SOFTWARE, an andere Personen zu übertragen bzw. weiterzugeben. ABBYY behält sich das Recht vor, im Falle einer solchen übertragung oder Weitergabe den vorliegenden Endbenutzer-Lizenzvertrag einseitig zu kündigen.

3.8. Dieser Endbenutzer-Lizenzvertrag gewährt Ihnen keinerlei Rechte in Verbindung mit Marken von ABBYY.

3.9. Rechtsvorbehalt. Alle Ihnen nicht ausdrücklich gewährten Rechte sind ABBYY vorbehalten.

4. Verwendung der SOFTWARE

4.1. Sie sind berechtigt, die SOFTWARE in dem in Ihrer Lizenz gewährten Umfang zu nutzen.

4.2. Sie sind berechtigt, die SOFTWARE ohne SOFTWARE-Aktivierung auf einer unbeschränkten Anzahl Computer zu installieren.

4.3. Sie sind berechtigt, so viele Kopien der SOFTWARE gleichzeitig zu verwenden, wie laut Ihrer Lizenz zulässig sind.

4.4. Die Anzahl der gleichzeitig ausgeführten Kopien des Entwurfstools darf unter keinen Umständen die laut Lizenz zulässige Anzahl SOFTWARE-Kopien überschreiten.

4.5. Wenn Sie die SOFTWARE über einen Terminaldienst aufrufen, dürfen Sie so viele Kopien der SOFTWARE gleichzeitig verwenden, wie laut Ihrer Lizenz zulässig und in diesem Endbenutzer-Lizenzvertrag festgelegt sind.

4.6. Sie sind nur dann berechtigt, mithilfe der SOFTWARE Scan- und Konvertierungsleistungen anzubieten und/oder die unter Verwendung der SOFTWARE erzielten Ergebnisse Dritten zur Verfügung zu stellen, wenn in Ihrem Lizenzschlüssel der Parameter "BPO services" aktiviert (d. h. auf "Enabled" gesetzt) ist.

4.7. Sie verpflichten sich, ABBYY gegen jede Art von Ansprüchen, Haftungsansprüchen, Verlusten, Vorgehen, Schäden und/oder gerichtlichen Verfahren, einschließlich jeglicher Anwaltsgebühren, die aus oder in Zusammenhang mit der Benutzung und/oder mit dem Verlass auf die SOFTWARE entstehen können, zu schützen, abzufinden und schadlos zu halten.

5. SOFTWARE auf mehreren Datenträgern

5.1. Sie erhalten die SOFTWARE möglicherweise auf mehreren Datenträgern, wozu auch Downloads über das Internet gehören können. Ungeachtet der Anzahl Datenträger, die Sie erhalten, sind Ihre Rechte zur Nutzung der SOFTWARE auf die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags beschränkt.

6. Endbenutzerdatenbanken

6.1. Sie sind berechtigt, eigene Datenbanken zu den Programmen der SOFTWARE zu erstellen, sofern diese Funktion in der SOFTWARE vorgesehen ist.

7. Weiterverteilung der SOFTWARE

7.1. Jegliche Weiterverteilung der SOFTWARE, die über den in Artikel 3.6 beschriebenen Rahmen hinausgeht, ist strengstens untersagt. "Weiterverteilung" beinhaltet das Verkaufen, Vermieten, Leasen und Verleihen der SOFTWARE, ist jedoch nicht darauf beschränkt.

8. Einschränkungen

8.1. Sie erkennen an, dass die SOFTWARE gegen unbefugtes Kopieren und/oder unbefugte Nutzung geschützt ist. Sie können die Ihnen in diesem Endbenutzer-Lizenzvertrag gewährten Rechte an der SOFTWARE möglicherweise nur ausüben, wenn Sie Ihre Kopie der SOFTWARE aktivieren. Bei der Aktivierung werden keine persönlichen Informationen an ABBYY weitergeleitet. Die Aktivierung erfolgt völlig anonym. Es wird lediglich ein eindeutiger Parameter erstellt, der die Konfiguration Ihres Computers zum Zeitpunkt der Aktivierung darstellt. Der Parameter enthält weder persönliche Informationen noch Informationen über Software oder Daten, die sich auf Ihrem Computer befinden, oder Informationen zum Hersteller oder Modell Ihres Computers. Er identifiziert lediglich den Computer für Aktivierungszwecke. Zusammen mit dem Parameter werden der Name, die Seriennummer und die Versionsnummer Ihrer SOFTWARE-Kopie an ABBYY geschickt. Diese Informationen werden ausschließlich zur Wahl des richtigen Inhalts einer Meldung genutzt, mit der das Ergebnis der Aktivierung bestätigt wird. Die Verwendung dieser Informationen für andere Zwecke ist ausgeschlossen.

8.2. Sofern mit ABBYY nicht in einem zusätzlichen Vertrag andere Vereinbarungen getroffen wurden, sind in diesem Endbenutzer-Lizenzvertrag alle Bedingungen und Einschränkungen angeführt, denen die Nutzung der SOFTWARE unterliegt.

8.3. Wenn die SOFTWARE die Beschriftung "Nicht für den Weiterverkauf bestimmt" oder eine ähnlich lautende Beschriftung trägt, dürfen Sie sie ungeachtet anderer Abschnitte dieses Endbenutzer-Lizenzvertrags lediglich zu Demonstrations- oder Testzwecken nutzen und sind nicht berechtigt, die SOFTWARE und/oder die durch die Verwendung der SOFTWARE erzielten Ergebnisse weiterzuverkaufen oder anderweitig gegen Entgelt weiterzugeben.

8.4. Sie dürfen keine der unten aufgeführten Vorgänge durchführen und auch Dritten nicht ermöglichen, diese durchzuführen:

8.4.1. Sie dürfen die SOFTWARE (Anwendungen, Datenbanken und alle Komponenten der SOFTWARE) nicht zurückentwickeln oder dekompilieren (den Quellcode des Objektcodes ermitteln) bzw. nur so weit, wie dies im ausdrücklich durch geltendes Recht abgedeckten Rahmen gestattet ist. Wenn anwendbare Gesetze derlei Vorgehen erlauben, dürfen keine der auf diese Art gefundenen Daten an Dritte weitergegeben werden, soweit eine derartige Nicht-Weitergabe durch das Gesetz gestattet ist, und die Daten müssen umgehend an ABBYY weitergegeben werden. Alle solche Daten müssen als vertrauliche Daten und als Eigentum von ABBYY betrachtet werden.

8.4.2. Sie dürfen außer den in der SOFTWARE vorgesehenen und in der Dokumentation beschriebenen änderungen keine Veränderungen an der SOFTWARE sowie Anpassungen und übersetzungen der SOFTWARE vornehmen, einschließlich Veränderungen am Objektcode der Anwendungen und Datenbanken der SOFTWARE.

8.4.3. Sie sind nicht berechtigt, irgendwelche Rechte, die Ihnen durch diesen Endbenutzer-Lizenzvertrag gewährt wurden, oder andere Rechte im Zusammenhang mit dieser SOFTWARE an Dritte zu vermieten, zu verleasen, zu unterlizenzieren, abzutreten oder zu übertragen oder diesen die Erlaubnis zu erteilen, die SOFTWARE über den in Artikel 3.6 beschriebenen Rahmen hinaus teilweise oder vollständig auf einen anderen Computer zu kopieren.

8.4.4. Sie dürfen keiner Person, die keine Nutzungsrechte an der SOFTWARE hat und die mit Ihnen in einem System mit mehreren Benutzern arbeitet, die Verwendung der SOFTWARE ermöglichen.

8.4.5. Sie sind nicht berechtigt, Hinweise auf Copyrights, Marken und Patente, die sich bei Lieferung auf der Software befinden, zu beseitigen oder unleserlich zu machen.

9. übereinstimmung mit den Lizenzen

9.1. Sie verpflichten sich, auf Anfrage von ABBYY oder eines autorisierten ABBYY-Vertreters innerhalb von dreißig (30) Tagen uneingeschränkt zu bestätigen, dass Sie die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags einhalten.

10. Supportleistungen

10.1. Sofern zwischen Ihnen und ABBYY bzw. Ihnen und dem ABBYY-Lieferanten nicht anderweitig vereinbart, bietet Ihnen ABBYY oder sein Lieferant Support im Rahmen der Bestimmungen im Anhang dieses Endbenutzer-Lizenzvertrags an.

11. SOFTWARE für Testzwecke

11.1 Wenn die SOFTWARE eine der Bezeichnungen "Try&Buy", "Trial" oder "Demo" trägt, gilt dieser Artikel so lange, bis Sie eine Lizenz für die im Handel erhältliche Vollversion der SOFTWARE erwerben. Sie erkennen an, dass der Funktionsumfang der SOFTWARE eingeschränkt ist und/oder dass die SOFTWARE nur für eine begrenzte Zeit genutzt werden kann. Die SOFTWARE wird "wie besehen" und lediglich als Demomodell lizenziert. Versionen der SOFTWARE mit zeitlicher Begrenzung werden nach Ablauf einer festgelegten Frist deaktiviert. Diese Frist ist in der SOFTWARE selbst angegeben. Zu diesem Ablaufdatum erlischt die hierin gewährte Lizenz, sofern sie nicht im Zuge Ihres Erwerbs einer Vollversion der SOFTWARE durch ABBYY verlängert wird.

12. Dauer und Beendigung des Vertrags

12.1. Sofern zwischen Ihnen und ABBYY bzw. Ihnen und dem ABBYY-Lieferanten keine anderen Vereinbarungen getroffen wurden, ist dieser Endbenutzer-Lizenzvertrag bis zu seiner Kündigung in Kraft. Sie können diesen Endbenutzer-Lizenzvertrag beenden, indem Sie die SOFTWARE und die beiliegende Dokumentation sowie alle entsprechenden Kopien vernichten. Ungeachtet anderer Rechte kann ABBYY diesen Endbenutzer-Lizenzvertrag kündigen, wenn Sie gegen seine Bestimmungen verstoßen. In diesem Fall sind Sie verpflichtet, alle Kopien der SOFTWARE und sämtliche SOFTWARE-Komponenten zu vernichten. Eine derartige Vertragskündigung entbindet Sie nicht von der Pflicht, die SOFTWARE und/oder erbrachte Supportleistungen zu bezahlen.

12.2. Die Bestimmungen 3.3–3.5, 3.8, 3.9, 4.7, 7, 8, 11, 13.2–13.4, 14–21, 23 und 24 bleiben auch nach Beendigung dieses Endbenutzer-Lizenzvertrags in Kraft, was Sie aber in keiner Weise dazu berechtigt, die SOFTWARE nach Beendigung dieses Vertrags weiterhin zu benutzen.

13. Eingeschränkte Garantie

13.1 ABBYY garantiert, dass die Datenträger, auf denen die SOFTWARE geliefert wird, bei sachgemäßer Behandlung im von der Gesetzgebung des Landes, in dem Sie die SOFTWARE erworben haben, festgesetzten Mindestzeitraum, gerechnet ab dem Kaufdatum, frei von Material- und Verarbeitungsfehlern sind.

13.2 Die SOFTWARE sowie alle Updates, Upgrades und Supportleistungen werden Ihnen wie besehen und ohne Garantien jeglicher Art geliefert. ABBYY und seine Lieferanten übernehmen keinerlei Gewähr für die durch die Nutzung der SOFTWARE erzielte Leistung.
Mit Ausnahme von Garantien, Bedingungen, Absprachen oder Bestimmungen, die durch das für Sie gültige Recht Ihres Landes nicht ausgeschlossen oder eingeschränkt werden können, gewähren ABBYY und seine Lieferanten keine Garantien, Bedingungen, Absprachen oder Bestimmungen (ausdrückliche oder stillschweigende, unabhängig davon, ob auf gesetzlichen Bestimmungen, bürgerlichem Recht, Gewohnheitsrecht oder anderen Bestimmungen basierend) für jedwede Sachlage, einschließlich und ohne Einschränkung der Nichtverletzung von Rechten Dritter, Marktgängigkeit, Eingliederung, ausreichender Qualität oder Eignung für einen bestimmten Zweck, oder dafür, dass die SOFTWARE frei von Fehlern ist und Ihren Anforderungen genügt, oder dass die SOFTWARE ordnungsgemäß funktioniert, wenn sie gleichzeitig mit anderer Software oder Hardware verwendet wird. Sämtliche Risiken bezüglich der Qualität und Leistung der SOFTWARE liegen bei Ihnen.

13.3 ABBYY übernimmt keine Garantien für Softwareprodukte Dritter, die mit der SOFTWARE geliefert werden können.

13.4. Eingeschränkte Garantie für Benutzer mit Wohnsitz in Deutschland und österreich
Wenn Sie Ihre Kopie der SOFTWARE in Deutschland oder österreich erworben haben und wenn sich Ihr Wohnsitz überwiegend in einem der beiden Länder befindet, dann garantieren ABBYY und seine Lieferanten in übereinstimmung mit der deutschen Rechtsprechung, dass die SOFTWARE für den Zeitraum der beschränkten Garantie ab Erhalt der SOFTWARE-Kopie die in ihrer Dokumentation beschriebenen Funktionen (die "vereinbarten Funktionen") aufweist, wenn sie auf der empfohlenen Hardwarekonfiguration betrieben wird. Im Sinne dieses Artikels bedeutet "Zeitraum der beschränkten Garantie" ein (1) Jahr, wenn Sie ein kommerzieller Benutzer oder eine juristische Person sind, und zwei (2) Jahre, wenn Sie kein kommerzieller Benutzer sind. Geringfügige Abweichungen von den vereinbarten Funktionen dürfen nicht in Betracht gezogen werden und begründen keinerlei Gewährleistungsansprüche. Diese eingeschränkte Garantie gilt nicht für die SOFTWARE, die Ihnen kostenlos zur Verfügung gestellt wird, wie zum Beispiel Updates, vorab veröffentlichte Versionen, "Testversionen", Produktwerbeexemplare, SOFTWARE-Kopien mit der Beschriftung "Nicht für den Weiterverkauf bestimmt" oder für die SOFTWARE, die von Ihnen so verändert wurde, dass dadurch ein Fehler entstand. Um die Garantie im eingeschränkten Garantiezeitraum in Anspruch zu nehmen, müssen Sie die SOFTWARE zusammen mit dem Zahlungsbeleg auf Kosten von ABBYY an Ihren Händler zurückschicken. Wenn die Funktionen der SOFTWARE wesentlich von den vereinbarten Funktionen abweichen, ist ABBYY dazu berechtigt (durch Neuerbringung der Leistung und nach freiem Ermessen), die SOFTWARE zu reparieren oder zu ersetzen. Wenn dies erfolglos bleibt, haben Sie Anrecht auf eine Minderung des Warenpreises (Preisnachlass) oder auf die Aufhebung des Verkaufsvertrags (Rücktritt). Weitere Informationen zur Garantie erhalten Sie vom ABBYY Customer Support in Deutschland: ABBYY Europe GmbH, Elsenheimerstrabe 49, 80687 München, Telefon: +49 (0)89 51 11 590, Fax: +49 (0)89 51 11 5959.

14. Beschränkung der Haftung

14.1 In keinem Fall übernehmen ABBYY oder seine Lieferanten Ihnen gegenüber die Haftung für jedwede Schäden, Betriebsunterbrechungen, Datenverluste aller Art (geschäftlicher oder anderer), Ansprüche oder irgendwelche Kosten oder für indirekte, zufällige Schäden oder für jedweden entgangenen Gewinn oder entgangene Einsparungen, die durch und/oder in Zusammenhang mit der Nutzung der SOFTWARE entstehen, oder für Schäden, die durch mögliche Fehler oder Druckfehler in der SOFTWARE entstehen, oder für jeden Anspruch durch Dritte. Dies gilt auch, wenn ein Vertreter von ABBYY auf die Möglichkeit solcher Verluste, Schäden, Ansprüche oder Kosten hingewiesen wurde. Die oben genannten Einschränkungen und Ausschlüsse gelten je nach den Bestimmungen des geltenden Rechts in Ihrem Land. Die alleinige und gesamte Haftung von ABBYY und seinen Lieferanten nach oder in Zusammenhang mit diesem Endbenutzer-Lizenzvertrag beschränkt sich, falls gegeben, auf die Höhe des ursprünglich für die SOFTWARE bezahlten Kaufpreises. Keine der Bestimmungen dieses Endbenutzer-Lizenzvertrags beschränkt ABBYYs Haftung Ihnen gegenüber im Todesfall oder bei Verletzung von Gesundheit und Leben infolge von Fahrlässigkeit durch ABBYY oder von Täuschungsdelikten (Betrug). ABBYY agiert im Namen seiner Lieferanten ausschießlich mit dem Ziel, die im Rahmen dieses Endbenutzer-Lizenzvertrags eingeräumten Verpflichtungen, Garantien und Haftungen auszuschließen und/oder zu beschränken. Weitere Informationen finden Sie unter den rechtsspezifischen Informationen, falls gegeben, in Artikel 21 dieses Endbenutzer-Lizenzvertrags. Falls Sie hierzu Fragen haben, wenden Sie sich an die Supportabteilung von ABBYY.

14.2. Haftungsbeschränkung für Benutzer mit Wohnsitz in Deutschland oder österreich
Wenn Sie Ihre Kopie der SOFTWARE in Deutschland oder österreich erworben haben und wenn sich Ihr Wohnsitz überwiegend in einem der beiden Länder befindet, dann gilt Folgendes:

14.2.1. Gemäß den Bestimmungen in Artikel 14.2.2 ist die gesetzlich festgelegte Haftung von ABBYY und seinen Lieferanten für Schäden folgendermaßen eingeschränkt: (i) ABBYY ist nur für eine Schadenshöhe haftbar, die zum Zeitpunkt des Verkaufsvertragsabschlusses unter normalen Umständen absehbar ist, und in Bezug auf Schäden, die durch geringfügige Verletzung einer materialbedingten Vertragspflicht entstehen, und (ii) ABBYY ist nicht für Schäden haftbar, die durch geringfügige Verletzung einer nicht materialbedingten Vertragspflicht entstehen.

14.2.2. Die Haftungsbeschränkung gemäß 14.2.1 ist nicht anwendbar bei jeglicher verbindlicher, gesetzlich festgelegter Haftung, insbesondere bei Haftung nach dem deutschen Produkthaftungsgesetz, Haftung für die übernahme einer besonderen Garantie oder Haftung für schuldhaft verursachte Personenschäden.

14.2.3. Sie sind verpflichtet, alle zumutbaren Maßnahmen zu ergreifen, um Schäden zu vermeiden und gering zu halten, indem Sie insbesondere Sicherungskopien der SOFTWARE und Ihrer Computerdaten, die den Bestimmungen dieses Endbenutzer-Lizenzvertrags unterliegen, erstellen.

15. Eingebettete Schriftarten

15.1. Schriftprogramme unterliegen dem Urheberrecht, und der Eigentümer eines Schriftprogramms kann Bedingungen zu dessen Benutzung auferlegen. Eine dieser Bedingungen kann sein, dass Sie eine lizenzierte Kopie des Schriftprogramms benötigen, damit die Schriftart in eine PDF-Datei eingebettet werden kann. In keinem Fall kann ABBYY für Schäden, die aus oder in Zusammenhang mit Ihrer Nutzung eingebetteter Schriftarten entstehen, haftbar gemacht werden.

16. Adobe® PDF Library

16.1. "Adobe-Software" bezieht sich auf Adobe® PDF Library für Windows 2000, XP und dazugehörige Dokumentationen sowie jegliche Upgrades, modifizierte Versionen, Updates, Ergänzungen und Kopien der Software. Die SOFTWARE verwendet Adobe-Software für die Konvertierung von PDF-Dateien in Bilddateien.

16.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet ein nicht exklusives Recht zur Nutzung der in die SOFTWARE integrierten Adobe-Software zu den Bedingungen des Endbenutzer-Lizenzvertrags. Die Erstellung einer Sicherungskopie der in die SOFTWARE integrierten Adobe-Software ist erlaubt, sofern die Sicherungskopie auf keinem anderen Computer installiert oder benutzt wird.

16.3. Urheberrechte. Die in die SOFTWARE integrierte Adobe-Software ist Eigentum von Adobe und seiner Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von Adobe und seiner Lieferanten. Darüber hinaus ist die Adobe-Software durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Das Kopieren der in die SOFTWARE integrierten Adobe-Software ist untersagt, es sei denn, es wurde in diesem Endbenutzer-Lizenzvertrag eine Ausnahme vorgesehen. Kopien, deren Anfertigung nach Maßgabe dieses Endbenutzer-Lizenzvertrags erlaubt sind, müssen exakt dieselben Angaben zu Urheber- und anderen Eigentumsrechten enthalten, wie sie in oder auf der SOFTWARE erscheinen. Sie nehmen zur Kenntnis, dass es Ihnen nicht gestattet ist, den Quellcode der in die SOFTWARE integrierten Adobe-Software zu modifizieren, anzupassen, zurückzuentwickeln (reverse engineering), zu dekompilieren, zu deassemblieren oder anderweitig zu versuchen, den Quellcode der in die SOFTWARE integrierten Adobe-Software zu erschließen. Mit Ausnahme des Obengesagten gewährt Ihnen dieser Endbenutzer-Lizenzvertrag keinerlei geistige Eigentumsrechte an der Adobe-Software.

16.4. Lizenzen für Schriftarten. Wenn die SOFTWARE oder die in die SOFTWARE integrierte Adobe-Software Schriftarten-Software enthält, sind Sie grundsätzlich dazu berechtigt, diese Schriftarten-Software oder Typen dieser Schriftarten-Software in Ihre elektronischen Dokumente einzubetten, sofern dies vom Inhaber des Urheberrechts oder vom Händler genehmigt wurde. Die Schriftarten in diesem Paket können sowohl Adobe-eigene als auch andere Schriftarten enthalten. Adobe-eigene Schriftarten dürfen vollständig eingebettet werden.

16.5. Garantie. ABBYY üBERNIMMT KEINERLEI GEWäHR FüR DIE DURCH NUTZUNG DER IN DIE SOFTWARE INTEGRIERTEN ADOBE-SOFTWARE ERZIELTE LEISTUNG.

16.6. Export der Software. Sie nehmen zur Kenntnis, dass die in die SOFTWARE integrierte Adobe-Software in kein anderes Land geliefert, übertragen oder exportiert und in keiner durch die Exportbestimmungen der Vereinigten Staaten (Export Administration Act) oder andere Exportgesetze, -beschränkungen oder -regulierungen (zusammengefasst "Exportgesetze") untersagten Art und Weise benutzt werden darf. Falls darüber hinaus die in die SOFTWARE integrierte Adobe-Software einer Exportkontrolle unterliegt, bestätigen und gewährleisten Sie, dass Sie weder Staatsbürger noch anderweitig wohnhaft in einem Land sind, das Gegenstand eines US-Embargos ist, und dass Sie auch auf keine andere Weise durch die Exportgesetze vom Empfang der in die SOFTWARE integrierten Adobe-Software ausgeschlossen sind. Alle Benutzerrechte der in die Adobe-Software integrierten SOFTWARE werden unter der Bedingung gewährleistet, dass sie bei Nicht-Einhaltung der Bedingungen dieses Endbenutzer-Lizenzvertrags hinfällig werden.

16.7. Marken. Adobe und Adobe PDF Library sind entweder eingetragene Marken oder Marken der Adobe Systems Incorporated in den Vereinigten Staaten und/oder anderen Ländern.

17. Microsoft XML Core Services

17.1. Die Software verwendet Microsoft XML Core Services (MSXML) für die Analyse und Verarbeitung von XML-Dokumenten.

17.2. Identifizierte Software. Mit dem Erwerb Ihrer Lizenz an der SOFTWARE verpflichten Sie sich, (a) gekennzeichnete Software nicht in MSXML oder daraus abgeleitete Bearbeitungen einzubinden bzw. damit zu kombinieren; (b) gekennzeichnete Software nicht im Zusammenhang mit MSXML weiterzugeben; und (c) gekennzeichnete Software nicht für die Entwicklung von MSXML-Ableitungen zu verwenden. Der Begriff "Gekennzeichnete Software" bezieht sich auf Software, deren Lizenzierung an Bedingungen geknüpft ist, die direkt oder indirekt zur Folge haben, dass (i) Microsoft tatsächlich oder angeblich Verpflichtungen in Bezug auf MSXML oder daraus abgeleitete Bearbeitungen entstehen oder (ii) Dritten tatsächlich oder angeblich Rechte oder Immunitäten zustehen, die die Urheberrechte bzw. das geistige Eigentum von Microsoft an MSXML oder daraus abgeleitete Bearbeitungen berühren. Gekennzeichnete Software umfasst ohne Einschränkung jede Software, für deren Nutzung, änderung und/oder Verteilung als Bedingung vorausgesetzt wird, dass andere Software, die in dieser Software integriert, aus ihr abgeleitet oder mit ihr vertrieben wird, (a) als Quellcode weitergegeben werden muss, (b) zum Zwecke der Erstellung von Ableitungen lizenziert sein muss oder (c) für die kostenlose Weitergabe geeignet sein muss.

18. PixTools® Scan-Laufzeitbibliotheken und ISIS®-Treiber

18.1. "Captiva-Software" bezieht sich auf Scan-Laufzeitbibliotheken sowie Level 1-, Level 2- und Level 3-ISIS-Treiber. Die SOFTWARE verwendet die Captiva-Software für die Kommunikation zwischen Scanner und SOFTWARE über die ISIS-Schnittstelle.

18.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet ein nicht exklusives Recht zur Nutzung der in die SOFTWARE integrierten Captiva-Software zu den Bedingungen des Endbenutzer-Lizenzvertrags.

18.3. Urheberrechte. Die in die SOFTWARE integrierte Captiva-Software ist Eigentum von Captiva und seiner Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von Captiva und seiner Lieferanten. Darüber hinaus ist die Captiva-Software durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Das Kopieren der in die SOFTWARE integrierten Captiva-Software ist untersagt. Sie nehmen zur Kenntnis, dass es Ihnen nicht gestattet ist, den Quellcode der in die SOFTWARE integrierten Captiva-Software zu modifizieren, anzupassen, zurückzuentwickeln (reverse engineering), zu dekompilieren, zu deassemblieren oder anderweitig zu versuchen, den Quellcode der in die SOFTWARE integrierten Captiva-Software zu erschließen. Mit Ausnahme des Obengesagten gewährt Ihnen dieser Endbenutzer-Lizenzvertrag keinerlei geistige Eigentumsrechte an der Captiva-Software.

18.4. Garantie.
ABBYY üBERNIMMT KEINERLEI GEWäHR FüR DIE DURCH NUTZUNG DER IN DIE SOFTWARE INTEGRIERTEN CAPTIVA-SOFTWARE ERZIELTE LEISTUNG.
CAPTIVA ODER SEINE LIEFERANTEN SIND IHNEN GEGENüBER UNTER KEINEN UMSTäNDEN HAFTBAR FüR IRGENDWELCHE SPEZIELLEN, ZUFäLLIGEN ODER FOLGESCHäDEN, EINSCHLIESSLICH SCHäDEN AUS ENTGANGENEM GEWINN, ENTGANGENEN EINSPARUNGEN ODER ANSPRüCHEN DRITTER.
Einige Staaten und Rechtssysteme gestatten keinen Ausschluss der konkludenten Gewährleistung bzw. keine Einschränkungen des Geltungszeitraums von konkludenten Gewährleistungen, sodass die obige Einschränkung unter Umständen für Sie nicht zutrifft. Außerdem können Ihnen je nach Land oder Rechtsprechung möglicherweise weitere Rechte zustehen.

18.5. Marken.
ISIS und PixTools sind Marken oder eingetragene Marken der Captiva Software Corporation in den USA und/oder anderen Ländern.

19. LIZARDTECH SOFTWARE

19.1. „LIZARDTECH SOFTWARE“ bezieht sich auf das DjVu Decoder Software Development Kit von LIZARDTECH, einschließlich sämtlicher dazugehöriger Datenträger, gedruckter Materialien sowie Online- oder elektronischer Dokumentation. Sie haben die LIZARDTECH-SOFTWARE von LIZARDTECH, INC. als Bestandteil der von ABBYY lizenzierten SOFTWARE erworben. Die SOFTWARE von ABBYY verwendet die LIZARDTECH-SOFTWARE für die Konvertierung von DjVu-Dateien in Bilddateien.

19.2. Die LIZARDTECH-SOFTWARE ist durch Urheberrechte und internationale Abkommen sowie durch weitere Gesetze und Verträge zum Schutz geistigen Eigentums geschützt. Die LIZARDTECH-SOFTWARE wird Ihnen lediglich als Lizenz zur Verfügung gestellt. Sie wird nicht an Sie verkauft.

19.3. Lizenzgewährung. Mit dieser Lizenz erhalten Sie das persönliche, nicht weiter lizenzierbare, nicht übertragbare und nicht exklusive Recht, die LIZARDTECH-SOFTWARE, einschließlich der dazugehörigen Dokumentation als integrierten Bestandteil der SOFTWARE zu nutzen. Sie sind nicht berechtigt, die LIZARDTECH-SOFTWARE vollständig oder teilweise zu vermieten, zu verkaufen, zu verleasen oder anderweitig weiterzugeben.

19.4. AUSSCHLUSS DER GEWÄHRLEISTUNG FÜR DIE LIZARDTECH-SOFTWARE. Die LIZARDTECH-SOFTWARE wird Ihnen „wie besehen“ und ohne Mängelgewähr zur Verfügung gestellt. FOLGLICH LIEGT DAS GESAMTE RISIKO HINSICHTLICH QUALITÄT, LEISTUNGSFÄHIGKEIT, GENAUIGKEIT UND AUFWAND (EINSCHLIESSLICH DER VERMEIDUNG VON FAHRLÄSSIGKEIT) DIESES PROGRAMMS BEI IHNEN. FERNER ERHALTEN SIE KEINE GEWÄHRLEISTUNGSZUSAGEN FÜR DIE STÖRUNGSFREIE BENUTZUNG DER LIZARDTECH-SOFTWARE BZW. DIE EVENTUELLE VERLETZUNG VON RECHTEN DRITTER. FALLS IHNEN HINSICHTLICH DER SOFTWARE ODER DER LIZARDTECH-SOFTWARE GEWÄHRLEISTUNGSZUSAGEN GEMACHT WORDEN SIND, SO STAMMEN DIESE ZUSAGEN AUSDRÜCKLICH NICHT VON LIZARDTECH UND SIND INSOFERN FÜR LIZARDTECH NICHT VERBINDLICH. HAFTUNGSBESCHRÄNKUNG. SOFERN ES NICHT AUSDRÜCKLICH DURCH GELTENDES RECHT UNTERSAGT IST, ÜBERNIMMT LIZARDTECH KEINERLEI HAFTUNG FÜR INDIREKTE, SPEZIELLE, ZUFÄLLIGE ODER FOLGESCHÄDEN, DIE AUFGRUND ODER IM ZUSAMMENHANG MIT DER VERWENDUNG ODER LEISTUNGSFÄHIGKEIT DER LIZARDTECH-SOFTWARE ENTSTEHEN. DIESE HAFTUNGSBESCHRÄNKUNG GILT AUCH DANN, WENN EIN RECHTSMITTEL SEINEN WESENTLICHEN ZWECK NICHT ERFÜLLT.

19.5. Beschränkungen hinsichtlich Reverse Engineering, Dekompilierung und Disassemblierung. Sofern es unbeschadet dieser Beschränkung nicht ausdrücklich durch geltendes Recht gestattet ist, sind Sie nicht berechtigt, die LIZARDTECH-SOFTWARE rückzuentwickeln (Reverse Engineering), zu dekompilieren oder zu disassemblieren.

19.6. Exportbestimmungen. Sie erkennen an, dass die LIZARDTECH-SOFTWARE mit all ihren Bestandteilen sowie jeglichen direkt daraus abgeleiteten Prozessen oder Dienstleistungen (einheitlich bezeichnet als „Beschränkungen unterliegende Komponenten“) aus den USA stammen. Sie verpflichten sich, alle für die Software geltenden internationalen und nationalen Gesetze einzuhalten, einschließlich der Exportrichtlinien der USA sowie aller von den USA oder anderen Regierungen ausgegebenen Beschränkungen für Endbenutzer, für den Endverbrauch sowie für Exportziele.

20. Benchmark-Tests

20.1. Sie sind nicht berechtigt, die Ergebnisse von Benchmark-Tests, die unter Verwendung der SOFTWARE durchgeführt werden, ohne vorherige schriftliche Genehmigung von ABBYY an Dritte weiterzugeben.

21. Export der Software

21.1. Die SOFTWARE darf nicht entgegen den Exportbestimmungen gemäß der Gesetzgebung des Landes, in dem die SOFTWARE gekauft oder auf andere Art erworben wurde, ausgeführt bzw. reexportiert werden. Außerdem erklären und versichern Sie, dass es Ihnen nach gültigem Recht nicht untersagt ist, die SOFTWARE zu erhalten.

22. Geltendes Recht

22.1. Wenn die SOFTWARE in den USA, in Kanada, Mexiko, Mittelamerika, Japan oder Taiwan erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte des Bundesstaates Kalifornien (USA). Hinsichtlich eventueller Streitfragen, die im Zusammenhang mit diesem Endbenutzer-Lizenzvertrag und/oder dieser SOFTWARE entstehen, stimmen Sie als Gerichtsbarkeit und Gerichtsstand den Bundesgerichten und/oder einzelstaatlichen Gerichten in Alameda oder Santa Clara (US-Bundesstaat Kalifornien) zu.

22.2. Wenn die SOFTWARE in österreich, Belgien, Dänemark, Finnland, Frankreich, Deutschland, Griechenland, Irland, Italien, Luxemburg, den Niederlanden, Portugal, Spanien, Schweden, Großbritannien oder einem anderen Mitgliedsland der Europäischen Union, das nicht in Artikel 21.3 oder 21.4 dieses Endbenutzer-Lizenzvertrags genannt wird, oder in der Schweiz, Norwegen, Island oder Liechtenstein erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte von München, Deutschland. Die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrags liegt bei den zuständigen Gerichten in München (Bundesrepublik Deutschland).

22.3. Wenn die SOFTWARE in Russland, Weißrussland, Kasachstan oder irgendeinem anderen Land der GUS, mit Ausnahme der Ukraine und Moldawien, erworben wurde, oder wenn die SOFTWARE in Lettland, Litauen oder Estland erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte der Russischen Föderation.

22.4 Wenn die SOFTWARE in Albanien, Bosnien-Herzegowina, Bulgarien, Kroatien, Zypern, der Tschechischen Republik, Ungarn, Israel, Mazedonien, Malta, Polen, Rumänien, der Slowakei, Slowenien, der Türkei, Serbien, Montenegro, der Ukraine oder Moldawien erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte der Ukraine.

22.5. Falls Artikel 21.3. dieses Endbenutzer-Lizenzvertrags zur Anwendung kommt und Sie eine juristische Person oder ein Privatunternehmer sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrags beim Schiedsgericht in Moskau (Russische Föderation). Falls Artikel 21.3 dieses Endbenutzer-Lizenzvertrags zur Anwendung kommt und Sie eine Privatperson sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrags beim Kreisgericht Lublinsky in Moskau (Russische Föderation).

22.6. In den in den Artikeln 21.1-21.4 beschriebenen Fällen unterliegt dieser Endbenutzer-Lizenzvertrag nicht den Vorschriften des internationalen Privatrechts der einzelnen Staaten oder dem übereinkommen der Vereinten Nationen über Verträge über den internationalen Warenkauf, deren Anwendung ausdrücklich ausgeschlossen wird.

22.7. Wenn die SOFTWARE in einem anderen als den in den Artikeln 21.1-21.4 aufgeführten Ländern erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte des Landes, in dem Sie die Software gekauft haben.

23. Verschiedenes

23.1. Wenn Sie die vorliegende Kopie der SOFTWARE als Erweiterung der aktuellen Version der SOFTWARE oder als umfangreicheres Versions-Upgrade zur SOFTWARE erhalten haben, erklären Sie mit der Installation dieser Kopie der SOFTWARE Ihren freiwilligen Verzicht auf alle Rechte im Zusammenhang mit jeglichen Vorgängerversionen der SOFTWARE, einschließlich der Nutzungsrechte für die aktuelle SOFTWARE. Sie erklären sich damit einverstanden, dass ABBYY oder seine Lieferanten mit Verfügbarkeit dieser Version der SOFTWARE von allen Verpflichtungen zur Unterstützung der vorherigen Version der SOFTWARE entbunden ist (sind).

23.2. Wenn Sie die SOFTWARE über das Internet erworben haben (einschließlich "Nicht für den Weiterverkauf bestimmter" und/oder "Upgrade"-Versionen), hat ABBYY nicht die Verpflichtung, Ihnen irgendwelches gedruckte Material einschließlich des Benutzerhandbuchs zuzustellen.

24. Nutzung durch Regierungsstellen

24.1. Wird die SOFTWARE durch die Regierung der USA oder eine Regierungsbehörde der USA genutzt, gelten die folgenden zusätzlichen Bestimmungen: (1) Restricted Computer Software, wie im Abschnitt Rights in Data-General der Federal Acquisition Regulations 52.227-14 definiert; und (2) jegliche Verwendung, Vervielfältigung oder Offenlegung durch die US-Regierung unterliegt den in Unterabsatz (c)(1)(ii) des Abschnitts Rights in Technical Data and Computer Software von DFARS 252.227-7013 festgelegten Beschränkungen.

25. Allgemeine Bestimmungen

25.1. Sollte sich ein Teil dieses Endbenutzer-Lizenzvertrags als nichtig und nicht einklagbar erweisen, berührt dies in keiner Weise die übrigen Bestimmungen des Vertrags, welche weiterhin Geltung behalten und einklagbar sind. Dieser Endbenutzer-Lizenzvertrag beeinträchtigt in keiner Weise die gesetzlich festgelegten Rechte des Verbrauchers.

Anhang A

Servicevertrag

Sofern keine anderslautende Vereinbarung mit ABBYY getroffen wurde, ist der vorliegende Anhang A integraler Bestandteil des Endbenutzer-Lizenzvertrags.

1. Definitionen

1.1. Update bezieht sich auf Erweiterungen der aktuellen Version der SOFTWARE.

1.2. Upgrade bezieht sich auf das nächste SOFTWARE-Release, das die aktuelle, von Ihnen laut Endbenutzer-Lizenzvertrag erworbene Hauptversion ersetzt (Beispiel 2.x als Ersatz für 1.x).

1.3. Fehler bezieht sich auf ein Problem, das zur Folge hat, dass die SOFTWARE nicht entsprechend den in der Dokumentation aufgelisteten Spezifikationen funktioniert. Dabei wird zwischen den folgenden drei Fehlertypen unterschieden:

1.3.1. Als Fehler der Priorität 1 gelten Problemsituationen, in denen Ihnen keine Lösung angeboten wird und die Produktion an Ihrem Standort nicht fortgesetzt werden kann. Dazu zählen Fehler mit folgenden Meldungen: "Interner Programmfehler", "Zu wenig Speicherplatz", "Zugriffsverletzung", "Allgemeiner Schutzfehler" und "Division durch null".

1.3.2. Als Fehler der Priorität 2 gelten Probleme, für die eine Lösung verfügbar ist.

1.3.3. Als Fehler der Priorität 3 gelten geringfügige Probleme, die den laufenden Betrieb an Ihrem Standort nicht beeinflussen.

1.4. Supportleistungen sind Serviceleistungen, die ABBYY oder seine Lieferanten im Zusammenhang mit den von Ihnen gemeldeten Fehlern erbringen.

1.5. Upgrade-Garantie bezeichnet den Teil des Servicepakets, der Ihnen das Recht auf den Erhalt von Upgrades einräumt.

2. Service

2.1. Der Support kann Updates, die "Upgrade-Garantie" und Supportleistungen oder eine beliebige Kombination daraus umfassen. Sie sind verpflichtet, für die ersten zwölf (12) Monate nach Versand bzw. Lieferung der SOFTWARE einen Supportvertrag abzuschließen. Eine Verlängerung des Supportzeitraums muss bei ABBYY bzw. seinen Lieferanten beantragt werden. ABBYY behält sich das Recht vor, den Inhalt und die Form des Supportvertrags von Zeit zu Zeit nach eigenem Ermessen zu ändern. Zusätzlicher Softwarecode, der Ihnen im Rahmen des Servicevertrags zur Verfügung gestellt wird, gilt als Bestandteil der SOFTWARE und unterliegt den Bedingungen und Bestimmungen des Endbenutzer-Lizenzvertrags.

3. Updates und Upgrade-Garantie

3.1. Upgrades und Updates werden auf einer CD-ROM und/oder in elektronischem Format (über FTP) bereitgestellt. Eventuell anfallende Versandkosten sind von Ihnen zu tragen.

3.2. Wenn Sie im Rahmen des Servicevertrags eine Update-Vereinbarung abgeschlossen haben, sind Sie berechtigt, von ABBYY oder seinen Lieferanten Updates zu erhalten. Die Software-Updates erhalten Sie von ABBYY oder seinen Lieferanten, sobald sie verfügbar sind.

3.3. Wenn Sie im Rahmen des Servicevertrags eine Upgrade-Garantie abgeschlossen haben, sind Sie berechtigt, von ABBYY oder seinen Lieferanten Upgrades zu erhalten. Die Software-Upgrades erhalten Sie von ABBYY oder seinen Lieferanten, sobald sie verfügbar sind.

3.4. Wenn Sie eine Anwendung entwickeln, die die SOFTWARE oder Teile dieser SOFTWARE enthält oder integraler Bestandteil der SOFTWARE ist, muss jedes neue Release dieser Anwendung das jeweils neueste Update der SOFTWARE enthalten, das Ihnen von ABBYY maximal drei (3) Monate vor der Veröffentlichung des Release bereitgestellt wurde (wenn Sie das neueste Update früher als drei (3) Monate vor einem solchen Release erhalten haben, ist dieses Update zu verwenden).

4. Supportleistungen

4.1. ABBYY bzw. seine Lieferanten bieten kostenlose Supportleistungen für alle Fehler der Priorität 1.

4.2. Wenn Sie im Rahmen des Servicevertrags Supportleistungen erworben haben, gewähren ABBYY bzw. seine Lieferanten bis zu acht (8) Serviceanfragen in Bezug auf Fehler der Prioritäten 2 und 3. Für alle weiteren Supportleistungen im Zusammenhang mit Fehlern der Prioritäten 2 und 3 entstehen Zusatzkosten.

4.3. ABBYY bzw. seine Lieferanten erbringen alle Supportleistungen in Bezug auf die SOFTWARE während der normalen Geschäftszeiten und stehen dafür per Telefon und E-Mail zur Verfügung.

4.4. ABBYY bzw. seine Lieferanten verpflichten sich zur Behebung aller ihnen zur Kenntnis gebrachten Fehler der Priorität 1 und werden zu diesem Zweck im wirtschaftlich vertretbaren Umfang auch außerhalb des normalen Release-Zyklus Emergency-Updates herausbringen. Im Normalfall werden Fehler der Prioritäten 2 und 3 im Zuge des nächstfolgenden Release behoben. Emergency-Updates werden ausschließlich für die aktuelle Version der SOFTWARE und mit dem Ziel der Behebung von Fehlern der Priorität 1 herausgegeben.

4.5. Wenn Sie ABBYY oder seinen Lieferanten Fehler zur Kenntnis bringen, verpflichten Sie sich gleichzeitig zur Offenlegung aller Daten, die für die Fehlersuche und die Behebung des Fehlers erforderlich sind. Dazu gehören eine Beschreibung des Problems, Angaben zur Plattform und zum Betriebssystem, auf dem das Problem aufgetreten ist, eine Kopie des Dokuments, das den zu untersuchenden Fehler verursacht hat, eine Kopie der bei Auftreten des Fehlers verwendeten Formatdatei sowie alle Fehlermeldungen, die auf dem Computer im Zusammenhang mit dem Fehler ausgegeben wurden. ABBYY bzw. seine Lieferanten behalten sich das Recht vor, die genannten Informationen für Geschäftszwecke einschließlich, aber nicht beschränkt auf Produktsupport und -entwicklung zu verwenden. ABBYY bzw. seine Lieferanten werden diese Informationen in keiner Form nutzen, durch die Sie identifiziert werden könnten.


Basic field properties

You can configure basic field properties on the Allgemein tab.

On this tab the field type is displayed as an icon to the right of the name.

  • Name – field name. The name is assigned automatically when the field is created and corresponds to the explanatory text closest to the field. When editing the properties, you can change the name assigned by default. See also How to change the field name.
  • Beschriftung: Der Name des Felds, der im Datenformular angezeigt wird
  • Feldwert exportieren – this option must be enabled if you want to export the field value (enabled by default). You may need to disable this option if, for example, the value of this field is used to obtain the value of a calculated field (see Rule validation), and only the end result has to be exported.
  • In Datenformular anzeigen – this option must be enabled if the field should be visible in the data form (enabled by default).
  • Kann nicht leer sein – enable this option if you want to make it a required field.
  • Schreibgeschützt – enable this option if the field should be accessible only for viewing, i.e. the operator will not be able to modify its value. You can enable this option for fields whose values have to be calculated automatically using a rule, for example, for a field where you plan to save the sum or combine other fields (see Rule validation).
  • Indexfeld – enable this option if you expect to use this field to perform document indexing. When processing documents, you will be able to display the value of this field for each document, and sort and search documents based on the field value.
  • Kommentar – you can enter any comments.

Field properties


Glossar

A

ABBYY FlexiCapture

Eine Softwarelösung für die Erfassung von Daten aus unterschiedlichen Dokumenttypen – z. B. strukturierter (statischer Formulare), teilweise strukturierter (flexibler Formulare und Dokumente) und nicht strukturierter Dokumente – in einem Durchgang.

ABBYY FlexiLayout Studio

Ein Programm, mit dem Sie ein FlexiLayout der Dokumentstruktur erstellen können, das anschließend für die automatische Dokumenterkennung verwendet werden kann.

ABBYY FormDesigner

Mithilfe von ABBYY FormDesigner können Sie Layouts für maschinenlesbare Formulare entwerfen. Nach der Duplizierung und dem Ausfüllen können diese Formulare mit dem automatisierten Formulareingabesystem von ABBYY FlexiCapture verarbeitet werden. Das Entwerfen eines Formularlayouts ist ein für die weitere Dokumentverarbeitung wichtiger Schritt, da die Qualität des Layouts (seine Lesbarkeit für die Software) die Effizienz aller nachfolgenden Schritte (Scannen, Erkennen, überprüfen und Exportieren) wesentlich beeinflusst.

ADF

Englische Abkürzung für "Automatic Document Feeder" (automatische Dokumentzufuhr). Eine Vorrichtung zur automatischen Dokumentzufuhr, mit der Sie mehrere Dokumente scannen können, ohne zwischenzeitlich eingreifen zu müssen.

Administrator

Ein Benutzer von ABBYY FlexiCapture, der berechtigt ist, das Programm für die Dokumenterfassung zu konfigurieren. Die Konfiguration umfasst das Erstellen und Bearbeiten von Dokumentvorlagen sowie das Importieren von Profilen. Siehe Administrator- und Operatormodus.

Alphabet

Ein in der beschriebenen Sprache verwendeter Zeichensatz.

Anhang

Seiten, die keine Felder enthalten, aber in die Dokumentzusammenstellung einbezogen werden müssen. Aus diesen Seiten werden zwar keine Daten extrahiert, sie können aber als Bilder oder durchsuchbare PDF-Dateien gespeichert werden. Siehe Erstellen von Vorlagen für Dokumente mit Anhängen.

Anker

Ein statisches Element in Form eines schwarzen Quadrats, Rechtecks, Kreuzes oder einer Ecke, das für die Vorlagenzuordnung verwendet wird. Details…

Anker sind spezielle Elemente bei der Formularerstellung, auf deren Grundlage das System nach dem Scannen Zuordnungen trifft (Entfernen von Verzerrungen, Korrigieren linearer und nicht linearer Scanfehler, Berechnen der Position von Blöcken). Die zuverlässigsten Anker sind schwarze Quadrate, die i. d. R. in den Ecken eines Formulars platziert werden. Wenn das Bild keine speziellen Anker enthält, können für die Vorlagezuordnung andere statische Elemente verwendet werden: Trennlinien, also vertikale oder horizontale Linien wie Tabellenlinien, Rahmen usw., oder deutlich erkennbarer statischer Text wie Kopfzeile des Formulars, Feldsignaturen oder erklärender Text. Statische Elemente können für die Vorlagenzuordnung nur verwendet werden, wenn die Option Für Vorlagenzuordnung verwenden aktiviert ist.

Ankerbarcode

Statisches Element, das einen Barcode darstellt, der nicht für das Extrahieren von Daten vorgesehen ist. Ankerbarcodes können für die Zuordnung oder Identifizierung von Vorlagen verwendet werden.

Ankertext

Statisches Element, das Text auf einem leeren Formular darstellt, der nicht zum Extrahieren von Daten vorgesehen ist. Dabei kann es sich um erklärenden Text oder eine Kopfzeile handeln. Ankertexte können für die Zuordnung oder Identifizierung von Vorlagen verwendet werden.

Arbeitsstapel

Dokumentstapel für die Dateneingabe. Für die Verarbeitung von Arbeitsstapeln werden nur veröffentliche Dokumentvorlagen verwendet. Siehe Dokumentstapel.

Auflösung

Bildparameter. Die Auflösung wird in dpi (Dots Per Inch, Punkten pro Zoll) angegeben.

Auswahlfeld

Ein Vorlagenfeld, das ein Auswahlkästchen enthält.

Auswahlgruppenfeld

Ein Dokumentvorlagenfeld, das eine Gruppe von Auswahlfeldern enthält.

Auswahlkästchen

Ein maschinenlesbares Formularelement, das von der Person, die das Formular ausfüllt, mit einer Markierung (Häkchen, Kreuz, Punkt usw.) versehen werden soll.

B

Barcode

Ein maschinenlesbares Formularelement, das durch abwechselnde weiße und schwarze Streifen gleicher Länge dargestellt wird und der Kodierung digitaler Informationen dient. Barcodes können in einem Dokument für das Extrahieren von Informationen (Barcodefeld) oder das Zuordnen und Identifizieren einer Vorlage (Ankerbarcode) verwendet werden.

Barcodeerkennung

Konvertierung eines grafischen Barcodebilds in Zahlen oder Text.

Barcodefeld

Ein Vorlagenfeld, das einen für die Erkennung vorgesehenen Barcode enthält.

Benutzerdefinierter Datentyp

Ein vom Benutzer festgelegter Datentyp. Siehe Erstellen benutzerdefinierter Datentypen.

Bereich einer Dokumentvorlage

Eine Reihe von Seiten (oder eine einzelne Seite) und alle Felder auf diesen Seiten, die einen logisch zusammenhängenden Teil eines Dokuments bilden. Dokumentbereiche können mit einem statischen oder einem flexiblen Template beschrieben werden. Siehe Erstellen von Vorlagen für mehrseitige Dokumente.

Beschreibungsdatei

Eine Zusatzdatei, in der definiert ist, wie ein Stapel zusammengesetzt wird, wenn Bilder aus einem Hot Folder hinzugefügt werden. Ausführliche Informationen finden Sie unter Beschreibungsdatei.

Bild

  1. Ein elektronisches Abbild einer gescannten Seite eines Papierdokuments.
  2. Element eines maschinenlesbaren Formulars, das nicht in die Erkennung einbezogen wird, aber für den Export in Form eines Grafikelements (z. B. als Datei) vorgesehen ist.

Bildersetzung

Vorgang während der Bearbeitung einer Vorlage, bei dem ein Bild durch ein anderes ersetzt wird.

Bilddrehung

Vorgang, bei dem ein Bild um seinen Mittelpunkt gedreht wird.

Bildfeld

Ein Vorlagenfeld, das ein Bild enthält.

Bildimport

Vorgang, bei dem Bilder einem Verarbeitungsstapel hinzugefügt werden. Die Bilder können aus Dateien, von einem Scanner oder mit Importprofilen zum Import ausgewählt werden. Siehe Hinzufügen von Seitenbildern.

Bildstörungen entfernen

Das Entfernen von Störungen aus einem Bild. Diese Störungen können beim Scannen auftreten und sollten entfernt werden, um die Datenerkennung zu verbessern. Beim Entfernen von Störungen löscht die Software auch Punkte aus dem Hintergrund sowie Rahmenlinien aus Rasterformularen.

Buchstaben auf Kamm

Texttyp, bei dem der Text durch einen "Kamm" begrenzt ist. Anzeigen...

Buchstaben in Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei nicht voneinander getrennt. Anzeigen...

Buchstaben in separaten Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei voneinander getrennt. Anzeigen...

D

Datenerfassung in einem Durchgang

Automatisches Extrahieren von Daten aus analogen (gedruckten) und digitalen Dokumenten (gescannte Bilder).

Datentyp

Ein Feldattribut, das bekannte Einschränkungen für die möglichen Feldwerte beschreibt. Mit dem Datentyp wird während der Felderkennung die Anzahl der möglichen Erkennungsvarianten reduziert. Details…

Eines der wesentlichen Merkmale eines Felds ist der Datentyp ( z. B. Zahl, Datum, Text, Nachname, Vorname oder Adresse). Anhand des Datentyps wird die Gruppe von Wörtern definiert, die in diesem Feld vorkommen können.

Der Datentyp ist ein wichtiger Erkennungsparameter, der Einfluss auf die Erkennungsqualität hat. Durch einen korrekt angegebenen Datentyp können Sie die Anzahl der falsch erkannten Zeichen deutlich reduzieren.

Dokument

Eine Kombination aus mehreren Seitenbildern und den Daten, die aus den Seiten extrahiert wurden.

Dokumentdaten

Daten, die nach der Verarbeitung (Erkennung, überprüfung und Bearbeitung der Erkennungsergebnisse) der Seitenbilder eines Dokuments erfasst werden.

Dokumenterfassung in einem Durchgang

Die automatisierte Konvertierung von Papierdokumenten in ein elektronisches Format.

Dokumentfehler

Wenn sich bei der Dokumentverarbeitung herausstellt, dass die Dokumentdaten entweder der Dokumentstruktur und den angegebenen Einschränkungen für den Feldwert oder den Steuerregeln nicht entsprechen, werden alle falschen Zuordnungen in der Fehlerliste des Dokuments erfasst.

Dokumentstapel

Eine Kombination aus Dokumenten, die vom Benutzer zusammengestellt wurden. Normalerweise enthält ein Stapel Dokumente, die in einem Durchgang gescannt oder aus einem bestimmten Ordner importiert wurden. Siehe Dokumentstapel.

Dokumentvorlage

Mit einer Dokumentvorlage werden die Verfahren für das Erkennen und Verarbeiten eines bestimmten Dokumenttyps definiert. Sie enthält folgende Angaben:

  • Die Dokumentstruktur, also eine Beschreibung der zulässigen Seitenreihenfolge für ein Dokument dieses Typs. Die Dokumentstruktur definiert auch die Regel für die Dokumentzusammenstellung.
  • Vorlagen für Dokumentbereiche
  • Eine Liste der Regeln für Felddaten
  • Die Position von Feldern und ihrer Signaturen im Datenfenster (Datenformularansicht)
  • Exporteinstellungen für diesen Dokumenttyp
  • Verarbeitungseinstellungen für diesen Dokumenttyp

Dokumentvorlagenbereich

Komponente einer Dokumentvorlage. Der Dokumentvorlagenbereich entspricht einer oder mehreren Seiten, die einen logisch verknüpften Satz von Feldern enthalten. Die Felder innerhalb eines Bereichs können sich auch über mehrere Seiten erstrecken (z. B. mehrseitige Tabellen), sofern sich die Feldsätze der unterschiedlichen Bereiche nicht überschneiden.
Bereichsvorlagen können flexibel oder statisch sein.

dpi

Englische Abkürzung für "Dots per inch" (Punkte pro Zoll). Eine Maßeinheit für die Bildauflösung.

E

Einfacher Text

Eine Form der Textmarkierung, bei der der Text ohne Trennzeichen in einen Block eingefügt wird.

Erkennung

Vorgang, bei dem Bildelemente bestimmten Zeichen zugeordnet werden.

Erklärender Text

Ein maschinenlesbares Formularelement, das einen beschreibenden Text (Formularname, Feldnamen, Erläuterungen von Feldern usw.) enthält.

Export

Vorgang, bei dem verarbeitete Daten an ein externes Informationssystem oder in eine Datei übertragen werden.

F

Falsch erkanntes Zeichen

Status, der einem Zeichen bei der Erkennung automatisch zugeordnet wird, wenn es einem bestimmten Grad der Eindeutigkeit nicht entspricht.

Feld

Ein Dokumentelement, das zum Extrahieren von Daten vorgesehen ist. Felder können einfach (ohne interne Struktur) oder zusammengesetzt sein. Ein zusammengesetztes Feld ist z. B. ein Tabellenfeld, das sowohl als einzelne Zelle als auch als untergeordnetes Feld der Tabelle angesehen werden kann. Siehe Erstellen von Feldern einer Dokumentvorlage.

Feld für die manuelle Eingabe

Ein Vorlagenfeld mit nicht erkennbarem Text (z. B. Text mit verschwommenen Buchstaben), der über die Tastatur eingegeben werden muss.

Feld mit mehreren Bereichen

Ein Feld, das mehrere Bereiche im Bild umfasst. Diese Bereiche können voneinander entfernt und sogar auf verschiedenen Seiten positioniert werden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert. Felder mit mehreren Bereichen werden meist für Objekte verwendet, die sich über mehrere Seiten erstrecken (z. B. große Tabellen). Siehe Felder mit mehreren Bereichen.

Feld mit mehreren Instanzen

Ein Feld zur Beschreibung mehrerer Objekt desselben Typs (sich wiederholende Objekte). Im Grunde sind diese Objekte als dasselbe Feld anzusehen, da sie dieselben Eigenschaften besitzen. Felder mit mehreren Instanzen sind eine ideale Alternative zum Erstellen mehrerer identischer Felder. Der Export von Feldern mit mehreren Instanzen erfolgt in getrennte Dateien oder Datenbanktabellen. Siehe Felder mit mehreren Instanzen.

Feld ohne Bereich

Ein in einer Dokumentvorlage erkanntes Feld, das über keinen Bereich im Bild verfügt. Siehe Felder ohne Bereich.

Feldbereich

Ein in der Vorlage hervorgehobener Bildbereich, der für die Datenextraktion vorgesehen ist.

Feldüberprüfung

Ein überprüfungsmodus, bei dem die erkannten Zeichen im Kontext eines Felds zur überprüfung übermittelt werden. Details…

Im Feldüberprüfungsmodus werden nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds überprüft.

Grundsätzlich werden alle Felder an die Feldüberprüfung übermittelt, für die die Option Bei Feldüberprüfung einschließen aktiviert wurde. Es wird empfohlen, grundsätzlich jene Felder an die Feldüberprüfung zu übermitteln, deren Wertebereich bekannt ist oder einfach ermittelt werden kann. Beispiele für Felder dieser Art sind Länder- oder Städtenamen, da die Werte dieser Felder im Voraus bekannt sind.

Flexible Beschreibung

Eine formalisierte Beschreibung der Dokumentstruktur zur Verbesserung der Felderkennung. Die Erstellung erfolgt in ABBYY FlexiLayout Studio. Das Dateiformat lautet: *.afl. Siehe FlexiLayout.

Flexibles Dokument

Ein Dokument mit einer Reihe von Informationsfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Siehe Unterstützte Dokumenttypen in ABBYY FlexiCapture 8.0.

Flexibles Template

Vorlage eines Dokuments oder eines Bereichs, die für das Verarbeiten flexibler Dokumente vorgesehen ist. Die Erstellung erfolgt durch Anfügen eines FlexiLayouts. Die Felder in diesen Templates haben keine feste Position. Sie werden stattdessen mithilfe eines FlexiLayouts erkannt. Siehe Erstellen einer Vorlage zum Verarbeiten flexibler Dokumente.

FlexiLayout

Beschreibung der Struktur eines flexiblen Dokuments. Diese Beschreibung wird mit ABBYY FlexiLayout Studio erstellt und kann nach ABBYY FlexiCapture exportiert werden. FlexiLayouts stellen die Anweisungen für das Erkennen und Identifizieren von Feldern in einem flexiblen Formular bereit.

Formular

Dokument mit einer oder mehreren Seiten, das von einer Person handschriftlich oder mit einem Druckverfahren ausgefüllt werden soll.

Formular mit farbigem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem farbigen Hintergrund erscheinen, der beim Scannen entfernt wird.

Formular mit grauem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem grauen Hintergrund erscheinen, der beim Scannen entfernt wird.

Formularerfassung

Datenerfassung aus den Informationsfeldern von Formularen.

G

Gedruckter Text

Ein Texttyp für die Erkennung, der mit einem typografischen Gerät oder einem Laser- bzw. Ink-Jet-Drucker mit einer Mindestauflösung von 300 dpi gedruckt wurde.

Gruppe von Auswahlfeldern

Ein Element eines maschinenlesbaren Formulars, in dem mehrere nahe beieinander stehende Auswahlfelder zusammengefasst werden. In einer Gruppe von Auswahlfeldern können ein oder mehrere Auswahlfelder markiert werden.

Gruppenüberprüfung

Ein überprüfungsmodus, bei dem als gleich erkannte Zeichen in Gruppen zur überprüfung übermittelt werden. Details…

Grundsätzlich werden alle Felder an die Gruppenüberprüfung übertragen, für die die Option Bei Gruppenüberprüfung einschließen aktiviert wurde.

Im Allgemeinen empfiehlt es sich, Zeichen aus Zahlenfeldern sowie Auswahlfelder zur Gruppenüberprüfung zu übermitteln.

H

Handschrifttext

Ein Texttyp für die Erkennung, der einen handschriftlichen Text darstellt.

Helligkeit

Ein Schwellenwert für die Lichtempfindlichkeit, der angibt, ab welchem Wert der Scanner Halbtöne von Graustufen als Weiß erkennt.

Hot Folder

Ein Ordner auf der Festplatte des lokalen oder eines Remotecomputers, der zum Importieren von Bildern verwendet wird. Er wird meist für das regelmäßig wiederholte Laden von Bildern ohne Benutzerbeteiligung verwendet. Siehe Bildimportprofile.

I

ICR

Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Dieser Begriff bezieht sich auf Technologien oder Systeme für die Massenverarbeitung von Dokumenten, die mit handgeschriebenen Buchstaben und Ziffern ausgefüllt wurden.

Ignoriertes Zeichen

Ein Zeichen innerhalb von Wörtern (z. B. ein Aufzählungszeichen) oder ein weiches Trennzeichen (Tabulator usw.), das die Software nicht daran hindert, das Wort als erkennbaren Datentyp zu kennzeichnen. Details…

Diese Zeichen werden aus den Wörtern ausgeblendet, d. h., die Wörter werden ohne diese Zeichen einem bestimmten Datentyp zugeordnet.

Importprofil

Eine Kombination von Einstellungen, auf deren Grundlage Bilder einem Stapel hinzugefügt werden können. Zu den Einstellungen gehören die Bildquelle, Bildverarbeitungsoptionen und Bereinigungsoptionen für Hot Folder. Siehe Bildimportprofile.

Indexfeld

Ein Feld, mit dessen Wert Dokumente für die Sortierung und Suche indiziert werden. Siehe Indexfelder.

Invertiertes Bild

Ein Bild mit hellem Text auf dunklem Hintergrund.

K

Konstantschrift

Texttyp, bei dem sich die einzelnen Buchstaben in einem Rahmen derselben Höhe und Breite befinden, der dann beim Scannen entfernt wird.

Kontrast

Das Verhältnis zwischen der Helligkeit des dunkelsten und hellsten Bereichs eines Bilds.

Korrigiertes Auswahlfeld

Ein Auswahlfeld, das fälschlicherweise markiert und anschließend durchgestrichen wurde. Wenn für das Auswahlfeld die Option Korrekturen zulassen aktiviert wurde, erkennt die Software das durchgestrichene Auswahlfeld als nicht markiert.

Kreuz

Ein Anker in Form eines Kreuzes.

L

Lineares Schwarz-Weiß-Formular

Ein Formular, auf dem Informationsfelder durch Ränder aus einfachen Linien begrenzt sind, die beim Scannen nicht entfernt werden.

M

Maschinenlesbares Formular

Ein Formular, das speziell für die automatische Datenerfassung entworfen wurde. Es enthält Arbeitselemente (Anker, Barcodes, Linien usw.), die für die ordnungsgemäße Verarbeitung erforderlich sind.

Mehrseitiges Dokument

Ein Dokument, das mehrere Seiten umfasst.

N

Nicht strukturiertes Dokument

Ein Dokument mit Informationen, die ohne feste Struktur dargestellt werden. Zu diesen Dokumenten gehören z. B. Verträge, Briefe, Aufträge und Diagramme. Siehe Verarbeiten nicht strukturierter Dokumente.

O

Objekt zur Identifizierung

Ein statisches Element, das für die Auswahl einer Vorlage verwendet wird, wenn mehrere Vorlagen über identisch positionierte Anker verfügen. In den Eigenschaften solcher statischen Elemente muss dazu die Option Für Vorlagenzuordnung verwenden aktiviert sein.

OCR

Englische Abkürzung für "Optical Character Recognition". Optische Erkennung gedruckter Texte.

OMR

Englische Abkürzung für "Optical Mark Recognition". Optische Erkennung von Markierungen. Mithilfe dieser Technologie kann ABBYY FlexiCapture einfache Markierungen (Häkchen, Kreuze usw.) auf Formularen mit einer hohen Genauigkeit erkennen und gleichzeitig auch zunächst falsch ausgefüllte und später durchgestrichene Markierungen ermitteln.

Operator

Ein Benutzer von ABBYY FlexiCapture, der für die Dokumenterfassung zuständig ist, also das Hinzufügen von Bildern, das Durchführen der Erkennung und überprüfung und das Exportieren der erkannten Daten. Siehe Administrator- und Operatormodus.

Optische Erkennung von Markierungen (Optical Mark Recognition, OMR)

Ein Vorgang, bei dem eine Markierung in einem entsprechenden Feld auf dem Formular erkannt wird.

P

Projekt

In einem Projekt sind verschiedene Dokumentstapel gebündelt und die zur Verarbeitung erforderlichen Einstellungen (Dokumentvorlagen oder Importprofile) festgelegt. Siehe Erstellen eines Projekts.

Punktmatrixdrucker

Ein Texttyp für die Erkennung, der mit einem Punktmatrixdrucker gedruckten Text darstellt.

R

Rasterformular

Ein Formular, in dem Informationsfelder als weiße Rechtecke auf grauem Hintergrund dargestellt werden, der entweder Rasterlinien oder durch Rasterlinien getrennte Rechtecke enthält.

Rasterlinie

Eine Linie aus Punkten in einheitlichem Abstand.

Regelbasierte Validierung

Vorgang, bei dem erkannte Daten anhand vordefinierter Regeln automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regeln

Bedingungen für Datenfelder, die vom Programm automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regulärer Ausdruck

Beschreibung der Struktur eines Worts oder eines Eingabewerts mithilfe einer speziellen Sprache. Die Software ermöglicht nicht nur die Angabe der zulässigen Zeichen, sondern auch der Struktur des Feldinhalts. Sie können die Struktur beim Festlegen von Einschränkungen für ein Textfeld und beim Erstellen benutzerdefinierter Datentypen mit einem regulären Ausdruck beschreiben. Siehe Alphabet in regulären Ausdrücken.

S

Scannen

Vorgang, bei dem ein Papierformular mithilfe eines Scanners in ein elektronisches Bild umgewandelt wird.

Schlüsselfeld

Ein Feld, das die automatische überprüfung der Zusammenstellung von Seiten zu Dokumenten ermöglicht. Die Werte der Schlüsselfelder müssen auf allen Seiten des Dokuments gleich sein.

Schreibmaschine

Ein Texttyp für die Erkennung, der mit einer Schreibmaschine geschriebenen Text darstellt.

Schreibstil

Schreibweise, die für eine spezielle Gruppe kennzeichnend ist. Beispielsweise die amerikanische Schreibweise von Zahlen. Details…

Diese Option wird für das Konfigurieren des Schreibstils handschriftlicher Zeichen in Formularen verwendet. Die Auswahl eines Schreibstils richtet sich nach dem Ort, an dem die Dokumente verarbeitet werden (Russland, Deutschland, Tschechische Republik, USA usw.).

Schwarzes Quadrat

Ein Anker in Form eines schwarzen Quadrats.

Seite

Abbild einer Papierseite mit dem Ergebnis der Dokumentverarbeitung.

Seitenausrichtung

Position der Seite in Bezug auf die Standardausrichtung: von oben nach unten und von links nach rechts. Die Seitenausrichtung kann automatisch bei der Erkennung des Seitenbilds bestimmt werden. Sie können dazu in ABBYY FlexiCapture 8.0 die möglichen Ausrichtungen angeben.

Seitenlayout

Ein Schema mit den Positionen der Felder auf einem Bild.

Sprache (Gebietsschema)

Eine Feldeigenschaft, die die Schriftsprache und wichtige regionale Parameter (z. B. Datumsformat oder Adressenschreibweise) festlegt.

Statische Elemente

Nicht erkennbare Zeichen, die der Vorlagenzuordnung und -identifizierung dienen. Zu diesen Zeichen gehören: Anker, Ankertext, Trennlinien und Ankerbarcodes.

Statisches Formular

Ein Dokument mit statischen Informationsfeldern, deren Formatierung, Anzahl und Layout fest definiert sind und auch bei unterschiedlichen Dokumentinstanzen unveränderlich bleiben.

Statisches Template

Vorlage eines Dokuments oder eines Bereichs, die für das Verarbeiten statischer Formulare vorgesehen ist. Die Felder in einem statischen Template haben eine feste Position.

T

Tabelle

Daten, die in einem (nicht notwendigerweise sichtbaren) zweidimensionalen Raster angeordnet sind. Die Software verarbeitet Tabellen, die aus Spalten mit gleichen Datentypen und sich wiederholenden Zeilen bestehen.

Tabellenfeld

Ein Vorlagenfeld, das eine Tabelle enthält. Dabei handelt es sich um ein zusammengesetztes Feld, bei dem jede Tabellenspalte einen Satz von Feldern desselben Typs darstellt: Textfelder, Auswahlfelder, Barcodes oder Bilder.

Teststapel

Dokumentstapel, die für das Testen und Konfigurieren von Vorlagen vorgesehen sind. Für die Verarbeitung von Teststapeln werden lokale Kopien von Dokumentstapeln verwendet. Siehe Dokumentstapel.

Text im Rahmen

Texttyp, der anzeigt, wo der Text durch einen Rahmen begrenzt wird. Anzeigen...

Text im Rahmen mit Kamm

Texttyp, der anzeigt, wo Text durch einen Rahmen begrenzt wird, dessen unterer Rand wie ein Kamm geformt ist. Anzeigen...

Textausrichtung

Ausrichtung des Texts in einem Feld in Bezug auf die Seite.

Textbeispiel

Eine Datei mit Beispielen aller alphabetischen Zeichen.

Texterkennung (OCR, ICR)

Umwandlung eines grafischen Bilds in Text.

Textfeld

Element eines maschinenlesbaren Formulars, das beim Ausfüllen dieses Formulars der Eingabe von Text dient.

Textfeldmarkierung

Ein Grafikelement, das ein Textfeld begrenzt, z. B. Rahmen, Kamm oder Linie.

Textmarkierung

Das Layout eines Seitenbereichs, der für die Texteingabe vorgesehen ist. Beispiele für die Textformatierung finden Sie unter Eingabefeld.

Trennlinie

Element eines maschinenlesbaren Formulars, das durch eine vertikale oder horizontale Linie dargestellt wird.

U

überprüfung

Vorgang, bei dem erkannte Daten durch den Operator überprüft werden. Dabei werden die Ergebnisse mit dem Original des entsprechenden Dokumentbereichs verglichen. Bei ABBYY-Produkten wurden Technologien für die überprüfung implementiert, die bestimmte Eigenheiten von Benutzern (Routine, Können, Wahrnehmungsvermögen) berücksichtigen. Siehe überprüfen erkannter Daten.

Unerkennbarer Bereich

Ein Bildbereich, der von der Erkennung ausgeschlossen ist. Auf diese Weise können Sie einen Bereich mit erklärendem Text oder einem Bild ausschließen, der die Felderkennung erschweren würde. Siehe Ausschließen eines Bereichs von der Erkennung.

Unterstrichener Text

Art der Hervorhebung, bei der Zeichen unterstrichen sind. Anzeigen...

Unzulässiges Zeichen

Ein Zeichen, von dem Sie bestimmt wissen, dass es nicht in den zu erkennenden Daten enthalten sein wird. Details...

Die Angabe solcher Zeichen kann zu einer deutlich höheren Geschwindigkeit und Qualität bei der Erkennung führen. Wenn erkannter Text z. B. nur Großbuchstaben enthält, können Sie sämtliche Kleinbuchstaben als unzulässige Zeichen kennzeichnen.

V

Vorlagenidentifizierung

Vorgang, bei dem die passende Vorlage mithilfe von Objekten zur Identifizierung ausgewählt wird.

Vorlagenveröffentlichung

Freigabe einer neuen Dokumentvorlagenversion nach deren Bearbeitung. Während veröffentlichte Versionen bei der Verarbeitung von Dokumenten aus Arbeitsstapeln zum Einsatz kommen, können nicht veröffentlichte, lokale Versionen nur bei der Verarbeitung von Vorlagen aus Teststapeln verwendet werden. Siehe Bearbeiten und Veröffentlichen einer Vorlage.

Vorlagenzuordnung

Vorgang, bei dem eine Vorlage ausgewählt wird und auf der Grundlage eines Bilds Tabellenfeldern zugeordnet werden.

W

Winkel

Ein Anker in Form eines Winkels.

Wörterbuch

Eine Liste von Wörtern, mit denen ein bestimmter Datentyp bestimmt wird. Details…

Das Wörterbuch wird beim Erstellen des Datentyps angegeben. Dadurch ist bereits mit dem Datentyp eines Felds das Wörterbuch festgelegt, das bei der Erkennung und überprüfung verwendet wird. Die Software unterstützt nicht nur das Hinzufügen vordefinierter Datentypen mit fertigen Wörterbüchern, sondern ermöglicht es dem Benutzer auch, Datentypen mit individuellen Wörterbüchern zu erstellen. Sie können die Wörterbuchdaten manuell eingeben oder aus einer Datei laden.

X

XFD

Abkürzung für XML-Formulardefinition (*.xfd). Hierbei handelt es sich um ein spezielles Dateiformat für Formulare, die mit ABBYY FormDesigner erstellt wurden. Mithilfe von XFD-Dateien können in ABBYY FlexiCapture Dokumentvorlagen erstellt werden.

Z

Zulässiger Zeichensatz

Eine Gruppe von Zeichen, die im zu erkennenden Datentyp vorkommt. Details…

Dieser Satz wird durch den Datentyp definiert. Das bedeutet, dass durch den an ein Feld angefügten Datentyp festgelegt wird, welcher Zeichensatz bei der Erkennung verwendet wird.

Neben der Auswahl der Zeichen in diesem Zeichensatz können Sie zusätzliche Parameter konfigurieren, die diesen Satz einschränken. Beispielsweise könnten Sie folgende Zeichen ausschließen:

  • Zeichen, von denen Sie wissen, dass sie nicht im zu erkennenden Feld vorkommen (z. B. sämtliche Kleinbuchstaben in einem Feld, wenn in diesem Feld nur Großbuchstaben zulässig sein sollen).
  • Zeichen, die in Wörtern auftreten können, aber die überprüfung dieser Wörter nicht beeinträchtigen sollen (z. B. Bindestriche, Betonungszeichen usw.).


Glossar

A B D E F G H I K L M N O P R S T U V W X Z


Beschreibungsdatei

Eine Beschreibungsdatei ist eine Hilfsdatei, in der definiert ist, auf welche Weise ein Stapel beim Hinzufügen von Bildern aus einem Hot Folder gebildet wird. Je nach Format der Beschreibungsdatei wird der Stapel aus unterschiedlichen Dateigruppen gebildet.

Im Programm werden die folgenden Beschreibungsdateitypen verwendet:

  1. Captiva QuickScan
    Alle in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt. Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.
  2. Kodak Capture Software
    Die Bilddateien im Ordner des Kodak-Stapels werden nach Dateiname sortiert in aufsteigender Reihenfolge zum Stapel hinzugefügt.
  3. Leere Datei
    Der Inhalt dieser Datei ist irrelevant. Alle Dateien, die der Beschreibungsdatei im Hot Folder vorangestellt sind, werden nach Dateiname sortiert in aufsteigender Reihenfolge zum Stapel hinzugefügt.
  4. XML-Datei
    Hierbei handelt es sich um eine XML-Datei mit dokumentierter Struktur. Die XML-Datei wird verwendet, wenn die anderen drei Dateitypen nicht eingesetzt werden können, jedoch eine benutzerdefinierte Beschreibungsdatei generiert werden kann. Die in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt.

    Eine XML-Datei muss das Stammelement Stapel mit untergeordneten Elementen vom Typ Bilder enthalten.

    Jedes untergeordnete Element Bilder muss wiederum Elemente vom Typ Bild enthalten, deren Anzahl der Anzahl der Seiten im zu erstellenden Stapel entspricht. Jedes Element Bild muss einen UNC-Pfad zur entsprechenden Bilddatei enthalten. Der Pfad zum Ordner mit dem Bild muss für alle Elemente vom Typ Bild gleich sein.

    <Batch>

    ...

    <Images>
    <Image>\\HotFolder\Page1.tif</Image>
    <Image>\\HotFolder\Page2.tif</Image>
    <Image>\\HotFolder\Page3.tif</Image>

    </Images>

    </Batch>

    In diesem Fall wird empfohlen, das Scanprogramm so einzurichten, dass gescannte Bilder direkt im Hot Folder oder in den zugehörigen Unterordnern auf der nächsten Ebene abgelegt werden. Beim Erstellen eines Stapels werden diesem alle in den Elementen vom Typ Bild der entsprechenden Beschreibungsdatei aufgeführten Bilder hinzugefügt. Die Bilder werden in der Reihenfolge hinzugefügt, in der sie in der Beschreibungsdatei angeordnet sind.

    Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.