Что такое ABBYY FlexiCapture

Программа ABBYY FlexiCapture – это программное решение для автоматизированного ввода данных с бумажных документов в информационные системы и базы данных.

Используя передовые технологии распознавания типографских и рукопечатных символов, обработки изображений и анализа документов, ABBYY FlexiCapture позволяет автоматизировать извлечение значимой информации из документов любого типа, обрабатываемых в одном потоке – структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных документов, оформленных в свободном стиле. В результате пользователи ABBYY FlexiCapture избавляются от трудоемкого и неэффективного труда, связанного с ручной сортировкой документов и перепечаткой информации с них.

Основной сценарий обработки документов сводится к следующему:

  1. Документы кладутся в автоподатчик сканера и запускается процесс сканирования.
  2. Отсканированные изображения документов поступают на распознавание, в процессе которого программа автоматически идентифицирует документы, в том числе многостраничные, находит значимые поля, извлекает данные и запускает правила проверки.
  3. При необходимости, по окончании распознавания запускается процесс визуальной проверки данных и ошибок правил.
  4. Распознанные и проверенные данные, а также электронные копии документов сохраняются в базу данных, информационную систему или в файл.


Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture

ABBYY FlexiCapture – программное решение для потокового ввода данных с документов различного типа.

Документы различных типов могут обрабатываться в одном потоке. Можно также настроить обработку документов смешанного типа, например, состоящих из жестких и гибких разделов. Тип документов влияет только на настройку системы, а именно, на способ создания определения документа. Работа оператора не зависит от типа обрабатываемых документов.

С помощью ABBYY FlexiCapture вы сможете настроить автоматизированный ввод следующих документов, в том числе в одном потоке:

Collapsed структурированных – жестких форм;

К структурированным относятся документы с набором выделенных информационных полей, оформление, количество и местоположение которых не меняются от одного экземпляра документа к другому. Такие документы называются жесткими формами. Например, анкеты, опросники, заявления чаще всего являются жесткими формами. Чаще всего такие формы распространяются в виде бланков и заполняются от руки.

Чтобы идентифицировать жесткую форму в потоке документов и извлечь из нее данные, необходимо создать единую жесткую разметку, которая укажет программе места расположения полей, из которых нужно извлечь данные.

Наиболее эффективно производится обработка жестких форм, созданных с учетом требований автоматического ввода. Такие формы называют машиночитаемыми формами. Подробнее о требованиях к таким формам и способах их создания читайте в разделе Создание машиночитаемых форм.

В состав программы входит удобный инструмент разработки машиночитаемых форм ABBYY FormDesigner (Поставляется вместе с ABBYY FlexiCapture). О создании форм с помощью ABBYY FormDesigner читайте в руководстве и справке к этой программе.

Основные этапы создания определения документа описаны именно для структурированных документов.

Замечание. Для обработки жестких форм, переданных по факсу, рекомендуется использовать гибкую разметку (см. следующий раздел). Поскольку при передаче факса могут возникнуть сильные искажения в размере формы и геометрическом расположении полей. Использование гибкой разметки в данном случае позволит повысить качество распознавания.

Collapsed частично структурированных – гибких форм и документов;

К ним относятся документы, содержащие набор информационных полей, оформление, количество и расположение которых могут значительно отличаться в разных экземплярах документа. Эти документы называются гибкими. К примеру, счета являются гибкими документами, т.к. они часто отличаются как количеством позиций, так и форматированием, потому что они поступают от разных компаний. На всех счетах присутствуют номер счета и сумма платежа, но и они расположены в разных местах.

Для идентификации гибких форм и извлечения из них данных программа ABBYY FlexiCapture использует гибкую разметку (FlexiLayout). Для создания гибкой разметки используется специальный модуль ABBYY FlexiLayout Studio, подробную информацию о работе которого можно найти в руководстве и справке к этому модулю.

Процесс обработки гибких документов отличается от обработки жестких форм только на этапе создания и подключения разметки. Подробнее см. Создание определения для обработки гибких документов.

Collapsed неструктурированных документов, оформленных в свободном стиле.

Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, графики, то и в этом случае поможет ABBYY FlexiCapture. Неструктурированные документы могут быть автоматически идентифицированы программой либо как приложения к жестким или гибким формам, либо с помощью гибкой разметки, а затем экспортированы в виде PDF файлов с возможностью поиска или файлов графических форматов. Извлекать индексные поля из неструктурированных документов можно как автоматически с помощью гибкой разметки, так и с помощью ручного ввода.

Типичным сценарием обработки неструктурированных документов является задача перевода бумажного архива в электронный вид с необходимостью извлечения двух-трех индексных полей для организации быстрого поиска по атрибутам.

Подробнее см. Обработка неструктурированных документов.


Обзор работы оператора с настроенной программой

Оператор работает с программой, уже настроенной для обработки документов определенного типа. Процесс обработки документов не зависит от типа документов и состоит из следующих этапов:

  1. Добавление изображений

    Удобнее всего добавлять изображения страниц документов, если в проекте настроены профили импорта. Также можно добавлять изображения путем сканирования или загружать их из файлов.

  2. Запуск процесса распознавания

    Распознавание производится автоматически: программа определяет определение документа по расположению статических элементов, заданных в определениях, производит наложение определения и распознает данные из указанных в определении документа областей - полей. До запуска распознавания можно произвести анализ документов или их страниц, а также наложить на изображение указанное определение.

  3. Верификация

    Верификация – процесс проверки данных – самый трудоемкий этап работы оператора. Он подразделяется на:

    • Верификацию сборки документов – проверку правильности сборки страниц в документы;
    • Групповую верификацию – визуальную проверку группы одинаково распознанных символов;
    • Контекстную верификацию – проверку неуверенно распознанных символов в контексте полей с известной областью значений;
    • Верификацию в окне документа – проверку ошибок в окне документа, в том числе проверку правил.
  4. Экспорт данных

    Экспорт производится при нажатии одной кнопки согласно настройкам экспорта, заданным в определении документа. Кроме того, можно экспортировать данные в файл или в базу данных, не используя настройки экспорта определения документа.
    Отметьте опцию Удалить документы после экспорта, если вы хотите, чтобы проэкспортированные документы удалялись автоматически.

Замечание. Вы можете полностью автоматизировать процесс обработки, используя следующие настройки:

  • Создайте профиль импорта для автоматического импорта изображений.
  • Отметьте опцию Автоматически распознавать добавленные изображения на закладке Обработка документов меню Сервис > Опции…
  • На закладке Процесс обработки в свойствах типа пакета отметьте опцию Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен.
  • На закладке Экспорт в свойствах определения документа отметьте опцию Разрешить автоматический экспорт для автоматической отправки документов.
  • Отметьте опцию Удалить документы после экспорта, чтобы автоматически удалять проэкспортированные документы.
Подробнее о работе оператора с настроенным проектом


Добавление изображений

Для того чтобы добавить изображения, выберите нужный пакет или создайте новый пакет. Кнопка импорта позволит вам добавить изображения разными способами, надпись на кнопке меняется в зависимости от выбранного способа импорта.

Если в проекте настроены профили импорта, то их названия будут отображаться в качестве пунктов меню кнопки импорта. Для того чтобы приступить к импорту, достаточно выбрать один из них.

Чтобы загрузить изображения из файла, нажмите на стрелку справа от кнопки импорта и выберите пункт меню Загрузить изображения…. Выберите файлы с изображениями, задайте необходимые опции и выполните импорт.

Чтобы добавить изображения со сканера, нажмите на стрелку справа от кнопки импорта и выберите пункт меню Сканировать изображения…

При выборе пункта меню Импортировать изображения… вы сможете не только выбрать один из существующих профилей импорта изображений и приступить к импорту, но и добавить новый профиль или отредактировать один из существующих.

Подробнее о добавлении изображений


Запуск процесса распознавания, анализ и наложение определения документа

Вы находитесь здесь: Знакомство с ABBYY FlexiCapture > Обзор работы оператора с настроенной программой > Запуск распознавания, анализ и наложение описания документа

Запуск процесса распознавания, анализа и наложения определения документа

Распознавание производится при нажатии кнопки Распознать.

Для предварительного анализа изображений нажмите на стрелку справа от кнопки Распознать и выберите пункт меню Наложить определение…. Если определение документа может быть наложено, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни одно из определений проекта не может быть наложено на изображение, то страница остается необработанной.

Программа также позволяет наложить на страницу или на весь документ определенное определение. В большинстве случаев правильно созданное в программе определение накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить его вручную. Чтобы наложить определение документа, выделите документ или страницу, нажмите на стрелку справа от кнопки Распознать и выберите пункт меню Наложить определение…

Подробнее о распознавании


Верификация

Верификация - проверка корректности распознавания, сборки страниц в документы (для многостраничных документов) и выполнения правил. Верификация осуществляется на Станции Оператора.

Процесс верификации начинается при нажатии кнопки Начать верификацию…. Процесс начинается с групповой верификации, за ней следует контекстная. Если в определении документа нет полей включенных в групповую или контекстную верификацию, то соответствующий этап верификации будет пропущен.

При создании определения документа задается правило сборки документа: порядок следования и количество повторений страниц. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа. Сборка страниц в документы производится автоматически на этапе распознавания. Во время верификации для многостраничных документов нужно исправить возможные ошибки сборки документов. Документы с ошибками сборки помечаются значком [image]. Описание ошибки выводится текстом красного цвета под названием определения документа. При несовпадении значений ключевых полей пользователь увидит сообщение об этом и значения будут отображены красным цветом. Ошибки сборки удобнее всего исправлять в режиме эскизов страниц, т.к. изображения страниц и их принадлежность к документам хорошо видны.

В процессе групповой верификации на проверку подаются группы одинаково распознанных символов. Задача оператора - выделить отличающиеся символы, распознанные неправильно, и исправить их значения, просмотрев, если нужно, изображения поля с этим символом. При невозможности исправления символы можно пометить как сомнительные.

В процессе контекстной верификации на проверку подаются поля с известной областью значения. Задача оператора - проверить неуверенно распознанные символы в контексте всего поля. Контекстная верификация имеет два режима: режим просмотра одного поля с нарезкой символов и режим просмотра нескольких однотипных полей.

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки. Ошибки формата помечаются значком [image]. Оператору нужно проверить поля с ошибками и, по возможности, исправить их значения. Для запуска верификации ошибок правил нажмите на стрелку справа от кнопки и выберите пункт меню Перепроверить правила. Если правила выполняются после исправления значений полей, то флажки будут сняты.

Также значком [image] отображаются ошибки не наложения полей гибких описаний. Для таких полей оператор может вручную указать регион на изображении документа.

Верификация также производится в окне документа (открывается двойным щелчком мыши на названии документа или страницы). В окне документа пользователь видит уже не отдельные поля, а весь документ целиком. Также ему видны все неуверенно распознанные символы, ошибки правил и т.д.

Подробнее о верификации


Запуск программы

Чтобы запустить программу ABBYY FlexiCapture

  • выберите пункт Станция оператора в меню Пуск/Программы/ABBYY FlexiCapture.

Внимание! Перед запуском программы убедитесь, что:

  • Используемый сканер подключен к компьютеру и включен в сеть. Если ваш сканер еще не подключен, воспользуйтесь руководством пользователя сканера. Для того, чтобы сканер работал корректно, необходимо сначала включить сканер и только после этого – компьютер.
  • На ваш компьютер установлен ключ защиты. Без ключа защиты запуск программы будет невозможен.


Работа оператора с настроенным проектом

Для того чтобы оператор мог приступить к обработке документов, проект должен быть настроен администратором. Процесс обработки документов можно настроить таким образом, чтобы операции сканирования или импорта изображений, распознавания и экспорта данных выполнялись с минимальным участием человека. В этом случае основным этапом работы оператора будет проверка и исправление распознанных данных – верификация.

Работа оператора не зависит от вида документов.

Процесс обработки документов состоит из четырех этапов и каждому этапу соответствует кнопка на панели инструментов.

1. Добавление изображений

Стрелка справа позволяет выбрать одну из опций импорта изображений: Загрузить изображения…, Сканировать изображения… или произвести импорт, выбрав один из настроенных профилей. Надпись на кнопке изменяется и соответствует выполняемому действию.

2. Распознавание

Запускает процесс распознавания документов. С помощью стрелки справа вы также сможете произвести анализ документов или наложение одного из определений документа.

3. Верификация

Запускает процесс верификации. С помощью стрелки можно также запустить процесс верификации ошибок правил.

4. Экспорт

Запускает экспорт данных согласно определенным в определении документа настройкам. С помощью стрелки можно осуществить экспорт данных в файл или базу данных, а также экспортировать изображения документов.


Добавление изображений страниц

Обработка документов начинается с добавления в проект изображений страниц документов – импорта изображений. Для начала работы выберите или создайте новый рабочий пакет, в который будут добавлены изображения (для создания щелкните правой кнопкой мыши в главном окне программы и выберите Новый пакет…). Двойным щелчком мыши откройте нужный пакет, либо просто выделите его в списке.

Замечание. При попытке добавить изображения в проект, где нет ни одного пакета, пакет документов будет создан автоматически.

Добавить изображения в пакет можно несколькими способами:

  1. Загрузить ранее сохраненные изображения из файлов;
  2. Отсканировать изображения;
  3. Произвести импорт изображений, используя один из ранее настроенных администратором профилей импорта изображений (cм. Профили импорта изображений.)

Чтобы выбрать способ добавления изображений, надо нажать на стрелку справа от кнопки импорта и выбрать один из пунктов меню.

Добавление изображений из файла

Для того чтобы загрузить изображения из файла, выберите пункт меню Загрузить изображения… или нажмите комбинацию клавиш Ctrl+O. В открывшемся диалоге выберите нужные файлы с изображениями и задайте опции импорта изображений:

  • Создавать новый документ – для добавленных изображений будут созданы новые документы.
  • Добавить в текущий документ – изображения будут добавлены в текущий, выделенный документ.
  • Вы также можете задать параметры предварительной обработки изображений. Для этого нажмите на кнопку Параметры обработки изображений… и задайте нужные параметры в открывшемся диалоге. Подробнее см. Параметры обработки изображений.

Сканирование изображений

Для добавления изображений со сканера, выберите пункт меню Сканировать изображения…. Выберите сканер, установите параметры сканирования и отсканируйте изображения.

Добавление изображений с использованием профилей импорта

Если профили импорта были настроены администратором, то их названия отобразятся в меню кнопки импорта. Для начала импорта изображений достаточно выбрать пункт с одним из названий профилей импорта.

При выборе Импортировать изображения… откроется диалогВыбор профиля импорта, в котором нужно выбрать профиль импорта из списка и нажать кнопку Импортировать для начала импорта изображений. Если вы работаете в режиме администратора, то из этого диалога можно также создать новый профиль импорта или отредактировать существующие профили.

Фоновый импорт изображений

Импорт изображений может производиться в фоновом режиме, если настроен соответствующий профиль импорта. Изображения из горячей папки автоматически импортируются в систему, проверка наличия новых изображений производится через указанный в настройках интервал времени.

Автоматическая проверка горячей папки запускается при команде пользователя импортировать изображения, используя профиль, в котором отмечена опция Проверять Горячую папку каждые. Проверка горячей папки прекращается при закрытии проекта, либо при снятии отметки с данной опции в свойствах профиля. См. Профили импорта изображений.

Замечание. Для добавления изображений из горячей папки у пользователя должны быть права на чтение и запись в данную папку.


Установка параметров сканирования

Качество распознавания во многом зависит от того, насколько хорошее изображение получено при сканировании. Качество изображения регулируется установкой основных параметров сканирования: типа изображения, разрешения и яркости.

При сканировании через программу ABBYY FlexiCapture возможно два варианта взаимодействия программы со сканерами через TWAIN или ISIS драйвера:

  • через интерфейс ABBYY FlexiCapture:
    в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера; параметры сканирования можно установить при создании профиля импорта с источником импорта Сканер.
  • через интерфейс TWAIN или ISIS-драйвера сканера:
    для настройки опций сканирования используется диалог соответствующего драйвера сканера. Этот диалог открывается автоматически при выборе пункта Сканировать изображения… выпадающего меню кнопки импорта.

Основные параметры сканирования

  • Тип изображения – сканирование в сером (256 градаций) является оптимальным режимом для системы распознавания. В случае сканирования в сером режиме осуществляется автоматический подбор яркости.

    Черно-белый тип изображения обеспечивает более высокую скорость сканирования, но при этом теряется часть информации о буквах, что может привести к ухудшению качества распознавания на документах среднего и низкого качества печати.
    Если вы хотите, чтобы содержащиеся в документе цветные элементы (картинки, цветные буквы и цветной фон) были переданы в электронный документ с сохранением цвета, необходимо выбрать цветной тип изображения. В других случаях используйте серый тип изображения.

  • Яркость и контрастность – нужно подобрать так, чтобы, во-первых, были сохранены реперные блоки, и, во-вторых, изображения распознаваемых блоков получились как можно более четкими и разборчивыми.
    В большинстве случаев подходит среднее значение яркости – 50%.
    На некоторых документах при сканировании в черно-белом режиме может понадобиться дополнительная настройка яркости.
  • Разрешение – рекомендованные разрешения для обработки форм, заполненных от руки, – 300 dpi. Разрешение изображений при сканировании обрабатываемых форм должно совпадать с разрешением изображения исходного документа.

Замечание.

  1. Сканирование с разрешением 400-600 dpi вместо 300 dpi или сканирование в сером или в цвете, а не в черно-белом, может занять существенно больше времени. На некоторых моделях сканеров сканирование с разрешением 600 dpi занимает в 4 раза больше времени, чем сканирование с разрешением 300 dpi. Не рекомендуется сканировать с разрешением менее 200 dpi.
  2. При использования диалога драйвера сканера, опции для установки параметров сканирования могут называться по-разному, в зависимости от модели сканера. Например, яркость может называться brightness, threshold, изображаться "солнышком" или черно-белым кружком. Смысл опций описан в документации, прилагаемой к вашему сканеру.

Совет.

  1. Сканирование цветных фоновых форм на нецветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо оборудовать сканер соответствующей лампой фильтрации цвета: для «розовых» форм – красной лампой (Red-Lamp), для «зеленых» форм – зеленой лампой (Green-Lamp).
  2. Сканирование цветных фоновых форм на цветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо в настройках параметров сканирования задать режим фильтрации соответствующего цвета.
  3. Сканирование цветных фоновых форм светлых тонов. Если вы обрабатываете цветные формы светлых оттенков, то за счет слабой насыщенности цвета фон может исчезать при сканировании белой лампой и без программной фильтрации цвета. Способ сканирования форм выбирается, как правило, на этапе разработки формы.

Совет.

  1. Отсканированное изображение должно быть читаемым (для того, чтобы просмотреть отсканированное изображение, откройте его в окне документа).
  2. Если в полученном изображении буквы "разорванные", светлые или тонкие:
    • Уменьшите яркость, увеличьте контрастность (сделайте изображение темнее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).
  3. Если в полученном изображении грязный фон; искаженные, залитые или склеенные символы; темные, толстые буквы:
    • Увеличьте яркость (сделайте изображение светлее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).


Распознавание

Распознавание производится при нажатии кнопки Распознать. При этом программа производит наложение определения документа, выбирая его по реперам и идентификаторам, и производит распознавание данных в областях документов, которые совпадают с областями полей выбранного определения.

Распознавание изображений может производиться автоматически, сразу после добавления изображений в пакет. Для этого нужно отметить опцию Автоматически распознавать добавленные изображения (меню Сервис главного окна, пункт Опции…, закладка Обработка документов).

Процентное соотношение уверенно распознанных символов к общему количеству отображается в колонке Уверенность.

После распознавания оператор может перейти к верификации документов.

Еще до начала распознавания можно, при необходимости, выполнить Предварительный анализ изображений и наложение определения документа.

Замечание. В процессе распознавания может возникнуть следующее сообщение об ошибке: "Cannot create <ProjectDirectory>\<BatchName>\BatchHeader.tmp". The specified file already exists." Данное сообщение возникает в результате влияния службы индексирования Windows Search на работу комплекса. Служба индексирования Windows Search обрабатывает временные файлы, которые создаются и удаляются в папке проекта в процессе работы комплекса, что приводит к возникновению ошибки. По этой причине мы рекомендуем отключать службу Windows Search.


Предварительный анализ изображений и наложение определения документа

Еще до начала распознавания страницы можно проанализировать, то есть определить, какое определение документа может быть наложено на страницу. Для этого нужно выбрать пункт главного меню Распознавание > Проанализировать или нажать на стрелку справа от кнопки Распознать и выбрать Проанализировать. Если определение документа может быть наложено, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни одно из определений проекта не может быть наложен на изображение, то страница остается необработанной.

Программа также позволяет наложить на страницу или на весь документ определенное определение документа. В большинстве случаев правильно созданное в программе определение накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить его вручную.

Чтобы произвести наложение определения документа:

  1. Выделите документ;
  2. Выберите пункт Наложить определение документа… локального меню документа или пункт главного меню Распознавание>Наложить определение документа… или нажмите на стрелку справа от кнопки Распознать и выберите Наложить определение…;
  3. В открывшемся диалоге Выберите определение документа выберите одно из определений документов и нажмите OK.

Если наложение выбранного определения документа прошло успешно, документу и входящим в него страницам будут присвоены названия соответствующего определения документа и его разделов.

Чтобы произвести наложение определения документа на одну из страниц:

  1. Выделите страницу;
  2. Выберите пункт Наложить определение документа… локального меню страницы или пункт главного меню Распознавание>Наложить определение документа…;
  3. В открывшемся диалоге Выбор определения для наложения выберите одно из определений документов и нажмите OK.

Если наложение определения документа прошло успешно, то выбранной странице будет присвоено название соответствующего раздела определения.


Верификация распознанных данных

Верификация, или проверка распознанных данных – самая трудоемкая часть работы оператора. Технология верификации в продуктах ABBYY реализована с учётом основных психосоматических особенностей человека: выработки привычек, использования навыков, целостности и целенаправленности восприятия. Таким образом, процесс верификации в ABBYY FlexiCapture ориентирован на максимальное удобство для оператора и минимальное количество ошибок.

Символы, насчет правильности распознавания которых нет абсолютной уверенности, помечаются программой как неуверенно распознанные. Процесс верификации предназначен для того, чтобы проверить такие символы, удостовериться, что они распознаны правильно или исправить их.

Проверка правил производится автоматически, если значения полей удовлетворяют правилам, то эти поля могут быть помечены как уверенно распознанные и не участвовать в процессе верификации. Если же значения полей не удовлетворяют правилам, то такие поля подаются на проверку оператору.

Для многостраничных документов сначала следует проверить сборку страниц в документы.

Затем запускается процесс верификации. Процесс верификации данных производится в 2 этапа – групповая верификация и контекстная. Если в определении документа нет полей, включенных в групповую или контекстную верификацию, то соответствующий этап верификации будет пропущен.

После прохождения этапов групповой и контекстной верификации, производится проверка в окне документа. Те символы, которые не были подтверждены на более ранних этапах, остаются подсвеченными красным цветом.

Переход к предыдущей и следующей ошибке осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил и т.д.

Сборка страниц в документы
Групповая верификация
Контекстная верификация
Верификация в окне документа
Верификация правил


Сборка страниц в документы

Как исправить ошибки сборки

  1. Неправильный порядок страниц в документе

    Возможно, страниц не хватает или присутствуют лишние страницы, либо страницы документа следуют не по порядку. Чтобы получить подсказку, наведите курсор мыши на страницу, помеченную красным крестиком:

    Для исправления таких ошибок можно переместить страницу с помощью мыши, как в пределах одного документа, так и из одного документа в другой.

    Соединить страницы нескольких документов в один документ можно следующим образом:

    • Выделите документы для объединения (несколько документов можно выделить удерживая нажатой клавишу Ctrl);
    • Нажмите на правую кнопку мыши и выберите пункт локального меню Объединить.

    Чтобы разделить страницы документа и поместить каждую из них в отдельный документ:

    • Выделите документ для разделения страниц;
    • Выберите пункт локального меню Разделить.

  2. Если в определении документа задано, что для правильной сборки страниц должна производиться проверка по ключевым полям, то значения ключевых полей будут отображены под изображением каждой страницы:

    • серым цветом - в случае совпадения;
    • красным цветом - в случае несовпадения.

    Ключевые поля могут не совпадать из-за того, что они были неправильно распознаны или заполнены. Проверьте значения ключевых полей. Если же значения ключевых полей все равно не совпадают, то, вероятно, такие страницы не относятся к одному документу. Если был перепутан порядок страниц, то найдите страницы с одинаковыми ключевыми полями и соберите их в документы, с помощью приемов, описанных в пункте 1.


Групповая верификация

Групповая верификация – это просмотр оператором изображений символов, распознанных с одинаковым значением. Таким образом легко заметить и исправить символы, выделяющиеся из общей массы. В ходе групповой верификации проверяются однотипные символы, для которых обычно не важен контекст, например, цифры и метки.

Неправильно распознанные символы можно исправить следующим образом: выделите символ, который не соответствует символу группы, и введите его правильное значение. Это значение отобразится зеленым цветом в левом верхнем углу изображения символа.

Если изображения символа недостаточно для определения, правильно ли он был распознан, можно просмотреть, в каком контексте он находится: изображение поля для текста или числа (даты, времени и т. п.) или группы меток. Для этого выберите пункт Показать изображение символа в локальном меню выделенного символа или нажмите клавишу F2.

Можно также включить режим, при котором при наведении курсора мыши на проверяемый символ будет отображаться изображение содержащего его поля целиком. Для этого нужно выбрать пункт меню Вид>Изображение поля>Показывать изображение поля в окне верификации, либо нажать комбинацию клавиш Ctrl+I.

Если в качестве символа было распознано постороннее изображение (например, возникший при сканировании дефект), его можно удалить, нажав клавишу Delete.

Если вы сомневаетесь в значении символа даже после просмотра контекста, нажмите на символ левой кнопкой мыши: символ будет помечен красным знаком вопроса. Его можно будет подтвердить или исправить во время контекстной верификации.

Статус символа можно изменять также с помощью кнопки Изменить статус панели инструментов.

Когда все неверно распознанные символы исправлены или отложены, можно подтвердить все остальные символы, нажав кнопку Подтвердить все панели инструментов. Также можно подтвердить отдельные символы с помощью локального меню, выбрав пункт Подтвердить.


Контекстная верификация

Контекстная верификация – это режим верификации, предназначенный для исправления ошибок распознания полей целиком. В данном режиме отображается все распознанное поле, что позволяет эффективно находить и исправлять ошибки распознавания слов.

Для принятия решения о том, как нужно исправить значение поля, пользователю достаточно видеть только это поле и предполагать, какое оно может иметь значение. Исправляются не только ошибки заполнения, но и ошибки формата поля.

Для исправления неправильно распознанных символов можно использовать стандартные режимы текстовых редакторов: режим вставки и замены символов, переключаться между ними можно с помощью кнопки Insert на клавиатуре.

При необходимости можно изменить способ корректировки значений полей, например, включить выделение всего поля для того, чтобы вводить его значение целиком вместо правки отдельных символов. Также можно настроить внешний вид окна контекстной верификации для отображения дополнительной информации: изображения поля, изображений аналогичных полей других документов и т. д.

Пользователь последовательно просматривает результат распознавания каждого поля, при необходимости исправляет его и подтверждает с помощью кнопки Подтвердить поле.

Значения полей нужно исправить, а если исправить не удается, то пропустить поле или отложить проверку значения поля с помощью кнопки Отложить поле, чтобы внести исправления при верификации документа целиком на этапе верификации.


Верификация в окне документа

Окно документа также позволяет проверить правильность распознавания и исправить неверно распознанные символы. Окно документа открывается при двойном щелчке на названии страницы и состоит из области данных, изображения страницы и области ошибок (если такие ошибки есть). При необходимости можно выбрать типы отображаемых ошибок: ошибки сборки, ошибки формата, ошибки правил, ошибки неналожения региона или любую их комбинацию. Для отображения ошибок определенного типа надо нажать на соответствующую кнопку в правом верхнем углу области ошибок.

В окне документа оператор видит уже не группы символов или отдельные поля, а весь документ целиком. Вид окна можно настроить с помощью кнопки Вид окна. Для просмотра изображения страницы на втором мониторе нажмите на стрелочку рядом с кнопкой Вид окна и выберите Окно изображения > Не закреплено. В этом режиме вы можете приблизить изображение страницы, выделить блок, удалить лишние разделители.

Collapsed Показать окно документа

В контекстном меню окна документа вы можете подтвердить поле, включить отображение форматных ошибок, копировать значение поля, перейти к предыдущему или следующему объекту верификации, выбрать размер текста, а также режим перехода по полям. Выберите режим Перейти к неуверенному полю для подтверждения для перехода между неуверенно распознанными полями. Для перехода по неналоженным полям выберите режим Перейти к следующему ненайденному полю при наложении (смотрите описание ниже).

В области данных неуверенно распознанные и сомнительные символы выделяются цветом, поля с неверными типами данных и невыполненными правилами подсвечиваются.

Поле с неуверенно распознанными символами можно подтвердить, установив курсор в данное поле и нажав Enter.

Поля для просмотра и редактирования распознанных данных могут располагаться не только в порядке следования, но и в любом другом порядке, удобном для пользователя.

Переход к следующей или предыдущей ошибке в окне документа осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, ошибки правил, несовпадение ключевых полей и т.д.

Быстрый ввод значений для неналоженных полей

Данная функциональность доступна для проектов, использующих гибкие описания, и позволяет быстро ввести значение поля, если данное поле не было наложено.

Режим быстрого ввода данных позволяет перенести данные в активное поле, выделив регион поля с помощью мыши.

Если значение поля не найдено или найдено неправильно, то для быстрого ввода значения щелкните кнопкой мыши по региону поля на странице. Можно также выделить часть текста, зажав левую клавишу мыши. Если в документе есть только одно поле без региона, значение будет добавлено автоматически. Если таких полей несколько, вам будет предложено выбрать, для какого поля следует ввести значение.

Если ни одно из предложенных значений не подходит, то при верификации на Станции настройки проекта или Станции верификации можно выделить регион и контекстном меню региона выбрать пункт Распознать(Ctrl+R). В этом случае поле будет распознано с использованием настроек, указанных для данного поля в определении документа. При верификации на Web-станциях данная возможность недоступна.

Режим навигации по неналоженным полям

Для навигации по полям, регионы которых не найдены, в контекстном меню окна документа нужно выбрать опцию Перейти к следующему ненайденному полю при наложении. При выборе данного режима в фокусе окажется первое поле с неналоженным регионом. При вводе значения поля или при навигации с помощью кнопок [image] и [image], будет осуществляться переход к следующему полю без региона.

Копирование значения поля в другие ячейки столбца

Существует возможность скопировать значение поля таблицы, повторяющихся полей и полей повторяющихся групп. Для этого в контекстном меню поля выберите необходимый пункт:

  • Копировать значение для диапазона строк (или воспользуйтесь сочетанием клавиш Ctrl+Q) – копирует значение поля в однотипные строки внутри группы. При выборе опции ячейка окрашивается в голубой цвет и на курсоре появляется специальный символ.
    Чтобы скопировать значение, выберите однотипное поле внутри группы или таблицы. В диапазон копирования попадают все ячейки, находящиеся между копируемым и выбранным полем включительно.
    Если поле с копируемым значением входит в повторяющуюся группу, значение будет также скопировано в экземпляры полей, попавших в выбранный диапазон.
    Замечание. Копирование значения меток возможно только для повторяющихся меток или для меток в повторяющихся группах.
  • Копировать значение для всех строк (или воспользуйтесь сочетанием клавиш Ctrl+Shift+Q) – копирует значение поля во все строки таблицы или повторяющиеся поля внутри группы, а также в их экземпляры.

Отображение информации об ошибках, связанных со скрытыми полями

Поле на форме данных может быть скрыто по следующим причинам:

  • В свойствах поля не отмечена опция Показывать в Форме данных.
  • В свойствах этапа ограничен набор полей.

Возможны следующие варианты отображения ошибок, связанных со скрытыми полями:

  1. Если со скрытым полем связана ошибка формата, то в области ошибок информация об ошибке отображаться не будет.
  2. Если со скрытым полем связана ошибка многополевого правила и в правиле участвует только данное поле, то в области ошибок информация об ошибке отображаться не будет.
  3. Если со скрытым полем связана ошибка многополевого правила, в котором участвуют также другие поля, присутствующие на форме, то в области ошибок будет отображаться информация об ошибке, однако для скрытого поля будет отображаться только его название, а не ссылка на поле.
    Collapsed Показать

Если в документе содержатся ошибки, которые не отображаются в области ошибок по причине скрытых полей, то, в зависимости от этапа, на котором выполняется просмотр документа, в списке данный документ может отображаться следующим образом:

  • Если просмотр документа выполняется на этапе Верификации, где набор данных ограничен, то документ в списке будет отображаться без значка ошибки. При этом область ошибок будет пустой.
    Collapsed Показать

  • Если просмотр документа выполняется на этапе, где набор данных не ограничен, например, на этапе Исключений, то документ в списке будет отображаться со значком ошибки. При этом область ошибок будет пустой.
    Collapsed Показать


Верификация правил

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки.

Ошибки правил отображаются в отдельном окне редактора документов, а документы с невыполненными правилами отмечены красными флажками.

При наличии невыполненных правил оператору надо проверить, как распознаны данные, если это ошибка распознавания – исправить ее, а если это ошибка заполнения, которую невозможно исправить, не экспортировать документ. Документы с ошибками можно проверить позже, сверяясь с бумажными документами или другими имеющимися источниками.

Для запуска повторной проверки ошибок правил нажмите на стрелку справа от кнопки Начать верификацию… и выберите пункт меню Перепроверить правила. Если правила выполняются после исправления значений полей, то флажки будут сняты.


Экспорт распознанных данных

После проверки распознанных данных оператор осуществляет экспорт пакета, нажав кнопку Экспортировать. Экспорт производится согласно настройкам определения документа.

Вы также можете произвести экспорт в файл или базу данных, не используя настройки экспорта, заданные в определении документа.

Замечание. При экспорте в файл или базу данных можно использовать настройки по умолчанию, либо изменять их по своему усмотрению. Настройки экспорта по умолчанию задаются в диалоге свойств проекта (пункт меню главного окна Проект>Свойства проекта…), на закладке Экспорт. См. Настройки экспорта по умолчанию.

Экспорт в файл

  1. Для экспорта данных в файл нажмите на стрелку справа от кнопки экспорта и выберите пункт меню Экспортировать данные в файлы…
  2. Выберите место хранения и префикс названия файла (полное название будет начинаться с этого префикса, к которому прибавится название определения документа, название пакета и номер документа, если вы будете сохранять каждый документ в отдельный файл (см. п.3)
  3. Отметьте опции:
    • Экспортировать каждый документ в отдельный файл – для того, чтобы данные каждого документа были сохранены в одном файле;
    • Перезаписывать файл – если вы хотите перезаписывать файл экспорта;
    • Сохранять изображения документов – для сохранения изображений документов.
  4. Если вы хотите изменить другие настройки экспорта, нажмите кнопку Настройки… Подробнее о настройке экспорта см. Настройка экспорта данных.
  5. Если вы хотите сохранить измененные настройки экспорта, в диалоге Настройки экспорта в файлы нажмите на кнопку Сохранить в определении документа… и выберите определение документа, в котором вы хотите сохранить текущие настройки.

Экспорт изображений в файлы

  1. Для экспорта изображений в файлы нажмите на стрелку справа от кнопки экспорта и выберите пункт меню Экспорт изображений в файлы.
  2. Выберите место хранения и формат файла (TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits или PNG).
  3. Нажмите кнопку Настройки… и в открывшемся окне укажите требуемые настройки экспорта.

Экспорт в базу данных

  1. Для экспорта данных в базу данных нажмите на стрелку справа от кнопки экспорта и выберите пункт меню Экспортировать в базу данных…
  2. Установите соединение c базой данных. Подробнее см. Экспорт в базу данных.
  3. Перейдите на закладку Изображения и задайте настройки сохранения изображений.

Замечание.

  1. Документы, данные из которых были успешно экспортированы, могут автоматически удаляться из пакета. Это происходит в том случае, если на закладке Экспорт свойств типа пакета или свойств проекта отмечена опция Удалить документы после экспорта.
  2. При попытке экспортировать документы с ошибками правил, будет выдаваться сообщение об этом. Наличие предупреждений правил не помешает экспорту.


Фоновый режим

Вы находитесь здесь: Работа оператора с настроенным проектом > Фоновые процессы

Фоновые процессы

Импорт, распознавание и экспорт документов, не требующие контроля оператора, могут производиться в фоновом режиме.

Для того чтобы перевести задачу в фоновый режим, надо в открывшемся диалоге Добавление изображений… (Распознавание… или Экспорт…) нажать кнопку Фоновый режим.

Автоматически в фоновом режиме выполняются задачи:

  • Загрузки документов при использовании соответствующего профиля импорта.
  • Экспорт документов.

При переходе в фоновый режим на панели задач появляется иконка [image], открывающая диалог Фоновые задачи, в котором отображается список задач.

  • Задачи выполняются в порядке их поступления или же в соответствии с расставленными пользователем приоритетами (кнопка Приоритет…).
  • Для контроля выполнения заданий и отслеживания ошибок ведется журнал, параметры которого можно настроить (Сервис > Опции…, закладка Выполнение задачи). Для просмотра надо нажать кнопку Журнал.
  • Прервать выполнение задачи можно кнопкой Снять задачу.

Программа также может информировать пользователя о ходе выполнения фоновых процессов при помощи всплывающей подсказки (в правом нижнем углу) - при старте, ошибке и завершении задач. См. Дополнительные настройки.


Интерфейс программы ABBYY FlexiCapture

Этот раздел содержит обзор основных элементов интерфейса программы ABBYY FlexiCapture: основных окон, меню и панелей инструментов.

Станция верификации
Меню станции верификации
Панели инструментов станции верификации
Станция верификации данных
Меню станции верификации данных
Панели инструментов станции верификации данных
Главное окно программы
Меню главного окна
Панели инструментов главного окна
Окно групповой верификации
Меню
Панель инструментов
Окно контекстной верификации
Меню
Панель инструментов


Главное окно программы ABBYY FlexiCapture

В главном окне программы отображается список пакетов документов, входящих в состав проекта, с которым ведется работа.

Collapsed Показать главное окно со списком пакетов

Чтобы увидеть содержимое пакета, откройте его двойным щелчком мыши. Вы увидите список документов, входящих в пакет.

Вернуться к списку пакетов можно, выбрав пункт меню Вид>Рабочие пакеты (или Тестовые пакеты при работе с тестовыми пакетами).

Collapsed Показать главное окно с открытым пакетом документов

В верхней части окна располагается меню, под ним – инструментальные панели.

Остальное пространство Главного окна занимает рабочее окно Пакет со списком входящих в него документов.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Для проверки распознанных данных нужно открыть Окно документа. Для этого щелкните дважды по названию документа или одной из его страниц. Окно документа состоит из трех частей:

  • изображение страницы документа;
  • распознанные данные;
  • ошибки правил (эта часть отображается только при наличии ошибок правил).

Подробнее см. Верификация в окне документа

Collapsed Показать окно документа

Меню главного окна
Панели инструментов главного окна


Меню главного окна программы ABBYY FlexiCapture

Collapsed Файл
Пункт меню | Описание
Новый проект… | Позволяет создать новый проект
Открыть проект… | Позволяет открыть существующий проект
Закрыть проект | Закрывает текущий проект
Сохранить | Сохраняет изменения
Новый пакет… | Создает новый пакет
Загрузить изображения… | Позволяет загрузить изображения из файлов
Сканировать изображения… | Позволяет добавить изображения путем сканирования
Импортировать изображения… | Позволяет импортировать изображения с использованием одного из настроенных профилей импорта
Экспортировать | Позволяет экспортировать данные, используя настройки экспорта определений документов
Экспортировать в |
файлы данных… | Позволяет экспортировать данные в файл
файлы изображений… | Позволяет экспортировать изображения в файлы
базу данных… | Позволяет экспортировать данные в базу данных
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCapture
Collapsed Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Объединить | Объединяет выделенные страницы в один документ
Разделить | Разделяет выделенный документ на страницы
Выделить все | Выделяет все
Найти… | Позволяет найти заданный текст
Найти следующий | Позволяет найти следующий ранее заданный текст
Перейти |
К следующему документу | Позволяет перейти к следующему документу в пакете
К предыдущему документу | Позволяет перейти к предыдущему документу в пакете
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Перевернуть горизонтально | Переворачивает изображение горизонтально (относительно вертикальной оси)
Перевернуть вертикально | Переворачивает изображение вертикально (относительно горизонтальной оси)
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Изменить разрешение… | Изменяет разрешение изображения
Сохранить как… | Позволяет сохранить изображение с указанным именем
Collapsed Вид
Пункт меню | Описание
Тестовые пакеты | Открывает список тестовых пакетов
Рабочие пакеты | Открывает список пакетов
Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Настройка столбцов… | Позволяет настроить список столбцов, отображаемых в детализированном списке
Редактор документа |
Изображение | Показывает изображение страницы в окне документа
Данные | Показывает распознанные данные в окне документа
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения страниц документов
Размер текста данных | Позволяет выбрать размер шрифта для отображения распознанных данных
Показать панель инструментов | Позволяет показать/спрятать панель инструментов в окне документа. Эта панель инструментов позволяет исправить некоторые ошибки наложения, например, дорисовать не найденное поле, добавить или удалить разделитель таблицы. Такая возможность используется, в основном, при работе с гибкими описаниями.
Показать ошибки формата | Позволяет указать способ отображения ошибок формата
Отображать в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц документа в черно-белом режиме
Размер эскизов | Позволяет выбрать размер эскизов страниц
Панели инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Свойства… | Открывает диалог свойств документа или страницы
Collapsed Распознавание
Пункт меню | Описание
Проанализировать | Анализирует страницы документов, подбирая для них подходящее определение
Наложить определение документа… | Производит наложение выбранного пользователем определения на выделенный документ или страницу
Распознать | Запускает процесс распознавания
Collapsed Верификация
Пункт меню | Описание
Начать верификацию… | Запускает процесс верификации
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет переход к предыдущему объекту верификации
Следующий документ с ошибками сборки | Осуществляет переход к следующей ошибке сборки
Предыдущий документ с ошибками сборки | Осуществляет переход к предыдущей ошибке сборки
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Collapsed Проект
Пункт меню | Описание
Определения документов… | Открывает диалог со списком определений документов, из которого осуществляются действия по работе с определениями: создание, редактирование, импорт, удаление (Этот пункт меню доступен только в режиме работы администратора)
Типы пакетов… | Открывает диалог со списком типов пакетов, из которого осуществляются действия по работе с типами: создание, редактирование, удаление (Этот пункт меню доступен только в режиме работы администратора)
Профили импорта изображений… | Открывает диалог со списком профилей импорта изображений, из которого осуществляются действия по работе с профилями импорта: создание нового профиля, копирование существующего, редактирование, удаление (В режиме работы оператора этот пункт позволяет только импортировать изображения, выбирая профиль импорта)
Режим администратора… | Позволяет перейти в режим работы администратора (Этот пункт меню доступен только в режиме работы оператора)
Защитить паролем… | Позволяет защитить паролем текущий проект (Этот пункт меню доступен только в режиме работы администратора)
Снять пароль… | Позволяет снять защиту паролем с проекта (Этот пункт меню доступен только в режиме работы администратора)
Экспортировать проект… | Экспортирует проект в указанную папку. При экспорте проекта изображения берутся из текущего пакета (Этот пункт меню доступен только в режиме работы администратора).
Обновление проекта… | Устанавливает обновление проекта. Сообщения и ошибки, возникающие при импорте, можно сохранять в файл (правая кнопка мыши - Экспортировать в файл). Этот пункт меню доступен только в режиме работы администратора.
Свойства проекта… | Открывает диалог свойств проекта (Этот пункт меню доступен только в режиме работы администратора)
Collapsed Сервис
Пункт меню | Описание
Обновить до последней версии | Применяет изменения в проекте к обрабатывающимся в данный момент документам
Повторный анализ | Производит повторный анализ документов
Повторное распознавание | Производит повторное распознавание документов
Обновить сборку | Обновляет сборку страниц в документы
Перепроверить правила | Производит повторную проверку правил
Проверить целостность пакета | Производит проверку целостности пакета
Изменить приоритет пакета | Позволяет выбрать приоритет пакета
Изменить тип пакета… | Изменяет тип пакета
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Collapsed Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 11, содержащий краткую информацию о программе.


Панели инструментов главного окна программы ABBYY FlexiCapture

Вы находитесь здесь: Интерфейс программы ABBYY FlexiCapture > Главное окно программы ABBYY FlexiCapture > Панели инструментов главного окна программы ABBYY FlexiCapture

Панели инструментов главного окна ABBYY FlexiCapture

Collapsed Стандартная панель инструментов

Название | Кнопка | Описание
Открыть проект |  | Позволяет открыть другой проект
Сохранить изменения |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Collapsed Представления документов

Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Список тестовых пакетов | Позволяет перейти к списку тестовых пакетов
Список рабочих пакетов | Позволяет перейти к списку рабочих пакетов
Обновить | Обновляет информацию в главном окне
Collapsed Навигация

Предыдущий объект верификации | Осуществляет переход к предыдущему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Следующий объект верификации | Осуществляет переход к следующему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Предыдущий документ | Осуществляет переход к предыдущему документу .
Следующий документ | Осуществляет переход к следующему документу.
Collapsed Обработки

Данная панель инструментов предназначена для прохождения всего процесса обработки документов. Кнопки этой панели инструментов многофункциональны и имеют несколько режимов работы.

Надпись на первой кнопке - кнопке для добавления изображений - меняется в зависимости от выбранного режима и при нажатии на нее производится действие, соответствующее надписи.

Для выбора режима нужно нажать на треугольник справа от кнопки и выбрать соответствующий пункт меню.

Кнопка | Режим | Описание
 | Загрузить изображения… | Позволяет загрузить изображения из файлов и добавить их в текущий пакет
 | Сканировать изображения… | Позволяет добавить изображения в пакет путем сканирования
 | Импортировать изображения… | Позволяет импортировать изображения, используя один из настроенных профилей импорта изображений
 | Список существующих профилей импорта | Для того чтобы начать импорт изображений, достаточно выбрать из списка один из настроенных профилей импорта.
 | Распознать | Запускает процесс распознавания
 | Проанализировать | Анализирует страницы документов, подбирая для них подходящее определение документа
 | Наложить определение… | Производит наложение выбранного пользователем определения на выделенный документ или страницу
 | Начать верификацию… | Запускает процесс верификации
 | Перепроверить правила | Запускает процесс перепроверки правил
 | Экспортировать | Экспортирует данные согласно профилю экспорта, настроенному в определениях документов
 | Экспортировать данные в файлы… | Позволяет произвести экспорт данных в файл
 | Экспорт изображений в файлы | Позволяет произвести экспорт изображений в файл
 | Экспортировать в базу данных… | Позволяет произвести экспорт данных в базу данных


Окно групповой верификации

Окно групповой верификации появляется при запуске процесса групповой верификации.

Это окно предназначено для визуальной проверки символов, распознанных с одинаковым значением. Одинаково распознанные символы выводятся на экран, чтобы можно было легко заметить и исправить выбивающиеся из общей массы символы. См. Групповая верификация.

Меню окна групповой верификации
Панель инструментов окна групповой верификации


Меню окна групповой верификации

Collapsed Очереди и задания
Пункт меню | Описание
Получить задание | Получить новое задание на верификацию данных
Отправить задание в Исключения… | Отправить текущее задание в Исключения
Отменить задание | Отменить текущее задание (в дальнейшем оно вновь будет направлено оператору)
Обновить | Обновить информацию о заданиях
Collapsed Верификация
Пункт меню | Описание
Подтвердить все | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Отложить все | Откладывает верификацию всех символов, помечая их знаком вопроса как сомнительные
Изменить статус | Откладывает верификацию выделенного символа, помечая его знаком вопроса как сомнительный символ
Следующая страница | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Предыдущая страница | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Закрыть | Закрывает окно верификации
Collapsed Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Выделить все | Выделяет все символы
Collapsed Вид
Пункт меню | Описание
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификации
Снизу | Размещает изображение поля в нижней части окна верификации
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Показывать изображение поля | Позволяет показать изображение символа
Панель инструментов | Позволяет показать/спрятать панели инструментов
Панели информации | Позволяет показать/спрятать панель информации
Строка состояния | Позволяет показать/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Collapsed Сервис
Пункт меню | Описание
Опции… | Позволяет настроить вид окрестности символа
Collapsed Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 11, содержащий краткую информацию о программе.


Панели инструментов окна групповой верификации

Collapsed Стандартная панель инструментов

Название | Кнопка | Описание
Предыдущая страница |  | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Следующая страница |  | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Подтвердить все |  | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Изменить статус символа |  | Изменяет статус символа на отклоненный и обратно
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Collapsed Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание на верификацию данных.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию о заданиях
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Окно контекстной верификации

Окно контекстной верификации появляется при начале контекстной верификации.

Это окно предназначено для визуальной проверки неуверенно распознанных символов в контексте всего поля. См. Контекстная верификация.

Меню окна контекстной верификации
Панель инструментов окна контекстной верификации


Меню окна контекстной верификации

Collapsed Очереди и задания
Пункт меню | Описание
Получить задание | Получить новое задание на верификацию данных
Отправить задание в Исключения… | Отправить текущее задание в Исключения
Отменить задание | Отменить текущее задание (в дальнейшем оно вновь будет направлено оператору)
Обновить | Обновить информацию о заданиях
Collapsed Верификация
Пункт меню | Описание
Подтвердить поле | Подтверждает поле
Отложить поле | Откладывает проверку поля
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующее поле | Позволяет перейти к следующему полю
Предыдущее поле | Позволяет перейти к предыдущему полю
Закрыть | Закрывает окно верификации
Collapsed Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Удалить все | Удаляет все объекты
Выделить все | Выделяет все
Вставить перенос строки | Вставляет перенос строки
Объединить символы | Позволяет объединить выделенные символы, если в процессе распознавания какой-либо символ был некорректно разбит на несколько символов
Collapsed Вид
Пункт меню | Описание
Данные поля |
Показывать распознанный текст | Показывает/прячет распознанный текст
Нарезка изображений символов | Переходит в режим показа поля с нарезкой символов
Показывать специальные символы | Показывает/прячет специальные символы
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификации
Снизу | Размещает изображение поля в нижней части окна верификации
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Аналогичные поля | Позволяет показать/спрятать аналогичные поля в других документах
Показать изображение символа | Позволяет отобразить/спрятать изображение символа
Панель инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Панель информации | Позволяет отобразить/спрятать панель информации
Строка состояния | Позволяет отобразить/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Collapsed Сервис
Пункт меню | Описание
Опции… | Позволяет настроить вид окна верификации: вид окрестности символа, шрифт и цвет текста
Collapsed Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 11, содержащий краткую информацию о программе.


Панели инструментов окна контекстной верификации

Collapsed Стандартная панель инструментов

Название | Кнопка | Описание
Предыдущее поле |  | Позволяет перейти к предыдущему полю
Следующее поле |  | Позволяет перейти к следующему полю
Подтвердить/Пропустить поле |  | Позволяет подтвердить корректное распознавание всех символов поля и осуществляет переход к следующему полю. Если значение поля не удовлетворяет формату поля, то название кнопки меняется на Пропустить поле. Если значение поля нельзя исправить, то его проверку можно только отложить,или пропустить.
Отложить поле |  | Позволяет отложить проверку поля, если его невозможно исправить
Предыдущий неуверенно распознанный символ |  | Позволяет перейти к предыдущему неуверенно распознанному символу
Следующий неуверенно распознанный символ |  | Позволяет перейти к следующему неуверенно распознанному символу
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Collapsed Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание на верификацию данных.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию о заданиях
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Что такое ABBYY FlexiCapture for Invoices

ABBYY FlexiCapture for Invoices

  • ABBYY FlexiCapture for Invoices простое в использовании решение для интеллектуальной обработки входящих инвойсов. Оно позволяет заменить утомительный ручной ввод информации понятным, управляемым и эффективным автоматическим вводом данных на основе технологий интеллектуального анализа документов и распознавания символов.
  • ABBYY FlexiCapture for Invoices базируется на мощной технологической платформе ABBYY FlexiCapture, расширенной дополнительной функциональностью, предустановленными настройками, правилами верификации, улучшенным поиском по базам данных и усовершенствованиями в пользовательском интерфейсе, специально предназначенными для обработки инвойсов.
  • ABBYY FlexiCapture for Invoices готовое к использованию решение, которое позволяет сразу же начать обработку поступающих инвойсов. Программа спроектирована таким образом, чтобы точно определять поля данных на большинстве документов без дополнительной подстройки. Умная технология автоматического обучения на лету позволяет улучшить распознавание данных на инвойсах с отличной от основной массы документов разметкой.
  • В ABBYY FlexiCapture for Invoices предусмотрены встроенные правила верификации, настроенные для конкретных стран, регулируемые логические и арифметические проверки, а также проверки по актуальным базам данных компании, что гарантирует полноту данных, соответствие законодательным нормам и облегчает процесс одобрения и выявления неправильно выставленных инвойсов. Гибкость настроек позволяет адаптировать порядок обработки согласно специфическим требованиям бизнеса компании и реализовать сквозную (без вмешательства оператора) обработку инвойсов, прошедших все автоматические правила верификации, что, в свою очередь, дает возможность верификаторам фокусировать свое внимание только на документах-исключениях.

Процесс ввода инвойсов

  1. Импорт изображений

    2. Для обработки инвойсов необходимо загрузить их изображения. Это может быть выполнено следующими способами:

    • сканирование бумажных инвойсов;
    • загрузка инвойсов из ящика электронной почты;
    • загрузка файлов с изображениями инвойсов из папки на компьютере или сервере FTP.
  2. Распознавание, проверка правил

    3. После добавления в программу инвойсы автоматически распознаются. Далее выполняется проверка распознанных данных с помощью предварительно настроенных правил. В результате проверки определяется статус инвойса.

    Статус | Описание
Valid | Проверки правил выполнены успешно, инвойс можно экспортировать
Exception | Инвойс требует проверки
Rejected | Инвойс не соответствует законодательству (необходимые данные не найдены, отсутствуют или были некорректно распознаны). Необходимо указать данные либо обработать инвойс особым образом (например, вернуть поставщику)

    Документы со статусом Valid могут быть экспортированы без исправления.

  3. Проверка и исправление ошибок

    4. Инвойсы с другими статусами требуют внимания оператора. Оператор просматривает каждый документ, исправляет ошибки и предупреждения, полученные при проверке правил. При исправлении всех недочетов статус инвойса меняется на Valid. Также оператор может подтвердить автоматически определенный статус. При необходимости статус инвойса может быть указан вручную, при этом необходимо указать основание для смены статуса.

    При возникновении систематических ошибок обнаружения полей на изображениях инвойсов, оператор имеет возможность обучить программу прямо в процессе ввода документов.

  4. Экспорт данных

    5. Заключительный этап обработки инвойсов. Распознанные данные экспортируются в соответствии с указанными настройками в зависимости от статуса (инвойсы со статусами Valid и Exception могут экспортироваться отдельно от инвойсов со статусом Rejected). При необходимости можно настроить несколько направлений экспорта, в этом случае один инвойс будет экспортирован несколько раз.

    Если статус инвойса был изменен вручную, указанные при этом обоснования также будут экспортированы.

    Программа поддерживает экспорт в файлы данных и изображений, в ODBC-совместимые базы данных, Microsoft SharePoint, а также имеет удобный API для интеграции с любыми системами.

Подробнее о том, как вводить инвойсы с помощью ABBYY FlexiCapture for Invoices: См. "Как вводить инвойсы".


Дополнительные возможности ABBYY FlexiCapture for Invoices

Распознавание и извлечение данных

Гибкое описание, специально настроенное под обработку инвойсов

ABBYY FlexiCapture for Invoices включает в себя готовое к использованию гибкое описание, специально адаптированное для незамедлительной обработки инвойсов. Оно имеет предопределенный набор полей данных для распознавания, который может быть расширен за счет дополнительных полей. Это гибкое описание позволяет извлекать все необходимые поля данных с большинства документов без дополнительной настройки или применения имеющихся возможностей обучения системы.
Настройки, зависимые от страны

В ABBYY FlexiCapture for Invoices имеется предварительно заданный набор правил обработки и других настроек, зависящих от конкретной страны, который применяется к инвойсу после того, как программа идентифицирует страну подразделения компании, которому он выставлен. Автоматические правила верификации гарантируют соответствие данных обычаям и юридическим нормам конкретной страны.

Готовые к использованию настройки доступны для списка поддержанных стран, который включает Австрию, Бельгию, Францию, Германию, Нидерланды, Испанию, Швейцарию и Великобританию. В ходе настройки системы новый профиль может быть добавлен пользователем для любой другой страны.
Правила верификации

Проверки с помощью предварительно заданных правил верификации гарантируют полноту данных и помогают выявить неправильные или неполные инвойсы, а также проблемные поля. Ошибки, установленные в ходе автоматических проверок с помощью правил, влияют на статус документа, что позволяет легко отсортировать полностью корректные документы от исключений, требующих отдельной обработки.

Ошибки, найденные в ходе проверок с помощью правил, на этапе верификации сопровождаются краткими комментариями, поясняющими их суть.
Определение статуса документа

Каждый инвойс получает один из трех возможных статусов, присваиваемых документу автоматически на основе результатов проверок с помощью правил верификации. Определение статуса документа упрощает классификацию инвойсов и позволяет реализовать сквозную обработку полностью корректных документов.

Инвойсам без ошибок присваивается статус Valid, инвойсам с незначительными ошибками и требующим особого внимания — статус Exception, инвойсам, не соответствующим законодательным нормам или с неполными данными, присваивается статус Rejected.

Статус документа автоматически меняется на Valid как только все ошибки были исправлены. Оператор может подтвердить присвоенный статус или принудительно его изменить, указав причины своего решения в поле для комментария. Для инвойсов со статусом Rejected может быть указано отдельное назначение экспорта.
Улучшенный поиск по базам данных

В процессе распознавания программное обеспечение проводит сравнение данных инвойса с актуальными пользовательскими базами данных поставщиков и подразделений компании. Если были найдены нужные записи в базах данных, поля автоматически заполняются значениями из этих баз данных. Если не было найдено ни одной записи (или несколько записей сразу), оператор может выбрать правильную запись вручную.
Проверка позиций инвойса

На этапе верификации данные инвойса могут быть проверены по текущим заказам, если настроено соединение с базой данных заказов или контрактов. В этом случае оператор может открыть соответствующий заказ из базы данных, сравнить данные заказа с указанными в инвойсе и подтвердить соответствие данных, извлеченных из этого поля.

Технология обучения на лету

Обучение оператором

Для улучшения нахождения полей данных в ABBYY FlexiCapture for Invoices предусмотрена технология обучения на лету, благодаря которой программа запоминает изменения, сделанные пользователем на этапе верификации, и автоматически улучшает гибкое описание новыми альтернативами гибкого описания.
Обучение администратором

Распознавание данных может быть дополнительно усовершенствовано за счет проверки результатов, достигнутых в ходе обучения оператором. Администратор имеет возможность проанализировать, откатить назад или адаптировать эти результаты, просмотреть и изменить набор документов, на котором проводилось обучение, а также деактивировать или активировать альтернативы, созданные в результате обучения оператором.

Пользовательский интерфейс верификации

Специально разработанная форма верификации данных

Интуитивно понятный интерфейс верификации ABBYY FlexiCapture for Invoices тщательно продуман для работы именно с данным типом документов. Поля данных на форме верификации сгруппированы и расположены наиболее подходящим для инвойсов образом. Ключевые поля сопровождаются показом области исходного изображения. Для быстрых и точных правок необходимые поля помечены цветом, а на экран выводятся сообщения о предупреждениях и ошибках вместе с пояснениями.

Форму верификации данных, а также порядок, в котором осуществляется проверка полей, можно легко настроить под нужды пользователя или в соответствии с устоявшейся практикой.

Настройка

Профиль страны

Такие настройки как язык, валюта, форматы даты, форматы чисел, правила верификации, налоговые ставки и т.д. зависят от страны. В ABBYY FlexiCapture for Invoices для списка поддержанных стран предусмотрены настройки по умолчанию, которые пользователь может изменить при необходимости.

Пользователь может легко добавить новый профиль и указать нужные настройки для любой другой страны, для которой в программе на данный момент нет настроек по умолчанию.


Как вводить инвойсы

Процесс ввода инвойсов включает следующие шаги:

  • Добавление изображений и их распознавание
  • Верификация и исправление ошибок распознавания
  • Экспорт проверенных данных


Добавление изображений и распознавание

Добавление изображений

Процесс обработки инвойсов начинается с добавления изображений документов.

Это можно сделать несколькими способами:

  • Сканировать бумажные документы с помощью персонального сканера;
  • Добавить ранее отсканированные изображения из папки;
  • Воспользоваться профилем загрузки изображений, который заранее настроил администратор (импорт изображений со сканера, из горячей папки в файловой системе или из почтового ящика.)

Подробнее о каждом из способов загрузки изображений См. "Добавление изображений страниц".

Распознавание

После того, как изображения будут добавлены, автоматически начнется их распознавание.

Распознанный документ имеет название European Invoice, столбцы Статус инвойса, Уверенность заполнены.

Collapsed Если документы не распознаются автоматически

Выделите документы, выберите пункт меню Распознавание>Распознать.

Чтобы добавленные изображения распознавались автоматически, отметьте опцию Автоматически распознавать добавленные изображения на вкладке Обработка документов (Сервис>Опции…).

Collapsed Если после распознавания документ имеет название <Неизвестный>
  1. Просмотрите причину, по которой документ не был распознан, в столбце Предупреждения и ошибки.

    Пример: Check the recognition language: язык инвойса не поддерживается ABBYY FlexiCapture for Invoices. Обратитесь к администратору.

  2. При необходимости откройте документ и убедитесь, что он является инвойсом.
  3. Наложите определение документа вручную.
    4. Collapsed Как наложить определение документа вручную
    1. Выберите в контекстном меню данного документа пункт Наложить определение документа…. Будет открыто окно со списком определений документов.
    2. Выберите в списке значение European Invoice и нажмите кнопку ОК.


Верификация

На данном этапе необходимо просмотреть документы, нуждающиеся в проверке и исправить ошибки и предупреждения.

Критерии проверки

  • статус, отличный от Valid (см. столбец Статус инвойса в списке документов)

  • наличие ошибок правил (красный флажок на значке документа)

  • объектов на верификацию>0 (см. столбец Символы для верификации в списке документов)

Чтобы начать проверку, откройте документ, требующий верификации, в редакторе документа.


Статусы инвойсов

Результатом проверки с помощью правил и/или оператором является статус документа (столбец Статус инвойса в главном окне со списком документов).

Статус | Описание
Valid | Проверки правил выполнены успешно, инвойс можно экспортировать
Exception | Инвойс требует проверки
Rejected | Инвойс не соответствует законодательству (необходимые данные не найдены, отсутствуют или были некорректно распознаны). Необходимо указать данные либо обработать инвойс особым образом (например, вернуть поставщику)

Статус рассчитывается автоматически на основе системы правил. После исправления ошибок правила проверяются повторно и статус инвойса автоматически изменяется. Подробнее о правилах в проекте ABBYY FlexiCapture for Invoices См. "Список правил".

Если инвойс содержит ошибки, которые не удается исправить, необходимо подтвердить статус, отличный от Valid. Такие инвойсы будут экспортированы отдельно от правильно заполненных (в соответствии с настройками, указанными администратором).

При необходимости можно изменить статус инвойса вручную: возможно, для экспорта инвойса не требуется выполнение абсолютно всех правил, в этом случае необходимо выбрать статус Valid. Или наоборот, соответствующий правилам инвойс не должен быть экспортирован, в этом случае необходимо выбрать статус Rejected или Exception.

Collapsed Изменение статуса инвойса

Текущий статус и описание ошибки правила, его определяющего, расположены в верхней части Формы данных. Также там может быть указана причина смены статуса вручную. Чтобы изменить статус, выполните следующие действия:

  1. Нажмите кнопку [image] справа от статуса.
  2. Выберите статус, который необходимо установить.
  3. Выберите причину смены статуса из списка или введите собственную (если ввод собственных причин не запрещен администратором).


Исправление ошибок распознавания

Во время верификации необходимо проверить инвойсы со статусом Exception и Rejected и устранить ошибки. Чтобы начать верификацию, наведите курсор мыши на инвойс и дважды нажмите левую клавишу. Будет открыто окно редактора документа.

Окно редактора документа разделено на три части: изображение страницы, Форма данных и окно ошибок (данный раздел отображается только при наличии ошибок в инвойсе). Существует четыре вида ошибок: ошибки сборки, ошибки не найденного региона для поля, ошибки формата и ошибки правил. Для отображения ошибок определенного вида нажмите соответствующую кнопку в верхней части окна ошибок (допускается выбор любой комбинации видов ошибок).

Контекстное меню Формы данных позволяет подтвердить значение поля, включить или отменить показ ошибок формата, перейти к предыдущему или следующему объекту, требующему верификации, и изменить режим навигации по полям.

Поля, распознанное значение которых не удовлетворяет указанному типу данных или правилам, подсвечены. Для подтверждения поля поместите в него курсор и нажмите клавишу Enter.

Чтобы указать регион поля, который не был найден автоматически, выполните следующие действия:

  1. Поместите курсор в поле на форме данных, регион которого необходимо указать.

  2. Укажите на изображении регион поля:
    • Наведите курсор мыши на распознанный регион (он подсвечивается синим цветом) и нажмите левую клавишу мыши

      • или

    • Нарисуйте регион, наведя курсор мыши на левый верхний угол, нажав левую клавишу мыши и, удерживая ее, переместив курсор в правый нижний угол региона.

    Замечание. Если выбрать или нарисовать регион, не выбрав предварительно поле, приложение откроет список доступных полей, из которого необходимо выбрать нужное.

Если при настройке комплекса Администратор создал набор данных с информацией о поставщиках и / или подразделениях компании, можно выбрать запись из него (См. "Поиск в базе данных информации о поставщике и подразделении").


Поиск в справочнике информации о поставщике и подразделении

Вы находитесь здесь: Работа с ABBYY FlexiCapture for Invoices > Как вводить инвойсы > Верификация > Поиск в справочнике информации о поставщике и подразделении

Поиск в базе данных информации о поставщике и подразделении

Если поставщик (подразделение компании) не был определён автоматически в процессе распознавания инвойса, у вас есть возможность выбрать запись из базы данных.

Для этого вы можете:

Collapsed начать вводить значение в одном из полей группы

Будет показан выпадающий список с похожими записями, а совпадения с введённым текстом будут выделены жирным шрифтом.

Нет разницы, в каком конкретно поле группы какая информация была набрана. Например, в поле с названием компании можно начать вводить название улицы.

После того, как запись найдена, выберите её в выпадающем списке:

  • кликните нужную запись с помощью мыши;
  • выберите с помощью клавиш стрелка вниз или вверх. Нажмите клавишу Enter.

Поля записи будут подставлены в соответствующие поля группы на форме.

Если вы не можете найти нужную запись в выпадающем списке, выберите запись Поставщик (Подразделение) не найден или нажмите сочетание клавиш Ctrl+Del — все поля группы будут очищены от значений.

Collapsed нажать кнопку Find... на форме группы

Откроется диалог Поиск поля Поставщик (Подразделение), в котором вам необходимо выбрать нужную запись.

Начните печатать значение в поле для ввода диалога. В списке справа будут показываться все записи, в которых найдены похожие вхождения (вхождения будут выделены полужирным шрифтом), слева будут отображаться все поля текущей записи.

Выберите нужную запись и с помощью мыши или клавиш стрелка вниз или вверх и нажмите кнопку Выбрать. Поля записи будут подставлены в соответствующие поля группы на форме.

Если вы не можете найти нужную запись в диалоге, нажмите кнопку Удалить данные — все поля группы будут очищены от значений.

Редактирование существующих и добавление новых записей о поставщиках и получателях

Для ввода инвойсов необходима информация о поставщиках и подразделениях. Группы полей Поставщик и Подразделение компании являются основными. Автоматическая обработка (распознавание) инвойса начинается с поиска поставщика и подразделения. Если они не найдены на изображении, ваш инвойс не будет обработан.

Для поиска этих полей на изображении инвойса используется информация из вашего списка поставщиков и подразделений. Этот список представляет собой локальную копию внешней базы данных, в которой хранится информация о поставщиках и подразделениях. Периодически эта локальная копия синхронизируется с внешней базой данных.

Если по каким-либо причинам вы не смогли найти записи о поставщике или подразделении в локальной копии базы данных, их необходимо добавить вручную. Это нужно для того, чтобы поля автоматически находились на инвойсах.

Аналогично, при изменении каких-либо данных (например, изменился адрес поставщика), необходимо внести изменения в локальную копию базы данных.

Collapsed Как добавить новую запись в локальную копию базы данных
  1. Заполните поля группы Поставщик / Подразделение.
  2. Нажмите кнопку Сохранить изменения или Ctrl+S.

Запись будет добавлена в локальную копию базы данных (но не во внешнюю базу данных!). Поля будут подсвечены зеленым цветом. В поле Id на форме документа будет указано UNKNOWN. Это означает, что такая запись есть только в локальной копии базы данных, во внешней базе данных эти данные пока отсутствуют.

Инвойсу будет присвоен статус Exception. Все последующие инвойсы от этого поставщика будут иметь такой же статус.

Как только запись о новом поставщике будет добавлена во внешнюю базу данных, в поступающих инвойсах будет заполнено поле Id.

Collapsed Как отредактировать существующую запись в локальной копии базы данных
  1. Измените данные в нужных полях.
  2. Нажмите кнопку Сохранить изменения или Ctrl+S.


Верификация позиций инвойса

ABBYY FlexiCapture автоматически извлекает позиции инвойса (Line Items), если соответствующая функциональность включена Администратором и разрешена лицензией.

В том случае, если автоматическое извлечение позиций не сработало, или позиции извлечены не полностью корректно, ABBYY FlexiCapture предлагает несколько инструментов для ручного извлечения и улучшения качества автоматического извлечения позиций.

Позиции инвойса (Line Items) состоят из набора отдельных позиций (Line Item), а каждая позиция включает в себя поля позиции, такие как Номер заказа, Артикул, Описание, Количество, Цена за ед., Итоговая сумма и т.д. (См. "Список полей определения документа для обработки инвойсов").

Поиск позиций

Команда Продолжить позиции, доступная в контекстном меню региона поля позиции, вызывает попытку повторного наложения позиций ниже текущей строки.

При повторном наложении позиций используется информация о разметке регионов полей текущей строки и предыдущих, которая задана (или скорректирована) пользователем.

Если разметка позиций наложилась неверно, оператору требуется:

  • нарисовать охватывающий прямоугольник первой позиции
  • отметить все поля первой позиции
  • из контекстного меню любого поля первой позиции выбрать пункт Продолжить позиции.

После этого программа автоматически наложит оставшиеся позиции. Для улучшения результата наложения позиций будет использована информация о положении первой позиции и о расположении регионов полей внутри позиции.

Если результат нахождения позиций все равно неудовлетворительный, необходимо:

  • исправить положение первой неверно наложенной позиции
  • указать поля данной позиции
  • вызывать команду Продолжить позиции для данной позиции.

После этого программа автоматически наложит оставшиеся позиции. В этом случае для улучшения результата наложения будет использована информация о текущей позиции и обо всех позициях выше текущей.

Если результат нахождения позиций все равно неудовлетворительный, необходимо вручную нарисовать охватывающий прямоугольник всех позиций и задать разбиение на позиции горизонтальными сепараторами.

Поиск полей в позициях

Если разметка позиций задана верно, но не все поля были найдены правильно внутри позиций, оператор может использовать команду Повторно проанализировать позиции ниже, доступную в контекстном меню региона позиции.

Данная команда учитывает расположение полей в позициях текущей строки и строк выше, которое считается заданным (или скорректированным) пользователем, и, используя данную информацию, располагает поля в позициях ниже текущей.

Если разметка позиций задана верно, но не все поля были найдены правильно внутри позиций, оператору нужно:

  • расположить верно регионы полей внутри первой позиции
  • из контекстного меню региона позиции выбрать пункт Повторно проанализировать позиции ниже

После этого программа автоматически наложит поля внутри оставшихся позиций, не изменяя положения самих позиций. Для улучшения результата наложения позиций будет использована информация о положении регионов полей внутри первой позиции.

Если результат нахождения полей внутри позиций все равно неудовлетворительный, необходимо:

  • исправить положение полей внутри первой позиции, где поля расположены неверно
  • вызывать команду Повторно проанализировать позиции ниже для данной позиции.

После этого программа автоматически наложит поля внутри оставшихся позиций, не изменяя положения самих позиций. Для улучшения результата наложения позиций будет использована информация о положении регионов полей внутри текущей позиции и всех позиций выше.

Замечание. Для работы команд Продолжить позиции и Повторно проанализировать позиции ниже необходимо, чтобы была определена страна поставщика или получателя инвойса, т.е. было заполнено соответствующее поле на форме данных.

Ручная разметка позиций

ABBYY FlexiCapture позволяет нарисовать разметку позиций вручную.

Для этого необходимо нарисовать обхватывающий прямоугольник позиций на изображении и выбрать из выпадающего меню пункт Позиции[*].

Далее,удерживая левую клавишу мыши, или с помощью специального инструмента Нарисовать разделитель (F) необходимо создать горизонтальные сепараторы, разделяющие положение разных позиций.

Расположение позиций на изображении очень разнообразно.

Часто некоторые колонки могут быть отделены вертикальными сепараторами от остальных полей. В этом случае создайте вертикальные сепараторы, отделяющие колонки от полей по принципу "в каждой колонке — одно поле". Кликните по разметке позиций (сепаратору или охватывающему прямоугольнику), при этом в заголовке колонки появится зеленый плюсик. Нажмите на плюсик и выберите из списка название данной колонки — внутри колонки будут автоматически созданы соответствующие поля.

Другие колонки (например, Описание, Артикул) могут быть расположены в одной колонке на изображении. В этом случае вы можете отмечать поля, просто нажимая на них или обводя их регионы на изображении мышью.

Создайте регионы для полей первой позиции внутри колонки. Когда вы будете создавать регионы полей следующих позиций внутри данной колонки, программа будет автоматически подсказывать поля, регионы которых вы создаете, учитывая информацию из предыдущих позиций.

Обучение позиций

После того, как разметка всех позиций инвойса и регионов полей внутри позиций задана верно, она может быть использована для обучения программы для улучшения качества автоматического извлечения позиций из следующих инвойсов от данного поставщика.

Оператору требуется убедиться в правильности заданной разметки инвойсов на всех страницах инвойса и нажать кнопку [image].

Администратор может обучать позиции инвойсов в режиме административного обучения (См. "Обучение в процессе ввода инвойсов") аналогично другим полям.

Замечание. Для возможности обучения извлечения позиций инвойса необходимо, чтобы был определен поставщик инвойса.

Работа с позициями на форме данных

Позиции инвойса отображаются в виде таблицы Line Items на форме данных.

По умолчанию на форме данных отображаются колонки, поля которых найдены на изображении, либо обязательное отображение которых включено Администратором в настройках определения документа.

Оператор может настроить отображение колонок под себя: нажмите правой клавишей мыши на заголовок таблицы на форме данных и в контекстном меню отметьте галочками те колонки, которые должны отображаться на форме всегда, даже если их поля не найдены.

Для добавления новых или удаления существующих позиций на форме данных используйте пункты контекстного меню, которое вызывается при нажатии правой клавиши мыши по столбцу с левого края позиций: Вставить экземпляр 'Позиции' выше/Вставить экземпляр 'Позиции' ниже и Удалить.

В контекстном меню поля позиции наряду со стандартными командами, доступными для любых полей на форме данных, есть команды:

  • Копировать значение для всех строк — копирует значение текущей ячейки во все ячейки текущей колонки,
  • Копировать значение для диапазона строк — копирует значение текущей ячейки в выбранные ячейки текущей колонки.


Обучение при вводе инвойсов

В случае, если ABBYY FlexiCapture for Invoices автоматически извлекает поля с недостаточным качеством, например, на примерах инвойсов со специфическим расположением полей вы может дообучить программу прямо в процессе ввода инвойсов.

Для этого вам будет необходимо указывать правильное расположение полей на изображении и нажимать кнопку [image]. После того, как наберётся хотя бы три изображения данной разновидности инвойса, программа выполнит обучение и последующие инвойсы данной разновидности будут обрабатываться с использованием результатов обучения.

Внимание! Функция обучения в процессе ввода должна быть разрешена администратором.

Как обучать программу в процессе ввода

  1. Возьмите пачку инвойсов (например, ваши инвойсы за последний месяц) и начните их ввод. См. "Как вводить инвойсы".
  2. После добавления в программу документы автоматически распознаются (если данная опция включена администратором) и проверяются с помощью правил.
  3. Если получившийся в результате статус инвойса отличается от Valid или у вас есть какие-то иные основания предполагать, что поля на изображения не были найдены программой или были найдены неверно, откройте документ в редакторе документа.
  4. Просмотрите форму документа. Группа полей Поставщик должна быть заполнена корректно.
Collapsed Подробнее

Обучение документов работает независимо для каждой разновидности документов. Инвойсы от одного поставщика считаются одной разновидностью документов. Если поставщик будет определён неправильно, то при обучении документ будет отнесён не к своей разновидности. Если поставщик не нашелся, выберите его с помощью поиска поставщиков в базе данных (Поиск поля Поставщик). Если поставщика не удаётся найти в базе данных, заполните формы полей группы Поставщик, введя данные с изображения, и сохраните в базу данных, нажав кнопку Сохранить изменения.

В зависимости от настроек проекта ABBYY FlexiCapture for Invoices, чтобы обучение стало доступно для данного инвойса, может потребоваться также указать уникальный идентификатор поставщика: заполнить значение поля VATID (в локализованной на ваш язык версии проекта поле может иметь другое название). VATID — это уникальный идентификационный номер компании для уплаты налогов. .

  5. Для обучения необходимо, чтобы разметка регионов всех полей на изображении соответствовала реальному расположению полей инвойса. Поэтому ваша цель — обеспечить правильное расположение регионов полей на изображении.

Для этого в окне изображения редактора документа исправьте разметку регионов полей или нарисуйте регионы для тех полей, которые не наложились вовсе.

Collapsed Как редактировать разметку регионов полей
  • поместить курсор в нужное поле на форме данных, на изображении найти соответствующий регион (он подсвечивается синим цветом), кликнуть по нему (или нарисовать разметку региона мышью);
  • поместить курсор над нужным регионом на изображении (он подсвечивается синим цветом), кликнуть по нему (или нарисовать регион мышью), из появившегося списка выбрать соответствующее поле;
  • на изображении исправить местоположение региона, передвигая при помощи мыши его границы;
  • на изображении удалить существующий регион, для чего навести курсор на его разметку, в верхнем правом углу появится красный крестик, кликнуть на него — разметка региона будет удалена. После этого создать регион для данного поля в нужном месте;
  • на форме данных начать ввод значения в поле с клавиатуры, при этом появится выпадающий список, который будет содержать все слова, распознанные на изображении и похожие на вводимое значение. Выберите значения из списка, и позиция слова на изображении станет регионом поля.
  6. Если все поля документа теперь размечены правильно, нажмите кнопку [image] — документ будет добавлен в набор примеров данной разновидности инвойсов.

Кнопка [image] становится доступна для нажатия, если выполнены все необходимые для обучения условия:

  • изменена разметка хотя бы одного региона на изображении

Внимание! Обучение для регионов полей, которые были удалены, не работает.

  • данные о поставщике заполнены корректно.

Если кнопка [image] недоступна, то при наведении курсора мыши на кнопку появляется подсказка с описанием причины недоступности кнопки.

При нажатии на кнопку в обучении будут участвовать все поля инвойса, а не только те, разметку для регионов которых вы нарисовали или изменили. Поэтому важно нажимать кнопку [image] только в случае, когда все регионы всех полей правильно расположены на изображении.

После того, как в набор примеров разновидности инвойсов будет добавлен хотя бы один инвойс, для следующего документа данной разновидности кнопка [image] будет доступна сразу. Это сделано для того, чтобы у вас была возможность пополнить набор примеров разновидности также и теми инвойсами, на которых все поля находятся правильно и нет необходимости исправлять какую-либо разметку на изображении.

  7. Перейдите к следующему документу и выполните действия из пунктов 4 – 6.
  8. При добавлении в набор третьего и всех последующих инвойсов от одного и того же поставщика запустится процесс обучения — пользователю будет показано окно Обучить определение документа, т.е. для данной разновидности инвойсов будет либо обучено специальное гибкое описание (разновидность гибкого описания), либо программа предложит продолжить накопление примеров (в этом случае перейдите к следующему документу и вернитесь к шагу 4).

Если гибкое описание для альтернативы было успешно обучено, то уже на следующем инвойсе от поставщика, определяющего данную разновидность инвойсов, оно начнёт применяться — после распознавания регионы полей будут наложены на изображение инвойса с учётом результатов обучения.

Кнопка [image] вернётся в обычный режим работы — будет доступна для нажатия только после того, как была изменена разметка хотя бы одного региона поля на изображении.

Теперь накоплено достаточное число примеров разновидности инвойса. Обучение будет запускаться при каждом добавлении нового изображения в набор (при каждом нажатии кнопки [image]). Нажимайте эту кнопку только в случае, если какие-либо из регионов полей наложились неверно, и их положение пришлось исправлять на изображении.

  9. Введите ещё несколько инвойсов от поставщика, для которого обучение было успешно выполнено. После распознавания откройте каждый новый документ в редакторе документа и проверьте правильность расположения разметки регионов полей. В случае если все регионы располагаются правильно, обучение можно считать законченным.

Если по каким-то причинам ожидаемого результата достигнуть не удалось, продолжите обучение на введённых инвойсах от данного поставщика (шаги 4 – 6).


Экспорт данных

После того, как данные будут проверены, их необходимо экспортировать.

Чтобы экспортировать данные в соответствии с настройками, указанными администратором, нажмите кнопку Экспорт главной панели инструментов.

Замечание. Также можно выполнить экспорт вручную. Для этого нажмите кнопку ▼ справа от кнопки Экспорт и выберите один из пунктов меню:

  • Экспорт в файлы данных — для экспорта данных в файлы;
  • Экспорт в файлы изображений — для экспорта изображений в файлы;
  • Экспорт в ODBC-совместимую базу данных — для экспорта в базу данных.

Подробнее о вариантах экспорта См. "Экспорт распознанных данных".


Спецификации

В данном разделе находится информация о проекте ABBYY FlexiCapture for Invoices:

См. "Список поддерживаемых языков и стран"

См. "Список полей определения документа для обработки инвойсов"

См. "Список правил"

См. "Глоссарий"


Список поддерживаемых языков и стран

Список поддерживаемых стран:

  • Австрия
  • Бельгия
  • Великобритания
  • Германия
  • Ирландия
  • Испания
  • Италия
  • Нидерланды
  • Польша
  • Франция
  • Чехия
  • Швейцария

Список поддерживаемых языков:

  • Английский
  • Нидерландский
  • Испанский
  • Итальянский
  • Немецкий
  • Польский
  • Французский
  • Чешский


Список полей определения документа для обработки инвойсов

Группа полей Наименование полей
Business Unit
  • Business Unit ID
  • Street
  • Postal Code
  • City
  • Country
  • VATID
  • Name
Vendor
  • Vendor ID
  • VATID
  • National VAT
  • IBAN
  • Bank Code
  • Bank Account
  • Street
  • ZIP
  • City
  • Country
  • Name
Группа полей Invoice Header
  • Invoice Type (Invoice/Credit Note)
  • Invoice Number
  • Invoice Date
  • Delivery Date*
  • Delivery Date Indicator*
  • Due Date*
  • Purchaser Name*
Группа полей Amounts
  • Total
  • Currency
  • Reversed Charge
  • Summary
  • Taxes
  • Net Amount 0

  • Net Amount 1
  • Tax Rate 1
  • Tax Amount 1

  • Net Amount 2
  • Tax Rate 2
  • Tax Amount 2

  • Total Tax Amount
  • Total Net Amount
  • Additional Tax Groups
  • NetAmount
  • Tax Amount
  • Tax Rate
  • Additional Costs
  • Additional Cost 1
  • Additional Cost 2
  • Total Additional Cost

Группа полей Purchase Order*
  • Order Number
  • Total
Группа полей Line Items*
  • Order Number
  • Order Date
  • Position
  • Article Number
  • Article NumberBU
  • Material Number
  • Material NumberBU
  • Description
  • Quantity
  • Quantity Undelivered
  • Quantity Ordered
  • Unit of Measurement
  • Unit Price
  • Unit Price Denominator
  • Discount Percentage
  • Discount Value
  • Total Price Netto
  • VAT Percentage
  • VAT Value
  • VAT Code
  • Total Price Brutto
  • Currency
  • Delievery Date
  • Order Item Id

Знаком * отмечены дополнительные поля, которые не извлекаются по умолчанию.


Список правил

Правила автоматической проверки инвойсов

Любые преднастроенные правила могут быть отключены пользователем в настройках определения документа. Также пользователь может создать свои правила.

Группы полей | Правило | Описание | Влияние на статус инвойса | Включено по умолчанию
Business Unit | Information about business unit must be added to database | Правило проверяет, было ли добавлено в базу данных новое подразделение компании, которое было найдено на изображении и добавлено в Набор данных. | Rejected | Да
 | Business Unit's address is required | Правило проверяет, заполнено ли поле BU\Street. | Rejected | Да
 | Business Unit's name is required | Правило проверяет, заполнено ли поле BU\Name. | Rejected | Да
 | Business Unit's VATID is required | Правило проверяет, заполнено ли поле BU\VATID. * Правило применяется к инвойсам из всех поддерживаемых странах, за исключением Швейцарии. | Rejected | Да
 | Business Unit must be found in database | Правило проверяет, найдено ли подразделение компании в Наборе данных. | Rejected | Да
 | Business Unit's Country is required | Правило проверяет, заполнено ли поле BU\Country. | Rejected | Нет
 | Check tax rates on national invoices | Проверяет правильность применённых налоговых ставок на инвойсах внутри одной страны: для каждой страны известны разрешенные налоговые ставки и период их действия. | Rejected | Да
 | Check tax rate field on international invoices | Проверяет правильность применённых налоговых ставок на международных инвойсах: для каждой страны известны разрешенные налоговые ставки и период их действия. | Exception | Да
Vendor | Vendor address is required | Правило проверяет, заполнено ли поле Vendor\Street. | Rejected | Да
 | Vendor name is required | Правило проверяет, заполнено ли поле Vendor\Name. | Rejected | Да
 | Vendor VATID is required | Правило проверяет, заполнено ли поле Vendor\VATID. * Правило применяется к инвойсам из всех поддерживаемых странах, за исключением Швейцарии. | Rejected | Да
 | Vendor must be found in database | Правило проверяет, присутствует ли поставщик, найденный на изображении инвойса, в Наборе данных Vendors. | Exception | Да
 | Vendor details must be added to database | Данное правило проверяет, был ли добавлен в базу данных новый поставщик, который был найден на изображении и добавлен в Набор данных. | Exception | Да
 | Vendor's bank details are required | Правило проверяет, соответствуют ли IBAN, Банковский код и Банковский счет значениям в Наборе данных Vendors. | Не влияет | Да
 | Check vendor's bank details against database | Проверяет, что банковские реквизиты поставщика, найденные на изображении, соответствуют реквизитам в Наборе данных поставщиков Vendors. | Не влияет | Да
Invoice Header Data | Invoice number is required | Правило проверяет, заполнено ли поле Invoice Number. * Правило применяется к инвойсам из всех поддерживаемых странах, за исключением Швейцарии. | Rejected | Да
 | Invoice date is required | Правило проверяет, заполнено ли поле Invoice Date. | Rejected | Да
 | Delivery date is required | Правило проверяет, заполнено ли поле Delivery Date. Правило не действует, ели указан Delivery Date Indicator. | Rejected | Нет
 | Delivery date must not be earlier than Invoice date | Выполняется следующая проверка: Дата доставки находится в пределах интервала Delivery Date <= Invoice Date. | Exception | Нет
 | Delivery date must not be earlier than a year ago | Выполняется следующая проверка: Дата доставки находится в пределах интервала Сегодня - 360 дней <= Delivery Date | Exception | Нет
 | Check currency value | Проверяет, что валюта соответствует списку допустимых настройками проекта валют. | Rejected | Да
Amounts | Total is a required field | Правило проверяет, заполнено ли поле Total. | Rejected | Да
 | Currency is required | Правило проверяет, заполнено ли поле Currency. | Rejected | Да
 | VAT rates check for national invoice | Правило проверяет соответствие ставок НДС, найденных на изображении инвойса, ставкам НДС страны (в соответствии с указанными в настройках). | Rejected | Да
 | Tax Rate field must not be empty | Если либо Net Amount, либо Tax Amount заполнены, то соответствующее поле Tax Rate заполнено. | Rejected | Да
 | If tax rate is detected, pre-tax amount is required | Правило проверяет, заполнены ли для каждой найденной налоговой ставки соответствующие поля Net Amount и Tax Amount, а также убеждается, что Tax Amount = (Tax Rate/100) × Net Amount. * Правило применяется только к инвойсам из Германии. | Rejected | Да
 | If tax rate is found, tax amount is required | Проверяет, что если на изображении найдена налоговая ставка, то заполнено поле TotalTax соответствующей налоговой группы. | Rejected | Да
 | Total Tax is required field | Правило проверяет, заполнено ли поле Amounts\Total Tax Amount. * Правило применяется к инвойсам из всех поддерживаемых странах, за исключением Германии. | Rejected | Да
 | Check Tax field | Проверяет для каждой налоговой группы, что значение суммы налога (TaxAmount) указано правильно для данной суммы до налогообложения (NetAmount) и налоговой ставки (TaxRate), т.е. что выполняется условие TaxAmount = NetAmount * TaxRate. | Exception | Да
 | Check Total Tax field | Выполняется следующая проверка: Total Tax Amount = Tax Amount 1 + Tax Amount 2. * Правило применяется к инвойсам из всех поддерживаемых странах, за исключением Германии. | Exception | Да
 | Check Net Total field | Выполняется следующая проверка: Total Net Amount = Net Amount 0 + Net Amount 1 + Net Amount 2. Если поле Total Net Amount не заполнено, это правило вводит данные в поле согласно расчетам. | Exception | Да
 | Check Total field if total tax amount is required | Проверяет, что сумма всех сумм до налогообложения (NetAmount0, NetAmount1, NetAmount2), суммы налогов (TotalTaxAmount) и дополнительных начислений (AdditionalCosts) равна сумме инвойса (Total). * Правило применяется для всех стран подразделений компании, кроме Германии. | Exception | Да
 | Check Total field if total tax amount is optional | Проверяет, что сумма всех сумм до налогообложения (NetAmount0, NetAmount1, NetAmount2), суммы налогов (TaxAmount1, TaxAmount2) и дополнительных начислений (AdditionalCosts) равна сумме инвойса (Total). * Правило применяется для страны подразделения компании Германия. | Exception | Да
 | Verify net total against order items | Сверяет сумму значений колонки TotalPriceNetto таблицы позиций счёта (LineItems) инвойса с суммой инвойс до налогообложения (TotalNetAmount). | Не влияет | Нет
Purchase Order | Check against database of orders | Проверяет значение найденного номера (PONumber) и суммы (Netto) заказа по Набору данных заказов PurchaseOrders. | Не влияет | Нет
 | Collect matched order items (necessary for proper work of PO Matching at items level) | Cобирает список позиций заказа, которые уже сопоставлены позициям инвойса. Это необходимо, чтобы при ручном сопоставлении позиций показывать оператору список только еще не сопоставленных позиций заказа. | Не влияет | Да
 | Check invoice line items count against order items count | Проверяет, что количество позиций в заказе равно количеству позиций инвойса, связанных с данным заказом. | Не влияет | Нет
 | Check purchase order number and amount | Проверяет соответствие номера заказа и суммы, извлечённых с инвойса, с заказами в Наборе данных PurchaseOrders. | Rejected | Да
 | Check if invoice line items are matched with unique order items | Проверяет, что несколько позиций инвойса не сопоставлены с одной и той же позицией заказа. | Rejected | Нет
Line Items | Check item amount | Для каждой позиции инвойса проверяет выполнение арифметического отношения: Количество (Quantity) * Стоимость единицы (UnitPrice) соответствует сумме до налогообложения за данную позицию (TotalPriceNetto) с учётом скидки (DiscountPercentage). | Не влияет | Да
 | Match invoice line item with order item | Для каждой позиции инвойса проверяет соответствие позиции заказа в Наборе данных позиций заказов PurchaseOrdersItems. | Rejected | Да
 | Check LineItems currency value | Проверяет, что валюта позиции соответствует списку допустимых настройками проекта валют. | Rejected | Да, при включении дополнительной возможности Извлечение позиций (См. "Дополнительные поля")

Служебныe правила

Эти правила не влияют на статус документа и не показывают сообщений оператору, но необходимы для корректной работы определения документовABBYY FlexiCapture for Invoices.

Любые преднастроенные правила могут быть отключены пользователем в настройках определения документа. Также пользователь может создать свои правила.

Группы полей | Правило | Описание | Включено по умолчанию
Invoice Header Data | Detect invoice type | Если поле Invoice Amount отрицательно или найдены слова "Credit note", тип инвойса будет изменен на Credit note. | Да
 | Delivery Date field is empty or completed | Правило устанавливает / сбрасывает значение поля Delivery Date Indicator в зависимости от того, заполнено или нет поле Delivery Date (если Delivery Date не заполнено, тогда Delivery Date Indicator не устанавливается). Правило не действует, если Delivery Date Indicator был проверен. | Нет
Amounts | Reversed Charge field is empty or completed | Если найденная ставка НДС равно 0 или найдены слова "Reverse Charge", в значении поля Reversed Charge будет указано "Да". | Да
 | Detect national currency | Правило автоматически вводит данные в поле Currency (если оно не заполнено) в инвойсах из Франции, Великобритании и Испании. | Да
 | Complete Total Additional Cost field | Вычисляет сумму дополнительных начислений (Additional Costs). | Да
 | Complete Tax Rate field if it is empty | Рассчитывает значение налоговой ставки (Tax Rate), если налоговая ставка не найдена на изображении, но найдены остальные поля налоговый группы | Да
 | Complete Total Tax field if it is optional | Правило автоматически вводит данные в поле Amounts\Total Tax Amount для стран, где это поле не является обязательным. * Правило применяется только к инвойсам из Германии. | Да
 | Complete Total Tax if only one tax rate is found | Правило автоматически вводит данные в поле Amounts\Total Tax Amount, если в инвойсе только одна налоговая ставка. | Да
 | Get summary information for Amounts group | Правило вводит данные в поле Amounts\Summary на основе следующих значений: Net0, Net1, Net2, Tax Amount 1, Tax Amount 2, Tax Rate 1, Tax Rate 2. Формат: Сумма (= Net0 + Net1 + Net2 + Tax Amount 1 + Tax Amount 2); ставки НДС, найденные на инвойсе. Example: 256; 0% | Да
 | Copy currency from LineItems | Если колонка Currency таблицы позиций счёта (LineItems) инвойса не наложена, значение валюты копируется в данную таблицу из поля Currency (значение валюты возле поля Total). | Нет
 | Separate currency from amount in <Field Name> field (for 15 fields) | Это правило разбивает сумму и валюту и копирует валюту в поле Currency, если оно не заполнено. | Да

Замечание. Качество нахождения ключевых слов на изображении зависит от качества полнотекстового распознавания документа.

Режим предраспознавания может быть изменён в настройках определения документа на вкладке Гибкое описание диалога свойств. Повышение качества распознавания может негативно сказаться на скорости распознавания инвойса.


Глоссарий

ABBYY FlexiCapture for Invoices

Компонента ABBYY FlexiCapture, предназначенная для ввода инвойсов.

Разновидность документа

Инвойсы с нетипичным расположением полей, принадлежащие к одному классу, например, полученные от одного поставщика.

Дополнительные возможности обработки инвойсов

Дополнительные возможности обработки инвойсов, например, извлечение дополнительных полей и связанные с ними автоматические проверки

Дополнительное гибкое описание

Гибкое описание, которое используется дополнительно к основному гибкому описанию, для извлечения дополнительных полей документа.

Заказ на покупку

Документ, являющийся предложением покупателя продавцу и содержащий информацию о типе, количестве и согласованной цене товара или услуги, предоставляемой покупателю продавцом.

Инвойс

Документ, предоставляемый продавцом покупателю и содержащий перечень товаров, их количество и цену, по которой они будут поставлены покупателю, формальные особенности товара (цвет, вес и т. д.), условия поставки и сведения об отправителе и получателе.

Ключевые слова

Слова, которые могут сопровождать поля на инвойсе и по которым производится поиск полей. Эти слова могут различаться для разных языков и стран.

Кредитная нота

Инвойс с отрицательной суммой, выставленный поставщиком, чтобы скорректировать ранее выставленный инвойс в количестве или цене. Например, если товар не доставлен или является неполным, поврежден или некорректен, а также, если покупатель заплатил слишком много. Продавец возвращает деньги покупателю или учитывает баланс на фоне других транзакций.

Найденные элементы

Объект гибкого описания, используется для позиционирования полей инвойса.

Нормализация

Приведение по-разному записанных, но одинаковых по сути значений к одному виду для последующего сравнения. Например, если настройки нормализации предполагают игнорирование регистра букв и пробелов, то значения «Invoice Number» и «invoicenumber» будут одинаковыми.

Обучение [определения документа]

Возможность системы использовать введенные данные для анализа и обучаться на основе этих данных, в результате чего происходит улучшение поиска обученных полей на изображениях. Обучение возможно как при предварительной настройке системы, так и в процессе ввода данных.

Общее гибкое описание

Гибкое описание, которые применяется по умолчанию для обработки всех документов данного типа. Для разновидностей документов может быть применена Разновидность гибкого описания.

Основное гибкое описание

Гибкое описание, используемое для извлечения основных полей документа.

Пакеты обучения

Пакеты документов, предназначенные для обучения и тестирования определений документов на разновидности документов. В результате обучения получается разновидность гибкого описания. См. Пакеты документов, Разновидность документа, Разновидность гибкого описания.

Подразделение [компании]

Юридическое лицо, являющееся получателем инвойса.

Поиск по справочнику

Проверка распознанных данных поля на соответствие значениям из базы данных.

Позиция инвойса

Строка инвойса, соответствующая определенному приобретаемому продукту или услуге. Как правило, содержит описание продукта / услуги, количество и стоимость.

Поставщик

Юридическое или физическое лицо, поставляющее товары или услуги. За оказанные услуги или поставленные товары в дальнейшем поставщик выставляет инвойс, который можно распознать с помощью ABBYY FlexiCapture for Invoices.

Проверка позиций инвойса

Возможность системы подтверждать при верификации инвойс на основе заказа (контракта) на поставку.

Разновидность гибкого описания

Гибкое описание для разновидности документов, созданное в результате обучения на данной разновидности документов или специально разработанное для данной разновидности документов.

Применяется дополнительно к общему гибкому описанию.

Статус

Результат обработки инвойса, вычисляемый на основании правил проверки данных. По результатам обработки инвойс может находиться в одном из трех статусов:

  • Valid — инвойс удовлетворяет всем требованиям, готов к экспорту в конечную систему;
  • Rejected — инвойс не удовлетворяет требованиям выставления инвойсов;
  • Exception — инвойс удовлетворяет требованиям выставления инвойсов, но не может считаться валидным по каким-то причинам. Требует особой обработки в конечной системе.


Приложения

Горячие клавиши
Поддерживаемые языки распознавания
Шрифты для корректного отображения символов
Поддерживаемые типы текста
Поддерживаемые типы штрих-кодов
Поддерживаемые графические форматы
Форматы файлов экспорта
Патенты
Технологии других компаний


Горячие клавиши

В этом разделе приведен список горячих клавиш, используемых в различных окнах программы. Использование горячих клавиш может сэкономить ваше время и сделать работу с программой более удобной.

Горячие клавиши в главном окне
Горячие клавиши в окне групповой верификации
Горячие клавиши в окне контекстной верификации


Горячие клавиши в главном окне программы

Меню | Команда | Горячие клавиши
Файл | Новый проект… | Ctrl+Shift+N
 | Открыть проект… | Ctrl+Shift+O
 | Сохранить | Ctrl+S
 | Новый пакет… | Ctrl+N
 | Загрузить изображения… | Ctrl+O
 | Сканировать изображения… | Ctrl+K
 | Импортировать изображения… | Ctrl+I
 | Экспортировать | Ctrl+U
 | Экспортировать в файлы данных… | Alt+Shift+S
 | Экспортировать в базу данных… | Alt+Shift+D
 | Выход | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Найти… | Ctrl+F
 | Найти следующий | F3
 | Перейти > К следующему документу | Ctrl+D
 | Перейти > К предыдущему документу | Ctrl+Shift+D
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Отобразить Тестовые пакеты | Ctrl+Shift+B
 | Отобразить Рабочие пакеты | Ctrl+B
 | Отобразить документы в режиме Детали | Alt+1
 | Отобразить документы в режиме Эскизы страниц | Alt+2
 | Отобразить окно документов в режиме Изображение | Ctrl+1
 | Отобразить окно документов в режиме Данные | Ctrl+2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Увеличить размер эскизов | Ctrl+Shift+Num+
 | Уменьшить размер эскизов | Ctrl+Shift+Num-
 | Полноэкранный режим | F11
 | Обновить | F5
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Распознавание | Проанализировать | Ctrl+E
 | Наложить определение документа… | Alt+Shift+E
 | Распознать | Ctrl+R
Верификация | Начать верификацию… | F7
 | Следующий объект верификации | F4
 | Предыдущий объект верификации | Shift+F4
 | Следующий документ с ошибками сборки | F9
 | Предыдущий документ с ошибками сборки | Shift+F9
 | Следующий неуверенный символ | F8
 | Предыдущий неуверенный символ | Shift+F8
 | Следующая ошибка правил | F6
 | Предыдущая ошибка правил | Shift+F6
Проект | Определения документов… | Ctrl+T
 | Типы пакетов… | Ctrl+Shift+T
 | Профили импорта изображений… | Ctrl+Shift+I
Сервис | Обновить до последней версии | Alt+Shift+U
 | Повторный анализ | Ctrl+Alt+E
 | Повторное распознавание | Ctrl+Alt+R
 | Перепроверить правила | Ctrl+F6
 | Проверить целостность пакета | Ctrl+Shift+E
Справка | Вызов справки | F1
Общие команды | Открыть окно документа (если выделен документ или страница) | Enter
 | Регистрационные параметры | Ctrl+P


Горячие клавиши в окне групповой верификации

Меню | Команда | Горячие клавиши
Верификация | Подтвердить все | Enter
 | Отложить все | Ctrl+Enter
 | Изменить статус | Space
 | Следующая страница | Page Down
 | Предыдущая страница | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Выделить все | Ctrl+A
Вид | Изображение поля >Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Увеличить масштаб изображения поля | Ctrl+Num+
 | Уменьшить масштаб изображения поля | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1
Локальное меню символов | Показать изображение символа | F2
 | Подтвердить | Ctrl+E
 | Отложить | Ctrl+R
 | Отменить изменение статуса | Esc


Горячие клавиши в окне контекстной верификации

Меню | Команда | Горячие клавиши
Верификация | Подтвердить поле | Enter
 | Отложить поле | Ctrl+Enter
 | Следующий неуверенный символ | F4
 | Предыдущий неуверенный символ | Shift+F4
 | Следующее поле | Page Down
 | Предыдущее поле | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Вставить перенос строки | Shift+Enter
 | Объединить символы | Ctrl+M
Вид | Данные поля > Показывать распознанный текст | Alt+F1
 | Данные поля > Нарезка изображений символов | Alt+F2
 | Изображение поля > Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Изображение поля > Масштаб изображения > Увеличить | Ctrl+Num+
 | Изображение поля > Масштаб изображения > Уменьшить | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1


Сочетания клавиш

Для часто используемых команд можно настроить удобные сочетания клавиш. Для этого выберите в меню пункт Сервис>Опции…и перейдите на закладку Сочетания клавиш.

Для настройки сочетаний клавиш выполните следующие действия:

  1. Выберите тип команды в списке Категории. Если неизвестно, к какому типу относится команда, выберите значение Все команды.
  2. Выберите команду в списке Команды. Список Текущее сочетание содержит текущие сочетания клавиш, при нажатии которых выполняется выбранная команда.
  3. Для выбора нового сочетания перейдите в поле Нажмите клавиши и нажмите комбинацию клавиш. Она будет отображена в поле. Нажмите кнопку Назначить, чтобы сохранить новое сочетание. Если сочетание клавиш используется для другой команды, будет отображено информационное сообщение. Подтвердите смену команды, нажав кнопку Да. Нажмите кнопку Нет, чтобы отказаться от смены команды.
  4. Чтобы удалить сочетание клавиш, назначенное команде, выберите его в списке Текущее сочетание и нажмите кнопку Удалить.
  5. Чтобы восстановить исходные сочетания клавиш для выбранной команды, нажмите кнопку Сбросить. Если необходимо восстановить сочетания клавиш для всех команд, нажмите кнопку Сбросить все.


Дополнительные настройки

Пользователь может гибко настроить процесс обработки документов и интерфейс программы в соответствии со своими задачами. Выберите пункт Опции… в меню Сервис главного окна программы. Диалог состоит из закладок Настройки цвета, Диалоги, Сочетания клавиш.

  • Закладка Настройки цвета.

    Вы можете изменить цвета элементов интерфейса, таких как рамки для выделения полей в редакторе определения документа, рамки и заливка для выделения полей с ошибками и предупреждениями. Для этого выберите нужный элемент и нажмите на кнопку Цвет.

  • Закладка Диалоги.

    По умолчанию при запуске программы показывается диалог Открытие проекта, где вы можете выбрать один из существующих проектов. Если вы не хотите каждый раз видеть этот диалог, вы можете отменить его показ, отключив опцию Показывать диалог открытия проекта при запуске программы (или непосредственно в диалоге Открытие проекта).

    Выберите опцию Запрашивать сохранение изменений при переключении между документами, чтобы при переключении между документами приложение запрашивало подтверждение сохранения изменений. В противном случае изменения будут сохраняться автоматически.

  • Сочетания клавиш

    На этой закладке можно настроить сочетания клавиш для часто используемых команд.


Поддерживаемые графические форматы

Тип | Цвет
BMP | ч/б, серый, цветной
PCX, DCX | ч/б, серый
PNG | ч/б, серый, цветной
JPEG | серый, цветной
JPEG-2000* | серый, цветной
TIFF | ч/б – несжатый, CCITT3, CCITT4, Packbits, ZIP; серый – несжатый, Packbits, JPEG, ZIP; цветной – несжатый, JPEG, ZIP.
JBIG2 | ч/б
GIF | цветной
PDF, PDF/A** |
PDF, PDF/A** с возможностью поиска |
DjVu | ч/б, серый, цветной

* - Для изображений в формате JPEG-2000 используется сжатие без потери качества.

** - PDF/A файлы, созданные в ABBYY FlexiCapture, соответствуют стандартам PDF/A-1a и PDF/A-1b. По умолчанию создаются файлы PDF/A-1a. Для того чтобы настроить экспорт в PDF/A-1b, добавьте в реестр следующее значение:

HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Export\UseTaggedPdfExport = false

Замечание. При обработке PDF-файлов, содержащих векторную графику, их визуальное качество может ухудшаться в связи с тем, что PDF-файл растеризуется и в выходной файл попадает растровое изображение.


Форматы файлов экспорта

Вы находитесь здесь: Приложения > Форматы файлов экспорта

Форматы файлов, в которые ABBYY FlexiCapture экспортирует данные из документов

  • Microsoft Office Excel Workbook (*.XLS)
  • DBase file (*.DBF)
  • Comma Separated Values File (*.CSV). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Comma Separated Values File (*.CSV) в формате Unicode (UTF-8, UTF-16)
  • Простой текст (*.TXT). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Простой текст (*.TXT) в формате Unicode (UTF-8, UTF-16)
  • XML Document (*.XML)


Технологии других компаний

© 1984-2011 Adobe Systems Incorporated и их лицензиары. Все права защищены.

Защищено патентами США 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Вопрос о выдаче патентов рассматривается.

Adobe, Acrobat, логотип Acrobat, логотип Adobe, логотип Adobe PDF и Adobe PDF Library являются зарегистрированными товарными знаками или товарными знаками компании Adobe Systems Incorporated в Соединенных Штатах Америки и/или других странах.

Авторское право на часть данной компьютерной программы принадлежит © 2008 Celartem, Inc. Все права сохранены.

Авторское право на часть данной компьютерной программы принадлежит © 2011 Caminova, Inc. Все права сохранены.

Авторское право на часть данной компьютерной программы принадлежит © 2013 Cuminas, Inc. Все права сохранены.

DjVu® охраняется патентами США No. 6.058.214. Заявки на патенты в других странах рассматриваются.

На основе AT&T Labs Technology.

PixTools © 1994-2007 EMC Corporation. Все права защищены.

WIBU, CodeMeter, SmartShelter, SmartBind являются зарегистрированными товарными знаками Wibu-Systems.

© 2012 В данном программном обеспечении частично использованы результаты работы Университета Нового Южного Уэльса. Все права защищены.

© 2001-2006 Michael David Adams

© 1999-2000 Image Power, Inc.

© 1999-2000 The University of British Columbia

В данном программном обеспечении частично использованы результаты работы Независимой группы JPEG.

© 1991-2013 Unicode, Inc. Все права защищены.

Словесный знак Unicode и логотип Unicode являются зарегистрированными товарными знаками Unicode, Inc.

© 1996-2002, 2006 The FreeType Project (www.freetype.org). Все права защищены.

© ParaType, 2003

EMC2, EMC, Captiva, ISIS и PixTools являются зарегистрированными товарными знаками, а QuickScan является товарным знаком EMC Corporation.

Kodak является зарегистрированным товарным знаком Eastman Kodak Company.

.NET, Access, Active Directory, ActiveX, Aero, Excel, Hyper-V, InfoPath, Internet Explorer, JScript, Microsoft, Office, Outlook, PowerPoint, SharePoint, Silverlight, SQL Azure, SQL Server, Visual Basic, Visual C++, Visual C#, Visual Studio, Windows, Windows Azure, Windows Power Shell, Windows Server, Windows Vista, Word являются товарными или зарегистрированными товарными знаками Microsoft Corporation в США и/или других странах.

Oracle и Java являются зарегистрированными товарными знаками Oracle и/или филиалов.

Другие товарные знаки являются собственностью соответствующих владельцев.

TWAIN Toolkit распространяется как есть. Разработчик и распространитель TWAIN Toolkit отказываются от любых подразумеваемых, явных или предусмотренных законодательством гарантий, включая, без ограничения, подразумеваемые гарантии пригодности для продажи, ненарушения прав третьих лиц и пригодности конкретной цели. Ни разработчики, ни распространители не несут ответственности за убытки, прямые, косвенные, специальные или случайные, возникшие в результате воспроизведения, изменения, распространения или иного использования TWAIN Toolkit.

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams

Copyright (c) 1999-2000 Image Power, Inc.

Copyright (c) 1999-2000 The University of British Columbia

Все права защищены.

Настоящей лицензией любому лицу (далее - "Пользователь"), получившему копию настоящего программного обеспечения и сопроводительную документацию к нему (далее - "ПО"), безвозмездно предоставляется право распоряжаться ПО без каких-либо ограничений, включая право использовать, копировать, изменять, встраивать, воспроизводить, публиковать, распространять и/или продавать копии ПО, а также разрешать лицам, которым передается ПО, совершать аналогичные действия при условии соблюдения нижеперечисленных условий:

  1. Любые копии или значительные части ПО должны содержать вышеприведенные уведомления об авторских правах, настоящую лицензию и нижеприведенный отказ от гарантий.
  2. Имя владельца авторских прав не должно использоваться для поддержки или рекламы продуктов, созданных на основе настоящего ПО, без предварительного письменного согласия владельца авторских прав.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ ЯВЛЯЕТСЯ НЕОТЪЕМЛЕМОЙ ЧАСТЬЮ НАСТОЯЩЕЙ ЛИЦЕНЗИИ.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ РАСПРОСТРАНЯЕТСЯ НА ЛЮБОЕ ИСПОЛЬЗОВАНИЕ ПО. ПО ПРЕДОСТАВЛЯЕТСЯ ВЛАДЕЛЬЦАМИ АВТОРСКИХ ПРАВ "ТАКИМ, КАКОВО ОНО ЕСТЬ" БЕЗ КАКИХ-ЛИБО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ (НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ) ГАРАНТИЙ ТОГО, ЧТО ПО ПРИГОДНО К ПРОДАЖЕ, ПРИГОДНО ДЛЯ КОНКРЕТНОГО ИСПОЛЬЗОВАНИЯ И НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ЛЮБЫЕ КОСВЕННЫЕ, ПРЯМЫЕ ИЛИ СЛУЧАЙНЫЕ УБЫТКИ, А ТАКЖЕ ЗА ЛЮБЫЕ УБЫТКИ ИЗ-ЗА НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПО, ПОТЕРИ ДАННЫХ ИЛИ УПУЩЕННОЙ ВЫГОДЫ В РЕЗУЛЬТАТЕ НЕВЫПОЛНЕНИЯ ОБЯЗАТЕЛЬСТВ ПО КОНТРАКТУ, НЕБРЕЖНОСТИ ИЛИ ИНЫХ ВРЕДОНОСНЫХ ДЕЙСТВИЙ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ИЛИ РАБОТОЙ ПО. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ ГАРАНТИРУЮТ, ЧТО ПО НЕ НАРУШАЕТ ПАТЕНТОВ И ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ТРЕТЬИХ ЛИЦ. КАЖДЫЙ ИЗ ВЛАДЕЛЬЦЕВ АВТОРСКИХ ПРАВ ОТКАЗЫВАЕТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ПОЛЬЗОВАТЕЛЯМИ ЗА ИСКИ ТРЕТЬИХ ЛИЦ В СВЯЗИ С НАРУШЕНИЕМ ИХ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ИЛИ ИНЫМИ НАРУШЕНИЯМИ. ДЛЯ ИСПОЛЬЗОВАНИЯ ПРАВ, ПРЕДОСТАВЛЯЕМЫХ НАСТОЯЩЕЙ ЛИЦЕНЗИЕЙ, КАЖДЫЙ ПОЛЬЗОВАТЕЛЬ ПРИНИМАЕТ НА СЕБЯ ЕДИНОЛИЧНОЕ ОБЯЗАТЕЛЬСТВО ПРИОБРЕСТИ НЕОБХОДИМЫЕ ПРАВА ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, ЕСЛИ ТАКОВЫЕ ПОТРЕБУЮТСЯ. ПО НЕ ОБЛАДАЕТ ОТКАЗОУСТОЙЧИВОСТЬЮ И НЕ ПРЕДНАЗНАЧЕНО ДЛЯ ИСПОЛЬЗОВАНИЯ В УСЛОВИЯХ, ТРЕБУЮЩИХ БЕЗОТКАЗНОЙ РАБОТЫ, ТАКИХ КАК ЯДЕРНЫЕ УСТАНОВКИ, АВИАЦИОННЫЕ НАВИГАЦИОННЫЕ ИЛИ КОММУНИКАЦИОННЫЕ СИСТЕМЫ, АВИАДИСПЕТЧЕРСКИЕ СИСТЕМЫ, АППАРАТЫ ПО ПОДДЕРЖАНИЮ ЖИЗНИ, ОРУЖИЕ ИЛИ СИСТЕМЫ, В КОТОРЫХ ОТКАЗ ПО ИЛИ СИСТЕМЫ МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, СЕРЬЕЗНОМУ УЩЕРБУ ЗДОРОВЬЮ ИЛИ ОКРУЖАЮЩЕЙ СРЕДЕ ("ДЕЯТЕЛЬНОСТЬ, СВЯЗАННАЯ С ПОВЫШЕННЫМ РИСКОМ"). ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НАСТОЯЩИМ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРИГОДНОСТИ ПО ДЛЯ ДЕЯТЕЛЬНОСТИ, СВЯЗАННОЙ С ПОВЫШЕННЫМ РИСКОМ.


Техническая поддержка

Если при использовании программы ABBYY FlexiCapture у вас возникли вопросы, то вы можете воспользоваться детальным описанием функциональности этой программы, приведенном в Справке и Руководстве пользователя ABBYY FlexiCapture. А также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать вам квалифицированные рекомендации, сотрудникам службы технической поддержки необходимо иметь следующую информацию:

  • Фамилия, Имя, Отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер дистрибутива
  • Выпуск (см. меню Справка/О программе ABBYY FlexiCapture)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия системы Windows
  • Другая информация, которую вы считаете важной
Координаты офисов ABBYY


ЛИЦЕНЗИОННЫЙ ДОГОВОР С КОНЕЧНЫМ ПОЛЬЗОВАТЕЛЕМ

ABBYY® FlexiCapture®

Важно! Внимательно прочитайте условия лицензионного договора прежде чем устанавливать, копировать, и/или иным образом использовать программу для ЭВМ ABBYY FlexiCapture (далее – ПО). Установка, копирование и использование ПО иным способом означает Ваше согласие с условиями приведенного ниже лицензионного договора.

Настоящий лицензионный договор с конечным пользователем (далее – Лицензионный договор) является юридически обязательным соглашением между Вами, конечным пользователем, приобретшим ПО, и Компанией ABBYY.

Настоящий Лицензионный договор вступает в силу после того, как Вы выразите свое согласие соблюдать изложенные в нем условия, нажав сначала кнопку «Я принимаю условия лицензионного договора», а затем кнопку «Далее», что приведет к установке ПО, либо после того, как Вы установите, скопируете или начнете каким-либо образом использовать ПО. Любое такое действие будет интерпретироваться как Ваше согласие с тем, что Вы прочитали настоящий Лицензионный договор, поняли его и согласны выполнять изложенные в нем условия. В случае если Вы не согласны с условиями настоящего Лицензионного договора, не используйте ПО, удалите ПО с Вашего компьютера и уничтожьте все имеющиеся у Вас копии ПО. Настоящий Лицензионный договор действует на протяжении всего срока действия авторских прав на ПО, если иное не оговорено в настоящем Лицензионном договоре или в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, и может зависеть от объема Лицензии, определенного в настоящем Лицензионном договоре.

ПО защищается законодательством об авторском праве и международными соглашениями, некоторые части ПО защищены патентным законодательством и законами о коммерческой тайне. Вы подтверждаете свое согласие с тем, что настоящий Лицензионный договор имеет такую же юридическую силу, как и любой другой письменный договор, заключенный Вами. В случае нарушения Лицензионного договора Вы можете быть привлечены в качестве ответчика.

Если ПО сопровождается договором, заключенным с Компанией ABBYY или Партнером Компании ABBYY, в бумажном виде, в том числе в письменной форме, и этот договор определяет условия использования Вами ПО, то в случае расхождений в содержании между текстом настоящего Лицензионного договора в электронном виде и текстом договора в бумажном виде, в том числе в письменной форме, преимущественную силу имеет текст договора в бумажном виде, в том числе в письменной форме.

Настоящий Лицензионный договор может быть доступен Вам на нескольких языках. Между английской версией Лицензионного договора и его версиями на других языках могут быть расхождения, а также могут быть различия в трактовке. Ради единообразия и предотвращения двусмысленности, английская версия Лицензионного договора будет иметь преимущественную силу, и все споры, претензии и судебные разбирательства, связанные с Лицензионным договором, в том числе с его толкованием или обеспечением его исполнения, должны разрешаться на основании английской версии Лицензионного договора.

Определения

«Компания ABBYY» означает

ABBYY USA Software House Inc. зарегистрированное по адресу 95035, США, Калифорния, г. Милпитас, бульвар Норс МакКарти, 880, офис 220, когда применяется статья 13.1 настоящего Лицензионного договора;

ABBYY Europe GmbH зарегистрированное по адресу: 80687, Германия, г. Мюнхен, Эльзенхаймер штрассе, 49, когда применяется статья 13.2 настоящего Лицензионного договора;

ABBYY UK Ltd. зарегистрированное по адресу: Соединенное Королевство, Эгхем, Суррей TW20 9EY, Хай-стрит, 65, Хитроу бизнес-центр, когда применяется статья 13.3 настоящего Лицензионного договора;

ООО «Аби Продакшн», зарегистрированное по адресу 109390, Москва, ул. 1-ая Текстильщиков, д. 12/9, офис 2., когда применяется статья 13.4 настоящего Лицензионного договора;

ООО «АБИ Украина», зарегистрированное по адресу 03680, Украина, г. Киев, ул. Дегтяревская, д. 31, когда применяется статья 13.5 настоящего Лицензионного договора;

и ABBYY Solutions Ltd., зарегистрированное по адресу: 2404, Кипр, г. Никосия, ул. Михаила Караоли, 2, Эгкоми - во всех остальных случаях.

«Партнер Компании ABBYY» означает физическое или юридическое лицо, которому Компания ABBYY предоставила право на перепродажу и распространение лицензионных копий ПО Конечным пользователям, либо напрямую, либо через одного или более посредника или дистрибьютора.

«Компьютер» означает физическое или виртуальное устройство с одним или более ядром ЦПУ (центрального процессорного устройства), и работающее под управлением определенной операционной системы. Любые изменения в конфигурации или в наборе комплектующих Компьютера могут привести к тому, что Компьютер будет считаться другим Компьютером для целей использования ПО.

«Права на интеллектуальную собственность» означает все права на интеллектуальную и промышленную собственность и включает в себя права на (i) изобретения, открытия и патенты, в том числе заявки на патенты, повторно выданные патенты, продолжения и частичные продолжения; (ii) авторские права; (iii) образцы и промышленные образцы; (iv) товарные знаки, знаки обслуживания, оформление товара и подобные права; (v) ноу-хау, коммерческую тайну и конфиденциальную информацию; (vi) права на топологию интегральных микросхем и права на шаблоны; и (vii) иные интеллектуальные права.

«Лицензия» – предоставляемое Вам Компанией ABBYY на условиях простой (неисключительной) лицензии ограниченное право на установку и использование функциональности ПО в соответствии с условиями Лицензионного договора.

«ПО» означает любую версию или издание программы для ЭВМ ABBYY FlexiCapture, включая все компоненты программы (расширения, пользовательские компоненты, модули, и т.д.) встроенные в программу или доступные в сети интернет или иным образом, такие как: исполняемый код, справка, демонстрационные, файлы для примера и другие файлы; библиотеки, базы данных, примеры, сопроводительные материалы (графические изображения, фотографии, анимированные изображения, аудио- и видео-компоненты, музыка, и т.д.), печатные материалы, и другие компоненты ПО.

«Вы», «Ваш», «Конечный пользователь» относится и подразумевает любое физическое и/или любое юридическое лицо, которое приобрело ПО для собственного использования и не для продажи, а также любого фактического пользователя ПО.

«Серийный номер» означает уникальный идентификатор лицензии или группы лицензий со сходными параметрами, предоставленный Компанией ABBYY или Партнером Компании ABBYY Конечному пользователю.

«Активация ПО» - процесс, при помощи которого осуществляется проверка Серийного номера на действительность и установленное ПО переводится в полнофункциональный режим и начинает выполнять все функции в соответствии с сопроводительной документацией и объемом приобретенной Вами Лицензии.

1. Предоставление лицензии

1.1 Согласно условиям и положениям настоящего Лицензионного договора, Компания ABBYY предоставляет Вам неисключительную, ограниченную Лицензию на установку и использование функциональности ПО, с учетом всех ограничений и объема Лицензии, которые могут содержаться: в Лицензионном договоре, программных и/или аппаратных лицензионных ключах, предоставленных Компанией ABBYY (далее - Лицензионный ключ), ПО, и/или отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY. Все условия Лицензионного договора относятся как к ПО в целом, так и ко всем компонентам ПО в отдельности. Любые разногласия по поводу объема Лицензии будут разрешаться в пользу ограничения объема Лицензии. Лицензионный ключ техническими средствами ограничивает использование ПО объемом Лицензии, которую Вы приобрели. Ограничения на использование ПО Вами и объем Вашей Лицензии могут включать следующие, но не ограничиваются таковыми:

1.1.1 Количество рабочих мест, компонентов ПО и сетевых подключений. Вы имеете право устанавливать ПО более чем на одном Компьютере в Сети и одновременно использовать определенные компоненты ПО на определенном количестве Компьютеров в Сети («конкурентное лицензирование»). Информация о доступных для использования компонентах ПО и количестве Компьютеров в Сети, разрешенных для одновременной работы с ПО, содержится в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.2 Обрабатываемый объем. Количество страниц, которое может быть обработано при помощи ПО, может быть ограничено одним или более способом, таким как ограничение на количество страниц, которое можно обработать за определенные отрезки времени, например каждый месяц или каждый год, или на суммарное количество обрабатываемых страниц. Размер страниц и количество полей в документе также могут быть ограничены. Ограничения на обрабатываемый объем содержатся в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.3 Срок. Использование ПО может быть ограниченно определенным сроком, после истечения которого Вы не можете использовать ПО. Ограничение срока содержится в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.1.4 Возможности, расширения и пользовательские компоненты. Использование определенных возможностей, расширений и/или пользовательских компонентов ПО может быть ограничена в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.2

Вычислительные мощности. Количество ядер ЦПУ (Центрального Процессора) Компьютеров, которые ПО может задействовать, могут быть также ограничены в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY. Компания ABBYY сохраняет все права, явным образом не предоставленные Вам согласно условиям настоящего Лицензионного договора. Лицензионный договор не предоставляет и не предает Вам никаких прав на товарные знаки Компании ABBYY.

1.3 Если применяется п. 13.4 Лицензионного договора и Вы являетесь физическим лицом, Вы можете использовать ПО на территории всего мира. Если применяется п. 13.4 Лицензионного договора и Вы являетесь юридическим лицом, Вы имеете право приобрести (купить) ПО только в стране регистрации юридического лица или его обособленных подразделений, если иное не указанно в отдельном письменном договоре между Вами или Компанией ABBYY. Сотрудники юридического лица или его обособленных подразделений могут использовать ПО на территории всего мира, при условии, что ПО было приобретено и установлено, на территории страны регистрации юридического лица или его обособленных подразделений, если иное не предусмотрено в отдельном соглашении, заключенном между Вами и Компанией ABBYY или Партнером Компании ABBY.

1.4 Любое использование ПО или его компонентов, не соответствующее условиям Лицензионного договора, является нарушением интеллектуальных прав Компании ABBYY и/или третьих лиц и служит основанием для лишения Вас прав использования ПО, предоставленных Вам по настоящему Лицензионному договору.

1.5 Если Вы используете ПО в виртуальной среде, использование и получение доступа к ПО не должно нарушать ограничения на ПО и объем предоставленной Вам лицензии. Например, Лицензионный Ключ не может быть использован для предоставления доступа и разрешения на использование ПО большему количеству Компьютеров, чем количество Компьютеров, для которых была надлежащим образом приобретена лицензия. Также ПО не может быть использовано для обработки большего количества страниц, чем количество, на которое было получено разрешение.

1.6 Если Вы развертываете ПО через терминальные службы, которые разрешают доступ к ПО на удаленном компьютере с помощью сети, количество одновременно запущенных экземпляров ПО не должно превышать количество Компьютеров, для которых была надлежащим образом приобретена лицензия.

1.7 Если Вы используете ПО при помощи веб-браузера, Вы имеете право одновременно запускать и использовать ПО таким количеством Компьютеров, которое разрешено объемом приобретенной Вами Лицензии и указано в Лицензионном ключе и/или письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

1.8 Вы можете получить ПО на нескольких носителях (ПО на множественных носителях), включая загрузки с помощью сети интернет. Вне зависимости от количества и типа полученных Вами материальных носителей, Вы можете использовать ПО только в соответствии с объемом Лицензии на ПО.

2. Ограничения на использование

2.1 Чтобы использовать ПО, Вам необходимо осуществить Активацию ПО после его установки.

2.2 Все условия использования ПО и ограничения на использование ПО приведены в Лицензионном договоре, если иное не указанно в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, или в сопутствующей документации к ПО.

2.3 Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:

2.3.1 Осуществлять обратное проектирование, дизассемблировать, декомпилировать (воспроизводить и преобразовывать объектный код в исходный текст) или иным способом осуществлять попытку получить исходный текст ПО или любой части ПО за исключением случаев, разрешенных применимым законодательством, несмотря на данное ограничение, и только в объеме, разрешенном применимым законодательством. Если применимое законодательство запрещает ограничение подобных действий, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть немедленно сообщена Компании ABBYY. Вся такая информация является конфиденциальной и принадлежит Компании ABBYY.

2.3.2 Модифицировать, адаптировать (в том числе, вносить в ПО изменения исключительно в целях его функционирования на конкретных технических средствах Конечного пользователя или под управлением конкретных программ Конечного пользователя), вносить любые изменения в объектный код ПО, программы и базы данных, содержащиеся в ПО, за исключением тех изменений, которые предусмотрены ПО и описаны в документации.

2.3.3 Осуществлять исправление ошибок в ПО или переводить ПО без предварительного письменного согласия Компании ABBYY.

2.3.4 Сдавать в аренду, сдавать в наем, сублицензировать, передавать или уступать права, предоставленные Вам по Лицензионному договору, и любые другие права, связанные с ПО, любому другому лицу, а также разрешать копировать ПО целиком или его части на другие Компьютеры (за исключением того, как это описано в п. 2.6).

2.3.5 Создавать условия для доступа к ПО или использования ПО третьими лицами, не имеющими прав на использование данного ПО, включая, но не ограничиваясь этим: пользователей работающих с Вами в одной многопользовательской системе, в виртуальной среде или через сеть интернет.

2.3.6 Удалять, изменять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

2.4 Вы не имеете права использовать ПО для предоставления платных или бесплатных услуг по распознаванию или преобразованию, и/или предоставлять третьим лицам результаты, полученные посредством ПО, или доступ к результатам, полученным посредством ПО, как часть другой услуги, в которой распознавание или преобразование текста является частью услуги, если Вы не заключали отдельный письменный договор с Компанией ABBYY и в Вашем Лицензионном ключе не активирован параметр “BPO services enabled”.

2.5 Вы не имеете права обходить предоставленный вместе с ПО пользовательский интерфейс ПО, если это не оговорено в отдельном письменном договоре с Компанией ABBYY.

2.6 Вы имеете право передать ПО напрямую другому Конечному пользователю только один раз. Если Вы являетесь юридическим лицом, такая передача может быть осуществлена только после получения письменного согласия Компании ABBYY. ПО может быть передано только целиком (включая все копии, все Компоненты ПО, носители и печатные материалы, любые обновления ПО), а также Лицензионный договор. Такая передача не может быть осуществлена при помощи посредников или любым другим косвенным образом. Лицо, получающее ПО в результате такой передачи, обязано согласиться с условиями Лицензионного договора, включая обязанность не осуществлять дальнейшую передачу Лицензионного договора и ПО. В случае осуществления такой передачи Вы обязаны удалить ПО со всех Ваших Компьютеров или из Вашей локальной сети.

3. Ознакомительные, испытательные и демонстрационные версии ПО

3.1 Если ПО, которое Вы получили вместе с этой Лицензией, является предпродажной версией или бета-версией ПО, предоставленной для ознакомления, тестирования или проверки, имеет ограниченный или неполный набор функций, обозначено как «Испытательная версия» или «Демонстрационная версия» (“Try&Buy” “Trial” или “Demo”), или было предоставлено бесплатно (далее – «Ознакомительное Программное Обеспечение»), то до тех пор, пока Вы не приобретете (купите) лицензию на полную версию ПО, применяется статья 3 Лицензионного договора. В случае любых расхождений между текстом других статей и текстом статьи 3 Лицензионного договора, статья 3 будет иметь преимущественную силу во всех вопросах, касающихся Ознакомительного Программного Обеспечения, но только в мере, необходимой для разрешения расхождений.

3.2 ОЗНАКОМИТЕЛЬНОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ПРЕДОСТАВЛЯЕТСЯ ВАМ «КАК ЕСТЬ» И БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ ИЛИ ОБЯЗАТЕЛЬСТВ ПО ВОЗМЕЩЕНИЮ УБЫТКОВ (ВЫРАЖЕННЫХ, ПОДРАЗУМЕВАЕМЫХ ИЛИ УСТАНОВЛЕННЫХ ЗАКОНОДАТЕЛЬСТВОМ). ОЗНАКОМИТЕЛЬНОЕ ПО НЕ ЯВЛЯЕТСЯ ОКОНЧАТЕЛЬНОЙ ВЕРСИЕЙ ПО ОТ КОМПАНИИ ABBYY, И МОЖЕТ СОДЕРЖАТЬ ДЕФЕКТЫ, ОШИБКИ И ДРУГИЕ НЕИСПРАВНОСТИ, КОТОРЫЕ МОГУТ ВЫЗВАТЬ СБОЙ СИСТЕМЫ ИЛИ ИНОЙ СБОЙ И ПОТЕРЮ ДАННЫХ. В ТОЙ СТЕПЕНИ, В КОТОРОЙ ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ, НА ОЗНАКОМИТЕЛЬНОЕ ПО НЕ РАСПРОСТРАНЯЮТСЯ НИКАКИЕ ГАРАНТИИ, И ВЫ СОГЛАСНЫ С ТЕМ, ЧТО КОМПАНИЯ ABBYY ОТКАЗЫВАЕТСЯ ОТ ВСЕХ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ И ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ВАМИ, В ТОМ ЧИСЛЕ, НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ, ОТ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРАВОВОГО ТИТУЛА, ГОДНОСТИ ДЛЯ ПРОДАЖИ, ОТСУТСТВИЯ НАРУШЕНИЯ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, СПОКОЙНОГО ПОЛЬЗОВАНИЯ И ГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ. В СЛУЧАЯХ, КОГДА ОТ ОТВЕТСТВЕННОСТИ НЕВОЗМОЖНО ОТКАЗАТЬСЯ, НО ОТВЕТСТВЕННОСТЬ МОЖЕТ БЫТЬ ОГРАНИЧЕНА, ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY НЕ ДОЛЖНА ПРЕВЫШАТЬ НАИБОЛЬШУЮ ИЗ ДВУХ СУММ: ЛИБО ПЯТИДЕСЯТИ (50) ДОЛЛАРОВ США, ЛИБО СУММУ, УПЛАЧЕННУЮ ВАМИ ЗА ПО.

3.3 Ознакомительное Программное Обеспечение может иметь ограниченную функциональность. Например, функциональность может быть доступна в течение ограниченного срока, по истечении которого (далее – истечение срока действия) Ваш доступ к Ознакомительному Программному Обеспечению и возможность им пользоваться будут прекращены. По истечении срока действия Вы теряете предоставленные Вам Лицензионным договором права, при условии, что Вы не приобрели новую лицензию у Компании ABBYY.

3.4 Ознакомительное Программное Обеспечение, коммерческая версия которого не поступала в продажу

3.4.1 Ознакомительное Программное Обеспечение, коммерческая версия которого не поступала в продажу, является Конфиденциальной Информацией Компании ABBYY.

3.4.2 В отношении Ознакомительного Программного Обеспечения, коммерческая версия которого не поступала в продажу, Компания ABBYY не обещает и не гарантирует, не имеет выраженных или подразумеваемых обязательств, и Вы признаете, что Компания ABBYY не обещала или не гарантировала, что такое программное обеспечение будет разрабатываться в дальнейшем, или что его коммерческая версия будет анонсирована или доступна в будущем. Компания ABBYY не имеет обязательств выпускать продукт, похожий или совместимый с таким программным обеспечением. Вы признаете, что все риски, связанные с использованием, изучением или разработкой такого программного обеспечения возлагаются на Вас.

3.4.3 Вы согласны предоставить Компании ABBYY отзывы о тестировании и использовании Ознакомительного Программного Обеспечения, включая сообщения об ошибках или дефектах (далее – Отзывы), и передать Компании ABBYY все права на Отзывы, включая без ограничений права на использование, публикацию и распространение Отзывов. Все Отзывы являются Конфиденциальной Информацией Компании ABBYY.

3.4.4 Конфиденциальность Ознакомительного Программного Обеспечения, коммерческая версия которого не поступала в продажу и его Результатов.

3.4.4.1 Вы обязуетесь не разглашать сопроводительную информацию, относящуюся к Ознакомительному Программному Обеспечению, коммерческая версия которого не поступала в продажу, и переданную Вам Компанией ABBYY в письменном, устном или электронном виде, а также любую информацию о качестве Ознакомительного Программного Обеспечения или качестве результатов, полученных при помощи Ознакомительного Программного Обеспечения, Отзывы, и любую информацию об ошибках, дефектах и других проблемах, обнаруженных Вами в Ознакомительном Программном Обеспечении, коммерческая версия которого не поступала в продажу. Такая информация является Конфиденциальной Информацией Компании ABBYY.

3.4.4.2 Вы обязуетесь не разглашать Конфиденциальную Информацию. «Разглашать» означает демонстрировать, описывать, копировать, отдавать во временное пользование, сдавать в аренду, передавать или предоставлять сетевой или иной доступ к Конфиденциальной Информации, воспроизведенной в любом виде, в том числе в устном, любым третьим лицам.

3.4.4.3 Вы обязуетесь принять все разумные меры для предотвращения разглашения Конфиденциальной Информации.

3.4.4.4 Вы обязуетесь своевременно уведомлять Компанию ABBYY о ставших известными Вам фактах разглашения Конфиденциальной Информации. Если Вы нарушите условия, указанные в п. 3.4.4.1 - 3.4.4.3 Лицензионного договора, Вы обязаны возместить Компании ABBYY все убытки, понесенные в результате такого нарушения.

3.5 В случае получения Вами новой версии Ознакомительного Программного Обеспечения или коммерческой версии такого программного обеспечения в виде отдельного продукта или части другого продукта, Вы обязаны вернуть или удалить все предыдущие версии Ознакомительного Программного Обеспечения, полученные вами от Компании ABBYY.

3.6 Если Ознакомительное Программное Обеспечение было предоставлено Вам в соответствии с отдельным письменным договором, использование Вами Ознакомительного Программного Обеспечения также подпадает под действие такого договора. В случае расхождений между условиями отдельного письменного договора и настоящего Лицензионного договора, отдельный письменный договор будет иметь преимущественную силу, но только в мере, необходимой для разрешения таких расхождений.

4. ПО, обозначенное «не для продажи»

4.1 Если ПО обозначено как «не для продажи» («Not for Resale» или «NFR»), то, независимо от остальных условий Лицензионного договора, допускается использование такого ПО только в целях демонстрации, проверки или тестирования ПО.

5. Обновления

5.1 Если ПО обозначено как обновление, Вы имеете право использовать ПО только при условии, что у вас есть лицензия на предыдущую версию ПО, обозначенную Компанией ABBYY как подлежащую такому обновлению.

5.2 ПО, обозначенное как обновление, заменяет или дополняет продукт, который являлся основанием для получения Вами обновления.

5.3 Вы имеете право использовать получившийся обновленный продукт только в соответствии с лицензионным договором, предоставленным вместе с обновлением.

5.4 Вы согласны с тем, что любые обязанности Компании ABBYY по поддержке обновляемой версии ПО заканчиваются в тот момент, когда обновление становится доступным.

6. Техническая поддержка и сопровождение

6.1 Вам может быть предоставлена техническая поддержка или сопровождение ПО (далее – Техническая поддержка) на условиях действующих правил предоставления Технической поддержки Компании ABBYY. Однако в случае заключения отдельного письменного договора между Вами и Компанией ABBYY или Партнером Компании ABBYY Вы можете иметь право на уровень Услуг по поддержке, отличный от уровня, обозначенного в политике Компании ABBYY по предоставлению поддержки.

6.2 Общие правила предоставления поддержки Компании ABBYY опубликованы на веб-сайте Компании ABBYY по адресу www.abbyy.com. Компания ABBYY оставляет за собой право изменять действующие правила предоставления Технической поддержки в любое время без предварительного уведомления.

6.3 В дополнение к общим правилам предоставления поддержки у Компании ABBYY могут быть особые правила предоставления Технической поддержки для отдельных регионов, которые могут быть регламентированы отдельными договорами.

6.4 Любой дополнительный программный код и любой компонент ПО, предоставленные Вам в рамках Технической поддержки, считаются частью ПО и подлежат действию условий Лицензионного договора.

6.5 В рамках предоставления Технической поддержки Компания ABBYY может запросить у Вас информацию про характеристики Вашего оборудования, серийный номер Вашего ПО, а также некоторые персональные данные, такие как Ваше имя, название Вашей компании (если применимо), адрес, номер телефона и адрес электронной почты. Компания ABBYY имеет право использовать эту информацию в соответствии с п.15.1 Лицензионного договора.

7. Права на интеллектуальную собственность.

7.1 Вам не передаются никакие принадлежащие Компании ABBYY Права на интеллектуальную собственность, в том числе никакие права на ПО, патенты и товарные знаки Компании ABBYY и никакие авторские права Компании ABBYY. Вы обязуетесь на протяжении всего срока действия настоящего Лицензионного договора и после его окончания не использовать и не претендовать на права на какие-либо наименования, логотипы, товарные знаки, модели или образцы, принадлежащие Компании ABBYY, или наименования, логотипы, товарные знаки, модели или образцы похожие на них.

7.2 Компании ABBYY не передаются никакие принадлежащие Вам Права на интеллектуальную собственность, в том числе никакие принадлежащие Вам права на приложение, патенты, товарные знаки и никакие принадлежащие Вам авторские права.

7.3 ПО содержит значимую коммерческую тайну и конфиденциальную информацию, принадлежащую Компании ABBYY и третьим лицам, и охраняется законами об авторском праве, в том числе, без каких- либо ограничений, законами об авторском праве США, законами Российской Федерации, международными соглашениями и законами страны, в которой ПО используется или было приобретено.

7.4 Все правовые титулы и права на материалы, которые не содержатся в ПО, но могут быть доступны посредством использования ПО, принадлежат их законным владельцам и могут охраняться применимыми законами об авторском праве, иными законами об охране интеллектуальной собственности и международными соглашениями. Настоящий Лицензионный договор не предоставляет Вам никаких прав на такую интеллектуальную собственность.

8. Ограниченная гарантия. Отказ от ответственности

8.1 Если этого требует законодательство страны, в которой Вы приобрели (купили) ПО, Компания ABBYY гарантирует качество и работоспособность носителей, на которых предоставляется ПО, только при условии нормального использования и только в течение минимального гарантийного срока, установленного законодательством страны, в которой Вы приобрели (купили) ПО, начиная с даты приобретения ПО. Если ПО было приобретено в одной из стран, указанных в п. 13.4 Лицензионного договора, гарантийный срок на материальные носители составляет тридцать (30) дней, начиная с даты приобретения ПО.

8.2 ЗА ИСКЛЮЧЕНИЕМ СЛУЧАЕВ, ЯВНО ОПИСАННЫХ В НАСТОЯЩЕЙ СТАТЬЕ 8 (ОГРАНИЧЕННАЯ ГАРАНТИЯ. ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ), И ЗА ИСКЛЮЧЕНИЕМ ГАРАНТИЙ, УСЛОВИЙ И ЗАВЕРЕНИЙ, КОТОРЫЕ НЕ МОГУТ БЫТЬ ИСКЛЮЧЕНЫ ИЛИ ОГРАНИЧЕНЫ В СООТВЕТСТВИИ С ПРИМЕНИМЫМИ К ВАМ ЗАКОНОДАТЕЛЬСТВОМ, ПО, ВКЛЮЧАЯ БЕЗ ОГРАНИЧЕНИЙ ЛЮБУЮ ДОКУМЕНТАЦИЮ, ОБНОВЛЕНИЯ И ИСПРАВЛЕНИЯ, ПРЕДОСТАВЛЯЕТСЯ ВАМ ТАКИМ, КАКОВО ОНО ЕСТЬ, И КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ ВАМ НИКАКИХ ГАРАНТИЙ, УСЛОВИЙ И ЗАВЕРЕНИЙ (ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ НА ОСНОВАНИИ СТАТУТНОГО ПРАВА, ОБЩЕГО ПРАВА, ОБЫЧАЯ ИЛИ СУЩЕСТВУЮЩЕЙ ПРАКТИКИ) В ОТНОШЕНИИ ЧЕГО-ЛИБО, ВКЛЮЧАЯ ОТСУТСТВИЕ НАРУШЕНИЯ ПРАВ ТРЕТЬИХ ЛИЦ, ГОДНОСТИ ДЛЯ ПРОДАЖИ, ВОЗМОЖНОСТИ ИНТЕГРАЦИИ, УДОВЛЕТВОРИТЕЛЬНОГО КАЧЕСТВА ИЛИ ГОДНОСТИ ДЛЯ КОНКРЕТНОЙ ЦЕЛИ, ОТСУТСТВИЯ ОШИБОК, СООТВЕТСТВИЯ ВАШИМ ТРЕБОВАНИЯМ И ПРАВИЛЬНОГО ФУНКЦИОНИРОВАНИЯ ПРИ ИСПОЛЬЗОВАНИИ СОВМЕСТНО С ДРУГИМ ПРОГРАММНЫМ ИЛИ АППАРАТНЫМ ОБЕСПЕЧЕНИЕМ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ ПРОИЗВОДИТЕЛЬНОСТЬ И РЕЗУЛЬТАТЫ РАБОТЫ ПО. ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВСЕ РИСКИ В СВЯЗИ С КАЧЕСТВОМ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПО. КОМПАНИЯ ABBYY ТАКЖЕ НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ НА ПРОГРАММНЫЕ ПРОДУКТЫ ТРЕТЬИХ ЛИЦ, КОТОРЫЕ МОГУТ ПОСТАВЛЯТЬСЯ В СОСТАВЕ ПО.

9. Ограничение ответственности

9.1 КОМПАНИЯ ABBYY НИ ПРИ КАКИХ ОБСТОЯТЕЛЬСТВАХ НЕ НЕСЕТ ПЕРЕД ВАМИ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА УБЫТКИ, ВЫНУЖДЕННЫЕ ПЕРЕРЫВЫ В ДЕЛОВОЙ АКТИВНОСТИ, ПОТЕРЮ ДЕЛОВЫХ ЛИБО ИНЫХ ДАННЫХ ИЛИ ИНФОРМАЦИИ, ПРЕТЕНЗИИ ИЛИ РАСХОДЫ, КОСВЕННЫЕ, НЕПРЯМЫЕ, СЛУЧАЙНЫЕ, СПЕЦИАЛЬНЫЕ ИЛИ ШТРАФНЫЕ УБЫТКИ, А ТАКЖЕ УПУЩЕННУЮ ВЫГОДУ И УТЕРЯННЫЕ ДОХОДЫ, ВЫЗВАННЫЕ ИСПОЛЬЗОВАНИЕМ ИЛИ СВЯЗАННЫЕ С ИСПОЛЬЗОВАНИЕМ ПО, А ТАКЖЕ ЗА УБЫТКИ, ВЫЗВАННЫЕ ВОЗМОЖНЫМИ ОШИБКАМИ И ОПЕЧАТКАМИ В ПО, ДАЖЕ ЕСЛИ ПРЕДСТАВИТЕЛЮ КОМПАНИИ ABBYY СТАЛО ИЗВЕСТНО О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ, ПОТЕРЬ, ПРЕТЕНЗИЙ ИЛИ РАСХОДОВ, РАВНО КАК И ЗА ЛЮБЫЕ ПРЕТЕНЗИИ СО СТОРОНЫ ТРЕТЬИХ ЛИЦ. ВЫШЕПЕРЕЧИСЛЕННЫЕ ОГРАНИЧЕНИЯ И ИСКЛЮЧЕНИЯ ДЕЙСТВУЮТ В ТОЙ СТЕПЕНИ, НАСКОЛЬКО ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ. ЕДИНСТВЕННАЯ ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY ПО НАСТОЯЩЕМУ ЛИЦЕНЗИОННОМУ ДОГОВОРУ ИЛИ В СВЯЗИ С НИМ ОГРАНИЧИВАЕТСЯ СУММОЙ, КОТОРУЮ ВЫ УПЛАТИЛИ ЗА ПО, ЕСЛИ ТАКОВАЯ БЫЛА УПЛАЧЕНА.

10. Исключение Гарантии и Ограничения для пользователей, проживающих в Германии и Австрии

10.1 Если Вы приобрели экземпляр ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то в соответствии с законодательством Германии, Компания ABBYY гарантирует, что ПО предоставляет функциональность, перечисленную в сопроводительной документации (далее – договорная функциональность) в течение ограниченного гарантийного срока, отсчитываемого с момента получения Вами экземпляра ПО, при условии использования ПО на оборудовании рекомендованной конфигурации. В настоящем пункте термин «ограниченный гарантийный срок» означает 1 (один) год в случае коммерческого использования ПО и для юридических лиц, и 2 (два) года в случае некоммерческого использования ПО. Незначительные отклонения от договорной функциональности во внимание не принимаются и не являются основанием для действия вышеуказанной гарантии. Настоящая ограниченная гарантия не распространяется на ПО, предоставленное Вам бесплатно, например, на обновления, испытательные версии, пробные версии и на ПО, которое было изменено Вами до такой степени, что в нем появился дефект. Для того чтобы воспользоваться предоставленной гарантией в течение ограниченного гарантийного периода, Вы должны вернуть (за счет Компании ABBYY) ПО продавцу вместе с документом, подтверждающим покупку. В случае если функциональность ПО значительно отличается от договорной функциональности, Компания ABBYY имеет право на выбор по своему усмотрению исправить или заменить ПО. Если проблема не будет устранена, Вы имеете право на скидку (уменьшение первоначальной цены) или на расторжение договора купли-продажи (аннулирование договора). Дополнительную информацию о гарантийных обязательствах можно получить в Службе поддержки пользователей в Германии по адресу: ABBYY Europe GmbH, 80687, Германия, г. Мюнхен, Эльзенхаймерштрассе, 49, тел.: +49 (0)89 51 11 590, факс: +49 (0)89 51 11 5959.

10.2 Если Вы приобрели экземпляр ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то:

10.2.1 С учетом условий п. 10.2.2, ответственность Компании ABBYY за убытки, предусмотренная законом, ограничивается следующим: (i) Компания ABBYY несет ответственность только в том размере, который можно предвидеть в момент заключения договора купли-продажи для убытков в результате незначительного нарушения существенного контрактного обязательства и (ii) Компания ABBYY не несет ответственности за убытки в результате незначительного нарушения несущественного контрактного обязательства.

10.2.2 Ограничение ответственности, изложенное в п. 10.2.1 не распространяется на обязательную ответственность, предусмотренную законом, в частности, на ответственность согласно Закону Германии об ответственности за качество выпускаемой продукции, на ответственность за предоставление особенной гарантии и на ответственность за причиненные увечья.

10.2.3 Вы обязуетесь принять все разумные меры для предотвращения и уменьшения убытков, в том числе создание резервных копий ПО и принадлежащих Вам компьютерных данных, на которые распространяется действие положений Лицензионного договора.

11. Дополнительные Ограничения, распространяющиеся на ПО, приобретенное в США

11.1 Использование ПО правительственными учреждениями. В случае если данное ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных – Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

11.2 Экспортные ограничения. Запрещается экспортировать или реэкспортировать данное ПО в нарушение экспортных ограничений, установленных законодательством страны, в которой ПО было приобретено или получено. Вы также подтверждаете и гарантируете, что применимое законодательство не запрещает Вам получать данное ПО.

12. Технологии третьих лиц

12.1 Встроенные Шрифты. Шрифтовые программы охраняются авторским правом, и их владельцы могут налагать условия на использование шрифтов. Одним из условий может быть необходимость наличия лицензионной версии шрифтовой программы для встраивания шрифтов при создании новых PDF-файлов. Компания ABBYY не несет никакой ответственности за любые убытки, вызванные использованием Вами встраиваемых шрифтов.

12.2 Библиотека Adobe® PDF Library.

12.2.1 «ПО Adobe» означает Технологию Adobe® и сопутствующую документацию, а также любые новые версии, измененные версии, обновления, дополнения или копии вышеперечисленного.

12.2.2 Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Adobe в соответствии с условиями настоящего Лицензионного договора. Вы имеете право сделать одну резервную копию ПО Adobe при условии, что резервная копия не устанавливается на другой Компьютер и не используется на другом Компьютере.

12.2.3 Права на интеллектуальную собственность. ПО Adobe, входящее в состав ПО, является собственностью Adobe и поставщиков Adobe, а его структура, организация и программный код являются значимой коммерческой тайной Adobe и поставщиков Adobe. ПО Adobe также защищено законами США об авторском праве и международными соглашениями. Вы не имеете права копировать ПО Adobe за исключением случаев, оговоренных в настоящем Лицензионном договоре. Все копии, которые Вы имеете право сделать в соответствии с настоящим Лицензионным договором, должны включать в себя те же уведомления об авторских правах и о правах собственности, которые содержатся в или на ПО Adobe. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Adobe. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких прав на интеллектуальную собственность в отношении ПО Adobe.

12.2.4 Лицензия на использование шрифтов. В случае если ПО Adobe включает шрифты, Вы можете встраивать шрифты или контуры шрифтов в Ваши электронные документы в той мере, в какой производитель шрифта, обладающий авторскими правами на него, допускает подобное встраивание. Данный комплект может содержать как принадлежащие, так и не принадлежащие Adobe шрифты. Вы имеете право полностью встраивать любые шрифты, принадлежащие Adobe.

12.2.5 Гарантия. КОМПАНИЯ ABBYY И ЕЕ ПОСТАВЩИКИ НЕ ГАРАНТИРУЮТ И НЕ МОГУТ ГАРАНТИРОВАТЬ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО ADOBE, ВХОДЯЩЕГО В СОСТАВ ПО.

12.2.6 Экспортные ограничения. Вы согласны с тем, что ПО Adobe не будет поставляться, передаваться или экспортироваться в другие страны или использоваться в нарушение Закона США о контроле над экспортом (The United States Export Administration Act) или иных нормативно-правовых актов, накладывающих экспортные ограничения (далее все вместе – «Экспортные ограничения»). Кроме того, в случае если ПО Adobe в экспортных ограничениях определено как продукт, подлежащий экспортному контролю, Вы гарантируете, что не являетесь гражданином страны, на которую наложено эмбарго, не находитесь в такой стране и что экспортными ограничениями Вам не запрещено приобретать ПО Adobe, входящее в состав ПО. В случае несоблюдения Вами условий настоящего Лицензионного договора Вы лишаетесь всех прав на использование ПО Adobe предоставленных Вам настоящим Лицензионным договором.

12.2.7 Товарные знаки. Adobe и Adobe PDF Library являются товарными знаками или зарегистрированными товарными знаками компании Adobe Systems Incorporated в США и/или в других странах.

12.3 Библиотеки PixTools® Scan Runtime.

12.3.1 «ПО EMC» означает библиотеки PixTools Scan, драйверы Level 1 ISIS, драйверы Level 2 ISIS, и драйверы Level 3 ISIS. ПО может использовать ПО EMC для осуществления обмена данными между сканером и ПО через интерфейс ISIS.

12.3.2 Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО EMC, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора.

12.3.3 Права на интеллектуальную собственность. ПО EMC, входящее в состав ПО, является собственностью EMC Corporation и поставщиков EMC Corporation, а его структура, организация и программный код являются производственным секретом EMC Corporation и поставщиков EMC Corporation. ПО EMC также защищено законами США об авторском праве и международными соглашениями. Вы не имеете права копировать ПО EMC, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО EMC, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких прав на интеллектуальную собственность в отношении ПО EMC.

12.3.4 ГАРАНТИЯ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО EMC, ВХОДЯЩЕГО В СОСТАВ ПО. EMC CORPORATION И ПОСТАВЩИКИ EMC CORPORATION НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ УПУЩЕННУЮ ВЫГОДУ ИЛИ ПОТЕРЯННЫЕ СБЕРЕЖЕНИЯ, РАВНО КАК И ЗА ПРЕТЕНЗИИ, ПРЕДЪЯВЛЕННЫЕ ТРЕТЬИМИ ЛИЦАМИ.

Некоторые штаты и юрисдикции запрещают исключение или ограничение ответственности за косвенные или специальные убытки, поэтому вышеперечисленные ограничения могут на Вас не распространяться. У Вас могут быть и другие права, которые зависят от штата и юрисдикции.

12.3.5 Товарные знаки. ISIS и PixTools являются товарными знаками или зарегистрированными товарными знаками EMC Corporation в Соединенных Штатах Америки и/или в других странах.

12.4 Программное обеспечение Cuminas DjV ® SDK.

12.4.1 Вы, являясь конечным пользователем, имеете право использовать DjVu SDK в составе ПО Компании ABBYY в течение всего срока действия исключительного права на такое ПО или в течение более короткого срока, указанного в Лицензионном соглашении с конечным пользователем.

12.4.2 Условия лицензии. Вы не имеете права осуществлять самостоятельно или предоставлять возможность третьим лицам изучать, исследовать или испытывать функционирование ПО в целях определения идей и принципов, лежащих в основе любого элемента или компонента ПО, дизассемблировать, декомпилировать (воспроизводить и преобразовывать объектный код в исходный текст) или иным способом осуществлять попытку получить исходный текст ПО или любой части либо компонента ПО любым другим образом, за исключением случаев, разрешенных применимым законодательством, несмотря на данное ограничение, и только в объеме, разрешенном применимым законодательством. Если применимое законодательство запрещает ограничение подобных действий, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть немедленно сообщена Компании ABBYY. Любая подобная информация является конфиденциальной и принадлежит Компании ABBYY.

12.4.3 КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ ИЛИ УСЛОВИЙ (ПРЯМЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ЗАКОНОДАТЕЛЬСТВОМ, ОБЩИМ ПРАВОМ, ОБЫЧНЫМ ПРАВОМ И ОБЫЧАЯМИ ДЕЛОВОГО ОБОРОТА) ОТНОСИТЕЛЬНО ЧЕГО БЫ ТО НИ БЫЛО, ВКЛЮЧАЯ БЕЗ ОГРАНИЧЕНИЯ ГАРАНТИИ О СОБЛЮДЕНИИ ПРАВ ТРЕТЬИХ ЛИЦ, ТОВАРНОЙ ПРИГОДНОСТИ, ИНТЕГРИРУЕМОСТИ, УДОВЛЕТВОРИТЕЛЬНОГО КАЧЕСТВА И ГОДНОСТИ К ИСПОЛЬЗОВАНИЮ ДЛЯ ВЫПОЛНЕНИЯ КОНКРЕТНЫХ ЗАДАЧ. КОМПАНИЯ ABBYY ТАКЖЕ НЕ ГАРАНТИРУЕТ, ЧТО ПО НЕ СОДЕРЖИТ ОШИБОК, БУДЕТ УДОВЛЕТВОРЯТЬ ВАШИМ ТРЕБОВАНИЯМ ИЛИ ЧТО ПО БУДЕТ ФУНКЦИОНИРОВАТЬ ДОЛЖНЫМ ОБРАЗОМ ПРИ ИСПОЛЬЗОВАНИИ СОВМЕСТНО С ЛЮБЫМ ДРУГИМ ПРОГРАММНЫМ ИЛИ АППАРАТНЫМ ОБЕСПЕЧЕНИЕМ. КОМПАНИЯ ABBYY НЕ ГАРАНТИРУЕТ И НЕ МОЖЕТ ГАРАНТИРОВАТЬ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО. ВСЕ РИСКИ, СВЯЗАННЫЕ С КАЧЕСТВОМ РАБОТЫ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПО, ВОЗЛАГАЮТСЯ НА ВАС. ТАКЖЕ, КОМПАНИЯ ABBYY НЕ ПРЕДОСТАВЛЯЕТ НИКАКИХ ГАРАНТИЙ ОТНОСИТЕЛЬНО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ ТРЕТЬИХ ЛИЦ, КОТОРОЕ МОЖЕТ БЫТЬ ПОСТАВЛЕНО ВМЕСТЕ С ПО.

12.4.4 КОМПАНИЯ ABBYY НИ ПРИ КАКИХ ОБСТОЯТЕЛЬСТВАХ НЕ ДОЛЖНА НЕСТИ ПЕРЕД ВАМИ НИКАКУЮ ОТВЕТСТВЕННОСТЬ ЗА УЩЕРБ, ВЫНУЖДЕННЫЕ ПЕРЕРЫВЫ В ДЕЛОВОЙ АКТИВНОСТИ, ПОТЕРЮ ДЕЛОВЫХ ЛИБО ИНЫХ ДАННЫХ ИЛИ ИНФОРМАЦИИ, ЗА ПРЕТЕНЗИИ ИЛИ РАСХОДЫ, КОСВЕННЫЕ, ОПОСРЕДОВАННЫЕ, СЛУЧАЙНЫЕ, ФАКТИЧЕСКИЕ ИЛИ ШТРАФНЫЕ УБЫТКИ, А ТАКЖЕ УПУЩЕННУЮ ВЫГОДУ И УТЕРЯННЫЕ СБЕРЕЖЕНИЯ, ВЫЗВАННЫЕ ИСПОЛЬЗОВАНИЕМ И/ИЛИ СВЯЗАННЫЕ С ИСПОЛЬЗОВАНИЕМ ПО, А ТАКЖЕ ЗА УЩЕРБ, ВЫЗВАННЫЙ ВОЗМОЖНЫМИ ОШИБКАМИ И ОПЕЧАТКАМИ В ПО, ДАЖЕ ЕСЛИ ПРЕДСТАВИТЕЛЮ КОМПАНИИ ABBYY СТАЛО ИЗВЕСТНО О ВОЗМОЖНОСТИ ТАКОГО УЩЕРБА, ПОТЕРЬ, ПРЕТЕНЗИЙ ИЛИ РАСХОДОВ, РАВНО КАК И ЗА ЛЮБЫЕ ПРЕТЕНЗИИ СО СТОРОНЫ ТРЕТЬИХ ЛИЦ. ВЫШЕПЕРЕЧИСЛЕННЫЕ ОГРАНИЧЕНИЯ И ИСКЛЮЧЕНИЯ ДЕЙСТВУЮТ В ТОЙ СТЕПЕНИ, НАСКОЛЬКО ЭТО РАЗРЕШЕНО ПРИМЕНИМЫМ ЗАКОНОДАТЕЛЬСТВОМ. В ЛЮБОМ СЛУЧАЕ ОТВЕТСТВЕННОСТЬ КОМПАНИИ ABBYY В СВЯЗИ С ПО ОГРАНИЧИВАЕТСЯ СУММОЙ, КОТОРУЮ ВЫ УПЛАТИЛИ ЗА ЛИЦЕНЗИЮ НА ПО, ЕСЛИ ТАКОВАЯ БЫЛА УПЛАЧЕНА.

12.4.5 Ограничения на ПО, приобретенное в США:

a) Использование правительственными учреждениями. В случае если ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных - Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

b) Ограничения на экспорт. Запрещается экспортировать или реэкспортировать данное ПО в нарушение экспортных ограничений, установленных законодательством страны, в которой ПО было приобретено или получено. Вы подтверждаете и гарантируете, что применимое законодательство не запрещает Вам получать данное ПО.

12.4.6 Программный код третьих лиц:

12.4.6.1 Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Разрешается распространение и использование в исходном и двоичном формате при соблюдении следующих условий. В распространяемом исходном коде должно быть сохранено вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности. При распространении в двоичном формате вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности должны быть воспроизведены в документации и/или в иных материалах, поставляемых совместно с распространяемыми файлами.

АВТОР И СОАВТОРЫ ПРЕДОСТАВЛЯЮТ НАСТОЯЩЕЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ТАКИМ, КАКОВО ОНО ЕСТЬ, И ОТКАЗЫВАЮТСЯ ОТ ПРЕДОСТАВЛЕНИЯ КАКИХ БЫ ТО НИ БЫЛО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ КАКОЙ-ЛИБО КОНКРЕТНОЙ ЦЕЛИ. АВТОР И СОАВТОРЫ НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ, КОСВЕННЫЕ, СЛУЧАЙНЫЕ ЛИБО ФАКТИЧЕСКИЕ УБЫТКИ (ВКЛЮЧАЯ ПРИОБРЕТЕНИЕ ТОВАРОВ ИЛИ УСЛУГ-ЗАМЕНИТЕЛЕЙ, НЕВОЗМОЖНОСТЬ ДАЛЬНЕЙШЕГО ИСПОЛЬЗОВАНИЯ, ПОТЕРЮ ДАННЫХ, УПУЩЕННУЮ ВЫГОДУ И ВЫНУЖДЕННЫЙ ПЕРЕРЫВ В ХОЗЯЙСТВЕННОЙ ДЕЯТЕЛЬНОСТИ) НЕЗАВИСИМО ОТ ТОГО, ЧЕМ ОНИ ВЫЗВАНЫ, И НЕЗАВИСИМО ОТ ДОКТРИНЫ ОТВЕТСТВЕННОСТИ, БУДЬ ТО КОНТРАКТ, ОБЪЕКТИВНАЯ ОТВЕТСТВЕННОСТЬ ИЛИ ДЕЛИКТ (ВКЛЮЧАЯ ИЛИ НЕ ВКЛЮЧАЯ НЕБРЕЖНОСТЬ), КОТОРЫЕ ВОЗНИКЛИ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ НАСТОЯЩЕГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ, ДАЖЕ ЕСЛИ АВТОРЫ И СОАВТОРЫ БЫЛИ ПОСТАВЛЕНЫ В ИЗВЕСТНОСТЬ О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ.

12.4.6.2 Часть настоящего программного обеспечения основана на алгоритме MD5 Message-Digest Algorithm компании RSA Data Security, Inc. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. Все права защищены.

Разрешается распространение и использование в исходном и двоичном формате при соблюдении следующих условий. В распространяемом исходном коде должно быть сохранено вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности. При распространении в двоичном формате вышеуказанное уведомление об авторских правах, настоящий список условий и нижеприведенный отказ от гарантий и ответственности должны быть воспроизведены в документации и/или в иных материалах, поставляемых совместно с распространяемыми файлами. Наименование университета Хиросимы и имена авторов не должны использоваться для рекламы или продвижения продуктов, созданных на основе настоящего программного обеспечения, без их предварительного письменного согласия.

ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ И СОАВТОРЫ ПРЕДОСТАВЛЯЮТ НАСТОЯЩЕЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ТАКИМ, КАКОВО ОНО ЕСТЬ, И ОТКАЗЫВАЮТСЯ ОТ ПРЕДОСТАВЛЕНИЯ КАКИХ БЫ ТО НИ БЫЛО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ТОВАРНОЙ ПРИГОДНОСТИ ИЛИ ПРИГОДНОСТИ ДЛЯ КАКОЙ-ЛИБО КОНКРЕТНОЙ ЦЕЛИ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ И СОАВТОРЫ НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ, КОСВЕННЫЕ, СЛУЧАЙНЫЕ ЛИБО ФАКТИЧЕСКИЕ УБЫТКИ (ВКЛЮЧАЯ ПРИОБРЕТЕНИЕ ТОВАРОВ ИЛИ УСЛУГ-ЗАМЕНИТЕЛЕЙ, НЕВОЗМОЖНОСТЬ ДАЛЬНЕЙШЕГО ИСПОЛЬЗОВАНИЯ, ПОТЕРЮ ДАННЫХ, УПУЩЕННУЮ ВЫГОДУ И ВЫНУЖДЕННЫЙ ПЕРЕРЫВ В ХОЗЯЙСТВЕННОЙ ДЕЯТЕЛЬНОСТИ) НЕЗАВИСИМО ОТ ТОГО, ЧЕМ ОНИ ВЫЗВАНЫ, И НЕЗАВИСИМО ОТ ДОКТРИНЫ ОТВЕТСТВЕННОСТИ, БУДЬ ТО КОНТРАКТ, ОБЪЕКТИВНАЯ ОТВЕТСТВЕННОСТЬ ИЛИ ДЕЛИКТ (ВКЛЮЧАЯ ИЛИ НЕ ВКЛЮЧАЯ НЕБРЕЖНОСТЬ), КОТОРЫЕ ВОЗНИКЛИ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ НАСТОЯЩЕГО ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ, ДАЖЕ ЕСЛИ АВТОРЫ И СОАВТОРЫ БЫЛИ ПОСТАВЛЕНЫ В ИЗВЕСТНОСТЬ О ВОЗМОЖНОСТИ ТАКИХ УБЫТКОВ.

12.5 Wibu-Systems

12.5.1 WIBU, CodeMeter, SmartShelter, SmartBind являются зарегистрированными товарными знаками Wibu-Systems.

12.6 Другие лицензируемые технологии. Настоящее ПО используется согласно лицензиям на патенты США № 5 625 465 и 5 768 416.

13. Применимое право

13.1 В случае если Вы приобрели ПО на территории США, Белиза, Виргинских Островов, Гватемалы, Гондураса, Канады, Коста-Рики, Мексики, Монтсеррата, Никарагуа, Панамы, Сальвадора, Тайваня, островов Теркс и Кайкос или Японии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство штата Калифорния Соединенных Штатов Америки. Вы согласны с тем, что, в случае, если Вы приобрели ПО на территории Соединенных Штатов Америки, то ПО продано Вам ABBYY USA Software House Inc. и все споры в отношении настоящего Лицензионного договора и/или ПО подлежат разрешению исключительно в федеральном суде и/или суде штата в округе Санта-Клара штата Калифорния.

13.2 В случае, если Вы приобрели ПО на территории Австрии, Бельгии, Германии, Дании, Испании, Италии, Люксембурга, Нидерландов, Португалии, Финляндии, Франции, Швеции или на территории любого другого государства, являющегося членом Европейского Союза, за исключением Греции, Кипра и Мальты, и не указанного явно в п.п.13.3, 13.4 или 13.5 настоящего Лицензионного договора, а также на территории Исландии, Лихтенштейна, Норвегии, или Швейцарии, к отношениям по настоящему Лицензионному договору применяется материальное право, действующее в г. Мюнхене, республика Германия. Все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в суде г. Мюнхена.

13.3 В случае, если Вы приобрели ПО на территории Великобритании или Республики Ирландии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство Англии и Уэльса. Все споры, вытекающие из настоящего Лицензионного договора подлежат разрешению исключительно в судах Англии и Уэльса.

13.4 В случае, если Вы приобрели ПО на территории России, Белоруссии, Казахстана или другого государства, являющегося членом Содружества Независимых Государств (СНГ), за исключением Украины и Молдавии, а также на территории Эстонии, Грузии, Латвии и Литвы, к отношениям по настоящему Лицензионному договору применяется материальное право Российской Федерации.

13.5 В случае, если Вы приобрели ПО на территории Албании, Болгарии, Боснии и Герцеговины, Греческой Республики, Венгрии, Израиля, Македонии, Польши, Румынии, Словакии, Словении, Турции, Хорватии, Чехии, Сербии, Черногории, Украины или Молдавии, к отношениям по настоящему Лицензионному договору применяется материальное право Украины, за исключением случаев, когда ПО было приобретено лицом, имеющим статус потребителя в соответствии с Гражданским кодексом Польши. Законодательство Польши применяется к таким потребителям.

13.6 В случае, если ПО было приобретено в стране, указанной в п. 13.5 и Вы являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в Международном Коммерческом Арбитражном суде при Торгово-промышленной палате Украины в соответствии с правилами и процедурами, установленными его Регламентом. Решение Международного Коммерческого Арбитражного суда при Торгово-промышленной палате Украины является окончательным и подлежит обязательному исполнению. В случае если ПО было приобретено в стране, указанной в п. 13.5 и Вы являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Шевченковском районном суде г. Киева.

13.7 В случае если ПО было приобретено в стране, указанной в п. 13.4 и Вы являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению исключительно в Арбитражном суде г. Москвы, Российская Федерация. В случае если ПО было приобретено в стране, указанной в п.13.4 и Вы являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Кузьминском районном суде г. Москвы.

13.8 В случае если ПО было приобретено в стране, указанной в п.п. 13.1-13.5, к отношениям по настоящему Лицензионному договору не применяются никакие коллизионные нормы, а также нормы Конвенции ООН о договорах международной купли-продажи товаров.

13.9 В случае если ПО было приобретено в стране, не указанной в п.п. 13.1 - 13.5, к отношениям по настоящему Лицензионному договору применяется действующее законодательство страны, в которой Вы приобрели ПО.

14. Срок действия

14.1 Если иное не оговорено в настоящем Лицензионном договоре или в документации к ПО, либо в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY, настоящий Лицензионный договор действует неограниченно, начиная с даты, когда Вы в первый раз выразили свое согласие с его условиями, как это описано в начале настоящего Лицензионного договора, или в течение всего срока, разрешенного применимым законодательством. В случае если в соответствии с применимым законодательством необходимо указать срока действия настоящего Лицензионного договора, настоящий Лицензионный договор действует в течение всего срока, разрешенного применимым законодательством, но не меньше, чем срок действия исключительного права на ПО, и без предварительного уведомления автоматически прекращает действие по истечении этого срока.

14.2 Без ущерба для каких-либо других прав Компания ABBYY имеет право расторгнуть Лицензионный договор в случае нарушения Вами положений и условий Лицензионного договора. В этом случае Вы обязаны уничтожить все экземпляры ПО и Компонентов ПО и удалить ПО с ваших Компьютеров.

14.3 Вы можете расторгнуть настоящий Лицензионный договор, уничтожив все экземпляры ПО, все Компоненты и удалив ПО.

14.4 Такое расторжение настоящего Лицензионного договора не освобождает Вас от обязательств оплатить приобретение ПО. Вне зависимости от причин расторжения или прекращения действия Лицензионного договора, Разделы 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 и п. 3.4.4 сохраняют свою силу и после расторжения или прекращения действия Лицензионного договора, однако это не дает Вам права продолжать использовать ПО после расторжения или прекращения действия настоящего Лицензионного договора.

15. Прочие условия

15.1 В процессе Активации, установки и работы, а также при оказании технической поддержки в отношении ПО Компания ABBYY может запросить у Вас определенные персональные данные (в частности, Ваше имя, адрес, адрес электронной почты, номер телефона). Настоящим Вы соглашаетесь предоставить Компании ABBYY такие персональные данные. Вы имеете право отказаться от предоставления Ваших персональных данных Компании ABBYY, что может привести к отказу со стороны Компании ABBYY оказать Вам техническую поддержку в отношении ПО, которая оказывается клиентам Компании ABBYY, предоставившим свои персональные данные, если предоставление персональных данных необходимо для оказания технической поддержки или является одним из условий оказания технической поддержки и не противоречит применимому законодательству. Вы согласны не предоставлять больше персональных данных, чем запрашивает Компания ABBYY или Партнер Компании ABBYY и согласны с тем, что Ваши персональные данные могут обрабатываться (в том числе собираться и/или иным образом использоваться) Компанией ABBYY, аффилированными лицами Компании ABBYY и/или Партнерами Компании ABBYY в соответствии с применимыми законами и при условии соблюдения конфиденциальности и обеспечения защиты предоставленных данных, если это предусмотрено применимым законодательством. Все персональные данные, которые Вы предоставите Компании ABBYY, аффилированным лицам Компании ABBYY или Партнерам Компании ABBYY будут обрабатываться, храниться и использоваться исключительно внутри Компании ABBYY, аффилированных лиц Компании ABBYY или Партнеров Компании ABBYY и не будут раскрываться третьим лицам, если только такое раскрытие не требуется применимым законодательством, а в случае хранения и обработки данных компанией ABBYY Software House Inc. на них распространяется политика конфиденциальности, текст которой находится по адресу http://abbyy.com/privacy_policy. Персональные данные будут обрабатываться исключительно с целью выполнения Компанией ABBYY своих обязательств по настоящему Лицензионному договору. В случае если Вы приобрели ПО в стране, указанной в п. 13.5, Ваши персональные данные будут обрабатываться в базе данных под названием «Физические лица, персональные данные которых обрабатываются при осуществлении деловых операций».

15.2 Вы согласны с тем, что ПО может соединяться с сервером Компании ABBYY через интернет или по электронной почте в процессе Активации, деактивации или обновления. Компания ABBYY предпримет разумные шаги с целью предотвратить передачу Ваших персональных данных во время таких соединений.

15.3 Компания ABBYY имеет право присылать Вам письма по электронной почте, содержащие новости о продуктах и о Компании ABBYY, информацию о специальных предложениях, советы по использованию продуктов и другую информацию, связанную с деятельностью и продуктами Компании ABBYY, при условии, что Вы явным образом согласились получать такую информацию от Компании ABBYY. Вы можете в любое время обратиться к Компании ABBYY с просьбой удалить адрес Вашей электронной почты из списка рассылки Компании ABBYY.

15.4 В случае предъявления Вам претензий или исков в связи с использованием Вами ПО, Вы обязуетесь сообщить Компании ABBYY о таких фактах в течение трех (3) календарных дней с момента, когда Вам стало известно об их возникновении. Вы обязуетесь совершить все необходимые действия для предоставления Компании ABBYY возможности участвовать в рассмотрении таких претензий или исков в суде, а также предоставлять необходимую информацию для урегулирования соответствующих претензий или исков не позднее семи (7) календарных дней с даты получения запроса от Компании ABBYY.

15.5 Вознаграждением по настоящему Лицензионному договору признается стоимость Лицензии на ПО, установленная Компанией ABBYY или Партнером Компании ABBYY, которая подлежит уплате в соответствии с определяемым Компанией ABBYY или Партнером Компании ABBYY порядком, либо входит в стоимость приобретенного Вами оборудования или аппаратных средств, либо является частью вознаграждения, которое подлежит уплате в случае приобретения Вами полной версии ПО. В случае если Вы являетесь физическим лицом, настоящий Лицензионный договор может быть безвозмездным.

15.6 В случае если какая-либо часть настоящего Лицензионного договора будет признана утратившей юридическую силу, недействительной или не подлежащей исполнению, остальные части Лицензионного договора сохраняют свою юридическую силу и подлежат исполнению.

Collapsed Лицензионный договор с конечным пользователем на английском языке

End-User License Agreement (EULA)

ABBYY® FlexiCapture®

Important! Read the following terms carefully before installing, copying and/or otherwise using ABBYY FlexiCapture (hereinafter referred to as “the SOFTWARE”). Installing, copying or otherwise using the SOFTWARE indicates Your acceptance of these terms. This End-User License Agreement (hereinafter referred to as the “EULA”) is a legal agreement between you, the end user, who obtained or is using the SOFTWARE, and ABBYY.

This EULA comes into force when You demonstrate your consent to be bound by its terms by selecting the “I accept the terms of the license agreement” button followed by selecting the “next” button and installing the SOFTWARE or when You install, copy or start using the SOFTWARE in any manner. Any such act is deemed to demonstrate Your acknowledgment that you have read this EULA, that You understand it and agree to be bound by its terms. If You do not agree to the terms of this EULA, do not use the SOFTWARE and disable, remove it from Your system and destroy Your copies of the SOFTWARE. This EULA is binding for the entire period of the SOFTWARE copyright unless otherwise stated in this EULA or in a separate written agreement between You and ABBYY or ABBYY’s Partner and may depend on the scope of the License as it is described in the EULA.

The SOFTWARE is protected by copyright laws and international treaty provisions and some portions are protected by patent and trade secret laws. You agree that this EULA is enforceable like any written negotiated agreement signed by you. This EULA is enforceable against You.

If the SOFTWARE is accompanied by a hard copy of separate agreement with ABBYY or an ABBYY Partner, governing terms of Your use of the SOFTWARE, then, in the case of any discrepancies in content between the text of this EULA and the text in the hard copy of such separate agreement, the text in the hard copy of the separate agreement shall prevail.

The EULA may be available in different languages. There may be inconsistencies or differences in interpretation between the English version of the EULA and those EULAs made available in other languages. For the sake of uniformity and to avoid any ambiguity, the English version of the EULA shall govern in all disputes, claims or proceedings to interpret, enforce or otherwise relating to the EULA.

Definitions

“ABBYY” means

ABBYY USA Software House Inc. registered at 880 North McCarthy Boulevard, Suite 220, Milpitas, California, 95035, USA, when article 13.1 of this EULA applies;

ABBYY Europe GmbH registered at Elsenheimerstrasse, 49, 80687, Munich, Germany, when article 13.2 of this EULA applies;

ABBYY UK Ltd. Registered at Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, United Kingdom, when article 13.3 of this EULA applies;

ABBYY Production LLC registered at 1-ya ul. Tekstilshikov, d. 12/9, office 2, 109390, Moscow, Russia, when article 13.4 of this EULA applies;

ABBYY Software House Ukraine registered at 31, Degtyarevskaya st., Kiev, Ukraine, 03680, when article 13.5 of this EULA applies;

and ABBYY Solutions Ltd., registered at Michail Karaoli 2, Egkomi, CY 2404, Nicosia, Cyprus, in all other cases.

“ABBYY Partner” means an entity or individual who is licensed by ABBYY to resell and distribute licensed copies of the SOFTWARE to End Users, either directly or through one or more sub-resellers or sub-distributors.

“Activation” means the procedure whereby the Serial number is checked for validity and the installed SOFTWARE is made fully operational in accordance with the SOFTWARE documentation and the scope of Your License.

“Computer” means a specific physical device or virtual machine that may consist of one or more CPU (central processing unit) cores and running specified operating system. Any changes to the configuration or composition of the Computer could result in the Computer being considered a different Computer for licensing purposes.“Intellectual Property Rights” means all intellectual and industrial property rights and includes rights to (i) inventions, discoveries, and letters patent including applications therefor, reissues thereof, and continuation and continuations in part; (ii) copyrights; (iii) designs and industrial designs; (iv) trademarks, service marks, trade dress and similar rights; (v) know-how, trade secrets and confidential information; (vi) integrated circuit topography rights and rights in mask works; and (vii) other proprietary rights.

“License” means the non-exclusive limited right granted to You by ABBYY to install and use the functionality of the SOFTWARE in accordance with the terms and conditions of this EULA.

“Serial number” means a unique identifier of License or License group with similar parameters that is being given by ABBYY or an ABBYY Partner to the End User.

“SOFTWARE” means any version or edition of ABBYY FlexiCapture including any and all software components (add-ons, custom components and modules, etc.) embedded in the software or made available online or by other ways such as: executable, help, demo, sample and other files; libraries, databases, samples, associated media (images, photos, animation, audio-video components, music etc.), printed materials, and other software components.

“You”, “Your” and “End User” refer to and include any person and/or any entity that obtained this SOFTWARE for its own use and not for purposes of further resale and any actual user of the SOFTWARE.

1. License Grant

1.1 Subject to the terms and conditions of the EULA ABBYY grants to You a limited, non-exclusive License to install and use functionality of the SOFTWARE subject to all restrictions and the scope of the License as may be provided by: this EULA, the software and/or hardware license keys provided by ABBYY (“License Key”), the SOFTWARE, and/or a separate written agreement between You and ABBYY or an ABBYY Partner. All provisions stated herein apply both to the SOFTWARE as a whole and to all of its separate components. Any issue with respect to the scope of the license shall be construed in favour of restrictions on the scope of the license. The License Key technically restricts the use of the SOFTWARE and reflects the scope of the License You obtained. Restrictions on Your use of the SOFTWARE and the scope of Your License may include but are not limited to the following:

1.1.1 Number of seats, SOFTWARE components and network access. You may install the SOFTWARE on more than one Computer on a Network and simultaneously use specified components of the SOFTWARE on a specified number of Computers on a Network (“concurrent licensing”). Information about the available SOFTWARE components and the number of Computers on a Network allowed for simultaneous work with the SOFTWARE is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.2 Processing volume. The number of pages that may be processed by the SOFTWARE may be limited in one or more ways, such as limitations on the number of pages that may be processed within particular time periods, such as monthly or annually, or on the overall number of pages that may be processed. The size of the page and the number of data fields per document may also be limited. Processing volume limitations are specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner

1.1.3 Duration. Use of the SOFTWARE may be limited by a fixed period of time, and the SOFTWARE may not be used beyond the expiration of such time period. Limitation of the duration is specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.1.4 Features, add-ons and custom components. The use of particular features, add-ons and/or custom components of the SOFTWARE may be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.2 Processing power. The number of CPU (central processing unit) cores of the Computers which can be utilized by the SOFTWARE may also be limited by License Key and/or written agreement between You and ABBYY or an ABBYY Partner. All rights not expressly granted to You by the EULA are reserved by ABBYY. This EULA does not grant You any rights in connection with any trademarks of ABBYY.

1.3 If Article 13.4 applies and You are an individual human being person, You may use the SOFTWARE worldwide. If Article 13.4 applies and You are an entity, the SOFTWARE may be obtained (purchased) only in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner. The employees of the entity or of its branch and representative offices may use the SOFTWARE worldwide, provided the SOFTWARE has been obtained and installed in the country where the entity or its branch and representative offices are registered, unless otherwise agreed in a separate written agreement between You and ABBYY or an ABBYY Partner.

1.4 Any use of the SOFTWARE or component parts outside of or in contravention of the terms and conditions of this EULA shall constitute a breach of ABBYY’s and/or third parties’ intellectual property rights and shall give cause for the revocation of all rights to use the SOFTWARE granted to You under this EULA.

1.5 If You deploy or use the SOFTWARE in a virtual environment, at no time may access or use of the SOFTWARE exceed the restrictions on the SOFTWARE, or the scope of the license that has been granted. For instance, the same License Key may not be used to permit use or access to the SOFTWARE in a virtual environment by a number of Computers that is greater than the number of Computers for which a license has been properly obtained, nor may the SOFTWARE be used to process more than the total number of pages that has been permitted.

1.6 If You deploy the SOFTWARE by using terminal services which allow accessing the SOFTWARE on a remote computer over a network, the amount of simultaneously running instances of the SOFTWARE may not exceed the number of Computers for which a License has been obtained.

1.7 If You use the SOFTWARE by means of a web browser, You may simultaneously access the SOFTWARE by as many Computers as permitted by the scope of Your License and specified in the License Key and/or written agreement between You and ABBYY or an ABBYY Partner.

1.8 You may receive the SOFTWARE on more than one medium (multiple-media SOFTWARE), including downloads over the Internet. Regardless of the quantity or type of media You receive, You are only licensed to use the SOFTWARE in accordance with the scope of the SOFTWARE License.

2. Limitations of Use

2.1 In order to use the SOFTWARE You should perform Activation of the SOFTWARE after installation.

2.2 All terms of use and limitations governing the use of the SOFTWARE are stated in this EULA, unless otherwise stipulated in a separate written agreement between You and ABBYY or an ABBYY Partner or in other documentation accompanying the SOFTWARE.

2.3 You may not perform or make it possible for other persons to perform any activities included in the list below:

2.3.1 Reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

2.3.2 Modify, adapt (including any changes for the purpose of enabling the SOFTWARE to run on Your hardware), or make any changes to the object code of the Software, applications and databases contained in the SOFTWARE other than those provided for by the SOFTWARE and described in the documentation.

2.3.3 Correct errors in the SOFTWARE or translate the SOFTWARE without the prior written consent of ABBYY.

2.3.4 Rent, lease, sublicense, assign or transfer any rights granted to You by this EULA and other rights related to the SOFTWARE to any other person or authorize all or any portion of the SOFTWARE to be copied onto another computers (except as described in article 2.6)

2.3.5 Make it possible for any person not entitled to use the SOFTWARE to access and/or use the SOFTWARE, including without limitation in a multi-user system, virtual environment, or via the Internet.

2.3.6 Remove, change or obscure any copyright, trademark or patent notices that appear on the SOFTWARE as delivered to You.

2.4 You may not use the SOFTWARE to provide paid or free recognition or conversion services and/or to provide the results or access to the results acquired through the use of the SOFTWARE as a part of another service that has recognition or conversion as its component to any third party unless You have signed a separate written agreement with ABBYY and Your License Key has the parameter “BPO services” enabled.

2.5 You may not bypass the SOFTWARE’s user interface that is provided with the SOFTWARE, without an additional written agreement with ABBYY.

2.6 You may only make a one-time permanent transfer of this SOFTWARE only directly to another end user. If you are an entity, such a transfer requires written approval by ABBYY. This transfer must include all of the SOFTWARE (including all copies, SOFTWARE Components, the media and printed materials, any updates) and this EULA. Such transfer may not be by way of consignment or any other indirect transfer. The transferee of such one-time transfer must agree to comply with the terms of this EULA, including the obligation not to further transfer this SOFTWARE. You must uninstall the SOFTWARE from all of Your Computers or from Your Local Area Network in the case of such SOFTWARE transfer.

3. Pre-release, Trial or Demo SOFTWARE

3.1 If the SOFTWARE You have received with this License is a pre-commercial release or Beta-Release Software, provided for a trial or for demonstration, verification or testing purposes, has limited or less than full functionality, labeled “Try&Buy” “Trial”, “Demo” or was provided at no charge (“Restricted Software”), then this article 3 shall apply until such time that You obtain (purchase) a license for the full version of the SOFTWARE. To the extent that any provision in this is in conflict with any other term or condition in this EULA, this article shall supersede such other term(s) and condition(s) with respect to the Restricted Software, but only to the extent necessary to resolve the conflict.

3.2 THE RESTRICTED SOFTWARE IS PROVIDED TO YOU “AS IS” AND WITHOUT WARRANTY OR INDEMNITY (EXPRESS, IMPLIED OR STATUTORY) OF ANY KIND. THE RESTRICTED SOFTWARE DOES NOT REPRESENT FINAL SOFTWARE FROM ABBYY, AND MAY CONTAIN BUGS, ERRORS AND OTHER PROBLEMS THAT COULD CAUSE SYSTEM OR OTHER FAILURES AND DATA LOSS. TO THE GREATEST EXTENT ALLOWABLE UNDER APPLICABLE LAWS, NO WARRANTY SHALL APPLY TO THE RESTRICTED SOFTWARE, AND FOR CLARITY YOU ACKNOWLEDGE THAT ABBYY DISCLAIMS ANY WARRANTY OR LIABILITY OBLIGATIONS TO YOU OF ANY KIND, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF TITLE, MERCHANTABILITY, NON-INFRINGEMENT, QUIET ENJOYMENT, AND FITNESS FOR A PARTICULAR PURPOSE. WHERE LIABILITY CANNOT BE EXCLUDED BUT MAY BE LIMITED, ABBYY’S TOTAL LIABILITY AND THAT OF ITS PARTNERS SHALL BE LIMITED TO THE SUM OF FIFTY UNITED STATES DOLLARS (U.S. $50) OR THE TOTAL AMOUNT YOU PAID FOR THE SOFTWARE, WHICHEVER IS GREATER.

3.3 Restricted Software may have limited functionality, such as having functionality for a limited period of time, and upon expiration of permitted functionality (“time-out”), Your access and ability to use the Restricted Software may be disabled. Upon a time-out, Your rights under the EULA shall terminate, unless You obtain a new license from ABBYY.

3.4 Restricted Software for which there has not been a commercial release.

3.4.1 Restricted Software for which there has not been a commercial release constitutes the Confidential Information of ABBYY.

3.4.2 As to Restricted Software for which there has not been a commercial release, ABBYY does not promise or guarantee, has no express or implied obligation, and You acknowledge that ABBYY has not promised or guaranteed, that such software will be further developed, or that a commercial version will be announced or made available in the future. ABBYY may not introduce a software product similar to or compatible with such software. Accordingly, You acknowledge that any use, research or development that You perform regarding such software is done entirely at Your own risk.

3.4.3 You agree to provide feedback to ABBYY regarding testing and use of the Restricted Software, including error or bug reports (“Feedback”), and to entirely transfer and grant to ABBYY all rights in such Feedback, including without limitation, the rights to use, publish and disseminate the Feedback. All Feedback constitutes the Confidential Information of ABBYY.

3.4.4 Confidentiality of Restricted Software for which there has not been a commercial release and its Results;

3.4.4.1 You agree not to disclose accompanying written, oral or electronic information divulged to You by ABBYY related to the Restricted Software for which there has not been a commercial release, any information about the quality of such Restricted Software or the quality of the results acquired through the use of such Restricted Software, Feedback, and any information about bugs, errors and other problems discovered by You in the Restricted Software for which there has not been a commercial release are the Confidential Information of ABBYY.

3.4.4.2 You shall not disclose Confidential Information. The term “disclose” means to display, describe, copy, lease, loan, rent, assign, transfer or provide access, over a network or otherwise, to Confidential Information reproduced in any form, including oral communications, to any third party.

3.4.4.3 You shall take all reasonable steps to prevent the disclosure of Confidential Information and to keep it confidential.

3.4.4.4 You shall promptly inform ABBYY if You become aware of any disclosure of Confidential Information. If You are in breach of the terms and conditions set forth in articles 3.4.4.1 - 3.4.4.3 above, You shall compensate ABBYY for any loss resulting from such breach.

3.5 Upon receipt of a later version of Restricted Software or a commercial release of such software, whether as a stand-alone product or as part of a larger product, You agree to return or destroy all earlier versions of the Restricted Software received from ABBYY.

3.6 If You have been provided the Restricted Software pursuant to a separate written agreement Your use of the SOFTWARE is also governed by such agreement. To the extent that any term or condition of a separate written agreement are in conflict with any term or condition of this EULA, a separate written agreement shall supersede such other term(s) and condition(s) with respect to the SOFTWARE, but only to the extent necessary to resolve the conflict.

4. Not-for-resale SOFTWARE

4.1 If the SOFTWARE is labeled “Not for Resale” or “NFR,” then, notwithstanding other articles of this EULA, You may only use such SOFTWARE for demonstration, verification or testing purposes.

5. Updates

5.1 If the SOFTWARE is labeled as an update, You must own a license for the previous version of the SOFTWARE identified by ABBYY as being eligible for this update in order to use the SOFTWARE.

5.2 The SOFTWARE labeled as an update replaces and/or supplements the product that formed the basis for Your eligibility for the update.

5.3 You may only use the resulting updated product in accordance with the terms of the EULA supplied with this update.

5.4 You acknowledge that any obligation ABBYY may have to support the version of the SOFTWARE being updated shall end upon the availability of the update.

6. Technical Support and Maintenance

6.1 You may be provided with technical support and maintenance related to the SOFTWARE (“Support Services”) subject to the current ABBYY support policy. However, You may be entitled to a different level of Support Services than is stated in the ABBYY support policy in accordance with a written agreement executed between You and ABBYY or an ABBYY Partner with respect to such Support Services.

6.2 General terms and conditions of the ABBYY support policy are published on the ABBYY Web site www.abbyy.com. ABBYY reserves the right to change the support policy any time without any prior notice.

6.3 In addition to the general terms and conditions, ABBYY may have specific support policies in specific regions which may be regulated by separate agreements.

6.4 Any supplementary software code and any SOFTWARE component provided to You as part of Support Services is to be considered a part of the SOFTWARE and subject to the terms and conditions of this EULA.

6.5 To be eligible for Support Services, You may be required to provide ABBYY with information about the characteristics of Your hardware, Serial Number of Your SOFTWARE as well as certain personal information, such as Your name, company name (if applicable), address, phone number and e-mail address. ABBYY may use the above-mentioned information as described in article 15.1 of the EULA.

7. Ownership.

7.1 No title to any of ABBYY’s Intellectual Property Rights (including the SOFTWARE and any ABBYY patents, trademarks, or copyrights) is transferred to You. You shall not, in any way, during or after the term of the Agreement, make any use of or claim any right to any name, logo, trademark, pattern, or design owned by ABBYY, or any name, logo, trademark, pattern, or design resembling them.

7.2 No title to any of Your Intellectual Property Rights (including the application and any of Your patents, trademarks, or copyrights) is transferred to ABBYY.

7.3 The SOFTWARE contains valuable trade secrets and confidential information belonging to ABBYY and third parties and is protected by copyright laws, including, without limitation, by United States Copyright Law, laws of Russian Federation, international treaty provisions, and the applicable laws of the country in which it is being used or obtained.

7.4 All title and rights in and to the content that is not contained in the SOFTWARE, but may be accessible through the use of the SOFTWARE, are the property of the respective content owners and may be protected by applicable copyright or other intellectual property laws and international treaties. This EULA does not grant You any rights to such intellectual property.

8. Limited Warranty. Disclaimers.

8.1 If required by the legislation of the country in which You obtained (purchased) the SOFTWARE, ABBYY warrants that the media on which the SOFTWARE is furnished will be free from defects in materials and workmanship under normal use only and only for the minimal guarantee term determined by the legislation of the country in which You obtained (purchased) the SOFTWARE starting from the date of purchase. If the SOFTWARE was obtained (purchased) in the countries defined in article 13.4 this period will constitute thirty (30) days starting from the date of obtain (purchase).

8.2 EXCEPT AS EXPPRESSLY PROVIDED IN THIS ARTICLE 8 (LIMITED WARRANTY. DISCLAIMERS), AND EXCEPT FOR ANY WARRANTY, CONDITION, REPRESENTATION, OR TERM TO THE EXTENT TO WHICH THE SAME CANNOT OR MAY NOT BE EXCLUDED OR LIMITED BY LAW APPLICABLE TO YOU IN YOUR JURISDICTION, THE SOFTWARE, INCLUDING WITHOUT LIMITATION ANY SOFTWARE DOCUMENTATION, UPGRADES AND UPDATES IS BEING DELIVERED TO YOU “AS IS” AND ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

9. Limitation of Liability

9.1 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL, SPECIAL OR PUNITIVE DAMAGES, OR ANY LOST PROFITS OR LOST REVENUE RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

10. Warranty Exclusion and Limitations for Users Residing in Germany or Austria

10.1 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then, in accordance with German law, ABBYY warrants that the SOFTWARE provides the functionalities set forth in its documentation included in the SOFTWARE (the “agreed upon functionalities”) for the limited warranty period following receipt of the SOFTWARE copy when used on the recommended hardware configuration. As used in this article, “limited warranty period” means one (1) year if You are a business user or legal entity, and two (2) years if You are not a business user. Non-substantial variation from the agreed upon functionalities shall not be considered and does not establish any warranty rights. This limited warranty does not apply to the SOFTWARE provided to You free of charge, for example, updates, pre-release versions, “Trial” versions, product samples, “Not for resale” (“NFR”) copies of the SOFTWARE, or the SOFTWARE that has been altered by You, to the extent such alterations caused a defect. To make a warranty claim, during the limited warranty period You must return, at our expense, the SOFTWARE and proof of purchase to the location where You obtained it. If the functionalities of the SOFTWARE vary substantially from the agreed upon functionalities, ABBYY is entitled (by way of re-performance and at its own discretion) to repair or replace the SOFTWARE. If this fails, You are entitled to a reduction of the purchase price (reduction) or to cancel the purchase agreement (rescission). For further warranty information, please contact ABBYY’s Customer Support Department in Germany: ABBYY Europe GmbH, Elsenheimerstrasse 49, 80687 Munich, tel.: +49 (0)89 51 11 590, fax: +49 (0)89 51 11 5959.

10.2 If You obtained Your copy of the SOFTWARE in Germany or Austria, and You usually reside in such country, then:

10.2.1 Subject to the provisions in article 10.2.2, ABBYY’s statutory liability for damages shall be limited as follows: (i) ABBYY shall be liable only up to the amount of damages as typically foreseeable at the time of entering into the purchase agreement in respect of damages caused by a slightly negligent breach of a material contractual obligation and (ii) ABBYY shall not be liable for damages caused by a slightly negligent breach of a non-material contractual obligation.

10.2.2 The limitation of liability set forth in 10.2.1 shall not apply to any mandatory statutory liability, in particular, to liability under the German Product Liability Act, liability for assuming a specific guarantee or liability for culpably caused personal injuries.

10.2.3 You are required to take all reasonable measures to avoid and reduce damages, in particular to make backup copies of the SOFTWARE and Your computer data subject to the provisions of this EULA.

11. Additional Limitations for SOFTWARE obtained in the USA

11.1 Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

11.2 Export rules. You agree that you shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12. Third-party technologies

12.1 Embedded Fonts. Font programs are subject to copyright, and the copyright owner may impose conditions under which a font program can be used. One of the conditions may be that You need a licensed copy of the font program to embed the font into a PDF file. In no event shall ABBYY be liable for any damages arising out of or in connection with Your use of embedded fonts.

12.2 Adobe® PDF Library.

12.2.1 The term “Adobe Software” includes Adobe Technology and related documentation, and any upgrades, modified versions, updates, additions, and copies thereof.

12.2.2 License Grant and Restrictions. ABBYY grants You a non-exclusive right to use the Adobe Software under the terms of this EULA. You may make one backup copy of the Adobe Software, provided the backup copy is not installed or used on any computer.

12.2.3 Intellectual Property Rights. The Adobe Software incorporated into the SOFTWARE is owned by Adobe and its suppliers, and its structure, organization and code are the valuable trade secrets of Adobe and it suppliers. The Adobe Software is also protected by United States Copyright law and International Treaty provisions. You may not copy the Adobe Software, except as provided in this EULA. Any copies that You are permitted to make pursuant to this EULA must contain the same copyright and other proprietary notices that appear on or in the Adobe Software. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the Adobe Software. Except as stated above, this EULA does not grant You any intellectual property rights in the Adobe Software.

12.2.4 Font License. If the Adobe Software includes font software You may embed the font software, or outlines of the font software, into Your electronic documents to the extent that the font vendor copyright owner allows for such embedding. The fonts contained in this package may contain both Adobe and non-Adobe owned fonts. You may fully embed any font owned by Adobe.

12.2.5 Warranty. ABBYY AND ITS SUPPLIER DO NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE SOFTWARE.

12.2.6 Export Rules. You agree that the Adobe Software will not be shipped, transferred or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions or regulations (collectively the “Export Laws”) - In addition, if the Adobe Software is identified as export controlled items under the Export Laws, You represent and warrant that You are not a citizen, or otherwise located within, an embargoed nation and that You are not otherwise prohibited under the Export Laws from receiving the Adobe Software. All rights to use the Adobe Software are granted on condition that such rights are forfeited if You fail to comply with the terms of this EULA.

12.2.7 Trademarks. Adobe and Adobe PDF Library are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other countries.

12.3 PixTools® Scan Runtime Libraries.

12.3.1 “EMC Software” shall mean PixTools Scan runtime libraries, Level 1 ISIS Drivers, Level 2 ISIS Drivers, and Level 3 ISIS Drivers. The SOFTWARE may use the EMC Software for communicating between scanner and SOFTWARE through the ISIS interface.

12.3.2 License Grant and Restrictions. ABBYY grants you a non-exclusive right to use the EMC Software incorporated into the SOFTWARE under the terms of this EULA.

12.3.3 Intellectual Property Rights. The EMC Software incorporated into the SOFTWARE is owned by EMC Corporation and its suppliers, and its structure, organization and code are the valuable trade secrets of EMC Corporation and its suppliers. The EMC Software is protected by United States Copyright Law and International Treaty provisions. You may not copy the EMC Software incorporated into the SOFTWARE. You agree not to modify, adapt, translate, reverse engineer, decompile, disassemble or otherwise attempt to discover the source code of the EMC Software incorporated into the SOFTWARE. Except as stated above, this EULA does not grant you any intellectual property rights in the EMC Software.

12.3.4 Warranty. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE RESULTS YOU MAY OBTAIN BY USING THE EMC SOFTWARE INCORPORATED INTO THE SOFTWARE. IN NO EVENT WILL EMC CORPORATION OR ITS SUPPLIERS BE LIABLE TO YOU FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING ANY LOST PROFITS OR LOST SAVINGS OR FOR ANY CLAIM BY ANY THIRD PARTY.

Some states or jurisdictions do not allow the exclusion or limitation of incidental, consequential or special damages, so the above limitations may not apply to you. You may have other rights, which vary from state to state or jurisdiction to jurisdiction.

12.3.5 Trademarks. ISIS and PixTools are either registered trademarks or trademarks of EMC Corporation in the United States and/or other countries.

12.4 Cuminas DjVu® SDK.

12.4.1 You, as the End-User, have the right to use DjVu SDK as part of the SOFTWARE for the entire period of such SOFTWARE copyright or for another lesser term of use, stated in the EULA.

12.4.2 License terms: You may not perform or make it possible for other persons to perform reverse engineer, disassemble, decompile (i.e. reproduce and transform the object code into source code) or otherwise attempt to derive the source code for the SOFTWARE or any part, except, and only to the extent, that such activity is expressly permitted by applicable law notwithstanding this limitation. If applicable law prohibits the restriction of such activities, any information so discovered must not be disclosed to third parties with the exception that such disclosure is required by law and such information must be promptly disclosed to ABBYY. All such information shall be deemed to be confidential and proprietary information of ABBYY.

12.4.3 ABBYY MAKES NO WARRANTIES, CONDITIONS, REPRESENTATIONS OR TERMS (EXPRESS OR IMPLIED WHETHER BY STATUTE, COMMON LAW, CUSTOM, USAGE OR OTHERWISE) AS TO ANY MATTER, INCLUDING WITHOUT LIMITATION NON-INFRINGEMENT OF THIRD PARTY RIGHTS, MERCHANTABILITY, INTEGRATION, SATISFACTORY QUALITY, OR FITNESS FOR ANY PARTICULAR PURPOSE, OR THAT THE SOFTWARE WILL CARRY NO ERRORS, MEET YOUR REQUIREMENTS, OR THAT THE SOFTWARE WILL FUNCTION PROPERLY WHEN USED IN CONJUNCTION WITH ANY OTHER SOFTWARE OR HARDWARE. ABBYY DOES NOT AND CANNOT WARRANT THE PERFORMANCE OR RESULT YOU MAY OBTAIN BY USING THE SOFTWARE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE LIES WITH YOU. FUTHERMORE ABBYY MAKES NO WARRANTIES FOR ANY THIRD PARTY SOFTWARE PRODUCTS WHICH MAY BE SUPPLIED WITHIN THE SOFTWARE.

12.4.4 IN NO EVENT WILL ABBYY BE LIABLE TO YOU FOR ANY DAMAGES, BUSINESS INTERRUPTION, LOSS OF DATA OR INFORMATION OF ANY KIND, BUSINESS OR OTHERWISE, CLAIMS OR COSTS WHATSOEVER, OR ANY CONSEQUENTIAL, INDIRECT, INCIDENTAL DAMAGE, OR ANY LOST PROFITS OR LOST SAVINGS RESULTING FROM AND/OR RELATING TO THE USE OF THE SOFTWARE, OR DAMAGES CAUSED BY POSSIBLE ERRORS OR MISPRINTS IN THE SOFTWARE, EVEN IF AN ABBYY REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH LOSS, DAMAGES, CLAIMS OR COSTS, OR FOR ANY CLAIM BY ANY THIRD PARTY. THE FOREGOING LIMITATIONS AND EXCLUSIONS APPLY TO THE EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION. ABBYY’S SOLE AND AGGREGATE LIABILITY UNDER OR IN CONNECTION WITH THIS EULA SHALL BE LIMITED TO THE PURCHASE PRICE ORIGINALLY PAID FOR THE SOFTWARE, IF ANY.

12.4.5 Limitations for SOFTWARE obtained at the USA.

a) Government Use. If use is made of the SOFTWARE by the United States Government or any US Government agency, the following additional terms shall apply: (1) Restricted Computer Software, as defined in the Rights in Data-General clause at Federal Acquisition Regulations 52.227-14; and (2) any use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFARS 252.227-7013.

b) Export rules. You agree that You shall not export or re-export the SOFTWARE in violation of any export provisions in the laws of the country in which this SOFTWARE was purchased or otherwise acquired. In addition, You represent and warrant that You are not prohibited under applicable laws from receiving the SOFTWARE.

12.4.6 Third-Party Code:

12.4.6.1 Oniguruma Copyright © 2002-2006 K.Kosako <sndgk393 AT ybb DOT ne DOT jp>. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.4.6.2 A portion of this software is derived from the RSA Data Security, Inc. MD5 Message-Digest Algorithm. Mersenne Twister Copyright © 2006,2007 Mutsuo Saito, Makoto Matsumoto and Hiroshima University. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. Neither the name of the Hiroshima University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

12.5 Wibu-Systems

12.5.1 WIBU, CodeMeter, SmartShelter, SmartBind are registered trademarks of Wibu-Systems.

12.6 Other licensed technologies. This SOFTWARE is used under license to the following U.S. Patent Nos.: 5,625,465 and 5,768,416.

13. Governing Law

13.1 If the SOFTWARE was obtained in the United States, Canada, Mexico, Belize, Costa Rica, El Salvador, Guatemala, Honduras, Montserrat, Nicaragua, Panama, Turks and Caicos Islands, Virgin Islands, Japan, or Taiwan, this EULA shall be governed by and construed in accordance with the laws of the State of California, United States of America. With respect to any dispute which may arise in connection with this EULA and/or this SOFTWARE, You consent to the exclusive jurisdiction and venue of the federal and/or state courts in the county of Santa Clara in the State of California. For the avoidance of doubt if the SOFTWARE was obtained in the United States, You obtained (purchased) the SOFTWARE from ABBYY USA Software House, Inc.

13.2 If the SOFTWARE was obtained in Austria, Belgium, Denmark, Finland, France, Germany, Italy, Luxembourg, the Netherlands, Portugal, Spain, Sweden, or any other member state of the European Union, except for Malta, Greece and Cyprus, that is not directly mentioned in article 13.3, 13.4 or 13.5 of this EULA, or in Switzerland, Norway, Iceland or Liechtenstein, this EULA shall be governed by and construed in accordance with the substantive law in force in Munich, the Federal Republic of Germany and the competent court of Munich, the Federal Republic of Germany shall have exclusive jurisdiction over all disputes relating to this EULA.

13.3 If the SOFTWARE was obtained in the United Kingdom of Great Britain and Northern Ireland, and Republic of Ireland this EULA shall be governed by and construed in accordance with the laws of England and Wales and the parties accept the exclusive jurisdiction of the courts of England and Wales.

13.4 If the SOFTWARE was obtained in Russia, Byelorussia, Kazakhstan, or any other country of the CIS, except for Ukraine and Moldova, or if the SOFTWARE was obtained (purchased) in Georgia, Latvia, Lithuania or Estonia, this EULA shall be governed by and construed in accordance with the substantive law in force in the Russian Federation.

13.5 If the SOFTWARE was obtained in Albania, Bosnia and Herzegovina, Bulgaria, Croatia, the Czech Republic, Hungary, Israel, Macedonia, Poland, Romania, Slovakia, Slovenia, Turkey, Serbia, Montenegro, Ukraine or Moldova, this EULA shall be governed by and construed in accordance with the substantive law of Ukraine, unless the SOFTWARE has been acquired by the person that has a status of consumer according to the Polish Civil Code. Polish law shall apply to such consumers.

13.6 If article 13.5 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business), any and all disputes, controversies or differences in opinion arising out of or relating to the EULA shall be finally resolved through arbitration in accordance with the arbitration rules and procedures of the International Commercial Arbitration Court at the Ukrainian Chamber of Commerce and Industry according to its Order. Judgment of the Court mentioned above is final and obligatory for execution by both Parties. If Section 13.5 is applied and You are an individual person, the Shevchenkovsky District Court of Kiev, Ukraine, shall have exclusive jurisdiction over all disputes relating to this EULA.

13.7 If article 13.4 is applied and You are an entity or a sole proprietor (a person who is in business by himself/herself without the use of a company structure or partners and bears alone full responsibility for the actions of the business) the Arbitrazh Court of Moscow, the Russian Federation, shall have exclusive jurisdiction over all disputes relating to this EULA. If article 13.4 is applied and You are an individual person, the Kuzminsky District Court of Moscow, the Russian Federation, shall have jurisdiction over all disputes relating to this EULA.

13.8 In the cases described in articles 13.1-13.5, this EULA will not be governed by the conflict of law rules of any jurisdiction or the United Nations Convention on Contracts for the International Sale of Goods, the application of which is expressly excluded.

13.9 If the SOFTWARE was obtained (purchased) in a country other than the countries specified in articles 13.1-13.5, this EULA shall be governed by and construed in accordance with the substantial laws of the country in which You obtained (purchased) the SOFTWARE.

14. Termination

14.1 Unless otherwise agreed by You and ABBYY or an ABBYY Partner in a separate written agreement or except as otherwise provided by the EULA or the documentation for the SOFTWARE, this EULA is effective in perpetuity from the date which You first demonstrated your acceptance as provided at the beginning of the EULA or as long as it is permitted under applicable law. To the extent that applicable law requires the statement of an expiration period for this EULA, this EULA will last as long as permitted, but in any event, at least as long as the duration of the SOFTWARE copyright and shall automatically expire without further notice when such time period elapses.

14.2 Without prejudice to any other rights, ABBYY may terminate this EULA if You fail to comply with the terms and conditions of this EULA. In such an event, You must destroy all copies of the SOFTWARE, all of its component parts and remove the SOFTWARE from your Computers.

14.3 You may terminate this EULA by destroying all copies of the SOFTWARE, all of its component parts and removing the SOFTWARE.

14.4 Such termination does not relieve You of Your obligation to pay for the SOFTWARE. Articles 2, 7, 8, 9, 10, 11, 12, 13, 14, 15 and article 3.4.4 shall survive the termination or expiration of this EULA, howsoever caused, but this shall not imply or create any continued right to use the SOFTWARE after termination or expiration of this EULA.

15. Miscellaneous

15.1 In the course of Activation, installation, operation and/or technical support and maintenance of the SOFTWARE You may be required and You hereby agree to provide ABBYY with certain personal information of Yours (such as but not limited to Your name, address, email address, phone number). You may choose not to provide us with your personal information, in which case You may be refused in future to obtain technical support or maintenance of the SOFTWARE available to ABBYY customers who provided their personal information, if provision of personal information is essential to provide You with technical support or maintenance of the SOFTWARE or is requirement of such technical support or maintenance of the SOFTWARE and it does not contradict applicable law. You agree not to provide more personal information than ABBYY or ABBYY’s Partner require, and agree that Your personal information may be processed (including but not limited to collected and/or otherwise used) by ABBYY and/or its affiliates or ABBYY Partners in compliance with applicable law provided that the confidentiality of the data and data security is maintained if it is required by applicable law. Any personal information You provide to ABBYY or its affiliates or ABBYY Partners will be processed, stored and used strictly within ABBYY and its affiliates or ABBYY Partners and will not be disclosed to any third party, except as may be required by applicable law, and, in case of ABBYY Software House Inc., will be maintained in accordance with its privacy policy found at http://abbyy.com/privacy_policy. All personal records will be processed solely for purposes of fulfillment obligations under this EULA by ABBYY. If article 13.5. applies Your personal information will be processed in the database named «Physical persons whose personal information is processed during business activity».

15.2 You agree that the SOFTWARE may require connections via Internet or via e-mail with an ABBYY server during Activation, deactivation or update of the SOFTWARE. ABBYY will take reasonable steps with the goal that no personal information about You will be transferred during such connections.

15.3 ABBYY may send You e-mails containing product and company news, information about special offers, advices on product usage and other product and company-related information provided You agree to receive such information. You may remove Your e-mail address from ABBYY’s mailing list at any time.

15.4 If any claims or lawsuits are brought against You in connection with Your use of the SOFTWARE, You shall inform ABBYY in writing about them promptly and whenever practicable within three (3) days from the moment You learn of them. You shall take all necessary actions to enable ABBYY to take part in the proceedings or hearings of or take over the defense of said claims or lawsuits in court or arbitration, and shall provide ABBYY with Your full cooperation and all information ABBYY deems useful or necessary for the defense of settlement of the corresponding claims or lawsuits, promptly upon (and whenever practicable no later than seven (7) days from the moment of) the receipt of an inquiry from ABBYY.

15.5 Consideration under this EULA is the price of the License established by ABBYY or an ABBYY Partner and payable in accordance with the payment procedures established by them, or may be included in value of equipment or hardware obtained by You or is part of the consideration payable by You for the full version of the SOFTWARE. If You are a natural person, this EULA may be gratuitous.

15.6 If any part of this EULA is found void or unenforceable, it will not affect the validity of the balance of the EULA, which shall remain valid and enforceable according to its terms.


Ограничение области значений для даты

В диалоге Настройка проверки значения вы можете задать интервал, в который должна попадать дата, введенная в данное поле.

  1. Отметьте опцию Дата должна попадать в интервал.
  2. Выберите Фиксированный чтобы задать фиксированный интервал времени или Относительно даты верификации чтобы задать интервал времени, относительно даты верификации документов.
  3. Введите начало и конец интервала.
  4. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.


Ограничение области значений для числа

Чтобы задать ограничение области значений для числа:

  1. Отметьте опцию Использовать ограничение.
  2. Задайте минимальное и максимальное значения числа.
  3. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.

При обработке документов будет производится проверка на попадание введенного значения в заданный интервал.


Свойства распознавания картинки

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля).

  • Исключить из распознавания – отметьте эту опцию, если область поля Картинка должна быть исключена из области распознавания остальных полей. (Эта опция доступна только для поля Картинка и используется для совместимости с определениями FormReader 6.5.)


Ограничение области значений для текстового типа данных

В диалоге Настройка проверки значения вы можете задать ограничения области значений для вводимого в поле текста.

Замечание. Текстовым типом считаются не только типы данных с содержимым Текст, но и типы с другим содержимым, у которых отмечена опция Рассматривать значение как текст.

  • Ограничение количества символов – задайте максимальное количество символов в поле;
  • В поле Ограничение содержимого выберите из списка значение Регулярное выражение, если необходимо производить проверку значений поля с помощью регулярного выражения.

    Правильно составить регулярное выражение вам поможет кнопка [image]. Подробнее см. Алфавит, используемый в регулярных выражениях.

    Для улучшения читаемости сообщений об ошибках при проверке с помощью регулярного выражения укажите в поле Описание регулярного выражения описание регулярного выражения, которое будет отображаться при возникновении ошибок.

  • В поле Ограничение содержимого выберите из списка значение Допустимые значения, если необходимо задать список допустимых значений для поля. Для того чтобы добавить значение, нажмите кнопку Добавить… и введите значение в появившемся диалоге. Для редактирования значения нажмите кнопку Правка…, для удаления – Удалить. Для загрузки допустимых значений из файла нажмите кнопку Загрузить….

  • Отметьте опцию Использовать внешний источник допустимых значений, если требуется проверять распознанное значение по списку допустимых значений из внешнего текстового файла или базы данных. Укажите источник значений, нажав кнопку Правка…. При этом типе проверки список допустимых значений не копируется в проект, подключение к внешнему источнику осуществляется непосредственно в момент проверки.

  • Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением. Наличие предупреждений не мешает оператору отправить документы на следующий этап обработки, тогда как неисправленные форматные ошибки требуют дополнительного подтверждения отправки документов оператором.


Обработка введенного значения

Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого на закладке Тип данных диалога свойств поля нажмите кнопку Правка… справа от поля Опции автозамены.

Задайте необходимые параметры автоматической замены или обработки текста.

Обработка будет производится только один раз после распознавания значения поля, если отмечена опция Производить замену только один раз после распознавания. В противном случае, замена будет производиться при каждом изменении значения поля.

  • Для того чтобы произвести автоматическую замену символов в распознанном значении поля, нажмите на кнопку Правка… справа от поля Замена символов. В открывшемся диалоге вы можете добавлять символы для автоматической замены. Добавленные значения будут отсортированы по алфавиту. Если указанные символы встретятся в распознанном значении поля, они будут автоматически заменены. Укажите следующие параметры автозамены:
    1. В поле Заменить введите один или несколько символов, которые требуется заменять.
    2. В поле На введите один или несколько символов для замены.
      Замечание. Замена на несколько символов может использоваться, если замена осуществляется по всему тексту. Для остальных опций (Префикс, Суффикс, Префикс и Суффикс) для замены используется только первый символ.
      Collapsed Показать пример

      Так как замена выполняется в префиксе, "A" заменяется на первый символ из указанной для замены строки.

      Так как замена выполняется по всему тексту, каждый символ строки "ENT" заменяется на "WXY".

    3. В поле Заменить в укажите, где требуется осуществлять замену: в префиксе, суффиксе, префиксе и суффиксе или по всему тексту.
      Если замена осуществляется в префиксе, будут замены все идущие подряд символы из поля Заменить, начиная с начала текста. Замена в суффиксе выполняется с конца текста.
      Например, при замене символов " B" на "%" и символов "AC" на "#" в префиксе строка "ABC ENTERTAC CORP" будет замена на "#%#%ENTERTAC CORP".
      Collapsed Показать пример

  • Для того чтобы произвести автоматическую замену всего значения поля или отдельных слов в значении поля, нажмите на кнопку Правка… справа от поля Замена текста.

    В открывшемся диалоге вы можете добавлять слова и выражения для автоматической замены. Для замены поля только целиком выберите опцию Заменять поля целиком.

    Если вы отметите опцию Точный поиск, то будет производиться поиск и замена строго введенного слова или выражения, а при выборе Неточный поиск будет найдено и заменено слово или выражение, близкое к введенному. Количество допустимых ошибок зависит от длины слова.

    Отметьте опцию Учитывать регистр, если важен регистр слова или выражения для замены.

  • Выберите один из способов преобразования букв текста в выпадающем списке Изменить регистр:

    Не изменять – без преобразования;

    ЗАГЛАВНЫЕ – все буквы будут преобразованы в заглавные;

    строчные – все буквы будут преобразованы в строчные;

    Первая буква заглавная – первая буква будет заглавной, остальные - строчные.

  • Удалить лишние пробелы – отметьте эту опцию, чтобы удалить лишние пробелы.

Также можно выполнять автозамену с помощью скрипта. Для этого необходимо отметить опцию Использовать скрипт, открыть окно редактирования скрипта с помощью кнопки Правка… справа от опции и ввести текст скрипта.


ABBYY Offices

Координаты офисов компании ABBYY

Россия | ABBYY Россия Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: 127273, Россия, Москва, а/я 32 Физический адрес: Москва, ст. м. Отрадное, ул. Отрадная, 2Б, строение 6, бизнес-центр "Отрадный" E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru Сайт: http://www.abbyy.ru Схема проезда
США, Мексика, Центральная Америка | ABBYY USA Тел.: +1 408-457-9777 Факс: +1 408-457-9778 Адрес: 880 North McCarthy Blvd., Suite 220 Milpitas, CA 95035, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Канада | ABBYY Canada Тел.: +1 408 457 9777 Факс: +1 408 457 9778 Адрес: 555 Legget Dr., Suite 304 Kanata, Ontario K2k 2X3, Canada E-mail: info_canada@abbyyusa.com Техническая поддержка: support_canada@abbyyusa.com Сайт: http://www.abbyy.com
Африка, Азия, Южная Америка, Греция, страны Балтики | ABBYY 3A Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Адрес: Россия, 127273, Москва, а/я 32, ООО «Аби» E-mail: sales_3A@abbyy.com Техническая поддержка: support@abbyy.com Сайт: http://www.abbyy.cn http://www.abbyy.com.br http://latam.abbyy.com
Восточная Европа и страны Средиземноморья | ABBYY Украина Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: Украина, 02002 Киев, а/я 23 E-mail: sales@abbyy.ua Техническая поддержка: тел. +380 44 490 9463, e-mail: support@abbyy.ua Сайт: http://www.abbyy.ua
Западная Европа | ABBYY Europe GmbH Тел.: +49 89 511 159 0 Факс: +49 89 511 159 59 Адрес: Elsenheimerstrasse 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com Сайт: http://www.abbyy.de http://www.france.abbyy.com http://www.abbyy.com
Соединенное королевство | ABBYY UK Ltd. Тел.:+0870 600 0231 Факс: +01344 392 611 Адрес: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-mail: sales_UK@abbyy.com Техническая поддержка: support_eu@abbyy.com Сайт: http://www.abbyy.co.uk
Япония | ABBYY Japan Тел.:+81-42-795-1901 Факс: +81-42-795-1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Австралия и Новая Зеландия | ABBYY Australia Адрес: Citigroup Building, level 39, 2 Park Street, Sydney, NSW, 2000, Australia E-mail: sales_au@abbyy.com Техническая поддержка: support@abbyy.com Сайт: http://www.abbyy.com
Тайвань | ABBYY Taiwan Тел.:+886-2-2655-0556 Факс: +886-2-2655-2339 Адрес: Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Все другие регионы | ABBYY Poccuя Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Адрес: Россия, 127273, Москва, а/я 32, ООО «Аби» E-mail: sales@abbyy.com Техническая поддержка: support@abbyy.ru Сайт: http://www.abbyy.ru, http://www.abbyy.com


Поддерживаемые типы штрих-кодов

Программа ABBYY FlexiCapture поддерживает штрих-коды следующих форматов:

  • EAN 13
  • EAN 8
  • Code 39
  • Code 39 without asterisk
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Check CodaBar
  • Aztec
  • Datamatrix
  • QR code

Замечание. Для распознавания штрих-кодов с кириллической кодировкой нужно использовать штрих-код в формате Datamatrix, PDF417 или QRCode.


Как купить программу ABBYY FlexiCapture

Чтобы оформить заказ на покупку ABBYY FlexiCapture и задать любые сопутствующие вопросы, обращайтесь в региональные офисы ABBYY.


Окрестность символа

Программа позволяет настроить отображение окрестности символа или поля. Выберите в меню пункт Сервис > Опции… и откройте закладку Окрестность символа.

  1. Выберите размер отображаемого участка в выпадающем списке Размер.
  2. Выберите прозрачность отображаемых окрестностей с помощью ползунка Контраст.

Пример изображения показан в блоке Предварительный просмотр.

Замечание. Изменение размера окрестности символа вступит в силу при следующем сеансе верификации.


Шрифт и цвет

Программа позволяет настроить параметры отображения текстовых полей. Выберите пункт меню Сервис > Опции… и перейдите на закладку Шрифт и цвет.

  • Для установки типа и размера шрифта редактируемого распознанного или текста ошибок, воспользуйтесь соответствующим выпадающим списком.
  • Для установки цвета нажмите кнопку слева от описания текста:
    • Редактируемый текст – текст редактируемого поля и аналогичных полей других документов;
    • Фон – фоновый цвет окна контекстной верификации;
    • Выделенный текст – цвет фона, на котором отображаются выделенные символы;
    • Текст ошибок – цвет сообщений об ошибках.
  • Для изменения прозрачности изображения аналогичных полей других документов используйте ползунок в нижней части окна.


Цвета

Можно выбрать фоновый цвет для разных объектов. Для этого выберите в меню пункт Сервис>Опции… и откройте закладку Настройки цвета.

Чтобы выбрать цвет фона для объекта, нажмите кнопку слева от его описания. Далее выберите цвет в открывшемся окне.


Контекстная верификация

Программа позволяет настроить положение курсора при начале верификации поля. Выберите в меню пункт Сервис>Опции…и перейдите на закладку Контекстная верификация.

По умолчанию выделен первый символ поля. Выберите опцию Установить курсор у первого неуверенно распознанного символа, чтобы автоматически выделять первый неуверенно распознанный символ поля.

Если предпочтительнее набирать текст поля целиком, выберите опцию Выделить все поле. В этом случае опция Установить курсор у первого неуверенно распознанного символа будет недоступна для выбора.


Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе FormReader

Шрифты, необходимые для корректного отображения символов поддерживаемых языков в редакторе ABBYY FlexiCapture

Язык | Шрифт
Со словарной поддержкой
армянский (восточный, западный, грабар) | Arial Unicode MS(2)
татарский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
Без словарной поддержки
абхазский; | Arial Unicode MS(2)
аварский | Arial Unicode MS(2), Lucida Sans Unicode(3)
агульский | Arial Unicode MS(2), Lucida Sans Unicode(3)
адыгейский | Arial Unicode MS(2), Lucida Sans Unicode(3)
азербайджанский (кириллица), азербайджанский (латиница) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
алтайский | Arial Unicode MS(2), Lucida Sans Unicode(3)
башкирский | Arial Unicode MS(2), Palatino Linotype(2)
бурятский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
гагаузский | Arial Unicode MS(2)
даргинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
дунгаский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
зулу | Arial Unicode MS,(2), Lucida Sans Unicode(3)
ингушский | Arial Unicode MS(2), Lucida Sans Unicode(3)
кабардино-черкесский | Arial Unicode MS(2), Lucida Sans Unicode(3)
казахский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
калмыцкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
каракалпакский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
киргизский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
корякский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лакский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лезгинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
мансийский | Arial Unicode MS(2), Lucida Sans Unicode(3)
марийский | Arial Unicode MS(2)
монгольский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
ненецкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
осетинский | Arial Unicode MS(2)
русский (старая орфография) | Arial Unicode MS(2), Palatino Linotype(2)
табасаранский | Arial Unicode MS(2), Lucida Sans Unicode(3)
таджикский | Arial Unicode MS(2), Palatino Linotype(2)
тувинский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
туркменский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
удмуртский | Arial Unicode MS(2)
узбекский (кириллица) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
хакасский | Arial Unicode MS(2)
хантыйский | Arial Unicode MS(2)
хауса | Arial Unicode MS(2), Lucida Sans Unicode(3)
чеченский | Arial Unicode MS(2), Lucida Sans Unicode(3)
чувашский | Arial Unicode MS(2)
чукотский | Arial Unicode MS(2), Lucida Sans Unicode(3)
якутский | Arial Unicode MS(2)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Глоссарий

A-Z

ABBYY FlexiCapture

Программное решение для потокового ввода данных с документов различного типа - структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных (документов в свободном стиле).

ABBYY FlexiLayout Studio

Программа, позволяющая создать описание структуры документа произвольного формата, необходимое для его дальнейшего автоматического распознавания.

ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка макета формы является важным этапом, так как от "правильности" разработанного макета (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

ABBYY FlexiCapture for Invoices

Компонента ABBYY FlexiCapture,предназначенная для ввода инвойсов.

ADF

Automatic Document Feeder. Устройство для автоматической подачи бумаги, позволяющее отсканировать большое количество документов без дополнительного вмешательства оператора.

dpi

Dots per Inch. Количество точек на дюйм; единица измерения разрешения.

FlexiLayout

Описание структуры гибкого документа. Это описание разрабатывается в программе ABBYY FlexiLayout Studio и передается в ABBYY FlexiCapture. FlexiLayout – своего рода «инструкция» о том, как следует искать и идентифицировать поля на гибкой форме.

MRC (смешанное растровое содержание)

Процесс применения методов сегментации изображений для улучшения контрастного разрешения растрового изображения, состоящего из пикселей.

OCR, Optical Character Recognition

Оптическое распознавание типографских текстов.

OMR, Optical Mark Recognition

Оптическое распознавание меток. Так называется технология, позволяющая ABBYY FlexiCapture не только уверенно распознавать на формах обычные метки (галочки, крестики, и т.п.), но и правильно идентифицировать метки, отмеченные по ошибке и затем полностью закрашенные.

ICR

Intelligent Character Recognition. Так называют технологии или системы, предназначенные для массовой обработки документов, заполненных печатными буквами и цифрами от руки, то есть для распознавания рукопечатных символов.

XFD

XML Form Definition (*.xfd) – специальный формат файла формы, созданной в программе ABBYY FormDesigner. Файл формата XML Form Definition используется для создания определения документа в программе ABBYY FlexiCapture.

А

Администратор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит настройка программы для ввода документов: создание и редактирование определений документов, профилей импорта.

Алфавит

Набор символов, используемых в описываемом языке.

Б

Буквы в гребенке

Тип разметки текста, при которой ограничителем текста является гребенка. Показать... Collapsed

Буквы в изолированных рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки изолированы друг от друга. Показать... Collapsed

Буквы в рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки не изолированы друг от друга. Показать... Collapsed

В

Верификация

Проверка корректности распознавания, сборки страниц в документы (для многостраничных документов) и выполнения правил. Верификация осуществляется на Станции Оператора. См. Верификация.

Ввод форм

Извлечение данных из информационных полей форм.

Г

Гибкое описание

Формализованное описание структуры документа, нацеленное на поиск местоположения полей. Создается в ABBYY FlexiLayout Studio. Файл формата *.afl. См. FlexiLayout.

Гибкое определение

Определение документа или раздела, разработанное для обработки гибких документов. Создается путем подключения гибкого описания. Поля таких документов не имеют фиксированного местоположения, их поиск производится с помощью гибкого описания. См. Создание определения для обработки гибких документов.

Горячая папка

Каталог на жестком диске локального или удаленного компьютера, используемый для импорта изображений. Как правило используется для многократной периодической загрузки изображений без участия пользователя. См. Профили импорта изображений.

Группа меток

Элемент машиночитаемой формы, объединяющий несколько меток, находящихся вблизи друг от друга. В Группе меток может выбираться одна или несколько меток.

Групповая верификация

Режим верификации, при котором одинаково распознанные символы поступают на верификацию группой. Подробнее... Collapsed На групповую верификацию подаются поля, в свойствах которых отмечена опция Отправлять символы на групповую верификацию. Целесообразно подавать на групповую верификацию символы из полей, которые заполняются цифрами, а также метки.

Д

Данные из документа

Данные, полученные в результате обработки (распознавания, проверки и редактирования результатов распознавания) изображений страниц документа.

Документ

Совокупность одного или нескольких изображений страниц и извлеченной из них информации.

Ж

Жесткая форма

Документ, имеющий заданные информационные поля, оформление, количество и местоположение которых строго определены и не меняются от одного экземпляра документа к другому.

Жесткое описание

определение документа или раздела документа, разработанное для обработки жестких форм. Поля жесткого описания имеют фиксированное расположение.

З

Замена изображения

Замена одного изображения другим при редактировании определения.

Запрещенный символ

Символ, который заведомо не может встретиться в определяемом типе данных. Подробнее... Collapsed Указание таких символов может существенно увеличить скорость и надежность распознавания. Например, при распознавании текстов, в которых встречаются только заглавные буквы, в качестве запрещенных следует указать все строчные буквы.

И

Игнорируемый символ

Символ, встречающийся внутри слов (например, маркер (bullet)) или символ мягкого переноса (табуляции и т.д.), наличие которого не мешает слову принадлежать к определяемому типу данных. Подробнее... Collapsed Эти символы исключаются из слов, т.о. принадлежность указанному типу данных определяется для слов без этих символов.

Идентификатор

Статический элемент, который используется для однозначного выбора определения среди нескольких с одинаковым расположением реперов. В свойствах таких статических элементов должна быть отмечена опция Использовать для идентификации определения документа.

Идентификация определений документов

Процесс выбора нужного определения документа с помощью идентификаторов.

Изображение

Электронный образ страницы бумажного документа, полученный в результате сканирования.

Инвертированное изображение

Изображение, текст которого напечатан на темном фоне светлыми буквами.

Инвойс

Документ, предоставляемый продавцом покупателю и содержащий перечень товаров, их количество и цену, по которой они будут поставлены покупателю. Для обработки инвойсов в ABBYY FlexiCapture используется отдельное решение — ABBYY FlexiCapture for Invoices. См. "Что такое ABBYY FlexiCapture for Invoices"

Индексное поле

Поле, по значению которого производится индексация документов для сортировки и поиска. См. Индексные поля.

Импорт изображений

Добавление в пакет изображений для обработки. Импорт может производиться путем добавления изображений из файлов, путем сканирования или с использованием профилей импорта. См. Добавление изображений страниц.

Исправленная метка

Метка, отмеченная по ошибке, и с целью исправления полностью заштрихованная. В случае если у поля метки включена опция Допускать исправления, то программа распознает заштрихованную метку как незаполненную.

К

Картинка

Элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в виде графического объекта (например, файла).

Классификатор

Проект FlexiLayout Studio, предназначенной для предварительной идентификации страниц перед наложением определений документов и выбора подходящего гибкого описания или его варианта.

Ключевое поле

Поле, позволяющее автоматически проверить сборку страниц в документы. Значения ключевых полей должны совпадать на всех страницах одного документа.

Кодовая страница

Таблица, сопоставляющая каждому значению байта некоторый символ (или его отсутствие).

Контекстная верификация

Режим верификации, при котором распознанные символы поступают на верификацию в контексте поля. Подробнее... Collapsed В режиме контекстной верификации неуверенно распознанные символы проверяются в контексте всего поля. На контекстную верификацию подаются поля, в свойствах которых отмечена опция Отправлять на контекстную верификацию. Целесообразно подавать на контекстную верификацию те поля, область значений которых известна или легко определяется. Например, таким полем может быть название страны, города: нам известно, какие значения могут встретится в данном поле.

Контрастность

Соотношение яркости самой темной и самой светлой области изображения.

Крест

Репер в виде креста.

М

Матричный принтер

Тип распознаваемого текста, представляющий собой текст, напечатанный на матричном принтере.

Машиночитаемая форма

Форма, специально изготовленная для целей автоматического ввода, которая содержит служебные элементы (реперы, штрих-коды, линии и т.д.), необходимые для ее успешной обработки.

Метка

Элемент машиночитаемой формы, в который при заполнении вносится отметка (галочка, крест, точка, сплошная закраска и т.д.).

Многостраничный документ

Документ, состоящий из нескольких страниц.

Множество допустимых символов

Набор символов, встречающихся в определяемом типе данных.

Collapsed Подробнее...

Этот набор определяется типом данных. Т.е. тип данных, подключенный к полю, определяет множество символов, используемых при распознавании.

Помимо непосредственного выбора символов, входящих в это множество, возможно задать дополнительные параметры, его ограничивающие. Например, можно указать:

  • Символы, которые заведомо не могут встретиться при распознавании данного поля, - запрещенные символы (например, для поля, в котором могут быть только заглавные символы, в качестве запрещенных могут быть указаны все строчные буквы).
  • Символы, которые могут встречаться внутри слов, но при этом не влияют на проверку этого слова - игнорируемые символы (например, знаки слогоделения, ударения и т.д.)

Моноширинный текст

Тип разметки текста, при котором под каждую букву слова отводится одинаковая по высоте и ширине рамка, но границы рамки при сканировании исчезают.

Н

Набор данных

Данные, использующиеся для автоматических проверок документа. Данные могут храниться в таблице внутри ABBYY FlexiCapture и синхронизироваться по расписанию или постоянно извлекаться из внешнего источника.

Наложение определения документа

Процесс подбора определения документа и наложение полей определения на изображение.

Нераспознаваемый регион

Область изображения, исключенная из распознавания. Нераспознаваемый регион нужен для исключения области с пояснительным текстом или рисунком, мешающим распознаванию поля. См. Исключение региона из распознавания.

Неструктурированный документ

Документ, содержащий информацию, изложенную в свободном стиле. Например, контракты, письма, приказы, графики являются неструктурированными документами. См. Обработка неструктурированных документов.

Неуверенно распознанный символ

Статус, присваиваемый символу автоматически в процессе распознавания, если он был распознан со значительной долей неуверенности.

О

Область поля

Область изображения, выделенная в определении документа и предназначенная для извлечения информации.

Обучение [определения документа]

Возможность системы использовать введенные данные для анализа и обучаться на основе этих данных, в результате чего происходит улучшение поиска обученных полей на изображениях. Обучение возможно как при предварительной настройке системы, так и в процессе ввода данных.

Ограничитель текстовых полей

Графический элемент, ограничивающий текстовое поле: рамка, гребенка, линия.

Оператор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит ввод документов: добавление изображений, распознавание, верификация, экспорт распознанных данных.

Определение документа

определение документа определяет принципы, по которым будет происходить идентификация и обработка документов данного типа, и содержит:

  • Структуру документа, т.е. описание допустимой последовательности страниц, которая образует документ данного типа. Структура документа задает правило сборки документа.
  • Описания разделов документа.
  • Список правил, которым должны удовлетворять данные полей.
  • Расположение полей и подписей к ним в окне "Данные" (вид формы данных).
  • Настройки экспорта для документов данного типа.
  • Настройки процесса обработки документов данного типа.

Описание раздела документа

Составная часть определения документа. Соответствует одной или нескольким страницам, содержащим логически завершенный набор полей. Поля внутри одного раздела могут переходить с одной страницы на другую (например, многостраничные таблицы), а наборы полей разных разделов не пересекаются.
Описание раздела может быть гибким, либо жестким.

Ориентация страницы

Расположение страницы относительно правильного расположения: сверху вниз, слева направо. Ориентация страницы может быть автоматически определена при распознавании изображения страницы; с этой целью в программе ABBYY FlexiCapture предусмотрено задание возможной ориентации.

Ориентация текста

Направление текста в поле относительно расположения страницы.

Очистка изображения

Удаление с изображения отдельных мелких черных точек. Лишние точки могут появиться в процессе сканирования и для качественного распознавания данных их лучше удалить. Также при очистке изображения происходит удаление точек фона или ограничительных линий с растровых форм.

Ошибка документа

Если в процессе обработки документа выясняется, что его данные не полностью соответствуют структуре документа и заданным ограничениям на значения полей, а также контрольным правилам, то все несоответствия заносятся в список ошибок и предупреждений документа.

Ошибка /предупреждение правила

Данная ошибка возникает, если распознанное значение поля (или нескольких полей) не удовлетворяет автоматически проверяемым условиям (например, сумма значений столбца не равна значению итогового поля).

Ошибка /предупреждение формата

Данная ошибка возникает, если распознанное значение поля не соответствует указанному формату (например, в числовом поле распознаны буквы, значение не входит в список допустимых и т. д.)

Ошибка сборки

Данная ошибка возникает, если получившийся в результате автоматического разбиения документ включает страницы из других документов, страницы документа идут в неправильной последовательности или на разных страницах документа не совпадают значения ключевых полей.

П

Пакет документов

Совокупность документов, сгруппированная пользователем. Обычно пакет соответствует пачке документов, отсканированных за один раз, или импортированных из определенного каталога. См. Пакеты документов.

Переменная окружения

Строка, использующаяся для хранения текстовой информации, например, о настройках системы. Например, с помощью переменных окружения можно в компактной форме задать строку соединения с базой данных либо переменную, которая будет использоваться при указании имени файла экспорта.

Пишущая машинка

Тип распознаваемого текста, представляющий собой текст, написанный на пишущей машинке.

Поворот изображения

Поворот изображения вокруг его центра.

Проверка позиций инвойса

Возможность системы подтверждать при верификации инвойс на основе заказа (контракта) на поставку.

Подстановка из базы данных

Проверка распознанных данных поля на соответствие значениям из базы данных.

Поле

Элемент документа, предназначенный для извлечения данных. Поля могут быть простыми (не имеющими внутренней структуры) или составными, как, например, поле типа «таблица», где каждая ячейка также может рассматриваться как отдельное «дочернее» поле таблицы. См. Создание полей определения документа.

Поле без разметки

Поле, определенное в определении документа, но не имеющее области на изображении. См. Поля без разметки.

Поле Группа Меток

Поле определения документа, содержащее группу меток.

Поле для ручного ввода

Поле определения документа, содержащее нераспознаваемый текст (например, состоящий из слитных букв), который необходимо ввести с клавиатуры.

Поле Картинка

Поле определения документа, содержащее картинку.

Поле Метка

Поле определения документа, содержащее метку.

Поле с несколькими областями

Поле, состоящее из нескольких областей на изображении. Области такого поля могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле. Обычно используется для объектов, расположенных на нескольких страницах, например, для больших таблиц. См. Поля с несколькими областями.

Поле с несколькими экземплярами

Поле, используемое для описания нескольких объектов одинакового типа (повторяющихся объектов). По сути, эти объекты являются одним и тем же полем, и обладают общими свойствами, но их несколько. Для того чтобы не создавать несколько одинаковых полей, используются поля с несколькими экземплярами. Поля с несколькими экземплярами экспортируются в отдельные файлы или таблицы базы данных. См. Поля с несколькими экземплярами.

Поле Таблица

Поле определения документа, содержащее таблицу. Это составное поле, каждый столбец таблицы представляет собой набор полей одного типа: текст, метки, штрих-коды или картинки.

Поле Штрих-код

Поле определения документа, содержащее штрих-код, предназначенный для распознавания.

Полуструктурированный документ

Документ, содержащий набор информационных полей, оформление, количество и расположение которых может значительно отличаться в разных экземплярах документа. См. Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture.

Пользовательский словарь

Вспомогательный словарь, составленный пользователем и содержащий список слов, которые не входят во встроенный словарь программы. Пользовательский словарь подключается к предустановленным словарям с целью улучшения качества распознавания документов за счет добавления в словарь специализированных терминов, аббревиатур, названий компаний и т. д.

Пользовательский тип данных

Тип данных, созданный пользователем. См. Создание пользовательских типов данных.

Поставщик

Юридическое или физическое лицо, поставляющее товары или услуги. За оказанные услуги или поставленные товары в дальнейшем поставщик выставляет инвойс, который можно распознать с помощью ABBYY FlexiCapture for Invoices.

Потоковый ввод данных

Автоматизированное извлечение данных из аналоговых (печатных) и цифровых (отсканированных изображений в файлах) документов.

Потоковый ввод документов

Автоматизированный перевод бумажных документов в электронный вид.

Пояснительный текст

Элемент машиночитаемой формы, представляющий собой описательный текст (название формы, названия полей, пояснения к полям и т.д.)

Правила

Некоторые условия, накладываемые на данные в полях и автоматически проверяемые программой. См. Проверка с помощью правил.

Предраспознавание

Полнотекстовое распознавание изображений документа для последующего наложения полей определения документа.

Приложение

Страницы, не содержащие полей, но участвующие в сборке документа. Из этих страниц не извлекаются данные, но они могут быть сохранены в виде изображения или PDF с возможностью поиска. См. Создание определений для документов с приложениями.

Проверка правил

Автоматическая проверка распознанных данных на соответствие заданным правилам. См. Верификация правил.

Проект

Проект – это единая среда, объединяющая пакеты документов и настройки, необходимые для их обработки, такие как определения документов, профили импорта и другие. См. Создание проекта.

Простой текст

Тип разметки текста, при котором текст вписывается в блок без каких-либо ограничителей.

Профиль импорта

Совокупность настроек, используемых для добавления в пакет изображений: источник импорта, опции обработки изображений, опции очистки горячей папки и др. См. Профили импорта изображений.

Профиль экспорта

Совокупность настроек, определяющих способ передачи обработанных данных: формат выходных файлов, каталог хранения, условия выполнения экспорта и др.

Публикация определения документа

Предоставление доступа к новой версии определения документа после редактирования. Опубликованная версия участвует в обработке документов из рабочих пакетов, в то время как неопубликованная, локальная версия, может участвовать только в обработке документов из тестовых пакетов. См. Редактирование и публикация определения документа.

Р

Рабочие пакеты

Пакеты документов, предназначенные для ввода данных. Для обработки рабочих пакетов используются только опубликованные определения документов. См. Пакеты документов.

Раздел определения документа

Набор страниц (или одна страница) и полей, находящихся на них, соответствующий логически законченной части документа. Разделы документа могут описываться "жестким" или "гибким" описанием. См. Создание определений для многостраничных документов.

Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную линию.

Разметка страницы

Схема расположения полей на изображении.

Разметка текста

Способ оформления области страницы, предназначенной для ввода текста. Примеры разметки текста см. в статье Поле для ввода.

Разрешение

Параметр изображения. Измеряется количеством точек, приходящихся на дюйм изображения.

Распознавание

Нахождение соответствия элементов изображения определенным символам.

Распознавание меток (OMR)

Определение наличия отметки в поле метки на форме.

Распознавание текста (OCR, ICR)

Перевод графического изображения в текстовый вид.

Распознавание штрих-кода

Перевод графического изображения штрих-кода в числовой или текстовый вид.

Растровая линия

Линия, состоящая из точек, расположенных на одинаковом расстоянии друг от друга.

Растровая форма

Форма, на которой информационные поля выглядят как белые прямоугольники на сером фоне, состоящем из растровых линий, или как прямоугольники, ограниченные растровыми линиями.

Регулярное выражение

Описание структуры слова или любого вводимого значения на специальном языке. Таким образом, можно определить не только набор допустимых символов, но и структуру содержимого поля. Описать структуру с помощью регулярного выражения можно при задании ограничений для текстового поля или при создании пользовательского типа данных. См. Алфавит, используемый в регулярных выражениях.

Репер

Статический элемент, представляющий собой черный квадрат, прямоугольник, крестик или уголок, и предназначенный для наложения определения.

Collapsed Подробнее...

Реперы - это специальные элементы дизайна формы, по которым система производит "привязку к местности" после сканирования (выравнивает перекос, компенсирует линейные и нелинейные дефекты сканирования, вычисляет расположение блоков). Наиболее надежными реперами служат черные квадраты, расположенные, как правило, по углам формы. При отсутствии на изображении специальных реперов, для наложения определения документа могут использоваться другие статические элементы: разделители, то есть вертикальные или горизонтальные линии, такие как линии таблиц, оформляющие рамки и т.д., или четкий статический текст, а именно: заголовок формы, подписи к полям, пояснительная информация и т.д. У статических элементов, служащих для наложения определения, должно быть отмечено свойство Использовать для наложения определения документа.

Реперный текст

Статический элемент, представляющий собой текст, присутствующий на незаполненной форме и не предназначенный для извлечения информации. Это может быть любой пояснительный текст или заголовок. Реперный текст может использоваться для наложения определения документа и для идентификации.

Реперный штрих-код

Статический элемент, представляющий собой штрих-код, не предназначенный для извлечения информации. Реперный штрих-код может использоваться для наложения определения документа и для идентификации.

Рукопечатный текст

Тип распознаваемого текста, представляющий собой текст, написанный от руки раздельными буквами..

С

Серая фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на сером фоне, исчезающем при сканировании.

Сканирование

Процесс получения электронного образа страницы бумажной формы с помощью сканера.

Словарь

Список слов, используемый при определении конкретного типа данных. Подробнее... Collapsed Словарь указывается при создании типа данных. Таким образом, тип данных, подключенный к полю, определяет используемый при распознавании и проверке словарь. Помимо существующих предопределенных типов данных с готовыми словарями, программа позволяет подключать типы данных, созданные на основе пользовательских словарей. Данные для словаря могут быть введены вручную или загружены из текстового файла.

Cправочник

Список в виде текстового файла или ODBC-совместимой базы данных, используемый для хранения справочной информации. Например, возможных значений извлекаемых полей документов или информации, необходимой для извлечения полей документа.

Статические элементы

Нераспознаваемые элементы, служащие для наложения определения документа и идентификации. Такими элементами являются: реперы, реперный текст, разделители, реперные штрих-коды.

Стиль написания

Манера написания, присущая определенной группе людей, например американская манера написания цифр. Подробнее... Collapsed Опция, которая задает стиль написания рукопечатных букв в формах. Стиль зависит от региона, в котором формы были заполнены (Россия, Германия, Чехия, США, и т.д.).

Страница

Изображение страницы бумажного документа и результаты его обработки.

Т

Таблица

Данные, расположенные по двумерной сетке, не обязательно видимой. В программе обрабатываются таблицы, состоящие из столбцов, каждый из которых содержит данные одного типа, и повторяющихся строк.

Текст в рамке

Тип разметки текста, при котором ограничителем текста является рамка. Показать... Collapsed

Текст в рамке с гребенкой

Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки. Показать... Collapsed

Текст документа

Полученный в ходе предварительного распознавания перед наложением гибкого описания полный текст документа. При необходимости данный текст можно сохранить (требуется дополнительное дисковое пространство), чтобы в дальнейшем использовать во время верификации.

Текст на линии

Тип разметки текста, при котором ограничителем текста является линия снизу. Показать... Collapsed

Текстовое поле

Элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы.

Тестовые пакеты

Пакеты документов, предназначенные для тестирования и отладки определений документов. Для обработки тестовых пакетов используются локальные копии определений документов. См. Пакеты документов.

Тип данных

Признак поля, описывающий известные ограничения на возможное значение поля и используемый при его распознавании для уменьшения числа возможных вариантов распознавания. Подробнее... Collapsed Одной из характеристик поля является тип данных: число, дата, текст, фамилия, имя, адрес и т.д. Тип данных определяет множество слов, которые могут встречаться в данном поле. Тип данных является важным параметром распознавания, влияющим на качество распознавания. Правильно указанный тип данных может существенно уменьшить количество неуверенно распознанных символов.

Тип пакета

Свойство пакета, описывающее параметры обработки документов в соответствующих пакетах. См. Типы пакетов

Типографский текст

Тип распознаваемого текста, представляющий собой текст, полученный типографским способом или с помощью лазерного или струйного принтера с разрешением не менее 300 точек на дюйм.

У

Уголок

Репер в виде уголка.

Ф

Файл описания

Сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. Подробнее см. Файл описания.

Форма

Документ, состоящий из одной или нескольких страниц и предназначенный для заполнения человеком от руки или любым печатным способом.

Ц

Цветная фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на цветном фоне, исчезающем при сканировании.

Ч

Черный квадрат

Репер в виде черного квадрата.

Черно-белая линейчатая форма

Форма, границы информационных полей которой задаются обычными линиями, не исчезающими при сканировании.

Ш

Штрих-код

Элемент машиночитаемой формы, представляющий собой штриховые знаки, кодирующие цифровую информацию посредством чередующихся полос черного и белого цвета определенной длины. Штрих-код в документе может предназначаться для извлечения информации (поле штрих-код) или для наложения или идентификации определения документа (реперный штрих-код).

Э

Экспорт

Процесс передачи обработанных данных во внешнюю информационную систему или файл.

Эталон текста

Файл, содержащий образцы начертания всех символов алфавита.

Я

Язык распознавания

Язык, на который опирается ABBYY FlexiCapture при распознавании текста.

Язык (регион)

Свойство поля, определяющее язык написания и соответствующие ему наборы региональных параметров (например, способ написания даты или адреса).

Яркость

Порог световой чувствительности, определяющий, начиная с какого значения полутона шкалы градаций серого будут восприниматься сканером как белый цвет.


Горячие клавиши на станции верификации данных

Меню | Команда | Горячие клавиши
Файл | Выход | Alt+F4
Вид | Полноэкранный режим | F11
 | Обновить | F5
Задания | Получить задание | Ctrl+G
Справка | Вызов справки | F1


Поддерживаемые языки распознавания

Программа ABBYY FlexiCapture поддерживает следующие языки распознавания со словарной поддержкой:

Язык | OCR* | ICR**
английский | ü | ü
армянский (восточный, западный, грабар) | ü |
башкирский | ü |
болгарский | ü | ü
венгерский | ü | ü
греческий | ü | ü
датский | ü |
иврит | ü |
индонезийский | ü | ü
испанский | ü | ü
итальянский | ü | ü
каталанский | ü |
латышский | ü | ü
литовский | ü | ü
немецкий (старая, новая орфография) | ü | ü
нидерландский (Нидерланды и Бельгия) | ü | ü
норвежский (нюнорск и букмол) | ü |
польский | ü | ü
португальский (Португалия и Бразилия) | ü |
румынский | ü | ü
русский | ü | ü
словацкий | ü | ü
словенский | ü | ü
староанглийский | ü |
староитальянский | ü | ü
староиспанский | ü | ü
старонемецкий | ü | ü
старофранцузский | ü | ü
тайский | ü |
татарский | ü |
турецкий | ü | ü
украинский | ü | ü
финский | ü | ü
французский | ü | ü
хорватский | ü | ü
чешский | ü | ü
шведский | ü |
эстонский | ü | ü

Более подробно о шрифтах для поддерживаемых языков см. раздел "Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе ABBYY FlexiCapture".

Полный актуальный список поддерживаемых типов данных и подробная информация о них приведены на сайте http://www.abbyy.ru.

* - OCR - Optical Character Recognition. Оптическое распознавание типографских текстов.

** - ICR - Intelligent Character Recognition. Распознавание рукопечатных текстов.


Алфавит, используемый в регулярных выражениях

Название | Условное обозначение | Пример использования
Любой символ | * | "к"*"т" – допускает слова типа кит, кот и т.п.
Буква | С | С"от" – допускает слова типа Рот, рот, кот, Кот, мот и т.д.
Заглавная буква | А | A"от" – допускает слова типа Рот, Кот, Мот, Дот и т.п.
Строчная буква | а | а"от" – допускает слова типа рот, кот, мот, дот и т.п.
Буква или цифра | Х | X – допускает любую одиночную цифру или букву.
Цифра | N | N"-й" допускает слова типа 5-й, 4-й, 1-й и т.п.
Строка | " " | "кот"
Или | | | "пл"("о"|"а")"т" – допускает слова "плот" и "плат".
Символ из группы | [] | [тм]"от" – допускает слова тот и мот.
Символ не из группы | [^] | [^т]"от" – допускает слова "кот", "лот" и т.п., но не допускает слова "тот".
Пробел (в группе) | \s | [A\s] допускает только букву А либо пробел.
Любое число повторений (распространяется на стоящее слева выражение или подвыражение) | {-} | [АБ74]{-} – допускает любые комбинации символов А, Б, 7, 4 произвольной длины.
Количество повторений n | {n} | N{2}"-й" допускает слова типа 25-й, 84-й, 11-й и т.п.
От n до m повторений | {n-m} | N{1-3}"-й" допускает слова типа 5-й, 84-й, 111-й и т.п.
От 0 до n повторений | {-n} | N{-2}"-й" допускает слова типа -й, 84-й, 1-й и т.п.
От n и больше повторений | {n-} | N{2-}"-й" допускает слова типа 25-й, 834-й, 311-й, 34576-й и т.п.
Подвыражение | () |
Символ "дефис" | [\-] |
Символ "слеш" | [\\] |

Примеры регулярных выражений:

  1. Почтовый индекс: [0-9]{6} Пример значения: "142172"
  2. Zip код (США): [0-9]{5}("-"[0-9]{4}){-1} Примеры значений: "55416", "33701-4313"
  3. Доход: N{4-8}[,]N{2} Примеры значений: "15000,00", "4499,00"
  4. Месяц числом: ((|"0")[1-9])|("10")|("11")|("12") Примеры значений: "4", "05", "12"
  5. Дробное число: ("-"|)([0-9]{1-})(|(("."|",")([0-9]{1-}))) Примеры значений: "1234,567", "0.99", "100,0", "-345.6788903"
  6. E-mail: [A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-3}"@"[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-4}"."([A-Za-z]{2-4}|"asia"|"museum"|"travel"|"example"|"localhost") Примеры значений: "support@abbyy.com", "my-name@company.org.ru", "info@gallery.museum"


Поддерживаемые типы текста

Программа ABBYY FlexiCapture поддерживает следующие типы текста:

Тип текста | Описание
Типографский, лазерный или струйный принтер | Текст, напечатанный типографским способом, на лазерном или на струйном принтере
Пишущая машинка | Текст, напечатанный на пишущей машинке
Матричный принтер | Текст, напечатанный на матричном принтере
Index | Специальный набор символов, включающий только цифры для написания почтового индекса.Выглядит следующим образом:
OCR-A | Моноширинный шрифт, разработанный специально для оптического распознавания символов.Широко используется банками и в смежных отраслях. Может выглядеть следующим образом:
OCR-B | Шрифт, разработанный специально для оптического распознавания символов.Может выглядеть следующим образом:
MICR E-138 | Специальный набор цифр, напечатанный магнитными чернилами. MICR - Magnetic Ink Character Recognition. Может выглядеть следующим образом:
MICR CMC-7 | Специальный шрифт MICR (CMC-7). Может выглядеть следующим образом:


Проверка правил

Скрипт после проверки правил

Назначение

Обработчик этого события используется после проверки правил.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Чтение/запись | Представляет документ.


Создание пакета

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-либо действия с пакетом, например, сохранить данные в регистрационные параметры пакета.

Когда вызывается

Вызывается сразу после добавления пакета в проект.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Вновь добавленный пакет

* - Внутреннее поле требует загрузки объекта в память.


Проверка целостности пакета

Назначение

Проверяет состав пакета. Например, с помощью данного скрипта можно проверить наличие обязательных документов в пакете или сравнить количество документов, указанное на контрольной странице, с количеством обработанных документов.

Когда вызывается

Вызывается перед отправкой (если в настройках маршрутизации включена соответствующая опция) или по явной команде пользователя.

Параметры

Имя | Тип | Права | Значение
CheckResults | IBatchCheckResults | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Объект, предоставляющий доступ к проверяемому пакету, а также служащий для выставления результатов проверки.

Внимание! Из скрипта недоступны следующие методы: HasField, Field, SaveAs, ExcludedFromDocumentImage, Page.Rect, Document.Children (для обращения к полям документа нужно использовать метод IndexedItemValue).

* - Внутреннее поле требует загрузки объекта в память.


Изменение свойств пакета

Назначение

Обработчик этого события можно использовать для осуществления форматирования некоторых свойств пакетов.

Свойства

  • Тип пакета (имя типа пакета)
  • Имя пакета
  • Описание пакета
  • Значение регистрационного параметра
  • Приоритет пакета. Задается строкой. Допустимые значения перечислены в описании объекта TProcessingPriority.

Когда вызывается

Вызывается перед изменением одного из свойств.

Замечание. Задать новое значения для свойства "тип пакета" с помощью данного сприпта нельзя.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Пакет, свойство которого изменяется.
PropertyModification | IPropertyModificationInfo | Полные права | Содержит информацию об изменяющемся свойстве. Позволяет подменять выставляемое значение.

* - Внутреннее поле требует загрузки объекта в память.


Открытие/закрытие пакета

Когда вызывается

Вызывается после открытия пакета или перед закрытием пакета.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Пакет

* - Внутреннее поле требует загрузки объекта в память.


Удаление пакета

Назначение

Обработчик этого события используется в том случае, если нужно удалить какие-либо данные, связанные с пакетом.

Когда вызывается

Вызывается непосредственно перед удалением пакета.

Замечание. При удалении пакета не происходит события удаления документов и страниц пакета.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Удаляемый пакет

* - Внутреннее поле требует загрузки объекта в память.


Изменение состава пакета (Добавление/Удаление страниц или документов)

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-то действия с пакетом, документом, страницей в зависимости от нового изображения. Например, если ведется подсчет общего числа страниц, добавлявшихся в данный пакет, чтобы убедиться, что никакие страницы не были потеряны.

Когда вызывается

Вызывается непосредственно после добавления и перед удалением страниц или документов.

Замечание. При удалении документа не происходит события удаления страниц документа.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Внутренние* поля документов и страниц пакета недоступны | Пакет, в котором происходит удаление/добавление страниц или документов
Document (или Page) | IDocument (или IPage) | Заголовки изменяемого документа (страницы) можно модифицировать. Документы (страницы) пакета, в том числе удаленный документ (страница), доступны только на чтение. | Удаляемый/добавляемый объект

* - Внутреннее поле требует загрузки объекта в память.


Перед наложением определений документов

Назначение

С помощью этого события пользователь может управлять тем, какие разделы или определения документов будут накладываться на очередную страницу, а также задавать порядок их наложения.

С помощью данного скрипта можно ускорить наложение определения документа, если известно, какие разделы нужно накладывать, например:

  • известно, что в пакете только первая страница может иметь определение документа Contents;
  • известно, что данная страница имеет данный тип раздела;
  • известно, что разделы в документах идут в определенном порядке.

Скрипт позволяет отключить распознавание документов после наложения определений документа. Для этого нужно присвоить параметру IMatchingInfo.NeedRecognition значение false. Это может потребоваться, если значения полей будут вводиться вручную.

Возможно также пометить страницу как страницу-приложение без распознавания. Для этого нужно указать пустой список разделов и присвоить параметру IMatchingInfo.ForceMatch значение true.

Когда вызывается

Вызывается непосредственно перед тем, как накладывать разделы на очередную страницу.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Документ, страницы которого анализируют
Matching | IMatchingInfo | Полные права | Объект, определяющий некоторые параметры наложения
PageIndex | int | Только чтение. Внутренние поля документов и страниц пакета недоступны. | Номер страницы в документе, которую сейчас будут анализировать

* - Внутреннее поле требует загрузки объекта в память.

Замечание. Указать, какие разделы и определения документов необходимо накладывать, можно также с помощью именованных регистрационных параметров. Подробнее смотрите Регистрационные параметры.


Изменение свойства документа

Назначение

Обработчик этого события можно использовать для осуществления форматирования некоторых свойств пакетов.

Свойства документа

  • Комментарий
  • Значение регистрационного параметра
  • ExternalID
  • Приоритет документа. Задается строкой. Допустимые значения указаны в описании объекта TProcessingPriority.

Когда вызывается

Вызывается перед изменением свойства документа.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Внутренние* поля документов и страниц пакета недоступны | Документ
PropertyModification | IPropertyModificationInfo | Полные права | Информация об изменяемом свойстве

* - Внутреннее поле требует загрузки объекта в память.


Изменение состояния документа

Назначение

В любой момент состояние документа можно описать массивом флагов. Данное событие происходит каждый раз, когда это состояние меняется. На вход событие получает множество флагов, описывающее изменение в состоянии документа.

Флаги, определяющие состояние:

  • Предобработанность
  • Проанализированность
  • Распознанность
  • Имеет ли ошибки правил/ форматные ошибки
  • Собранность
  • Верифицирован
  • Проэкспортирован
  • Имеет ли форму

Когда вызывается

Вызывается при сохранении документа, если с момента чтения его состояние изменилось.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Полные права | Документ
ChangedStates | IScriptBinaryAttributes<TStateType> | Только чтение | Объект, содержащий информацию об изменении состояния документа


Особенности .Net скриптов

Ниже описаны некоторые особенности .Net скриптов.

  • Доступ к элементам объекта осуществляется без дополнительных ключевых слов. Например, в правилах, написанных на .Net, контекст правила передаётся как параметр с именем "Context".
  • Сборки .Net должны быть скомпилированы в среде Microsoft .Net Framework версия 3.5 (или более ранняя). Версию .Net Framework можно задать в свойствах проекта в Visual Studio.
  • В скриптах и глобальных модулях разрешается использовать внешние сборки. Можно использовать как стандартные, так и скомпилированные пользовательские сборки. Все классы из добавленных сборок будут доступны всем скриптам и глобальным модулям. Подробнее смотрите Внешние сборки.
  • После компиляции откомпилированные тела .Net скриптов хранятся там же, где они определены. Поэтому .Net скрипты могут занимать больше места, чем обычные скрипты.
  • Объекты FlexiCapture не поддерживают многопоточность.
  • Для отладки .Net скриптов используется метод System.Diagnostics.Debugger.Break.
  • При отладке .Net скриптов помимо сборки требуется также .pdb-файл с символьной информацией. PDB-файл имеет большой размер, и его не рекомендуется хранить вместе со скриптами в рабочем проекте. Однако перед компиляцией необходимо указывать, что скрипт должен компилироваться с отладочной информацией.
    Если используется MS Visual Studio 2010, то для отладки библиотек можно подсоединяться к процессу, в котором выполняет .Net-код.

  • Объекты скриптов FlexiCapture доступны в сборках ControllerInterop.dll и ShellInterop.dll и принадлежат пространству имен ABBYY.FlexiCapture и ABBYY.FlexiCapture.ClientUI соответственно. Файлы сборок хранятся в корневой папке программы.

  • Все объекты скриптов ABBYY FlexiCapture доступны под их собственными именами как классы из пространства имен ABBYY.FlexiCapture и ABBYY.FlexiCapture.ClientUI. Например:

    ABBYY.FlexiCapture.IDocument document = Batch.Documents[i];

    ABBYY.FlexiCapture.ClientUI.IToolbars toolbars = TaskWindow.MainWindow.Toolbars;

  • Using-директивы могут использоваться в заголовке кода. При этом используется тот же синтаксис, что и в языке программирования: using в языке C#.Net, Import в языке JScript.Net и Imports в языке VisualBasic.Net. Например:

    using System.Drawing;

    Image img = Image.FromFile( @"D:\2.png" );

    FCTools.ShowMessage( img.VerticalResolution.ToString(), false );

    Замечание. В Редакторе скриптов поддержана возможность использования директивы using. Такое поведение возможно только, если ключевое слово using используется до первой строчки исполняемого кода. Например:

    using System.IO;

    File.Create(@"C:\sample.txt");

  • Функции глобальных модулей вызываются из .Net скриптов напрямую, без указания названия модуля.
    Замечание. Классы, описанные в глобальном модуле правил и в глобальном модуле скриптов, должны иметь разные имена. Если в модуле Rule Global Script Module описан класс с тем же именем, что и в модуле Export Global Script Module, то при попытке создать экземпляр класса в коде правила возникнет сообщение об ошибке.
  • Если функция имеет опциональные параметры и вы не хотите задавать конкретное значение опционального параметра, то в качестве опционального параметра необходимо передавать System.null или System.Type.Missing.

Замечание. Если скрипт выполняет не в интерактивном режиме (процессом FlexiEx.exe, а не FlexiCapture.exe), то по умолчанию кнопка Debug не отображается в окне "Поиск решений" (для скриптов, в которых установлен breakpoint). Для того чтобы отобразить кнопку, нажмите на иконку Центр поддержки на панели задач и отметьте опцию Настройка центра поддержки > Параметры отчетов о неполадках > Не проверять на наличие новых решений.


Обработчики событий

FlexiCapture позволяет создавать обработчики для событий пакета, событий документа и событий поля.

Обработчики событий хранятся в типе пакета или определении документа и настраиваются на вкладке Обработчики событий в свойствах:

  • типа пакета (для определенного типа пакета);
  • проекта (для всех типов пакетов проекта, кроме тех, для которых были настроены обработчики событий в свойствах типа пакета);
  • определения документа (для документов текущего типа).

События пакета

После создания пакета
Перед удалением пакета
Перед изменением свойств пакета
После добавления страницы
Перед удалением страницы
После создания документа
Перед удалением документа
Перед перемещением страниц
После открытия пакета
Перед закрытием пакета
Проверка целостности пакета

События документа для типов пакетов

Обработчики событий для типов пакетов настраиваются в свойствах проекта или в свойствах типов пакетов.

Перед изменением свойств документа
После изменения состояния документа
После завершения экспорта
Перед наложением

События документа для текущего типа документов

Обработчики событий для текущего типа документов настраиваются в свойствах определения документа.

Перед изменением свойств документа
После изменения состояния документа
После проверки правил в документе

Также в свойствах определения документа настраивается событие для поля (см. ниже).

События поля

Запрос верификации поля

Замечание. Если одно и то же событие определено и для типов пакетов, и для текущего типа документов, сначала запускается обработчик событий для документа, затем - для пакета.

Collapsed Запись повторяющихся процедур в глобальные модули

Процедуры, которые планируется использовать в нескольких обработчиках, рекомендуется записать в глобальный модуль. Для этого в редакторе скриптов в выпадающем списке на панели инструментов необходимо выбрать Events.

Замечание. Для обработчиков событий в редакторе определений документа глобальные модули не доступны.

Collapsed Подключение внешней сборки

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить. Данную процедуру можно выполнить на вкладке Сборки .Net в свойствах объекта (типа пакета, проекта, определения документа).


Запрос на верификацию поля

Назначение

Позволяет пользователю управлять тем, какие поля не попадут на контекстную верификацию. Может быть использовано для того, чтобы верифицировать разные поля на разных этапах обработки.

На вход обработчику события передается поле и документ.

Когда вызывается

Событие вызывается для всех полей перед тем, как они поступают на контекстную верификацию. Для полей, пропускающих контекстную верификацию, событие не выполняется.

Параметры

Имя | Тип | Права | Значение
Field | IField | Только чтение | Поле, для которого осуществляется проверка
Document | IDocument | Только чтение | Документ, содержащий поле
NeedVerification | IBoxedBoolean | Полные права | Нужно ли верифицировать поле. Записав в этот параметр значение "false", пользователь отказывается от верификации поля.


IActionResult

Назначение

Описывает специальный объект для описания того, успешно ли прошёл экспорт (или событие пост-экспорта) конкретного документа.

Свойства

Имя | Тип | Права | Значение
Succeeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли операция успешной
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке
Result | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Формальное описание результата операции. Для экспорта – описание того, куда был проэкспортирован документ (например, путь к файлу).
Name | string | Только чтение | Имя профиля экспорта
Type | TExportType | Только чтение | Тип профиля экспорта (для использование в скрипте )"после экспорта"
Applied bool Только чтение Был ли экспорт произведён в течение текущей сессии экспорта. В случае если параметр имеет значение false:
  • если значение флага Succeeded равно true, это означает, что документ был проэкспортирован в эту цель ранее;
  • если значение флага Succeeded равно false, это означает, что документ не подходит для экспорта в данную цель (например, из-за ошибок в документе).


IAssemblingError

Назначение

Ошибка сборки документа.

Свойства

Имя | Тип | Права | Значение
Type | TAssemblingErrorType | Только чтение | Тип ошибки сборки
Description | string | Только чтение | Описание
SectionName | string | Только чтение | Имя недостающего раздела (для AET_ObligatoryItemOmitted). Для страниц-приложений пусто.
Position | int | Только чтение | Позиция в документе
Weight | string | Только чтение | Вес ошибки


IAssemblingErrors

Назначение

Коллекция объектов IAssemblingError.

Можно менять только в скрипте сборки документа.

Методы

Определение | Описание
AddSectionOmittedError( int position, sectionName : string, [optional] description ) | Позволяет добавить ошибку о пропущенном разделе
AddRedundantPageError( int position, [optional] description ) | Позволяет добавить ошибку о лишней странице
AddCustomError( description : string, [optional] weight : int ) | Позволяет добавить пользовательскую ошибку сборки

Внимание! Метод AddCustomError следует использовать осторожно и только в том случае, когда не подходят другие типы ошибок. Так как сборка документа полностью определяется числом ошибок сборки, то при добавлении таких ошибок нужно правильно выставлять вес, а правильный выбор веса является непростой задачей.

Желательно не объединять в CustomError несколько стандартных ошибок, порождая одну ошибку с сообщением обо всех возникших ошибках.


IUserAttachment

Назначение

Интерфейс используется для работы с содержимым файла пользовательского приложения. Объект является массивом байт. Доступ к байтам осуществляется так же, как к объектам в коллекции. Разрешается менять значение байтов в любой позиции.

Методы

Определение | Описание
SetSize( newSize : int) : bool | Изменяет размер файла. Если файл имеет размер меньше указанного, размер файла увеличивается; файлы, имеющие размер больше указанного, обрезаются.
ToFile( fileName : string) | Сохраняет файл на диск по указанному пути.
FromFile( fileName : string) | Заменяет содержимое приложение файлом, расположенным по указанному пути.
UploadAttachment( ) | Сохраняет все изменения, сделанные в приложении.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя файла.
AsString | string | Чтение/запись | Представление файла в виде одной Unicode-строки. Файлы можно как записывать, так и читать в виде Unicode-строки.


IUserAttachments

Назначение

Коллекция объектов IUserAttachment.

Методы

Определение | Описание
Has( name : string) : bool | Проверяет, существует ли файл-приложение с указанным именем.
Get( name : string) : IUserAttachment | Позволяет получить доступ к файлу-приложению с указанным именем.
AddNew( name : string) : IUserAttachment | Позволяет создать новый файл-приложение и начать его редактировать. Внимание! Метод создает новый экземпляр IUserAttachment, не добавляя его в коллекцию, и возвращает ссылку на созданный экземпляр. Чтобы созданный экземпляр был добавлен в коллекцию и был доступен из коллекции, нужно вызвать метод UploadAttachment( ). Замечание. Если коллекция уже содержит вложение с таким именем, имеющее ненулевой размер, будет возвращено исключение.
Delete( name : string) | Удаляет файл-приложение с указанным именем. Замечание. При удалении наличие удаляемого элемента не проверяется. Таким образом, данный метод выполнится успешно, даже если удаляемый элемент отсутствует в коллекции.

Свойства

Имя | Тип | Права | Значение
Names | IVariantArray | Только чтение | Массив с именами файлов-приложений.
IsEmpty | bool | Только чтение | Проверяет, есть ли в массиве какие-либо файлы приложений.


IBatch

Назначение

Служит для представления пакета.

Методы

Внимание! Методы ниже требуют права на модификацию структуры пакета. Эти методы могут быть вызваны только из скрипта обработки пакета.

Определение | Описание
CleanRecognitionResults( document : IDocument ) | Удаление результатов распознавания документа.
CreatePageFromImage( page : IPictureObject, [optional] target : IDocument, [optional] position : int, [optional] sourceInfo : string ) : IPage | Создает страницу из объектаIPictureObject и возвращает созданную страницу. Если указан документ, страница добавляется в этот документ. Для создания одностраничного документа в качестве документа нужно указать null. Если указана позиция, происходит добавление страницы на указанную позицию в документе (если документа задан) либо добавление одностраничного документа на указанную позицию в пакете (если в качестве документа указан null). Начальной позиции соответствует значение "0", позиции в конце документа или пакета - значение "-1". Если указан параметр sourceInfo, он записывается в информацию об источнике страницы. Если параметр sourceInfo не указан, в информацию об источнике страницы записывается информация, полученная из объекта IPictureObject.
CreateDocumentFromPage( targetPosition : int, page : IPage ): IDocument | Извлечение страницы из документа для создания на ее основе нового документа
DeleteDocument( document : IDocument ) | Удаление документа
DeletePage( page : IPage ) | Удаление страницы
MoveDocument( source : IDocument, targetPosition : int ) | Перемещение документа в указанную позицию в пакете.
MovePage( source : IDocument, target : IDocument, sourcePageIndex : int, int targetPageIndex : int ) | Перемещение страницы с индексом "sourcePageIndex" из документа "source" в документ "target" в позицию "targetPageIndex"
[Obsolete] RegistrationProperty( name : string ) : string | Получение регистрационного параметра по имени. Устаревший метод, оставленный для совместимости.

Свойства

Имя | Тип | Права | Значение
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений.
BatchTypeName | string | Только чтение | Имя типа пакетов.
Comment | string | Чтение/запись | Комментарий.
CreatedBy | IPrincipal | Только чтение | Автор созданного пакета. Для ABBYY FlexiCapture версии Standalone возвращает значение null.
Documents | IDocuments | Только чтение | Документы пакета.
Id | int | Только чтение | Идентификатор пакета. Уникален в пределах проекта.
Name | string | Чтение/запись | Имя пакета.
Priority | TProcessingPriority | Чтение/запись | Приоритет пакета.
Project | IProject | Только чтение | Проект, содержащий пакет.
Properties | IProperties | Только чтение | Именованные параметры пакета.
[Obsolete] RegistrationProperties | IProperties | Только чтение | Регистрационные параметры пакета. Устаревшее свойство, оставлено для совместимости.


IBatchCheckResults

Назначение

Объект – контекст события "Проверка целостности пакета".

Свойства

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение | Пакет
CheckSucceeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли проверка успешна
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке


IBoxedBoolean

Назначение

Объект для передачи в скрипты in-out булевого значения.

Свойства

Имя | Тип | Права | Значение
Value | bool | Чтение/запись | Значение


ICharacterParams

Назначение

Информация о свойствах символа.

Методы

Определение | Описание
SetRect( newRect : string, [optional] pageId : int ) | Задает новый прямоугольник для символа. Параметр newRect нужно передавать в виде строки "[left, top, right, bottom]". Задаваемый прямоугольник должен полностью входить в регион поля, содержащего символ. Замечание. В скрипте автозамены данный метод недоступен.

Свойства

Имя | Тип | Права | Значение
Confidence int Только чтение Уровень уверенности в типе пакетов. Возвращает значение от 0 до 100.

Внимание! Для работы данного свойства необходимо хранение дополнительной информации, что может привести к увеличению размера документов и увеличению потребления дискового пространства. По умолчанию дополнительная информация не сохраняется, и свойство не работает.
Для корректной работы данного свойства в системном реестре необходимо задать ключ [HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller] “ForceSaveConfidenceLevel” = “true”. Вместо HKEY_CURRENT_USER следует выбрать ветку пользователя, под учетной записью которого выполняется распознавание документов.
IsSuspicious bool Чтение/запись Уверенно ли распознан символ. Указывать значение этого флага имеет смысл только в скрипте распознавания.

Замечание. При выставлении флага IsSuspicious из скрипта распознавания символы будут проверены на порог полевой верификации. Если процент символов поля с выставленным флагом IsSuspicious превышает указанный порог полевой верификации, таким символам выставляется флаг NeedVerification.
NeedVerification bool Чтение/запись Требуется ли символу верификация. Значение этого флага определяет, будет ли символ подсвечен.

Замечание. При выставлении флага NeedVerification из скриптов всех типов, кроме скрипта распознавания, поле сразу помечается к отправке на верификацию. Выставлению флага NeedVerification из скрипта распознавания предшествует проверка на порог полевой верификации (см. замечание для свойства IsSuspicious).

Чтобы указать, требуется ли верификация для всего поля (не отдельных символов), используйте свойство NeedVerification интерфейса IField
PageId | int | Только чтение | Идентификатор страницы, на которой расположен прямоугольник символа (для многостраничных полей).
Rect | IRect | Только чтение | Прямоугольник символа. Если прямоугольник не задан, возвращает null.
Symbol | string | Чтение/запись | Символ (строка, состоящая из одного символа).


ICharactersParams

Назначение

Массив объектов типа ICharacterParams.

Методы

Определение | Описание
Add( value : Object, [optional] position : int ) | Вставляет элемент value в текст на указанную позицию. Если позиция не указана, элемент добавляется в конец. Замечание. Параметр value может быть символом, строкой, объектом ICharacterParams, а также объектом ICharactersParams. Таким образом, можно копировать символы или текст из других полей с сохранением разметки и подсветки. Если регионы символов не помещаются в регион нового поля, копирование не выполняется.


ICheckmarkGroupValue

Назначение

Коллекция объектов ICheckmarkValue.


ICheckmarkValue

Назначение

Служит для представления значения метки.

Свойства

Имя | Тип | Права | Значение
IsSuspicious | bool | Чтение/запись | Уверенно ли распознано значение метки. По умолчанию все метки считаются неуверенно распознанными.
Name | string | Только чтение | Имя метки (имя поля в определении документа)
Rect | IRect | Только чтение | Прямоугольная область метки
Value | bool | Чтение/запись | Значение метки


IPageClassificationResult

Назначение

Содержит информацию о результатах классификации страницы.

Свойства

Имя | Тип | Права | Значение
MatchedSections string Только чтение Список разделов, которые могут быть наложены. Содержит записи вида <Document Definition Name>\<Section Name>, разделенные точкой с запятой. Этот список может быть в неизменном виде передан объекту IMatchingInfo в качестве параметра DefinitionsList (IMatchingInfo::DefinitionsList). Передать результаты в скрипт можно следующим образом:
  1. Создать пользовательский этап на основе скрипта.
  2. На этом этапе написать скрипт, который классифицирует документы и записывает результаты в регистрационные параметры.
  3. В скрипте Перед наложением определений документов добавить код, использующий результаты классификации из регистрационного параметра, если регистрационный параметр задан.

Замечание. При передаче результатов классификации в скрипт Перед наложением определений документов, установите для флага IMatchingInfo.ForceMatch значение false, для того чтобы не выполнялась повторная классификация страниц при помощи скрипта.
PageType | TPageClassificationType | Только чтение | Тип страницы


IDataSet

Служит для представления набора данных.

Методы

Определение | Описание
CreateRecord () : IDataSetRecord | Создает запись для последующего добавления в набор данных.
AddRecord ( dataSetRecord : IDataSetRecord ) | Добавляет запись в набор данных.
CreateQuery () : IDataSetQuery | Создает объект запроса к набору данных.
GetRecords (IDataSetQuery : query) : IRecordset | Позволяет получить из набора данные, соответствующие запросу.
GetRecordsCount (IDataSetQuery : query) : int | Позволяет узнать количество соответствующих запросу записей в наборе данных.


IDataSetQuery

Служит для представления запроса к набору данных.

Методы

Определение | Описание
AddValue ( column : string, value : object ) | Позволяет добавить одно или несколько условий к запросу путем указания имени колонки и ее значения.


IDataSetRecord

Служит для представления записи из набора данных.

Методы

Определение | Описание
AddValue ( column : string, value : object ) | Добавляет значение в запись из набора данных путем указания имени колонки и ее значения.
GetColumnName ( index : int ) : string | Позволяет получить название столбца. Замечание. Т.к. существует возможность множественных значений, название столбца может встречаться в IDataSetRecord несколько раз с различными значениями.
GetValue ( index : int ) : object | Позволяет получить значение поля.

Свойства

Имя | Тип | Права | Значение
ColumnCount | Int | Только чтение | Количество полей в записи.


IDocumentDefinitionInfo

Назначение

Содержит информацию о наложенном на документ Определении документа.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя Определения документа.
SectionsInDefinition | ISectionDefinitionInfoArray | Только чтение | Массив секций в Определении документа. Возвращает только включённые секции.
Version | int | Только чтение | Версия Определения документа.


IDocumentDefinitionInfoArray

Назначение

Коллекция объектов типа IDocumentDefinitionInfo.


IDocumentsExportResults

Назначение

Коллекция объектов IDocumentExportResults.

Представляет результаты экспорта для множества документов.


IDocument

Назначение

Служит для представления документа.

Методы

Определение | Описание
CheckRules( ) | Проверяет все правила в документе. Требуются права на запись в документ.
Field( name : string ) : IField | Доступ к полю документа по полному пути к нему. Используются полные пути. Является внутренним* полем. В правилах запрещено.
HasField( name : string ) : bool | Есть поле с указанным путём. Используются относительные пути. Является внутренним* полем. В правилах запрещено.
IndexedItemValue( name : string ) : VARIANT | Позволяет получить значение поля по пути к нему или по имени. Доступно из внешних полей документов и страниц. Разрешается использовать имя поля или полный путь к полю в документе. Использование в правилах запрещено.
IndexedItemValues( name : string ) : IVARIANTArray | Позволяет получить множество индексных полей, соответствующих одному полю в определении документа. Если поле помечено как индексное в повторяющемся разделе, метод возвращает все значения этого поля для всех разделов. Доступно из внешних полей документов и страниц. Разрешается использовать имя поля или полный путь к полю в документе. Использование в правилах запрещено.
Property( name : string ) : VARIANT Возвращает значение предопределённого свойства по его имени. Возвращаемое значение может быть в виде строки, числа или времени. Имена свойств и возвращаемые значения:
  • Exported - время экспорта
  • ExportedBy - кто экспортировал документ
  • Created - время создания
  • CreatedBy - кем был создан документ
  • Recognized - время распознавания
  • RecognizedBy - кем был распознан докуметн
  • Modified - время последнего редактирования
  • ModifiedBy - кем редактировался документ
  • TotalSymbolsCount - общее число символов
  • UncertainSymbolsCount - общее число неуверенно распознанных символов
  • RecognizedSymbolsCount - число распознанных символов
  • Comment - комментарий к документу
  • ProcessingErrors - ошибки обработки документа
  • ProcessingWarnings - прудупреждения обработки документа
Repair( [optional] Object reserved ) : IDocument Обновляет определение документа до последней версии. При этом данные в документах, которые уже были отверифицированы или отредактированы, сохраняются.
Обновление определения документа без распознавания может потребоваться, например, в связи с изменившимися настройками экспорта.
Замечание. Метод является скрытым и не отображается в Visual Studio.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) Сохраняет изображение одностраничного или многостраничного документа. Если в опциях формат сохранения не указан, изображение сохраняется *.tif. Является внутренним* полем.
SaveAsStream( [optional ]options: IExportImageSavingOptions ) : byte[] Сохраняет документ в поток в памяти и возвращает его как массив byte (COM SafeArray).

Замечание. Языки JScript, VBScript не поддерживают итерацию по возвращаемому массиву.

Внимание! Метод Property не следует путать с коллекцией Properties, которая содержит свойства документа, задаваемые пользователем.

Свойства

Имя | Тип | Права | Значение
Action | IActionResult | Только чтение | Использование этого свойства имеет смысл только в скриптах экспорта и пост-экспорта
AssemblingErrors | IAssemblingErrors | Только чтение | Коллекция ошибок сборки. Доступ к коллекции всегда только на чтение.
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений
Batch | IBatch | Только чтение | Пакет. Независимо от прав скрипта на документ, доступ к пакету будет только на чтение, внутренние* поля документов и страниц недоступны.
BatchName | string | Только чтение | Имя пакета
Children | IFields | Только чтение | Дочерние поля документа – разделы. В отличие от свойства Sections, порядок разделов соответствует их порядку в определении документа. Повторяющиеся разделы предствлены одним элементом и сами повторения доступны через метод Items такого элемента. Является внутренним* полем. Использование в правилах запрещено.
Comment | string | Чтение/запись | Комментарий документа
DefinitionName | string | Только чтение | Имя определения документа
DocumentDefinition | IDocumentDefinitionInfo | Только чтение | Детальная информация о наложенном на документ Определении документа. Для нераспознанных и необработанных документов свойство возвращает пустую строку.
Id | string | Только чтение | Идентификатор документа (External Id)
IsAnalyzed | bool | Только чтение | Проанализирован ли документ. Документ считается проанализрованным, если проанализирована каждая страница документа.
Index | int | Только чтение | Индекс документа в пакете.
IsAssembled | bool | Только чтение | Собран ли документ
IsExcludedFromAutomaticAssembling | bool | Чтение/запись | Участвует ли документ в автоматической сборке.
IsExported | bool | Только чтение | Проэкспортирован ли документ
IsRecognized | bool | Только чтение | Распознан ли документ. Документ считается распознанным, если каждая страница документа либо распознана, либо является страницей-приложением.
IsVerified | bool | Только чтение | Верифицирован ли документ
HasErrors | bool | Только чтение | Есть ли в документе ошибки правил или формата
HasUnpreparedImages | bool | Только чтение | Содержит ли документ непредобработанные страницы.
HasWarnings | bool | Только чтение | Есть ли в документе предупреждения правил или формата
MarkedNextStage | IStageInfo | Только чтение | Возвращает объект IStageInfo - информацию об этапе обработке документа. Если документ не размечен, то свойство IStageInfo.StageName имеет значение null.
Pages | IPages | Только чтение | Страницы документа
Priority | TProcessingPriority | Только чтение | Приоритет документа.
ProcessingErrors | string | Только чтение | Ошибки процесса обработки, разделённые через перенос строки
ProcessingWarnings | string | Только чтение | Предупреждения процесса обработки, разделённые через перенос строки
ProhibitedUserId | int | Только чтение | Задание, созданное из документа, не будет доступно пользователю с данным идентификатором. По умолчанию имеет значение "0" - означает, что задание доступно любому пользователю.
Properties | IProperties | Только чтение | Регистрационные параметры документа
RecognizedSymbolsCount | int | Только чтение | Число распознанных символов
RuleErrors | IRuleErrors | Только чтение | Коллекция ошибок в документе (ошибки формата, ошибки правил, ошибки при слиянии результатов двойной верификации). Доступно только для открытых документов.
Sections | IFields | Только чтение | Плоский список разделов документа. Если раздел повторяется, то в списке лежат все повторения раздела. Порядок разделов в списке соответствует порядку первых страниц разделов в документе. Разделы без страниц идут последними в списке. Является внутренним* полем. Использование в правилах запрещено.
StageInfo | IStageInfo | Только чтение | Информация об этапе обработки документа на сервере приложений
SymbolsForVerificationCount | int | Только чтение | Число символов, для которых требуется верификация
TotalSymbolsCount | int | Только чтение | Общее число символов
UncertainSymbolsCount | int | Только чтение | Число неуверенно распознанных символов
[Obsolete]RegistrationProperties | IProperties | Только чтение | Регистрационные параметры документа. Свойство оставлено для совместимости.
[Obsolete]RegistrationProperty( name : string ) | string | Только чтение | Получение регистрационного параметра по имени. Свойство оставлено для совместимости.
[Obsolete]TemplateName | string | Только чтение | Имя определения документа. Свойство оставлено для совместимости.

* - Внутреннее поле требует загрузки объекта в память.


IDocuments

Назначение

Коллекция объектов IDocument.


IEditablePictureObject

Назначение

Represents a picture that can be edited in ABBYY FlexiCapture. Расширяет интерфейс IPictureObject.

Методы

Определение | Описание
Rotate( angle : int ) | Поворачивает изображение по часовой стрелке на указанный угол в градусах.
FlipHorizontal() | Отражает изображение относительно вертикальной оси.
FlipVertical() | Отражает изображение относительно горизонтальной оси.
Invert( [optional] rectString : string ) | Инвертирует изображение. Можно указать строку с координатами прямоугольника, который нужно инвертировать.
ConvertToBW( [optional] threshold : int ) | Преобразует изображение в черно-белое. Можно указать значение пороговой яркости, выше которого точки будут считаться белыми, а ниже – чёрными. Пороговая яркость указывается в диапазоне от 0 до 255.
Deskew( [optional] byLines : bool, [optional] byBlackSquares : bool, [optional] byText : bool ) | Автоматически исправляет перекос изображения. Коррекция перекоса изображения может осуществляться на основе прямых линий, по черным квадратам или по тексту. По умолчанию параметр byText имеет значение true.
Despeckle( [optional] garbageSize : int ) | Очищает черно-белое изображение от мусора. Точки не крупнее заданной величины garbageSize удаляются. Если значение параметра garbageSize не задано, размер определяется автоматически. Внимание! Метод применим только к черно-белым изображениям.
Erase( rectangle : string, [optional] red : int, [optional] green : int, [optional] blue : int ) | Затирает область на изображении. Можно указать цвет, используемый при затирании. По умолчанию используется черный цвет.
CutOut( rect : string ) : IEditablePictureObject | Вырезает из изображения заданный прямоугольник и возвращает этот прямоугольник.
Crop( rect : string ) | Обрезает края изображения за пределами заданного прямоугольника rect.
Scale( ratio : int ) | Растягивает или сжимает изображение относительно базового размера в 100%. Метод изменяет только пиксельные размеры изображения. Физические размеры изображения остаются прежними.
FreeScale( newWidth : int, newHeight : int, newResolution : int ) | Масштабирует страницу в соответствии с указанными значениями.

Замечание. Параметр rect, передаваемый на вход методам CutOut и Crop, представляет собой строку вида «[left, top, right, bottom]». Получить такую строку можно либо вызвав метод ToString для любого объекта типа IRect, либо с помощью метода FCTools::Rect.


IExportFieldsToRedact

Назначение

Список полей, которые необходимо вырезать из целевой картинки.

Методы

Определение | Описание
Add( field : IField ) | Добавляет поле в список.
Clean() | Очищает список полей.

Свойства

Имя | Тип | Права | Значение
PlainList | string | Только чтение | Список полей, которые необходимо вырезать из целевой картинки. Формат записи - через точку с запятой в одну строку.


IExportImageSavingOptions

Назначение

Описывает настройки сохранения изображений.

Методы

Определение Описание
Add( value : Object, [optional] position : int ) Вставляет элемент value в текст на указанную позицию. Если позиция не указана, элемент добавляется в конец.
Замечание. Параметр value может быть символом, строкой, объектом ICharacterParams, а также объектом ICharactersParams. Таким образом, можно копировать символы или текст из других полей с сохранением разметки и подсветки. Если регионы символов не помещаются в регион нового поля, копирование не выполняется.
SetPdfDocumentInfo( type: TPdfDocumentInfoType, value: string ) Метаданные PDF-файла.

TPdfDocumentInfoType – виды полей в PDF.

PDIT_Author = 0 – автор документа

PDIT_Title = 1 – заголовок документа

PDIT_Subject = 2 – тема документа

PDIT_KeyWords = 3 – ключевые слова

Свойства

Имя | Тип | Права | Значение
AddProperFileExt | bool | Чтение/запись | Если выставлено значение "true", то при сохранении изображения его расширение выставится в соответствии с форматом. По умолчанию выставлено значение "false".
ColorType | string | Чтение/запись | Цветовая схема. Допустимые значения: "FullColor", "GrayScale", "BlackAndWhite". Строки не чувствительны к регистру.
FieldsToRedact | IExportFieldsToRedact | Чтение/запись | Список полей, которые необходимо вырезать из целевой картинки.
Format | string | Чтение/запись | Формат сохранения изображений. Допустимые выражения: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf" + параметры "-s" (PDF Searchable) и "-a" (PDF/A). Строки не чувствительны к регистру. Параметры пишутся начиная с "-" через табуляцию или пробел или без разделителей (например, "pdf -s", "pdf-a-s").
ImageCompressionType TImageCompressionType Чтение/запись Позволяет установить тип сжатия изображения при экспорте. По умолчанию тип сжатия выбирается автоматически в зависимости от формата и цветности.

Возможные значения:

ICT_Auto = -1. Тип сжатия устанавливается по умолчанию.

IFC_Lzw = 1,

IFC_Jpeg = 2,

IFC_PackBits = 3,

IFC_Png = 4,

IFC_Uncompressed = 5,

IFC_Zip = 6,

IFC_CcittGroup4 = 7

Замечание. При выборе неподходящего типа сжатия задание будет отправлено в исключения.
PdfTextSearchArea TPdfTextSearchAreaType Чтение/запись Определяет, где создавать текстовый слой для экспорта в PDF-S.

Возможные значения:

PTSAT_AttachmentsOnly = 0 – только аннексы
PTSAT_FormsOnly = 1 – только страницы с формой
PTSAT_AllPages = 2 – везде

Quality | int | Чтение/запись | Качество изображения для jpeg-сжатия (в процентах).
RecognitionLanguages | string | Чтение/запись | Множество языков, которые можно использовать при распознавании документов для экспорта в PDF с возможностью поиска. Список должен содержать внутренние имена языков на английском, разделенные точкой с запятой без пробелов. Если список пуст, то используется язык определения документов, наложенного на документ. Использование свойства имеет смысл только для страниц-приложений, так как для страниц, на которые наложены разделы, текстовый слой имеют только распознанные поля. Такие поля распознаются на этапе распознавания, а не на этапе экспорта, и задание этого свойства не влияет на их распознавание.
Resolution | int | Чтение/запись | Разрешение изображения (в DPI).
ShouldOverwrite | bool | Чтение/запись | Разрешается ли перезапись существующего файла.
UseMRC bool Чтение/запись Определяет, нужно ли использовать сжатие с помощью технологии Mixed Raster Content (MRC) при экспорте в PDF или PDF/A. Для некоторых изображений технология MRC обеспечивает лучшее сжатие, чем обычно используемый метод JPEG, например, для изображений хорошего качества с высоким уровнем контрастности текста на однородном фоне. Используйте MRC для уменьшения размера PDF-файла.
Замечание. По умолчанию флаг имеет значение true при экспорте в PDF и false при экспорте в PDF/A.


IFlexiCaptureTools

Назначение

Глобальный объект FCTools, реализующий данный интерфейс, доступен из скриптов. Все методы глобального объекта FCTools можно вызывать как статические, например: FCTools.ShowMessage( “Test” );

Методы

Определение | Описание
ClassifyPage( page : IPage, [optional] callback : IProcessingCallback, [optional] detectClassesWithoutLayout : bool ) : IPageClassificationResult Классифицирует страницу и, если операция была успешной, возвращает результат классификации. Результатом классификации может быть имя класса из классификатора в типе пакетов или пустое значение.
Данный метод может использоваться в следующих случаях:
  • требуется классифицировать страницы и в соответствии с результатами классификации экспортировать их в разные папки в PDF с возможностью поиска; распознавание и наложение определений документов при этом не требуется;
  • в зависимости от результатов классификации требуется выполнить какие-либо действия с документами до распознавания (например, скорректировать ориентацию страниц).

Замечание. Если параметр detectClassesWithoutLayout не указан, его значение считается равным false. Если значение параметра равно true, то при классификации используются только классы из классификатора без учета имеющихся определений документов.
Замечание. Вы можете либо использовать имеющийся интерфейс IProcessingCallback, либо реализовать этот интерфейс самостоятельно.
IsModuleAllowedByLicense( authorId : string, moduleName : string ) : bool | Проверяет, разрешен ли указанный модуль лицензией.
LoadImage( filePath : string, [optional] pageNumber : int ) : IEditablePictureObject | Загружает из файла изображение, которое в дальнейшем можно редактировать. Если не указан параметр pageNumber, его значение считается равным 1.
NewImageSavingOptions() : IExportImageSavingOptions | Создаёт новый объект типа IExportImageSavingOptions.
PictureFromHBitmap( bitmap : HBITMAP, [optional] resolution : int ) : IEditablePictureObject Создает из объекта HBITMAP изображение с указанным разрешением, доступное для дальнейшего редактирования. Если параметр resolution не указан, разрешение определяется автоматически.
Пример кода:
System.Drawing.Bitmap bitmap = System.Drawing.Image.FromHbitmap( handle );
<do something>
IPictureObject FinalPicture = FCTools.PictureFromHBitmap( bitmap.GetHbitmap().ToInt32(), 300 );
Замечание. Так как объект HBITMAP берется во владение, для него не нужно вызывать метод CloseHandle после генерации изображения.
Rect( left : int, right : int, top : int, bottom : int ) : string | Генерирует по координатам строку, представляющую прямоугольник.
ShowMessage( text : string, [optional] isError : bool ) | Показывает сообщение пользователю. Если значение флага isError равно true, будет показано сообщение об ошибке, иначе будет показана нотификация. Если параметр isError не указан, его значение считается равным false. Если данный скрипт выполняется внутри какого-либо процесса обработки, то сообщение запишется в лог процесса обработки.

Замечание. В отличие от использования классификатора, метод ClassifyPage определяет класс страницы, но не применяет к странице результат классификации. Например, если классификатор не содержит определение документа Banking_eng, метод ClassifyPage может вернуть для страницы раздел данного определения документа.

Свойства

Имя | Тип | Права | Значение
CurrentUserSession | IUserSessionInfo | Только чтение | Возвращает информацию о текущей сессии пользователя. При маршрутизации, выполняемой после обработки документа на web-станции, текущим пользователем считается пользователь, который обрабатывал документ на этапе.
ScriptContext | IScriptDefinitionContext | Только чтение | Предоставляет доступ к объекту, внутри которого скрипт был написан. Данное свойство позволяет получить доступ к проекту независимо от того, какие параметры приходят на вход скрипту.


IDocumentExportResults

Назначение

Объект представляет множество результатов экспорта в разные цели для одного документа. Объект является коллекцией объектов IActionResult, содержащих информацию об экспорте для конкретных целей.

Свойства

Имя | Тип | Права | Значение
Succeeded | bool | Только чтение | Был ли экспорт документа успешен.
ErrorMessage | string | Только чтение | Сообщение, описывающее, почему экспорт завершился неудачно.
Document | IDocument | Только чтение | Документ, которому соответствуют данные результаты.


IField

Назначение

Поле документа. Тип поля можно установить из свойства Type. Для полей-таблиц доступны методы Rows и Cell.

Методы

Определение | Описание
AddRegion( page : IPage, rect : string ) : IFieldRegion | Добавляет полю регион с заданными координатами, где rect - строковое представление прямоугольника вида[left,top,right,bottom]. Требуются права на запись к объекту IField. Пример кода иллюстрирует копирование региона поля filed1 в поле filed2: field2.AddRegion( field1.Regions[0].Page, field1.Regions[0].SurroundingRect.ToString() ); Замечание. Метод недоступен для таблиц. Для удаления региона используется метод IFieldRegion.Delete().
Cell( columnName : string, rowNum : int ) : IField | Позволяет получить ячейку таблицы по имени столбца и номеру строки. Метод доступен только для таблиц. В скриптах правил этот метод недоступен.
CheckRules( ) | Проверяет правила для данного поля и всех дочерних полей. В правилах этот метод недоступен.
Field( Path : string) : IField | Поиск дочернего поля относительно данного. Используются относительные пути. В правилах разрешено только использование синонимов имён полей в том виде, как они заданы в настройках правил.
HasField( parameter : string) : bool | Проверяет, есть ли поле с указанным путём. Используются относительные пути. В правилах разрешено только использование синонимов имён полей в том виде, как они заданы в настройках правил.
Suggest( VARIANT newSuggest ) | Позволяет добавить подсказку к полю. Замечание. Можно добавить значение или строку. Добавленные значения записываются с 4-мя знаками после запятой. Например, при вызове метода field.Suggest( "12.90" ) подсказка будет добавлена в виде "12.90", а при вызове метода field.Suggest( 12.90 ) - в виде 12.9000.

Свойства

Имя | Тип | Права | Значение
Caption | string | Только чтение | Название поля, отображаемое на форме. Значение свойства может совпадать со значением Name.
Children | IFields | Только чтение | Дочерние элементы поля (для строк таблицы - ячейки) В скриптах правил это свойство недоступно.
FullName | string | Только чтение | Полное имя поля относительно документа. Уникально идентифицирует поле в документе. Может быть использовано для поиска полей в документе через метод Field. В скриптах правил возвращаемое значение совпадает с Name и не является уникальным.
HasRuleError | bool | Чтение/запись | Связано ли с данным полем ошибка или предупреждение правила. Замечание. В скриптах правил данное свойство определяет, отображать ли данное поле в сообщении об ошибке. Правило включает коллекцию полей, указанных в диалогом окне свойств правила. Если проверка данного правила завершится неуспешно, в редакторе документа будет отображаться сообщение об ошибке (указанное в IRuleContext.ErrorMessage) и ссылки на поля из коллекции. Указав значение свойства false, можно исключить поле из списка ссылок, связанных с ошибкой.
IsExportable | bool | Только чтение | Предназначено ли поле для экспорта (в соответствии с настройками определения документа).
IsIndexed | bool | Только чтение | Является ли поле индексируемым. Если да, то значение этого поля может быть доступно из внешних полей документов и страниц определения документа.
IsMatched | bool | Только чтение | Наложено ли поле.
IsSuspicious | bool | Только чтение | Уверенно ли распознано значение поля.
IsValid | bool | Только чтение | Проверяет, что поле не содержит ошибки формата.
IsVerified | bool | Чтение/запись | Верифицировано ли поле. В правилах можно присваивать этому полю значение true даже при отсутствии прав на запись в поле. Для того чтобы сбросить выставленный флаг, требуются права на запись. Если флаг имеет значение true, поле в редакторе документа выделено серым как уже подтвержденное. Если флаг имеет значение false, поле имеет белый цвет и его необходимо подтвердить. После верификации значение флага меняется на false. Замечание. Присваивание флагу значения false не обеспечивает попадания поля на этап Верификации данных - для этого нужно использовать свойство NeedVerification интерфейсов IField или ICharacterParams.
IsVisible | bool | Чтение/запись | Должно ли поле отражаться в форме документа (в соответствии с настройками определения документа).
Items | IFields | Только чтение | Повторения поля (для таблиц - строки таблицы).
Name | string | Только чтение | Имя поля в определении документа.
NeedVerification | bool | Чтение/запись | Требуется ли верификация самому полю (не символам, из которых оно состоит). Если флаг имеет значение true, поле в редакторе документа отображается на красном фоне как требующее верификации. Если в свойствах поля отмечена опция Отправлять на контекстную верификацию, поле попадёт на этап Верификации данных. После верификации значение флага меняется на false. Чтобы указать, требуется ли верификация для отдельных символов (не для всего поля), используйте свойство NeedVerification интерфейса ICharacterParams.
ReadOnly | bool | Только чтение | Доступно ли поле только для чтения (в соответствии с настройками определения документа). В скриптах правил этот флаг означает, что правило имеет права на запись в данное поле.
ReadOnlyInForm | bool | Чтение/запись | Доступно ли поле на форме только для чтения (в соответствии с настройками определения документа).
Regions* | IFieldRegions | Только чтение | Массив регионов поля. Перетекающие поля могут иметь несколько регионов.
Rows | IFields | Только чтение | Множество строк таблицы. Свойство недоступно для полей, не являющихся таблицами.
Symbols | ICharactersParams | Только чтение | Подробная информация о свойствах символов текста.
Text | string | Чтение/запись | Текстовое представление значения поля.
Type | TExportFieldType | Только чтение | Тип поля.
Value | VARIANT | Чтение/запись | Значение поля в виде VARIANT. Свойство возвращает объект типа Int32, если в настройках числового поля указано, что оно целое, а значение поля по модулю не превышает 2147483647. Если значение поля превышает указанное значение, то возвращает объект типа double.
[Obsolete] IsCertain | bool | Чтение/запись | Уверенно ли распознано поле (содержит ли неуверенно распознанные символы).
[Obsolete]SuspiciousSymbols* | string | Только чтение | Строка из нулей и единиц, обозначающих уверенно распознанные символы. Устаревшее свойство, оставлено для совместимости.

* - Свойство недоступно, если в свойствах лицензии отключена опция Расширенный экспорт в Xml.


IFieldRegion

Назначение

Служит для представления региона поля документа.

Методы

Определение | Описание
Delete( ) | Позволяет удалить регион поля.

Свойства

Имя | Тип | Права | Значение
PageIndex | int | Чтение/запись | Номер страницы в документе, где расположен регион
Page | IPage | Только чтение | Страница, содержащая регион
Rects | IRects | Только чтение | Массив прямоугольников, из которых состоит регион
SurroundingRect | IRect | Только чтение | Прямоугольник, описывающий весь регион
Picture | IPictureObject | Только чтение | Картинка, соответствующая региону
IsMatched | bool | Только чтение | Наложен ли данный регион
Field | IField | Только чтение | Поле документа, соответствующее региону. Может быть "0".

Замечание. В скрипте пользовательского распознавания значение свойства Field всегда "0", так как на момент распознавания поле еще не существует.


IFieldRegions

Назначение

Коллекция объектов IFieldRegion.


IFields

Назначение

Коллекция объектов IField.

Методы

Определение | Описание
AddNew( insertAt : int ) | Добавляет новое вхождение повторяющегося поля. Аргумент insertAt указывает позицию нового элемента в коллекции. Метод позволяет создавать строки для табличного блока без региона. В скриптах правил этот метод недоступен. Пример кода: Document.Field( "Page 1\\Address" ).Items.AddNew( 0 );
Delete( what : Object ) | Удаляет вхождение поля или строку таблицы. В качестве аргумента what можно указать объект в коллекции, который нужно удалить, либо его индекс. В скриптах правил этот метод недоступен.


IMatchingInfo

Назначение

Объект для хранения параметров наложения разделов и определений документов на страницу.

Свойства

Имя | Тип | Права | Значение
DefinitionsList | string | Чтение/запись | Список разделов или определений документов, которые нужно накладывать на страницу, разделённых точкой с запятой. Имена определений документов или имена разделов в них могут быть заданы в виде <DefinitionName> или <DefinitionName>\<SectionName> соответственно. Допустимо использовать только существующие разделы и определения документов. Например, указать первый раздел из документа Banking_eng можно следующим образом: Banking_eng\Page 1.
ForceMatch | bool | Чтение/запись | Нужно ли принудительно накладывать разделы. Значение этого флага может быть "true", только если задано не более одного раздела. Если список разделов пустой и выставлен этот флаг, то страница будет помечена как страница-приложение без распознавания.
MaxPagesToMatch | int | Чтение/запись | Определяет максимальное количество страниц, на которые разрешено накладывать многостраничные секции. Значение 0 означает отсутствие ограничений.
NeedRecognition | bool | Чтение/запись | Нужно ли распознавание полей внутри разделов. Если выставлено значение "false", то после наложения поля в документе распознаваться не будут.

Замечание. Чтобы распознать страницу со всеми разделами, не изменяйте свойство DefinitionsList. Если задан пустой список DefinitionsList и не выставлен флаг ForceMatch, то страница не будет распознана, а в лог запишется сообщение "No Document Definitions to match". Если флаг ForceMatch выставлен, то страница будет помечена как страница-приложение.


Внутренние имена языков распознавания

Назначение

Внутренние имена языков распознавания используются в свойстве RecognitionLanguages объекта IExportImageSavingOptions.

Соответствие языков распознавания и их внутренних имен:

Abkhaz->Abkhaz
Adyghe->Adyghe
Afrikaans->Afrikaans
Agul->Agul
Albanian->Albanian
Altaic->Altaic
Arabic (Saudi Arabia)->Arabic
Armenian (Eastern)->ArmenianEastern
Armenian (Grabar)->ArmenianGrabar
Armenian (Western)->ArmenianWestern
Avar->Awar
Aymara->Aymara
Azerbaijani (Cyrillic)->AzeriCyrillic
Azerbaijani (Latin)->AzeriLatin
Bashkir->Bashkir
Basque->Basque
Bemba->Bemba
Blackfoot->Blackfoot
Portuguese (Brazilian)->PortugueseBrazilian
Breton->Breton
Bugotu->Bugotu
Bulgarian->Bulgarian
Buryat->Buryat
Belarusian->Belarusian
Catalan->Catalan
Chamorro->Chamorro
Chechen->Chechen
Chinese Simplified->ChinesePRC
Chinese Traditional->ChineseTaiwan
Chukchee->Chukcha
Chuvash->Chuvash
Corsican->Corsican
Crimean Tatar->CrimeanTatar
Croatian->Croatian
Crow->Crow
Czech->Czech
Danish->Danish
Dargwa->Dargwa
Dungan->Dungan
Dutch->Dutch
English->English
Eskimo (Cyrillic)->EskimoCyrillic
Eskimo (Latin)->EskimoLatin
Esperanto->Esperanto
Estonian->Estonian
Even->Even
Evenki->Evenki
Faroese->Faeroese
Fijian->Fijian
Finnish->Finnish
Dutch (Belgian)->DutchBelgian
French->French
Frisian->Frisian
Friulian->Friulian
Scottish Gaelic->GaelicScottish
Gagauz->Gagauz
Galician->Galician
Ganda->Ganda
German->German
German (new spelling)->GermanNewSpelling
German (Luxembourg)->GermanLuxembourg
Greek->Greek
Guarani->Guarani
Hani->Hani
Hausa->Hausa
Hawaiian->Hawaiian
Hebrew->Hebrew
Hungarian->Hungarian
Icelandic->Icelandic
Ido->Ido
Indonesian->Indonesian
Ingush->Ingush
Interlingua->Interlingua
Irish->Irish
Italian->Italian
Japanese->Japanese
Kabardian->Kabardian
Kalmyk->Kalmyk
Karachay-balkar->KarachayBalkar
Karakalpak->Karakalpak
Kasub->Kasub
Kawa->Kawa
Kazakh->Kazakh
Khakass->Khakas
Khanty->Khanty
Kikuyu->Kikuyu
Kirghiz ->Kirgiz
Kongo->Kongo
Korean->Korean
Koryak->Koryak
Kpelle->Kpelle
Kumyk->Kumyk
Kurdish->Kurdish
Lak->Lak
Sami (Lappish)->Lappish
Latin->Latin
Latvian->Latvian
Latvian Gothic->LatvianGothic
Lezgi->Lezgin
Lithuanian->Lithuanian
Luba->Luba
Macedonian->Macedonian
Malagasy->Malagasy
Malay (Malaysian)->Malay
Malinke->Malinke
Maltese->Maltese
Mansi->Mansi
Maori->Maori
Mari->Mari
Maya->Maya
Miao->Miao
Minangkabau->Minankabaw
Mohawk->Mohawk
Moldavian->RomanianMoldavia
Mongol->Mongol
Mordvin->Mordvin
Nahuatl->Nahuatl
Nenets->Nenets
Nivkh->Nivkh
Nogay->Nogay
Norwegian (Bokmal)->NorwegianBokmal
Norwegian (Nynorsk)->NorwegianNynorsk
Nyanja->Nyanja
Occidental->Occidental
Ojibway->Ojibway
Old English->OldEnglish
Old French->OldFrench
Old German->OldGerman
Old Italian->OldItalian
Old Spanish->OldSpanish
Ossetian->Ossetic
Papiamento->Papiamento
Tok Pisin->PidginEnglish
Pinyin->Pinyin
Polish->Polish
Portuguese->PortugueseStandard
Occitan->Provencal
Quechua->Quechua
Rhaeto-Romanic->RhaetoRomanic
Romanian->Romanian
Romany->Romany
Rwanda->Ruanda
Rundi->Rundi
Russian (Old Spelling)->RussianOldSpelling
Russian->Russian
Samoan->Samoan
Selkup->Selkup
Serbian (Cyrillic)->SerbianCyrillic
Serbian (Latin)->SerbianLatin
Shona->Shona
Dakota->Sioux
Slovak->Slovak
Slovenian->Slovenian
Somali->Somali
Sorbian->Sorbian
Sotho->Sotho
Spanish->Spanish
Sunda->Sunda
Swahili->Swahili
Swazi->Swazi
Swedish->Swedish
Tabasaran->Tabassaran
Tagalog->Tagalog
Tahitian->Tahitian
Tajik->Tajik
Tatar->Tatar
Thai->Thai
Jingpo->Tinpo
Tongan->Tongan
Tswana->Tswana
Tun->Tun
Turkish->Turkish
Turkmen->Turkmen
Tuvinian->Tuvin
Udmurt->Udmurt
Uighur (Cyrillic)->UighurCyrillic
Uighur (Latin)->UighurLatin
Ukrainian->Ukrainian
Uzbek (Cyrillic)->UzbekCyrillic
Uzbek (Latin)->UzbekLatin
Cebuano->Visayan
Vietnamese->Vietnamese
Welsh->Welsh
Wolof->Wolof
Xhosa->Xhosa
Yakut->Yakut
Yiddish->Yiddish
Zapotec->Zapotec
Zulu->Zulu
Korean (Hangul)->KoreanHangul
Russian and English->Mixed
Norwegian->Norwegian
Chinese Simplified and English->ChinesePRC+English
Chinese Traditional and English->ChineseTaiwan+English
Japanese and English->Japanese+English


IPage

Назначение

Служит для представления страницы.

Методы

Определение | Описание
MarkAsAnnex() | Позволяет пометить страницу как приложение, не требующее распознавания.
ReplaceImage( newPicture : IPictureObject ) | Заменяет изображение страницы на новое. Новое изображение может быть загружено из файла с помощью метода FCTools.LoadImage, создано из имеющегося в памяти изображения (например, .NET System.Drawing.Image) с помощью метода FCTools.PictureFromHBitmap либо получено путем редактирования другого объекта IPictureObject.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Позволяет сохранить изображение страницы в соответствии с настройками. Если опции сохранения не заданы, изображение сохраняется как *.tif. Является внутренним* полем.

Свойства

Имя | Тип | Права | Значение
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений
Document | IDocument | Только чтение | Документ, содержащий страницу
ExcludedFromDocumentImage | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Используется при экспорте изображения документа. Означает, что изображение данной страницы не нужно экспортировать при экспорте всего документа. Является внутренним* полем.
Id | string | Только чтение | Идентификатор страницы
ImageSource | string | Только чтение | Для файлов - полный путь к файлу. Для других источников - то, что было указано в ImageSourceDetails.
ImageSourceFileSubPath | string | Только чтение | Путь исходного изображения относительно корневого каталога HotFolder или папки, из которой изображения были импортированы.
ImageSourcePageNumber | int | Только чтение | Номер исходной страницы в файле
ImageSourceType | string | Только чтение | Строка "File", "Scanner" или "Custom" в зависимости от типа источника
Index | int | Только чтение | Индекс страницы в документе
IsAnalyzed | bool | Только чтение | Проанализирована ли страница.
Picture | IPictureObject | Только чтение | Изображение страницы. Является внутренним* полем.
Rect | IRect | Только чтение | Прямоугольник страницы. Является внутренним* полем.
SectionName | string | Только чтение | Имя раздела документа
SourceImageRotation int Только чтение Угол (в градусах), на который было повернуто исходное изображение. Возможные значения: 0, 90, 180, 270. Для страниц, повернутых против часовой стрелки, возвращается значение поворота по часовой стрелке (например, если изображение было повернуто на 90˚ против часовой стрелки, будет возвращено 270).
Свойство доступно, только если открыт документ, содержащий страницу.
Является внутренним* полем.
Возвращает угол поворота для изображений:
  1. импортированных из горячей папки;
  2. загруженных на Станции настройки проекта или на полной Станции верификации;
  3. повернутых при распознавании;
  4. повернутых вручную на полных и удаленных станциях;
  5. повернутых вручную на Web-станции Верификации или при верификации на Web-станции Ввода документов.
Не учитывает значение поворота для изображений:
  1. повернутых с помощью скрипта;
  2. повернутых на (Web-) станции Сканирования или при сканировании на Web-станции Ввода документов;
  3. повернутых автоматически при исправлении перекоса.
[Obsolete] TemplateName | string | Только чтение | Имя раздела документа (то же, что и SectionName). Свойство оставлено для совместимости.

* - Внутреннее поле требует загрузки объекта в память.


IPages

Назначение

Коллекция объектов IPage.


IPictureObject

Назначение

Представление изображения страницы или региона.

Объект реализует интерфейс IPicture и предоставляет доступ к некоторым его свойствам через интерфейс IDispatch.

Подробнее об интерфейсе IPicture вы можете прочитать в соответствующей статье на MSDN.

Методы

Определение | Описание
AnalyzePageObjects( [optional] reserved: Object ) : IPictureObjectsInfo | Определяет объекты на странице и возвращает параметры страницы с точки зрения системы распознавания программы. Метод работает с небольшой задержкой.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Позволяет сохранить изображение. Если опции сохранения не указаны, изображение сохраняется как *.tif.
CreateEditableCopy() : IEditablePictureObject | Создает копию данного изображения, которую можно редактировать.
DetectPageOrientation( [optional] language: string ) : int | Определяет ориентацию страницы по тексту на ней. В качестве входного параметра передается внутреннее имя языка. Если язык не указан, используется язык текущей локали машины. Возвращает угол (в градусах), на который нужно повернуть страницу. Может вернуть следующие значения: 0, 90, 180 и 270.

Свойства

Имя | Тип | Права | Значение
Handle | OLE_HANDLE | Только чтение | Handle объекта Windows GDI. Это поле может использоваться для получения в .Net объекта картинки методом System.Drawing.Image.FromHbitmap.
hPal | OLE_HANDLE | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | GDI Handle палитры изображения. Это поле может использоваться в качестве второго параметра при вызове метода System.Drawing.Image.FromHbitmap.
Type | SHORT | Только чтение | Тип изображения
Width | int | Только чтение | Ширина изображения в точках
Height | int | Только чтение | Высота изображения в точках
IsBlackWhite | bool | Только чтение | Является ли изображение черно-белым
XResolution | int | Только чтение | Горизонтальное разрешение изображения
YResolution | int | Только чтение | Вертикальное разрешение изображения


IPictureObjectsInfo

Назначение

Объект, хранящий результаты выделения объектов на изображении.

Свойства

Имя | Тип | Права | Значение
BarcodesCount | int | Только чтение | Число штрих-кодов, найденных на изображении (двумерные штрих-коды не учитываются).
BlacknessPercentage | int | Только чтение | Процент чёрного цвета на страницу.
BlackSquaresCount | int | Только чтение | Количество найденных чёрных квадратов.
TextObjectsCount | int | Только чтение | Количество текстовых объектов.


IPrincipal

Назначение

Представление пользователя или группы в скриптах.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя пользователя или группыp
Id | int | Только чтение | Уникальный идентификатор
Type | TPrincipalType | Только чтение | Тип принципала


IPrincipals

Назначение

Общая коллекция пользователей и групп пользователей (коллекция объектов IPrincipal).


IProcessingCallback

Назначение

Объект для передачи информации о ходе процесса обработки.

Методы

Определение | Описание
ReportMessage( message : string ) | Записывает в лог информационное сообщение.
ReportWarning( warning : string ) | Записывает в лог предупреждение.
ReportError( error : string ) | Записывает в лог сообщение об ошибке. Операция, содержащая сообщения об ошибке, считается неуспешной.

Свойства

Имя | Тип | Права | Значение
ShouldStop | bool | Только чтение | Проверяет, не отменена ли задача (нажал ли пользователь кнопку Отмена).


IProject

Назначение

Представление проекта в скриптах.

Методы

Определение | Описание
GetDocumentDefinitions( [optional] reserved :object ) : IDocumentDefinitionInfoArray | Возвращает информацию о включённых шаблонах в проекте. Параметр reserved должен быть null или не указан.

Свойства

Имя | Тип | Права | Значение
EnvironmentVariables | IProperties | Только чтение | Возвращает массив переменных окружения проекта.
ExportRootPath | string | Только чтение | Корневой путь для экспорта в том виде, в котором он указан в настройках проекта. Может быть пустой строкой.
Name | string | Только чтение | Имя проекта.
Principals | IPrincipals | Только чтение | Массив пользователей или групп.


IProperties

Назначение

Коллекция объектов типа IProperty.

Методы

Определение | Описание
Get (name : string) : string | Позволяет получить значение свойства по имени
Set (name : string, value : string) | Устанавливает значение именованного свойства. Создаёт свойство, если его не было. Замечание. Как изменить состояние документа, смотрите описание интерфейса ITaskWindow.
Has (name : string) : bool | Проверяет, есть ли во множестве свойство с заданным именем.
Delete (name : string) | Удаляет свойство с заданным именем.


IProperty

Назначение

Именованный параметр документа или пакета.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя свойства
Value | string | Только чтение | Значение свойства


IPropertyModificationInfo

Назначение

Информация об изменении свойства документа или пакета.

Выставляемое значение свойства можно подправить.

Свойства

Имя | Тип | Права | Значение
PropertyType | TPropertyType | Только чтение | Тип изменяемого свойства
NewValue | string | Чтение/запись | Новое значение свойства. В скрипте можно выставлять другое новое значение, например, нормализовать его.
Name | string | Только чтение | Имя именованного параметра (только для типа PT_NamedPropertyValue)


IRecordset

Служит для представления результата поиска набора записей в наборе данных.

Методы

Определение | Описание
GetRecord ( index : int ) : IDataSetRecord | Возвращает запись по номеру индекса. Полученный IDataSetRecord доступен только на чтение.

Свойства

Имя | Тип | Права | Значение
Count | Int | Только чтение | Количество записей.


IRect

Назначение

Прямоугольник.

Методы

Определение | Описание
ToString() : string | Представление прямоугольника в виде строки вида "[left,top,right,bottom]".

Свойства

Имя | Тип | Права | Значение
Left | int | Только чтение | Левая координата
Right | int | Только чтение | Правая координата
Top | int | Только чтение | Верхняя координата
Bottom | int | Только чтение | Нижняя координата


IRects

Назначение

Коллекция объектов IRect.


IRoutingRuleResult

Назначение

Результат работы скрипта маршрутизации.

Свойства

Имя | Тип | Права | Значение
CheckSucceeded | bool | Чтение/запись | Была ли проверка правила успешной.
DocumentComment | string | Чтение/запись | Комментарий, который будет добавлен к документу в случае успешной маршрутизации.
PrincipalId | int | Чтение/запись | Идентификатор пользователя или группы, который будет присвоен документу в случае успешной маршрутизации. Если в скрипте маршрутизации документ не назначен ни одному пользователю, идентификатор имеет значение "0". Ноль означает, что задачу с таким документом может взять в обработку любой пользователь. Смотрите описание параметра IPrincipal.
Priority | TProcessingPriority | Чтение/запись | Приоритет документа, который будет выставлен, если в результате работы скрипта маршрутизации будет возвращено значение "true".
ProhibitedUserId | int | Чтение/запись | Позволяет указать или узнать идентификатор пользователя, которому не разрешена обработка задания на следующем этапе. По умолчанию значение равно "0", то есть задание может быть обработано любым пользователем. Замечание. Свойство применяется только к заданиям, которые отправляются на этап автоматически в соответствии со схемой маршрутизации. Если задание отправлено на этап вручную, значение свойства игнорируется.


IRuleContext

Назначение

Контекстный объект правил. Представляет тот объект, на уровне которого создано правило.

Реализует интерфейс IField (предоставляя доступ к контекстному полю правила), а также имеет дополнительные методы.

Методы

Определение | Описание
DataSet ( dataSetName : string ) : IDataSet | Предоставляет доступ к кэшированному набору данных. Полученный IDataSet доступен только на чтение.

Свойства

Имя | Тип | Права | Значение
CheckSucceeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли проверка правила успешной
Document | IDocument | Только чтение | Доступ к документу
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке правила
Fields | IFields | Только чтение | Коллекция полей правила. Задаётся в настройках правила.
FocusedField | IField | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Поле, на которое требуется установить фокус при нажатии на ошибку правила (поле, вызвавшее ошибку правила)
FocusRect | IRect | Только чтение | Прямоугольник в экранных координатах, к которому относится выполняемое действие (прямоугольник окна). Применяется только в "пользовательском скрипте".
ParentWindow | int | Только чтение | Дескриптор родительского окна. Применяется только в "пользовательском скрипте".
[Obsolete] FieldsObject | IFR65Fields | Только чтение | Для поддержки скриптов, созданных в FormReader 6.5. Устаревшее свойство, оставлено для совместимости.
[Obsolete] ErrorObjectObject | IFR65Errors | Только чтение | Для поддержки скриптов, созданных в FormReader 6.5. Устаревшее свойство, оставлено для совместимости.


IRuleError

Назначение

Служит для представления ошибки правила, формата или объединения.

Методы

Определение | Описание
GetFields() : IFields | Возвращает поля, связанные с данной ошибкой поля.

Свойства

Имя | Тип | Права | Значение
Message | string | Только чтение | Текст сообщения об ошибке.
IsWarning | bool | Только чтение | Проверяет, является ли сообщение предупреждением.
Type | TRuleErrorType | Только чтение | Тип ошибки.
RuleName | string | Только чтение | Имя правила, вызвашего ошибку. Для ошибок формата и объединения возвращает пустую строку.


IRuleErrors

Назначение

Коллекция объектов IRuleError.


IScriptBinaryAttributes

Назначение

Множество булевых флагов.

Методы

Определение | Описание
Has( TStateType : int ) : bool | Проверяет, выставлен ли запрошенный флаг


IScriptDefinitionContext

Назначение

Предоставляет доступ к некоторым свойствам объектов, которые могут быть использованы в скриптах.

Свойства

Имя | Тип | Права | Значение
Project | IProject | Только чтение | Предоставляет доступ к информации о проекте.


ISectionDefinitionInfo

Назначение

Описывает секцию в Определении документа.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Название секции.
IsFlexible | bool | Только чтение | Гибкая ли секция.


ISectionDefinitionInfoArray

Назначение

Коллекция объектов типа ISectionDefinitionInfo.


IMatchedSectionInfo

Назначение

Содержит детальную информацию о наложенном на страницу разделе Определения документа.

Определение | Описание
FlexibleAlternativeName() : string | Возвращает имя гибкого описания. Метод доступен только для документов, которые уже были открыты ранее.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя раздела.
IsFlexible | bool | Только чтение | Является ли раздел гибким.
FlexibleInstanceId | int | Только чтение | Индекс гибкого раздела. Множество страниц с одинаковым индексом гибкого раздела образуют один раздел документа. Поле имеет смысл только для гибких разделов. Если для двух страниц с одним и тем же определением гибкого раздела значение параметра FlexibleInstanceId различно, это означает, что страницы принадлежат разным разделам документа.
SectionDefinitionPageNumber | int | Только чтение | Номер страницы в определении жёсткого раздела, наложенного на данную страницу. Поле имеет смысл только для жестких разделов.
DocumentDefinition | IDocumentDefinitionInfo | Только чтение | Информация об определении документа, содержащем раздел.


IStageInfo

Назначение

Информация об этапе обработке документа.

Свойства

Имя | Тип | Права | Значение
StageId | int | Только чтение | Идентификатор текущего этапа обработки
StageName | int | Только чтение | Имя текущего этапа обработки
TaskId | string | Только чтение | Идентификатор задачи. При отсутствии задачи идентификатор равен нулю.
PrincipalId | string | Только чтение | Идентификатор пользователя или группы, который может получать задачу с данным документов. "0" означает, что данная задача не назначена конкретному пользователю или группе. Смотрите описание параметра IPrincipal.


IUserSessionInfo

Назначение

Информация о сессии пользователя, работающего на станции обработки.

При верификации возвращается информация о сессии пользователя, который выполняет верификацию (в т. ч. удаленно).

Properties

Name | Type | Access | Description
PrincipalId | int | Только чтение | Идентификатор пользователя на сервере приложений. Для ABBYY FlexiCapture версии Standalone возвращает значение null.
RoleId | int | Только чтение | Идентификатор роли пользователя. Для ABBYY FlexiCapture версии Standalone возвращает значение null.
SessionId | int | Только чтение | Идентификатор сессии подключения к серверу приложений. Для ABBYY FlexiCapture версии Standalone возвращает значение null.
UserName | string | Только чтение | Имя пользователя. При работе без сервера приложений возвращает имя пользователя, под учетной записью которого запущен процесс. При работе с сервером приложений - имя пользователя, под учетной записью которого был выполнен вход на сервер приложений.


IValue

Назначение

Служит для представления значения поля.

Свойства

Имя | Тип | Права | Значение
Text | string | Чтение/запись | Текстовое представление значения
ErrorMessage | string | Чтение/запись | Сообщение об ошибке форматирования значения
Symbols | ICharactersParams | Только чтение | Детализированная информация о свойствах символов
[Obsolete] SuspiciousSymbols | string | Чтение/запись | Строка из нулей и единиц, описывающая, какие символы являются подозрительными для распознавателя. Устаревшее свойство, оставлено для совместимости.


IVARIANTArray

Назначение

Представляет коллекцию элементов типа Variant.


Перемещение страниц

Замечание. Перемещение страниц может производиться в том числе в момент сборки.

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-то манипуляции с новым документом на основе исходных документов. Например, сохранить объединенные регистрационные параметры.

Если один документ полностью вливается в другой, то его страницы в массиве Pages идут подряд и в том же порядке, в котором они идут в документе.

Замечание. После объединения страниц форма целевого документа может измениться.

Когда вызывается

Вызывается непосредственно перед перемещением страниц из документа в документ.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Внутренние* поля документов и страниц пакета недоступны | Пакет
TargetDocument | IDocument | Полные права | Документ, в который перемещаются страницы
InsertionPosition | int | Только чтение | Позиция в документе, куда перемещаются страницы
Pages | IPages | Только чтение | Массив перемещаемых страниц

* - Внутреннее поле требует загрузки объекта в память.


Объекты

Этот раздел содержит описание используемых в скриптах объектов, их методов и свойств.

Замечание. Некоторые свойства и методы являются устаревшими и оставлены только для совместимости со скриптами, созданными в более ранних версиях. Названия таких свойств и методов начинаются со слова [Obsolete] в квадратных скобках.

IActionResult
IAssemblingError
IAssemblingErrors
IBatch
IBatchCheckResults
IBoxedBoolean
ICharacterParams
ICharactersParams
ICheckmarkGroupValue
ICheckmarkValue
IDocument
IDocumentDefinitionInfo
IDocumentDefinitionInfoArray
IDocumentExportResults
IDocuments
IDocumentsExportResults
IEditablePictureObject
IExportFieldsToRedact
IExportImageSavingOptions
IField
IFieldRegion
IFieldRegions
IFields
IFlexiCaptureTools
IMatchedSectionInfo
IMatchingInfo
IPage
IPageClassificationResult
IPages
IPictureObject
IPictureObjectsInfo
IPrincipal
IPrincipals
IProcessingCallback
IProject
IProperties
IProperty
IPropertyModificationInfo
IRect
IRects
IRuleContext
IRuleError
IRuleErrors
IScriptBinaryAttributes
IScriptDefinitionContext
ISectionDefinitionInfo
ISectionDefinitionInfoArray
IStageInfo
IUserAttachment
IUserAttachments
IValue
IVARIANTArray
TAssemlingErrorType
TExportFieldType
TExportType
TPageClassificationType
TPrincipalType
TProcessingPriority
TPropertyType
TRuleErrorType
TStateType


Скрипт после экспорта

В качестве входного параметра скрипт получает результаты экспорта.

Когда вызывается

Вызывается после завершения задания экспорта. Если для этапа экспорта отмечена опция Обрабатывать пакеты целиком, задание будет включать все документы пакета. Если опция не отмечена, количество документов в задании может варьироваться от одного документа до всех документов пакета. Скрипт вызывается независимо от того, успешно ли прошел экспорт. В этом основное отличие данного скрипта от события "Изменение состояния документа".

Если в текущей сессии экспорт документ не экспортировался в какую-либо цель, так как экспорт в эту цель прошёл ранее, то для соответствующих результатов параметр Applied будет иметь значение false.

Параметры

Name | Type | Access | Description
ExportResults | IDocumentsExportResults | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Результаты экспорта во все цели для всех документов
Processing | IProcesingCallback | Полные права | Объект для хранения информации о процессе работы

* - Внутреннее поле требует загрузки объекта в память.


Скрипт сборки документа

Назначение

В этом скрипте пользователю передаётся массив документов, и пользователь должен определить, можно ли эти документы объединить в один.

Для этого пользователь генерирует ошибки сборки, которые будут в результирующем документе. Сборка осуществляется следующим образом: два документа объединятся в один, если в результирующем документе число ошибок сборки не больше, чем в любом из исходных.

Скрипт настраивается на закладке Сборка свойств определения документа. Чтобы открыть редактор скрипта, нажмите кнопку Правка скрипта сборки… под опцией Использовать пользовательские правила сборки.

Скрипт выполняется автоматически после распознавания, либо может быть вызван вручную для обновления сборки (для этого выберите команду Сервис > Обновить сборку). В первом случае в скрипт попадут также ошибки сборки, сгенерированные стандартной проверкой.

Параметры

Имя | Тип | Права | Значение
Documents | IDocuments | Только чтение | Множество документов, страницы которых объединяются
AssemblingErrors | IAssemblingErrors | Полные права | Результирующие ошибки сборки

Замечание. Для оптимизации работы сборки желательно не обращаться к внутренним полям документов, так как это приводит к полной загрузке документа и может стать причиной замедления работы. Если требуется обращение к полям документа, то по возможности следует пользоваться индексными полями.

Замечание. Ошибки сборки, содержащиеся в параметре скрипта AssemblingErrors, различаются в зависимости от того, каким из двух возможных способов был получен параметр:

  1. AssemblingErrors может передавать в скрипт в качестве одного из параметров. В этом случае он будет содержать ошибки сборки текущей проверки.
  2. В скрипт в качестве параметра также передаётся коллекция документов, для которых вызывается скрипт сборки. У каждого документа есть свои ошибки сборки, которые можно получить так: document.AssemblingErrors. В этом случае параметр AssemblingErrors будет содержать ошибки сборки последней проверки для данного документа.

Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для правил. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Правила….

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Создание определений для многостраничных документов.


Скрипт автозамены

Назначение

Позволяет преобразовывать строки, содержащиеся в полях, и осуществлять проверки формата, не зависящие от контекста.

Описывается на закладке Тип данных диалога свойств поля.

Параметры

Имя | Тип | Права | Значение
Value | IValue | Чтение/запись | Значение поля

Замечание. Если включена опция Производить замену только один раз после распознавания, то сообщение об ошибке формата, указанное в IValue.ErrorMessage, не показывается, так как такую ошибку нельзя будет исправить.
Если данная опция не отмечена, скрипт может выполняться несколько раз даже в пределах одного этапа.

Замечание. Скрипт вызывается при подтверждении поля на станции Верификации Данных. При подтверждении поля на Web-станции Верификации Данных вызов скрипта не происходит.

Если в скрипте используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Обработка введенного значения.


Пользовательский скрипт

Назначение

Действия, описанные в скрипте, выполняются при нажатии на кнопку в процессе верификации поля или в окне редактора документа.

Скрипт задается на закладке Пользовательский скрипт в диалоговом окне свойств поля.

Параметры

Имя | Тип | Права | Значение
Context | IRuleContext | В соответствии с настройками правила | Контекст правила

Если в скрипте используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Пользовательский скрипт.


Скрипт экспорта

Назначение

Позволяет настраивать экспорт.

Скрипт экспорта добавляется на закладке Экспорт свойств определения документа.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только чтение | Экспортируемый документ
Processing | IProcessingCallback | Только чтение | Объект для записи информации в лог

Замечание. Информация о результатах экспорта должна записываться в поле Document.Action.

Процедуры, которые вы хотите использовать в нескольких скриптах экспорта, следует записать в глобальный модуль экспорта. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для экспорта. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Экспорт….

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

Подробнее о настройке скрипта экспорта см. Экспорт, описанный с помощью скрипта.


Скрипт пользовательского распознавания

С помощью этого скрипта вы можете определить свой алгоритм распознавания (или инициализации) полей, имеющих регионы.

Скрипт распознавания задается на закладке Распознавание диалога свойств поля.

Вызов скрипта происходит в момент инициализации значения поля из результатов распознавателя. На вход скрипту передаётся распознаваемая область изображения. Форма документа в этот момент не проинициализирована, потому доступ к полям документа запрещён (при этом регистрационные и другие параметры доступны).

С помощью данного скрипта вы можете указать, какие символы являются подозрительными и требуют верификации (свойства IsSuspicious и NeedVerification).

Параметры

Имя | Тип | Права | Значение
Result IValue / ICheckmarkValue / ICheckmarkGroupValue Полные права. Доступ к параметру CharacterParams.NeedVerification запрещен. Флаг CharacterParams.IsSuspicious доступен на чтение/запись. Результирующее распознанное значение. В зависимости от типа поля скрипт будет получать параметры следующих типов:
  • IValue - для полей на основе текста
  • ICheckmarkValue - для меток
  • ICheckmarkGroupValue - для групп меток
FieldRegion | IFieldRegion | Только чтение. Внутренние* поля документов и страниц пакета недоступны. (Права применяются также к родительским объектам.) | Регион, который нужно распознать

Если в скрипте используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

* - Внутреннее поле требует загрузки объекта в память.

См. также Свойства распознавания текстового поля.


Скрипт правила

Назначение

Правила на основе скриптов (ScriptRule) позволяют создавать произвольно сложные алгоритмы проверки и нормализации документа.

Скрипт правила настраивается на закладке Правила свойств определения документа.

Параметры

Имя | Тип | Права | Значение
Context | IRuleContext | В соответствии с настройками правила | Контекст правила

Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для правил. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Правила….

Существует возможность получить доступ к записям кэшированного набора данных из скриптовых правил, например, для ручного создания правил проверки значений. Для этого выполните следующие действия:

  1. Произведите подключение к набору данных с помощью метода IRuleContext.DataSet.
  2. Создайте запрос с помощью метода IDataSet.CreateQuery.
  3. Добавьте одно или несколько условий методом IDataSetQuery.AddValue.
  4. Чтобы получить данные, соответствующие запросу, используйте метод IDataSet.GetRecords. Для получения количества записей, соответствующих запросу, в числовом значении используйте метод IDataSet.GetRecordsCount.
  5. Получить отдельные записи по их номеру можно с помощью метода IRecordset.GetRecord.

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

Также о настройке скрипта правила см. Правило, заданное с помощью скрипта.


Объектная модель

Ниже описаны особенности используемой объектной модели.

Работа с коллекциями

Все коллекции в используемой объектной модели поддерживают следующие методы:

Название | Тип | Доступ | Описание
Count | int | Read only | Число элементов коллекции
Item( index : int ) | ItemInterface | Read only | Получение элемента коллекции с заданным индексом. Нумерация начинается с нуля.

Замечание. К методам коллекции можно обращаться без метода Item, используя вместо этого круглые или квадратные скобки в зависимости от выбранного языка скрипта. В языках JScript, VBScript и Visual Basic.Net используются круглые скобки, в языке C#.Net допустимо использование только квадратных скобок, язык JScript.Net допускает использование как круглых, так и квадратных скобок.

Например, Items( 1 ).Text = "Hello" или Items[ 1 ].Text = "Hello"

Все коллекции могут использоваться в конструкциях типа for each.

Работа с повторяющимися полями и таблицами

Все поля документа, кроме таблиц, могут быть повторяющимися.

В структуре документа повторяющие поля представлены специальным полем-прототипом, имеющим ненулевую коллекцию Items.

Поле-прототип не имеет дочерних элементов и у него нет значения. Оно служит только для хранения множества повторений этого поля. Дочерние поля и/или значение поля присущи лишь повторениям поля, доступным через метод Items объекта IField.

Таблицы всегда имеют коллекцию Rows ( Items является ее синонимом). В этой коллекции содержатся строки таблицы, ячейки которых можно получить через метод Children строк объекта IField.

Формирование путей к полям

Методы Field, HasField и IndexedItemValue объекта IDocument используют в качестве параметра пути к полям на форме. Эти пути строятся по следующему принципу (в форме Бэкуса-Наура):

<Путь> ::= <Компонент_пути> | <Путь> "\" <Компонент_пути>

<Компонент_пути > ::= <Имя_поля> | <Имя_поля> "["<Номер повторения поля>"]"

Где Имя_поля – имена полей документов, как они заданы в определении документа, а Номер_повторения_поля – номер повторения повторяющегося поля (для таблиц это номер строки), начиная с нуля.

Путь может быть полным или относительным. Полные пути строятся, начиная с имени раздела документа, относительные – начиная с имени дочернего элемента в группе.

Например, обращение к третьей строке колонки "Total" в таблице "Table", расположенной в разделе "Section", записывается следующим образом:

"Section\Table[2]\Total"

Метод FullName объекта IField позволяет построить такое полное имя.


Использование скриптов в ABBYY FlexiCapture

В данном разделе описано использование скриптов для настройки этапа обработки и для настройки интерфейса станций в ABBYY FlexiCapture.

Поддерживаемые языки

ABBYY FlexiCapture поддерживает написание скриптов на следующих языках: C#.Net, VisualBasic.Net, JScript.Net, JScript®, JScript.Compact и VBScript.

Особенности .Net скриптов

Особенности использования

В языке VBScript нулевой параметр передается с ключевым словом "Me", в языке JScript для передачи нулевого параметра используется ключевое слово "this". В .Net скриптах нулевой параметр передается как обычный параметр.

Для каждого типа скрипта заведомо известны права на все параметры скрипта. Эти права определяют подмножество методов, доступных из скриптов. При обращении к методам объектов права на возвращаемые объекты всегда наследуются из исходного объекта, за некоторыми исключениями, описанными в комментарии к соответствующим методам.

Замечание. Объекты скрипта не должны использоваться после завершения скрипта, так как в этом случае поведение объекта становится неопределенным.

Замечание. Для отладки скриптов, написанных в редакторе скрипта в ABBYY FlexiCapture, можно использовать метод MessageBox.

Пользовательские функции

Редактор скрипта позволяет создавать собственные функции и процедуры и вызывать их в дальнейшем из кода скрипта.

Пользовательские функции и процедуры следует записать в глобальный модуль. Этот модуль доступен из редактора скрипта, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать доступный глобальный модуль: Модуль для правил, Модуль для экспорта, Events или NonInteractiveProcessor.

Все функции внутри одного модуля должны быть написаны на одном языке. Основной код скрипта может быть написан на языке, отличном от используемого в соответствующем глобальном модуле.

Из скриптовых языков JScript®, JScript.Compact и VBScript можно вызвать глобальную функцию, написанную на каком-либо из этих языков. Например, можно из кода правила на VBScript вызывать функцию из глобального модуля, написанного на JScript.

Из скриптов, написанных на языках .Net, можно вызывать глобальные функции, также написанные на языках .Net (C#.Net, VisualBasic.Net или JScript.Net).

Для обращения к функциям глобальных модулей нужно использовать префиксы Rules, Export, Events и NonInteractiveProcessor соответственно. Например, функция DoSomething из модуля Модуль для правил вызывается следующим образом: Rules.DoSomething ().

Замечание. Для скриптов на языках .Net вызов функций глобальных модулей осуществляется без использования префикса.

Таймаут на выполнение скрипта

По умолчанию заданы следующие таймауты – 10 секунд для скриптов правил и 1 минута для скриптов экспорта.

Для изменения значения таймаута необходимо задать новое значение в следующей ветви реестра:

HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\DefaultScriptTimeout

Значение таймаута в реестре задается в миллисекундах. Если скрипт выполняется дольше, чем заданный таймаут, то его выполнение будет прервано и возникнет ошибка "Таймаут выполнения скрипта". Для скриптов, являющихся частью задачи импорт, распознавания, или экспорта, аналогичное сообщение будет записано в лог.

Внимание! Таймаут на выполнение скрипта действует только для скриптов, написанных на языках JScript и VBScript.

Внимание! Если скрипт выполняется под сервисом NetworkService, то для изменения значения таймаута нужно вносить изменения в ветвь реестра соответствующего профиля.

Объектная модель

Объектная модель совместима со скриптами, созданными в предыдущих версиях ABBYY FlexiCapture.

Подробнее об используемой объектной модели


Скрипты обработки

Назначение

Скрипты обработки документа или пакета позволяют изменять структуру документа (пакета), указывать порядок разделов в документе или документов в пакете. Скрипты обработки можно добавить при создании пользовательского этапа в Расширенном режиме процесса обработки.

Оба скрипта служат для обработки множества документов и имеют возможность писать лог процесса обработки.

Скрипт обработки одного документа

Скрипту обработки одного документа подаются по очереди все документы, которые нужно обработать.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Полные права | Документ, который нужно обработать
Processing | IProcessingCallback | Полные права | Объект для записи в лог информации об обработке

Замечание. Если задача отменяется, то Processing Status принимает значение false (как и при использовании свойства IProcessingCallback.ReportError).

Скрипт обработки пакета

Скрипту обработки пакета передаётся пакет и множество документов в нём, которые нужно обрабатывать. Переход по документам осуществляется пользователем.

Преимущество этого типа скрипта в том, что в нем доступны методы, меняющие структуру пакета. С помощью данного скрипта можно перемещать и удалять документы и страницы.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение. Внутренние* поля документов и страниц пакета недоступны. | Пакет
Documents | IDocuments | Полные права. Также можно менять структуру пакета для этих документов. | Документы, которые нужно обработать
Processing | IProcessingCallback | Полные права | Объект для записи в лог информации об обработке

* - Внутреннее поле требует загрузки объекта в память.


TAssemlingErrorType

Назначение

Тип ошибки сборки.

Допустимые значения:

  • AET_ObligatoryItemOmitted = 0 - Недостающий раздел
  • AET_RubbishItem = 1 - Лишняя страница
  • AET_AssemblingRuleError = 2 - Пользовательская ошибка сборки
  • AET_KeyValuesMismatch = 3 - Не совпадают значения ключевых полей (возможно не более одной ошибки этого типа на документ)


TExportFieldType

Назначение

Перечисление, имеет тип int. Описывает тип полей документа.

Допустимые значения:

  • EFT_TextField = 0 - Текстовое поле
  • EFT_DateTimeField = 1 - Поле с датой
  • EFT_NumberField = 2 - Поле с числом
  • EFT_PictureField = 3 - Поле-картинка
  • EFT_CurrencyField = 4 - Поле с валютой
  • EFT_Checkmark = 5 - Метка
  • EFT_CheckmarkGroup = 6 - Группа меток
  • EFT_Group = 7 - Обычная группа
  • EFT_Table = 8 - Таблица. Через методы Items или Rows объекта IField можно получить доступ к строкам таблицы.
  • EFT_Section = 9 - Раздел документа
  • EFT_Document = 10 - Документ. Поля такого типа встречаются только в правилах, написанных на уровне документа. Большинство параметров таких полей недоступно.
  • EFT_TableRow = 11 - Строка в таблице. Ячейки в ней являются дочерними полями и доступны через метод Children.
  • EFT_TimeField = 12 - Поле со временем


TExportType

Назначение

Тип назначения экспорта.

Допустимые значения:

  • ET_File = 1 - Экспорт в файл
  • ET_Database = 2 - Экспорт в базу данных
  • ET_Script = 3 - Скриптовый экспорт
  • ET_SharePoint = 4 - Экспорт в SharePoint
  • ET_Unknown = 5 - Тип не задан, если есть ошибки, не относящиеся к определённому экспортёру


TPageClassificationType

Назначение

Тип страницы, определенный Классификатором. Используются в интерфейсе IPageClassificationResult.

Допустимые значения:

  • PCT_Unknown = 0 - Неизвестный тип страницы.
  • PCT_Empty = 1 - Пустая страница.
  • PCT_FixedForm = 2 - Страница с жесткой структурой.
  • PCT_FlexibleMultiPageFormHeader = 3 - Заголовок многостраничного гибкого раздела.
  • PCT_FlexibleMultiPageFormNonHeader = 4 - Страница в многостраничной гибком разделе, не являющая заголовком.
  • PCT_FlexibleSinglePageForm = 5 - Одностраничный гибкий раздел.
  • PCT_ClassWithoutDefinition = 6 - Страница класса без определения документа.


TPrincipalType

Назначение

Типы принципалов (пользователей или процессов, имеющих учетную запись (account) в данной среде).

Допустимые значения:

  • PT_User = 0 - Обычный пользователь
  • ST_Group = 1 - Группа пользователей


TProcessingPriority

Назначение

Приоритет обработки документа или пакета.

Замечание. Значение приоритета передается в события "Изменение свойства документа" и "Изменение свойства пакета" в виде строки. Новое значение также должно задаваться в виде строки.

Допустимые значения:

  • PP_Lowest = -2 - Низший приоритет. Передается в виде строки "lowest".
  • PP_Low = -1 - Низкий приоритет. Передается в виде строки "low".
  • PP_Normal = 0 - Нормальный приоритет. Передается в виде строки "normal".
  • PP_High = 1 - Высокий приоритет. Передается в виде строки "high".
  • PP_Highest = 2 - Высший приоритет. Передается в виде строки "highest".


TPropertyType

Назначение

Тип свойств документов или пакетов. Используется в объекте IPropertyModificationInfo.

Типы:

  • PT_Name = 0 - Имя (только для пакетов).
  • PT_Comment = 1 - Комментарий.
  • PT_BatchType = 2 - Тип пакета (только для пакетов).
  • PT_NamedPropertyValue = 3 - Именованное свойство (то же, что регистрационный параметр во FlexiCapture)
  • PT_Id = 4 - Идентификатор (ExternalId документа). Значение меняется редко и только у документов. Изменение значения происходит главным образом в момент импорта.


TRuleErrorType

Описание

Тип ошибки. Используется в интерфейсе IRuleError.

Типы:

  • ET_RuleError = 0 - Ошибка правила.
  • ET_FormatError = 1 - Ошибка формата.
  • ET_MergeVersionError = 2 - Ошибка объединения разных версий документа.


TStateType

Назначение

Типы состояния документа. Используются в событии "Изменение состояния документа". С помощью параметра ChangedState этого события можно узнать про каждый тип состояния, изменилось ли оно.

Допустимые значения:

  • ST_Preprocessed = 0 - Документ предобработан. Значение может меняться только "false" на "true".
  • ST_Analyzed = 1 - Проанализирован ли документ.
  • ST_Recognized = 2 - Распознан ли документ (документ считается распознанным, если в нём распознано хотя бы одно поле).
  • ST_HasErrors = 3 - Есть ли ошибки в документе (в том числе форматные).
  • ST_Assembled = 4 - Документ собран.
  • ST_Verifyed = 5 - Документ полностью верифицирован.
  • ST_Exported = 6 - Документ проэкспортирован.
  • ST_HasLayout = 7 - На документ наложена форма. (Проанализированный документ также может не иметь формы, например, если это страница неизвестного типа.)


Внешние сборки

В скриптах и глобальных модулях разрешается использовать внешние сборки. Можно использовать как стандартные, так и откомпилированные пользовательские сборки.

Подключение внешней сборки

Внешние сборки добавляются на закладке Сборки .Net в свойствах типа пакета, в свойствах проекта или в свойствах определения документа. Все классы и методы из добавленных сборок доступны в скриптах и глобальных модулях.
Сборки, добавленные в свойствах типа пакета или определения документа, доступны определенному типу пакета или определению документа соответственно. Сборки, добавленные в свойствах проекта, являются общими сборками, доступными всем типам пакетов и определениям документов данного проекта. Таким образом, если вам требуется использовать одну и ту же сборку для различных типов пакета и определений документов, вы можете использовать общую сборку. Если общую сборку необходимо обновить, вам нужно будет обновить ее только в свойствах проекта.
Для добавления сборки в свойствах проекта выполните следующие действия:

  1. На закладке Сборки .Net свойств проекта нажмите Добавить…
  2. В открывшемся диалоговом окне Добавление сборки выберите тип: Стандартное имя сборки или Путь к прикрепленному файлу.
  3. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки.

Общая сборка добавляется во вновь созданные типы пакета автоматически. Для добавления общей сборки в определения документа и в ранее созданные типы пакета выполните следующие действия:

  1. На закладке Сборки .Net свойств типа пакета или определения документа нажмите Добавить…
  2. В открывшемся диалоговом окне Добавление сборки выберите Общая сборка.
  3. Выберите имя сборки из списка Ссылка.

    Замечание. Если в типе пакета уже содержится стандартная сборка с указанным именем, добавить общую сборку с таким же именем нельзя.

Пример кода пользовательской сборки, содержащей пространство имен, класс и метод этого класса:

namespace TestNameSpace

{

public class Test

{

public void Show(string text)

{

// will show text by standard FlexiCapture means – static method void ShowMessage(string text, bool IsError) from static class FCTools ABBYY.FlexiCapture.FCTools.ShowMessage(text, false);

}

}

}

Для того чтобы классы и методы из добавленной сборки были доступны из скриптов-обработчиков событий, сборка должна быть добавлена на закладке Сборки .Net свойств типа пакета (для определенного типа пакета) или свойствах проекта (для типа пакета по умолчанию).

Для следующих скриптов внешние сборки добавляются на закладке Сборки .Net свойств определения документа:

  • скрипт правила
  • скрипт автозамены
  • скрипт экспорта
  • пользовательский скрипт
  • скрипт сборки документа
  • скрипт пользовательского распознавания

Скрипт, использующий классы и методы из внешней сборки, должен содержать следующий код:

TestNameSpace.Test test = new TestNameSpace.Test(); // creates an object of Test class

test.Show(“hello world”); // calls void Show() method from Test class

Отладка .Net-сборки

Для отладки внешних сборок, помимо самой сборки, требуется также .pdb-файл с символьной информацией. Отладка возможна только для сборок, для которых загружена символьная информация. Этот файл имеет большой размер, поэтому загрузку символьной информации желательно отключать в рабочем проекте.

Ключи в реестре, контролирующие загрузку символьной информации:

В реестре можно задать следующие ключи, позволяющие подключать .pdb-файл с символьной информацией (можно задать один ключ или оба):

  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\ [LoadSymbolsFromOriginalPath]- определяет, нужно ли загружать pdb-файлы из той же папки, откуда загружена сборка (для загрузки файлов нужно установить значение ключа True);
  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller\ScriptSupport\ [PDBSearchLocations] = <путь к папке с PDB-файлами> - служит для перечисления путей, по которым нужно искать pdb-файлы для сборок (пути должны быть перечислены через точку с запятой; при поиске загружается файл с символьной информацией (.pdb), имя которого совпадает с именем сборки).

В реестре ключи по умолчанию не создаются. Администратор при необходимости может добавить эти ключи в реестр пользователя.

Изменения в реестре вступают в силу после перезапуска программы.

Для отладки сборки нужно подключаться к managed-коду.


После закрытия документа

Когда вызывается

Вызывается во время закрытия документа в редакторе документа после подтверждений изменений.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа


После закрытия проекта

Когда вызывается

Вызывается во время закрытия проекта после того, как пользователь подтверждает действия в окне опроса (в случае показа окна опроса).

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно


При активации документа

Когда вызывается

Вызывается перед активизацией документа в окне задания (двойным щелчком мыши, из меню программы и т.д.).

Если значение параметра CanOpen равно true, то после завершения скрипта документ будет открыт в редакторе документа. Если значение параметра CanOpen равно false, документ не будет открыт.

По умолчанию значение параметра CanOpen равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задач
DocumentItem | IDocumentItem | Чтение/запись | Обрабатываемый документ
CanOpen | IBoolean | Чтение/запись | Нужно ли открывать документ после выполнения скрипта


При закрытии документа

Когда вызывается

Вызывается при закрытием документа в редакторе документа перед подтверждением изменений. Например, при попытке перейти к другому документу или закрыть редактор.

Если значение параметра CanClose равно false, документ не будет закрыт. Если значение параметра CanClose равно true, произойдет закрытие документа.

По умолчанию параметр CanClose имеет значение true.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа
CanClose | IBoolean | Чтение/запись | Нужно ли закрывать документ после выполнения скрипта


При открытии документа

Когда вызывается

Вызывается после открытия документа в редакторе документа (при открытии окна редактора или при переходе на новый документ).

На момент запуска скрипта все окна внутри редактора документа уже созданы.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа

Замечание. Закрыть документ из этого скрипта нельзя. Использование команды DocumentEditor.TaskWindow.CloseEditorWindow(); вызовет сообщение об ошибке: "System.Runtime.InteropServices.COMException (0x80004005): Document editor cannot be closed."


События

Ниже перечислены события в оболочке программы, которые могут быть обработаны с помощью скриптов:

При активации документа
При закрытии документа
При закрытии проекта
После закрытия документа
При активации поля
При деактивации поля
При открытии документа
После закрытия проекта
При изменении региона
При отображении региона
При подтверждении текстового поля
При вызове пользовательской команды


При активации поля

Когда вызывается

Вызывается после активации поля.

Параметры

Имя | Тип | Права | Значение
Context | IFieldControl | Чтение/запись | Активированное поле

Замечание. Активировать какое-либо другое поле из этого скрипта нельзя.


При деактивации поля

Когда вызывается

Вызывается перед тем, как поле перестает быть активным.

В качестве параметра передается поле, которое будет активно следующим. Этот параметр можно изменить.

Параметры

Имя | Тип | Права | Значение
Context | IFieldControl | Чтение/запись | Поле, которое перестает быть активным
WasModified | bool | Чтение/запись | Было ли поле модифицировано
NewActiveControl | IBoxedFieldControl | Чтение/запись | Активизированное поле. Замечание. Имеет нулевое значение, если поле, которое будет активировано, находится в другом документе.


IBoolean

Назначение

Используется для передачи в скрипт in-out булевого значения.

Свойства

Имя | Тип | Права | Значение
Value | bool | Чтение/запись | Значение

Замечание. Чтобы присвоить значение объекту типа IBoolean, нужно использовать свойство Value. Например, чтобы присвоить значение true объекту A типа IBoolean, нужно написать A.Value = true. Запись A = true является некорректной.


IBoxedFieldControl

Назначение

Хранит управляющий элемент поля документа.

Свойства

Имя | Тип | Права | Значение
Value | IFieldControl | Чтение/запись | Поле


IDocumentsCollection

Назначение

Коллекция объектов IDocument.


IDocumentEditor

Назначение

Служит для представления редактора документа.

Методы

Определение | Описание
Save() : bool | Сохраняет документ

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
Document | IDocument | Только чтение | Редактируемый документ
Modified | bool | Только чтение | Модифицирован ли документ
TaskWindow | ITaskWindow | Только чтение | Окно задания
ImageWindow | IImageWindow | Только чтение | Окно изображения документа
FormWindow | IFormWindow | Только чтение | Окно формы
ErrorsWindow | IErrorsWindow | Только чтение | Окно ошибок
FormMode | bool | Чтение/запись | Включен ли режим показа данных


IDocumentItem

Назначение

Служит для представления документа в окне документов.

Свойства

Имя | Тип | Права | Значение
Collection | IDocumentItems | Только чтение | Коллекция документов, в которой находится документ.
Document | IDocument | Только чтение | Документ.
Expanded | bool | Чтение/запись | Развернут ли в окне документ.
MarkedNextStage | IStageInfo | Только чтение | Следующуя стадия, на которую будет отправлен документ после закрытия задачи.
PageItems | IPageItems | Только чтение | Коллекция страниц, содержащихся в документе.
Rect | IShellRect | Только чтение | Прямоугольник, занимаемый документом в окне IDocumentsWindow.
Selected | bool | Чтение/запись | Выделен ли документ.
TaskDocument | bool | Только чтение | Принадлежит ли документ текущему заданию.
TaskWindow | ITaskWindow | Только чтение | Окно задания.

Замечание. Если выбран вид Эскизы страниц, то значение свойства Expanded всегда будет равно true. Изменение значения этого свойства на false не вызовет ошибок, однако значение останется равным true.

Замечание. Если документ свернут, свойство DocumentItem.PageItems.Count возвращает "0".


IDocumentItems

Назначение

Коллекция объектов IDocumentItem. Служит для представления коллекции документов в окне документа.


IDocumentsWindow

Назначение

Окно показа документов в режиме Эскизы страниц или Детали.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден
FindDocumentItem( document : IDocument ) : IDocumentItem | Находит объект IDocumentItem по объекту IDocument из ControllerInterop
FindPageItem( page : IPage ) : IPageItem | Находит объект IPageItem по объекту IPage из ControllerInterop

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0, 0).
TotalRect | IShellRect | Только чтение | Прямоугольник всего окна
ScrollPos | IPoint | Чтение/запись | Позиция ползунка прокрутки
Docking | TDockingType | Чтение/запись | Позиция окна IDocumentsWindow в окне Редактора документа
Ratio | IShellRational | Чтение/запись | Отношение размера окна к размеру родительского окна
TaskWindow | ITaskWindow | Только чтение | Окно задания
Items | IDocumentItems | Только чтение | Коллекция документов
SelectedItems | IDocumentItems | Только чтение | Выделенные документы
FocusedItem | IDocumentItem | Только чтение | Документы, находящиеся в фокусе


IDrawContext

Назначение

Контекст для рисования. Позволяет с помощью скрипта нанести простейшие геометрические объекты. Цвет задается с помощью стандартной последовательности из 4-х байтов: 0x00BBGGRR, где BB – байт для обозначения синего цвета, GG – зеленого, RR – красного.

Методы

Определение | Описание
GetPixel( x : int, y : int ) : int | Возвращает цвет пиксела (в RGB) с координатами x и y.
SetPixel( x : int, y : int, rgbColor : int ) : int | Устанавливает цвет пиксела (в RGB) с указанными координатами x и y. Возвращает значение предыдущего цвета пиксела.
Line( start : IPoint, end : IPoint, rgbColor : int ) | Рисует линию с началом в точке "start" и концом в точке "end".
Rect( rect : IShellRect, rgbColor : int ) | Рисует рамку указанного цвета.
FillRect( rect : IShellRect, rgbColor : int ) | Рисует закрашенный прямоугольник указанного цвета.
FillAlphaRect( rect : IShellRect, rgbColor : int, alpha : int ) | Рисует закрашенный прямоугольник определенной прозрачности, которая устанавливается параметром "transparency".

Свойства

Имя | Тип | Права | Значение
Handle | int | Read only | Дескриптор контекста


IErrorControl

Назначение

Служит для представления элемента в списке окна ошибок IErrorsWindow.

Методы

Определение | Описание
Field( index : int ) : IField | Находит поле, связанное с ошибкой, по номеру ошибки

Свойства

Имя | Тип | Права | Значение
Type | TErrorType | Только чтение | Тип ошибки
Error | string | Только чтение | Текст ошибки
IsWarning | bool | Только чтение | Является ли ошибка предупреждением
FieldsCount | int | Только чтение | Количество полей, связанных с ошибкой
Index | int | Только чтение | Номер ошибки в окне ошибок IErrorsWindow


IErrorControls

Назначение

Коллекция объектов IErrorControl.


IErrorsWindow

Назначение

Служит для представления окна ошибок.

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentWindow | IDocumentEditor | Только чтение | Редактор документа
Controls | IErrorControls | Только чтение | Коллекция элементов
FocusedControl | IErrorControl | Чтение/запись | Ошибка, которая находится в фокусе
Docking | TDockingType | Чтение/запись | Позиция окна IErrorsWindow по отношению к окну IFormWindow в редакторе документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окна IErrorsWindow (числитель) к размеру окон IFromWindow + IErrorsWindow (знаменатель).
ShowAssemblingErrors | bool | Чтение/запись | Показывать ли ошибки сборки
ShowRuleErrors | bool | Чтение/запись | Показывать ли ошибки правил
ShowFormatErrors | bool | Чтение/запись | Показывать ли ошибки формата
ShowUnmatchedRegionErrors | bool | Чтение/запись | Показывать ли ошибки, связанные с неналоженными полями


IFieldControl

Назначение

Служит для представления элемента управления поля документа.

Внимание! Объект возвращает значение null для полей, не участвующих в распределенной верификации.

Свойства

Имя | Тип | Права | Значение
DeviceRect | IShellRect | Только чтение | Прямоугольник поля
Field | IField | Только чтение | Поле
FieldFullName | string | Только чтение | Полное имя поля
FieldRegionControls | IFieldRegionControls | Только чтение | Коллекция регионов поля документа. Для полей, у которых нет регионов, значение свойства равно null.
First | IFieldControl | Только чтение | Первое поле-потомок
FormWindow | IFormWindow | Только чтение | Окно формы
IsExpandable | bool | Только чтение | Если значение равно true, поле можно сворачивать и разворачивать на форме. Позволяет проверить, можно ли сворачивать и разворачивать поле до применения к полю свойства IsExpanded. Свойство имеет значение true для групповых полей.
IsExpanded | bool | Чтение/запись | Возвращает информацию о том, развернуто ли групповое поле. Позволяет свернуть/развернуть поле.
IsUserReadOnly | bool | Чтение/запись | Можно ли редактировать поле. Если значение свойства равно true, редактирование поля не разрешается. Если значение свойства равно false, возможность редактирования поля зависит от настроек определения документа.
Last | IFieldControl | Только чтение | Последний дочерний элемент управления поля
Next | IFieldControl | Только чтение | Следующий элемент управления поля
Parent | IFieldControl | Только чтение | Родительский элемент управления поля
Prev | IFieldControl | Только чтение | Предыдущий элемент управления поля
TextEditor | ITextEditor | Только чтение | Редактор поля. Для неактивных полей возвращает null.


IFieldRegionControl

Назначение

Служит для представления региона поля документа.

Внимание! Объект возвращает значение null для полей, не участвующих в распределенной верификации.

Свойства

Имя | Тип | Права | Значение
FieldRegion | IFieldRegion | Только чтение | Регион поля документа
Page | IPageControl | Только чтение | Страница, содержащая регион
Window | IImageWindow | Только чтение | Окно изображения документа
DeviceRect | IShellRect | Только чтение | Прямоугольник окна
Visible | bool | Чтение/запись | Виден ли регион
FieldControl | IFieldControl | Только чтение | Поле документа, связанное с регионом
Parent | IFieldRegionControl | Только чтение | Родительский регион
First | IFieldRegionControl | Только чтение | Первый потомок-регион
Last | IFieldRegionControl | Только чтение | Последний потомок-регион
Prev | IFieldRegionControl | Только чтение | Предыдущий регион
Next | IFieldRegionControl | Только чтение | Следующий регион


IFieldRegionControls

Назначение

Коллекция объектов IFieldRegionControl.


IFormWindow

Назначение

Служит для представления окна формы документа.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден
FindControl( field : IField ) : IFieldControl | Осуществляет поиск поля по значению региона поля из ControllerInterop

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentWindow | IDocumentEditor | Только чтение | Редактор документа
Control | IFieldControl | Только чтение | Главный элемент на форме
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0,0).
TotalRect | IShellRect | Только чтение | Прямоугольник всей формы. Если размер клиентской области меньше, чем размер всей формы, то окно формы будет иметь полосы прокрутки.
ScrollPos | int | Чтение/запись | Позиция ползунка прокрутки
ActiveControl | IFieldControl | Чтение/запись | Активный элемент на форме. Из событий При активации поля и При деактивации поля изменять значение активного элемента нельзя.
TextSize | TTextSize | Чтение/запись | Размер текста
Docking | TDockingType | Чтение/запись | Позиция окна IFormWindow относительно позиции окна IImageWindow в окне редактора документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окон IFormWindow + IErrorsWindow (числитель) к размеру окна IDocumentEditor (знаменатель). Если значение Docking равно DT_Top или DT_Bottom, отношение измеряется по высоте. В противном случае отношение измеряется по ширине.


IImageWindow

Назначение

Служит для представления окна изображения.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentEditor | IDocuementEditor | Только чтение | Редактор документа
First | IPageControl | Только чтение | Первая страница
Last | IPageControl | Только чтение | Последняя страница
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0, 0). Если размер клиентской области меньше, чем размер области TotalRect, то окно изображения будет иметь полосы прокрутки.
TotalRect | IShellRect | Только чтение | Прямоугольник, занимаемый изображениями всех страниц
ScrollPos | IPoint | Чтение/запись | Позиция ползунка прокрутки
Docking | TDockingType | Чтение/запись | Позиция окна IImageWindow относительно окна IFormWindow в окне редактора документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окна IImageWindow (числитель) к размеру окна IDocumentEditor (знаменатель). Если значение Docking равно DT_Top или DT_Bottom, отношение измеряется по высоте. В противном случае отношение измеряется по ширине.
ShowBWImages | bool | Чтение/запись | Нужно ли показывать черно-белое изображение
ImageScale | IShellRational | Чтение/запись | Масштаб изображения. Диапазон допустимых значений от 1/8 до 8.
ShowToolbar | IShellRational | Чтение/запись | Нужно ли показывать панель инструментов
IsDocked | bool | Чтение/запись | Определяет, закреплено ли окно изображения.


IMainMenu

Назначение

Коллекция объектов IMenuItem. Служит для представления меню главного окна.

Для всех элементов этого меню идентификатор TCommandID равен CI_SubMenu.

Методы

Определение | Описание
Reset() | Сбрасывает изменения и возвращает меню в исходный вид.

Внимание! Применение метода Reset приводит к уничтожению имеющегося объекта IMainMenu и порождению нового объекта. Вследствие этого все ссылки на имеющийся объект становятся недействительными и попытки использовать этот объект будут порождать исключение. Необходимо либо создать новый объект IMainMenu, либо заново инициализировать имеющийся объект.

Код, приведенный ниже, иллюстрирует применение метода Reset. В результате применения метода объект menu становится недействительным и не может быть использован.

// Define a new IMainMenu object and initialize it

IMainMenu menu = TaskWindow.MainWindow.MainMenu;

// Call the Reset method

menu.Reset();


IMainWindow

Назначение

Служит для представления главного окна.

Методы

Определение | Описание
CommandIsEnabled( commandId: TCommandID ) : bool | Возвращает значение true, если команда включена, и значение false, если команда отключена.
EnableCommand( commandId: TCommandID, bool) | Делает доступной/недоступной команду в интерфейсе.

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
MainMenu | IMainMenu | Только чтение | Главное меню
Toolbars | IToolbars | Только чтение | Коллекция панелей инструментов
WorkWindowType | TWorkWindowType | Только чтение | Тип рабочего окна
TaskWindow | ITaskWindow | Только чтение | Окно задания
UserRole | TUserRole | Только чтение | Роль пользователя
Selection | ISelection | Только чтение | Выделение


IMenu

Назначение

Коллекция объектов IMenuItem. Служит для представления меню или подменю.

Методы

Определение | Описание
AppendItem( commandId : TCommandID, text : string ) : IMenuItem | Возвращает объект IMenuItem соответствующего элемента. Можно использовать любые идентификаторы из перечисления TCommandID (в том числе CI_SubMenu и CI_Separator), кроме CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.
Delete( index : int ) | Удаляет элемент по его индексу в коллекции.
Find( commandId : TCommandID ) : int | Находит индекс первого объекта с указанным идентификатором команды в коллекции.
InsertItem( index : int, commandId : TCommandID, text : string ) : IMenuItem | Возвращает объект IMenuItem соответствующего элемента. Можно использовать любые идентификаторы из перечисления TCommandID (в том числе CI_SubMenu и CI_Separator), кроме CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.


IMenuItem

Назначение

Служит для представления элемента меню.

Свойства

Имя | Тип | Права | Значение
Command | TCommandID | Только чтение | Идентификатор команды. Для заголовка подменю возвращает CI_SubMenu. Для разделителя возвращает CI_Separator. Если среди значений TCommandID отсутствует идентификатор команды, возвращается CI_Undefined.
Enable | bool | Чтение/запись | Определяет включенность/выключенность пунктов меню. Если значение свойства равно false, то все пункты меню с указанным идентификатором Command будут выключены. Если значение свойства равно true, включенность/выключенность зависит от внутренней логики программы. Для разделителей и заголовков подменю значение свойства всегда равно true.
Text | string | Чтение/запись | Текст пункта меню. Замечание. Данное свойство не позволяет изменять названия заголовков главного меню: Файл, Правка, Вид и т.д.
Submenu | IMenu | Только чтение | Подменю. Если подменю отсутствует, возвращает null.


IPagesCollection

Назначение

Коллекция объектов IPage.


IPageControl

Назначение

Служит для представления страницы в окне изображения.

Методы

Определение | Описание
ImageToDevice( imageRect : IShellRect ) : IShellRect | Преобразует координаты изображения в оконные координаты

Свойства

Имя | Тип | Права | Значение
Page | IPage | Только чтение | Страница
ImageWindow | IImageWindow | Только чтение | Окно изображения документа
DeviceRect | IShellRect | Только чтение | Прямоугольник, занимаемый страницей
First | IFieldRegionControl | Только чтение | Первый потомок-регион
Last | IFieldRegionControl | Только чтение | Последний потомок-регион
Prev | IPageControl | Только чтение | Предыдущая страница
Next | IPageControl | Только чтение | Следующая страница


IPageItem

Назначение

Служит для представления страницы в окне документов.

Свойства

Имя | Тип | Права | Значение
TaskWindow | ITaskWindow | Только чтение | Окно задания
DeviceRect | IShellRect | Только чтение | Прямоугольник, занимаемый страницей в окне IDocumentsWindow
Selected | bool | Чтение/запись | Выделена ли страница
DocumentItem | IDocumentItem | Только чтение | Документ, содержащий страницу
Page | IPage | Только чтение | Страница


IPageItems

Назначение

Коллекция объектов IPageItem.


IPoint

Назначение

Служит для представления точки.

Свойства

Имя | Тип | Права | Значение
X | int | Чтение/запись | X-координата
Y | int | Чтение/запись | Y-координата


IShellRational

Назначение

Служит для представления дроби.

Свойства

Имя | Тип | Права | Значение
Numerator | int | Чтение/запись | Числитель
Denominator | int | Чтение/запись | Знаменатель


IShellRect

Назначение

Служит для представления прямоугольника.

Методы

Определение | Описание
ToString() : string | Представление прямоугольника в виде строки вида "[left,top,right,bottom]"

Свойства

Имя | Тип | Права | Значение
Left | int | Чтение/запись | Левая координата
Right | int | Чтение/запись | Правая координата
Top | int | Чтение/запись | Верхняя координата
Bottom | int | Чтение/запись | Нижняя координата


IShellRects

Назначение

Коллекция объектов IShellRect.


ISelection

Назначение

Служит для представления выделения (документов или страниц).

Свойства

Имя | Тип | Права | Значение
Type | TSelectionType | Только чтение | Тип выделения
DocumentItems | IDocumentItems | Только чтение | Выделенные документы
Documents | IDocumentsCollection | Только чтение | Объекты типа IDocument, соответствующие выделенным документам
PageItems | IPageItems | Только чтение | Выделенные страницы
Pages | IPagesCollection | Только чтение | Объекты типа IPage, соответствующие выделенным страницам

Замечание. Если документ свернут, свойство DocumentItems[i].PageItems.Count возвращает "0".


ITaskWindow

Назначение

Служит для представления окна задания.

Методы

Определение | Описание
CloseDocument( document : IDocument ) | Закрывает документ из состояния для редактирования из скрипта. При вызове данного метода происходит изменение состояния документа.
CloseEditorWindow() | Закрывает открытый редактор документа. Внимание! При закрытии редактора документа все несохраненные изменения будут утеряны. При вызове данного метода происходит изменение состояния документа.
CloseTask( bool ) | Закрывает задание с предупреждением об отмене процесса (если аргумент имеет значение true) либо без предупреждения (если аргумент имеет значение false).
DocumentState( document : IDocument ) : TDocumentState | Определяет состояние документа в окне задач. Замечание. Метод может вызываться только из основного потока.
EditDocument( document : IDocument, page : IPage ) : IDocumentEditor | Открывает документ для редактирования в редакторе документа. Замечание. В случае успешного открытия документа метод возвращает объект типа IDocumentEditor. Иначе возвращает null. При вызове данного метода происходит изменение состояния документа.
OpenDocument( document : IDocument ) | Открывает документ для редактирования с помощью скрипта. Метод можно вызывать также в случае, если документ открыт в редакторе документа с правами только на чтение. При вызове данного метода происходит изменение состояния документа.
RejectTask( bool ) | Отклонить задание с предупреждением об отмене процесса (если true) либо без предупреждения (если false).

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
MainWindow | IMainWindow | Только чтение | Главное окно
Batch | IBatch | Только чтение | Пакет
Mode | TTaskWindowMode | Чтение/запись | Режим показа окна
DocumentsWindow | IDocumentsWindow | Только чтение | Окно документов
EditorWindow | IDocumentEditor | Только чтение | Редактор документа


ITextEditor

Назначение

Служит для представления редактора поля документа.

Методы

Определение | Описание
GetSelection( startPos : int, endPos : int ) | Определяет начало и конец выделения. Если выделение отсутствует, присваивает параметрам startPos и endPos значение "0".
SetSelection( startPos : int, endPos : int ) | Устанавливает новое выделение
ApplyChanges() : bool | Применяет сделанные изменения
ResetChanges() | Сбрасывает сделанные изменения
ShowSuggestList() | Показывает список подсказок. Если подсказок нет, ничего не происходит.

Свойства

Имя | Тип | Права | Значение
Control | IFieldControl | Только чтение | Элемент управления поля
Modified | bool | Только чтение | Модифицировано ли поле
Text | string | Только чтение | Текст поля
FormWindow | IFormWindow | Только чтение | Окно формы


IToolbar

Назначение

Коллекция объектов IToolbarButton. Служит для представления панели инструментов.

Методы

Определение | Описание
AppendButton( commandId: TCommandID, text: string ) : IToolbarButton | Возвращает объект IToolbarButton соответствующего элемента. Можно использовать любые идентификаторы из перечисления TCommandID (в том числе CI_Separator), кроме CI_SubMenu и CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.
Delete( index: int ) | Удаляет элемент по его индексу в коллекции
InsertButton( index: int, commandId: TCommandID, text: string ) : IToolbarButton | Возвращает объект IToolbarButton соответствующего элемента. Можно использовать любые идентификаторы из перечисления TCommandID (в том числе CI_Separator), кроме CI_SubMenu и CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.
Find( commandId: TCommandID ) : int | Находит в коллекции индекс кнопки с указанным идентификатором
Reset() | Сбрасывает изменения и возвращает панель инструментов в исходный вид

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя панели
Type | TCommandBarType | Только чтение | Тип панели
Visible | bool | Чтение/запись | Видна ли панель инструментов


IToolbarButton

Назначение

Служит для представления кнопки на панели управления.

Свойства

Имя | Тип | Права | Значение
Command | TCommandID | Только чтение | Идентификатор команды. Возвращаемое значение не может равняться CI_SubMenu. Если среди значений TCommandID отсутствует идентификатор команды, возвращается CI_Undefined
Enable | bool | Чтение/запись | Определяет включенность/выключенность кнопок. Если значение свойства равно false, то все кнопки с указанным идентификатором Command будут выключены. Если значение свойства равно true, включенность/выключенность зависит от внутренней логики программы.
Visible | bool | Чтение/запись | Видимость кнопки или разделителя
Text | string | Чтение/запись | Текст на кнопке


IToolbars

Назначение

Коллекция объектов IToolbar.


Объекты

В этом разделе содержится описания объектов, используемых в скриптах, их методов и свойств.

IBoolean
IBoxedFieldControl
IDocumentEditor
IDocumentItem
IDocumentItems
IDocumentsCollection
IDocumentsWindow
IDrawContext
IErrorControl
IErrorControls
IErrorsWindow
IFieldControl
IFieldRegionControl
IFieldRegionControls
IFormWindow
IImageWindow
IMainMenu
IMainWindow
IMenu
IMenuItem
IPageControl
IPageItem
IPageItems
IPagesCollection
IPoint
ISelection
IShellRational
IShellRect
IShellRects
ITaskWindow
ITextEditor
IToolbar
IToolbarButton
IToolbars
TCommandBarType
TCommandID
TDockingType
TErrorType
TSelectionType
TTaskWindowMode
TTextSize
TUserRole
TWorkWindowType


При закрытии проекта

Когда вызывается

Вызывается при закрытии проекта перед показом окна опроса пользователя. Диалоговое окно опроса пользователя появляется в случае, если перед продолжением работы требуется подтвердить какое-либо действие.

Если значение параметра CanClose равно false, то после выполнения скрипта главное окно не будет закрыто. Если параметр CanClose имеет значение true, произойдет закрытие главного окна.

По умолчанию значение параметра CanClose равно true.

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно
CanClose | IBoolean | Чтение/запись | Нужно ли закрывать главное окно


При отображении региона

Когда вызывается

Скрипт выполняется перед перерисовыванием региона.

Если значение параметра DrawDefault равно true, перерисовывание региона будет прекращено. В противном случае регион будет перерисован.

По умолчанию значение параметра DrawDefault равно false.

Parameters

Имя | Тип | Права | Значение
Context | IFieldRegionControl | Чтение/запись | Регион
DrawContext | IDrawContext | Чтение/запись | Контекст изображения
DrawDefault | IBoolean | Чтение/запись | Признак необходимости перерисовывания региона


При изменении региона

Когда вызывается

Вызывается перед изменением блока в окне изображения.

Если значение параметра AllowChangeRegion равно true, то после выполнения скрипта произойдет изменение блока. Если параметр AllowChangeRegion имеет значение false, изменение не произойдет.

По умолчанию значение параметра AllowChangeRegion равно true.

Параметры

Имя | Тип | Права | Значение
Context | IFieldRegionControl | Чтение/запись | Регион
NewRegionParam | IShellRects | Чтение/запись | Прямоугольники региона. Для таблицы в качестве аргумента передается весь прямоугольник таблицы. Замечание. При изменении региона контейнера возвращается новый регион этого контейнера, новые регионы дочерних элементов возвращены не будут. При изменение региона дочернего элемента, будет возвращен только новый регион измененного дочернего элемента. Для таблиц регион самой таблицы возвращается всегда, в том числе при изменении региона строки или столбца таблицы.
AllowChangeRegion | IBoolean | Чтение/запись | Нужно ли выполнять действие после завершения скрипта


При подтверждении текстового поля

Когда вызывается

Вызывается при проверке элементом управления значения, введенного в текстовое поле, например, при выборе значения поля из предложенных вариантов или когда поле теряет фокус.

Если значение параметра CanApply равно true, то после завершения скрипта в качестве значения поля будут применены введенные данные. Если параметр CanApply имеет значение false, то будет восстановлено значение поля до редактирования.

По умолчанию значение параметра CanApply равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITextEditor | Чтение/запись | Редактор поля документа
CanApply | IBoolean | Чтение/запись | Нужно ли сохранять изменения


TCommandBarType

Описание

Тип меню (панели инструментов). Используется в интерфейсе IToolbar.

Допустимые значения:

  • CBT_Undefined = 0 - Панель не определена.
  • CBT_GroupVerification = 1 - Панель инструментов с командами групповой верификации.
  • CBT_FieldVerification = 2 - Панель инструментов с командами полевой верификации.
  • CBT_Standard = 3 - Стандартная панель инструментов.
  • CBT_Navigation = 4 - Панель навигации при сканировании и распознавании. Содержит кнопки К предыдущему документу, К следующему документу, Предыдущий объект верификации и т.д.
  • CBT_Views = 5 - Панель переключения вида. Содержит кнопки Детали и Эскизы страниц.
  • CBT_Tasks = 6 - Панель инструментов с командами операций над заданиями.
  • CBT_Setup = 7 - Панель инструментов с основными кнопками управления проектом. Содержит кнопки Определения документов…, Типы пакетов…, Свойства проекта… и другие.
  • CBT_ScanAndRead = 8 - Панель инструментов с кнопками импорта, распознавания и других операций над изображениями.
  • CBT_UserToolbar = 9 - - Панель инструментов, добавленная пользователем в настройках внешнего вида этапа.


TCommandID

Описание

Идентификатор команды.

Допустимые значения:

Collapsed Общие команды
  • CI_SubMenu - Заголовок подменю
  • CI_Separator - Разделитель
  • CI_Undefined - Неопределенный идентификатор
Collapsed Команды меню Файл
  • CI_NewProject - Новый проект…
  • CI_BrowseProject - Открыть проект…
  • CI_BrowseWebProject - Открыть проект на сервере…
  • CI_CloseProject - Закрыть проект
  • CI_UploadProject - Загрузить проект на сервер…
  • CI_Save - Сохранить
  • CI_NewBatch - Новый пакет…
  • CI_LoadImage - Загрузить изображения…
  • CI_ScanImages - Сканировать изображения…
  • CI_ImportImage - Импортировать изображения…
  • CI_Export - Экспортировать
  • CI_ExportToFile - Экспортировать данные в файлы
  • CI_ExportImages - Экспортировать изображения в файлы
  • CI_ExportToDB - Экспортировать в базу данных
  • CI_RecentFiles - Открыть предыдущий проект
  • CI_Exit - Выход из ABBYY FlexiCapture 11
Collapsed Команды меню Правка
  • CI_EditUndo - Отменить
  • CI_EditRedo - Повторить
  • CI_EditCut - Вырезать
  • CI_EditCopy - Копировать
  • CI_EditPaste - Вставить
  • CI_EditClear - Удалить
  • CI_MergeDocuments - Объединить в документ
  • CI_SplitDocuments - Разделить документ
  • CI_EditSelectAll - Выделить все
  • CI_EditFind - Найти…
  • CI_EditFindNext - Найти следующий
  • CI_MoveToNextItem - К следующему документу
  • CI_MoveToPreviousItem - К предыдущему документу
  • CI_ImageClean - Очистить изображение
  • CI_ImageInvert - Инвертировать изображение
  • CI_ImageMirrorHorizontal - Перевернуть горизонтально
  • CI_ImageMirrorVertical - Перевернуть вертикально
  • CI_ImageRotate90 - Повернуть на 90° по часовой стрелке
  • CI_ImageRotate270 - Повернуть на 90° против часовой стрелки
  • CI_ImageRotate180 - Повернуть на 180°
  • CI_ImageChangeResolution - Изменить разрешение
  • CI_ExportImage - Сохранить изображение

Дополнительные команды для удаленной станции верификации (контекстная верификация):

  • CI_EditDeleteAll - Удалить все символы
  • CI_EditInsertLineBreak - Вставить пустую строку
  • CI_VerificationMergeSymbols - Объединить символы
Collapsed Команды меню Вид
  • CI_ShowTestBatches - Показать тестовые пакеты
  • CI_ShowWorkBatches - Показать пакеты
  • CI_ShowQueues - Показать очереди
  • CI_ShowDetails - Показать детали
  • CI_ShowThumbnails - Показать эскизы страниц
  • CI_SetupDetailsView - Настройка столбцов
  • CI_DocModeImage - Редактор документов в режиме изображений
  • CI_DocModeForm - Редактор документов в режиме данных
  • CI_DockImageOnTop - Изображение сверху от документа
  • CI_DockImageOnBottom - Изображение снизу от документа
  • CI_DocImageOnLeft - Изображение слева от документа
  • CI_DocImageOnRight - Изображение справа от документа
  • CI_DocImageUndocked - Не закреплено
  • CI_DocErrorsOnTop - Ошибки сверху от документа
  • CI_DocErrorsOnBottom - Ошибки снизу от документа
  • CI_DocErrorsOnLeft - Ошибки слева от документа
  • CI_DocErrorsOnRight - Ошибки справа от документа
  • CI_ImageScalePageWidth - Подобрать по ширине масштаб изображения
  • CI_ImageScalePageHeight - Подобрать по высоте масштаб изображения
  • CI_ImageScaleWholePage - Подобрать наилучший масштаб изображения
  • CI_ImageScale400 - Установить в 400% масштаб изображения
  • CI_ImageScale200 - Установить в 200% масштаб изображения
  • CI_ImageScale100 - Установить в 100% масштаб изображения
  • CI_ImageScale75 - Установить в 75% масштаб изображения
  • CI_ImageScale50 - Установить в 50% масштаб изображения
  • CI_ImageScale25 - Установить в 25% масштаб изображения
  • CI_ImageScaleCustom - Выбрать масштаб изображения
  • CI_ImageScaleZoomIn - Увеличить масштаб изображения
  • CI_ImageScaleZoomOut - Уменьшить масштаб изображения
  • CI_TextSizeLargest - Наибольший размер текста данных
  • CI_TextSizeLarger - Большой размер текста данных
  • CI_TextSizeMedium - Средний размер текста данных
  • CI_TextSizeSmaller - Маленький размер текста данных
  • CI_TextSizeSmallest - Наименьший размер текста данных
  • CI_ViewToolbarsLayout - Показать панель инструментов в редакторе документов
  • CI_ShowFormatErrorInBallon - Показывать ошибки формата во всплывающей подсказке
  • CI_ShowFormatErrorInErrorView - Показывать ошибки формата вверху
  • CI_ShowFormatErrorInFormView - Показывать ошибки формата внизу
  • CI_BWImageMode - Черно-белый режим показа изображений
  • CI_ThumbnailSizeSmallest - Минимальный размер эскизов
  • CI_ThumbnailSizeDefault - Размер эскизов по умолчанию
  • CI_ThumbnailSizeLargest - Максимальный размер эскизов
  • CI_ThumbnailSizeIncrease - Увеличить размер эскизов
  • CI_ThumbnailSizeDecrease - Уменьшить размер эскизов
  • CI_ViewToolbarsStandard - Показать/спрятать стандартную панель инструментов
  • CI_ViewToolbarsDocuments - Показать/спрятать панель инструментов представления документов
  • CI_ViewToolbarsNavigation - Показать/спрятать панель инструментов навигации
  • CI_ViewToolbarsScanAndRead - Показать/спрятать панель инструментов сканирования
  • CI_ViewToolbarsProjectSetup - Показать/спрятать панель инструментов настройки проекта
  • CI_ViewToolbarsTasks - Показывает/прячет панель инструментов очередей и заданий
  • CI_ShowToolbar1 - Показать панели инструментов
  • CI_ViewStatusbar - Показать/спрятать строку состояния
  • CI_ViewFullScreen - Переключиться в полноэкранный/оконный режим
  • CI_Refresh - Обновить
  • CI_ViewProperties - Показать свойства

Дополнительные команды для удаленной станции верификации (групповая верификация):

  • CI_ShowFieldImage - Показать/Убрать изображение поля
  • CI_ShowFieldImageOnTop - Показывать изображение поля сверху
  • CI_ShowFieldImageOnBottom - Показывать изображение поля снизу
  • CI_ShrinkToFit - Подобрать наилучший масштаб изображения поля
  • CI_ContextImageScale400 - Установить в 400% масштаб изображения поля
  • CI_ContextImageScale200 - Установить в 200% масштаб изображения поля
  • CI_ContextImageScale150 - Установить в 150% масштаб изображения поля
  • CI_ContextImageScale100 - Установить в 100% масштаб изображения поля
  • CI_ContextImageScale75 - Установить в 75% масштаб изображения поля
  • CI_ContextImageScale50 - Установить в 50% масштаб изображения поля
  • CI_ShowCharacterImage - Показать изображение символа
  • CI_ShowActionsToolBar - Показать/Спрятать панель инструментов Действия
  • CI_ShowVerInfoBar - Показать/Спрятать панель информации
  • CI_VerificationOptions - Показать свойства верификатора

Дополнительные команды для удаленной станции верификации (контекстная верификация):

  • CI_ShowRecognizedText - Показать распознанный текст
  • CI_ShowSymbolImagesCutting - Включить/Выключить обрезку изображения символа
  • CI_ShowSpecialSymbols - Показать/Спрятать специальные символы
  • CI_ShowAnalogousFields - Показать/Спрятать аналогичные поля
Collapsed Команды меню Задание
  • CI_GetTask - Получить задание
  • CI_ReturnTask - Закрыть задание
  • CI_ShowTaskComment - Показывать комментарий к заданию
  • CI_CancelTask - Отменить задание
  • CI_DeferTask - Отложить задание
  • CI_SendTaskToException - Отправить задание в исключения
  • CI_SendTaskToRescan - Отправка на повторное сканирование
  • CI_SendTaskToStage - Отправить задание на этап
  • CI_AutoTaskReceive - Включить/выключить автоматическое получение заданий
  • CI_CI_AddDocsToMarked - Добавить документы к отмеченным
  • CI_UnmarksDocs - Снять отметку с документов
  • CI_MarkDocsToException - Отметить документы для отправки в Исключения
  • CI_MarkDocsToRescan -Отметить документы для отправки на повторное сканирование
  • CI_MarkDocsToStage - Отметить документы для отправки на этап
  • CI_ViewMarkedGroupList - Просмотреть список отмеченных
Collapsed Команды меню Распознавание
  • CI_ApplyTemplate - Проанализировать
  • CI_SetDocTemplate - Наложить определение документа
  • CI_ReadActive - Распознать
Collapsed Команды меню Верификация
  • CI_VerifyAll -Начать верификацию
  • CI_GotoNextError - Следующий объект верификации
  • CI_GotoPrevError - Предыдущий объект верификации
  • CI_GotoNextAssembleError - Следующий документ с ошибками сборки
  • CI_GotoPrevAssembleError - Предыдущий документ с ошибками сборки
  • CI_GotoNextUnkCharacher - Следующий неуверенный символ
  • CI_GotoPrevUnkCharacher - Предыдущий неуверенный символ
  • CI_GotoNextRuleError - Следующая ошибка правил
  • CI_GotoPrevRuleError - Предыдущая ошибка правил
Collapsed Verification menu commands
  • CI_VerifyAll - Начать верификацию
  • CI_GotoNextError - Следующий объект верификации
  • CI_GotoPrevError - Предыдущий объект верификации
  • CI_GotoNextAssembleError - Следующий документ с ошибками сборки
  • CI_GotoPrevAssembleError - Предыдущий документ с ошибками сборки
  • CI_GotoNextUnkCharacher - Следующий неуверенный символ
  • CI_GotoPrevUnkCharacher - Предыдущий неуверенный символ
  • CI_GotoNextRuleError - Следующая ошибка правил
  • CI_GotoPrevRuleError - Предыдущая ошибка правил

Дополнительные команды для удаленной станции верификации (групповая верификация):

  • CI_VerificationConfirmAll - Подтвердить все
  • CI_VerificationPostponeAll - Отложить все
  • CI_VerificationToggleSelected - Переключить значение для выбранного объекта
  • CI_VerificationNextPage - Следующая страница верификации
  • CI_VerificationPrevPage - Предыдущая страница верификации
  • CI_VerificationClose - Закрыть верификатор

Дополнительные команды для удаленной станции верификации (контекстная верификация):

  • CI_VerificationConfirmField - Подтвердить поле
  • CI_VerificationNextUncertain - Следующий неуверенный символ
  • CI_VerificationPrevUncertain - Предыдущий неуверенный символ
  • CI_VerificationNextField - Следующее поле
  • CI_VerificationPrevField - Предыдущее поле
Collapsed Команды меню Проект
  • CI_ShowTemplatesList - Показать список определений документов
  • CI_ShowBatchTypes - Показать список типов пакетов
  • CI_ShowImportProfiles - Показать список профилей импорта
  • CI_SwitchToAdminMode - Переключиться в режим администратора
  • CI_ProtectProject - Защитить проект паролем
  • CI_UnprotectProject - Снять пароль с проекта
  • CI_ExportProject - Экспортировать проект
  • CI_ImportProject - Обновление проекта
  • CI_ViewProjectProperties - Показать свойства проекта
  • CI_CreateTestCopy - Создать тестовую копию
  • CI_CommitTestCopy - Применить тестовую копию
  • CI_DeleteTestCopy - Удалить тестовую копию
Collapsed Команды меню Сервис
  • CI_DocPriorityLowest - Установить документу самый низкий приоритет
  • CI_DocPriorityLow - Установить документу низкий приоритет
  • CI_DocPriorityNormal - Установить документу обычный приоритет
  • CI_DocPriorityHigh - Установить документу высокий приоритет
  • CI_DocPriorityHighest - Установить документу самый высокий приоритет
  • CI_UpdateDocToLatestVersion - Обновить документы до последней версии проекта
  • CI_Reanalize - Повторный анализ
  • CI_Reread - Повторное распознавание
  • CI_AssembleDocuments - Обновить сборку
  • CI_RecheckRules - Перепроверить правила
  • CI_CheckBatchIntegrity - Проверить целостность пакета
  • CI_BatchPriorityLowest - Установить пакету самый низкий приоритет
  • CI_BatchPriorityLow - Установить пакету низкий приоритет
  • CI_BatchPriorityNormal - Установить пакету обычный приоритет
  • CI_BatchPriorityHigh - Установить пакету высокий приоритет
  • CI_BatchPriorityHighest - Установить пакету самый высокий приоритет
  • CI_ChangeBatchType - Изменить тип пакета
  • CI_ViewOptions - Показать настройки
Collapsed Команды локального меню поля
  • CI_ExecuteCustomAction - Выполнить пользовательский скрипт
Collapsed Пользовательские команды
  • CI_UserCommand - Команды пользователя
Collapsed Команды меню Справка
  • CI_HelpAbbyyWebSite - Web-сайт ABBYY
  • CI_HelpAbout - О программе ABBYY FlexiCapture
  • CI_HelpContent - Вызов справки
  • CI_HelpPurchaseInfo - Как купить продукцию ABBYY
  • CI_HelpSendFeedback - Отправить отзыв…
  • CI_HelpTechSupport - Техническая поддержка


TDockingType

Описание

Сторона основного окна, к которой примыкает данное окно.

Допустимые значения:

  • DT_Undefined = 0 - Сторона не определена или окна не смежные.
  • DT_Left = 1 - Левая сторона.
  • DT_Right = 2 - Правая сторона.
  • DT_Top = 3 - Верхняя сторона.
  • DT_Bottom = 4 - Нижняя сторона.


TDocumentState

Описание

Состояние документа в окне задач. Используется в интерфейсе ITaskWindow.

Допустимые значения:

  • DS_Locked = 0 - Документ заблокирован. Никакие действия с документом невозможны.
  • DS_Edited = 1 - Документ редактируется в редакторе документа.
  • DS_Closed = 2 - Документ в данный момент закрыт. Его можно как начать редактировать, так и открыть.
  • DS_Opened = 3 - Документ открыт. Документ в данном состоянии можно изменять из скрипта.
  • DS_EditedAndOpened = 4 - Документ редактируется в редакторе документа и доступен для редактирования из скрипта.
  • DS_EditedAndLocked = 5 - Документ открыт в редакторе документа и заблокирован для любых действий.

Замечание. При изменении документа в окне редактора документа его состояние изменяется на DS_EditedAndOpened.


TErrorType

Описание

Тип ошибки. Используется в интерфейсе IErrorControl.

Допустимые значения:

  • ET_Assembling = 0 - Ошибка сборки
  • ET_Rule =1 - Ошибка правил
  • ET_Format = 2 - Ошибка формата


TSelectionType

Описание

Тип выделения. Используется в интерфейсе ISelection.

Допустимые значения:

  • ST_Undefined = 0 - Выделение не определено
  • ST_Documents = 1 - Выделены документы
  • ST_Pages = 2 - Выделены страницы


TTaskWindowMode

Описание

Режим показа окна. Используется в интерфейсе ITaskWindow.

Допустимые значения:

  • TWM_Undefined = 1 - Вид не определен.
  • TWM_ListView = 1 - Детали.
  • TWM_ThumbnailView = 2 - Эскизы страниц.


TTextSize

Описание

Размер текста. Используется в интерфейсе IFormWindow.

Допустимые значения:

  • TS_Undefined = 0 - Размер текста не определен
  • TS_Smallest = 1 - Самый маленький размер текста
  • TS_Smaller = 2 - Размер текста меньше среднего
  • TS_Medium = 3 - Средний размер текста
  • TS_Larger = 4 - Размер текста больше среднего
  • TS_Largest = 5 - Самый большой размер текста


TUserRole

Описание

Роль пользователя. Используется в интерфейсе IMainWindow.

Допустимые значения:

  • UR_Undefined = 0 - Роль не определена
  • UR_VerificationOperator =1 - Оператор верификации
  • UR_SeniorVerificationOperator = 2 - Старший оператор верификации


TWorkWindowType

Описание

Тип рабочего окна.

Допустимые значения:

  • WWT_Undefined = 0 - Тип окна неопределен.
  • WWT_Task = 1 - Окно задания.


По запросу пользователя

При вызове пользовательской команды

Когда вызывается

Событие происходит при вызове пользовательской команды (для этого в главном меню или на панели инструментов должен быть размещен соответствующий пункт).

Идентификаторы пользовательских команд можно представить в виде CI_UserCommand + <неотрицательное целое число>.

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно приложения
CommandId | TCommandID | Чтение/запись | Идентификатор пользовательской команды

Замечание. Чтобы добавить пользовательскую команду на панель инструментов или в главное меню, нужно использовать методы AppendButton/InsertButton объекта IToolbar и AppendItem/InsertItem объекта IMenu соответственно. В качестве пунктов меню необходимо использовать идентификаторы CI_UserCommand или CI_UserCommand + <неотрицательное целое число>.

Код, приведенный ниже, иллюстрирует добавление пункта меню для пользовательской команды с идентификатором CI_UserCommand + 1.

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

IMenu menu = MainWindow.MainMenu[0].Submenu;

menu.AppendItem( userCommand1, “User command” );

Добавленная кнопка или пункт меню для пользовательской команды будут иметь статус "disabled" до тех пор, пока не будет добавлен обработчик события "По запросу пользователя".

Пример кода ниже иллюстрирует обработку события "По запросу пользователя".

ABBYY.FlexiCapture.ClientUI.TCommandID commandID = ( ABBYY.FlexiCapture.ClientUI.TCommandID )( CommandId );

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

if( commandID == userCommand1 ) {

<… вызываем нужные методы …>


Сервер Обработки

Сервер Обработки предназначен для распределения заданий между станциями обработки. Вместе с сервером устанавливается Монитор Сервера Обработки, который позволяет отслеживать работу сервера и устанавливать приоритеты выполнения заданий. Непосредственная обработка документов происходит на Станции Обработки.

После того как Сервер Обработки будет установлен, его необходимо сконфигурировать: запустить сервер, добавить, настроить и запустить станции обработки, включить работу горячих папок.

Замечание. Перед запуском Сервера Обработки необходимо убедиться, что учетной записи (<имя домена\имя компьютера>$), под которой работает сервер, выданы права доступа - Сервер обработки.

Далее описан процесс настройки Сервера Обработки.

Collapsed Запуск Сервера Обработки

Для того чтобы запустить Сервер Обработки необходимо:

  1. Запустить Монитор Сервера Обработки (Пуск>Программы>ABBYY FlexiCapture Servers>Сервер Обработки).
  2. В дереве сервера выбрать Серверы ABBYY FlexiCapture, вызвать контекстное меню и выбрать команду Добавить сервер…
  3. В диалоге Добавить сервер обработки указать расположения сервера (Сетевой хост или Локальный хост).
  4. Открыть диалог Свойства сервера обработки (Действия>Свойства) и указать путь к Серверу Приложений (http://server). Если Сервер Обработки и Сервер Приложений установлены на одном компьютере, его имя должно быть указано прямо: использование IP-адреса 127.0.0.1 или выражения localhost сделает невозможным работу станций обработки.

    Замечание. На Сервере Приложений необходимо с помощью Консоли администрирования и мониторинга присвоить компьютеру, на который установлен Сервер Обработки, соответствующую роль).

  5. Запустить Сервер Обработки по кнопке [image].

    Замечание. Предусмотрено два режима остановки Сервера Обработки: немедленная и "мягкая". Если по каким-либо причинам вам требуется остановить Сервер Обработки (например, при обновления оборудования или переноса базы данных), вы можете выполнить "мягкую" остановку. Для этого выберите пункт Остановить в меню Действия. При выборе "мягкой" остановки выполняется завершение текущих заданий, после чего Сервер Обработки останавливается. Новые задания при этом не берутся.
    Для немедленного завершения работы Сервера Обработка выберите пункт Остановить немедленно. При этом текущие задания будут завершены неуспешно.

Collapsed Запуск Станций Обработки

Для того чтобы настроить станции обработки необходимо:

  1. В дереве сервера обработки выбрать Станции и нажать кнопку [image], в открывшемся диалоге Добавление станций выбрать станцию из списка всех компьютеров. Также можно указать имя компьютера или его IP-адрес. Имя компьютера можно указывать и при использовании динамических IP-адресов. IP-адреса можно использовать в том случае, если возникают проблемы с доступом к DNS сети.
  2. Открыть диалог Свойства станции с помощью пункта Действия>Свойства главного меню и указать параметры станции:
    • Имя - отображаемое имя станции;
    • Автоматический запуск - признак запуска станции автоматически Сервером Обработки. По умолчанию данная опция отмечена;

      Замечание. Частые попытки запуска большого количества станций могут привести к значительному замедлению работы Сервера Обработки;

    • Требуется места на диске - минимальное количество дискового пространства для работы станции обработки. Если доступного пространства станет меньше, станция будет остановлена. Минимальное значение, которое может быть указано в этом поле, должно превышать утроенный максимальный размер изображения, встречающегося в обработке. Оптимальное значение этого параметра соответствует удвоенному максимальному размеру пакета, встречающегося в обработке;
    • Максимальное количество процессов - максимальное количество ядер, которые можно использовать для обработки заданий;
    • Допустимое количество процессов - допустимое количество ядер для обработки заданий. Данный параметр рассчитывается автоматически в зависимости от параметров компьютера и используемой лицензии, и не может быть изменен;
    • Приоритет - приоритет процесса обработки;
    • Допустимые типы заданий - типы заданий, которые может обрабатывать станция:
      • Импорт изображений - задания импорта
      • Распознавание страниц - распознавание и предобработка экспорта
      • Поддержка верификации - слияние результатов двойной верификации, а также пред- и постобработка заданий для Web-станции верификации и Web-станции верификации данных.
      • Пользовательская обработка - обработка скриптов обработки пакета и документа
      • Экспорт документов - задания отправки документов
  3. Запустить станцию вручную по кнопке [image] или дождаться автоматического запуска станции (если отмечена опция Автоматический запуск, станция должна запуститься автоматически в течение минуты).

    Замечание. Предусмотрено два режима остановки Станции Обработки: немедленная и "мягкая". Если по каким-либо причинам вам требуется остановить Станцию Обработки (например, при обновления оборудования), вы можете выполнить "мягкую" остановку. Для этого выберите пункт Остановить в меню Действия. При выборе "мягкой" остановки выполняется завершение текущих заданий, после чего Станция Обработки останавливается. Новые задания при этом не берутся.
    Для немедленного завершения работы Станции Обработка выберите пункт Остановить немедленно. При этом текущие задания будут завершены неуспешно.

Замечание. Права на обработку документов станциям выдает Сервер Обработки при подключении.

Collapsed Включение Горячих папок проекта

Для того чтобы включить Горячие папки проекта необходимо:

  1. в дереве сервера обработки выбрать Горячие папки
  2. в списке всех проектов выбрать нужный
  3. и в контекстном меню выбрать команду Подключить.

    Замечание. В проекте необходимо отметить опцию Проверять Горячую папку каждые N секунд.

Collapsed Настройка журнала Сервера обработки

Для настройки журнала Сервера обработки необходимо:

  1. открыть диалоговое окно Настройки монитора сервера обработки, выбрав в главном меню пункт Файл>Настройки…
  2. указать, какие именно сообщения должны отображаться в журнале (Ошибки, Предупреждения, Информационные сообщения).
  3. указать, необходимо ли удалять информацию о завершенных заданиях, с помощью опции Убирать завершенные задания из списка.
  4. указать, при наличии каких сообщений необходимо сохранять информацию о задании в журнале.

    Замечание. Отключать опцию Убирать завершенные задания из списка в рабочем режиме нежелательно: это может привести к накоплению большого объема данных и значительному замедлению работы монитора Сервера Обработки. Рекомендуется отключать эту опцию только при настройке и отладке комплекса.

  5. Для просмотра лога задания нажмите [image]. Чтобы сохранить лог задания в формате *.txt, в открывшемся диалоге нажмите кнопку Экспортировать…
Collapsed Просмотр информации о заданиях

Для просмотра информации о заданиях выберите в дереве сервера обработки Задания. Для каждого задания отображается следующая информация: название, время начала, ход выполнения, статус задания, приоритет и имя рабочей станции. Задания, выполненные неуспешно, отмечены значком [image]. Если, помимо сообщений об ошибках, лог также содержит информационные сообщения, задание отмечено значком [image].

Collapsed Технический журнал работы

Помимо журнала обработки заданий, Сервер обработки и Станция обработки могут вести технический журнал работы службы. Этот журнал может понадобиться для анализа работы комплекса при обращении в техническую поддержку компании ABBYY. Ведение журнала не приводит к замедлению работы сервера или станции, но информация, содержащаяся в нем, предназначена для анализа сотрудниками компании ABBYY, поэтому в обычном режиме работы включать журналирование не рекомендуется. Если сотрудник технической поддержки компании попросит выслать технические журнальные файлы с информацией о работе Сервера обработки или Станции обработки, выполните следующие действия:

  1. Откройте окно Свойства сервера обработки (пункт Свойства контекстного меню сервера) или Свойства станции обработки (пункт Свойства контекстного меню станции) в зависимости от запрошенной информации.
  2. Отметьте опцию Вести журнал обработки и нажмите кнопку ОК.
  3. После формирования журнальных файлов скопируйте их из каталога %programdata%\ABBYY\FlexiCapture\11.0\FlexiBrSvc\Logs и отправьте в техническую поддержку компании ABBYY.
  4. Отключите ведение технического журнала работы службы, очистив опцию Вести журнал обработки и нажав кнопку ОК.
Collapsed Управление Сервером обработки с помощью командной строки

Для Сервера обработки предусмотрен режим управления с помощью командной строки. Для работы через командную строку выполните следующие действия:

  • В меню Windows Пуск -> Выполнить наберите 'cmd' и нажмите OK. Появится окно командной строки;
  • Введите путь к файлу FlexiBRSvc.exe (по умолчанию, "C:\Program Files\ABBYY FlexiCapture 11 Servers");
  • Наберите "FlexiBRSvc Please obey" для входа в командный режим. Команды вводятся в виде 'FlexiBRSvc Please <command>'. С помощью команд вы можете запустить или остановить станцию, отобразить список станций, остановить или запустить Сервер обработки, добавить или удалить станции, просмотреть информацию о станции, включить или отключить горячие папки, а также указать параметры сервера и станции;
  • Для отображения списка разрешенных команд и другой справочной информации, наберите 'FlexiBRSvc.exe /?'.


Удаленная станция Верификации

Так же, как и локальная станция Верификации, удаленная станция Верификации предназначена проверки распознанных данных, обработки проблемных пакетов (документов), проверки ошибок сборки, правил, целостности пакета.

Отличие удаленной станции Верификации от локальной состоит в том, что удаленная станция Верификации не поддерживает фоновые процессы, такие как импорт, распознавание и экспорт. Таким образом, операции, которые включают фоновые процессы, могут выполняться только на локальной станции Верификации.

Наложение определений документов на удаленной станции верификации

Удаленная станция Верификации позволяет накладывать определения документа на документы и страницы. Для того чтобы изменить определение документа, в контекстном меню документа или страницы выберите пункт Наложить определение документа…. При этом документ помечается на обработку и в комментариях на отправку отображается имя нового определения документа. Для того чтобы отменить наложение нового определение документа, в контекстном меню выберите первоначальное определение документа, используя пункт Наложить определение документа… в контекстном меню документа или страницы.

При необходимости вы также можете пометить страницу как страницу-приложение. Для этого в контекстном меню страницы выберите пункт Установить страницу как приложение.

Для очистки результатов распознавания документа или отдельной страницы выберите в контекстном меню пункт Очистить результаты анализа.

После закрытия задания все документы, определение которых было изменено (либо новое определение документа было наложено на страницы документов), отправляются на перераспознавание. После перераспознавания маршрутизация документов выполняется по стандартной схеме (также относится к документам, которые ранее были помечены на отправку на определенный этап или отправлены на этап вручную).

Замечание. Документы, определение которых было изменено, а затем возвращено первоначальное определение документа, не будут отправлены на перераспознавание и дальнейшая обработка будет выполняться в соответствии с ранее заданной схемой маршрутизации.


Станция Верификации

Станция Верификации предназначена для более сложной проверки, чем Станция Верификации Данных. Помимо проверки распознанных данных, станция позволяет обрабатывать проблемные пакеты (документы), осуществлять проверку ошибок сборки, правил, целостности пакета. Станция Верификации может работать как в локальной сети, так и удаленно, через Интернет, авторизация при этом осуществляется с помощью логина и пароля. Подробнее см. Удаленная станция Верификации.

На Станции Верификации могут работать операторы: Оператор Верификации Данных, Оператор Верификации, Старший Оператор Верификации. В зависимости от Роли, под которой зашел оператор, он может видеть и обрабатывать задания только из определенных очередей:

  • Оператор Верификации Данных может обрабатывать задания только из очереди Верификация данных;
  • Оператор Верификации может обрабатывать задания со всех этапов, кроме Исключений и Подтверждения экспорта;
  • Старший Оператор Верификации может обрабатывать задания из всех очередей. Помимо списка очередей, Старшему Оператору Верификации доступен определенный список пакетов (см. описание ниже), а также вид просмотра каждой очереди, который позволяет выбрать конкретную задачу в очереди.

Замечание. Администратор может создать дополнительные этапы обработки и соответствующие им очереди. Доступ к этим очередям также определяется ролью оператора и назначенными ей Администратором правами доступа.

Замечание. Список доступных ролей зависит от прав оператора. Если оператору доступна только одна роль, список ролей показываться не будет.

Очереди, доступные для обработки на Станции Верификации.

  • Любая

    Из этой очереди оператор станции может взять задание, сформированное в любой очереди. Список доступных очередей зависит от Роли, под которой оператор зашел на станцию. Задания берутся в порядке заданного приоритета.

  • Верификация Данных

    Процесс проверки данных начинается с групповой верификации, за ней следует контекстная. Если в определении документа нет полей включенных в групповую или контекстную верификацию, то документ не попадет в очередь на верификацию.

  • Проверка сборки документов

    Для многостраничных документов нужно исправить возможные ошибки сборки документов. Правило сборки документа задается при создании определения документа и определяет порядок следования и количество повторений страниц. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа. При несовпадении оператор увидит сообщение об этом и значения ключевых полей будут отображены красным цветом. Ошибки сборки удобнее всего исправлять в режиме эскизов страниц, т.к. оператор хорошо видит изображения страниц и их принадлежность к документам.

  • Верификация

    В случае, если параметрами обработки не определены отдельные очереди, в очередь на Верификацию попадают все задания с ошибками сборки документов, проверки данных и правил.

  • Проверка целостности пакета

    Правила, задающие проверку целостности пакета, устанавливают связь между данными документов пакета и служат для проверки этих данных.

  • Подтверждение экспорта

    Запуск экспорта данных может происходить в двух режимах - автоматическом и ручном. В случае, если параметрами обработки не определена отдельная очередь для подтверждение экспорта, документы экспортируются в автоматическом режиме. Если отдельная очередь определена, то Старший Оператор Верификации сначала должен проверить документы в задании, после чего они отправляются на Экспорт. В случае возникновения ошибок при экспорте, документы автоматически попадут в очередь Исключений.

  • Исключения

    В очередь исключений попадают проблемные пакеты (документы), которые операторы или станции по каким-то причинам не смогли обработать.

Замечание. Параметры обработки документов (использование отдельных очередей) настраиваются для Типов Пакетов или на проект, если типы пакетов не создаются.

Для того, чтобы выполнить задание, в списке очередей необходимо выбрать нужную и нажать на кнопку [image]. При этом будет сформировано задание из текущей очереди.

При необходимости можно включить режим автоматического получения заданий, нажав кнопку [image] или выбрав в меню пункт Задания>Получать задания автоматически.

Просмотр документов задания на Станции Верификации возможен в режимах Детали и Эскизы страниц. В режиме Детали отображаются только документы текущего задания. В режиме Эскизы страниц отображаются все страницы пакета, при этом страницы, не входящие в текущее задание, выделены серым.

Помимо списка очередей с заданиями Старшему оператору верификации также доступен список пакетов данного проекта, определяемый заданными в Консоли администрирования и мониторинга правами доступа оператора к типам пакетов. Для просмотра списка доступных пакетов необходимо выбрать пункт меню Вид>Пакеты или нажать соответствующую кнопку на панели инструментов.

В режиме просмотра пакетов оператору доступна информация об уверенности распознавания пакета, количестве страниц и документов, типе пакета и т.д. Выделив мышью пакет из списка, можно отправить его на любой этап обработки, задать приоритет, выбрать конкретного пользователя, который будет обрабатывать данный пакет, и дополнить комментарием. Таким образом можно собрать документы пакета, находящиеся в различных очередях обработки, и отправить их на один этап.

С помощью двойного щелчка можно открыть пакет для просмотра списка документов, верификации данных, исправления ошибок правил, сборки и т.д. Выделив мышью один или несколько документов, можно пометить выборочные документы для отправки на какой-либо этап обработки, сформировать для них отдельное задание.

Для того чтобы пометить выбранные документы для отправки в исключения, на пересканирование или на произвольный этап, выберите соответствующий пункт в меню Задание либо в контекстном меню документа. В открывшемся диалоговом окне вы можете ввести комментарий или выбрать комментарий из списка Последние комментарии. Для выбора доступны последние 10 комментариев к отправленным заданиям. Если вам требуется изменить текст комментария из списка, выберите нужный комментарий, нажмите ОК и отредактируйте комментарий в поле ввода. Если какой-либо комментарий используется редко, его можно удалить.
Список комментариев хранится в системном реестре в ветке

[HKСU\Software\ABBYY\FlexiCapture\11.0\Shell\Stages\RecentStageCommentList]

Комментарии в строке разделяются запятой. Если текст комментария содержит запятую, то запятая записывается как «/,». Символ перехода на новую строку «/» записывается как «//». Многострочный комментарий будет отображаться как одна строка, разделенная пробелами. В тексте комментария допускается использование любых символов.

Таким образом, всем пользователям FlexiCapture, работающим на локальной станции Верификации в рамках сессии одного Windows-пользователя, будет доступен один и тот же список комментариев.

При отправке документов на повторное сканирование вы также можете выбрать оператора, которому будет назначено задание. По умолчанию выбран оператор, выполнявший сканирование данного документа. Если этот оператор не обладает необходимыми правами либо изображения были импортированы из горячей папки, в качестве оператора будет указан пользователь "Any".

Документы, помеченные для отправки, будут отправлены на соответствующие этапы обработки при закрытии задания.

Замечание. При отправке пакетов на этапы, следует проверять, что документы пакета не входят в уже сформированные задания, так как иначе будут созданы пустые задания. Проверить, входит ли документ в задание, можно в столбце ID задания документа.


Создание пакетов документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

Если в проекте нет ни одного пакета, то при попытке добавления изображений пакет будет создан программой автоматически.

Чтобы создать новый пакет выберите пункт Новый пакет… контекстного меню, главного окна со списком пакетов.

При формировании пакета указывается его тип, определяющий порядок обработки пакета.

Подробнее о создании пакетов документов


Создание типов пакетов документов

Обработка документов осуществляется пакетным образом. Пакеты создаются при импорте или сканировании документов. При этом каждому пакету присваивается определенный тип.

Тип пакета определяет следующие параметры обработки документов:

  • способ предварительной обработки изображений;
  • наложение определений документов;
  • проверка целостности пакета;
  • экспорт пакета по умолчанию;
  • процесс обработки пакета.
Типы пакетов
Создание пакетов документов


Экспорт

Для того чтобы выполнить экспорт распознанных и верифицированных документов, достаточно нажать на кнопку Экспортировать. Экспорт будет выполнен согласно настройкам, заданным в определении документа.

Если вы хотите выполнить экспорт в файл, нажмите стрелку справа от кнопки и выберите пункт меню Экспортировать данные в файлы…

Если вы хотите экспортировать изображения в файл, нажмите стрелку справа от кнопки и выберите пункт меню Экспорт изображений в файлы

Для экспорта в базу данных выберите пункт меню Экспортировать в базу данных…

При необходимости измените настройки экспорта, используемые по умолчанию, и выполните экспорт.

Подробнее об экспорте


Создание профилей импорта

Оператор начинает работу с добавления в проект новых изображений: это могут быть бумажные документы, которые он должен отсканировать, или уже имеющиеся электронные изображения.

Часто выполняемые действия по добавлению регулярно поступающих из одного и того же места изображений можно автоматизировать, тогда импорт будет производиться нажатием одной кнопки. Для этого нужно создать профиль импорта изображений. Кроме того, можно настроить параметры обработки поступающих изображений и периодическое добавление изображений в фоновом режиме. Если произведены необходимые настройки, то при нажатии одной кнопки выполняется сканирование или импорт из заранее настроенного источника, а полученные изображения обрабатываются (например, очищаются от «мусора»). При желании пользователь может сменить источник ввода изображений или его настройки.

В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

Чтобы добавить профиль импорта, выберите пункт меню Проект > Профили импорта изображений… главного окна программы. В открывшемся диалоге вы можете создавать новые профили импорта, редактировать, удалять и копировать существующие профили.

Подробнее о создании профилей импорта


Обзор создания определения документа

Создание определения документа – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Определение документа определяет расположение элементов документа, указывает, откуда будут извлечены данные.

Для начала создания любого определения документа, нужно запустить Мастер создания определения документа, для этого:

  1. В главном меню Станции Настройки Проектов выберите пункт Проект>Определения документов…
  2. В открывшемся диалоге Определения документов… нажмите кнопку Новое…
  3. Следуйте инструкциям Мастера создания определения документа.

Основные этапы создания определения документа зависят от типа обрабатываемых документов.

Collapsed Основные этапы создания определения документа для жестких форм
  1. Создание нового определения документа с помощью Мастера создания определения документа. В процессе работы Мастера нужно открыть изображение страницы документа, на основе которого будет произведена разметка определения.
  2. Разметка статических элементов - реперов и идентификаторов, задание их свойств. Статические элементы используются для наложения определения документа и идентификации. Статические элементы обычно выделяются автоматически и им присваиваются свойства по умолчанию.
  3. Разметка полей на изображении. Поля используются для извлечения данных.
  4. Задание свойств полей. Свойства полей влияют и на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку, определяют типы данных и область значений поля.
  5. Для создания определения многостраничных документов: добавление страниц и повторение всех этапов для каждой страницы.
  6. Настройка экспорта данных.
  7. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  8. Тестирование определения на изображениях нескольких документов.

Замечание. Если вы создавали машиночитаемые формы с помощью программы ABBYY FormDesigner, то вместо первых трех этапов достаточно импортировать файл с расширением *.xfd. Откроется изображение страницы с готовой разметкой (или нескольких страниц, если в программе ABBYY FormDesigner была создана многостраничная форма). Подробнее см. Импорт определения для форм, созданных в программе ABBYY FormDesigner.

Collapsed Основные этапы создания определения для гибких документов
  1. Создание гибкого описания (файл *.afl) с помощью программы ABBYY FlexiLayout Studio. Подробнее см. справку программы ABBYY FlexiLayout Studio.
  2. Создание нового определения документа с помощью Мастера создания определения документа. В процессе работы Мастера нужно открыть изображение страницы документа и подключить гибкое описание (созданный файл *.afl). После завершения работы мастера разметка полей уже будет присутствовать на изображении.
  3. Задание свойств полей. Производится аналогично заданию свойств в описании для жестких форм.
  4. Настройка экспорта данных.
  5. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  6. Тестирование определения на изображениях нескольких документов.

Для документов смешанного типа, содержащих как страницы с жесткими формами, так и полуструктурированные разделы, можно подключить гибкое описание в качестве одного из разделов определения документа. Начните создание определения с любого раздела (гибкого или жесткого), а затем добавьте новый раздел другого типа.

Документы разных типов можно обрабатывать в одном потоке: в одном проекте можно создать определения и для жестких форм, и для гибких документов, и определения для документов смешанного типа. Определение выбирается программой автоматически.

Для обработки документов с приложениями создайте определение документа, а затем в свойствах определения отметьте опцию Допускать страницы приложений. Cм. Создание определений для документов с приложениями.

Подробнее о создании определений документов


Меню станции верификации данных

Collapsed Файл
Пункт меню | Описание
Открыть проект на сервере… | Позволяет открыть существующий проект на сервере приложений
Закрыть проект | Закрывает текущий проект
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCapture
Collapsed Вид
Пункт меню | Описание
Панели инструментов | Позволяет отобразить/спрятать панели инструментов
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Collapsed Задания
Пункт меню | Описание
Получить задание | Получает задание из выбранной очереди
Показывать комментарий к заданию | Позволяет показывать комментарий к заданию
Отменить задание | Отменяет текущее задание и возвращает его на сервер приложений
Отправить задание в Исключения… | Отправляет текущее задание в Исключения
Получать задания автоматически | Включает/выключает режим автоматического получения заданий
Collapsed Сервис
Пункт меню | Описание
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Collapsed Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 11, содержащий краткую информацию о программе.


Панели инструментов станции верификации данных

Collapsed Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание из выбранной очереди.
Отправить задание в Исключения… |  | Отправляет задание в Исключения.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию в главном окне
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Главное окно станции верификации данных

В главном окне программы отображается наименование очереди, из которой берутся задания (очереди верификации данных).

После получения задания в окне последовательно открываются окна групповой и контекстной верификации.

В верхней части окна располагается меню, под ним – инструментальные панели.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Меню станции верификации данных
Панели инструментов станции верификации данных


Окно редактора кода скрипта

В редакторе кода скрипта пользователь может написать и отредактировать скрипт.

Доступны следующие языки для написания скриптов: VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net или JScript.Net. Выбранный язык запоминается и будет устанавливаться при следующем запуске редактора автоматически.

Проверка скрипта

Запустить проверку написанного кода можно с помощью команды Проверить одним из следующих способов:

  • кнопка F9;
  • кнопка Проверка на панели инструментов;
  • меню Сервис → Проверить скрипт.

Если проверка скрипта завершилась успешно, будет выведено сообщение Скрипт корректный.

Если скрипт содержит ошибки, список ошибок будет выведен в окне ошибок. При двойном щелчке по тексту сообщения ошибки курсор в редакторе скрипта переходит на позицию с ошибкой.

Замечание. Программа позволяет сохранить скрипт с ошибками с целью дальнейшей отладки скрипта.

По умолчанию окно с сообщениями об ошибках открывается в нижней части окна редактора. Изменить размер окна можно с помощью мыши. Как изменить положение окна ошибок - см. ниже.

Внешний вид редактора

С помощью команд меню Вид пользователь может настроить внешний вид редактора скриптов по своему усмотрению, а именно:

  • Окно ошибок - задать расположение окна ошибок в редакторе: сверху, снизу (по умолчанию), слева, справа.
  • Панель инструментов - скрыть/отобразить панель инструментов.
  • Строка состояния - скрыть/отобразить строку состояния.

Добавление пользовательской функции

Для добавления пользовательской функции выберите доступный глобальный модуль в выпадающем списке на панели инструментов: Скрипт в <имя_объекта\имя_описания>, Модуль для правил, Модуль для экспорта

Более подробную информацию о скриптах в ABBYY FlexiCapture можно найти в разделе Использование скриптов.


Меню станции верификации

Collapsed Файл
Пункт меню | Описание
Открыть проект на сервере… | Позволяет открыть существующий проект на сервере приложений
Закрыть проект | Закрывает текущий проект
Сохранить | Сохраняет изменения на сервере
Загрузить изображения… | Позволяет загрузить изображения из файлов
Сканировать изображения… | Позволяет добавить изображения путем сканирования
Экспортировать в |
файлы данных… | Позволяет экспортировать данные в файл
файлы изображений… | Позволяет экспортировать изображения в файлы
базу данных… | Позволяет экспортировать данные в базу данных
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCapture
Collapsed Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Объединить | Объединяет выделенные страницы в один документ
Разделить | Разделяет выделенный документ на страницы
Выделить все | Выделяет все
Найти… | Позволяет найти заданный текст
Найти следующий | Позволяет найти следующий ранее заданный текст
Перейти |
К следующему документу | Позволяет перейти к следующему документу в пакете
К предыдущему документу | Позволяет перейти к предыдущему документу в пакете
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Перевернуть горизонтально | Переворачивает изображение горизонтально (относительно вертикальной оси)
Перевернуть вертикально | Переворачивает изображение вертикально (относительно горизонтальной оси)
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Изменить разрешение… | Изменяет разрешение изображения
Сохранить как… | Позволяет сохранить изображение с указанным именем
Collapsed Вид
Пункт меню | Описание
Рабочие пакеты | Открывает список пакетов
Очереди | Открывает список очередей
Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Настройка столбцов… | Позволяет настроить список столбцов, отображаемых в детализированном списке
Редактор документа |
Изображение | Показывает изображение страницы в окне документа
Данные | Показывает распознанные данные в окне документа
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения страниц документов
Размер текста данных | Позволяет выбрать размер шрифта для отображения распознанных данных
Показать панель инструментов | Позволяет показать/спрятать панель инструментов в окне документа. Эта панель инструментов позволяет исправить некоторые ошибки наложения, например, дорисовать не найденное поле, добавить или удалить разделитель таблицы. Такая возможность используется, в основном, при работе с гибкими описаниями.
Показать ошибки формата | Позволяет указать способ отображения ошибок формата
Отображать в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц документа в черно-белом режиме
Размер эскизов | Позволяет выбрать размер эскизов страниц
Панели инструментов | Позволяет отобразить/спрятать панели инструментов
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Collapsed Распознавание
Пункт меню | Описание
Проанализировать | Анализирует страницы документов, подбирая для них подходящее определение
Наложить определение документа… | Производит наложение выбранного пользователем определения на выделенный документ или страницу
Распознать | Запускает процесс распознавания
Collapsed Задания
Пункт меню | Описание
Получить задание | Получает задание из выбранной очереди
Закрыть задание | Закрывает текущее задание и возвращает его на сервер приложений как выполненное
Показывать комментарий к заданию | Позволяет показывать комментарий к заданию
Отменить задание | Отменяет текущее задание и возвращает его на сервер приложений
Отложить задание… | Откладывает текущее задание для последующей обработки
Отправить |
в Исключения... | Отправляет текущее задание в Исключения
на Повторное сканирование... | Отправляет текущее задание на Повторное сканирование
этап обработки... | Отправляет текущее задание на выбранный этап обработки. Отправка заданий на этапы, отличные от этапа Исключений и Повторного сканирования, доступна только для роли типа Старший Оператор Верификации.
Пометить документы для отправки |
в Исключения... | Помечает выбранные документы для отправки в Исключения. При закрытии задания отмеченные задания будут отправлены на этап.
на Повторное сканирование... | Помечает выбранные документы для отправки на Повторное сканирование. При закрытии задания отмеченные задания будут отправлены на этап.
этап обработки... | Помечает выбранные документы для отправки на выбранный этап обработки. При закрытии задания отмеченные задания будут отправлены на этап. Отправка заданий на этапы, отличные от этапа Исключений и Повторного сканирования, доступна только для роли типа Старший Оператор Верификации.
Добавить документы к помеченным… | Добавляет выбранные документы к уже помеченным документам. В открывшемся диалоговом окне выберите нужный этап обработки из списка ранее выбранных этапов.
Удалить пометку к отправке | Удаляет выбранные документы из списка документов, помеченных для отправки
Пометки к отправке… | Открывает диалоговое окно Пометки к отправке, где вы можете просмотреть список отметок, удалить выбранную отметку или изменить комментарий
Получать задания автоматически | Включает/выключает режим автоматического получения заданий
Получить весь пакет в задание | Если оператору назначена роль, права доступа которой позволяют редактировать пакеты, то в режиме просмотра пакетов оператор может взять открытый пакет на редактирование. Команда доступна, если хотя бы один документ пакета принадлежит заданию. Если все документы принадлежат одному заданию, открывает это задание. Если документы принадлежат разным пакетам, создает задание для пакета на этапе Исключений.
Edit document | Если оператору назначена роль, права доступа которой позволяют редактировать документы, то в режиме просмотра документов пакета оператор может взять открытый документ на редактирование. Команда доступна, если хотя бы один из выделенных документов принадлежит заданию. Если выделенные документы принадлежат одному заданию, открывает это задание. Если документы принадлежат разным заданиям, выполняет редактирование всего пакета и создает задание для этого пакета на этапе Исключений.
Свойства задания… | Открывает диалоговое окно Свойства задания, где вы можете просмотреть информацию о задании: идентификатор задания, время создания, приоритет и др.
Collapsed Верификация
Пункт меню | Описание
Начать верификацию… | Запускает процесс верификации
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет переход к предыдущему объекту верификации
Следующий документ с ошибками сборки | Осуществляет переход к следующей ошибке сборки
Предыдущий документ с ошибками сборки | Осуществляет переход к предыдущей ошибке сборки
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Collapsed Сервис
Пункт меню | Описание
Изменить приоритет документа | Позволяет изменить приоритет обрабатываемых документов. Доступный значения: Самый низкий, Низкий, Обычный, Высокий, Самый высокий.
Обновить до последней версии | Применяет изменения в проекте к обрабатывающимся в данный момент документам
Повторный анализ | Производит повторный анализ документов
Повторное распознавание | Производит повторное распознавание документов
Обновить сборку | Обновляет сборку страниц в документы
Перепроверить правила | Производит повторную проверку правил
Проверить целостность пакета | Производит проверку целостности пакета
Изменить приоритет пакета | Позволяет выбрать приоритет пакета
Изменить тип пакета… | Изменяет тип пакета
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Collapsed Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 11, содержащий краткую информацию о программе.


Панели инструментов станции верификации

Collapsed Стандартная панель инструментов

Название | Кнопка | Описание
Открыть проект |  | Позволяет открыть другой проект
Сохранить изменения |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Collapsed Представления документов

Название | Кнопка | Описание
Детали |  | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц |  | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Список тестовых пакетов |  | Позволяет перейти к списку тестовых пакетов
Список рабочих пакетов |  | Позволяет перейти к списку рабочих пакетов
Обновить |  | Обновляет информацию в главном окне
Collapsed Навигация

Название | Кнопка | Описание
Предыдущий объект верификации |  | Осуществляет переход к предыдущему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Следующий объект верификации |  | Осуществляет переход к следующему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Предыдущий документ |  | Осуществляет переход к предыдущему документу.
Следующий документ |  | Осуществляет переход к следующему документу.
Collapsed Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание из выбранной очереди.
Закрыть задание |  | Возвращает задание на сервер.
Пометить документы для отправки в исключения |  | Помечает задание для отправки в исключения (для старшего оператора верификации - на выбранный этап обработки). При закрытии или отмене задания, программа предлагает отправить отмеченные документы в исключения.
Пометить документы для отправки на повторное сканирование |  | Помечает документ для отправки на повторное сканирование. При закрытии или отмене задания, программа предлагает отправить отмеченные документы на повторное сканирование.
Снять отметку |  | Снимает отметку с выделенного документа, отмеченного для отправки.
Отложить задание… |  | Откладывает задание для обработки позднее.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Главное окно станции верификации

В верхней части главного окна программы располагается меню, под ним – инструментальные панели. В нижней части окна расположена информационная панель (строка состояния). В информационной панели пользователь может просмотреть сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбранных пунктах меню и кнопках. Остальное пространство Главного окна занимает рабочее окно со списком очередей или документов.

Вид главного окна станции меняется в зависимости от выбранного режима работы: работа с пакетами или работа с очередью заданий.

Вид "Очередь"

В главном окне отображается список очередей, из которых выбираются задания для обработки.

Оператору верификации и Старшему оператору верификации доступно несколько очередей с заданиями.

В окне заданий отображается следующая информация:

Число всех заданий – общее количество заданий данной очереди, автоматических и сформированных операторами, находящихся в обработке в текущий момент времени.

Максимальный приоритет – наивысший приоритет, присвоенный одному или нескольким заданиям данной очереди.

Персональных заданий – количество заданий, переданных на обработку данному оператору.

Число документов вне обработки – количество документов, которое требуется обработать в составе заданий, сформированных программой автоматически.

Число сформированных заданий – количество заданий, сформированных вручную операторами, например, при принудительной отправке в данную очередь документов в качестве отдельного задания (с использованием опции Сформировать задание в диалоге отправки).

Число пакетов вне обработки – количество пакетов, отправленных оператором вручную в данную очередь, без формирования отдельного задания.

Collapsed Показать главное окно со списком очередей

После получения задания в окне отображается список документов задания.

Collapsed Показать главное окно со списком документов

Вид "Пакеты"

В режиме просмотра пакетов выводится следующая информация о пакетах проекта: число документов и страниц в пакете, приоритет, число распознанных, верифицированных и проэкспортированных символов и т.д.

По умолчанию показываются все доступные оператору пакеты, кроме обработанных. На одной странице может отображаться до 500 пакетов. Для перехода по страницам используйте стрелки справа.

Фильтрация пакетов

Для проектов, которые хранятся на сервере обработки, пользователь может выполнить фильтрацию отображаемых пакетов. Для этого в выпадающем списке Показать необходимо выбрать признак, по которому будет происходить фильтрация, и задать параметры.

  • Все пакеты, кроме обработанных;
  • Пакеты на этапах… - фильтрация пакетов по стадии(ям) обработки;
    Collapsed Дополнительные опции фильтра
    • Только включенные этапы - при выборе опции в списке отобразятся только те этапы, которые включены в процесс обработки типов пакетов текущего проекта.
    • Показывать без пакетов процесса обработки - включение опции позволяет отобразить пакеты, которые не попали в процесс обработки. В данном случае невозможна фильтрация по выбранным типам пакета.
  • Пакет с префиксом имени… - фильтрация по префиксу имени пакета;
  • Пакет с ID… - фильтрация по ID пакета;
  • Пакет, содержащий документ с ID… - фильтрация по ID документа;
  • Пакеты, созданные за период… - фильтрация по периоду создания пакета. Допустимый диапазон дат - 02/01/1753-12/31/2100.
  • Пакеты выбранного типа… - фильтрация по типу пакетов;
  • Пакеты с определенным регистрационным параметром… - фильтрация по названию и значению регистрационных параметров типов пакетов. Возможна фильтрация одновременно по трем регистрационным параметрам.
    Collapsed Совет

    Пользователь может ввести название и значение регистрационного параметра вручную либо выбрать из предложенного списка. Выпадающий список Parameter содержит имена регистрационных параметров из всех типов пакетов, а также десять последних названий, введенных пользователем. Выпадающий список Value содержит десять различных значений регистрационных параметров, введенных пользователем.

  • Пакеты, отобранные с помощью… - расширенный поиск с использованием префикса имени пакета, типа пакетов, даты создания, регистрационных параметров и этапа (этапов).

При настроенном фильтре справа от выпадающего списка Показать выводится строковое сообщение с кратким указанием параметров фильтрации. Чтобы изменить параметры текущего фильтра, нажмите кнопку [image], выполните необходимые правки.

Меню станции верификации
Панели инструментов станции верификации


Дополнительные поля

Управление дополнительными полями инвойса осуществляется в свойствах определения документа. В главном меню редактора определения документа выберите Document Definition>Свойства определения документа…. В открывшемся диалоге перейдите на вкладку Настройки инвойсов и нажмите кнопку Правка… в группе Дополнительные поля и возможности.

В открывшемся диалоге Свойства инвойсов будут доступны дополнительные возможности обработки инвойсов. Каждая возможность может состоять из одного или нескольких полей инвойса, которые будут извлекаться с изображения, а также связанных ними правил.

Список дополнительных полей в диалоговом окне Свойства инвойсов:

  • Дата оплаты;
  • Дата доставки;
  • Имя покупателя;
  • Сравнение с заказом на поставку;
  • Извлечение позиций (использование должно быть разрешено вашей лицензией).

Каждая опция в диалоге имеет описание, в котором перечисляются поля, которые будут извлекаться с изображения.

Для включения опции необходимо в диалоге около её названия отметить галочку.

Для работы опции Сравнение с заказом на поставку необходимо также подключить базу данных заказов. См. "Проверка позиций инвойса".

Имена полей, связанных с отключенными опциями, отображаются в списке полей определения документа серым цветом. Их форма на форме данных в редакторе определения документа также окрашена в серый цвет, а в редакторе документа, т.е. в процессе верификации, такие поля не отображаются вовсе. При открытии диалога свойств таких полей выдаётся сообщение: Поле отключено его свойством.

Правила, связанные с отключенными опциями, также отображаются отключенными в списке правил определения документа.

После включения опции связанные с ней поля становятся полноценными полями определения документа, а правила включаются.


Обучение в ABBYY FlexiCapture for Invoices

ABBYY FlexiCapture for Invoices позволяет пользователю обучить программу предварительно или в процессе ввода инвойсов для повышения качества автоматической обработки инвойсов.

Обучение применяется исключительно на тех изображениях или в тех случаях, когда:

  • у преднастроенного определения документа возникли проблемы с нахождением правильного положения полей инвойса на изображении;
  • пользователь хочет извлекать с изображений новые поля, не предусмотренные по умолчанию определением документа ABBYY FlexiCapture for Invoices.
Collapsed Когда может потребоваться обучение

В потоке документов одного типа могут появляться специфичные документы с нетипичным расположением полей. Если в этом случае ABBYY FlexiCapture for Invoices не находит поля инвойса на изображении достаточно хорошо, пользователь может указать программе правильное расположение полей, после чего ABBYY FlexiCapture for Invoices «обучится» и станет находить поля на данной разновидности инвойсов более точно.

Наряду с базовыми и дополнительными полями, извлечение которых поддержано в ABBYY FlexiCapture for Invoices по умолчанию, пользователю может потребоваться извлекать новые поля, не предусмотренные программой. В этом случае в определении документа ABBYY FlexiCapture for Invoices пользователь может создать новые поля, а затем указать их расположение на изображениях инвойсов, после чего программа начнёт распознавать их автоматически.

Как правило, инвойсы определённой разновидности свойственны конкретному поставщику. Поэтому ABBYY FlexiCapture for Invoices обучается независимо на инвойсах от разных поставщиков. Инвойсы от разных поставщиков считаются разными разновидностями документа.

Collapsed Как работает обучение

Пользователь в процессе штатного ввода документов или в специальном режиме, предназначенном для обучения, добавляет изображения инвойсов. Они автоматически распознаются, после чего оператор их верифицирует. В процессе верификации пользователь исправляет разметку полей на изображении инвойса, указывая программе правильное расположение полей на изображении — создает эталонную разметку.

После этого пользователь может добавить данный документ в набор примеров для разновидности иновойсов, определяемой поставщиком. Администратор может видеть список всех разновидностей инвойсов и наборы примеров изображений документов для них в специальном виде — [image] Пакеты обучения. После того, как для разновидности добавлен первый пример документа, разновидность переходит в состояние накопления примеров.

Для обучения разновидности требуется не менее трех документов. Когда в наборе накопится достаточное количество изображений документов, при добавлении нового документа или по явной команде пользователя ABBYY FlexiCapture for Invoices запустит обучение на данной разновидности инвойсов.

Результатом процесса обучения является гибкое описание для разновидности, которое будет применяться для всех документов данной разновидности, т.е. для всех инвойсов от данного поставщика.

После обучения гибкое описание для разновидности автоматически, без каких-либо действий со стороны пользователя, тестируется программой — все документы из набора примеров изображений для данной разновидности распознаются с использованием создавшегося гибкого описания.

Качество гибкого описания для разновидности определяется путем сравнения результата распознавания с эталонной разметкой, заданной пользователем. Аналогичным образом качество определяется для основного гибкого описания, которое используется в ABBYY FlexiCapture for Invoices в отсутствии обучения. Затем качество гибкого описания для разновидности сравнивается с качеством предыдущей версии гибкого описания для разновидности, либо с качеством основного гибкого описания:

  • если качество гибкого описания для разновидности проигрывает в сравнении, то такое гибкое описание не сохраняется, а пользователю выдаются соответствующие разъяснения в окне Обучить определение документа;
  • если качество гибкого описания для разновидности оказывается выше, оно сохраняется и применяется при дальнейшей обработке документов данной разновидности, т.е инвойсов от данного поставщика.

Обучение в ABBYY FlexiCapture for Invoices происходит в процессе ввода документов. Пользователь добавляет в рабочий пакет изображения инвойсов, они автоматически распознаются, после чего оператор их верифицирует. В процессе верификации пользователь исправляет разметку полей на изображении инвойса, указывая программе правильное расположение полей на изображении. Далее пользователь нажимает кнопку [image], доступную в редакторе документа. При этом документ добавляется в набор для обучения разновидности документов, к которой он относится. Разновидность документов определяется компанией-поставщиком, от которой пришли инвойсы. Когда в наборе накопится достаточное количество изображений документов, при добавлении нового документа ABBYY FlexiCapture for Invoices запустит обучение на данной разновидности инвойсов, т.е. для данного поставщика. При дальнейшем вводе инвойсов от этого же поставщика будет применяться результат пользовательского обучения. Обучение в процессе ввода может быть разрешено не только администратору, но и операторам.

В случае, если обучение в процессе ввода документов не даёт ожидаемого результата, у администратора есть возможность перейти в специальный вид — [image] Пакеты обучения и продолжить обучение там. Администратор может:

  • управлять набором документов для разновидности: добавлять новые документы, исключать нетипичные для разновидности документы;
  • создавать новые пакеты обучения;
  • добавить в набор документов для разновидности примеры документов, которые не участвуют в обучении, но применяются для автоматического тестирования гибкого описания для разновидности, получившегося в результате обучения;
  • выгрузить результат обучения — гибкое описание для разновидности в программу ABBYY FlexiLayout Studio, а также загрузить гибкое описание для разновидности, созданное в программе ABBYY FlexiLayout Studio.

Данные возможности помогают администратору достичь максимального эффекта от обучения, после чего администратор может, например, запретить дальнейшее обучение данной разновидности документов в процессе ввода.

См. "Обучение в процессе ввода инвойсов"

См. "Обучение настройщиком проекта"


Дополнительные возможности работы операторов

Администратор может дать операторам, которые будут вводить инвойсы, дополнительные возможности. Стоит отметить, что у пользователя с ролью администратор эти возможности будут всегда. Задаваемые настройки будут изменять поведение только для пользователей с ролями, отличными от администратора.

Обучение в процессе ввода инвойсов

Если ABBYY FlexiCapture for Invoices автоматически извлекает поля с недостаточным качеством, например, на инвойсах со специфическим расположением полей оператор может дообучить программу прямо в процессе ввода инвойсов.

Для этого оператору будет необходимо указывать правильное расположение полей на изображении и нажимать кнопку [image]. После того, как наберётся хотя бы три изображения данной разновидности инвойса, программа выполнит обучение, и последующие инвойсы данной разновидности будут обрабатываться с использованием результатов обучения. Подробнее См. "Обучение в ABBYY FlexiCapture for Invoices".

По умолчанию данная возможность разрешена операторам. Чтобы её запретить:

  1. В главном меню редактора определения документа выберите Определение документа>Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Настройки инвойсов.
  3. Нажмите кнопку Правка… справа от группы Дополнительные поля и возможности. Откроется окно Свойства инвойсов.
  4. Снимите галочку с позиции Обучение во время обработки инвойсов.

В случае, если такую возможность операторам надо, наоборот, предоставить — отметьте галочку для данной позиции.

Редактирование существующих и добавление новых записей о поставщиках и получателях

В процессе настройки проекта для ввода инвойсов вы подключали базы данных поставщиков и получателей к соответствующим Наборам данных проекта. Эти Наборы данных не только задают структуру данных, но и хранят копию данных внутри проекта, периодически синхронизируя данные с вашей внешней базой. См. "Подключение справочников поставщиков и подразделений компаний".

Процесс распознавания инвойса начинается с нахождения поставщика и получателя. Во-первых, данные группы полей могут быть найдены на изображении только тогда, когда они есть в Наборе данных. Во-вторых, найти эти поля крайне важно, т.к. по ним определяется страна инвойса, а следовательно налоговые ставки, которые используются для поиска группы полей Amounts на изображении, и система правил для автоматической валидации инвойса. Таким образом, находить поставщика и получателя на инвойсе автоматически очень важно для дальнейшей обработки.

Как правило, все поставщики и получатели уже содержатся в соответствующих Наборах данных. Но если инвойс пришел от нового поставщика, которого не было в вашей базе данных поставщиков, на таком инвойсе группа полей Поставщик найдена не будет. Бизнес-процесс по заведению нового поставщика в базу поставщиков предприятия и последующая синхронизация базы поставщиков с Наборами данных могут занять много времени, а всё это время инвойсы от нового поставщика могут поступать в обработку.

Другой пример, когда у уже известного поставщика меняется номер счёта или адрес. В этом случае также до обновления информации в базе данных и в Наборе данных может пройти много времени, а оператору необходимо вводить инвойсы, опираясь на актуальную информацию.

Для оперативного разрешения подобных ситуаций администратор может дать операторам возможность изменять данные или заводить новые записи в Наборах данных поставщиков и получателей (именно те данные, которые хранятся внутри проекта ABBYY FlexiCapture, но не в реальных внешних базах поставщиков и получателей!).

Если оператор добавил нового поставщика в Набор данных, то при распознавании следующего инвойса от данного поставщика, группа полей поставщик будет найдена автоматически на изображении. Аналогично случаю, если бы поставщик был в базе данных поставщиков. Однако система правил автоматической валидации инвойсов сможет определить, что данного поставщика нет в вашей реальной базе данных поставщиков, он есть только в Наборе данных. В связи с чем статус инвойсу будет присвоен Exception.

При ближайшей синхронизации Набора данных и внешней базы данных все добавленные операторами поставщики будут замещены соответствующими поставщиками из внешней базы данных, либо просто удалены из Набора данных. Подробнее про обновление Набора данных См. "Обновление данных в Наборе данных".

По умолчанию возможности редактирования и добавления новых записей запрещены операторам. Чтобы их разрешить:

  1. В главном меню редактора определения документа Определение документа>Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Наборы данных.
  3. Выберите Набор данных из списка. Нажмите кнопку Настроить….
  4. Отметьте галочками позиции Операторам разрешено добавлять записи и/или Операторам разрешено редактировать записи.

В случае, если эти возможности операторам надо, наоборот, запретить — снимите галочки для с данных позиций.


Столбцы Набора данных PurchaseOrders

Набор данных содержит информацию о заказах. Он используется для автоматического извлечения номеров и сумм заказов с инвойса, а также для сопоставления инвойса и заказа.

Название | Тип | Описание
PONumber | Текст, нет нормализации | Обязательное поле. Номер заказа. Используется для поиска номера заказа на изображении.
Netto | Действительное двойной точности, нет нормализации | Обязательное поле. Сумма заказа. Используется для поиска суммы заказа на изображении.
VendorId | Текст, нет нормализации | Опциональное поле. Идентификатор поставщика, которому соответствует номер заказа. Если значения данного столбца заданы, то после определения поставщика инвойса, список заказов будет профильтрован и программа будет работать только с заказами из Набора данных от данного поставщика.
BUId | Текст, нет нормализации | Опциональное поле. Идентификатор подразделения компании (Business Unit). Данное поле требуется определять, если одновременно происходит обработка инвойсов, выставленных разным подразделениям компании. При этом каждое подразделение компании может иметь свой список PO-номеров. Поле BUId используется для объединения в один Набор данных PO-номеров разных подразделений компании. В этом случае поля BUId и PONumber уникально идентифицируют заказ.


Столбцы Набора данных PurchaseOrdersItems

Набор данных содержит информацию о позициях заказов, связан с Набором данных заказов (PurchaseOrders) ключом PONumber — номер заказа. Набор данных используется для показа оператору позиций заказа во время верификации инвойса.

Название | Тип | Описание
PONumber | Текст, нет нормализации | Обязательное поле. Номер заказа. Используется для связи с записями из Набора данных PurchaseOrders.
Article | Текст, нет нормализации | Опциональное поле. Код позиции заказа.
Description | Текст, нет нормализации | Опциональное поле. Описание позиции заказа.
Quantity | Целое, нет нормализации | Опциональное поле. Количество, относящееся к позиции заказа.
UnitPrice | Действительное двойной точности, нет нормализации | Опциональное поле. Цена для позиции заказа.
Discount | Действительное двойной точности, нет нормализации | Опциональное поле. Скидка для позиции заказа.
TaxSum | Действительное двойной точности, нет нормализации | Опциональное поле. Сумма налога для позиции заказа.
TotalPriceNetto | Действительное двойной точности, нет нормализации | Опциональное поле. Сумма до налогообложения для позиции заказа.
TotalPriceBrutto | Действительное двойной точности, нет нормализации | Опциональное поле. Сумма для позиции заказа.
ItemId | Текст, нет нормализации | Уникальный идентификатор позиции заказа. Данное поле требуется определять, если при сопоставлении инвойса с заказом (PO Matching) каждой позиции инвойса необходимо сопоставить конкретную позицию заказа, в этом случае результатом сопоставления является значение поля ItemId, записанное в одно из полей позиции инвойса.
BUId | Текст, нет нормализации | Опциональное поле.Идентификатор подразделения компании (Business Unit). Данное поле требуется определять, если одновременно происходит обработка инвойсов, выставленных разным подразделениям компании. При этом каждое подразделение компании может иметь свой список PO-номеров. Поле BUId используется для объединения в один Набор данных PO-номеров разных подразделений компании. В этом случае поля BUId и PONumber уникально идентифицируют заказ.


Столбцы Набора данных BusinessUnits

Этот Набор данных содержит информацию о подразделениях компании. Он используется для автоматического определения подразделения компании — получателя инвойса, а также для проверки данных о подразделении компании по базе данных.

Название | Тип | Описание
Id | Текст, нет нормализации | Обязательное поле. Является результатом определения подразделения компании и идентификатора во внешней системе. Для поиска подразделения компании на изображении не используется. Уникальный ключ записи в Наборе данных.
VATID | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Уникальный идентификационный номер компании для уплаты налогов. Используется для поиска подразделения компании на изображении, имеет сильное влияние.
Name | Текст, нормализация: Текст | Опциональное поле. Название подразделения компании. Используется для поиска подразделения компании на изображении.
Street | Текст, нормализация: Текст | Опциональное поле. Компонент адреса подразделения компании, улица. Используется для поиска подразделения компании на изображении.
ZIP | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Компонент адреса подразделения компании, индекс. Используется для поиска подразделения компании на изображении.
City | Текст, нормализация: Текст | Опциональное поле. Компонент адреса подразделения компании, город. Используется для поиска подразделения компании на изображении.
CountryCode Текст, нормализация: Буквенно-цифровой код

Обязательное поле. Компонент адреса подразделения компании, страна. Для поиска подразделения компании на изображении не используется.

Комментарий. Формат данного поля — двухбуквенный код страны в формате ISO 3166-1 alpha-2. Данное поле обязательно должно быть заполнено, потому что страна подразделения компании определяет правила наложения определения документов на инвойсы и проверки полей.


Столбцы Набора данных Vendors

Этот Набор данных содержит информацию о компаниях поставщиках. Он используется для автоматического определения поставщика инвойса, а также для проверки данных поставщиков по базе данных.

Название | Тип | Описание
Id Текст, нет нормализации

Обязательное поле. Является результатом определения поставщика и идентификатором поставщика во внешней системе. Для поиска поставщика на изображении не используется.

Комментарий. Если поле BusinessUnitId не используется, то является уникальным ключом записи в Наборе данных.

BusinessUnitId Текст, нет нормализации

Опциональное поле. Идентификатор подразделения компании – получателя инвойсов. Для поиска поставщика на изображении не используется.

Комментарий. Если данное поле задано, то Id считается не уникальным, а зависящем от значения BusinessUnitId. Имеется ввиду, что каждое подразделение компании (BusinessUnitId) имеет свой уникальный список поставщиков (Id). Уникальным ключом записи о поставщике в Наборе данных является пара BusinessUnitId + Id.

VATID | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Уникальный идентификационный номер компании поставщика для уплаты налогов. Используется для поиска поставщика на изображении, имеет сильное влияние.
NationalVATID | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Уникальный национальный идентификационный номер компании поставщика для уплаты налогов. Используется для поиска поставщика на изображении, имеет сильное влияние.
IBAN | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Международный номер банковского счёта компании поставщика. Используется для поиска поставщика на изображении, имеет сильное влияние. Используется для проверки найденного на изображении банковских реквизитов поставщика по справочнику.
BankAccount | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Номер банковского счёта компании поставщика. Для поиска поставщика на изображении не используется. Используется для проверки найденного на изображении банковских реквизитов поставщика по справочнику.
BankCode | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Номер банковского счёта компании поставщика. Для поиска поставщика на изображении не используется. Используется для проверки найденного на изображении банковских реквизитов поставщика по справочнику.
Name | Текст, нормализация: Текст | Опциональное поле. Название компании поставщика. Используется для поиска поставщика на изображении.
Street | Текст, нормализация: Текст | Опциональное поле. Компонент адреса компании поставщика, улица. Используется для поиска поставщика на изображении.
ZIP | Текст, нормализация: Буквенно-цифровой код | Опциональное поле. Компонент адреса компании поставщика, индекс. Используется для поиска поставщика на изображении.
City | Текст, нормализация: Текст | Опциональное поле. Компонент адреса компании поставщика, город. Используется для поиска поставщика на изображении.
CountryCode Текст, нормализация: Буквенно-цифровой код

Обязательное поле. Компонент адреса компании поставщика, страна. Для поиска поставщика на изображении не используется.

Комментарий. Формат данного поля — двухбуквенный код страны в формате ISO 3166-1 alpha-2. Данное поле обязательно должно быть заполнено, потому что страна поставщика определяет правила наложения определения документов на инвойсы и проверки полей.


Пользовательские поля

ABBYY FlexiCapture for Invoices позволяет пользователям добавить извлечение любых полей инвойсов, не предусмотренных программой, а также изменить способ извлечения стандартных полей.

Это можно сделать следующими способами:

Способ | Описание
Разработка дополнительного гибкого описания | Позволяет добавить извлечение нового поля или изменить механизм извлечения стандартных полей независимо от поставщика.
Разработка разновидности гибкого описания для конкретного поставщика | Позволяет добавить извлечение нового поля или изменить механизм извлечение стандартных полей для конкретного поставщика.
Обучение определения документа для конкретного поставщика | Позволяет обучить новые или стандартные поля для конкретного поставщика.

Применять данные способы можно как независимо, так и совместно: например, можно добавить извлечение нового поля в дополнительное гибкое описание для всех поставщиков, но для некоторых поставщиков данное поле обучить, а для некоторых — разработать разновидность гибкого описания.

Подробнее о механизме наложения разных гибких описаний См. "Механизм слияния результатов наложения гибких описаний".

Разработка дополнительного гибкого описания

ABBYY FlexiCapture for Invoices позволяет использовать любое гибкое описание, разработанное в программе ABBYY FlexiLayout Studio в качестве дополнительного.

Чтобы добавить извлечение нового поля, необходимо создать блок с уникальным именем в гибком описании и определить логику его поиска на изображении. При загрузке данного гибкого описания в качестве дополнительного в определение документа, будет автоматически создано новое поле с таким же названием, как у блока в гибком описании.

Если в дополнительном гибком описании название блока совпадает с названием стандартного поля определения документа для инвойсов, то для извлечения данного поля будет использоваться дополнительное гибкое описание.

Как загрузить дополнительное гибкое описание:

  1. В меню Проект выберите пункт Определения документов….
  2. В открывшемся окне нажмите кнопку Правка….
  3. В меню Определение документа выберите пункт Свойства определения документа….
  4. В открывшемся окне перейдите на вкладку Гибкое описание.
  5. В группе Additional FlexiLayout нажмите кнопку Загрузить… и укажите в открывшемся диалоге путь к *.afl файлу гибкого описания.

В программе ABBYY FlexiLayout Studio предусмотрены специальные возможности для разработки дополнительного гибкого описания для обработки инвойсов:

  • Узнать идентификатор поставщика и подразделения компании для текущего инвойса и сделать запрос к Набору данных из определения документов
  • Задавать отношения для поиска элементов относительно регионов полей, которые наложены основным гибким описанием для обработки инвойсов
  • Параметризовать гибкое описание с помощью XML-файла, что позволяет хранить и редактировать сложные списки ключевых слов и прочие параметры гибкого описания без модификации как самого гибкого описания, так и определения документа.

Подробнее об использовании специальных возможностей ABBYY FlexiLayout Studio См. "Специальные возможности ABBYY FlexiLayout Studio для разработки дополнительного гибкого описания"

Разработка разновидности гибкого описания для конкретного поставщика

ABBYY FlexiCapture for Invoices позволяет использовать для конкретного поставщика отдельную разновидность гибкого описания — фактически отдельное гибкое описание. Данное гибкое описание может быть получено автоматически с помощью обучения. Если качество автоматически полученной разновидности гибкого описания не удовлетворяет, данное гибкое описание можно открыть с помощью ABBYY FlexiLayout Studio и внести изменения в алгоритм поиска полей.

Collapsed Алгоритм разработки разновидности гибкого описания

  1. Чтобы добавить извлечение нового поля, необходимо сначала создать это поле в редакторе определения документа.

    Например, создать поле с именем MyField:

    В Редакторе определения документа выберите пункт меню Правка>Создать поле (или щелкните правой клавишей мыши в списке полей). Выберите тип поля. В окне свойств укажите имя дополнительного поля — MyField.

Если необходимо изменить алгоритм поиска для стандартного поля, то данный шаг нужно пропустить.

  2. Затем необходимо выполнить следующий порядок действий:

    • загрузить хотя бы один инвойс от данного поставщика в пакет для обработки инвойсов;
    • распознать его;
    • проследить за тем, что определился необходимый поставщик (при необходимости вручную выбрать нужного поставщика);
    • нажать кнопку [image] — в результате будет создан Пакет обучения для данного поставщика.
  3. На следующем шаге перейдите в вид [image] Пакеты обучения. В данном пакете хранятся примеры инвойсов конкретного поставщика, на которых будет автоматически обучена разновидность гибкого описания для данного поставщика. Выполните одно из следующих действий:
    • Если вы хотите использовать автоматическое обучение, добавьте ещё несколько примеров инвойсов в пакет (рекомендуется не менее трёх) и разметьте регионы полей. Подробнее про обучение в виде пакетов обучения См. "Обучение настройщиком проекта"
    • Если вы хотите сразу перейти к ручной разработке Разновидности гибкого описания, пропустите следующий шаг.

  4. Запустите обучение. Для этого:

    • выберите в главном меню Проект>Обучение>Обучить

    или

    • выберите пункт Обучить из контекстного меню пакета.

    В результате автоматически создастся Разновидность гибкого описания.

  5. На следующем шаге создайте проект ABBYY FlexiLayout Studio, содержащий изображения из пакета обучения данного поставщика, а также гибкое описание, полученное в результате автоматического обучения:
    • выберите в главном меню Проект>Обучение>Экспортировать обученное гибкое описание…

    или

    • выберите пункт Экспортировать обученное гибкое описание… из контекстного меню пакета.

    Сохраните проект.

  6. Откройте созданный проект в программе ABBYY FlexiLayout Studio.

    Набор блоков в гибком описании соответствует набору полей в определении документа инвойсов. Все блоки имеют специальную иконку, сообщающую о том, что алгоритм их извлечения получен автоматически — [image].

    Внесение изменений в гибкое описание приведёт к тому, что все определённые в нём блоки будут считаться разработанными вручную. При наложении определения документа программе необходимо принять решение, из какого гибкого описания выбрать регион поля (подробнее См. "Механизм слияния результатов наложения гибких описаний"), при этом предпочтение всегда отдаётся блокам, разработанным пользователем вручную.

Поэтому необходимо удалить из гибкого описания те блоки, алгоритм поиска которых вы не хотите менять для данного поставщика (при наложении они будут браться из общего гибкого описания для инвойсов). Например, если вы хотите определить алгоритм поиска только для блоков InvoiceDate и MyField, то их нужно оставить, а все остальные блоки удалить.

Замечание. Нельзя добавить новые блоки в данном гибком описании и таким образом создать новые поля в определении документа для данного поставщика. Если необходимо извлекать новое поле только для конкретного поставщика, сначала необходимо создать это поле в определении документа, используя редактор документов, см. шаг 1 данного алгоритма. Создание новых блоков в гибком описании, которое будет использоваться в качестве разновидности гибкого описания для инвойсов, которые не соответствуют полям в определении документа, приведёт к ошибке при обработке инвойсов от данного поставщика.

  7. Задайте алгоритм поиска блоков, используя стандартные средства ABBYY FlexiLayout Studio.

  8. Скомпилируйте гибкое описание, выбрав из главного меню команду FlexiLayout > Build, и выгрузите его в *.afl файл с помощью команды главного меню File > Export….

  9. Перейдите в интерфейс программы ABBYY FlexiCapture, в вид [image] Пакеты обучения.

  • выберите в главном меню Проект>Обучение>Импортировать гибкое описание…

или

  • выберите пункт Импортировать гибкое описание… из контекстного меню пакета.

Укажите путь к созданному на предыдущем шаге *.afl файлу гибкого описания.

  10. Распознайте примеры инвойсов от данного поставщика.

    В логе операции распознавания будут показаны сообщения о том, регионы каких именно полей были выбраны из разновидности гибкого описания для данного поставщика.

  11. Проверьте результат обработки, открыв документы в редакторе документов.

Обучение определения документа для конкретного поставщика

Чтобы создать новое поле:

  1. В Редакторе определения документа выберите пункт меню Правка>Создать поле (или щелкните правой клавишей мыши в списке полей). Выберите тип поля.
  2. В окне свойств укажите имя дополнительного поля и отметьте опцию Может иметь регион.

Замечание. Об остальных настройках полей различных типов См. "Свойства полей".

В форме данных и в списке полей появилось новое поле с заданным названием.

Для автоматического извлечения значения данного поля в процессе ввода инвойсов необходимо обучить систему с помощью хотя бы трёх примеров инвойсов с данным полем. Обратите внимание, что обучение необходимо производить для каждого поставщика независимо. См. "Обучение в процессе ввода инвойсов"


Настройка экспорта данных

В проекте ABBYY FlexiCapture for Invoices можно настроить профили экспорта для каждого статуса документа (подробнее о статусах См. "Что такое ABBYY FlexiCapture for Invoices"). Например, документы со статусом Rejected экспортировать в отдельную папку. Для каждого профиля можно задать свой тип экспорта (файлы данных, ODBC-совместимые базы данных и т.д.), путь, а также список выгружаемых полей.

После того, как данные будут распознаны и проверены, их необходимо экспортировать. В проекте уже существует два настроенных профиля экспорта. Эти профили настроены для примера. Один профиль для документов со статусом Valid, другой — для документов со статусом Exception. Выгрузка данных по ним осуществляется в формате *.csv в папку Export (Valid) и Export (Exception) соответственно. Подробнее о профилях экспорта См. "Настройка экспорта данных".

Как настроить экспорт данных по типу статуса

Настройка экспорта для ABBYY FlexiCapture for Invoices в целом не отличается от настройки в ABBYY FlexiCapture (См. "Настройка экспорта данных"):

  1. В меню Проект выберите пункт Определения документов….
  2. В открывшемся окне нажмите кнопку Правка….
  3. В меню Определение документа выберите пункт Настройки экспорта….
  4. В открывшемся окне нажмите кнопку Добавить…, откроется окно Мастер настройки экспорта.
  5. Задайте необходимые параметры экспорта.
  6. Отметьте Условие для поля.
  7. В открывшемся окне Условия экспорта нажмите кнопку Выбрать….
  8. Выберите из списка полей значение Status, дважды кликнув по нему.
  9. В выпадающем списке ниже выберите Принадлежит множеству.
  10. Введите в поле значение статуса: Valid, Exception или Rejected, при наличии которого документ должен экспортироваться по данному профилю.
  11. Нажмите кнопку Добавить.
  12. Нажмите кнопку ОК. Значение выбранного статуса появится в окне Мастер настройки экспорта.
  13. Следуйте шагам мастера, чтобы настроить профиль экспорта.

В результате в списке профилей экспорта появится новый профиль по типу статуса.

Редактирование списка полей для экспорта

В ABBYY FlexiCapture for Invoices по умолчанию экспортируются значения всех полей. Но можно исключить из экспорта какие-либо поля. Или настроить список экспортируемых полей отдельно для каждого профиля экспорта. Подробнее См. "Настройка экспорта данных".


Обновление данных в Наборе данных

ABBYY FlexiCapture позволяет создавать два типа Набора данных:

  • первый тип Набора данных лишь фиксирует структуру данных;
  • второй тип — сам хранит копию данных из внешней базы данных. Это регулируется галочкой Хранить данные в свойствах Набора данных.

Обновление данных имеет смысл только для Наборов данных, которые хранят копию данных из внешней базы данных внутри проекта ABBYY FlexiCapture.

Смысл обновления в том, чтобы получить современную копию данных из внешней базы данных для последующей работы.

Обновление может выполняться:

  • по явной команде пользователя в редакторе определения документа;
  • с заданным периодом при открытии пакета на станции Администратора или Оператора ABBYY FlexiCapture Standalone, а также на Станции настройки проекта ABBYY FlexiCapture Distributed;
  • по явной команде или по расписанию на сервере обработки или на полнофункциональной станции ABBYY FlexiCapture Distributed.

Обновление Набора данных из Редактора определения документа

  1. В меню Определение документа выберите пункт Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Наборы данных.
  3. Выберите нужный Набор данных и нажмите кнопку Обновить.

Периодическое обновление Набора данных при открытии пакета

Чтобы настроить периодическое обновление данных в Наборе данных, необходимо перейти в свойства Набора данных, отметить галочку Период обновления и задать период обновления.

Обновление будет выполнено при открытии пакета любым оператором Standalone-версии или настройщиком проекта Distributed-версии на Станции настройки проекта после истечения периода обновления.

Некоторые пользовательские станции могут не иметь доступа к внешней базе данных и поэтому обновление Наборов данных не будет возможным. Чтобы отключить обновление Наборов данных на пользовательской станции, необходимо воспользоваться настройкой Обновлять наборы данных при открытии пакета (вкладка Обработка документов диалогового окна Опции), либо ключом реестра:

[HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller]

"DisableCacheUpdate"="1".

Обновление Набора данных по расписанию

В ABBYY FlexiCapture Distributed обновление Наборов данных можно инициировать из командной строки. Для этого на сервере обработки или на любой полнофункциональной пользовательской станции (только не на удаленной и не на Web-станциях) необходимо иметь доступ к файлу FlexiBr.exe или FlexiBrSvc.exe и выполнить следующую команду в командной строке (cmd):

update dataset <project path> [<document definition name>] [<data set name>], где

<project path> — путь к проекту на сервере приложений ABBYY FlexiCapture вида «http://appserver/{GUID}/ProjectName» (это значение можно скопировать из диалога свойств проекта на Станции настройки проекта);

<document definition name> — имя определения документа, которому принадлежит Набор данных;

<data set name> — имя Набора данных, который необходимо обновить.

Пользователь, инициировавший команду, должен иметь роль Администратора или Настройщика проекта в ABBYY FlexiCapture.

Пример команды, которая должна исполняться на сервере обработки ABBYY FlexiCapture и запускать обновление Набора данных Vendors:

FlexiBRSvc.exe please update dataset “http://myAppServer/D111842C-C6AF-44AC-B341-3295881012E5/MyProject” “Invoice” “Vendors”

После выполнения команды обновления Набор данных на сервере приложений будет обновлен. Однако полнофункциональные станции будут работать с локальной копией Набора данных до перезапуска и только при перезапуске получат обновленный Набор данных.

Станции обработки, которые являются сервисами Windows и не перезапускаются, обновят локальные копии Набора данных после пяти минут простоя без задач, когда отгрузятся процессы исполнители задач FlexiEx.exe.

Вы можете использовать Планировщик задач Windows (Windows Scheduler) для настройки обновления Наборов данных по расписанию.

В этом случае вы также можете из командной строки инициировать перезапуск станций обработки для принудительного обновления их локальной копии Набора данных (см. справку по работе с сервером обработки из командной строки: FlexiBRSvc.exe).

Слияние данных при обновлении Набора данных

ABBYY FlexiCapture позволяет операторам модифицировать данные в Наборе данных в процессе работы. В частности, пользователи ABBYY FlexiCapture for Invoices могут добавлять в Набор данных данные о новых поставщиках или подразделениях, а также изменять данные о существующих. Эти изменения никак не отражаются на внешней базе данных.

Внешняя база данных может модифицироваться совершенно независимо, в ней могут добавляться, изменяться и удаляться записи.

Обновление Набора данных происходит по следующим правилам:

  • Если новая запись появилась во внешней базе данных, она будет добавлена в Набор данных.
  • Если запись была удалена из внешней базы данных, она будет удалена из Набора данных.

Если новая запись была добавлена в Набор данных операторами, она будет удалена (если аналогичная запись появилась во внешней базе данных, то она будет добавлена в Набор данных). Если запись есть и в Наборе данных и во внешней базе,то ее поля могут изменяться независимо. В этом случае слияние выполняется по следующим правилам:

  • Если операторы изменили в процессе ввода определённые поля записи (например, добавили новый адрес для поставщика), то эти изменения при слиянии не потеряются, а останутся в Наборе данных.
  • Если какие-то поля записи изменились во внешней базе данных, а в Наборе данных операторы их до этого не меняли (они были взяты из внешней базы), то они будут обновлены из внешней базы.

Полное замещение данных в Наборе данных данными из внешней базы

Если Набор данных не менялся операторами, слияние данных всегда будет иметь один результат — полное замещение значений в Наборе данных с данными из внешней базы.

Если же данные в Наборе данных модифицировались операторами, у администратора есть возможность полностью заново взять данные для Набора данных из внешней базы данных и тем самым удалить все модификации данных, сделанные операторами.

Для этого нужно переподключить Набор данных заново:

  1. В диалоге свойств определения документа на вкладке Наборы данных выберите нужный Набор данных.
  2. Нажмите кнопку Настроить….
  3. Задайте строку подключения, выберите схему и таблицу, настройте соответствие колонок.

Подробнее См. "Подключение справочников поставщиков и подразделений компаний".


Подключение справочников поставщиков и подразделений компаний

Для ввода инвойсов необходима информация о поставщиках и подразделениях. Группы полей Поставщик и Подразделение являются ключевыми: с них начинается наложение определения документа на инвойс, также они определяют дальнейшие правила извлечения и проверки полей инвойса.

Поставщик — компания, которая выставила инвойс. Чаще всего именно поставщик определяет язык документа и особенности представления чисел, дат, сумм в инвойсе.

Подразделение — компания или подразделение компании, которая является получателем инвойса. Подразделение определяет набор правил проверки инвойса, налоговые ставки и прочее регулирование.

Автоматическая обработка (распознавание) инвойса начинается с поиска поставщика и подразделения. Для поиска этих полей на изображении инвойса используется информация из вашего списка поставщиков и подразделений.

В процессе автоматической проверки инвойса правило выполнит проверку по базе данных с целью сравнения всех параметров найденного на изображении поставщика и подразделения с записями в базе данных.

Во время ручной верификации оператор сможет выполнить поиск нужного поставщика и подразделения в базе данных.

Чтобы предоставить программе информацию о поставщиках и подразделениях, необходимо подключить свои базы данных к Наборам данных, заданным в определении документа.

Набор данных представляет собой локальную копию таблицы внешней базы данных, в которой хранится информация о поставщиках или подразделениях. Значения в Наборе данных могут быть типизированы и нормализованы. Информация в Наборе данных может периодически автоматически обновляться для синхронизации с внешней базой данных.

См. "Как подготовить справочники поставщиков и подразделений компании".

Как подключить базы данных

Алгоритм подключения одинаков для баз данных поставщиков и подразделений:

  1. В меню Проект выберите пункт Определения документов….
  2. В открывшемся окне нажмите кнопку Правка….
  3. В меню Определение документа выберите пункт Свойства определения документа….
  4. В открывшемся окне перейдите на вкладку Наборы данных.
  5. Дважды щелкните по строке BusinessUnits (Vendors) или нажмите кнопку Настроить…. Откроется окно Набор данных.

По умолчанию в Наборе данных заданы необходимые столбцы и их типы (по сути Набор данных — это таблица). Пользователю не разрешено их менять. Задача пользователя сопоставить каждому столбцу в Наборе данных столбец с данными из внешней базы данных. Если в вашей базе данных нет таблицы с соответствующей информацией, необходимо создать представление с требуемыми данными и указать его в качестве таблицы.

  6. Задайте строку соединения с базой данных.

Можно выбрать из уже заданных в проекте переменных окружения или задать кнопкой новую строку, нажав кнопку Установить…. Использование строки соединения, которая задана с помощью переменной окружения в свойствах проекта, позволяет переносить проект и присоединяться к другим базам с аналогичной структурой данных без модификации определения документа.

  7. Выберите: Схема данных и Таблица базы данных.
  8. Настройте соответствие столбцов Набора данных и внешней базы данных.

Для всех столбцов Набора данных нужно задать соответствующие столбцы внешней базы данных, либо указать значение <Не используется>.

В списке Соответствие полей отображаются:

  • названия столбцов в Наборе данных;
  • соответствующие столбцы внешней базы данных

    По умолчанию у каждого поля из Наборе данных отображается значение <Не используется> в Столбец внешней базы данных, что означает, что колонки внешней базы данных не заданы.

  • Найдено: задано ли соответствие между полем в Наборе данных и столбцом базы данных. Если отмечено галочкой, то соответствие задано;
  • Используемый тип нормализации значения

    Нормализация позволяет несущественно отличающиеся значения считать одинаковыми (См. "Нормализация значений в Наборе данных").

Выберите столбец в таблице, нажмите кнопку Правка….

  9. В окне Настройка соответствия столбцов набора данных выберите из списка Столбцы базы данных соответствующий столбец внешней базы данных.

На инвойсах от одного поставщика могут встречаться разные названия компании поставщика, разные адреса. В случае, если одному поставщику (один VATID) соответствует несколько значений, их необходимо расположить в нескольких столбцах таблицы (или представлениях) внешней базы данных, например, Name1, Name2, Address1, …, AddressN.

В этом случае при настройке соответствия можно выбрать из списка столбцов значение Несколько столбцов… — это позволит в соответствии одному столбцу из Набора данных задать произвольное число столбцов из внешней базы данных.

Замечание. Во внешней базе данных может быть задано, например, только одно значение: название компании или улицы. Однако данные поля могут иметь несколько распространённых вариантов написания на инвойсах. Для достижения максимального качества автоматического определения поставщика (подразделения компании) необходимо, чтобы напечатанные на изображении данные максимально точно соответствовали данным в Наборе данных. Поэтому рекомендуется во внешней базе данных создать представление (view), соответствующее таблице с данными, но содержащее дополнительные пустые колонки. Например, для колонки Название компании из таблицы с данными можно создать в представлении несколько колонок Название1, Название2..., одна из которых будет содержать название компании, а остальные будут оставаться пустыми. На этапе задания соответствия между колонками Набора данных и внешней базой данных выберите Несколько столбцов… и поставьте в соответствие полю Name Набора данных все колонки Название* из представления. Это позволит при обработке инвойсов добавлять в Набор данных (но не во вешнюю базу данных!), т.е. в локальную копию данных, дополнительные варианты значений, в данном случае — названий компании, что повысит точность автоматического определения данной компании в качестве поставщика (подразделения компании).

См. "Множественные столбцы в Наборах данных".

Если в вашей базе данных нет информации, соответствующей данному столбцу Набора данных, выберите <Не используется>.

См. "Столбцы Набора данных Vendors"

См. "Столбцы Набора данных BusinessUnits"

  10. Из списка Нормализация выберите подходящее значение, наиболее соответствующее типу данных в столбце (См. "Нормализация значений в Наборе данных").
  11. Задайте период обновления данных в Наборе данных при необходимости автоматического обновления.

Данные Набора данных для BusinessUnits и Vendors хранятся внутри проекта ABBYY FlexiCapture for Invoices, поэтому их нужно синхронизировать с внешней базой данных, которая может меняться. Обновление выполняется при открытии пакета, если с последнего обновления прошло больше заданного времени. Подробнее о механизме обновления (См. "Обновление данных в Наборе данных").

Правило проверки по базе данных

В определении документа European Invoice настроены правила для автоматической проверки найденных на изображении групп полей Поставщик и Подразделение компании по подключенным базам данных. Это стандартные правила типа Проверка по базе данных с названиями (Rejected) Vendor must be found in database и (Rejected) Business Unit must be found in database. Как найти правило в списке, См. "Правила".

В свойствах данных правил можно посмотреть, какие поля группы Поставщик (Подразделение) должны совпасть точно с записью в базе данных (фактически в Наборе данных), какие неточно, и какие поля просто копируются из базы данных. Подробнее о правиле проверки по базе данных См. "Правило проверки по базе данных".

Правило проверки по базе данных выполняется автоматически после распознавания инвойса, а затем каждый раз после любых модификаций полей группы оператором в процессе верификации инвойса.

Поиск по базе данных в процессе ввода инвойсов

Если поставщик (подразделение) не был определён автоматически в процессе распознавания инвойса, у оператора есть возможность выбрать запись из базы данных (фактически из Набора данных).

См. "Поиск в базе данных информации о поставщике и подразделении".

Редактирование существующих и добавление новых записей о поставщиках и получателях

Вы можете разрешить добавлять записи о новых поставщиках и подразделениях в Набор данных в процессе верификации (если они не были найдены в базе) или редактировать существующие. Эти данные не будут попадать во внешнюю базу данных поставщиков или подразделений, но будут использоваться для поиска полей на изображении при обработке инвойсов, а также для работы правил. Подробнее См. "Дополнительные возможности работы операторов".

См. "Поиск в базе данных информации о поставщике и подразделении".


Использование более одного определения документа

В одном проекте ABBYY FlexiCapture for Invoices вы можете использовать несколько определений документа для обработки инвойсов.

Данная возможность удобна в том случае, если в одном проекте вы обрабатываете несколько видов инвойсов, различающиеся, например, расположением и количеством полей, которые необходимо извлекать.

Чтобы получить новое определение документа, продублируйте имеющееся определение документа European Invoice (кнопка Дублировать в диалоговом окне Определения документов).

Внимание! Для корректной работы определения документа должны быть разделены по типам пакета. При этом каждый тип пакета должен использовать не более одного инвойсного определения документа. Подробнее о типах пакета См. "Типы пакетов".


Специальные возможности ABBYY FlexiLayout Studio для разработки дополнительного гибкого описания

В программе ABBYY FlexiLayout Studio предусмотрены специальные возможности для разработки дополнительного гибкого описания для обработки инвойсов:

  • Задавать отношения для поиска элементов относительно регионов полей, которые наложены основным гибким описанием для обработки инвойсов,
  • Используя идентификатор поставщика и подразделения компании для текущего инвойса, сделать запрос к Набору данных из определения документов,
  • Параметризовать гибкое описание с помощью XML-файла, что позволяет хранить и редактировать сложные списки ключевых слов и прочие параметры гибкого описания без модификации как самого гибкого описания, так и определения документа.
Collapsed Как разработать дополнительное гибкое описание
  1. В интерфейсе программы ABBYY FlexiCapture откройте рабочий пакет с распознанными инвойсами
  2. Создайте проект ABBYY FlexiLayout Studio. В главном меню выберите пункт Опции>Создать новый проект FLS….

Замечание. Команда доступна только для проекта ABBYY FlexiCapture в файловой системе. Если используется Distributed версия ABBYY FlexiCapture и проект загружен на сервер, то сначала необходимо выгрузить его в файловую систему с помощью команды главного меню Проект>Экспортировать проект….

Замечание. Суффикс в название проекта ABBYY FlexiLayout Studio указывает на версию определения документа на момент создания проекта.

Созданный проект ABBYY FlexiLayout Studio содержит все документы рабочего пакета ABBYY FlexiCapture, а регионы полей, наложенных в результате распознавания в ABBYY FlexiCapture, превращены в референсную разметку.

Дерево SearchElements содержит узлы:

CommonBlockRegions

В данном узле представлены элементы, соответствующие всем полям определения документа. Для каждого документа в проекте ABBYY FlexiLayout Studio сохранены координаты регионов блоков, которые получились в результате наложения в программе ABBYY FlexiCapture. По умолчанию элементы, соответствующие одноимённым полям определения документа, при наложении гибкого описания в ABBYY FlexiLayout Studio будут получать регионы с данными координатами — это позволяет использовать их при создании отношений при разработке новых элементов.

CustomSearchElements

В данном узле содержатся элементы-примеры. По умолчанию они отключены, чтобы не влиять на наложение гибкого описания.

DataSetRequestSample — иллюстрирует обращение к Набору данных поставщиков и подразделений компании, хранящихся в определении документа, с использованием значений идентификаторов поставщика и подразделения компании для данного документа.

XMLSettingsSample — иллюстрирует получение списков ключевых слов из XML-файла KeywordsCustom.xml, хранящегося в папке Settings внутри проекта ABBYY FlexiLayout Studio.

Collapsed Как добавить поле в дополнительное гибкое описание

Необходимо создать соответствующий блок и связать его с элементом для поиска.

В определении документа поля должны обладать уникальными именами, поэтому:

  • чтобы описать логику извлечения нового поля, необходимо завести блок с уникальным именем;
  • чтобы переопределить логику извлечения существующего в определении документа поля, нужно создать блок с соответствующим именем.
Collapsed Как выполнить запрос к Наборам данных определения документов

Пример запроса находится в выключенном по умолчанию элементе DataSetRequestSample.

Тип | Описание
NamedValue | Именованное значение.
Конструктор |
NamedValue( String, String ) |
Методы |
String Name() | Возвращает имя именованного значения.
String Value() | Возвращает значение именованного значения.
NamedValueArray | Массив именованных значений.
Конструкторы |
NamedValueArray() |
NamedValueArray( NamedValue namedValue ) |
Методы |
Int Count() | Возвращает количество элементов массива.
NamedValue GetAt( Int index ) | Возвращает элемент с заданным индексом.
Void Add( NamedValue namedValue ) | Добавляет в массив именованных значений еще одно значение.
Void Add( NamedValueArray namedValueArray ) | Добавляет в массив именованных значений массив именованных значений.
Void InsertAt( Int index, NamedValue namedValue ) | Добавляет именованное значение namedValue в позицию index.
Void DeleteAll() | Удаляет все элементы массива.
Void DeleteAt( Int index ) | Удаляет элемент в позиции index.
Int FindByName( String name ) | Возвращает позицию именованного значения с именем name.

Функции

Синтаксис:

  • При разработке гибкого описания в ABBYY FlexiLayout Studio будут использоваться путь к определению документа и имя Набора данных.
  • После загрузки скомпилированного гибкого описания в определение документа ABBYY FlexiCapture для доступа к Набору данных будет использоваться только его имя.
  • Формат connectionString:

"dbtype=FCDataset;fcTemplate=путь_к_определению_документа;datasetName=имя_набора_данных;" (путь пишется через удвоенный \)

  • Параметр searchFields — массив имен столбцов, значения из которых будут возвращены.

  • Параметр searchCriteria — массив пар Столбец-Запись, либо пустое условие для выбора всех значений.
    • При запросе, содержащем разные значения для одного поля, запрос создается объединением по OR.
    • Если в запросе задаются значения для разных полей, то запрос делается по AND.
    • При использовании сразу двух типов запросов соответственно значения из одного поля объединяются по OR, а значения из других полей уже с ними по AND.
Определение | Описание
Logic TestAccessToFCDataSet( String connectionString ) | Проверка возможности подключения к Набору данных.
Logic TestFCDataSetSearchCriteria( String connectionString, StringArray searchFields, NamedValueArray searchCriteria ); | Проверка условий поиска по Набору данных.
StringArray FieldNamesOfFCDataset( String connectionString ); | Возвращает список всех полей Набора данных в порядке возрастания индекса.
StringArray FieldNamesOfFCDataset( String connectionString, StringArray searchFields ); | Возвращает список полей Набора данных для заданного набора в порядке возрастания индекса. Предполагается использование совместно с RecordOfFCDataset при наличии множественных столбцов.
Int RecordCountOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria ); | Возвращает число записей в Наборе данных, соответствующее заданным условиям поиска. Требуется для того, чтобы знать сколько записей можно вернуть с помощью RecordOfFCDataset.
Void PrepareRecordsetOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ); | Подготавливает данные запроса к Набору данных. Должно выполняться для каждых новых условий поиска, перед вызовом RecordOfFCDataset.
StringArray RecordOfFCDataset( String connectionString, StringArray searchFields, NamedValueArray searchCriteria, Int rowIndex ); | Возвращает массив значений для записи под номером rowIndex из результатов запроса к Набору данных. Количество значений соответствует количеству переданных полей в searchFields с учетом множественных столбцов.
Quality ValidateByFCDataSet( String word, String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxErrors, Rational maxErrorsPart, Logic ignoreSpaces = true, Int maxRecordsCount = DefaultMaxRecordsCount ); | Возвращает качество строки word по запросу к Набору данных. Принимает индекс поля. Индекс можно получить, проиндексировав результат выполнения FieldNamesOfFCDataset.
Void SearchTextFromFCDataSet( String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ); | Функция задания параметров поиска слов для элемента StaticText. При вызове предыдущие параметры заменяются новыми. Принимает индекс поля. Индекс можно получить, проиндексировав результат выполнения FieldNamesOfFCDataset.
Void RegularExpressionFromFCDataSet( String connectionString, Int fieldIndex, NamedValueArray searchCriteria, Int maxRecordsCount = DefaultMaxRecordsCount ); | Функция для задания параметров поиска слов с помощью регулярных выражений для элемента CharString. При вызове предыдущие параметры заменяются новыми. Принимает индекс поля. Индекс можно получить, проиндексировав результат выполнения FieldNamesOfFCDataset.

Как выполнить поиск на картинке строк из одного столбца справочника

  1. С помощью FieldNamesOfFCDataset получите список столбцов в порядке увеличения индекса.
  2. Определите по имени индекс столбца, данные из которого нужно найти.
  3. Сформируйте массив условий для фильтрации данных из Набора данных.
  4. Передайте индекс интересующего столбца и условий фильтрации в SearchTextFromFCDataSet (или RegularExpressionFromFCDataSet, если требуется выполнить поиск с использованием регулярных выражений).

Данный код будет автоматически генерироваться в выгружаемом из ABBYY FlexiCapture распознанном пакете.

Как выполнить поиск на картинке строк из нескольких столбцов справочника

Так как каждый вызов SearchTextFromFCDataSet замещает предыдущие параметры поиска, вызов этой функции в цикле для каждой колонки не имеет смысла. Обойти это можно извлечением из справочника строк и передачей их в функцию SearchText. Вызов данной функции не замещает предыдущие параметры, а добавляет к ним переданную в неё строку.

Порядок действий при поиске:

  1. Сформируйте массив имен столбцов, данные из которых нужно найти.
  2. Сформируйте массив условий для фильтрации данных из Набора данных.
  3. Определите количество возвращаемых записей через RecordCountOfFCDataset.
  4. Подготовьте данные запроса, используя PrepareRecordsetOfFCDataset.
  5. В цикле для каждой записи верните массив с содержимым через RecordOfFCDataset.
  6. Для каждого элемента массива передайте его значение в функцию SearchText.

Особенности при наличии множественных столбцов

  • FieldNamesOfFCDataset вернет массив, в котором будет несколько раз повторяться имя множественного столбца. Число повторений будет соответствовать тому, сколько множественных столбцов в закодированном справочнике.

Например: {VendorId, VATID, Name, Name, Name, City}. В данном случае к справочнике три множественных столбца для поля Name.

  • Если в searchCriteria указано условие для поля, которому соответствует несколько столбцов, как в примере выше, то это условие будет проверено по всем колонкам.
  • Если в searchFields указано условие для поля, которому соответствует несколько столбцов, как в примере выше, то получится следующее: вместо одного запрошенного поля в возвращаемый массив будет встроено столько значений, сколько множественных столбцов соответствует полю.

Например, если для {VendorId, VATID, Name, Name, Name, City} запросить

searchFields = { VATID, Name, Сity}, то на выходе будет получено

{VATID_value, Name_valueInColumn1, Name_valueInColumn2, Name_valueInColumn3, City_value}

  • Чтобы узнать заранее, какие столбцы будут получены, можно передать в функцию FieldNamesOfFCDataset дополнительно массив searchFields и получить список возвращаемых колонок.
Collapsed Как выполнить запрос к файлу настроек гибкого описания

Для доступа к содержимому XML-файла используются стандартные функции, описанные в справочной документации программы ABBYY FlexiLayout Studio:

StringArray ReadFromXML(String filename, String xPathQuery)

String ReadSingleStringFromXML(String filename, String xPathQuery)

Элемент XMLSettingsSample иллюстрирует получение списков ключевых слов из XML-файла KeywordsCustom.xml, хранящегося в папке Settings внутри проекта ABBYY FlexiLayout Studio.

При разработке гибкого описания в программе FlexiLayout Studio файл должен располагаться внутри папки проекта FlexiLayout Studio, а путь к нему задаётся относительно файла проекта FlexiLayout Studio.

После загрузки скомпилированного гибкого описания в качестве дополнительного в определение документа ABBYY FlexiCapture, XML-файл будет располагаться в папке Templates и будет доступен для редактирования. Доступом к файлу при наложении дополнительного гибкого описания программа будет управлять автоматически.


Редактирование настроек обработки инвойсов в XML

Настройки обработки инвойсов можно выгрузить в XML файл, отредактировать, загрузить обратно или перенести в другой проект.

Содержание XML-файла настроек

XML-файл настроек содержит:

  • ключевые слова и другие настройки, специфичные для стран и языков, см. теги <Countries> <Country>< /Countries> и <Languages> <Language></Languages>;
  • регулярное выражение для номера заказа, см. тег <OrderNumber><Value><RegularExpression></RegularExpression></Value></OrderNumber>;
  • список дополнительных возможностей определения документа для обработки инвойсов (См. "Дополнительные поля", См. "Дополнительные возможности работы операторов") и их состояние: включено/выключено, см. тег AdditionalFeatures;
  • список языков, которые используются для распознавания инвойсов, см. тег PrimaryLanguages;
  • настройки дополнительной возможности Статус документа (См. "Статус документа в проекте ABBYY FlexiCapture for Invoices"), см. тег DocumentStatus.

Как сохранить текущие настройки в XML-файл

  1. В главном меню редактора определения документа выберите пункт Определение документа > Свойства определения документа….
  2. Перейдите на вкладку Настройки инвойсов.
  3. Нажмите кнопку Экспорт настроек….
  4. Сохраните файл.

После чего файл можно открыть в редакторе XML, внести в него необходимые изменения и сохранить.

Как загрузить XML-файл с настройками инвойса

  1. В главном меню редактора определения документа выберите пункт Определение документа > Свойства определения документа….
  2. Перейдите на вкладку Настройки инвойсов.
  3. Нажмите кнопку Импорт настроек….
  4. Выберите файл invoices_settings.xml.

Внимание! Если в XMLфайле были допущены ошибки в тегах, структуре или в значениях параметра, то при импорте настроек будет показано диагностическое сообщение с указанием строки, в которой обнаружена ошибка. Если были добавлены новые неизвестные секции или параметры, то они будут пропущены.


Список ключевых слов

Ключевые слова для группы полей Vendor / Business Unit, Invoice Header Data

Ключевые слова применяются для поиска в их окрестности значений извлекаемых полей. Как правило, это название поля или другая подпись поля на изображении.

Например, Invoice Date: <value>. В данном случае "Invoice Date" является ключевым словом для поля InvoiceDate.

Ключевые слова можно задать, используя Найденные элементы. Каждый Найденный элемент связан только с одним полем определения документа, но поле может иметь несколько Найденных элементов, каждый из которых будет отвечать за отдельную модель отношений ключевого слова и значения поля на инвойсе.

  • Ключевые слова задаются на язык и на страну. При наложении определения документа список используемых ключевых слов берётся из объединения стран поставщика и подразделения компании, а также языков этих стран.
  • К ключевым словам применяется нормализация:
    • игнорируются пробелы, табуляция, переносы строк, диакритика
    • заглавные буквы приравниваются к строчным.

      Например, Tax point = taxpoint.

  • Допускаются 2 — 3 (в зависимости от элемента) ошибки распознавания в ключевом слове.

  • В случае двуязычных ключевых слов, например, Quantity/Anzahl рекомендуется добавлять в качестве ключевого слова всю строку Quantity/Anzahl в оба языка.
Группа полей | Найденные элементы | Описание | В каких настройках задается
Vendor / Business Unit | Банковский счет | Ключевые слова для поля Банковский счет | Страна (вкладка Ключевые слова)
 | Банковский код | Ключевые слова для поля Банковский код | Страна (вкладка Ключевые слова)
 | IBAN | Ключевые слова для поля IBAN | Страна (вкладка Ключевые слова)
 | Национальный VATID | Ключевые слова для поля Национальный VATID | Страна (вкладка Ключевые слова)
 | Итого | Ключевые слова для поля Итого | Страна (вкладка Ключевые слова)
 | Итого налог | Ключевые слова для поля Итого налог | Страна (вкладка Ключевые слова)
 | VATID | Ключевые слова для поля VATID | Страна (вкладка Ключевые слова)
Invoice Header Data | PurchaserNameLabels | Варианты названий поля PurchaserName на данном языке | Язык
 | PurchaserNameFalseFieldPrefixes | Варианты названий полей, ошибочно распознаваемых как поле Purchaser Name. Рекомендуется заполнять при обнаружении конкретных примеров | Язык
 | CreditNoteKeywords | Слова для обозначения типа документа Credit Note на данном языке | Язык
 | InvoiceIdentifiers | Слова, обозначающие, что документ является инвойсом | Язык
 | OrderNumberLabels | Варианты названий поля OrderNumber на данном языке | Язык
 | InvoiceNumberExcludePreffixes | Слова, которые нужно исключать из начала номера. Например, “Nr.” | Язык
 | InvoiceNumberExcludeSuffixes | Слова, которые нужно исключать из окончания номера. Рекомендуется заполнять при обнаружении конкретных примеров | Язык
 | InvoiceNumberWithDateLabels | Текст перед номером инвойса в случае, если номер и дата выводятся в одной строке и их разделяет косая черта или другой символ. Пример: Invoice Number / date 23061336 / 07.07.2013 Rechnungsnr./ -datum 23061336 / 07.07.2013 | Язык
 | InvoiceNumberHighConfidenceLabels InvoiceNumberLowConfidenceLabels | В список InvoiceNumberHighConfidenceLabels входят слова, однозначно определяющие поле, например, “Invoice number», «Document number». Список InvoiceNumberLowConfidenceLabels предназначен для менее вероятных слов: "No.", "Bill" | Язык
 | DueDateLabels | Варианты названий поля DueDate на данном языке | Язык
 | DeliveryDateLabels | Варианты названий поля DeliveryDate на данном языке | Язык
 | InvoiceDateLabelsNearCity | Текст между названием города и датой, если они находятся в одной строке. Например, запятая | Язык
 | InvoiceDateLabelsNearInvoiceNumber | Текст между номером инвойса и датой, если они находятся в одной строке | Язык
 | InvoiceDateHighConfidenceLabels InvoiceDateLowConfidenceLabels | В список InvoiceDateHighConfidenceLabels входят слова, однозначно определяющие поле, например, “Invoice date», «Document date». Список InvoiceDateLowConfidenceLabels предназначен для менее вероятных слов: "Tax Date", "Tax Point" | Язык

Ключевые слова для группы полей Amounts

Программа ABBYY FlexiCapture умеет различать ситуации, когда одно ключевое слово является подстрокой другого. Например, если добавлены ключевые слова total и total netto, а на изображении находится total netto, то это будет определено как ключевое слово total netto, а не как total.

  • Ключевые слова допускают 3 ошибки распознавания.
  • Такое ограничение приводит к ошибкам. Например, могут быть перепутаны слова brutto и netto. Для избежания ошибок, если добавлено некоторое значение в список AmountTotalNettoLabels, например total netto, стоит добавить соответствующее значение в список AmountTotalLabels, например, total brutto.
Группа полей | Найденные элементы | Описание | В каких настройках задается
Amounts | AmountTotalHighConfidenceLabels AmountTotalLowConfidenceLabels | Подписи поля Total. Подписи, которые встречаются только у итоговой суммы инвойса, стоит помещать в группу HighConfidence. Подписи, которые могут быть встречены и у других сумм инвойса, — в LowConfindence. | Язык
 | AmountTotalNettoLabels | Ключевое слово левее или выше поля Total Netto | Язык
 | AmountTotalTaxLabels | Ключевое слово левее или выше поля Total Tax | Язык, Страна (вкладка Ключевые слова)
 | ReversedChargeKeywords | Слова для обозначения Reversed Charge на данном языке | Язык
 | Ставки налогов | Ключевые слова для налоговых ставок | Страна (вкладка Ставки налогов)
 | Валюта | Ключевые слова (символы) для обозначения валюты | Страна (вкладка Валюта)

Замечание. Не следует добавлять одинаковые слова в список Total Netto и Total.

Ключевые слова для группы полей Line Items

Ключевые слова используются для нахождения заголовка таблицы с позициями инвойса, а также для нахождения конкретного столбца таблицы. В качестве ключевых стоит добавлять слова, которые часто используются в заголовке соответствующих Найденному элементу столбцов.

Если одно и тоже слово часто встречается в заголовках разных столбцов, рекомендуется добавить его в Найденные элементы соответствующих столбцов — в этом случае программа будет пытаться отличить столбцы по содержимому строк в столбцах.

В случае, если автоматическое различение столбцов после этого работает неверно (не получается отличить столбцы) или в случае, если слово бывает часто в одном столбце, и редко в остальных, необходимо оставить слово только в Найденном элементе столбца, в заголовке которого оно встречается наиболее часто.

  • Ключевые слова допускают 3 ошибки распознавания.
  • Ключевые слова должны быть в одну строку.
  • Содержимое столбца должно находиться по вертикали под заголовком столбца.
  • Ключевое слово на изображении должно быть окружено пробелами, запятыми или точками. Т.е. Quantity/Anzahl — это одно слово, а Quantity / Anzahl — два слова.

    Если встречаются различные написания, то необходимо добавить в качестве ключевых три слова: Quantity/Anzahl, Quantity, Anzahl.

Группа полей | Найденные элементы | Описание | В каких настройках задается
Line Items | LineItemsArticleNumberLabels | Ключевое слово для столбца ArticleNumber | Язык
LineItemsArticleNumberBULabels | Ключевое слово для столбца Article Number BU | Язык
LineItemsCurrencyLabels | Ключевое слово для столбца Currency | Язык
LineItemsDeliveryDateLabels | Ключевое слово для столбца DeliveryDate | Язык
LineItemsDescriptionLabels | Ключевое слово для столбца Description | Язык
LineItemsDiscountAmountLabels | Ключевое слово для столбца Discoun Amount | Язык
LineItemsDiscountPercentageLabels | Ключевое слово для столбца Discount Percentage | Язык
LineItemsMaterialNumberBULabels | Ключевое слово для столбца Material Number BU | Язык
LineItemsMaterialNumberLabels | Ключевое слово для столбца Material Number | Язык
LineItemsOrderDateLabels | Ключевое слово для столбца Order Date | Язык
LineItemsOrderNumberLabels | Ключевое слово для столбца Order Number | Язык
LineItemsPositionLabels | Ключевое слово для столбца Position | Язык
LineItemsQuantityLabels | Ключевое слово для столбца Quantity | Язык
LineItemsQuantityOrderedLabels | Ключевое слово для столбца Quantity Ordered | Язык
LineItemsQuantityUndeliveredLabels | Ключевое слово для столбца Quantity Undelivered | Язык
LineItemsSubtotalVariants | Зарезервировано, не используется. | Язык
LineItemsTotalPriceBruttoLabels | Ключевое слово для столбца Total Price Brutto | Язык
LineItemsTotalPriceNettoLabels | Ключевое слово для столбца Total Price Netto | Язык
LineItemsUnitsOfMeasureLabels | Ключевое слово для столбца Units of Measure | Язык
LineItemsUnitsOfMeasureVariants | Возможные значения полей в столбце Unit Of Measure | Язык
LineItemsUnitPriceDenominatorLabels

Подписи в заголовке столбца, который используется как множитель для столбца Unit Price при вычислении равенства для позиции инвойса: Unit Price * Denominator * Quantity = Total Netto.

Например, если UnittPrice указано за одно изделие, а Quantity указывает число упаковок, то логическому столбцу UnitPriceDenoinator будет соответствовать столбец с количеством изделий в упаковке.

Язык
LineItemsUnitPriceLabels | Ключевое слово для столбца UnitPrice | Язык
LineItemsVATAmountLabels | Ключевое слово для столбца VAT Amount | Язык
LineItemsVATCodeLabels | Ключевое слово для столбца VAT Code | Язык
LineItemsVATPercentageLabels | Ключевое слово для столбца VAT Percentage | Язык

Замечание. Качество нахождения ключевых слов на изображении зависит от качества полнотекстового распознавания документа.

Режим предраспознавания может быть изменён в настройках определения документа на вкладке Гибкое описание диалога свойств. Повышение качества распознавания может негативно сказаться на скорости распознавания инвойса.


Механизм слияния результатов наложения гибких описаний

Данная статья описывает очередность наложения и механизм выбора регионов полей из гибких описаний.

ABBYY FlexiCapture for Invoices при наложении определения документов для инвойсов может использовать несколько гибких описаний:

  1. Общее гибкое описание, которое используется для обработки всего потока инвойсов, может состоять из двух:
    1. Основное гибкое описание, с помощью которого извлекаются стандартные поля инвойсов, предусмотренные программой. Данное гибкое описание поставляется вместе с ABBYY FlexiCapture for Invoices и не может быть изменено пользователем.
    2. Дополнительное гибкое описание, с помощью которого извлекаются поля, определённые пользователем, а также стандартные поля, логику извлечения которых пользователь переопределил. Данное гибкое описание может быть разработано пользователем.
  2. Разновидность гибкого описания, которая используется для обработки разновидности инвойсов, т.е. документов от конкретного поставщика. Данное гибкое описание может извлекать любые поля, которые есть в определении документов инвойсов. Описание может быть разработано пользователем или получено автоматически в результате обучения на инвойсах конкретного поставщика.

Результат наложения определения документа представляет собой набор регионов полей, которые фактически взяты из разных гибких описаний.

1. Наложение Общего гибкого описания

  1. Первым накладывается основная часть общего гибкого описания — Основное гибкое описание.

Настройки предраспознавания

Изображение документа предраспознаётся с использованием настроек, указанных в определении документа:

  • список языков задаётся в свойствах определения документа, вкладка Настройки инвойсов, группа Страны и языки.
  • режим предраспознавания (Очень быстрое / Быстрое / Сбалансированное / Полное) задаётся в свойствах определения документа на вкладке Гибкое описание.

Результат наложения Основного гибкого описания

Результатом наложения являются:

  • идентификатор поставщика и подразделения компании, если их удалось определить.
  • регионы стандартных полей (См. "Список полей определения документа для обработки инвойсов").
  2. Вторым накладывается дополнительная часть общего гибкого описания, если она есть, — Дополнительное гибкое описание.

Настройки предраспознавания

Изображение документа предраспознаётся с использованием настроек (список языков и режим предраспознавания), указанных непосредственно в самом гибком описании. Рекомендуется использовать в дополнительном гибком описании настройки предраспознавания аналогичные указанным в определении документов, в этом случае повторного предраспознавания не происходит, а используется результат предраспознавания, описанный в шаге 1.

Использование в дополнительном гибком описании настроек предраспознавания, отличных от определения документа, может быть необходимо для обработки специфичных полей, но негативно сказывается на скорости.

Результат наложения Дополнительного гибкого описания

Результатом наложения являются регионы всех полей, которые определены в дополнительном гибком описании: это могут быть как стандартные поля, механизм поиска которых необходимо изменить, так и дополнительные по отношению к основному гибкому описанию поля.

  3. Далее формируется результат наложения Общего гибкого описания.

    В случае, если в определении документа есть дополнительное гибкое описание, на данном шаге происходит слияние результатов наложения основного и дополнительного гибких описаний.

    Поля идентифицируются по именам. Результатом является сумма уникальных полей из основного и дополнительного гибких описаний. В случае наличия полей с одинаковым именем в основном и дополнительном гибких описаниях регион поля берётся из дополнительного гибкого описания.

    Такой подход позволяет как добавлять новые поля, так и изменять логику извлечения стандартных полей с помощью дополнительного гибкого описания.

2. Наложение Разновидности гибкого описания

Если при наложении общего гибкого описания на шаге 1 удалось определить поставщика и для данного поставщика существует Разновидность гибкого описания, то на данном шаге накладывается оно.

Настройки предраспознавания

Настройки предраспознавания берутся из определения документа и соответствуют настройкам, использованным при наложении основной части общего гибкого описания. Поэтому дополнительное предраспознавание изображений не требуется.

Результат наложения Разновидности гибкого описания

Результатом наложения являются регионы всех полей, которые определены в Разновидности гибкого описания для конкретного поставщика. Важно отметить, что в случае автоматического создания Разновидности гибкого описания с помощью обучения в ней содержатся все поля определения документа. Если разновидность гибкого описания была разработана вручную, то в ней необходимо оставлять только те поля, которые требуется накладывать специфично для данного поставщика.

3. Результат наложения определения документа

На данном шаге результат наложения Общего гибкого описания объединяется с результатом наложения Разновидности гибкого описания.

Если Разновидность гибкого описания была создана автоматически в результате обучения, то она содержит все поля определения документа. В определении документа хранится информация о том, регионы каких полей приходилось изменять пользователям при обучении, т.е. какие поля работали с недостаточным качеством в общем гибком описании для данного поставщика. На основании этой информации принимается решение о том, регионы каких полей необходимо взять из общего гибкого описания, а каких из обученного для данной разновидности документов, т.е. для данного поставщика.

Замечание. Особый алгоритм выбора региона используется для полей группы Amount. При наложении общего гибкого описания у группы Amount выставляется свойство уверенности найденных регионов. В случае, если регионы найдены неуверенно, поле Total будет требовать верификации. При наличии обученной разновидности гибкого описания для поставщика регионы группы полей Amount берутся из обученной разновидности в случаях, если общее гибкое описание не нашло поля группы или нашло их неуверенно.

Если разновидность гибкого описания была разработана вручную, то регионы всех полей, которые присутствуют в разновидности гибкого описания, в итоговом наложении определения документа будут взяты оттуда. Остальные поля — из общего гибкого описания.

Информация о том, из какого гибкого описания были взяты регионы полей, записывается в лог задачи распознавания документа.

Collapsed Пример

Для простоты рассмотрим несколько полей определения документов.

Например, пару стандартных полей: InvoiceDate, InvoiceNumber и пару полей, обработку которых пользователь хочет добавить самостоятельно: CustomFieldA и CustomFieldB.

  • Поля InvoiceDate и InvoiceNumber являются стандартными, алгоритм их поиска определён в основной части общего гибкого описания.
  • Поля CustomFieldA и CustomFieldB являются пользовательскими, они разработаны пользователем и извлекаются на инвойсах всех поставщиков дополнительной частью общего гибкого описания инвойсов.

Допустим, что в процессе ввода оператора не устраивает качество извлечения полей InvoiceDate и CustomFieldB на инвойсах определённого поставщика. Оператор применил обучение.

Схема объединения полей на инвойсах данного поставщика будет выглядеть следующим образом:

  • InvoiceNumber — из основной части общего гибкого описания.
  • CustomFieldA — из дополнительной части общего гибкого описания.
  • InvoiceDate и CustomFieldB — из разновидности гибкого описания для данного поставщика.

На инвойсах остальных поставщиков схема объединения полей будет выглядеть следующим образом:

  • InvoiceDate и InvoiceNumber — из основной части общего гибкого описания.
  • CustomFieldA и CustomFieldB — из дополнительной части общего гибкого описания.


Нормализация значений в Наборе данных

Данная статья описывает типы нормализации, которые можно использовать при подключении столбцов внешней базы данных к Набору данных в определении документа ABBYY FlexiCapture for Invoices, а также их настройку.

Цель нормализации значений — привести по-разному записанные, но одинаковые по сути значения к одному виду для последующего сравнения.

Например, один и тот же адрес компании или её название могут быть записаны большим числом способов. При этом это всё-таки одна и та же компания, расположенная по одному конкретному адресу. Для сравнения подобных значений применяется нормализация.

Тип нормализация задаётся при настройке соответствия столбцов в Наборе данных и во внешней базе для каждого столбца Набора данных.

Нормализация применяется только для значений, которые хранятся в Наборе данных (в свойствах Набора данных должна быть включена галочка Хранить данные), значения во внешней базе данных никак не изменяются.

Collapsed Как работает нормализация при извлечении данных в ABBYY FlexiCapture for Invoices?

Наборы данных используются в ABBYY FlexiCapture for Invoices не только для автоматических проверок инвойсов, но и для наложения гибких описаний для последующего извлечения полей. Во внешней базе данных значение, например, имя компании поставщика или адрес может быть записано одним способом, а на изображениях инвойсов от данного поставщика будет встречаться множество вариантов написания. При наложении гибкого описания на основании одного значения будет сгенерировано множество гипотез значений, которые допустимы с точки зрения нормализации данного значения, и все они будут проверены на изображении.

ABBYY FlexiCapture for Invoices предлагает два режима нормализации для значений столбца Набор данных.

1. Текст

Рекомендуется применять для сравнения текстовых значений, таких как имя компании или адрес.

  1. замена всевозможных пробелов и символов-разделителей на обычные пробелы;
  2. обработка точек. Точки между словами (разделители) заменяются на пробелы, точки внутри аббревиатур удаляются;
  3. обработка символов-союзов (&, +, -, /, ~):
    • цепочки отдельных слов, которые идут через одинаковый союз и начинаются с однобуквенного слова, объединяются в одно слово. Например, R & D заменяется на R&D;

    • во всех остальных случаях символы-союзы удаляются: Procter&Gamble заменяется на Procter Gamble.

  4. удаление двойных пробелов;
  5. разрезание слов по заданному списку. Например, CoKG заменяется Co KG;
  6. разрезание всего полученного текста значения на слова по пробелам;
  7. автозамена суффиксов для каждого слова по заданному списку. Например, суффикс strasse заменяется на суффикс str.
  8. автозамена слов целиком по заданному списку. Например, слово Limited заменяется целиком на слово Ltd.

Алгоритм нормализации параметризуется через файл Normalization.xml, который хранится в папке проекта.

Collapsed Подробнее...

Путь для локального проекта в файловой системе : <путь к папке проекта>\ Templates\InvoiceData\<Название Набора Данных>.Cache\Normalization.xml.

Пример: C:\InvoicesProject\Templates\InvoiceData\Vendors.Cache\Normalization.xml.

Путь для проекта, загруженного на сервер приложений, в файловом хранилище данных ABBYY FlexiCapture for Invoices: <путь к файловому хранилищу>\<GUID хранилища>\project_<id проекта>\ DatabaseCaches\<Название Набора Данных>\Normalization.xml.

Пример: D:\FileStorage\2FBE40C5-26EF-4756-AA7F-A52E7FBDA97D\project_1\DatabaseCaches\Vendors\Normalization.xml.

Данный файл возможно изменять после создания Набора данных (независимо для каждого Набора данных).

Замечание. Алгоритм может существенно измениться в следующих версиях программы.

2. Буквенно-цифровой код

Рекомендуется применять для сравнения буквенно-цифровых кодов, таких как идентификационные номера для уплаты налогов, банковские счета, почтовые индексы.

Из значения удаляются все символы, за исключением цифр и букв. Это позволяет сравнивать коды, игнорируя пробел, тире, косую черту и прочие знаки в записи.

Если применяется нормализация, то при задании соответствия столбца Набор данных и колонки внешней базы данных, доступна галочка Сохранять нормализованное значение.

  • При включении данной галочки внутри Набора данных будет сохранено уже нормализованное значение.
  • Если галочка не включена, то будет скопировано исходное значение из внешней базы данных.

Этот выбор никак не влияет на извлечение данных или на автоматические проверки, но будет определять, какое значение будет показано оператору при поиске записи по справочнику.


Извлечение дополнительных полей инвойсов

ABBYY FlexiCapture for Invoices по умолчанию извлекает только основные поля инвойса (См. "Список полей определения документа для обработки инвойсов").

В случае необходимости извлекать дополнительную информацию инвойса пользователь может:

  • включить извлечение дополнительных полей с инвойса, которые преднастроены в определении документа
  • обучить программу для каждого поставщика извлекать произвольные поля
  • разработать гибкое описание для извлечения произвольных полей инвойса для каждого поставщика или независимо от поставщика.
Поля | Описание
Основные поля | Основные поля инвойса, такие как номер, дата инвойса, информация о поставщике и получателе инвойса и прочие (См. "Список полей определения документа для обработки инвойсов"). Извлечение основных полей включено по умолчанию и не может быть отключено, однако сами поля могут быть при желании скрыты и не показываться пользователю при верификации.
Дополнительные поля | Типовые поля инвойса, такие как PO Number, Line Items и прочие. Извлечение этих полей по умолчанию отключено, но может быть включено по желанию пользователя.
Пользовательские поля | Нестандартные поля инвойса, не предусмотренные программой по умолчанию. Вы можете добавить обработку таких полей самостоятельно.

У пользователя есть возможность повлиять на извлечение любых полей инвойса, используя обучение. См. "Обучение в ABBYY FlexiCapture for Invoices"


Проверка позиций инвойса

Заказ на покупку — документ, являющийся предложением покупателя продавцу и содержащий информацию о типе, количестве и согласованной цене товара или услуги, предоставляемой покупателю продавцом.

Многие компании ведут учёт заказов, а выставленные поставщиком инвойсы содержат номер заказа, по которому нужно произвести оплату. Это позволяет при обработке инвойса сверять продукты или услуги, за которые выставлен инвойс, их количество и цены с теми, которые указаны в соответствующем заказе.

Например, инвойсы, которые автоматически совпали с подтвержденным ранее заказом, могут пропускать этап верификации.

По умолчанию сравнение позиций инвойса с заказом отключено.

Как включить сравнение позиций инвойса с заказом

I. Включите соответствующую возможность ABBYY FlexiCapture for Invoices.

  1. В меню Проект выберите пункт Определения документов….
  2. В открывшемся окне нажмите кнопку Правка….
  3. В меню Определение документа выберите пункт Свойства определения документа….
  4. В открывшемся окне перейдите на вкладку Настройки инвойсов.
  5. Нажмите кнопку Правка… справа от группы Дополнительные поля и возможности. Откроется окно Свойства инвойсов.
  6. Отметьте Сравнение с заказом на поставку.

II. Подключите базу данных заказов.

  1. В главном меню редактора определения документа выберите Определение документа>Свойства определения документа….
  2. В открывшемся диалоге перейдите на вкладку Наборы данных.

Набор данных — это таблица, которая задаёт структуру данных, может хранить сами данные или может брать данные из внешней базы данных.

  3. Выберите в списке PurchaseOrders и нажмите кнопку Настроить….

Обратите внимание на структуру подключаемых данных. См. "Столбцы Набора данных PurchaseOrders".

Если в вашей базе данных нет таблицы с данной информацией, возможно, вам придётся сформировать соответствующее представление средствами базы данных.

  4. В диалоге Наборы данных (PurchaseOrders) задайте строку соединения с ODBC-совместимой базой данных заказов, укажите схему и выберите нужную таблицу или представление в базе данных.
  5. Задайте соответствие между столбцами Набора данных и внешней базой данных.

Теперь на инвойсе будут находиться номера заказов и их суммы и сравниваться с записями в базе данных заказов.

III. Подключение базы данных позиций заказов

При необходимости повторите шаги 1 и 2 из предыдущего пункта, чтобы открыть вкладку Наборы данных диалогового окна Свойства определения документа….

  1. Выберите в списке PurchaseOrdersItems и нажмите кнопку Настроить….

Обратите внимание на структуру подключаемых данных. См. "Столбцы Набора данных PurchaseOrdersItems".

Важно, что номер заказа должен совпадать с номером заказа, указанным в базе данных заказов, Набор данных: PurchaseOrders — данная колонка является обязательной. Все остальные колонки являются опциональными.

Если в вашей базе данных нет таблицы с данной информацией, возможно, вам придётся сформировать соответствующее представление (view) средствами базы данных.

  2. В диалоге Набор данных (PurchaseOrdersItems) задайте строку соединения с ODBC-совместимой базой данных заказов, укажите схему и выберите нужную таблицу или представление в базе данных.
  3. Задайте соответствие между столбцами Набора данных и внешней базой данных.

Также См. "Алгоритм поиска основных полей".

IV. Включите извлечение позиций инвойса

См. "Дополнительные поля"

V. Настройте список правил для сравнения

Для реализации сопоставления инвойса заказуABBYY FlexiCapture for Invoices имеет несколько предопределенных проверок. Администратору необходимо включить те проверки, которые требуется выполнять для данного проекта, для этого необходимо открыть вкладку Правила диалога настроек определения документа.

Правило | Описание | Где хранится | Состояние по умолчанию
Check purchase order number and amount | Проверяет соответствие номера заказа и суммы, извлечённых с инвойса, с заказами в Наборе данных PurchaseOrders. | PurchaseOrder | Включено
Match invoice line item with order item | Проверяет соответствие позиции инвойса позиции заказа. В настройках правила можно задать список полей для сравнения и способ сравнения. | LineItems | Включено,если включена опция Извлечение позиций
Check invoice line items count against order items count | Проверяет, что количество позиций в заказе равно количеству позиций инвойса, связанных с данным заказом. | PurchaseOrder | Выключено
Check if invoice line items are matched with unique order items | Проверяет, что несколько позиций инвойса не сопоставлены с одной и той же позицией заказа. | PurchaseOrder | Выключено
Collect matched order items (necessary for proper work of PO Matching at items level) | Cобирает список позиций заказа, которые уже сопоставлены позициям инвойса. Это необходимо, чтобы при ручном сопоставлении позиций показывать оператору список только еще не сопоставленных позиций заказа. | PurchaseOrder | Включено

Как сравнивать позиции инвойса с заказом

ABBYY FlexiCapture for Invoices предлагает несколько способов сравнения инвойса с заказом:

  • сравнение номера и суммы инвойса с заказом (сравнение заголовка инвойса),
  • попозиционное сравнение инвойса с заказом или заказами (сравнение позиций инвойса).

Сравнение номера и суммы инвойса с заказом

В процессе верификации инвойса в редакторе документа в случае, если включена возможность Сравнение с заказом на поставку, на форме документа будет отображаться группа Purchase Orders.

Для каждого заказа, найденного на изображении инвойса, будет отображаться элемент группы, состоящий из:

  • номера заказа
  • суммы заказа
  • кнопки Details...
  • галочки Order Checked

При нажатии кнопки Details... будут отображены детали заказа (если администратор подключил соответствующую базу данных с деталями заказов) внизу окна изображения документа для удобства сравнения позиций инвойса с позициями заказа.

Чтобы подтвердить соответствие инвойса заказу, вы можете отметить галочку Order Сhecked. Эта галочка может быть включена только вручную. Она обозначает, что оператор проверил и подтверждает соответствие заказу значений полей инвойса Order Number и Total. После включения этой галочки автоматическая проверка значений полей правилом не выполняется.

Если какой-либо из заказов на изображении не найден и не отображается на форме данных, нажмите на ссылку Добавить экземпляр 'Purchase Order' внизу группы Purchase Orders. Будет добавлен пустой элемент группы Purchase Orders. Заполните значения полей Order Number и Total, указав значения на изображении или введя их с клавиатуры. Введённые значения будут автоматически проверены по базе данных заказов с помощью правила.

Попозиционное сравнение инвойса с заказом

Для сопоставления инвойса с заказом можно использовать позиции, извлеченные из инвойса. Также может потребоваться подобрать для каждой позиции инвойса соответствующую позицию заказа.

Если включено извлечение позиций инвойсов, на форме данных будет отображаться группа Line Items, содержащая позиции, извлеченные с изображения инвойса.

ABBYY FlexiCapture автоматически сопоставляет позициям инвойса позиции из заказа. Чтобы сопоставить позиции вручную, необходимо нажать на кнопку внутри колонки OrderItemId и выбрать позицию заказа из списка в появившемся диалоге.

Если позиции инвойса невозможно сопоставить позицию заказа, однако эта позиция не является ошибочной, оператору требуется отметить галочку Is valid для данной позиции.

В зависимости от настроек, заданных администратором, правила автоматически проверяют:

  • что количество позиций в заказе равно количеству позиций инвойса, отнесённых к данному заказу,
  • что все позиции инвойса сопоставлены разным позициям заказа, либо вручную отмечены оператором как валидные.


Как подготовить справочники поставщиков и подразделений компании

ODBC-совместимая база данных

ABBYY FlexiCapture for Invoices позволяет подключить Набор данных к ODBC-совместимой базе данных (См. "Подключение справочников поставщиков и подразделений компаний"), однократно загрузить данные, а также регулярно обновлять Набор данных данными из внешней базы (См. "Обновление данных в Наборе данных").

Поэтому первым шагом является разворачивание внешних данных в ODBC-совместимой базе данных, например, MS Access, MS SQL Server или Oracle.

Дедубликация записей во внешней базе

Важно определить поле во внешних данных о поставщиках (подразделениях компании), значение которого должно быть получено в результате определения поставщика (подразделения компании) инвойса. Это поле (или набор полей) должно стать уникальным ключом Набора данных.

Уникальным ключом Набора данных подразделений компании является поле Id (См. "Столбцы Набора данных BusinessUnits"). С точки зрения пользователя данное поле — есть результат определения подразделения компании, которому выставлен инвойс, в результате обработки в ABBYY FlexiCapture for Invoices.

Уникальным ключом Набора данных поставщиков должно являться значение, которое будет передано во внешнюю систему как результат определения поставщика инвойса в результате обработки в ABBYY FlexiCapture for Invoices. Если используется одна таблица поставщиков, то уникальный ключ должен быть поставлен в соответствие полю Id Набора данных. Это значение будет передано во вешнюю систему в результате определения поставщика инвойса.

Если же в одном проекте предполагается обрабатывать инвойсы, выставленные разным подразделениям компании, и каждое подразделение компании имеет свою базу поставщиков, то при настройке Набора данных необходимо сопоставить уникальный ключ подразделения компании со столбцом BusinessUnitId Набора данных Vendors, а ключ поставщика — со столбцом Id Набора данных Vendors. Таким образом, уникальным ключом записи поставщика, который будет передан во вешнюю систему в результате определения поставщика инвойса, будет пара значений Id и BusinessUnitId (См. "Столбцы Набора данных Vendors").

Далее для простоты мы будем говорить только о поставщике (для подразделения компании всё аналогично).

Уникальный ключ записи должен определять уникальное сочетание параметров, которые используются для автоматического определения поставщика. Часто бывает, что внешняя система считает уникальной запись о поставщике, основываясь на большем количестве параметров, чем указано на инвойсе и / или используется для автоматического определения поставщика.

Например, внешняя система может предполагать получение идентификатора MCN_USD, если поставщик My Company Name Ltd. выставил инвойс в долларах США, и идентификатора MCN_EUR, если та же компания выставила инвойс в евро. Несмотря на то, что информация о валюте указана на инвойсе (следовательно, при обработке инвойса это случай, когда нужно вернуть идентификатор MCN_USD, может быть отличён от случая, когда должен быть возвращён идентификатор MCN_EUR), валюта не является признаком, который используется для определения поставщика.

Таким образом, в рамках механизма автоматического определения поставщика инвойса невозможно разрешить случаи MCN_USD и MCN_EUR.

В таком случае необходимо завести идентификатор MCN, который будет соответствовать двум случаям MCN_USD и MCN_EUR и будет возвращён в результате автоматического определения поставщика. После этого можно создать правило в определении документа, которое, в зависимости от валюты инвойса, будет делать выбор между MCN_USD и MCN_EUR.

Если обобщить рассмотренный пример,можно сделать вывод, что уникальный идентификатор записи о поставщике должен обладать уникальным набором параметров, которые участвуют в автоматическом определении поставщика: название компании, адрес компании, идентификационные номера для уплаты налогов (VATID, NationalVATID), международный банковский счёт (IBAN). (См. "Столбцы Набора данных Vendors"). Только в этом случае механизм автоматического определения поставщика сможет однозначно выбрать запись о поставщике, которой соответствует инвойс.

Замечание. После этого с помощью извлечения дополнительных полей и правил определения документа возможно уточнять данный результат до значения, которое требуется в результате обработки инвойса.

В случае, если одинаковый (или трудно различимый) набор параметров, используемых для автоматического определения поставщика, соответствует различным уникальным ключам, то программа не будет иметь возможности выбрать один из данных ключей — результат определения поставщика будет не только случайным, но и качество сильно деградирует.

Причина в том, что если по данным, напечатанным на инвойсе, уверенно определяется поставщик My Company Name, но в Наборе данных данным инвойса соответствует несколько записей MCN1, MCN2, ... MCNN, то программа может сделать выбор в пользу другой записи, которая хуже соответствует данным инвойса, но не порождает столь большого числа соответствующих записей, что в конечном итоге приведёт к неправильно определённому поставщику.

Поэтому очень важно провести процедуру дедубликации записей во внешней базе данных — получить столбец во внешней базе данных, который будет иметь уникальное значение для каждого уникального набора значений полей записи, используемых для определения поставщика.

При подключении к Набору данных строки с одинаковыми значениями столбца, который будет поставлен в соответствие уникальному ключу Набора данных, будут автоматически свёрнуты в одну запись в Наборе данных.

Множественные столбцы в Наборах данных

Набор данных позволяет хранить несколько значений для одного логического столбца одной записи о компании.

Это необходимо, так как такие параметры компаний, как название, улица и т.д. могут указываться на изображениях в различных вариантах (например, "My Company Name" и "MCN Ltd."), а для определения компании, которой соответствует инвойс, желательно максимальное совпадения текста в записи Набора данных и на изображении.

Также компании могут иметь несколько банковских счетов или других атрибутов.

Значения для множественных столбцов могут быть взяты как из внешней базы данных (например, таблица поставщиков содержит от одного до пяти банковских реквизитов для каждой компании), так и добавлены пользователем в процессе ввода (например, оператор добавляет в Набор данных часто встречающееся на инвойсах написание названия компании, которого нет во внешней базе данных, для повышения качества автоматического определения компании поставщика).

Набор Данных использует денормализацию таблицы по столбцам, т.е. хранит информацию в следующем виде:

Уникальный ключ Набора данных* | Name1 | Name2 | ... | NameN | ...
1 | My Company Name | MCN Ltd. | ... | <empty value> | ...
2 | The Second Company, Inc. | S-Company | ... | <empty value> | ...
... | ... | ... | ... | ... | ...

Таким образом, для одного логического поля записи Name создаётся несколько столбцов в Наборе данных, которые хранят все возможные значения поля — это называется множественным столбцом Name.

При подключении таблицы (или представления) внешней базы данных допустимо использовать как аналогичную денормализацию по столбцам, так и более распространённую денормализацию по строкам. В этом случае строки, которые должны быть объединены в параметры одной записи в Наборе данных, должны иметь одинаковое значение колонки, соответствующие уникальному ключу в Наборе данных. Например:

Столбец, соответствующий уникальному ключу в Наборе данных* | Name | ...
1 | My Company Name | ...
1 | MCN Ltd. | ...
... | ... | ...
N | <empty value> | ...
2 | The Second Company, Inc. | ...
2 | S-Company | ...
... | ... | ...
N | <empty value> | ...
... | ... | ...

*В качестве уникального ключа для Набора данных BusinessUnits выступает поле Id. В качестве уникального ключа для Набора Данных Vendors выступает в зависимости от настроек либо поле Id, либо пара полей: Id и BusinessUnitId (См. "Столбцы Набора данных Vendors").


Расширенный язык регулярных выражений

Для задания форматов используется расширенный язык регулярных выражений.

Расширенные регулярные выражения — это обычные регулярные выражения со следующими дополнениями:

  1. Специальные скобки [% и %]. Символы внутри них дополняются популярными символами-ошибками распознавания.

Например, [%S%] может допускать символы S, $ или 5.

  2. Специальные слова внутри [%...%] для обозначения популярных множеств символов и популярных символов-ошибок распознавания:
    1. LETTERS — заглавные буквы латинского алфавита и символы, которые часто распознаются как они;
    2. DIGITS — цифры и символы, которые часто распознаются как они;
    3. LETERSANDDIGITS — заглавные буквы латинского алфавита, цифры и символы, которые часто распознаются как они.

Например, [%DIGITS%]{9} задаёт девять подряд идущих цифр или популярных символов-ошибок распознавания для цифр, например «OI234Sb7B9».


Алгоритм поиска основных полей

Данная статья описывает алгоритм поиска и извлечения основных полей инвойса, а также его настройку.

Обработка инвойса начинается с предраспознавания текста документа в соответствии с настройками из определения документа:

  • режим предраспознавания (Очень быстрое / Быстрое / Сбалансированное / Полное) определяет скорость распознавания и качество распознанного текстового слоя. Настраивается в свойствах определения документа (Редактор определения документа: Определение документа > Свойства определения документа…, вкладка Гибкое описание).
  • список языков для предраспознавания задаётся в свойствах определения документа (Редактор определения документа: Определение документа > Свойства определения документа…, вкладка Настройки инвойсов, группа Страны и языки).

После выполнения предраспознавания начинается извлечение полей инвойса.

Collapsed Подразделение компании и Поставщик

Результатом поиска Подразделения компании и Поставщика инвойса являются:

  • идентификатор записи о подразделении компании из Набора данных BusinessUnits
  • идентификатор записи о поставщике из Набора данных Vendors.

Для определения Поставщика (или Подразделения компании) инвойса могут использоваться:

  • поля записи из Набора данных: IBAN, VATID, NationalVATID, Name, Street, City, ZIP
  • настройки, заданные в определении документа: форматы IBAN, VATID, NationalVATID и соответствующие им ключевые слова.

Подробнее о столбцах Наборов данных BusinessUnits и Vendors и их использовании См. "Столбцы Набора данных BusinessUnits" и См. "Столбцы Набора данных Vendors".

Алгоритм автоматического детектирования компании

  1. Поиск уникальных идентификаторов компании

Полями, уникально идентифицирующими компанию, считаются:

  • VATID,
  • National VATID,
  • IBAN.

ABBYY FlexiCapture for Invoices сначала пытается определить компанию из Набора данных, соответствующую инвойсу, по вышеуказанным полям. Чтобы это стало возможным, соответствующие столбцы записи о компании в Наборе данных должны быть заполнены, а значения должны присутствовать на изображении.

В свойствах определения документа для каждой страны (вкладка Настройки инвойсов, группа Страны и языки) задаются регулярными выражениями форматы VATID, Национальный VATID, IBAN (вкладка Форматы) и ключевые слова (вкладка Ключевые слова).

Данные поля ищутся на изображении со строгим совпадением. При этом в регулярных выражениях можно учесть возможность неправильного распознавания, для этого используется расширенный язык регулярных выражений (См. "Расширенный язык регулярных выражений").

Найденные значения полей VATID, NationalVATID, IBAN нормализуются:

  • буквы приводятся к верхнему регистру,
  • удаляются пробелы и символы: «.», «,», «—», «/», «\».

Если в свойствах страны на вкладке Форматы буквенный префикс значения поля задан регулярным выражением, то распознанный префикс заменяется на базовый вариант (задаётся на вкладке Форматы в свойствах страны).

Например, идентификатор DE12345 может быть распознан как OE12345, тогда при нормализации распознанный префикс OE будет заменен на правильный вариант — DE.

По найденным на изображении полям VATID, NationalVATID, IBAN, делается запрос к Набору данных. У полученных из Набора данных записей значения столбцов VATID, NationalVATID, IBAN нормализуются так же, как и значения полей, найденные на странице, после чего они сравниваются с нестрогим совпадением со значениями полей, найденными на изображении, при этом считается число несовпадений.

Запись о компании из Набора данных считается уверенно соответствующей изображению, если в Наборе данных нашлась запись у которой со значениями, найденными на изображении, совпало:

  • как минимум два идентификатора с не более чем одной ошибкой,

    либо

  • все три идентификатора (VATID, NationalVATID, IBAN ) с не более чем двумя ошибками.

В этих случаях дальнейший поиск прекращается.

Иначе ведется поиск имени и адреса компании, в качестве гипотез используются полученные в результате поиска по уникальным идентификаторам записи Набора данных.

  2. Поиск имени и адреса

В качестве гипотез при поиске имени и адреса компании на изображении инвойса используется набор записей из Набора данных.

Если в результате поиска уникальных идентификаторов есть непустой набор записей из Набора данных, то используется он.

Если поиск имени и адреса по данному набору записей не даёт результата или если набор записей в результате поиска уникальных идентификаторов пуст:

  • не были найдены поля VATID, NationalVATID, IBAN на изображении,

    либо

  • у соответствующей изображению записи в Наборе данных не заполнены значения столбцов VATID, NationalVATID, IBAN)

к Набору данных делается запрос с использованием всего текста страницы —в результате возвращаются записи о компаниях, наиболее точно соответствующие тексту страницы. Эти записи рассматриваются далее в качестве гипотез.

На изображении документа ведется поиск поля Name и компоненты адреса Street, ZIP и City из каждой записи-гипотезы:

  1. Поля Name и Street ищутся как одной стройкой с 25% допустимых ошибок, так и по словам (при этом учитывается кучность слов на изображении).
  2. Поля ZIP и City ищутся как один компонент адреса, при этом важно, чтобы оба поля были расположены в одной строке на изображении.

Найденные на изображении значения полей Name, Street, ZIP, City сравниваются с соответствующими значениями записи из Набора данных, при этом ведется подсчет несовпадений.

Решение о том, какая запись из Набора данных соответствует изображению, принимается следующим образом:

  • Если в дополнение к уникальным идентификаторам (VATID, NationalVATID, IBAN), совпали Name и хотя бы один компонент адреса (Street или вместе Zip и City) и число ошибок сравнения не более четырех , то запись считается уверенно соответствующей изображению.
  • Если в дополнение к уникальным идентификаторам совпали все компоненты адреса, но не совпало Name, запись считается неуверенно соответствующей изображению.
  • Если уникальных идентификаторов (VATID, NationalVATID, IBAN) у записи из Набора данных нет, или они не найдены на изображении, то уверенно соответствующей изображению считается запись, у которой совпало с найденными на изображении поле Name и хотя бы один компонент адреса (Street или вместе Zip и City) с суммарным числом ошибок не более восьми.

В противном случае, запись с максимальным числом совпадений со значениями с изображения считается неуверенно соответствующей изображению.

Результат определения поставщика и подразделения компании

Основным результатом определения поставщика и подразделения компании инвойса являются:

  • идентификатор записи о подразделении компании из Набора данных BusinessUnits,
  • идентификатор записи о поставщике из Набора данных Vendors.

Замечание. Если в Наборе данных Vendors задана зависимость Id от BusinessUnitId (подробнее См. "Столбцы Набора данных Vendors", то в результат определения поставщика инвойса будет возвращён Id, соответствующий BusinessUnitId.

Подразделение компании (или BU) инвойса может быть определено программой неуверенно: в этом случае регистрационный параметр документа fc_Predefined:InvoiceIsVendorSuspicious (fc_Predefined:InvoiceIsBusinessUnitSuspicious) будет установлен в true.

Также в результате определения поставщика и подразделения компании инвойса могут быть найдены регионы следующих полей:

Поставщик:

  • Name
  • VatID
  • NationalVatID
  • IBAN
  • Street
  • Zip
  • City

Подразделение компании:

  • Name
  • VatID
  • Street
  • Zip
  • City

По расположению данных регионов на изображении можно делать выводы о том, где на изображении программа обнаружила поля группы Поставщик и Подразделение компании, на основании которых были определены поставщик и подразделение компании.

Замечание. Регион поля IBAN, если его значение отсутствует в Наборе данных Vendors может быть найден по ключевым словам и формату отдельным механизмом извлечения банковских реквизитов уже после определения поставщика инвойса.

Замечание. Поиск региона любого поля может быть изменен в результате обучения или применения дополнительного гибкого описания (См. "Извлечение дополнительных полей инвойсов"). Это никак не повлияет на результат определения поставщика и подразделения компании, но может повлиять на расположение регионов полей этих групп после наложения определения документа инвойсов.

Важным результатом определения поставщика и подразделения компании инвойса является информация о странах поставщика и подразделения компании, которая берётся из поля CountryCode найденных записей Набора данных. Информация о странах используется для выбора множества ключевых слов, налоговых ставок для извлечения других полей инвойса, а также как условие запуска правил автоматической валидации инвойса.

Как повлиять на определение поставщика или подразделения компании

Определение поставщика (подразделения компании) работает тем точнее, чем лучше запись о компании из Набора данных совпадает с текстом на изображении.

Прежде всего необходимо идентифицировать данные во внешней базе данных, соответствующие столбцам Набора данных, которые используются для поиска компании на инвойсе, и правильно подключить внешнюю базу данных к Набору данных (См. "Подключение справочников поставщиков и подразделений компаний").

Чтобы компенсировать вариативность значений полей на изображении, можно применять:

  • нормализацию значений столбцов в Наборе данных (См. "Нормализация значений в Наборе данных"),
  • множественные значения столбцов в Наборе данных (См. "Множественные столбцы в Наборах данных").

Наложение с заранее заданным поставщиком или подразделением компании

Поставщик или подразделение компании инвойса могут быть известны заранее, например, по параметрам источника инвойса (имени оператора сканирования или электронному адресу отправителя письма).

ABBYY FlexiCapture for Invoices предусматривает возможность задать явно поставщика и / или подразделение компании до автоматического детектирования.

Для этого в качестве значения регистрационного параметра документа fc_Predefined:InvoicePredefinedVendorId (fc_Predefined:InvoicePredefinedBusinessUnitId) необходимо задать идентификатор (Id) соответствующей записи из Набора данных Vendors (BusinessUnits).

В этом случае процедура автоматического определения поставщика (подразделения компании) всё равно сработает для данной записи. В результате будет получено не только предопределённое значение в качестве поставщика (подразделения компании), но и признак уверенности (насколько данная предопределённая запись хорошо соответствует изображению по мнению программы), а также регионы полей группы Vendor (Business Unit).

Collapsed Группа полей заголовка инвойса (Invoice Header)

InvoiceNumber, InvoiceDate

К полям заголовка инвойса относятся поля InvoiceNumber, InvoiceDate, а также некоторые другие.

Данные поля накладываются с использованием ключевых слов, заданных в редакторе определения документа, в свойствах языка. Сначала определяются поставщик и подразделение компании инвойса, в результате чего появляется информация о странах поставщика и подразделения. Страны определяют языки (соответствие задаётся в определении документа). Множество ключевых слов для поиска полей берётся из объединения языков стран поставщика и подразделения компании.

Повлиять на поиск регионов данных полей можно путём редактирования ключевых слов (подробнее См. "Список ключевых слов"), а также с помощью обучения (См. "Обучение в ABBYY FlexiCapture for Invoices").

Является ли документ инвойсом?

При наложении определения документа ABBYY FlexiCapture for Invoices определяет, является ли документ инвойсом или документом другого типа.

Решение о том, что данный документ является инвойсом, принимается по совокупности следующих факторов (не все из них являются обязательными, но каждый имеет определяющее значение):

  • найдены поля InvoiceNumber, InvoiceDate,
  • на изображении встретились ключевые слова из Найденного элемента InvoiceIdentifiers (подробнее См. "Список ключевых слов"),
  • на документе удалось определить поставщика и / или подразделение компании.

Документ может быть определён как Кредитная нота, если на изображении встретились ключевые слова из элемента CreditNoreKeyword или документ имеет отрицательную сумму (Total).

Collapsed Группа полей Amounts

ABBYY FlexiCapture for Invoices извлекает с изображения:

  • сумму инвойса (Total),
  • валюту инвойса (Currency),
  • сумму до налогообложения (TotalNetto) и полную сумму налогов (TotalTax),
  • налоговые группы: налоговые ставки, соответствующие суммы до налогообложения и суммы налога.

Для поиска сумм с налоговыми ставками используется информация из настроек определения документа:

  • налоговые ставки, применяемые в стране поставщика (задаются в свойствах страны, вкладка Ставки налогов)
  • ключевые слова для налоговых ставок (задаются в свойствах налоговой ставки).

ABBYY FlexiCapture for Invoices ищет на изображении три числа, которые расположены в одной строке и являются частью арифметического выражения с использованием налоговой ставки. Ключевые слова используются для фильтрации ложных гипотез налоговых групп.

Для извлечения полей Total, TotalNetto и TotalTax используются ключевые слова из настроек определения документа. Программа будет искать:

  • одинаковые числа, которые встречаются 2—3 раза в одной строке или в одном столбце на изображении, для обработки безналогового случая,
  • число, которое является суммой значений, расположенных в столбце над ним,
  • самое большое число по модулю, расположенное в конце документа.

Поле Currency ищется только в случае, если было найдено поле Total, с использованием ключевых слов, заданных в свойствах страны в свойствах определения документа.

Не найденные на изображении поля группы Amounts могут быть автоматически рассчитаны правилами, за исключением поля Total, которое обязательно должно быть найдено на изображении.

Если поле Total помечено в документе как требующее проверки, это означает, что поля группы сумма были найдены программой неуверенно и требуется проверка. В случае, если сумма находится неуверенно, качество поиска можно попробовать улучшить с помощью обучения.

Collapsed Группа полей Purchase Order

ABBYY FlexiCapture for Invoices извлекает с изображения все номера заказов и соответствующие им суммы.

Извлечение Номеров заказов отключено по умолчанию (См. "Проверка позиций инвойса").

Для извлечения поля Номер заказа (Purchase Order) могут использоваться:

  • регулярное выражение;
  • Набор данных со значениями возможных номеров заказов (См. "Столбцы Набора данных PurchaseOrders").

Если подключен Набор данных с номерами заказов, ABBYY FlexiCapture for Invoices берёт возможные значения номеров заказов и ищет их на изображении. Рекомендуется максимально сократить количество номеров заказов в базе данных, для этого возможно:

  • использовать столбец VendorId Набора данных, тогда программа будет работать только с заказами поставщика инвойса,
  • добавлять в Набор данных не все заказы, а предварительно фильтровать список заказов и оставлять только открытые заказы, т.е. те, по которым инвойс ещё не получен.

Соответственно найденным номерам заказов на изображении ищутся суммы заказов из базы данных.

На изображении ищутся все номера заказов, в том числе те, которые встречаются внутри позиций инвойса.

Номер заказа создается в ERP-системе покупателя, поэтому часто номера заказов, выставленные одному Подразделению компании (Business Unit), однотипны и могут быть описаны регулярным выражением.

Если задано регулярное выражение для номера заказа, то на изображении будут найдены все номера, удовлетворяющие регулярному выражению. Регулярное выражение для номера заказа можно задать в файле настроек invoices_settings.xml в теге:

<OrderNumber>

<Value>

<RegularExpression></RegularExpression>

</Value>

</OrderNumber>

Подробнее о работе с файлом настроек См. "Редактирование настроек обработки инвойсов в XML"

Collapsed Группа полей Line Items

ABBYY FlexiCapture for Invoices извлекает с изображения позиции инвойса.

Данная функциональность является дополнительной, извлечение позиций инвойса отключено по умолчанию (См. "Дополнительные поля").

Список столбцов, которые может автоматически находить программа См. "Список полей определения документа для обработки инвойсов".

ABBYY FlexiCapture for Invoices сначала находит таблицу на изображении, для чего используются ключевые слова для заголовков столбцов позиций счёта, которые задаются в свойствах определения документа для каждого языка. Ключевые слова для заголовков столбцов позиций также используются для классификации столбцов, т.е. определения типа каждого столбца позиций инвойса.

Далее, используя информацию о найденных столбцах, а также арифметические выражения в позициях инвойса, программа выделяет строки в таблице позиций.

После этого внутри строки позиции происходит поиск полей позиции, соответствующих столбцам.

Улучшить результат автоматического извлечения позиций инвойса можно с помощью обучения.


Правила

ABBYY FlexiCapture for Invoices использует правила для автоматической проверки инвойсов. В результате проверки определяется статус инвойса и формируется список ошибок и предупреждений правил. Это помогает оператору принять решение о необходимости ручной проверки данного инвойса. Во время верификации в редакторе документа оператор видит список ошибок правил и может использовать его для навигации по полям, вызвавшим ошибки.

По умолчанию в ABBYY FlexiCapture for Invoices настроены правила для валидации инвойсов различных стран (См. "Список правил"). Однако пользователь может создать новые правила, изменить или удалить существующие, чтобы гибко настроить систему под себя.

Особенности правил в ABBYY FlexiCapture for Invoices

О работе с правилами в ABBYY FlexiCapture См. "Проверка с помощью правил".

В ABBYY FlexiCapture for Invoices правила имеют следующие особенности:

Collapsed Правила могут влиять на статус документа

Для реализации этой возможности используются имена правил. Если имя правила содержит префикс (Exception) или (Rejected), то это означает, что при вычислении статуса инвойса, ошибка в данном правиле будет приводить к статусу инвойса Exception или Rejected соответственно.

Collapsed Правила могут выполняться только для определённого множества стран инвойсов

Для реализации этой возможности используются условия запуска правил. Подробнее См. "Проверка с помощью правил".

Правила определяют страну инвойса по стране подразделения, которому выставлен инвойс.

Если какая-то проверка специфична только для некоторых стран, то в условиях запуска для данного правила будут заданы только соответствующие страны. Или наоборот, если проверка должна выполняться для всех инвойсов, кроме определённой страны, то в условии запуска необходимо задать проверку на несовпадение значения страны подразделения с данной страной.

Работа со списком правил

Просмотр списка всех правил

Чтобы посмотреть все правила, настроенные в проекте:

  1. В меню Определение документа выберите пункт Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Правила.
  3. В списке Показать выберите значение Правила, хранимые в данном элементе и во вложенных элементах.

Чтобы посмотреть все правила, которые будут выполняться для данной страны, например Германии, необходимо воспользоваться фильтром.

Collapsed Как установить фильтр
  1. В диалоге свойств определения документа на вкладке Правила нажмите кнопку Фильтр….
  2. В открывшемся диалоге Фильтр отметьте галочкой Если выполняется условие, выберите в Поле, используемое правилом поле Invoice Layout\BU\Country, которое определяет страну подразделения.
  3. В выпадающем списке выберите условие Перекрывает множество.
  4. В поле ниже задайте нужные страны с помощью кнопки Выбрать…. Откроется диалог Установка значения поля, выберите в нём необходимые значения, т.е. те страны, правила для которых вы хотите отобразить в списке. В рассматриваемом примере это будет DE.
  5. Нажмите кнопку OK в диалоге Фильтр.

В списке будут отображены все правила, которые будут выполняться для выбранных при настройке фильтра стран.

Обратите внимание, что условие запуска для каждого правила отображается в списке всех правил в столбце Применять правило.

Collapsed Как найти правило в списке

Искать правило в списке можно с помощью фильтра. Для поиска можно использовать:

  • название правила;
  • имя поля, с которым правило связано;
  • условие запуска правила.
  1. В диалоге свойств определения документа на вкладке Правила нажмите кнопку Фильтр….
  2. В открывшемся диалоге вы можете задать имя нужного правила (они перечислены в алфавитном порядке), выбрать поле, связанное с правилом, или условие запуска правила.

Подробнее о работе с фильтром См. "Проверка с помощью правил".

Создание новых правил

Чтобы создать новое правило, выполните следующие действия:

  1. В меню Определение документа выберите пункт Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Правила.
  3. В списке Показать выберите значение Правила, хранимые в данном элементе и во вложенных элементах.
  4. Выберите поле в списке, в котором будет храниться правило. Для некоторых правил это влияет на их работу, например, на формирование сообщения об ошибке правила. Если вы сомневаетесь, какое поле выбрать для хранения правила, выберите узел самого верхнего уровня, т.е. Invoice Layout.
  5. Нажмите кнопку Новое правило….
  6. В открывшемся диалоге необходимо выбрать один из стандартных типов правил, либо тип Скрипт, который позволит вам написать своё правило.

Замечание. Подробнее о каждом из типов правил и дальнейших шагах по их созданию См. "Проверка с помощью правил".

Далее описана информация, специфичная для создания правил в ABBYY FlexiCapture for Invoices.

  7. На следующем шаге после выбора типа правила необходимо задать:
    1. Имя правила

    Имя правила должно отражать суть выполняемой проверки. Ошибка правила будет отражать результат проверки. Оператор увидит сообщение об ошибке в следующем формате:

    Имя правила: Сообщение об ошибке.

    Если вы хотите, чтобы правило влияло на статус инвойса, необходимо начать имя правила с префикса (Exception) или (Rejected) в зависимости от статуса инвойса, к которому должна приводить ошибка в правиле.

    2. Строгость правила

    Строгость правила помогает оператору правильно распределить свое внимание между ошибками правил и принять верное решение о необходимости обязательной ручной проверки инвойса.

    Также в зависимости от строгости невыполнившихся правил можно настраивать экспорт документа в различные назначения. Например:

    • документы без ошибок правил и с предупреждениями правил экспортировать в рабочую базу данных;
    • документы с ошибками правил экспортировать в папку для исключительных ситуаций;
    • вовсе запретить экспорт документов с ошибками правил.

    Подробнее о настройке экспорта в зависимости от строгости правил См. "Проверка с помощью правил".

    3. Включить ли правило после создания
  8. На данном шаге задаётся условие запуска правила. В ABBYY FlexiCapture for Invoices условие запуска обычно определяется по значению поля Invoice Layout\BU\Country.

По умолчанию правило будет запускаться всегда (Применять правило=всегда). Если вы хотите, чтобы правило выполнялось только для определённых стран, необходимо:

  1. В списке Применять правило выбрать при выполнении условия.
  2. Нажать кнопку Правка… для редактирования условий запуска правила.
  3. Выбрать поле, в зависимости от значения которого будет срабатывать правило (Invoice Layout\BU\Country).
  4. Определить условие и в случае необходимости задать допустимые или запрещённые значения.

Пример 1. Правило должно выполняться для страны Германия.

Выбираем условие Входит в набор, с помощью кнопки Добавить добавляем значение DE.

Пример 2. Правило должно выполняться для всех стран, кроме Германии и Франции.

Выбираем условие Не входит в набор, с помощью кнопки Добавить добавляем значения DE, FR.

  9. На следующем шаге происходит настройка самого правила. Подробнее См. "Проверка с помощью правил".

Отключение правила

Чтобы отключить преднастроенное правило, необходимо выполнить следующие действия:

  1. Найдите правило в списке (это подробно описано в данной статье выше).
  2. Снимите галочку в столбце Включено у данного правила. Либо двойным щелчком по имени правила откройте его свойства и снимите галочку Правило включено на вкладке Основные.

Если вы уверены, что правило более вам не пригодится, его можно удалить. Для этого:

  1. Найдите правило в списке (это подробно описано в данной статье выше).
  2. Выделите правило, кликнув его имя в списке, и нажмите кнопку Удалить.


Статус документа в проекте ABBYY FlexiCapture for Invoices

После добавления в программу инвойсы автоматически распознаются, а затем проверяются с помощью правил, настроенных в программе. Результатом проверки является статус инвойса.

Статус | Описание
Valid | Проверки правил выполнены успешно, инвойс можно экспортировать
Exception | Инвойс требует проверки
Rejected | Инвойс не соответствует законодательству (необходимые данные не найдены, отсутствуют или были некорректно распознаны). Необходимо указать данные либо обработать инвойс особым образом (например, вернуть поставщику)

Статус рассчитывается автоматически на основе системы правил. Все необходимые правила уже созданы (См. "Список правил").

Документы со статусом Valid могут быть выгружены без верифицирования.

Инвойсы с другими статусами требуют внимания оператора. Оператор просматривает каждый документ, исправляет ошибки и предупреждения, выданные правилами — статус инвойса меняется на Valid, либо соглашается с автоматически вычисленным статусом. Оператор может также отказаться от подсказок системы правил и выставить статус инвойса вручную, обосновав свои действия в поле комментария.

В случае возникновения систематических ошибок обнаружения полей на изображениях инвойсов, оператор имеет возможность обучить программу прямо в процессе ввода документов, указывая правильные позиции полей на изображении.

Документы с различными статусами могут быть выгружены из программы по-разному, для того, чтобы обеспечить их различную обработку в вашей финансовой системе. Причины ручной смены статуса оператором будут также доступны в вашей системе.

Возможность смены статуса инвойса оператором: указание собственной причины смены статуса, список предопределенных причин

Оператор может игнорировать ошибки и предупреждения, выданные системой правил, и установить статус инвойса вручную. При этом ему потребуется ввести комментарий или выбрать причину ручной смены статуса из списка заранее заданных.

  1. В меню Проект выберите пункт Определения документов….
  2. В открывшемся окне нажмите кнопку Правка….
  3. В меню Определение документа выберите пункт Свойства определения документа….
  4. В открывшемся окне перейдите на вкладку Настройки инвойсов.
  5. Нажмите кнопку Правка… справа от группы Управление статусами инвойса. Откроется окно Причины изменения статуса.

Редактирование списка предопределенных причин:

Выбирая из списка Статус нужное значение, можно просмотреть список существующих причин.

Чтобы добавить собственную причину, нажмите кнопку Добавить…. В окне Причина изменения статуса введите новую причину смены статуса и ее код.

Чтобы загрузить причину из текстового файла, нажмите кнопку Загрузить….

Возможность указывать собственную причину смены статуса:

Отметьте Разрешен ввод новых причин, если вы хотите, чтобы оператор мог вводить собственную причину смены статуса.

Как настроить экспорт данных по типу статуса

Настройка экспорта для ABBYY FlexiCapture for Invoices в целом не отличается от настройки в ABBYY FlexiCapture (См. "Настройка экспорта данных"). Подробнее о том, как настроить экспорт по типу статуса в ABBYY FlexiCapture for Invoices См. "Настройка экспорта данных".

Правила, влияющие на статус инвойса

Чтобы посмотреть правила:

  1. В меню Определение документа выберите пункт Свойства определения документа….
  2. В открывшемся окне перейдите на вкладку Правила.

В проекте ABBYY FlexiCapture for Invoices для правил реализована дополнительная возможность — влиять на статус инвойса.

Чтобы правило влияло на статус инвойса, необходимо к его имени добавить префикс (Rejected) или (Exception). Тогда ошибка при проверке данного правила будет приводить к соответствующему статусу. Добавить нужный префикс можно либо при создании нового правила, либо при редактировании существующего.


Обучение настройщиком проекта

Обучение в процессе настройки ABBYY FlexiCapture for Invoices предполагает, что администратор вводит тестовую выборку инвойсов и использует Режим обучения в процессе ввода инвойсов. Если результат такого обучения неудовлетворителен, то администратор переходит в вид пакетов обучения, где ему доступен расширенный набор возможностей для обучения. По завершению обучения администратор может разрешить (или запретить) операторам продолжать обучение инвойсов от данного поставщика в процессе ввода.

Замечание. Описываемые в данном пункте действия может выполнить только пользователь с ролью Администратор или Настройщик проекта.

Вид пакетов обучения отображает все наборы изображений, которые были добавлены для обучения с помощью кнопки [image]. Для перехода к виду воспользуйтесь кнопкой [image] — Пакеты обучения на панели инструментов или пунктом меню Вид>Пакеты обучения.

Программа отобразит список всех разновидностей инвойсов, которые операторы добавили в набор для обучения, нажимая кнопку [image].

Разновидность инвойсов определяется поставщиком и имя разновидности совпадает с названием компании поставщика. В столбцах для удобства поиска отображены такие параметры поставщика, как VATID (уникальный номер компании, используемый для уплаты налогов), IBAN, ID поставщика в справочнике и прочие.

В данном виде возможно управлять каждой конкретной разновидностью или создать новую:

Collapsed Управлять выборками примеров, которые участвуют в обучении Разновидности гибкого описания

Для этого дважды кликните по разновидности документов или выберите пункт Открыть из контекстного меню. При этом откроется список примеров данной разновидности.

Каждый пример находится в одном из трёх состояний:

  • Не используется - не используется;
  • Для обучения - пример используется для обучения и тестирования Разновидности гибкого описания;
  • Для тестирования - пример используется только для тестирования Разновидности гибкого описания;

Для обучения Разновидности гибкого описания в данном режиме достаточно даже одного примера изображения. Но рекомендуется иметь как минимум три примера в состоянии Для обучения.

Если примеров не хватает, добавьте изображения для данной разновидности документа с помощью команды Загрузить изображения…. Новые изображения по умолчанию добавляются в состоянии Не используется.

Если распознавание добавленных изображений не запустилось автоматически, распознайте добавленные примеры с помощью команды Распознать.

  1. Переведите документы, которые должны участвовать в обучении Разновидности гибкого описания, в состояние Для обучения. Для этого выделите нужные документы, кликните правой клавишей мыши и выберите из контекстного меню Установить состояние документа>Для обучения. Рекомендуем для начала перевести в данное состояние все документы разновидности.
  2. Проверьте разметку всех регионов полей документов, исправьте её положение на правильное в случае необходимости. Это необходимо сделать, так как обучение будет учитывать расположение регионов всех полей на документах.
  3. Запустите обучение для Разновидности гибкого описания. Для этого:
  • выберите в главном меню Проект>Обучение>Обучить;
  • кликните правой клавишей мыши в пустом месте списка и выберите пункт Обучить из контекстного меню;
  • перейдите в вид пакетов обучения и выберите пункт Обучить из контекстного меню разновидности.

В окне Обучить определение документа будет отображен ход операции. На документах будет запущен процесс обучения, в результате которого будет сгенерирована разновидность гибкого описания . Далее разновидность гибкого описания для будет протестирована на всех документах в состояниях Для обучения и Для тестирования. В процессе тестирования разновидность гибкого описания накладывается на каждый документ выборки (незаметно для пользователя), а результат наложения сравнивается с эталонной разметкой, т.е. той разметкой, которую на документе задал пользователь. Таким образом вычисляется качество наложения Разновидности гибкого описания.

Если качество наложения выше, чем качество Основного гибкого описания и последней версии Разновидности гибкого описания, созданного в предыдущих итерациях обучения для данной разновидности, то обученное гибкое описание для разновидности сохраняется и будет использоваться в работе.

Если по вашему мнению какие-то примеры инвойсов негативно влияют на обучение, но вы хотите использовать их при тестировании качества Разновидности гибкого описания, вам необходимо перевести эти примеры в состоянии Для тестирования.

Важно понимать, что документы на момент обучения (нажатие кнопки [image]) должны быть распознаны и иметь правильное расположение регионов всех полей, а тестирование будет выполняться программой автоматически, незаметно для пользователя в процессе обучения нового гибкого описания для разновидности.

Collapsed Выгрузить Разновидность гибкого описания в FlexiLayout Studio для ручной настройки

Для этого кликните правой клавишей мыши по разновидности и выберите пункт Экспортировать обученное гибкое описание… из контекстного меню.

Это может понадобиться, если не удаётся добиться удовлетворительного качества обработки инвойсов разновидности только путём управления выборкой примеров для обучения.

Collapsed Загрузить Разновидность гибкого описания, созданную в FlexiLayout Studio

Для этого кликните правой клавишей мыши по разновидности и выберите пункт Импортировать гибкое описание… из контекстного меню.

Это может понадобиться, если гибкое описание для разновидности было разработано вручную с помощью инструмента для разработки гибких описаний FlexiLayout Studio.

Collapsed Запретить дальнейшее обучение для данного поставщика

Для этого кликните правой клавишей мыши по разновидности и выберите пункт Заблокировано из контекстного меню.

Это может потребоваться, если гибкое описание для разновидности уже было обучено (или было разработано вручную) и не нуждается в дообучении операторами в процессе ввода.

Collapsed Отключить применение результатов обучения для данного поставщика

Для этого кликните правой клавишей мыши по разновидности и выберите пункт Отключено из контекстного меню.

Это необходимо, если вы хотите, чтобы для обработки инвойсов от данного поставщика использовалось исключительно Основное гибкое описание.

Collapsed Создать новый пакет обучения

Создание нового пакета обучения может потребоваться в том случае, если вы хотите обучить Разновидность гибкого описания до начала ввода инвойсов операторами.

  1. Кликните правой клавишей мыши в виде пакетов обучения и выберите из контекстного меню пункт Новый пакет….

После создания пакета обучения необходимо связать его с определением документа (если в проекте используется более одного определения документа) и поставщиком, для инвойсов которого должен применяться результат обучения.

  2. Если в проекте имеется более одного определения документа, выберите необходимое из списка доступных определений документа (диалоговое окно Выберите определение документа).
  3. Затем выберите запись Поставщика, к которому этот пакет обучения будет привязан (диалоговое окно Поиск поставщика для пакета обучения).

В виде пакетов обучения есть столбцы VendorID и Определение документа, значения которых определяют поставщика и определение документа соответственно, с которыми связан пакет обучения.

Замечание. Важно, чтобы документы в пакете обучения были распознаны тем определением документа, с которым связан пакет.

Чтобы изменить поставщика или определение документа, с которыми связан пакет обучения, используйте пункты контекстного меню пакета: Изменить поставщика…, Изменить определение документа….

Команда Убрать определение документа отвязывает пакет от определения документа — в таком состоянии пакет не может быть использован для обучения.

  4. Загрузите изображения документов в пакет обучения, например, с помощью команды Загрузить образцы…. После чего документы будут автоматически распознаны.
  5. Проверьте правильность наложения регионов полей, исправьте их при необходимости.
  6. Переведите документы, которые должны участвовать в обучении Разновидности гибкого описания, в состояние Для обучения. Для этого выделите нужные документы, кликните правой клавишей мыши и выберите из контекстного меню Установить состояние документа>Для обучения.
  7. Запустите обучение для Разновидности гибкого описания. Для этого:
    • выберите в главном меню Проект>Обучение>Обучить;
    • кликните правой клавишей мыши в пустом месте списка и выберите пункт Обучить из контекстного меню;
    • перейдите в вид пакетов обучения и выберите пункт Обучить из контекстного меню разновидности.

Состояние разновидности документов отображается в столбце Состояние списка пакетов обучения. Для обучения гибкого описания для разновидности документа необходимо как минимум три примера. Поэтому обучение запустится, если в процессе ввода инвойсов с помощью кнопки [image] будет добавлено не менее трёх примеров разновидности. До этого момента в столбце Состояние будет отображаться состояние Сбор образцов. После того, как разновидность гибкого описания обучена, а её качество признано программой удовлетворительным, отображается состояние Стабильный.


Обучение в процессе ввода инвойсов

ABBYY FlexiCapture for Invoices предоставляет возможность оператору улучшить качество автоматической обработки документов непосредственно в процессе ввода. Для этого оператор в том случае, если программа не смогла правильно автоматически определить расположение поля на изображении документа, может указать правильное расположение поля и нажать кнопку [image]. Данная информация будет использована программой для обработки последующих документов.

Данная статья описывает, как использовать обучение в процессе ввода с помощью многофункциональной станции верификации, а также некоторые особенности обучения, которые должен знать оператор. Отличия в использовании обучения в процессе ввода с помощью удалённой и Web станций верификации описаны в отдельной статье.

  1. Возьмите пачку инвойсов (например, ваши инвойсы за последний месяц) и начните их ввод. См. "Как вводить инвойсы".
  2. После добавления в программу документы автоматически распознаются (если включена опция Автоматически распознавать добавленные изображения: пункт меню Сервис> Опции…, вкладка Обработка документов) и проверяются с помощью правил.
  3. Если получившийся в результате статус инвойса отличается от Valid или у вас есть какие-то иные основания предполагать, что поля на изображения не были найдены программой или были найдены неверно, откройте документ в редакторе документа.
  4. Просмотрите форму документа. Группа полей Vendor должна быть заполнена корректно.
Collapsed Подробнее

Обучение документов работает независимо для каждой разновидности документов. Инвойсы от одного поставщика считаются одной разновидностью документов. Если поставщик будет определён неправильно, то при обучении документ будет отнесён не к своей разновидности. Если поставщик не нашелся, выберите его с помощью поиска поставщиков в базе данных. Если поставщика не удаётся найти в базе данных, заполните формы полей группы Поставщик, введя данные с изображения, и сохраните в базу данных, нажав кнопку Сохранить.

В зависимости от настроек проекта ABBYY FlexiCapture for Invoices, чтобы обучение стало доступно для данного инвойса, может потребоваться также указать уникальный идентификатор поставщика: заполнить значение поля VATID (в локализованной на ваш язык версии проекта поле может иметь другое название). VATID — это уникальный идентификационный номер компании для уплаты налогов.

  5. Для обучения необходимо, чтобы разметка регионов всех полей на изображении соответствовала реальному расположению полей инвойса. Поэтому ваша цель — обеспечить правильное расположение регионов полей на изображении.

Для этого в окне изображения редактора документа исправьте разметку регионов полей или нарисуйте регионы для тех полей, которые не наложились вовсе.

Collapsed Как редактировать разметку регионов полей
  • поместить курсор в нужное поле на форме данных, на изображении найти соответствующий регион (он подсвечивается синим цветом), кликнуть по нему (или нарисовать разметку региона мышью);
  • поместить курсор над нужным регионом на изображении (он подсвечивается синим цветом), кликнуть по нему (или нарисовать регион мышью), из появившегося списка выбрать соответствующее поле;
  • на изображении исправить местоположение региона, передвигая при помощи мыши его границы;
  • на изображении удалить существующий регион, для чего навести курсор на его разметку, в верхнем правом углу появится красный крестик, кликнуть на него — разметка региона будет удалена. После этого создать регион для данного поля в нужном месте;
  • на форме данных начать ввод значения в поле с клавиатуры, при этом появится выпадающий список, который будет содержать все слова, распознанные на изображении и похожие на вводимое значение. Выберите значения из списка, и позиция слова на изображении станет регионом поля.
  6. Если все поля документа теперь размечены правильно, нажмите кнопку [image] — документ будет добавлен в набор примеров данной разновидности инвойсов.

Кнопка [image] становится доступна для нажатия, если выполнены все необходимые для обучения условия:

  • изменена разметка хотя бы одного региона на изображении

Внимание! Обучение для регионов полей, которые были удалены, не работает.

  • данные о поставщике заполнены корректно.

Если кнопка [image] недоступна, то при наведении курсора мыши на кнопку появляется подсказка с описанием причины недоступности кнопки.

При нажатии на кнопку в обучении будут участвовать все поля инвойса, а не только те, разметку для регионов которых вы нарисовали или изменили. Поэтому важно нажимать кнопку [image] только в случае, когда все регионы всех полей правильно расположены на изображении.

После того, как в набор примеров разновидности инвойсов будет добавлен хотя бы один инвойс, для следующего документа данной разновидности кнопка [image] будет доступна сразу. Это сделано для того, чтобы у вас была возможность пополнить набор примеров разновидности также и теми инвойсами, на которых все поля находятся правильно и нет необходимости исправлять какую-либо разметку на изображении.

  7. Перейдите к следующему документу и выполните действия из пунктов 4 – 6.
  8. При добавлении в набор третьего и всех последующих инвойсов от одного и того же поставщика запустится процесс обучения — пользователю будет показано окно Обучить определение документа, т.е. для данной разновидности инвойсов будет либо обучено специальное гибкое описание (разновидность гибкого описания), либо программа предложит продолжить накопление примеров (в этом случае перейдите к следующему документу и вернитесь к шагу 4).

Если гибкое описание для альтернативы было успешно обучено, то уже на следующем инвойсе от поставщика, определяющего данную разновидность инвойсов, оно начнёт применяться — после распознавания регионы полей будут наложены на изображение инвойса с учётом результатов обучения.

Кнопка [image] вернётся в обычный режим работы — будет доступна для нажатия только после того, как была изменена разметка хотя бы одного региона поля на изображении.

Теперь накоплено достаточное число примеров разновидности инвойса. Обучение будет запускаться при каждом добавлении нового изображения в набор (при каждом нажатии кнопки [image]). Нажимайте эту кнопку только в случае, если какие-либо из регионов полей наложились неверно, и их положение пришлось исправлять на изображении.

  9. Введите ещё несколько инвойсов от поставщика, для которого обучение было успешно выполнено. После распознавания откройте каждый новый документ в редакторе документа и проверьте правильность расположения разметки регионов полей. В случае если все регионы располагаются правильно, обучение можно считать законченным.

Если по каким-то причинам ожидаемого результата достигнуть не удалось, продолжите обучение на введённых инвойсах от данного поставщика (шаги 4 – 6). Теперь каждый раз при нажатии кнопки [image] будет запускаться процесс обучения и, в случае успеха, создаваться новая версия гибкого описания для разновидности.

Также См. "Обучение настройщиком проекта"


Параметры лицензии

У каждой лицензии есть свой серийный номер. Лицензия состоит из набора параметров. Набор параметров лицензии определяет право пользователя на выполнение отдельных операций.

Параметры лицензии:

  • Общие - серийный номер, способ лицензирования, возможность работы на виртуальной машине.
  • Назначение лицензии – тип лицензии (программная или аппаратная), возможность оказания услуг по вводу документов.
  • Станции и их количество, Инструменты - ограничения по количеству используемых станций и инструментов разработки (FlexiLayout Studio, FormDesigner).

    Замечание. В зависимости от типа лицензии, ограничения на количество используемых станций могут указываться как отдельно для установленных и Web-станций, так и совместно для станций обоих типов.

  • Производительность – ограничения на количество страниц и ядер процессора. Для страниц отображается общее количество страниц для лицензии и количество страниц, доступных на данный момент.
  • Обработка – дополнительные параметры обработки документов: использование гибких описаний, дополнительных языков распознавания.
  • Пользовательские компоненты (в том числе определения документов) – параметры и использования компонентов, разработанных пользователями системы.

Для того, чтобы вы могли обрабатывать инвойсы, в Пользовательских компонентах должен быть компонент от вендора ABBYY HQ с названием EuropeanInvoice.

Компонент EuropeanInvoice.AddOn.LineItems позволяет включить извлечение дополнительных полей — Извлечение позиций.

  • Импорт – дополнительные возможности импорта; указывает, разрешен ли ISIS протокол и открытие PDF файлов.
  • Экспорт – дополнительные возможности при экспорте документов и изображений; указывает, разрешен ли экспорт в PDF с возможностью поиска и расширенный XML экспорт.


Выбор вида формы

Кроме учета особенностей дизайна и обработки форм необходимо учитывать следующие характеристики видов форм: сложность изготовления, тиражирование, стоимость печати, размер изображения, режим сканирования, время обработки изображения, качество распознавания, расположение пояснительной информации, привлекательность, качество заполнения. Для удобства сравнения видов форм, мы собрали их характеристики в сводную таблицу:

Критерий | Цветная фоновая форма |  | Черно-белая растровая форма |  | Черно-белая линейчатая форма
 | Недостаток | Преимущество | Недостаток | Преимущество | Недостаток | Преимущество
Сложность изготовления |  | Простота изготовления в любом редакторе. | Ограниченные возможности по созданию форм в текстовых редакторах. Важность размера точек растра. |  |  | Простота изготовления в графических редакторах.
Тиражирование | Сложность тиражирования в условиях офиса. |  |  | Возможность тиражирования в условиях офиса. |  | Возможность тиражирования в условиях офиса.
Стоимость печати | Выше стоимость изготовления при типографском способе тиражирования по сравнению с черно-белой формой. |  |  | Ниже стоимость изготовления при типографском способе тиражирования по сравнению с цветной фоновой формой. |  | Ниже стоимость изготовления при типографском способе тиражирования (по сравнению с цветной фоновой формой).
Размер изображения |  | Меньший размер отсканированного изображения. | Больший размер отсканированного изображения. |  | Больший размер отсканированного изображения. |
Режим сканирования | Сканирование только в определенных режимах. |  | Меньшая свобода в подборе яркости и контрастности. |  | Меньшая свобода в подборе яркости и контрастности. |
Время обработки изображения |  | Меньше среднее время автоматической обработки. | Больше среднее время обработки за счет необходимости очистки "мусора" на изображении. |  | Большая вероятность ошибок распознавания при касании или "наползании" символов на ограничители. |
Качество распознавания |  | Очень высокое качество распознавания. |  | Высокое качество распознавания. | Сильно зависит от аккуратности заполнения. | При правильном заполнении высокое качество распознавания.
Расположение пояснительной информации |  | Более гибкое расположение пояснительной информации (вплоть до размещения непосредственно внутри полей для ввода). | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |  | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |
Привлекательность и читаемость | Выбор низкой контрастности фона и цвета пояснительной информации может снизить читаемость формы. | Наиболее привлекательный вид формы. | Менее привлекательные формы. Не очень удобны для зрительного восприятия. |  | Менее привлекательные формы. | Хорошая читаемость.
Качество заполнения |  | Менее чувствительны к выходу текста за рамки полей. | При заполнении формы символы должны быть написаны четко и крупно, чтобы они не были удалены вместе с мусором. | Менее чувствительны к выходу текста за рамки полей. | Очень чувствительны к выходу текста за рамки полей. |


Поле метки

Поле метки - это элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении формы вносится метка (галочка, крест, сплошная закраска и т.д.).

Поле метки обычно сопровождается описательным текстом, поясняющим смысл метки.

Collapsed Показать поле метки

Поле метки может иметь ограничители следующих типов:

Квадрат
Круг
Подчеркивание

Возможны и другие типы ограничителей поля метки: многоугольник, овал и т.д.


Создание машиночитаемых форм

Анкеты, карточки социального страхования, опросные листы, бюллетени, гарантийные талоны и т.д. - все это формы, используемые для сбора разного рода информации.

Что отличает формы от обычных документов?

  1. В отличие от обычных документов форма всегда имеет фиксированный набор полей.
  2. В каждом поле формы может находиться информация строго определенного содержания: например, в поле "Фамилия" может находиться только фамилия (если, конечно, заполнивший форму не вписал туда по ошибке адрес), в поле Дата - дата и т.д.

Использование форм обычно подразумевает получение информации от большого числа респондентов с последующей компьютерной обработкой полученных данных.

Ручной ввод информации в компьютер очень трудоемок. Более того, такая форма работы ведет к большому количеству ошибок (опечаток), на исправление которых уходит много времени. Поэтому эффективнее автоматизировать процесс ввода форм.

Процесс автоматизированного ввода форм состоит из следующих стадий:

  1. Настройка программы автоматизированного ввода на обработку формы данного образца (описание формы, выделение на образце формы данных для распознавания).
  2. Создание изображения формы (сканирование).
  3. Обработка изображений программой автоматизированного ввода (распознавание и проверка данных).
  4. Экспорт данных во внешнюю информационную систему.

Наиболее просто и эффективно производится автоматическая обработка форм, удовлетворяющих специальным требованиям. Им и будет посвящена эта глава.

Машиночитаемая форма
Элементы машиночитаемой формы
Заполнение формы
Виды машиночитаемых форм
Выбор вида формы
Требования к машиночитаемым формам


Элементы машиночитаемой формы

Рассмотрим подробнее элементы машиночитаемой формы:

Текст
Поле для ввода
Поле метки
Группа меток
Репер
Разделитель
Идентификатор
Картинка
Таблица
Группа элементов


Поле для ввода

Поле для ввода - это элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы. Для удобства ввода символов в таком поле может присутствовать разметка. Поле для ввода обычно сопровождается описательным текстом, поясняющим смысл вводимого текста.

Collapsed Показать поле для ввода

Существует несколько типов разметки текста:

Текст на линии | Тип разметки текста, при котором ограничителем текста является линия снизу.
Буквы в рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки не изолированы друг от друга.
Буквы в изолированных рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки изолированы друг от друга.
Буквы в гребенке | Тип разметки текста, при которой ограничителем текста является гребенка.
Текст в рамке | Тип разметки текста, при котором ограничителем текста является рамка.
Текст в рамке с гребенкой | Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки.


Заполнение формы

Форма может быть заполнена следующими способами:

  • От руки.
  • На матричном принтере.
  • На пишущей машинке.
  • Типографским способом. К данному способу относится также заполнение на принтерах (не матричных), которые обеспечивают разрешение не менее 300 точек на дюйм.
  • Заполнение представляет собой комбинацию любых способов заполнения, перечисленных в предыдущих пунктах.


Машиночитаемая форма

При обработке форм программа автоматизированного ввода сталкивается с рядом задач, от решения которых зависит качество распознавания данных из формы.

Выделим две из них:

  1. Определение положения элементов на изображении формы.
  2. Отделение внесенной в форму информации (данных) от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Чтобы облегчить программе решение этих задач, создаются специальные машиночитаемые формы.

Для решения первой задачи машиночитаемым формам выдвигается требование точного соответствия формы образцу. Это значит, что у всех форм одного образца расположение элементов формы должно быть одинаковым (совпадать на просвет).

Для решения второй задачи к машиночитаемым формам предъявляется требование специального дизайна формы: он должен позволять корректно отделить собственно данные от элементов формы: разметки текста, границ полей, фона, пояснительных надписей и др.


Группа элементов

Группа элементов - элемент машиночитаемой формы, предназначенный для объединения в группу нескольких логически связанных элементов.


Группа меток

Группа меток - это элемент машиночитаемой формы, объединяющий несколько находящихся вблизи друг от друга полей меток, из которых при заполнении формы будет заполнено только одно. Группа меток обычно сопровождается описательным текстом, поясняющим смысл группы.

Collapsed Показать группу меток


Идентификатор

Идентификатор - это элемент машиночитаемой формы, однозначно характеризующий форму данного образца. Если при распознавании невозможно однозначно определить по реперам принадлежность формы к образцу (т.е. реперы у нескольких форм различных образцов совпадают), то для точного определения используется идентификатор. Рекомендуется в качестве идентификатора использовать штрих-код.

Штрих-код - это набор штриховых знаков, кодирующих информацию посредством чередующихся полос черного и белого цвета различной ширины.

Collapsed Показать штрих-код

Возможно использование и других элементов в качестве идентификаторов.


Картинка

Картинка - это элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в графическом формате.

Любое графическое изображение, место для печати или подписи - все это картинки.


Репер

Репер - это элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

Первое, что определяется при распознавании данных из формы, это принадлежность формы к тому или другому образцу. Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование точного соответствия формы образцу. Количество и расположение реперов является основной характеристикой принадлежности формы к тому или другому образцу. Настроенная на работу с формами данного образца программа автоматизированного ввода ориентирует форму, т.е. пытается расположить её так, чтобы реперы совпали с реперами образца. Если реперы совпали, то программа может определить, к какому образцу относится данная форма и где находятся данные для распознавания.

Стандартные реперы:

Черный квадрат
Уголок
Крест
Черный прямоугольник

Присутствие стандартных реперов на машиночитаемой форме крайне желательно, хотя в некоторых случаях в качестве репера может использоваться разделитель, описательный текст или штрих-код. Эти варианты реперов считаются приемлемыми, но по возможности их следует избегать, т.к. они могут привести к ухудшению распознавания формы.


Требования к машиночитаемым формам

Познакомившись с элементами машиночитаемых форм, их видами и типами разметки текста, систематизируем и сформулируем требования, при соблюдении которых созданная форма будет машиночитаемой.

Требования к фону формы
Требования к реперам формы
Требования к полю метки
Требования к геометрическим параметрам разметки текста на формах
Требования к размещению элементов формы
Требования к тиражированию
Требования к заполнению форм от руки


Требования к фону формы

  1. По возможности используйте Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация. цветную фоновую форму или Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками). форму с растровыми ограничителями полей ввода.
  2. При проектировании цветной фоновой формы используйте цвет, фильтруемый при сканировании. Перечень рекомендованных цветов приведен в разделе Рекомендуемые цвета для разработки цветных фоновых форм.
  3. На цветной фоновой форме пояснительную информацию рекомендуется выполнять в том же цвете, что и фон формы (кроме случаев, когда по каким-либо причинам вы не можете разместить на форме стандартные реперы и вынуждены использовать черный статический текст в качестве реперов). Если цвета фона и пояснительной информации совпадают, то пояснительная информация может быть размещена внутри полей ввода.
  4. Не используйте оттенки синего для фона тех форм, которые будут заполняться от руки. Такой фон может слиться с синей ручкой, что отрицательно скажется на качестве распознавания.


Требования к полю метки

  1. Рекомендуемый размер Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.). поля метки - 3,5х3,5 мм; 4х4 мм; 4,5х4,5 мм; 5х5 мм (в случае ограничителя поля метки типа Круг приведенный размер - это размер квадрата, в который вписан ограничитель)
  2. Рекомендуемая толщина линии ограничителя поля метки - 0,4 мм (при любом размере поля метки).


Требования к размещению элементов формы

  1. Рекомендуется оставлять по краям формы отступы. Это требование вызвано тем, что элементы, размещенные слишком близко к краям формы, могут пропасть при сканировании, что приведет к потере части информации.
  2. Рекомендуемое расстояние между элементами формы: не менее 2 мм.
  3. Рекомендуемое расстояние между Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.). полем метки и поясняющим текстом: не менее 2/3 размера поля метки.
  4. Пояснительная информация должна размещаться на форме так, чтобы она не пересекалась с полями для ввода информации.
  5. Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов не менее 1,5-2 мм. Если пояснительная информация выполнена в цвете фона, можно не отслеживать расстояние между пояснительной информацией и другими элементами формы.


Требования к заполнению форм от руки

Цвет и вид ручки

Формы лучше всего заполнять черной перьевой, капиллярной, гелевой или шариковой ручкой. Темно-синяя или фиолетовая ручка тоже дает хорошие результаты (особенно на цветных фоновых формах). Фломастер приводит к более низкому качеству распознавания из-за заливания мелких деталей. Хуже всего распознаются карандаш и светлая цветная ручка.

Размер и написание букв

Для улучшения качества распознавания формы лучше всего заполнять раздельными прописными буквами. Размер буквы должен быть таким, чтобы буква занимала все пространство Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.). знакоместа, но не касалась его границ.

Если знакоместа явно выделены на форме, т.е. используются следующие типы разметки текста: буквы в рамках, буквы в изолированных рамках, то проще управлять заполняющим форму, т.к. требуемый размер букв явно указан знакоместом и явное наличие знакомест мешает написать буквы слитно.

Сложнее ситуация при использовании разметки текста следующих типов: текст в рамке с гребенкой или буквы в гребенке. Здесь задается ширина знакоместа, но из-за отсутствия полных боковых ограничителей ничто не мешает заполняющему форму написать буквы слитно. И если в первом случае высота знакоместа указана явно, то во втором случае может возникнуть ситуация, когда заполняющий форму впишет слишком маленькие или слишком высокие буквы.

В разметках текста "текст в рамке" или "текст по линии" вообще не содержится информации о ширине знакоместа. Поэтому ничто не мешает заполняющему форму написать буквы слитно, что приведет к значительному ухудшению качества распознавания. В разметке текста "текст по линии" также отсутствует информация о высоте знакоместа, поэтому этот тип разметки не рекомендуется применять для форм, требующих высокого качества распознавания данных.

Помимо размера букв и раздельности написания, важным требованием является требование отсутствия "наползания" символов на ограничители. Это требование не так актуально для цветной фоновой или черно-белой растровой формы, т.к. ограничители в этих формах пропадут после сканирования и очистки изображения. А для черно-белой линейчатой формы это требование очень актуально, т.к. нарушение этого требования влечет за собой значительное ухудшение качества распознавания.

Образец заполнения

Чтобы обратить внимание респондента на перечисленные особенности заполнения формы, на форме рекомендуется указывать образец заполнения. Обычно он содержит рекомендации по заполнению данной формы и образцы букв, цифр и символов, необходимых для заполнения.


Требования к реперам формы

  1. Рекомендуется размещать на форме стандартные Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода. реперы (черные квадраты, уголки, кресты) в количестве 5 штук: четыре - по углам формы (при соединении центров этих реперов должен получаться прямоугольник) и один - на одной из сторон этого прямоугольника.
  2. Если по каким-то причинам на форме невозможно разместить стандартные реперы, то рекомендуются следующие комбинации элементов: а) не менее 2-х горизонтальных Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию. разделителей и 2-х вертикальных разделителей; б) не менее 4-х элементов Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д. Текст и элемент Элемент машиночитаемой формы, однозначно характеризующий данную форму. Идентификатор; в) возможны другие комбинации этих элементов.
  3. Расстояние от репера до ближайшего элемента формы должно быть не менее 3 мм.
  4. Расстояние от репера до края листа должно быть не менее 8 мм.
  5. Реперы должны быть выполнены в темном цвете, не исчезающем при сканировании. Лучше всего для этого подходит черный цвет.
  6. На форме должны быть реперы, расположенные так, чтобы все заполняемые поля находились внутри ограниченной ими области.

Помимо вышеперечисленных общих требований ко всем реперам, для каждого типа реперов существуют специальные требования:

Требования к Черным квадратам

На формах одного типа все квадраты должны иметь одинаковый размер: от 4х4 мм до 8х8 мм. Рекомендуемый размер 5х5 мм. Прямоугольники не допускаются.

Требования к Уголкам и Крестам

  1. Длина стороны квадрата, описанного вокруг реперов, должна находиться в интервале от 4 мм до 8 мм. Рекомендуемый размер 5 мм.

  2. Размеры реперов одного вида должны быть одинаковыми внутри одной формы.

  3. Стороны реперов должны быть равными.

  4. Толщина линий реперов должны быть одинаковыми внутри одной формы и находиться в интервале от 0,3 мм до 1 мм. Рекомендуемая толщина 0,5 мм.

Требования к элементу Текст (в случае использования элемента в качестве репера)

Должен использоваться шрифт размером не менее 7 пунктов. Для заголовков и крупных надписей рекомендуется использовать шрифт размером не менее 14 пунктов.

Требования к элементу Разделитель (в случае использования элемента в качестве репера)

Толщина линии должна быть не менее 0,8 пункта. Рекомендуемая толщина 0,8-1,5 пункта.

Требования к штрих-коду (в случае использования элемента в качестве репера)

  1. Ширина штрих-кода (расстояние между крайней левой и крайней правой полосами штрих-кода) - 47-50 мм.
  2. Высота штрих-кода (без учета цифр) - 12-15 мм.
  3. Ориентация штрих-кода (направление полос) должна совпадать с ориентацией формы.
  4. Рекомендуется использовать штрих-код типа EAN 13.
  5. Рекомендованное расстояние от штрих-кода до любых элементов формы должно быть не менее 10 мм.


Требования к тиражированию форм

При изготовлении форм необходимо выполнять следующие требования:

  1. Формы могут быть изготовлены типографским способом или распечатаны на принтере. Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация. Цветные фоновые формы рекомендуется изготавливать в типографии, в противном случае необходимо тестирование цвета формы на сканере. Необходимо проводить тестирование пробного тиража, полученного из типографии.
  2. Все экземпляры одного типа должны быть отпечатаны с одного образца. Они должны "совпадать на просвет".
  3. Поля формы (расстояние от края листа до ближайшего объекта) должны быть не менее 8 мм, рекомендуется делать поля не менее 12 мм.
  4. Допустимое отклонение по линейным размерам элементов на форме не более 0.15%, что составляет 0,5 мм при формате А4.
  5. При печати формы нужно использовать лазерные принтеры с разрешением не менее 600 точек на дюйм.
  6. Желательно распечатывать формы на одном и том же принтере или на разных принтерах одной и той же модели.

    Совет. Не рекомендуется множить машиночитаемые формы с использованием копировальной техники. В этом случае происходит изменение размеров и смещение элементов формы: утолщение рамок или растра ограничителей полей ввода, изменение насыщенности цветов, что ухудшает качество распознавания.


Требования к геометрическим параметрам разметки текста на формах

Точки растра:

  1. В случае использования Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками). черно-белой формы с растровыми границами размер точек растра должен составлять 0,39 пункта.
  2. Оптимальное расстояние между точками растра - в пять раз больше размера самой точки.

    Внимание! Обычно угроза "склеивания" точек возникает по углам Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.). знакоместа, поэтому особое внимание следует уделять именно угловым точкам.

    Совет. Если редактор не позволяет задать расстояние между точками растра, необходимо выбрать такой стиль линии, чтобы ее точки были расположены на достаточном расстоянии друг от друга и не "склеивались" на отсканированном изображении.

Размер знакоместа:

  1. Рекомендуемый размер знакоместа - 4х5 мм, меньший размер знакоместа использовать не рекомендуется, т.к. поля с таким размером знакоместа требуют более аккуратного заполнения, что не всегда удается обеспечить. Также не рекомендуется использовать знакоместа очень большого размера: для получения хорошего результата при распознавании такие поля требуется заполнять непривычно большими буквами. Размер знакоместа должен примерно соответствовать общепринятым нормам письма.
  2. Рекомендуемое расстояние между строчками: не менее 2,5-3 мм. Расстояние между знакоместами по горизонтали: не менее 1-1,2 мм.
    Collapsed Показать иллюстрацию

Толщина линий разметки текста:

  1. Если границы представлены черными линиями, что соответствует типам разметки Текст в рамке, Буквы в изолированных рамках или Буквы в рамках, - толщина линий должна составлять 1 пункт.
    Collapsed Показать иллюстрацию

Гребенки:

  1. Рекомендуемый шаг гребенки в пределах одного поля формы: 5 мм.
  2. Рекомендуемое расстояние между строчками: не менее 7,5-8 мм.
  3. Рекомендуемая высота "гребенки": 0,9-1,2 мм.
  4. Рекомендуемая толщина линий гребенки: 1 пункт.
  5. В случае выполнения границы в виде "гребенки в рамке" минимальное расстояние между рамками должно быть 2,5-3 мм.
    Collapsed Показать иллюстрацию


Разделитель

Разделитель - это элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Разделитель используется для визуального разделения формы на несколько смысловых частей.


Таблица

Таблица содержит столбцы с однотипными элементами.

Столбцы таблицы могут содержать элементы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.

Таблица может содержать строку с заголовками столбцов.


Текст

Текст - это элемент машиночитаемой формы, представляющий собой описательный текст (название формы, название полей, пояснения к полям и т.д.).


Виды машиночитаемых форм

Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование к дизайну формы: дизайн формы должен позволять корректно отделить внесенную в форму информацию от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Существует два различных подхода для реализации этого требования:

  1. Дизайн формы создается таким образом, чтобы при сканировании формы и последующей очистке изображения разметка текста, границы полей и фон исчезали.
  2. Дизайн формы создается таким образом, чтобы на изображении формы после сканирования и очистки изображения были четко выделены разметка текста и границы полей.

При использовании первого подхода на изображении формы после сканирования и очистки остаются только реперы, описательный текст и информация, которую ввели при заполнении формы. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении данные, не ограниченные никакой разметкой, что сузит задачи программы и повысит качество распознавания.

Для реализации этого подхода используются формы следующих видов: цветные фоновые формы, черно-белые формы с растровым фоном, черно-белые формы с растровыми границами, и черно-белые линейчатые формы.

При использовании второго подхода на изображении формы после сканирования остаются реперы, описательный текст, информация, которую ввели при заполнении формы, а также разметка текста и границы полей. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении именно ограниченные разметкой данные. Отсутствие разметки приведет к ухудшению качества распознавания.

Для реализации этого подхода используются черно-белые линейчатые формы.


Цветные фоновые формы

Цветные фоновые формы - это формы с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация. Например, Серые фоновые формы. Фон этих форм выполнен серым цветом.

Частным случаем цветных фоновых форм являются форма, на которых фоном выделены только ограничители полей для ввода информации.

Знакоместо - это прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.)

Цвет фона имеет большое значение, т.к. при сканировании фон таких форм должен "пропадать". Обычно фон имеет светлый "розово-оранжевый" или "зеленый" оттенок. Существуют цвета, рекомендованные для использования в качестве фона для фоновых форм (подробнее см. Рекомендуемые цвета для разработки цветных фоновых форм).

Collapsed Показать цветную фоновую форму

В идеальном случае после сканирования и очистки изображения с цветной фоновой формы должны "пропадать" все элементы, за исключением реперов и информации, внесенной во время заполнения формы.

Пояснительная информация может оставаться на форме (если она выполнена в черном цвете); но можно добиться того, что и этот элемент будет "пропадать" при сканировании. Для этого пояснительную информацию необходимо выполнить в том же цвете, что и фон формы, но с большей насыщенностью.

Выбирая между черным цветом и цветом фона для пояснительной информации, учитывайте следующее:

  • Размер файла изображения формы с пояснительной информацией, выполненной в черном цвете (или любом другом, который останется после сканирования на форме), больше, чем размер файла изображения формы с пояснительной информацией, выполненной в цвете фона (или любом другом, который исчезнет после сканирования на форме).
  • Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов на расстояние, не меньшее 1,5-2 мм. В случае пояснительной информации, выполненной в цвете фона, можно не так пристально отслеживать расстояние между пояснительной информацией и другими элементами формы.

Форма с пояснительной информацией, выполненной в черном цвете, является более читаемой. Рекомендуется использовать именно черный цвет для пояснительной информации, если на форме отсутствуют реперы.

Совет. Для настройки определения документов с пояснительной информацией, выполненной в цвете фона, сканируйте форму в цвете или оттенках серого, иначе границы элементов формы и пояснительная информация не будут видны.

Рассмотрим приемы обработки фоновых форм. Технологической основой "пропадания" фона при сканировании является отсечение цвета фона с помощью цветной лампы или цветного фильтра. Цвет лампы подбирается в зависимости от того, какой оттенок имеет цвет фона "розово-оранжевый" или "зеленый".

Итак, сканирование производится:

  • На цветном сканере с программной фильтрацией красного или зеленого цвета в зависимости от оттенка фона формы.
  • На нецветном сканере с "красной лампой" (Red-Lamp) или "зеленой лампой" (Green-Lamp) соответственно (аппаратная фильтрация цвета).
  • На нецветном сканере с использованием белой лампы и красного или зеленого фильтра соответственно. Качество фильтрации, в отличие от первого и второго вариантов, хуже - может остаться фон формы или исчезнуть часть значимой информации.
  • На нецветном сканере с использованием белой лампы и без фильтра.

При сканировании с использованием белой лампы возможно отсечение различных цветов светлых оттенков без фильтрации. Исчезновение фона достигается за счет слабой насыщенности цвета фона. В этом случае подбор цвета формы и его насыщенность должны производиться опытным путем для каждого конкретного сканера.

Замечание. У многих цветных сканеров, кроме того, есть режим программной фильтрации синего цвета. Но не рекомендуется выполнять формы в "синих" оттенках, поскольку нельзя гарантировать, что все формы будут заполнены только черной, а не темно-синей ручкой. В случае сканирования форм с фильтрацией синего цвета данные, написанные синей ручкой, "исчезнут".

Подбор цвета

Если выбирать между зелеными и красными оттенками форм, то надо иметь в виду, что красно-оранжевые оттенки предпочтительнее, так как они являются максимально контрастными к синему цвету, что улучшает качество полученных при сканировании изображений и распознавания текста, написанного синей ручкой.

В разделе Рекомендуемые цвета для разработки цветных фоновых форм приводится список рекомендуемых цветов, которые "пропадают" при сканировании форм практически любым сканером. Для каждого конкретного сканера можно также получить у производителя или дилера список цветов в стандарте Pantone (или любом другом), которые можно использовать с данным сканером.


Черно-белые линейчатые формы

Черно-белые линейчатые формы - это формы без фона (как правило), на которых границы Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.). знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены черными линиями.

Границы полей черно-белой линейчатой формы остаются на изображении после сканирования и очистки.

Замечание. Формы этого вида особенно чувствительны к качеству заполнения. Под качеством заполнения подразумевается следующее: при заполнении формы текст помещается внутри ограничителей, и становится крайне важно, чтобы внесенный текст не заезжал на ограничители, а в идеале, и не касался их. В случае касания или "наползания" символов на ограничитель программа распознавания будет воспринимать символы и ограничитель как единое целое и качество распознавания ухудшится.


Черно-белые формы с растровым фоном

Черно-белые формы с растровым фоном - это формы с растровым фоном (растр - мелкие черные точки), на котором белыми прямоугольниками выделены Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.). знакоместа (а также поля меток и др.), в которые при заполнении формы вносится информация. Фон должен состоять из отдельных точек. Рекомендуемый размер точек растра не более 0,1 мм. Расстояние между точками растра должно быть около 1 мм. Размер точек и расстояние между точками имеют большое значение, т.к. они должны восприниматься программой распознавания как мусор и удаляться с изображения при очистке. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровым фоном.

Растровый фон не исчезает непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации изображение уже не содержит точек растра после очистки.


Черно-белые формы с растровыми границами

Черно-белые формы с растровыми границами - это формы без фона, на которых границы Знакоместо - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.). знакомест полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками). Размер точки растра 0,39 - 0,5 пункта. Рекомендуемый размер точки растра 0,39 пункта. Расстояние между точками растра должно быть в пять раз больше размера самой точки.

Размер точек и расстояние между точками имеют большое значение, т.к. при очистке изображения точки растра должны восприниматься программой распознавания как мусор и удаляться с изображения. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровыми границами.

Растровые границы не исчезают непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации после очистки изображение уже не содержит точек растра.


Рекомендуемые цвета для разработки цветных фоновых форм

Таблицы содержат примеры цветов фона (с номерами соответствующих пантонов), "исчезающих" при сканировании

  • любым сканером;

  • цветным сканером с фильтрацией красного или нецветным сканером с красной лампой/красным фильтром.


Распределенная верификация

Распределенная верификация позволяет ограничить набор полей, требующих верификации на данном этапе. Распределенная верификация может использоваться на этапах типа Верификация и Верификация Данных. Создав на основе этих этапов пользовательские этапы обработки, вы можете обеспечить обработку различных полей документа на различных этапах (правило отправки документа на этап обработки настраивается с помощью скрипта). Список полей, доступных для данного этапа, необходимо указать в диалоговом окне свойств этапа, на закладке Набор полей.

При использовании распределенной верификации рекомендуется обратить внимание на следующее:

  • Информация об ошибке отображается в окне ошибок, только если в доступный оператору набор полей включено хотя бы одно поле, с которым связана данная ошибка. Если ни одно из полей, с которыми связана ошибка, не входит в заданный набор, оператору не будет показано, что в документе есть ошибки.
  • Если часть полей, с которыми связана ошибка, не входят в набор, то в окне ошибок информация об ошибке отображается, однако перейти к исправлению полей, не входящих в набор, нельзя.
  • При необходимости обеспечить высокий уровень безопасности на этапе Верификация данных рекомендуется использовать опцию Скрывать изображение страницы вне выбранных полей. В этом случае оператору будут доступны только поля, включенные в заданный набор полей. Все остальные поля на изображении будут скрыты.

    Замечание. Если выбрана данная опция, но при наложении определения документа регион поля был определен неверно либо со смещением, может оказаться невозможным верифицировать поле. В этом случае оператор должен отправить изображение на этап Исключения.


Двойная верификация

Двойная верификация – это режим верификации, при котором проверка полей осуществляется двумя операторами.

Для того чтобы поле отправлялось на двойную верификацию:

  1. Отметьте в свойствах поля опцию Требуется двойная верификация.
  2. Отметьте опцию Двойная верификация на закладке Набор полей в диалоговом окне свойств этапа.

Слияние результатов верификации, полученных операторами, осуществляется на Сервере обработки. Если результаты совпадают, документ переходит на следующий этап. В случае несовпадения результатов первой и второй руки верификации, осуществляется проверка результирующей рукой.

Для двойной верификации могут быть использованы Web-станции верификации данных.


Процесс обработки

Управление заданиями

После выбора проекта можно получать задания на верификацию данных. По умолчанию включен режим автоматического получения заданий. Нажмите кнопку [image] панели инструментов или выберите в меню пункт Задания>Получать задания автоматически для включения или выключения режима автоматического получения заданий. Если этот режим выключен, для получения заданий используйте кнопку [image].

Количество доступных заданий в очереди верификации данных отображается в столбце Число всех заданий. Для обновления информации нажмите кнопку [image].

Управлять заданием можно также и во время верификации данных:

  • Отменить задание. Чтобы прекратить обработку задания выберите в меню пункт Задания>Отменить задание. При отказе от задания можно сохранить сделанные изменения на сервере, сделав их доступными остальным операторам, или отказаться от сохранения.
  • Отправить задание в Исключения…. Если при обработке задания возникла непредвиденная ситуация, отправьте его в очередь исключений, выбрав в меню пункт Задания>Отправить задание в Исключения….

Старший Оператор Верификации может отправить на другой этап обработки сразу несколько задач или пакетов. Для этого в соответствующем режиме просмотра (Очереди для заданий, Пакеты для пакетов) необходимо выделить требуемые задачи или пакеты, открыть главное или контекстное меню и выбрать опцию Отправить задания... для заданий или Отправить на этап обработки... для пакетов (также доступно сочетание клавиш Ctrl + Alt + Q). В открывшемся диалоговом окне определите следующий этап, назначьте оператора и приоритет обработки. Если нужного оператора нет в списке, проверьте его права доступа на заданном этапе ко всем выбранным типам пакетов.

Замечание. Отправка одновременно пакетов разных типов на один и тот же этап возможна только при условии совпадения имени и типа данного этапа для каждого типа пакетов в отдельности.


Запрет отправки с одного этапа обработки на любой, кроме выбранного

Данная страница описывает, как с помощью механизма ролей доступа запретить оператору отправлять документы с этапа обработки А на любой этап обработки, кроме этапа Б.

Collapsed Этап Б - Исключения

Чтобы разрешить отправку документов на этап Исключений, достаточно просто включить в схему маршрутизации на закладке Процесс обработки окна свойств проекта (пункт меню Проект>Свойства проекта…) или на одноименной закладке окна свойств типа пакетов (пункт меню Проект>Типы пакетов…, выбрать тип пакета и нажать кнопку Правка…).

Collapsed Этап Б - Пересканирование

Необходимо использовать схему маршрутизации "Расширенный". Для этапа А в свойствах этапа необходимо указать признак разрешения отправки документов на этап пересканирования. Для этого выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, с этапа которого необходимо разрешить отправку на пересканирование;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. Выберите в поле Схема значение "Расширенный".
  4. Выберите в списке этап, с которого необходимо разрешить отправку.
  5. Нажмите кнопку Правка….
  6. В диалоговом окне Свойства этапа обработки перейдите на закладку Маршруты выхода.
  7. Заполните поле выбора Разрешить оператору отправку заданий на пересканирование.
  8. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.

Также необходимо запретить оператору отправку документов на любой другой этап. Для этого создайте соответствующую роль и предоставьте ему ее на Консоли администрирования и мониторинга:

  1. Выберите в меню пункт Проект>Свойства проекта…
  2. Перейдите на закладку Роли пользователя.
  3. Нажмите кнопку Добавить…
  4. Укажите название роли в одноименном поле.
  5. Очистите поле Отправка пакета на любой из возможных этапов. Заполните или очистите остальные поля в зависимости от прав доступа, которые необходимо предоставить оператору.
  6. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.
  7. Предоставьте оператору данную роль на соответствующий тип пакета с помощью Консоли администрирования и мониторинга.
Collapsed Этап Б - не Пересканирование и не Исключения

В этом случае необходимо создать роль пользователя, у которой отсутствует право на отправку документов на любой этап. Далее необходимо явно разрешить оператору отправку документов на этап Б в свойствах этапа А.

Чтобы запретить оператору отправку документов на любой этап, создайте соответствующую роль и предоставьте ему ее на Консоли администрирования и мониторинга:

  1. Выберите в меню пункт Проект>Свойства проекта…
  2. Перейдите на закладку Роли пользователя.
  3. Нажмите кнопку Добавить…
  4. Укажите название роли в одноименном поле.
  5. Очистите поле Отправка пакета на любой из возможных этапов. Заполните или очистите остальные поля в зависимости от прав доступа, которые необходимо предоставить оператору.
  6. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.
  7. Предоставьте оператору данную роль на соответствующий тип пакета с помощью Консоли администрирования и мониторинга.

Чтобы разрешить отправку оператором документов на этап Б, выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, с этапа которого необходимо разрешить отправку;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. Выберите в поле Схема значение "Расширенный" .
  4. Выберите в списке этап А, с которого необходимо разрешить отправку.
  5. Нажмите кнопку Правка….
  6. В диалоговом окне Свойства этапа обработки перейдите на закладку Маршруты выхода.
  7. Добавьте этап с помощью кнопки Этап… либо выберите наименование этапа в списке и нажмите кнопку Правка…
  8. В диалоговом окне Следующий этап заполните поле выбора Разрешить оператору отправку заданий на этот этап.
  9. Нажмите кнопку ОК, чтобы сохранить изменения в настройках отправки.
  10. Нажмите кнопку ОК, чтобы сохранить изменения этапа А.

Замечание. Если при отправке документов оператором не будет указан признак Сформировать задание, то будут проверены условия входа на этап Б. Если они не будут выполнены, то документы будут направлены на этап, следующий за этапом А в схеме маршрутизации.


Приложения

Пользовательские приложения могут быть добавлены для страниц, документов и пакетов. Добавленные приложения доступны дальнейшего редактирования и загрузки.

Вы можете прикрепить файлы любого формата, например, добавить файл с цифровой подписью при сканировании изображений.

Приложения могут быть добавлены одним из следующих способов:

  1. При загрузке изображений из горячей папки в соответствии с настройками, указанными в файле описания.
  2. На закладке Вложения в диалоговом окне свойств страницы, документа или пакета нажмите кнопку Новое…. В открывшемся диалоговом окне укажите имя приложения и путь к нему.
  3. С помощью скрипта, используя метод IUserAttachments.AddNew. Методы интерфейса IUserAttachment также позволяют редактировать добавленные приложения.
  4. Используя программный интерфейс (API). Подробнее смотрите в справке программного интерфейса (API).

Чтобы сохранить приложение на жесткий диск, нажмите кнопку Сохранить как… на закладке Вложения либо используйте метод IUserAttachment.ToFile.


Типы пакетов

В комплексе ABBYY FlexiCapture предусмотрен пакетный режим обработки документов: перед началом обработки создается пакет, в него добавляются изображения документов и далее они могут обрабатываться в этом пакете. Пакеты создаются автоматически или вручную при импорте изображений (сканировании или добавлении уже отсканированных изображений документов). Настройки, с которыми будут обрабатываться пакеты документов, задаются в Типе Пакета. Можно создать несколько Типов Пакетов с наиболее часто используемыми наборами настроек обработки. Тогда, чтобы указать с какими настройками должен обрабатываться пакет, оператору необходимо просто задать тип пакета.

Типы пакетов создаются Редактором Настроек Проектов в рамках определенного проекта.

Для того чтобы создать Тип Пакета, нужно:

  • открыть проект;
  • открыть диалог Типы пакетов (Проект > Типы пакетов…);
  • запустить мастер создания типов пакетов по кнопке Новый и следовать его инструкциям.

В свойствах Типа пакета указываются следующие параметры обработки документов:

  • Вкладка Общие: название проекта, описание, качество отображения изображений, регистрационные параметры , инструменты типа пакета;
  • Вкладка Предобработка изображений: способ предварительной обработки изображений: разделение на документы и параметры обработки изображений;
  • Вкладка Распознавание: список и порядок наложения определений документов, классификатор гибких описаний, удалять ли пустые страницы на этапе распознавания;
  • Вкладка Обработчики событий: используемые обработчики событий;
  • Вкладка Верификация: группировать ли поля при контекстной верификации;
  • Вкладка Экспорт: настройки экспорта; если тип пакета не указан, пакет экспортируется с настройками <По умолчанию>, указанными в свойствах проекта;
  • Вкладка Процесс обработки: процесс обработки пакета;
  • Вкладка Сборки .Net: подключенные внешние сборки;


Пакеты документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

Пакеты могут формироваться автоматически при импорте изображений из горячих папок либо на станции сканирования. Для добавления пакета в ручном режиме выберите пункт контекстного меню Новый пакет…, появляющегося при нажатии правой кнопки мыши в главном окне со списком пакетов.

При формировании пакета указывается его тип, определяющий порядок обработки пакета.

Добавление изображений страниц документов производится в процессе потокового ввода. Подробнее см. Добавление изображений страниц.

Рабочие и тестовые пакеты

Для обработки документов используются рабочие пакеты. Тестовые пакеты используются в процессе отладки определения документа. Отличие этих пакетов в том, что для обработки документов из тестовых пакетов используется локальная версия определения документа, а для обработки документов из рабочих пакетов – опубликованная версия. Cм. Редактирование и публикация определения документа.

Переход к списку пакетов документов осуществляется из меню Проект главного окна программы. Рабочие пакеты: Рабочие пакеты, тестовые пакеты: Тестовые пакеты.


Настройки инструмента

Диалог Настройки инструмента позволяет настроить обработку определенных событий для всех типов пакетов. Настройки инструмента, указанные в свойствах проекта, применяются ко всем пакетам, независимо от типа. В остальном, обработка пакета осуществляется в соответствии с настройками, указанными для типа пакета.

Настройки инструмента применяются к пакету до входа на этап. Инструменты, применяющиеся к пакету на определенном этапе в рамках задания, настраиваются на закладке Инструменты этапов.

Для открытия диалога Настройки инструмента нажмите кнопку Правка… на закладке Общие в свойствах проекта. В открывшемся диалоговом окне вы можете указать следующие настройки:

Настройка | Описание
Группа Параметры события
Кнопка Добавить… | Открывает диалоговое окно Добавление события для выбора события, которое необходимо обрабатывать. Чтобы написать скрипт-обработчик события, нажмите кнопку Правка скрипта….
Кнопка Правка скрипта… | Открывает диалоговое окно Редактор кода скрипта для ввода текста скрипта.
Кнопка Удалить | Удаляет выбранный инструмент из списка.
Группа Настройки оболочки
Кнопка Редактировать… | Открывает диалоговое окно Настройки оболочки для настройки внешнего станции.
Кнопка Сбросить | Сбрасывает настройки оболочки на изначальные.


Классификатор проекта

Классификатор - проект ABBYY FlexiLayout Studio, предназначенный для предварительной идентификации отдельных страниц и отнесения их к определенному типу (например, по используемому гибкому описанию / варианту гибкого описания). После разработки классификатор используется в ABBYY FlexiCapture для классификации документов на уровне проекта или типа пакета.

Для того чтобы подключить проект классификатора на уровне проекта, необходимо

  • открыть проект;
  • в главном окне в меню Проект выбрать Свойства проекта…;
  • в открывшемся диалоге свойств проекта перейти на закладку Распознавание и нажать на кнопку Загрузить…;
  • выбрать нужный .cfl файл, содержащий классификатор.

Замечание. Если при создании пакета был указан тип По умолчанию, он будет обрабатываться согласно настройкам, заданным в свойствах проекта.

Для того чтобы подключить проект классификатора на уровне типа пакета, необходимо

  • открыть диалог Типы Пакетов (Проект>Типы пакетов…);
  • в диалоге в списке выбрать нужный тип пакета и нажать на кнопку Правка…;
  • в открывшемся диалоге свойств типов пакетов перейти на закладку Распознавание и в разделе классификатора нажать на кнопку Загрузить…;
  • выбрать нужный .cfl файл, содержащий классификатор.

Классификаторы могут использоваться в следующих целях:

  • Для ускорения выбора определения документа для наложения. Использование классификатора позволяет не перебирать все определения документа для поиска наиболее подходящего, а выбирать нужное определение на основании классификационных признаков. При этом порядок перебора определяется пользователем с помощью выбора классификационных признаков и построения дерева классификатора. Ускорение наиболее заметно для крупных проектов, содержащих большое количество определений документов.
  • Для распределения классифицирующих признаков по дереву классификатора. На верхнем уровне можно отбирать документы, поступившие от определенной компании, по наличию поля с ее наименованием. На следующем уровне классификации отобранные документы можно различать по типам с помощью заголовков или, например, количества разделителей на странице.
  • Для управления наложением гибких описаний сторонней разработки. Возможна ситуация, когда описания, полученные от стороннего разработчика, накладываются неправильно (не на те документы, на которые требуется). В данном случае классификатор можно использовать для управления наложением определений документов, не обращаясь к разработчику описаний.
  • Для ускорения работы проектов, содержащих определения документов на разных языках. При использовании классификатора предраспознавание для классифицируемых документов будет осуществляться не по количеству языков всех определений в проекте, а два раза: при классификации и при наложении выбранного определения документа.

Подробная информация о классификаторах приведена в справочной системе ABBYY FlexiLayout Studio.


Пользовательские роли

Для управления доступом пользователя к данным и очередям на этапах обработки можно дополнительно к базовым ролям доступа (Оператор верификации данных, Оператор верификации, Старший оператор верификации) создавать пользовательские роли.

Используя механизм ролей можно, например, осуществлять гибкую настройку доступа пользователей к этапам обработки при большом их количестве: предоставлять разным группам пользователей доступ к разным этапам верификации (например, с разными наборами полей) одного и того же типа пакета. Также роли позволяют ограничить возможности операторов: запретить операторам с данной ролью удалять документы, запретить им отправлять задачи с одной стадии на другую (или, наоборот, разрешить отправлять только на эту стадию).

Замечание. Запретить операторам отправлять задачи на определенный этап можно и без использования механизма ролей, так, как показано в одном из примеров.

Управление ролями осуществляется на закладке Роли пользователя окна свойств проекта (пункт меню Проект>Свойства проекта…). Созданные роли потом назначаются пользователям системы с помощью Консоли администрирования и мониторинга.

Замечание. Создать новую роль можно непосредственно при редактировании свойств этапа, который должен быть ей доступен (закладка Роли диалогового окна Свойства этапа обработки, для перехода к окну выберите в меню пункт Проект>Свойства проекта… либо Проект>Типы пакетов… и выберите тип пакета для изменения, затем перейдите на закладку Процесс обработки, и при использовании схем обработки "Расширенный" или "Расширенный для Web-станции Ввода документов" создайте интерактивный этап или выберите существующий и нажмите кнопку Правка…) Однако права доступа созданной таким образом роли необходимо будет предоставить на закладке Роли пользователя.

Новую роль можно создать на закладке Роли пользователя окна свойств проекта (пункт меню Проект>Свойства проекта…). Все прочие операции с ролями выполняются на данной закладке. Помимо создания (кнопка Добавить…) и удаления (кнопка Удалить) роли можно создать новую роль на основе существующей (выбрав ее в списке и нажав кнопку Копировать…) или изменить существующую роль (выбрав ее в списке и нажав кнопку Правка…). При создании новой роли с нуля или на основе существующей и при нажатии кнопки Правка… система открывает диалоговое окно Свойства роли.

Замечание. Изменение базовых ролей доступа (Оператор верификации данных, Оператор верификации, Старший оператор верификации) невозможно.

С помощью диалогового окна Свойства роли можно указать следующие права доступа для роли:

  • Список этапов, с которых пользователи с данной ролью смогут получать задания. Для указания списка этапов выполните следующие действия:
    1. Нажмите кнопку Этапы для получения заданий… Система откроет одноименное диалоговое окно.
    2. Отметьте поля выбора напротив тех этапов, к которым необходимо предоставить доступ. При необходимости воспользуйтесь полями выбора напротив наименований типов пакетов, чтобы предоставить доступ ко всем этапам выбранного типа или кнопкой Выбрать/отменить все этапы, чтобы выбрать или отменить выбор всех этапов.
    3. Для сохранения изменений и возврата в диалоговое окно Свойства роли нажмите кнопку ОК.
  • Доступ к операциям с данными

    Поле выбора

    Предоставляемые права доступа

    Просмотр списка пакетов в проекте
    • Возможность просматривать список пакетов.
    Создание/удаление пакетов
    • Создание и удаление пакетов;
    • Работа с приложениями к пакетам;
    • Работа с регистрационными параметрами пакетов;
    • Смена типа пакета.
    Изменение содержимого пакетов
    • Работа с приложениями к документам;
    • Работа с регистрационными параметрами документов;
    • Добавление / удаление / перемещение страниц / документов;
    • Изменение изображений;
    • Сохранение изображения на диск.
    Изменение разметки документа
    • Изменение определения секции / документа, отметка страниц как приложений;
    • Изменение разметки полей.
    Изменение содержимого документа
    • Изменение содержимого полей;
    • Добавление или удаление экземпляров полей;
    • Подтверждение полей;
    • Работа с регистрационными параметрами документов;
    • Запуск верификации (F7).
  • Доступ к операциям с заданиями

    Поле выбора

    Предоставляемые права доступа

    Создание заданий или подзаданий
    • Возможность отправки пакетов или документов на этап обработки.
    Возможность отложить задание
    • Возможность отложить задание.
    Просмотр списка заданий
    • Возможность просмотра очереди заданий на доступном этапе обработки и получения из нее заданий.

    Замечание. На станции верификации данных наличие данного права доступа позволяет обрабатывать полученные задания вне зависимости от наличия других прав.

    Отправка пакета на любой из возможных этапов
    • Возможность посылать задания/подзадания на любой доступный этап обработки типа пакета.

    Замечание. Если поле выбора очищено, то оператор сможет отправлять задания только в очереди Исключений и Пересканирования (если это допускается настройками), а также на все интерактивные этапы, на которые разрешена отправка схемой маршрутизации.

    Изменение приоритета обработки
    • Возможность изменять приоритет задания/документа/пакета.

Роль ограничивает набор этапов обработки, с которых пользователь с данной ролью может получать задания. Поэтому предоставить роли доступ к определенному этапу обработки выбранного типа можно также на закладкеРолидиалогового окна Свойства этапа обработки. Для этого выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, к которому надо предоставить или запретить доступ;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. При использовании схем обработки "Расширенный" или "Расширенный для Web-станции Ввода документов" создайте интерактивный этап или выберите существующий и нажмите кнопку Правка…
  4. В окне Свойства этапа обработки перейдите на закладку Роли.
  5. Заполните поля выборов для ролей, которым необходимо предоставить доступ к данному этапу обработки.
  6. При необходимости добавить новую роль нажмите кнопку Новая роль…, в диалоговом окне укажите название роли и нажмите кнопку ОК.

    Замечание. Прочие права доступа созданной таким образом роли необходимо будет предоставить на закладке Роли пользователя.

Примеры:

Запрет отправки документов на этап обработки

Запрет отправки с одного этапа обработки на другой

Запрет отправки с одного этапа обработки на любой, кроме выбранного


Настройки экспорта

Настройки экспорта указываются для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и при выборе команды Файл > Экспорт в экспорт пакета осуществляется в соответствии с настройками данного типа пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…, закладка Экспорт). Если тип пакета не указан, то при выборе команды Файл > Экспорт в, пакет будет проэкспортирован с настройками <По умолчанию>.

На этой закладке вы можете разрешить удаление проэкспортированных документов, а также указать настройки экспорта для нераспознанных документов. Распознанные документы экспортируются в соответствии с настройками, указанными в Определении документа.

Вы можете указать следующие опции:

Опция | Описание
Экспортировать нераспознанные документы | Отметьте эту опцию, если вы хотите экспортировать нераспознанные документы.
Группа Настройки экспорта изображений
Тип файла Выберите требуемый формат сохранения из списка. Поддерживаются следующие форматы: TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits, PNG.
Нажмите кнопку Настроить…, чтобы указать настройки для выбранного формата. Для всех форматов доступны следующие настройки:
  • Качество;
  • Цвет;
  • Изменение разрешения на новое значение (в dpi).

Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска поиск осуществляется по всему тексту документа: текстовый слой формируется как из проверенных на верификации значений полей, так и из областей документа за пределами этих полей. Для таких областей выполняется полнотекстовое распознавание.

Язык распознавания определяется следующим образом:

  • Для полей язык распознавания указывается на закладке Тип данных свойств поля;
  • При полнотекстовом распознавании используется язык Определения документа;
  • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
Отметьте опцию Использовать MRC (Mixed Raster Content), если вы хотите получить более высокую скорость распознавания и малый размер конечных файлов. При использовании этой опции поля, для которых выбран режим Не распознавать, могут экспортироваться с ухудшением качества.
Цель Выберите требуемую цель экспорта из выпадающего списка. В зависимости от выбранной цели экспорта, укажите дополнительные настройки. Вы можете выбрать один из следующих вариантов:
  • Экспортировать с заданным шаблоном имени файла
    При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.
  • Экспортировать каждый документ в отдельный файл
    Укажите путь и первые символы названия файла в поле Префикс файла.
  • Воссоздать структуру подпапок Горячей Папки
    При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.
Корень экспорта | Укажите корневой путь экспорта.
Шаблон имени | Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
При совпадении | Выберите действие, которое необходимо выполнять, если файл со сформированным именем уже существует.
Удалить документы после экспорта Отметьте эту опцию, если вы хотите удалять документы после экспорта.

Замечание. Данные о документах, удаленных сразу после экспорта, не будут включены в отчеты.


Файл описания

Файл описания – сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. В зависимости от формата файла описания, отличается набор файлов для формирования пакета.

В программе используются файлы описания следующих типов:

  1. Captiva QuickScan В пакет добавляются все файлы изображений, перечисленные в сопроводительном файле. Порядок следования файлов соответствует порядку в сопроводительном файле.
  2. Capture Software for Kodak В пакет добавляются файлы изображений, находящиеся в папке Kodak-пакета, указанной в сопроводительном файле, в порядке возрастания имен. Файл описания в формате *.ini содержит раздел Properties, в ключе Batch которого указан путь к папке с изображениями:

    [Properties]
    BatchPath=\\computer\HotFolder\PathInHF"

    Изображения из подпапок также добавляются в пакет.

  3. Пустой файл Данный файл служит маркером, свидетельствующим о необходимости создать новый пакет. Содержание файла не имеет значения, существенно только его имя. Добавление изображений из горячей папки осуществляется в алфавитном порядке. При обнаружении файла, наименование которого соответствует маске, указанной в поле Название, система создает новый пакет. Таким образом, если задана маска *.dat, и горячая папка содержит следующие файлы: Contract1.jpg Contract2.jpg Contract3.dat Contract4.jpg Contract5.jpg Contract6.dat то для файлов Contract1.jpg and Contract2.jpg будет создан первый пакет (при нахождении файла Contract3.dat), а для файлов Contract4.jpg and Contract5.jpg - второй (при нахождении файла Contract6.dat).
  4. Файл XML Файл в xml-формате с документированной структурой. Предназначен для случаев, когда три предыдущих типа файлов не подходят, но есть возможность генерировать собственный файл сопровождения. В пакет добавляются файлы изображений, указанные в сопроводительном файле.

    Структура файла:

    XML-документ должен содержать корневой элемент Batch со следующими дочерними элементами: RegistrationParams, Documents и Images.

    Элемент Images, в свою очередь, должен включать в себя элементы Image, количество которых соответствует количеству страниц в создаваемом пакете.

    Элемент Batch содержит следующие теги:

    • Priority - приоритет пакета. Может иметь значения: Lowest, Low, Normal, High или Highest. Необязательный тег. Если приоритет не указан, используется приоритет, указанный в профиле импорта.
    • Name - желаемое имя пакета.
    • TypeName - имя типа пакета. Используется, только если в профиле импорта указан тип пакета По умолчанию.
      Если в качестве горячей папки используется папка экспорта на станции Сканирования, то имя, указанное в теге, должно совпадать с именем типа пакета на станции Сканирования. В этом случае будет создан пакет указанного типа.
    • Attachments - приложения к пакету.
    • SourceID - строковый идентификатор источника пакета.
    • Description - описание.
    • RegistrationParams - список регистрационных параметров пакета. Регистрационные параметры из файла описания добавляются к регистрационным параметрам, указанным в профиле импорта.
    • Documents - список документов (не участвуют в автоматической сборке).
    • Images - список отдельных страниц (участвуют в автоматической сборке).

    Элемент Document содержит следующие теги:

    • Index (обязательный атрибут) - индекс документа (начиная с нуля) среди документов пакета.
    • Priority - приоритет. Может иметь значения: Lowest, Low, Normal, High или Highest. Необязательный тег.
    • Name - имя документа.
    • Barcode - значение штрих-кода.
    • RegistrationParams - список регистрационных параметров документа.
    • Attachments - приложения к документу.
    • Images - список страниц документа.

    Элемент Parameter (дочерний элемент RegistrationParams) содержит следующие теги:

    • Name (атрибут) - название регистрационного параметра.
    • Value - значение регистрационного параметра.

    Элемент Image содержит следующие теги:

    • Index (обязательный атрибут) - индекс страницы (соответствующего документа для страниц из элемента Images) среди страниц документа (документов пакета); нумерация начинается с нуля.
    • PageIndex (атрибут) - номер страницы (начиная с нуля) в многостраничном импортируемом файле.
    • SourcePath (атрибут) - путь к папке с исходными изображениями.
    • SourceFile (атрибут) - исходный файл с изображением страницы (путь относительно SourcePath).
    • SourceFilePageIndex (атрибут) - номер страницы (начиная с нуля) в многостраничном исходном файле.
    • SourceDetails (атрибут) - произвольное описание источника (название сканера).
    • Attachments - приложения к странице.
    • Value - путь к импортируемому файлу, указанный для страницы относительно горячей папки.

    Элемент Attachment содержит следующие теги:

    • Name - имя файла приложения. Если имя не указано, будет использовано имя исходного файла.
    • Value - путь к файлу приложения. Можно указать путь относительно корня горячей папки.

    Программу сканирования рекомендуется настроить таким образом, чтобы отсканированные изображения помещались в саму горячую папку или ее подпапки первого уровня. При создании пакета в него будут добавлены все изображения, пути к которым указаны в элементах Image соответствующего файла сопровождения. Порядок добавления изображений соответствует порядку их следования в файле.


Настройка определения пустой страницы

Настройки определения пустых страниц

В этом диалоге вы можете указать параметры, по которым будет определяться пустая страница при разделении документов. Этот диалог открывается при нажатии кнопки Настройки… при выбранном разделении документов по пустым страницам в параметрах предобработки изображений.

Опция | Описание опции
Не учитывать поля страницы, мм | Отметьте эту опцию, если вы хотите, чтобы при определении, является ли страница пустой, страница была предварительно обрезана на указанное расстояние в миллиметрах сверху, снизу, слева, справа. Полученная после обрезки страница будет проверяться на соответствие остальным параметрам.
Черные квадраты | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число черных квадратов (специальных элементов дизайна форм), могла считаться пустой. Укажите допустимое число черных квадратов на странице.
Текстовые объекты | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число текстовых объектов, могла считаться пустой. Под текстовым объектом понимается любой отдельный фрагмент текста. Например, вы можете использовать эту опцию с ненулевым числом текстовых объектов для страниц, содержащих колонтитулы. Укажите допустимое число текстовых объектов на странице.
Штрихкоды | Отметьте эту опцию, если вы хотите, чтобы страница, содержащая определенное число штрих-кодов, считалась пустой. Укажите допустимое число штрих-кодов на странице.
Процент черного | Отметьте эту опцию, если вы хотите, чтобы процентное содержание черного цвета на пустой странице не превосходило указанное. Процентное соотношение белого и черного цветов вычисляется на бинаризованном изображении.

Замечание. Параметр Черные квадраты не рекомендуется использовать в качестве основного, так как черные точки могут появляться на страницы при сканировании. Более надёжным параметром является число текстовых объектов. Ограничение на число черных квадратов можно использовать в качестве дополнительной проверки.


Переменные окружения

Переменная окружения - строка, которая используется для хранения текстовой информации, в частности, путь подключения к внешним ресурсам. Переменные окружения задаются в свойствах проекта (Свойства проекта > Переменные окружения), используются при настройке определения документа или в скриптах.

При запуске существующего проекта на другом сервере приложений или компьютере могут измениться пути к внешним ресурсам проекта: базе данных, месту хранения данных и т.д.

В случае, если проект содержит несколько определений документов, множество правил проверки по базе данных, скриптов, редактирование перечисленных объектов займет много времени.

Чтобы при переносе проекта не изменять все используемые объекты, необходимо в свойствах проекта задать пути к внешним ресурсам с помощью переменных окружения, далее при создании правил, настройке экспорта, написании скриптов использовать эти переменные. Таким образом, при запуске проекта в другой среде использование переменных окружения позволит редактировать параметры подключения только в диалоговом окне Переменные окружения. Это, в свою очередь, упростит процесс.

Типы переменных окружения

Переменные окружения ABBYY FlexiCapture делятся на два типа:

  • Строка – текстовая переменная.
  • Строка соединения с базой данных - строка соединения с ODBC-совместимой базой данных.

Создание и редактирование переменных окружения

Чтобы создать новую переменную окружения, выполните следующие шаги:

  1. В свойствах проекта на закладке Переменные окружения нажмите кнопку Новая…
  2. В открывшемся диалоговом окне выберите тип переменной, введите название переменной. Тип переменной не может быть изменен в дальнейшем.
  3. В зависимости от выбранного типа переменной заполните поле Значение следующим образом:
    • Для переменной типа Строка введите требуемое значение (например, путь к папке в файловой системе или адрес электронной почты).
    • Для переменной типа Строка подключения ADO укажите путь подключения к базе, параметры доступа пользователя и другие параметры соединения в зависимости от выбранного драйвера.
  4. При необходимости заполните поле Описание.

Чтобы отредактировать/удалить существующую переменную, нажмите кнопку Правка…/Удалить.

Использование переменных окружения

  • Переменные окружения типа Строка можно использовать:
    • при настройке источника импорта изображений;
    • при настройке экспорта документов в файлы данных и изображений.

      • При обращении к переменной используется следующий синтаксис: <Env:Название_переменной_окружения> или <$:Название_переменной_окружения>.

  • Переменные окружения типа Строка соединения с базой данных могут быть использованы при подключении к различным базам данных в зависимости от назначения, например:
    • При создании правила проверки по базе данных;
    • В определении документа при настройке экспорта данных;
    • В определении документа при подключении набора данных к внешнему источнику данных;
    • В свойствах поля при настройке проверки значений .
  • В скриптах можно применять переменные окружения любого типа. Для этого необходимо использовать свойство IProperties EnviromentVariables, доступное в интерфейсе IProject.


Запрет отправки с одного этапа обработки на другой

Данная страница описывает, как с помощью механизма ролей доступа запретить оператору отправлять документы с этапа обработки А на этап обработки Б.

Collapsed Этап Б - Исключения

Запретить отправлять документы на этап Исключений можно только полностью исключив этот этап из схемы маршрутизации на закладке Процесс обработки окна свойств проекта (пункт меню Проект>Свойства проекта…) или на одноименной закладке окна свойств типа пакетов (пункт меню Проект>Типы пакетов…, выбрать тип пакета и нажать кнопку Правка…).

Collapsed Этап Б - Пересканирование

Необходимо использовать схему маршрутизации "Расширенный". Для этапа А в свойствах этапа необходимо снять признак разрешения отправки документов на этап пересканирования. Далее необходимо создать роль пользователя, у которой отсутствует разрешение на отправку документов на любой этап, и присвоить ее пользователю на Консоли администрирования и мониторинга.

Чтобы запретить отправку на этап пересканирования, выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, с этапа которого необходимо запретить отправку на пересканирование;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. Выберите в поле Схема значение "Расширенный".
  4. Выберите в списке этап, с которого необходимо запретить отправку.
  5. Нажмите кнопку Правка….
  6. В диалоговом окне Свойства этапа обработки перейдите на закладку Маршруты выхода.
  7. Очистите поле выбора Разрешить оператору отправку заданий на пересканирование.
  8. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.

Также необходимо запретить оператору отправку документов на любой этап. Для этого создайте соответствующую роль и предоставьте ему ее на Консоли администрирования и мониторинга:

  1. Выберите в меню пункт Проект>Свойства проекта…
  2. Перейдите на закладку Роли пользователя.
  3. Нажмите кнопку Добавить…
  4. Укажите название роли в одноименном поле.
  5. Очистите поле Отправка пакета на любой из возможных этапов. Заполните или очистите остальные поля в зависимости от прав доступа, которые необходимо предоставить оператору.
  6. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.
  7. Предоставьте оператору данную роль на соответствующий тип пакета с помощью Консоли администрирования и мониторинга.
Collapsed Этап Б - не Пересканирование и не Исключения

В этом случае необходимо создать роль пользователя, у которой отсутствует право на отправку документов на любой этап. Далее необходимо явно запретить оператору отправку документов на этап Б в свойствах этапа А. Это можно сделать, либо полностью убрав этап Б из возможных адресатов, либо разрешить отправку в автоматическом режиме, но запретить в ручном.

Чтобы запретить оператору отправку документов на любой этап, соответствующую роль и предоставьте ему ее на Консоли администрирования и мониторинга:

  1. Выберите в меню пункт Проект>Свойства проекта…
  2. Перейдите на закладку Роли пользователя.
  3. Нажмите кнопку Добавить…
  4. Укажите название роли в одноименном поле.
  5. Очистите поле Отправка пакета на любой из возможных этапов. Заполните или очистите остальные поля в зависимости от прав доступа, которые необходимо предоставить оператору.
  6. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.
  7. Предоставьте оператору данную роль на соответствующий тип пакета с помощью Консоли администрирования и мониторинга.

Чтобы запретить отправку оператором документов на этап Б, выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, с этапа которого необходимо запретить отправку;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. Выберите в поле Схема значение "Расширенный".
  4. Выберите в списке этап А, с которого необходимо запретить отправку.
  5. Нажмите кнопку Правка…
  6. В диалоговом окне Свойства этапа обработки перейдите на закладку Маршруты выхода.
  7. Если необходимо полностью исключить отправку документов на этап Б, отключите данный этап, очистив поле выбора напротив его названия, либо удалите его, выбрав в списке и нажав кнопку Удалить.
  8. Если необходимо исключить отправку документов оператором, но разрешить делать это автоматически, выполните следующие действия:
    1. Выберите наименование этапа в списке.
    2. Нажмите кнопку Правка…
    3. В диалоговом окне Следующий этап очистите поле выбора Разрешить оператору отправку заданий на этот этап.
    4. Нажмите кнопку ОК, чтобы сохранить изменения в настройках отправки.
  9. Нажмите кнопку ОК, чтобы сохранить изменения этапа А.


Запрет отправки документов на этап обработки

Запрет отправки документов на этап обработки можно осуществить без использования механизма ролей пользователя. Для этого необходимо установить для этапа обработки свойство Связать с предыдущим (операторы не смогут вручную отправлять задания на этот этап)" с помощью одноименного поля выбора. Данное свойство, например, можно установить для этапов, перед которыми в обязательном порядке необходимо осуществить предварительную обработку. Нельзя запретить отправку документов на этапы обработки Исключения и Обработано, для данных этапов указать данное свойство невозможно.

Чтобы запретить любому оператору отправлять документы на этап обработки, выполните следующие действия:

  1. Выберите в меню пункт Проект>Свойства проекта… (для пакетов с типом "По умолчанию") либо (для выбранного типа пакетов):
    • Выберите в меню пункт Проект>Типы пакетов…
    • Выберите тип пакета, к которому надо предоставить или запретить доступ;
    • Нажмите кнопку Правка…
  2. Перейдите на закладку Процесс обработки.
  3. При использовании схем обработки "Расширенный" выберите этап обработки и нажмите кнопку Правка…
  4. Заполните поле выбора Связать с предыдущим (операторы не смогут вручную отправлять задания на этот этап).
  5. Нажмите кнопку ОК, чтобы сохранить внесенные изменения.


Параметры обработки изображений

При добавлении изображений в пакет производится их предварительная обработка: деление изображений по документам, очищение, поворот изображений и т.д.

Параметры обработки изображений задаются в диалоге (на закладке) Предобработка изображений. Их можно задать:

  1. Для проекта. Тогда они будут использоваться по умолчанию при ручном добавлении изображений в пакеты проекта. Для этого в главном окне программы выберите пункт меню Проект>Свойства проекта… и в открывшемся диалоге перейдите на закладку Предобработка изображений.
  2. Для профиля импорта. Эти параметры будут использоваться при добавлении изображений с помощью данного профиля импорта. Для этого при создании профиля импорта задайте параметры обработки изображений на шаге Предобработка изображений.
  3. Для изображений, добавляемых вручную. Для этого при добавлении изображений из файла нажмите на кнопку Параметры обработки изображений… в диалоге Загрузка изображений.

    Замечание. При сканировании вручную предварительная обработка изображений не осуществляется. Только при сканировании с использованием профиля импорта.

  4. Для типа пакета. Тогда они будут использоваться для обработки изображений пакетов данного типа. Для этого при создании типа пакета задайте необходимые параметры на шаге Предобработка изображений. Настройки, указанные для типа пакета, также применяются к изображениям:
    • полученным со Станции сканирования или Web-станции Сканирования, в случае если они не были собраны в документы на соответствующей станции. Настройки из группы Обработка изображений будут применяться к полученным изображениям независимо от того, собраны изображения в документы или нет;
    • добавленным с помощью методов программного интерфейса (API), в случае если флаг ExcludeFromAutomaticAssembling имеет значение false. Подробнее смотрите в справке программного интерфейса (API);
    • добавленным из горячей папки (если отмечена опция Использовать настройки обработки изображений типа пакетов). Подробнее смотрите Профили импорта изображений;
    • добавленным вручную из файла. В этом случае опции, указанные для типа пакета, используются по умолчанию.

Пользователь может определить следующие параметры предварительной обработки изображений:

  • Опции для добавления изображений в документы:
    • Автоматически при наложении определения документа – отметьте эту опцию, если вы хотите, чтобы изображения собирались в документы при наложении определения документа (при распознавании). В этом случае при добавлении изображений документы формироваться не будут, они соберутся по результатам анализа страниц при распознавании согласно структуре, описанной для данного определения документа. Подробнее см. Создание определений для многостраничных документов и Сборка страниц в документы.
    • Для каждого файла – новый документ будет создан для каждого файла (файл изображения может быть многостраничным).
    • Для изображений, разделенных – страницы будут добавляться в один документ, пока не встретится страница-разделитель, тогда будет создан следующий документ и страницы будут добавляться в него и т.д. В качестве разделителя могут быть использованы пустые страницы, в этом случае выберите пустыми страницами в выпадающем списке. В открывшемся диалоге Настройки определения пустых страниц укажите параметры, по которым будет определяться пустая страница. Также можно использовать в качестве разделителя страницы со штрих-кодами, в этом случае выберите страницами со штрих-кодом. Для штрих-кодов или пустых страниц можно задать дополнительные параметры, для этого нужно нажать кнопку Настройки… Если страницы-разделители не нужно добавлять в пакет, то отметьте опцию Удалять страницу-разделитель. Если она не будет отмечена, страницы-разделители добавляются в пакет и становятся первыми страницами каждого документа.

    Замечание. Страницы-разделители для определения разбивки по документам использовать не обязательно. Без них нельзя обойтись только в одном случае: когда по виду страницы невозможно определить, относится она к предыдущему документу, или к следующему. Например, когда документ состоит из произвольного количества одинаковых страниц, а в пакете может присутствовать более одного такого документа.

    Замечание. Для изображений, отсканированных или добавленных на станции сканирования, параметры разделения документов и пакетов указываются в настройках типа пакета на станции сканирования.

  • Опции обработки поступающих изображений:
    • Очищать изображения – изображения будут очищаться от мусора;
    • Конвертировать цветные и серые изображения в черно-белые – изображения будут конвертированы в черно-белые;
    • Поворачивать изображения на – будет осуществляться разворот изображений в указанном направлении;
    • Обрабатывать изображение как фотографию – рекомендуется использовать при импорте фотографий документов.
  • Опции выравнивания изображений. Эти опции по умолчанию включены и при добавлении изображений производится их выравнивание по черным квадратам и по вертикальным и горизонтальным разделителям и по тексту. Опции выравнивания не рекомендуется отключать, кроме тех случаев, когда выравнивание производится неправильно, например, программа может интерпретировать сторону неровно поставленного штампа или наклонную линию графика как разделитель и выровнять изображение по нему. В этом случае выравнивание по разделителям можно отключить.
    • Выравнивать изображения по разделителям – при включенной опции изображения выравниваются по сепараторам;
    • Выравнивать изображение по чёрным квадратам – при включенной опции изображения выравниваются по черным квадратам.
    • Выравнивать изображение по тексту – при включенной опции изображения выравниваются по тексту на изображении.


Качество отображения изображений

Настройка Качество отображения изображений определяет качество изображений при загрузке на станциях.

Качество отображения изображений указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и изображения пакета отображаются с заданным качеством.

В случае если не создано ни одного Типа Пакетов, изображения пакетов будут отображаться с качеством, указанным в свойствах проекта (Проект>Свойства проекта…, закладка Общие).

Каждое изображение хранится в виде набора файлов: исходный файл, его сжатые копии (цветная и черно-белая) и его миниатюра. Исходный файл изображения используется для распознавания и экспорта. Для отображения на станциях используется сжатая копия.

Можно выбрать следующие значения качества изображений: 20%, 40%, 60%, 80% или 100%.

Отображение изображений в более низком качестве может применяться для ускорения загрузки изображений, в случае низкой пропускной способности сетевого соединения на компьютерах операторов (например, при удаленной работе). Если выбрано более низкое качество, изображения будут загружаться быстрее за счет уменьшения размера.


Профили импорта изображений

Обработка документов начинается с добавления новых изображений. Оператор может добавлять изображения, сканируя их с бумажных документов, либо импортировать в систему файлы с изображениями в электронном виде.

Если действия по добавлению регулярно поступающих из одного и того же места изображений, их можно автоматизировать. Для этого нужно создать на Станции Администратора профиль импорта изображений для определенного проекта. Кроме того, можно настроить параметры обработки поступающих изображений и периодическое добавление изображений в фоновом режиме. Если произведены необходимые настройки, то при нажатии одной кнопки выполняется сканирование или импорт из заранее настроенного источника, а полученные изображения обрабатываются (например, очищаются от «мусора»). При желании пользователь может сменить источник ввода изображений или его настройки.

В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

Создание профиля импорта

Чтобы добавить профиль импорта, выберите пункт меню Проект > Профили импорта изображений… главного окна программы. В открывшемся диалоге вы можете создавать новые профили импорта, редактировать, удалять и копировать существующие профили.

Создать новый профиль импорта вам поможет мастер создания профиля, который запустится из диалога Профили импорта изображений при нажатии кнопки Новый…. На первом шаге мастера выберите источник импорта. Источником импорта может служить сканер или горячая папка.

Collapsed Создание профиля импорта с использованием сканера
  1. В качестве источника импорта выберите Сканер.

    Внимание! Сканер должен быть подключен. Чтобы правильно подключить сканер, обратитесь к документации, прилагаемой к сканеру. При установке не забудьте установить все программное обеспечение, поставляемое вместе со сканером.

  2. На следующем шаге мастера вы можете задать опции сканирования и обработки поступающих изображений:
    • Стиль диалога настроек – выберите способ взаимодействия программы со сканером:
      • Настройки сканирования FlexiCapture: в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера. Нажмите на кнопку Настройки… чтобы установить опции сканирования. Если вы отметите Показывать настройки перед сканированием, то при выборе данного профиля импорта перед началом сканирования будет появляться диалог программы ABBYY FlexiCapture Настройки сканера.
      • Системные настройки сканирования: для настройки опций сканирования будет использоваться диалог соответствующего драйвера сканера. В этом случае при создании профиля импорта нельзя изменить опции сканирования, но диалог настроек сканирования будет появляться каждый раз перед началом сканирования изображений.
    • Отметьте, хотите ли вы сканировать одно или несколько изображений за один раз.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений.
  4. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.
Collapsed Создание профиля импорта с использованием горячей папки или из почты
  1. В качестве источника импорта выберите Горячая папка. Выберите тип папки: Локальная или сетевая папка, POP3-сервер, MAPI (почтовый ящик) или FTP-сервер. Задайте путь к горячей папке с помощью кнопки Обзор… или учетную запись и пароль с помощью кнопки Настройка…

    Внимание! Для добавления изображений из горячей папки пользователь должен обладать правами на чтение и запись в данную папку.

    Collapsed Чтобы настроить импорт через MAPI (почтовый ящик)
    • На компьютере должна быть настроена почтовая учетная запись.
    • Импортирующий процесс (пользовательская станция или станция обработки) должен быть запущен под учетной записью пользователя, чей почтовый ящик указан в настройках импорта.

    Замечание. Microsoft Outlook должен быть запущен под этой учетной записью пользователя на этом компьютере хотя бы один раз перед настройкой профиля импорта.

    Замечание. ABBYY FlexiCapture не поддерживает работу с 64-разрядной версией Microsoft Outlook 2010.

    • Для выбора доступного почтового ящика, нажмите Обзор…
    Collapsed Чтобы настроить импорт через POP3-сервер
    • Введите адрес POP3-сервера. После адреса сервера необходимо указать номер порта через двоеточие. Например, pop.server.com:110 или pop.server.com:995.
    • Нажмите Настройка… и в открывшемся окне введите имя пользователя и пароль для получения доступа к сообщениям на сервере. Для защиты передаваемых данных с помощью технологии SSL (порт 995) выберите опцию Использовать SSL.

    Замечание. Если все настройки указаны верно, но ABBYY FlexiCapture не получает сообщения от сервера электронной почты POP3, убедитесь, что сетевой экран не блокирует соединение с почтовым сервером.

  2. На втором шаге задайте опции загрузки изображений:
    • Проверять Горячую папку каждые – отметьте эту опцию и введите промежуток времени, чтобы производилась автоматическая проверка наличия новых изображений в горячей папке.

      Замечание. Для запуска импорта с помощью горячих папок необходимо включить их для данного проекта с помощью монитора сервера обработки.

    • В области Настройки пакета выберите одну из опций, чтобы определить, в какой пакет будут добавлены новые изображения.
      • Добавлять изображения в текущий пакет – отметьте эту опцию, чтобы изображения из горячей папки были добавлены в текущий пакет;
      • Добавлять в пакет – отметьте эту опцию и выберите название пакета в выпадающем списке, чтобы изображения были добавлены в указанный пакет.
      • Создавать новые пакеты изображений автоматически – отметьте эту опцию, чтобы пакеты для новых изображений создавались автоматически. В этом случае при каждой проверке горячей папки (отметьте опцию Проверять Горячую папку каждые) будет создаваться один или несколько пакетов, в которые будут добавляться найденные в папке изображения в соответствии с указанным ниже правилом.
        В поле Тип пакета укажите тип автоматически создаваемого пакета. При необходимости укажите регистрационные параметры пакета (кнопка Регистрационные параметры…) и измените его приоритет в поле Приоритет.

        • Замечание. Если задания импорта обрабатываются на Сервере обработки, нужно выбрать опцию Создавать новые пакеты изображений автоматически. Опции Добавлять изображения в текущий пакет и Добавлять в пакет могут быть выбраны, только при импорте на Станции настройки проекта или при использовании версии Standalone.

    • Прикрепить почту к пакету (только для горячей папки типа РОР3-сервер) - отметьте эту опцию, чтобы файл письма в формате EML был прикреплен к создаваемому пакету. Далее EML-файл можно сохранить на жесткий диск и открыть с помощью почтового клиента. Более подробно см. Приложения.
    • В выпадающем списке Количество файлов выберите одно из значений, чтобы определить, сколько файлов будет добавлено в указанный или вновь созданный пакет:
      • В соответствии с файлом описания – файлы будут добавлены согласно описанию. Чтобы задать имя и тип файла описания, нажмите кнопку Настройки… Подробнее см. Файл описания.
      • Все файлы – будут добавлены все файлы, обнаруженные в горячей папке. Файлы из подкаталогов добавляться не будут.
      • Из подпапки - будут добавлены файлы из подкаталогов, имя которых совпадает с заданным форматом. Для задания формата имени нажмите кнопку Настройки…
        Замечание. Для обозначения любой последовательности символов используется звездочка *, для обозначения одного символа используется вопросительный знак ?.

        Замечание. Переименовывать подкаталог в соответствии с заданным форматом нужно только после того, как в него были скопированы все требуемые файлы. В противном случае может возникнуть конфликт доступа к файлу.

      • Несколько файлов– будут добавлены несколько файлов. Чтобы определить количество файлов, нажмите кнопку Настройки… и введите число или диапазон значений. Файлы из подкаталогов добавляться не будут.
        Замечание. Если задано число, например 5, а в горячей папке осталось 4 файла, то эти файлы импортироваться не будут. Если же задан интервал 1-5, то оставшиеся 4 файла будут импортированы.
      • Один файл – будет добавлен один файл.
      • Прикреплено к письму – будут добавлены все прикрепленные к письму файлы.
      Замечание. Новые изображения добавляются в пакет в порядке возрастания имен.
    • Если профиль предназначен для импорта фотографий, а не сканированных изображений, отметьте опцию Обрабатывать изображение как фотографию.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений. Вы также можете использовать настройки разделения документов и обработки изображений, указанные для типа пакета. Для этого отметьте опцию Использовать настройки обработки изображений типа пакетов.

  4. На четвертом шаге мастер создания профиля предложит вам задать опции очищения горячей папки после импорта: успешно импортированные изображения можно удалять или перемещать в указанную папку. Изображения, в процессе обработки которых произошла ошибка (например, если файл был поврежден либо в результате ошибки сети), можно оставлять в Горячей папке или также перемещать в указанную папку. Если вы хотите перемещать изображения, задайте папки для перемещения.

    Замечание. Оставлять изображения, при обработке которых произошла ошибка, в Горячей папке рекомендуется в следующих случаях:

    • если используется режим ручного импорта из папки, так как при автоматическом импорте наличие в Горячей папке поврежденного файла может препятствовать обработке остальных файлов в папке;
    • если обработка Горячей папки часто прерывается из-за нестабильной работы сети.

  5. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.

Редактировать и создавать новые профили импорта можно также из диалога Выбор профиля импорта, который открывается при выборе пункта Файл>Импортировать изображения… главного меню.

Добавление изображений страниц


Индексные поля

Для удобства поиска документов при их обработке, можно проиндексировать документы по значениям любых полей определения документа. Тогда в списке документов в главном окне программы кроме основной информации можно будет вывести значения индексного поля для каждого документа, производить сортировку документов по этим значениям и легко находить нужные документы.

Для того чтобы производить индексирование по значению поля, нужно отметить свойство Индексное поле для этого поля (редактор определения документа, диалог свойств поля, закладка Общие).

Чтобы отобразить значения индексного поля в списке документов:

  • В главном окне программы откройте пакет документов и перейдите в режим детализованного списка документов (кнопка [image] панели инструментов).
  • Нажмите правую кнопку мыши в области шапки таблицы (названий колонок) и выберите в выпадающем списке пункт Настроить…
  • В диалоге Настройка столбцов нажмите кнопку Новая…
  • В диалоге Правка столбца нажмите Выбрать… справа от Индексное поле. В открывшемся диалоге можно выбрать одно из полей, у которых отмечена опция Индексное поле. Можете также ввести любое название столбца и задать способ выравнивания.
  • В таблице появится еще одна колонка со значениями индексного поля. Щелкнув левой кнопкой мыши на ее названии, вы можете произвести сортировку документов по значению индексного поля.


Свойства проекта

Свойства проекта можно просмотреть и отредактировать в диалоге, который открывается при выборе пункта меню главного окна Проект > Свойства проекта….

  • На вкладке Общие отображаются название проекта, путь к файлам проекта и описание. На этой вкладке можно также настроить инструменты типа пакета. Нажмите кнопку Правка…, чтобы открыть диалоговое окно Настройки инструмента типа пакета.
  • На вкладке Предобработка изображений можно просмотреть и отредактировать опции предварительной обработки изображений. Эти опции применяются к изображениям, добавленным из файла вручную. Подробнее см. Параметры обработки изображений.
  • На вкладке Распознавание можно отметить опцию Удалять пустые страницы во время распознавания - тогда пустые страницы будут удаляться на этапе распознавания. Также на данной вкладке можно подключить к проекту классификатор гибких описаний.
  • На вкладке Верификация отметьте опцию Группировать поля при контекстной верификации, если вы хотите группировать поля на этом этапе. Поля группируются по имени поля или группы, указанной в свойствах поля.
  • На вкладке Экспорт можно просмотреть и изменить настройки экспорта. Для экспорта нераспознанных документов отметьте опцию Экспортировать нераспознанные документы и укажите параметры экспорта.
  • На вкладке Процесс обработки настраивается процесс обработки пакетов (для типа пакетов "по умолчанию"). Подробнее о настройке процесса обработки см. в разделе Настройка процесса обработки.
  • На вкладке Обработчики событий можно просмотреть список событий, которые могут быть обработаны при помощи скриптов. Для того чтобы создать обработчик события, выберите событие из списка и нажмите кнопку Правка скрипта… В открывшемся редакторе скрипта напишите текст скрипта. Подробнее см. Обработчики событий.
  • На вкладке Сборки .Net можно подключать внешние сборки, которые могут использоваться в скриптах и глобальных модулях. Можно использовать как стандартные, так и откомпилированные пользовательские сборки. Для добавления сборки нажмите Добавить…. В открывшемся диалоговом окне укажите тип: Стандартное имя сборки или Путь к прикрепленному файлу. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки. Подробнее см. Подключение внешней сборки.
  • На вкладке Переменные окружения можно задать переменные окружения, которые могут использоваться при создании правил, настройке экспорта, написании скриптов. Подробнее см. Переменные окружения.


Создание проекта

Для начала работы необходимо создать проект. Проект включает в себя:

  • профили импорта изображений;
  • одно или несколько определений документов;
  • типы пакетов документов.

При запуске программы откроется диалог Открытие проекта, который позволяет вам выбрать один из существующих проектов или создать новый.

Для создания нового проекта:

  1. Нажмите кнопку Новый….
  2. Из выпадающего списка Тип проекта выберите тип проекта Общий.

Замечание. В программе ABBYY FlexiCapture реализована возможность создания проекта для обработки инвойсов - ABBYY FlexiCapture for Invoices. Чтобы создать проект для обработки инвойсов, выберите тип проекта Обработка инвойсов.

Подробнее См. "Что такое ABBYY FlexiCapture for Invoices".

  3. Задайте папку для хранения проекта и имя проекта.
  4. Нажмите кнопку Создать.

Свойства проекта
Определения документов
Профили импорта изображений
Типы пакетов
Пакеты документов


Загрузка проекта на сервер

Созданный проект необходимо загрузить на Сервер Приложений. В процессе выгрузки проекта на Сервер Приложений копируется информация о настройках проекта, а также файлы с определениями документов, вспомогательные словари и т.д.

Внимание! Если в проекте были созданы пакеты, в процессе выгрузки проекта на сервер, пакеты не копируются.

Для того чтобы загрузить проект на Сервер Приложений необходимо выбрать Файл>Загрузить проект на сервер… в главном меню Станции Настройки Проектов.

Замечание. Только Администратор комплекса может создавать проекты. Настройку созданного проекта осуществляет Оператор Настройки Проектов. Поэтому после выгрузки созданного проекта на Сервер Приложений и выдачи прав операторам станций (настраивает Администратор через Консоль Администрирования и Мониторинга на данный проект), Оператору Настройки Проектов необходимо открыть проект на сервере выбрав в главном меню станции команду Файл>Открыть проект на сервере…и настроить его (создать определения, профили импорта, настройки экспорта и т.д.)

Внимание! Для корректного экспорта после загрузки проекта на сервер путь должен быть указан в формате UNC (\\computer_name\share_name[\path]). Убедитесь, что все станции, осуществляющие экспорт, имеют доступ к указанному пути.

В загруженном на сервер проекте будут возникать ошибки экспорта, если путь указан в формате <disk:>\[path]. Если будет указан относительный путь экспорта, данные будут доступны только c помощью программного интерфейса (API). Для доступа к данным иным образом необходимо указать в формате UNC корневой каталог для относительных путей (это можно сделать при настройке свойств проекта).


Регистрационные параметры

Регистрационные параметры – текстовые свойства, позволяющие идентифицировать конкретный пакет или документ. В качестве таких свойств можно использовать, например, дату сканирования, фамилию оператора сканирования и т. д. Регистрационный параметр может быть обязательным и необязательным для указания.

Регистрационные параметры могут присваиваться пакету при создании (если пакет создается автоматически при использовании профилей импорта). Также регистрационные параметры могут быть присвоены пакетам и документам на станции сканирования и переданы в ABBYY FlexiCapture вместе с изображениями.

Регистрационные параметры можно изменить на закладке Регистрационные параметры диалогового окна свойств пакета или документа соответственно (пункт Свойства… локального меню).

Замечание. Рекомендуется указывать различные имена для регистрационных параметров документа и пакета. В случае совпадения имен, при подстановке значения регистрационного параметра всегда используется регистрационный параметр документа. Например, при формировании имен файлов во время экспорта.

Collapsed Именованные регистрационные параметры

Также существует возможность указать некоторые настройки обработки документов, используя именованные регистрационные параметры.

  • Параметр fc_Predefined:DefinitionsToMatch. С помощью данного регистрационного параметра можно ограничить список определений документов, используемых при наложении. Значение параметра будет считаться множеством определений документов, используемых при наложения для данного документа. Значением параметра может быть имя определения документа, имя определенного раздела или их множество, в котором элементы перечислены через точку с запятой. Например:

    «Document Definition 1; Document Definition 2\Section 1; Document Definition 2\ Section 2».

    Данный регистрационный параметр может быть заполнен оператором на Станции сканирования (вручную или с помощью скрипта). Также данный параметр можно заполнить на любом этапе, предшествующем распознаванию, если получена информация, какое определение документа нужно наложить (например, в результате применения классификации).

  • Параметр fc_Predefined:DocumentError. Если данный регистрационный параметр не пуст, то на этапе экспорта документ будет считаться документом, содержащим ошибку, и экспорт документа будет выполняться по профилям для документов с ошибками. В описании ошибки содержится значение регистрационного параметра.
Collapsed Хранение основных заголовков письма в регистрационных параметрах

При импорте изображений из папки электронной почты (с использованием протокола POP3-сервер или MAPI) параметры письма автоматически записываются в регистрационные параметры созданного пакета, а именно:

  • fc_Predefined:EmailSubject - тема письма;
  • fc_Predefined:EmailSender - имя отправителя;
  • fc_Predefined:EmailAddressee - имя получателя;
  • fc_Predefined:EmailDate - дата и время получения письма.

Замечание. При необходимости можно отключить запись вышеуказанных регистрационных параметров. Для этого в системном реестре необходимо задать ключ [HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\11.0\Controller] "UseHotFolderSpecialParameters"="false".


Диалоговое окно Настройки правила

В режиме Расширенный настройки процесса обработки вы можете указывать маршруты выхода и условия входа на этап при помощи правил.
Правила позволяют указать как условия, при которых задания будут отправлены на следующий этап, так и условия, при которых документы допускаются на данный этап.

Правила отправки на следующий этап настраиваются в окне Следующий этап, которое открывается при добавлении или редактировании этапа на закладке Маршруты выхода окна Свойства этапа обработки.
Правила, определяющие условия, при которых документы допускаются на этап, настраиваются на закладке Условия входа окна Свойства этапа обработки.

Маршруты выхода и условия входа на этап могут быть заданы с помощью стандартных правил либо с помощью правила этапа.

Для добавления правила нажмите кнопку Правило…. Для редактирования правила нажмите Правка….

Диалоговое окно Настройки правила содержит следующие поля:

Поле | Описание
Имя | Название правила.
Тип условия Вы можете выбрать один из следующих типов условия:
  • Стандартное правило
  • Скрипт

Для типа условия Стандартное правило:
Правило выполняется, если Выберите условие применения правила:
  • Условие выполняется
  • Условие не выполняется
Условие Выберите одно из следующих условий:
  • Задача обработана успешно
  • Количество символов для верификации удовлетворяет выражению
  • Процент символов для верификации удовлетворяет выражению
  • Количество полей для обязательной верификации удовлетворяет выражению
  • Количество символов для двойной верификации удовлетворяет выражению
  • Есть ошибки правил
  • Есть ошибки сборки
  • Есть ошибки целостности пакета
  • Значение поля удовлетворяет выражению
Для условий, в которых содержится выражение, введите эталонное значение и укажите, как проверяемое значение должно относиться к эталонному: быть равным эталонному, быть не равным, быть меньше, быть меньше или равным, быть больше, быть больше или равным.

Для условия Значение поля удовлетворяет выражению укажите также поле, значение которого будет сравниваться с эталонным значением. Для этого нажмите кнопку Выбрать… и выберите требуемое поле из списка.

Для типа условия Скрипт:
Скрипт… | Открывает окно редактора скрипта, где вы можете редактировать правило этапа. После закрытия редактора сохраненный код скрипта отображается в окне Настройки правила слева от кнопки Скрипт….


Настройка внешнего вида программы

Диалоговое окно Настройки оболочки позволяет настроить внешний вид станции оператора при помощи инструментов типа пакета. Для открытия диалога нажмите кнопку Редактировать… в диалоговом окне Настройки инструмента типа пакета.

На закладке Панели инструментов можно настроить панели управления для выбранного инструмента. Для каждого инструмента список панелей управления содержит четыре обязательных пункта: Задания, Стандартная, Вид и Навигация. Для добавления новой панели управления нажмите кнопку Новая.... Укажите в открывшемся диалоговом окне наименования панели управления и нажмите кнопку OK для добавления ее в список. Для изменения наименования созданной панели нажмите кнопку Переименовать…

На закладке Команды можно изменить команды меню и панелей управления. Отметьте пункт Меню или Панель и выберите в выпадающем списке наименование пункта меню или панели, которую необходимо изменить. Раздел Команды содержит список доступных для выбора команд, для каждой из которых с помощью кнопок доступны следующие действия:

Кнопка | Действие
Новая... | Открывает диалоговое окно Редактировать команду для добавления новой команды.
Правка... | Открывает диалоговое окно Редактировать команду, в котором вы можете изменить название команды.
Удалить | Удаляет выбранную команду из списка.
Выше и Ниже | Перемещает выбранную команду выше или ниже в списке.
Сбросить | Восстанавливает настройки по умолчанию.

Поле Подсказка содержит текст подсказки для команды и горячие клавиши (если для команды указаны горячие клавиши).

Замечание. При добавлении пользовательской команды вы можете ввести для нее текст подсказки. Максимальная длина текста подсказки составляет 80 символов. Горячие клавиши для пользовательских команд настраиваются на закладке Сочетания клавиш меню Сервис > Опции…

При добавлении и редактировании команд панелей управления можно выбрать, каким образом отображать команду на панели: в виде текста либо в виде иконки. Если выбран пункт Использовать пиктограмму, нажмите кнопку Обзор (bmp, 24x24)…, чтобы загрузить изображение, которое будет использоваться в качестве иконки команды. Изображение должно быть в формате .bmp и иметь размер 24x24 пикселя. Для команд панели Задания размер изображения должен быть 32x32 пикселя.

Видимостью пользовательских панелей можно управлять через меню. Для добавления пункта меню, позволяющего показывать/скрывать пользовательские панели, выберите на закладке Команды пункт меню, в который будет добавлен список пользовательских панелей и нажмите Правка... В открывшемся диалоге Редактировать команду выберите в списке Категории пункт Вид и в списке Команды выберите Настраиваемые панели инструментов. В меню станции появится пункт Настраиваемые панели инструментов, содержащий список всех пользовательских панелей.

Замечание. Команду Настраиваемые панели инструментов можно добавить только в меню. Добавить команду на панель инструментов нельзя.


Свойства этапа обработки

В режиме Расширенный настройки процесса обработки вы можете задать свойства этапа при создании нового этапа, а также редактировать свойства базовых и ранее созданных пользовательских этапов.
Редактирование свойств этапа происходит в окне Свойства этапа обработки. Чтобы открыть это диалоговое окно для выбранного этапа, нажмите кнопку Правка… справа.
Свойства сгруппированы на закладках. Число закладок и набор доступных для редактирования свойств на каждой закладке определяется базовым типом выбранного этапа.

Свойство

Описание

Этап

Закладка Общие

Имя

В этом поле можно ввести название этапа

Для всех этапов

Инструмент

Название используемого инструмента. Название инструмента совпадает с базовым типом этапа.
Замечание. Для этапа Интерактивные можно выбрать один из следующих инструментов:

  • Проверка сборки документов
  • Верификация
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта.
В зависимости от выбранного инструмента, этапу будет присвоен соответствующий базовый тип.

Только для этапов:

  • Интерактивные
  • Проверка сборки документов
  • Верификация данных
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта

Документов в задании

Устанавливает максимальное количество документов в задании
Замечание. Если указанное количество меньше аналогичного параметра на предыдущем этапе, то задания будут формироваться в соответствии с ограничением для данного этапа. Следует либо устанавливать одинаковые ограничения для этапов, либо использовать опцию Обрабатывать пакеты целиком.

Можно изменять для всех этапов, кроме Проверка целостности пакета и Обработано

Ожидать все документы пакета

Нужно ли обрабатывать ли пакеты целиком или отправлять документы на следующий этап по мере обработки

Для всех этапов, кроме Проверка целостности пакета и Обработано

Документы, допускаемые на этап

С помощью данной опции можно указать, какие документы допускаются на этап. Для документов, поступающих на этап, выполняется проверка, соответствуют ли они указанным определениям документа. Документы, распознанные по указанным определениям документов, будут допущены на этап.
Замечание. Если на этап допускается ограниченный набор документов и отмечена опция Ожидать все документы пакета, то на данном этапе будут обрабатываться только документы из указанного набора, но в задание отправки на следующий этап будут включены все документы пакета.
Замечание. Ограничить набор определений документов, используемых при распознавании, можно с помощью скрипта.

Для всех этапов, кроме Исключения и Обработано
Разрешить web-станции Можно ли использовать web-станцию Только для этапов:
  • Исключения
  • Верификация данных
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта
Связать с предыдущим (операторы не смогут вручную отправлять задания на этот этап) Допускается ли переход на данный этап с этапов, не являющихся непосредственными предшественниками в схеме маршрутизации. Если поле выбора заполнено, то переход на этап возможен только с предыдущего в схеме маршрутизации. Это может потребоваться в случае, если данный этап зависит от результатов предыдущего и отправка на этот этап, минуя предыдущий, не допускается. Чтобы разрешить операторам вручную отправлять задания на данный этап с других этапов обработки, очистите данное поле. Для всех этапов, кроме Исключения и Обработано

Закладка Набор полей (присутствует только у этапов Верификация данных и Верификация)

Данные, обрабатываемые на этапе

Позволяет ограничить набор полей, доступных для обработки (при использовании распределенной верификации). В списке Доступные поля укажите поля, которые нужно обрабатывать. Список содержит определения документов, указанные на закладке Общие.
Используйте кнопки ">" и ">>" для добавления требуемых полей в список Выбранные поля.
Кнопка ">" добавляет в список выбранный элемент (определение документов, страницу, группу полей или поле).
Кнопка ">>" добавляет все определения документов из списка Доступные поля в список Выбранные поля.
Кнопки "<" и "<<" удаляют из списка Выбранные поля данный элемент или все элементы соответственно.

Только для этапов Верификация данных и Верификация

Скрывать изображение страницы вне выбранных полей

Нужно ли скрывать поля, не включенные в Набор полей. Отметьте эту опцию, если требуется обеспечить высокий уровень безопасности при распределенной верификации.

Только для этапа Верификация данных

Двойная верификация

Нужно ли использовать двойную верификацию на этапе. Если эта опция выбрана, верификация данных для документа будет осуществляться двумя различными операторами.

Только для этапа Верификация данных

Закладка Скрипт (присутствует только у этапа Автоматические)

Тип

В выпадающем списке выберите один из скриптов обработки: скрипт обработки документа или скрипт обработки пакета.

Только для этапа Автоматические

Правка скрипта…

Открывает окно редактора скрипта.

Только для этапа Автоматические

Закладка Маршруты выхода (отсутствует у этапов Исключения, Повторное сканирование и Обработано)

Следующий этап

Выберите, каким образом определяется следующий этап:

  • Следующий по схеме
  • Указанный (выберите следующий этап в выпадающем списке)

Для всех этапов, кроме Исключения, Повторное сканирование и Обработано

Условия отправки документов на другие этапы

Содержит список этапов, на которые может быть отправлено задание при выполнении заданных условий.
Для добавления этапа нажмите кнопку Этап…. Откроется окно Следующий этап. В этом диалоговом окне вы можете выбрать этап и задать условия, при которых задание будет отправлено на данный этап. Используйте кнопки справа для настройки этапов:

  • Правило… - открывает диалоговое окно Настройки правила для добавления нового правила.
  • Правка… - открывает диалоговое окно Настройки правила для редактирования настроек выбранного правила.
  • Удалить - удаляет выбранный элемент (правило или группу правил).
  • Группа… - открывает диалоговое окно Группа правил для добавления группы правил. Укажите название группы и условие, при котором будет выполнена группа правил: при выполнении "Хотя бы одного правила в группе" или "Всех правил в группе".
  • Выше - перемещает выбранное правило или группу правил на одну позицию вверх.
  • Ниже - перемещает выбранное правило или группу правил на одну позицию вниз.
Для редактирования выбранного этапа нажмите кнопку Правка…. Откроется окно Следующий этап, содержащее настройки правил для выбранного этапа.
Для удаления выбранного этапа нажмите Удалить.
Используйте кнопки Выше и Ниже для изменения порядка расположения этапов.

Для всех этапов, кроме Исключения, Повторное сканирование и Обработано

Закладка Условия входа (отсутствует у этапов Исключения и Обработано)

Документы на этап допускаются

Укажите, допускаются ли документы на этап всегда или при определенных условиях. Если выбрана опция При условиях, используйте кнопки справа для задания условий.
Для добавления правила нажмите кнопку Правило…. Откроется окно Настройки правила.
Для редактирования выбранного правила нажмите Правка…. Откроется диалоговое окно Настройки правила, в котором содержатся настройки выбранного правила.
Для удаления выбранного элемента (правила или группы правил) нажмите Удалить.
Для добавления группы правил нажмите кнопку Группа…. В открывшемся окне Группа правил укажите название группы и условие, при котором будет выполнена группа правил: при выполнении

  • Хотя бы одного правила в группе или
  • Всех правил в группе
Используйте кнопки Выше и Ниже для изменения порядка следования правил внутри группы.

Замечание. Если условие не выполняется, документ переходит на следующий этап, указанный в настройках процесса обработки.

Для всех этапов, кроме Исключения и Обработано

Замечание. Информация о выбранном маршруте выхода и проверявшихся условиях входа записывается в Журнале событий.


Инструменты этапа

Инструменты этапов

Закладка Инструменты этапов диалогового окна Свойства проекта позволяет настроить инструменты этапов обработки. С помощью данной закладки можно добавлять и удалять инструменты и редактировать их параметры.

Для создания нового инструмента этапа обработки, нажмите кнопку Новый... В диалоговом окне Создание инструмента этапа обработки укажите название инструмента обработки и его описание и выберите тип этапа в выпадающем списке Тип. Для добавления инструмента в список, нажмите кнопку ОК.

Для редактирования существующего этапа выберите его в списке и нажмите кнопку Правка. В диалоговом окне Настройки инструмента этапа обработки укажите следующие настройки:

Настройка | Описание
Группа Параметры события
Кнопка Добавить… | Открывает диалоговое окно Добавление события для выбора события, которое необходимо обрабатывать. Чтобы написать скрипт-обработчик события, нажмите кнопку Правка скрипта… для открытия диалогового окна Редактор кода скрипта.
Кнопка Правка скрипта… | Открывает диалоговое окно Редактор кода скрипта для ввода текста скрипта.
Кнопка Удалить | Удаляет выбранный инструмент из списка.
Группа Настройки оболочки
Кнопка Редактировать… | Открывает диалоговое окно Настройки оболочки для настройки внешнего вида этапа.
Кнопка Сбросить | Сбрасывает настройки оболочки на изначальные.


Настройка процесса обработки

Последовательность обработки пакета указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и таким образом формируется последовательность обработки этого пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…, закладка Процесс обработки).

Настройка процесса обработки пакетов осуществляется на закладке Процесс обработки диалога Свойства Типа пакетов.

Предусмотрены следующие режимы обработки: Обычный, Расширенный, Автоматический, для Web-станции Ввода документов и Расширенный для Web-станции Ввода документов.

Collapsed Обычный режим обработки

Обычный режим включает следующие этапы: Сканирование, Повторное сканирование, Распознавание, Верификация данных, Проверка сборки документов, Верификация, Проверка целостности пакета, Подтверждение экспорта, Исключения, Экспорт и Обработано.

Вы можете настроить следующие параметры обработки:

  1. Обрабатывать пакеты целиком
    • если опция отмечена, то пакет обрабатывается целиком (т.е. до тех пор, пока не будут обработаны все документы пакета, он не будет отправлен на следующий этап);
    • если опция не отмечена, то документы по мере обработки будут отправляться на следующий этап, не дожидаясь обработки всех документов пакета.
  2. Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен - документ будет направлен на верификацию только при наличии ошибок, либо если количество подсвеченных символов больше значения, указанного в поле % на документ.
    Замечание. Если в настройках контекстной верификации какого-нибудь поля документа выбрано значение Всегда, то документ обязательно будет направлен на верификацию.
  3. Использовать отдельные этапы для:
    • Повторное сканирование
    • Верификация данных
    • Проверка сборки документов
    • Верификация
    • Проверка целостности пакета
    • Подтверждение экспорта
    • Исключения

    Все этапы, кроме этапа Верификация, необязательны.

    Формируя отдельные очереди, можно разбить работу по проверке распознанных документов на этапы и выделить на каждую отдельного оператора. Таким образом, оператор верификации будет занят одной задачей - либо проверкой данных, либо проверкой сборки документов и т.д.

    Если все эти очереди обрабатывает один оператор, то в этом случае ему нужно будет последовательно выполнить задания: сначала забрать документ из очереди на проверку сборки документа, только проверив сборку он сможет проверить данные, взяв задание из очереди на верификацию данных и т.д.

    Также можно использовать web-станции для всех этапов, за исключением этапа Повторное сканирование. Для этого в столбце Разрешить web-станции поставьте галочку напротив нужного этапа. Верификация данных будет осуществляться на web-станции Верификации или Верификации данных, остальные этапы будут обрабатываться на web-станции Верификации.

Collapsed Расширенный режим обработки

В режиме Расширенный можно настраивать сложные схемы обработки. Этот режим позволяет как редактировать базовые этапы, так и создавать этапы самостоятельно.

Замечание. Существует задержка во времени между тем, когда настройки применяются на Станции настройки проекта и тем, когда они отражаются на Станции верификации.

Режим Расширенный включает следующие базовые этапы:

  • Исключения
  • Сканирование
  • Повторное сканирование
  • Распознавание
  • Автоматическая обработка
  • Верификация данных
  • Верификация
  • Проверка сборки документов
  • Проверка целостности пакета
  • Подтверждение экспорта
  • Экспорт
  • Обработано

Отметьте этапы, которые должны быть включены в схему обработки. Все этапы, кроме Сканирование и Обработано, опциональны.
Чтобы изменить порядок следования этапов, используйте кнопки Выше и Ниже справа. Для этапов, которые не могут быть выполнены ранее или позднее, соответствующие кнопки отключены.

Для каждого этапа в столбце Документов в задании указано максимальное количество документов, которое может содержаться в задании. Чтобы изменить это количество для выбранного этапа, щелкните по числу и введите новое значение.

Замечание. На этапах Проверка целостности пакета и Обработано пакеты обрабатываются целиком и не разделяются на задания, поэтому для этих этапов изменить число документов в задании нельзя.

В столбце Базовый тип для каждого этапа указан его базовый тип - тип, настройки которого использовались при создании данного этапа.

Для каждого этапа можно просматривать и редактировать его свойства. Чтобы открыть диалоговое окно с настройками для выбранного этапа, нажмите кнопку Правка… справа. Смотрите также Свойства этапа.

Помимо базовых этапов, можно также создавать пользовательские этапы и включать их в процесс обработки. Пользовательские этапы могут быть созданы на основе инструментов этапов. Добавление пользовательских этапов позволяет создавать этапы, имеющие один базовый тип, но различные свойства этапа.

Для добавления этапа нажмите кнопку Этап… справа. В открывшемся окне выберите базовый этап, на основе которого будет создан пользовательский этап и укажите свойства нового этапа. Созданный этап будет включен в схему. Смотрите также Создание пользовательских этапов.

Чтобы удалить выбранный пользовательский этап, нажмите кнопку Удалить справа.

Если переход на этап определяется условиями, этап отмечен значком [image]. Если документы всегда допускаются на этап, этап имеет значок [image].

Collapsed Автоматический режим обработки

В режиме Автоматический документы обрабатываются и экспортируются без участия операторов. В случае возникновения ошибок, нераспознанные изображения можно сохранить в отдельную папку (настраивается на закладке Экспорт), а обработанные документы будут автоматически экспортированы. В автоматическом режиме пакеты обрабатываются целиком.

Процесс обработки на Web-станции ввода документов можно настроить с помощью режимов для Web-станции Ввода документов и Расширенный для Web-станции Ввода документов.

Collapsed Режим обработки для Web-станции Ввода документов

Режим для Web-станции Ввода документов позволяет указать условие отправки документов на верификацию. Отметьте опцию Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен, если вы хотите отправлять документы на верификацию только при наличии ошибок, либо если количество подсвеченных символов больше значения, указанного в поле % на документ.

Collapsed Режим Расширенный для Web-станции Ввода документов

Режим Расширенный для Web-станции Ввода документов так же, как и режим Расширенный, предназначен для настройки сложных схем обработки за счет редактирования существующих этапов и добавления новых. По сравнению с режимом Расширенный имеет следующие ограничения:

  • Нельзя изменять набор предопределенных этапов.
  • Пользовательский этап может быть создан только на основе этапа Автоматические.
  • В свойствах этапа для редактирования доступно только название этапа, а также условия входа и выхода.

Замечание. При изменении режима Расширенный для Web-станции Ввода документов на режим Расширенный и наоборот все настройки сбрасываются на изначальные.


Настройка процесса обработки

Последовательность обработки пакета указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и таким образом формируется последовательность обработки этого пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…, закладка Процесс обработки).

Настройка процесса обработки пакетов осуществляется на закладке Процесс обработки диалога Свойства Типа пакетов.

Настройки процесса обработки:

  1. Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен - если процент подсвеченных символов меньше, чем указано в поле % на документ, стадии Верификации и Верификации данных для документа будут пропущены.
  2. Для того чтобы документы экспортировались автоматически, выберите опцию Разрешить автоматический экспорт на закладке Экспорт окна свойств определения документа.


Создание пользовательских этапов

Добавление пользовательских этапов происходит в режиме Расширенный настройки процесса обработки.
Чтобы добавить пользовательский этап, нажмите кнопку Этап… справа. В открывшемся окне Создание этапа обработки содержится список базовых и ранее созданных пользовательских этапов, на основе которых можно создать новый этап. Свойства выбранного этапа отображаются в нижней части диалогового окна под заголовком Выбранные настройки.

В режиме Расширенный можно создать этап одного из следующих типов:

  1. Автоматические - задания этого типа выполняются на Станции обработки без участия оператора.
    Этап Автоматические включает следующие подэтапы:
    • Распознавание
    • Автоматическая обработка
    • Экспорт
  2. Интерактивные - задания этого типа обрабатываются операторами на Станции верификации, Станции верификации данных и Станции сканирования.
    Этап Интерактивные включает следующие подэтапы:
    • Сканирование
    • Верификация данных
    • Проверка сборки документов
    • Верификация
    • Проверка целостности пакета
    • Подтверждение экспорта
  3. Пользовательские - задания этого типа обрабатываются внешними клиентами с помощью программного интерфейса (API) и возвращаются на следующий этап.

Замечание. Чтобы включить в схему скрипт обработки, выберите этап Автоматические.

Выберите этап, на основе которого будет создан пользовательский этап, и нажмите OK. Откроется окно Свойства этапа обработки. Это окно содержит следующие закладки:

  • Общие
  • Набор полей (только для этапов Верификация данных и Верификация)
  • Скрипт (только для этапа Автоматические)
  • Маршруты выхода (для всех этапов, кроме Исключения, Повторное сканирование и Обработано)
  • Условия входа (для всех этапов, кроме Исключения и Обработано)
  • Роли (для этапов, основанных на пользовательских инструментах этапов)

Настройки на каждой закладке зависят от выбранного этапа. Подробное описание настроек смотрите на странице Свойства этапа обработки.


Реперы

Реперы - статические элементы, выделяются на изображении автоматически.

Для того, чтобы выделить реперы вручную:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];

  3. Установите курсор мыши в угол репера, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области репера.

Свойства репера

Чтобы изменить свойства репера:

  1. Выделите репер;
  2. Щелкните в области репера правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы репер использовался для наложения определения документа (рекомендуется);
    • Использовать для идентификации определения документа - отметьте эту опцию для использования репера в качестве идентификатора;
    • Вид репера - для правильного наложения определения документа важно, чтобы была указана форма репера: черный квадрат, крестик, уголок или черный прямоугольник.


Реперный штрих-код

Реперный штрих-код - статический элемент.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это зависит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения определения документа или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства статического элемента - реперного штрих-кода, см. также поле штрих-код.

Для того, чтобы выделить реперный штрих-код:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол штрих-кода, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области штрих-кода.

Свойства реперного штрих-кода

Чтобы изменить свойства реперного штрих-кода:

  1. Выделите штрих-код;
  2. Щелкните в области штрих-кода правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы штрих-код использовался для наложения определения документа;
    • Использовать для идентификации определения документа- отметьте эту опцию для использования штрих-кода в качестве идентификатора;
    • Значение - если вы используете реперный штрих-код в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить
    • Требуется для наложения определения - если эта опция отмечена, то определение документа может быть наложено, только если будет наложен штрих-код. Штрих-код следует делать обязательным для наложения определения документа, если в пакете много определений и остро стоит задача выбора, например, из очень похожих определений документов, отличающихся только значением штрих-кода, или даже значением одного из нескольких штрих-кодов. Тогда обязательное наложение штрих-кода ускорит выбор определения. Не следует отмечать эту опцию, если вы хотите, чтобы определение могло быть наложено даже при отсутствии штрих-кода или если он плохо пропечатан.

    На закладке Распознавание:

    • Тип кода - задайте тип штрих-кода (обычно определяется автоматически);
    • Ориентация - задайте ориентацию штрих-кода.

    Можно задать опции обработки изображения штрих-кода:

    • Инвертировать - инвертировать изображение;
    • Удалять текстуру - удалять текстуру;
    • Очищать изображение - задайте эту опцию, чтобы производилось очищение изображения от "мусора";
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Реперный текст

Реперный текст - статический элемент. Это любой статический текст на изображении - заголовки, пояснительные подписи.

Для того, чтобы выделить реперный текст:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол текста, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области текста.

Свойства реперного текста

Чтобы изменить свойства реперного текста:

  1. Выделите текст;
  2. Щелкните в области текста правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы текст использовался для наложения определения документа;
    • Использовать для идентификации определения документа- отметьте эту опцию для использования текста в качестве идентификатора;
    • Значение - если вы используете реперный текст в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить;
    • Допустимое число ошибок - вы можете задать максимальное количество возможных ошибок в строке реперного текста.

    На закладке Распознавание нужно задать опции распознавания, чтобы статический текст был распознан с максимальной точностью:

    • ICR (рукопечатный) – отметьте эту опцию, если статический текст написан от руки.

    • OCR (печатный) – отметьте эту опцию, если статический текст напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машине и т.д.) См. Поддерживаемые типы текста.

    • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.

    • Тип данных – выберите язык, на котором написан текст. Для выбора воспользуйтесь кнопкой Выбрать…

    • Регистр – выберите регистр букв статического текста, если в тексте встречаются как строчные, так и заглавные буквы, оставьте значение Любой.

    • Ориентация – задайте ориентацию текста.

    • Для однострочного текста отметьте опцию Однострочное.

    • Если текст не содержит пробелов, то есть, состоит из одного слова, отметьте опцию Одно слово.

    • Задайте опции обработки изображения при распознавании:
    • Инвертировать – инвертировать изображение.
    • Удалять текстуру – удалять текстуру.
    • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Автоматическое выделение полей и статических элементов

Автоматическое выделение при добавлении изображения:

При добавлении изображения страницы, автоматически производится поиск реперов на этом изображении. Стандартные реперы (например, черные квадраты) будут найдены и отмечены. Поиск текстовых полей и меток производится в том случае, если необходимость их поиска указана пользователем, то есть отмечены опции Текст или Метки. Особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

Автоматическое выделение в окне редактора определения документа:

Для автоматического выделения в окне редактора определения документа, выберите нужный режим работы (поля или статические элементы) и выберите пункт меню Сервис>Найти объекты на изображении по типу…. Отметьте типы полей или статических элементов, которые должны быть найдены автоматически.

Если вы хотите автоматически выделять конкретные объекты на изображении, то выберите нужный режим работы (поля или статические элементы) и нажмите [image] на панели инструментов. Затем щелкните мышью в области элемента - он будет выделен прямоугольником. Тип элемента будет определен автоматически.

Автоматическое выделение области:

Для того, чтобы область поля или статического элемента определенного типа была выделена автоматически, выполните следующие действия:

  1. Выберите нужный режим работы (поля или статические элементы);
  2. Выберите тип поля или статического элемента с помощью нужной кнопки панели инструментов;
  3. Нажмите Shift;
  4. Щелкните левой кнопкой мыши в области поля или статического элемента.


Как изменить название поля

Для того чтобы изменить название поля:

  • Щелкните на название поля в структуре документа, нажмите на правую кнопку мыши, выберите пункт локального меню Переименовать и введите новое название.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Подобрать название. Полю будет присвоено название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Распознать название с изображения…. Затем обведите курсором мыши пояснительный текст, который подходит для названия поля. Название поля изменится на выбранный текст.

или

  • Откройте диалог свойств поля и измените название на закладке Общие.


Копирование, перемещение, удаление полей

Поля можно копировать, удалять, перемещать, изменять их размеры. Названия скопированных полей отличаются цифрами. Можно выделить одновременно несколько полей, удерживая нажатой кнопку Ctrl. Тогда выполняемое действие будет применено ко всем выделенным полям.

Для того чтобы удалить поле, выделите его и нажмите клавишу Delete или выберите пункт Удалить локального меню. Для того чтобы удалить только разметку, а поле оставить в структуре документа, нужно нажать клавиши Shift+Delete или выбрать пункт Удалить область локального меню поля. См. Поля без разметки.


Создание группы меток

В группу объединяются логически связанные метки и, как правило, соответствующие взаимоисключающим ответам на один вопрос. В этом случае из группы выбирается одна метка, чье значение и будет экспортироваться. Однако, это не обязательное условие, вы можете разрешить отмечать более одной метки из группы (опция в свойствах группы меток).

Первый способ создания группы меток:

Чтобы создать группу меток:

  1. Выбрав инструмент [image], создайте метки, входящие в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все метки, которые будут входить в данную группу.
  3. Метки, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы меток. Свойства меток, входящих в группу, одинаковы и не редактируются по отдельности.

Второй способ:

Не обязательно отмечать каждую метку, входящую в группу.

  1. Не выделяя метки по отдельности, сразу выберите инструмент [image] и обведите прямоугольником метки, которые будут входить в данную группу.
  2. Метки, оказавшиеся внутри прямоугольника, будут автоматически найдены, им присваиваются названия и они объединяются в группу.


Создание пользовательских типов данных

Чтобы создать новый тип данных, выберите одно из значений в списке Тип данных на закладке Тип данных свойств поля. Вы можете выбрать любое значение из списка, которое соответствует смыслу вашего пользовательского типа: создание нового типа от этого не зависит, но храниться новый тип данных будет в выбранной категории.

Затем нажмите кнопку Правка… справа от поля Details.

В открывшемся диалоге выберите значение Специальный в поле Тип содержимого.

Нажмите кнопку Новый…справа от поля Типы данных для выбранного языка.

Следуйте инструкциям Мастера создания нового типа данных.

На первом шаге мастера выберите способ создания типа данных, вы можете создать новый тип данных на основе словаря, регулярного выражения или алфавита или создать новый тип на основе уже существующего типа данных, например, добавив к его алфавиту недостающие вам символы или дополнив словарь.

Чтобы создать новый тип данных на основе словаря, регулярного выражения или алфавита:

  1. Выберите Новый тип данных на основе и отметьте соответствующую опцию, в зависимости от того, будете вы создавать новый тип данных на основе словаря, регулярного выражения или алфавита. Вы можете выбрать одну или несколько опций. Выберите Язык (регион) для вашего типа данных. Нажмите Далее (Next).
  2. Если на первом шаге вы выбрали словарь, то на следующем шаге нужно задать принцип использования словарей. Отметьте опцию Использовать встроенный словарь, если вы хотите использовать встроенный словарь для выбранного на первом шаге языка. Чтобы определить наличие слова в словаре, нажмите Просмотр… и введите искомое слово. При нажатии на кнопку Посмотреть вы получите парадигму слова или сообщение об отсутствии слова в словаре. Отметьте опцию Пользовательские словари для использования пользовательского словаря и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic. Нажмите Далее (Next).
    Замечание. Файл в формате DIC является пользовательским словарем Microsoft Office. Представляет собой список слов в виде текстового файла, по одному слову в строке.
    Замечание. Чтобы создать пользовательский словарь, содержащий слова вида:

    201.01.063.030
    201.01.063.031
    201.01.063.040

    , нужно создать файл с расширением .txt, содержащий следующие данные:

    DICTIONARY_PROPERTIES=USE_CONFIDENCE
    201.01.063.030 100
    201.01.063.031 100
    201.01.063.040 100

  3. Если на первом шаге вы выбрали регулярное выражение, то на следующем шаге нужно задать это выражение. Правильно составить регулярное выражение вам поможет кнопка [image] справа от окна для ввода выражения. Подробнее см. Алфавит, используемый в регулярных выражениях. Нажмите Далее (Next).
  4. Если на первом шаге вы выбрали алфавит, или использовали не включенные в алфавит языка символы при создании регулярного выражения, то на следующем этапе нужно задать алфавит для вашего типа данных. Символы можно вводить с клавиатуры, или вы можете нажать Изменить… и выделите нужные символы с помощью мыши.

    Чтобы добавить знаки препинания и исключенные (запрещенные) символы, нажмите Расширенные параметры…. Эти символы тоже можно вводить с клавиатуры или нажать кнопку справа и выбирать среди возможных символов.

    Нажмите Далее (Next).

  5. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Чтобы создать новый тип данных на основе существующего типа:

  1. На первом шаге Мастера создания нового типа данных выберите На базе существующих типов. Выберите язык (или несколько языков). Нажмите Далее (Next).
  2. На следующем шаге нужно выбрать исходный тип данных (несколько типов), на основе которого вы хотите создать свой тип. В левой части диалога в поле List1 вы увидите типы данных, соответствующие выбранным языкам. В папке Текст содержаться натуральные языки, выбранные на первом шаге. В папке Пользовательские содержаться типы данных, созданные пользователями. В остальных папках содержаться типы данных, относящиеся к соответствующей категории и специальному типу содержимого. Чтобы выбрать базовый тип данных, выделите его в поле List1(можно выделить несколько, удерживая клавишу Ctrl) и перенесите его в правую часть с помощью кнопки Добавить ->. Нажмите Далее (Next).
    Замечание. Если новый тип данных создан на основе нескольких типов, то всё поле будет проверяться на совпадение хотя бы с одним из указанных типов данных.
  3. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Созданные типы данных появятся в списке предопределенных типов данных при выборе того содержимого, которое было выбрано и при создании типа данных.

Таким образом, чтобы задать созданный тип данных для вашего поля:

  1. На закладке Тип данных диалога задания свойств поля выберите нужное значение в списке Тип данных;
  2. Нажмите на кнопку Правка… справа от поля Details;
  3. В списке Тип содержимого выберите Специальный;
  4. Найдите в списке созданный тип данных (пользовательские типы данных отличаются от встроенных значком), выберите его и нажмите ОК.


Создание групп полей

Создание группы полей

Поля могут быть объединены в группы для наглядности структуры документов, а также для создания повторяющихся групп полей. Например, город, улица и номер дома могут быть объединены в группу "Домашний адрес". Создать поля для "Рабочего адреса" можно простым копированием группы полей "Домашний адрес".

Чтобы создать группу полей:

  1. Создайте поля, которые будут входить в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все поля, которые должны входить в группу.
  3. Поля, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы.

Если на форме есть повторяющиеся группы полей, то после создания одной группы вы можете создать несколько экземпляров группы. Все свойства полей, а также правила, заданные внутри группы, будут работать для каждого экземпляра группы. См. Поля с несколькими экземплярами.

Вы также можете копировать группу полей, но в этом случае результатом копирования будет создание еще одной независимой группы.


Создание таблицы

ABBYY FlexiCapture позволяет создавать определения документов, содержащих таблицы. Создание полей типа Таблица существенно облегчает настройку, извлечение данных и экспорт данных из таблиц. Поле Таблица представляет собой набор из столбцов одного типа и повторяющихся строк.

Столбцы таблицы могут относится к одному из типов:

  • текст
  • метки
  • штрих-коды
  • картинки

Чтобы создать таблицу:

  1. Выберите инструмент [image] и обведите прямоугольником область таблицы. Шапка таблицы не должна быть включена в обведенную область. На панели появится дополнительный инструмент для удаления разделителя:
    Удаление разделителя
  2. Разметьте ячейки таблицы, создав нужное количество разделителей. Для создания вертикальных разделителей поместите курсор в нужное место таблицы таблицы, нажмите клавишу Shift и зафиксируйте его там щелчком мыши. Горизонтальные разделители создаются аналогично при нажатой клавише Alt. Также можно осуществить автоматический поиск разделителей. Для этого выделите созданную таблицу и воспользуйтесь пунктами локального меню: Найти вертикальные разделители и Найти горизонтальные разделители.
  3. Создайте столбцы таблицы. Чтобы создать столбец, щелкните в области столбца и выберите тип столбца из выпадающего списка.


Настройка отображения данных в окне документа

После того как данные будут распознаны, пользователь увидит их в окне документа. По умолчанию данные расположены по порядку, подписи к ним соответствуют названиям полей определения документа. Однако можно изменить представление данных, расположив их удобным для пользователя образом или изменив названия элементов.

Настройку отображения данных осуществляет Администратор станции на форме данных в редакторе определения документа.

Чтобы изменить представление распознанных данных:

  • откройте редактор определения документа;
  • включите отображение формы данных (Вид > Форма данных или Alt + F2);
  • с помощью команд контекстного меню настройте форму данных по своему усмотрению.
    Более подробное описание см. в разделе Пользовательские настройки отображения данных.

Чтобы восстановить вид формы по умолчанию, выберите соответствующий пункт контекстного меню. Все изменения пользователя при этом будут утеряны.

Свойства элементов формы

Каждый из элементов формы обладает набором свойств. Этот набор зависит от типа элемента. Ниже приводится описание свойств, которые являются общими для элементов всех типов, а также свойства групп и текстовых меток.

Чтобы просмотреть свойства определенного элемента, выберите пункт Свойства в контекстном меню или дважды щелкните левой кнопкой мыши по элементу.

Общие свойства, вкладка Расположение:

  • Выравнивание — выравнивание элемента по горизонтали и вертикали.
    Выравнивание задаётся с помощью команд контекстного меню или в свойствах элемента.
  • Отступы — расстояние от элемента до границ его ячейки, измеряется в пунктах. Если пользователь задал нулевое значение, устанавливается минимально возможный отступ, при котором элементы не пересекаются.
    Величину отступов можно задать одним из следующих способов: с помощью команд контекстного меню, в свойствах элемента, при перемещении элемента в пределах его ячейки, при смещении правой или нижней границы ячейки вплотную к элементу.
  • Установить минимальный размер — минимальная ширина и высота элемента. Если минимальный размер не задан, то он вычисляется автоматически.
    Значение минимальной ширины и высоты можно задать в свойствах элемента, а также при изменении границы элемента с помощью мыши. Чтобы восстановить размер элемента по умолчанию, выберите соответствующую команду контекстного меню.

    На форме данных границы и отступы элементов, для которых минимальный размер вычисляется автоматически, выделяются зелёным цветом, для элементов с заданным минимальным размером — красным.

Свойства текстовых меток, вкладка Формат:

  • Текст — значение текстовой метки (пояснительный текст или заголовок поля).
  • Шрифт — параметры шрифта: тип, размер, начертание. По умолчанию используются тип и размер шрифта, указанные в свойствах определения документа. Для применения индивидуальных параметров шрифта необходимо отключить опцию По умолчанию.

Совет. В форме данных можно изменить подпись поля, не меняя его названия в структуре документа. Например, при работе с гибким определением документа, где невозможно изменить название поля, или для задания пользовательских названий столбцов в таблицах.

Совет. В окне документа можно добавить произвольный текст, например, пояснения. Для этого в свободном месте формы данных вызовите контекстное меню, выберите пункт Вставить текст.

Свойства групп, вкладки Формат и Экземпляры:

  • Отображение группы полей

    Для группы полей можно задать условие начального отображения в окне документа. Для этого на форме данных выберите необходимую группу полей. Далее откройте свойства группы, выберите вкладку Формат. В выпадающем списке Сворачивать группу выберите одно из значений:
    • Никогда — группа развернута. Все поля, находящиеся в группе, видны оператору при верификации. Это значение установлено по умолчанию.
    • Всегда — группа свернута. Чтобы увидеть содержимое полей группы, необходимо развернуть ее.
    • Если нет форматных ошибок — группа свернута, если содержимое полей не имеет форматных ошибок. Форматные ошибки, которые возникли после открытия документа, не влияют на текущее отображение группы полей.
    • Если все поля пустые — группа свернута, если ее поля не заполнены.
  • Показывать рамку группы — показывать ли рамку группы в окне документа.
    Для группы с экземплярами при скрытой рамке слева от экземпляра остаётся видимым элемент управления экземпляром. С помощью данного элемента управления можно удалить экземпляр, а также добавить новый экземпляр на одну позицию выше или ниже относительно выделенного.
  • Показывать приглашение 'Добавить новый экземпляр' — показывать ли ссылку-приглашение на добавление экземпляра для группы или поля с экземплярами.

С помощью вышеописанных свойств элементов вычисляется их расположение на форме данных в зависимости от выбранного разрешения монитора, масштаба формы и содержимого ячеек.

Пользовательские настройки отображения данных

Collapsed Шрифт и размер текста

По умолчанию для отображения распознанного текста используются следующие параметры шрифта: тип — Arial, размер — 10 pt. Пользователь может изменить параметры шрифта в свойствах определения документа (Определение документа > Свойства определения документа… > вкладка Форма данных).

  • Группа Текст полей данных — настройки шрифта для отображения распознанных значений.
  • Группа Текст меток — настройки шрифта для отображения пояснительного текста и заголовков полей.
Collapsed Изображение поля в окне документа

Для полей типа Текст, Штрих-код, Метка, Группа меток к распознанным данным можно добавлять изображения поля в окне документа.

Для этого в форме данных вызовите контекстное меню нужного поля, выберите пункт Добавить изображение поля.

В результате обработки в окне документа будет отображаться поле с извлеченными данными, снизу — изображение поля.

Collapsed Группировка элементов

Несколько элементов могут быть объединены в одну группу. Группу элементов можно перемещать на форме данных. С помощью команд контекстного меню можно задавать выравнивание группы, управлять отступами группы (удалять или восстанавливать значения по умолчанию). Также можно удалить или заблокировать группу.
При блокировке группы невозможно перемещать элементы группы.

Чтобы объединить элементы в группу, выделите необходимые элементы с помощью левой кнопки мыши + Ctrl, далее выберите команду Сгруппировать контекстного меню. Чтобы разгруппировать элементы, переместите их с помощью мыши за пределы группы.

Замечание. При добавлении заголовка или изображения к полю данные элементы группируются.

Collapsed Скрытие пустых столбцов таблицы

Пользователь может настроить автоматическое скрытие столбцов таблицы, которые оказались пустыми в результате распознавания.

  • на форме данных: выбрать название столбца(ов) в свойствах таблицы (свойства таблицы > вкладке Форматирование > список Укажите столбцы, которые необходимо скрывать, если они пустые);
  • в окне документа: выбрать название столбца(ов) в контекстном меню заголовка таблицы.
Collapsed Порядок обхода полей

При верификации в окне документа по умолчанию используется геометрический порядок обхода: сверху вниз, слева направо. Порядок обхода полей, выполняемый при нажатии клавиш Tab, F4, F8, можно изменить на усмотрение пользователя.

Для этого в контекстном меню формы данных выберите пункт Порядок обхода…. В открывшемся диалоге установите переключатель в положение Пользовательский. Далее задайте необходимый порядок обхода полей с помощью кнопок:

  • В начало — переместить поле в начало списка или переместить элемент группы в начало группы;
  • Выше — переместить поле вверх;
  • Ниже — переместить поле вниз;
  • В конец — переместить поле в конец списка или переместить элемент группы в конец группы;
  • Автоматический порядок — выстроить все поля аналогично порядку следования в структуре документа.

Замечание. Данная функциональность недоступна в web-станциях.

Collapsed Масштабирование изображения документа

При верификации в окне документа пользователь может менять масштаб изображения с помощью команд контекстного меню, а также с помощью мыши.

При двойном нажатии левой кнопки мыши:

  • По определенному полю на изображении масштаб изображения изменяется до 100 %, поле выделяется жёлтым цветом.
    При повторном двойном щелчке по полю устанавливается исходный масштаб.
  • По полю в области распознанных данных масштаб изображения изменяется до 200 %, поле размещается по центру страницы, выделяется жёлтым цветом.
  • В свободном месте страницы масштаб изменяется таким образом, чтобы страница полностью помещалась в области изображения. При повторении действия область под курсором мыши увеличивается до 100%.
  • В свободном месте области изображения устанавливается масштаб 25 %.

Совет. Для изменения масштаба изображения также можно использовать колесо прокрутки мыши + Ctrl.

Упорядочить расположение страниц по горизонтали или вертикали можно с помощью команды Располагать страницы по вертикали (заголовок окна Документ > контекстное меню).


Создание определений для документов с приложениями

ABBYY FlexiCapture позволяет создавать определения для документов с приложениями. Приложения – это дополнительные страницы, которые могут сопровождать каждую форму, на эти страницы не будет наложено определение документа, но они учитываются при сборке документов. Например, к заявлению на получение кредита (жесткая форма) прилагается справка с места работы, составленная в свободном стиле. Эта справка может обрабатываться как приложение.

Чтобы создать определение документа с приложением:

Первый способ:

  1. Перейдите на закладку Страницы в окне Структура документа (правая часть редактора определения документа).
  2. Включите опцию Подключить раздел приложения в документе.
  3. Введите количество или диапазон страниц приложения в появившемся квадрате справа от названия раздела.
Collapsed Показать окно структуры документа

Второй способ:
  1. Откройте диалог свойств определения документа (Определение документа > Свойства определения документа… в окне редактора определения документа);
  2. Перейдите на закладку Сборка;
  3. Отметьте опцию Допускать страницы приложений. В списке разделов появится строка Страницы приложения;
  4. Введите минимальное и максимальное количество страниц в приложении.
Collapsed Показать диалог

Для того чтобы сохранить текст приложения, нужно при настройке экспорта задать опции сохранения изображений (в диалоге Настройки экспорта). Если вы выберите формат PDF searchable для сохранения изображения, то текст будет распознан и сохранен в PDF с возможностью поиска.


Экспорт в базу данных

Чтобы настроить экспорт в базу данных, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в ODBC-совместимую базу данных в поле Type.
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, необходимо ли экспортировать изображения.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>.

    • Установите соединение с базой данных. Введите строку соединения в окно Connection string или нажмите на кнопку Установить… и задайте параметры соединения в открывшемся диалоге.
      • Collapsed Список протестированных провайдеров и драйверов

      Для БД SQL 2000, 2005, 2008, 2008R2, 2012:

      1. Провайдер - OLE DB Provider for ODBC Drivers;

        Замечание. При выборе OLE DB Provider for SQL Server могут возникнуть проблемы при работе с некоторыми типами данных, при работе с длинными полями.

      2. Драйвер - SQL Server.

      Для БД Access 2003, 2007, 2010:

      1. Провайдер - OLE DB Provider for ODBC Drivers;
      2. Драйвер - Microsoft Access Driver (Driver do Microsoft Access или Microsoft Access-Treiber).

      Для БД Oracle 9g, 10g, 11g

      1. Провайдер - Oracle Provider for OLE DB;
      2. Драйвер выбирать не требуется.

      Провайдер и драйвер должны быть доступны на компьютере, на котором выполняется экспорт.

    • Выберите схему из выпадающего списка.
    • Вы можете проверить соединение с базой данных, нажав на кнопку Тестировать.
    • Нажмите кнопку Создать таблицы автоматически для того, чтобы в базе данных были автоматически созданы новые таблицы для экспорта данных из документов. Для каждого раздела документа будет создана отдельная таблица. Структура и формат полей автоматически созданных таблиц соответствуют набору полей определения документа и их типам данных.

      Замечание. Перед экспортом ABBYY FlexiCapture запрашивает в базе данных информацию обо всех объектах схемы. Рекомендуется использовать для экспорта схемы с небольшим количеством объектов. В противном случае создание таблиц может занимать значительное время (до нескольких часов).

    • Если необходимо экспортировать данные в существующие таблицы базы данных, то установите соответствие полей определения документа столбцам таблиц базы данных с помощью кнопки Соответствие полей…
    • В диалоге Соответствие полей нужно определить, в какие таблицы и столбцы таблиц базы данных будут экспортироваться значения полей определения документа.
      Collapsed Подробнее...

      В диалоге Соответствие полей слева расположены разделы и поля документа, в правой части им нужно поставить в соответствие таблицы и поля базы данных. Если в базе данных уже есть таблицы для экспорта данных, то в диалоге Соответствие полей выберите таблицу базы данных для каждого раздела и столбец таблицы базы данных для каждого поля документа. (Помимо прямого экспорта данных в таблицы баз данных существует возможность сохранять данные в базу данных посредством хранимых процедур. См. подробнее Особенности настройки экспорта данных с использованием хранимых процедур баз данных)

      Если в базе данных нет таблиц для экспорта, можно создать таблицы базы данных автоматически, для этого надо нажать на кнопку Создать таблицы автоматически. При ее нажатии создаются таблицы именно той структуры, которые нам нужны для экспорта. Полям документа будут поставлены в соответствие столбцы таблиц.

      Группы полей, поля с несколькими экземплярами, таблицы документа экспортируются в отдельные таблицы базы данных. Для связи между главной и подчиненными таблицами используются первичный ключ (Primary key) и внешний ключ (Foreign key). В главной таблице к каждой записи добавляется первичный ключ, а в подчиненной таблице к каждой записи добавляется внешний ключ, в который записывается значение первичного ключа той записи из главной таблицы, к которой относится данная запись. Первичный и внешний ключи добавляются автоматически, где необходимо. Нужно только указать, в какое поле ключ должен быть проэкспортирован.

      Выберите столбец таблицы базы данных для каждого поля документа.

      Если в таблице отсутствует столбец для экспорта данных какого-либо поля, то его можно добавить автоматически в существующую таблицу. Для этого достаточно оставить соответствие поля документа полю базы данных с аналогичным названием и с комментарием (авто) в скобках или нажать кнопку Авто, предварительно выделив мышью требуемое поле. Также с помощью кнопки Авто можно создать новую таблицу в базе данных с названием аналогичным названию раздела или таблицы определения документа.

      Если в диалоге настройки соответствия полей требуется создать новую таблицу с именем и названиями столбцов, отличными от имен полей определения документа, то воспользуйтесь кнопкой Новый для создания таблицы и каждого из полей.

      Кнопками Вверх и Вниз можно управлять порядком следования столбцов в автоматически создаваемой таблице базы данных.

      С помощью кнопки Формат… можно настроить параметры сохранения типизированных полей, например, количество десятичных знаков в значении поля типа Число или формат и разделители для поля типа Дата.

      Замечание. При экспорте поля с типом данных Time соответствующий столбец таблицы в базе данных должен иметь тип DateTime. По умолчанию столбец создается с типом SmallDateTime, что приводит к возникновению ошибки.

  7. Если необходимо сохранять изображения (изображения документов и/или изображения полей типа Картинка), укажите параметры сохранения и нажмите кнопку Далее>.
    • Укажите, где именно необходимо сохранять изображения - в базе данных или в виде файлов.
    • При сохранении изображений в файлы укажите папку, формат имени файлов (окно вызывается с помощью кнопки Правка…) и признак перезаписи файлов при совпадении названий. Подробнее см. Критерии формирования имен файлов экспорта.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.

    Замечание. В зависимости от выбранной опции содержимое полей типа Картинка и изображения документов можно экспортировать в файловую систему или базу данных. При экспорте в отдельные файлы имя и путь к файлу картинки\изображения сохраняются в базе данных в соответствующем поле (настраивается при установке соответствия полей). Если в качестве пути к папке экспорта (для изображений, картинок и т.д.) указывается сетевой диск, убедитесь, что станции обработки, работающие с проектом, имеют к нему доступ. При экспорте изображений и картинок в базу данных изображения сохраняются в бинарном виде в поля формата BLOB (Binary Large OBject). С помощью специальной процедуры из любой базы данных можно преобразовать бинарное изображение в файл.

    Замечание. При экспорте изображений в отдельные файлы длина строки, хранящей пути к файлам, может превысить 255 символов, и возникнет сообщение об ошибке. В этом случае требуется увеличить ограничение на длину строки для данного столбца.

  8. Если была выбрана опция сохранения изображений, то укажите формат файлов изображений и нажмите кнопку Далее>.

    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
      • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска поиск осуществляется по всему тексту документа: текстовый слой формируется как из проверенных на верификации значений полей, так и из областей документа за пределами этих полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.

  9. Введите имя профиля экспорта и нажмите кнопку Закончить.

Замечание.

  1. Картинки экспортируются в отдельные файлы. Имя и путь к файлу картинки можно хранить в базе данных в соответствующем поле (настраивается при установке соответствия полей).
  2. Если в качестве пути к папке экспорта (для изображений, картинок и т.д.) указывается сетевой диск, убедитесь, что станции обработки, работающие с проектом, имеют к нему доступ.

Особенности настройки экспорта данных с использованием хранимых процедур баз данных

Помимо прямого экспорта данных в таблицы баз данных существует возможность сохранять данные в базу данных посредством хранимых процедур.

Хранимая процедура — объект базы данных, представляющий собой набор SQL-инструкций, который компилируется один раз и хранится на сервере. В хранимых процедурах могут производиться числовые вычисления и операции над символьными данными, результаты которых могут присваиваться переменным и параметрам, а также выполняться стандартные операции с базами данных.

Преимущества использования хранимых процедур над прямым экспортом в таблицы баз данных:

  • Быстродействие работы с базой данных
  • Возможность использовать дополнительные вычисления
  • Обеспечение целостности данных

Пример хранимой процедуры для MS SQL:

Create procedure Export( @userId as int, @lastName as nvarchar(255), @firstName as nvarchar(255) ) as begin if Exists( Select Id from Users where Id = @userId ) begin Update Users set LastName = @lastName, FirstName=@firstName where Id = @userId end else begin Insert into Users ( Id, LastName, FirstName ) values( @userId, @lastName, @firstName ) end end

При экспорте данных из FlexiCapture в базу данных посредством данной процедуры выполняются следующие действия:

На вход процедуре передаются 3 параметра (3 поля документа FlexiCapture): идентификатор (UserId), имя (FirstName), фамилия (LastName). Если в таблице базы данных (Users) нет записи с таким идентификатором, то в таблицу добавляется новая запись. Если запись с таким идентификатором присутствует, то в данной записи данные об имени и фамилии заменяются новыми значениями (значения полей из FlexiCapture).

Настройка экспорта с использованием хранимых процедур

Для того чтобы настроить экспорт данных с помощью хранимых процедур, необходимо вначале установить подключение к базе данных (см. выше). Далее нажмите кнопку Установить соответствие… для определения соответствия полей документа параметрам хранимой процедуры.

В диалоге соответствия полей из списка таблиц и хранимых процедур базы данных выберите в качестве приемника для сохранения данных требуемую хранимую процедуру.

В отличие от настройки экспорта напрямую в столбцы таблицы базы данных, в качестве полей для экспорта предлагаются параметры хранимой процедуры. Параметры процедуры являются типизированными. Для установки соответствия необходимо, чтобы тип параметра совпадал с типом данных поля определения документа.

Установите соответствие полей документа параметрам хранимой процедуры базы данных.

Замечание. Если необходимо экспортировать из документа не только отдельные поля, но и таблицы, сложные поля (например, поля с несколькими экземплярами), то требуется настроить корректные индексы для связи дочерних записей с основной записью данных документа. В качестве экспортируемого первичного ключа (ROW_INDEX) необходимо указать возвращаемое значение (@RETURN_VALUE), либо выходной (output) параметр хранимой процедуры. Таким образом, при экспорте данных процедура будет записывать данные в таблицу базы данных и возвращать идентификатор текущей записи, который будет передаваться в хранимую процедуру для экспорта дочерних записей.


Экспорт данных в файл

Чтобы настроить экспорт в файл, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в файлы данных в поле Тип .
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, необходимо ли экспортировать изображения документа.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>. Настраиваемые параметры экспорта зависят от значения, выбранного в поле Цель.

    Collapsed Воссоздать структуру подпапок Горячей Папки

    При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.

    Collapsed Экспортировать все в один файл

    При выборе данного значения все данные будут экспортированы в один файл. При настройке такого экспорта необходимо указать в поле Имя файла путь и название файла, в который будут экспортироваться данные.

    Collapsed Экспортировать каждый документ в отдельный файл

    При выборе данного значения каждый документ будет экспортирован в отдельный файл:

    • Укажите путь и первые символы названия файла в поле Префикс файла.
    • Для того, чтобы каждый пакет экспортировался в отдельную папку, отметьте опцию Создавать отдельную папку для каждого пакета.
    Collapsed Экспортировать с заданным шаблоном имени файла

    При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.

    • Укажите корневой путь экспорта в полеКорень экспорта.
    • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
    • Выберите в поле При совпадении действие, которое необходимо выполнять, если файл со сформированным именем уже существует.

    Путь экспорта указывается относительно корневого пути, заданного в свойствах проекта. Таким образом, требуется указать только название подпапки, в которую будут сохраняться файлы. Если в качестве пути экспорта требуется использовать путь, отличный от корневого пути в свойствах проекта, путь экспорта должен быть указан в формате UNC (\\computer_name\share_name[\path]). Убедитесь, что все станции, осуществляющие экспорт, имеют доступ к указанному пути.
    В загруженном на сервер проекте будут возникать ошибки экспорта, если путь указан в формате <disk:>\[path].

  7. Выберите тип файла (поддерживаются форматы CSV, DBF, TXT, XLS, XML), задайте дополнительные свойства экспорта для выбранного типа файла и при необходимости кодировку текста, соот. Затем нажмите кнопку Далее>.

    Collapsed Microsoft Office Excel workbook (*.xls)
    • Выберите версию Excel (5.0/95; 97-2003; 97-2003 (совместимость с 5,0/95));
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все данные будут экспортироваться с типом General;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Для версии Excel 5.0/95 выберите кодовую страницу.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    Collapsed XML Document (*.xml)
    • Отметьте, какие дополнительные данные хотите экспортировать (расположение полей, тип полей, ошибки, данные о качестве распознавания);
    • При отмеченной опции Сохранять тип значения при экспорте сохраняется xml-схема, в которой описаны типы полей;
    • Выберите кодировку.
    • При необходимости настройте наименования полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей.
    Collapsed Comma-sepatated values file (*.csv)
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    Collapsed Text file (*.txt)
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    Collapsed DBase file (*.dbf)
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все поля будут текстовыми;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • При необходимости настройте наименования полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей.

    8. Шаги 8, 9 выполняются, если в п. 4 пользователь выбрал опцию Экспортировать изображения документа.

  8. Укажите параметры сохранения изображений и нажмите кнопку Далее>.
    • Укажите, сохранять ли изображения вместе с данными или выберите папку для сохранения изображений.
    • Выберите способ именования файлов изображений: так же, как и файлов данных, либо по-другому. Подробнее см. Критерии формирования имен файлов экспорта.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.
  9. Укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска поиск осуществляется по всему тексту документа: текстовый слой формируется как из проверенных на верификации значений полей, так и из областей документа за пределами этих полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
  10. Введите имя профиля экспорта и нажмите кнопку Finish.

Результатом экспорта будет файл или файлы выбранного формата, содержащий значения всех полей документов.

Замечание. Повторяющиеся поля, то есть поля с несколькими экземплярами и таблицы, экспортируются в отдельные файлы. Для них создается папка, имя которой совпадает с именем файла экспорта. Можно отключить экспорт повторяющихся полей в отдельные файлы, сняв галочку Создавать отдельные файлы для повторяющихся элементов на закладке Формат (доступна для файлов всех форматов, кроме XML). Тогда повторяющиеся поля будут экспортироваться в общий файл экспорта и для каждого экземпляра элемента будет добавлена новая строка.

Замечание. При экспорте в файл данных для проэкспортированных изображений (изображения страниц или поля-картинки) указывается путь к ним: относительный - если изображение сохраняется в той же папке (или её подпапках), что и файл данных; абсолютный - во всех остальных случаях.


Критерии формирования имен файлов экспорта

Имена файлов и пути к ним при экспорте формируются автоматически на основании критериев, заданных пользователем. Настроить можно как имена файлов данных, так и имена файлов с изображениями.

Замечание. Задать шаблон имени для файлов данных можно при экспорте в файлы, для изображений – при экспорте в файлы, в ODBC-совместимую базу данных, в Sharepoint, в файлы изображений.

Настройка формирования имен и путей к файлам экспорта выполняется в окне Назначение и шаблон именования файлов. В зависимости от выбранного варианта экспорта переход в данное окно осуществляется с помощью кнопок Настроить… (слева от поля с шаблоном имени файла) или Задать имена файлов…

Возможны два вида формирования шаблона для файлов экспорта, выбираемых в поле Вид:

Collapsed Обычный

В данном виде можно выбрать дополнительный путь (за исключением настройки экспорта изображений совместно с экспортом данных в файл), значимую часть имени файла и добавить к ней при необходимости дополнительные идентификаторы.

Для указания дополнительного пути отметьте опцию Использовать дополнительный путь и выберите способ указания дополнительного пути: аналогично структуре горячей папки (пункт Путь к источнику относительно корневого каталога Горячей папки) или по имени пакета (пункт Название пакета).

В качестве значимой части имени файла может использоваться

  • Имя оригинального файла изображений, которое определяется следующим образом:
    • При добавлении файлов из папки используются имена исходных файлов;
    • При добавлении нескольких файлов будет использоваться имя первого добавленного файла;
    • Для файлов, отсканированных на Станции сканирования, используется имя источника сканирования. При этом выходной файл создается с именем {Empty Value};
    • Для файлов, отсканированных на Станции настройки проекта, используются имена временных файлов.
  • Имя определения документа;
  • Заданное имя - сочетание символов, указанное пользователем.

В качестве дополнительных идентификаторов могут использоваться

  • Идентификатор документа (отметьте опцию Добавлять к имени уникальный индекс документа);
  • Значение индексного поля (отметьте опцию Добавлять к имени значение индексного поля, нажмите кнопку … и выберите индексное поле в окне Выбор полей).
Collapsed Расширенный

В данном виде шаблон имени файла вводится в виде текстовой строки в поле Шаблон имени файла. Шаблон может содержать неизменную часть и теги, вместо которых будет подставляться информация для конкретных файлов. Теги можно вводить с клавиатуры, либо добавлять и удалять с помощью кнопок Добавить тег... и Удалить тег соответственно.

Для корректного формирования имен файлов экспорта нужно задать критерии таким образом, чтобы имена не оказались пустыми. Если имена файлов могут оказаться пустыми, программа выдаст предупреждение об этом.

Замечание. В именовании файлов изображений документов, которые необходимо экспортировать вместе с данными, можно использовать ту же схему, что и для данных. Для этого в разделе Настройки экспорта изображений отметьте опцию Аналогично настройкам для данных (диалог Назначение и шаблон именования файлов).


Экспорт изображений в файлы

Чтобы настроить экспорт изображений в файл, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в файлы изображений в поле Type.
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.
  5. Укажите параметры экспорта и нажмите кнопку Далее>. При необходимости выберите поля, которые необходимо скрывать при экспорте. Настраиваемые параметры экспорта зависят от значения, выбранного в поле Цель.
      Collapsed Воссоздать структуру подпапок Горячей Папки

      При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.

      Collapsed Экспортировать каждый документ в отдельный файл

      При выборе данного значения каждый документ будет экспортирован в отдельный файл:

      • Укажите путь и первые символы названия файла в поле Префикс файла.
      • Для того, чтобы каждый пакет экспортировался в отдельную папку, отметьте опцию Создавать отдельную папку для каждого пакета.
      Collapsed Экспортировать с заданным шаблоном имени файла

      При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.

      • Укажите корневой путь экспорта в полеКорень экспорта.
      • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
      • Выберите в поле При совпадении действие, которое необходимо выполнять, если файл со сформированным именем уже существует.
  6. Укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска поиск осуществляется по всему тексту документа: текстовый слой формируется как из проверенных на верификации значений полей, так и из областей документа за пределами этих полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
      Отметьте опцию Использовать MRC (Mixed Raster Content), если вы хотите получить более высокую скорость распознавания и малый размер конечных файлов. При использовании этой опции поля, для которых выбран режим Не распознавать, могут экспортироваться с ухудшением качества.
  7. Введите имя профиля экспорта и нажмите кнопку Завершить.


Настройка экспорта данных

Настройка экспорта данных, полученных в ходе обработки документов, осуществляется в окне редактора определения документа, пункт меню Определение документа > Настройки экспорта…

В рамках одного определения документа можно указать несколько вариантов (профилей) экспорта. То есть, полученные результаты обработки могут быть проэкспортированы в нескольких форматах файлов, а также в различные места назначения.

Основные параметры экспорта. Типы экспорта

На закладке Экспорт в списке профилей экспорта отображаются настроенные варианты экспорта с указанием следующей информации:

  • Имя – наименование профиля экспорта;
  • Тип – тип экспорта. Возможен экспорт следующих типов:
    • Пользовательский экспорт (описывается с помощью скрипта);
    • Экспорт данных в файл заданного формата (по умолчанию в каждом определении документа создается профиль экспорта, сохраняющий данные в таблицу Excel );
    • Экспорт изображений в файлы;
    • Экспорт в базу данных;
    • Экспорт в библиотеку документов MS SharePoint.
  • Обязательно – при активированной опции профиль экспорта является обязательным для выполнения, при деактивированной опции – необязательным.

    Так, если экспорт не был выполнен для профиля экспорта, помеченного как Обязательный, то в журнале событий будет содержаться сообщение об ошибке экспорта, а заданию экспорта будет присвоен статус Failed. Если же экспорт не был выполнен для профиля экспорта, который не был помечен в качестве обязательного, то задание завершится с предупреждениями об ошибке экспорта по одному из профилей, при этом заданию экспорта будет присвоен статус Succeeded.

    Замечание. Причинами невыполнения экспорта могут служить, например, отсутствие доступа к файлу или ошибка подключения к базе данных.

  • Включен - при активированной опции экспорт по данному профилю выполняться будет, при деактивированной опции – не будет.
  • Условия – условия выполнения экспорта.

Настройка условий выполнения экспорта

В ABBYY FlexiCapture реализована возможность выполнения экспорта в зависимости от ошибок правил, а также в зависимости от значения какого-либо поля. Данные настройки производятся в группе Экспортировать, если выполняются условия.

Для того чтобы задать условие выполнения экспорта в зависимости от ошибок правил, в выпадающем списке Условие для документов выберите одно из следующих условий:

  • Не содержат ошибки – будет выполнен экспорт только тех документов, которые не содержат ошибок правил, а также ошибок форматных проверок;
  • Содержат ошибки – будет выполнен экспорт только тех документов, которые содержат ошибки правил или ошибки форматных проверок;
  • Отсутствует (ошибки не имеют значения) – будет выполнен экспорт всех документов, вне зависимости от наличия ошибок правил.

Для того чтобы задать условия выполнения экспорта в зависимости от значения какого-либо поля, выберите опцию Условие для поля.

Далее в диалоговом окне Условия экспорта выполните следующие действия:

  1. Выберите поле.
  2. В выпадающем списке укажите условие выполнения экспорта.
  3. Добавьте элементы множества возможных значений поля (при необходимости).

Возможны следующие условия выполнения экспорта в зависимости от значения поля:

  • Принадлежит множеству - экспорт будет выполнен, если значение поля совпадает с одним из значений введенного множества;
  • Не принадлежит множеству - экспорт будет выполнен, если значение поля не совпадает ни с одним из элементов множества;
  • Не указано - экспорт будет выполнен, если значение поля пустое;
  • Указано - экспорт будет выполнен, если значение поля не пустое.

Для того чтобы добавить элемент множества возможных значений поля, нужно ввести его значение в поле и нажать кнопку Добавить. Для того чтобы удалить элемент, необходимо выделить его и нажать кнопку Удалить. Во множество значений может быть добавлено пустое значение. Для этого нужно нажать кнопку Добавить при пустом текстовом поле – в окно элементов добавится значение <Пустое значение>. Каждый элемент может быть добавлен только один раз.

При задании условий выполнения экспорта могут быть использованы только текстовые поля (в том числе поля с продолжением), штрих-коды и столбцы таблицы. Недопустимы метки, группы меток, повторяющиеся поля, изображения, а также ячейки таблицы.

Замечание. Если в условии запуска экспорта указать столбец таблицы, то экспорт будет выполнен при выполнении условия в любой ячейке столбца.

Таким образом, при настройке условий выполнения экспорта можно предопределить место хранения обработанных документов. Например, по значению какого-либо поля (например, Филиал) распределять документы в различные папки, а документы с ошибками правил экспортировать в заданную папку (например, С ошибками).

Тонкая настройка экспорта

Множество экспортируемых полей формируется, в первую очередь, в свойствах поля (опция Экспортировать значение поля). Далее при настройке определенного типа экспорта можно отключить экспорт любого поля из уже сформированного множества. Таким образом можно распределить экспорт полей из единого множества в различные места назначения. Данная настройка осуществляется в диалоговом окне Настройка соответствия полей настроек профиля экспорта. (Экспорт > кнопка Изменить... > кнопка Настроить... > кнопка Настройка соответствия полей…).

Замечание. При экспорте результатов в файлы графических форматов (в т.ч. pdf) доступна опция Удалять конфиденциальную информацию, которая позволяет дополнительно удалять изображения полей, содержимое которых должно быть скрыто. Данная настройка осуществляется в диалоговом окне Выберите конфиденциальные поля Экспорт > кнопка Изменить... > опция Удалять конфиденциальную информацию > кнопка Выбрать поля для удаления…)

Автоматический экспорт

Возможность автоматического экспорта (для версии FlexiCapture Standalone) настраивается на закладке Экспорт окна свойств определения документа. Чтобы документы, готовые к экспорту, могли экспортироваться автоматически (без нажатия оператором кнопки, инициализирующей экспорт), выберите опцию Разрешить автоматический экспорт.

Автоматический экспорт работает только в случае, если количество страниц в определении документа задано явно. Таким образом, если страницы в разделе могут повторяться либо число разделов задано интервалом (в т. ч. 0-1)автоматический экспорт не работает. Также автоматический экспорт не будет выполнен для документа, который попал на верификацию.

Замечание. Если документы экспортируются автоматически, проверка целостности пакета не выполняется и в лог задания записывается предупреждение.

Сохранение результатов в файловой системе

При задании вариантов экспорта можно указать сохранение распознанных данных и/или изображений документов в файловую систему. При использовании абсолютного пути к папке хранения данных можно указать локальный или сетевой путь (в формате UNC).

Если в настройках экспорта указывается относительный путь к приемнику, т.е. название подпапки, в которую требуется сохранять файлы, без указания полного пути, то по умолчанию данная подпапка будет создана в подпапке Экспорт папки проекта. Для того чтобы указать путь хранения файлов, отличный от папки по умолчанию, задайте Корневой путь экспорта в свойствах проекта. Все новые подпапки для хранения данных будут создаваться относительно корневого пути. Корневой путь может быть локальным или указывать сетевую папку (в формате UNC).

Экспорт в файл
Экспорт изображений в файлы
Экспорт в базу данных
Экспорт в SharePoint
Экспорт, описанный с помощью скрипта


Экспорт картинок

Для каждой картинки в определении документа можно настроить параметры экспорта, такие как тип файла, качество, цвет и разрешение. Эти параметры задаются на закладке Экспорт диалога задания свойств поля (пункт Свойства… локального меню поля). Можно задать:

  • Тип файла (TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits, PNG).
  • Качество. Для файлов формата TIFF, JPEG или JPEG2000 можно выбрать качество экспортируемого файла (наилучшее, высокое, обычное, низкое).
  • Тип цвета - цветной, градации серого, полутона (ч/б).

Чтобы установить разрешение экспортируемой картинки, отметьте опцию Установить разрешение равным и выберите нужное значение разрешения из списка или введите его вручную.

Имя файла, в который будет сохранена картинка, формируется автоматически на основании критериев, заданных пользователем. Для того чтобы задать параметры нажмите кнопку Изменить… и в открывшемся диалоге Имя файла экспорта выберите необходимые опции. Подробнее см. Критерии формирования имен файлов экспорта.


Экспорт, описанный с помощью скрипта

Чтобы настроить экспорт с помощью скрипта:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить…
  3. Выберите значение Пользовательский экспорт (скрипт) в поле Тип.
  4. Укажите, является ли экспорт обязательным.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.
  6. Выберите язык скрипта.
  7. Введите текст скрипта в окне редактора, которое появляется при нажатии на кнопку Правка скрипта…. Затем нажмите кнопку Далее>.
  8. Введите имя профиля экспорта и нажмите кнопку Завершить.

Подробнее о параметрах скрипта см. Скрипт экспорта.


Экспорт данных в библиотеку документов SharePoint

Программа ABBYY FlexiCapture позволяет настроить экспорт документов в библиотеку документов Microsoftтм SharePont. В результате можно получить библиотеку изображений документов, а дополнительные колонки для каждого документа будут заполнены значениями определенных полей.

Замечание.

  1. ABBYY FlexiCapture поддерживает следующие версии Microsoftтм SharePont: MS SharePoint 2003, MS SharePoint 2007, MS SharePoint 2010 и MS SharePoint 2013.
  2. Для настройки экспорта в SharePoint необходимо иметь права администратора, для осуществления экспорта достаточно прав участника (contributor).
  3. Колонки в SharePoint, в которые планируется записывать данные, должны иметь тип Однострочный текст или Многострочный текст (дополнительно см. Преобразование типов данных в SharePoint2013).
  4. В настройках Internet Information Server (IIS) для сайта SharePoint должна быть отмечена опция Enable Kernel-mode authentication.
    Collapsed Показать скриншот

    Если данный режим отключен, то при экспорте появится следующее сообщение об ошибке: "Cannot connect to SharePoint server: Unauthorized access to SharePoint server".

Чтобы настроить экспорт в SharePoint, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить…
  3. Выберите значение Экспорт в SharePoint в поле Тип.
  4. Укажите, является ли экспорт обязательным.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>.

    • URL сервера (например, http://myserver) – введите адрес сервера, где находятся ваши библиотеки SharePoint. C помощью кнопки Настройки соединения… можно настроить параметры аутентификации (по умолчанию используются параметры аутентификации для входа в Windows) и настройки Proxy, если это необходимо.
    • Ниже отображается состояние соединения, если соединения нет, его можно восстановить с помощью кнопки Соединение.
    • После соединения с сервером SharePoint выберите библиотеку из списка Выберите библиотеку SharePoint.
    • Нажмите кнопку Обзор… и укажите папку в библиотеке.
    • Выберите тип содержимого для документов в поле Тип содержимого (поддержано начиная с SharePoint 2007). В этом случае экспорт значений можно будет настроить в поля, относящиеся к выбранному типу содержания.

      Замечание. Тип содержимого - список типов содержимого, заданных пользователем в SharePoint. Поля SharePoint, доступные для маппинга, зависят от выбранного типа содержимого.

    • Далее нужно настроить, какие поля определения документа будут экспортироваться и куда. Для этого нажмите на кнопку Соответствие полей… и произведите необходимые настройки в открывшемся диалоге Соответствие полей. В этом диалоге нужно поставить в соответствие полям определения документа колонки документов в SharePoint. Поля определения документа отображаются слева. Для каждого экспортируемого поля определения (кроме групп и таблиц) можно выбрать еще не занятую колонку в SharePoint.
  7. Если необходимо сохранять изображения, укажите параметры сохранения изображений и нажмите кнопку Далее>.
    • При сохранении изображений в файлы укажите папку, формат имени файлов (окно вызывается с помощью кнопки Правка…) и признак перезаписи файлов при совпадении названий.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.
  8. Если необходимо сохранять изображения, укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска поиск осуществляется по всему тексту документа: текстовый слой формируется как из проверенных на верификации значений полей, так и из областей документа за пределами этих полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
  9. Введите имя профиля экспорта и нажмите кнопку Завершить.

В результате экспорта документы будут сохранены в библиотеке SharePoint. Каждому документу будут соответствовать колонки со значениями из определенных полей документа. Эти значения можно использовать для поиска и индексации документов.

Collapsed Преобразование типов данных в SharePoint2013

При экспорте данных в SharePoint2013 возможно преобразование данных текущего типа в данные одного из следующих типов:

  • Однострочный текст;
  • Многострочный текст;
  • Число;
  • Денежное значение;
  • Дата и время;
  • Да/Нет.

При этом, тип данных ячейки может быть преобразован в один из совместимых типов, например:

  • Дата преобразуется в тип данных Дата и время или Текст;
  • Метка преобразуется в тип данных Да/Нет или Текст.

Проэкспортированные, но не поддерживаемые типы данных, будут недоступны (выделены серым цветом).


Штрих-код

При создании поля штрих-кода ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это зависит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения определения документа или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства поля, см. также реперный штрих-код.

Основные свойства
Свойства распознавания
Свойства верификации
Проверка с помощью правил


Метки

Внимание! Свойства меток, объединенных в группы, задаются сразу для всей группы меток. При попытке редактирования свойств метки, входящей в группу, откроется диалог редактирования свойств группы.

При создании поля метки ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Группы меток

Внимание! Свойства группы распространяются на все метки, входящие в группу меток.

Значение группы меток представляет собой список имен выбранных меток, разделенных точкой с запятой (;). Если ни одна метка не выбрана, то значение группы меток - пустая строка.

При создании группы меток, ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Группа полей

При создании группы полей ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств

Основные свойства
Поля
Проверка с помощью правил


Картинки

При создании картинки ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из четырех закладок, на каждой из которых редактируется определенная группа свойств.

Основные свойства
Свойства распознавания
Экспорт
Проверка с помощью правил


Свойства полей

Очень важно правильно задать свойства каждого поля. Свойства полей влияют на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку. Некоторые свойства очень важны для распознавания данных, например, способ разметки для текстового поля ввода: если он задан неправильно, то разметка, не исчезающая при сканировании, не будет отделена от символов и результат распознавания может быть неудовлетворительным.

Поле каждого типа имеет свой набор свойств. Когда вы «нарисовали» на изображении поле определенного типа, ему присваиваются свойства по умолчанию.

Как изменить свойства поля:

  1. Выделите название поля в структуре документа или область поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства поля в открывшемся диалоге.

Подробнее о свойствах полей:

Текстовые поля ввода
Метки
Группы меток
Штрих-коды
Картинки
Таблицы
Группы полей
Служебные поля


Таблицы

При создании таблицы ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Столбцы
Проверка с помощью правил


Текстовые поля ввода

При создании текстового поля ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Типы данных
Свойства распознавания
Свойства верификации
Проверка с помощью правил
Пользовательский скрипт


Поля без разметки

Поля могут не иметь соответствующей области на изображении. Названия полей без разметки в списке помечены красной звездочкой. Такие поля могут использоваться для хранения промежуточных результатов вычислений, производимых со значениями распознаваемых полей. Например, можно объединить значения нескольких полей с помощью правила объединения значений полей, а результат сохранить в поле без разметки.

Поля без разметки обладают всеми свойствами, присущими тому типу, к которому они относятся. Значения этих полей также можно экспортировать.

Создать поле без разметки можно двумя способами:

  1. В окне редактора определения документа выберите пункт меню Правка>Создать поле и создайте поле нужного типа. Название поля появится в списке и будет помечено звездочкой. В этом случае создается поле структуры документа, но не создается его область на изображении.
  2. Второй способ заключается в удалении разметки обычного поля. Выделите нужное поле на изображении или в списке и выберите пункт локального меню Удалить область. Разметка будет удалена, а название поля будет помечено красной звездочкой.

Чтобы создать область для полей, не имеющих области на изображении, выберите [image] на панели инструментов и выделите мышью соответствующую область. Если в списке есть поля, помеченные звездочкой, то программа предложит вам выбрать название одного из таких полей.


Создание полей определения документа

Поля предназначены для извлечения информации.

Для работы с полями в редакторе определения документа нужно переключиться в режим разметки полей - по кнопке [image].

Все области на изображении, откуда предполагается извлечение информации, должны быть отмечены как поля. Данные в этих полях распознаются, их значения могут экспортироваться.

У полей есть названия, список которых отображается в окне структуры документа. Обычно, поля имеют область на изображении, но можно создать поля и без области (например, для хранения промежуточных результатов).

Предусмотрены поля следующих типов:

Поле | Кнопка на панели инструментов
Текстовое поле ввода |
Метка |
Группа меток |
Штрих-код |
Картинка |
Таблица |
Группа полей |
Регион для поля без разметки |
Нераспознаваемый блок |

Чтобы создать поле:

  1. Выберите режим разметки полей;
  2. Выберите инструмент для создания поля нужного типа;
  3. Установите курсор мыши в угол поля, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол или нажмите Shift и щелкните левой кнопкой мыши в области поля.

Область поля будет обведена прямоугольником, цвет которого зависит от типа поля.

Созданному полю по умолчанию присваивается название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля. Это название появится в списке полей на закладке Поля в окне структуры документа.

Полю присваиваются свойства по умолчанию.

  • Создание групп меток
  • Создание таблиц
  • Создание групп полей
  • Как изменить название поля
  • Копирование, перемещение, удаление полей
  • Поля без разметки
  • Свойства полей

Множественный выбор полей

При необходимости отредактировать группу полей определенного типа (типов) ABBYY FlexiCapture позволяет быстро выделить необходимые поля. Для этого выберите пункт меню Правка -> Выделить поля по типу… (или нажмите Ctrl+Shift+F). В открывшемся диалоговом окне отметьте необходимые типы полей и нажмите ОК. Чтобы выбрать все поля сразу, нажмите кнопку Выбрать все.


Поля с несколькими областями

Поле может состоять из нескольких областей на изображении, причем эти области могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле.

Несколько областей удобно создавать для полей, расположенных на нескольких страницах, например, для больших таблиц.

Collapsed Показать пример

Сортировка значений в таком поле выполняется по вертикали, то есть первым в поле будет значение из региона с самой верхней границей.

Чтобы создать поле с несколькими областями, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать продолжение области…;
  3. Переместите изображение области в нужное место на странице.


Поля с несколькими экземплярами

На формах могут встречаться повторяющиеся элементы – поля или группы полей, встречающиеся на форме несколько раз и описывающие схожие объекты, например, одни и те же сведения о нескольких сотрудниках, о детях, о счетах. Для таких объектов создаются поля с несколькими экземплярами.

Любое поле может иметь несколько экземпляров, их области могут располагаться на расстоянии друг от друга, даже на разных страницах. Экземпляры полей обладают одними и теми же свойствами. Экспортируются они в отдельные файлы или таблицы базы данных.

Несколько экземпляров можно создать для группы полей, если на форме есть повторяющиеся группы.

Collapsed Показать пример

Чтобы создать поле с несколькими экземплярами, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать экземпляр области…;
  3. Переместите изображение области в нужное место на странице.


Создание определения для обработки гибких документов

Для счетов, платежных поручений и других аналогичных документов невозможно создать определение документа с жестким расположением полей, потому что местоположение, размеры и количество полей на разных экземплярах могут не совпадать, а значит, жесткое описание не может быть наложено на все документы. На таких документах поля ищутся после предварительного распознавания всей страницы целиком, и на основе ключевых слов и взаимного расположения полей создается гибкое описание. Для разработки гибких описаний предназначен специальный компонент программы ABBYY FlexiLayout Studio (поставляется вместе с ABBYY FlexiCapture). Подробное руководство создания гибкого описания вы найдете в справке для ABBYY FlexiLayout Studio.

Гибкое описание экспортируется в .afl файл, а затем подключается в ABBYY FlexiCapture. Мы можем использовать гибкое описание для всего определения документа или в качестве одного из разделов. Гибкое описание может быть многостраничным.

Подключение гибкого описания

Гибкое описание можно подключить на этапе создания определения документа. Для этого на втором шаге Мастера создания определения документа добавьте изображение документа, а затем отметьте опцию Загрузить гибкое описание и введите путь к файлу с расширением .afl, содержащему гибкое описание.

Вы можете подключить гибкое описание и из окна Редактора определения документа, в диалоге свойств описания раздела документа.

  1. Выберите раздел документа. (Если определение документа состоит из одного раздела, то в окне Структура документа перейдите на закладку Страницы и выберите название единственного раздела.) Нажмите на правую кнопку мыши и выберите пункт локального меню Свойства…
  2. Перейдите на закладку Гибкое описание.
  3. Нажмите Загрузить…
  4. Выберите нужный .afl файл, содержащий гибкое описание.

После подключения гибкого описания геометрическая разметка полей уже будет присутствовать на изображении. Теперь нужно задать свойства полей точно так же, как и для жесткого определения документа. Определите свойства распознавания, верификации, экспорта, задайте необходимые правила.

Обновление гибких описаний

Для того чтобы обновить используемые гибкие описание, выберите пункт меню Сервис > Обновить гибкие описания…. В открывшемся окне укажите путь к гибкому описанию и нажмите Обновить.

Замечание. При импорте гибкого описания, содержащего текстовые файлы со списками возможных значений полей, данные файлы размещаются по относительным путям, указанным при создании гибкого описания. При этом относительные пути отсчитываются от файла проекта. Для редактирования данных файлов необходимо сохранить проект локально (пункт меню Проект>Экспортировать проект…), отредактировать файлы и обновить проект на сервере (пункт меню Проект>Обновление проекта…).


Задание значений идентификаторов

Идентификаторы служат для определения принадлежности страницы к той или иной форме и используется для выбора определения документа при наличии в пакете нескольких определений со сходным набором реперов. В случае одновременной обработки нескольких форм в одном потоке, программа определяет, к какой форме относится данная страница, по расположению идентификаторов.

Если в качестве идентификаторов используются реперный штрих-код или реперный текст, то можно задать значения таких идентификаторов. В этом случае при попытке наложить определение документа, программа будет сравнивать распознанные данные на изображении со значением идентификатора, и наложение определения будет возможным только при совпадении значений.

Значения идентификаторов задаются в диалоге свойств статических элементов на закладке Общие. Значение текста и штрих-кода можно ввести автоматически, для этого предусмотрена кнопка Подставить.

Замечание. Если можно однозначно идентифицировать страницу только по расположению элементов, значения задавать не нужно. Не следует без крайней необходимости пользоваться этой возможностью, т.к. задание значения идентификатора запускает модуль распознавания на этапе наложения определения документа, тем самым замедляя наложение определений на изображения.


Локализация определения документа

Локализация определения документа позволяет перевести определение документа на другие языки, отличные от языка, на котором определение документа было разработано. Оператор ABBYY FlexiCapture может выбрать язык программы при установке. Если определение документа содержит локализацию для данного языка, то при работе оператора с программой, будет использована локализованная версия определения документа.

Локализация включает в себя перевод:

  • заголовков полей, названий кнопок и надписей на форме данных
  • сообщений пользовательских скриптов (например, скриптовых правил, экспорта, обработчиков событий).

При редактировании определения документа настройщик проекта всегда работает со значениями "по умолчанию", на которые никак не влияет локализация. Однако при работе оператора в редакторе документа будет использована локализация, соответствующая языку интерфейса программы у оператора.

Процесс локализации

Работа с локализацией определения документа включает в себя следующие этапы:

  1. Выгрузка идентификаторов локализуемых строк в текстовый файл.
  2. Задание значений локализованных строк для идентификаторов сообщений.
  3. Загрузка локализации из текстового файла в определение документа.

Замечание. Локализация импортируется только в то определение документа, из которого были выгружены идентификаторы локализуемых строк.

Файл локализации

Представляет собой файл в формате *.txt, который содержит список локализуемых строк. Файл создается в диалоговом окне Настройки локализации. Строки файла сгруппированы по типу элемента (заголовки полей, название определения документа, сообщения оболочки, сообщения скрипта), внутри группы строки упорядочены по алфавиту.

Строка файла локализации:

BANK_CODE ,"Код банка"

BANK_CODE — идентификатор строки. Идентификатор уникален для поля определения документа, не зависит от заголовка поля, формируется автоматически на основании имени поля или по схеме FC_<порядковый номер поля>.

Далее после запятой в кавычках указывается значение строки, которое буде показано оператору — "Код банка". Именно это значение подлежит переводу при локализации.

Если значение строки уже было изменено, то далее после символа, открывающего комментарии — //, указывается значение строки "по умолчанию" — "Bank Code", которое видит настройщик при редактировании определения документа.

В конечном итоге строка имеет следующий вид:

BANK_CODE ,"Код банка" // "Bank Code"

Синтаксис файла локализации:

  • Идентификатор строки и ее значение разделяются запятой (,)
  • Комментарии отделяются символом //
  • Значения строк записываются в кавычках ("Имя строки")
  • Кавычка в значении ставится символами \"
  • Символ \ обозначается как \\
  • Перенос строки осуществляется символом \n.

Настройка локализации

Экспорт

  1. В главном меню редактора определения документа выберите пункт Определение документа > Локализация > Настройки локализации….
  2. Выберите из списка язык, локализацию которого необходимо выгрузить (имеет статус Не локализован). Нажмите кнопку Экспорт….
  3. В открывшемся диалоговом окне укажите путь к файлу и его имя.

Редактирование файла локализации

  1. Откройте файл в текстовом редакторе и переведите значения строк на необходимый язык.
  2. Сохраните файл в кодировке Unicode.

    Импорт

  3. В главном меню редактора определения документа выберите пункт Определение документа > Локализация > Настройки локализации….
  4. Выберите из списка язык, локализацию которого необходимо загрузить. Нажмите кнопку Импорт….
  5. В открывшемся диалоговом окне укажите путь к файлу.
  6. После загрузки статус языка изменится на Локализован.
  7. Сохраните изменения в определении документа.

После успешного импорта файла локализации текст на форме данных в редакторе определения документа будет отображаться в виде значений по умолчанию. Загруженная локализация буде использована только при работе оператора в редакторе документа. Настройщик может увидеть локализацию в режиме тестирования определения документа при использовании соответствующего локализации языка графического интерфейса программы ABBYY FlexiCapture.

Если локализованная строка длиннее строки по умолчанию, то на форме данных поля справа от нее сдвигаются.

Удаление локализации

  1. В главном меню редактора определения документа выберите пункт Определение документа > Локализация > Настройки локализации….
  2. Выберите из списка язык, локализацию которого необходимо удалить (имеет статус Локализован). Нажмите кнопку Очистить.
  3. Статус языка локализации изменится на Не локализован.

Локализация сообщений

Для локализации сообщений пользовательских скриптов (например, скриптовые правила, экспорт, обработчики событий), необходимо создать идентификатор для каждого сообщения, задать ему локализуемое значение и из кода скрипта обращаться к сообщению, используя его идентификатор.

Идентификаторы сообщений пользовательских скриптов будут выгружены в файл для локализации командой Определение документа > Локализация > Настройки локализации…. Значения строк можно локализовать в данном файле на нужный язык и загрузить стандартным образом в виде файла локализации для определения документа.

Этот механизм позволяет отображать различный текст локализации сообщений для разных языков графического интерфейса ABBYY FlexiCapture.

В главном меню редактора определения документа выберите пункт Определение документа > Локализация > Локализуемые сообщения скрипта….

В открывшемся диалоговом окне отображается список возможных сообщений об ошибках. Редактируйте сообщения с помощью кнопок Добавить…, Изменить…, Удалить.

Нажмите кнопку Добавить… / Изменить…, чтобы добавить новое сообщение или отредактировать существующее. В окне добавления/редактирования сообщения можно менять как имя сообщения, так и его значение по умолчанию.

Использование локализованных сообщений из скриптов

Для доступа к сообщению из скриптов необходимо использовать объект FCTools.LocalizedStrings, который реализует интерфейс IProperties.

Данный пример возвращает локализованное сообщение с идентификатором MY_ MESSAGE_1:

FCTools.LocalizedStrings.Get ("MY _MESSAGE_1")


Пользовательский скрипт

Пользовательский скрипт - скриптовое правило, которое выполняется не автоматически, а по запросу пользователя при просмотре поля во время контекстной верификации либо при просмотре документа в редакторе документа. Скрипт запускается с помощью кнопки … справа от значения поля либо нажатием клавиш Ctrl+Shift+A.

Пользовательский скрипт задается на закладке Пользовательский скрипт в свойствах поля. Добавление и удаление полей, информация о которых будет доступна в пользовательском скрипте, осуществляется с помощью кнопок Добавить… и Удалить соответственно. Редактирование скрипта осуществляется в окне Редактор кода скрипта, которое открывается при нажатии кнопки Правка…

Чтобы скрипт был доступен операторам, отметьте опцию Включить пользовательский скрипт.

Внимание! Пользовательский скрипт нельзя применить на Web-станции Верификации Данных.

Подробно о параметрах скрипта см. Пользовательский скрипт.


Типы данных для меток

Тип данных для меток задается на закладке Тип данных диалога задания свойств поля.

Тип данных для меток определяет значения, которые будут присвоены полю метки в случае отмеченной и неотмеченной метки. Соответствующее значение будет содержаться в результатах экспорта и в свойстве Value интерфейса ICheckmarkValue.

Выберите подходящие варианты значений метки:

  • Да / Нет – если метка отмечена, значение поля будет "Yes", не отмечена – "No".
  • 1 / 0 – если метка отмечена, значение поля будет 1, не отмечена - 0.
  • <Название метки> / Пустая строка – если метка отмечена, значение поля будет совпадать с названием метки, не отмечено – полю будет присвоено пустое значение.
  • Пользовательские значения – отметив эту опцию, вы можете ввести свои значения, Если метка выбрана – для отмеченной метки, Если метка не выбрана – для неотмеченной.


Типы данных для групп меток

Тип данных для группы меток задается на закладке Тип данных диалога задания свойств поля.

Допускать, если не выбрано ни одной метки – отметьте эту опцию, если в группе должна быть обязательно отмечена хотя бы одна метка. Тогда в случае, если ни одна метка их группы не будет отмечена, программа выдаст соответствующее предупреждение.

Допускать множественный выбор – отметьте эту опцию, если вы допускаете, что в группе будут отмечены несколько меток. Если эта опция не отмечена, то программа выдает предупреждение при наличии нескольких отмеченных метках в группе.

Ошибку при проверке считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением. Наличие предупреждений не мешает оператору отправить документы на следующий этап обработки, тогда как неисправленные форматные ошибки требуют дополнительного подтверждения отправки документов оператором.

Экспортировать как число – если данная опция отмечена, то выполняется проверка, что все метки являются числами. В случае множественного выбора сумма значений меток может быть использована как экспортируемое значение. Значение группы меток доступно из скриптов через свойство Value интерфейса IField.

На этой закладке отображается список названий меток, входящих в данную группу. Вы можете изменить названия меток группы, для этого выделите нужную строку и нажмите кнопку Правка…. В открывшемся диалоге вы можете задать название поля метки и название метки для экспорта.

Вы можете определить экспортируемые значения в случае, если не было выбрано ни одной метки и в случае, если в группе выбрано более одной метки. Для этого выберите в списке одно из значений <Не выбрано ни одного значения> или <Выбрано несколько значений…>, нажмите на кнопку Правка… и в открывшемся диалоге задайте значение в поле Название метки. Если значения для экспорта не заданы, то в случае, если ни одна метка не выбрана, экспортируется пустая строка, а в случае выбора нескольких меток экспортируются их значения через запятую. Если отмечена опция Экспортировать как число, то в случае выбора нескольких меток выполняется проверка, что все метки являются числами, и экспортируется сумма значений меток.

Создание группы меток


Типы данных текстового поля ввода

Одними из самых важных параметров текстовых полей, влияющих на качество распознавания, предварительную проверку и модификацию данных поля, являются настройки типа данных.

Тип содержимого используется программой в процессе распознавания данных текстового поля. Правильное задание содержимого поля повышает качество распознавания данных, увеличивает процент уверенности распознавания символов и, как результат, сокращает время, затрачиваемое оператором на этапе верификации данных.

Механизм задания типов содержимого очень гибок. Пользователь может выбрать тип содержимого из существующего набора типов, а также создать свои собственные типы на основе алфавита, регулярного выражения или пользовательского словаря, подходящие для решения конкретной задачи.

Тип данных для текстового поля ввода задается на вкладке Тип данных диалога задания свойств поля. Ниже приведено описание настроек в общем случае и в случае текстового поля определенного типа.

Общие настройки для текстового поля

  • Тип данных (выпадающий список) - тип содержимого поля. С помощью данного типа пользователь указывает программе, данные какого типа он ожидает увидеть в текущем поле: адрес, время, дата, денежная сумма, имя, код, текст, число.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым.

    • Значение по умолчанию также добавляется в поле, если регион поля был удален. Если же пользователь сам ввёл пустое значение, например, на этапе верификации, то значение по умолчанию подставлено не будет. При необходимости значение данной записи может быть изменено. В том случае, когда значение по умолчанию не определено, поле остается пустым, пока в него не введено значение.
    Замечание. Данная опция доступна для текстовых полей и/или текстовых колонок таблицы.

  • Опции автозамены - параметры, с помощью которых выполняется автоматическая коррекция распознанного значения поля, например, замена или удаление лишних символов, пробелов, изменение регистра символов и т.д.

    Таким образом, с помощью автозамены выполняется преобразование данных к требуемому для экспорта виду, и, как следствие, сокращается ручной труд оператора на исправление данных поля. При задании опций автозамены можно воспользоваться стандартными параметрами либо создать пользовательский скрипт для более сложного преобразования значения поля. Подробнее см. Обработка введенного значения.

  • В группе Контроль данных можно задать параметры проверки формата введенного значения, а также ограничить значения: количество символов, минимальное и максимального значений для числа, интервал даты и т.д.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
    • Collapsed Внешний источник допустимых значений

    Ограничить список возможных значений поля можно также с помощью внешнего источника - текстового файла или базы данных. Параметры проверки и ограничения значений зависят от выбранного типа содержимого поля. Несоответствие распознанных данных параметрам проверки значения приводит к возникновению форматных ошибок в окне документа на этапе верификации.

    Внешний источник допустимых значений позволяет:

    • Повысить качество распознавания поля путем предложения программе не только алфавита символов, но и списка возможных слов. Значения из данного списка используются программой в процессе распознавания. В качестве результата распознавания текстового поля предлагается вариант идентичный или наиболее близкий к какому-либо значению из загруженного списка. Если распознаваемое значение отсутствует в словаре, то для распознавания используется только алфавит. Для решения данной задачи требуется подключить пользовательский словарь в настройках типа содержимого поля.
    • Проверить уже распознанное текстовое значение по списку допустимых значений. Сразу после распознавания поля осуществляется поиск его значения среди значений списка допустимых значений (локального или из внешнего источника). Если значение не найдено, то выдается сообщение о форматной ошибке поля. Для решения данной задачи список значений требуется загрузить или подключить в настройках проверки значения поля.
  • Использовать нормализацию - параметры, с помощью которых пользователь может настроить необходимый формат выходных значений для текстовых полей типа Время, Дата, Денежная сумма, Число. По умолчанию данная опция отключена. В этом случае извлеченные данные отображаются на форме и экспортируются в том формате, в котором они были извлечены.

Настройки для текстового поля определенного типа

Collapsed Адрес

Для текстового поля типа Адрес доступны следующие настройки:

  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, задать пользовательский словарь или выбрать более узкий тип данных, например, адрес электронной почты или почтовый индекс. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае рекомендуется подключить пользовательский словарь с целью улучшения качества распознавания документов. Для этого отметьте опцию Подключить пользовательский словарь и нажмите Правка... для редактирования словаря. Пользовательский словарь можно создать, добавляя в него отдельные слова (кнопка Добавить...), или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить... и укажите путь к файлу с расширением .txt или .dic.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Также можно создать собственный пользовательский тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • В группе Контроль данных можно задать ограничение количества символов, ограничение содержимого. Подробнее см. Ограничение области значений для текстового типа данных.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
Collapsed Время

Для текстового поля типа Время доступны следующие настройки:

  • Опция Рассматривать значение как текст. Обрабатывать значение поля как текст. Рекомендуется использовать в случае, если время невозможно привести к стандартному формату или нет необходимости работать со значением как с датой. Для проверки значения может использоваться пользовательский словарь, а область значений задается так же, как и для текста. См. Ограничение области значений для текстового типа данных.
  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, изменить формат времени, выбрать более узкий тип данных, например, 12-часовой формат времени. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. Используется для времени, записанного стандартным способом.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Пользователь может создать собственный тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • Группа Контроль данных. В данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым
  • Группа Использовать нормализацию. Используется для задания пользовательского формата записи выходных значений типа Время. Настройки данной группы отображаются при нажатии кнопки Настройка нормализации.... В диалоговом окне Настройки нормализации времени задайте необходимый формат времени, выберите символ, который будет использоваться в качестве разделителя времени.
Collapsed Дата

Для текстового поля типа Дата доступны следующие настройки:

  • Опция Рассматривать значение как текст. Обрабатывать значение поля как текст. Рекомендуется использовать в случае, если дату невозможно привести к стандартному формату или нет необходимости работать со значением как с датой. Для проверки значения может использоваться пользовательский словарь, а область значений задается так же, как и для текста. См. Ограничение области значений для текстового типа данных.
  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, изменить порядок следования компонентов даты, добавить время или день недели, выбрать более узкий тип данных, например, обозначение месяца римскими цифрами. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык(и) распознавания для данного поля.
    • Тип содержимого: Стандартный. Для стандартного типа даты доступны дополнительные опции : Возможно написание месяца словом - если возможно написание месяца словом, а не только числом, Может содержать день недели - если дата может содержать день недели, Может содержать время - если дата может включать время.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Пользователь может создать собственный тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
    • Порядок компонентов даты - выбрать необходимый или один из возможных форматов записи даты. Если указаны несколько допустимых форматов записи даты, но не включена опция Использовать первый подходящий формат даты, программа выбирает наиболее подходящий формат записи.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • Группа Контроль данных. Проверка: попадает ли дата в заданный интервал. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Контроль данных. Подробнее см. Ограничение области значений для даты.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
  • Группа Использовать нормализацию. Используется для задания пользовательского формата записи выходных значений типа Дата. Настройки данной группы отображаются при нажатии кнопки Настройка нормализации.... В верхней части диалогового окна Настройка нормализации даты пользователь видит пример записи данных в зависимости от заданных настроек:
    • Формат даты - выходной формат записи даты.
    • Разделитель даты - символ, который будет использоваться в качестве разделителя даты.
    • Содержит день недели - в поле с датой на первой позиции будет указан день недели. Если день недели не был найден при распознавании, программа вычислит день недели по найденной дате.
    • Содержит время - в поле с датой на последней позиции будет указано время. Если время не было найдено при распознавании, то будет подставлено значение 00:00 в формате, указанном ниже.
    • Формат времени - выходной формат записи времени.
    • Разделитель времени - символ, который будет использоваться в качестве разделителя времени.

    Замечание. Нормализованное значение должно быть допустимым для поля. Если настройки группы Использовать нормализацию противоречат настройкам группы Детали содержимого, при проверке определения документа будет выводиться ошибка.

    Замечание. В программе реализована интеллектуальная система определения даты.
    Так, например, при распознавании даты, записанной неоднозначно (01/02/02), программа предлагает список возможных значений, исходя из заданных настроек.
    Если в дате присутствует день недели, не соответствующий указанной дате, при верификации возникнет форматная ошибка.
    Значения с ошибками написания или распознавания автоматически заменяются на правильные значения (например, "Wensday " заменяется на "Wednesday", а "Septembere" заменяется на "September").

Collapsed Денежная сумма

Для текстового поля типа Денежная сумма доступны следующие настройки:

  • Опция Рассматривать значение как текст. Обрабатывать значение поля как текст. Рекомендуется использовать в случае, если денежную сумму невозможно привести к стандартному формату или нет необходимости работать со значением как с числом. Для проверки значения может использоваться пользовательский словарь, а область значений задается так же, как и для текста. См. Ограничение области значений для текстового типа данных.
  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, указать дополнительные параметры для целых или дробных чисел, выбрать более узкий тип данных, например, двузначное число или римские цифры. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае для целых и дробных возможны следующие дополнительные настройки: для отрицательных значений разрешать знак минуса справа (например, 54 -), разрешить запись отрицательного числа с помощью скобок (например, значение "- 54" равносильно значению "(54)". Для дробных чисел возможны следующие настройки: Дробная часть обязательна, Разрешать более двух цифр в дробной части, Разрешать пробел как десятичный разделитель.

      При выборе опции Только целые значения в процессе распознавания игнорируются разделители целой и дробной части: точка, запятая, дефис, знак равенства, пробел.

      Замечание. Работа опции Разрешать пробел как десятичный разделитель возможна только в случае, если в свойствах поля на вкладке Распознавание не выбрана опция Одно слово.

    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Пользователь может создать собственный тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • Группа Контроль данных. Проверка: попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Контроль данных. Подробнее см. Ограничение области значений для числа.

    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
  • Группа Использовать нормализацию. Используется для задания пользовательского формата записи выходных значений типа Денежная сумма. Настройки данной группы отображаются при нажатии кнопки Настройка нормализации.... В верхней части диалогового окна Настройка нормализации чисел пользователь видит пример записи положительного и отрицательного числа в зависимости от заданных настроек:
    • Минимальное количество цифр в целой части. Возможные значения: от 0 до 9.
    • Группировка цифр - использовать ли группировку цифр по три цифры в каждой группировке.
    • Разделитель группировки - символ,который будет использоваться для разделения группировки цифр. Возможные разделители: пробел, запятая, точка.
    • Десятичный разделитель - символ, который будет использоваться для отделения целой части от десятичной. Возможные значения: запятая, точка.
    • Минимум цифр после разделителя - минимальное количество цифр в дробной части. Возможные значения: от 0 до 4.
    • Максимум цифр после разделителя - максимальное количество цифр в дробной части. Возможные значения: от 0 до 4. Если выбрано значение 0, дробное число округляется до целого по правилам математики.
    • Использовать скобки для отрицательных значений - при выборе данной опции отрицательное значение будет записано с помощью скобок, а не символа "минус".
    • Формат валюты - в выпадающем списке выберите необходимый формат записи валюты.

    Замечание. Нормализованное значение должно быть допустимым для поля. Если настройки группы Использовать нормализацию противоречат настройкам группы Детали содержимого, при проверке определения документа будет выводиться ошибка.

Внимание! Не следует использовать числовые типы данных для полей, значения которых состоят из цифр, но по сути числом не являются (например, номера карт или паспортов). Использование числового типа для этих полей может привести к проблемам, например, нули в начале строки отбрасываются. В таких случаях можно либо создать текстовый пользовательский тип данных с алфавитом 0-9 и, при необходимости, задать регулярное выражение, либо использовать числовой тип данных и отметить опцию Рассматривать значение как текст.

Collapsed Имя

Для текстового поля типа Имя доступны следующие настройки:

  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, задать пользовательский словарь или выбрать более узкий тип данных, например, фамилию или отчество. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае рекомендуется подключить пользовательский словарь с целью улучшения качества распознавания документов. Для этого отметьте опцию Подключить пользовательский словарь и нажмите Правка... для редактирования словаря. Пользовательский словарь можно создать, добавляя в него отдельные слова (кнопка Добавить...), или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить... и укажите путь к файлу с расширением .txt или .dic.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Также можно создать собственный пользовательский тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • В группе Контроль данных можно задать ограничение количества символов, ограничение содержимого. Подробнее см. Ограничение области значений для текстового типа данных.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
Collapsed Код

Для текстового поля типа Код (буквенно-цифровой код) доступны следующие настройки:

  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, задать пользовательский словарь или выбрать более узкий тип данных, например, номер социального страхования. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае рекомендуется подключить пользовательский словарь с целью улучшения качества распознавания документов. Для этого отметьте опцию Подключить пользовательский словарь и нажмите Правка... для редактирования словаря. Пользовательский словарь можно создать, добавляя в него отдельные слова (кнопка Add...), или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить... и укажите путь к файлу с расширением .txt или .dic.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Также можно создать собственный пользовательский тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • В группе Контроль данных можно задать ограничение количества символов, ограничение содержимого. Подробнее см. Ограничение области значений для текстового типа данных.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
Collapsed Текст

Для текстового поля типа Текст доступны следующие настройки:

  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, задать пользовательский словарь или выбрать более узкий тип данных. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае можно использовать встроенный словарь и/или пользовательский словарь. Тогда значение поля будет проверяться на вхождение в эти словари. Для использования встроенного словаря отметьте опцию Использовать встроенный словарь. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
      Замечание. Файл в формате DIC является пользовательским словарем Microsoft Office. Представляет собой список слов в виде текстового файла, по одному слову в строке.
    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Также можно создать собственный пользовательский тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • В группе Контроль данных можно задать ограничение количества символов, ограничение содержимого. Подробнее см. Ограничение области значений для текстового типа данных.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
Collapsed Число

Для текстового поля типа Число доступны следующие настройки:

  • Опция Рассматривать значение как текст. Обрабатывать значение поля как текст. Рекомендуется использовать в случае, если число невозможно привести к стандартному формату или нет необходимости работать со значением как с числом. Для проверки значения может использоваться пользовательский словарь, а область значений задается так же, как и для текста. См. Ограничение области значений для текстового типа данных.
  • Группа Детали содержимого. В настройках данной группы можно поменять язык распознавания, указать дополнительные параметры для целых или дробных чисел, выбрать более узкий тип данных, например, двузначное число или римские цифры. Настройки группы отображаются при нажатии кнопки Правка... справа от текстового поля с описанием деталей текущего поля.
    • Язык - выбрать язык распознавания для данного поля.
    • Тип содержимого: Стандартный. В данном случае для целых и дробных возможны следующие дополнительные настройки: для отрицательных значений разрешать знак минуса справа (например, 54 -), разрешить запись отрицательного числа с помощью скобок (например, значение "- 54" равносильно значению "(54)". Для дробных чисел возможны следующие настройки: Дробная часть обязательна, Разрешать более двух цифр в дробной части, Разрешать пробел как десятичный разделитель.

      При выборе опции Только целые значения в процессе распознавания игнорируются разделители целой и дробной части: точка, запятая, дефис, знак равенства, пробел.

      Замечание. Работа опции Разрешать пробел как десятичный разделитель возможна только в случае, если в свойствах поля на вкладке Распознавание не выбрана опция Одно слово.

    • Тип содержимого: Специальный. Содержит предопределенные типы данных, среди которых можно выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Пользователь может создать собственный тип данных, если ни один из предопределенных типов не подходит. Подробнее см. Создание пользовательских типов данных.
  • Значение по умолчанию - значение, которое автоматически добавляется в текстовое поле, если после наложения определения или сборки документа поле оказалось пустым. Более подробно см. выше.
  • Группа Опции автозамены. Автоматическая обработка введенного значения: удалить лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Настройки данной группы отображаются при нажатии кнопки Правка… справа от поля Опции автозамены. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения
  • Группа Контроль данных. Проверка: попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Контроль данных. Подробнее см. Ограничение области значений для числа.
    Также в данном разделе можно указать признак обязательности поля. Для этого необходимо отметить опцию Не может быть пустым.
  • Группа Использовать нормализацию. Используется для задания пользовательского формата записи выходных значений типа Число. Настройки данной группы отображаются при нажатии кнопки Настройка нормализации.... В верхней части диалогового окна Настройка нормализации чисел пользователь видит пример записи положительного и отрицательного числа в зависимости от заданных настроек:
    • Минимальное количество цифр в целой части. Возможные значения: от 0 до 9.
    • Группировка цифр - использовать ли группировку цифр по три цифры в каждой группировке.
    • Разделитель группировки - символ,который будет использоваться для разделения группировки цифр. Возможные разделители: пробел, запятая, точка.
    • Десятичный разделитель - символ, который будет использоваться для отделения целой части от десятичной. Возможные значения: запятая, точка.
    • Минимум цифр после разделителя - минимальное количество цифр в дробной части. Возможные значения: от 0 до 4.
    • Максимум цифр после разделителя - максимальное количество цифр в дробной части. Возможные значения: от 0 до 4. Если выбрано значение 0, дробное число округляется до целого по правилам математики.
    • Использовать скобки для отрицательных значений - при выборе данной опции отрицательное значение будет записано с помощью скобок, а не символа "минус".

    Замечание. Нормализованное значение должно быть допустимым для поля. Если настройки группы Использовать нормализацию противоречат настройкам группы Детали содержимого, при проверке определения документа будет выводиться ошибка.

Внимание! Не следует использовать числовые типы данных для полей, значения которых состоят из цифр, но по сути числом не являются (например, номера карт или паспортов). Использование числового типа для этих полей может привести к проблемам, например, нули в начале строки отбрасываются. В таких случаях можно либо создать текстовый пользовательский тип данных с алфавитом 0-9 и, при необходимости, задать регулярное выражение, либо использовать числовой тип данных и отметить опцию Рассматривать значение как текст.


Поля группы

На закладке Поля отображается список полей, входящих в группу.

Для редактирования свойств одного из полей:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…

Создание группы полей


Основные свойства поля

Основные свойства поля можно задать на вкладке Общие.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. Название по умолчанию возможно изменить при редактировании свойств поля. См. также Как изменить название поля.
  • Заголовок – подпись для поля, которая отобразится в форме данных.
  • Экспортировать значение поля – экспортировать ли значение поля (включено по умолчанию). Отключение опции может понадобиться, если, например, значение данного поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
    Опция доступна для полей всех типов.
  • Только для чтения – поле доступно только для просмотра. Если опция включена, оператор не сможет изменить значение. Рекомендуется использовать для полей, значение которых вычисляется автоматически. Например, после проверки с помощью правил в поле добавляется значение вычисленной суммы или результат объединения полей.
    Опция доступна для полей типа Текст, Штрих-код, Метка, Группа меток.
  • Показывать в Форме данных – отображать ли поле на форме данных (включено по умолчанию).
    Опция доступна для полей всех типов.
  • Индексное поле – индексировать ли документы по этому полю. Если опция включена, возможна сортировка и поиск документов по значению данного поля.
    Опция доступна для полей типа Текст, Штрих-код.
  • Показывать в области предварительного просмотра группы – отображать значение поля в сводной области, если группа, к которой принадлежит текущее поле, свернута.
    Опция доступна для полей типа Текст, Штрих-код, Служебное поле, Метка, Группа меток.
  • Может иметь регион – включение данной опции позволит задать регион для группы или поля.
    Опция доступна для полей всех, кроме Служебное поле.
  • Должно быть наложено – отметьте эту опцию, чтобы при верификации данное поле было подсвечено, если его регион не будет найден. В случае неналожения поля оно также будет доступно при переходе по полям документа в режиме Перейти к следующему ненайденному полю при наложении. Опция доступна только при включенной опции Может иметь регион.
  • Комментарии – пользовательский комментарий для текущего поля.

Замечание. Тип поля отображается в виде пиктограммы справа от названия поля.

Свойства полей


Свойства распознавания штрих-кода

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… контекстного меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

В выпадающем списке Тип заполнения выберите один из режимов распознавания: Стандартное распознавание, Не распознавать или Распознавание с помощью скрипта.

Для режима Стандартное распознавание укажите следующие опции:

  • Тип кода – задайте тип штрих-кода (обычно определяется автоматически). Нажмите кнопку Выбрать типы…, чтобы указать типы штрих-кода вручную.

    Замечание. Поиск штрих-кодов типа QR Code, Aztec и DataMatrix может замедлять работу, поэтому рекомендуется выбирать штрих-коды данных типов, только если они действительно встречаются в проекте. Выделение этих штрих-кодов должно происходить, только если хотя бы одно Определение документа из данного типа пакета содержит жесткий или гибкий раздел, где используется двухмерный штрих-код (QR Code, Aztec или DataMatrix), или если двухмерный штрих-код используется в классификаторе, подключенном к типу пакета.
    Если в проекте содержатся штрих-коды типа Code 39 without asterisk, данный тип также нужно указать явно, иначе штрих-коды этого типа обнаруживаться не будут.

  • Ориентация – задайте ориентацию штрих-кода.

Задайте параметры предварительной обработки изображений:

  • Инвертировать – в процессе распознавания заменить цвет и яркость изображения на противоположные.
    • Автоопределение - определять цвета фона и цвет шрифта, при необходимости инвертировать. Рекомендуется использовать при обработке документов, на которых встречается как текст, написанный светлым шрифтом на тёмном фоне, так и текст, написанный тёмным шрифтом на светлом фоне.
    • Инверсия - инвертировать изображение полностью.
    • Не инвертировать - не изменять изображение (по умолчанию).
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.

Выберите режим Не распознавать если это поле по каким-либо причинам не может быть распознано (например, если текст в поле написан слитными буквами), и его значение будет вводиться вручную оператором. В этом случае не нужно вводить другие свойства распознавания, так как такое поле распознаваться не будет, а при проверке оператору будет предложено ввести значение поля.

Выберите режим Распознавание с помощью скрипта, если при распознавании вы хотите применять пользовательский алгоритм. Подробнее см. Скрипт пользовательского распознавания.


Свойства распознавания меток

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… контекстного меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

В выпадающем списке Тип заполнения выберите один из режимов распознавания: Стандартное распознавание, Не распознавать или Распознавание с помощью скрипта.

Для режима Стандартное распознавание укажите следующие опции:

  • Тип метки – выберите тип метки. Это свойство очень важно для правильного распознавания меток.

    Квадрат – выберите этот тип метки, если метки ставятся в ограниченные квадратные области. Примеры: и [image].

    Без рамки – выберите этот тип метки, если метки ставятся на белом фоне, без ограничителя. Примеры: и [image].

    Автоматическое определение – при выборе этого типа, программа будет определять тип метки автоматически. Этот тип следует выбирать только в том случае, если первые два типа не подходят, например, у метки есть ограничитель, но он имеет неквадратную форму. Примеры: и [image].

    В режиме Автоматическое определение программа определяет, проставлена ли метка, сравнивая область метки в обрабатываемом документе и на бланке, на основе которого создается определение документа. Для корректного распознавания меток важно аккуратно указывать область метки в определении документа. Автоматический режим может применяться как для жестких, так и для гибких описаний:

    • Для жестких описаний
      Изображение метки в определении документа должно быть не заполнено. В результате сравнения области метки в обрабатываемом документе и в определении документа определяется, отмечена метка в документе или нет.
    • Для гибких описаний
      За эталон принимается количество черного в области метки в определении документа.
      • При сравнении процентного отношения черного в области метки в обрабатываемом документе и в определении документа определяется, отмечена метка в документе или нет.
  • Допускать исправления – отметьте эту опцию, если вы хотите разрешить исправления для каких-либо меток: полностью заштрихованные метки в этом случае будут считаться неотмеченными. Но если вы выбрали тип Автоматическое определение, то для таких меток исправления допускать нельзя.

Задайте параметры предварительной обработки изображений:

  • Инвертировать – в процессе распознавания заменить цвет и яркость изображения на противоположные.
    • Автоопределение - определять цвета фона и цвет шрифта, при необходимости инвертировать. Рекомендуется использовать при обработке документов, на которых встречается как текст, написанный светлым шрифтом на тёмном фоне, так и текст, написанный тёмным шрифтом на светлом фоне.
    • Инверсия - инвертировать изображение полностью.
    • Не инвертировать - не изменять изображение (по умолчанию).
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.

Выберите режим Не распознавать если это поле по каким-либо причинам не может быть распознано (например, если текст в поле написан слитными буквами), и его значение будет вводиться вручную оператором. В этом случае не нужно вводить другие свойства распознавания, так как такое поле распознаваться не будет, а при проверке оператору будет предложено ввести значение поля.

Выберите режим Распознавание с помощью скрипта, если при распознавании вы хотите применять пользовательский алгоритм. Подробнее см. Скрипт пользовательского распознавания.


Свойства распознавания текстового поля

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… контекстного меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

В выпадающем списке Тип заполнения выберите один из режимов распознавания: Стандартное распознавание, Не распознавать или Распознавание с помощью скрипта.

Для режима Стандартное распознавание укажите следующие опции:

  • ICR (рукопечатный) – отметьте эту опцию, если текст в данном поле будет написан от руки.

  • OCR (печатный) – отметьте эту опцию, если текст в данном поле будет напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машинке и т.д.) См. Поддерживаемые типы текста.

  • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.
    При выборе данной опции также можно подключить файл эталона в формате *.ptn. Вы можете создавать пользовательские эталоны в программах ABBYY FineReader Professional/Corporate Edition 9.0 (или более ранние версии) и ABBYY FineReader Engine 9.0 (или более ранние версии).

    Collapsed Пользовательский эталон распознавания

    Эталон — это набор пар «изображение символа — сам символ», созданных при распознавании с обучением. Пользовательский эталон используется как источник дополнительной информации при распознавании. Распознавание с обучением полезно в случае:

    • распознавания текста, при наборе которого использовались декоративные шрифты;
    • распознавания текста, содержащего специальные символы (например, математические знаки);
    • распознавания большого по объему (более 1000 страниц) текста с низким качеством печати.

    Для подключения эталона нажмите Изменить…, в открывшемся диалоге отметьте опцию По эталону и укажите путь к файлу эталона.

  • Тип разметки – выберите тип разметки, выбор облегчают образцы разметки в выпадающем списке. Если разметка исчезает при сканировании, то рекомендуемый тип разметки является моноширинным (Gray boxes), а если разметка не исчезает при сканировании и разделена на ячейки для знакомест, то обязательно нужно ввести общее число ячеек. При автоматическом нахождении полей с такой разметкой, число ячеек также определяется автоматически.

  • Регистр – выберите регистр букв в поле. Если поле может быть заполнено как строчными, так и заглавными буквами, оставьте значение Любой.

  • Ориентация – задайте ориентацию текста.

  • Для однострочного поля отметьте опцию Однострочное.

  • Для поля, значение которого всегда будет состоять из одного слова, отметьте опцию Одно слово. Отметьте эту опцию, если вы хотите, чтобы регулярное выражение применялось ко всему полю, независимо от того, содержит ли поле одно слово или несколько.

    • Задайте параметры предварительной обработки изображений:

  • Инвертировать – в процессе распознавания заменить цвет и яркость изображения на противоположные.
    • Автоопределение - определять цвета фона и цвет шрифта, при необходимости инвертировать. Рекомендуется использовать при обработке документов, на которых встречается как текст, написанный светлым шрифтом на тёмном фоне, так и текст, написанный тёмным шрифтом на светлом фоне.
    • Инверсия - инвертировать изображение полностью.
    • Не инвертировать - не изменять изображение (по умолчанию).
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – отметьте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.

Выберите режим Не распознавать если это поле по каким-либо причинам не может быть распознано (например, если текст в поле написан слитными буквами), и его значение будет вводиться вручную оператором. В этом случае не нужно вводить другие свойства распознавания, так как такое поле распознаваться не будет, а при проверке оператору будет предложено ввести значение поля.

Выберите режим Распознавание с помощью скрипта, если при распознавании вы хотите применять пользовательский алгоритм. Подробнее см. Скрипт пользовательского распознавания.


Источник данных

На закладке Источник данных указывается источник и тип данных служебного поля:

  1. В списке Источник выберите источник данных для поля.
  2. Если выбрано значение Регистрационный параметр документа или Регистрационный параметр пакета, в поле Имя параметра укажите наименование регистрационного параметра, который будет использован в качестве источника данных.
  3. В блоке Тип данных выберите тип данных служебного поля.


Столбцы таблицы

На закладке Столбцы отображается список столбцов данной таблицы. Каждый столбец таблицы относится к определенному типу полей (см. Создание таблицы) и обладает свойствами, присущими этому типу поля.

Для редактирования свойств одного из столбцов:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы выделяются программой красным шрифтом и подаются оператору на проверку. Но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

По умолчанию все поля определения документа поступают на верификацию.

Параметры верификации задаются на вкладке Верификация диалога задания свойств поля.

Если верификация требуется, оставьте включенной опцию Требуется верификация, далее определите параметры отображения символов при верификации:

  • Не подсвечивать символы - неуверенно распознанные символы не выделяются.
  • Подсвечивать, если уверенность меньше - выделять символы, для которых уровень уверенности распознавания меньше выбранного значения (40 %, 60 %, 80 %).
  • Подсвечивать все символы - выделять все неуверенно распознанные символы, вне зависимости от уровня уверенности их распознавания.

Групповая верификация

Если требуется групповая верификация, отметьте опцию Отправлять символы на групповую верификацию. Далее укажите, какие именно символы будут отправляться на групповую верификацию:

  • Только подсвеченные символы;
  • Все символы.

Выберите набор символов для групповой верификации:

  • Только цифры;
  • Собственный.
    При необходимости измените пользовательский набор символов. Для этого нажмите кнопку Правка…, в открывшемся окне выберите необходимые символы.

Контекстная верификация

Если требуется контекстная верификация, отметьте опцию Отправлять на контекстную верификацию. Далее укажите, в каких случаях поле будет отправляться на контекстную верификацию:

  • Всегда
    Поле отправляется на контекстную верификацию в любом случае, независимо от процента неуверенно распознанных символов или наличия/отсутствия форматных ошибок. В данном случае поле при верификации выделяется пунктирной линией красного цвета.
  • Если поле содержит ошибки формата или процент подсвеченных символов превышает или равен
    Поле отправляется на контекстную верификацию в случае, если имеются форматные ошибки или достигнут порог полевой верификации Collapsed Порог полевой верификации - процент неуверенно распознанных символов в поле, при достижении которого поле отправляется на верификацию. Если указано значение "0 %", поле подаётся на верификацию при наличии хотя бы одного подсвеченного символа. Возможен ввод значений вручную, а также с помощью кнопок увеличения и уменьшения значения (в этом случае шаг равен 10 %).

Контекстная верификация в составе группы полей

Если поле требуется отправить на контекстную верификацию в составе группы полей, введите название группы в поле Имя группы полей. При этом, дополнительно необходимо включить опцию Группировать поля при контекстной верификации на вкладке Верификация диалогового окна Свойства проекта.

Двойная верификация

Если требуется независимая проверка поля разными операторами, отметьте опцию Требуется двойная верификация.


Правило проверки по базе данных

Проверка значений полей по базе данных заключается в том, что распознанное значение поля сравнивается со значениями из таблицы базы данных и считается правильным, если значение поля найдено среди значений в базе данных. В противном случае выдается сообщение об ошибке правила.

С помощью данного правила можно проверить вхождение требуемого значения в базу данных, обеспечить нечеткий поиск значения в таблице даже при наличии опечаток\ошибок в значении поля, заменить значение поля документа оригинальным значением из базы данных, скопировать в поля документа необходимые значения из базы данных.

Как создать правило проверки по базе данных

Чтобы создать правило проверки по базе данных, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Проверка по базе данных и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. Укажите строгость правила.
  8. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил).
  9. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  10. Нажмите Далее >.
  11. В открывшемся окне укажите тип источника данных и параметры подключения для него.

    Возможен один из следующих типов источника данных:

    • Внешняя база данных (Обычная) – внешняя база данных, подключение к которой настраиваются в определении документа для каждого правила.
    • Внешняя база данных (Переменная) – внешняя база данных, параметры подключения к которой задаются только в свойствах проекта (Свойства проекта > Переменные окружения). Данный тип источника данных может использоваться для нескольких правил одновременно, что позволяет при использовании проекта с другой базой данных переопределить параметры подключения к внешней базе данных только в свойствах проекта, а не во всех правилах.
    • Набор данных – параметры подключения к базе данных, заданные пользователем в свойствах определения документа (Свойства определения документа > Наборы данных).

    Совет. В качестве OLE DB Provider рекомендуется выбирать:

    • При экспорте в SQL - OLE DB Provider for ODBC Drivers.
    • При экспорте в Oracle - Oracle Provider for OLE DB.
    Замечание. Для того чтобы при подключении к базе данных не запрашивался пароль, отметьте опцию "Allow saving password" или настройте базу данных таким образом, чтобы подключение осуществлялось без пароля (например, используйте Windows-аутентификацию).

  12. Выберите из списка схему и таблицу базы данных при подключении к внешней базе данных. Либо укажите необходимый набор данных при подключении к источнику типа Наборы данных.

    Замечание. Если в качестве схемы выбран пункт Искать во всех схемах и при этом указанная таблица находится не в схеме по умолчанию, то может возникнуть ошибка вида:

    [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name K1. [Microsoft][ODBC SQL Server Driver][SQL Server]Statement(s) could not be prepared.

    В случае возникновения ошибки нужно явно указать в настройках имя схемы, в которой находится таблица.

  13. Отметьте опцию Не проверять, если все поля пустые для того, чтобы проверка правила не выполнялась в случае отсутствия значений в полях документа, участвующих в сравнении (это позволит сократить время на проверку правил документа).
  14. Установите соответствие между полями определения документа и полями таблицы базы данных (см. раздел Настройка сравнения полей).
  15. С помощью кнопок Добавить…, Правка… и Удалить можно добавлять, редактировать и удалять связи (соответствия) между полями.

Настройка сравнения полей

В группе Соответствие полей на закладке Задание параметров правила отображается список настроенных вариантов сравнения полей. Правило проверки по базе данных можно настроить как для одного поля, так и для набора полей.

При добавлении нового или правке существующего типа сравнения следующие поля являются обязательными для заполнения:

  • Поле документа - поле определения документа, которое участвует в сравнении;
  • Поле базы данных - соответствующее поле таблицы базы данных;
  • Поиск - данная опция позволяет выбрать тип сравнения полей, а именно:
    • Точный – значения полей должны точно совпадать (регистр символов при сравнении не учитывается).
    • Нечеткий – значения полей должны совпадать частично. Данный тип сравнения можно использовать только для текстовых полей.

      • Collapsed Особенности нечеткого поиска

      При нечетком поиске происходит поиск наиболее близких слов, таких, чтобы для получения исходного слова нужно было добавить, удалить или заменить наименьшее количество букв. Количество допустимых ошибок зависит от длины исходного слова. Если несколько вариантов значений подходит под критерии нечеткого поиска, то в окне документа оператору выдается сообщение об ошибке правила Найдено слишком много записей. и список наиболее похожих значений поля из базы данных. Оператор может выбрать подходящее значение из списка.

При необходимости можно настроить дополнительные опции:

  • Не выполнять поиск, если поле пустое - если поле документа пустое, то его значение не будет сравниваться со значением из базы.
  • Заполнять из базы данных - если с помощью нечеткого сравнения требуемое значение было найдено в базе данных, то оно автоматически будет подставлено в поле документа в одном из следующих случаев:
    • Если значения различаются;
    • Только если поле пустое.

      Замечание. При точном сравнении полей использование опции Заполнять из базы данных не имеет смысла.

  • Разрешить пустые значения в базе данных - в зависимости от результатов сравнения и настроек данная опция может иметь следующее значение:
    • если в базе данных поле оказалось пустым, а в документе - нет, то считаем, что значения совпадают;
    • если в базе данных поле оказалось пустым, а в документе - нет, но при этом настроено автозаполнение из базы данных, в этом случае значение поля документа не будет заполнено пустым значением из базы.

Сравнение набора полей

В данном случае осуществляется поиск подходящей строки таблицы для значений из набора полей, каждое значение из набора сопоставляется разным столбцам найденной строки.

В качестве примера рассмотрим следующий случай:

Настроим сопоставление полей Fa, Fb, Fc документа со столбцами Ta, Tb, Tc таблицы базы данных следующим образом:

  • Значение поля Fa точно соответствует значению Ta;
  • Значение поля Fb нечетко соответствует значению Tb;
  • При выполнении заданных условий значение поля Tc копируется в поле Fc.

Проверка полученных результатов будет завершена успешно, если будет найдена строка таблицы, в которой значение столбца Ta точно совпадает со значением поля Fa, значение столбца Tb нечетко совпадает со значением поля Fb. При заданных настройках значение столбца Tc этой строки будет скопировано в поле Fc.

Если же такая строка не будет найдена, то проверка правила завершится неуспешно, хотя, например, было найдено Ta = Fa и Tb = Fb, но в разных строках.

Замечание. Возможны различные комбинации сравнения набора полей: точное/нечеткое/смешанное сопоставление, отсутствие автозаполнения, произвольное количество полей и т. д.


Правило вычисления суммы значений

Это правило предназначено для вычисления суммы значений нескольких полей и записи его в указанное поле. Например, если в документе есть поля с суммой оклада, премии, иных начислений, то можно задать правило, вычисляющее их сумму и записывающее результат в указанное поле.

Также можно использовать данное правило для подсчета суммы значений в колонке таблицы. Для этого необходимо создать правило в свойствах определения документа или раздела документа. При этом опция Необходимы хотя бы два непустых объекта не должна быть отмечена.

Чтобы создать правило вычисления суммы, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на вкладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Вычисление суммы и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  8. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  9. Нажмите Далее >.
  10. В открывшемся диалоговом окне добавьте в список Поля для суммирования те поля, сумму значений которых необходимо найти. Для добавления используйте кнопку Добавить….
  11. В поле Записать результат в поле укажите поле, в которое надо записать результат суммирования. Используйте для этого кнопку Выбрать…
  12. Отметьте опцию Необходимы хотя бы два непустых объекта, если требуется, чтобы при суммировании было как минимум два непустых и ненулевых слагаемых. В случае невыполнения данного условия при проверке правила появится сообщение в окне ошибок правил документа.

    13. Замечание: при применении данной опции в параметрах правила необходимо добавить к суммированию минимум два поля (или два столбца таблицы) документа. Поэтому не отмечайте опцию, если данное правило используется для суммирования значений из всех ячеек одного столбца таблицы.

  13. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на вкладке Правила.


Правило проверки суммы значений

Это правило предназначено для проверки суммы значений нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле. Например, если в документе есть поля с суммой оклада, премии, иных начислений, а также есть поле с общей суммой дохода, то можно задать правило, проверяющее совпадает ли сумма значений полей со значением в результирующем поле. При несовпадении будет выдаваться сообщение об ошибке.

Замечание: При использовании данного правила для поля типа Таблица вычисление будет зависеть от уровня, на котором создается правило. При необходимости сравнения суммы значений всех ячеек некоторой колонки таблицы с вычисляемым или заданным числом правило нужно создавать в свойствах определения документа или раздела документа. При необходимости сравнения каждой ячейки некоторой колонки или суммы ячеек нескольких колонок таблицы с вычисляемым или заданным числом правило нужно создавать в свойствах таблицы или колонки таблицы. Также подобным принципом нужно руководствоваться при создании правила проверки суммы значений полей с несколькими экземплярами.

Чтобы создать правило проверки суммы, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Проверка суммы и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. Укажите строгость правила.
  8. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  9. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  10. Нажмите Далее >.
  11. В открывшемся диалоговом окне добавьте в список Суммировать значения полей поля, сумму значений которых вы хотите проверить, для добавления используйте кнопку Добавить….
  12. Выберите одну из опций:
    • полем – для сравнения суммы со значением результирующего поля. Название этого поля выберите с помощью кнопки Выбрать….
    • числом – для сравнения суммы с заданным числом. Введите это число.
  13. Точность – допустимая разность между значениями полей, для которых настроено правило. Правило выполнено, если модуль разности сравниваемых значений меньше или равен указанному значению точности. В противном случае, если модуль разности сравниваемых значений больше указанного значения точности, правило не выполнено, и будет выведено сообщение об ошибке.
  14. Отметьте опцию Необходимы хотя бы два непустых объекта, если требуется, чтобы при суммировании было как минимум два непустых и ненулевых слагаемых. В случае невыполнения данного условия при проверке правила появится сообщение в окне ошибок правил документа.
  15. Подтверждать поля при успешной проверке правила – при включенной опции значения поля, для которых проверка с помощью правила завершилась успешно, будут автоматически подтверждены в редакторе определения документа. При отключенной данной опции оператору верификации необходимо вручную подтверждать значения полей, независимо от того, успешно или нет выполнилась проверка с помощью правила.
  16. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило сравнения значений нескольких полей

Это правило предназначено для сравнения значений нескольких полей. Его можно применять, если в вашем документе есть несколько полей, значения которых должны быть одинаковыми. При несовпадении значений для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Сравнение значений полей и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. Укажите строгость правила.
  8. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  9. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  10. Нажмите Далее >.
  11. В открывшемся диалоговом окне добавьте в список Сравнить значения полей поля, значения которых вы хотите сравнивать, для добавления используйте кнопку Добавить….
  12. Выберите тип сравнения:
    • Четкое – для точного сравнения значений;
    • Нечеткое – для нечеткого сравнения. В этом случае сравнение будет производиться без учета регистра и лишних пробелов, а для значений полей длиннее 4-х символов допускается одна ошибка.
  13. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило объединения значений полей

Это правило предназначено для объединения значений нескольких полей. Значения полей при объединении можно отделять друг от друга точкой, пробелом или другими разделителями.

Чтобы создать правило объединения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Объединение значений полей и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  8. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  9. Нажмите Далее >.
  10. В открывшемся диалоговом окне добавьте в список Поля для объединения значений поля, которые будут участвовать в объединении. Для добавления используйте кнопку Добавить…. Выберите Записать результат в поле – поле, в котором будет храниться результат объединения. В окне Разделитель введите нужный разделитель.
  11. По умолчанию, разделители будут добавлены между непустыми значениями. Если вы хотите, чтобы разделители добавлялись в любом случае, даже при наличии пустых значений полей, то отметьте опцию Добавлять разделитель при пустом значении.
  12. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.

Результат объединения может храниться в любом поле определения документа, удобно использовать с этой целью поля без разметки.

Если вам нужно экспортировать только значение результирующего поля, а не полей, участвующих в объединении, то у последних можно отключить опцию Экспортировать значение поля.


Правило, заданное с помощью скрипта

Программа ABBYY FlexiCapture позволяет задать правило проверки данных с помощью скрипта.

Чтобы создать такое правило, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Скрипт и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. Укажите строгость правила.
  8. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  9. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  10. Нажмите Далее >.
  11. В открывшемся диалоговом окне в списке Доступные поля отображается список доступных объектов. Вы можете добавлять и удалять поля в помощью кнопок Добавить… и Удалить. Значения полей, у которых отмечена опция Только для чтения, доступны для чтения, а значения полей из списка, у которых эта опция не отмечена, могут быть перезаписаны с помощью скрипта.

    Замечание. В список должны быть добавлены все поля, которые будут использоваться в скрипте. Если поле не добавлено в список, использовать его в скрипте нельзя.

  12. Нажав кнопку Правка…, откройте специальное окно для редактирования скрипта.
  13. Выберите язык скрипта и введите текст скрипта.
  14. Проверку скрипта можно выполнить с помощью пункта меню Сервис>Проверить скрипт.
  15. Сохраните скрипт с помощью пункта меню Файл > Сохранить.
  16. Нажмите Готово (Finish). Созданное правило отобразится в списке на закладке Правила.

Подробно о параметрах скрипта см. Скрипт правила


Правило сравнения суммы цифрами с суммой прописью

Внимание! Правило работает только для русского языка. Это правило можно задать только в том случае, если установлен русский язык распознавания для определения документа (меню Определение документа>Свойства определения документа…, закладка Распознавание).

Это правило предназначено для сравнения суммы цифрами с суммой прописью на русском языке. При несовпадении сумм для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения суммы цифрами с суммой прописью, выполните следующие действия:

  1. Откройте диалог свойств поля (контекстное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа > Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое правило….
  4. Из списка типов правил выберите Сравнение суммы цифрами с суммой прописью и нажмите ОК.
  5. Введите название правила.
  6. При необходимости отключите опцию Показывать название правила в сообщении верификатору. В этом случае ошибка правил выводится в формате "текст ошибки", а не "название правила: текст ошибки".
  7. Укажите строгость правила.
  8. При необходимости настройте условие запуска правила. По умолчанию правило применяется всегда, подробнее см. Настройка условий запуска правил.
  9. При необходимости отключите опцию Правило включено. В этом случае правило будет создано, но не будет выполняться до тех пор, пока пользователь не включит данную опцию.
  10. Нажмите Далее >.
  11. Нажмите кнопку Выбрать…справа от поля Сумма цифрами и выберите поле определения документа, в котором находится предназначенная для сравнения сумма цифрами.
  12. Нажмите кнопку Выбрать… справа от поля Сумма прописью и выберите поле определения документа, в котором находится предназначенная для сравнения сумма прописью.
  13. При необходимости включите опцию Учитывать копейки в сумме.
  14. Нажмите Готово для завершения создания правила. Название правила отобразится на закладке Правила.


Проверка с помощью правил

Правила – один из инструментов для автоматической проверки результата. Правила позволяют задать условия, которым должны удовлетворять значения тех или иных полей.

Кроме того, с помощью правил можно обработать введенные значения: соединить значения нескольких полей или заменить распознанные значения соответствующими значениями из базы данных.

Правилу можно присвоить статус ошибки или предупреждения, при невыполнении условия поле помечается красным флажком в случае ошибки, желтым – в случае предупреждения. См. Верификация правил.

Настройка правила осуществляется в диалоге свойств поля, раздела, определения документа и т.д. объекта на вкладке Правила. Вкладку Rules можно условно разделить на три области: режим отображения и фильтрация правил, сводная информация о настроенных правилах, кнопки управления правилами.

Режим отображения и фильтрация правил

В выпадающем списке Показать пользователь выбирает режим отображения правил:

  • Правила, использующие данный элемент – в списке отобразятся правила, которые работают с данным объектом (диалог свойств которого открыт в данный момент).

  • Правила, хранимые в данном элементе – в списке отобразятся правила, которые хранятся в данном объекте.
  • Правила, хранимые в данном элементе и во вложенных элементах – в списке отобразятся правила, которые хранятся в данном объекте и в его дочерних объектах. Например, если объект является группой, то отобразятся правила, хранящиеся в группе и во входящих в группу полях.

Замечание. Создать новое правило можно только в режимах отображения Правила, хранимые в данном элементе и Правила, хранимые в данном элементе и во вложенных элементах. В режиме Правила, использующие данный элемент новое правило создать нельзя.

Collapsed Фильтрация правил

Фильтрация правил позволяет ограничить количество отображаемых правил в списке. Например, с помощью фильтра можно просмотреть правила, в которых участвует указанное поле, или правила с определенным условием запуска.

Чтобы настроить фильтр, нажмите кнопку Фильтр на вкладке Правила.

Доступны следующие типы фильтров:

  • Название правила – в результате наложения фильтра данного типа будут отображены правила, название которых соответствует значению, выбранному из выпадающего списка.
  • Поле, используемое правилом – в результате наложения фильтра данного типа будут отображены правила, в которых участвует указанное поле.
  • Применение правил – фильтрация по условию запуска правил: правило выполняется Всегда или Если выполняется условие для поля, а именно:
    • Входит в множество (точное соответствие) – в списке будут отображены правила, у которых множество разрешённых значений поля (т.е. все те значения поля, при которых правило будет выполнено) в точности совпадает с заданным в настройках фильтра набором значений;
    • Не входит в множество (точное соответствие) – в списке будут отображены правила, у которых множество запрещенных значений поля (т.е. все те значения поля, при которых правило не будет выполнено) в точности совпадает с заданным в настройках фильтра набором значений;
    • Не указано - в списке будут отображены правила, выполнение которых разрешено только при пустом значение поля;
    • Перекрывает множество – в списке будут отображены правила, у которых разрешенное множество значений поля (т.е. все те значения поля, при которых правило будет выполнено) содержит хотя бы одно из значений, заданных в настройках фильтра.
    • Указано - в списке будут отображены правила, выполнение которых разрешено только при непустом значение поля;

Возможно одновременное применение фильтров всех типов.

При настроенном фильтре справа от кнопки Фильтр выводится строковое сообщение с кратким указанием параметров фильтрации. Чтобы очистить фильтр, необходимо нажать кнопку [image]. В результате отобразятся все настроенные правила без каких-либо ограничений. Фильтр автоматически очищается после закрытия диалога.

Пример работы фильтра

Предположим, имеются два правила:

FirstRule – запускается, если Currency = EUR, USD

SecondRule – запускается, если Currency = EUR, RUR.

Далее в табличном виде приведены результаты фильтрации правил в зависимости от выбранных условий запуска.

Условие запуска | Значение из множества | Отображаемое правило
Входит в множество (точное соответствие) | EUR, USD | FirstRule
Не входит в множество (точное соответствие) | EUR | —
Перекрывает множество | EUR | FirstRule, SecondRule
Перекрывает множество | EUR, XXX | FirstRule, SecondRule

Создание и настройка правил

В списке правил отображаются все настроенные правила с указанием сводной информации по каждому правилу.

Чтобы создать правило, нажмите кнопку Новое правило… на вкладке Правила. В открывшемся диалоговом окне выберите тип правила, нажмите ОК. В диалоговом окне Новое правило <тип правила> укажите следующую информацию:

  • Название - название правила;
  • Показывать название правила в сообщении верификатору (опция) - отображать ли название правила, при проверке которого произошла ошибка. По умолчанию ошибки правил выводятся в формате "название правила: текст ошибки". Отключение данной опции позволит выводить только текст ошибки.
  • Строгость - строгость выполнения правила. При невыполнении правила генерируется сообщение об ошибке с соответствующим флагом состояния: Ошибка или Предупреждение.

    При попытке экспортировать документы с ошибками правил будет выдаваться соответствующее сообщение. Наличие предупреждений правил не помешает экспорту.

    Замечание. Данное свойство не доступно для правил типа Вычисление суммы и Объединение значений полей.

  • Применять правило - условие запуска правила:
    • Всегда – правило применяется всегда. Перевыполняться будет при любом изменении в участвующих полях. По умолчанию выбрано это значение;
    • Если выполняется условие – правило применяется при определенных условиях. Подробности см. в разделе Настройка условий запуска правил данной статьи.
  • Правило включено (опция) - при выбранной опции правило выполняется, при отключенной – не выполняется.

Дальнейшие настройки зависят от выбранного типа правила:

  • Вычисление суммы - вычисление суммы значений нескольких полей и запись его в указанное поле.
  • Объединение значений полей– объединение значений нескольких полей. При объединении можно добавлять любые разделители.
  • Проверка по базе данных – производится проверка введенных значений путем их сравнения со значениями из определенной базы данных.
  • Проверка суммы – проверка суммы нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле.
  • Скрипт – проверка данных с помощью пользовательского скрипта.
  • Сравнение значений полей – сравнение значений нескольких полей.
  • Сравнение суммы цифрами с суммой прописью – сравнение суммы цифрами с суммой прописью (только на русском языке).

Настройка условий запуска правил

ABBYY FlexiCapture текущей версии позволяет запускать правила в зависимости от значения определенного поля. Пользователь определяет параметр запуска правила при его создании: Всегда или Если выполняется условие. Для того чтобы задать условие запуска правила, нажмите кнопку Правка... справа от Если выполняется условие. В диалоговом окне Условие применения правила выполните следующие действия:

  • Выберите необходимое поле.
  • В выпадающем списке укажите условие запуска правила.
    • Входит в набор – определяет множество разрешенных значений поля. Правило выполняется, если значение поля входит в множество разрешенных значений
    • Не входит в набор – определяет множество запрещённых значений поля. Правило выполняется, если значение поля не входит в множество запрещенных значений.
    • Не указано - правило выполняется, если значение поля пустое.
    • Указано - правило выполняется, если значение поля не пустое.

  • При необходимости добавьте возможные значения поля.

    • Чтобы добавить элемент множества возможных значений поля, введите его значение в поле и нажмите кнопку Добавить. Чтобы удалить элемент, выделите его и нажмите кнопку Удалить. Во множество значений может быть добавлено пустое значение. Для этого нажмите добавить при пустом текстовом поле – в окно элементов добавится значение <Empty value>. Каждый элемент может быть добавлен только один раз.

При наложении условий запуска правила могут быть использованы только текстовые поля (в том числе поля с продолжением), штрих-коды и столбцы таблицы. Недопустимы метки, группы меток, повторяющиеся поля, изображения, а также ячейки таблицы.

Внимание! Если в свойствах поля не отмечена опция Показывать в Форме данных, то ошибки, связанные с этим полем, не будут выводиться при верификации. Таким образом, документ будет иметь неустранимый флаг ошибки.

Цепочки правил

Цепочки правил позволяют объединить правила в одну группу и однозначно определить порядок их выполнения. Это, в свою очередь, позволяет настроить несколько правил с участием одного и того же поля.

Чтобы создать цепочку правил, выполните следующие действия:

  • На вкладке Rules нажмите кнопку Цепочки…;
  • В открывшемся окне нажмите кнопку Новая цепочка…;
  • Далее укажите название цепочки и комментарий, если необходимо;
  • Нажмите ОК.

Новая цепочка появится в списке диалога Цепочки. Теперь нужно добавить правила в созданную цепочку. Для этого:

  • Нажмите кнопку Добавить правило…;
  • Из списка выберите необходимые правила;
  • С помощью кнопок Выше/Ниже задайте желаемый порядок выполнения правил.

Внимание! Каждое правило может входить в состав только одной цепочки.

Замечание. При попытке добавить в правило редактируемое поле (*) , которое уже входит в состав другой цепочки и его значение также доступно для редактирования, пользователю будет предложено объединить все правила в одну цепочку. При согласии пользователя, если правила принадлежали разным цепочкам, все цепочки объединяются в одну.

(*) Редактируемое поле - поле, значение которого доступно для редактирования (в свойствах поля отключена опция Только чтение).

Collapsed Хранение правил

В иерархической структуре правила хранятся на уровне того объекта, в котором они были созданы: это может быть поле, раздел или само определение документа. В большинстве случаев место хранения правил не имеет значения. Но если необходимо создать определение документа со сложной структурой, с группами полей или повторяющимися элементами, то нужно следить за местом хранения правил. Например, если у вас есть группа полей, и некоторые поля группы связаны каким-либо правилом, то при создании нового экземпляра этой группы правило будет скопировано и корректно выполняться в новом элементе только в том случае, если правило хранится в самой группе или в одном из ее полей, а не на уровне выше. Из диалога свойств объекта доступен просмотр правил, которые работают с данным объектом, либо правил, хранящихся в данном объекте и в его дочерних объектах. Вы можете указать, какие правила вы хотите просмотреть, выбрав одно из значений выпадающего списка Показать.


Разделители

Разделители - статические элементы. Это любые горизонтальные и вертикальные линии на изображении.

Для того, чтобы выделить разделители:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол области разделителя, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области разделителя.

Свойства разделителя

Чтобы изменить свойства разделителя:

  1. Выделите разделитель;
  2. Щелкните в области разделителя правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения определения документа – эта опция должна быть отмечена, чтобы разделитель использовался для наложения определения документа;
    • Использовать для идентификации определения документа – отметьте эту опцию для использования разделителя в качестве идентификатора.


Служебные поля

При создании служебного поля ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из двух закладок, на каждой из которых редактируется определенная группа свойств

Основные свойства
Источник данных


Статические элементы

Статические элементы служат для наложения определения документа и идентификации. Из них не извлекаются никакие данные.

Для работы со статическими элементами в редакторе определения документа нужно переключиться в режим статических элементов - по кнопке [image].

Статические элементы могут использоваться для наложения определения документа и идентификации, способ использования определяется при задании свойств элемента. С помощью реперов производится совмещение определения документа с изображением формы. Идентификаторы нужны для определения принадлежности страницы к одной из форм, если в одном потоке обрабатываются разные формы. Подробнее см. Создание машиночитаемых форм.

У статических элементов нет названий, есть только области на изображении.

При наложении определения на изображение документа производится поиск статических элементов и по их расположению выбирается определение документа. Распознавание значений статических элементов (текста и штрих-кода) производится только в том случае, если это необходимо для идентификации. См. Задание значений идентификаторов.

В программе предусмотрены статические элементы следующих типов:

Статический элемент | Кнопка на панели инструментов
Репер |
Разделитель |
Реперный текст |
Реперный штрих-код |

Поиск реперов производится автоматически при добавлении изображения.

Как создать статический элемент вручную:

  1. Выберите режим статических элементов;
  2. Выберите инструмент для создания элемента нужного типа;
  3. Установите курсор мыши в угол элемента, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол или нажмите Shift и щелкните левой кнопкой мыши в области элемента.

Область статического элемента будет обведена прямоугольником, цвет которого зависит от типа статического элемента. Статическому элементу присваиваются свойства по умолчанию.

Как изменить свойства статического элемента:

  1. Выделите область элемента на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства статического элемента в открывшемся диалоге.

Подробнее о статических элементах:

  • Реперы
  • Разделители
  • Реперный текст
  • Реперный штрих-код


Редактирование и публикация определения документа

Редактирование определения документа производится в окне редактора определения документа, в котором вы можете изменять расположение полей и статических элементов, редактировать их свойства, правила, настройки экспорта и т.д.

Для того чтобы при редактировании определения документа не влиять на работу других участников проекта, в программе предусмотрена возможность редактирования локальной копии определения, в то время как для распознавания используется последняя опубликованная версия. Такой режим работы позволяет вносить изменения и тестировать определение документа локально, а операторам даст возможность завершить верификацию и экспорт документов, распознанных в старой версии, даже если определение документа сильно изменено или удалено. Редактируемое определение недоступно для редактирования другими пользователями. После завершения редактирования можно опубликовать определение документа, тогда новая версия становится доступной для распознавания документов, или отменить все сделанные изменения.

Чтобы отредактировать определение документа, выполните следующие действия:

  1. В главном окне программы выберите пункт меню Проект>Определения документов…
  2. Выберите в списке определение документа для редактирования.
  3. Нажмите кнопку Правка… в диалоге Определения документов, чтобы начать редактирование определения документа. Локальная версия определения будет скопирована на ваш компьютер. определение документа станет недоступно для редактирования другими пользователями.
  4. Сделайте необходимые изменения в окне редактора определения документа. Сохраните определение.
  5. Протестируйте определение документа на нескольких изображениях. Для отладки определения используются тестовые пакеты, которые работают с локальной версией определения.
  6. Нажмите кнопку Опубликовать в диалоге Определения документов, чтобы опубликовать определение. После публикации новая версия определения будет использоваться для распознавания документов из рабочих пакетов. определение документа снова станет доступно для редактирования другими администраторами. Для того чтобы вернуть определение, но без сделанных изменений, нужно нажать кнопку Отменить правку.
  7. Наложение определений документов осуществляется в том порядке, в котором они перечислены в диалоговом окне Определения документов. При необходимости измените порядок наложения определений документов.
  8. Для ускорения наложения гибких описаний отметьте опцию Использовать первое подошедшее гибкое описание: в этом случае будет использоваться первое наложившееся описание. Если опция не отмечена, приложение будет пытаться наложить все гибкие описания, с последующим выбором наилучшего.

Новая версия определения документа начинает использоваться при распознавании и дальнейшей обработке документов сразу после публикации. Однако для документов, обрабатывавшихся на момент публикации определения, используется предыдущая версия. При необходимости можно обновить версию определения и для обрабатывающихся документов. Для этого выберите пункт меню Сервис>Обновить до последней версии. При этом в зависимости от изменений в определении документа будет выведено сообщение о необходимости повторно отправить документы на распознавание (если изменились параметры распознавания), на проверку правил (если изменились правила документов) либо просто проэкспортированы с новыми настройками (если изменились только настройки экспорта). Сообщение о необходимости повторно отправить документы на распознавание будет выведено, если:

  • изменилась структура блоков (были добавлены/удалены блоки, изменилась вложенность);
  • изменились регионы блоков;
  • изменились настройки распознавания (в том числе тип данных, за исключением настроек форматных проверок и автокоррекции).


Импорт определений документов, созданных в программе ABBYY FormDesigner

ABBYY FormDesigner является удобным инструментом, разработанным специально для создания машиночитаемых форм. Создавая формы с помощью ABBYY FormDesigner, вы не только получаете формы, удовлетворяющие всем требованиям автоматизированной обработки документов, но и почти готовое определение документа для обработки этих форм в программе ABBYY FlexiCapture.

Чтобы получить определение документа для обработки созданных в программе ABBYY FormDesigner форм, нужно:

В ABBYY FormDesigner:

  1. Создать форму;
  2. Опубликовать ее;
  3. Экспортировать в формат XML Form Definition. Будет получен файл с расширением .xfd

Подробнее о создании формы, публикации и экспорте читайте в справке и руководстве ABBYY FormDesigner.

В ABBYY FlexiCapture:

  1. В главном окне программы выбрать пункт меню Проект > Определения документов…;
  2. В диалоге Определения документов нажать кнопку Импорт…;
  3. В открывшемся диалоге Открытие файла для импорта выберите значение XML Form Definition Files (*.xfd) в выпадающем списке Files of type и укажите путь к *.xfd файлу;
  4. Название нового определения документа появится в списке диалога Определения документов.

Открыв импортированное определение документа для редактирования, вы увидите, что разметка полей и статических элементов уже присутствует на изображении. Вам осталось только отредактировать свойства полей и настроить экспорт.

Обновление определения документа на основе XFD-файла

Существует возможность дополнить определение документа, созданное на основе формы XML Form Definition, без потери настроек, которые пользователь уже произвел в Редакторе определения документа.

Для этого в меню Сервис Редактора определения документа выберите пункт Обновить определение документа файлом XFD… и укажите путь к xfd-файлу. В процессе обновления изображения страниц заменяются на новые, создаются блоки согласно новому XFD-описанию. При этом поля определения документа, которые не соответствуют новой форме, остаются в структуре документа, помечаются звездочкой, но не отображаются в виде блоков на изображении. При обновлении таких элементов выводится предупреждение.

Внимание! Если определение документа состоит из нескольких секций, необходимо обновить определение документа для каждой секции: в структуре документа выделить секцию, к выделенной секции применить команду Обновить определение документа файлом XFD….


?Создание определений для многостраничных документов

ABBYY FlexiCapture позволяет создавать определения для многостраничных документов. Определение документа может состоять из произвольного количества разделов, каждый из которых может содержать одну или несколько страниц. Для определений многостраничных документов задается порядок следования разделов, их количество и правила сборки страниц в документы.

После завершения работы Мастера создания нового определения создается простое определение документа, не содержащее разделов. В это определение документа могут быть добавлены страницы и разделы.

Добавление страниц

Вы можете добавлять в определение страницы. При добавлении страницы ее изображение добавляется в область изображения в окне редактора определения документа, а созданные на ней поля будут фигурировать в общем списке полей. В этом случае документ состоит из одного раздела, хотя он может содержать несколько страниц.

Добавлять страницы в один раздел следует, если в документе есть блоки, переходящие со страницы на страницу, повторяющиеся на разных страницах блоки, таблицы, переходящие на следующую страницу. Такой же способ используется при загрузке многостраничного гибкого описания (см. Создание определения для обработки гибких документов). Все поля гибкого описания должны относиться к одному разделу определения документа.

Для того чтобы добавить страницу в раздел, воспользуйтесь пунктом меню редактора определения документа Определение документа > Добавить страницы… или пунктом локального меню изображения Добавить страницы… После этого загрузите изображение новой незаполненной страницы и выберите типы объектов, которые должны быть отмечены на странице автоматически.

Добавление разделов

Другой способ заключается в добавлении к определению документа разделов. В наиболее простом случае один раздел содержит одну страницу. Так можно поступать, если наборы полей на страницах независимы. Такой способ более наглядный: в структуре документа видно, к какому разделу относятся поля, а также вы можете задать произвольную структуру сборки документа. Например, в вашем документе страницы трех типов, причем страницы первого и третьего типа содержатся в документе 1 раз, а страница второго типа может повторяться от 2 до 5 раз. Тогда нужно создать 3 раздела: для каждого типа страницы отдельный раздел, а потом задать структуру документа, то есть последовательность и количество повторений разделов.

Более сложный случай – определение документа, состоящее из нескольких разделов, причем некоторые разделы содержат более одной страницы. Это, например, определение, состоящее из жестких разделов и гибкого многостраничного раздела. Или определение для документов, содержащих двусторонний лист, который может повторяться несколько раз. Допустим, вам нужно создать определение документа, содержащего титульный лист (страницу A) и некоторое количество двусторонних листов (последовательность страниц BCBC…). Тогда создаем раздел A, состоящий из одной страницы A и раздел BC, состоящий из двух страниц B и С. Структуру документа зададим следующим образом: раздел A повторяется 1 раз, за ним следует раздел BC, повторяющийся, например, от 3 до 7 раз.

Для того чтобы добавить новый раздел, воспользуйтесь пунктом меню Определение документа > Добавить раздел документа… в окне редактора определения документа. Откроется мастер создания раздела, который поможет вам задать все необходимые параметры. Следуя инструкциям мастера, выполните следующие действия:

  • задайте название раздела;
  • загрузите изображение незаполненной страницы (отсканируйте или загрузите из файла) либо загрузите файл гибкого определения;
  • выберите типы объектов, которые будут отмечены автоматически.

Новый раздел и содержащиеся в нем поля отобразятся в окне структуры документа.

Дополнительные возможности

Для определения документа, состоящего из нескольких разделов, кроме последовательности и числа повторений разделов, можно задать проверку ключевых полей. Для этого в каждом разделе документа определяются ключевые поля, значения которых в разных разделах должны быть одинаковыми. Для добавления ключевого поля на несколько страниц одного раздела, создайте множественное поле и расположите экземпляры поля на разных страницах. В качестве ключевого поля можно взять, например, фамилию заполняющего документ, которую он должен написать на каждой странице, или некий идентификационный номер.

При обработке пакета программа пытается собрать в документы следующие друг за другом страницы, производя при этом проверку правил сборки. При выборе соответствующей опции будет произведена проверка значений ключевых полей. При несовпадении ключевых полей на страницах одного документа, появится сообщение об ошибке. Иногда это происходит из-за того, что страницы документов перепутаны при сканировании, и для выполнения правил сборки документов достаточно изменить порядок следования страниц. См. Сборка страниц в документы.

Также можно импортировать раздел из другого определения документа, входящего в проект. Для этого выберите в меню пункт Определение документа > Импортировать раздел документа… и выберите раздел в диалоговом окне Выберите определение раздела для импорта.

Замечание. При импорте разделов разделяемые скриптовые модули не импортируются. Это может приводить к тому, что скриптовые правила, написанные в новом разделе, станут неработоспособными или будут работать неправильно.

Просмотр и редактирование результатов

Для того чтобы просмотреть получившуюся структуру документа при создании определения, в окне Структура документа редактора определения документа перейдите на закладку Страницы. На ней представлена структура документа в режиме эскизов страниц. На этой закладке можно изменить количество вхождений разделов в документ (для этого введите новое значение – число или интервал – в квадрате справа от названия раздела), подключить страницы приложения, изменить порядок страниц в разделе и перенести страницы из одного раздела в другой простым перетаскиванием изображения страницы.

Для страниц, которые могут повторяться в разделе, отметьте опцию Может повторяться в разделе документа в свойствах страницы. Чтобы открыть диалог свойств страницы, выберите пункт Свойства... в локальном меню страницы или нажмите Alt+Enter.

Collapsed Показать окно структуры документа

Сборка страниц в документы

Для того чтобы задать последовательность и число повторений разделов, а также правило сборки, воспользуйтесь пунктом меню Определение документа > Свойства определения документа… в окне редактора определения документа.

На закладке Сборка задайте минимальное и максимальное число вхождений каждого раздела в документ (по умолчанию 1).

Если вы хотите проверять значения ключевых полей, отметьте опцию Использовать правило сборки по совпадению ключевых полей и выберите ключевое поле в каждом разделе.

Укажите, какие правила сборки должны использоваться. Вы можете использовать как стандартные, так и пользовательские правила сборки.

Стандартные правила сборки позволяют отключить проверку порядка разделов и включать в документы страницы приложений.Отключение проверки порядка следования разделов в документе (опция Отключить проверку порядка разделов) требуется, например, если порядок не важен для сборки документов. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет. Для того чтобы включать в сборку страницы приложений, отметьте опцию Допускать страницы приложений. Если вы хотите определять страницы приложений на основе структуры документа, отметьте соответствующую опцию.

Для того чтобы осуществлять сборку документа при помощи скрипта сборки, отметьте опцию Использовать пользовательские правила сборки. Для редактирования скрипта, нажмите кнопку Правка скрипта сборки…

Collapsed Показать закладку Сборка


Свойства определения документа

Основные свойства определения документа, такие как название, язык и стиль написания, задаются в процессе работы Мастера создания определения документа. Другие свойства определяются по умолчанию.

Просмотреть и изменить свойства определения документа можно в диалоге свойств, который открывается при выборе пункта меню определение документа>Свойства определения документа… в окне Редактора определения документа.

Диалог состоит из следующих вкладок:

Collapsed Вкладка Общие

На этой вкладке вы можете изменить название определения и ввести или отредактировать комментарий. Опция Включен включает/исключает определение из обработки документов.

Collapsed Вкладка Распознавание

На данной вкладке вы можете изменить общие свойства распознавания определения документа:

  • Язык (регион) – для правильного распознавания данных важно правильно задать используемый язык. Это свойство определяет как язык заполнения, так и другие локальные установки, такие как формат даты, валюты и др.
  • Стиль написания – стиль написания может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания. Если в списке поддерживаемых стилей есть стиль, название которого совпадает с языком документа, выберите этот стиль. Если такого стиля нет, выберите стиль Другие.

  • Задайте тип текста:

    ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;

    OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Вы можете изменить тип текста для отдельных полей, а указанный на этой вкладке тип будет использоваться по умолчанию.

  • Вы можете отметить одну или несколько опций из группы Возможные положения страниц, для того, чтобы при автоматическом подборе ориентации страницы, она поворачивалась на 180°, 90° по часовой стрелке или 90° против часовой стрелки.
  • Нажмите на кнопку Расширенные настройки…, чтобы настроить исправление линейных и нелинейных искажений изображения.

    Замечание. Отметьте опцию Исправлять линейные искажения, чтобы указать параметры растяжения/сжатия изображений по высоте и ширине. Масштабирование изображений выполняется по имеющимся реперам (черный квадрат, крестик или уголок), а также горизонтальным и вертикальным разделителям.

  • Хранить полный текст документа - отметьте эту опцию, чтобы при заполнении значений полей в процессе верификации можно было использовать распознанные данные из сохраненного текста документа.
Collapsed Вкладка Сборка

Эта вкладка предназначена для задания правил сборки многостраничных документов.

В самом простом случае определение документа состоит из одного раздела, повторяющегося один раз. Если определение документа состоит из нескольких разделов, список их названий отображается на данной вкладке. Вы можете задать количество повторений каждого раздела, изменив цифры в столбцах Минимальное количество и Максимальное количество.

  • Использовать правило сборки по совпадению ключевых полей – отметьте эту опцию, если вы хотите осуществлять проверку сборки документов по ключевым полям. Затем в столбце Ключевое поле выберите ключевое поле для каждого раздела. При вводе документов, правильно собранными будут считаться документы, у которых совпадают значения ключевых полей в каждом разделе. При несовпадении значений, будет выдано сообщение об ошибках сборки.
  • Использовать стандартные правила сборки - отметьте эту опцию, если вы хотите осуществлять проверку сборки документов с использованием следующих стандартных правил:
    • Отключить проверку порядка разделов - отметьте эту опцию, если вы хотите отключить проверку порядка следования разделов в документе. Отключение такой проверки требуется, например, если порядок следования разделов не важен для сборки документов. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет.
    • Допускать страницы приложений – отметьте эту опцию, если вы хотите обрабатывать документы с приложениями. Если разрешена обработка документов с приложениями, можно также отметить опцию Определять приложения на основе структуры документа, без анализа (быстро) для более быстрого определения страниц приложений на основе структуры документа.

      Замечание. Опция Определять приложения на основе структуры документа, без анализа (быстро) применяется только для документов, исключенных из сборки. Документы исключаются из сборки в случае, если они были получены путем разделения на этапе импорта либо с помощью API с использованием специального флага.

  • Использовать пользовательские правила сборки - отметьте эту опцию, если вы хотите осуществлять проверку сборки документов, используя скрипт сборки документа. Пользовательский скрипт сборки может выполняться как отдельно, так и совместно со стандартной проверкой сборки. Для редактирования скрипта нажмите кнопку Правка скрипта сборки…. Откроется окно редактора скрипта.

Подробнее см. Создание определений для многостраничных документов, Сборка страниц в документы и Создание определений для документов с приложениями.

Collapsed Вкладка Правила

Эта вкладка предназначена для работы с правилами определения документа. Вы можете удалять, редактировать и создавать новые правила.

Подробнее см. Проверка с помощью правил.

Collapsed Вкладка Экспорт

На этой вкладке отображаются текущие настройки экспорта данного определения документа. Для изменения настроек экспорта нажмите кнопку Изменить…

Подробнее см. Настройка экспорта данных.

Collapsed Вкладка Форма данных

На этой вкладке можно изменить начертание и размер шрифта для отображения распознанных данных.

В группе Параметры текста данных – настройки шрифта для отображения распознанных значений.

В группе Параметры текстовых меток – настройки для отображения пояснительного текста (названий полей).

Подробнее см. Настройка отображения данных в окне документа.

Collapsed Вкладка Наборы данных

На этой вкладке можно определить наборы пользовательских данных.

Collapsed Вкладка Обработчики событий

На этой вкладке можно определить обработчики событий для документов текущего типа.

Подробнее см. Обработчики событий.

Collapsed Вкладка Сборки .Net

На этой вкладке можно подключать внешние сборки, которые могут использоваться в скриптах и глобальных модулях. Можно использовать как стандартные, так и откомпилированные пользовательские сборки. Для добавления сборки нажмите Добавить…. В открывшемся диалоговом окне укажите тип: Стандартное имя сборки или Путь к прикрепленному файлу. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки.

Подробнее см. Особенности .Net скриптов.


Мастер создания определения документа

Для создания нового определения документа выберите пункт основного меню Проект>Определения документов… и в диалоге Определения документов нажмите кнопку Новое… Откроется Мастер создания нового определения документа.

  1. В диалоге Создание нового определения документа задайте основные свойства определения документа: название и комментарий, используемый язык (Язык (регион)) и стиль написания (Стиль написания). По умолчанию, выпадающий список содержит только языки со словарной поддержкой. Чтобы выбрать язык без словарной поддержки, отметьте опцию Показать все. Очень важно правильно задать язык: от этого зависит правильность распознавания документов. Стиль написания тоже может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания.

    Collapsed Показать примеры разных стилей написания цифр
    - русская двойка
    - американская двойка
    - "обычная" пятерка – может встретиться в любом стиле
    - японская пятерка
    - русская единица
    - немецкая единица
    - "обычная девятка" – может встретиться в любом стиле
    - чешская девятка с кольцом справа
    - американская девятка без "крючка" внизу

    Задайте тип текста:

    • ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;
    • OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Позже вы сможете изменить тип текста для отдельных полей, а указанный на данном этапе тип будет использоваться по умолчанию.

    Нажмите кнопку Далее (Next) для перехода к следующему шагу.

  2. На втором шаге добавьте изображение страницы вашего документа для создания определения документа. Вы можете отсканировать изображение незаполненной страницы или загрузить его из файла.

    Замечание. Определение для жестких форм создается на основе изображения, полученного при сканировании незаполненной формы. Это изображение должно быть хорошего качества, без искажений (не содержать перекосов, сдвигов и т.д.). Для цветных фоновых форм при создании определения следует использовать страницы, отсканированные без применения фильтров, так, чтобы фон не исчезал при сканировании. (Позже, когда вы будете сканировать изображения страниц для распознавания данных, вы выберете режим сканирования, при котором фон пропадает).

    Если ваш документ состоит из нескольких страниц, то загрузите первую страницу, а для добавления остальных руководствуйтесь рекомендациями раздела Создание определения для многостраничного документа.

    Если вам нужно использовать гибкое описание, созданное в программе ABBYY FlexiLayout Studio, то отметьте опцию Загрузить гибкое описание и введите путь к файлу, содержащему гибкое описание. Подробнее см. Создание определения для обработки гибких документов.

    Нажмите кнопку Далее (Next).

  3. На следующем шаге выберите типы полей, которые должны быть найдены на изображении автоматически. Вы можете отметить метки и текстовые поля ввода, особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

    Замечание. Автоматический поиск реперов производится всегда. Если на форме есть реперы, то они будут найдены и отмечены на изображении.

    Нажмите кнопку Готово (Finish).

После окончания работы Мастера создания определения документа откроется окно Редактора определения документа, в котором выполняются дальнейшие действия по созданию определения. На следующем этапе создания определения нужно разметить поля и статические элементы на изображении страницы и определить их свойства.


Определения документов

Создание определения документа – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Работа с определениями документов доступна только в режиме администратора.

Определение документа определяет расположение элементов документа, указывает, откуда будут извлечены данные. При создании определения документа определяются свойства полей, их область значений. Задаются также настройки экспорта данных.

Для начала создания определения документов запустите Мастер создания определения документа:

  1. В главном меню ABBYY FlexiCapture выберите пункт Проект>Определения документов…
  2. В открывшемся диалоге Определения документов нажмите кнопку Новое…
  3. Следуйте инструкциям Мастера создания определения документа.
Мастер создания определения документа
Автоматическое выделение полей и статических элементов
Статические элементы
Создание полей определения документов
Свойства полей
Проверка с помощью правил
Настройка экспорта данных
Настройка отображения данных в окне документа
Свойства определения документов
Импорт определения документа для форм, созданных в программе ABBYY FormDesigner
Создание определений для многостраничных документов
Создание определения для обработки гибких документов
Создание определений для документов с приложениями
Обработка неструктурированных документов
Редактирование и публикация определения документа
Тестирование определения документа
См. "Локализация определения документа"


Тестирование определений документов

Прежде чем приступать к массовому вводу документов, необходимо протестировать определения документов. Тестирование производится на документах, добавляемых в тестовые пакеты, т.к. эти пакеты работают с локальной версией определения. Эти пакеты доступны из меню Вид>Тестовые пакеты главного окна программы. Также к ним можно перейти из окна редактора определения документа, выбрав пункт меню Пакет>Режим тестовых пакетов….

Внимание! С тестовыми пакетами может работать только пользователь, создавший их. При необходимости, роль постоянных тестовых пакетов могут играть рабочие пакеты, используемые как источник изображений для тестового пакета.

Тестировать определение документа можно прямо в редакторе определения документа, на том изображении, которое используется для создания определения. Чтобы начать тестирование, выберите пункт меню Тестирование>Начать тестирование. Форма данных отобразится также, как и при обработке документов, будут показаны форматные ошибки, неуверенно распознанные символы и ошибки правил.

Для удобного расположения окон при тестировании воспользуйтесь меню Тестирование>Вид, а для навигации между объектами верификации, неуверенно распознанными символами и ошибками правил, меню Тестирование>Верификация. Для выхода из режима тестирования нажмите на кнопку Закончить тестирование документа или выберите пункт меню Тестирование>Закончить тестирование.

Замечание. В режиме тестирования перемещение разметки поля в окне изображения не приводит к перераспознаванию поля, как это происходит при работе в окне документа.

Для тестирования определения на других изображениях нужно выбрать тестовый пакет, перейти к нему можно из редактора определения документа, выбрав пункт меню Пакет>Режим тестовых пакетов…. Перед вызовом диалога выбора тестового пакета происходит проверка правильности определения документа. В случае если ошибок нет, определение сохраняется и вызывается диалог выбора тестового пакета. При выборе какого-либо пакета происходит переключение на этот пакет в главном окне программы (главное окно становится активным).

Замечание. При необходимости документы можно копировать или перемещать между пакетами. При этом сохраняется вся информация о документе: наложенное определение документов, распознанные данные. Чтобы скопировать или переместить документы (например, из рабочего пакета в тестовый для отладки ), выделите их в списке при просмотре содержимого пакета и нажмите сочетание клавиш Ctrl+C (для копирования) или Ctrl+X (для перемещения), кнопку [image] или [image] панели инструментов либо воспользуйтесь подпунктами Копировать или Вырезать пункта меню Правка. Далее откройте пакет, в который нужно скопировать или переместить документы и нажмите сочетание клавиш Ctrl+V, кнопку [image] панели инструментов или выберите в главном меню пункт Правка>Вставить.

Рекомендуется проверить каждое определение не менее, чем на 20 изображениях документов (если документы заполняются от руки, то желательно, чтобы они были заполнены разными людьми).

Тестирование необходимо для того, чтобы выяснить:

  1. Достаточно ли выделенных реперов и идентификаторов для уверенного наложения определения документа на изображения.
  2. Корректно ли заданы свойства полей.
  3. Корректно ли заданы правила.
  4. Корректно ли настроен экспорт.

При тестировании должна быть проделана вся последовательность действий, выполняемая при обработке документов.

Если в результате тестирования были обнаружены ошибки в правилах, некорректно заданные значения свойств полей и т.д., то для их исправления необходимо отредактировать определение.

Только после устранения всех найденных проблем можно опубликовать определение документа и приступать к массовому вводу документов.

Работа оператора с настроенным проектом


Исключение региона из распозавания

Исключение региона из распознавания

Иногда бывает необходимо исключить из распознавания некоторую область, например, область с пояснительным текстом, который мешает извлечению данных из поля.

Чтобы исключить регион из распознавания, выберите инструмент [image] и выделите с помощью мыши область, которую нужно исключить.


Обработка неструктурированных документов

Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, приложения, то и в этом случае поможет ABBYY FlexiCapture. Неструктурированные документы с текстом или изображениями, разделенные пустыми страницами или страницами со штрих-кодом, обрабатываются и экспортируются в PDF файлы с возможностью поиска или в файлы графических форматов.

Обработка таких документов обычно состоит в том, чтобы перевести документы в электронный вид и организовать их поиск по значениям ключевых полей.

Если возможно, поиск ключевых полей (например, номер контракта) на таких документах производится с помощью гибкого описания, созданного в приложении ABBYY FlexiLayout Studio. См. Создание определения для обработки гибких документов.

Если автоматический поиск ключевых полей невозможен, то их значения могут вводиться вручную оператором. Для этого создайте определение документа с одним полем (или с несколькими полями, если нужно), и в свойствах распознавания этого поля (полей) отметьте опцию Не распознавать значение поля, оно будет введено вручную. В этом случае при запуске процесса верификации оператору будет предложено ввести значения ключевых полей вручную.

Для хранения документов нужно настроить экспорт: значения ключевых полей вы можете экспортировать в файл или базу данных, а изображения документов сохранить в удобном для вас формате. Вы можете сохранять изображения документов в графических файлах или в PDF с возможностью поиска.

Обратите внимание на сборку страниц в документы: для неструктурированных документов бывает сложно определить, к какому документу относится та или иная страница. Для автоматизации сборки неструктурированных документов рекомендуется разделять документы чистыми страницами или страницами со штрих-кодами. Тогда при добавлении изображений в пакет (путем сканирования, добавления из файлов или при создании профиля импорта) нужно отметить опцию Для изображений, разделенных и выбрать из выпадающего списка значение пустыми страницами или страницами со штрих-кодом в зависимости, от того, какие страницы используются в качестве разделителя. Сборка страниц в документы будет произведена автоматически: страницы будут добавляться в текущий документ, пока не встретится страница-разделитель. Подробнее см. Добавление изображений страниц.