Acerca de ABBYY FlexiCapture 8.0 Professional

ABBYY FlexiCapture 8.0 Professional es una solución de software para la introducción automática de datos de documentos impresos en bases de datos y sistemas de información.

Mediante el empleo de tecnologías avanzadas de reconocimiento de caracteres escritos a máquina y manuscritos, así como de procesamiento de imágenes y análisis de documentos, ABBYY FlexiCapture 8.0 Professional ofrece la conveniente extracción automatizada de información significativa de todo tipo de documentos que se procesan en un flujo único: formas estructuradas (fijas), semiestructuradas (documentos y formas flexibles) y documentos sin estructura de formato libre. ABBYY FlexiCapture 8.0 Professional evita la necesidad del procesamiento ineficaz y trabajoso que conlleva ordenar y volver a imprimir la información de los documentos de forma manual.

El escenario básico de procesamiento de documentos es el siguiente:

  1. Los documentos se colocan en el alimentador automático del escáner y comienza la digitalización.
  2. Las imágenes digitalizadas del documento se envían para el reconocimiento; en ese momento, el software identifica automáticamente los documentos, incluidos los documentos de varias páginas, ubica los campos significativos, extrae los datos y carga las reglas de comprobación.
  3. De ser necesario, después del reconocimiento se realizará la verificación visual de datos y la comprobación de errores de regla.
  4. Los datos reconocidos y verificados junto con las copias electrónicas de los documentos se guardan en una base de datos, un sistema de información o un archivo.


Comparación entre las nuevas funciones de ABBYY FlexiCapture 8.0 Professional y FormReader 6.5 Desktop

Tipos de documentos procesados

Documentos de varias páginas con una estructura compleja

El programa permite el procesamiento y la identificación automática de documentos estructurados, semiestructurados y sin estructura con una cantidad variable de páginas, páginas recurrentes y documentos con adjuntos.
Tipos de documentos procesados con ABBYY FlexiCapture 8.0
Creación de plantillas para documentos de varias páginas
Creación de plantillas para documentos con adjuntos

Documentos sin estructura

Los documentos sin estructura con texto o imágenes separados por páginas en blanco, páginas con código de barras o código de revisión se indexan con la ayuda de plantillas simples, procesadas y exportadas a archivos PDF para búsquedas o a archivos de gráfico.
Procesamiento de documentos sin estructura

Documentos semiestructurados de varias páginas con tablas complejas o tablas de varias páginas

Los documentos semiestructurados de varias páginas con tablas continuas de una página a otra se identifican, se ensamblan en documentos y se procesan con la ayuda de una descripción flexible única.
Creación de una plantilla para el procesamiento de documentos flexibles

Formularios fijos con tablas

Para simplificar el procesamiento de documentos que contienen tablas, el programa ahora admite tablas en los formularios fijos.
Creación de una tabla

Elementos recurrentes

El programa admite los grupos de campos recurrentes en documentos estructurados y semiestructurados. Esto simplifica el proceso de configuración del procesamiento de documentos con grupos de elementos idénticos que se repiten varias veces, tal como el procesamiento de tablas complejas con ese tipo de grupos.
Creación de un grupo de campos

Arquitectura del programa

Modos de administrador y operador

Los modos de administrador y operador se habilitan al seleccionar diferentes comandos en el menú Inicio. Pueden instalarse en diferentes ordenadores. Todas las funciones del programa están disponibles en el modo de administrador. En el modo de operador, el usuario no puede editar plantillas de documento, importar perfiles ni obtener acceso a los lotes de prueba.
Modos de administrador y operador

Trabajo con proyectos

Un proyecto es un entorno único de unión de lotes de documentos y la configuración necesaria para procesarlos, como las plantillas de documento, los perfiles de importación y otros elementos semejantes.

Diferentes copias del programa pueden usar un proyecto: un proyecto se puede exportar e importar como un objeto único; un proyecto se puede actualizar o transferir de un ordenador a otro. Las diferentes estaciones de trabajo pueden trabajar con los mismos proyectos en una red, lo que posibilita la racionalización del procesamiento de documentos.
Creación de un proyecto
Propiedades del proyecto

Herramientas prácticas para el trabajo con procesos en segundo plano

Las operaciones que demandan mucho tiempo, como la adición de imágenes, el reconocimiento o la exportación, pueden realizarse en el modo en segundo plano, que reduce significativamente el tiempo de procesamiento de documentos. El usuario siempre puede comprobar el estado de cualquier proceso en segundo plano, cambiar las prioridades de las tareas y visualizar el registro de procesamiento.

Modo en segundo plano

Editor de plantillas de documento

Trabajo al nivel del documento

Las plantillas se crean para todo el documento como unidades de procesamiento y se denominan plantillas de documento. Una plantilla de documento determina el modo en que se identifican y se procesan los documentos de un tipo relevante. Cada plantilla de documento incluye imágenes de página, reglas de ensamblaje, descripciones de campos y elementos estáticos, reglas de verificación, configuración de verificación, descripciones de los tipos de datos y configuración de la exportación de datos.
Creación de plantillas para documentos de varias páginas

Cambio entre modos de imagen

A través del editor de plantillas, ahora puede alternar entre dos modos de imagen: puede visualizar imágenes del color original y en blanco y negro, independientemente del formato en el que se agregan las imágenes al lote. Una imagen en color simplifica la creación de plantillas para formularios de color, ya que en este modo puede ver la marcación de campos y el texto explicativo: esto es necesario para trazar la región del campo y para asignarle un nombre al campo. La visualización de las imágenes en blanco y negro es importante para garantizar que los delimitadores y el texto estático estén visibles después de que se realice la binarización en el proceso de reconocimiento.

Editor de formulario de datos

El editor de formulario de datos facilita la tarea de crear una presentación personalizada de datos extraídos y de visualizar estos datos de la manera más conveniente para el operador.
Configuración de la presentación de datos en la ventana del documento

Presentación de campos en forma de árbol

La estructura de documentos se presenta gráficamente en forma de árbol de campos. Esta forma de presentación de campos le permite editar, copiar, eliminar y mover campos rápidamente.
Presentación de la estructura de documentos en forma de esquemas de páginas

La estructura de documentos se presenta convenientemente como esquemas de páginas. Esto facilita la visualización, la edición y la creación de plantillas para documentos de varias páginas.
Visualización de campos y elementos estáticos por separado

Los campos y los elementos estáticos se muestran por separado. Este tipo de presentación de campos y elementos estáticos facilita la creación de plantillas. Este proceso puede dividirse en dos etapas: los elementos estáticos se crean por separado, mientras que los delimitadores, los separadores, el texto del delimitador y los códigos de barras no interfieren con la creación de las regiones del campo.

Creación de campos de una plantilla de documento
Elementos estáticos
Agrupamiento de campos

Los campos pueden combinarse en grupos para habilitar una presentación clara de las estructuras de documentos y la creación de grupos de campos recurrentes.

Creación de un grupo de campos
Propiedades de un grupo de campos
Tablas en plantillas fijas

Ahora, puede crear un campo de tabla en plantillas fijas y, de esa manera, simplificar considerablemente la configuración, la extracción de datos y la exportación de datos de las tablas. Un campo de tabla es un conjunto de columnas del mismo tipo y líneas recurrentes.

Creación de una tabla
Propiedades de la tabla
Elementos recurrentes en plantillas fijas

Los elementos recurrentes son campos o grupos de campos que aparecen en el formulario una determinada cantidad de veces y que describen objetos similares, tales como los mismos detalles de varios empleados, niños, cuentas, etc. La estructura de estos elementos recurrentes es similar a la de una tabla: un conjunto de campos representa una columna, mientras que cada repetición es una fila de tablas. El editor de plantillas de documento simplifica la configuración y el procesamiento de estos campos.

Campos con varias instancias
Campos ubicados en varias páginas de un formulario

Si su formulario tiene varios campos cuyas regiones se ubican en varias páginas (por ejemplo, en tablas largas), el editor de plantillas de documento le permite visualizarlas como un campo único y, de esa manera, simplifica ampliamente la configuración y el procesamiento.

Campos con varias regiones
Creación automatizada de plantillas fijas

El editor de plantillas le ofrece nuevas herramientas que automatizan y simplifican la creación de plantillas fijas:

  • identificación automática de campos de texto con una región;
  • identificación automática de separadores verticales y horizontales en tablas;
  • identificación automática de un campo con un solo clic de un botón del ratón en la región del campo;
  • asignación automática de un nombre de campo que coincida con el texto explicativo más próximo;
  • reconocimiento y copia del texto estático de la imagen de la plantilla a las propiedades del campo;
  • ajuste automático de los perímetros del campo
Detección automática de campos y elementos estáticos
Cómo cambiar un nombre de campo
Mejoras en la configuración de los tipos de datos

Hemos elaborado la configuración de los tipos de datos para simplificar la creación de las plantillas de documento y mejorar la extracción y la verificación de los datos de los campos. Los tipos de datos utilizados con mayor frecuencia (texto, fecha y hora, moneda, número) se incluyen en el conjunto de tipos de datos previamente configurados. A su vez, los formatos más utilizados de los tipos de datos previamente configurados están incluidos en el conjunto de formatos previamente configurados y pueden seleccionarse en la lista sin necesidad de crear reglas complejas para la verificación de formatos.
Tipos de datos del campo de entrada de texto
Creación de tipos de datos personalizados

Descripción de reglas de verificación a través del idioma JScript®

Las reglas de verificación ahora pueden describirse como scripts con el idioma JScript® (además del idioma VBScript). Esto le permite configurar cualquier regla personalizada para la verificación de datos extraídos.
Regla configurada con la ayuda de un script
Uso de scripts para crear reglas

Campos de índice

Si se habilita la opción Campo Índice en las propiedades del campo, los valores de ese campo pueden visualizarse en forma de una columna adicional en la ventana del lote de documentos. Los documentos pueden clasificarse según el valor de este campo. Durante la exportación, los valores de los campos de índice pueden agregarse a los nombres de los archivos, lo que facilita la búsqueda de la información necesaria.
Campos de índice
Reglas de denominación para los archivos de exportación

Estados adicionales de las plantillas de documento

Cuando abre una plantilla de documento en el editor de plantillas, se crea automáticamente una versión local temporal de la plantilla. Esta versión editable no está incluida en el procesamiento de documentos hasta que se publica. Esta funcionalidad le permite organizar el trabajo con plantillas en proyectos separados.
Edición y publicación de una plantilla

Prueba de plantillas de documento en lotes especiales del editor de plantillas

Para simplificar y acelerar la creación de plantillas, las plantillas editables pueden probarse durante el proceso de creación sin necesidad de salir del editor de plantillas de documento. Se puede probar una plantilla mientras se la está creando, en la imagen que se utiliza para crear la plantilla. Para llevar a cabo esta prueba, se pueden utilizar lotes de prueba especiales que no se utilizan para el procesamiento real de documentos.
Prueba de las plantillas de documento
Lotes de documentos

Importación de imágenes

Ensamblaje automático de páginas en documentos

El flujo entrante de imágenes desde el escáner o la carpeta dinámica puede dividirse automáticamente en documentos, cuando utiliza:

  • formatos de imagen de varias páginas, tales como TIFF o PDF
  • páginas en blanco, páginas con códigos de barra o códigos de revisión
Adición de imágenes de página
Opciones de procesamiento previo de imágenes
Perfiles de importación de imágenes

Los perfiles de importación de imágenes se usan para crear conjuntos de ajustes previamente configurados para varios orígenes de importación de documentos (escáneres o carpetas). Se guarda un perfil de importación y se le asigna un nombre, que el operador puede seleccionar de una lista luego.
Perfiles de importación de imágenes

Importación con un solo clic

La importación de imágenes según la configuración del último perfil usado puede realizarse con un solo clic.
Adición de imágenes de página

Modo de importación en segundo plano

La importación puede realizarse en el modo en segundo plano. El programa busca nuevas imágenes en la carpeta dinámica a intervalos específicos.

Modo en segundo plano

Clasificación, aplicación de plantillas, reconocimiento

Reconocimiento de texto completo para la exportación a un archivo PDF para búsquedas

El programa admite un escenario de reconocimiento de documento de texto completo con la exportación subsiguiente a archivos PDF y PDF\A para búsquedas. Esto es particularmente cuando se deben archivar documentos sin estructura y semiestructurados.
Nuevos idiomas de reconocimiento

Kirguiz (OCR e ICR)

Kazako (OCR e ICR)

Tailandés (OCR)

Idiomas de reconocimiento compatibles

Nuevos tipos de códigos de barras

Matriz 25, Industrial 25, PostNet.

Tipos de códigos de barras compatibles
Ubicación de caracteres corregidos en formularios fijos

Si se eliminó un carácter introducido por error, se lo presenta al operador durante el proceso de verificación para permitirle introducir el carácter correcto de forma manual.
Capacidad para eliminar páginas del separador

Las páginas con códigos de barras, las páginas con códigos de revisión y las páginas en blanco que se usan como hojas del separador pueden eliminarse automáticamente del lote.

Opciones de procesamiento previo de imágenes
Capacidad para eliminar páginas en blanco

Las páginas en blanco pueden eliminarse durante el proceso de reconocimiento.

Propiedades del proyecto

Verificación de datos

Mejoras en la interfaz de verificación
  • Modo de pantalla completa.
  • La barra de estado muestra el porcentaje actual de caracteres verificados.
Verificación de datos reconocidos
Nuevas posibilidades de configuración de la interfaz
  • Puede cambiarse la ubicación de la ventana que tiene la imagen del campo.
  • Puede cambiarse la escala de la ventana. También hay una función para la selección automática de la mejor escala.
  • El usuario puede cambiar el tamaño de fuente de los caracteres.
Verificación de datos reconocidos
Mejoras en la verificación de grupo
  • Sugerencia emergente con el contexto de caracteres.
  • Tamaño y contraste configurables en el área adyacente al carácter.
Verificación de grupo
Mejoras en la verificación de campo
  • Las reglas de formato ahora se pueden comprobar durante el proceso de verificación de campo. El usuario ve una descripción del error y tiene una lista de cambios propuestos para el valor.
  • Ahora, se ofrece un nuevo modo de visualización de campos con corte de caracteres.
  • Se admiten los campos de varias líneas.
  • Sugerencias emergentes para caracteres que simplifican la comprensión, por ejemplo, la letra "O" y el número "0".
Verificación de campo
Reconocimiento de campo al instante

Durante el proceso de verificación en la ventana del documento, cada cambio en los perímetros de la región del campo implica un nuevo reconocimiento automático de la región de la imagen correspondiente. Esta funcionalidad simplifica y acelera la extracción de los datos de los campos cuyas regiones se especificaron de manera incorrecta.
Interfaz mejorada para la corrección de errores de regla
  • Cada regla de la lista de errores de regla está acompañada de una referencia al campo correspondiente. Estas referencias le permiten ir rápidamente a los campos con posibles errores.
  • La lista de reglas de error puede acoplarse en la parte inferior, superior, derecha o izquierda de la ventana del documento.
Validación de regla
Corrección de errores de ensamblaje de documentos en el modo de esquema de la página

Está disponible un nuevo modo de esquema de páginas para los documentos del lote. Este modo es muy práctico para la corrección de errores de ensamblaje de documentos y permite al usuario:

  • ver los esquemas de páginas agrupados por documentos
  • ver la falta de coincidencia entre los valores de los campos clave y las descripciones de los errores de ensamblaje
  • corregir errores de ensamblaje moviendo las páginas de un documento a otro, arrastrando y soltando páginas con la ayuda del ratón
  • cambiar la escala de esquemas de páginas para ver los detalles (para hacerlo, debe mantener pulsada la tecla Ctrl y utilizar la rueda del ratón)
Ensamblaje de páginas en documentos
Los archivos PDF protegidos con contraseñas ahora se pueden abrir

Ahora, se pueden agregar archivos DjVu
Formatos de gráficos compatibles

Exportación

Exportación a Microsoft SharePoint

Ahora, puede configurar la exportación a Microsoft SharePoint mediante el uso de la interfaz del programa.

Exportación de datos a la biblioteca de documentos de SharePoint
Exportación con un solo clic

Si se estableció la configuración de exportación, se puede exportar un lote de documentos con un solo clic. De esa manera, el operador no tiene la necesidad de realizar otras acciones y se acelera el proceso de entrada de documentos.

Exportación de datos reconocidos
Exportación de imágenes del documento junto con los datos

Junto con la exportación de datos, se pueden exportar imágenes de los documentos relevantes.
Reglas útiles para la denominación de los archivos obtenidos

Al exportar datos a un archivo de Microsoft SharePoint, los nombres de los archivos se generan automáticamente de acuerdo con las reglas definidas por el usuario. Puede anexar los valores de los campos de índice a los nombres de los archivos, el valor de los códigos de barras de las páginas del separador, etc. Los nombres de los archivos significativos facilitan la búsqueda de la información necesaria.
Reglas de denominación para los archivos de exportación

Nuevos formatos de imagen y documentos

PDF, PDF/A para búsquedas

Formatos de gráficos compatibles
Vinculación de campos durante la exportación a una base de datos

La configuración de la exportación a una base de datos está acompañada de una práctica interfaz para vincular campos; de esta manera, el usuario puede realizar la asociación de campos de documentos con los campos de la base de datos rápidamente.

Exportación a la base de datos
Exportación descrita con un script

El usuario puede describir cualquier procedimiento de exportación con los idiomas de scripting VBScript y JScript.

Exportación descrita con un script
Uso de scripts para describir la exportación
Cambio de la resolución de la imagen durante la exportación

La resolución de las imágenes exportadas puede modificarse para adaptarse a los requisitos de almacenamiento.

Configuración de exportación de datos
Exportación de imágenes a archivo

La imagen del documento completo o de un campo de imagen individual se puede exportar a un archivo de gráfico independiente.
Eliminación de documentos exportados del lote

Si no necesita almacenar los documentos exportados en el lote, puede eliminarlos inmediatamente después de la exportación.

Exportación de datos reconocidos
Opciones adicionales


Tipos de documentos procesados con ABBYY FlexiCapture 8.0

ABBYY FlexiCapture 8.0 Professional es una solución de software para la captura de datos de flujo único desde documentos de distintos tipos.

Pueden procesarse varios documentos en un flujo único. También puede configurar el programa para procesar documentos de tipos mixtos, por ejemplo, documentos que contienen secciones estructuradas y semiestructuradas. El tipo de documentos solo afecta la configuración del sistema, particularmente, el método de creación de plantillas de documento. La naturaleza del trabajo del operador no se ve afectada por el tipo de documentos procesados.

ABBYY FlexiCapture puede configurarse para el ingreso automático de los siguientes documentos, incluso en un flujo único:

Formularios fijos estructurados
Los formularios estructurados son documentos que tienen un conjunto de campos de información marcados cuyo formato, número y diseño no cambian de una instancia del documento a otra. Estos documentos se denominan formularios fijos. Por ejemplo, la mayoría de los formularios de solicitud y los cuestionarios son formularios fijos. Por lo general, estos formularios se distribuyen como formularios en blanco y se completan a mano.

Si desea identificar un formulario fijo en un flujo de documentos y extraer datos de él, debe crear un diseño fijo único que informe al programa acerca de la ubicación de los campos que contienen los datos que se extraerán.

Los formularios fijos que se crearon para cumplir con los requisitos de ingreso automático se pueden procesar con más eficacia. Estos formularios se denominan formularios legibles por máquina. Para obtener más información acerca de los requisitos para los formularios y los métodos de creación mencionados, consulte la sección Creación de formularios legibles por máquina.

El programa incluye una práctica herramienta para diseñar formularios legibles por máquina: ABBYY FormDesigner 8.0 (suministrado junto con ABBYY FlexiCapture 8.0 Professional). Puede obtener información acerca del diseño de formularios con la ayuda de ABBYY FormDesigner 8.0 en el Manual del usuario y los temas de la Ayuda.

Se describen específicamente las etapas básicas de la creación de una plantilla para documentos estructurados.
Documentos y formularios flexibles semiestructurados
Estos son documentos que contienen un conjunto de campos de información cuyo diseño, número y distribución pueden variar significativamente en diferentes instancias del documento. Estos documentos se denominan flexibles. Por ejemplo, las facturas son documentos flexibles, ya que suelen presentar variaciones en la cantidad de elementos y el formato debido a que se reciben de diferentes empresas. Todas las facturas tienen un número de factura y un monto de pago determinado, pero se ubican en diferentes lugares.

Para identificar formularios flexibles y extraer datos de ellos, ABBYY FlexiCapture 8.0 Professional utiliza un diseño flexible (FlexiLayout). El diseño flexible se crea con la ayuda de un módulo especial llamado ABBYY FlexiLayout Studio. Los detalles de este módulo están disponibles en el Manual del usuario y en los temas de la Ayuda.

El procesamiento de los documentos flexibles se diferencia del procesamiento de los formularios fijos únicamente en la etapa de creación y carga de un diseño. Para obtener más detalles, consulte Creación de una plantilla para el procesamiento de documentos flexibles.
Documentos sin estructura con diseño de estilo libre
ABBYY FlexiCapture 8.0 Professional puede utilizarse para procesar documentos sin estructura que incluyen información presentada en un estilo libre; por ejemplo, contratos, cartas, solicitudes y gráficos. El programa puede identificar automáticamente documentos sin estructura como adjuntos a las formas fijas o flexibles, o puede identificarlos con la ayuda de un diseño flexible y luego exportarlos como archivos PDF para búsquedas o archivos de gráfico. Puede extraer automáticamente archivos de índice de los documentos sin estructura con la ayuda de un diseño flexible y mediante el ingreso manual.

Un escenario típico para el procesamiento de documentos sin estructura se presenta cuando es necesario convertir un archivo impreso al formato electrónico y hay un requisito para extraer dos o tres campos de índice para organizar una búsqueda rápida basada en atributos.

Para obtener detalles, consulte Procesamiento de documentos sin estructura.


Breve descripción del procesamiento de documentos con ABBYY FlexiCapture 8.0 Professional

Esta sección ofrece una descripción general de la forma en que se procesan los documentos con ABBYY FlexiCapture 8.0 Professional.

El proceso de utilización del programa se describe más detalladamente en las secciones Configuración del programa y Operaciones con un proyecto configurado.

Descripción general de la configuración del programa para el procesamiento de documentos
Descripción general de las operaciones con un programa configurado


Descripción breve de la configuración del programa para el procesamiento de documentos

El administrador configura el programa para procesar ciertos tipos de documentos. A fin de preparar el programa para el procesamiento de documentos, debe crear:

  1. Un proyecto

    Un proyecto incluye todas las configuraciones para procesar un tipo de documento determinado: perfiles de importación de imágenes, plantillas de documento y lotes del documento para procesamiento.

  2. Una o varias plantillas de documento

    La creación de una plantilla es la etapa más crítica en la configuración de un proyecto. Si planea procesar varios tipos de documentos en un flujo único, debe crear varias plantillas como parte de un único proyecto.

  3. Perfiles de importación de imágenes

    Los perfiles de importación se crean para su conveniencia y para optimizar el trabajo de los operadores. Si no se configuran los perfiles de importación, cada vez que agregue imágenes debe seleccionar el origen de importación y establecer la configuración. Los perfiles de importación le permiten agregar imágenes con un solo clic y alternar fácilmente entre los orígenes de importación.

  4. Un lote de documentos

    Los documentos enviados para que se los procese se agregan a los lotes. El principio de asignación de documentos a los lotes está definido por el usuario: puede procesar todos los documentos en un único lote o formar lotes a partir de documentos agregados en la misma fecha o a partir de un lote digitalizado en una sola pasada. Si agrega imágenes para las que no hay lotes, se creará automáticamente un lote.

Obtenga más información sobre la configuración del programa


Creación de un proyecto

Para procesar diferentes documentos como parte de un proyecto único, el proyecto debe tener varias plantillas. Si los flujos de documentos no se cruzan y su configuración de procesamiento varía considerablemente, puede crear proyectos independientes para estos.

Para comenzar, necesita crear al menos un proyecto.

Al ejecutar el programa, se abrirá el cuadro de diálogo Abrir proyecto que le permitirá seleccionar un proyecto existente o crear uno nuevo al hacer clic en Crear nuevo…

Si ABBYY FlexiCapture 8.0 Professional ya está en ejecución y se abrió un proyecto, para crear un nuevo proyecto, seleccione el elemento del menú Archivo>Nuevo proyecto…

Obtenga más información sobre la creación de un proyecto


Descripción general de la creación de una plantilla de documento

La creación de una plantilla es la parte más crítica en la configuración de un proyecto y determina la calidad de los datos obtenidos tras el procesamiento.

Una plantilla describe la ubicación de los elementos del documento e indica los campos que se usarán en la extracción de datos.

Para crear una plantilla, ejecute el Asistente para plantillas:

  1. En el menú principal de ABBYY FlexiCapture 8.0 Professional, seleccione Proyecto>Plantillas de documento…
  2. En el cuadro de diálogo Plantillas de documento, haga clic en el botón Nuevo….
  3. Siga las instrucciones del Asistente para plantillas.

Las etapas principales de la creación de plantillas dependen del tipo de documentos que se procesarán.

Las etapas principales de la creación de una plantilla para formas fijas
  1. Cree una nueva plantilla de documento con la ayuda del Asistente para plantillas. Con el Asistente en ejecución, abra la imagen de página del documento que se usará para realizar la marcación de plantillas.
  2. Marque los elementos estáticos, delimitadores e identificadores, y configure sus propiedades. Los elementos estáticos se utilizan para la asociación y la identificación de plantillas. Normalmente, los elementos estáticos se detectan automáticamente y se les asignan propiedades predeterminadas.
  3. Marque los campos de la imagen. Los campos se usan para la extracción de datos.
  4. Configure las propiedades del campo. Las propiedades del campo afectan la calidad de reconocimiento y determinan si los valores del campo se exportarán y enviarán al operador para la verificación. Especifican los tipos de datos y el rango de valores de un campo.
  5. Cree plantillas para documentos de varias páginas: al agregar páginas y repetir todas las etapas para cada página.
  6. Configure la exportación de datos.
  7. Si es necesario, puede configurar el modo en que se muestran los datos en la ventana del documento, se comprueban según las reglas, etc.
  8. Pruebe una plantilla utilizando las imágenes de varios documentos.

Nota: Si creó formas legibles por máquina con ABBYY FormDesigner, en vez de realizar las primeras tres etapas solo debe importar un archivo con extensión *.xfd. Se abrirá una imagen de página con la marcación lista (o imágenes de varias páginas si usó ABBYY FormDesigner para crear una forma de varias páginas). Para obtener detalles, consulte Importación de una plantilla para formularios creados con ABBYY FormDesigner.

Etapas principales de la creación de plantillas para documentos flexibles
  1. Cree una descripción flexible (un archivo con extensión *.afl) con ABBYY FlexiLayout Studio. Para obtener detalles, consulte los Temas de ayuda de ABBYY FlexiLayout Studio.
  2. Cree una nueva plantilla de documento con la ayuda del Asistente para plantillas. Con el Asistente en ejecución, abra una imagen de la página del documento y adjunte una descripción flexible (el archivo *.afl que creó). Una vez que haya finalizado el Asistente, la marcación de campos estará presente en la imagen.
  3. Configure las propiedades del campo. Siga los procedimientos para configurar las propiedades de la plantilla para un formulario fijo.
  4. Configure la exportación de datos.
  5. Si es necesario, puede configurar el modo en que se muestran los datos en la ventana del documento, se comprueban según las reglas, etc.
  6. Pruebe una plantilla utilizando las imágenes de varios documentos.

Para documentos de tipos mixtos que incluyen páginas de formas fijas y secciones semiestructuradas, puede adjuntar una descripción flexible como una de las secciones de la plantilla. Comience por crear una plantilla de cualquier sección (flexible o fija) y luego agregue una nueva sección de un tipo diferente.

Pueden procesarse varios tipos de documentos en un flujo único: como parte del mismo proyecto, puede crear plantillas para formas fijas y documentos flexibles, así como plantillas para documentos de tipos mixtos. El programa selecciona una plantilla automáticamente.

Para procesar documentos con anexos, cree una plantilla de documento y habilite la opción Habilitar páginas adjuntas en las propiedades de la plantilla. Consulte Creación de plantillas para documentos con anexos.

Obtenga más información acerca de la creación de plantillas


Creación de perfiles de importación

Para comenzar, el operador agrega nuevas imágenes al proyecto: estas pueden ser documentos impresos para digitalizar o imágenes electrónicas existentes.

Las acciones que se repiten con frecuencia o la adición de imágenes desde el mismo origen pueden automatizarse para habilitar la importación con un solo clic. Para hacerlo, cree un perfil de importación de imágenes. Además, puede configurar el procesamiento de imágenes entrantes y la adición periódica de imágenes en el modo en segundo plano. Una vez que se haya establecido la configuración requerida, las imágenes se digitalizarán o se importarán desde un origen predefinido con solo un clic y las imágenes recibidas se procesarán (por ejemplo, se limpiarán). Si es necesario, puede cambiar el origen de la importación de la imagen o su configuración.

Si el origen de la importación se cambia con frecuencia, puede crear varios perfiles de importación y alternar entre ellos para evitar cambiar la configuración del origen de importación permanentemente.

Para agregar un perfil de importación, seleccione el elemento del menú Proyecto > Perfiles de importación de imágenes… en la ventana principal del programa. En el cuadro de diálogo que se abrirá, puede crear nuevos perfiles de importación, editar, eliminar y copiar perfiles existentes.

Obtenga más información acerca de la creación de perfiles de importación


Creación de lotes de documentos

Los documentos enviados para que se los procese se agregan a los lotes. El principio de asignación de documentos a los lotes está definido por el usuario: puede procesar todos los documentos en un solo lote o crear lotes a partir de documentos agregados en la misma fecha o a partir de un lote digitalizado en una sola pasada.

Si el proyecto no contiene lotes, el programa creará automáticamente un lote cuando intente agregar imágenes.

Para crear un nuevo lote, seleccione Nuevo lote en el menú contextual con una lista de lotes que aparece cuando hace clic con el botón derecho en la ventana principal.

Obtenga más información acerca de la creación de lotes de documentos


Descripción general del trabajo de los operadores con un programa configurado

Los operadores utilizan un programa que está preconfigurado para el procesamiento de ciertos tipos de documentos. El procesamiento de documentos es el mismo que el de todos los tipos de documentos e incluye las siguientes etapas:

  1. Adición de imágenes

    Agregar imágenes de la página del documento es más fácil una vez que configura los perfiles de importación. También puede agregar imágenes al digitalizarlas o cargarlas desde los archivos.

  2. Inicio del proceso de reconocimiento

    El reconocimiento es un proceso automático: el programa identifica la plantilla de documento sobre la base de la ubicación de los elementos estáticos preconfigurados en plantillas, aplica la plantilla y reconoce los datos en los campos que se especifican en la plantilla. Antes de iniciar el proceso de reconocimiento, puede analizar documentos o sus páginas y aplicar la plantilla correspondiente a la imagen.

  3. Verificación

    La verificación, el proceso de comprobación de datos, es la parte más trabajosa de la tarea del operador. Incluye:

    • Verificación del ensamblaje de documentos: comprobación del ensamblaje correcto de las páginas del documento.
    • Verificación del grupo: comprobación visual de grupos de caracteres reconocidos como idénticos.
    • Verificación de campo: comprobación de caracteres reconocidos sin certeza dentro del contexto de campos con un rango de valores conocido.
    • Validación de regla: comprobación de errores de regla.

  4. Exportación de datos

    La exportación se realiza con un solo clic de acuerdo con la configuración de exportación establecida en la plantilla. También puede exportar datos al archivo o base de datos sin utilizar la configuración de exportación de la plantilla.

Obtenga más información acerca del modo en que trabajan los operadores con proyectos configurados


Adición de imágenes

Para agregar imágenes, seleccione el lote necesario o cree uno nuevo. El botón de importación le permite agregar imágenes de diferentes maneras y el nombre del botón cambia según el método de importación elegido.

Si se configuraron los perfiles de importación en el proyecto, sus nombres se mostrarán como elementos del menú del botón de importación. Para comenzar con el procedimiento de importación, solo debe seleccionar uno de ellos.

Para cargar imágenes desde un archivo, haga clic en la flecha ubicada a la derecha del botón de importación y seleccione Cargar imágenes… Seleccione archivos con imágenes, configure las opciones necesarias y realice la importación.

Para agregar imágenes desde un escáner, haga clic en la flecha ubicada a la derecha del botón de importación y seleccione Digitalizar imágenes…

Después de seleccionar Importar imágenes… en el menú, puede seleccionar uno de los perfiles de importación de imágenes existentes para iniciar la exportación, agregar uno nuevo o editar un perfil existente.

Obtenga más información acerca de la adición de imágenes


Inicio del proceso de reconocimiento y análisis, y aplicación de una plantilla

Para realizar el reconocimiento, haga clic en Reconocer.

Para realizar el análisis preliminar de las imágenes, haga clic en la flecha ubicada a la derecha del botón Reconocer y seleccione Asociar plantilla… Si se puede aplicar una plantilla, se nombrarán la página y el documento al que pertenece. Si no se puede asociar ninguna de las plantillas del proyecto con la imagen, la página permanecerá sin ser procesada.

También puede aplicar una plantilla determinada a una página o a un documento completo. En la mayoría de los casos, la plantilla que se creó correctamente en el programa se aplica a las páginas de forma automática; sin embargo, es posible que tenga que aplicarla a una plantilla de forma manual. Para aplicar una plantilla, resalte un documento o una página, haga clic en la flecha ubicada a la derecha del botón Reconocer y haga clic en Asociar plantilla…

Obtenga más información sobre el reconocimiento


Verificación

Para iniciar el proceso de verificación, haga clic en Ejecutar verificación…. El proceso comienza con la verificación del grupo seguida de la verificación de campos. Si una plantilla no tiene campos incluidos en la verificación de grupo o campo, se omitirá la etapa de verificación correspondiente.

Para los documentos de varias páginas, necesita corregir los posibles errores de ensamblaje del documento. Las páginas se ensamblan en documentos automáticamente. Los documentos con errores de ensamblaje se marcan con el siguiente símbolo [image]. La descripción del error se muestra con una leyenda en rojo debajo del nombre de la plantilla de documento. Al crear una plantilla de documento, debe configurar la regla de ensamblaje de documentos: secuencia y cantidad de repeticiones de las páginas. También puede configurar la verificación del ensamblaje de acuerdo con los valores de los campos clave: en este caso, los valores de los campos clave deben ser idénticos en todas las páginas del documento. En el caso de falta de asociación, aparecerá el mensaje correspondiente y se resaltarán en rojo los valores de los campos clave. Los errores de ensamblaje pueden corregirse más fácilmente en el modo de esquema de la página, que brinda al usuario una buena visualización de las imágenes de la página y los diferentes documentos a los que pertenecen.

Durante la verificación del grupo, los grupos de caracteres con reconocimiento idéntico se envían para la verificación. La tarea del operador es la de identificar los caracteres con diferencias que se reconocieron de forma incorrecta. A continuación, corrigen sus valores después de visualizar la imagen del campo que incluye este carácter. Si no es posible corregir los caracteres, puede marcarlos como cuestionables.

Durante la verificación de campos, los campos con un rango de valores conocidos se envían para su verificación. La tarea del operador es la de comprobar los caracteres reconocidos sin certeza en el contexto del campo completo. La verificación de campo tiene dos modos: un modo de visualización de campos único con cortes de caracteres y un modo de visualización múltiple con campos del mismo tipo.

Las reglas sin cumplir se marcan: con un indicador amarillo [image] (advertencia) o con un indicador rojo [image] (error). El operador debe comprobar los campos con errores de regla y; si es posible, corregir sus valores. Para ejecutar la verificación de los errores de regla, haga clic en la flecha ubicada a la derecha del botón y seleccione el elemento del menú Volver a comprobar reglas. Si pueden cumplirse las condiciones de las reglas después de haber corregido los valores del campo, se eliminarán los indicadores.

La verificación de datos también se realiza en la ventana de documentos que se abre cuando hace doble clic en el nombre de un documento o una página. La ventana del documento no muestra campos independientes, sino únicamente el documento completo. También muestra todos los caracteres reconocidos sin certeza, errores de la regla, etc.

Obtenga más información acerca de la verificación


Exportación

Para exportar documentos reconocidos y verificados, haga clic en Exportar. La exportación se realizará de acuerdo con la configuración establecida en la plantilla de documento.

Si necesita realizar la exportación al archivo, haga clic en la flecha ubicada a la derecha del botón y seleccione Exportar a archivo…

Si necesita realizar la exportación a la base de datos, seleccione Exportar a base de datos…

Si es necesario, cambie la configuración de exportación predeterminada y realice la exportación.

Obtenga más información acerca de la exportación


Instalación y ejecución del programa

Esta sección incluye información básica acerca de la instalación, protección y ejecución de ABBYY FlexiCapture 8.0 Professional. También trata los requisitos del sistema para la instalación.

Protección del programa
Programa de administración de claves de protección del Administrador de licencias
Requisitos de hardware y software
Instalación de ABBYY FlexiCapture 8.0 Professional
Ejecución del programa


Tipos de protección

Para instalar y usar ABBYY FlexiCapture 8.0 Professional, se necesita una clave de protección válida.

ABBYY FlexiCapture 8.0 Professional puede incluir uno de los siguientes tipos de clave de protección:

  • clave de protección de hardware
  • clave de protección de software

Clave de protección de hardware

Esta es una llave electrónica para conectar a un puerto USB en su ordenador (llave electrónica USB).

Para que ABBYY FlexiCapture 8.0 Professional se ejecute con una clave de protección de hardware, necesita instalar el controlador correspondiente del programa de instalación. Para usar el programa, la clave de protección de hardware debe estar conectada de forma permanente.

La clave de protección de hardware almacena los parámetros de su licencia.

Puede activarse una clave de protección de hardware de forma remota utilizando únicamente el número de serie de la licencia. Simplemente inicie la utilidad DongleUpdate (DongleUpdate.FlexiCapture.exe), haga clic en el botón Nueva licencia e introduzca su número de serie. El programa se pondrá en contacto con el servidor de activación en Internet, solicitará los parámetros del número de serie y los escribirá en la clave de protección de hardware.

Importante: Debe poder ejecutar el servicio SmartCard para utilizar la clave de protección de hardware.

Clave de protección de software

Este es un archivo de licencia.

Para que ABBYY FlexiCapture 8.0 Professional se ejecute con una clave de protección de software, el archivo de licencia debe activarse en el servidor de activación de ABBYY. Puede activar su archivo de licencia desde el programa de instalación o la utilidad Administrador de licencias.

La información necesaria para activar su archivo de licencia se envía a ABBYY en forma de código (Id. de producto), el cual se genera según información sobre el ordenador en el cual está instalado ABBYY FlexiCapture 8.0 Professional. No se utiliza información personal para generar el Id. de producto y este código no puede usarse para identificar al usuario.

Métodos de activación:

  • A través de Internet
    La activación a través de Internet se lleva a cabo de forma automática y demora unos segundos. Para utilizar este método, se requiere una conexión a Internet activa.
  • Por correo electrónico
    Si selecciona este método de activación, se generará automáticamente una solicitud de activación por correo electrónico. Envíe este mensaje de correo electrónico a la dirección que se especificó. Para garantizar una respuesta inmediata del robot de correo, no modifique el asunto ni el contenido del mensaje del correo electrónico.

En el caso de realizar la activación a través de Internet, no se requieren pasos adicionales. En el caso de la activación por correo electrónico, recibirá un archivo activado desde el robot de activación. Guarde este archivo en su disco duro, ejecute la utilidad Administrador de licencias y suministre la ruta al archivo guardado en el Asistente para la activación.

Repetir activación

Puede volver a instalar ABBYY FlexiCapture 8.0 Professional cuantas veces desee en el ordenador en que se activó. Sin embargo, si realiza actualizaciones significativas, formatea el disco duro o vuelve a instalar el sistema operativo, es posible que necesite volver a activar el producto.

El servidor de activación mantiene un registro de la cantidad de veces que se activó cada número de serie. Una vez que se excede el umbral de un número de serie, este se bloquea y ya no puede volver a activarse.

Puede desactivar una licencia activada para usarla en otro ordenador. Cuando desactiva una licencia, el servidor de activación reduce el recuento de activaciones para este número de serie en uno.

Importante: El programa activado podrá utilizarse solo en el ordenador en que se generó el Id. del producto. Para trasladar el programa a otro ordenador, primero desactive su licencia.


Administrador de licencias

La utilidad Administrador de licencias se utiliza para administrar claves de protección y reunir información sobre el estado de las licencias de ABBYY FlexiCapture.

Advertencia: El Administrador de licencias es una utilidad administrativa. Para usar el Administrador de licencias, el usuario debe tener derechos de administrador local.

El Administrador de licencias se instala:

  • en el ordenador donde se instala ABBYY FlexiCapture 8.0 Professional (instalación local) o
  • en el servidor donde se instala ABBYY FlexiCapture 8.0 Professional (instalación de red)

Para iniciar la utilidad Administrador de licencias:

  • Vaya a Inicio>Programas>ABBYY FlexiCapture 8.0>Herramientas y seleccione Administrador de licencias de ABBYY FlexiCapture 8.0 Professional.

Administración de licencias

Agregar una nueva licencia

Para agregar una nueva licencia, haga clic en el botón Agregar nueva licencia... en la ventana principal de la utilidad Administrador de licencias. En el cuadro de diálogo que se abrirá, introduzca el nuevo número de serie y haga clic en Agregar. O bien, haga clic en Desde archivo... y seleccione el archivo de texto que incluye los números de serie.

Las nuevas licencias aparecerán en la ventana principal del Administrador de licencias.

Activación de una licencia

Después de agregar una licencia, debe activarla. Haga clic en el botón Activar licencia... para activar una licencia agregada. Puede activar sus licencias a través de Internet (recomendado) o por correo electrónico. Siga las instrucciones del Asistente para la activación.

Actualización de una licencia

Para actualizar una licencia, selecciónela en la ventana Administrador de licencias y haga clic en el botón Actualizar licencia... También se solicitará la activación por Internet o correo electrónico. Siga las instrucciones del Asistente para la activación.

Parámetros de licencia

El Administrador de licencias le permite revisar los parámetros de licencia. Seleccione la licencia cuyos parámetros desea ver y haga clic en Propiedades de licencia...


Tipos y parámetros de licencia

Parámetros de licencia

Cada licencia tiene su propio número de serie e incluye un conjunto de parámetros. Cada conjunto de parámetros de licencias determina las funciones del producto para las cuales tiene derechos el usuario.

Existen dos tipos de licencia:

  • Licencia completa: permite ejecutar la Estación del administrador y todas las herramientas (FormDesigner y FlexiLayout Studio). Si no hay licencias de operador disponibles, también permite ejecutar la Estación del operador.
  • Licencia de operador: permite ejecutar la Estación del operador.

La licencia siempre especifica cuántos administradores y Estaciones del operador pueden ejecutarse simultáneamente. Por ejemplo, los parámetros 2 licencias completas y 5 licencias de operador significan que el usuario puede ejecutar simultáneamente dos Estaciones del administrador (en diferentes ordenadores o en el mismo ordenador con diferentes usuarios) y cinco Estaciones del operador.

Puede iniciarse cualquier cantidad de copias del programa en un ordenador bajo el mismo inicio de sesión —solo se usará una licencia. Si hay 5 licencias de operador en uso, para iniciar otra Estación del operador, se usará la licencia completa.

Parámetros de licencia:

  • Fecha de caducidad: muestra la fecha de caducidad de la licencia.
  • Límite de páginas: muestra la cantidad de páginas que pueden reconocerse en un período de tiempo particular.
  • Apertura de PDF: permite la apertura de documentos PDF.
  • Búsqueda de PDF: permite la exportación de datos a PDF con capacidad de búsqueda de texto completo.
  • FlexiLayouts: permite la utilización de plantillas flexibles (FlexiLayouts).
  • Cantidad máxima de campos: establece la cantidad máxima permitida de campos en una plantilla de documento.
  • FlexiLayout Studio: permite la ejecución de FlexiLayout Studio.
  • FormDesigner: permite la ejecución de FormDesigner.


Requisitos de hardware y software

  1. Ordenador con procesador Intel® Pentium®/Celeron®/Xeon™/Athlon™/Duron™/Sempron™ u otro compatible:
    • 500 MHz (mínimo)/2 GHz (recomendado): para Microsoft Windows Vista;
    • 350 MHz (mínimo)/ 2 GHz (recomendado): para Windows 2000/XP/2003.
  2. Sistema operativo:
    • Microsoft ® Windows Vista™;
    • Microsoft Windows Server 2003;
    • Microsoft Windows XP (Service Pack 2 o posterior);
    • Microsoft Windows 2000 (Service Pack 3 o posterior);
    • Microsoft Windows Server 2000 (Service Pack 3 o posterior).

    Para que el programa se ejecute con una interfaz localizada, el sistema operativo debe admitir el idioma necesario.

  3. Memoria RAM:
    • 512 MB (mínimo)/1024 MB (recomendado): para Windows Vista;
    • 128 MB (mínimo)/512 MB (recomendado): para Windows ??/2003.

    En sistemas con varios procesadores, se necesitan 16 MB de memoria RAM adicionales para cada procesador.

  4. Espacio libre en el disco duro: 420 MB para la configuración mínima (Estación del operador únicamente), 450 MB para la instalación estándar (Estaciones de administrador y operador, herramientas FlexiLayout y FormDesigner) y 200 MB para el funcionamiento del programa (1 GB recomendado).
  5. Escáner que admita TWAIN o ISIS.
  6. Conexión a Internet para activar el número de serie al utilizar una clave de protección de software o un puerto USB para una clave de protección de hardware (llave electrónica).
  7. Tarjeta de vídeo y pantalla con una resolución mínima de 800x600.
  8. Teclado y ratón u otro dispositivo puntero.


Instalación de ABBYY FlexiCapture 8.0 Professional

Cierre todas las demás aplicaciones (por ejemplo, Microsoft Outlook o Microsoft Word) antes de instalar ABBYY FlexiCapture 8.0 Professional.

Para instalar ABBYY FlexiCapture 8.0 Professional:

  1. Coloque el CD-ROM de ABBYY FlexiCapture 8.0 Professional en la unidad de CD-ROM.
  2. En el menú Ejecución automática, seleccione Instalación local y siga las instrucciones para el programa de instalación. (Si la Ejecución automática no está habilitada en su ordenador, haga doble clic en el archivo setup.exe que se encuentra en el CD-ROM).
  3. Seleccione un idioma de instalación (inglés o ruso). El programa de instalación comparará la configuración regional de su sistema y el idioma seleccionado. Si los idiomas no son compatibles, aparecerá un mensaje de advertencia.
  4. A continuación, el programa de instalación comprueba la versión de su sistema operativo y la disponibilidad de permisos administrativos. Si la versión del sistema operativo no es compatible con el programa o si no tiene permisos administrativos, aparecerá un mensaje de advertencia y finalizará el programa de instalación.
  5. Si se realizaron todas las comprobaciones de forma correcta, se mostrará el Contrato de licencia para el usuario final. Lea el contrato de licencia con detenimiento y, si acepta los términos que allí se expresan, seleccione la opción correspondiente y haga clic en Siguiente.
  6. Se abrirá un cuadro de diálogo en el que debe introducir cierta información personal. Introduzca la información solicitada y continúe con la instalación.
  7. En el siguiente cuadro de diálogo que se abre, seleccione una de las modalidades de instalación disponibles:
    • Completo: el programa se instalará en forma completa. Podrá alternar entre los modos de administrador y operador, y utilizar FormDesigner 8.0 y FlexiLayout Studio 8.0.
    • Estación del operador: solo se instalará la Estación del operador. (No se instalará la Estación del administrador, FormDesigner 8.0 ni FlexiLayout Studio 8.0).
  8. Luego, seleccione una carpeta de destino. De manera predeterminada, el programa se instalará en: <nombre del disco>:\Archivos de programa\ABBYY FlexiCapture 8.0 Professional. Si no hay espacio suficiente en el disco duro seleccionado, aparecerá una ventana que le mostrará sus discos duros, el espacio libre disponible y el espacio necesario para la instalación. Seleccione un disco con suficiente espacio libre y continúe con la instalación.
  9. Los archivos del programa se copiarán en su ordenador. Una vez que se haya completado la instalación, el programa de instalación mostrará un mensaje que indicará que la aplicación se instaló de forma correcta.
  10. El Administrador de licencias de FlexiCapture 8.0 Professional se iniciará automáticamente para que pueda activar su copia de la aplicación. Introduzca su número de serie y active la aplicación.


Instalación de ABBYY FlexiCapture 8.0 Professional en una red de área local

ABBYY FlexiCapture 8.0 Professional puede instalarse y usarse en una red de área local.

Para instalar el programa en una red, seleccione Instalación de red en el menú Ejecución automática y siga las instrucciones del programa de instalación.

La instalación de red le permite implementar ABBYY FlexiCapture 8.0 Professional en varios ordenadores. La instalación de red se realiza en dos etapas. Primero, se instalan la utilidad Administrador de licencias y la clave de protección en uno de los ordenadores de la red de área local (LAN) (el servidor). Si es necesario, la distribución completa de ABBYY FlexiCapture 8.0 Professional también puede copiarse en el servidor. A continuación, se instala ABBYY FlexiCapture 8.0 Professional en las estaciones de trabajo de la red de área local (LAN).

Para obtener más información sobre la instalación del programa en una red de área local (LAN), consulte el Manual del administrador del sistema, que también está disponible en el menú Ejecución automática.


Cambio del modo de instalación, reparación y eliminación de ABBYY FlexiCapture 8.0 Professional

Para cambiar el modo de instalación (seleccione la instalación completa o la Estación del operador):

  1. Seleccione Inicio > Panel de control > Agregar o quitar programas, luego seleccione ABBYY FlexiCapture 8.0 Professional en la lista de programas instalados y haga clic enCambiar.

  2. Seleccione el elemento Modificar y haga clic en Siguiente.

  3. En el cuadro de diálogo que se abrirá, seleccione el modo de instalación requerido.

Para reparar los archivos dañados o eliminados:

  1. Seleccione Inicio > Panel de control > Agregar o quitar programas, luego seleccione ABBYY FlexiCapture 8.0 Professional en la lista de programas instalados y haga clic en Cambiar.

  2. Seleccione el elemento Reparar y haga clic en Siguiente.

Para eliminar ABBYY FlexiCapture 8.0 Professional de su ordenador:

  1. Seleccione Inicio > Panel de control > Agregar o quitar programas, luego seleccione ABBYY FlexiCapture 8.0 Professional en la lista de programas instalados y haga clic en Eliminar.

  2. Confirme que desea eliminar el programa.


Ejecución del programa

Para iniciar ABBYY FlexiCapture 8.0 Professional:

  • en el modo de administrador: diríjase a Inicio>Programas>ABBYY FlexiCapture 8.0 y seleccione la Estación del administrador de ABBYY FlexiCapture 8.0 Professional.
  • en el modo de operador: diríjase a Inicio>Programas>ABBYY FlexiCapture 8.0 y seleccione la Estación del operador de ABBYY FlexiCapture 8.0 Professional.

Importante: Antes de ejecutar el programa, asegúrese de que:

  • El escáner esté conectado al ordenador y encendido.
    Si el escáner no está conectado, consulte el manual del usuario del escáner.
    Para que el escáner funcione correctamente, debe encenderlo antes de encender el ordenador.
  • Se instaló una clave de protección en su ordenador. No puede ejecutar el programa sin ella.

Claves de registro que controlan el inicio de la aplicación

Puede utilizar las siguientes claves de registro (en Shell\Inicio) para controlar el modo de inicio de la aplicación:

  • Modo de administrador: define si la aplicación se ejecuta en el modo de operador o administrador.
  • Proyecto: configura el proyecto que se abre automáticamente cuando se inicia la aplicación.
  • Lote: configura el lote que se abre automáticamente cuando se inicia la aplicación (debe especificarse el lote).
  • Prohibir cambio de ruta: prohíbe el cambio de lote y proyecto que se abren automáticamente en el modo de operador (establezca el valor clave en Verdadero).

Dichas claves no se crean en el registro de manera predeterminada. De ser necesario, el administrador puede agregar dichas claves en el registro del sistema operativo del usuario.

Las claves del registro pueden reemplazarse por los parámetros de inicio de la línea de comandos correspondientes.

Parámetros de inicio de la línea de comandos

Pueden usarse los siguientes parámetros para iniciar la aplicación a través de una línea de comandos:

FlexiCapture.exe [/Estación:(Admin,Operador)] [/Proyecto:"ruta al proyecto"] [/Lote:"nombre del lote"] [/Prohibir cambio de ruta].

  • [/Estación:(Admin,Operador)]: define si la aplicación se ejecuta en el modo de operador o administrador. Si no se especificó ningún modo, aparece un cuadro de diálogo al iniciar la aplicación que le indica al usuario que seleccione el modo deseado.
  • [/Proyecto:"ruta al proyecto"]: configura el proyecto que se abre automáticamente cuando se inicia la aplicación.
  • [/Lote:"nombre del lote"]: configura el lote que se abre automáticamente cuando se inicia la aplicación.
  • [/Prohibir cambio de ruta]: prohíbe el cambio de lote y proyecto que se abren automáticamente en el modo de operador.


Utilización de plantillas creadas en versiones anteriores de ABBYY FormReader

Las plantillas creadas en ABBYY FormReader 6.5 y 6.0 pueden importarse en ABBYY FlexiCapture 8.0 Professional.

Al importar una plantilla creada en una versión anterior, se importa la marca de páginas (excepto los campos de servicio) y los tipos de datos. Los tipos de datos se copian en la carpeta Personalizado en los tipos de datos de la plantilla de documento. Para obtener más información, consulte Tipos de datos del campo de entrada de texto.

Importante: La configuración de exportación, las reglas de validación y las imágenes incluidas en el lote no se importan.

Para importar una plantilla creada en ABBYY FormReader 6.5 ó 6.0:

  1. Inicie ABBYY FlexiCapture 8.0 Professional en el modo de administrador.
  2. Cree un nuevo proyecto o abra un proyecto existente al cual desee importar una plantilla creada en una versión anterior del programa.
  3. En el menú principal, seleccione Proyecto > Plantillas de documento…
  4. En el cuadro de diálogo Plantillas de documento, haga clic en el botón Importar…
  5. En la lista desplegable Archivos de tipo, seleccione Lotes de FormReader 6.5 (*.frm) y seleccione el lote cuya plantilla desea importar.

La plantilla importada se agregará a la lista de plantillas. Si hay más de una plantilla en el lote, se importarán todas las plantillas. Si especifica una estructura para documentos de varias páginas en ABBYY FormReader 6.5, las plantillas descritas por esta estructura se combinarán en una plantilla de varias páginas.

Sugerencias:
  1. Para obtener más información sobre las diferencias entre las reglas de las versiones nuevas y las antiguas, consulte Comparación de reglas de FormReader 6.5 y FlexiCapture 8.0 Professional.
  2. Para obtener recomendaciones sobre la migración de las reglas If-Then, las reglas de automatización y la exportación de automatización de FormReader 6.5 a scripts de FlexiCapture 8.0, consulte Migración de las reglas y la exportación de FormReader 6.5 a los scripts de FlexiCapture 8.0 Professional.


Interfaz de ABBYY FlexiCapture 8.0 Professional

Esta sección ofrece una descripción general de los elementos clave de la interfaz de ABBYY FlexiCapture 8.0 Professional: las ventanas principales, los menús y las barras de herramientas.

Ventana principal del programa
Menú de la ventana principal
Barras de herramientas de la ventana principal
Editor de plantillas de documento
Menú del editor de plantillas de documento
Barras de herramientas del editor de plantillas de documento
Ventana del verificador de grupo
Menú
Barra de herramientas
Ventana del verificador de campos
Menú
Barra de herramientas


Ventana principal de ABBYY FlexiCapture 8.0 Professional

La ventana principal del programa muestra la lista de lotes del documento que forman parte del proyecto con el que está trabajando.

Mostrar la ventana principal con la lista del lote

Haga doble clic en un lote para ver su contenido. Verá una lista de los documentos que forman el lote.

Para regresar a la lista de lotes, en el menú seleccione Proyecto>Lista de lotes de trabajo (o Lista de lotes de prueba si trabaja con lotes de prueba).

Mostrar la ventana principal con un lote abierto de documentos

El menú está ubicado en la parte superior de la ventana, con las barras de herramientas por debajo.

El resto de la ventana principal incluye la ventana del lote de trabajo que contiene una lista de documentos.

En la sección inferior de la ventana se ubica la barra de estado. Muestra los detalles de las operaciones y el estado del programa, así como sugerencias breves sobre los elementos del menú y los botones que selecciona.

Debe abrir la ventana del documento para verificar los datos reconocidos. Para hacerlo, haga doble clic en el nombre del documento o en una de sus páginas. La ventana del documento incluye tres partes:

  • imagen de página del documento;
  • datos reconocidos;
  • errores de regla (esta parte se muestra únicamente si se presentan errores de regla).

Para obtener detalles, consulte Verificación en la ventana del documento.

Mostrar la ventana del documento

Menú de la ventana principal
Barras de herramientas de la ventana principal


Menú de la ventana principal de ABBYY FlexiCapture 8.0 Professional

Archivo
Elemento del menú | Descripción
Nuevo proyecto… | Crea un nuevo proyecto.
Abrir proyecto… | Abre un proyecto existente.
Cerrar proyecto | Cierra el proyecto actual.
Guardar | Guarda los cambios.
Cargar imágenes… | Carga imágenes de archivos.
Digitalizar imágenes… | Agrega imágenes del escáner.
Importar imágenes… | Importa imágenes mediante el uso de uno de los perfiles de importación configurados.
Exportar… | Exporta datos mediante la configuración de exportación de las plantillas de documento.
Exportar a |
Archivo… | Exporta datos a un archivo.
Base de datos… | Exporta datos a una base de datos.
Proyectos recientes | Abre uno de los proyectos que se utilizaron recientemente.
Salir | Cierra ABBYY FlexiCapture 8.0.
Edición
Elemento del menú | Descripción
Deshacer | Deshace la acción anterior.
Rehacer | Rehace la acción deshecha.
Cortar | Corta los objetos resaltados.
Copiar | Copia los objetos resaltados en el portapapeles.
Pegar | Pega el contenido del portapapeles.
Eliminar | Elimina los objetos resaltados.
Seleccionar todo | Selecciona todo.
Buscar… | Busca un texto específico.
Buscar siguiente | Busca la próxima vez que aparece determinado texto.
Ir a |
Siguiente documento | Se desplaza hacia adelante hasta el próximo documento.
Documento anterior | Regresa al documento anterior.
Imagen |
Refinar | Elimina el ruido de la imagen.
Invertir | Invierte la imagen.
Girar 90° a la derecha | Gira la imagen 90° a la derecha.
Girar 90° a la izquierda | Gira la imagen 90° a la izquierda.
Girar 180° | Gira la imagen 180°.
Ver
Elemento del menú | Descripción
Documentos |
Detalles | Muestra los documentos y sus páginas en forma de lista detallada.
Miniaturas | Muestra imágenes de página del documento como miniaturas.
Editor de documentos |
Modo de imagen | Muestra una imagen de página en la ventana del documento.
Modo de datos | Muestra datos reconocidos en la ventana del documento.
Ventana de la imagen | Permite seleccionar la ubicación de la imagen en la ventana del documento.
Ventana de errores | Permite seleccionar la ubicación de la ventana de errores en la ventana del documento.
Mostrar barra de herramientas en el modo de datos | Muestra u oculta la barra de herramientas en la ventana del documento. Esta barra de herramientas le permite corregir ciertos errores de aplicación; por ejemplo, agregar un campo no encontrado, o agregar o eliminar un separador de tabla. Esta opción se usa principalmente al trabajar con descripciones flexibles.
Barras de herramientas | Muestra u oculta las barras de herramientas en la ventana principal.
Barra de estado | Muestra u oculta la barra de estado.
Mostrar imagen en blanco y negro | Muestra las imágenes en color y en escala de grises de las páginas del documento en el modo en blanco y negro.
Escala de la imagen | Establece la escala de imagen apropiada para las páginas del documento.
Tamaño del texto de datos | Permite la selección de un tamaño de fuente para mostrar los datos reconocidos.
Pantalla completa | Cambia al modo de pantalla completa.
Propiedades… | Abre el cuadro de diálogo de las propiedades para un documento o una página.
Importación y reconocimiento
Elemento del menú | Descripción
Importar imágenes… | Importa imágenes mediante el uso de uno de los perfiles de importación configurados.
Analizar | Analiza las páginas del documento mediante la selección de una plantilla apropiada.
Asociar plantilla… | Aplica la plantilla seleccionada por el usuario al documento o la página resaltados.
Reconocer | Ejecuta el proceso de reconocimiento.
Verificación
Elemento del menú | Descripción
Ejecutar verificación… | Ejecuta el proceso de verificación.
Siguiente error de ensamblaje | Se dirige al siguiente error de ensamblaje.
Error de ensamblaje anterior | Regresa al error de ensamblaje anterior.
Siguiente carácter incierto | Se dirige al próximo carácter reconocido sin certeza.
Carácter incierto anterior | Regresa al carácter anterior reconocido sin certeza.
Siguiente error de regla | Se dirige al siguiente error de regla.
Error de regla anterior | Regresa al error de regla anterior.
Proyecto
Elemento del menú | Descripción
Lista de lotes de trabajo | Cierra el lote actual y abre la lista de lotes de documentos de trabajo.
Lista de lotes de prueba | Cierra el lote actual y abre la lista de lotes de documentos de prueba. Este elemento del menú está disponible solo en el modo de administrador.
Plantillas de documento… | Abre un cuadro de diálogo con una lista de plantillas de documento, a partir de la cual puede realizar acciones con plantillas: crear, editar, importar, eliminar una nueva plantilla. Este elemento del menú está disponible solo en el modo de administrador.
Perfiles de importación de imágenes… | Abre un cuadro de diálogo con una lista de perfiles de importación de imágenes, a partir de la cual puede realizar acciones con perfiles de importación: crear un nuevo perfil, copiar un perfil existente, editarlo, eliminarlo. Este elemento del menú está disponible solo en el modo de administrador.
Cambiar a modo de administrador… | Cambia al modo de administrador. Este elemento del menú está disponible solo en el modo de operador.
Proteger con contraseña… | Protege el proyecto actual con una contraseña. Este elemento del menú está disponible solo en el modo de administrador.
Desproteger… | Elimina la protección con contraseña del proyecto. Este elemento del menú está disponible solo en el modo de administrador.
Exportar proyecto… | Exporta el proyecto a la carpeta que especificó el usuario. Las imágenes se tomarán del proyecto actual.
Actualizar proyecto… | Actualiza el proyecto. Los mensajes y errores que pueden ocurrir durante la exportación pueden guardarse en un archivo (haga clic con el botón derecho y seleccione Exportación a archivo).
Propiedades del proyecto… | Abre el cuadro de diálogo de las propiedades del proyecto.
Herramientas
Elemento del menú | Descripción
Volver a analizar | Vuelve a analizar los documentos.
Volver a reconocer | Vuelve a reconocer los documentos.
Actualizar ensamblaje | Actualiza el ensamblaje de páginas en un documento.
Volver a comprobar reglas | Vuelve a revisar las reglas.
Opciones… | Abre el cuadro de diálogo Opciones para establecer varias configuraciones, como el procesamiento de tareas en segundo plano, la visualización de ventanas, etc.
Ayuda
Elemento del menú | Descripción
Temas de ayuda… | Abre los Temas de ayuda de ABBYY FlexiCapture 8.0 Professional.
Asistencia técnica | Abre la página Asistencia técnica en los Temas de ayuda.
Cómo adquirir los productos de ABBYY… | Abre la página Cómo adquirir ABBYY FlexiCapture 8.0 Professional en los Temas de ayuda.
Sitio web de ABBYY… | Abre el sitio web de ABBYY.
Enviar comentario | Permite a los usuarios enviar comentarios y sugerencias a ABBYY.
Acerca de ABBYY FlexiCapture 8.0… | Abre el cuadro de diálogo Acerca de ABBYY FlexiCapture 8.0 Professional, que presenta una breve descripción del programa.


Barras de herramientas en la ventana principal de ABBYY FlexiCapture 8.0 Professional

Barra de herramientas estándar

Nombre | Botón | Descripción
Abrir proyecto |  | Abre otro proyecto.
Guardar cambios |  | Guarda los cambios.
Cortar |  | Corta un objeto seleccionado cuando trabaja con datos en la ventana del documento.
Copiar |  | Copia un objeto seleccionado.
Pegar |  | Pega un objeto copiado anteriormente desde el portapapeles.
Eliminar |  | Elimina un objeto resaltado.
Deshacer |  | Deshace la acción anterior.
Rehacer |  | Rehace la acción previamente deshecha.
Vista Miniaturas |  | Muestra imágenes de página del documento como miniaturas.
Vista Detalles |  | Muestra los documentos y sus páginas en forma de lista detallada.
Elemento anterior para verificar |  | Regresa al elemento anterior para verificar. El programa navega por todos los errores, por ejemplo, los errores de ensamblaje, los caracteres reconocidos sin certeza, los errores de regla y los campos clave que no se asociaron correctamente, entre otros.
Siguiente elemento para verificar |  | Avanza al siguiente elemento para verificar. El programa navega por todos los errores, por ejemplo, los errores de ensamblaje, los caracteres reconocidos sin certeza, los errores de regla y los campos clave que no se asociaron correctamente, entre otros.
Documento anterior |  | Regresa al documento anterior.
Siguiente documento |  | Se desplaza hacia adelante hasta el próximo documento.
Barra de herramientas de procesamiento

La barra de herramientas de procesamiento le permite realizar todas las acciones de procesamiento de documentos. Los botones de esta barra de herramientas tienen varias funciones y trabajan en diferentes modos.

El nombre del primer botón, el botón para agregar imágenes, varía de acuerdo con el modo seleccionado. Al hacer clic en este, el programa realiza una acción que coincide con el nombre.

Para seleccionar un modo, haga clic en el triángulo ubicado a la derecha del botón y seleccione el elemento del menú necesario.

Botón | Modo | Descripción
 | Cargar imágenes… | Carga imágenes desde los archivos y las agrega al lote actual
 | Digitalizar imágenes… | Agrega imágenes al lote desde el escáner
 | Importar imágenes… | Importa imágenes utilizando uno de los perfiles de importación de imágenes configurados
 | Lista de perfiles de importación existentes | Para comenzar con la importación de imágenes, simplemente seleccione uno de los perfiles de importación configurados de la lista.
 | Reconocer | Ejecuta el proceso de reconocimiento.
 | Analizar | Analiza las páginas del documento mediante la selección de una plantilla apropiada.
 | Asociar plantilla… | Aplica la plantilla seleccionada por el usuario al documento o la página resaltados.
 | Ejecutar verificación… | Ejecuta el proceso de verificación.
 | Volver a comprobar reglas | Ejecuta el proceso de comprobación de reglas.
 | Exportar | Exporta datos de acuerdo con el perfil de exportación configurado en las plantillas del documento.
 | Exportar a archivo… | Exporta datos al archivo.
 | Exportar a base de datos… | Exporta datos a una base de datos.


Ventana del editor de plantillas de documento

Las plantillas se crean y editan en la ventana del editor de la plantilla de documento.

Para abrir el editor de plantillas de documento, en la ventana principal del programa:

  1. Seleccione el elemento del menú Proyecto>Plantillas de documento…
  2. En el cuadro de diálogo Plantillas de documento que se abrirá, resalte el nombre de la plantilla y haga clic en Editar…

La ventana del editor de plantillas de documento también se abre cuando finaliza el Asistente para plantillas.

Mostrar la ventana del editor de plantillas de documento

La ventana del editor de plantillas de documento incluye tres partes:

  1. La imagen de página con la marcación de campos y los elementos estáticos se muestra en la parte superior izquierda.

    El programa también tiene dos modos de manejo de campos y elementos estáticos:

    • el modo de marcación de campos, que se activa al hacer clic en el botón [image];
    • el modo de elementos estáticos, que se activa al hacer clic en el botón [image].
  2. El editor para configurar la presentación de datos reconocidos se ubica en la parte inferior izquierda.
  3. La estructura del documento con una lista de los campos de plantilla (ficha Campos) se ubica en la parte derecha. También puede cambiar al modo de esquema de páginas (ficha Páginas).

Menú del editor de plantillas
Barras de herramientas del editor de plantillas


Menú del editor de plantillas

Plantilla
Elemento del menú | Descripción
Agregar página… | Agrega una nueva imagen de página a la plantilla.
Agregar sección del documento… | Agrega una nueva sección al lote.
Módulos de script |
Script de regla… | Abre el Módulo de reglas de script global del Editor de scripts. Para obtener más información sobre los módulos de script, consulte Uso de scripts en FlexiCapture 8.0.
Script de exportación… | Abre el Módulo de exportación de script global del Editor de scripts. Para obtener más información sobre los módulos de script, consulte Uso de scripts en FlexiCapture 8.0.
Configuración de exportación… | Abre el cuadro de diálogo Configuración de exportación para configurar las opciones de exportación de datos.
Propiedades de la plantilla de documento… | Abre un cuadro de diálogo para visualizar y editar las propiedades de la plantilla de documento.
Guardar | Guarda los cambios.
Cerrar | Cierra el editor de la plantilla de documento.
Edición
Elemento del menú | Descripción
Deshacer | Deshace la acción anterior.
Rehacer | Rehace la acción deshecha.
Cortar | Corta los objetos resaltados.
Copiar | Copia los objetos resaltados en el portapapeles.
Pegar | Pega el contenido del portapapeles.
Eliminar | Elimina los objetos resaltados.
Eliminar región | Elimina regiones de las imágenes de los objetos resaltados.
Seleccionar todo | Selecciona todo.
Seleccionar por tipo… | Detecta objetos de cierto tipo.
Crear campo |
Texto | Agrega un campo de entrada de texto a la estructura del documento (sin una región en la imagen).
Marca de verificación | Agrega un campo de marca de verificación a la estructura del documento (sin una región en la imagen).
Grupo de marcas de verificación | Agrega un campo de grupo de marca de verificación a la estructura del documento (sin una región en la imagen).
Código de barras | Agrega un campo de código de barras a la estructura del documento (sin una región en la imagen).
Imagen | Agrega un campo de imagen a la estructura del documento (sin una región en la imagen).
Tabla | Agrega un campo de tabla a la estructura del documento (sin una región en la imagen).
Agrupar | Agrega un grupo de campos a la estructura del documento (sin una región en la imagen).
Agrupar | Agrupa los objetos resaltados.
Desagrupar | Desagrupa los objetos resaltados.
Copiar texto desde imagen… | Obtiene texto de cualquier región de la imagen y lo almacena en el portapapeles. Después de seleccionar este comando, resalte la región en la que se ubica el texto deseado.
Imagen... |
Refinar | Elimina el ruido de la imagen.
Invertir | Invierte la imagen.
Girar 90° a la derecha | Gira la imagen 90° a la derecha.
Girar 90° a la izquierda | Gira la imagen 90° a la izquierda.
Girar 180° | Gira la imagen 180°.
Guardar como… | Guarda la imagen de la página de la plantilla en el archivo específico
Reemplazar… | Reemplaza la imagen de la página de la plantilla.
Ver
Elemento del menú | Descripción
Diseño de la imagen |
Elementos estáticos | Cambia al modo de elementos estáticos.
Regiones de los campos | Cambia al modo de marcación de campos.
Estructura de documentos |
Mostrar estructura del documento | Muestra u oculta la ventana de estructura de documentos.
Campos | Cambia la ventana de estructura de documentos al modo de campos.
Páginas | Cambia la ventana de estructura de documentos al modo de páginas.
Formulario de datos | Muestra u oculta la ventana del editor de datos.
Barra de herramientas de diseño |
Horizontal | Acopla la barra de herramientas de la ventana de diseño de imagen de forma horizontal.
Vertical | Acopla la barra de herramientas de la ventana de diseño de imagen de forma vertical.
Mostrar imagen en blanco y negro | Muestra las imágenes en color y escala de grises de las páginas en el modo de blanco y negro.
Escala de la imagen | Selecciona una escala de imagen apropiada.
Propiedades… | Abre un cuadro de diálogo para visualizar y editar las propiedades del objeto resaltado.
Documento
Elemento del menú | Descripción
Ejecutar prueba | Inicia la prueba de la plantilla en la imagen del documento.
Finalizar prueba | Detiene la prueba de la plantilla.
Modo de imagen | Muestra la imagen de página en la ventana del documento.
Modo de datos | Muestra los datos reconocidos en la ventana del documento.
Diseño |
Ventana de la imagen | Cambia la posición de la imagen en la ventana del documento.
Arriba | Coloca la ventana de la imagen en la parte superior de la pantalla.
Abajo | Coloca la ventana de la imagen en la parte inferior de la pantalla.
Izquierda | Coloca la ventana de la imagen a la izquierda.
Derecha | Coloca la ventana de la imagen a la derecha.
Ventana de errores | Cambia la posición de la ventana de errores en la ventana del documento.
Arriba | Coloca la ventana de errores en la parte superior de la pantalla.
Abajo | Coloca la ventana de errores en la parte inferior de la pantalla.
Izquierda | Coloca la ventana de errores a la izquierda.
Derecha | Coloca la ventana de errores a la derecha.
Mostrar barra de herramientas en el modo de datos | Muestra u oculta la barra de herramientas en el modo de datos. En el modo de imagen, la barra de herramientas se muestra siempre y no puede ocultarse.
Verificación |
Siguiente elemento para verificar | Se dirige al siguiente elemento para verificar.
Elemento anterior para verificar | Se dirige al elemento anterior para verificar.
Siguiente carácter incierto | Se dirige al próximo carácter incierto.
Carácter incierto anterior | Se dirige al próximo carácter incierto.
Siguiente error de regla | Se dirige al siguiente error de regla.
Error de regla anterior | Se dirige al error de regla anterior.
Herramientas
Elemento del menú | Descripción
Detectar objetos automáticamente… | Detecta automáticamente y resalta los campos y los elementos estáticos de un tipo determinado (según el modo).
Comprobar plantilla de documento | Comprueba la plantilla de documento.
Asociar sección | Comprueba la asociación de una sección de la plantilla.
Cambiar a lote de prueba… | Permite la prueba de la plantilla de documento con los lotes de prueba.
Ayuda
Elemento del menú | Descripción
Temas de ayuda… | Abre los Temas de ayuda de ABBYY FlexiCapture 8.0 Professional.
Enviar comentario | Permite a los usuarios enviar comentarios y sugerencias a ABBYY.


Barras de herramientas en el editor de plantillas

Barra de herramientas estándar

Nombre | Botón | Descripción
Guardar cambios |  | Guarda los cambios.
Cortar |  | Corta un objeto seleccionado cuando trabaja con datos en la ventana del documento.
Copiar |  | Copia un objeto seleccionado.
Pegar |  | Pega un objeto copiado anteriormente desde el portapapeles.
Eliminar |  | Elimina un objeto resaltado.
Deshacer |  | Deshace la acción anterior.
Rehacer |  | Rehace la acción previamente deshecha.
Comprobar plantilla de documento |  | Comprueba la visualización de resultados de comprobación de una plantilla de documento en la parte inferior de la ventana del editor de plantillas.
Barra de herramientas en la ventana de diseño de la imagen

La barra de herramientas de la ventana de diseño de la imagen se utiliza para crear elementos estáticos y campos de las plantillas. El conjunto de botones de la barra de herramientas cambia de acuerdo con el modo seleccionado.

En el modo de elementos estáticos:

En el modo de marcación de campos:

Esta barra de herramientas puede acoplarse de forma horizontal o vertical. La orientación de la barra de herramientas puede cambiarse en Ver>Barra de herramientas Diseño.
Nombre | Botón | Descripción
General
Modo de elementos estáticos |  | Cambia al modo de elementos estáticos.
Modo de regiones del campo |  | Cambia al modo de regiones del campo.
Zoom |  | Aumenta la escala de la imagen.
Detectar objetos automáticamente |  | Detecta objetos automáticamente en la imagen. Seleccione esta herramienta y haga clic con el botón izquierdo en la región del objeto.
Seleccionar regiones |  | Selecciona regiones de los objetos que se marcaron en la imagen. Para resaltar una región, seleccione esta herramienta y haga clic con el botón izquierdo en la región del objeto.
En el modo de elementos estáticos
Crear delimitador |  | Crea un delimitador. Seleccione esta herramienta y luego utilice el ratón para enmarcar el delimitador con un rectángulo.
Crear separador |  | Crea un separador. Seleccione esta herramienta y luego utilice el ratón para enmarcar el separador con un rectángulo.
Crear texto del delimitador |  | Crea un texto del delimitador. Seleccione esta herramienta y luego utilice el ratón para enmarcar el texto con un rectángulo.
Crear código de barras para el delimitador |  | Crea un código de barras para el delimitador. Seleccione esta herramienta y luego utilice el ratón para enmarcar el código de barras con un rectángulo.
En el modo de marcación de campos
Crear texto |  | Crea un campo de entrada de texto. Seleccione esta herramienta y luego utilice el ratón para enmarcar la región de entrada de texto con un rectángulo.
Crear marca de verificación |  | Crea un campo de marca de verificación. Seleccione esta herramienta y luego utilice el ratón para enmarcar la región de marca de verificación con un rectángulo.
Crear grupo de marcas de verificación |  | Crea un grupo de marcas de verificación. Seleccione esta herramienta y luego utilice el ratón para enmarcar el grupo de marcas de verificación con un rectángulo.
Crear código de barras |  | Crea un campo de código de barras. Seleccione esta herramienta y luego utilice el ratón para enmarcar el código de barras con un rectángulo.
Crear imagen |  | Crea un campo de imagen. Seleccione esta herramienta y luego utilice el ratón para enmarcar el imagen con un rectángulo.
Crear tabla |  | Crea un campo de tabla. Seleccione esta herramienta y luego utilice el ratón para enmarcar la tabla con un rectángulo. Los botones de marcación de tablas adicionales aparecerán en la barra de herramientas.
Crear grupo |  | Crea un grupo de campos. Seleccione esta herramienta y luego utilice el ratón para enmarcar el grupo de campos con un rectángulo.
Crear región para campo sin región |  | Crea una región para un campo que se incluyó en la estructura del documento, pero no tiene una región en la imagen. Seleccione esta herramienta y luego utilice el ratón para enmarcar la región del campo con un rectángulo. Seleccione un nombre de la lista desplegable. (La lista muestra nombres de campos que no tienen una región en la imagen).
Crear región no reconocible |  | Resalta un campo que se excluirá del proceso de reconocimiento.
Botones de marcación de tablas Se muestran si se creó al menos una tabla en la sección de la plantilla dada.
Crear columna |  | Se utiliza para crear una columna de tablas y especificar su tipo. Para crear una columna, seleccione esta herramienta y haga clic en la región en la que intenta crearla. Seleccione un tipo de columna en la lista desplegable.
Trazar separador de tabla |  | Agrega separadores horizontales y verticales a la tabla.
Eliminar separador |  | Elimina un separador.


Ventana del verificador de grupo

La ventana del verificador de grupo se abre cuando ejecuta el proceso de verificación (al seleccionar Verificación>Ejecutar verificación… desde el menú de la ventana principal) siempre que la plantilla tenga campos con la opción Incluir en la verificación de grupo habilitada. Para obtener detalles, consulte Propiedades de la verificación de campo.

Esta ventana está diseñada para permitirle realizar una comprobación visual de los caracteres reconocidos como idénticos. Consulte Verificación de grupo.

Menú de la ventana del verificador de grupo
Barra de herramientas de la ventana del verificador de grupo


Menú de la ventana del verificador de grupo

Verificación
Elemento del menú | Descripción
Confirmar todo | Confirma el reconocimiento correcto de todos los caracteres y lo dirige a la siguiente pantalla.
Posponer todo | Rechaza todos los caracteres y los marca como cuestionables.
Alternar | Rechaza el carácter resaltado y lo marca como cuestionable.
Página siguiente | Lo lleva a la página siguiente en caso de que no entren todos los caracteres en una sola pantalla.
Página anterior | Lo lleva a la página anterior en caso de que no entren todos los caracteres en una sola pantalla.
Cerrar | Cierra la ventana del verificador.
Edición
Elemento del menú | Descripción
Deshacer | Deshace la acción anterior.
Rehacer | Rehace la acción previamente deshecha.
Seleccionar todo | Resalta todos los caracteres.
Ver
Elemento del menú | Descripción
Imagen de campo |
Mostrar imagen de campo | Muestra u oculta una imagen de campo que contiene el carácter actual.
En la parte superior | Coloca la imagen de campo en la parte superior de la ventana del verificador.
En la parte inferior | Coloca la imagen de campo en la parte inferior de la ventana del verificador.
Escala de la imagen | Selecciona una escala apropiada para la imagen de campo.
Mostrar imagen de caracteres | Muestra la imagen de los caracteres.
Barra de herramientas | Muestra u oculta la barra de herramientas.
Barra de estado | Muestra u oculta la barra de estado.
Tamaño de los caracteres | Cumple la función de seleccionar un tamaño de carácter apropiado.
Pantalla completa | Cambia al modo de pantalla completa.
Preferencias… | Cumple la función de configurar la visualización del área adyacente de los caracteres.
Ayuda
Elemento del menú | Descripción
Temas de ayuda… | Abre los Temas de ayuda de ABBYY FlexiCapture 8.0 Professional.
Acerca de ABBYY FlexiCapture 8.0… | Abre el cuadro de diálogo Acerca de ABBYY FlexiCapture 8.0 Professional, que presenta una breve descripción del programa.


Barra de herramientas de la ventana del verificador de grupo

Nombre | Botón | Descripción
Página anterior |  | Lo lleva a la página anterior en caso de que no entren todos los caracteres en una sola pantalla.
Página siguiente |  | Lo lleva a la página siguiente en caso de que no entren todos los caracteres en una sola pantalla.
Confirmar pantalla |  | Confirma el reconocimiento correcto de todos los caracteres y lo dirige a la siguiente pantalla.
Cambiar estado de caracteres |  | Cambia el estado de los caracteres a rechazado o confirmado.
Deshacer |  | Deshace la acción anterior.
Rehacer |  | Rehace la acción previamente deshecha.


Ventana del verificador de campos

La ventana del verificador de campos aparece cuando se completa el proceso de verificación de grupo siempre que la plantilla tenga campos para los cuales está habilitada la opción Incluir en la verificación de campo. Para obtener detalles, consulte Propiedades de la verificación de campo.

Esta ventana le permite realizar una comprobación visual de caracteres reconocidos sin certeza en el contexto del campo completo. Consulte Verificación de campo.

Barra de herramientas de la ventana del verificador de campos
Barra de herramientas de la ventana del verificador de campos


El menú de la ventana del verificador de campos

Verificación
Elemento del menú | Descripción
Confirmar campo | Confirma un campo.
Postergar | Pospone la verificación de un campo.
Siguiente carácter incierto | Se dirige al próximo carácter reconocido sin certeza.
Carácter incierto anterior | Regresa al carácter anterior reconocido sin certeza.
Campo siguiente | Se dirige al siguiente campo.
Campo anterior | Regresa al campo anterior.
Cerrar | Cierra la ventana del verificador.
Edición
Elemento del menú | Descripción
Deshacer | Deshace la acción anterior.
Rehacer | Rehace la acción previamente deshecha.
Cortar | Corta los objetos resaltados.
Copiar | Copia los objetos resaltados en el portapapeles.
Pegar | Pega el contenido del portapapeles.
Eliminar | Elimina los objetos resaltados.
Seleccionar todo | Selecciona todo.
Insertar salto de línea | Inserta un salto de línea.
Combinar caracteres | Combina caracteres resaltados si, durante el reconocimiento, se dividió incorrectamente un carácter en varios caracteres.
Ver
Elemento del menú | Descripción
Datos del campo |
Texto reconocido | Muestra u oculta el texto reconocido.
Corte de imágenes de caracteres | Cambia al modo de visualización de campos con corte de caracteres.
Mostrar símbolos especiales | Muestra u oculta los símbolos especiales.
Imagen de campo |
Mostrar imagen de campo | Muestra u oculta una imagen de campo que contiene el carácter actual.
En la parte superior | Coloca la imagen de campo en la parte superior de la ventana del verificador.
En la parte inferior | Coloca la imagen de campo en la parte inferior de la ventana del verificador.
Escala de la imagen | Establece la escala de imagen apropiada para las páginas del documento.
Campos adyacentes | Muestra u oculta los campos adyacentes.
Mostrar imagen del carácter | Muestra u oculta la imagen del carácter.
Barra de herramientas | Muestra u oculta las barras de herramientas en la ventana principal.
Barra de estado | Muestra u oculta la barra de estado.
Tamaño de los caracteres | Cumple la función de seleccionar un tamaño de carácter apropiado.
Pantalla completa | Cambia al modo de pantalla completa.
Preferencias… | Cumple la función de configurar la visualización de la ventana del verificador.
Ayuda
Elemento del menú | Descripción
Temas de ayuda… | Abre los Temas de ayuda de ABBYY FlexiCapture 8.0 Professional.
Acerca de ABBYY FlexiCapture 8.0… | Abre el cuadro de diálogo Acerca de ABBYY FlexiCapture 8.0 Professional, que presenta una breve descripción del programa.


Barra de herramientas de la ventana del verificador de campos

Nombre | Botón | Descripción
Campo anterior |  | Regresa al campo anterior.
Campo siguiente |  | Se dirige al siguiente campo.
Confirmar/Omitir campo |  | Confirma el reconocimiento correcto de todos los caracteres de un campo y lo dirige al campo siguiente. Si el valor del campo no se ajusta al formato del campo, el nombre del botón cambia a Omitir campo. Si el valor del campo no puede corregirse, la verificación puede diferirse u omitirse.
Diferir |  | Difiere la verificación de campo si no puede corregirse su valor.
Carácter incierto anterior |  | Regresa al carácter anterior reconocido sin certeza.
Siguiente carácter incierto |  | Se dirige al próximo carácter reconocido sin certeza.
Deshacer |  | Deshace la acción anterior.
Rehacer |  | Rehace la acción previamente deshecha.


Configuración del programa

Antes del ingreso masivo de documentos, es necesario configurar el programa para el procesamiento de documentos del tipo necesario. El administrador establece todas las configuraciones necesarias.

Para configurar el procesamiento de documentos, cree un proyecto que incluya:

  • perfiles de importación de imágenes
  • una o varias plantillas de documento
  • lotes de documentos para procesar

Puede incluir varias plantillas en el proyecto, en cuyo caso se procesarán varios documentos como parte del mismo proyecto, de acuerdo con la plantilla aplicada. Sin embargo, si los flujos de documentos no se cruzan, puede crear proyectos independientes para ellos.

Modos de administrador y operador
Creación de un proyecto
Plantillas de documento
Perfiles de importación de imágenes
Configuración de exportación predeterminada
Lotes de documentos
Campos de índice


Modos de administrador y operador

Para organizar la entrada de datos de flujo único con la ayuda de ABBYY FlexiCapture 8.0 Professional, debe configurar el sistema para el procesamiento de ciertos tipos de documentos. El administrador establece toda la configuración, mientras que los operadores se encargan de la introducción de documentos. La cantidad de estaciones de trabajo depende de la cantidad y el volumen de documentos que requieren procesamiento.

El Administrador configura el sistema y controla el modo en que este funciona. Al administrador se le asigna la tarea de:

  • diseñar nuevos espacios en blanco en el formulario (esta tarea puede estar en manos del diseñador)
  • configurar la importación de imágenes y las opciones de digitalización
  • preparar plantillas de documento
  • supervisar la entrada de datos a un sistema configurado y asesorar a los operadores

Los Operadores realizan la tarea de introducir los documentos. Trabajan con un sistema previamente configurado por el administrador, listo para procesar documentos completos de ciertos tipos. A los operadores se les asigna la tarea de:

  • digitalizar o importar documentos
  • verificar datos
  • exportar datos

El reconocimiento de documentos es un proceso automático.

El programa cuenta con dos modos de operación: el modo de administrador y el modo de operador. El administrador tiene acceso a todas las funciones del programa, y el modo de administrador puede protegerse con una contraseña. El operador no puede crear ni editar plantillas, tampoco puede crear perfiles de importación. El operador está autorizado a trabajar solo con un proyecto o un lote único.

Al realizar la instalación del programa, se puede optar por instalar solo la Estación del operador o el programa completo. Si selecciona la instalación completa, podrá alternar entre el modo de operador y el modo de administrador. Para elegir uno de los modos, seleccione Inicio > Programas > ABBYY FlexiCapture 8.0 > Estación del administrador de ABBYY FlexiCapture 8.0 Professional o Inicio > Programas > ABBYY FlexiCapture 8.0 > Estación del operador de ABBYY FlexiCapture 8.0 Professional. (Para obtener detalles, consulte Ejecución del programa).

En el modo de administrador, el menú Proyecto presenta los elementos Lista de lotes de prueba, Plantillas de documento…, Perfiles de importación de imágenes…, Proteger con contraseña…, Desproteger…, que no están disponibles en el modo de operador. Por lo tanto, en el modo de administrador, solo se puede trabajar con lotes de prueba y plantillas de documento, y se pueden importar perfiles. El administrador también puede proteger un proyecto con contraseña o desprotegerlo. Si intenta abrir un proyecto protegido con contraseña en el modo de administrador, se le solicitará que introduzca una contraseña.

En el modo de operador, el menú Proyecto presenta el elemento Cambiar a modo de administrador…. Después de seleccionar este elemento, se abrirán el lote y el proyecto actuales (una vez que introduzca la contraseña correcta, si el lote está protegido con contraseña). Si no está autorizado a modificar el lote o el proyecto actuales en el modo de operador, las barras de herramientas y los elementos del menú pertinentes estarán ausentes.


Creación de un proyecto

Para comenzar a trabajar, necesita crear un proyecto. Un proyecto incluye:

  • perfiles de importación de imágenes
  • una o varias plantillas de documento
  • lotes de documentos para procesar

Después de ejecutar el programa, se abrirá el cuadro de diálogo Abrir proyecto, que le permitirá seleccionar uno de los proyectos existentes o crear uno nuevo.

Para crear un nuevo proyecto:

  1. Haga clic en el botón Crear nuevo….
  2. Especifique un nombre para el proyecto y una carpeta en la que desee almacenarlo.
  3. Haga clic en Crear.

Si ABBYY FlexiCapture 8.0 Professional ya está en ejecución y se abrió un proyecto, para crear un nuevo proyecto, seleccione el elemento del menú Archivo>Nuevo proyecto…

Propiedades del proyecto
Plantillas de documento
Perfiles de importación de imágenes
Lotes de documentos


Propiedades del proyecto

Se pueden ver y cambiar las propiedades de un proyecto en un cuadro de diálogo independiente que se abrirá cuando seleccione Proyecto>Propiedades del proyecto… en la ventana principal.

La ficha General muestra el nombre y una descripción del proyecto, y la ruta a los archivos que este incluye.

La ficha Procesamiento previo de imágenes muestra las opciones del procesamiento previo de imágenes. Puede cambiar estas opciones, si es necesario. Para obtener detalles, consulte Opciones de procesamiento previo de imágenes.

La ficha Reconocimiento contiene la opción Eliminar páginas en blanco durante el reconocimiento. Seleccione esta opción si desea eliminar las páginas en blanco durante el reconocimiento.

La ficha Exportar muestra la configuración de exportación predeterminada. Puede cambiar esta configuración, si es necesario. La opción Ejecutar script después de la exportación habilita el controlador de exportación. Para obtener más información acerca del controlador de exportación, consulte Uso de scripts para describir la exportación y Scripts de muestra que describen la exportación.


Plantillas de documento

La creación de una plantilla es la etapa principal y la más crítica en la configuración de un proyecto, y determina la calidad de los datos obtenidos tras el procesamiento.

Las plantillas solo pueden crearse en el modo de administrador.

Una plantilla describe la ubicación de los elementos del documento e indica los campos que se usarán en la extracción de datos. Al crear una plantilla, las propiedades del campo se especifican junto con su rango de valores. También se establece la configuración de exportación de datos.

Para comenzar a crear una plantilla de documento, ejecute el Asistente para plantillas:

  1. En el menú principal de ABBYY FlexiCapture 8.0 Professional, seleccione Proyecto>Plantillas de documento…
  2. En el cuadro de diálogo Plantillas de documento que se abrirá, haga clic en el botón Nuevo….
  3. Siga las instrucciones del Asistente para plantillas.

Asistente para plantillas
Detección automática de campos y elementos estáticos
Elementos estáticos
Creación de campos de una plantilla de documento
Propiedades del campo
Validación de regla
Configuración de exportación de datos
Configuración de la presentación de datos en la ventana del documento
Propiedades de la plantilla de documento
Importación de una plantilla para formularios creados con ABBYY FormDesigner
Creación de plantillas para documentos de varias páginas
Creación de una plantilla para el procesamiento de documentos flexibles
Creación de plantillas para documentos con adjuntos
Procesamiento de documentos sin estructura
Edición y publicación de una plantilla
Prueba de una plantilla


Asistente para plantillas

Para crear una plantilla nueva, seleccione el elemento del menú principal Proyecto>Plantillas de documento… y en el cuadro de diálogo Plantillas de documento haga clic en el botón Nuevo…. Se abrirá el nuevo asistente para crear plantillas.

  1. En el cuadro de diálogo Crear nueva plantilla de documento especifique la configuración de la plantilla principal: nombre y comentarios, idioma usado (Idioma (configuración regional)) y estilo de escritura (Estilo de escritura). De manera predeterminada, la lista desplegable incluye solo los idiomas que tienen diccionarios compatibles. Para seleccionar un idioma sin diccionarios compatibles, habilite la opción Mostrar todos los idiomas. Es muy importante que especifique el idioma correctamente: de ello depende el reconocimiento correcto de los documentos. El estilo de escritura puede diferenciarse ligeramente en diferentes países; por eso es importante especificar el país para habilitar en el programa la selección del estilo de escritura típico.

    Mostrar ejemplos de varios estilos de escritura numéricos
    - Ruso dos
    - Estadounidense dos
    - "Común" cinco: puede ocurrir en cualquier estilo
    - Japonés cinco
    - Ruso uno
    - Alemán uno
    - "Común" nueve: puede ocurrir en cualquier estilo
    - Checo nueve con el círculo a la derecha
    - Estadounidense nueve sin el "gancho" en la parte inferior

    Especifique el tipo de texto:

    • ICR (manuscrito): habilite esta función si la mayoría de los campos de los documentos se van a completar a mano.
    • OCR (impreso): habilite esta función si los valores de la mayoría de los campos se van a imprimir. Seleccione el tipo de impresión en la lista desplegable.

    Nota: El reconocimiento de texto manuscrito no es compatible con todos los idiomas. Para algunos idiomas, este tipo de reconocimiento no estará disponible. Consulte Idiomas de reconocimiento compatibles.

    Luego, puede cambiar el tipo de texto para campos individuales; mientras tanto el tipo específico en esta etapa se usará como predeterminado.

    Haga clic en Siguiente para ir al paso siguiente.

  2. Para el segundo paso, cargue la imagen de la página de su documento para crear la plantilla. Puede digitalizar la imagen de una página sin completar o cargarla del archivo.

    Nota: La plantilla para formularios fijos se crea usando una imagen obtenida mediante la digitalización de un formulario sin completar. Esta debe ser una imagen de buena calidad sin distorsiones (sin fallas, inclinaciones, etc.). Al crear plantillas de formularios con fondo de color, debe usar páginas digitalizadas sin filtros para que el fondo no desaparezca durante la digitalización. (Más adelante, cuando digitalice imágenes de páginas para el reconocimiento de datos, seleccionará un modo de digitalización que haga desaparecer el fondo).

    Si su documento incluye varias páginas, cargue la primera página y siga las recomendaciones de la sección Creación de plantillas para documentos de varias páginas para agregar las páginas restantes.

    Si necesita usar una descripción flexible creada con ABBYY FlexiLayout Studio, habilite la opción Cargar FlexiLayout e introduzca la ruta del archivo que incluye la descripción flexible. Para obtener más detalles, consulte Creación de una plantilla para el procesamiento de documentos flexibles.

    Haga clic en el botón Siguiente.

  3. Para el siguiente paso, seleccione los tipos de campo que deben detectarse automáticamente en la imagen. Puede marcar los campos de entrada de texto y las marcas de verificación. El programa detecta automáticamente los campos de texto con una región y las marcas de verificación rectangulares de manera particularmente satisfactoria. Si los campos de entrada de su formulario no tienen una región, y las marcas de verificación se insertan contra un fondo blanco, por lo general, deben resaltarse de forma manual.

    Nota: La búsqueda automática de delimitadores se realiza de forma permanente. Si el formulario contiene delimitadores, se detectarán y se marcarán en la imagen.

    Haga clic en el botón Finalizar.

Cuando el Asistente para plantillas finaliza, se abrirá la ventana editor de plantillas de documento en la que podrá realizar más acciones para crear una plantilla. En el siguiente paso de la creación de la plantilla, debe marcar los campos y los elementos estáticos en la imagen de página y configurar sus propiedades.


Detección automática de campos y elementos estáticos

Detección automática al agregar una imagen:

Al agregar una imagen de página, el programa siempre detecta los delimitadores. Si la imagen contiene delimitadores estándar (como cuadros negros), estos se detectarán y marcarán. El programa busca campos de texto y marcas de verificación si el usuario activó las opciones Texto o Marcas de verificación. El programa realiza la detección automática de los campos de texto con una región y marcas de verificación rectangulares de manera particularmente satisfactoria. Si los campos de entrada de su formulario no tienen una región, y las marcas de verificación se insertan contra un fondo blanco, por lo general, necesitarán resaltarse de forma manual.

Detección automática en la ventana del editor de plantillas de documento:

Para la detección automática en la ventana del editor de plantillas de documento, seleccione el modo necesario (campos o elementos estáticos) y luego el elemento del menú Herramientas>Detectar objetos automáticamente…. Marque los tipos de campos o elementos estáticos que se detectarán automáticamente.

Si necesita detectar objetos específicos en la imagen automáticamente, seleccione el modo necesario (campos o elementos estáticos) y haga clic en [image] en la barra de herramientas. Si hace clic en el elemento, este se marcará con un rectángulo. El tipo de elemento se detectará automáticamente.

Detección automática de una región:

Para que la región de un elemento estático o un campo de un tipo específico se detecte automáticamente, realice lo siguiente:

  1. Seleccione el modo necesario (campos o elementos estáticos).
  2. Seleccione el tipo de campo o elemento estático con la ayuda del botón apropiado de la barra de herramientas.
  3. Pulse Mayús.
  4. Haga clic con el botón izquierdo en la región del elemento estático o en el campo.


Elementos estáticos

Los elementos estáticos se utilizan para la asociación y la identificación de plantillas. No se extraen datos de estos.

Para trabajar con los elementos estáticos en el editor de plantillas de documento, cambie al modo de elementos estáticos al hacer clic en el botón [image].

Los elementos estáticos pueden utilizarse para la asociación y la identificación de plantillas. Su método de uso se determina cuando configura las propiedades de los elementos. Los delimitadores se utilizan para la asociación de plantillas con la imagen del formulario. Los identificadores son necesarios para determinar a qué formularios pertenecen las páginas cuando se procesan varios formularios en un único flujo. Para obtener detalles, consulte Creación de formularios legibles por máquina.

Los elementos estáticos no tienen nombres, solo regiones en la imagen.

Cuando se aplica una plantilla a una imagen del documento, el programa busca elementos estáticos y selecciona una plantilla de documento según su ubicación. El reconocimiento de valores de elementos estáticos (texto y código de barras) se realiza únicamente en caso de ser necesario con fines de identificación. Consulte Especificación de valores del identificador.

El programa trabaja con elementos estáticos de los siguientes tipos:

Elemento estático | Botón de la barra de herramientas
Delimitador |
Separador |
Texto del delimitador |
Código de barras del delimitador |

El programa busca delimitadores automáticamente cuando se agrega una imagen.

Cómo crear un elemento estático manualmente:

  1. Seleccione el modo de elementos estáticos
  2. Seleccione la herramienta para la creación de un elemento del tipo necesario
  3. Coloque el cursor en la esquina del elemento, haga clic con el botón izquierdo y arrastre en diagonal hasta la esquina opuesta
    o
    pulse Mayús y haga clic en la región del elemento.

La región del elemento estático se enmarcará con un rectángulo. Su color depende del tipo de elemento estático. Al elemento estático se le asignan propiedades predeterminadas.

Cómo cambiar las propiedades de un elemento estático:

  1. Resalte la región del elemento en la imagen, haga clic con el botón derecho y seleccione Propiedades… en el menú contextual.
  2. Modifique las propiedades del elemento estático en el cuadro de diálogo que se abrirá.

Obtenga más información acerca de los elementos estáticos:

  • Delimitadores
  • Separadores
  • Texto del delimitador
  • Código de barras del delimitador


Delimitadores

Los delimitadores, elementos estáticos se resaltan en la imagen automáticamente.

Para resaltar los delimitadores manualmente:

  1. Cambie al modo de elementos estáticos.
  2. Seleccione [image] en la barra de herramientas.

  3. Coloque el cursor en la esquina de un delimitador, haga clic con el botón izquierdo y arrastre el cursor en diagonal hasta la esquina opuesta.

    O bien, pulse Mayús y haga clic en la región del delimitador.

Propiedades del delimitador

Para modificar las propiedades del delimitador:

  1. Resalte el delimitador.
  2. Haga clic con el botón derecho en la región del delimitador y seleccione el elemento Propiedades… en el menú contextual.
  3. Modifique las propiedades en el cuadro de diálogo que se abrirá:
    • Utilizar para asociar plantillas: esta opción debe estar habilitada para que el programa utilice el delimitador para la asociación de plantillas (recomendado).
    • Utilizar para identificar plantillas: habilite esta opción para utilizar el delimitador para la identificación de plantillas.
    • Tipo de delimitador: para realizar la asociación de plantillas de forma correcta, es importante especificar el tipo de delimitador: cuadrado negro, cruz o esquina


Texto del delimitador

Texto del delimitador, elemento estático. Abarca cualquier texto estático de la imagen: encabezados, firmas explicativas.

Para resaltar el texto del delimitador:

  1. Cambie al modo de elementos estáticos.
  2. Seleccione [image] en la barra de herramientas.
  3. Ubique el cursor en la esquina del texto del delimitador, haga clic con el botón izquierdo y arrastre el cursor en diagonal hasta la esquina opuesta.

    O bien, puede pulsar Mayús y hacer clic en la región del texto del delimitador.

Propiedades del texto del delimitador

Para modificar las propiedades del texto del delimitador:

  1. Resalte el texto
  2. Haga clic con el botón derecho en la región del texto del delimitador y seleccione Propiedades… en el menú contextual.
  3. Modifique las propiedades en el cuadro de diálogo que se abrirá:

    En la ficha General:

    • Utilizar para asociar plantillas: esta opción debe estar habilitada para que el programa utilice el texto del delimitador para la asociación de plantillas.
    • Utilizar para identificar plantillas: habilite esta opción para utilizar el texto del delimitador para la identificación de plantillas.
    • Valor: si utiliza el texto del delimitador como identificador, puede establecer su valor. Para insertar un valor automáticamente, haga clic en el botón Sugerencia.
    • Cantidad máxima de errores: aquí puede especificar la cantidad máxima de errores permitidos en la cadena del texto del delimitador.

    En la ficha Reconocimiento debe configurar las opciones de reconocimiento para que el reconocimiento del texto estático se realice con la máxima precisión:

    • ICR (manuscrito): habilite esta opción si el texto estático es manuscrito.

    • OCR (impreso): habilite esta opción si el texto estático está impreso. Seleccione el estilo de impresión de la lista desplegable (tipográfico, impresora matricial de puntos, máquina de escribir, etc.). Consulte también Tipos de texto compatibles.

    • Avanzado: utilice esta opción para seleccionar varios tipos de texto o especificar un tipo de texto personalizado.

    • Tipo de datos: seleccione el idioma del texto. Utilice el botón Seleccionar… para realizar su selección.

    • Tipo de letra: seleccione el tipo de letra de texto estático; si el texto posee letras mayúsculas y minúsculas, deje el valor en Automático.

    • Orientación: especifique la orientación del texto.

    • Habilite la opción Una línea para el texto de una línea.

    • Si el texto no posee espacios en blanco; es decir, si incluye una sola palabra, habilite la opción Una palabra.

    • Configure las opciones del procesamiento de imágenes durante el reconocimiento:
    • Invertir: invierte la imagen.
    • Eliminar textura: quita la textura.
    • Refinar: habilite esta opción para eliminar los elementos no utilizados de la imagen.
    • Borrar residuos sólo del tamaño especificado: habilite esta opción si desea eliminar los residuos del tamaño específico únicamente. Especifique el tamaño de los residuos. Si esta opción está deshabilitada y solo está habilitada la opción Refinar, el tamaño de los residuos se seleccionará automáticamente.


Separadores

Los separadores son elementos estáticos. Un separador es cualquier línea horizontal o vertical en la imagen.

Para resaltar separadores:

  1. Cambie al modo de elementos estáticos.
  2. Seleccione [image] en la barra de herramientas.
  3. Coloque el cursor en la esquina de un separador, haga clic con el botón izquierdo y arrastre el cursor en diagonal hasta la esquina opuesta.

    O bien, pulse Mayús y haga clic en la región del separador.

Propiedades del separador

Para modificar las propiedades del separador:

  1. Resalte el separador.
  2. Haga clic con el botón derecho en la región del separador y seleccione el elemento Propiedades… en el menú contextual.
  3. Modifique las propiedades en el cuadro de diálogo que se abrirá:
    • Utilizar para asociar plantillas: esta opción debe estar habilitada para que el programa utilice el separador para la asociación de plantillas.
    • Utilizar para identificar plantillas: habilite esta opción para utilizar el separador para la identificación de plantillas.


Código de barras del delimitador

Código de barras del delimitador, elemento estático.

Importante: Un código de barras puede resaltarse como un campo o un elemento estático. Esto depende del valor del código de barras en los documentos que se están procesando: si se lo va a usar para la asociación o identificación de plantillas, debe crearlo en el modo de elementos estáticos. Si el código de barras se va a usar para la captura de datos, debe crearlo en el modo de marcación de campos. Las propiedades del código de barras varían según si este es un campo o un elemento estático. Esta sección describe las propiedades de un elemento estático: un código de barras del delimitador, consulte también campo del código de barras.

Para resaltar un código de barras del delimitador:

  1. Cambie al modo de elementos estáticos.
  2. Seleccione [image] en la barra de herramientas.
  3. Ubique el cursor en la esquina de un código de barras, haga clic con el botón izquierdo y arrastre el cursor en diagonal hasta la esquina opuesta.

    O bien, puede pulsar Mayús y hacer clic en la región del código de barras.

Propiedades de un código de barras del delimitador

Para modificar las propiedades de un código de barras del delimitador:

  1. Resalte el código de barras
  2. Haga clic con el botón derecho en la región del código de barras y seleccione el elemento Propiedades… en el menú contextual.
  3. Modifique las propiedades en el cuadro de diálogo que se abrirá:

    En la ficha General:

    • Utilizar para asociar plantillas: esta opción debe estar habilitada para que el programa utilice el código de barras para la asociación de plantillas.
    • Utilizar para identificar plantillas: habilite esta opción para utilizar el código de barras para la identificación de plantillas.
    • Valor: si utiliza un código de barras del delimitador como identificador, puede establecer su valor. Para insertar un valor automáticamente, haga clic en el botón Sugerencia
    • Necesario para la asociación de plantillas –si se selecciona esta opción, la plantilla se asociará únicamente si el código de barras coincide. Seleccione esta opción si existen varias plantillas muy similares en el lote que solo pueden distinguirse por los valores de sus códigos de barra o incluso por los valores de uno de sus diferentes códigos de barra. En este caso, la selección de esta opción acelerará la selección de plantillas. No seleccione esta opción si desea que se realice la asociación de la plantilla incluso si no hay ningún código de barras o este es demasiado débil.

    En la ficha Reconocimiento:

    • Tipo de código: especifique el tipo de código de barras (esto generalmente se determina de forma automática)
    • Orientación: especifique la orientación del código de barras.

    También puede configurar las opciones de procesamiento de imágenes:

    • Invertir: invierte la imagen
    • Eliminar textura: elimina la textura
    • Refinar: habilite esta opción para eliminar los elementos no utilizados de la imagen
    • Borrar residuos sólo del tamaño especificado: habilite esta opción si desea eliminar los residuos del tamaño específico únicamente. Especifique el tamaño de los residuos. Si esta opción está deshabilitada y solo está habilitada la opción Refinar, el tamaño de los residuos se seleccionará automáticamente.


Especificación de valores del identificador

La función de los identificadores consiste en determinar a qué formulario pertenece una página y se utiliza para seleccionar una plantilla del lote que contiene varias plantillas con el conjunto original de delimitadores. En el caso del procesamiento simultáneo de varios formularios en un flujo único, el programa determina a qué formulario pertenece dicha página según la ubicación de los identificadores.

Si se utiliza un código de barras del delimitador o texto del delimitador como identificador, puede especificar los valores de estos identificadores. En este caso, al aplicar una plantilla, el programa comparará los datos reconocidos en la imagen con el valor del identificador, y la asociación de plantillas solo será posible si estos valores están asociados.

Los valores de los identificadores se pueden configurar en el cuadro de diálogo de las propiedades de los elementos estáticos de la ficha General. Los valores del texto y los códigos de barras se pueden introducir automáticamente. El botón Sugerencia tiene dicha función.

Nota: Si es posible identificar una página con absoluta certeza según la ubicación de los elementos únicamente, no necesita configurar los valores. Deberá usar esta función solo cuando sea absolutamente necesario, ya que al asignar el valor del identificador se ejecuta el módulo de reconocimiento en la etapa de la aplicación de la plantilla y, como consecuencia, disminuye la velocidad del proceso de asociación de plantillas con imágenes.


Creación de campos de una plantilla de documento

Los campos están diseñados para la extracción de datos.

Para trabajar con los campos en el editor de plantillas de documento, cambie al modo de marcación de campos mediante un clic en el botón [image].

Todas las regiones de la imagen diseñadas para la captura de datos deben estar marcadas como campos. Los datos de estos campos están reconocidos y su valor se puede exportar.

Los campos tienen nombres, cuyas listas se muestran en la ventana de la estructura del documento. Normalmente, los campos tienen una región en la imagen, pero también se pueden crear campos sin región (por ejemplo, para almacenar resultados intermedios).

El programa reconoce los siguientes tipos de campos:

Campo | Botón de la barra de herramientas
Campo de entrada de texto |
Marca de verificación |
Grupo de marcas de verificación |
Código de barras |
Imagen |
Tabla |
Grupo de campos |

Para crear un campo:

  1. Seleccione el modo de marcación de campos
  2. Seleccione la herramienta para crear un campo del tipo necesario
  3. Ubique el cursor en la esquina del campo, haga clic con el botón izquierdo y arrastre el cursor en diagonal hasta la esquina opuesta
    o
    pulse Mayús y haga clic en la región del campo.

La región del campo se enmarcará con un rectángulo. Su color depende del tipo de campo.

Al campo creado se le asignará un nombre predeterminado correspondiente al texto explicativo más próximo a la región del campo. Este nombre aparecerá en la lista de campos de la ficha Campos en la ventana de la estructura del documento.

Al campo se le asignan propiedades predeterminadas.

  • Creación de grupos de marcas de verificación
  • Creación de tablas
  • Creación de un grupo de campos
  • Cómo cambiar un nombre de campo
  • Copia, movimiento y eliminación de campos
  • Campos sin región
  • Propiedades del campo


Creación de un grupo de marcas de verificación

Un grupo de marcas de verificación combina las marcas de verificación relacionadas lógicamente que, por lo general, corresponden a respuestas mutuamente exclusivas para la misma pregunta. En este caso, el programa seleccionará una marca de verificación del grupo y exportará su valor. Sin embargo, esta no es una condición obligatoria. Puede permitir que el programa marque más de una marca de verificación en un grupo (seleccione la opción correspondiente en las propiedades del grupo de marcas de verificación).

Una manera de crear un grupo de marcas de verificación:

Para crear un grupo de marcas de verificación:

  1. Después de seleccionar la herramienta [image], cree las marcas de verificación correspondientes al grupo.
  2. Seleccione la herramienta [image] y enmarque con un rectángulo todas las marcas de verificación que se incluirán en este grupo.
  3. Las marcas de verificación dentro del rectángulo se resaltarán. Se combinarán y se ubicarán sus nombres en la estructura del documento bajo el nombre del grupo de marcas de verificación. Las propiedades de las marcas de verificación pertenecientes al mismo grupo son idénticas y no pueden editarse de forma individual.

Otra manera de crear un grupo de marcas de verificación:

No necesita resaltar cada marca de verificación perteneciente al grupo.

  1. Sin resaltar las marcas de verificación de forma individual, seleccione la herramienta [image] y resalte con un rectángulo todas las marcas de verificación que se incluirán en este grupo.
  2. Las marcas de verificación dentro del rectángulo se detectarán automáticamente, se nombrarán y combinarán en un grupo.


Creación de un grupo de campos

Los campos pueden combinarse en grupos para habilitar una presentación clara de las estructuras de documentos y para crear grupos de campos recurrentes. Por ejemplo, el número de un edificio, de una calle o de una ciudad pueden combinarse en el grupo Dirección particular. Puede crear campos para un grupo Dirección de oficina; para ello, simplemente debe copiar el grupo de campos Dirección particular.

Para crear un grupo de campos:

  1. Cree los campos que se incluirán en el grupo.
  2. Seleccione la herramienta [image] y enmarque dentro de un rectángulo todos los campos que se incluirán en este grupo.
  3. Se resaltarán los campos dentro del rectángulo. Se combinarán y se ubicarán sus nombres en la estructura del documento bajo el nombre del grupo de campos.

Si el formulario cuenta con grupos de campos recurrentes, después de crear un grupo puede crear varias instancias del mismo grupo. Todas las propiedades del campo así como las reglas establecidas dentro del grupo se aplicarán a cada instancia del grupo. Consulte Campos con varias instancias.

También puede copiar un grupo de campos, pero en ese caso, la copia dará como resultado la creación de otro grupo independiente.


Creación de una tabla

ABBYY FlexiCapture 8.0 Professional le permite crear plantillas para documentos con tablas. La creación de campos de tabla puede simplificar notablemente la configuración, la extracción de datos y la exportación de datos provenientes de tablas. Un campo de tabla es un conjunto de columnas del mismo tipo y líneas recurrentes.

Las columnas de la tabla pueden ser de los siguientes tipos:

  • texto
  • marcas de verificación
  • códigos de barras
  • imágenes

Para crear una tabla:

  1. Seleccione la herramienta [image] y enmarque la región de la tabla con un rectángulo. El encabezado de la tabla no debe incluirse en la región seleccionada. En la barra de herramientas, aparecerán más herramientas de procesamiento de tablas:
    Creación de una columna de la tabla
    Creación de separadores
    Eliminación de un separador
  2. Desmarque las celdas de la tabla mediante la creación de la cantidad necesaria de separadores. Para crear separadores, seleccione la herramienta [image] y haga clic en el lugar donde se colocará el separador. Para crear separadores verticales, coloque el cursor en el área de la tabla, arrastre el señalador de puntos hasta la ubicación deseada y haga clic una vez. Para crear un separador horizontal, realice la misma operación, pero mantenga pulsada la tecla Alt. También puede detectar separadores automáticamente: seleccione la tabla creada y, a continuación, seleccione los elementos Detectar automáticamente separadores verticales y Detectar automáticamente separadores horizontales en el menú local.
  3. Creación de las columnas de la tabla: para crear una columna, seleccione la herramienta [image] y haga clic en la región de la columna. Seleccione un tipo de columna en la lista desplegable.


Cómo cambiar un nombre de campo

Cambio de un nombre de campo

Para cambiar el nombre de un campo:

  • Haga clic en el nombre del campo de la estructura del documento, haga clic con el botón derecho y seleccione Cambiar nombre en el menú contextual e introduzca un nombre nuevo.

  • O bien, haga clic en la región del campo de la imagen, haga clic con el botón derecho y seleccione Sugerir nombre en el menú contextual. Al campo se le asignará un nombre correspondiente al texto explicativo más próximo a la región del campo.

  • O bien, haga clic en la región del campo de la imagen, haga clic con el botón derecho y seleccione Obtener nombre de la imagen… en el menú contextual. A continuación, resalte con el cursor el texto explicativo que puede usarse como nombre del campo. El nombre del campo cambiará por el texto seleccionado.

  • O bien, abra el cuadro de diálogo propiedades del campo y cambie el nombre en la ficha General.


Copia, movimiento y eliminación de campos

Los campos pueden copiarse, eliminarse, moverse y modificarse. Los nombres de los campos copiados tienen números diferentes. Para resaltar varios campos, pulse Ctrl y haga clic. La acción seleccionada se aplicará a todos los campos resaltados.

Para eliminar un campo, resalte y presione la tecla Eliminar o seleccione Eliminar en el menú contextual. Para eliminar solo una región y mantener el campo en la estructura del documento, pulse Mayús+Eliminar o seleccione Eliminar región del menú contextual para el campo. Consulte Campos sin región.


Campos sin región

Es posible que el campo no tenga ninguna región en la imagen. Los nombres de los campos sin región están marcados con un asterisco rojo en la lista. Estos campos pueden usarse para almacenar resultados intermedios de los cálculos realizados con los valores de los campos que se están reconociendo. Por ejemplo, puede combinar los valores de varios campos con la ayuda de la regla de combinación de valores de campos y guardar el resultado en un campo sin región.

Los campos sin región tienen todas las propiedades del tipo de campo al que pertenecen. Los valores de estos campos también pueden exportarse.

Existen dos formas de crear un campo sin región:

  1. En la ventana del editor de plantillas, seleccione el elemento del menú Insertar y cree un campo del tipo necesario. El nombre del campo aparecerá en la lista marcado con un asterisco. En este caso, el programa crea un campo en la estructura del documento, pero no crea su región en la imagen.
  2. Otra forma de hacerlo consiste en eliminar la región de un campo común. Resalte el campo requerido en la imagen o en la lista y seleccione Eliminar región en el menú contextual. La región se eliminará y el nombre del campo se marcará con un asterisco rojo.

Para crear una región para los campos que no tienen una región en la imagen, seleccione [image] en la barra de herramientas y resalte la región requerida con el cursor. Si la lista incluye campos marcados con un asterisco, el programa le solicitará que seleccione el nombre de alguno de esos campos.


Exclusión de una región del reconocimiento

En ocasiones, es necesario excluir ciertas regiones del reconocimiento; por ejemplo, una región con texto explicativo que complica la extracción de datos del campo.

Para excluir una región del reconocimiento, seleccione la herramienta [image] y resalte con el cursor la región que se excluirá.


Creación de un campo con una región no rectangular

A veces, es necesario crear campos con regiones no rectangulares, como se ejemplifica en el cuestionario:

Para crear un campo con región no rectangular:

  1. Seleccione la herramienta para crear un campo del tipo necesario.
  2. Seleccione una región rectangular en la que pueda agregar o eliminar fragmentos para crear una región de la forma necesaria.
  3. Seleccione la herramienta [image] y asegúrese de que la región rectangular esté resaltada.
  4. Para agregar un fragmento a la región: pulse Mayús (el cursor aparecerá como un signo "más") y resalte el fragmento que desee agregar.
  5. Para excluir un fragmento de la región: pulse Alt (el cursor aparecerá como un signo "menos") y resalte el fragmento que desee excluir.


Campos con varias regiones

Un campo puede incluir varias regiones en la imagen. Esas regiones pueden estar ubicadas a una distancia entre sí o incluso en diferentes páginas. Los valores de todas las regiones del mismo campo se combinan y se exportan en forma conjunta como un campo.

Es conveniente crear varias regiones para los campos ubicados en varias páginas, por ejemplo, para tablas grandes.

Mostrar ejemplo

Para crear un campo con varias regiones, realice los siguientes pasos:

  1. Cree un campo.
  2. Resáltelo, haga clic con el botón derecho en la región del campo y seleccione Continuar región… en el menú contextual.
  3. Mueva la imagen de la región a la ubicación que desee de la página.


Campos con varias instancias

Pueden aparecer elementos recurrentes en sus campos. Estos son campos y grupos de campos que aparecen en el formulario cierta cantidad de veces y describen objetos similares, tales como los mismos detalles de varios empleados, niños, cuentas, etc. Para estos objetos se crean campos con varias instancias.

Cualquier campo puede tener varias instancias. Sus regiones pueden estar ubicadas a una distancia entre sí o incluso en diferentes páginas. Las instancias de los campos tienen las mismas propiedades. Se exportan a tablas de la base de datos o archivos independientes.

Se pueden crear varias instancias para un grupo de campos si el formulario tiene grupos recurrentes.

Mostrar ejemplo

Para crear un campo con varias instancias, realice los siguientes pasos:

  1. Cree un campo.
  2. Resáltelo, haga clic con el botón derecho en la región del campo y, en el menú contextual, seleccione Nueva instancia….
  3. Mueva la imagen de la región a la ubicación que desee de la página.


Propiedades del campo

Es muy importante que se configuren correctamente las propiedades de cada campo. Las propiedades del campo afectan la calidad de su reconocimiento y determinan si sus valores se van a exportar y se van a enviar al operador para la verificación. Ciertas propiedades son muy importantes para el reconocimiento de datos. Por ejemplo, el método de marcación del campo de entrada de texto: si está configurado incorrectamente, la marcación que no desaparece durante la digitalización no se separará de los caracteres, y los resultados de reconocimiento pueden no ser satisfactorios.

Los campos de cada tipo tienen su propio conjunto de propiedades. Cuando crea un campo de un cierto tipo en la imagen, se le asignan propiedades predeterminadas a este.

Cómo cambiar las propiedades del campo:

  1. Resalte el nombre del campo en la estructura del documento o la región del campo en la imagen, haga clic con el botón derecho y seleccione Propiedades… en el menú contextual.
  2. Modifique las propiedades del campo en el cuadro de diálogo que se abrirá.

Obtenga más información acerca de las propiedades del campo:

Campos de entrada de texto
Marcas de verificación
Grupos de marcas de verificación
Códigos de barras
Imágenes
Tablas
Grupos de campos


Campo de entrada de texto

Cuando crea un campo de texto, se le asignan propiedades predeterminadas a este. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye cinco fichas para los diferentes grupos de propiedades:

Propiedades básicas
Tipos de datos
Propiedades del reconocimiento
Propiedades de la verificación
Validación de regla


Propiedades básicas del campo

Puede configurar las propiedades básicas del campo en la ficha General.

En esta ficha, el tipo de campo se muestra como un icono ubicado a la derecha del nombre.

  • Nombre: nombre del campo. El nombre se asigna automáticamente cuando se crea el campo y corresponde al texto explicativo más próximo al campo. Al editar las propiedades, puede cambiar el nombre asignado de manera predeterminada. Consulte también Cómo cambiar el nombre del campo.
  • Título: nombre del campo que se mostrará en el formulario de datos.
  • Exportar valor del campo: esta opción debe estar habilitada si desea exportar el valor del campo (habilitada de manera predeterminada). Es posible que necesite deshabilitar esta opción si, por ejemplo, el valor de este campo se usa para obtener el valor de un campo calculado (consulte Validación de regla) y solo debe exportarse el resultado final.
  • Mostrar en formulario de datos: esta opción debe habilitarse si el campo debe mostrarse en el formulario de datos (habilitada de manera predeterminada).
  • No puede estar vacío: habilite esta opción si desea convertirla en un campo obligatorio.
  • Sólo lectura: habilite esta opción si el campo solo debe estar disponible para la visualización; es decir, el operador no podrá modificar su valor. Puede habilitar esta opción para los campos cuyos valores deben calcularse automáticamente a través de una regla, por ejemplo, para un campo en el que planea guardar la suma o combinar otros campos (consulte Validación de regla).
  • Campo Índice: habilite esta opción si cree que utilizará este campo para realizar la indexación de documentos. Al procesar documentos, podrá ver el valor de este campo para cada documento, así como ordenar y buscar los documentos según el valor del campo.
  • Comentario: puede introducir cualquier comentario.


Tipos de datos del campo de entrada de texto

Es muy importante que asigne un tipo de datos a un campo de entrada de texto para informar al programa el tipo de datos que espera ver en este campo: ya sean solo números, letras de un determinado alfabeto, caracteres de un grupo específico, una fecha o un elemento semejante. El mecanismo de configuración de los tipos de datos es muy flexible, y el usuario puede seleccionar un tipo de datos de una lista de tipos de datos disponibles y crear tipos de datos personalizados que resulten adecuados para una tarea específica.

Al especificar los tipos de datos, puede configurar la comprobación de formato del valor de entrada y configurar las restricciones del valor, como las restricciones de longitud del texto, el valor mínimo y máximo para el número, el intervalo de tiempo y la fecha.

Si durante el procesamiento de documentos el valor del campo reconocido no se puede asociar con el tipo de datos configurado, el operador recibirá un mensaje de error.

El tipo de datos para el campo de entrada de texto puede especificarse en la ficha Tipo de datos del cuadro de diálogo de las propiedades del campo.

Texto
  1. Si este campo va a incluir texto, seleccione Texto en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionados. Si desea cambiar el idioma, el uso de diccionarios, o especificar un tipo de datos más estrecho, haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Para el tipo de texto estándar (es decir, seleccione General en la lista Configuración de contenido), puede usar un diccionario incorporado o un diccionario personalizado. En este caso, el valor del campo se cotejará con estos diccionarios.
      Para utilizar un diccionario incorporado, seleccione la opción Usar diccionario incorporado.
      Para utilizar un diccionario personalizado, seleccione la opción Usar diccionario personalizado y haga clic en Editar… para editar el diccionario. Puede crear un diccionario personalizado; para hacerlo, agregue palabras de a una (haga clic en el botón Agregar... para agregar una palabra) o cargue una lista de palabras de un archivo (haga clic en el botón Cargar... y especifique la ruta al archivo deseado con la extensión *.txt o *.dic).
    • El tipo de texto especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Número
  1. Si este campo va a incluir un valor numérico, seleccione Número en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionados. Si desea cambiar el idioma, cambie el número entero a fracción o viceversa, o especifique un tipo de datos más estrecho (por ejemplo, un número de dos dígitos o un número romano) y haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione Número entero, si el campo debe incluir un número entero. Borre esta opción si el campo debe incluir una fracción.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para un número entero o una fracción.
    • El tipo de número especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para los números.
Importante: No utilice el tipo de datos de número para los campos que incluyen números que solo son números de manera formal, pero se utilizan realmente como códigos (por ejemplo, números de tarjetas de crédito, series de pasaporte, etc.). La especificación del tipo de datos de número para estos campos puede causar errores (por ejemplo, los ceros al inicio de las cadenas se eliminarán). Para casos como este, cree un tipo de texto personalizado y especifique un alfabeto de 0 a 9 (y agregue una expresión regular si es necesario) o use el tipo de datos de número de todos modos, pero asegúrese de seleccionar la opción Procesar valor como texto. En el último caso, se procesa el valor del campo como texto, se puede usar un diccionario personalizado para comprobar el valor y se puede especificar el rango de posibles valores del mismo modo que un valor de texto. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Fecha
  1. Si este campo va a incluir una fecha, seleccione Fecha en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionados. Si desea cambiar el idioma, cambie el orden de los componentes de la fecha, agregue la hora o los días de la semana, o especifique un tipo de datos más estrecho (por ejemplo, los meses se indican con números romanos) y haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione el orden deseado en la lista Orden del componente fecha.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para las fechas escritas en formatos estándar. Para el tipo de datos estándar, están disponibles las siguientes opciones adicionales:
      Puede incluir un mes en palabras: utilice esta opción si los meses también pueden escribirse en palabras, no solo en números;
      Puede incluir un día de la semana: utilice esta opción si las fechas pueden incluir los días de la semana;
      Puede incluir la hora: utilice esta opción si las fechas pueden incluir la hora.
    • El tipo de fecha especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para la fecha.
Importante: Si la fecha no puede reducirse a un formato estándar o no va a procesar los valores en este campo como fechas, seleccione la opción Procesar valor como texto. En este caso, se procesa el valor del campo como texto, se puede usar un diccionario personalizado para comprobar el valor y se puede especificar el rango de posibles valores del mismo modo que un valor de texto. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Cantidad de dinero
  1. Si este campo va a incluir una cantidad de dinero, seleccione Cantidad de dinero en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionado. Si desea cambiar el idioma o especificar un tipo de datos más estrecho (por ejemplo, un código de moneda), haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para la cantidad de dinero si el valor del campo es un número o si el número va acompañado de un código o símbolo de moneda estándar.
    • El tipo especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Importante: Si la cantidad de dinero no puede reducirse a un formato estándar o no va a procesar los valores en este campo como una cantidad de dinero, seleccione la opción Procesar valor como texto. En este caso, se procesa el valor del campo como texto, se puede usar un diccionario personalizado para comprobar el valor y se puede especificar el rango de posibles valores del mismo modo que un valor de texto. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Dirección
  1. Si este campo va a incluir una dirección, seleccione Dirección en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionado. Si desea cambiar el idioma, especificar un diccionario personalizado o especificar un tipo de datos más estrecho (por ejemplo, una dirección de correo electrónico o un código postal), haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para la dirección. Se recomienda el uso de un diccionario personalizado en este caso. Para utilizar un diccionario personalizado, seleccione la opción Usar diccionario personalizado y haga clic en Editar… para editar el diccionario. Puede crear un diccionario personalizado; para hacerlo, agregue palabras de a una (haga clic en el botón Agregar... para agregar una palabra) o cargue una lista de palabras de un archivo (haga clic en el botón Cargar... y especifique la ruta al archivo deseado con la extensión *.txt o *.dic).
    • El tipo especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Nombre
  1. Si este campo va a incluir un nombre, seleccione NombreNombre en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionado. Si desea cambiar el idioma, especificar un diccionario personalizado o especificar un tipo de datos más estrecho (por ejemplo, un nombre o un apellido), haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para el nombre. Se recomienda el uso de un diccionario personalizado en este caso. Para utilizar un diccionario personalizado, seleccione la opción Usar diccionario personalizado y haga clic en Editar… para editar el diccionario. Puede crear un diccionario personalizado; para hacerlo, agregue palabras de a una (haga clic en el botón Agregar... para agregar una palabra) o cargue una lista de palabras de un archivo (haga clic en el botón Cargar... y especifique la ruta al archivo deseado con la extensión *.txt o *.dic).
    • El tipo especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.
Código
  1. Si este campo va a incluir un código formado por letras y dígitos, seleccione CódigoCódigo en la lista Contenido.
    En el campo Detalles, verá una descripción del tipo de datos seleccionados. Si desea cambiar el idioma, especificar un diccionario personalizado o especificar un tipo de datos más estrecho (por ejemplo, un número de seguro social), haga clic en el botón Editar… ubicado a la derecha de la descripción. En el cuadro de diálogo que se abrirá, puede:
    • Cambiar el idioma de reconocimiento para este campo. Para cambiar el idioma, haga clic en el botón "..." ubicado a la derecha del campo Idioma. Puede seleccionar uno o varios idiomas.
    • Seleccione el tipo de datos estándar (es decir, seleccione General en la lista Configuración de contenido) para el código alfanumérico. Se recomienda el uso de un diccionario personalizado en este caso. Para utilizar un diccionario personalizado, seleccione la opción Usar diccionario personalizado y haga clic en Editar… para editar el diccionario. Puede crear un diccionario personalizado; para hacerlo, agregue palabras de a una (haga clic en el botón Agregar... para agregar una palabra) o cargue una lista de palabras de un archivo (haga clic en el botón Cargar... y especifique la ruta al archivo deseado con la extensión *.txt o *.dic).
    • El tipo especial (es decir, seleccione Especial en la lista Configuración de contenido) contiene tipos de datos predefinidos, entre los cuales puede seleccionar el tipo de datos adecuado para el campo determinado. Al seleccionar un tipo de datos, consulte la descripción que aparece en la parte inferior del cuadro de
      diálogo. También puede crear su propio tipo de datos personalizado si ninguno de los tipos predefinidos se adapta a sus fines. Para obtener detalles, consulte Creación de tipos de datos personalizados.
  2. Para cualquier tipo de datos, el programa puede procesar automáticamente los valores introducidos: eliminar espacios innecesarios, convertir letras a mayúscula o minúscula, o reemplazar automáticamente fragmentos de texto o caracteres específicos. Para habilitar el procesamiento automático de valores, haga clic en el botón Editar… junto al campo Opciones de corrección automática. En el cuadro de diálogo que se abrirá, seleccione las opciones de procesamiento automático necesarias. Para obtener detalles, consulte Procesamiento de valores introducidos.
  3. También puede configurar la validación del valor para el campo de modo que el programa verifique si el valor introducido se encuentra dentro del rango que especificó. Para especificar un rango de valores para el campo, haga clic en el botón Editar… ubicado a la derecha del campo Validación. Para obtener detalles, consulte Restricciones del rango de valor para el tipo de datos de texto.


Creación de tipos de datos personalizados

Para crear un nuevo tipo de datos, seleccione el elemento deseado en la lista Contenido de la ficha Tipo de datos en las propiedades del campo. Puede seleccionar cualquier elemento de la lista que coincida con la semántica del tipo de datos personalizado: esto no afectará la naturaleza del nuevo tipo de datos, pero se almacenará en la categoría seleccionada.

Haga clic en el botón Editar… ubicado a la derecha del campo Detalles.

En el cuadro de diálogo que se abrirá, seleccione Especial en el campo Configuración de contenido.

Haga clic en el botón Nuevo… ubicado a la derecha del campo Tipos de datos para el idioma seleccionado.

Siga las instrucciones del asistente para la creación de tipos de datos.

En la primera ventana del asistente, seleccione cómo se crearán los datos. Puede crear un nuevo tipo de datos basado en un diccionario, una expresión regular, un alfabeto o un tipo de datos existente (por ejemplo, al agregar los caracteres deseados a su alfabeto o al expandir su diccionario).

Para crear un nuevo tipo de datos basado en un diccionario, una expresión regular o un alfabeto:

  1. Seleccione Nuevo tipo de datos basado en y seleccione la base que usará para el nuevo tipo de datos: un diccionario, una expresión regular o un alfabeto. Luego, seleccione Idioma (configuración regional) para su tipo de datos y haga clic en Siguiente.
  2. Si decide crear un nuevo tipo de datos basado en un diccionario, en la siguiente ventana del asistente se le solicitará que seleccione el tipo de diccionario que utilizará.
    Seleccione Usar diccionario incorporado si desea utilizar el diccionario incorporado para el idioma seleccionado en la ventana anterior. Para comprobar si el diccionario incluye una palabra en particular, haga clic en Ver… y escriba la palabra. Haga clic en el botón Ver para mostrar las formas conjugadas de la palabra o un mensaje de advertencia que indique que no existe esa palabra en el diccionario.
    Seleccione Usar diccionarios personalizados si desea utilizar un diccionario personalizado y haga clic en Editar… para editar el diccionario. Puede crear un diccionario personalizado; para hacerlo, agregue palabras de a una (haga clic en el botón Agregar... para agregar una palabra) o cargue una lista de palabras de un archivo (haga clic en el botón Cargar... y especifique la ruta al archivo deseado con la extensión *.txt o *.dic). Haga clic en Siguiente.
  3. Si decide crear un nuevo tipo de datos basado en una expresión regular, el asistente le indicará que introduzca una expresión regular. Utilice el botón [image] ubicado a la derecha del campo de expresión regular para crear su expresión regular. Para obtener detalles, consulte Alfabeto utilizado en expresiones regulares. Haga clic en Siguiente.
  4. Si decide crear un nuevo tipo de datos basado en un alfabeto o si utilizó caracteres en la expresión regular que no están incluidos en el alfabeto del idioma, el asistente le solicitará que especifique un alfabeto para el tipo de datos. Puede escribir los caracteres deseados directamente desde el teclado o hacer clic en Personalizar… y utilizar el ratón para seleccionar los caracteres deseados.

    Para agregar signos de puntuación y caracteres excluidos (prohibidos), haga clic en Parámetros avanzados…. Puede escribir los caracteres prohibidos directamente desde el teclado o hacer clic en el botón ubicado a la derecha y usar el ratón para seleccionar los caracteres deseados.

    Haga clic en Siguiente.

  5. En la última ventana del asistente, escriba un nombre para el nuevo tipo de datos y una breve descripción. Si desea editar las propiedades del tipo de datos recientemente creado, seleccione la opción Editar propiedades. Haga clic en Finalizar.

Para crear un nuevo tipo de datos basado en un tipo de datos existente:

  1. En la primera ventana del asistente para la creación de tipos de datos, seleccione Tipo de datos basado en tipos existentes. Seleccione los idiomas deseados y haga clic en Siguiente.
  2. En la siguiente ventana, seleccione los tipos de datos de origen a partir de los que creará el nuevo tipo de datos. Los tipos de datos que corresponden a los idiomas seleccionados se enumeran en los Tipos de datos disponibles en la parte izquierda del cuadro de diálogo. La carpeta Texto incluye los idiomas naturales seleccionados en la primera ventana. La carpeta Personalizado incluye los tipos de datos creados por los usuarios. Las demás carpetas incluyen los tipos de datos correspondientes a la categoría y tipo especial de contenido.
    Para seleccionar un tipo de datos de origen, elíjalo en el campo Tipos de datos disponibles (mantenga pulsada la tecla Ctrl para seleccionar más de uno) y haga clic en Agregar -> para transferirlo al panel derecho. Haga clic en Siguiente.
  3. En la última ventana del asistente, escriba un nombre para el nuevo tipo de datos y una breve descripción. Si desea editar las propiedades del tipo de datos recientemente creado, seleccione la opción Editar propiedades. Haga clic en Finalizar.

El tipo de datos recién creado aparecerá en la lista de tipos de datos predefinidos cuando selecciona el contenido seleccionado durante la creación del tipo de datos.

Para especificar el tipo de datos recién creado para su campo:

  1. En la ficha Tipo de datos del cuadro de diálogo de las propiedades del campo, seleccione el elemento deseado en la lista Contenido.
  2. Haga clic en el botón Editar… ubicado a la derecha del campo Detalles.
  3. En la lista Configuración de contenido, seleccione Especial.
  4. En la lista que aparecerá, seleccione el tipo de datos que creó (los tipos de datos personalizados están marcados con un símbolo especial) y haga clic en Aceptar.


Restricciones del rango de valor para el tipo de datos del texto

En el cuadro de diálogo Configuración de validación, puede especificar las restricciones del rango de valor para el texto introducido en el campo.

Nota: El programa considerará como tipo de texto no solo a los tipos de datos con contenido de texto sino también a los tipos de datos con otro contenido para los que se seleccione la opción Procesar valor como texto.

  • Longitud máxima: especifique la longitud máxima del texto en el campo.
  • Expresión regular: habilite esta opción si desea comprobar los valores del campo con una expresión regular.

    El [image] botón lo ayudará a formar una expresión regular de manera correcta. Para obtener detalles, consulte Alfabeto usado en expresiones regulares.

  • Valores permitidos: seleccione esta opción si desea especificar una lista de valores permitidos para este campo. Para agregar un valor, haga clic en Agregar… e introduzca el valor en el cuadro de diálogo que se abrirá. Para editar un valor, haga clic en Editar… Para eliminar un valor, haga clic en Eliminar.
  • Tratar error de validación como advertencia: seleccione esta opción si desea que cualquier incumplimiento con las restricciones que especificó se consideren una advertencia.


Restricciones del rango de valor para los números

Para especificar las restricciones del rango de valor para los números:

  1. Habilite la opción Usar restricciones.
  2. Especifique los valores de la cantidad mínima y máxima.
  3. Tratar error de validación como advertencia: seleccione esta opción si desea que cualquier incumplimiento con las restricciones específicas se consideren una advertencia.

Al procesar documentos, el programa comprobará si el valor introducido está dentro del intervalo que se especificó.


Restricciones del rango de valores para la fecha

En el cuadro de diálogo Configuración de validación, puede especificar el intervalo para la fecha introducida en este campo.

  1. Habilite la opción La fecha debe encontrarse dentro del siguiente intervalo.
  2. Seleccione Fija para establecer un intervalo de tiempo fijo o seleccione En relación a la fecha de verificación para establecer un intervalo de tiempo en relación con la fecha de verificación del documento.
  3. Introduzca el inicio y el final del intervalo.
  4. Tratar error de validación como advertencia: seleccione esta opción si desea que cualquier incumplimiento con las restricciones específicas se consideren una advertencia.


Procesamiento del valor introducido para el tipo de datos de texto

Procesamiento de valores introducidos

Para cualquier tipo de datos, puede realizar el procesamiento automático del valor introducido: eliminar espacios blancos, convertir letras a mayúscula o minúscula, reemplazar automáticamente texto o caracteres específicos. Para habilitar el procesamiento automático de los valores del campo, en la ficha Tipo de datos del cuadro de diálogo de las propiedades del campo, haga clic en el botón Editar… ubicado a la derecha del campo Opciones de corrección automática.

Seleccione las opciones de procesamiento automático deseadas.

Si está seleccionado Aplicar corrección automática sólo una vez después del reconocimiento, el procesamiento automático se realiza solo una vez después de que se haya reconocido el valor del campo. De lo contrario, el procesamiento automático se realiza cada vez que cambia el valor del campo.

  • Para realizar el reemplazo automático de caracteres en el valor del campo reconocido, haga clic en el botón Editar… ubicado a la derecha del campo Reemplazar caracteres. En el cuadro de diálogo que se abrirá, puede agregar caracteres para el reemplazo automático. Si los caracteres específicos aparecen en el valor del campo reconocido, se reemplazarán automáticamente.
  • Para realizar el reemplazo automático del valor completo del campo reconocido o de las palabras por separado, haga clic en el botón Editar… ubicado a la derecha del campo Reemplazar texto.

    En el cuadro de diálogo que se abrirá, puede agregar palabras y expresiones para el reemplazo automático. Para reemplazar el valor del campo completo, habilite la opción Reemplazar el valor del campo completo. En este caso, el reemplazo automático se realizará solo cuando la palabra o expresión que se especificaron representan un valor del campo completo. Para reemplazar las palabras individuales, habilite la opción Reemplazar palabras encontradas.

    Si activa la opción Exacta, el programa buscará y reemplazará la palabra o expresión exactas que introdujo, o si habilita Aproximada, el programa buscará y reemplazará una palabra o expresión similares a alguna que haya introducido. La cantidad de errores permitidos dependerá de la longitud de la palabra.

    Habilite la opción Coincidir mayúsculas y minúsculas para las palabras o expresiones de reemplazo que distinguen entre mayúsculas y minúsculas.

  • Elija uno de los métodos de conversión de letras del texto en la lista desplegable Cambiar el uso de mayúsculas:

    Ninguno: sin conversión.

    MAYÚSCULA: todas las letras se cambiarán a mayúscula.

    minúscula: todas las letras se cambiarán a minúscula.

    Mayúscula inicial: la primera letra estará en mayúscula y las siguientes en minúscula.

  • Eliminar espacios innecesarios: habilite esta opción si desea eliminar los espacios en blanco.


Opciones del reconocimiento de campos de texto

Las propiedades del reconocimiento se establecen en la ficha Reconocimiento del cuadro de diálogo de las propiedades del campo (elemento Propiedades… en el menú contextual del campo). Los valores del campo correctamente determinados aumentan de manera considerable la calidad del reconocimiento y reducen las probabilidades de que se generen errores.

  • No reconocer (campo de clave de imagen: se introducirá manualmente): habilite esta opción si el campo no puede reconocerse por algún motivo (por ejemplo, si el texto del campo incluye letras combinadas) y el operador va a introducir su valor de forma manual. En este caso, no debe configurar otras propiedades del reconocimiento, ya que este campo no se reconocerá y al operador se le solicitará que introduzca el valor del campo durante la verificación.

  • ICR (manuscrito): habilite esta opción si el texto estático de este campo es manuscrito.

  • OCR (impreso): habilite esta opción si el texto estático de este campo está impreso. Seleccione el estilo de impresión de la lista desplegable (tipográfico, impresora matricial de puntos, máquina de escribir, etc.). Consulte también Tipos de texto compatibles.

  • Avanzado: utilice esta opción para seleccionar varios tipos de texto o especificar un tipo de texto personalizado.

  • Tipo de marcado: seleccione el tipo de marcación; para simplificar la elección, seleccione las muestras de la lista desplegable. Si la marcación desaparece durante la digitalización, su tipo de marcación es monoespaciado (cuadros grises). Si la marcación no desaparece durante la digitalización y se divide en celdas para espacios de caracteres, debe introducir la cantidad total de celdas. Cuando el programa detecta de forma automática los campos con esa marcación, la cantidad de celdas se determina de forma automática.

  • Tipo de letra: seleccione los tipos de letra en el campo. Si tanto las letras mayúsculas como las minúsculas son posibles, deje habilitada la opción Automático.

  • Orientación: especifique la orientación del texto.

  • Habilite la opción Una línea para los campos de una línea.

  • Para los campos cuyos valores siempre incluirán una palabra única, habilite la opción Una palabra.

  • Configure las opciones del procesamiento de imágenes durante el reconocimiento:

  • Invertir: invierte la imagen.
  • Eliminar textura: quita la textura.
  • Refinar: habilite esta opción para eliminar los elementos no utilizados de la imagen.
  • Borrar residuos sólo del tamaño especificado: habilite esta opción si desea eliminar los residuos del tamaño específico únicamente. Especifique el tamaño de los residuos. Si esta opción está deshabilitada y solo está habilitada la opción Refinar, el tamaño de los residuos se seleccionará automáticamente.


Propiedades de la verificación de campo

La verificación se realiza por medio del operador y es el proceso de comprobación de datos reconocidos. El programa marca los caracteres reconocidos sin certeza y los envía al operador para que este los verifique. Sin embargo, puede configurar las propiedades del campo de modo que el programa envíe un campo para que lo verifiquen aunque no contenga caracteres reconocidos sin certeza. De lo contrario, no lo enviará para que lo verifiquen aunque contenga caracteres reconocidos sin certeza. El operador puede ver un carácter reconocido y su imagen, y confirmar o corregir el resultado del reconocimiento.

Al crear una plantilla, puede configurar las opciones de verificación en la ficha Verificación del cuadro de diálogo de las propiedades del campo.

Seleccione el valor de la lista desplegable:

  • Verificar reconocimiento incierto sin certeza: los caracteres del campo se envían para que los verifiquen si se los ha reconocido sin certeza. Este valor se asigna a todos los campos de manera predeterminada.
  • Verificar todos los caracteres: se envían los caracteres del campo para que los verifiquen. Puede seleccionar el valor denominado todos si no se permiten errores en los valores para este campo.
  • Verificar ninguno caracteres: los caracteres de este campo no se envían para que los verifiquen.

Habilite las opciones:

  • Incluir en la verificación de grupo: habilite esta opción para incluir los caracteres del campo en la verificación de grupo. Si bien todos los campos pueden incluirse en la verificación de grupo, solo se deben enviar marcas de verificación y campos que incluyan números en la verificación de grupo. Por el contrario, es mejor verificar las letras dentro del contexto del valor del campo.
  • Incluir en la verificación de campo: habilite esta opción para incluir el campo en la verificación de campo.


Marcas de verificación

Importante: Las propiedades de las marcas de verificación combinadas en grupos se configuran para todo el grupo de marcas de verificación. Si intenta editar las propiedades de una marca de verificación que pertenece a un grupo, se abrirá el cuadro de diálogo para editar las propiedades del grupo de marcas de verificación.

Cuando crea un campo de marca de verificación, se le asignan propiedades predeterminadas a este. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye cinco fichas para los diferentes grupos de propiedades:

Propiedades básicas
Propiedades del reconocimiento
Tipos de datos
Propiedades de la verificación
Validación de regla


Propiedades básicas del campo

Puede configurar las propiedades básicas del campo en la ficha General.

En esta ficha, el tipo de campo se muestra como un icono ubicado a la derecha del nombre.

  • Nombre: nombre del campo. El nombre se asigna automáticamente cuando se crea el campo y corresponde al texto explicativo más próximo al campo. Al editar las propiedades, puede cambiar el nombre asignado de manera predeterminada. Consulte también Cómo cambiar el nombre del campo.
  • Título: nombre del campo que se mostrará en el formulario de datos.
  • Exportar valor del campo: esta opción debe estar habilitada si desea exportar el valor del campo (habilitada de manera predeterminada). Es posible que necesite deshabilitar esta opción si, por ejemplo, el valor de este campo se usa para obtener el valor de un campo calculado (consulte Validación de regla) y solo debe exportarse el resultado final.
  • Mostrar en formulario de datos: esta opción debe habilitarse si el campo debe mostrarse en el formulario de datos (habilitada de manera predeterminada).
  • Sólo lectura: habilite esta opción si el campo solo debe estar disponible para la visualización; es decir, el operador no podrá modificar su valor. Puede habilitar esta opción para los campos cuyos valores deben calcularse automáticamente a través de una regla, por ejemplo, para un campo en el que planea guardar la suma o combinar otros campos (consulte Validación de regla).
  • Comentario: puede introducir cualquier comentario.


Tipos de datos para marcas de verificación

El tipo de datos para las marcas de verificación se puede configurar en la ficha Tipo de datos del cuadro de diálogo de las propiedades del campo.

El tipo de datos para las marcas de verificación determina los valores que se asignarán al campo de marca de verificación para una marca de verificación seleccionada y no seleccionada.

Seleccione las opciones apropiadas para los valores de las marcas de verificación:

  • Sí/No: si se seleccionó la marca de verificación, el valor del campo es "Sí"; si no se seleccionó, es "No".
  • 1/0: si se seleccionó la marca de verificación, el valor del campo es 1; si no se seleccionó, es 0.
  • <Nombre de marca de verificación>/Vacío: si se selecciona la marca de verificación, el valor del campo se asociará con el nombre de la marca de verificación; si no se selecciona, al campo se le asignará un valor vacío.
  • Personalizado: al habilitar esta opción, puede introducir sus valores personalizados; Seleccionado para una marca de verificación seleccionada y No seleccionado para una marca de verificación no seleccionada.


Propiedades del reconocimiento de las marcas de verificación

Las propiedades del reconocimiento se establecen en la ficha Reconocimiento del cuadro de diálogo de las propiedades del campo (Propiedades… en el menú contextual de este campo). Los valores del campo correctamente determinados aumentan de manera considerable la calidad del reconocimiento y reducen las probabilidades de que se generen errores.

  • Tipo de marca de verificación: seleccione el tipo de marca de verificación. Esta propiedad es muy importante para el reconocimiento correcto de las marcas de verificación.

    Cuadro: seleccione este tipo de marca de verificación si las marcas de verificación se colocan en marcos cuadrados restringidos.

    Sin marco: seleccione este tipo de marca de verificación si las marcas de verificación se colocan frente a un fondo blanco sin marcos.

    Automático: si selecciona este tipo, el programa determinará automáticamente el tipo de marca de verificación.
    Importante: Tenga en cuenta que en este caso, la marca de verificación del formulario no debe seleccionarse, ya que el programa detecta si la marca de verificación está seleccionada al comparar la imagen de la marca de verificación en un documento procesado con la imagen del formulario en blanco usado para crear la plantilla.

  • Permitir correcciones: habilite esta opción si desea permitir las correcciones de cualquier marca de verificación; en este caso, las marcas de verificación tachadas se considerarán no seleccionadas. Sin embargo, si seleccionó el tipo Automático, es posible que no permita las correcciones de esas marcas de verificación.

    • Puede configurar las opciones de procesamiento de imágenes del campo:

  • Invertir: invierte la imagen.
  • Eliminar textura: quita la textura.
  • Refinar: habilite esta opción para eliminar los elementos no utilizados de la imagen.
  • Borrar residuos sólo del tamaño especificado: habilite esta opción si desea eliminar los residuos de un tamaño específico únicamente. Especifique el tamaño de los residuos. Si esta opción está deshabilitada y solo está habilitada la opción Refinar, el tamaño de los elementos sin utilizar se seleccionará automáticamente.


Propiedades de la verificación de campo

La verificación se realiza por medio del operador y es el proceso de comprobación de datos reconocidos. El programa marca los caracteres reconocidos sin certeza y los envía al operador para que este los verifique. Sin embargo, puede configurar las propiedades del campo de modo que el programa envíe un campo para que lo verifiquen aunque no contenga caracteres reconocidos sin certeza. De lo contrario, no lo enviará para que lo verifiquen aunque contenga caracteres reconocidos sin certeza. El operador puede ver un carácter reconocido y su imagen, y confirmar o corregir el resultado del reconocimiento.

Al crear una plantilla, puede configurar las opciones de verificación en la ficha Verificación del cuadro de diálogo de las propiedades del campo.

Seleccione el valor de la lista desplegable:

  • Verificar reconocimiento incierto sin certeza: los caracteres del campo se envían para que los verifiquen si se los ha reconocido sin certeza. Este valor se asigna a todos los campos de manera predeterminada.
  • Verificar todos los caracteres: se envían los caracteres del campo para que los verifiquen. Puede seleccionar el valor denominado todos si no se permiten errores en los valores para este campo.
  • Verificar ninguno caracteres: los caracteres de este campo no se envían para que los verifiquen.

Habilite las opciones:

  • Incluir en la verificación de grupo: habilite esta opción para incluir los caracteres del campo en la verificación de grupo. Si bien todos los campos pueden incluirse en la verificación de grupo, solo se deben enviar marcas de verificación y campos que incluyan números en la verificación de grupo. Por el contrario, es mejor verificar las letras dentro del contexto del valor del campo.


Grupos de marcas de verificación

Importante: Las propiedades del grupo se aplican a todas las marcas de verificación que pertenecen a un grupo de marcas de verificación.

El valor de un grupo de marcas de verificación es una lista de nombres de las marcas de verificación seleccionadas separados por un punto y coma (;) o una cadena vacía en el caso de que no se hayan seleccionado marcas de verificación.

Cuando crea un grupo de marcas de verificación, se le asignan propiedades predeterminadas a este. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye cinco fichas para los diferentes grupos de propiedades:

Propiedades básicas
Propiedades del reconocimiento
Tipos de datos
Propiedades de la verificación
Validación de regla


Tipos de datos para grupos de marcas de verificación

El tipo de datos para un grupo de marcas de verificación se puede configurar en la ficha Tipo de datos del cuadro de diálogo de las propiedades del campo.

Permitir selección vacía: habilite esta opción si se debe al menos una marca de verificación en el grupo. En este caso, si no se seleccionó ninguna marca de verificación en el grupo, el programa mostrará una advertencia relevante.

Permitir selección múltiple: habilite esta opción para permitir la selección de varias marcas de verificación en el grupo. Si se deshabilita esta opción, el programa mostrará una advertencia cuando se hayan seleccionado varias marcas de verificación en el grupo.

Para cambiar el nombre de una marca de verificación, seleccione la línea que desee y haga clic en Editar…. En el cuadro de diálogo que se abrirá, proporcione un nuevo nombre para el campo de marca de verificación y un nuevo nombre para asignarle a la marca de verificación durante la exportación.

Puede definir los valores que se exportarán para los casos en que no se seleccionen campos de marca de verificación y para los casos en que se seleccione más de un campo de marca de verificación. Para hacerlo, seleccione <No se seleccionó ningún elemento> o <Varios elementos…> en la lista, haga clic en Editar… y en el cuadro de diálogo que se abrirá, especifique el valor que desee en el campo Valor exportado. Si no se especificaron valores de exportación: a) en el caso de que no haya campos de marca de verificación seleccionados, se exportará una cadena vacía y b) en el caso de que haya varios campos seleccionados, se especificarán los valores de los campos de marca de verificación seleccionados (separados por comas).

Creación de un grupo de marcas de verificación


Código de barras

Cuando crea un campo de código de barras, se le asignan propiedades predeterminadas a este. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye cinco fichas para los diferentes grupos de propiedades.

Importante: Un código de barras puede resaltarse como un campo o un elemento estático. Esto depende del valor del código de barras en los documentos que se están procesando: si se lo va a usar para la asociación o identificación de plantillas, debe crearlo en el modo de elementos estáticos. Mientras tanto, si el código de barras se va a usar para la captura de datos, debe crearlo en el modo de marcación de campos. Las propiedades del código de barras varían según si este es un campo o un elemento estático. Esta sección describe las propiedades del campo; consulte también código de barras del delimitador.

Propiedades básicas
Propiedades del reconocimiento
Propiedades de la verificación
Validación de regla


Propiedades del reconocimiento del código de barras

Las propiedades del reconocimiento se establecen en la ficha Reconocimiento del cuadro de diálogo de las propiedades del campo (Propiedades… en el menú contextual de este campo). Los valores del campo correctamente determinados aumentan de manera considerable la calidad del reconocimiento y reducen las probabilidades de que se generen errores.

  • No reconocer (campo de clave de imagen: se introducirá manualmente): habilite esta opción si el operador va a introducir el valor del código de barras de forma manual. De ser así, no es necesario establecer la configuración de reconocimiento restante.
  • Tipo de código: especifique el tipo de código de barras (por lo general, se determina de modo automático).
  • Orientación: especifique la orientación del código de barras.

También puede configurar las opciones de procesamiento de imágenes:

  • Invertir: invierte la imagen.
  • Eliminar textura: quita la textura.
  • Refinar: habilite esta opción para eliminar los elementos no utilizados de la imagen.
  • Borrar residuos sólo del tamaño especificado: habilite esta opción si desea eliminar los residuos del tamaño específico únicamente. Especifique el tamaño de los residuos. Si esta opción está deshabilitada y solo está habilitada la opción Refinar, el tamaño de los elementos sin utilizar se seleccionará automáticamente.


Propiedades de la verificación de campo

La verificación es el proceso de comprobación de datos reconocidos y es una tarea que realiza el operador. El programa marca los caracteres reconocidos sin certeza y los envía al operador para que este los verifique. Sin embargo, puede configurar las propiedades del campo de modo que el programa envíe un campo para que lo verifiquen aunque no contenga caracteres reconocidos sin certeza. O bien, por el contrario, puede especificar que el campo no se envíe para que lo verifiquen aunque contenga caracteres reconocidos sin certeza. El operador puede ver un carácter reconocido y su imagen, y confirmar o corregir el resultado del reconocimiento.

Al crear una plantilla, puede configurar las opciones de verificación en la ficha Verificación del cuadro de diálogo de las propiedades del campo.

Seleccione el valor de la lista desplegable:

  • Verificar reconocimiento incierto sin certeza: los caracteres del campo se enviarán para que los verifiquen si se los ha reconocido sin certeza. Este valor se asigna a todos los campos de manera predeterminada.
  • Verificar todos los caracteres: se enviarán todos los caracteres del campo para que los verifiquen. Puede seleccionar el valor denominado todos si no se permiten errores en los valores para este campo.
  • Verificar ninguno caracteres: los caracteres de este campo no se enviarán para que los verifiquen.

Habilite la opción:

  • Incluir en la verificación de campo: habilite esta opción para incluir el campo en la verificación de campo.


Fotografías

Imágenes

En el proceso de creación, a un imagen se le asignan propiedades predeterminadas. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye cuatro fichas para los diferentes grupos de propiedades.

Propiedades básicas
Propiedades del reconocimiento
Exportación de imágenes
Validación de regla


Propiedades básicas del campo

Puede configurar las propiedades básicas del campo en la ficha General.

En esta ficha, el tipo de campo se muestra como un icono ubicado a la derecha del nombre.

  • Nombre: nombre del campo. El nombre se asigna automáticamente cuando se crea el campo y corresponde al texto explicativo más próximo al campo. Al editar las propiedades, puede cambiar el nombre asignado de manera predeterminada. Consulte también Cómo cambiar el nombre del campo.
  • Título: nombre del campo que se mostrará en el formulario de datos.
  • Exportar valor del campo: habilite esta opción si desea exportar el valor del campo (habilitada de manera predeterminada). Es posible que necesite deshabilitar esta opción si, por ejemplo, el valor de este campo se usa para obtener el valor de un campo calculado (consulte Validación de regla) y solo debe exportarse el resultado final.
  • Mostrar en formulario de datos: habilite esta opción si el campo debe mostrarse en el formulario de datos (habilitada de manera predeterminada).
  • Comentario: puede introducir cualquier comentario.


Propiedades del reconocimiento de fotografías

Propiedades del reconocimiento de imágenes

Las propiedades del reconocimiento se establecen en la ficha Reconocimiento del cuadro de diálogo de las propiedades del campo (Propiedades… en el menú contextual de este campo).

  • Excluir del reconocimiento: habilite esta opción si la región de un campo Imagen debe excluirse de las regiones de reconocimiento de otros campos. (Esta opción solo está disponible para un campo Imagen y garantiza la compatibilidad con las plantillas de FormReader 6.5).


Exportación de fotografías

Exportación de imágenes

En una plantilla de documento, puede seleccionar las opciones de exportación para cada imagen. Para seleccionar las opciones de exportación de imágenes, haga clic con el botón derecho en el campo deseado, seleccione Propiedades… y, luego, haga clic en la ficha Exportar. Puede seleccionar cualquiera de las siguientes opciones:

  • Tipo de archivo:(TIFF, JPEG, BMP, JPEG2000, bits empaquetados PCX, PNG).
  • Calidad: Para los archivos TIFF, JPEG y JPEG2000, puede seleccionar la calidad del archivo obtenido, de mayor a menor.
  • Tipo de color: Color, escala de grises, semitonos (blanco y negro).

También puede establecer la resolución del imagen obtenido: al seleccionar Cambiar resolución a y puede escribir la resolución deseada o seleccionarla de la lista.


Tablas

Cuando crea una tabla, se le asignan propiedades predeterminadas a esta. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye tres fichas para los diferentes grupos de propiedades.

Propiedades básicas
Columnas
Validación de regla


Columnas de la tabla

La ficha Columnas muestra la lista de columnas de esta tabla. Cada columna de la tabla pertenece a un tipo de campo específico (consulte Creación de una tabla) y tiene propiedades específicas de este tipo de campo.

Para editar las propiedades de una de las columnas:

  1. Seleccione su nombre de la lista.
  2. Haga clic en el botón Propiedades…


Grupo de campos

Cuando crea un grupo de campos, se le asignan propiedades predeterminadas a este. Para cambiar las propiedades, puede seleccionar Propiedades… en el menú contextual. El cuadro de diálogo de modificación de propiedades incluye tres fichas para los diferentes grupos de propiedades.

Propiedades básicas
Campos
Validación de regla


Campos de grupo

La ficha Campos muestra la lista de campos que conforman el grupo.

Para editar las propiedades de uno de los campos:

  1. Seleccione su nombre de la lista.
  2. Haga clic en el botón Propiedades….

Creación de un grupo de campos


Verificación de regla

Validación de regla

Reglas amplía las posibilidades de la comprobación automatizada de resultados. La opción Reglas posibilita la configuración de las restricciones de datos; es decir, permite especificar las condiciones que deben reunir los valores en ciertos campos.

Si los valores de los documentos no reúnen estas condiciones, dichas páginas se marcarán con una advertencia. El objetivo principal de la aplicación de reglas es comprobar la integridad de los datos del documento.

Asimismo, puede procesar los valores introducidos con la ayuda de las reglas: combinar valores de varios campos o reemplazar valores reconocidos con los valores correspondientes de la base de datos.

ABBYY FlexiCapture 8.0 Professional le permite configurar reglas de los siguientes tipos:

  • Suma de comprobación: comprueba la suma de varios campos. La suma de valores de campos específicos se compara con un número preestablecido o con el valor en un campo diferente.
  • Comparar campos: compara los valores de varios campos.
  • Comprobación de la base de datos: comprueba los valores introducidos al compararlos con los valores de una base de datos específica.
  • Combinar campos: combina los valores de varios campos. Puede agregarse cualquier separador al combinar campos.
  • Script: el usuario describe las restricciones con la ayuda de un script.
  • Suma en cifras - suma en palabras(ruso): compara una suma numérica con la misma suma escrita en palabras (idioma ruso únicamente).

La regla puede recibir un estado de advertencia o error. Cuando no se cumple una condición, los campos pueden marcarse con una bandera roja (error) o una bandera amarilla (advertencia). Consulte Validación de regla.

Las reglas pueden configurarse en la ficha Reglas del cuadro de diálogo de las propiedades de objetos (campo, sección, documento, etc.).

En la estructura jerárquica, las reglas se almacenan en el nivel del objeto en el que se crearon; este puede ser un campo, la sección de una plantilla o la plantilla misma. En la mayoría de los casos, el nivel de almacenamiento de la regla no es relevante. Sin embargo, si está creando una plantilla con una estructura compleja, con grupos de campos o elementos recurrentes, necesita verificar dónde guarda las reglas. Por ejemplo, si tiene un grupo de campos y ciertos campos del grupo están relacionados con un valor, cuando cree una nueva instancia de este grupo, la regla se copiará y trabajará en el nuevo objeto únicamente si la regla está almacenada en el grupo mismo o en uno de sus campos y no en un nivel mayor. En el cuadro de diálogo de las propiedades de objetos, puede ver las reglas que trabajan con este objeto o las reglas almacenadas en este objeto y sus objetos subordinados. Puede especificar las reglas que desea ver al seleccionar uno de los valores en la lista desplegable Mostrar en la lista:

  • Reglas de administración del objeto: muestran las reglas que se aplican al objeto actual (es decir, el objeto cuyo cuadro de diálogo de las propiedades está abierto actualmente).
  • Reglas almacenadas en el objeto: muestra las reglas almacenadas en el objeto actual.
  • Reglas almacenadas en el objeto y sus elementos secundarios: muestra las reglas almacenadas en el objeto actual y sus elementos secundarios (para un grupo de campo, por ejemplo, se mostrarán las reglas almacenadas en el grupo y en todos sus campos).

Nota: Puede crearse una nueva regla en los modos de visualización Reglas almacenadas en el objeto o en Reglas almacenadas en el objeto y sus elementos secundarios. No puede crear una regla nueva en el modo de visualización Reglas de administración del objeto.

Cada regla tiene un estado de advertencia o error. Si intenta exportar documentos con errores de regla, el programa mostrará un mensaje de error. Las advertencias de regla no impedirán que se realice la exportación.

Suma de comprobación
Comparar campos
Comprobación de la base de datos
Combinar campos
Suma en cifras, suma en palabras

Regla configurada con la ayuda de un script


Regla de comprobación de la suma de valores

Esta regla se utiliza para comprobar la suma de valores de varios campos. La suma de valores de campos específicos se compara con el número preestablecido o con el valor en un campo diferente. Por ejemplo, si su documento incluye campos con un importe de salario, un importe de bonificación, otros pagos de compensación y un campo total de suma, puede configurar una regla para que compruebe si la suma de los valores del campo coinciden con la suma total del campo obtenido. Se mostrará un mensaje de error en caso de diferencias.

Para crear una regla de suma de comprobación, realice lo siguiente:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de las propiedades de la plantilla de documento (menú del editor de plantillas, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla….
  4. En la lista de tipos de regla, seleccione Suma de comprobación y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente.
  6. Agregue a la lista Resumir valores de campos los campos cuya suma de valores desea comprobar. Utilice el botón Agregar… para agregar campos.
  7. Habilite una de las siguientes opciones:
    • campo: para comparar la suma con el valor del campo obtenido. Seleccione el nombre de este campo con el botón Seleccionar….
    • número: para comparar la suma con el número específico. Introduzca este número.
  8. Fracción de valores comparados: introduzca la cantidad de dígitos después del punto decimal del número para determinar la precisión de la comparación.
  9. Habilite la opción Al menos dos elementos no vacíos para sumar si desea al menos dos elementos no vacíos para sumar.
  10. Haga clic en Finalizar para completar la creación de la regla. El nombre de la regla aparecerá en la ficha Reglas.


Regla de comparación de valores de varios campos

Esta regla está diseñada para comprobar los valores de varios campos. Puede usarse si su documento tiene varios campos cuyos valores deben ser idénticos. En caso de que los valores no se puedan asociar, aparecerá un mensaje de error para el documento.

Para crear una regla de comparación de valores, realice lo siguiente:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de las propiedades de la plantilla de documentos (menú del editor de plantillas, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla…
  4. En la lista de tipos de regla, seleccione Comparar campos y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente.
  6. Agregue a la lista Campos para comparar los campos cuyos valores desea comparar. Utilice el botón Agregar… para agregar campos.
  7. Seleccione el tipo de asociación:
    • Exacto: para una asociación de valor exacta.
    • Aproximado: para una asociación de valor aproximada. En este caso, los campos se compararán sin tener en cuenta el tipo de letra ni los espacios en blanco, y se permitirá un error para los valores del campo con más de 4 caracteres.
  8. Haga clic en Finalizar para completar la creación de la regla. El nombre de la regla aparecerá en la ficha Reglas.


Regla de comprobación de la base de datos

La comprobación de los valores del campo de la base de datos incluye la comparación del valor del campo reconocido con los valores de la tabla de la base de datos y se considera correcta si los dos valores se asocian. En el caso de que no se asocien, aparecerá un mensaje de error de regla.

Para crear una regla de comprobación de la base de datos, realice los siguientes pasos:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de las propiedades de la plantilla de documento (menú del editor de plantillas, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla….
  4. En la lista de tipos de regla, seleccione Comprobación de la base de datos y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente.
  6. Establezca una conexión con la base de datos. La configuración requerida se puede establecer en el cuadro de diálogo Propiedades del enlace de datos que se abrirá al hacer clic en el botón Establecer….
  7. Seleccione un esquema de base de datos y una tabla de la lista.
  8. Asocie los campos de la plantilla de documento y los campos de la tabla de la base de datos. Para hacerlo, haga clic en el botón Agregar… Se abrirá el cuadro de diálogo Enlace a campo. Seleccione de la lista un campo de la plantilla de documento y el campo correspondiente en la tabla de la base de datos. Seleccione el tipo de asociación:
    • Exacto: los valores del campo deben asociarse con exactitud.
    • Aproximado: los valores del campo deben asociarse parcialmente. Aquí, el programa busca las palabras más próximas en las que se deba agregar, eliminar o reemplazar la menor cantidad de letras para obtener la palabra original. La cantidad de errores permitidos dependerá de la longitud de la palabra original. Habilite la opción Copiar valor del campo desde la base de datos si desea reemplazar el valor del campo del documento por el valor correspondiente de la base de datos.
    • No comparar: no se realizará la comparación, el valor del campo se reemplazará por un valor de la base de datos (opción Copiar valor del campo desde la base de datos habilitada).
  9. Utilice los botones Agregar…, Editar… y Eliminar para agregar, editar o eliminar los enlaces entre los campos.


Regla de combinación de valores de campos

Esta regla está diseñada para combinar los valores de varios campos. Los valores de campos combinados pueden separarse con un punto, un espacio u otros separadores.

Para crear una regla de combinación de valores, realice lo siguiente:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de las propiedades de la plantilla de documento (menú del editor de plantillas, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla….
  4. En la lista de tipos de regla, seleccione Combinar campos y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente. Aparecerá un error para esta regla si, por ejemplo, uno de los campos incluidos en la combinación se eliminó de la plantilla.
  6. Agregue a la lista Campos para combinar los campos que desea incluir en la combinación. Utilice el botón Agregar… para agregar campos. Seleccione Campo Resultado: un campo que almacenará el resultado de la combinación. Introduzca el separador necesario en la ventana Separador.
  7. De manera predeterminada, los separadores se agregarán entre los valores no vacíos. Si desea que el programa agregue los separadores de forma permanente, incluso para los valores de campos vacíos, habilite la opción Colocar separadores para los valores de campo vacíos.
  8. Haga clic en Finalizar para completar la creación de la regla. El nombre de la regla aparecerá en la ficha Reglas.

El resultado de la combinación puede almacenarse en cualquier campo de la plantilla. Por este motivo, es conveniente utilizar campos sin regiones.

Si necesita exportar solo el valor del campo obtenido y no los valores de los campos incluidos en la combinación, desactive la opción Exportar valor del campo para estos campos.


Regla configurada con la ayuda de un script

ABBYY FlexiCapture 8.0 Professional le permite configurar la regla de comprobación de datos con la ayuda de un script.

Para crear dicha regla, realice lo siguiente:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de las propiedades de la plantilla de documento (menú del editor de plantilla, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla….
  4. En la lista de tipos de regla, seleccione Script y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente.
  6. La lista de Campos disponibles mostrará una lista de objetos disponibles. Puede agregar y eliminar campos con la ayuda de los botones Agregar… y Eliminar. Los valores de los campos con la opción Sólo lectura habilitada solo están disponibles para la lectura, mientras que los valores de los campos enumerados con esta opción deshabilitada pueden sobrescribirse con la ayuda de un script.
  7. Seleccione el lenguaje de scripting e introduzca el texto del script. Al hacer clic en Editar… puede abrir una ventana especial para la edición de scripts. El script puede comprobarse al hacer clic en el botón Comprobar.
  8. Haga clic en Finalizar. La regla creada aparecerá en la lista de la ficha Reglas.

Nota: Los procedimientos que desee usar en más de una regla deben escribirse en el módulo de regla global, al que se puede acceder desde el editor de scripts. En la lista desplegable de la barra de herramientas del editor de scripts, seleccioneMódulo de reglas de script global. También puede accederse al módulo de regla global desde el editor de plantilla (Plantilla>Módulos de script>Script de regla…).

Para obtener detalles sobre la creación de reglas mediante scripts, consulte Uso de scripts en FlexiCapture 8.0


Suma en cifras, suma en palabras

Importante: Esta regla solo puede configurarse si selecciona el idioma de reconocimiento ruso para su plantilla (Plantilla>Propiedades de la plantilla de documento…).

El objetivo de esta regla es comparar una suma numérica con la correspondiente suma en palabras escritas en ruso. Si las dos sumas no son idénticas, aparecerá un mensaje que indicará que la regla arrojó un error.

Para crear una regla de "suma en cifras, suma en palabras", realice lo siguiente:

  1. Abra el cuadro de diálogo de las propiedades del campo (menú contextual, Propiedades…) o el cuadro de diálogo de la plantilla de documento (menú del editor de plantilla, Plantilla>Propiedades de la plantilla de documento…).
  2. Vaya a la ficha Reglas.
  3. Haga clic en el botón Nueva regla….
  4. En la lista de tipos de reglas, seleccione Suma en cifras - suma en palabras(ruso) y haga clic en Aceptar.
  5. Introduzca el nombre de la regla y seleccione el tipo de regla: Advertencia o Error y haga clic en Siguiente.
  6. Haga clic en el botón Seleccionar… ubicado a la derecha del campo Suma en cifras y seleccione el campo de la plantilla que contiene la suma numérica.
  7. Haga clic en el botón Seleccionar… ubicado a la derecha del campo Suma en palabras y seleccione el campo de la plantilla que contiene la misma suma en palabras.
  8. Haga clic en Finalizar para completar la creación de la regla. El nombre de la regla aparecerá en la ficha Reglas.


Configuración de exportación de datos

Para especificar el método de almacenamiento de los datos capturados durante el procesamiento de documentos impresos, el administrador configura las propiedades de exportación para cada plantilla. Existen cuatro tipos de exportaciones: a un archivo de formato específico, a una base de datos, a la biblioteca de Microsoft SharePoint o según se describa con un script.

Para configurar la exportación, en la ventana del editor de la plantilla de documento, seleccione el elemento del menú Plantilla > Configuración de exportación… y configure las opciones necesarias en el cuadro de diálogo Configuración de exportación.

Especifique el tipo de exportación (archivo, base de datos, SharePoint o script) en el campo Tipo de exportación. Las configuraciones subsiguientes dependen del valor seleccionado en este campo.

Exportación a un archivo
Exportación a la base de datos
Exportación a SharePoint
Exportación descrita con un script


Exportación de datos a un archivo

Para configurar la exportación a archivo, realice los siguientes pasos:

  1. En la ventana del editor de plantillas de documento, seleccione el elemento del menú Plantilla > Configuración de exportación….
  2. Seleccione el valor Exportar a archivos en el campo Tipo de exportación.

  3. En el Destino:

    • Ruta: haga clic en Examinar… para seleccionar la carpeta de destino para el almacenamiento de los archivos exportados.

    Importante: Si la ruta a la carpeta de destino contiene un disco de red, asegúrese de que todos los operadores que trabajan con el proyecto tengan acceso a ese disco.

    • Crear carpetas independientes para cada lote: habilite esta opción si desea que los resultados de la exportación del lote de un documento único se almacenen en una carpeta independiente.
    • Crear archivos independientes para cada documento: habilite esta opción si desea que los resultados de la exportación de un documento único se almacenen en un archivo independiente. De lo contrario, todos los documentos se exportarán al mismo archivo.
    • Habilite la opción Sobrescribir archivos existentes si desea permitir que se sobrescriban los archivos de exportación.
    • Especifique las reglas que se usarán para denominar a los archivos de exportación. Haga clic en el botón Opciones de denominación de archivos… y, cuando se abra el cuadro de diálogo correspondiente, seleccione las opciones deseadas. Para obtener detalles, consulte Reglas de denominación para los archivos de exportación.

  4. En la ficha Formato, seleccione el tipo de archivo (formatos compatibles: CSV, DBF, TXT, XLS, XML) y configure las propiedades adicionales de exportación para el tipo de archivo seleccionado. También puede especificar la codificación del texto.

Libro de trabajo de Microsoft Office Excel (*.xls):
  • Seleccione la versión deseada de Microsoft Excel (5.0/95; 97-2003; 97-2003 [compatibilidad con 5.0/95]).
  • Seleccione Conservar tipo de valor en la exportación para exportar los datos por tipo. Si borra esta opción, todos los datos se exportarán como General.
  • Seleccione Crear archivos independientes para elementos repetibles si desea que los campos y las tablas que se repiten se exporten a archivos independientes. Consulte las notas.
  • En el caso de Microsoft Excel 5.0/95, seleccione la página de códigos deseada.
Documento XML (*.xml):
  • Seleccione los datos adicionales que desee exportar (ubicación de archivos, tipos de archivos, errores e información sobre la calidad de reconocimiento).
  • Si selecciona Conservar tipo de valor en la exportación, se conservará el esquema XML en el que se describen los tipos de campo.
  • Seleccione la codificación deseada.
Archivo de valores separados por comas (*.csv):
  • Seleccione Separador de columna.
  • Seleccione Crear archivos independientes para elementos repetibles si desea que los campos y las tablas que se repiten se exporten a archivos independientes. Consulte las notas.
  • Seleccione la codificación deseada.
Archivo de texto (*.txt):
  • Seleccione Separador de columna.
  • Seleccione Crear archivos independientes para elementos repetibles si desea que los campos y las tablas que se repiten se exporten a archivos independientes. Consulte las notas.
  • Seleccione la codificación deseada.
Archivo DBase (*.dbf):
  • Seleccione Conservar tipo de valor en la exportación para exportar los datos por tipo. Si borra esta opción, todos los campos se convertirán en campos de texto.
  • Seleccione Crear archivos independientes para elementos repetibles si desea que los campos y las tablas que se repiten se exporten a archivos independientes. Consulte las notas.

  5. En la ficha Imágenes, puede configurar los parámetros de almacenamiento de imágenes.

    • Habilite la opción Guardar imágenes del documento si desea guardar las imágenes de página del documento.

    • Habilite la opción en la carpeta de datos si desea que las imágenes se guarden en la misma carpeta en la que se exportan los datos.

    • Habilite la opción en la carpeta y especifique la ruta a la carpeta si desea guardar las imágenes en una ubicación diferente.

    • Seleccione el color, la calidad y el formato para el almacenamiento de imágenes.
    • Si desea cambiar la resolución de las imágenes originales, habilite la opción Cambiar resolución a e introduzca la resolución deseada o selecciónela de la lista.
    • Si seleccionó PDF o PDF/A para el almacenamiento de imágenes, puede crear un archivo PDF para búsquedas al seleccionar Crear PDF para búsquedas. Puede seleccionar un idioma (o varios idiomas, si su documento utiliza más de uno) que sea diferente al idioma que se especificó en la plantilla de documento. Haga clic en el botón Seleccionar… ubicado a la derecha del campo Idioma y agregue los idiomas deseados. Si desea utilizar el idioma que se especifica en la plantilla de documento, seleccione Como en la plantilla en el campo Idioma.

Los valores de todos los campos del documento se exportarán a los archivos del formato especifico.

Notas:

  1. De manera predeterminada, los campos repetibles (es decir, los campos con varias instancias y tablas) se exportarán a archivos independientes para los cuales se crea una nueva carpeta. El nombre de la carpeta incluye el nombre del archivo de exportación. Para deshabilitar la exportación de campos repetibles en archivos independientes, borre la opción Crear archivos independientes para elementos repetibles en la ficha Formato (la opción está disponible para todos los formatos excepto XML). En ese caso, los campos repetibles se exportarán a un archivo de exportación y el programa agregará una nueva línea para cada instancia del elemento.
  2. Los imágenes se exportan a archivos independientes y se guardan en la misma carpeta en que se guardan los campos repetibles. El nombre del imágen incluye el nombre del campo y el número del documento. Puede especificar el formato del archivo de imagen en la ficha Exportar del cuadro de diálogo de las propiedades del campo de imagen. Para obtener detalles, consulte Exportación de imágenes.


Exportación a la base de datos

Para configurar la exportación a una base de datos, realice los siguientes pasos:

  1. En la ventana del editor de plantillas de documento, seleccione el elemento del menú Plantilla > Configuración de exportación….
  2. Seleccione el valor Exportar a la base de datos compatible con ODBC en el campo Tipo de exportación.

  3. En la ficha Conexión:

    • Establezca una conexión con la base de datos. Introduzca los parámetros de conexión en la ventana Cadena de conexión o haga clic en el botón Configurar conexión… y configure los parámetros de conexión en el cuadro de diálogo Propiedades del enlace de datos.
    • Seleccione un esquema de la lista desplegable.
    • Puede comprobar la conexión con la base de datos mediante un clic en el botón Probar conexión.

      Sugerencia: El proveedor OLE DB de controladores ODBC está recomendado como proveedor OLE DB. Al seleccionar Proveedor OLE DB para el servidor SQL, se pueden generar problemas de trabajo con ciertos tipos de datos y campos largos.

    • Asocie los campos de la plantilla de documento con las columnas de las tablas de la base de datos. Para hacerlo, haga clic en Asignación de campos de instalación…
    • En el cuadro de diálogo Asignación de campos, especifique las tablas y las columnas de las tablas de la base de datos a las que el programa exportará los valores de los campos de la plantilla de documento.
      Detalles...

      El cuadro de diálogo Asignación de campos ubicado a la izquierda contiene campos y secciones del documento. A la derecha, debe asociarlos con las tablas y los campos de la base de datos. Si la base de datos ya tiene tablas para la exportación de datos, en el cuadro de diálogo Asignación de campos, debe seleccionar una tabla de la base de datos para cada sección del documento y una columna de la tabla de la base de datos para cada campo del documento.

      Si la base de datos no tiene tablas para exportar, puede crear tablas de la base de datos automáticamente al hacer clic en el botón Crear tablas automáticamente. Después de hacer clic en el botón, el programa creará tablas con la estructura necesaria para la exportación. Se asociarán los campos del documento con las columnas de la tabla.

      Los grupos de campos, los campos con varias instancias y las tablas del documento se exportarán a tablas independientes de la base de datos. Se utilizan una clave principal y una clave externa para vincular la tabla principal y las tablas subordinadas. En la tabla principal, se agrega la clave principal a cada entrada. En la tabla subordinada, cada entrada tiene una clave externa que registra el valor de la clave principal de la correspondiente entrada en la tabla principal. La clave principal y la clave externa se agregan automáticamente cuando se solicita. Solo debe especificar el campo al que se exportará la clave.

      La opción Mostrar columnas vinculadas se habilita de manera predeterminada. Si la deshabilita, la lista de columnas disponibles de la tabla en la parte derecha del árbol no mostrará las columnas para las cuales ya se haya configurado la exportación.

  4. En la ficha Imágenes, puede configurar los parámetros de almacenamiento de imágenes.

    • Puede guardar las imágenes en una base de datos o en un archivo (en ese caso, especifique la carpeta de destino).

    • Seleccione el color, la calidad y el formato para el almacenamiento de imágenes.

    • Si desea cambiar la resolución de las imágenes originales, habilite la opción Cambiar resolución a e introduzca la resolución deseada o selecciónela de la lista.

    • Si seleccionó PDF o PDF/A para el almacenamiento de imágenes, puede crear un archivo PDF para búsquedas al seleccionar Crear PDF para búsquedas. Puede seleccionar un idioma (o varios idiomas, si su documento utiliza más de uno) que sea diferente al idioma que se especificó en la plantilla de documento. Haga clic en el botón Seleccionar… ubicado a la derecha del campo Idioma y agregue los idiomas deseados. Si desea utilizar el idioma que se especifica en la plantilla de documento, seleccione Como en la plantilla en el campo Idioma.

Notas:

  1. Para deshabilitar la opción de guardar las imágenes al exportar datos a una base de datos, en el cuadro de diálogo Asignación de campos, seleccione el valor NotExported para el nodo que tiene la imagen del documento.
  2. Los imágenes se exportan a archivos independientes, cuyos formatos pueden seleccionarse en la ficha Exportar del cuadro de diálogo de las propiedades del campo de imagen. Consulte Exportación de imágenes. El nombre y la ruta al archivo de imagen pueden almacenarse en el archivo correspondiente de la base de datos (esto puede configurarse al asignar los campos).
  3. Si la ruta a la carpeta de destino para las imágenes, los imágenes, etc., contiene un disco de red, asegúrese de que todos los operadores que trabajan con el proyecto tengan acceso a ese disco.


Exportación de datos a la biblioteca de documentos de SharePoint

ABBYY FlexiCapture 8.0 le permite exportar documentos a la biblioteca de documentos de MicrosoftTM SharePoint. Como resultado, obtendrá una biblioteca de las imágenes de sus documentos con columnas adicionales para cada documento completo con los valores de ciertos campos.

Nota:

  1. Se requieren derechos de administrador para configurar la exportación de datos a SharePoint. Los derechos de colaborador son suficientes para exportar datos a SharePoint.
  2. Las columnas de SharePoint en las que se registrarán los datos deben ser del tipo Texto de una línea o Texto de varias líneas.

Para configurar la exportación a SharePoint:

  1. En el editor de plantillas, seleccione Plantilla > Configuración de exportación….
  2. En la lista desplegable Tipo de exportación, seleccione Exportar a SharePoint.

  3. En la ficha Conexión con SharePoint:

    • URL del servidor (por ej.: http://miservidor): introduzca la dirección del servidor donde se ubican las bibliotecas de SharePoint. Use el botón Configuración\n de la conexión… para configurar los parámetros de autenticación (los parámetros de autenticación de Windows se utilizan de manera predeterminada) y la configuración del Proxy, si fuera necesario.
    • El estado de la conexión se indica debajo de la dirección del servidor. Si el servidor está desconectado, haga clic en Conectar para volver a establecer la conexión.
    • Una vez que se conecte al servidor SharePoint, seleccione una biblioteca de la lista Seleccionar biblioteca de SharePoint.
    • En el campo Tipo de contenido, seleccione el tipo de contenido de sus documentos (admitido desde SharePoint 2007). En este caso, podrá exportar valores a los campos que coinciden con el tipo de contenido seleccionado.
    • Ahora especifique qué campos de la plantilla se exportarán y a dónde. Haga clic en el botón Asignación de campos\n de instalación… y seleccione las opciones deseadas en el cuadro de diálogo Asignación de campos. En este cuadro de diálogo, debe establecer la correspondencia entre los campos de la plantilla y las columnas del documento de SharePoint. Los campos de la plantilla aparecen a la izquierda. Para cada campo de la plantilla que exportará (con excepción de los grupos y las tablas), puede seleccionar una columna libre de SharePoint.
    • Especifique las reglas de denominación de archivos para los archivos de exportación. Al exportar a SharePoint, estos son archivos de imagen del documento. Haga clic en el botón Opciones de denominación de archivos… y seleccione las opciones deseadas de denominación de archivos. Para obtener detalles, consulte Reglas de denominación para los archivos de exportación.

  4. En la ficha Imágenes, seleccione las opciones de almacenamiento de imágenes.
    • En la lista desplegable Tipo de archivo, seleccione el formato en el que desea guardar las imágenes del documento.
    • En el campo Calidad, seleccione la calidad de imagen deseada.
    • En el campo Tipo de color, seleccione el tipo de color deseado para las imágenes.
    • Si desea cambiar la resolución de las imágenes originales, habilite la opción Cambiar resolución a e introduzca la resolución deseada o selecciónela de la lista.
    • Si seleccionó PDF o PDF/A para el almacenamiento de imágenes, puede crear un archivo PDF para búsquedas al seleccionar Crear PDF para búsquedas. Puede seleccionar un idioma (o varios idiomas, si su documento utiliza más de uno) que sea diferente al idioma que se especificó en la plantilla de documento. Haga clic en el botón Seleccionar… ubicado a la derecha del campo Idioma y agregue los idiomas deseados. Si desea utilizar el idioma que se especifica en la plantilla de documento, seleccione Como en la plantilla en el campo Idioma.

Una vez que la exportación haya finalizado, los documentos se guardarán en la biblioteca de SharePoint especificada y cada documento tendrá una columna correspondiente completa con los valores de los campos específicos. Estos valores pueden usarse para búsquedas e indexación de documentos.


Exportación descrita con un script

Para configurar la exportación con la ayuda de un script:

  1. En la ventana del editor de plantillas de documento, seleccione Plantilla > Configuración de exportación….
  2. Seleccione el valor Exportación personalizada (script) en el campo Tipo de exportación.
  3. Seleccione el lenguaje de scripting (JScript(r) o VBScript).
  4. Introduzca el texto del script en la ventana del editor que se abrirá cuando haga clic en el botón Editar script….

Nota: Los procedimientos que desee usar en más de un script de exportación deben escribirse en el módulo de exportación global, al que se puede acceder desde el editor de scripts. En la lista desplegable de la barra de herramientas del editor de scripts, seleccione Módulo de exportación de script global. También se puede acceder al módulo de exportación global desde el editor de plantillas (Plantilla>Módulos de script>Script de exportación…).

Para obtener detalles sobre la descripción de la exportación con un script, consulte Uso de scripts en FlexiCapture 8.0


Reglas de denominación para los archivos de exportación

Durante la exportación, los nombres de archivo se generan automáticamente de acuerdo con las reglas definidas por los usuarios. Puede especificar las reglas de denominación de archivos al configurar la exportación a archivo o a SharePoint. Haga clic en el botón Opciones de denominación de archivos… en la ficha Destino al configurar la exportación a un archivo o en la ficha Conexión con SharePoint al configurar la exportación a SharePoint. Se abrirá el cuadro de diálogo Opciones de denominación de archivos, en donde deberá seleccionar las opciones de denominación de archivos.

Las siguientes opciones pueden adjuntarse automáticamente al nombre del archivo de exportación:

  • nombre de proyecto (seleccione la opción Título del proyecto)
  • nombre de lote (seleccione la opción Título del lote)
  • nombre de plantilla de documento (seleccione la opción Nombre de plantilla del documento)
  • identificador del documento, es decir, el valor del código de barras de la página del separador si se utilizaron separadores de código de barras al agregar las imágenes. Para obtener detalles, consulte Opciones de procesamiento de imágenes. Para anexar identificadores del documento, seleccione la opción Identificador del documento
  • los valores de los campos de índice. Para obtener detalles, consulte Campos de índice. Para anexar los valores de los campos de índice, seleccione Valor del campo de índice y, luego, haga clic en Seleccionar… para seleccionar el campo de índice deseado.

La Plantilla de nombre de archivo muestra la plantilla que se usará para la generación de los nombres de archivos. Si desea agregar alguna cadena de texto para los futuros nombres de archivo, escriba el texto deseado en este campo.

Para que los nombres de archivo se generen correctamente, asegúrese de que las opciones de denominación de archivos que seleccione no den como resultado nombres de archivo vacíos. En caso de que esto ocurra, el programa mostrará un mensaje de advertencia.


Configuración de la presentación de datos en la ventana del documento

Después de que se hayan reconocido los datos, el usuario los verá en la ventana del documento. De manera predeterminada, los datos se ordenarán de forma secuencial y sus títulos coincidirán con los nombres de los campos de las plantillas.

Sin embargo, puede cambiar la presentación de los datos y ordenarlos convenientemente o cambiar el nombre de los elementos. La presentación de los datos se puede editar en la esquina inferior derecha de la ventana del editor de plantillas.

Puede cambiar el título de un campo en el formulario de datos sin cambiar su nombre en la estructura del documento. Para cambiar un título, abra el cuadro de diálogo de las propiedades del campo, haga clic en la ficha General y escriba un nuevo nombre en el campo Título. Este nombre se usará como título del campo en el formulario de datos. Esta función puede ser útil para personalizar los nombres de las columnas, particularmente, en el caso de FlexiLayouts, donde no puede cambiar los nombres de los campos.

El tamaño y la fuente del texto para los nombres de los campos y los valores de los datos reconocidos pueden especificarse en la ficha Formulario de datos del cuadro de diálogo de las propiedades de la plantilla (Plantilla > Propiedades de la plantilla de documento…). También puede cambiar el tamaño al hacer clic con el botón derecho en la ventana Formulario de datos y seleccionar el tamaño deseado (elemento del menú contextual Tamaño del texto).

Puede mover los campos, modificarlos y cambiarles el nombre, como también puede cambiarles otras propiedades. Para regresar a la presentación original del campo, seleccione el elemento del menú contextual correspondiente.

Puede agregar cualquier texto, por ejemplo, explicaciones. Para hacerlo, haga clic con el botón derecho en la ventana Formulario de datos y seleccione Insertar cuadro de etiqueta en el menú contextual. Introduzca el texto y reemplace el Texto de la etiqueta.


Propiedades de la plantilla de documento

Las propiedades básicas de plantilla, como el nombre, el idioma y el estilo de escritura se configuran con la ayuda del Asistente para plantillas. Otras propiedades se configuran de manera predeterminada.

Puede ver y cambiar las propiedades de una plantilla de documento en el cuadro de diálogo de propiedades que se abre al seleccionar el elemento del menú Plantilla>Propiedades de la plantilla de documento… en la ventana editor de la plantilla de documento.

El cuadro de diálogo tiene seis fichas.

La ficha General .

En esta ficha, puede cambiar el nombre de la plantilla y escribir o editar su descripción. La opción Habilitado incluye o excluye la plantilla del procesamiento del documento.

La ficha Reconocimiento

En esta ficha, puede modificar las propiedades generales del reconocimiento de la plantilla de documento:

  • Idioma (configuración regional): es importante especificar el idioma usado para un correcto reconocimiento. Esta propiedad determina el idioma de entrada y otras configuraciones regionales, como el formato de fecha, moneda, etc.
  • Estilo de escritura: el estilo de escritura puede diferenciarse ligeramente en diferentes países; por eso es importante especificar el país para habilitar en el programa la selección del estilo de escritura típico.

  • Especifique el tipo de texto:

    ICR (manuscrito): habilite esta función si la mayoría de los campos de los documentos se van a completar a mano.

    OCR (impreso): habilite esta función si los valores de la mayoría de los campos se van a imprimir. Seleccione el tipo de impresión en la lista desplegable.

    Nota: El reconocimiento de texto manuscrito no es compatible con todos los idiomas. Para algunos idiomas, este tipo de reconocimiento no estará disponible. Consulte Idiomas de reconocimiento compatibles.

    Luego, puede cambiar el tipo de texto para campos individuales; mientras tanto, el tipo que especificó en esta etapa se usará como predeterminado.

  • Puede habilitar una o varias opciones en el grupo Orientación posible de página para que la página gire 180°, 90° a la drecha o 90° a la izquierda durante la selección de orientación automática de la página.
  • Haga clic en Opciones avanzadas… para configurar la corrección de distorsiones de imágenes lineales y no lineales.

La ficha Ensamblaje

Esta ficha está diseñada para configurar las reglas de ensamblaje de documentos de varias páginas.

En el escenario más simple, una plantilla comprende una sección única que aparece una vez. Si la plantilla incluye varias secciones, esta ficha mostrará la lista de sus nombres. Puede especificar la cantidad de repeticiones de cada sección al modificar las cantidades en las columnas Cantidad mínima y Cantidad máxima.

  • Comprobar igualdad de campos clave: habilite esta opción si desea realizar una comprobación del ensamblaje del documento según los campos clave. Luego, seleccione un campo clave para cada sección en la columna Campo clave. Al introducir los documentos, solo los documentos cuyos valores se asocian a los campos clave de cada sección se considerarán correctamente ensamblados. Si los valores no se pueden asociar, aparecerá un mensaje de error de ensamblaje.
  • Habilitar páginas adjuntas: habilite esta opción si desea procesar documentos con adjuntos.
  • En ocasiones, puede desactivar las comprobaciones del orden de las secciones en el documento (por ejemplo: si el orden de las secciones no afecta el ensamblaje del documento). Seleccione Deshabilitar comprobación de orden de secciones para deshabilitar las comprobaciones. El programa aún comprobará que todas las secciones estén presentes en el documento, pero ignorará el orden.

Para obtener detalles, consulte Creación de plantillas para documentos de varias páginas, Ensamblaje de páginas en documentos y Creación de plantillas para documentos con adjuntos.

La ficha Reglas

Esta ficha está diseñada para las acciones con las reglas de la plantilla. Puede eliminar, editar o crear reglas nuevas.

Para obtener detalles, consulte Validación de regla.

La ficha Exportar

Esta ficha muestra la configuración de exportación actual de la plantilla determinada. Para cambiar la configuración de exportación, haga clic en el botón Cambiar configuración de exportación….

Para obtener detalles, consulte Configuración de exportación de datos.

La ficha Formulario de datos

En esta ficha, puede modificar el diseño y el tamaño de la fuente para mostrar los datos reconocidos.

El grupo Configuración del texto de datos contiene la configuración de la fuente para mostrar los valores reconocidos.

El grupo Configuración del texto de etiquetas contiene la configuración para mostrar el texto explicativo (nombres de campo).

Para obtener detalles, consulte Configuración de la presentación de datos en la ventana del documento.


Propiedades de una sección de la plantilla de documento

Puede ver y cambiar las propiedades de una sección de la plantilla de documento en el cuadro de diálogo de propiedades que se abre cuando selecciona Propiedades… en el menú contextual.

El cuadro de diálogo cuenta con tres fichas.

La ficha General

En esta ficha, puede cambiar el nombre de una sección del documento, introducir o editar la descripción, introducir o modificar la cantidad mínima y máxima de repeticiones de la sección en el documento. La opción Habilitado incluye o excluye la plantilla de la sección del procesamiento del documento. Para obtener más detalles sobre los documentos de varias páginas y el trabajo con secciones, consulte Creación de plantillas para documentos de varias páginas.

La ficha FlexiLayout

Si se adjunta una descripción flexible a la sección, esta ficha muestra su Nombre, Versión y Comentario. Puede adjuntar una descripción flexible al hacer clic en el botón Cargar… y quitarla al hacer clic en el botón Separar.

Para obtener más detalles, consulte Creación de una plantilla para el procesamiento de documentos flexibles.

La ficha Imágenes
Esta ficha enumera los parámetros de visualización para las imágenes de la página de la sección. Puede elegir entre los siguientes parámetros: tamaño, resolución, tamaño de impresión y modo de color.

La ficha Reglas

Esta ficha está diseñada para las acciones con las reglas de la plantilla. Puede eliminar, editar o crear reglas nuevas.

Para obtener detalles, consulte Validación de regla.


Importación de una plantilla para formularios creados con ABBYY FormDesigner

ABBYY FormDesigner es una conveniente herramienta diseñada especialmente para la creación de formularios legibles por máquina. Además de los formularios que cumplen con todos los requisitos de procesamiento automatizado de documentos, el diseño de formularios con ABBYY FormDesigner también le ofrece una plantilla que está preparada prácticamente por completo para el procesamiento de estos formularios en ABBYY FlexiCapture 8.0 Professional.

Para obtener una plantilla de documento para el procesamiento de formularios diseñados con ABBYY FormDesigner, realice lo siguiente:

En ABBYY FormDesigner:

  1. Cree un formulario
  2. Publíquelo
  3. Expórtelo al formato de definición de formulario XML. Obtendrá un archivo con la extensión .xfd.

Para obtener detalles para la creación, publicación y exportación de formularios, consulte los Temas de ayuda y el Manual del usuario de ABBYY FormDesigner 8.0.

En ABBYY FlexiCapture:

  1. En la ventana principal del programa, seleccione el elemento del menú Proyecto> Plantillas de documento…
  2. En el cuadro de diálogo Plantillas de documento haga clic en el botón Importar…
  3. En Abrir archivo para importación que se abrirá, seleccione Archivos de definición de formulario XML (*.xfd) en la lista desplegable Archivos de tipo y especifique la ruta al archivo *.xfd;
  4. El nombre de la nueva plantilla de documento aparecerá en la lista de plantillas del cuadro de diálogo Plantillas de documento.

Después de abrir una plantilla importada para la edición, verá que la marcación de campos y elementos estáticos ya está presente en la imagen. Lo único que necesita hacer es editar las propiedades del campo y la configuración de exportación.


Creación de plantillas para documentos de varias páginas

ABBYY FlexiCapture 8.0 Professional permite crear plantillas para documentos de varias páginas. Una plantilla puede abarcar una cantidad de secciones, que pueden incluir una o varias páginas. Las plantillas de documentos de varias páginas requieren la especificación del orden de las secciones, su número y las reglas utilizadas para ensamblar las páginas y formar documentos.

Después de que el Asistente finaliza la creación de una plantilla nueva, se crea una plantilla simple sin secciones. Puede agregar páginas a la plantilla. Cuando agrega una página, su imagen se agrega a la región de la imagen en la ventana del editor de plantilla, mientras que los campos creados en esta se enumerarán en la lista de campos comunes. En este caso, el documento está formado por una sección única a pesar de que puede incluir varias páginas.

Debe agregar las páginas a una sección única si el documento tiene bloques continuos o recurrentes en varias páginas o tablas que continúan en la siguiente página. El mismo método se utiliza para cargar una descripción flexible de varias páginas (consulte Creación de una plantilla para el procesamiento de documentos flexibles). Todos los campos de una descripción flexible deben pertenecer a una sección de la plantilla de documento.

Otra manera es agregar secciones a la plantilla. En el escenario más simple, una sección incluye una página. Puede elegirla si los conjuntos de campos en las páginas son independientes. Este método es más ilustrativo: la estructura del documento muestra a qué sección pertenecen los campos y también puede configurar una estructura personalizada del ensamblaje del documento. Supongamos, por ejemplo, que su documento incluye tres tipos de páginas y las páginas de los tipos primero y tercero pueden aparecer solo una vez, mientras que las páginas del segundo tipo pueden aparecer de 2 a 5 veces. En este caso, debe crear tres secciones, una para cada tipo de página, y especificar el orden de las secciones del documento y la posible cantidad de apariciones.

Un escenario más complejo es una plantilla que comprende varias secciones; algunas de las cuales incluyen más de una página. Por ejemplo, esta puede ser una plantilla que incluye secciones fijas y una sección flexible de varias páginas. O bien, una plantilla que describe documentos que incluyen una hoja de dos caras que puede repetirse varias veces. Supongamos que necesita crear una plantilla para un documento que incluye una página de títulos (página A) y una cierta cantidad de hojas de dos caras (secuencia de páginas, BCBC...). Por lo tanto, creará una sección A que incluye una página A y una sección BC que incluye dos páginas B y C. La estructura del documento se configura de la siguiente manera: la sección A se repite una vez, seguida de la sección BC, que se repite de 3 a 7 veces.

Para una plantilla que incluye varias secciones, puede habilitar la verificación de campos clave además del orden y la cantidad de secciones recurrentes. Para hacerlo, tiene que identificar los campos clave de cada sección del documento. Sus valores deben ser idénticos en las diferentes secciones. Un ejemplo de un campo clave es el apellido de la persona que completó el documento, que debe estar escrito en cada página, o un número de identificación específico.

Al procesar un lote, el programa intenta reunir una secuencia de páginas en documentos, verificando las reglas de ensamblaje en el proceso. El programa realizará una revisión de los valores del campo clave. Si los campos clave no se puedan asociar en las páginas del mismo documento, aparecerá un mensaje de error. En ocasiones, esto ocurre debido a que las páginas del documento se ubican incorrectamente durante la digitalización, en cuyo caso el cambio del orden de las páginas será suficiente para completar las reglas de ensamblaje del documento. Consulte Ensamblaje de páginas en documentos.

Para agregar una página a la sección, use el elemento del menú de editor de plantillas Plantilla > Agregar página… o el elemento Agregar página… en el menú contextual de la imagen. Luego, cargue la imagen de una nueva página sin completar y seleccione los tipos de objetos que deben marcarse en la página automáticamente.

Para agregar una nueva sección, use el elemento del menú Plantilla > Agregar sección del documento… en la ventana del editor de plantilla. El asistente para crear secciones se abrirá para ayudarlo a configurar todos los parámetros necesarios. Siguiendo las instrucciones del asistente, realice lo siguiente:

  • Especifique el nombre de la sección.
  • Cargue la imagen de una página sin completar (realice la digitalización o la carga desde el archivo) o cargue un archivo de descripción flexible.
  • Seleccione los tipos de objeto que se marcarán automáticamente.

Se mostrará una nueva sección junto con sus campos en la ventana de estructura de documentos.

Para ver la estructura del documento obtenido al crear una plantilla, en la ventana Estructura de documentos ubicada en la parte derecha de la ventana del editor de plantilla de documento, vaya a la ficha Páginas. Muestra la estructura del documento en el modo de esquema de la página. En esta ficha puede cambiar la cantidad de inclusiones de la sección en un documento; para hacerlo, introduzca un valor nuevo (número o intervalo) en el cuadro ubicado a la derecha del nombre de la sección, a continuación, adjunte las páginas de un adjunto, cambie el orden de las páginas de la sección y mueva las páginas de una sección a otra simplemente arrastrando y soltando cada página.

Mostrar la ventana de estructura de documentos

Para especificar la secuencia y la cantidad de secciones recurrentes así como la regla de ensamblaje, use el elemento del menú Plantilla > Propiedades de la plantilla de documento… en la ventana del editor de plantilla. En la ficha Ensamblaje especifique la cantidad mínima y máxima de inclusiones de cada sección en el documento (el valor predeterminado es 1). Si desea revisar los valores de los campos clave, habilite la opción Comprobar igualdad de campos clave y seleccione un campo clave en cada sección.

En ocasiones, puede desactivar las comprobaciones del orden de las secciones en el documento (por ejemplo: si el orden de las secciones no afecta el ensamblaje del documento). Seleccione Deshabilitar comprobación de orden de secciones para deshabilitar las comprobaciones. El programa aún comprobará que todas las secciones estén presentes en el documento, pero ignorará el orden.

Mostrar la ficha Ensamblaje


Creación de una plantilla para el procesamiento de documentos flexibles

Para las facturas, las órdenes de pago y otros documentos similares, no se puede crear una plantilla con ubicaciones de campos fijos. Esto se debe a que su ubicación, tamaño y cantidad no pueden ser idénticos, de modo que una plantilla fija no puede aplicarse a todos los documentos. En estos documentos, el programa busca campos después de reconocer previamente toda la página y crea una descripción flexible basada en palabras clave y ubicaciones relativas de los campos. Un módulo del programa especial ABBYY FlexiLayout Studio 8.0 tiene como función el diseño de descripciones flexibles (suministrado junto con ABBYY FlexiCapture 8.0 Professional). Encontrará instrucciones detalladas para diseñar una descripción flexible en los Temas de ayuda de ABBYY FlexiLayout Studio 8.0.

Se exporta una descripción flexible a un archivo .afl y, luego, se carga en ABBYY FlexiCapture 8.0 Professional. Se puede usar una descripción flexible para toda la plantilla o como una de sus secciones. Una descripción flexible puede incluir varias páginas.

Cómo adjuntar una descripción flexible

Puede adjuntarse una descripción flexible en la etapa de creación de una plantilla de documento. Para hacerlo, en la segunda etapa del Asistente para plantillas, agregue la imagen del documento y, luego, habilite la opción Cargar FlexiLayout e introduzca la ruta al archivo .afl que contenga la descripción flexible.

Puede adjuntar una descripción flexible en la ventana del editor de plantillas de documento, en el cuadro de diálogo de la sección de la plantilla de documento.

  1. Seleccione una sección del documento. (Si el documento incluye una sola sección, en la ventana Estructura de documentos, abra la ficha Páginas y seleccione el nombre de la única sección). Haga clic con el botón derecho y seleccione Propiedades… en el menú contextual.
  2. Vaya a la ficha FlexiLayout.
  3. Haga clic en Cargar….
  4. Seleccione el archivo .afl requerido que contenga la descripción flexible.

Después de adjuntar la descripción flexible, la imagen mostrará el diseño geométrico de los campos. Ahora, debe configurar las propiedades del campo del mismo modo que se configura la plantilla fija. Especifique las propiedades de la exportación, el reconocimiento y la verificación, y configure las reglas requeridas.


Creación de plantillas para documentos con adjuntos

ABBYY FlexiCapture 8.0 Professional le permite crear plantillas para documentos con adjuntos. Los adjuntos son páginas adicionales que acompañan cada formulario. A estas páginas no se les aplica ninguna plantilla, pero se tienen en cuenta durante el ensamblaje de documentos. Por ejemplo, se presenta una solicitud de préstamo (formulario fijo) junto con una declaración de ingresos en un estilo de formulario libre. Esta declaración de ingresos puede procesarse como un adjunto.

Para crear una plantilla para un documento con un adjunto:

Primer método:

  1. Abra la ficha Páginas en la ventana Estructura de documentos (primera parte del editor de plantillas).
  2. Habilite la opción Habilitar páginas adjuntas en el documento.
  3. Introduzca el número o rango de páginas del adjunto en el cuadro que aparece a la derecha del nombre de la sección.
Mostrar la ventana de estructura de documentos

Método alternativo de creación de una plantilla para un documento con un adjunto:
  1. Abra el cuadro de diálogo de las propiedades de la plantilla de documento (Plantilla > Propiedades de la plantilla de documento… en la ventana del editor de plantillas).
  2. Vaya a la ficha Ensamblaje.
  3. Habilite la opción Habilitar páginas adjuntas. La línea Páginas adjuntas aparecerá en la lista de secciones.
  4. Introduzca una cantidad mínima y una cantidad máxima de páginas en el adjunto.
Mostrar cuadro de diálogo

Para guardar el texto del adjunto, al configurar la exportación necesita especificar las opciones de guardamiento de imágenes (en la ficha Imágenes del cuadro de diálogo Configuración de exportación). Si selecciona PDF para búsquedas para guardar la imagen, el texto se reconocerá y se guardará en un archivo PDF para búsquedas.


Procesamiento de documentos sin estructura

ABBYY FlexiCapture 8.0 Professional puede utilizarse para procesar documentos sin estructura que incluyen información presentada en un estilo libre; por ejemplo, contratos, cartas, solicitudes o adjuntos. Los documentos sin estructura con texto o imágenes separados por hojas en blanco o páginas con código de barras se procesan y exportan a archivos PDF para búsquedas o archivos de gráfico.

El procesamiento de estos documentos normalmente incluye la conversión de documentos a formato electrónico y la ejecución de una búsqueda de acuerdo con los valores clave del campo.

De ser posible, la búsqueda de campos clave (como el número de contrato) en estos documentos se realiza usando una descripción flexible creada con ABBYY FlexiLayout Studio. Consulte Creación de una plantilla para el procesamiento de documentos flexibles.

Si la búsqueda automática de campos clave no es posible, el operador puede introducir los valores manualmente. Para hacerlo, cree una plantilla de documento con un campo (o varios campos, si es necesario) y habilite la opción No reconocer (campo de clave de imagen: se introducirá manualmente) en las propiedades del reconocimiento de este campo. Al ejecutar el proceso de verificación, el operador podrá introducir los valores del campo clave manualmente.

Debe configurar la exportación para habilitar el almacenamiento de datos: puede exportar los valores del campo clave al archivo o la base de datos y guardar las imágenes del documento en un formato conveniente. Para hacerlo, en la ficha Imágenes del cuadro de diálogo Configuración de exportación, habilite la opción Guardar imágenes del documento y configure los parámetros de guardamiento de imágenes. Puede guardar las imágenes del documento en archivos de gráfico o archivos PDF para búsquedas.

Preste atención al ensamblar las páginas en documentos: con documentos sin estructura, puede establecerse para que determine a qué documento pertenece una página particular. Para automatizar el ensamblaje de documentos sin estructura, recomendamos separar los documentos con hojas en blanco o páginas con código de barras. Al agregar imágenes a un lote (mediante digitalización, agregándolas desde un archivo o creando un perfil de importación) debe habilitar la opción Para imágenes separadas por y seleccionar el valor páginas en blanco o páginas con código de barras en la lista desplegable de acuerdo con las páginas que se usarán como separadores. Las páginas se ensamblan en documentos automáticamente: las páginas se agregarán al documento actual hasta la próxima página de separador. Para obtener detalles, consulte Agregar imágenes a las páginas.


Edición y publicación de una plantilla

Las plantillas pueden editarse en la ventana editor de plantillas de documento. Aquí, puede modificar el diseño de los campos y los elementos estáticos; editar sus propiedades, reglas, configuración de exportación, etc.

Para no afectar el trabajo de otros miembros del proyecto al editar una plantilla, el programa le permite editar una copia de la plantilla local mientras se utiliza la última versión de la plantilla publicada para el reconocimiento. Este modo permite que los administradores modifiquen y prueben las plantillas de forma local mientras los operadores pueden completar la verificación y exportar los documentos reconocidos utilizando la versión anterior, incluso si la plantilla se modificó considerablemente o se eliminó. La plantilla que se está editando no estará disponible para que otros usuarios la editen. Una vez que se complete la edición, el administrador puede publicar la plantilla; en cuyo caso la nueva versión estará disponible para el reconocimiento del documento, o puede anular todos los cambios.

Para editar una plantilla, realice lo siguiente:

  1. En la ventana principal del programa, seleccione el elemento del menú Proyecto>Plantillas de documento…
  2. Seleccione la plantilla que editará.
  3. Haga clic en el botón Editar… en el cuadro de diálogo Plantillas de documento para comenzar a editar la plantilla. Se copiará una versión local de la plantilla en su ordenador. La plantilla no estará disponible para que otros usuarios la editen.
  4. Realice las modificaciones necesarias en la ventana editor de plantillas de documento. Guarde la plantilla.
  5. Pruebe la plantilla con varias imágenes. Para realizar ajustes en la plantilla, puede utilizar lotes de prueba que trabajen con la versión local de la plantilla.
  6. Haga clic en el botón Publicar en el cuadro de diálogo Plantillas de documento para publicar la plantilla. Después de la publicación, la nueva versión de la plantilla se usará para el reconocimiento de documentos en los lotes de trabajo. Ahora, la plantilla puede ser editada por otros administradores. Para regresar a la plantilla original, haga clic enAnular cambios.


Prueba de las plantillas de documento

Antes de comenzar con el ingreso masivo de documentos, deben probarse las plantillas. La prueba se realiza con los documentos agregados a los lotes de prueba, ya que estos lotes trabajan con la versión de plantilla local. Estos lotes están disponibles en el menú Proyecto>Lista de lotes de prueba en la ventana principal del programa. También puede obtener acceso a los lotes de prueba desde la ventana del editor de plantilla al seleccionar Herramientas>Cambiar a lote de prueba….

Importante: Solo el usuario que creó un lote de prueba puede trabajar con ese lote de prueba. Si es necesario, un lote de trabajo puede usarse como lote de prueba; en este caso, funcionará como una fuente de imágenes para el lote de prueba.

Una plantilla puede probarse directamente en el editor de plantilla, en la imagen que se está utilizando para crear la plantilla. Para comenzar la prueba, seleccione Documento>Ejecutar prueba. El formulario de datos se mostrará como en el caso del procesamiento de documentos y también se mostrarán los errores de formato, los caracteres inciertos y los errores de regla.

Puede usar el menú Documento>Ver para volver a organizar las ventanas y el menú Documento>Verificación para desplazarse por los elementos de verificación, los caracteres inciertos y los errores de regla. Haga clic en el botón Finalizar prueba o seleccione Documento>Finalizar prueba para detener la prueba.

Nota: En el modo de prueba, el cambio del borde de un campo no hará que el programa vuelva a reconocer un campo; como ocurre cuando se cambian los bordes de un campo en la ventana del documento.

Para probar su plantilla en otras imágenes, seleccione un lote de prueba (puede hacerlo al seleccionar Herramientas>Cambiar a lote de prueba… en el editor de plantilla). Antes de que aparezca el cuadro de diálogo de selección de lotes, el programa verifica la plantilla actual para detectar errores. Si la plantilla no presenta errores, se guarda y aparece el cuadro de diálogo de selección de lotes. Cuando selecciona un lote en este cuadro de diálogo, la ventana principal del programa se activará y cambiará automáticamente al lote recientemente seleccionado.

Recomendamos verificar cada plantilla al menos con 20 imágenes de documentos (si los documentos se completaron a mano, es preferible usar documentos completados por diferentes personas).

Se requiere llevar a cabo una prueba para determinar si:

  1. Existe una cantidad suficiente de delimitadores e identificadores marcados para la aplicación determinada de una plantilla a una imagen.
  2. Las propiedades del campo se configuraron correctamente.
  3. Las reglas se configuraron correctamente.
  4. La exportación se configuró correctamente.

Durante la prueba, debe realizar la secuencia completa de acciones que se llevó a cabo al procesar los documentos.

Si se detectan errores en la regla, valores de campo incorrectos, etc., durante la prueba, debe editar la plantilla para corregirlos.

Solo después de solucionar todos los problemas detectados podrá publicar la plantilla y comenzar con el ingreso masivo de documentos.

Funcionamiento de un proyecto configurado


Perfiles de importación de imágenes

Para comenzar, el operador agrega nuevas imágenes: estas pueden ser documentos impresos para digitalizar o imágenes electrónicas existentes.

Las acciones que se repiten con frecuencia para agregar imágenes del mismo origen pueden automatizarse a fin de habilitar la importación con un solo clic. Para hacerlo, debe crear un perfil de importación de imágenes. Además, puede configurar el procesamiento de imágenes entrantes y la adición periódica de imágenes en el modo en segundo plano. Una vez que se haya establecido la configuración requerida, solo deberá hacer clic en un botón y las imágenes se digitalizarán o se importarán desde un origen predefinido, y las imágenes recibidas se procesarán (por ejemplo, se refinarán). Si es necesario, puede cambiar el origen o la configuración de la importación de imágenes.

Si suele cambiar el origen de la importación con frecuencia, puede crear varios perfiles de importación y alternarlos para evitar la necesidad de cambiar la configuración del origen de importación permanentemente.

Creación de un perfil de importación

Para agregar un perfil de importación, seleccione el elemento del menú Proyecto > Perfiles de importación de imágenes… en la ventana principal del programa. En el cuadro de diálogo que se abrirá, puede crear nuevos perfiles de importación, editar, eliminar y copiar perfiles existentes.

Puede crear un nuevo perfil de importación con la ayuda del Asistente para perfiles que puede ejecutarse desde el cuadro de diálogo Perfiles de importación de imágenes al hacer clic en Nuevo…. Seleccione un origen de importación, por ejemplo, un escáner o una carpeta dinámica, en la primera etapa de la operación del Asistente.

Creación de un perfil de importación con un escáner
  1. Seleccione Escáner como origen de la importación.

    Importante: El escáner debe estar conectado. Para conectar el escáner de manera correcta, consulte la documentación suministrada con el escáner. Asegúrese de instalar la totalidad del software suministrado con el escáner.

  2. Para el segundo paso, puede configurar las opciones para la digitalización y el procesamiento de imágenes digitalizadas:
    • Estilo del cuadro de diálogo de configuración: elija el método de interacción entre el programa y el escáner.
      • Configuración de escáner FlexiCapture: en este caso, el cuadro de diálogo Configuración de escáner de ABBYY FlexiCapture se utiliza para configurar las opciones de digitalización. Haga clic en el botón Configuración… para configurar las opciones de digitalización. Si habilita la opción Mostrar configuración del escáner antes de la digitalización, el cuadro de diálogo Configuración de escáner de ABBYY FlexiCapture aparecerá cuando seleccione este perfil de importación antes de la digitalización.
      • Opciones de digitalización: el cuadro de diálogo del controlador del escáner correspondiente se utilizará para configurar las opciones de digitalización. En este caso, no podrá cambiar las opciones de digitalización al crear un perfil de importación; sin embargo, el cuadro de diálogo de la configuración del escáner aparecerá siempre antes de comenzar la digitalización de imágenes.
    • Especifique si desea digitalizar una o más imágenes en una sola pasada.
  3. Para el siguiente paso, puede configurar las opciones para determinar el principio para agregar imágenes a los documentos y las opciones de procesamiento de imágenes. Para obtener detalles, consulte Opciones de procesamiento previo de imágenes.
  4. Para el paso final, puede cambiar el nombre predeterminado que se haya asignado a un perfil de importación e introducir su comentario.

Importante: Si el administrador que creó el perfil de importación con un escáner desea permitir que otros usuarios de este ordenador con derechos de usuario habituales (miembros del Grupo de usuarios) creen o editen perfiles de importación con un escáner, el administrador debe otorgarles el derecho de modificar el archivo %allusersprofile%\Application Data\ABBYY\FlexiCapture\Digitalización\Perfiles.

Creación de un perfil de importación con una carpeta dinámica
  1. Seleccione Carpeta dinámica como el origen de la importación. Especifique la ruta a la carpeta dinámica mediante un clic en el botón Examinar…

    Importante: Para poder agregar imágenes de la carpeta dinámica, el usuario debe tener privilegios de lectura y escritura para esta carpeta.

  2. Para el segundo paso, configure las opciones de carga de imágenes:
    • Revisar carpeta dinámica cada: habilite esta opción e introduzca un intervalo de tiempo para que el programa compruebe automáticamente si hay nuevas imágenes en la carpeta dinámica.

      Nota: El programa comienza a supervisar la carpeta dinámica cuando el usuario comienza a importar imágenes mediante un perfil con la opción Revisar carpeta dinámica cada habilitada. El programa deja de supervisar la carpeta dinámica cuando el usuario cierra el proyecto o deshabilita la opción Revisar carpeta dinámica cada en las propiedades del perfil.

    • En Configuración de lote, habilite una de las opciones para especificar el lote donde agregará nuevas imágenes.
      • Agregar imágenes al lote actual: habilite esta opción para agregar imágenes de la carpeta dinámica al lote actual.
      • Agregar imágenes al lote especificado: habilite esta opción y seleccione el nombre del lote de la lista desplegable para agregar imágenes a un lote específico.
      • Crear automáticamente nuevos lotes para imágenes importadas: habilite esta opción si desea crear lotes para nuevas imágenes de forma automática.
    • En la lista desplegable Cantidad de archivos para agregar, seleccione uno de los valores para especificar la cantidad de archivos que agregará al lote específico o recién creado:
      • Según archivo de descripción: los archivos se agregarán de acuerdo con la descripción. Para especificar el nombre y el tipo de archivo de descripción, haga clic en el botón Configuración…. Para obtener detalles, consulte Archivo de descripción.
      • Todos los archivos: se agregarán todos los archivos de la carpeta dinámica.
      • Varios archivos: se agregarán varios archivos. Para especificar la cantidad de archivos, haga clic en el botón Configuración… e introduzca la cantidad o el rango de valores.
      • Nota: Si especifica determinada cantidad de archivos, por ejemplo, 5, y solo hay 4 archivos disponibles en la carpeta dinámica, estos archivos no se importarán. Si especifica un rango, por ejemplo, de 1 a 5, los 5 archivos restantes se importarán.
      • Archivo único: se agregará un único archivo.
  3. Para el siguiente paso, puede configurar las opciones para determinar el principio para agregar imágenes a los documentos y las opciones de procesamiento de imágenes. Para obtener detalles, consulte Opciones de procesamiento previo de imágenes.

  4. Para el cuarto paso, el Asistente para perfiles le solicitará que especifique las opciones para la limpieza de la carpeta dinámica después de la importación: las imágenes correctamente importadas pueden eliminarse o moverse a una carpeta específica. Las imágenes que se procesaron con errores pueden permanecer en la carpeta dinámica o moverse a una carpeta específica. Si desea mover las imágenes, especifique las carpetas a donde las colocará.

  5. Para el paso final, puede cambiar el nombre predeterminado que se haya asignado a un perfil de importación e introducir su comentario.

El nombre del perfil de importación de imágenes que se creó aparecerá en el menú desplegable del botón de importación. Para realizar la importación de imágenes con este perfil, debe hacer clic en la flecha ubicada a la derecha del botón de importación y seleccionar el elemento con el nombre del perfil.

También puede editar y crear nuevos perfiles de importación en el cuadro de diálogo Seleccionar perfil de importación que se abrirá cuando selecciona el elemento Importar imágenes… en el menú desplegable del botón de importación.

Adición de imágenes de página


Opciones de procesamiento previo de imágenes

Cuando se agregan nuevas imágenes a un lote, el programa realiza el procesamiento previo de imágenes: las imágenes se separan en documentos, se giran, se eliminan los ruidos, etc.

Puede seleccionar las opciones de procesamiento previo en la ficha Procesamiento previo de imágenes. Pueden seleccionarse las opciones de procesamiento previo para:

  1. Un proyecto: en este caso, las opciones seleccionadas se usarán de manera predeterminada cuando se agreguen manualmente nuevas imágenes a los lotes del proyecto. Seleccione Proyecto>Propiedades del proyecto… en la ventana principal y, luego, haga clic en la ficha Procesamiento previo de imágenes.
  2. Un perfil de importación: estas opciones se usarán cuando este perfil de importación se utilice para agregar nuevas imágenes. Durante la creación de un nuevo perfil de importación , seleccione las opciones de procesamiento previo de imágenes en la etapa del Procesamiento previo de imágenes.
  3. Imágenes agregadas manualmente: al agregar imágenes de un archivo, haga clic en el botón Configuración del procesamiento previo de imágenes… en el cuadro de diálogo Cargar imágenes.

Nota: Si las imágenes se digitalizan de forma manual, no se realiza el procesamiento previo de imágenes. Las imágenes se procesan previamente solo si se utiliza un perfil de importación para agregar imágenes.

Los usuarios pueden seleccionar cualquiera de las siguientes opciones de procesamiento previo de imágenes:

  • Opciones que determinan los principios para agregar imágenes a los documentos:
    • Automáticamente cuando se aplica la plantilla: seleccione esta opción si desea que las imágenes se separen en documentos durante la asociación (durante el reconocimiento). En este caso, las imágenes no se separarán en distintos documentos inmediatamente después de agregarlas, y los documentos se ensamblarán solo después de que se hayan analizado y reconocido las páginas según la estructura descrita en la plantilla apropiada. Para obtener detalles, consulte Creación de plantillas para documentos de varias páginas y Ensamblaje de páginas en documentos.
    • Para cada archivo de imagen (Para cada archivo de imagen).
    • O se creará un nuevo documento cuando el programa alcance una hoja del separador (Para imágenes separadas por).

    • Para usar páginas en blanco como separadores, seleccione páginas en blanco en la lista desplegable.
      Para usar páginas con código de barras como separadores, seleccione páginas con código de barras de la lista desplegable. Puede configurar el valor y el tipo de código de barras mediante un clic en el botón Configuración… Si no se especifica ningún valor o tipo de código de barras, cualquier página que incluya un código de barras se considerará una página de separador. De lo contrario, solo se utilizarán las páginas con el código de barras del tipo o valor que se haya especificado. Si no necesita que se agreguen páginas de separador al lote, seleccione Eliminar páginas de separador. Si esta opción no está seleccionada, las páginas de separador se agregarán al lote y se convertirán en las primeras páginas de cada documento.

    Nota: No necesita usar páginas de separador para dividir las páginas entre los documentos. Las páginas de separador deben usarse solo cuando la apariencia de la página no permita determinar si pertenece al documento anterior o al siguiente. Por ejemplo, esto ocurre cuando un documento tiene determinada cantidad de páginas idénticas y el lote tiene más de un documento con esas características.

  • Configure las opciones de procesamiento de imágenes:
    • Refinar imágenes: elimina el ruido de las imágenes.
    • Convertir imágenes en color y en escala de grises a blanco y negro: convierte las imágenes a blanco y negro.
    • Girar imágenes: gira las imágenes hacia la dirección específica.
  • Opciones para enderezar la imagen: estas opciones están seleccionadas de manera predeterminada y el programa endereza las imágenes recién agregadas según los cuadrados negros y los separadores verticales y horizontales. No se recomienda desactivar las opciones para enderezar la imagen, a menos que el enderezamiento no funcione correctamente (por ejemplo, si el programa interpreta una impresión o un gráfico como un separador e intenta enderezar la imagen según indican esos datos incorrectos).
    • Utilizar separadores negros para corregir inclinación: si se selecciona esta opción, las imágenes se enderezan según las líneas del separador.
    • Utilizar cuadros negros para corregir la inclinación: si se selecciona esta opción, las imágenes se enderezan según los cuadrados negros.


Configuración de exportación predeterminada

La configuración de exportación predeterminada se utiliza para la exportación a archivo o a la base de datos sin utilizar la configuración de plantillas y también para las plantillas para las cuales no se estableció la configuración de exportación.

La configuración de exportación se establece para cada plantilla de documento; sin embargo, en ocasiones, es posible que necesite realizar la exportación a una ubicación de almacenamiento diferente, por ejemplo, para la exportación de prueba. En este caso, el operador puede utilizar el menú del botón de exportación y la exportación a archivo o a la base de datos con una configuración diferente de la configuración de la plantilla. Consulte Exportación de datos reconocidos. La configuración predeterminada se utiliza cuando se realiza la exportación por primera vez. Si la configuración de exportación se modifica después, se guardará la configuración de exportación que se utilizó por última vez.

La configuración predeterminada para la exportación a archivo o a la base de datos puede configurarse en la ficha Exportar del cuadro de diálogo Propiedades del proyecto (elemento del menú de la ventana principal Proyecto> Propiedades del proyecto…). Esta ficha muestra la configuración de exportación predeterminada actual. Puede establecer la configuración de exportación a archivo o a la base de datos. Para modificar la configuración de exportación predeterminada, haga clic en Cambiar configuración de exportación… y determine una configuración de exportación similar a la configuración de exportación de la plantilla (consulte Configuración de exportación de datos).


Lotes de documentos

Los documentos enviados para que se los procese se agregan a los lotes. La asignación de los documentos a los lotes está definida por el usuario: puede procesar todos los documentos en un lote o formar lotes a partir de documentos agregados en la misma fecha o a partir de un lote digitalizado en un único pase.

Para agregar lotes a un proyecto, seleccione Nuevo lote del menú contextual con una lista de lotes que aparece al hacer clic con el botón derecho en la ventana principal.

Si el proyecto no contiene lotes, el programa creará automáticamente un lote cuando intente agregar imágenes.

El operador agregará las imágenes de página del documento durante el ingreso de flujo único. Para obtener detalles, consulte Adición de imágenes de página.

Para ver los documentos que se agregaron al lote, abra el lote haciendo doble clic en él. Puede regresar a la lista de lotes desde la ventana de documentos mediante la selección del elemento del menú principal Proyecto>Lista de lotes de trabajo.

Lotes de prueba y trabajo

Los lotes de trabajo se utilizan para procesar documentos. En el modo de administrador, solo están disponibles los lotes de trabajo. El administrador utiliza lotes de prueba en el proceso de configuración de plantillas. La diferencia entre estos lotes consiste en que para procesar documentos de los lotes de prueba se utiliza una versión de plantilla local, mientras que para procesar documentos de los lotes de trabajo se utiliza una versión de plantilla publicada. Consulte también Modos de administrador y operador y Edición y publicación de una plantilla.

Puede abrir la lista de lotes de documentos en Proyecto de la ventana principal del programa. Lotes de trabajo: Lista de lotes de trabajo; lotes de prueba: Lista de lotes de prueba.


Campos de índice

Para facilitar la búsqueda y el procesamiento de documentos, puede indexar los documentos; para hacerlo, utilice los valores de cualquier campo de una plantilla. En la lista de documentos de la ventana principal del programa, además de la información básica, luego, podrá enviar los valores del campo de índice para cada documento, ordenar los documentos según estos valores y ubicar fácilmente los documentos necesarios.

Para realizar la indexación según los valores del campo, habilite la opción Campo Índice para este campo (ficha General del editor de la plantilla de documento).

Para mostrar el valor del campo de índice de la lista de documentos:

  • En la ventana principal del programa, abra un lote de documentos y habilite el modo de lista de documentos detallada (botón [image] de la barra de herramientas).
  • Haga clic con el botón derecho en la región del encabezado de la tabla (nombres de columnas) y seleccione Personalizar… de la lista desplegable.
  • En el cuadro de diálogo Personalizar tabla de documentos, haga clic en el botón Nuevo…
  • En el cuadro de diálogo Editar columna, haga clic en el botón Seleccionar… ubicado a la derecha del Campo de índice. En el cuadro de diálogo que se abre, seleccione uno de los campos con la opción Campo Índice habilitada. También puede introducir el nombre de cualquier columna y especificar el método de justificación.
  • En la tabla, aparecerá otra columna con el valor del campo de índice. Haga clic en este valor para clasificar los documentos según el valor del campo de índice.


Funcionamiento de un proyecto configurado

Antes de que el operador pueda comenzar a procesar los documentos, el administrador debe configurar el proyecto. El procesamiento de documentos se puede configurar de modo que requiera una participación mínima por parte del operador en las operaciones de digitalización e importación de imágenes, reconocimiento de datos y exportación. En este caso, la etapa principal del trabajo del operador consiste en comprobar y corregir los datos reconocidos: Verificación.

El trabajo del operador no se ve afectado por el tipo de documento.

El procesamiento de documentos consta de cuatro etapas, y a cada etapa le corresponde un botón en la barra de herramientas.

1. Adición de imágenes

La flecha ubicada a la derecha le permite seleccionar una de las opciones de importación de imágenes: Cargar imágenes…, Digitalizar imágenes… o importar imágenes mediante la selección de uno de los perfiles de importación configurados. El nombre del botón cambia de acuerdo con la acción seleccionada.

2. Reconocimiento

Ejecuta el proceso de reconocimiento de documentos. La flecha ubicada a la derecha también le permite analizar documentos o aplicar una de las plantillas.

3. Verificación

Ejecuta el proceso de verificación. Con la ayuda de la flecha, también puede ejecutar el proceso de validación de regla.

4. Exportación

Inicia la exportación de datos de acuerdo con la configuración establecida en la plantilla. También puede hacer clic en la flecha para exportar datos a archivo o a la base de datos.


Adición de imágenes de página

El procesamiento de documentos comienza al agregar imágenes de página del documento al proyecto: Importación de imágenes. Para comenzar con el trabajo, seleccione o cree un nuevo lote de trabajo para agregar imágenes (para crear un lote, haga clic con el botón derecho en la ventana principal del programa y seleccione Nuevo lote). Para abrir el lote necesario, haga doble clic sobre él o simplemente resáltelo en la lista.

Nota: Si intenta agregar una imagen a un proyecto sin lotes, se creará automáticamente un lote de documentos.

Hay varias maneras de agregar imágenes a un lote:

  1. Cargue las imágenes previamente guardadas de archivos.
  2. Digitalice las imágenes.
  3. Importe las imágenes mediante el uso de uno de los perfiles de importación de imágenes previamente configurados por el administrador (consulte Perfiles de importación de imágenes).

Para seleccionar un método para agregar imágenes, haga clic en la flecha ubicada a la derecha del botón de importación y seleccione uno de los elementos del menú.

Adición de imágenes de archivo

Para cargar imágenes de archivo, seleccione el elemento del menú Cargar imágenes… o utilice el acceso directo Ctrl+O. En el cuadro de diálogo que se abrirá, seleccione los archivos de imagen necesarios y configure las opciones de importación de imágenes:

  • Crear un documento nuevo: se crearán nuevos documentos para las imágenes agregadas.
  • Agregar al documento actual: se agregarán las imágenes al documento actual que está resaltado.
  • También puede seleccionar las opciones de procesamiento previo de imágenes: haga clic en el botón Configuración del procesamiento previo de imágenes… y seleccione las opciones deseadas en el cuadro de diálogo que se abrirá. Para obtener detalles, consulte Opciones de procesamiento previo de imágenes.

Digitalización de imágenes

Para agregar imágenes de un escáner, seleccione el elemento del menú Digitalizar imágenes…. Elija un escáner, configure las opciones de digitalización y digitalice las imágenes.

Adición de imágenes con la ayuda de perfiles de importación

Si el administrador configuró los perfiles de importación, sus nombres aparecerán en el menú del botón de importación. Para comenzar con la importación de imágenes, solo debe seleccionar un elemento con el nombre de uno de los perfiles de importación.

Después de seleccionar Importar imágenes…, se abrirá el cuadro de diálogo Seleccionar perfil de importación. Seleccione el perfil de importación de la lista y haga clic en el botón Importar para comenzar a importar las imágenes. Si está trabajando en el modo de administrador, en este cuadro de diálogo también puede crear un nuevo perfil de importación o editar los perfiles existentes.

Importación de imágenes en segundo plano

La importación de imágenes puede realizarse en el modo de segundo plano si se configuró el perfil de importación correcto. Las imágenes de la carpeta dinámica se importan automáticamente al sistema. El programa revisa la carpeta para buscar nuevas imágenes en los intervalos de tiempo que se especifican en la configuración.

El programa comienza a supervisar la carpeta dinámica cuando el usuario comienza a importar imágenes mediante un perfil con la opción Revisar carpeta dinámica cada habilitada. El programa deja de supervisar la carpeta dinámica cuando el usuario cierra el proyecto o deshabilita la opción Revisar carpeta dinámica cada en las propiedades del perfil. Para obtener detalles, consulte Perfiles de importación de imágenes.

Nota: Para agregar imágenes de la carpeta dinámica, el usuario debe tener privilegios de lectura y escritura para esta carpeta.


Configuración de opciones de digitalización

La calidad del reconocimiento depende, en gran parte, de la calidad de la imagen digitalizada. La calidad de la imagen puede regularse con la configuración de las opciones básicas de digitalización: tipo de imagen, resolución y brillo.

Al digitalizar imágenes con ABBYY FlexiCapture, hay dos posibles formas en las que el programa puede interaccionar con los escáneres mediante controladores TWAIN o ISIS:

  • Mediante la interfaz de ABBYY FlexiCapture:
    en este caso, las opciones de digitalización se configuran con la ayuda del cuadro de diálogo de ABBYY FlexiCapture Configuración de escáner; las opciones de digitalización pueden configurarse al crear un perfil de importación con el Escáner que se especifica como el origen de la importación.
  • Mediante la interfaz del controlador TWAIN o ISIS del escáner:
    el cuadro de diálogo del controlador del escáner correspondiente se utiliza para configurar las opciones de digitalización. Este cuadro de diálogo se abre automáticamente cuando selecciona Digitalizar imágenes… en el menú desplegable del botón de importación.

Opciones básicas de digitalización

  • Tipo de imagen: la digitalización en escala de grises (256 tonos de gris) es el mejor modo para el sistema de reconocimiento. Al escanear en el modo de escala de grises, el programa selecciona el nivel de brillo de forma automática.

    El tipo de imagen en blanco y negro asegura una mayor velocidad de digitalización a cuenta de cierta información de letras, que puede afectar la calidad de reconocimiento de los documentos con calidad de impresión reducida e intermedia.
    Si necesita que los elementos de color del documento (imágenes, letras de color y fondo de color) aparezcan en el documento electrónico y conserven el color, debe seleccionar el tipo de imagen de color. En otros casos, utilice el tipo de imagen en escala de grises.

  • Los valores de brillo y contraste deben seleccionarse con el fin de preservar los bloques del delimitador y, además, para que los bloques de imágenes diseñados para el reconocimiento reciban la mayor claridad y definición posible.
    En la mayoría de los casos, el valor de brillo intermedio más adecuado es del 50%.
    Es posible que, además, deba configurar el brillo al digitalizar ciertos documentos en el modo en blanco y negro.
  • Resolución: la resolución recomendada para el procesamiento de formularios que se completan de forma manual es de 300 ppp durante la digitalización en el modo en blanco y negro, y de 200 ppp durante la digitalización en el modo en escala de grises. La resolución de los formularios digitalizados debe poder asociarse con la resolución de la imagen de la plantilla.

Notas:

  1. La digitalización realizada con una resolución de 400-600 ppp en vez de 300 ppp o la digitalización realizada en gris o en color en vez de ser en blanco y negro puede demorar un tiempo considerablemente mayor. Con algunos modelos de escáner, la digitalización a una resolución de 600 ppp demora cuatro veces más que con una resolución de 300 ppp. No se recomienda la digitalización a una resolución inferior a 200 ppp.
  2. Cuando utiliza el cuadro de diálogo del controlador del escáner, las opciones para establecer la configuración de digitalización pueden tener diferentes nombres según el modelo del escáner. Por ejemplo, el brillo puede denominarse umbral o puede estar marcado con un círculo en blanco y negro o un sol. Los significados de las opciones se describen en la documentación incluida con su escáner.
Sugerencias para el modo de digitalización
  1. Digitalización de formularios con fondo de color con un escáner monocromático. Para que el fondo desaparezca durante la digitalización, debe equipar el escáner con una lámpara filtradora de luz apropiada: para los formularios de color rosa, una lámpara roja; para los formularios de color verde: una lámpara verde.
  2. Digitalización de formularios con fondo de color con un escáner en color. Para que el fondo desaparezca durante la digitalización, debe configurar el modo de filtrado para el color correspondiente en la configuración del escáner.
  3. Digitalización de formularios con fondo de colores claros. Si está procesando formularios de colores claros, debido a la baja intensidad del color, es posible que desaparezca el fondo durante la digitalización con una lámpara blanca, incluso sin el filtrado del software para el color. Como regla, el método de digitalización de formularios se elige en la etapa de desarrollo del formulario.
Sugerencias para la selección de brillo
  1. Una imagen digitalizada debe ser legible (para ver una imagen digitalizada, ábrala en la ventana del documento).
  2. Si las letras de la imagen digitalizada aparecen rasgadas, claras o delgadas:
    • Reduzca el brillo y aumente el contraste (se oscurece la imagen).
    • Intente digitalizarla en escala de grises (en este caso, el brillo se seleccionará automáticamente).
  3. Si la imagen digitalizada presenta un fondo sucio; caracteres deformados, borrosos o combinados; letras oscuras y gruesas:
    • Aumente el brillo (se aclara la imagen).
    • Intente digitalizarla en escala de grises (en este caso, el brillo se seleccionará automáticamente).


Reconocimiento

Para activar el reconocimiento, haga clic en el botón Reconocer. El programa aplica una plantilla después de seleccionarla mediante el uso de delimitadores e identificadores, y realiza el reconocimiento de datos en las regiones del documento mediante la asociación de las regiones del campo en la plantilla seleccionada.

El reconocimiento de imágenes puede realizarse automáticamente desde el momento en que se agregan las imágenes al lote. Con ese fin, debe habilitar la opción Reconocer imágenes agregadas de forma automatica (en el menú Herramientas de la ventana principal, seleccione el elemento Opciones… debajo de la ficha Procesamiento de documentos).

La relación entre los caracteres recientemente reconocidos y la cantidad total de caracteres se muestra en la columna Nivel de confianza. Después del reconocimiento, el operador puede ejecutar la verificación del documento.

Si es necesario, antes del reconocimiento, el operador puede realizar el Análisis preliminar de imágenes y asociación de plantillas.


Análisis preliminar de aplicación de plantillas e imágenes

Antes de ejecutar el reconocimiento, puede analizar o determinar qué plantilla puede aplicarse a cada página particular. Con ese fin, seleccione el elemento del menú principal Importación y reconocimiento > Analizar o haga clic en la flecha ubicada a la derecha del botón Reconocer y seleccione Analizar. Si se puede aplicar una plantilla, se nombrarán la página y el documento al que pertenece. Si no se puede asociar ninguna de las plantillas del proyecto con la imagen, la página permanecerá sin ser procesada.

También puede aplicar una plantilla determinada a una página o a un documento completo. En la mayoría de los casos, una plantilla que se creó correctamente en el programa se aplica a las páginas de forma automática; sin embargo, en algunos casos, es posible que tenga que aplicar una plantilla de forma manual.

Para aplicar una plantilla de documento:

  1. Resalte el documento.
  2. Seleccione Asociar plantilla… en el menú contextual del documento o el elemento del menú principal Importación y reconocimiento>Asociar plantilla…, o haga clic en la flecha ubicada a la derecha del botón Reconocer y seleccione Asociar plantilla…
  3. En el cuadro de diálogo Seleccionar plantilla de documento que se abrirá, seleccione una de las plantillas y haga clic en Aceptar.

Si la plantilla seleccionada se aplicó correctamente, el documento y sus páginas se denominarán según los nombres de la plantilla correspondiente y sus secciones.

Para aplicar una plantilla a una de las páginas:

  1. Resalte la página.
  2. Seleccione Asociar plantilla… en el menú contextual de la página o el elemento del menú principal Importación y reconocimiento>Asociar plantilla…
  3. En el cuadro de diálogo Seleccionar plantilla para asociar que se abrirá, seleccione una de las plantillas y haga clic en Aceptar.

Cuando se aplica correctamente la plantilla, la página seleccionada se denomina según el nombre de la sección de la plantilla correspondiente.


Verificación de datos reconocidos

La verificación o comprobación de datos reconocidos, es la parte más trabajosa de la tarea del operador. Por este motivo, el proceso de verificación en ABBYY FlexiCapture 8.0 Professional está organizado de la manera más práctica para el operador y con el fin de minimizar la cantidad de errores.

En los casos en que el programa no tiene certeza absoluta acerca de la precisión del reconocimiento de ciertos caracteres, los marca como reconocidos sin certeza. El objetivo del proceso de verificación consiste en verificar estos caracteres, garantizar que se hayan reconocido correctamente y corregirlos cuando sea necesario.

La validación de regla se realiza automáticamente. Si los valores de un campo cumplen con las condiciones de la regla, el campo puede marcarse como reconocido con certeza y excluirse del proceso de verificación. Cuando los valores de un campo no cumplen con las condiciones de la regla, el campo se envía para que lo verifiquen.

En el caso de documentos de varias páginas, primero, debe comprobar el ensamblaje de páginas en documentos.

Luego, ejecute el proceso de verificación haciendo clic en el botón Ejecutar verificación… o seleccionando el elemento del menú Verificación>Ejecutar verificación…. La verificación es un proceso de dos etapas: verificación de grupo y de campo. Si la plantilla no tiene campos incluidos en la verificación de grupo o de campo (consulte Propiedades de la verificación de campo), se omitirá la etapa correspondiente de verificación.

La verificación de grupo y de campo está seguida de la verificación en la ventana del documento. Los caracteres que no se confirmaron en las etapas anteriores permanecen resaltados en rojo.

Puede navegar por los errores haciendo clic en los botones [image] y [image] en la barra de herramientas de la ventana principal. El programa navega por todos los errores, por ejemplo, los errores de ensamblaje, los caracteres reconocidos sin certeza y los errores de regla, entre otros.

Ensamblaje de páginas en documentos
Verificación de grupo
Verificación de campo
Verificación en la ventana del documento
Validación de regla


Ensamblaje de páginas en documentos

Las páginas se ensamblan en documentos automáticamente. Con ese fin, durante la creación de una plantilla para el procesamiento de documentos de varias páginas, debe describir el principio de ensamblaje. También puede configurar la verificación de campos clave.

La tarea del operador consiste en identificar y corregir los posibles errores de ensamblaje del documento.

Los errores de ensamblaje pueden corregirse de manera más práctica en el modo de esquema de la página que brinda al usuario una buena visualización de las imágenes de página y los documentos a los que pertenecen. Puede cambiar a este modo haciendo clic en el botón [image].

Nota: Para cambiar la escala de esquemas de la página para ver detalles, mantenga pulsada la tecla Ctrl y gire la rueda del ratón.

Nota: El orden de las secciones no se comprobará si, durante la creación de la plantilla de documento, se seleccionó la opción Deshabilitar comprobación de orden de secciones en la ficha Ensamblaje. El programa aún realizará la comprobación para garantizar que todas las secciones estén presentes en el documento, pero ignorará el orden de las secciones.

Al crear una plantilla de documento, debe configurar la regla de ensamblaje de documentos: secuencia y cantidad de secciones recurrentes del documento. También puede configurar una verificación del ensamblaje de acuerdo con los valores de los campos clave: en este caso, los valores de los campos clave deben ser idénticos en todas las páginas del documento.

Los documentos que tengan errores de ensamblaje se marcan con este símbolo [image]. La descripción del error se indica con una leyenda en rojo debajo del nombre de la plantilla de documento.

Cómo corregir errores de ensamblaje

  1. Secuencia incorrecta de páginas en un documento

    Es posible que existan muy pocas o demasiadas páginas, o que las páginas del documento no estén organizadas en la secuencia correcta. Para leer una sugerencia, coloque el cursor sobre la página marcada con una cruz roja:

    Si desea corregir estos errores, puede usar el ratón para mover la página dentro de un único documento y de un documento a otro.

    Las páginas de varios documentos pueden combinarse en un documento único de la siguiente manera:

    • Resalte los documentos que se combinarán (pulse Ctrl y haga clic para seleccionar varios documentos).
    • Haga clic con el botón derecho y seleccione Combinar en el menú contextual.

    Para dividir las páginas de un documento y colocar cada una de ellas en un documento diferente:

    • Resalte el documento en el que desea dividir las páginas.
    • Seleccione Dividir en el menú contextual.

  2. Si la plantilla requiere la verificación de campos clave para el ensamblaje correcto de las páginas, los valores de los campos clave se mostrarán debajo de la imagen de cada página:

    • Resaltado en gris: en caso de una asociación.
    • Resaltado en rojo: en caso de que no se hayan asociado.

    Es posible que los campos clave no se hayan podido asociar si se reconocieron o completaron de manera incorrecta. Compruebe los valores de los campos clave. Si los valores de los campos clave aún no se pueden asociar, es probable que las páginas no pertenezcan al mismo documento. Si la secuencia de páginas es incorrecta, busque páginas con campos clave idénticos y ensámblelas en documentos como se describe en el punto 1.


Verificación de grupo

La verificación de grupo implica agrupar las imágenes de caracteres reconocidas con valores idénticos y visualizarlas en la ventana del verificador, de modo que el operador pueda identificar y corregir fácilmente los caracteres que se desvían del grupo.

Mostrar la ventana de verificación de grupo

Durante la verificación de grupo, el operador puede ver el contexto del carácter que se está verificando; para hacerlo, debe seleccionar el elemento Mostrar imagen del carácter en el menú contextual del carácter resaltado o pulsar F2.

También puede activar un modo por el cual el campo que contiene el carácter mostrará, cuando apunte el cursor, el carácter que se está verificando. Con ese fin, seleccione el elemento del menú Ver>Campo de imagen>Mostrar imagen de campo en la ventana del verificador o utilice el acceso directo Ctrl+I.

Los caracteres reconocidos de forma incorrecta pueden corregirse de la siguiente manera: resalte el carácter que no coincide con el carácter del grupo e introduzca el valor correcto. Este valor, resaltado en verde, aparecerá en la esquina superior izquierda de la imagen del carácter.

Si aún tiene dudas sobre el significado del carácter, incluso después de verlo en contexto, haga clic con el botón izquierdo en el carácter: se resaltará con un signo de interrogación rojo.

También puede cambiar el estado del carácter si pulsa el botón Alternar en la barra de herramientas.

Puede confirmar los caracteres correctamente reconocidos al seleccionar Confirmar en el menú contextual. Para confirmar todos los caracteres al mismo tiempo, haga clic en el botón Confirmar todo en la barra de herramientas.

Nota: Durante la creación de una plantilla, puede modificar las opciones de verificación al configurar las propiedades del campo. Los caracteres de los campos con la opción Incluir en la verificación de grupo habilitada en la ficha Verificación del cuadro de diálogo de las propiedades del campo se envían para la verificación de grupo. Consulte Propiedades de la verificación de campo. Para la verificación de grupo, recomendamos enviar marcas de verificación y campos que solo pueden completarse con números. Las letras se verifican mejor en el contexto del campo.


Verificación de campo

La verificación de campo es un modo de verificación diseñado para la corrección eficaz de errores de campos "reconocidos", es decir, campos cuyo rango de valor es conocido o puede identificarse fácilmente. Un ejemplo de este tipo de campos es el nombre de una ciudad o de un país: sabemos qué valores puede tener este campo.

Para decidir cómo corregir un campo, el usuario solo necesita ver este campo y conocer su rango de valores. Los errores de entrada y de formato de campos pueden corregirse.

Mostrar la ventana de verificación de campo

Para corregir los caracteres reconocidos de forma incorrecta, puede usar los modos estándar de los editores de texto: Modos de pegamiento y reemplazo de caracteres: puede alternar entre los dos modos al pulsar el botón Insertar en el teclado.

El usuario revisa los resultados de reconocimiento de cada campo en una secuencia, los corrige si es necesario y los confirma mediante un clic en el botón Confirmar campo.

Debe corregir los valores en los campos. Si es imposible corregirlos, puede omitir el campo o diferir la verificación haciendo clic en el botón En pausa para corregirlo más adelante.

Nota: Los campos que tengan la opción Incluir en la verificación de campo habilitada en la ficha Verificación del cuadro de diálogo de las propiedades del campo se envían para la verificación de campo. Consulte Propiedades de la verificación de campo. Para la verificación de campo, recomendamos enviar campos de una línea con un rango de valores conocido.


Verificación en la ventana del documento

La ventana del documento también le permite comprobar la precisión del reconocimiento y corregir caracteres reconocidos de forma incorrecta. La ventana del documento se abre al hacer doble clic en el nombre de la página. La ventana del documento incluye la región de datos, la imagen de página y la región de errores de regla (si estos errores están presentes). Puede configurar el diseño de la ventana haciendo clic en el botón Diseño. En la ventana del documento, el operador visualiza no solo los grupos de caracteres o campos independientes sino también el documento completo.

Mostrar la ventana del documento

En la región de datos, los caracteres reconocidos sin certeza y aquellos que sean cuestionables se marcan con color, y los campos que tengan tipos de datos incorrectos o las reglas que no se hayan cumplido se resaltan.

Para confirmar un campo que tenga caracteres reconocidos sin certeza, coloque el cursor en el campo y pulse Intro.

Los campos para la visualización y la edición de datos reconocidos pueden organizarse no solo en secuencia sino de cualquier otra manera que le resulte práctico al usuario. Puede cambiar la forma en que estén dispuestos en el editor de plantillas de documento. Consulte Configuración de la presentación de datos en la ventana del documento.

Puede navegar hasta el siguiente error en la ventana del documento haciendo clic en los botones [image] y [image] en la barra de herramientas de la ventana principal. El programa navega por todos los errores, por ejemplo, los errores de ensamblaje, los caracteres reconocidos sin certeza, los errores de regla y los campos clave que no se asociaron correctamente, entre otros.


Verificación de regla

Validación de regla

Las reglas que no cumplen con las condiciones, se marcan: con un indicador amarillo [image] (advertencia) o con un indicador rojo [image] (error).

Los errores de regla se muestran en otra ventana del editor de documentos y los documentos que no cumplieron ciertas reglas se marcan con indicadores rojos.

En el caso de las reglas que no se cumplieron, el operador debe comprobar la calidad del reconocimiento de datos. Si es un error de reconocimiento, el operador debe corregirlo. Si hubo un error en el proceso por el que se completó el formulario y no puede corregirse, el operador no debe exportar el documento. Los documentos que tengan errores pueden verificarse más adelante; para hacerlo, se los deben comparar con los documentos impresos u otras fuentes disponibles.

Para volver a revisar los datos en busca de errores de regla, haga clic en la flecha ubicada a la derecha del botón Ejecutar verificación… y seleccione el elemento del menú Volver a comprobar reglas. Si se cumplen las reglas después de que haya corregido los valores del campo, se eliminarán los indicadores.


Exportación de datos reconocidos

Después de verificar los datos reconocidos, el operador exporta el lote mediante un clic en el botón Exportar. La exportación se realiza de acuerdo con la configuración de la plantilla de documento.

También puede realizar la exportación a archivo o a la base de datos sin utilizar la configuración de exportación establecida en la plantilla.

Nota: Al realizar la exportación a archivo o la base de datos, puede utilizar la configuración predeterminada o, si lo desea, cambiarla. La configuración de exportación predeterminada se configura en el cuadro de diálogo de las propiedades del proyecto (elemento del menú principal Proyecto>Propiedades del proyecto…) en la ficha Exportar. Consulte Configuración de exportación predeterminada.

Exportación a un archivo

  1. Para exportar datos a archivo, haga clic en la flecha ubicada a la derecha del botón de exportación y seleccione el elemento del menú Exportar a archivo…
  2. Seleccione la ubicación de almacenamiento y el prefijo del nombre de archivo. El nombre completo comenzará con este prefijo seguido del nombre de la plantilla de documento, el nombre del lote y el número del documento si guardó cada documento como un archivo independiente (consulte el punto 3).
  3. Habilite las opciones:
    • Crear archivo para cada documento: permite almacenar los datos de cada documento en un archivo único.
    • Sobrescribir archivos existentes: permite sobrescribir el archivo de exportación.
    • Guardar imágenes del documento: permite guardar las imágenes del documento.
  4. Para cambiar otras opciones de la configuración de exportación, haga clic en el botón Configuración…. Para obtener detalles relacionados con la configuración de exportación, consulte Configuración de exportación de datos.
  5. Para guardar la configuración de exportación modificada, en el cuadro de diálogo Configuración de exportación de archivos, haga clic en el botón Guardar en la plantilla de documento y seleccione una plantilla de documento para la cual desea guardar la configuración actual.

Exportación a la base de datos

  1. Para exportar datos a una base de datos, haga clic en la flecha ubicada a la derecha del botón de exportación y seleccione el elemento del menú Exportar a base de datos….
  2. Establezca una conexión con la base de datos. Para obtener detalles, consulte Exportación a la base de datos.
  3. Vaya a la ficha Imágenes y establezca la configuración de almacenamiento de imágenes.

Notas:

  1. Es posible que los documentos cuyos datos se exportaron correctamente se eliminen automáticamente del lote. Esto ocurrirá si se habilita la opción Eliminar los documentos procesados después de la exportación en el cuadro de diálogo Opciones en la ficha Procesamiento de documentos.
  2. Si intenta exportar documentos con errores de regla, el programa mostrará un mensaje de error. Las advertencias de regla no impedirán que se realice la exportación.


Modo en segundo plano

Cuando no se requiere el control del operador, los documentos se pueden importar, reconocer y exportar en el modo en segundo plano.

Para transferir una tarea en el modo en segundo plano, haga clic en el botón Modo de segundo plano en el cuadro de diálogo Agregando imágenes… (o en los cuadros de diálogo Reconociendo… o Exportando…).

Las siguientes tareas pueden ejecutarse en el modo en segundo plano:

  • Carga de imágenes desde una carpeta dinámica con el correspondiente perfil de importación.
  • Reconocimiento de documentos, si se seleccionó la opción Reconocer imágenes agregadas de forma automatica (Herramientas > Opciones…, ficha Procesamiento de documentos).

Al cambiar al modo en segundo plano, el icono [image] aparece en la barra de tareas. Al hacer clic en este icono se abre el cuadro de diálogo Tareas en segundo plano, que muestra la lista de tareas.

  • Las tareas se ejecutan en el orden en que aparecen o de acuerdo con las prioridades establecidas por el usuario (botón Establecer prioridad…).
  • La ejecución de la tarea se registra en un archivo de registro que el usuario puede personalizar (Herramientas > Opciones…, ficha Progreso de la tarea). Haga clic en el botón Ver registro para ver el registro.
  • Puede interrumpir una tarea haciendo clic en el botón Finalizar tarea.

El programa también puede informarle acerca del progreso de las tareas en segundo plano mediante mensajes emergentes en forma de globos que se muestran en la esquina inferior derecha. Los mensajes aparecen al comenzar la tarea, al finalizarla y en el momento en que aparece un error. Para obtener más detalles, consulte Opciones adicionales.


Anexo

Diseño de formas legibles por máquina
Teclas de acceso rápido
Uso de scripts en FlexiCapture 8.0
Comparación de reglas de FormReader 6.5 y FlexiCapture 8.0 Professional
Idiomas de reconocimiento compatibles
Fuentes para la interpretación correcta de caracteres
Tipos de texto compatibles
Tipos de códigos de barras compatibles
Formatos de gráficos compatibles
Formatos de archivo de exportación
Alfabeto utilizado en expresiones regulares
Patentes
Tecnologías proporcionadas por otras empresas


Cómo crear un formulario legible por máquina

Los cuestionarios, los formularios de seguridad social, las boletas de votación, las tarjetas de garantía son tipos de formulario que se utilizan para recaudar diferentes tipos de información.

¿De qué manera los formularios se diferencian de otros tipos de documentos?

  1. Un formulario siempre tiene un número de conjuntos de campos
  2. Cada campo contiene sólo un determinado tipo de información, por ej. el campo "Apellido" contiene sólo los apellidos (si se completa correctamente) y el campo "Fecha" contiene sólo fechas.

Los formularios se utilizan para recopilar la información de una gran cantidad de encuestados. La recopilación manual de información es un proceso largo y cansador en el que los errores simples y de imprenta son prácticamente inevitables y los formularios legibles por máquina se utilizan para automatizar este proceso.

El procesamiento automatizado de formularios consiste en los siguientes pasos:

  1. Configuración de la aplicación del procesamiento de formularios (cómo crear una plantilla y especificar los campos que se deben reconocer).
  2. Adquisición de imágenes de formularios (digitalización).
  3. Procesamiento de imágenes de formularios (reconocimiento de imágenes y validación de los datos extraídos).
  4. Exportación de los datos extraídos al sistema de información externa.
No todos los formularios utilizados para recopilar información son adecuados para la entrada automatizada. Para que sea legible por máquina, el formulario debe cumplir con determinados requisitos que se discuten en este capítulo.

Formularios legibles por máquina

Elementos de los formularios legibles por máquina

Métodos para completar el formulario

Tipos de formularios legibles por máquina

Cómo seleccionar el Tipo correcto de formulario

Requisitos generales para los formularios legibles por máquina


Formularios legibles por máquina

Para poder leer la información de un formulario, la aplicación de procesamiento de formularios debe hacer lo siguiente:

  1. Determinar la ubicación de los elementos del formulario.
  2. Separar los contenidos de campo de los bordes del campo, marcación del texto, fondos, texto explicativo, etc.

Los formularios legibles por máquina permiten que el programa lleve a cabo estas tareas.

Para que la primera tarea se lleve a cabo correctamente, los formularios deben corresponder al patrón o plantilla del formulario, es decir, la ubicación de todos los elementos del formulario debe ser idéntica en todos los formularios del mismo tipo.

Para que la segunda tarea se lleve a cabo correctamente, los formularios deben diseñarse teniendo en cuenta la entrada automatizada, es decir, de modo que el programa pueda distinguir fácilmente los datos que debe capturar de los elementos de formulario no reconocibles como los bordes de campo, la marcación del texto, los fondos o el texto explicativo.


Elementos de los formularios legibles por máquina

Los siguientes elementos pueden aparecer en un formulario:

Texto

Campo de entrada

Campo de marca de verificación

Grupo de marcas de verificación

Marca de referencia

Separador de líneas

Identificador de formulario

Imagen

Tabla

Grupo de elementos


Cómo crear un formulario o texto legible por máquina

Texto

El Texto es un elemento del formulario legible por máquina que contiene texto descriptivo: título del formulario, nombres de campo, explicaciones, etc.


Cómo crear un formulario o campo de entrada legible por máquina

Campo de entrada

El campo de entrada es un elemento del formulario legible por máquina en donde la persona que completa el formulario ingresa el texto. Para facilitar el ingreso del texto, los campos de entrada pueden contener una marcación especial de texto. Por lo general, los campos de entrada están acompañados de un texto que describe o explica la naturaleza de los datos que se deben ingresar.

Mostrar un campo de entrada

Los tipos de marcación de texto posibles se muestran en la tabla a continuación.

Texto sobre una línea | El texto se ingresa sobre una línea.
Letras en marcos | Las letras se ingresan en marcos conjuntos.
Letras en marcos individuales | Las letras se ingresan en marcos individuales.
Letras que se ingresan en un código de combinación | Las letras se ingresan en un código de combinación.
Texto en un marco | El texto se ingresa en un marco.
Texto en un marco con una combinación | El texto se ingresa en un marco con una combinación.


Cómo crear un formulario o campo de marca de verificación legible por máquina

Campo de marca de verificación

El campo de marca de verificación es un elemento del formulario legible por máquina (generalmente un cuadrado denominado "cuadro de verificación") donde la persona que completa el formulario debe hacer una marca.

El campo de la marca de verificación suele ser acompañado por el texto de descripción que aclara el significado de la marca.

A continuación se muestran las formas posibles de los campos de marca de verificación.

Cuadrado

Círculo

Subrayado

También hay otras formas posibles, por ej. polígonos, óvalos, etc.


Cómo crear un formulario o grupo de marcas de verificación legible por máquina

Grupo de marcas de verificación

El grupo de marcas de verificación es un elemento del formulario legible por máquina que reúne diferentes campos de marcas de verificación de los cuales sólo uno debe verificarse. Por lo general, los grupos de marcas de verificación están acompañados del texto explicativo que especifica la naturaleza de la elección a tomar.

Mostrar un grupo de marcas de verificación


Cómo crear un formulario o marca de referencia legible por máquina

Marca de referencia

La marca de referencia es un elemento del formulario legible por máquina que se utiliza para facilitar la combinación de las imágenes del formulario con las plantillas, y para determinar la orientación de los formularios durante el procesamiento automatizado.

Antes de que el programa comience a reconocer los contenidos del formulario, debe combinar el formulario con la plantilla. Todos los formularios legibles por máquina que sean del mismo tipo deben ajustarse a una plantilla, es decir, la ubicación de todos los elementos del formulario debe ser exactamente la misma en todos los formularios. El programa intenta combinar el formulario con la plantilla según el número y la ubicación de las marcas de referencia del formulario. Si el programa logra combinar las marcas de referencia del formulario con las marcas de referencia de la plantilla, sabrá exactamente dónde buscar los campos que contienen datos que deben reconocerse.

Las marcas de referencia estándar se muestran en la tabla a continuación.

Cuadrado negro

Esquina

Cruz

Marcas de tiempo

Para obtener mejores resultados del reconocimiento, es recomendable tener marcas de referencia estándar en el formulario, pero, en algunos casos, los separadores de líneas, el texto explicativo o los códigos de barras pueden utilizarse como marcas de referencia. Sin embargo, las marcas de referencia estándar son más confiables y siempre deben elegirse como primera opción.


Cómo crear un formulario o separador de líneas legible por máquina

Separador de líneas

El separador de líneas es un elemento del formulario legible por máquina con forma de una línea negra vertical u horizontal.

Los separadores de líneas de utilizan para dividir formularios en diferentes segmentos lógicos.


Cómo crear un formulario o identificador del formulario por máquina

Identificador del formulario

El identificador del formulario es un elemento del formulario legible por máquina que se utiliza para seleccionar la plantilla adecuada si existen diferentes plantillas con la misma disposición de marcas de referencia.

Se recomienda utilizar códigos de barras como identificadores de formulario.

Un código de barras es un conjunto de líneas verticales negras y blancas de diferentes anchos que se utilizan para codificar información.

Mostrar un código de barras.

También se puede utilizar otros elementos del formulario como identificadores del formulario


Cómo crear un formulario o imagen legible por máquina

Imagen

La imagen es un elemento del formulario legible por máquina que no debe reconocerse y que debe exportarse como un archivo de imagen.

Por ejemplo, la parte del formulario en la que se pone la estampilla o firma es una imagen.


Tabla

Una tabla contiene columnas con elementos del mismo tipo.

Las columnas de la tabla pueden contener elementos de los siguientes tipos:

  • texto
  • campo de entrada
  • fecha
  • número
  • marca de verificación

Una tabla puede contener una línea con encabezados de columna.


Grupo de elementos

Grupo de elementos: elemento de un formulario legible por máquina cuya función consiste en combinar varios elementos vinculados lógicamente en un grupo.


Métodos para completar el formulario

El formulario debe completarse de una de las siguientes maneras:

  • a mano

  • con una impresora de matriz de puntos

  • con una máquina de escribir

  • en una imprenta (aquí también se incluyen los formularios que se completan con impresoras a láser o de chorro de tinta con una resolución que no debe ser inferior a 300 dpi)

  • con varios métodos de los antes mencionados


Tipos de formularios legibles por máquina

Los formularios legibles por máquina están diseñados teniendo en cuenta una entrada automatizada, es decir, el programa debe poder distinguir fácilmente los datos que debe capturar de los elementos del formulario no reconocibles, como los bordes de campo, la marcación del texto, los fondos, o el texto explicativo.

Se puede hacer de dos maneras:

  1. Se debe diseñar el formulario de modo que haga que los bordes de campo, el fondo y la marcación de texto desaparezcan después de la digitalización, o

  2. Se debe diseñar el formulario de modo que haga que los bordes de campo, el fondo y la marcación de texto se distingan claramente después de la digitalización.

Si se utiliza la primera opción, sólo las marcas de referencia, el texto explicativo, y los datos ingresados permanecen en el formulario después de la digitalización. Por consiguiente, el programa no tiene que separar los datos de los elementos del formulario, lo que hace que el reconocimiento sea más fácil y confiable.

En este caso, se utilizan los siguientes tipos de formularios: formularios con omisiones de color, formularios blanco y negro con fondos de trama, formularios blanco y negro con bordes de trama, y formularios lineales blanco y negro.

Si se utiliza la segunda opción, las marcas de referencia, el texto explicativo, los datos ingresados, la marcación de texto y los bordes de campo permanecen en el formulario después de la digitalización. El programa busca información que esté rodeada de bordes de campo y de marcación de texto. La ausencia de estos elementos del formulario tiene un efecto adverso en la calidad de reconocimiento.
En este caso, se utilizan formularios lineales blanco y negro.


Formularios con omisiones

Los formularios con omisiones tienen un fondo de color claro con rectángulos blancos que funcionan como celdas de carácter, campos de marca de verificación, etc.

Por ejemplo, formularios con omisiones grises. El fondo es gris.

Los formularios con omisiones de color incluyen los formularios en el que sólo están coloreados los bordes de los elementos.

La celda de carácter es un rectángulo pequeño en el que se debe ingresar sólo un carácter (por ej. una letra o un dígito). El color del fondo es muy importante debido a que debe desaparecer durante la digitalización. Por lo general, el fondo es anaranjado rojizo claro o verde. Véase la lista de colores recomendados en la sección Colores recomendados para formularios con omisiones.

Mostrar formulario con omisiones

Lo ideal sería que todos los elementos del formulario, con excepción de las marcas de referencia, desaparezcan durante la digitalización, de modo que sólo se deban reconocer los contenidos del campo en la imagen del formulario.

El texto explicativo puede mantenerse (si se imprime con negro) o filtrarse junto con el fondo. Para que el texto explicativo desaparezca durante la digitalización, debe imprimirse con el mismo color del fondo del formulario pero con mayor saturación.

Al decidir si el texto explicativo debe imprimirse con negro o con el color del fondo, se debe tener en cuenta lo siguiente:

  • El tamaño del archivo de imagen será mayor si se mantiene el texto explicativo.

  • Debe haber un espacio de, por lo menos, 1,5-2 mm entre el texto explicativo impreso en negro y los demás elementos del formulario. El espacio entre el texto explicativo y el campo de marca de verificación correspondiente no debe ser menor a 2/3 del tamaño del campo de marca de verificación. Si el texto explicativo se imprime con el color del fondo, los espacios entre el texto y los demás elementos del formulario no son tan fundamentales.

Los formularios con texto explicativo impresos con negro son más legibles. Se recomienda imprimir el texto explicativo con negro, en especial, si no hay marcas de referencia en el formulario.

Consejos útiles
Al crear una plantilla para un formulario con texto explicativo impreso con el color del fondo, asegúrese de digitalizar el formulario en modo de color o escala de grises para hacer que el texto explicativo y los elementos del formulario estén claramente visibles.

Los formularios con omisiones deben digitalizarse utilizando una lámpara de color o filtro. El color de la lámpara se selecciona según el color del fondo.

Los formularios con fondo rojo o verde deben digitalizarse:

  • en un escáner de color utilizando software de filtrado de color,

  • en un escáner sin color utilizando una lámpara roja o verde (filtrado de color del hardware),

  • en un escáner sin color utilizando una lámpara blanca y un filtro rojo o verde (la calidad de filtrado en este caso es mucho inferior, debido a que el fondo no desaparece por completo, o los contenidos de los campos se eliminan sin darse cuenta), o

  • en un escáner sin color utilizando una lámpara blanca sin filtros.
    Al digitalizar con una lámpara blanca, algunos fondos más claros pueden eliminarse sin filtrado: la saturación débil del fondo hace que desaparezca durante la digitalización. En este caso, el color y la saturación del fondo debe seleccionarse por prueba y error para cada escáner en particular.

Nota. Muchos escáneres a color también utilizan filtrado de software para filtrar los colores azules. Sin embargo, no se recomienda utilizar sombras de azul en los formularios, debido a que es muy común completar los formularios con tinta negra y azul. Los contenidos de los campos escritos con tinta azul desaparecen en este caso.

Cómo elegir el color correcto

Se prefiere colores anaranjado rojizos a los verdes ya que son los que más contrastan con el azul, obteniendo así una digitalización y calidad de reconocimiento superior si los formularios se completan con tinta azul.

En la sección Colores recomendados para formularios con omisión se muestran los colores recomendados para el procesamiento de formularios, es decir, aquellos que desaparecen con más facilidad durante la digitalización con casi todos los escáneres. Cualquier fabricante o vendedor de escáneres puede brindarle la lista de colores "con omisión" para un escáner en particular (en Pantone o cualquier otro formato).


Formularios en blanco y negro con fondo de trama

Formularios en blanco y negro con cuadrícula

Los campos en estos formularios son simplemente espacios blancos (por lo general, rectángulos) sobre una cuadrícula. El fondo está hecho de puntos individuales. El tamaño recomendado de los puntos es de 0,1 mm como máximo, con una distancia de 1 mm entre sí. El tamaño de los puntos y la distancia entre ellos es fundamental, debido a que la cuadrícula se elimina durante la eliminación de manchas más que durante la digitalización: el programa trata los puntos como basura y los elimina. Por consiguiente, los puntos no deben estar amontonados en las imágenes digitalizadas.


Formularios en blanco y negro con bordes de trama

Estos formularios no tienen fondo. Todos los bordes de los campos (bordes de las celdas de carácter, campos de marca de verificación y demás elementos del formulario) están hechos de líneas de trama, es decir, secuencias de pequeños puntos negros. Por lo general, el tamaño del punto de trama es 0,39 - 0,5 pto. El tamaño recomendado es 0,39 pto, con una distancia entre los puntos de trama de, al menos, cinco veces el tamaño del punto. El tamaño de los puntos y la distancia entre ellos es fundamental, debido a que el fondo de trama se elimina durante la eliminación de manchas más que durante la digitalización: el programa trata los puntos como basura y los elimina. Por consiguiente, los puntos no deben estar amontonados en las imágenes digitalizadas.


Formularios lineales en blanco y negro

Por lo general, estos formularios no tienen fondo. Todos los bordes de los campos (celdas de carácter, campos de marca de verificación y los demás elementos del formulario) están hechos de líneas negras sólidas. Los bordes de los campos no desaparecen con la digitalización ni con la eliminación de manchas.

Nota. Los formularios de este tipo deben completarse con cuidado. De lo contrario, las letras pueden superponerse a los bordes de los campos, disminuyendo así la calidad de reconocimiento. Esto se debe a que cuando el contenido del campo se superpone a los bordes del campo, es extremadamente difícil para la aplicación separar los bordes del texto. Lo ideal sería que el texto ingresado no toque los bordes del campo.


Cómo seleccionar el Tipo correcto de formulario

Además de los requerimientos de diseño y procesamiento para cada tipo de formulario, también se deben considerar otros criterios al seleccionar un tipo de formulario: costos y métodos de impresión, el número de copias requerido, el tamaño de imagen resultante, modos de digitalización, el grado requerido de exactitud de reconocimiento, velocidad de procesamiento del formulario, apariencia general del formulario, cuidado para completar el formulario, etc. La tabla a continuación resume las ventajas y las desventajas de cada tipo de formulario.

Criterios | Formulario con omisiones |  | Formulario Raster blanco y negro |  | Formulario lineal blanco y negro
 | Desventaja | Ventaja | Desventaja | Ventaja | Desventaja | Ventaja
Complejidad de diseño |  | Fácil de diseñar utilizando el editor de gráficos. | Los editores de texto ofrecen herramientas limitadas para diseñar este tipo de formulario. El tamaño de los puntos de trama es fundamental. |  |  | Fácil de diseñar utilizando cualquier editor de gráficos.
Impresión | Difícil de imprimir mucha cantidad de formularios de buena calidad en la empresa. |  |  | Fácil de imprimir en la empresa. |  | Fácil de imprimir en la empresa.
Costos de impresión | Si se utilizan servicios de impresión profesional, los costos de impresión son mayores en relación con los formularios blanco y negro. |  |  | Si se utilizan servicios de impresión profesional, los costos de impresión son inferiores en relación con los formularios con omisiones. |  | Si se utilizan servicios de impresión profesional, los costos de impresión son inferiores en relación con los formularios con omisiones
Tamaño de imagen |  | Los tamaños del archivo de imagen son más pequeños. | Los tamaños del archivo de imagen son más grandes. |  | Los tamaños del archivo de imagen son más grandes. |
Modo de digitalización | Sólo se puede utilizar los modos especiales de digitalización (filtrado de color). |  | Rango limitado de configuraciones de brillo y contraste. |  | Rango limitado de configuraciones de brillo y contraste. |
Velocidad de procesamiento |  | Velocidad promedio de procesamiento más alta. | Mayor tiempo promedio de procesamiento, debido a que se deben eliminar las manchas de las imágenes. |  | Hay mayor probabilidad de error si los caracteres están pegados o se superponen a los bordes de campo. |
Calidad de reconocimiento |  | Calidad de reconocimiento muy alta. |  | Calidad de reconocimiento alta. | La calidad de reconocimiento depende, en gran medida, del cuidado con el que se completa el formulario. | Alta calidad de reconocimiento si el formulario se completa correctamente.
Ubicación del texto explicativo |  | El texto explicativo puede ubicarse en cualquier lugar, incluso dentro de los campos (siempre que se imprima utilizando el mismo color del fondo del formulario). | El texto explicativo y los demás elementos del formulario deben disponerse cuidadosamente en el formulario. |  | El texto explicativo y los demás elementos del formulario deben disponerse cuidadosamente en el formulario. |
Apariencia y legibilidad del formulario | Las configuraciones de fondo y del texto explicativo de bajo contraste pueden tener un efecto adverso en la legibilidad del formulario. | Estéticamente agradable | Diseño menos atractivo. Menor legibilidad. |  | Diseño menos atractivo. | Buena legibilidad.
Cuidado al completar |  | Menos sensible al texto superpuesto en los bordes del campo. | Los caracteres pequeños deben escribirse con mucho cuidado y deben ser lo suficientemente grandes para que no se eliminen como basura. | Menos sensible al texto superpuesto en los bordes del campo. | Muy sensible al texto superpuesto en los bordes del campo. |


Requisitos generales para los formularios legibles por máquina

Requisitos generales que debe cumplir un formulario para ser legible por máquina.

  • Requisitos de fondo del formulario

  • Requisitos de marca de referencia

  • Requisitos de campo de marca de verificación

  • Requisitos de marcación de texto

  • Requisitos de posicionamiento del elemento

  • Requisitos de calidad de impresión

  • Requisitos para completar el formulario


Requisitos de fondo del formulario

  1. Siempre que sea posible, utilice los formularios con omisiones o formularios con bordes de campo de trama.
  2. Al crear un formulario con omisiones, utilice un color que desaparezca durante la digitalización. Véase la lista de colores recomendados en la sección Colores recomendados para formularios con omisiones.
  3. Asegúrese siempre de que exista distancia entre el texto explicativo y los contenidos de campo. En el caso de los formularios con omisiones, es recomendable que toda la información se imprima en el mismo color del fondo del formulario (excepto donde se utiliza el texto explicativo como marca de referencia en lugar de o junto con cuadrados negros). Al imprimir la información en el mismo color del fondo, usted puede colocarla en cualquier lugar del formulario, incluso dentro de los campos del formulario.
  4. No utilice colores azules para los formularios que deben completarse a mano. El fondo azul puede fusionarse con la tinta azul que se quizá se utilice para completar los formularios, obteniendo así un efecto adverso en la calidad de reconocimiento.


Requisitos de marca de referencia

  1. Se recomienda utilizar marcas de referencia estándar en los formularios legibles por máquina (es decir, cuadrados negros, esquinas, cruces). Es recomendable que las marcas de referencia sean cinco: cuatro marcas de referencia en cada esquina del formulario (deben formar un rectángulo si se dibujan líneas imaginarias entre cada par) y un cuadrado en uno de los lados del rectángulo imaginario.
  2. Si, por alguna razón, no se puede utilizar marcas de referencia estándar, se recomienda utilizar las siguientes combinaciones como marcas de referencia:
    a) al menos dos separadores de líneas verticales y dos separadores de líneas horizontales
    b) al menos cuatro elementos de texto y un elemento identificador de formulario
    c) también son posibles otras combinaciones
  3. La distancia entre el borde de la marca de referencia y el elemento de formulario más próximo no debe ser menor a 3 mm.
  4. La distancia entre la marca de referencia y el borde de la página no debe ser menor a 8 mm.
  5. Las marcas de referencia deben imprimirse con un color oscuro (se recomienda negro) de modo que no desaparezcan durante la digitalización.

Además de los requisitos generales antes mencionados, cada tipo de marca de referencia tiene su propios requisitos específicos:

Requisitos para Cuadrados negros

Los cuadrados negros en el mismo tipo de formulario deben ser todos del mismo tamaño, es decir, entre 4x4 mm y 8x8 mm. El tamaño recomendado es de 5x5 mm. No se permiten rectángulos.

Requisitos para cruces y esquinas

  1. El tamaño de un cuadrado imaginario que podría dibujarse alrededor de una marca de referencia de este tipo debe ser de entre 4x4 y 8x8 mm. El tamaño recomendado es 5x5 mm.

  2. El tamaño de las marcas de referencia de un tipo debe ser el mismo en todo el formulario.

  3. Todos los lados de la marca de referencia deben ser del mismo tamaño.

  4. El grosor de la línea que se utiliza para marcas de referencia en el mismo formulario debe ser el mismo y debe ser entre 0,3 y 1 mm. El grosor recomendado es 0,5 mm.

Requisitos para texto (si se utiliza como marcas de referencia)

El tamaño de la fuente no debe ser menor a 7 pto (los encabezados - no menor a 14 pto).

Requisitos para separadores de líneas (si se utilizan como marcas de referencia)

El grosor de la línea no debe ser menor a 1 pto. El grosor recomendado es 1-1,5 pto.

Requisitos para código de barras (si se utilizan como marcas de referencia)

  1. El ancho del código de barras (la distancia entre la barra situada más a la izquierda y la barra situada más a la derecha) no debe ser menor a 47-50 mm.
  2. El alto del código de barras no debe ser menor a 12-15 mm (dígitos no incluidos).
  3. La orientación del código de barras (dirección de las barras) debe ser la misma que la orientación de la página (se recomienda digitalizar las páginas en la dirección de las barras).
  4. Se recomienda el formato EAN 13 del código de barras.
  5. La distancia recomendada entre el código de barras y cualquier otro elemento del formulario es de 10 mm como mínimo.


Requisitos de campo de marca de verificación

  1. Los tamaños de campo recomendados son 3,5x3,5 mm, 4x4 mm, 4,5x4,5 mm, o 5x5 mm (si se utilizan campos de marca de verificación circulares, deben caber en los cuadrados de los tamaños recomendados).
  2. El ancho de línea recomendado para los bordes del campo de marca de verificación es 0,4 mm (independientemente del tamaño del campo.


Requisitos de marcación de texto

Tamaño de los puntos de la trama:

  1. Si los bordes del campo son puntos de trama, el grosor de la línea de la trama (es decir, el tamaño de la trama) debe ser de 0,39 pto.

  2. La distancia óptima entre los puntos de la trama es de cinco veces el tamaño de los mismos.

¡Importante! Los puntos con mayor posibilidad de estar pegados son los puntos que se encuentran en las esquinas de las celdas del carácter.

Consejos útiles
Si su software no le permite especificar la distancia entre cada punto de la trama, debe seleccionar un estilo de línea que tenga puntos ubicados a una distancia prudente para evitar que se amontonen en la imagen digitalizada, y que permanezcan en la imagen después de eliminar las manchas de la misma, debido a que el sistema OCR no interpreta a los puntos grandes como basura y no los elimina de la imagen durante la eliminación de manchas.

Tamaño de la celda del carácter:

  1. El tamaño recomendado de las celdas de caracteres es de 4x5 mm; los tamaños más pequeños requieren de un mayor grado de exactitud por parte de las personas que completan el formulario, lo cual es muy difícil de lograr. No es recomendable utilizar celdas grandes de caracteres ya que fomenta el uso de letras inusualmente grandes. Lo ideal sería que el tamaño de la celda del carácter refleje el tamaño de letra promedio.
  2. La distancia entre las líneas de campo no debe ser menor a 2,5 – 3 mm, y la distancia entre dos celdas de carácter adyacentes en la misma línea no debe ser menor a 1-1,2 mm.

Mostrar celdas de carácter

Grosor de la línea:

  1. Si los bordes son líneas negras ("texto en un marco", "letras en marcos individuales", o "letras en marcos"), el grosor de la línea debe ser de 1 pto.
Mostrar bordes de líneas negras

Combinaciones:

  1. La distancia recomendada entre las muescas de una combinación es de 5 mm.
  2. La distancia entre las líneas horizontales de dos combinaciones, cuando se encuentran una debajo de la otra, no debe ser menor a 7,5 - 8 mm.
  3. El alto de la muesca debe ser de 0,9 - 1,2 mm aproximadamente.
  1. El grosor de las muescas y de las líneas horizontales debe ser de 1 pto.
  4. Si se utilizan marcos con una combinación, la distancia mínima entre los marcos debe ser de 2,5 - 3 mm.
Mostrar una combinación


Requisitos de posicionamiento del elemento

  1. Asegúrese de que los márgenes del formulario sean suficientes. De lo contrario, los elementos del formulario que se encuentran demasiado cerca de los lados del formulario pueden desaparecer durante la digitalización, perdiendo así datos.
  2. El espacio entre los elementos del formulario no debe ser menor a 2 mm.
  3. El espacio entre un campo de marca de verificación y el texto explicativo no debe ser menor a 2/3 del tamaño del campo de marca de verificación.
  4. Asegúrese de que el texto explicativo no se superponga con los bordes del campo de entrada.
  5. Si el texto explicativo se imprime en tinta negra, asegúrese de que la distancia entre el texto explicativo y los demás elementos sea, por lo menos, de 1,5-2 mm. La distancia no es tan fundamental para el texto explicativo que se imprime con la misma tinta que el fondo.


Requisitos de calidad de impresión

Al imprimir formularios en blanco, tenga en cuenta los siguientes requisitos:

  1. Los formularios deben imprimirse de manera profesional o con una impresora. Se recomienda que los formularios a color se impriman de manera profesional. De ser posible, pruebe el color del formulario en un escáner antes de iniciar la impresión.
  2. Todas las copias del formulario deben imprimirse utilizando el mismo documento de origen, debido a que la ubicación de los campos de cada formulario debe ser idéntica.
  3. El tamaño mínimo del margen (es decir, la distancia entre el borde de la página y el elemento del formulario más próximo) debe ser de, por lo menos, 8 mm (se recomienda márgenes de 12 mm).
  4. La desviación lineal permitida de los elementos del formulario es de 0,15% máximo (es decir, 0,5 mm para una página de tamaño A4).
  5. Si imprime los formularios con una impresora, la resolución no debe ser inferior a 600 dpi.

Siempre utilice la misma impresora para imprimir los formularios del mismo lote. Si no es posible, asegúrese de que se utilicen los mismos modelos de impresora.


Requisitos para completar el formulario

Lapiceras y bolígrafos

La mejor forma de completar los formularios es con cuidado, con letras mayúsculas, con una lapicera negra, con una lapicera capilar o en gel (también puede ser azul oscuro o violeta). No es recomendable usar lapiceras de punta blanda o rotuladores ya que los caracteres son gruesos, causando así problemas de reconocimiento. El reconocimiento es aún peor cuando los formularios se completan con lápiz o con tinta clara.

Tamaño y estilo de letra

Para obtener mejores resultados del reconocimiento, los formularios deben completarse con letra imprenta mayúscula. Las letras deben cubrir toda la celda del carácter sin superponerse a los bordes de las celdas.

Si las celdas de los caracteres están marcadas visualmente en los formularios (es decir, se utilizan los siguientes tipos de marcación de texto: letras en marcos, letras en marcos individuales), es poco probable que la persona que completa el formulario junte las letras.

Los siguientes tipos de marcación de texto presentan grandes problemas en el reconocimiento: texto en marco con un código de combinación, letras en una combinación. Aquí sólo está predeterminada el ancho de la celda del carácter, y, al no haber bordes laterales, es posible que las letras estén pegadas. En el caso de la combinación sin marco, las letras pueden hacerse muy grandes o muy pequeñas.

Si se utiliza el texto dentro de un marco o el texto sobre una línea, no existe restricción evidente respecto del ancho de las celdas de caracteres. Las letras pueden estar pegadas, lo cual tiene un efecto adverso en la calidad de reconocimiento. En el caso del texto sobre una línea, no existen restricciones respecto del alto del carácter. Por consiguiente, este tipo de marcación no es recomendable para formularios que requieren de un alto grado de exactitud de reconocimiento.

Otro requisito importante es que las letras no se superpongan a los bordes del campo. Esto no es tan importante para los formularios con omisiones o los formularios con cuadrícula, debido a que los bordes del campo desaparecen cuando se digitalizan y se eliminan las manchas. Sin embargo, si las letras se superponen a los bordes del campo en los formularios lineales blanco y negro, puede haber una importante disminución en la calidad de reconocimiento.

Ejemplo

Para que el formulario se complete correctamente, se recomienda incluir una nota similar a la que se muestra a continuación.


Colores recomendados para formularios con omisión

La tabla que se muestra a continuación muestra los ejemplos de colores con omisión y sus números Pantone correspondientes. Estos colores de fondo desaparecen al digitalizar los formularios:

  • utilizando cualquier escáner;
    • Mostrar la tabla de lámpara blanca
  • utilizando un escáner a color con software de filtrado de color rojo o utilizando un escáner sin color con una lámpara roja o un filtro rojo.
    • Mostrar la tabla de lámpara roja


Teclas de acceso rápido

Esta sección contiene una lista de las teclas de acceso rápido que se utilizan en varias ventanas de programas. El uso de teclas de acceso rápido puede ahorrarle tiempo y hace que el uso del programa sea más fácil y cómodo.

Teclas de acceso rápido en la ventana principal
Teclas de acceso rápido en la ventana del editor de plantillas
Teclas de acceso rápido en la ventana del verificador de grupo
Teclas de acceso rápido en la ventana del verificador de campos


Teclas de acceso rápido de la ventana principal del programa

Menú | Comando | Teclas de acceso rápido
Archivo | Nuevo proyecto… | Ctrl+Shift+N
 | Abrir proyecto… | Ctrl+Shift+O
 | Guardar | Ctrl+S
 | Cargar imágenes… | Ctrl+O
 | Digitalizar imágenes… | Ctrl+K
 | Importar imágenes… | Ctrl+I
 | Exportar… | Ctrl+U
 | Exportar a Archivo… | Alt+Shift+S
 | Exportar a Base de datos… | Alt+Shift+D
 | Salir | Alt+F4
Edición | Deshacer | Ctrl+Z
 | Rehacer | Ctrl+Y
 | Cortar | Ctrl+X
 | Copiar | Ctrl+C
 | Pegar | Ctrl+V
 | Eliminar | Supr
 | Seleccionar todo | Ctrl+A
 | Buscar… | Ctrl+F
 | Buscar siguiente | F3
 | Imagen > Refinar | Ctrl+Alt+K
 | Imagen > Invertir | Ctrl+Alt+V
 | Imagen > Girar 90° a la derecha | Ctrl+W
 | Imagen > Girar 90° a la izquierda | Ctrl+Shift+W
Ver | Mostrar Detalles del documento | Alt+1
 | Mostrar documentos como Miniaturas | Alt+2
 | Mostrar la ventana de documentos en Modo de imagen | Ctrl+1
 | Mostrar la ventana de documentos en Modo de datos | Ctrl+2
 | Escala de imagen de página > Acercar | Ctrl+Num+
 | Escala de imagen de página > Alejar | Ctrl+Num-
 | Pantalla completa | F11
 | Abrir diálogo de propiedades del objeto resaltado | Alt+Intro
Importación y reconocimiento | Importar imágenes… | Ctrl+I
 | Analizar | Ctrl+E
 | Asociar plantilla… | Alt+Shift+E
 | Reconocer | Ctrl+R
Verificación | Ejecutar verificación… | F7
 | Siguiente elemento para verificar | F4
 | Elemento anterior para verificar | Mayús+F4
 | Siguiente error de ensamblaje | F10
 | Error de ensamblaje anterior | Mayús+F10
 | Siguiente carácter incierto | F8
 | Carácter incierto anterior | Mayús+F8
 | Siguiente error de regla | F6
 | Error de regla anterior | Mayús+F6
Proyecto | Lista de lotes de trabajo | Ctrl+B
 | Lista de lotes de prueba | Ctrl+Mayús+B
 | Plantillas de documento… | Ctrl+T
 | Perfiles de importación de imágenes… | Ctrl+Mayús+I
Servicio | Volver a analizar | Ctrl+Alt+E
 | Volver a reconocer | Ctrl+Alt+R
 | Volver a comprobar reglas | Ctrl+F6
Ayuda | Mostrar Ayuda | F1
Comandos generales | Abrir ventana del documento (si hay una página o un documento resaltado) | Intro


Teclas de acceso rápido en la ventana del editor de plantillas

Menú | Comando | Teclas de acceso rápido
Plantilla | Agregar página… | Ctrl+P
 | Agregar sección del documento… | Ctrl+Alt+S
 | Crear campo de Texto | Alt+Shift+T
 | Crear campo de Marca de verificación | Alt+Shift+C
 | Crear campo de Grupo de marcas de verificación | Alt+Shift+M
 | Crear campo de Código de barras | Alt+Shift+B
 | Crear Imagen | Alt+Shift+P
 | Crear campo de Tabla | Alt+Shift+L
 | Crear campo de Agrupar | Alt+Shift+G
 | Propiedades de la plantilla de documento… | Ctrl+T
 | Guardar | Ctrl+S
 | Cerrar | Alt+F4
Edición | Deshacer | Ctrl+Z
 | Rehacer | Ctrl+Y
 | Cortar | Ctrl+X
 | Copiar | Ctrl+C
 | Pegar | Ctrl+V
 | Eliminar | Supr
 | Eliminar región | Shift+Del
 | Seleccionar todo | Ctrl+A
 | Seleccionar por tipo… | Ctrl+Shift+A
 | Agrupar | Ctrl+G
 | Desagrupar | Ctrl+Shift+G
 | Imagen > Refinar | Ctrl+Alt+K
 | Imagen > Invertir | Ctrl+Alt+V
 | Imagen > Girar 90° a la derecha | Ctrl+W
 | Imagen > Girar 90° a la izquierda | Ctrl+Shift+W
Ver | Cambiar al modo de elementos estáticos | Ctrl+1
 | Cambiar al modo de marcación de campos | Ctrl+2
 | Abrir/Cerrar la ventana de estructura de documentos | Alt+F1
 | Cambia la ventana de estructura de documentos al modo de campos. | Alt+1
 | Cambia la ventana de estructura de documentos al modo de páginas. | Alt+2
 | Abrir/Cerrar la ventana Formulario de datos | Alt+F2
 | Escala de imagen de página > Acercar | Ctrl+Num+
 | Escala de imagen de página > Alejar | Ctrl+Num-
 | Abrir diálogo de propiedades del objeto resaltado | Alt+Intro
Servicio | Detectar objetos automáticamente… | Ctrl+D
 | Comprobar plantilla de documento | F9
 | Asociar sección | Ctrl+E
Ayuda | Mostrar ayuda | F1

Ventana de marcación de imágenes

Comando | Teclas de acceso rápido
Activar herramienta de selección | Esc
Detección automática de objetos | Ctrl+Shift+D
Crear delimitador | A
Crear separador | S
Crear texto del delimitador | X
Crear código de barras para el delimitador | D
Crear campo de texto | T
Crear marca de verificación | C
Crear grupo de marcas de verificación | M
Crear código de barras | B
Crear imagen | P
Crear tabla | L
Crear grupo de campos | G
Crear región para campo sin región | R
Crear región no reconocible | O
Crear columna de la tabla | U
Agregar separador a la tabla | F
Eliminar separador de tabla | E
Ajustar región | Ctrl+Alt+A
Sugerir nombre | Ctrl+Alt+N
Obtener nombre de la imagen… | Ctrl+Alt+I
Detectar tipo de marcado | Ctrl+Alt+D

Ventana de estructura de documentos

Comando | Teclas de acceso rápido
Mostrar imagen del campo detectado | Intro
Cambiar el nombre al campo detectado | F2
Si un campo de la tabla está resaltado: |
Agregar columna con texto | Alt+Shift+T
Agregar columna con marcas de verificación | Alt+Shift+C
Agregar columna con códigos de barras | Alt+Mayús+B
Agregar columna con imágenes | Alt+Mayús+P
Si un grupo de marcas de verificación está resaltado: |
Agregar al grupo de marcas de verificación | Alt+Mayús+C


Teclas de acceso rápido en la ventana del verificador de grupo

Menú | Comando | Teclas de acceso rápido
Verificación | Confirmar todo | Intro
 | Posponer todo | Ctrl+Intro
 | Alternar | Espacio
 | Página siguiente | Avance de página
 | Página anterior | Retroceso de página
 | Cerrar | Alt+F4
Edición | Deshacer | Ctrl+Z
 | Rehacer | Ctrl+Y
 | Seleccionar todo | Ctrl+A
Ver | Imagen del campo > Mostrar imagen de campo | Ctrl+I
 | Imagen de campo > En la parte superior | Alt+1
 | Imagen de campo > En la parte inferior | Alt+2
 | Imagen de campo > Escala de la imagen > Acercar | Ctrl+Num+
 | Imagen de campo > Escala de la imagen > Alejar | Ctrl+Num-
 | Mostrar imagen de caracteres | F2
 | Pantalla completa | F11
Ayuda | Mostrar Ayuda | F1
Menú de símbolos locales | Mostrar imagen del carácter | F2
 | Confirmar | Ctrl+E
 | Posponer | Ctrl+R
 | Restablecer | Esc


Teclas de acceso rápido en la ventana del verificador de campos

Menú | Comando | Teclas de acceso rápido
Verificación | Confirmar campo | Intro
 | Postergar | Ctrl+Intro
 | Siguiente carácter incierto | F4
 | Carácter incierto anterior | Mayús+F4
 | Campo siguiente | Avance de página
 | Campo anterior | Retroceso de página
 | Cerrar | Alt+F4
Edición | Deshacer | Ctrl+Z
 | Rehacer | Ctrl+Y
 | Cortar | Ctrl+X
 | Copiar | Ctrl+C
 | Pegar | Ctrl+V
 | Eliminar | Supr
 | Seleccionar todo | Ctrl+A
 | Insertar salto de línea | Mayús+Intro
 | Combinar caracteres | Ctrl+M
Ver | Datos del campo > Texto reconocido | Alt+F1
 | Datos del campo > Corte de imágenes de caracteres | Alt+F2
 | Imagen de campo > Mostrar imagen de campo | Ctrl+I
 | Imagen de campo > En la parte superior | Alt+1
 | Imagen de campo > En la parte inferior | Alt+2
 | Imagen de campo > Escala de la imagen > Acercar | Ctrl+Num+
 | Imagen de campo > Escala de la imagen > Alejar | Ctrl+Num-
 | Mostrar imagen del carácter | F2
 | Pantalla completa | F11
Ayuda | Mostrar ayuda | F1


Uso de scripts en FlexiCapture 8.0

Esta sección describe cómo utilizar scripts para crear reglas personalizadas, para ejecutar operaciones de exportación y para crear controladores de exportación en FlexiCapture 8.0.

Se admiten dos idiomas de scripting: JScript® y VBScript.

Especificaciones de uso

En VBSript, es obligatorio utilizar la palabra clave Me al hacer referencia a los métodos y a los campos de un objeto actual (la alternativa de "this" en C++ y Java). Un objeto actual es una unidad de documento verificable (una unidad que contiene una regla) para las reglas y un documento exportable para las operaciones de exportación.

Me.CheckSucceeded = False

En la misma situación en JScript, se puede omitir "this":

this.CheckSucceeded = false; CheckSucceeded = false;

Durante el tiempo de ejecución del script, se envían errores como "No se encontró el método ni la propiedad":

ChecckSucceeded = false; // error de tiempo de ejecución

Los errores de sintaxis se envían cuando se guarda un script:

CheckSucceeded +++ false; // error de sintaxis

Funciones personalizadas

El editor de scripts permite que los usuarios creen sus propias funciones y procedimientos y, luego, los invoquen desde el código de las reglas o desde el código de exportación.

Las funciones personalizadas se pueden crear en uno de los módulos globales, ya sea en el módulo de exportación o en el módulo de reglas. Puede seleccionar el módulo deseado en el editor de scripts.

Todas las funciones en un módulo deben escribirse en el mismo idioma. El código básico de una regla o exportación puede estar escrito en un idioma diferente del que se utiliza en el módulo global correspondiente.

Por ejemplo, desde el código de una regla escrita en VBScript, es posible invocar una función del módulo global escrito en JScript.

Las funciones solo pueden invocarse desde "sus propios" módulos. Esto significa que, desde el código de las reglas, solo se pueden invocar funciones del módulo de reglas global y, desde el código de exportación, solo se pueden invocar funciones del módulo de reglas global. De lo contrario, se producirá un error durante la ejecución.

Las funciones son las siguientes:

[VBScript]

resultado = Rules.SomeFunction( param1, param2 ... )

Export.SomeFunction param1, param2 ...

[JScript]

resultado = Rules.SomeFunction( param1, param2 ... );

Export.SomeFunction( param1, param2 ... );

Tiempo de espera de ejecución de scripts

Los tiempos de espera predeterminados son de 10 segundos para las reglas y de 1 minuto para la exportación.

Para cambiar los tiempos de espera predeterminados, cambie los valores correspondientes en el registro.

Para las reglas:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\DefaultScriptTimeout

Para la exportación:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\ExportScriptTimeout

El valor de un tiempo de espera en el registro se especifica en milisegundos. Si un script requiere más tiempo para ejecutarse que el tiempo de espera que se especificó, este se cerrará. Para las reglas, se muestra como resultado el mensaje de error "Tiempo de espera de ejecución de scripts". Para la exportación, aparece un mensaje similar en la columna Notas de procesamiento de la ventana del lote.

Uso de scripts para crear reglas
Uso de scripts para describir la exportación
Migración de las reglas y la exportación de FormReader 6.5 a los scripts de FlexiCapture 8.0 Professional


Uso de scripts para crear reglas

Las reglas basadas en scripts (ScriptRule) permiten a los usuarios crear algoritmos complejos personalizados para la validación y la normalización de documentos mediante el uso de los idiomas de scripting estándar JScript® y VBScript.

Nota: Es posible que algunos scripts creados con la primera versión de ABBYY FlexiCapture no funcionen con el segundo lanzamiento. Esto ocurre porque los valores del campo se tipificaron en el segundo lanzamiento, mientras que en el primer lanzamiento se utilizaron valores de texto. Para solucionar este problema, es posible: a) cambiar la propiedad de Valor a Texto para los scripts que funcionan con el texto de un campo o b) cambiar el uso de la propiedad Valor para que se ajuste a su descripción actual. Consulte las propiedades del objeto Campo.

Modelo de objeto

Una regla debería considerarse un método de una unidad de documento validada, es decir, la referencia "this" o "Me" se refiere al objeto [Unidad de documento validada] en el que se aplica actualmente la regla.

Una regla puede realizar la validación de documentos según los valores de uno o más campos. En el caso de que el resultado sea un error, es necesario establecer un indicador de error y, según sea necesario, especificar la descripción del error, el campo Enfoque y las variantes de reemplazo propuestas. Una regla también puede marcar cierto campo como reconocido con certeza.

Una regla puede realizar la normalización de documentos mediante el cambio de los valores del campo a una apariencia normal o mediante la adición de información (por ejemplo, la fecha del último procesamiento).

Unidad de documento validada

Propiedades:

Nombre | Tipo | Acceso | Descripción
CheckSucceeded | Booleano | Lectura y escritura | Indicador de error. Verdadero: la regla no tiene ningún error; falso: la regla tiene un error.
ErrorMessage | cadena | Lectura y escritura | Mensaje de error.
FocusedField | [Campo] | Lectura y escritura | Campo Enfoque.
Field("AliasName") [Campo] Solo lectura Campo con el alias AliasName.

Un alias es un nombre especial para un campo que se utiliza al acceder al campo desde el código de una regla. Por lo tanto, el cambio de nombre del campo no afectará el uso del campo en el código de la regla.

Los alias también permiten utilizar campos con nombres idénticos en una regla (por ejemplo, campos con nombres idénticos de diferentes secciones).

Un alias puede ser igual al nombre del campo o diferente.

Cuando agrega un campo a una regla, se genera un alias automáticamente para esta; pero puede modificar o cambiar cualquier alias que genera el programa.

Fields | [Colección de campos] | Solo lectura | Colección de campos que participa de la regla.
Document | [Documento] | Solo lectura | Documento que contiene una unidad validada.

Cuando la unidad de documento validada es un campo, es compatible con todas las propiedades y métodos que corresponden al objeto [Campo]. Si la unidad validada no es un campo, no es posible consultar esas propiedades y métodos, ya que se producirá un error.

Campo

Propiedades:

Nombre | Tipo | Acceso | Descripción
Value Variante Lectura y escritura Valor tipificado del campo.

En el campo de los campos numéricos, contiene un número de coma flotante.

En el caso de los campos "Fecha" y "Hora", contiene el valor de la fecha (VT_DATE).

En el caso de los campos "Moneda", contiene el valor total (VT_CY).

En el caso de las marcas de verificación, contiene un valor booleano. Al asignar valores a una marca de verificación, puede utilizar los valores booleanos de verdadero y falso, y los valores de texto "Verdadero" y "Falso" (distinguen entre mayúsculas y minúsculas).
El valor de un grupo de marcas de verificación es una lista de los nombres de las marcas de verificación seleccionadas separados por punto y coma (;). Si no se seleccionaron marcas de verificación, la cadena estará vacía. Para cambiar el valor de un grupo de marcas de verificación, asigne el valor de "verdadero" a las marcas de verificación que necesita seleccionar y el de "falso" a las que no necesita seleccionar. Al mismo tiempo, deben incluirse todas esas marcas de verificación en la regla.
Para los grupos, las tablas y las imágenes: cadena vacía.
No se pueden asignar valores a los grupos, a los grupos de marcas de verificación ni a las tablas. Si intenta asignar un valor a esos tipos de campo, se producirá un error.

Text cadena Solo lectura Valor de texto de un campo. Coincide con el Valor para todos los tipos de campo, excepto las marcas de verificación.
En el caso de las marcas de verificación, el valor de esta propiedad se determina según las propiedades del campo seleccionadas en la ficha Tipo de datos.
Importante: El valor de la propiedad Texto no cambia cuando se aplica la regla, es decir, el cambio de la propiedad Valor en el código de la regla no cambia simultáneamente la propiedad Texto.
En el siguiente ejemplo, los valores de oldText y newText serán los mismos:

Dimensión oldText, newText
oldText = me.Field("FieldName").Text
me.Field("FieldName").Value = newValue
newText = me.Field("FieldName").Text

Nombre | cadena | Solo lectura | Nombre del campo
IsVerified Booleano Lectura y escritura Indicador que muestra si se verificó o no el campo. Un campo marcado como verificado se ignorará durante la verificación y durante el recuento de caracteres para el que es necesaria la verificación.

Esta propiedad está configurada en verdadero si el usuario confirmó el campo durante la verificación o si alguna regla estableció el valor de la propiedad en verdadero.

De lo contrario, el valor de la propiedad es falso.

IsCertain Booleano Lectura y escritura Indicador de certeza del campo. Un campo marcado como reconocido con certeza se ignorará durante la verificación y el cálculo de los caracteres que necesitan verificarse.

Esta propiedad es obsoleta y solo se conservó para que sea compatible con versiones anteriores. En su lugar, utilice la propiedad IsVerified.

IsMatched | Booleano | Solo lectura | Indicador que muestra si un campo puede asociarse o no.
Items | [Colección de campos] | Solo lectura | En el caso de un campo múltiple, una colección de sus instancias. Si un campo no es múltiple: 0.

Métodos:

Nombre | Parámetros | Descripción
Suggest( text ) | Variante | Agrega una sugerencia con un valor de campo recomendado. Para diferentes variantes, invoque el método, de manera secuencial, la cantidad de veces que sea necesario. El valor de la sugerencia que agregue debe coincidir con el tipo de campo (por ejemplo: en el caso de los campos numéricos, debe ser un número; en el caso de los campos "Fecha" y "Hora", una fecha, etc.).

Colección de campos

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de campos en una colección.
Item(index) | [Campo] | Solo lectura | Campo Índice. El índice puede tener valores de 0 a Recuento: 1.

Documento

Propiedades:

Nombre | Tipo | Acceso | Descripción
Pages | [Recopilación de páginas] | Sólo lectura | Recopilación de páginas del documento.

Métodos:

Nombre | Parámetros | Descripción
Property( name ) | name: nombre de la propiedad. | Muestra como resultado el valor de la propiedad solicitada. Tipo de valor que muestra como resultado: variante.

Propiedades del documento que pueden configurarse mediante el método Propiedad (las propiedades del documento que obtiene este método son de solo lectura):

Valor | Tipo | Descripción
"TemplateName" | Cadena | Nombre de la plantilla
"TotalSymbolsCount" | Número entero | Cantidad de caracteres
"UncertainSymbolsCount" | Número entero | Cantidad de caracteres reconocidos sin certeza
"RecognizedSymbolsCount" | Número entero | Cantidad de caracteres reconocidos
"Comment" | Cadena | Comentario
"Created" | Fecha | Creado el
"CreatedBy" | Cadena | Creado por
"Recognized" | Fecha | Reconocido el
"RecognizedBy" | Cadena | Reconocido por
"Modified" | Fecha | Última modificación
"ModifiedBy" | Cadena | Modificado por
"ProcessingErrors" | Cadena | Errores
"ProcessingWarnings" | Cadena | Advertencias

Collection of pages

Properties:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Sólo lectura | Cantidad de páginas en la recopilación.
Item(index) | [Página] | Sólo lectura | La página con índice. El índice utiliza valores de 0 a 1.

Página

Proporciona información acerca de las páginas del documento que están siendo validadas.

Propiedades:

Nombre | Tipo | Acceso | Descripción
ImageSourceType | Cadena | Sólo lectura | El tipo de origen de la imagen. Puede asumir los valores "Archivo" o "Escáner".
ImageSource | Cadena | Sólo lectura | Origen de la imagen. En el caso del archivo, este es el nombre del archivo con la ruta completa. En el caso del escáner, este es el nombre del escáner.
ImageSourcePageNumber | Número entero | Sólo lectura | El número de la página dentro del origen de la imagen. Los números de las páginas comienzan con 0. Sólo para archivos.

Scripts de muestra para la creación de reglas


Scripts de muestra para la creación de reglas personalizadas

Regla de automatización

Este ejemplo muestra la comprobación de datos de una tabla. La regla comprueba que los datos de la tabla se asocien con el valor en el campo resultante. La tabla contiene columnas con los precios y las cantidades de ciertos productos. La regla se escribió al nivel de una sección que contiene la tabla y el campo resultante.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("coste"), me.FIELD("número"), _

me.FIELD("Resultado"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("coste"), Field("número"),

Field("Resultado"), this );

Código de un componente ActiveX

El código que aquí se proporciona es un código de clase CheckDocdel proyecto AutomationRule, que se utiliza en los scripts antes mencionados.

Option Explicit

' Comprueba que los datos de la tabla se asocian con el resultado

' columna1: columna de precios

' columna2: columna de cantidades

' resultField: campo resultante (<Total> o equivalente)

' docObj: nodo del documento que se está comprobando

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' total de los datos de la tabla

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' precisión de la comparación: resultado redondeado al segundo dígito después del punto decimal

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Los datos de la tabla no se asocian con el valor resultante"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Buscar en la lista de variantes

El código de la regla que se proporciona a continuación comprueba que el valor del campo se asocie con uno de los valores de la lista. Si no se asocia, aparece un indicador de error de regla y el campo recibe una lista de valores sugeridos. Según el resultado de la comprobación, el campo se marca como reconocido con certeza o sin ella.

[VBScript]

'recuerde el valor del campo

Dim fieldValue

fieldValue = me.Field("Campo6").Value

'cree la lista de valores para comprobar

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

'compruebe que el valor del campo se asocie con los valores de la lista

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

'según el resultado de la comprobación, establezca el estado de certeza correspondiente para el campo

me.Field("Campo6").IsCertain = success

'complete la lista de sugerencias para el campo. Una sugerencia puede ser cualquiera de los

'valores adecuados

if success = false then

for i = 0 to 4

me.Field("Campo6").Suggest( list(i) )

next

end if

'coloque un indicador de error

me.CheckSucceeded = success

[JScript]

// recuerde el valor del campo

var fieldValue = Field("Campo6").Value;

// cree la lista de valores para comprobar

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// asocie el valor del campo con los valores de la lista

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// según el resultado de la comprobación, establezca un estado de certeza correspondiente para el campo

Field("Campo6").IsCertain = success;

// complete la lista de sugerencias para el campo. Una sugerencia puede ser cualquiera de los

// valores adecuados

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Campo6").Suggest( list[i] );

}

}

// coloque un indicador de error

CheckSucceeded = success;

Comprobación de asociación de campos

El código de la regla que se proporciona a continuación comprueba que se haya asociado el campo que se comprobó.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "El campo InvoiceNumber no está asociado"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "El campo InvoiceNumber no está asociado";

}

Comprobación de marcas de verificación

El código de regla que se proporciona a continuación comprueba que se haya seleccionado o no la marca de verificación.

[VBScript]

if me.Field("Estado de la página").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "No se comprobó el estado de la página"

end if

[JScript]

if( Field("Estado de la página").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "No se comprobó el estado de la página";

}

Comprobación del grupo de marcas de verificación

El código de regla que se proporciona a continuación repite todas las marcas de verificación en el grupo y, si no se seleccionó ninguna, selecciona la primera. La regla está escrita para el nivel del grupo de marcas de verificación. Todas las marcas de verificación en el grupo se agregaron a la lista de campos que se incluyeron a la regla. Para la marca de verificación predeterminada (la primera), se deshabilitó el indicador Readonly. Si no hay marcas de verificación en el grupo, se habilita un indicador de error de regla.

Este código de muestra repite todos los campos que se incluyen en la regla. Debido a que los nombres de los campos no se especifican en el código, este código puede utilizarse para cualquier grupo de marcas de verificación.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "No hay marcas de verificación en el grupo"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "No hay marcas de verificación en el grupo";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}


Uso de scripts para describir la exportación

Modelo de objeto

Este modelo se utiliza tanto en scripts de exportación como en scripts de controlador de exportación.

Un controlador de exportación es un script especial que se ejecuta cuando finaliza la exportación (siempre que esté seleccionada la opción Ejecutar script después de la exportación de la ficha Exportar en el cuadro de diálogo de las propiedades del proyecto y que el cuerpo del script no esté vacío).

La exportación debe considerarse un método de un documento exportable, es decir, la referencia "this" o "Me" hace referencia al objeto [documento exportable] que se está exportando en ese momento.

En un controlador de exportación, el puntero this o Me apunta a un objeto de tipo [resultados de la exportación].

No es posible modificar los valores del campo durante la exportación.

Documento exportable

Propiedades:

Nombre | Tipo | Acceso | Descripción
IsAssembled | Booleano | Solo lectura | El indicador muestra si se ensambló o no el documento.
IsVerified | Booleano | Solo lectura | El indicador muestra si se verificó o no el documento.
IsExported | Booleano | Solo lectura | El indicador muestra si se exportó o no el documento.
TemplateName | cadena | Solo lectura | Nombre de la plantilla de documento.
ProcessingErrors | cadena | Solo lectura | Mensaje de error de procesamiento.
ProcessingWarnings | cadena | Solo lectura | Sugerencias y advertencias que se muestran durante el procesamiento.
TotalSymbolsCount | Número entero | Solo lectura | Cantidad total de caracteres (además de los caracteres reconocidos, también incluye los caracteres agregados por el usuario y por las reglas).
RecognizedSymbolsCount | Número entero | Solo lectura | Cantidad de caracteres reconocidos
UncertainSymbolsCount | Número entero | Solo lectura | Cantidad de caracteres reconocidos sin certeza
Id | cadena | Solo lectura | Identificador del documento.
BatchName | cadena | Solo lectura | Nombre del lote.
Field(FieldName) | [Unidad de documento] | Solo lectura | Unidad con el nombre FieldName. Puede dar como resultado un campo o una sección. FieldName es el nombre de una unidad junto con la ruta completa, que comienza con la sección. Por ejemplo: "Sección 1\Grupo\Campo 1". Importante: Si alguno de los componentes de la ruta al campo es un componente múltiple, debe proporcionar el índice de ese componente. Por ejemplo, para un grupo múltiple, la ruta anterior debería ser la siguiente: "Sección 1\Grupo[índice]\Campo 1". El índice se atribuye un valor de 0 a Recuento: 1, donde Recuento es la cantidad de instancias del componente múltiple.
Children | [Colección de unidades de documento] | Solo lectura | Colección de secciones del documento.
Pages | [Colección de páginas] | Solo lectura | Colección de páginas del documento.
IndexedItemValue | Variante | Sólo lectura. | El valor del campo de índice con el nombre especificado: IndexedItemValue(fieldName).
Action | [Resultado de la operación] | Solo lectura | Objeto especial que contiene información sobre los resultados de la operación de exportación. El programa escribe información en este objeto durante la exportación. En caso de ser necesario, el controlador que se ejecuta después de la exportación puede utilizar esta información.

Métodos:

Nombre | Parámetros | Descripción
SaveAs (filename, imageSaveOptions) | fileName: nombre del archivo. imageSaveOptions: parámetros de guardamiento de imágenes (opcional). | Guarda las imágenes de todas las páginas del documento en un archivo.

Unidad de documento

Una unidad de documento es una sección o un campo.

Propiedades:

Nombre | Tipo | Acceso | Descripción
Value Variante Solo lectura Valor tipificado de la unidad.

En el caso de los campos numéricos, introduce un número de coma flotante.

En el caso de los campos "Fecha" y "Hora", introduce el valor de la fecha (VT_DATE).

En el caso de los campos "Moneda", introduce el valor total (VT_CY).

En el caso de las marcas de verificación, introduce un valor booleano.

Valor de la unidad. Siempre texto.
Introduce los valores "Sí" y "No" para las marcas de verificación. En el caso de los grupos de marcas de verificación, muestra como resultado una lista de las marcas de verificación seleccionadas o una cadena vacía donde no hay marcas de verificación seleccionadas. Muestra como resultado una cadena vacía para un imagen.
Si una unidad no tiene ningún valor, no muestra ningún resultado. Antes de tratar de leer el valor de una unidad, asegúrese siempre de que no sea igual a cero (consulte las muestras de script). Si intenta leer un valor que equivalga a cero, se producirá un error.
Por ejemplo, el valor equivale a cero en las secciones y en los campos Tabla y Grupo.

El valor también puede ser cero si el contenido del campo (texto reconocido o texto escrito por el usuario) no coincide con el tipo de campo.

Text cadena Solo lectura

Valor de texto de la unidad.

En el caso de las marcas de verificación, muestra como resultado los valores Sí y No.

En el caso de los grupos de marcas de verificación, muestra como resultado la lista de campos Marca de verificación seleccionados o una cadena vacía, si no se seleccionó ninguno de los campos Marca de verificación.

Muestra como resultado una cadena vacía para las unidades vacías que no tienen ningún valor (por ejemplo, un imagen, un grupo o una sección).
Name | cadena | Solo lectura | Nombre de la unidad.
IsExportable | Booleano | Solo lectura | Muestra si la unidad debe exportarse.
IsIndexed | Booleano | Sólo lectura | Especifica si la unidad es un campo de índice.
SuspiciousSymbols cadena Solo lectura

Una cadena formada de unos y ceros, donde los unos corresponden a caracteres inciertos.

En el caso de las marcas de verificación, se muestra como resultado una cadena que contiene un solo símbolo.

En el caso de las unidades que no tienen ningún valor, se muestra como resultado una cadena vacía.
Children [Colección de unidades de documento] Solo lectura Colección de unidades subordinadas. Si no hay unidades subordinadas: 0.
Por ejemplo, un grupo, un grupo de marcas de verificación y una fila de una tabla tienen unidades subordinadas.
Items | [Colección de unidades de documento] | Solo lectura | En el caso de una unidad múltiple: una colección de sus instancias. Si una unidad no es múltiple: 0.
Regions | [Colección de regiones] | Solo lectura | Colección de regiones del campo.

Imagen

Esta es un imagen que se puede guardar en un archivo del disco.

Métodos:

Nombre | Parámetros | Descripción
SaveAs (filename, imageSaveOptions) | fileName: nombre del archivo. imageSaveOptions: parámetros de guardamiento de imágenes (opcional). | Guarda la imagen del campo en un archivo.

Colección de unidades de documento

Una colección de unidades de documento es una colección de campos o secciones.

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de unidades en una colección.
Item(index) | [Unidad] | Solo lectura | Instancia de la unidad. El índice puede tener valores de 0 a Recuento: 1.

Colección de páginas

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de páginas en una colección.
Item(index) | [Página] | Solo lectura | Página con índice. El índice puede tener valores de 0 a Recuento: 1.

Página

Propiedades:

Nombre | Tipo | Acceso | Descripción
TemplateName | cadena | Solo lectura | Nombre de la sección.
ImageSourceType | cadena | Solo lectura | Tipo de origen de la imagen. Puede atribuirse el valor de Archivo o Escáner.
ImageSource | cadena | Solo lectura | Origen de la imagen. En el caso de un archivo, es el nombre del archivo con una ruta completa al archivo. En el caso de un escáner, es el nombre del escáner.
ImageSourcePageNumber | Número entero | Sólo lectura | El número de la página dentro del origen de la imagen. Los números de las páginas comienzan con 0. Sólo para archivos.

Métodos:

Nombre | Parámetros | Descripción
SaveAs (filename, imageSaveOptions) | fileName: nombre del archivo. imageSaveOptions: opciones de guardamiento de imágenes (opcional). | Guardar imagen de página.

Colección de regiones

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de regiones en la colección.
Item(index) | [Región] | Solo lectura | Región que tiene el índice índex. El índice se atribuye valores de 0 a Recuento: 1.

Región

Propiedades:

Nombre | Tipo | Acceso | Descripción
PageIndex | Número entero | Solo lectura | Índice de la página en la que se ubica la región determinada.
Rects | [Colección de rectángulos] | Solo lectura | Colección de rectángulos a partir de la que se crea la región. En el caso de una región rectangular, la colección contiene solo un rectángulo.
SurroundingRect | [Rectángulo] | Solo lectura | Rectángulo que encierra la región.
Picture | [Imagen] | Solo lectura | Imagen para la región determinada.

Colección de rectángulos

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de rectángulos en la colección.
Item(index) | [rectángulo] | Solo lectura | Rectángulo que tiene el índice index. A index se le atribuyen valores de 0 a Recuento: 1.

Rectángulo

Propiedades:

Nombre | Tipo | Acceso | Descripción
Left | Número entero | Solo lectura | Coordenada izquierda del rectángulo en la página.
Top | Número entero | Solo lectura | Coordenada superior del rectángulo en la página.
Right | Número entero | Solo lectura | Coordenada derecha del rectángulo en la página.
Bottom | Número entero | Solo lectura | Coordenada inferior del rectángulo en la página.

ExportTools

Objeto global que se utiliza para obtener un objeto [Opciones de guardamiento de imágenes].

Métodos:

Nombre | Parámetros | Descripción
NewImageSavingOptions |  | Crea un objeto [Opciones de guardamiento de imágenes].

Opciones de guardamiento de imágenes

Opciones de guardamiento de imágenes de páginas.

Propiedades:

Nombre | Tipo | Acceso | Descripción
Format | cadena | Lectura y escritura | Formato de la imagen. Puede adoptar uno de estos valores: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf", "pdf-s", "pdf-a", "pdf-a-s" o "pdf-s-a". No distingue entre mayúsculas y minúsculas.
ColorType | cadena | Lectura y escritura | Tipo de esquema de color que se utiliza. Puede adoptar uno de estos valores: "FullColor", "GrayScale" y "BlackAndWhite". No distingue entre mayúsculas y minúsculas.
Resolution | Número entero | Lectura y escritura | Resolución de la imagen en ppp
ShouldOverwrite | Booleano | Lectura y escritura | Este indicador muestra si se debe escribir sobre el archivo existente al guardarlo. Si este indicador está configurado en false, la invocación del método SaveAs provocará un error en el caso de que ya existiera un archivo con el mismo nombre.

Resultados de la operación

Contiene información sobre los resultados de la operación de exportación.

Propiedades:

Nombre | Tipo | Acceso | Descripción
Succeeded | Booleano | Lectura y escritura | Contiene true (verdadero) si la exportación se realizó correctamente; de lo contrario, contiene false (falso).
ErrorMessage | cadena | Lectura y escritura | Mensaje de error sobre un error que se produjo durante la exportación.
Result | cadena | Lectura y escritura | Descripción formal del resultado. En el caso de la exportación a un archivo, contiene el nombre del archivo junto con una ruta completa al archivo. En el caso de la exportación a una base de datos, contiene el nombre de la tabla de exportación principal. En el caso de la exportación a SharePoint, contiene la URL del documento exportado.

Resultados de la exportación

Propiedades:

Nombre | Tipo | Acceso | Descripción
Documents | [Colección de documentos exportados] | Solo lectura | Colección de documentos exportados durante una sesión de exportación.
Type | Número entero | Solo lectura | Tipo de exportación. Se atribuye uno de los siguientes valores: ET_File: exportación a formatos de archivo. ET_Database: exportación a una base de datos. ET_Script: exportación personalizada basada en un script. ET_SharePoint: exportación a SharePoint.

Colección de documentos exportados

Propiedades:

Nombre | Tipo | Acceso | Descripción
Count | Número entero | Solo lectura | Cantidad de documentos en la colección.
Item(index) | [Documento exportado] | Solo lectura | Documento que tiene el índice index. A index se le atribuyen valores de 0 a Recuento: 1.

Scripts de muestra que describen la exportación


Scripts de muestra que describen la exportación

Obtención de valores del campo durante la exportación
Este código de muestra ejemplifica cómo es posible obtener el valor de un código durante la exportación. Este valor se puede utilizar para denominar los archivos a los que se exportan las imágenes o la fecha. Si no existe este campo en el documento, se producirá un error.

Estructura del documento que se exportará:

Sección 1

Campo1

...

Grupo1

Campo2

...

...

CampoN

Sección 2

Campo1

...

CampoK

[VBScript]

Dim field1Value, field2Value

' Obtiene el valor del Campo1 en la Sección 1

if Not IsNull( me.Field( "Sección 1\Campo1" ).Value ) then

field1Value = me.Field( "Sección 1\Campo1" ).Value

end if

' Obtiene el valor del Campo2 en el Grupo1 de la Sección 1

if Not IsNull( me.FIELD( "Sección 1\Grupo1\Campo2" ).Value ) then

field2Value = me.Field( "Sección 1\Grupo1\Campo2" ).Value

end if

' Obtiene el valor del Campo1 en la Sección 1 si la sección posee varias instancias

if Not me.Field( "Sección 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Sección 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Campo1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Obtiene el valor del Campo1 en la Sección 1

if( Field("Sección 1\\Campo1").Value != null ) {

var field1Value = Field("Sección 1\\Campo1").Value;

}

// Obtiene el valor del Campo2 en el Grupo1 de la Sección 1

if( Field("Sección 1\\Grupo1\\Campo2").Value != null ) {

var field2Value = Field("Sección 1\\Grupo1\\Campo2").Value;

}

// Obtiene el valor del Campo1 en la Sección 1 si la sección posee varias instancias

if( Field( "Sección 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Sección 1" ).Items.Count; i++ ) {

var curPage = Field( "Sección 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Campo1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Exportación de imágenes de páginas

El código en este ejemplo muestra cómo exportar imágenes de todas las páginas del documento con el formato de archivo, el esquema de color y la resolución requeridos. Las imágenes se guardan por página, es decir, cada página en un archivo independiente.

Los archivos en este ejemplo se denominan "página1.tif", "página2.tif", etc. Puede cambiar el mecanismo de denominación de archivos, según sea necesario. Por ejemplo, puede crear nombres de archivos basados en el valor de un campo.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' Establece el nombre y la extensión deseados para el archivo según el formato seleccionado

fileName = fso.BuildPath( folderName, "página" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // Establece el nombre y la extensión deseados para el archivo según el formato seleccionado

var fileName = fso.BuildPath( folderName, "página" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Exportación de una tabla

Este ejemplo muestra cómo exportar una tabla a un archivo *.txt.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject")

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Tabla"

dim table, row, cell, rowNumber

set table = me.Field("Página 1\Tabla")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Tabla" );

var table, i, j;

table = Field("Página 1\\Tabla");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Exportación de un documento de cualquier nivel de anidamiento

Este ejemplo muestra cómo exportar campos de un documento de cualquier nivel de anidamiento mediante el uso de funciones personalizadas del módulo de exportación global. Si necesita exportar campos de un documento de anidamiento variable, se recomienda utilizar un componente COM externo (consulte el siguiente ejemplo).

Código de exportación básica

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Código de las funciones del módulo de exportación global

[VBScript]

' El procedimiento realiza la exportación: crea una carpeta de exportación y

' guarda en ella los archivos de imagen de página, el archivo de texto con los campos del documento e

' información sobre el documento

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject")

    ' creación de la carpeta de exportación

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error durante la creación de la carpeta de exportación: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' exportación de imágenes

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error durante la exportación de imágenes: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' creación del archivo de texto

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' exportación de información sobre el documento

    ExportDocInfo docObj, txtFile

    ' exportación de campos

    txtFile.WriteLine "Campos:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error durante la exportación de datos: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Función de exportación de imágenes.

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' opciones de configuración de exportación

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' exportación página por página

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pages

        fileName = fso.BuildPath(exportFolder, "página" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Procedimiento que exporta información sobre el documento

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Información sobre el documento:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Procedimiento que exporta campos de la colección de campos

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next

End Sub

' Comprueba si el valor de la unidad es cero

' Si el valor del campo no es válido, cualquier intento para acceder a este campo (incluso

' para comprobar si es cero) puede provocar una excepción

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Procedimiento de exportación de campos

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' guardamiento del nombre del campo

    txtFile.Write (indent & field.Name)

    ' guardamiento del valor del campo si se puede acceder a él

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("    " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' exportación de campos secundarios

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' exportación de instancias del campo

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' La función crea una carpeta de exportación y muestra como resultado una ruta completa a esa carpeta

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderNameme

    ' ' carpeta principal

    Const exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' la carpeta de la plantilla de documento específica

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End If

    ' la carpeta del documento exportado

    Dim i

    i = 1

    folderName = fso.BuildPath(docFolder, i)

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath(docFolder, i)

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// La función realiza la exportación: crea una carpeta de exportación y

// guarda en ella los archivos de imagen de página, el archivo de texto con los campos del documento e

// información sobre el documento

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // creación de carpetas de exportación

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error durante la creación de la carpeta de exportación: " + e.description;

        return;

    }

    // exportación de imágenes

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error durante la exportación de imágenes: " + e.description;

        return;

    }

    // creación del archivo de texto

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile(fileName, true);

    // exportación de información sobre el documento

    ExportDocInfo( docObj, txtFile);

    // exportación de campos

    txtFile.WriteLine( "Campos:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error durante la exportación de datos: " + e.description;

        txtFile.Close();

        return;

    }

    txtFile.Close();

    txtFile= 0;

    fso= 0;

}

// Función de exportación de imágenes.

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // opciones de configuración de exportación

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // exportación página por página

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "página" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Procedimiento que exporta información sobre el documento

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Información sobre el documento:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Procedimiento que exporta campos de la colección de campos

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Comprueba si el valor del campo es cero

// Si el valor del campo no es válido, cualquier intento para acceder a este campo (incluso

// para comprobar si es cero) puede provocar una excepción

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Procedimiento de exportación de campos

function ExportField(field, txtFile, indent)

{

    // guardamiento del nombre del campo

    txtFile.Write(indent + field.Name);

    // guardamiento del valor del campo si se puede acceder a él

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // exportación de campos secundarios

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // exportación de instancias del campo

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// La función crea una carpeta de exportación y muestra como resultado una ruta completa a esa carpeta

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // carpeta principal

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // la carpeta de la plantilla de documento específica

    docFolder = fso.BuildPath(exportFolder, templateName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder);

    }

    // la carpeta del documento exportado

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder(folderName);

    return folderName;

}

Uso de un componente COM externo

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Código de un componente ActiveX en VisualBasic

A continuación, se proporciona un código de clase Exporter del proyecto AutomationExport, que se utiliza en los scripts antes mencionados.

OptionExplicit

DimmFso As New Scripting.FileSystemObject

' El procedimiento realiza la exportación del documento: crea una carpeta de exportación y

' guarda en ella los archivos de imagen de página, el archivo de texto con los campos del documento e

' información sobre el documento

PublicSub Export(ByRef docObj As Object, ByRef exportTools As Object)

OnError GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' creación de carpeta de exportación

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "No se puede crear la carpeta de exportación"

        ExitSub

    End If

    ' exportación de imágenes

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' creación del archivo de texto

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' guardamiento de información sobre problemas de exportación de imágenes

    IfimageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' exportación de información sobre el documento

    exportDocInfo docObj, txtFile

    ' exportación de campos

    txtFile.WriteLine "Campos:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Error durante la exportación de datos"

    EndIf

    txtFile.Close

    ' si se produce un error durante la exportación, restablezca

    ' el indicador de exportación exitosa a Falso

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

ExitSub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

EndSub

' Función de exportación de imágenes. Si se produce un error al exportar imágenes,

' se mostrará como resultado un mensaje de error sobre el error; de lo contrario, se mostrará como resultado una cadena vacía

PrivateFunction exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

OnError GoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' opciones de configuración de exportación

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' exportación página por página

    Set pages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_página" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

ExitFunction

err_h:

    exportImages = Err.Description

EndFunction

' Procedimiento que exporta información sobre el documento

PrivateSub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

OnError GoTo err_h

    txtFile.WriteLine "Información sobre el documento:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

ExitSub

err_h:

    txtFile.WriteLine Err.Description

EndSub

' Procedimiento que exporta campos de la colección de campos

PrivateFunction exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim curField As Object

    exportFields = True

    For Each curField In fields

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

        End If

    Next curField

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

EndFunction

' Comprueba si el valor del campo es cero

' Si el valor no es válido, cualquier intento para acceder a este campo (incluso

' para comprobar si es cero) puede provocar una excepción

FunctionIsNullFieldValue(ByRef field As Object) As Boolean

OnError GoTo err_h

    IsNullFieldValue = IsNull( field.Value )

ExitFunction

err_h:

    IsNullFieldValue = True

EndFunction

' Función de exportación de campos

PrivateFunction exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim result As Boolean

    result = True

    ' guardamiento del nombre del campo

    txtFile.Write (indent & field.Name)

    ' guardamiento del valor del campo si se puede acceder a él

    IfNot IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' exportación de campos secundarios

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' exportación de instancias del campo

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

EndFunction

' La función crea una carpeta de exportación y muestra como resultado una ruta completa a esa carpeta

PrivateFunction createExportFolder(ByVal templateName As String) As String

OnError GoTo err_h

    Dim docFolder As String, folderName As String

    ' carpeta principal

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' la carpeta de la plantilla de documento específica

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' la carpeta del documento exportado

    Dimi As Long

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

ExitFunction

err_h:

    createExportFolder = ""

EndFunction

Uso de un componente externo escrito en .Net( C# )

Para utilizar un componente externo escrito en .Net, realice lo siguiente:

  1. Cree un proyecto de tipo ClassLibrary.
  2. Agregue Controller.dll a las referencias del proyecto: aparecerá FlexiCaptureScriptingObjects en la lista de Referencias y todas las interfaces de los objetos del script se habilitarán en el proyecto.
  3. Defina la interfaz de envío y la clase que implementa esta interfaz, como también Progld (esto permitirá trabajar con el componente .Net como con ActiveX desde el código del script).
  4. Después de crear el proyecto, registre la biblioteca de tipos generada (esto se puede realizar automáticamente al habilitar la opción correspondiente en las propiedades del proyecto).
  5. Invoque el método del componente de la manera habitual desde el código de exportación:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

A continuación, aparece el código de un componente de este tipo:

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// La interfaz del componente de exportación al que puede accederse desde el script

// Al crear un componente nuevo, genere un nuevo GUID

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// La clase que implementa la funcionalidad del componente de exportación

// Al crear un componente nuevo, genere un nuevo GUID

// y establezca su ProgId

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// La función realiza la exportación del documento: crea una carpeta de exportación y

// guarda en ella los archivos de imagen de página,

// el archivo de texto con los campos del documento e información sobre el documento

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// creación del archivo de texto

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// exportación de información sobre el documento

exportDocInfo( docRef, sw );

// exportación de campos

sw.WriteLine( "Campos:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// La función crea una carpeta de exportación y muestra como resultado una ruta completa a esa carpeta

privatestring createExportFolder( string templateName )

{

string docFolder, folderName;

// carpeta principal

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// la carpeta de la plantilla de documento específico

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// la carpeta del documento exportado

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

returnfolderName;

}

// Función de exportación de imágenes.

privatevoid exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions(); ;

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Exportación de información sobre el documento

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Información sobre el documento:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Exportación de colección de campos

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Comprueba si el valor del campo es cero

// Si el valor del campo no es válido, cualquier intento para acceder a este campo (incluso

// para comprobar si es cero) puede provocar una excepción

privatebool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// Exportación del campo específico

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// guardamiento del nombre del campo

sw.Write( indent + field.Name );

//guardamiento del valor del campo si se puede acceder a él

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// exportación de campos secundarios

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// exportación de instancias del campo

exportFields( field.Items, sw, indent + " " );

}

}

}

}
Controlador de exportación
Este código de muestra ejemplifica un controlador de exportación simple que guarda información sobre los documentos exportados y exporta los resultados a archivos de texto. En este ejemplo, se utilizan dos archivos de texto: uno contiene la lista de documentos exportados correctamente y otro contiene la lista de documentos que mostraron como resultado errores durante la exportación.

[VBScript]

dimcurDoc

dimfso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

setfso = CreateObject("Scripting.FileSystemObject")

' creación del archivo con documentos que tienen fallas

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

settxtErrorFile = fso.CreateTextFile( fileErrorName, true )

' creación del archivo con documentos exportados correctamente

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

settxtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

DimdocInfo

' repetición de la colección de documentos exportados

foreach curDoc in me.Documents

    docInfo = "DocumentId:" & curDoc.Id

    if curDoc.Action.Succeeded then

        docInfo = docInfo & ". Se exportó correctamente.  Resultado:" & curDoc.Action.Result

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & ". Error de exportación: " & curDoc.Action.ErrorMessage & "  Resultado:" & curDoc.Action.Result

        txtErrorFile.WriteLine docInfo

    end if

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

varfso = new ActiveXObject("Scripting.FileSystemObject");

// creación de los archivos con documentos que tienen fallas

varfileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

vartxtErrorFile = fso.CreateTextFile( fileErrorName, true );

// creación del archivo con documentos exportados correctamente

varfileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

vartxtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

vari

// repetición de la colección de documentos exportados

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Se exportó correctamente.  Resultado:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Error de exportación: " + curDoc.Action.ErrorMessage + "  Resultado:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Migración de las reglas y la exportación de FormReader 6.5 a los scripts de FlexiCapture 8.0 Professional

Migración de las reglas de FormReader a las reglas de script de FlexiCapture

Reglas If-Then (Si-Entonces)

Cambios en los métodos y las funciones:

  1. Error (campo, mensaje). En lugar de esta función, utilice la combinación de las siguientes propiedades de la unidad que se comprobará: CheckSucceeded, ErrorMessage y FocusedField.

    Por ejemplo, este código de FormReader 6.5:

    if [City].IsEmpty() then Error( [City] , "debe completarse el nombre de la ciudad")

    debe cambiar a:

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "debe completarse el nombre de la ciudad"

    me.FocusedField = me.Field("Ciudad")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("Ciudad").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "debe completarse el nombre de la ciudad";

    FocusedField = Field("Ciudad");

    } else {

    CheckSucceeded = true;

    }

  2. Operaciones de cadenas. A continuación, encontrará una lista de instrucciones para implementar en FlexiCapture 8.0 las operaciones de cadenas disponibles en las reglas If-Then.

    [VBScript]

    .Length(): utilice la función análoga Len(cadena).

    .CmpNoCase(str): para comparaciones de cadenas que no distinguen mayúsculas de minúsculas, utilice las funciones LCase(cadena) o UCase(cadena).

    .Mid(position, count): utilice la función análoga Mid(cadena, posición, recuento).

    [JScript]

    .Length(): utilice la propiedad de longitud análoga de la variable de cadenas.

    .CmpNoCase(str): para comparaciones de cadenas que no distinguen mayúsculas de minúsculas, utilice los métodos toLowerCase(cadena) o toUpperCase(cadena) de las variables de cadenas.

    .Mid(position, count): utilice los métodos análogos substr(inicio, [longitud]) de la variable de cadenas.

  3. Operaciones con números reales.

    [VBScript]

    Floor(d), Ceil(d): no existen equivalentes ya listos en VBScript. Si es necesario, puede crear su propia implementación.

    Round(d),Round(d, i): utilice la función análoga Round(d, [i]).

    [JScript]

    Floor(d), Ceil(d): utilice los métodos floor(d) y ceil(d) del objeto Matemática.

    Round(d): utilice los métodos round(d) del objeto Matemática.

    Round(d, i): no existen equivalentes ya listos en JScript. Si es necesario, puede crear su propia implementación.

  4. Operaciones del campo de texto

    IsEmpty(): compare el valor de texto del campo Field("fieldName").Text con una cadena vacía.

    Text() : utilice Field("fieldName").Text.

    Length(): obtenga el valor de texto del campo y, luego, determine la longitud del valor de la cadena resultante según se describió anteriormente en el punto 2.

    SetText(text) : utilice Field("fieldName").Text = text.

  5. Operaciones con marcas de verificación

    IsValid(): puede utilizar la propiedad IsVerified.

    Value() :Field("fieldName").Value ahora muestra como resultado un valor booleano y no 0 ó 1 como en FormReader 6.5.

    SetValue(newValue) : utilice Field("fieldName").Value = newValue.

  6. Operaciones con grupos de marcas de verificación

    IsValid(): puede utilizar la propiedad IsVerified para determinar la certeza de un campo en un grupo. Para saber cuántas casillas de verificación se seleccionaron, repita las marcas de verificación en el grupo tal como se muestra en el ejemplo "Revisión de grupo de marcas de verificación". (Consulte Scripts de muestra para la creación de reglas personalizadas).

    Value(): para obtener la cantidad de marcas de verificación seleccionadas, puede utilizar uno de los siguientes métodos:

    1. Asignar nombres con números a las marcas de verificación en el grupo: 0, 1, etc. Luego, Field("groupName").Value incluirá el número de la marca de verificación seleccionada, la lista de números (si se selecciona más de una) o una cadena vacía (si no se selecciona ninguna).
    2. Agregar a la regla solo las marcas de verificación del grupo determinado en el orden en el que se ubican en el grupo. Luego, se deben repetir las marcas de verificación en el grupo tal como se muestra en el ejemplo "Revisión de grupo de marcas de verificación".

    Text(): utilice Field("groupName").Value.

    SetValue(newValue): para cambiar el valor de un grupo de marcas de verificación, debe establecer o restablecer las marcas de verificación necesarias en este grupo. Las marcas de verificación deben incluirse en la regla, y el indicador ReadOnly debe habilitarse para ellas.

Reglas de automatización

Para poder utilizar en FlexiCapture 8.0 los componentes de automatización que se crearon en FormReader 6.5, necesita realizar los siguientes cambios en sus componentes de automatización.

  1. El método de un componente externo que implementa la lógica de las reglas debe invocarse desde una regla de script, tal como se muestra en los ejemplos. No hay requisitos específicos para la firma de este método. Sin embargo, tenga en cuenta que los parámetros que pasan de la regla de script al método del componente externo deben coincidir con la firma seleccionada del método, que puede verse de esta manera:

    Public Sub Check(ByRef docObj As Object)

    2. docObj: referencia a la unidad de documento que se comprobará.

  2. Los métodos del objeto fieldsObj que se utilizó en FormReader 6.5 deben reemplazarse por métodos compatibles en FlexiCapture 8.0. La siguiente tabla enumera las correspondencias entre los métodos antiguos y nuevos del objeto fieldsObj.
Método fieldsObj | Muestras de código en VisualBasic que pueden sustituir el método antiguo
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | No compatible
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Para poder trabajar con las columnas de la tabla, agregue los campos de la columna a la regla. La comprobación de que la columna se haya asociado satisfactoriamente es la misma que se realiza para cualquier otro campo:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Para poder trabajar con las celdas de la tabla, agregue los campos de la columna a la regla.

Las operaciones con estos campos dependen del nivel de la regla. Si la regla se creó para ser utilizada en el nivel de la columna o al nivel de la tabla, se aplicará a cada fila y utilizará los valores de las columnas de la fila que se está comprobando (es decir, funciona en las celdas):

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Por lo tanto, puede crear una regla que, por ejemplo, utilice los datos de las dos primeras columnas de una tabla para completar una tercera columna:

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Si la regla se creó para ser utilizada en el nivel de una unidad que contiene una tabla (grupo, sección, documento), necesitará repetir una columna para acceder a las celdas, tal como se describió en el ejemplo "Regla de automatización".

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' sugerencias para el campo

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' sugerencias para el campo

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Se puede acceder a los campos de celdas de la misma manera que se describe para el método SetTableCellValue.

Luego, podrá trabajar con la celda a la que accedió como con cualquier otro campo. La configuración de una sugerencia se verá de la siguiente manera:

cell.Suggest cellSuggest

  3. Los métodos del objeto errorsObj que se utilizó en FormReader 6.5 deben reemplazarse por métodos compatibles con FlexiCapture 8.0. La siguiente tabla enumera las correspondencias entre los métodos antiguos y nuevos del objeto errorsObj.
Método errorsObj Muestras de código en VisualBasic que pueden sustituir el método antiguo
SendFieldError( ErrMsg As String, Index As Integer) docObj.ErrorMessage = ErrMsg

docObj.CheckSucceeded = false

docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant )

docObj.ErrorMessage = ErrMsg
docObj.CheckSucceeded = false

Si la regla se creó para ser utilizada en el nivel de la tabla o en el nivel de la columna, el programa marcará como error todas las celdas en las filas comprobadas cuyos campos (columnas) se hayan agregado a la regla. Para mover el enfoque a una celda específica, escriba el siguiente código:

docObj.FocusedField = docObj.Field("ColumnName")

Si la regla se creó para ser utilizada en un nivel superior, el programa no marcará ninguna celda ni moverá el enfoque hacia ellas.

Migración de la exportación de automatización de FormReader a la exportación de scripts de FlexiCapture

El método de un componente externo que implementa la lógica de las reglas debe invocarse desde una regla de script, tal como se muestra en los ejemplos. No hay requisitos específicos para la firma de este método. Sin embargo, tenga en cuenta que los parámetros que pasan de la regla de script al método del componente externo deben coincidir con la firma seleccionada del método, que puede verse de esta manera:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj: referencia al documento que se exportará.

exportTools: referencia al objeto ExportTools.

Los métodos del objeto fieldsObj que se utilizó en FormReader 6.5 deben reemplazarse por métodos compatibles con la versión actual de la aplicación. La siguiente tabla contiene las correspondencias entre los métodos del objeto fieldsObj y el nuevo medio de trabajo con documentos para exportar:

Métodos del objeto fieldsObj | Posibles implementaciones en el nuevo modelo de objetos
GetFieldsCount As
Integer 		Para obtener la cantidad de campos en el documento que se está exportando, repita el árbol de campos tal como se muestra en el ejemplo "Uso de un componente externo COM" y realice el cálculo.
GetFieldsNames(Names As Variant) | Para obtener los nombres de los campos en el documento que se está exportando, repita el árbol de campos tal como se muestra en el ejemplo "Uso de un componente externo COM" y complete la secuencia con los nombres del campo.
GetFieldsTypes(FieldTypes As Variant) | No compatible.
GetFieldByIndex(Index As Integer, FieldValue As Variant) El acceso a través del índice no tiene sentido, ya que el nuevo modelo de documento posee una estructura jerárquica.
El árbol de campos puede repetirse fácilmente, tal como se muestra en el ejemplo "Uso de un componente externo COM", y complete la secuencia con los nombres del campo.
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


Comparación de reglas de FormReader 6.5 y FlexiCapture 8.0 Professional

FormReader 6.5

Equivalente en FlexiCapture 8.0 Professional

Comprobación en relación con una base de datos

Regla de comprobación de la base de datos

Sumas de comprobación

Regla de suma de comprobación

Combinar bloques

Regla de combinación de campos

Reglas VBScript

Regla de script

Buscar en la lista de sugerencias

Propiedades del campo, ficha Tipo de datos. Enumera las variantes en el campo Restricciones. Funciona para todos los tipos, excepto Fecha y Número. Consulte Tipos de datos del campo de entrada de texto.

Asociar bloques

Puede implementarse a través de una regla de script.

Reglas If-Then (Si-Entonces)

Regla de script

Reemplazar valores de la lista

Propiedades del campo, ficha Tipo de datos. Tipo de Texto, campo Procesamiento. Consulte Tipos de datos del campo de entrada de texto.

Reemplazar caracteres de la lista

Propiedades del campo, ficha Tipo de datos. Tipo de Texto, campo Procesamiento. Consulte Tipos de datos del campo de entrada de texto.

Normalizar y comprobar fechas

Propiedades del campo, ficha Tipo de datos. En la lista Categoría, seleccione Fecha; en la lista Formatos, seleccione los formatos requeridos; en el campo Restricciones, introduzca las restricciones correspondientes. Consulte Tipos de datos del campo de entrada de texto.

Expresiones regulares

Propiedades del campo, ficha Tipo de datos. Introduzca la expresión regular correspondiente en el campo Restricciones. Funciona para todos los tipos, excepto Fecha y Número. Consulte Tipos de datos del campo de entrada de texto.

Comprobación de automatización

En la versión anterior de la aplicación, el uso de los objetos de automatización requería el registro de los componentes en el ordenador de destino, que dificultaba la transferencia de lotes de un ordenador a otro. En la nueva versión, la lógica de la mayoría de dicha reglas se implementa con mayor eficacia a través de scripts.

Si la lógica de la regla es demasiado compleja y requiere la utilización de un componente externo, el componente debe invocarse desde el código de una regla de script. Luego, debe transferirse al componente una referencia al objeto en el documento revisado.

Normalizar precios

Puede implementarse a través de un componente externo COM invocado desde una regla de script.

Validar número y series de pasaporte

Puede implementarse a través de un componente externo COM invocado desde una regla de script.

Suma en cifras, suma por escrito

Regla de suma en cifras - suma en palabras

Precio en cifras, precio en palabras

Puede implementarse a través de un componente externo COM invocado desde una regla de script.


Opciones adicionales

Puede configurar el procesamiento de documentos y la interfaz del programa para que se adapten a sus necesidades. En la ventana principal, seleccione Herramientas>Opciones… El cuadro de diálogo que se abrirá incluye cuatro fichas:

  • Progreso de la tarea

    Cuando se ejecutan las tareas en el modo en segundo plano, puede leer el archivo de registro y leer las sugerencias emergentes en la ventana de progreso de las tareas para supervisar el proceso. En esta ficha, puede seleccionar la información que debe introducirse en el archivo de registro y los casos en que deben aparecer mensajes en forma de globos.

  • Colores

    Puede cambiar el color de los elementos de la interfaz (por ejemplo, los marcos que encuadran los campos seleccionados en el editor de plantillas o los marcos y el color de relleno de los campos con errores y advertencias). Seleccione el elemento deseado y haga clic en el botón Color.

  • Procesamiento de documentos

    Las imágenes pueden reconocerse de forma automática inmediatamente después de que se hayan agregado al lote si selecciona la opción Reconocer imágenes agregadas de forma automatica.

    Al seleccionar Eliminar los documentos procesados después de la exportación, eliminará del lote aquellos documentos cuyos datos se exportaron correctamente.

    Si se detecta un error de script, se iniciará el depurador Visual Studio. Seleccione Deshabilitar depuración externa de scripts si no desea que se inicie el depurador. Solo aparecerá un mensaje de error.

  • Cuadros de diálogo

    De manera predeterminada, cuando inicia el programa, aparece el cuadro de diálogo Abrir proyecto, donde puede seleccionar uno de los proyectos existentes. Puede desactivar el cuadro de diálogo al desactivar la opción Mostrar cuadro de diálogo de inicio en la ficha Cuadros de diálogo (o bien, puede desactivar este cuadro de diálogo al desactivar la misma opción en el cuadro de diálogo).

    Al cerrar una lista de plantillas, el programa le advierte acerca de cualquier plantilla de documentos sin publicar. Si no desea que aparezca este mensaje de advertencia, desactive la opción Mostrar advertencia si hay una plantilla sin publicar (también puede desactivar este cuadro de diálogo si desactiva la misma opción en el cuadro de diálogo mismo).


Proyectos de muestra de ABBYY FlexiCapture

Para ver cómo funciona ABBYY FlexiCapture 8.0 y para comprender mejor las funciones, puede utilizar los proyectos de muestra que se incluyen en el programa. Estos proyectos listos para usar contienen plantillas de documentos configuradas e imágenes de documentos para procesar.

Puede encontrar proyectos de muestra en <nombre del disco>:\Documents and Settings\All Users\Application Data\ABBYY\FlexiCapture\8.0\Samples.

Nota: En Microsoft Windows Vista, puede encontrar los proyectos de muestra en <nombre del disco>:\Users\Public\ABBYY\FlexiCapture\8.0\Samples.

La carpeta Muestras contiene las siguientes carpetas:

  1. FlexiCapture: esta carpeta contiene los proyectos de muestra de FlexiCapture.
  2. FlexiLayoutStudio: esta carpeta contiene los proyectos de muestra de FlexiLayout Studio. Estos proyectos de muestra ejemplifican el procesamiento de documentos semiestructurados y deben abrirse con ABBYY FlexiLayout Studio 8.0. Puede encontrar una descripción detallada de algunos de esos proyectos en el archivo de ayuda de FlexiLayout Studio (consulte las secciones Tutorial y Trucos y sugerencias).
  3. FormDesigner: esta carpeta contiene formularios fijos desarrollados en ABBYY FormDesigner. El archivo *.fdd debe abrirse con ABBYY FormDesigner 8.0. Estos formularios se utilizan en los siguientes proyectos de muestra de FlexiCapture: Solicitud de tarjeta bancaria y Cuestionario.
  4. Imágenes: esta carpeta contiene imágenes de documentos digitalizadas para los proyectos de muestra de FlexiCapture.

A continuación, se muestra una lista de los proyectos de muestra de FlexiCapture y una descripción breve de cada una de ellas.

Un proyecto de muestra con documentos de diferentes tipos

Las carpetas del proyecto contienen proyectos de muestra de FlexiCapture.

  1. Punto de entrada individual

    Este proyecto muestra cómo pueden procesarse documentos de diferentes tipos. No es necesario ordenar los documentos de antemano; los formularios fijos y los documentos flexibles pueden procesarse juntos. Las plantillas que se utilizan en este proyecto también se utilizan en los proyectos que se describen a continuación.

    El proyecto contiene todos los tipos de documentos: solicitudes de tarjetas bancarias, facturas, contratos, cartas y precios.

Proyectos de muestra con formularios fijos

Las carpetas del proyecto contienen formularios creados en proyectos de ABBYY FormDesigner y FlexiCapture.

  2. Solicitud de tarjeta bancaria

    Este proyecto de muestra ejemplifica las siguientes capacidades:

    • Detección automática de campos en formularios fijos (para saber cómo funciona la detección automática, elimine todos los campos de la plantilla de documento y seleccione Herramientas>Detectar objetos automáticamente…)
    • Asistencia para documentos con estructuras complejas:
      1. Documentos de varias páginas (en el proyecto de muestra se utilizan aplicaciones de tres páginas)
      2. Trabajo con secciones del documento (en el proyecto de muestra, cada página es una sección independiente)
      3. Reglas de ensamblaje de documentos
      4. Procesamiento de adjuntos
    • Asistencia para campos complejos:
      1. Trabajo con tablas en formularios fijos (tabla Cuentas abiertas)
      2. Repetición de grupos de campos (grupos Dirección y Cuentas solicitadas)
    • Verificaciones de formato de datos (se especifican los formatos para todos los campos numéricos y de fecha)
    • Personalización del formulario de datos

  3. Cuestionario

    Puede encontrar una descripción detallada de este proyecto de muestra en el manual del usuario. El proyecto muestra paso a paso cómo configurar una plantilla de documento. Para ilustrar las funciones básicas de ABBYY FlexiCapture, se utiliza una serie de formularios más simples. Puede completar el cuestionario en este simple proyecto de muestra, procesarlo con ABBYY FlexiCapture y enviar los datos exportados a ABBYY.

Proyectos de muestra con formularios flexibles

Las carpetas del proyecto contienen proyectos de FlexiLayout Studio y FlexiCapture.

  4. Factura

    Este proyecto de muestra ejemplifica el procesamiento de documentos semiestructurados y las siguientes capacidades:

    • Cantidad variable de páginas en los documentos (de 1 a 3)
    • Tablas que se extienden a lo largo de varias páginas
    • Uso de un diccionario externo de palabras clave (archivo de texto)
    • Uso de una regla JScript para comparar la suma en el campo Total con la suma que se obtiene al sumar los valores del Total de todas las filas de la tabla.

  5. Precios

    Este proyecto de muestra ejemplifica el procesamiento de documentos semiestructurados y las siguientes capacidades:

    • Asistencia para grupos repetidos. Este proyecto de muestra expone cómo los grupos repetidos pueden utilizarse para describir tablas anidadas (tablas con subtítulos)

  6. Cartas y contratos

    Este proyecto de muestra ejemplifica el procesamiento de documentos sin estructura de los que se capturan 2 ó 3 campos. El proyecto ejemplifica las siguientes capacidades:

    • Cantidad variable de páginas en los documentos (de 1 a 4)
    • Configuración de la exportación a PDF para búsquedas


Idiomas de reconocimiento compatibles

ABBYY FlexiCapture 8.0 Professional admite los siguientes idiomas de reconocimiento con diccionarios compatibles:

Idioma | OCR* | ICR**
Armenio (oriental, occidental, grabar) | ü |
Bashkir | ü |
Búlgaro | ü | ü
Catalán | ü |
Croata | ü | ü
Checo | ü | ü
Danés | ü |
Neerlandés (Países Bajos y Bélgica) | ü | ü
Inglés | ü | ü
Estonio | ü | ü
Finlandés | ü | ü
Francés | ü | ü
Alemán (ortografía antigua y nueva) | ü | ü
Griego | ü | ü
Húngaro | ü | ü
Indonesio | ü | ü
Italiano | ü | ü
Kazakh | ü | ü
Kirguís | ü | ü
Letón | ü | ü
Lituano | ü | ü
Noruego (Nynorsk y Bokmal) | ü |
Polaco | ü | ü
Portugués (Portugal y Brasil) | ü |
Rumano | ü | ü
Ruso | ü | ü
Eslovaco | ü | ü
Esloveno | ü | ü
Español | ü | ü
Sueco | ü |
Tártaro | ü |
Tailandés | ü |
Turco | ü | ü
Ucraniano | ü | ü

Para obtener más información acerca de los idiomas compatibles, consulte la sección "Fuentes necesarias para la interpretación correcta de caracteres de los tipos de datos admitidos en el editor ABBYY FlexiCapture".

Encontrará una lista completa y actualizada de tipos de datos compatibles y sus detalles en http://www.abbyy.com.

* OCR: Reconocimiento óptico de caracteres. Reconocimiento óptico de textos impresos.

** ICR : Reconocimiento inteligente de caracteres. Reconocimiento de textos manuscritos.


Fuentes necesarias para la interpretación correcta de caracteres de los tipos de datos admitidos en el editor FormReader.

Fuentes necesarias para la interpretación correcta de caracteres de los idiomas admitidos en el editor de ABBYY FlexiCapture.

Idioma | Fuente
Con diccionarios compatibles |
Armenio (oriental, occidental, grabar) | Arial Unicode MS(2)
Tártaro | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Sin diccionarios compatibles |
Abjaso | Arial Unicode MS(2)
Adigués | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aghul | Arial Unicode MS(2), Lucida Sans Unicode(3)
Altaico | Arial Unicode MS(2), Lucida Sans Unicode(3)
Avéstico | Arial Unicode MS(2), Lucida Sans Unicode(3)
Azerbaijano (cirílico), Azerbaijano (latín) | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Bashkir | Arial Unicode MS(2), Palatino Linotype(2)
Buryat | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Chechén | Arial Unicode MS(2), Lucida Sans Unicode(3)
Chukchi | Arial Unicode MS(2), Lucida Sans Unicode(3)
Chuvash | Arial Unicode MS(2)
Dargin | Arial Unicode MS(2), Lucida Sans Unicode(3)
Dungan | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Gagauz | Arial Unicode MS(2)
Hausa | Arial Unicode MS(2), Lucida Sans Unicode(3)
Ingush | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kabardian | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kalmyk | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Karakalpako | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Kazakh | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Khakas | Arial Unicode MS(2)
Khanty | Arial Unicode MS(2)
Koryak | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kirguíz | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Lak | Arial Unicode MS(2), Lucida Sans Unicode(3)
Lezgin | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mansi | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mari | Arial Unicode MS(2)
Mongol | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Nenets | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Ossetic | Arial Unicode MS(2)
Ruso (ortografía antigua) | Arial Unicode MS(2), Palatino Linotype(2)
Tabassaran | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tajik | Arial Unicode MS(2), Palatino Linotype(2)
Turcomano | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Tuvan | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Udmurt | Arial Unicode MS(2)
Uzbeko (cirílico) | Fuentes principales MS 2.82(1) (Arial, Courier New y Times New Roman)
Yakuto | Arial Unicode MS(2)
Zulú | Arial Unicode MS,(2), Lucida Sans Unicode(3)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Tipos de texto compatibles

ABBYY FlexiCapture 8.0 Professional admite los siguientes tipos de texto:

Tipo de texto | Descripción
Impresoras de chorro de tinta, láser y tipográficas | Textos impresos en una imprenta, en una impresora láser o en una impresora de chorro de tinta.
Máquina de escribir | Textos mecanografiados.
Impresora matricial | Textos impresos en una impresora matricial de puntos.
Índice | Conjunto especial de caracteres que incluye solo dígitos escritos en estilo de código postal. Se ven de la siguiente manera:
OCR-A | Fuente monoespaciada diseñada para el Reconocimiento óptico de caracteres. Muy utilizado por bancos, compañías de tarjetas de crédito y empresas similares. Puede verse de la siguiente manera:
OCR-B | Fuente diseñada para el Reconocimiento óptico de caracteres. Puede verse de la siguiente manera:
MICR E-138 | Conjunto especial de caracteres numéricos impresos con tinta magnética especial. Los caracteres MICR (reconocimiento de caracteres en tinta magnética) se encuentran en una variedad de lugares, incluidos los cheques personales. Puede verse de la siguiente manera:
MICR CMC-7 | Fuente MICR especial para códigos de barras (CMC-7). Puede verse de la siguiente manera:


Tipos de códigos de barras compatibles

ABBYY FlexiCapture 8.0 Professional admite los siguientes formatos de códigos de barras:

  • EAN 13
  • EAN 8
  • Código 39
  • Código de verificación 39
  • Intercalado 25
  • Código de verificación intercalado 25
  • Código 128
  • Codabar
  • UPC-A
  • UPC-E
  • Código 93
  • UCC-128
  • PDF -417
  • IATA 25
  • Matriz 25
  • Industrial 25
  • PostNet
  • Código de revisión


Formatos de gráficos compatibles

Tipo | Color
BMP | blanco y negro, gris, color
PCX | blanco y negro, gris
PNG | blanco y negro, gris, color
JPEG | gris, color
JPEG-2000 | gris, color
TIFF | blanco y negro: sin comprimir, CCITT3, CCITT4, Bits empaquetados, ZIP. gris: sin comprimir, Bits empaquetados, JPEG, ZIP. color: sin comprimir, JPEG, ZIP.
PDF, PDF/A |
PDF, PDF/A para búsquedas |
DjVu | blanco y negro, gris, color


Formatos de archivo de exportación

Formatos de archivo a los que ABBYY FlexiCapture 8.0 Professional exporta datos de documentos

  • Libro de Microsoft Office Excel (*.XLS)
  • Archivo DBase (*.DBF)
  • Archivo de valores separados por comas (*.CSV) ABBYY FlexiCapture es compatible con varias páginas de códigos (Windows, DOS)
  • Archivo de valores separados por comas (*.CSV) en formato Unicode (UTF-8, UTF-16)
  • Texto simple (*.TXT) ABBYY FlexiCapture es compatible con varias páginas de códigos (Windows, DOS)
  • Texto simple (*.TXT) en formato Unicode (UTF-8, UTF-16)
  • Documento XML (*.XML)


Alfabeto utilizado en expresiones regulares

Nombre | Designación convencional | Ejemplo de uso
Cualquier carácter | * | "c"*"a": permite palabras como cosa, casa, etc.
Letra | C | C"ote": permite palabras como Pote, lote, trote, Dote, mote, etc.
Mayúscula | A | A"ote": permite palabras como Pote, Lote, Trote, Dote, etc.
Minúscula | a | a"ote": permite palabras como pote, lote, trote, dote, etc.
Letra o número | X | X: permite cualquier número o letra independiente.
Número | N | N".º": permite palabras como 5.º, 4.º, 6.º, etc.
Cadena | " " | "pote".
O | | | "pl"("e"|"a")"na": permite las palabras como "plena" y "plana".
Carácter de grupo | [] | [dm]"ote": permite palabras como "dote" y "mote".
Carácter no de grupo | [^] | [^d]"ote": permite palabras como "pote", "lote", etc., pero no permite la palabra "dote".
Espacio (dentro de un grupo) | \s | [A\s]: solo permite la letra A o un espacio.
Cualquier cantidad de repeticiones (se aplica a la expresión o subexpresión ubicada a la izquierda) | {-} | [AB74]{-}: permite cualquier combinación de caracteres A, B, 7, 4 de cualquier longitud.
Cantidad de repeticiones n | {n} | N{2}".º": permite palabras como 25.º, 84.º, 11.º, etc.
De n a m repeticiones | {n-m} | N{1-3}".º": permite palabras como 5.º, 84.º, 111.º, etc.
De 0 a n repeticiones | {-n} | N{-2}".º": permite palabras como 84.º, 111.º, etc.
Desde n repeticiones y una cantidad mayor | {n-} | N{2-}".º": permite palabras como 25.º, 834.º, 311.º, 34576.º, etc.
Subexpresión | () |
Símbolo de guión | [\-] |
Símbolo de barra diagonal | [\\] |


Patentes

Patentes de los Estados Unidos N.ºs 5 258 855, 5 369 508, 5 625 465, 5 768 416 y 6 094 505


Tecnologías de terceros

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 Universidad de British Columbia

Reservados todos los derechos.

Más

Por medio del presente, se le concede, de forma gratuita, a cualquier persona (el "Usuario") que obtenga una copia de este software y los archivos de documentación relacionados (el "Software"), el permiso para utilizar el Software sin restricción alguna, para ejercer los derechos de uso, copia, modificación, combinación, publicación, distribución y/o venta de copias del Software, y para permitir que las personas a quienes se les entrega el Software los ejerzan, sujetas a las siguientes condiciones:

  1. El aviso sobre la ley de derechos de autor anterior y el presente aviso sobre permisos (que incluye la renuncia de garantías incluida más abajo) se incluirán en todas las copias o partes importantes del Software.

  2. El nombre del titular de los derechos de autor no puede usarse para avalar ni promover productos derivados del Software sin la autorización previa específica por escrito.

LA PRESENTE RENUNCIA DE GARANTÍAS CONSTITUYE UNA PARTE ESENCIAL DE ESTA LICENCIA.

POR MEDIO DE ESTE DOCUMENTO, NO SE AUTORIZA NINGÚN USO DEL SOFTWARE, EXCEPTO QUE ASÍ LO INDIQUE LA PRESENTE RENUNCIA. LOS TITULARES DE LOS DERECHOS DE AUTOR SUMINISTRAN EL SOFTWARE "TAL COMO ES", SIN GARANTÍA DE NINGÚN TIPO, EXPRESA O IMPLÍCITA, INCLUIDAS, ENTRE OTRAS, LAS GARANTÍAS DE COMERCIALIZACIÓN, LA IDONEIDAD PARA UN FIN DETERMINADO Y LA NO INFRACCIÓN DE LOS DERECHOS DE TERCEROS. EN NINGÚN CASO LOS TITULARES DE LOS DERECHOS DE AUTOR SERÁN RESPONSABLES DE NINGUNA RECLAMACIÓN NI DE NINGÚN DAÑO ESPECIAL INDIRECTO O CONSECUENTE, ASÍ COMO DE NINGÚN TIPO DE DAÑO COMO CONSECUENCIA DE LA FALTA DE USO, DATOS O GANANCIAS, YA SEA EN UNA ACCIÓN DE CONTRATO, ACCIÓN DE NEGLIGENCIA U OTRA ACCIÓN DE AGRAVIO QUE SE DESPRENDA DEL USO O FUNCIONAMIENTO DE ESTE SOFTWARE O QUE GUARDE RELACIÓN CON ESTE. LOS TITULARES DE LOS DERECHOS DE AUTOR NO OFRECEN GARANTÍAS DE QUE EL SOFTWARE NO VIOLARÁ LOS DERECHOS DE PATENTE NI NINGÚN OTRO DERECHO DE PROPIEDAD INTELECTUAL DE CUALQUIER OTRA ENTIDAD. CADA TITULAR DE LOS DERECHOS DE AUTOR RENUNCIA A TODA RESPONSABILIDAD ANTE EL USUARIO POR RECLAMACIONES PRESENTADAS POR CUALQUIER OTRA ENTIDAD QUE ESTÉN RELACIONADAS CON EL INCUMPLIMIENTO DE LOS DERECHOS DE PROPIEDAD INTELECTUAL O DE ALGÚN OTRO TIPO. COMO CONDICIÓN PARA EL EJERCICIO DE LOS DERECHOS OTORGADOS CONFORME AL PRESENTE, CADA USUARIO ASUME LA RESPONSABILIDAD ABSOLUTA DE GARANTIZAR CUALQUIER OTRO DERECHO DE PROPIEDAD INTELECTUAL NECESARIO, SI LO HUBIERA. EL SOFTWARE NO ES TOLERANTE A FALLAS Y NO ESTÁ DISEÑADO PARA UTILIZARSE EN SISTEMAS DE USO CRÍTICO, COMO AQUELLOS UTILIZADOS PARA LA OPERACIÓN DE INSTALACIONES NUCLEARES, NAVEGACIÓN DE AERONAVES O SISTEMAS DE COMUNICACIÓN, SISTEMAS DE CONTROL DEL TRÁFICO AÉREO, MÁQUINAS DE AUXILIO VITAL DIRECTO O SISTEMAS DE ARMAS, EN QUE LA FALLA DEL SOFTWARE O EL SISTEMA PODRÍA OCASIONAR DIRECTAMENTE MUERTE, LESIONES PERSONALES O DAÑOS AMBIENTALES O FÍSICOS GRAVES ("ACTIVIDADES DE ALTO RIESGO"). LOS TITULARES DE LOS DERECHOS DE AUTOR RENUNCIAN ESPECÍFICAMENTE A CUALQUIER GARANTÍA EXPRESA O IMPLÍCITA DE IDONEIDAD DE LAS ACTIVIDADES DE ALTO RIESGO.

MARCAS COMERCIALES

QuickScan es una marca comercial, y Captiva es una marca comercial registrada de Captiva Software Corporation.

KODAK es una marca comercial de Eastman Kodak Company.

TWAIN Toolkit

TWAIN Toolkit se distribuye tal como es. El programador y los distribuidores de TWAIN Toolkit renuncian expresamente a todas las garantías implícitas, expresas o establecidas, incluidas, entre otras, las garantías implícitas de comercialización, la no infracción de derechos de terceros y la idoneidad para un fin particular. Tanto los programadores como los distribuidores no serán responsables por daños, ya sean directos, indirectos, especiales, incidentales o consecuentes, que se desprendan de la reproducción, modificación, distribución u otro uso de TWAIN Toolkit.


Asistencia técnica

En caso de que tenga preguntas sobre el uso de ABBYY FlexiCapture 8.0 Professional, consulte la descripción detallada de la funcionalidad en los Temas de ayuda y el Manual del usuario que se proporciona con ABBYY FlexiCapture 8.0 Professional. También puede buscar la sección de asistencia técnica en nuestro sitio web www.abbyy.com, donde puede encontrar una respuesta a su pregunta.

Para proporcionar consejos de expertos, nuestro servicio de asistencia técnica necesita la siguiente información:

  • Apellido, nombre, patronímico
  • Nombre de la organización
  • Número de teléfono (fax, dirección de correo electrónico)
  • Número de serie de su paquete de instalación
  • Versión (consulte Ayuda/Acerca de ABBYY FlexiCapture 8.0…)
  • Descripción general del problema con el texto completo del mensaje de error (si se encuentra disponible)
  • Tipo de ordenador y procesador
  • Versión para Windows
  • Cualquier otra información que considere importante
Dirección e información de contacto de las oficinas de ABBYY


Cómo adquirir ABBYY FormDesigner 8.0 Professional

Cómo adquirir ABBYY FlexiCapture 8.0 Professional

Para enviar una orden de compra de ABBYY FlexiCapture o hacer preguntas relacionadas con este tema, comuníquese con los socios autorizados de ABBYY o con las oficinas regionales de ABBYY.


Dirección e información de contacto de las oficinas de ABBYY

Rusia | ABBYY Russia Teléfono: +7 495 783 3700 Fax: +7 495 783 2663 Dirección: P.O. Box 49, 129301, Moscú, Rusia, ABBYY Software LLC. Dirección de la oficina: Kasatkina 11, Edificio 1, Estación de metro VDNKh, Moscú Correo electrónico: sales@abbyy.ru Asistencia técnica: support@abbyy.ru Sitio web: http://www.abbyy.ru INDICACIONES
Norteamérica y América Central | Los clientes de Estados Unidos, Canadá, México y los países de América Central deben ponerse en contacto con: ABBYY USA Teléfono: +1 510 226 6717 Fax: +1 510 226 6069 Dirección: 47221 Fremont Boulevard, Fremont, California 94538, Estados Unidos Correo electrónico: sales@abbyyusa.com Asistencia técnica: support@abbyyusa.com Sitio web: http://www.abbyy.com
Europa del Este y Mediterráneo | Los clientes de Albania, Bosnia-Herzegovina, Bulgaria, Croacia, Eslovaquia, Eslovenia, Hungría, Israel, Macedonia, Moldavia, Montenegro, Polonia, República Checa, Rumanía, Serbia, Turquía o Ucrania deben ponerse en contacto con: ABBYY Ukraine Teléfono: +380 44 490 9999 Fax: +380 44 490 9461 Dirección: P.O. Box 23, 02002 Kiev, Ucrania Correo electrónico: forms@abbyy.ua Asistencia técnica: Teléfono: +380 44 490 94 63 Correo electrónico: formssupport@abbyy.ua Sitio web: http://www.abbyy.ua
Europa Occidental | Los clientes de Alemania, Austria, Benelux, Dinamarca, España, Francia, Grecia, Irlanda, Italia, Noruega, Portugal, Reino Unido, Suecia, Suiza u otros países de Europa Occidental deben ponerse en contacto con: ABBYY Europa GmbH Teléfono: +49 89 511 159 0 Fax: +49 89 511 159 59 Dirección: Elsenheimerstrasse 49, 80687 Munich, Alemania Correo electrónico: sales_eu@abbyy.com Asistencia técnica: support_eu@abbyy.com Sitio web: http://www.abbyy.com
Japón | Los clientes de Japón deben ponerse en contacto con: ABBYY Japan: Teléfono:+81-42-795-1901 Fax: +81-42-795-1901 Dirección: 658-1 Tsuruma, Machida-shi, Tokio 194-8510 Correo electrónico: sales@abbyyusa.com Asistencia técnica: support@abbyyusa.com Sitio web: http://www.abbyy.com
Todas las demás regiones | Los clientes de países que no se hayan mencionado antes deben ponerse en contacto con: ABBYY Russia Teléfono: +7 495 783 3700 Fax: +7 495 783 2663 Dirección: P.O. Box 49, 129301, Moscú, Rusia, ABBYY Software LLC. Correo electrónico: sales@abbyy.com Asistencia técnica: support@abbyy.ru Sitio web: http://www.abbyy.ru; http://www.abbyy.com


Contrato de licencia para el usuario final

ABBYY FlexiCapture 8.0 Professional

Importante: Lea detenidamente los siguientes términos antes de instalar, copiar o utilizar el producto. Si instala, copia o utiliza el producto, aceptará automáticamente estos términos.

El presente contrato de licencia para el usuario final (en adelante, "CLUF") de ABBYY constituye un acuerdo jurídico entre Usted, el usuario final (incluida cualquier entidad jurídica para la que se haya obtenido este SOFTWARE), y ABBYY, con respecto al software de ABBYY antes identificado que acompaña a este CLUF, incluidos toda la documentación electrónica, el material impreso y los medios asociados (denominados de forma colectiva "SOFTWARE").

La instalación, copia o utilización de este SOFTWARE significa que ha leído este CLUF y que comprende y acepta sus términos y condiciones.

El SOFTWARE está protegido por leyes de derechos de autor y tratados internacionales. Acepta que este CLUF es aplicable como cualquier otro contrato negociado por escrito que haya firmado.

Si el SOFTWARE está acompañado de una copia impresa de este CLUF, en caso de que existan diferencias de contenido entre el texto de este contrato y el texto de la copia impresa adjunta, prevalecerá el texto de la copia impresa.

Este CLUF entra en vigor en el momento en que Usted acepta todas las condiciones expuestas en el presente contrato al seleccionar "Acepto los términos del contrato de licencia" y hacer clic en el botón "Siguiente" en el programa de instalación del SOFTWARE, y es vinculante durante todo el período de existencia de los derechos de autor del SOFTWARE.

Si no acepta los términos y condiciones de este CLUF, no utilice el SOFTWARE, elija "No acepto los términos del contrato de licencia" y haga clic en "Cancelar" en el programa de instalación del SOFTWARE. Puede conseguir un reembolso del importe abonado originalmente si:

(I) No utiliza el SOFTWARE.
(I) Devuelve el SOFTWARE, incluidos todo el envase, los medios y la documentación que se mencionó anteriormente, con el comprobante de pago, al establecimiento en el que Usted adquirió el SOFTWARE, en el plazo de treinta (30) días a partir de la fecha de la compra, a no ser que se estipule de otro modo según las leyes del país en el que Usted adquirió el SOFTWARE y la política de devolución del vendedor del que Usted adquirió el SOFTWARE.

1. Definiciones:

"SOFTWARE" hace referencia al software ABBYY FlexiCapture 8.0 Professional, que es un conjunto de documentación, bases de datos y programas informáticos (que puede proporcionarse de forma impresa o electrónica), que está protegido por la ley de derechos de autor.

"Componente de SOFTWARE" implica cualquier pieza constitutiva del SOFTWARE, incluidos, pero sin limitarse a ello, cualquier programa informático proporcionado con el SOFTWARE.

"Ordenador" es un dispositivo electrónico con una o más CPU que acepta información digital o similar y la manipula para obtener un resultado específico según una secuencia de instrucciones.

"Copia de SOFTWARE" es una copia del SOFTWARE o una copia de un componente de SOFTWARE que se instala en el ordenador y funciona de acuerdo con la documentación del SOFTWARE.

"Herramienta de diseño" es el módulo ABBYY FlexiLayout Studio o ABBYY FormDesigner del SOFTWARE.

"Licencia" es el derecho no exclusivo que ABBYY le otorga a Usted para utilizar el SOFTWARE conforme a los términos de este CLUF.

"Activación del SOFTWARE" es el procedimiento mediante el cual el SOFTWARE instalado adquiere plena capacidad de funcionamiento de acuerdo con la documentación del SOFTWARE.

"Uso del SOFTWARE" implica la realización de cualquiera de las acciones que se describen en la documentación del SOFTWARE como también el uso de cualquier funcionalidad del SOFTWARE.

"Mantenimiento" es el servicio que ABBYY o su Proveedor de servicios le proporcionan a Usted: mejoras y actualizaciones para SOFTWARE, y asistencia técnica.

"Proveedor" hace referencia a una entidad jurídica o física autorizada por ABBYY para suministrar el SOFTWARE y el Mantenimiento.

"ABBYY" significa:

ABBYY USA Software House Inc. registrado en 47221 Fremont Boulevard, Fremont, California 94538, Estados Unidos, cuando se aplica el artículo 21.1 de este CLUF;

ABBYY Europe GmbH registrado en Elsenheimerstr. 49, 80687 Múnich, cuando se aplica el artículo 21.2 de este CLUF;

ABBYY LLC registrado en 21 Bratislavskaya Ulitsa, edificio 1, 109451, Moscú, Rusia, cuando se aplica el artículo 21.3 de este CLUF;

ABBYY Software House Ukraine registrado en 31, Degtyarevskaya st., 03680, Kiev, Ucrania, cuando se aplica el artículo 21.4 de este CLUF;

y ABBYY Solutions Ltd., Kastoros 2, CY 1087, Nicosia, Chipre, en los demás casos.

"Grupo ABBYY" hace referencia a ABBYY junto a todas sus filiales.

"Filial de ABBYY hace referencia a una entidad que, directa o indirectamente, a través de uno o más intermediarios, controla a ABBYY, está controlada por ella o bajo su control general.

"Usted, Su/s y Suyo/s hacen referencia e incluyen a cualquier persona o entidad jurídica que haya obtenido este SOFTWARE y en cuyo nombre se utilice este SOFTWARE.

2. Concesión de licencia

2.1. Conforme a lo estipulado en los términos y las condiciones de este CLUF, ABBYY le concede a Usted una licencia limitada no exclusiva (en adelante, la "Licencia") que le permite utilizar el SOFTWARE, incluidas todas las imágenes, las fotografías, las animaciones, los componentes de sonido y vídeo, música, texto y las "pequeñas aplicaciones" incorporadas en el SOFTWARE, así como el material impreso adjunto y todas las copias del SOFTWARE únicamente del modo establecido. Todas las condiciones que se exponen a continuación se aplican al SOFTWARE en su totalidad y a cada uno de sus componentes.

3. Licencia

3.1. ABBYY declara, garantiza y asegura tener plenos derechos y facultades, y absoluta personalidad jurídica, capacidad y autoridad para otorgar licencias y distribuir el SOFTWARE, incluidas todas las imágenes, las fotografías, las animaciones, los componentes de audio y vídeo, música, texto y las "pequeñas aplicaciones" incorporadas en el SOFTWARE, así como el material impreso adjunto y todas las copias del SOFTWARE.

3.2. Todos los derechos de título y propiedad intelectual del SOFTWARE y el contenido que no incluye pero al que se puede acceder con el uso del SOFTWARE pertenecen a sus respectivos propietarios y pueden estar protegidos por leyes de derechos de autor y otros tratados y leyes sobre la propiedad intelectual. Este CLUF no pretende transferir dicha propiedad intelectual.

3.3. Reconoce que el SOFTWARE está protegido contra la copia no autorizada y el uso ilimitado, y puede incluir claves de protección de software o hardware para cumplir con dicha protección (en adelante, "Claves de la licencia") y acepta que el SOFTWARE está sujeto a todas esas protecciones.

3.4. Es posible que el alcance de la Licencia dependa de varios factores que se especifican durante la compra: el conjunto de funciones, la cantidad permitida de copias del software que se ejecutan en la red, la cantidad de CPU que se utilizan durante el procesamiento, la cantidad de páginas que pueden procesarse y la fecha de caducidad, entre otros aspectos. Toda esta información y cualquier otra información están codificadas en la Clave de la licencia. Técnicamente, la Clave de la licencia limita el uso del SOFTWARE y refleja el alcance de la Licencia que Usted solicitó.

3.5. El SOFTWARE contiene secretos comerciales importantes e información confidencial que pertenece a ABBYY, y está protegido por leyes de derechos de autor, incluidas sin carácter limitativo, las leyes de derechos de autor de los Estados Unidos, los tratados internacionales y la legislación vigente del territorio en el que se utilice el SOFTWARE. Cualquier uso del SOFTWARE que contravenga a los términos y las condiciones de este CLUF o que transgreda sus límites se considera una violación de los derechos de propiedad intelectual de ABBYY y será motivo de revocación de todos los derechos de uso del SOFTWARE que se hayan concedido en virtud de este CLUF.

3.6. Puede hacer una única transferencia permanente de este CLUF y del SOFTWARE solo de manera directa a otro usuario final. La transferencia debe abarcar todo el SOFTWARE (incluidos todos sus componentes, medios, material impreso, mejoras y este CLUF). Dicha transferencia no se puede efectuar mediante envío ni ningún otro tipo de transferencia indirecta. El beneficiario de esta transferencia exclusiva debe aceptar el cumplimiento de los términos de este CLUF, incluida la obligación de no efectuar ninguna otra transferencia de este CLUF ni del SOFTWARE. En caso de efectuar esta clase de transferencia de SOFTWARE, debe desinstalar los componentes de SOFTWARE de todos Sus ordenadores o de la red de área local.

3.7. No debe transferir ni distribuir el SOFTWARE a ninguna otra persona, como tampoco los derechos que por el presente contrato se le conceden ni cualquier otro derecho relacionado con el SOFTWARE. ABBYY tiene derecho de rescindir este CLUF en caso de que ocurra una transferencia o una distribución de cualquiera de los tipos que se describieron anteriormente.

3.8. Este CLUF no otorga derechos relativos a ninguna marca comercial de ABBYY.

3.9. Reserva de derechos. ABBYY se reserva todos los derechos que no hayan sido expresamente otorgados.

4. Uso del SOFTWARE

4.1. Puede usar el SOFTWARE de acuerdo con el alcance de Su Licencia.

4.2. Puede instalar el SOFTWARE sin la Activación del SOFTWARE en una cantidad ilimitada de Ordenadores.

4.3. Puede ejecutar o utilizar simultáneamente todas las copias del SOFTWARE según lo permita el alcance de Su Licencia.

4.4. La cantidad de copias de la Herramienta de diseño que pueden ejecutarse simultáneamente no debe superar la cantidad de copias del SOFTWARE que permite el alcance de Su Licencia.

4.5. Si accede al SOFTWARE mediante Terminal Services, puede ejecutar o utilizar simultáneamente la cantidad de copias del SOFTWARE que permita el alcance de Su Licencia y que estipule este CLUF.

4.6. Puede usar el SOFTWARE para proporcionar servicios de reconocimiento y conversión o para proporcionar los resultados obtenidos mediante el uso del SOFTWARE a cualquier tercero, solo si la Clave de Su Licencia posee el parámetro "Servicios BPO habilitados".

4.7. El usuario indemnizará, no perjudicará y defenderá a ABBYY ante cualquier reclamación, responsabilidad, pérdida, acción, daño o juicio, como también se hará cargo de los honorarios de todos los abogados, que puedan surgir del uso o la dependencia del SOFTWARE o que puedan estar relacionados con ello.

5. SOFTWARE de doble medio

5.1. El SOFTWARE se puede recibir a través de varios medios, incluida la descarga por Internet. Independientemente de la cantidad de medios de los cuales disponga Usted, se le concede la licencia para usar el SOFTWARE de acuerdo con este CLUF.

6. Bases de datos del usuario final

6.1. Puede crear Sus propias bases de datos para los programas que incluye el SOFTWARE si tal función está disponible en este SOFTWARE.

7. Redistribución del SOFTWARE

7.1. Queda totalmente prohibida cualquier redistribución del SOFTWARE, a excepción de lo establecido en el artículo 3.6. La redistribución incluye sin carácter limitativo la venta, el alquiler, el arrendamiento o el préstamo del SOFTWARE.

8. Limitaciones

8.1. Reconoce que el SOFTWARE está protegido contra la copia y el uso no autorizados. A menos que active Su copia del SOFTWARE, no podrá ejercer sus derechos respecto del SOFTWARE conforme a este contrato. Al activar Su copia del SOFTWARE, no se enviará ninguna información personal a ABBYY. La activación se realiza de forma completamente anónima. Durante la activación, se crea un parámetro exclusivo que representa la configuración de Su Ordenador en el momento de la activación. Este parámetro no contiene datos personales, información sobre el software ni ningún otro dato que haya en Su Ordenador, como tampoco información sobre la marca o el modelo específicos de Su Ordenador. Este parámetro identifica al Ordenador solo a fin de activarlo. Junto con este parámetro, se envía a ABBYY el nombre, el número de serie y el número de versión de Su copia del SOFTWARE. Esta información se utiliza únicamente para seleccionar el contenido adecuado para el mensaje que se le enviará a fin de confirmar los resultados de la activación. Ninguno de estos datos se utilizará para otro propósito.

8.2. Todos los términos y las limitaciones de uso del SOFTWARE se establecen en este CLUF, a menos que se haya estipulado lo contrario en un contrato independiente con ABBYY.

8.3. Si el SOFTWARE se encuentra marcado "No destinado a reventa" o "NPR", a pesar de las demás secciones de este CLUF, Su uso del SOFTWARE se limita a los propósitos de demostración, prueba o evaluación, y Usted no puede revender ni transferir de otro modo a cambio de un valor el SOFTWARE ni los resultados obtenidos a través del uso del SOFTWARE.

8.4. No se puede llevar a cabo ninguna de las actividades que se indican a continuación ni permitir que otras personas lo hagan:

8.4.1. Desmontar o desensamblar (es decir, obtener el código de origen a partir del código de objeto) el SOFTWARE (aplicaciones, bases de datos y otros Componentes del SOFTWARE), excepto y solo si lo permite expresamente la ley aplicable, a pesar de esta limitación. Si la ley aplicable permite dichas actividades, cualquier información obtenida por estos métodos no podrá revelarse a terceros en la medida que la ley prohíba la revelación, y deberá comunicarlo de inmediato a ABBYY. Dicha información se considerará confidencial y propiedad de ABBYY.

8.4.2. Modificar, adaptar o traducir el SOFTWARE, así como cambiar el código del objeto de las aplicaciones y las bases de datos del SOFTWARE que no presten conformidad con el SOFTWARE y lo establecido en la documentación.

8.4.3. Alquilar, prestar, otorgar una sublicencia, asignar o transferir cualquier derecho que se le conceda por este CLUF y otros derechos derivados del SOFTWARE a cualquier otra persona, o autorizar la copia total o parcial del SOFTWARE en los Ordenadores de otro usuario, excepto en el caso descrito en el artículo 3.6.

8.4.4. Permitir que cualquier persona no autorizada use el SOFTWARE y trabaje en el mismo sistema de varios usuarios que Usted para utilizar el SOFTWARE.

8.4.5 Eliminar u ocultar cualquier notificación respecto de las leyes de derechos de autor, la marca comercial o la patente que aparezca en el SOFTWARE en el momento de la entrega.

9. Cumplimiento con las licencias

9.1. Usted acuerda que cuando ABBYY o un representante autorizado de ABBYY lo solicite, documentará y certificará en un plazo no mayor a treinta (30) días que acepta los términos y las condiciones de este CLUF.

10. Servicios de Asistencia

10.1. ABBYY o su Proveedor le proporcionarán el Mantenimiento según los términos y las condiciones que se establecen en el Anexo A de este CLUF, a menos que Usted y ABBYY o Usted y el Proveedor de ABBYY hubieran acordado lo contrario.

11. SOFTWARE con fines de prueba

11.1. Si el SOFTWARE tiene la etiqueta "Probar y comprar", "Prueba" o "Demo", entonces, se aplicará esta sección hasta el momento en que Usted adquiera una licencia para obtener la versión completa del SOFTWARE. Reconoce que la funcionalidad o las funciones del SOFTWARE están limitadas durante un determinado período de tiempo. Se concede la licencia del SOFTWARE "tal como es", únicamente como modelo de demostración. Si el SOFTWARE tiene fecha de expiración, significa que su fincionalidad se deshabilitará después de un período de tiempo determinado; este período se especifica en el SOFTWARE. En tal fecha de expiración, se rescindirá la Licencia que se concede por el presente documento, a menos que ABBYY la amplíe como resultado de que Usted solicite una licencia para usar la versión completa del SOFTWARE.

12. Términos y rescisión

12.1. A menos que Usted y ABBYY o Usted y el Proveedor de ABBYY acuerden lo contrario, este CLUF estará vigente hasta que se rescinda. Usted puede rescindir este contrato si destruye el SOFTWARE y la documentación adjunta, así como todas sus copias. Sin perjuicio de ningún otro derecho, ABBYY puede rescindir este CLUF si Usted no cumple los términos y condiciones. En tal caso, Usted deberá destruir todas las copias del SOFTWARE y todos los Componentes de SOFTWARE. Dicha rescisión no le libera de Su obligación de pagar el SOFTWARE y el Mantenimiento.

12.2. Las disposiciones 3.3–3.5, 3.8, 3.9, 4.7, 7, 8, 11, 13.2–13.4, 14–21, 23 y 24 seguirán vigentes tras la rescisión de este CLUF, independientemente de cuál sea el motivo. No obstante, esto no implicará ni creará ningún derecho continuado de utilizar el SOFTWARE una vez rescindido el CLUF.

13. Garantía limitada

13.1. ABBYY garantiza que los medios en los que se proporciona el SOFTWARE carecen de defectos de material o de fabricación siempre que se haga un uso normal durante el período de tiempo mínimo estipulado por la legislación del país en el que se haya adquirido el SOFTWARE y a partir de la fecha de adquisición.

13.2. El SOFTWARE, las actualizaciones, las mejoras y el Mantenimiento se le entregarán "tal como son" y ABBYY no ofrece garantías de ningún tipo. ABBYY y sus Proveedores no garantizan ni pueden garantizar el rendimiento o los resultados que Usted puede obtener del uso del SOFTWARE.
Salvo que no se pueda negar ni limitar al usuario cualquier garantía, condición, representación o término según la ley aplicable a su jurisdicción, ABBYY y sus Proveedores no conceden garantías, condiciones, representaciones ni términos (explícitos o implícitos por ley, derecho consuetudinario, costumbre, uso o de cualquier tipo) con respecto a ningún ámbito, incluida sin carácter limitativo, la no violación de derechos de terceros, comerciabilidad, integración, calidad satisfactoria o idoneidad para un fin concreto, ni garantiza que el SOFTWARE no contenga errores, que cumpla Sus requisitos o que funcione correctamente cuando lo utilice junto con cualquier otro hardware o software. Todo el riesgo relativo a la calidad y el rendimiento del SOFTWARE recaerá sobre Usted.

13.3. ABBYY no garantiza ningún producto de software de terceros que se pueda suministrar con el SOFTWARE.

13.4. Garantía limitada para los usuarios residentes de Alemania o Austria.
Si ha obtenido Su copia del SOFTWARE en Alemania o Austria y habitualmente reside en estos países, ABBYY y sus Proveedores garantizan, de acuerdo con la ley alemana, que el SOFTWARE proporciona las funciones establecidas en su documentación (las "funcionalidades acordadas") durante el período de la garantía limitada, que comienza a partir de la recepción de la copia del SOFTWARE, siempre y cuando se la utilice con la configuración de hardware recomendada. Tal como se usa en este artículo, el "período de garantía limitada" significa un (1) año si Usted es un usuario de una empresa o entidad jurídica y dos (2) años si no lo es. No se tendrá en cuenta ninguna variación no sustancial de las funcionalidades acordadas ni se establecerán por ello derechos de garantías. Esta garantía limitada no se aplica al SOFTWARE obtenido por Usted de forma gratuita; por ejemplo, las actualizaciones, las versiones previas al lanzamiento, las versiones de "Prueba", las muestras de productos, las copias "No para reventa (NPR)" del SOFTWARE y el SOFTWARE modificado por Usted, en la medida en que dichas modificaciones hayan causado un defecto. Para presentar una reclamación respecto de la garantía, debe devolver, durante el período de garantía limitado y a cargo de ABBYY, el SOFTWARE y el comprobante de compra al establecimiento donde lo obtuvo. Si las funcionalidades del SOFTWARE varían notablemente de las funcionalidades acordadas, ABBYY reparará o sustituirá el SOFTWARE, a fin de mejorar su rendimiento y según su propio criterio. Si no lo consigue, Usted tiene derecho de reducir el precio de compra (descuento) o de cancelar el contrato de compra (rescisión). Para obtener más información relativa a la garantía, póngase en contacto con el Departamento de Asistencia al Cliente de ABBYY en Alemania: ABBYY Europe GmbH, Elsenheimerstrabe 49, 80687 Múnich. Tel.: +49 (0)89 51 11 590. Fax: +49 (0)89 51 11 5959.

14. Limitación de la responsabilidad

14.1. En ninguna circunstancia ABBYY o sus Proveedores se harán responsables ante Usted de los daños, la interrupción de la actividad comercial, la pérdida de datos o de información de cualquier tipo u otro tipo de pérdida comercial, como tampoco de reclamaciones o costes de cualquier índole, ni de los daños consecuentes, indirectos, incidentales o la pérdida de ganancias comerciales que resulten del uso del SOFTWARE o que estén relacionados con él. Tampoco se hará responsable de los daños ocasionados por posibles errores o erratas del SOFTWARE, incluso si un representante de ABBYY ha sido advertido de la posibilidad de que se produzcan estos daños, pérdidas, reclamaciones o costes por algún tercero. Las limitaciones y exclusiones anteriores se aplican en la medida que lo permita la ley vigente en Su jurisdicción. La única y máxima responsabilidad de ABBYY y sus Proveedores en conformidad con este CLUF se limita al precio de compra pagado originalmente por el SOFTWARE, si corresponde. Ningún artículo de este CLUF limita la responsabilidad de ABBYY ante Usted en el caso de muerte o lesiones físicas que surjan a partir de un acto negligente o ilícito (fraude) por parte de ABBYY. ABBYY responderá por sus Proveedores ante la renuncia, exclusión o limitación de obligaciones, garantías y responsabilidad, tal como se establece en el presente CLUF, pero en ninguna otra circunstancia ni por ningún otro motivo. Si desea obtener más información, consulte la sección específica sobre la jurisdicción en el artículo 21 de este CLUF, si corresponde, o comuníquese con el departamento de asistencia al cliente de ABBYY.

14.2. Limitación de responsabilidad para los usuarios residentes de Alemania o Austria.
Si ha obtenido Su copia del SOFTWARE en Alemania o Austria y habitualmente reside en estos países:

14.2.1. De acuerdo con las disposiciones del artículo 14.2.2, la responsabilidad legal de ABBYY y sus Proveedores por daños presentan las siguientes limitaciones: (I) ABBYY solo se hará responsable hasta por una cantidad normalmente predecible en el momento de la firma del contrato de compra en lo concerniente a los daños debidos a un incumplimiento ligeramente negligente de una obligación contractual material, y (II) ABBYY no se hará responsable de los daños debidos a un incumplimiento ligeramente negligente de una obligación contractual no material.

14.2.2. La limitación de responsabilidad establecida en el apartado 14.2.1 no se aplicará a ninguna responsabilidad legal obligatoria, específicamente, a la responsabilidad establecida por la ley de responsabilidad por productos de Alemania ("German Product Liability Act"), la responsabilidad de asumir una garantía concreta o la responsabilidad de lesiones físicas de los que se considera el causante.

14.2.3. Usted está obligado a tomar todas las medidas razonables para evitar y reducir los daños, específicamente, a realizar copias de seguridad del SOFTWARE y los datos de Su ordenador, de acuerdo con las disposiciones de este CLUF.

15. Fuentes incorporadas

15.1. Los programas de fuentes están sujetos a las leyes de derechos de autor, y el propietario de estos derechos puede imponer condiciones para el uso de estos programas. Una de las condiciones podría ser que Usted necesite una copia con licencia del programa de fuentes para incorporar la fuente en un archivo PDF. En ningún caso ABBYY se hace responsable de los daños que puedan estar relacionados con la forma en que Usted usa las fuentes incorporadas.

16. Adobe® PDF Library

16.1. "Software Adobe" hace referencia a Adobe ® PDF Library para Windows 2000, XP y a la documentación, las mejoras, las versiones modificadas, las actualizaciones, las adiciones y las copias relacionadas a este software. El SOFTWARE utiliza el Software Adobe para convertir archivos PDF en archivos de imagen.

16.2. Restricciones y concesión de licencia. ABBYY le concede a Usted un derecho no exclusivo de utilizar el Software Adobe incorporado al SOFTWARE de acuerdo con los términos de este CLUF. Puede hacer una copia de seguridad del Software Adobe incorporado al SOFTWARE, siempre que la copia de seguridad no se instale ni se utilice en ningún Ordenador.

16.3. Derechos de propiedad intelectual. El Software Adobe incorporado al SOFTWARE es propiedad de Adobe y sus proveedores, y su estructura, organización y código son los valiosos secretos comerciales de Adobe y sus proveedores. El Software Adobe, además, está protegido por las leyes de derechos de autor de los Estados Unidos y por tratados internacionales. No podrá copiar el Software Adobe incorporado al SOFTWARE, excepto en los casos establecidos en este CLUF. Las copias permitidas según este CLUF deben contener las mismas notificaciones sobre leyes de derechos de autor y propiedad que aparecen en el SOFTWARE. Usted acepta no modificar, adaptar, traducir, aplicar ingeniería inversa, desensamblar, desmontar ni tratar de descubrir de otro modo el código de origen del Software Adobe incorporado al SOFTWARE. Excepto en los casos mencionados anteriormente, este CLUF no le concede ningún derecho de propiedad intelectual sobre el Software Adobe.

16.4. Licencia de fuentes. Si el SOFTWARE o el Software Adobe incorporado al SOFTWARE incluyen software de fuentes, Usted puede incorporar el software de fuentes, o esquemas del mismo, en Sus documentos electrónicos en la medida que lo permita el propietario de los derechos de autor del proveedor de fuentes. Este paquete puede contener fuentes de Adobe y de otros propietarios. Podrá incorporar por completo cualquier fuente de Adobe.

16.5. Garantía. ABBYY NO GARANTIZA NI PUEDE GARANTIZAR LOS RESULTADOS DEL RENDIMIENTO QUE PUEDA OBTENER CON EL USO DEL SOFTWARE ADOBE INCORPORADO AL SOFTWARE.

16.6. Normas de exportación. Usted acepta que el Software Adobe incorporado al SOFTWARE no se enviará, transferirá ni exportará a ningún país, ni se utilizará de ningún modo que esté prohibido por las leyes de administración de la exportación de los Estados Unidos u otras leyes, restricciones o reglamentaciones relativas a la exportación (en adelante "Leyes de exportación"). Asimismo, si el Software Adobe incorporado al SOFTWARE se considera material controlado para la exportación según las Leyes de exportación, Usted declara y garantiza que no es un ciudadano de una nación con bloqueo económico, ni reside en ella, y que no se le ha prohibido de ningún otro modo, de acuerdo con las Leyes de exportación, recibir el Software Adobe incorporado al SOFTWARE. Todos los derechos de uso del Software Adobe incorporado al SOFTWARE se conceden con la condición de que, si no se cumplen los términos de este contrato, estos derechos se perderán.

16.7. Marcas comerciales. Adobe y Adobe PDF Library son marcas comerciales registradas o marcas comerciales de Adobe Systems Incorporated en los Estados Unidos o en otros países.

17. Microsoft XML Core Services

17.1. El Software utiliza Microsoft XML Core Services (MSXML) para analizar y procesar documentos XML.

17.2. Software Identificado. Sus derechos de licencia con respecto al SOFTWARE están condicionados por (a) la no incorporación o combinación del Software Identificado con MSXML o un trabajo derivado; (b) la no distribución del Software Identificado junto con MSXML; y (c) el no uso del Software Identificado en el desarrollo de trabajos derivados de MSXML. "Software identificado" hace referencia al software concedido bajo licencia conforme a los términos que directa o indirectamente (I) crean o pretenden crear obligaciones para Microsoft en relación con MSXML o trabajos derivados o (II) conceden o pretenden conceder a cualquier tercero derechos o inmunidades según los derechos de propiedad intelectual de Microsoft o los derechos de propiedad de MSXML o trabajos derivados del mismo. El Software Identificado incluye sin carácter limitativo cualquier software que requiera como condición de uso la modificación o distribución de tal software, que otro software incorporado, derivado o distribuido con tal software (a) se divulgue o se distribuya en forma de código de origen; (b) obtenga una licencia con el propósito de realizar trabajos derivados; o (c) se redistribuya sin cargo.

18. Bibliotecas de tiempo de ejecución de la digitalización PixTools® y controladores ISIS®

18.1. "Software Captiva" hace referencia a las bibliotecas de tiempo de ejecución de la digitalización, los controladores ISIS de Nivel 1, los controladores ISIS de Nivel 2 y los controladores ISIS de Nivel 3. El SOFTWARE utiliza Software Captiva para establecer la comunicación entre el escáner y el SOFTWARE a través de la interfaz ISIS.

18.2. Restricciones y concesión de licencia. ABBYY le concede a Usted un derecho no exclusivo de utilizar el Software Captiva incorporado al SOFTWARE de acuerdo con los términos de este CLUF.

18.3. Derechos de propiedad intelectual. El Software Captiva incorporado al SOFTWARE es propiedad de Captiva y sus proveedores, y su estructura, organización y código son los valiosos secretos comerciales de Captiva y sus proveedores. El Software Captiva está protegido por las leyes de derechos de autor de los Estados Unidos y por tratados internacionales. No debe copiar el Software Captiva incorporado al SOFTWARE. Usted acepta no modificar, adaptar, traducir, aplicar ingeniería inversa, desensamblar, desmontar ni tratar de descubrir de otro modo el código de origen del Software Captiva incorporado al SOFTWARE. Excepto en los casos mencionados anteriormente, este CLUF no le concede ningún derecho de propiedad intelectual sobre el Software Captiva.

18.4. Garantía.
ABBYY NO GARANTIZA NI PUEDE GARANTIZAR LOS RESULTADOS DEL RENDIMIENTO QUE PUEDA OBTENER CON EL USO DEL SOFTWARE CAPTIVA INCORPORADO AL SOFTWARE.
EN NINGÚN CASO CAPTIVA NI SUS PROVEEDORES SERÁN RESPONSABLES DE LOS DAÑOS CONSECUENTES, INCIDENTALES O ESPECIALES, ENTRE ELLOS, LA PÉRDIDA DE GANANCIAS COMERCIALES O CUALQUIER RECLAMACIÓN DE TERCEROS.
Algunos estados o algunas jurisdicciones no permiten la exclusión ni la limitación de los daños incidentales, consecuentes o especiales, por lo que las limitaciones anteriores pueden no aplicarse en Su caso. Es posible que tenga otros derechos, que varían según el estado o la jurisdicción en que se encuentre.

18.5. Marcas comerciales.
ISIS y PixTools son marcas comerciales registradas o marcas comerciales de Captiva Software Corporation en los Estados Unidos y en otros países.

19. SOFTWARE LIZARDTECH

19.1. “SOFTWARE LIZARDTECH” hace referencia a DjVu Decoder Software Development Kit de LIZARDTECH, como también a cualquier medio, material impreso y documentación electrónica o "en línea" relacionados. Usted adquirió el SOFTWARE que incluye el SOFTWARE LIZARDTECH con licencia LIZARDTECH, INC. otorgada por ABBYY. El SOFTWARE utiliza el SOFTWARE LIZARDTECH para convertir archivos DjVu en archivos de imagen.

19.2. El SOFTWARE LIZARDTECH está protegido por leyes de derechos de autor y por tratados internacionales sobre los derechos de autor, como también por otras leyes y tratados sobre la propiedad intelectual. El SOFTWARE LIZARDTECH se otorga bajo licencia, no se vende.

19.3. Concesión de licencia. Se le otorga una licencia personal, no sublicenciable, intransferible y no exclusiva para utilizar el SOFTWARE LIZARDTECH incorporado al SOFTWARE (como también cualquier otra documentación relacionada). No alquilará, venderá, prestará ni distribuirá de ningún otro modo el SOFTWARE LIZARDTECH ni una parte de él.

19.4. SOFTWARE LIZARDTECH SIN GARANTÍAS. El SOFTWARE LIZARDTECH se proporciona “TAL COMO ES” y con todas las fallas. TODO EL RIESGO EN RELACIÓN CON LA CALIDAD SATISFACTORIA, RENDIMIENTO, PRECISIÓN Y ESFUERZO (INCLUIDA LA FALTA DE NEGLIGENCIA) RECAE SOBRE USTED. ASIMISMO, NO HAY GARANTÍA RELACIONADA CON LA INTERFERENCIA EN LA FORMA EN QUE USTED DISFRUTE DEL SOFTWARE LIZARDTECH NI CON LAS INFRACCIONES. SI RECIBIÓ GARANTÍAS EN RELACIÓN CON EL SOFTWARE O EL SOFTWARE LIZARDTECH, ESAS GARANTÍAS NO SE ORIGINAN EN LIZARDTECH NI LO VINCULAN. SIN RESPONSABILIDAD DE CIERTOS DAÑOS. SALVO QUE LA LEY LO PROHÍBA, LIZARDTECH NO SERÁ RESPONSABLE DE NINGÚN DAÑO INDIRECTO, ESPECIAL, CONSECUENTE O INCIDENTAL QUE SURJA DEL USO O EL RENDIMIENTO DEL SOFTWARE LIZARDTECH O QUE PUDIERA RELACIONARSE CON ESTO. ESTA LIMITACIÓN SE APLICA INCLUSO SI FALLA CUALQUIER SOLUCIÓN Y NO LOGRA SU PROPÓSITO FUNDAMENTAL.

19.5. Limitaciones sobre la ingeniería inversa, el desensamblaje y el desmontaje. No puede realizar ingeniería inversa, desensamblar ni desmontar el SOFTWARE LIZARDTECH, en la medida que lo permita expresamente la legislación pertinente, a pesar de esta limitación.

19.6. Restricciones de exportación. Reconoce que el SOFTWARE LIZARDTECH, cualquier parte de él o cualquier proceso o servicio que sea producto directo del SOFTWARE LIZARDTECH (denominados colectivamente "Componentes restringidos") son de origen estadounidense. Acepta cumplir con todas las leyes nacionales e internacionales que se apliquen a esos productos, incluidas las normas de administración de la exportación de los Estados Unidos, como también las restricciones para el usuario final, el uso final y el destino emitidas por los Estados Unidos y otros gobiernos.

20. Pruebas comparativas

20.1. No debe divulgar los resultados de las pruebas comparativas que realiza con el SOFTWARE a ningún tercero sin la aprobación previa por escrito de ABBYY.

21. Normas de exportación

21.1. El SOFTWARE no se podrá exportar ni volver a exportar si esto viola cualquier disposición de exportación de las leyes del país en el que se haya adquirido u obtenido. Asimismo, Usted declara y garantiza que ninguna ley aplicable le prohíbe recibir el SOFTWARE.

22. Jurisprudencia

22.1. Si el SOFTWARE se adquirió en los Estados Unidos, Canadá, México, América Central, Japón o Taiwán, este CLUF se regirá e interpretará conforme a las leyes del estado de California, Estados Unidos. Cualquier disputa que pudiese surgir en relación con este CLUF o con el SOFTWARE se someterá a la jurisdicción y competencia de los juzgados federales o estatales del condado de Alameda o Santa Clara, en el estado de California.

22.2. Si el SOFTWARE se adquirió en Austria, Bélgica, Dinamarca, Finlandia, Francia, Alemania, Grecia, Irlanda, Italia, Luxemburgo, Países Bajos, Portugal, España, Suecia, Reino Unido o cualquier otro país miembro de la Unión Europea que no conste en los artículos 22.3 ó 22.4 de este contrato, o en Suiza, Noruega, Islandia o Liechtenstein, el presente CLUF se regirá e interpretará conforme a las leyes fundamentales vigentes en Múnich, República Federal de Alemania, y el juzgado con jurisdicción en Múnich, República Federal de Alemania, será el encargado de dirimir todas las disputas relacionadas con este CLUF.

22.3. Si el SOFTWARE se adquirió en Rusia, Bielorrusia, Kazajstán o cualquier otro país perteneciente a la Comunidad de Estados Independientes (CEI), excepto Ucrania y Moldavia, o si se adquirió en Letonia, Lituania o Estonia, el presente CLUF se regirá e interpretará conforme a las leyes fundamentales vigentes en la Federación Rusa.

22.4. Si el SOFTWARE se adquirió en Albania, Bosnia y Herzegovina, Bulgaria, Croacia, Chipre, República Checa, Hungría, Israel, Macedonia, Malta, Polonia, Rumanía, Eslovaquia, Eslovenia, Turquía, Serbia, Montenegro, Ucrania o Moldavia, el presente CLUF se regirá e interpretará conforme a la legislación de Ucrania.

22.5. En caso de que se aplique el artículo 22.3 y que Usted sea una entidad jurídica o un comerciante privado, el tribunal de arbitraje de Moscú, Federación Rusa, tendrá jurisdicción sobre todas las disputas relacionadas con este CLUF. En caso de que se aplique el artículo 22.3 y de que Usted sea un individuo independiente, el tribunal de distrito de Lublinsky, en Moscú, Federación Rusa, tendrá jurisdicción sobre todas las disputas relacionadas con este CLUF.

22.6. En los casos que se mencionan en los artículos 22.1-22.4, este contrato no se regirá por conflictos con las disposiciones de la ley de ninguna jurisdicción ni por la Convención de las Naciones Unidas sobre contratos de compraventa internacional de mercaderías, cuya aplicación está expresamente excluida.

22.7. Si el SOFTWARE se adquiere en un país distinto de los enumerados en los artículos 22.1-22.4, este CLUF se regirá e interpretará conforme a las leyes fundamentales vigentes en el país donde se adquiera el SOFTWARE.

23. Varios

23.1. Si Usted recibió esta copia del SOFTWARE como una mejora de la versión actual del SOFTWARE o como una actualización importante de la versión del SOFTWARE, al instalar esta copia del SOFTWARE, Usted renuncia voluntariamente a sus derechos relacionados con cualquier versión anterior del SOFTWARE, entre ellos, el derecho de uso de ese SOFTWARE. Reconoce que cualquier obligación de ofrecer asistencia para las versiones anteriores del SOFTWARE que ABBYY o sus Proveedores pudieran tener finalizarán cuando se encuentre disponible esta versión del SOFTWARE.

23.2. Si Usted ha adquirido el SOFTWARE por Internet (incluidas las versiones "No para reventa" y de "Mejora"), ABBYY no le proporcionará ningún material impreso, ni siquiera el Manual del usuario.

24. Uso gubernamental

24.1. Si el Gobierno de los Estados Unidos o cualquiera de sus organismos o instituciones utiliza el SOFTWARE, se aplicarán los siguientes términos adicionales: (1) Software de ordenador restringido, tal como se define en la cláusula general de derechos de datos en el artículo 52.227-14 de la reglamentación federal sobre adquisiciones y (2) cualquier uso, duplicado o revelación por parte del Gobierno están sujetos a las restricciones establecidas en el subapartado (c)(1)(II) de la cláusula sobre derechos de datos técnicos y software de ordenador de DFARS 252.227-7013.

25. Disposiciones generales

25.1. Si alguna parte de este CLUF se considera nula o no aplicable, esto no afectará la validez del resto del CLUF, que permanecerá aplicable según sus términos. Este CLUF no perjudicará los derechos establecidos por la ley de ninguna de las partes que actúe como cliente.

Anexo A

Contrato de Mantenimiento

Este Anexo A será una parte integral del CLUF, a menos que se estipule lo contrario en un contrato independiente con ABBYY.

1. Definiciones

1.1. "Actualización" hace referencia a las mejoras para la versión actual del SOFTWARE.

1.2. "Mejora" hace referencia al siguiente lanzamiento del SOFTWARE para reemplazar la versión principal (por ejemplo, 2.x reemplazará a 1.x) de la que actualmente se le otorga licencia en el CLUF.

1.3. "Error" hace referencia a cualquier error del SOFTWARE de acuerdo con las especificaciones que se enumeran en la documentación. Se reconocerán los siguientes tres tipos de Error:

1.3.1. Un Error de prioridad 1 hace referencia a situaciones problemáticas donde no se encuentran disponibles soluciones temporales para Usted y se interrumpe la producción en Su sitio, incluidos los Errores que muestren los mensajes "Error interno del programa", "Memoria insuficiente", "Violación de acceso", "Falla de protección general" y "División por cero".

1.3.2. Un Error de prioridad 2 hace referencia a un error para el cual se encuentra disponible una solución temporal.

1.3.3. Un Error de prioridad 3 es un problema menor que no interfiere en la producción en Su sitio.

1.4. "Servicios de Asistencia" hace referencia a los servicios que ABBYY o sus Proveedores le proporcionan por los Errores que Usted informa.

1.5. "Garantía de Mejoras" hace referencia a la parte del Mantenimiento que le concede a Usted el derecho de recibir Mejoras.

2. Mantenimiento

2.1. El Mantenimiento puede incluir la entrega de Actualizaciones, la Garantía de Mejoras y los Servicios de Asistencia o cualquier combinación entre ellos. Usted debe adquirir el Mantenimiento para el período inicial de doce (12) meses que comienza a partir de la fecha de envío o entrega del SOFTWARE. Para extender el período de Mantenimiento, debe solicitar tal extensión a ABBYY o a su Proveedor. ABBYY se reserva el derecho de cambiar periódicamente la forma y el contenido del Mantenimiento, a su entera discreción. Cualquier código complementario del SOFTWARE que se le proporcione en calidad de Mantenimiento se considera parte del SOFTWARE y está sujeto a los términos y las condiciones de este CLUF.

3. Garantía de Mejoras y Actualizaciones

3.1. Las Actualizaciones y las Mejoras se enviarán en el CD-ROM o en formato electrónico (a través de FTP). Los costes de envío, si corresponde, estarán a Su cargo.

3.2. Si adquirió la parte de la Actualización del Mantenimiento, tiene el derecho de recibir Actualizaciones por parte de ABBYY o sus Proveedores. ABBYY o sus Proveedores le proporcionarán Actualizaciones para el SOFTWARE tan pronto como se encuentren disponibles.

3.3. Si adquirió la parte de la Garantía de Mejoras del Mantenimiento, tiene el derecho de recibir Mejoras por parte de ABBYY o sus Proveedores. ABBYY o sus Proveedores le proporcionarán Mejoras para el SOFTWARE tan pronto como se encuentren disponibles.

3.4. Si Usted desarrolla una aplicación que contiene el SOFTWARE, partes del SOFTWARE o que está incorporada al SOFTWARE, cualquier nuevo gran lanzamiento de esta aplicación incluirá la última Actualización del SOFTWARE que ABBYY le proporcionó antes de los tres (3) meses del lanzamiento (o la última Actualización, si se lanzó más de tres (3) meses antes del lanzamiento).

4. Servicios de Asistencia

4.1. ABBYY o su Proveedor le proporcionará Servicios de Asistencia gratuitos para solucionar Errores de prioridad 1.

4.2. Si adquirió la parte de los Servicios de Asistencia del Mantenimiento, ABBYY o su Proveedor le proporcionarán Servicios de Asistencia hasta para ocho (8) solicitudes que incluyan Errores de prioridad 2 y 3. Los Servicios de Asistencia para cualquier solicitud adicional que incluya Errores de prioridad 2 y 3 deberán adquirirse por separado.

4.3. ABBYY o su Proveedor proporcionará los Servicios de Asistencia relacionados con el SOFTWARE durante horas laborales normales por teléfono o correo electrónico.

4.4. ABBYY o su Proveedor acuerda realizar esfuerzos comercialmente razonables para brindar Actualizaciones de emergencia para el SOFTWARE fuera de la programación normal de lanzamiento, con el fin de solucionar cualquier Error de prioridad 1 que se haya informado. En el curso normal de los acontecimientos, los Errores de prioridad 2 y 3 pueden solucionarse en versiones siguientes. Las Actualizaciones de emergencia solo se ofrecerán para la versión actual del SOFTWARE a fin de solucionar Errores de prioridad 1.

4.5. Al informar los Errores, Usted acepta proporcionar a ABBYY o a su Proveedor la información de respaldo necesaria para localizar el Error y determinar la reparación y la solución temporal de ese error. La información de respaldo deberá incluir una descripción del problema, la identificación de la plataforma y el sistema operativo en los que se produjo el problema, una copia de los datos que hicieron que se descubriera el Error, una copia del archivo de formato en uso cuando se descubrió el Error y cualquier volcado del equipo que se haya producido a causa del Error. ABBYY o su Proveedor puede utilizar la información antes proporcionada con fines comerciales, incluidos sin carácter limitativo, el desarrollo del producto y la asistencia técnica. Ni ABBYY ni su Proveedor utilizará esa información de manera que lo identifique a Usted personalmente.


Propiedades básicas del campo

Puede configurar las propiedades básicas del campo en la ficha General.

En esta ficha, el tipo de campo se muestra como un icono ubicado a la derecha del nombre.

  • Nombre: nombre del campo. El nombre se asigna automáticamente cuando se crea el campo y corresponde al texto explicativo más próximo al campo. Al editar las propiedades, puede cambiar el nombre asignado de manera predeterminada. Consulte también Cómo cambiar el nombre del campo.
  • Título: el nombre del campo que se mostrará en el formulario de datos.
  • Exportar valor del campo: esta opción debe estar habilitada si desea exportar el valor del campo (habilitada de manera predeterminada). Es posible que necesite deshabilitar esta opción si, por ejemplo, el valor de este campo se usa para obtener el valor de un campo calculado (consulte Validación de regla) y solo debe exportarse el resultado final.
  • Mostrar en formulario de datos: esta opción debe habilitarse si el campo debe mostrarse en el formulario de datos (habilitada de manera predeterminada).
  • No puede estar vacío: habilite esta opción si desea convertirla en un campo obligatorio.
  • Sólo lectura: habilite esta opción si el campo solo debe estar disponible para la visualización; es decir, el operador no podrá modificar su valor. Puede habilitar esta opción para los campos cuyos valores deben calcularse automáticamente a través de una regla; por ejemplo, para un campo en el que planea guardar la suma o combinar otros campos (consulte Validación de regla).
  • Campo Índice: habilite esta opción si cree que utilizará este campo para realizar la indexación de documentos. Al procesar documentos, podrá ver el valor de este campo para cada documento, así como ordenar y buscar los documentos según el valor del campo.
  • Comentario: puede introducir cualquier comentario.

Propiedades del campo


Glosario

A

ABBYY FlexiCapture

Solución de software para la recepción de datos de flujo único de varios tipos de documento: estructurados (formularios fijos), semiestructurados (documentos y formularios flexibles) y sin estructura (documentos de formato libre).

ABBYY FlexiLayout Studio

Programa que le permite crear una descripción flexible de la estructura del documento, que luego puede utilizarse para el reconocimiento automático de documentos.

ABBYY FormDesigner

ABBYY FormDesigner se utiliza para crear diseños de formularios legibles por máquina. Una vez que estos formularios se duplican y se completan, se los puede procesar con el sistema automatizado de recepción de formularios de ABBYY FlexiCapture. La creación del diseño de un formulario es una etapa importante, ya que la calidad del diseño (su legibilidad por máquina) determina la eficacia de todas las etapas de procesamiento subsiguientes: digitalización, reconocimiento, verificación y exportación.

ADF

Alimentador automático de documentos (Automatic Document Feeder). Dispositivo para la alimentación automática de documentos que le permite digitalizar cualquier cantidad de documentos sin la necesidad de realizar operaciones manuales adicionales.

Adjunto

Páginas que no contienen campos, pero que están incluidas en el ensamblaje del documento. No se extraen datos de estas páginas, pero pueden guardarse como imágenes o como archivos PDF para búsquedas. Consulte Creación de plantillas para documentos con adjuntos.

Administrador

Usuario de ABBYY FlexiCapture que está autorizado para configurar el programa para la recepción de documentos: creación y edición de plantillas de documento y perfiles de importación. Consulte Modos de administrador y operador.

Alfabeto

Conjunto de caracteres utilizados en el idioma que se describe.

Ángulo

Delimitador con forma de ángulo.

Archivo de descripción

Archivo auxiliar que define cómo se forma un lote cuando se agregan imágenes de una carpeta dinámica. Para obtener detalles, consulte Archivo de descripción.

Asociación de plantillas

Proceso de selección de una plantilla y de asociación de los campos de la plantilla con una imagen.

B

Brillo

Umbral de sensibilidad de la luz que determina el punto en el que el escáner detecta los semitonos de la escala de grises como blanco.

C

Campo

Elemento de un documento diseñado para la extracción de datos. Los campos pueden ser simples (sin una estructura interna) o compuestos, como el campo de tabla en el que cada celda puede verse como un campo subordinado diferente de la tabla. Consulte Creación de campos de una plantilla de documento.

Campo clave

Campo que permite la comprobación automática del ensamblaje de página en documentos. Los valores de los campos clave deben ser idénticos en todas las páginas del mismo documento.

Campo con varias instancias

Campo que se utiliza para describir varios objetos del mismo tipo (objetos recurrentes). Básicamente, estos objetos múltiples conforman el mismo campo y comparten las mismas propiedades. Los campos con varias instancias se utilizan para evitar la necesidad de crear varios campos idénticos. Los campos con varias instancias se exportan a tablas de bases de datos o archivos independientes. Consulte Campos con varias instancias.

Campo con varias regiones

Campo que contiene varias regiones en la imagen. Estas regiones pueden ubicarse a cierta distancia una de otra, e incluso pueden estar en páginas diferentes. Los valores de todas las regiones que pertenecen al mismo campo se combinan y se exportan juntas como un campo. Normalmente se utilizan para objetos ubicados en varias páginas, como tablas grandes. Consulte Campos con varias regiones.

Campo de código de barras

Campo de una plantilla que contiene un código de barras diseñado para el reconocimiento.

Campo de entrada manual

Campo de una plantilla que contiene texto irreconocible (por ejemplo, texto que consiste en letras combinadas) que se debe introducir desde el teclado.

Campo de grupo de marcas de verificación

Campo de una plantilla de documento que contiene un grupo de marcas de verificación.

Campo de imagen

Campo de una plantilla que contiene un imagen.

Campo de índice

Campo cuyo valor se utiliza para indexar documentos con fines de clasificación y búsqueda. Consulte Campos de índice.

Campo de marca de verificación

Campo de una plantilla que contiene una marca de verificación.

Campo de tabla

Campo de una plantilla que contiene una tabla. Es un campo compuesto, en el que cada columna de la tabla representa un conjunto de campos del mismo tipo: texto, marcas de verificación, códigos de barras o imágenes.

Campo de texto

Elemento de un formulario legible por máquina diseñado para introducir texto al completar un formulario.

Campo sin región

Campo que se detecta en una plantilla de documento pero que no posee una región en la imagen. Consulte Campos sin región.

Carácter mal reconocido

Estado que se asigna automáticamente a un carácter en el proceso de reconocimiento si se ha reconocido con una notable falta de certeza.

Carácter omitido

Carácter que aparece dentro de las palabras (por ejemplo, una viñeta) o un guión (tabulación, etc.) cuya presencia no evita que el programa atribuya la palabra a un tipo de datos reconocible. Detalles...

Esos caracteres se excluyen de las palabras; es decir, las palabras se atribuyen a tipos de datos particulares sin esos caracteres.

Carácter prohibido

Carácter del que tiene la certeza que no aparecerá en los datos que se están reconociendo. Detalles...

La especificación de esos caracteres puede aumentar notablemente la velocidad y la calidad del reconocimiento. Por ejemplo, al reconocer textos que solo tienen letras mayúsculas, especifique todas las letras minúsculas como caracteres prohibidos.

Carpeta dinámica

Carpeta en el disco duro de un ordenador local o remoto que se utiliza para importar imágenes. Normalmente se utiliza para cargas periódicas de imágenes sin la participación del usuario. Consulte Perfiles de importación de imágenes.

Contraste

Relación entre el brillo de las áreas más oscuras y las áreas más claras de una imagen.

Código de barras

Elemento de un formulario legible por máquina representado por barras alternadas blancas y negras de cierta longitud, que codifican información digital. Un código de barras en un documento puede utilizarse para extraer información (campo de código de barras) o para asociar e identificar una plantilla (código de barras del delimitador).

Código de barras del delimitador

Elemento estático que representa un código de barras que no está diseñado para la extracción de datos. El código de barras de un delimitador se puede utilizar para la asociación o identificación de plantillas.

Conjunto de caracteres permitidos

Conjunto de caracteres que aparecen en el tipo de datos que se está reconociendo. Detalles...

Este conjunto está determinado por el tipo de datos. Es decir, el tipo de datos adjuntos a un campo determina el conjunto de caracteres que se utiliza durante el reconocimiento.

Además de seleccionar los caracteres de este conjunto, puede configurar parámetros adicionales para limitar este conjunto. Por ejemplo, puede especificar:

  • Caracteres que usted sabe que no aparecerán al reconocer un campo determinado: caracteres prohibidos (por ejemplo, puede especificar todas las letras minúsculas como prohibidas para un campo donde solo puede haber letras mayúsculas).
  • Caracteres que pueden aparecer dentro de palabras sin afectar la verificación: caracteres omitidos (por ejemplo, guiones, acentos, etc.).

Cruz

Delimitador con forma de cruz.

Cuadrado negro

Delimitador en forma de cuadrado negro.

D

Datos del documento

Datos capturados después del procesamiento (reconocimiento, verificación y edición de los resultados del reconocimiento) de imágenes de página del documento.

Delimitador

Elemento estático en forma de cuadrado, rectángulo, cruz o esquina negros para la asociación de plantillas. Detalles...

Los delimitadores son elementos especiales de diseño de formularios que utiliza el sistema para realizar la asociación después de la digitalización (elimina la inclinación, compensa defectos lineales y no lineales de la digitalización, calcula la ubicación de los bloques). Los delimitadores más confiables son cuadrados negros que normalmente se ubican en las esquinas de un formulario. Si no hay delimitadores especiales en la imagen, pueden utilizarse otros elementos estáticos para asociar la plantilla: separadores; por ejemplo, líneas verticales y horizontales, tales como líneas de tablas, marcos, etc., o texto estático claro, a saber: encabezado del formulario, firmas de campo, información explicativa, etc. La opción Utilizar para asociar plantillas debe habilitarse para los elementos estáticos que se utilizan para la asociación de plantillas.

Descripción flexible

Descripción formal de la estructura del documento, diseñada para ayudar a detectar campos. Creada con ABBYY FlexiLayout Studio. Formato de archivo: *.afl. Consulte FlexiLayout.

Diccionario

Lista de palabras que se utilizan para determinar un tipo de datos específico. Detalles...

El diccionario se especifica al crear un tipo de datos. Como resultado, el tipo de datos adjunto a un campo determina el diccionario que se utiliza durante el reconocimiento y la verificación. Además de los tipos de datos predeterminados con diccionarios listos, el programa le permite adjuntar tipos de datos creados sobre la base de diccionarios personalizados. Puede escribir manualmente los datos del diccionario o cargarlos desde un archivo.

Digitalización

Proceso de obtención de una imagen electrónica de un formulario en papel mediante el uso de un escáner.

Diseño de página

Esquema que muestra la ubicación de los campos en una imagen.

Documento

Combinación de una o varias imágenes y datos de páginas que se extraen de ellas.

Documento de varias páginas

Documento formado por varias páginas.

Documento flexible

Documento que contiene un conjunto de campos de información cuyo diseño, número y distribución puede variar notablemente en diferentes instancias del documento. Consulte Tipos de documentos procesados con ABBYY FlexiCapture 8.0.

Documento sin estructura

Documento que contiene información presentada en un formulario libre. Los contratos, las cartas, los pedidos y los diagramas son algunos ejemplos de estos documentos. Consulte Procesamiento de documentos sin estructura.

E

Elementos estáticos

Elementos irreconocibles diseñados para la asociación e identificación de plantillas. Estos elementos son: delimitadores, texto del delimitador, separadores, códigos de barras del delimitador.

Entrada de datos de flujo único

Extracción automatizada de datos de documentos análogos (impresos) y digitales (imagen digitalizada).

Error del documento

Si, durante el procesamiento de documentos, los datos del documento no se pueden asociar completamente con la estructura del documento y el valor del campo que se especifica o con las reglas de control, se registrarán todas las diferencias en los errores y en la lista de advertencias del documento.

Estilo de escritura

Modo de escritura específico de un grupo particular. Por ejemplo, el modo estadounidense de escribir los números. Detalles...

Esta opción se utiliza para configurar el estilo de escritura de cartas manuscritas en formularios. La elección de un estilo de escritura depende del área donde se lleva a cabo el procesamiento del formulario (Rusia, Alemania, República Checa, Estados Unidos, etc.).

Exportación

Proceso de transferencia de datos procesados a un archivo o sistema de información externo.

Expresión regular

Descripción de la estructura de una palabra o cualquier valor introducido mediante un idioma especial. El programa le permite especificar no solo el conjunto de caracteres permitidos, sino también la estructura del contenido de los campos. Puede describir la estructura con una expresión regular al configurar restricciones para un campo de texto o al crear un tipo de datos personalizado. Consulte Alfabeto utilizado en expresiones regulares.

F

FlexiLayout

Descripción de la estructura del documento flexible. Esta descripción está diseñada con ABBYY FlexiLayout Studio y se exporta a ABBYY FlexiCapture. FlexiLayout es un tipo de instrucción para detectar e identificar campos en un formulario flexible.

Formulario

Documento compuesto por una o varias páginas diseñado para que una persona lo complete a mano o mediante cualquier otra técnica de impresión.

Formulario con fondo de color

Formulario en el que todos los campos de información son rectángulos blancos sobre un fondo de color que desaparece durante la digitalización.

Formulario con fondo gris

Formulario en el que todos los campos de información son rectángulos blancos sobre un fondo gris que desaparece durante la digitalización.

Formulario con tramas

Formulario en el que los campos de información son rectángulos blancos sobre un fondo gris que consiste en líneas de trama o rectángulos delimitados por líneas de trama.

Formulario fijo

Documento con campos de información fijos cuyo formato, cantidad y diseño se define estrictamente y no cambia de una instancia del documento a otra.

Formulario legible por máquina

Formulario diseñado especialmente para la entrada automatizada. Contiene elementos de trabajo (delimitadores, códigos de barras, líneas, etc.) que son necesarios para procesarlo correctamente.

Formulario lineal en blanco y negro

Formulario en el que los bordes de los campos de información están formados por líneas comunes que no desaparecen durante la digitalización.

G

Grupo de marcas de verificación

Elemento de un formulario legible por máquina que une varias marcas de verificación cercanas. En un grupo de marcas de verificación, se puede seleccionar una o varias marcas de verificación.

I

Identificación de plantillas

Proceso de selección de la plantilla necesaria con la ayuda de identificadores.

Identificador

Elemento estático que se utiliza para cierta selección de una plantilla entre varias plantillas con la misma ubicación de los delimitadores. La opción Utilizar para identificar plantillas debe estar habilitada en las propiedades de estos elementos estáticos.

Idioma (local)

Propiedad de campo que determina el idioma de escritura y los conjuntos importantes de parámetros regionales (como el estilo de escritura de la fecha o la dirección).

ICR

Reconocimiento inteligente de caracteres (Intelligent Character Recognition). Hace referencia a tecnologías o sistemas diseñados para el procesamiento masivo de documentos con números y letras manuscritas, es decir, el reconocimiento de caracteres manuscritos.

Imagen

Imagen electrónica de una página digitalizada de un documento impreso.

Imagen

Elemento de un formulario legible por máquina que no está sujeto al reconocimiento pero que está diseñado para exportarse en forma de objeto gráfico (por ejemplo, un archivo).

Imagen invertida

Imagen con texto de color claro sobre un fondo oscuro.

Importación de imágenes

Proceso de adición de imágenes en un lote para procesarlas. La importación se puede realizar mediante la adición de imágenes de archivos, de un escáner o mediante perfiles de importación. Consulte Adición de imágenes de página.

Impresora matricial de puntos

Tipo de texto reconocible que representa un texto impreso con una impresora matricial de puntos.

Información del formulario

Captura de datos desde campos de información de los formularios.

Ingreso de documentos de flujo único

Conversión automática de documentos impresos a formularios electrónicos.

L

Letras en marcos

Tipo de marcación de texto donde cada carácter está delimitado por un marco; los marcos no están aislados entre sí. Mostrar...

Letras en marcos aislados

Tipo de marcación de texto donde cada carácter está delimitado por un marco; los marcos están aislados entre sí. Mostrar...

Letras sobre un peine

Tipo de marcación de texto en el que un "peine" delimita el texto. Mostrar...

Línea de trama

Línea que consiste en puntos equidistantes.

Lote de documentos

Combinación de documentos agrupados por el usuario. Un lote normalmente contiene la pila de documentos digitalizados en una sola pasada o importados desde una carpeta específica. Consulte Lotes de documentos.

Lotes de prueba

Lotes de documentos diseñados para la prueba y la configuración de plantillas. Para procesar lotes de prueba se utilizan las copias locales de los lotes de documentos. Consulte Lotes de documentos.

Lotes de trabajo

Lotes de documentos diseñados para la entrada de datos. Solo se utilizan plantillas de documento publicadas para el procesamiento de lotes de trabajo. Consulte Lotes de documentos.

M

Máquina de escribir

Tipo de texto reconocible que representa un texto escrito con una máquina de escribir.

Marca de verificación

Elemento de un formulario legible por máquina al que la persona que lo completa le coloca una marca (tilde, cruz, punto, tachón, etc.).

Marca de verificación corregida

Marca de verificación que se seleccionó por error y, luego, se tachó. Si está habilitada la opción Permitir correcciones para el campo de marca de verificación, el programa reconocerá la marca de verificación tachada como no seleccionada.

Marcación de texto

Diseño de una región de la página para la entrada de texto. Consulte las muestras de formato de texto en el tema Campo de entrada.

Marcación del campo de texto

Elemento gráfico que delimita un campo de texto: marco, peine, línea.

Muestra de texto

Archivo que contiene muestras de los caracteres del alfabeto.

O

OCR

Reconocimiento óptico de caracteres (Optical Character Recognition). Reconocimiento óptico de textos impresos.

OMR

Reconocimiento óptico de marcas (Optical Mark Recognition). Proceso de reconocimiento óptico de las marcas. Esta tecnología permite que ABBYY FlexiCapture reconozca las marcas comunes (tildes, cruces, etc.) de los formularios con un gran nivel de certeza e identifique correctamente las marcas que se crearon por error y, luego, se tacharon.

Operador

Usuario de ABBYY FlexiCapture al que se le asigna la entrada de documentos: adición de imágenes, operaciones de reconocimiento y verificación, exportación de datos reconocidos. Consulte Modos de administrador y operador.

Orientación de la página

Ubicación de la página en relación con la alineación estándar: de arriba hacia abajo, de izquierda a derecha. La orientación de la página puede determinarse automáticamente durante el reconocimiento de la imagen de página; para hacerlo, ABBYY FlexiCapture 8.0 le permite especificar posibles orientaciones.

Orientación del texto

Orientación del texto en un campo en relación con la página.

P

Página

Imagen de una página de un documento en papel y los resultados de su procesamiento.

Perfil de importación

Combinación de configuraciones que se utilizan para agregar imágenes a un lote: origen de importación, opciones de procesamiento de imágenes, opciones de limpieza de la carpeta dinámica, etc. Consulte Perfiles de importación de imágenes.

Plantilla de documento

Una plantilla de documento define los principios de identificación y procesamiento de este tipo de documentos y contiene:

  • La estructura del documento, es decir, la descripción del orden permitido de las páginas que forman el documento de este tipo. La estructura del documento define la regla de ensamblaje del documento.
  • Las plantillas de las secciones del documento.
  • La lista de reglas que deben cumplir los datos del campo.
  • La ubicación de los campos y sus firmas en la ventana de datos (vista de formulario de datos).
  • La configuración de exportación para este tipo de documentos.
  • La configuración de procesamiento para este tipo de documentos.

Plantilla fija

Plantilla de un documento o su sección diseñada para procesar formularios fijos. Los campos en una plantilla fija poseen ubicaciones fijas.

Plantilla flexible

Plantilla de un documento o su sección diseñada para procesar formularios flexibles. Creada al adjuntar una descripción flexible. Los campos en una plantilla como esta no poseen ubicaciones fijas. Se detectan con la ayuda de una descripción flexible. Consulte Creación de una plantilla para el procesamiento de documentos flexibles.

ppp

Puntos por pulgada. Cantidad de puntos por pulgada; una unidad de medida de la resolución de la imagen.

Proyecto

Un proyecto es un entorno independiente que combina la configuración y los lotes de los documentos que se necesitan para el procesamiento, tales como las plantillas de documentos, los perfiles de importación, etc. Consulte Creación de un proyecto.

Publicación de plantilla

Permiso de acceso a una versión nueva de la plantilla de documento una vez editada. Una versión publicada participa en el procesamiento de documentos desde lotes de trabajo, mientras que una versión local, no publicada, puede participar únicamente en el procesamiento de plantillas desde lotes de prueba. Consulte Edición y publicación de una plantilla.

R

Reconocimiento

Proceso de asociación de elementos de la imagen con caracteres específicos.

Reconocimiento de texto (OCR, ICR)

Conversión de una imagen gráfica a texto.

Reconocimiento del código de barras

Conversión de la imagen de un código de barras gráfico a números o texto.

Reconocimiento óptico de marcas (OMR)

Proceso para determinar la presencia de una marca en el campo de marca de un formulario.

Reemplazo de imagen

Reemplazo de una imagen por otra diferente al editar una plantilla.

Refinamiento de imágenes

Eliminación del ruido de la imagen. El ruido puede aparecer durante la digitalización y se recomienda que se elimine para permitir un mejor reconocimiento de datos. Durante el refinamiento, el programa también elimina los puntos de fondo o las líneas de demarcación de los formularios con tramas.

Región del campo

Región de una imagen resaltada en la plantilla y diseñada para la extracción de datos.

Región irreconocible

Región de una imagen que se excluye del reconocimiento. Una región irreconocible debe excluir una región con imágenes o texto explicativo que puedan complicar el reconocimiento de campos. Consulte Exclusión de una región del reconocimiento.

Reglas

Se imponen ciertas condiciones en los datos de los campos y el programa las comprueba automáticamente. Consulte Validación de regla

Resolución

Parámetro de la imagen. La resolución se mide en puntos por pulgada (ppp).

Rotación de imágenes

Rotación de una imagen sobre su centro.

S

Sección de una plantilla de documento

Conjunto de páginas (o una sola página) y los campos que contiene cada página, que corresponde a una parte lógicamente completa de un documento. Las secciones del documento se pueden describir mediante una plantilla fija o flexible. Consulte Creación de plantillas para documentos de varias páginas.

Sección de la plantilla de documento

Componente de una plantilla de documento. Corresponde a una o varias páginas que contienen un conjunto de campos lógicamente completo. Los campos de una sección pueden continuar de una página a la siguiente (por ejemplo, tablas de varias páginas), mientras que los conjuntos de campos de varias secciones no se entrecruzan.
La sección de una plantilla puede ser flexible o fija.

Separador

Elemento de un formulario legible por máquina que representa una línea vertical u horizontal.

T

Tabla

Datos organizados en una cuadrícula bidimensional que no es necesariamente visible. El programa procesa tablas que consisten en columnas con el mismo tipo de datos y filas repetidas.

Texto del delimitador

Elemento estático que representa un texto que se encuentra en un formulario en blanco y que no está diseñado para la extracción de datos. Este texto puede ser cualquier encabezado o texto explicativo. El texto del delimitador se puede utilizar para la asociación o identificación de plantillas.

Texto enmarcado

Tipo de marcación de texto en el que un marco delimita el texto. Mostrar...

Texto enmarcado sobre un peine

Tipo de marcación de texto donde el texto está delimitado por un marco con un límite inferior en forma de peine. Mostrar...

Texto en monoespacio

Tipo de marcación de texto en el que cada letra se ubica dentro de un marco de la misma altura y del mismo ancho, pero el borde del marco desaparece durante la digitalización.

Texto explicativo

Elemento de un formulario legible por máquina que representa un texto descriptivo (nombre del formulario, nombres de campos, explicaciones de los campos, etc.).

Texto impreso a máquina

Tipo de texto reconocible impreso mediante un equipo tipográfico o una impresora láser o de chorro de tinta con una resolución mínima de 300 ppp.

Texto manuscrito

Tipo de texto reconocible que representa un texto escrito a mano en un tipo definido.

Texto simple

Tipo de marcación de texto en el que el texto se inserta en un bloque sin delimitadores.

Texto subrayado

Tipo de marcación de texto en el que el subrayado delimita el texto. Mostrar...

Tipo de datos

Atributo de un campo que describe las restricciones conocidas de los valores posibles del campo. Se utiliza durante el reconocimiento de campos para reducir la cantidad de variantes de reconocimiento posibles. Detalles...

Una de las características del campo es el tipo de datos: número, fecha, texto, apellido, nombre, dirección, etc. Un tipo de datos define el conjunto de palabras que pueden aparecer en un campo determinado.

El tipo de datos es un parámetro de reconocimiento importante que afecta la calidad del reconocimiento. Un tipo de datos que se haya especificado bien puede reducir notablemente la cantidad de caracteres mal reconocidos.

Tipo de datos personalizados

Tipo de datos definidos por el usuario. Consulte Creación de tipos de datos personalizados.

V

Validación de regla

Comprobación automática de datos reconocidos en comparación con las reglas predeterminadas. Consulte Validación de regla.

Verificación

Proceso de comprobación de datos reconocidos que realiza el operador. Se lleva a cabo mediante la comparación de los resultados del reconocimiento con la imagen original de cualquier parte del documento. En los productos ABBYY, la tecnología de verificación se ha implementado teniendo en cuenta las peculiaridades psicosomáticas básicas de los humanos: la formación de hábitos, la utilización de aptitudes, la integridad y el propósito de la percepción. Consulte Verificación de datos reconocidos.

Verificación de campo

Modo de verificación en el que los caracteres reconocidos se envían para la verificación dentro del contexto de un campo. Detalles...

En el modo de verificación de campo, se comprueban los caracteres inciertos en el contexto del campo completo.

Los campos con la opción Incluir en la verificación de campo habilitada se envían para realizar la verificación de campo. Recomendamos enviar a la verificación de campo aquellos campos cuyo rango de valores se conoce o se puede determinar fácilmente. Los nombres de ciudades o países son ejemplos de estos campos: sabemos qué valores puede tener este campo.

Verificación de grupo

Modo de verificación en el que se envían caracteres idénticamente reconocidos para la verificación en grupos. Detalles...

Los campos con la opción Incluir en la verificación de grupo habilitada se envían para realizar la verificación de grupo.

Recomendamos enviar caracteres de campos de número y también marcas de verificación para la verificación de grupo.

X

XFD

Definición de formulario XML (XML Form Definition): formato de archivo especial de un formulario diseñado con ABBYY FormDesigner. Un archivo de formato de definición de formulario XML (*.xfd) se utiliza para crear plantillas de documento en ABBYY FlexiCapture.


Glosario

A B C D E F G I L M O P R S T V X


Archivo de descripción

Un archivo de descripción es un archivo auxiliar que define cómo está formado un lote cuando se agregan imágenes de una carpeta dinámica. De acuerdo con el formato del archivo de descripción, se utilizan diferentes conjuntos de archivos para formar el lote.

El programa utiliza los siguientes tipos de archivo de descripción:

  1. Captiva QuickScan
    Todos los archivos de imagen enumerados en el archivo de descripción se agregan al lote. El orden de los archivos de imagen del lote es el mismo que el orden del archivo de descripción.
  2. Software para captura de archivos Kodak
    Los archivos de imagen que están ubicados en la carpeta del lote de Kodak se agregan al lote en orden ascendente según el nombre del archivo.
  3. Archivo vacío
     El contenido de este archivo es irrelevante. Todos los archivos que preceden al archivo de descripción de la carpeta dinámica se agregarán al lote en orden ascendente según el nombre de archivo.
  4. Archivo XML
    Este es un archivo XML con una estructura documentada. Un archivo XML se utiliza cuando los otros tres tipos no pueden usarse pero puede generarse un archivo de descripción personalizado. Los archivos de imagen enumerados en el archivo de descripción se agregan al lote.

    Un archivo XML debe incluir un elemento raíz Lote con elementos secundarios Imágenes.

    El elemento Imágenes, a su vez, debe incluir elementos Imágenes, cuya cantidad corresponde a la cantidad de páginas del lote que se está creando. Cada elemento Imagen debe incluir una ruta UNC al archivo de imagen correspondiente. La ruta a la carpeta que contiene la imagen debe ser la misma que para todos los elementos Imagen.

    <Lote>

    ...

    <Imágenes>
    <Imagen>\\HotFolder\Page1.tif</Imagen>
    <Imagen>\\HotFolder\Page2.tif</Imagen>
    <Imagen>\\HotFolder\Page3.tif</Imagen>

    </Imágenes>

    </Lote>

    En ese caso, recomendamos configurar el programa de digitalización de modo que las imágenes digitalizadas se coloquen en la carpeta dinámica o dentro de las subcarpetas del primer nivel. Al crear un lote, el programa le agregará todas las imágenes enumeradas en los elementos Imagen del archivo de descripción correspondiente. Las imágenes se agregarán según el orden en que están dispuestas en el archivo de descripción.

    El orden de los archivos de imagen del lote es el mismo que el orden del archivo de descripción.