Info…

ABBYY FlexiCapture 9.0 ist eine Softwarelösung, mit der Daten aus Papierdokumenten automatisch in Informationssysteme und Datenbanken übertragen werden können.

Durch den Einsatz moderner Technologien zur Erkennung gedruckter und handschriftlicher Zeichen, zur Bildverarbeitung und zur Dokumentanalyse können mit ABBYY FlexiCapture 9.0 alle wichtigen Arten von Informationen automatisch aus Dokumenten extrahiert werden. Dabei können in einem Durchgang sowohl strukturierte (statische) Formulare als auch teilweise strukturierte (flexible) und nicht strukturierte Dokumente verarbeitet werden. Mit ABBYY FlexiCapture 9.0 ersparen Sie sich die aufwendige und ineffiziente Arbeit, die bei der manuellen Sortierung und Erfassung von Informationen aus Dokumenten entsteht.

Die Dokumentverarbeitung umfasst im Allgemeinen folgende Arbeitsschritte:

  1. Zunächst werden die Dokumente in die automatische Dokumentenzufuhr des Scanners eingelegt, und der Scanvorgang wird gestartet.
  2. Anschließend werden die gescannten Dokumentenbilder zur Erkennung weitergeleitet. Die Software erkennt auch mehrseitige Dokumente automatisch, sucht nach aussagekräftigen Feldern, extrahiert die Daten und lädt die Überprüfungsregeln.
  3. Sofern erforderlich, werden die Daten dann visuell überprüft und auf mögliche Regelfehler hin untersucht.
  4. Abschließend werden die erkannten und geprüften Daten zusammen mit den elektronischen Kopien der Dokumente in einer Datenbank, einem Informationssystem oder einer Datei gespeichert.


Neue Funktionen von ABBYY FlexiCapture 9.0, die nicht in ABBYY FlexiCapture 8.0 Professional verfügbar sind

Architektur

Verteilte Installation

ABBYY FlexiCapture 9.0 unterstützt die verteilte Installation und den verteilten Betrieb. Die in ABBYY FlexiCapture 9.0 implementierte verteilte Installation ähnelt derjenigen der FormReader 6.5 Enterprise Edition, macht das System aber dank einiger Modifikationen flexibler, sklaierbarer und zuverlässiger. Die Scanstation und die Datenverifizierungsstation können nun dezentral über das Internet genutzt werden.

Architektur und Grundprinzipien von ABBYY FlexiCapture 9.0
Workflow
ABBYY FlexiCapture 9.0 Server
ABBYY FlexiCapture 9.0 Stationen
Anwendungsserver-API

Die API des Anwendungsservers ermöglicht Ihnen die programmtechnische Kontrolle der Verarbeitung, ohne auf das GUI zurückgreifen zu müssen. Die API ermöglicht Entwicklern von Drittanbietern, ihre eigenen Anwendungen zu erstellen, die ABBYY FlexiCapture 9.0 als Dienst zur Analyse von Dokumentbildern sowie zum Export der Verarbeitungsergebnisse nutzen.
Anwendungsserver-API

Projektmanagement

Stapeltypen

Ein Typ kann für jeden Stapel festgelegt werden (wenn kein Typ festgelegt ist, wird ein "Standardtyp" zugewiesen). Ein Projekt kann eine beliebige Anzahl von Stapeltypen enthalten. Ein Stapeltyp definiert die Bildverarbeitungs- und Erkennungsoptionen, Stapelintegritätsprüfungen, Standardexporteinstellungen und die Art und Weise, wie die zu diesem Typ gehörenden Stapel verarbeitet werden sollen. Die Projekteinstellungen werden für Stapel des "Standardtyps" verwendet.
Dokumentstapel

Registrierungsparameter

Es ist nun möglich, Registrierungsparameter für Stapel und Dokumente anzugeben. Diese Parameter können für den späteren Bild- und Datenexport genutzt werden.

Registrierungsparameter
Prioritäten

Für die Steuerung der Verarbeitungsreihenfolge können nun Prioritäten für Dokumente und Stapel angegeben werden.

Analyse und Erkennung

Reihenfolge, in der die Dokumentdefinitionen zugeordnet werden

Sie können jetzt die Reihenfolge kontrollieren, in der die Dokumentdefinitionen zugeordnet werden. Folgende Methoden können zur Bestimmung der Zuordnungsreihenfolge verwendet werden:

  • Genaue Bestimmung der Reihenfolge der Dokumentdefinitionen im Dialogfeld Dokumentdefinitionen
  • Für FlexiLayouts: verwenden Sie einen Klassifikator, um die gewünschte Dokumentdefinition auszuwählen
  • Für FlexiLayouts: legen Sie im Dialogfeld Dokumentdefinitionen fest, wie das erforderliche FlexiLayout ausgewählt werden soll
Bearbeitung und Veröffentlichung einer Dokumentdefinition
Klassifikator
Aktualisieren der Version einer Dokumentdefinition ohne erneute Erkennung

Sie können jetzt die Version einer Dokumentdefinition aktualisieren, ohne die Erkennung zu wiederholen. Dies ist möglich, wenn eine der folgenden Bedingungen erfüllt ist:

  • Wenn nur die Exporteinstellungen verändert wurden. In diesem Fall wird das Dokument mit den neuen Einstellungen exportiert
  • Wenn die Regeln verändert wurden. In diesem Fall wird die regelbasierte Validierung noch einmal durchgeführt

Überprüfung und Validierung

Überprüfungs- und Validierungstasks können nun automatisch abgerufen werden.
Während der Gruppen- und Feldvalidierung können die Bilder betrachtet werden
Dateien und Datenbanken können als Datenquellen für die regelbasierte Validierung verwendet werden
Die Regel für die Datenbanküberprüfung kann für leere Felder deaktiviert werden
Es wurde eine Regel für die Summenberechnung hinzugefügt.
Die Stufe für die Erkennungszuverlässigkeit wird für den gesamten Stapel angegeben
Es wurden Einstellungen für die Gruppen- und Feldüberprüfung ergänzt. Dazu gehört die Möglichkeit, Eindeutigkeitsanforderungen für spezifische Zeichen zu konfigurieren.
Für die Feldüberprüfung kann die Startposition des Mauszeigers bestimmt werden
Während der Feldüberprüfung können ganze Felder optional markiert werden (nützlich, wenn der Benutzer Eingaben vornehmen möchte)
Jeder Fehlertyp wird separat angezeigt. Folgende Fehlerarten werden erkannt:
  • Zusammenstellungsfehler
  • Formatfehler
  • Regelfehler
Überprüfung erkannter Daten

Export

Automatischer Export

Dokumente mit einer hohen Erkennungsqualität und ohne Regel- oder Formatfehler werden nun ohne Eingriff des Benutzers automatisch exportiert. Der erforderliche Prozentsatz der nicht eindeutigen Zeichen wird beim Einrichten des Projekts bestimmt.
Workflow

Exportieren in mehrere Zielorte

Daten und Bilder können in mehrere Zielorte exportiert werden. Einige Zielorte können als kritisch markiert werden. Wenn das Exportieren in einen kritischen Zielort fehlschlägt, wird eine Fehlermeldung angezeigt. Wenn das Exportieren in einen unkritischen Zielort fehlschlägt, führt dies nicht zu einem gesamten Exportfehler.
Konfigurieren des Datenexports

Einrichten von Dateinamen und Speicherorten

Für die Konfiguration von Namensvorlagen für Dateien, in denen exportierte Daten und Bilder gespeichert werden, sowie deren Pfade gibt es jetzt mehr Möglichkeiten. Neu ist außerdem die Möglichkeit, die Ordnerstruktur während des Exports aus einem Hot Folder nachzubilden.
Namensschema für Exportdateien

Archivieren von Dokumenten mit Fehlern

Dokumente mit Format- oder Regelfehlern können in einem vorgegebenen Speicherort abgelegt werden. Der Export von Dokumenten mit Fehlern wird auf dieselbe Weise eingerichtet wie das Exportieren von normalen Dokumenten.
Konfigurieren des Datenexports

Automatisches Löschen von Dokumenten nach dem Export

Exportierte Dokumente können gelöscht werden, wenn der Export erfolgreich durchgeführt wurde. Die Option, die Dokumente manuell zu löschen, besteht nach wie vor.
Workflow

Gewährleistung der Geheimhaltung

Einzelne Felder auf Dokumentbildern können nun geschwärzt werden (d. h. überdeckt werden). Es können für jeden Export verschiedene Schwärzungsregeln bestimmt werden. Somit wird die Anzahl der für verschiedene Benutzer sichtbaren Informationen gesteuert.
Konfigurieren des Datenexports

Optionen

Stapelintegritätsüberprüfungen

Skripte können verwendet werden, um Stapel auf Integrität zu überprüfen. Skripte werden vor dem Export automatisch gestartet.
Dokumentstapel
Beispielskripte zum Erstellen benutzerdefinierter Regeln

Normalisierungsskripte

Skripte können verwendet werden, um die aus den Feldern extrahierten Informationen zu korrigieren.
Verarbeiten eingegebener Werte
Beispielskripte zum Erstellen benutzerdefinierter Regeln

Automatische Verarbeitung

Dokumente können automatisch ohne Einwirken des Operators verarbeitet werden. Erfolgreich verarbeitete Dokumente werden exportiert, und Dokumentbilder, bei denen Fehler aufgetreten sind, können für eine zukünftige Analyse gespeichert werden.

Workflowkonfigurierung
Benutzerdefinierte Skripte

Für jedes Feld kann ein vom Überprüfungsoperator ausgelöstes Skript angegeben werden.

Benutzerdefinierte Aktion
Dienstfelder

Ein neuer Feldtyp wurde ergänzt: das Dienstfeld. Felder dieser Art werden automatisch mit den Daten der ausgewählten Quelle ausgefüllt.

Dienstfelder

Unterstützte Sprachen

Neue OCR-Sprachen

OCR-Unterstützung für die folgenden Sprachen wurde hinzugefügt:

  • Vietnamesisch
  • Chinesisch
  • Koreanisch
  • Japanisch

Neue Funktionen von ABBYY FlexiCapture 8.0 Professional, die nicht in FormReader 6.5 Desktop verfügbar sind

Unterstützte Dokumenttypen

Mehrseitige Dokumente mit komplexer Struktur

Mit dem Programm können strukturierte, teilweise strukturierte und nicht strukturierte Dokumente unterschiedlicher Größe und mit sich wiederholenden Seiten sowie Dokumente mit Anhängen automatisch identifiziert und verarbeitet werden.
Unterstützte Dokumenttypen in ABBYY FlexiCapture 9.0
Erstellen einer Dokumentdefinition für mehrseitige Dokumente
Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen

Nicht strukturierte Dokumente

Nicht strukturierte Dokumente mit Text oder Bildern, die durch leere Blätter oder Seiten mit Barcodes oder Patchcodes getrennt sind, werden mithilfe einfacher Dokumentdefinitionen indiziert, verarbeitet und als durchsuchbare PDF-Dateien oder Grafikdateien exportiert.
Verarbeiten nicht strukturierter Dokumente

Teilweise strukturierte mehrseitige Dokumente mit komplexen Tabellen oder Tabellen auf mehreren Seiten

Teilweise strukturierte mehrseitige Dokumente mit Tabellen, die sich über mehrere Seiten erstrecken, werden identifiziert, zu Dokumenten zusammengestellt und mithilfe eines einzigen FlexiLayouts verarbeitet.
Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente

Statische Formulare mit Tabellen

Die Verarbeitung von Dokumenten mit Tabellen wurde vereinfacht, da nun Tabellen in statischen Formularen unterstützt werden.
Erstellen einer Tabelle

Wiederholt vorkommende Elemente

Wiederholt vorkommende Feldgruppen werden sowohl in strukturierten als auch in teilweise strukturierten Dokumenten unterstützt. Dadurch vereinfacht sich die Konfiguration der Verarbeitung von Dokumenten mit gleichen Elementgruppen, die sich mehrfach wiederholen, einschließlich komplexer Tabellen mit solchen Gruppen.
Erstellen einer Feldgruppe

Programmarchitektur

Operator- und Administratormodus

Der Operator- oder der Administratormodus wird jeweils über den entsprechenden Befehl im Startmenü aktiviert. Operator- und Administratorstation können auf verschiedenen Computern installiert werden. Im Administratormodus stehen alle Programmfunktionen zur Verfügung. Im Operatormodus können Benutzer dagegen weder Dokumentdefinitionen bearbeiten noch Profile importieren oder auf Teststapel zugreifen.

Arbeiten mit Projekten

In einem Projekt sind verschiedene Dokumentstapel und die zur Verarbeitung erforderlichen Einstellungen, z. B. Dokumentdefinitionen oder Importprofile, vereint und festgelegt.

Ein Projekt kann von verschiedenen Kopien des Programms verwendet werden: Ein Projekt kann als einzelnes Objekt exportiert und importiert, aktualisiert und von einem Computer zu einem anderen übertragen werden. Benutzer an verschiedenen Workstations in einem Netzwerk können im Hinblick auf eine optimierte Dokumentverarbeitung an den gleichen Projekten arbeiten.
Erstellen eines Projekts
Projekteigenschaften

Benutzerfreundliche Tools für die Arbeit mit Hintergrundprozessen

Zeitintensive Operationen wie das Hinzufügen von Bildern, die Erkennung oder der Export können im Hintergrundmodus ausgeführt werden, wodurch die Verarbeitungszeit von Dokumenten erheblich gesenkt wird. Der Benutzer kann jederzeit den Status aller Hintergrundprozesse überprüfen, die Prioritäten der Tasks ändern und das Verarbeitungsprotokoll anzeigen.

Hintergrundmodus

Dokumentdefinitionseditor

Arbeiten auf Dokumentebene

Es werden Dokumentdefinitionen für das gesamte Dokument als Verarbeitungseinheiten erstellt. Mit einer Dokumentdefinition wird festgelegt, auf welche Weise Dokumente eines bestimmten Typs identifiziert und verarbeitet werden. Jede Dokumentdefinition enthält Seitenbilder, Zusammenstellungsregeln, Beschreibungen von Feldern und statischen Elementen, Überprüfungsregeln, Überprüfungseinstellungen, Beschreibungen von Datentypen sowie Einstellungen für den Datenexport.
Erstellen von Dokumentdefinitionen für mehrseitige Dokumente

Wechseln zwischen zwei verschiedenen Bildmodi

Mithilfe der Dokumentdefinition können Sie nun zwischen zwei Bildansichten wechseln. Unabhängig von dem Format, in dem Bilder zu einem Stapel hinzugefügt werden, können Sie sie entweder in den Originalfarben oder schwarz-weiß anzeigen. Mithilfe von Farbbildern können Dokumentdefinitionen für Farbformulare einfacher erstellt werden, da in dieser Ansicht Feldmarkierungen und erklärender Text angezeigt werden. Diese Elemente werden zum Zeichnen des Feldbereichs und zum Zuweisen eines Namens zum Feld benötigt. In Schwarz-Weiß-Bildern kann überprüft werden, ob Anker und statischer Text nach der Binärumwandlung während des Erkennungsvorgangs immer noch sichtbar sind.

Datenformulareditor

Im Datenformulareditor können Sie eine benutzerdefinierte Ansicht der extrahierten Daten definieren und deren Darstellung an die Anforderungen der Operatoren anpassen.
Konfigurieren der Datendarstellung im Dokumentfenster

Darstellung der Felder in einer Baumstruktur

Die Dokumentstruktur wird grafisch als Baum von Feldern dargestellt. Durch diese Darstellungsform der Felder können Sie Felder schnell bearbeiten, kopieren, löschen und verschieben.
Darstellung der Dokumentstruktur in der Gliederungsansicht

Die Dokumentstruktur wird mit der entsprechenden Seitengliederung angezeigt. Auf diese Weise können Dokumentdefinitionen für mehrseitige Dokumente einfacher erstellt, angezeigt und bearbeitet werden.
Getrennte Anzeige von statischen Elementen und Feldern

Statische Elemente und Felder werden getrennt voneinander angezeigt. Dies vereinfacht die Erstellung von Dokumentdefinitionen: Statische Elemente (Anker, Trennlinien, Ankertext und Barcodes) werden getrennt erstellt und beeinträchtigen die Erstellung von Feldbereichen nicht.

Erstellen von Feldern einer Dokumentdefinition
Statische Elemente
Gruppieren von Feldern

Felder können in Gruppen zusammengefasst werden, was die Darstellung der Dokumentstrukturen sowie die Erzeugung sich wiederholender Feldgruppen vereinfacht.

Erstellen einer Feldgruppe
Eigenschaften einer Feldgruppe
Tabellen in statischen Dokumentdefinitionen

In statischen Dokumentdefinitionen können jetzt Tabellenfelder erstellt werden. Dies trägt erheblich zur Vereinfachung der Konfiguration und Datenextraktion sowie des Datenexports aus Tabellen bei. Bei einem Tabellenfeld handelt es sich um eine Gruppe von Spalten des gleichen Typs und mehreren Zeilen.

Erstellen einer Tabelle
Tabelleneigenschaften
Wiederholt vorkommende Elemente in statischen Dokumentdefinitionen

Bei wiederholt vorkommenden Elementen handelt es sich um Felder und Feldgruppen, die in einem Formular mehrfach vorkommen und ähnliche Objekte betreffen, z. B. die gleichen Details mehrerer Mitarbeiter, Kinder, Konten usw. Die Struktur dieser Elemente erinnert an die Struktur von Tabellen: Eine Feldgruppe entspricht dabei einer Tabellenspalte und jedes mehrfach vorkommende Feld einer Tabellenzeile. Mit dem Dokumentdefinitionseditor kann die Konfiguration und Verarbeitung dieser Felder und Feldgruppen einfacher durchgeführt werden.

Felder mit mehreren Instanzen
Felder auf mehreren Seiten eines Formulars

Wenn ein Formular Felder enthält, deren Bereich sich über mehrere Seiten erstreckt, z. B. große Tabellen, können Sie diese Felder im Dokumentdefinitionseditor als ein großes Feld anzeigen, wodurch die Konfiguration und Verarbeitung erheblich erleichtert wird.

Felder mit mehreren Bereichen
Automatische Erstellung statischer Dokumentdefinitionen

Mit den folgenden neuen Funktionen des Dokumentdefinitionseditors kann die Erstellung statischer Dokumentdefinitionen automatisch und somit leichter durchgeführt werden:

  • Automatische Identifizierung von Textfeldern mit einem Bereich;
  • Automatische Identifizierung vertikaler und horizontaler Trennlinien in Tabellen;
  • Automatische Identifizierung eines Felds mit nur einem Mausklick auf den Bereich des Felds;
  • Automatische Zuweisung eines Feldnamens, der dem nächstliegenden erklärenden Text entspricht;
  • Erkennung und Kopieren von statischem Text aus dem Dokumentdefinitionsbild in die Feldeigenschaften;
  • Automatische Anpassung der Feldränder.
Automatische Erkennung von Feldern und statischen Elementen
Ändern eines Feldnamens
Verbesserte Konfiguration von Datentypen

Die Einstellungen der Datentypen wurden weiter ausgearbeitet, um so die Erstellung von Dokumentdefinitionen zu vereinfachen sowie die Extraktion und Überprüfung von Felddaten zu optimieren. Die am häufigsten verwendeten Datentypen (Text, Datum und Uhrzeit, Währung, Anzahl) sind nun in der Gruppe vorkonfigurierter Datentypen integriert. Gleichzeitig wurden die am häufigsten verwendeten Formate der vorkonfigurierten Datentypen zur Gruppe vorkonfigurierter Formate hinzugefügt und können nun in der entsprechenden Liste ausgewählt werden, ohne dass komplexe Regeln für die Formatüberprüfung erstellt werden müssen.
Datentypen für Texteingabefelder
Erstellen benutzerdefinierter Datentypen

Beschreibung der Überprüfungsregeln mit JScript®

Überprüfungsregeln können jetzt (zusätzlich zu VBScript) auch mit JScript® als Skript definiert werden. Dadurch können Sie benutzerdefinierte Regeln zur Überprüfung extrahierter Daten konfigurieren.
Festlegen einer Regel mithilfe eines Skripts
Erstellen von Regeln mithilfe von Skripten

Indexfelder

Wenn in den Eigenschaften eines Felds die Option Indexfeld aktiviert ist, können die Werte dieses Felds als zusätzliche Spalte im Fenster des Dokumentstapels angezeigt werden. Dokumente können dann anhand des Werts dieses Felds sortiert werden. Beim Export können die Werte der Indexfelder zum Dateinamen hinzugefügt werden, wodurch das Auffinden gesuchter Informationen vereinfacht wird.
Indexfelder
Regeln für das Benennen von Exportdateien

Zusätzliche Versionen von Dokumentdefinitionen

Beim Öffnen einer Dokumentdefinition im Dokumentdefinitionseditor wird automatisch eine temporäre lokale Version der Dokumentdefinition erstellt. Diese bearbeitbare Version wird erst in die Verarbeitung von Dokumenten einbezogen, nachdem sie veröffentlicht wurde. Mit dieser Funktion können Dokumentdefinitionen in Projekten von mehreren Benutzern bearbeitet werden.
Bearbeitung und Veröffentlichung einer Dokumentdefinition

Testen von Dokumentdefinitionen in speziellen Stapeln im Dokumentdefinitionseditor

Um die Erstellung von Dokumentdefinitionen zu vereinfachen und zu beschleunigen, können bearbeitbare Dokumentdefinitionen während des Erstellungsvorgangs getestet werden, ohne dass dazu der Dokumentdefinitionseditor geschlossen werden muss. Eine Dokumentdefinition kann beim Erstellen mit dem Bild getestet werden, das zum Erstellen der Dokumentdefinition verwendet wurde. Für diese Tests können spezielle Teststapel eingesetzt werden, die nicht für die tatsächliche Verarbeitung von Dokumenten verwendet werden.
Testen von Dokumentdefinitionen
Dokumentstapel

Bildimport

Automatische Zusammenstellung von Seiten zu Dokumenten

Die eingehenden Bilder vom Scanner oder Hot Folder können automatisch in Dokumente untergliedert werden, und zwar durch:

  • mehrseitige Bildformate, z. B. TIFF oder PDF;
  • leere Seiten sowie Seiten mit Barcodes oder Patchcodes
Hinzufügen von Seitenbildern
Optionen zur Bildvorverarbeitung
Bildimportprofile

Mithilfe von Bildimportprofilen können Gruppen vorkonfigurierter Einstellungen für unterschiedliche Importquellen von Dokumenten (Scanner oder Ordner) erstellt werden. Importprofile werden gespeichert und mit einem Namen versehen, unter dem sie anschließend in der entsprechenden Liste ausgewählt werden können.
Bildimportprofile

Import mit nur einem Klick

Der Importvorgang von Bildern entsprechend den Einstellungen des zuletzt verwendeten Profils kann mit nur einem Mausklick durchgeführt werden.
Hinzufügen von Seitenbildern

Import im Hintergrundmodus

Bilder können im Hintergrundmodus importiert werden. Im Hot Folder wird in bestimmten Zeitabständen überprüft, ob der Ordner neue Bilder enthält.

Hintergrundmodus

Einordnung, Dokumentdefinitionszuordnung und Erkennung

Volltexterkennung für den Export in durchsuchbare PDF-Dateien

Das Programm unterstützt die Volltexterkennung in Dokumenten mit anschließendem Export in durchsuchbare PDF- und PDF/A-Dateien. Dies ist insbesondere beim Archivieren nicht strukturierter und teilweise strukturierter Dokumente sehr hilfreich.
Neue Erkennungssprachen

Kirgisisch (OCR/ICR)

Kasachisch (OCR/ICR)

Thailändisch (OCR)

Unterstützte Erkennungssprachen

Neue Barcodetypen

Matrix 25, Industrial 25, PostNet.

Unterstützte Barcodetypen
Position korrigierter Zeichen in statischen Formularen

Wenn ein versehentlich eingegebenes Zeichen gelöscht wurde, wird es bei der Überprüfung angezeigt, so dass Sie das korrekte Zeichen manuell eingeben können.
Möglichkeit zum Entfernen von Trennseiten

Seiten mit Barcodes, Seiten mit Patchcodes und leere Seiten, die als Trennseiten verwendet werden, können automatisch aus dem Stapel entfernt werden.

Optionen zur Bildvorverarbeitung
Möglichkeit zum Entfernen von Leerseiten

Leerseiten können während der Erkennung entfernt werden.

Projekteigenschaften

Datenüberprüfung

Verbesserte Überprüfungsoberfläche
  • Vollbildmodus.
  • In der Statusleiste wird der aktuelle Prozentsatz überprüfter Zeichen angezeigt.
?
Überprüfung erkannter Daten
Neue Optionen zur Konfiguration der Benutzeroberfläche
  • Die Position des Fensters mit dem Feldbild kann jetzt geändert werden.
  • Der Zoomfaktor des Fensters kann geändert werden. Zudem kann mit einer neuen Funktion automatisch die optimale Größe ausgewählt werden.
  • Der Benutzer kann die Schriftgröße der Zeichen ändern.
Überprüfung erkannter Daten
Verbesserte Gruppenüberprüfung
  • Anzeige eines Popupfelds mit dem Kontext der Zeichen.
  • Konfigurierbare Größen- und Kontrasteinstellung des angrenzenden Bereichs der Zeichen.
Gruppenüberprüfung
Verbesserte Feldüberprüfung
  • Formatregeln können nun bei der Feldüberprüfung geprüft werden. Dabei werden eine Fehlerbeschreibung und eine Liste mit Änderungsvorschlägen für den Wert angezeigt.
  • Es gibt einen neuen Modus zum Anzeigen eines Felds mit einem Zeichenausschnitt.
  • Mehrzeilige Felder werden unterstützt.
  • Zum besseren Verständnis werden bei Zeichen Popupfelder angezeigt, z. B. der Buchstabe "O" und die Ziffer "0".
Feldüberprüfung
Direkte Felderkennung

Während der Überprüfung im Dokumentfenster wird nach jeder Änderung der Ränder eines Feldbereichs automatisch eine erneute Erkennung des entsprechenden Bildbereichs durchgeführt. Diese Funktion vereinfacht und beschleunigt die Extraktion der Daten aus Feldern mit ungenau angegebenen Bereichen.
Verbesserte Benutzeroberfläche zum Korrigieren von Regelfehlern
  • Jede Regel in der Liste der Regelfehler wird mit einem Verweis auf das entsprechende Feld angezeigt. Anhand dieser Verweise können Sie schnell zu den Feldern mit möglichen Fehlern wechseln.
  • Die Liste der Regelfehler kann oben, unten, rechts oder links im Dokumentfenster angedockt werden.
Regelbasierte Validierung
Korrektur von Zusammenstellungsfehlern in der Gliederungsansicht

Für Stapeldokumente steht jetzt eine neue Gliederungsansicht zur Verfügung. Dieser Modus eignet sich vor allem für die Korrektur von Zusammenstellungsfehlern. Dazu können in dieser Ansicht folgende Aktionen ausgeführt werden:

  • Anzeigen von nach Dokumenten zusammengefassten Seitengliederungen;
  • Anzeigen der Unstimmigkeiten zwischen den Schlüsselfeldwerten und den Beschreibungen der Zusammenstellungsfehler;
  • Korrigieren der Zusammenstellungsfehler durch Verschieben von Seiten zwischen den Dokumenten mit dem Mauszeiger;
  • Ändern der Größe der Seitengliederung für eine Detailansicht (durch Drehen des Scrollrads der Maus bei gedrückter Strg-Taste).
Zusammenstellen von Seiten zu Dokumenten
Kennwortgeschützte PDF-Dateien können jetzt geöffnet werden

DjVu-Dateien können jetzt hinzugefügt werden
Unterstützte Grafikformate

Export

Exportieren in Microsoft SharePoint

Sie können jetzt mithilfe der Programmoberfläche den Export nach Microsoft SharePoint einrichten.

Exportieren von Daten in eine SharePoint-Dokumentbibliothek
Export mit nur einem Klick

Wenn Exporteinstellungen konfiguriert wurden, kann ein Dokumentstapel mit nur einem Klick auf eine Schaltfläche exportiert werden. Dadurch müssen keine weiteren Aktionen durchgeführt werden, was wiederum die Dokumenteingabe beschleunigt.

Exportieren erkannter Daten
Exportieren von Dokumentbildern mit den Daten

Beim Export von Daten können Sie nun auch gleichzeitig die Bilder der entsprechenden Dokumente exportieren.
Hilfreiche Regeln für das Benennen von Ergebnisdateien

Wenn Daten in eine Datei nach Microsoft SharePoint exportiert werden, dann werden die Dateinamen automatisch auf der Grundlage benutzerdefinierter Regeln erzeugt. Sie können die Werte der Indexfelder, die Werte der Barcodes von Trennseiten usw. an Dateinamen anhängen. Aussagekräftige Dateinamen erleichtern das Auffinden gesuchter Informationen erheblich.
Regeln für das Benennen von Exportdateien

Neue Dokument- und Bildformate

PDF, durchsuchbares PDF/A

Unterstützte Grafikformate
Verknüpfen von Feldern beim Export in eine Datenbank

Bei der Konfiguration des Exports von Daten in eine Datenbank können Felder praktischerweise verknüpft werden, so dass Dokumentfelder schnell Datenbankfeldern zugeordnet werden können.

Export in eine Datenbank
Export mithilfe eines Skripts

Benutzer können Exportprozeduren mit der Skriptsprache VBScript oder JScript beschreiben.

Export mithilfe eines Skripts
Beschreibung von Exportprozeduren mithilfe von Skripten
Ändern der Bildauflösung beim Exportieren

Die Auflösung exportierter Bilder kann zum Speichern geändert werden.

Konfigurieren des Datenexports
Bildexport in eine Datei

Bilder gesamter Dokumente oder auch einzelne Bildfelder können jeweils in separate Grafikdateien exportiert werden.
Entfernen exportierter Dokumente aus einem Stapel

Wenn Sie exportierte Dokumente eines Stapels nicht speichern möchten, können Sie sie unmittelbar nach dem Exportvorgang löschen.

Exportieren erkannter Daten
Zusätzliche Optionen


Unterstützte Dokumenttypen in ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 ist ein Softwaresystem, mit dem Daten aus unterschiedlich aufgebauten Dokumenten erfasst werden können.

Dabei können verschiedene Dokumenttypen in einem Durchgang verarbeitet werden. Sie können das Programm zudem so konfigurieren, dass Dokumente mit einer Kombination verschiedener Dokumenttypen, z. B. Dokumente mit strukturierten und teilweise strukturierten Bereichen, verarbeitet werden. Die einzelnen Dokumenttypen wirken sich lediglich auf die Systemkonfiguration und dabei vor allem auf die Erstellung von Dokumentdefinitionen aus. Sie haben keinerlei Einfluss auf die Arbeit der Operatoren.

ABBYY FlexiCapture kann für die automatische Erfassung der folgenden Dokumente in einem Durchgang konfiguriert werden:

Strukturierte Dokumente (statische Formulare):
Strukturierte Dokumente verfügen über eine Reihe markierter Informationsfelder, deren Formatierung, Anzahl und Layout bei den verschiedenen Instanzen des Dokuments unverändert bleiben. Diese Dokumente werden auch als statische Formulare bezeichnet. Die meisten Fragebogen und Antragsformulare können als statische Formulare betrachtet werden. Derartige Formulare werden in der Regel als leere Formulare verteilt und dann von Hand ausgefüllt.

Um ein statisches Formular innerhalb eines Dokumentstapels zu erkennen und Daten daraus extrahieren zu können, müssen Sie ein statisches Layout erstellen, auf dessen Grundlage das Programm die Felder erkennen kann, aus denen Daten zu extrahieren sind.

Am effektivsten lassen sich statische Formulare verarbeiten, die an die Anforderungen der automatischen Datenerfassung angepasst sind. Diese Formulare werden auch als maschinenlesbare Formulare bezeichnet. Weitere Informationen über Anforderungen an diese Formulare sowie Hinweise zu ihrer Erstellung finden Sie im Abschnitt Erstellen von maschinenlesbaren Formularen.

Ein besonders effizientes Programm zum Erstellen maschinenlesbarer Formulare ist ABBYY FormDesigner 9.0, das im Lieferumfang von ABBYY FlexiCapture 9.0 enthalten ist. Hinweise zum Entwerfen von Formularen mit ABBYY FormDesigner 9.0 finden Sie im Benutzerhandbuch und in der Online-Hilfe.

Die wichtigsten Schritte zum Erstellen einer Dokumentdefinition werden speziell für strukturierte Dokumente beschrieben.
Teilweise strukturierte Dokumente (flexible Formulare):
Hierbei handelt es sich um Dokumente mit einem Satz von Datenfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Diese Dokumente werden auch als flexibel bezeichnet. Ein gutes Beispiel für flexible Dokumente sind Rechnungen, da bei ihnen die Anzahl und das Format der Datenfelder je nach Unternehmen unterschiedlich sein können Natürlich verfügen alle Rechnungen über eine Rechnungsnummer und einen Zahlbetrag, allerdings können sich diese Felder an sehr unterschiedlichen Stellen im Dokument befinden.

Um flexible Dokumente zu erkennen und Daten daraus zu extrahieren, werden in ABBYY FlexiCapture 9.0 sogenannte FlexiLayouts verwendet. FlexiLayouts können mithilfe von ABBYY FlexiLayout Studio erstellt werden. Ausführliche Informationen über dieses Programm finden Sie im Benutzerhandbuch und in der Online-Hilfe.

Die Verarbeitung flexibler Dokumente unterscheidet sich von der Verarbeitung statischer Dokumente nur im Hinblick auf das Erstellen und Laden der Layouts. Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.
Nicht strukturierte Dokumente mit freiem Layout:
Mithilfe von ABBYY FlexiCapture 9.0 können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Diagramme. Das Programm kann nicht strukturierte Dokumente automatisch als Anlagen statischer bzw. flexibler Dokumente erkennen. Die Erkennung ist auch mithilfe eines FlexiLayouts möglich. Die Dokumente werden dann als durchsuchbare PDF-Dateien oder als Grafikdateien exportiert. Indexfelder können aus nicht strukturierten Dokumenten sowohl automatisch (mithilfe eines FlexiLayouts) als auch durch manuelle Eingaben extrahiert werden.

Ein typisches Beispiel für die Verarbeitung nicht strukturierter Dokumente ist die Übertragung eines Papierarchivs in ein elektronisches Format und das Extrahieren mehrerer Indexfelder für die Organisation einer attributbasierten Schnellsuche.

Nähere Informationen hierzu finden Sie unter Verarbeiten nicht strukturierter Dokumente.


Kurzbeschreibung der Dokumentverarbeitung mit ABBYY FlexiCapture 9.0

In diesem Abschnitt finden Sie eine allgemeine Übersicht über die Verarbeitung von Dokumenten mit ABBYY FlexiCapture 9.0.

Die Programmverwendung wird in den Abschnitten Konfigurieren des Programms und Arbeiten mit einem konfigurierten Projekt genauer beschrieben.

Übersicht über die Konfiguration des Programms für die Dokumentverarbeitung
Übersicht über die Arbeit mit einem konfigurierten Programm


Kurzbeschreibung der Programmeinstellungen für die Dokumentverarbeitung

Das Programm wird durch die Administratoren für die Verarbeitung bestimmter Dokumenttypen konfiguriert. Um das Programm auf die Dokumentverarbeitung vorzubereiten, muss Folgendes erstellt werden:

  1. Ein Projekt

    Ein Projekt enthält alle Einstellungen für das Verarbeiten eines bestimmten Dokumenttyps: Bildimportprofile, Dokumentdefinitionen und Dokumentstapel für die Verarbeitung.

  2. Eine oder mehrere Dokumentdefinitionen

    Der wichtigste Schritt beim Konfigurieren eines Projekts ist das Erstellen einer Dokumentdefinition. Wenn Sie die Verarbeitung unterschiedlicher Dokumenttypen auf einmal planen, müssen Sie in einem Projekt mehrere Dokumentdefinitionen erstellen.

  3. Bildimportprofile

    Durch Importprofile wird die Arbeit der Operatoren vereinfacht und optimiert. Wenn keine Importprofile konfiguriert wurden, müssen Sie jedes Mal, wenn Sie Bilder hinzufügen, die Importquelle auswählen und die Einstellungen konfigurieren. Mit Importprofilen können Sie Bilder mit nur einem Mausklick auf eine Schaltfläche hinzufügen und sehr schnell zwischen Importquellen wechseln.

  4. Ein Dokumentstapel

    Die zur Verarbeitung gesendeten Dokumente werden Stapeln hinzugefügt. Die Zuweisung von Dokumenten zu Stapeln ist benutzerdefiniert: Sie können alle Dokumente in einem Stapel verarbeiten, Stapel aus Dokumenten erstellen, die am gleichen Datum hinzugefügt wurden, oder Stapel aus einem Stapel erstellen, der in einem Durchgang gescannt wurde. Wenn Sie Bilder hinzufügen, für die keine Stapel vorhanden sind, wird automatisch ein Stapel erstellt.

Weitere Informationen zum Konfigurieren des Programms


Verteilte Arbeit

ABBYY FlexiCapture 9.0 (Verteilte Installation) ist ein verteiltes Client/Server-System für die Datenerfassung.

ABBYY FlexiCapture 9.0 (Verteilte Installation) beinhaltet mehrere Stationen und Server. Jede Station ist für bestimmte Verarbeitungsvorgänge zuständig. Die Server sichern den Betrieb des gesamten Komplexes, ermöglichen die Verbindung der Stationen miteinander und verteilen die Arbeitslast. Vor der Verarbeitung von Dokumenten müssen die Server konfiguriert werden.

Es folgt eine kurze Übersicht über die Komponenten:

  • Verwaltungs- und Überwachungskonsole

    Nach der Installation des Systems müssen Sie eine Datenbankverbindung herstellen und den Operatoren geeignete Berechtigungen erteilen. Dies wird über die Verwaltungs- und Überwachungskonsole vom Operator mit Administratorrechten durchgeführt.

    Die Verwaltungs- und Überwachungskonsole ist eine webbasierte Benutzerschnittstelle, die den Anwendungsserver steuert. Auf die Konsole kann von jedem Computer aus zugegriffen werden, der mit dem Anwendungsserver mit der Adresse http:\\<Anwendungsserver>\FlexiCapture verbunden ist, wobei <Anwendungsserver> der Name des Computers ist, auf dem der Anwendungsserver installiert ist.

    Während der Dokumentverarbeitung können über die Konsole Statistiken abgerufen und Berichte erstellt werden.

  • Projektkonfigurationsstation

    Der nächste Schritt ist die Erstellung und Konfiguration eines Projekts. Zu diesem Zweck erstellt der Operator der Station Dokumentdefinitionen und Stapeltypen und gibt die Reihenfolge der Verarbeitung vor. Wenn das System konfiguriert wurde, wird das Projekt zum Anwendungsserver hochgeladen, und die Dokumentverarbeitung kann beginnen.

  • Scanstation

    Die Scanstation ist möglicherweise die erste Station, auf der die zu verarbeitenden Dokumente eintreffen. Der Operator dieser Station erstellt Stapel und fügt ihnen Dokumentbilder hinzu. Bei Bedarf können die hinzugefügten Bilder bearbeitet werden. Der Stapel wird dann zur weiteren Verarbeitung an ABBYY FlexiCapture geschickt.

    Die Benutzung einer Scanstation ist nicht notwendig, wenn die zu verarbeitenden Bilder aus einem Hot Folder stammen.

  • Verarbeitungsstation

    Die Verarbeitungsstation arbeitet selbstständig und führt die folgenden Operationen aus: Bilder aus Hot Foldern laden, Dokumentdefinitionen zuweisen und Dokumente erkennen, Regeln validieren und die Ergebnisse an ein vom Benutzer festgelegtes Ziel exportieren.

  • Datenverifizierungsstation

    Zweck dieser Station ist die Prüfung der erfassten Daten. Der Operator der Station betrachtet unzuverlässig erkannte Schriftzeichen erst in der Gruppenansicht und dann in der Feldansicht. Danach wird der Stapel zur Verifizierungsstation geschickt. Falls ein Verarbeitungsfehler auftritt, kann der Operator der Datenverifizierungsstation den Stapel oder die Dokumente in die Ausnahmen-Warteschlange einreihen, wo sie vom Hauptverifikator bearbeitet werden.

  • Verifizierungsstation

    Diese Station führt tiefergehende Prüfungen als die Datenverifizierungsstation durch. Neben Datenprüfungen kann die Station problematische Stapel oder Dokumente abarbeiten, Zusammenstellungsfehler korrigieren, Regeln kontrollieren und die Stapelintegrität überprüfen.

  • Verarbeitungsserver

    Der Verarbeitungsserver verteilt die Arbeitslast auf die verschiedenen Verarbeitungsstationen. Zusammen mit dem Server wird der Monitor des Verarbeitungsservers installiert, der zur Überwachung des Serverbetriebs und zur Festlegung von Aufgabenprioritäten verwendet wird.

  • Anwendungsserver

    Der Anwendungsserver verbindet die Stationen miteinander und sichert ihren Betrieb. Vergewissern Sie sich vor der Installation des Servers, dass alle für seinen ordnungsgemäßen Betrieb erforderlichen Komponenten installiert sind.

  • Datenbankserver

    Der Datenbankserver speichert die für Verarbeitungsvorgänge notwendigen Daten: Informationen über die Operatoren, Stapel, Ereignisse u.a. Falls sich nicht mehr als 50 Verifizierungsstationen im System befinden und nicht mehr als 100.000 Dokumente pro Tag verarbeitet werden, können Sie Microsoft SQL Server Express Edition verwenden. Bei größeren Volumina wird die Verwendung der Vollversion von Microsoft SQL Server und/oder Dateiablageordnern empfohlen.

  • Dateiablageordner

    Die Projektdateien können entweder in einer Datenbank oder einem separaten Dateiablageordner gespeichert werden, bei dem es sich um einen gewöhnlichen Ordner des Computers handelt, auf dem sich der Anwendungsserver befindet. Dateiablageordner können über die Verwaltungs- und Überwachungskonsole eingerichtet werden.

  • Sicherheitsserver

    Für den Normalbetrieb des Systems ist ein Sicherheitsschlüssel erforderlich. ABBYY FlexiCapture 9.0 Lizenzmanager ist eine Anwendung zur Verwaltung von Sicherheitsschlüsseln

Installation der Stationen für ABBYY FlexiCapture 9.0
Konfiguration von Verarbeitungsserver und Stationen
Architektur und Grundprinzipien von ABBYY FlexiCapture 9.0
Konfiguration des Anwendungsservers


Erstellen eines Projekts

Damit Sie unterschiedliche Dokumente in einem Projekt verarbeiten können, muss dieses über mehrere Dokumentdefinitionen verfügen. Wenn sich die Dokumente nicht überschneiden und sich ihre Verarbeitungseinstellungen deutlich unterscheiden, können Sie auch getrennte Projekte erstellen.

Dazu müssen Sie zunächst mindestens ein Projekt erstellen.

Um ein neues Projekt zu erstellen, startet Sie die Projektkonfigurationsstation und wählen Sie Datei>Neues Projekt…

Weitere Informationen zum Erstellen eines Projekts


Übersicht über das Erstellen einer Dokumentdefinition

Die Erstellung von Dokumentdefinitionen ist der entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

In einer Dokumentdefinition sind die Positionen von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben.

Zum Erstellen einer Dokumentdefinition starten Sie den Dokumentdefinitionsassistenten:

  1. Wählen Sie im Hauptfenster der Projektkonfigurationsstation Projekt>Dokumentdefinitionen…
  2. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Dokumentdefinitionsassistenten.

Die einzelnen Schritte bei der Erstellung von Dokumentdefinitionen hängen vom verarbeiteten Dokumenttyp ab.

Die wichtigsten Schritte beim Erstellen einer Dokumentdefinition für statische Formulare
  1. Erstellen Sie mit dem Dokumentdefinitionsassistenten eine neue Dokumentdefinition. Öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, auf dessen Basis die Markierungen der Dokumentdefinition erstellt werden.
  2. Markieren Sie die statischen Elemente (Anker und Objekte zur Identifizierung), und konfigurieren Sie ihre Eigenschaften. Statische Elemente werden zur Zuordnung und Identifizierung der Dokumentdefinition verwendet. Normalerweise werden statische Elemente automatisch erkannt und Standardeigenschaften zugeordnet.
  3. Markieren Sie die Felder auf dem Bild. Felder werden für die Datenextraktion verwendet.
  4. Konfigurieren Sie die Feldeigenschaften. Feldeigenschaften beeinflussen die Erkennungsqualität und legen fest, ob die Werte der Felder exportiert und zur Überprüfung an den Operator gesendet werden. Sie geben die Datentypen und den Wertebereich eines Felds an.
  5. Erstellen einer Dokumentdefinition für mehrseitige Dokumente: Fügen Sie Seiten hinzu, und wiederholen Sie sämtliche Schritte für alle Seiten.
  6. Konfigurieren Sie den Datenexport.
  7. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.
  8. Testen Sie eine Dokumentdefinition mithilfe der Bilder verschiedener Dokumente.

Hinweis:Wenn Sie mit ABBYY FormDesigner maschinenlesbare Formulare erstellt haben, müssen Sie anstelle der ersten drei Schritte lediglich eine Datei mit der Dateinamenerweiterung *.xfd importieren. Daraufhin wird ein Seitenbild mit vorbereiteter Markierung geöffnet (bzw. Bilder mehrerer Seiten, wenn Sie mit ABBYY FormDesigner ein mehrseitiges Formular erstellt haben). Einzelheiten finden Sie unter Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare.

Die wichtigsten Schritte beim Erstellen einer Dokumentdefinition für flexible Dokumente
  1. Erstellen Sie mit ABBYY FlexiLayout Studio ein FlexiLayout (eine Datei mit der Dateinamenerweiterung *.afl). Einzelheiten finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.
  2. Erstellen Sie mit dem Dokumentdefinitionsassistenten eine neue Dokumentdefinition. Öffnen Sie während der Ausführung des Assistenten das Bild der Dokumentseite, und fügen Sie ein FlexiLayout an (die von Ihnen erstellte AFL-Datei). Nach Abschluss des Assistenten werden auf dem Bild die Feldmarkierungen angezeigt.
  3. Konfigurieren Sie die Feldeigenschaften. Folgen Sie dabei den Schritten beim Konfigurieren der Dokumentdefinitionseigenschaften für ein statisches Formular.
  4. Konfigurieren Sie den Datenexport.
  5. Sie können ggf. auch das Verfahren festlegen, mit dem die Daten im Dokumentfenster angezeigt werden, auf Regeleinhaltung geprüft werden usw.
  6. Testen Sie eine Dokumentdefinition mithilfe der Bilder verschiedener Dokumente.

Bei kombinierten Dokumenttypen, die Seiten mit statischen Formularen und teilweise strukturierte Bereiche enthalten, können Sie ein FlexiLayout als einen der Dokumentdefinitionsbereiche anfügen. Erstellen Sie zunächst eine Dokumentdefinition für einen der Bereiche (flexibel oder statisch), und fügen Sie dann einen neuen Bereich eines anderen Typs hinzu.

Sie können in einem Durchgang Dokumente unterschiedlichen Typs verarbeiten: Sie können als Teil desselben Projekts sowohl Dokumentdefinitionen für statische Formulare und flexible Dokumente als auch Dokumentdefinitionen für kombinierte Dokumenttypen erstellen. Das Programm wählt dann automatisch eine Dokumentdefinition aus.

Für die Verarbeitung von Dokumenten mit Anhängen erstellen Sie eine Dokumentdefinition und aktivieren dann in den Dokumentdefinitionseigenschaften die Option Anhangseiten berücksichtigen. Siehe Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Weitere Informationen über das Erstellen von Dokumentdefinitionen


Erstellung von Stapeltypen

Dokumente werden in Stapeln verarbeitet. Stapel werden beim Importieren oder Scannen von Dokumenten erstellt Gleichzeitig wird jedem Stapel ein Typ zugeordnet.

Der Stapeltyp legt die folgenden Dokumentverarbeitungsparameter fest:

  • Bildvorverarbeitung
  • Abgleich von Dokumentdefinitionen mit den entsprechenden Dokumenten
  • Stapelintegritätsprüfung
  • Standard-Stapel-Export
  • Stapelverarbeitung
Stapeltypen
Erstellen von Dokumentstapeln


Erstellen von Importprofilen

Die Dokumentverarbeitung beginnt mit dem Hinzufügen neuer Bilder zum Stapel. Dabei kann es sich um zu scannende Papierdokumente oder um zu importierende elektronische Bilddaten handeln.

Bilder können hinzugefügt werden:

  • automatisch auf den Verarbeitungsstationen

    Zur Automatisierung des Bildimports müssen Sie auf der Projektkonfigurationsstation ein Bildimportprofil erstellen und die zu verwendenden Hot Folder festlegen. Die Bilder werden dann automatisch aus den Hot Foldern importiert.

  • manuell durch die Operatoren der Scanstationen. Um scannen zu können, muss der Operator einer Scanstation Scanprofile erstellen.

    Bei häufig wechselnder Bildquelle kann es sinnvoll sein, mehrere Importprofile zu erstellen. Der Operator kann dann jeweils das für die Quelle geeignete Profil wählen.

Auf der Projektkonfigurationsstation können Sie Dokumentdefinitionen auf Fehler untersuchen, indem Sie Stapel erstellen, ihnen Dokumentbilder hinzufügen und diese verarbeiten. Das Hinzufügen von Bildern kann ebenfalls automatisiert werden: Der Operator der Projektkonfigurationsstation kann ein Bildimportprofil erstellen, das einen Scanner benutzt.

Bildimportprofile


Erstellen von Dokumentstapeln

Zu verarbeitende Dokumente werden in Stapeln zusammengefasst. Das Prinzip der Dokumentgruppierung in Stapel wird vom Benutzer bestimmt. Der Benutzer kann beispielsweise wählen, alle Dokumente als einen Stapel zu verarbeiten oder die Dokumente zu gruppieren, die am gleichen Tag importiert oder in einem Durchgang gescannt wurden.

Stapel können automatisch erstellt werden, wenn Bilder aus Hot Foldern importiert oder auf der Scanstation gescannt werden. Wenn Sie einen neuen Stapel erstellen möchten, klicken Sie mit der rechten Maustaste auf die Stapelliste im Hauptfenster, und wählen Sie im Kontextmenü die Option Neuer Stapel… aus.

Beim Erstellen eines Stapels wird sein Typ angegeben, der die Reihenfolge bestimmt, in welcher der Stapel verarbeitet wird.

Weitere Informationen über das Erstellen von Dokumentstapeln


Übersicht über die Arbeit von Operatoren mit einem konfigurierten Programm

Die Operatoren verwenden ein Programm, dass für die Verarbeitung bestimmter Dokumenttypen vorkonfiguriert wurde. Die Dokumentverarbeitung ist bei allen Dokumenttypen gleich und umfasst folgende Schritte:

  1. Bilder werden hinzugefügt

    Die Dokumentverarbeitung beginnt mit der Erfassung von Bildern – entweder durch Scannen und dem manuellen Hinzufügen von Bildern oder durch Verwendung von Scanprofilen. Alle Operationen, die zur Erfassung von Bildern durchgeführt werden müssen, werden vom Operator der Scanstation ausgeführt.

  2. Starten des Erkennungsvorgangs

    Die Erkennung erfolgt automatisch auf der Verarbeitungsstation: das Programm wählt die entsprechende Dokumentdefinition basierend auf den Positionen der statischen Elemente aus, ordnet die Dokumentdefinition zu und erkennt die Daten in den Feldern, die in der Dokumentdefinition angegeben wurden.

  3. Überprüfung

    Überprüfung – Die Überprüfung der Daten ist der aufwändigste Teil der Arbeit von Operatoren. Er umfasst Folgendes:

    • Überprüfung der Dokumentzusammenstellung – Überprüfung, ob die Dokumentseiten richtig zusammengefasst wurden;
    • Gruppenüberprüfung – visuelle Überprüfung von Gruppen von als gleich erkannten Zeichen;
    • Feldüberprüfung – Überprüfung von nicht eindeutig erkannten Zeichen im Kontext von Feldern mit einem bekannten Wertebereich;
    • Regelbasierte Validierung – Überprüfung auf Regelfehler.
    • Stapelintegritätsüberprüfung – Start der Integritätsskripte und Behebung der Fehler.

    Dokumente können auf zwei Stationen überprüft werden.

    Die Grundüberprüfung wird auf der Datenverifizierungsstation durchgeführt, auf der nur die Gruppen- und Feldüberprüfungsmodi für den Operator verfügbar sind.

    Komplexere Überprüfungen werden auf der Verifizierungsstation durchgeführt, wo der Überprüfungsoperator und der leitende Überprüfungsoperator neben den Daten die Dokumentzusammenstellung überprüfen und Regelfehler korrigieren können.

  4. Datenexport

    Die Daten werden automatisch auf der Verarbeitungsstation in Übereinstimmung mit den Einstellungen in der Dokumentdefinition exportiert. Ein Stapel wird entweder sofort nach seiner Verarbeitung oder nach der Bestätigung durch den leitenden Überprüfungsoperator exportiert (die entsprechenden Einstellungen werden für jeden Stapeltyp vorgenommen).

Weitere Informationen über die Arbeit von Operatoren mit konfigurierten Projekten


Operatoren von ABBYY FlexiCapture 9.0

Operatoren sind Benutzer von ABBYY FlexiCapture 9.0, für die eine Dokumentverarbeitungsrolle festgelegt und die entsprechenden Berechtigungen erteilt wurden. Die Zugriffsrechte der Operatoren unterscheiden sich je nach Zuständigkeitsbereich.Die Zugriffsrechte eines Operators hängen von der Rolle des Operators ab.

Die folgenden Rollen stehen unter ABBYY FlexiCapture 9.0 zur Verfügung (eine Rolle wird immer für das aktuelle Projekt festgelegt):

  • Scanoperator – Operatoren mit dieser Rolle können Scanstationen benutzen
  • Datenüberprüfungsoperator – Operatoren mit dieser Rolle können Datenprüfungs- und Verifizierungsstationen benutzen
  • Überprüfungsoperator – Operatoren mit dieser Rolle können Verifizierungsstationen benutzen (nur Datenprüfungen, Zusammenstellungsfehler und regelbasierte Validierung sind zugänglich)
  • Leitender Überprüfungsoperator – Operatoren mit dieser Rolle können Verifizierungsstationen benutzen (alle Funktionen der Station sind zugänglich)
  • Überwachungsoperator – Operatoren mit dieser Rolle können die Verwaltungs- und Überwachungskonsole benutzen (alle Funktionen außer der Konfiguration sind zugänglich)
  • Projektkonfigurator – Operatoren mit dieser Rollen können Projektkonfigurationsstationen benutzen
  • Administrator – Operatoren mit dieser Rolle können die Verwaltungs- und Überwachungskonsole benutzen (alle Funktionen sind zugänglich). Administatoren können außerdem auf alle Stationen des Systems zugreifen. Die Administratorrechte gelten für alle zum Anwendungsserver hochgeladenen Projekte, nicht nur für die aktuellen.

Die Rolle eines Operators entscheidet darüber, auf welche Stationen er zugreifen kann und aus welchen Warteschlangen er während der Dokumentverarbeitung Aufgaben erhalten kann.

Die Rollen „Administrator“ und „Überwachungsoperator“ gelten jeweils für das gesamte System. Andere Operatorrollen gelten nur für einzelne Projekte. Die Zugriffsrechte der Rollen „Scanoperator“, „Datenüberprüfungsoperator“ und „Leitender Überprüfungsoperator“ können sich außerdem je nach Stapeltyp unterscheiden. Ein Benutzer könnte daher gleichzeitig die folgenden Rollen innehaben:

  • Projekt A: Projektkonfigurator
  • Projekt B:
    • Stapel Typ 1: Leitender Überprüfungsoperator
    • Stapel Typ 2: Datenüberprüfungsoperator


Hinzufügen von Bildern

Normalerweise werden Bilder auf der Scanstation hinzugefügt (weitere Informationen siehe Scanstation-Hilfe). Der Hauptverifikator kann jedoch auch Bilder auf seiner/ihrer Station hinzufügen.

Um Bilder auf der Verifizierungsstation hinzuzufügen, wählen Sie den Stapel, dem die Bilder hinzugefügt werden sollen, oder erstellen einen neuen. Bilder können auf zwei Arten hinzugefügt werden:

  • Durch Scannen (Datei>Bilder scannen…Bilder scannen… wählen)
  • Aus Bilddateien (Datei>Bilder laden…Bilder laden… wählen)

Zur Untersuchung von Dokumentdefinitionen auf Fehler können auf der Projektkonfigurationsstation Bilder hinzugefügt werden.

Hinzufügen von Seitenbildern


Starten der Erkennung und Analysieren und Zuordnen einer Dokumentdefinition

Normalerweise werden Dokumente erkannt, analysiert und Dokumentdefinitionen automatisch zugeordnet. Diese Operationen können jedoch auch manuell auf der Verifizierungsstation und der Projektkonfigurationsstation gestartet werden.

Um die Bilder zu erkennen, wählen Sie im Hauptmenü Erkennung>Erkennen.

Um die Bilder zu analysieren, wählen Sie im Hauptmenü Erkennung>Analysieren. Wenn eine Dokumentdefinition auf ein Dokument passt, werden die Seite und ihr Dokument die entsprechenden Namen haben. Wenn keine der Dokumentdefinitionen im Projekt zu einem Bild passt, wird die Seite als unbekannt gekennzeichnet.

Das System erlaubt es, eine bestimmte Dokumentdefinition auf eine Seite oder das gesamte Dokument anzuwenden. In den meisten Fällen wird eine richtig erstellte Dokumentdefinition automatisch ihrer Seite zugeordnet, aber in einigen Fällen kann eine manuelle Zuordnung erforderlich sein. Um eine Dokumentdefinition zuzuordnen, wählen Sie die Seite oder das Dokument, der bzw. dem Sie die Dokumentdefinition zuordnen möchten, und wählen Sie dann im Hauptmenü Erkennung>Dokumentdefinition zuordnen….

Weitere Informationen über die Erkennung


Überprüfung

Bei der Überprüfung wird festgestellt, ob die Daten erkannt wurden, die Seiten korrekt in Dokumente zusammengefasst wurden und die Regeln keine Fehler zurückgegeben haben. Die Überprüfung wird auf der Datenverifizierungsstation (wo die Erkennungsgenauigkeit überprüft wird) und auf der Verifizierungsstation vorgenommen (wo alle Überprüfungstypen durchgeführt werden können). Die Überprüfung wird für Tasks durchgeführt.

Die Überprüfung startet, wenn ein Task auf der Station ankommt. Zuerst erfolgt die Gruppenüberprüfung, danach die Feldüberprüfung. Wenn eine Dokumentdefinition über keine Felder verfügt, die in die Gruppen- oder Feldüberprüfung einbezogen werden, wird der entsprechende Überprüfungsschritt übersprungen.

Bei mehrseitigen Dokumenten müssen Sie möglicherweise auch Zusammenstellungsfehler im Dokument korrigieren. Seiten werden automatisch zu Dokumenten zusammengestellt. Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Eine Beschreibung des Fehlers finden Sie in roten Buchstaben unter dem Namen der Dokumentdefinition. Sie müssen beim Erstellen einer Dokumentdefinition eine Regel für die Dokumentzusammenstellung definieren. Diese umfasst Festlegungen zur Reihenfolge und Anzahl der Seitenwiederholungen. Außerdem können Sie die Überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren: dabei müssen die Werte von Schlüsselfeldern auf sämtlichen Seiten des Dokuments gleich sein. Bei Abweichungen wird eine entsprechende Meldung angezeigt, und die Werte der Schlüsselfelder werden rot hervorgehoben. Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt.

Bei der Gruppenüberprüfung werden Gruppen von als gleich erkannten Zeichen für die Überprüfung übermittelt. Der Operator muss dann abweichende Zeichen bestimmen, die falsch erkannt wurden. Nachdem der Operator das Feld mit diesem Zeichen angezeigt hat, kann er seine Werte berichtigen. Wenn ein Zeichen nicht korrigiert werden kann, können Sie es als nicht eindeutig markieren.

Bei der Feldüberprüfung werden Felder mit einem bekannten Wertebereich zur Überprüfung übermittelt. Der Operator muss dann nicht eindeutig erkannte Zeichen im Kontext des vollständigen Felds überprüfen. Die Feldüberprüfung kann in zwei Modi durchgeführt werden: in der Einzelfeldansicht mit Zeichenausschnitten und in der Ansicht mehrerer gleichartiger Felder.

Nicht eingehaltene Regeln werden durch: eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet. Der Operator muss Felder mit Regelfehlern überprüfen und ggf. korrigieren.

Die Datenüberprüfung kann auch im Dokumentfenster durchgeführt werden, das Sie durch Doppelklicken auf den Namen eines Dokuments oder einer Seite öffnen. Im Dokumentfenster werden nicht einzelne Felder, sondern das gesamte Dokument angezeigt. Außerdem enthält es alle nicht eindeutig erkannten Zeichen, Regelfehler usw.

Weitere Informationen über die Überprüfung


Exportieren

Daten werden automatisch exportiert. Falls erforderlich, kann vom Verifikator eine separate Exportbestätigungs-Warteschlange erstellt werden. In diesem Fall wird der Export nach Erhalt der Bestätigung durchgeführt. Die Daten werden gemäß den Einstellungen in der Dokumentdefinition exportiert.

Um Dokumente manuell zu exportieren, wählen Sie eine der Optionen im Menü Datei>Exportieren nach:

  • Daten in Dateien… – um Daten in Dateien zu exportieren
  • Bilder in Dateien… – um Bilder in Dateien zu exportieren
  • Datenbank… – um das Dokument in die Datenbank zu exportieren

Ändern Sie bei Bedarf die Standard-Exporteinstellungen und exportieren Sie die Daten.

Markierte Liste Weitere Informationen über das Exportieren


Installieren und Ausführen des Programms

Dieser Abschnitt enthält grundlegende Informationen zum Installieren, Schützen und Ausführen von ABBYY FlexiCapture 9.0. Außerdem enthält er die Systemanforderungen für die Installation.

Programmschutz
Lizenzmanager für die Dongleverwaltung
Software- und Hardwareanforderungen
Installieren von ABBYY FlexiCapture 9.0
Ausführen der Software


Schutztypen

Für die Installation und Verwendung von ABBYY FlexiCapture 9.0 ist ein gültiger Lizenzschlüssel erforderlich.

ABBYY FlexiCapture 9.0 kann einen der beiden folgenden Typen von Lizenzschlüsseln enthalten:

  • Dongle
  • Softwareschlüssel

Dongle

Der Dongle wird an einen USB-Anschluss des Computers (USB-Dongle) angeschlossen.

Um ABBYY FlexiCapture 9.0 mit einem Dongle ausführen zu können, müssen Sie den zugehörigen Treiber mit dem Installationsprogramm installieren. Der Dongle muss immer angeschlossen bleiben, wenn die Software verwendet wird.

Auf dem Dongle sind die Parameter Ihrer Lizenz gespeichert.

Sie können einen leeren Dongle per Fernzugriff aktivieren, wofür lediglich die Seriennummer der Lizenz erforderlich ist. Dazu wird der Lizenzmanager verwendet, der über das Internet den Aktivierungsserver kontaktiert, die Parameter der Seriennummer abfragt und sie im Dongle speichert.

Wichtig!Für die Verwendung eines Dongles muss der Standarddienst für SmartCards ausgeführt werden.

Softwareschlüssel

Dies ist eine Lizenzdatei.

Wenn Sie ABBYY FlexiCapture 9.0 mit einem Softwareschlüssel ausführen möchten, muss die Lizenzdatei auf dem Aktivierungsserver von ABBYY aktiviert werden. Sie können Ihre Lizenz mit dem Lizenzmanager aktivieren.

Die für das Aktivieren der Lizenz erforderlichen Informationen werden kodiert (Produkt-ID) an ABBYY gesendet, wobei der Code auf Informationen über den Computer beruht, auf dem ABBYY FlexiCapture 9.0 installiert ist. Für die Generierung einer Produkt-ID werden keine persönlichen Informationen verwendet, auch ist es nicht möglich, mit diesem Code einen Benutzer zu identifizieren.

Aktivierungsmethoden:

  • Über das Internet
    Die Aktivierung erfolgt automatisch über das Internet und dauert nur wenige Sekunden. Sie benötigen für diese Methode eine funktionierende Internetverbindung.
  • Per E-Mail
    Bei dieser Aktivierungsmethode wird automatisch eine E-Mail mit einer Aktivierungsanfrage erstellt. Senden Sie diese E-Mail-Nachricht an die angegebene Adresse. Damit das automatische E-Mail-Programm direkt antworten kann, dürfen Sie weder den Betreff noch den Text der E-Mail ändern.

Bei der Aktivierung über das Internet sind keine weiteren Schritte erforderlich. Bei der Aktivierung per E-Mail wird Ihnen vom Aktivierungsprogramm eine Aktivierungsdatei zugesendet. Speichern Sie diese Datei auf Ihrer Festplatte, führen Sie den Lizenzmanager aus, und geben Sie den Pfad zu der gespeicherten Datei im Aktivierungsassistenten an.

Wiederholen der Aktivierung

Sie können ABBYY FlexiCapture 9.0 beliebig oft neu auf dem Computer installieren, auf dem die Software aktiviert wurde. Wenn Sie jedoch grundlegende Änderungen vornehmen, die Festplatte formatieren oder das Betriebssystem neu installieren, müssen Sie die Software möglicherweise erneut aktivieren.

Der Aktivierungsserver speichert ein Protokoll mit der Anzahl der Aktivierungen der einzelnen Seriennummern. Wenn ein bestimmter Schwellenwert überschritten wurde, wird die Seriennummer gesperrt und kann nicht mehr verwendet werden.

Sie können Lizenzen deaktivieren und wieder aktivieren, um sie auf einem anderen Computer zu verwenden. Wenn Sie eine Lizenz deaktivieren, verringert der Aktivierungsserver den Aktivierungszähler für diese Lizenz um eins.

Wichtig! Sie können das aktivierte Programm nur auf dem Computer verwenden, auf dem die Produkt-ID generiert wurde. Wenn Sie die Software auf einem anderen Computer verwenden möchten, müssen Sie die Lizenz zunächst deaktivieren.


Lizenzmanager (License Manager)

Mit dem Lizenzmanager werden die Zugangsschlüssel verwaltet und Informationen über den Status von ABBYY FlexiCapture-Lizenzen gesammelt.

Wichtig! Der Lizenzmanager ist ein Administratorprogramm. Zur Verwendung des Lizenzmanagers benötigen Sie lokale Administratorrechte.

Der Lizenzmanager wird zusammen mit dem Anwendungsserver installiert.

So starten Sie den Lizenzmanager:

  • Gehen Sie auf Start > Programme > ABBYY FlexiCapture 9.0 Server > Extras, und wählen Sie ABBYY FlexiCapture 9.0 Lizenzmanager aus.

Verwalten von Lizenzen

Hinzufügen einer neuen Lizenz

Klicken Sie im Hauptfenster des ABBYY FlexiCapture 9.0 Lizenzmanager auf Wählen...Im Dialogfeld Lizenz klicken Sie auf Aktivieren... Geben Sie die neue Seriennummer ein und klicken Sie auf Weiter. Wählen Sie dann eine Lizenzaktivierungsart aus und aktivieren Sie Ihre Lizenz. Die neue Lizenz wird im Hauptfenster des Lizenzmanagers angezeigt.

Aktualisieren einer Lizenz

Um eine Lizenz zu aktualisieren, gehen Sie zur Lizenzliste, indem Sie auf im Hauptfenster des Lizenzmanagers auf die Schaltfläche Wählen... klicken. Wählen Sie die zu aktualisierende Lizenz und klicken Sie auf Lizenz aktualisieren ... Sie müssen Ihre Lizenz außerdem über das Internet oder per E-Mail aktivieren. Befolgen Sie die auf dem Bildschirm angezeigten Anweisungen.

Lizenzparameter

Sie können im Lizenzmanager die Parameter Ihrer Lizenz ansehen. Wählen Sie eine Lizenz aus der Liste und klicken Sie auf Lizenzparameter...Die Parameter der aktuellen Lizenz werden in Kurzform im Hauptanwendungsfenster angezeigt.


Lizenzparameter

Jede Lizenz hat ihre eigene Seriennummer. Eine Lizenz umfasst einen Satz von Parametern, in dem festgelegt ist, ob der Benutzer die Berechtigung zur Durchführung bestimmter Vorgänge zur Dokumentverarbeitung hat.

Lizenzparameter:

  • Allgemein – Seriennummer, Lizenzart, Verfügbarkeit einer virtuellen Maschine
  • Lizenzzweck – Lizenztyp (Software oder Hardware), Möglichkeit der Bereitstellung von Dokumentverarbeitungsdiensten
  • Workstations, Werkzeuge – Einschränkungen bei der Anzahl der Stationen und Entwicklungswerkzeuge (FlexiLayout Studio, FormDesigner).
  • Zeit, Leistung – Einschränkungen der Verwendung
  • Verarbeitung – zusätzliche Parameter fpr die Dokumentverarbeitung: Verwendung von FlexiLayouts und zusätzlichen Erkennungssprachen
  • Benutzerdefinierte Komponenten – die Verwendung von vom Benutzer entwickelten Komponenten
  • Import – zusätzliche Importoptionen
  • Export – zusätzliche Exportoptionen


Software- und Hardwareanforderungen

Hardwareanforderungen

  1. Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™, AMD K6/Turion™/Athlon™/Duron™/Sempron™ 2 GHz Prozessor oder schneller
  2. 512 MB RAM für jeden CPU-Kern, jedoch nicht weniger als 1 GB
  3. Festplattenspeicher
    • Stationen: 1 GB, von denen 800 MB für die Installation der Stationen benötigt wird
    • Anwendungsserver: 50 MB
    • Verarbeitungsserver: 50 MB
    • Datenbankserver: 2 GB (bei Verwendung von Microsoft SQL Server Express Edition)
  4. TWAIN, WIA oder ISIS-Scanner
  5. Eine aktive Internet-Verbindung, um Ihre Seriennummer zu aktivieren, USB-Anschluss für einen Dongle
  6. Mindestens 1024×768 Grafikkarte und Monitor
  7. Tastatur, Maus oder anderes Zeigegerät

Softwareanforderungen

Server:

  1. Betriebssystem:
    • Windows Server 2003 SP2
    • Windows Server 2008 SP2
    • Windows Server 2008 R2

    Wenn Sie eine lokalisierte Benutzeroberfläche verwenden, muss Ihr Betriebssystem die entsprechende Sprache unterstützen.

  2. Internet Information Server 6, 7 oder 7.5 (für Anwendungsserver)
  3. .NetFramework 2.0 oder spätere Version
  4. Crystal Reports Basic Runtime für Visual Studio 2008
  5. Adobe Acrobat Reader 9
  6. Datenbankserver: Microsoft SQL Server 2005 oder 2008

Stationen

  1. Betriebssystem:
    • Windows XP SP2
    • Windows Vista SP2
    • Windows 7

    Stationen können auf Computern installiert werden, die unter Windows Server 2008 SP2 oder Windows Server 2008 R2 laufen, vorausgesetzt die Komponente Desktop Experience ist installiert.

    Wenn Sie eine lokalisierte Benutzeroberfläche verwenden, muss Ihr Betriebssystem die entsprechende Sprache unterstützen.

    Die Verwendung der Schriftart Arial Unicode MS wird empfohlen. Andere Schriftarten können CJK-Zeichen falsch anzeigen.

  2. Microsoft Internet Explorer 6, 7 oder 8 (im Kompatibilitätsmodus) für Überwachungsstation

Die Server und Stationen müssen im selben Active Directory sein.


Installation von ABBYY FlexiCapture 9.0

Es wird empfohlen, vor der Installation von ABBYY FlexiCapture 9.0 alle anderen Anwendungen (z. B. Microsoft Outlook oder Microsoft Word) zu schließen.

Wichtig: Das Konfigurationsprogramm kopiert temporäre Dateien in den durch die Umgebungsvariable %temp% definierten Ordner. Falls bei der Installation Probleme auftreten, stellen Sie sicher, dass auf den Ordner zugegriffen werden kann und genug freier Festplattenplatz zur Speicherung der temporären Dateien verfügbar ist.

Die Installation von ABBYY FlexiCapture 9.0 umfasst die folgenden Schritte:

  1. Installation der Server.
  2. Installation der Stationen.

Konfigurieren Sie das System nach Abschluss der Installation wie gewünscht.

Installation der Server für ABBYY FlexiCapture 9.0
Installation der Stationen für ABBYY FlexiCapture 9.0
Konfiguration von Verarbeitungsserver und Stationen


Installation der Server für ABBYY FlexiCapture 9.0

Die Server werden über das Installationsmenü der ABBYY FlexiCapture 9.0-Disk installiert. Die folgenden Server müssen installiert werden:

  • Anwendungsserver
  • Datenbankserver
  • Verarbeitungsserver
  • Sicherungsserver

Im Folgenden finden Sie Anleitungen zur Installation der einzelnen Server.

Anwendungsserver

Vergewissern Sie sich vor der Installation des Anwendungsservers, dass die folgenden Komponenten bereits vorhanden sind:

  • Net FrameWork 2.0 oder neuer
  • I nternet Information Services 6.0 oder 7.0 (Installation als Windows-Komponente)
  • Crystal Reports
  • Microsoft SQL Server (wählen Sie bei der Installation den Gemischten Modus)

Falls diese Komponenten noch nicht auf Ihrem Computer vorhanden sind, können Sie sie alle (mit Ausnahme von Internet Information Services) von der ABBYY FlexiCapture 9.0-Disk installieren.(Autorun, 2. Verteilte Installation>1. Installation externer Komponenten).

Falls bereits alle der oben genannten Komponenten installiert sind, können Sie mit der Installation des Anwendungsservers fortfahren. Im Menü Autorun 2. Verteilte Installation>2. Installation der Server wählen und den Anweisungen des Installationsassistenten folgen. Im Dialogfeld Benutzerdefinierte Installation die Option Anwendungsserver wählen.

Hinweis: Um das Installationsprogramm für Stationen auf den Server zu kopieren, wählen Sie im Dialogfeld Benutzerdefinierte Installation die Option Installationsprogramm für Stationen. Sie können dann die Stationen direkt vom Server anstatt von der Installations-Disk installieren.

Nachdem der Anwendungsserver installiert wurde, startet die Verwaltungs- und Überwachungskonsole automatisch. Sie können dort eine Datenbankverbindung einrichten und Benutzern Zugriffsrechte erteilen.

Datenbankserver

Der Datenbankserver speichert die für Verarbeitungsvorgänge von Dokumenten notwendigen Daten: Informationen über die Operatoren, Stapel, Ereignisse u.a. Falls sich höchstens 50 Verifizierungsstationen im System befinden und höchstens 100.000 Dokumente pro Tag verarbeitet werden, können Sie Microsoft SQL Server Express Edition verwenden. Bei größeren Volumina wird die Verwendung der Vollversion von Microsoft SQL Server und/oder Dateiablageordnern empfohlen.

Microsoft SQL Server Express Edition kann von der ABBYY FlexiCapture 9.0-Disk installiert werden: Im Menü Autorun 2. Verteilte Installation>1. Installation externer Komponenten wählen.

Verarbeitungsserver

Der Verarbeitungsserver verteilt alle Arbeiten auf die Verarbeitungsstationen. Zusammen mit dem Server wird der Monitor des Verarbeitungsservers installiert, der zur Überwachung des Serverbetriebs und Festlegung von Aufgabenprioritäten verwendet wird.

Zur Installation des Verarbeitungsservers wählen Sie im Menü Autorun 2. Verteilte Installation>2. Installation der Server und folgen den Anweisungen des Installationsassistenten. Im Dialogfeld Benutzerdefinierte Installation wählen Sie Verarbeitungsserver.

Nach der Installation des Verarbeitungsservers müssen Sie ihn konfigurieren (d.h. den Server starten, die Verarbeitungsstationen hinzufügen usw.).

Sicherungsserver

Das System verlangt einen gültigen Sicherheitsschlüssel , der durch ABBYYs Aktivierungsserver aktiviert werden muss. Dies kann mit dem Lizenzmanager durchgeführt werden, der nach der Installation des Sicherungsservers automatisch gestartet wird.

Zur Installation des Sicherungsservers wählen Sie im Menü Autorun 2. Verteilte Installation>2. Installation der Server und folgen dann den Anweisungen des Installationsassistenten. Wählen Sie im Dialogfeld Benutzerdefinierte Installation die Option Sicherungsserver.

Der Lizenzmanager dient der Verwaltung Ihrer Lizenzen, z.B. Hinzufügen, Aktivieren, Auswählen von Lizenzen und Anzeige ihrer Parameter.


Installation der Stationen für ABBYY FlexiCapture 9.0

Die Server werden über das Installationsmenü der ABBYY FlexiCapture 9.0-Disk installiert. Sie können die Stationen auch vom Server installieren, sofern die zu installierende Station bei der Einrichtung des Anwendungsservers auf den Server kopiert wurde.

Die folgenden Stationen müssen installiert werden:

  • Projektkonfigurationsstation

  • Scanstation

  • Datenverifizierungsstation

  • Verifizierungsstation

  • Verarbeitungsstation

Die Scan- und Datenverifizierungsstationen können sowohl in einem lokalen Netzwerk als auch dezentral über das Internet genutzt werden. Die Autorisierung wird mittels Benutzername und Passwort durchgeführt.


Installieren von ABBYY FlexiCapture 9.0 in einem lokalen Netzwerk

ABBYY FlexiCapture 9.0 kann einfach in einem lokalen Netzwerk installiert und verwendet werden.

Um die Stationen erfolgreich vom Server installieren zu können, müssen Sie beim Installieren des Anwendungsservers die Option Stations-Installationsprogramm auswählen. Die Dateien zur Installation der Stationen vom Server werden auf den Server kopiert.

ABBYY FlexiCapture 9.0 kann problemlos auf mehreren LAN-Computern bereitgestellt werden. Die Netzwerkinstallation erfolgt in zwei Schritten: als erstes werden die ABBYY FlexiCapture 9.0 Stationsdateien bei der Installation des Anwendungsserver auf den Server kopiert, danach können die Stationen vom Server über LAN installiert werden.

Ausführliche Anweisungen finden Sie im Handbuch für Administratoren, das im Menü Autorun zur Verfügung steht.


Ändern des Installationsmodus, Reparieren und Deinstallieren von ABBYY FlexiCapture 9.0

Reparieren und Deinstallieren von ABBYY FlexiCapture 9.0

So reparieren Sie beschädigte oder gelöschte Dateien:

  1. Wählen Sie Start > Systemsteuerung > Software und wählen Sie dann in der Liste der installierten Programme ABBYY FlexiCapture 9.0 Server oder ABBYY FlexiCapture 9.0 Stationen und klicken Sie auf Ändern.

  2. Wählen Sie Reparieren aus und klicken Sie auf Weiter.

So entfernen Sie ABBYY FlexiCapture 9.0 vom Computer:

  1. Wählen Sie Start > Systemsteuerung > Software und wählen Sie dann in der Liste der installierten Programme ABBYY FlexiCapture 9.0 Server oder ABBYY FlexiCapture 9.0 Stationen und klicken Sie auf Entfernen.

  2. Bestätigen Sie, dass das Programm entfernt werden soll.


Ausführen der Software

Die Server- und die Verarbeitungsstationsdienste werden automatisch gestartet. Die Stationen und der Verarbeitungsserver können entweder laufen oder gestoppt sein. Der Verarbeitungsserver wird vom Verarbeitungsservermonitor aus gestartet. Die Verarbeitungsstationen werden vom Benutzer oder automatisch vom Verarbeitungsserver gestartet (wenn die entsprechenden Einstellungen ausgewählt wurden).

Um den Betrieb des Verarbeitungsservers und des Anwendungsservers zu überwachen und zu steuern, wählen Sie die folgenden Optionen aus dem Menü Start:

  • Start/Programme/ABBYY FlexiCapture 9.0 Server/Verarbeitungsserver, um den Verarbeitungsservermonitor zu starten
  • Start/Programme/ABBYY FlexiCapture 9.0 Server/Administrations- und Überwachungs-Konsole, um die Hauptseite der Konsole in Ihrem Browser einzurichten und den Anwendungsserver zu steuern

ABBYY FlexiCapture 9.0 Stationen werden durch Auswahl der entsprechenden Menüoptionen in Start/Programme/ABBYY FlexiCapture 9.0 Stationen gestartet.

Registrierungsschlüssel, die den Start der Anwendung steuern

Sie können folgende Registrierungsschlüssel (in Shell\Start) verwenden, um zu steuern, wie die Anwendung gestartet wird:

  • Project – Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird;
  • Batch – Bestimmt den Stapel, der beim Start der Anwendung automatisch geöffnet wird (der Stapel muss angegeben werden);
  • ProhibitChangePath – Unterbindet das Ändern von Stapel und Projekt, die automatisch im Operatormodus geöffnet werden (setzen Sie den Schlüsselwert dazu auf „True“).

Diese Schlüssel werden nicht standardmäßig in der Registrierung erstellt. Falls erforderlich, kann der Administrator diese Schlüssel zur Registrierung des Benutzerbetriebssystems hinzufügen.

Die Registrierungsschlüssel können von den entsprechenden Startparametern der Befehlszeile überschrieben werden.

Befehlszeilen-Startparameter

Die folgenden Parameter können beim Start der Stationen über die Befehlszeile verwendet werden:

FlexiCapture.exe [/Station:(Setup,Validator,Verificator)] [/Project:"Projektpfad"] [/Batch:"Projektname"] [/ProhibitChangePath].

  • [/Station:(Setup,Validator,Verificator)] – bestimmt die Station (die entsprechende Projektkonfigurationsstation, Verifizierungsstation oder Datenverifizierungsstation). Wenn kein Modus bestimmt wurde, wird das Programm Sie dazu auffordern, einen Modus beim Start auszuwählen;
  • [/Project:"Projektpfad"] – Legt das Projekt fest, das beim Start der Anwendung automatisch geöffnet wird;
  • [/Batch:"Stapelname"] – Legt den Stapel fest, der beim Start der Anwendung automatisch geöffnet wird;
  • [/ProhibitChangePath] - Unterbindet das Ändern von Stapel und Projekt, die automatisch im Operatormodus geöffnet werden.


Verwenden von Vorlagen, die mit älteren Versionen von ABBYY FormReader erstellt wurden

Vorlagen, die in ABBYY FormReader 6.5 und 6.0 erstellt wurden, können in ABBYY FlexiCapture 9.0 importiert werden.

Wenn Sie eine Dokumentdefinition importieren, die mit einer älteren Version erstellt wurde, werden die Seitenmarkierungen (mit Ausnahme der Dienstfelder) und die Datentypen importiert. Die Datentypen werden in den Ordner Benutzerdefiniert der Dokumentdefinition kopiert. Weitere Informationen finden Sie unter Datentypen für Texteingabefelder.

Wichtig! Exporteinstellungen, Überprüfungsregeln und Bilder aus dem Stapel werden nicht importiert.

So importieren Sie eine Dokumentdefinition, die in ABBYY FormReader 6.5 oder 6.0 erstellt wurde:

  1. Starten Sie die Projektkonfigurationsstation.
  2. Erstellen Sie ein neues Projekt oder öffnen Sie ein vorhandenes Projekt, in das Sie eine Dokumentdefinition importieren möchten, die mit einer älteren Programmversion erstellt wurde.
  3. Wählen Sie im Hauptmenü Projekt > Dokumentdefinitionen…
    4. aus.
  4. Klicken Sie im Dialogfeld Dokumentdefinitionen auf Importieren….
  5. Wählen Sie aus der Dropdownliste Dateityp FormReader 6.5-Stapel (*.frm) aus, und wählen Sie dann den Stapel aus, dessen Dokumentdefinition Sie importieren möchten.

Die importierte Dokumentdefinition wird der Vorlagenliste hinzugefügt. Wenn der Stapel mehrere Dokumentdefinitionen enthält, werden alle Vorlagen importiert. Wenn Sie in ABBYY FormReader 6.5 eine Struktur für mehrseitige Dokumente ausgewählt haben, werden die durch diese Struktur beschriebenen Vorlagen in einer mehrseitigen Dokumentdefinition zusammengeführt.

Tipps:
  1. Einzelheiten zu den Unterschieden zwischen den Regeln der älteren und neueren Version finden Sie unter Vergleich von Regeln in FormReader 6.5 und FlexiCapture 9.0.
  2. Empfehlungen zur Migration von Wenn-Dann-Regeln, Automatisierungsregeln und Automatisierungsexporten aus FormReader 6.5 in FlexiCapture 9.0-Skripte finden Sie unter Migrieren von FormReader 6.5-Regeln und -Exporten in FlexiCapture 9.0-Skripte.


Architektur und Grundprinzipien von ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 ist eine verteilte Client/Server-Anwendung für die Datenerfassung.

ABBYY FlexiCapture 9.0 beinhaltet mehrere Stationen und Server. Die Stationen werden vom jeweiligen Operator bedient. Die Server laufen selbstständig.

Das System muss für die Erfassung von Daten aus Dokumenten konfiguriert werden:

  • Eine Datenbankverbindung herstellen (über die Verwaltungs- und Überwachungskonsole)

  • Projekte erstellen (auf der Projektkonfigurationsstation von einem Operator mit Administratorrechten)

  • Projekte konfigurieren (auf der Projektkonfigurationsstation von einem Operator mit Projektkonfigurator-Rechten.)

  • Für jedes Projekt Operatorrechte und -rollen festlegen (über die Verwaltungs- und Überwachungskonsole)

  • den Verarbeitungsserver starten

Nach der Systemkonfiguration können die Operatoren mit der Verarbeitung von Dokumenten beginnen:

  • Dokumentbilder hinzufügen

    An der Scanstation können Operatoren neue Dokumente scannen und Bilder bereits gescannter Dokumente hinzufügen. Die Verarbeitungsstation kann die im Hot Folder ankommenden Bilder automatisch registrieren.

  • die hinzugefügten Dokumentbilder erkennen

    Die Erkennung wird automatisch von der Verarbeitungsstation ohne Einwirken des Operators durchgeführt. Die Aufgaben werden vom Verarbeitungsserver unter den Stationen aufgeteilt.

  • die Ergebnisse überprüfen

    Die erkannten Daten werden auf der Datenprüfungsstation und der Verifizierungsstation überprüft. Ein Operator der Verifizierungsstation mit Verifikatorrechten kann weitergehende Prüfungen durchführen: die Dokumentzusammenstellung und Regelfehler auf Stapelebene kontrollieren.

  • die Ergebnisse exportieren

    Die Ergebnisse werden automatisch von der Verarbeitungsstation exportiert.


ABBYY FlexiCapture 9.0 Server

ABBYY FlexiCapture 9.0 (Verteilte Installation) beinhaltet Stationen und Server. Die Stationen sind für die Vorgänge der Dokumentverarbeitung verantwortlich, während die Server den Betrieb des gesamten Komplexes sicherstellen. Der Komplex umfasst folgende Server:

  • Anwendungsserver
  • Datenbankserver
  • Verarbeitungsserver
  • Sicherungsserver

Sie können auch einen Dateiablageordner (optional) erstellen, um Ihre Projektdateien zu speichern.


Anwendungsserver

Der Anwendungsserver gewährleistet den ordnungsgemäßen Betrieb des gesamten ABBYY FlexiCapture 9.0-Systems. Die verschiedenen Stationen kommunizieren über den Anwendungsserver miteinander.

Wir empfehlen Ihnen, den Anwendungsserver vor den Stationen zu installieren. Vergewissern Sie sich vor der Installation des Anwendungsservers, dass die folgenden Komponenten bereits installiert sind:

  • Net Framework 2.0 oder neuer
  • Internet Information Services 5.1, 6.0 oder 7.0
  • Crystal Reports (zum Drucken von Berichten in der Verwaltungs- und Überwachungskonsole)
  • Microsoft SQL Server (wählen Sie bei der Installation des SQL Servers den Gemischten Modus)

Hinweis: Falls die obigen Komponenten noch nicht auf Ihrem Computer vorhanden sind, können Sie sie alle (mit Ausnahme von Internet Information Services) von der ABBYY FlexiCapture 9.0-Disk installieren. Internet Information Services ist eine Windows-Komponente und wird zusammen mit dem Betriebssystem geliefert.

Wichtig:
  1. Falls Sie eine Firewall einsetzen, müssen Sie den World Wide Web Publishing Service erlauben.
  2. Wenn Sie die Scanstation über Benutzername und Passwort anstatt über Windows-Authentifizierung authentifizieren wollen, müssen Sie den Internet Information Server einrichten: Aktivieren Sie die einfache Authentifizierung (Basic Authentication) auf dem Level FlexiCapture/Server.

Nachdem der Anwendungsserver installiert wurde, startet die Verwaltungs- und Überwachungskonsole automatisch (sie wird zusammen mit dem Server installiert). Sie können dort eine Datenbankverbindung einrichten und Benutzern Zugriffsrechte erteilen.


Datenbankserver

Der Datenbankserver speichert Informationen über Operatoren, Stapel, Vorgänge, Aufgabenstatus, Verarbeitungsfortschritt und erfasste Daten.

Sie können Microsoft SQL Server Express Edition von der ABBYY FlexiCapture 9.0-Disk installieren. Dieses Programm ermöglicht Ihnen die Verarbeitung von bis 100.000 Seiten pro Tag mit bis zu 50 Verfizierungsstationen. Bei größeren Verarbeitungsvolumina wird die Verwendung der Vollversion von Microsoft SQL Server empfohlen.

Hinweis: Falls kein spezieller Dateiablageordner verwendet wird, werden die Projektdateien in der Datenbank gespeichert.


Verarbeitungsserver

Der Verarbeitungsserver verteilt alle Arbeiten auf die Verarbeitungsstationen. Zusammen mit dem Verarbeitungsserver wird ein Verarbeitungsserver-Monitor installiert, der zur Überwachung des Servers und zum Festlegen von Taskprioritäten dient. Die eigentlche Verarbeitung von Dokumenten erfolgt auf der Verarbeitungsstation.

Konfigurieren Sie den Verarbeitungsserver, sobald er installiert ist: Starten Sie den Server, fügen Sie die Verarbeitungsstationen hinzu, richten Sie sie ein und starten Sie sie, und aktivieren Sie Hot Folder.

Hinweis: Achten Sie darauf, dass vor dem Start des Verarbeitungsservers dem Konto, unter dem der Server ausgeführt wird, Zugriffsrechte für den Verarbeitungsserver zugewiesen wurden (<Domänenname\Computername>$).

Eine Beschreibung des Verfahrens zur Einrichtung ist unten aufgeführt.

  1. Starten Sie den Verarbeitungsserver.
  2. Starten Sie die Verarbeitungsstationen.
  3. Aktivieren Sie Hot Folder.

  • So starten Sie den Verarbeitungsserver:

    1. Starten Sie den Verarbeitungsserver-Monitor, indem Sie Start>Programme>ABBYY FlexiCapture 9.0 Server> Verarbeitungsserver wählen.
    2. Im Serverbaum wählen Sie ABBYY FlexiCapture 9.0 Server, klicken mit der rechten Maustaste darauf und wählen Server hinzufügen…
    3. Im Dialogfeld Verarbeitungsserver hinzufügen geben Sie den Speicherort des Servers (Netzwerkhost oder Lokaler Host) an.
    4. Wählen Sie Aktionen>Eigenschaften und geben Sie den Pfad zum Anwendungsserver (http://server) an. Wenn der Verarbeitungsserver und der Anwendungsserver auf demselben Computer installiert werden, geben Sie dessen Namen direkt an, weil die Verwendung der IP-Adresse 127.0.0.1 oder des Ausdrucks localhost die Verarbeitungsstationen funktionsunfähig macht.

      Hinweis: Starten Sie auf dem Anwendungsserver die Administrations- und Überwachungskonsole, und weisen Sie dem Computer, auf dem der Verarbeitungsserver installiert wird, die entsprechende Rolle zu.

    5. Klicken Sie auf [image], um den Anwendungsserver zu starten.

  • Um die Verarbeitungsstationen einzurichten:

    1. Wählen Sie im Serverbaum Stationen aus und klicken Sie auf [image]. Das Dialogfeld Stationen hinzufügen wird angezeigt. Wählen Sie aus der Gesamtliste die gewünschten Stationen aus. Sie können auch den Namen des Computers oder seine IP-Adresse angeben. Sie können den Namen des Computers sogar dann angeben, wenn dynamische IP-Adressen verwendet werden. Verwenden Sie IP-Adressen, wenn beim Zugriff auf das DNS-Netzwerk Probleme auftreten.
    2. Wählen Sie Aktionen>Eigenschaften und geben Sie im Dialogfeld Stationseigenschaften die Parameter der Station an:
      • Name - der angezeigte Name der Station
      • Start automatisch - dieses Kennzeichen bedeutet, dass die Station vom Verarbeitungsserver automatisch gestartet wird.

        Hinweis: Häufige Versuche, zu viele Stationen zu starten, können den Verarbeitungsserver beträchtlich verlangsamen.

      • Erforderlicher Festplattenspeicherplatz - der minimale Festplattenspeicherplatz, der für den Betrieb der Verarbeitungsstationen benötigt wird; wenn nicht genügend freier Festplattenspeicherplatz verfügbar ist, wird die Station gestoppt.
      • Maximale Anzahl von Prozessen (CPU-Cores) - die maximale Anzahl an CPU-Kernen, die für die Taskverarbeitung verwendet werden können
      • Zulässige Anzahl von Prozessen (CPU-Cores) - die zulässige Anzahl an CPU-Kernen für die Taskverarbeitung; dieser Parameter wird basierend auf Ihrer Hardware und den Parametern Ihrer Lizenz berechnet und kann nicht geändert werden.
      • Prozesspriorität - die Priorität des Prozesses
      • Zulässige Tasktypen - die Tasktypen, die von der Station verarbeitet werden können
    3. Klicken Sie auf [image], um die Station zu starten.

    Hinweis: Die Stationen erhalten die Rechte für das Verarbeiten von Dokumenten vom Verarbeitungsserver, wenn sie mit dem Server verbunden werden.

  • So aktivieren Sie Hot Folder:

    1. Wählen Sie im Baum des Verarbeitungsservers Hot Folder.
    2. Wählen Sie in der Gesamtliste der Projekte das gewünschte Projekt aus.
    3. Wählen Sie aus dem Kontextmenü Verbinden aus.

    Hinweis: Die Registrierung von Bildern aus den Hot Foldern beginnt erst, nachdem das entsprechende Projekt mit dem Verarbeitungsserver verbunden ist.

  • Um das Verarbeitungsserverprotokoll anzupassen:
    1. Öffnen Sie das Dialogfeld Verarbeitungsserver-Monitoreinstellungen, indem Sie Datei>Einstellungen… wählen
    2. Geben Sie an, welche Meldungen protokolliert werden sollen (Fehler, Warnungen, Informationsmeldungen).
    3. Geben Sie an, ob Informationen zu abgeschlossenen Tasks gelöscht werden sollen (Warnungen).
    4. Geben Sie an, welche Meldungen Protokollierungsinformationen über den Task auslösen.

      Hinweis: Wir raten davon ab, die Option Warnungen während des normalen Betriebs des Systems zu deaktivieren, weil dies zu einer Anhäufung von Daten und einer Verlangsamung des Verarbeitungsserver-Monitors führen kann. Deaktivieren Sie diese Option nur beim Einrichten und Abstimmen des Systems.


Sicherungsserver

Für das System ist ein gültiger Lizenzschlüssel erforderlich, der auf dem ABBYY-Aktivierungsserver aktiviert werden muss.

ABBYY FlexiCapture 9.0 unterstützt zwei Arten von Lizenzschlüsseln:

  • Dongle
  • Softwareschlüssel

Dongle

Einen Dongle schließen Sie an einem USB-Anschluss an Ihrem Computer an.

Der Dongle muss an einem USB-Anschluss des Computers angeschlossen werden, auf dem Sie den Sicherungsserver installiert haben. Der Dongle kann nur automatisch über das Internet aktiviert werden.

Die Parameter Ihrer Lizenz sind im Lizenzschlüssel gespeichert.

Wichtig! Stellen Sie sicher, dass die standardmäßige SmartCard ausgeführt wird, damit die normale Funktionsweise des Dongles gewährleistet ist.

Softwareschlüssel

Ein Softwareschlüssel ist eine Computerdatei ("Lizenzdatei").

Der Softwareschlüssel muss auf dem Aktivierungsserver von ABBYY aktiviert werden. Die Aktivierung erfolgt mit dem ABBYY FlexiCapture 9.0 Lizenzmanager, der automatisch gestartet wird, sobald der Sicherungsserver installiert wurde.

Die für die Aktivierung erforderlichen Daten werden in Form einer Produkt-ID an den Server gesendet. Die Produkt-ID wird anhand der Informationen über den Computer erstellt, auf dem ABBYY FlexiCapture 9.0 installiert wurde. Für die Generierung der Produkt-ID werden keine persönlichen Informationen verwendet, auch ist es nicht möglich, mit diesem Code einen Benutzer zu identifizieren.

Aktivierungsmethoden:

  • Automatisch über das Internet (empfohlen)

    Die Aktivierung über das Internet dauert nur wenige Sekunden. Sie erfordert eine aktive Verbindung zum Internet.

  • Per E-Mail

    Auf dem Computer, auf dem Sie den Sicherungsserver installiert haben, wird automatisch eine E-Mail-Nachricht erzeugt. Diese E-Mail-Nachricht enthält die für das Aktivieren Ihrer Lizenzdatei erforderlichen Daten. Ändern Sie den Text dieser E-Mail nicht, damit eine schnelle Antwort vom Aktivierungsserver gewährleistet ist.

  • Per E-Mail von einem anderen Computer

    Um eine Aktivierungs-E-Mail von einem anderen Computer zu versenden, müssen Sie zunächst auf demjenigen Computer, auf dem der Sicherungsserver installiert ist, eine E-Mail-Nachricht erstellen. Dann kopieren Sie den Text dieser E-Mail-Nachricht in eine E-Mail auf Ihrem anderen Computer und senden sie von dort aus zum ABBYY-Aktivierungsserver. Ändern Sie weder den Betreff noch den Inhalt dieser E-Mail, damit eine umgehende Antwort vom Aktivierungsserver gewährleistet ist.

Wiederholen der Aktivierung

Sie können den Sicherungsserver auf demselben Computer beliebig oft neu installieren, ohne ihn neu aktivieren zu müssen. Wenn Sie jedoch grundlegende Änderungen an der Hardware vornehmen, die Festplatte formatieren oder das Betriebssystem neu installieren, müssen Sie die Lizenzdatei möglicherweise erneut aktivieren.

Für jede Seriennummer wird die Anzahl der Aktivierungen überwacht. Wenn die Anzahl an Aktivierungen den zulässigen Höchstwert überschreitet, können Sie Ihre Lizenzdatei nicht mehr aktivieren. Sie können eine aktivierte Lizenz freigeben, indem Sie einen Deaktivierungsvorgang einleiten. Bei diesem Vorgang zählt der Aktivierungszähler rückwärts.

Verwalten von Lizenzen

Im ABBYY FlexiCapture 9.0 Lizenzmanager, der zusammen mit dem Sicherungsserver installiert wird, können Lizenzen hinzugefügt, aktiviert, ausgewählt, deaktiviert sowie Informationen zu jeder Lizenz angezeigt werden.

So starten Sie den ABBYY FlexiCapture 9.0 Lizenzmanager:

  • Wählen Sie Start>Programme>ABBYY FlexiCapture 9.0 Server>Tools>ABBYY FlexiCapture 9.0 Lizenzmanager.

Hinzufügen einer neuen Lizenz

So fügen Sie eine Lizenz hinzu:

  1. Klicken Sie im Hauptfenster des ABBYY FlexiCapture 9.0 Lizenzmanager auf Auswählen.
  2. Klicken Sie im Dialogfeld Lizenzen auf Aktivieren...
  3. Geben Sie Ihre neue Seriennummer ein, klicken Sie auf Weiter und befolgen Sie die Anweisungen des Aktivierungsassistenten von ABBYY FlexiCapture 9.0.

    Hinweis: Wenn beim Starten des ABBYY FlexiCapture 9.0 Lizenzmanager keine Lizenzen hinzugefügt wurden, wird der Aktivierungsassistent von ABBYY FlexiCapture 9.0 automatisch gestartet, und das Programm fordert Sie aus, Ihre Seriennummer einzugeben.

Aktualisieren einer Lizenz

Sie können Ihre Lizenz aktualisieren, indem Sie die aktuellen Lizenzinformationen vom ABBYY-Registrierungsserver herunterladen.

  1. Klicken Sie im Hauptfenster des ABBYY FlexiCapture 9.0 Lizenzmanagers auf Auswählen...
  2. Wählen Sie im Dialogfeld Lizenzen... die zu aktualisierende Lizenz aus und klicken Sie auf Aktualisieren...
  3. Wählen Sie eine Aktualisierungsmethode, und aktualisieren Sie Ihre Lizenz.

Deaktivieren einer Lizenz

So deaktivieren Sie eine Lizenz (geben sie frei):

  1. Klicken Sie im Hauptfenster des ABBYY FlexiCapture 9.0 Lizenzmanagers auf Auswählen...
  2. Wählen Sie im Dialogfeld Lizenzen... die zu deaktivierende Lizenz aus und klicken Sie auf Deaktivieren.


Dateiablageordner

Die Projektdateien (d.h. Dokumente, Dokumentdefinitionen u.a.) können entweder in einer Datenbank oder in einem speziellen Dateiablageordner gespeichert werden. Der Dateiablageordner kann über die Verwaltungs- und Überwachungskonsole eingerichtet werden. Der Dateiablageordner muss sich auf demselben Rechner wie der Anwendungsserver befinden. Achten Sie darauf, den lokalen (d.h. c:\\...) und nicht den Netzwerkpfad (d.h. \\server\...) zum Dateiablageordner anzugeben. Falls kein Dateiablageordner festgelegt wurde, werden die Dateien in der Datenbank gespeichert.

Ob ein Dateiablageordner oder eine Datenbank zur Speicherung der Projektdateien verwendet wird, beeinflusst weder Systemleistung noch -sicherheit. Bei Verwendung eines Dateiablageordners können Sie jedoch viel mehr Dokumente (Bilder) in den Projekten auf dem Anwendungsserver speichern, und anders als bei Microsoft SQL Server Express Edition gibt es keine Beschränkung der Gesamtgröße der gespeicherten Dateien.


Die Stationen von ABBYY FlexiCapture 9.0

Der Komplex umfasst die folgenden Stationen:

  • Projektkonfigurationsstation

  • Scanstation

  • Verarbeitungsstation

  • Datenverifizierungsstation

  • Verifizierungsstation

Zum Komplex gehört außerdem eine Verwaltungs- und Überwachungskonsole.


Projektkonfigurationsstation

Die Projektkonfigurationsstation ist die Station, in der Projekte erstellt, eingerichtet und überprüft werden. Ein Projekt bestimmt die Dokumentdefinitionen und Stapeltypen, den Bildimport, den Dokumentexport und die Verarbeitungsoptionen.

So erstellen und richten Sie ein Projekt ein:

  1. Erstellen Sie ein Projekt und laden Sie es in den Anwendungsserver.
  2. Öffnen Sie das Projekt auf dem Server und bestimmen Sie seine Eigenschaften.
  3. Erstellen Sie Dokumentdefinitionen.
  4. Erstellen Sie Stapeltypen.
  5. Erstellen Sie Bildimportprofile.

Wichtig! Nur der Administrator kann neue Projekte erstellen. Ein Projektkonfigurationsoperator kann nur bereits erstellte Projekte konfigurieren.

  1. Erstellen eines neuen Projekts

    Wenn der Administrator eine Verbindung zur Datenbank hergestellt hat, sollte der Administrator:

    1. die Projektkonfigurationsstation starten (Start>Programme>ABBYY FlexiCapture 9.0 Stationen>Projektkonfigurationsstation )
    2. ein Projekt erstellen
    3. das Projekt in den Anwendungsserver laden

    Wenn das Projekt in den Anwendungsserver geladen wurde, kann der Administrator einem Projektkonfigurationsoperator Konfigurationsrechte für das Projekt gewähren.

  2. Projekteigenschaften

    Um die Projekteigenschaften einzustellen, sollte der Projektkonfigurationsoperator:

    1. die Projektkonfigurationsstation starten.
    2. Wählen Sie Datei>Projekt von Server öffnen… und bestimmen Sie den Pfad zum Anwendungsserver. Das Dialogfeld Auf dem Anwendungsserver vorhandenes Projekt öffnen wird angezeigt.
    3. Wählen Sie das Projekt aus der Liste der verfügbaren Projekte.
    4. Wählen Sie Projekt>Projekteigenschaften… und bestimmen Sie die Eigenschaften des Projekts: Optionen für die Vorverarbeitung eines Bilds, Optionen für die Dokumenterkennung, Regeln für die Integritätsüberprüfung, Exporteinstellungen und Verarbeitungsoptionen.

  3. Erstellen von Dokumentdefinitionen

    Um zu bestimmen, wie Dokumenttypen identifiziert und verarbeitet werden sollen, sollte der Projektkonfigurationsoperator Dokumentdefinitionen erstellen. Eine Dokumentdefinition beinhaltet Informationen über die Dokumentstruktur, die Positionen der Felder, die Optionen für Export und Dokumentverarbeitung etc. Dokumentdefinitionen werden in einem Dokumentdefinitionsassistent erstellt und die Eigenschaften werden in einem Dokumentdefinitionseditor bestimmt.

  4. Erstellen von Stapeltypen

    ABBYY FlexiCapture 9.0 kann Dokumente in Stapeln verarbeiten: Vor der Verarbeitung wird ein Stapel erstellt und die Dokumentbilder in diesem Stapel platziert, der dann die verschiedenen Verarbeitungsschritte durchläuft. Normalerweise enthält ein Stapel alle Dokumente, die in einem Durchgang verarbeitet werden, oder alle Dokumente, die aus einem bestimmten Ordner importiert wurden. Die Einstellungen, die für die Verarbeitung der Dokumente verwendet werden, werden im Stapeltyp bestimmt. Sie können mehrere Stapeltypen für die am häufigsten genutzten Verarbeitungskonfigurationen erstellen. In diesem Fall kann ein Operator jedes Mal, wenn er einen neuen Stapel erstellt, seinen Typ bestimmen und der Stapel wird gemäß den für diesen Stapeltyp vorgesehenen Einstellungen verarbeitet.

    Hinweis:

    • Wenn keine Stapeltypen erstellt werden, werden alle Stapel mit den <Standard> Einstellungen, die für das gesamte Projekt bestimmt wurden, verarbeitet.
    • Dokumente können entweder in Stapeln oder individuell überprüft bzw. exportiert werden. Das wird auch in den Einstellungen des Stapeltyps bestimmt.

  5. Erstellen von Bildimportprofilen

    Um den Vorgang des Hinzufügens von Bildern zu automatisieren, können Bildimportprofile auf der Projektkonfigurationsstation erstellt werden. Dabei kann zwischen zwei Profiltypen ausgewählt werden: ein Profil mit Verwendung eines Scanners und ein Profil mit Verwendung eines Hot Folders. Ein Scannerprofil kann verwendet werden, um das Projekt zu überprüfen. Ein Hot Folder-Profil importiert die Bilder automatisch in die Verarbeitungsstation.

    Hinweis:

    • Ein Scannerprofil ist nur auf der Projektkonfigurationsstation verfügbar.
    • Um Hot Folder verwenden zu können, müssen Sie den Hot Folder für dieses Projekt im Monitor des Verarbeitungsservers aktivieren.


Verwaltungs- und Überwachungskonsole

Wichtig! Für die korrekte Benutzung der Verwaltungs- und Überwachungskonsole muss Ihr Browser die Verwendung von JavaScript und Popup-Windows zulassen.

Die Verwaltungs- und Überwachungskonsole dient der Konfiguration des gesamten Komplexes und der Überwachung des Betriebs.

Die Verwaltungs- und Überwachungskonsole ist eine webbasierte Bedienoberfläche, die dem Benutzer des Anwendungsservers zur Verfügung steht und über einen Internet-Browser Zugriff auf den Server ermöglicht. Die Konsole kann von jedem Computer aus geöffnet werden, der auf den Anwendungsserver zugreifen kann. Geben Sie dazu einfach die Adresse http://<AnwServer>/FlexiCapture in den Browser ein, wobei <AnwServer> durch den Namen des Computers ersetzt wird, auf dem der Anwendungsserver installiert ist.

Die Verwaltungs- und Überwachungskonsole wird direkt im Anschluss an die Installation des Anwendungsservers gestartet und ermöglicht dem Operator die Herstellung einer Datenbankverbindung. Der Operator kann sich mit einer bestehenden Datenbank verbinden oder eine neue erstellen.

Hinweis: Der Operator, der die Datenbank auf dem Anwendungsserver erstellt, erhält automatisch Administratorrechte.

Zur Einrichtung einer Datenbankverbindung wählen Sie Optionen>Anwendungsserver und klicken entweder auf Mit einer bestehenden Datenbank verbinden oder Eine neue Datenbank erstellen. Füllen Sie dann die Felder durch Eingabe folgender Daten aus:

  • Den Namen der SQL-Serverinstance

  • Den Namen der Datenbank

  • Den zur Verbindung mit der Datenbank benutzten Authentifizierungstyp

  • Ob der Dateiablageordner benutzt werden soll

    Beim Dateiablageordner handelt es sich um ein lokales Verzeichnis des Computers, auf dem der Anwendungsserver installiert ist. In dem Verzeichnis werden die Projektdateien gespeichert. Alternativ können die Projektdateien in einer Datenbank gespeichert werden. Wenn die Projektdateien getrennt gespeichert werden sollen, wählen Sie Externe Dateiablage verwenden und geben den Pfad zum entsprechenden Ordner an.

Bei der Durchführung einer Aktualisierung müssen Sie möglicherweise Änderungen der Datenbankstruktur vornehmen. Verwenden Sie in diesem Fall das mit der Aktualisierung bereitgestellte Skript. Klicken Sie zur Ausführung des Skripts auf die Schaltfläche Aktualisierung durchführen und geben den Pfad zur Skriptdatei an.

Neben der Einrichtung einer Verbindung zur Datenbank muss der Administrator Benutzerzugriffsrechte konfigurieren und Operatorrollen zuteilen.

Wichtig! Die dem Administrator, dem überwachenden Operator und dem Verarbeitungsserver erteilten Berechtigungen gelten für alle Projekte. Sie können daher sofort nach Herstellung der Datenbankverbindung eingerichtet werden. Die Berechtigungen für alle anderen Operatoren werden auf Projektbasis erteilt. Vor der Vergabe von Berechtigungen an andere Operatoren muss der Administrator daher Projekte erstellen und sie zum Anwendungsserver exportieren. Wenn sich keine Projekte auf dem Anwendungsserver befinden, kann der Administrator keine Operatoren hinzufügen und folglich auch keine Zugriffsrechte erteilen.

Nach der Konfiguration des Komplexes kann die Verwaltungs- und Überwachungsstation zur Betriebsüberwachung genutzt werden (d.h. Verfolgung des aktuellen Status des Komplexes und Erstellung von Berichten). Der Administrator nutzt die Angaben über den aktuellen Status des Komplexes, um die Konfiguration zu ändern oder Ressourcen umzuverteilen.

Der Administrator kann folgende Informationen abrufen:

  • Stapel – die Konsole zeigt die Liste der Stapel, Stapelstatistiken und den aktuellen Verarbeitungsschritt an

  • Aufgaben – die Konsole zeigt die Liste der Aufgaben sowie Statistiken an

  • Sitzungen – die Konsole zeigt die Liste der laufenden Sitzungen an

  • Aktueller Verarbeitungsstatus – die Konsole zeigt die Liste der Verarbeitungsschritte und die Anzahl der Dokumente oder Stapel jedes Schritts an

  • Ereignisprotokoll – die Konsole zeigt die Liste der Ereignisse und diesbezügliche Informationen an

  • Fehlerprotokoll – die Konsole zeigt die Liste der Fehler und eine Beschreibung jedes Fehlers an

Zum Abrufen eines Status wählen Sie ein Projekt und dann die entsprechende Option aus dem Menü Überwachung. Die Ergebnisliste kann auf dem Bildschirm betrachtet, ausgedruckt oder im CSV-Format gespeichert werden.

Der überwachende Operator kann nicht nur Informationen über den aktuellen Status des Komplexes abrufen, sondern auch Berichte über den Betrieb erstellen.

Die folgenden Berichte können erstellt werden:

  • Allgemeiner Dokumentverarbeitungsbericht – es wird ein separater Bericht für jedes Projekt erstellt

  • Vollständiger Bericht für Datenüberprüfungsoperatoren

  • Allgemeiner Bericht für Datenüberprüfungsoperatoren

  • Vollständiger Bericht für Überprüfungsoperatoren

  • Allgemeiner Bericht für Überprüfungsoperatoren

Hinweis: Berichte für Überprüfungsoperatoren und Datenprüfer werden auf Grundlage aller Projekte erstellt.


Scanstation

Wichtig! Ausführliche Informationen finden Sie in der Scanstation-Hilfe.

Der Zweck der Scan Station ist es, das Scannen einer großen Anzahl von Dokumenten zu ermöglichen. Die Scanstation kann sowohl in einem lokalen als auch in einem dezentralen Netzwerk (über das Internet) genutzt werden. Die Autorisierung wird mittels Benutzername und Passwort durchgeführt.

Die Scanstation ist möglicherweise die erste Station, auf der ein Dokument eintrifft. Die Station wird von einem Scanoperator bedient, der mit einer der folgenden beiden Methoden Bilder hinzufügen kann:

  • Scanprofile erstellen und benutzen und/oder Bilder manuell hinzufügen
  • die Bilder bereits gescannter Dokumente aus einem Ordner hinzufügen

Profile automatisieren die Bildbeschaffung: Operatoren können die zuvor festgelegten Einstellungen nutzen, um mit nur einem Mausklick Bilder hinzuzufügen.

Der Scanoperator kann nicht nur Bilder hinzufügen, sondern auch bearbeiten (Weiteres siehe Scanstation-Hilfe).

Typischerweise gestaltet sich der Arbeitsablauf des Scanoperators folgendermaßen:

  • Start der Scanstation
  • Falls auf der Station noch ein nicht abgearbeiteter Stapel vorhanden ist: Verarbeitung fortsetzen. Andernfalls Erstellung eines neuen Stapels.
  • Falls bereits Importprofile erstellt wurden: Auswahl eines geeigneten Profils und Start des Scanvorgangs. Falls keine Profile bereitstehen: erstellen und zum Scannen von Dokumenten verwenden.
  • Beim Hinzufügen von Bildern kann der Operator ihre Eigenschaften visuell kontrollieren und ggfs. bearbeiten. Falls die Probleme durch Bearbeitung nicht behoben werden können, kann der Operator die Scanoptionen modifzieren und die fehlerhaften Seiten neu einlesen.
  • Kontrolle der Qualität der Dokumentzusammenstellung und Fehlerbeseitigung.
  • Nach Vorbereitung des Stapels die Registrierungsparameter festlegen und den Stapel zum Server schicken.
  • Wiederholung der obigen Arbeitsschritte für den nächsten Bilderstapel oder Herunterfahren der Scanstation.


Datenüberprüfungsstation

Datenverifizierungsstation

Zweck der Datenverifizierungsstation ist die Kontrolle von Schriftzeichen, die mit unzureichender Sicherheit erfasst wurden. Der Datenprüfer betrachtet unzuverlässig erfasste Schriftzeichen erst im Gruppen-Prüfmodus und dann im Feld-Prüfmodus.

Bei der Gruppenüberprüfung werden Gruppen ähnlicher Schriftzeichen angezeigt. Der Operator hat die Aufgabe, falsch erfasste Schriftzeichen zu erkennen, zu korrigieren und ggfs. mit dem Bild des entsprechenden Felds zu vergleichen. Wenn aus irgendeinem Grund ein Zeichen nicht korrigiert werden kann, markiert es der Operator als ungeklärt.

Bei der Feldüberprüfung werden Felder angezeigt, deren Wertebereich im Voraus bekannt ist. Der Operator hat die Aufgabe, das unsicher erfasste Schriftzeichen durch Untersuchung des Kontexts zu klären. Für die Feldüberprüfung stehen zwei Anzeigemodi zur Verfügung: Die Anzeige einzelner Felder mit extrahierten Schriftzeichen sowie die Anzeige mehrerer Felder – dabei werden alle identischen Felder auf dem gleichen Bildschirm dargestellt.

Hinweis: Außer dem Datenprüfer haben der Verifikator und der Hauptverifikator Zugriff auf die Datenverifizierungsstation. Egal, welcher Operator mit der Station arbeitet – es kann immer nur auf die Datenprüfungs-Warteschlange zugegriffen werden.

So starten Sie die Datenprüfung:

  1. Starten Sie die Datenverifizierungsstation durch Wahl von Start>Programme>ABBYY FlexiCapture 9.0 Stationen>Datenverifizierungsstation.
  2. Wählen Sie das gewünschte Projekt.
  3. Klicken Sie auf [image] zum Start der Prüfung.

    Hinweis: Zuerst erfolgt die Gruppenüberprüfung, danach die Feldüberprüfung. Wenn eine Dokumentdefinition über keine Felder verfügt, die in die Gruppen- oder Feldüberprüfung einbezogen werden, entfällt die Überprüfung.

Wenn die Datenprüfung abgeschlossen ist, wird der Stapel oder Dokumentensatz an die Verifizierungsstation geschickt.

Falls der prüfende Operator bei der Verarbeitung der Dokumente auf Probleme stößt, kann er den Stapel oder die Dokumente durch Klicken von [image] der Ausnahmen-Warteschlange hinzufügen.


Verifizierungsstation

Mit der Verifizierungsstation können komplexere Überprüfungen als mit der Datenverifizierungsstation vorgenommen werden. Außer der Überprüfung der Daten kann der Operator mit der Station problematische Stapel oder Dokumente verarbeiten, Zusammenstellungsfehler korrigieren, Datenregeln anwenden und Stapel auf Integrität überprüfen.

Die Verifizierungsstation kann von den folgenen Operatoren betrieben werden: Datenüberprüfungsoperatoren, Überprüfungsoperatoren und leitende Überprüfungsoperatoren. Abhängig von der bei der Anmeldung auf die Station vom Operator ausgewählten Rolle kann er Tasks von verschiedenen Warteschlangen sehen und verarbeiten:

  • Ein Datenüberprüfungsoperator kann nur Tasks von der Datenüberprüfungswarteschlange verarbeiten
  • Ein Überprüfungsoperator kann Tasks von jeder Warteschlange, außer der Ausnahmen- und der Exportbestätigungswarteschlange verarbeiten
  • Ein leitender Überprüfungsoperator kann Task von jeder Warteschlange verarbeiten. Außer auf die Warteschlangenliste kann der leitende Überprüfungsoperator auch auf die Stapelliste zugreifen.

Folgende Warteschlangen sind auf der Verifizierungsstation verfügbar:

  • <Beliebig>

    Diese Warteschlange beinhaltet in allen anderen Warteschlangen erstellte Tasks. Die für einen Operator verfügbaren Warteschlangen sind abhängig von der vom Operator ausgewählten Rolle bei der Anmeldung auf der Station. Tasks werden in der Reihenfolge ihrer Priorität durchgeführt.

  • Überprüfen der Dokumentzusammenstellung

    Bei mehrseitigen Dokumenten müssen fehlerhafte Dokumentzusammenstellungen unter Umständen korrigiert werden. Dokumentzusammenstellungsregeln werden zusammen mit den Dokumentdefinitionen erstellt und definieren die Reihenfolge der Seiten und Anzahl der Seitenwiederholungen. Zusätzlich kann eine Überprüfung der Dokumentzusammenstellung anhand von Schlüsselfeldern notwendig sein. In diesem Fall müssen die Werte der Schlüsselfelder auf sämtlichen Seiten des Dokuments gleich sein. Wenn die Werte unterschiedlich sind, wird eine Fehlermeldung angezeigt und die Werte werden rot markiert. Zusammenstellungsfehler können am Besten in der Miniaturansicht der Seite korrigiert werden, da sie eine übersichtliche Ansicht der Seiten bietet und es sofort klar wird, zu welchem Dokument die Fehler gehören.

  • Datenüberprüfung

    Der Datenüberprüfungsvorgang startet mit der Gruppenüberprüfung, danach folgt die Feldüberprüfung. Wenn eine Dokumentdefinition keine in Gruppen oder Feldüberprüfung enthaltenen Felder beinhaltet, wird das Dokument nicht in der Datenüberprüfungswarteschlange positioniert.

  • Überprüfung

    Wenn durch die Verarbeitungsparameter keine speziellen Warteschlangen bestimmt sind, enthält die Überprüfungswarteschlange alle Tasks mit fehlerhaften Dokumentzusammenstellungen, Datenüberprüfungsfehlern und Regelfehlern.

  • Stapelintegritätsprüfung

    Die für die Datenintegritätsüberprüfung verwendeten Regeln stellen Links zwischen den Daten in den Dokumenten oder in einem Stapel her.

  • Exportbestätigung

    Daten können manuell oder automatisch exportiert werden. Wenn die Verarbeitungsparameter keine separate Exportbestätigungs-Warteschlange definieren, werden die Stapel oder Dokumente automatisch im unbeaufsichtigten Modus exportiert. Wenn die Verarbeitungsparameter eine separate Exportbestätigungs-Warteschlange enthalten, muss der leitende Überprüfungsoperator zuerst den Task von der Warteschlange erhalten und diesen dann wieder an sie zurückschicken. Wenn ein Fehler auftritt, wird der Stapel oder das Dokument automatisch an die Ausnahmenwarteschlange gesendet.

  • Ausnahmen

    Problematische Stapel oder Dokumente, die der Operator nicht verarbeiten könnte, werden an die Ausnahmenwarteschlange gesendet.

Hinweis: Die Verarbeitungsparameter des Dokuments (z. B. separate Warteschlangen) werden für Stapeltypen oder - wenn keine Stapeltypen verwendet werden - für das gesamte Projekt bestimmt.

Um einen Task auszuführen, wählen Sie die gewünschte Warteschlange in der Liste aus und klicken auf [image].

Sie können den automatischen Taskempfangsmodus durch Anklicken von [image] oder über den Menübefehl Task > Tasks automatisch abrufen aktivieren.

Die Station bietet auch die Ansichtsmöglichkeiten Details und Miniaturansichten. In der Ansicht Details werden die Dokumente des aktiven Tasks angezeigt. In der Ansicht Miniaturansichten werden alle Dokumente des Stapels angezeigt und die Seiten, die nicht Teil des aktiven Tasks sind, werden grau markiert.


Verarbeitungsstation

Verarbeitungsstationen arbeiten selbstständig und übernehmen die folgenden Tasks: Bilder aus Hot Foldern laden, Dokumentdefinitionen zuweisen, Dokumente erkennen, Regeln validieren und Daten zu einem vorgegebenen Speicherort exportieren. Die Verarbeitungsstationen erhalten die Tasks vom Verarbeitungsserver.

So zeigen Sie die aktuellen Tasks an:

  1. Die Verarbeitungsstation starten (Start>Programme>ABBYY FlexiCapture 9.0 Stationen>Verarbeitungsstation). Das Dialogfeld Verbindung mit der Station herstellen wird geöffnet.
  2. Geben Sie den Ort des Verarbeitungsservers an.
    • Netzwerkrechner und den Namen des Computers, auf dem der Verarbeitungsserver installiert ist (falls Verarbeitungsserver und -station auf verschiedenen Computern installiert sind)
    • Lokaler Recher (wenn Verarbeitungsserver und Verarbeitungsstation auf demselben Computer installiert sind)

Alle aktiven Tasks werden in der Spalte Tasks angezeigt. Für jeden Task sind die folgenden Angaben verfügbar: Startzeit, Fortschritt, Status, Priorität, Station und Urheber. Die Tasks können durch Klicken auf die Bezeichnung der gewünschten Spalte sortiert werden.

Hinweis: Nur Operatoren mit Administratorrechten können Verarbeitungsstationen starten und Tasks überwachen (d.h. Taskdetails anzeigen, Tasks abbrechen und Protokolle abrufen).


Verarbeitungsschritte und Warteschlangen

Dokumente werden entweder automatisch oder mit Unterstützung eines Operators in mehreren Schritten verarbeitet, dabei enthält jeder Schritt bestimmte Vorgänge. Die Schritte haben eine festgelegte Reihenfolge und um einen bestimmten Schritt durchlaufen zu können, müssen die Dokumente erst die vorherigen Schritte abschließen. Die folgenden Schritte sind insgesamt erforderlich: Bilder hinzufügen, Erkennen, Überprüfen, Exportieren.

Bei jedem Schritt wird eine Verarbeitungswarteschlange gebildet. Mit fortschreitender Verarbeitung werden die Dokumente aus der ersten Warteschlange (Erkennung) in Richtung der letzten Warteschlange verschoben (Exportieren). Normalerweise entsprechen die Warteschlangen den Verarbeitungsschritten, es gibt jedoch auch spezielle Warteschlangen, wie die für Ausnahmen.

Wenn große Mengen verarbeitet werden müssen, kann der Überprüfungsschritt in kleinere Schritte unterteilt werden. Jeder Schritt wird dann von seinem eigenen Operator ausgeführt. Anders gesagt, können Sie separate Warteschlangen zur Datenüberprüfung, Überprüfung, Überprüfung der Dokumentzusammenstellung und Exportbestätigung erstellen.

Mit Ausnahme des Erkennungs- und Exportschritts sind alle Verarbeitungsschritte und die entsprechenden Warteschlangen optional. Für jeden Stapeltyp wird auf der Projektkonfigurationsstation bestimmt, ob eine Warteschlange benötigt wird oder nicht.

Warteschlangen

  1. Erkennung

    Notwendige Warteschlange, in der nur ganze Stapel verarbeitet werden. Die Erkennung wird automatisch auf der Verarbeitungsstation vorgenommen.

  2. Überprüfen der Dokumentzusammenstellung

    Eine optionale Warteschlange. Die Tasks dieser Warteschlange werden auf der Verifizierungsstation verarbeitet. Wenn keine separate Dokumentzusammenstellungs-Warteschlange in den Einstellungen festgelegt wurde, werden fehlerhafte Stapel oder Dokumente in der Überprüfungswarteschlange verarbeitet.

  3. Datenüberprüfung

    Eine optionale Warteschlange. Die Tasks dieser Warteschlange können auf der Datenverifizierungsstation oder auf der Verifizierungssstation verarbeitet werden. Wenn der Prozentsatz der nicht eindeutigen Zeichen niedriger ist als der festgelegte Grenzwert, wird das Dokument an die Datenüberprüfung geschickt.

  4. Überprüfung

    Eine optionale Warteschlange. Wenn keine separaten Warteschlange festgelegt wurden, werden alle fehlerhaften Dokumentzusammenstellungen, Datenfehler und Regelfehler an die Überprüfungswarteschlange gesendet.Tasks aus dieser Warteschlange werden auf der Verifizierungsstation verarbeitet.

  5. Stapelintegritätsüberprüfung

    Eine optionale Warteschlange.Stapel mit Integritätsfehlern werden an diese Warteschlange gesendet. Integritätsüberprüfungsoptionen werden von Skripten bei der Einrichtung eines Stapeltyps bestimmt. Die Tasks dieser Warteschlange werden auf der Verifizierungsstation verarbeitet.

  6. Exportbestätigung

    Eine optionale Warteschlange, die eine größere Genauigkeit der erfassten Daten sicherstellt. Ein Stapel oder Dokument wird nur exportiert, wenn der Operator bestätigt, dass er/es für den Export geeignet ist. Die Tasks dieser Warteschlange werden auf der Verifizierungsstation verarbeitet.

  7. Exportieren

    Eine notwendige Warteschlange. Die Tasks dieser Warteschlange werden auf der Verarbeitungsstation verarbeitet.

  8. Ausnahmen

    Eine notwendige Warteschlange. Fehlerhafte Dokumente werden nach der automatischen Verarbeitung an diese Warteschlange gesendet. Außerdem können Operatoren Dokumente an diese Warteschlange senden, wenn sie diese aus irgendeinem Grund nicht verarbeiten können.

Hinweis: Sie können in den Einstellungen für Stapeltypen bestimmen, ob Stapel überprüft werden sollen und als Ganzes oder Dokument für Dokument exportiert werden sollen.


Arbeitsablauf

Dokumente können entweder automatisch ohne menschliche Eingriffe oder mit Unterstützung durch Prüfer verarbeitet werden.

Im selbstständigen Modus laufen Verarbeitung und Exportierung von Dokumenten ohne Zutun eines Operators ab. Falls ein Fehler auftritt, kann das betreffende Bild in einem speziellen über die Registerkarte Export festgelegten Ordner gespeichert werden. Erfolgreich verarbeitete Dokumente werden automatisch exportiert. Im selbstständigen Modus werden Stapel als Ganzes verarbeitet.

Bei Mitwirkung von Menschen müssen die Stapelverarbeitungsparameter wie z.B. Überprüfung und Export konfiguriert werden. Außerdem kann die Verifizierung der Dokumente in mehrere Arbeitsgänge unterteilt werden, wobei jeder Arbeitsgang einer Warteschlange zugeordnet wird. Dokumente (oder ganze Stapel) können diese Arbeitsgänge entweder automatisch durchlaufen (wenn keine Fehler auftreten) oder nach Prüfung und Korrektur durch einen Operator. Falls bei einem im selbstständigen Modus verarbeiteten Dokument ein Fehler auftritt, wird es in die Ausnahmen-Warteschlange eingereiht. Auch ein Operator kann Dokumente in die Ausnahmen-Warteschlange einreihen.

Die Verarbeitungsreihenfolge wird für jeden Stapeltyp einzeln festgelegt. Neu erstellten Stapeln wird ein Typ zugewiesen, der über die Verarbeitungsreihenfolge entscheidet.

Falls keine Stapeltypen erstellt werden, werden alle Stapel mit den für das gesamte Projekt festgelegten <Standard>-Einstellungen verarbeitet.


Konfigurieren des Programms

Vor der Masseneingabe von Dokumenten muss das Programm für die Verarbeitung der Dokumente des gewünschten Typs konfiguriert werden. Alle erforderlichen Einstellungen werden in der Projektkonfigurationsstation vorgenommen.

Erstellen Sie zum Konfigurieren der Dokumentverarbeitung ein Projekt mit folgenden Elementen:

  • Bildimportprofile
  • Eine oder mehrere Dokumentdefinitionen
  • Stapeltypen zur Verarbeitung.

Sie können verschiedene Dokumentdefinitionen in das Projekt einbinden. In diesem Fall werden je nach zugeordneter Dokumentdefinition verschiedene Dokumente im gleichen Projekt verarbeitet. Wenn sich die verschiedenen Dokumentflüsse jedoch nicht überschneiden, können Sie jeweils separate Projekte erstellen.

Erstellen eines Projekts
Dokumentdefinitionen
Bildimportprofile
Standardexporteinstellungen
Stapeltypen
Dokumentstapel
Indexfelder


Konfiguration von ABBYY FlexiCapture 9.0

So konfigurieren Sie ABBYY FlexiCapture für die verteilte Dokumentverarbeitung:

  1. Über die Verwaltungs- und Überwachungskonsole den Anwendungsserver konfigurieren.
  2. Das Projekt zum Anwendungsserver hochladen.
  3. Über die Verwaltungs- und Überwachungskonsole Operatoren und Administratoren Zugriffsrechte erteilen.
  4. Über den Monitor des Verarbeitungsservers Verarbeitungsserver und -stationen konfigurieren.
  5. Auf der Projektkonfigurationsstation den Arbeitsablauf konfigurieren.


Konfiguration des Anwendungsservers

Der Anwendungsserver wird vom Systemadministrator über die Verwaltungs- und Überwachungskonsole konfiguriert.

Zur Konfiguration des Anwendungsservers starten Sie die Verwaltungs- und Überwachungskonsole, rufen die Seite Neue Datenbank erstellen auf (Einstellungen>Anwendungsserver, Schaltfläche Neue Datenbank erstellen) und geben Folgendes ein:

  • SQL Server-Name
  • Datenbankname
  • Authentifizierungstyp

  • Dateiablage festlegen

Hinweis: Der Ordner, in dem die Projektdateien gespeichert werden, muss sich auf demselben Computer befinden, auf dem der Anwendungsserver installiert ist.

Die Projektdateien können entweder direkt in der Datenbank oder in einem speziellen Dateiablageordner gespeichert werden. Falls kein Dateiablageordner festgelegt wurde, werden die Dateien in der Datenbank gespeichert. Die Speicherung der Dateien in der Datenbank erleichtert einerseits Backups, vergrößert aber andererseits die Datenbank.


Benutzern Zugriffsrechte erteilen

Zugriffsrechte werden über die Verwaltungs- und Überwachungskonsole erteilt. Rechte können an Benutzer und Prozesse vergeben werden.

Die Rollen „Verarbeitungsserver“, „Überwachung“ und „Administrator“ sind projektunabhängig. Alle anderen Zugriffsrechte gelten nur für einzelne Projekte. Sie müssen daher zuerst ein Projekt erstellen.

Hinweis:

  • Die Administratorrolle wird automatisch demjenigen Benutzer zugeteilt, der die Datenbank erstellt hat.
  • Die Zugriffsrechte auf den Verarbeitungsserver werden demjenigen Konto erteilt, unter dem der Server läuft (<Domainname\Computername>$).

Wenn ein Administrator über die Projektkonfigurationsstation ein Projekt erstellt und auf den Anwendungsserver hochgeladen hat, kann er den Operatoren, die an dem Projekt arbeiten werden, Zugriffsrechte erteilen. Rollen und Zugriffsrechte können sowohl einzelnen Benutzern als auch Gruppen erteilt werden. Im letzteren Fall erhält ein Benutzer automatisch alle der Gruppe erteilten Zugriffsrechte, sobald er ihr hinzugefügt wird.

So erstellen Sie ein neues Benutzerkonto:

  1. Starten Sie die Verwaltungs- und Überwachungskonsole (Start>Programme>ABBYY FlexiCapture 9.0 Server>Verwaltungs- und Überwachungskonsole).
  2. Wählen Sie Einstellungen>Benutzer und Gruppen.
  3. Wählen Sie das Projekt aus der Gesamtliste der Projekte.
  4. Fügen Sie durch Angabe des Domainnamens des Benutzers ein neues Benutzerkonto hinzu (Feld Hinzufügen) und auf Benutzer klicken.
  5. Legen Sie die Rolle (z.B. Scanoperator) und die Stapeltypen fest, auf die dieser Operator zugreifen können soll.

Hinweis: Wenn sich ein Benutzer bei der Station anmelden oder den Verarbeitungsserver starten will, erscheint das Konto des Benutzers bzw. des Prozesses in der Benutzerliste. Danach kann der Administrator dem Benutzer eine Rolle zuweisen.

So erstellen Sie eine Gruppe:

  1. Starten Sie die Verwaltungs- und Überwachungskonsole (Start>Programme>ABBYY FlexiCapture 9.0 Server>Verwaltungs- und Überwachungskonsole).
  2. Wählen Sie Einstellungen>Benutzer und Gruppen.
  3. Wählen Sie das Projekt aus der Gesamtliste der Projekte.
  4. Fügen Sie durch Angabe des Namens eine neue Gruppe hinzu (Feld Hinzufügen) und auf Gruppe klicken.
  5. Legen Sie die Zugriffsrechte und Rollen sowie die Stapeltypen fest, auf die die Operatoren dieser Gruppe zugreifen können sollen.
  6. Fügen Sie Benutzer zur Gruppe hinzu.


Konfiguration von Verarbeitungsserver und Verarbeitungsstationen

Der Verarbeitungsserver wird über den Monitor des Verarbeitungsservers konfiguriert, einer automatisch zusammen mit dem Server installierten Anwendung.

So konfigurieren Sie den Verarbeitungsserver:

  1. Den Monitor des Verarbeitungsservers durch Wahl von Start>Programme>ABBYY FlexiCapture 9.0-Server>Verarbeitungsserver starten.
  2. Den Server hinzufügen (Aktionen>Server hinzufügen…)
  3. Den Pfad zum Anwendungsserver angeben (Aktionen>Eigenschaften).
  4. Den Verarbeitungsserver starten (Aktions>Start)

    Hinweis: Zum Start des Verarbeitungsservers muss der Administrator die Benutzerkontenrechte bereitstellen, unter denen der Server läuft (d.h. <Domain-Name\Computer-Name>$).

  5. Die Liste der Verarbeitungsstationen erstellen, ihre Eigenschaften festlegen und starten:
  • Zum Hinzufügen einer Station wechseln Sie zum Stationsknoten im Baum des Verarbeitungsservers und wählen Aktionen>Stationen hinzufügen…
  • Zur Konfiguration wählen Sie eine Station aus der Gesamtliste der Stationen und dann aus ihrem Kontextmenü Eigenschaften.
  • Legen Sie die erforderlichen Stationsparameter fest: Start, Priorität, mögliche Aufgabentypen u.a.

    Wichtig! Die Höchstzahl gleichzeitiger Vorgänge (Feld Maximale Anzahl von Prozessen (CPU-Cores)) darf nicht höher als die zulässige Anzahl der Vorgänge sein (Feld Zulässige Anzahl von Prozessen (CPU-Cores)). Außerdem darf die Gesamtzahl gleichzeitiger Vorgänge aller Verarbeitungsstationen zusammen nicht die von Ihrer Lizenz zugelassene Höchstzahl übersteigen. Es ist nicht möglich, mehr Stationen als von der Lizenz erlaubt zu starten.

Die Verarbeitungsstationen laufen unter demselben Konto wie der Verarbeitungsserver. Die Berechtigungen werden den Stationen vom Verarbeitungsserver erteilt, wenn diese mit ihm verbunden sind.

Über den Monitor des Verarbeitungsservers können Sie auch Hot Folder einrichten.

So aktivieren Sie Hot Folder:

  1. Aus dem Baum des Verarbeitungsservers Hot Folder wählen.
  2. Das gewünschte Projekt aus der Gesamtliste der Projekte wählen.
  3. Im Hauptfenster Aktionen>Aktivieren wählen.

Hinweis: Die Registrierung von Bildern aus den Hot Foldern beginnt erst, nachdem das entsprechende Projekt mit dem Verarbeitungsserver verbunden ist.

Der Monitor des Verarbeitungsservers ermöglicht Ihnen außerdem die Festlegung von Aufgabenprioriäten und die Verfolgung der Aufgaben (der Knoten Aufgaben im Baum des Verarbeitungsservers).


Workflow-Installation

Die Reihenfolge, in der ein Stapel verarbeitet werden sollte, wird für jeden Stapeltyp bestimmt. Beim Erstellen eines Stapels wird sein Typ bestimmt und der Stapel wird gemäß den Einstellungen für diesen Stapeltyp verarbeitet.

Wenn keine Stapeltypen erstellt werden, werden alle Stapel mit den <Standard>-Einstellungen, die für das gesamte Projekt bestimmt wurden, verarbeitet (Projekt>Projekteigenschaften… Registerkarte Workflow).

Workflows werden auf der Registerkarte Workflow im Dialogfeld Stapeltypeigenschaften installiert.

  1. Wählen Sie den Modus Unbeaufsichtigt oder Mit Überprüfung.
    • Im Modus Unbeaufsichtigt werden die Dokumente ohne Einwirken des Operators verarbeitet und exportiert. Wenn Verarbeitungsfehler auftreten, kann das nicht erkannte Bild in einen angegebenen Ordner gespeichert werden (dies wird auf der Registerkarte Export bestimmt) und die erfolgreich verarbeiteten Dokumente werden automatisch exportiert. Im unbeaufsichtigten Modus werden die Stapel als Ganzes verarbeitet.
    • Im Modus Mit Überprüfung müssen Sie die Überprüfungsparameter bestimmen, wenn der gesamte Stapel oder ein einzelnes Dokument exportiert werden soll. Sie müssen dann separate Warteschlangen für verschiedene Überprüfungsschritte vorgeben.
  2. Ganze Stapel überprüfen
    • Wenn diese Option ausgewählt wird, wird der gesamte Stapel einer Überprüfung unterzogen (d. h. der Stapel wird nicht weitergeleitet, bis alle seine Dokumente erkannt wurden).
    • Wenn diese Option nicht ausgewählt wird, wird jedes Dokument aus diesem Stapel zur Überprüfung gesendet, sobald es erkannt wurde.
  3. Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als - Das Dokument wird nur dann zur Überprüfung gesendet, wenn Fehler vorliegen oder wenn die Anzahl der markierten Zeichen größer ist als der im Feld % pro Dokumentangegebene Wert.
    . Hinweis: Wenn Sie für eines der Felder in den Feldüberprüfungseinstellungen , immer ausgewählt haben, wird das Dokument in jedem Fall zur Überprüfung gesendet.
  4. Überprüfung und Datenüberprüfung auslassen, falls der Prozentsatz uneindeutiger Zeichen nicht höher ist als - das Dokument wird nur dann an die Überprüfungswarteschlange gesendet, wenn der Prozentsatz der nicht eindeutigen Zeichen größer ist als der im Feld % pro Dokument bestimmte Wert.
  5. Ganze Stapel exportieren – der Stapel wird nicht exportiert, solange nicht alle seine Dokumente verarbeitet wurden.
  6. Verarbeitete Dokumente nach Export löschen – löscht automatisch verarbeitete Dokumente nach dem Export.
  7. Verwenden Sie separate Warteschlangen für:
    • Überprüfung der Dokumentzusammenstellung
    • Datenüberprüfung
    • Stapelintegritätsprüfung
    • Exportbestätigung

    Das Erstellen von separaten Überprüfungswarteschlangen unterteilt die Überprüfungsphase in Unterschritte, die alle von ihrem eigenen Operator durchgeführt werden. Somit ist jeder Operator nur für eine Aufgabe zuständig: Datenüberprüfung, Überprüfen der Dokumentzusammenstellung usw.

    Wenn alle oben genannten Warteschlangen von einem Operator gehandhabt werden, wird er/sie alle Tasks abwechselnd ausführen müssen: das Dokument aus der Überprüfungswarteschlange der Dokumentzusammenstellung nehmen, die Zusammenstellung überprüfen, die Daten aus der Datenüberprüfungswarteschlange nehmen und diese überprüfen, etc.


Erstellen eines Projekts

Bevor Sie mit der Verarbeitung von Dokumenten starten können, müssen Sie ein Projekt erstellen. Projekte umfassen:

  • Bildimportprofile
  • Eine oder mehrere Dokumentdefinitionen
  • Stapeltypen

Laden Sie das fertige Projekt zum Anwendungsserver hoch.

Projekte werden auf der Projektkonfigurationsstation erstellt und über die Verwaltungs- und Überwachungskonsole zum Anwendungsserver hochgeladen.

Zur Erstellung eines neuen Projekts wählen Sie Datei>Neues Projekt…

Projekteigenschaften
Dokumentdefinitionen
Bildimportprofile
Stapeltypen
Stapel


Projekteigenschaften

Die Eigenschaften eines Projekts können in einem separaten Dialogfeld angezeigt und geändert werden, wenn Sie im Hauptfenster die Option Projekt>Projekteigenschaften… auswählen.

Die Registerkarte Allgemein zeigt den Namen des Projekts, den Pfad zu den Projektdateien und eine Beschreibung des Projekts an. Sie können im Feld Exportstammpfad auch das Stammverzeichnis für den Export in Dateien angeben.

Die Registerkarte Bildvorverarbeitung zeigt die Optionen für die Bildvorverarbeitung an. Sie können diese Optionen gegebenenfalls ändern. Einzelheiten finden Sie unter Optionen für die Bildvorverarbeitung.

Die Registerkarte Erkennung enthält die Option Leerseiten bei der Erkennung löschen. Aktivieren Sie diese Option, wenn Sie möchten, dass leere Seiten während des Erkennungsvorgangs gelöscht werden. Zusätzlich können Sie auf dieser Registerkarte einen FlexiLayout Klassifikator Ihrem Projekt hinzufügen.

Wählen Sie auf der Registerkarte Integritätsprüfung Vor dem Export Stapelintegritätsprüfung durchführen, wenn Sie ein Skript ausführen möchten, das die Stapelintegrität vor dem Export überprüft. Klicken Sie auf Prüfskript bearbeiten…, wenn das Skript bearbeitet werden soll.

Die Registerkarte Exportieren zeigt die Standardexporteinstellungen an. Sie können diese Einstellungen gegebenenfalls ändern. Mit der Option Skript nach Export ausführen wird die Exportsteuerung aktiviert. Weitere Informationen über die Exportsteuerung finden Sie unter Beschreibung von Exportprozeduren mithilfe von Skripten und Beispielskripte für die Exportbeschreibung. Um ein nicht erkanntes Dokument zu exportieren, wählen Sie Export nicht erkannter Dokumenteund spezifizieren Sie die Exporteinstellungen im Dialogfeld Export von nicht erkannten Dokumenten, das angezeigt wird, wenn Sie auf Bearbeiten…klicken

Auf der Registerkarte Workflow können Sie Ihre Workflows einstellen (für den "Standard"-Stapeltyp). Einzelheiten finden Sie unter Workflow-Installation.


Stapeltypen

ABBYY FlexiCapture 9.0 ermöglicht die Stapelverarbeitung von Dokumenten: Vor der eigentlichen Verarbeitung wird ein Stapel erstellt und ihm die Dokumentbilder hinzugefügt. Stapel können beim Import von Bildern automatisch oder manuell erstellt werden (d.h. beim Einscannen von Dokumenten oder beim Import von Bildern bereits gescannter Dokumente). Die Einstellungen für die Dokumentverarbeitung werden für jeden Stapeltyp einzeln festgelegt. Sie können mehrere Stapeltypen für die am häufigsten genutzten Verarbeitungskonfigurationen erstellen. In diesem Fall reduziert sich die Arbeit der Operatoren darauf, einen geeigneten Stapeltyp auszuwählen.

Ein Stapeltyp definiert die folgenden Verarbeitungseinstellungen:

  • Bildvorverarbeitung
  • Dokumentdefinitionen und die Reihenfolge, in der sie angewendet werden sollen
  • Stapelintegritätsprüfung
  • Standard-Stapel-Export
  • Stapelverarbeitung

Der Stapeltyp legt auch den Inhalt der Liste der Registrierungsparameter fest (dabei handelt es sich um Textinformationen, die einen Stapel charakterisieren).

Stapeltypen werden vom Projektkonfigurator für jedes Projekt einzeln erstellt.

So erstellen Sie einen Stapeltyp:

  1. Starten Sie die Projektkonfigurationsstation (Start>Programs>Stations von ABBYY FlexiCapture 9.0>Projektkonfigurationsstation) und öffnen Sie das Projekt vom Server ( (Datei>Projekt von Server öffnen…)
  2. Öffnen Sie das Dialogfeld Stapeltypen durch Auswahl von Projekt>Stapeltypen….
  3. Klicken Sie auf Neu und folgen den Bildschirmanweisungen.

Die von Ihnen erstellten Stapeltypen werden automatisch zum Anwendungsserver hochgeladen und stehen den Operatoren zur Verfügung.

Hinweis: Um den Operatoren die Arbeit mit den neu erstellten Stapeltypen zu ermöglichen, muss der Administrator die Stapeltypen festlegen, die jedem Operator zur Verfügung stehen. Dies geschieht im Rahmen der Zuteilung von Rollen an die Operatoren.


Registrierungsparameter

Registrierungsparameter sind textuelle Eigenschaften für die Identifizierung eines spezifischen Stapels oder Dokuments. Solche Eigenschaften können das Scandatum, der Name des Scanoperators usw. sein. Ein Registrierungsparameter kann zwingend erforderlich oder optional sein.

Registrierungsparameter können dem Stapel während der Erstellung zugewiesen werden (wenn der Stapel automatisch mittels Importprofilen erstellt wird). Registrierungsparameter können Stapeln und Dokumenten auch auf der Scanstation zugewiesen und zusammen mit den Bildern an ABBYY FlexiCapture gesendet werden.

Die Registrierungsparameter können in der Registerkarte Registrierungsparameter des Dialogfelds für die Stapeleigenschaften oder Dokumenteigenschaften konfiguriert werden (klicken Sie hierfür im Kontextmenü auf Eigenschaften…).


Hochladen eines Projekts zum Anwendungsserver

Nach der Erstellung eines Projekts müssen Sie es zum Anwendungsserver hochladen. Dadurch werden Projekteinstellungen, Dokumentdefinitions-Dateien, Wörterbücher und andere Servicedaten auf den Anwendungsserver kopiert.

Wichtig! Im Projekt erstellte Stapel werden beim Hochladen nicht auf den Anwendungsserver kopiert.

Um ein Projekt zum Anwendungsserver hochzuladen, wählen Sie aus dem Hauptmenü der Projektkonfigurationsstation Datei>Projekt auf Server hochladen….

Hinweis: Neue Projekte können nur vom Administrator erstellt werden. Ein Projektkonfigurationsoperator kann nur bereits erstellte Projekte konfigurieren. Nachdem das Projekt zum Anwendungsserver hochgeladen wurde und der Administrator den Operatoren der Stationen die erforderlichen Berechtigungen erteilt hat (über die Verwaltungs- und Überwachungskonsole), muss der Projektkonfigurator daher das Projekt auf dem Anwendungsserver durch Wahl von Datei>Projekt von Server öffnen… öffnen und die notwendigen Einstellungen vornehmen (d.h. Dokumentdefinitionen und Importprofile erstellen, Exporteinstellungen festlegen usw.).


Dokumentdefinitionen

Das Erstellen von Dokumentdefinitionen ist der wichtigste und entscheidendste Schritt beim Konfigurieren von Projekten und trägt wesentlich zur Qualität der Daten nach der Verarbeitung bei.

Dokumentdefinitionen können nur in der Projektkonfigurationsstation erstellt werden.

In einer Dokumentdefinition sind die Positionen von Dokumentelementen definiert sowie die bei der Datenextraktion zu verwendenden Felder angegeben. Beim Erstellen einer Dokumentdefinition werden die Eigenschaften der Felder und deren Wertebereiche festgelegt. Darüber hinaus werden Exporteinstellungen für die Daten konfiguriert.

Zum Erstellen einer Dokumentdefinition starten Sie den Dokumentdefinitionsassistenten:

  1. Wählen Sie im Hauptmenü von ABBYY FlexiCapture 9.0 Projekt>Dokumentdefinitionen…
    2. aus.
  2. Klicken Sie im daraufhin geöffneten Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu….
  3. Befolgen Sie die Anweisungen des Dokumentdefinitionsassistenten.
Dokumentdefinitionsassistent
Automatische Erkennung von Feldern und statischen Elementen
Statische Elemente
Erstellen von Feldern einer Dokumentdefinition
Feldeigenschaften
Regelbasierte Validierung
Konfigurieren des Datenexports
Konfigurieren der Datendarstellung im Dokumentfenster
Eigenschaften einer Dokumentdefinition
Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare
Erstellen einer Dokumentdefinition für mehrseitige Dokumente
Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente
Erstellen einer Dokumentdefinition für Dokumente mit Anhängen
Verarbeiten nicht strukturierter Dokumente
Bearbeitung und Veröffentlichung einer Dokumentdefinition
Testen einer Dokumentdefinition


Dokumentdefinitionsassistent

Wenn Sie eine neue Dokumentdefinition erstellen möchten, wählen Sie im Hauptmenü die Option Projekt > Dokumentdefinitionen… aus und klicken dann im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Neu…. Daraufhin wird der Assistent zum Erstellen neuer Dokumentdefinitionen geöffnet.

  1. Legen Sie im Dialogfeld Neue Dokumentdefinition erstellen die Grundeinstellungen der Dokumentdefinition fest: Name und Kommentar, verwendete Sprache [Sprache (Gebietsschema)] und Schreibstil (Schreibstil). Die Dropdownliste enthält standardmäßig nur Sprachen mit Wörterbuchunterstützung. Wenn Sie eine Sprache ohne Wörterbuchunterstützung auswählen möchten, aktivieren Sie die Option Alle Sprachen anzeigen. Es ist sehr wichtig, die Sprache korrekt anzugeben, da die präzise Dokumenterkennung davon abhängt. Der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, so dass im Programm der jeweils typische Schreibstil ausgewählt wird.

    Beispiele für unterschiedliche Schreibstile von Zahlen anzeigen
    – russische Zwei
    – amerikanische Zwei
    – „normale“ Fünf in jedem Schreibstil
    – japanische Fünf
    – russische Eins
    – deutsche Eins
    – „normale“ Neun in jedem Schreibstil
    – tschechische Neun mit Kreis rechts
    – amerikanische Neun ohne Bogenabschluss

    Geben Sie den Texttyp an:

    • ICR (Handschrift): Aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden.
    • OCR (Druck): Aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis:Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

    Klicken Sie auf Weiter, um mit dem nächsten Schritt fortzufahren.

  2. Im zweiten Schritt laden Sie das Bild der Dokumentseite, um die Dokumentdefinition zu erstellen. Sie können das Bild einer unausgefüllten Seite scannen oder aus einer Datei laden.

    Hinweis: Die Dokumentdefinition für statische Formulare wird mithilfe eines Bilds erstellt, das durch Scannen eines unausgefüllten Formulars entsteht. Dabei sollte es sich um ein Bild mit guter Qualität ohne Verzerrungen (ohne Schrägstellen, Fehlstellen usw.) handeln. Beim Erstellen von Dokumentdefinitionen von Formularen mit farbigem Hintergrund sollten die Seiten ohne Filter gescannt werden, sodass der Hintergrund beim Scannen nicht ausgeblendet wird. (Wählen Sie später beim Scannen von Seitenbildern zur Datenerkennung einen Scanmodus aus, bei dem der Hintergrund ausgeblendet wird.)

    Wenn Dokumente mehrere Seiten umfassen, laden Sie die erste Seite, und fügen Sie die restlichen Seiten entsprechend den Empfehlungen im Abschnitt Erstellen von Dokumentdefinitionen für mehrseitige Dokumente hinzu.

    Wenn Sie ein FlexiLayout verwenden möchten, das mit ABBYY FlexiLayout Studio erstellt wurde, aktivieren Sie die Option FlexiLayout laden, und geben Sie den Pfad der FlexiLayout-Datei an. Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

    Klicken Sie auf die Schaltfläche Weiter.

  3. Im nächsten Schritt wählen Sie Feldtypen aus, die automatisch im Bild erkannt werden sollen. Sie können Auswahlfelder und Texteingabefelder auswählen. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

    Hinweis:Die automatische Ankersuche wird immer durchgeführt. Wenn ein Formular Anker enthält, werden diese erkannt und im Bild gekennzeichnet.

    Klicken Sie auf die Schaltfläche Fertigstellen.

Nach Beenden des Dokumentdefinitionsassistenten wird das Fenster des Dokumentdefinitionseditors geöffnet, in dem Sie weitere Vorgänge zum Erstellen einer Dokumentdefinition durchführen können. Der nächste Schritt der Erstellung einer Dokumentdefinition ist die Kennzeichnung von Feldern und statischen Elementen im Seitenbild und die Konfiguration der zugehörigen Eigenschaften.


Automatische Erkennung von Feldern und statischen Elementen

Automatische Erkennung beim Hinzufügen eines Bilds:

Beim Hinzufügen eines Seitenbilds werden Anker vom Programm immer erkannt. Wenn das Bild Standardanker enthält (z. B. schwarze Quadrate) werden diese erkannt und markiert. Wenn die Optionen Text und Auswahlfelder aktiviert sind, werden Textfelder und Auswahlfelder gesucht. Textfelder mit einem Bereich und rechteckige Auswahlfelder werden besonders gut automatisch erkannt. Wenn Eingabefelder in einem Formular über keinen Bereich verfügen und Auswahlfelder vor einem weißen Hintergrund eingefügt werden, müssen sie in der Regel manuell hervorgehoben werden.

Automatische Erkennung im Fenster des Dokumentdefinitionseditors:

Wenn Sie die automatische Erkennung im Fenster des Dokumentdefinitionseditors festlegen möchten, wählen Sie den entsprechenden Modus (Feldmodus oder Modus für statische Elemente) und anschließend die Menüoptionen Extras > Objekte automatisch erkennen… aus. Markieren Sie die Typen der Felder oder statischen Elemente, die automatisch erkannt werden sollen.

Wenn spezifische Objekte im Bild automatisch erkannt werden sollen, wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus, und klicken Sie in der Symbolleiste auf [image]. Wenn Sie auf das betreffende Element klicken, wird es mit einem Rechteck markiert. Der Elementtyp wird automatisch erkannt.

Automatische Erkennung eines Bereichs:

Führen Sie folgende Schritte aus, damit der Bereich eines Felds oder eines statischen Elements eines bestimmten Typs automatisch erkannt wird:

  1. Wählen Sie den erforderlichen Modus (Feldmodus oder Modus für statische Elemente) aus.
  2. Wählen Sie den Typ des Felds oder statischen Elements über die entsprechende Schaltfläche in der Symbolleiste aus.
  3. Drücken Sie die Umschalttaste
  4. Klicken Sie mit der linken Maustaste in den Bereich des Felds oder des statischen Elements.


Statische Elemente

Statische Elemente werden zur Zuordnung und Identifizierung von Dokumentdefinitionen verwendet. Aus statischen Elementen werden keine Daten extrahiert.

Klicken Sie auf die Schaltfläche [image], um in den Modus für statische Elemente zu wechseln und statische Elemente im Dokumentdefinitionseditor bearbeiten zu können.

Statische Elemente können zur Zuordnung und Identifizierung von Dokumentdefinitionen verwendet werden. Die entsprechende Verwendung wird beim Konfigurieren der Eigenschaften der Elemente festgelegt. Anker dienen der Zuordnung von Dokumentdefinitionen zu Formularbildern. Kennungen sind erforderlich, um beim Verarbeiten mehrerer Formulare in einem Durchgang ermitteln zu können, zu welchen Formularen die entsprechenden Seiten jeweils gehören. Weitere Informationen finden Sie unter Erstellen von maschinenlesbaren Formularen.

Statischen Elementen sind keine Namen, sondern nur Bereiche im Bild zugewiesen.

Wenn eine Dokumentdefinition einem Dokumentbild zugeordnet wird, sucht das Programm nach statischen Elementen. Anhand ihrer Position wird dann eine Dokumentdefinition ausgewählt. Die Erkennung der Werte statischer Elemente (Text und Barcode) wird nur dann durchgeführt, wenn dies zur Identifizierung erforderlich ist. Siehe Angeben von Werten für Objekte zur Identifizierung.

Im Programm werden folgende statische Elemente verwendet:

Statisches Element | Schaltfläche in der Symbolleiste
Anker |
Trennlinie |
Ankertext |
Ankerbarcode |

Beim Hinzufügen eines Bilds wird im Programm automatisch nach Ankern gesucht.

So erstellen Sie ein statisches Element manuell:

  1. Wählen Sie den Modus für statische Elemente aus.
  2. Wählen Sie das Tool zum Erstellen des gewünschten Elementtyps aus.
  3. Setzen Sie den Mauszeiger in die Ecke des Elements, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Bereich des Elements.

Der Bereich des statischen Elements wird in einem Rechteck eingerahmt. Je nach Elementtyp wird der Rahmen in einer anderen Farbe angezeigt. Dem statischen Element werden Standardeigenschaften zugewiesen.

So ändern Sie die Eigenschaften eines statischen Elements:

  1. Markieren Sie den Bereich des statischen Elements im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Ändern Sie die Eigenschaften des statischen Elements im daraufhin geöffneten Dialogfeld.

Weitere Informationen zu statischen Elementen:

  • Anker
  • Trennlinien
  • Ankertext
  • Ankerbarcode


Anker

Anker sind statische Elemente, die im Bild automatisch markiert werden.

So markieren Sie Anker manuell:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].

  3. Setzen Sie den Mauszeiger in die Ecke eines Ankers, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankerbereich.

Ankereigenschaften

So ändern Sie die Ankereigenschaften:

  1. Markieren Sie den entsprechenden Anker.
  2. Klicken Sie mit der rechten Maustaste in den Ankerbereich und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Eigenschaften im daraufhin geöffneten Dialogfeld:
    • Für Zuordnung von Dokumentdefinitionen verwenden: Diese Option muss aktiviert sein, damit der Anker für die Zuordnung von Dokumentdefinitionen verwendet wird (empfohlen).
    • Für Identifizierung von Dokumentdefinitionen verwenden: Aktivieren Sie diese Option, um den Ankertext zur Identifizierung von Dokumentdefinitionen zu verwenden.
    • Ankertyp: Es ist wichtig, für eine korrekte Zuordnung von Dokumentdefinitionen den Ankertyp anzugeben. Folgende Optionen sind verfügbar: Schwarzes Quadrat, Kreuz oder Ecke.


Ankertext

Ankertext ist ein statisches Element. Dabei kann es sich um einen beliebigen statischen Text in einem Bild handeln, beispielsweise eine Kopfzeile oder Signatur.

So markieren Sie Ankertext:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke des Ankertexts, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Ankertextbereich.

Ankertexteigenschaften

So ändern Sie die Ankertexteigenschaften:

  1. Markieren Sie den Text.
  2. Klicken Sie mit der rechten Maustaste in den Ankertextbereich und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Eigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Zuordnung von Dokumentdefinitionen verwenden: Diese Option muss aktiviert sein, damit der Ankertext zur Zuordnung von Dokumentdefinitionen verwendet wird.
    • Für Identifizierung von Dokumentdefinitionen verwenden: Aktivieren Sie diese Option, um den Ankertext zur Identifizierung von Dokumentdefinitionen zu verwenden.
    • Wert: Wenn Sie Ankertext als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Wenn automatisch ein Wert eingefügt werden soll, klicken Sie auf die SchaltflächeTipp.
    • Maximale Fehlerzahl: Hier können Sie die maximal zulässige Anzahl von Fehlern für die Ankertextzeichenfolge festlegen.

    Legen Sie auf der Registerkarte Erkennung Erkennungsoptionen für den mit maximaler Genauigkeit zu erkennenden statischen Text fest:

    • ICR (Handschrift): Aktivieren Sie diese Option, wenn statischer Text handschriftlich vorliegt.

    • OCR (Druck): Aktivieren Sie diese Option, wenn statischer Text gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (Druckmaschine, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

    • Erweitert: Über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben.

    • Datentyp: Wählen Sie die Sprache des Texts aus. Verwenden Sie dazu die Schaltfläche Auswählen….

    • Groß-/Kleinschreibung: Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im statischen Text aus. Wenn der Text Groß- und Kleinschreibung enthält, ändern Sie den Wert Automatisch nicht.

    • Ausrichtung: Geben Sie die Ausrichtung des Texts an.

    • Aktivieren Sie bei einzeiligem Text die Option Eine Zeile.

    • Wenn der Text keine Leerzeichen enthält, z. B. nur aus einem Wort besteht, aktivieren Sie die Option Ein Wort.

    • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:
    • Invertieren: Das Bild wird invertiert.
    • Textur entfernen: Die Textur wird entfernt.
    • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Trennlinien

Trennlinien sind statische Elemente. Dabei handelt es sich um horizontale oder vertikale Linien in einem Bild.

So markieren Sie Trennlinien:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke einer Trennlinie, und ziehen Sie die Maus bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Bereich der Trennlinie.

Eigenschaften von Trennlinien

So ändern Sie die Eigenschaften von Trennlinien:

  1. Markieren Sie die Trennlinie.
  2. Klicken Sie mit der rechten Maustaste in den Bereich der Trennlinie, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:
    • Für Zuordnung von Dokumentdefinitionen verwenden: Diese Option muss aktiviert sein, damit die Trennlinie zur Zuordnung von Dokumentdefinitionen verwendet werden kann.
    • Für Identifizierung von Dokumentdefinitionen verwenden: Aktivieren Sie diese Option, um die Trennlinie zur Identifizierung von Dokumentdefinitionen zu verwenden.


Ankerbarcode

Der Ankerbarcode ist ein statisches Element.

Wichtig! Ein Barcode kann sowohl als Feld als auch als statisches Element markiert werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Zuordnung oder Identifizierung von Dokumentdefinitionen vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Eigenschaften eines statischen Elements, eines Ankerbarcodes, erläutert. Siehe auch Barcodefeld.

So markieren Sie einen Ankerbarcode:

  1. Wechseln Sie in den Modus für statische Elemente.
  2. Klicken Sie in der Symbolleiste auf [image].
  3. Setzen Sie den Mauszeiger in die Ecke eines Barcodes, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.

    Oder

    Klicken Sie bei gedrückter Umschalttaste in den Barcodebereich.

Eigenschaften eines Ankerbarcodes

So ändern Sie die Eigenschaften eines Ankerbarcodes:

  1. Markieren Sie den Barcode.
  2. Klicken Sie mit der rechten Maustaste in den Barcodebereich, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  3. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld:

    Registerkarte Allgemein:

    • Für Zuordnung von Dokumentdefinitionen verwenden: Diese Option muss aktiviert sein, damit der Barcode zur Zuordnung von Dokumentdefinitionen verwendet wird
    • Für Identifizierung von Dokumentdefinitionen verwenden: Aktivieren Sie diese Option, um den Barcode zur Identifizierung von Dokumentdefinitionen zu verwenden.
    • Wert: Wenn Sie einen Ankerbarcode als Objekt zur Identifizierung verwenden, können Sie den entsprechenden Wert festlegen. Um einen Wert automatisch einzufügen, klicken Sie auf die Schaltfläche Tipp.
    • Für Zuordnung von Dokumentdefinitionen erforderlich: Wenn diese Option aktiviert ist, wird die Dokumentdefinition nur zugeordnet, wenn der Barcode zugeordnet wird. Aktivieren Sie diese Option, wenn ein Stapel zahlreiche ähnliche Dokumentdefinitionen enthält, die nur durch die Werte der Barcodes oder die Werte eines von mehreren Barcodes unterschieden werden können. Dies beschleunigt die Auswahl von Dokumentdefinitionen. Aktivieren Sie diese Option nicht, wenn die Dokumentdefinition zugeordnet werden soll, obwohl kein Barcode vorliegt oder der Barcode zu undeutlich ist.

    Registerkarte Erkennung:

    • Codetyp: Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt).
    • Ausrichtung: Geben Sie die Ausrichtung des Barcodes an.

    Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

    • Invertieren: Das Bild wird invertiert.
    • Textur entfernen : Die Textur wird entfernt.
    • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
    • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Angabe von Werten für Objekte zur Identifizierung

Mithilfe von Objekten zur Identifizierung kann festgestellt werden, zu welchem Formular eine Seite gehört und eine Dokumentdefinition ausgewählt werden, bei der der Stapel mehrere Dokumentdefinitionen mit der anfänglichen Ankergruppe enthält. Bei der gleichzeitigen Verarbeitung mehrerer Formulare in einem Durchgang wird anhand der Position der Objekte zur Identifizierung ermittelt, zu welchem Formular die betreffende Seite gehört.

Wenn ein Ankerbarcode oder Ankertext als Objekt zur Identifizierung verwendet wird, können Sie die Werte dieser Objekte zur Identifizierung angeben. In diesem Fall werden beim Zuordnen einer Dokumentdefinition die im Bild erkannten Daten mit dem Wert des Objekts zur Identifizierung verglichen. Die Zuordnung der Dokumentdefinition ist dann nur bei Übereinstimmung der Werte möglich.

Die Werte von Objekten zur Identifizierung können im Dialogfeld für die Eigenschaften von statischen Elementen auf der Registerkarte Allgemein festgelegt werden. Die Werte für Text und Barcodes können automatisch eingetragen werden. Dies erfolgt über die Schaltfläche Tipp.

Hinweis:Wenn es möglich ist, eine Seite nur anhand der Position der Elemente mit absoluter Sicherheit zu identifizieren, müssen Sie diese Werte nicht festlegen. Sie sollten diese Funktion nur einsetzen, wenn dies absolut notwendig ist, da durch die Zuweisung des Werts für das Objekt zur Identifizierung das Erkennungsmodul bei der Anwendung von Dokumentdefinitionen gestartet wird, wodurch sich die Zuordnung von Dokumentdefinitionen mit Bildern verlangsamt.


Erstellen von Feldern einer Dokumentdefinition

Felder sind zur Datenextraktion vorgesehen.

Klicken Sie auf die Schaltfläche [image], um in den Modus für Feldbereiche zu wechseln und Felder im Dokumentdefinitionseditor bearbeiten zu können.

Alle Bereiche im Bild, die zur Datenerfassung eingesetzt werden sollen, müssen als Felder markiert sein. Die Daten in diesen Feldern werden erkannt, und die zugehörigen Werte können exportiert werden.

Feldern sind Namen zugewiesen, deren Listen im Fenster Dokumentstruktur angezeigt werden. Normalerweise verfügen Felder über einen Bereich im Bild. Sie können jedoch auch Felder ohne Bereich erstellen, z. B. zum Speichern von Zwischenergebnissen.

Folgende Feldtypen werden vom Programm erkannt:

Feld | Schaltfläche in der Symbolleiste
Texteingabefeld |
Auswahlfeld |
Auswahlfeldgruppe |
Barcode |
Bild |
Tabelle |
Feldgruppe |

So erstellen Sie ein Feld:

  1. Wählen Sie den Modus für Feldbereiche aus.
  2. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.
  3. Setzen Sie den Mauszeiger in die Ecke des Felds, und ziehen Sie den Mauszeiger bei gedrückter linker Maustaste diagonal in die gegenüberliegende Ecke.
    Oder
    Klicken Sie bei gedrückter Umschalttaste in den Feldbereich.

Der Feldbereich wird in einem Rechteck eingerahmt. Je nach Feldtyp wird der Rahmen in einer anderen Farbe angezeigt.

Dem erstellten Feld wird ein Standardname zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt. Der Name wird im Fenster Dokumentstruktur auf der Registerkarte Felder in der Liste der Felder angezeigt.

Dem Feld werden Standardeigenschaften zugewiesen.

  • Erstellen von Gruppen von Auswahlfeldern
  • Erstellen von Tabellen
  • Erstellen einer Feldgruppe
  • Ändern eines Feldnamens
  • Kopieren, Verschieben und Löschen von Feldern
  • Felder ohne Bereich
  • Feldeigenschaften


Erstellen einer Gruppe von Auswahlfeldern

In einer Gruppe von Auswahlfeldern werden logisch verknüpfte Auswahlfelder zusammengefasst, die normalerweise sich gegenseitig ausschließenden Antworten auf eine Frage entsprechen. In diesem Fall wird ein Auswahlfeld aus der Gruppe ausgewählt und der zugehörige Wert exportiert. Dabei handelt es sich jedoch nicht um eine zwingende Bedingung. Sie können im Programm festlegen, dass mehrere Auswahlfelder einer Gruppe aktiviert werden können (die entsprechende Option wählen Sie in den Eigenschaften für Gruppen von Auswahlfeldern aus).

Erste Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

So erstellen Sie eine Gruppe von Auswahlfeldern:

  1. Klicken Sie auf das Tool [image], und erstellen Sie Auswahlfelder für die entsprechende Gruppe.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Auswahlfelder der Gruppe einen Auswahlrahmen.
  3. Die innerhalb des Rechtecks liegenden Auswahlfelder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Gruppe positioniert. Die Eigenschaften der Auswahlfelder in einer Gruppe sind identisch und können nicht einzeln bearbeitet werden.

Zweite Möglichkeit zum Erstellen einer Gruppe von Auswahlfeldern:

Sie müssen nicht jedes Auswahlfeld in der Gruppe markieren.

  1. Klicken Sie auf das Tool [image], und markieren Sie stattdessen alle Auswahlfelder, die ein und derselben Gruppe angehören sollen, mit einem Rechteck.
  2. Die Auswahlfelder innerhalb des Rechtecks werden automatisch erkannt, benannt und in einer Gruppe zusammengefasst.


Erstellen einer Feldgruppe

Felder können in Gruppen zusammengefasst werden, so dass Dokumentstrukturen klar dargestellt sowie mehrfach vorkommende Feldgruppen erstellt werden können. So können z. B. Ort, Straße und Hausnummer als „Anschrift“ zusammengefasst werden. Sie können dann Felder für die Gruppe „Firmenanschrift“ einfach durch Kopieren der Feldgruppe „Anschrift“ erstellen.

So erstellen Sie eine Feldgruppe:

  1. Erstellen Sie die Felder, die der Gruppe angehören sollen.
  2. Klicken Sie auf das Tool [image], und ziehen Sie um alle Felder der Gruppe einen Auswahlrahmen.
  3. Die innerhalb des Rechtecks liegenden Felder werden markiert. Die Namen der Felder in der Dokumentstruktur werden zusammengefasst und unterhalb des Namens der Feldgruppe positioniert.

Wenn in einem Formular bestimmte Feldgruppen mehrfach vorkommen, können Sie nach dem Erstellen einer Gruppe mehrere Instanzen dieser Gruppe erstellen. Alle Feldeigenschaften und Regeln der Gruppe gelten jeweils für alle Instanzen der Gruppe. Siehe Felder mit mehreren Instanzen.

Sie können eine Feldgruppe auch kopieren. Dadurch wird jedoch eine neue unabhängige Gruppe erstellt.


Erstellen einer Tabelle

Mit ABBYY FlexiCapture 9.0 können Sie Dokumentdefinitionen für Dokumente mit Tabellen erstellen. Durch Erstellen von Tabellenfeldern können die Konfiguration und Datenextraktion von Tabellen sowie der Datenexport aus Tabellen erheblich vereinfacht werden. Bei einem Tabellenfeld handelt es sich um eine Gruppe mit Spalten des gleichen Typs und mehreren Zeilen.

Es stehen folgende Typen von Tabellenspalten zur Verfügung:

  • Text
  • Auswahlfeld
  • Barcode
  • Bild

So erstellen Sie eine Tabelle:

  1. Wählen Sie das Tool [image] aus, und ziehen Sie um den Tabellenbereich einen Auswahlrahmen. Die Tabellenkopfzeile muss außerhalb des ausgewählten Bereichs liegen. In der Symbolleiste werden weitere Tools zur Tabellenverarbeitung angezeigt:
    Erstellen einer Tabellenspalte
    Erstellen von Trennlinien
    Entfernen von Trennlinien
  2. Grenzen Sie Tabellenzellen ab, indem Sie die erforderliche Anzahl Trennlinien erstellen. Wählen Sie zum Erstellen von Trennlinien das Tool [image] aus, und klicken Sie auf die Stelle, an der die Trennlinie eingefügt werden soll. Setzen Sie zum Erstellen einer vertikalen Trennlinie den Mauszeiger in den Tabellenbereich, ziehen Sie den gepunkteten Zeiger bis zur gewünschten Stelle, und klicken Sie einmal mit der linken Maustaste. Führen Sie zum Erstellen einer horizontalen Trennlinie den gleichen Vorgang bei gedrückter Alt-Taste aus. Sie können auch festlegen, dass Trennlinien automatisch erkannt werden. Markieren Sie die erstellte Tabelle, und wählen Sie dann im Menü die Optionen Vertikale Trennlinien automatisch erkennen und Horizontale Trennlinien automatisch erkennen aus.
  3. Erstellen von Tabellenspalten. Um eine Tabellenspalte zu erstellen, wählen Sie das Tool [image] aus, und klicken Sie in den Spaltenbereich. Wählen Sie in der Dropdownliste einen Spaltentyp aus.


Ändern eines Feldnamens

So benennen Sie ein Feld um:

  • Klicken Sie in der Dokumentstruktur auf den entsprechenden Feldnamen, klicken Sie mit der rechten Maustaste, wählen Sie im Kontextmenü die Option Umbenennen aus, und geben Sie einen neuen Namen ein.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Name vorschlagen aus. Dem Feld wird ein Name zugewiesen, der dem erklärenden Text entspricht, der dem Feldbereich am nächsten liegt.

Oder

  • Klicken Sie im Bild auf den Feldbereich, klicken Sie mit der rechten Maustaste und wählen Sie im Kontextmenü die Option Name aus Bild abrufen… aus. Markieren Sie anschließend mit dem Mauszeiger den erklärenden Text, der als Feldname verwendet werden kann. Daraufhin wird der ausgewählte Text als Feldname angezeigt.

Oder

  • Öffnen Sie das Dialogfeld für die Feldeigenschaften und ändern Sie den Namen auf der Registerkarte Allgemein.


Kopieren, Verschieben und Löschen von Feldern

Felder können kopiert, gelöscht, verschoben und geändert werden. Die Namen kopierter Felder sind durch eine unterschiedliche Nummerierung gekennzeichnet. Mehrere Felder können Sie durch Klicken bei gedrückter Strg-Taste markieren. Die ausgewählte Aktion wird dann auf alle markierten Felder angewendet.

Wenn Sie ein Feld löschen möchten, markieren Sie es und drücken Sie Entf oder wählen Sie im Kontextmenü die Option Löschen aus. Wenn Sie nur den Bereich löschen und das Feld in der Dokumentstruktur beibehalten möchten, drücken Sie Umschalt+Entf oder wählen Sie im Kontextmenü des entsprechenden Felds die Option Bereich löschen aus. Siehe Felder ohne Bereich.


Felder ohne Bereich

Felder haben im Bild möglicherweise keinen Bereich. Die Namen der Felder ohne Bereich sind in der Liste durch ein rotes Sternchen gekennzeichnet. In diesen Feldern können beispielsweise Zwischenergebnisse aus Berechnungen gespeichert werden, die anhand der Werte der erkannten Felder durchgeführt werden. Sie können z. B. die Werte mehrerer Felder mithilfe der Regel zum Verbinden von Feldwerten kombinieren und das Ergebnis in einem Feld ohne Bereich speichern.

Felder ohne Bereich haben alle Eigenschaften des entsprechenden Feldtyps. Die Werte dieser Felder können ebenfalls exportiert werden.

Felder ohne Bereich können folgendermaßen erstellt werden:

  1. Klicken Sie im Dokumentdefinitionseditor auf die Menüoption Bearbeiten>Feld erstellen und erstellen Sie ein Feld mit dem gewünschten Feldtyp. Der Feldname wird in der Liste mit einem Sternchen angezeigt. Damit wird in der Dokumentstruktur ein Feld, jedoch kein Bereich im Bild erstellt.
  2. Die andere Möglichkeit besteht darin, den Bereich eines regulären Felds zu löschen. Markieren Sie das gewünschte Feld im Bild oder in der Liste und wählen Sie im Kontextmenü die Option Bereich löschen aus. Der Bereich wird gelöscht, und der Name des Felds wird durch ein rotes Sternchen gekennzeichnet.

Wenn Sie einen Bereich für Felder erstellen möchten, die im Bild keinen Bereich haben, klicken Sie in der Symbolleiste auf [image], und markieren Sie den gewünschten Bereich mit dem Mauszeiger. Wenn die Liste Felder mit Sternchen enthält, werden Sie aufgefordert, ein Feld mit dieser Kennzeichnung auszuwählen.


Ausschließen eines Bereichs von der Erkennung

Manchmal ist es erforderlich, einen bestimmten Bereich von der Erkennung auszuschließen, z. B. einen Bereich mit erklärendem Text, der die Extraktion der Daten aus einem Feld erschwert.

Wenn Sie einen Bereich von der Erkennung ausschließen möchten, klicken Sie auf das Tool [image], und markieren Sie den auszuschließenden Bereich mit dem Mauszeiger.


Erstellen eines Felds mit einem nicht rechteckigen Bereich

Manchmal ist es notwendig, Felder mit nicht rechteckigen Bereichen zu erstellen, z. B. im folgenden Fragebogen:

So erstellen Sie einen nicht rechteckigen Feldbereich:

  1. Wählen Sie das Tool zum Erstellen des gewünschten Feldtyps aus.
  2. Wählen Sie einen rechteckigen Bereich aus, in dem Sie Bereichsteile in der gewünschten Form hinzufügen oder entfernen können.
  3. Wählen Sie das Tool [image] aus und markieren Sie den rechteckigen Bereich.
  4. So fügen Sie ein Bereichsfragment in den Bereich ein: Drücken Sie die Umschalttaste (der Mauszeiger wird als Pluszeichen angezeigt), und markieren Sie das entsprechende Fragment.
  5. So entfernen Sie ein Bereichsfragment: Drücken Sie Alt (der Mauszeiger wird als Minuszeichen angezeigt) und markieren Sie das entsprechende Fragment.


Felder mit mehreren Bereichen

Ein Feld kann mehrere Bereiche im Bild umfassen. Diese Bereiche können sich voneinander entfernt und auch auf verschiedenen Seiten befinden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert.

Es empfiehlt sich, bei Feldern, die sich auf mehreren Seiten befinden, mehrere Bereiche zu erstellen, z. B. bei großen Tabellen.

Beispiel anzeigen

So erstellen Sie ein Feld mit mehreren Bereichen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Bereich fortsetzen… aus.
  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Felder mit mehreren Instanzen

In Feldern können manche Elemente wiederholt auftreten. Dabei handelt es sich um Felder und Feldgruppen, die in einem Formular mehrfach vorkommen und ähnliche Objekte betreffen, z. B. die gleichen Details mehrerer Mitarbeiter, Kinder, Konten usw. Für diese Objekte werden Felder mit mehreren Instanzen erstellt.

Für jedes Feld können mehrere Instanzen festgelegt werden. Die zugehörigen Bereiche können voneinander entfernt und auch auf verschiedenen Seiten positioniert werden. Feldinstanzen weisen die gleichen Eigenschaften auf. Sie werden in separate Dateien oder Datenbanktabellen exportiert.

Sie können mehrere Instanzen einer Feldgruppe erstellen, wenn in einem Feld Gruppen mehrfach vorkommen.

Beispiel anzeigen

So erstellen Sie ein Feld mit mehreren Instanzen:

  1. Erstellen Sie ein Feld.
  2. Markieren Sie das Feld, klicken Sie mit der rechten Maustaste in den Feldbereich, und wählen Sie im Kontextmenü die Option Neue Instanz… aus.
  3. Verschieben Sie das Bereichsbild an die gewünschte Stelle auf der Seite.


Feldeigenschaften

Es ist sehr wichtig, dass die Eigenschaften jedes Felds korrekt konfiguriert werden. Feldeigenschaften wirken sich auf die Qualität beim Erkennen der Felder sowie darauf aus, ob die Werte der Felder exportiert und zur Überprüfung an den Operator gesendet werden können. Einige Eigenschaften spielen bei der Datenerkennung eine große Rolle. Dies betrifft beispielsweise die Markierungsmethode eines Texteingabefelds. Wenn das Texteingabefeld falsch konfiguriert ist, wird die beim Scannen nicht ausgeblendete Markierung nicht von den Zeichen getrennt. Die Erkennung ist dadurch möglicherweise nicht zufriedenstellend.

Die verschiedenen Feldtypen verfügen jeweils über andere Eigenschaften. Wenn Sie in einem Bild ein Feld eines bestimmten Typs erstellen, werden dem Feld die entsprechenden Standardeigenschaften zugewiesen.

So können Sie Feldeigenschaften ändern:

  1. Markieren Sie den Feldnamen in der Dokumentstruktur oder den Feldbereich im Bild, klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Ändern Sie die Feldeigenschaften im daraufhin geöffneten Dialogfeld.

Über die folgenden Links erhalten Sie weitere Informationen zu den Feldeigenschaften:

Texteingabefelder
Auswahlkästchen
Gruppen von Auswahlfeldern
Barcodes
Bilder
Tabellen
Feldgruppen


Texteingabefeld

Wenn Sie ein Textfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Datentypen
Erkennungseigenschaften
Überprüfungseigenschaften
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem treffendsten Beschreibungstext für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch Ändern des Feldnamens.
  • Überschrift: Der Name des Felds, der im Datenformular angezeigt wird.
  • Feldwert exportieren: Diese Option muss aktiviert sein, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z.B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Diese Option muss aktiviert sein, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Kann nicht leer sein: Aktivieren Sie diese Option, wenn es sich um ein erforderliches Feld handeln soll.
  • Schreibgeschützt: Aktivieren Sie diese Option, wenn das Feld nur zur Ansicht verfügbar sein soll, d. h. der Feldwert nicht geändert werden kann. Sie können diese Option für Felder aktivieren, deren Werte mithilfe einer Regel automatisch berechnet werden, z. B. Felder, in denen eine Summe gespeichert wird oder andere Felder zusammengefasst werden (siehe Regelbasierte Validierung).
  • Indexfeld: Aktivieren Sie diese Option, wenn Sie ein Feld zur Dokumentindizierung verwenden möchten. Beim Verarbeiten von Dokumenten können Sie dann den Wert des Felds für jedes Dokument anzeigen und Dokumente anhand des Feldwerts sortieren und suchen.
  • Kommentar: Hier können Sie Kommentare eingeben.


Datentypen für Texteingabefelder

Es ist sehr wichtig, dass Sie einem Texteingabefeld einen Datentyp zuweisen, sodass im Programm festgelegt wird, welche Daten im entsprechenden Feld angezeigt werden sollen: ausschließlich Zahlen, Buchstaben eines bestimmten Alphabets, Zeichen eines bestimmten Zeichensatzes oder ein Datum. Datentypen können äußerst flexibel festgelegt werden. Benutzer können in einer Liste verfügbarer Datentypen einen Datentyp auswählen sowie benutzerdefinierte Datentypen für bestimmte Tasks erstellen.

Bei der Angabe der Datentypen können Sie auch die Formatüberprüfung des Eingabewerts konfigurieren sowie Einschränkungen für den Wert festlegen, z. B. die Länge des Texts, Mindest- und Höchstwert für die Zahl, Zeitintervall und Datum.

Die möglichen Werte eines Feldes können auch von einer externen Quelle eingeschränkt werden - einer Textdatei oder einer Datenbank.

Wenn der erkannte Feldwert während der Dokumentverarbeitung nicht mit dem festgelegten Datentyp übereinstimmt, wird eine Fehlermeldung angezeigt.

Der Datentyp für ein Texteingabefeld kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Text
  1. Wenn dieses Feld Text enthalten wird, wählen Sie aus der Liste Inhalt die Option Text.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache oder die Verwendung von Wörterbüchern ändern oder einen genauer eingegrenzten Datentyp angeben möchten, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Für den Standardtexttyp (d. h., wenn die Option Allgemein in der Liste Inhaltseinstellungen ausgewählt ist) können Sie ein integriertes Wörterbuch und/oder ein benutzerdefiniertes Wörterbuch verwenden. In diesem Fall wird der Wert des Felds mithilfe dieser Wörterbücher überprüft.
      Wenn Sie ein integriertes Wörterbuch verwenden möchten, wählen Sie die Option Integriertes Wörterbuch verwenden.
      Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden... und geben Sie den Pfad zur gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Texttyp für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Zahl
  1. Wenn dieses Feld einen Zahlenwert enthalten wird, wählen Sie aus der Liste Inhalt die Option Zahl.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern oder eine Ganzzahl zu einem Bruch ändern möchten oder umgekehrt oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. eine nur zweistellige Zahl oder eine römische Zahl), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie Ganzzahl, wenn das Feld eine Ganzzahl enthalten muss. Deaktivieren Sie diese Option, wenn das Feld einen Bruch enthalten muss.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für eine Ganzzahl oder einen Bruch wählen.
    • Der Typ für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich von Zahlen.
Wichtig! Verwenden Sie den Datentyp Zahl nicht für Felder mit Zahlen, bei denen es sich zwar formal um Zahlen handelt, die aber eigentlich als Codes verwendet werden (z. B. Kartennummern, Reisepassnummern usw.). Die Auswahl des Datentyps Zahl für diese Felder hat möglicherweise Fehler zur Folge (z. B. werden die Nullen am Anfang der Zeichenfolge entfernt). Erstellen Sie in solchen Fällen stattdessen einen benutzerdefinierten Texttyp, und legen Sie ein Alphabet von 0-9 fest (und fügen Sie ggf. einen regulären Ausdruck hinzu). Oder Sie verwenden trotzdem den Datentyp Zahl, stellen aber sicher, dass die Option Wert als Text verarbeiten aktiviert ist. Im letztgenannten Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur Überprüfung des Werts verwendet und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Datum
  1. Wenn dieses Feld ein Datum enthalten wird, wählen Sie aus der Liste Inhalt die Option Datum .
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache oder die Reihenfolge der Datumskomponenten ändern, die Uhrzeit oder Wochentage hinzufügen oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. dass Monate als römische Zahlen dargestellt werden), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie die gewünschte Reihenfolge aus der Liste Anordnung der Datumskomponenten aus.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für Datumsangaben in Standardformaten wählen. Für den Standarddatentyp stehen folgende zusätzliche Optionen zur Verfügung:
      Kann Monate in Worten enthalten – Verwenden Sie diese Option, wenn die Monate auch in Worten geschrieben sein können, nicht nur in Zahlen;
      Kann Wochentag enthalten – Verwenden Sie diese Option, wenn Datumsangaben auch Wochentage enthalten können;
      Kann Zeit enthalten – Verwenden Sie diese Option, wenn Datumsangaben auch die Uhrzeit enthalten können.
    • Der Datumstyp für Sonderformate (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich von Datumsangaben.
Wichtig! Wenn das Datum nicht auf ein Standardformat reduziert werden kann oder Sie die Werte dieses Felds nicht als Datumsangaben verarbeiten werden, dann wählen Sie die Option Wert als Text verarbeiten. Im diesem Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur Überprüfung des Werts verwendet und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Geldbetrag
  1. Wenn dieses Feld einen Geldbetrag enthalten wird, wählen Sie aus der Liste Inhalt die Option Geldbetrag.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. einen Währungscode), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Wählen Sie den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den Geldbetrag, wenn der Wert des Felds nur eine Zahl oder eine Zahl mit einem Standardwährungssymbol oder -code ist.
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Wichtig! Wenn der Geldbetrag nicht auf ein Standardformat reduziert werden kann oder Sie die Werte dieses Felds nicht als Geldbeträge verarbeiten werden, dann wählen Sie die Option Wert als Text verarbeiten. Im diesem Fall wird der Wert des Felds als Text verarbeitet, sodass ein benutzerdefiniertes Wörterbuch zur Überprüfung des Werts verwendet und der Bereich der möglichen Werte wie bei einem Textwert festgelegt werden kann. Einzelheiten finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Adresse
  1. Wenn dieses Feld eine Adresse enthalten wird, wählen Sie aus der Liste Inhalt die Option Adresse.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. E-Mail-Adresse oder Postleitzahl), dann klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für die Adresse wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden... und geben Sie den Pfad zur gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Name
  1. Wenn dieses Feld einen Namen enthalten wird, wählen Sie aus der Liste Inhalt die Option Name.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. Nachname oder Vorname), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den Namen wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden... und geben Sie den Pfad zur gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".
Code
  1. Wenn dieses Feld einen Code aus Buchstaben und Ziffern enthalten wird, wählen Sie aus der Liste Inhalt die Option Code.
    Im Feld Details wird eine Beschreibung des ausgewählten Datentyps angezeigt. Wenn Sie die Sprache ändern, ein benutzerdefiniertes Wörterbuch oder einen genauer eingegrenzten Datentyp angeben möchten (z. B. eine Sozialversicherungsnummer), klicken Sie auf die Schaltfläche Bearbeiten… rechts neben der Beschreibung. Im daraufhin angezeigten Dialogfeld stehen Ihnen folgende Möglichkeiten zur Verfügung:
    • Änderung der Erkennungssprache für dieses Feld. Klicken Sie zum Ändern der Sprache auf die Schaltfläche "..." rechts neben dem Feld Sprache. Sie können eine oder mehrere Sprachen auswählen.
    • Sie können den Standarddatentyp (d. h. die Option Allgemein in der Liste Inhaltseinstellungen) für den alphanumerischen Code wählen. Die Verwendung eines benutzerdefinierten Wörterbuchs ist in diesem Fall empfehlenswert. Wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, wählen Sie die Option Benutzerdefiniertes Wörterbuch verwenden, und klicken Sie auf Bearbeiten…, um das Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden... und geben Sie den Pfad zur gewünschten Datei mit der Endung *.txt oder *.dic an).
    • Der Sonderformattyp (d. h., wenn die Option Sonderformat in der Liste Inhaltseinstellungen ausgewählt ist) enthält vordefinierte Datentypen, aus denen Sie für das entsprechende Feld den passenden Datentyp auswählen können. Beachten Sie bei der Auswahl eines Datentyps dessen Beschreibung, die im unteren Bereich des Dialogfelds
      angezeigt wird. Sie können auch eigene benutzerdefinierte Datentypen erstellen, wenn keiner der vordefinierten Typen für Ihre Zwecke infrage kommt. Weitere Informationen finden Sie unter Erstellen benutzerdefinierter Datentypen.
  2. Für jeden Datentyp kann das Programm die eingegebenen Werte automatisch verarbeiten und dabei folgende Schritte ausführen: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben und automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung der Werte auf die Schaltfläche Bearbeiten… neben dem Feld Autokorrektur-Optionen. Wählen Sie im daraufhin angezeigten Dialogfeld die erforderlichen Parameter für die automatische Verarbeitung aus. Nähere Informationen hierzu finden Sie unter Verarbeiten eingegebener Werte.
  3. Sie können für das Feld auch die Validierung der Werte einrichten, sodass das Programm prüft, ob die eingegebenen Werte innerhalb des von Ihnen festgelegten Bereichs liegen. Klicken Sie zum Festlegen eines Wertebereichs für das Feld auf die Schaltfläche Bearbeiten… rechts neben dem Feld Validierung. Einzelheiten hierzu finden Sie unter Einschränkungen für den Wertebereich des Datentyps "Text".


Erstellen benutzerdefinierter Datentypen

Wählen Sie zum Erstellen eines neuen Datentyps in den Feldeigenschaften auf der Registerkarte Datentyp das gewünschte Element aus der Liste Inhalt. Sie können jedes Element aus der Liste wählen, das der Semantik Ihres benutzerdefinierten Datentyps entspricht. Das hat zwar keinen Einfluss auf die Art des neuen Datentyps, aber er wird in der ausgewählten Kategorie gespeichert.

Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details.

Wählen Sie in dem daraufhin angezeigten Dialogfeld die Option Sonderformat im Feld Inhaltseinstellungen.

Klicken Sie auf die Schaltfläche Neu… rechts neben dem Feld Datentypen für ausgewählte Sprache.

Befolgen Sie die Anweisungen im Assistenten für neue Datentypen.

Im ersten Fenster des Assistenten wählen Sie aus, wie Ihre Daten erstellt werden sollen. Sie können einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks, eines Alphabets oder eines vorhandenen Datentyps erstellen (z. B., indem Sie gewünschte Zeichen zu seinem Alphabet hinzufügen oder sein Wörterbuch erweitern).

So erstellen Sie einen neuen Datentyp auf der Grundlage eines Wörterbuchs, eines regulären Ausdrucks oder eines Alphabets:

  1. Wählen Sie Neuer Datentyp beruht auf und dann die Grundlage, die für Ihren neuen Datentyp verwendet werden soll: ein Wörterbuch, ein regulärer Ausdruck oder ein Alphabet. Wählen Sie dann die Sprache (Gebietsschema) für Ihren Datentyp, und klicken Sie auf Weiter.
  2. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Wörterbuchs zu erstellen, dann fordert Sie der Assistent im nächsten Fenster dazu auf, die Art des Wörterbuchs auszuwählen, das verwendet werden soll.
    Wählen Sie Integriertes Wörterbuch verwenden, wenn Sie das integrierte Wörterbuch für die Sprache verwenden möchten, die Sie im Fenster zuvor ausgewählt haben. Wenn Sie prüfen möchten, ob das Wörterbuch ein bestimmtes Wort enthält, dann klicken Sie auf Anzeigen…, und geben Sie das Wort ein. Durch Klicken auf die Schaltfläche Anzeigen werden entweder die gebeugten Formen des Worts angezeigt oder eine Warnmeldung, die besagt, dass es dieses Wort im Wörterbuch nicht gibt.
    Wählen Sie Benutzerdefinierte Wörterbücher verwenden, wenn Sie ein benutzerdefiniertes Wörterbuch verwenden möchten, und klicken Sie auf Bearbeiten…, um das entsprechende Wörterbuch zu bearbeiten. Sie können ein benutzerdefiniertes Wörterbuch erstellen, indem Sie entweder Wort für Wort hinzufügen (klicken Sie auf die Schaltfläche Hinzufügen..., um ein Wort hinzuzufügen) oder indem Sie eine Liste mit Wörtern aus einer Datei laden (klicken Sie auf die Schaltfläche Laden..., und geben Sie den Pfad zu der gewünschten Datei mit der Endung *.txt oder *.dic an). Klicken Sie auf Weiter.
  3. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines regulären Ausdrucks zu erstellen, wird der Assistent Sie dazu auffordern, einen regulären Ausdruck einzugeben. Verwenden Sie die Schaltfläche [image] rechts neben dem Feld für den regulären Ausdruck, um Ihren regulären Ausdruck zusammenzusetzen. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken. Klicken Sie auf Weiter.
  4. Wenn Sie sich dafür entscheiden, einen neuen Datentyp auf der Grundlage eines Alphabets zu erstellen, oder wenn Sie in Ihrem regulären Ausdruck Zeichen verwendet haben, die nicht Teil des Alphabets der gewählten Sprache sind, dann werden Sie vom Assistenten aufgefordert, ein Alphabet für Ihren Datentyp anzugeben. Sie können die gewünschten Zeichen entweder direkt über die Tastatur eingeben oder auf Anpassen… klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Wenn Sie Satzzeichen und ausgeschlossene (unzulässige) Zeichen einfügen möchten, klicken Sie auf Erweiterte Parameter…. Sie können die unzulässigen Zeichen entweder direkt über die Tastatur eingeben oder auf die Schaltfläche auf der rechten Seite klicken und dann die gewünschten Zeichen mithilfe der Maus auswählen.

    Klicken Sie auf Weiter.

  5. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

So erstellen Sie einen neuen Datentyp auf der Grundlage eines vorhandenen Datentyps:

  1. Wählen Sie im ersten Fenster des Assistenten für neue Datentypen Datentyp beruht auf vorhandenen Typen. Wählen Sie die gewünschte(n) Sprache(n) aus, und klicken Sie auf Weiter.
  2. Wählen Sie im nächsten Fenster den (die) Quelldatentyp(en) aus, welche(r) die Grundlage für Ihren neuen Datentyp bilden soll(en). Diejenigen Datentypen, die den ausgewählten Sprachen entsprechen, werden auf der linken Seite des Dialogfelds in der Liste Verfügbare Datentypen aufgeführt. Der Ordner Text enthält die natürlichen Sprachen, die im ersten Fenster ausgewählt wurden. Der Ordner Benutzerdefiniert enthält die Datentypen, die von Benutzern erstellt wurden. Die anderen Ordner enthalten die Datentypen entsprechend der Kategorie und den Sonderformaten für spezielle Inhalte.
    Sie wählen einen Quelldatentyp aus, indem Sie ihn im Feld Verfügbare Datentypen markieren (halten Sie die Strg-Taste gedrückt, um mehrere Typen zu markieren) und dann auf Hinzufügen -> klicken, um ihn in den rechten Bereich zu übertragen. Klicken Sie auf Weiter.
  3. Geben Sie im letzten Fenster des Assistenten einen Namen und eine Kurzbeschreibung für Ihren neuen Datentyp ein. Wenn Sie die Eigenschaften des neu erstellten Datentyps bearbeiten möchten, wählen Sie dazu die Option Eigenschaften bearbeiten. Klicken Sie auf Fertig stellen.

Der neu erstellte Datentyp wird in der Liste der vordefinierten Datentypen angezeigt, wenn Sie den Inhalt auswählen, der beim Erstellen des Datentyps gewählt wurde.

So legen Sie den neu erstellten Datentyp für Ihr Feld fest:

  1. Wählen Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp das gewünschte Element in der Liste Inhalt aus.
  2. Klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Details.
  3. Wählen Sie in der Liste Inhaltseinstellungen die Option Sonderformat.
  4. Wählen Sie in der nun angezeigten Liste den Datentyp aus, den Sie erstellt haben (benutzerdefinierte Datentypen sind mit einem speziellen Symbol gekennzeichnet), und klicken Sie auf OK.


Einschränkungen für den Wertebereich des Datentyps "Text"

Im Dialogfeld Validierungseinstellungen können Sie Einschränkungen für den Wertebereich von Text festlegen, der in diesem Feld eingegeben wird.

Hinweis:Das Programm behandelt nicht nur Datentypen mit Textinhalten als Texttyp, sondern auch alle Datentypen mit anderen Inhalten, für die die Option Wert als Text verarbeiten aktiviert wurde.

  • Maximale Länge: Geben Sie die maximale Länge für Text in diesem Feld an.
  • Wählen Sie im Feld Inhalts-Einschränkung die Option Regulärer Ausdruck aus der Liste aus, wenn ein regulärer Ausdruck zur Überprüfung der Feldwerte verwendet werden soll.

    Über die Schaltfläche [image] erhalten Sie Hilfe zur korrekten Formulierung von regulären Ausdrücken. Ausführliche Informationen finden Sie unter Alphabet in regulären Ausdrücken.

    Geben Sie im Feld Beschreibung des regulären Ausdrucks eine Beschreibung der in Fehlermeldungen verwendeten regulären Ausdrücke ein, damit Fehlermeldungen leichter verstanden werden können.

  • Wählen Sie im Feld Inhalts-Einschränkung die Option Zulässige Werte aus der Liste aus, wenn Sie eine Liste zulässiger Werte festlegen müssen. Um einen Wert hinzuzufügen, klicken Sie auf Hinzufügen… und geben den Wert ein. Wenn Sie einen Wert bearbeiten möchten, klicken Sie auf Bearbeiten…, und wenn Sie einen Wert löschen möchten, klicken Sie auf Löschen. Um mögliche Werte aus einer Datei zu laden, klicken Sie auf Laden…
  • Validierungsfehler als Warnungen behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.


Einschränkungen für den Wertebereich von Zahlen

So geben Sie Einschränkungen für den Wertebereich von Zahlen an:

  1. Aktivieren Sie die Option Einschränkungen verwenden.
  2. Geben Sie die Höchst- und Mindestwerte für die Zahlen an.
  3. Validierungsfehler als Warnungen behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.

Bei der Dokumentverarbeitung überprüft die Software, ob der eingegebene Wert im angegebenen Intervall liegt.


Einschränkungen für den Wertebereich von Datumsangaben

Im Dialogfeld Validierungseinstellungen können Sie das Intervall für das in diesem Feld eingegebene Datum festlegen.

  1. Aktivieren Sie die Option Datum muss innerhalb des folgenden Bereichs liegen.
  2. Wählen Sie Fest vorgegeben, um ein festes Zeitintervall festzulegen, oder wählen Sie In Abhängigkeit vom Überprüfungsdatum, um ein Zeitintervall einzurichten, das sich relativ zum Datum der Dokumentüberprüfung verhält.
  3. Geben Sie den Beginn und das Ende des Zeitraums ein.
  4. Validierungsfehler als Warnungen behandeln: Wählen Sie diese Option aus, wenn Sie möchten, dass Abweichungen von den von Ihnen festgelegten Einschränkungen nur als Warnungen gewertet werden sollen.


Verarbeiten der eingegebenen Werte für den Datentyp "Text"

Verarbeiten eingegebener Werte

Für jeden Datentyp können Sie festlegen, dass die eingegebenen Werte automatisch verarbeitet und dabei folgende Schritte ausgeführt werden: Entfernen von Leerzeichen, Ändern der Groß- oder Kleinschreibung von Buchstaben, automatisches Ersetzen bestimmter Zeichen oder eines bestimmten Texts. Klicken Sie zum Aktivieren der automatischen Verarbeitung von Feldwerten auf der Registerkarte Datentyp des Dialogfelds für die Feldeigenschaften auf die Schaltfläche Bearbeiten… rechts neben dem Feld Autokorrektur-Optionen.

Wählen Sie die gewünschten Optionen für die automatische Verarbeitung aus.

Wenn die Option AutoCorrect nur unmittelbar nach Erkennung anwenden ausgewählt ist, wird die automatische Verarbeitung nur einmal ausgeführt, nachdem der Feldwert erkannt worden ist. Andernfalls wird die automatische Verarbeitung jedes Mal ausgeführt, wenn der Wert des Felds geändert wird.

  • Um die Zeichen im erkannten Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Zeichen ersetzen. Im daraufhin angezeigten Dialogfeld können Sie Zeichen für die automatische Ersetzung hinzufügen. Sofern die angegebenen Zeichen in den erkannten Feldwerten auftreten, werden sie automatisch ersetzt.
  • Um den gesamten erkannten Feldwert oder einzelne Wörter im Feldwert automatisch zu ersetzen, klicken Sie auf die Schaltfläche Bearbeiten… rechts neben dem Feld Text ersetzen.

    Im angezeigten Dialogfeld können Sie Wörter und Ausdrücke für die automatische Ersetzung hinzufügen. Um nur ganze Felder zu ersetzen, wählen Sie Nach gesamtem Feldinhalt suchen.

    Wenn Sie die Option Genaue Suche aktivieren, sucht das Programm nach genau dem eingegebenen Wort oder Ausdruck und ersetzt diesen. Wenn Sie jedoch Tolerante Suche aktivieren, sucht das Programm nach einem dem eingegebenen Wort oder Ausdruck ähnelnden Wert und ersetzt diesen. Die Anzahl der zulässigen Fehler hängt von der Länge des Worts ab.

    Aktivieren Sie das Kontrollkästchen Groß-/Kleinschreibung beachten, damit bei der Ersetzung von Wörtern oder Ausdrücken die Groß- und Kleinschreibung berücksichtigt wird.

  • Wählen Sie in der Dropdownliste Groß-/Kleinschreibung ändern eines der Verfahren für die Buchstabenumwandlung aus:

    Keine Festlegung: Es erfolgt keine Umwandlung.

    GROSSSCHREIBUNG: Alle Buchstaben werden in Großschreibung geändert.

    kleinschreibung: Alle Buchstaben werden in Kleinschreibung geändert.

    Erster Buchstabe groß: Der erste Buchstabe wird in einen Großbuchstaben und die übrigen werden in Kleinbuchstaben geändert.

  • Überschüssige Leerzeichen entfernen: Aktivieren Sie diese Option, wenn überzählige Leerzeichen entfernt werden sollen.

Für automatische Ersetzungen können Sie auch ein Skript verwenden: wählen Sie die Option Skript verwenden, klicken Sie auf Bearbeiten…, um den Skripteditor zu öffnen, und geben Sie den Code des Skripts ein.


Erkennungsoptionen für Textfelder

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte werden die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Keine Erkennung (Manueller Eingabeblock – wird manuell eingegeben): Aktivieren Sie diese Option, wenn das Feld aus einem bestimmten Grund nicht erkannt wird (z. B. wenn der Text im Feld verschwommene Zeichen enthält) und der Operator den Wert manuell eingeben muss. In diesem Fall müssen Sie die anderen Erkennungseigenschaften nicht konfigurieren, da das Feld nicht erkannt wird. Der Operator wird während der Überprüfung aufgefordert, den Feldwert einzugeben.

  • ICR (Handschrift): Aktivieren Sie diese Option, wenn statischer Text in diesem Feld handschriftlich vorliegt.

  • OCR (Druck): Aktivieren Sie diese Option, wenn statischer Text in diesem Feld gedruckt ist. Wählen Sie in der Dropdownliste den Druckstil aus (Druckmaschine, Punktmatrixdrucker, Schreibmaschine usw.). Siehe auch Unterstützte Texttypen.

  • Erweitert: Über diese Option können Sie mehrere Texttypen auswählen oder einen benutzerdefinierten Texttyp angeben.

  • Markierungstyp: Wählen Sie den Markierungstyp aus. Zur Vereinfachung können Sie in der Dropdownliste Beispiele auswählen. Wenn die Markierung beim Scannen verschwindet, wird für die Markierung der gleiche Abstand zwischen den Zeichen verwendet (graue Felder). Wenn die Markierung beim Scannen nicht verschwindet und für die Leerzeichen in Zellen unterteilt wird, müssen Sie die Gesamtanzahl der Zellen eingeben. Wenn Felder mit dieser Markierung im Programm automatisch erkannt werden, wird auch die Anzahl der Zellen automatisch festgelegt.

  • Groß-/Kleinschreibung: Wählen Sie die Groß- oder Kleinschreibung der Buchstaben im Feld aus. Wenn sowohl Groß- als auch Kleinschreibung möglich ist, lassen Sie die Option Automatisch aktiviert.

  • Ausrichtung: Geben Sie die Ausrichtung des Texts an.

  • Aktivieren Sie bei einzeiligen Feldern die Option Eine Zeile.

  • Aktivieren Sie bei Feldern, die immer nur ein Wort enthalten, die Option Ein Wort.

  • Konfigurieren Sie die Bildverarbeitungsoptionen für die Erkennung:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Bei der Überprüfung handelt es sich um den Vorgang, bei dem erkannte Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur Überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur Überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur Überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, so dass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Dokumentdefinition können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene Überprüfungsoptionen festlegen.

Damit das Feld von einem Operator überprüft wird, wählen Sie Erfordert Überprüfung.

Konfigurieren Sie die Parameter für die Zeichenanzeige:

  • Wenn die Zeichen für die Überprüfung markiert werden sollen, wählen Sie Alle Zeichen hervorheben.
  • Wenn die Zeichen für die Überprüfung nicht markiert zu werden brauchen, wählen Sie Zeichen nicht hervorheben.
  • Wenn die Zeichen je nach Eindeutigkeit der Erkennung markiert werden sollen, wählen Sie Zeichen hervorheben, wenn der Zuverlässigkeitsgrad geringer ist alsund in der Dropdown-Liste die niedrigste Eindeutigkeitsstufe, die möglich ist, bevor die Zeichen markiert werden.

Gruppenüberprüfung

  • Damit die Feldzeichen zur Gruppenüberprüfung gesendet werden,wählen Sie Zeichen der Gruppenüberprüfung übergeben aus.
  • Wählen Sie die Zeichen aus, die zur Gruppenüberprüfung gesendet werden sollen: nur hervorgehobene Zeichenoder alle Zeichen.
  • Wählen Sie den Zeichensatz für die Gruppenüberprüfung aus: Nur Ziffernoder Individuell. Ändern Sie ggf. den benutzerdefinierten Zeichensatz, indem Sie auf Ändern…klicken.

Feldüberprüfung

  • Damit die Feldzeichen zur Feldüberprüfung gesendet werden, wählen Sie Der Feldüberprüfung übergeben aus.
  • Wählen Sie aus, in welchem Fall das Feld zur Feldüberprüfung gesendet werden soll: immeroder wenn das Feld hervorgehobene Zeichen oder Formatfehler enthält.


Benutzerskript

Benutzerskript (benutzerdefinierte Aktion)

Ein Benutzerskriptist eine benutzerdefinierte Skriptregel, die vom Benutzer bei der Ansicht eines Felds während der Feldüberprüfung oder im Dokumenteditor ausgelöst wird. Das Skript wird durch Klicken auf …rechts vom Feldwert ausgelöst.

Das benutzerdefinierte Skript richten Sie in der Registerkarte Benutzerdefinierte Aktionein. Um Feldinformationen im Benutzerskript zur Verfügung zu stellen oder zu löschen, verwenden Sie die Schaltflächen Hinzufügen…und Löschen. Um das Skript zu bearbeiten, rufen Sie das Fenster Skripteditorauf. Dieses wird geöffnet, wenn Sie auf Bearbeiten… klicken.

Um das Skript den Operatoren zur Verfügung zu stellen, wählen Sie Benutzerdefinierte Aktion aktivieren aus.

Weitere Informationen zu Skripten finden Sie unter Verwenden von Skripten in FlexiCapture 9.0.


Auswahlfelder

Wichtig!Die Eigenschaften von Auswahlfeldern, die in Gruppen zusammengefasst werden, werden für die gesamte Gruppe von Auswahlfeldern konfiguriert. Wenn Sie die Eigenschaften eines Auswahlfelds bearbeiten, das einer Gruppe angehört, wird ein Dialogfeld zum Bearbeiten der Eigenschaften der Gruppe geöffnet.

Wenn Sie ein Auswahlfeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
Überprüfungseigenschaften
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem treffendsten Beschreibungstext für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch Ändern des Feldnamens.
  • Überschrift: Der Name des Felds, der im Datenformular angezeigt wird.
  • Feldwert exportieren: Diese Option muss aktiviert sein, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z.B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Diese Option muss aktiviert sein, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Schreibgeschützt: Aktivieren Sie diese Option, wenn das Feld nur zur Ansicht verfügbar sein soll, d. h. der Feldwert nicht geändert werden kann. Sie können diese Option für Felder aktivieren, deren Werte mithilfe einer Regel automatisch berechnet werden, z. B. Felder, in denen eine Summe gespeichert wird oder andere Felder zusammengefasst werden (siehe Regelbasierte Validierung).
  • Kommentar: Hier können Sie Kommentare eingeben.


Datentypen für Auswahlfelder

Der Datentyp für Auswahlfelder kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Mit dem Datentyp für Auswahlfelder werden die Werte festgelegt, die dem Auswahlfeld zugewiesen werden, wenn das Auswahlkästchen aktiviert oder deaktiviert ist.

Wählen Sie die entsprechenden Optionen für die Werte des Auswahlfelds aus:

  • Ja/Nein – Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "Ja". Wenn es deaktiviert ist, lautet der Wert "Nein".
  • 1/0: Wenn das Auswahlkästchen aktiviert ist, lautet der Feldwert "1". Wenn es deaktiviert ist, lautet der Wert "0".
  • <Auswahlfeldname>/Leer: Wenn das Auswahlkästchen aktiviert ist, entspricht der Feldwert dem Namen des Auswahlfelds. Wenn das Auswahlkästchen deaktiviert ist, wird dem Feld ein leerer Wert zugewiesen.
  • Benutzerdefiniert: Durch Aktivieren dieser Option können Sie benutzerdefinierte Werte eingeben. Ausgewählt: Aktiviertes Auswahlkästchen. Nicht ausgewählt: Deaktiviertes Auswahlkästchen.


Erkennungseigenschaften für Auswahlfelder

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte werden die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Auswahlfeldtyp: Wählen Sie den Auswahlfeldtyp aus. Diese Eigenschaft ist sehr wichtig für die korrekte Erkennung von Auswahlfeldern.

    Quadrat: Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder in begrenzten quadratischen Rahmen positioniert werden.

    Ohne Rahmen: Wählen Sie diesen Auswahlfeldtyp aus, wenn die Auswahlfelder ohne Rahmen vor einem weißen Hintergrund positioniert werden.

    Automatisch: Wenn Sie diesen Typ auswählen, wird der Auswahlfeldtyp automatisch festgelegt.
    Wichtig! Beachten Sie, dass in diesem Fall das Auswahlfeld im Formular nicht ausgewählt werden muss. Das Programm erkennt, ob das Auswahlfeld ausgewählt wird oder nicht, indem es das Abbild des Auswahlfelds in einem verarbeiteten Dokument mit dem Abbild des leeren, zum Erstellen der Dokumentdefinition verwendeten Formulars vergleicht.

  • Korrekturen zulassen: Aktivieren Sie diese Option, wenn Sie Korrekturen an den Auswahlfeldern zulassen möchten. In diesem Fall werden durchgestrichene Auswahlfelder als nicht ausgewählt eingestuft. Wenn Sie jedoch den Auswahlfeldtyp Automatisch ausgewählt haben, können Sie keine Korrekturen der entsprechenden Auswahlfelder zulassen.

    • Sie können folgende Optionen für die Verarbeitung des Feldbilds festlegen:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Bei der Überprüfung handelt es sich um den Vorgang, bei dem erkannte Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur Überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur Überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur Überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, so dass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Dokumentdefinition können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene Überprüfungsoptionen festlegen.

Damit das Feld von einem Operator überprüft wird, wählen Sie Erfordert Überprüfung.

  • Damit die Zeichen des Felds zur Gruppenüberprüfung gesendet werden,wählen Sie Zeichen der Gruppenüberprüfung übergeben aus.
  • Wählen Sie die Zeichen aus, die zur Gruppenüberprüfung gesendet werden sollen: nur hervorgehobene Zeichenoder alle Zeichen.


Gruppen von Auswahlfeldern

Wichtig! Gruppeneigenschaften gelten für alle Auswahlkästchen, die einer Gruppe von Auswahlfeldern angehören.

Der Wert einer Auswahlfeldgruppe ist eine Liste mit den Namen der ausgewählten Auswahlkästchen, die durch ein Semikolon (;) getrennt sind, oder eine leere Zeichenfolge, wenn keine Auswahlkästchen ausgewählt wurden.

Wenn Sie eine Gruppe von Auswahlfeldern erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften:

Allgemeine Eigenschaften
Erkennungseigenschaften
Datentypen
Überprüfungseigenschaften
Regelbasierte Validierung


Datentypen für Gruppen von Auswahlfeldern

Der Datentyp für eine Gruppe von Auswahlfeldern kann im Dialogfeld für die Feldeigenschaften auf der Registerkarte Datentyp festgelegt werden.

Leere Auswahl zulassen: Aktivieren Sie diese Option, wenn mindestens ein Auswahlfeld in der Gruppe aktiviert sein muss. Wenn kein Auswahlfeld in der Gruppe aktiviert ist, wird eine entsprechende Warnmeldung angezeigt.

Mehrfachauswahl zulassen: Aktivieren Sie diese Option, damit mehrere Auswahlfelder in der Gruppe aktiviert werden können. Wenn die Option deaktiviert ist, wird eine Warnmeldung angezeigt, wenn mehrere Auswahlfelder in der Gruppe aktiviert wurden.

Wenn Sie den Namen eines Auswahlfelds ändern möchten, markieren Sie die entsprechende Zeile und klicken Sie auf Bearbeiten…. Geben Sie im daraufhin geöffneten Dialogfeld einen neuen Namen für das Auswahlfeld sowie einen neuen Namen ein, der dem Auswahlfeld beim Exportieren zugewiesen wird.

Sie können die zu exportierenden Werte für Fälle auswählen, in denen keine Auswahlfelder aktiviert sind, und für Fälle, in denen mehrere Auswahlfelder aktiviert sind. Wählen Sie hierzu <Es wurde kein Objekt ausgewählt.> bzw. <Mehrere Objekte…> aus der Liste, klicken Sie auf Bearbeiten…, geben Sie in dem dann angezeigten Dialogfeld den gewünschten Wert in das Feld Exportierter Wert ein. Wenn keine Exportwerte festgelegt wurden, passiert Folgendes: a) Es wird eine leere Zeichenfolge exportiert, wenn keine Auswahlfelder aktiviert wurden oder b) die Werte der aktivierten Auswahlfelder werden angegeben (getrennt durch Kommas), wenn mehrere Auswahlfelder aktiviert sind.

Erstellen einer Gruppe von Auswahlfeldern


Barcode

Wenn Sie ein Barcodefeld erstellen, werden dem Feld Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst fünf Registerkarten für verschiedene Gruppen von Eigenschaften.

Wichtig! Ein Barcode kann sowohl als Feld als auch als statisches Element hervorgehoben werden. Dies hängt jeweils vom Barcodewert in den zu verarbeitenden Dokumenten ab. Wenn der Wert zur Dokumentdefinitionszuordnung oder -identifizierung vorgesehen ist, müssen Sie ihn im Modus für statische Elemente erstellen. Wenn ein Barcode jedoch zur Datenerfassung dienen soll, müssen Sie ihn im Modus für Feldbereiche erstellen. Die Barcodeeigenschaften unterscheiden sich je nachdem, ob es sich um ein Feld oder ein statisches Element handelt. In diesem Abschnitt werden die Feldeigenschaften beschrieben. Siehe auch Ankerbarcode.

Allgemeine Eigenschaften
Erkennungseigenschaften
Überprüfungseigenschaften
Regelbasierte Validierung


Barcodeerkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt. Durch korrekt festgelegte Feldwerte wird die Erkennungsqualität erheblich verbessert sowie die Wahrscheinlichkeit von Fehlern verringert.

  • Keine Erkennung (Manueller Eingabeblock – wird manuell eingegeben): Aktivieren Sie diese Option, wenn der Barcodewert vom Operator manuell eingegeben wird. In diesem Fall müssen Sie die restlichen Erkennungseigenschaften nicht festlegen.
  • Codetyp: Geben Sie den Barcodetyp ein (wird in der Regel automatisch festgelegt).
  • Ausrichtung: Geben Sie die Ausrichtung des Barcodes an.

Sie können zudem folgende Optionen für die Verarbeitung des Barcodebilds festlegen:

  • Invertieren: Das Bild wird invertiert.
  • Textur entfernen: Die Textur wird entfernt.
  • Störungen entfernen: Aktivieren Sie diese Option, um überflüssige Elemente aus dem Bild zu entfernen.
  • Überflüssige Elemente nur in angegebener Größe löschen: Aktivieren Sie diese Option, um nur überflüssige Elemente einer bestimmten Größe zu entfernen. Geben Sie die entsprechende Größe an. Wenn diese Option deaktiviert und nur die Option Störungen entfernen aktiviert ist, wird die Größe der überflüssigen Elemente automatisch ausgewählt.


Feldüberprüfungseigenschaften

Die Überprüfung ist der Vorgang, bei dem die erkannten Daten vom Operator geprüft werden. Nicht eindeutig erkannte Zeichen werden gekennzeichnet und zur Überprüfung an den Operator gesendet. Sie können jedoch die Feldeigenschaften so konfigurieren, dass auch ein Feld ohne nicht eindeutig erkannte Zeichen zur Überprüfung weitergeleitet wird. Umgekehrt können Sie festlegen, dass ein Feld nicht zur Überprüfung gesendet wird, selbst wenn es nicht eindeutig erkannte Zeichen enthält. Dem Operator wird sowohl das erkannte Zeichen als auch das zugehörige Bild angezeigt, so dass er das Erkennungsergebnis bestätigen oder korrigieren kann.

Beim Erstellen einer Dokumentdefinition können Sie im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung verschiedene Überprüfungsoptionen festlegen.

Damit das Feld von einem Operator überprüft wird, wählen Sie Erfordert Überprüfung.

  • Damit die Feldzeichen zur Feldüberprüfung gesendet werden, wählen Sie Der Feldüberprüfung übergeben aus.
  • Wählen Sie aus, in welchem Fall das Feld zur Feldüberprüfung gesendet werden soll: immeroder wenn das Feld hervorgehobene Zeichen oder Formatfehler enthält.


Bilder

Bei der Erstellung werden einem Bild Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst vier Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Erkennungseigenschaften
Exportieren von Bildern
Regelbasierte Validierung


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem treffendsten Beschreibungstext für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch Ändern des Feldnamens.
  • Überschrift: Der Name des Felds, der im Datenformular angezeigt wird.
  • Feldwert exportieren: Aktivieren Sie diese Option, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z.B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Aktivieren Sie diese Option, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Kommentar: Hier können Sie Kommentare eingeben.


Bilderkennungseigenschaften

Erkennungseigenschaften werden auf der Registerkarte Erkennung des Dialogfelds für die Feldeigenschaften (Eigenschaften… im Kontextmenü des entsprechenden Felds) festgelegt.

  • Von Erkennung ausschließen: Aktivieren Sie diese Option, wenn der Bereich eines Bildfelds von den Erkennungsbereichen der anderen Felder ausgeschlossen werden soll. (Diese Option ist nur bei Bildfeldern verfügbar, um die Kompatibilität mit Vorlagen von FormReader 6.5 sicherzustellen.)


Exportieren von Bildern

In einer Dokumentdefinition können Sie für jedes Bild die Exporteinstellungen auswählen. Klicken Sie zum Auswählen der Exporteinstellungen für Bilder mit der rechten Maustaste in das gewünschte Feld, wählen Sie Eigenschaften… und klicken Sie auf die Registerkarte Exportieren. Folgende Optionen stehen zur Auswahl:

  • Dateityp: (TIFF, JPEG, BMP, JPEG2000, PCX Packbits, PNG).
  • Qualität: Für TIFF-, JPEG-, und JPEG2000-Dateien können Sie die Qualität der erzeugten Datei auswählen: von "Beste" bis "Gering".
  • Farbtyp: Farbe, Graustufen, Raster (Schwarz-Weiß).

Sie können auch die Auflösung des resultierenden Bildes ändern: Aktivieren Sie die Option Auflösung ändern in und geben Sie entweder die gewünschte Auflösung ein oder wählen Sie eine in der Liste aus.


Tabellen

Wenn Sie eine Tabelle erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Gruppen von Eigenschaften.

Allgemeine Eigenschaften
Spalten
Regelbasierte Validierung


Tabellenspalten

Auf der Registerkarte Spalten sind die Spalten der entsprechenden Tabelle aufgeführt. Jede Tabellenspalte ist einem bestimmten Feldtyp zugewiesen (siehe Erstellen einer Tabelle) und verfügt über für diesen Feldtyp spezifische Eigenschaften.

So bearbeiten Sie die Eigenschaften einer Tabellenspalte:

  1. Wählen Sie die entsprechende Spalte in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….


Feldgruppe

Wenn Sie eine Feldgruppe erstellen, werden ihr Standardeigenschaften zugewiesen. Sie können die Eigenschaften ändern, indem Sie im Kontextmenü die Option Eigenschaften… auswählen. Das Dialogfeld zum Ändern der Eigenschaften umfasst drei Registerkarten für verschiedene Eigenschaftsgruppen.

Allgemeine Eigenschaften
Felder
Regelbasierte Validierung


Gruppenfelder

Auf der Registerkarte Felder wird eine Liste der Felder der entsprechenden Gruppe angezeigt.

So bearbeiten Sie die Eigenschaften eines dieser Felder:

  1. Wählen Sie den Namen des entsprechenden Felds in der Liste aus.
  2. Klicken Sie auf die Schaltfläche Eigenschaften….

Erstellen einer Feldgruppe


Dienstfeld

Wenn ein Dienstfeld erstellt wird, verfügt es über die Standardeigenschaften, die durch Klicken auf Eigenschaften…im Kontextmenü konfiguriert werden können. Das Eigenschaftsdialogfeld hat zwei Registerkarten, eine für jede Gruppe von Eigenschaften.

Eigenschaften des Basisfelds
Eigenschaften der Datenquelle


Eigenschaften der Datenquelle

In der Registerkarte Datenquellewerden die Quelle und der Datentyp des Dienstfelds angegeben:

  1. Wählen Sie in der Liste Quelleeine Datenquelle für das Feld aus.
  2. Wenn Sie Dokument-Registrierungsparameteroder Stapel-Registrierungsparameter auswählen, geben Sie im Feld Parameternameden Namen der Registrierungseigenschaft an, die als Datenquelle verwendet werden soll.
  3. Wählen Sie unter Datentyp den gewünschten Datentyp für das Dienstfeld aus.


Regelbasierte Validierung

Regeln erweitern die Möglichkeiten der automatischen Ergebnisüberprüfung. Mit Regeln können Einschränkungen für Daten festgelegt werden, z. B. Bedingungen, die Werte in bestimmten Feldern erfüllen müssen.

Wenn die Werte in Dokumenten die jeweiligen Bedingungen nicht erfüllen, werden die entsprechenden Seiten durch eine Warnung gekennzeichnet. Regeln werden hauptsächlich zur Überprüfung der Datenintegrität in Dokumenten eingesetzt.

Sie können zudem eingegebene Werte mithilfe von Regeln verarbeiten, z. B. Werte mehrerer Felder zusammenführen oder erkannte Werte durch entsprechende Werte aus der Datenbank ersetzen.

Mithilfe von ABBYY FlexiCapture 9.0 können Sie folgende Regeltypen erstellen:

  • Summenüberprüfung: Überprüfen der Summe mehrerer Felder. Die Summe der Werte bestimmter Felder wird mit einer festgelegten Zahl oder dem Wert in einem anderen Feld verglichen.
  • Felder vergleichen: Vergleichen der Werte mehrerer Felder.
  • Datenbanküberprüfung: Überprüfen eingegebener Werte durch den Vergleich mit Werten aus einer bestimmten Datenbank.
  • Felder verbinden: Zusammenführen der Werte mehrerer Felder. Beim Verbinden von Feldern können beliebige Trennzeichen hinzugefügt werden.
  • Skript: Der Benutzer kann Einschränkungen mithilfe eines Skripts festlegen.
  • Summe in Zahlen und Summe in Worten (Russisch): Vergleicht eine Zahlensumme mit der Summe der geschriebenen Wörter (nur für die russische Sprache).

Regeln kann ein Fehler- oder Warnstatus zugewiesen werden. Wenn eine Bedingung nicht erfüllt wird, wird das entsprechende Feld durch eine rote Markierung (Fehler) oder eine gelbe Markierung (Warnung) gekennzeichnet. Siehe Regelbasierte Validierung.

Regeln können auf der Registerkarte Regeln des Dialogfelds für die Objekteigenschaften (Feld, Bereich, Dokument usw.) definiert werden.

In der hierarchischen Struktur werden Regeln auf der Ebene des Objekts gespeichert, in dem sie erstellt wurden. Dabei kann es sich um ein Feld, einen Dokumentdefinitionsbereich oder eine Dokumentdefinition handeln. In den meisten Fällen spielt die Ebene, in der Regeln gespeichert sind, keine Rolle. Wenn Sie jedoch eine Dokumentdefinition mit komplexer Struktur, mit Feldgruppen oder wiederholt vorkommenden Elementen erstellen, müssen Sie auf den Speicherort der Regeln achten. Wenn Sie beispielsweise bei einer Vorlage mit einer Feldgruppe, bei der bestimmte Felder mit einer Regel verknüpft sind, eine neue Instanz der Gruppe erstellen, wird die Regel im neuen Objekt nur kopiert und erfüllt, wenn sie in der Gruppe oder einem der zugehörigen Felder und nicht auf einer höheren Ebene gespeichert ist. Im Dialogfeld für die Objekteigenschaften können Sie Regeln anzeigen, die mit dem entsprechenden Objekt verwendet werden oder in diesem Objekt und den untergeordneten Objekten gespeichert sind. Sie können die Regeln angeben, die angezeigt werden sollen, indem Sie in der Dropdownliste Anzeigen in Liste eine der folgenden Optionen auswählen:

  • Regeln zur Verarbeitung des Objekts: Die für das aktuelle Objekt geltenden Regeln werden angezeigt (d. h. das Objekt, dessen Eigenschaftsdialogfeld geöffnet ist).
  • Gespeicherte Regeln im Objekt: Die im aktuellen Objekt gespeicherten Regeln werden angezeigt.
  • Gespeicherte Regeln im Objekt und den zugehörigen untergeordneten Objekten: Die im aktuellen Objekt und den zugehörigen untergeordneten Objekten gespeicherten Regeln werden angezeigt (dies sind bei einer Feldgruppe die in der Gruppe und allen zugehörigen Feldern gespeicherten Regeln).

Hinweis: Neue Regeln können nur im Anzeigemodus Gespeicherte Regeln im Objekt oder Gespeicherte Regeln im Objekt und den zugehörigen untergeordneten Objekten erstellt werden. Im Anzeigemodus Regeln zur Verarbeitung des Objekts kann hingegen keine neue Regel erstellt werden.

Jede Regel verfügt über einen Fehler- oder Warnstatus. Wenn Sie Dokumente mit Regelfehlern exportieren, wird eine Fehlermeldung angezeigt. Regelwarnungen haben keine Auswirkungen auf den Exportvorgang.

Summenüberprüfung
Felder vergleichen
Datenbanküberprüfung
Felder verbinden
Summe in Zahlen und Summe in Wörtern

Festlegen einer Regel mithilfe eines Skripts


Regel zum Überprüfen von Wertsummen

Mit dieser Regel wird die Summe der Werte mehrerer Felder überprüft. Die Summe der Werte bestimmter Felder wird mit einer festgelegten Zahl oder dem Wert in einem anderen Feld verglichen. Wenn ein Dokument beispielsweise Felder für Gehalt, Zulage und andere Ausgleichszahlungen sowie ein Feld für die Gesamtsumme enthält, können Sie eine Regel definieren, mit der überprüft wird, ob die Summe der Feldwerte mit der Gesamtsumme im Ergebnisfeld übereinstimmt. Wenn dies nicht der Fall ist, wird eine Fehlermeldung angezeigt.

So erstellen Sie eine Regel für die Summenüberprüfung:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summenüberprüfung aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Fügen Sie in der Liste Feldwerte zusammenfassen die Felder ein, für die die Summe der entsprechenden Werte überprüft werden soll. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein.
  7. Aktivieren Sie eine der folgenden Optionen:
    • Feld: Vergleich der Summe mit dem Wert des Ergebnisfelds. Wählen Sie den Namen des Felds über die Schaltfläche Auswählen… aus.
    • Nummer: Vergleich der Summe mit der angegebenen Zahl. Geben Sie die entsprechende Zahl ein.
  8. Dezimalwert der Vergleichswerte: Geben Sie die Anzahl der Nachkommastellen der Zahl ein, um die Vergleichsgenauigkeit festzulegen.
  9. Aktivieren Sie die Option Mindestens zwei zu addierende Elemente ungleich Null, wenn mindestens zwei nicht leere Elemente addiert werden sollen.
  10. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel zum Vergleichen mehrerer Feldwerte

Diese Regel dient zur Überprüfung von Werten mehrerer Felder. Mithilfe der Regel kann ein Dokument mit mehreren Feldern überprüft werden, deren Werte identisch sein müssen. Wenn die Werte nicht übereinstimmen, wird für das Dokument eine Regelfehlermeldung angezeigt.

So erstellen Sie eine Regel zum Vergleichen von Werten:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder vergleichen aus und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Fügen Sie in der Liste Zu vergleichende Felder die Felder ein, deren Werte verglichen werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein.
  7. Wählen Sie den Übereinstimmungstyp aus:
    • Genau: Exakte Übereinstimmung der Werte;
    • Annähernd: Annähernde Übereinstimmung der Werte. In diesem Fall werden die Felder verglichen, ohne dass die Groß- und Kleinschreibung oder Leerzeichen berücksichtigt werden. Für Feldwerte mit mehr als vier Zeichen ist ein Fehler zulässig.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel für die Datenbanküberprüfung

Bei der Datenbanküberprüfung von Feldwerten werden die erkannten Feldwerte mit Werten in der Datenbanktabelle verglichen. Die Überprüfung gilt als erfolgreich, wenn zwei Werte übereinstimmen. Bei einer Nichtübereinstimmung wird eine Regelfehlermeldung angezeigt.

So erstellen Sie eine Regel für die Datenbanküberprüfung:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Datenbanküberprüfung aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Stellen Sie eine Verbindung mit einer Datenbank her. Die entsprechenden Einstellungen können im Dialogfeld Eigenschaften von Datenverbindung festgelegt werden. Dieses Dialogfeld wird durch Klicken auf die Schaltfläche Festlegen… geöffnet.
  7. Wählen Sie in der Liste ein Datenbankschema und eine Datenbanktabelle aus.
  8. Ordnen Sie die Felder in der Dokumentdefinition den Feldern in der Datenbanktabelle zu. Klicken Sie dazu auf die Schaltfläche Hinzufügen…. Das Dialogfeld Feldverknüpfung wird geöffnet. Wählen Sie in der Liste ein Feld in der Dokumentdefinition und das entsprechende Feld in der Datenbanktabelle aus. Wählen Sie den Übereinstimmungstyp aus:
    • Genau: Die Feldwerte müssen genau übereinstimmen.
    • Annähernd: Die Feldwerte müssen teilweise übereinstimmen. Hier wird nach ähnlichen Wörtern gesucht, bei denen im Verhältnis zum gesuchten Begriff die wenigsten Buchstaben hinzugefügt, entfernt oder ersetzt werden müssen. Die Anzahl der zulässigen Fehler hängt von der Länge des gesuchten Begriffs ab. Aktivieren Sie die Option Feldwert aus Datenbank kopieren, wenn der Feldwert im Dokument durch den entsprechenden Wert aus der Datenbank ersetzt werden soll.
    • Nicht vergleichen: Die Werte werden nicht verglichen. Der Feldwert wird durch einen Wert aus der Datenbank ersetzt (Option Feldwert aus Datenbank kopieren ist aktiviert).
  9. Über die Schaltflächen Hinzufügen…, Bearbeiten… und Löschen können die Verknüpfungen von Feldern hinzugefügt, bearbeitet oder entfernt werden.


Regel zum Verbinden von Feldwerten

Diese Regel dient zum Verbinden von Werten mehrerer Felder. Verbundene Feldwerte können durch einen Punkt, ein Leerzeichen oder andere Trennzeichen getrennt werden.

So erstellen Sie eine Regel zum Verbinden von Werten:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Felder verbinden aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein, und wählen Sie den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter. Für diese Regel wird eine Fehlermeldung angezeigt, wenn beispielsweise eines der Felder aus der Dokumentdefinition entfernt wurde.
  6. Fügen Sie in der Liste Zu verbindende Felder die Felder ein, die verbunden werden sollen. Fügen Sie die Felder über die Schaltfläche Hinzufügen… ein. Wählen Sie Ergebnisfeld aus, d. h. ein Feld, in dem das Ergebnis der verbundenen Feldwerte angezeigt wird. Geben Sie im Fenster Trennzeichen das gewünschte Trennzeichen ein.
  7. Trennzeichen werden automatisch zwischen nicht leeren Werten eingefügt. Wenn Trennzeichen immer, d. h. auch bei leeren Feldwerten, eingefügt werden sollen, aktivieren Sie die Option Trennzeichen für leere Feldwerte einsetzen.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.

Das Ergebnis kann in jeder beliebigen Dokumentdefinition gespeichert werden. Es empfiehlt sich die Verwendung von Feldern ohne Bereich.

Wenn Sie nur den Wert des Ergebnisfelds und nicht die Werte der verbundenen Felder exportieren möchten, deaktivieren Sie die Option Feldwert exportieren der entsprechenden Felder.


Festlegen einer Regel mithilfe eines Skripts

Mithilfe von ABBYY FlexiCapture 9.0 können Sie eine Regel zum Überprüfen von Daten mithilfe eines Skripts konfigurieren.

So erstellen Sie diese Regel:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Eigenschaften von Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Skript aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein und wählen den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. In der Liste Verfügbare Felder sind die verfügbaren Objekte aufgeführt. Über die Schaltfläche Hinzufügen… oder Löschen können Sie Felder hinzufügen bzw. löschen. Die Werte der Felder, bei denen die Option Schreibgeschützt aktiviert ist, können nur gelesen werden, während die Werte der Felder, bei denen diese Option deaktiviert ist, mithilfe eines Skripts überschrieben werden können.
  7. Durch Klicken auf Bearbeiten… können Sie ein spezielles Fenster zur Skriptbearbeitung öffnen.
  8. Wählen Sie die Skriptsprache aus und geben den Skripttext ein.
  9. Das Skript kann durch Auswahl von Extras>Skript überprüfen aus dem Hauptmenü überprüft werden.
  10. Speichern Sie das Skript durch Auswahl von Datei>Speichern.
  11. Klicken Sie auf Fertigstellen. Die erstellte Regel wird in der Liste auf der Registerkarte Regeln angezeigt.

Hinweis:Prozeduren, die in mehr als einer Regel verwendet werden sollen, sollten in das Modul für globale Regeln geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste des Skripteditors die Option Regel für globales Skriptmodul. Sie können auch über den Dokumentdefinitionseditor auf das Modul für globale Regeln zugreifen (Dokumentdefinition>Skriptmodule>Regelskript…

Weitere Informationen zum Erstellen von Regeln mithilfe eines Skripts finden Sie unter Verwenden von Skripten in FlexiCapture 9.0


Summe in Zahlen und Summe in Wörtern

Wichtig! Diese Regel kann nur eingerichtet werden, wenn Sie für Ihre Dokumentdefinition die Erkennungssprache Russisch wählen (Dokumentdefinition>Eigenschaften der Dokumentdefinition…).

Der Zweck dieser Regel ist es, eine Zahlensumme mit der entsprechenden Summe von in Russisch geschriebenen Wörtern zu vergleichen. Wenn diese beiden Summen nicht identisch sind, dann wird die Meldung angezeigt, dass die Regel einen Fehler zurückgegeben hat.

So erstellen Sie die Regel „Summe in Zahlen und Summe in Wörtern“:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Option Eigenschaften… im Kontextmenü) oder das Dialogfeld Dokumentdefinition (Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf die Schaltfläche Neue Regel….
  4. Wählen Sie in der Liste der Regeltypen die Option Summe in Zahlen und Summe in Worten (Russisch) aus, und klicken Sie auf OK.
  5. Geben Sie einen Namen für die Regel ein und wählen den Regeltyp aus: Warnung oder Fehler, und klicken Sie auf Weiter.
  6. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Zahlen, und wählen Sie dann das Feld der Dokumentdefinition aus, das die Summe in Zahlen enthält.
  7. Klicken Sie auf die Schaltfläche Auswählen… auf der rechten Seite des Felds Summe in Wörtern, und wählen Sie dann das Feld der Dokumentdefinition aus, das dieselbe Summe in Wörtern enthält.
  8. Klicken Sie auf Fertig stellen, um die Erstellung der Regel abzuschließen. Der Name der Regel wird auf der Registerkarte Regeln angezeigt.


Regel für die Berechnung der Wertesumme

Diese Regel dient dazu, die Summe aus mehreren Feldwerten zu berechnen und in ein festgelegtes Feld einzugeben. Wenn das Dokument beispielsweise Felder mit Gehalt, Bonus und anderen Zahlungen enthält, können Sie eine Regel aufstellen, die deren Summe berechnet und die Ergebnisse in ein vorgegebenes Feld einträgt.

So erstellen Sie eine Regel für die Summenberechnung:

  1. Öffnen Sie das Dialogfeld für die Feldeigenschaften (Eigenschaften… im Kontextmenü) oder das Dialogfeld für die Dokumentdefinitionseigenschaften ( Dokumentdefinition>Eigenschaften der Dokumentdefinition… im Menü Dokumentdefinitionseditor).
  2. Klicken Sie auf die Registerkarte Regeln.
  3. Klicken Sie auf Neue Regel….
  4. Wählen Sie in der Liste der Regeln Summe berechnenund klicken Sie auf ??.
  5. Geben Sie den Namen der Regel ein und wählen Sie den Regeltyp aus: Warnungoder Fehler. Klicken Sie dann auf Weiter.
  6. Geben Sie in die Liste Feldwerte summierendie Felder ein, deren Werte summiert werden sollen. Klicken Sie dazu auf Hinzufügen….
  7. Geben Sie im Feld Ergebnisfelddas Feld ein, in das die Summe eingegeben werden soll. Klicken Sie hierfür auf Auswählen….
  8. Wählen Sie Mindestens zwei zu addierende Elemente ungleich Null, wenn mindestens zwei Werte ungleich Null vorhanden sein müssen.
  9. Klicken Sie aufFertigstellen, um die Erstellung der Regel zu beenden. Der Name der Regel wird in der Registerkarte Regeln angezeigt.


Konfigurieren des Datenexports

Um zu bestimmen, wie die beim Verarbeiten von Papierdokumenten erhaltenen Daten gespeichert werden, müssen Sie den Export für jede Dokumentdefinition einrichten. Vier Exporttypen sind möglich: Export in eine Datei, Export in eine Datenbank, Export in eine Microsoft SharePoint-Bibliothek oder Skriptexport. Der von Ihnen ausgewählte Exporttyp legt fest, welche Exporteinstellungen zur Verfügung stehen. Sie können für eine Dokumentdefinition mehr als einen Exporttyp festlegen.

Bestimmen Sie für jeden Exporttyp, welche Dokumente exportiert werden sollen: Dokumente mit Fehlern und/oder Dokumente ohne Fehler.

Bestimmen Sie für jeden Exporttyp, ob er obligatorisch ist oder nicht. Wenn ein Exporttyp obligatorisch ist, wird beim Fehlschlagen dieses Fehlertyps ein Fehler zurückgegeben. Wenn ein Exporttyp optional ist, führt ein Fehlschlagen nicht zu einem Fehler.

Während des Bildexports können Sie die Bilder von spezifischen Feldern ausblenden (und auf diese Weise vertrauliche Informationen und andere sensible Daten entfernen). Die Liste der Felder wird unabhängig von den einzelnen Exporttypen definiert. Auf diese Weise lässt sich der Zugang der Mitarbeiter auf bestimmte Daten steuern. Um Felder auszublenden, wählen Sie beim Konfigurieren des Bildexports die Option Vertrauliche Daten aus Bildern entfernen, klicken dann auf Zu schwärzende Felder auswählen…und geben im Dialogfeld Zu schwärzende Felder auswählendie Liste der Felder an, deren Bilder Sie ausblenden möchten.

Der automatische Export wird auf der Registerkarte Exportieren im Dialogfeld Eigenschaften der Dokumentdefinition eingerichtet. Wählen SieAuto-Export aktivieren, um einen automatischen Export von Dokumenten zu ermöglichen.

Zum Einrichten des Exports wählen Sie im Fenster des Dokumentdefinitionseditors Dokumentdefinition > Exporteinstellungen… aus und legen dann im Dialogfeld Exporteinstellungen die entsprechenden Optionen fest.

Export in eine Datei
Bildexport in eine Datei
In Datenbank exportieren
Nach SharePoint exportieren
Export mithilfe eines Skripts


Datenexport in eine Datei

So konfigurieren Sie den Export in eine Datei:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoptionen Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Feld Typ die Option Exportieren in Datendateien.
  3. Bestimmen Sie, ob der Export obligatorisch ist.
  4. Bestimmen Sie, ob Bilder exportiert werden sollen.
  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Legen Sie die Exportparameter fest und klicken Sie auf Weiter>. Die änderbaren Exportparameter richten sich nach dem im Feld Typ angegebenen Wert.

      Dateinamen und Struktur der Unterordner des Hot Folders nachbilden

      Wenn Sie diese Option wählen, entspricht die Ordnerstruktur der des Hot Folders, aus dem die Dokumentbilder importiert wurden. Wenn Sie diesen Exporttyp konfigurieren, wählen Sie im Feld Exportpfad den Ordner aus, der die Struktur des Hot Folders widerspiegeln soll.

      Alle Dokumente in eine Datei exportieren

      Wählen Sie diese Option aus, um alle Daten in eine Datei zu exportieren. Wenn Sie diesen Exporttyp konfigurieren, geben Sie im Feld Pfad den Pfad und den Namen der Datei für den Datenexport an.

      Dokumente als einzelne Dateien exportieren

      Wählen Sie diese Option aus, um jedes Dokument als eine separate Datei zu exportieren:

      • Geben Sie im Feld Dateipräfixden Pfad und die ersten Zeichen des Dateinamens ein.
      • Wenn jeder Stapel in einen eigenen Ordner exportiert werden soll, wählen Sie die Option Für jeden Stapel separaten Ordner erstellen aus.
      Ordnerstruktur und Dateiname mittels Vorlage erstellen

      Wenn Sie diese Option auswählen, werden die Dateinamen und die Struktur der Unterordner in Abhängigkeit von den Dokumentparametern gebildet.

      • Geben Sie im Feld Exportpfad den Stammpfad für den Export an.
      • Legen Sie die Optionen für die Dateinamen fest. Klicken Sie hierfür auf Bearbeiten… und geben Sie die benötigten Regeln ein. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
      • Wählen Sie im Feld Wenn Datei bereits vorhanden aus, welche Aktion das Programm durchführen soll, wenn bereits eine Datei mit dem generierten Namen existiert.

      Wichtig! Damit der Export korrekt beendet wird, müssen Sie nach dem Hochladen des Projekts auf den Server sicherstellen, dass der Exportpfad im UNC-Format angegeben ist (\\Computername\Freigabename[\Pfad]). Prüfen Sie außerdem, dass alle am Export beteiligten Stationen Zugriff auf den angegebenen Speicherort haben.

      Exportfehler treten auf, wenn der Pfad in folgendem Format angegeben wird: <Datenträger:>\[Pfad]. Wenn Sie einen relativen Exportpfad angeben, kann nur über die Anwendungsschnittstelle (API) auf die Daten zugegriffen werden. Um auf andere Weise auf die Daten zuzugreifen, muss das Stammverzeichnis für relative Pfade im UNC-Format angegeben werden (dies lässt sich in den Projekteigenschaften konfigurieren).

  7. Wählen Sie den Dateityp aus (unterstützt werden die Formate CSV, DBF, TXT, XLS und XML), legen Sie weitere Exporteigenschaften für den ausgewählten Dateityp fest und wählen Sie ggf. die Textcodierung aus. Klicken Sie dann auf Weiter>.

    Microsoft Office Excel-Arbeitsmappe (*.xls)
    • Wählen Sie die Version von Microsoft Excel (5.0/95; 97-2003; 97-2003 (kompatibel mit 5.0/95)).
    • Wählen Sie Werttyp beim Exportieren beibehalten aus, um die Daten basierend auf ihrem Typ zu exportieren. Deaktivieren Sie diese Option, um alle Daten mit dem Typ "Allgemein" zu exportieren.
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, um mehrmals vorkommende Felder und Tabellen in separate Dateien zu exportieren.
    • Wählen Sie bei Excel 5.0/95 eine Zeichencodierung aus.
    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung einrichten… und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    XML-Dokument (*.xml)
    • Geben Sie die zusätzlich zu exportierenden Daten ein (Feldpositionen und -typen, Fehler, Daten zur Erkennungsqualität).
    • Wählen Sie Werttyp beim Exportieren beibehalten, wenn Sie das XML-Schema mit den Beschreibungen der Feldtypen speichern möchten.
    • Wählen Sie die Codierung aus.
    • Legen Sie ggf. die Feldnamen fest. Klicken Sie hierfür auf Feldzuordnung einrichten… und geben Sie im Dialogfeld Feldzuordnung die Feldnamen ein.
    Kommagetrennte Datei (*.csv)
    • Wählen Sie das Spaltentrennlinie aus.
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten.
    • Wählen Sie die Codierung aus.
    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung einrichten… und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    Textdatei (*.txt)
    • Wählen Sie das Spaltentrennlinie aus.
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten.
    • Wählen Sie die Codierung aus.
    • Konfigurieren Sie ggf. die Feldnamen und das Format. Klicken Sie hierfür auf Feldzuordnung einrichten… und geben Sie im Dialogfeld Feldzuordnung die Feldnamen und Formate von Feldern mit Zahlen und Datumsangaben ein.
    DBase-Datei (*.dbf)
    • Wählen Sie Werttyp beim Exportieren beibehalten, um die Daten basierend auf ihrem Typ zu exportieren. Deaktivieren Sie diese Option für alle Felder, damit diese vom Typ "Text" sind.
    • Wählen Sie Separate Dateien für wiederholbare Elemente erstellen aus, wenn Sie mehrmals vorkommende Felder und Tabellen in separate Dateien exportieren möchten.
    • Konfigurieren Sie ggf. die Feldnamen. Klicken Sie hierfür auf Feldzuordnung einrichten… und geben Sie im Dialogfeld Feldzuordnung die Feldnamen ein.
  8. Wenn Sie die Bilder speichern möchten, legen Sie die Parameter zum Speichern von Bildern fest und klicken auf Weiter>.
    • Wählen Sie aus, ob die Bilder zusammen mit den Daten gespeichert werden sollen, oder geben Sie den Bildordner an.
    • Wählen Sie das Namensschema für die Bilddateien aus: ähnlich wie bei den Datendateien oder anders. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
    • Geben Sie die Felder an, die Bilder enthalten, die Sie beim Export ausblenden möchten.
  9. Wenn Bilder gespeichert werden sollen, bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.
    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.
    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbares PDF erstellen wählen. Sie können eine Sprache auswählen (oder Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet: Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen… und fügen Sie die entsprechenden Sprachen hinzu. Wenn Sie die in der Dokumentdefinition festgelegte Sprache verwenden möchten, wählen Sie im Feld Wie in der Dokumentdefinition die Option Sprache.
  10. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Hinweis:Mehrfach vorkommende Felder (d. h. Felder mit mehreren Instanzen und Tabellen) werden jeweils in separate Dateien exportiert, für die ein neuer Ordner erstellt wird. Der Name des Ordners besteht aus dem Namen der Exportdatei. Wenn mehrfach vorkommende Felder nicht in separate Dateien exportiert werden sollen, deaktivieren Sie auf der Registerkarte Separate Dateien für wiederholbare Elemente erstellen die Option Exportzielassistent (die Option ist für alle Formate mit Ausnahme von XML verfügbar). In diesem Fall werden mehrfach vorkommende Felder in eine Exportdatei exportiert und es wird eine neue Zeile für jede Elementinstanz hinzugefügt.


Bilder in Datei exportieren

Bildexport in eine Datei

So exportieren Sie Bilder in eine Datei:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Option Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Typ feld Exportieren in Bilddateien.
  3. Bestimmen Sie, ob der Export obligatorisch ist.
  4. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.
  5. Legen Sie die Exportparameter fest und klicken Sie auf Weiter>. Die änderbaren Exportparameter richten sich nach dem im Feld Typ angegebenen Wert.
      Dateinamen und Struktur der Unterordner des Hot Folders nachbilden
      Wenn Sie diese Option wählen, entspricht die Ordnerstruktur der des Hot Folders, aus dem die Dokumentbilder importiert wurden. Wenn Sie diesen Exporttyp konfigurieren, wählen Sie im Feld Exportpfad den Ordner aus, der die Struktur des Hot Folders widerspiegeln soll.
      Alle Dokumente in eine Datei exportieren
      Wählen Sie diese Option aus, um alle Daten in eine Datei zu exportieren. Wenn Sie diesen Exporttyp konfigurieren, geben Sie im Feld Pfad den Pfad und den Namen der Datei für den Datenexport an.
      Dokumente als einzelne Dateien exportieren
      Wählen Sie diese Option aus, um jedes Dokument als eine separate Datei zu exportieren:
      • Geben Sie im Feld Dateipräfix den Pfad und die ersten Zeichen des Dateinamens ein.
      • Wenn jeder Stapel in einen eigenen Ordner exportiert werden soll, wählen Sie die Option Für jeden Stapel separaten Ordner erstellen aus.
      Ordnerstruktur und Dateiname mittels Vorlage erstellen
      Wenn Sie diese Option auswählen, werden die Dateinamen und die Struktur der Unterordner in Abhängigkeit von den Dokumentparametern gebildet.
      • Geben Sie im Feld Exportpfad den Stammpfad für den Export an.
      • Legen Sie die Optionen für die Dateinamen fest. Klicken Sie hierfür auf Bearbeiten… und geben Sie die benötigten Regeln ein. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
      • Wählen Sie im Feld Wenn Datei bereits vorhanden aus, welche Aktion das Programm durchführen soll, wenn bereits eine Datei mit dem generierten Namen existiert.

      Wichtig! Damit der Export korrekt beendet wird, müssen Sie nach dem Hochladen des Projekts auf den Server sicherstellen, dass der Exportpfad im UNC-Format angegeben ist (\\Computername\Freigabename[\Pfad]). Prüfen Sie außerdem, dass alle am Export beteiligten Stationen Zugriff auf den angegebenen Speicherort haben.

      Exportfehler treten auf, wenn der Pfad in folgendem Format angegeben wird: <Datenträger:>\[Pfad]. Wenn Sie einen relativen Exportpfad angeben, kann nur über die Anwendungsschnittstelle (API) auf die Daten zugegriffen werden. Um auf andere Weise auf die Daten zuzugreifen, muss das Stammverzeichnis für relative Pfade im UNC-Format angegeben werden (dies lässt sich in den Projekteigenschaften konfigurieren).

  6. Bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.
    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.
    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbares PDF erstellen wählen. Sie können eine Sprache auswählen (oder Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet: Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen… und fügen Sie die entsprechenden Sprachen hinzu. Wenn Sie die in der Dokumentdefinition festgelegte Sprache verwenden möchten, wählen Sie im Feld Wie in der Dokumentdefinition die Option Sprache.
  7. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.


Export in eine Datenbank

In Datenbank exportieren

So konfigurieren Sie den Export in eine Datenbank:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoption Dokumentdefinition> Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen… und wählen Sie im Feld Typ die Option In ODBC-kompatible Datenbank exportieren.
  3. Bestimmen Sie, ob der Export obligatorisch ist.
  4. Bestimmen Sie, ob Bilder exportiert werden sollen.
  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Legen Sie die Exporteinstellungen fest und klicken Sie auf Weiter>.

    • Stellen Sie eine Verbindung mit einer Datenbank her. Geben Sie im Fenster Verbindungszeichenfolge die Verbindungsparameter ein, oder klicken Sie auf die Schaltfläche Verbindung einrichten… und legen im Dialogfeld Eigenschaften von Datenverbindung die Verbindungsparameter fest.
    • Wählen Sie in der Dropdownliste ein Datenbankschema aus.
    • Sie können die Verbindung mit der Datenbank überprüfen, indem Sie auf die Schaltfläche Verbindung testen klicken.

      Tipp:Als OLE DB-Anbieter wird ein OLE DB-Anbieter für ODBC-Treiber empfohlen. Die Auswahl des OLE DB-Anbieters für SQL Server führt bei der Verwendung bestimmter Datentypen und langer Felder möglicherweise zu Fehlern.

    • Ordnen Sie die Felder der Dokumentdefinition den Spalten der Datenbanktabellen zu. Klicken Sie dazu auf Feldzuordnung einrichten….
    • Geben Sie im Dialogfeld Feldzuordnung an, in welche Tabellen und Tabellenspalten der Datenbank die Feldwerte der Dokumentdefinition exportiert werden sollen.
      Details…

      Im linken Bereich des Dialogfelds Feldzuordnung sind Dokumentbereiche und -felder aufgeführt. Im rechten Bereich müssen Sie diese Bereiche und Felder den Tabellen und Feldern in der Datenbank zuordnen. Wenn die Datenbank bereits Tabellen für den Datenexport enthält, müssen Sie im Dialogfeld Feldzuordnung eine Datenbanktabelle für jeden Dokumentbereich und eine Datenbanktabellenspalte für jedes Dokumentfeld auswählen.

      Wenn die Datenbank keine Tabellen für den Export enthält, können Sie Datenbanktabellen automatisch erstellen. Klicken Sie dazu auf die Schaltfläche Tabellen automatisch erstellen. Damit werden Tabellen mit der für den Export erforderlichen Struktur erstellt. Die Dokumentfelder werden Tabellenspalten zugeordnet.

      Feldgruppen, Felder mit mehreren Instanzen und Dokumenttabellen werden jeweils in separate Datenbanktabellen exportiert. Die Haupttabelle wird mithilfe eines primären Schlüssels und eines Fremdschlüssels mit den untergeordneten Tabellen verknüpft. In der Haupttabelle wird jedem Eintrag ein primärer Schlüssel hinzugefügt. In der untergeordneten Tabelle wird jedem Eintrag ein Fremdschlüssel zugewiesen, mit dem der Wert des primären Schlüssels des entsprechenden Eintrags in der Haupttabelle erfasst wird. Die primären und Fremdschlüssel werden an den entsprechenden Stellen automatisch hinzugefügt. Sie müssen lediglich das Feld angeben, zu dem der Schlüssel exportiert werden soll.

      Die Option Verknüpfte Spalten anzeigen ist standardmäßig aktiviert. Wenn Sie die Option deaktivieren, werden im rechten Bereich in der Liste der verfügbaren Tabellenspalten die Spalten nicht angezeigt, für die der Export bereits definiert wurde.

  7. Wenn Bilder gespeichert werden sollen, bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.
    • Legen Sie fest, ob die Bilder in der Datenbank oder als Dateien gespeichert werden sollen.
    • Wenn Sie Bilder in Dateien speichern möchten, müssen Sie eine Dateinamenvorlage angeben (klicken Sie auf Dateinamenoptionen…), und wenn Dateien denselben Namen tragen, ob diese überschrieben werden sollen. Weitere Informationen finden Sie unter Optionen für die Namen von Exportdateien.
    • Legen Sie bei Bedarf die Felder fest, die beim Export nicht angezeigt werden sollen.
  8. Wenn Bilder gespeichert werden sollen, bestimmen Sie die Bildspeicheroptionen und klicken Sie auf Weiter>.
    • Wählen Sie das gewünschte Bildformat, die Qualität und die Farbe.
    • Wählen Sie zum Ändern der Auflösung des Ausgangsbildes Auflösung ändern in und wählen Sie den entsprechenden Wert aus der Liste.
    • Wenn Sie zum Speichern von Bildern die Option PDF oder PDF/A ausgewählt haben, können Sie eine durchsuchbare PDF-Datei erstellen, indem Sie die Option Durchsuchbares PDF erstellen wählen. Sie können eine Sprache auswählen (oder Sprachen, wenn in Ihrem Dokument mehrere Sprachen verwendet werden), die sich von der in der Dokumentdefinition festgelegten Sprache unterscheidet: Klicken Sie dazu rechts neben dem Feld Sprache auf Auswählen… und fügen Sie die entsprechenden Sprachen hinzu. Wenn Sie die in der Dokumentdefinition festgelegte Sprache verwenden möchten, wählen Sie im Feld Wie in der Dokumentdefinition die Option Sprache.
  9. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Hinweis:

  1. Bilder werden in separate Dateien exportiert. Name und Pfad der Bilddatei können in dem entsprechenden Feld der Datenbank gespeichert werden (dieses kann beim Zuordnen der Felder eingerichtet werden).
  2. Wenn sich der Pfad zum Zielordner für Dokumente, Bilder usw. auf ein Netzlaufwerk bezieht, stellen Sie sicher, dass alle am Projekt arbeitenden Verarbeitungsstationen Zugriff auf dieses Laufwerk haben.


Exportieren von Daten in eine SharePoint-Dokumentbibliothek

ABBYY FlexiCapture 9.0 ermöglicht Ihnen das Exportieren von Dokumenten in eine MicrosoftTM SharePoint-Dokumentbibliothek. Als Ergebnis erhalten Sie eine Bibliothek Ihrer Dokumentbilder mit zusätzlichen Spalten für jedes Dokument, die mit Werten bestimmter Felder ausgefüllt sind.

Hinweis:

  1. Zum Einrichten des Exports von Daten nach SharePoint sind Administratorrechte erforderlich. Für den eigentlichen Export nach SharePoint sind Mitarbeiterrechte ausreichend.
  2. Die SharePoint-Spalten, in denen die Daten erfasst werden sollen, müssen vom Typ Eine Textzeile oder Mehrere Textzeilen sein.

So richten Sie den Export nach SharePoint ein:

  1. Wählen Sie im Dokumentdefinitionseditor die Option Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen….
  3. Wählen Sie im Feld Typ die Option Nach SharePoint exportieren aus.
  4. Bestimmen Sie, ob der Export obligatorisch ist
  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.

  6. Bestimmen Sie die Exporteinstellungen.

    • Server-URL (z.B. http://meinserver): Geben Sie die Adresse des Servers ein, auf dem sich Ihre SharePoint-Bibliotheken befinden. Verwenden Sie die Schaltfläche Verbindungseinstellungen…, um gegebenenfalls die Authentifizierungsparameter (standardmäßig werden die Windows-Authentifizierungsparameter verwendet) und die Proxy-Einstellungen einzurichten.
    • Unter der Serveradresse wird der Verbindungsstatus angezeigt. Wenn die Serververbindung getrennt ist, klicken Sie auf Verbinden, um die Verbindung wiederherzustellen.
    • Wenn Sie mit dem SharePoint-Server verbunden sind, wählen Sie aus der Liste SharePoint-Bibliothek auswählen eine Bibliothek aus.
    • Klicken Sie auf Durchsuchen… und suchen Sie den gewünschten Ordner in der Bibliothek.
    • Wählen Sie im Feld Inhaltstyp den Inhaltstyp Ihres Dokuments aus (unterstützt ab SharePoint 2007). In diesem Fall haben Sie die Möglichkeit, Werte in die Felder zu exportieren, die dem ausgewählten Inhaltstyp entsprechen.
    • Legen Sie nun fest, welche Dokumentdefinitionsfelder wohin exportiert werden sollen. Klicken Sie auf die Schaltfläche Feldzuordnung einrichten… und wählen Sie die gewünschten Optionen im Dialogfeld Feldzuordnung aus. In diesem Dialogfeld müssen Sie die Entsprechungen zwischen den Dokumentdefinitionsfeldern und den SharePoint-Dokumentspalten herstellen. Die Dokumentdefinitionsfelder werden auf der linken Seite angezeigt. Für jedes zu exportierende Dokumentdefinitionsfeld (mit Ausnahme von Gruppen und Tabellen) können Sie eine freie SharePoint-Spalte auswählen.
  7. Klicken Sie auf Weiter>.
  8. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Nachdem der Export abgeschlossen worden ist, werden die Dokumente in der angegebenen SharePoint-Bibliothek gespeichert. Jedes Dokument verfügt dann über eine entsprechende Spalte, die mit den Werten der festgelegten Felder ausgefüllt ist. Diese Werte können für Suchvorgänge und zur Dokumentindizierung verwendet werden.


Export mithilfe eines Skripts

So konfigurieren Sie den Export mithilfe eines Skripts:

  1. Wählen Sie im Fenster des Dokumentdefinitionseditors die Option Dokumentdefinition > Exporteinstellungen… aus.
  2. Klicken Sie auf Hinzufügen….
  3. Wählen Sie im Feld Typ die Option Benutzerdefinierter Export (Skript) aus.
  4. Bestimmen Sie, ob der Export obligatorisch ist.
  5. Bestimmen Sie, welche Dokumente (mit und/oder ohne Fehler) exportiert werden sollen und klicken Sie auf Weiter>.
  6. Wählen Sie die Skriptsprache (JScript(r) oder VBScript) aus.
  7. Geben Sie den Skriptcode im Fenster des Editors ein, das angezeigt wird, wenn Sie auf Skript bearbeiten… klicken. Klicken Sie dann auf Weiter>.
  8. Geben Sie einen Exportprofilnamen ein und klicken Sie auf Fertigstellen.

Hinweis: Prozeduren, die in mehr als einem Exportskript verwendet werden sollen, sollten in das Modul für globale Exporte geschrieben werden, das vom Skripteditor aus aufgerufen werden kann. Wählen Sie aus der Dropdownliste in der Symbolleiste des Skripteditors die Option Globales Skriptmodul exportieren. Auf das Modul für globale Exportskripte können Sie auch vom Dokumentdefinitionseditor aus zugreifen (Dokumentdefinition>Skriptmodule>Exportskript…).

Weitere Informationen zum Definieren des Exports mithilfe eines Skripts finden Sie unter Verwenden von Skripten in FlexiCapture 9.0


Regeln für das Benennen von Exportdateien

Namenskriterien für Exportdateien

Dateinamen und -pfade werden während des Exports basierend auf den vom Benutzer angegebenen Kriterien automatisch generiert. Sie können sowohl die Namen von Datendateien als auch die Namen von Bilddateien konfigurieren.

Die Erstellung von Dateinamen und -pfaden kann im Fenster Exportdateiziel konfiguriert werden. Je nach gewähltem Exporttyp öffnen Sie dieses Fenster durch Klicken auf Bearbeiten… (links vom Feld mit der Dateinamenvorlage) oder auf Dateinamenoptionen….

Es gibt zwei Typen für die Bildung von Dateiexportvorlagen (wählen Sie im Feld Ansicht):

Einfach

Bei diesem Typ können Sie einen zusätzlichen Pfad(außer beim Einrichten des Bildexports zusammen mit dem Export von Daten in eine Datei) und den signifikanten Teil des Dateinamens auswählen sowie ggf. Kennungen ergänzen.

Um den relativen Pfad festzulegen, wählen Sie Zusätzlichen Pfad verwendenund dann die Methode aus: ähnlich wie die Struktur des Hot Folders (Quellpfad relativ zum Hot Folder) oder entsprechend dem Stapelnamen (Stapelname).

Folgende Elemente können als signifikanter Teil des Dateinamens verwendet werden:

  • Quelldateiname
  • Name der Dokumentdefinition
  • Festgelegter Dateiname- Kombination aus vom Benutzer festgelegten Zeichen

Folgende Elemente können als zusätzliche Kennungen verwendet werden:

  • Dokumentkennung(wählen Sie Dokumentkennung zum Dateinamen hinzufügen)
  • Wert des Indexfelds (wählen Sie Indexfeld zum Dateinamen hinzufügen, klicken Sie dann auf …und wählen Sie im Fenster Felder auswählen das Indexfeld aus)
Erweitert

Bei diesem Typ wird die Dateinamenvorlage als Textzeile ins Feld Dateinamenvorlageeingegeben. Die Vorlage kann einen permanenten Teil und Markierungen umfassen, die durch Angaben für spezifische Dateien ersetzt werden. Die Markierungen können über die Tastatur eingegeben und mit Hilfe der Schaltflächen Markierung hinzufügen…und Markierung löschen ergänzt oder gelöscht werden.

Damit die Dateinamen korrekt erzeugt werden können, stellen Sie sicher, dass die von Ihnen ausgewählten Dateinamenoptionen nicht zu leeren Dateinamen führen. Tritt dieser Fall ein, zeigt das Programm eine Warnmeldung an.


Konfigurieren der Datendarstellung im Dokumentfenster

Nach der Erkennung werden die Daten im Dokumentfenster angezeigt. Die Daten werden standardmäßig der Reihe nach angeordnet. Die zugehörigen Beschriftungen entsprechen jeweils den Namen der Felder der Dokumentdefinitionen.

Sie können jedoch die Darstellung der Daten ändern, die Anordnung nach Bedarf anpassen oder Elemente umbenennen. Die Datendarstellung kann in der rechten unteren Ecke des Dokumentdefinitionseditors bearbeitet werden.

Sie können die Beschriftung eines Felds im Datenformular ändern, ohne den Namen des Felds in der Dokumentstruktur zu verändern. Öffnen Sie zum Ändern einer Beschriftung das Dialogfeld für die Feldeigenschaften, klicken Sie auf die Registerkarte Allgemein und geben Sie einen neuen Namen in das Feld Überschrift ein. Dieser Name wird nun für die Beschriftung des Felds im Datenformular verwendet. Diese Funktion kann hilfreich sein bei der Anpassung von Spaltennamen, insbesondere bei FlexiLayouts, bei denen Sie die Namen der Felder nicht ändern können.

Die Textschrift und -größe von Feldnamen und Werten erkannter Daten können auf der Registerkarte Datenformular des Dialogfelds Eigenschaften der Dokumentdefinition (Dokumentdefinition> Eigenschaften der Dokumentdefinition…) geändert werden. Sie können die Größe auch ändern, indem Sie mit der rechten Maustaste in das Fenster Datenformular klicken und die gewünschte Größe auswählen (Menü Textgröße im Kontextmenü).

Sie können Felder verschieben, bearbeiten und umbenennen sowie andere Feldeigenschaften ändern. Wählen Sie im Kontextmenü die entsprechende Option aus, um wieder zur anfänglichen Felddarstellung zu wechseln.

Sie können Text hinzufügen, beispielsweise Erläuterungen. Klicken Sie dazu mit der rechten Maustaste in das Fenster Datenformular und wählen Sie im Kontextmenü die Option Beschriftungsfeld einfügen aus. Ersetzen Sie den Beschriftungstext durch den gewünschten Text.


Eigenschaften von Dokumentdefinitionen

Die allgemeinen Eigenschaften einer Dokumentdefinition, z. B. Name, Sprache und Schreibstil, werden mithilfe des Dokumentdefinitionsassistenten festgelegt. Andere Eigenschaften werden automatisch konfiguriert.

Sie können die Eigenschaften einer Dokumentdefinition im entsprechenden Eigenschaftsdialogfeld anzeigen und ändern. Dieses Dialogfeld wird geöffnet, wenn Sie im Fenster des Dokumentdefinitionseditors die Menüoption Dokumentdefinition > Eigenschaften der Dokumentdefinition… auswählen.

Das Dialogfeld enthält sechs Registerkarten.

Registerkarte Allgemein

Auf dieser Registerkarte können Sie die Dokumentdefinition umbenennen und ihre Beschreibung eingeben oder bearbeiten. Über die Option Aktiviert wird die Dokumentdefinition in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen.

Registerkarte Erkennung

Auf dieser Registerkarte können Sie die allgemeinen Eigenschaften zur Erkennung einer Dokumentdefinition ändern.

  • Sprache (Gebietsschema): Für eine korrekte Erkennung ist es wichtig, die verwendete Sprache einzugeben. Diese Eigenschaft legt die Eingabesprache und andere lokale Einstellungen fest, z. B. Datumsformat, Währung usw.
  • Schreibstil: Der Schreibstil kann sich in verschiedenen Ländern erheblich unterscheiden. Daher ist es wichtig, das Land anzugeben, so dass im Programm der jeweils typische Schreibstil ausgewählt wird.

  • Geben Sie den Texttyp an:

    ICR (Handschrift): Aktivieren Sie diese Option, wenn die meisten Felder in Dokumenten von Hand ausgefüllt werden.

    OCR (Druck): Aktivieren Sie diese Option, wenn die Werte in den meisten Feldern gedruckt werden. Wählen Sie in der Dropdownliste den Drucktyp aus.

    Hinweis:Die Erkennung von handgeschriebenem Text wird nicht für alle Sprachen unterstützt. Bei einigen Sprachen ist dieser Erkennungstyp nicht verfügbar. Siehe Unterstützte Erkennungssprachen.

    Der hier angegebene Texttyp wird als Standard verwendet. Zu einem späteren Zeitpunkt können Sie den Typ für einzelne Felder ändern.

  • Sie können in der Gruppe Mögliche Seitenausrichtung eine oder mehrere Optionen aktivieren, so dass die Seite bei der automatischen Seitenausrichtung um 180° oder um 90° im Uhrzeigersinn bzw. gegen den Uhrzeigersinn gedreht wird.
  • Klicken Sie auf Erweiterte Optionen…, um die Korrektur linearer oder nicht linearer Bildverzerrungen festzulegen.

Registerkarte Zusammenstellung

Auf dieser Registerkarte können Zusammenstellungsregeln für mehrseitige Dokumente konfiguriert werden.

Im einfachsten Fall enthält die Dokumentdefinition einen Bereich, der genau einmal vorkommt. Wenn eine Dokumentdefinition mehrere Bereiche umfasst, wird auf dieser Registerkarte eine Liste mit den zugehörigen Namen angezeigt. Sie können die Anzahl der Wiederholungen jedes Bereichs angeben, indem Sie jeweils die Zahl in den Spalten Mindestanzahl und Maximalanzahl ändern.

  • Gleichwertigkeit der Schlüsselfelder überprüfen: Aktivieren Sie diese Option, wenn eine Überprüfung der Dokumentzusammenstellung anhand von Schlüsselfeldern durchgeführt werden soll. Wählen Sie dann in der Spalte Schlüsselfeld für jeden Bereich ein Schlüsselfeld aus. Bei der Eingabe von Dokumenten werden nur Dokumente mit übereinstimmenden Schlüsselfeldwerten in jedem Bereich als korrekt zusammengestellt eingestuft. Wenn die Werte nicht übereinstimmen, wird eine Zusammenstellungsfehlermeldung angezeigt.
  • Anhangseiten berücksichtigen: Aktivieren Sie diese Option, wenn Dokumente mit Anhängen verarbeitet werden sollen.
  • Es kann vorkommen, dass Sie die Überprüfung der Reihenfolge der Bereiche im Dokument deaktivieren möchten (z. B., wenn die Reihenfolge der Bereiche keinen Einfluss auf die Dokumentzusammenstellung hat). Wählen Sie Überprüfung der Bereichsreihenfolge deaktivieren, um die Überprüfung zu deaktivieren. Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.

Weitere Informationen finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente, Zusammenstellen von Seiten in Dokumenten und Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Registerkarte Regeln

Diese Registerkarte ist für die Arbeit mit Regeln in der Dokumentdefinition vorgesehen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.

Registerkarte Exportieren

Auf dieser Registerkarte werden die aktuellen Exporteinstellungen der entsprechenden Dokumentdefinition angezeigt. Wenn Sie die Exporteinstellungen ändern möchten, klicken Sie auf die Schaltfläche Bearbeiten….

Ausführliche Informationen finden Sie unter Konfigurieren des Datenexports.

Registerkarte Datenformular

Auf dieser Registerkarte können Sie die Schriftkontur und Schriftgröße zum Anzeigen erkannter Daten ändern.

Die Gruppe Einstellungen für Datentext enthält Schrifteinstellungen zum Anzeigen erkannter Werte.

Die Gruppe Einstellungen für Beschriftungstext enthält Einstellungen zum Anzeigen des erklärenden Texts (Feldnamen).

Weitere Informationen finden Sie unter Konfigurieren der Datendarstellung im Dokumentfenster.


Importieren einer Dokumentdefinition für mit ABBYY FormDesigner erstellte Formulare

ABBYY FormDesigner ist ein benutzerfreundliches Tool, das speziell zum Erstellen maschinenlesbarer Formulare entwickelt wurde. Mit ABBYY FormDesigner können Sie nicht nur Formulare erstellen, die allen Anforderungen für die automatische Dokumentverarbeitung entsprechen, das Tool enthält darüber hinaus eine nahezu vollständige Dokumentdefinition zum Verarbeiten dieser Formulare in ABBYY FlexiCapture 9.0.

So erstellen Sie eine Dokumentdefinition zum Verarbeiten von Formularen, die mit ABBYY FormDesigner erstellt wurden:

In ABBYY FormDesigner:

  1. Erstellen Sie ein Formular.
  2. Veröffentlichen Sie das Formular.
  3. Exportieren Sie es in das XML-Formulardefinitionsformat. Sie erhalten eine Datei mit der Dateierweiterung „xfd“.

Ausführliche Informationen zum Erstellen, Veröffentlichen und Exportieren von Formularen finden Sie in den Hilfethemen und im Benutzerhandbuch für ABBYY FormDesigner 9.0.

In ABBYY FlexiCapture:

  1. Wählen Sie im Hauptmenü die Menüoption Projekt > Dokumentdefinitionen… aus.
  2. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Importieren….
  3. Wählen Sie im daraufhin geöffneten Dialogfeld Datei zum Importieren öffnen in der Dropdownliste Dateityp die Option XML-Formulardefinitionsdateien (*.xfd) aus und geben den Pfad der XFD-Datei an.
  4. Der Name der neuen Dokumentdefinition wird dann in der Liste des Dialogfelds Dokumentdefinitionen angezeigt.

Nach dem Öffnen einer importierten Dokumentdefinition, die Sie bearbeiten möchten, sind die Felder und statischen Elemente im Bild bereits gekennzeichnet. Sie müssen lediglich die Feldeigenschaften bearbeiten und den Export konfigurieren.


Erstellen einer Dokumentdefinition für mehrseitige Dokumente

Mit ABBYY FlexiCapture 9.0 können Sie Dokumentdefinitionen für mehrseitige Dokumente erstellen. Eine Dokumentdefinition kann aus einer beliebigen Anzahl von Bereichen bestehen, die jeweils eine oder mehrere Seiten umfassen können. Bei Dokumentdefinitionen für mehrseitige Dokumente müssen Sie die Reihenfolge der Bereiche, die Anzahl der Bereiche und die Regeln angeben, anhand derer Seiten zu Dokumenten zusammengestellt werden.

Im Assistenten wird eine neue einfache Dokumentdefinition ohne Bereiche erstellt. Sie können dieser Dokumentdefinition Seiten hinzufügen. Beim Hinzufügen einer Seite wird das entsprechende Bild zur Bildregion im Fenster des Dokumentdefinitionseditors hinzugefügt. Die in diesem Bereich erstellten Felder sind dagegen in der Liste der allgemeinen Felder aufgeführt. Das Dokument umfasst dann einen Bereich, obwohl es mehrere Seiten enthalten kann.

Sie sollten einem Bereich Seiten hinzufügen, wenn das Dokument Bereichsblöcke enthält, die sich über mehrere Seiten oder über Tabellen auf mehreren Seiten erstrecken oder auf mehreren Seiten mehrfach vorkommen. Das gleiche Verfahren wird zum Laden eines FlexiLayouts für mehrseitige Dokumente angewendet (siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente). Alle Felder in einem FlexiLayout müssen ein und demselben Bereich einer Dokumentdefinition zugewiesen sein.

Eine andere Möglichkeit besteht darin, der Dokumentdefinition Bereiche hinzuzufügen. Im einfachsten Fall enthält ein Bereich genau eine Seite. Sie können festlegen, ob Feldgruppen auf Seiten voneinander unabhängig sind. Dieses Verfahren ist anschaulicher: In der Dokumentstruktur wird angezeigt, welchem Bereich die Felder zugewiesen sind. Sie können zudem eine benutzerdefinierte Struktur der Dokumentzusammenstellung definieren. Angenommen, Ihr Dokument enthält drei Seitentypen, wobei Seiten des ersten und dritten Typs nur einmal auftreten können, Seiten des zweiten Typs jedoch 2 bis 5-mal. Sie müssen dann drei Bereiche – für jeden Seitentyp einen – erstellen und festlegen, in welcher Reihenfolge die Bereiche innerhalb des Dokuments angeordnet sind und wie oft sie auftreten können.

Ein komplexeres Beispiel ist eine Dokumentdefinition mit mehreren Bereichen, von denen einige mehrere Seiten umfassen. Dabei kann es sich beispielsweise um eine Dokumentdefinition mit statischen Bereichen und einem flexiblen mehrseitigen Bereich handeln oder um eine Dokumentdefinition für Dokumente mit einem doppelseitigen Blatt, das mehrfach vorkommen kann. Beispiel: Sie möchten eine Dokumentdefinition für ein Dokument mit einer Titelseite (Seite A) und einer bestimmten Anzahl doppelseitiger Blätter (Seitenfolge BCBC…) erstellen. Sie erstellen dann den Bereich A mit der Seite A sowie den Bereich BC mit den zwei Seiten B und C. Die Dokumentstruktur wird folgendermaßen definiert: Bereich A wird einmal wiederholt, gefolgt von Bereich BC, der 3- bis 7-mal wiederholt wird.

Bei einer Dokumentdefinition mit mehreren Bereichen können Sie neben der Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche die Überprüfung von Schlüsselfeldern festlegen. Dazu müssen Sie die Schlüsselfelder in jedem Dokumentbereich identifizieren. Die entsprechenden Werte müssen in verschiedenen Bereichen identisch sein. Ein Beispiel für ein Schlüsselfeld ist der Nachname einer Person, die ein Dokument ausfüllt, der auf jeder Seite eingetragen werden muss, oder eine bestimmte Identifikationsnummer.

Beim Verarbeiten eines Stapels wird im Programm eine Folge von Seiten in Dokumenten zusammengestellt. Dabei werden die Zusammenstellungsregeln überprüft. Zudem wird eine Überprüfung der Schlüsselfeldwerte durchgeführt. Wenn Schlüsselfelder auf den Seiten eines Dokuments nicht übereinstimmen, wird eine Fehlermeldung angezeigt. Die Schlüsselfelder stimmen manchmal nicht überein, da die Seiten eines Dokuments beim Scannen in falscher Reihenfolge angeordnet wurden. Nach dem Ändern der Reihenfolge der Seiten sind die Zusammenstellungsregeln dann wieder erfüllt. Siehe Zusammenstellen von Seiten in Dokumenten.

Wenn Sie einem Bereich eine Seite hinzufügen möchten, wählen Sie im Dokumentdefinitionseditor die Menüoption DokumentdefinitionSeite hinzufügen… oder im Kontextmenü des Bilds die Option Seite hinzufügen… aus. Laden Sie dann das Bild einer neuen unausgefüllten Seite, und wählen Sie Objekttypen aus, die in der Seite automatisch markiert werden sollen.

Wenn Sie einen neuen Bereich hinzufügen möchten, wählen Sie im Fenster des Dokumentdefinitionseditors die Menüoption Vorlage > Dokumentbereich hinzufügen… aus. Daraufhin wird der Assistent zum Erstellen von Bereichen geöffnet, in dem Sie alle erforderlichen Parameter festlegen können. Befolgen Sie die Anweisungen des Assistenten, und führen Sie folgende Schritte aus:

  • Geben Sie den Namen des Bereichs an.
  • Laden Sie das Bild einer unausgefüllten Seite (Scannen oder Laden aus Datei) oder eine FlexiLayout-Datei.
  • Wählen Sie Objekttypen aus, die automatisch markiert werden sollen.

Damit wird im Fenster Dokumentstruktur ein neuer Bereich mit den zugehörigen Feldern angezeigt.

Wenn Sie beim Erstellen einer Dokumentdefinition die entsprechende Dokumentstruktur anzeigen möchten, klicken Sie im rechten Bereich des Dokumentdefinitionseditors im Fenster Dokumentstruktur auf die Registerkarte Seiten. Hier wird die Dokumentstruktur in der Gliederungsansicht angezeigt. Auf dieser Registerkarte können Sie die Anzahl der Bereichswiederholungen in einem Dokument ändern (geben Sie dazu im Feld rechts neben dem Namen des Bereichs einen neuen Wert ein, d. h. eine Anzahl oder ein Intervall), Seiten eines Anhangs anfügen, die Reihenfolge der Seiten im Bereich ändern und Seiten per Drag&Drop zwischen verschiedenen Bereichen verschieben.

Fenster Dokumentstruktur anzeigen

Über die Menüoption Dokumentdefinition > Eigenschaften der Dokumentdefinition… im Fenster des Dokumentdefinitionseditors können Sie die Reihenfolge und Anzahl der mehrfach vorkommenden Bereiche sowie die Zusammenstellungsregel festlegen. Geben Sie auf der Registerkarte Zusammenstellung für jeden Bereich im Dokument die Mindest- und Höchstanzahl der Wiederholungen an (Standardwert: 1). Wenn die Werte der Schlüsselfelder überprüft werden sollen, aktivieren Sie die Option Gleichwertigkeit der Schlüsselfelder überprüfen und wählen in jedem Bereich ein Schlüsselfeld aus.

Es kann vorkommen, dass Sie die Überprüfung der Reihenfolge der Bereiche im Dokument deaktivieren möchten (z. B., wenn die Reihenfolge der Bereiche keinen Einfluss auf die Dokumentzusammenstellung hat). Wählen Sie Überprüfung der Bereichsreihenfolge deaktivieren, um die Überprüfung zu deaktivieren. Das Programm wird weiterhin alle im Dokument vorhandenen Bereiche überprüfen, aber die Reihenfolge wird dabei ignoriert.

Registerkarte Zusammenstellung anzeigen


Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente

Für Rechnungen, Zahlungsaufträge und ähnliche Dokumente können Sie keine Dokumentdefinition mit statischen Feldern erstellen. Die Position, Größe und Anzahl der Felder ist möglicherweise nicht immer identisch, sodass eine statische Dokumentdefinition nicht auf alle Dokumente angewendet werden kann. In diesen Dokumenten wird nach einer Vorerkennung der gesamten Seite nach Feldern gesucht und anhand von Schlüsselwörtern und der relativen Position der Felder ein FlexiLayout erstellt. Ein spezielles Programmmodul, ABBYY FlexiLayout Studio 9.0, wurde für die Festlegung von FlexiLayouts konzipiert (dieses Modul ist im Lieferumfang von ABBYY FlexiCapture 9.0 enthalten). Ausführliche Anweisungen zum Erstellen eines FlexiLayouts finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio 9.0.

FlexiLayouts werden in eine AFL-Datei exportiert und dann in ABBYY FlexiCapture 9.0 geladen. Sie können ein FlexiLayout für die gesamte Dokumentdefinition oder einen ihrer Bereiche verwenden. FlexiLayouts können mehrseitig sein.

Anfügen eines FlexiLayouts

Ein FlexiLayout kann beim Erstellen einer Dokumentdefinition angefügt werden. Fügen Sie dazu im zweiten Schritt im Dokumentdefinitionsassistenten das Dokumentbild hinzu, aktivieren Sie dann die Option FlexiLayout laden und geben Sie den Pfad der AFL-Datei ein, die das FlexiLayout enthält.

Über das Fenster des Dokumentdefinitionseditors können Sie ein FlexiLayout im Dialogfeld des Dokumentdefinitionsbereichs anfügen.

  1. Wählen Sie einen Dokumentbereich aus. (Wenn das Dokument nur einen Bereich umfasst, klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten und wählen Sie den Namen des Bereichs aus.) Klicken Sie mit der rechten Maustaste und wählen Sie im Kontextmenü die Option Eigenschaften… aus.
  2. Klicken Sie auf die Registerkarte FlexiLayout.
  3. Klicken Sie auf Laden….
  4. Wählen Sie die entsprechende AFL-Datei aus.

Nach dem Anfügen eines FlexiLayouts wird im Bild das geometrische Layout der Felder angezeigt. Sie müssen dann die Feldeigenschaften wie bei einer statischen Dokumentdefinition festlegen. Geben Sie die Erkennungs-, Überprüfungs- und Exporteigenschaften an, und legen Sie die gewünschten Regeln fest.

Hinweis: Beim Import eines FlexiLayouts mit Textdateien, die mögliche Feldwerte enthalten, werden diese Dateien entlang der beim Erstellen des FlexiLayouts definierten relativen Pfade positioniert. Die relativen Pfade stehen in Bezug zur Projektdatei. Um diese Dateien zu bearbeiten, speichern Sie das Projekt lokal (wählen Sie Projekt>Projekt exportieren…), bearbeiten Sie die Dateien und aktualisieren Sie das Projekt auf dem Server (wählen Sie Projekt>Projekt aktualisieren…).


Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen

Mit ABBYY FlexiCapture 9.0 können Sie Dokumentdefinitionen für Dokumente mit Anhängen erstellen. Anhänge sind zusätzliche Seiten, die jedem Formular beigefügt werden können. Diesen Seiten wird keine Dokumentdefinition zugeordnet. Sie werden jedoch bei der Dokumentzusammenstellung berücksichtigt. Ein Darlehensantrag (statisches Formular) wird beispielsweise zusammen mit einem Einkommensnachweis ohne feste Struktur übermittelt. Dieser Einkommensnachweis kann als Anhang verarbeitet werden.

So erstellen Sie eine Dokumentdefinition für ein Dokument mit Anhang:

Erste Methode:

  1. Klicken Sie im Fenster Dokumentstruktur auf die Registerkarte Seiten (erster Teil des Dokumentdefinitionseditors).
  2. Aktivieren Sie die Option Anhangseiten im Dokument berücksichtigen.
  3. Geben Sie die Anzahl oder den Bereich der Anhangseiten in dem Feld ein, das rechts neben dem Namen des Bereichs angezeigt wird.
Fenster Dokumentstruktur anzeigen

Alternative Methode für das Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen:
  1. Öffnen Sie das Dialogfeld Eigenschaften der Dokumentdefinition (Dokumentdefinition > Eigenschaften der Dokumentdefinition… im Fenster des Dokumentdefinitionseditors).
  2. Klicken Sie auf die Registerkarte Zusammenstellung.
  3. Aktivieren Sie die Option Anhangseiten berücksichtigen. Die Zeile Anhangseiten wird in der Liste der Bereiche angezeigt.
  4. Geben Sie die Mindest- und Höchstanzahl für die Anhangseiten an.
Dialogfeld anzeigen

Wenn Sie den Text eines Anhangs speichern möchten, müssen Sie beim Konfigurieren des Datenexports Optionen zum Speichern von Bildern angeben (im Dialogfeld Exporteinstellungen). Wenn Sie Durchsuchbares PDF zum Speichern der Bilder auswählen, wird der Text erkannt und in einer durchsuchbaren PDF-Datei gespeichert.


Verarbeiten nicht strukturierter Dokumente

Mithilfe von ABBYY FlexiCapture 9.0 können Dokumente verarbeitet werden, in denen die Darstellung der Informationen keiner festen Struktur folgt, z. B. Verträge, Briefe, Bestellungen oder Anhänge. Nicht strukturierte Dokumente mit Text oder Bildern, die durch leere Blätter oder Seiten mit Barcodes getrennt sind, werden verarbeitet und in durchsuchbare PDF-Dateien oder Grafikdateien exportiert.

Die Verarbeitung dieser Dokumente umfasst normalerweise das Konvertieren der Dokumente in elektronische Formate sowie das Durchführen einer Suche nach Schlüsselfeldwerten.

Wenn möglich, sollte die Suche nach Schlüsselfeldern (z. B. einer Vertragsnummer) in diesen Dokumenten anhand eines in ABBYY FlexiLayout Studio erstellten FlexiLayouts durchgeführt werden. Siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Wenn die automatische Suche nach Schlüsselfeldern nicht möglich ist, können Sie die Werte manuell eingeben. Erstellen Sie dazu eine Dokumentdefinition mit einem Feld (oder gegebenenfalls mit mehreren Feldern), und aktivieren Sie in den Erkennungseigenschaften dieses Felds die Option Keine Erkennung (Manueller Eingabeblock – wird manuell eingegeben). Beim Durchführen des Überprüfungsvorgangs können Sie dann die Schlüsselfeldwerte manuell eingeben.

Zum Aktivieren der Datenspeicherung müssen Sie den Export konfigurieren. Sie können Schlüsselfeldwerte in Dateien oder Datenbanken exportieren und Dokumentbilder in einem benutzerfreundlichen Format speichern. Sie können Dokumentbilder in Grafikdateien oder durchsuchbaren PDF-Dateien speichern.

Geben Sie Acht beim Zusammenstellen von Seiten zu Dokumenten. Bei nicht strukturierten Dokumenten kann fest definiert werden, zu welchem Dokument eine bestimmte Seite gehört. Für die automatische Zusammenstellung nicht strukturierter Dokumente wird empfohlen, Dokumente durch leere Blätter oder Seiten mit Barcodes zu trennen. Beim Hinzufügen von Bildern zu einem Stapel (durch Scannen, Hinzufügen aus einer Datei oder Erstellen eines Importprofils) müssen Sie dann die Option Für Bilder getrennt durch aktivieren und in der Dropdownliste den Wert Leere Seiten oder Seiten mit Barcode auswählen, je nachdem welche Seiten als Trennseiten verwendet werden sollen. Die Seiten werden automatisch in Dokumenten zusammengestellt. Sie werden bis zur nächsten Trennseite dem aktuellen Dokument hinzugefügt. Ausführliche Informationen hierzu finden Sie unter Hinzufügen von Seitenbildern.


Bearbeitung und Veröffentlichung einer Dokumentdefinition

Im Fenster des Dokumentdefinitionseditors können Dokumentdefinitionen erstellt und bearbeitet werden. In diesem Fenster können Sie das Layout von Feldern und statischen Elementen ändern, die zugehörigen Eigenschaften, Regeln oder Exporteinstellungen bearbeiten usw.

Damit sich Änderungen nicht auf die Arbeit anderer Projektmitarbeiter auswirken, können Sie eine lokale Kopie der Dokumentdefinition bearbeiten, während die zuletzt veröffentlichte Version zur Erkennung verwendet wird. In diesem Modus können Dokumentdefinitionen lokal geändert und getestet werden, während Operatoren erkannte Dokumente weiterhin mit der alten Version überprüfen und exportieren können, auch wenn die Dokumentdefinition erheblich geändert oder gelöscht wurde. Andere Benutzer können an der bearbeiteten Dokumentdefinition keine Änderungen vornehmen. Nach der Bearbeitung der Dokumentdefinition können Sie sie entweder veröffentlichen – die neue Version steht dann zur Dokumenterkennung zur Verfügung – oder alle Änderungen rückgängig machen.

Zum Bearbeiten einer Dokumentdefinition gehen Sie wie folgt vor:

  1. Wählen Sie im Hauptmenü die Menüoption Projekt > Dokumentdefinitionen… aus.
  2. Wählen Sie die zu bearbeitende Dokumentdefinition aus.
  3. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Bearbeiten…, um die Bearbeitung der Dokumentdefinition zu starten. Eine lokale Version der Dokumentdefinition wird auf Ihren Computer kopiert. Andere Benutzer können diese Dokumentdefinition nun nicht mehr bearbeiten.
  4. Nehmen Sie im Dokumentdefinitionseditor die gewünschten Änderungen vor. Speichern Sie die Dokumentdefinition.
  5. Testen Sie die Dokumentdefinition anhand einiger Bilder. Zur Anpassung von Dokumentdefinitionen können Sie Teststapel einsetzen, bei denen die lokale Version der Dokumentdefinition verwendet wird.
  6. Klicken Sie im Dialogfeld Dokumentdefinitionen auf die Schaltfläche Veröffentlichen, um die Dokumentdefinition zu veröffentlichen. Nach der Veröffentlichung wird die neue Version der Dokumentdefinition zum Erkennen der Dokumente in den Arbeitsstapeln verwendet. Die Dokumentdefinition kann nun von anderen Administratoren bearbeitet werden. Wenn Sie die ursprüngliche Dokumentdefinition wiederherstellen möchten, klicken Sie auf Änderungen rückgängig machen.
  7. Die Dokumentdefinitionen werden in der Reihenfolge angewandt, in der sie im Fenster Dokumentdefinitionen aufgelistet werden. Ändern Sie ggfs. die Reihenfolge der Dokumentdefinitionen.
  8. Sie können die Zuordnung eines FlexiLayouts beschleunigen, indem Sie die Option Erstes akzeptables FlexiLayout verwenden auswählen. Das Programm benutzt dann das erste geeignete FlexiLayout. Andernfalls testet das Programm alle FlexiLayouts und wählt dann das am besten übereinstimmende aus.

Neue Dokumentdefinitionen werden unmittelbar nach der Veröffentlichung zur Erkennung und weiteren Dokumentverarbeitung eingesetzt. Für diejenigen Dokumente, deren Verarbeitung zum Zeitpunkt der Veröffentlichung bereits begonnen hat, wird jedoch noch die vorherige Version der Dokumentdefinition benutzt. Sie können die Dokumentdefinition für die gerade verarbeiteten Dokumente aktualisieren, indem Sie Extras>Auf neueste Version aktualisieren wählen. Je nachdem, welche Änderungen an einer Dokumentdefinition vorgenommen wurden, werden Sie gefragt, ob die Dokumente neu erkannt (bei geänderten Erkennungsparametern), die Regeln neu überprüft (bei Regeländerungen) oder die Dokumente neu exportiert (wenn nur die Exporteinstellungen geändert wurden) werden sollen.


Testen von Dokumentdefinitionen

Vor der Masseneingabe von Dokumenten müssen die Dokumentdefinitionen getestet werden. Beim Testen werden Dokumente zu Teststapeln hinzugefügt, da für diese Stapel die lokale Version der Dokumentdefinition verwendet wird. Diese Stapel sind im Hauptfenster des Programms über Projekt>Teststapel verfügbar. Sie können auf die Teststapel auch vom Fenster des Dokumentdefinitionseditors aus zugreifen, indem Sie Extras>Zu Teststapel wechseln… wählen.

Wichtig! Ein Teststapel kann nur von demjenigem Benutzer verwendet werden, der ihn erstellt hat. Gegebenenfalls kann ein Arbeitsstapel als Teststapel verwendet werden. Er dient dann als Bildquelle für den Teststapel.

Eine Dokumentdefinition kann direkt im Dokumentdefinitionseditor mit dem Bild getestet werden, das zum Erstellen der Dokumentdefinition verwendet wurde. Wählen Sie zum Starten des Tests Dokument>Test ausführen. Wie bei einer Dokumentverarbeitung wird das Datenformular angezeigt und es werden Formatfehler, nicht eindeutige Zeichen und Regelfehler ausgegeben.

Sie können das Menü Dokument>Ansicht verwenden, um die Anordnung der Fenster zu verändern, und das Menü Dokument>Überprüfung, um die einzelnen Elemente der Überprüfung, nicht eindeutige Zeichen und Regelfehler durchzugehen. Klicken Sie auf die Schaltfläche Test beenden, oder wählen Sie Dokument>Test beenden um den Test zu beenden.

Hinweis:Im Testmodus führt eine Veränderung der Feldränder nicht dazu, dass das Programm das Feld erneut erfasst. Im Gegensatz dazu ist dies bei einer Änderung der Feldränder im Dokumentfenster der Fall.

Um Ihre Dokumentdefinition mit anderen Bildern zu testen, wählen Sie einen Teststapel aus (Sie können dies tun, indem Sie im Dokumentdefinitionseditor Extras>Zu Teststapel wechseln… wählen). Bevor das Dialogfeld zur Stapelauswahl angezeigt wird, prüft das Programm die aktuelle Dokumentdefinition auf Fehler. Wenn die Dokumentdefinition fehlerfrei ist, wird sie gespeichert und das Dialogfeld zur Stapelauswahl wird angezeigt. Wenn Sie in diesem Dialogfeld einen Stapel auswählen, wird das Programmfenster aktiviert und wechselt automatisch zum neu gewählten Stapel.

Es wird empfohlen, jede Dokumentdefinition mit mindestens 20 Dokumentbildern zu überprüfen (wenn Dokumente von Hand ausgefüllt werden, empfiehlt es sich, Dokumente mit verschiedenen Handschriften zu testen).

Beim Testen muss Folgendes überprüft werden:

  1. Ist eine ausreichende Anzahl markierter Anker und Kennungen für die zielgerichtete Anwendung einer Dokumentdefinition auf ein Bild vorhanden?
  2. Wurden die Feldeigenschaften korrekt konfiguriert?
  3. Wurden die Regeln korrekt konfiguriert?
  4. Wurde der Export korrekt konfiguriert?

Beim Testen müssen Sie die gesamten Vorgänge durchführen, die beim Verarbeiten von Dokumenten anfallen.

Wenn beim Testen Regelfehler, falsche Feldwerte o. Ä. erkannt werden, müssen Sie die Dokumentdefinition bearbeiten, um die Fehler zu korrigieren.

Sie können die Dokumentdefinition erst nach Beheben aller Fehler veröffentlichen und dann mit der Masseneingabe von Dokumenten beginnen.

Arbeiten mit einem konfigurierten Projekt


Klassifikatoren

Klassifikator

Klassifikatoren sind mit ABBYY FlexiLayout Studio erstellte Projekte, die der vorbereitenden Analyse einzelner Seiten und deren Klassifizierung mit einem bestimmten Typ dienen. Seiten können z.B. basierend auf einem FlexiLayout oder alternativem Layout klassifiziert werden. Nachdem ein Klassifikator mit ABBYY FlexiLayout Studio erstellt wurde, kann er von ABBYY FlexiCapture zur Klassifikation von Dokumenten auf Projekt- oder Stapeltypebene verwendet werden.

So fügen Sie auf Projektebene ein Klassifikationsprojekt hinzu:

  1. Öffnen Sie das Projekt.
  2. Wählen Sie im Hauptfenster aus dem Menü Projekt die Option Projekteigenschaften…. Das Dialogfeld Projekteigenschaften öffnet sich.
  3. Klicken Sie auf die Registerkarte Erkennung und dann auf Laden….
  4. Wählen Sie die *.CFL-Datei, die den Klassifikator enthält.

Hinweis: Falls bei der Erstellung eines Stapels als Typ Standard gewählt wurde, werden die in den Projekteigenschaften gewählten Einstellungen zur Verarbeitung verwendet.

So fügen Sie auf Stapeltypebene ein Klassifikationsprojekt hinzu:

  1. Öffnen Sie das Dialogfeld Stapeltypen durch Auswahl von Projekt>Stapeltypen….
  2. Wählen Sie den Stapeltyp aus der Liste und klicken Sie auf Bearbeiten…. Das Dialogfeld Stapeltypeigenschaften öffnet sich.
  3. Klicken Sie auf die Registerkarte Erkennung und dann im Abschnitt Klassifikator auf Laden….
  4. Wählen Sie die *.CFL-Datei, die den Klassifikator enthält.

Klassifikatoren können wie folgt eingesetzt werden:

  • Zur Beschleunigung der Auswahl der Dokumentdefinition. Bei Verwendung eines Klassifikators muss das Programm nicht alle verfügbaren Dokumentendefinitionen untersuchen, sondern kann auf Grundlage der Klassifikationsmerkmale die beste auswählen. Die Suchreihenfolge wird von demjenigen Benutzer festgelegt, der die Klassifikationsmerkmale auswählt und einen Klassifikationsbaum erstellt. Der Zugewinn an Geschwindigkeit ist vor allem bei umfangreichen Projekten mit vielen Dokumentdefinitionen deutlich.
  • Zur Verteilung der Klassifikationsmerkmale im Klassifikationsbaum. Auf der obersten Ebene können Sie z.B. anhand eines Dokumentabschnitts, der den Namen eines bestimmten Unternehmens enthält, von diesem Unternehmen verschickte Dokumente auswählen. Auf der nächsten Ebene können Dokumente nach ihrem Titel oder der Anzahl von Trennzeichen auf einer bestimmten Seite klassifiziert werden.
  • Zur Verwaltung der FlexiLayouts von Drittanbietern. Von Drittanbietern entwickelte FlexiLayouts entsprechen manchmal nicht vollständig deren Dokumenten. In diesem Fall können Sie mit einem Klassifikator Abhilfe schaffen, ohne den Entwickler kontaktieren zu müssen.
  • Zur Beschleunigung von Projekten mit mehrsprachigen Dokumentdefinitionen. Bei Verwendung eines Klassifikators wird die Vorerkennung der Dokumente nur zweimal durchgeführt: Bei der Klassifizierung der Dokumente und bei der Anwendung der gewählten Dokumentdefinition. Ansonsten muss die Vorerkennung für jede Sprache der Dokumentdefinitionen im Projekt durchgeführt werden.

Ausführliche Informationen zu Klassifikatoren finden Sie in den Hilfethemen von ABBYY FlexiLayout Studio.


Bildimportprofile

Die Dokumentverarbeitung beginnt mit dem Hinzufügen neuer Bilder. Normalerweise werden neue Bilder auf der Scanstation hinzugefügt (weitere Anweisungen siehe Scanstation-Hilfe). Neue Bilder können jedoch auch auf der Verifizierungsstation, auf der Projektkonfigurationsstation oder automatisch aus den Hot Foldern hinzugefügt werden.

Sie können die Vorgänge zum Hinzufügen von Bildern auf der Verifizierungsstation und/oder der Projektkonfigurationsstation automatisieren, wenn Bilder regelmäßig aus derselben Quelle genommen werden. Zur Automatisierung des Vorgangs müssen Sie auf der Projektkonfigurationsstation ein Bildimportprofil erstellen. Sie können darüber hinaus auch noch die Verarbeitung eingehender Bilder und das regelmäßige Hinzufügen von Bildern im Hintergrund konfigurieren. Nach dem Festlegen der erforderlichen Einstellungen können die Bilder durch Klicken auf nur eine Schaltfläche gescannt oder aus einer zuvor definierten Quelle importiert und verarbeitet werden (z. B. Entfernen von Störungen). Sie können bei Bedarf die Quelle für den Bildimport oder die entsprechenden Einstellungen ändern.

Wenn sich die Importquellen häufig ändern, können Sie mehrere Importprofile erstellen und zwischen diesen Profilen wechseln, so dass Sie nicht jedes Mal die Einstellungen für die Importquelle ändern müssen.

Erstellen eines Importprofils

Wählen Sie zum Hinzufügen eines Importprofils im Hauptfenster des Programms die Menüoption Projekt > Bildimportprofile… aus. Im daraufhin geöffneten Dialogfeld können Sie Importprofile erstellen, bearbeiten, löschen und kopieren.

Sie können neue Importprofile mithilfe des Assistenten für Importprofile erstellen. Der Assistent kann durch Klicken auf Bildimportprofile im Dialogfeld Neu… ausgeführt werden. Wählen Sie im ersten Schritt des Assistenten eine Importquelle aus, z. B. einen Scanner oder Hot Folder.

Erstellen eines Importprofils mit einem Scanner
  1. Wählen Sie als Importquelle die Option Scanner aus.

    Wichtig! Der Scanner muss angeschlossen sein. Anweisungen zum ordnungsgemäßen Anschluss des Scanners finden Sie in der zugehörigen Dokumentation. Vergewissern Sie sich, dass alle mit dem Scanner gelieferten Softwarekomponenten installiert sind.

  2. Im zweiten Schritt können Sie die Optionen zum Scannen und Verarbeiten der Bilder festlegen:
    • Stil des Dialogfelds 'Scannereinstellungen' Wählen Sie die Verbindung zwischen Programm und Scanner aus:
      • FlexiCapture-Scannereinstellungen: Das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture wird zum Konfigurieren der Scanoptionen verwendet. Klicken Sie auf die Schaltfläche Einstellungen…, um Scanoptionen zu konfigurieren. Wenn Sie die Option Scannereinstellungen vor dem Scannen anzeigen auswählen, wird bei der Auswahl des entsprechenden Importprofils vor dem Scannen das Dialogfeld Scannereinstellungen von ABBYY FlexiCapture angezeigt.
      • Scanoptionen: Das Dialogfeld des entsprechenden Scannertreibers wird zum Konfigurieren der Scanoptionen verwendet. In diesem Fall können Sie beim Erstellen eines Importprofils die Scanoptionen nicht ändern. Das Dialogfeld für die Einstellungen des Scanners wird jedoch jedes Mal vor dem Scannen von Bildern angezeigt.
    • Geben Sie an, ob ein Bild oder mehrere Bilder in einem Durchgang gescannt werden sollen.
  3. Im nächsten Schritt können Sie Optionen zum Hinzufügen von Bildern zu Dokumenten sowie Optionen für die Bildverarbeitung festlegen. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.
  4. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.
Erstellen eines Importprofils mit einem Hot Folder
  1. Wählen Sie als Importquelle die Option Hot Folder aus. Klicken Sie auf die Schaltfläche Durchsuchen…, um den Pfad für den Hot Folder anzugeben.

    Wichtig!Zum Hinzufügen von Bildern aus dem Hot Folder müssen Sie über Lese- und Schreibzugriff für diesen Ordner verfügen.

  2. Legen Sie im zweiten Schritt die Optionen zum Laden von Bildern fest:
    • Hot Folder alle: Aktivieren Sie diese Option, und geben Sie ein Zeitintervall ein, in dem automatisch überprüft wird, ob der Hot Folder neue Bilder enthält.

      Hinweis: Um den Bildimport aus Hot Foldern zu starten, aktivieren Sie Hot Folder für das gegebene Projekt über den Monitor des Verarbeitungsservers.

    • Aktivieren Sie unter Stapeleinstellungen eine der Optionen zum Festlegen des Stapels, dem neue Bilder hinzugefügt werden.
      • Bilder zum aktuellen Stapel hinzufügen: Aktivieren Sie diese Option, um Bilder aus dem Hot Folder zum aktuellen Stapel hinzuzufügen.
      • Bilder zum angegebenen Stapel hinzufügen: Aktivieren Sie diese Option und wählen Sie in der Dropdownliste den Stapel aus, dem Bilder hinzugefügt werden sollen.
      • Neue Stapel für importierte Bilder automatisch erstellen: Aktivieren Sie diese Option, damit für neue Bilder automatisch Stapel erstellt werden. Bestimmen Sie im Feld Stapeltyp den Typ des Stapels. Bestimmen Sie die Registrierungsparameter, falls notwendig, (klicken Sie auf Registrierungsparameter…) und ändern Sie die Prioriät im Feld Priorität.
    • Wählen Sie in der Dropdownliste Anzahl der hinzuzufügenden Dateien einen Wert aus, um die Anzahl der Dateien festzulegen, die dem angegebenen oder neu erstellten Stapel hinzugefügt werden sollen.
      • Entsprechend Beschreibungsdatei: Dateien werden entsprechend der Beschreibung hinzugefügt. Klicken Sie auf die Schaltfläche Einstellungen…, um den Namen und den Typ der Beschreibungsdatei anzugeben. Ausführliche Informationen finden Sie unter Beschreibungsdatei.
      • Alle Dateien: Alle Dateien aus dem Hot Folder werden hinzugefügt.
      • Aus dem Unterverzeichnis – fügt Dateien aus den Unterverzeichnissen hinzu, deren Namen mit dem bestimmten Format übereinstimmen. Klicken Sie zur Bestimmung eines Namenformats auf Einstellungen….
      • Mehrere Dateien: Mehrere Dateien werden hinzugefügt. Klicken Sie zum Angeben der Anzahl der Dateien auf die Schaltfläche Einstellungen…, und geben Sie die Anzahl oder den Wertebereich ein.
      • Hinweis: Wenn Sie eine bestimmte Anzahl von Dateien, z. B. 5, angeben und sich im Hot Folder nur 4 Dateien befinden, werden diese Dateien nicht importiert. Wenn Sie einen Bereich festlegen, z. B. 1-5, werden die restlichen 5 Dateien importiert.
      • Einzelne Datei: Es wird nur eine Datei hinzugefügt.
    • Wählen Sie Bild als Foto behandeln, wenn das Profil eher für das Importieren von Fotos und nicht für gescannte Bilder verwendet werden soll.
  3. Im nächsten Schritt können Sie Optionen zum Hinzufügen von Bildern zu Dokumenten sowie Optionen für die Bildverarbeitung festlegen. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.

  4. Im vierten Schritt werden Sie im Assistenten für Importprofile aufgefordert, Optionen zur Handhabung der Dateien im Hot Folder nach dem Import anzugeben: Erfolgreich importierte Bilder können gelöscht oder in einen bestimmten Ordner verschoben werden. Bilder, die mit Fehlern verarbeitet wurden, können im Hot Folder verbleiben oder ebenfalls in einen bestimmten Ordner verschoben werden. Wenn Bilder verschoben werden sollen, geben Sie die entsprechenden Ordner an.

  5. Im letzten Schritt können Sie den Standardnamen ändern, der dem Importprofil zugewiesen wurde, und gegebenenfalls Kommentare eingeben.

Sie können auch im Dialogfeld Importprofil auswählen Bildimportprofile bearbeiten und erstellen. Es erscheint, wenn Sie aus dem Hauptmenü Datei>Bilder importieren… auswählen.

Markierte Liste Hinzufügen von Seitenbildern


Optionen zur Bildvorverarbeitung

Wenn neue Bilder zu einem Stapel hinzugefügt werden, führt das Programm eine Bildvorverarbeitung durch: Die Bilder werden in Dokumente unterteilt, Störungen werden beseitigt, sie werden gedreht usw.

Die Optionen zur Bildvorverarbeitung können Sie in der Registerkarte Bildvorverarbeitung auswählen. Die Optionen für die Bildvorverarbeitung können für folgende Programmbereiche ausgewählt werden:

  1. Ein Projekt. In diesem Fall werden die ausgewählten Optionen standardmäßig verwendet, wenn neue Bilder manuell zu Projektstapeln hinzugefügt werden. Wählen Sie im Hauptfenster Projekt>Projekteigenschaften… und klicken Sie auf die Registerkarte Bildvorverarbeitung.
  2. Ein Importprofil. Diese Optionen werden verwendet, wenn das entsprechende Importprofil zum Hinzufügen neuer Bilder verwendet wird. Wählen Sie beim Erstellen eines neuen Importprofils die gewünschten Optionen zur Bildvorverarbeitung im Schritt Bildvorverarbeitung aus.
  3. Manuell hinzugefügte Bilder. Klicken Sie beim Hinzufügen von Bildern aus einer Datei auf die Schaltfläche Einstellungen zur Bildvorverarbeitung… im Dialogfeld Bilder laden.

Hinweis: Wenn Bilder manuell gescannt werden, findet keine Bildvorverarbeitung statt. Bilder durchlaufen nur dann die Bildvorverarbeitung, wenn zum Hinzufügen ein Importprofil verwendet wird.

Die Benutzer können aus den folgenden Vorverarbeitungsoptionen beliebig auswählen:

  • Optionen, welche die Vorgehensweise beim Hinzufügen von Bildern zu Dokumenten festlegen:
    • Automatisch, wenn Dokumentdefinition übereinstimmt – Wählen Sie diese Option, wenn Bilder bei der Zuordnung (bei der Erkennung) in Dokumente aufgeteilt werden sollen.In diesem Fall werden Bilder nicht, sobald sie hinzugefügt werden, sofort in Dokumente getrennt, und Dokumente werden erst zusammengestellt, nachdem die Seiten analysiert und anhand der in der entsprechenden Dokumentdefinition beschriebenen Struktur erkennt wurden. Ausführliche Informationen hierzu finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente und Zusammenstellen von Seiten in Dokumenten.
    • Für jede Bilddatei (Für jede Bilddatei),
    • Oder ein neues Dokument wird beim Erreichen einer Trennseite erstellt (Für Bilder getrennt durch).

    • Um leere Seiten als Trennseiten zu verwenden, wählen Sie in der Dropdownliste die Option Leere Seiten aus.
      Wenn Sie Seiten mit Barcodes als Trennblätter verwenden möchten, wählen Sie in der Dropdownliste die Option Seiten mit Barcode aus. Sie können den Barcodetyp und/oder Barcodewert durch Klicken auf die Schaltfläche Einstellungen… festlegen. Wenn kein Barcodetyp oder -wert angegeben ist, wird jede Seite mit einem Barcode als Trennseite verwendet. Andernfalls werden nur Seiten mit den angegebenen Barcodetypen oder -werten verwendet. Wenn die Trennseiten nicht zum Stapel hinzugefügt werden sollen, wählen Sie Trennseiten löschen. Wenn diese Option nicht aktiviert ist, werden die Trennseiten dem Stapel hinzugefügt und in den einzelnen Dokumenten jeweils als erste Seite verwendet.

    Hinweis Sie müssen die Seiten zwischen Dokumenten nicht mithilfe von Trennseiten aufteilen. Trennseiten müssen nur verwendet werden, wenn es aufgrund der Darstellung einer Seite nicht möglich ist zu ermitteln, ob sie zum vorherigen oder nächsten Dokument gehört. Dies ist beispielsweise der Fall, wenn ein Dokument mehrere identische Seiten und der Stapel mehrere solcher Dokumente enthält.

  • Konfigurieren Sie die Optionen für die Bildverarbeitung:
    • Störungen in Bildern entfernen: Verzerrungen in Bildern werden entfernt.
    • Farb- und Graustufenbilder in Schwarz-Weiß-Bilder konvertieren: Die Bilder werden in Schwarz-Weiß-Bilder umgewandelt.
    • Bilder drehen um: Die Bilder werden in die angegebene Richtung gedreht.
  • Entzerrungsoptionen Standardmäßig sind diese Optionen aktiviert, und das Programm entzerrt neu hinzugefügte Bilder auf der Grundlage von schwarzen Quadraten und/oder vertikalen und horizontalen Trennlinien. Es ist nicht zu empfehlen, die Entzerrungsoptionen auszuschalten, solange kein Fehler bei der Entzerrung auftritt (z. B., wenn das Programm einen Stempel oder eine Grafik als Trennlinie interpretiert und versucht, das Bild auf der Grundlage dieser falschen Daten zu entzerren).
    • Zur Korrektur von Verzerrungen schwarze Trennzeichen verwenden : Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von Trennlinien entzerrt.
    • Zur Korrektur von Verzerrungen schwarze Quadrate verwenden: Wenn diese Option aktiviert ist, dann werden die Bilder auf der Grundlage von schwarzen Quadraten entzerrt.


Standardexporteinstellungen

Standardexporteinstellungen werden beim Exportieren in eine Datei oder Datenbank ohne Verwendung von Dokumentdefinitionseinstellungen sowie für Dokumentdefinitionen verwendet, in denen keine Exporteinstellungen konfiguriert wurden.

Exporteinstellungen sind für jede Dokumentdefinition konfiguriert. Es kann jedoch vorkommen, dass Sie die Daten in einen anderen Speicherort exportieren möchten, z. B. bei einem Testexport. In diesem Fall können Sie die Daten über die Exportschaltfläche mit Einstellungen, die von den in der Dokumentdefinition vorhandenen Vorgaben abweichen, in eine Datei oder Datenbank exportieren. Siehe dazu Exportieren erkannter Daten. Beim erstmaligen Export werden die Standardeinstellungen verwendet. Wenn die Exporteinstellungen geändert werden, werden jeweils die zuletzt verwendeten Einstellungen gespeichert.

Die Standardeinstellungen zum Exportieren von Daten in eine Datei oder Datenbank können auf der Registerkarte Exportieren des Dialogfelds Projekteigenschaften (Menüoption Projekt > Projekteigenschaften… im Hauptfenster) konfiguriert werden. Auf dieser Registerkarte werden die aktuellen Standardexporteinstellungen angezeigt. Sie können die Einstellungen für den Export in eine Datei oder in eine Datenbank konfigurieren. Wenn Sie die Standardexporteinstellungen ändern möchten, klicken Sie auf Bearbeiten…, und legen Sie Exporteinstellungen fest, die den Exporteinstellungen in der Dokumentdefinition ähneln (siehe Konfigurieren des Datenexports).


Stapel

Zu verarbeitende Dokumente werden in Stapeln zusammengefasst. Das Prinzip der Dokumentgruppierung in Stapel wird vom Benutzer bestimmt. Der Benutzer kann beispielsweise wählen, alle Dokumente als einen Stapel zu verarbeiten oder die Dokumente zu gruppieren, die am gleichen Tag importiert oder in einem Durchgang gescannt wurden.

Stapel werden an den Verarbeitungsstationen automatisch erstellt, wenn Bilder aus Hot Foldern importiert werden. Stapel können an der Scanstation vom Operator manuell oder automatisch erstellt werden, wenn die entsprechenden Scanprofile verfügbar sind. Wenn ein Stapel erstellt wird, sollte ein Typ spezifiziert werden, der definiert, wie der Stapel verarbeitet werden muss.

Seitenbilder werden während der Verarbeitung hinzugefügt. Siehe Hinzufügen von Seitenbildern für weitere Einzelheiten.

An der Projektkonfigurationsstation können Dokumentdefinitionen durch das Erstellen von Stapeln, Hinzufügen von Dokumentbildern zu den Stapeln und deren Verarbeitung (d. h. Erkennung, Verifizierung und Export der Ergebnisse) getestet und korrigiert werden. Wenn Sie einen neuen Stapel erstellen möchten, klicken Sie mit der rechten Maustaste auf die Stapelliste im Hauptfenster und wählen Sie im Kontextmenü die Option Neuer Stapel aus.

Arbeits- und Teststapel

Die Teststapel werden vom Batch Setup Operator verwendet, um die Dokumentdefinitionen zu testen und zu korrigieren. Arbeitsstapel sind für die Verarbeitung von Dokumenten mit ABBYY FlexiCapture 9.0 vorgesehen. Der Batch Setup Operator kann auch auf Arbeitsstapel zugreifen, wenn während der Verarbeitung Fehler auftreten. Im Falle eines Fehlers kann der Operator den Stapel öffnen und den Fehler beheben. Teststapel und Arbeitsstapel unterscheiden sich dadurch, dass die lokale Dokumentdefinition verwendet wird, um die Dokumente eines Teststapels zu verarbeiten, während eine veröffentlichte Dokumentdefinition verwendet wird, um die Dokumente eines Arbeitsstapels zu verarbeiten. Siehe Bearbeitung und Veröffentlichung einer Dokumentdefinition.

Um die Stapelliste zu öffnen, wählen Sie die Option Stapel oder Teststapel aus dem Menü 'Ansicht' in der Projektkonfigurationsstation.


Indexfelder

Um die Suche und Verarbeitung von Dokumenten zu vereinfachen, können Sie Dokumente mit den Werten beliebiger Felder aus einer Dokumentdefinition indizieren. Sie können dann zusätzlich zu den allgemeinen Informationen in den Dokumentlisten im Hauptfenster des Programms für jedes Dokument die Werte der Indexfelder ausgeben, die Dokumente nach diesen Werten sortieren und die gewünschten Dokumente auf einfache Weise suchen.

Aktivieren Sie für die Indizierung nach Feldwerten für das entsprechende Feld die Option Indexfeld (Registerkarte Allgemein im Dokumentdefinitionseditor).

So zeigen Sie den Wert des Indexfelds in der Dokumentliste an:

  • Öffnen Sie im Hauptfenster des Programms einen Dokumentstapel, und aktivieren Sie den Modus für die detaillierte Dokumentliste (Schaltfläche [image] in der Symbolleiste).
  • Klicken Sie mit der rechten Maustaste in den Bereich der Tabellenkopfzeile (Spaltennamen), und wählen Sie in der Dropdownliste die Option Anpassen… aus.
  • Klicken Sie im Dialogfeld Spalten auswählen auf die Schaltfläche Neu….
  • Klicken Sie im Dialogfeld Spalte bearbeiten auf die Schaltfläche Auswählen… rechts neben dem IDD_SH_NEW_SUPER_GRID_COLUMN::IDC_INDEXED_FIELD_NEW_COLUMNIndexfeld. Wählen Sie im daraufhin geöffneten Dialogfeld eines der Felder aus, bei denen die Indexfeld aktiviert ist. Sie können auch einen Spaltennamen eingeben und die entsprechende Indizierungsmethode festlegen.
  • In der Tabelle wird eine neue Spalte mit dem Wert des Indexfelds angezeigt. Klicken Sie auf diese Spalte, um Dokumente nach dem Wert des Indexfelds zu sortieren.


Arbeiten mit einem konfigurierten Projekt

Dokumente durchlaufen verschiedene Verarbeitungsstufen. Bei der Erstellung und beim Einrichten eines Projekts sollten Sie spezifizieren, bei welcher Stufe und unter welchen Umständen eine Interaktion mit dem Operator oder eine Fehlerbehebung erforderlich ist. Für diese Stufen werden Taskwarteschlangen erstellt. Zusätzlich ist eine spezielle Ausnahmewarteschlange für Problemdokumente verfügbar.

Operatoren sind die Benutzer des Systems, die die Verarbeitung überwachen und Fehler in Dokumenten oder in Stapeln beheben. Die nachstehende Tabelle listet ABBYY FlexiCapture-Operatoren und die Stationen und Reihen auf, die ihnen zur Verfügung stehen.

Operator | Stationen | Warteschlangen | Funktionen
Überwachungsoperator | Verwaltungs- und Überwachungskonsole | - | Überwachung des Systemvorgangs
Scan-Operator | Scanstation | - | Das Scannen von Dokumenten oder das Importieren von Dokumentbildern, das Senden von Dokumenten in die Verarbeitung
Datenüberprüfungsoperator | Datenverifizierungsstation Überprüfungsstation (nur Gruppen- und Feldüberprüfung) | Datenüberprüfung | Das Überprüfen und Beheben von unzuverlässig erkannten Zeichen (Gruppen- und Feldüberprüfung)
Überprüfungsoperator | Datenverifizierungsstation Datenverifizierungsstation | Datenüberprüfung Überprüfung Überprüfen der Dokumentzusammenstellung Stapelintegritätsprüfung | Dieselben Daten wie der Überprüfungsoperator + Überprüfung und Beheben von Fehlern bei Dokument- und Stapelzusammenstellung
Leitender Überprüfungsoperator | Datenverifizierungsstation Verifizierungsstation | Datenüberprüfung Überprüfung Überprüfen der Dokumentzusammenstellung Stapelintegritätsprüfung Exportbestätigung Ausnahmen | Dieselben Daten wie der Überprüfungsoperator + Bestätigung des Dokumentexports, Verarbeitungsausnahmen

Operatoren starten ihre entsprechenden Stationen und führen die erforderlichen Vorgänge in Übereinstimmung mit den ihnen erteilten Zugangsberechtigungen durch.


Workflow

Dokumente werden in mehreren Arbeitsphasen verarbeitet. In der Verarbeitungsphase, die automatisiert oder unter Mitwirkung eines Operators ablaufen kann, werden die Dokumente konvertiert. Die Phasen sind in einer fest vorgegebenen Reihenfolge angeordnet: Bevor ein Dokument eine bestimmte Phase erreicht, muss es alle früheren Phasen erfolgreich durchlaufen haben. Allgemein gesprochen umfasst die Dokumentverarbeitung die folgenden Phasen: Hinzufügen von Bildern, Erkennung, Überprüfung und Export. Die Überprüfungsphase muss nicht unbedingt stattfinden. Die anderen Phasen sind obligatorisch.

In jeder Phase wird eine Taskwarteschlange gebildet, die eine Liste der zu verarbeitenden Dokumente enthält. Im weiteren Verlauf der Verarbeitung wandern die Dokumente von der ersten Warteschlange (Erkennung) bis zur letzten (Export). In der Regel entsprechen die Warteschlangen den Verarbeitungsphasen. Es gibt jedoch auch gesonderte Warteschlangen, z.B. die Ausnahmenwarteschlange.

Phasen

  1. Import von Bildern.

    Die Bilder können automatisch aus Hot Foldern geladen oder vom Operator der Scanstation hinzugefügt werden. Der Scanoperator kann entweder Dokumente einscannen oder die Abbilder bereits gescannter Dokumente importieren. Zur Automatisierung dieses Vorgangs kann der Scanoperator Scanprofile erstellen (Hinzufügen der Bilder mit vordefinierten Einstellungen mit nur einem Mausklick).

  2. Erkennung. Die Erkennungswarteschlange wird automatisch von der Verarbeitungsstation abgearbeitet.
  3. Überprüfung. Die Überprüfungswarteschlange wird vom Operator der Verifizierungsstation abgearbeitet.
  4. Export. Die Exportwarteschlange wird automatisch von der Verarbeitungsstation abgearbeitet.

Wenn große Mengen verarbeitet werden müssen, kann der Überprüfungsschritt in kleinere Schritte unterteilt werden. Jeder Schritt wird dann von seinem eigenen Operator ausgeführt.

Die folgenden separaten Warteschlangen können erstellt werden:

  • Überprüfen der Dokumentzusammenstellung
  • Datenüberprüfung: Gruppen- und Feldüberprüfung uneindeutiger Zeichen und Korrektur von Formatierungsfehlern
  • Verifizierung: Prüfung von Regeln und Dokumentfenstern
  • Stapelintegritätsprüfung
  • Exportbestätigung

Hinweis: Die Warteschlangen werden für jeden Stapeltyp einzeln festgelegt.

Die Tasks aus den Warteschlangen werden von den Operatoren abgearbeitet, die über die notwendigen Zugriffsrechte verfügen:

  • Datenüberprüfungsoperator – nur die Datenüberprüfungswarteschlange
  • Überprüfungsoperator – Datenüberprüfung, Verifizierung, Prüfung der Dokumentzusammenstellung, Stapelintegritätsprüfung
  • Leitender Überprüfungsoperator – alle Warteschlangen

Hinweis: Die Datenverifizierungsstation lässt ihre Operatoren nur die Tasks aus der Datenüberprüfungswarteschlange bearbeiten, unabhängig von den Rechten des jeweiligen Operators.


Hinzufügen von Seitenbildern

Die Verarbeitung von Dokumenten beginnt mit dem Bildimport, d. h. dem Hinzufügen von Bildern der Dokumentseiten zu einem Projekt. Die Bilder werden aus der Scanstation oder automatisch aus den Hot Foldern empfangen.

Bildimport im Hintergrund

Bildimporte können im Hintergrundmodus durchgeführt werden, wenn ein entsprechendes Importprofil konfiguriert wurde. Bilder aus dem Hot Folder werden automatisch in das System importiert. In dem in den Einstellungen festgelegten Zeitintervall wird automatisch überprüft, ob der Hot Folder neue Bilder enthält.

Bilder können folgendermaßen zu Stapeln hinzugefügt werden:

  1. Durch Laden zuvor gespeicherter Bilder aus Dateien;
  2. Durch Scannen von Bildern;
  3. Durch Importieren der Bilder mit einem der Bildimportprofile, die zuvor von einem Administrator erstellt wurden (siehe Bildimportprofile.)

Bilder manuell hinzufügen

Bilder können, falls notwendig, dem Stapel manuell auf der Verifizierungsstation (vom leitenden Überprüfungsoperator) oder auf der Projektkonfigurationsstation hinzugefügt werden. Bilder werden im Stapelansichtsmodus hinzugefügt. Öffnen Sie den Stapel, dem Sie Bilder hinzufügen möchten oder wählen Sie einfach den Stapel aus der Liste.

Folgende Methoden sind für das Hinzufügen von Bildern zum Stapel verfügbar:

  • Laden zuvor gespeicherter Bilddateien
  • Scannen von Dokumenten
  • Importieren der Bilder mit einem der zuvor erstellten Bildimportprofile (siehe Bildimportprofile)

Klicken Sie mit der rechten Maustaste auf den Stapel und wählen Sie die entsprechende Option aus dem Kontextmenü, um die Bilder hinzuzufügen.

Hinzufügen von Bildern aus einer Datei

Wenn Sie Bilder aus einer Datei laden möchten, wählen Sie die Option Bilder laden… oder drücken Sie Strg+O auf der Tastatur. Wählen Sie im daraufhin geöffneten Dialogfeld die gewünschten Bilddateien aus, und konfigurieren Sie die folgenden Optionen für den Bildimport:

  • Neues Dokument erstellen – für die hinzugefügten Bilder werden neue Dokumente erstellt.
  • Zum aktuellen Dokument hinzufügen – Die Bilder werden zum aktuellen, markierten Dokument hinzugefügt.
  • Sie können zudem Optionen für die Vorverarbeitung eines Bilds auswählen. Klicken Sie im Dialogfeld für die Bildvorverarbeitung auf die Schaltfläche Einstellungen zur Bildvorverarbeitung…, und wählen Sie die gewünschten Optionen im angezeigten Dialogfeld aus. Detaillierte Informationen finden Sie unter Optionen zur Bildvorverarbeitung.

Scannen von Bildern

Wählen Sie zum Hinzufügen von Bildern von einem Scanner die Option Bilder scannen… aus. Wählen Sie einen Scanner aus, konfigurieren Sie die Scanoptionen, und scannen Sie anschließend die Bilder.

Hinzufügen von Bildern mithilfe von Importprofilen

Wenn vom Administrator Importprofile konfiguriert wurden, werden ihre Namen im Menü der Importschaltfläche angezeigt. Um Bilder zu importieren, müssen Sie lediglich eines der Importprofile auswählen.

Wenn Sie Bilder importieren… auswählen, wird das Dialogfeld Importprofil auswählen geöffnet. Wählen Sie in der Liste ein Importprofil aus, und klicken Sie auf die Schaltfläche Importieren, um den Importvorgang zu starten.


Konfigurieren von Scanoptionen

Normalerweise kommen zu verarbeitende Dokumente von der Scanstation oder dem Hot Folder. Dokumente können jedoch auch auf der Verifizierungsstation oder auf der Projektkonfigurationsstation gescannt werden. In diesem Fall müssen die erforderlichen Scanparameter ausgewählt werden.

Die Qualität der Erkennung hängt größtenteils von der Qualität der gescannten Bilder ab. Die Qualität der Bilder kann durch Konfigurieren der allgemeinen Scaneinstellungen für den Bildtyp, die Auflösung und die Helligkeit reguliert werden.

Beim Scannen von Bildern mit ABBYY FlexiCapture kann auf zweierlei Weise eine Verbindung zwischen dem Programm und den Scannern über den TWAIN- oder ISIS-Treiber hergestellt werden:

  • Über die Schnittstelle von ABBYY FlexiCapture:
    In diesem Fall werden die Scanoptionen im ABBYY FlexiCapture-Dialogfeld Scannereinstellungen konfiguriert. Die Scanoptionen können beim Erstellen eines Importprofils festgelegt werden, bei dem der Scanner als Importquelle angegeben ist.
  • Über die Schnittstelle des TWAIN- oder ISIS-Treibers des Scanners:
    Dabei werden die Scanoptionen im Dialogfeld des entsprechenden Scannertreibers konfiguriert. Dieses Dialogfeld wird automatisch geöffnet, wenn Sie im Dropdownmenü der Importschaltfläche die Option Bilder scannen… auswählen.

Allgemeine Scanoptionen

  • Bildtyp – Das Scannen in Graustufen (256 Grautöne) ist der optimale Modus für das Erkennungssystem. Wenn Sie im Graustufenmodus scannen, wird der Grad der Helligkeit automatisch ausgewählt.

    Durch den Bildtyp Schwarz-weiß erhöht sich die Scangeschwindigkeit auf Kosten einiger Buchstabeninformationen. Dies wirkt sich möglicherweise auf die Erkennungsqualität von Dokumenten mit mittlerer und schlechter Druckqualität aus.
    Wenn Farbelemente eines Dokuments (Bilder, farbige Buchstaben oder Farbhintergrund) im elektronischen Dokument farbig dargestellt werden sollen, muss dagegen der Bildtyp Farbe ausgewählt werden. In anderen Fällen eignet sich wiederum der Bildtyp Graustufen besser.

    • Die Werte für
  • Helligkeit und Kontrast müssen so ausgewählt werden, dass erstens die Ankerblöcke beibehalten werden und zweitens die zur Erkennung vorgesehenen Bilder der Blöcke möglichst klar und eindeutig dargestellt werden.
    In den meisten Fällen eignet sich hierfür der mittlere Helligkeitswert von 50 %.
    Unter Umständen müssen Sie beim Scannen bestimmter Dokumente im Schwarz-Weiß-Modus den Helligkeitsgrad ändern.
  • Auflösung –Für die Verarbeitung von Formularen, die von Hand ausgefüllt wurden, empfiehlt sich im Schwarz-Weiß-Modus eine Auflösung von 300 dpi und im Graustufenmodus eine Auflösung von 200 dpi. Die Auflösung gescannter Formulare muss mit der Auflösung des Vorlagenbilds übereinstimmen.

Hinweis:

  1. Scanvorgänge mit einer Auflösung von 400 bis 600 dpi anstelle von 300 dpi sowie im Graustufen- oder Farbmodus anstelle des Schwarz-Weiß-Modus dauern unter Umständen erheblich länger. Bei einigen Scannermodellen dauern Scanvorgänge mit einer Auflösung von 600 dpi viermal so lange wie Scanvorgänge mit einer Auflösung von 300 dpi. Vom Scannen mit einer Auflösung unter 200 dpi wird abgeraten.
  2. Wenn Sie die Scanoptionen im Dialogfeld des Scannertreibers konfigurieren, können die entsprechenden Optionen je nach Scannermodell abweichende Bezeichnungen tragen. Die Helligkeit wird beispielsweise als Schwellenwert bezeichnet oder mit einer Sonne oder einem schwarz-weißen Kreis angezeigt. Erklärungen zu den einzelnen Einstellungen finden Sie in der Dokumentation des jeweiligen Scanners.
Tipps zum Scanmodus
  1. Scannen von Formularen mit Farbhintergrund mit einem Schwarz-Weiß-Scanner. Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie den Scanner mit einer entsprechenden Lampe zum Filtern des Lichts ausrüsten. Verwenden Sie bei rosafarbenen Formularen eine rote Lampe und bei grünen Formularen – eine grüne Lampe.
  2. Scannen von Formularen mit Farbhintergrund mit einem Farbscanner. Damit der Hintergrund beim Scannen ausgeblendet wird, müssen Sie in den Scannereinstellungen den Filtermodus für die entsprechende Farbe konfigurieren.
  3. Scannen von Formularen mit Farbhintergrund in hellen Farbtönen. Wenn Sie Formulare mit hellen Farbtönen verarbeiten, wird der Hintergrund aufgrund der geringen Farbstärke beim Scannen mit einer weißen Lampe möglicherweise auch ausgeblendet, wenn in den Scaneinstellungen keine Farbfilter ausgewählt sind. In der Regel wird das Verfahren zum Scannen von Formularen beim Entwerfen der Formulare gewählt.
Tipps zur Auswahl des Helligkeitsgrads
  1. Ein gescanntes Bild muss lesbar sein (öffnen Sie das gescannte Bild im Dokumentfenster).
  2. Wenn Buchstaben im gescannten Bild unvollständig, hell oder ausgebrochen angezeigt werden, gehen Sie folgendermaßen vor:
    • Verringern Sie den Helligkeitsgrad und erhöhen Sie den Kontrast (das Bild wird dunkler) oder
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).
  3. Wenn das gescannte Bild einen fleckigen Hintergrund, verzerrte, verschmierte oder verschwommene Zeichen oder dunkle bzw. fette Buchstaben aufweist, gehen Sie wie folgt vor:
    • Erhöhen Sie den Helligkeitsgrad (das Bild wird heller) oder
    • Scannen Sie das Bild in Graustufen (der Helligkeitsgrad wird dann automatisch ausgewählt).


Erkennung

Die Dokumenterkennung wird auf den Verarbeitungsstationen automatisch ausgeführt.

Das System wählt die zugeordneten Dokumentdefinitionen basierend auf Ankerelementen und Objekten zur Identifizierung aus und erkennt die Daten in den Feldern, die den Feldern der ausgewählten Dokumentdefinition entsprechen.

Das Verhältnis von zuverlässig erkannten Zeichen zur Gesamtanzahl der Zeichen wird in der Spalte Grad der Zuverlässigkeit angezeigt.

Wenn Änderungen am Projekt während der Erkennung vorgenommen werden und wenn das Projekt einen Überprüfungsschritt enthält, können der Überprüfungsoperator und der leitende Überprüfungsoperator die Dokumenterkennung manuell wiederholen und dabei die neuen Einstellungen verwenden. Um die Dokumente neu zu erkennen, starten Sie die Verifizierungsstation und wählen dann aus dem Hauptmenü Extras>Auf neueste Version aktualisieren.


Voranalyse von Bildern und Zuordnen von Dokumentdefinitionen

Erkennung, Analyse und Zuordnung von Dokumentdefinitionen werden automatisch durchgeführt. Der Überprüfungsoperator und der leitende Überprüfungsoperator können die Analyse und Zuordnung der Dokumentdefinition jedoch manuell durchführen, indem auf der Verifizierungsstation Extras > Neu analysieren ausgewählt wird. Wenn eine Dokumentdefinition auf ein Dokument passt, werden die Seite und ihr Dokument die entsprechenden Namen haben. Wenn keine der Dokumentdefinitionen im Projekt zu einem Bild passt, wird die Seite nicht verarbeitet.

Vor der Erkennung können Sie analysieren oder festlegen, welche Dokumentdefinition einer bestimmten Seite zugeordnet werden kann. Wählen Sie dazu im Hauptmenü die Option Erkennung > Analysieren. Wenn eine Dokumentdefinition zugeordnet werden kann, werden die Seite und das Dokument entsprechend benannt. Wenn dem Bild keine Dokumentdefinition zugeordnet werden kann, wird die Seite nicht verarbeitet.

Sie können einer Seite oder einem vollständigen Dokument auch eine bestimmte Dokumentdefinition zuordnen. Größtenteils werden Seiten ordnungsgemäß erstellten Dokumentdefinitionen automatisch zugeordnet. In einigen Fällen müssen Sie jedoch möglicherweise Dokumentdefinitionen manuell zuordnen.

So ordnen Sie eine Dokumentdefinition zu:

  1. Markieren Sie das entsprechende Dokument;
  2. Wählen Sie im Kontextmenü des Dokuments Dokumentdefinitionsbereich zuordnen… oder im Hauptmenü des Dokuments die Option Erkennung>Dokumentdefinition zuordnen…;
  3. Im Dialogfeld Dokumentdefinition auswählen, das geöffnet wird, wählen Sie eine der Dokumentdefinitionen und klicken Sie auf OK.

Nachdem die ausgewählte Dokumentdefinition erfolgreich zugeordnet wurde, wird dem Dokument und den zugehörigen Seiten der Name der entsprechenden Dokumentdefinition und der zugehörigen Bereiche zugewiesen.

So ordnen Sie einer Seite eine Dokumentdefinition zu:

  1. Markieren Sie die entsprechende Seite;
  2. Wählen Sie im Kontextmenü des Dokuments Dokumentdefinitionsbereich zuordnen… oder im Hauptmenü der Seite die Option Erkennung>Dokumentdefinition zuordnen…;
  3. Im Dialogfeld Dokumentdefinition für Zuordnung auswählen, das geöffnet wird, wählen Sie eine der Dokumentdefinitionen und klicken Sie auf OK.

Wenn die Dokumentdefinition erfolgreich zugeordnet wird, wird der ausgewählten Seite der Name des entsprechenden Dokumentdefinitionbereichs zugeordnet.


Überprüfung erkannter Daten

Die Überprüfung der erkannten Daten ist die arbeitsintensivste Aufgabe von Operatoren. Aus diesem Grund wurde der Überprüfungsprozess in ABBYY FlexiCapture 9.0 so konzipiert, dass einerseits die Benutzerfreundlichkeit für Operatoren im Vordergrund steht und sich andererseits die Anzahl möglicher Fehler auf ein Minimum reduziert.

Wenn bestimmte Zeichen nicht mit absoluter Sicherheit erkannt werden können, werden sie im Programm als nicht eindeutig erkannt gekennzeichnet. Bei der Überprüfung wird geprüft, ob diese Zeichen richtig erkannt wurden. Bei Bedarf werden dann eventuelle Korrekturen vorgenommen.

Die regelbasierte Validierung wird automatisch durchgeführt. Wenn Feldwerte den festgelegten Regeln entsprechen, können die entsprechenden Felder als eindeutig erkannt gekennzeichnet und aus dem Validierungsvorgang ausgenommen werden. Felder, deren Werte nicht den Regeln entsprechen, werden zur Überprüfung weitergeleitet.

Bei mehrseitigen Dokumenten muss zunächst die Zusammenstellung der Seiten zu Dokumenten überprüft werden.

Dann wird der Überprüfungsvorgang durchgeführt. Die Überprüfung erfolgt in zwei Schritten: Zunächst wird eine Gruppen- und anschließend eine Feldüberprüfung durchgeführt. Wenn eine Dokumentdefinition keine Felder zur Gruppen- oder Feldüberprüfung enthält (siehe Feldüberprüfungseigenschaften), wird der entsprechende Überprüfungsschritt übersprungen.

Nach der Gruppen- und Feldüberprüfung können Sie die Zeichen im Dokumentfenster überprüfen. Die Zeichen, die in früheren Schritten nicht bestätigt wurden, werden weiterhin rot angezeigt.

Durch Klicken auf die Schaltfläche [image] oder [image] in der Symbolleiste des Hauptfensters können Sie durch die einzelnen Fehler navigieren. Dabei werden alle Fehlerkategorien angezeigt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler usw.

Zusammenstellen von Seiten zu Dokumenten
Gruppenüberprüfung
Feldüberprüfung
Überprüfung im Dokumentfenster
Regelbasierte Validierung


Zusammenstellen von Seiten zu Dokumenten

Seiten werden automatisch zu Dokumenten zusammengestellt. Beim Erstellen von Dokumentdefinitionen für mehrseitige Dokumente müssen Sie hierfür die entsprechenden Zusammenstellungsregeln definieren. Sie können zudem die Überprüfung von Schlüsselfeldern festlegen.

Operatoren müssen eventuelle Fehler bei der Dokumentzusammenstellung identifizieren und korrigieren.

Zusammenstellungsfehler können am einfachsten in der Gliederungsansicht korrigiert werden. In dieser Ansicht sind die Seitenbilder und die entsprechenden Dokumente übersichtlich dargestellt. Klicken Sie auf die Schaltfläche [image], um in die Gliederungsansicht zu wechseln.

Hinweis:Sie können die Größe der Seitengliederung ändern, um Details anzuzeigen. Drehen Sie dazu bei gedrückter Strg-Taste das Scrollrad der Maus in die gewünschte Richtung.

Hinweis:Die Reihenfolge der Bereiche wird beim Erstellen der Dokumentdefinition nicht überprüft, wenn die Option Überprüfung der Bereichsreihenfolge deaktivieren auf der Registerkarte Zusammenstellung ausgewählt wurde. Das Programm wird weiterhin überprüfen, ob alle Bereiche im Dokument vorhanden sind, aber die Reihenfolge wird dabei ignoriert.

Sie müssen beim Erstellen einer Dokumentdefinition eine Regel für die Dokumentzusammenstellung definieren. Reihenfolge und Anzahl wiederholter Dokumentbereiche. Zudem können Sie die Überprüfung der Zusammenstellung anhand der Werte von Schlüsselfeldern konfigurieren. Dabei müssen die Werte von Schlüsselfeldern auf sämtlichen Seiten des Dokuments gleich sein.

Dokumente mit Zusammenstellungsfehlern sind durch das Symbol [image] gekennzeichnet. Die entsprechende Fehlerbeschreibung wird unterhalb der Dokumentdefinition in roter Schrift angezeigt.

Korrigieren von Zusammenstellungsfehlern

  1. Falsche Reihenfolge der Seiten in einem Dokument

    Möglicherweise enthält das Dokument zu viele oder zu wenige Seiten, oder die Dokumentseiten sind nicht in der richtigen Reihenfolge angeordnet. Wenn Sie den entsprechenden Tipp lesen möchten, setzen Sie den Mauszeiger auf die Seite mit dem roten Kreuz.

    Diese Fehler können Sie korrigieren, indem Sie die entsprechende Seite mit dem Mauszeiger in einem Dokument oder zwischen verschiedenen Dokumenten verschieben.

    Seiten mehrerer Dokumente können wie folgt in einem Dokument zusammengeführt werden:

    • Markieren Sie die entsprechenden Dokumente (durch Klicken bei gedrückter Strg-Taste können Sie mehrere Dokumente markieren).
    • Klicken Sie mit der rechten Maustaste, und wählen Sie im Kontextmenü die Option Verbinden aus.

    So trennen Sie Seiten in einem Dokument und positionieren sie jeweils in einem separaten Dokument:

    • Markieren Sie das Dokument, in dem Seiten getrennt werden sollen.
    • Wählen Sie im Kontextmenü die Option Teilen aus.

  2. Wenn in einer Dokumentdefinition festgelegt ist, dass die Zusammenstellung von Seiten anhand von Schlüsselfeldern überprüft wird, werden die Schlüsselfeldwerte jeweils unterhalb der Seitenbilder angezeigt.

    • Bei Übereinstimmung werden die Werte grau angezeigt.
    • Bei Nichtübereinstimmung werden sie rot angezeigt.

    Schlüsselfelder stimmen möglicherweise nicht überein, wenn sie falsch erkannt oder ausgefüllt wurden. Überprüfen Sie die Werte der Schlüsselfelder. Wenn die Werte weiterhin nicht übereinstimmen, handelt es sich wahrscheinlich nicht um die Seiten ein und desselben Dokuments. Wenn die Seiten in der falschen Reihenfolge angeordnet sind, suchen Sie Seiten mit identischen Schlüsselfeldern, und stellen Sie sie zu Dokumenten zusammen (siehe Punkt 1).


Gruppenüberprüfung

Bei der Gruppenüberprüfung werden Zeichenbilder, die mit identischen Werten erkannt wurden, gruppiert und im Überprüfungsfenster angezeigt, so dass der Operator die von der Gruppe abweichenden Zeichen einfach identifizieren und korrigieren kann.

Fenster für die Gruppenüberprüfung anzeigen

Während der Gruppenüberprüfung können Sie den Kontext des überprüften Zeichens anzeigen, indem Sie im Kontextmenü des markierten Zeichens die Option Zeichenbild anzeigen auswählen oder die Taste F2 drücken.

Sie können zudem einen Modus aktivieren, in dem das Feld des überprüften Zeichens angezeigt wird, wenn Sie den Mauszeiger auf das Zeichen setzen. Wählen Sie dazu im Überprüfungsfenster die Menüoptionen Ansicht >Feldbild > Feldbild anzeigen aus, oder drücken Sie Strg+I auf der Tastatur.

Falsch erkannte Zeichen können wie folgt korrigiert werden: Markieren Sie das Zeichen, das nicht mit der Zeichengruppe übereinstimmt, und geben Sie das richtige Zeichen ein. Dieser Wert wird links oben im Zeichenbild grün angezeigt.

Wenn selbst nach der Anzeige eines Zeichens in seinem Kontext Zweifel bestehen, klicken Sie mit der linken Taste auf das Zeichen. Es wird dann mit einem roten Fragezeichen gekennzeichnet.

Der Status von Zeichen kann darüber hinaus über die Schaltfläche Status ändern in der Symbolleiste geändert werden.

Durch Auswählen von Bestätigen im Kontextmenü können Sie richtig erkannte Zeichen bestätigen. Wenn Sie alle Zeichen auf einmal bestätigen möchten, klicken Sie in der Symbolleiste auf die Schaltfläche Alle bestätigen.

Hinweis:Beim Erstellen einer Dokumentdefinition können Sie beim Festlegen der Feldeigenschaften die Überprüfungsoptionen ändern. Bei Zeichen, für die im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung die Option Zeichen der Gruppenüberprüfung übergeben aktiviert ist, wird eine Gruppenüberprüfung durchgeführt. Siehe Feldüberprüfungseigenschaften. Es empfiehlt sich, die Gruppenüberprüfung bei Auswahlfeldern sowie Feldern durchzuführen, in denen nur Zahlen eingegeben werden können. Buchstaben sollten dagegen im Kontext eines Felds überprüft werden.


Feldüberprüfung

Die Feldüberprüfung dient zur effektiven Korrektur von Formatfehlern bei leicht erkennbaren Feldern, d. h. Feldern, deren Wertebereich bekannt ist oder einfach identifiziert werden kann. Beispiele für diese Felder sind Länder oder Orte. da die Werte dieser Felder im Voraus bekannt sind.

Um zu entscheiden, wie der Fehler in einem Feld korrigiert werden muss, muss der Benutzer lediglich das Feld anzeigen und den entsprechenden Wertebereich kennen. Sowohl Eingabefehler als auch Fehler beim Feldformat können berichtigt werden.

Fenster für die Feldüberprüfung anzeigen

Sie können falsch erkannte Zeichen mit den Standardmodi von Texteditoren korrigieren, d. h. Einfügen oder Ersetzen von Zeichen. Durch Drücken der Einfg-Taste auf der Tastatur können Sie zwischen den beiden Modi wechseln.

Sie können die Erkennungsergebnisse der einzelnen Felder überprüfen, sie gegebenenfalls korrigieren und durch Klicken auf die Schaltfläche Feld bestätigen bestätigen.

Die Werte dieser Felder müssen berichtigt werden. Wenn sie nicht korrigiert werden können, können Sie das entsprechende Feld überspringen oder ablehnen, um es zu einem späteren Zeitpunkt zu korrigieren. Klicken Sie dazu auf die Schaltfläche Aufschieben.

Hinweis:Bei Feldern, für die im Dialogfeld für die Feldeigenschaften auf der Registerkarte Überprüfung die Option Der Feldüberprüfung übergeben aktiviert ist, wird eine Feldüberprüfung durchgeführt. Siehe Feldüberprüfungseigenschaften. Es empfiehlt sich, bei einzeiligen Feldern mit einem bekannten Wertebereich eine Feldüberprüfung durchzuführen.


Überprüfung im Dokumentfenster

Im Dokumentfenster können Sie die Genauigkeit der Erkennung überprüfen und falsch erkannte Zeichen korrigieren. Das Dokumentfenster wird geöffnet, wenn Sie auf den Namen der Seite doppelklicken. Das Dokumentfenster umfasst den Datenbereich, das Seitenbild und den Bereich für Fehler (sofern Fehler aufgetreten sind). Sie können die anzuzeigenden Fehlerarten auswählen: Zusammenstellungsfehler, Formatfehler, Regelfehler oder beliebige Kombinationen davon. Um Fehler einer bestimmten Art anzuzeigen, klicken Sie in der oberen rechten Ecke im Fehlerbereich auf die entsprechende Schaltfläche.

Durch Klicken auf die Schaltfläche Layout können Sie das Layout des Fensters festlegen. Im Dokumentfenster können nicht nur Zeichengruppen oder einzelne Felder, sondern das gesamte Dokument angezeigt werden.

Dokumentfenster anzeigen

Im Datenbereich werden nicht eindeutig erkannte und fragliche Zeichen farbig angezeigt. Felder mit falschen Datentypen oder nicht eingehaltenen Regeln werden hervorgehoben.

Wenn Sie ein Feld mit nicht eindeutig erkannten Zeichen bestätigen möchten, setzen Sie den Mauszeiger in das Feld und drücken die Eingabetaste.

Felder zum Anzeigen und Bearbeiten erkannter Daten können nicht nur nacheinander, sondern in jeder gewünschten Weise angeordnet werden. Sie können die Anordnung der Felder im Dokumentdefinitionseditor ändern. Siehe dazu Konfigurieren der Datendarstellung im Dokumentfenster.

Sie können zum nächsten Fehler im Dokumentfenster wechseln, indem Sie in der Symbolleiste des Hauptfensters auf die Schaltfläche [image] oder [image] klicken. Über diese Schaltfläche können Sie durch alle Fehlerkategorien navigieren, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.


Regelbasierte Validierung

Nicht eingehaltene Regeln sind durch eine gelbe Markierung [image] (Warnung) oder eine rote Markierung [image] (Fehler) gekennzeichnet.

Regelfehler werden im Dokumenteditor in einem separaten Fenster angezeigt. Dokumente mit nicht eingehaltenen Regeln sind durch rote Markierungen gekennzeichnet.

Bei Dokumenten mit nicht eingehaltenen Regeln muss der Operator die Qualität der Datenerkennung überprüfen. Wenn es sich um einen Erkennungsfehler handelt, muss dieser behoben werden. Wenn es sich um einen Fehler beim Ausfüllen eines Formulars handelt, der nicht korrigiert werden kann, sollte das Dokument nicht exportiert werden. Dokumente mit Fehlern können zu einem späteren Zeitpunkt überprüft werden, indem sie mit Papierdokumenten oder anderen verfügbaren Quellen verglichen werden.

Klicken Sie zum erneuten Überprüfen der Regeln auf das Pfeilsymbol rechts neben der Schaltfläche Überprüfung ausführen…, und wählen Sie die Menüoption Regeln erneut überprüfen aus. Wenn die Dokumente nach dem Ändern der Feldwerte den Regeln entsprechen, werden die Markierungen entfernt.


Exportieren erkannter Daten

Dokumente werden automatisch exportiert. Es kann, abhängig von den Einstellungen, eine zusätzliche Bestätigung durch den leitenden Überprüfungsoperator erforderlich sein. Dokumente werden in Übereinstimmung mit den Einstellungen in der Dokumentdefinition exportiert. Wenn keine Exporteinstellungen in der Dokumentdefinition vorhanden sind, werden die Dokumente basierend auf den Projekteinstellungen exportiert. Wenn einige der Dokumente vor den anderen exportiert werden müssen, können diese an die Exportwarteschlange des Exportschritts gesendet werden.

Dokumente können auch manuell auf der Verifizierungsstation oder auf der Projektkonfigurationsstation exportiert werden.

Daten in eine Datei exportieren

  1. Wählen Sie für den Export von Daten in eine Datei Exportieren nach>Daten in Dateien… aus dem Kontextmenü des Dokuments. Das Dialogfeld Exportieren in Datendateien wird angezeigt.
  2. Passen Sie die Exporteinstellungen, falls erforderlich, an, indem Sie Einstellungen... klicken. Klicken Sie dann auf OK, um die Änderungen anzunehmen.
  3. Klicken Sie aufExport, um die Daten zu exportieren.

Daten in eine Datenbank exportieren

  1. Wählen Sie für den Export von Daten in eine Datenbank Exportieren nach>Daten in Datenbank... aus dem Kontextmenü des Dokuments. Das Dialogfeld In ODBC-kompatible Datenbank exportieren wird angezeigt.
  2. Bestimmen Sie die Exporteinstellungen.
  3. Klicken Sie auf OK, um die Daten zu exportieren.


Hintergrundmodus

Verarbeitungsschritte, die keine Beteiligung des Operators erfordern, werden vom Verarbeitungsserver automatisch ausgeführt. Sie können jedoch auch auf einer Verifizierungssstation oder auf der Projektkonfigurationsstation manuell ausgeführt werden. In diesem Fall können sie im Hintergrundmodus laufen.

Wenn keinerlei Interaktion mit dem Operator erforderlich ist, dann kann das Importieren, Erkennen und Exportieren von Dokumenten im Hintergrundmodus ausgeführt werden.

Klicken Sie zum Übertragen eines Tasks in den Hintergrundmodus auf die Schaltfläche Hintergrundmodus im Dialogfeld Bilder werden hinzugefügt… (oder in den Dialogfeldern Erkennungsvorgang wird durchgeführt… oder Export wird durchgeführt…...).

Folgende Tasks können im Hintergrundmodus ausgeführt werden:

  • Laden von Bildern unter Verwendung des entsprechenden Importprofils.
  • Die Dokumenterkennung, sofern die Option Hinzugefügte Bilder automatisch erkennen aktiviert ist (Extras > Optionen…, Registerkarte Dokumentverarbeitung).

Wenn in den Hintergrundmodus umgeschaltet wird, dann wird in der Taskleiste das Symbol [image] angezeigt. Durch Klicken auf dieses Symbol wird das Dialogfeld Hintergrundtasks aufgerufen, in dem die Liste der Tasks angezeigt wird.

  • Die Tasks werden entweder in der Reihenfolge ihres Aufrufs oder auf der Grundlage der vom Benutzer (mithilfe der Schaltfläche Priorität festlegen…) angegebenen Prioritäten ausgeführt.
  • Die Ausführung der Tasks wird in einer Protokolldatei protokolliert, die vom Benutzer angepasst werden kann (Extras > Optionen…, Registerkarte Taskstatus). Klicken Sie auf die Schaltfläche Protokoll anzeigen, um das Protokoll anzuzeigen.
  • Sie können einen Task unterbrechen, indem Sie auf die Schaltfläche Task beenden klicken.

Das Programm informiert Sie gegebenenfalls über den Fortschritt eines Hintergrundtasks mithilfe von Popup-Meldungen, die in der rechten unteren Ecke angezeigt werden. Die Meldungen werden beim Start, bei einem Fehler und bei der Fertigstellung eines Tasks angezeigt. Einzelheiten finden Sie unter Zusätzliche Optionen.


Benutzeroberfläche von ABBYY FlexiCapture 9.0

In diesem Abschnitt werden die wesentlichen Elemente der Benutzeroberfläche von ABBYY FlexiCapture 9.0 beschrieben: die Hauptfenster, Menüs und Symbolleisten.

Projektkonfigurationsstation
Menüs der Projektkonfigurationsstation
Symbolleisten der Projektkonfigurationsstation
Verifizierungsstation
Menü der Verifizierungsstation
Symbolleisten der Verifizierungsstation
Datenverifizierungsstation
Menü der Datenverifizierungsstation
Symbolleisten der Datenverifizierungsstation
Dokumentdefinitionseditor
Menüs des Dokumentdefinitionseditors
Symbolleisten des Dokumentdefinitionseditors
Fenster für die Gruppenüberprüfung
Menüs im Fenster für die Gruppenüberprüfung
Symbolleisten im Fenster für die Gruppenüberprüfung
Fenster für die Feldüberprüfung
Menüs im Fenster für die Feldüberprüfung
Symbolleisten im Fenster für die Feldüberprüfung


Fenster der Projektkonfigurationsstation

Im Hauptfenster des Programms wird die Liste der Dokumentstapel angezeigt, die zum geöffneten Projekt gehören.

Zeigt das Hauptfenster mit der Liste der Stapel

Um den Inhalt eines Stapels anzuzeigen, doppelklicken Sie auf den Stapel. Daraufhin wird eine Liste mit den Dokumenten im Stapel angezeigt.

Wenn Sie zur Liste der Stapel zurückkehren möchten, klicken Sie auf Projekt>Stapel (oder auf Teststapel,wenn Sie Teststapel verwenden).

Das Hauptmenü mit den darunter liegenden Symbolleisten befindet sich am oberen Rand des Fensters.

Der Rest des Hauptfensters wird durch das Fenster des geöffneten Stapelsmit der Liste der darin enthaltenen Dokumente belegt.

Die Statusleiste befindet sich am unteren Rand des Fensters. Die Statusleiste zeigt den Status des Programms und die Operationen, die gerade durchgeführt werden. Wenn Sie den Mauszeiger auf einem Menübefehl oder einer Schaltfläche positionieren, zeigt die Statusleiste eine kurze Beschreibung dazu an.

Um die erkannten Daten zu prüfen, öffnen Sie das Dokumentfenster. Doppelklicken Sie hierfür auf ein Dokument oder eine der Dokumentseiten. Das Dokumentfenster besteht aus drei Bereichen:

  • Bild der Dokumentseite
  • Erkannte Daten
  • Regelfehler (werden angezeigt, wenn vorhanden)

Weitere Informationen finden Sie unter Überprüfung im Dokumentfenster.

Dokumentfenster anzeigen

Menü der Projektkonfigurationsstation
Symbolleisten der Projektkonfigurationsstation


Menü der Projektkonfigurationsstation

Datei
Menü | Beschreibung
Neues Projekt… | Erstellt ein neues Projekt
Projekt öffnen… | Öffnet ein vorhandenes Projekt
Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert die Änderungen
Neuer Stapel… | Erstellt einen neuen Stapel
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt gescannte Bilder hinzu
Bilder importieren… | Importiert Bilder mit einem der konfigurierten Importprofile
Exportieren in |
Daten in Dateien… | Exportiert die Daten in eine Datei
Bilder in Dateien… | Exportiert Bilder in Dateien
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzliche Projekte | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture 9.0
Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Verbinden | Verbindet die ausgewählten Seiten zu einem Dokument
Teilen | Teilt das ausgewählte Dokument in Seiten auf
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht den vorgegebenen Text
Weitersuchen | Sucht den nächsten zuvor angegebenen Text
Gehe zu |
Nächstes Dokument | Geht zum nächsten Dokument im Stapel
Vorheriges Dokument | Geht zum vorherigen Dokument im Stapel
Bild |
Störungen entfernen | Entfernt Flecken im Bild
Invertieren | Invertiert das Bild
Horizontal spiegeln | Spiegelt das Bild horizontal (in Bezug auf die vertikale Achse)
Vertikal spiegeln | Spiegelt das Bild vertikal (in Bezug auf die horizontale Achse)
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern… | Ändert die Auflösung des Bilds
Speichern unter… | Speichert das Bild unter dem angegebenen Namen
Ansicht
Menü | Beschreibung
Teststapel | Öffnet die Liste der Teststapel
Stapel | Öffnet die Liste der Stapel
Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Dokumentbilder als Miniaturansichten an
Details wählen… | Ermöglicht die Konfiguration der Liste von Spalten, die in der Detailansicht angezeigt werden
Dokumenteditor |
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Positionierung des Bilds im Dokumentfenster
Fehlerfenster | Ermöglicht die Positionierung des Fehlerfensters im Dokumentfenster
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Datentextanzeige | Ermöglicht die Auswahl der Schriftgröße für die Anzeige erkannter Daten
Symbolleiste anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. Über diese Symbolleiste können Sie einige der Zuordnungsfehler korrigieren, z.B. können Sie ein nicht gefundenes Feld hinzufügen oder eine Tabellentrennlinie hinzufügen bzw. löschen. Diese Funktionen werden im Wesentlichen bei der Arbeit mit FlexiLayouts verwendet.
Formatfehler des aktiven Felds anzeigen | Ermöglicht die Angabe des Anzeigemodus für Formatfehler
Bild schwarz-weiß anzeigen | Zeigt Farb- und Graustufenbilder als Schwarz-Weiß-Bilder an
?????? ??????? | Ermöglicht die Auswahl der Größe für Miniaturansichten von Seiten
?????? ???????????? | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Eigenschaften… | Öffnet das Dialogfeld für die Dokument- oder Seiteneigenschaften
Erkennung
Menü | Beschreibung
Analysieren | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
Erkennen | Startet die Erkennung
Überprüfung
Menü | Beschreibung
Überprüfung ausführen… | Startet die Überprüfung
Nächstes zu überprüfendes Element | Wechselt zum nächsten Überprüfungsobjekt
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen Überprüfungsobjekt
Nächster Zusammenstellungsfehler | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriger Zusammenstellungsfehler | Wechselt zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler
Projekt
Menü | Beschreibung
Dokumentdefinitionen… | Öffnet das Dialogfeld mit der Liste der Dokumentdefinitionen, in dem Definitionen erstellt, bearbeitet, importiert und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Stapeltypen… | Öffnet das Dialogfeld mit der Liste der Stapeltypen, in dem Stapeltypen erstellt, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Bildimportprofile… | Öffnet das Dialogfeld mit der Liste der Bildimportprofile, in dem Profile erstellt, kopiert, bearbeitet und gelöscht werden können (dieses Menü steht nur dem Administrator zur Verfügung)
Mit Kennwort schützen… | Ermöglicht den Schutz des aktuellen Projekts durch ein Passwort (dieses Menü steht nur dem Administrator zur Verfügung)
Kennwortschutz aufheben… | Ermöglicht die Deaktivierung des Passwortschutzes für das Projekt (dieses Menü steht nur dem Administrator zur Verfügung)
Projekt exportieren… | Exportiert das Projekt in den angegebenen Ordner. Bilder werden aus dem aktuellen Projekt genommen.
Projekt aktualisieren… | Konfiguriert die Projektaktualisierung. Meldungen und Fehler, die während des Exports auftreten, können in einer Datei gespeichert werden (klicken Sie mit der rechten Maustaste und wählen Sie "In Datei exportieren").
Projekteigenschaften… | Öffnet das Dialogfeld für die Projekteigenschaften
Extras
Menü | Beschreibung
Auf neueste Version aktualisieren | Wendet die Projektänderungen auf die Dokumente an, die gerade verarbeitet werden
Neu analysieren | Wiederholt die Analyse des Dokuments
Neu erkennen | Wiederholt die Erkennung des Dokuments
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung der Seiten zu Dokumenten
Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
Stapelintegritätsprüfung | Prüft die Stapelintegrität
Stapelpriorität ändern | Ermöglicht die Auswahl der Stapelpriorität
Stapeltyp ändern… | Ändert den Stapeltyp
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Hilfe
Menü | Beschreibung
Hilfethemen… | Öffnet die Hilfedatei von ABBYY FlexiCapture 9.0
Technischer Support… | Öffnet den Bereich Technischer Supportin der Programmhilfe
ABBYY-Produkte erwerben… | Öffnet den Bereich ABBYY FlexiCapture 9.0 erwerbenin der Programmhilfe
ABBYY-Website… | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info… | Öffnet das Dialogfeld Info zu ABBYY FlexiCapture 9.0 mit einer kurzen Beschreibung des Programms


Symbolleisten der Projektkonfigurationsstation

Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Projekt öffnen |  | Öffnet ein Projekt
Änderungen speichern |  | Speichert die Änderungen
Ausschneiden |  | Bei der Arbeit mit Daten im Dokumentbild: schneidet das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt in die Zwischenablage
Einfügen |  | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen |  | Löscht das ausgewählte Objekt
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Dokumentansicht

Funktion | Schaltfläche | Beschreibung
Detailansicht |  | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansicht |  | Zeigt die Dokumentseiten als Miniaturansichten an
Liste der Teststapel |  | Zeigt die Liste der Teststapel
Liste der Arbeitsstapel |  | Zeigt die Liste der Arbeitsstapel
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Navigation

Funktion | Schaltfläche | Beschreibung
Vorheriges zu überprüfendes Element |  | Geht zum vorherigen Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element |  | Geht zum nächsten Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument |  | Wechselt zum vorherigen Dokument.
Nächstes Dokument |  | Wechselt zum nächsten Dokument.
Projektkonfiguration

Funktion | Schaltfläche | Beschreibung
Dokumentdefinitionen… |  | Öffnet das Fenster mit der Liste der Dokumentdefinitionen im Projekt
Stapeltypen… |  | Öffnet das Fenster mit der Liste der Stapeltypen im Projekt
Projekteigenschaften… |  | Öffnet das Fenster für die Projekteigenschaften
Bildimportprofil zeigen |  | Öffnet das Fenster mit der Liste der Bildimportprofile im Projekt
Projekt auf Server hochladen… |  | Öffnet das Fenster zum Hochladen des Projekts auf den Anwendungsserver.


Fenster der Verifizierungsstation

Verifizierungsstation

Das Hauptfenster des Programms zeigt die Liste der Warteschlangen, aus denen Verarbeitungstasks ausgewählt werden.

Zeigt das Hauptfenster mit der Liste der Warteschlangen

Wenn ein Task empfangen wird, zeigt das Fenster die Liste der Dokumente in dem Task an.

Zeigt das Hauptfenster mit der Liste der Dokumente

Das Hauptmenü mit den darunter liegenden Symbolleisten befindet sich am oberen Rand des Fensters.

Der Rest des Hauptfensters wird durch den Arbeitsbereich mit einer Liste der Warteschlangen oder Dokumente belegt.

Die Statusleiste befindet sich am unteren Rand des Fensters. Die Statusleiste zeigt den Status des Programms und die Operationen, die gerade durchgeführt werden. Wenn Sie den Mauszeiger auf einem Menübefehl oder einer Schaltfläche positionieren, zeigt die Statusleiste eine kurze Beschreibung dazu an.

Menü der Verifizierungsstation
Symbolleisten der Verifizierungsstation


Menü der Verifizierungsstation

Datei
Menü | Beschreibung
Projekt von Server öffnen Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Speichern | Speichert die Änderungen
Bilder laden… | Lädt Bilder aus Dateien
Bilder scannen… | Fügt gescannte Bilder hinzu
Exportieren in |
Daten in Daten in Dateien… | Exportiert die Daten in eine Datei
Bilder in Dateien Bilder in Dateien… | Exportiert Bilder in Dateien
Datenbank… | Exportiert die Daten in eine Datenbank
Kürzliche Projekte | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture 9.0
Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Verbinden | Verbindet die ausgewählten Seiten zu einem Dokument
Teilen | Teilt das ausgewählte Dokument in Seiten auf
Alles auswählen | Wählt alle Objekte aus
Suchen… | Sucht vorgegebenen Text
Weitersuchen | Sucht den nächsten zuvor angegebenen Text
Gehe zu |
Nächstes Dokument | Geht zum nächsten Dokument im Stapel
Vorheriges Dokument | Geht zum vorherigen Dokument im Stapel
Bild |
Störungen entfernen | Entfernt Flecken im Bild
Invertieren | Invertiert das Bild
Horizontal spiegeln | Spiegelt das Bild horizontal (in Bezug auf die vertikale Achse)
Vertikal spiegeln | Spiegelt das Bild vertikal (in Bezug auf die horizontale Achse)
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Auflösung ändern Auflösung ändern… | Ändert die Auflösung des Bilds
Speichern unter Speichern unter… | Speichert das Bild unter dem angegebenen Namen
Ansicht
Menü | Beschreibung
Stapel | Öffnet die Liste der Stapel
Warteschlangen | Öffnet die Liste der Warteschlangen
Details | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten | Zeigt die Dokumentbilder als Miniaturansichten an
Details wählen… | Ermöglicht die Konfiguration der Liste von Spalten, die in der Detailansicht angezeigt werden
Dokumenteditor |
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an
Bildfenster | Ermöglicht die Positionierung des Bilds im Dokumentfenster
Fehlerfenster | Ermöglicht die Positionierung des Fehlerfensters im Dokumentfenster
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Datentextanzeige | Ermöglicht die Auswahl der Schriftgröße für die Anzeige erkannter Daten
Symbolleiste anzeigen | Blendet die Symbolleiste im Dokumentfenster ein oder aus. Über diese Symbolleiste können Sie einige der Zuordnungsfehler korrigieren, z.B. können Sie ein nicht gefundenes Feld hinzufügen oder eine Tabellentrennlinie hinzufügen bzw. löschen. Diese Funktionen werden im Wesentlichen bei der Arbeit mit FlexiLayouts verwendet.
Formatfehler des aktiven Felds anzeigen | Ermöglicht die Angabe des Anzeigemodus für Formatfehler
Bild schwarz-weiß anzeigen | Zeigt Farb- und Graustufenbilder als Schwarz-Weiß-Bilder an
Miniaturgröße | Ermöglicht die Auswahl der Größe für Miniaturansichten von Seiten
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Erkennung
Menü | Beschreibung
Analysieren | Analysiert die Seiten des Dokuments und findet eine geeignete Dokumentdefinition
Dokumentdefinition zuordnen… | Ordnet die ausgewählte Dokumentdefinition dem ausgewählten Dokument bzw. der ausgewählten Seite zu
Erkennen | Startet die Erkennung
Tasks
Menü | Beschreibung
Task abrufen | Ruft einen Task aus der ausgewählten Warteschlange ab
Task schließen | Schließt den aktuellen Task und gibt ihn an den Anwendungsserver als beendet zurück
Taskkommentar anzeigen | Zeigt Kommentare zu dem Task an
Task ablehnen | Weist den aktuellen Task ab und gibt ihn an den Anwendungsserver zurück
Task aufschieben… | Verschiebt die Verarbeitung des aktuellen Tasks auf später
Sende Task zur Ausnahme…(für den leitenden Überprüfungsoperator - S&ende Task zu Schritt…) | Sendet den aktuelle Task an die Ausnahmen (der leitende Überprüfungsoperator kann den Task an jede Verarbeitungsphase senden)
Automatischer Taskempfang | Aktiviert/deaktiviert den automatischenTaskabruf
Sende Dokumente zur Ausnahme… | Sendet die ausgewählten Dokumente an eine neue Ausnahme
Dokumente zur Ausnahme hinzufügen… | Fügt die ausgewählten Dokumente zu einer bestehenden Ausnahme hinzu
Dokumente von Ausnahme entfernen | Löscht die Dokumente aus der Ausnahme
Ausnahmenliste anzeigen… | Zeigt die Liste der Ausnahmen
Überprüfung
Menü | Beschreibung
Überprüfung ausführen… | Startet die Überprüfung
Nächstes zu überprüfendes Element | Wechselt zum nächsten Überprüfungsobjekt
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen Überprüfungsobjekt
Nächster Zusammenstellungsfehler | Wechselt zum nächsten Zusammenstellungsfehler
Vorheriger Zusammenstellungsfehler | Wechselt zum vorherigen Zusammenstellungsfehler
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächster Regelfehler | Wechselt zum nächsten Regelfehler
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler
Extras
Menü | Beschreibung
Auf neueste Version aktualisieren | Wendet die Projektänderungen auf die Dokumente an, die gerade verarbeitet werden
Neu analysieren | Wiederholt die Analyse des Dokuments
Neu erkennen | Wiederholt die Erkennung des Dokuments
Zusammenstellung aktualisieren | Aktualisiert die Zusammenstellung der Seiten zu Dokumenten
Regeln erneut überprüfen | Wiederholt die Überprüfung von Regeln
Stapelintegritätsprüfung | Prüft die Stapelintegrität
Stapelpriorität ändern | Ermöglicht die Auswahl der Stapelpriorität
Stapeltyp ändern… | Ändert den Stapeltyp
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Hilfe
Menü | Beschreibung
Hilfethemen… | Öffnet die Hilfedatei von ABBYY FlexiCapture 9.0
Technischer Support… | Öffnet den Bereich Technischer Supportin der Programmhilfe
ABBYY-Produkte erwerben… | Öffnet den Bereich ABBYY FlexiCapture 9.0 erwerbenin der Programmhilfe
ABBYY-Website… | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info… | Öffnet das Dialogfeld Info zu ABBYY FlexiCapture 9.0 mit einer kurzen Beschreibung des Programms


Symbolleiste der Verifizierungsstation

Symbolleisten der Verifizierungsstation

Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Projekt öffnen |  | Öffnet ein Projekt
Änderungen speichern |  | Speichert die Änderungen
Ausschneiden |  | Bei der Arbeit mit Daten im Dokumentfenster: schneidet das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen |  | Löscht das ausgewählte Objekt
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Dokumentansicht

Funktion | Schaltfläche | Beschreibung
Details |  | Zeigt die Dokumente und die zugehörigen Seiten in einer detaillierten Liste an
Miniaturansichten |  | Zeigt Miniaturansichten der Dokumentbilder
Teststapel |  | Zeigt die Liste der Teststapel
Arbeitsstapel |  | Zeigt die Liste der Arbeitsstapel
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Navigation

Extras | Schaltfläche | Beschreibung
Vorheriges zu überprüfendes Element |  | Geht zum vorherigen Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Nächstes zu überprüfendes Element |  | Geht zum nächsten Überprüfungsobjekt. Die Navigation wird durch alle Fehlerkategorien durchgeführt, darunter Zusammenstellungsfehler, nicht eindeutig erkannte Zeichen, Regelfehler, nicht übereinstimmende Schlüsselfelder usw.
Vorheriges Dokument |  | Wechselt zum vorherigen Dokument.
Nächstes Dokument |  | Wechselt zum nächsten Dokument.
Warteschlangen und Tasks

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Öffnet einen Task aus der ausgewählten Warteschlange
Task schließen |  | Gibt den Task zum Server zurück
Zu Ausnahmen senden (zur Verarbeitungsphase) |  | Sendet den Task an die Ausnahmen (für den leitenden Überprüfungsoperator: zur ausgewählten Verarbeitungsphase)
Task aufschiebenTask aufschieben… |  | Schiebt den Task auf
Task ablehnen |  | Bricht den Task ab (er wird vom Server an einen anderen Operator gesendet)
Tasks automatisch abrufen |  | Aktiviert/deaktiviert den automatischenTaskabruf


Hauptfenster der Datenverifizierungsstation

Datenverifizierungsstation

Das Hauptfenster des Programms zeigt die Namen der Warteschlangen, aus denen die Tasks stammen (Warteschlangen für die Datenüberprüfung).

Zeigt das Hauptfenster mit der Liste der Warteschlangen

Nachdem Sie den Task abgerufen haben, werden nacheinander die Überprüfungsfenster Gruppe undFeldgeöffnet.

Das Hauptmenü mit den darunter liegenden Symbolleisten befindet sich am oberen Rand des Fensters.

Die Statusleiste befindet sich am unteren Rand des Fensters. Die Statusleiste zeigt den Status des Programms und die Operationen, die gerade durchgeführt werden. Wenn Sie den Mauszeiger auf einem Menübefehl oder einer Schaltfläche positionieren, zeigt die Statusleiste eine kurze Beschreibung dazu an.

Menü der Datenverifizierungsstation
Symbolleisten der Datenverifizierungsstation


Menü der Datenverifizierungsstation

Datei
Menü | Beschreibung
Projekt von Server öffnen… | Öffnet ein vorhandenes Projekt auf dem Anwendungsserver
Projekt schließen | Schließt das aktuelle Projekt
Kürzliche Projekte | Öffnet eines der zuvor geöffneten Projekte
Beenden | Schließt ABBYY FlexiCapture 9.0
Ansicht
Menü | Beschreibung
Symbolleisten | Blendet die Symbolleisten ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Vollbild | Wechselt in den Vollbildmodus
Aktualisieren | Aktualisiert die angezeigten Informationen
Tasks
Menü | Beschreibung
Task abrufen | Ruft einen Task aus der ausgewählten Warteschlange ab
Taskkommentar anzeigen | Zeigt Kommentare zu dem Task an
Task ablehnen | Weist den aktuellen Task ab und gibt ihn an den Anwendungsserver zurück
Sende Task zur Ausnahme… | Sendet den aktuellen Task an die Ausnahmen
Automatischer Taskempfang | Aktiviert/deaktiviert den automatischen Taskempfangsmodus
Extras
Menü | Beschreibung
Optionen… | Öffnet das Dialogfeld Optionen, in dem Sie verschiedene Eigenschaften wie die Taskverarbeitung im Hintergrund, die Fensteransicht usw. konfigurieren können
Hilfe
Menü | Beschreibung
Hilfethemen… | Öffnet die Hilfedatei von ABBYY FlexiCapture 9.0
Technischer Support… | Öffnet den Bereich Technischer Supportin der Programmhilfe
ABBYY-Produkte erwerben… | Öffnet den Bereich ABBYY FlexiCapture 9.0 erwerbenin der Programmhilfe
ABBYY-Website… | Öffnet die ABBYY-Website
Feedback senden… | Ermöglicht das Senden von Feedback an ABBYY: Meinungen, Wünsche oder Kommentare der Benutzer
Info… | Öffnet das Dialogfeld Info zu ABBYY FlexiCapture 9.0 mit einer kurzen Beschreibung des Programms


Symbolleisten der Datenverifizierungsstation

Warteschlangen und Tasks

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Öffnet einen Task aus der ausgewählten Warteschlange
Zu Ausnahme senden… |  | Sendet den Task an die Ausnahmen
Task ablehnen |  | Weist den Task ab (er wird später vom Server an einen anderen Operator gesendet)
Aktualisieren |  | Aktualisiert die Informationen im Hauptfenster
Automatischer Taskempfang |  | Aktiviert/deaktiviert den automatischen Taskempfangsmodus


Fenster des Dokumentdefinitionseditors

Dokumentdefinitionen werden im Fenster des Dokumentdefinitionseditors erstellt und bearbeitet. Dieses Fenster ist nur auf der Projektkonfigurationsstation verfügbar.

So öffnen Sie den Dokumentdefinitionseditor im Hauptfenster des Programms:

  1. Wählen Sie die Menüoption Projekt > Dokumentdefinitionen… aus.
  2. Markieren Sie im daraufhin geöffneten Dialogfeld Dokumentdefinitionen den Namen der Dokumentdefinition, und klicken Sie auf Bearbeiten….

Das Fenster des Dokumentdefinitionseditors wird auch nach dem Beenden des Dokumentdefinitionsassistenten geöffnet.

Fenster des Dokumentdefinitionseditors anzeigen

Das Fenster des Dokumentdefinitionseditors besteht aus drei Bereichen:

  1. Bild der Seite mit der Kennzeichnung der Felder und statischen Elemente links oben im Fenster.

    Zur Bearbeitung der Felder und statischen Elemente verfügt das Programm über zwei Modi:

    • Modus für Feldbereiche: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert.
    • Modus für statische Elemente: Dieser Modus wird durch Klicken auf die Schaltfläche [image] aktiviert.
  2. Editor zum Konfigurieren der Darstellung erkannter Daten links unten im Fenster.
  3. Dokumentstruktur mit einer Liste aller Dokumentdefinitionsfelder (Registerkarte Felder) im rechten Bereich des Fensters. Sie können darüber hinaus in die Gliederungsansicht (Registerkarte Seiten) wechseln.

Menü des Dokumentdefinitionseditors
Symbolleisten des Dokumentdefinitionseditors


Menü des Dokumentdefinitionseditors

Dokumentdefinition
Menüoption | Beschreibung
Seite hinzufügen… | Fügt ein neues Seitenbild in einer Dokumentdefinition ein
Dokumentbereich hinzufügen… | Fügt einen neuen Bereich in einem Stapel ein
Skriptmodule |
Regelskript… | Öffnet das Regel für globales Skriptmodul im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter Verwenden von Skripten in FlexiCapture 9.0.
Exportskript… | Öffnet das Globales Skriptmodul exportieren im Skripteditor. Weitere Informationen zu Skriptmodulen finden Sie unter Verwenden von Skripten in FlexiCapture 9.0.
Exporteinstellungen… | Öffnet das Dialogfeld Exporteinstellungen zum Konfigurieren der Optionen für den Datenexport
Eigenschaften der Dokumentdefinition… | Öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der Eigenschaften einer Dokumentdefinition
Speichern | Speichert Änderungen
Schließen | Schließt den Dokumentdefinitionseditor
Bearbeiten
Menüoption | Beschreibung
Rückgängig | Macht die vorherige Aktion rückgängig
Wiederholen | Stellt die rückgängig gemachte Aktion wieder her
Ausschneiden | Schneidet die markierten Objekte aus
Kopieren | Kopiert die markierten Objekte in die Zwischenablage
Einfügen | Fügt den Inhalt der Zwischenablage ein
Löschen | Löscht die markierten Objekte
Bereich löschen | Entfernt Bereiche aus den Bildern der markierten Objekte
Alles auswählen | Wählt alle Objekte aus
Nach Typ auswählen… | Erkennt bestimmte Objekttypen
Feld erstellen |
Text | Fügt der Dokumentstruktur ein Texteingabefeld hinzu (ohne Bereich im Bild)
Auswahlfeld | Fügt der Dokumentstruktur ein Auswahlfeld hinzu (ohne Bereich im Bild)
Auswahlfeldgruppe | Fügt der Dokumentstruktur eine Gruppe von Auswahlfeldern hinzu (ohne Bereich im Bild)
Barcode | Fügt der Dokumentstruktur ein Barcodefeld hinzu (ohne Bereich im Bild)
Bild | Fügt der Dokumentstruktur ein Bildfeld hinzu (ohne Bereich im Bild)
Tabelle | Fügt der Dokumentstruktur ein Tabellenfeld hinzu (ohne Bereich im Bild)
Gruppieren | Fügt der Dokumentstruktur eine Gruppe von Feldern hinzu (ohne Bereich im Bild)
Gruppe | Gruppiert die markierten Objekte
Gruppierung aufheben | Hebt die Gruppierung der markierten Objekte auf
Text aus Bild kopieren… | Kopiert Text aus einem Bereich des Bilds und speichert ihn in der Zwischenablage. Markieren Sie nach der Auswahl dieses Befehls den Bereich, in dem sich der gewünschte Text befindet.
Bild |
Störungen entfernen | Entfernt Störungen im Bild
Invertieren | Invertiert das Bild
Drehen 90° im Uhrzeigersinn | Dreht das Bild um 90° im Uhrzeigersinn
Drehen 90° gegen Uhrzeigersinn | Dreht das Bild um 90° gegen den Uhrzeigersinn
Drehen 180° | Dreht das Bild um 180°
Speichern als… | Speichert das Bild der Vorlagenseite in der angegebenen Datei
Ersetzen… | Ersetzt das Bild der Vorlagenseite
Ansicht
Menüoption | Beschreibung
Bildlayout |
Statische Elemente | Wechselt in den Modus für statische Elemente
Feldbereiche | Wechselt in den Modus für Feldbereiche
Dokumentstruktur |
Dokumentstruktur anzeigen | Blendet das Fenster Dokumentstruktur ein oder aus
Felder | Schaltet das Fenster Dokumentstruktur in den Feldmodus um
Seiten | Schaltet das Fenster Dokumentstruktur in den Seitenmodus um
Datenformular | Blendet das Fenster des Dateneditors ein oder aus
Symbolleiste "Layout" |
Horizontal | Dockt die Symbolleiste horizontal im Bildlayoutfenster an
Vertikal | Dockt die Symbolleiste vertikal im Bildlayoutfenster an
Bild schwarz-weiß anzeigen | Zeigt die Farb- und Graustufenbilder von Seiten im Schwarz-Weiß-Modus an
Bildanzeige | Legt die geeignete Bildgröße fest
Eigenschaften… | Öffnet ein Dialogfeld zum Anzeigen und Bearbeiten der Eigenschaften des markierten Objekts
Dokument
Menüoption | Beschreibung
Test ausführen | Startet das Testen von Dokumentdefinitionen anhand des Dokumentbilds.
Test beenden | Beendet das Testen der Dokumentdefinition
Bildmodus | Zeigt das Seitenbild im Dokumentfenster an.
Datenmodus | Zeigt die erkannten Daten im Dokumentfenster an.
Layout |
Bildfenster | Ändert die Position des Bilds im Dokumentfenster.
Oben | Positioniert das Bildfenster oben auf dem Bildschirm.
Unten | Positioniert das Bildfenster unten auf dem Bildschirm.
Links | Positioniert das Bildfenster links.
Rechts | Positioniert das Bildfenster rechts.
Fehlerfenster | Ändert die Position des Fehlerfensters im Dokumentfenster.
Oben | Positioniert das Fehlerfenster oben auf dem Bildschirm.
Unten | Positioniert das Fehlerfenster unten auf dem Bildschirm.
Links | Positioniert das Fehlerfenster links.
Rechts | Positioniert das Fehlerfenster rechts.
Symbolleiste anzeigen | Blendet die Symbolleiste im Datenmodus ein oder aus Im Bildmodus wird die Symbolleiste ständig angezeigt und kann nicht ausgeblendet werden.
Überprüfung |
Nächstes zu überprüfendes Element | Wechselt zum nächsten zu überprüfenden Element.
Vorheriges zu überprüfendes Element | Wechselt zum vorherigen zu überprüfenden Element.
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutigen Zeichen.
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutigen Zeichen.
Nächster Regelfehler | Wechselt zum nächsten Regelfehler.
Vorheriger Regelfehler | Wechselt zum vorherigen Regelfehler.
Extras
Menüoption | Beschreibung
Objekte automatisch erkennen… | Erkennt und markiert automatisch Felder und statische Elemente eines bestimmten Typs (je nach Modus)
Dokumentlayout überprüfen | Überprüft die Dokumentdefinition
Bereich zuordnen | Überprüft die Zuordnung eines Dokumentdefinitionsbereichs
Zu Teststapel wechseln… | Ermöglicht das Testen der Dokumentdefinition mit Teststapeln
Hilfe
Menüoption | Beschreibung
Hilfethemen… | Öffnet die Hilfethemen von ABBYY FlexiCapture 9.0
Feedback senden | Über diesen Link können Benutzer ihre Kommentare und Anregungen an ABBYY senden.


Symbolleisten im Dokumentdefinitionseditor

Symbolleiste "Standard"

Name | Schaltfläche | Beschreibung
Änderungen speichern |  | Speichert Änderungen
Ausschneiden |  | Schneidet beim Bearbeiten der Daten im Dokumentfenster das ausgewählte Objekt aus
Kopieren |  | Kopiert das ausgewählte Objekt
Einfügen |  | Fügt ein zuvor kopiertes Objekt aus der Zwischenablage ein
Löschen |  | Löscht ein markiertes Objekt
Rückgängig |  | Macht die vorherige Aktion rückgängig
Wiederherstellen |  | Stellt eine zuvor rückgängig gemachte Aktion wieder her
Dokumentdefinition überprüfen |  | Überprüft eine Dokumentdefinition. Die Ergebnisanzeige erfolgt unten im Fenster des Dokumentdefinitionseditors
Symbolleiste im Bildlayoutfenster

Über die Symbolleiste im Bildlayoutfenster können statische Elemente und Dokumentdefinitionsfelder erstellt werden. Die Symbolleiste enthält je nach dem ausgewählten Modus unterschiedliche Schaltflächen.

Modus für statische Elemente:

Modus für Feldbereiche:

Die Symbolleiste kann horizontal oder vertikal im Fenster angedockt werden. Die Ausrichtung der Symbolleiste kann unter Ansicht > Symbolleiste "Layout" geändert werden.
Name | Schaltfläche | Beschreibung
Allgemein
Modus für statische Elemente |  | Wechselt in den Modus für statische Elemente
Modus für Feldbereiche |  | Wechselt in den Modus für Feldbereiche
Zoom |  | Vergrößert die Bildanzeige
Objekte automatisch erkennen |  | Erkennt automatisch Objekte im Bild. Klicken Sie auf dieses Tool und anschließend in den Objektbereich.
Bereiche auswählen |  | Markiert die Objektbereiche, die im Bild markiert wurden. Klicken Sie zum Markieren eines Bereichs auf dieses Tool und anschließend in den Objektbereich.
Modus für statische Elemente
Anker erstellen |  | Erstellt einen Anker. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Anker.
Trennlinie erstellen |  | Erstellt eine Trennlinie. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Trennlinie.
Ankertext erstellen |  | Erstellt einen Ankertext. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Text.
Ankerbarcode erstellen |  | Erstellt einen Ankerbarcode. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Modus für Feldbereiche
Text erstellen |  | Erstellt ein Texteingabefeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Texteingabebereich.
Auswahlfeld erstellen |  | Erstellt ein Auswahlfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Auswahlfeldbereich.
Auswahlgruppenfeld erstellen |  | Erstellt eine Gruppe von Auswahlfeldern. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Gruppe von Auswahlfeldern.
Barcode erstellen |  | Erstellt ein Barcodefeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Barcode.
Bild erstellen |  | Erstellt ein Bildfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um das Bild.
Tabelle erstellen |  | Erstellt ein Tabellenfeld. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Tabelle. In der Symbolleiste werden weitere Schaltflächen für Markierungen in Tabellen angezeigt.
Gruppe erstellen |  | Erstellt eine Feldgruppe. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um die Feldgruppe.
Bereich für Feld ohne Bereich erstellen |  | Erstellt einen Bereich für ein Feld, das in der Dokumentstruktur enthalten ist, dem jedoch im Bild kein Bereich zugewiesen ist. Klicken Sie auf dieses Tool, und ziehen Sie dann mit dem Mauszeiger einen rechteckigen Rahmen um den Bereich des Felds. Wählen Sie in der Dropdownliste einen Namen aus. (In der Liste sind die Namen der Felder aufgeführt, denen im Bild kein Bereich zugeordnet ist.)
Unerkennbaren Bereich erstellen |  | Markiert ein Feld, das beim Erkennungsvorgang ausgeschlossen werden soll.
Schaltflächen zum Markieren in Tabellen Diese Schaltflächen werden angezeigt, wenn in einem Dokumentdefinitionsbereich mindestens eine Tabelle erstellt wurde.
Spalte erstellen |  | Über diese Schaltfläche können Sie eine Tabellenspalte erstellen und den entsprechenden Spaltentyp angeben. Klicken Sie dazu auf dieses Tool und anschließend in den Bereich, in dem die Spalte erstellt werden soll. Wählen Sie in der Dropdownliste einen Spaltentyp aus.
Tabellentrennlinie zeichnen |  | Fügt horizontale und vertikale Trennlinien in die Tabelle ein
Trennlinie löschen |  | Löscht eine Trennlinie


Fenster für die Gruppenüberprüfung

Das Fenster für die Gruppenüberprüfung wird nach dem Start der Überprüfung angezeigt, sofern die Dokumentdefinition Felder enthält, für die die Option Zeichen der Gruppenüberprüfung übergeben ausgewählt ist. Weitere Informationen finden Sie unter Eigenschaften für die Feldüberprüfung.

Dieses Fenster dient dazu, die mit demselben Wert erkannten Zeichen visuell zu prüfen. Als gleich erkannte Zeichen werden angezeigt, um die Identifizierung zu ermöglichen und abweichende Zeichen zu korrigieren. Siehe Gruppenüberprüfung.

Menü im Fenster für die Gruppenüberprüfung
Symbolleisten im Fenster für die Gruppenüberprüfung


Menü für die Gruppenüberprüfung

s

Menü im Fenster für die Gruppenüberprüfung

Warteschlangen und Tasks (diese Symbolleiste ist nur auf der Datenverifizierungsstation verfügbar)
Menü | Beschreibung
Task abrufen | Ruft einen neuen Datenüberprüfungstask ab
Task zu Ausnahmen senden Sende Task zur Ausnahme… | Sendet den aktuellen Task an die Ausnahmen
Task ablehnen | Weist den aktuellen Task ab (er wird zu einem bestimmten Zeitpunkt an einen Operator zurückgegeben)
Aktualisieren | Aktualisiert Informationen über die Tasks
Überprüfung
Menü | Beschreibung
Alle bestätigen | Bestätigt die korrekte Überprüfung aller Zeichen und wechselt zur nächsten Phase
Alle Alle aufschieben | Schiebt die Überprüfung aller Zeichen auf und kennzeichnet sie mit einem Fragezeichen
Status ändern | Schiebt die Überprüfung des ausgewählten Zeichens auf und kennzeichnet es mit einem Fragezeichen
Nächste Seite | Geht zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Vorherige Seite | Geht zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Schließen | Schließt das Überprüfungsfenster
Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Alles auswählen | Wählt alle Zeichen aus
Ansicht
Menü | Beschreibung
Feldbild |
Feldbild anzeigen | Blendet das Bild des Felds mit dem aktuellen Zeichen ein bzw. aus
Oben | Positioniert das Feldbild im oberen Bereich des Überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des Überprüfungsfensters
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Zeichenbild anzeigen | Blendet das Bild des Zeichens ein oder aus
Symbolleiste | Blendet die Symbolleisten ein oder aus
Infoleiste | Blendet die Infoleiste ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Zeichengröße | Ermöglicht die Auswahl der geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Voreinstellungen Voreinstellungen… | Ermöglicht die Einstellung des an das Zeichen angrenzenden Bereichs
Hilfe
Menü | Beschreibung
Hilfethemen… | Öffnet die Hilfedatei von ABBYY FlexiCapture 9.0
Info… | Öffnet das Dialogfeld Info zu ABBYY FlexiCapture 9.0 mit kurzen Informationen zum Programm


Symbolleisten für die Gruppenüberprüfung

Symbolleisten im Fenster für die Gruppenüberprüfung

Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Vorherige Seite |  | Geht zur vorherigen Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Nächste Seite |  | Geht zur nächsten Seite, wenn nicht alle Zeichen in einem Fenster angezeigt werden können
Alle bestätigen |  | Bestätigt die korrekte Erkennung aller Zeichen und wechselt zur nächsten Phase
Zeichenstatus ändern |  | Ändert den Zeichenstatus (in abgelehnt und zurück)
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Warteschlangen und Tasks (diese Symbolleiste ist nur auf der Datenverifizierungsstation verfügbar)

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Öffnet den Datenüberprüfungstask
Zu Ausnahmen senden |  | Fügt den Task zu den Ausnahmen hinzu
Task ablehnen |  | Weist den Task ab. Er wird dann an einen anderen Operator gesendet.
Aktualisieren |  | Aktualisiert Informationen über die Tasks


Fenster für die Feldüberprüfung

Das Fenster für die Feldüberprüfung wird nach Fertigstellung der Gruppenüberprüfung angezeigt, sofern die Dokumentdefinition Felder enthält, für die die Option Der Feldüberprüfung übergeben ausgewählt ist. Weitere Informationen finden Sie unter Eigenschaften für die Feldüberprüfung.

Dieses Fenster dient dazu, nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds visuell zu prüfen. Siehe Feldüberprüfung.

Menü im Fenster für die Feldüberprüfung
Symbolleisten im Fenster für die Feldüberprüfung


Menü für die Feldüberprüfung

Menü im Fenster für die Feldüberprüfung

Warteschlangen und Tasks (dieses Menü ist nur auf der Datenverifizierungsstation verfügbar)
Menü | Beschreibung
Task abrufen | Ruft einen neuen Datenüberprüfungstask ab
Sende Task zur Ausnahme… | Sendet den aktuellen Task an die Ausnahmen
Task ablehnen | Weist den aktuellen Task ab (er wird zu einem bestimmten Zeitpunkt an einen Operator zurückgegeben)
Aktualisieren | Aktualisiert Informationen über die Tasks
Überprüfung
Menü | Beschreibung
Feld bestätigen | Bestätigt das Feld
Aufschieben | Schiebt die Feldüberprüfung auf
Nächstes nicht eindeutiges Zeichen | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Vorheriges nicht eindeutiges Zeichen | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes Feld | Wechselt zum nächsten Feld
Vorheriges Feld | Wechselt zum vorherigen Feld
Schließen | Schließt das Überprüfungsfenster
Bearbeiten
Menü | Beschreibung
Rückgängig machen | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Ausschneiden | Schneidet die ausgewählten Objekte aus
Kopieren | Kopiert die ausgewählten Objekte in die Zwischenablage
Einfügen | Fügt das kopierte Objekt aus der Zwischenablage ein
Löschen | Löscht die ausgewählten Objekte
Alle löschen | Löscht alle Objekte
Alles auswählen | Wählt alle Objekte aus
Zeilenumbruch einfügen | Fügt einen Zeilenumbruch ein
Zeichen verbinden | Verbindet die ausgewählten Zeichen, wenn ein Zeichen während der Erkennung in mehrere Zeichen aufgeteilt wurde
Ansicht
Menü | Beschreibung
Felddaten |
Erkannter Text | Blendet den erkannten Text ein bzw. aus
Zeichenausschnitt | Wechselt in die Feldansicht mit Zeichenbildausschnitt
Sonderzeichen anzeigen | Blendet Sonderzeichen ein bzw. aus
Feldbild |
Feldbild anzeigen | Blendet das Bild des Felds mit dem aktuellen Zeichen ein bzw. aus
Oben | Positioniert das Feldbild im oberen Bereich des Überprüfungsfensters
Unten | Positioniert das Feldbild im unteren Bereich des Überprüfungsfensters
Bildanzeige | Ermöglicht die Auswahl einer geeigneten Feldbildskalierung
Analoge Analoge Felder | Blendet ähnliche Felder in anderen Dokumenten ein bzw. aus
Zeichenbild anzeigen | Blendet das Bild des Zeichens ein oder aus
Symbolleiste | Blendet die Symbolleisten im Hauptfenster ein oder aus
Infoleiste | Blendet die Infoleiste ein oder aus
Statusleiste | Blendet die Statusleiste ein oder aus
Zeichengröße | Ermöglicht die Auswahl der geeigneten Zeichengröße
Vollbild | Wechselt in den Vollbildmodus
Voreinstellungen… | Ermöglicht die Einstellung des an das Zeichen angrenzenden Bereichs
Hilfe
Menü | Beschreibung
Hilfethemen… | Öffnet die Hilfedatei von ABBYY FlexiCapture 9.0
Info… | Öffnet das Dialogfeld Info zu ABBYY FlexiCapture 9.0 mit kurzen Informationen zum Programm


Symbolleisten für die Feldüberprüfung

Symbolleisten im Fenster für die Feldüberprüfung

Symbolleiste "Standard"

Funktion | Schaltfläche | Beschreibung
Vorheriges Feld |  | Wechselt zum vorherigen Feld
Nächstes Feld |  | Wechselt zum nächsten Feld
Feld bestätigen/Feld überspringen |  | Bestätigt die korrekte Erkennung aller Zeichen im Feld und wechselt zum nächsten Feld. Wenn der Feldwert nicht dem Feldformat entspricht, ändert sich die Beschriftung der Schaltfläche in Feld überspringen. Wenn der Feldwert nicht korrigiert werden kann, kann das Feld übersprungen oder aufgeschoben werden.
Feld aufschieben |  | Schiebt die Überprüfung des Felds auf, wenn das Feld nicht korrigiert werden kann
Vorheriges nicht eindeutiges Zeichen |  | Wechselt zum vorherigen nicht eindeutig erkannten Zeichen
Nächstes nicht eindeutiges Zeichen |  | Wechselt zum nächsten nicht eindeutig erkannten Zeichen
Rückgängig |  | Macht den letzten Bearbeitungsschritt rückgängig
Wiederherstellen |  | Stellt den rückgängig gemachten Bearbeitungsschritt wieder her
Warteschlangen und Tasks (diese Symbolleiste ist nur auf der Datenverifizierungsstation verfügbar)

Funktion | Schaltfläche | Beschreibung
Task abrufen |  | Ruft einen neuen Datenüberprüfungstask ab
Zu Ausnahmen senden |  | Sendet den aktuellen Task an die Ausnahmen
Task ablehnen |  | Weist den aktuellen Task ab (er wird später vom Server an einen anderen Operator gesendet)
Aktualisieren |  | Aktualisiert die Taskinformationen


Anhang

Erstellen von maschinenlesbaren Formularen
Tastaturbefehle
Verwenden von Skripten in FlexiCapture 9.0
Vergleich von Regeln in FormReader 6.5 und FlexiCapture 9.0
Unterstützte Erkennungssprachen
Schriftarten für die korrekte Darstellung von Zeichen
Unterstützte Texttypen
Unterstützte Barcodetypen
Unterstützte Grafikformate
Exportdateiformate
Alphabet in regulären Ausdrücken
Patente
Technologien anderer Unternehmen


Erstellen von maschinenlesbaren Formularen

Fragebögen, Sozialversicherungsformulare, Umfragebögen und Garantiekarten sind verschiedene Formulartypen, die zur Erfassung unterschiedlicher Informationstypen verwendet werden.

Wie unterscheiden sich Formulare von anderen Dokumenttypen?

  1. Ein Formular enthält immer eine festgelegte Anzahl Felder.
  2. Jedes Feld kann nur einen bestimmten Informationstyp enthalten. Beispielsweise enthält ein Feld "Nachname" nur Nachnamen (sofern es richtig ausgefüllt wurde), und ein Feld "Datum" enthält nur Datumsangaben.

Formulare werden verwendet, wenn Daten von einer großen Anzahl von befragten Personen erfasst werden müssen. Die manuelle Erfassung von Informationen ist langwierig und mühselig; dabei sind Tippfehler und Fehler fast unvermeidlich. Zur Automatisierung dieses Vorgangs werden maschinenlesbare Formulare verwendet.

Die automatisierte Verarbeitung von Formularen besteht aus den folgenden Stufen:

  1. Einrichten der Anwendung zur Formularverarbeitung (Erstellen einer Dokumentdefinition und Festlegen der zu erkennenden Felder).
  2. Erfassen von Formularbildern (Scannen).
  3. Verarbeiten der Formularbilder (Erkennen der Bilder und Überprüfen der extrahierten Daten).
  4. Exportieren der extrahierten Daten an ein externes Informationssystem.

Am effektivsten ist die automatische Verarbeitung von Formularen für Formulare, welche die in diesem Kapitel beschriebenen Anforderungen erfüllen.

Maschinenlesbare Formulare
Elemente maschinenlesbarer Formulare
Methoden zum Ausfüllen von Formularen
Maschinenlesbare Formulartypen
Wahl des richtigen Formulartyps
Allgemeine Anforderungen für maschinenlesbare Formulare


Maschinenlesbare Formulare

Um Informationen auf Formularen lesen zu können, muss eine Anwendung zur Formularverarbeitung:

  1. Die Position der Formularelemente bestimmen.
  2. Feldinhalte von Feldbegrenzungen, Textmarkierungen, Hintergründen und erklärenden Texten abtrennen.

Maschinenlesbare Formulare ermöglichen es dem Programm, diese Tasks auszuführen.

Um den ersten Task erfolgreich ausführen zu können, müssen die Formulare den Formularmustern oder Dokumentdefinitionen entsprechen, d. h. die Position aller Formularelemente muss auf allen Formularen desselben Typs identisch sein.

Um den zweiten Task erfolgreich ausführen zu können, müssen die Formulare für die automatische Datenerfassung gestaltet sein, so dass das Programm leicht zwischen den zu verarbeitenden Daten und nicht der Erkennung unterliegenden Formularelementen wie Feldbegrenzungen, Textmarkierungen, Hintergründen oder erklärendem Text unterscheiden kann.


Elemente maschinenlesbarer Formulare

Die folgenden Elemente können in einem Formular vorkommen:

Text
Eingabefeld
Auswahlfeld
Auswahlfeldgruppe
Anker
Zeilentrennzeichen
Formularkennung
Bild
Tabelle
Elementgruppe


Erstellung maschinenlesbarer Formulare/Text

Text

Als Text werden die beschreibenden Elemente eines maschinenlesbaren Formulars bezeichnet: Formulartitel, Feldnamen, Erklärungen usw.


Erstellung maschinenlesbarer Formulare/Eingabefeld

Eingabefeld

Eingabe- oder Eintragsfelder sind Elemente maschinenlesbarer Formulare, in welche die ausfüllende Person Text eintragen kann. Zur Erleichterung der Eintragung können diese Felder besondere Textmarkierungen enthalten. Eingabefelder werden meist von Text zur Erläuterung der gewünschten Informationen begleitet.

Beispiel eines Eingabefelds zeigen

Die folgende Tabelle zeigt einige mögliche Textmarkierungsarten.

Text über einer Linie | Text wird über einer Linie eingetragen.
Buchstaben in Rahmen | Die Buchstaben werden in miteinander verbundene Rahmen eingetragen.
Buchstaben in getrennten Rahmen | Die Buchstaben werden in voneinander getrennte Rahmen eingetragen.
Buchstaben auf Kamm | Die Buchstaben werden über einem Kamm eingetragen.
Text im Rahmen | Der Text wird in einen Rahmen eingetragen.
Text im Rahmen mit Kamm | Der Text wird in einen Rahmen mit Kamm eingetragen.


Erstellung maschinenlesbarer Formulare/Auswahlfeld

Auswahlfeld

Auswahlfelder sind Elemente maschinenlesbarer Formulare (meistens in Form eines quadratischen Ankreuzfelds), die von der ausfüllenden Person markiert werden können.

Auswahlfelder werden normalerweise von erklärendem Text begleitet, der die Verwendung des Auswahlfelds beschreibt.

Beispiel eines Auswahlfelds zeigen

Einige mögliche Formen von Auswahlfeldern werden in der folgenden Tabelle gezeigt.

Quadrat
Kreis
Unterstrich

Es sind auch andere Formen möglich, z.B. Polygone, Ovale u.ä.


Erstellung maschinenlesbarer Formulare/Auswahlfeldgruppe

Auswahlfeldgruppe

Auswahlfeldgruppen sind Elemente maschinenlesbarer Formulare, die mehrere Auswahlfelder vereinigen, von denen nur eines ausgewählt werden muss. Auswahlfeldgruppen werden normalerweise von erklärendem Text begleitet, der die Art der zu treffenden Auswahl beschreibt.

Beispiel einer Auswahlfeldgruppe zeigen


Anker

Anker sind Elemente maschinenlesbarer Formulare, die die Zuordnung der Bilder zu Dokumentdefinitionen erleichtern und die Ausrichtung der Formulare für die automatische Verarbeitung festlegen.

Bevor das Programm mit der Erkennung des Formularinhalts beginnen kann, muss es das Formular mit seiner Dokumentdefinition abgleichen. Alle maschinenlesbaren Formulare gleichen Typs müssen einer bestimmten Dokumentdefinition entsprechen, d.h. die Position aller Formularelemente muss auf allen Formularen identisch sein. Das Programm versucht, das Formular mit Hilfe von Anzahl und Position seiner Anker mit der Dokumentdefinition abzugleichen. Falls es dem Programm gelingt, die Anker des Formulars mit den Ankern der Dokumentdefinition abzugleichen, kann es daraus die genaue Position der Felder ableiten, die die zu erkennenden Daten enthalten.

Die folgende Tabelle zeigt einige Standardanker.

Schwarzes Quadrat
Ecke
Kreuz
Zeitmarkierung
Um die bestmögliche Erkennungsqualität zu erreichen, empfiehlt es sich, auf Formularen Standardanker zu nutzen. In manchen Fällen können aber auch Zeilentrennzeichen, erklärender Text oder Barcodes als Anker benutzt werden. Standardanker sind jedoch zuverlässiger und sollten daher immer Ihre erste Wahl sein.


Erstellung maschinenlesbarer Formulare/Zeilentrennzeichen

Zeilentrennzeichen

Ein Zeilentrennzeichen ist ein Element eines maschinenlesbaren Formulars, das die Gestalt einer vertikalen oder horizontalen schwarzen Linie hat.

Zeilentrennzeichen werden verwendet, um Formulare in verschiedene logische Abschnitte zu unterteilen.


Erstellung eines maschinenlesbaren Formulars/Formularkennung

Formularkennung

Die Formularkennung ist ein Element eines maschinenlesbaren Formulars, das zur Auswahl der richtigen Dokumentdefinition verwendet wird, falls mehrere Dokumentdefinitionen über die gleiche Ankeranordnung verfügen.

Wir empfehlen die Verwendung von Barcodes als Formularkennung

Barcodes bestehen aus vertikalen schwarzen und weißen Balken verschiedener Breite, die codierte Informationen enthalten.

Beispiel eines Barcodes zeigen

Auch andere Elemente auf dem Formular können als Formularkennung benutzt werden.


Erstellung eines maschinenlesbaren Formulars/Bild

Bild

Bilder sind Elemente maschinenlesbarer Formulare, für die kein Erkennungsprozess durchgeführt wird und die als Bilddatei exportiert werden.

Der Bereich des Formulars, wo Stempel oder Unterschrift hingehören, ist z.B. ein Bild.


Tabelle

Eine Tabelle enthält Spalten mit Elementen gleichen Typs.

Tabellenspalten können folgende Typen von Elementen enthalten:

  • Text
  • Eingabefeld
  • Datum
  • Zahl
  • Auswahlkästchen

Tabellen können eine Zeile mit Spaltenüberschriften enthalten.


Elementgruppe

Elementgruppe – Element eines maschinenlesbaren Formulars, das dazu dient, mehrere logisch verknüpfte Elemente in einer Gruppe zusammenzufassen.


Methoden zum Ausfüllen von Formularen

Ein Formular kann auf eine der folgenden Arten ausgefüllt werden:

  • Von Hand

  • Durch Verwendung eines Punktmatrixdruckers

  • Durch Verwendung einer Schreibmaschine

  • In einer Druckerei (dies beinhaltet Formulare, die mithilfe von Tintenstrahl- oder Laserdruckern mit einer Auflösung von mindestens 300 dpi ausgefüllt wurden)

  • Durch eine Kombination der oben genannten Möglichkeiten


Maschinenlesbare Formulartypen

Maschinenlesbare Formulare werden für die automatische Datenerfassung entwickelt, d. h. das Programm sollte leicht zwischen den zu verarbeitenden Daten und solchen nicht der Erkennung unterliegenden Formularelementen, wie Feldbegrenzungen, Textmarkierungen, Hintergründen oder erklärendem Text, unterscheiden können.

Dies kann auf zwei Arten erreicht werden:

  1. Das Formular muss so gestaltet sein, dass die Feldbegrenzungen, der Hintergrund und die Textmarkierung nach dem Scannen verschwinden oder

  2. Das Formular muss so gestaltet sein, dass die Feldbegrenzungen, der Hintergrund und die Textmarkierung nach dem Scannen klar zu erkennen sind.

Wenn die erste Möglichkeit verwendet wird, verbleiben nach dem Scannen nur die Anker, erklärender Text und die eingetragenen Daten auf dem Formular. Dadurch muss das Programm nicht die Daten von den Formularelementen trennen, was die Erkennung einfacher und zuverlässiger gestaltet.

In diesem Fall werden folgende Formulartypen verwendet: Formulare mit Blindfarben, Schwarz-Weiß-Formulare mit gerastertem Hintergrund, Schwarz-Weiß-Formulare mit gerasterten Rändern und lineare Schwarz-Weiß-Formulare.

Wenn die zweite Möglichkeit verwendet wird, verbleiben nach dem Scannen die Anker, erklärender Text und die eingetragenen Daten sowie Textmarkierungen und Feldbegrenzungen auf dem Formular. Das Programm wird nach Informationen suchen, die von Feldbegrenzungen und Textmarkierungen umgeben sind. Wenn diese Formularelemente fehlen, wird die Erkennungsqualität erheblich beinträchtigt.
In diesem Fall werden lineare Schwarz-Weiß-Formulare verwendet.


Blindfarbformulare (Color Dropout)

Blindfarbformulare haben einen hellfarbigen Hintergrund, wobei weiße Rechtecke als Zeichenfelder, Auswahlfelder usw. dienen.

Ein Beispiel sind graue Blindfarbformulare, deren Hintergrund grau ist.

Zu den Blindfarbformularen gehören auch solche Formulare, bei denen nur die Ränder der Elemente farbig sind.

Zeichenfelder sind kleine Rechtecke, in die nur ein Zeichen eingegeben wird (z.B. ein Buchstabe oder eine Zahl). Die Farbe des Hintergrunds ist von großer Bedeutung, da sie beim Scannen verschwinden soll. Meistens ist der Hintergrund ein helles Rot-Orange oder Grün. Die Liste der empfohlenen Farben finden Sie unter Empfohlene Farben für Blindfarbformulare.

Beispiel eines Blindfarbformulars zeigen

Idealerweise sollten alle Formularelemente mit Ausnahme der Anker beim Scannen verschwinden, so dass nur die zu erkennenden Feldinhalte auf dem Formularabbild zurückbleiben.

Erklärende Texte können entweder beibehalten (bei schwarzem Druck) oder zusammen mit dem Hintergrund herausgefiltert werden. Wenn die erklärenden Texte beim Scannen verschwinden sollen, müssen Sie dieselbe Farbe wie der Hintergrund des Formulars haben, aber einen höheren Sättigungsgrad.

Bei der Entscheidung, ob die erklärenden Texte in Schwarz oder in der Hintergrundfarbe gedruckt werden sollen, ist zu berücksichtigen:

  • Die Bilddatei wird größer, wenn die erklärenden Texte beibehalten werden.

  • Zwischen schwarz gedruckten erklärenden Texten und anderen Elementen des Formulars sollte ein Abstand von wenigstens 1,5-2 mm bestehen. Der Abstand zwischen erklärendem Text und dem entsprechenden Auswahlfeld muss mindestens 2/3 der Auswahlfeldgröße betragen. Falls die erklärenden Texte in der Hintergrundfarbe gedruckt werden, sind die Abstände zu anderen Elementen des Formulars von geringerer Bedeutung.

Formulare mit schwarz gedruckten erklärenden Texten sind besser lesbar. Wir empfehlen, erklärende Texte in Schwarz zu drucken, besonders dann, wenn das Formular keine Anker enthält.

Tipp
Beachten Sie bei der Erstellung einer Dokumentdefinition für ein Formular, bei dem die erklärenden Texte in der Hintergrundfarbe gedruckt sind, dass dieses als Farb- oder Graustufenbild gescannt werden sollte, damit erklärende Texte und Elemente deutlich erkennbar sind.

Blindfarbformulare müssen mit einer Farblichtlampe oder einem Filter gescannt werden. Die Farbe der Lampe wird in Abhängigkeit von der Hintergrundfarbe ausgewählt.

Formulare mit rotem oder grünem Hintergrund müssen mit einer der folgenden Methoden gescannt werden:

  • Verwendung von Farbfiltersoftware mit einem Farbscanner
  • Verwendung einer Rot- oder Grünlichtlampe (Hardware-Farbfilter) mit einem Schwarzweiß-Scanner
  • Verwendung einer weißen Lampe und eines roten oder grünen Filters mit einem Schwarzweiß-Scanner (die Filterqualität ist in diesem Fall wesentlich geringer: Der Hintergrund wird u.U. nicht vollständig beseitigt, oder es gehen Feldinhalte verloren), oder
  • Verwendung einer weißen Lampe ohne Filter mit einem Schwarzweiß-Scanner
    Beim Scannen mit einer weißen Lampe können manche hellen Hintergründe auch ohne Filter entfernt werden: die geringe Sättigung des Hintergrunds sorgt dafür, dass er beim Scannen verschwindet. In diesem Fall muss durch Probieren für jeden Scanner eine geeignete Farbe und Sättigung ermittelt werden.

Hinweis: Manche Farbscanner verfügen auch über Software-Filterung zur Beseitigung blauer Farbtöne. Von der Verwendung von Blautönen wird jedoch abgeraten, da die Formulare vermutlich nicht nur mit schwarzer, sondern auch blauer Tinte ausgefüllt werden. Mit blauer Tinte geschriebene Feldinhalte würden dann verschwinden.

Wahl der richtigen Farbe

Rot-orange Farben sind gegenüber Grün zu bevorzugen, da sie im größtmöglichen Kontrast zu Blau stehen. Dies gewährleistet bei mit blauer Tinte ausgefüllten Formularen eine bessere Scan- und Erkennungsqualität.

Unter Empfohlene Farben für Blindfarbformulare sind die für die Formularverarbeitung empfohlenen Farben zusammengestellt, d.h. diejenigen, die mit fast jedem Scanner ausgeblendet werden können. Eine Liste geeigneter Blindfarben für ein bestimmtes Scannermodell (im Pantone- oder einem anderen Format) kann auch über den Hersteller oder Verkäufer des Geräts bezogen werden.


Schwarz-Weiß-Formulare mit gerastertem Hintergrund

Felder auf solchen Formularen sind einfache leere Flächen (normalerweise Rechtecke) vor einem gerastertem Hintergrund. Der Hintergrund wird aus einzelnen Punkten zusammengesetzt. Die empfohlene Größe der Punkte beträgt nicht mehr als 0,1 mm und der Abstand zwischen den Punkten beträgt ca. 1 mm. Die Größe der Punkte und der Abstand zwischen den Punkten ist sehr wichtig, da ein gerasterter Hintergrund vor allem während des Entfernens von Störungen entfernt wird und nicht während des Scannens. Das Programm behandelt die Punkte als überflüssige Elemente und löscht sie. Die Punkte dürfen daher auf den gescannten Bildern nicht verschmelzen.


Schwarz-Weiß-Formulare mit gerasterten Rändern

Diese Formulare haben keinen Hintergrund. Alle Feldränder (Zeichen- und Auswahlfelder sowie andere Elemente) bestehen aus gerasterten Linien, d.h Reihen kleiner schwarzer Punkte. Die Rasterpunktgröße liegt meist im Bereich 0,39-0,5 pt. Die empfohlene Größe ist 0,39 pt, wobei der Abstand der Rasterpunkte mindestens das Fünffache der Punktgröße betragen sollte. Die Größe der Punkte und Abstände ist von entscheidender Bedeutung, da gerasterter Hintergrund nicht beim Scannen, sondern vorwiegend beim Entfernen von Störungen beseitigt wird: Das Programm behandelt die Punkte als überflüssige Elemente und löscht sie. Die Punkte dürfen daher auf den gescannten Bildern nicht verschmelzen.


Lineare Schwarz-Weiß-Formulare

Diese Formulare haben normalerweise keinen Hintergrund. Alle Feldränder (Zeichen- und Auswahlfelder sowie andere Elemente) bestehen aus durchgängigen schwarzen Linien. Die Feldränder verschwinden beim Scannen und Entfernen von Störungen nicht.

Hinweis: Formulare dieses Typs müssen sehr ordentlich ausgefüllt werden. Falls die Formulare achtlos ausgefüllt werden, können sich Buchstaben und Feldränder überlappen, was die Erkennungsqualität reduziert. Grund dafür ist, dass es für das Programm äußerst schwierig ist, Text und Ränder zu unterscheiden, die sich überlappen. Am besten ist es, wenn der eingetragene Text die Felder nicht berührt.


Wahl des richtigen Formulartyps

Zusätzlich zu den Anforderungen an Layout und Verarbeitung, die jeder Formulartyp stellt, sind bei der Wahl eines Formulartyps weitere Kriterien zu berücksichtigen. Dazu gehören Druckkosten und Druckverfahren, die Anzahl der erforderlichen Kopien, die resultierende Bildgröße, Scanmodi, der erforderliche Grad der Erkennungsgenauigkeit, die Geschwindigkeit der Formularverarbeitung, das gesamte Aussehen der Formulare, wie ordentlich sie ausgefüllt werden usw. Die Vor- und Nachteile eines jeden Formulartyps sind in der nachfolgenden Tabelle aufgeführt.

Kriterien | Blindfarbformular (Color Dropout) |  | Schwarz-Weiß-Rasterformular |  | Lineares Schwarz-Weiß-Formular
 | Nachteil | Vorteil | Nachteil | Vorteil | Nachteil | Vorteil
Kompliziertheit des Layouts |  | Mit jedem beliebigen Grafikeditor leicht zu entwerfen. | Texteditoren bieten nur in eingeschränktem Maß Funktionen zum Entwurf dieses Formulartyps an. Ausschlaggebend ist die Größe der Rasterpunkte. |  |  | Mit jedem beliebigen Grafikeditor leicht zu entwerfen
Druck | Große Mengen an qualitativ hochwertigen Formularen können hausintern nur schwierig gedruckt werden. |  |  | Hausintern leicht auszudrucken. |  | Hausintern leicht auszudrucken.
Druckkosten | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Schwarz-Weiß-Formularen höher. |  |  | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Blindfarbformularen geringer. |  | Bei Inanspruchnahme professioneller Druckereien sind die Druckkosten im Vergleich zu Blindfarbformularen geringer
Bildgröße |  | Die Bilddateien sind kleiner. | Die Bilddateien sind größer. |  | Die Bilddateien sind größer. |
Scanmodus | Nur spezielle Scanmodi (Farbfilter) können verwendet werden. |  | Der Bereich von Helligkeits- und Kontrasteinstellungen ist eingeschränkt. |  | Der Bereich von Helligkeits- und Kontrasteinstellungen ist eingeschränkt. |
Verarbeitungsgeschwindigkeit |  | Die mittlere Verarbeitungsgeschwindigkeit ist höher. | Die mittlere Verarbeitungszeit ist länger, weil Störungen aus den Bildern entfernt werden müssen. |  | Fehler sind wahrscheinlicher, wenn Buchstaben verschmolzen sind oder Feldränder überlappen. |
Erkennungsqualität |  | Hohe Erkennungsqualität. |  | Hohe Erkennungsqualität. | Die Erkennungsqualität hängt größtenteils davon ab, wie ordentlich das Formular ausgefüllt wurde. | Wenn das Formular richtig ausgefüllt wurde, ist die Erkennungsqualität hoch.
Position von erklärendem Text |  | Erklärender Text kann beliebig, beispielsweise innerhalb von Feldern, angeordnet werden (solange er mit derselben Farbe wie der Formularhintergrund gedruckt wird). | Erklärender Text und andere Formularelemente müssen auf dem Formular sorgfältig angeordnet werden. |  | Erklärender Text und andere Formularelemente müssen auf dem Formular sorgfältig angeordnet werden. |
Aussehen und Lesbarkeit des Formulars | Niedriger Kontrast des Hintergrundes und des erklärenden Textes können die Lesbarkeit beeinträchtigen. | Ästhetisch ansprechend | Weniger auffälliges Design. Geringere Lesbarkeit. |  | Weniger auffälliges Design. | Gute Lesbarkeit.
Genauigkeit beim Ausfüllen |  | Weniger empfindlich gegen ein Überlappen von Text und Feldrändern. | Kleine Buchstaben müssen sehr sorgfältig geschrieben werden und groß genug sein, um nicht als überflüssige Elemente entfernt zu werden. | Weniger empfindlich gegen ein Überlappen von Text und Feldrändern. | Sehr empfindlich gegen ein Überlappen von Text und Feldrändern. |


Allgemeine Anforderungen für maschinenlesbare Formulare

Wir wollen jetzt einen Blick auf die allgemeinen Anforderungen werfen, die ein Formular erfüllen muss, um maschinenlesbar zu sein.

Anforderungen an den Formularhintergrund
Ankeranforderungen
Anforderungen für Auswahlfelder
Anforderungen für die Textmarkierung
Anforderungen an die Elementanordnung
Anforderungen an die Druckqualität
Anforderungen für das Ausfüllen der Formulare


Anforderungen an den Formularhintergrund

  1. Verwenden Sie nach Möglichkeit Formulare mit Blindfarben (Color Dropout) oder mit gerasterten Feldrändern.
  2. Wählen Sie bei der Erstellung eines Formulars eine Farbe, die beim Scannen entfernt wird. Siehe Liste der empfohlenen Farben unter Empfohlene Farben für Blindfarbformulare.
  3. Achten Sie darauf, dass zwischen Erklärungstext und Feldinhalt immer ein Freiraum besteht. Bei Blindfarbformularen empfehlen wir, alle Informationen in der Farbe des Formularhintergrunds zu drucken (außer, wenn der Erklärungstext als Anker anstatt von oder zusammen mit schwarzen Quadraten verwendet wird). Wenn Sie Informationen in der Hintergrundfarbe drucken, können Sie sie überall auf dem Formular positionieren, auch innerhalb der Formularfelder.
  4. Verwenden Sie keine Blautöne für Formulare, die von Hand ausgefüllt werden sollen. Ein blauer Hintergrund könnte nur schwer von blauer Tinte unterschieden werden, die gewöhnlich zum Ausfüllen der Formulare verwendet wird. Dies würde die Erkennungsqualität beeinträchtigen.


Ankeranforderungen

  1. Zur Verwendung in maschinenlesbaren Formularen werden Standardanker empfohlen (d. h. schwarze Quadrate, Ecken, Kreuze). Die empfohlene Anzahl der Anker beträgt fünf: vier Anker in jeder Ecke des Formulars (sie sollten ein Rechteck bilden, wenn imaginäre Linien zwischen jedem Paar gezeichnet werden) und ein quadratischer Anker auf einer der Seiten des imaginären Rechtecks.
  2. Wenn aus irgendwelchen Gründen keine Standardanker verwendet werden können, empfehlen wir die folgenden Elementkombinationen zur Verwendung als Anker:
    a) mindestens zwei senkrechte Zeilentrennzeichen und zwei waagerechte Zeilentrennzeichen
    b) mindestens vier Textelemente und ein Formularidentifizierungselement
    c) es sind auch andere Kombinationen möglich
  3. Der Abstand zwischen dem Rand eines Ankers und dem nächstgelegenem Formularelement sollte mindestens 3 mm betragen.
  4. Der Abstand zwischen einem Anker und dem Seitenrand sollte mindestens 8 mm betragen.
  5. Anker sollten mit einer dunklen Farbe gedruckt werden (es wird schwarz empfohlen), so dass diese während des Scannes nicht verschwinden.

Zusätzlich zu den oben gelisteten allgemeinen Anforderungen hat jeder Ankertyp seine eigenen spezifischen Anforderungen:

Anforderungen für schwarze Quadrate

Schwarze Quadrate auf demselben Formulartyp sollten alle dieselbe Größe haben, d. h. zwischen 4 ? 4 mm und 8 ? 8 mm. Die empfohlene Größe beträgt 5 ? 5 mm. Rechtecke sind nicht erlaubt.

Anforderungen für Kreuze und Ecken

  1. Die Größe eines imaginären Quadrats, das um diesen Ankertyp gezeichnet werden könnte, muss zwischen 4 x 4 und 8 x 8 mm betragen. Die empfohlene Größe beträgt 5 x 5 mm.
  2. Die Ankergröße eines Typs muss innerhalb eines Formulars dieselbe sein.
  3. Alle Ankerseiten müssen dieselbe Größe haben.
  4. Die für Anker auf demselben Formular verwendete Linienbreite muss einheitlich sein und zwischen 0,3 und 1 mm liegen. Die empfohlene Breite beträgt 0,5 mm.

Anforderungen für Text (wenn als Anker verwendet)

Die Schriftgröße sollte mindestens 7 pt betragen (Titelzeilen – mindestens 14 pt).

Anforderungen für Zeilentrennzeichen (wenn als Anker verwendet)

Die Linienbreite sollte mindestens 1 pt betragen. Die empfohlene Breite beträgt 1 – 1,5 pt.

Anforderungen für Barcodes (wenn als Anker verwendet)

  1. Die Breite des Barcodes (der Abstand zwischen den äußeren Strichen) sollte mindestens 47-50 mm betragen.
  2. Die Höhe des Barcodes sollte mindestens 12-15 mm betragen (ohne Ziffern).
  3. Die Ausrichtung des Barcodes (Richtung der Striche) sollte mit der Seitenausrichtung übereinstimmen (es wird empfohlen, die Seiten in der Richtung der Striche zu scannen).
  4. Es wird das Barcodeformat EAN 13 empfohlen.
  5. Der empfohlene Abstand zwischen einem Barcode und einem anderen Formularelement muss mindestens 10 mm betragen.


Anforderungen für Auswahlfelder

  1. Als Feldgrößen werden 3,5x3,5 mm, 4x4 mm, 4,5x4,5 mm und 5x5 mm empfohlen (falls kreisförmige Auswahlfelder benutzt werden, müssen sie in das Quadrat einer der empfohlenen Größen passen).
  2. Als Linienstärke für den Rand der Auswahlfelder empfehlen wir 0,4 mm (unabhängig von der Feldgröße).


Anforderungen für die Textmarkierung

Rasterpunktgröße:

  1. Falls die Feldränder aus Rasterpunkten bestehen, muss die Stärke der Rasterlinie (d.h. die Rastergröße) 0,39 pt sein.

  2. Der optimale Abstand der Rasterpunkte beträgt das Fünffache ihrer Größe.

    Wichtig! Die Punkte, die am wahrscheinlichsten miteinander verschmelzen, sind diejenigen in den Ecken der Zeichenfelder.

Tipp
Falls Ihre Software keine Möglichkeit zur Einstellung des Rasterpunktabstands bietet, müssen Sie einen Linienstil wählen, bei dem zwischen den Punkten ausreichender Abstand besteht. Ansonsten können die Punkte auf dem gescannten Bild verschmelzen und nach der Störungsbeseitigung zurückbleiben. Dies liegt daran, dass große Punkte vom OCR-System nicht als überflüssige Elemente interpretiert und folglich nicht bereinigt werden.

Zeichenfeldgröße:

  1. Die empfohlene Größe der Zeichenfelder ist 4?5 mm; bei Verwendung kleinerer Felder wird von der ausfüllenden Person eine sehr genaue Schreibweise verlangt, die nicht leicht zu erreichen ist. Zu große Zeichenfelder sind ebenfalls nicht zu empfehlen, da sie zur Verwendung übergroßer Buchstaben ermutigen würden. Idealerweise sollte die Zeichenfeldgröße auf die durchschnittliche Buchstabengröße abgestimmt sein.
  2. Der Abstand zwischen den Feldlinien sollte nicht weniger als 2,5-3 mm betragen und der Abstand zwischen benachbarten Zeichenfeldern derselben Linie nicht weniger als 1-1,2 mm.
Beispiel von Zeichenfeldern zeigen

Linienstärke:

  1. Falls die Feldränder aus schwarzen Linien bestehen („Text im Rahmen“, „Buchstaben in getrennten Rahmen“ oder „Buchstaben in Rahmen“), sollte die Linienstärke 1 pt sein.
Beispiel schwarzer Linien zeigen

Kämme:

  1. Der empfohlene Abstand zwischen den Kammzinken beträgt 5 mm.
  2. Wenn zwei Kämme untereinander positioniert sind, sollte der Abstand zwischen ihren horizontalen Linien nicht weniger als 7,5-8 mm betragen.
  3. Die Zinkenhöhe sollte etwa 0,9-1,2 mm betragen.
  4. Die Stärke sowohl der Kammzinken als auch der horizontalen Linie sollte 1 pt betragen.
  5. Falls Rahmen mit Kamm verwendet werden, sollte ein Mindestabstand zwischen den Rahmen von 2,5-3 mm bestehen.
Beispiel eines Kamms zeigen


Anforderungen an die Elementanordnung

  1. Achten Sie darauf, ausreichend große Ränder auf Ihrem Formular zu lassen. Andernfalls könnten Elemente, die sich zu nahe am Seitenrand befinden, beim Scanvorgang ausgelassen werden und Daten verloren gehen.
  2. Der Abstand zwischen benachbarten Formularelementen sollte nicht weniger als 2 mm betragen.
  3. Der Abstand zwischen Auswahlfeldern und erklärendem Text sollte mindestens 2/3 der Auswahlfeldgröße betragen.
  4. Achten Sie darauf, dass der erklärende Text nicht die Ränder der Eintragsfelder überschneidet.
  5. Falls der erklärende Text in schwarzer Tinte gedruckt wird, sollten Sie darauf achten, dass ein Abstand von wenigstens 1,5-2 mm zwischen dem erklärenden Text und anderen Elementen besteht. Dieser Abstand ist weniger wichtig, wenn der erklärende Text in der Hintergrundfarbe gedruckt wird.


Anforderungen an die Druckqualität

Beachten Sie beim Drucken leerer Formulare die folgenden Anforderungen:

  1. Die Formulare müssen entweder professionell oder mit einem Drucker gedruckt werden. Bei Farbformularen empfehlen wir Ihnen professionellen Druck. Falls dies nicht möglich ist, testen Sie die Formularfarbe mit einem Scanner, bevor Sie eine größere Anzahl drucken.
  2. Alle Exemplare des Formulars müssen vom selben Quelldokument gedruckt werden, damit sich die Felder auf jedem Formular an derselben Position befinden.
  3. Der Rand (d.h. der Abstand zwischen Blattrand und nächsten Formularelement) muss mindestens 8 mm breit sein (12 mm empfohlen).
  4. Die lineare Abweichung der Formularelemente darf 0,15 % nicht übersteigen (d.h. 0,5 mm bei A4-Seiten).
  5. Verwenden Sie eine Auflösung von mindestens 600 dpi, falls Sie Ihre Formulare mit einem Drucker drucken.
  6. Es empfiehlt sich, alle Formulare mit demselben Drucker oder mit mehreren Druckern desselben Modells zu drucken.

Tipp: Wir raten davon ab, für die maschinelle Verarbeitung bestimmte Dokumente mit Kopiergeräten zu vervielfältigen. Bei Verwendung solcher Geräte kann es zu leichten Abweichungen der Größe der Elemente oder ihrer Anordnung kommen. Z.B. können die Ränder von Tabellen und Eintragsfeldern breiter ausfallen oder die Farbtiefe verändert und so die Erkennungsqualität beeinträchtigt werden.


Anforderungen für das Ausfüllen der Formulare

Schreibgeräte und Tinte

Formulare werden am besten ordentlich in Großbuchstaben mit einem schwarzen Kugelschreiber, Gelstift oder Kapillarfüller ausgefüllt (dunkles Blau und Violett sind auch akzeptabel). Filzstifte und andere Stifte mit weichem Kopf sind nicht zu empfehlen, da breite Schreiblinien die Erkennung erschweren. Am schwierigsten ist die Erkennung bei Formularen, die mit Bleistift oder heller Tinte ausgefüllt wurden.

Buchstabengröße und -stil

Für optimale Erkennungsresultate sollte ein Formular mit großen Druckbuchstaben ausgefüllt werden. Die Buchstaben müssen alle Zeichenfelder ausfüllen, dürfen aber nicht über die Feldränder hinausgehen.

Falls die Zeichenfelder auf dem Formular visuell kenntlich gemacht werden (d.h. eine der folgenden Textmarkierungsarten verwendet wird: Buchstaben in Rahmen, Buchstaben in getrennten Rahmen), wird die ausfüllende Person die Buchstaben mit geringerer Wahrscheinlichkeit miteinander verbinden.

Die folgenden Textmarkierungsarten stellen größere Anforderungen an das Erkennungsverfahren: Text im Rahmen mit Kamm, Buchstaben auf einem Kamm. In diesen Fällen wird nur die Breite des Zeichenfelds vorgegeben. Das Fehlen von Seitenrändern erlaubt das Verbinden der einzelnen Buchstaben. Im Fall des Kamms ohne Rahmen können die Buchstaben zu groß oder zu klein geschrieben werden.

Falls Text in Rahmen oder Text über Linien verwendet wird, liegt keine erkennbare Beschränkung der Schriftzeichenbreite vor. Die Buchstaben können miteinander verbunden werden, was die Erkennungsqualität beeinträchtigt. Im Fall von Text über einer Linie gibt es auch keine Beschränkung der Schriftzeichenhöhe. Diese Markierungsart wird daher nicht für Formulare empfohlen, die eine hohe Erkennungsgenauigkeit verlangen.

Eine weitere wichtige Anforderung ist, dass die Buchstaben nicht die Feldränder überlappen. Dies ist weniger entscheidend bei Blindfarben- und Schwarzweißraster-Formularen, bei denen die Feldränder während des Scannens und Entfernens von Störungen verschwinden. Wenn sich die Buchstaben jedoch auf linearen Schwarzweiß-Formularen mit den Rändern überlappen, kann dies zu einer erheblichen Verschlechterung der Erkennungsqualität führen.

Beispiel

Wir empfehlen, einen Hinweis ähnlich dem Folgenden auf dem Formular anzubringen, um das korrekte Ausfüllen zu unterstützen.


Empfohlene Farben für Blindfarbformulare

Die folgende Tabelle zeigt Beispiele zu filternder Farben und die entsprechenden Pantone-Nummern. Diese Hintergrundfarben verschwinden beim Scannen der Formulare:

  • Verwendung eines beliebigen Scanners
    Tabelle für Weißlichtlampe anzeigen
  • Verwendung eines Farbscanners mit softwaregesteuertem Rotfilter oder eines Schwarzweiß-Scanners zusammen mit einer Rotlichtlampe oder einem Rotfilter.
    • Tabelle für Rotlichtlampe anzeigen


Tastaturbefehle

Tastenkombinationen

In diesem Abschnitt werden die Tastenkombinationen aufgeführt, die in verschiedenen Fenstern des Programms verwendet werden können. Das Arbeiten mit Tastenkombinationen ist zeitsparend und vereinfacht die Arbeit.

Tastenkombinationen für die Projektkonfigurationsstation
Tastenkombinationen für die Verifizierungsstation
Tastenkombinationen für die Datenverifizierungsstation
Tastenkombinationen für den Dokumentdefinitionseditor
Tastenkombinationen für die Gruppenüberprüfung
Tastenkombinationen für die Feldüberprüfung


Tastaturbefehle im Hauptfenster der Projektkonfigurationsstation

Tastenkombinationen für die Projektkonfigurationsstation

Menü | Option | Tastenkombination
Datei | Neues Projekt… | Strg+Umschalt+N
 | Projekt öffnen… | Strg+Umschalt+O
 | Speichern | Strg+S
 | Neuer StapelNeuer Stapel… | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Bilder importieren… | Strg+I
 | Exportieren in Daten in Dateien… | Alt+Umschalt+S
 | Exportieren in Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > DrehenDrehen 90° im Uhrzeigersinn | Strg+W
 | Bild > DrehenDrehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Teststapel | Strg+Umschalt+B
 | Stapel | Strg+B
 | Details | Alt+1
 | Miniaturansichten | Alt+2
 | Bildmodus | Strg+1
 | Datenmodus | Strg+2
 | Vergrößern | Strg+Num+
 | Verkleinern | Strg+Num-
 | Miniaturansicht: Vergrößern | Strg+Umschalt+Num+
 | Miniaturansicht: Verkleinern | Strg+Umschalt+Num-
 | Vollbild | F11
 | Aktualisieren | F5
 | Objekteigenschaften | Alt+Eingabetaste
Erkennung | Analysieren | Strg+E
 | Dokumentdefinition zuordnen… | Alt+Umschalt+E
 | Erkennen | Strg+R
Überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächster Zusammenstellungsfehler | F9
 | Vorheriger Zusammenstellungsfehler | Umschalt+F9
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Projekt | Dokumentdefinitionen… | Strg+T
 | StapeltypenStapeltypen… | Strg+Umschalt+T
 | Bildimportprofile… | Strg+Umschalt+I
Extras | Auf neueste Version aktualisieren | Alt+Umschalt+U
 | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
 | Stapelintegritätsprüfung | Strg+Umschalt+E
Hilfe | Hilfethemen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste


Tastaturbefehle im Hauptfenster der Verifizierungsstation

Tastenkombinationen für die Verifizierungsstation

Menü | Option | Tastenkombination
Datei | Speichern | Strg+S
 | Neuer StapelNeuer Stapel… | Strg+N
 | Bilder laden… | Strg+O
 | Bilder scannen… | Strg+K
 | Exportieren in Daten in Dateien… | Alt+Umschalt+S
 | Exportieren in Datenbank… | Alt+Umschalt+D
 | Beenden | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Suchen… | Strg+F
 | Weitersuchen | F3
 | Gehe zu > Nächstes Dokument | Strg+D
 | Gehe zu > Vorheriges Dokument | Strg+Umschalt+D
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > DrehenDrehen 90° im Uhrzeigersinn | Strg+W
 | Bild > DrehenDrehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Stapel | Strg+B
 | Warteschlangen | Strg+Q
 | Details | Alt+1
 | Miniaturansichten | Alt+2
 | Bildmodus | Strg+1
 | Datenmodus | Strg+2
 | Vergrößern | Strg+Num+
 | Verkleinern | Strg+Num-
 | Miniaturansicht: Vergrößern | Strg+Umschalt+Num+
 | Miniaturansicht: Verkleinern | Strg+Umschalt+Num-
 | Vollbild | F11
 | Aktualisieren | F5
 | Objekteigenschaften | Alt+Eingabetaste
Task | Task abrufen | Strg+G
Erkennung | Analysieren | Strg+E
 | Dokumentdefinition zuordnen… | Alt+Umschalt+E
 | Erkennen | Strg+R
Überprüfung | Überprüfung ausführen… | F7
 | Nächstes zu überprüfendes Element | F4
 | Vorheriges zu überprüfendes Element | Umschalt+F4
 | Nächster Zusammenstellungsfehler | F9
 | Vorheriger Zusammenstellungsfehler | Umschalt+F9
 | Nächstes nicht eindeutiges Zeichen | F8
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F8
 | Nächster Regelfehler | F6
 | Vorheriger Regelfehler | Umschalt+F6
Extras | Auf neueste Version aktualisieren | Alt+Umschalt+U
 | Neu analysieren | Strg+Alt+E
 | Neu erkennen | Strg+Alt+R
 | Regeln erneut überprüfen | Strg+F6
 | Stapelintegritätsprüfung | Strg+Umschalt+E
Hilfe | Hilfethemen | F1
Allgemeine Befehle | Dokumentfenster öffnen (wenn ein Dokument oder eine Seite ausgewählt wurde) | Eingabetaste
 | Registrierungsparameter | Strg+P


Tastaturbefehle im Hauptfenster der Datenverifizierungsstation

Tastenkombinationen für die Datenverifizierungsstation

Menü | Option | Tastenkombination
Datei | Beenden | Alt+F4
Ansicht | Vollbild | F11
 | Aktualisieren | F5
Tasks | Task abrufen | Strg+G
Hilfe | Hilfethemen | F1


Tastaturbefehle im Dokumentdefinitionseditor

Tastenkombinationen für den Dokumentdefinitionseditor

Menü | Option | Tastenkombination
Dokumentdefinition | Seite hinzufügen… | Strg+P
 | Dokumentbereich hinzufügen… | Strg+Alt+S
 | Eigenschaften der Dokumentdefinition… | Strg+T
 | Speichern | Strg+S
 | Schließen | Alt+F4
Bearbeiten | Rückgängig | Strg+Z
 | Wiederholen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Bereich löschen | Umschalt+Entf
 | Alles auswählen | Strg+A
 | Nach Typ auswählen… | Strg+Umschalt+A
 | Feld erstellen - Text | Alt+Umschalt+T
 | Feld erstellen - Auswahlfeld | Alt+Umschalt+C
 | Feld erstellen - Auswahlfeldgruppe | Alt+Umschalt+M
 | Feld erstellen - Barcode | Alt+Umschalt+B
 | Feld erstellen -Bild | Alt+Umschalt+P
 | Feld erstellen - Tabelle | Alt+Umschalt+L
 | Feld erstellen - Gruppieren | Alt+Umschalt+G
 | Gruppe | Strg+G
 | Gruppierung aufheben | Strg+Umschalt+G
 | Text aus Bild kopieren… | Strg+Alt+C
 | Bild > Störungen entfernen | Strg+Alt+K
 | Bild > Invertieren | Strg+Alt+V
 | Bild > Drehen 90° im Uhrzeigersinn | Strg+W
 | Bild > Drehen 90° gegen Uhrzeigersinn | Strg+Umschalt+W
Ansicht | Statische Elemente | Strg+1
 | Feldbereiche | Strg+2
 | Dokumentstruktur anzeigen | Alt+F1
 | Dokumentstruktur - Felder | Alt+1
 | Dokumentstruktur - Seiten | Alt+2
 | Datenformular | Alt+F2
 | Bild skalieren - Vergrößern | Strg+Num+
 | Bild skalieren - Verkleinern | Strg+Num-
 | Eigenschaften | Alt+Eingabetaste
Dokument | Test ausführen. | Strg+R
Extras | Objekte automatisch erkennen… | Strg+D
 | Dokumentlayout überprüfen | F9
 | Bereich zuordnen | Strg+E
Hilfe | Hilfethemen | F1

Bildfenster

Option | Tastenkombination
Bereiche auswählen | Esc
Objekte automatisch erkennen | Strg+Umschalt+D
Anker erstellen | A
Trennlinie erstellen | S
Ankertext erstellen | X
Ankerbarcode erstellen | D
Text erstellen | T
Auswahlfeld erstellen | C
Auswahlfeldgruppe erstellen | M
Barcode erstellen | B
Bild erstellen | P
Tabelle erstellen | L
Gruppe erstellen | G
Bereich für Feld ohne Bereich erstellen | R
Unerkannten Bereich erstellen | O
Spaltenfeld erstellen | U
Tabellentrennlinie zeichnen | F
Trennlinie aus Tabelle löschen | E
Bereich anpassen | Strg+Alt+A
Name vorschlagen | Strg+Alt+N
Name aus Bild abrufen… | Strg+Alt+I
Markierungstyp erkennen | Strg+Alt+D

Fenster "Dokumentstruktur"

Option | Tastenkombination
Feldbild anzeigen | Eingabetaste
Feld umbenennen | F2
Wenn ein Feld ausgewählt ist: |
Hinzufügen einer Spalte mit Textfeldern | Alt+Umschalt+T
Hinzufügen einer Spalte mit Auswahlfeldern | Alt+Umschalt+C
Hinzufügen einer Spalte mit Barcodes | Alt+Umschalt+B
Hinzufügen einer Spalte mit Bildern | Alt+Umschalt+P
Wenn eine Auswahlfeldgruppe ausgewählt ist: |
Auswahlfeld hinzufügen | Alt+Umschalt+C


Tastaturbefehle im Fenster für die Gruppenüberprüfung

Tastenkombinationen für das Gruppenüberprüfungsfenster

Menü | Option | Tastaturbefehle
Überprüfung | Alle bestätigen | Eingabetaste
 | Alle aufschieben | Strg+Eingabetaste
 | Status ändern | Leertaste
 | Nächste Seite | Bild ab
 | Vorherige Seite | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Alles auswählen | Strg+A
Ansicht | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Bildanzeige > Vergrößern | Strg+Num+
 | Feldbild > Bildanzeige > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfethemen | F1
Lokales Symbolmenü | Zeichenbild anzeigen | F2
 | Bestätigen | Strg+E
 | Aufschieben | Strg+R
 | Zurücksetzen | Esc


Tastaturbefehle im Fenster für die Feldüberprüfung

Menü | Option | Tastaturbefehle
Überprüfung | Feld bestätigen | Eingabetaste
 | Aufschieben | Strg+Eingabetaste
 | Nächstes nicht eindeutiges Zeichen | F4
 | Vorheriges nicht eindeutiges Zeichen | Umschalt+F4
 | Nächstes Feld | Bild ab
 | Vorheriges Feld | Bild auf
 | Schließen | Alt+F4
Bearbeiten | Rückgängig machen | Strg+Z
 | Wiederherstellen | Strg+Y
 | Ausschneiden | Strg+X
 | Kopieren | Strg+C
 | Einfügen | Strg+V
 | Löschen | Entf
 | Alles auswählen | Strg+A
 | Zeilenumbruch einfügen | Umschalttaste+Eingabetaste
 | Zeichen verbinden | Strg+M
Ansicht | Felddaten > Erkannter Text | Alt+F1
 | Felddaten > Zeichenausschnitt | Alt+F2
 | Feldbild > Feldbild anzeigen | Strg+I
 | Feldbild > Oben | Alt+1
 | Feldbild > Unten | Alt+2
 | Feldbild > Bildanzeige > Vergrößern | Strg+Num+
 | Feldbild > Bildanzeige > Verkleinern | Strg+Num-
 | Zeichenbild anzeigen | F2
 | Vollbild | F11
Hilfe | Hilfe anzeigen | F1


Verwenden von Skripten in FlexiCapture 9.0

In diesem Abschnitt wird beschrieben, wie Sie in FlexiCapture 9,0 mithilfe von Skripten benutzerdefinierte Regeln schreiben, Exporte ausführen oder Exportsteuerungen erstellen.

Grundsätzlich werden zwei Skriptsprachen unterstützt: JScript® und VBScript.

Besonderheiten bei der Verwendung

In VBScript muss das Schlüsselwort "Me" verwendet werden, um auf Methoden und Felder im aktuellen Objekt zu verweisen (die Entsprechung in C++ und Java lautet "this"). Als aktuelle Objekte gelten bei Regeln verifizierbare Dokumenteinheiten (Einheiten mit einer Regel) und beim Export exportierbare Dokumente.

Me.CheckSucceeded = False

In JScript können Sie in derselben Situation das Schlüsselwort "this" auslassen:

this.CheckSucceeded = false; CheckSucceeded = false;

Fehler zu nicht gefundenen Methoden oder Eigenschaften werden zur Laufzeit des Skripts ausgegeben:

ChecckSucceeded = false; // Laufzeitfehler

Syntaxfehler werden beim Speichern des Skripts ausgegeben:

CheckSucceeded +++ false; // Syntaxfehler

Benutzerdefinierte Funktionen

Mithilfe des Skripteditors können Benutzer eigene Funktionen und Prozeduren schreiben und diese dann aus den Codes von Regeln oder Codes von Exporten aufrufen.

Benutzerdefinierte Funktionen können in einem der globalen Module erstellt werden, entweder im Exportmodul oder im Regelmodul. Sie können das gewünschte Modul im Skripteditor auswählen.

Alle Funktionen innerhalb eines Moduls müssen in derselben Sprache geschrieben sein. Der Kerncode einer Regel oder eines Exports kann in einer anderen Sprache geschrieben sein als in derjenigen, die im entsprechenden globalen Modul verwendet wird.

Sie können zum Beispiel von dem Code einer Regel aus, die in VBScript geschrieben ist, eine im globalen Modul enthaltene Funktion aufrufen, die in JScript geschrieben ist.

Funktionen können nur von „ihren eigenen“ Modulen aufgerufen werden. Das bedeutet, dass Sie aus dem Code für Regeln nur Funktionen aufrufen können, die im globalen Regelmodul enthalten sind, und aus dem Code für Exporte nur Funktionen, die im globalen Modul für Exporte enthalten sind. Andernfalls tritt während der Ausführung ein Fehler auf.

Funktionen werden folgendermaßen aufgerufen:

[VBScript]

result = Rules.SomeFunction( param1, param2 … )

Export.SomeFunction param1, param2 …

[JScript]

result = Rules.SomeFunction( param1, param2 … );

Export.SomeFunction( param1, param2 … );

Zeitüberschreitung bei Skriptausführung

Der Standardwert für Zeitüberschreitungen beträgt 10 Sekunden für Regeln und 1 Minute für den Export.

Zum Ändern des Standardwerts für Zeitüberschreitungen passen Sie die entsprechenden Werte in der Registrierung an.

Für Regeln:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\9.0\Controller\ScriptSupport\DefaultScriptTimeout

Für den Export:
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\9.0\Controller\ScriptSupport\ExportScriptTimeout

Die Werte für Zeitüberschreitungen werden in der Registrierung in Millisekunden angegeben. Dauert die Ausführung eines Skripts länger als der angegebene Wert für die Zeitüberschreitung, wird das Skript beendet. Bei Regeln wird die Fehlermeldung "Zeitüberschreitung bei Skriptausführung." zurückgegeben. Beim Exportieren wird eine ähnliche Meldung im Fenster Stapel in der Spalte Hinweise zur Verarbeitung angezeigt.

Erstellen von Regeln mithilfe von Skripten
Beschreibung von Exportprozeduren mithilfe von Skripten
Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture 9.0 Skripte


Erstellen von Regeln mithilfe von Skripten

Mit auf Skripten basierenden Regeln (ScriptRule) können Benutzer komplexe benutzerdefinierte Algorithmen für die Dokumentüberprüfung und Normalisierung erstellen. Dabei kommen die Standardskriptsprachen JScript® und VBScript zum Einsatz.

Hinweis: Einige der im ersten Release von ABBYY FlexiCapture erstellten Skripts funktionieren im zweiten Release möglicherweise nicht. Das liegt daran, dass die im zweiten Release typisierten Feldwerte im ersten Release noch als Textwerte verwendet wurden. Sie können dieses Problem beheben, indem Sie a) die Eigenschaft "Value" für Skripte, die im Zusammenhang mit Feldtext verwendet werden, auf "Text" setzen oder b) die Eigenschaft "Value" so ändern, dass sie der aktuellen Beschreibung entspricht. Siehe auch Eigenschaften des Objekts "Feld".

Skripte für automatische Ersetzungen und Stapelintegritätsskripte werden auch in diesem Abschnitt beschrieben.

Objektmodell

Regeln können als Methode überprüfter Dokumenteinheiten angesehen werden, d. h., dass "this" oder "Me" auf das Objekt [Überprüfte Dokumenteinheit] verweisen, für das diese Regel derzeit gilt.

Mit einer Regel kann eine Dokumentüberprüfung basierend auf den Werten eines oder mehrerer Felder durchgeführt werden. Bei der Ausgabe eines Fehlers muss ein Fehlerkennzeichen gesetzt werden, und ggf. müssen die Fehlerbeschreibung, das Fokusfeld und Vorschläge für Ersetzungen angegeben werden. Außerdem können Sie mit einer Regel Felder als eindeutig erkannt kennzeichnen.

Sie können Dokumente mithilfe einer Regel normalisieren, indem Sie die Feldwerte in eine normale Darstellung ändern oder Informationen hinzufügen (beispielsweise das Datum der letzten Verarbeitung).

Überprüfte Dokumenteinheit

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
CheckSucceeded | Boolescher Wert | Lesen/Schreiben | Fehlerkennzeichen. True: Es ist kein Regelfehler aufgetreten. False: Es ist ein Regelfehler aufgetreten.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Fehlermeldung
FocusedField | [Feld] | Lesen/Schreiben | Fokusfeld
Field("AliasName") [Feld] Schreibgeschützt Feld mit dem Alias "AliasName".

Ein Alias ist ein spezieller Name für ein Feld, der verwendet wird, wenn das Feld vom Code einer Regel aus aufgerufen wird. Dadurch wirkt sich die Umbenennung eines Felds nicht auf die Verwendung des Felds im Regelcode aus.

Aliase ermöglichen außerdem die Verwendung von Feldern mit identischen Namen in derselben Regel (z. B. Felder mit identischen Namen aus verschiedenen Bereichen).

Ein Alias kann mit dem Namen des Felds übereinstimmen, kann sich aber auch davon unterscheiden.

Wenn Sie ein Feld zu einer Regel hinzufügen, wird für dieses Feld automatisch ein Alias erzeugt. Diese vom Programm erzeugten Aliase können Sie jedoch immer ändern.

Felder | [Auflistung von Feldern] | Schreibgeschützt | Eine Auflistung von Feldern der Regel
Dokument | [Dokument] | Schreibgeschützt | Ein Dokument mit einer überprüften Einheit
IsModuleAllowedByLicense | Boolescher Wert | Schreibgeschützt | Überprüft, ob auf das Modul mit den Lizenzparametern zugegriffen werden kann. Parameter: author ID, module ID (Zeichenfolge).

Wenn die überprüfte Dokumenteinheit ein Feld ist, unterstützt sie alle Eigenschaften und Methoden des Objekts [Feld]. Ist die überprüfte Einheit kein Feld, können Sie nicht auf die entsprechenden Eigenschaften und Methoden verweisen, da andernfalls ein Fehler auftritt.

Feld

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Wert Variable Lesen/Schreiben Typabhängiger Wert des Felds.

Bei Zahlfeldern ist eine Fließkommazahl enthalten.

Bei Feldern des Typs "Datum/Uhrzeit" ist der Wert des Datums enthalten (VT_DATE).

Bei Feldern des Typs "Währung" ist ein Summenwert enthalten (VT_CY).

Bei Auswahlfeldern ist ein boolescher Wert enthalten. Wenn Sie einem Auswahlfeld Werte zuweisen, können Sie sowohl die booleschen Werte true/false als auch die Textwerte "True"/"False" (unter Berücksichtigung der Groß-/Kleinschreibung) verwenden.
Der Wert einer Gruppe von Auswahlfeldern ist eine Liste mit den Namen der ausgewählten Auswahlfelder getrennt durch Semikola (;). Wenn keine Auswahlfelder ausgewählt wurden, ist die Zeichenfolge leer. Um den Wert einer Gruppe von Auswahlfeldern zu ändern, weisen Sie den zu markierenden Auswahlfeldern "true" und den nicht zu markierenden Feldern "false" zu. Außerdem müssen alle diese Auswahlfelder in der Regel enthalten sein.
Bei Gruppen, Tabellen und Bildern eine leere Zeichenfolge.
Sie können Gruppen, Gruppen von Auswahlfeldern und Tabellen keine Werte zuordnen. Wenn Sie versuchen, einem dieser Feldtypen einen Wert zuzuordnen, wird ein Fehler ausgelöst.

Text Zeichenfolge Lesen/Schreiben Der Textwert eines Felds. Ist bei allen Typen außer Auswahlfeldern mit "Value" identisch.
Bei Auswahlfeldern wird der Wert dieser Eigenschaft anhand der Feldeigenschaften bestimmt, die auf der Registerkarte Datentyp ausgewählt wurden.
Wichtig! Der Wert der Eigenschaft "Text" wird bei Anwendung der Regel nicht geändert, d. h., dass Sie nicht durch Ändern der Eigenschaft "Value" im Code gleichzeitig die Eigenschaft "Text" ändern können.
Im folgenden Beispiel sind die Werte von "oldText" und "newText" identisch:

Dim oldText, newText
oldText = me.Field("FieldName").Text
me.Field("FieldName").Value = newValue
newText = me.Field("FieldName").Text

Name | Zeichenfolge | Schreibgeschützt | Feldname
IsVerified Boolescher Wert Lesen/Schreiben Ein Kennzeichen gibt an, ob das Feld überprüft wurde. Ein Feld, das als geprüft gekennzeichnet ist, wird sowohl bei der Überprüfung als auch beim Zählen der Zeichen ignoriert, für die eine Überprüfung erforderlich ist.

Die Eigenschaft ist auf "True" gesetzt, wenn der Benutzer das Feld während der Überprüfung bestätigt hat oder wenn eine Regel die Eigenschaft auf "True" gesetzt hat.

Andernfalls ist der Wert der Eigenschaft "False".

IsCertain Boolescher Wert Lesen/Schreiben Kennzeichen zur Eindeutigkeit des Felds. Ein als eindeutig erkanntes Feld wird bei der Überprüfung und der Berechnung der Zeichen, für die eine Überprüfung erforderlich ist, ignoriert.

Diese Eigenschaft ist überholt und wurde nur aus Gründen der Abwärtskompatibilität erhalten. Bitte verwenden Sie stattdessen die Eigenschaft IsVerified.

IsMatched | Boolescher Wert | Schreibgeschützt | Ein Kennzeichen, das angibt, ob ein Feld übereinstimmt.
Items | [Auflistung von Feldern] | Schreibgeschützt | Bei einem mehrfach auftretenden Feld eine Auflistung aller seiner Instanzen. Wenn das Feld nicht mehrfach vorkommt: 0.
IsValid | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob der Feldwert gültig ist.
SuspiciousSymbols | Zeichenfolge | Schreibgeschützt | Eine Zeichenfolge aus den Zeichen 0 und 1, wobei die 1 für nicht eindeutige Zeichen steht. Bei Auswahlfeldern wird eine Zeichenfolge mit nur einem Symbol zurückgegeben.
IsVerified | Boolescher Wert | Lesen/Schreiben | Das Kennzeichen gibt an, ob das Feld überprüft wurde.
Regions | [Auflistung von Bereichen] | Schreibgeschützt | Auflistung von Feldbereichen.

Methoden:

Name | Parameter | Beschreibung
Suggest( Text ) | Variable | Fügt einen Hinweis mit einem Vorschlag für den Feldwert hinzu. Wenn Sie mehrere Varianten angeben möchten, rufen Sie die Methode nacheinander auf, bis die gewünschte Anzahl von Vorschlägen erreicht ist. Der Wert des von Ihnen hinzugefügten Hinweises muss dem Typ des Felds entsprechen (d. h., bei Zahlenfeldern muss es sich um eine Zahl handeln, bei Feldern des Typs "Datum/Uhrzeit" um ein Datum usw.).

Auflistung von Bereichen

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Bereiche in der Auflistung
Item(Index) | [Bereich] | Schreibgeschützt | Bereich mit dem Indexwert Index. Index kann Werte zwischen 0 und Count-1 annehmen.

Bereich

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
PageIndex | Ganzzahl | Schreibgeschützt | Der Index der Seite, auf der sich dieser Bereich befindet.
Rects | [Auflistung von Rechtecken] | Schreibgeschützt | Die Auflistung der Rechtecke, aus der der angegebene Bereich zusammengesetzt ist. Enthält im Fall eines rechteckigen Bereichs nur ein Rechteck.
SurroundingRect | [Rechteck] | Schreibgeschützt | Einschließendes Rechteck des Bereichs.
Bild | IPicture | Schreibgeschützt | Das Bild für diesen Bereich.

Auflistung von Feldern

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Felder in einer Auflistung
Item(Index) | [Feld] | Schreibgeschützt | Indexfeld. Für den Index sind Werte zwischen 0 und Count-1 möglich.

Dokument

Methoden:

Name | Parameter | Beschreibung
Seiten | [Auflistung von Seiten] | Auflistung von Dokumentseiten.
Property( Name ) | Name: Eigenschaftenname | Gibt den Wert der abgefragten Eigenschaft zurück. Der Rückgabewert ist vom Typ Variable.

Dokumenteigenschaften, die mit der Methode "Property" festgelegt werden können (die von dieser Eigenschaft abgerufenen Dokumenteigenschaften sind schreibgeschützt):

Wert | Typ | Beschreibung
"TemplateName" | Zeichenfolge | Dokumentdefinitionsname
"TotalSymbolsCount" | Ganzzahl | Anzahl von Zeichen
"UncertainSymbolsCount" | Ganzzahl | Anzahl nicht eindeutig erkannter Zeichen
"RecognizedSymbolsCount" | Ganzzahl | Anzahl von erkannten Zeichen
"Comment" | Zeichenfolge | Kommentar
"Created" | Datum | Erstellungsdatum
"CreatedBy" | Zeichenfolge | Erstellt von
"Recognized" | Datum | Erkennungsdatum
"RecognizedBy" | Zeichenfolge | Erkannt von
"Modified" | Datum | Datum der letzten Änderung
"ModifiedBy" | Zeichenfolge | Geändert von
"ProcessingErrors" | Zeichenfolge | Fehler
"ProcessingWarnings" | Zeichenfolge | Warnungen

Seite

Name | Typ | Zugriff | Beschreibung
ImageSource | Zeichenfolge | Schreibgeschützt | Name der Bildquelle (Dateiname, Scanprofilname).
ImageSourceType | Zeichenfolge | Schreibgeschützt | Eine Zeichenfolge, die den Typ der Bildquelle beschreibt. Mögliche Werte: Datei, Scanner, benutzerdefiniert oder leer.
ImageSourcePageNumber | Ganzzahl | Schreibgeschützt | Die Anzahl der Seiten in der Quelldatei.

Formatüberprüfung und automatische Ersetzungen mit einem Skript

Objektmodell

Die Referenz "this" oder "Me" zeigt auf das zu überprüfende Objekt und auf welches das Skript angewendet wird.

Das Skript ermöglicht Ihnen die Überprüfung eines gespeicherten Werts und, falls erforderlich, dessen Bearbeitung. Sie können auch eine Fehlermeldung bestimmen.

Zu überprüfendes Objekt

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Text | Zeichenfolge | Lesen/Schreiben | Die Zeichenfolge, die den Wert des Feldes enthält.
SuspiciousSymbols | Zeichenfolge | Schreibgeschützt | Eine Zeichenfolge aus den Zeichen 0 und 1, wobei die 1 für nicht eindeutige Zeichen steht. Bei Auswahlfeldern wird eine Zeichenfolge mit nur einem Symbol zurückgegeben.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Fehlermeldung.

Stapelintegritätsprüfung

Objektmodell

Die Referenz "this" oder "Me" zeigt auf das zu überprüfende Objekt und auf welches das Skript angewendet wird. Das Objekt enthält die Stapel- und Verarbeitungsergebnisse.

Das Skript ermöglicht Ihnen, den Stapel auf Integrität zu überprüfen und die Ergebnisse zurückzugeben. Es kann, falls erforderlich, eine Fehlermeldung erstellt werden.

Bei einem Dokument sind allgemeine Informationen über das Dokument ausreichend. Es sind keine Daten über die Elemente erforderlich. Daten über die Schlüsselfelder sind jedoch auch verfügbar (genauso wie beim Export). Deshalb muss das Feld ein Schlüsselfeld sein, wenn Sie den Wert eines Feldes bei einer Integritätsüberprüfung verwenden müssen.

Zu überprüfendes Objekt

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Stapel | [Stapel] | Schreibgeschützt | Zu überprüfender Stapel.
CheckSucceeded | Boolescher Wert | Lesen/Schreiben | Das Ergebnis der Stapelintegritätsprüfung.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Fehlermeldung.

Stapel

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
BatchTypeName | Zeichenfolge | Schreibgeschützt | Stapeltypname
Dokumente | [Auflistung von Dokumenten] | Schreibgeschützt | Dokumente im Stapel Bei einem Dokument sind allgemeine Informationen über das Dokument ausreichend. Es sind keine Daten über die Elemente (Felder, Seiten) erforderlich. Daten über die Schlüsselfelder sind jedoch auch verfügbar.
RegistrationProperties | [Auflistung der Registrierungsparameter] | Schreibgeschützt | Registrierungsparameter des Stapels.
RegistrationProperty (Name) | Zeichenfolge | Schreibgeschützt | Der Wert des Stapel-Registrierungsparameter mit dem Namen Name.

Seite

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
TemplateName | Zeichenfolge | Schreibgeschützt | Name des Bereichs
ImageSourceType | Zeichenfolge | Schreibgeschützt | Typ der Bildquelle. Kann die Werte Datei oder Scanner annehmen.
ImageSource | Zeichenfolge | Schreibgeschützt | Bildquelle Im Fall einer Datei ist dies der Name der Datei mit dem vollständigen Dateipfad. Im Fall eines Scanners ist dies der Name des Scanners.
ImageSourcePageNumber | Ganzzahl | Schreibgeschützt | Die Anzahl der Seiten in der Quelldatei.

Auflistung von Dokumenten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Dokumente in der Auflistung
Item(Index) | [Exportiertes Dokument] | Schreibgeschützt | Das Dokument mit dem Indexwert Index. Index kann Werte zwischen 0 und Count-1 annehmen.

Dokument

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
IsAssembled | Boolescher Wert | Schreibgeschützt | Die Markierung zeigt an, ob das Dokument zusammengestellt ist oder nicht.
IsVerified | Boolescher Wert | Schreibgeschützt | Die Markierung zeigt an, ob das Dokument überprüft ist oder nicht.
IsExported | Boolescher Wert | Schreibgeschützt | Die Markierung zeigt an, ob das Dokument exportiert wurde oder nicht.
TemplateName | Zeichenfolge | Schreibgeschützt | Name der Dokumentdefinition
ProcessingErrors | Zeichenfolge | Schreibgeschützt | Meldungstext für Verarbeitungsfehler
ProcessingWarnings | Zeichenfolge | Schreibgeschützt | Hinweise und/oder Warnungen, die dem Benutzer während der Verarbeitung angezeigt werden
TotalSymbolsCount | Zeichenfolge | Schreibgeschützt | Anzahl der Zeichen (ohne erkannte Zeichen, umfasst vom Benutzer hinzugefügte Zeichen und Regeln)
RecognizedSymbolsCount | Zeichenfolge | Schreibgeschützt | Anzahl erkannter Zeichen
UncertainSymbolsCount | Zeichenfolge | Schreibgeschützt | Anzahl nicht eindeutig erkannter Zeichen
Id | Zeichenfolge | Schreibgeschützt | Dokumentkennung
BatchName | Zeichenfolge | Schreibgeschützt | Name des Stapels
Field(FieldName) | [Dokumentfeld] | Schreibgeschützt | Feld mit dem NamenFieldName. Es können sowohl Felder als auch Bereiche zurückgegeben werden. FieldNameist der Name des Felds mit vollständigem Pfad (ab dem Bereich). Beispiel: "Bereich 1\Gruppe\Feld 1" Wichtig: Kommt eine Komponente im Feldpfad mehrmals vor, muss der Index dieser Komponente angegeben werden. Bei einer mehrmals vorkommenden Gruppe sieht die oben erwähnte Zeichenfolge beispielsweise wie folgt aus: "Bereich 1\Gruppe[Index]\Feld 1" Der Index nimmt den Wert zwischen 0 und Count-1 an, wobei "Count" die Anzahl der mehrmals vorkommenden Komponente ist. Eine Ausnahme tritt auf, wenn ein inkorrekter Name verwendet wird.
HasField (FieldName) | Boolescher Wert | Schreibgeschützt | Existenzprüfung für das Feld FieldName
Children | [Auflistung von Dokumentfeldern] | Schreibgeschützt | Auflistung der Dokumentbereiche
Pages | [Auflistung von Seiten] | Schreibgeschützt | Auflistung der Dokumentseiten
RegistrationProperties | [Auflistung der Registrierungseigenschaften] | Schreibgeschützt | Auflistung der Registrierungseigenschaften des Dokuments
Action | [Arbeitsergebnisse] | Schreibgeschützt | Spezielles Objekt mit Informationen zu den Exportergebnissen. Die Informationen werden während des Exports in dieses Objekt geschrieben. Diese Informationen können ggf. während der Verarbeitung nach dem Export verwendet werden.
IndexedItemValue (Name) | [Dokumentfeld] | Schreibgeschützt | Indexfeld mit dem Namen Name.Namekann ein Feldname mit vollständigem Pfad (ab dem Bereich) sein. Beispiel: "Bereich 1\Gruppe\Feld 1"
IsModuleAllowedByLicense (AuthorID, ModuleID) | Boolescher Wert | Schreibgeschützt | Modulverfügbarkeitsprüfung (entsprechend den Lizenzparametern:Autorenkennung,Modulkennung (Zeichenfolge).

Auflistung der Registrierungsparameter

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Parameter in der Auflistung
Item(Index) | [Registrierungsparameter] | Schreibgeschützt | Der Parameter mit dem Index index. index kann Werte zwischen 0 und Count – 1 annehmen.

Registrierungsparameter

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Name | Zeichenfolge | Schreibgeschützt | Name des Registrierungsparameters
Value | Zeichenfolge | Schreibgeschützt | Wert des Registrierungsparameters

Beispielskripte zum Erstellen benutzerdefinierter Regeln


Beispielskripte zum Erstellen benutzerdefinierter Regeln

Automatisierungsregel

In diesem Beispiel wird die Überprüfung von Tabellendaten veranschaulicht. Die Regel überprüft, ob die Tabellendaten dem Wert im Ergebnisfeld entsprechen. Die Tabelle enthält Spalten mit Preisen und Mengen bestimmter Waren. Die Regel wurde auf der Ebene eines Bereichs erstellt, der die Tabelle und das Ergebnisfeld enthält.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Code einer ActiveX-Komponente

Der angegebene Code entstammt einer CheckDoc-Klasse aus dem Projekt AutomationRule, das in den oben genannten Skripten verwendet wird.

Explizite Option

' Überprüft, ob die Tabellendaten mit dem Ergebnis übereinstimmen

' column1 - Preisspalte

' column2 - Mengenspalte

' resultField - Ergebnisfeld (<Total> oder Entsprechung)

' docObj - der überprüfte Dokumentknoten

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' Summieren der Tabellendaten

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' Genauigkeit des Vergleichs: das Ergebnis wird auf 2 Nachkommastellen gerundet

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Table data does not match the resulting value"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Durchsuchen der Liste von Varianten

Mit dem unten angegebenen Regelcode wird geprüft, ob der Feldwert einem der Werte in der Liste entspricht. Trifft dies nicht zu, wird ein Fehlerkennzeichen angezeigt, und dem Feld wird eine Liste von vorgeschlagenen Werten zugeordnet. Das Feld wird in Abhängigkeit vom Prüfergebnis als eindeutig oder nicht eindeutig erkannt gekennzeichnet.

[VBScript]

' Feldwert speichern

Dim fieldValue

fieldValue = me.Field("Field6").Value

' Liste von Werten für die Überprüfung erstellen

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

' Überprüfen, ob der Feldwert Werten in der Liste entspricht

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

' Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

me.Field("Field6").IsCertain = success

' Liste der Vorschläge für das Feld erstellen – Vorschläge können alle

' passenden Werte sein

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

' Ein Fehlerkennzeichen setzen

me.CheckSucceeded = success

[JScript]

// Feldwert speichern

var fieldValue = Field("Field6").Value;

// Liste von Werten für die Überprüfung erstellen

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// Feldwert mit Werten in der Liste vergleichen

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// Je nach Prüfergebnis den Eindeutigkeitsstatus des Felds festlegen

Field("Field6").IsCertain = success;

// Liste der Vorschläge für das Feld erstellen – Vorschläge können alle

// passenden Werte sein

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// Fehlerkennzeichen setzen

CheckSucceeded = success;

Überprüfung von Feldzuordnungen

Mit dem unten angegebenen Regelcode wird überprüft, ob das überprüfte Feld zugeordnet werden konnte.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Field InvoiceNumber is not matched"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Field InvoiceNumber is not matched";

}

Überprüfung von Auswahlfeldern

Mit dem unten stehenden Regelcode wird überprüft, ob das Auswahlfeld markiert wurde.

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Page status is not checked"

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Page status is not checked";

}

Überprüfung einer Auswahlfeldgruppe

Mit dem unten stehenden Regelcode werden alle Auswahlfelder in der Gruppe durchlaufen. Wenn kein Auswahlfeld markiert wurde, wird das erste Feld ausgewählt. Die Regel wurde für die Ebene mit den Gruppen von Auswahlfeldern geschrieben. Alle Auswahlfelder in der Gruppe wurden der Liste von Feldern hinzugefügt, die in die Regel einbezogen werden sollen. Für das Standardauswahlfeld (das erste Feld) wurde der Schreibschutz deaktiviert. Wenn die Gruppe keine Auswahlfelder enthält, wird das Kennzeichen für einen Regelfehler aktiviert.

Mit diesem Beispielcode werden sämtliche Felder der Regel durchlaufen. Da die Feldnamen nicht im Code angegeben sind, kann der Code für beliebige Gruppen von Auswahlfeldern verwendet werden.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "Keine Auswahlfelder in Gruppe"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "Keine Auswahlfelder in Gruppe";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}

Zuverlässigkeitsüberprüfung des Feldes
Mit dem unten angegebenen Regelcode wird die Anzahl der nicht eindeutigen Zeichen im Feld überprüft. Das Feld wird gelöscht, wenn die Anzahl der nicht eindeutigen Zeichen größer oder gleich drei ist. Dies ist ein Autokorrekturskript.

[VBScript]

dim susp, qty, strpos, i, SC, strposPrev

strposPrev = 0

qty = 0

SC = "1"

susp = me.SuspiciousSymbols

for i = 1 to len (susp)

strpos = InStr (i, susp, SC,1)

if strpos <> strposPrev and strpos <> 0 then

qty = qty + 1

strposPrev = strpos

end if

next

if qty >= 3 then

me.text = ""

end if

Stapelintegritätsprüfung
Überprüft, ob die Anzahl der auf der Kontrollseite bestimmten Dokumente mit der Zahl im Stapel und der Anzahl der eigentlich verarbeiteten Dokumente übereinstimmt. Wenn die Anzahl nicht übereinstimmt, wird ein Fehler zurückgegeben.

[VBScript]

dim DQty

dim i

for i = 0 to me.Batch.Documents.Count - 1

if me.Batch.Documents.Item(i).TemplateName = "Inv" then

DQty = me.Batch.Documents.Item(i).IndexedItemValue("DocQty")

exit for

end if

next

dim AcQty

AcQty = me.Batch.Documents.Count

if acqty <> DQty then

me.CheckSucceeded = false

me.ErrorMessage = "Falsche Anzahl von Dokumenten im Stapel:" & " " & AcQty& ". " & "Expected number:" & " " & DQty & "!"

end if


Beschreibung von Exportprozeduren mithilfe von Skripten

Objektmodell

Dieses Modell wird sowohl in Exportskripten als auch in Exportsteuerungsskripten verwendet.

Bei der Exportsteuerung handelt sich um ein spezielles Skript, das nach dem Abschluss des Exports ausgeführt wird (vorausgesetzt, dass die Option Skript nach Export ausführen auf der Registerkarte Exportieren des Dialogfelds für die Projekteigenschaften aktiviert und der Inhalt des Skripts nicht leer ist).

Der Export ist als Methode eines exportierbaren Dokuments anzusehen, d. h., dass "this" oder "Me" auf das Objekt [Exportierbares Dokument] verweisen, das derzeit exportiert wird.

Bei einer Exportsteuerung zeigen die Zeiger this oder Me auf ein Objekt des Typs [Exportergebnisse].

Feldwerte können während des Exports nicht geändert werden.

Stapel

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
BatchTypeName | Zeichenfolge | Schreibgeschützt | Stapeltypname.
Documents | [Auflistungvon Dokumenten] | Schreibgeschützt | Dokumente, die Teil des Stapels sind. Es stehen nur allgemeine Informationen über das Dokument und keine Informationen zu dessen Elementen (Felder, Seiten) zur Verfügung. Informationen zu Schlüsselfeldern sind jedoch verfügbar.
RegistrationProperties | [Auflistung von Registrierungsparametern] | Schreibgeschützt | Registrierungsparameter des Stapels.
RegistrationProperty (Name) | Zeichenfolge | Schreibgeschützt | Wert des Registrierungsstapels mit dem Namen Name.

Exportierbares Dokument

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
IsAssembled | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument zusammengestellt wurde.
IsVerified | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument überprüft wurde.
IsExported | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob das Dokument exportiert wurde.
TemplateName | Zeichenfolge | Schreibgeschützt | Dokumentdefinitionsname
ProcessingErrors | Zeichenfolge | Schreibgeschützt | Meldung über Verarbeitungsfehler
ProcessingWarnings | Zeichenfolge | Schreibgeschützt | Hinweise und/oder Warnungen, die während der Verarbeitung angezeigt wurden
TotalSymbolsCount | Ganzzahl | Schreibgeschützt | Summe der Zeichen (enthält neben den erkannten Zeichen auch vom Benutzer und durch Regeln hinzugefügte Zeichen)
RecognizedSymbolsCount | Ganzzahl | Schreibgeschützt | Anzahl erkannter Zeichen
UncertainSymbolsCount | Ganzzahl | Schreibgeschützt | Anzahl nicht eindeutig erkannter Zeichen
Id | Zeichenfolge | Schreibgeschützt | Dokumentkennung
BatchName | Zeichenfolge | Schreibgeschützt | Stapelname
Field(FieldName) | [Dokumenteinheit] | Schreibgeschützt | Einheit mit dem Namen "FieldName". Gibt ein Feld oder einen Bereich zurück. "FieldName" ist der Name einer Einheit zusammen mit dem vollständigen Pfad, beginnend beim Bereich. Beispiel: "Bereich 1\Gruppe\Feld 1" Wichtig! Wenn es sich bei einem Bestandteil des Pfads zu dem Feld um eine Mehrfachkomponente handelt, müssen Sie den Index dieser Komponente angeben. Bei einer Mehrfachgruppe müsste der Pfad beispielsweise wie folgt aussehen: "Bereich 1\Gruppe[Index]\Feld 1" Beim Index wird von einem Wert zwischen 0 und Count-1 ausgegangen, wobei "Count" für die Anzahl der Instanzen der Mehrfachkomponente steht. Es tritt eine Ausnahme auf, wenn ein ungültiger Name genannt wird.
HasField (FieldName) | Boolescher Wert | Schreibgeschützt | Überprüft, ob ein Feld mit dem Namen FieldName existiert.
Children | [Auflistung von Dokumenteinheiten] | Schreibgeschützt | Auflistung von Dokumentbereichen
Seiten | [Auflistung von Seiten] | Schreibgeschützt | Auflistung von Dokumentseiten
RegistrationProperties | [Auflistung von Registrierungsparametern] | Schreibgeschützt | Registrierungsparameter des Stapels.
Action | [Ergebnis der Operation] | Schreibgeschützt | Ein spezielles Objekt, das Daten zu den Ergebnissen der Exportoperation enthält. Das Programm schreibt die Daten während des Exports in dieses Objekt. Diese Daten können im Bedarfsfall von der Steuerung verwendet werden, die nach dem Abschluss des Exports ausgeführt wird.
IndexedItemValue (Name) | [Feld] | Schreibgeschützt | Indexfeld mit Namen Name.
IsModuleAllowedByLicense (AuthorID, ModuleID) | Boolescher Wert | Schreibgeschützt | Überprüft, ob auf das Modul mit den Lizenzparametern zugegriffen werden kann. Parameter: author ID, module ID (Zeichenfolgen).

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert die Bilder aller Dokumentseiten in eine Datei.

Dokumenteinheit

Eine Dokumenteinheit ist ein Bereich oder ein Feld.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Wert Variable Schreibgeschützt Eingegebener Wert des Knotens.

Bei Zahlfeldern wird eine Fließkommazahl zurückgegeben.

Bei Feldern des Typs "Datum/Uhrzeit" wird der Wert des Datums zurückgegeben (VT_DATE).

Bei Feldern des Typs "Währung" wird ein Summenwert zurückgegeben (VT_CY).

Bei Auswahlfeldern wird ein boolescher Wert zurückgegeben.

Bei Gruppen von Auswahlfeldern wird eine Liste der markierten Auswahlfelder oder, wenn keine Auswahlfelder markiert wurden, eine leere Zeichenfolge zurückgegeben.

Bei einem Bild wird ein Objekt zurückgegeben [Picture].

Gibt NULL zurück, wenn der Knoten keinen Wert hat. Überprüfen Sie immer, ob der Knoten Null ist, bevor Sie versuchen, den Knotenwert zu lesen (siehe Skriptbeispiel).

Das Lesen eines Werts gleich NULL löst einen Fehler aus.

In Bereichen, Tabellen und Gruppenfeldern ist der Wert beispielsweise NULL.

Der Wert kann NULL sein, wenn der Feldinhalt (erkannter oder vom Benutzer eingegebener Text) nicht mit dem Feldtyp übereinstimmt.

Text Zeichenfolge Schreibgeschützt Textwert des Knotens.

Bei Auswahlfeldern werden die Werte Yes/No (Ja/Nein) zurückgegeben.

Bei Gruppen von Auswahlfeldern wird eine Liste der markierten Auswahlfelder oder, wenn keine Auswahlfelder markiert wurden, eine leere Zeichenfolge zurückgegeben.

Bei Knoten ohne Wert (z. B. Bilder, Gruppen, Bereiche, etc.) wird eine leere Zeichenfolge zurückgegeben.

Name | Zeichenfolge | Schreibgeschützt | Name der Einheit
IsExportable | Boolescher Wert | Schreibgeschützt | Zeigt an, ob die Einheit exportiert werden soll
SuspiciousSymbols Zeichenfolge Schreibgeschützt

Eine Zeichenfolge aus den Zeichen 0 und 1, wobei die 1 für nicht eindeutige Zeichen steht.

Bei Auswahlfeldern wird eine Zeichenfolge mit nur einem Symbol zurückgegeben.

Für leere Einheiten ohne Wert wird eine leere Zeichenfolge zurückgegeben.
Children [Auflistung von Dokumenteinheiten] Schreibgeschützt Auflistung der untergeordneten Einheiten. Wenn keine untergeordneten Einheiten vorhanden sind, ist der Wert 0.
Eine Gruppe, eine Gruppe von Auswahlfeldern und eine Tabellenzeile verfügen z. B. nicht über untergeordnete Einheiten.
Items | [Auflistung von Dokumenteinheiten] | Schreibgeschützt | Bei einer mehrfach auftretenden Einheit eine Auflistung aller seiner Instanzen. Wenn die Einheit nicht mehrfach vorkommt: 0.
Regions | [Auflistung von Bereichen] | Schreibgeschützt | Eine Liste der Feldbereiche.
Field(FieldName) [Dokumentknoten] Schreibgeschützt Ein Knoten mit dem Namen FieldName. Gibt ein Feld oder einen Bereich zurück.
FieldName ist der Name des Knotens mit einem relativen Pfad (startet beim aktuellen Knoten).

Wichtig!

Bestimmen Sie den Index dieser Komponente, wenn ein Pfad mehrfach vorkommt.
HasField (Name) | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob ein Feld mit dem Namen "Name" im Dokument existiert.
IsIndexed | Boolescher Wert | Schreibgeschützt | Das Kennzeichen gibt an, ob der Knoten ein Indexfeld ist.

Bild

Hier ist ein Bild gemeint, das in eine Datei auf der Festplatte gespeichert werden kann.

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert das Bild eines Felds in eine Datei.

Auflistung von Dokumenteinheiten

Eine Auflistung von Dokumenteinheiten ist eine Auflistung von Feldern oder Bereichen.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Einheiten in einer Auflistung
Item(Index) | [Einheit] | Schreibgeschützt | Instanz einer Einheit. Für den Index sind Werte zwischen 0 und Count-1 möglich.

Auflistung von Seiten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Seiten in einer Auflistung
Item(Index) | [Seite] | Schreibgeschützt | Seite mit dem Index. Für den Index sind Werte zwischen 0 und Count-1 möglich.

Seite

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
TemplateName | Zeichenfolge | Schreibgeschützt | Name des Bereichs
ImageSourceType | Zeichenfolge | Schreibgeschützt | Typ der Bildquelle. Kann die Werte Datei oder Scanner annehmen.
ImageSource | Zeichenfolge | Schreibgeschützt | Bildquelle Im Fall einer Datei ist dies der Name der Datei mit dem vollständigen Dateipfad. Im Fall eines Scanners ist dies der Name des Scanners.
ImageSourcePageNumber | Ganzzahl | Schreibgeschützt | Die Anzahl der Seiten in der Quelldatei.
ExcludedFromDocumentImage | Boolescher Wert | Lesen/Schreiben | Das Kennzeichen schließt die Seite vom Export aus. Der Standardwert ist falsch.

Methoden:

Name | Parameter | Beschreibung
SaveAs (Dateiname, Bildspeicheroptionen) | Dateiname: der Name der Datei Bildspeicheroptionen: Speicheroptionen für das Bild (optional) | Speichert das Seitenbild.

Auflistung von Bereichen

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Bereiche in der Auflistung
Item(Index) | [Bereich] | Schreibgeschützt | Der Bereich mit dem Indexwert index. Der Index kann Werte zwischen 0 und Count-1 annehmen.

Bereich

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
PageIndex | Ganzzahl | Schreibgeschützt | Der Index der Seite, auf der sich der angegebene Bereich befindet.
Rects | [Auflistung von Rechtecken] | Schreibgeschützt | Die Auflistung der Rechtecke, aus der der angegebene Bereich zusammengesetzt ist. Im Fall eines rechteckigen Bereichs enthält die Auflistung der Rechtecke nur ein Rechteck.
SurroundingRect | [Rechteck] | Schreibgeschützt | Das Rechteck, das den Bereich umschließt.
Bild | [Bild] | Schreibgeschützt | Das Bild für den angegebenen Bereich.
IsMatched | Boolescher Wert | Schreibgeschützt | Gibt an, ob das Feld erfolgreich zugeordnet wurde.

Auflistung von Rechtecken

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Rechtecke in der Auflistung
Item(Index) | [Rechteck] | Schreibgeschützt | Das Rechteck mit dem Indexwert Index. Index kann Werte zwischen 0 und Count-1 annehmen.

Rechteck

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Left | Ganzzahl | Schreibgeschützt | Die Koordinate für die linke Kante des Rechtecks auf der Seite.
Top | Ganzzahl | Schreibgeschützt | Die Koordinate für die obere Kante des Rechtecks auf der Seite.
Right | Ganzzahl | Schreibgeschützt | Die Koordinate für die rechte Kante des Rechtecks auf der Seite.
Bottom | Ganzzahl | Schreibgeschützt | Die Koordinate für die untere Kante des Rechtecks auf der Seite.

ExportTools

Ein globales Objekt, das zum Abrufen eines Objekts [Bildspeicheroptionen] verwendet wird.

Methoden:

Name | Parameter | Beschreibung
NewImageSavingOptions |  | Erstellt ein Objekt [Bildspeicheroptionen]

Bildspeicheroptionen

Optionen für das Speichern von Seitenbildern.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Format | Zeichenfolge | Lesen/Schreiben | Bildformat. Diese Eigenschaft kann folgende Werte annehmen: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf", "pdf-s", "pdf-a", "pdf-a-s", "pdf-s-a". Die Groß- und Kleinschreibung wird nicht berücksichtigt.
ColorType | Zeichenfolge | Lesen/Schreiben | Typ des verwendeten Farbschemas. Diese Eigenschaft kann folgende Werte annehmen: "FullColor", "GrayScale", "BlackAndWhite". Die Groß- und Kleinschreibung wird nicht berücksichtigt.
Resolution | Ganzzahl | Lesen/Schreiben | Die Auflösung des Bilds in dpi
Qualität | Ganzzahl im Bereich von 1 bis 100 | Lesen/Schreiben | Die Qualität der JPEG-Komprimierung (nur anwendbar bei Formaten, in denen die JPEG-Komprimierung verwendet wird).
ShouldOverwrite | Boolescher Wert | Lesen/Schreiben | Dieses Kennzeichen gibt an, ob beim Speichern eine vorhandene Datei überschrieben werden soll. Wenn das Kennzeichen auf false gesetzt ist, dann führt der Aufruf der Methode "SaveAs" zu einem Fehler, wenn bereits eine Datei mit demselben Namen vorhanden ist.

Ergebnisse der Operation

Enthält Daten zu den Ergebnissen der Exportoperation.

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Succeeded | Boolescher Wert | Lesen/Schreiben | Enthält true, wenn der Export erfolgreich war, andernfalls false.
ErrorMessage | Zeichenfolge | Lesen/Schreiben | Eine Fehlermeldung zu dem Fehler, der während des Exports aufgetreten ist.
Result Zeichenfolge Lesen/Schreiben Eine formale Beschreibung des Ergebnisses.

Bei einem Export in eine Datei ist hier der Name der Datei mit dem vollständigen Dateipfad enthalten.
Bei einem Export in eine Datenbank ist hier der Name der Haupttabelle des Exports enthalten.
Bei einem Export nach SharePoint ist hier die URL des exportierten Dokuments enthalten.

Name | Zeichenfolge | Schreibgeschützt | Exportprofilname.
Typ Ganzzahl Schreibgeschützt Typ der Exporteinstellungen(wird in Skripten nach dem Export verwendet). Folgende Werte sind möglich:
  • ET_File=1, Export in eine Datei
  • ET_Database=2, Export in eine Datenbank
  • ET_Script, Skript-basierter Export
  • ET_SharePoint, Export in SharePoint;
  • ET_Unknown, Typ wird nicht bestimmt (bei Fehlern, die nicht mit einem bestimmten Exportprofil in Zusammenhang stehen).

Exportergebnisse

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Dokumente | [Auflistung der exportierten Dokumente] | Schreibgeschützt | Eine Auflistung der während einer Exportsitzung exportierten Dokumente. Bei einem Dokument sind allgemeine Informationen über das Dokument ausreichend. Es sind keine Daten über die Elemente (Felder, Seiten) erforderlich. Daten über die wichtigsten Felder sind jedoch auch verfügbar.

Auflistung von exportierten Dokumenten

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Dokumente in der Auflistung
Item(Index) | [Exportiertes Dokument] | Schreibgeschützt | Das Dokument mit dem Indexwert Index. Index kann Werte zwischen 0 und Count-1 annehmen.

Auflistung der Registrierungsparameter

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Count | Ganzzahl | Schreibgeschützt | Anzahl der Parameter in der Auflistung
Item(Index) | [Registrierungsparameter] | Schreibgeschützt | Der Parameter mit dem Index index. index kann Werte zwischen 0 und Count – 1 annehmen.

Registrierungsparameter

Eigenschaften:

Name | Typ | Zugriff | Beschreibung
Name | Zeichenfolge | Schreibgeschützt | Name des Registrierungsparameters
Wert | Zeichenfolge | Schreibgeschützt | Wert des Registrierungsparameters

Beispielskripte für die Exportbeschreibung


Beispielskripte für die Exportbeschreibung

Abrufen von Feldwerten beim Export
Dieser Beispielcode veranschaulicht, wie Sie den Wert eines Felds beim Export abrufen. Sie können mit diesem Wert die Dateien benennen, in die die Bilder oder Daten exportiert werden. Ist kein entsprechendes Feld im Dokument enthalten, tritt ein Fehler auf.

Die Struktur des in diesem Beispiel exportierten Dokuments sieht wie folgt aus:

Section 1

Field1

…

Group1

Field2

…

…

FieldN

Section 2

Field1

…

FieldK

[VBScript]

Dim field1Value, field2Value

' Ruft den Wert von Field1 in Section 1 ab

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Ruft den Wert von Field2 in Group1 in Section 1 ab

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Ruft den Wert von Field1 in Section 1 ab, wenn der Bereich über mehrere Instanzen verfügt

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Ruft den Wert von Field1 in Section 1 ab

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Ruft den Wert von Field2 in Group1 in Section 1 ab

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Ruft den Wert von Field1 in Section 1 ab, wenn der Bereich über mehrere Instanzen verfügt

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Exportieren von Seitenbildern

Anhand des Codes in diesem Beispiel wird das Exportieren von Bildern aller Dokumentseiten mit dem erforderlichen Dateiformat, dem Farbschema und der Auflösung veranschaulicht. Die Bilder werden seitenweise gespeichert, so dass jede Seite in einer eigenen Datei gespeichert wird.

Die Dateien in diesem Beispiel werden mit "page1.tif", "page2.tif" usw. bezeichnet, Sie können das Benennungsschema für die Dateien aber ggf. ändern, indem Sie beispielsweise die Dateinamen auf Grundlage des Werts eines Felds erstellen.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject" )

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject" );

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // Legt den gewünschten Dateinamen und die Erweiterung in Abhängigkeit vom ausgewählten Format fest

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Exportieren einer Tabelle

In diesem Beispiel wird das Exportieren einer Tabelle in eine TXT-Datei veranschaulicht.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject" )

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Exportieren eines Dokuments mit beliebiger Verschachtelungstiefe

Dieses Beispiel zeigt, wie Felder eines Dokuments mit beliebiger Verschachtelungstiefe mithilfe benutzerdefinierter Funktionen aus dem globalen Exportmodul exportiert werden. Wenn Sie Dokumentfelder mit variabler Verschachtelung exportieren möchten, sollten Sie eine externe COM-Komponente verwenden. (Weitere Informationen finden Sie im nächsten Beispiel.)

Kerncode für den Export

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Der Code der Funktionen des globalen Exportmoduls

[VBScript]

' Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

set fso = CreateObject("Scripting.FileSystemObject" )

    ' Den Exportordner erstellen

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = falsch

        docObj.Action.ErrorMessage = "Fehler beim Erstellen eines Exportordners: " + Err.Description

        Err.Clear

Exit Sub

    End if

    ' Bilder exportieren

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Fehler beim Bildexport: " + Err.Description

        Err.Clear

Exit Sub

    End if

' Die Textdatei erstellen

fileName = fso.BuildPath( folderName, "doc.txt" )

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' Informationen über das Dokument exportieren

    ExportDocInfo docObj, txtFile

    ' Felder exportieren

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Fehler beim Datenexport: " + Err.Description

        Err.Clear

Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Bildexportfunktion.

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' Spezifizierungder Exporteinstellungen

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' Seitenweiser Export

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pages

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Prozedur zum Exportieren der Informationen über das Dokument

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

Next

End Sub

' Überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die Überprüfung auf NULL) eine Ausnahme auslösen

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Feldexportprozedur

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' Feldnamen speichern

    txtFile.Write (indent & field.Name)

    ' Feldwert, sofern verfügbar, speichern

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

   Else

        txtFile.WriteLine ("    " & field.Text)

   End If

    If Not field.Children Is Nothing Then

' untergeordnete Felder exportieren

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' Feldinstanzen exportieren

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderName

    ' Hauptordner

    exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

   End If

    ' the folder of the specified Document Definition

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

    fso.CreateFolder( docFolder )

   End If

    ' der Ordner für das exportierte Dokument

    Dim i

    i = 1

    folderName = fso.BuildPath( docFolder, i )

    While fso.FolderExists(folderName)

        i = i + 1

    folderName = fso.BuildPath( docFolder, i )

Wend

fso.CreateFolder( folderName )

    CreateExportFolder = folderName

End Function

[JScript]

// Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

// und Informationen über das Dokument

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

fso = new ActiveXObject("Scripting.FileSystemObject");

    // Exportordner erstellen

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Fehler beim Erstellen eines Exportordners: " + e.description;

        return;

    }

    // Bilder exportieren

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Fehler beim Bildexport: " + e.description;

        return;

    }

// Die Textdatei erstellen

    fileName = fso.BuildPath(folderName, "doc.txt");

txtFile = fso.CreateTextFile( fileName, true );

    // Informationen über das Dokument exportieren

    ExportDocInfo( docObj, txtFile);

    // Felder exportieren

    txtFile.WriteLine( "Fields:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Fehler beim Datenexport: " + e.description;

txtFile.Close();

        return;

    }

txtFile.Close();

    txtFile= 0;

    fso= 0;

}

// Bildexportfunktion

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // Spezifizierung der Exporteinstellungen

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

    // Seitenweiser Export

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Prozedur zum Exportieren der Informationen über das Dokument

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Überprüft, ob der Wert des Felds NULL ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die Überprüfung auf NULL) eine Ausnahme auslösen

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Feldexportprozedur

function ExportField(field, txtFile, indent)

{

    // Feldnamen speichern

    txtFile.Write(indent + field.Name);

    // Feldwert, sofern verfügbar, speichern

    if( IsNullFieldValue( field ) ) {

                            txtFile.WriteLine();

} else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // untergeordnete Felder exportieren

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // Export von Feldinstanzen

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // Hauptordner

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // der Ordner der spezifizierten Dokumentdefinition

    docFolder = fso.BuildPath(exportFolder, templateName);

if( !fso.FolderExists( docFolder ) ) {

    fso.CreateFolder( docFolder );

    }

    // der Ordner für das exportierte Dokument

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

while( fso.FolderExists( folderName ) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

fso.CreateFolder( folderName );

    return folderName;

}

Verwenden einer externen COM-Komponente

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Code einer ActiveX-Komponente in VisualBasic

Im Folgenden sehen Sie Code einer Exporter-Klasse aus dem Projekt "AutomationExport", das bereits in den oben beschriebenen Skripten verwendet wurde.

ExpliziteOption

DimmFso As New Scripting.FileSystemObject

' Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

' speichert in ihm Seitenbilddateien, die Textdatei mit den Dokumentfeldern

' und Informationen über das Dokument

PublicSub Export(ByRef docObj As Object, ByRef exportTools As Object)

OnError GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' Exportordner erstellen

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Kann Exportordner nicht erstellen"

        ExitSub

    End If

    ' Bilder exportieren

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' Die Textdatei erstellen

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' Informationen über Probleme beim Bildexport speichern

    IfimageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' Informationen über das Dokument exportieren

    exportDocInfo docObj, txtFile

    ' Felder exportieren

    txtFile.WriteLine "Fields:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Fehler beim Datenexport"

    EndIf

    txtFile.Close

    ' Wenn Fehler während des Exports auftreten,

    ' das Kennzeichen für erfolgreichen Export auf False zurücksetzen

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

ExitSub

err_h:

        docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

EndSub

' Bildexportfunktion. Wenn während des Bildexports ein Fehler auftritt,

' dann wird eine Meldung über den Fehler zurückgegeben, andernfalls eine leere Zeichenfolge

PrivateFunction exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

OnError GoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' Spezifizierung der Exporteinstellungen

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' Seitenweiser Export

    Set pages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

ExitFunction

err_h:

    exportImages = Err.Description

EndFunction

' Prozedur zum Exportieren der Informationen über das Dokument

PrivateSub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

OnError GoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

        txtFile.WriteLine

ExitSub

err_h:

    txtFile.WriteLine Err.Description

EndSub

' Prozedur zum Exportieren von Feldern aus der Auflistung von Feldern

PrivateFunction exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim curField As Object

    exportFields = True

    Für Jedes curField In Felder

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

    End If

    Next curField

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

EndFunction

' Überprüft, ob der Wert des Felds NULL ist

' Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

' die Überprüfung auf NULL) eine Ausnahme auslösen

FunctionIsNullFieldValue(ByRef field As Object) As Boolean

OnError GoTo err_h

    IsNullFieldValue = IsNull( field.Value )

ExitFunction

err_h:

    IsNullFieldValue = True

EndFunction

' Feldexportfunktion

PrivateFunction exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim result As Boolean

    result = True

    ' Feldnamen speichern

    txtFile.Write (indent & field.Name)

    ' Feldwert, sofern verfügbar, speichern

    IfNot IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' untergeordnete Felder exportieren

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' Feldinstanzen exportieren

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

EndFunction

' Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

PrivateFunction createExportFolder(ByVal templateName As String) As String

OnError GoTo err_h

    Dim docFolder As String, folderName As String

    ' Hauptordner

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' der Ordner der spezifizierten Dokumentdefinition

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' Ordner für das exportierte Dokument

    Dimi As Long

    i = 1

        folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

ExitFunction

err_h:

    createExportFolder = ""

EndFunction

Verwenden einer externen Komponente, die in .Net (C#) geschrieben ist

So verwenden Sie eine externe Komponente, die in .Net (C#) geschrieben ist:

  1. Erstellen Sie ein Projekt des Typs ClassLibrary.
  2. Fügen Sie die Controller.dll zu den Referenzen des Projekts hinzu. FlexiCaptureScriptingObjects wird in der Liste References aufgeführt, und alle Schnittstellen der Skriptobjekte werden im Projekt verfügbar.
  3. Definieren Sie die Schnittstelle disp und die Klasse, die diese Schnittstelle implementiert, sowie ProgId (dadurch wird es möglich, im Code des Skripts mit der .Net-Komponente so zu arbeiten wie mit ActiveX).
  4. Registrieren Sie nach dem Aufbau des Projekts die Library der generierten Typen (das kann auch automatisch durch das Aktivieren der entsprechenden Option in den Projekteigenschaften erfolgen).
  5. Rufen Sie vom Exportcode aus die Methode der Komponente auf die übliche Weise auf:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

Nachstehend der Code einer solchen Komponente:

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// Die Schnittstelle der Exportkomponente, auf die vom Skript aus zugegriffen werden kann

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// Die Klasse, die die Funktion der Exportkomponente implementiert

// Beim Erstellen einer neuen Komponente eine neue GUID erstellen

// und Ihre ProgId festlegen

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// Die Prozedur führt den Export durch: Sie erstellt einen Exportordner und

// speichert in ihm Seitenbilddateien,

// die Textdatei mit Dokumentfeldern und Informationen über das Dokument

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// Die Textdatei erstellen

string exportFolder = createExportFolder( docRef.TemplateName );

StreamWriter sw = File.CreateText( fileName );

// Informationen über das Dokument exportieren

exportDocInfo( docRef, sw );

// Felder exportieren

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// Die Funktion erstellt einen Exportordner und gibt seinen vollständigen Pfad zurück

privatestring createExportFolder( string templateName )

{

string docFolder, folderName;

// Hauptordner

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// der Ordner der spezifizierten Dokumentdefinition

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// Ordner für das exportierte Dokument

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

returnfolderName;

}

// Bildexportfunktion

privatevoid exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions(); ;

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Informationen über das Dokument exportieren

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Auflistung von Feldern exportieren

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Überprüft, ob der Wert des Felds Null ist

// Wenn der Feldwert ungültig ist, dann kann jeder Zugriffsversuch (auch

// die Überprüfung auf NULL) eine Ausnahme auslösen

privatebool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// Angegebenes Feld exportieren

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// Feldnamen speichern

sw.Write( indent + field.Name );

//Feldwert, sofern verfügbar, speichern

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// untergeordnete Felder exportieren

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// Feldinstanzen exportieren

exportFields( field.Items, sw, indent + " " );

}

}

}

}
Exportsteuerung
Dieser Beispielcode zeigt eine einfache Exportsteuerung, die Informationen über die exportierten Dokumente und Exportergebnisse in Textdateien speichert. In diesem Beispiel werden zwei Textdateien verwendet: Eine Datei enthält die Liste der erfolgreich exportierten Dokumente und die andere die Liste der Dokumente, bei denen während des Exports Fehler aufgetreten sind.

[VBScript]

dimcurDoc

dimfso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

setfso = CreateObject("Scripting.FileSystemObject")

' Datei mit der Liste fehlgeschlagener Dokumente erstellen

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

settxtErrorFile = fso.CreateTextFile( fileErrorName, true )

' Datei mit der Liste erfolgreich exportierter Dokumente erstellen

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

settxtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

DimdocInfo

' Auflistung der exportierten Dokumente durchlaufen

foreach curDoc in me.Documents

    docInfo = "DocumentId:" & curDoc.Id

    if curDoc.Action.Succeeded then

        docInfo = docInfo & ". Erfolgreich exportiert.  Ergebnis:" & curDoc.Action.Result

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & ". Exportfehler: " & curDoc.Action.ErrorMessage & "  Result:" & curDoc.Action.Result

        txtErrorFile.WriteLine docInfo

    End If

    next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

varfso = new ActiveXObject("Scripting.FileSystemObject");

// Datei mit der Liste fehlgeschlagener Dokumente erstellen

varfileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

vartxtErrorFile = fso.CreateTextFile( fileErrorName, true );

// Datei mit der Liste erfolgreich exportierter Dokumente erstellen

varfileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

settxtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

vari

// Auflistung der exportierten Dokumente durchlaufen

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Erfolgreich exportiert.  Ergebnis:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Exportfehler: " + curDoc.Action.ErrorMessage + "  Result:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Migrieren von FormReader 6.5-Regeln und -Exports in FlexiCapture 9.0 Skripte

Migrieren von FormReader-Regeln in FlexiCapture-Skriptregeln

If-Then-Regeln

Änderungen bei Funktionen und Methoden:

  1. Error(field, message). Verwenden Sie anstelle dieser Funktion eine Kombination aus folgenden Eigenschaften der zu überprüfenden Einheit: CheckSucceeded, ErrorMessage und FocusedField.

    Der folgende Code aus FormReader 6.5

    if [City].IsEmpty() then Error( [City] , "Stadtname darf nicht leer sein")

    muss geändert werden in:

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "Stadtname darf nicht leer sein"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "Stadtname darf nicht leer sein";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Zeichenfolgenoperationen. Im Folgenden finden Sie Anweisungen zum Implementieren von Zeichenfolgenoperationen in FlexiCapture 9.0, die über If-Then-Regeln verfügbar waren.

    [VBScript]

    .Length() – Verwenden Sie die entsprechende Funktion "Len(string)".

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Funktion "LCase(string)" oder "UCase(string)".

    .Mid(position, count) – Verwenden Sie die entsprechende Funktion "Mid(string, pos, count)".

    [JScript]

    .Length() – Verwenden Sie die entsprechende Längenfunktion der Zeichenfolgenvariablen.

    .CmpNoCase(str) – Verwenden Sie für Zeichenfolgenvergleiche ohne Berücksichtigung der Groß- und Kleinschreibung die Methode "toLowerCase()" oder "toUpperCase()" der Zeichenfolgenvariablen.

    .Mid(position, count) – Verwenden Sie die entsprechende Methode "substr(start, [length])" der Zeichenfolgenvariablen.

  3. Operationen mit reellen Zahlen

    [VBScript]

    Floor(d), Ceil(d) – Es sind keine vordefinierten Entsprechungen in VBScript vorhanden, Sie können bei Bedarf aber eigene Implementierungen erstellen.

    Round(d),Round(d, i) – Verwenden Sie die entsprechende Funktion "Round(d, [i])".

    [JScript]

    Floor(d), Ceil(d) – Verwenden Sie die Methoden "floor(d)" und "ceil(d)" des Math-Objekts.

    Round(d) – Verwenden Sie die round(d)-Methode des Math-Objekts.

    Round(d, i) – Es ist keine vordefinierte Entsprechung in JScript vorhanden, Sie können bei Bedarf aber eine eigene Implementierung erstellen.

  4. Operationen mit Textfeldern

    IsEmpty() – Vergleichen Sie den Wert des Felds "Field("fieldName").Text" mit einer leeren Zeichenfolge.

    Text() – Verwenden Sie "Field("fieldName").Text.

    Length() – Rufen Sie den Wert des Felds ab, und bestimmen Sie anschließend die Länge der resultierenden Zeichenfolge wie unter Punkt 2 beschrieben.

    SetText(text) – Verwenden Sie "Field("fieldName").Text = text".

  5. Operationen mit Auswahlfeldern

    IsValid() – Verwenden Sie die IsVerified-Eigenschaft

    Value() – "Field("fieldName").Value" gibt jetzt einen booleschen Wert zurück und nicht mehr 0 oder 1 wie in FormReader 6.5.

    SetValue(newValue) – Verwenden Sie "Field("fieldName").Value = newValue".

  6. Operationen mit Gruppen von Auswahlfeldern

    IsValid() – Sie können mithilfe der IsVerified-Eigenschaft die Bestimmtheit eines Felds in einer Gruppe bestimmen. Wenn Sie die Anzahl der markierten Auswahlfelder ermitteln möchten, durchlaufen Sie die Auswahlfelder in der Gruppe wie im Beispiel "Überprüfung von Gruppen von Auswahlfeldern" beschrieben (siehe Beispielskripte zum Erstellen benutzerdefinierter Regeln).

    Value() – Für das Abrufen der Anzahl markierter Auswahlfelder können Sie eine der beiden unten stehenden Methoden verwenden:

    1. Weisen Sie den Auswahlfeldern in der Gruppe Zahlennamen zu: 0, 1 usw. Anschließend enthält "Field("groupName").Value" entweder die Anzahl der markierten Auswahlfelder, die Liste der Zahlen (bei mehreren Markierungen) oder eine leere Zeichenfolge (bei keiner Markierung).
    2. Fügen Sie der Regel nur die Auswahlfelder in der angegebenen Gruppe in der richtigen Reihenfolge zu. Durchlaufen Sie anschließend die Auswahlfelder in der Gruppe wie im Beispiel "Überprüfung von Gruppen von Auswahlfeldern" beschrieben.

    Text() – Verwenden Sie "Field("groupName").Value".

    SetValue(newValue) – Um den Wert einer Gruppe von Auswahlfeldern zu ändern, müssen Sie die entsprechenden Auswahlfelder in der Gruppe festlegen oder zurücksetzen. Die Auswahlfelder müssen in der Regel enthalten sein, und das Kennzeichen für den Schreibschutz muss aktiviert sein.

Automatisierungsregeln

Um in FlexiCapture 9.0 Automatisierungskomponenten verwenden zu können, die in FormReader 6.5 erstellt wurden, müssen Sie an diesen Automatisierungsregeln die folgenden Änderungen vornehmen.

  1. Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

    Public Sub Check(ByRef docObj As Object)

    2. docObj – Dies ist ein Verweis auf die zu überprüfende Dokumenteinheit.

  2. Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture 9.0 unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des fieldsObj-Objekts aufgeführt.
Methode von fieldsObj | Beispiele für neuen Code in VisualBasic
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Für die Arbeit mit Tabellenspalten fügen Sie der Regel die Spaltenfelder hinzu. Die Überprüfung der richtigen Zuordnung der Spalte funktioniert wie bei allen anderen Feldern auch:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Für die Arbeit mit Tabellenzellen fügen Sie der Regel die Spaltenfelder hinzu.

Die Operationen mit diesen Feldern sind von der Ebene der Regel abhängig. Wenn die Regel für die Spalten- oder Tabellenebene erstellt wurde, gilt sie für jede Zeile. Dabei werden die Werte der Spalten in der überprüften Zeile verwendet (also zellenweise):

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Sie können daher eine Regel erstellen, die beispielsweise die Daten in den ersten beiden Spalten einer Tabelle verwendet, um eine dritte Spalte auszufüllen:

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Wenn die Regel für die Ebene einer Einheit erstellt wurde, die eine Tabelle enthält (Gruppe, Bereich, Dokument), müssen Sie die Spalte wie im Abschnitt "Automatisierungsregel" beschrieben durchlaufen, um auf die enthaltenen Zellen zuzugreifen.

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' Vorschläge für das Feld

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' Vorschläge für das Feld

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Auf Zellenfelder kann so wie im Abschnitt zur SetTableCellValue-Methode beschrieben zugegriffen werden.

Sie können anschließend mit den Zellen, auf die Sie zugegriffen haben, wie mit jedem anderen Feld arbeiten. Das Festlegen eines Vorschlags erfolgt z. B. folgendermaßen:

cell.Suggest cellSuggest

  3. Die Methoden des errorsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die in FlexiCapture 9.0 unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen der alten und neuen Methoden des errorsObj-Objekts aufgeführt.
Methode von errorsObj Beispiele für neuen Code in VisualBasic
SendFieldError( ErrMsg As String, Index As Integer) docObj.ErrorMessage = ErrMsg

docObj.CheckSucceeded = false

docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant )

docObj.ErrorMessage = ErrMsg
docObj.CheckSucceeded = false

Wenn die Regel für die Tabellen- oder Spaltenebene erstellt wurde, kennzeichnet das Programm alle Zellen in der überprüften Zeile als fehlerhaft, deren Felder (Spalten) der Regel hinzugefügt wurden. Um den Fokus auf eine bestimmte Zelle festzulegen, verwenden Sie folgenden Code:

docObj.FocusedField = docObj.Field("ColumnName")

Wenn die Regel für eine höhere Ebene geschrieben wurde, kennzeichnet das Programm keine Zellen und legt auch nicht den Fokus auf Zellen fest.

Migrieren des FormReader-Automatisierungsexports in den FlexiCapture-Skriptexport

Die Methode einer externen Komponente, die Regellogik implementiert, sollte aus einer Skriptregel aufgerufen werden, wie in den Beispielen beschrieben. Für die Signatur dieser Methode gelten keine besonderen Bedingungen. Beachten Sie jedoch, dass die von der Skriptregel an die Methode der externen Komponente übergebenen Parameter der Signatur der Methode entsprechen müssen. Diese könnte folgendermaßen lauten:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – Dies ist ein Verweis auf das zu exportierende Dokument.

exportTools – Dies ist ein Verweis auf das ExportTools-Objekt.

Die Methoden des fieldsObj-Objekts, das in FormReader 6.5 verwendet wurde, sollten durch die von der aktuellen Programmversion unterstützten Methoden ersetzt werden. In der folgenden Tabelle werden die Entsprechungen des fieldsObj-Objekts und die neue Bedeutung für die Arbeit mit zu exportierenden Dokumenten aufgeführt:

Methoden des fieldsObj-Objekts | Mögliche Implementierungen im neuen Objektmodell
GetFieldsCount As
Integer 		Um die Anzahl der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und nehmen die Berechnung vor.
GetFieldsNames(Names As Variant) | Um die Namen der Felder im exportierten Dokument abzurufen, durchlaufen Sie die Struktur der Felder wie im Beispiel "Verwenden einer externen COM-Komponente" beschrieben und füllen das Array mit den Namen des Felds auf.
GetFieldsTypes(FieldTypes As Variant) | Nicht unterstützt
GetFieldByIndex(Index As Integer, FieldValue As Variant) Der Zugriff über den Index ist nicht sinnvoll, da das neue Dokumentmodell über eine andere hierarchische Struktur verfügt.
Die Struktur der Felder kann ganz einfach durchlaufen werden (eine Beschreibung finden Sie im Beispiel "Verwenden einer externen COM-Komponente"), um das Array mit den Namen des Felds aufzufüllen.
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


Anwendungsserver-API

Die Anwendungsserver-API ermöglicht die Erstellung von Verarbeitungstasks, den Start des Verarbeitungsvorgangs und das Abrufen der Ergebnisse über ein externes System. Drittanbieter können die API nutzen, um Anwendungen zu entwickeln, die ABBYY FlexiCapture 9.0 als Bildanalyse-Server und für den Export der Ergebnisse verwenden.

Die API kann eingesetzt werden, um einen bereits konfigurierten Arbeitsablauf zu steuern. Der Benutzer muss die erforderlichen Objekte auf der Projektkonfigurationsstation erstellen und die für jedes Projekt zu verwendenden Dokumentdefinitionen, Stapeltypen, Bildverarbeitungsoptionen u.a. festlegen.

Falls die API verwendet wird, empfiehlt es sich, den selbstständigen Verarbeitungsmodus einzusetzen.

Eine formale Beschreibung der Service-Schnittstelle (WSDL) finden Sie unter der folgenden Adresse:

ttp://appServer/FlexiCapture/Server/WebServices.dll?Handler=Version2WSDL, dabei ist appServer der Name des installierten Anwendungsservers.

A C#equivalent follows:

// Methoden aus der ersten Version der Schnittstelle

// Methoden, die in der zweiten Version ergänzt wurden

// Liste der Stapel des Projekts abrufen

Batch[] GetBatches( int projectId );

// Stapel mittels Kennung abrufen

BatchGetBatch( int batchId );

// Stapeltyp mittels Kennung abrufen

BatchTypeGetBatchType( int batchTypeId );

// Stapel öffnen (Löschung sperren)

boolOpenBatch( int sessionId, int batchId );

// Stapel schließen (Löschung freigeben)

voidCloseBatch( int sessionId, int batchId );

// Ausführliche Informationen zum Dokument abrufen

DocumentExGetDocument( int batchId, int documentId );

// Dokument mit Registrierungsparametern hinzufügen

intAddNewDocumentEx( int sessionId, int batchId, DocumentExdocument, File file, bool omAutomaticAssembling );

// Dokument löschen

boolDeleteDocument( int sessionId, int batchId, int documentId );

// Registrierungsparameter des Dokuments angeben

voidSetDocumentProperties( int sessionId, int batchId, int documentId, RegistrationProperty[] properties );

// Seite mit zusätzlichen Informationen zum Dokument hinzufügen

intAddNewPageEx( int sessionId, int batchId, int documentId, PageEx page, File file );

// Seite aus dem Dokument löschen

boolDeletePage( int sessionId, int batchId, int documentId, int pageId );

// Arbeiten mit Tasks zum Neuscannen

// Liste der verfügbaren Tasks abrufen

TaskListGetAvailableTasks( int sessionId, int projectId, int processingStage );

// Liste der aufgeschobenen Tasks abrufen

TaskListGetPostponedTasks( int sessionId, int projectId, int processingStage );

// Task öffnen. Zuerst muss der Task geöffnet werden, damit kein anderer Benutzer ihn öffnen kann.

boolOpenTask( int sessionId, int taskId );

// Task zur weiteren Verarbeitung zurückgeben

voidCloseTask( int sessionId, int taskId );

// Task ablehnen

voidCancelTask( int sessionId, int taskId );

// Task aufschieben

voidPostponeTask( int sessionId, int taskId, string comment);

// Task an Ausnahmen senden

voidSendTaskToException( int sessionId, int taskId, string comment );

// Liste der Dokumente in dem Task abrufen

TaskDocumentListGetTaskDocuments( int taskId );

// Informationen über den Task abrufen

TaskGetTaskInfo( int taskId );

// Arbeiten mit benutzerdefinierten Dateien

// Benutzerdefinierte Datei auf dem Server speichern

voidSaveCustomFile( int sessionId, File file );

// Benutzerdefinierte Datei vom Server laden

FileLoadCustomFile( string fileName );

// Benutzerdefinierte Datei vom Server löschen

voidRemoveCustomFile( int sessionId,  string filename );

// Liste der benutzerdefinierten Dateien abrufen

string[] GetCustomFileNames();

// Arbeiten mit Schutz

// Neues Ticket abrufen

boolGetNewTicket( int sessionId, int stationType, out TicketInfoticketInfo );

// Vorhandenes Ticket aktualisieren

boolUpdateTicket( int sessionId, int ticketId, out TicketInfoticketInfo );

// Vorhandenes Ticket auschecken

voidReleaseTicket( int sessionId, int ticketId );

// In Protokoll des Meldungsservers schreiben

voidWriteToLog( long clientTime, LogRecord[] records );
Anwendungsserver-API Verwendungsbeispiel
Beschreibung der Anwendungsserver-API-Webdienste


Anwendungsserver-API: Beispiel für die Verwendung

Dieses Beispiel wurde in Microsoft Visual Studio erstellt. Im Beispielcode unten wird angenommen, dass ein Verweis (Webverweis) auf den Webdienst hinzugefügt wurde und der Name FlexiCapture für den Verweis ausgewählt wurde (der erzeugte Namespace entspricht diesem Namen). Für den Beispielcode wird außerdem davon ausgegangen, dass die Trace-Funktion definiert wurde (z. B. mittels Debug.Print). Sie dient dazu, Daten zur Protokolldatei hinzuzufügen.

Bei diesem Beispiel handelt es sich um eine reine Demonstration. Achten Sie bei Ihren eigenen Projekten darauf, verlässliche Hüllenklassen um die geöffneten Objekte zu erstellen und Mechanismen anzuwenden, die den in C# eingesetzten ähnlich sind. Wünschenswert ist ein Mechanismus zum Löschen abgebrochener Sitzungen, der ausfallsicher ist und von Unterbrechungen der Stromversorgung und Kommunikationsfehlern nicht beeinflusst wird (z. B. muss der Identifier gespeichert werden und die Sitzung als Teil des Wiederherstellungsvorgangs geschlossen werden). Abgebrochene Sitzungen stellen an sich keine Gefahr dar, können sich aber aufstauen und dem Administrator lästig fallen. Darüber hinaus können abgebrochene Stapel beträchtliche Serverressourcen verbrauchen, hauptsächlich indem sie Speicherplatz belegen, der für Bilder und Dokumente reserviert ist.

Um dieses Beispiel auszuführen, laden Sie Ihr Projekt einfach in den frisch installierten Anwendungsserver hoch und wählen auf der Registerkarte Workflow die unbeaufsichtigte Verarbeitung aus.

publicvoid RunSample(string serverUrl)

{

       try

       {

             // Initialisierung des Dienstes

             FlexiCapture.FlexiCaptureWebService service = new FlexiCaptureWebService();

// Um Version 1des Dienstes zu referenzieren, muss die URL wie folgt aufgebaut sein.
// Beachten Sie, dass die resultierende URL von derjenigen verschieden ist, die zum
// Verweis auf WSDL (das zuvor zum Hinzufügen des Webverweises verwendet wurde) genutzt wird

service.Url = serverUrl + "/FlexiCapture/Server/WebServices.dll?Handler=Version1";

// Aktivierung der transparenten Anmeldung unter Verwendung der Anmeldeinformationen des aktuellen Threads

service.Credentials = System.Net.CredentialCache.DefaultCredentials;

             // Sitzung öffnen

             int sessionId = service.OpenSession();

             try

             { {

// Auflisten verfügbarer Projekte (dies kann entfallen, wenn Sie mit
// einem festen Projekt arbeiten; in diesem Fall besteht die
// bevorzugte Methode im Öffnen mittels GUID)

                    FlexiCapture.Project[] projects = service.GetProjects();

                    if( projects != null )

                    {

                          foreach( FlexiCapture.Project project in projects )

                          {

                                 Trace( project.Name + " : " + project.Guid );

                          }

                    }

                    // Öffnen des ersten Projekts in der Liste

                    int projectId = service.OpenProject( sessionId, projects[0].Guid );

                    // Auflisten verfügbarer Stapeltypen

                    FlexiCapture.BatchType[] batchTypes = service.GetBatchTypes( projectId );

                    if( batchTypes != null )

                    {

                          foreach( FlexiCapture.BatchType batchType in batchTypes )

                          { {

                                 Trace( batchType.Name + " : " + batchType.Description );

                          }

                    }

                    // Erstellen eines neuen Stapels

                    FlexiCapture.Batch batch = new FlexiCapture.Batch();

                    batch.Name = "Sample API Batch";

                    int batchId = service.AddNewBatch( sessionId, projectId, batch );

                    // Laden der Beispielbilder (die Definition des LoadFile ist unten aufgeführt)

                    FlexiCapture.File file1 = LoadFile( "Banking 1.png" );

                    FlexiCapture.File file2 = LoadFile( "Banking 2.png" );

                    FlexiCapture.File file3 = LoadFile( "Banking 3.png" );

                    // Hinzufügen von Beispielbildern

                    for( int i = 0; i < 3; i++ )

                    {

                          service.AddNewImage( sessionId, batchId, file1 );

                          service.AddNewImage ( sessionId, batchId, file2 );

                          service.AddNewImage ( sessionId, batchId, file3 );

                    }

                    // Beginn der Stapelverarbeitung

                    service.ProcessBatch( sessionId, batchId );

                    // Warten auf den Abschluss der Verarbeitung

                    int percentCompleted = 0;

                    while( percentCompleted < 100 )

                    {

                          percentCompleted = service.GetBatchPercentCompleted( batchId );

                          System.Threading.Thread.Sleep( 500 );

                    } }

                    // Analyse der Ergebnisse

                    FlexiCapture.Document[] documents = service.GetDocuments( batchId );

                    if( documents != null )

                    {

                          foreach( FlexiCapture.Document document in documents )

                          {

                                 FlexiCapture.File attachedFile =

service.GetDocumentResult( document.Id, "MyResult.xml" );

                          } }

                    }

                    // Bereinigen

                    service.DeleteBatch( sessionId, batchId );

                    service.CloseProject( sessionId, projectId );

             }

             finally

             {

                    service.CloseSession( sessionId );

             }

       }

       catch ( Exception ex )

       {

             Trace( ex.Message );

       }

}

publicFlexiCapture.File LoadFile( string fileName )

{

       FlexiCapture.File file = new FlexiCapture.File();

       using( FileStream stream = File.Open( fileName, FileMode.Open ) )

       {

             file.Name = fileName;

             file.Bytes = new byte[stream.Length];

             stream.Read( file.Bytes, 0, file.Bytes.Length );

       }

       return file;

}


Beschreibung der Webdienste für Anwendungsserver

Eine aktuelle Beschreibung der Service-Schnittstelle (WSDL) finden Sie unter dieser Adresse:

http://AnwServer/FlexiCapture/Server/WebServices.dll?Handler=Version1WSDL, wobei AnwServer der Name des installierten Anwendungsservers ist.

<?xml version="1.0" ?>
- <definitionsxmlns:s="http://www.w3.org/2001/XMLSchema"xmlns:http="http://schemas.xmlsoap.org/wsdl/http/"xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"xmlns:s0="urn:http://www.abbyy.com/FlexiCapture"xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"xmlns:atls="http://tempuri.org/vc/atl/server/"targetNamespace="urn:http://www.abbyy.com/FlexiCapture"xmlns="http://schemas.xmlsoap.org/wsdl/">
- <types>
- <s:schema targetNamespace="urn:http://www.abbyy.com/FlexiCapture"attributeFormDefault="qualified"elementFormDefault="qualified">
<s:import namespace="http://schemas.xmlsoap.org/soap/encoding/" />
- <s:element name="OpenSession">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="OpenSessionResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetProjects">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetProjectsResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="projects"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Project" type="s0:Project" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseSession">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseSessionResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="OpenProject">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectNameOrGuid"type="s:string" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="OpenProjectResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseProject">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseProjectResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetBatchTypes">
- <s:complexType>
- <s:sequence>
<s:element name="projectId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetBatchTypesResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="batchTypes"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="BatchType" type="s0:BatchType" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectId"type="s:int" />
<s:element name="batch"type="s0:Batch" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewBatchResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="DeleteBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="DeleteBatchResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:boolean" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewImage">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewImageResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="AddNewDocument">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewDocumentResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewEmptyDocument">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewEmptyDocumentResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewPage">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="documentId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewPageResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="ProcessBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="ProcessBatchResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetBatchPercentCompleted">
- <s:complexType>
- <s:sequence>
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetBatchPercentCompletedResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocuments">
- <s:complexType>
- <s:sequence>
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentsResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="documents"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Document" type="s0:Document" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentResultsList">
- <s:complexType>
- <s:sequence>
<s:element name="documentId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentResultsListResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="fileNames"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="string" type="s:string" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="LoadDocumentResult">
- <s:complexType>
- <s:sequence>
<s:element name="documentId"type="s:int" />
<s:element name="fileName"type="s:string" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="LoadDocumentResultResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:complexType name="Batch">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="Name"type="s:string" />
<s:element name="BatchTypeId"type="s:int" />
<s:element name="Priority"type="s:int" />
<s:element name="Description"type="s:string" />
- <s:element name="Properties"atls:SizeIs="PropertiesCount"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="RegistrationProperty"type="s0:RegistrationProperty"minOccurs="0"maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
<s:element name="PropertiesCount"type="s:int" />
</s:sequence>
</s:complexType>
- <s:complexType name="File">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Bytes"type="s:base64Binary" />
</s:sequence>
</s:complexType>
- <s:complexType name="Document">
- <s:sequence>
<s:element name="Id"type="s:int" />
- <s:element name="Pages"atls:SizeIs="PageCount"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Page"type="s0:Page"minOccurs="0"maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
<s:element name="PageCount"type="s:int" />
<s:element name="IsProcessed"type="s:boolean" />
<s:element name="HasProcessingErrors"type="s:boolean" />
<s:element name="HasDocumentErrors"type="s:boolean" />
<s:element name="ErrorText"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="Project">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Guid"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="RegistrationProperty">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Value"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="BatchType">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="Name"type="s:string" />
<s:element name="Description"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="Page">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="SourceFileName"type="s:string" />
<s:element name="SourcePageNumber"type="s:int" />
<s:element name="ErrorText"type="s:string" />
</s:sequence>
</s:complexType>
</s:schema>
</types>
- <message name="OpenSessionIn">
<part name="parameters"element="s0:OpenSession" />
</message>
- <message name="OpenSessionOut">
<part name="parameters"element="s0:OpenSessionResponse" />
</message>
- <message name="GetProjectsIn">
<part name="parameters"element="s0:GetProjects" />
</message>
- <message name="GetProjectsOut">
<part name="parameters"element="s0:GetProjectsResponse" />
</message>
- <message name="CloseSessionIn">
<part name="parameters"element="s0:CloseSession" />
</message>
- <message name="CloseSessionOut">
<part name="parameters"element="s0:CloseSessionResponse" />
</message>
- <message name="OpenProjectIn">
<part name="parameters"element="s0:OpenProject" />
</message>
- <message name="OpenProjectOut">
<part name="parameters"element="s0:OpenProjectResponse" />
</message>
- <message name="CloseProjectIn">
<part name="parameters"element="s0:CloseProject" />
</message>
- <message name="CloseProjectOut">
<part name="parameters"element="s0:CloseProjectResponse" />
</message>
- <message name="GetBatchTypesIn">
<part name="parameters"element="s0:GetBatchTypes" />
</message>
- <message name="GetBatchTypesOut">
<part name="parameters"element="s0:GetBatchTypesResponse" />
</message>
- <message name="AddNewBatchIn">
<part name="parameters"element="s0:AddNewBatch" />
</message>
- <message name="AddNewBatchOut">
<part name="parameters"element="s0:AddNewBatchResponse" />
</message>
- <message name="DeleteBatchIn">
<part name="parameters"element="s0:DeleteBatch" />
</message>
- <message name="DeleteBatchOut">
<part name="parameters"element="s0:DeleteBatchResponse" />
</message>
- <message name="AddNewImageIn">
<part name="parameters"element="s0:AddNewImage" />
</message>
- <message name="AddNewImageOut">
<part name="parameters"element="s0:AddNewImageResponse" />
</message>
- <message name="AddNewDocumentIn">
<part name="parameters"element="s0:AddNewDocument" />
</message>
- <message name="AddNewDocumentOut">
<part name="parameters"element="s0:AddNewDocumentResponse" />
</message>
- <message name="AddNewEmptyDocumentIn">
<part name="parameters"element="s0:AddNewEmptyDocument" />
</message>
- <message name="AddNewEmptyDocumentOut">
<part name="parameters"element="s0:AddNewEmptyDocumentResponse" />
</message>
- <message name="AddNewPageIn">
<part name="parameters"element="s0:AddNewPage" />
</message>
- <message name="AddNewPageOut">
<part name="parameters"element="s0:AddNewPageResponse" />
</message>
- <message name="ProcessBatchIn">
<part name="parameters"element="s0:ProcessBatch" />
</message>
- <message name="ProcessBatchOut">
<part name="parameters"element="s0:ProcessBatchResponse" />
</message>
- <message name="GetBatchPercentCompletedIn">
<part name="parameters"element="s0:GetBatchPercentCompleted" />
</message>
- <message name="GetBatchPercentCompletedOut">
<part name="parameters"element="s0:GetBatchPercentCompletedResponse" />
</message>
- <message name="GetDocumentsIn">
<part name="parameters"element="s0:GetDocuments" />
</message>
- <message name="GetDocumentsOut">
<part name="parameters"element="s0:GetDocumentsResponse" />
</message>
- <message name="GetDocumentResultsListIn">
<part name="parameters"element="s0:GetDocumentResultsList" />
</message>
- <message name="GetDocumentResultsListOut">
<part name="parameters"element="s0:GetDocumentResultsListResponse" />
</message>
- <message name="LoadDocumentResultIn">
<part name="parameters"element="s0:LoadDocumentResult" />
</message>
- <message name="LoadDocumentResultOut">
<part name="parameters"element="s0:LoadDocumentResultResponse" />
</message>
- <portType name="FlexiCaptureWebServiceSoap">
- <operation name="OpenSession">
<input message="s0:OpenSessionIn" />
<output message="s0:OpenSessionOut" />
</operation>
- <operation name="GetProjects">
<input message="s0:GetProjectsIn" />
<output message="s0:GetProjectsOut" />
</operation>
- <operation name="CloseSession">
<input message="s0:CloseSessionIn" />
<output message="s0:CloseSessionOut" />
</operation>
- <operation name="OpenProject">
<input message="s0:OpenProjectIn" />
<output message="s0:OpenProjectOut" />
</operation>
- <operation name="CloseProject">
<input message="s0:CloseProjectIn" />
<output message="s0:CloseProjectOut" />
</operation>
- <operation name="GetBatchTypes">
<input message="s0:GetBatchTypesIn" />
<output message="s0:GetBatchTypesOut" />
</operation>
- <operation name="AddNewBatch">
<input message="s0:AddNewBatchIn" />
<output message="s0:AddNewBatchOut" />
</operation>
- <operation name="DeleteBatch">
<input message="s0:DeleteBatchIn" />
<output message="s0:DeleteBatchOut" />
</operation>
- <operation name="AddNewImage">
<input message="s0:AddNewImageIn" />
<output message="s0:AddNewImageOut" />
</operation>
- <operation name="AddNewDocument">
<input message="s0:AddNewDocumentIn" />
<output message="s0:AddNewDocumentOut" />
</operation>
- <operation name="AddNewEmptyDocument">
<input message="s0:AddNewEmptyDocumentIn" />
<output message="s0:AddNewEmptyDocumentOut" />
</operation>
- <operation name="AddNewPage">
<input message="s0:AddNewPageIn" />
<output message="s0:AddNewPageOut" />
</operation>
- <operation name="ProcessBatch">
<input message="s0:ProcessBatchIn" />
<output message="s0:ProcessBatchOut" />
</operation>
- <operation name="GetBatchPercentCompleted">
<input message="s0:GetBatchPercentCompletedIn" />
<output message="s0:GetBatchPercentCompletedOut" />
</operation>
- <operation name="GetDocuments">
<input message="s0:GetDocumentsIn" />
<output message="s0:GetDocumentsOut" />
</operation>
- <operation name="GetDocumentResultsList">
<input message="s0:GetDocumentResultsListIn" />
<output message="s0:GetDocumentResultsListOut" />
</operation>
- <operation name="LoadDocumentResult">
<input message="s0:LoadDocumentResultIn" />
<output message="s0:LoadDocumentResultOut" />
</operation>
</portType>
- <binding name="FlexiCaptureWebServiceSoap"type="s0:FlexiCaptureWebServiceSoap">
<soap:binding transport="http://schemas.xmlsoap.org/soap/http"style="document" />
- <operation name="OpenSession">
<soap:operation soapAction="#OpenSession"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetProjects">
<soap:operation soapAction="#GetProjects"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="CloseSession">
<soap:operation soapAction="#CloseSession"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="OpenProject">
<soap:operation soapAction="#OpenProject"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="CloseProject">
<soap:operation soapAction="#CloseProject"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetBatchTypes">
<soap:operation soapAction="#GetBatchTypes"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewBatch">
<soap:operation soapAction="#AddNewBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="DeleteBatch">
<soap:operation soapAction="#DeleteBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewImage">
<soap:operation soapAction="#AddNewImage"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewDocument">
<soap:operation soapAction="#AddNewDocument"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewEmptyDocument">
<soap:operation soapAction="#AddNewEmptyDocument"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewPage">
<soap:operation soapAction="#AddNewPage"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="ProcessBatch">
<soap:operation soapAction="#ProcessBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetBatchPercentCompleted">
<soap:operation soapAction="#GetBatchPercentCompleted"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetDocuments">
<soap:operation soapAction="#GetDocuments"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetDocumentResultsList">
<soap:operation soapAction="#GetDocumentResultsList"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="LoadDocumentResult">
<soap:operation soapAction="#LoadDocumentResult"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
</binding>
- <service name="FlexiCaptureWebService">
- <port name="FlexiCaptureWebServiceSoap"binding="s0:FlexiCaptureWebServiceSoap">
<soap:address location="http://appserver:80/FlexiCapture/Server/WebServices.dll?Handler=Version1" />
</port>
</service>
</definitions>


Vergleich von Regeln in FormReader 6.5 und FlexiCapture 9.0

FormReader 6.5

Entsprechung in FlexiCapture 9.0 Automatische Konvertierung

Datenbanküberprüfung

Regel für die Datenbanküberprüfung

Nein

Summenüberprüfung

Regel für die Summenüberprüfung

Nein

Verbinden von Blöcken

Regel für das Verbinden von Feldern

Ja

VBScript-Regeln

Skriptregel

Nein

Suchen in einer Liste von Vorschlägen

Feldeigenschaften, Registerkarte Datentyp. Liste der Varianten im Feld Einschränkungen. Funktioniert bei allen Typen außer Datum und Zahl. Siehe Datentypen für Texteingabefelder.

Ja

Zuordnen von Blöcken

Implementierung über eine Skriptregel.

Nein

If-Then-Regeln

Skriptregel

Nein

Ersetzen von Werten in der Liste

Feldeigenschaften, Registerkarte Datentyp. Typ Text, Feld Verarbeitung. Siehe Datentypen für Texteingabefelder.

Ja

Ersetzen von Zeichen in der Liste

Feldeigenschaften, Registerkarte Datentyp. Typ Text, Feld Verarbeitung. Siehe Datentypen für Texteingabefelder.

Ja

Normalisieren und Überprüfen von Datumsangaben

Feldeigenschaften, Registerkarte Datentyp. Wählen Sie in der Liste Kategorie die Option Datum aus. Wählen Sie in der Formatliste die gewünschten Formate aus und geben Sie dann im Feld Einschränkungen die Einschränkungen ein. Siehe Datentypen für Texteingabefelder.

Nein

Reguläre Ausdrücke

Feldeigenschaften, Registerkarte Datentyp. Geben Sie den gewünschten regulären Ausdruck im Feld Einschränkungen ein. Funktioniert bei allen Typen außer Datum und Zahl. Siehe Datentypen für Texteingabefelder.

Ja

Automatisierungsüberprüfung

In der früheren Version der Anwendung mussten für die Verwendung von Automatisierungsobjekten Komponenten auf dem Zielcomputer registriert werden, wodurch die Übertragung von Stapeln auf einen anderen Computer erschwert wurde. In der neuen Version implementieren Sie die Logik der meisten Regeln dieser Art mithilfe von Skripten.

Wenn die Logik einer Regel zu komplex ist und die Verwendung externer Komponenten erfordert, sollte diese Komponente im Code einer Skriptregel aufgerufen werden. Anschließend sollte ein Verweis auf das Objekt im überprüften Dokument an die Komponente übergeben werden.

Nein

Normalisieren von Preisen

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

Nein

Validieren von Passserie und -nummer

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

Nein

Summe in Zahlen – Summe in Worten

Summe in Zahlen und Summe in Worten Nein

Preis in Zahlen – Preis in Worten

Implementierung über eine externe COM-Komponente, die über eine Skriptregel aufgerufen wird.

Nein


Zusätzliche Optionen

Sie haben die Möglichkeit, die Dokumentverarbeitung und die Benutzeroberfläche des Programms Ihren Bedürfnissen anzupassen. Wählen Sie im Hauptfenster der Projektkonfigurationsstation Extras>Optionen… Das daraufhin angezeigte Dialogfeld enthält vier Registerkarten:

  • Taskstatus

    Wenn Tasks im Hintergrundmodus ausgeführt werden, dann können Sie den Fortschritt im Fenster Taskstatus, in der Protokolldatei und mithilfe der Popup-Meldungen überwachen und verfolgen. In dieser Registerkarte können Sie auswählen, welche Informationen in die Protokolldatei geschrieben und in welchen Fällen die Popup-Meldungen angezeigt werden sollen.

  • Farben

    Sie können die Farben der Elemente der Benutzeroberfläche ändern (z. B. die Rahmen, die ausgewählte Felder im Dokumentdefinitionseditor umschließen oder die Rahmen- und die Füllfarbe von Feldern mit Fehlern und Warnungen). Wählen Sie das gewünschte Element aus, und klicken Sie auf die Schaltfläche Farbe.

  • Dokumentverarbeitung

    Bilder können direkt nach dem Hinzufügen zu einem Stapel automatisch erkannt werden, wenn Sie die Option Hinzugefügte Bilder automatisch erkennen aktivieren.

    Die Erkennung kann im Hintergrundmodus durchgeführt werden (wählen Sie Erkennungsprozess im Hintergrundmodus ausführen).

    Wenn die Option Fehlerhafte Dokumente beim Export auslassen ausgewählt wird, werden sowohl erfolgreich verarbeitete Dokumente als auch Dokumente mit Fehlern exportiert.

    Wenn ein Skriptfehler erkannt wurde, wird der Debugger von Visual Studio aufgerufen. Aktivieren Sie Debugging externer Skripte deaktivieren, wenn Sie nicht möchten, dass der Debugger aufgerufen wird. In diesem Fall wird dann nur eine Fehlermeldung angezeigt.

  • Dialogfelder

    Standardmäßig wird beim Aufrufen des Programms das Dialogfeld Projekt öffnen anzeigt, in dem Sie ein vorhandenes Projekt auswählen können. Sie können die Anzeige dieses Dialogfelds verhindern, indem Sie die Option Startdialogfeld anzeigen in der Registerkarte Dialogfelder deaktivieren (alternativ können Sie die erneute Anzeige auch verhindern, indem Sie dieselbe Option im angezeigten Dialogfeld selbst deaktivieren).

    Wenn Sie eine Dokumentdefinitionsliste schließen, gibt das Programm gegebenenfalls eine Warnmeldung zu vorhandenen, nicht veröffentlichten Dokumentdefinitionen aus. Wenn Sie nicht möchten, dass die Warnmeldung angezeigt wird, deaktivieren Sie die Option Bei nicht veröffentlichter Dokumentdefinition Warnmeldung anzeigen (alternativ können Sie eine erneute Anzeige auch verhindern, indem Sie dieselbe Option im Dialogfeld selbst deaktivieren).

    Wenn Sie möchten, dass Meldungen beim Exportieren von Dokumenten mit Fehlern angezeigt werden , wählen Sie Bei fehlerhaftem Dokumentexport Warnmeldung anzeigen.

    Wählen Sie Beim Wechseln zwischen Dokumenten Aufforderung zum Speichern anzeigen , um keine Änderungen beim Umschalten zwischen Dokumenten zu verlieren.


ABBYY FlexiCapture-Beispielprojekte

Um die Arbeitsweise und die Funktionen von ABBYY FlexiCapture 9,0 besser zu verstehen, können Sie die Beispielprojekte verwenden, die im Programm enthalten sind. Diese vordefinierten Projekte enthalten fertig eingerichtete Dokumentdefinitionen und Dokumentbilder für die Verarbeitung.

Die Beispielprojekte finden Sie im Verzeichnis <Laufwerksbezeichnung>:\\Dokumente und Einstellungen\All Users\Anwendungsdaten\ABBYY\FlexiCapture\9.0\Samples.

Hinweis:Unter Microsoft Windows Vista finden Sie die Beispielprojekte im Verzeichnis <Laufwerksbezeichnung>:\\Users\Public\ABBYY\FlexiCapture\9.0\Samples.

Das Verzeichnis Samples enthält folgende Ordner:

  1. FlexiCapture: Dieser Ordner enthält die Beispielprojekte für FlexiCapture.
  2. FlexiLayoutStudio: Dieser Ordner enthält die Beispielprojekte für FlexiLayout Studio. Diese Beispielprojekte illustrieren die Verarbeitung von teilweise strukturierten Dokumenten und sollten in ABBYY FlexiLayout Studio 9.0 geöffnet werden. Ausführliche Beschreibungen einiger dieser Projekte sind in der Hilfedatei von FlexiLayout Studio verfügbar (siehe dazu die Abschnitte Lernprogramm und Tipps und Tricks).
  3. FormDesigner: Dieser Ordner enthält statische Formulare, die in ABBYY FormDesigner entwickelt wurden. Die Dateien mit der Endung *.fdd sollten in ABBYY FormDesigner 9.0 geöffnet werden. Diese Formulare werden in folgenden FlexiCapture-Projekten verwendet: Bankkartenanwendung, Fragebogen.
  4. Images: Dieser Ordner enthält die gescannten Dokumentbilder für die Beispielprojekte in FlexiCapture.

Nachstehend werden die FlexiCapture-Beispielprojekte aufgeführt und kurz beschrieben.

Ein Beispielprojekt mit Dokumenten unterschiedlichen Typs

Die Projektordner enthalten Beispielprojekte für FlexiCapture.

  1. Zentraler Einstieg

    Dieses Projekt zeigt, wie Dokumente unterschiedlichen Typs verarbeitet werden können. Es ist keine vorherige Sortierung der Dokumente erforderlich, statische Formulare und flexible Dokumente können zusammen verarbeitet werden. Die in diesem Projekt verwendeten Dokumentdefinitionen werden auch in den unten beschriebenen Projekten verwendet.

    Das Projekt enthält alle Arten von Dokumenten: Bankkartenanwendungen, Rechnungen, Verträge, Briefe, Preise.

Beispielprojekte mit statischen Formularen

Die Projektordner enthalten Formulare, die in ABBYY FormDesigner- und FlexiCapture-Projekten erstellt wurden.

  2. Bankkartenanwendung

    Dieses Beispielprojekt stellt die folgenden Funktionen heraus:

    • Automatische Erkennung von Feldern auf statischen Formularen (wenn Sie die Funktionsweise der automatischen Erkennung testen möchten, löschen Sie alle Felder aus der Dokumentvorlage, und wählen Sie Extras >Objekte automatisch erkennen…).
    • Unterstützung von Dokumenten mit komplexen Strukturen:
      1. Mehrseitige Dokumente (im Beispielprojekt werden dreiseitige Anwendungen verwendet)
      2. Arbeit mit Dokumentbereichen (im Beispielprojekt ist jede Seite ein separater Bereich)
      3. Dokumentzusammenstellungsregeln
      4. Verarbeitung von Anhängen
    • Unterstützung von komplexen Feldern:
      1. Arbeit mit Tabellen auf statischen Formularen (Tabelle "Eröffnete Konten")
      2. Wiederholte Feldgruppen (die Gruppen "Adresse" und "Angeforderte Konten")
    • Überprüfung der Datenformate (die Formate aller Zahl- und Datumsfelder sind festgelegt)
    • Anpassung des Datenformulars
    • Exportieren in mehrere Zielorte.
    • Bearbeitung von vertraulichen Informationen (Schwärzung).

  3. Fragebogen

    Eine ausführliche Beschreibung dieses Beispielprojekts finden Sie im Benutzerhandbuch. Das Projekt zeigt, wie eine Dokumentdefinition schrittweise eingerichtet wird. Mehrere einfache Formulare werden dabei verwendet, um die grundlegenden Funktionen von ABBYY FlexiCapture zu verdeutlichen. Sie können den Fragebogen dieses Beispielprojekts vervollständigen, ihn in ABBYY FlexiCapture verarbeiten und die exportierten Daten an ABBYY senden.

Beispielprojekte mit flexiblen Formularen

Die Projektordner enthalten Beispielprojekte für FlexiLayout Studio und FlexiCapture.

  4. Rechnung

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 3)
    • Tabellen, die sich über mehrere Seiten erstrecken
    • Verwendung eines externen Wörterbuchs mit Schlüsselwörtern (eine Textdatei)
    • Es wird eine JScript-Regel verwendet, um die Summe im Feld "Total" (Gesamt) mit der durch Addition der einzelnen Gesamtwerte aller Tabellenzeilen ermittelten Summe zu vergleichen.

  5. Preise

    Dieses Beispielprojekt zeigt die Verarbeitung von teilweise strukturierten Dokumenten und stellt dabei die folgenden Funktionsvarianten heraus:

    • Unterstützung wiederholter Gruppen. Dieses Beispielprojekt zeigt, wie wiederholt auftretende Gruppen verwendet werden können, um verschachtelte Tabellen (Tabellen mit untergeordneten Überschriften) zu beschreiben.

  6. Briefe und Verträge

    Dieses Beispielprojekt zeigt die Verarbeitung unstrukturierter Dokumente, aus denen zwei oder drei Felder erfasst werden. Dabei kommen im Projekt vor allem die folgenden Funktionen zur Geltung:

    • Veränderliche Seitenzahl bei Dokumenten (von 1 bis 4)
    • Einrichtung des Exports in eine durchsuchbare PDF-Datei


Unterstützte Erkennungssprachen

ABBYY FlexiCapture 9.0 bietet für die folgenden Erkennungssprachen eine Wörterbuchunterstützung an:

Sprache | OCR* | ICR**
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | ü |
Baschkirisch | ü |
Bulgarisch | ü | ü
Katalanisch | ü |
Kroatisch | ü | ü
Tschechisch | ü | ü
Dänisch | ü |
Niederländisch (Niederlande und Belgien) | ü | ü
Englisch | ü | ü
Estnisch | ü | ü
Finnisch | ü | ü
Französisch | ü | ü
Deutsch (alte und neue Rechtschreibung) | ü | ü
Griechisch | ü | ü
Hebräisch | ü |
Ungarisch | ü | ü
Indonesisch | ü | ü
Italienisch | ü | ü
Lettisch | ü | ü
Litauisch | ü | ü
Norwegisch (Nynorsk und Bokmål) | ü |
Altenglisch | ü |
Altfranzösisch | ü | ü
Altdeutsch | ü | ü
Altitalienisch | ü | ü
Altspanisch | ü | ü
Polnisch | ü | ü
Portugiesisch (Portugal und Brasilien) | ü |
Rumänisch | ü | ü
Russisch | ü | ü
Slowakisch | ü | ü
Slowenisch | ü | ü
Spanisch | ü | ü
Schwedisch | ü |
Tatarisch | ü |
Thailändisch | ü |
Türkisch | ü | ü
Ukrainisch | ü | ü

Weitere Informationen über Schriftarten der unterstützten Sprachen finden Sie im Abschnitt Schriftarten für die korrekte Darstellung von Zeichen der in FormReader-Editor unterstützten Sprachen.

Eine vollständige und aktualisierte Liste der unterstützten Datentypen mit den zugehörigen Einzelheiten finden Sie unter http://www.abbyy.com.

* - OCR: Englische Abkürzung für "Optical Character Recognition" (optische Zeichenerkennung). Optische Erkennung gedruckter Texte.

** - ICR : Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Erkennung handschriftlicher Texte.


Schriftarten für die korrekte Darstellung von Zeichen der im FormReader-Editor unterstützten Sprachen

Schriftarten für die korrekte Darstellung von Zeichen der im ABBYY FlexiCapture-Editor unterstützten Sprachen

Sprache | Schriftart
Mit Wörterbuchunterstützung |
Armenisch (Ostarmenisch, Westarmenisch, Grabar) | Arial Unicode MS(2)
Tatarisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ohne Wörterbuchunterstützung |
Abchasisch | Arial Unicode MS(2)
Adygeisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aghulisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Altaisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Awarisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aserbaidschanisch (Kyrillisch), Aserbaidschanisch (Lateinisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Baschkirisch | Arial Unicode MS(2), Palatino Linotype(2)
Burjatisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Tschetschenisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuktschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tschuwaschisch | Arial Unicode MS(2)
Darginisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Dunganisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Gagausisch | Arial Unicode MS(2)
Haussa | Arial Unicode MS(2), Lucida Sans Unicode(3)
Inguschisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kabardinisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kalmückisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Karakalpakisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Kasachisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Chakassisch | Arial Unicode MS(2)
Chantisch | Arial Unicode MS(2)
Korjakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kirgisisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Lakisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Lesgisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mansisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mari | Arial Unicode MS(2)
Mongolisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Nenzisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Ossetisch | Arial Unicode MS(2)
Russisch (alte Rechtschreibung) | Arial Unicode MS(2), Palatino Linotype(2)
Tabassaranisch | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tadschikisch | Arial Unicode MS(2), Palatino Linotype(2)
Turkmenisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Tuwinisch | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Udmurtisch | Arial Unicode MS(2)
Usbekisch (Kyrillisch) | MS-Hauptschriftarten 2.82(1) (Arial, Courier New und Times New Roman)
Jakutisch | Arial Unicode MS(2)
Zulu | Arial Unicode MS(2), Lucida Sans Unicode(3)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Unterstützte Texttypen

ABBYY FlexiCapture 9.0 unterstützt die folgenden Texttypen:

Texttyp | Beschreibung
Professionelle, Laser- und Ink-Jet-Drucker | Die Texte wurden in einer Druckerei, auf einem Laserdrucker oder einem Ink-Jet-Drucker gedruckt.
Schreibmaschine | Auf einer Schreibmaschine geschriebene Texte.
Matrixdrucker | Die Texte wurden auf einem Punktmatrixdrucker gedruckt.
Index | Ein spezieller Zeichensatz, der nur Ziffern im PLZ-Format enthält. Diese werden folgendermaßen dargestellt:
OCR-A | Eine Konstantschriftart für die optische Zeichenerkennung. Sie wird häufig von Banken, Kreditkarteninstituten und ähnlichen Firmen verwendet. Die Darstellung ähnelt folgender:
OCR-B | Eine Schriftart für die optische Zeichenerkennung. Die Darstellung ähnelt folgender:
MICR E-138 | Ein spezieller Satz numerischer Zeichen, die mit einer magnetischen Spezialtinte gedruckt werden. MICR-Zeichen (Magnetic Ink Character Recognition) finden sich an verschiedenen Stellen, unter anderem auf Barschecks. Die Darstellung ähnelt folgender:
MICR CMC-7 | Eine spezielle MICR-Schriftart für Barcodes (CMC-7). Die Darstellung ähnelt folgender:


Unterstützte Barcodetypen

ABBYY FlexiCapture 9.0 unterstützt die folgenden Barcodeformate:

  • EAN 13
  • EAN 8
  • Code 39
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patchcode
  • Check Codabar
  • Aztec
  • DataMatrix

Hinweis: ABBYY FlexiCapture 9.0 kann Aztec und DataMatrix Barcodes lesen, diese jedoch nicht auf Bildern erkennen. Somit können Sie diese Barcode-Typen in Dokumentdefinitionen, jedoch nicht in FlexiLayouts oder als Dokumenttrennzeichen verwenden.


Unterstützte Grafikformate

Typ | Farbe
BMP | S/W, Grau, Farbe
PCX, DCX | S/W, Grau
PNG | S/W, Grau, Farbe
JPEG | Grau, Farbe
JPEG-2000 | Grau, Farbe
TIFF | S/W: unkomprimiert, CCITT3, CCITT4, Packbits, ZIP Grau: unkomprimiert, Packbits, JPEG, ZIP Farbe: unkomprimiert, JPEG, ZIP
JBIG2 | S/W
GIF | Farbe
PDF, PDF/A |
Durchsuchbare PDF- und PDF/A-Dateien |
DjVu | S/W, Grau, Farbe


Exportdateiformate

Dateiformate für das Exportieren aus Dokumenten in ABBYY FlexiCapture 9.0

  • Microsoft Office Excel-Arbeitsmappe (*.xls)
  • DBase-Datei (*.dbf)
  • Kommagetrennte Datei (*.csv). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).
  • Kommagetrennte Datei (*.csv) im Unicode-Format (UTF-8, UTF-16)
  • Textdatei (*.txt). ABBYY FlexiCapture unterstützt mehrere Zeichenkodierungen (Windows, DOS).
  • Textdatei (*.txt) im Unicode-Format (UTF-8, UTF-16)
  • XML-Dokument (*.xml)


Alphabet in regulären Ausdrücken

Name | Verwendete Bezeichnung | Beispiel für die Verwendung
Beliebiges Zeichen | * | "c"*"t" – lässt die Wörter cat, cot usw. zu.
Buchstabe | C | C"ot" – lässt die Wörter Rot, pot, cot, Dot, mot usw. zu.
Großbuchstabe | A | A"ot" – lässt die Wörter Rot, Cot, Mot, Dot usw. zu.
Kleinbuchstabe | a | a"ot" – lässt die Wörter rot, cot, mot, dot usw. zu.
Ziffer oder Buchstabe | X | X – lässt jedes einzelne Vorkommen eines Buchstabens oder einer Ziffer zu.
Zahl | N | N"." – lässt die Kombinationen 5., 4., 6. usw. zu.
Zeichenfolge | " " | "cot"
Oder | | | "pl"("o"|"a")"t" – lässt die Wörter "plot" und "plat" zu.
Zeichen aus Gruppe | [] | [tm]"ot" – lässt die Wörter "tot" und "mot" zu.
Zeichen nicht aus Gruppe | [^] | [^t]"ot" – lässt die Wörter "cot", "lot" usw. zu, aber nicht das Wort "tot".
Leerzeichen (in Gruppe) | \s | [A\s] – lässt nur den Buchstaben A oder ein Leerzeichen zu.
Eine beliebige Anzahl von Wiederholungen (gilt für den davor stehenden Ausdruck oder Unterausdruck) | {-} | [AB74]{-} – lässt beliebige Kombinationen der Zeichen A, B, 7 und 4 beliebiger Länge zu.
n Wiederholungen | {n} | N{2}"." – lässt die Kombinationen 25., 84., 11. usw. zu.
n bis m Wiederholungen | {n-m} | N{1-3}"." – lässt die Kombinationen 5., 84., 111. usw. zu.
0 bis n Wiederholungen | {-n} | N{-2}"th" – lässt die Kombinationen 84th, 5th usw. zu.
n und mehr Wiederholungen | {n-} | N{2-}"." – lässt die Kombinationen 25., 834., 311., 34576. usw. zu.
Unterausdruck | () |
Bindestrich | [\-] |
Umgekehrter Schrägstrich | [\\] |


Patente

US-Patentnummern: 5,258,855; 5,369,508; 5,625,465; 5,768,416 und 6,094,505


Technologien von Drittanbietern

JasPer-Lizenz Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

Alle Rechte vorbehalten.

Sonstiges

Vorbehaltlich der nachstehenden Bedingungen erhalten Personen (die „Benutzer“), die eine Kopie dieser Software sowie der dazugehörigen Dokumentationsdateien (die „Software“) erworben haben, hiermit die uneingeschränkte Genehmigung, die Software gebührenfrei weiterzugeben, einschließlich des Rechts, Kopien dieser Software zu verwenden, sie zu kopieren, zu ändern, zusammenzuführen, zu veröffentlichen, zu verteilen und/oder zu verkaufen, und diese Genehmigung auch Dritten zu erteilen, denen die Software bereitgestellt wird:

  1. Die oben stehenden Copyright-Hinweise und sowie diese Genehmigung (einschließlich des folgenden Haftungsausschlusses) müssen in allen wichtigen Teilen der Software enthalten sein.

  2. Der Name des Copyright-Inhabers darf nicht ohne vorherige schriftliche Genehmigung des Copyright-Inhabers zur Werbung oder für den Vertrieb von Produkten, die aus der Software abgeleitet wurden, verwendet werden.

DIESER GEWÄHRLEISTUNGSAUSSCHLUSS STELLT EINEN WESENTLICHEN TEIL DIESER LIZENZ DAR.

DIE NUTZUNG DER SOFTWARE IST NUR UNTER BEACHTUNG DIESES AUSSCHLUSSES ZULÄSSIG. DIE SOFTWARE WIRD VOM COPYRIGHT-INHABER OHNE MÄNGELGEWÄHR UND OHNE AUSDRÜCKLICHE ODER STILLSCHWEIGEND EINGESCHLOSSENE GARANTIE AUSGELIEFERT, EINSCHLIESSLICH, ABER NICHT BEGRENZT AUF DIE GEWÄHRLEISTUNG, DASS DIE SOFTWARE VON MARKTGÄNGIGER QUALITÄT UND FÜR EINEN BESTIMMTEN ZWECK GEEIGNET IST UND DIE RECHTE DRITTER NICHT VERLETZT WERDEN. UNTER KEINEN UMSTÄNDEN SIND DIE IN DIESEM HINWEIS ERWÄHNTEN COPYRIGHT-INHABER HAFTBAR FÜR INDIREKTE, SONDER- ODER FOLGESCHÄDEN, ODER SCHÄDEN, DIE DURCH DIE NICHTVERWENDBARKEIT, DEN VERLUST VON DATEN ODER GEWINNVERLUST, AUF DER GRUNDLAGE EINES VERTRAGS, AUFGRUND VON FAHRLÄSSIGKEIT ODER ANDERER UNERLAUBTER HANDLUNGEN, AUS DEM GEBRAUCH ODER IN ZUSAMMENHANG MIT DEM GEBRAUCH ODER DER LEISTUNG DIESER SOFTWARE ENTSTEHEN. ES WERDEN VOM COPYRIGHT-INHABER KEINERLEI GARANTIEN DAFÜR ÜBERNOMMEN, DASS DURCH DIE SOFTWARE KEINE PATENTE ODER ANDERE RECHTE AN GEISTIGEM EIGENTUM ANDERER RECHTSPERSONEN VERLETZT WERDEN. DIE COPYRIGHT-INHABER ÜBERNEHMEN KEINERLEI HAFTUNG FÜR ETWAIGE RECHTSANSPRÜCHE DRITTER, DIE AUF DER GRUNDLAGE VON VERLETZUNGEN DES RECHTS AN GEISTIGEM EIGENTUM ODER ANDEREN RECHTEN DURCH DIE NUTZUNG DER SOFTWARE DURCH DEN BENUTZER ENTSTEHEN. ALS BEDINGUNG ZUR INANSPRUCHNAHME DER HIERMIT GEWÄHRTEN RECHTE ERKLÄRT JEDER BENUTZER HIERMIT SEINE EIGENE VERANTWORTUNG IM UMGANG MIT DEN RECHTEN DRITTER AM GEISTIGEN EIGENTUM UND VERSICHERT, DIESE ZU ACHTEN. DIE SOFTWARE KANN FEHLER AUFWEISEN UND IST NICHT FÜR DIE BENUTZUNG IN RISIKO-UMGEBUNGEN ENTWICKELT ODER VORGESEHEN, DIE FEHLERFREIEN BETRIEB VORAUSSETZEN, Z. B. BEIM BETRIEB VON KERNKRAFT-EINRICHTUNGEN, LUFTFAHRTNAVIGATIONS- ODER KOMMUNIKATIONSSYSTEMEN, LUFTVERKEHRSKONTROLLEINRICHTUNGEN, WAFFENSYSTEMEN, LEBENSERHALTENDEN MASCHINEN ODER SÄMTLICHEN ANDEREN ANWENDUNGEN, BEI DENEN SOFTWAREFEHLER UNMITTELBARE GEFAHR FÜR LEIB ODER LEBEN ODER ERHEBLICHE SACHSCHÄDEN NACH SICH ZIEHEN KÖNNEN („HOCHRISIKOAKTIVITÄTEN“). DIE COPYRIGHT-INHABER LEHNEN DESHALB JEDE AUSDRÜCKLICHE ODER KONKLUDENTE GEWÄHRLEISTUNG DER EIGNUNG FÜR MIT EINEM HOHEN RISIKO BEHAFTETE AKTIVITÄTEN AB.

MARKEN

QuickScan ist eine Marke und Captiva ist eine eingetragene Marke der Captiva Software Corporation.

KODAK ist eine Marke der Eastman Kodak Company.

TWAIN Toolkit

Das TWAIN Toolkit wird ohne Mängelgewähr geliefert. Die Entwickler und Händler des TWAIN Toolkits schließen jegliche ausdrückliche oder konkludente Gewährleistung aus, einschließlich, aber nicht beschränkt auf die konkludente Gewährleistung der Gebrauchstauglichkeit und der Eignung für einen bestimmten Zweck. Weder die Entwickler noch die Händler sind für direkte, indirekte, zufällige, spezielle oder Folgeschäden verantwortlich, die das Ergebnis der Vervielfältigung, Modifikation, Weitergabe oder anderer Verwendung des TWAIN Toolkits sind.


Technischer Support

Wenn Sie Fragen zur Verwendung von ABBYY FlexiCapture 9.0 haben, finden Sie in den Hilfethemen und im Benutzerhandbuch von ABBYY FlexiCapture 9.0 eine ausführliche Beschreibung der Funktionen. Auch im Bereich des Technischen Supports auf unserer Website unter http://www.abbyy.com finden Sie Antworten zu bestimmten Fragen.

Damit der Technische Support Ihre Fragen beantworten kann, sind folgende Informationen erforderlich:

  • Nachname, Vorname
  • Name der Organisation
  • Telefonnummer (Fax, E-Mail-Adresse)
  • Seriennummer Ihres Installationspakets
  • Build (siehe Hilfe/Info…)
  • Allgemeine Beschreibung des Problems mit dem vollständigen Text der Fehlermeldung (sofern vorhanden)
  • Typ des Computers und Prozessors
  • Windows-Version
  • Weitere Informationen, die Sie für wichtig erachten
Adressen und Kontaktinformationen der Niederlassungen von ABBYY


Informationen zum Kauf von ABBYY FlexiCapture 9.0

Wenn Sie ABBYY FlexiCapture bestellen möchten oder eine Frage zum Kauf haben, wenden Sie sich bitte an eine der regionalen ABBYY-Niederlassungen.


ABBYY-Vertretungen

ABBYY Russland | Telefon: +7 495 783 3700 Fax: +7 495 783 2663 Postanschrift: Russland, 127273, Moskau, P.O. Box 32, ABBYY Firmenanschrift: Moscow, ul. Otradnaya 2B, str. 6, Otradny Business Centre E-Mail: sales@abbyy.ru Technischer Support: support@abbyy.ru Website: http://www.abbyy.ru MAP
ABBYY USA | Tel.: +1 408-457-9777 Fax: +1 408-457-9778 Adresse: 880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, USA E-Mail: sales@abbyyusa.com Technischer Support: support@abbyyusa.com Website: http://www.abbyy.com
ABBYY Ukraine | Telefon: +380 44 490 9999 Fax: +380 44 490 9461 Adresse: P.O. Box 23, 02002 Kiew, Ukraine E-Mail: forms@abbyy.ua Support-Telefon: +380 44 490 9463 Support-E-Mail: formsupport@abbyy.ua Website: http://www.abbyy.ua
ABBYY Europe GmbH | Telefon: +49 (0)89 511 159 0 Fax: +49 89 (0)511 159 59 Adresse: Elsenheimerstraße 49, 80687 München, Deutschland E-Mail: sales_eu@abbyy.com Support-E-Mail: support_eu@abbyy.com Website: http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
ABBYY UK Ltd. | Telefon:+0870 600 0231 Fax: +01344 392 611 Adresse: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-Mail: sales_UK@abbyy.com Support-E-Mail: support_eu@abbyy.com Website: http://www.abbyy.co.uk
ABBYY Japan | Telefon:+81-42-795-1901 Fax: +81-42-795-1901 Adresse: 658-1 Tsuruma, Machida-shi, Tokio 194-8510 E-Mail: sales@abbyyusa.com Support-E-Mail: support@abbyyusa.com Website: http://www.abbyy.com
ABBYY Taiwan | Telefon:+886-2-2655-0556 Fax: +886-2-2655-2339 Adresse: Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. E-Mail: sales@abbyyusa.com Support-E-Mail: support@abbyyusa.com Website: http://www.abbyy.com


Endbenutzer-Lizenzvertrag

ABBYY FlexiCapture 9.0

Wichtig! Lesen Sie die nachstehenden Bedingungen sorgfältig durch, bevor Sie das Produkt installieren, kopieren und/oder verwenden. Indem Sie das Produkt installieren, kopieren oder verwenden, erklären Sie sich mit diesen Bedingungen einverstanden.

Dieser ABBYY-Endbenutzer-Lizenzvertrag (EULA) ist ein rechtsgültiger Vertrag zwischen Ihnen, dem Endbenutzer des oben genannten Softwareproduktes von ABBYY, zu dem dieser Endbenutzer-Lizenzvertrag gehört und ABBYY für das oben genannte Softwareprodukt von ABBYY, einschließlich sämtlicher dazugehörigen Datenträger, gedruckten Materialien sowie Online- oder elektronischer Dokumentation (gemeinsam als die „SOFTWARE“ bezeichnet).

Indem Sie die SOFTWARE installieren, kopieren oder anderweitig nutzen, bestätigen Sie, diesen Endbenutzer-Lizenzvertrag gelesen und zur Kenntnis genommen zu haben, und verpflichten sich zur Einhaltung der hierin festgelegten Bedingungen.

Die SOFTWARE ist durch Urheberrechte sowie internationale Verträge geschützt. Sie erkennen an, dass dieser Endbenutzer-Lizenzvertrag – wie jeder andere schriftliche, ausgehandelte und von Ihnen unterzeichnete Vertrag – einklagbar ist.

Dieser Endbenutzer-Lizenzvertrag tritt in Kraft, sobald Sie alle hierin genannten Bedingungen durch Auswählen der Option "Ich akzeptiere die Bedingungen der Lizenzvereinbarung" und anschließendes Klicken auf "Weiter" im Installationsprogramm der SOFTWARE akzeptiert haben. Das Datum dieses Vorgangs ist das Datum des Inkrafttretens.

Falls der SOFTWARE ein Endbenutzer-Lizenzvertrag in Papierformat beiliegt und Abweichungen zwischen der vorliegenden Version und der Papierversion bestehen, ist der Text in der Papierversion maßgebend.

Wenn Sie den Bestimmungen dieses Endbenutzer-Lizenzvertrags nicht zustimmen, dürfen Sie die SOFTWARE nicht verwenden. Wählen Sie in diesem Fall im Installationsprogramm der SOFTWARE die Option "Ich lehne die Bedingungen der Lizenzvereinbarung ab", und klicken Sie anschließend auf "Abbrechen".

Definitionen:

"SOFTWARE" ist die ABBYY FlexiCapture 9.0-Software, bei der es sich um ein Paket handelt aus Computerprogrammen, Datenbanken und (in einem gedruckten oder elektronischen Format vorliegender) Dokumentation, die urheberrechtlich geschützt sind.

"SOFTWARE-Komponente" ist ein beliebiger Bestandteil der SOFTWARE, einschließlich, aber nicht beschränkt auf sämtliche Computerprogramme, die im Lieferumfang der SOFTWARE enthalten sind.

"Computer" ist ein elektronisches Gerät mit mindestens einem CPU-Kern, der Daten in digitaler oder ähnlicher Form erfasst und für ein bestimmtes Ergebnis auf der Grundlage einer Befehlsfolge verarbeitet.

"Lizenz" bezeichnet das Ihnen von ABBYY gewährte nicht exklusive Recht zur Nutzung der SOFTWARE gemäß den Bedingungen des vorliegenden Endbenutzer-Lizenzvertrags.

"Aktivierung der SOFTWARE" bezeichnet das Verfahren, bei dem die vollständige Funktionsfähigkeit der SOFTWARE gemäß den Anweisungen in der SOFTWARE-Dokumentation hergestellt wird.

"ABBYY" bezieht sich auf:

ABBYY USA Software House Inc. eingetragen bei 880 North McCarthy Boulevard, Suite 220, Milpitas, Kalifornien 95035, USA, wenn Artikel 16.1 dieses Endbenutzer-Lizenzvertrags Anwendung findet;

ABBYY Europe GmbH eingetragen in der Elsenheimerstr. 49, 80687 München, wenn Artikel 16.2 dieses Endbenutzer-Lizenzvertrags Anwendung findet;

ABBYY UK Ltd. eingetragen im Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, Großbritannien, wenn Artikel 16.3 Anwendung findet;

ABBYY LLC eingetragen in der ul. Perovskaya dom 22, korpus 1, 111398, Moskau, Russland, wenn Artikel 16.4 dieses Endbenutzer-Lizenzvertrags Anwendung findet,

ABBYY Software House Ukraine mit Sitz in 31, Degtyarevskaya st., Kiew, Ukraine 03680, für den Fall, dass Artikel 16.5 des vorliegenden Endbenutzer-Lizenzvertrags zur Anwendung kommt;

und in allen anderen Fällen ABBYY Solutions Ltd., Michail Karaoli 2, Egkomi CY 2404, Nicosia, Zypern.

"ABBYY Group" bezieht sich auf ABBYY und alle seine Tochtergesellschaften.

"ABBYY-Tochtergesellschaft" bezieht sich auf eine juristische Person, die direkt oder indirekt über eine oder mehrere Zwischenstufen von ABBYY kontrolliert wird, unter allgemeiner Kontrolle von ABBYY steht oder ABBYY kontrolliert.

"Sie" und "Ihr" bezieht sich auf und umfasst jede natürliche und/oder juristische Person, die diese SOFTWARE erworben hat und für die diese SOFTWARE benutzt wird.

“ABBYY Partner” steht für die juristische Person, die die SOFTWARE und das Recht, die SOFTWARE zu verwenden, bereitstellt, basierend auf einer Vereinbarung mit ABBYY, die der juristischen Person die Rechte an der SOFTWARE gewährt, die für diese Aktivität notwendig sind.

1. Lizenzgewährung

1.1. Unter der Voraussetzung Ihrer Einhaltung der Bestimmungen dieses Vertrags garantiert Ihnen ABBYY ein nicht exklusives beschränktes Recht (die "Lizenz"), das Sie zur Nutzung der SOFTWARE einschließlich aller darin integrierten Bilder, Fotos, Animationen, Audio-Video-Komponenten, Musik, Texte und Applets sowie der begleitenden gedruckten Materialien und sämtlicher Kopien der SOFTWARE wie weiter unten aufgeführt berechtigt. Alle im Folgenden angeführten Bedingungen beziehen sich sowohl auf die SOFTWARE als Ganzes als auch auf alle Softwarekomponenten.

1.2. Wenn Artikel 15.4 gilt und Sie eine juristische Person sind, dürfen Sie die SOFTWARE nur in dem Land Ihrer Registrierung benutzen, wenn nicht anders in einer getrennten Vereinbarung zwischen Ihnen und ABBYY vereinbart

2. Lizenz

2,1. ABBYY verbürgt sich dafür und garantiert, dass es in vollem Umfang über die Berechtigung, Befugnis, Rechtsfähigkeit, Fähigkeit und Autorisierung zur Lizenzierung und Verteilung der SOFTWARE einschließlich aller darin integrierten Bilder, Fotos, Animationen, Audio-Video-Komponenten, Musik, Texte und Applets sowie der begleitenden gedruckten Materialien und sämtlicher Kopien der SOFTWARE verfügt.

2.2. Alle Rechte an Titeln und geistigem Eigentum, die nicht Bestandteil der SOFTWARE sind, auf die aber durch die Softwarenutzung zugegriffen wird, liegen beim jeweiligen Eigentümer und sind möglicherweise durch das Urheberrecht und/oder andere Gesetze und Verträge für geistiges Eigentum geschützt. Dieser Endbenutzer-Lizenzvertrag überträgt keinesfalls das Eigentum derartigen geistigen Eigentums.

2.3. Die SOFTWARE beinhaltet wertvolle Geschäftsgeheimnisse und vertrauliche Informationen von ABBYY und ist durch (einschließlich, aber nicht beschränkt auf) das Urheberrechtsgesetz der USA, internationale Verträge und die in dem Bestimmungsland geltenden Gesetze urheberrechtlich geschützt. Jegliche Verwendung der SOFTWARE außerhalb der oder unter Zuwiderhandlung gegen die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags stellt einen Verstoß gegen die Rechte am geistigen Eigentum von ABBYY dar und hat den Entzug aller Rechte zur Nutzung der SOFTWARE zur Folge, die Ihnen in diesem Endbenutzer-Lizenzvertrag gewährt werden.

2.4. Sie erkennen an, dass die SOFTWARE gegen unbefugtes Kopieren und/oder unbefugte Nutzung geschützt ist und zu diesem Schutz einen Softwareschlüssel oder Dongle beinhalten kann (nachstehend als "Lizenzschlüssel" bezeichnet), und verpflichten sich in diesem Zusammenhang zur Einhaltung dieser Schutzmaßnahmen in Bezug auf die SOFTWARE.

2.5. Der genaue Umfang der Lizenz kann von verschiedenen beim Kauf der SOFTWARE anzugebenden Faktoren abhängen: dem Funktionsumfang, der zulässigen Anzahl und Arten von Softwarekomponenten im Netzwerk, der Anzahl der von der SOFTWARE verwendeten CPUs, der Anzahl der Seiten, die verarbeitet werden können, dem Ablaufdatum und anderem. Diese und weitere Informationen sind im Lizenzschlüssel kodiert gespeichert. Der Lizenzschlüssel definiert also den Umfang der von Ihnen erworbenen Lizenz und schränkt die Nutzung der SOFTWARE technisch entsprechend ein.

2.6. Sie können diesen Endbenutzer-Lizenzvertrag und die SOFTWARE lediglich einmal dauerhaft an einen anderen Endbenutzer übertragen. Diese Übertragung muss die gesamte SOFTWARE (einschließlich aller SOFTWARE-Komponenten, Datenträger, gedruckten Materialien, sämtlicher Upgrades sowie dieses Endbenutzer-Lizenzvertrags) umfassen. Eine solche Übertragung darf nicht per Zusendung oder auf anderem indirekten Weg erfolgen. Der Empfänger der Übertragung muss sich zur Einhaltung der Bestimmungen dieses Endbenutzer-Lizenzvertrags verpflichten, einschließlich der Verpflichtung die SOFTWARE nicht seinerseits weiterzugeben. Sie müssen die SOFTWARE im Falle einer solchen Übertragung der SOFTWARE von allen Computern, auf der sie installiert wurde, deinstallieren.

2.7. Sie sind nicht berechtigt, ausgenommen die unter Artikel 2.6 beschriebenen Ausnahmen, die SOFTWARE, einschließlich sämtlicher Ihnen hierin gewährten Rechte und/oder anderer Rechte in Bezug auf die SOFTWARE, an andere Personen zu übertragen bzw. weiterzugeben. ABBYY behält sich das Recht vor, im Falle einer solchen Übertragung oder Weitergabe den vorliegenden Endbenutzer-Lizenzvertrag einseitig zu kündigen.

2.8. Dieser Endbenutzer-Lizenzvertrag gewährt Ihnen keinerlei Rechte in Verbindung mit Marken von ABBYY.

2.9. Rechtsvorbehalt. Alle Ihnen nicht ausdrücklich gewährten Rechte sind ABBYY vorbehalten.

3. Verwendung der SOFTWARE

3.1. Sie sind berechtigt, die SOFTWARE in dem in Ihrer Lizenz gewährten Umfang zu nutzen.

3.2. Sie können die SOFTWARE auf einer beliebigen Anzahl von Computern installieren.

3.3. Sie sind berechtigt, so viele Kopien der SOFTWARE gleichzeitig zu verwenden, wie laut Ihrer Lizenz zulässig sind.

3.4. Wenn Sie die SOFTWARE über einen Terminaldienst, der die Nutzung der SOFTWARE über einen Remote-Computer in einem Netzwerk erlaubt, aufrufen, dürfen Sie so viele Kopien der SOFTWARE gleichzeitig verwenden, wie laut Ihrer Lizenz zulässig und in diesem Endbenutzer-Lizenzvertrag festgelegt sind.

3.5. Sie sind nur dann berechtigt, mithilfe der SOFTWARE Scan- und Konvertierungsleistungen anzubieten und/oder die unter Verwendung der SOFTWARE erzielten Ergebnisse Dritten zur Verfügung zu stellen, wenn in Ihrem Lizenzschlüssel der Parameter "BPO services" aktiviert (d. h. auf "Enabled" gesetzt) ist.

3.6. Wenn die SOFTWARE die Beschriftung "Testversion" oder "Nicht für den Weiterverkauf bestimmt" oder eine ähnlich lautende Beschriftung trägt, dürfen Sie sie ungeachtet anderer Abschnitte dieses Endbenutzer-Lizenzvertrags lediglich zu Demonstrations- oder Testzwecken nutzen. Sie erkennen an, dass der Funktionsumfang der SOFTWARE eingeschränkt ist und/oder dass die SOFTWARE nur für eine begrenzte Zeit genutzt werden kann. Versionen der SOFTWARE mit zeitlicher Begrenzung werden nach Ablauf einer festgelegten Frist deaktiviert. Diese Frist ist im Umfang Ihrer Lizenz angegeben.

3.7. Sie dürfen keine der nachfolgend aufgeführten Vorgänge durchführen und auch Dritten nicht ermöglichen, diese durchzuführen:

3.7.1. Sie dürfen die Programme, Datenbanken und andere SOFTWARE-Komponente nicht zurückentwickeln und/oder dekompilieren (den Quellcode des Objektcodes ermitteln) bzw. nur so weit, wie dies im ausdrücklich durch geltendes Recht abgedeckten Rahmen gestattet ist. Wenn anwendbare Gesetze derlei Vorgehen erlauben, dürfen keine der auf diese Art gefundenen Daten an Dritte weitergegeben werden, soweit eine derartige Nicht-Weitergabe durch das Gesetz gestattet ist, und die Daten müssen umgehend an ABBYY weitergegeben werden. Alle solche Daten müssen als vertrauliche Daten und als Eigentum von ABBYY betrachtet werden.

3.7.2. Sie dürfen außer den in der SOFTWARE vorgesehenen und in der Dokumentation beschriebenen Änderungen keine Veränderungen an der SOFTWARE sowie Anpassungen und Übersetzungen der SOFTWARE vornehmen, einschließlich Veränderungen am Objektcode der Anwendungen und Datenbanken der SOFTWARE.

3.7.3 Das Vermieten, Verleasen, Unterlizenzieren, Abtreten oder Übertragen jeglicher Rechte, die Ihnen durch diesen Endbenutzer-Lizenzvertrag gegeben wurden, sowie anderer Rechte im Zusammenhang mit der SOFTWARE an jede andere Person, oder die Erlaubniserteilung, die gesamte oder Teile der SOFTWARE auf einen anderen Computer zu kopieren, sind nicht gestattet, es sei denn, in einem getrennten Vertrag mit ABBYY wurden andere Vereinbarungen getroffen.

3.7.4. Sie dürfen keiner Person, die keine Nutzungsrechte an der SOFTWARE hat und die mit Ihnen in einem System mit mehreren Benutzern arbeitet, die Verwendung der SOFTWARE ermöglichen.

3.7.5. Sie sind nicht berechtigt, Hinweise auf Copyrights, Marken und Patente, die sich bei Lieferung auf der Software befinden, zu beseitigen oder unleserlich zu machen.

4. SOFTWARE auf mehreren Datenträgern

4.1. Sie erhalten die SOFTWARE möglicherweise auf mehreren Datenträgern, wozu auch Downloads über das Internet gehören können. Ungeachtet der Anzahl Datenträger, die Sie erhalten, sind Ihre Rechte zur Nutzung der SOFTWARE auf die Bedingungen und Bestimmungen dieses Endbenutzer-Lizenzvertrags beschränkt.

5. Einschränkungen

5.1. Sie erkennen an, dass die SOFTWARE gegen unbefugtes Kopieren und/oder unbefugte Nutzung geschützt ist. Sie können die Ihnen in diesem Endbenutzer-Lizenzvertrag gewährten Rechte an der SOFTWARE möglicherweise nur ausüben, wenn Sie die SOFTWARE aktivieren.

5.2. Sofern mit ABBYY nicht in einem zusätzlichen Vertrag andere Vereinbarungen getroffen wurden, sind in diesem Endbenutzer-Lizenzvertrag alle Bedingungen und Einschränkungen angeführt, denen die Nutzung der SOFTWARE unterliegt.

6. Endbenutzerdatenbanken

6.1. Sie dürfen Ihre eigenen Datenbanken für die Programme der SOFTWARE erstellen, sofern diese Funktion in der SOFTWARE vorgesehen und in ihrer Dokumentation beschrieben ist.

7. Weiterverteilung der SOFTWARE

7.1. Jegliche Weiterverteilung der SOFTWARE, die über den in Artikel 2.6 beschriebenen Rahmen hinausgeht, ist strengstens untersagt. „Weitergabe“ beinhaltet dritten Parteien Zugang zu dieser Software zu gewähren, das Vermieten, Verleasen und Verleihen der SOFTWARE, ist jedoch nicht darauf beschränkt.

8. Wartung und Technischer Support

8.1. Sofern zwischen Ihnen und ABBYY bzw. Ihnen und dem ABBYY-Partner nicht anderweitig vereinbart, bietet Ihnen ABBYY oder sein Partner Wartung und technischen Support im Rahmen der Bestimmungen im Anhang A dieses Endbenutzer-Lizenzvertrags an.

9. Eingeschränkte Garantie

9.1. ABBYY garantiert, dass die Datenträger, auf denen die SOFTWARE geliefert wird, bei sachgemäßer Behandlung im von der Gesetzgebung des Landes, in dem Sie die SOFTWARE erworben haben, festgesetzten Mindestzeitraum, gerechnet ab dem Kaufdatum, frei von Material- und Verarbeitungsfehlern sind. Wenn die SOFTWARE gemäß Artikel 15.4 erworben wurde, stellt dieser Zeitraum dreißig (30) Tage ab Kaufdatum dar.

9.2. Die SOFTWARE sowie alle Updates und Upgrades werden Ihnen wie besehen („as is“) und ohne Garantien jeglicher Art geliefert. ABBYY übernimmt keinerlei Gewähr für die durch Nutzung der SOFTWARE erzielte Leistung. Mit Ausnahme von Garantien, Bedingungen, Absprachen oder Bestimmungen, die durch das für Sie gültige Recht Ihres Landes nicht ausgeschlossen oder eingeschränkt werden können, gewähren ABBYY und seine Lieferanten keine Garantien, Bedingungen, Absprachen oder Bestimmungen (ausdrückliche oder stillschweigende, unabhängig davon, ob auf gesetzlichen Bestimmungen, bürgerlichem Recht, Gewohnheitsrecht oder anderen Bestimmungen basierend) für jedwede Sachlage, einschließlich und ohne Einschränkung der Nichtverletzung von Rechten Dritter, Marktgängigkeit, Eingliederung, ausreichender Qualität oder Eignung für einen bestimmten Zweck, oder dafür, dass die SOFTWARE frei von Fehlern ist und Ihren Anforderungen genügt, oder dass die SOFTWARE ordnungsgemäß funktioniert, wenn sie gleichzeitig mit anderer Software oder Hardware verwendet wird. Sämtliche Risiken bezüglich der Qualität und Leistung der SOFTWARE liegen bei Ihnen.

9.3. ABBYY übernimmt keine Garantien für Softwareprodukte Dritter, die mit der SOFTWARE geliefert werden können.

10. Beschränkung der Haftung

10.1. In keinem Fall übernehmen ABBYY oder seine Lieferanten Ihnen gegenüber die Haftung für jedwede Schäden, Betriebsunterbrechungen, Datenverluste aller Art (geschäftlicher oder anderer), Ansprüche oder irgendwelche Kosten oder für indirekte, zufällige Schäden oder für jedweden entgangenen Gewinn oder entgangene Einsparungen, die durch und/oder in Zusammenhang mit der Nutzung der SOFTWARE entstehen, oder für Schäden, die durch mögliche Fehler oder Druckfehler in der SOFTWARE entstehen, oder für jeden Anspruch durch Dritte. Dies gilt auch, wenn ein Vertreter von ABBYY auf die Möglichkeit solcher Verluste, Schäden, Ansprüche oder Kosten hingewiesen wurde. Die oben genannten Einschränkungen und Ausschlüsse gelten je nach den Bestimmungen des geltenden Rechts in Ihrem Land. Die alleinige und gesamte Haftung ABBYYs nach oder in Zusammenhang mit diesem Endbenutzer-Lizenzvertrag beschränkt sich, falls vorhanden, auf die Höhe des ursprünglich für die SOFTWARE bezahlten Kaufpreises. Weitere Informationen finden Sie unter den rechtsspezifischen Informationen in Artikel 15 dieses Endbenutzer-Lizenzvertrags.

10.2. Haftungsbeschränkung für Benutzer mit Wohnsitz in Deutschland oder Österreich.
Wenn Sie Ihre Kopie der SOFTWARE in Deutschland oder Österreich erworben haben und wenn sich Ihr Wohnsitz normalerweise in einem der beiden Länder befindet, dann gilt Folgendes:

10.2.1. Gemäß den Bestimmungen in Artikel 10.2.2 ist die gesetzlich festgelegte Haftung ABBYYs für Schäden folgendermaßen eingeschränkt: (i) ABBYY ist nur für eine Schadenshöhe haftbar, die zum Zeitpunkt des Verkaufsvertragsabschlusses unter normalen Umständen absehbar ist, und in Bezug auf Schäden, die durch geringfügige Verletzung einer materialbedingten Vertragspflicht entstehen, und (ii) ABBYY ist nicht für Schäden haftbar, die durch geringfügige Verletzung einer nicht materialbedingten Vertragspflicht entstehen.

10.2.2. Die Haftungsbeschränkung gemäß 10.2.1 ist nicht anwendbar bei jeglicher verbindlicher, gesetzlich festgelegter Haftung, insbesondere bei Haftung nach dem deutschen Produkthaftungsgesetz, Haftung für die Übernahme einer besonderen Garantie oder Haftung für schuldhaft verursachte Personenschäden.

10.2.3. Sie sind verpflichtet, alle zumutbaren Maßnahmen zu ergreifen, um Schäden zu vermeiden und gering zu halten, indem Sie insbesondere Sicherungskopien der SOFTWARE und Ihrer Computerdaten, die den Bestimmungen dieses Endbenutzer-Lizenzvertrags unterliegen, erstellen.

11. Eingebettete Schriftarten

11.1. Schriftprogramme unterliegen dem Urheberrecht, und der Eigentümer eines Schriftprogramms kann Bedingungen zu dessen Benutzung auferlegen. Eine dieser Bedingungen kann sein, dass Sie eine lizenzierte Kopie des Schriftprogramms benötigen, damit die Schriftart in eine PDF-Datei eingebettet werden kann. In keinem Fall kann ABBYY für Schäden, die aus oder in Zusammenhang mit Ihrer Nutzung eingebetteter Schriftarten entstehen, haftbar gemacht werden.

12. Adobe® PDF Library

12.1. "Adobe-Software" bezieht sich auf Adobe® PDF Library für Windows 2000, XP und dazugehörige Dokumentationen sowie jegliche Upgrades, modifizierte Versionen, Updates, Ergänzungen und Kopien der Software. Die SOFTWARE verwendet Adobe-Software für die Konvertierung von PDF-Dateien in Bilddateien.

12.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet ein nicht exklusives Recht zur Nutzung der in die SOFTWARE integrierten Adobe-Software zu den Bedingungen des Endbenutzer-Lizenzvertrags. Die Erstellung einer Sicherungskopie der in die SOFTWARE integrierten Adobe-Software ist erlaubt, sofern die Sicherungskopie auf keinem anderen Computer installiert oder benutzt wird.

12.3. Urheberrechte. Die in die SOFTWARE integrierte Adobe-Software ist Eigentum von Adobe und seiner Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von Adobe und seiner Lieferanten. Darüber hinaus ist die Adobe-Software durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Das Kopieren der in die SOFTWARE integrierten Adobe-Software ist untersagt, es sei denn, es wurde in diesem Endbenutzer-Lizenzvertrag eine Ausnahme vorgesehen. Kopien, deren Anfertigung nach Maßgabe dieses Endbenutzer-Lizenzvertrags erlaubt sind, müssen exakt dieselben Angaben zu Urheber- und anderen Eigentumsrechten enthalten, wie sie in oder auf der SOFTWARE erscheinen. Sie nehmen zur Kenntnis, dass es Ihnen nicht gestattet ist, den Quellcode der in die SOFTWARE integrierten Adobe-Software zu modifizieren, anzupassen, zurückzuentwickeln (reverse engineering), zu dekompilieren, zu deassemblieren oder anderweitig zu versuchen, den Quellcode der in die SOFTWARE integrierten Adobe-Software zu erschließen. Mit Ausnahme des Obengesagten gewährt Ihnen dieser Endbenutzer-Lizenzvertrag keinerlei geistige Eigentumsrechte an der Adobe-Software.

12.4. Lizenzen für Schriftarten. Wenn die SOFTWARE oder die in die SOFTWARE integrierte Adobe-Software Schriftarten-Software enthält, sind Sie grundsätzlich dazu berechtigt, diese Schriftarten-Software oder Typen dieser Schriftarten-Software in Ihre elektronischen Dokumente einzubetten, sofern dies vom Inhaber des Urheberrechts oder vom Händler genehmigt wurde. Die Schriftarten in diesem Paket können sowohl Adobe-eigene als auch andere Schriftarten enthalten. Adobe-eigene Schriftarten dürfen vollständig eingebettet werden.

12.5. Garantie. ABBYY ÜBERNIMMT KEINERLEI GEWÄHR FÜR DIE DURCH NUTZUNG DER IN DIE SOFTWARE INTEGRIERTEN ADOBE-SOFTWARE ERZIELTE LEISTUNG.

12.6. Export der Software. Sie nehmen zur Kenntnis, dass die in die SOFTWARE integrierte Adobe-Software in kein anderes Land geliefert, übertragen oder exportiert und in keiner durch die Exportbestimmungen der Vereinigten Staaten (Export Administration Act) oder andere Exportgesetze, -beschränkungen oder -regulierungen (zusammengefasst "Exportgesetze") untersagten Art und Weise benutzt werden darf. Falls darüber hinaus die in die SOFTWARE integrierte Adobe-Software einer Exportkontrolle unterliegt, bestätigen und gewährleisten Sie, dass Sie weder Staatsbürger noch anderweitig wohnhaft in einem Land sind, das Gegenstand eines US-Embargos ist, und dass Sie auch auf keine andere Weise durch die Exportgesetze vom Empfang der in die SOFTWARE integrierten Adobe-Software ausgeschlossen sind. Alle Benutzerrechte der in die Adobe-Software integrierten SOFTWARE werden unter der Bedingung gewährleistet, dass sie bei Nicht-Einhaltung der Bedingungen dieses Endbenutzer-Lizenzvertrags hinfällig werden.

12.7. Marken. Adobe und Adobe PDF Library sind entweder eingetragene Marken oder Marken der Adobe Systems Incorporated in den Vereinigten Staaten und/oder anderen Ländern.

13. PixTools® Scan-Laufzeitbibliotheken.

13.1. "EMC Software" bezieht sich auf PixTools Scan-Laufzeitbibliotheken sowie Level 1-, Level 2- und Level 3-ISIS-Treiber. Die SOFTWARE verwendet unter Umständen die EMC-Software für die Kommunikation zwischen Scanner und SOFTWARE über die ISIS-Schnittstelle.

13.2. Lizenzgewährung und Beschränkungen. ABBYY gewährleistet ein nicht exklusives Recht zur Nutzung der in die SOFTWARE integrierten EMC-Software zu den Bedingungen des Endbenutzer-Lizenzvertrags.

13.3. Urheberrechte. Die in die SOFTWARE integrierte EMC-Software ist Eigentum der EMC Corporation und seiner Lieferanten. Aufbau, Organisation und Quellcode sind wertvolle Geschäftsgeheimnisse von EMC Corporation und seiner Lieferanten. Darüber hinaus ist die EMC-Software durch das Urheberrecht der Vereinigten Staaten und internationale Abkommen geschützt. Das Kopieren der in die SOFTWARE integrierten EMC-Software ist untersagt. Sie nehmen zur Kenntnis, dass es Ihnen nicht gestattet ist, den Quellcode der in die SOFTWARE integrierten Captiva-Software zu modifizieren, anzupassen, zurückzuentwickeln (reverse engineering), zu dekompilieren, zu deassemblieren oder anderweitig zu versuchen, den Quellcode der in die SOFTWARE integrierten EMC-Software zu erschließen. Mit Ausnahme des Obengesagten gewährt Ihnen dieser Endbenutzer-Lizenzvertrag keinerlei geistige Eigentumsrechte an der EMC-Software.

13.4. Garantie.
ABBYY ÜBERNIMMT KEINERLEI GEWÄHR FÜR DIE DURCH NUTZUNG DER IN DIE SOFTWARE INTEGRIERTEN EMC-SOFTWARE ERZIELTE LEISTUNG.
EMC CORPORATION ODER SEINE LIEFERANTEN SIND IHNEN GEGENÜBER UNTER KEINEN UMSTÄNDEN HAFTBAR FÜR IRGENDWELCHE SPEZIELLEN, ZUFÄLLIGEN ODER FOLGESCHÄDEN, EINSCHLIESSLICH SCHÄDEN AUS ENTGANGENEM GEWINN, ENTGANGENEN EINSPARUNGEN ODER ANSPRÜCHEN DRITTER.
Einige Staaten und Rechtssysteme gestatten keinen Ausschluss der konkludenten Gewährleistung bzw. keine Einschränkungen des Geltungszeitraums von konkludenten Gewährleistungen, so dass die obige Einschränkung unter Umständen für Sie nicht zutrifft. Außerdem können Ihnen je nach Land oder Rechtsprechung möglicherweise weitere Rechte zustehen.

13.5. Marken.
ISIS und PixTools sind Marken oder eingetragene Marken der EMC Corporation in den USA und/oder anderen Ländern.

14. Export der Software

14.1. Die SOFTWARE darf nicht entgegen den Exportbestimmungen gemäß der Gesetzgebung des Landes, in dem die SOFTWARE gekauft oder auf andere Art erworben wurde, ausgeführt bzw. reexportiert werden. Außerdem erklären und versichern Sie, dass es Ihnen nach gültigem Recht nicht untersagt ist, die SOFTWARE zu erhalten.

15. Geltendes Recht

15.1. Wenn die SOFTWARE in den USA, in Kanada, Mexiko, Mittelamerika, Japan oder Taiwan erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte des Bundesstaates Kalifornien (USA). Hinsichtlich eventueller Streitfragen, die im Zusammenhang mit diesem Endbenutzer-Lizenzvertrag und/oder dieser SOFTWARE entstehen, stimmen Sie als Gerichtsbarkeit und Gerichtsstand den Bundesgerichten und/oder einzelstaatlichen Gerichten in Santa Clara (US-Bundesstaat Kalifornien) zu.

15.2. Wenn die SOFTWARE in Österreich, Belgien, Dänemark, Finnland, Frankreich, Deutschland, Griechenland, Italien, Luxemburg, den Niederlanden, Portugal, Spanien, Schweden oder einem anderen Mitgliedsland der Europäischen Union, das nicht in Artikel 15.3 oder 15.4 dieses Endbenutzer-Lizenzvertrags genannt wird, oder auf den Kanalinseln, in der Schweiz, Norwegen, Island oder Liechtenstein erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte von München, Deutschland. Die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrags liegt bei den zuständigen Gerichten in München (Bundesrepublik Deutschland).

15.3. Wenn die SOFTWARE im Vereinigten Königreich von Großbritannien und Nordirland oder in der Republik Irland erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte in England und Wales und die Parteien akzeptieren die Gerichtsbarkeit der Gerichte in England und Wales.

15.4. Wenn die SOFTWARE in Russland, Weißrussland, Kasachstan oder irgendeinem anderen Land der GUS, mit Ausnahme der Ukraine und Moldawien, erworben wurde, oder wenn die SOFTWARE in Lettland, Litauen oder Estland erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte der Russischen Föderation.

15.5. Wenn die SOFTWARE in Albanien, Bosnien-Herzegowina, Bulgarien, Kroatien, der Tschechischen Republik, Ungarn, Israel, Mazedonien, Polen, Rumänien, der Slowakei, Slowenien, der Türkei, Serbien, Montenegro, der Ukraine oder Moldawien erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte der Ukraine.

15.6. Falls Artikel 15.4. dieses Endbenutzer-Lizenzvertrags zur Anwendung kommt und Sie eine juristische Person oder ein Privatunternehmer sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrags beim Schiedsgericht in Moskau (Russische Föderation). Wenn Artikel 15.4 Anwendung findet und Sie eine Privatperson sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrages beim Kreisgericht Perovsky in Moskau (Russische Föderation).

15.7. Wenn Artikel 15.5 Anwendung findet und Sie eine juristische Person oder ein Privatunternehmer sind, müssen alle Streitfragen, Debatten oder Meinungsverschiedenheiten, die aus dem Endbenutzer-Lizenzvertrag entstehen oder mit ihm in Verbindung stehen, endgültig durch ein Schiedsgericht gemäß den Schiedsgerichtsordnungen und -verfahren der internationalen Handelsschiedsgerichtsbarkeit bei der ukrainischen Industrie- und Handelskammer gemäß ihrer Verfahrensordnung gelöst werden. Das Urteil dieses Gerichts ist endgültig und für beide Parteien verbindlich. Wenn Artikel 15.5 Anwendung findet und Sie eine Privatperson sind, liegt die Gerichtsbarkeit für alle Streitfragen bezüglich dieses Endbenutzer-Lizenzvertrages beim Kreisgericht Shevchenkovsky in Kiew, Ukraine.

15.8. Dieser Endbenutzer-Lizenzvertrag unterliegt nicht den Vorschriften des internationalen Privatrechts der einzelnen Staaten oder dem Übereinkommen der Vereinten Nationen über Verträge über den internationalen Warenkauf, deren Anwendung ausdrücklich ausgeschlossen wird.

15.9. Wenn die SOFTWARE in einem anderen als den in den Artikeln 15.1, 15.2, 15.3, 15.4, 15.5 aufgeführten Ländern erworben wurde, unterliegt dieser Endbenutzer-Lizenzvertrag der Rechtsprechung der Gerichte des Landes, in dem Sie die Software gekauft haben.

16. Dauer und Beendigung des Vertrags

16.1. Dieser Endbenutzer-Lizenzvertrag tritt in Kraft am Datum des Inkrafttretens. Wenn nicht anders vereinbart zwischen Ihnen und ABBYY oder außer wenn anders vom Endbenutzer-Lizenzvertrag festgelegt, bleibt dieser Endbenutzer-Lizenzvertrag bis zum Ablauf des Urheberrechts für die SOFTWARE gültig.

16.2. Sie können den Endbenutzer-Lizenzvertrag beenden, indem Sie die SOFTWARE und die beiliegende Dokumentation sowie alle entsprechenden Kopien vernichten.

16.3. Ungeachtet anderer Rechte kann ABBYY diesen Endbenutzer-Lizenzvertrag kündigen, wenn Sie gegen seine Bestimmungen verstoßen. In diesem Fall sind Sie verpflichtet, alle Kopien der SOFTWARE und sämtliche SOFTWARE-Komponenten zu vernichten. Eine derartige Vertragskündigung entbindet Sie nicht von der Pflicht, die SOFTWARE und/oder erbrachte Supportleistungen zu bezahlen.

16.4. Die Bestimmungen 2.3, 2.8, 2.9, 3.7, 7, 9.2, 9.3, 10, 15, 18.2, 18.3 bleiben auch nach Beendigung dieses Endbenutzer-Lizenzvertrags in Kraft, was Sie aber in keiner Weise dazu berechtigt, die SOFTWARE nach Beendigung dieses Vertrags weiterhin zu benutzen.

17. Nutzung durch Regierungsstellen

17.1. Wird die SOFTWARE durch die Regierung der USA oder eine Regierungsbehörde der USA genutzt, gelten die folgenden zusätzlichen Bestimmungen: (1) Restricted Computer Software, wie im Abschnitt Rights in Data-General der Federal Acquisition Regulations 52.227-14 definiert; und (2) jegliche Verwendung, Vervielfältigung oder Offenlegung durch die US-Regierung unterliegt den in Unterabsatz (c)(1)(ii) des Abschnitts Rights in Technical Data and Computer Software von DFARS 252.227-7013 festgelegten Beschränkungen.

18. Allgemeine Bestimmungen

18,1. Sollte sich ein Teil dieses Endbenutzer-Lizenzvertrags als nichtig und nicht einklagbar erweisen, berührt dies in keiner Weise die übrigen Bestimmungen des Vertrags, welche weiterhin Geltung behalten und einklagbar sind. Dieser Endbenutzer-Lizenzvertrag beeinträchtigt in keiner Weise die gesetzlich festgelegten Rechte des Verbrauchers.

18.2. Sie stimmmen zu, während der Aktivierung, Installation und Registrierung der SOFTWARE einige Angaben zu Ihrer Person an ABBYY zu übermitteln. Sie stimmen zu, dass die Angaben zu Ihrer Person von ABBYY gemäß geltendem Recht gesammelt, verarbeitet und genutzt werden dürfen, sofern die Geheimhaltung der Daten gewährleistet ist. Alle an ABBYY übermittelten Angaben zu Ihrer Person werden ausschließlich innerhalb der ABBYY Gruppe gespeichert und verwendet und nicht an Dritte weitergegeben, außer geltendes Recht erfordert dies.

18.3. ABBYY kann Ihnen E-Mails mit Neuigkeiten zu Produkten und zum Unternehmen, Informationen zu Sonderangeboten, Ratschläge zur Verwendung von Produkten sowie firmen- und produktbezogene Informationen zuschicken, falls Sie dem Empfang solcher Informationen ausdrücklich zugestimmt haben. Sie haben die Möglichkeit, Ihre Adresse jederzeit aus ABBYYs E-Mail-Liste entfernen zu lassen.

18.4. ABBYY kann Ihnen gedruckte Materialien, einschließlich dem Benutzerhandbuch, anbieten.

18.5. Die Bezahlung gemäß diesem Endbenutzer-Lizenzvertrag ist der von ABBYY oder einem ABBYY Partner angegebene Preis der SOFTWARE und ist zahlbar gemäß den von ABBYY oder einem ABBYY Partner festgelegten Zahlungsverfahren oder wird in den Preis der Hardware, die von Ihnen erworben wurde, eingerechnet oder ist Teil des von Ihnen zu zahlenden Betrags für die Vollversion der SOFTWARE. Wenn Sie eine natürliche Person sind, kann dieser Endbenutzer-Lizenzvertrag unentgeltlich sein.

18.6. Wenn gegen Sie Ansprüche erhoben oder gerichtliche Verfahren eingeleitet wurden, die in Zusammenhang mit Ihrer Benutzung der SOFTWARE stehen, müssen Sie ABBYY darüber innerhalb von 3 Tagen, nachdem Sie davon erfahren haben, in Kenntnis setzen. Sie müssen alle notwendigen Maßnahmen treffen, um ABBYY die Möglichkeit zu geben, an den Anhörungen der besagten Ansprüche oder gerichtlichen Verfahren teilzunehmen und die notwendigen Informationen zur Einigung der entsprechenden Ansprüche oder gerichtlichen Verfahren, nicht später als 7 Tage nach Erhalt der Anfrage durch ABBYY, bereitzustellen.

Anhang A

Servicevertrag

Sofern keine anderslautende Vereinbarung mit ABBYY getroffen wurde, ist der vorliegende Anhang A integraler Bestandteil des Endbenutzer-Lizenzvertrags.

1. Definitionen

1.1. "Update" bezieht sich auf Erweiterungen der aktuellen Version der SOFTWARE.

1.2. "Upgrade" bezieht sich auf das nächste SOFTWARE-Version, die die aktuelle, von Ihnen laut Endbenutzer-Lizenzvertrag erworbene Haupt- oder Nebenversion ersetzt (Beispiel 1.5. als Ersatz für 1.0, 2.0 als Ersatz für 1.x).

1.3. "Fehler" bezieht sich auf ein Problem, das zur Folge hat, dass die SOFTWARE nicht entsprechend den in der Dokumentation aufgelisteten Spezifikationen funktioniert. Dabei wird zwischen den folgenden drei Fehlertypen unterschieden:

1.3.1. Als Fehler der Priorität 1 gelten Problemsituationen, in denen Ihnen keine Lösung angeboten wird und die Produktion an Ihrem Standort nicht fortgesetzt werden kann. Dazu zählen Fehler mit folgenden Meldungen: "Interner Programmfehler", "Zu wenig Speicherplatz", "Zugriffsverletzung", "Allgemeiner Schutzfehler" und "Division durch null".

1.3.2. Als Fehler der Priorität 2 gelten Probleme, für die eine Lösung verfügbar ist.

1.3.3. Als Fehler der Priorität 3 gelten geringfügige Probleme, die den laufenden Betrieb an Ihrem Standort nicht beeinflussen.

1.4. "Supportleistungen sind Serviceleistungen, die ABBYY oder seine Partner im Zusammenhang mit den von Ihnen gemeldeten Fehlern erbringen.

1.5. "Upgrade-Garantie" bezeichnet den Teil des Servicepakets, der Ihnen das Recht auf den Erhalt von Upgrades einräumt.

2. Service

2.1. Der Support kann Updates, die "Upgrade-Garantie" und Supportleistungen oder eine beliebige Kombination daraus umfassen.

2.2. Der Supportzeitraum sind die ersten zwölf (12) Monate nach Versand bzw. Lieferung der SOFTWARE.

2.3. Eine Verlängerung des Supportzeitraums muss bei ABBYY bzw. seinen Partnern beantragt werden. Wenn Artikel 15.2 oder 15.3 Anwendung findet, wird der Support für einen Zeitraum von 12 Monaten ohne eine weitere Vereinbarung erneuert, wenn Sie den Support nicht innerhalb von 45 Tagen vor Ablauf des Supportzeitraumes stornieren. Eine solche Stornierung muss in schriftlicher Form erfolgen.

2.4. ABBYY oder sein Partner können Ihnen zusätzliche spezifische Bedingungen und Bestimmungen hinsichtlich des Supports liefern.

2.5. ABBYY behält sich das Recht vor, den Inhalt und die Form des Supportvertrags von Zeit zu Zeit nach eigenem Ermessen zu ändern.

2.6. Zusätzlicher Softwarecode, der Ihnen im Rahmen des Servicevertrags zur Verfügung gestellt wird, gilt als Bestandteil der SOFTWARE und unterliegt den Bedingungen und Bestimmungen des Endbenutzer-Lizenzvertrags.

3. Updates und Upgrade-Garantie

3.1. Upgrades und Updates werden auf einer CD-ROM und/oder in elektronischem Format (über FTP) bereitgestellt. Eventuell anfallende Versandkosten sind von Ihnen zu tragen.

3.2. Wenn Sie im Rahmen des Servicevertrags eine Update-Vereinbarung abgeschlossen haben, sind Sie berechtigt, von ABBYY oder seinen Partnern Updates zu erhalten. Die Software-Updates erhalten Sie von ABBYY oder seinen Partnern, sobald sie verfügbar sind.

3.3. Wenn Sie im Rahmen des Servicevertrags eine Upgrade-Garantie abgeschlossen haben, sind Sie berechtigt, von ABBYY oder seinen Partnern Upgrades zu erhalten. Die Software-Upgrades erhalten Sie von ABBYY oder seinen Partnern, sobald sie verfügbar sind.

3.4. Wenn Sie eine Anwendung entwickeln, die die SOFTWARE oder Teile dieser SOFTWARE enthält oder integraler Bestandteil der SOFTWARE ist, muss jedes neue Release dieser Anwendung das jeweils neueste Update der SOFTWARE enthalten, das Ihnen von ABBYY maximal drei (3) Monate vor der Veröffentlichung des Release bereitgestellt wurde (wenn Sie das neueste Update früher als drei (3) Monate vor einem solchen Release erhalten haben, ist dieses Update zu verwenden).

4. Supportleistungen

4.1. ABBYY bzw. seine Partner bieten Supportleistungen für alle Fehler der Priorität 1.

4.2. Wenn Sie im Rahmen des Servicevertrags Supportleistungen erworben haben, gewähren ABBYY bzw. seine Partner bis zu acht (8) Serviceanfragen in Bezug auf Fehler der Prioritäten 2 und 3 für einen Zeitraum von zwölf (12) Monaten. Für alle weiteren Supportleistungen im Zusammenhang mit Fehlern der Prioritäten 2 und 3 in diesem Zeitraum entstehen Zusatzkosten.

4.3. ABBYY bzw. seine Partner erbringen alle Supportleistungen in Bezug auf die SOFTWARE während der normalen Geschäftszeiten und stehen dafür per Telefon und E-Mail zur Verfügung.

4.4. ABBYY bzw. seine Partner verpflichten sich zur Behebung aller ihnen zur Kenntnis gebrachten Fehler der Priorität 1 und werden zu diesem Zweck in wirtschaftlich vertretbarem Umfang auch außerhalb des normalen Release-Zyklus Emergency-Updates herausbringen. Im Normalfall werden Fehler der Prioritäten 2 und 3 im Zuge des nächstfolgenden Release behoben. Emergency-Updates werden ausschließlich für die aktuelle Version der SOFTWARE und mit dem Ziel der Behebung von Fehlern der Priorität 1 herausgegeben.

4.5. Wenn Sie ABBYY oder seinen Lieferanten Fehler zur Kenntnis bringen, verpflichten Sie sich gleichzeitig zur Offenlegung aller Daten, die für die Fehlersuche und die Behebung des Fehlers erforderlich sind. Dazu gehören eine Beschreibung des Problems, Angaben zur Plattform und zum Betriebssystem, auf dem das Problem aufgetreten ist, eine Kopie des Dokuments, das den zu untersuchenden Fehler verursacht hat, eine Kopie der bei Auftreten des Fehlers verwendeten Formatdatei sowie alle Fehlermeldungen, die auf dem Computer im Zusammenhang mit dem Fehler ausgegeben wurden. ABBYY bzw. seine Partner behalten sich das Recht vor, die genannten Informationen für Geschäftszwecke einschließlich, aber nicht beschränkt auf Produktsupport und -entwicklung zu verwenden. ABBYY bzw. seine Partner werden diese Informationen in keiner Form nutzen, durch die Sie identifiziert werden könnten.


Allgemeine Feldeigenschaften

Auf der Registerkarte Allgemein können Sie allgemeine Feldeigenschaften konfigurieren.

Auf dieser Registerkarte wird der Feldtyp rechts neben dem Namen des Felds als Symbol angezeigt.

  • Name: Name des Felds. Der Name wird beim Erstellen des Felds automatisch zugewiesen und entspricht dem treffendsten Beschreibungstext für das Feld. Beim Bearbeiten der Eigenschaften können Sie den automatisch zugewiesenen Namen ändern. Siehe auch Ändern des Feldnamens.
  • Überschrift – der Name des Felds, der im Datenformular angezeigt wird.
  • Feldwert exportieren: Diese Option muss aktiviert sein, wenn Sie den Feldwert exportieren möchten (standardmäßig aktiviert). Sie müssen diese Option z. B. deaktivieren, wenn der Feldwert zum Abrufen des Werts eines berechneten Felds verwendet wird (siehe Regelbasierte Validierung) und nur das Endergebnis exportiert werden soll.
  • In Datenformular anzeigen: Diese Option muss aktiviert sein, wenn das Feld im Datenformular angezeigt werden soll (standardmäßig aktiviert).
  • Kann nicht leer sein: Aktivieren Sie diese Option, wenn es sich um ein erforderliches Feld handeln soll.
  • Schreibgeschützt: Aktivieren Sie diese Option, wenn das Feld nur zur Ansicht verfügbar sein soll, d. h. der Feldwert nicht geändert werden kann. Sie können diese Option für Felder aktivieren, deren Werte mithilfe einer Regel automatisch berechnet werden, z. B. Felder, in denen eine Summe gespeichert wird oder andere Felder zusammengefasst werden (siehe Regelbasierte Validierung).
  • Indexfeld: Aktivieren Sie diese Option, wenn Sie ein Feld zur Dokumentindizierung verwenden möchten. Beim Verarbeiten von Dokumenten können Sie dann den Wert des Felds für jedes Dokument anzeigen und Dokumente anhand des Feldwerts sortieren und suchen.
  • Kommentar: Hier können Sie Kommentare eingeben.

Feldeigenschaften


Glossar

A

ABBYY FlexiCapture

Eine Softwarelösung für die Erfassung von Daten aus unterschiedlichen Dokumenttypen – z. B. strukturierter (statischer Formulare), teilweise strukturierter (flexibler Formulare und Dokumente) und nicht strukturierter Dokumente – in einem Durchgang.

ABBYY FlexiLayout Studio

Ein Programm, mit dem Sie eine flexible Beschreibung (FlexiLayout) der Dokumentstruktur erstellen können, die anschließend für die automatische Dokumenterkennung verwendet werden kann.

ABBYY FormDesigner

Mithilfe von ABBYY FormDesigner können Sie Layouts für maschinenlesbare Formulare entwerfen. Nach der Vervielfältigung und dem Ausfüllen können diese Formulare mit dem automatisierten Formulareingabesystem von ABBYY FlexiCapture verarbeitet werden. Das Entwerfen eines Formularlayouts ist ein für die weitere Dokumentverarbeitung wichtiger Schritt, da die Qualität des Layouts (seine Lesbarkeit für die Software) die Effizienz aller nachfolgenden Schritte (Scannen, Erkennen, Überprüfen und Exportieren) wesentlich beeinflusst.

ADF

Englische Abkürzung für "Automatic Document Feeder" (automatische Dokumentzufuhr). Eine Vorrichtung zur automatischen Dokumentzufuhr, mit der Sie mehrere Dokumente scannen können, ohne zwischenzeitlich eingreifen zu müssen.

Administrator

Ein Benutzer von ABBYY FlexiCapture, der berechtigt ist, das Programm für die Dokumenterfassung zu konfigurieren. Die Konfiguration umfasst das Erstellen und Bearbeiten von Dokumentdefinitionen sowie das Importieren von Profilen.

Alphabet

Ein in der beschriebenen Sprache verwendeter Zeichensatz.

Anhang

Seiten, die keine Felder enthalten, aber in die Dokumentzusammenstellung einbezogen werden. Aus diesen Seiten werden zwar keine Daten extrahiert, sie können aber als Bilder oder durchsuchbare PDF-Dateien gespeichert werden. Siehe Erstellen von Dokumentdefinitionen für Dokumente mit Anhängen.

Anker

Ein statisches Element in Form eines schwarzen Quadrats, Rechtecks, Kreuzes oder einer Ecke, das für die Zuordnung von Dokumentdefinitionen verwendet wird. Details…

Anker sind spezielle Elemente des Formularlayouts, auf deren Grundlage das System nach dem Scannen Zuordnungen trifft (Entfernen von Verzerrungen, Korrigieren linearer und nicht linearer Scanfehler, Berechnen der Position von Blöcken). Die zuverlässigsten Anker sind schwarze Quadrate, die i. d. R. in den Ecken eines Formulars platziert werden. Wenn das Bild keine speziellen Anker enthält, können für die Zuordnung von Dokumentdefinitionen andere statische Elemente verwendet werden: Trennlinien, also vertikale oder horizontale Linien wie Tabellenlinien, Rahmen usw., oder deutlich erkennbarer statischer Text wie Kopfzeile des Formulars, Feldsignaturen oder erklärender Text. Statische Elemente können für die Zuordnung von Dokumentdefinitionen nur verwendet werden, wenn die Option Für Zuordnung von Dokumentdefinitionen verwenden aktiviert ist.

Ankerbarcode

Statisches Element in Form eines Barcodes, der nicht für das Extrahieren von Daten vorgesehen ist. Ankerbarcodes können für die Zuordnung oder Identifizierung von Dokumentdefinitionen verwendet werden.

Ankertext

Statisches Element, das Text auf einem leeren Formular darstellt, der nicht zum Extrahieren von Daten vorgesehen ist. Dabei kann es sich um erklärenden Text oder eine Kopfzeile handeln. Ankertexte können für die Zuordnung oder Identifizierung von Dokumentdefinitionen verwendet werden.

Arbeitsstapel

Dokumentstapel für die Dateneingabe. Für die Verarbeitung von Arbeitsstapeln werden nur veröffentliche Dokumentdefinitionen verwendet. Siehe Dokumentstapel.

Auflösung

Bildparameter. Die Auflösung wird in dpi (Dots Per Inch, Punkten pro Zoll) angegeben.

Auswahlfeld

Ein Dokumentdefinitionsfeld, das ein Auswahlkästchen enthält.

Auswahlfeldgruppe

Ein Element eines maschinenlesbaren Formulars, in dem mehrere nahe beieinander stehende Auswahlkästchen zusammengefasst werden. In einer Gruppe von Auswahlkästchen können eine oder mehrere Möglichkeiten markiert werden.

Auswahlgruppenfeld

Ein Dokumentdefinitionsfeld, das eine Auswahlfeldgruppe enthält.

Auswahlkästchen

Ein maschinenlesbares Formularelement, das von der Person, die das Formular ausfüllt, mit einer Markierung (Häkchen, Kreuz, Punkt usw.) versehen werden soll.

B

Barcode

Ein maschinenlesbares Formularelement, das durch abwechselnde weiße und schwarze Streifen gleicher Länge dargestellt wird und der Kodierung digitaler Informationen dient. Barcodes können in einem Dokument für das Extrahieren von Informationen (Barcodefeld) oder das Zuordnen und Identifizieren einer Dokumentdefinition (Ankerbarcode) verwendet werden.

Barcodeerkennung

Konvertierung eines grafischen Barcodebilds in Zahlen oder Text.

Barcodefeld

Ein Dokumentdefinitionsfeld, das einen für die Erkennung vorgesehenen Barcode enthält.

Benutzerdefinierter Datentyp

Ein vom Benutzer festgelegter Datentyp. Siehe Erstellen benutzerdefinierter Datentypen.

Bereich einer Dokumentdefinition

Eine Reihe von Seiten (oder eine einzelne Seite) und alle Felder auf diesen Seiten, die einen logisch zusammenhängenden Teil eines Dokuments bilden. Dokumentbereiche können mit einer statischen oder einer flexiblen Dokumentdefinition beschrieben werden. Einzelheiten finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente.

Beschreibungsdatei

Eine Zusatzdatei, in der definiert ist, wie ein Stapel zusammengesetzt wird, wenn Bilder aus einem Hot Folder hinzugefügt werden. Ausführliche Informationen finden Sie unter Beschreibungsdatei.

Bild

Ein elektronisches Abbild einer gescannten Seite eines Papierdokuments.

Element eines maschinenlesbaren Formulars, das nicht in die Erkennung einbezogen wird, aber für den Export in Form eines Grafikelements (z. B. als Datei) vorgesehen ist.

Bilddrehung

Vorgang, bei dem ein Bild um seinen Mittelpunkt gedreht wird.

Bildersetzung

Vorgang während der Bearbeitung einer Dokumentdefinition, bei dem ein Bild durch ein anderes ersetzt wird.

Bildfeld

Ein Dokumentdefinitionsfeld, das ein Bild enthält.

Bildimport

Vorgang, bei dem Bilder einem Verarbeitungsstapel hinzugefügt werden. Die Bilder können aus Dateien, von einem Scanner oder mit Importprofilen zum Import ausgewählt werden. Siehe Hinzufügen von Seitenbildern.

Bildstörungen entfernen

Das Entfernen von Störungen aus einem Bild. Diese Störungen können beim Scannen auftreten und sollten entfernt werden, um die Datenerkennung zu verbessern. Beim Entfernen von Störungen löscht die Software auch Punkte aus dem Hintergrund sowie Rahmenlinien aus Rasterformularen.

Buchstaben auf Kamm

Texttyp, bei dem der Text durch einen "Kamm" begrenzt ist. Anzeigen...

Buchstaben in Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei nicht voneinander getrennt. Anzeigen...

Buchstaben in separaten Rahmen

Art der Textmarkierung, bei der jedes Zeichen durch einen Rahmen begrenzt wird. Die Rahmen sind dabei voneinander getrennt. Anzeigen...

D

Datenerfassung in einem Durchgang

Automatisches Extrahieren von Daten aus analogen (gedruckten) und digitalen Dokumenten (gescannte Bilder).

Datentyp

Ein Feldattribut, das bekannte Einschränkungen für die möglichen Feldwerte beschreibt. Mit dem Datentyp wird während der Felderkennung die Anzahl der möglichen Erkennungsvarianten reduziert. Details…

Eines der wesentlichen Merkmale eines Felds ist der Datentyp ( z. B. Zahl, Datum, Text, Nachname, Vorname oder Adresse). Anhand des Datentyps wird die Gruppe von Wörtern definiert, die in diesem Feld vorkommen können.

Der Datentyp ist ein wichtiger Erkennungsparameter, der Einfluss auf die Erkennungsqualität hat. Durch einen korrekt angegebenen Datentyp können Sie die Anzahl der falsch erkannten Zeichen deutlich reduzieren.

Dokument

Eine Kombination aus mehreren Seitenbildern und den Daten, die aus den Seiten extrahiert wurden.

Dokumentdaten

Daten, die nach der Verarbeitung (Erkennung, Überprüfung und Bearbeitung der Erkennungsergebnisse) der Seitenbilder eines Dokuments erfasst werden.

Dokumentdefinition

Mit einer Dokumentdefinition werden die Verfahren für das Erkennen und Verarbeiten eines bestimmten Dokumenttyps definiert. Sie enthält folgende Angaben:

  • Die Dokumentstruktur, also eine Beschreibung der zulässigen Seitenreihenfolge für ein Dokument dieses Typs. Die Dokumentstruktur definiert auch die Regel für die Dokumentzusammenstellung.
  • Definitionen von Dokumentbereichen.
  • Eine Liste der Regeln für Felddaten.
  • Die Position von Feldern und ihrer Signaturen im Datenfenster (Datenformularansicht)
  • Exporteinstellungen für diesen Dokumenttyp.
  • Verarbeitungseinstellungen für diesen Dokumenttyp.

Dokumentdefinitionsbereich

Komponente einer Dokumentdefinition. Der Dokumentdefinitionsbereich entspricht einer oder mehreren Seiten, die einen logisch verknüpften Satz von Feldern enthalten. Die Felder innerhalb eines Bereichs können sich auch über mehrere Seiten erstrecken (z. B. mehrseitige Tabellen), sofern sich die Feldsätze der unterschiedlichen Bereiche nicht überschneiden.
Dokumentdefinitionsbereiche können flexibel oder statisch sein.

Dokumenterfassung in einem Durchgang

Die automatisierte Konvertierung von Papierdokumenten in ein elektronisches Format.

Dokumentfehler

Wenn sich bei der Dokumentverarbeitung herausstellt, dass die Dokumentdaten entweder der Dokumentstruktur und den angegebenen Einschränkungen für den Feldwert oder den Steuerregeln nicht entsprechen, werden alle falschen Zuordnungen in der Fehlerliste des Dokuments erfasst.

Dokumentstapel

Eine Kombination aus Dokumenten, die vom Benutzer zusammengestellt wurden. Normalerweise enthält ein Stapel Dokumente, die in einem Durchgang gescannt oder aus einem bestimmten Ordner importiert wurden. Siehe Dokumentstapel.

dpi

Englische Abkürzung für "Dots per inch" (Punkte pro Zoll). Eine Maßeinheit für die Bildauflösung.

E

Einfacher Text

Eine Form der Textmarkierung, bei der der Text ohne Trennzeichen in einen Block eingefügt wird.

Erkennung

Vorgang, bei dem Bildelemente bestimmten Zeichen zugeordnet werden.

Erklärender Text

Ein maschinenlesbares Formularelement, das einen beschreibenden Text (Formularname, Feldnamen, Erläuterungen von Feldern usw.) enthält.

Export

Vorgang, bei dem verarbeitete Daten an ein externes Informationssystem oder in eine Datei übertragen werden.

F

Falsch erkanntes Zeichen

Status, der einem Zeichen bei der Erkennung automatisch zugeordnet wird, wenn es einem bestimmten Grad der Eindeutigkeit nicht entspricht.

Feld

Ein Dokumentelement, das zum Extrahieren von Daten vorgesehen ist. Felder können einfach (ohne interne Struktur) oder zusammengesetzt sein. Ein zusammengesetztes Feld ist z. B. ein Tabellenfeld, das sowohl als einzelne Zelle als auch als untergeordnetes Feld der Tabelle angesehen werden kann. Siehe Erstellen von Feldern einer Dokumentdefinition.

Feld für die manuelle Eingabe

Ein Dokumentdefinitionsfeld mit nicht erkennbarem Text (z. B. Text mit verschwommenen Buchstaben), der über die Tastatur eingegeben werden muss.

Feld mit mehreren Bereichen

Ein Feld, das mehrere Bereiche im Bild umfasst. Diese Bereiche können voneinander entfernt und sogar auf verschiedenen Seiten positioniert werden. Die Werte aller Bereiche im gleichen Feld werden kombiniert und zusammen als ein Feld exportiert. Felder mit mehreren Bereichen werden meist für Objekte verwendet, die sich über mehrere Seiten erstrecken (z. B. große Tabellen). Siehe Felder mit mehreren Bereichen.

Feld mit mehreren Instanzen

Ein Feld zur Beschreibung mehrerer Objekte desselben Typs (sich wiederholende Objekte). Im Grunde sind diese Objekte als dasselbe Feld anzusehen, da sie dieselben Eigenschaften besitzen. Felder mit mehreren Instanzen sind eine ideale Alternative zum Erstellen mehrerer identischer Felder. Der Export von Feldern mit mehreren Instanzen erfolgt in getrennte Dateien oder Datenbanktabellen. Siehe Felder mit mehreren Instanzen.

Feld ohne Bereich

Ein in einer Dokumentdefinition erkanntes Feld, das über keinen Bereich im Bild verfügt. Siehe Felder ohne Bereich.

Feldbereich

Ein in der Dokumentdefinition hervorgehobener Bildbereich, der für die Datenextraktion vorgesehen ist.

Feldüberprüfung

Ein Überprüfungsmodus, bei dem die erkannten Zeichen im Kontext eines Felds zur Überprüfung übermittelt werden. Details…

Im Feldüberprüfungsmodus werden nicht eindeutig erkannte Zeichen im Kontext des gesamten Felds überprüft.

Grundsätzlich werden alle Felder an die Feldüberprüfung übermittelt, für die die Option Der Feldüberprüfung übergeben aktiviert wurde. Es wird empfohlen, grundsätzlich jene Felder an die Feldüberprüfung zu übermitteln, deren Wertebereich bekannt ist oder einfach ermittelt werden kann. Beispiele für Felder dieser Art sind Länder- oder Städtenamen, da die Werte dieser Felder im Voraus bekannt sind.

FlexiLayout

Beschreibung der Struktur eines flexiblen Dokuments. Diese Beschreibung wird mit ABBYY FlexiLayout Studio erstellt und kann nach ABBYY FlexiCapture exportiert werden. FlexiLayouts stellen die Anweisungen für das Erkennen und Identifizieren von Feldern in einem flexiblen Formular bereit.

Flexible Beschreibung

Eine formalisierte Beschreibung der Dokumentstruktur zur Verbesserung der Felderkennung. Die Erstellung erfolgt in ABBYY FlexiLayout Studio. Das Dateiformat lautet: *.afl. Siehe FlexiLayout.

Flexible Dokumentdefinition

Definition eines Dokuments oder eines Bereichs davon, die für das Verarbeiten flexibler Dokumente vorgesehen ist. Die Erstellung erfolgt durch Anfügen eines FlexiLayouts. Die Felder in diesen Dokumentdefinitionen haben keine feste Position. Sie werden stattdessen mithilfe eines FlexiLayouts erkannt. Siehe Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Formular

Dokument mit einer oder mehreren Seiten, das von einer Person handschriftlich oder mit einem Druckverfahren ausgefüllt werden soll.

Formular mit farbigem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem farbigen Hintergrund erscheinen, der beim Scannen verschwindet.

Formular mit grauem Hintergrund

Ein Formular, in dem alle Informationsfelder als weiße Rechtecke auf einem grauen Hintergrund erscheinen, der beim Scannen verschwindet.

Formularerfassung

Datenerfassung aus den Informationsfeldern von Formularen.

G

Gedruckter Text

Ein Texttyp für die Erkennung von Text, der mit einer Druckmaschine oder einem Laser- bzw. Ink-Jet-Drucker mit einer Mindestauflösung von 300 dpi gedruckt wurde.

Gruppenüberprüfung

Ein Überprüfungsmodus, bei dem als gleich erkannte Zeichen in Gruppen zur Überprüfung übermittelt werden. Details…

Grundsätzlich werden alle Felder an die Gruppenüberprüfung übertragen, für die die Option Zeichen der Gruppenüberprüfung übergeben aktiviert wurde.

Im Allgemeinen empfiehlt es sich, Zeichen aus Zahlenfeldern sowie Auswahlfelder zur Gruppenüberprüfung zu übermitteln.

H

Handschrifttext

Ein Texttyp für die Erkennung, der einen handschriftlichen Text darstellt.

Helligkeit

Ein Schwellenwert für die Lichtempfindlichkeit, der angibt, ab welchem Wert der Scanner Halbtöne von Graustufen als Weiß wiedergibt.

Hot Folder

Ein Ordner auf der Festplatte des lokalen oder eines Remotecomputers, der zum Importieren von Bildern verwendet wird. Er wird meist für das regelmäßig wiederholte Laden von Bildern ohne Benutzerbeteiligung verwendet. Siehe Bildimportprofile.

I

Identifizierung von Dokumentdefinitionen

Vorgang, bei dem die passende Dokumentdefinition mithilfe von Kennungen ausgewählt wird.

Ignoriertes Zeichen

Ein Zeichen innerhalb von Wörtern (z. B. ein Aufzählungszeichen) oder ein weiches Trennzeichen (Tabulator usw.), das die Software nicht daran hindert, das Wort als erkennbaren Datentyp zu kennzeichnen. Details…

Diese Zeichen werden aus den Wörtern ausgeblendet, d. h. die Wörter werden ohne diese Zeichen einem bestimmten Datentyp zugeordnet.

Importprofil

Eine Kombination von Einstellungen, auf deren Grundlage Bilder einem Stapel hinzugefügt werden können. Zu den Einstellungen gehören die Bildquelle, Bildverarbeitungsoptionen und Bereinigungsoptionen für Hot Folder. Siehe Bildimportprofile.

Indexfeld

Ein Feld, mit dessen Wert Dokumente für die Sortierung und Suche indiziert werden. Siehe Indexfelder.

Invertiertes Bild

Ein Bild mit hellem Text auf dunklem Hintergrund.

ICR

Englische Abkürzung für "Intelligent Character Recognition" (intelligente Zeichenerkennung). Dieser Begriff bezieht sich auf Technologien oder Systeme für die Massenverarbeitung von Dokumenten, die mit handgeschriebenen Buchstaben und Ziffern ausgefüllt wurden.

K

Kennung

Ein statisches Element, das für die Auswahl einer Dokumentdefinition verwendet wird, wenn mehrere Dokumentdefinitionen über identisch positionierte Anker verfügen. In den Eigenschaften solcher statischen Elemente muss dazu die Option Für Identifizierung von Dokumentdefinitionen verwenden aktiviert sein.

Klassifikator

Ein in FlexiLayout Studio erstelltes Projekt zur vorläufigen Identifizierung von Seiten vor der Anwendung von Dokumentdefinitionen sowie zur Auswahl der zuzuordnenden FlexiLayout- oder Layoutalternative.

Konstantschrift

Texttyp, bei dem sich die einzelnen Buchstaben in einem Rahmen mit konstanter Höhe und Breite befinden, der dann beim Scannen verschwindet.

Kontrast

Das Verhältnis zwischen der Helligkeit des dunkelsten und hellsten Bereichs eines Bilds.

Korrigiertes Auswahlkästchen

Ein Auswahlkästchen, das fälschlicherweise markiert und anschließend durchgestrichen wurde. Wenn für das Auswahlfeld die Option Korrekturen zulassen aktiviert wurde, erkennt die Software das durchgestrichene Auswahlkästchen als nicht markiert.

Kreuz

Ein Anker in Form eines Kreuzes.

L

Lineares Schwarz-Weiß-Formular

Ein Formular, auf dem Informationsfelder durch Ränder aus einfachen Linien begrenzt sind, die beim Scannen nicht verschwinden.

M

Maschinenlesbares Formular

Ein Formular, das speziell für die automatische Datenerfassung entworfen wurde. Es enthält Arbeitselemente (Anker, Barcodes, Linien usw.), die für die ordnungsgemäße Verarbeitung erforderlich sind.

Mehrseitiges Dokument

Ein Dokument, das mehrere Seiten umfasst.

N

Nicht strukturiertes Dokument

Ein Dokument mit Informationen, die ohne feste Struktur dargestellt werden. Zu diesen Dokumenten gehören z. B. Verträge, Briefe, Aufträge und Diagramme. Siehe Verarbeiten nicht strukturierter Dokumente.

O

OCR

Englische Abkürzung für "Optical Character Recognition". Optische Erkennung gedruckter Texte.

OMR

Englische Abkürzung für "Optical Mark Recognition". Optische Erkennung von Markierungen. Mithilfe dieser Technologie kann ABBYY FlexiCapture einfache Markierungen (Häkchen, Kreuze usw.) auf Formularen mit einer hohen Genauigkeit erkennen und gleichzeitig auch zunächst falsch ausgefüllte und später durchgestrichene Markierungen ermitteln.

Operator

Ein Benutzer von ABBYY FlexiCapture, der für die Dokumenterfassung zuständig ist, also das Hinzufügen von Bildern, das Durchführen der Erkennung und Überprüfung und das Exportieren der erkannten Daten.

Optische Erkennung von Markierungen (Optical Mark Recognition, OMR)

Ein Vorgang, bei dem eine Markierung in einem entsprechenden Feld auf dem Formular erkannt wird.

P

Projekt

In einem Projekt sind verschiedene Dokumentstapel gebündelt und die zur Verarbeitung erforderlichen Einstellungen (Dokumentdefinitionen oder Importprofile) festgelegt. Einzelheiten finden Sie unter Erstellen eines Projekts.

Punktmatrixdrucker

Ein Texttyp für die Erkennung, der mit einem Punktmatrixdrucker gedruckten Text darstellt.

R

Rasterformular

Ein Formular, in dem Informationsfelder als weiße Rechtecke auf grauem Hintergrund dargestellt werden, der entweder Rasterlinien oder durch Rasterlinien getrennte Rechtecke enthält.

Rasterlinie

Eine Linie aus Punkten in einheitlichem Abstand.

Regelbasierte Validierung

Vorgang, bei dem erkannte Daten anhand vordefinierter Regeln automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regeln

Bedingungen für Datenfelder, die vom Programm automatisch überprüft werden. Siehe Regelbasierte Validierung.

Regulärer Ausdruck

Beschreibung der Struktur eines Worts oder eines Eingabewerts mithilfe einer speziellen Sprache. Die Software ermöglicht nicht nur die Angabe der zulässigen Zeichen, sondern auch der Struktur des Feldinhalts. Sie können die Struktur beim Festlegen von Einschränkungen für ein Textfeld und beim Erstellen benutzerdefinierter Datentypen mit einem regulären Ausdruck beschreiben. Siehe Alphabet in regulären Ausdrücken.

Rolle 'Operator'

Die Eigenschaft eines Benutzerkontos in ABBYY FlexiCapture 9.0, mit der festgelegt wird, auf welche Daten der Benutzer zugreifen kann und welche Aktionen mit diesen Daten durchgeführt werden können. Einzelheiten finden Sie unter Arbeiten mit einem konfigurierten Projekt

S

Scannen

Vorgang, bei dem ein Papierformular mithilfe eines Scanners in ein elektronisches Bild umgewandelt wird.

Schlüsselfeld

Ein Feld, das die automatische Überprüfung der Zusammenstellung von Seiten zu Dokumenten ermöglicht. Die Werte der Schlüsselfelder müssen auf allen Seiten des Dokuments gleich sein.

Schreibmaschine

Ein Texttyp für die Erkennung, der mit einer Schreibmaschine geschriebenen Text darstellt.

Schreibstil

Schreibweise, die für eine spezielle Gruppe kennzeichnend ist. Ein Beispiel ist die amerikanische Schreibweise von Zahlen. Details…

Diese Option wird für das Konfigurieren des Schreibstils handschriftlicher Zeichen in Formularen verwendet. Die Auswahl eines Schreibstils richtet sich nach dem Ort, an dem die Dokumente verarbeitet werden (Russland, Deutschland, Tschechische Republik, USA usw.).

Schwarzes Quadrat

Ein Anker in Form eines schwarzen Quadrats.

Seite

Abbild einer Papierseite mit dem Ergebnis der Dokumentverarbeitung.

Seitenausrichtung

Position der Seite in Bezug auf die Standardausrichtung: von oben nach unten und von links nach rechts. Die Seitenausrichtung kann automatisch bei der Erkennung des Seitenbilds bestimmt werden. Sie können dazu in ABBYY FlexiCapture 9.0 die möglichen Ausrichtungen angeben.

Seitenlayout

Ein Schema mit den Positionen der Felder auf einem Bild.

Sprache (Gebietsschema)

Eine Feldeigenschaft, die die Schriftsprache und wichtige regionale Parameter (z. B. Datumsformat oder Adressenschreibweise) festlegt.

Stapeltyp

Die Eigenschaft eines Stapels, die definiert, wie Dokumente in den entsprechenden Stapeln verarbeitet werden müssen. Siehe Stapeltypen

Statische Dokumentdefinition

Definition eines Dokuments oder eines Bereichs davon, die für das Verarbeiten statischer Formulare vorgesehen ist. Die Felder in einer statischen Dokumentdefinition haben eine feste Position.

Statische Elemente

Nicht erkennbare Zeichen, die der Zuordnung und Identifizierung der Dokumentdefinition dienen. Zu diesen Zeichen gehören: Anker, Ankertext, Trennlinien und Ankerbarcodes.

Statisches Formular

Ein Dokument mit statischen Informationsfeldern, deren Formatierung, Anzahl und Layout fest definiert sind und die auch bei unterschiedlichen Dokumentinstanzen unveränderlich bleiben.

T

Tabelle

Daten, die in einem (nicht notwendigerweise sichtbaren) zweidimensionalen Raster angeordnet sind. Die Software verarbeitet Tabellen, die aus Spalten mit gleichen Datentypen und sich wiederholenden Zeilen bestehen.

Tabellenfeld

Ein Dokumentdefinitionsfeld, das eine Tabelle enthält. Dabei handelt es sich um ein zusammengesetztes Feld, bei dem jede Tabellenspalte einen Satz von Feldern desselben Typs darstellt: Textfelder, Auswahlkästchen, Barcodes oder Bilder.

Task

Eine Gruppe von Dokumenten aus demselben Stapel , die zusammen verarbeitet werden sollen. Abhängig von den Projekteinstellungen und vom Verarbeitungsschritt kann ein Task eine unterschiedliche Anzahl von Dokumenten enthalten. Wenn in einem Verarbeitungsschritt ein Stapel komplett verarbeitet werden muss, ist der gesamte Stapel in den Task eingeschlossen. Wenn Überprüfungstasks automatisch erstellt werden, enthält jeder Task 10 Dokumente (wenn ein Stapel weniger als 10 nicht überprüfte Dokumente enthält, werden alle als ein Task verarbeitet).

Teilweise strukturiertes Dokument

Ein Dokument mit einer Reihe von Informationsfeldern, deren Design, Anzahl und Layout sich bei verschiedenen Instanzen des Dokuments erheblich unterscheiden können. Einzelheiten finden Sie unter Unterstützte Dokumenttypen in ABBYY FlexiCapture 9,0.

Teststapel

Dokumentstapel, die für das Testen und Konfigurieren von Dokumentdefinitionen vorgesehen sind. Für die Verarbeitung von Teststapeln werden lokale Kopien von Dokumentstapeln verwendet. Siehe Dokumentstapel.

Text im Rahmen

Texttyp, der anzeigt, wo der Text durch einen Rahmen begrenzt wird. Anzeigen...

Text im Rahmen mit Kamm

Texttyp, der anzeigt, wo Text durch einen Rahmen begrenzt wird, dessen unterer Rand wie ein Kamm geformt ist. Anzeigen...

Textausrichtung

Ausrichtung des Texts in einem Feld in Bezug auf die Seite.

Textbeispiel

Eine Datei mit Beispielen aller alphabetischen Zeichen.

Texterkennung (OCR, ICR)

Umwandlung eines grafischen Bilds in Text.

Textfeld

Element eines maschinenlesbaren Formulars, das beim Ausfüllen dieses Formulars der Eingabe von Text dient.

Textfeldmarkierung

Ein Grafikelement, das ein Textfeld begrenzt, z. B. Rahmen, Kamm oder Linie.

Textmarkierung

Das Layout eines Seitenbereichs, der für die Texteingabe vorgesehen ist. Beispiele für die Textformatierung finden Sie unter Eingabefeld.

Trennzeichen

Element eines maschinenlesbaren Formulars, das durch eine vertikale oder horizontale Linie dargestellt wird.

U

Überprüfung

Vorgang, bei dem erkannte Daten durch den Operator überprüft werden. Dabei werden die Ergebnisse mit dem Original des entsprechenden Dokumentbereichs verglichen. Bei ABBYY-Produkten wurden Technologien für die Überprüfung implementiert, die bestimmte Eigenheiten von Benutzern ( Routine, Können, Wahrnehmungsvermögen) berücksichtigen. Siehe Überprüfen erkannter Daten.

Unerkennbarer Bereich

Ein Bildbereich, der von der Erkennung ausgeschlossen ist. Auf diese Weise können Sie einen Bereich mit erklärendem Text oder einem Bild ausschließen, der die Felderkennung erschweren würde. Siehe Ausschließen eines Bereichs von der Erkennung.

Unterstrichener Text

Art der Hervorhebung, bei der Zeichen unterstrichen sind. Anzeigen...

Unzulässiges Zeichen

Ein Zeichen, von dem Sie mit Sicherheit wissen, dass es nicht in den zu erkennenden Daten enthalten sein wird. Details...

Die Angabe solcher Zeichen kann zu einer deutlich höheren Geschwindigkeit und Qualität bei der Erkennung führen. Wenn erkannter Text z. B. nur Großbuchstaben enthält, können Sie sämtliche Kleinbuchstaben als unzulässige Zeichen kennzeichnen.

V

Verarbeitungsschritt

Ein Schritt im Workflow, in dem mit einem Dokument oder einem Stapel (entweder automatisch oder von einem Operator) bestimmte Aktionen durchgeführt werden. Einzelheiten finden Sie unter Verarbeitungsschritte und Warteschlangen

Veröffentlichung von Dokumentdefinitionen

Freigabe einer neuen Dokumentdefinitionsversion nach deren Bearbeitung. Während veröffentlichte Versionen bei der Verarbeitung von Dokumenten aus Arbeitsstapeln zum Einsatz kommen, können nicht veröffentlichte, lokale Versionen nur bei der Verarbeitung von Dokumentdefinitionen aus Teststapeln verwendet werden. Siehe Bearbeitung und Veröffentlichung einer Dokumentdefinition.

W

Warteschlange

Dokumente, die in Tasks und/oder Stapeln zusammengefasst sind und zur Verarbeitung in einem bestimmten Verarbeitungsschritt anstehen. Einzelheiten finden Sie unter Verarbeitungsschritte und Warteschlangen

Winkel

Ein Anker in Form eines Winkels.

Wörterbuch

Eine Liste von Wörtern, mit denen ein bestimmter Datentyp bestimmt wird. Details…

Das Wörterbuch wird beim Erstellen des Datentyps angegeben. Dadurch ist bereits mit dem Datentyp eines Felds das Wörterbuch festgelegt, das bei der Erkennung und Überprüfung verwendet wird. Die Software unterstützt nicht nur vordefinierte Datentypen mit fertigen Wörterbüchern, sondern ermöglicht es dem Benutzer auch, Datentypen mit individuellen Wörterbüchern zu erstellen. Sie können die Wörterbuchdaten manuell eingeben oder aus einer Datei laden.

X

XFD

Abkürzung für XML-Formulardefinition (*.xfd). Hierbei handelt es sich um ein spezielles Dateiformat für Formulare, die mit ABBYY FormDesigner erstellt wurden. Mithilfe von XFD-Dateien können in ABBYY FlexiCapture Dokumentdefinitionen erstellt werden.

Z

Zulässiger Zeichensatz

Eine Gruppe von Zeichen, die im zu erkennenden Datentyp vorkommt. Details…

Dieser Satz wird durch den Datentyp definiert. Das bedeutet, dass durch den an ein Feld angefügten Datentyp festgelegt wird, welcher Zeichensatz bei der Erkennung verwendet wird.

Neben der Auswahl der Zeichen in diesem Zeichensatz können Sie zusätzliche Parameter konfigurieren, die diesen Satz einschränken. Beispielsweise könnten Sie folgende Zeichen ausschließen:

  • Zeichen, von denen Sie wissen, dass sie nicht im zu erkennenden Feld vorkommen (z. B. sämtliche Kleinbuchstaben in einem Feld, wenn in diesem Feld nur Großbuchstaben zulässig sein sollen).
  • Zeichen, die in Wörtern auftreten können, aber die Überprüfung dieser Wörter nicht beeinträchtigen sollen (z. B. Bindestriche, Betonungszeichen usw.).

Zuordnung von Dokumentdefinitionen

Vorgang, bei dem eine Dokumentdefinition ausgewählt wird und ihre Felder einem Bild zugeordnet werden.


Glossar

A B D E F G H I K L M N O P R S T U V W X Z


Beschreibungsdatei

Eine Beschreibungsdatei ist eine Hilfsdatei, in der definiert ist, auf welche Weise ein Stapel beim Hinzufügen von Bildern aus einem Hot Folder gebildet wird. Je nach Format der Beschreibungsdatei wird der Stapel aus unterschiedlichen Dateigruppen gebildet.

Im Programm werden die folgenden Beschreibungsdateitypen verwendet:

  1. Captiva QuickScan
    Alle in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt. Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.
  2. Kodak Capture Software
    Die Bilddateien im Ordner des Kodak-Stapels werden nach Dateiname sortiert in aufsteigender Reihenfolge zum Stapel hinzugefügt.
  3. Leere Datei
    Diese Datei dient als Merker und weist darauf hin, dass ein neuer Stapel zu erstellen ist. Der Inhalt der Datei ist irrelevant, nur der Name ist von Bedeutung. Bilder werden in alphabetischer Reihenfolge aus dem Hot Folder hinzugefügt. Wenn im Feld Dateiname eine Datei mit dem der Maske entsprechenden Namen gefunden wird, erstellt das System einen neuen Stapel. Wenn also die Maske *.dat angegeben wurde und der Hot Folder die folgenden Dateien enthält:
    Contract.dat
    Contract1.jpg
    Contract2.jpg
    Letter.dat
    Letter1.jpg
    Letter2.jpg,
    wird für die Dateien Contract*.jpg ein Stapel erstellt (wenn Contract.dat gefunden wird), und ein weiterer Stapel wird für die Dateien Letter*.jpg erstellt (wenn Letter.dat gefunden wird).
  4. XML-Datei
    Hierbei handelt es sich um eine XML-Datei mit dokumentierter Struktur. Die XML-Datei wird verwendet, wenn die anderen drei Dateitypen nicht eingesetzt werden können, jedoch eine benutzerdefinierte Beschreibungsdatei generiert werden kann. Die in der Beschreibungsdatei aufgeführten Bilddateien werden zum Stapel hinzugefügt.

    Eine XML-Datei muss das Stammelement Stapel mit untergeordneten Elementen vom Typ Bilder enthalten.

    Jedes untergeordnete Element Bilder muss wiederum Elemente vom Typ Bild enthalten, deren Anzahl der Anzahl der Seiten im zu erstellenden Stapel entspricht. Jedes Element Bild muss einen UNC-Pfad zur entsprechenden Bilddatei enthalten. Der Pfad zum Ordner mit dem Bild muss für alle Elemente vom Typ Bild gleich sein.

    <Batch>

    ...

    <Images>
    <Image>\\HotFolder\Page1.tif</Image>
    <Image>\\HotFolder\Page2.tif</Image>
    <Image>\\HotFolder\Page3.tif</Image>

    </Images>

    </Batch>

    In diesem Fall wird empfohlen, das Scanprogramm so einzurichten, dass gescannte Bilder direkt im Hot Folder oder in den zugehörigen Unterordnern auf der nächsten Ebene abgelegt werden. Beim Erstellen eines Stapels werden diesem alle in den Elementen vom Typ Bild der entsprechenden Beschreibungsdatei aufgeführten Bilder hinzugefügt. Die Bilder werden in der Reihenfolge hinzugefügt, in der sie in der Beschreibungsdatei angeordnet sind.

    Die Reihenfolge der Bilddateien im Stapel entspricht der Reihenfolge in der Beschreibungsdatei.


Eigenschaften eines Dokumentdefinitionsbereichs

Sie können die Eigenschaften eines Dokumentdefinitionsbereichs im entsprechenden Eigenschaftsdialogfeld anzeigen und ändern. Wählen Sie dazu im Kontextmenü des Bereichs die Option Eigenschaften… aus.

Das Dialogfeld enthält drei Registerkarten.

Registerkarte Allgemein

Auf dieser Registerkarte können Sie den Namen eines Dokumentbereichs ändern, die Beschreibung eingeben oder bearbeiten sowie die Mindest- oder Maximalanzahl der Bereichswiederholungen im Dokument eingeben oder ändern. Über die Option Aktiviert wird die Abschnitts-Dokumentdefinition in die Dokumentverarbeitung eingeschlossen bzw. von dieser ausgeschlossen. Ausführliche Informationen zu mehrseitigen Dokumenten und zum Verwenden von Vorlagenbereichen finden Sie unter Erstellen von Dokumentdefinitionen für mehrseitige Dokumente.

Registerkarte FlexiLayout

Wenn einem Bereich ein FlexiLayout zugewiesen wurde, werden auf dieser Registerkarte Name, Version und Kommentar angezeigt. Sie können ein FlexiLayout anfügen, indem Sie auf die Schaltfläche Laden… klicken, und entfernen, indem Sie auf die Schaltfläche Entfernen klicken.

Ausführliche Informationen finden Sie unter Erstellen einer Dokumentdefinition zum Verarbeiten flexibler Dokumente.

Registerkarte Bilder
Auf dieser Registerkarte werden die Parameter für die Seitenbilder eines Bereichs angezeigt. Folgende Parameter sind verfügbar: Größe, Auflösung, Druckgröße und Farbmodus.

Registerkarte Regeln

Auf dieser Registerkarte können Sie Vorgänge mithilfe von Regeln für Vorlagen durchführen. Sie können Regeln löschen oder bearbeiten sowie neue Regeln erstellen.

Weitere Informationen finden Sie unter Regelbasierte Validierung.