À propos d'ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 est un logiciel conçu pour intégrer automatiquement les données des documents au format papier dans des systèmes d'information et des bases de données.

Il utilise des technologies avancées de reconnaissance de caractères dactylographiés et manuscrits, de traitement d'images et d'analyse de documents. ABBYY FlexiCapture 9.0 offre un système très pratique d'extraction automatique d'informations utiles à partir de toutes sortes de documents. Ces documents sont traités en une seule opération. Il peut s'agir de formulaires structurés (fixes) ou semi-structurés, ou encore de documents non structurés de format libre. ABBYY FlexiCapture 9.0 permet de ne pas avoir à trier ni à réimprimer les documents manuellement, opération qui nécessite beaucoup d'efforts et fait perdre du temps.

Le processus de traitement documentaire type se déroule comme suit :

  1. Les documents sont placés dans le chargeur automatique du scanner, et la numérisation commence.
  2. Les images des documents numérisés sont alors soumises au processus de reconnaissance. Le logiciel identifie automatiquement les documents, notamment ceux qui comportent plusieurs pages. Il localise les champs importants, extrait les données et charge les règles de contrôle.
  3. Si nécessaire, le processus de reconnaissance est suivi d'une vérification visuelle des données et d'un contrôle des erreurs de règles.
  4. Les données reconnues et vérifiées, ainsi que les copies électroniques des documents, sont enregistrées dans une base de données, un système d'information ou un fichier.


Nouvelles fonctionnalités d'ABBYY FlexiCapture 9.0 non disponibles dans ABBYY FlexiCapture 8.0 Professional

Architecture

Installation distribuée

ABBYY FlexiCapture 9.0 prend en charge l'installation et l'exécution distribuées. L'installation distribuée implémentée dans ABBYY FlexiCapture 9.0 est similaire à celle de FormReader 6.5 Enterprise Edition, avec quelques modifications pour rendre le système plus flexible, extensible et fiable. La station de numérisation et la station de vérification de données peuvent maintenant être utilisées à distance via Internet.

Architecture et principes de base d'ABBYY FlexiCapture 9.0
Flux de travail
Serveurs ABBYY FlexiCapture 9.0
Stations ABBYY FlexiCapture 9.0
API du serveur d'application

L'API fourni pour le serveur d'application vous permet de contrôler le traitement par programme sans passer par l'interface graphique. L'API permet aux éditeurs tiers de créer leurs propres applications qui utilisent ABBYY FlexiCapture 9.0 comme service d'analyse d'images de documents mais également pour exporter les résultats du traitement.
API du serveur d'application

Gestion de projet

Types de lots

Un type peut être défini pour chaque lot (si aucun type n'est défini, un type « par défaut » est attribué). Un projet peut contenir n'importe quel nombre de types de lots. Un type de lot définit les options de reconnaissance et de traitement d'image, la vérification de l'intégrité du lot, les paramètres d'exportation par défaut et la manière dont les lots appartenant à ce type doivent être traités. Les paramètres de projet sont utilisés pour les lots du type « par défaut ».
Lots de documents

Paramètres d’enregistrement

Il est maintenant possible de définir les paramètres d’enregistrement concernant les lots ou les documents. Ces paramètres peuvent être utilisés ultérieurement pour l’exportation d’images et de données.

Paramètres d’enregistrement
Priorités

Les priorités des documents et des lots peuvent désormais être définies pour contrôler l’ordre de traitement.

Analyse et reconnaissance

L'ordre dans lequel les définitions de documents sont associées

Vous pouvez désormais contrôler l'ordre dans lequel les définitions de documents sont associées. Les méthodes suivantes peuvent être utilisées pour définir l'ordre d'association :

  • définition explicite de l'ordre des définitions de document dans la boîte de dialogue Définitions de documents ;
  • pour les FlexiLayouts, utilisation d'un classifieur pour sélectionner la définition de document requise ;
  • pour les FlexiLayouts, la manière dont le FlexiLayout approprié doit être sélectionné doit être indiquée dans la boîte de dialogue Définitions de document.
Modification et publication d'une définition de document
Classifieur
Mise à jour de la version d'une définition de document sans nouvelle reconnaissance

Vous pouvez désormais mettre à jour votre définition de document sans effectuer de nouvelle reconnaissance. Cela est possible si l'une des conditions suivantes est remplie :

  • si seuls les paramètres d'exportation ont été modifiés, auquel cas le document sera exporté avec les nouveaux paramètres ;
  • si les règles ont été modifiées, auquel cas la validation par règle sera effectuée une nouvelle fois.

Vérification et validation

Les tâches de vérification et de validation peuvent désormais être obtenues automatiquement
Les images peuvent être affichées pendant la vérification de groupe et de champ.
Les fichiers et les bases de données peuvent être utilisés comme sources de données pour la validation par règle.
La règle de vérification de la base de données peut être désactivée pour les champs vides.
Une règle de calcul de somme a été ajoutée
Le niveau de fiabilité de la reconnaissance est indiqué pour le lot entier.
Des paramètres de champ et de groupe ont été ajoutés, y compris la possibilité de configurer certaines exigences relatives à des caractères spécifiques
La position initiale du curseur peut être définie pour la vérification de champ.
Les champs entiers peuvent optionnellement être mis en surbrillance pendant la vérification de champ (utile si l'utilisateur souhaite effectuer une saisie dans l'intégralité du champ).
Chaque type d'erreur est affiché séparément. Les types d'erreurs suivants sont détectés :
  • erreurs d'assemblage ;
  • erreurs de format ;
  • erreurs de règles.
Vérification des données reconnues

Exportation

Exportation automatique

Les documents présentant une haute qualité de reconnaissance sans erreur de format ou de règles sont désormais exportés automatiquement sans l'intervention de l'utilisateur. Le pourcentage de caractères incertains requis est défini lors de la configuration du projet.
Flux de travail

Exporter vers plusieurs destinations

Les données et les images peuvent être exportées vers plusieurs destinations. Certaines destinations peuvent être marquées comme critiques. Si l'exportation vers une destination critique échoue, un message d'erreur s'affiche. Si l'exportation vers une destination non critique échoue, il n'en résulte pas d'erreur globale d'exportation.
Configuration de l'exportation de données

Configuration des noms et des emplacements de fichiers

Les modèles de dénomination des fichiers utilisés pour stocker les données et les images exportées, ainsi que leurs chemins d’accès, peuvent être configurés de manière plus approfondie. Parmi les ajouts figure la possibilité de recréer la structure du dossier pendant l’exportation à partir d’un dossier actif.
Exporter un système de dénomination de fichier

Archivage de documents comportant des erreurs

Les documents présentant des erreurs de format ou de règle peuvent être enregistrés dans un emplacement de stockage dédié. L'exportation de documents comportant des erreurs est définie de la même manière que l'exportation de documents ordinaires.
Configuration de l'exportation de données

Suppression automatique des documents à la fin de l'exportation

Les documents exportés peuvent être supprimés si l'exportation s'est terminée avec succès. L'option de suppression manuelle des documents a été conservée.
Flux de travail

Préserver les informations confidentielles

Les champs individuels figurant sur les images de documents peuvent désormais être masqués (c'est-à-dire coupés). Pour chaque exportation, différentes règles de masquage peuvent être définies, régulant ainsi la quantité d'informations visibles par différents utilisateurs.
Configuration de l'exportation de données

Options

Vérifications de l'intégrité du lot

Les scripts peuvent être utilisés pour vérifier l'intégrité des lots. Les scripts se lancent automatiquement avant l'exportation.
Lots de documents
Exemples de scripts permettant de créer des règles personnalisées

Scripts de normalisation

Les scripts peuvent être utilisés pour corriger les informations extraites à partir des champs.
Traitement des données entrées
Exemples de scripts permettant de créer des règles personnalisées

Traitement automatique

Les documents peuvent être traités automatiquement sans l'intervention de l'opérateur. Les documents traités avec succès sont exportés et les images de documents sur lesquelles des erreurs se sont produites peuvent être enregistrées en vue d'une analyse ultérieure.

Configuration du flux de travail
Personnaliser des scripts

Un script, déclenché par l’opérateur de vérification, peut être défini pour chaque champ.

Personnaliser une action
Champs de service

Un nouveau type de champ a été ajouté : le champ de service. Les champs de ce type sont remplis automatiquement à l’aide des données issues d’une source sélectionnée.

Champs de service

Langues prises en charge

Nouvelles langues d'OCR

La prise en charge de la reconnaissance optique des caractères (OCR) pour les langues suivantes a été ajoutée :

  • Vietnamien
  • Chinois
  • Coréen
  • Japonais

Nouvelles fonctionnalités d'ABBYY FlexiCapture 8.0 Professional non disponibles dans FormReader 6.5 Desktop

Types de documents traités

Documents multipages avec une structure complexe

Le programme permet d'identifier et de traiter automatiquement les documents structurés, semi-structurés et non structurés comportant un nombre variable de pages, des pages récurrentes ainsi que des documents avec des annexes.
Types de documents traités à l'aide d'ABBYY FlexiCapture 9.0
Création de définitions de document pour les documents multipages
Création de définitions de document pour des documents comportant des annexes

Documents non structurés

Les documents non structurés contenant du texte ou des images séparés par des pages vierges, des pages avec des codes barres ou du code de correction, sont indexés à l'aide de définitions de document simples, traités et exportés vers des fichiers indexés ou vers des fichiers graphiques.
Traitement de documents non structurés

Documents de plusieurs pages semi-structurés avec tableaux complexes ou sur plusieurs pages

Les documents semi-structurés de plusieurs pages contenant des tableaux qui continuent à la page suivante sont identifiés, assemblés sous forme de documents, et traités à l'aide d'une description flexible unique.
Création d'une définition de document pour le traitement des documents flexibles

Formulaires fixes contenant des tableaux

Afin de simplifier le traitement des documents qui contiennent des tableaux, le programme prend désormais en charge les tableaux dans les formulaires fixes.
Création d'un tableau

Éléments récurrents

Le programme prend en charge les groupes de champs récurrents dans les documents structurés et semi-structurés. Cela simplifie la configuration du traitement des documents contenant des groupes d'éléments identiques qui se répètent, ainsi que le traitement des tableaux complexes comprenant de tels groupes.
Création d'un groupe de champs

Architecture du programme

Modes opérateur et administrateur

Les modes opérateurs et administrateur s'activent selon les différentes commandes sélectionnées dans le menu Démarrer. Ils peuvent être installés sur différents ordinateurs. Toutes les fonctions du programme sont disponibles en mode administrateur. En mode opérateur, l'utilisateur ne peut pas modifier de définitions de document, importer des fichiers ou accéder aux lots de test.

Travail sur des projets

Un projet est un environnement unique qui unifie les lots de documents et les paramètres requis pour les traiter, comme les définitions de document, les profils d'importation, etc.

Un même projet peut être utilisé par différentes copies du programme : un projet peut être exporté et importé sous forme d'objet unique, un projet peut être mis à jour ou transféré d'un ordinateur vers un autre. Différentes stations de travail peuvent travailler avec les mêmes projets dans un réseau, ce qui permet d'optimiser le traitement des documents.
Création d'un projet
Propriétés du projet

Outils pratiques à utiliser avec les processus d'arrière-plan

Il est possible d'exécuter les opérations longues, comme l'ajout d'images, la reconnaissance ou l'exportation, en mode Arrière-plan de manière à réduire de manière significative le temps de traitement des documents. L'utilisateur peut toujours vérifier l'état d'un processus d'arrière-plan, modifier la priorité des tâches et consulter le journal de traitement.

Mode Arrière-plan

Éditeur de définition de document

Travailler au niveau document

Les définitions de document sont créées pour l'intégralité du document en tant qu'unités de traitement. Une définition de document détermine la manière dont les documents d'un type donné sont identifiés et traités. Chaque définition de document contient des images de page, des règles d'assemblage, des descriptions de champs et d'éléments statiques, des règles de vérification, des paramètres de vérification, des descriptions des types de données, et des paramètres d'exportation de données.
Création de définitions de document pour les documents multipages

Passer d'un mode d'image à un autre

L'éditeur de définitions de document permet désormais d'alterner entre deux modes d'image. Vous pouvez afficher les images dans leur couleur d'origine ou en noir et blanc, indépendamment du format sous lequel elles ont été ajoutées au lot. Une image couleur simplifie la création des définitions de document pour les formulaires couleur. En effet, ce mode permet de voir le marquage du champ et le texte d'explication, ce qui est nécessaire pour dessiner la région du champ et pour attribuer un nom au champ. Il est important de pouvoir afficher les images en noir et blanc afin de s'assurer que les ancres et le texte statique sont visibles après la phase de conversion binaire qui intervient au cours de la reconnaissance.

Éditeur de formulaires de données

L'éditeur de formulaires de données permet de créer facilement une présentation personnalisée pour des données extraites, et de les afficher sous un format agréable.
Configuration de la présentation des données dans la fenêtre de document

Présentation des champs sous forme d'arborescence

La structure du document est représentée graphiquement sous forme d'arborescence, ce qui permet de modifier, de copier, de supprimer et de déplacer rapidement des champs.
Présentation de la structure du document sous forme de contours de page

La structure du document est présentée sous forme de contours de page très pratiques. Il est ainsi facile d'afficher, de modifier et de créer des définitions de document pour des documents de plusieurs pages.
Séparation de l'affichage des éléments statiques et des champs

Les éléments statiques et les champs peuvent être affichés séparément. Il est ainsi plus facile de créer des définitions de document. L'opération peut en effet être subdivisée en deux. Les éléments statiques sont créés séparément, tandis que les ancres, les séparateurs, le texte d'ancre et les codes barres ne perturbent pas la création des régions des champs.

Création de champs dans une définition de document
Éléments statiques
Groupement de champs

Les champs peuvent être combinés en groupes, ce qui permet de clarifier la structure du document et de créer des groupes de champs récurrents.

Création d'un groupe de champs
Propriétés d'un groupe de champs
Tableaux dans les définitions de documents fixes

Vous pouvez désormais créer un champ de tableau dans une définition de document fixe, ce qui simplifie considérablement la configuration, l'extraction des données et leur exportation à partir de tableaux. Un champ de tableau est un ensemble de colonnes de même type et de lignes récurrentes.

Création d'un tableau
Propriétés de tableau
Éléments récurrents dans les définitions de documents fixes

Les éléments récurrents sont des champs ou des groupes de champs qui apparaissent un certain nombre de fois dans le formulaire et qui décrivent des objets similaires, tels que les mêmes informations sur différents employés, enfants, comptes, etc. La structure de ces éléments récurrents est similaire à celle d'un tableau : les champs représentent une colonne, tandis que chaque répétition correspond à une ligne. L'éditeur de définitions de document simplifie la configuration et le traitement de ces champs.

Champs avec plusieurs instances
Champs situés sur plusieurs pages d'un formulaire

Si votre formulaire contient des champs dont la région est située sur plusieurs pages (par exemple, des tableaux longs), l'éditeur de définitions de document vous permet de les afficher sous la forme d'un champ unique, ce qui simplifie considérablement la configuration et le traitement.

Champ appartenant à plusieurs régions
Création automatique de définition de document fixe

L'éditeur de définitions de document contient de nouveaux outils qui permettent de créer automatiquement et facilement des définitions de document fixes, et plus particulièrement :

  • d'identifier automatiquement les champs de texte qui contiennent une région ;
  • d'identifier automatiquement les séparateurs verticaux et horizontaux au sein des tableaux ;
  • d'identifier automatiquement un champ, en cliquant simplement sur un bouton au sein de la région de champ ;
  • d'attribuer automatiquement un nom de champ correspondant au texte d'explication le plus proche ;
  • de reconnaître le texte statique à partir de l'image de la définition de document et de le coller dans les propriétés du champ ;
  • d'ajuster automatiquement les limites du champ.
Détection automatique des champs et des éléments statiques
Comment modifier le nom d'un champ
Amélioration de la configuration des types de données

Nous avons optimisé les paramètres relatifs aux types de données afin de simplifier la création des définitions de document et d'améliorer l'extraction et la vérification des données contenues dans les champs. Les types de données les plus utilisés (texte, date et heure, devise, nombre) sont inclus dans le jeu de types de données préconfigurés. Les formats de types de données les plus utilisés peuvent à leur tour être inclus dans le jeu de formats préconfigurés et être sélectionnés dans la liste sans qu'il faille créer des règles complexes pour la vérification du format.
Types de données d'un champ d'entrée de texte
Création de types de données personnalisés

Description de règles de vérification à l'aide du langage JScript®

Pour décrire une règle de vérification, iI est désormais possible d'utiliser le langage JScript® (en plus du langage VBScript). Vous pouvez ainsi configurer des règles personnalisées pour vérifier les données extraites.
Définition d'une règle à l'aide d'un script
Utilisation de scripts pour créer des règles

Champs d'index

Si l'option Champ d'index est activée dans les propriétés du champ, les valeurs de ce champ peuvent être affichées sous la forme d'une colonne supplémentaire dans la fenêtre de lot de documents. Les documents peuvent être triés en fonction de la valeur de ce champ. Vous pouvez ajouter les valeurs des champs d'index aux noms de fichiers pendant l'exportation de manière de rechercher plus facilement les informations dont vous avez besoin.
Champs d'index
Règles de dénomination des fichiers d'exportation

États supplémentaires des définitions de document

Quand vous ouvrez une définition de document dans l'éditeur de définitions de document, une version locale temporaire de la définition de document est créée automatiquement. Cette version modifiable n'est pas incluse dans le traitement des documents tant qu'elle n'est pas publiée. Cette fonctionnalité vous permet d'organiser votre travail sur les définitions de document quand le projet est scindé.
Modification et publication d'une définition de document

Test de définitions de document sur des lots spéciaux dans l’éditeur de définitions de document

Pour simplifier et accélérer la création des définitions de document, vous pouvez tester les définitions de document modifiables pendant la phase de création sans devoir quitter l'éditeur de définitions de document. Vous pouvez tester une définition de document lors de sa création à partir de l'image utilisée pour la créer. Pour effectuer ces tests, vous pouvez également utiliser des lots de test spéciaux qui ne sont pas utilisés pour le traitement réel des documents.
Test des définitions de document
Lots de documents

Importation d'image

Assemblage automatique de pages sous forme de documents

Le flux entrant d'images en provenance du scanner ou du dossier actif peut être subdivisé automatiquement en documents quand vous utilisez :

  • des formats d'image de plusieurs pages (de type TIFF ou PDF) ;
  • des pages vierges, des pages avec des codes barres ou des codes de correction.
Ajout d'images de pages
Options de prétraitement d'image
Profils d'importation d'image

Les profils d'importation d'image servent à créer des jeux de paramètres préconfigurés pour diverses sources d'importation (scanners ou dossiers). Un profil d'importation est enregistré et il reçoit un nom, que l'opérateur peut ensuite sélectionner dans une liste.
Profils d'importation d'image

Importation d'un simple clic

Un simple clic permet d'importer une image conformément aux paramètres du dernier profil utilisé.
Ajout d'images de pages

Mode d'importation en arrière-plan

L'importation peut également s'effectuer en mode Arrière-plan. Le programme interroge alors le dossier actif à intervalle régulier pour vérifier s'il contient de nouvelles images.

Mode Arrière-plan

Classification, application de la définition de document et reconnaissance

Reconnaissance de texte intégral pour l'exportation vers un fichier PDF indexé

Le programme prend en charge la reconnaissance de documents en texte intégral, suivie d'une exportation vers des fichiers indexés PDF et PDF\A. Cette fonction est particulièrement utile pour archiver des documents non structurés et semi-structurés.
Nouvelles langues de reconnaissance

Kirghiz (OCR/ICR)

Kazakh (OCR/ICR)

Thaï (OCR)

Langues de reconnaissance prises en charge

Nouveaux types de codes barres

Matrix 25, Industrial 25, PostNet.

Types de codes barres pris en charge
Emplacement des caractères corrigés dans les formulaires fixes

Si un caractère entré par erreur a été effacé, il est présenté pendant la vérification à l'opérateur qui peut ainsi le corriger manuellement.
Possibilité de suppression des pages de séparation

Vous pouvez supprimer automatiquement les pages comportant des codes barres ou des codes de correction et les pages vierges du lot.

Options de prétraitement d'image
Possibilité de suppression des pages vierges

Vous pouvez supprimer les pages vierges pendant la reconnaissance.

Propriétés du projet

Vérification des données

Améliorations apportées à l'interface de vérification
  • Mode plein écran.
  • La barre d'état indique le pourcentage actuel des caractères vérifiés.
Vérification des données reconnues
Nouvelles possibilités de configuration de l'interface
  • L'emplacement de la fenêtre contenant l'image de champ peut être modifié.
  • L'échelle de la fenêtre aussi. Une fonction permet en outre de sélectionner automatiquement la meilleure échelle.
  • L'utilisateur peut modifier la taille de la police de caractères.
Vérification des données reconnues
Améliorations apportées à la vérification groupée
  • Un conseil s'affiche, avec le contexte des caractères.
  • La taille et le contraste de la zone adjacente au caractère sont configurables.
Vérification groupée
Améliorations apportées à la vérification de champ
  • Les règles de format peuvent désormais être vérifiées pendant la vérification de champ. L'utilisateur voit une description de l'erreur ainsi qu'une liste de propositions de changement.
  • Un mode spécial permet désormais d'afficher un champ avec la coupe de caractères.
  • Les champs de plusieurs lignes sont pris en charge.
  • Des conseils s'affichent pour les caractères afin de faciliter leur identification (en distinguant la lettre « O » du chiffre « 0 », par exemple).
Vérification de champ
Reconnaissance de champ en temps réel

Pendant la vérification dans la fenêtre de document, toute modification au sein de la région de champ entraîne une nouvelle reconnaissance automatique de la région d'image correspondante. Cette fonctionnalité simplifie et accélère l'extraction des données pour les champs dont les régions n'ont pas été spécifiées avec précision.
Amélioration de l'interface pour la correction des erreurs de règle
  • Chaque règle de la liste d'erreurs de règle est accompagnée d'une référence au champ correspondant. Ces références permettent d'atteindre rapidement les champs susceptibles de contenir des erreurs.
  • La liste d'erreurs de règle peut être ancrée en bas, en haut, à droite ou à gauche de la fenêtre de document.
Validation par règle
Correction des erreurs d'assemblage de document en mode contour de page

Un nouveau mode contour de page est disponible pour les documents en lot. Ce mode est très pratique pour corriger les erreurs d'assemblage de document car il permet à l'utilisateur :

  • d'afficher les contours de page groupés par document ;
  • de voir les erreurs de correspondance entre les valeurs de champs clés et les descriptions d'erreurs d'assemblage ;
  • de corriger les erreurs d'assemblage en déplaçant des pages d'un document à un autre, en faisant glisser les pages d'un endroit à un autre à l'aide de la souris ;
  • de modifier l'échelle des contours de page pour voir les détails (en maintenant la touche CTRL enfoncée et en faisant tourner la molette de défilement).
Assemblage de pages sous forme de documents
Vous pouvez désormais ouvrir les fichiers PDF protégés par mot de passe

Vous pouvez désormais ajouter les fichiers DjVu
Formats graphiques pris en charge

Exportation

Exportation vers Microsoft SharePoint

Vous pouvez désormais configurer l'exportation vers Microsoft SharePoint à l'aide de l'interface du programme.

Exportation de données vers une bibliothèque de documents SharePoint
Exportation d'un simple clic

Si les paramètres d'exportation ont été configurés, vous pouvez exporter un lot de documents d'un simple clic. Cela évite à l'opérateur d'avoir à effectuer des opérations supplémentaires et accélère le processus d'acquisition de documents.

Exportation des données reconnues
Exportation des images de document avec les données

Vous pouvez exporter les images des documents en même temps que les données elles-mêmes.
Règles utiles de dénomination des fichiers obtenus

Lors de l'exportation de données dans un fichier Microsoft SharePoint, les noms de fichier sont générés automatiquement en fonction des règles définies par l'utilisateur. Vous pouvez ajouter les valeurs des champs d'index aux noms des fichiers, la valeur des codes barres des pages de séparation, etc. Plus les noms des fichiers sont évocateurs, plus vous trouverez facilement les informations dont vous avez besoin.
Règles de dénomination des fichiers d'exportation

Nouveaux formats de document et d'image

PDF, PDF/A indexé

Formats graphiques pris en charge
Liaison de champs lors de l'exportation vers une base de données

Lors de la configuration de l'exportation vers une base de données, une interface très conviviale permet de lier des champs. L'utilisateur peut ainsi rapidement associer des champs de document à des champs de base de données.

Exportation vers une base de données
Description d'une exportation à l'aide d'un script

L'utilisateur peut décrire toutes sortes de procédures d'exportation à l'aide des langages de script VBScript et JScript.

Description d'une exportation à l'aide d'un script
Utilisation de scripts pour décrire une exportation
Modification de la résolution des images pendant l'exportation

Il est désormais possible de modifier la résolution des images exportées en fonction des contraintes de stockage.

Configuration de l'exportation de données
Exportation d'image graphique vers un fichier

L'image du document entier, ou un champ d'image graphique isolé, peuvent être exportés vers un fichier graphique distinct.
Suppression des documents exportés du lot

Si vous n'avez pas besoin de stocker les documents exportés dans le lot, vous pouvez les supprimer juste après les avoir exportés.

Exportation des données reconnues
Autres options


Types de documents traités à l'aide d'ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 est une solution logicielle qui permet d'acquérir en une seule opération des données à partir de différents types de documents.

Vous pouvez traiter divers documents en une même opération. Vous pouvez également configurer le programme pour traiter des documents de types différents, par exemple des documents contenant à la fois des sections structurées et des sections semi-structurées. Le type des documents n'affecte que la configuration système, c'est-à-dire la méthode de création des Définitions de document. Il n'affecte pas la nature du travail de l'opérateur.

ABBYY FlexiCapture peut être configuré pour accepter automatiquement les documents suivants en une seule opération :

Documents structurés – formulaires fixes
Les formulaires structurés sont des documents contenant un ensemble de champs d'information marqués, dont le formatage, le nombre et la présentation ne changent pas d'une instance de document à l'autre. Ces documents sont appelés des formulaires fixes. Par exemple, la plupart des questionnaires et des formulaires de demande sont des formulaires fixes. Ils sont généralement distribués sous forme de formulaires vierges et remplis à la main.

Pour identifier un formulaire fixe au sein d'un flux documentaire et en extraire les données, vous devrez créer un modèle fixe unique, qui indiquera au programme l'emplacement des champs contenant des données à extraire.

Les formulaires fixes créés pour répondre aux besoins de l'acquisition automatique peuvent être traités avec une grande efficacité. Ces formulaires sont appelés des formulaires lisibles par machine. Pour plus d'informations sur les exigences de ces formulaires et sur la manière de les créer, consultez la section Création de formulaires lisibles par machine.

Le programme inclut un outil très pratique pour concevoir des formulaires lisibles par machine – ABBYY FormDesigner 9.0 (fourni avec ABBYY FlexiCapture 9.0). Pour plus d'informations sur la création de formulaires à l'aide d'ABBYY FormDesigner 9.0, consultez le guide d'utilisation et les rubriques d'aide.

Vous y trouverez une description des étapes de base de la création d'une définition de document pour les documents non structurés.
Documents semi-structurés – formulaires et documents flexibles
Il s'agit de documents contenant un ensemble de champs d'information dont la conception, le nombre et la présentation peuvent varier significativement dans différentes instances du document. Ces documents sont qualifiés de flexibles. Par exemple, les factures sont des documents flexibles car elles varient souvent en termes de nombre d'éléments et de format. En effet, elles sont envoyées par des entreprises différentes. Toutes les factures ont un numéro et un montant à régler, mais ils peuvent figurer à différents endroits.

Pour identifier les formulaires flexibles et extraire leurs données, ABBYY FlexiCapture 9.0 utilise une présentation flexible (FlexiLayout). Vous pouvez créer une présentation flexible à l'aide d'un module spécial appelé ABBYY FlexiLayout Studio. Pour plus d'informations sur ce module, consultez le guide d'utilisation et les rubriques d'aide.

Le traitement des documents flexibles diffère de celui des formulaires fixes uniquement au niveau de la phase de création et de chargement de la présentation. Pour plus d'informations, consultez la section Création d'une définition de document pour traiter des documents flexibles.
Documents non structurés avec une conception de forme libre.
ABBYY FlexiCapture 9.0 peut servir à traiter des documents non structurés contenant des informations sous une forme libre, par exemple des contrats, des lettres, des commandes et des graphiques. Le programme peut identifier automatiquement les documents non structurés sous forme d'annexes de formulaires fixes ou flexibles. Il peut aussi les identifier à l'aide d'un FlexiLayout, puis les exporter sous forme de fichiers PDF indexés ou de fichiers graphiques. Vous pouvez extraire les champs d'index des documents non structurés, soit automatiquement, à l'aide d'une présentation flexible, soit à l'aide d'une entrée manuelle.

Un cas de figure type de traitement de documents non structurés est celui des archives au format papier, qui doivent être converties au format électronique et pour lesquelles il est nécessaire d'extraire deux ou trois champs pour organiser une recherche rapide reposant sur les attributs.

Pour plus d'informations, consultez la section Traitement de documents non structurés.


Brève description du traitement de document à l'aide d'ABBYY FlexiCapture 9.0

Cette section présente de manière générale le traitement des documents à l'aide d'ABBYY FlexiCapture 9.0.

L'utilisation du programme dans le détail est décrite dans les sections Configuration du programme et Fonctionnement avec un projet configuré.

Présentation de la configuration du programme pour le traitement de documents
Présentation du fonctionnement avec un programme configuré


Brève description des paramètres du programme pour le traitement documentaire

L'administrateur configure le programme pour traiter certains types de documents. Pour préparer le programme au traitement documentaire, vous devez créer :

  1. Un projet

    Un projet contient tous les paramètres de traitement d'un certain type de document : les profils d'importation d'images, les définitions de documents et les lots de documents à traiter.

  2. Une définition de document ou plusieurs

    La phase de création d'une définition de document est la plus importante de la configuration d'un projet. Si vous prévoyez de traiter divers types de documents en une même opération, vous devez créer plusieurs définitions de document pour le même projet.

  3. Profils d'importation d'image

    Les profils d'importation créés servent à accroître le confort de travail de l'opérateur et à rationaliser son travail. Si les profils d'importation ne sont pas configurés, chaque fois que vous ajouterez des images, vous devrez sélectionner la source d'importation et configurer les paramètres. Les profils d'importation permettent d'ajouter des images en cliquant simplement sur un bouton et de basculer facilement d'une source d'importation à une autre.

  4. Un lot de documents

    Les documents soumis au traitement sont ajoutés à des lots. C'est l'utilisateur qui définit comment les documents doivent être affectés à des lots : vous pouvez traiter tous les documents sous la forme d'un même lot ou créer des lots à partir de documents ajoutés à la même date ou à partir d'un lot numérisé en un même passage. Si vous ajoutez des images pour lesquelles il n'y a pas de lots, un lot sera créé automatiquement.

En savoir plus sur la configuration du programme


Travail distribué

ABBYY FlexiCapture 9.0 (Installation distribuée) est un système d'acquisition de données en architecture client/serveur distribuée.

ABBYY FlexiCapture 9.0 (Installation distribuée) inclut plusieurs stations et serveurs. Chaque station est responsable de certaines routines de traitement. Les serveurs assurent le fonctionnement de l'intégralité de l'application complexe, connectent les stations et répartit la charge de travail entre les stations. Avant que les documents puissent être traités, les serveurs doivent être configurés.

Voici une brève présentation des composants :

  • Console d'administration et de suivi

    Après avoir installé le système, vous devez établir une connexion à la base de données et accorder les droits appropriés aux opérateurs. Ceci est effectué sur la console d'administration et de suivi par l'opérateur disposant des droits Administrateur.

    La console d'administration et de suivi est une interface Web contrôlant le serveur d'application. Il est possible d'accéder à la console depuis n'importe quel ordinateur connecté au serveur d'application via http:\\<ServeurApplication>\FlexiCapture, où <ServeurApplication> est le nom de l'ordinateur sur lequel le serveur d'application est installé.

    Pendant le traitement de documents, la console peut être utilisée pour obtenir des statistiques et pour générer des rapports.

  • Station de configuration de projets

    L'étape suivante est la création et la configuration d'un projet. Pour ce faire, l'opérateur de la station crée des définitions de document et des type de lots et définit l'ordre de traitement. Dès que le système est configuré, le projet est téléchargé sur le serveur d'application et le traitement des documents peut commencer.

  • Station de numérisation

    La station de numérisation peut être la première station où les documents à traiter arrivent. L'opérateur de cette station crée des lots et y ajoute des images de document. Si nécessaire, les images ajoutées peuvent être modifiées. Ensuite, le lot est transféré vers ABBYY FlexiCapture pour la suite du traitement.

    L'utilisation d'une station de numérisation n'est pas nécessaire lorsque les images à traiter proviennent d'un dossier actif.

  • Station de traitement

    La station de traitement fonctionne sans assistance et effectue les opérations suivantes : l'obtention des images depuis les dossiers actifs, l'application des définitions de documents, la reconnaissance de documents, la validation par règle et l'exportation des résultats vers les destinations définies par l'utilisateur.

  • Station de vérification de données

    La finalité de cette station est la vérification des données acquises. L'opérateur de cette station relit d'abord les caractères mal reconnus en les affichant par groupe puis par champ. Ensuite, le lot est transféré vers la station de vérification. En cas d'erreur de traitement, l'opérateur de la station de vérification de données peut envoyer le lot ou les documents vers la file Exceptions où ils sont traités par le chef-opérateur de vérification.

  • Station de vérification

    Cette station effectue des vérifications plus complexes que la station de vérification de données. En plus des vérifications de données, la station peut traiter les lots ou documents problématiques, corriger les erreurs d'assemblage, vérifier les règles et vérifier l'intégrité du lot.

  • Serveur de traitement

    Le serveur de traitement répartit la charge de travail entre les stations de traitement. Un moniteur de serveur de traitement est installé en même temps que le serveur : il sert à surveiller les opérations du serveur et à définir les priorités des tâches.

  • Serveur d'application

    Le serveur d'application connecte les stations entre elles et assure leur fonctionnement. Avant d'installer le serveur, assurez-vous que tous les composants requis pour un fonctionnement normal du serveur sont installés.

  • Serveur de base de données

    Le serveur de base de données stocke les données requises pour le opérations de traitement : les informations concernant les opérateurs, les lots, les événements, etc. Si le système comporte au maximum 50 stations de vérification et que 100 000 documents au maximum sont traités quotidiennement, vous pouvez utiliser Microsoft SQL Server Express Edition. Pour des volumes plus importants, l'utilisation de la version complète de Microsoft SQL Server et/ou d'un dossier de stockage de fichiers est recommandée.

  • Dossier de stockage de fichiers

    Les fichiers du projet peuvent être stockés dans une base de données ou dans un dossier de stockage de fichiers séparé, qui est un dossier normal situé sur l'ordinateur où le serveur d'application est installé. Un dossier de stockage de fichiers peut être configuré sur la console d'administration et de suivi.

  • Serveur de protection

    Une clé de protection est requise pour un bon fonctionnement du système. Le gestionnaire de licences ABBYY FlexiCapture 9.0 est une application dédiée à la gestion des clés de protection

puce | Installation des stations ABBYY FlexiCapture 9.0
puce | Configuration du serveur et des stations de traitement
puce | Architecture et principes de base d'ABBYY FlexiCapture 9.0
puce | Configuration du serveur d'application


Création d'un projet

Pour traiter différents documents dans un même projet, ce projet doit comporter plusieurs définitions de documents. Si les flux documentaires ne se coupent pas et que leurs paramètres de traitement diffèrent considérablement, vous pouvez créer des projets distincts.

Pour commencer, vous devez créer au moins un projet.

Pour créer un nouveau projet, lancez la station de configuration de projet puis sélectionnez Fichier>Nouveau projet…

En savoir plus sur la création d'un projet


Présentation de la création d'une Définition de document

La création d'une Définition de document est l'aspect le plus délicat de la configuration d'un projet. Elle détermine la qualité des données obtenues au terme du traitement.

Une Définition de document décrit l'emplacement des éléments d'un document et indique les champs à utiliser lors de l'extraction des données.

Pour créer une Définition de document, lancez l'assistant de définition de document :

  1. Dans la fenêtre principale de la station de configuration de projet, sélectionnez Projet>Définitions de document…
  2. Dans la boîte de dialogue Définitions de document, cliquez sur le bouton Nouveau…
  3. Suivez les instructions de l'assistant de définition de document.

Les principales étapes de la création d'une Définition de document dépendent du type des documents à traiter.

Principales étapes de création d'une Définition de document pour des formulaires fixes
  1. Créez une nouvelle Définition de document à l'aide de l'assistant de définition de document. L'assistant lancé, ouvrez l'image de la page de document qui servira pour le marquage de Définition de document.
  2. Marquez les éléments statiques, ancres et identificateurs, en configurant leurs propriétés. Les éléments statiques sont destinés à l'association et à l'identification de la Définition de document correcte. En général, les éléments statiques sont détectés automatiquement et se voient attribuer des propriétés par défaut.
  3. Marquez les champs de l'image. Ces champs sont utilisés pour l'extraction des données.
  4. Configurez les propriétés des champs. Les propriétés des champs affectent la qualité de la reconnaissance et déterminent si les valeurs des champs seront exportées et envoyées à l'opérateur pour vérification. Elles spécifient les types de données et la plage de valeurs d'un champ.
  5. Pour créer des Définitions de documents pour des documents de plusieurs pages : ajoutez les pages et répétez toutes les étapes pour chacune de ces pages.
  6. Configurez l'exportation des données.
  7. Si nécessaire, vous pouvez configurer la méthode d'affichage dans la fenêtre de document, la vérification par règle des données, etc.
  8. Testez une Définition de document à l'aide des images de plusieurs documents.

Remarque : si vous avez créé des formulaires lisibles par machine avec ABBYY FormDesigner, vous n'avez qu'à importer un fichier portant une extension *.xfd au lieu de suivre les trois premières étapes. Une page d'image avec un marquage prêt à l'emploi s'ouvre alors (ou des images de plusieurs pages si vous avez utilisé ABBYY FormDesigner pour créer un formulaire de plusieurs pages). Pour plus d'informations, consultez la section Importation d'une Définition de document pour des formulaires créés avec ABBYY FormDesigner.

Principales étapes à suivre pour créer une Définition de document pour des documents flexibles
  1. Créez une description flexible (un fichier portant une extension *.afl extension) avec ABBYY FlexiLayout Studio. Pour plus d'informations, consultez les rubriques d'aide d'ABBYY FlexiLayout Studio.
  2. Créez une nouvelle Définition de document à l'aide de l'assistant de définition de document. L'assistant étant actif, ouvrez une image de page de document, et joignez-y une description flexible (le fichier *.afl que vous avez créé). Au terme de la procédure de l'assistant, le marquage de champ est présent sur l'image.
  3. Configurez les propriétés des champs. Suivez la procédure permettant de configurer les propriétés de Définition de document pour un formulaire fixe.
  4. Configurez l'exportation des données.
  5. Si nécessaire, vous pouvez configurer la méthode d'affichage dans la fenêtre de document, la vérification par règle des données, etc.
  6. Testez une Définition de document à l'aide des images de plusieurs documents.

Pour des documents de types mixtes qui contiennent des pages avec des formulaires fixes et des sections semi-structurées, vous pouvez joindre une description flexible en tant que section de Définition de document. Commencez par créer une Définition de document à partir d'une section quelconque (flexible ou fixe), puis ajoutez une nouvelle section d'un type différent.

Vous pouvez traiter des documents comprenant des types différents en une même opération : pour un même projet, vous pouvez créer des Définitions de document pour des formulaires fixes et des documents flexibles, et des Définitions de document pour des documents de types mixtes. Le programme sélectionne automatiquement la Définition de document correspondante.

Pour traiter des documents comportant des annexes, créez une Définition de document et activez l'option Activer les pages d'annexe dans les propriétés de la Définition de document. Consultez la section Création de modèles pour des documents avec des annexes.

En savoir plus sur la création de Définitions de document


Création de types de lots

Les documents sont traités par lot. Les lots sont créés lorsque les documents sont importés ou numérisés. Dans le même temps, chaque lot se voit attribuer un type.

Les types de lots prédéterminent les paramètres de traitement de documents suivants :

  • prétraitement d'image
  • association de définitions de documents avec les documents correspondants
  • vérification de l'intégrité du lot
  • exportation de lot par défaut
  • traitement par lot
Types de lots
Création de lots de documents


Création de profils d'importation

Le traitement de document commence par l'ajout de nouvelles images au lot. Ces images peuvent être des documents papier à numériser ou des images électroniques à importer.

Les images peuvent être ajoutées :

  • automatiquement sur les stations de traitement

    Pour automatiser l'importation d'images, il vous faut créer un profil d'importation d'images sur la station de configuration de projets et spécifier les dossiers actifs à utiliser. Les images seront automatiquement importées depuis les dossiers actifs.

  • manuellement par les opérateurs des stations de numérisation. Pour numériser des pages, l'opérateur d'une station de numérisation doit créer des profils de numérisation.

    Si les images sont souvent obtenues depuis différentes sources, il est possible de créer plusieurs profils d'importation parmi lesquels l'opérateur pourra ensuite sélectionner le profil approprié pour chaque source.

Sur la station de configuration de projets, vous pouvez déboguer les définitions de document en créant des lots, en y ajoutant des images de document et en les traitant. Le processus d'ajout d'images peut aussi être automatisé : l'opérateur de la station de configuration de projets peut créer un profil d'importation d'images qui utilise un scanner.

puce Profils d'importation d'images


Création de lots de documents

Les documents à traiter sont placés dans des lots. Les principes de regroupement de documents en lots sont déterminés par l'utilisateur. Par exemple, l'utilisateur peut choisir de traiter tous les documents comme un seul lot ou de grouper tous les documents importés le même jour ou numérisés en une fois.

Les lots peuvent être créés automatiquement lorsque les images sont importées depuis les dossiers actifs ou numérisées dans la station de numérisation. Pour créer un lot manuellement, cliquez avec le bouton droit de la souris dans la liste de lots de la fenêtre principale et sélectionnez Nouveau lot… depuis le menu raccourcis.

Lorsqu'un lot est créé, son type est spécifié, ce qui définit l'ordre dans lequel le lot va être traité.

En savoir plus sur la création de lots de documents


Présentation du travail de l'opérateur avec un programme configuré

L'opérateur utilise un programme préconfiguré pour traiter certains types de documents. Le traitement documentaire est le même pour tous les types de documents et il inclut les phases suivantes :

  1. Ajout d'images

    Le traitement de document démarre lors de l'acquisition d'images, que ce soit en numérisant et en ajoutant des images manuellement ou en utilisant des profils de numérisation. Toutes les actions qui doivent être exécutées pour acquérir des images sont réalisées par l'opérateur de la station de numérisation.

  2. Démarrage du processus de reconnaissance

    La reconnaissance est effectuée automatiquement dans la station de traitement : le programme sélectionne la définition de document appropriée selon les positions des éléments statiques, applique la définition de document et reconnaît les données dans les champs spécifiés dans la définition du document.

  3. Vérification

    Vérification – le processus de vérification des données – est la phase qui nécessite le plus de travail de la part de l'opérateur. Elle comprend :

    • La vérification de l'assemblage de documents – vérification de l'assemblage correcte des pages du document ;
    • La vérification du groupe – une vérification visuelle des groupes de caractères reconnus de manière identique ;
    • Vérification des champs– une vérification des caractères reconnus incertains dans le contexte de champs avec des plages de valeurs connues ;
    • Validation des règles– vérification des erreurs de règles.
    • Vérification de l'intégrité des lots : démarrer les scripts d'intégrité et corriger n'importe quelle erreur.

    Les documents peuvent être vérifiés sur deux stations.

    La vérification de base est effectuée sur la station de vérification de données, où seuls les modes de vérification de champs et de groupes sont disponibles pour l'opérateur.

    Une vérification plus complexe est effectuée sur la station de vérification, où à part la vérification de données, l'opérateur de vérification et le chef-opérateur de vérification peut vérifier l'assemblage de document et corriger les erreurs de règles.

  4. Exportation de données

    Les données sont exportées automatiquement sur la station de traitement conformément aux paramètres fournis dans la définition de document. Un lot est exporté soit tout de suite après son traitement ou après qu'il a été confirmé par le chef-opérateur de vérification (les paramètres correspondants sont effectués pour chaque type de lot).

En savoir plus sur le travail des opérateurs avec les projets configurés


Opérateurs d'ABBYY FlexiCapture 9.0

L'opérateur est un utilisateur d'ABBYY FlexiCapture 9.0 pour qui un rôle de traitement de documents et les droits correspondants ont été définis. Les droits d'accès des opérateurs diffèrent selon leurs domaines de responsabilité. Les droits d'accès d'un opérateur dépendent du rôle de l'opérateur.

Les rôles suivants sont disponibles sous ABBYY FlexiCapture 9.0 (chaque rôle est configuré pour le projet en cours :

  • Opérateur de numérisation - un opérateur endossant ce rôle peut travailler sur une station de numérisation
  • Opérateur de vérification de données - un opérateur endossant ce rôle peut travailler sur une station de vérification de données et sur une station de vérification
  • Opérateur de vérification - un opérateur endossant ce rôle peut travailler sur une station de vérification (seules les vérifications de données, les erreurs d'assemblage et les validations par règle sont accessibles à l'opérateur)
  • Chef-opérateur de vérification - un opérateur endossant ce rôle peut travailler sur une station de vérification (l'intégralité des fonctionnalités de la station est accessible à l'opérateur)
  • Opérateur de suivi - un opérateur endossant ce rôle peut travailler sur la console d'administration et de suivi (toutes les fonctionnalités lui sont accessibles sauf la configuration)
  • Éditeur de configuration de projets - un opérateur endossant ce rôle peut travailler sur une station de configuration de projets
  • Administrateur - un opérateur endossant ce rôle peut travailler sur la console d'administration et de suivi (l'intégralité des fonctionnalités de la console sont accessibles à l'administrateur). De plus, l'administrateur peut accéder à toute station du système et les droits Administrateur s'appliquent à tous les projets téléchargés vers le serveur d'application et non aux seuls projets en cours.

Un rôle définit l'ensemble des stations auxquelles un opérateur de ce rôle peut accéder, ainsi que les files à partir desquelles l'opérateur peut obtenir des tâches pendant le traitement de documents.

Les rôles de l'administrateur et de l'opérateur de suivi s'appliquent à l'intégralité du système. Les rôles des autres opérateurs ne s'appliquent qu'aux projets particuliers. De plus, les rôles de l'opérateur de numérisation, de l'opérateur de vérification de données et du chef-opérateur de vérification octroient différents droits selon les types de lots. Par conséquent, un utilisateur peut endosser simultanément les rôles suivants :

  • Projet A : Opérateur de configuration de projets
  • Projet B :
    • Lots de type 1 : Chef-opérateur de vérification
    • Lots de type 2 : Opérateur de vérification de données


Ajout d'images

Généralement, les images sont ajoutées sur la station de numérisation (pour plus d'informations, consultez l'aide de la station de numérisation). Néanmoins, le chef-opérateur de vérification peut également ajouter des images sur sa station.

Pour ajouter des images sur la station de vérification, sélectionnez le lot auquel ajouter les images ou créez un nouveau lot. Les images peuvent être ajoutées de deux manières :

  • par numérisation (sélectionnez Fichier>Numériser des images…Numériser des images…
  • depuis des fichiers image (sélectionnez Fichier>Charger des images…Charger des images…

Pour déboguer les définitions de document, vous pouvez ajouter des images sur la station de configuration de projets.

puce Ajout d'images de pages


Démarrage du processus de reconnaissance, analyse et application d'une définition de document

Les documents sont généralement reconnus, analysés et les définitions de document sont appliquées automatiquement. Cependant, ces opérations peuvent être démarrées manuellement dans la station de vérification et dans la station de configuration de projet.

Pour reconnaître les images, sélectionnez Reconnaissance>Reconnaître à partir du menu principal.

Pour analyser les images, sélectionnez Reconnaissance>Analyser à partir du menu principal. Si une définition de document correspond à un document, la page et son document auront des noms correspondants. Si une définition de document dans le projet ne correspond pas à une image, la page est marquée comme inconnue.

Le système vous permet également d'appliquer une définition de document particulière à une page ou au document en entier. Dans la plupart des cas, une définition de document correctement créée sera mise en correspondance avec ses pages automatiquement, mais dans certains cas cette opération devra peut-être être effectuée manuellement. Pour faire correspondre une définition de document, sélectionnez la page ou le document avec lequel vous souhaitez établir la correspondance de la définition de document, puis sélectionnez Reconnaissance>Associer une définition de document… à partir du menu principal.

En savoir plus sur la reconnaissance


Vérification

La vérification consiste à s'assurer que les données ont été reconnues, que les pages ont été assemblées en documents correctement et que les règles n'ont pas généré d'erreurs. La vérification est effectuée sur la station de vérification de données (où la précision de la reconnaissance est vérifiée) et sur la station de vérification (où tout type de vérification peut être effectué). La vérification est effectué pour les tâches.

La vérification démarre une fois qu'une tâche est arrivée à la station. La vérification commence par la vérification de groupe suivie de la vérification de champ. Si une définition de document ne comporte aucun champ inclus pendant la vérification de groupe ou de champ, la phase de vérification correspondante sera omise.

Pour les documents multipages, vous devez corriger les possibles erreurs d'assemblage. Les pages sont assemblées en documents automatiquement. Les documents présentant des erreurs d'assemblage sont marqués par le symbole suivant [image]. Une description de l'erreur est affichée en lettres rouges sous le nom de la définition de document. Lors de la création d'une définition de document, vous devez configurer la règle d'assemblage de document : la séquence et le nombre de répétitions de page. Vous pouvez également configurer la vérification de l'assemblage à partir des valeurs des champs clés : dans ce cas, les champs clés doivent avoir la même valeur sur toutes les pages d'un même document. Dans le cas contraire, le message correspondant s'affiche et les valeurs des champs clés sont mises en surbrillance en rouge. Les erreurs d'assemblage peuvent être corrigées très facilement en mode contour de page, qui permet à l'utilisateur de bien visualiser les images de page et les différents documents dont elles font partie.

Pendant la vérification groupée, les groupes de caractères reconnus de manière identique sont soumis à la vérification. Le travail de l'opérateur consiste à identifier les caractères différents qui n'ont pas été reconnus correctement. Il doit ensuite corriger les valeurs, après avoir affiché l'image du champ contenant les caractères en question. S'il n'est possible de corriger les caractères, vous pouvez les marquer comme discutables.

Lors de la vérification de champ, les champs ayant une plage de valeurs connues sont soumis à la vérification. Le travail de l'opérateur consiste à vérifier les caractères reconnus sans certitude dans le contexte du champ entier. Il y a deux modes de vérification de champs : un mode d'affichage monochamp avec des coupes de caractères et un mode d'affichage multichamp, qui affiche des champs de même type.

Les règles qui n'ont pas été exécutées sont signalées : par un indicateur jaune [image] (avertissement) ou rouge [image] (erreur). L'opérateur doit vérifier les champs présentant des erreurs de règle et, si possible, corriger les valeurs.

La vérification des données est également effectuée dans la fenêtre de document qui s'ouvre quand vous double-cliquez sur le nom d'un document ou d'une page. Cette fenêtre n'affiche pas les champs distincts mais le document entier. Elle affiche également les caractères reconnus sans certitude, les erreurs de règle, etc.

En savoir plus sur la vérification


Exportation

Les données sont automatiquement exportées. Si nécessaire, l'opérateur de vérification peut créer une file de confirmation des exportations séparée. Dans ce cas, l'exportation s'effectue une fois la confirmation obtenue. Les données sont exportées en fonction des paramètres fournis dans la définition du document.

Pour exporter des documents manuellement, sélectionnez l'un des éléments dans le menu Fichier>Exporter vers :

  • Données vers fichiers… - pour exporter des données vers des fichiers
  • Images vers fichiers… - pour exporter des images vers des fichiers
  • Base de données… - pour exporter un document vers la base de données

Modifiez les paramètres d'exportation par défaut si nécessaire et exportez les données.

puce En savoir plus sur l'exportation


Installing and running the program

This section contains basic information about installing, protecting, and running ABBYY FlexiCapture 9.0. It also covers the system requirements for installation.

Protection of the program
License Manager protection key management program
Software and hardware requirements
Installing ABBYY FlexiCapture 9.0
Running the program


Types de protection

Pour utiliser ABBYY FlexiCapture 9.0, vous devez disposer d'une clé de protection valide.

ABBYY FlexiCapture 9.0 peut inclure l'un des types de clés de protection suivants :

  • clé de protection matérielle
  • clé de protection logicielle

Clé de protection matérielle

Il s'agit d'un dongle à connecter sur le port USB de votre ordinateur (dongle USB).

Pour qu'ABBYY FlexiCapture 9.0 Professional fonctionne avec une clé de protection matérielle, vous devez installer le pilote correspondant à partir du programme d'installation. Pour que le programme fonctionne, votre clé de protection matérielle doit être connectée en permanence.

La clé de protection matérielle stocke les paramètres de votre licence.

Une clé de protection matérielle vide peut être activée à distance, à l'aide du seul numéro de série de votre licence. Cette opération s'effectue dans le Gestionnaire de licences, qui contacte le serveur d'activation par Internet, effectue une requête des paramètres d'un numéro de série, puis les enregistre dans la clé.

Important !Vous devez être en mesure d'exécuter le service SmartCard standard pour utiliser la clé de protection matérielle.

Clé de protection logicielle

Il s'agit d'un fichier de licence.

Pour qu'ABBYY FlexiCapture 9.0 fonctionne avec une clé de protection matérielle, il faut que le fichier de licence soit activé sur le serveur d'activation ABBYY. Vous pouvez activer votre fichier de licence à partir du Gestionnaire de licences.

Les informations requises pour activer votre fichier de licence sont envoyées à ABBYY sous forme de code (ID de produit), code généré à partir des informations relatives à l'ordinateur sur lequel ABBYY FlexiCapture 9.0 est installé. Aucune information personnelle n'est utilisée pour générer l'ID de produit, et ce code ne peut pas être utilisé pour identifier l'utilisateur.

Méthodes d'activation :

  • Via Internet
    L'activation via Internet s'effectue automatiquement et ne prend que quelques secondes. Cette méthode d'activation requiert une connexion Internet.
  • Par e-mail
    Si vous choisissez cette méthode d'activation, une demande d'activation par courrier électronique sera automatiquement générée. Envoyez ce courrier électronique à l'adresse indiquée. Pour obtenir une réponse rapide du système de messagerie automatisé, veillez à ne pas modifier l'objet ni le corps du message électronique.

Pour l'activation via Internet, aucune autre opération n'est requise. Dans le cas de l'activation par courrier électronique, le robot d'activation doit vous envoyer un fichier activé. Enregistrez ce fichier sur votre disque dur, exécutez le Gestionnaire de licences et indiquez le chemin d'accès du fichier enregistré dans l'assistant d'activation.

Répétition de l'activation

Vous pouvez réinstaller ABBYY FlexiCapture 9.0 autant de fois que nécessaire sur l'ordinateur sur lequel il a été activé. Toutefois, si vous installez des mises à jour importantes, que vous formatez le disque dur ou que vous réinstallez le système d'exploitation, vous pourrez avoir à réactiver le produit.

Le serveur d'activation enregistre dans un journal le nombre de fois que chaque numéro de série a été activé. Au-delà d'un certain seuil, le numéro de de série est bloqué et il ne peut plus être activé.

Vous pouvez désactiver une licence activée pour l'utiliser sur un autre ordinateur. Quand vous désactivez une licence, le serveur d'activation décrémente le compteur d'activation du numéro de licence correspondant d'une unité.

Important ! Vous ne pouvez utiliser le programme activé que sur l'ordinateur sur lequel l'ID de produit a été généré. Pour déplacer le programme sur un autre ordinateur, désactivez d'abord votre licence.


Gestionnaire de licences

Le Gestionnaire de licences est un utilitaire qui sert à gérer les clés de protection et à collecter des informations sur l'état des licences ABBYY FlexiCapture.

Avertissement ! Le Gestionnaire de licences est un utilitaire d'administration. Pour l'utiliser, il faut disposer de droits d'administrateur local.

Le Gestionnaire de licences s'installe avec le serveur d'application.

Pour lancer l'utilitaire Gestionnaire de licences :

  • Cliquez sur Démarrer>Programmes>Serveurs d'ABBYY FlexiCapture 9.0>Outils puis sélectionnez Gestionnaire de licences ABBYY FlexiCapture 9.0.

Gestion des licences

Ajout d'une nouvelle licence

Dans la fenêtre principale Gestionnaire de licences ABBYY FlexiCapture 9.0, cliquez sur Sélectionner... Dans la boîte de dialogue Licences, cliquez sur Activer... Saisissez votre nouveau numéro de série puis cliquez sur Suivant. Ensuite, sélectionnez une méthode d'activation de licence et activez votre licence. La nouvelle licence (il peut y en avoir plusieurs) apparaît dans la fenêtre principale du Gestionnaire de licences.

Mise à jour d'une licence

Pour mettre à jour une licence, accédez à la liste des licences en cliquant sur le bouton Sélectionner... de la fenêtre principale du Gestionnaire de licences. Sélectionnez la licence à mettre à jour puis cliquez sur Mettre à jour la licence... Vous devrez également activer votre licence par le biais d'Internet ou d'un courrier électronique. Suivez les instructions affichées à l'écran.

Paramètres de licence

Dans le Gestionnaire de licences, vous pouvez afficher les paramètres de vos licences . Sélectionnez une licence dans la liste puis cliquez sur Paramètres de licence... Les paramètres de la licence actuelle sont affichés sous forme d'aperçu rapide dans la fenêtre principale de l'application.


Paramètres de licence

Chaque licence est pourvue de son propre numéro de série. Une licence inclut un ensemble de paramètres qui détermine si l'utilisateur dispose des droits qui permettent d'effectuer certaines opérations de traitement de documents.

Paramètres de licence :

  • Général - numéro de série, méthode de licence, disponibilité d'une machine virtuelle
  • Objectif de la licence – type de licence (logicielle ou matérielle), capacité à fournir des services de traitement de documents
  • Stations de travail, Outils - restrictions sur le nombre de stations et sur les outils de développement (FlexiLayout Studio, FormDesigner)
  • Heure, Performance – restrictions concernant l'utilisation
  • Traitement – paramètres de traitement de documents supplémentaires : utilisation des structures FlexiLayout et de langues de reconnaissance supplémentaires
  • Composants personnalisés – utilisation de composants développés par l'utilisateur
  • Importation – options d'importation supplémentaires
  • Exportation – options d'exportation supplémentaires


Configuration matérielle et logicielle requise

Configuration matérielle

  1. Processeur Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™, AMD K6/Turion™/Athlon™/Duron™/Sempron™ cadencé à 2 GHz ou plus
  2. 512 Mo de RAM pour chaque cœur de processeur, mais pas moins d'1 Go
  3. Espace disponible
    • Stations : 1 Go, desquels 800 Mo sont nécessaires l'installation des stations
    • Serveur d'application : 50 Mo
    • Serveur de traitement : 50 Mo
    • Serveur de base de données : 2 Go (si vous utilisez Microsoft SQL Server Express Edition)
  4. Un scanner TWAIN, WIA ou ISIS
  5. Une connexion à Internet pour activer votre numéro de série, un port USB pour la clé de protection matérielle
  6. Une carte graphique et un écran compatibles 1024×768 au minimum
  7. Clavier, souris ou autre dispositif de pointage

Configuration logicielle

Serveurs :

  1. Système d'exploitation :
    • Windows Server 2003 SP2
    • Windows Server 2008 SP2
    • Windows Server 2008 R2

    Si vous utilisez une interface localisée, votre système d'exploitation doit prendre en charge la langue correspondante.

  2. Internet Information Server 6, 7 ou 7.5 (pour le serveur d'application)
  3. .Net Framework 2.0 ou ultérieur
  4. Crystal Reports Basic Runtime pour Visual Studio 2008
  5. Adobe Acrobat Reader 9
  6. Serveur de base de données : Microsoft SQL Server 2005 ou 2008

Stations

  1. Système d'exploitation :
    • Windows XP SP2
    • Windows Vista SP2
    • Windows 7

    Les stations peuvent être installées sur des ordinateurs fonctionnant sous Windows Server 2008 SP2 ou Windows Server 2008 R2 à condition que le composant Desktop Experience soit installé.

    Si vous utilisez une interface localisée, votre système d'exploitation doit prendre en charge la langue correspondante.

    L'utilisation de la police Arial Unicode MS est recommandée. Les autres polices peuvent ne pas afficher correctement les caractères chinois, japonais et coréens.

  2. Microsoft Internet Explorer 6, 7 ou 8 (en mode compatibilité) pour la station de suivi.

Les serveurs et les stations doivent se trouver dans le même répertoire Active Directory.


Installation d'ABBYY FlexiCapture 9.0

Avant d'installer ABBYY FlexiCapture 9.0, nous vous recommandons de fermer toutes les autres applications (par ex. Microsoft Outlook, Microsoft Word, etc.).

Important ! Le programme d'installation copie des fichiers temporaires dans le dossier défini par la variable d'environnement %temp%.Si vous rencontrez des problèmes d'installation, assurez-vous que ce dossier est accessible et qu'il y a suffisamment d'espace pour stocker les fichiers temporaires.

L'installation d'ABBYY FlexiCapture 9.0 comprend les étapes suivantes :

  1. Installation des serveurs.
  2. Installation des stations.

Une fois que l'installation est terminée, configurez le système si nécessaire.

puce | Installation des serveurs ABBYY FlexiCapture 9.0
puce | Installation des stations ABBYY FlexiCapture 9.0
puce | Configuration du serveur et des stations de traitement


Installation des serveurs ABBYY FlexiCapture 9.0

Les serveurs sont installés à partir du disque d'ABBYY FlexiCapture 9.0 via le menu de configuration. Les serveurs suivants doivent être installés :

  • Serveur d'application
  • Serveur de base de données
  • Serveur de traitement
  • Serveur de protection

Les instructions d'installation pour chaque serveur sont fournies ci-dessous.

Serveur d'application

Avant d'installer le serveur d'application, assurez-vous que les composants suivants sont installés :

  • Net FrameWork 2.0 ou ultérieur
  • S ervices Internet (IIS) 6.0 ou 7.0 (installés comme composant Windows )
  • Crystal Reports
  • Microsoft SQL Server (avec l'option Mode mixte sélectionnée lors de l'installation du serveur SQL)

Si ces composants ne sont pas installés sur votre ordinateur, ils peuvent tous (à l'exception des Services Internet IIS) être installés à partir du disque d'ABBYY FlexiCapture 9.0 (Exécution automatique, 2. Installation distribuée>1. Installer des composants externes).

Si tous les composants mentionnés ci-dessus sont déjà installés, vous pouvez commencer à installer le serveur d'application. Dans le menu Exécution automatique , sélectionnez 2. Installation distribuée>2. Installer les serveurs et suivez les instructions de l'assistant d'installation. Dans la boîte de dialogue Installation personnalisée, sélectionnez Serveur d'application.

Remarque : Pour copier le programme d'installation des stations sur le serveur, dans la boîte de dialogue Installation personnalisée, sélectionnez l'option Programme d'installation des stations. Dans ce cas, vous aurez la possibilité d'installer les stations directement à partir du serveur plutôt qu'à partir du disque d'installation.

Dès que le serveur d'application est installé, la console d'administration et de suivi se lance automatiquement et vous pouvez y configurer une connexion à la base de données et accorder des droits aux opérateurs.

Serveur de base de données

Le serveur de base de données stocke les données requises pour les opérations de traitement de documents : les informations concernant les opérateurs, les lots, les événements, etc. Si le système comporte au maximum 50 stations de vérification et que 100 000 documents au maximum sont traités quotidiennement, vous pouvez utiliser Microsoft SQL Server Express Edition. Pour des volumes plus importants, l'utilisation de la version complète de Microsoft SQL Server et/ou d'un dossier de stockage de fichiers est recommandée.

Microsoft SQL Server Express Edition peut être installé à partir du disque d'ABBYY FlexiCapture 9.0 : dans le menu Exécution automatique, sélectionnez 2. Installation distribuée>1. Installer des composants externes.

Serveur de traitement

Le serveur de traitement répartit la charge de travail entre les stations de traitement. Le moniteur de serveur de traitement est installé avec le serveur et sert à surveiller les opérations du serveur et à définir les priorités des tâches.

Pour installer le serveur de traitement, dans le menu Exécution automatique , sélectionnez 2. Installation distribuée>2. Installer les serveurs et suivez les instructions de l'assistant d'installation. Dans la boîte de dialogue Installation personnalisée, sélectionnez Serveur de traitement.

Dès que le serveur de traitement est installé, vous devez le configurer (c'est-à-dire démarrer le serveur, ajouter les stations de traitement, etc.).

Serveur de protection

Le système requiert une clé de protection valide qui doit être activée sur le serveur d'activation d'ABBYY. Ceci peut être effectué via l'application Gestionnaire de licences qui se lance automatiquement dès que vous avez installé le serveur de protection.

Pour installer le serveur de protection, dans le menu Exécution automatique, sélectionnez 2. Installation distribuée>2. Installer les serveurs et suivez les instructions de l'assistant d'installation. Dans la boîte de dialogue Installation personnalisée, sélectionnez Serveur de protection.

L e Gestionnaire de licences vous permet de gérer vos licences, c'est-à-dire d'ajouter, d'activer et de sélectionner des licences et d' afficher leurs paramètres.


Installation des stations ABBYY FlexiCapture 9.0

Les stations sont installées à partir du disque d'ABBYY FlexiCapture 9.0 via le menu de configuration. Vous pouvez également installer les stations depuis le serveur si la station installée a été copiée sur le serveur lors de l'installation du serveur d'application.

Les stations suivantes doivent être installées :

  • Station de configuration de projets

  • Station de numérisation

  • Station de vérification de données

  • Station de vérification

  • Station de traitement

Les stations de numérisation et de vérification de données peuvent fonctionner dans un réseau local mais à distance via Internet. L’authentification s’effectue via un identifiant et un mot de passe.


Installation d'ABBYY FlexiCapture 9.0 dans un réseau local

ABBYY FlexiCapture 9.0 peut être installé et utilisé sur un réseau local.

Pour pouvoir installer les stations à partir du serveur, vous devez sélectionner l'option Programme d'installation des stations lorsque vous installez le serveur d'application. Les fichiers nécessaires à l'installation des stations à partir du serveur seront copiés sur le serveur.

ABBYY FlexiCapture 9.0 peut être facilement déployé sur plusieurs ordinateurs en réseau local. L'installation réseau s'effectue en deux phases : premièrement, les fichiers de la station d'ABBYY FlexiCapture 9.0 sont copiés sur le serveur lors de l'installation du serveur d'application ; ensuite, les stations peuvent être installées à partir du serveur via le réseau local.

Pour obtenir des instructions détaillées, consultez le Guide de l'administrateur, accessible dans le menu Exécution automatique.


Changement de mode d'installation, réparation et suppression d'ABBYY FlexiCapture 9.0

Réparation et suppression d'ABBYY FlexiCapture 9.0

Pour réparer des fichiers corrompus ou supprimés :

  1. Sélectionnez Démarrer > Panneau de configuration > Ajout/suppression de programmes, sélectionnez Serveurs d'ABBYY FlexiCapture 9.0 ou Stations d'ABBYY FlexiCapture 9.0 à partir de la liste des programmes installés puis cliquez sur Modifier.

  2. Sélectionnez l'élément Réparer, puis cliquez sur Suivant.

Pour supprimer ABBYY FlexiCapture 9.0 de votre ordinateur :

  1. Sélectionnez Démarrer > Panneau de configuration > Ajout/Suppression de programmes, puis sélectionnez Serveurs d'ABBYY FlexiCapture 9.0 ou Stations d'ABBYY FlexiCapture 9.0 dans la liste des programmes installés, et cliquez sur Supprimer.

  2. Confirmez que vous souhaitez supprimer le programme.


Exécution du programme

Le serveur et la station de traitement démarrent automatiquement. Les stations et le serveur de traitement peuvent être en cours d'exécution ou arrêtés. Le serveur de traitement se lance à partir du moniteur de serveur de traitement. Les stations de traitement sont lancées par l'utilisateur ou par le serveur de traitement automatiquement (si les paramètres correspondants ont été sélectionnés).

Pour suivre et contrôler le fonctionnement du serveur de traitement et du serveur d'application, sélectionnez les éléments suivants à partir du menu Démarrer :

  • Démarrer/Programmes/Serveurs ABBYY FlexiCapture 9.0/Serveur de traitement pour démarrer le Moniteur de serveur de traitement
  • Démarrer/Programmes/Serveurs ABBYY FlexiCapture 9.0/Console d'administration et de suivi pour ouvrir la page principale de la console dans votre navigateur et contrôler le serveur d'application

Les stations d'ABBYY FlexiCapture 9.0 se lancent en sélectionnant les éléments de menus correspondants à partir de Démarrer/Programmes/Stations ABBYY FlexiCapture 9.0.

Clés de registre contrôlant le lancement de l'application

Vous pouvez utiliser les clés de registre suivantes (sous Shell\StartUp) pour contrôler le processus de lancement de l'application :

  • Project : détermine le projet automatiquement ouvert au lancement de l'application ;
  • Batch : détermine le lot automatiquement ouvert au lancement de l'application (le lot doit être spécifié) ;
  • ProhibitChangePath : empêche de modifier le lot et le projet qui s'ouvrent automatiquement en mode opérateur (définir la valeur de la clé sur True).

Par défaut, ces clés ne sont pas créées dans le registre. Si nécessaire, l'administrateur peut ajouter ces clés au registre du système d'exploitation de l'utilisateur.

Il est possible d'écraser les clés de registre par les paramètres de lancement de la ligne de commande correspondante.

Paramètres de lancement via la ligne de commande

Les paramètres suivants servent à démarrer des stations à partir de la ligne de commande :

FlexiCapture.exe [/Station:(Setup,Validator,Verificator)] [/Project:"chemin d'accès du projet"] [/Batch:"nom du lot"] [/ProhibitChangePath].

  • [/Station:(Setup,Validator,Verificator)] : définit la station (station de configuration de projet, station de vérification ou station de vérification des données respectivement). Si aucun mode n'est défini, le programme vous invite à sélectionner un mode au démarrage.
  • [/Project:"chemin d'accès du projet"] : détermine le projet automatiquement ouvert au lancement de l'application.
  • [/Batch:"nom du lot"] : détermine le lot automatiquement ouvert au lancement de l'application.
  • [/ProhibitChangePath] : empêche de modifier le lot et le projet qui s'ouvrent automatiquement en mode opérateur.


Utilisation de modèles créés avec des versions antérieures d'ABBYY FormReader

Vous pouvez importer des modèles créés avec ABBYY FormReader 6.5 ou 6.0 dans ABBYY FlexiCapture 9.0.

Quand vous importez une définition de document créée avec une version antérieure, le marquage de page (à l'exception des champs de service) et les types de données sont importés. Les types de données sont copiés dans le dossier Personnalisé dans les types de données de la définition de document. Pour plus d'informations, consultez la section Types de données des champs d'entrée de texte.

Important ! Les paramètres d'exportation, les règles de validation et les images contenus dans le lot ne sont pas importés.

Pour importer une définition de document créée avec ABBYY FormReader 6.5 ou 6.0 :

  1. Démarrez la station de configuration de projet.
  2. Créez un nouveau projet ou ouvrez un projet existant dans lequel vous souhaitez importer une définition de document créée avec une version précédente du programme.
  3. Dans le menu principal, sélectionnez Projet > Définitions de document…
  4. Dans la boîte de dialogue Définitions de document, cliquez sur Importer….
  5. Dans la liste déroulante Fichiers de type, sélectionnez Lots FormReader 6.5 (*.frm), puis sélectionnez le lot dont vous souhaitez importer la définition de document.

La définition de document importée est alors ajoutée à la liste de modèles. Si plusieurs définitions de document sont présentes dans le lot, les modèles sont tous importés. Si vous avez spécifié une structure pour des documents de plusieurs pages dans ABBYY FormReader 6.5, les modèles décrits par cette structure sont fusionnés dans une seule et même définition de document multipage.

Conseils.
  1. Pour obtenir des informations détaillées sur les différences entre les règles des anciennes versions et de la nouvelle, consultez la section Comparaison entre les règles de FormReader 6.5 et de FlexiCapture 9.0.
  2. Pour obtenir des conseils sur la migration des règles If-Then, des règles d'automatisation et des exportations d'automatisation de FormReader 6.5 aux scripts FlexiCapture 9.0, consultez la section Migration des règles et exportations FormReader 6.5 aux scripts FlexiCapture 9.0.


Architecture et principes de base d'ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 est une application d'acquisition de données en architecture client/serveur distribuée.

ABBYY FlexiCapture 9.0inclut plusieurs stations de travail et serveurs. Les stations de travail sont exécutées par leurs opérateurs respectifs. Les serveurs s'exécutent sans assistance.

Vous devez configurer le système pour acquérir des données à partir de documents et :

  • établir une connexion à la base de données (sur la console d'administration et de suivi)

  • créer des projets (ceci est effectué sur la station de travail de configuration de projets par un opérateur disposant des droits Administrateur)

  • configurer des projets (ceci est effectué sur la station de travail de configuration de projets par un opérateur disposant des droits Éditeur de paramètres de projets)

  • configurer les droits et rôles des opérateurs pour chaque projet (sur la console d'administration et de suivi)

  • exécuter le serveur de traitement

Une fois que le système est configuré, les opérateurs peuvent commencer le traitement des documents et :

  • ajouter des images de document

    Sur la station de numérisation, l'opérateur peut numériser de nouveaux documents ou ajouter des images de documents déjà numérisés. La station de traitement peut enregistrer automatiquement les images qui arrivent dans le dossier actif.

  • reconnaître les images de document ajoutées

    La reconnaissance est effectuée automatiquement par la station de traitement sans intervention de l'opérateur. Les tâches sont réparties entre les stations par le serveur de traitement.

  • vérifier les résultats

    Les données reconnues sont vérifiées sur la station de vérification de données et sur la station de vérification. L'opérateur de la station de vérification disposant des droits Vérificateur peut effectuer des vérifications plus approfondies, nommément la vérification de l'assemblage du document et le contrôle des erreurs de règles au niveau lot.

  • exporter les résultats

    Les résultats sont automatiquement exportés par la station de traitement.


Serveurs ABBYY FlexiCapture 9.0

ABBYY FlexiCapture 9.0 (installation distribuée) inclut des stations et des serveurs. Les stations sont chargées de gérer les routines de traitement de document tandis que les serveurs assurent le fonctionnement de l'intégralité du complexe de serveurs. Le complexe comprend les serveurs suivants :

  • Serveur d'application
  • Serveur de base de données
  • Serveur de traitement
  • Serveur de protection

Vous pouvez également créer un Dossier de stockage de fichiers (facultatif) pour stocker vos fichiers de projet.


Serveur d'application

Le serveur d'application garantit le bon fonctionnement de l'intégralité du système ABBYY FlexiCapture 9.0. Les stations de travail communiquent entre elles via le serveur d'application.

Nous vous recommandons d'installer le serveur d'application avant d'installer les stations de travail. Avant d'installer le serveur d'application, assurez-vous que les composants suivants sont installés :

  • Net Framework 2.0 ou ultérieur
  • Internet Information Services 5.1, 6.0 ou 7.0
  • Crystal Reports (pour imprimer des rapports via la console d'administration et de suivi)
  • Microsoft SQL Server (sélectionnez l'option Mode mixte lors de l'installation du serveur SQL)

Remarque : Si les composants ci-dessus ne sont pas installés sur votre ordinateur, ils peuvent tous (à l'exception des Services Internet IIS) être installés à partir du disque d'ABBYY FlexiCapture 9.0 . Les Services Internet (IIS) sont un composant Windows distribué avec le système d'exploitation Windows.

Important !
  1. Si vous utilisez un pare-feu, assurez-vous d'autoriser le service de publication World Wide Web.
  2. Pour authentifier la station de numérisation par le biais d'un identifiant et d'un mot de passe plutôt que l'authentification Windows, il vous faut configurer le Serveur d'informations Internet : activez l'authentification de base au niveau de FlexiCapture/du serveur.

Une fois le serveur d'application installé, la console d'administration et de suivi démarre automatiquement (la console est installée avec le serveur) : vous pouvez y configurer une connexion à la base de données et accorder des droits d'accès aux opérateurs.


Serveur de base de données

Le serveur de base de données stocke les informations concernant les opérateurs, les lots, les opérations, les états des tâches, la progression du traitement et les données acquises.

À partir du disque d'ABBYY FlexiCapture 9.0, vous pouvez installer Microsoft SQL Server Express Edition qui permet de traiter jusqu'à 100 000 pages par jour et qui utilise jusqu'à 50 stations de vérification. Pour traiter des volumes plus importants, nous vous recommandons d'utiliser la version complète de Microsoft SQL Server.

Remarque : Si un dossier de stockage de fichiers dédié n'est pas utilisé, les fichiers du projet sont stockés dans la base de données.


Serveur de traitement

Le serveur de traitement répartit la charge de travail entre les stations de traitement. Un moniteur de serveur de traitement est installé avec le serveur de traitement. Il sert à surveiller les opérations du serveur et à définir les priorités des tâches. Le traitement de documents est effectué sur la station de traitement.

Une fois le serveur de traitement installé, vous devrez le configurer : démarrer le serveur, ajouter, configurer et démarrer les stations de traitement et activer les dossiers actifs.

Remarque : Avant de démarrer le serveur de traitement, assurez-vous que les droits d'accès du serveur de traitement ont été concédés au compte sous lequel le serveur est actuellement utilisé (<nom de domaine\nom d'ordinateur>$).

Une description du processus de paramétrage est fournie ci-dessous.

  1. Démarrez le serveur de traitement.
  2. Démarrez les stations de traitement.
  3. Activez les dossiers actifs.

  • Pour démarrer le serveur de traitement :

    1. Lancez le moniteur de serveur de traitement en sélectionnant Démarrer>Programmes>Serveurs ABBYY FlexiCapture 9.0> Serveur de traitement.
    2. Dans l'arborescence du serveur, sélectionnez Serveurs ABBYY FlexiCapture 9.0, cliquez avec le bouton droit de la souris et sélectionnez Ajouter un serveur…
    3. Dans la boîte de dialogue Ajouter un serveur de traitement, spécifiez l'emplacement du serveur (Hôte réseau ou Hôte local).
    4. Sélectionnez Actions>Propriétés et indiquez le chemin vers le serveur d'application (http://server). Si le serveur de traitement et le serveur d'application sont installés sur le même ordinateur, spécifiez directement son nom, car l'utilisation de l'adresse IP 127.0.0.1 ou de l'expression localhost rendra les stations de traitement inopérables.

      Remarque : Sur le serveur d'application, lancez la console d'administration et de suivi et assignez le rôle correspondant à l'ordinateur sur lequel le serveur de traitement est installé.

    5. Cliquez sur [image] pour démarrer le serveur d'application.

  • Pour configurer les stations de traitement :

    1. Dans l'arborescence du serveur, sélectionnez Stations et cliquez sur [image]. La boîte de dialogue Ajouter des stations apparaît. Sélectionnez les stations désirées dans la liste globale. Vous pouvez également spécifier le nom de l'ordinateur ou son adresse IP. Vous pouvez spécifier le nom de l'ordinateur même si des adresses IP dynamiques sont utilisées. Utilisez des adresses IP si vous rencontrez des problèmes d'accès au réseau DNS.
    2. Sélectionnez Actions>Propriétés et dans la boîte de dialogue Propriétés de la station spécifiez les paramètres de la station :
      • Nom : le nom affiché de la station
      • Démarrer automatiquement : cet indicateur signifie que la station est démarrée automatiquement par le serveur de traitement

        Remarque : Des essais fréquents de démarrage d'un trop grand nombre de stations peut ralentir considérablement le serveur de traitement

      • Quantité d'espace disque requise : l'espace disque minimum requis pour le fonctionnement des stations de traitement ; s'il n'y a pas assez d'espace disque, la station sera arrêtée
      • Nombre maximum de processus (cœurs de CPU) : le nombre maximum de noyaux de CPU pouvant être utilisés pour le traitement des tâches
      • Nombre de processus autorisé (cœurs de CPU) : le nombre autorisé de cœur de CPU pour le traitement des tâches ; ce paramètre est calculé automatiquement selon vos paramètres matériels et de licence et ne peut pas être modifié
      • Priorité du processus : la priorité du processus
      • Types de tâches acceptables : les types de tâches pouvant être traités par la station
    3. Cliquez sur [image] pour démarrer la station.

    Remarque : Les stations reçoivent les droits de traiter des documents du serveur de traitement lorsqu'elles se connectent au serveur.

  • Pour activer les dossiers actifs :

    1. Dans l'arborescence du serveur de traitement, sélectionnez Dossiers actifs.
    2. Sélectionnez le projet souhaité dans la liste globale de projets.
    3. Sélectionnez Connecter dans le menu contextuel.

    Remarque : L'enregistrement des images depuis les dossiers actifs démarrera uniquement après que le projet correspondant a été connecté au serveur de traitement.

  • Pour configurer le journal du serveur de traitement :
    1. Ouvrez la boîte de dialogue Paramètres de moniteur de serveur de traitement en sélectionnant Fichier>Paramètres…
    2. Spécifiez quels types de messages doivent être consignés (Erreurs, Avertissements, Messages d'informations).
    3. Spécifiez si les informations relatives aux tâches terminées doivent être effacées (Avertissements).
    4. Spécifiez les messages qui déclencheront la journalisation des informations relatives à la tâche.

      Remarque : Nous déconseillons de désactiver l'option Avertissements durant le fonctionnement normal du système, car ceci peut entraîner une accumulation des données et ralentir le moniteur du serveur de traitement. Désactivez cette option uniquement lors de la configuration et de l'ajustement du système.


Serveur de protection

Le système requiert une clé de protection valide qui doit être activée sur le serveur d'activation d'ABBYY.

ABBYY FlexiCapture 9.0 prend en charge deux types de clés de protection :

  • clé de protection matérielle
  • clé de protection logicielle

Clé de protection matérielle

Une clé de protection matérielle est un « dongle » à brancher sur le port USB de votre ordinateur.

La clé de protection matérielle doit être branchée sur un port USB de l'ordinateur sur lequel vous avez installé le serveur de protection. La clé de protection matérielle ne peut être activée que via Internet automatiquement.

Les paramètres de votre licence sont stockés dans la clé de protection.

Important ! Pour garantir le fonctionnement normal de la clé de protection matérielle, assurez-vous que la SmartCard standard fonctionne.

Clé de protection logicielle

Une clé de protection logicielle est un fichier informatique (« fichier de licence »).

La clé de protection logicielle doit être activée sur le serveur d'activation d'ABBYY. L'activation est effectuée dans le Gestionnaire de licences ABBYY FlexiCapture 9.0 , qui démarre automatiquement une fois que le serveur de protection a été installé.

Les informations requises pour l'activation sont envoyées au serveur sous forme d'ID de produit, qui est généré à partir des informations relatives à l'ordinateur sur lequel ABBYY FlexiCapture 9.0 est installé. Aucune information personnelle n'est utilisée pour générer l'ID de produit et ce code ne peut pas être utilisé pour identifier l'utilisateur.

Méthodes d'activation :

  • Automatiquement par Internet (recommandé)

    L'activation par Internet ne prend que quelques secondes et requiert une connexion à Internet.

  • Par courrier électronique

    Un courrier électronique est automatiquement généré sur l'ordinateur où le serveur de protection est installé. Ce courrier électronique contient les données nécessaires pour activer votre fichier de licence. Pour obtenir une réponse rapide du serveur d'activation, veillez à ne pas modifier l'objet ni le corps du message électronique.

  • Par courrier électronique depuis un autre ordinateur

    Pour envoyer un courrier électronique d'activation depuis un autre ordinateur, vous devez d'abord générer un courrier électronique sur l'ordinateur sur lequel le serveur de protection est installé. Collez ensuite le corps de ce courrier électronique dans un courrier sur l'autre ordinateur et envoyez-le au serveur d'activation ABBYY. Pour obtenir une réponse rapide du serveur d'activation, veillez à ne pas modifier l'objet ni le corps du message électronique.

Répétition de l'activation

Vous pouvez réinstaller le serveur de protection sur un seul et même ordinateur autant de fois que vous le souhaitez sans avoir besoin de réactiver. Toutefois, si vous installez des mises à jour matérielles importantes, que vous formatez le disque dur ou que vous réinstallez le système d'exploitation, vous devrez probablement réactiver le produit.

Pour chaque numéro de série, le nombre d'activations est contrôlé. Si vous dépassez le nombre maximal d'activations, vous ne pourrez plus activer votre fichier de licence. Vous pouvez libérer une licence activée en commençant une procédure de désactivation. Ceci réduira la valeur du compteur d'activation.

Gestion de vos licences

Les licences peuvent être ajoutées, activées, sélectionnées, désactivées et l'information de chaque licence peut être visualisée dans le Gestionnaire de licences ABBYY FlexiCapture 9.0, qui est installé avec le serveur de protection.

Pour lancer le gestionnaire de licences ABBYY FlexiCapture 9.0 :

  • Sélectionnez Démarrer>Programmes>ABBYY FlexiCapture 9.0 Serveurs>Outils>Gestionnaire de licences ABBYY FlexiCapture 9.0.

Ajout d'une nouvelle licence

Pour ajouter une nouvelle licence :

  1. Dans la fenêtre principale du gestionnaire de licences ABBYY FlexiCapture 9.0, cliquez sur Sélectionner.
  2. Dans la boîte de dialogue Licences, cliquez sur Activer...
  3. Saisissez votre numéro de série, cliquez sur Suivant et suivez les instructions de l'assistant d'activation d'ABBYY FlexiCapture 9.0.

    Remarque : Si aucune licence n'a été ajoutée, lorsque vous lancez le gestionnaire de licences ABBYY FlexiCapture 9.0, l'Assistant d'activation ABBYY FlexiCapture 9.0 est lancé automatiquement et le programme vous demande de saisir votre numéro de série.

Mise à jour d'une licence

Vous pouvez mettre à jour votre licence en chargeant les informations de licence mises à jour à partir du serveur d'enregistrement ABBYY :

  1. Dans la fenêtre principale du gestionnaire de licences ABBYY FlexiCapture 9.0, cliquez sur Sélectionner...
  2. Dans la boîte de dialogue Licences..., sélectionnez la licence à mettre à jour et cliquez sur Mise à jour...
  3. Sélectionnez une méthode de mise à jour et mettez à jour votre licence.

Désactivation d'une licence.

Pour désactiver (« libérer ») une licence :

  1. Dans la fenêtre principale du gestionnaire de licences ABBYY FlexiCapture 9.0, cliquez sur Sélectionner...
  2. Dans la boîte de dialogue Licences..., sélectionnez la licence à désactiver et cliquez sur Désactiver.


Dossier de stockage de fichiers

Les fichiers du projet (c'est-à-dire les documents, les définitions de document, etc.) peuvent être stockés dans une base de données ou dans un dossier de stockage de fichiers dédié. Le dossier de stockage de fichiers doit être spécifié sur la console d'administration et de suivi. Le dossier de stockage de fichiers doit être situé sur le même ordinateur que le serveur d'application. Assurez-vous de spécifier le chemin d'accès local au dossier de stockage de fichiers (c'est-à-dire c:\\...) et non le chemin réseau (c'est-à-dire \\serveur\...). Si aucun dossier de stockage de fichiers n'est spécifié, les fichiers seront stockés dans la base de données.

Choisir entre un dossier de stockage de fichiers et une base de données pour stocker vos fichiers de projet n'affecte pas la performance ou la sécurité du système. Cependant, l'utilisation d'un dossier de stockage de fichiers implique que vous puissiez stocker de nombreux documents supplémentaires (images) dans les projets sur le serveur d'application, et, contrairement à Microsoft SQL Server Express Edition, il n'existe aucune restriction sur la taille totale des fichiers stockés.


Stations ABBYY FlexiCapture 9.0

L'application complexe inclut les stations suivantes :

  • Station de configuration de projets

  • Station de numérisation

  • Station de traitement

  • Station de vérification de données

  • Station de vérification

L'application complexe inclut également une console d'administration et de suivi.


Station de configuration de projets

La Station de configuration de projets est la station où les projets sont créés, configurés et débogués. Un projet spécifie les définitions de document, les types de lot, l'importation d'images, l'exportation de documents et les options de traitement.

Pour créer et configurer un projet :

  1. Créez un projet et chargez-le vers le serveur d'application.
  2. Ouvrez le projet sur le serveur et configurez ses propriétés.
  3. Créez des définitions de document.
  4. Créez des types de lot.
  5. Créez des profils d'importation d'images.

Important ! Seul l'administrateur peut créer des nouveaux projets. Un opérateur de configuration de projets peut uniquement configurer les projets déjà créés.

  1. Création d'un nouveau projet

    Une fois que l'administrateur a établi une connexion avec la base de données, l'administrateur devra :

    1. Lancer la station de configuration de projets (Démarrer>Programmes>Stations ABBYY FlexiCapture 9.0>Station de configuration de projets)
    2. Créer un projet
    3. Charger le projet vers le serveur d'applications

    Une fois le projet chargé sur le serveur d'applications, l'administrateur peut concéder les droits de configuration pour le projet à un opérateur de configuration de projets.

  2. Propriétés du projet

    Pour configurer les propriétés du projet, l'opérateur de configuration de projets devra :

    1. Lancer la station de configuration de projets.
    2. Sélectionner Fichier>Ouvrir un projet à partir du serveur… et spécifier le chemin vers le serveur d'applications. Une boîte de dialogue Ouvrir un projet existant à partir du serveur d'application apparaît.
    3. Sélectionner le projet à partir de la liste de tous les projets disponibles.
    4. SélectionnerProjet>Propriétés du projet… et spécifiez les propriétés du projet : options de prétraitement d'image, options de reconnaissance du document, règles de vérification de l'intégrité, paramètres d'exportation et options de traitement.

  3. Création de définitions de document

    Pour déterminer comment les types de documents doivent être identifiés et traités, l'opérateur de configuration de projets doit créer des définitions de document. Une définition de document inclut des informations sur la structure du document, les positions de ses champs, les options de traitement de document et d'exportation, etc. Les définitions de document sont créées dans un Assistant de définition et les propriétés sont spécifiées dans un Éditeur de définitions de document.

  4. Création de types de lots

    ABBYY FlexiCapture 9.0 peut traiter les documents en lots : avant le traitement, un lot est créé et les images de document sont placées dans ce lot, qui passe ensuite par les différentes phases de traitement. Un lot contient en principe la pile de documents numérisés au cours d'un même passage ou importés à partir d'un dossier donné. Les paramètres à utiliser pour le traitement des documents sont spécifiés dans le type de lot. Vous pouvez créer différents types de lot pour les jeux d'options de traitement les plus couramment utilisés. Dans ce cas, à chaque fois qu'un opérateur crée un nouveau lot, il peut spécifier son type et le lot sera traité selon les paramètres spécifiés pour ce type de lot.

    Remarque :

    • Si aucun type de lot n'est créé, tous les lots sont traités avec les paramètres <par défaut> spécifiés pour le projet entier.
    • Les documents peuvent être vérifiés ou exportés en lots ou individuellement. Ceci est également spécifié dans les paramètres de type de lot.

  5. Création de profils d'importation d'images

    Pour automatiser le processus d'ajout d'images, des profils d'importation d'images peuvent être créés dans la station de configuration de projets. Deux types de profils sont disponibles : un impliquant l'utilisation d'un scanner et un autre impliquant l'utilisation d'un dossier actif. Un profil de scanneur peut être utilisé pour déboguer le projet. Un profil de dossier actif importe des images automatiquement dans la station de traitement.

    Remarque :

    • Un profil de scanner est uniquement disponible dans la station de configuration de projets.
    • Pour utiliser des dossiers actifs, vous devez activer un dossier actif pour ce projet dans le Moniteur du serveur de traitement.


Console d'administration et de suivi

Important ! Pour un bon fonctionnement de la console d'administration et de suivi, assurez-vous que votre navigateur autorise l'utilisation du JavaScript et des fenêtres pop-up.

La console d'administration et de suivi est utilisée pour configurer l'intégralité de l'application complexe et pour surveiller son fonctionnement.

La console d'administration et de suivi est une interface Web disponible pour l'utilisateur du serveur d'application et donne accès au serveur via un navigateur Internet. La console peut être ouverte sur tout ordinateur qui peut accéder au serveur d'application en saisissanthttp://<ServeurAppli>/FlexiCapture dans le navigateur où <ServeurAppli> doit être remplacé par le nom de l'ordinateur sur lequel le serveur d'application est installé.

La console d'administration et de suivi est lancée immédiatement après l'installation du serveur d'application, ce qui permet à l'opérateur d'établir une connexion avec la base de données. L'opérateur peut se connecter à une base de données existante ou en créer une.

Remarque : Les droits Administrateur sont automatiquement accordés à l'opérateur qui crée la base de données sur le serveur d'application.

Pour configurer une connexion à la base de données, sélectionnez Options>Serveur d'application et cliquez sur Se connecter à une base de données existante ou sur Créer une nouvelle base de données. Remplissez ensuite les champs en saisissant les données suivantes :

  • le nom de l'instance du serveur SQL ;

  • le nom de la base de données ;

  • le type d'authentification devant être utilisé pour accéder à la base de données ;

  • si le dossier de stockage de fichiers doit être utilisé.

    Un dossier de stockage de fichiers est un dossier local situé sur l'ordinateur où est installé le serveur d'application et qui stocke les fichiers du projet. Sinon, les fichiers du projet peuvent être stockés dans une base de données. Si les fichiers du projet doivent être stockés séparément, sélectionnez Utiliser un stockage de fichiers externe et indiquez le chemin d'accès au dossier local approprié.

En cas de mise à jour, il se peut que vous deviez apporter des modifications à la structure de la base de données. Si tel est le cas, utilisez le script fourni avec la mise à jour. Pour exécuter le script, cliquez sur le bouton Appliquer la mise à jour et indiquez le chemin d'accès au fichier de script.

En plus de la connexion à une base de données, l'administrateur doit configurer des droits d'accès pour les utilisateurs et répartir les rôles entre les opérateurs.

Important ! Les droits accordés à l'administrateur, à l'opérateur de suivi et au serveur de traitement s'appliquent à tous les projets. Par conséquent, ils peuvent être configurés immédiatement après que la connexion avec la base de données a été établie. Les droits de tous les autres opérateurs sont accordés pour des projets particuliers. Par conséquent, avant d'accorder des droits aux autres opérateurs, l'administrateur doit créer des projets et les exporter vers le serveur d'application. L'administrateur ne pourra pas ajouter d'opérateurs et leur accorder des droits d'accès s'il n'y a pas de projet sur le serveur d'application.

Dès que l'application complexe est configurée, la station d'administration et de suivi peut être utilisée pour surveiller le fonctionnement de l'application complexe (c'est-à-dire suivre l'état actuel de l'application complexe et générer des rapports). En se basant sur les informations concernant l'état actuel de l'application complexe, l'administrateur apporte des modifications à la configuration ou réalloue les ressources.

L'administrateur peut consulter les états des éléments suivants :

  • Lots - la console affiche la liste des lots, des statistiques sur les lots et les étapes de traitement actives

  • Tâches - la console affiche la liste des tâches et des statistiques sur les tâches

  • Sessions - la console affiche la liste des sessions ouvertes

  • État de traitement actuel - la console affiche la liste des étapes de traitement et le nombre de documents ou de lots dans chaque phase

  • Journal des événements - la console affiche la liste des événements et des informations concernant chaque événement

  • Journal des erreurs - la console affiche la liste des erreurs et la description de chaque erreur

Pour consulter les états, sélectionnez un projet puis l'élément approprié dans le menu Suivi. La liste obtenue peut être affichée à l'écran, imprimée ou enregistrée au format CSV.

L'opérateur de suivi peut non seulement obtenir des informations concernant l'état actuel de l'application complexe, mais aussi générer des rapports concernant le fonctionnement de l'application complexe.

Les rapports suivants peuvent être créés :

  • Rapport général sur le traitement de documents - un rapport est créé indépendamment pour chaque projet

  • Rapport complet sur les opérateurs de vérification de données

  • Rapport général sur les opérateurs de vérification de données

  • Rapport complet sur les opérateurs de vérification

  • Rapport général sur les opérateurs de vérification

Remarque : Les rapports sur les opérateurs de vérification et sur les opérateurs de vérification de données sont générés en se basant sur tous les projets.


Station de numérisation

Important ! Pour plus d'informations sur la station, consultez l'aide de la station de numérisation

La finalité de la station de numérisation est de faciliter la numérisation de grandes quantité de documents. La station de numérisation peut fonctionner dans un réseau local ou distant (par Internet). L’authentification s’effectue via un identifiant et un mot de passe.

La station de numérisation peut être la première station où un document arrive. La station est exploitée par un opérateur de numérisation qui peut ajouter des images selon l'une des deux méthodes suivantes :

  • la création et l'utilisation de profils de numérisation et/ou l'ajout manuel d'images
  • l'ajout des images de documents déjà numérisés à partir d'un dossier

Les profils automatisent le processus d'acquisition d'images, ce qui permet à l'opérateur d'ajouter des images selon les paramètres précédemment configurés en un seul clic de souris.

En plus de l'ajout d'images, l'opérateur peut modifier les images ajoutées (consultez l'aide de la station de numérisation pour obtenir des informations supplémentaires).

En tant qu'opérateur de numérisation, les actions à mener sont les suivantes, dans l'ordre :

  • Lancez la station de numérisation
  • S'il reste un lot dont le traitement n'est pas terminé sur la station, continuez le traitement de ce lot. Sinon, créez un nouveau lot.
  • Si des profils d'importation ont déjà été créés, sélectionnez le profil approprié et commencez le processus de numérisation. S'il n'existe pas de profils prêts à l'emploi, créez les profils nécessaires et utilisez-les pour numériser les documents.
  • En ajoutant des images, l'opérateur peut contrôler visuellement leurs propriétés et les modifier si nécessaire. Si cette seule action ne résout pas le problème, l'opérateur peut modifier les options de numérisation et renumériser les pages inexactes.
  • Contrôlez la qualité de l'assemblage du document et corrigez toute erreur d'assemblage.
  • Dès que le lot est prêt, spécifiez ses paramètres d'enregistrement et envoyez-le vers le serveur.
  • Répétez les étapes précédentes pour le lot d'images suivant ou fermez la station de numérisation.


Station de vérification de données

La finalité de la station de vérification de données est la vérification des caractères mal reconnus. L'opérateur de vérification de données relit d'abord les caractères incertains en mode de vérification de groupe puis en mode de vérification de champ.

Pendant la vérification de groupe, l'opérateur voit affichés des groupes de caractères similaires. L'opérateur doit repérer tous les caractères mal reconnus et les corriger en les comparant avec l'image du champ correspondant si nécessaire. Si, quelle qu'en soit la raison, un caractère ne peut pas être corrigé, l'opérateur le marque comme incertain.

Pendant la vérification de champ, l'opérateur voit affichés des champs dont les plages de valeurs sont connues à l'avance. L'opérateur doit vérifier les caractères incertains en les examinant dans leur contexte. Deux affichages sont disponibles pendant la vérification de champ : l'affichage monochamp qui extrait les caractères, et l'affichage multi-champs qui affiche tous les champs identiques sur le même écran.

Remarque : À part l'opérateur de vérification de données, l'opérateur de vérification et le chef-opérateur de vérification peuvent également accéder à la station de vérification de données. Qui que soit l'opérateur travaillant sur la station, il ne peut accéder qu'à la file de vérification de données.

Pour démarrer la vérification de données :

  1. Lancez la station de vérification de données en sélectionnant Démarrer>Programmes>Stations ABBYY FlexiCapture 9.0>Station de vérification de données.
  2. Sélectionnez le projet approprié.
  3. Cliquez sur [image] pour commencer la vérification.

    Remarque : La vérification commence par la vérification de groupe suivie de la vérification de champ. Si une définition de document ne comporte aucun champ inclus pendant la vérification de groupe ou de champ, le document ne sera pas mis en attente dans la file de vérification.

Une fois la vérification de données terminée, le lot ou l'ensemble de documents est envoyé vers la station de vérification.

Si les opérateurs de vérification de données rencontrent des problèmes en traitant les documents, ils peuvent envoyer le lot ou les documents vers la File Exceptions en cliquant sur [image].


Station de vérification

La station de vérification permet des vérifications plus complexes que la station de vérification de données. En plus des vérifications de données, la station permet à l'opérateur de traiter les lots ou les documents problématiques, de corriger les erreurs d'assemblage, de vérifier les règles et de vérifier l'intégrité des lots.

La station de vérification peut être opérée par les opérateurs suivants : opérateurs de vérification de données, opérateurs de vérification et chef-opérateurs de vérification. Selon le rôle sélectionné par l'opérateur lors de la connexion à la station, les tâches peuvent être traitées à partir de files différentes :

  • Un opérateur de vérification de données peut uniquement traiter les tâches à partir de la file de vérification de données
  • Un opérateur de vérification peut traiter les tâches de n'importe quelle file excepté la file Exceptions et la file de confirmation d'exportation
  • Un chef-opérateur de vérification peut traiter les tâches de n'importe quelle file. En plus de la liste de files, le chef-opérateur peut également accéder à la liste de lots.

Les files suivantes sont disponibles dans la station de vérification :

  • <Toute>

    Cette file inclut les tâches créées dans n'importe quelle autre file. La liste de files disponibles pour un opérateur dépend du rôle sélectionné par l'opérateur lors de la connexion à la station. Les tâches sont prises par ordre de priorité.

  • Vérification de l'assemblage du document

    Pour les documents multipages, il faut peut-être corriger des erreurs d'assemblage de document. Les règles d'assemblage de documents sont créées avec les définitions de document et définissent l'ordre des pages et le nombre de répétitions de page. De plus, l'assemblage de documents peut être vérifié selon les valeurs de champs clés, dans ce cas les valeurs des champs clé doivent être les mêmes sur toutes les pages d'un document. Si les valeurs sont différentes, un message d'erreur s'affiche et les valeurs sont surlignées en rouge. Les erreurs d'assemblage peuvent être corrigées plus facilement en vue vignettes, car elle permet à l'utilisateur de bien visualiser les images de page et les différents documents dont elles font partie.

  • Vérification de données

    Le processus de vérification de données démarre par la vérification groupée suivie de la vérification de champ. Si la définition d'un document n'a aucun champ inclus dans la vérification groupée ou de champ, le document n'est pas placé dans la file de vérification de données.

  • Vérification

    Si aucune file spéciale n'est spécifiée par les paramètres de traitement, la file de vérification contient toutes les tâches avec les erreurs d'assemblage de document, les erreurs de vérification de données et les erreurs de règles.

  • Contrôle de l'intégrité du lot

    Les règles utilisées pour les vérifications d'intégrité de données établissent les liens entre les données dans les documents d'un lot.

  • Exporter la confirmation

    Les données peuvent être exportées manuellement ou automatiquement. Si les paramètres de traitement ne définissent pas une file de confirmation d'exportation séparée, les lots ou les documents sont exportés automatiquement en mode non assisté. Si les paramètres de traitement incluent une file de confirmation d'exportation séparée, le chef-opérateur de vérification doit d'abord recevoir la tâche de la file puis la renvoyer dans la file. Si une erreur se produit, le lot ou les documents sont automatiquement envoyés vers la file Exceptions.

  • Exceptions

    Les lots ou les documents problématiques, que l'opérateur n'a pas pu traiter, sont envoyés vers la file Exceptions.

Remarque : Les paramètres de traitement de document (c-à-d file séparées) sont spécifiés pour les types de lot ou pour le projet entier si aucun type de lot n'est utilisé.

Pour effectuer une tâche, sélectionnez la file désirée dans la liste de files et cliquez sur [image].

Vous pouvez activer le mode automatique d’obtention de tâches en cliquant sur [image] ou Tâche>Obtenir les tâches automatiquement.

La station offre également les vues Détails et Vignettes. Les documents de la tâche active sont affichés dans la vue Détails. Dans la vue Vignettes, tous les documents du lot sont affichés et les pages ne faisant pas partie de la tâche active sont surlignées en gris.


Station de traitement

Lesstations de traitement fonctionnent sans assistance et gèrent les tâches suivantes : le chargement des images depuis les dossiers actifs, l'application de définitions de documents et la reconnaissance de documents, la validation par règle, l'exportation de données vers des emplacements de stockage prédéfinis. Les stations de traitement reçoivent des tâches du serveur de traitement.

Pour afficher les tâches en cours :

  1. Lancez la station de traitement en sélectionnant Démarrer>Programmes>Stations ABBYY FlexiCapture 9.0>Station de traitement. Une boîte de dialogue Se connecter à la station s'ouvre.
  2. Désignez l'emplacement du serveur de traitement.
    • L'Hôte du réseau et le nom de l'ordinateur sur lequel le serveur de traitement est installé (si le serveur de traitement et la station de traitement sont installés sur des ordinateurs différents)
    • L'Hôte local (si le serveur de traitement et la station de traitement sont installés sur le même ordinateur)

Toutes les tâches actives sont affichées dans la colonne Tâches. Les informations suivantes sont disponibles pour chaque tâche : heure de début, progression, état, priorité, station et créateur. Les tâches peuvent être triées en cliquant sur le nom de la colonne souhaitée.

Remarque : Seul un opérateur disposant des autorisations Administrateur peut lancer les stations de traitement et suivre les tâches (c'est-à-dire afficher les détails des tâches, annuler des tâches et afficher des journaux).


Etapes et files de traitement

Les documents sont traités en plusieurs phases, avec certaines routines effectuées à chaque phases, que ce soit de manière automatique ou par un opérateur. Les phases ont un ordre spécifique et pour pouvoir passer à une phase en particulier, les documents doivent d'abord passer par les phases précédentes. Dans l'ensemble, les phases suivantes sont requises : l'ajout d'images, la reconnaissance, la vérification et l'exportation.

À chaque phase, une file de traitement est composée. Durant la progression du traitement, les documents sont déplacés de la première file (reconnaissance) à la dernière file (exportation). Généralement, les files correspondent aux phases de traitement, mais il existe également des files spéciales, comme les files d'exception.

Dans le cas de grands volumes de traitement, la phase de vérification peut être subdivisée en phases plus petites, chacune traitée par son opérateur propre. En autres termes, vous pouvez créer des files séparées pour la vérification des données, la vérification, les vérifications d'assemblage de documents et la confirmation d'exportation.

Toutes les phases de traitement et les files correspondantes sont facultatives, à l'exception des phases de reconnaissance et d'exportation. La nécessité d'une file ou non est définie pour chaque type de lot dans la station de configuration de projets.

Reconnaissance de

  1. files

    Une file requise dans laquelle des lots entiers uniquement sont traités. La reconnaissance est effectuée automatiquement dans la station de traitement.

  2. Vérification de l'assemblage du document

    Une file facultative. Les tâches de cette file sont traitées dans la station de vérification. Si aucune file d'assemblage de documents séparée n'est spécifiée dans les paramètres, les lots ou documents avec des erreurs sont traités dans la file de vérification.

  3. Vérification des données

    Une file facultative. Les tâches de cette file sont traitées dans la station de vérification de données ou dans la station de vérification. Si le pourcentage de caractères incertains est inférieur au seul spécifié, le document est envoyé à l'étape de vérification de données.

  4. Vérification

    Une file facultative. Si aucune file séparée n'est spécifiée, toutes les tâches avec des erreurs d'assemblage de document, des erreurs de données et des erreurs de règles sont envoyées à la file de vérification.Les tâches de cette file sont traitées dans la station de vérification.

  5. Vérification de l'intégrité du lot

    Une file facultative.Les lots avec des erreurs d'intégrité sont envoyés à cette file. Les options de vérification d'intégrité sont spécifiées par des scripts lors de la configuration d'un type de lot. Les tâches de cette file sont traitées dans la station de vérification.

  6. Confirmation de l'exportation

    Une file facultative permettant une meilleure précision des données acquises. Un lot ou un document est exporté uniquement une fois que l'opérateur confirme qu'il peut être exporté. Les tâches de cette file sont traitées dans la station de vérification.

  7. Exportation

    Une file requise. Les tâches de cette file sont traitées dans la station de traitement.

  8. Exceptions

    Une file requise. Les documents présentant des erreurs sont envoyés à cette file pour un traitement automatisé. De plus, les opérateurs peuvent également envoyer des documents à cette file s'ils ne peuvent pas les traiter pour quelque raison que ce soit.

Remarque : Dans les paramètres de type de lot, vous pouvez spécifier si les lots doivent être vérifiés et exportés intégralement ou document par document.


Flux de travail

Les documents peuvent être traités automatiquement sans intervention humaine ou avec l'assistance des opérateurs de vérification.

En mode assisté, aucune implication de l'opérateur n'est requise pour traiter et exporter les documents. En cas d'erreur, l'image non reconnue peut être enregistrée dans un dossier prévu à cet effet qui peut être sélectionné dans l'onglet Exportation, tandis que les documents dont la reconnaissance a réussi sont exportés automatiquement. En mode non assisté, les lots sont traités dans leur intégralité.

Si des opérateurs humains sont impliqués, les paramètres de traitement par lot, tels que ceux de vérification et d'exportation, doivent être configurés. De plus, la vérification de documents peut être subdivisée en étapes indépendantes, c'est-à-dire que chaque étape est mise dans une file indépendante. Les documents (ou des lots entiers) peuvent passer par ces étapes automatiquement (s'il n'y a aucune erreur de traitement) ou après avoir été contrôlés et corrigés par un opérateur. Si une erreur se produit pour un document traité en mode non assisté, le document est envoyé vers la file Exceptions. Un opérateur peut également envoyer un document vers la file Exceptions.

L'ordre de traitement est spécifié pour chaque type de lot. Lorsqu'un nouveau lot est créé, un type prédéterminant l'ordre de traitement lui est attribué.

Si aucun type de lot n'est créé, tous les lots sont traités avec les paramètres par <défaut> spécifiés pour l'intégralité du projet.


Configuration du programme

Avant d'entrer des documents en masse, vous devez configurer le programme pour traiter les documents du type requis. Tous les paramètres requis sont configurés dans la station de configuration de projet.

Pour configurer le traitement des documents, créez un projet contenant :

  • des profils d'importation d'image ;
  • une ou plusieurs définitions de document ;
  • les types de lots à traiter.

Vous pouvez inclure différentes définitions de document dans le projet, auquel cas les différents documents seront traités dans le cadre du même projet, en fonction de la définition de document appliquée. Toutefois, si les flux de documents ne s'entrecoupent jamais, vous pouvez créer des projets différents pour chaque type de document.

puce | Création d'un projet
puce | Définitions de document
puce | Profils d'importation d'image
puce | Paramètres d'exportation par défaut
puce | Types de lots
puce | Lots de documents
puce | Champs d'index


Configuration d'ABBYY FlexiCapture 9.0

Pour configurer ABBYY FlexiCapture pour le traitement distribué de documents :

  1. Configurez le serveur d'application sur la console d'administration et de suivi.
  2. Téléchargez le projet sur le serveur d'application.
  3. Accordez des droits d'accès aux opérateurs sur la console d'administration et de suivi.
  4. Configurez le serveur de traitement et les stations de traitement dans le moniteur de serveur de traitement.
  5. Configurez le flux de travail sur la station de configuration de projets.


Configuration du serveur d'application

Le serveur d'application est configuré par l'administrateur du système dans la console d'administration et de suivi.

Pour configurer le serveur d'application, lancez la console d'administration et de suivi, allez à la page Créer une nouvelle base de données (Paramètres>Serveur d'application, bouton Créer une nouvelle base de données) puis indiquez les éléments suivants :

  • le nom de l'instance de serveur SQL ;
  • le nom de la base de données ;
  • le type d'authentification ;

  • l'emplacement de stockage du fichier.

Remarque : Le dossier dans lequel les fichiers de projet doivent être stockés doit se trouver sur le même ordinateur que celui sur lequel l'application est installée.

Les fichiers de projet peuvent être stockés directement dans la base données ou dans un dossier de stockage de fichier dédié. Si aucun dossier de stockage de fichiers n'est spécifié, les fichiers seront stockés dans la base de données. Le stockage des fichiers dans la base de données facilite les sauvegardes mais augmente la taille de la base de données.


Accorder des droits d'accès aux utilisateurs

Les droits d'accès sont accordés par l'administrateur dans la console d'administration et de suivi. Les droits sont accordés à un utilisateur ou à un processus.

Les rôles de serveur de traitement, opérateur de suivi et administrateur sont indépendants d'un projet. Tous les autres droits d'accès ne s'appliquent qu'à des projets individuels. Vous devez donc d'abord créer un projet.

Remarque :

  • Le rôle d'administrateur est octroyé automatiquement à l'utilisateur qui a créé la base de données.
  • Les droits d'accès au serveur de traitement sont accordés au compte sous lequel le serveur fonctionne (<nom de domaine\nom de l'ordinateur>$).

Une fois que l'administrateur a créé un projet dans la station de configuration de projet et qu'il l'a téléchargé sur le serveur d'application, il peut accorder des droits d'accès aux opérateurs qui vont travailler sur ce projet. Les rôles et droits d'accès peuvent être accordés à des utilisateurs individuels ou à des groupes. Dans ce dernier cas, une fois qu'un utilisateur entre dans un groupe, il obtient automatiquement tous les droits d'accès accordés à son groupe.

Pour créer un nouveau compte utilisateur :

  1. Démarrez la console d'administration et de suivi en sélectionnant Démarrer>Programmes>Serveurs ABBYY FlexiCapture 9.0>Console d'administration et de suivi.
  2. Sélectionnez Paramètres>Utilisateurs et groupes.
  3. Sélectionnez le projet dans la liste globale de projets.
  4. Ajoutez un nouveau compte utilisateur en indiquant le nom de domaine de l'utilisateur (Champ Ajouter) puis en cliquant sur Utilisateur.
  5. Indiquez le rôle (par exemple Opérateur de numérisation) puis définissez les types de lots accessibles à cet opérateur.

Remarque : Lorsque l'utilisateur tente de se connecter à la station ou de démarrer le serveur de traitement, le compte utilisateur ou processus apparaîtra dans la liste des utilisateurs. Ensuite, l'administrateur attribue un rôle à l'utilisateur.

Pour créer un groupe :

  1. Démarrez la console d'administration et de suivi en sélectionnant Démarrer>Programmes>Serveurs ABBYY FlexiCapture 9.0>Console d'administration et de suivi.
  2. Sélectionnez Paramètres>Utilisateurs et groupes.
  3. Sélectionnez le projet dans la liste globale de projets.
  4. Ajoutez un nouveau compte de groupe en indiquant son nom (Champ Ajouter) puis en cliquant sur Groupe.
  5. Définissez les droits d'accès et les rôles ainsi que les types de lots accessibles aux opérateurs de ce groupe.
  6. Ajoutez des utilisateurs au groupe.


Configuration du serveur et des stations de traitement

Le serveur de traitement est configuré grâce au moniteur de serveur de traitement, une application qui est automatiquement installée avec le serveur.

Pour configurer le serveur de traitement :

  1. Lancez le moniteur de serveur de traitement en sélectionnant Démarrer>Programmes>Serveurs ABBYY FlexiCapture 9.0>Serveur de traitement.
  2. Ajoutez le serveur en sélectionnant Actions>Ajouter un serveur…
  3. Indiquez le chemin d'accès au serveur d'application (Actions>Propriétés).
  4. Démarrez le serveur de traitement (Actions>Démarrer)

    Remarque : Pour démarrer le serveur de traitement, l'administrateur doit attribuer des droits au compte utilisateur sur lequel le serveur fonctionne (c'est-à-dire <nom du domaine\nom de l'ordinateur>$).

  5. Créez la liste des stations de traitement, spécifiez leurs propriétés et démarrez-les :
  • Pour ajouter une station, accédez au nœud Stations de l'arborescence du serveur de traitement et sélectionnez Actions>Ajouter des stations…
  • Pour configurer une station, sélectionnez-la dans la liste globale des stations et sélectionnez Propriétés dans son menu contextuel.
  • Spécifiez les paramètres de station requis : lancement, priorité, types de tâches possibles, etc.

    Important ! Le nombre maximum de traitements simultanés (champNombre maximum de processus (cœurs de CPU) ) ne peut pas être supérieur au nombre de traitements autorisé (champNombre de processus autorisé (cœurs de CPU) ). Dans le même temps, le nombre total de traitements simultanés sur toutes les stations de traitement ne peut pas être supérieur au nombre autorisé par votre licence. Si vous essayez de démarrer davantage de stations, elles ne fonctionneront pas.

Les stations de traitement fonctionnent sur le même compte que le serveur de traitement. Les droits sont accordés aux stations par le serveur de traitement lorsque les stations sont connectées au serveur.

Dans le moniteur de serveur de traitement, vous pouvez également configurer des dossiers actifs.

Pour activer les dossiers actifs :

  1. Dans l'arborescence du serveur de traitement, sélectionnez Dossiers actifs.
  2. Sélectionnez le projet souhaité dans la liste globale de projets.
  3. Dans la fenêtre principale, sélectionnez Actions>Activer.

Remarque : L'enregistrement des images depuis les dossiers actifs démarrera uniquement après que le projet correspondant a été connecté au serveur de traitement.

De plus, le moniteur de serveur de traitement vous permet de définir les priorités des tâches et de suivre les tâches (nœud Tâches dans l'arborescence du serveur de traitement).


Configuration du flux de travail

L'ordre dans lequel un lot doit être traité est spécifié pour chaque type de lot. Lorsqu'un lot est créé, son type est défini et le lot est traité selon les paramètres de ce type de lot.

Si aucun type de lot n'est créé, tous les lots sont traités avec les paramètres <par défaut> spécifiés pour l'intégralité du projet (Projet>Propriétés du projet…, onglet Flux de travail ).

Les flux de travail sont configurés dans l'onglet Flux de travail de la boîte de dialogue Propriétés du type de lot.

  1. Sélectionnez le mode Non assisté ou Avec vérification.
    • En mode Non assisté, les documents sont traités et exportés sans l'intervention de l'opérateur. Si des erreurs de traitement se produisent, l'image non reconnue peut être enregistrée dans un dossier dédié (défini dans l'onglet Exporter) et les documents traités avec succès sont automatiquement exportés. En mode non assisté, les lots sont traités dans leur intégralité.
    • En mode Avec vérification mode, vous devez spécifier les paramètres de vérification, indiquer si le lot entier ou des documents individuels doivent être exportés et définir des files séparées pour les différentes étapes de la vérification.
  2. Vérifier les lots entiers
    • Si cette option est sélectionnée, le lot entier est envoyé à la vérification (c'est-à-dire que le lot n'est pas transféré à moins que tous les documents qu'il contient ne soient reconnus).
    • Si cette option n'est pas sélectionnée, chaque document provenant de ce lot est envoyé à la vérification aussitôt qu'il est reconnu.
  3. Passer la vérification et la vérification de données si le pourcentage de caractères incertains est inférieur ou égal à : le document est envoyé pour vérification uniquement s’il y a des erreurs ou si le nombre de caractères en surbrillance est supérieur à celui spécifié dans le champ % par document.
    Remarque : Si vous avez sélectionné toujours pour n’importe quel champ dans les Paramètres de vérification de champ ,le document sera envoyé pour vérification quoi qu’il arrive.
  4. Passer la vérification et la vérification de données si le pourcentage de caractères incertains est inférieur ou égal à : le document n'est envoyé dans la file de vérification que si le pourcentage de caractères incertains est supérieur à la valeur spécifiée dans le champ % par document.
  5. Exporter les lots entiers : le lot n'est exporté que lorsque tous les documents qu'il contient sont traités.
  6. Supprimer les documents traités après l'exportation : supprime automatiquement les documents traités une fois qu'ils ont été exportés.
  7. Utilisez des files séparées pour les étapes de :
    • Vérification de l'assemblage des documents
    • Vérification de données
    • Vérification de l'intégrité du lot
    • Exporter la confirmation

    La création de files de vérification séparées divise les étapes de vérification en sous-étapes, chacune prise en charge par son opérateur dédié. Ainsi, chaque opérateur n'aura qu'une tâche à accomplir : vérification des données, vérification de l'assemblage du document, etc.

    Si toutes les files ci-dessus sont prises en charge par un opérateur, il/elle devra accomplir toutes les tâches tour à tour : récupérer le document à partir de la file de vérification de l'assemblage du document, vérifier l'assemblage, récupérer les données de la file de vérification des données puis les vérifier, etc.


Création d'un projet

Avant de pouvoir commencer le traitement de vos documents, il vous faut créer un projet. Un projet inclut :

  • des profils d'importation d'image
  • une définition de document ou plus
  • des types de lots

Dès qu'un projet est créé, téléchargez-le vers le serveur d'application.

Les projets sont créés sur la station de configuration de projets et sont téléchargés vers le serveur d'application via la console d'administration et de suivi.

Pour créer un nouveau projet, sélectionnez Fichier>Nouveau projet…

puce | Propriétés du projet
puce | Définitions de document
puce | Profils d'importation d'images
puce | Types de lots
puce | Lots


Propriétés du projet

Vous pouvez consulter et modifier les propriétés du projet dans une boîte de dialogue distincte que vous pouvez afficher en sélectionnant Projet>Propriétés du projet… dans la fenêtre principale.

L'onglet Général affiche le nom du projet, le chemin d'accès aux fichiers du projet et une description du projet. Vous pouvez également spécifier un dossier racine pour l’exportation vers des fichiers dans le champ Chemin de la racine pour l'exportation .

L'onglet Prétraitement d'images affiche les options de prétraitement d'image. Vous pouvez modifier ces options si nécessaire. Pour plus d'informations, consultez la section Options de prétraitement d'image.

L'onglet Reconnaissance contient l'option Supprimer les pages vierges pendant la reconnaissance. Sélectionnez cette option si vous souhaitez supprimer les pages vierges pendant la reconnaissance. Dans cet onglet, vous pouvez également ajouter un classifieur FlexiLayout à votre projet.

Dans l'onglet Vérification de l'intégrité, sélectionnez Exécuter la vérification d'intégrité du lot avant l'exportation si vous souhaitez exécuter un script qui vérifiera l'intégrité du lot avant l'exportation. Cliquez sur Éditer le script de vérification… si le script requiert des modifications.

L'onglet Exportation affiche les paramètres d'exportation par défaut. Vous pouvez modifier ces paramètres si nécessaire. L'option Exécuter un script après l'exportation active le gestionnaire d'exportation. Pour plus d'informations sur le gestionnaire d'exportation, consultez les sections Utilisation de scripts pour décrire une exportation et Exemples de scripts décrivant une exportation. Pour exporter des documents non reconnus, sélectionnez Exporter les documents non reconnus puis définissez les paramètres d'exportation dans la boîte de dialogue Exportation de documents non reconnus, qui apparaît lorsque vous cliquez sur Éditer…

Dans l'onglet Flux de travail, vous pouvez configurer vos flux de travail (pour le type de lot par « défaut »). Pour plus d'informations, consultez la section Configuration des flux de travail.


Types de lot

Types de lots

ABBYY FlexiCapture 9.0 permet de traiter les documents par lots : avant le traitement proprement dit, un lot est créé après quoi les images du document y sont ajoutées. Les lots sont créés automatiquement ou manuellement lors de l'importation d'images (soit lors de la numérisation de documents ou lors de l'importation d'images issues de documents préalablement numérisés). Les paramètres à utiliser pour le traitement des documents sont spécifiés pour chaque type de lot en particulier. Vous pouvez créer plusieurs types de lots pour les ensembles de paramètres de traitement les plus couramment utilisés. Dans ce cas-là, l'opérateur a juste à sélectionner le type de lot approprié.

Un type de lot définit les paramètres de traitement suivants :

  • le prétraitement d'image ;
  • les Définitions de document et l'ordre dans lequel elles doivent être appliquées ;
  • la vérification de l'intégrité du lot ;
  • l'exportation du lot par défaut ;
  • le traitement par lots.

Un type de lot définit également la liste des paramètres d'enregistrement (ce sont des informations textuelles qui caractérisent un lot).

Les types de lots sont créés par l'éditeur de configuration de projet pour chaque projet individuellement.

Pour créer un type de lot :

  1. Démarrez la station de configuration de projet en sélectionnant Démarrer>Programmes>Stations ABBYY FlexiCapture 9.0>Station de projet de configuration puis ouvrez le projet à partir du serveur (Fichier>Ouvrir un projet à partir du serveur…)
  2. Ouvrez la boîte de dialogue Types de lots en sélectionnant Projet>Types de lot…
  3. Cliquez sur Nouveau puis suivez les instructions qui apparaissent à l'écran.

Les types de lots que vous créez sont téléchargés automatiquement sur le serveur d'application et sont accessibles aux opérateurs.

Remarque : Pour permettre aux opérateurs de travailler avec les types de lots nouvellement créés, l'administrateur doit spécifier les types de lots accessibles par chaque opérateur. Cette opération s'effectue lorsque les rôles sont attribués aux opérateurs.


Paramètres d’enregistrement

Les Paramètres d’enregistrement sont des propriétés textuelles permettant d’identifier un lot ou un document spécifique. Ces propriétés peuvent être représentées par la date de numérisation, le nom de l’opérateur de numérisation, etc. Un paramètre d’enregistrement peut être obligatoire ou facultatif.

Les paramètres d’enregistrement peuvent être attribués au lot pendant sa création (si le lot est créé automatiquement à l’aide des profils d’importation). Les paramètres d’enregistrement peuvent également être attribués aux lots et documents de la station de numérisation et envoyés vers ABBYY FlexiCapture avec les images.

Les paramètres d’enregistrement peuvent être configurés respectivement dans l’onglet Paramètres d'enregistrement de la boîte de dialogue Propriétés du lot ou Propriétés du document (cliquez sur Propriétés… dans le menu contextuel).


Téléchargement d'un projet vers le serveur d'application

Dès que vous avez créé un projet, il vous faut le télécharger vers le serveur d'application. Les paramètres du projet, les fichiers de définition de documents, les dictionnaires et les autres données de service seront ainsi copiés sur le serveur d'application.

Important ! Si des lots ont été créés dans le projet, les lots ne seront pas copiés vers le serveur d'application lors du téléchargement.

Pour télécharger votre projet vers le serveur d'application, sélectionnez Fichier>Télécharger le projet sur le serveur… dans le menu principal de la station de configuration de projets.

Remarque : Seul l'administrateur peut créer des nouveaux projets. Un opérateur de configuration de projets peut uniquement configurer les projets déjà créés. Par conséquent, après le téléchargement du projet vers le serveur d'application et une fois les droits nécessaires accordés aux opérateurs de la station par l'administrateur (à partir de la console d'administration et de suivi), l'opérateur de configuration de projets doit ouvrir le projet sur le serveur d'application en sélectionnant Fichier>Ouvrir un projet à partir du serveur… puis régler les paramètres nécessaires (c'est-à-dire créer les définitions de document, importer les profils, spécifier les paramètres d'exportation, etc.).


Définitions de document

La création d'une définition de document est l'aspect principal et le plus délicat de la configuration d'un projet. Elle détermine la qualité des données obtenues au terme du traitement.

Les définitions de document ne peuvent être créées que sur la station de configuration de projet.

Une définition de document décrit l'emplacement des éléments d'un document et indique les champs à utiliser lors de l'extraction des données. Pour créer une définition de document, vous devez spécifier les propriétés des champs ainsi que leur plage de valeurs. Vous devez aussi configurer les paramètres d'exportation des données.

Pour commencer à créer une définition de document, lancez l'assistant de définition de document :

  1. Dans le menu principal d'ABBYY FlexiCapture 9.0, sélectionnez Projet>Définitions de document…
  2. Dans la boîte de dialogue Définitions de document qui s'ouvre, cliquez sur le bouton Nouveau…
  3. Suivez les instructions de l'assistant de définition de document.
puce | Assistant de définition de document
puce | Détection automatique des champs et des éléments statiques
puce | Éléments statiques
puce | Création de champs dans une définition de document
puce | Propriétés de champ
puce | Validation par règle
puce | Configuration de l'exportation de données
puce | Configuration de la présentation des données dans la fenêtre de document
puce | Propriétés de définition de document
puce | Importation d'une définition de document pour les formulaires créés avec ABBYY FormDesigner
puce | Création de définitions de document pour les documents multipages
puce | Création d'une définition de document pour le traitement des documents flexibles
puce | Création de définitions de document pour des documents comportant des annexes
puce | Traitement de documents non structurés
puce | Modification et publication d'une définition de document
puce | Test d'une définition de document


Assistant de la Définition de Document

Assistant de définition de document

Pour créer un nouvelle définition de document, sélectionnez Projet >Définitions de document… dans le menu principal. Dans la boîte de dialogue Définitions de document qui s'ouvre, cliquez sur le bouton Nouveau…. L'Assistant de définition de document s'ouvre pour aider à créer une nouvelle définition de document.

  1. Dans la boîte de dialogue Créer une nouvelle définition de document qui s'ouvre, renseignez les paramètres de définition de document principaux : nom et commentaire, langue utilisée (Langue (lieu) ) et style d'écriture (Style d'écriture ). Par défaut, la liste déroulante ne contient que les langues prises en charge par le dictionnaire. Pour sélectionner une langue non prise en charge par un dictionnaire, activez l'option Afficher toutes les langues. Il est très important de spécifier la langue correctement, car cela détermine si le document sera reconnu correctement ensuite ou non. Le style d'écriture peut varier considérablement d'un pays à l'autre. Il est donc très important d'indiquer le pays, ce qui permet au programme de sélectionner son style d'écriture type.

    Affichage d'exemples de divers styles d'écriture numérique
    - Deux russe
    - Deux américain
    - Cinq « ordinaire » - peut apparaître dans n'importe quel style
    - Cinq japonais
    - Un russe
    - Un allemand
    - Neuf « ordinaire » - peut apparaître dans n'importe quel style
    - Neuf tchèque, avec le cercle à droite
    - Neuf américain sans le « crochet » en bas

    Indiquez le type de texte :

    • ICR (manuscrit) : activez cette option si la plupart des champs des documents doivent être remplis à la main.
    • OCR (imprimé) : activez cette option si les valeurs de la plupart des champs doivent être imprimées. Sélectionnez un type d'impression dans la liste déroulante.

    Remarque : la reconnaissance du texte manuscrit n'est pas prise en charge dans toutes les langues. Pour certaines, ce type de reconnaissance n'est pas disponible. Consultez la section Langues de reconnaissance prises en charge.

    À ce stade, c'est le type de texte par défaut qui est utilisé, mais vous pourrez le modifier pour chaque champ ultérieurement.

    Cliquez sur Suivant pour passer à l'étape suivante.

  2. Pour la seconde étape, chargez l'image de votre page de document pour créer la définition de document. Vous pouvez numériser l'image d'une page non complétée ou la charger à partir d'un fichier.

    Remarque : La définition de document destinée aux formulaires fixes est créée à l'aide d'une image obtenue en numérisant un formulaire non rempli. Ce doit être une image de bonne qualité, sans distorsions (sans défauts, problèmes d'inclinaison, etc.). Pour créer des définitions de document de formulaires avec un arrière-plan en couleur, utilisez des pages numérisées sans filtre de couleur afin que l'arrière-plan ne disparaisse pas pendant la numérisation. (Par la suite, quand vous numériserez des images de page pour la reconnaissance de données, vous sélectionnerez un mode de numérisation qui fera disparaître l'arrière-plan.)

    Si votre document est composé de plusieurs pages, chargez la première page et suivez les recommandations de la section Création de définitions de document pour des documents de plusieurs pages pour ajouter les pages restantes.

    Si vous avez besoin d'une description flexible créée à l'aide d'ABBYY FlexiLayout Studio, activez l'option Charger FlexiLayout et entrez le chemin d'accès du fichier contenant la description flexible. Pour plus d'informations, consultez la section Création d'une Définition de Document pour traiter des documents flexibles.

    Cliquez sur le bouton Suivant.

  3. À l'étape suivante, sélectionnez les types de champs qui doivent être détectés automatiquement dans l'image. Vous pouvez marquer des coches et des champs d'entrée de texte. Le programme détecte automatiquement les champs de texte avec une région, ainsi que les coches rectangulaires. Si les champs d'entrée de votre formulaire n'ont pas de région, et si les coches sont insérées sur fond blanc, vous devrez normalement les mettre en surbrillance manuellement.

    Remarque : le programme recherche toujours automatiquement les ancres. Si le formulaire contient des ancres, elles sont détectées et marquées sur l'image.

    Cliquez sur le bouton Terminer.

Au terme de la procédure de l'Assistant de définition de document, la fenêtre de l'éditeur de définitions de document s'ouvre et vous pouvez effectuer d'autres opérations pour créer une définition de document. À l'étape suivante de la création de la définition de document, vous devez marquer les champs et les éléments statiques de l'image de page et configurer leurs propriétés.


Détection automatique des champs et des éléments statiques

Détection automatique lors de l'ajout d'une image :

Quand une image est ajoutée, le programme détecte toujours les ancres. Si l'image a des ancres standard (des carrés noirs, par exemple), elles sont détectées et marquées. Le programme recherche les champs de texte et les coches si l'utilisateur a activé l'option Texte ou Coches. Il est particulièrement efficace pour détecter automatiquement les champs de texte avec une région, ainsi que les coches rectangulaires. Si les champs d'entrée de votre formulaire n'ont pas de région, et si les coches sont insérées sur fond blanc, vous devrez normalement les mettre en surbrillance manuellement.

Détection automatique dans la fenêtre de l'éditeur de définitions de documents :

Pour la détection automatique dans la fenêtre de l'éditeur de définitions de documents, sélectionnez le mode requis (champs ou éléments statiques), suivi de l'élément de menu Outils > Détecter automatiquement les objets…. Marquez les types de champs ou d'éléments statiques à détecter automatiquement.

Si vous avez besoin de détecter automatiquement des objets de l'image, sélectionnez le mode requis (champs ou éléments statiques) et cliquez sur [image] sur la barre d'outils. Si vous cliquez sur l'élément, il sera marqué d'un rectangle. Le type d'élément sera détecté automatiquement.

Détection automatique d'une région :

Pour qu'une région de champ ou d'élément statique d'un type donné soit détectée automatiquement, procédez comme suit :

  1. Sélectionnez le mode requis (champs ou éléments statiques).
  2. Sélectionnez le type d'un champ ou d'un élément statique à l'aide d'un bouton approprié de la barre d'outils.
  3. Appuyez sur MAJ.
  4. Cliquez à l'intérieur de la région de champ ou d'élément statique.


Éléments statiques

Les éléments statiques sont destinés à l'association de la définition de document et à son identification. Ils ne servent pas à extraire des données.

Pour travailler sur des éléments statiques dans l'éditeur de définitions de document, basculez en mode d'éléments statiques en cliquant sur le bouton [image].

Les éléments statiques peuvent être utilisés pour l'association de la définition de document et son identification. Leur mode d'utilisation est déterminé lors de la configuration des propriétés des éléments. Les ancres servent à associer la définition de document à l'image de formulaire. Des identificateurs sont nécessaires pour déterminer à quels formulaires les pages appartiennent quand plusieurs formulaires sont traités en une même opération. Pour plus d'informations, consultez la section Création de formulaires lisibles par machine.

Les éléments statiques n'ont pas de nom. Ils n'ont que des régions sur l'image.

Quand une définition de document est appliquée à une image de document, le programme recherche les éléments statiques et sélectionne une définition de document en fonction de leur emplacement. La reconnaissance des éléments statiques (texte et code barre) n'est effectuée quand c'est nécessaire à des fins d'identification. Consultez la section Spécification de valeurs d'identificateur.

Le programme travaille avec les éléments statiques des types suivants :

Élément statique | Bouton de barre d'outils
Ancre |
Séparateur |
Texte d'ancre |
Code barre d'ancrage |

Le programme recherche automatiquement les ancres quand une image est ajoutée.

Comment créer un élément statique manuellement :

  1. Sélectionnez le mode d'éléments statiques.
  2. Sélectionnez l'outil qui permet de créer un élément du type requis.
  3. Positionnez le curseur dans le coin de l'élément, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé
    ou
    utilisez la combinaison MAJ+clic dans la région de l'élément.

Un rectangle apparaît autour de la région de l'élément statique. Sa couleur dépend du type d'élément statique. L'élément statique reçoit des propriétés par défaut.

Comment modifier les propriétés d'un élément statique :

  1. Mettez en surbrillance la région de l'élément sur l'image, cliquez avec le bouton droit de la souris et sélectionnez Propriétés… dans le menu contextuel.
  2. Modifiez les propriétés de l'élément statique dans la boîte de dialogue qui s'ouvre :

Pour plus d'informations sur les éléments statiques :

  • Ancres
  • Séparateurs
  • Texte d'ancre
  • Code barre d'ancrage


Ancres

Ancres - les éléments statiques sont mis en surbrillance automatiquement sur l'image.

Pour mettre en surbrillance les ancres manuellement :

  1. Basculez en mode d'éléments statiques.
  2. Sélectionnez [image] sur la barre d'outils.

  3. Positionnez le curseur dans le coin d'une ancre, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé.

    ou

    Utilisez la combinaison MAJ+clic dans la région d'ancre.

Propriétés des ancres

Pour modifier les propriétés d'une ancre :

  1. Mettez l'ancre en surbrillance.
  2. Cliquez avec le bouton droit de la souris sur la région de l'ancre et sélectionnez Propriétés… dans le menu contextuel.
  3. Modifiez les propriétés dans la boîte de dialogue qui s'ouvre :
    • Utiliser pour l'association de la définition de document – cette option doit être activée pour que le programme utilise l'ancre pour l'association de la définition de document (recommandé).
    • Utiliser pour l'identification de la définition de document – activez cette option pour utiliser l'ancre pour l'identification de la définition de document.
    • Type d'ancre – pour que l'association de la définition de document soit correcte, il est important de spécifier le type d'ancre : carré noir, croix ou coin.


Texte d'ancre

Texte d'ancre - élément statique. Il s'agit de tout texte statique de l'image – en-têtes ou signatures d'explication.

Pour mettre en surbrillance un texte d'ancre :

  1. Basculez en mode d'éléments statiques.
  2. Sélectionnez [image] sur la barre d'outils.
  3. Positionnez le curseur dans le coin du texte d'ancre, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé.

    ou

    Utilisez la combinaison MAJ+clic dans la région de texte d'ancre.

Propriétés du texte d'ancre

Pour modifier les propriétés d'un texte d'ancre :

  1. Mettez le texte en surbrillance.
  2. Cliquez à l'aide du bouton droit de la souris dans la région de texte d'ancre et sélectionnez Propriétés… dans le menu contextuel.
  3. Modifiez les propriétés dans la boîte de dialogue qui s'ouvre :

    L'onglet Généralités contient les options suivantes :

    • Utiliser pour l'association de la définition de document – cette option doit être activée pour que le programme utilise le code barre pour l'association de la définition de document.
    • Utiliser pour l'identification de la définition de document – activez cette option pour utiliser le texte d'ancre pour l'identification de la définition de document.
    • Valeur – si vous utilisez un texte d'ancre comme identificateur, vous pouvez définir sa valeur. Pour insérer automatiquement une valeur, cliquez sur le bouton Conseil.
    • Nombre max d'erreurs - permet de spécifier le nombre maximum d’erreurs autorisées dans la chaîne de texte d’ancre.

    Sur l'onglet Reconnaissance, vous devez configurer les options de reconnaissance pour que le texte statique soit reconnu avec une précision maximale :

    • ICR (manuscrit) – activez cette option si le texte statique est manuscrit.

    • OCR (imprimé) – activez cette option si le texte statique est imprimé. Sélectionnez le style d'impression dans la liste déroulante (typographique, imprimante matricielle, machine à écrire, etc.). Consultez aussi la section Types de texte pris en charge.

    • Avancé – utilisez cette option pour sélectionner plusieurs types de texte ou pour spécifier un type de texte personnalisé.

    • Type de données – sélectionnez la langue du texte. Utilisez le bouton Sélectionner… pour effectuer votre sélection.

    • Casse – sélectionnez la casse des lettres de texte statique. Si le texte contient à la fois des minuscules et des majuscules, conservez la valeur Automatique.

    • Orientation : indiquez l'orientation du texte.

    • Activez l'option Une ligne pour du texte d'une ligne.

    • Si le texte ne contient pas d'espaces, c'est-à-dire s'il est constitué d'un seul mot, activez l'option Un mot.

    • Configurez les options de traitement d'image pendant la reconnaissance :
    • Inverser : activez cette option si vous souhaitez inverser l'image.
    • Supprimer la texture : activez cette option si vous souhaitez supprimer la texture.
    • Nettoyer : activez cette option pour supprimer les éléments parasites de l'image.
    • Vider la corbeille de la taille spécifiée uniquement : n'activez cette option que pour supprimer les éléments parasites de la taille indiquée. Indiquez également la taille des éléments parasites. Si cette option est désactivée et que seule l'option Nettoyer est activée, la taille des éléments parasites sera sélectionnée automatiquement.


Séparateurs

Les séparateurs sont des éléments statiques. Ils se présentent sous forme de lignes horizontales ou verticales sur l'image.

Pour mettre en surbrillance des séparateurs :

  1. Basculez en mode d'éléments statiques.
  2. Sélectionnez [image] sur la barre d'outils.
  3. Positionnez le curseur dans le coin d'un séparateur, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé.

    ou

    Utilisez la combinaison MAJ+clic dans la région de code barre.

Propriétés de séparateur

Pour modifier les propriétés d'un séparateur :

  1. Mettez le séparateur en surbrillance.
  2. Cliquez à l'aide du bouton droit de la souris dans la région de séparateur et sélectionnez Propriétés… dans le menu contextuel.
  3. Modifiez les propriétés dans la boîte de dialogue qui s'ouvre :
    • Utiliser pour l'association de la définition de document : cette option doit être activée pour que le programme utilise le séparateur pour l'association de la définition de document.
    • Utiliser pour l'identification de la définition de document : activez cette option pour utiliser le séparateur pour l'identification de la définition de document.


Code barre d'ancrage

Code barre d'ancrage - élément statique.

Important ! Un code barre peut être mis en surbrillance sous forme de champ ou d'élément statique. Tout dépend de la valeur du code barre dans les documents en cours de traitement. Si le code barre est destiné à l'association ou à l'identification de la définition de document, il faut le créer en mode d'éléments statiques. S'il est destiné à l'acquisition de données, il faut le créer en mode de marquage de champ. Les propriétés d'un code barre varient suivant qu'il s'agit d'un champ ou d'un élément statique. Cette section décrit les propriétés d'un élément statique – un code barre d'ancrage. Consultez aussi la section champ de code barre.

Pour mettre en surbrillance un code barre d'ancrage :

  1. Basculez en mode d'éléments statiques.
  2. Sélectionnez [image] sur la barre d'outils.
  3. Positionnez le curseur dans le coin d'un code barre, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé.

    ou

    Utilisez la combinaison MAJ+clic dans la région de code barre.

Propriétés d'un code barre d'ancrage

Pour modifier les propriétés d'un code barre d'ancrage :

  1. Mettez en surbrillance le code barre
  2. Cliquez avec le bouton droit de la souris sur la région de code barre et sélectionnez Propriétés… dans le menu contextuel.
  3. Modifiez les propriétés dans la boîte de dialogue qui s'ouvre :

    L'onglet Généralités contient les options suivantes :

    • Utiliser pour l'association de la définition de document – cette option doit être activée pour que le programme utilise le code barre pour l'association de la définition de document.
    • Utiliser pour l'identification de la définition de document – activez cette option pour utiliser le code barre pour l'identification de la définition de document.
    • Valeur – si vous utilisez un code barre d'ancrage comme identificateur, vous pouvez définir sa valeur. Pour insérer automatiquement une valeur, cliquez sur le bouton Conseil.
    • Requis pour l'association de la définition de document–si cette option est sélectionnée, la définition de document ne sera associée que si le code barre l'est aussi. Sélectionnez cette option si le lot contient un grand nombre de définitions de documents très similaires, qui ne peuvent être distinguées que par la valeur de leurs différents codes barres, voire par la valeur d'un code barre précis. Dans ce cas, si cette option est activée, la sélection de la définition de document se fera plus rapidement. Ne sélectionnez pas cette option si vous souhaitez que la définition de document soit associée même s'il n'y a pas de code barre ou s'il est trop estompé.

    L'onglet Reconnaissance contient différentes options :

    • Type de code – permet d'indiquer le type du code barre (il est en principe déterminé automatiquement).
    • Orientation : indiquez l'orientation du code barre.

    Vous pouvez aussi configurer les options de traitement d'image de code barre :

    • Inverser : activez cette option si vous souhaitez inverser l'image.
    • Supprimer la texture – supprime la texture.
    • Nettoyer – activez cette option pour supprimer les éléments parasites de l'image.
    • Vider la corbeille de la taille spécifiée uniquement : n'activez cette option que pour supprimer les éléments parasites de la taille indiquée. Indiquez également la taille des éléments parasites. Si cette option est désactivée et que seule l'option Nettoyer est activée, la taille des éléments parasites sera sélectionnée automatiquement.


Spécification de valeurs d'identificateur

Les identificateurs servent à déterminer à quel formulaire une page appartient, et à sélectionner une définition de document dont le lot contient plusieurs définitions de document comportant le jeu d'ancres original. Si plusieurs formulaires sont traités simultanément au cours d'une même opération, le programme détermine à quel formulaire la page appartient à partir de l'emplacement des identificateurs.

Si un code barre d'ancrage ou un texte d'ancre est utilisé comme identificateur, vous pouvez indiquer la valeur de cet identificateur. Dans ce cas, lorsque vous appliquez une définition de document, le programme compare les données reconnues dans l'image à la valeur de l'identificateur,et l'association de définition de document ne sera possible que si ces valeurs correspondent.

Les valeurs des identificateurs peuvent être définies dans la boîte de dialogue de propriétés des éléments statiques de l'onglet Généralités. Les valeurs du texte des codes barres peuvent être saisies automatiquement. Le bouton Conseil a été prévu à cet effet.

Remarque : S'il est possible d'identifier une page avec une certitude absolue à partir du seul emplacement des éléments, il ne vous est pas nécessaire de définir ces valeurs. Vous ne devez utiliser cette fonctionnalité que si c'est absolument nécessaire, car si vous attribuez une valeur d'identificateur, le module de reconnaissance se lance au niveau de l'application de définition de document, ce qui ralentit le processus d'association entre définitions de document et images.


Création de champs dans une définition de document

Les champs sont destinés à l'extraction de données.

Pour travailler sur des champs dans l'éditeur de définitions de documents, basculez en mode de marquage de champs en cliquant sur le bouton [image].

Toutes les régions de l'image destinées à l'acquisition de données doivent être marquées comme des champs. Les données contenues dans ces champs sont reconnues, et leurs valeurs peuvent être exportées.

Les champs ont des noms dont les listes sont affichées dans la fenêtre de structure du document. Normalement, les champs ont une région sur l'image, mais vous pouvez aussi créer des champs sans région (par exemple, pour stocker le résultat immédiat).

Le programme reconnaît les types de champs suivants :

Champ | Bouton de barre d'outils
Champ d'entrée de texte |
Coche |
Groupe de coches |
Code barre |
Image |
Tableau |
Groupe de champs |

Pour créer un champ :

  1. Sélectionnez le mode de marquage de champs.
  2. Sélectionnez l'outil qui permet de créer le champ du type requis.
  3. Positionnez le curseur dans un coin du champ, cliquez et faites glisser le curseur à la diagonale jusqu'au coin opposé
    ou
    utilisez la combinaison MAJ+clic dans la région du champ.

Un rectangle apparaît autour de la région du champ. Sa couleur dépend du type de champ.

Le champ créé reçoit un nom par défaut correspondant au texte d'explication le plus proche de la région de champ. Ce nom apparaît dans la liste de champs de l'onglet Champs de la fenêtre de structure du document.

Le champ reçoit des propriétés par défaut.

  • Création de groupes de coches
  • Création de tableaux
  • Création d'un groupe de champs
  • Comment modifier le nom d'un champ
  • Copie, déplacement et suppression de champs
  • Champs sans région
  • Propriétés de champ


Création d'un groupe de coches

Un groupe de coches combine des coches liées de manière logique. Ces coches correspondent normalement à des réponses mutuellement exclusives à la même question. Dans ce cas, le programme sélectionnera une coche du groupe et exportera sa valeur. Toutefois, cette condition n'est pas obligatoire. Vous pouvez autoriser le programme à marquer plus d'une coche d'un groupe (sélectionnez l'option correspondante dans les propriétés du groupe de coches).

Une manière de créer un groupe de coches :

Pour créer un groupe de coches :

  1. Après avoir sélectionné l'outil [image], créez les coches appartenant au groupe.
  2. Sélectionnez l'outil [image] et dessinez un rectangle autour de toutes les coches à inclure dans ce groupe.
  3. Les coches situées à l'intérieur du rectangle seront mises en surbrillance. Leurs noms dans la structure du document seront combinés et placés sous le nom du groupe de coches. Les propriétés des coches appartenant au même groupe sont identiques et ne peuvent pas être modifiées individuellement.

Une autre manière de créer un groupe de coches :

Il n'est pas nécessaire de mettre en surbrillance chaque coche appartenant au groupe.

  1. Sans mettre en surbrillance chaque coche, sélectionnez l'outil [image] et dessinez un rectangle autour de toutes les coches à inclure dans ce groupe.
  2. Les coches contenues dans le rectangle seront automatiquement détectées, nommées et combinées en un groupe.


Création d'un groupe de champs

Les champs peuvent être combinés en groupes, ce qui permet de clarifier la structure du document et de créer des groupes de champs récurrents. Par exemple, une ville, un numéro d'immeuble et une rue peuvent être combinés dans un même groupe Adresse personnelle. Vous pouvez créer des champs pour un groupe Adresse professionnelle en copiant simplement le groupe de champs Adresse personnelle.

Pour créer un groupe de champs :

  1. Créez les champs à inclure dans le groupe.
  2. Sélectionnez l'outil [image] et dessinez un rectangle autour de tous les champs à inclure dans ce groupe.
  3. Les champs situés à l'intérieur du rectangle sont mis en surbrillance. Leurs noms dans la structure du document sont combinés, et placés sous le nom du groupe de champs.

Si le formulaire contient des groupes de champs récurrents, après avoir créé un groupe, vous pouvez créer plusieurs instances du même groupe. Toutes les propriétés de champ ainsi que les règles définies au sein du groupe fonctionneront pour chaque instance du groupe. Consultez la section Champs avec plusieurs instances.

Vous pouvez aussi copier un groupe de champs, mais dans ce cas, un autre groupe indépendant sera créé.


Création d'un tableau

ABBYY FlexiCapture 9.0 permet de créer des définitions de documents pour des documents contenant des tableaux. Les tableaux peuvent simplifier considérablement la configuration des données, leur extraction et leur exportation. Un champ de tableau est un ensemble de colonnes de même type et de lignes récurrentes.

Les colonnes d'un tableau peuvent relever des types suivants :

  • Texte
  • Coches
  • Codes barres
  • Images graphiques

Pour créer un tableau :

  1. Sélectionnez l'outil [image] et dessinez un rectangle autour de la région de tableau. L'en-tête de tableau ne doit pas être inclus dans la région sélectionnée. Des outils de traitement de tableau supplémentaires apparaissent alors sur la barre d'outils.
    Création d'une colonne de tableau
    Création de séparateurs
    Suppression d'un séparateur
  2. Marquez les cellules de tableau en créant le nombre requis de séparateurs. Pour créer des séparateurs, sélectionnez l'outil [image] et cliquez à l'endroit où le séparateur doit être placé. Pour créer des séparateurs verticaux, placez le curseur dans le tableau, faites glisser le pointeur en pointillé à l’emplacement souhaité et cliquez une fois. Pour créer un séparateur horizontal, exécutez la même opération en maintenant la touche Alt enfoncée. Vous pouvez également détecter les séparateurs automatiquement : sélectionnez le tableau créé, puis sélectionnez les éléments Détecter automatiquement les séparateurs verticaux et Détecter automatiquement les séparateurs horizontaux dans le menu local.
  3. Créez des colonnes de tableau. Pour créer une colonne, sélectionnez l'outil [image] et cliquez à l'intérieur de la région de colonne. Sélectionnez un type de colonne dans la liste déroulante.


Comment modifier le nom d'un champ

Modification du nom d'un champ

Pour modifier le nom d'un champ :

  • Cliquez sur le nom du champ dans la structure du document, cliquez avec le bouton droit de la souris, sélectionnez Renommer dans le menu contextuel, puis entrez un nouveau nom.

ou

  • Cliquez dans la région de champ de l'image, puis cliquez avec le bouton droit de la souris et sélectionnez Suggérer un nom dans le menu contextuel. Le champ recevra un nom correspondant au texte d'explication le plus proche de la région de champ.

ou

  • Cliquez dans la région de champ de l'image, puis cliquez avec le bouton droit de la souris et sélectionnez Obtenir le nom de l'image… dans le menu contextuel. Ensuite, mettez en surbrillance avec votre curseur le texte d'explication qui peut être utilisé pour le nom du champ. Le nom du champ est remplacé par le texte sélectionné.

ou

  • Ouvrez la boîte de dialogue propriété de champ et modifiez le nom sur l'onglet Généralités.


Copie, déplacement et suppression de champs

Les champs peuvent être copiés, supprimés, déplacés et modifiés. Les noms des champs copiés portent des numéros différents. Pour mettre en surbrillance plusieurs champs, utilisez la combinaison CTRL+clic. L'action sélectionnée s'appliquera alors à tous les champs en surbrillance.

Pour supprimer un champ, mettez-le en surbrillance, puis appuyez sur la touche SUPPR ou sélectionnez Supprimer dans le menu contextuel. Pour ne supprimer que la région et conserver le champ dans la structure du document, utilisez la combinaison de touches MAJ+SUPPR ou sélectionnez Supprimer la région dans le menu contextuel du champ. Consultez la section Champs sans région.


Champs sans région

Un champ peut ne pas comporter de région sur l'image. Les noms de champ sans région sont marqués d'un astérisque rouge dans la liste. Ces champs peuvent servir à stocker les résultats intermédiaires de calculs effectués sur les valeurs des champs en cours de reconnaissance. Par exemple, vous pouvez combiner les valeurs de plusieurs champs à l'aide de la règle de fusion de valeurs de champs et enregistrer le résultat dans un champ sans région.

Les champs sans région ont toutes les propriétés du type de champ dont ils relèvent. Les valeurs de ces champs peuvent aussi être exportées.

Vous pouvez procéder de deux manières pour créer un champ sans région :

  1. Dans la fenêtre de l'éditeur de définitions de documents, sélectionnez l'élément de menu Éditer>Créer un champ et créez un champ du type requis. Le nom du champ apparaît dans la liste marqué d'un astérisque. Dans ce cas, le programme crée un champ dans la structure du document, mais il ne crée pas sa région sur l'image.
  2. L'autre méthode consiste à supprimer la région d'un champ ordinaire. Mettez en surbrillance le champ requis sur l'image ou dans la liste, puis sélectionnez Supprimer la région dans le menu contextuel. La région est alors supprimée, et le nom du champ est marqué d'un astérisque rouge.

Pour créer une région pour des champs qui n'ont pas de région sur l'image, sélectionnez [image] sur la barre d'outils et mettez en surbrillance la région requise à l'aide du curseur. Si la liste contient des champs marqués d'un astérisque, le programme vous demande de sélectionner le nom de l'un d'eux.


Exclusion d'une région de la reconnaissance

Il est parfois nécessaire d'exclure une région donnée de la reconnaissance, par exemple parce qu'elle contient du texte explicatif qui complique l'extraction des données du champ.

Pour exclure une région de la reconnaissance, sélectionnez l'outil [image] et mettez en surbrillance la région à exclure à l'aide de votre curseur.


Création d'un champ comportant une région non rectangulaire

Il est parfois nécessaire de créer des champs comportant des régions non rectangulaires, comme dans l'exemple du questionnaire.

Pour créer une région de champ non rectangulaire :

  1. Sélectionnez l'outil qui permet de créer un champ du type requis.
  2. Sélectionnez une région rectangulaire, où vous pourrez ajouter ou supprimer des fragments pour créer une région de la forme requise.
  3. Sélectionnez l'outil [image] et assurez-vous que la région rectangulaire est en surbrillance.
  4. Pour ajouter un fragment à la région : appuyez sur la touche Maj (le curseur se transforme en signe « plus ») et sélectionnez un fragment que vous souhaitez ajouter.
  5. Pour exclure un fragment de la région : appuyez sur la touche Alt (le curseur se transforme en signe « moins ») et sélectionnez le fragment que vous souhaitez exclure.


Champ contenant plusieurs régions

Un champ peut contenir plusieurs régions sur l'image. Ces régions peuvent être éloignées les unes des autres, et même être placées sur des pages différentes. Les valeurs de l'ensemble des régions appartenant au même champ sont combinées et exportées ensemble sous la forme d'un même champ.

Il est intéressant de pouvoir créer plusieurs régions pour des champs situés sur plusieurs pages, par exemple pour des tableaux volumineux.

Affichage d'un exemple

Pour créer un champ avec plusieurs régions, procédez comme suit :

  1. Créez un champ.
  2. Mettez-le en surbrillance, cliquez avec le bouton droit de la souris sur sa région et sélectionnez Continuer la région… dans le menu contextuel.
  3. Déplacez l'image de région à l'endroit de votre choix sur la page.


Champs avec plusieurs instances

Vos formulaires peuvent contenir des éléments récurrents. Ce sont les champs et groupes de champs qui apparaissent un certain nombre de fois dans le formulaire et qui décrivent des objets similaires, tels que les mêmes détails pour plusieurs employés, plusieurs enfants, plusieurs comptes, etc. Pour ces objets, des champs avec plusieurs instances sont créés.

Tout champ peut avoir plusieurs instances. Leurs régions peuvent être éloignées les unes des autres, et même être placées sur des pages différentes. Les instances de champ ont les mêmes propriétés. Elles sont exportées vers des fichiers ou des tables de base de données différents.

Vous pouvez créer plusieurs instances pour un groupe de champs si le formulaire contient des groupes récurrents.

Affichage d'un exemple

Pour créer un champ avec plusieurs instances, procédez comme suit :

  1. Créez un champ.
  2. Mettez-le en surbrillance, cliquez avec le bouton droit de la souris sur sa région et sélectionnez Nouvelle instance… dans le menu contextuel.
  3. Déplacez l'image de région à l'endroit de votre choix sur la page.


Propriétés de champ

Il est très important que les propriétés de chaque champ soient configurées correctement. Les propriétés des champs affectent la qualité de reconnaissance et déterminent si les valeurs des champs seront exportées et envoyées à l'opérateur pour vérification. Certaines propriétés sont très importantes pour la reconnaissance des données. C'est par exemple le cas de la méthode de marquage pour un champ d'entrée de texte : si cette propriété n'est pas configurée correctement, le maquage qui ne disparaît pas pendant la numérisation ne sera pas séparé des caractères, et le résultat de la reconnaissance risque de ne pas être satisfaisant.

Les champs de chaque type ont leur propre jeu de propriétés. Quand vous créez un champ d'un certain type sur l'image, il reçoit des propriétés par défaut.

Comment modifier les propriétés d'un champ :

  1. Mettez en surbrillance le nom du champ dans la structure du document, ou la région de champ sur l'image, cliquez avec le bouton droit de la souris et sélectionnez Propriétés… dans le menu contextuel.
  2. Modifiez les propriétés du champ dans la boîte de dialogue qui s'ouvre :

Pour plus d'informations sur les propriétés de champ :

Puce | Champs d'entrée de texte
Puce | Coches
Puce | Groupes de coches
Puce | Codes barres
Puce | Images
Puce | Tableaux
Puce | Groupes de champs


Champ de saisie de texte

Lorsque vous créez un champ de texte, des propriétés par défaut lui sont attribuées. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de propriétés contient cinq onglets rassemblant différents groupes de propriétés :

puce | Propriétés de base
puce | Types de données
puce | Propriétés de reconnaissance
puce | Propriétés de vérification
puce | Validation par règle


Propriétés de base d'un champ

Vous pouvez configurer les propriétés de base d'un champ dans l'onglet Généralités.

Dans cet onglet, le type de champ est affiché sous la forme d'une icône à droite du nom.

  • Nom : nom du champ. Le nom est attribué automatiquement lors de la création du champ et il correspond au texte explicatif le plus proche du champ. Lorsque vous modifiez les propriétés, vous pouvez modifier le nom attribué par défaut. Consultez également Comment modifier le nom d'un champ.
  • Légende – le nom du champ qui sera affiché dans le formulaire de données.
  • Exporter la valeur du champ – cette option doit être activée si vous souhaitez exporter la valeur du champ (option activée par défaut). Il se peut que vous deviez désactiver cette option, si, par exemple, la valeur de ce champ est utilisée pour obtenir la valeur d'un champ calculé (consultez Validation par règle), et que seul le résultat final doit être exporté.
  • Afficher dans le formulaire de données – cette option doit être activée si le champ doit être affiché dans le formulaire de données (option activée par défaut).
  • Ne peut pas être vide – activez cette option si vous souhaitez rendre le champ obligatoire.
  • Lecture seule – activez cette option si le champ doit être accessible uniquement en lecture, c'est-à-dire si l'opérateur ne doit pas pouvoir modifier sa valeur. Vous pouvez activer cette option pour les champs dont la valeur doit être calculée automatiquement à l'aide d'une règle, par exemple pour un champ dont vous prévoyez d'enregistrer la somme ou que vous prévoyez de combiner à d'autres champs (consultez Validation par règle).
  • Champ d'index – activez cette option si vous prévoyez d'utiliser ce champ pour effectuer une indexation de documents. Lorsque vous traiterez les documents, vous aurez la possibilité d'afficher la valeur de ce champ pour chaque document, et de trier et de rechercher des documents à partir de la valeur du champ.
  • Commentaire – vous pouvez saisir tout commentaire.


Types de données d'un champ d'entrée de texte

Il est extrêmement important que vous affectiez un type de données à un champ d'entrée de texte afin d'indiquer au programme quel type de données vous vous attendez à voir dans ce champ : il peut s'agir de nombres uniquement, de lettres d'un certain alphabet, de caractères d'un certain jeu, d'une date ou d'autres éléments de ce genre. Le mécanisme qui permet de définir les types de données est extrêmement flexible, et l'utilisateur peut sélectionner un type de données dans une liste de types disponibles, et créer des types de données adaptés à une tâche spécifique.

Quand vous spécifiez les types de données, vous pouvez confirmer la vérification du format de la valeur entrée et définir des contraintes, limitant par exemple la longueur du texte, ou définissant une valeur minimale et une valeur maximale pour le nombre, ou encore un intervalle de temps et une date.

Les valeurs autorisées pour un champ peuvent également être limitées par une source externe, à savoir- un fichier texte ou une base de données.

Si, pendant le traitement documentaire, la valeur du champ reconnu ne correspond pas au type de données défini, l'opérateur voit un message d'erreur.

Le type de données du champ d'entrée peut être défini sur l'onglet Type de données de la boîte de dialogue de propriétés de champ.

Texte
  1. Si ce champ contient du texte, sélectionnez Texte dans la liste Contenu .
    Une description du type de données sélectionné apparaît dans le champ Détails . Si vous souhaitez modifier la langue, l'utilisation des dictionnaires ou spécifier un type de données plus précis, cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Pour le type de texte standard (soit lorsque Général est sélectionné dans la liste Paramètres du contenu ) vous pouvez utiliser un dictionnaire intégré et/ou un dictionnaire personnalisé. Le cas échéant, la valeur du champ est contrôlée par rapport à ces dictionnaires.
      Pour utiliser un dictionnaire intégré, sélectionnez l'option Utiliser le dictionnaire intégré.
      Pour utiliser un dictionnaire personnalisé, sélectionnez l'option Utiliser un dictionnaire personnalisé et cliquez sur Éditer… pour éditer le dictionnaire. Vous pouvez créer un dictionnaire personnalisé en ajoutant des mots un à un (cliquez sur le bouton Ajouter... pour ajouter un mot) ou en chargeant une liste de mots à partir d'un fichier (cliquez sur le bouton Charger... et spécifiez le chemin d'accès du fichier souhaité portant l'extension *.txt ou *.dic).
    • Le type de texte spécial (soit lorsque Spécial est sélectionné dans la liste Paramètres du contenu ) contient des types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les données de type texte.
Nombre
  1. Si ce champ contient une valeur numérique, sélectionnez Numéro dans la liste Contenu .
    Une description du type de données sélectionné apparaît dans le champ Détails . Si vous souhaitez modifier la langue, un entier en fraction ou inversement ou spécifier un type de données plus précis (par exemple, un nombre à deux chiffres ou un chiffre romain), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez Entier, si le champ doit contenir un nombre entier. Désactivez cette option si le champ doit contenir une fraction.
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans la liste Paramètres du contenu ) pour un entier ou une fraction.
    • Le type de numéro spécial (par exemple, Spécial est sélectionné dans la liste Paramètres du contenu ) contient des types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les nombres.
Important ! N'utilisez pas de type de données numérique pour les champs contenant des numéros qui ne sont pas à proprement parler des valeurs numériques mais plutôt des codes (par exemple les numéros de cartes de crédit, de passeports, etc.). Attribuer le type de données numérique à ces champs peut provoquer des erreurs (par exemple, suppression des zéros du début). Le cas échéant, créez un type de texte personnalisé et spécifiez un alphabet de 0 à 9 (ajoutez, au besoin, une expression normale) ou utilisez le type de données numérique en veillant à sélectionner l'option Traiter la valeur comme un texte. Dans ce dernier cas, la valeur du champ est traitée comme du texte, un dictionnaire personnalisé peut être utilisé pour vérifier la valeur et vous pouvez définir la plage de valeurs possibles comme pour le texte. Pour plus d'informations, consultez la section Contraintes de plage de valeurs pour les données de type texte.
Date
  1. Si ce champ contient une date, sélectionnez Date dans la liste Contenu .
    Une description du type de données sélectionné apparaît dans le champ Détails . Si vous souhaitez modifier la langue ou l'ordre des composants de la date, ajouter des heures ou des jours de la semaine ou spécifier un type de données plus précis (par exemple, les mois sont indiqués en chiffres romains), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez l'ordre souhaité dans la liste Ordre de composant de date .
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans la liste Paramètres du contenu ) pour les données rédigées dans les formats standard. Les options supplémentaires suivantes sont disponibles pour le type de données standard :
      Peut inclure le mois en lettres : utilisez cette option s'il est possible d'écrire les mois en toutes lettres en plus de les écrire sous forme de numéro ;
      Peut inclure le jour de la semaine : utilisez cette option si les dates peuvent inclure le jour de la semaine ;
      Peut inclure l'heure : utilisez cette option si les dates peuvent inclure l'heure.
    • Le type de date spécial (par exemple, Spécial est sélectionné dans la liste Paramètres du contenu ) contient des types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeurs pour la date.
Important ! Si vous ne pouvez pas réduire la date dans un format standard ou que vous n'envisagez pas de traiter les données contenues dans ce champ comme des dates, sélectionnez l'option Traiter la valeur comme un texte. Dans ce cas, la valeur du champ est traitée comme du texte, un dictionnaire personnalisé peut être utilisé pour vérifier la valeur et vous pouvez définir la plage de valeurs possibles comme pour le texte. Pour plus d'informations, consultez la section Contraintes de plage de valeurs pour les données de type texte.
Somme d'argent
  1. Si ce champ contient une somme d'argent, sélectionnez Somme d'argent dans la liste Contenu .
    Dans le champ Détails , une description du type de données sélectionné s'affiche. Si vous souhaitez modifier la langue ou spécifier un type de données plus précis (par exemple, un code de devise), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans le Paramètres du contenu ) pour la somme d'argent si la valeur du champ est un numéro ou un numéro accompagné d'un symbole ou d'un code de devise standard.
    • Le type spécial (par exemple Spécial est sélectionné dans la liste Paramètres du contenu ) contient les types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les données de type texte.
Important ! Si vous ne pouvez pas réduire la somme d'argent dans un format standard ou que vous n'envisagez pas de traiter les données contenues dans ce champ comme des sommes d'argent, sélectionnez l'option Traiter la valeur comme un texte. Dans ce cas, la valeur du champ est traitée comme du texte, un dictionnaire personnalisé peut être utilisé pour vérifier la valeur et vous pouvez définir la plage de valeurs possibles comme pour le texte. Pour plus d'informations, consultez la section Contraintes de plage de valeurs pour les données de type texte.
Adresse
  1. Si ce champ contient une adresse, sélectionnez Adresse dans la liste Contenu .
    Dans le champ Détails , une description du type de données sélectionné s'affiche. Si vous souhaitez modifier la langue ou spécifier un dictionnaire personnalisé ou un type de données plus précis (par exemple, une adresse de courrier électronique ou un code ZIP), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans la liste Paramètres du contenu ) pour l'adresse. L'utilisation d'un dictionnaire personnalisé est recommandée, dans ce cas. Pour utiliser un dictionnaire personnalisé, sélectionnez l'option Utiliser un dictionnaire personnalisé et cliquez sur Éditer… pour éditer le dictionnaire. Vous pouvez créer un dictionnaire personnalisé en ajoutant des mots un à un (cliquez sur le bouton Ajouter... pour ajouter un mot) ou en chargeant une liste de mots à partir d'un fichier (cliquez sur le bouton Charger... et spécifiez le chemin d'accès du fichier souhaité portant l'extension *.txt ou *.dic).
    • Le type spécial (par exemple Spécial est sélectionné dans la liste Paramètres du contenu ) contient les types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les données de type texte.
Nom
  1. Si ce champ contient un nom, sélectionnez NomNom dans la liste Contenu .
    Une description du type de données sélectionné apparaît dans le champ Détails . Si vous souhaitez modifier la langue ou spécifier un dictionnaire personnalisé ou un type de données plus précis (par exemple, un nom ou un patronyme), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans la liste Paramètres du contenu ) pour le nom. L'utilisation d'un dictionnaire personnalisé est recommandée, dans ce cas. Pour utiliser un dictionnaire personnalisé, sélectionnez l'option Utiliser un dictionnaire personnalisé et cliquez sur Éditer… pour éditer le dictionnaire. Vous pouvez créer un dictionnaire personnalisé en ajoutant des mots un à un (cliquez sur le bouton Ajouter... pour ajouter un mot) ou en chargeant une liste de mots à partir d'un fichier (cliquez sur le bouton Charger... et spécifiez le chemin d'accès du fichier souhaité portant l'extension *.txt ou *.dic).
    • Le type spécial (par exemple Spécial est sélectionné dans la liste Paramètres du contenu ) contient les types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les données de type texte.
Code
  1. Si ce champ contient un code constitué de lettres et de chiffres, sélectionnez CodeCode dans la liste Contenu .
    Une description du type de données sélectionné apparaît dans le champ Détails . Si vous souhaitez modifier la langue ou spécifier un dictionnaire personnalisé ou un type de données plus précis (par exemple, un numéro de sécurité sociale), cliquez sur le bouton Éditer… à droite de la description. Dans la boîte de dialogue qui apparaît, vous pouvez :
    • Modifier la langue de reconnaissance de ce champ. Pour modifier la langue, cliquez sur le bouton « ... » situé à droite du champ Langue. Vous pouvez sélectionner une ou plusieurs langues.
    • Sélectionnez le type de données standard (par exemple, Général est sélectionné dans la liste Paramètres du contenu ) pour le code alphanumérique. L'utilisation d'un dictionnaire personnalisé est recommandée, dans ce cas. Pour utiliser un dictionnaire personnalisé, sélectionnez l'option Utiliser un dictionnaire personnalisé et cliquez sur Éditer… pour éditer le dictionnaire. Vous pouvez créer un dictionnaire personnalisé en ajoutant des mots un à un (cliquez sur le bouton Ajouter... pour ajouter un mot) ou en chargeant une liste de mots à partir d'un fichier (cliquez sur le bouton Charger... et spécifiez le chemin d'accès du fichier souhaité portant l'extension *.txt ou *.dic).
    • Le type spécial (par exemple Spécial est sélectionné dans la liste Paramètres du contenu ) contient les types de données prédéfinis, parmi lesquels vous pouvez sélectionner le type de données adapté au champ donné. Lors de la sélection d'un type de données, vous pouvez en lire la description dans la partie inférieure de la boîte de dialogue.
      Vous pouvez également créer votre propre type de données personnalisé si aucun des types prédéfinis ne répond à vos besoins. Pour plus d'informations, consultez la section Création de types de données personnalisés.
  2. Le programme peut traiter automatiquement les valeurs entrées quel que soit le type de données : supprimer les espaces en trop, convertir les lettres en majuscules ou en minuscules ou remplacer automatiquement les caractères ou parties de texte spécifiés. Pour activer le traitement automatique des valeurs, cliquez sur le bouton Éditer… en regard du champ Options de correction automatique . Dans la boîte de dialogue qui s'affiche, sélectionnez les options de traitement automatique requises. Pour plus d'informations, consultez la section Traitement des valeurs entrées.
  3. Vous pouvez également configurer la validation des valeurs du champ de sorte que le programme vérifie si la valeur saisie se situe dans la plage que vous avez spécifiée. Pour spécifier une plage de valeurs pour le champ, cliquez sur le bouton Éditer… situé à droite du champ Validation . Pour plus d'informations, consultez la section Contraintes de plage de valeur pour les données de type texte.


Création de types de données personnalisés

Pour créer un nouveau type de données, sélectionnez l'élément souhaité dans la liste Contenu de l'onglet Type de données dans les propriétés du champ. Vous pouvez sélectionner n'importe quel élément de la liste dont la sémantique correspond à votre type de données personnalisé : ceci n'affecte pas la nature du nouveau type de données mais permet simplement de stocker ce dernier dans la catégorie sélectionnée.

Cliquez sur le bouton Éditer… situé à droite du champ Détails .

Dans la boîte de dialogue qui s'ouvre, sélectionnez Spécial dans le champ Paramètres du contenu .

Cliquez sur le bouton Nouveau… situé à droite du champ Types de données pour la langue sélectionnée .

Suivez les instructions de l'Assistant Création de type de données.

Dans la première fenêtre de l'Assistant, sélectionnez le processus de création de vos données. Vous pouvez créer un nouveau type de données d'après un dictionnaire, une expression normale, un alphabet ou un type de données existant (par exemple, en ajoutant les caractères souhaités à son alphabet ou en développant son dictionnaire).

Pour créer un nouveau type de données reposant sur un dictionnaire, une expression normale ou un alphabet :

  1. Sélectionnez Nouveau type de données basé sur , puis la base à utiliser pour votre nouveau type de données : un dictionnaire, une expression normale ou un alphabet. Sélectionnez ensuite Langue (lieu) pour votre type de données et cliquez sur Suivant.
  2. Si vous choisissez de créer un nouveau type de données basé sur un dictionnaire, l'Assistant vous invite dans la fenêtre suivante à sélectionner le type de dictionnaire à utiliser.
    Sélectionnez Utiliser le dictionnaire intégré si vous souhaitez utiliser le dictionnaire intégré pour la langue sélectionnée dans la fenêtre précédente. Pour vérifier si le dictionnaire contient un mot particulier, cliquez sur Afficher… et saisissez le mot. Lorsque vous cliquez sur le bouton Afficher, les formes flexionnelles du mot ou un message d'avertissement indiquant que le mot recherché ne figure pas dans le dictionnaire s'affichent.
    Sélectionnez Utiliser les dictionnaires personnalisés si vous souhaitez utiliser un dictionnaire personnalisé et cliquez sur Éditer… pour modifier le dictionnaire. Vous pouvez créer un dictionnaire personnalisé en ajoutant des mots un à un (cliquez sur le bouton Ajouter... pour ajouter un mot) ou en chargeant une liste de mots à partir d'un fichier (cliquez sur le bouton Charger... et spécifiez le chemin d'accès du fichier souhaité portant l'extension *.txt ou *.dic). Cliquez sur Suivant.
  3. Si vous choisissez de créer un nouveau type de données reposant sur une expression normale, l'Assistant vous invite à saisir une expression normale. Utilisez le bouton [image] situé à droite du champ de l'expression normale pour compiler votre expression normale. Pour plus d'informations, consultez la section Caractères alphabétiques dans des expressions normales. Cliquez sur Suivant.
  4. Si vous choisissez de créer un nouveau type de données reposant sur un alphabet ou si vous utilisez dans une expression normale des caractères n'appartenant pas à l'alphabet de la langue employée, l'Assistant vous invite à spécifier un alphabet pour votre type de données. Vous pouvez saisir les caractères souhaités directement au clavier ou cliquer sur Personnaliser… et sélectionner les caractères souhaités à la souris.

    Pour ajouter des signes de ponctuation et des caractères exclus (interdits), cliquez sur Paramètres avancés…. Vous pouvez saisir les caractères interdits directement au clavier ou cliquer sur le bouton situé à droite et sélectionner les caractères souhaités à la souris.

    Cliquez sur Suivant.

  5. Dans la dernière fenêtre de l'Assistant, attribuez un nom au nouveau type de données et décrivez-le brièvement. Pour éditer les propriétés d'un type de données nouvellement créé, sélectionnez l'option Éditer les propriétés. Cliquez sur Terminer.

Pour créer un nouveau type de données reposant sur un type de données existant :

  1. Dans la première fenêtre de l'Assistant Création de type de données, sélectionnez Type de données basé sur des types existants. Sélectionnez la ou les langues souhaitées et cliquez sur Suivant.
  2. Dans la fenêtre suivante, sélectionnez le ou les types de données source en fonction de celui ou de ceux que vous souhaitez utiliser pour créer votre nouveau type de données. Les types de données correspondant aux langues sélectionnées apparaissent dans la liste Types de données disponibles dans la partie gauche de la boîte de dialogue. Le dossier Texte contient les langues naturelles sélectionnées dans la première fenêtre. Le dossier Personnalisé contient les types créés par les utilisateurs. Les autres dossiers contiennent les types de données correspondant à la catégorie et au type spécial de contenu.
    Pour sélectionner un type de données source, sélectionnez-le dans le champ Types de données disponibles (maintenez la touche CTRL enfoncée pour en sélectionner plusieurs), puis cliquez sur Ajouter -> pour le transférer dans le volet droit. Cliquez sur Suivant.
  3. Dans la dernière fenêtre de l'Assistant, attribuez un nom au nouveau type de données et décrivez-le brièvement. Pour éditer les propriétés d'un type de données nouvellement créé, sélectionnez l'option Éditer les propriétés. Cliquez sur Terminer.

Le type de données nouvellement créé apparaît dans la liste des types de données prédéfinis lorsque vous sélectionnez le contenu sélectionné à la création du type de données.

Pour spécifier le type de données nouvellement créé pour votre champ :

  1. Sur l'onglet Type de données de la boîte de dialogue des propriétés du champ, sélectionnez l'élément souhaité dans la liste Contenu .
  2. Cliquez sur le bouton Éditer… situé à droite du champ Détails .
  3. Dans la liste Paramètres du contenu , sélectionnez Spécial.
  4. Dans la liste qui s'affiche, sélectionnez le type de données que vous avez créé (les types de données personnalisés sont indiqués par un symbole spécial) et cliquez sur OK.


Contraintes de plage de valeurs pour les types de données texte

Dans la boîte de dialogue Paramètres de validation, vous pouvez spécifier des contraintes de plage de valeurs pour le texte saisi dans le champ.

Remarque : Le programme considérera comme type de texte non seulement les types de données comportant du texte mais aussi les types de données comportant d'autres contenus pour lesquels l'option Traiter la valeur comme un texte est sélectionnée.

  • Longueur maximale – spécifiez la longueur maximale du texte du champ ;
  • Dans le champ Contrainte sur le contenu , sélectionnez Expression normale dans la liste si une expression normale doit être utilisée pour vérifier les valeurs de champ.

    Le bouton [image] peut vous aider à former correctement une expression normale. Pour plus d'informations, consultez la section Caractères alphabétiques dans des expressions normales.

    Pour faire en sorte que les messages d'erreur soient plus lisibles, dans le champ Description de l'expression normale , fournissez une description des expressions normales qui seront utilisées dans les messages d'erreur.

  • Dans le champ Contrainte sur le contenu , sélectionnez Valeurs autorisées dans la liste s'il vous faut spécifier une liste de valeurs autorisées. Pour ajouter une valeur, cliquez sur Ajouter… et saisissez la valeur. Pour modifier une valeur, cliquez sur Éditer…, et pour supprimer une valeur, cliquez sur Supprimer. Pour charger des valeurs possibles depuis un fichier, cliquez sur Charger…
  • Traiter l'erreur de validation comme un avertissement – Sélectionnez cette option si vous souhaitez que toute non conformité aux contraintes que vous avez spécifiée soit considérée comme un avertissement.


Contraintes de plage de valeurs pour les nombres

Pour spécifier les contraintes de plages de valeurs pour les nombres :

  1. Activez l'option Utiliser des contraintes .
  2. Spécifiez les valeurs numériques minimale et maximale.
  3. Traiter l'erreur de validation comme un avertissement – Sélectionnez cette option si vous souhaitez que toute non conformité aux contraintes que vous avez spécifiée soit considérée comme un avertissement.

Quand le programme traitera des documents, il déterminera si la valeur entrée est comprise dans l'intervalle spécifié.


Contraintes de plage de valeurs pour la date

Dans la boîte de dialogue Paramètres de validation, vous pouvez spécifier l'intervalle pour la date saisie dans ce champ.

  1. Activer l'option La date doit appartenir à l'intervalle suivant .
  2. Sélectionnez Fixe pour définir un intervalle de temps fixe ou sélectionnez Date relative à la vérification pour définir un intervalle de temps relatif à la date de vérification du document.
  3. Entrez le début et la fin de l'intervalle.
  4. Traiter l'erreur de validation comme un avertissement – Sélectionnez cette option si vous souhaitez que toute non conformité aux contraintes que vous avez spécifiée soit considérée comme un avertissement.


Traitement de la valeur saisie pour les données de type texte

Traitement des valeurs saisies

Quel que soit le type de données, vous pouvez traiter automatiquement la valeur entrée : supprimer les espaces, convertir les lettres en majuscules ou en minuscules, et remplacer automatiquement certains caractères ou certaines parties de texte. Pour activer le traitement automatique des valeurs de champs, sur l'onglet Type de données de la boîte de dialogue de propriétés du champ, cliquez sur le bouton Éditer… à droite du champ Options de correction automatique .

Sélectionnez les options de traitement automatique souhaitées.

Si l'option N'appliquer la correction automatique qu'une fois après la reconnaissance est sélectionnée, le traitement automatique n'est effectué qu'une fois la valeur du champ reconnue. Dans le cas contraire, le traitement automatique est exécuté à chaque modification de la valeur du champ.

  • Pour effectuer un remplacement automatique des caractères dans la valeur de champ reconnue, cliquez sur le bouton Éditer… à droite du champ Remplacer les caractères . Dans la boîte de dialogue qui s'ouvre, vous pouvez ajouter des caractères à remplacer automatiquement. Si les caractères spécifiés apparaissent dans la valeur de champ reconnue, ils seront remplacés automatiquement.
  • Pour effectuer un remplacement automatique de l'intégralité de la valeur de champ reconnue ou de mots distincts de la valeur de champ, cliquez sur le bouton Éditer… à droite du champ Remplacer le texte .

    Dans la boîte de dialogue qui s'ouvre, vous pouvez ajouter des mots et des expressions à remplacer automatiquement. Pour ne remplacer que l'intégralité des champs, sélectionnez Respecter l'intégralité du contenu du champ.

    Si vous activez l'option Recherche exacte, le programme recherchera et remplacera le mot ou l'expression exacte que vous avez saisi. Sinon, si vous activez l'option Recherche approximative, le programme recherchera et remplacera un mot ou une expression similaire à celui/celle que vous avez saisi. Le nombre d'erreurs autorisées dépend de la longueur du mot.

    Activez l'option Respecter la casse pour que le programme tienne compte de la casse pour remplacer les mots ou expressions.

  • Choisissez l'une des méthodes de conversion des lettres du texte dans la liste déroulante Changer l'emploi des lettres majuscules :

    Aucun – sans conversion ;

    MAJUSCULES – toutes les lettres seront mises en majuscules ;

    minuscules – toutes les lettres seront mises en minuscules ;

    Première majuscule – la première lettre sera mise en majuscule et les suivantes en minuscules.

  • Supprimer les espaces excédentaires – activez cette option si vous souhaitez supprimer les espaces.

Vous pouvez également utiliser un script pour le remplacement automatique : sélectionnez l'option Utiliser un script, cliquez sur Éditer… pour ouvrir l'éditeur de scripts puis saisissez le code du script.


Options de reconnaissance pour les champs de texte

Vous pouvez définir les propriétés de la reconnaissance dans l'onglet Reconnaissance de la boîte de dialogue de propriétés du champ (accessible à l'aide de la commande Propriétés… du menu contextuel). Quand les valeurs des champs sont déterminées correctement, la qualité de la reconnaissance s'améliore considérablement et le risque d'erreurs diminue sensiblement.

  • Ne pas reconnaître (clé du champ d'image - sera entré manuellement) : activez cette option si le champ ne peut pas être reconnu pour une raison ou pour une autre (par exemple, si le texte du champ est composé de lettres fondues) et que l'opérateur doit entrer sa valeur manuellement. Dans ce cas, vous n'avez pas besoin de configurer les autres propriétés de reconnaissance car ce champ ne sera pas reconnu, et il sera demandé à l'opérateur d'entrer la valeur du champ pendant la vérification.

  • ICR (manuscrit) : activez cette option si le texte statique de ce champ est manuscrit.

  • OCR (imprimé) : activez cette option si le texte statique de ce champ est imprimé. Sélectionnez le style d'impression dans la liste déroulante (typographique, imprimante matricielle, machine à écrire, etc.). Consultez aussi la section Types de texte pris en charge.

  • Avancé : utilisez cette option pour sélectionner plusieurs types de texte ou pour spécifier un type de texte personnalisé.

  • Type de marquage : sélectionnez le type de marquage ; pour simplifier votre choix, sélectionnez des exemples dans la liste déroulante. Si le marquage disparaît pendant la numérisation, votre type de marquage aura un espacement fixe (rectangles gris). Si le marquage ne disparaît pas pendant la numérisation et est subdivisé en cellules pour les espaces des caractères, vous devez entrer le nombre total de cellules. Quand le programme détecte automatiquement les champs comportant un tel marquage, le nombre de cellules est déterminé automatiquement.

  • Casse : sélectionnez la casse des lettres de ce champ. Si le champ peut contenir à la fois des majuscules et des minuscules, laissez l'option Automatique activée.

  • Orientation : indiquez l'orientation du texte.

  • Activez l'option Une ligne pour un champ d'une ligne.

  • Pour les champs dont la valeur est toujours composée d'un seul mot, activez l'option Un mot.

  • Configurez les options de traitement d'image pendant la reconnaissance :

  • Inverser : activez cette option si vous souhaitez inverser l'image.
  • Supprimer la texture : activez cette option si vous souhaitez supprimer la texture.
  • Nettoyer : activez cette option pour supprimer les éléments parasites de l'image.
  • Vider la corbeille de la taille spécifiée uniquement : n'activez cette option que pour supprimer les éléments parasites de la taille indiquée. Indiquez également la taille des éléments parasites. Si cette option est désactivée et que seule l'option Nettoyer est activée, la taille des éléments parasites sera sélectionnée automatiquement.


Propriétés de la vérification de champ

La vérification consiste, pour l’opérateur, à contrôler les données reconnues. Les caractères reconnus sans certitude sont indiqués par le programme et soumis à l’opérateur afin qu’il les vérifie. Toutefois, vous pouvez configurer les propriétés d’un champ de telle sorte que le programme le fasse vérifier par l’opérateur même s’il ne contient pas de caractères reconnus sans certitude. Inversement, vous pouvez demander à ce que le programme ne fasse pas vérifier le champ même s’il contient des caractères reconnus sans certitude. L’opérateur voit un caractère reconnu et son image, et soit il confirme le résultat de la reconnaissance, soit il le corrige.

Quand vous créez une définition de document, vous pouvez configurer les options de vérification dans l’onglet Vérification de la boîte de dialogue de propriétés de champ.

Pour que le champ soit vérifié par un opérateur, sélectionnez Nécessite une vérification.

Configurez les paramètres d’affichage de caractères :

  • Si vous devez mettre en surbrillance les caractères pour vérification, sélectionnez Mettre tous les caractères en surbrillance.
  • Si vous n’avez pas besoin de mettre en surbrillance les caractères pour vérification, sélectionnez Ne pas mettre les caractères en surbrillance.
  • Si vous devez mettre en surbrillance les caractères selon la certitude de la reconnaissance, sélectionnez Mettre les caractères en surbrillance si le niveau de confiance est inférieur à et, dans la liste déroulante, spécifiez le plus bas niveau de certitude possible avant que les caractères ne soient mis en surbrillance.

Vérification groupée

  • Pour que les caractères du champ soient envoyés vers la vérification groupée ,sélectionnez Envoyer les caractères vers la vérification de groupe.
  • Sélectionnez les caractères à envoyer vers la vérification groupée : caractères en surbrillance uniquement ou tous les caractères.
  • Sélectionnez l’ensemble de caractères pour la vérification groupée : Chiffres uniquement ou Personnaliser. Modifiez l’ensemble de caractères défini par l’utilisateur en cliquant sur Modifier… si nécessaire.

Vérification de champ

  • Pour que le champ soit envoyé vers la vérification de champ, sélectionnez Envoyer vers la vérification de champ.
  • Sélectionnez le cas de figure où le champ doit être envoyé vers la vérification de champ : toujours ou si le champ comporte des caractères en surbrillance ou des erreurs de format.


Script utilisateur

Script utilisateur (action personnalisée)

Le Script utilisateur est une règle de script personnalisée déclenchée par l’utilisateur lors de l’affichage d’un champ pendant la vérification de champ ou dans l’éditeur de document. Le script est déclenché en cliquant sur … à droite de la valeur du champ.

Vous pouvez définir le script personnalisé dans l’onglet Personnaliser une action. Pour ajouter ou supprimer les informations de champ qui seront disponibles dans le script utilisateur, utilisez les boutons Ajouter… et Supprimer. Pour modifier le script, utilisez la fenêtre Éditeur de script qui s’ouvre lorsque vous cliquez sur Éditer…

Pour rendre le script accessible aux opérateurs, sélectionnez Activer l'action personnalisée.

Pour plus d’informations sur les scripts, consultez la section Utilisation des scripts dans FlexiCapture 9.0.


Coches

Important ! Les propriétés des coches combinées sous forme de groupes sont configurées pour le groupe de coches entier. Si vous essayez de modifier les propriétés d'une coche appartenant à un groupe, une boîte de dialogue permettant de modifier les propriétés du groupe de coches s'ouvre.

Quand vous créez un champ de coche, il reçoit des propriétés par défaut. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de propriétés contient trois onglets, rassemblant différents groupes de propriétés.

puce | Propriétés de base
puce | Propriétés de reconnaissance
puce | Types de données
puce | Propriétés de vérification
puce | Validation par règle


Propriétés de base d'un champ

Vous pouvez configurer les propriétés de base d'un champ dans l'onglet Généralités.

Dans cet onglet, le type de champ est affiché sous forme d'icône à droite du nom.

  • Nom – nom du champ. Le nom est attribué automatiquement lors de la création du champ et il correspond au texte explicatif le plus proche du champ. Lorsque vous modifiez les propriétés, vous pouvez modifier le nom attribué par défaut. Consultez également Comment modifier le nom d'un champ.
  • Légende – le nom du champ qui sera affiché dans le formulaire de données.
  • Exporter la valeur du champ – cette option doit être activée si vous souhaitez exporter la valeur du champ (option activée par défaut). Il se peut que vous deviez désactiver cette option, si, par exemple, la valeur de ce champ est utilisée pour obtenir la valeur d'un champ calculé (consultez Validation par règle), et que seul le résultat final doit être exporté.
  • Afficher dans le formulaire de données – cette option doit être activée si le champ doit être affiché dans le formulaire de données (option activée par défaut).
  • Lecture seule – activez cette option si le champ doit être accessible uniquement en lecture, c'est-à-dire si l'opérateur ne doit pas pouvoir modifier sa valeur. Vous pouvez activer cette option pour les champs dont la valeur doit être calculée automatiquement à l'aide d'une règle, par exemple pour un champ dont vous prévoyez d'enregistrer la somme ou que vous prévoyez de combiner à d'autres champs (consultez Validation par règle).
  • Commentaire – vous pouvez saisir tout commentaire.


Types de données pour des coches

Le type de données des coches peut être défini sur l'onglet Type de données de la boîte de dialogue de propriétés de champ.

Il détermine les valeurs à affecter au champ de coche pour une coche sélectionnée et pour une coche non sélectionnée.

Sélectionnez les options appropriées pour les valeurs de coche :

  • Oui / Non : si la coche est sélectionnée, la valeur du champ est "Oui". Si elle n'est pas sélectionnée, la valeur est "Non".
  • 1 / 0 : Si la coche est sélectionnée, la valeur du champ est 1. Si elle n'est pas sélectionnée, la valeur est 0.
  • <Nom de la coche> / Vide : si la coche est sélectionnée, la valeur du champ correspond au nom de la coche. Si elle n'est pas sélectionnée, le champ reçoit une valeur vide.
  • Personnalisé : en activant cette option, vous pouvez entrer vos valeurs personnalisées. Sélectionné à une coche sélectionnée et Non sélectionné à une coche non sélectionnée.


Propriétés de la reconnaissance de coche

Vous pouvez définir les propriétés de la reconnaissance dans l'onglet Reconnaissance de la boîte de dialogue de propriétés du champ (option Propriétés… du menu contextuel de ce champ). Quand les valeurs des champs sont déterminées correctement, la qualité de la reconnaissance s'améliore considérablement et le risque d'erreurs diminue sensiblement.

  • Type de coche : sélectionnez le type de coche. Cette propriété est très importante pour la reconnaissance correcte des coches.

    Carré : sélectionnez ce type de coche si les coches sont placées dans des cadres carrés restreints.

    Sans cadre : sélectionnez ce type de coche si les coches sont placées sur un arrière-plan blanc sans cadre.

    Automatique : si vous sélectionnez ce type, le programme déterminera automatiquement le type de coche.
    Important ! Notez que dans ce cas, la coche du formulaire ne doit pas être sélectionnée. En effet, le programme détecte si la coche est sélectionnée ou non en comparant l'image de la coche sur un document traité à l'image du formulaire vierge utilisé pour créer la définition de document.

  • Autoriser les corrections : activez cette option si vous souhaitez autoriser les corrections pour les coches. Dans ce cas, les coches retouchées seront considérées comme non sélectionnées. Si vous avez sélectionné le type Automatique, vous ne pouvez pas autoriser les corrections pour ces coches.

    • Vous pouvez configurer les options de traitement d'image de champ :

  • Inverser : activez cette option si vous souhaitez inverser l'image.
  • Supprimer la texture : activez cette option si vous souhaitez supprimer la texture.
  • Nettoyer : activez cette option pour supprimer les éléments parasites de l'image.
  • Vider la corbeille de la taille spécifiée uniquement : n'activez cette option que pour supprimer les éléments parasites de la taille indiquée. Indiquez également la taille des éléments parasites. Si cette option est désactivée et que seule l'option Nettoyer est activée, la taille des éléments parasites sera sélectionnée automatiquement.


Propriétés de la vérification de champ

La vérification consiste, pour l’opérateur, à contrôler les données reconnues. Les caractères reconnus sans certitude sont indiqués par le programme et soumis à l’opérateur afin qu’il les vérifie. Toutefois, vous pouvez configurer les propriétés d’un champ de telle sorte que le programme le fasse vérifier par l’opérateur même s’il ne contient pas de caractères reconnus sans certitude. Inversement, vous pouvez demander à ce que le programme ne fasse pas vérifier le champ même s’il contient des caractères reconnus sans certitude. L’opérateur voit un caractère reconnu et son image, et soit il confirme le résultat de la reconnaissance, soit il le corrige.

Quand vous créez une définition de document, vous pouvez configurer les options de vérification dans l’onglet Vérification de la boîte de dialogue de propriétés de champ.

Pour que le champ soit vérifié par un opérateur, sélectionnez Nécessite une vérification.

  • Pour que les caractères du champ soient envoyés vers la vérification groupée , sélectionnez Envoyer les caractères vers la vérification de groupe.
  • Sélectionnez les caractères à envoyer vers la vérification groupée : caractères en surbrillance uniquement ou tous les caractères.


Groupes de coches

Important ! Les propriétés de groupe s'appliquent à toutes les coches appartenant à un groupe.

La valeur d'un groupe de coches est la liste des noms des coches sélectionnées, séparés par un point-virgule (;), ou une chaîne vide si aucune coche n'a été sélectionnée.

Quand vous créez un groupe de coches, il reçoit des propriétés par défaut. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de propriétés contient trois onglets, rassemblant différents groupes de propriétés.

puce | Propriétés de base
puce | Propriétés de reconnaissance
puce | Types de données
puce | Propriétés de vérification
puce | Validation par règle


Types de données pour les groupes de coches

Le type de données des groupes de coches peut être défini sur l'onglet Type de données de la boîte de dialogue de propriétés de champ.

Autoriser les sélections vides : activez cette option si au moins une coche du groupe doit être sélectionnée. Dans ce cas, si aucune coche du groupe n'est sélectionnée, le programme affiche un avertissement correspondant.

Autoriser les sélections multiples : activez cette option pour autoriser la sélection de plusieurs coches du groupe. Si cette option est désactivée, le programme affiche un avertissement quand plusieurs coches du groupe sont sélectionnées.

Pour modifier le nom d'une coche, sélectionnez la ligne de votre choix, puis cliquez sur Éditer…. Dans la boîte de dialogue qui s'ouvre, indiquez un nouveau nom pour le champ de coche et un nouveau nom à affecter à la coche pendant l'exportation.

Vous pouvez définir les valeurs à exporter lorsqu'aucun champ de coche n’est sélectionné et lorsque plusieurs champs de coche sont sélectionnés. Pour ce faire, sélectionnez soit <Aucun élément sélectionné> soit <Plusieurs éléments…> dans la liste, cliquez sur Éditer… puis, dans la boîte de dialogue qui s'ouvre précisez la valeur désirée dans le champ Valeur exportée . Si aucune valeur d’exportation n’est spécifiée : a) une chaîne vide est exportée si aucun champ de coche n’est sélectionné, et b) les valeurs des champs de coches sélectionnés sont spécifiées (une virgule faisant office de séparateur) si plusieurs champs sont sélectionnés.

Création d'un groupe de coches


Code barre

Quand vous créez un champ de code barre, il reçoit des propriétés par défaut. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de modification des propriétés contient cinq onglets, rassemblant différents groupes de propriétés.

Important ! Un code barre peut être mis en surbrillance sous forme de champ ou d'élément statique. Tout dépend de la valeur du code barre dans les documents en cours de traitement. Si le code barre est destiné à l'association ou à l'identification de la définition de document, vous devez le créer en mode d'éléments statiques. S'il est destiné à l'acquisition de données, il faut le créer en mode de marquage de champ. Les propriétés d'un code barre varient suivant qu'il s'agit d'un champ ou d'un élément statique. Cette section décrit les propriétés de champ. Consultez aussi la section code barre d'ancrage.

puce | Propriétés de base
puce | Propriétés de reconnaissance
puce | Propriétés de vérification
puce | Validation par règle


Propriétés de la reconnaissance de codes barres

Vous pouvez définir les propriétés de la reconnaissance dans l'onglet Reconnaissance de la boîte de dialogue de propriétés du champ (option Propriétés… du menu contextuel de ce champ). Quand les valeurs des champs sont déterminées correctement, la qualité de la reconnaissance s'améliore considérablement et le risque d'erreurs diminue sensiblement.

  • Ne pas reconnaître (clé du champ d'image - sera entré manuellement) : activez cette option si la valeur du code barre doit être entrée manuellement par l'opérateur. Dans pareil cas, vous n'avez pas besoin de configurer les paramètres de reconnaissance restants.
  • Type de code : indiquez le type du code barre (il est en principe déterminé automatiquement).
  • Orientation : indiquez l'orientation du code barre.

Vous pouvez aussi configurer les options de traitement d'image de code barre :

  • Inverser : activez cette option si vous souhaitez inverser l'image.
  • Supprimer la texture : activez cette option si vous souhaitez supprimer la texture.
  • Nettoyer : activez cette option pour supprimer les éléments parasites de l'image.
  • Vider la corbeille de la taille spécifiée uniquement : n'activez cette option que pour supprimer les éléments parasites de la taille indiquée. Indiquez également la taille des éléments parasites. Si cette option est désactivée et que seule l'option Nettoyer est activée, la taille des éléments parasites sera sélectionnée automatiquement.


Propriétés de la vérification de champ

La vérification consiste, pour l’opérateur, à contrôler les données reconnues. Les caractères reconnus sans certitude sont indiqués par le programme et soumis à l’opérateur afin qu’il les vérifie. Toutefois, vous pouvez configurer les propriétés d’un champ de telle sorte que le programme le fasse vérifier par l’opérateur même s’il ne contient pas de caractères reconnus sans certitude. Inversement, vous pouvez demander à ce que le programme ne fasse pas vérifier le champ même s’il contient des caractères reconnus sans certitude. L’opérateur voit un caractère reconnu et son image, et soit il confirme le résultat de la reconnaissance, soit il le corrige.

Quand vous créez une définition de document, vous pouvez configurer les options de vérification dans l’onglet Vérification de la boîte de dialogue de propriétés de champ.

Pour que le champ soit vérifié par un opérateur, sélectionnez Nécessite une vérification.

  • Pour que le champ soit envoyé vers la vérification de champ, sélectionnez Envoyer vers la vérification de champ.
  • Sélectionnez le cas de figure où le champ doit être envoyé vers la vérification de champ : toujours ou si le champ comporte des caractères en surbrillance ou des erreurs de format.


Images

Lorsque vous créez une image, des propriétés par défaut lui sont attribuées. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de modification de propriétés contient quatre onglets rassemblant différents groupes de propriétés.

puce | Propriétés de base
puce | Propriétés de reconnaissance
puce | Exportation d'images
puce | Validation par règle


Propriétés de base d'un champ

Vous pouvez configurer les propriétés de base d'un champ dans l'onglet Généralités.

Dans cet onglet, le type de champ est affiché sous forme d'icône à droite du nom.

  • Nom – nom du champ. Le nom est attribué automatiquement lors de la création du champ et il correspond au texte explicatif le plus proche du champ. Lorsque vous modifiez les propriétés du champ, vous pouvez aussi modifier le nom affecté par défaut. Consultez également Comment modifier le nom d'un champ.
  • Légende – le nom du champ qui sera affiché dans le formulaire de données.
  • Exporter la valeur du champ – activez cette option si vous souhaitez exporter la valeur du champ (option est activée par défaut). Il se peut que vous deviez désactiver cette option, si, par exemple, la valeur de ce champ est utilisée pour obtenir la valeur d'un champ calculé (consultez Validation par règle), et que seul le résultat final doit être exporté.
  • Afficher dans le formulaire de données – activez cette option si le champ doit être affiché dans le formulaire (option activée par défaut).
  • Commentaire – vous pouvez saisir tout commentaire.


Propriétés de la reconnaissance d'image graphique

Vous pouvez définir les propriétés de la reconnaissance dans l'onglet Reconnaissance de la boîte de dialogue de propriétés du champ (option Propriétés… du menu contextuel de ce champ).

  • Exclure de la reconnaissance : activez cette option si la région d'un champ d'image graphique doit être exclu des régions de reconnaissance des autres champs (cette option n'est disponible que pour un champ d'image graphique, et elle assure la compatibilité avec les modèles FormReader 6.5).


Exportation d'images

Dans une définition de document, vous pouvez sélectionner les paramètres d'exportation de chaque image graphique. Pour sélectionner les paramètres d'exportation des images, cliquez avec le bouton droit de la souris sur le champ souhaité, sélectionnez Propriétés…, puis cliquez sur l'onglet Exportation. Vous pouvez sélectionner l'une des options suivantes :

  • Type de fichier :(TIFF, JPEG, BMP, JPEG2000, PCX packbits, PNG).
  • Qualité : pour les fichiers TIFF, JPEG et JPEG2000, vous pouvez sélectionner la qualité du fichier obtenu (qualité optimale à minimale).
  • Type de couleur : couleur, niveaux de gris, demi-ton (noir et blanc).

Vous pouvez également définir la résolution de l'image obtenue : sélectionnez Changer la résolution en et saisissez la résolution souhaitée ou sélectionnez-la dans la liste.


Tableaux

Lorsque vous créez un tableau, des propriétés par défaut lui sont attribuées. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de modification de propriétés contient trois onglets rassemblant différents groupes de propriétés.

puce | Propriétés de base
puce | Colonnes
puce | Validation par règle


Colonnes de tableaux

L'onglet Colonnes affiche la liste des colonnes de ce tableau. Chaque colonne de tableau relève d'un certain type de champ (consultez Création d'un tableau) et a des propriétés spécifiques à ce type de champ.

Pour modifier les propriétés de l'une des colonnes :

  1. Sélectionnez son nom dans la liste.
  2. Cliquez sur le bouton Propriétés….


Groupe de champs

Quand vous créez un groupe de champs, il reçoit des propriétés par défaut. Vous pouvez modifier ces propriétés en sélectionnant Propriétés… dans le menu contextuel. La boîte de dialogue de modification de propriétés contient trois onglets, rassemblant différents groupes de propriétés.

puce | Propriétés de base
puce | Champs
puce | Validation par règle


Champs groupés

L'onglet Fields affiche la liste des champs qui forment le groupe.

Pour modifier les propriétés de l'un des champs :

  1. Sélectionnez son nom dans la liste.
  2. Cliquez sur le bouton Propriétés….

Création d'un groupe de champs


Champ de service

Lorsqu’un champ de service est créé, il possède les propriétés par défaut qui peuvent être configurées en cliquant sur Propriétés… dans le menu contextuel. La boîte de dialogue Propriétés présente deux onglets, un pour chaque groupe de propriétés

Propriétés de champ de base
Propriétés de la source de données


Propriétés de la source de données

Dans l’onglet Source des données, la source et le type de données du champ de service sont spécifiés :

  1. Dans la liste Source , sélectionnez une source de données pour le champ.
  2. Si vous sélectionnez Paramètres d'enregistrement du document ou Paramètre d'enregistrement de lot, spécifiez le nom de la propriété d’enregistrement à utiliser en tant que source de donnée dans le champ Nom du paramètre .
  3. Pour le Type de données, sélectionnez le type de données souhaité du champ de service.


Vérification par règle

Validation par règle

Les règles décuplent les possibilités de contrôle automatique des résultats. Elles permettent de définir des contraintes de données, c'est-à-dire de spécifier des conditions pour les valeurs de certains champs.

Si les valeurs des documents ne remplissent pas ces conditions, les pages correspondantes sont signalées par un avertissement. Le principal objectif de la validation par règle est de vérifier l'intégrité des données du document.

Vous pouvez également traiter les valeurs entrées à l'aide de règles. Vous pouvez par exemple fusionner les valeurs de plusieurs champs ou remplacer les valeurs reconnues par les valeurs correspondantes de la base de données.

ABBYY FlexiCapture 9.0 permet de configurer les règles des types suivants :

  • Somme de contrôle : vérifie la somme de plusieurs champs. La somme de valeurs de champs spécifiques est comparée à un nombre prédéfini ou à la valeur d'un autre champ.
  • Comparer les champs : compare les valeurs de plusieurs champs.
  • Vérification de base de données : vérifie les valeurs entrées en les comparant aux valeurs d'une base de données précise.
  • Fusionner les champs : fusionne les valeurs de plusieurs champs. Vous pouvez ajouter des séparateurs en fusionnant des champs.
  • Script : vous pouvez décrire les contraintes à l'aide d'un script.
  • Somme en chiffres - Somme en lettres (Russe) : compare une somme numérique et la même somme écrite en mots (en russe uniquement).

Vous pouvez affecter un statut d'erreur ou d'avertissement à la règle. Quand une condition n'est pas remplie, le champ est marqué d'un indicateur rouge (erreur) ou jaune (avertissement). Consultez la section Validation par règle.

Les règles peuvent être configurées sur l'onglet Règles de la boîte de dialogue de propriétés de l'objet (champ, section, document, etc.).

Dans la structure hiérarchique, les règles sont stockées au niveau de l'objet dans lequel elles ont été créées : il peut s'agir d'un champ, d'une section de définition de document ou de la définition de document elle-même. Le plus souvent, le niveau de stockage de la règle importe peu. Toutefois, si vous créez une définition de document avec une structure complexe, avec des groupes de champs ou des éléments récurrents, vous devez faire attention à l'endroit où vous stockez les règles. Par exemple, si vous avez un groupe de champs et que certains champs du groupe sont liés à une règle, quand vous créerez une nouvelle instance de ce groupe, la règle ne sera copiée et satisfaite dans le nouvel objet que si elle est stockée dans le groupe lui-même ou dans l'un de ses champs, et non à un niveau supérieur. À partir de la boîte de dialogue de propriétés de l'objet, vous pouvez afficher les règles qui opèrent sur cet objet ou qui sont stockées dans cet objet, ainsi que les objets subordonnés. Vous pouvez spécifier les règles à afficher en sélectionnant l'une des valeurs de la liste déroulante Présenter dans la liste :

  • Règles gérant l'objet : affiche les règles applicables à l'objet en cours (c'est-à-dire l'objet dont la boîte de dialogue de propriétés est actuellement ouverte).
  • Règles stockées dans l'objet : affiche les règles stockées dans l'objet en cours.
  • Règles stockées dans l'objet et ses enfants : affiche les règles stockées dans l'objet en cours et dans ses objets enfants (pour un groupe de champs, par exemple, les règles stockées dans le groupe et dans tous ses champs sont affichées).

Remarque : vous ne pouvez créer une règle qu'en mode d'affichage Règles stockées dans l'objet ou Règles stockées dans l'objet et ses enfants, et non en mode Règles gérant l'objet.

Chaque règle a un statut d'erreur ou d'avertissement. Si vous tentez d'exporter des documents présentant des erreurs de règle, le programme affichera un message d'erreur. Les avertissements relatifs aux règles n'empêchent pas l'exportation d'avoir lieu.

Somme de contrôle
Comparaison de champs
Contrôle d'une base de données
Fusion de champs
Somme en chiffres - somme en lettres

Définition d'une règle à l'aide d'un script


Règle de somme de contrôle de valeurs

Cette règle sert à vérifier la somme des valeurs de plusieurs champs. La somme de valeurs de champs spécifiques est comparée à un nombre prédéfini ou à la valeur d'un autre champ. Par exemple, si votre document contient des champs avec un salaire, une prime, d'autres paiements compensatoires et un champ de total, vous pouvez configurer une règle qui vérifiera si la somme des valeurs de champ correspond à la valeur du champ de total. Si les valeurs ne correspondent pas, un message d'erreur sera affiché.

Pour créer une règle de somme de contrôle, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de documents (option Définition de Document >Propriétés de la définition de document… du menu de l'éditeur de Définitions de Document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste de types de règles, sélectionnez Somme de contrôle et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant.
  6. Ajoutez à la liste Résumer les valeurs des champs les champs dont vous souhaitez vérifier la somme. Utilisez le bouton Ajouter… pour ajouter des champs.
  7. Activez l'une des options suivantes :
    • champ : activez cette option pour comparer la somme à la valeur du champ de résultat. Sélectionnez le nom de ce champ à l'aide du bouton Sélectionner….
    • nombre : activez cette option pour comparer la somme à un nombre précis. Entrez ce nombre.
  8. Partie fractionnelle des valeurs comparées : entrez le nombre de chiffres après la virgule dans le nombre pour déterminer la précision de la comparaison.
  9. Activez l'option Au moins deux éléments non vides à additionner si vous souhaitez additionner au moins deux éléments non vides.
  10. Cliquez sur Terminer pour terminer la création de la règle. Le nom de cette règle s'affiche sur l'onglet Règles.


Règle de comparaison de valeurs entre plusieurs champs

Cette règle permet de vérifier les valeurs de plusieurs champs. Elle est utile si votre document contient plusieurs champs dont les valeurs doivent être identiques. Si ces valeurs ne correspondent pas, un message d'erreur de règle s'affiche pour le document.

Pour créer une règle de contrôle de valeurs, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de documents (option Définition de document >Propriétés de la définition de document… du menu de l'éditeur de définition de document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste des types de règles, sélectionnez Comparer les champs et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant.
  6. Ajoutez à la liste Champs à comparer les champs dont vous voulez comparer les valeurs. Utilisez le bouton Ajouter… pour ajouter des champs.
  7. Sélectionnez le type de correspondance :
    • Exact : pour une correspondance de valeur exacte.
    • Approximative : pour une correspondance de valeur approximative. Dans ce cas, les champs seront comparés sans tenir compte la casse et les caractères, et une erreur est autorisée pour les valeurs de champ dépassant 4 caractères.
  8. Cliquez sur Terminer pour terminer la création de la règle. Le nom de cette règle s'affiche dans l'onglet Règles.


Règle de contrôle de base de données

Le contrôle des champs d'une base de données consiste à comparer la valeur reconnue pour un champ aux valeurs de la table contenue dans la base de données. Ce contrôle est considéré comme satisfaisant si les deux valeurs correspondent. Si elles ne correspondent pas, un message d'erreur de règle s'affiche.

Pour créer une règle de contrôle de base de données, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de documents (option Définition de Document >Propriétés de la définition de document… du menu de l'éditeur de Définitions de Document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste de types de règles, sélectionnez Vérification de base de données et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant.
  6. Établissez une connexion avec une base de données. Vous pouvez configurer les paramètres requis dans la boîte de dialogue Propriétés de la liaison de données qui s'ouvre quand vous cliquez sur le bouton Définir….
  7. Sélectionnez un schéma de base de données et une table dans la liste.
  8. Établissez une correspondance entre les champs de la définition de document et ceux de la table de base de données. Pour ce faire, cliquez sur le bouton Ajouter…. La boîte de dialogue Liaison de champ s'ouvre. Sélectionnez dans la liste un champ de définition de document et le champ correspondant dans la table de base de données. Sélectionnez le type de correspondance :
    • Exact : les valeurs de champ doivent correspondre exactement.
    • Approximative : les valeurs de champ ne doivent correspondre que partiellement. Dans ce cas, le programme recherche les mots les plus proches, pour lesquels le moins de lettres ont été ajoutées, supprimées ou remplacées pour obtenir le mot d'origine. Le nombre d'erreurs autorisées dépend de la longueur du mot d'origine. Activez l'option Copier la valeur du champ à partir de la base de données si vous souhaitez que la valeur du champ du document soit remplacée par la valeur correspondante de la base de données.
    • Ne pas comparer : aucune comparaison n'est effectuée, et la valeur du champ est remplacée par une valeur de la base de données (option Copier la valeur du champ à partir de la base de données activée).
  9. Utilisez les boutons Ajouter…, Éditer… et Supprimer pour ajouter, modifier ou supprimer des liens entre les champs.


Règle de fusion de valeurs de champs

Cette règle permet de fusionner les valeurs de plusieurs champs. Les valeurs de champs fusionnées peuvent être séparées par un point, un espace ou un autre séparateur.

Pour créer une règle de fusion de valeurs, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de documents (option Définition de Document >Propriétés de la définition de document… du menu de l'éditeur de Définitions de Document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste de types de règles, sélectionnez Fusionner les champs et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant. Une erreur s'affiche pour cette règle si, par exemple, l'un des champs inclus dans la fusion a été supprimé de la définition de document.
  6. Ajoutez à la liste Champs à fusionner les champs à inclure dans la fusion. Utilisez le bouton Ajouter… pour ajouter des champs. Sélectionnez Champ de résultat : ce champ sert à stocker le résultat de la fusion. Saisissez le séparateur requis dans la fenêtre Séparateur .
  7. Par défaut, des séparateurs sont ajoutés entre les valeurs non vides. Si vous souhaitez que le programme ajoute systématiquement des séparateurs, même pour les valeurs de champ vierge, activez l'option Placer des séparateurs pour les valeurs de champ vides.
  8. Cliquez sur Terminer pour terminer la création de la règle. Le nom de cette règle s'affiche sur l'onglet Règles.

Le résultat de la fusion peut être stocké dans n'importe quel champ Définition de document. À cet effet, il est pratique d'utiliser des champs sans régions.

Si vous n'avez besoin d'exporter que la valeur du champ de résultat, et non les valeurs des champs inclus dans la fusion, désactivez l'option Exporter la valeur du champ pour ces champs.


Définition d'une règle à l'aide d'un script

ABBYY FlexiCapture 9.0 permet de configurer une règle de contrôle de données à l'aide d'un script.

Pour créer une telle règle, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de documents (option Définition de Document >Propriétés de la définition de document… du menu de l'éditeur de Définitions de Document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste de types de règles, sélectionnez Script et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant.
  6. La liste Champs disponibles répertorie les objets disponibles. Vous pouvez ajouter et supprimer des champs à l'aide des boutons Ajouter… et Supprimer. Les valeurs des champs dont l'option Lecture seule est activée ne sont accessibles qu'en lecture, tandis que celles des champs dont cette option est désactivée peuvent être écrasées à l'aide d'un script.
  7. Cliquez sur le bouton Editer… pour ouvrir une fenêtre spéciale pour la modification du script.
  8. Sélectionnez le langage de script et entrez le texte du script.
  9. Pour vérifier le script, sélectionnez Outils>Vérifier le scriptdans le menu principal.
  10. Enregistrez le script en sélectionnant Fichier>Enregistrer.
  11. Cliquez sur Terminer. La règle nouvellement créée s'affiche dans la liste de l'onglet Règles.

Remarque : les procédures que vous souhaitez utiliser dans plusieurs règles doivent être rédigées sur un module général de règles accessible depuis l’éditeur de scripts. Depuis la liste déroulante de la barre d'outils de l’éditeur de scripts, sélectionnez Module de script global de règle. Le module général de règles est également accessible depuis l'éditeur de définitions de document (Définition de document>Modules de scripts>Règle de script…).

Pour plus d'informations sur la création de règles à l'aide d'un script, consultez la section Utilisation de scripts dans FlexiCapture 9.0


Somme en chiffres - somme en lettres

Important ! Vous ne pouvez définir cette règle que si vous sélectionnez le rsse comme langue de reconnaissance pour votre définition de document (Définition de document>Propriétés de la définition de document…).

Cette règle a pour objet de comparer une somme numérique à la somme correspondante en lettres (alphabet russe). Si les deux sommes diffèrent, un message s'affiche indiquant que la règle a renvoyé une erreur.

Pour créer une « somme en chiffres - somme en lettres », procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés du champ (option Propriétés… du menu contextuel) ou la boîte de dialogue Propriétés de la définition de document (option Définition de Document >Propriétés de la définition de document… du menu de l'éditeur de Définitions de document).
  2. Accédez à l'onglet Règles.
  3. Cliquez sur le bouton Nouvelle règle….
  4. Dans la liste de types de règles, sélectionnez Somme en chiffres - Somme en lettres (Russe) et cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type : Avertissement ou Erreur, puis cliquez sur Suivant.
  6. Cliquez sur le bouton Sélectionner… situé à droite du champ Somme en chiffres , puis sélectionnez le champ du la Définition de document qui contient la somme numérique.
  7. Cliquez sur le bouton Sélectionner… situé à droite du champ Somme en mots , puis sélectionnez le champ de la définition de document qui contient la somme en mots.
  8. Cliquez sur Terminer pour terminer la création de la règle. Le nom de cette règle s'affiche sur l'onglet Règles.


Règle de calcul de la somme des valeurs

Cette règle est utilisée pour calculer la somme de plusieurs valeurs de champ et les entrer dans le champ spécifié. Par exemple, si le document comporte des champs avec le salaire, le bonus et d’autres charges, vous pouvez définir une règle qui calcule leur somme et écrive les résultats dans un champ spécifique.

Pour créer une règle de calcul de somme, procédez comme suit :

  1. Ouvrez la boîte de dialogue Propriétés de champ (menu contextuel Propriétés…) ou la boîte de dialogue Propriétés de définition de document (menu Éditeur de définition de document, Définition de document >Propriétés de la définition de document…).
  2. Accédez à l’onglet Règles.
  3. Cliquez sur Nouvelle règle…
  4. Dans la liste des règles, sélectionnez Calculer la somme puis cliquez sur OK.
  5. Entrez le nom de la règle et sélectionnez le type de règle : Avertissement ou Erreur. Cliquez ensuite sur Suivant.
  6. Ajoutez les champs dont les valeurs doivent être additionnées à la liste Résumer les valeurs des champs . Pour ce faire, cliquez sur le bouton Ajouter….
  7. Dans le champ Champ de résultat , spécifiez le champ où entrer la somme. Pour ce faire, cliquez sur Sélectionner…
  8. Sélectionnez Au moins deux éléments non vides à additionner si vous avez besoin d’au moins deux nombres non égaux à 0 pour les additionner.
  9. Cliquez surTerminer pour achever la création de la règle. Le nom de cette règle s’affiche dans l’onglet Règles.


Configuration de l'exportation de données

Pour déterminer la méthode d'enregistrement des données obtenues en traitant les documents papiers, vous devez configurer l'exportation pour chacune des définitions de documents. Quatre types d'exportation sont possibles : exporter vers un fichier, exporter vers une base de données, exporter vers une bibliothèque Microsoft Sharepoint ou exportation scriptée. Le type d'exportation que vous sélectionnez détermine les paramètres d'exportation disponibles. Vous pouvez spécifier plus d'un type d'exportation pour une définition de document.

Pour chaque type d'exportation, indiquez les documents à exporter : documents comportant des erreurs et/ou documents n'en comportant pas.

Pour chaque type d'exportation, indiquez s'il est obligatoire. Si un type d'exportation est obligatoire et qu'une erreur de ce type échoue, une erreur est retournée. Si un type d'exportation est facultatif, son dysfonctionnement ne cause pas d'erreur.

L'exportation automatique se configure dans l'onglet Exportation de la boîte de dialogue Propriétés de la définition de document. Sélectionnez Activer l'exportation auto pour permettre l'exportation automatique de documents.

Pendant l’exportation d’image, vous pouvez masquer les images de champs spécifiques (masquant ainsi les informations confidentielles et autres données sensibles). La liste de champs est définie indépendamment pour chacun des types d’exportation. Ainsi, il est possible de contrôler l’accès des employés à des informations particulières. Pour masquer des champs, sélectionnez Masquer les données sensibles des images lorsque vous configurez l’exportation d’image, puis cliquez sur Sélectionner des champs pour le masque… et, dans la boîte de dialogue Sélectionner des champs pour le masque, spécifiez la liste des champs, les images que vous voulez masquer.

Pour configurer l'exportation, sélectionnez Définition de Document > Paramètres d'exportation… dans l'éditeur de définitions de documents puis spécifiez les types d'exportation requis dans la boîte de dialogue Paramètres d'exportation.

Exportation vers un fichier
Exportation d'image vers un fichier
Exportation vers une base de données
Exporter vers SharePoint
Description d'une exportation à l'aide d'un script


Exportation de données vers un fichier

  1. Définissez les paramètres d’exportation puis cliquez sur Suivant>. Les paramètres d’exportation ajustables dépendent de la valeur spécifiée dans le champ Cible .

      Recréer les noms de fichier et la structure des sous-dossiers du dossier actif

      Si vous sélectionnez cette valeur, la structure du dossier reprendra celle du dossier actif d’où les images de document proviennent. Lorsque vous configurez ce type d’exportation, sélectionnez le dossier qui reprendra la structure du dossier actif dans le champ Chemin d'exportation .

      Exporter tous les documents vers un fichier

      Sélectionnez cette valeur pour exporter toutes les données vers un fichier. Lorsque vous configurez ce type d’exportation, saisissez le chemin d’accès et le nom du fichier vers lequel exporter les données dans le champ Chemin d’accès.

      Exporter les documents vers des fichiers distincts

      Sélectionnez cette valeur pour exporter chaque document vers un fichier distinct :

      • indiquez le chemin d’accès et les premiers caractères du nom de fichier dans le champ Préfixe de fichier ;
      • pour que chaque lot soit exporté vers un dossier distinct, sélectionnez Créer un dossier distinct pour chaque lot.
      Créer une structure de dossier et un nom de fichier à l'aide d'un modèle

      Si vous sélectionnez cette valeur, les noms de fichier et la structure des sous-dossiers seront créés selon les paramètres du document.

      • Indiquez le chemin d’exportation racine dans le champ Chemin d'exportation .
      • Définissez les options de dénomination des fichiers. Pour ce faire, cliquez sur Éditer… et définissez les règles nécessaires. Pour plus d’informations, consultez Options de dénomination du fichier d’exportation.
      • Dans le champ Si le fichier existe, sélectionnez l’action que le programme doit effectuer si un fichier portant le nom généré existe déjà.

      Important ! Pour que l’exportation se termine correctement, une fois que le projet a été téléchargé sur le serveur, assurez-vous que le chemin d’exportation est indiqué au format UNC (\\nom_de_l_ordinateur\nom_de_partage[\chemin_d_accès]). Assurez-vous également que les stations impliquées dans l’exportation ont accès à l’emplacement spécifié.

      Des erreurs d’exportation se produiront si le chemin d’accès est indiqué au format suivant : <disque:>\[chemin_d_accès]. Si vous spécifiez un chemin d’exportation relatif, les données seront accessibles via une interface de programmation (API) uniquement. Pour accéder aux données autrement, le dossier racine des chemins d’accès relatifs doit être spécifié au format UNC (configurable dans Propriétés du projet).

  2. Sélectionnez un type de fichier (les formats pris en charge sont CSV, DBF, TXT, XLS et XML), définissez si nécessaire les propriétés d’exportation supplémentaires pour le type de fichier et le codage du texte sélectionnés. Cliquez ensuite sur Suivant >.

    Classeur Microsoft Office Excel (*.xls) :
    • Sélectionnez la version de Microsoft Excel (5.0/95 ; 97-2003 ; 97-2003 (compatible avec 5.0/95)).
    • Sélectionnez Préserver le type de valeur à l'exportation pour exporter les données en fonction de ses types. Désactivez cette option pour exporter toutes les données de type Général.
    • Sélectionnez Créer des fichiers distincts pour les éléments répétables pour exporter les tableaux et les champs comportant plusieurs répétitions vers des fichiers distincts.
    • Pour Excel 5.0/95, sélectionnez une page de code.
    • Configurez les noms et formats de champ, si nécessaire. Pour ce faire, cliquez sur Configurer le mappage des champs… et, dans la boîte de dialogue Mappage de champ, indiquez les noms et le format des champs à l’aide de nombres et de dates.
    Document XML (*.xml) :
    • Définissez les autres données à exporter (emplacements et types de champ, erreurs, données sur la qualité de la reconnaissance).
    • Sélectionnez Préserver le type de valeur à l'exportation si vous souhaitez enregistrer le schéma xml avec les descriptions de type de champ.
    • Sélectionnez le codage.
    • Indiquez les noms de champ, si nécessaire. Pour ce faire, cliquez sur Configurer le mappage des champs… et, dans la boîte de dialogue Mappage de champ, spécifiez les noms de champ.
    Fichier de valeurs séparées par des virgules (*.csv) :
    • Sélectionnez Séparateur de colonnes .
    • Sélectionnez Créer des fichiers distincts pour les éléments répétables pour exporter les tableaux et les champs comportant plusieurs répétitions vers des fichiers distincts.
    • Sélectionnez le codage.
    • Configurez les noms et formats de champ, si nécessaire. Pour ce faire, cliquez sur Configurer le mappage des champs… et, dans la boîte de dialogue Mappage de champ, indiquez les noms et le format des champs à l’aide de nombres et de dates.
    Fichier texte (*.txt) :
    • Sélectionnez Séparateur de colonnes .
    • Sélectionnez Créer des fichiers distincts pour les éléments répétables pour exporter les tableaux et les champs comportant plusieurs répétitions vers des fichiers distincts.
    • Sélectionnez le codage.
    • Configurez les noms et formats de champ, si nécessaire. Pour ce faire, cliquez sur Configurer le mappage des champs… et, dans la boîte de dialogue Mappage de champ, indiquez les noms et le format des champs à l’aide de nombres et de dates.
    Fichier DBase (*.dbf) :
    • Sélectionnez Préserver le type de valeur à l'exportation pour exporter les données en fonction de ses types. Désactivez cette option pour que tous les champs soient de type Texte.
    • Sélectionnez Créer des fichiers distincts pour les éléments répétables pour exporter les tableaux et les champs comportant plusieurs répétitions vers des fichiers distincts.
    • Configurez les noms de champ, si nécessaire. Pour ce faire, cliquez sur Configurer le mappage des champs… et, dans la boîte de dialogue Mappage de champ, spécifiez les noms de champ.
  3. Si vous souhaitez enregistrer les images, définissez les paramètres d’enregistrement d’image puis cliquez sur Suivant >.
    • Choisissez entre enregistrer les images avec les données ou définir le dossier d’images.
    • Sélectionnez le système de dénomination de fichier d’image : identique aux fichiers de données ou autre. Consultez la section Options de dénomination de fichier d’exportation.
    • Définissez les champs qui contiennent les images que vous souhaitez masquer pendant l’exportation.


Exportation d’images vers un fichier

Exportation d’image vers un fichier

Pour exporter des images vers un fichier :

  1. Dans la fenêtre de l’éditeur de définitions de documents, sélectionnez Définition de Document > Paramètres d'exportation….
  2. Cliquez sur Ajouter… puis sélectionnez Exporter vers des fichiers image dans le champ Type .
  3. Indiquez si l’exportation est obligatoire.
  4. Indiquez quels documents (avec et/ou sans erreurs) doivent être exportés puis cliquez sur Suivant>.
  5. Définissez les paramètres d’exportation puis cliquez sur Suivant>. Les paramètres d’exportation ajustables dépendent de la valeur spécifiée dans le champ Cible .
      Recréer les noms de fichier et la structure des sous-dossiers du dossier actif
      Si vous sélectionnez cette valeur, la structure du dossier reprendra celle du dossier actif d’où les images de document proviennent. Lorsque vous configurez ce type d’exportation, sélectionnez le dossier qui reprendra la structure du dossier actif dans le champ Chemin d'exportation .
      Exporter tous les documents vers un fichier
      Sélectionnez cette valeur pour exporter toutes les données vers un fichier. Lorsque vous configurez ce type d’exportation, saisissez le chemin d’accès et le nom du fichier vers lequel exporter les données dans le champ Chemin d’accès.
      Exporter les documents vers des fichiers distincts
      Sélectionnez cette valeur pour exporter chaque document vers un fichier distinct :
      • indiquez le chemin d’accès et les premiers caractères du nom de fichier dans le champ Préfixe de fichier ;
      • pour que chaque lot soit exporté vers un dossier distinct, sélectionnez Créer un dossier distinct pour chaque lot.
      Créer une structure de dossier et un nom de fichier à l'aide d'un modèle
      Si vous sélectionnez cette valeur, les noms de fichier et la structure des sous-dossiers seront créés selon les paramètres du document.
      • Indiquez le chemin d’exportation racine dans le champ Chemin d'exportation .
      • Définissez les options de dénomination des fichiers. Pour ce faire, cliquez sur Éditer… et définissez les règles nécessaires. Pour plus d’informations, consultez Options de dénomination du fichier d’exportation.
      • Dans le champ Si le fichier existe, sélectionnez l’action que le programme doit effectuer si un fichier portant le nom généré existe déjà.

      Important ! Pour que l’exportation se termine correctement, une fois que le projet a été téléchargé sur le serveur, assurez-vous que le chemin d’exportation est indiqué au format UNC (\\nom_de_l_ordinateur\nom_de_partage[\chemin_d_accès]). Assurez-vous également que les stations impliquées dans l’exportation ont accès à l’emplacement spécifié.

      Des erreurs d’exportation se produiront si le chemin d’accès est indiqué au format suivant : <disque:>\[chemin_d_accès]. Si vous spécifiez un chemin d’exportation relatif, les données seront accessibles via une interface de programmation (API) uniquement. Pour accéder aux données autrement, le dossier racine des chemins d’accès relatifs doit être spécifié au format UNC (configurable dans Propriétés du projet).

  6. Définissez les options d’enregistrement d’image puis cliquez sur Suivant >.
    • Sélectionnez le format d’image, la qualité et la couleur souhaités.
    • Pour modifier la résolution des images sources, sélectionnez Changer la résolution en puis sélectionnez la valeur appropriée dans la liste.
    • Si vous avez sélectionné le format PDF ou PDF/A comme format de stockage, vous pouvez créer un fichier PDF indexé en sélectionnant Créer un fichier PDF indexé. Vous pouvez sélectionner une langue (ou des langues dans le cas de documents multilingues) différente de la langue spécifiée dans la définition de document : cliquez sur Sélectionner… situé à droite du champ Langue et sélectionnez les langues appropriées. Si vous souhaitez utiliser la langue spécifiée dans la définition de document, sélectionnez Comme dans la définition de document dans le champ Langue .
  7. Saisissez un nom de profil d’exportation puis cliquez sur Terminer.


Exportation vers une base de données

Pour configurer l'exportation vers une base de données, procédez comme suit :

  1. Dans la fenêtre de l'éditeur de définitions de document, sélectionnez l'élément de menu Définition de Document > Paramètres d'exportation….
  2. Cliquez sur Ajouter…, puis sélectionnez Exporter vers une base de données compatible ODBC dans le champ Type .
  3. Indiquez si l'exportation est obligatoire.
  4. Indiquez si les images doivent être exportées.
  5. Indiquez quels documents (avec et/ou sans erreurs) doivent être exportés puis cliquez sur Suivant>.

  6. Définissez les paramètres d'exportation puis cliquez sur Suivant>.

    • Établissez une connexion avec une base de données. Entrez les paramètres de connexion dans la fenêtre Chaîne de connexion ou cliquez sur le bouton Configurer la connexion… et configurez les paramètres de connexion dans la boîte de dialogue Propriétés de la liaison de données.
    • Sélectionnez un système dans la liste déroulante.
    • Vous pouvez vérifier la connexion à la base de données en cliquant sur le bouton Tester la connexion.

      Conseil : Pour le fournisseur de base de données OLE, il est conseillé d'utiliser Fournisseur de base de données OLE pour pilotes ODBC . Si vous sélectionnez Fournisseur de base de données OLE DB pour serveur SQL, des problèmes risquent d'apparaître avec certains types de données et avec les champs longs.

    • Associez les champs de la définition de document aux colonnes des tables de la base de données. Pour ce faire, cliquez sur Configurer le mappage des champs…
    • Dans la boîte de dialogue Mappage de champ, indiquez vers quels tableaux et quelles colonnes de tableaux de la base de données le programme doit exporter les valeurs de champ de la définition de document.
      Détails...

      La boîte de dialogue Mappage de champ contient les sections de document et les champs. À droite, vous devez les associer aux tableaux et champs de la base de données. Si la base de données contient déjà des tableaux pour l'exportation de données, dans la boîte de dialogue Mappage de champ, vous devez sélectionner un tableau de base de données pour chaque section de document et une colonne de tableaux de base de données pour chaque champ de document.

      Si la base de données ne contient pas de tableau pour l'exportation, vous pouvez en créer automatiquement en cliquant sur le bouton Créer automatiquement des tableaux. Dès que vous cliquez, le programme crée des tableaux avec la structure dont vous avez besoin pour l'exportation. Les champs de document sont associés aux colonnes de tableaux.

      Les groupes de champs, les champs avec plusieurs instances et les tableaux de document sont exportés vers des tableaux séparées au sein de la base de données. Une clé primaire et une clé étrangère sont utilisées pour lier la table principale aux tableaux subordonnés. Dans la table principale, une clé primaire est ajoutée à chaque entrée. Dans le tableau subordonné, chaque entrée comporte une clé étrangère qui stocke la valeur de la clé primaire de l'entrée correspondante de la table principale. Les clés primaire et étrangère sont ajoutées automatiquement si elles sont nécessaires. Vous devez simplement indiquer le champ vers lequel la clé doit être exportée.

      L'option Afficher les colonnes liées est activée par défaut. Si vous la désactivez, la liste des colonnes de tableaux située à droite de l'arborescence n'affiche pas les colonnes pour lesquelles l'exportation a déjà été configurée.

  7. Si des images doivent être enregistrées, définissez les options d'enregistrement d'image puis cliquez sur Suivant>.
    • Indiquez si les images doivent être enregistrées dans la base de données ou dans des fichiers.
    • Si choisissez d'enregistrer des images dans des fichiers, sélectionnez un gabarit de dénomination de fichiers (cliquez sur Options de dénomination des fichiers…) et le moment auquel les fichiers doivent être écrasés si leurs noms coïncident. Pour plus d’informations consultez la section Critères de dénomination de fichier d’exportation.
    • Si nécessaire, indiquez les champs à cacher après exportation.
  8. Si des images doivent être enregistrées, définissez les options de stockage d'image puis cliquez sur Suivant>.
    • Sélectionnez le format d'image, le niveau de qualité et la couleur souhaités.
    • Pour modifier la résolution des images sources, sélectionnez Changer la résolution en puis sélectionnez la valeur appropriée à partir de la liste.
    • Si vous avez sélectionné le format PDF ou PDF/A comme format de stockage, vous pouvez créer un fichier PDF avec possibilité de recherche en sélectionnant Créer un fichier PDF indexé. Vous pouvez sélectionner une langue (ou des langues dans le cas de documents multilingues) différente de la langue spécifiée dans la définition de document : cliquez sur Sélectionner… situé à droite du champ Langue et sélectionnez les langues appropriées. Si vous souhaitez utiliser la langue spécifiée dans la définition de document, sélectionnez Comme dans la définition de document dans le champ Langue .
  9. Saisissez un nom de profil d'exportation puis cliquez sur Terminer.

Remarque :

  1. Les images graphiques sont exportées dans des fichiers séparés. Vous pouvez enregistrer le nom et le chemin d’accès du fichier d’image dans les champs correspondants de la base de données (vous pouvez effectuer ces opérations lors du mappage des champs).
  2. Si le chemin d’accès du dossier cible des images, etc. contient un disque réseau, vérifiez que toutes les stations de traitement travaillant sur le projet bénéficient d’un accès à ce disque.


Exportation de données vers une bibliothèque de documents SharePoint

ABBYY FlexiCapture 9.0 vous permet d'exporter des documents vers une bibliothèque de documents MicrosoftTM SharePoint. Ce processus vous permet d'obtenir une bibliothèque contenant vos images de document et des colonnes supplémentaires comprenant la valeur de certains champs pour chaque document.

Remarque :

  1. Vous devez disposer de droits d'administrateur pour configurer l'exportation de données vers SharePoint. Des droits de collaborateur sont suffisants pour exporter des données vers SharePoint.
  2. Les colonnes SharePoint dans lesquelles les données sont enregistrées doivent être de type Ligne de texte unique ou Lignes de texte multiple.

Pour configurer l'exportation vers SharePoint :

  1. dans l'éditeur de définitions de documents, sélectionnez Définition de Document > Paramètres d'exportation… ;
  2. cliquez sur Ajouter… ;
  3. sélectionnez Exporter vers SharePoint dans le champ Type ;
  4. indiquez si l'exportation est obligatoire ;
  5. indiquez quels documents (avec et/ou sans erreurs) doivent être exportés puis cliquez sur Suivant> ;

  6. définissez les paramètres d'exportation.

    • URL du serveur (par ex. : http://monserveur) : entrez l'adresse du serveur sur lequel figurent les bibliothèques SharePoint. Utilisez le bouton Paramètres de connexion… pour configurer les paramètres d'authentification (les paramètres d'authentification de Windows sont utilisés par défaut) et les paramètres proxy si nécessaire.
    • L'état de la connexion est indiqué sous l'adresse du serveur. Si le serveur est déconnecté, cliquez sur Connecter pour rétablir la connexion.
    • Une fois connecté au serveur SharePoint, sélectionnez une bibliothèque dans la liste Sélectionner la bibliothèque SharePoint .
    • Cliquez sur Parcourir… puis localisez le dossier souhaité dans la bibliothèque.
    • Dans le champ Type de contenu , sélectionnez le type de contenu de vos documents (prise en charge à partir de SharePoint 2007). Le cas échéant, vous pourrez exporter les valeurs vers les champs correspondant au type de contenu sélectionné.
    • Renseignez à présent les champs de la définition de document à exporter et à quel emplacement ils doivent l'être. Cliquez sur le bouton Configurer le mappage des champs… et sélectionnez les options souhaitées dans la boîte de dialogue Mappage de champ. Dans cette boîte de dialogue, vous devez établir la correspondance entre les champs de la définition de document et les colonnes du document SharePoint. Les champs de la définition de document apparaissent à gauche. Pour chaque champ de définition de document à exporter (à l'exception des groupes et tableaux), vous pouvez sélectionner une colonne SharePoint inutilisée.
  7. Cliquez sur Suivant>.
  8. Saisissez un nom de profil d'exportation puis cliquez sur Terminer.

Une fois l'exportation terminée, les documents sont enregistrés dans la bibliothèque SharePoint spécifiée. De plus, une colonne comporte les valeurs des champs spécifiés pour chaque document. Vous pouvez utiliser ces valeurs à des fins de recherche et d'indexation des documents.


Description d'une exportation à l'aide d'un script

Pour configurer une exportation à l'aide d'un script :

  1. Dans la fenêtre de l'éditeur de définitions de documents, sélectionnez Définition de Document > Paramètres d'exportation….
  2. Cliquez sur Ajouter….
  3. Sélectionnez Exportation personnalisée (script) dans le champ Type .
  4. Indiquez si l'exportation est obligatoire.
  5. Indiquez quels documents (avec et/ou sans erreurs) doivent être exportés puis cliquez sur Suivant>.
  6. Sélectionnez le langage de script JScript(r) ou VBScript).
  7. Saisissez le code du script dans la fenêtre de l'éditeur qui apparaît lorsque vous cliquez sur Éditer le script…. Cliquez sur Suivant>.
  8. Saisissez un nom de profil d'exportation puis cliquez sur Terminer.

Remarque : Les procédures que vous souhaitez utiliser dans plusieurs scripts d’exportation doivent être rédigées sur un module général d’exportation accessible depuis l’éditeur de scripts. Depuis la liste déroulante de la barre d'outils de l’éditeur de scripts, sélectionnez Module de script global d'exportation. Le module général d'exportation est également accessible à partir de l'éditeur de Définitions de Documents (Définition de Document>Modules de script>Exporter un script…).

Pour plus d'informations sur la description d'une exportation à l'aide d'un script, consultez la section Utilisation de scripts dans FlexiCapture 9.0


Règles de dénomination des fichiers d'exportation

Critères de dénomination de fichier d’exportation

Les noms des fichiers et leur chemin d’accès sont créés automatiquement pendant l’exportation, selon les critères spécifiés par l’utilisateur. Vous pouvez configurer les noms des fichiers de données et les noms des fichiers d’image.

La formation des noms des fichiers et de leur chemin d’accès peut être configurée dans la fenêtre Destination d'exportation des fichiers. Selon le type d’exportation sélectionné, la fenêtre s’ouvre en cliquant sur Éditer…(à gauche du champ avec le modèle de dénomination de fichier) ou Options de dénomination des fichiers…

Il existe deux types de formation de modèle d’exportation de fichiers (sélectionnez Afficher dans le champ) :

Simple

Pour ce type, vous pouvez sélectionner un chemin d’accès supplémentaire (sauf pour configurer l’exportation d’image avec l’exportation de données vers un fichier), la partie importante du nom de fichier, et ajouter des identificateurs si nécessaire.

Pour définir le chemin d’accès relatif, sélectionnez Utiliser un chemin supplémentaire puis sélectionnez la méthode : identique à la structure du dossier actif (Chemin source relatif au dossier actif) ou en fonction du nom du lot (Nom de lot).

Les éléments suivants peuvent être utilisés en tant que partie importante du nom du fichier :

  • Nom du fichier source
  • Nom de la définition de document
  • Nom de fichier spécifié : combinaison des caractères spécifiés par l’utilisateur

Les éléments suivants peuvent être utilisés comme identificateurs supplémentaires

  • Identificateur de document (sélectionnez Ajouter l'identificateur de document au nom de fichier)
  • Valeur de champ d’index (sélectionnez Ajouter un champ d'index au nom de fichier, puis cliquez sur … et sélectionnez le champ d’index dans la fenêtre Sélectionner des champs)
Avancé

Dans ce type, le modèle de dénomination de fichier est saisi sous forme de ligne de texte dans le champ Modèle de nom de fichier . Le modèle peut comprendre une partie permanente et des balises qui seront remplacées par des informations pour les fichiers spécifiques. Les balises peuvent être entrées à l’aide d’un clavier ou ajoutées et supprimées à l’aide des boutons Ajouter une balise… et Supprimer une balise .

Pour générer correctement les noms de fichier, vérifiez que les options de dénomination de fichier que vous sélectionnez ne créent pas de noms de fichier vides. Dans le cas contraire, le programme affiche un message d'avertissement.


Configuration de la présentation des données dans la fenêtre de document

Une fois que les données ont été reconnues, l'utilisateur les voit dans la fenêtre de document. Les données sont organisées de manière séquentielle par défaut, et leurs légendes correspondent aux noms des champs de la définition de document.

Toutefois, vous pouvez modifier la présentation des données en fonction de vos besoins, ou renommer les éléments. La présentation des données peut être modifiée dans le coin inférieur droit de la fenêtre d'éditeur de définitions de documents.

Vous pouvez modifier la légende d’un champ dans le formulaire de données sans modifier son nom dans la structure de document. Pour modifier une légende, ouvrez la boîte de dialogue de propriétés du champ, cliquez sur l’onglet Généralités, puis saisissez un nouveau nom dans le champ Légende . Ce nom sera utilisé comme légende du champ dans le formulaire de base de données. Cette fonctionnalité peut s’avérer utile pour personnaliser des noms de colonne, notamment dans FlexiLayouts où vous ne pouvez pas modifier le nom des champs.

La police et la taille des caractères des noms de champs et des valeurs de données reconnues peuvent être définis sur l'onglet Formulaire de données de la boîte de dialogue de propriétés de la définition de document (Définition de Document > Propriétés de la définition de document…). Vous pouvez également modifier la taille des caractères en cliquant à l'aide du bouton droit de la souris dans la fenêtre Formulaire de données et en sélectionnant la taille de votre choix (Taille du texte dans le menu contextuel).

Vous pouvez déplacer, modifier et renommer les champs, mais aussi modifier leurs propriétés. Pour retrouver la présentation initiale des champs, sélectionnez la commande correspondante dans le menu contextuel.

Vous pouvez également ajouter du texte (d'explication, par exemple). Pour ce faire, cliquez avec le bouton droit de la souris sur la fenêtre Formulaire de données et sélectionnez Insérer une zone de libellé dans le menu contextuel. Entrez votre texte, qui remplacera le Texte de libellé.


Propriétés de la Définition de Document

Les propriétés de base d'une définition de document, comme son nom, la langue et le style d'écriture, sont configurées à l'aide de l'Assistant de définition de document. Les autres propriétés sont configurées par défaut.

Vous pouvez afficher et modifier les propriétés d'une définition de document dans la boîte de dialogue qui s'ouvre quand vous sélectionnez l'élément de menu Définition de Document>Propriétés de la définition de document… dans la fenêtre de l'éditeur de définitions de document.

Cette boîte de dialogue comporte six onglets.

L'onglet Généralités

Sur cet onglet, vous pouvez renommer la définition de Document et saisir ou modifier sa description. L'option Activé inclut/exclut la définition de document du traitement documentaire.

L'onglet Reconnaissance

Sur cet onglet, vous pouvez modifier les propriétés générales de la reconnaissance de définition de document :

  • Langue (lieu) : il est important d'indiquer la langue utilisée pour que la reconnaissance soit correcte. Cette propriété détermine la langue d'entrée et d'autres paramètres locaux, comme le format de date, la devise, etc.
  • Style d'écriture : le style d'écriture peut varier considérablement d'un pays à l'autre. Il est donc très important d'indiquer le pays, ce qui permet au programme de sélectionner son style d'écriture type.

  • Indiquez le type de texte :

    ICR (manuscrit) : activez cette option si la plupart des champs des documents doivent être remplis à la main.

    OCR (imprimé) : activez cette option si les valeurs de la plupart des champs doivent être imprimées. Sélectionnez un type d'impression dans la liste déroulante.

    Remarque : la reconnaissance du texte manuscrit n'est pas prise en charge dans toutes les langues. Pour certaines, ce type de reconnaissance n'est pas disponible. Consultez la section Langues de reconnaissance prises en charge.

    À ce stade, c'est le type de texte par défaut qui est utilisé, mais vous pourrez le modifier pour chaque champ ultérieurement.

  • Vous pouvez activer une ou plusieurs options du groupe Orientation de page possible afin que la page soit orientée à 180°, à 90° dans le sens horaire, ou encore à 90° dans le sens anti-horaire pendant la sélection automatique de l'orientation de la page.
  • Cliquez sur Options avancées… pour configurer la correction des distorsions d'image linéaires et non linéaires.

L'onglet Assemblage

Cet onglet permet de configurer des règles d'assemblage pour des documents de plusieurs pages.

Dans le cas de figure le plus simple, la définition de document est composée d'une seule section, qui n'apparaît qu'une fois. Si une définition de document comporte plusieurs sections, cet onglet répertorie leurs noms. Vous pouvez spécifier le nombre de répétitions de chaque section en modifiant les valeurs des colonnes Nombre min. et Nombre max..

  • Vérifier l'égalité des champs clés : activez cette option si vous souhaitez effectuer une vérification de l'assemblage de document à partir des champs clés. Sélectionnez ensuite un champ clé pour chaque section de la colonne Champ clé. Quand vous entrerez des documents, seuls les documents dont les valeurs correspondent pour les champs clés pour chaque section seront considérés comme assemblés correctement. Si leurs valeurs ne correspondent pas, un message d'erreur d'assemblage sera affiché.
  • Activer les pages d'annexe : activez cette option si vous souhaitez traiter des documents avec des annexes.
  • Il se peut que vous souhaitiez désactiver la vérification de l’ordre des sections du document (par exemple, si l’ordre des sections n’affecte pas l’assemblage de document). Le cas échéant, sélectionnez Désactiver la vérification de l'ordre des sections pour désactiver la vérification. Le programme continuera de vérifier que toutes les sections sont présentes dans le document mais leur ordre sera ignoré.

Pour plus d'informations, consultez les sections Création de définitions de document pour des documents de plusieurs pages, Assemblage de pages sous forme de documents et Création de définitions de document pour documents avec des annexes.

L'onglet Règles

Cet onglet est consacré aux actions relatives aux règles de Définition de Document. Vous pouvez supprimer, modifier ou créer des règles.

Pour plus d'informations, consultez la section Validation par règle.

L'onglet Exportation

Cet onglet affiche les paramètres d'exportation en cours de la définition de document donnée. Pour modifier les paramètres d'exportation, cliquez sur le bouton Éditer….

Pour plus d'informations, consultez la section Configuration de l'exportation de données.

L'onglet Formulaire de données

Sur cet onglet, vous pouvez modifier la police et la taille d'affichage des données reconnues.

Le groupe Paramètres du texte de données contient les paramètres de police pour l'affichage des valeurs reconnues.

Le groupe Paramètres du texte de libellé contient les paramètres d'affichage applicables au texte d'explication (noms de champs).

Pour plus d'informations, consultez la section Configurer la présentation des données dans la fenêtre de document.


Importation d'une Définition de Document pour les formulaires créés avec ABBYY FormDesigner

ABBYY FormDesigner est un outil très pratique conçu spécialement pour créer des formulaires lisibles par machine. Outre des formulaires respectant toutes les exigences du traitement documentaire automatisé, vous pouvez créer des formulaires avec ABBYY FormDesigner pour obtenir une définition de document qui est pratiquement prête à traiter ces formulaires dans ABBYY FlexiCapture 9.0.

Pour obtenir une définition de document pour traiter les formulaires conçus avec ABBYY FormDesigner, procédez comme suit :

Dans ABBYY FormDesigner :

  1. créez un formulaire ;
  2. publiez-le ;
  3. exportez-le au format Fichiers de définition de formulaire XML. Vous obtenez alors un fichier portant une extension .xfd.

Pour plus d'informations sur la création, la publication et l'exportation de formulaires, consultez les rubriques d'aide et le manuel d'utilisateur d'ABBYY FormDesigner 9,0.

Dans ABBYY FlexiCapture :

  1. dans la fenêtre principale du programme, sélectionnez l'élément de menu Projet > Définitions de document… ;
  2. dans la boîte de dialogue Définitions de document, cliquez sur le bouton Importer… ;
  3. dans la boîte de dialogue Ouvrir le fichier pour l'importation qui s'ouvre, sélectionnez Fichiers de définition de formulaire XML (*.xfd) dans la liste déroulante Fichiers de type, puis indiquez le chemin d'accès du fichier *.xfd.
  4. Le nom de la nouvelle définition de document s'affiche dans la liste des définitions de document de la boîte de dialogue Définitions de document.

Après avoir ouvert une définition de document importée pour la modifier, vous pourrez voir que le marquage des champs et des éléments statiques est déjà présent dans l'image. Vous n'avez qu'à modifier les propriétés du champ et à configurer l'exportation.


Création de Définitions de Document pour des documents multipages

ABBYY FlexiCapture 9.0 permet de créer des définitions de document pour des documents de plusieurs pages. Une définition de document peut contenir des sections, qui, elles-mêmes, peuvent contenir une ou plusieurs pages. Les définitions de document pour les documents de plusieurs pages requièrent la définition de l'ordre des sections, leur nombre et les règles utilisées pour assembler les pages sous forme de documents.

Au terme de la procédure de création de l'Assistant, une nouvelle définition de document simple, sans section, est créée. Vous pouvez ajouter des pages à cette définition de document. Quand vous ajoutez une page, son image est ajoutée à la région d'image dans la fenêtre de l'éditeur de définitions de document, tandis que les champs créés dessus sont répertoriés dans la liste de champs commune. Dans ce cas, le document est composé d'une seule section même s'il peut contenir plusieurs pages.

Ajoutez des pages à une même section si le document contient des blocs qui continuent ou se répètent sur plusieurs pages, ou des tableaux qui continuent à la page suivante. Utilisez la même méthode pour charger une description flexible de plusieurs pages (consultez la section Création d'une définition de document pour traiter des documents flexibles). Tous les champs d'une description flexible doivent faire partie d'une même section de définition de document.

L'autre technique consiste à ajouter des sections à la définition de document. Dans le cas de figure le plus simple, une section contient une page. Vous pouvez choisir cette méthode si les jeux de champs des pages sont indépendants. Cette méthode est plus parlante : la structure du document montre de quelle section les champs font partie, et vous pouvez aussi configurer une structure personnalisée pour l'assemblage de document. Supposons, par exemple, que le document contient trois types de pages et que les pages du premier et du troisième type ne doivent apparaître qu'une seule fois, tandis que les pages du deuxième type doivent apparaitre de 2 à 5 fois. Vous devez alors créer trois sections, une pour chaque type de page et préciser l'ordres des sections dans le document et le nombre d'occurence éventuelle de chacune.

Imaginons un cas de figure plus complexe : une définition de document composée de plusieurs sections, dont certaines contiennent plusieurs pages. Par exemple, il peut s'agir d'une définition de document composée de sections fixes et d'une section flexible de plusieurs pages, ou encore d'une définition de document décrivant des documents qui contiennent une feuille recto-verso qui se répète plusieurs fois. Imaginons que vous ayez besoin de créer une définition de document pour un document contenant une page de titre (page A) et un certain nombre de feuilles recto-verso (séquence de page – BCBC...). Vous commencez par conséquent à créer une section A contenant une page A et une section BC contenant deux pages B et C. La structure du document est configurée comme suit : la section A se répète une fois, suivie de la section BC, qui se répète de 3 à 7 fois.

Pour une définition de document composée de plusieurs sections, vous pouvez activer la vérification des champs clés en plus de celle de l'ordre et du nombre de sections récurrentes. Pour ce faire, vous devez identifier les champs clés de chaque section de document. Leurs valeurs doivent être identiques dans les différentes sections. Un champ clé peut, par exemple, être le nom de famille de la personne qui a complété le document (ce nom devant être écrit sur chaque page) ou un certain numéro d'identification.

Quand il traite un lot, le programme essaie d'assembler une séquence de pages sous forme de documents, et il vérifie les règles d'assemblage au cours de l'opération. Le programme effectue un contrôle des valeurs des champs clés. Si les champs clés ne correspondent pas sur les pages du même document, un message d'erreur s'affiche. Ce message est parfois dû au fait que les pages de document ont été mal placées pendant la numérisation, auquel cas il suffit de modifier l'ordre des pages pour respecter les règles d'assemblage de document. Consultez la section Assemblage de pages sous forme de documents.

Pour ajouter une page à une section, sélectionnez Définition de document > Ajouter une page… dans le menu de l'éditeur de définitions de document ou Ajouter une page… dans le menu contextuel de l'image. Chargez ensuite l'image d'une nouvelle page non terminée, puis sélectionnez les types d'objets qui doivent être marqués automatiquement sur la page.

Pour ajouter une nouvelle section, dans la fenêtre de l'éditeur de définitions de document, sélectionnez Définition de document > Ajouter une section de document…. L'Assistant Création de section s'ouvre pour vous aider à configurer tous les paramètres requis. Suivez les instructions de l'Assistant pour :

  • indiquer le nom de la section ;
  • charger l'image d'une page non remplie (numérisée ou chargée à partir d'un fichier), ou un fichier de description flexible ;
  • sélectionner les types d'objets qui seront marqués automatiquement.

Une nouvelle section, avec les champs qu'elle contient, s'affiche dans la fenêtre de structure du document.

Pour afficher la structure de document générée quand vous créez une définition de document, dans la fenêtre Structure de document située dans la partie droite de la fenêtre d'éditeur de définitions de document, accédez à l'onglet Pages. Cet onglet affiche la structure du document en mode contour de page. Sur cet onglet, vous pouvez modifier le nombre de sections incluses dans un document (pour ce faire, entrez une nouvelle valeur – un nombre ou un intervalle – dans la zone située à droite du nom de la section), joindre des pages d'annexe, modifier l'ordre des pages de la section et déplacer des pages d'une section à une autre en les faisant glisser.

Affichage de la fenêtre de structure du document

Pour spécifier la séquence et le nombre de sections récurrentes, et pour définir la règle d'assemblage, utilisez l'élément de menu Définition de Document> Propriétés de la définition de document… de la fenêtre de l'éditeur de définitions de document. Sur l'onglet Assemblage spécifiez le nombre minimum et le nombre maximum d'inclusions pour chaque section du document (la valeur par défaut est 1). Si vous souhaitez vérifier les valeurs des champs clés, activez l'option Vérifier l'égalité des champs clés et sélectionnez un champ clé dans chaque section.

Il se peut que vous souhaitiez désactiver la vérification de l’ordre des sections du document (par exemple, si l’ordre des sections n’affecte pas l’assemblage de document). Le cas échéant, sélectionnez Désactiver la vérification de l'ordre des sections pour désactiver la vérification. Le programme continuera de vérifier que toutes les sections sont présentes dans le document mais leur ordre sera ignoré.

Affichage de l'onglet Assemblage


Création d'une définition de document pour le traitement des documents flexible

Pour les factures, les ordres de paiement et les documents apparentés, vous ne pouvez pas créer une définition de document avec des emplacements de champ fixes. En effet, l'emplacement, la taille et le nombre des champs risquent de ne pas être identiques. Il n'est donc pas possible d'appliquer une définition de document fixe à tous les documents. Dans les documents de ce type, le programme recherche les champs après une pré-reconnaissance de l'ensemble de la page, puis il crée une description flexible à partir des mots clés et de l'emplacement relatif des champs. Un module de programme spécial, ABBYY FlexiLayout Studio 9.0 (fourni avec ABBYY FlexiCapture 9.0), permet de concevoir des descriptions flexibles. Vous trouverez des instructions détaillées sur la conception d'une description flexible dans les rubriques d'aide d'ABBYY FlexiLayout Studio 9,0.

Une description flexible est exportée vers un fichier .afl, puis chargée dans ABBYY FlexiCapture 9.0. Nous pouvons utiliser une description flexible pour la définition de document dans son ensemble ou comme l'une de ses sections. Une description flexible peut couvrir plusieurs pages.

Association d'une description flexible

Vous pouvez associer une description flexible lors de la création d'une définition de document. Pour ce faire, à la deuxième étape de l'Assistant Définition de document, ajoutez l'image de document, puis activez l'option Charger FlexiLayout et entrez le chemin d'accès du fichier .afl contenant la description flexible.

Vous pouvez joindre une description flexible à partir de la fenêtre de l'éditeur de définitions de documents dans la boîte de dialogue de la section de la définition de document.

  1. Sélectionnez une section de document. (Si le document ne contient qu'une section, dans la fenêtre Structure de document, ouvrez l'onglet Pages, puis sélectionnez le nom de cette section.) Cliquez avec le bouton droit de la souris et sélectionnez Propriétés… dans le menu contextuel.
  2. Accédez à l'onglet FlexiLayout.
  3. Cliquez sur Charger….
  4. Sélectionnez le fichier .afl contenant la description flexible dont vous avez besoin.

Une fois la description flexible associée, la présentation géométrique des champs s'affiche sur l'image. Vous devez maintenant configurer les propriétés de champ comme vous le feriez pour une définition de document fixe. Spécifiez les propriétés de reconnaissance, de vérification et d'exportation et définissez les règles requises.

Remarque : Lorsque vous importez un projet FlexiLayout comportant des fichiers texte qui contiennent des valeurs de champ possibles, ces fichiers sont placés selon les chemins d'accès relatifs définis lors de la création du projet FlexiLayout. Les chemins d'accès relatifs dépendent du fichier de projet. Pour modifier ces fichiers, enregistrez le projet localement (sélectionnez Projet>Exporter un projet…), modifiez les fichiers puis mettez à jour le projet sur le serveur (sélectionnez Projet>Mettre à jour un projet…).


Création de définitions de documents pour des documents avec des annexes.

ABBYY FlexiCapture 9.0 permet de créer des définitions de documents pour des documents contenant des annexes. Les annexes sont des pages supplémentaires qui peuvent accompagner chaque formulaire. Aucune définition de document n'est appliquée à ces pages, mais elles sont prises en compte pendant l'assemblage du document. Par exemple, imaginons qu'une demande de prêt (formulaire fixe) soit envoyée avec une déclaration de revenus de forme libre. Cette déclaration de revenus peut être traitée comme une annexe.

Pour créer une définition de document pour un document avec une annexe :

Première méthode :

  1. Ouvrez l'onglet Pages de la fenêtre Structure de document (première partie de l'éditeur de définitions de documents).
  2. Activez l'option Activer les pages d'annexe dans le document.
  3. Entrez le numéro de page ou la plage de pages de l'annexe dans la zone située à droite du nom de section.
Affichage de la fenêtre de structure du document

Méthode alternative de création d'une définition de document pour un document avec une annexe :
  1. Ouvrez la boîte de dialogue Propriétés de la définition de document (Définition de Document > Propriétés de la définition de document… dans la fenêtre de l'éditeur de définitions de documents).
  2. Accédez à l'onglet Assemblage.
  3. Activez l'option Activer les pages d'annexe. La ligne Pages d'annexe apparaît dans la liste de sections.
  4. Entrez le nombre minimum et le nombre maximum de pages de l'annexe.
Affichage de la boîte de dialogue

Pour enregistrer le texte de l'annexe, lors de la configuration de l'exportation, vous devez spécifier les options d'enregistrement d'image (dans la boîte de dialogue Paramètres d'exportation). Si vous sélectionnez le format PDF avec possibilité de recherche pour enregistrer l'image, le texte sera reconnu et enregistré dans un fichier PDF avec possibilité de recherche.


Traitement de documents non structurés

ABBYY FlexiCapture 9.0 peut servir à traiter des documents non structurés contenant des informations sous une forme libre, par exemple des contrats, des lettres, des commandes et des annexes. Les documents non structurés contenant du texte ou des images séparés par des feuilles vierges ou des pages avec des codes barres sont traités et exportés sous forme de fichiers PDF indexés ou de fichiers graphiques.

Le traitement de documents de ce type implique habituellement de convertir les documents sous une forme électronique et d'effectuer une recherche à partir des valeurs de champs clés.

Si c'est possible, la recherche des champs clés (tels qu'un numéro de contrat) au sein de ces documents est effectuée à l'aide d'une description flexible créée avec ABBYY FlexiLayout Studio. Consultez la section Création d'une définition de document pour traiter des documents flexibles.

Si la recherche automatique de champs clés est impossible, l'opérateur peut entrer les valeurs manuellement. Pour ce faire, créez une définition de document avec un champ (ou plusieurs, si nécessaire) et activez l'option Ne pas reconnaître (clé du champ d'image - sera entré manuellement) dans les propriétés de reconnaissance de ce champ. Quand il exécute le processus de vérification, l'opérateur peut ensuite entrer les valeurs des champs manuellement.

Vous devez configurer l'exportation pour activer le stockage de données : vous pouvez exporter les valeurs des champs clés vers un fichier ou une base de données, puis enregistrer les images de document sous un format plus pratique. Vous pouvez enregistrer les images de document sous forme de fichiers graphiques ou de fichiers PDF indexés.

Soyez vigilant lorsque vous assemblez des pages sous forme de documents : avec les documents non structurés, il peut être difficile de savoir de quel document une page donnée fait partie. Pour automatiser l'assemblage des documents non structurés, nous recommandons de séparer les documents à l'aide de feuilles vierges ou de pages contenant des codes barres. Lorsque vous ajoutez des images à un lot (en les numérisant, en les ajoutant à partir d'un fichier ou en créant un profil d'importation), vous devez activer l'option Pour les images séparées par et sélectionner la valeur pages vierges ou pages avec code barre dans la liste déroulante, en fonction des pages à utiliser comme séparateurs. Les pages sont assemblées automatiquement sous forme de documents : elles sont ajoutées au document en cours jusqu'à la page de séparation suivante. Pour plus d'informations, consultez la section Ajout d'images de pages.


Modification et publication d'une Définition de Document.

Les définitions de document peuvent être modifiées dans la fenêtre de l'éditeur de définitions de document. Vous pouvez alors modifier la présentation des champs et des éléments statiques, éditer leurs propriétés, leurs règles, les paramètres d'exportation, etc.

Ainsi, pour ne pas affecter le travail exécuté par les membres d'autres projets, lors de la modification d'une définition de document, le programme vous permet d'éditer une copie de définition de document locale tandis que la dernière version de la définition de document publiée est utilisée pour la reconnaissance. Ce mode permet de modifier et de tester localement les définitions de document. De plus, l'opérateur peut terminer la vérification et l'exportation des documents reconnus en utilisant l'ancienne version, même si la définition de document a été considérablement modifiée, voire supprimée. La définition de document en cours d'édition n'est pas accessible pour la modification par d'autres utilisateurs. Une fois la modification de la définition de document terminée, vous pouvez soit la publier, soit créer une nouvelle version disponible pour la reconnaissance de document, soit annuler toutes les modifications.

Pour éditer une définition de document, procédez comme suit :

  1. Dans la fenêtre principale du programme, sélectionnez l'élément de menu Projet > Définitions de document….
  2. Sélectionnez la définition de document à modifier.
  3. Cliquez sur le bouton Éditer… dans la boîte de dialogue Définitions de document pour démarrer la modification de la définition de document. Une version locale de la définition de document sera copiée sur votre PC La définition de document ne pourra être modifiée par d'autres utilisateurs.
  4. Exécutez les modifications nécessaires dans la fenêtre de l'éditeur de définitions de document. Enregistrez la définition de document.
  5. Testez la définition de document avec plusieurs images. Pour procéder aux ajustements de la définition de document, vous pouvez utiliser des lots de tests qui fonctionnent avec la version locale de la définition de document.
  6. Cliquez sur le bouton Publier dans la boîte de dialogue Définitions de document pour publier la définition de document. Après la publication, la nouvelle version de la définition de document sera utilisée pour la reconnaissance des documents dans les lots de travail. La définition de document peut à présent être modifiée par d'autres administrateurs. Pour revenir à la définition de document initiale, cliquez sur Refuser les modifications.
  7. Les définitions de document sont appliquées selon leur ordre dans la liste de la fenêtre Définitions de document. Modifiez l'ordre des définitions de document si nécessaire.
  8. Pour accélérer l'association FlexiLayout, sélectionnez Utiliser la première présentation flexible acceptable pour que le programme utilise la première association FlexiLayout. Sinon, le programme tente d'appliquer tous les FlexiLayouts et sélectionne la meilleure association.

Une nouvelle version de définition de document est utilisée pour la reconnaissance et la suite du traitement documentaire tout de suite après la publication. Toutefois, la version de la définition de document précédente est utilisée pour les documents traités au moment de la publication. Vous pouvez mettre à jour la définition de document pour les documents en cours de traitement en sélectionnant Outils>Mettre à jour vers la version la plus récente. En fonction des modifications de la définition de document exécutées, un message est affiché vous invitant à reconnaitre à nouveau les documents (si les paramètres de reconnaissance ont été modifiés), à revérifier les règles (si les règles ont été modifiées) ou à exporter à nouveau les documents, (si les paramètres d'exportation ont été modifiés).


Test de Définitions de Document

Avant de commencer à entrer des documents en masse, vous devez tester les définitions de document Les tests sont effectués à l'aide de documents ajoutés aux lots de test, puisque ces lots fonctionnent avec la version locale de la définition de document. Ces lots sont disponibles dans le menu Projet>Lots de test de la fenêtre principale du programme. Vous pouvez également accéder aux lots de test à partir de la fenêtre de l’éditeur de définitions de document, en sélectionnant Outils>Basculer vers le lot de test….

Important ! Seul l'utilisateur qui a créé un lot de test est autorisé à utiliser celui-ci. Si nécessaire, vous pouvez utiliser un lot de travail comme lot de test, auquel cas il fera office de source d'images pour le lot de test.

Vous pouvez tester une définition de document directement dans l’éditeur de Définitions de document à partir de l’image utilisée pour la créer. Pour démarrer le test, sélectionnez Document>Exécuter le test. Un formulaire de données identique à celui utilisé dans le cadre du traitement de documents s’affiche et les erreurs de formatage, les caractères incertains et les erreurs de règles apparaissent.

Vous pouvez réorganiser les fenêtres depuis le menu Document>Afficher et parcourir les éléments de vérification, les caractères incertains et les erreurs de règles depuis le menu Document>Vérification. Cliquez sur le bouton Terminer un test ou sélectionnez Document>Terminer le test pour interrompre le test.

Remarque : En mode test, si la bordure d’un champ est modifiée, le programme ne doit pas reconnaître le champ à nouveau étant donné que vous modifiez les bordures de champs dans la fenêtre de document.

Pour tester votre définition de document sur d'autres images, sélectionnez un lot de test (pour ce faire, vous pouvez sélectionner Outils>Basculer vers le lot de test… dans l'éditeur de définitions de document). Le programme vérifie que la définition de document actuelle ne comporte pas d’erreur avant d’afficher la boîte de dialogue de sélection du lot. Si la définition de document ne comporte aucune erreur, elle est enregistrée et la boîte de dialogue de sélection du lot s’affiche. Lorsque vous sélectionnez un lot dans cette boîte de dialogue, la fenêtre principale du programme s’active et bascule automatiquement sur le lot nouvellement sélectionné.

Nous recommandons de tester chaque définition de document avec au moins 20 images de document (si les documents sont remplis à la main, il est préférable d'utiliser des documents remplis par des personnes différentes).

Il est nécessaire d'effectuer des tests afin de déterminer si :

  1. Il y a suffisamment d'ancres et d'identificateurs marqués pour l'application d'une définition de document donnée à une image.
  2. Les propriétés des champs ont été configurées correctement.
  3. Les règles ont été configurées correctement.
  4. L'exportation a été configurée correctement.

Pendant le test, vous devez effectuer l'ensemble des opérations effectuées lors du traitement de documents.

Si des erreurs de règle, des valeurs de champ incorrectes, etc. sont détectées pendant le test, vous devez modifier la définition de document afin de les corriger.

Ce n'est qu'après avoir éliminé tous les problèmes détectés que vous pouvez publier la définition de document et commencer à entrer des documents en masse.

puce Utilisation d'un projet configuré


Classifieurs

Classifieur

Un classifieur est un projet créé sous ABBYY FlexiLayout Studio pour une identification préliminaire des pages individuelles et pour les classer comme appartenant à un type particulier. Par exemple, les pages peuvent être classées en fonction d'un projet FlexiLayout ou en fonction d'une alternative de mise en page. Dès qu'un classifieur est créé sous ABBYY FlexiLayout Studio, il peut être utilisé sous ABBYY FlexiCapture pour classer les documents au niveau projet ou au niveau type de lot.

Pour ajouter un projet classifieur au niveau du projet :

  1. Ouvrez le projet.
  2. Dans la fenêtre principale, sélectionnez Propriétés du projet… dans le menu Projet. La boîte de dialogue propriétés du projet apparaît.
  3. Cliquez sur l'onglet Reconnaissance puis sur Charger…
  4. Sélectionnez le fichier *.cfl contenant le classifieur.

Remarque : Si, en créant un lot, Par défaut a été spécifié comme type de lot, les paramètres spécifiés dans les propriétés du projet seront utilisés pour le traitement.

Pour ajouter un projet classifieur au niveau du type de lot :

  1. Ouvrez la boîte de dialogue Types de lots en sélectionnant Projet>Types de lot…
  2. Sélectionnez le type de lot dans la liste et cliquez sur Éditer…La boîte de dialogue Propriétés du type de lot apparaît.
  3. Cliquez sur l'onglet Reconnaissance puis, dans la section classifieur, cliquez sur Charger…
  4. Sélectionnez le fichier *.cfl contenant le classifieur.

Les classifieurs peuvent être utilisés dans les buts suivants :

  • Pour accélérer la sélection de la définition de document. L'utilisation d'un classifieur permet au programme de ne pas parcourir tous les définitions disponibles à la recherche de la meilleure association mais de sélectionner la définition de document appropriée en fonction des caractéristiques de la classification. L'ordre de la recherche est déterminé par l'utilisateur qui sélectionne les caractéristiques de la classification et crée l'arborescence du classifieur. Les gains de vitesse sont particulièrement remarquables dans le cas d'un projet à grande échelle impliquant de nombreuses définitions de document.
  • Pour répartir les caractéristiques de la classification dans l'arborescence du classifieur. Par exemple, au plus haut niveau, vous pouvez sélectionner des documents envoyés par une certaine entreprise en fonction d'une section de document comportant le nom de cette entreprise. Au niveau suivant, les documents peuvent être classés en fonction de leurs titres ou en fonction du nombre de séparateurs présents sur une page particulière.
  • Pour gérer l'application de structures FlexiLayout tierces. Il est possible que les structures FlexiLayout créées par un éditeur tiers ne correspondent pas exactement à leurs documents. Dans ce cas, vous pouvez utiliser un classifieur pour remédier au problème sans contacter l'éditeur.
  • Pour accélérer la progression des projets contenant des définitions de documents en plusieurs langues. Si un classifieur est utilisé, la pré-reconnaissance des documents n'est effectuée que deux fois : pendant le classement des documents et pendant l'application de la définition de document sélectionnée. Sinon la pré-reconnaissance doit être effectuée pour chaque langue de définition de document du projet.

Pour obtenir des informations supplémentaires sur les classifieurs, consultez l'aide d'ABBYY FlexiLayout Studio.


Profils d'importation d'image

Le traitement de documents démarre lors de l'ajout de nouvelles images. Généralement, les images sont ajoutées sur la station de numérisation (pour plus d'informations, consultez l'aide de la station de numérisation). Cependant, de nouvelles images peuvent également être ajoutées sur la station de vérification, sur la station de configuration de projet ou automatiquement à partir des dossiers actifs.

Vous pouvez automatiser les routines d'ajout d'images sur la station de vérification et/ou sur la station de configuration de projet si les images sont régulièrement prises à partir de la même source. Pour automatiser le processus, créez un profil d'importation d'image sur la station de configuration de projet. Vous pouvez également configurer le traitement des images entrantes et l'ajout périodique d'images en mode Arrière-plan. Une fois les paramètres requis configurés, il suffit de cliquer sur un bouton pour que les images soient numérisées ou importées à partir d'une source prédéfinie, et les images reçues sont traitées (elles sont nettoyées, par exemple). Si nécessaire, vous pouvez modifier la source de l'importation d'image ou ses paramètres.

Si les sources d'importation changent souvent, vous pouvez créer plusieurs profils d'importation et passer de l'un à l'autre pour ne pas avoir à modifier constamment les paramètres de source d'importation.

Création d'un profil d'importation

Pour ajouter un profil d'importation, sélectionnez l'élément de menu Projet > Profils d'importation d'images… dans la fenêtre principale du programme. Dans la boîte de dialogue qui s'ouvre, vous pouvez créer de nouveaux profils d'importation. Vous pouvez aussi modifier, supprimer et copier des profils existants.

Vous pouvez créer un nouveau profil d'importation à l'aide de l'assistant de profil, accessible à partir de la boîte de dialogue Profils d'importation d'image en cliquant sur Nouveau… À la première étape de l'assistant, sélectionnez une source d'importation (par exemple, un scanner ou un dossier actif).

Création d'un profil d'importation avec un scanner
  1. Sélectionnez Scanner comme source d'importation.

    Important ! Le scanner doit être connecté. Pour vérifier s'il est connecté correctement, consultez sa documentation. Veillez à installer tous les logiciels fournis avec le scanner.

  2. À la deuxième étape, vous pouvez configurer les options pour la numérisation et le traitement des images :
    • Style de la boîte de dialogue des paramètres : choisissez la méthode d'interaction entre le programme et le scanner :
      • Paramètres du scanner FlexiCapture : avec cette option, les options de numérisation sont définies dans la boîte de dialogue Paramètres du scanner d'ABBYY FlexiCapture. Cliquez sur le bouton Paramètres… pour configurer les options de numérisation. Si vous activez l'option Afficher les paramètres du scanner avant la numérisation, la boîte de dialogue Paramètres du scanner d'ABBYY FlexiCapture apparaît quand vous sélectionnez ce profil d'importation avant de numériser.
      • Options de numérisation : avec cette option, les options de numérisation sont définies dans la boîte de dialogue du pilote de scanner correspondant. Dans ce cas, vous ne pourrez pas modifier les options de numérisation lors de la création du fichier d'importation, mais la boîte de dialogue des paramètres du scanner apparaîtra avant chaque numérisation d'image.
    • Indiquez si vous souhaitez numériser une ou plusieurs images en une même passe.
  3. À l'étape suivante, vous pouvez configurer les options pour déterminer la manière dont les images doivent être ajoutées aux documents et traitées. Pour plus d'informations, consultez la section Options de prétraitement d'image.
  4. À la dernière étape, vous pouvez modifier le nom par défaut attribué à un profil d'importation et entrer votre commentaire.
Création d'un profil d'importation avec un dossier actif
  1. Sélectionnez Dossier actif comme source d'importation. Spécifiez le chemin du dossier actif en cliquant sur le bouton Parcourir…

    Important ! Pour pouvoir ajouter des images à partir du dossier actif, l'utilisateur doit disposer de droits d'accès en lecture et en écriture pour ce dossier.

  2. À la seconde étape, paramétrez les options de chargement d'image :
    • Vérifier le dossier actif toutes les : activez cette option et indiquez à quel intervalle de temps le programme doit vérifier automatiquement si le dossier actif contient de nouvelles images.

      Remarque : Pour lancer l'importation d'images à partir de dossiers actifs, activez les dossiers actifs pour un projet donné dans le moniteur de serveur de traitement.

    • Dans Paramètres du lot, activez l'une des options pour désigner le lot à utiliser pour l'ajout de nouvelles images.
      • Ajouter des images au lot courant : activez cette option pour ajouter des images provenant du dossier actif au lot en cours.
      • Ajouter des images au lot spécifié : activez cette option et sélectionnez le nom du lot dans la liste déroulante pour ajouter des images à un lot précis.
      • Créer de nouveaux lots pour les images importées automatiquement : activez cette option pour créer automatiquement des lots pour les nouvelles images. Dans le champ Type de lot , indiquez le type du lot. Si nécessaire, définissez les paramètres d'enregistrement de lot (cliquez sur Paramètres d'enregistrement…) et modifiez sa priorité dans le champ Priorité .
    • Dans la liste déroulante Nombre de fichiers à ajouter, sélectionnez l'une des valeurs pour indiquer le nombre de fichiers à ajouter au dossier désigné ou nouvellement créé :
      • En fonction du fichier de description : les fichiers seront ajoutés conformément à la description. Pour spécifier le nom et le type du fichier de description, cliquez sur le bouton Paramètres…. Pour plus d'informations, consultez la section Fichier de description.
      • Tous les fichiers > tous les fichiers du dossier actif seront ajoutés.
      • Depuis un sous-dossier : ajoute des fichiers à partir des sous-dossiers dont les noms sont conformes au format spécifié. Cliquez sur Paramètres… pour définir un nom de format.
      • Plusieurs fichiers : plusieurs fichiers seront ajoutés. Pour indiquer le nombre de fichiers, cliquez sur le bouton Paramètres… et entrez le nombre ou la plage de valeurs.
      • Remarque : Si vous indiquez un certain nombre de fichiers, par exemple 5, et qu'il n'en reste que 4 dans le dossier actif, ils ne seront pas importés. Si vous indiquez une plage, par exemple 1-5, les 5 fichiers restants seront importés.
      • Un seul fichier : un seul fichier sera ajouté.
    • Si le profil est destiné à importer des photos plutôt que des images numérisées, sélectionnez Traiter l'image comme une photo.
  3. À l'étape suivante, vous pouvez configurer les options pour déterminer la manière dont les images doivent être ajoutées aux documents et traitées. Pour plus d'informations, consultez la section Options de prétraitement d'image.

  4. À la quatrième étape, l'assistant de profil vous demande de définir les options pour le nettoyage du dossier actif après l'importation : les images importées avec succès peuvent être supprimées ou déplacées dans un dossier spécifique. Les images dont l'importation a provoqué une erreur peuvent rester dans le dossier actif ou être elles aussi déplacées dans un dossier spécifique. Si vous souhaitez déplacer des images, indiquez vers quels dossiers.

  5. À la dernière étape, vous pouvez modifier le nom par défaut attribué à un profil d'importation et entrer votre commentaire.

Vous pouvez également modifier et créer des profils d'importation d'image dans la boîte de dialogue Sélectionner le profil d'importation qui apparaît lorsque vous sélectionnez Fichier>Importer des images… à partir du menu principal.

Ajout d'images de pages


Options de prétraitement d'image

Lorsque de nouvelles images sont ajoutées à un lot, le programme procède au prétraitement des images : les images sont séparées en documents, nettoyées de tout parasite, pivotées, etc.

Vous pouvez sélectionner des options de prétraitement d'images sur l'onglet Prétraitement d'images. Vous pouvez sélectionner les options de prétraitement pour :

  1. Un projet. Le cas échéant, les options sélectionnées sont utilisées par défaut lorsque de nouvelles images sont ajoutées manuellement aux lots du projet. Sélectionnez Projet>Propriétés du projet… dans la fenêtre principale puis cliquez sur l'onglet Prétraitement d'images .
  2. Un profil d'importation. Vous utilisez ces options lorsque de nouvelles images sont ajoutées à l'aide de ce profil d'importation. Lors de la création d'un nouveau profil d'importation , sélectionnez les options de prétraitement d'image au niveau du Prétraitement d'images.
  3. Images ajoutées manuellement. Lors de l'ajout d'images à partir d'un fichier, cliquez sur le bouton Paramètres du prétraitement d'images… dans la boîte de dialogue Charger les images .

Remarque : les images numérisées manuellement ne sont pas prétraitées. Les images ne sont prétraitées que si un profil d'importation est utilisé pour les ajouter.

Les utilisateurs peuvent sélectionner les options de prétraitement d'image suivantes :

  • Options déterminant les principes de l'ajout d'images aux documents :
    • Automatiquement lorsque la définition de document est associée – Sélectionnez cette option si vous souhaitez que des images soient séparées en documents pendant l'association (pendant la reconnaissance).Dans ce cas, les images ne seront pas immédiatement séparées en documents lorsqu'elles seront ajoutées. Les documents ne seront assemblés qu'après que les pages aient été analysées et reconnues en se basant sur la structure décrite dans la définition de document appropriée. Pour obtenir des détails à ce sujet, consultez Création de définitions de documents pour des documents multipages et Assemblage de pages en documents.
    • Pour chaque fichier image (Pour chaque fichier image),
    • Ou un nouveau document sera créé lorsque le programme atteindra une feuille de séparation (Pour les images séparées par).

    • Pour utiliser des pages vierges comme séparateurs, sélectionnez pages vierges dans la liste déroulante.
      Pour utiliser des pages avec des codes barres comme séparateurs, sélectionnez pages avec code barre dans la liste déroulante. Vous pouvez définir le type de codes barres et/ou sa valeur en cliquant sur le bouton Paramètres… . Si aucun code barre ni aucune valeur n'a été spécifié, toute page comportant un code barre sera traitée comme une page de séparation. Sinon, seules les pages comportant des codes barres du type ou de la valeur indiqués seront utilisées. S'il ne vous est pas nécessaire d'ajouter des pages de séparation au lot, sélectionnez Supprimer les pages du séparateur. Si cette option n'est pas cochée, des pages de séparation sont ajoutées au lot et deviennent les premières pages de chaque document.

    Remarque Vous n'avez pas besoin d'utiliser des pages de séparation pour scinder des pages en plusieurs documents. Ces séparateurs ne doivent être utilisés que quand l'apparence de la page empêche de déterminer si elle fait partie du document précédent ou suivant : par exemple, quand un document comprend un certain nombre de pages identiques et que le lot contient plusieurs documents de ce type.

  • Configurez les options de traitement d'image :
    • Nettoyer les images – supprime le bruit des images ;
    • Convertir les images en couleur et en niveaux de gris en images noires et blanches – convertit des images en noir et blanc ;
    • Faire tourner les images de – fait tourner les images dans la direction spécifiée.
  • Options de suppression de la mise en travers.Ces options sont sélectionnées par défaut et le programme supprime la mise en travers des images nouvellement ajoutées en s'appuyant sur les carrées noirs et/ou les séparateurs verticaux et horizontaux. Il n'est pas conseillé de désactiver les options de suppression de la mise en travers à mois que la suppression de la mise en travers soit effectuée de manière incorrecte (par exemple, si le programme interprète un tampon ou un graphique comme un séparateur et tente de supprimer la mise en travers de l'image à partir de ces données erronées).
    • Utiliser des séparateurs noirs pour corriger la mise en travers – Si cette option est sélectionnée, les images sont réalignées en se basant sur les lignes de séparation;
    • Utiliser des carrés noirs pour corriger la mise en travers – Si cette option est sélectionnée, les images sont réalignées en se basant sur des carrés noirs.


Paramètres d'exportation par défaut

Le programme utilise les paramètres d'exportation par défaut quand vous effectuez une exportation vers un fichier ou une base de données sans utiliser de paramètres de définition de document, mais aussi pour les définitions de document pour lesquelles aucun paramètre d'exportation n'a été configuré.

Les paramètres d'exportation sont configurés pour chaque définition de document, mais vous pouvez parfois avoir besoin d'exporter les données vers un autre emplacement de stockage, par exemple pour effectuer un test. Dans ce cas, l'opérateur peut utiliser le menu du bouton d'exportation et exporter les données vers un fichier ou une base de données avec des paramètres différents de ceux de la définition de document. Consultez la section Exportation des données reconnues. Le programme utilise également les paramètres par défaut la première fois que vous effectuez une exportation. Si, par la suite, vous modifiez les paramètres d'exportation, le programme enregistre les derniers paramètres utilisés.

Vous pouvez configurer les paramètres utilisés pour l'exportation vers un fichier ou une base de données dans l'onglet Exportation de la boîte de dialogue Propriétés du projet (à partir de l'élément Projet > Propriétés du projet… du menu principal). Cet onglet affiche les paramètres d'exportation par défaut actuels. Vous pouvez configurer les paramètres pour une exportation vers un fichier ou une base de données. Pour modifier les paramètres d'exportation par défaut, cliquez sur Éditer…. Configurez-les ensuite en procédant comme pour les paramètres d'exportation de la définition de document (consultez la section Configuration de l'exportation de données).


Lots

Les documents à traiter sont placés dans des lots. Les principes de regroupement de documents en lots sont déterminés par l'utilisateur. Par exemple, l'utilisateur peut choisir de traiter tous les documents comme un seul lot ou de grouper tous les documents importés le même jour ou numérisés en une fois.

Sur les stations de traitement, les lots sont créés automatiquement lors de l'importation d'images à partir des dossiers actifs. Sur la station de numérisation, les lots peuvent être créés manuellement par un opérateur, ou automatiquement si des profils de numérisation sont disponibles. Lorsqu'un lot est créé, son type doit être précisé car il définit la manière dont le lot sera traité.

Les images de pages sont ajoutées pendant le traitement. Consultez la section Ajout d'images de pages pour obtenir plus d'informations.

Sur la station de configuration du projet, les définitions de document peuvent être déboguées en créant des lots, en ajoutant des images de documents dans les lots et en les traitant (c'est-à-dire en les reconnaissant, en les vérifiant et en exportant les résultats). Pour créer un nouveau lot, cliquez sur la liste de lots dans la fenêtre principale avec le bouton droit de la souris et sélectionnez Nouveau lot... dans le menu contextuel.

Lots de travail et de test

Les lots de test sont utilisés par l'opérateur de configuration de lot pour tester et déboguer les définitions de document. Les lots de travail sont destinés au traitement de documents par le biais d'ABBYY FlexiCapture 9.0. L'opérateur de configuration de lot peut également accéder aux lots de travail si des erreurs se produisent pendant le traitement. Si l'événement est une erreur, l'opérateur peut ouvrir le lot et corriger l'erreur. Les lots de test et les lots de travail sont différents dans le sens où la définition de document locale est utilisée pour traiter les documents d'un lot de test tandis qu'une définition de document publiée est utilisée pour traiter les documents d'un lot de travail. Consultez la section Modification et publication d'une définition de document.

Pour ouvrir la liste des lots, sélectionnez la Lots ou la Lots de test à partir du menu Afficher sur la station de configuration de projet.


Champs d'index

Afin de faciliter la recherche de documents et leur traitement, vous pouvez indexer ces documents à l'aide des valeurs contenues dans tout champ d'une définition de document. Dans la liste de documents de la fenêtre principale du programme, outre les informations de base, vous pourrez extraire les valeurs du champ d'index de chaque document et vous servir de ces valeurs pour trier les documents et localiser aisément les documents requis.

Pour indexer les documents à partir des valeurs de champs, activez l'option Champ d'index pour ce champ (ongletGénéralités dans l'éditeur de définitions de documents).

Pour afficher la valeur du champ d'index dans la liste de documents :

  • Dans la fenêtre principale du programme, ouvrez un lot de documents et activez le mode de liste de documents détaillée (bouton [image] de la barre d'outils).
  • Cliquez avec le bouton droit de la souris sur la région d'en-tête de tableau (noms de colonnes) et sélectionnez Personnaliser… dans la liste déroulante.
  • Dans la boîte de dialogue Choisir des colonnes, cliquez sur le bouton Nouveau… .
  • Dans la boîte de dialogue Éditer la colonne, cliquez sur le bouton Sélectionner… situé à droite du IDD_SH_NEW_SUPER_GRID_COLUMN::IDC_INDEXED_FIELD_NEW_COLUMNchamp d'index. Dans la boîte de dialogue qui s'ouvre, sélectionnez l'un des champs avec l'option Champ d'index activée. Vous pouvez aussi saisir un nom de colonne et spécifier la méthode de justification.
  • Une autre colonne contenant la valeur du champ d'index apparaîtra dans le tableau. Cliquez dessus pour trier les documents en fonction de la valeur du champ d'index.


Utilisation d'un projet configuré

Les documents passent par différentes étapes de traitement. Lorsque vous créez et configurez un projet, vous devez spécifier les étapes et les circonstances pour lesquelles le contrôle de l'opérateur ou une correction d'erreur sont requis. Pour ces étapes, des files de tâches sont créées. De plus, une file spéciale des exceptions est disponible pour les documents problématiques.

Les opérateurs sont les utilisateurs du système qui surveillent le traitement et corrigent les erreurs présentes dans les documents ou dans les lots. Le tableau liste les opérateurs d'ABBYY FlexiCapture ainsi que les stations et les files qui leur sont accessibles.

Opérateur | Stations | Files | Fonctions
Opérateur de suivi | Console d'administration et de suivi | - | Surveillance du fonctionnement du système
Opérateur de numérisation | Station de numérisation | - | Numérisation de documents ou importation d'images de documents, envoi de documents au traitement
Opérateur de vérification de données | Station de vérification de données Station de vérification (vérification de champs et de groupes uniquement) | Vérification des données | Vérification et correction des caractères mal reconnus (vérification de champs et de groupes)
Opérateur de vérification | Station de vérification de données Station de vérification de données | Vérification des données Vérification Vérification de l'assemblage du document Vérification de l'intégrité du lot | Identique à l'opérateur de vérification de données avec en plus vérification et correction de l'assemblage de document et des erreurs d'assemblage de lot.
Chef-opérateur de vérification | Station de vérification de données Station de vérification | Vérification des données Vérification Vérification de l'assemblage du document Vérification de l'intégrité du lot Confirmation de l'exportation Exceptions | Identique à l'opérateur de vérification de données avec en plus confirmation de l'exportation du document, prise en charge des exceptions

Les opérateurs démarrent les stations appropriées et effectuent les opérations requises conformément aux droits d'accès qui leur sont conférés.


Flux de travail

Les documents sont traités au cours de plusieurs phases. Lors de la phase de traitement, qui peut être automatisée ou qui peut impliquer un opérateur, les documents sont convertis. Toutes les phases sont organisées dans un ordre particulier, et avant qu'un document ne puisse passer à une phase donnée, il doit réussir à passer toutes les étapes précédentes. En général, le traitement de document comprend les phases suivantes : l'ajout d'images, la reconnaissance, la vérification et l'exportation. La phase de vérification est facultative. Les autres phases sont obligatoires.

À chaque phase, une file de tâches se forme. Elle contient une liste des documents à traiter. Alors que le traitement progresse, les documents sont déplacés de la première file (reconnaissance) à la dernière file (exportation). En règle générale, les files correspondent à des phases de traitement, mais il existe également des files spéciales, telle que la file des exceptions.

Phases

  1. Importation d'images

    Les images peuvent être récupérées automatiquement à partir des dossiers actifs ou ajoutées par l'opérateur de la station de numérisation. L'opérateur de numérisation peut les numériser à partir de documents ou importer les images de documents déjà numérisés. Pour automatiser le processus (c'est-à-dire ajouter les images avec des paramètres prédéfinis d'un seul clic de souris), l'opérateur de numérisation peut créer des profils de numérisation.

  2. Reconnaissance. La file de reconnaissance est traitée automatiquement sur la station de traitement.
  3. Vérification. La file de vérification est traitée par l'opérateur de la station de vérification.
  4. Exportation. La file d'exportation est traitée automatiquement sur la station de traitement..

En cas de gros volumes à traiter, la phase de vérification peut être divisée en sous-phases, chaque opérateur n'étant sollicité que pour un nombre de tâches restreint.

Les files séparées suivantes peuvent être créées :

  • Vérification de l'assemblage du document
  • Vérification des données : vérification de groupe et de champ pour les caractères incertains et correction des erreurs de format.
  • Vérification : vérification par règles et vérification de la fenêtre de document.
  • Vérification de l'intégrité du lot.
  • Confirmation de l'exportation.

Remarque : Les files sont définies individuellement pour chaque type de lot.

Les tâches de la file sont traitées par les opérateurs disposant des droits d'accès nécessaires :

  • Opérateur de vérification de données : seulement pour la file de vérification des données.
  • Opérateur de vérification : vérification des données, vérification, vérification de l'assemblage du document, vérification de l'intégrité du lot.
  • Chef-opérateur de vérification : pour toutes les files.

Remarque : La station de vérification de données permet à ses opérateurs de ne traiter que les tâches issues de la file de vérification des données, sans tenir compte des droits d'accès dont il ou elle dispose.


Ajout d'images de pages

Le traitement de document commence par l'importation d'image, une procédure d'ajout d'images de pages de document au projet . Les images proviennent de la station de numérisation ou sont récupérées automatiquement à partir des dossiers actifs.

Importation d'image en arrière-plan

L'importation d'image peut s'effectuer en arrière-plan si le profil d'importation approprié a été configuré. Les images du dossier actif sont importées automatiquement dans le système. Le programme contrôle le dossier à l'intervalle spécifié dans les paramètres afin de déterminer s'il contient de nouvelles images.

Vous pouvez procéder de différentes manières pour ajouter des images à un lot. Vous pouvez :

  1. charger des images enregistrées précédemment à partir de fichiers ;
  2. numériser des images ;
  3. importer des images à l'aide de l'un des profils d'importation configurés précédemment par l'administrateur (consultez la section Profils d'importation d'images).

Ajout d'images manuel

Si nécessaire, les images peuvent être ajoutées au lot manuellement sur la station de vérification (par le chef-opérateur de vérification) ou sur la station de configuration de projet. Les images sont ajoutées en mode affichage de lot. Ouvrez les lots dans lesquels vous souhaitez ajouter des images ou sélectionnez simplement ce lot dans la liste.

Les méthodes suivantes permettent d'ajouter des images dans un lot. Vous pouvez :

  • charger des fichiers d'images déjà enregistrés ;
  • numériser des documents ;
  • importer des images en utilisant l'un des profils d'importation d'images déjà créés (consultez la section Profils d'importation d'images).

Pour ajouter les images, faites un clic droit sur le lot puis sélectionnez l'élément de menu correspondant à partir du menu contextuel.

Ajout d'images à partir d'un fichier

Pour charger les images à partir d'un fichier, sélectionnez l'élément de menu Charger des images… ou utilisez le raccourci CTRL+O. Dans la boîte de dialogue qui s'ouvre, sélectionnez les fichiers d'image requis et configurez les options d'importation d'image :

  • Créer un nouveau document, de nouveaux documents seront créés pour les images ajoutées.
  • Ajouter au document courant, les images seront ajoutées au document courant mis en surbrillance.
  • Vous pouvez également sélectionner les options de prétraitement d’image. Cliquez sur le bouton Paramètres du prétraitement d'images… et sélectionnez les options souhaitées dans la boîte de dialogue qui apparaît. Pour plus d'informations, consultez la section Options de prétraitement d'image.

Numérisation d'images

Pour ajouter les images à partir d'un scanner, sélectionnez l'élément de menu Numériser les images… Choisissez un scanner, configurez les options de numérisation et numérisez les images.

Ajout d'images à l'aide de profils d'importation

Si l'administrateur a configuré des profils d'importation, leurs noms apparaissent dans le menu du bouton d'importation. Pour commencer à importer des images, il suffit de sélectionner un élément ayant le même nom que l'un des profils d'importation.

Une fois que vous avez sélectionné Importer des images…, la boîte de dialogue Sélectionner le profil d'importation s'ouvre. Sélectionnez le profil d'importation dans la liste et cliquez sur le bouton Importer pour commencer à importer des images.


Configuration des options de numérisation

En général, les documents devant être traités proviennent de la station de numérisation ou du dossier actif. Toutefois, les documents peuvent également être numérisés sur la station de vérification ou sur la station de configuration de projet. Dans ce cas, les paramètres de numérisation requis doivent être sélectionnés.

La qualité de la reconnaissance dépend dans une large mesure de la qualité de l'image source. Vous pouvez ajuster la qualité de l'image en configurant les options de numérisation de base : le type d'image, la résolution et la luminosité.

Quand vous numérisez des images via ABBYY FlexiCapture, vous pouvez choisir entre deux modes d'interaction entre le programme et le scanner compatible TWAIN ou ISIS :

  • Interface d'ABBYY FlexiCapture :
    dans ce cas, les options de numérisation sont configurées à l'aide de la boîte de dialogue Paramètres du scanner d'ABBYY FlexiCapture. Vous pouvez configurer les options de numérisation au moment de créer un profil d'importation en spécifiant la source d'importation du Scanner .
  • Interface du pilote TWAIN ou ISIS du scanner :
    la boîte de dialogue du pilote de scanner correspondant sert à configurer les options de numérisation. Cette boîte de dialogue s'ouvre automatiquement quand vous sélectionnez Numériser les images… dans le menu déroulant du bouton d'importation.

Options de numérisation de base

  • Type d'image : la numérisation en niveaux de gris (256 niveaux de gris) est le mode optimal pour le système de reconnaissance. Quand vous numérisez en niveaux de gris, le programme sélectionne automatiquement le niveau de luminosité.

    Le type d'image noir et blanc assure une vitesse de numérisation supérieure mais peut entraîner la perte de certaines informations sur les lettres, ce qui affecte la reconnaissance des impressions de qualité moyenne ou basse.
    Si vous avez besoin que les éléments en couleur du document (les photos, les lettres en couleur et les arrière-plans en couleur) soient restitués en couleur dans le document électronique, sélectionnez le type d'image couleur. Dans les autres cas, utilisez le type d'image niveaux de gris.

  • Luminosité et contraste : vous devez également spécifier des valeurs pour la luminosité et le contraste, afin de préserver les blocs d'ancre mais aussi de rendre les images de bloc destinées à être reconnues aussi claires et définitives que possible.
    Le plus souvent, la valeur de luminosité moyenne de 50 % est adaptée.
    Vous devrez peut-être configurer une nouvelle fois la luminosité si vous numérisez certains documents en noir et blanc.
  • Résolution : la résolution recommandée pour le traitement des formulaires remplis à la main est de 300 ppp pour la numérisation en noir et blanc et de 200 ppp pour la numérisation en niveaux de gris. La résolution des formulaires numérisés doit correspondre à celle de l'image du modèle.

Remarque :

  1. Si vous numérisez à une résolution de 400 à 600 ppp au lieu de 300 ppp, ou en niveaux de gris ou en noir et blanc plutôt qu'en couleur, l'opération risque de prendre beaucoup plus de temps. Avec certains modèles de scanners, à 600 ppp, la résolution peut prendre 4 fois plus de temps qu'à 300 ppp. Il est déconseillé de numériser à une résolution inférieure à 200 ppp.
  2. Quand vous utilisez la boîte de dialogue du pilote du scanner, les paramètres de numérisation peuvent changer en fonction du modèle de scanner. Par exemple, la luminosité peut s'appeler « Seuil » ou être symbolisée par un soleil ou un cercle noir et blanc. La signification des options est décrite dans la documentation qui accompagne votre scanner.
Conseils sur le mode de numérisation
  1. Numérisation de formulaires à arrière-plan couleur à l'aide d'un scanner monochrome. Pour que l'arrière-plan disparaisse pendant la numérisation, vous devez équiper le scanner d'une lampe qui filtre la lumière : pour les formulaires roses, une lampe rouge ; pour les formulaires verts, une lampe verte.
  2. Numérisation de formulaires à arrière-plan couleur à l'aide d'un scanner couleur. Pour que l'arrière-plan disparaisse pendant la numérisation, vous devez configurer le mode de filtrage pour la couleur correspondante dans les paramètres du scanner.
  3. Numérisation de formulaires à arrière-plan couleur avec des ombres. Si vous traitez des formulaires couleur avec des ombres, du fait de la faible intensité de la couleur, l'arrière-plan peut disparaître pendant la numérisation avec une lampe blanche même si vous ne filtrez pas la couleur à l'aide du logiciel. En règle générale, la méthode de numérisation des formulaires est définie lors de la conception de ces formulaires.
Conseils pour sélectionner la luminosité
  1. Une image numérisée doit être lisible (pour afficher une image numérisée, ouvrez-la dans la fenêtre de document).
  2. Si, dans une image numérisée, les lettres sont déchirées, trop claires ou trop fines :
    • réduisez la luminosité, augmentez le contraste (afin de rendre l'image plus sombre) ; ou
    • essayez de numériser l'image en niveaux de gris (dans ce cas, la luminosité sera sélectionnée automatiquement).
  3. Si l'arrière-plan de l'image numérisée est sale, si les caractères sont déformés, maculés, fondus, trop sombres ou trop épais :
    • augmentez la luminosité (afin de rendre l'image plus claire) ; ou
    • essayez de numériser l'image en niveaux de gris (dans ce cas, la luminosité sera sélectionnée automatiquement).


Reconnaissance

Les documents sont reconnus automatiquement sur les stations de traitement.

Le système sélectionne la définition de document correspondante en fonction des ancres et des identificateurs puis reconnaît les données dans les champs correspondant aux champs de la définition de document sélectionnée.

Le ratio entre les caractères reconnus de manière fiable et le nombre total de caractères est affiché dans la colonne Niveau de confiance.

Si des modifications sont effectuées au sein du projet pendant la reconnaissance et si le projet inclut une phase de vérification, l'opérateur de vérification et le chef-opérateur de vérification peuvent manuellement lancer une nouvelle reconnaissance des documents à l'aide des nouveaux paramètres. Pour reconnaître à nouveau les documents, démarrez la station de vérification puis sélectionnez Outils>Mettre à jour vers la version la plus récente à partir du menu principal.


Analyse d'image préliminaire et application des définitions de documents

La reconnaissance, l'analyse et l'association de définitions de document s'effectuent automatiquement. Cependant, l'opérateur de vérification et le chef-opérateur de vérification peuvent exécuter manuellement l'analyse et l'association de définitions de document en sélectionnant Outils > Analyser à nouveau sur la station de vérification. Si une définition de document correspond à un document, la page et son document auront des noms correspondants. Si l'une des définitions de document du projet ne correspond pas à une image, la page reste non traitée.

Avant de lancer la reconnaissance, vous pouvez effectuer une analyse pour déterminer quelle définition de document peut être appliquée à une page donnée. Pour ce faire, sélectionnez l'élément du menu principal Reconnaissance > Analyser. Si une définition de document peut être appliquée, la page et le document dont elle fait partie sont nommés en conséquence. Si aucune des définitions de document de projet ne correspond à l'image, la page demeure non traitée.

Vous pouvez également appliquer une certaine définition de document à une page ou à un document entier. Le plus souvent, une définition de document qui a été créée correctement dans le programme s'applique automatiquement aux pages, mais dans certains cas, vous pouvez avoir à appliquer la définition de document manuellement.

Pour appliquer une définition de document :

  1. mettez le document en surbrillance ;
  2. sélectionnez Associer une section de définition de document… dans le menu contextuel du document ou sélectionnez l'élément du menu principal Reconnaissance>Associer une définition de document… ;
  3. dans la boîte de dialogue Sélectionner la définition de document qui s'ouvre, sélectionnez l'une des définitions de document et cliquez sur OK.

Si la définition de document sélectionnée a été appliquée avec succès, le document et ses pages sont nommés d'après la définition de document correspondante et ses sections.

Pour appliquer une définition de document à l'une des pages :

  1. mettez en surbrillance la page ;
  2. sélectionnez Associer une définition de document… dans le menu contextuel de la page ou sélectionnez l'élément du menu principal Reconnaissance>Associer une définition de document… ;
  3. dans la boîte de dialogue Sélectionner la définition de document à associer qui s'ouvre, sélectionnez l'une des définitions de document et cliquez sur OK.

Si la définition de document a été appliquée correctement, la page sélectionnée est nommée d'après la section de définition de document correspondante.


Vérification des données reconnues

La vérification, qui consiste à contrôler les données reconnues, est la phase qui nécessite le plus de travail. Pour cette raison, le processus de vérification au sein d'ABBYY FlexiCapture 9.0 est organisé de manière à être aussi pratique que possible pour l'opérateur, l'objectif étant de réduire le nombre d'erreurs.

Quand le programme n'est pas absolument certain de l'exactitude de certains caractères reconnus, il les marque comme reconnus sans certitude. L'objet de cette vérification est de vérifier ces caractères, de s'assurer qu'ils ont été reconnus correctement, et de les corriger si nécessaire.

La validation par règle est effectuée automatiquement. Si les valeurs des champs respectent les conditions des règles, ces champs peuvent être marqués comme reconnus avec certitude et être exclus du processus de vérification. Quand les valeurs des champs ne respectent pas les conditions des règles, ces champs sont soumis au processus de vérification.

Si un document contient plusieurs pages, vous devez d'abord vérifier l'assemblage des pages sous forme de documents.

Exécutez ensuite le processus de vérification. La vérification s'effectue en deux phases. Il y a d'abord la vérification groupée, puis la vérification de champ. Si, pour une définition de document, il n'y a pas de champs inclus dans la vérification groupée ou dans la vérification de champ (consultez la section Propriétés de la vérification de champ), la phase de vérification correspondante est omise.

La vérification groupée et la vérification de champ sont suivies d'une autre vérification, effectuée dans la fenêtre de document. Les caractères qui n'ont pas été confirmés au cours des phases précédentes restent en surbrillance rouge.

Vous pouvez naviguer au sein des erreurs en cliquant sur les boutons [image] et [image] de la barre d'outils de la fenêtre principale. Le programme navigue au sein de toutes les erreurs, y compris les erreurs d'assemblage, les caractères reconnus sans certitude, les erreurs de règle, etc.

puce | Assemblage de pages sous forme de documents
puce | Vérification groupée
puce | Vérification de champ
puce | Vérification dans la fenêtre de document
puce | Validation par règle


Assemblage de pages sous forme de documents

Les pages sont assemblées automatiquement sous forme de documents. À cet effet, pour créer une définition de document destinée au traitement multipage, vous devez décrire le principe d'assemblage. Vous pouvez aussi configurer la vérification des champs clés.

Le travail de l'opérateur consiste à identifier et à corriger les éventuelles erreurs d'assemblage des documents.

Les erreurs d'assemblage peuvent être corrigées très facilement en mode contour de page, qui permet à l'utilisateur de bien visualiser les images de page et les documents dont elles font partie. Vous pouvez activer ce mode en cliquant sur le bouton [image].

Remarque : Vous pouvez modifier l'échelle des contours de page pour voir les détails en maintenant la touche CTRL enfoncée et en faisant tourner la molette de défilement.

Remarque : L’ordre des sections n’est pas vérifié si, à la création de la définition de document, l’option Désactiver la vérification de l'ordre des sections a été sélectionnée dans l'onglet Assemblage. Le programme continue de vérifier que toutes les sections sont présentes dans le document mais l’ordre des sections est ignoré.

Lors de la création d'une définition de document, vous devez configurer la règle d'assemblage de documents : la séquence et le nombre de sections de document récurrentes. Vous pouvez également configurer la vérification de l'assemblage à partir des valeurs des champs clés : dans ce cas, les champs clés doivent avoir la même valeur sur toutes les pages d'un même document.

Les documents présentant des erreurs d'assemblage sont marqués de ce symbole [image]. Une description de l'erreur est fournie en caractères rouges sous le nom de la définition de document.

Comment corriger les erreurs d'assemblage

  1. Séquence de pages incorrecte dans un document

    Il peut y avoir trop peu ou trop de pages, et certaines pages de document risquent de ne pas être organisées dans le bon ordre. Pour lire un conseil, placez votre curseur sur la page marquée d'une croix rouge :

    Pour corriger ces erreurs, vous pouvez utiliser la souris pour déplacer la page au sein d'un même document ou d'un document à un autre.

    Vous pouvez fusionner des pages provenant de documents différents dans un même document de la manière suivante :

    • Mettez en surbrillance les documents à fusionner (utilisez la combinaison CTRL+clic pour sélectionner plusieurs documents).
    • Cliquez à l'aide du bouton droit de la souris et sélectionnez Fusionner dans le menu contextuel.

    Pour scinder des pages au sein d'un document et placer chacune d'elles dans un document distinct :

    • Mettez en surbrillance le document dans lequel vous souhaitez scinder des pages.
    • Sélectionnez Scinder dans le menu contextuel.

  2. Si la définition de document nécessite que vous vérifiiez les champs clés afin de déterminer si l'assemblage des pages est correct, les valeurs des champs clés s'affichent sous l'image de chaque page :

    • en surbrillance grise s'il y a une correspondance ;
    • en surbrillance rouge s'il n'y a pas de correspondance.

    Les champs clés ne peuvent pas correspondre s'ils n'ont pas été reconnus ou remplis correctement. Vérifiez les valeurs des champs clés. Si elles ne correspondent pas, les pages en question ne font probablement pas partie du même document. Si la séquence de pages est incorrecte, identifiez les pages qui ont des champs clés identiques et assemblez-les sous forme de documents comme décrit à l'étape 1.


Vérification groupée

La vérification groupée consiste à grouper les images de caractères reconnues comme ayant des valeurs identiques, puis à les afficher sur l'écran du vérificateur, ce qui permet à l'opérateur d'identifier et de corriger les caractères qui divergent du groupe.

Affichage de la fenêtre de vérification groupée

Pendant la vérification groupée, l'opérateur peut afficher le contexte du caractère en cours de vérification en sélectionnant l'élément Afficher l'image des caractères dans le menu contextuel du caractère en surbrillance ou en appuyant sur F2.

Vous pouvez aussi activer un mode dans lequel le champ contenant le caractère s'affiche quand vous pointez le curseur sur le caractère en cours de vérification. Pour ce faire, sélectionnez l'élément de menu Afficher>Image du champ>Afficher l'image du champ dans la fenêtre du vérificateur, ou utilisez le raccourci CTRL+I.

Vous pouvez corriger les caractères mal reconnus de la manière suivante : sélectionnez le caractère qui ne correspond pas au caractère du groupe, puis entrez la valeur correcte. Cette valeur, en surbrillance verte, apparaît dans l'angle supérieur gauche de l'image du caractère.

Si vous avez toujours des doutes sur la signification du caractère même après l'avoir affiché dans son contexte, cliquez dessus : il est alors mis en surbrillance, et un point d'interrogation apparaît dessus.

Vous pouvez aussi activer ou désactiver l'état des caractères à l'aide du bouton Basculer de la barre d'outils.

Vous pouvez confirmer les caractères reconnus correctement en sélectionnant Confirmer dans le menu contextuel. Pour confirmer tous les caractères simultanément, cliquez sur le bouton Tout confirmer de la barre d'outils.

Remarque : Lors de la création d'une définition de document, vous pouvez modifier les options de vérification dans la configuration des propriétés. Les caractères contenus dans des champs pour lesquels l'option Envoyer les caractères vers la vérification de groupe est activée dans l'onglet Vérification de la boîte de dialogue de propriétés sont soumis au processus de vérification groupée. Consultez la section Propriétés de la vérification de champ. Pour la vérification groupée, nous recommandons de soumettre les coches et les champs qui ne peuvent recevoir que des nombres. Il est plus facile de vérifier les lettres dans le contexte d'un champ.


Vérification de champ

La vérification de champ est un mode de vérification destiné à permettre de corriger efficacement les erreurs des champs « bien reconnus », c'est-à-dire des champs dont la plage de valeurs est connue ou peut être identifiée aisément. Il peut s'agir d'un champ de nom de pays ou de ville, par exemple : nous savons quelles valeurs ces champs peuvent contenir.

Pour déterminer comment corriger un champ, il suffit d'afficher ce champ et de connaître sa plage de valeurs. Il est possible de corriger les erreurs d'entrée et les erreurs de format de champ.

Affichage de la fenêtre de vérification de champ

Pour corriger des caractères mal reconnus, vous pouvez utiliser les modes standard des éditeurs de texte : Insertion et remplacement de caractères (vous pouvez alterner entre ces deux modes en appuyant sur la touche INSERTION du clavier).

Vous pouvez afficher le résultat de chaque champ tour à tour, corriger si nécessaire, puis confirmer en cliquant sur le bouton Confirmer le champ.

Vous devez corriger les valeurs de ces champs. Si ce n'est pas possible, vous pouvez ignorer le champ ou différer la vérification en cliquant sur le bouton Pause afin de le corriger ultérieurement.

Remarque : Les champs pour lesquels l'option Envoyer vers la vérification de champ est activée dans l'onglet Vérification de la boîte de dialogue de propriétés sont soumis au processus de vérification de champ. Consultez la section Propriétés de la vérification de champ. Pour la vérification de champ, nous recommandons de soumettre des champs d'une ligne avec une plage de valeurs bien connue.


Vérification dans la fenêtre de document

La fenêtre de document permet aussi de vérifier la précision de la reconnaissance et de corriger les caractères mal reconnus. Elle s'ouvre quand vous double-cliquez sur le nom de la page. Elle est composée de la région de données, de l'image de page et de la région d'erreurs (s'il y a effectivement des erreurs). Vous pouvez sélectionner les types d'erreurs à afficher : erreurs d'assemblage, erreurs de formatage, erreurs de règles ou toute combinaison de ces erreurs. Pour afficher les erreurs d'un certain type, cliquez sur le bouton correspondant dans le coin en haut à droite du volet des erreurs.

Vous pouvez configurer la présentation de cette fenêtre en cliquant sur le bouton Présentation. Dans la fenêtre de document, l'opérateur ne voit pas que les groupes de caractères ou les différents champs, mais le document dans son entier.

Afficher la fenêtre de document

Dans la région de données, les caractères reconnus sans certitude et les caractères discutables sont marqués en couleur, et les champs dont le type est incorrect, ainsi que les règles non respectées, sont en surbrillance.

Pour confirmer un champ dont les caractères ont été reconnus sans certitude, placez le curseur sur le champ et appuyez sur ENTRÉE.

Les champs qui permettent d'afficher et de modifier les données reconnues peuvent être organisés non seulement de manière séquentielle mais aussi dans n'importe quel autre ordre plus pratique. Vous pouvez aussi modifier leur organisation dans l'éditeur de définition de document (consultez la section Configurer la présentation des données dans la fenêtre de document).

Pour atteindre l'erreur suivante au sein de la fenêtre de document, cliquez sur les boutons [image] et [image] sur la barre d'outils de la fenêtre principale. Le programme navigue au sein de toutes les erreurs, y compris les erreurs d'assemblage, les caractères reconnus sans certitude, les erreurs de règle, les défauts de correspondance entre champs clés, etc.


Vérification par règle

Validation par règle

Les règles non satisfaites sont signalées d'un indicateur jaune [image] (avertissement) ou rouge [image] (erreur).

Les erreurs de règle sont affichées dans une fenêtre distincte de l'éditeur de document, et les documents dont les règles ne sont pas satisfaites sont signalées par un indicateur rouge.

Quand des règles ne sont pas satisfaites, l'opérateur doit vérifier la qualité des données reconnues. S'il s'agit d'une erreur de reconnaissance, l'opérateur doit la corriger. S'il s'agit d'une erreur de remplissage qui ne peut pas être corrigée, l'opérateur ne doit pas exporter le document. Les documents présentant des erreurs peuvent être vérifiés ultérieurement, en les comparant aux documents au format papier ou aux autres sources disponibles.

Pour vérifier de nouveau si les données présentent des erreurs de règle, cliquez sur la flèche à droite du bouton Exécuter la vérification… et sélectionnez l'élément de menu Vérifier à nouveau les règles. Si les règles sont respectées une fois que vous avez corrigé les valeurs des champs, les indicateurs disparaissent.


Exportation des données reconnues

Les documents sont automatiquement exportés. Selon les paramètres, une confirmation supplémentaire de la part du chef-opérateur de vérification peut être requise. Les documents sont exportés en fonction des paramètres fournis dans la définition du document. Si aucun paramètre d'exportation n'est défini dans la définition de document, les documents sont exportés en fonction des paramètres du projet. Si certains des documents doivent être exportés avant les autres, ils peuvent être envoyés dans la file d'exportation lors de la phase d'exportation.

Les documents peuvent également être exportés manuellement sur la station de vérification ou sur la station de configuration de projet.

Exportation des données vers un fichier

  1. Pour exporter des données vers un fichier, sélectionnez Exporter vers>Données vers fichiers… à partir du menu contextuel du document. La boîte de dialogue Exportation vers des fichiers de données apparaît.
  2. Si nécessaire, réglez les paramètres d'exportation en cliquant sur Paramètres.... Cliquez sur OK pour appliquer les modifications.
  3. Cliquez sur Exporter pour exporter les données.

Exportation des données vers une base de données

  1. Pour exporter des données vers une base de données, sélectionnez Exporter vers>Base de données... à partir du menu contextuel du document. La boîte de dialogue Exporter vers une base de données compatible ODBC apparaît.
  2. Définissez les paramètres d'exportation.
  3. Cliquez sur OK pour exporter les données.


Mode Arrière-plan

Les étapes de traitement qui ne nécessitent pas l'intervention de l'opérateur sont effectuées automatiquement par le serveur de traitement. Cependant, elles peuvent également être effectuées manuellement sur la station de vérification ou sur la station de configuration de projet, auquel cas elles peuvent être exécutées en mode Arrière-plan.

Quand aucun contrôle opérateur n'est requis, il est possible d'importer, reconnaître et exporter les documents en mode Arrière-plan.

Pour transférer une tâche en mode Arrière-plan, cliquez sur le bouton Mode Arrière-plan dans la boîte de dialogue Ajout d'images… (ou dans la boîte de dialogue Reconnaissance… ou Exportation…...).

Vous pouvez effectuer les tâches suivantes en mode Arrière-plan :

  • chargement d'images à l'aide du profil d'importation correspondant ;
  • reconnaissance de document, si l'option Reconnaître les images ajoutées automatiquement est sélectionnée (Outils > Options…, onglet Traitement de document).

L'icône [image] apparaît sur la barre des tâches lors du passage en mode Arrière-plan. Cliquer sur cette icône ouvre la boîte de dialogue Tâches en arrière-plan qui affiche la liste des tâches.

  • Les tâches sont exécutées dans l'ordre dans lequel elles se présentent ou en fonction des priorités définies par l'utilisateur (bouton Définir la priorité…).
  • L'exécution des tâches est consignée dans un fichier journal que l'utilisateur peut personnaliser (Outils > Options…, onglet Progression de la tâche). Cliquez sur le bouton Afficher le journal pour afficher le journal.
  • Vous pouvez interrompre une tâche en cliquant sur le bouton Terminer la tâche.

Le programme peut également vous informer sur la progression des tâches en arrière-plan par le biais d'info-bulles visibles dans le coin inférieur droit de l'écran. Le message apparaît au lancement et à la fin d'une tâche ou en cas d'erreur. Pour plus d'informations, consultez la section Autres options.


Interface d’ABBYY FlexiCapture 9.0

Cette section décrit les éléments principaux figurant dans l’interface d’ABBYY FlexiCapture 9.0 : les principales fenêtres ainsi que les menus et barres d’outils.

Station de configuration de projets
Menus de la station de configuration de projets
Barres d’outils de la station de configuration de projets
Station de vérification
Menu de la station de vérification
Barres d’outils de la station de vérification
Station de vérification de données
Menu de la station de vérification de données
Barres d’outils de la station de vérification de données
Éditeur de définition de document
Menus de l’éditeur de définition de document
Barres d’outils de l’éditeur de définition de document
Fenêtre Vérification groupée
Menus de la fenêtre Vérification groupée
Barres d’outils de la fenêtre Vérification groupée
Fenêtre Vérification de champ
Menus de la fenêtre Vérification de champ
Barres d’outils de la fenêtre Vérification de champ


Fenêtre de la station de configuration de projets

La fenêtre principale du programme affiche la liste des lots de documents qui font partie du projet sur lequel l’utilisateur travaille.

Afficher la fenêtre principale avec la liste des lots

Pour afficher le contenu d’un lot, double-cliquez dessus. Une liste des documents inclus dans le lot s’affichera.

Pour revenir à la liste de lots, cliquez sur Projet>Lots (ou Lots de test, si vous utilisez des lots de test).

Le menu principal, sous lequel se trouvent des barres d’outils, se situe en haut de la fenêtre.

Le reste de la Fenêtre principale est occupé par la fenêtre Lot de travail contenant la liste des documents inclus.

La Barre d’état se trouve en bas de la fenêtre. La barre d’état affiche l’état du programme et des opérations en cours. Lorsque vous placez le curseur sur les éléments ou les boutons du menu, la barre d’état affiche la brève description qui leur est associée.

Pour vérifier les données reconnues, ouvrez la fenêtre Document. Pour ce faire, double-cliquez sur le nom du document ou sur l’une de ses pages. La fenêtre Document se décompose en trois parties :

  • l’image de page document ;
  • les données reconnues ;
  • les erreurs de règles (affichées le cas échéant).

Pour plus d’informations, consultez la section Vérification dans la fenêtre Document

Afficher la fenêtre Document

Menu de la station de configuration de projets
Barres d’outils de la station de configuration de projets


Menu de la station de configuration de projets

Fichier
Menu | Description
Nouveau projet… | Crée un nouveau projet
Ouvrir un projet… | Ouvre un projet existant
Ouvrir un projet à partir du serveur… | Ouvre un projet existant sur le serveur d’application
Fermer le projet | Ferme le projet en cours
Enregistrer | Enregistre les modifications
Nouveau lot… | Crée un nouveau lot
Charger des images… | Charge des images à partir de fichiers
Numériser des images… | Ajoute des images obtenues par numérisation
Importer des images… | Importe des images à l’aide de l’un des profils d’importation configurés
Exporter vers |
Données vers fichiers… | Exporte des données vers un fichier
Images vers fichiers… | Exporte des images vers des fichiers
Base de données… | Exporte les données vers une base de données
Projets récents | Ouvre l’un des projets ouverts précédemment
Quitter | Ferme ABBYY FlexiCapture 9.0
Éditer
Menu | Description
Annuler | Annule la dernière action
Rétablir | Restaure l’action annulée
Couper | Coupe les objets sélectionnés
Copier | Copie les objets sélectionnés dans le presse-papiers
Coller | Colle l’objet copié dans le presse-papiers
Supprimer | Supprime les objets sélectionnés
Fusionner | Fusionne les pages sélectionnées en un document
Scinder | Subdivise le document sélectionné en pages
Tout sélectionner | Sélectionne tous les objets
Rechercher… | Recherche le texte spécifié
Rechercher suivant | Recherche la prochaine occurrence du texte précédemment spécifié
Aller à |
Document suivant | Passe au document suivant du lot
Document précédent | Passe au document précédent du lot
Image |
Nettoyer | Nettoie l’image
Inverser | Inverse l’image
Pivoter horizontalement | Fait pivoter l’image horizontalement selon l’axe vertical
Pivoter verticalement | Fait pivoter l’image verticalement selon l’axe horizontal
Tourner de 90° vers la droite | Fait tourner l’image de 90° vers la droite
Tourner de 90° vers la gauche | Fait tourner l’image de 90° vers la gauche
Tourner de 180° | Fait tourner l’image à 180°
Changer la résolution… | Change la résolution de l’image.
Enregistrer sous… | Enregistre l’image avec le nom spécifié
Afficher
Menu | Description
Lots de test | Ouvre la liste des lots de test
Lots | Ouvre la liste des lots
Détails | Affiche les documents et leurs pages sous forme de liste détaillée
Vignettes | Affiche les images du document sous forme de vignettes
Choisir les détails… | Permet de configurer la liste des colonnes affichées en mode vue détaillée
Éditeur de document |
Mode Image | Affiche l’image de page dans la fenêtre de document
Mode Données | Affiche les données reconnues dans la fenêtre de document
Fenêtre Image | Permet de positionner l’image dans la fenêtre de document
Fenêtre Erreurs | Permet de positionner la fenêtre des erreurs dans la fenêtre de document
Échelle de l’image | Permet de sélectionner une échelle d’image de champ adaptée
Échelle de texte de données | Permet de sélectionner la taille de la police utilisée pour l’affichage des données reconnues
Afficher la barre d'outils | Affiche/masque la barre d’outils dans la fenêtre de document. Cette barre d’outils permet de corriger certaines erreurs d’association, par exemple, vous pouvez ajouter le champ qui n’a pas été trouvé, et ajouter ou supprimer un séparateur de tableau. Elle est principalement utilisée avec des FlexiLayouts.
Afficher l’erreur de format du champ actif | Permet de définir le mode d’affichage de l’erreur de format
Afficher l'image en noir et blanc | Affiche les images en couleur et en niveaux de gris en images noires et blanches
?????? ??????? | Permet de sélectionner la taille des vignettes de la page
?????? ???????????? | Affiche/masque les barres d’outils
Barre d'état | Affiche/masque la barre d’état
Plein écran | Passe en mode plein écran
Actualiser | Actualise les informations affichées
Propriétés… | Ouvre la boîte de dialogue des propriétés de la page ou du document
Reconnaissance
Menu | Description
Analyser | Analyse les pages des documents et recherche une définition de document adaptée
Associer une définition de document… | Associe la définition de document sélectionnée à la page ou au document sélectionné
Reconnaître | Lance la reconnaissance
Vérification
Menu | Description
Exécuter la vérification… | Lance la vérification
Élément suivant à vérifier | Passe à l’objet de vérification suivant
Élément précédent à vérifier | Passe à l’objet de vérification précédent
Erreur d'assemblage suivante | Passe à l’erreur d’assemblage suivante
Erreur d'assemblage précédente | Passe à l’erreur d’assemblage précédente
Caractère incertain suivant | Passe au caractère suivant reconnu sans certitude
Caractère incertain précédent | Passe au caractère précédent reconnu sans certitude
Erreur de règle suivante | Passe à l’erreur de règle suivante
Erreur de règle précédente | Passe à l’erreur de règle précédente
Projet
Menu | Description
Définitions de document… | Ouvre la boîte de dialogue comportant la liste des définitions de document qui permet de les créer, modifier, importer et supprimer (seul l’administrateur a accès à ce menu)
Types de lot… | Ouvre la boîte de dialogue comportant la liste des types de lot qui permet de les créer, modifier, importer et supprimer (seul l’administrateur a accès à ce menu)
Profils d'importation d'images… | Ouvre la boîte de dialogue comportant la liste des profils d’importation d’image qui permet de les créer, modifier, importer et supprimer (seul l’administrateur a accès à ce menu)
Protéger par un mot de passe… | Permet de protéger le projet en cours avec un mot de passe (seul l’administrateur a accès à ce menu)
Ôter la protection… | Permet de désactiver la protection par mot de passe du projet (seul l’administrateur a accès à ce menu)
Exporter un projet… | Exporte le projet vers le dossier spécifié. Les images proviennent du projet en cours.
Mettre à jour un projet… | Configure la mise à jour du projet. Vous pouvez enregistrer dans un fichier les messages et les erreurs qui apparaissent pendant l’importation (cliquez avec le bouton droit de la souris et sélectionnez : Exporter vers un fichier).
Propriétés du projet… | Ouvre la boîte de dialogue Propriétés du projet
Outils
Menu | Description
Mettre à jour vers la version la plus récente | Applique les modifications du projet aux documents en cours de traitement
Analyser à nouveau | Réanalyse les documents
Reconnaître à nouveau | Reconnaît de nouveau les documents
Actualiser l'assemblage | Actualise l’assemblage des pages en documents
Vérifier à nouveau les règles | Vérifie à nouveau les règles
Vérifier l'intégrité du lot | Vérifie l’intégrité du lot
Changer la priorité du lot | Permet de sélectionner la priorité d’un lot
Modifier un type de lot… | Change le type du lot
Options… | Ouvre la boîte de dialogue Options, où vous pouvez configurer différentes propriétés telles que le traitement des tâches en arrière-plan, les vues de fenêtres, etc.
Aide
Menu | Description
Rubriques d'aide… | Ouvre le fichier d’aide d’ABBYY FlexiCapture 9.0
Support technique… | Ouvre la section Support technique de l’aide du programme
Comment acheter des produits ABBYY… | Ouvre la section Acheter ABBYY FlexiCapture 9.0 de l’aide du programme
Site Web d'ABBYY… | Ouvre le site Web d’ABBYY
Envoyer des commentaires… | Permet d’envoyer des commentaires à ABBYY : les remarques, souhaits et avis de l’utilisateur
À propos d'ABBYY FlexiCapture… | Ouvre la boîte de dialogue À &propos d'ABBYY FlexiCapture 9.0 comportant une brève description du programme.


Barres d’outils de la station de configuration de projets

La barre d’outils standard

Outil | Bouton | Description
Ouvrir un projet |  | Ouvre un projet
Enregistrer les modifications |  | Enregistre les modifications
Couper |  | Lorsque vous travaillez sur les données de l’image de document, coupe l’objet sélectionné
Copier |  | Copie l’objet sélectionné vers
Coller |  | Colle l’objet copié dans le presse-papiers
Supprimer |  | Supprime l’objet sélectionné
Annuler |  | Annule la dernière action
Rétablir |  | Restaure l’action annulée
Vue des documents

Outil | Bouton | Description
Vue Détails |  | Affiche les documents et leurs pages sous forme de liste détaillée
Vue Vignettes |  | ????????? ????????????? ??????????? ??????? ?????????? ? ???? ??????????? ?????
Liste de lots de test |  | Affiche la liste des lots de test
Liste de lots de travail |  | Affiche la liste des lots de travail
Actualiser |  | Actualise les informations de la fenêtre principale
Navigation

Outil | Bouton | Description
Élément précédent à vérifier |  | Passe à l’objet de vérification précédent. Le programme parcourt toutes les erreurs, y compris les erreurs d’assemblage, les caractères reconnus sans certitude, les erreurs de règle, les défauts de correspondance entre champs clés, etc.
Élément suivant à vérifier |  | Passe à l’objet de vérification suivant. Le programme parcourt toutes les erreurs, y compris les erreurs d’assemblage, les caractères reconnus sans certitude, les erreurs de règle, les défauts de correspondance entre champs clés, etc.
Document précédent |  | Passe au document précédent.
Document suivant |  | Passe au document suivant.
Configuration de projet

Outil | Bouton | Description
Définitions de document… |  | Ouvre la fenêtre comportant la liste des définitions de document du projet.
Types de lot… |  | Ouvre la fenêtre comportant la liste des types de lot du projet.
Propriétés du projet… |  | Ouvre la fenêtre Propriétés du projet.
Afficher le profil d’importation d’image |  | Ouvre la fenêtre comportant la liste des profils d’importation d’image du projet.
Télécharger le projet sur le serveur… |  | Ouvre la fenêtre permettant de télécharger le projet vers le serveur d’application.


Fenêtre de la station de vérification

Station de vérification

La fenêtre principale du programme affiche la liste des files d’où proviennent les tâches de traitement.

Afficher la fenêtre principale avec la liste de files

Lorsqu’une tâche est reçue, la fenêtre affiche la liste des documents de la tâche.

Afficher la fenêtre principale avec la liste de documents

Le menu principal, sous lequel se trouvent des barres d’outils, se situe en haut de la fenêtre.

Le reste de la Fenêtre principale est occupé par l’espace de travail contenant la liste des documents ou des files.

La Barre d’état se trouve en bas de la fenêtre. La barre d’état affiche l’état du programme et des opérations en cours. Lorsque vous placez le curseur sur les éléments ou les boutons du menu, la barre d’état affiche la brève description qui leur est associée.

Menu de la station de vérification
Barres d’outils de la station de vérification


Menu de la station de vérification

Fichier
Menu | Description
Ouvrir un projet à partir du serveur Ouvrir un projet à partir du serveur… | Ouvre un projet existant sur le serveur d’application
Fermer le projet | Ferme le projet en cours
Enregistrer | Enregistre les modifications
Charger des images… | Charge des images à partir de fichiers
Numériser des images… | Ajoute des images obtenues par numérisation
Exporter vers |
Fichiers de d Données vers fichiers… | Exporte des données vers un fichier
Images vers fichiers Images vers fichiers… | Exporte des images vers des fichiers
Base de données… | Exporte les données vers une base de données
Projets récents | Ouvre l’un des projets ouverts précédemment
Quitter | Ferme ABBYY FlexiCapture 9.0
Éditer
Menu | Description
Annuler | Annule la dernière action
Rétablir | Restaure l’action annulée
Couper | Coupe les objets sélectionnés
Copier | Copie les objets sélectionnés dans le presse-papiers
Coller | Colle l’objet copié dans le presse-papiers
Supprimer | Supprime les objets sélectionnés
Fusionner | Fusionne les pages sélectionnées en un document
Segmenter | Subdivise le document sélectionné en pages
Tout sélectionner | Sélectionne tous les objets
Rechercher… | Recherche le texte spécifié
Rechercher suivant | Recherche la prochaine occurrence du texte précédemment spécifié
Aller à |
Document suivant | Passe au document suivant du lot
Document précédent | Passe au document précédent du lot
Image |
Nettoyer | Nettoie l’image
Inverser | Inverse l’image
Flip Horizontally | Fait pivoter l’image horizontalement selon l’axe vertical
Flip Vertically | Fait pivoter l’image verticalement selon l’axe horizontal
Tourner de 90° vers la droite | Fait tourner l’image de 90° vers la droite
Tourner de 90° vers la gauche | Fait tourner l’image de 90° vers la gauche
Tourner de 180° | Fait tourner l’image à 180°
Changer la résolution Changer la résolution… | Change la résolution de l’image.
Enregistrer sous Enregistrer sous… | Enregistre l’image avec le nom spécifié
Afficher
Menu | Description
Lots | Ouvre la liste des lots
Files | Ouvre la liste des files
Détails | Affiche les documents et leurs pages sous forme de liste détaillée
Vignettes | Affiche les images du document sous forme de vignettes
Choisir les détails… | Permet de configurer la liste des colonnes affichées en mode vue détaillée
Éditeur de document |
Mode Image | Affiche l’image de page dans la fenêtre de document
Mode Données | Affiche les données reconnues dans la fenêtre de document
Fenêtre Image | Permet de positionner l’image dans la fenêtre de document
Fenêtre Erreurs | Permet de positionner la fenêtre des erreurs dans la fenêtre de document
Échelle de l’image | Permet de sélectionner une échelle d’image de champ adaptée
Échelle de texte de données | Permet de sélectionner la taille de la police utilisée pour l’affichage des données reconnues
Afficher la barre d'outils | Affiche/masque la barre d’outils dans la fenêtre de document. Cette barre d’outils permet de corriger certaines erreurs d’association, par exemple, vous pouvez ajouter le champ qui n’a pas été trouvé, et ajouter ou supprimer un séparateur de tableau. Elle est principalement utilisée avec des FlexiLayouts.
Afficher l’erreur de format du champ actif | Permet de définir le mode d’affichage de l’erreur de format
Afficher l'image en noir et blanc | Affiche les images en couleur et en niveaux de gris en images noires et blanches
Taille des vignettes | Permet de sélectionner la taille des vignettes de la page
Barres d’outils | Affiche/masque les barres d’outils
Barre d'état | Affiche/masque la barre d’état
Plein écran | Passe en mode plein écran
Actualiser | Actualise les informations affichées
Reconnaissance
Menu | Description
Analyser | Analyse les pages des documents et recherche une définition de document adaptée
Associer une définition de document… | Associe la définition de document sélectionnée à la page ou au document sélectionné
Reconnaître | Lance la reconnaissance
Tâches
Menu | Description
Obtenir la tâche | Obtient une tâche dans la file sélectionnée
Fermer la tâche | Ferme la tâche en cours et la renvoie au serveur d’application comme étant terminée
Afficher le commentaire sur la tâche | Affiche les commentaires relatifs à la tâche
Rejeter la tâche | Rejette la tâche en cours et la renvoie au serveur d’application
Différer une tâche… | Diffère la tâche en cours pour un traitement ultérieur
Envoyer la tâche vers les exceptions… (pour le chef-opérateur de vérification - E&nvoyer la tâche vers l'étape…) | Envoie la tâche en cours aux exceptions (le chef-opérateur de vérification peut envoyer la tâche vers n’importe quelle étape de traitement)
Réception de tâches automatiques | Active/désactive l’obtention automatique des tâches
Envoyer des documents vers les exceptions… | Envoie les documents sélectionnés vers une nouvelle exception
Ajouter des documents aux exceptions… | Ajoute les documents sélectionnés à une exception existante
Supprimer des documents des exceptions | Supprime les documents des exceptions
Afficher la liste des exceptions… | Affiche la liste des exceptions
Vérification
Menu | Description
Exécuter la vérification… | Lance la vérification
Élément suivant à vérifier | Passe à l’objet de vérification suivant
Élément précédent à vérifier | Passe à l’objet de vérification précédent
Erreur d'assemblage suivante | Passe à l’erreur d’assemblage suivante
Erreur d'assemblage précédente | Passe à l’erreur d’assemblage précédente
Caractère incertain suivant | Passe au caractère suivant reconnu sans certitude
Caractère incertain précédent | Passe au caractère précédent reconnu sans certitude
Erreur de règle suivante | Passe à l’erreur de règle suivante
Erreur de règle précédente | Passe à l’erreur de règle précédente
Outils
Menu | Description
Mettre à jour vers la version la plus récente | Applique les modifications du projet aux documents en cours de traitement
Analyser à nouveau | Réanalyse les documents
Reconnaître à nouveau | Reconnaît de nouveau les documents
Actualiser l'assemblage | Actualise l’assemblage des pages en documents
Vérifier à nouveau les règles | Vérifie à nouveau les règles
Vérifier l'intégrité du lot | Vérifie l’intégrité du lot
Changer la priorité du lot | Permet de sélectionner la priorité d’un lot
Modifier un type de lot… | Change le type du lot
Options… | Ouvre la boîte de dialogue Options, où vous pouvez configurer différentes propriétés telles que le traitement des tâches en arrière-plan, les vues de fenêtres, etc.
Aide
Menu | Description
Rubriques d'aide… | Ouvre le fichier d’aide d’ABBYY FlexiCapture 9.0
Support technique… | Ouvre la section Support technique de l’aide du programme
Comment acheter des produits ABBYY… | Ouvre la section Acheter ABBYY FlexiCapture 9.0 de l’aide du programme
Site Web d'ABBYY… | Ouvre le site Web d’ABBYY
Envoyer des commentaires… | Permet d’envoyer des commentaires à ABBYY : les remarques, souhaits et avis de l’utilisateur
À propos d'ABBYY FlexiCapture… | Ouvre la boîte de dialogue À &propos d'ABBYY FlexiCapture 9.0 comportant une brève description du programme.


Barre d’outils de la station de vérification

Barres d’outils de la station de vérification

La barre d’outils standard

Outil | Bouton | Description
Ouvrir un projet |  | Ouvre un projet
Enregistrer les modifications |  | Enregistre les modifications
Couper |  | Lorsque vous travaillez sur les données de la fenêtre de document, coupe l’objet sélectionné
Copier |  | Copie l’objet sélectionné
Coller |  | Colle l’objet copié dans le presse-papiers
Supprimer |  | Supprime l’objet sélectionné
Annuler |  | Annule la dernière action
Rétablir |  | Restaure l’action annulée
Vue des documents

Outil | Bouton | Description
Détails |  | Affiche les documents et leurs pages sous forme de liste détaillée
Vignettes |  | Affiche les vignettes des images de document
Lots de test |  | Affiche la liste des lots de test
Lots de travail |  | Affiche la liste des lots de travail
Actualiser |  | Actualise les informations de la fenêtre principale
Navigation

Outils | Bouton | Description
Élément précédent à vérifier |  | Passe à l’objet de vérification précédent. Le programme parcourt toutes les erreurs, y compris les erreurs d’assemblage, les caractères reconnus sans certitude, les erreurs de règle, les défauts de correspondance entre champs clés, etc.
Élément suivant à vérifier |  | Passe à l’objet de vérification suivant. Le programme parcourt toutes les erreurs, y compris les erreurs d’assemblage, les caractères reconnus sans certitude, les erreurs de règle, les défauts de correspondance entre champs clés, etc.
Document précédent |  | Passe au document précédent.
Document suivant |  | Passe au document suivant.
Files et tâches

Outil | Bouton | Description
Obtenir la tâche |  | Ouvre une tâche dans la file sélectionnée.
Fermer la tâche |  | Renvoie la tâche au serveur.
Envoyer vers les exceptions (à l’étape de vérification) |  | Envoie la tâche vers les exceptions (pour le chef-opérateur de vérification : vers l’étape de traitement sélectionnée).
Différer la tâcheDifférer une tâche… |  | Diffère la tâche.
Rejeter la tâche |  | Annule la tâche (le serveur la renverra à un autre opérateur).
Obtenir les tâches automatiquement |  | Active/désactive l’obtention automatique des tâches.


Fenêtre principale de la station de vérification de données

Station de vérification de données

La fenêtre principale du programme affiche les noms des files d’où les tâches proviennent (files de vérification de données).

Afficher la fenêtre principale avec la liste de files

Après avoir obtenu une tâche, les fenêtre de vérifications groupée et de champ s’ouvriront consécutivement.

Le menu principal, sous lequel se trouvent des barres d’outils, se situe en haut de la fenêtre.

La Barre d’état se trouve en bas de la fenêtre. La barre d’état affiche l’état du programme et des opérations en cours. Lorsque vous placez le curseur sur les éléments ou les boutons du menu, la barre d’état affiche la brève description qui leur est associée.

Menu de la station de vérification de données
Barres d’outils de la station de vérification de données


Menu de la station de vérification de données

Fichier
Menu | Description
Ouvrir un projet à partir du serveur… | Ouvre un projet existant sur le serveur d’application
Fermer le projet | Ferme le projet en cours
Projets récents | Ouvre l’un des projets ouverts précédemment
Quitter | Ferme ABBYY FlexiCapture 9.0
Afficher
Menu | Description
Barres d’outils | Affiche/masque les barres d’outils
Barre d'état | Affiche/masque la barre d’état
Plein écran | Passe en mode plein écran
Actualiser | Actualise les informations affichées
Tâches
Menu | Description
Obtenir la tâche | Obtient une tâche dans la file sélectionnée
Afficher le commentaire sur la tâche | Affiche les commentaires relatifs à la tâche
Rejeter la tâche | Rejette la tâche en cours et la renvoie au serveur d’application
Envoyer la tâche vers les exceptions… | Envoie la tâche en cours vers les exceptions
Réception de tâches automatiques | Active/désactive le mode de réception automatique des tâches
Outils
Menu | Description
Options… | Ouvre la boîte de dialogue Options, où vous pouvez configurer différentes propriétés telles que le traitement des tâches en arrière-plan, les vues de fenêtres, etc.
Aide
Menu | Description
Rubriques d'aide… | Ouvre le fichier d’aide d’ABBYY FlexiCapture 9.0
Support technique… | Ouvre la section Support technique de l’aide du programme
Comment acheter des produits ABBYY… | Ouvre la section Acheter ABBYY FlexiCapture 9.0 de l’aide du programme
Site Web d'ABBYY… | Ouvre le site Web d’ABBYY
Envoyer des commentaires… | Permet d’envoyer des commentaires à ABBYY : les remarques, souhaits et avis de l’utilisateur
À propos d'ABBYY FlexiCapture… | Ouvre la boîte de dialogue À &propos d'ABBYY FlexiCapture 9.0 comportant une brève description du programme.


Barres d’outils de la station de vérification de données

Files et tâches

Outil | Bouton | Description
Obtenir la tâche |  | Ouvre une tâche dans la file sélectionnée.
Envoyer vers les exceptions… |  | Envoie la tâche vers les exceptions.
Rejeter la tâche |  | Rejette la tâche (le serveur la renverra ultérieurement à un autre opérateur).
Actualiser |  | Actualise les informations de la fenêtre principale.
Réception de tâches automatiques |  | Active/désactive le mode de réception automatique des tâches.


Fenêtre de l'éditeur de Définitions de document

Fenêtre de l'éditeur de Définition de document

La fenêtre de d'éditeur de Définition de document de document permet de créer et de modifier des Définitions de document. Cette fenêtre n'est disponible que sur la station de configuration de projet.

Pour ouvrir l'éditeur de Définition de document, à partir de la fenêtre principale du programme :

  1. Sélectionnez l'élément de menu Projet>Définitions de document…
  2. Dans la boîte de dialogue Définitions de document qui s'ouvre, mettez en surbrillance le nom de la Définition de document puis cliquez sur Éditer….

La fenêtre de l'éditeur de Définition de document s'ouvre également au terme de la procédure de l'assistant de définition de document.

Afficher la fenêtre de l'éditeur de Définition de document

La fenêtre de l'éditeur de Définition de document se décompose en trois parties :

  1. l'image de page, avec le marquage des champs et des éléments statiques visibles dans la partie supérieure gauche.

    Le programme comporte deux modes pour le traitement des champs et les éléments statiques :

    • le mode Marquage de champ – qui s'active en cliquant sur le bouton [image],
    • le mode Éléments statiques – qui s'active en cliquant sur le bouton [image] ;
  2. l'éditeur qui permet de configurer la présentation des données reconnues est situé dans la partie inférieure gauche ;
  3. la structure du document, avec une liste de tous les champs du modèle (onglet Champs), est située dans la partie droite. Vous pouvez également passer en mode contour de page (onglet Pages).

маркированный список | Menu de l'éditeur de Définition de document
маркированный список | Barres d'outils de l'éditeur de Définition de document


Menu de l'éditeur de Définitions de document

Définition de document
Élément du menu | Description
Ajouter une page… | Ajoute une nouvelle image de page à la Définition de document.
Ajouter une section de document… | Ajoute une nouvelle section au lot.
Modules de scripts |
Règle de script… | Ouvre le Module de script global de règle de l'Éditeur de script. Pour plus d’informations sur les modules de script, consultez la section Utilisation de scripts dans FlexiCapture 9.0.
Exporter un script… | Ouvre le Module de script global d'exportation de l'Éditeur de script. Pour plus d’informations sur les modules de script, consultez la section Utilisation de scripts dans FlexiCapture 9.0.
Paramètres d'exportation… | Ouvre la boîte de dialogue Paramètres d'exportation qui permet de configurer les options d'exportation des données.
Propriétés de la définition de document… | Ouvre une boîte de dialogue qui permet d'afficher et de modifier les propriétés des Définitions de document.
Enregistrer | Enregistre les modifications.
Fermer | Ferme l'éditeur de Définitions de document.
Éditer
Élément du menu | Description
Annuler | Annule l'action précédente.
Rétablir | Rétablit l'action annulée.
Couper | Coupe les objets en surbrillance.
Copier | Copie les objets en surbrillance vers le presse-papiers.
Coller | Colle le contenu du presse-papiers.
Supprimer | Supprime les objets en surbrillance.
Supprimer la région | Supprime les régions des images des objets en surbrillance.
Sélectionner tout | Sélectionne tout.
Sélectionner par type… | Détecte les objets d'un certain type.
Créer un champ |
Texte | Ajoute un champ de saisie de texte à la structure du document (sans région sur l'image).
Coche | Ajoute un champ de coche à la structure du document (sans région sur l'image).
Groupe de coches | Ajoute un champ de groupe de coches à la structure du document (sans région sur l'image).
Code barres | Ajoute un champ de code barres à la structure du document (sans région sur l'image).
Image | Ajoute un champ d'image graphique à la structure du document (sans région sur l'image).
Tableau | Ajoute un champ de tableau à la structure du document (sans région sur l'image).
Groupe | Ajoute un groupe de champs à la structure du document (sans région sur l'image).
Grouper | Groupe les objets en surbrillance.
Dégrouper | Dégroupe les objets en surbrillance.
Copier le texte de l'image… | Récupère le texte d'une région de l'image et le stocke dans le presse-papiers. Après avoir sélectionné cette commande, mettez en surbrillance la région contenant le texte désiré.
Image... |
Nettoyer | Supprime le bruit sur l'image.
Inverser | Inverse l'image.
Pivoter à 90° vers la droite | Fait tourner l'image de 90° vers la droite.
Pivoter à 90° vers la gauche | Fait tourner l'image de 90° vers la gauche.
Pivoter à 180° | Fait tourner l'image de 180°.
Enregistrer sous… | Enregistre l'image de la page de modèle dans le fichier spécifié.
Remplacer… | Remplace l'image de la page de modèle.
Afficher
Élément du menu | Description
Présentation de l'image |
Éléments statiques | Bascule en mode Éléments statiques.
Régions de champ | Bascule en mode Marquage de champs.
Structure du document |
Afficher la structure du document | Affiche/masque la fenêtre Structure du document.
Champs | Fait basculer la fenêtre Structure du document en mode Champs.
Pages | Fait basculer la fenêtre Structure du document en mode Pages.
Formulaire de données | Affiche/masque la fenêtre de l'éditeur de données.
Barre d'outils de mise en page |
Horizontal | Ancre la barre d'outils de la fenêtre de présentation d'image horizontalement.
Vertical | Ancre la barre d'outils de la fenêtre de présentation d'image verticalement.
Afficher l'image en noir et blanc | Affiche en noir et blanc les images de pages qui sont en couleur et en niveaux de gris.
Échelle d'image | Sélectionne une échelle d'image appropriée.
Propriétés… | Ouvre une boîte de dialogue permettant d'afficher et de modifier les propriétés de l'objet en surbrillance.
Document
Élément du menu | Description
Exécuter le test | Démarre le test de la Définition de document sur l'image du document.
Terminer le test | Met fin au test de la Définition de document.
Mode Image | Affiche l'image de page dans la fenêtre du document.
Mode Données | Affiche les données reconnues dans la fenêtre du document.
Présentation |
Fenêtre Image | Modifie la position de l'image dans la fenêtre du document.
Haut | Place la fenêtre d'image en haut de l'écran.
Bas | Place la fenêtre d'image en bas de l'écran.
Gauche | Place la fenêtre d'image à gauche.
Droite | Place la fenêtre d'image à droite.
Fenêtre Erreurs | Modifie la position de la fenêtre des erreurs dans la fenêtre du document.
Haut | Place la fenêtre des erreurs en haut de l'écran.
Bas | Place la fenêtre des erreurs en bas de l'écran.
Gauche | Place la fenêtre des erreurs à gauche.
Droite | Place la fenêtre des erreurs à droite.
Afficher la barre d'outils | Affiche/masque la barre d'outils en mode Données. En mode Image, la barre d'outils est toujours affichée et ne peut être masquée.
Vérification |
Élément suivant à vérifier | Va à l'élément suivant devant être vérifié.
Élément précédent à vérifier | Va à l'élément précédent devant être vérifié.
Caractère incertain suivant | Va au caractère incertain suivant.
Caractère incertain précédent | Va au caractère incertain précédent.
Erreur de règle suivante | Va à l'erreur de règle suivante.
Erreur de règle précédente | Va à l'erreur de règle précédente.
Outils
Élément du menu | Description
Détecter automatiquement les objets… | Détecte et met en surbrillance automatiquement les champs et éléments statiques d'un certain type (selon le mode).
Vérifier la présentation du document | Vérifie la Définition de document.
Associer la section | Vérifie la correspondance d'une section de Définition de document.
Basculer vers le lot de test… | Permet de tester la Définition de document à l'aide de lots de test.
Aide
Élément du menu | Description
Rubriques d'aide… | Ouvre les rubriques d'aide d'ABBYY FlexiCapture 9.0.
Envoyer des commentaires… | Permet aux utilisateurs d'envoyer des commentaires et des suggestions à ABBYY.


Barres d'outils de l'éditeur de Définition de document

Barre d'outils standard

Nom | Bouton | Description
Enregistrer les modifications |  | Enregistre les modifications.
Couper |  | Coupe un objet sélectionné lorsque vous travaillez avec des données dans la fenêtre du document.
Copier |  | Copie un objet sélectionné.
Coller |  | Colle un objet précédemment copié dans le presse-papiers.
Supprimer |  | Supprime un objet en surbrillance
Annuler |  | Annule l'action précédente
Rétablir |  | Rétablit une action précédemment annulée.
Vérifier la Définition de document |  | Vérifie une Définition de document. Les résultats de la vérification s'affichent dans la partie inférieure de la fenêtre de l'éditeur de Définition de document.
Barre d'outils de la fenêtre de présentation d'image

La barre d'outils de la fenêtre de présentation d'image sert à créer des éléments statiques et des champs de Définition de document. Le jeu de boutons de la barre d'outils change en fonction du mode sélectionné.

En mode d'éléments statiques :

En mode de marquage de champs :

Cette barre d'outils peut être ancrée horizontalement ou verticalement. Son orientation peut être modifiée sous Afficher>Présentation d'image.
Nom | Bouton | Description
Général
Mode Éléments statiques |  | Bascule en mode Éléments statiques.
Mode Régions de champ |  | Bascule en mode Régions de champ.
Zoom |  | Augmente l'échelle de l'image.
Détecter les objets automatiquement |  | Détecte automatiquement les objets présents sur l'image. Sélectionnez cet outil, puis cliquez à l'intérieur de la région de l'objet.
Sélectionner des régions |  | Met en surbrillance les régions des objets qui ont été sélectionnés sur l'image. Pour mettre en surbrillance une région, sélectionnez cet outil, puis cliquez au sein de la région de l'objet.
En mode Éléments statiques
Créer une ancre |  | Crée une ancre. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour de l'ancre.
Créer un séparateur |  | Crée un séparateur. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du séparateur.
Créer du texte ancré |  | Crée du texte ancré. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du texte.
Créer un code barres d'ancrage |  | Crée un code barres d'ancrage. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du code barres.
En mode de marquage de champs
Créer le texte |  | Crée un champ d'entrée de texte. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour de la région d'entrée de texte.
Créer un champ de coche |  | Crée un champ de coche. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour de la région de coche.
Créer un groupe de coches |  | Crée un groupe de coches. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du groupe de coches.
Créer un code barres |  | Crée un champ de code barres. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du code barres.
Créer une image graphique |  | Crée un champ d'image graphique. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour de l'image graphique.
Créer un tableau |  | Crée un champ de tableau. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du tableau. Des boutons de marquage de tableau supplémentaires apparaissent alors dans la barre d'outils.
Créer un groupe de champs |  | Crée un groupe de champs. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour du groupe de champs.
Créer une région pour un champ sans région |  | Crée une région pour un champ qui est inclus dans la structure du document mais n'a pas de région sur l'image. Sélectionnez cet outil, puis utilisez la souris pour dessiner un rectangle autour de la région de champ. Sélectionnez un nom dans la liste déroulante (la liste affiche les noms des champs qui n'ont pas de région sur l'image).
Créer une région non reconnaissable |  | Met en surbrillance un champ qui sera exclu du processus de reconnaissance.
Boutons de marquage de tableau Visibles uniquement si au moins un tableau a été créé dans la section de Définition de document concernée
Créer une colonne |  | Permet de créer une colonne de tableau et d'indiquer son type. Pour créer une colonne, sélectionnez cet outil puis cliquez à l'intérieur de la région où vous souhaitez la créer. Sélectionnez un type de colonne dans la liste déroulante.
Dessiner un séparateur de tableau |  | Ajoute des séparateurs horizontaux et verticaux au tableau.
Supprimer un séparateur |  | Supprime un séparateur.


Fenêtre du vérificateur groupé

Fenêtre Vérification groupée

La fenêtre Vérification groupée apparaît au début de la vérification, à condition que la définition de document contienne des champs pour lesquels l’option Envoyer les caractères vers la vérification de groupe est sélectionnée. Pour plus d’informations, consultez Propriétés de la vérification de champ.

Cette fenêtre est utilisée pour vérifier visuellement les caractères reconnus avec la même valeur. Les caractères reconnus comme identiques sont affichés pour permettre l’identification et la correction des caractères qui se distinguent du reste. Consultez la section Vérification de groupe.

Menu de la fenêtre Vérification groupée
Barres d’outils de la fenêtre Vérification groupée


Menu du vérificateur groupé

s

Menu de la fenêtre Vérification groupée

Files et tâches (cette barre d’outils est disponible sur la station de vérification de données uniquement)
Menu | Description
Obtenir la tâche | Obtient une nouvelle tâche de vérification
Envoyer la tâche vers les exceptions Envoyer la tâche vers Exception… | Envoie la tâche en cours vers les exceptions
Rejeter la tâche | Rejette la tâche en cours (elle sera renvoyée à un opérateur à un moment donné)
Actualiser | Actualise les informations relatives à la tâche
Vérification
Menu | Description
Tout confirmer | Confirme la vérification correcte de tous les caractères et passe à l’étape suivante
Tout mettre en Différer tout | Diffère la vérification de tous les caractères et les marque d’un point d’interrogation
Basculer | Diffère la vérification du caractère sélectionné et le marque d’un point d’interrogation
Page suivante | Passe à la page suivante si tous les caractères ne tiennent pas dans un écran
Page précédente | Passe à la page précédente si tous les caractères ne tiennent pas dans un écran
Fermer | Ferme la fenêtre de vérification
Éditer
Menu | Description
Annuler | Annule la dernière action
Rétablir | Restaure l’action annulée
Tout sélectionner | Sélectionne tous les caractères
Afficher
Menu | Description
Image de champ |
Afficher l'image du champ | Affiche/masque l’image du champ avec le caractère en cours
Au-dessus | Positionne l’image de champ en haut de la fenêtre de vérification
En dessous | Positionne l’image de champ en bas de la fenêtre de vérification
Échelle de l’image | Permet de sélectionner une échelle d’image de champ adaptée
Afficher l’image du caractère | Affiche/masque l’image du caractère
Barre d'outils | Affiche/masque les barres d’outils
Barre d’infos | Affiche/masque la barre d’infos
Barre d'état | Affiche/masque la barre d’état
Taille de caractère | Permet de sélectionner la taille de caractère adaptée
Plein écran | Passe en mode plein écran
Préférences Préférences… | Permet de configurer la zone adjacente au caractère
Aide
Menu | Description
Rubriques d'aide… | Ouvre le fichier d’aide d’ABBYY FlexiCapture 9.0
À propos d'ABBYY FlexiCapture… | Ouvre la boîte de dialogue À &propos d'ABBYY FlexiCapture 9.0 comportant une brève description du programme.


Barres d’outils du vérificateur groupé

Barres d’outils de la fenêtre Vérification groupée

La barre d’outils standard

Outil | Bouton | Description
Page précédente |  | Passe à la page précédente si tous les caractères ne tiennent pas dans un écran
Page suivante |  | Passe à la page suivante si tous les caractères ne tiennent pas dans un écran
Tout confirmer |  | Confirme la reconnaissance correcte de tous les caractères et passe à l’étape suivante
Changer l’état du caractère |  | Change l’état du caractère en rejeté et inversement
Annuler |  | Annule la dernière action
Rétablir |  | Restaure l’action annulée
Files et tâches (cette barre d’outils est accessible sur la station de vérification de données uniquement)

Outil | Bouton | Description
Obtenir la tâche |  | Ouvre la tâche de vérification de données
Envoyer vers les exceptions |  | Ajoute la tâche aux exceptions.
Rejeter la tâche |  | Rejette la tâch?. Elle sera envoyée à un autre opérateur
Actualiser |  | Actualise les informations relatives à la tâche


Fenêtre du vérificateur de champs

Fenêtre Vérification de champ

La fenêtre Vérification de champ apparaît une fois la vérification groupée terminée, à condition que la définition de document comprenne des champs pour lesquels l’option Envoyer vers la vérification de champ est sélectionnée. Pour plus d’informations, consultez Propriétés de la vérification de champ.

Cette fenêtre est utilisée pour vérifier visuellement les caractères reconnus sans certitude dans le contexte d’un champ entier. Consultez la section Vérification de champ.

Menu de la fenêtre Vérification de champ
Barres d’outils de la fenêtre Vérification de champ


Menu du vérificateur de champs

Menu de la fenêtre Vérification de champ

Files et tâches (ce menu est disponible sur la station de vérification de données uniquement)
Menu | Description
Obtenir la tâche | Obtient une nouvelle tâche de vérification
Envoyer la tâche vers Exception… | Envoie la tâche en cours vers les exceptions
Rejeter la tâche | Rejette la tâche en cours (elle sera renvoyée à un opérateur à un moment donné)
Actualiser | Actualise les informations relatives à la tâche
Vérification
Menu | Description
Confirmer le champ | Confirme le champ
Différer | Diffère la vérification du champ
Caractère incertain suivant | Passe au caractère suivant reconnu sans certitude
Caractère incertain précédent | Passe au caractère précédent reconnu sans certitude
Champ suivant | Passe au champ suivant
Champ précédent | Passe au champ précédent
Fermer | Ferme la fenêtre de vérification
Éditer
Menu | Description
Annuler | Annule la dernière action
Rétablir | Restaure l’action annulée
Couper | Coupe les objets sélectionnés
Copier | Copie les objets sélectionnés dans le presse-papiers
Coller | Colle l’objet copié dans le presse-papiers
Supprimer | Supprime les objets sélectionnés
Supprimer tout | Supprime tous les objets
Tout sélectionner | Sélectionne tous les objets
Insérer un saut de ligne | Insère un saut de ligne
Fusionner les caractères | Fusionne les caractères sélectionnés si un caractère a été subdivisé en plusieurs caractères pendant la reconnaissance
Afficher
Menu | Description
Données de champ |
Texte reconnu | Affiche/masque le texte reconnu
Coupe des images de caractère | Passe en vue de champ avec la coupe d’image de caractère
Afficher les symboles spéciaux | Affiche/masque les caractères spéciaux
Image de champ |
Afficher l'image du champ | Affiche/masque l’image du champ avec le caractère en cours
Au-dessus | Positionne l’image de champ en haut de la fenêtre de vérification
En dessous | Positionne l’image de champ en bas de la fenêtre de vérification
Échelle de l’image | Permet de sélectionner une échelle d’image de champ adaptée
Champs analogues | Affiche/masque les champs identiques dans d’autres documents
Afficher l'image des caractères | Affiche/masque l’image du caractère
Barre d'outils | Affiche/masque les barres d’outils de la fenêtre principale
Barre d’infos | Affiche/masque la barre d’infos
Barre d'état | Affiche/masque la barre d’état
Taille de caractère | Permet de sélectionner la taille de caractère adaptée
Plein écran | Passe en mode plein écran
Préférences Préférences… | Permet de configurer la zone adjacente au caractère
Aide
Menu | Description
Rubriques d'aide… | Ouvre le fichier d’aide d’ABBYY FlexiCapture 9.0
À propos d'ABBYY FlexiCapture… | Ouvre la boîte de dialogue À &propos d'ABBYY FlexiCapture 9.0 comportant une brève description du programme.


Barres d’outils du vérificateur de champs

Barres d’outils de la fenêtre Vérification de champ

La barre d’outils standard

Outil | Bouton | Description
Champ précédent |  | Passe au champ précédent
Champ suivant |  | Passe au champ suivant
Confirmer/ignorer le champ |  | Confirme la reconnaissance correcte de tous les caractères du champ et passe au champ suivant. Si la valeur du champ ne correspond pas au format du champ, le nom du bouton change et indique Ignorer le champ. Si la valeur du champ ne peut pas être corrigée, elle peut être ignorée ou différée.
Différer le champ |  | Diffère la vérification du champ s’il n’est pas possible de le corriger
Caractère incertain précédent |  | Passe au caractère précédent reconnu sans certitude
Caractère incertain suivant |  | Passe au caractère suivant reconnu sans certitude
Annuler |  | Annule la dernière action
Rétablir |  | Restaure l’action annulée
Files et tâches (cette barre d’outils est disponible sur la station de vérification de données uniquement)

Outil | Bouton | Description
Obtenir la tâche |  | Obtient une nouvelle tâche de vérification.
Envoyer vers les exceptions |  | Envoie la tâche en cours vers les exceptions.
Rejeter la tâche |  | Rejette la tâche en cours (le serveur la renverra ultérieurement à un autre opérateur).
Actualiser |  | Actualise les informations de la tâche


Annexe

Conception de formulaires lisibles par machine
Raccourcis clavier
Utilisation de scripts dans FlexiCapture 9.0
Règles de FormReader 6.5 et FlexiCapture 9.0 comparées
Langues de reconnaissance prises en charge
Polices pour un rendu correct des caractères
Types de texte pris en charge
Type de codes barres pris en charge
Formats graphiques pris en charge
Formats de fichiers d'exportation
Alphabet utilisé dans des expressions normales
Brevets
Technologies fournies par d'autres sociétés


Création d'un formulaire lisible par machine

Les questionnaires, les formulaires de la sécurité sociale, les bulletins de vote et les contrats de garantie représentent tous des types de formulaire utilisés pour collecter différents types d'informations.

En quoi les formulaires sont-ils différents des autres types de documents ?

  1. Un formulaire contient toujours un certain nombre de champs.
  2. Chaque champ ne contient qu'un certain type d'informations, par exemple, un champ « Nom » ne contient que les noms (si le formulaire est correctement rempli) et un champ « Date » ne contient que des dates.

Les formulaires sont utilisés lorsque les informations à recueillir proviennent d'un grand nombre de personnes. La collecte manuelle des données représente un processus long et fastidieux, les coquilles et les erreurs sont difficilement évitables. Les formulaires lisibles par machine sont utilisés pour automatiser le processus.

Le traitement des formulaires automatisés passe par les étapes suivantes :

  1. configuration de l'application de traitement des formulaires (création d'une définition de document et définition des champs à reconnaître) ;
  2. acquisition des images des formulaires (numérisation) ;
  3. traitement des images des formulaires (reconnaissance des images et validation des données extraites) ;
  4. exportation des données extraites vers un système d'information externe.

Le traitement automatisé des formulaires est plus efficace pour les formulaires qui remplissent les conditions discutées dans le présent chapitre.

Formulaires lisibles par machine
Éléments de formulaires lisibles par machine
Méthodes de remplissage de formulaire
Types de formulaires lisibles par machine
Choix du type de formulaire adéquat
Exigences générales pour les formulaires lisibles par machine


Formulaires lisibles par machine

Pour lire les informations présentes sur un formulaire, une application de traitement de formulaire doit :

  1. déterminer l'emplacement des éléments du formulaire ;
  2. séparer les contenus de champs des bords de champs, marquages de textes, arrière-plans, textes explicatifs, etc.

Les formulaires lisibles par machine permettent au programme d'effectuer ces tâches.

Pour que la première tâche soit effectuée correctement, les formulaires doivent correspondre au gabarit du formulaire ou à la définition du document, c'est-à-dire que la position de tous les éléments du formulaire doit être identique sur tous les formulaires du même type.

Pour que la seconde tâche soit effectuée correctement, les formulaires doivent être conçus en gardant à l'esprit l'entrée automatique, afin que le programme puisse facilement faire la distinction entre les données à acquérir et les éléments non reconnaissables du formulaire tels que les bords de champs, marquages de texte, arrière-plans ou textes explicatifs.


Éléments de formulaires lisibles par machine

Les éléments suivants peuvent être présents sur un formulaire :

puce | Texte
puce | Champ d'entrée
puce | Champ de coche
puce | Groupe de coches
puce | Ancre
puce | Séparateur de ligne
puce | Identificateur de formulaire
puce | Image
puce | Tableau
puce | Groupe d'éléments


Création d'un formulaire lisible par machine/texte

Texte

Untexte est un élément de formulaire lisible par machine contenant du texte descriptif : titre du formulaire, noms des champs, explications, etc.


Création d'un formulaire/champ d'entrée lisible par machine

Champ d'entrée

Un champ d'entrée est un élément d'un formulaire lisible par machine dans lequel la personne qui remplit le formulaire entre du texte. Pour faciliter l'entrée de texte, les champs d'entrée peuvent contenir des marquages de textes spéciaux. Les champs d'entrée dont généralement accompagnés d'un texte décrivant ou expliquant la nature des données à entrer.

Pour voir un champ d'entrée

Les types de marquages de texte possibles sont listés dans le tableau ci-dessous.

Texte sur une ligne | Le texte est entré sur une ligne.
Lettres encadrées | Les lettres sont entrées dans des cadres conjoints.
Lettres encadrées séparément | Les lettres sont entrées dans des cadres isolés.
Lettres sur un peigne | Les lettres sont entrés dans un peigne.
Texte encadré | Le texte est entré dans un cadre.
Texte dans un cadre muni d'un peigne | Le texte est entré dans un cadre muni d'un peigne.


Création d'un formulaire/champ de coche lisible par machine

Champ de coche

Un champ de coche est un élément d'un formulaire lisible par machine (en général, il s'agit d'un carré que l'on appelle « case à cocher ») que la personne qui remplit le questionnaire doit cocher.

Un champ de coche est généralement pourvu d'un texte d'accompagnement qui explique l'utilisation de la coche.

Pour voir un champ de coche

Les formes possibles des champs de coche sont affichées dans le tableau ci-dessous

Carré
Cercle
Souligné

D'autres formes sont également possibles, comme des polygones, ovales, etc.


Création d'un formulaire lisible par machine/groupe de coches

Groupe de coches

Un groupe de coches est un élément de formulaire lisible par machine réunissant plusieurs champs de coche parmi lesquels un seul doit être coché. Les groupes de coches sont généralement accompagnés d'un texte explicatif décrivant le type de choix à faire.

Afficher un groupe de coches


Ancre

Une ancre est un élément d'un formulaire lisible par machine utilisé pour faciliter l'association d'images de formulaires avec des définitions de document. Elle est également utilisée pour déterminer l'orientation des formulaires pendant le traitement automatique.

Avant que le programme puisse démarrer la reconnaissance du contenu du formulaire, il doit faire correspondre le formulaire à sa définition de document. Tous les formulaires lisibles par machine du même type doivent se conformer à une définition de document, c'est-à-dire que la position de tous les éléments du formulaire doit être exactement la même sur tous les formulaires. Le programme tentera d'associer le formulaire à sa définition de document selon le nombre et la position des ancres sur le formulaire. Si le programme réussit à associer les ancres présentes sur le formulaire avec les ancres de la définition de document, il saura exactement où chercher les champs contenant les données devant être reconnues.

Les ancres standard sont listées dans le tableau ci-dessous.

Carré noir
Coin
Croix
Marque de temporisation
Pour obtenir les meilleurs résultats de reconnaissance possibles, il est conseillé de pourvoir le formulaire d'ancres standard même si, dans certains cas, les séparateurs de ligne, textes explicatifs ou codes barres peuvent servir d'ancres. Cependant, les ancres standard sont plus fiables et doivent toujours primer sur les autres choix possibles.


Création d'un formulaire lisible par machine/séparateur de lignes

Séparateur de lignes

Un séparateur de lignes est un élément de formulaire lisible par machine qui a la forme d'une ligne noire verticale ou horizontale.

Les séparateurs de lignes sont utilisés pour diviser les formulaires en plusieurs segments logiques.


Création d'un formulaire lisible par machine/identificateur

Identificateur de formulaire

Un identificateur de formulaire est un élément de formulaire lisible par machine utilisé pour sélectionner la bonne définition de document si plusieurs définitions de document ont la même organisation d'ancres.

Nous vous recommandons d'utiliser des codes barres comme identificateurs de formulaire.

Un code barre est un ensemble de lignes verticales noires et blanches de différentes largeurs utilisé pour encoder des informations.

Afficher un code barre

D'autres éléments du formulaire peuvent également être utilisés comme identificateurs de formulaire.


Création d'un formulaire lisible par machine/image

Image

Une image est un élément de formulaire lisible par machine qui ne doit pas être reconnu et qui doit être exporté en tant que fichier image.

Par exemple, la partie du formulaire où un tampon ou une signature doit être apposé est une image.


Tableau

Un tableau contient des colonnes avec des éléments de même type.

Les colonnes d'un tableau peuvent contenir des éléments des types suivants :

  • texte ;
  • champ de saisie ;
  • date ;
  • nombre ;
  • coche.

Un tableau peut contenir une ligne avec des en-têtes de colonnes.


Groupe d'éléments

Groupe d'éléments : élément d'un formulaire lisible par machine qui permet de combiner plusieurs éléments liés de manière logique en un groupe.


Méthodes de remplissage de formulaire

Un formulaire peut être rempli d'une des manière suivantes :

  • À la main

  • À l'aide d'une imprimante matricielle

  • À l'aide d'une machine à écrire

  • Dans un atelier d'impression (comprend les formulaires remplis à l'aide d'imprimantes laser ou à jet d'encre avec une résolution de 300 dpi au minimum)

  • À l'aide d'une combinaison des méthodes susmentionnées


Types de formulaires lisibles par machine

Les formulaires lisibles par machine sont conçus pour la saisie automatisée des données, c'est-à-dire que le programme doit être en mesure de distinguer facilement les données à acquérir des éléments de formulaire non reconnaissables tels que les bordures de champs, les marquages de texte, les arrière-plans ou les textes explicatifs.

Ce formulaire peut être obtenu de deux manières :

  1. le formulaire doit être conçu de manière à ce que les bordures de champs, arrière-plans et marquages de texte disparaissent après la numérisation ; ou

  2. le formulaire doit être conçu de manière à ce que les bordures de champs, arrière-plans et marquages de texte ressortent clairement après la numérisation.

Avec la première approche, seuls les ancres, les textes explicatifs et les données saisies resteront sur le formulaire après la numérisation. Par conséquent, le programme n'aura pas à séparer les données des éléments du formulaire ce qui facilitera la reconnaissance et la rendra plus fiable.

Dans ce cas, les types de formulaires suivants sont utilisés : formulaires simili détourés couleur, formulaires noir et blanc avec arrière-plans tramés, formulaires noir et blanc avec bordures tramées et formulaires linéaires noir et blanc.

Avec la deuxième approche, seuls les ancres, les textes explicatifs et les données saisies ainsi que les marquages de texte et les bordures de champs resteront sur le formulaire après la numérisation. Le programme recherchera les informations entourées par des bordures de champs et des marquages de texte. Si ces éléments de formulaire sont absents, cela nuira à la qualité de la reconnaissance.
Dans ce cas, des formulaires linéaires noir et blanc sont utilisés.


Formulaires simili détouré

Les formulaires simili détourés ont un arrière-plan de couleur claire avec des rectangles blancs qui servent de cellules de caractères, de champs de coche, etc.

Les formulaires simili détourés en niveaux de gris, dont l'arrière-plan est en niveaux de gris sont un exemple.

Les formulaires simili détourés couleur incluent les formulaires pour lesquels seuls les bords d'éléments sont colorés.

Une cellule de caractères est un petit rectangle dans lequel un seul caractère peut être entré (une lettre ou un chiffre par exemple). La couleur de l'arrière-plan est très importante car elle doit disparaître pendant la numérisation. L'arrière-plan est habituellement orange-rouge clair ou vert. Consultez la liste des couleurs recommandées dans Couleurs recommandées pour les formulaires simili détourés.

Pour voir un formulaire simili détouré

Idéalement, tous les éléments des formulaires, sauf les ancres, doivent disparaître au cours de la numérisation en ne laissant que les contenus des champs à reconnaître sur l'image du formulaire.

Le texte d'explication peut être soit conservé (si l'impression est en noir), soit filtré avec l'arrière-plan. Pour que le texte d'explication disparaisse au cours de la numérisation, il doit être imprimé de la même couleur que l'arrière-plan du formulaire mais avec une saturation supérieure.

Lorsque vous décidez d'imprimer ou pas le texte d'explication en noir ou dans la couleur de l'arrière-plan, il est important de prendre en considération les points suivants :

  • La taille du fichier image sera supérieure si le texte d'explication est conservé.

  • Il doit y avoir un espace d'au moins 1,5-2 mm entre le texte d'explication imprimé en noir et les autres éléments du formulaire. L'espacement entre le texte d'explication et le champ de coche correspondant ne doit pas être inférieur à 2/3 de la taille du champ de coche. Si le texte d'explication est imprimé dans la couleur de l'arrière-plan, les espaces entre le texte et les autres éléments du formulaire ne sont pas très importants.

Les formulaires avec un texte d'explication imprimé en noir sont plus lisibles. Nous vous recommandons d'imprimer le texte d'explication en noir, en particulier s'il n'y a pas d'ancre sur le formulaire.

Conseil
Lors de la création d'une définition de document pour un formulaire avec un texte d'explication imprimé dans la couleur de l'arrière-plan, assurez-vous de numériser en couleur ou en niveaux de gris pour que le texte d'explication et les éléments du formulaire soient clairement lisibles.

Les formulaires simili détourés doivent être numérisés au moyen d'une lampe de couleur ou d'un filtre. La couleur de la lampe est sélectionnés en fonction de la couleur de l'arrière-plan.

Les formulaires avec des arrière-plans rouges ou verts doivent être numérisés selon les modes suivants :

  • avec un scanner couleur, au moyen d'un logiciel de filtrage de couleur ;
  • avec un scanner noir et blanc, au moyen d'une lampe rouge ou verte (filtrage matériel de la couleur) ;
  • avec un scanner noir et blanc, au moyen d'une lampe blanche et d'un filtre rouge ou vert (la qualité de filtrage dans ce cas est nettement inférieure, puisque l'arrière-plan peut ne pas disparaître complètement, ou les contenus des champs peuvent être effacés par inadvertance) ; ou
  • avec un scanner noir et blanc, au moyen d'une lampe blanche sans filtre
    Lors de la numérisation avec une lampe blanche, certains arrière-plans plus clairs peuvent être effacés sans filtrage : la faible saturation de l'arrière-plan garantit sa disparition au cours de la numérisation. Dans ce cas, la couleur et la saturation de l'arrière-plan doivent être sélectionnées par approximations successives pour chaque scanner en particulier.

Remarque : De nombreux scanners couleur disposent également d'un filtrage des couleurs bleues. Toutefois, il n'est pas conseillé d'utiliser les niveaux de bleus pour vos formulaires, car les formulaires ne sont pas remplis qu'avec de l'encre noire, mais parfois aussi avec de l'encre bleue. Les contenus de champs écrits avec de l'encre bleue disparaîtraient alors.

Choix de la bonne couleur

Les couleurs orange-rouges sont préférables au vert car elles représentent la plus importante possibilité de contraste avec le bleu, ce qui améliore la qualité de numérisation et de reconnaissance si les formulaires sont remplis avec de l'encre bleue.

Dans la section Couleurs recommandées pour les formulaires simili détourés, vous trouverez les couleurs recommandées pour le traitement des formulaires, par exemple, les couleurs qui présentent le plus grand risque de disparition pendant la numérisation, quel que soit le scanner. Vous pouvez obtenir une liste des couleurs « simili détourées » pour un scanner en particulier (sous Pantome ou sous un autre format) auprès du fabricant/revendeur de votre scanner.


Formulaires en noir et blanc avec arrière-plan tramé

Formulaires en noir et blanc avec arrière-plans tramés

Les champs de ce type de formulaire sont représentés par de simples espaces blancs (en général, des rectangles) sur un arrière-plan tramé. L'arrière-plan est constitué de points distincts. La taille recommandée des points est inférieure à 0,1 mm, avec une distance entre chaque point d'environ 1 mm. La taille des points et la distance entre les points sont des données essentielles du fait qu'un arrière-plan tramé se voit effacé pendant le nettoyage et non pas pendant la numérisation : le programme traitera les points comme s'ils étaient des éléments parasites et les effacera alors. C'est pourquoi les points ne doivent pas être collés ensemble sur les images numérisées.


Formulaires en noir et blanc avec bords tramés

Ces formulaires n'ont aucun arrière-plan. Tous les bords des champs (bords des cellules de caractères, champs de coche et autres éléments de formulaire) sont constitués de lignes tramées, soit des suites de petits points noirs. La taille d'un point de trame est généralement comprise entre 0,39 et 0,5 pt. La taille recommandée est 0,39 pt, avec une distance entre les points de trame au moins cinq fois plus grande que la taille du point. La taille des points et la distance qui les séparent sont des données essentielles du fait qu'un arrière-plan tramé se voit effacé pendant le nettoyage et non pas pendant la numérisation : le programme traitera les points comme s'ils étaient des éléments parasites et les effacera alors. C'est pourquoi les points ne doivent pas être collés ensemble sur les images numérisées.


Formulaires linéaires à lignes noires et blanches

Ces formulaires n'ont généralement aucun arrière-plan. Toutes les bordures de champs (cellules de caractères, champs de coche et autres éléments de formulaires) sont faites de lignes noires épaisses. Les bordures de champs ne disparaissent pas après la numérisation ou le nettoyage.

Remarque : Les formulaires de ce type doivent être remplis avec beaucoup de soin. Si les formulaires ne sont pas remplis avec soin, les lettres peuvent chevaucher les bordures des champs et réduire de ce fait la qualité de la reconnaissance. En effet, lorsque le contenu des champs chevauche les bords des champs, il est extrêmement difficile pour l'application de séparer les bordures du texte. Idéalement, le texte entré ne doit pas toucher les bordures des champs.


Choix du type de formulaire adéquat

Outre les exigences de conception et de traitement de chaque type de formulaire, d'autres critères sont à prendre en considération lors du choix d'un type de formulaire. Ces critères comprennent les coûts et les méthodes d'impression, le nombre de copies nécessaire, la taille de l'image obtenue, les modes de numérisation, le degré de précision de reconnaissance requis, la vitesse de traitement des formulaires, l'apparence générale des formulaires, leur mode de remplissage, etc. Le tableau ci-après présente de façon sommaire les avantages et les inconvénients de chaque type de formulaire.

Critères | Formulaire simili détouré |  | Formulaire tramé à lignes noires et blanches |  | Formulaire linéaire à lignes noires et blanches
 | Inconvénients | Avantages | Inconvénients | Avantages | Inconvénients | Avantages
Complexité de la conception |  | Conception facile au moyen de tout éditeur graphique | Les éditeurs de texte offrent des outils limités pour la conception de ce type de formulaire La taille des points de trame est une donnée essentielle |  |  | Conception facile au moyen de tout éditeur graphique
Impression | Il est difficile d'imprimer une grande quantité de formulaires avec une bonne qualité en interne. |  |  | Facile à imprimer en interne |  | Facile à imprimer en interne
Coûts de l'impression | Si vous utilisez des services d'impression professionnels, les coûts de l'impression sont supérieurs par rapport à l'impression des formulaires en noir et blanc. |  |  | Si vous utilisez des services d'impression professionnels, les coûts de l'impression sont inférieurs par rapport à l'impression des formulaires en simili détouré. |  | Si vous utilisez des services d'impression professionnels, les coûts de l'impression sont inférieurs par rapport à l'impression des formulaires en simili détouré.
Taille de l'image |  | Les tailles des fichiers images sont plus petites. | Les tailles des fichiers images sont plus grandes. |  | Les tailles des fichiers images sont plus grandes. |
Mode de numérisation | Seuls les modes de numérisation spéciaux (filtrage de la couleur) peuvent être utilisés. |  | La plage des paramètres de luminosité et de contraste est limitée. |  | La plage des paramètres de luminosité et de contraste est limitée. |
Vitesse de traitement |  | La moyenne de la vitesse de traitement est plus élevée. | La moyenne de temps d'impression est supérieure car les images doivent être nettoyées. |  | Les erreurs sont plus fréquentes si les caractères sont collés entre eux ou chevauchent les bords des champs. |
Qualité de reconnaissance |  | Une qualité de reconnaissance très élevée. |  | Une qualité de reconnaissance élevée. | Une qualité de reconnaissance très dépendante de la manière avec laquelle le formulaire a été rempli. | Une qualité de reconnaissance élevée si le formulaire a été correctement rempli.
Emplacement du texte d'explication |  | Le texte d'explication peut être placé n'importe où, y compris à l'intérieur des champs (tant qu'il est imprimé au moyen de la même couleur que l'arrière-plan du formulaire). | Le texte d'explication et les autres éléments du formulaire doivent être organisés avec soin dans le formulaire. |  | Le texte d'explication et les autres éléments du formulaire doivent être organisés avec soin dans le formulaire. |
Apparence et lisibilité des formulaires | Les paramètres de contraste peu élevé entre l'arrière-plan et le texte d'explication sont susceptibles d'affecter négativement la lisibilité des formulaires. | Esthétique agréable | Une conception moins accrocheuse. Lisibilité moindre. |  | Une conception moins accrocheuse. | Bonne lisibilité.
Soin du remplissage |  | Moins sensible au texte chevauchant les bords des champs. | Les petits caractères doivent être écrits avec soin et doivent être suffisamment grands pour ne pas être effacés comme des éléments parasites. | Moins sensible au texte chevauchant les bords des champs. | Très sensible au texte chevauchant les bords des champs. |


Exigences générales pour les formulaires lisibles par machine

Considérons à présent les conditions requises pour qu'un formulaire soit lisible par machine.

puce | Exigences pour l'arrière-plan de formulaire
puce | Exigences relatives aux ancres
puce | Exigences pour le champ de coche
puce | Exigences relatives au marquage de texte
puce | Exigences pour le positionnement des éléments
puce | Exigences pour la qualité d'impression
puce | Exigences de remplissage des formulaires


Exigences pour l'arrière-plan de formulaire

  1. Si possible, utilisez des formulaires simili détourés ou des formulaires dont les bordures de champs sont tramées.
  2. Lorsque vous créez un formulaire simili détouré, utilisez une couleur qui disparaît pendant la numérisation. Consultez la liste des couleurs recommandées dans Couleurs recommandées pour les formulaires simili détourés.
  3. Veillez toujours à ce qu'il y ait un espace entre le texte explicatif et le contenu du champ. Pour les formulaires simili détourés, nous vous recommandons d'imprimer toutes les informations dans la même couleur que l'arrière-plan du formulaire (sauf à l'endroit où le texte explicatif est utilisé comme ancre au lieu des carrés noirs ou conjointement avec les carrés noirs). En imprimant des informations dans la même couleur que l'arrière-plan, vous êtes libre de les placer n'importe où sur le formulaire, y compris à l'intérieur des champs du formulaire.
  4. N'utilisez pas de couleurs bleues pour les formulaires à remplir à la main. L'arrière-plan bleu pourrait se mélanger à l'encre bleue qui sera certainement utilisée pour remplir les formulaires, ce qui nuirait à la qualité de la reconnaissance.


Exigences relatives aux ancres

  1. Les ancres standard sont recommandées pour utilisation sur des formulaires lisibles par machine (soit les carrés noirs, coins ou croix). Le nombre d'ancres recommandé est de cinq : quatre ancres disposées à chaque coin du formulaire (elles formeraient un rectangle si l'on devait tracer des lignes entre chaque paire d'ancres) et un carré sur l'un des côtés dudit rectangle.
  2. Si, pour une raison ou une autre, les ancres standard ne peuvent être utilisées, il est recommandé d'utiliser la combinaison d'éléments suivante en guise d'ancres :
    a) au moins deux séparateurs de ligne verticale et deux séparateurs de ligne horizontale
    b) au moins quatre éléments de texte et un identificateur de formulaire
    c) d'autres combinaisons sont également possibles
  3. La distance séparant le bord d'une ancre et l'élément de formulaire le plus proche ne doit pas être inférieure à 3 mm.
  4. La distance séparant une ancre et le bord de la page ne doit pas être inférieure à 8 mm.
  5. Les ancres doivent être imprimées dans une couleur sombre (le noir est recommandé) de manière à ce qu'elles ne disparaissent pas pendant la numérisation.

En plus des exigences générales listées ci-dessus, chaque type d'ancre possède ses exigences propres :

Exigences relatives aux carrés noirs

Les carrés noirs d'un même type de formulaire doivent tous avoir les même dimensions, soit de 4x4 mm à 8x8 mm. Les dimensions recommandées sont 5x5 mm. Les rectangles ne sont pas permis.

Exigences relatives aux croix et aux coins

  1. Les dimensions d'un carré imaginaire qui pourrait être tracé autour d'une ancre de ce type doivent être comprises entre 4x4 mm et 8x8 mm. Les dimensions recommandées sont 5x5 mm.
  2. Les dimensions d'une ancre d'un type donné doivent être les mêmes dans un formulaire.
  3. Tous les côtés d'une ancre doivent être de taille égale.
  4. L'épaisseur de ligne utilisée pour les ancres d'un même formulaire doit être la même et comprise dans une plage de 0,3 à 1 mm. L'épaisseur recommandée est 0,5 mm.

Exigences relatives au texte(s'il est utilisé comme ancre)

La taille de la police ne doit pas être inférieure à 7 pt (et pour les en-têtes, pas moins de 14 pt).

Exigences relatives aux séparateurs de ligne (si utilisés comme ancres)

L'épaisseur de ligne ne doit pas être inférieure à 1 pt. L'épaisseur recommandée est comprise entre 1 et 1,5 pt.

Exigences relatives aux codes barres (si utilisés comme ancres)

  1. La largeur du code barres (la distance entre la barre la plus à gauche et la barre la plus à droite) ne doit pas être inférieure à une plage de 47 à 50 mm.
  2. La hauteur du code barres ne doit pas être inférieure à une plage de 12 à 15 mm (chiffres exclus).
  3. L'orientation du code barres (direction des barres) doit être la même que l'orientation de la page (il est recommandé de numériser les pages dans la même direction que les barres).
  4. Le format de code barres EAN 13 est recommandé.
  5. La distance recommandée entre un code barres et tout autre élément du formulaire est de 10 mm au minimum.


Exigences pour le champ de coche

  1. Les tailles de champ recommandées sont 3,5x3,5 mm, 4x4 mm, 4,5x4,5 mm ou 5x5 mm ; dans le cas de champs de coche circulaires, ils doivent tenir dans les carrés des tailles recommandées.
  2. La largeur de ligne recommandée pour les bordures de champs de coche est de 0,4 mm (quelle que soit la taille du champ).


Exigences relatives au marquage de texte

Taille du point de trame :

  1. Si les bords du champ sont des points de trame, l'épaisseur de la ligne tramée (soit la taille de la trame) doit être 0,39 pt.

  2. La distance optimale séparant les points de trame est de cinq fois leur taille.

    Important ! Les points qui ont le plus de chance d'être collés entre eux sont ceux situés dans les coins des cellules de caractères.

Conseil
Si votre logiciel ne vous permet pas de définir la distance qui sépare chaque point de trame, vous devez sélectionner un style de ligne dont les points sont suffisamment espacés les uns des autres pour éviter qu'ils ne soient collés entre eux sur l'image numérisée et qu'ils ne restent sur l'image après le nettoyage de celle-ci. Cela est dû au fait que les gros points ne sont pas interprétés par le système OCR comme étant des éléments parasites et ne sont donc pas effacés de l'image pendant le nettoyage.

Dimensions d'une cellule de caractères :

  1. Les dimensions recommandées pour une cellule de caractères sont 4x5 mm ; l'utilisation de dimensions plus réduites implique un plus haut degré de précision de la part des personnes censées remplir le formulaire, ce qui complique considérablement la chose. Les cellules de caractères de grande taille ne sont également pas recommandées étant donné qu'elles encouragent l'emploi de lettres anormalement grandes. L'idéal serait que les dimensions de la cellule de caractères correspondent à la taille moyenne d'une lettre.
  2. La distance entre les lignes de champ ne doit pas être inférieure à une plage de 2,5 à 3 mm et la distance entre deux cellules de caractères adjacentes situées sur la même ligne ne doit pas être inférieure à une plage de 1 à 1,2 mm.
Pour voir des cellules de caractères

Épaisseur de ligne :

  1. Si les bords sont des lignes noires (« texte encadré », « lettres encadrées séparément » et « lettres encadrées »), l'épaisseur de ligne doit être de 1 pt.
Pour voir des bords en lignes noires

Peignes :

  1. La distance recommandée entre les crans d'un peigne est 5 mm.
  2. La distance séparant les lignes horizontales de deux peignes, lorsqu'on les positionne l'un en-dessous de l'autre, ne doit pas être inférieure à une plage de 7,5 à 8 mm.
  3. La hauteur de cran doit être comprise entre 0,9 et 1,2 mm.
  4. L'épaisseur des lignes horizontales ainsi que des crans doit être de 1 pt.
  5. Si des cadres munis d'un peigne sont utilisés, la distance minimum entre les cadres doit être comprise entre 2,5 et 3 mm.
Pour voir un peigne


Exigences pour le positionnement des éléments

  1. Assurez-vous d'attribuer suffisamment de marges à votre formulaire, sinon les éléments du formulaire trop proches des bords du formulaire pourraient disparaître pendant la numérisation ce qui conduira à une perte de données.
  2. L'espacement entre les éléments voisins d'un formulaire ne doit pas être inférieur à 2 mm.
  3. L'espacement entre un champ de coche et le texte explicatif ne doit pas être inférieur à 2/3 de la taille du champ de coche.
  4. Assurez-vous que le texte explicatif ne chevauche pas les bordures du champ de saisie.
  5. Si le texte explicatif est imprimé en encre noire, assurez-vous qu'il y a un écart d'au moins 1,5-2 mm entre le texte explicatif et les autres éléments. Cette distance n'est pas aussi importante pour le texte explicatif imprimé avec la même encre que l'arrière-plan.


Exigences pour la qualité d'impression

Lorsque vous imprimez des formulaires vierges, gardez à l'esprit les exigences suivantes :

  1. Les formulaires doivent être imprimés en qualité professionnelle ou avec une imprimante. Nous vous recommandons d'imprimer les formulaires en couleurs en qualité professionnelle. Si ceci est impossible, testez la couleur du formulaire sur un scanner avant de commencer votre série d'impressions.
  2. Toutes les copies du formulaire doivent être imprimées en utilisant le même document source parce que l'emplacement des champs de chaque formulaire doit être identique.
  3. La taille minimale des marges (c'est-à-dire la distance entre le bord de la page et l'élément du formulaire le plus proche) doit être d'au moins 8 mm, et la taille recommandée est de 12 mm.
  4. La déviation linéaire autorisée des éléments du formulaire est au maximum de 0,15 %, c'est-à-dire 0,5 mm pour une page A4.
  5. Si vous imprimez vos formulaires avec une imprimante, ne les imprimez pas dans une résolution inférieure à 600 ppp.
  6. Nous vous recommandons d'imprimer les formulaires à l'aide du même scanner ou de différents scanners du même modèle.

Conseil : Nous déconseillons de copier des formulaires lisibles par machine en utilisant un équipement de copie. L'utilisation d'un tel équipement peut légèrement modifier les dimensions des éléments du formulaire ou leur organisation, par exemple, les bordures de tableau ou de champs de saisie peuvent devenir plus épaisses ou la profondeur des couleurs peut changer ce qui peut nuire à la qualité de la reconnaissance.


Exigences de remplissage des formulaires

Stylos et encre

Il est préférable de remplir les formulaires en capitales, à l'aide d'un stylo à bille, d'un stylo gel ou d'un stylo à système capillaire noir (l'encre bleue foncé ou violette est également acceptable). Les stylos feutre ou marqueurs ne sont pas recommandés car les caractères écrits sont trop épais, ce qui provoque des problèmes de reconnaissance. La reconnaissance est moins bonne lorsque le formulaire est rempli à l'aide d'un crayon à papier ou d'une encre de couleur claire.

Taille et style des lettres

Pour obtenir de meilleurs résultats de reconnaissance, les formulaires doivent être remplis en caractères d'imprimerie. Les lettres doivent remplir toutes les cellules de caractères, mais sans chevaucher les bords des cellules.

Si les cellules de caractères sont marquées visuellement dans les formulaires (par exemple, les types de marquage de texte suivants sont utilisés : lettres encadrées, lettres encadrées séparément), il est moins probable que la personne qui remplit le formulaire écrive en lettres attachées.

Les types de marquage de texte suivants posent des problèmes de reconnaissance plus importants : texte dans un cadre muni d'un peigne, lettres sur un peigne. Dans ce cas, seule la largeur de la cellule de caractères est prédéfinie, et l'absence de bordures rend l'écriture en lettres attachées possible. Dans le cas de peigne sans cadre, les lettres écrites peuvent être soient trop petites soient trop grandes.

Si un texte encadré ou un texte sur une ligne est utilisé, il n'y a pas de limitation de la largeur des cellules de caractères. Les lettres peuvent être attachées, ce qui peut affecter de façon négative la qualité de la reconnaissance. Dans le cas de texte sur une ligne, il n'y a pas de limitation de la hauteur des caractères. Par conséquent, le type de marquage n'est pas recommandé pour les formulaires qui nécessitent une précision de reconnaissance de haute qualité.

Il est également nécessaire que les lettres ne chevauchent pas les bordures des champs. Cette recommandation n'est pas si cruciale pour les formulaires simili détourés ou les formulaires tramés à lignes noires et blanches, car les bordures des champs disparaissent au cours de la numérisation et du nettoyage. Mais, si les lettres chevauchent les bordures des champs dans les formulaires linéaires à lignes noires et blanches, la qualité de la reconnaissance peut être sérieusement diminuée.

Exemple

Afin d'encourager un bon remplissage des formulaires, nous vous recommandons de joindre une note au formulaire, similaire à celle ci-dessous.


Couleurs recommandées pour les formulaires simili détourés

Le tableau ci-dessous contient des exemples de couleurs simili détourées et leurs numéros Pantone correspondants. Ces couleurs d'arrière-plan disparaissent si les formulaires sont numérisés à l'aide de :

  • n'importe quel scanner
    Afficher le tableau de la lumière blanche
  • un scanner couleur avec filtrage de la couleur rouge par logiciel ou un scanner noir et blanc à lampe rouge/filtre rouge
    • Afficher le tableau de la lumière rouge


Raccourcis clavier

Cette section liste les raccourcis clavier utilisés dans les différentes fenêtres du programme. L’utilisation des raccourcis permettra d’économiser du temps et d’optimiser votre manière de travailler.

Raccourcis clavier de la station de configuration de projets
Raccourcis clavier de la station de vérification
Raccourcis clavier de la station de vérification des données
Raccourcis clavier de l’éditeur de définition de document
Raccourcis clavier de la vérification groupée
Raccourcis clavier de la vérification de champ


Raccourcis clavier dans la fenêtre principale de la station de configuration de projets

Raccourcis clavier de la station de configuration de projets

Menu | Commande | Raccourci
Fichier | Nouveau projet… | CTRL+MAJ+N
 | Ouvrir un projet… | CTRL+MAJ+O
 | Enregistrer | CTRL+S
 | Nouveau lotNouveau lot… | CTRL+N
 | Charger des images… | CTRL+O
 | Numériser des images… | CTRL+K
 | Importer des images… | CTRL+I
 | Exporter vers un Données vers fichiers… | ALT+MAJ+S
 | Exporter vers une Base de données… | ALT+MAJ+D
 | Quitter | ALT+F4
Éditer | Annuler | CTRL+Z
 | Rétablir | CTRL+Y
 | Couper | CTRL+X
 | Copier | CTRL+C
 | Coller | CTRL+V
 | Supprimer | SUPPR
 | Tout sélectionner | CTRL+A
 | Rechercher… | CTRL+F
 | Rechercher suivant | F3
 | Accéder à > Document suivant | CTRL+D
 | Accéder à > Document précédent | CTRL+MAJ+D
 | Image > Nettoyer | CTRL+ALT+K
 | Image > Inverser | CTRL+ALT+V
 | Image > Faire tourner deTourner de 90° vers la droite | CTRL+W
 | Image > Faire tourner deTourner de 90° vers la gauche | CTRL+MAJ+W
Afficher | Lots de test | CTRL+MAJ+B
 | Lots | CTRL+B
 | Details | ALT+1
 | Vignettes | ALT+2
 | Mode Image | CTRL+1
 | Mode Données | CTRL+2
 | Zoom avant | CTRL+NUM+
 | Zoom arrière | CTRL+NUM-
 | Taille des vignettes : Augmenter | CTRL+MAJ+NUM+
 | Taille des vignettes : Diminuer | CTRL+MAJ+NUM-
 | Plein écran | F11
 | Actualiser | F5
 | Propriétés des objets | ALT+ENTRÉE
Reconnaissance | Analyser | CTRL+E
 | Associer une définition de document… | ALT+MAJ+E
 | Reconnaître | CTRL+R
Vérification | Exécuter la vérification… | F7
 | Élément suivant à vérifier | F4
 | Élément précédent à vérifier | MAJ+F4
 | Erreur d'assemblage suivante | F9
 | Erreur d'assemblage précédente | MAJ+F9
 | Caractère incertain suivant | F8
 | Caractère incertain précédent | MAJ+F8
 | Erreur de règle suivante | F6
 | Erreur de règle précédente | MAJ+F6
Projet | Définitions de document… | CTRL+T
 | Types de lotsTypes de lot… | CTRL+MAJ+T
 | Profils d'importation d'images… | CTRL+MAJ+I
Outils | Mettre à jour vers la version la plus récente | ALT+MAJ+U
 | Analyser à nouveau | CTRL+ALT+E
 | Reconnaître à nouveau | CTRL+ALT+R
 | Vérifier à nouveau les règles | CTRL+F6
 | Vérifier l’intégrité du lot | CTRL+MAJ+E
Aide | Rubriques d’aide | F1
Commandes générales | Ouvrir la fenêtre de document (si un document ou une page est sélectionnée) | ENTRÉE


Raccourcis clavier dans la fenêtre principale de la station de vérification

Raccourcis clavier de la station de vérification

Menu | Commande | Raccourci
File | Enregistrer | CTRL+S
 | Nouveau lotNouveau lot… | CTRL+N
 | Charger des images… | CTRL+O
 | Numériser des images… | CTRL+K
 | Exporter vers un Données vers fichiers… | ALT+MAJ+S
 | Exporter vers une Base de données… | ALT+MAJ+D
 | Quitter | ALT+F4
Éditer | Annuler | CTRL+Z
 | Rétablir | CTRL+Y
 | Couper | CTRL+X
 | Copier | CTRL+C
 | Coller | CTRL+V
 | Supprimer | SUPPR
 | Tout sélectionner | CTRL+A
 | Rechercher… | CTRL+F
 | Rechercher suivant | F3
 | Accéder à > Document suivant | CTRL+D
 | Accéder à > Document précédent | CTRL+MAJ+D
 | Image > Nettoyer | CTRL+ALT+K
 | Image > Inverser | CTRL+ALT+V
 | Image > Faire tourner deTourner de 90° vers la droite | CTRL+W
 | Image > Faire tourner deTourner de 90° vers la gauche | CTRL+MAJ+W
Afficher | Lots | CTRL+B
 | Files | CTRL+Q
 | Details | ALT+1
 | Vignettes | ALT+2
 | Mode Image | CTRL+1
 | Mode Données | CTRL+2
 | Zoom avant | CTRL+NUM+
 | Zoom arrière | CTRL+NUM-
 | Taille des vignettes : Augmenter | CTRL+MAJ+NUM+
 | Taille des vignettes : Diminuer | CTRL+MAJ+NUM-
 | Plein écran | F11
 | Actualiser | F5
 | Propriétés des objets | ALT+ENTRÉE
Tâche | Obtenir la tâche | CTRL+G
Reconnaissance | Analyser | CTRL+E
 | Associer une définition de document… | ALT+MAJ+E
 | Reconnaître | CTRL+R
Vérification | Exécuter la vérification… | F7
 | Élément suivant à vérifier | F4
 | Élément précédent à vérifier | MAJ+F4
 | Erreur d'assemblage suivante | F9
 | Erreur d'assemblage précédente | MAJ+F9
 | Caractère incertain suivant | F8
 | Caractère incertain précédent | MAJ+F8
 | Erreur de règle suivante | F6
 | Erreur de règle précédente | MAJ+F6
Outils | Mettre à jour vers la version la plus récente | ALT+MAJ+U
 | Analyser à nouveau | CTRL+ALT+E
 | Reconnaître à nouveau | CTRL+ALT+R
 | Vérifier à nouveau les règles | CTRL+F6
 | Vérifier l’intégrité du lot | CTRL+MAJ+E
Aide | Rubriques d’aide | F1
Commandes générales | Ouvrir la fenêtre de document (si un document ou une page est sélectionnée) | ENTRÉE
 | Paramètres d’enregistrement | CTRL+P


Raccourcis clavier dans la fenêtre principale de la station de vérification de données

Raccourcis clavier de la station de vérification des données

Menu | Commande | Raccourci
File | Quitter | ALT+F4
Afficher | Plein écran | F11
 | Actualiser | F5
Tâches | Obtenir la tâche | CTRL+G
Aide | Rubriques d’aide | F1


Raccourcis clavier de l’éditeur de définition de document

Menu | Commande | Raccourci
Définition de document | Ajouter une page… | CTRL+P
 | Ajouter une section de document… | CTRL+ALT+S
 | Propriétés de la définition de document… | CTRL+T
 | Enregistrer | CTRL+S
 | Fermer | ALT+F4
Éditer | Annuler | CTRL+Z
 | Rétablir | CTRL+Y
 | Couper | CTRL+X
 | Copier | CTRL+C
 | Coller | CTRL+V
 | Supprimer | SUPPR
 | Supprimer la région | MAJ+SUPPR
 | Sélectionner tout | CTRL+A
 | Sélectionner par type… | CTRL+MAJ+A
 | Créer un champ : Texte | ALT+MAJ+T
 | Créer un champ : Coche | ALT+MAJ+C
 | Créer un champ : Groupe de coches | ALT+MAJ+M
 | Créer un champ : Code barres | ALT+MAJ+B
 | Créer un champ :Image | ALT+MAJ+P
 | Créer un champ : Tableau | ALT+MAJ+L
 | Créer un champ : Groupe | ALT+MAJ+G
 | Grouper | CTRL+G
 | Dégrouper | CTRL+MAJ+G
 | Copier le texte de l'image… | CTRL+ALT+C
 | Image > Nettoyer | CTRL+ALT+K
 | Image > Inverser | CTRL+ALT+V
 | Image > Tourner de 90° vers la droite | CTRL+W
 | Image > Tourner de 90° vers la gauche | CTRL+MAJ+W
Afficher | Éléments statiques | CTRL+1
 | Régions de champ | CTRL+2
 | Afficher la structure du document | ALT+F1
 | Structure de document : champs | ALT+1
 | Structure de document : pages | ALT+2
 | Formulaire de données | ALT+F2
 | Échelle de l’image : zoom avant | CTRL+NUM+
 | Échelle de l’image : zoom arrière | CTRL+NUM-
 | Propriétés | ALT+ENTRÉE
Document | Exécuter le test. | CTRL+R
Outils | Détecter automatiquement les objets… | CTRL+D
 | Vérifier la présentation du document | F9
 | Associer la section | CTRL+E
Aide | Rubriques d’aide | F1

Fenêtre Image

Commande | Raccourci
Sélectionner des régions | ÉCHAP
Détection automatique d’objets | CTRL+MAJ+D
Créer une ancre | A
Créer un séparateur | S
Créer du texte ancré | X
Créer un code barres d’ancrage | D
Créer un texte | T
Créer une coche | C
Créer un groupe de coches | M
Créer un code barres | B
Créer une image | P
Créer un tableau | L
Créer un groupe | G
Créer une région pour un champ sans région | R
Créer une région non reconnue | O
Créer une colonne de champ | U
Ajouter un séparateur à un tableau | F
Supprimer le séparateur du tableau | E
Ajuster la région | CTRL+ALT+A
Suggérer un nom | CTRL+ALT+N
Obtenir le nom de l'image… | CTRL+ALT+I
Détecter le type de marquage | CTRL+ALT+D

Fenêtre Structure du document

Commande | Raccourci
Afficher l’image du champ | ENTRÉE
Renommer le champ | F2
Lorsqu’un champ est sélectionné : |
Ajouter une colonne avec du texte | ALT+MAJ+T
Ajouter une colonne avec des coches | ALT+MAJ+C
Ajouter une colonne avec des codes barres | ALT+MAJ+B
Ajouter une colonne avec des images | ALT+MAJ+P
Lorsqu’un groupe de coches est sélectionné : |
Ajouter une coche | ALT+MAJ+C


Raccourcis clavier dans la fenêtre de vérification groupée

Raccourcis clavier de la fenêtre de vérification groupée

Menu | Commande | Raccourcis clavier
Vérification | Tout confirmer | ENTRÉE
 | Différer tout | CTRL+ENTRÉE
 | Basculer | ESPACE
 | Page suivante | PAGE SUIVANTE
 | Page précédente | PAGE PRÉCÉDENTE
 | Fermer | ALT+F4
Éditer | Annuler | CTRL+Z
 | Rétablir | CTRL+Y
 | Tout sélectionner | CTRL+A
Afficher | Image de champ > Afficher l'image du champ | CTRL+I
 | Image de champ > Au-dessus | ALT+1
 | Image de champ > En dessous | ALT+2
 | Image du champ > Échelle de l’image > Zoom avant | CTRL+NUM+
 | Image du champ > Échelle de l’image > Zoom arrière | CTRL+NUM-
 | Afficher l'image du caractère | F2
 | Plein écran | F11
Aide | Rubriques d’aide | F1
Menu d’icônes locales | Afficher l'image des caractères | F2
 | Confirmer | CTRL+E
 | Pause | CTRL+R
 | Réinitialiser | ÉCHAP


Raccourcis clavier dans la fenêtre de vérification de champ

Menu | Commande | Raccourcis clavier
Vérification | Confirmer le champ | ENTRÉE
 | Différer | CTRL+ENTRÉE
 | Caractère incertain suivant | F4
 | Caractère incertain précédent | MAJ+F4
 | Champ suivant | PAGE SUIVANTE
 | Champ précédent | PAGE PRÉCÉDENTE
 | Fermer | ALT+F4
Éditer | Annuler | CTRL+Z
 | Rétablir | CTRL+Y
 | Couper | CTRL+X
 | Copier | CTRL+C
 | Coller | CTRL+V
 | Supprimer | SUPPR
 | Tout sélectionner | CTRL+A
 | Insérer un saut de ligne | MAJ+ENTRÉE
 | Fusionner les caractères | CTRL+M
Afficher | Données de champ > Texte reconnu | ALT+F1
 | Données de champ > Coupe des images de caractère | ALT+F2
 | Image du champ > Afficher l'image du champ | CTRL+I
 | Image du champ > Au-dessus | ALT+1
 | Image du champ > En dessous | ALT+2
 | Image du champ > Échelle de l’image > Zoom avant | CTRL+NUM+
 | Image du champ > Échelle de l’image > Zoom arrière | CTRL+NUM-
 | Afficher l'image des caractères | F2
 | Plein écran | F11
Aide | Afficher l’Aide | F1


Utilisation de scripts dans FlexiCapture 9.0

Cette section explique comment utiliser des scripts pour créer des règles personnalisées, pour effectuer une exportation et pour créer des gestionnaires d'exportation dans FlexiCapture 9.0.

Deux langages de script sont pris en charge – JScript® et VBScript.

Règles d'utilisation

En VBScript, le mot-clé Me est obligatoire pour faire référence aux méthodes et champs de l'objet en cours (c'est l'équivalent de « this » en C++ et en Java). L'objet en cours est une unité de document vérifiable (une unité contenant une règle) dans le cas de règles, et un document exportable dans le cas d'une exportation.

Me.CheckSucceeded = False

Dans la même situation en JScript, il est possible d'omettre « this » :

this.CheckSucceeded = false; CheckSucceeded = false;

Les erreurs telles que « Méthode ou propriété non trouvée » sont générées pendant l'exécution du script :

ChecckSucceeded = false; // erreur d'exécution

Les erreurs de syntaxe sont générées à l'enregistrement du script :

CheckSucceeded +++ false; // erreur de syntaxe

Fonctions personnalisées

L'éditeur de script permet aux utilisateurs de créer leurs propres fonctions et procédures, puis de les rappeler au moyen du code des règles ou du code d'exportation.

Vous pouvez créer des fonctions personnalisées dans l'un des modules généraux suivants : soit dans le module d'exportation ou soit dans les modules de règles. Vous pouvez sélectionner le module souhaité dans l’éditeur de script.

Toutes les fonctions contenues dans un module doivent être rédigées dans le même langage. Vous pouvez rédiger le code de base d’une règle ou d’une exportation dans un autre langage que celui utilisé dans le module général correspondant.

Par exemple, à partir du code d’une règle rédigée en VBScript, vous pouvez appeler une fonction du module général rédigée en JScript.

Vous ne pouvez appeler les fonctions qu’à partir de leur « propre » module. Cela signifie que vous ne pouvez appeler que les fonctions contenues dans le module général de règles à partir du code des règles, et que des fonctions du module général de règles à partir du code d’exportation. Dans le cas contraire, vous obtiendrez une erreur pendant l’exécution.

Les fonctions sont appelées comme suit :

[VBScript]

result = Rules.SomeFunction( param1, param2 … )

Export.SomeFunction param1, param2 …

[JScript]

result = Rules.SomeFunction( param1, param2 … );

Export.SomeFunction( param1, param2 … );

Délai d'exécution d'un script

Par défaut, le délai d'exécution est de 10 secondes pour les règles et de 1 minute pour une exportation.

Pour changer ces valeurs par défaut, modifiez les paramètres correspondants du registre.

Pour les règles :
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\9.0\Controller\ScriptSupport\DefaultScriptTimeout

Pour une exportation :
HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\9.0\Controller\ScriptSupport\ExportScriptTimeout

Ces valeurs enregistrées dans le registre sont exprimées en millisecondes. Si un script a besoin de plus de temps pour s'exécuter que le délai prévu, il s'arrête. En ce qui concerne les règles, un message d'erreur est retourné « Expiration de l'exécution des scripts ». Pour une exportation, un message similaire s'affiche dans la fenêtre de lot, dans la colonne Notes de traitement.

Utilisation de scripts pour créer des règles
Utilisation de scripts pour décrire l'exportation
Migration des règles de FormReader 6.5 et exportation vers des scripts FlexiCapture 9.0


Utilisation de scripts pour créer des règles

Les règles reposant sur des scripts (ScriptRules) permettent aux utilisateurs de créer des algorithmes personnalisés complexes pour la validation et la normalisation de documents, avec les langages de script JScript® et VBScript standard.

Remarque : il se peut que certains scripts créés à l'aide de la première version d'ABBYY FlexiCapture ne fonctionnent pas avec la seconde version, car l'utilisation de valeurs de champ a été généralisée dans la seconde version, alors que des valeurs de texte étaient utilisées dans la première. Pour résoudre le problème, vous pouvez a) passer de la propriété Value à Text pour les scripts fonctionnant avec le texte d'un champ ou b) modifier l'utilisation de la propriété Value de telle sorte qu'elle soit conforme à sa description actuelle. Consultez les Propriétés de l'objet champ.

Les scripts de remplacement automatique et de contrôle de l'intégrité des lots sont également décrits dans cette section.

Modèle d'objets

Une règle doit être considérée comme une méthode d'une unité de document validée. En d'autres termes, la référence « this » ou « Me » fait référence à l'objet [Validated Document Unit] auquel cette règle s'applique actuellement.

Une règle peut valider un document à partir des valeurs d'un ou de plusieurs champs. Si une erreur est générée, il faut définir un indicateur d'erreur et, si nécessaire, spécifier la description de l'erreur, le champ qui a le focus et les variantes de remplacement proposées. Une règle peut également marquer un certain champ comme reconnu avec certitude.

Une règle peut normaliser un document en modifiant les valeurs de ses champs afin de leur donner une apparence normale, ou en ajoutant des informations (par exemple, la date du dernier traitement).

Validated document unit

Propriétés :

Nom | Type | Accès | Description
CheckSucceeded | Booléen | Lecture/écriture | Indicateur d'erreur. True – il n'y a pas d'erreur de règle, False – il y a une erreur de règle
ErrorMessage | chaîne | Lecture/écriture | Message d'erreur
FocusedField | [Field] | Lecture/écriture | Champ du focus
Field("AliasName") [Field] Lecture seule Champ comportant l'alias AliasName

Un alias est un nom spécial attribué à un champ et utilisé lors de l’accès au champ à partir du code d’une règle. Ainsi, renommer un champ n'aura aucune incidence sur l'utilisation du champ dans le code de la règle.

Les alias vous permettent également d’utiliser des champs de règle portant des noms identiques (par exemple, des champs portant le même nom issus de différentes sections).

Un alias peut être identique ou différent du nom du champ.

Lorsque vous ajoutez un champ à une règle, un alias est automatiquement généré pour ce champ. Vous pouvez, cependant, modifier les alias générés par le programme.

Fields | [Collection of fields] | Lecture seule | Un ensemble de champs impliqués dans la règle
Document | [Document] | Lecture seule | Un document contenant une unité validée
IsModuleAllowedByLicense | Booléen | Lecture seule | Vérifie si le module est accessible en fonction des paramètres de licence. Paramètres: ID de l'auteur, ID du module (chaînes).

Quand le document validé est un champ, il prend en charge toutes les propriétés et méthodes appartenant à l'objet [Field]. Si l'unité validée n'est pas un champ, il n'est pas possible de faire référence à ces propriétés et méthodes, car cela provoquerait une erreur.

Field

Propriétés :

Nom | Type | Accès | Description
Value Variable Lecture/écriture Valeur généralisée du champ.

Contient un nombre à virgule flottante pour les champs numériques.

Contient la valeur de la date (VT_DATE) pour les champs « Date/Heure ».

Contient la valeur de la date (VT_CY) pour les champs « Devise ».

Contient une valeur booléenne pour les coches. Lors de l'attribution des valeurs à une coche, vous pouvez utiliser à la fois la valeur booléenne true/false et les valeurs texte « True »/« False » (sensibles à la casse).
La valeur d'un groupe de coches est une liste des noms des coches sélectionnées séparées par un point-virgule (;). Si aucune coche n'a été sélectionnée, la chaîne est vide. Pour changer la valeur d'un groupe de coches, affectez la valeur « true » aux coches que vous avez besoin de sélectionner et « false » à celles que vous n'avez pas besoin de sélectionner. Dans le même temps, toutes ces coches doivent être incluses dans la règle.
Pour les groupes, tableaux et images graphiques – une chaîne vide.
Il n'est pas possible d'affecter des valeurs à des groupes, à des groupes de coches ou à des tableaux. Sinon, une erreur se produit.

Text chaîne Lecture/écriture La valeur texte d'un champ. Coïncide avec Value pour tous les types de champs excepté Coches.
En cas de coches, la valeur de cette propriété est déterminée en fonction des propriétés de champ sélectionnées dans l'onglet Type de données .
Important ! La valeur de la propriété Text ne change pas quand la règle est appliquée. En d'autres termes, le fait de changer la propriété Value dans le code de la règle ne change pas simultanément la propriété Text.
Dans l'exemple ci-dessous, les valeurs de oldText et de newText restent identiques :

Dim oldText, newText
oldText = me.Field("FieldName").Text
me.Field("FieldName").Value = newValue
newText = me.Field("FieldName").Text

Name | chaîne | Lecture seule | Nom du champ
IsVerified Booléen Lecture/écriture Un indicateur affichant si le champ a été vérifié ou pas. Un champ signalé comme vérifié est ignoré pendant la vérification et lors du comptage des caractères pour lesquels la vérification est requise.

Cette propriété est définie sur True si l'utilisateur a confirmé le champ pendant la vérification ou si une règle a défini la valeur de la propriété comme étant True.

Dans le cas contraire, la valeur de la propriété est False.

IsCertain Booléen Lecture/écriture Indicateur de certitude du champ. Un champ marqué comme reconnu avec certitude est ignoré pendant la vérification et le calcul des caractères qui doivent être vérifiés.

Cette propriété est obsolète et n’a été conservée que pour garantir la rétrocompatibilité. Veuillez plutôt utiliser la propriété IsVerified.

IsMatched | Booléen | Lecture seule | Un indicateur affichant si un champ correspond ou pas.
Items | [Collection of fields] | Lecture seule | En cas de champ multiple un ensemble de ses instances. Si un champ n'est pas multiple –0.
IsValid | Booléen | Lecture seule | Indicateur qui affiche si la valeur du champ est valide.
SuspiciousSymbols | chaîne | Lecture seule | Une chaîne de 1 et de 0 où les 1 correspondent aux éléments mal reconnus. Une chaîne d'un caractère est retournée pour les coches..
IsVerified | Booléen | Lecture/écriture | Indicateur qui affiche si le champ a été vérifié.
Regions | [Collection of regions] | Lecture seule | Ensemble de régions de champs.

Méthodes :

Nom | Paramètres | Description
Suggest( text ) | Variable | Ajoute une suggestion de valeur de champ. Pour définir plusieurs variantes, invoquez de manière séquentielle la méthode le nombre de fois requis. La valeur de la suggestion que vous ajoutez doit correspondre au type de champ (c'est-à-dire qu'il doit s'agir d'un nombre pour les champs numériques, d'une date pour les champs « Date/Heure », etc.).

Collection of regions

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre de régions de l'ensemble
Item(index) | [Region] | Lecture seule | Région portant l'index index. index prend des valeurs comprises entre 0 et Count – 1

Region

Propriétés :

Nom | Type | Accès | Description
PageIndex | Entier | Lecture seule | L'index de la page sur laquelle cette région se situe.
Rects | [Collection of rectangles] | Lecture seule | L'ensemble de rectangles constituant la région. Ne contient qu'un rectangle en cas de région rectangulaire.
SurroundingRect | [Rectangle] | Lecture seule | Rectangle entourant la région.
Image | IPicture | Lecture seule | L'image de cette région.

Collection of fields

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre de champs d'un ensemble
Item(index) | [Field] | Lecture seule | Champ d'index. Index peut avoir une valeur comprise entre 0 et Count – 1

Document

Méthodes :

Nom | Paramètres | Description
Pages | [Collection of pages] | Ensemble de pages de document.
Property( name ) | name – property name | Retourne la valeur de la propriété demandée. Type de la valeur retournée – variant

Propriétés de document pouvant être définies à l'aide de la méthode Property (les propriétés de document que cette méthode récupère sont en lecture seule) :

Valeur | Type | Description
"TemplateName" | Chaîne | Nom de la définition de document
"TotalSymbolsCount" | Entier | Nombre de caractères
"UncertainSymbolsCount" | Entier | Nombre de caractères reconnus sans certitude
"RecognizedSymbolsCount" | Entier | Nombre de caractères reconnus
"Comment" | Chaîne | Commentaire
"Created" | Date | Créé le
"CreatedBy" | Chaîne | Créé par
"Recognized" | Date | Reconnu le
"RecognizedBy" | Chaîne | Reconnu par
"Modified" | Date | Dernière modification
"ModifiedBy" | Chaîne | Modifié par
"ProcessingErrors" | Chaîne | Erreurs
"ProcessingWarnings" | Chaîne | Avertissements

Page

Nom | Type | Accès | Description
ImageSource | chaîne | Lecture seule | Nom de la source d'image (nom de fichier, nom du profil de numérisation).
ImageSourceType | chaîne | Lecture seule | Une chaîne décrivant le type de la source d'image. Valeurs possibles : Fichier, Scanner, personnalisée ou vide.
ImageSourcePageNumber | Entier | Lecture seule | Le numéro de la page dans le fichier source.

Vérification du format et remplacement automatique en utilisant un script

Modèle d'objet

Les références This ou Me pointent vers l'objet à vérifier et auquel le script est appliqué.

Le script vous permet de vérifier la valeur d'un champ et de la modifier si nécessaire. Vous pouvez également spécifier un message d'erreur.

Objet à vérifier

Propriétés :

Nom | Type | Accès | Description
Text | chaîne | Lecture/écriture | La chaîne contenant la valeur du champ.
SuspiciousSymbols | chaîne | Lecture seule | Une chaîne de 1 et de 0 où les 1 correspondent aux éléments mal reconnus. Une chaîne d'un caractère est retournée pour les coches..
ErrorMessage | chaîne | Lecture/écriture | Message d'erreur.

Vérification de l'intégrité des lots

Modèle d'objet

Les références This ou Me pointent vers l'objet à vérifier et auquel le script est appliqué. L'objet contient le lot et les résultats du traitement.

Le script vous permet de vérifier l'intégrité du lot et de retourner le résultat. Si nécessaire, un message d'erreur peut être créé.

Pour un document, les informations générales concernant le document sont suffisantes. Aucune donnée concernant ses éléments n'est requise. Cependant, les données concernant les champs clé sont également disponibles (tout comme pour l'exportation). Par conséquent, s'il vous faut utiliser une valeur de champ dans une vérification d'intégrité, le champ doit être un champ clé.

Objet à vérifier

Propriétés :

Nom | Type | Accès | Description
Batch | [Batch] | Lecture seule | Lot à vérifier.
CheckSucceeded | Booléen | Lecture/écriture | Le résultat de la vérification d'intégrité du lot.
ErrorMessage | chaîne | Lecture/écriture | Message d'erreur.

Lot

Propriétés :

Nom | Type | Accès | Description
BatchTypeName | chaîne | Lecture seule | Nom du type de lot
Documents | [Collection of documents] | Lecture seule | Documents du lot. Pour un document, les informations générales concernant le document sont suffisantes. Aucune donnée concernant ses éléments (champs, pages) n'est requise. Cependant, les données concernant les champs clé sont également disponibles
RegistrationProperties | [Ensemble des paramètres d’enregistrement] | Lecture seule | Les paramètres d’enregistrement du lot.
RegistrationProperty (Name) | chaîne | Lecture seule | La valeur du paramètre d'enregistrement de lot portant le nom Name.

Page

Propriétés :

Nom | Type | Accès | Description
TemplateName | chaîne | Lecture seule | Nom de section
ImageSourceType | chaîne | Lecture seule | Le type de la source d'image. Peut prendre la valeur File ou Scanner
ImageSource | chaîne | Lecture seule | Source d'image Dans le cas d'un fichier, il s'agit du nom du fichier avec le chemin d'accès complet du fichier. Dans le cas d'un scanner, il s'agit du nom du scanner.
ImageSourcePageNumber | Entier | Lecture seule | Le numéro de la page dans le fichier source.

Ensemble de documents

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Le nombre de documents de l'ensemble
Item(index) | [Exported Document] | Lecture seule | Le document portant l'index index. index prend les valeurs comprises entre 0 et Count – 1

Document

Propriétés :

Nom | Type | Accès | Description
IsAssembled | Booléen | Lecture seule | L’indicateur permet de savoir si le document a été assemblé ou non
IsVerified | Booléen | Lecture seule | L’indicateur permet de savoir si le document a été vérifié ou non
IsExported | Booléen | Lecture seule | L’indicateur permet de savoir si le document a été exporté ou non
TemplateName | Chaîne | Lecture seule | Nom de la définition de document
ProcessingErrors | Chaîne | Lecture seule | Message textuel pour les erreurs de traitement
ProcessingWarnings | Chaîne | Lecture seule | Conseils ou avertissements envoyés à l’utilisateur pendant le traitement
TotalSymbolsCount | Chaîne | Lecture seule | Nombre total de caractères (sans les caractères reconnus, inclut les caractères ajoutés par l’utilisateur et les règles)
RecognizedSymbolsCount | Chaîne | Lecture seule | Nombre de caractères reconnus
UncertainSymbolsCount | Chaîne | Lecture seule | Nombre de caractères reconnus sans certitude
Id | Chaîne | Lecture seule | Identificateur de document
BatchName | Chaîne | Lecture seule | Nom du lot
Field(Nom_du_champ) | [Champ du document] | Lecture seule | Champ ayant pour nom Nom_du_champ. Il peut retourner aussi bien des champs que des sections. Nom_du_champ est le nom du champ avec le chemin d’accès complet (à partir de la section). Exemple : "Section 1\Groupe\Champ 1" Important : Au cas où un composant du chemin d’accès au champ existe en plusieurs exemplaires, l’index de ce composant doit être spécifié. Par exemple, pour un groupe multiple, la chaîne susmentionnée se présente comme suit : "Section 1\Groupe[index]\Champ 1" l’index peut prendre une valeur allant de 0 jusque Count-1, Count étant le nombre de copies de composants multiples. Une exception apparaît lorsqu’un nom utilisé n’est pas correct.
HasField (Nom_du_champ) | Booléen | Lecture seule | Vérification de l’existence du champ Nom_du_champ.
Children | [Ensemble des champs de document] | Lecture seule | Ensemble des sections de document
Pages | [Ensemble de pages] | Lecture seule | Ensemble de pages de document
RegistrationProperties | [Ensemble des propriétés d’enregistrement] | Lecture seule | Ensemble des propriétés d’enregistrement de document
Action | [Résultats de travail] | Lecture seule | Objet spécial comportant des informations sur les résultats de l’exportation. Les informations sont écrites dans cet objet pendant l’exportation. Pendant le traitement post-exportation, ces informations peuvent être utilisées lorsque nécessaire.
IndexedItemValue (Nom) | [Champ du document] | Lecture seule | Champ d’index ayant le nom Nom. Nom peut être un champ de nom ayant un chemin d’accès complet (à partir de la section). Exemple : "Section 1\Groupe\Champ 1"
IsModuleAllowedByLicense (AuthorID, ModuleID) | Booléen | Lecture seule | Vérification de la disponibilité du module (selon les paramètres de la licence :identificateur de l’auteur, identificateur de module (chaîne).

Ensemble des paramètres d’enregistrement

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre de paramètres de l’ensemble
Item(index) | [Paramètre d’enregistrement] | Lecture seule | Le paramètre avec l’index index. index peut prendre une valeur comprise entre 0 et Count – 1

Paramètre d’enregistrement

Propriétés :

Nom | Type | Accès | Description
Name | Chaîne | Lecture seule | Nom du paramètre d’enregistrement
Value | Chaîne | Lecture seule | Valeur du paramètre d’enregistrement

Exemples de scripts permettant de créer des règles utilisateur


Exemples de scripts permettant de créer des règles personnalisées

Règle d'automatisation

Cet exemple montre comment contrôler les données d'un tableau. Cette règle vérifie si les données du tableau correspondant à la valeur du champ qui en résulte. Le tableau contient des colonnes avec des prix et des quantités pour certains produits. La règle a été écrite au niveau d'une section contenant le tableau et le champ qui en résulte.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Code d'un composant ActiveX

Le code fourni ici est un code de classe CheckDoc issu du projet AutomationRule, qui est utilisé dans les scripts mentionnés ci-dessus.

Option Explicit

' Vérifier si les données du tableau correspondent au résultat

' column1 - colonne de prix

' column2 - colonne de quantité

' resultField - champs qui en résulte (<Total> ou équivalent )

' docObj - nœud de document en cours de vérification

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' Somme des données du tableau

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' Précision de la comparaison – résultat arrondi au deuxième chiffre après la virgule

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Le tableau de données ne correspond pas à la valeur du résultat"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Recherche dans la liste de variantes

Le code de la règle ci-dessous vérifie si la valeur du champ correspond à l'une des valeurs de la liste. S'il n'y a pas de correspondance, un indicateur d'erreur apparaît et le champ reçoit une liste de valeurs suggérées. En fonction du résultat de la vérification, le champ est marqué comme reconnu avec ou sans certitude.

[VBScript]

'Mémoriser la valeur du champ

Dim fieldValue

fieldValue = me.Field("Field6").Value

'Créer la liste des valeurs à vérifier

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

'Vérifier si la valeur d'un champ correspond aux valeurs de la liste

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

'En fonction du résultat de la vérification, définir le niveau de certitude correspondant pour le champ

me.Field("Field6").IsCertain = success

'remplir la liste de suggestions pour le champ – une suggestion peut être l'une des

'valeurs adaptées

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

'Placer un indicateur d'erreur

me.CheckSucceeded = success

[JScript]

// Mémoriser la valeur du champ

var fieldValue = Field("Field6").Value;

// Créer la liste des valeurs à vérifier

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// Faire correspondre la valeur du champ aux valeurs de la liste

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// En fonction du résultat de la vérification, définir le niveau de certitude correspondant pour le champ

Field("Field6").IsCertain = success;

// Remplir la liste de suggestions pour le champ – une suggestion peut être l'une des

// valeurs adaptées

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// Placer un indicateur d'erreur

CheckSucceeded = success;

Vérification de la correspondance de champ

Le code de la règle ci-dessous vérifie si le champ vérifié correspond.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Aucune correspondance trouvée pour le champ InvoiceNumber"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Aucune correspondance trouvée pour le champ InvoiceNumber";

}

Vérification d'une coche

Le code de la règle ci-dessous vérifie si la coche a été sélectionnée ou non

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "L'état de la page n'est pas vérifié"

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "L'état de la page n'est pas vérifié";

}

Vérification d'un groupe de coches

Le code de la règle ci-dessous effectue une itération au sein de l'ensemble des coches du groupe et, si aucune n'est sélectionnée, sélectionne la première. La règle est écrite pour intervenir au niveau du groupe de coches. Toutes les coches du groupe ont été ajoutées à la liste des champs inclus dans la règle. Pour la coche par défaut (la première), l'indicateur Readonly a été désactivé. S'il n'y a pas de coches dans le groupe, un indicateur d'erreur est activé.

Cet exemple de code effectue une itération au sein de tous les champs inclus dans la règle. Comme les noms de champs ne sont pas spécifiés dans le code, ce code ne peut pas être utilisé pour un groupe de coches.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "Aucune coche dans le groupe"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "Aucune coche dans le groupe";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}

Contrôle de la fiabilité du champ
Le code de règle fourni ci-dessous contrôle le nombre de caractères incertains d'un champ et efface le champ si le nombre de caractères incertains est supérieur ou égal à trois. Ceci est un script de correction automatique.

[VBScript]

dim susp, qty, strpos, i, SC, strposPrev

strposPrev = 0

qty = 0

SC = "1"

susp = me.SuspiciousSymbols

for i = 1 to len (susp)

strpos = InStr (i, susp, SC,1)

if strpos <> strposPrev and strpos <> 0 then

qty = qty + 1

strposPrev = strpos

end if

next

if qty >= 3 then

me.text = ""

end if

Vérification de l'intégrité des lots
Vérifie si le nombre de documents spécifié sur la page de contrôle coïncide avec l'inventaire du lot et avec le nombre de documents réellement traités. Si les nombres ne correspondent pas, une erreur est retournée.

[VBScript]

dim DQty

dim i

for i = 0 to me.Batch.Documents.Count - 1

if me.Batch.Documents.Item(i).TemplateName = "Inv" then

DQty = me.Batch.Documents.Item(i).IndexedItemValue("DocQty")

exit for

end if

next

dim AcQty

AcQty = me.Batch.Documents.Count

if acqty <> DQty then

me.CheckSucceeded = false

me.ErrorMessage = "Nombre de documents présent dans le lot incorrect :" & " " & AcQty& ". " & "Nombre attendu :" & " " & DQty & "!"

end if


Utilisation de scripts pour décrire une exportation

Modèle d'objet

Ce modèle est utilisé dans les scripts d'exportation et dans les scripts de gestionnaire d'exportation.

Un gestionnaire d'exportation est un script spécial exécuté à la fin de l'exportation (à condition que l'option Exécuter un script après l'exportation soit sélectionnée dans l'onglet Exportation de la boîte de dialogue des propriétés du projet et que le corps du script ne soit pas vide).

L'exportation doit être considérée comme une méthode d'un document exportable. Cela signifie que la référence « this » ou « Me » désigne l'objet [Exportable document] en cours d'exportation.

Dans un gestionnaire d'exportation, le pointeur this ou Me indique un objet de type [Export results].

Il est impossible de modifier les valeurs des champs pendant l'exportation.

Lot

Propriétés :

Nom | Type | Accès | Description
BatchTypeName | Chaîne | Lecture seule | Nom du type de lot.
Documents | [Ensemble de documents] | Lecture seule | Les documents faisant partie du lot. Seules des informations générales sur le document sont disponibles, sans aucune information concernant ses éléments (champs, pages). Toutefois, les informations sur les champs clés sont disponibles.
RegistrationProperties | [Ensemble des paramètres d’enregistrement] | Lecture seule | Les paramètres d’enregistrement du lot.
RegistrationProperty (nom) | Chaîne | Lecture seule | La valeur du lot d’enregistrement avec le nom nom.

Exportable document

Propriétés :

Nom | Type | Accès | Description
IsAssembled | Booléen | Lecture seule | L'indicateur affiche si le document a été assemblé ou pas
IsVerified | Booléen | Lecture seule | L'indicateur affiche si le document a été vérifié ou pas
IsExported | Booléen | Lecture seule | L'indicateur affiche si le document a été exporté ou pas
TemplateName | chaîne | Lecture seule | Nom de la définition de document
ProcessingErrors | chaîne | Lecture seule | Message d'erreur de traitement
ProcessingWarnings | chaîne | Lecture seule | Suggestions et/ou avertissements affichés pendant le traitement
TotalSymbolsCount | Entier | Lecture seule | Nombre total de caractères (inclut également les caractères ajoutés par l'utilisateur et par les règles en plus des caractères reconnus)
RecognizedSymbolsCount | Entier | Lecture seule | Nombre de caractères reconnus
UncertainSymbolsCount | Entier | Lecture seule | Nombre de caractères reconnus sans certitude
Id | chaîne | Lecture seule | Identifiant de document
BatchName | chaîne | Lecture seule | Nom de lot
Field(FieldName) | [Document Unit] | Lecture seule | Unité comportant le nom FieldName. Peut retourner un champ ou une section. FieldName est le nom d'une unité, avec le chemin complet, commençant par la section. Par exemple : "Section 1\Group\Field 1" Important ! Si le chemin d'accès du champ comporte un composant multiple, vous devez fournir l'index de ce composant. Par exemple, pour un groupe multiple, le chemin d'accès ci-dessus se présente comme suit : "Section 1\Group[index]\Field 1" index suppose une valeur comprise entre 0 et Count-1, où Count est le nombre d'instances du composant multiple. En cas d'invocation par un nom non valide, une exception se produit.
HasField (FieldName) | Booléen | Lecture seule | Vérifie si le champ portant le nom FieldName existe.
Children | [Collection of document units] | Lecture seule | Ensemble de sections de documents
Pages | [Collection of pages] | Lecture seule | Ensemble de pages de documents
RegistrationProperties | [Ensemble des paramètres d’enregistrement] | Lecture seule | Les paramètres d’enregistrement du lot.
Action | [Operation result] | Lecture seule | Objet spécial contenant des informations sur le résultat de l'exportation. Le programme écrit les informations dans cet objet pendant l'exportation. Cette information peut être utilisée, au besoin, par le gestionnaire exécuté à la fin de l'exportation.
IndexedItemValue (Name) | [Field] | Lecture seule | Champ d'index portant le nom Name.
IsModuleAllowedByLicense (AuthorID, ModuleID) | Booléen | Lecture seule | Vérifie si le module est accessible en fonction des paramètres de licence. Paramètres : ID de l'auteur, ID du module (chaînes).

Méthodes :

Nom | Paramètres | Description
SaveAs (filename, imageSaveOptions) | fileName – le nom du fichier imageSaveOptions – Paramètres d'enregistrement d'images (facultatif) | Enregistre les images de toutes les pages du document dans un fichier.

Document unit

Un objet [Document unit] est une section ou un champ.

Propriétés :

Nom | Type | Accès | Description
Valeur Variable Lecture seule Valeur saisie du nœud.

Retourne un nombre à virgule flottante pour les champs numériques.

Retourne la valeur de la date (VT_DATE) pour les champs « Date/Heure ».

Retourne la valeur de la somme (VT_CY) pour les champs « Devise ».

Retourne une valeur booléenne pour les coches.

Pour des groupes de coches, retourne la liste des champs de coches sélectionnés ou une chaîne vide si aucun champ n'est sélectionné.

Pour une image, retourne l'objet [Picture].

Retourne zéro si le nœud n'a aucune valeur. Avant d'essayer de lire la valeur du nœud, vérifiez toujours si elle est nulle (consultez les exemples de scripts).

Essayer de lire une valeur nulle provoquera une erreur.

La valeur est nulle, par exemple, pour les sections, pour les champs de tableaux et pour les champs de groupes.

La valeur peut être nulle si le contenu du champ (texte reconnu ou saisi par l'utilisateur) ne correspond pas au type du champ.

Text chaîne Lecture seule Valeur du texte du nœud.

Retourne la valeur « Yes/No » pour les coches.

Pour des groupes de coches, retourne la liste des champs de coches sélectionnés ou une chaîne vide si aucun champ n'est sélectionné.

Retourne une chaîne vide pour tout nœud n'ayant aucune valeur (ex : image, groupe, section, etc.).

Name | chaîne | Lecture seule | Nom d'unité
IsExportable | Booléen | Lecture seule | Affiche si l'unité doit être exportée
SuspiciousSymbols chaîne Lecture seule

Une chaîne de 1 et de 0, où les 1 correspondent aux caractères incertains.

Pour les coches, une chaîne contenant un seul symbole est retournée.

Pour les unités sans valeur, une chaîne vide est retournée.
Children [Collection of document units] Lecture seule Ensemble d'unités subordonnées. S'il n'y a pas d'unités subordonnées – 0. –
Par exemple, un groupe, un groupe de coches et une ligne de tableau ont des unités subordonnées.
Items | [Collection of document units] | Lecture seule | En cas d'unité multiple – un ensemble de ses instances. Si une unité n'est pas multiple – 0.
Regions | [Collection of regions] | Lecture seule | L'ensemble des régions de champs.
Field(FieldName) [Document node] Lecture seule Un nœud portant le nom FieldName. Peut retourner un champ ou une section.
FieldName est le nom du nœud avec un chemin relatif (commence par le nœud en cours).

Important !

Si un composant du chemin est un multiple, spécifiez l'index de ce composant.

HasField (Name) | Booléen | Lecture seule | Indicateur qui affiche si un champ portant le nom Name existe dans le document.
IsIndexed | Booléen | Lecture seule | Indicateur qui affiche si le nœud est un champ d'index.

Picture

Il s'agit d'une image que vous pouvez enregistrer dans un fichier sur le disque.

Méthodes :

Nom | Paramètres | Description
SaveAs (filename, imageSaveOptions) | fileName – le nom du fichier imageSaveOptions – paramètres d'enregistrement d'images (facultatif) | Enregistre l'image du champ dans un fichier.

Collection of document units

Un objet [Collection of document units] est un ensemble de champs ou de sections.

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre d'unités d'un ensemble
Item(index) | [Unit] | Lecture seule | Instance d'unité. Les valeurs des index peuvent être comprises entre 0 et Count – 1

Collection of pages

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre de pages d'un ensemble
Item(index) | [Page] | Lecture seule | Page avec index. Les valeurs des index peuvent être comprises entre 0 et Count– 1

Page

Propriétés :

Nom | Type | Accès | Description
TemplateName | chaîne | Lecture seule | Nom de section
ImageSourceType | chaîne | Lecture seule | Le type de la source d'image. Peut prendre la valeur File ou Scanner
ImageSource | chaîne | Lecture seule | Source d'image Dans le cas d'un fichier, il s'agit du nom du fichier avec le chemin d'accès complet du fichier. Dans le cas d'un scanner, il s'agit du nom du scanner.
ImageSourcePageNumber | Entier | Lecture seule | Le numéro de la page dans le fichier source.
ExcludedFromDocumentImage | Booléen | Lecture/écriture | Un indicateur qui exclut la page de l'exportation. La valeur par défaut est false.

Méthodes :

Nom | Paramètres | Description
SaveAs (filename, imageSaveOptions) | fileName – filename imageSaveOptions –– options d'enregistrement de l'image (facultatives) | Enregistrez une image de page

Collection of regions

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Le nombre de régions de l'ensemble
Item(index) | [Region] | Lecture seule | Région avec l'index index. L'index peut prendre des valeurs comprises entre 0 et Count – 1

Region

Propriétés :

Nom | Type | Accès | Description
PageIndex | Entier | Lecture seule | L'index de la page sur laquelle la région spécifiée se situe.
Rects | [Collection of rectangles] | Lecture seule | L'ensemble de rectangles constituant la région. Dans le cas d'une région rectangulaire, la collection contient un seul rectangle.
SurroundingRect | [Rectangle] | Lecture seule | Le rectangle qui entoure la région.
Image | [Picture] | Lecture seule | Image graphique de la région donnée.
IsMatched | Booléen | Lecture seule | Affiche si le champ a été associé correctement.

Collection of rectangles

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Le nombre de rectangles de l'ensemble
Item(index) | [rectangle] | Lecture seule | Le rectangle portant l'index index. index prend les valeurs comprises entre 0 et Count – 1

Rectangle

Propriétés :

Nom | Type | Accès | Description
Left | Entier | Lecture seule | Coordonnée gauche du rectangle sur la page
Top | Entier | Lecture seule | Coordonnée supérieure du rectangle sur la page
Right | Entier | Lecture seule | Coordonnée droite du rectangle sur la page
Bottom | Entier | Lecture seule | Coordonnée inférieure du rectangle sur la page

ExportTools

Objet global utilisé pour récupérer un objet [Image save options]

Méthodes :

Nom | Paramètres | Description
NewImageSavingOptions |  | Crée un objet [Image save options]

Image save options

Options d'enregistrement d'images de page.

Propriétés :

Nom | Type | Accès | Description
Format | chaîne | Lecture/écriture | Format d'image. Peut prendre l'une des valeurs suivantes : « tif », « jpg », « bmp », « jpg2000 », « pcx », « png », « pdf », « pdf-s », « pdf-a », « pdf-a-s », « pdf-s-a ». Non sensible à la casse.
ColorType | chaîne | Lecture/écriture | Type de système de couleurs utilisé. Peut prendre l'une des valeurs suivantes : « FullColor », « GrayScale » et « BlackAndWhite" ». Non sensible à la casse.
Resolution | Entier | Lecture/écriture | Résolution d'image en ppp
Quality | Entier compris entre 1 et 100 | Lecture/écriture | La qualité de la compression JPEG (applicable uniquement aux formats pour lesquels la compression JPEG est utilisée).
ShouldOverwrite | Booléen | Lecture/écriture | Cet indicateur affiche s'il faut écraser le fichier existant lors de l'enregistrement. Si cet indicateur est réglé sur false, l'appel de la méthode Save engendre une erreur si un fichier portant le même nom existe déjà.

Results of operation

Contient des informations sur les résultats de l'exportation

Propriétés :

Nom | Type | Accès | Description
Succeeded | Booléen | Lecture/écriture | Contient true si l'exportation a réussi sinon false.
ErrorMessage | chaîne | Lecture/écriture | Un message d'erreur concernant une erreur qui s'est produite pendant l'exportation.
Result chaîne Lecture/écriture Une description formelle du résultat.

Contient le nom du fichier avec un chemin complet vers le fichier pour une exportation vers un fichier.
Contient le nom du tableau d'exportation principal pour une exportation vers une base de données.
Contient l'URL du document exporté pour une exportation vers SharePoint.

Name | chaîne | Lecture seule | Nom du profil d'exportation.
Type Entier Lecture seule Type des paramètres d'exportation(à utiliser dans les scripts de post-exportation). Les valeurs suivantes sont possibles :
  • ET_File=1, exportation vers un fichier
  • ET_DataBase=2, exportation vers une base de données
  • ET_Script, exportation basée sur un script
  • ET_SharePoint, exportation vers SharePoint;
  • ET_Unknown, type non spécifié (s'il y a des erreurs qui ne sont pas en rapport avec un profil d'exportation spécifique).

Export results

Propriétés :

Nom | Type | Accès | Description
Documents | [collection of exported documents] | Lecture seule | Un ensemble de documents exportés en une session d'exportation. Pour un document, les informations générales concernant le document sont suffisantes. Aucune donnée concernant ses éléments (champs, pages) n'est requise. Cependant, les données concernant les champs clé sont également disponibles.

Collection of exported documents

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Le nombre de documents de l'ensemble
Item(index) | [Exported Document] | Lecture seule | Le document portant l'index index. index prend les valeurs comprises entre 0 et Count – 1

Ensemble des paramètres d’enregistrement

Propriétés :

Nom | Type | Accès | Description
Count | Entier | Lecture seule | Nombre de paramètres de l’ensemble.
Item(index) | [Paramètre d’enregistrement] | Lecture seule | Le paramètre avec l’index index. index peut prendre une valeur comprise entre 0 et Count – 1.

Paramètre d’enregistrement

Propriétés :

Nom | Type | Accès | Description
Name | Chaîne | Lecture seule | Nom du paramètre d’enregistrement.
Value | Chaîne | Lecture seule | Valeur du paramètre d’enregistrement.

Exemples de scripts décrivant une exportation


Exemples de scripts décrivant une exportation

Récupération des valeurs de champ pendant une exportation
Cet exemple de code montre comment récupérer la valeur d'un champ pendant une exportation. Vous pouvez utiliser cette valeur pour nommer les fichiers dans lesquels les images ou les données sont exportées. S'il n'y a pas de champ de ce type dans le document, une erreur se produira.

Structure du document à exporter :

Section 1

Field1

…

Group1

Field2

…

…

FieldN

Section 2

Field1

…

FieldK

[VBScript]

Dim Field1Value, champ2Value

' Récupère la valeur de Field1 dans la Section 1

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Récupère la valeur de Field2 dans Group1 dans la Section 1

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Récupère la valeur de Field1 dans Section 1 si la section comporte plusieurs instances

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Récupère la valeur de Field1 dans Section 1

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Récupère la valeur de Field2 dans Group1, Section 1

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Récupère la valeur de Field1 dans Section 1 si la section comporte plusieurs instances

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Exportation d'images de page

Le code de cet exemple montre comment exporter des images de toutes les pages de document à l'aide du format de fichier, du système de couleurs et de la résolution requis. Les images sont enregistrées page par page. Chaque page est donc stockée dans un fichier distinct.

Les fichiers de cet exemple sont nommés « page1.tif », « page2.tif », etc. Vous pouvez modifier le mécanisme de dénomination de fichiers si nécessaire. Par exemple, vous pouvez créer les noms de fichiers à partir de la valeur d'un champ.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' Définir le nom et l'extension désirés pour le fichier, en fonction du format sélectionné

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // Définir le nom et l'extension désirés pour le fichier, en fonction du format sélectionné

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Exportation d'un tableau

Cet exemple montre comment exporter un tableau vers un fichier *.txt.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject" )

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Exportation d'un document quel que soit son niveau d'imbrication

Cet exemple présente la procédure d'exportation des champs d'un document quel que soit son niveau d'imbrication à l'aide de fonctions personnalisées à partir du module d'exportation général. Si vous avez besoin d'exporter des champs de document présentant une imbrication variable, utilisez plutôt un composant COM externe (voir l'exemple suivant)

Code d'exportation de base

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Code des fonctions du module d'exportation général

[VBScript]

' La procédure exécute l'exportation : création d'un dossier d'exportation et

' enregistrement dans ce dernier des fichiers d'images de page, du fichier texte contenant les champs du document

' et des informations relatives au document

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject" )

    ' création du dossier d'exportation

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Erreur lors de la création du dossier d'exportation : " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' exportation d'images

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Erreur lors de l'exportation d'images : " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' création du fichier texte

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' exportation des informations sur le document

    ExportDocInfo docObj, txtFile

    ' exportation des champs

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Erreur lors de l'exportation de données : " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Fonction d'exportation d'image.

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' spécificationdes paramètres d'exportation

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' exportation page par page

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pages

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Procédure d'exportation des informations sur le document

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Procédure d'exportation des champs à partir d'un ensemble de champs

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next

End Sub

' Vérifie que la valeur du champ est nulle

' Si la valeur du champ n'est pas valide, toute tentative d'accès à ce champ (y compris

' pour en vérifier la nullité) peut provoquer une exception

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Procédure d'exportation des champs

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' Enregistrement du nom du champ

    txtFile.Write (indent & field.Name)

    ' enregistrement de la valeur des champs accessibles

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("   " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' exportation des champs enfants

        ExportFields field.Children, txtFile, indent & "     "

    ElseIf Not field.Items Is Nothing Then

        ' exportation des instances de champ

        ExportFields field.Items, txtFile, indent & "     "

    End If

End Sub

' La fonction crée un dossier d'exportation et retourne le chemin d'accès complet de ce dossier

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderName

    ' Dossier principal

    exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' le dossier de la définition de document spécifiée

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End If

    ' le dossier du document exporté

    Dim i

    i = 1

    folderName = fso.BuildPath( docFolder, i )

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath( docFolder, i )

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// La fonction exécute l'exportation : création d'un dossier d'exportation et

// enregistrement dans ce dernier des fichiers d'images de page, du fichier texte contenant les champs du document

// et des informations relatives au document

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // création de dossiers d'exportation

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Erreur lors de la création du dossier d'exportation : " + e.description;

        return;

    }

    // exportation d'images

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Erreur lors de l'exportation d'images : " + e.description;

        return;

    }

    // création du fichier texte

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile( fileName, true );

    // exportation des informations sur le document

    ExportDocInfo( docObj, txtFile);

    // exportation des champs

    txtFile.WriteLine( "Fields:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Erreur lors de l'exportation de données : " + e.description;

        txtFile.Close();

        return;

    }

    txtFile.Close();

    txtFile= 0;

    fso= 0;

}

// Fonction d'exportation d'image.

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // spécification des paramètres d'exportation

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // exportation page par page

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Procédure d'exportation des informations sur le document

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Procédure d'exportation des champs à partir d'un ensemble de champs

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Vérifie que la valeur du champ est nulle

// Si la valeur du champ n'est pas valide, toute tentative d'accès à ce champ (y compris

// pour en vérifier la nullité) peut provoquer une exception

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Procédure d'exportation des champs

function ExportField(field, txtFile, indent)

{

    // enregistrement du nom du champ

    txtFile.Write(indent + field.Name);

    // enregistrement de la valeur des champs accessibles

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // exportation des champs enfants

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // exportation des instances de champ

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// La fonction crée un dossier d'exportation et retourne le chemin d'accès complet de ce dossier

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // dossier principal

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // le dossier de la définition de document spécifiée

    docFolder = fso.BuildPath(exportFolder, templateName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder);

    }

    // le dossier du document exporté

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder( folderName );

    return folderName;

}

Utilisation d'un composant COM externe

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Code d'un composant ActiveX dans VisualBasic

Vous trouverez ci-dessous un code de classe Exporter tiré du projet AutomationExport, qui est utilisé dans les scripts ci-dessus.

OptionExplicit

DimmFso As New Scripting.FileSystemObject

' La procédure exécute l'exportation du document : création d'un dossier d'exportation et

' enregistrement dans ce dernier des fichiers d'images de page, du fichier texte contenant les champs du document

' et des informations relatives au document

PublicSub Export(ByRef docObj As Object, ByRef exportTools As Object)

OnError GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' création du dossier d'exportation

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Impossible de créer le dossier d'exportation"

        ExitSub

    End If

    ' exportation d'images

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' création du fichier texte

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' enregistrement des informations sur les problèmes d'exportation des images

    If imageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' exportation des informations sur le document

    exportDocInfo docObj, txtFile

    ' exportation des champs

    txtFile.WriteLine "Fields:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Erreur lors de l'exportation des données"

    End If

    txtFile.Close

    ' si des erreurs surviennent pendant l'exportation, réinitialisez

    ' l'indicateur de réussite de l'exportation sur False

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

ExitSub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

EndSub

' Fonction d'exportation d'image. Si une erreur se produit pendant l'exportation d'images,

' renvoie un message relatif à l'erreur, sinon renvoie une chaîne une vide

PrivateFunction exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

OnError GoTo err_h

    Dim pages As Objectpage As Object imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' spécification des paramètres d'exportation

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' Exportation page par page

     Setpages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

ExitFunction

err_h:

    exportImages = Err.Description

EndFunction

' Procédure d'exportation des informations sur le document

PrivateSub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

OnError GoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

ExitSub

err_h:

    txtFile.WriteLine Err.Description

EndSub

' Procédure d'exportation des champs à partir d'un ensemble de champs

PrivateFunction exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim curField As Object

    exportFields = True

    For Each curField In champs

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

        End If

    Next curField

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

EndFunction

' Vérifie que la valeur du champ est nulle

' Si la valeur du champ n'est pas valide, toute tentative d'accès à ce champ (y compris

' pour en vérifier la nullité) peut provoquer une exception

FunctionIsNullFieldValue(ByRef field As Object) As Boolean

OnError GoTo err_h

    IsNullFieldValue = IsNull(field.Value)

ExitFunction

err_h:

    IsNullFieldValue = True

EndFunction

' Fonction d'exportation de champ

PrivateFunction exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

OnError GoTo err_h

    Dim result As Boolean

    result = True

    ' Enregistrement du nom du champ

    txtFile.Write (indent & field.Name)

    ' enregistrement de la valeur des champs accessibles

    IfNot IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' exportation des champs enfants

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' exportation des instances de champ

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

ExitFunction

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

EndFunction

' La fonction crée un dossier d'exportation et retourne le chemin d'accès complet de ce dossier

PrivateFunction createExportFolder(ByVal templateName As String) As String

OnError GoTo err_h

    Dim docFolder As String, folderName As String

    ' Dossier principal

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' le dossier de la définition de document spécifiée

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' dossier du document exporté

    Dim i As Long

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

ExitFunction

err_h:

    createExportFolder = ""

EndFunction

Utilisation d'un composant externe rédigé en .Net( C# )

Pour utiliser un composant externe rédigé en .Net, procédez comme suit :

  1. Créez un projet du type ClassLibrary
  2. Ajoutez Controller.dll aux références du projet - FlexiCaptureScriptingObjects apparaît dans la liste Références et toutes les interfaces des objets de script sont désormais disponibles dans le projet.
  3. Définissez l'interface disp et la classe implémentant cette interface, ainsi que ProgId (afin de pouvoir utiliser le composant .Net comme ActiveX à partir du code du script).
  4. Une fois le projet créé, enregistrez la bibliothèque de types générés (activez l'option correspondante dans les propriétés du projet pour exécuter cette opération automatiquement).
  5. À partir du code d'exportation, appelez la méthode du composant suivant la procédure habituelle :

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

Le code d'un tel composant est illustré ci-dessous :

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// Interface du composant d'exportation accessible à partir du script

// Lors de la création d'un nouveau composant, générez un nouveau GUID

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// Classe implémentant la fonctionnalité du composant d'exportation

// Lors de la création d'un nouveau composant, générez un nouveau GUID

// et définissez votre ProgId

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// La fonction exécute l'exportation du document : création d'un dossier d'exportation et

// l'enregistrement dans ce dernier des fichiers d'images de page,

//du fichier texte contenant les champs du document et des informations relatives au document

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// création du fichier texte

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// exportation des informations sur le document

exportDocInfo( docRef, sw );

// exportation des champs

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// La fonction crée un dossier d'exportation et retourne le chemin d'accès complet de ce dossier

privatestring createExportFolder( string templateName )

{

string docFolder, folderName;

// dossier principal

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// le dossier de la définition de document spécifiée

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// dossier du document exporté

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

returnfolderName;

}

// Fonction d'exportation d'image.

privatevoid exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions(); ;

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Exportation des informations sur le document

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Exportation d'un ensemble de champs

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Vérifie que la valeur du champ est nulle

// Si la valeur du champ n'est pas valide, toute tentative d'accès à ce champ (y compris

// pour en vérifier la nullité) peut provoquer une exception

privatebool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// Exportation du champ spécifié

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// enregistrement du nom des champs

sw.Write( indent + field.Name );

//enregistrement de la valeur des champs accessibles

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// exportation des champs enfants

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// exportation des instances de champ

exportFields( field.Items, sw, indent + " " );

}

}

}

}
Gestionnaire d'exportation
Cet exemple de code présente un gestionnaire de code simple qui permet d'enregistrer les informations sur les documents exportées et d'exporter les résultats dans des fichiers texte. Deux fichiers texte sont utilisés dans cet exemple : l'un contient la liste des documents exportés avec succès et l'autre la liste des documents pour lesquels des erreurs ont été retournées pendant l'exportation.

[VBScript]

dimcurDoc

dimfso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

setfso = CreateObject("Scripting.FileSystemObject")

' création du fichier pour les documents dont l'exportation a échoué

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

settxtErrorFile = fso.CreateTextFile( fileErrorName, true )

' création du fichier pour les documents dont l'exportation a réussi

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

settxtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

DimdocInfo

' itération de l'ensemble de documents exportés

foreach curDoc in me.Documents

    docInfo = "DocumentId:" & curDoc.Id

    if curDoc.Action.Succeeded then

        docInfo = docInfo & ". Exportation réussie. Résultat:" & curDoc.Action.Result

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & ". Export error: " & curDoc.Action.ErrorMessage & "  Result:" & curDoc.Action.Result

        txtErrorFile.WriteLine docInfo

    end if

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

varfso = new ActiveXObject("Scripting.FileSystemObject");

// création des fichiers pour les documents dont l'exportation a échoué

varfileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

vartxtErrorFile = fso.CreateTextFile( fileErrorName, true );

// création du fichier pour les documents dont l'exportation a réussi

varfileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

vartxtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

vari

// itération de l'ensemble de documents exportés

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Exportation réussie. Résultat:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Export error: " + curDoc.Action.ErrorMessage + "  Result:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Migration des règles FormReader 6.5 et exportation vers des scripts FlexiCapture 9.0

Migration des règles FormReader aux règles de script FlexiCapture

Règles If-Then

Changements dans les fonctions et méthodes :

  1. Error(champ, message). Au lieu de cette fonction, utilisez une combinaison des propriétés suivantes de l'unité à vérifier : CheckSucceeded, ErrorMessage et FocusedField.

    Par exemple, ce code FormReader 6.5

    if [City].IsEmpty() then Error( [City] , "le nom de la ville doit être indiqué")

    doit être changé en

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "le nom de la ville doit être indiqué"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "le nom de la ville doit être indiqué";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Opérations sur des chaînes. La section ci-dessous répertorie les instructions permettant de réaliser dans FlexiCapture 9,0 les opérations de chaîne qui étaient disponibles avec les règles If-Then.

    [VBScript]

    .Length() – Utilisez la fonction analogue Len(string)

    .CmpNoCase(str) – Pour les comparaisons de chaînes non sensibles à la casse, utilisez la fonction LCase(string) ou UCase(string)

    .Mid(position, count) – Utilisez la fonction analogue Mid(string, pos, count)

    [JScript]

    .Length() – Utilisez la propriété length analogue de la variable de type chaîne

    .CmpNoCase(str) – Pour les comparaisons de chaînes non sensibles à la casse, utilisez la fonction LCase(string) ou UCase(string)

    .Mid(position, count) – Utilisez les méthodes analogues substr(start, [length]) de la variable de type chaîne

  3. Opérations sur des nombres réels.

    [VBScript]

    Floor(d), Ceil(d) – Il n'existe pas d'équivalents prêts à l'emploi en VBScript, mais vous pouvez créer votre propre implémentation si nécessaire

    Round(d),Round(d, i) – Utilisez la fonction analogue Round(d, [i])

    [JScript]

    Floor(d), Ceil(d) – Utilisez les méthodes floor(d) et ceil(d) de l'objet Math

    Round(d) – Utilisez les méthodes round(d) de l'objet Math

    Round(d, i) – Il n'existe pas d'équivalent prêt à l'emploi en JScript, mais vous pouvez créer votre propre implémentation si nécessaire

  4. Opérations sur des champs de texte

    IsEmpty() – Comparez la valeur du texte du champ Field("fieldName").Text avec une chaîne vide

    Text() – Utilisez Field("fieldName").Text

    Length() – Récupérez la valeur du texte du champ puis déterminez la longueur de la chaîne qui en résulte comme décrit à l'étape 2 ci-dessus

    SetText(text) – Utilisez Field("fieldName").Text = text

  5. Opérations sur des coches

    IsValid() – Vous pouvez utiliser la propriété IsVerified

    Value() –Field("fieldName").Value retourne maintenant une valeur booléenne, et non 0 ou 1 comme dans FormReader 6.5

    SetValue(newValue) – Utilisez Field("fieldName").Value = newValue

  6. Opérations sur des groupes de coches

    IsValid() – Vous pouvez utiliser la propriété IsVerified pour déterminer la certitude d'un champ dans un groupe. Pour déterminer combien de cases à cocher ont été sélectionnées, réalisez une itération au sein des coches du groupe, comme dans l'exemple « Contrôle d'un groupe de coches » (consultez la section Exemples de scripts permettant de créer des règles personnalisées).

    Value() – Pour récupérer le numéro de la coche sélectionnée, vous pouvez utiliser l'une des deux méthodes ci-dessous :

    1. Attribuez des noms numérotés aux coches du groupe : 0, 1, etc. Ensuite, Field("groupName").Value contiendra le numéro de la coche sélectionnée, ou la liste de numéros (plusieurs coches sélectionnées), ou encore une chaîne vide (aucune coche sélectionnée).
    2. N'ajoutez à la règle que les coches du groupe donné et ajoutez-les dans l'ordre dans lequel elles apparaissent dans le groupe. Ensuite, réalisez une itération au sein des coches du groupe, comme dans l'exemple « Contrôle d'un groupe de coches ».

    Text() - Utilisez Field("groupName").Value

    SetValue(newValue) – Pour changer la valeur d'un groupe de coches, vous devez définir/redéfinir les coches requises dans ce groupe. Les coches doivent être incluses dans la règle, et l'indicateur ReadOnly doit être activé pour elles.

Règles d'automatisation

Pour pouvoir utiliser dans FlexiCapture 9,0 des composants d'automatisation créés dans FormReader 6.5, vous devez effectuer les changements suivants dans ces composants.

  1. La méthode d'un composant externe qui implémente la logique de la règle doit être invoquée à partir d'une règle de script, comme indiqué dans les exemples. Il n'y a pas d'exigences particulières pour la signature de cette méthode. Notez, toutefois, que les paramètres transmis de la règle de script à la méthode du composant externe doivent correspondre à la signature sélectionnée de la méthode, qui peut se présenter comme suit :

    Public Sub Check(ByRef docObj As Object)

    2. docObj – Il s'agit d'une référence à l'unité de document à vérifier.

  2. Les méthodes de l'objet fieldsObj qui étaient utilisées sous FormReader 6.5 doivent être remplacées par les méthodes prises en charge par FlexiCapture 9.0. Le tableau ci-dessous répertorie les correspondances entre les anciennes et les nouvelles méthodes de l'objet fieldsObj
Méthode fieldsObj | Exemples de code VisualBasic pouvant se substituer à l'ancienne méthode
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()

GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next

GetFieldsTypes(FieldTypes As Variant) | Non pris en charge
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value

GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value

GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Pour pouvoir travailler avec des colonnes de tableaux, ajoutez des champs de colonnes à la règle. La procédure à suivre pour vérifier si la colonne a été associée correctement est la même que pour n'importe quel autre champ :

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Pour pouvoir travailler avec des cellules de tableau, ajoutez des champs de colonnes à la règle.

Les opérations portant sur ces champs dépendent du niveau de la règle. Si la règle a été créée pour intervenir au niveau d'une colonne ou d'un tableau, elle s'applique à chaque ligne et utilise les valeurs des colonnes de la ligne en cours de vérification (elle intervient donc sur les cellules) :

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Ainsi, vous pouvez créer une règle qui utilise les données des deux premières colonnes d'un tableau pour en compléter une troisième :

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Si la règle a été créée pour intervenir au niveau d'une unité contenant un tableau (groupe, section, document), il vous faut effectuer une itération dans une colonne, comme décrit dans l'exemple de « règle d'automatisation », pour accéder à ses cellules.

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' suggestions pour le champ

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next

SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' suggestions pour le champ

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next

SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Il est possible d'accéder aux champs de cellules comme il est décrit pour la méthode SetTableCellValue.

Ensuite, vous pouvez travailler avec la cellule à laquelle vous avez accédé de la même manière que pour n'importe quel champ. Pour définir une suggestion, procédez comme suit :

cell.Suggest cellSuggest

  3. Les méthodes de l'objet errorsObj qui étaient utilisées sous FormReader 6.5 doivent être remplacées par les méthodes prises en charge par FlexiCapture 9.0. Le tableau ci-dessous répertorie les correspondances entre les anciennes et les nouvelles méthodes de l'objet errorsObj.
Méthode errorsObj Exemples de code VisualBasic pouvant se substituer à l'ancienne méthode
SendFieldError( ErrMsg As String, Index As Integer) docObj.ErrorMessage = ErrMsg

docObj.CheckSucceeded = false

docObj.FocusedField = docObj.Fields.Item(index)

SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant )

docObj.ErrorMessage = ErrMsg
docObj.CheckSucceeded = false

Si la règle a été créée pour intervenir au niveau d'un tableau ou d'une colonne, le programme signale comme des erreurs toutes les cellules de la ligne vérifiée dont les champs (colonnes) ont été ajoutés à la règle. Pour déplacer le focus sur une cellule donnée, utilisez le code suivant :

docObj.FocusedField = docObj.Field("ColumnName")

Si la règle a été créée pour un niveau supérieur, le programme ne marque pas de cellules, et il ne déplace pas non plus le focus au sein de ces cellules.

Migration de l'exportation d'automatisation FormRead à l'exportation de scripts FlexiCapture

La méthode d'un composant externe qui implémente la logique de la règle doit être invoquée à partir d'une règle de script, comme indiqué dans les exemples. Il n'y a pas d'exigences particulières pour la signature de cette méthode. Notez, toutefois, que les paramètres transmis de la règle de script à la méthode du composant externe doivent correspondre à la signature sélectionnée de la méthode, qui peut se présenter comme suit :

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – Il s'agit d'une référence au document à exporter

exportTools – Il s'agit d'une référence à l'objet ExportTools

Les méthodes de l'objet fieldsObj qui était utilisé dans FormReader 6.5 doivent être remplacées par les méthodes prises en charge par la version actuelle de l'application. Le tableau ci-dessous répertorie les correspondances entre les méthodes de l'objet fieldsObj et les nouvelles manières de travailler avec des documents à exporter :

Méthodes de l'objet fieldsObj | Implémentations possibles dans le nouveau modèle d'objets
GetFieldsCount As
Integer 		Pour récupérer le nombre de champs dans le document en cours d'exportation, effectuez une itération au sein de l'arborescence de champs, comme illustré dans l'exemple « Utilisation d'un composant COM externe » et effectuez le calcul.
GetFieldsNames(Names As Variant) | Pour récupérer les noms des champs du document en cours d'exportation, effectuez une itération au sein de l'arborescence de champs, comme dans l'exemple « Utilisation d'un composant COM externe », puis remplissez le tableau avec les noms des champs.
GetFieldsTypes(FieldTypes As Variant) | Non pris en charge.
GetFieldByIndex(Index As Integer, FieldValue As Variant) Un accès via l'index n'a aucun sens parce que le nouveau modèle de document dispose d'une structure hiérarchique.
Il est facile d'effectuer une itération au niveau de l'arborescence de champs comme illustré dans l'exemple « Utilisation d'un composant COM externe » et de remplir le tableau avec les noms du champ.
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


API du serveur d'application

L'API du serveur d'application permet à un système externe de créer une tâche de traitement, de démarrer le traitement et d'obtenir les résultats du traitement. La disponibilité de l'API permet le développement d'applications tierces qui utilisent ABBYY FlexiCapture 9.0 en tant que serveur d'analyse d'images de documents et permet également l'exportation des résultats.

L'API peut être utilisé pour contrôler un flux de travail déjà configuré. L'utilisateur doit créer les projets requis dans la station de configuration des projets et préciser les définitions des documents à utiliser pour chaque projet, types de lots, options de traitement des images, etc.

Si l'API est utilisé, il est conseillé d'utiliser un mode de traitement sans assistance.

Une description formelle de l'interface du service (WSDL) est disponible ici :

http://appServer/FlexiCapture/Server/WebServices.dll?Handler=Version2WSDL, où appServer est le nom du serveur d’application installé.

Un équivalent C# suit :

// Méthodes issues de la première version de l’interface

// Méthodes ajoutées dans la deuxième version

// Obtenir la liste de lots du projet

Batch[] GetBatches( int projectId );

// Obtenir le lot à l’aide de l’identificateur

BatchGetBatch( int batchId );

// Obtenir le type du lot à l’aide de l’identificateur

BatchTypeGetBatchType( int batchTypeId );

// Ouvrir le lot (verrouiller la suppression)

boolOpenBatch( int sessionId, int batchId );

// Fermer le lot (déverrouiller la suppression)

voidCloseBatch( int sessionId, int batchId );

// Obtenir des informations détaillées sur le document

DocumentExGetDocument( int batchId, int documentId );

// Ajouter un document comportant des paramètres d’enregistrement

intAddNewDocumentEx( int sessionId, int batchId, DocumentExdocument, File file, bool omAutomaticAssembling );

// Supprimer le document

boolDeleteDocument( int sessionId, int batchId, int documentId );

// Définir les paramètres d’enregistrement du document

voidSetDocumentProperties( int sessionId, int batchId, int documentId, RegistrationProperty[] properties );

// Ajouter au document une page comportant des informations supplémentaires

intAddNewPageEx( int sessionId, int batchId, int documentId, PageEx page, File file );

// Supprimer la page du document

boolDeletePage( int sessionId, int batchId, int documentId, int pageId );

// Utilisation des tâches de renumérisation

// Obtenir la liste des tâches disponibles

TaskListGetAvailableTasks( int sessionId, int projectId, int processingStage );

// Obtenir la liste des tâches différées

TaskListGetPostponedTasks( int sessionId, int projectId, int processingStage );

// Ouvrir la tâche. Avant de faire quoi que ce soit d’autre, elle doit être ouverte pour empêcher les autres utilisateurs de l’ouvrir.

boolOpenTask( int sessionId, int taskId );

// Renvoyer la tâche traitement supplémentaire

voidCloseTask( int sessionId, int taskId );

// Rejeter la tâche

voidCancelTask( int sessionId, int taskId );

// Différer la tâche

voidPostponeTask( int sessionId, int taskId, string comment);

// Envoyer la tâche aux exceptions

voidSendTaskToException( int sessionId, int taskId, string comment );

// Obtenir la liste de documents de la tâche

TaskDocumentListGetTaskDocuments( int taskId );

// Obtenir des informations sur la tâche

TaskGetTaskInfo( int taskId );

// Utiliser des fichiers personnalisés

// Enregistrer le fichier personnalisé sur le serveur

voidSaveCustomFile( int sessionId, File file );

// Charger le fichier personnalisé à partir du serveur

FileLoadCustomFile( string fileName );

// Supprimer le fichier personnalisé du serveur

voidRemoveCustomFile( int sessionId,  string filename );

// Obtenir la liste des fichiers personnalisés

string[] GetCustomFileNames();

// Utiliser la protection

// Obtenir un nouveau ticket

boolGetNewTicket( int sessionId, int stationType, out TicketInfoticketInfo );

// Mettre à jour le ticket existant

boolUpdateTicket( int sessionId, int ticketId, out TicketInfoticketInfo );

// Extraire à jour le ticket existant

voidReleaseTicket( int sessionId, int ticketId );

// Écrire dans le journal du serveur de messagerie

voidWriteToLog( long clientTime, LogRecord[] records );
API du serveur d'application : exemple d'utilisation
Description des services web de l'API du serveur d'application


API du serveur d'application : exemple d'utilisation

Cet exemple a été créé sous Microsoft Visual Studio. Le code de l’exemple ci-dessous suppose qu’une référence (WebReference) au service Web a été ajoutée et que le nom FlexiCapture a été sélectionné pour la référence (l’espace du nom généré correspond à ce nom). L’exemple suppose également que la fonction Trace a été définie (par exemple, à l’aide de l’impression des informations de débogage Debug.Print). Elle est utilisée pour ajouter des données au fichier journal.

L'exemple est une simple démonstration. Dans le cadre d'un projet réel, assurez-vous de créer des classes d'habillage fiables autour des objets ouverts et utilisez des mécanismes similaires à l'utilisation dans C#. Un mécanisme pour effacer les sessions et les lots abandonnés, à sécurité intégrée et non affecté par des coupures de courant ni par des défaillances de lignes de communication (par exemple, l'identificateur doit être enregistré et la session fermée dans le cadre de la procédure de récupération) est souhaitable. Les sessions abandonnées ne présentent aucun danger en elle-mêmes, mais elles peuvent s'accumuler et devenir une nuisance pour l'administrateur. De plus, les lots abandonnés peuvent prendre un volume considérable de ressources au serveur, principalement en utilisant tout l'espace de stockage réservé aux images et aux documents.

Pour exécuter cet exemple, téléchargez tout simplement votre projet sur le serveur d'applications nouvellement installé et sélectionnez le traitement sans assistance dans l'onglet Flux de travail.

publicvoid RunSample(string serverUrl)

{

       try

       {

             // Initialiser le service

             FlexiCapture.FlexiCaptureWebService service = new FlexiCaptureWebService();

// Pour référencer la version 1du service, l'URL doit être construit comme suit.
// Notez que l'URL obtenue est différente de celle utilisée pour
// référencer l'interface WSDL (précédemment utilisée pour ajouter la référence)

service.Url = serverUrl + "/FlexiCapture/Server/WebServices.dll?Handler=Version1";

// Activer la connexion transparente au moyen des justificatifs d'identité du fil courant

service.Credentials = System.Net.CredentialCache.DefaultCredentials;

             // Ouvrir une session

             int sessionId = service.OpenSession();

             try

             { {

// Exécuter la liste des projets disponibles (cette action peut être omise si vous utilisez
// un projet fixe. Dans ce cas, la méthode conseillée est d'ouvrir
// un projet par GUID)

                    FlexiCapture.Project[] projects = service.GetProjects();

                    if( projects != null )

                    {

                          foreach( FlexiCapture.Project project in projects )

                          {

                                 Trace( project.Name + " : " + project.Guid );

                          }

                    }

                    // Ouvrir le premier projet de la liste

                    int projectId = service.OpenProject( sessionId, projects[0].Guid );

                    // Exécuter la liste des types de lots disponibles

                    FlexiCapture.BatchType[] batchTypes = service.GetBatchTypes( projectId );

                    if( batchTypes != null )

                    {

                          foreach( FlexiCapture.BatchType batchType in batchTypes )

                          { {

                                 Trace( batchType.Name + " : " + batchType.Description );

                          }

                    }

                    // Créer un nouveau lot

                    FlexiCapture.Batch batch = new FlexiCapture.Batch();

                    batch.Name = "Sample API Batch";

                    int batchId = service.AddNewBatch( sessionId, projectId, batch );

                    // Charger des images d'exemple (voir la définition de LoadFile ci-dessous)

                    FlexiCapture.File file1 = LoadFile( "Banking 1.png" );

                    FlexiCapture.File file2 = LoadFile( "Banking 2.png" );

                    FlexiCapture.File file3 = LoadFile( "Banking 3.png" );

                    // Ajouter des images d'exemple

                    for( int i = 0; i < 3; i++ )

                    {

                          service.AddNewImage( sessionId, batchId, file1 );

                          service.AddNewImage ( sessionId, batchId, file2 );

                          service.AddNewImage ( sessionId, batchId, file3 );

                    }

                    // Démarrer le traitement du lot

                    service.ProcessBatch( sessionId, batchId );

                    // Attendre la fin du traitement

                    int percentCompleted = 0;

                    while( percentCompleted < 100 )

                    {

                          percentCompleted = service.GetBatchPercentCompleted( batchId );

                          System.Threading.Thread.Sleep( 500 );

                    } }

                    // Analyser les résultats

                    FlexiCapture.Document[] documents = service.GetDocuments( batchId );

                    if( documents != null )

                    {

                          foreach( FlexiCapture.Document document in documents )

                          {

                                 FlexiCapture.File attachedFile =

service.GetDocumentResult( document.Id, "MyResult.xml" );

                          } }

                    }

                    // Effacer

                    service.DeleteBatch( sessionId, batchId );

                    service.CloseProject( sessionId, projectId );

             }

             finally

             {

                    service.CloseSession( sessionId );

             }

       }

       catch ( Exception ex )

       {

             Trace( ex.Message );

       }

}

publicFlexiCapture.File LoadFile( string fileName )

{

       FlexiCapture.File file = new FlexiCapture.File();

       using( FileStream stream = File.Open( fileName, FileMode.Open ) )

       {

             file.Name = fileName;

             file.Bytes = new byte[stream.Length];

             stream.Read( file.Bytes, 0, file.Bytes.Length );

       }

       return file;

}


Description des services Web du serveur d'application

Une description à jour de l'interface du service (WSDL) est disponible ici :

http://appServer/FlexiCapture/Server/WebServices.dll?Handler=Version1WSDL, où appServer est le nom du serveur d'application installé.

<?xml version="1.0" ?>
- <definitionsxmlns:s="http://www.w3.org/2001/XMLSchema"xmlns:http="http://schemas.xmlsoap.org/wsdl/http/"xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/"xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"xmlns:s0="urn:http://www.abbyy.com/FlexiCapture"xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"xmlns:atls="http://tempuri.org/vc/atl/server/"targetNamespace="urn:http://www.abbyy.com/FlexiCapture"xmlns="http://schemas.xmlsoap.org/wsdl/">
- <types>
- <s:schema targetNamespace="urn:http://www.abbyy.com/FlexiCapture"attributeFormDefault="qualified"elementFormDefault="qualified">
<s:import namespace="http://schemas.xmlsoap.org/soap/encoding/" />
- <s:element name="OpenSession">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="OpenSessionResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetProjects">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetProjectsResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="projects"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Project" type="s0:Project" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseSession">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseSessionResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="OpenProject">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectNameOrGuid"type="s:string" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="OpenProjectResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseProject">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="CloseProjectResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetBatchTypes">
- <s:complexType>
- <s:sequence>
<s:element name="projectId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetBatchTypesResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="batchTypes"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="BatchType" type="s0:BatchType" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="projectId"type="s:int" />
<s:element name="batch"type="s0:Batch" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewBatchResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="DeleteBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="DeleteBatchResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:boolean" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewImage">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewImageResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="AddNewDocument">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewDocumentResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewEmptyDocument">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewEmptyDocumentResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewPage">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="documentId"type="s:int" />
<s:element name="file"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="AddNewPageResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="ProcessBatch">
- <s:complexType>
- <s:sequence>
<s:element name="sessionId"type="s:int" />
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="ProcessBatchResponse">
- <s:complexType>
<s:sequence />
</s:complexType>
</s:element>
- <s:element name="GetBatchPercentCompleted">
- <s:complexType>
- <s:sequence>
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetBatchPercentCompletedResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocuments">
- <s:complexType>
- <s:sequence>
<s:element name="batchId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentsResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="documents"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Document" type="s0:Document" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentResultsList">
- <s:complexType>
- <s:sequence>
<s:element name="documentId"type="s:int" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="GetDocumentResultsListResponse">
- <s:complexType>
- <s:sequence>
- <s:element name="fileNames"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="string" type="s:string" minOccurs="0" maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="LoadDocumentResult">
- <s:complexType>
- <s:sequence>
<s:element name="documentId"type="s:int" />
<s:element name="fileName"type="s:string" />
</s:sequence>
</s:complexType>
</s:element>
- <s:element name="LoadDocumentResultResponse">
- <s:complexType>
- <s:sequence>
<s:element name="return"type="s0:File" />
</s:sequence>
</s:complexType>
</s:element>
- <s:complexType name="Batch">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="Name"type="s:string" />
<s:element name="BatchTypeId"type="s:int" />
<s:element name="Priority"type="s:int" />
<s:element name="Description"type="s:string" />
- <s:element name="Properties"atls:SizeIs="PropertiesCount"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="RegistrationProperty"type="s0:RegistrationProperty"minOccurs="0"maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
<s:element name="PropertiesCount"type="s:int" />
</s:sequence>
</s:complexType>
- <s:complexType name="File">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Bytes"type="s:base64Binary" />
</s:sequence>
</s:complexType>
- <s:complexType name="Document">
- <s:sequence>
<s:element name="Id"type="s:int" />
- <s:element name="Pages"atls:SizeIs="PageCount"nillable="true">
- <s:complexType>
- <s:sequence>
<s:element name="Page"type="s0:Page"minOccurs="0"maxOccurs="unbounded" />
</s:sequence>
</s:complexType>
</s:element>
<s:element name="PageCount"type="s:int" />
<s:element name="IsProcessed"type="s:boolean" />
<s:element name="HasProcessingErrors"type="s:boolean" />
<s:element name="HasDocumentErrors"type="s:boolean" />
<s:element name="ErrorText"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="Project">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Guid"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="RegistrationProperty">
- <s:sequence>
<s:element name="Name"type="s:string" />
<s:element name="Value"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="BatchType">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="Name"type="s:string" />
<s:element name="Description"type="s:string" />
</s:sequence>
</s:complexType>
- <s:complexType name="Page">
- <s:sequence>
<s:element name="Id"type="s:int" />
<s:element name="SourceFileName"type="s:string" />
<s:element name="SourcePageNumber"type="s:int" />
<s:element name="ErrorText"type="s:string" />
</s:sequence>
</s:complexType>
</s:schema>
</types>
- <message name="OpenSessionIn">
<part name="parameters"element="s0:OpenSession" />
</message>
- <message name="OpenSessionOut">
<part name="parameters"element="s0:OpenSessionResponse" />
</message>
- <message name="GetProjectsIn">
<part name="parameters"element="s0:GetProjects" />
</message>
- <message name="GetProjectsOut">
<part name="parameters"element="s0:GetProjectsResponse" />
</message>
- <message name="CloseSessionIn">
<part name="parameters"element="s0:CloseSession" />
</message>
- <message name="CloseSessionOut">
<part name="parameters"element="s0:CloseSessionResponse" />
</message>
- <message name="OpenProjectIn">
<part name="parameters"element="s0:OpenProject" />
</message>
- <message name="OpenProjectOut">
<part name="parameters"element="s0:OpenProjectResponse" />
</message>
- <message name="CloseProjectIn">
<part name="parameters"element="s0:CloseProject" />
</message>
- <message name="CloseProjectOut">
<part name="parameters"element="s0:CloseProjectResponse" />
</message>
- <message name="GetBatchTypesIn">
<part name="parameters"element="s0:GetBatchTypes" />
</message>
- <message name="GetBatchTypesOut">
<part name="parameters"element="s0:GetBatchTypesResponse" />
</message>
- <message name="AddNewBatchIn">
<part name="parameters"element="s0:AddNewBatch" />
</message>
- <message name="AddNewBatchOut">
<part name="parameters"element="s0:AddNewBatchResponse" />
</message>
- <message name="DeleteBatchIn">
<part name="parameters"element="s0:DeleteBatch" />
</message>
- <message name="DeleteBatchOut">
<part name="parameters"element="s0:DeleteBatchResponse" />
</message>
- <message name="AddNewImageIn">
<part name="parameters"element="s0:AddNewImage" />
</message>
- <message name="AddNewImageOut">
<part name="parameters"element="s0:AddNewImageResponse" />
</message>
- <message name="AddNewDocumentIn">
<part name="parameters"element="s0:AddNewDocument" />
</message>
- <message name="AddNewDocumentOut">
<part name="parameters"element="s0:AddNewDocumentResponse" />
</message>
- <message name="AddNewEmptyDocumentIn">
<part name="parameters"element="s0:AddNewEmptyDocument" />
</message>
- <message name="AddNewEmptyDocumentOut">
<part name="parameters"element="s0:AddNewEmptyDocumentResponse" />
</message>
- <message name="AddNewPageIn">
<part name="parameters"element="s0:AddNewPage" />
</message>
- <message name="AddNewPageOut">
<part name="parameters"element="s0:AddNewPageResponse" />
</message>
- <message name="ProcessBatchIn">
<part name="parameters"element="s0:ProcessBatch" />
</message>
- <message name="ProcessBatchOut">
<part name="parameters"element="s0:ProcessBatchResponse" />
</message>
- <message name="GetBatchPercentCompletedIn">
<part name="parameters"element="s0:GetBatchPercentCompleted" />
</message>
- <message name="GetBatchPercentCompletedOut">
<part name="parameters"element="s0:GetBatchPercentCompletedResponse" />
</message>
- <message name="GetDocumentsIn">
<part name="parameters"element="s0:GetDocuments" />
</message>
- <message name="GetDocumentsOut">
<part name="parameters"element="s0:GetDocumentsResponse" />
</message>
- <message name="GetDocumentResultsListIn">
<part name="parameters"element="s0:GetDocumentResultsList" />
</message>
- <message name="GetDocumentResultsListOut">
<part name="parameters"element="s0:GetDocumentResultsListResponse" />
</message>
- <message name="LoadDocumentResultIn">
<part name="parameters"element="s0:LoadDocumentResult" />
</message>
- <message name="LoadDocumentResultOut">
<part name="parameters"element="s0:LoadDocumentResultResponse" />
</message>
- <portType name="FlexiCaptureWebServiceSoap">
- <operation name="OpenSession">
<input message="s0:OpenSessionIn" />
<output message="s0:OpenSessionOut" />
</operation>
- <operation name="GetProjects">
<input message="s0:GetProjectsIn" />
<output message="s0:GetProjectsOut" />
</operation>
- <operation name="CloseSession">
<input message="s0:CloseSessionIn" />
<output message="s0:CloseSessionOut" />
</operation>
- <operation name="OpenProject">
<input message="s0:OpenProjectIn" />
<output message="s0:OpenProjectOut" />
</operation>
- <operation name="CloseProject">
<input message="s0:CloseProjectIn" />
<output message="s0:CloseProjectOut" />
</operation>
- <operation name="GetBatchTypes">
<input message="s0:GetBatchTypesIn" />
<output message="s0:GetBatchTypesOut" />
</operation>
- <operation name="AddNewBatch">
<input message="s0:AddNewBatchIn" />
<output message="s0:AddNewBatchOut" />
</operation>
- <operation name="DeleteBatch">
<input message="s0:DeleteBatchIn" />
<output message="s0:DeleteBatchOut" />
</operation>
- <operation name="AddNewImage">
<input message="s0:AddNewImageIn" />
<output message="s0:AddNewImageOut" />
</operation>
- <operation name="AddNewDocument">
<input message="s0:AddNewDocumentIn" />
<output message="s0:AddNewDocumentOut" />
</operation>
- <operation name="AddNewEmptyDocument">
<input message="s0:AddNewEmptyDocumentIn" />
<output message="s0:AddNewEmptyDocumentOut" />
</operation>
- <operation name="AddNewPage">
<input message="s0:AddNewPageIn" />
<output message="s0:AddNewPageOut" />
</operation>
- <operation name="ProcessBatch">
<input message="s0:ProcessBatchIn" />
<output message="s0:ProcessBatchOut" />
</operation>
- <operation name="GetBatchPercentCompleted">
<input message="s0:GetBatchPercentCompletedIn" />
<output message="s0:GetBatchPercentCompletedOut" />
</operation>
- <operation name="GetDocuments">
<input message="s0:GetDocumentsIn" />
<output message="s0:GetDocumentsOut" />
</operation>
- <operation name="GetDocumentResultsList">
<input message="s0:GetDocumentResultsListIn" />
<output message="s0:GetDocumentResultsListOut" />
</operation>
- <operation name="LoadDocumentResult">
<input message="s0:LoadDocumentResultIn" />
<output message="s0:LoadDocumentResultOut" />
</operation>
</portType>
- <binding name="FlexiCaptureWebServiceSoap"type="s0:FlexiCaptureWebServiceSoap">
<soap:binding transport="http://schemas.xmlsoap.org/soap/http"style="document" />
- <operation name="OpenSession">
<soap:operation soapAction="#OpenSession"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetProjects">
<soap:operation soapAction="#GetProjects"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="CloseSession">
<soap:operation soapAction="#CloseSession"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="OpenProject">
<soap:operation soapAction="#OpenProject"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="CloseProject">
<soap:operation soapAction="#CloseProject"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetBatchTypes">
<soap:operation soapAction="#GetBatchTypes"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewBatch">
<soap:operation soapAction="#AddNewBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="DeleteBatch">
<soap:operation soapAction="#DeleteBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewImage">
<soap:operation soapAction="#AddNewImage"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewDocument">
<soap:operation soapAction="#AddNewDocument"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewEmptyDocument">
<soap:operation soapAction="#AddNewEmptyDocument"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="AddNewPage">
<soap:operation soapAction="#AddNewPage"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="ProcessBatch">
<soap:operation soapAction="#ProcessBatch"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetBatchPercentCompleted">
<soap:operation soapAction="#GetBatchPercentCompleted"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetDocuments">
<soap:operation soapAction="#GetDocuments"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="GetDocumentResultsList">
<soap:operation soapAction="#GetDocumentResultsList"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
- <operation name="LoadDocumentResult">
<soap:operation soapAction="#LoadDocumentResult"style="document" />
- <input>
<soap:body use="literal" />
</input>
- <output>
<soap:body use="literal" />
</output>
</operation>
</binding>
- <service name="FlexiCaptureWebService">
- <port name="FlexiCaptureWebServiceSoap"binding="s0:FlexiCaptureWebServiceSoap">
<soap:address location="http://appserver:80/FlexiCapture/Server/WebServices.dll?Handler=Version1" />
</port>
</service>
</definitions>


Comparaison entre les règles de FormReader 6.5 et de FlexiCapture 9.0

FormReader 6.5

Équivalent dans FlexiCapture 9.0 Conversion automatique

Contrôle par rapport à une base de données

Règle de contrôle de base de données

Non

Sommes de contrôle

Règle de somme de contrôle

Non

Blocs de fusion

Règle de champs de fusion

Oui

Règles VBScript

Règle de script

Non

Recherche dans la liste de suggestions

Propriétés du champ, onglet Type de données. Liste des variants dans le champ Contraintes. Fonctionne avec tous les types excepté Date et Numéro. Consultez la section Types de données du champ d'entrée de texte.

Oui

Mise en correspondance de blocs

Peut être mise en œuvre par l'intermédiaire d'une règle de script.

Non

Règles If-Then

Règle de script

Non

Remplacement de valeurs à partir d'une liste

Propriétés du champ, onglet Type de données. Type Texte, champ Traitement. Consultez la section Types de données du champ d'entrée de texte.

Oui

Remplacement de caractères de la liste

Propriétés du champ, onglet Type de données. Type Texte, champ Traitement. Consultez la section Types de données du champ d'entrée de texte.

Oui

Normalisation et contrôle des dates

Propriétés du champ, onglet Type de données. Dans la liste Catégorie, sélectionnez Date ; dans la liste Formats, sélectionnez les formats requis ; dans le champ Contraintes, saisissez les contraintes requises. Consultez la section Types de données du champ d'entrée de texte.

Non

Expressions régulières

Propriétés du champ, onglet Type de données. Saisissez l'expression regulière requise dans le champ Contraintes. Fonctionne avec tous les types excepté Date et Numéro. Consultez la section Types de données du champ d'entrée de texte.

Oui

Contrôle d'automatisation

Dans la version précédente de l'application, pour utiliser des objets d'automatisation, il fallait enregistrer les composants sur l'ordinateur cible. Il était donc difficile de transférer des lots d'un ordinateur à un autre. Dans la nouvelle version, la logique de la plupart des règles de ce type est plus facile à implémenter par l'intermédiaire de scripts.

Si la logique d'une règle est trop complexe et nécessite l'utilisation un composant externe, ce composant doit être invoqué à partir du code d'une règle de script. Ensuite, une référence à l'objet du document vérifié doit être transmise au composant.

Non

Normalisation des prix

Peut être mis en œuvre par l'intermédiaire d'un composant COM externe appelé règle de script.

Non

Validation de série et de numéro de passeport

Peut être mis en œuvre par l'intermédiaire d'un composant COM externe appelé règle de script.

Non

Somme en chiffres - somme en lettres

Règle somme en chiffres - somme en lettres Non

Prix en chiffres - prix en lettres

Peut être mis en œuvre par l'intermédiaire d'un composant COM externe appelé règle de script.

Non


Autres options

Vous pouvez configurer le traitement des documents et l'interface du programme pour les adapter à vos besoins. Dans la fenêtre principale de la station de configuration de projets, sélectionnez Outils>Options… La boîte de dialogue qui s'affiche comporte quatre onglets :

  • Progression de la tâche

    Lorsque des tâches sont exécutées en mode arrière-plan, vous pouvez surveiller leur progression dans la fenêtre de progression des tâches, en consultant le fichier journal et en lisant les astuces contextuelles. Cet onglet vous permet de sélectionner les informations à consigner dans le fichier journal et dans quelles circonstances afficher des info-bulles.

  • Couleurs

    Vous pouvez modifier la couleur des éléments d'interface (par exemple, le cadre entourant les champs sélectionnés dans l'éditeur de définition de document ou le cadre et la couleur de remplissage des champs avec erreurs et avertissements). Sélectionnez l'élément souhaité, puis cliquez sur le bouton Couleur.

  • Traitement de document

    Les images peuvent être reconnues automatiquement juste dès leur ajout au lot si vous sélectionnez l'option Reconnaître les images ajoutées automatiquement.

    La reconnaissance peut être exécutée en arrière-plan (sélectionnez Exécuter le processus de reconnaissance en mode arrière-plan).

    Si Omettre les documents erronés pendant l'exportation est sélectionné, les documents traités avec succès et les documents avec des erreurs seront exportés.

    Si une erreur de script est détectée, le débogueur de Visual Studio se lance. Sélectionnez Désactiver le débogage de script externe si vous ne souhaitez pas que le débogueur se lance. Seul un message d'erreur s'affiche.

  • Boîtes de dialogue

    Lorsque vous lancez le programme, la boîte de dialogue Ouvrir un projet apparaît par défaut. Vous pouvez y sélectionner un ou plusieurs projets existants. Vous pouvez désactiver cette boîte de dialogue en désélectionnant l'option Afficher la boîte de dialogue de démarrage dans l'onglet Boîtes de dialogue (vous pouvez également désactiver cette boîte de dialogue en désélectionnant la même option dans la boîte de dialogue elle-même).

    Lorsque vous fermez une liste de définitions de documents, le programme affiche un avertissement indiquant les définitions de documents non publiées. Si vous ne souhaitez que ce message d'avertissement s'affiche, désactivez l'option Afficher un avertissement si une définition de document non publiée existe (vous pouvez également désactiver cette boîte de dialogue en désélectionnant la même option dans la boîte de dialogue elle-même).

    Si vous souhaitez que des avertissements soient affichés lors de l'exportation de documents erronés, sélectionnez Afficher un avertissement lors de l'exportation de documents erronés.

    Sélectionnez Demander s'il faut enregistrer les modifications en basculant entre les documents pour ne perdre aucun changement lors des passages entre différents documents.


Exemples de projets ABBYY FlexiCapture

Pour découvrir le fonctionnement d'ABBYY FlexiCapture 9.0 et mieux comprendre ses fonctionnalités, vous pouvez utiliser les exemples de projet intégrés au programme. Ces projets prêts à l'emploi contiennent des définitions de document prédéfinies et des images de document à traiter.

Vous trouverez les exemples de projets sur <nom du disque>:\Documents and Settings\All Users\Application Data\ABBYY\FlexiCapture\9.0\Samples.

Remarque : Sous Microsoft Windows Vista, les exemples de projets sont disponibles dans <nom du disque>:\\Users\Public\ABBYY\FlexiCapture\9.0\Samples.

Le dossier Samples contient les dossiers suivants :

  1. FlexiCapture : ce dossier contient les projets FlexiCapture.
  2. FlexiLayoutStudio : ce dossier contient les projets modèles FlexiLayout Studio. Ces exemples de projets illustrent le traitement de documents semi-structurés et doivent être ouverts dans ABBYY FlexiLayout Studio 9.0. La description détaillée de certains de ces projets est disponible dans le fichier d'aide de FlexiLayout Studio (consultez les sections Didacticiel et Conseils et astuces).
  3. FormDesigner - Ce dossier contient les formulaires fixes développés dans ABBYY FormDesigner. Les fichiers portant l'extension *.fdd s'ouvrent dans ABBYY FormDesigner 9.0. Ces formulaires sont utilisés dans les exemples de projets FlexiCapture suivants : Demande de carte bancaire, questionnaire.
  4. Images : ce dossier contient les images de document numérisées des exemples de projet FlexiCapture.

Les exemples de projets FlexiCapture sont énumérés et brièvement décrits ci-après.

Exemple de projet avec des documents de différents types

Les dossiers de projet contiennent les exemples de projets FlexiCapture.

  1. Point d'entrée unique

    Ce projet présente le processus de traitement de documents de différents types. Aucun tri préliminaire des documents n'est requis. Vous pouvez traiter simultanément les formulaires fixes et les documents flexibles. Les définitions de document utilisées dans ce projet sont également utilisées dans les projets décrits ci-dessous.

    Le projet contient tous les types de documents : demandes de carte bancaire, factures, contrats, lettres et tarifs.

Exemples de projets avec formulaires fixes

Les dossiers de projet contiennent les formulaires créés dans les projets ABBYY FormDesigner et FlexiCapture.

  2. Demande de carte bancaire

    Cet exemple de projet illustre les fonctionnalités suivantes :

    • Détection automatique des champs des formulaires fixes (pour découvrir comment fonctionne la détection automatique, supprimez tous les champs de la définition de document et sélectionnez Outils >Détecter automatiquement les objets…)
    • Prise en charge de documents dont la structure est complexe :
      1. Documents multipages (utilisation d'applications de trois pages dans l'exemple de projet)
      2. Utilisation de sections de document (dans l'exemple de projet, chaque page correspond à une section distincte)
      3. Règles d'assemblage de documents
      4. Traitement des annexes
    • Prise en charge des champs complexes :
      1. Utilisation de tableaux dans les formulaires fixes (tableau de comptes ouverts)
      2. Groupes de champs qui se répètent (groupes Adresse et Comptes demandés)
    • Vérification du format des données (les formats pour tous les champs numériques et de dates sont spécifiés)
    • Personnalisation du formulaire de données.
    • Exportation vers plusieurs destinations.
    • Édition d'informations confidentielles (rédaction).

  3. Questionnaire

    Une description détaillée de cet exemple de projet est disponible dans le manuel d'utilisation. Le projet décrit la procédure de configuration d'une définition de document étape par étape. Plusieurs formulaires plus simples sont utilisés pour illustrer les fonctionnalités de base d'ABBYY FlexiCapture. Vous pouvez compléter le questionnaire dans cet exemple de projet, le traiter dans ABBYY FlexiCapture et transmettre les données exportées à ABBYY.

Exemples de projets avec formulaires flexibles

Les dossiers de projet contiennent les exemples de projets FlexiLayout Studio et FlexiCapture.

  4. Facture

    Cet exemple de projet illustre le traitement de documents semi-structurés, ainsi que les fonctionnalités suivantes :

    • Nombre variable de pages dans les documents (de 1 à 3)
    • Tableaux sur plusieurs pages
    • Utilisation d'un dictionnaire de mots clés externe (fichier texte)
    • Une règle JScript permet de comparer la somme du champ Total avec la somme obtenue par l'ajout des totaux de toutes les lignes du tableau.

  5. Tarifs

    Cet exemple de projet illustre le traitement de documents semi-structurés, ainsi que les fonctionnalités suivantes :

    • Prise en charge de groupes qui se répètent. Cet exemple de projet illustre l'utilisation de groupes qui se répètent pour décrire les tableaux imbriqués (tableaux avec sous-titres)

  6. Lettres et contrats

    Cet exemple de projet illustre le processus d'acquisition de documents non structurés à partir de 2 ou 3 champs. Ce projet illustre les fonctionnalités suivantes :

    • Documents avec nombre de pages variable (de 1 à 4)
    • Configuration de l'exportation en PDF indexé.


Langues de reconnaissance prises en charge

ABBYY FlexiCapture 9.0 prend en charge les langues de reconnaissance suivantes (avec dictionnaire) :

Langue | OCR* | ICR**
Arménien (oriental, occidental, Grabar) | ü |
Bashkir | ü |
Bulgare | ü | ü
Catalan | ü |
Croate | ü | ü
Tchèque | ü | ü
Danois | ü |
Néerlandais (Pays-Bas et Belgique) | ü | ü
Anglais | ü | ü
Estonien | ü | ü
Finnois | ü | ü
Français | ü | ü
Allemand (nouvelle et ancienne orthographe) | ü | ü
Grec | ü | ü
Hébreu | ü |
Hongrois | ü | ü
Indonésien | ü | ü
Italien | ü | ü
Letton | ü | ü
Lituanien | ü | ü
Norvégien (Nynorsk et Bokmal) | ü |
Anglo-saxon | ü |
Vieux français | ü | ü
Saxon | ü | ü
Vieux italien | ü | ü
Vieux espagnol | ü | ü
Polonais | ü | ü
Portuguais (Portugal et Brésil) | ü |
Roumain | ü | ü
Russe | ü | ü
Slovaque | ü | ü
Slovène | ü | ü
Espagnol | ü | ü
Suédois | ü |
Tatar | ü |
Thaï | ü |
Turc | ü | ü
Ukrainien | ü | ü

Pour plus d'informations sur les polices pour les langues prises en charge, consultez la section « Polices requises pour un rendu correct des caractères pour les types de données pris en charge dans l'éditeur ABBYY FlexiCapture ».

Une liste complète et mise à jour des types de données pris en charge et de leurs détails est disponible à l'adresse http://www.abbyy.com.

* - OCR : reconnaissance optique de caractères. Reconnaissance optique des textes imprimés.

** - ICR : reconnaissance intelligente de caractères. Reconnaissance des textes manuscrits.


Polices requises pour un rendu correct des caractères pour les types de données pris en charge dans l'éditeur FormReader

Polices requises pour un rendu correct des caractères des langues prises en charge dans l'éditeur ABBYY FlexiCapture

Langue | Police
Avec prise en charge lexicographique |
Arménien (oriental, occidental, Grabar) | Arial Unicode MS(2)
Tatar | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Sans prise en charge lexicographique |
Abkhaze | Arial Unicode MS(2)
Adygéen | Arial Unicode MS(2), Lucida Sans Unicode(3)
Aghul | Arial Unicode MS(2), Lucida Sans Unicode(3)
Altaïque | Arial Unicode MS(2), Lucida Sans Unicode(3)
Avar | Arial Unicode MS(2), Lucida Sans Unicode(3)
Azerbaïdjanais (cyrillique), azerbaïdjanais (latin) | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Bashkir | Arial Unicode MS(2), Palatino Linotype(2)
Bouriate | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Tchétchène | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tchoukche | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tchouvache | Arial Unicode MS(2)
Dargin | Arial Unicode MS(2), Lucida Sans Unicode(3)
Dungan | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Gagauz | Arial Unicode MS(2)
Haoussa | Arial Unicode MS(2), Lucida Sans Unicode(3)
Ingouche | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kabarde | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kalmouk | MS Core Fonts 2.82(1) (Arial, Courier New etTimes New Roman)
Karakalpak | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Kazakh | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Khakas | Arial Unicode MS(2)
Khanty | Arial Unicode MS(2)
Koriak | Arial Unicode MS(2), Lucida Sans Unicode(3)
Kirghize | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Lak | Arial Unicode MS(2), Lucida Sans Unicode(3)
Lezgin | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mansi | Arial Unicode MS(2), Lucida Sans Unicode(3)
Mari | Arial Unicode MS(2)
Mongol | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Nenets | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Ossetic | Arial Unicode MS(2)
Russe (ancienne orthographe) | Arial Unicode MS(2), Palatino Linotype(2)
Tabassaran | Arial Unicode MS(2), Lucida Sans Unicode(3)
Tadjik | Arial Unicode MS(2), Palatino Linotype(2)
Turkmène | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Touvain | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Oudmourte | Arial Unicode MS(2)
Ouzbèque (cyrillique) | MS Core Fonts 2.82(1) (Arial, Courier New et Times New Roman)
Yakoute | Arial Unicode MS(2)
Zoulou | Arial Unicode MS,(2), Lucida Sans Unicode(3)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Supported text types

Types de textes pris en charge

ABBYY FlexiCapture 9.0 prend en charge les types de texte suivants :

Type de texte | Description
Imprimantes typographiques, laser et jet d'encre | Textes imprimés dans une imprimerie, sur une imprimante laser ou jet d'encre.
Machine à écrire | Textes tapés à la machine.
Imprimante matricielle | Textes imprimés sur une imprimante matricielle.
Index | Un jeu de caractères spécial qui n'inclut que des chiffres écrits en style code postal. Ces caractères se présentent de la manière suivante :
OCR-A | Police à espacement fixe conçue pour la reconnaissance optique de caractères. Largement utilisé par les banques, les compagnies de cartes de crédit et les sociétés apparentées. Ce texte peut se présenter de la manière suivante :
OCR-B | Police conçue pour la reconnaissance optique de caractères. Ce texte peut se présenter de la manière suivante :
MICR E-138 | Jeu spécial de caractères numériques imprimés à l'aide d'une encre magnétique spéciale. On trouve des caractères MICR (Magnetic Ink Character Recognition) dans divers endroits, notamment sur les chèques personnels. Ce texte peut se présenter de la manière suivante :
MICR CMC-7 | Police spéciale de code barres MICR (CMC-7). Ce texte peut se présenter de la manière suivante :


Types de codes barres pris en charge

ABBYY FlexiCapture 9.0 prend en charge les formats de codes barres suivants :

  • EAN 13
  • EAN 8
  • Code 39
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Check CodaBar
  • Aztec
  • Datamatrix

Remarque : ABBYY FlexiCapture 9.0 peut lire les codes barres Aztec et Datamatrix mais ne peut pas les détecter sur des images. Par conséquent, vous pouvez utiliser ces types de codes barres dans les définitions de document mais ne pouvez pas les utiliser dans les FlexiLayouts ou en tant que séparateurs de document.


Formats graphiques pris en charge

Type | Couleur
BMP | noir et blanc, gris, couleur
PCX, DCX | noir et blanc, gris
PNG | noir et blanc, gris, couleur
JPEG | gris, couleur
JPEG-2000 | gris, couleur
TIFF noir et blanc – non compressé, CCITT3, CCITT4, Packbits, ZIP;
gris – non compressé, Packbits, JPEG, ZIP;
couleur – non compressé, JPEG, ZIP.
JBIG2 | noir et blanc
GIF | couleur
PDF, PDF/A
PDF, PDF/A indexé
DjVu | noir et blanc, gris, couleur


Formats de fichiers d'exportation

Formats de fichiers vers lesquels ABBYY FlexiCapture 9.0 peut Exportationer les données des documents

  • Microsoft Office Excel Workbook (*.XLS)
  • DBase file (*.DBF)
  • Comma Separated Values File (*.CSV). ABBYY FlexiCapture prend en charges différentes pages de code (Windows, DOS)
  • Fichier de valeurs séparées par une virgule (*.CSV) au format Unicode (UTF-8, UTF-16)
  • Texte simple (*.TXT). ABBYY FlexiCapture prend en charge différentes pages de code (Windows, DOS)
  • Texte simple (*.TXT) au format Unicode (UTF-8, UTF-16)
  • Document XML (*.XML)


Alphabet utilisé dans les expressions normales

Caractères alphabétiques dans des expressions régulières

Nom | Désignation conventionnelle | Exemple d'utilisation
N'importe quel caractère | * | "c"*"t" : permet de rechercher des mots tels que cat, cot, etc.
Lettre | C | C"ot" : permet de rechercher des mots tels que Rot, pot, cot, Dot, mot, etc.
La lettre majuscule | A | A"ot" permet de rechercher des mots tels que Rot, Cot, Mot, Dot, etc.
La lettre minuscule | a | a"ot" permet de rechercher des mots tels que rot, cot, mot, dot, etc.
La lettre ou le nombre | X | X permet de rechercher tout chiffre ou toute lettre autonome.
Le nombre | N | N"e" permet de rechercher des mots tels que 5e, 4e, 6e, etc.
La chaîne | " " | "cot"
Or | | | "pl"("o"|"a")"t" permet de rechercher des mots tels que "plot" et "plat".
Le caractère du groupe | [] | [tm]"ot" permet de rechercher des mots tels que "tot" et "mot".
Le caractère hors groupe | [^] | [^t]"ot" permet la recherche de mots tels que "cot", "lot", etc., mais ne permet pas la recherche du mot "tot".
L'espace (dans un groupe) | \s | [A\s] permet de rechercher uniquement la lettre A ou un espace.
N'importe quel nombre de répétitions (s'applique à l'expression ou à la sous-expression de gauche) | {-} | [AB74]{-} : permet de rechercher toute combinaison des caractères A, B, 7, 4 de n'importe quelle longueur.
Nombre de répétitions n | {n} | N{2}"e" permet de rechercher des mots tels que 25e, 84e, 11e, etc.
De n à m répétitions | {n-m} | N{1-3}"e" permet de rechercher des mots tels que 5e, 84e, 111e, etc.
De 0 à n répétitions | {-n} | N{-2}"e" permet de rechercher des mots tels que 84e, 5e, etc.
À partir de n répétitions et plus | {n} | N{2}"e" permet de rechercher des mots tels que 25e, 834e, 311e, 34576e, etc.
Sous-expression | () |
Symbole tiret | [\-] |
Symbole barre oblique inversée | [\\] |


Brevets

Numéros de brevets aux États-Unis 5 258 855, 5 369 508, 5 625 465, 5 768 416 et 6 094 505


Technologies tierces

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 Université de British Columbia

Tous droits réservés.

En savoir plus

La présente autorise gratuitement toute personne (l'« Utilisateur ») à se procurer une copie du présent logiciel et des fichiers de documentation connexes (le « Logiciel »), à utiliser le Logiciel sans restriction, y compris et sans s'y limiter à utiliser, copier, modifier, fusionner, publier, distribuer et/ou commercialiser des copies du Logiciel et autorise les personnes à qui le Logiciel est fourni à faire de même, conformément aux conditions suivantes :

  1. Les avis de copyright susmentionnés et cette autorisation (qui comprend le déni de responsabilité ci-dessous) doivent figurer sur toutes les copies partielles ou complètes du Logiciel.

  2. Le nom du détenteur du copyright ne doit pas être utilisé pour recommander ou promouvoir les produits dérivés du Logiciel sans autorisation écrite préalable.

CE DÉNI DE GARANTIE CONSTITUE UN ÉLÉMENT ESSENTIEL DE CETTE LICENCE.

L'UTILISATION DU LOGICIEL SELON LE PRÉSENT CONTRAT EST SOUMISE AU RESPECT DU PRÉSENT DÉNI DE RESPONSABILITÉ. LE LOGICIEL EST FOURNI « EN L'ÉTAT », SANS GARANTIE D'AUCUNE SORTE, IMPLICITE OU EXPLICITE, Y COMPRIS MAIS SANS S'Y LIMITER, LES GARANTIES DE COMMERCIALISATION, D'ADÉQUATION À UN USAGE PARTICULIER ET DE NON-TRANSGRESSION DES DROITS DES TIERS. EN AUCUN CAS, LES DÉTENTEURS DU COPYRIGHT NE POURRONT ÊTRE TENUS RESPONSABLES DES RÉCLAMATIONS, DES DOMMAGES SPÉCIAUX, INDIRECTS OU CONSÉCUTIFS, DES DOMMAGES RÉSULTANT D'UNE PERTE D'UTILISATION, DE DONNÉES OU DE PROFITS RÉSULTANT D'UNE ACTION CONFORME AU CONTRAT, D'UNE NÉGLIGENCE OU DE TOUTE AUTRE ACTION TORTUEUSE, RÉSULTANT DE OU EN RAPPORT AVEC L'UTILISATION OU LES PERFORMANCES DE CE LOGICIEL. LES DÉTENTEURS DU COPYRIGHT N'APPORTENT AUCUNE GARANTIE QUANT À LA NON-TRANSGRESSION DES BREVETS OU DES DROITS DE PROPRIÉTÉS INTELLECTUELLES D'UNE AUTRE ENTITÉ. TOUT DÉTENTEUR DE COPYRIGHT SE DÉGAGE DE TOUTE RESPONSABILITÉ ENVERS L'UTILISATEUR POUR TOUTE REVENDICATION D'UNE AUTRE ENTITÉ REPOSANT SUR LE NON-RESPECT DES DROITS DE PROPRIÉTÉ INTELLECTUELLE OU AUTRE. CONFORMÉMENT AUX DROITS ACCORDÉS PAR LA PRÉSENTE, CHAQUE UTILISATEUR ASSUME SEUL LA RESPONSABILITÉ D'ASSURER LA SÉCURITÉ DES DROITS DE PROPRIÉTÉ INTELLECTUELLE, AU BESOIN. LE LOGICIEL N'EST PAS TOLÉRANT AUX PANNES ET N'EST PAS PRÉVU POUR PRENDRE EN CHARGE DES SYSTÈMES STRATÉGIQUES DU TYPE DE CEUX UTILISÉS DANS LE FONCTIONNEMENT DES INSTALLATIONS NUCLÉAIRES, DES SYSTÈMES DE NAVIGATION DES AVIONS OU DE COMMUNICATION, DES SYSTÈMES DE CONTRÔLE DU TRAFIC AÉRIEN, DES ÉQUIPEMENTS DE SOUTIEN À LA VIE OU DES SYSTÈMES D'ARMES, DANS LESQUELS UNE DÉFAILLANCE DU LOGICIEL OU DU SYSTÈME POURRAIT CONDUIRE DIRECTEMENT À LA MORT OU ENTRAÎNER DES BLESSURES CORPORELLES OU PHYSIQUES GRAVES OU DES DOMMAGES ENVIRONNEMENTAUX (« ACTIVITÉS À HAUT RISQUE »). LES DÉTENTEURS DU COPYRIGHT RÉFUTENT SPÉCIFIQUEMENT TOUTE GARANTIE IMPLICITE OU EXPLICITE D'ADÉQUATION À UN USAGE PARTICULIER DANS LES ACTIVITÉS À HAUT RISQUE.

MARQUES COMMERCIALES

QuickScan est une marque commerciale et Captiva une marque déposée de Captiva Software Corporation.

KODAK est une marque commerciale d'Eastman Kodak Company.

Kit de développement TWAIN

Le kit de développement TWAIN est distribué en l'état. Le développeur et les distributeurs du kit de développement TWAIN déclinent expressément toute garantie implicite, expresse ou statutaire, ce qui inclut mais ne se limite pas aux garanties implicites de commercialisation, de non-transgression des droits de tiers et d'adéquation à un usage particulier. Ni les développeurs, ni les distributeurs ne seront responsables des dommages, qu'ils soient directs, indirects, spéciaux, accidentels ou consécutifs, résultant de la reproduction, de la modification, de la distribution ou d'une autre utilisation du kit de développement TWAIN.


Support technique

En cas de questions sur l'utilisation d'ABBYY FlexiCapture 9.0, veuillez consulter la description détaillée de la fonctionnalité concernée dans les rubriques d'aide et dans le guide d'utilisation fournis avec ABBYY FlexiCapture 9.0. Vous pouvez également consulter la section de notre site Web www.abbyy.com consacrée au support technique, ou vous trouverez peut-être la réponse à votre question.

Pour vous offrir un conseil pertinent, notre service de support technique a besoin des informations suivantes :

  • Nom, prénom, patronyme
  • Nom de l'entreprise
  • Numéro de téléphone (fax, adresse de courrier électronique)
  • Numéro de série de votre pack d'installation
  • Version (consultez Aide/À propos d'ABBYY FlexiCapture…)
  • Description générale du problème, avec le texte complet du message d'erreur (si disponible)
  • Type de PC et de processeur
  • Version de SE Windows
  • Toute autre information jugée importante
Adresse et coordonnées des bureaux ABBYY


Comment acheter ABBYY FormDesigner 9.0

Comment acheter ABBYY FlexiCapture 9.0

Pour commander ABBYY FlexiCapture ou pour toute question liée à l’achat du produit, contactez les bureaux régionaux d’ABBYY.


Bureaux d’ABBYY

ABBYY Russie | Téléphone : +7 495 783 3700 Télécopie : +7 495 783 2663 Adresse postale : Russie, 127273, Moscou, P.O. box 32, ABBYY Adresse de l’entreprise : Moscou, ul. Otradnaya 2B, str. 6, Otradny Business Centre Adresse électronique : sales@abbyy.ru Support technique : support@abbyy.ru Web : http://www.abbyy.ru CARTE
ABBYY États-Unis | Tél. : +1 408-457-9777 Télécopie : +1 408-457-9778 Adresse : 880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, États-Unis Adresse électronique : sales@abbyyusa.com Support technique : support@abbyyusa.com Web : http://www.abbyy.com
ABBYY Ukraine | Téléphone : +380 44 490 9999 Télécopie : +380 44 490 9461 Adresse : P.O. Box 23, 02002 Kiev, Ukraine Adresse électronique : forms@abbyy.ua Téléphone du support technique : +380 44 490 9463 Adresse électronique du support technique : formsupport@abbyy.ua Web : http://www.abbyy.ua
ABBYY Europe GmbH | Téléphone : +49 (0)89 511 159 0 Télécopie : +49 89 (0)511 159 59 Adresse : Elsenheimerstraße 49, 80687 Munich, Allemagne Adresse électronique : sales_eu@abbyy.com Adresse électronique du support technique : support_eu@abbyy.com Web : http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
ABBYY UK Ltd. | Téléphone : +0870 600 0231 Télécopie : +01344 392 611 Adresse : Abbey House, Grenville Place, Bracknell RG12 1BP, Royaume-Uni Adresse électronique : sales_UK@abbyy.com Adresse électronique du support technique : support_eu@abbyy.com Web : http://www.abbyy.co.uk
ABBYY Japon | Téléphone : +81-42-795-1901 Télécopie : +81-42-795-1901 Adresse : 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 Adresse électronique : sales@abbyyusa.com Adresse électronique du support technique : support@abbyyusa.com Web : http://www.abbyy.com
ABBYY Taïwan | Téléphone : +886-2-2655-0556 Télécopie : +886-2-2655-2339 Adresse : Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taïwan, République de Chine. Adresse électronique : sales@abbyyusa.com Adresse électronique du support technique : support@abbyyusa.com Web : http://www.abbyy.com


Contrat de licence utilisateur final

ABBYY FlexiCapture 9.0

Important ! Veuillez lire attentivement le document suivant avant d'installer, de copier ou d'utiliser ce produit. En installant, copiant ou utilisant ce produit, vous vous engagez à accepter les termes suivants.

Ce Contrat de licence utilisateur final (« CLUF ») constitue un accord juridique entre vous, l'utilisateur final du produit logiciel susmentionné d'ABBYY, qui accompagne ce CLUF, y compris tous les supports, informations imprimées et documentation électronique ou « en ligne » associés (collectivement appelés « LOGICIEL ») et ABBYY.

En installant, copiant ou utilisant de quelque autre façon que ce soit ce LOGICIEL, vous reconnaissez avoir lu le présent CLUF et l'avoir compris, et acceptez de vous soumettre à ses conditions d’utilisation.

Le LOGICIEL est protégé par les lois et traités internationaux en vigueur sur le copyright. Vous acceptez que le présent CLUF s’applique au même titre que tout autre accord écrit que vous auriez signé.

Ce CLUF entre en vigueur à la date de votre acceptation de toutes les conditions prévues dans le cadre des présentes. Pour confirmer votre acceptation, cochez la case « J'accepte les termes de ce contrat de licence », puis cliquez sur le bouton « Suivant » dans le programme d'installation du LOGICIEL. La date de cet évènement est la Date d'entrée en vigueur.

Si le logiciel est accompagné d'une copie papier du présent Contrat de licence, en cas de différence de contenu entre le texte du présent CLUF et celui du Contrat de licence, celui du Contrat de licence prévaut.

Si vous n'acceptez pas les termes du présent CLUF, n’utilisez pas le LOGICIEL et cochez la case « Je n'accepte pas les termes de ce contrat de licence », puis cliquez sur "Annuler" dans le programme d'installation du LOGICIEL.

Définitions :

"Le terme « LOGICIEL » désigne le logiciel ABBYY FlexiCapture 9.0 Professional, qui est un ensemble de programmes informatiques, de bases de données et de documentation (qui peut être au format papier ou électronique) protégé par les lois du copyright.

"Le terme « composant LOGICIEL » désigne toute partie constitutive du LOGICIEL, notamment, mais sans s'y limiter, les programmes informatiques inclus dans le LOGICIEL.

"Le terme « ordinateur » désigne un appareil électronique équipé d'un ou de plusieurs noyaux de processeurs, qui accepte des informations sous une forme numérique ou similaire, et les manipule afin d'atteindre un résultat donné, à partir d'une séquence d'instructions.

"Le terme « licence » désigne le droit non exclusif que vous accorde ABBYY d'installer et d'utiliser le LOGICIEL, conformément aux termes du présent CLUF.

"Le terme « activation du LOGICIEL » désigne la procédure permettant de rendre le LOGICIEL pleinement opérationnel conformément à la documentation du LOGICIEL et à la portée de votre licence.

Le terme « ABBYY » désigne :

ABBYY USA Software House Inc., sis au 880 North McCarthy Boulevard, Suite 220, Milpitas, Californie 95035, États-Unis, quand l'article 16.1 de ce CLUF s'applique ;

ABBYY Europe GmbH, Elsenheimerstr. 49 80687 Munich, quand l'article 16.2 de ce CLUF s'applique ;

ABBYY UK Ltd. sis à Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, Royaume-Uni, quand l'article 16.3 s'applique ;

ABBYY LLC enregistré à ul. Perovskaya dom 22, korpus 1, 111398, Moscou, Russie, quand l'article 16.4 du présent CLUF s'applique ;

ABBYY Software House Ukraine, 31, Degtyarevskaya st., Kiev, Ukraine 03680, quand l'article 16.5 de ce CLUF s'applique ;

et ABBYY Solutions Ltd., Michail Karaoli 2, Egkomi CY 2404, Nicosia, Chypre, dans tous les autres cas.

"Le terme « groupe ABBYY » désigne ABBYY et toutes ses filiales.

Le terme « filiale d'ABBYY » désigne une entité qui, directement ou indirectement, via un ou plusieurs intermédiaires, contrôle ABBYY, est contrôlée par ABBYY ou est sous contrôle commun d'ABBYY.

"Les termes « vous », « votre » et « utilisateur final » désignent et incluent toute personne et/ou entité juridique s’étant procuré le LOGICIEL et pour le compte de qui ce LOGICIEL est utilisé.

Le terme « partenaire d'ABBYY » désigne une entité juridique qui fournit le LOGICIEL et le droit d'utilisation du LOGICIEL conformément à un contrat signé avec ABBYY qui accorde à une telle entité juridique les droits requis pour l'utilisation du LOGICIEL.

1. Octroi de licence

1.1. Sous réserve du respect des termes de ce CLUF, ABBYY vous accorde une licence limitée et non exclusive (la « licence ») couvrant l’installation et l'utilisation de la fonctionnalité du LOGICIEL, y compris les images, photos, animations, composants audio et vidéo, musique, texte et applets intégrés au LOGICIEL, ainsi que la documentation imprimée l'accompagnant et toutes les copies du LOGICIEL, uniquement dans le cadre énoncé ci-dessous. Toutes les conditions énoncées ci-dessous s'appliquent au LOGICIEL dans son ensemble ainsi qu'à tous ses composants.

1.2. Lorsque le paragraphe 15.4 s'applique et que vous êtes une entité juridique, vous n'êtes autorisé à utiliser le LOGICIEL qu'au sein du pays dans lequel vous êtes enregistré, sauf dispositions contraires prévues dans le cadre d'un autre contrat signé entre vous-même et ABBYY.

2. Licence

2.1. ABBYY agit en tant que représentant, garant et détenteur de tous les droits, de la capacité juridique et de l'autorité d'attribution de licences et de distribution du LOGICIEL, y compris pour les images, les photos, les animations, les composants audio et vidéo, la musique, le texte et les applets inclus dans le LOGICIEL, ainsi que pour les documents imprimés qui l'accompagnent et toutes les copies du LOGICIEL.

2.2. Tous les droits relatifs au titre et à la propriété intellectuelle du LOGICIEL et du contenu externe au LOGICIEL, mais pouvant être consultés à partir de ce dernier, appartiennent aux propriétaires des contenus respectifs et peuvent être protégés par copyright ou d’autres lois et traités sur la propriété intellectuelle. Ce CLUF ne porte pas sur le transfert de propriété d’une telle propriété intellectuelle.

2.3. Le LOGICIEL contient des secrets industriels et des informations confidentielles qui sont la propriété d'ABBYY et de tierces parties. Il est protégé par les lois du copyright, qui incluent, sans s'y limiter, les lois sur les droits d'auteur aux États-Unis et les traités internationaux, ainsi que les lois en vigueur dans le pays où il est utilisé. Toute infraction aux termes et conditions d'utilisation stipulés dans ce CLUF constitue une violation des droits de la propriété intellectuelle d'ABBYY et un motif de résiliation de tous les droits d'utilisation du LOGICIEL, octroyés par ce CLUF.

2.4. Vous reconnaissez savoir que le LOGICIEL est protégé contre la copie non autorisée et l'utilisation illimitée, et qu'il peut contenir des clés de protection logicielles ou matérielles (ci-après appelées « clés de licence ») à cet effet, et vous acceptez que le LOGICIEL soit soumis à toutes ces protections.

2.5. La portée de la Licence peut varier en fonction de différents facteurs, définis lors de la commande du LOGICIEL : l'ensemble de fonctions disponibles, le nombre et le type de composants Logiciel autorisés en réseau, le nombre de processeurs utilisés par le LOGICIEL, le nombre maximal de pages pouvant être traitées, la date d'expiration et d'autres facteurs encore. Toutes ces informations, ainsi que d'autres, sont codées dans la clé de licence. La clé de licence restreint l'utilisation du LOGICIEL techniquement et reflète la portée de la licence que vous avez commandée.

2.6. Vous êtes autorisé à effectuer un transfert unique et définitif de ce CLUF et du LOGICIEL directement à un autre utilisateur final. Ce transfert doit inclure l'intégralité du LOGICIEL (y compris tous les composants, supports, matériaux imprimés et mises à niveau de ce LOGICIEL, et le présent CLUF). Ce transfert ne peut s'effectuer par voie de consignation ni par aucun autre mode de transfert indirect. Le bénéficiaire de ce transfert unique doit accepter de se conformer aux termes du présent CLUF, notamment à l'obligation de ne pas transférer à son tour ce LOGICIEL. Vous devez désinstaller le LOGICIEL de tous les ordinateurs sur lesquels il était installé en cas de transfert du LOGICIEL.

2.7. Excepté les indications mentionnées à l'article 2.6, vous n'êtes pas autorisé à transférer ou à distribuer à une autre personne le LOGICIEL, ni les droits qui vous sont octroyés dans le cadre du présent contrat, ni aucun autre droit lié au LOGICIEL. ABBYY est autorisé à mettre fin à ce CLUF en cas d'un tel transfert ou d'une telle distribution.

2.8. Ce CLUF ne vous octroie aucun droit relatif aux marques déposées d’ABBYY.

2.9. Clause de réserve de propriété Tous les droits non expressément octroyés sont réservés par ABBYY.

3. Utilisation du LOGICIEL

3.1. Vous pouvez utiliser le LOGICIEL conformément à la portée de votre licence.

3.2. Vous pouvez installer le LOGICIEL sur un nombre illimité d'ordinateurs.

3.3. Vous pouvez exécuter simultanément autant de copies du LOGICIEL que la portée de votre licence le permet.

3.4. Si vous accédez au LOGICIEL par l'intermédiaire de services de terminal, qui permettent l'accès au LOGICIEL sur un ordinateur distant du réseau, vous pouvez exécuter simultanément autant de copies du LOGICIEL que ce qu'autorise votre Licence et que ce que stipule ce CLUF.

3.5. Vous ne pouvez utiliser le LOGICIEL pour assurer des services de reconnaissance et de conversion et/ou pour fournir le résultat de l'utilisation de ce LOGICIEL à des tiers que si le paramètre « Services BPO » de votre clé de licence est activé.

3.6. Si la mention « ?Évaluation » ou « Revente interdite » figure sur le LOGICIEL, nonobstant les autres dispositions du présent CLUF, vous ne pourrez utiliser le LOGICIEL qu'à des fins de démonstration ou de test. Vous reconnaissez que les fonctionnalités et/ou l'exécution du LOGICIEL sont limitées pendant une période donnée. Si la version de votre LOGICIEL a expiré, ses fonctionnalités seront désactivées après une période déterminée, conformément à la portée de votre licence.

3.7. Vous n'êtes pas autorisé à exécuter ou à permettre à d'autres personnes d'exécuter les opérations répertoriées ci-dessous :

3.7.1. Effectuer des opérations de rétrotechnique, désassembler et/ou décompiler (extraire le code source du code objet) les programmes, les bases de données et autres composants LOGICIEL, sauf dans la mesure expressément autorisée par la loi indépendamment de cette limitation. Si la loi autorise de telles activités, toute information découverte de cette façon ne doit pas être divulguée à des tiers, si une telle clause de non-divulgation est autorisée par la loi, mais doit être communiquée immédiatement à ABBYY. De telles informations sont considérées comme des informations confidentielles et appartenant à ABBYY.

3.7.2. Modifier le LOGICIEL, adapter (procéder à des modifications sur le logiciel visant à le faire fonctionner sur le matériel de l'utilisateur final) ou traduire le LOGICIEL, y compris procéder à des modifications du code objet des applications et des bases de données du LOGICIEL, autres que celles fournies à cet effet par le LOGICIEL et décrites dans la présente documentation.

3.7.3. Louer, concéder en location-vente ou sous sous-licence, attribuer ou transférer tout droit qui vous a été accordé par le présent CONTRAT et tout autre droit relatif au LOGICIEL à toute autre personne, ni autoriser la copie intégrale ou partielle du LOGICIEL sur l'ordinateur d'un autre utilisateur, à l’exception des stipulations d'un autre contrat signé avec ABBYY.

3.7.4. Permettre à toute personne non autorisée d'utiliser le LOGICIEL et de travailler sur le même système multi-utilisateurs que vous pour utiliser le LOGICIEL.

3.7.5. Supprimer, changer ou rendre illisibles tous copyright, marque déposée ou notes de brevet apparaissant dans le LOGICIEL tel qu’il vous a été livré.

4. LOGICIEL fourni sur deux supports

4.1. Il se peut que le LOGICIEL soit fourni sur plusieurs supports, notamment via des téléchargements sur Internet. Quel que soit le nombre de supports reçus, la licence ne vous autorise à utiliser que le LOGICIEL visé par ce CLUF.

5. Limitations

5.1. Vous reconnaissez savoir que le LOGICIEL est protégé contre la copie et/ou l’utilisation non autorisée(s). Si vous n'activez pas le LOGICIEL, vous risquez de ne pas pouvoir exercer vos droits d'utilisation du LOGICIEL, comme prévu par ce CLUF.

5.2. Les conditions d'utilisation et les limitations régissant l'utilisation du LOGICIEL sont énoncées dans ce CLUF, sauf stipulation contraire dans un accord distinct avec ABBYY.

6. Bases de données de l'utilisateur final

6.1. Vous pouvez créer vos propres bases de données pour les programmes figurant dans le LOGICIEL, si cette fonctionnalité est incluse dans le LOGICIEL et décrite dans la présente documentation.

7. Redistribution du LOGICIEL

7.1. Toute redistribution du LOGICIEL, sauf exception stipulée dans l’article 2.6, est strictement interdite. La redistribution inclut, sans s'y limiter, l'octroi d'accès à des tierces parties, la location, la location-vente ou le prêt du LOGICIEL.

8. Maintenance et support technique

8.1. ABBYY ou son partenaire assure les services de maintenance et de support technique prévus conformément aux termes et conditions de l'Annexe A de ce CLUF, sauf accord contraire conclu entre vous et ABBYY ou entre vous et le partenaire d'ABBYY.

9. Garantie limitée

9.1. Sous réserve d'une utilisation normale, ABBYY garantit que les supports sur lesquels le LOGICIEL est fourni, le cas échéant, sont exempts de défauts matériels ou malfaçons pendant la période minimale définie par la législation du pays où le LOGICIEL a été acheté et à compter de la date d'achat. Si le LOGICIEL est acheté conformément à l'article 15.4, cette période correspond à trente (30) jours à compter de la date d'achat.

9.2. Le LOGICIEL et toute mise à jour et mise à niveau vous sont fournis « en l'état » et ABBYY n'offre aucune garantie d'aucune sorte. ABBYY ne garantit pas et n'est pas en mesure de garantir les performances ni les résultats obtenus par l’utilisation du LOGICIEL. À l’exception de tout(e) garantie, condition, représentation ou terme dans la mesure où celui/celle-ci ne peut pas être exclu(e) ni limité(e) par la loi en vigueur dans votre juridiction, ABBYY et ses partenaires n’offrent aucune garantie, condition, représentation ni terme (expresse ou implicite, que ce soit par droit statutaire, légal, coutumier, d’usage ni autre) d’aucune sorte, y compris et de manière non limitative, de non-transgression des droits des tiers, de commercialisation, d’intégration, de qualité satisfaisante ou d’adéquation à un objectif particulier, et ne garantissent pas que le LOGICIEL soit exempt d’erreurs, répondra à vos besoins ou que le LOGICIEL fonctionnera correctement en cas d’utilisation avec d’autres logiciels ou éléments matériels. Tous risques afférents à la qualité et aux performances du LOGICIEL vous incombent entièrement.

9.3. ABBYY n’offre aucune garantie vis-à-vis des produits logiciels tiers fournis avec le LOGICIEL.

10. Limites de responsabilité

10.1. ABBYY ne saurait en aucun cas être tenu pour responsable des dommages, de l’interruption d’une activité commerciale, de la perte d’informations commerciales ou autres, de toute réclamation ou dépense, ni de dommages conséquents, indirects, incidents d’aucune sorte, de toute perte de bénéfices consécutive ou liée à l’utilisation du LOGICIEL, de dommages causés par d’éventuelles erreurs (d’impression, par exemple) dans le LOGICIEL, même dans l’éventualité où un représentant d’ABBYY aurait été prévenu par un tiers de la possibilité de tels pertes, dommages, réclamations ou dépenses. Les limitations et exclusions précédentes s’appliquent dans la limite autorisée par la loi en vigueur dans votre juridiction. La seule et entière responsabilité d’ABBYY dans le cadre du présent CLUF ou associée au présent CLUF sera limitée au montant versé (le cas échéant) lors de l’achat du LOGICIEL. Pour plus d'informations, veuillez consulter les informations spécifiques à votre juridiction dans l'article 15 du présent CLUF.

10.2. Limites de responsabilité pour les utilisateurs résidant en Allemagne ou en Autriche.
Si vous vous êtes procuré le LOGICIEL en Allemagne ou en Autriche, et que vous résidez dans l'un de ces pays :

10.2.1. Conformément aux dispositions de l'article 10.2.2, la responsabilité statutaire d'ABBYY vis-à-vis des dommages sera limitée de la manière suivante : (i) ABBYY ne sera tenu responsable que des dommages raisonnablement prévisibles lors de l’entrée d’entente d’achat contractuelle en matière de dommages causés par une légère violation par négligence d’une obligation contractuelle relative au matériel mais (ii) ABBYY ne sera pas tenu responsable des dommages causés par une légère violation par négligence d’une obligation contractuelle non liée au matériel.

10.2.2. La limitation de responsabilité stipulée à l’article 10.2.1 ne sera pas applicable aux responsabilités statutaires obligatoires, en particulier, à la responsabilité entrant dans le cadre du droit allemand de la responsabilité du fait des produits (German Product Liability Act), à la responsabilité liée à la prise en charge d’une garantie spécifique ou à la responsabilité des blessures corporelles infligées de manière volontaire.

10.2.3. Vous prendrez toutes les mesures raisonnables afin d’éviter ou de minimiser tout dommage, notamment de réaliser des copies de sauvegarde du LOGICIEL et de vos données informatiques entrant dans le cadre des dispositions de ce CLUF.

11. Polices intégrées

11.1. Les programmes de polices sont soumis aux droits d'auteur et le propriétaire est en droit de fixer les conditions d'utilisation de tels programmes. Une des dites conditions peut éventuellement exiger la possession d'une copie sous licence du programme de police pour incorporer la police dans un fichier PDF. En aucun cas, la société ABBYY ne sera tenue responsable des dommages résultant de l'utilisation des polices incorporées ou associés à celle-ci d'une quelconque manière.

12. Adobe® PDF Library

12.1. Le terme « logiciel Adobe » désigne Adobe PDF Library® pour les systèmes Windows 2000, XP ainsi que toute documentation, mise à niveau, version modifiée, mise à jour, copie et tout ajout y afférent. Le LOGICIEL utilise le logiciel Adobe pour convertir des fichiers PDF en fichiers d'images.

12.2. Octroi de licence et restrictions. ABBYY octroie un droit non exclusif vous autorisant à utiliser le Logiciel Adobe incorporé au LOGICIEL, en conformité avec les termes du présent Accord de licence d'utilisateur final. Vous pouvez effectuer une copie de sauvegarde du logiciel Adobe incorporé au LOGICIEL, dans la mesure où la copie de sauvegarde n'est pas destinée à être installée ou utilisée sur un autre ordinateur.

12.3. Droits relatifs à la propriété intellectuelle. Le logiciel Adobe incorporé au LOGICIEL est la propriété d'Adobe ou de ses fournisseurs, et sa structure, son organisation et son code constituent des secrets industriels précieux d'Adobe et de ses fournisseurs. Le logiciel Adobe est également protégé par les lois sur les droits d'auteur aux États-Unis et par les traités internationaux. Toute copie du logiciel Adobe incorporé au LOGICIEL, sauf tel qu'expressément prévu dans ce CLUF, est prohibée. Toute copie autorisée effectuée conformément aux termes de ce CLUF doit inclure le présent avertissement relatif à la propriété intellectuelle ainsi que tout autre avis de propriété apparaissant dans le LOGICIEL. Vous vous engagez à ne pas modifier, adapter, traduire, effectuer d'opération de rétrotechnique, décompiler, désassembler ni essayer de découvrir le code source du logiciel Adobe incorporé à ce LOGICIEL. Sauf tel qu'expressément spécifié auparavant, ce CLUF ne vous octroie aucun droit de propriété intellectuelle sur le Logiciel Adobe.

12.4. Licence pour les polices. Si le LOGICIEL ou le logiciel Adobe incorporé inclut un logiciel de polices, vous êtes autorisé à incorporer ce logiciel ou le logiciel des caractères vectorisés dans vos documents au format électronique, dans la mesure expressément autorisée par le propriétaire du copyright des polices. Certaines polices contenues dans ce produit peuvent être la propriété d'Adobe. Vous pouvez incorporer toute police dont Adobe est le propriétaire.

12.5. Garantie. ABBYY NE GARANTIT PAS ET N'EST PAS EN MESURE DE GARANTIR LES RÉSULTATS DE PERFORMANCES CONSÉCUTIVES À L'UTILISATION DU LOGICIEL ADOBE INCORPORÉ AU PRÉSENT LOGICIEL.

12.6. Règles sur l'exportation. Vous vous engagez à ne pas expédier, transférer ni exporter le logiciel Adobe incorporé à votre LOGICIEL vers quelque pays que ce soit, ni à l'utiliser en infraction à la législation des États-Unis régissant les exportations ou à toute autre loi, restriction ou réglementation sur l'exportation (collectivement «Lois sur l'exportation»). En outre, si le logiciel Adobe incorporé au LOGICIEL est identifié en tant que produit d'exportation contrôlé par les Lois sur l'exportation, vous devez certifier et prouver que vous n'êtes ni citoyen ni résident d'un pays soumis à un embargo commercial et qu'aucune loi sur l'exportation ne vous interdit la réception du logiciel Adobe incorporé au LOGICIEL. Le droit d'utiliser le logiciel Adobe incorporé au LOGICIEL vous est accordé dans la mesure où vous vous conformez aux termes de ce CLUF. Vous serez déchu de ce droit si vous enfreignez cette condition.

12.7. Marques déposées. Adobe et Adobe PDF Library sont des appellations commerciales ou des marques déposées d'Adobe Systems Incorporated aux États-Unis et dans d'autres pays.

13. Bibliothèques d'exécution PixTools® Scan.

13.1. Le terme « logiciel EMC » désigne les bibliothèques d'exécution PixTools Scan et les pilotes ISIS de niveaux 1, 2 et 3. Le LOGICIEL utilise le logiciel EMC pour communiquer avec le scanner et le LOGICIEL par l'intermédiaire de l'interface ISIS.

13.2. Octroi de licence et restrictions. ABBYY octroie un droit non exclusif vous autorisant à utiliser le logiciel EMC incorporé au LOGICIEL, conformément aux termes du présent CLUF.

13.3. Droits relatifs à la propriété intellectuelle. Le logiciel EMC incorporé au LOGICIEL est la propriété d'EMC Corporation ou de ses fournisseurs, et sa structure, son organisation et son code constituent des secrets industriels précieux d'EMC Corporation et de ses fournisseurs. Le logiciel EMC est protégé par les lois sur les droits d'auteur aux États-Unis et par les traités internationaux. Vous n'êtes pas autorisé à copier le logiciel EMC incorporé à ce LOGICIEL. Vous vous engagez à ne pas modifier, adapter, traduire, effectuer d'opération de rétrotechnique, décompiler, désassembler ni essayer de découvrir le code source du logiciel EMC incorporé à ce LOGICIEL. Sauf tel qu'expressément spécifié auparavant, ce CLUF ne vous octroie aucun droit de propriété intellectuelle sur le Logiciel EMC.

13.4. Garantie.
ABBYY NE GARANTIT PAS ET N'EST PAS EN MESURE DE GARANTIR LES ?RÉSULTATS DE PERFORMANCES CONSÉCUTIFS À L'UTILISATION DU LOGICIEL EMC INCORPORÉ AU PRÉSENT LOGICIEL.
EMC CORPORATION ?OU SES FOURNISSEURS NE POURRONT EN AUCUN CAS ÊTRE TENUS POUR RESPONSABLES DE TOUT DOMMAGE DIRECT, ACCESSOIRE OU SPÉCIAL D'AUCUNE SORTE, DE TOUTE PERTE DE BÉNÉFICES NI DE PLAINTE ÉMANANT D'UN TIERS.
Certains états ou juridictions n'autorisent pas l'exclusion ni la limitation des dommages accessoires, directs ou spéciaux. Il est donc possible que les limitations ci-dessus ne s'appliquent pas à vous. Vous pouvez bénéficier d'autres droits, qui peuvent varier d'un état à l'autre ou d'une juridiction à l'autre.

13.5. Appellations commerciales.
ISIS et PixTools sont des appellations commerciales ou des marques déposées d'EMC Corporation aux États-Unis et/ou dans d'autres pays.

14. Règles sur l'exportation

14.1. Le LOGICIEL ne doit pas être exporté ni ré-exporté si une telle exportation engendre la violation des dispositions juridiques en matière d’exportation du pays dans lequel ce LOGICIEL a été acheté ou autrement obtenu. En outre, vous déclarez et garantissez ne pas être interdit de recevoir ce LOGICIEL dans le cadre des lois en vigueur.

15. Droit applicable

15.1. Si le LOGICIEL a été acheté aux États-Unis, au Canada, au Mexique, en Amérique Centrale, au Japon ou à Taïwan, ce CLUF sera régi et interprété selon la loi en vigueur dans l'État de Californie (États-Unis). Quant aux litiges qui pourraient résulter de ce CLUF et/ou de ce LOGICIEL, vous acceptez de vous soumettre aux lois et aux juridictions fédérales et/ou aux cours d'état du comté de Santa Clara, dans l'état de Californie.

15.2. Si le LOGICIEL a été acheté en Autriche, en Belgique, au Danemark, en Finlande, en France, en Allemagne, en Grèce, en Italie, au Luxembourg, aux Pays-Bas, au Portugal, en Espagne, en Suède ou dans tout autre État membre de l'Union européenne non mentionné à l'article 15.3 ou 15.4 de ce CLUF, ou bien dans les îles de la Manche, en Islande, au Liechtenstein, en Norvège ou en Suisse, ce CLUF sera régi et interprété conformément à la législation de Munich, Allemagne.

15.3. Si le LOGICIEL a été acheté au Royaume-Uni de Grande Bretagne et d'Ireland du Nord ou en république d'Irlande, le présent CLUF est alors régi et interprété conformément à la législation en vigueur en Angleterre et aux Pays de Galles et les parties acceptent de se soumettre aux juridictions d'Angleterre et du Pays de Galles

15.4. Si le LOGICIEL a été acheté en Russie, en Biélorussie, au Kazakhstan ou dans tout autre pays de la CEI, à l'exception de l'Ukraine et de la Moldavie, ou si le LOGICIEL a été acheté en Lettonie, Lituanie ou en Estonie, ce CLUF sera régi et interprété conformément à la législation de la Fédération de Russie.

15.5. Si le LOGICIEL a été acheté en Albanie, en Bosnie-Herzégovine, en Bulgarie, en Croatie, en République Tchèque, en Hongrie, en Israël, en Macédoine, en Pologne, en Roumanie, en Slovaquie, en Slovénie, en Turquie, en Serbie, au Monténégro, en Ukraine ou en Moldavie, ce CLUF est soumis à la législation de l'Ukraine.

15.6. Si l'article 15.4 est appliqué et si vous êtes une entité juridique ou un entrepreneur privé, la cour d'arbitrage de Moscou, Fédération de Russie, aura la juridiction sur tous les litiges en rapport avec ce CLUF. Si l'article 15.4 est appliqué et si vous êtes un particulier, la cour du district de Perovsky, Moscou, Fédération de Russie, aura la juridiction sur tous les litiges en rapport avec ce CLUF.

15.7. Si l'article 15.5 s'applique et si vous êtes une entité juridique ou un entrepreneur privé, tout(e) litige, controverse ou divergence d'opinion résultant ou en rapport avec le CLUF sera résolu(e) par l'arbitrage conformément aux règles et procédures d'arbitrage de l'arbitrage commercial international de la Chambre de commerce et de l'industrie d'Ukraine. L'arrêt prononcé par ce Tribunal est définitif et engage les deux parties. Si l'article 15.5 est appliqué et si vous êtes un particulier, la cour du district de Shevchenkovsky de Kiev, Ukraine aura la juridiction sur tous les litiges en rapport avec ce CLUF.

15.8. Ce CLUF ne sera pas régi par la législation sur les conflits de lois en vigueur dans une quelconque juridiction, ni par la convention des Nations unies sur les contrats relatifs au commerce international de biens, qui ne saurait s'appliquer à la présente licence.

15.9. Si vous avez acheté le LOGICIEL dans un pays non spécifié aux articles 15.1, 15.2, 15.3, 15.4, 15.5, ce CLUF est soumis à la législation des tribunaux du pays d'achat du LOGICIEL.

16. Termes et résiliation

16.1. Ce CLUF entre en vigueur à la Date d'entrée en vigueur. Sauf accord contraire passé entre vous et ABBYY, ou sauf dispositions contraires prévues dans le cadre du présent CLUF, ce dernier est applicable pour toute la durée du copyright du LOGICIEL.

16.2. Vous pouvez le résilier en détruisant le LOGICIEL et la documentation qui l’accompagne, ainsi que toute copie y afférente.

16.3. Sans préjudice de tous autres droits, ABBYY peut résilier le présent CLUF si vous n'en respectez pas les termes et conditions. Dans pareil cas, vous devez détruire toutes les copies du LOGICIEL et tous les composants du LOGICIEL. Une telle résiliation ne vous décharge pas de votre obligation de régler le montant du LOGICIEL et/ou de la maintenance.

16.4. Les dispositions 2.3, 2.8, 2.9, 3.7, 7, 9.2, 9.3, 10, 15, 18.2, 18.3 subsistent après la résiliation du présent CLUF quelle qu'en soit la cause; toutefois, ceci n'implique pas ni ne maintien le droit d’utiliser le LOGICIEL après la résiliation de ce CLUF.

17. Utilisation gouvernementale

17.1. Si le Gouvernement des États-Unis ou une quelconque agence gouvernementale américaine est titulaire d'une licence de ce LOGICIEL, les conditions supplémentaires suivantes s'appliquent : (1) le LOGICIEL est classé «Restricted Computer Software», tel que défini dans la clause 52.227-14 «Rights in Data-General» des Federal Acquisition Regulations; et (2) toute utilisation, reproduction ou divulgation par le Gouvernement américain est soumise aux restrictions figurant dans le sous-paragraphe (c)(1)(ii) de la clause DFARS 252.227-7013 «Rights in Technical Data and Computer Software».

18. Dispositions d'ordre général

18.1. Si une partie de ce CLUF est considérée non avenue et non exécutoire, cela n'aura aucune incidence sur la validité de l'ensemble du CLUF, qui conservera sa force exécutoire conformément aux conditions prescrites. Ce CLUF ne portera pas préjudice aux droits statutaires de toute partie impliquée en tant que consommateur.

18.2. Vous vous engagez à fournir à ABBYY certaines informations personnelles au cours de l'activation, de l'installation et de l'enregistrement du LOGICIEL. Vous acceptez que vos informations personnelles puissent être collectées, traitées et utilisées par ABBYY, conformément à la loi applicable prévoyant que la confidentialité des données soit maintenue. Toute information personnelle que vous fournissez à ABBYY sera stockée et utilisée strictement au sein du groupe ABBYY et ne sera divulguée à aucun tiers à moins que cela ne soit exigé par la loi applicable.

18.3. ABBYY peut vous envoyer des courriers électroniques contenant des communications sur le produit et la société, sur des offres spéciales, des conseils d'utilisation des produits et des informations relatives à la société, à condition que vous ayez accepté de recevoir de telles informations de la part D'ABBYY. Vous pouvez, si vous le souhaitez et à tout moment, retirer votre adresse de la liste de distribution d'ABBYYY.

18.4. ABBYY peut vous fournir des documents imprimés, y compris le guide d'utilisation.

18.5. La contrepartie prévue pour ce CLUF est le prix du ??LOGICIEL établi par ABBYY ou l'un de ses partenaires payable conformément aux procédures de paiement mises en œuvre par ABBYY ou par le partenaire d'ABBYY, ou inclus dans le prix d'achat de votre matériel, ou encore, faisant partie de la contrepartie payable par vous-même pour la version complète du LOGICIEL. Si vous êtes un particulier, il se peut que ce CLUF soit gratuit.

18.6. Si toute plainte ou toute poursuite est engagée contre vous en rapport avec une utilisation du LOGICIEL, vous devez en informer ABBYY sous trois (3) jours à compter du moment où vous en avez été averti. Vous devez mener toutes les actions nécessaires pour donner à ABBYY la possibilité de prendre part aux audiences desdites plaintes ou poursuites au tribunal et pour fournir les informations nécessaires au règlement des plaintes ou poursuites correspondantes pas plus tard que sept (7) jours à compter du moment où vous en avez reçu la demande d'ABBYY.

Annexe A

Contrat de maintenance

L'Annexe A fait partie intégrante du CLUF, sauf mention contraire dans un contrat séparé signé avec ABBYY.

1. Définitions

1.1.Le terme « mise à jour » désigne des améliorations apportées à la version actuelle du LOGICIEL, qui incluent généralement la résolution des bogues.

1.2. Le terme « mise à niveau » désigne la version suivante du LOGICIEL destinée à remplacer la version majeure ou mineure (par exemple, la version 1.5 remplace la version 1.0, la version 2.0 remplace la version 1.x) qui vous est actuellement concédée sous licence dans le cadre du CLUF.

1.3. Le terme « Erreur » désigne l'incapacité du LOGICIEL à fonctionner conformément aux spécifications répertoriées dans la documentation. Trois types d'erreurs peuvent être distingués :

1.3.1. Une erreur de priorité 1 désigne une situation problématique pour laquelle aucune solution n'est disponible pour vous, et à cause de laquelle la production de votre site est bloquée. Parmi les erreurs de ce type, citons les erreurs intitulées « Erreur de programme interne », « Dépassement de mémoire », « Violation d'accès », « Faute de protection générale », « Erreur de protection générale » et « Division par zéro ».

1.3.2. Une erreur de priorité 2 désigne un dysfonctionnement pour lequel il existe une solution.

1.3.3. Une erreur de priorité 3 est un problème mineur qui ne perturbe pas la production de votre site.

1.4. Les « services d'assistance » désignent les services mis à votre disposition par ABBYY ou son partenaire pour les erreurs que vous nous signalez.

1.5. L'« assurance mise à niveau » désigne la partie de la maintenance qui vous octroie le droit de recevoir des mises à niveau.

2. Maintenance

2.1. La maintenance peut inclure la fourniture de mises à jour, d'une assurance mise à niveau ou de services d'assistance, ou une combinaison des trois.

2.2. Le terme de la maintenance correspond à la période de départ de douze (12) mois, commençant à la date d'envoi ou de livraison du LOGICIEL.

2.3. Pour étendre la période de maintenance, vous devez faire une demande d'extension auprès d'ABBYY ou de son partenaire. Si l'article 15.2 ou 15.3 s'applique, la maintenance sera renouvelée pour une période de 12 mois, sans autre avis, si vous n'annulez pas le contrat de maintenance dans un délai de 45 jours avant la résiliation de la période de maintenance. Une telle annulation doit être déclarée au préalable par écrit.

2.4. ABBYY ou son partenaire peut mettre à votre disposition des termes et conditions spécifiques de maintenance supplémentaires.

2.5. ABBYY se réserve le droit, à sa seule discrétion, de modifier de temps en temps la forme et le contenu de la maintenance.

2.6. Tout code de LOGICIEL supplémentaire fourni dans le cadre de la maintenance doit être considéré comme faisant partie intégrante du LOGICIEL et est soumis aux conditions générales du présent CLUF.

3. Mises à jour et assurance mise à niveau

3.1. Les mises à niveau et mises à jour peuvent être diffusées sur CD-ROM et/ou par voie électronique (via le protocole FTP). Si des frais d'envois s'appliquent, ils sont à votre charge.

3.2. Si vous avez souscrit l'option de maintenance Livraison de mises à jour, vous pouvez prétendre à recevoir des mises à jour d'ABBYY ou de son partenaire. ABBYY ou son partenaire vous fourniront les mises à jour du LOGICIEL dès qu'elles seront disponibles.

3.3. Si vous avez souscrit l'option de maintenance Assurance mise à niveau, vous pouvez prétendre à recevoir des mises à niveau d'ABBYY ou de son partenaire. ABBYY ou son partenaire vous fourniront les mises à niveau du LOGICIEL dès qu'elles seront disponibles.

3.4. Si vous développez une application qui contient le LOGICIEL ou une partie du LOGICIEL, ou qui est intégrée au LOGICIEL, toute nouvelle version majeure de cette application devra inclure la dernière mise à jour du LOGICIEL, qui vous sera fournie par ABBYY sous trois (3) mois maximum à compter de sa sortie (ou la dernière mise à jour si cette mise à jour est sortie plus de trois (3) mois avant cette sortie).

4. Services d'assistance

4.1. ABBYY ou son partenaire doit assurer des services d'assistance pour résoudre les erreurs de priorité 1.

4.2. Si vous avez souscrit l'option de maintenance Services d'assistance, ABBYY ou son partenaire vous fournira des services d'assistance pour un maximum de huit (8) demandes relatives à des erreurs de priorité 2 ou 3 pour la période de douze (12) mois. De plus, vous pouvez acheter des services d'assistance pour des demandes supplémentaires relatives à des erreurs de priorité 2 et 3 pour la période.

4.3. ABBYY ou son partenaire assurera les services d'assistance liés au LOGICIEL pendant les heures de travail normales, par téléphone ou par courrier électronique.

4.4. ABBYY ou son partenaire s'engage à tout mettre en œuvre commercialement, dans la limite du raisonnable, pour publier des mises à jour d'urgence pour le LOGICIEL en plus des mises à jour normales programmées, pour remédier aux erreurs de priorité 1 qui pourraient lui être signalées. Selon le processus normal, les erreurs de priorité 2 ou 3 sont réparées dans les versions suivantes. Les mises à jour d'urgence ne seront proposées pour la version actuelle du LOGICIELLE que pour résoudre les erreurs de priorité 1.

4.5. Pour signaler les erreurs, vous vous engagez à fournir à ABBYY ou à son partenaire les données techniques requises pour localiser l'erreur et assurer sa résolution. Ces données techniques incluent une description du problème, les références de la plate-forme et du système d'exploitation sur lesquels le problème a eu lieu, une copie des informations entrées qui ont provoqué l'erreur découverte, une copie du fichier, avec le format utilisé quand l'erreur a été découverte, et le résultat affiché par la machine suite à l'erreur s'il y a lieu. Les informations mentionnées ci-dessus pourront être utilisées par ABBYY ou par son partenaire à des fins professionnelles conformément aux lois applicables, notamment, et de façon non exclusive, pour l'assistance produit et le développement. ABBYY ou son partenaire n'utilisera pas ces informations sous une forme qui permettrait de vous identifier personnellement.


Propriétés de base d'un champ

Les propriétés de base d'un champ peuvent être paramétrées dans l'onglet Généralités.

Dans cet onglet, le type de champ est affiché sous forme d'icône à droite du nom.

  • Nom : nom du champ. Le nom est automatiquement affecté lors de la création du champ, et il correspond au texte d'explication le plus proche du champ. Lorsque vous modifiez les propriétés du champ, vous pouvez aussi modifier le nom affecté par défaut. Consultez aussi la section Comment modifier le nom d'un champ.
  • Légende : le nom du champ qui sera affiché dans le formulaire de données.
  • Exporter la valeur du champ : vous devez activer cette option si vous souhaitez exporter la valeur du champ (cette option est activée par défaut). Vous pouvez avoir à désactiver cette option si, par exemple, la valeur de ce champ est utilisée pour obtenir la valeur d'un champ calculé (consultez la section Validation par règle), et si seul le résultat final doit être exporté.
  • Afficher dans le formulaire de données : cette option doit être activée si le champ doit être visible dans le formulaire (elle est activée par défaut).
  • Ne peut pas être vide : activez cette option si vous souhaitez rendre le champ obligatoire.
  • Lecture seule : activez cette option si le champ doit être accessible uniquement en lecture, c'est-à-dire si l'opérateur ne doit pas pouvoir modifier sa valeur. Vous pouvez activer cette option pour les champs dont la valeur doit être calculée automatiquement à l'aide d'une règle, par exemple pour un champ dont vous prévoyez d'enregistrer la somme ou que vous prévoyez de combiner à d'autres champs (consultez la section Validation par règle).
  • Champ d'index : activez cette option si vous prévoyez d'utiliser ce champ pour effectuer une indexation de document. Quand vous traiterez les documents, vous aurez la possibilité d'afficher la valeur de ce champ pour chaque document, et de trier et d'interroger des documents à partir de la valeur du champ.
  • Commentaire : vous pouvez entrer le commentaire de votre choix.

puce Propriétés de champ


Glossary

A

ABBYY FlexiCapture

Solution logicielle permettant d'incorporer en une seule opération des données à partir de différents types de documents – structurés (formulaires fixes), semi-structurés (formulaires et documents flexibles) et non structurés (documents de format libre).

ABBYY FlexiLayout Studio

Programme permettant de créer une description flexible de la structure d'un document, ce qui permet ensuite de reconnaître automatiquement les documents.

ABBYY FormDesigner

ABBYY FormDesigner sert à concevoir des modèles de formulaires lisibles par machine. Une fois répliqués et remplis, ces formulaires peuvent être traités avec le système d'entrée de formulaires automatisé ABBYY FlexiCapture. La conception du modèle de formulaire est une étape importante car la qualité du modèle conçu (sa lisibilité par ordinateur) détermine l'efficacité de toutes les phases de traitement suivantes : la numérisation, la reconnaissance, la vérification et l'exportation.

ADF

Chargeur automatique de documents. Dispositif permettant de charger automatiquement les documents, ce qui permet de numériser un grand nombre de documents sans avoir à intervenir manuellement.

Administrateur

Utilisateur de ABBYY FlexiCapture qui est autorisé à configurer le programme pour l'entrée de documents : il peut créer et modifier des Définitions de Document, et importer des profils.

Alphabet

Ensemble de caractères utilisés dans la langue décrite.

Ancre

Élément statique sous forme de carré, de rectangle, de croix ou de coin noirs, servant pour l'association de la définition de document. Détails...

Les ancres sont des éléments spéciaux de conception de formulaire utilisés par le système pour effectuer des associations après avoir numérisé (élimination de l'inclinaison, compensation des défauts, linéaires ou non, de la numérisation, calcul de l'emplacement des blocs). Les ancres les plus fiables sont des carrés noirs, qui sont normalement situés dans les coins d'un formulaire. Si aucune ancre spéciale n'est présente sur l'image, d'autres éléments statiques peuvent être utilisés pour associer la Définition de Document : des séparateurs, c'est-à-dire des lignes horizontales, telles que des lignes de tableau, des cadres, etc., ou du texte statique transparent, à savoir : l'en-tête de formulaire, les signatures de champs, les informations d'explication, etc. L'option Utiliser pour l'association de la définition de document doit être activée pour les éléments statiques utilisés pour l'association de la définition des documents.

Angle

Ancre en forme d'angle.

Annexe

Ensemble de pages qui ne contiennent pas de champs mais sont incluses dans l'assemblage du document. Aucune donnée n'est extraite de ces pages, mais ces pages peuvent être enregistrées sous forme d'images ou de fichiers PDF indexés. Consultez la section Créer des définitions de document pour des documents avec des annexes.

Association de la définition de document

Opération consistant à sélectionner une définition de document et à associer ses champs à une image.

C

Caractère ignoré

Caractère apparaissant au sein d'un mot (par exemple, une puce), ou caractère à tiret conditionnel (tabulation, etc.) dont la présence n'empêche pas le programme d'attribuer le mot à un type de données reconnaissable. Détails...

Les caractères de ce type sont exclus des mots. En d'autres termes, les mots sont attribués à un type de données particulier sans ces caractères.

Caractère interdit

Caractère dont vous êtes certain qu'il n'interviendra pas dans les données à reconnaître. Détails...

En spécifiant des caractères de ce type, vous pouvez accroître considérablement la vitesse et la qualité de la reconnaissance. Par exemple, pour reconnaître des textes qui ne contiennent que des majuscules, faites de toutes les minuscules des caractères interdits.

Caractères reconnus incorrectement

Statut affecté automatiquement à un caractère qui, au cours du processus de reconnaissance, a été reconnu avec un degré d'incertitude considérable.

Carré noir

Ancre en forme de carré noir.

Champ

Élément de document destiné à l'extraction de données. Un champ peut être simple (sans structure interne) ou composite, comme un champ de tableau, où chaque cellule peut être affichée sous forme de champ subordonné du tableau. Consultez la section Création de champs dans une définition de document.

Champ clé

Champ qui permet de vérifier automatiquement l'assemblage des pages dans les documents. Les champs clés doivent avoir la même valeur sur toutes les pages d'un même document.

Champ contenant plusieurs instances

Champ utilisé pour décrire plusieurs objets du même type (objets récurrents). Par nature, ces objets multiples constituent un seul et même champ, et ils partagent les mêmes propriétés. Les champs contenant plusieurs instances servent à éviter de créer plusieurs champs identiques. Ils sont exportés dans des fichiers ou tables de base de données différents. Consultez la section Champs avec plusieurs instances.

Champ contenant plusieurs régions

Champ composé de plusieurs régions de l'image. Ces régions peuvent être éloignées les unes des autres, et même être placées sur des pages différentes. Les valeurs de l'ensemble des régions appartenant au même champ sont combinées et exportées ensemble sous la forme d'un même champ. Ce type de champ est en principe utilisé pour des objets placés sur plusieurs pages, comme des tableaux particulièrement longs. Consultez la section Champ contenant plusieurs régions.

Champ d'entrée manuelle

Champ de définition de document contenant du texte non reconnaissable (par exemple, du texte composé de lettres qui se chevauchent) qui n'a pas été entré à l'aide d'un clavier.

Champ d'image

Champ de définition de document contenant une image.

Champ d'index

Champ dont la valeur est utilisée pour indexer les documents, afin de faciliter les opérations de tri et de recherche. Consultez la section Champs d'index.

Champ de coche

Champ de définition de document contenant une coche.

Champ de code barre

Champ de définition de document contenant un code barres destiné à être reconnu.

Champ de groupe de coches

Champ de définition de document contenant un groupe de coches.

Champ de texte

Élément de formulaire lisible par machine conçu pour entrer du texte lors du remplissage d'un formulaire.

Champ sans région

Champ détecté dans une définition de document mais qui ne comporte pas de région dans l'image. Consultez la section Champs sans région.

Champ tableau

Champ de définition de document contenant un tableau. C'est un champ composite, dans lequel chaque colonne de tableau représente un jeu de champs du même type : texte, coches, codes barres ou images.

Checkmark

Élément de formulaire lisible par machine rempli d'une marque (biffure, croix, point, retouche, etc.) par la personne qui remplit le formulaire.

Classifieur

Projet créé sous FlexiLayout Studio et destiné à une identification préliminaire des pages avant l'application des définitions de document ainsi qu'à la sélection d'un projet FlexiLayout ou de l'alternative de mise en page associé.

Coche corrigée

Coche qui a été sélectionnée par erreur, puis retouchée. Si l'option Autoriser les corrections est active pour le champ de coche, le programme reconnaît la coche retouchée comme non sélectionnée.

Code barre

Formulaire lisible par machine, constitué d'une alternance de barres blanches et noires d'une certaine longueur, qui encodent des informations numériques. Dans un document, un code barres peut servir à extraire des informations (champ de code barres) ou à associer et identifier une définition de document (code barres d'ancre).

Code barre d'ancrage

Élément statique représentant un code barre, et qui n'est pas destiné à l'extraction de données. Un code barre d'ancrage peut être utilisé pour l'association ou l'identification de Définition de document.

Contraste

Rapport mathématique entre les zones les plus claires et les plus sombres d'une image.

Croix

Ancre en forme de croix.

D

Définition de documents

Une définition de document définit les principes d'identification et de traitement de ce type de document, et contient :

  • La structure du document, c'est-à-dire la description de l'ordre autorisé pour les pages formant le document de ce type. La structure du document définit la règle d'assemblage du document.
  • Les définitions de sections de documents.
  • La liste des règles qui doivent être satisfaites par les données des champs.
  • L'emplacement des champs et leurs signatures dans la fenêtre de données (dans une vue de formulaire de données).
  • Les paramètres d'exportation pour ce type de document.
  • Les paramètres de traitement pour ce type de document.

Définition de document fixe

Définition de document, ou sa section, destinée au traitement de formulaires fixes. Les champs d'une définition de document fixe ont des emplacements fixes.

Définition de document flexible

Définition de document, ou sa section, destinée au traitement de formulaires flexibles. Un tel modèle est créé à l'aide d'une description flexible. Les champs d'une telle définition de document n'ont pas d'emplacement fixe. Ils sont détectés à l'aide d'une description flexible. Consultez la section Création d'une définition de document pour traiter des documents flexibles.

Description flexible

Description formalisée de la structure du document. Elle est destinée à faciliter la détection des champs. Elle est créée à l'aide d'ABBYY FlexiLayout Studio. Format de fichier : *.afl. Consultez la section FlexiLayout.

Dictionnaire

Liste de mots utilisés pour déterminer un type de données spécifique. Détails...

Un dictionnaire est spécifié lors de la création d'un type de données. En conséquence, le type de données associé à un champ détermine le dictionnaire utilisé pendant la reconnaissance et la vérification. Outre les types de données prédéterminés existants, associés à des dictionnaires prêts à l'emploi, le programme permet d'associer des types de données créés à partir de dictionnaires personnalisés. Vous pouvez saisir les données de dictionnaire manuellement ou les charger à partir d'un fichier.

Document

Combinaison d'une ou de plusieurs images de pages et de données extraites à partir de ces images.

Document de plusieurs pages

Document composé de plusieurs pages.

Document non structuré

Document contenant des informations présentées sous une forme libre. Il peut s'agir d'un contrat, d'une lettre, d'une commande ou d'un graphique, par exemple. Consultez la section Traitement de documents non structurés.

Documents semi-structurés.

Document contenant un ensemble de champs d'information dont la conception, le nombre et la présentation peuvent varier significativement dans différentes instances du document. Consultez la section Types de documents traités avec ABBYY FlexiCapture 9,0.

Données de document

Données acquises après le traitement (reconnaissance, vérification et modification des résultats de reconnaissance) des images de pages de document.

Dossier d'images

Dossier du disque dur de l'ordinateur local ou d'un ordinateur distant qui sert à importer des images. Ce dossier est en principe utilisé pour télécharger périodiquement des images récurrentes sans que l'utilisateur intervienne. Consultez la section Profils d'importation d'images.

E

Éléments statiques

Éléments non reconnaissables destinés à l'association et à l'identification de la définition de document. Ces éléments sont : les ancres, le texte d'ancre, les séparateurs et les codes barres d'ancre.

Entrée de documents sous forme de flux unique

Conversion automatique de documents au format papier sous une forme électronique.

Entrée de données sous forme de flux unique

Extraction automatique de données à partir de documents analogiques (imprimés) et numériques (images numérisées).

Entrée de formulaire

Acquisition de données provenant des champs d'information de formulaires.

Erreur de document

Si, lors du traitement d'un document, il apparaît que les données de ce document ne correspondent pas parfaitement à la structure du document, à ses contraintes de valeur ou à ses règles de contrôle, toutes les incohérences sont enregistrées dans la liste d'erreurs et d'avertissements du document.

Étape de traitement

Étape du flux de travail au sein de laquelle certaines actions sont exécutées sur un document ou un lot (que ce soit automatiquement ou par un opérateur). Consultez la section ?Étapes et files de traitement

Exemple de texte

Fichier contenant des exemples de tous les caractères alphabétiques

Exportation

Opération consistant à transférer les données traitées vers un système d'informations externe ou un fichier.

Expression normale

Description de la structure d'un mot ou d'une valeur entrée à l'aide d'un langage spécial. Le programme permet de spécifier non seulement le jeu de caractères autorisés mais aussi la structure du contenu des champs. Vous pouvez décrire la structure à l'aide d'une expression régulière au moment de définir les contraintes d'un champ de texte ou au moment de créer un type de données personnalisé. Consultez la section Caractères alphabétiques dans des expressions régulières.

F

Fichier de description

Fichier auxiliaire définissant la manière dont un lot est formé quand des images sont ajoutées à partir d'un dossier actif. Pour plus d'informations, consultez la section Fichier de description.

File

Documents regroupés en tâches et/ou en lots qui attendent d'être traités à une certaine étape de traitement. Consultez la section Étapes et files de traitement.

FlexiLayout

Description de la structure d'un document flexible. Cette description est conçue avec ABBYY FlexiLayout Studio et exportée vers ABBYY FlexiCapture. Un FlexiLayout est une sorte d'instruction permettant de détecter et d'identifier les champs.

Formulaire

Document comportant une ou plusieurs pages, conçu pour être rempli par une personne à la main ou à l'aide d'une technique d'impression.

Formulaire à arrière-plan couleur

Formulaire dans lequel tous les champs d'informations sont des rectangles blancs sur arrière-plan en couleur, qui disparaît pendant la numérisation.

Formulaire à fond gris

Formulaire dans lequel tous les champs d'informations sont des rectangles blancs sur fond gris, qui disparaît pendant la numérisation.

Formulaire à lignes noires et blanches

Formulaire dans lequel les bordures des champs d'informations sont formées par des lignes ordinaires qui ne disparaissent pas pendant la numérisation.

Formulaire fixe

Document avec des champs d'information fixes dont la mise en forme, le nombre et la présentation sont définis de manière stricte et ne changent pas d'une instance de document à l'autre.

Formulaire lisible par machine

Formulaire conçu spécialement pour l'entrée automatique. Il contient des éléments de travail (ancres, codes barres, lignes, etc.) nécessaires pour le traiter correctement.

Formulaire tramé

Formulaire dans lequel les champs d'informations sont représentés sous forme de rectangles blancs sur fond gris constitué de lignes tramées ou de rectangles délimités par des lignes tramées.

G

Groupe de coches

Élément de formulaire lisible par machine qui rassemble plusieurs coches situées à proximité les unes des autres. Une ou plusieurs coches peuvent être sélectionnées dans un groupe de coches.

I

Identificateur

Élément statique utilisé pour sélectionner une définition de document parmi plusieurs définitions de document présentant des emplacements d'ancres identiques. L'option Utiliser pour l'identification de la définition de document doit être activée dans les propriétés de ces éléments statiques.

Identification de la définition de document

Opération consistant à sélectionner la définition de document requise à l'aide d'identificateurs.

Image

Image électronique d'une page numérisée à partir d'un document au format papier.

Élément de formulaire lisible par machine qui n'est pas destiné à la reconnaissance mais est prévu pour être exporté sous forme d'objet graphique (par exemple, un fichier).

Image inversée

Image contenant du texte légèrement coloré sur fond sombre.

Importation d'image

Processus consistant à ajouter des images à un lot pour les traiter. L'importation peut être exécutée en ajoutant des images à partir de fichiers, à partir d'un scanner ou à l'aide de profils d'importation. Consultez la section Ajout d'images de pages.

Imprimante matricielle

Type de texte reconnaissable qui représente un texte imprimé à l'aide d'une imprimante matricielle.

ICR

Reconnaissance intelligente de caractères. Désigne les technologies ou systèmes conçus pour traiter en masse les documents remplis à l'aide de lettres et de chiffres manuscrits.

J

Jeu de caractères autorisés

Ensemble de caractères survenant dans le type de données reconnu. Détails...

Cet ensemble, ou jeu, est déterminé par le type de données. En d'autres termes, le type de données associé à un champ détermine le jeu de caractères utilisé pendant la reconnaissance.

Vous pouvez non seulement sélectionner les caractères inclus dans ce jeu, mais aussi configurer des paramètres supplémentaires restreignant ce jeu. Par exemple, vous pouvez spécifier :

  • Les caractères dont vous savez qu'ils ne surviendront pas lorsqu'un champ spécifique sera reconnu – les caractères interdits (par exemple, vous pouvez faire de toutes les minuscules des caractères interdits pour un champ dans lequel seules des majuscules interviendront).
  • Les caractères qui peuvent apparaître au sein d'un mot sans affecter sa vérification – les caractères ignorés (par exemple, les tirets, les marques d'accentuation, etc.).

L

Langue (locale)

Propriété de champ qui détermine la langue d'écriture et le jeu de paramètres régionaux approprié (comme le style d'écriture de la date ou de l'adresse).

Lettres dans des cadres séparés

Type de marquage de texte selon lequel chaque caractère est délimité par un cadre. Les cadres sont séparés les uns des autres. Afficher...

Lettres encadrées

Type de marquage de texte selon lequel chaque caractère est délimité par un cadre. Les cadres ne sont pas séparés les uns des autres. Afficher...

Lettres sur un peigne

Type de marquage de texte selon lequel le texte est délimité par un « peigne ». Afficher...

Ligne tramée

Ligne composée de points espacés de manière égale.

Lot de documents

Combinaison de documents groupés par l'utilisateur. Un lot contient en principe la pile de documents numérisés au cours d'un même passage, ou importés à partir d'un dossier donné. Consultez la section Lots de documents.

Lots de test

Lots de documents conçus pour tester et configurer des définitions de document. Les copies locales des lots de documents sont utilisées pour traiter les lots de test. Consultez la section Lots de documents.

Lots de travail

Lots de documents destinés à l'entrée de données. Seules les définitions de document publiées sont utilisées pour traiter des lots de travail. Consultez la section Lots de documents.

Luminosité

Seuil de sensibilité lumineuse qui détermine à partir de quel moment le scanner détecte les demi-tons en niveau de gris comme du blanc.

M

Machine à écrire

Type de texte reconnaissable qui représente un texte dactylographié à l'aide d'une machine à écrire.

Marquage de champ de texte

Élément graphique délimitant un champ de texte : cadre, peigne ou ligne.

Marquage de texte

Structure d'une région de page destinée à recevoir du texte. Pour voir des informations sur la mise en forme de texte, consultez la rubrique Champ d'entrée.

N

Nettoyage d'image

Suppression du bruit d'une image. Du bruit peut apparaître pendant la numérisation, et il est recommandé de le supprimer pour une meilleure reconnaissance des données. Pendant le nettoyage, le programme supprime également les points d'arrière-plan ou les lignes de contour des formes tramées.

Numérisation

Opération consistant à obtenir une image électronique d'un formulaire papier à l'aide d'un scanner.

O

OCR

Reconnaissance optique de caractères. Reconnaissance optique des textes imprimés.

OMR

Reconnaissance optique de marques. Cette technologie permet à ABBYY FlexiCapture de reconnaître à la fois les marques ordinaires (coches, croix, etc.) sur les formulaires avec un certain degré de précision, et de corriger les marques qui ont été faites par erreur et qui doivent être retouchées.

Opérateur

Utilisateur d'ABBYY FlexiCapture en charge d'entrer des documents, qu'il s'agisse d'ajouter des images, d'effectuer une reconnaissance et une vérification, ou encore d'exporter les données reconnues.

Orientation de page

Emplacement d'une page par rapport à l'alignement standard : de haut en bas ou de gauche à droite. L'orientation d'une page peut être déterminée automatiquement pendant la reconnaissance de l'image de cette page. À cet effet, ABBYY FlexiCapture 9,0 permet de spécifier plusieurs orientations.

Orientation du texte

Sens du texte d'un champ par rapport à la page.

P

Page

Image d'une page de document au format papier, et résultat de son traitement.

ppp

Points par pouce. Nombre de points par pouce ; unité de résolution d'une image.

Présentation de page

Système montrant l'emplacement des champs d'une image.

Profil d'importation

Combinaison de paramètres utilisée pour ajouter des images à un lot : source d'importation, options de traitement d'image, options de nettoyage de dossier d'images, etc. Consultez la section Profils d'importation d'images.

Projet

Un projet est un environnement unique qui unifie les lots de documents et les paramètres requis pour les traiter, comme les définitions de document, les profils d'importation, etc. Consultez la section Création d'un projet.

Publication de la définition de document

Opération consistant à accéder à une nouvelle version de définition de document une fois qu'elle a été modifiée. Une version publiée contribue au traitement des documents à partir de lots de travail, tandis qu'une version locale non publiée ne peut contribuer qu'au traitement des définitions de document à partir de lots de test. Consultez la section Modification et publication d'une définition de document.

R

Reconnaissance

Processus consistant à associer des éléments d'image à des caractères spécifiques.

Reconnaissance de code barre

Conversion d'une image de code barre graphique en valeurs numériques ou en texte.

Reconnaissance de texte (OCR, ICR)

Conversion d'une image graphique en texte.

Reconnaissance optique de marques (OMR)

Processus consistant à déterminer la présence d'une marque dans le champ de marque d'un formulaire.

Région de champ

Région d'image mise en surbrillance dans la définition de document et destinée à l'extraction de données.

Région non reconnaissable

Région d'image exclue de la reconnaissance. Une région non reconnaissable est requise pour exclure une région contenant du texte d'explication ou une image qui complique la reconnaissance d'un champ. Consultez la section Exclusion d'une région de la reconnaissance.

Règles

Conditions imposées aux données des champs. Ces conditions sont vérifiées automatiquement par le programme. Consultez le chapitre Validation par règle

Remplacement d'image

Remplacement d'une image par une autre lors de la modification d'une définition de document.

Résolution

Paramètre d'image. La résolution se mesure en points par pouce (ppp).

Rôle d'opérateur

Propriété d'un compte utilisateur dans ABBYY FlexiCapture 9.0 qui détermine les données accessibles à l'utilisateur et les actions pouvant être exécutées sur ces données. Consultez la section Utilisation d'un projet configuré.

Rotation d'image

Rotation d'une image autour de son centre.

S

Section d'une définition de document

Ensemble de pages (ou page unique), avec tous les champs qu'elles contiennent, correspondant à une partie de document complète d'un point de vue logique. Des sections de document peuvent être décrites à l'aide d'une définition de document fixe ou flexible. Consultez la section Création de définitions de document pour des documents de plusieurs pages.

Section de la définition de document

Composant d'une définition de document. Correspond à une ou à plusieurs pages contenant un ensemble de champs complet d'un point de vue logique. Au sein d'une même section, les champs peuvent s'étendre d'une page à la suivante (dans le cas de tableaux de plusieurs pages, par exemple), tandis que les jeux de champs de différentes sections ne peuvent pas se couper.
Une définition de section peut être soit flexible soit fixe.

Séparateur

Élément de formulaire lisible par machine représentant une ligne verticale ou horizontale.

Style d'écriture

Manière d'écrire spécifique à un groupe donné. Par exemple, la manière des Américains d'écrire les nombres. Détails...

Cette option sert à configurer le style d'écriture des lettres manuscrites dans les formulaires. Le style d'écriture à choisir dépend de l'endroit où les formulaires sont traités (en Russie, en Allemagne, en République tchèque, aux États-Unis, etc.).

T

Table

Ensemble de données organisé en grille bidimensionnelle qui n'est pas forcément visible. Le programme traite les tableaux composés de colonnes avec des données de même type et des lignes qui se répètent.

Tâche

Jeu de documents issus du même lot et devant être traités en même temps. En fonction des paramètres du projet, et de l'étape de traitement, une tâche peut contenir des numéros de documents différents. Si une étape de traitement requiert le traitement d'un lot en entier, tout le lot est inclus dans la tâche. Lorsque les tâches de vérification sont formées automatiquement, chaque tâche contient 10 documents (si un lot contient moins de 10 documents non vérifiés, ils seront tous traités en une seule tâche).

Texte à châsse fixe

Type de marquage de texte selon lequel chaque lettre est placée dans un cadre de la même hauteur et de la même largeur, mais dont les bords disparaissent pendant la numérisation.

Texte d'ancre

Élément statique représentant un texte présent sur un formulaire vide, et qui n'est pas destiné à l'extraction de données. Il peut s'agir de texte explicatif ou d'un en-tête. Un texte d'ancre peut être utilisé pour l'association ou l'identification de la Définition de document.

Texte d'explication

Élément de formulaire lisible par machine qui représente un texte descriptif (nom de formulaire, noms de champs, explications de champs, etc.).

Texte dactylographié

Type de texte reconnaissable qui a été imprimé à l'aide d'un équipement typographique ou d'une imprimante laser ou à jet d'encre présentant une résolution minimale de 300 ppp.

Texte encadré

Type de marquage de texte selon lequel le texte est délimité par un cadre. Afficher...

Texte encadré par-dessus un peigne

Type de marquage de texte selon lequel le texte est délimité par un cadre dont la limite inférieure est en forme de peigne. Afficher...

Texte manuscrit

Type de texte reconnaissable représentant du texte manuscrit sous une forme distincte.

Texte simple

Type de marquage de texte selon lequel le texte est inséré dans un bloc sans délimiteurs.

Texte souligné

Type de marquage de texte selon lequel le texte est souligné. Afficher...

Type de données

Attribut de champ décrivant les contraintes connues des valeurs de champs possibles. Il est utilisé pendant la reconnaissance des champs pour réduire le nombre de variantes de reconnaissance possibles. Détails...

Parmi les caractéristiques d'un champ figure le type de données : nombre, date, texte, nom, nom de famille, adresse, etc. Le type de données détermine l'ensemble de mots pouvant survenir dans le champ concerné.

Le type de données est un paramètre de reconnaissance important qui affecte la qualité de la reconnaissance. Un type de données spécifié correctement peut réduire considérablement le nombre de caractères mal reconnus.

Type de données personnalisé

Type de données défini par l'utilisateur. Consultez la section Création de types de données personnalisés.

Type de lot

Propriété d'un lot qui définit de quelle manière doivent être traités les documents dans les lots correspondant. Consultez la section Types de lot

V

Validation par règle

Contrôle automatique des données reconnues par rapport à un ensemble de règles prédéfinies. Consultez la section Validation par règle.

Vérification

Opération consistant, pour l'opérateur, à vérifier les données reconnues. Cette opération est effectuée en comparant les résultats de la reconnaissance à l'image originale d'une partie de document. Dans les produits ABBYY, la technologie de vérification a été mise en œuvre en prenant en compte les particularités psychosomatiques des humains : les habitudes qui se sont mises en place, l'utilisation des compétences et l'objectif de la perception. Consultez la section Vérification des données reconnues.

Vérification de champ

Mode de vérification au cours duquel les caractères reconnus sont soumis à une vérification dans le contexte d'un champ. Détails...

En mode vérification de champ, les caractères incertains sont vérifiés dans le contexte du champ entier.

Les champs dont l'option Envoyer vers la vérification de champ est activée sont soumis à la vérification de champ. Nous recommandons de soumettre à la vérification de champ les champs dont la plage de valeurs est connue ou peut être déterminée aisément. C'est par exemple le cas des champs de pays ou de villes : nous savons quelles valeurs ces champs peuvent contenir.

Vérification groupée

Mode de vérification suivant lequel les caractères reconnus de manière identique sont soumis à la vérification en groupes. Détails...

Les champs dont l'option Envoyer les caractères vers la vérification de groupe est activée sont soumis à la vérification groupée.

Nous recommandons de soumettre les caractères des champs numériques ainsi que les coches à la vérification groupée.

X

XFD

XML Form Definition (définition de formulaire XML ; *.xfd) – format de fichier spécial conçu avec ABBYY FormDesigner. Un fichier au format XML Form Definition sert à créer des définitions de document dans ABBYY FlexiCapture.


Glossaire

A C D E F G I J L M N O P R S T V X


Fichier de description

Un fichier de description est un fichier auxiliaire qui définit la manière dont un lot est formé quand des images sont ajoutées à partir d'un dossier actif. En fonction du format du fichier de description, différents jeux de fichiers sont utilisés pour former le lot.

Le programme utilise les types de fichiers de description suivants :

  1. Captiva QuickScan
    Tous les fichiers d'image répertoriés dans le fichier de description sont ajoutés au lot. Les fichiers d'image du lot sont classés dans le même ordre que dans le fichier de description.
  2. Capture Software for Kodak
    Les fichiers d'image situés dans le dossier du lot Kodak sont ajoutés au lot par ordre alphabétique croissant.
  3. Fichier vide
    Ce fichier sert de marqueur signifiant qu’un nouveau lot doit être créé. Le contenu de ce fichier n’est pas important, seul son nom l’est. Les images sont ajoutées à partir du dossier actif dans l’ordre alphabétique. Lorsqu’un fichier portant le nom correspondant au masque spécifié dans le champ Nom de fichier est trouvé, le système crée un nouveau lot. Ainsi, si le masque *.dat a été spécifié, et que le dossier actif contient les fichiers suivants :
    Contrat.dat
    Contrat1.jpg
    Contrat2.jpg
    Lettre.dat
    Lettre1.jpg
    Lettre2.jpg,
    un lot sera créé pour les fichiers Contrat*.jpg (lorsque Contrat.dat est trouvé), et un autre lot sera créé pour les fichiers Lettre*.jpg (lorsque Lettre.dat est trouvé).
  4. Fichier XML
    Fichier XML avec une structure documentée. Un fichier XML est utilisé quand les trois autres types ne peuvent pas être utilisés mais qu'un fichier de description personnalisé peut être généré. Les fichiers d'image répertoriés dans le fichier de description sont ajoutés au lot.

    Un fichier XML doit contenir un élément racine Batch (lot) avec des éléments enfants Images.

    L'élément Images doit à son tour inclure des éléments Image, dont le nombre correspond au nombre de pages du lot en cours de création. Chaque élément Image doit contenir le chemin d'accès UNC correspondant du fichier d'image. Le chemin d'accès du dossier contenant l'image doit être le même pour tous les éléments Image.

    <Batch>

    ...

    <Images>
    <Image>\\HotFolder\Page1.tif</Image>
    <Image>\\HotFolder\Page2.tif</Image>
    <Image>\\HotFolder\Page3.tif</Image>

    </Images>

    </Batch>

    Dans ce cas, nous recommandons de configurer le programme de numérisation de telle sorte que les images numérisées soient placées dans le dossier actif lui-même, ou dans ses sous-dossiers de premier niveau. Quand vous créez un lot, le programme y ajoute toutes les images figurant dans les éléments Image du fichier de description correspondant. Les images sont ajoutées dans l'ordre dans lequel elles apparaissent dans le fichier de description.

    Les fichiers d'image du lot sont classés dans le même ordre que dans le fichier de description.


Propriétés d'une section de définition de document

Vous pouvez afficher et modifier les propriétés d'une section de définition de document dans la boîte de dialogue Propriétés qui s'ouvre quand vous sélectionnez Propriétés… dans le menu contextuel.

Cette boîte de dialogue contient trois onglets.

L'onglet Généralités

Sur cet onglet, vous pouvez modifier le nom d'une section de document, entrer ou modifier une description, et entrer ou modifier le nombre minimal et le nombre maximal de répétitions de section dans le document. L'option Activé inclut/exclut la section définition de document du traitement documentaire. Pour plus d'informations sur les documents de plusieurs pages et sur l'utilisation des sections, consultez la section Création de définitions de document pour des documents de plusieurs pages.

L'onglet FlexiLayout

Si une description flexible a été jointe à la section, cet onglet montre son Nom , sa Version et son Commentaire . Vous pouvez joindre une description flexible en cliquant sur le bouton Charger… et la détacher en cliquant sur le bouton Détacher.

Pour plus d'informations, consultez la section Création d'une définition de document pour traiter des documents flexibles.

L'onglet Images
Cet onglet répertorie les paramètres d'affichage des images de page de la section. Vous avez le choix entre les paramètres suivants : taille, résolution, taille d'impression, et mode de couleur.

L'onglet Règles

Cet onglet est consacré aux actions relatives aux règles de définition de document. Vous pouvez supprimer, modifier ou créer des règles.

Pour plus d'informations, consultez la section Validation par règle.