Что такое ABBYY FlexiCapture 10

Программа ABBYY FlexiCapture 10 – это программное решение для автоматизированного ввода данных с бумажных документов в информационные системы и базы данных.

Используя передовые технологии распознавания типографских и рукопечатных символов, обработки изображений и анализа документов, ABBYY FlexiCapture 10 позволяет автоматизировать извлечение значимой информации из документов любого типа, обрабатываемых в одном потоке – структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных документов, оформленных в свободном стиле. В результате пользователи ABBYY FlexiCapture 10 избавляются от трудоемкого и неэффективного труда, связанного с ручной сортировкой документов и перепечаткой информации с них.

Основной сценарий обработки документов сводится к следующему:

  1. Документы кладутся в автоподатчик сканера и запускается процесс сканирования.
  2. Отсканированные изображения документов поступают на распознавание, в процессе которого программа автоматически идентифицирует документы, в том числе многостраничные, находит значимые поля, извлекает данные и запускает правила проверки.
  3. При необходимости, по окончании распознавания запускается процесс визуальной проверки данных и ошибок правил.
  4. Распознанные и проверенные данные, а также электронные копии документов сохраняются в базу данных, информационную систему или в файл.


Новые возможности ABBYY FlexiCapture 10

Новые возможности ABBYY FlexiCapture 10 по сравнению с ABBYY FlexiCapture 9.0

Архитектура

Устойчивость к сбоям

Реализована работа системы на кластере. При сбое одного сервера обработка будет продолжена на другом.

Управление проектами

Тестовые проекты

Реализована возможность создать тестовую копию проекта, убедиться в корректности ее работы и применить изменения к рабочему проекту.
Проекты

Процесс обработки

Повторное сканирование документов и отдельных страниц

Оператор имеет возможность отправлять на повторное сканирование не только пакеты целиком, но и отдельные документы или их страницы.
Отправка задания группе пользователей

Задание может быть направлено на обработку указанному пользователю. Также можно отправить его группе пользователей, которым присвоена соответствующая роль. Роли присваиваются группам пользователей с помощью Консоли администрирования и мониторинга.

Импорт и обработка изображений

Импорт изображений из электронной почты и по FTP

Изображения могут импортироваться из электронных писем, включая приложения. Поддерживаются протоколы POP3 и MAPI. При использовании протокола MAPI станции обработки должны запускаться от имени учетной записи владельца почтового ящика. Также изображения могут быть загружены с FTP-сервера.
Профили импорта изображений

Верификация

Двойная верификация

При разработке определения документа поля могут быть отмечены как требующие двойной проверки. Для данных полей в документе будут храниться два независимых результата верификации.
Настройки верификации поля

Распределенная верификация

Администратор может ограничить набор полей, требующих верификации. При этом оператору верификации будут доступны только поля из указанного набора.
Распределенная верификация

Контекстная верификация групп меток

Группы меток единственного выбора, в которых выбрано более одного значения, будут отправлены на контекстную верификацию. Верификатор операции данных будет иметь возможность изменить выбранное значение.

Удаленная станция верификации

Станция верификации может использоваться удаленно, аналогично станциям верификации данных и сканирования. Реализована возможность доступа с помощью базовой аутентификации. В некоторых случаях она работает быстрее, чем сквозная аутентификация, даже при использовании в локальной сети.

Web-интерфейс станции верификации данных

Разработан web-интерфейс станции верификации данных. Он доступен по следующему адресу: http://<FCServer>/DataVerification/ где <FCServer> - имя или IP-адрес сервера приложений.

Web-интерфейс станции сканирования

Разработан web-интерфейс станции сканирования. Он доступен по следующему адресу: http://<FCServer>/Scanning/ где <FCServer> - имя или IP-адрес сервера приложений.

Web-станция ввода документов

Разработана web-станция ввода документов. Она доступна по следующему адресу: http://<FCServer>/Capture/ где <FCServer> - имя или IP-адрес сервера приложений.

Экспорт

Отложенное удаление документов

Добавлена возможность указать промежуток времени после экспорта, по истечении которого документы будут удалены.
Настройки экспорта

Дополнительные настройки

Настройка интерфейса верификации

Добавлены инструменты для настройки интерфейса станции верификации. Изменять интерфейс можно для пользовательских этапов обработки.
Настройка оболочки

Настройка маршрутизации документов

В процесс обработки могут быть добавлены пользовательские этапы. Этап может быть автоматическим (например, очистки изображений, классификации) или требовать взаимодействия с оператором (например, подтверждение штрих-кодов, подтверждения дополнительных правил).

Как для предопределенных, так и для пользовательских этапов обработки можно указать правила допуска документов на этап и правила маршрутизации документа после прохождения этапа в зависимости от таких параметров как значения полей или регистрационных параметров, количества неуверенно распознанных символов, возникновения ошибок и т. д. Правила могут быть как простыми (выбранными из списка), так и скриптовыми.
Этапы обработки
Настройка этапа

Скрипты

Было добавлено большое количество новых скриптов, таких как скрипты распознавания, обработчики событий и т. д.

Использование скриптов в ABBYY FlexiCapture 10
Настройка горячих клавиш

Добавлена возможность выбора горячих клавиш для часто используемых команд. При необходимости также можно изменить действие предопределенных горячих клавиш на каждой станции.

Настройка горячих клавиш
Новые возможности ABBYY FlexiCapture 9.0 по сравнению с ABBYY FlexiCapture 8.0 Professional

Архитектура

Распределенная установка

Основным отличием ABBYY FlexiCapture 9.0 является наличие возможности распределенной установки и функционирования. Распределенная установка аналогична реализованной в системе FormReader 6.5 Enterprise Edition с некоторыми модификациями, добавленными для повышения гибкости, масштабируемости и устойчивости. Станции сканирования и верификации данных могут работать удаленно через Интернет.

Архитектура и принципы работы ABBYY FlexiCapture
Процесс обработки
Серверы ABBYY FlexiCapture
Станции ABBYY FlexiCapture
Программный интерфейс сервера приложений

Программный интерфейс сервера приложений позволяет управлять процессом обработки на программном уровне, без использования пользовательского интерфейса. Наличие программного интерфейса позволяет разрабатывать сторонние приложения, использующие систему ABBYY FlexiCapture 9.0 как сервис анализа изображений документов и экспорта результатов.

Управление проектом

Типы пакетов

Реализован механизм типов пакетов. Каждый пакет относится к одному определенному типу (если тип не указывается явно при создании, используется тип "по умолчанию"). Проект может содержать произвольное количество типов пакетов. Тип пакета определяет параметры обработки изображений, распознавания, проверки целостности пакета, настроек экспорта по умолчанию, а также процесс обработки пакетов данного типа. Если для какого-либо пакета используется тип "по умолчанию" (тип не задан явно), то для пакета используются настройки проекта.
Пакеты документов

Регистрационные параметры

Добавлена возможность указывать регистрационные параметры, описывающие пакеты или документы. В дальнейшем регистрационные параметры могут использоваться при экспорте изображений и данных.

Регистрационные параметры
Приоритеты

Добавлена возможность указывать приоритеты для документов и пакетов, управляя порядком обработки.

Анализ и распознавание

Порядок наложения определений документов

Реализована возможность управлять порядком наложения определений документов. Указать порядок наложения определений можно одним из следующих способов:

  • Явно указав порядок определений документа в окне Определения документов.
  • Для гибких описаний: использовать классификатор для выбора необходимого описания.
  • Для гибких описаний: указать способ выбора подходящего гибкого описания в окне Определения документов.
Редактирование и публикация определения документа
Классификатор проекта
Обновление версии определения документа без повторного распознавания

Появилась возможность обновлять определение документа без повторного распознавания документов. Это возможно в следующих случаях:

  • Если изменились только настройки экспорта. В данном случае документ будет экспортирован с новыми настройками.
  • Если изменились правила проверки. В данном случае будет повторно выполнена проверка правил.

Верификация и проверка

Добавлена возможность автоматического получения заданий на верификацию и проверку
Добавлена возможность просмотра изображения страницы во время групповой и контекстной верификации
Реализована возможность использования файлов и баз данных в качестве источников значений при проверке правил
Реализована возможность отключить правило проверки по базе данных для пустых полей
Добавлено правило вычисления суммы
Отображается уровень уверенности распознавания для пакета в целом
Добавлены настройки для групповой и контекстной верификации, в том числе уровень уверенности отдельных символов
Добавлена возможность указать начальную позицию курсора при контекстной верификации
Опциональная подсветка всего поля (если пользователь хочет ввести поле целиком) при контекстной верификации
Раздельное отображение ошибок в зависимости от типа. Выделяются следующие ошибки:
  • Ошибки сборки;
  • Ошибки формата;
  • Ошибки правил.
Верификация распознанных данных

Экспорт

Автоматический экспорт

Документы с высоким качеством распознавания и без ошибок правил или формата теперь экспортируются без участия пользователя. Процент неуверенно распознанных символов указывается при настройке проекта.
Процесс обработки

Экспорт по нескольким адресам

Теперь возможен экспорт данных и изображений по нескольким различным адресам. Некоторые адреса могут быть помечены как обязательные. Если экспорт по обязательному адресу завершается ошибкой, программа отображает сообщение об ошибке. Ошибка при экспорте по необязательному адресу не означает ошибки экспорта в целом.
Настройка экспорта данных

Настройка расположения и имен файлов

Добавлены новые возможности по созданию шаблона имени файлов для экспорта данных и изображений, а также путей к ним. В том числе добавлена возможность воссоздания структуры папок при экспорте из Горячей Папки.
Критерии формирования имен файлов экспорта

Архивация документов с ошибками

Документы с ошибками сохранены в специальное хранилище. Настройка экспорта документов с ошибками осуществляется так же, как и для обычных документов. Могут быть сохранены как документы с ошибками сборки и / или правил, так и нераспознанные документы (точнее, их изображения).
Настройка экспорта данных

Автоматическое удаление документов после экспорта

Экспортированные документы могут удаляться автоматически после успешного завершения экспорта. Возможность удаления документов в ручном режиме также сохранена.
Процесс обработки

Сохранение конфиденциальности

Добавлена возможность сокрытия отдельных полей на изображении документа. Для каждого варианта экспорта указываются свои правила сокрытия информации, и, таким образом, можно предоставлять разным пользователям разный объем данных.
Настройка экспорта данных

Настройки

Проверка целостности пакета

Реализована возможность проверки целостности пакета с помощью скриптов. Скрипты запускаются автоматически перед экспортом.
Пакеты документов
Примеры скриптов для создания пользовательских правил

Скрипты нормализации

Реализована возможность корректировки извлеченной из полей информации с помощью скриптов.
Обработка введенного значения
Примеры скриптов для создания пользовательских правил

Автоматический режим обработки

Документы могут обрабатываться автоматически без участия оператора. При этом успешно обработанные документы экспортируются, изображения документов с ошибками могут быть сохранены для последующего анализа.

Настройка процесса обработки
Пользовательский скрипт

Для каждого поля можно указать скрипт, выполняемый по запросу оператора верификации.

Пользовательский скрипт
Служебные поля

Добавлен новый тип поля: служебное. Поля такого типа заполняются автоматически на основе данных из выбранного источника.

Служебные поля

Поддержка языков

Новые языки распознавания

Добавлена поддержка следующих языков распознавания (OCR):

  • Вьетнамский;
  • Китайский;
  • Корейский;
  • Японский.


Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture 10

ABBYY FlexiCapture 10 – программное решение для потокового ввода данных с документов различного типа.

Документы различных типов могут обрабатываться в одном потоке. Можно также настроить обработку документов смешанного типа, например, состоящих из жестких и гибких разделов. Тип документов влияет только на настройку системы, а именно, на способ создания определения документа. Работа оператора не зависит от типа обрабатываемых документов.

С помощью ABBYY FlexiCapture вы сможете настроить автоматизированный ввод следующих документов, в том числе в одном потоке:

структурированных – жестких форм;
К структурированным относятся документы с набором выделенных информационных полей, оформление, количество и местоположение которых не меняются от одного экземпляра документа к другому. Такие документы называются жесткими формами. Например, анкеты, опросники, заявления чаще всего являются жесткими формами. Чаще всего такие формы распространяются в виде бланков и заполняются от руки.

Чтобы идентифицировать жесткую форму в потоке документов и извлечь из нее данные, необходимо создать единую жесткую разметку, которая укажет программе места расположения полей, из которых нужно извлечь данные.

Наиболее эффективно производится обработка жестких форм, созданных с учетом требований автоматического ввода. Такие формы называют машиночитаемыми формами. Подробнее о требованиях к таким формам и способах их создания читайте в разделе Создание машиночитаемых форм.

В состав программы входит удобный инструмент разработки машиночитаемых форм ABBYY FormDesigner 10 (Поставляется вместе с ABBYY FlexiCapture 10). О создании форм с помощью ABBYY FormDesigner 10 читайте в руководстве и справке к этой программе.

Основные этапы создания определения документа описаны именно для структурированных документов.
частично структурированных – гибких форм и документов;
К ним относятся документы, содержащие набор информационных полей, оформление, количество и расположение которых могут значительно отличаться в разных экземплярах документа. Эти документы называются гибкими. К примеру, счета являются гибкими документами, т.к. они часто отличаются как количеством позиций, так и форматированием, потому что они поступают от разных компаний. На всех счетах присутствуют номер счета и сумма платежа, но и они расположены в разных местах.

Для идентификации гибких форм и извлечения из них данных программа ABBYY FlexiCapture 10 использует гибкую разметку (FlexiLayout). Для создания гибкой разметки используется специальный модуль ABBYY FlexiLayout Studio, подробную информацию о работе которого можно найти в руководстве и справке к этому модулю.

Процесс обработки гибких документов отличается от обработки жестких форм только на этапе создания и подключения разметки. Подробнее см. Создание определения для обработки гибких документов.
неструктурированных документов, оформленных в свободном стиле.
Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, графики, то и в этом случае поможет ABBYY FlexiCapture 10. Неструктурированные документы могут быть автоматически идентифицированы программой либо как приложения к жестким или гибким формам, либо с помощью гибкой разметки, а затем экспортированы в виде PDF файлов с возможностью поиска или файлов графических форматов. Извлекать индексные поля из неструктурированных документов можно как автоматически с помощью гибкой разметки, так и с помощью ручного ввода.

Типичным сценарием обработки неструктурированных документов является задача перевода бумажного архива в электронный вид с необходимостью извлечения двух-трех индексных полей для организации быстрого поиска по атрибутам.

Подробнее см. Обработка неструктурированных документов.


Краткое описание процесса обработки документов с помощью программы ABBYY FlexiCapture 10

В этом разделе вы узнаете, как обрабатывать документы с помощью программы ABBYY FlexiCapture 10. Информация в этом разделе носит обзорный характер.

Подробно процесс работы с программой описан в разделах Настройка программы и Работа оператора с настроенным проектом.

Обзор настройки программы для обработки документов
Обзор работы с настроенной программой


Краткое описание настройки программы для обработки документов

Настройка программы для обработки документов определенного типа выполняется администратором. Чтобы подготовить программу к обработке документов, нужно:

  1. Создать проект

    Проект включает в себя все настройки для обработки документов определенного типа: профили импорта изображений, определения документов, пакеты документов для обработки.

  2. Создать одно или несколько определений документов

    Создание определения документа – основной и самый ответственный этап настройки проекта. Если вы собираетесь обрабатывать в одном потоке документы разного типа, то в рамках одного проекта нужно создать несколько определений документов.

  3. Создать типы пакетов

    Тип пакета определяет параметры обработки изображений, распознавания, проверки целостности пакета, настроек экспорта по умолчанию, а также процесс обработки пакетов данного типа.

  4. Создать профили импорта изображений

    Профили импорта создаются для удобства и ускорения работы оператора. Если профили импорта не настроены, то при добавлении изображений приходится каждый раз выбирать источник импорта и задавать необходимые настройки, а профили импорта позволяют добавлять изображения нажатием одной кнопки, а также легко переключаться между источниками импорта.

  5. Создать пакет документов

    Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки. При попытке добавления изображений при отсутствии пакетов, пакет будет создан автоматически.

Подробнее о настройке программы


Распределенная работа

ABBYY FlexiCapture 10 (Distributed Installation) – это комплекс ввода данных с бумажных документов, представляющий собой распределенное клиент-серверное приложение.

В состав комплекса ABBYY FlexiCapture 10 (Distributed Installation) входят несколько станций и серверов. На каждой станции выполняются однотипные операции. Серверы обеспечивают работу комплекса, осуществляют взаимодействие и распределяют работу между станциями. Перед тем как приступить к обработке документов, серверы необходимо настроить.

Ниже приведено описание компонент комплекса:

  • Консоль Администрирования и Мониторинга

    После установки комплекса, необходимо настроить связь с базой данных и раздать права операторам станций. Все эти действия выполняются оператором с правами администратора через Консоль Администрирования и Мониторинга.

    Консоль Администрирования и мониторинга является web-интерфейсом, предназначенным для управления Сервером Приложений. Консоль доступна с любого компьютера, связанного с Сервером Приложений, по адресу http:\\<ApplicationServer>\FlexiCapture10, где <ApplicationServer> - имя компьютера, на который установлен Сервер Приложений.

    В процессе обработки документов Консоль Администрирования и Мониторинга позволяет получать статистику о работе комплекса и создавать отчеты.

  • Станция Настройки Проектов

    На следующем этапе нужно создать и настроить проект. Для этого оператору станции необходимо создать определения документов, типы пакетов и настроить последовательность обработки. После того как настроен комплекс, проект необходимо загрузить на Сервер Приложений. Только после того как проект будет загружен на сервер, можно начать обработку документов.

  • Станция Сканирования

    Первой станцией на которую поступают документы для обработки, может быть Станция Сканирования. Оператор на этой станции создает пакеты и загружает в них изображения. Если необходимо, после добавления изображений, оператор может их отредактировать. Для дальнейшей обработки изображений, готовый пакет необходимо отправить в ABBYY FlexiCapture.

    Станция Сканирования может не использоваться в том случае, если изображения для обработки поступают из Горячей папки.

  • Станция Обработки

    Станция Обработки работает в автоматическом режиме и выполняет следующие операции: загрузка изображений из Горячих папок, применение определений документов и распознавание, проверка с помощью правил и экспорт результатов в заданные хранилища.

  • Станция Верификации Данных

    Данная станция предназначена для проверки распознанных данных. Оператор станции последовательно выполняет проверку неуверенно распознанных символов в режимах групповой и контекстной верификации. По окончании работы, для последующей обработки, пакет отправляется на Станцию Верификации. В случае возникновения проблем при обработке пакета Оператор Верификации Данных может отправить пакет (документы) как проблемный в очередь исключений (обрабатывается Старшим Оператором Верификации).

  • Станция Верификации

    Данная станция предназначена для более сложной проверки, чем Станция Верификации Данных. Помимо проверки распознанных данных, станция позволяет обрабатывать проблемные пакеты (документы), осуществлять проверку ошибок сборки, правил, комплектации пакета.

  • Сервер Обработки

    Сервер Обработки распределяет задания между Станциями Обработки. Вместе с сервером устанавливается Монитор Сервера Обработки, который позволяет отслеживать работу сервера и устанавливать приоритеты выполнения заданий.

  • Сервер Приложений

    Сервер Приложений осуществляет взаимодействие между станциями комплекса. Перед установкой сервера, убедитесь что на данном компьютере установлены компоненты, необходимые для установки и работы сервера.

  • Сервер Базы Данных

    Сервер Базы Данных необходим для хранения данных, связанных с операциями обработки: информация об операторах, пакетах, производимых операциях и т.д. Для демонстрационных проектов можно использовать Microsoft SQL Server Express Edition. Для всех остальных проектов рекомендуется использовать полную версию Microsoft SQL Server и использовать файловое хранилище.

  • Файловое Хранилище

    Рабочие файлы проекта можно хранить в Базе Данных или в отдельном Файловом Хранилище. Файловое Хранилище представляет собой обычную папку с файлами, на компьютере, на котором установлен Сервер Приложений. Настройка использования отдельной папки для хранения файлов проекта осуществляется с помощью Консоли Администрирования и Мониторинга.

  • Сервер Защиты

    Для корректной работы комплекса необходим ключ защиты. Для управления ключами защиты предназначена программа ABBYY FlexiCapture 10 License Manager.

Установка ABBYY FlexiCapture 10
Настройка распределенной работы ABBYY FlexiCapture 10
Архитектура и принципы работы ABBYY FlexiCapture 10
Работа с базой данных и файловым хранилищем


Создание проекта

В рамках одного проекта можно обрабатывать различные документы, для этого в проекте должно быть несколько определений документов. Если же потоки документов не пересекаются и настройки для их обработки сильно отличаются, то для них можно создать отдельные проекты.

Для начала работы нужно создать хотя бы один проект.

Для создания нового проекта запустите Станцию Настройки Проектов и выберите пункт меню Файл>Новый проект…

Подробнее о создании проекта


Обзор создания определения документа

Создание определения документа – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Определение документа определяет расположение элементов документа, указывает, откуда будут извлечены данные.

Для начала создания любого определения документа, нужно запустить Мастер создания определения документа, для этого:

  1. В главном меню Станции Настройки Проектов выберите пункт Проект>Определения документов…
  2. В открывшемся диалоге Определения документов… нажмите кнопку Новое…
  3. Следуйте инструкциям Мастера создания определения документа.

Основные этапы создания определения документа зависят от типа обрабатываемых документов.

Основные этапы создания определения документа для жестких форм
  1. Создание нового определения документа с помощью Мастера создания определения документа. В процессе работы Мастера нужно открыть изображение страницы документа, на основе которого будет произведена разметка определения.
  2. Разметка статических элементов - реперов и идентификаторов, задание их свойств. Статические элементы используются для наложения определения документа и идентификации. Статические элементы обычно выделяются автоматически и им присваиваются свойства по умолчанию.
  3. Разметка полей на изображении. Поля используются для извлечения данных.
  4. Задание свойств полей. Свойства полей влияют и на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку, определяют типы данных и область значений поля.
  5. Для создания определения многостраничных документов: добавление страниц и повторение всех этапов для каждой страницы.
  6. Настройка экспорта данных.
  7. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  8. Тестирование определения на изображениях нескольких документов.

Замечание. Если вы создавали машиночитаемые формы с помощью программы ABBYY FormDesigner, то вместо первых трех этапов достаточно импортировать файл с расширением *.xfd. Откроется изображение страницы с готовой разметкой (или нескольких страниц, если в программе ABBYY FormDesigner была создана многостраничная форма). Подробнее см. Импорт определения для форм, созданных в программе ABBYY FormDesigner.

Основные этапы создания определения для гибких документов
  1. Создание гибкого описания (файл *.afl) с помощью программы ABBYY FlexiLayout Studio. Подробнее см. справку программы ABBYY FlexiLayout Studio.
  2. Создание нового определения документа с помощью Мастера создания определения документа. В процессе работы Мастера нужно открыть изображение страницы документа и подключить гибкое описание (созданный файл *.afl). После завершения работы мастера разметка полей уже будет присутствовать на изображении.
  3. Задание свойств полей. Производится аналогично заданию свойств в описании для жестких форм.
  4. Настройка экспорта данных.
  5. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  6. Тестирование определения на изображениях нескольких документов.

Для документов смешанного типа, содержащих как страницы с жесткими формами, так и полуструктурированные разделы, можно подключить гибкое описание в качестве одного из разделов определения документа. Начните создание определения с любого раздела (гибкого или жесткого), а затем добавьте новый раздел другого типа.

Документы разных типов можно обрабатывать в одном потоке: в одном проекте можно создать определения и для жестких форм, и для гибких документов, и определения для документов смешанного типа. Определение выбирается программой автоматически.

Для обработки документов с приложениями создайте определение документа, а затем в свойствах определения отметьте опцию Допускать страницы приложений. Cм. Создание определений для документов с приложениями.

Подробнее о создании определений документов


Создание типов пакетов документов

Обработка документов осуществляется пакетным образом. Пакеты создаются при импорте или сканировании документов. При этом каждому пакету присваивается определенный тип.

Тип пакета определяет следующие параметры обработки документов:

  • способ предварительной обработки изображений;
  • наложение определений документов;
  • проверка целостности пакета;
  • экспорт пакета по умолчанию;
  • процесс обработки пакета.
Типы пакетов
Создание пакетов документов


Создание профилей импорта

Обработка документов начинается с добавления в пакет новых изображений: это могут быть бумажные документы, которые оператор должен отсканировать, или электронные изображения, которые нужно импортировать.

Добавление изображений возможно:

  • В автоматическом режиме на станциях обработки.

    Для автоматизации импорта изображений, на Станции Настройки Проектов нужно создать профиль импорта изображений с использованием горячей папки. Тогда, на станциях обработки, изображения документов будут импортироваться из горячих папок в автоматическом режиме, без участия операторов.

  • На Станции Сканирования операторы могут добавлять или сканировать изображения в ручном режиме. Для этого Оператору Сканирования на своей станции нужно создать профили сканирования.

    В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

На Станции Настройки Проектов, для отладки определений документов, можно создавать пакеты, добавлять в них изображения документов и обрабатывать их (распознавать, верифицировать, экспортировать данные). Процесс добавления изображений также можно автоматизировать. Для этого на Станции Настройки Проектов оператор может создать профиль импорта изображений с использованием сканера.

Подробнее о создании профилей импорта


Создание пакетов документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

Пакеты могут формироваться автоматически при импорте изображений из горячих папок либо на станции сканирования. Для добавления пакета в ручном режиме выберите пункт контекстного меню Новый пакет, появляющегося при нажатии правой кнопки мыши в главном окне со списком пакетов.

При формировании пакета указывается его тип, определяющий порядок обработки пакета.

Подробнее о создании пакетов документов


Обзор работы оператора с настроенной программой

Оператор работает с программой, уже настроенной для обработки документов определенного типа. Процесс обработки документов не зависит от типа документов и состоит из следующих этапов:

  1. Добавление изображений

    Обработка документов начинается с загрузки изображений: сканирования или добавления изображений в ручном режиме с использованием профилей сканирования. Все действия по загрузке изображений выполняет оператор Сканирования на Станции Сканирования.

  2. Запуск процесса распознавания

    Распознавание производится автоматически на Станции Обработки: программа определяет определение документа по расположению статических элементов, заданных в определениях, производит наложение определения и распознает данные из указанных в определении документа областей - полей.

  3. Верификация

    Верификация – процесс проверки данных – самый трудоемкий этап работы оператора. Он подразделяется на:

    • Верификацию сборки документов – проверку правильности сборки страниц в документы;
    • Групповую верификацию – визуальную проверку группы одинаково распознанных символов;
    • Контекстную верификацию – проверку неуверенно распознанных символов в контексте полей с известной областью значений;
    • Верификацию правил – проверку ошибок правил.
    • Проверку целостности пакета - запуск скриптов проверки целостности пакета и исправление ошибок.

    Для верификации документов в комплексе предусмотрено две станции.

    Первая - Станция Верификации Данных. Оператор Верификации Данных может выполнить только групповую и контекстную верификации данных.

    Вторая - Станция Верификации. Оператор Верификации и Старший Верификатор могут помимо верификации данных осуществлять проверку правильности сборки страниц в документы и ошибок правил.

  4. Экспорт данных

    Экспорт данных осуществляется в автоматическом режиме на Станции Обработки согласно настройкам экспорта, заданным в определении документа. Пакет уходит на экспорт сразу после обработки, либо после подтверждения Старшего Оператора Верификации (соответствующие настройки задаются на тип пакета).

Подробнее о работе оператора с настроенным проектом


Операторы ABBYY FlexiCapture 10

Оператор - это пользователь комплекса, для которого заданы роли и права на обработку документов. В зависимости от выполняемых функций операторы ABBYY FlexiCapture 10 имеют различные права доступа. Права доступа оператора определяются присвоенной ему ролью.

В комплексе ABBYY FlexiCapture 10 предусмотрены следующие роли, которые настраиваются на текущий проект:

  • Оператор Сканирования - роль, под которой оператор может работать на Станции Сканирования;
  • Оператор Верификации Данных - роль, под которой оператор может работать на Станции Верификации Данных и Станции Верификации (доступны контекстная и групповая верификации);
  • Оператор Верификации - роль, под которой оператор может работать на Станции Верификации (доступны проверка данных и ошибок сборки, правил);
  • Старший Оператор Верификации - роль, под которой оператор может работать на Станции Верификации (доступна вся функциональность станции).
  • Оператор Мониторинга - роль, под которой оператор может работать с Консолью Администрирования и Мониторинга (доступно все кроме настроек).
  • Редактор Настроек Проекта - роль, под которой оператор может работать на Станции Настройки Проектов.
  • Администратор - роль, под которой оператор может работать с Консолью Администрирования и Мониторинга (доступна вся функциональность). Кроме этого Администратору доступны все станции комплекса и эти права распространяются на все, а не только текущие проекты, загруженные на Сервер Приложений.

Роль определяет список доступных оператору станций и очередей на этапах обработки, из которых он может получать задания.

Роли Администратора и Оператора мониторинга относятся к комплексу в целом. Остальные роли операторов относятся к конкретным проектам. Кроме того, роли операторов сканирования, верификации данных, а также старшего оператора верификации имеют дифференцированный доступ к различным типам пакетов. Таким образом, пользователь может иметь одновременно следующие роли:

  • Проект А - Редактор Настроек Проекта;
  • Проект Б:
    • Пакеты типа 1 - Старший Оператор Верификации;
    • Пакеты типа 2 - Оператор Верификации Данных.


Добавление изображений

Обычно добавление изображений осуществляется на Станции Сканирования (описание работы на Станции Сканирования приведено в ее справочной системе). Если необходимо, Старший Оператор Верификации на своей станции также может добавить изображения.

Для того чтобы добавить изображения на Станции Верификации, выберите нужный пакет или создайте новый. Изображения импортируются в пакет одним из следующих способов:

  • Сканирование. Для этого выберите в главном меню пункт Файл>Сканировать изображения…
  • Добавление изображений из файлов. Для этого выберите в главном меню пункт Файл>Загрузить изображения…

Для отладки определений документов, изображения можно добавлять в пакеты на Станции Настройки Проектов.

Подробнее о добавлении изображений


Запуск процесса распознавания, анализа и наложения определения документа

Обычно распознавание, анализ и наложение определения документа осуществляются в автоматическом режиме. На Станции Верификации и Станции Настройки Проектов возможен ручной запуск данных операций.

Распознавание производится с помощью пункта Распознавание>Распознать главного меню.

Для предварительного анализа выберите пункт Распознавание>Проанализировать главного меню. Если определение документа может быть наложено, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни одно из определений проекта не может быть наложено на изображение, то страница помечается как нераспознанная (неизвестная).

Программа также позволяет наложить на страницу или на весь документ определенное определение. В большинстве случаев правильно созданное в программе определение накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить его вручную. Чтобы наложить определение документа, выделите документ или страницу, и выберите пункт выберите пункт Распознавание>Наложить определение документа… главного меню.

Подробнее о распознавании


Верификация

Верификация - проверка корректности распознавания, сборки страниц в документы (для многостраничных документов) и выполнения правил. Верификация осуществляется на Станции Верификации Данных (проверка корректности распознавания) и на Станции Верификации (все проверки). Верификация осуществляется в рамках заданий.

Процесс верификации начинается сразу после получения задания. Процесс начинается с групповой верификации, за ней следует контекстная. Если в определении документа нет полей включенных в групповую или контекстную верификацию, то соответствующий этап верификации будет пропущен.

Для многостраничных документов нужно исправить возможные ошибки сборки документов. Сборка страниц в документы производится автоматически. Документы с ошибками сборки помечаются значком [image]. Описание ошибки выводится текстом красного цвета под названием определения документа. При создании определения документа задается правило сборки документа: порядок следования и количество повторений страниц. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа. При несовпадении пользователь увидит сообщение об этом и значения ключевых полей будут отображены красным цветом. Ошибки сборки удобнее всего исправлять в режиме эскизов страниц, т.к. пользователь хорошо видит изображения страниц и их принадлежность к документам.

В процессе групповой верификации на проверку подаются группы одинаково распознанных символов. Задача оператора - выделить отличающиеся символы, распознанные неправильно, и исправить их значения, просмотрев, если нужно, изображения поля с этим символом. При невозможности исправления символы можно пометить как сомнительные.

В процессе контекстной верификации на проверку подаются поля с известной областью значения. Задача оператора - проверить неуверенно распознанные символы в контексте всего поля. Контекстная верификация имеет два режима: режим просмотра одного поля с нарезкой символов и режим просмотра нескольких однотипных полей.

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки. Ошибки формата помечаются значком [image]. Оператору нужно проверить поля с ошибками и, по возможности, исправить их значения.

Верификация производится в окне документа (открывается двойным щелчком мыши на названии документа или страницы). В окне документа пользователь видит уже не отдельные поля, а весь документ целиком. Также ему видны все неуверенно распознанные символы, ошибки правил и т.д.

Подробнее о верификации


Экспорт

Экспорт данных осуществляется автоматически. При необходимости может быть создана отдельная очередь подтверждения экспорта оператором верификации. В этом случае экспорт выполняется после получения подтверждения. Экспорт осуществляется согласно настройкам, заданным в определении документа.

Если Вы хотите выполнить экспорт документа в ручном режиме, выберите один из пунктов в меню Файл>Экспортировать в:

  • файлы данных… - для экспорта информации в файлы;
  • файлы изображений… - для экспорта изображений в файлы;
  • базу данных… - для экспорта в базу данных.

При необходимости измените настройки экспорта, используемые по умолчанию, и выполните экспорт.

Подробнее об экспорте


Установка и запуск программы

В данном разделе содержится основная информация об установке, защите и запуске программы ABBYY FlexiCapture 10, системные требования для установки программы.

Программные и аппаратные требования
Установка программы ABBYY FlexiCapture 10
Запуск программы


Программные и аппаратные требования

Аппаратные требования

  1. ПК с процессором семейств Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™/Core™ i5/Core™ i7, AMD K6/Turion™/Athlon™/Duron™/Sempron™, тактовая частота 2ГГц или выше.
  2. Оперативная память
    • Станция сканирования, удаленные станции Верификации и Верификации данных: 1ГБ;
    • Другие станции: 512 МБ на каждое ядро процессора, но не менее 1ГБ;
    • Серверы: 2ГБ и 2 ГБ, если MS SQL Server установлен на том же компьютере.
  3. Место на диске
    • Удаленные станции Верификации и Верификации данных: 100 МБ;
    • Другие станции: 1 ГБ;
    • Серверы: 100 МБ для установки, 2 ГБ для базы данных (при использовании Microsoft SQL Server Express Edition). При использовании файлового хранилища необходимо дополнительное место на диске.
  4. Сканер с поддержкой TWAIN, WIA или ISIS.
  5. Интернет-соединение для активации серийного номера, USB-порт для аппаратного ключа защиты.
  6. Видеоплата и монитор с разрешением не менее 1024×768.
  7. Клавиатура, мышь или другое указательное устройство.

Программные требования

Серверы:

  1. Операционная система
    • Windows Server 2003 SP2;
    • Windows Server 2008 SP2;
    • Windows Server 2008 R2.

    На 64-битных операционных системах программа работает в режиме эмуляции.

    Для работы с локализованным интерфейсом операционная система должна обеспечивать необходимую языковую поддержку.

  2. Internet Information Server 6, 7 или 7.5 (для сервера приложений).
  3. .NetFramework 3.5 SP1.
  4. Crystal Reports for Visual Studio 2008 или 2010.
  5. Internet Explorer 7.0 или выше.
  6. Сервер базы данных - Microsoft SQL Server 2005 SP2, 2008 SP1 или 2008 R2, Oracle 10g или 11g.

Станции

  1. Операционная система:
    • Windows XP SP2;
    • Windows Vista SP2,
    • Windows 7;
    • Windows Server 2003 SP2;
    • Windows Server 2008 SP2 или R2 + Desktop Experience.

    На 64-битных операционных системах программа работает в режиме эмуляции.

    Для работы с локализованным интерфейсом операционная система должна обеспечивать необходимую языковую поддержку.

    Рекомендуемый шрифт для работы с системой - Arial Unicode MS. При использовании других шрифтов возможны проблемы при работе с языками группы CJK.

  2. .Net Framework 3.5 SP1 при использовании скриптов .Net и для Станции сканирования, устанавливаемой с помощью ClickOnce.
  3. Microsoft Internet Explorer 7, 8 или 9 - для станции мониторинга и установки станции сканирования с использованием ClickOnce.
  4. SilverLight 4.0.60129 или выше и один из следующих браузеров для web-станции Верификации Данных:
    • Microsoft Internet Explorer 7 или выше;

      Web-станция ввода документовn, Web-станция сканирования и Web-станция верификации данных поддерживают работу только с Internet Exporer 32-бит. Работа на 64-битных операционных системах поддержана в режиме эмуляции.

    • FireFox 3.6 или выше с дополнением IETabs;
    • Opera 11.0 или выше;
    • Google Chrome 8.0 или выше;
    • Safari 5.0 или выше.

Серверы и рабочие станции (за исключением удаленных и web-станций) должны входить в один домен Active Directory.

Поддерживаемые терминальные серверы

  • Citrix Presentation Server 4.5
  • Citrix XenApp 5.0

Поддерживаемые виртуальные машины

  • VMware Server 2.0 и выше
  • VMware Workstation 6.5 и выше

Виртуальные машины VMware ESXi 4.0 и Hyper-V не поддерживают работу с USB устройствами.


Установка ABBYY FlexiCapture 10

На время установки программы ABBYY FlexiCapture 10 рекомендуем вам закрыть все другие приложения (например, Microsoft Outlook, Microsoft Word и т.п.).

Внимание! При установке временные файлы копируются в папку, определяемую переменной окружения %temp%. При возникновении проблем с установкой проверьте, что данная папка доступна и в ней достаточно свободного места для записи временных файлов.

Установка ABBYY FlexiCapture 10 включает в себя следующие этапы:

  1. Установка серверов ABBYY FlexiCapture 10.
  2. Установка станций ABBYY FlexiCapture 10.

После установки при необходимости проведите дополнительную настройку комплекса.

Установка серверов ABBYY FlexiCapture 10
Установка станций ABBYY FlexiCapture 10
Настройка распределенной работы ABBYY FlexiCapture 10


Установка серверов ABBYY FlexiCapture 10

Установка серверов осуществляется с помощью одноименного пункта меню установочного диска. Для работы ABBYY FlexiCapture 10 необходимо установить следующие серверы:

  • Сервер Приложений
  • Сервер Базы Данных
  • Сервер Обработки
  • Сервер Защиты

Далее описывается процесс установки каждого сервера.

Сервер Приложений

Перед установкой Сервера Приложений необходимо убедиться в том, что на компьютере установлены необходимые компоненты.

Если эти компоненты не установлены, их (кроме Internet Information Services) можно установить с установочного диска ABBYY FlexiCapture 10 (Autorun, 2. Распределенная установка>1. Установка внешних компонент).

Если компоненты установлены, то можно приступить к установке Сервера Приложений. Для этого в меню Autorun выберите 2. Распределенная установка>2. Установка серверов, далее следуйте инструкциям мастера установки. В диалоге Выборочной установки выберите Сервер приложений.

Замечание. Для того чтобы скопировать инсталлятор станций на сервер, в диалоге Выборочной установки также отметьте пункт Инсталлятор станций. В этом случае установку станций можно будет произвести не с установочного диска ABBYY FlexiCapture 10, а с сервера (компьютер, на который установлен Сервер Приложений).

Для того чтобы установить Web-cтанцию Верификации Данных, Web-cтанцию Сканирования и Web-cтанцию Ввода документов, в диалоге Выборочной установки отметьте пункт Web-станции. В этом случае операторы смогут получить доступ к станциям через браузер. Для установки Модуля аутентификации веб клиентов отметьте также соответсвующий подпункт. Изменять указанные по умолчанию пути установки нельзя.

Замечание. Для того чтобы были установлены пререквизиты (напр., Ajax.Net), установку или изменение конфигурации программы нужно запускать с помощью файла setup.exe.

После того как Сервер Приложений будет установлен, автоматически запустится Консоль Администрирования и Мониторинга, которая позволяет настроить соединение с базой данных и распределить права операторам.

Сервер Базы Данных

Сервер базы Данных необходим для хранения данных связанных с операциями обработки: информация об операторах, пакетах, производимых операциях и т.д. Если объем обрабатываемых документов не превышает 100 000 страниц в день и работает не больше 50 станций верификации, то можно использовать Microsoft SQL Server Express Edition. Если необходимо обрабатывать большее количество документов, то рекомендуется использовать полную версию Microsoft SQL Server.

Версию Microsoft SQL Server Express Edition можно установить с установочного диска ABBYY FlexiCapture 10. Для этого в меню Autorun выберите 2. Распределенная установка>1. Установка внешних компонент.

Сервер Обработки

Сервер Обработки распределяет задания между Станциями Обработки. Вместе с сервером устанавливается Монитор Сервера Обработки, который позволяет отслеживать работу сервера и устанавливать приоритеты выполнения заданий.

Для того чтобы установить Сервер Обработки в меню Autorun выберите 2. Распределенная установка>2. Установка серверов, далее следуйте инструкциям мастера установки. В диалоге Выборочной установки выберите Сервер Обработки.

После того как Сервер Обработки будет установлен, его необходимо сконфигурировать (запустить сервер, добавить станции обработки и т.д.).

Сервер Защиты

Для работы комплекса необходим ключ защиты, который должен быть активирован на сервере активации ABBYY. Это может быть сделано из программы Менеджер лицензий, которая автоматически запустится после установки Сервера Защиты.

Для того чтобы установить Сервер Защиты в меню Autorun выберите 2. Распределенная установка>2. Установка серверов, далее следуйте инструкциям мастера установки. В диалоге Выборочной установки выберите Сервер защиты.

Менеджер лицензий позволяет управлять лицензиями (добавлять, активировать, выбирать рабочую) и просматривать их параметры.


Установка станций ABBYY FlexiCapture 10

Установка станций осуществляется с помощью одноименного пункта меню Autorun, который нужно запустить с установочного диска ABBYY FlexiCapture 10. Также станции можно установить по сети с сервера в случае, если во время установки Сервера Приложений инсталлятор станций был скопирован на сервер.

Для работы ABBYY FlexiCapture 10 необходимо установить следующие станции:

  • Станция Настройки Проектов

  • Станция Сканирования

  • Станция Верификации Данных

  • Станция Верификации

  • Станция Обработки

Станции Сканирования, Верификации и Верификации Данных могут работать как в локальной сети, так и удаленно, через Интернет, авторизация при этом осуществляется с помощью логина и пароля.


Сетевая установка программы ABBYY FlexiCapture 10

Программа ABBYY FlexiCapture 10 обладает удобными возможностями для установки и работы в сети.

Для сетевой установки станций необходимо при установке Сервера приложений выбрать пункт Инсталлятор станций. При этом необходимые для установки станций файлы будут скопированы на сервер.

Сетевая установка программы ABBYY FlexiCapture 10 нужна для удобного развертывания программного комплекса на несколько компьютеров. Сетевая установка производится в два этапа: на сервер при установке Сервера приложений копируется дистрибутив станций ABBYY FlexiCapture 10, после чего установка системы на рабочие станции осуществляется по локальной сети.

Подробнее о сетевой установке см. Руководство администратора по установке, которое вы также можете открыть из меню Autorun.


Восстановление и удаление программы ABBYY FlexiCapture 10

Чтобы восстановить испорченные или удаленные файлы:

  1. Выберите пункт меню Пуск>Панель управления>Установка и удаление программ, выберите в списке программу ABBYY FlexiCapture 10 Servers или ABBYY FlexiCapture 10 Stations и нажмите на кнопку Изменить.

  2. Выберите пункт Исправить и нажмите кнопку Далее.

Чтобы удалить программу ABBYY FlexiCapture 10:

  1. Выберите пункт меню Пуск>Панель управления>Установка и удаление программ, выберите в списке программу ABBYY FlexiCapture 10 Servers или ABBYY FlexiCapture 10 Stations и нажмите на кнопку Удалить.

  2. Подтвердите удаление программы.


Запуск программы

Службы серверов и станций обработки ABBYY FlexiCapture 10 запускаются автоматически. Станции и Сервер Обработки могут находиться в запущенном или остановленном состоянии. Запуск Сервера Обработки осуществляется с помощью Монитора Сервера Обработки. Станции обработки запускаются пользователем либо Сервером Обработки в автоматическом режиме (при соответствующих настройках).

Для мониторинга и управления Сервером Обработки или Сервером Приложений выберите следующие пункты в меню Пуск:

  • Пуск/Программы/ABBYY FlexiCapture 10 Servers/Сервер обработки для запуска Монитора Сервера обработки.
  • Пуск/Программы/ABBYY FlexiCapture 10 Servers/Консоль администрирования и мониторинга для открытия в браузере главной страницы Консоли администрирования и мониторинга Сервера Приложений.

Запуск станций ABBYY FleixCapture 10 осуществляется с помощью пунктов, расположенных в меню Пуск/Программы/ABBYY FlexiCapture 10 Stations.

Ключи в реестре, задающие параметры запуска программы

В реестре (в подразделе Shell\StartUp) можно задать следующие ключи, позволяющие контролировать параметры запуска программы:

  • Project - задает проект, открываемый автоматически при запуске программы;
  • Batch - задает пакет, открываемый автоматически при запуске программы, (работает, только если задан проект);
  • ProhibitChangePath - позволяет запретить в режиме оператора менять пакет и проект, открываемые автоматически (для этого нужно установить значение ключа True).

В реестре ключи по умолчанию не создаются. Администратор при необходимости может добавить эти ключи в реестр пользователя.

Ключи реестра можно перекрыть соответствующими параметрами запуска FlexiCapture через командную строку.

Параметры запуска программы через командную строку

Для запуска станций через командную строку используются следующие параметры:

FlexiCapture.exe [/Station:(Setup,Validator,Verificator)] [/Project:"путь к проекту"] [/Batch:"имя пакета"] [/ProhibitChangePath].

  • [/Station:(Setup,Validator,Verificator)] - определяет запускаемую станцию (настройки проектов, верификации или верификации данных соответственно). Если режим не указан, при запуске программы появляется диалог для выбора нужного режима;
  • [/Project:"путь к проекту"] - задает проект, открываемый автоматически;
  • [/Batch:"имя пакета"] - задает пакет, открываемый автоматически;
  • [/ProhibitChangePath] - позволяет запретить изменять в режиме оператора проект и пакет, открываемые автоматически.


Использование пакетов, созданных в предыдущих версиях ABBYY FormReader

Использование определений документов, созданных в предыдущих версиях ABBYY FlexiCapture

Определения, созданные в ABBYY FormReader 6.5 и 6.0, можно импортировать в ABBYY FlexiCapture 10.

При этом импортируется разметка страниц (кроме служебных полей) и типы данных. Типы данных копируются в папку Пользовательские в типах данных определения документа. См. Типы данных текстового поля ввода.

Внимание! Правила проверки и настройки экспорта не импортируются. Также не импортируются изображения, содержащиеся в пакете.

Чтобы импортировать определение, созданное в ABBYY FormReader 6.5 или 6.0:

  1. Запустите Станцию Настройки Проектов ABBYY FlexiCapture 10.
  2. Создайте новый проект или откройте один из существующих проектов, в который вы хотите импортировать определение из предыдущей версии.
  3. Выберите пункт главного меню Проект > Определения документов…
  4. В диалоге со списком определений документов нажмите кнопку Импорт…
  5. В списке типов файлов (Files of type) выберите Пакеты FormReader 6.5 (*.frm) и укажите файл пакета.

В списке определений документов появится новое, созданное на основе импортированного пакета. Если в пакете было несколько определений, то все они появятся в списке. Если в ABBYY FormReader 6.5 была задана структура для многостраничных документов, то описанные в этой структуре определения будут объединены в одно многостраничное определение документа.

Советы.

  1. Подробно об использовании правил в старой и новой версии см. Различия в правилах FormReader 6.5 и FlexiCapture 10.
  2. Рекомендации по переходу от использования правила проверки с условием, Automation-правил и Automation-экспорта в FormReader 6.5 к использованию скриптов во FlexiCapture 10 вы найдете в статье Переход к скриптам в программе FlexiCapture 10 после использования FormReader 6.5.


Архитектура и принципы работы ABBYY FlexiCapture 10

ABBYY FlexiCapture 10 – это комплекс ввода данных с бумажных документов, представляющий собой распределенное клиент-серверное приложение.

В состав комплекса ABBYY FlexiCapture 10 входят несколько станций и серверов. Станции комплекса управляются соответствующими операторами. Серверы комплекса работают в автоматическом режиме.

Перед непосредственной обработкой документов комплекс необходимо настроить:

  • установить соединение с базой данных (через Консоль Администрирования и Мониторинга)

  • создать проекты (на Станции Настройки Проектов оператором с правами администратора)

  • настроить проекты (на Станции Настройки Проектов оператором с правами Редактора настроек проекта)

  • настроить права и роли операторов станций для каждого проекта (через Консоль Администрирования и Мониторинга)

  • запустить Сервер Обработки

После того как комплекс настроен, операторы могу начать обработку документов:

  • добавить изображения документов

    На Станции Сканирования можно отсканировать или добавить уже отсканированные изображения. На Станции Обработки автоматически можно регистрировать изображения из Горячей Папки.

  • распознать загруженные изображения документов

    Распознавание производится в автоматическом режиме (без участия оператора) на Станции Обработки. Задания для станций распределяются на Сервере Обработки.

  • проверить результаты распознавания

    Для проверки распознанных данных предназначены Станция Верификации Данных и Станция Верификации. Оператор Станции Верификации с правами Оператора верификации может провести более глубокую проверку: проверить сборку документов, ошибки правил уровня пакета.

  • экспортировать результаты распознавания

    Экспорт результатов распознавания происходит в автоматическом режиме на Станции Обработки.


Серверы ABBYY FlexiCapture 10

Комплекс ABBYY FlexiCapture 10 (Distributed installation) представляет собой набор станций и серверов. На станциях выполняются однотипные операции по обработке документов, а серверы обеспечивают работу комплекса. В состав комплекса входят следующие серверы:

  • Сервер приложений
  • Сервер базы данных
  • Сервер обработки
  • Сервер лицензий
  • Файловое хранилище (рекомендуется)

Замечание. Для сервера базы данных и файлового хранилища можно создать резервные копии.


Сервер Приложений

Сервер Приложений предназначен для обеспечения корректной работы комплекса ABBYY FlexiCapture 10. Сервер Приложений осуществляет взаимодействие между станциями комплекса.

Сервер Приложений рекомендуется устанавливать до установки рабочих станций. Перед установкой сервера, убедитесь что на компьютере установлены необходимые компоненты.

Замечание. Если эти компоненты не установлены, их (кроме Internet Information Services) можно установить с установочного диска ABBYY FlexiCapture 10. Internet Information Services является компонентом Windows и распространяется совместно с операционной системой.

Внимание:
  1. Для корректной работы Сервера приложений при использовании брандмауэра необходимо разрешить работу службы World Wide Web Publishing Service.
  2. Для аутентификации Станции сканирования с помощью логина и пароля, а не Windows-аутентификации, необходимо настроить Internet Information Server: включить Basic Autentication на уровне папки FlexiCapture/Server.

После того как Сервер Приложений будет установлен, автоматически запустится Консоль Администрирования и Мониторинга (устанавливается вместе с сервером), которая позволяет настроить соединение с базой данных и распределить права операторам.


Сервер базы данных

Сервер Базы Данных предназначен для хранения внутренней информации об операторах, пакетах, операциях, статусах заданий, ходе обработки и извлеченных данных.

С установочного диска ABBYY FlexiCapture 10 можно установить Microsoft SQL Server Express Edition, который позволяет обрабатывать до 100 000 страниц в день и использовать до 50 станций верификации. Если необходимо обрабатывать больший объем документов, то рекомендуется использовать полную версию Microsoft SQL Server.

Замечание. Если не используется отдельное Файловое Хранилище, то рабочие файлы проекта также хранятся в Базе Данных.


Сервер Обработки

Сервер Обработки предназначен для распределения заданий между станциями обработки. Вместе с сервером устанавливается Монитор Сервера Обработки, который позволяет отслеживать работу сервера и устанавливать приоритеты выполнения заданий. Непосредственная обработка документов происходит на Станции Обработки.

После того как Сервер Обработки будет установлен, его необходимо сконфигурировать: запустить сервер, добавить, настроить и запустить станции обработки, включить работу горячих папок.

Замечание. Перед запуском Сервера Обработки необходимо убедиться, что учетной записи (<имя домена\имя компьютера>$), под которой работает сервер, выданы права доступа - Сервер обработки.

Далее описан процесс настройки Сервера Обработки:

  1. Запуск Сервера Обработки.
  2. Запуск Станций Обработки.
  3. Включение Горячих папок проекта.

  • Для того чтобы запустить Сервер Обработки необходимо:

    1. Запустить Монитор Сервера Обработки (Пуск>Программы>ABBYY FlexiCapture 10 Servers> Сервер Обработки).
    2. В дереве сервера выбрать Серверы ABBYY FlexiCapture 10, вызвать контекстное меню и выбрать команду Добавить сервер…
    3. В диалоге Добавить сервер обработки указать расположения сервера (Сетевой хост или Локальный хост).
    4. Открыть диалог Свойства сервера обработки (Действия>Свойства) и указать путь к Серверу Приложений (http://server). Если Сервер Обработки и Сервер Приложений установлены на одном компьютере, его имя должно быть указано прямо: использование IP-адреса 127.0.0.1 или выражения localhost сделает невозможным работу станций обработки.

      Замечание. На Сервере Приложений необходимо с помощью Консоли администрирования и мониторинга присвоить компьютеру, на который установлен Сервер Обработки, соответствующую роль).

    5. Запустить Сервер Обработки по кнопке [image].

      Замечание. Предусмотрено два режима остановки Сервера Обработки: немедленная и "мягкая". Если по каким-либо причинам вам требуется остановить Сервер Обработки (например, при обновления оборудования или переноса базы данных), вы можете выполнить "мягкую" остановку. Для этого выберите пункт Остановить в меню Действия. При выборе "мягкой" остановки выполняется завершение текущих заданий, после чего Сервер Обработки останавливается. Новые задания при этом не берутся.
      Для немедленного завершения работы Сервера Обработка выберите пункт Остановить немедленно. При этом текущие задания будут завершены неуспешно.

  • Для того чтобы настроить станции обработки необходимо:

    1. В дереве сервера обработки выбрать Станции и нажать кнопку [image], в открывшемся диалоге Добавление станций выбрать станцию из списка всех компьютеров. Также можно указать имя компьютера или его IP-адрес. Имя компьютера можно указывать и при использовании динамических IP-адресов. IP-адреса можно использовать в том случае, если возникают проблемы с доступом к DNS сети.
    2. Открыть диалог Свойства станции с помощью пункта Действия>Свойства главного меню и указать параметры станции:
      • Имя - отображаемое имя станции;
      • Автоматический запуск - признак запуска станции автоматически Сервером Обработки;

        Замечание. Частые попытки запуска большого количества станций могут привести к значительному замедлению работы Сервера Обработки;

      • Требуется места на диске - минимальное количество дискового пространства для работы станции обработки. Если доступного пространства станет меньше, станция будет остановлена. Минимальное значение, которое может быть указано в этом поле, должно превышать утроенный максимальный размер изображения, встречающегося в обработке. Оптимальное значение этого параметра соответствует удвоенному максимальному размеру пакета, встречающегося в обработке;
      • Максимальное количество процессов - максимальное количество ядер, которые можно использовать для обработки заданий;
      • Допустимое количество процессов - допустимое количество ядер для обработки заданий. Данный параметр рассчитывается автоматически в зависимости от параметров компьютера и используемой лицензии, и не может быть изменен;
      • Приоритет - приоритет процесса обработки;
      • Допустимые типы заданий - типы заданий, которые может обрабатывать станция:
        • Импорт изображений - задания импорта
        • Распознавание страниц - предобработка экспорта
        • Поддержка верификации - слияние результатов двойной верификации, а также пред- и постобработка заданий для Web-станции верификации и Web-станции верификации данных.
        • Пользовательская обработка - обработка скриптов обработки пакета и документа
        • Экспорт документов - задания отправки документов
    3. Запустить станцию по кнопке [image].

      Замечание. Предусмотрено два режима остановки Станции Обработки: немедленная и "мягкая". Если по каким-либо причинам вам требуется остановить Станцию Обработки (например, при обновления оборудования), вы можете выполнить "мягкую" остановку. Для этого выберите пункт Остановить в меню Действия. При выборе "мягкой" остановки выполняется завершение текущих заданий, после чего Станция Обработки останавливается. Новые задания при этом не берутся.
      Для немедленного завершения работы Станции Обработка выберите пункт Остановить немедленно. При этом текущие задания будут завершены неуспешно.

    Замечание. Права на обработку документов станциям выдает Сервер Обработки при подключении.

  • Для того чтобы включить Горячие папки проекта необходимо:

    1. в дереве сервера обработки выбрать Горячие папки
    2. в списке всех проектов выбрать нужный
    3. и в контекстном меню выбрать команду Подключить.

      Замечание. В проекте необходимо отметить опцию Проверять Горячую папку каждые N секунд.

  • Для настройки журнала Сервера обработки необходимо:
    1. открыть диалоговое окно Настройки монитора сервера обработки, выбрав в главном меню пункт Файл>Настройки…
    2. указать, какие именно сообщения должны отображаться в журнале (Ошибки, Предупреждения, Информационные сообщения).
    3. указать, необходимо ли удалять информацию о завершенных заданиях, с помощью опции Убирать завершенные задания из списка.
    4. указать, при наличии каких сообщений необходимо сохранять информацию о задании в журнале.

      Замечание. Отключать опцию Убирать завершенные задания из списка в рабочем режиме нежелательно: это может привести к накоплению большого объема данных и значительному замедлению работы монитора Сервера Обработки. Рекомендуется отключать эту опцию только при настройке и отладке комплекса.

    5. Для просмотра лога задания нажмите [image]. Чтобы сохранить лог задания в формате *.txt, в открывшемся диалоге нажмите кнопку Экспортировать…


Сервер лицензий

Сервер Защиты

Для работы комплекса необходим ключ защиты, который должен быть активирован на сервере активации ABBYY.

В комплексе ABBYY FlexiCapture 10 поддержано два вида ключа защиты:

  • аппаратный ключ защиты или
  • программный ключ защиты.

Защита аппаратным ключом

Защита аппаратным ключом представляет собой защиту с помощью ключа для USB-порта (USB-ключ).

Работа с программой возможна только в том случае, если ваш ключ защиты подключен к USB-порту компьютера, на который был установлен Сервер Защиты. Активация аппаратного ключа возможно только автоматически через интернет.

В аппаратном ключе записаны параметры лицензии.

Внимание! Для работы с USB-ключами защиты необходимо, чтобы запускался стандартный сервис SmartCard.

Защита программным ключом

Программный ключ представляет собой лицензионный файл.

Для корректной работы ABBYY FlexiCapture 10 с программным ключом лицензионный файл должен быть активирован на сервере активации ABBYY. Это может быть сделано из программы ABBYY FlexiCapture 10 License Manager, которая автоматически запустится после установки Сервера Защиты.

Информация для активации передается в виде кода (Product ID), который генерируется на основе информации о компьютере, на который установлена программа ABBYY FlexiCapture 10. При генерации кода не используется никакая персональная информация о пользователе или его компьютере и этот код не может быть использован для идентификации пользователя.

Способы активации:

  • Автоматически через интернет (рекомендуется)

    Активация через интернет производится автоматически и занимает всего несколько секунд. Для активации лицензионного файла этим способом требуется подключение компьютера к интернету.

  • По электронной почте

    Для активации по электронной почте нужно отправить автоматически сгенерированное на компьютере, на котором установлен сервер защиты, сообщение, содержащее необходимую для активации информацию. Чтобы обеспечить быстрый ответ от почтового робота, пожалуйста, не изменяйте текст и тему письма.

  • По электронной почте с другого компьютера

    Для активации по электронной почте с другого компьютера нужно сохранить автоматически сгенерированное на компьютере, на котором установлен сервер защиты, сообщение, содержащее необходимую для активации информацию. На другом компьютере создать письмо, в тело которого вставить сгенерированное сообщение и отправить его по электронной почте. Чтобы обеспечить быстрый ответ от почтового робота, пожалуйста, не изменяйте текст и тему письма.

Повторная активация

Вы можете переустанавливать Сервер Защиты на том же компьютере неограниченное число раз без повторной активации. Однако, если вы производили значительные обновления, форматировали жесткий диск или переустанавливали операционную систему, вам может понадобиться повторная активация.

Для каждого серийного номера ведется подсчет количества возможных активаций. После превышения этого лимита активация невозможна. Пользователь может освободить активированную лицензию, используя деактивацию, при этом счетчик активаций уменьшится.

Управление лицензиями

Для управления лицензиями (добавление, активация, выбор рабочей, деактивация) и получения информации о лицензиях программы ABBYY FlexiCapture 10 служит программа ABBYY FlexiCapture 10 License Manager, которая устанавливается вместе с Сервером Защиты.

Чтобы запустить программу ABBYY FlexiCapture 10 License Manager:

  • В меню Пуск>Программы>ABBYY FlexiCapture 10 Servers>Инструменты выберите пункт ABBYY FlexiCapture 10 License Manager.

Добавление новой лицензии

Чтобы добавить лицензию

  1. В главном окне программы ABBYY FlexiCapture 10 License Manager нажмите на кнопку Активировать...
  2. В открывшемся диалоге введите новый серийный номер, нажмите на кнопку Далее и следуйте инструкциям Мастера активации ABBYY FlexiCapture 10.

    Замечание. В случае если еще не было добавлено ни одной лицензии, после запуска ABBYY FlexiCapture 10 License Manager автоматически будет запущен Мастер активации ABBYY FlexiCapture 10 и откроется диалог ввода серийного номера.

Обновление лицензии

При необходимости можно обновить лицензию, загрузив актуальную информацию с сервера регистрации ABBYY. Для этого выполните следующие действия:

  1. В главном окне программы ABBYY FlexiCapture 10 License Manager выберите лицензию и нажмите кнопку Обновить...
  2. Выберите способ обновления (аналогично активации) лицензии и обновите ее.

Выбор рабочей лицензии

Чтобы выбрать лицензию

  1. В главном окне программы ABBYY FlexiCapture 10 License Manager выберите лицензию, которую вы хотите использовать.
  2. Нажмите на кнопку Выбрать или выберите соответствующий пункт в локальном меню лицензии.

Параметры лицензии

При выборе лицензии в поле Параметры лицензии отображаются следующие параметры: серийный номер, тип лицензии, ограничения по количеству используемых станций и инструментов разработки, ограничения по времени и производительности и т.д.

Замечание. В зависимости от типа лицензии, ограничения на количество используемых станций могут указываться как отдельно для установленных и Web-станций, так и совместно для станций обоих типов.

Деактивация лицензии

Для освобождения (деактивации) лицензии в главном окне программы ABBYY FlexiCapture 10 License Manager выберите Деактивировать в локальном меню лицензии, которую требуется деактивировать.


Файловое хранилище

Файлы проекта (документы, определения документов и т.д.) следует хранить в специальном файловом хранилище. Расположение файлового хранилища указывается с помощью Консоли Администрирования и Мониторинга. Хранилище должно располагаться на том же компьютере, что и Сервер Приложений. Необходимо указывать локальный (c:\\...), а не сетевой (\\server\...) путь к хранилищу. Если хранилище не указано, файлы хранятся в базе данных.

Замечание. Хранение файлов проекта в базе данных может приводить к значительной загрузке SQL-сервера, так как обрабатываемые изображения обычно занимают много места. Поэтому нежелательно использовать базу данных для хранения файлов проекта, за исключением файлов демо-проектов.

Размер файлового хранилища зависит от обрабатываемых изображений. Приблизительно оценить требуемый размер файлового хранилища можно следующим образом: средний размер обрабатываемого изображения * количество изображений в комплексе * 2.


Станции ABBYY FlexiCapture 10

Станции комплекса:

  • Станция Настройки Проектов

  • Станция Сканирования

  • Станция Обработки

  • Станция Верификации Данных

  • Станция Верификации

  • Web-станция Верификации Данных

  • Web-станция Сканирования

  • Web-станция Ввода Докуменов

Комплекс также включает Консоль Администрирования и Мониторинга.


Станция Настройки Проектов

Станция Настройки Проектов предназначена для создания, настройки и отладки проектов: определений документов, типов пакетов, настроек импорта изображений, экспорта документов и процесса обработки.

Для того чтобы создать и настроить проект, необходимо:

  • Создать проект и загрузить его на Сервер Приложений.
  • Открыть проект на сервере и задать его свойства.
  • Создать Определения документов.
  • Создать Типы Пакетов.
  • Создать Профили импорта изображений.

Внимание. Права на создание нового проекта есть только у Администратора комплекса. Оператор Настройки Проектов осуществляет настройку уже созданных проектов.

  1. Создание Проекта

    После того как Администратор комплекса настроил соединения с Базой Данных, ему необходимо:

    • запустить Станцию Настройки Проектов (Пуск>Программы>ABBYY FlexiCapture 10 Stations>Станция Настройки Проектов),
    • создать проект
    • и загрузить его на Сервер Приложений.

    После того как проект будет загружен на Сервер Приложений, Администратор комплекса может выдать права Оператору Настройки Проектов на настройку этого проекта.

  2. Свойства проекта

    Для того чтобы задать свойства проекта, Оператору Настройки Проектов необходимо:

    • Запустить Станцию Настройки Проектов;
    • В диалоге Открыть существующий проект на сервере (Файл>Открыть проект на сервере…) указать путь к Серверу Приложений;
    • В открывшемся диалоге Выбрать проект в списке всех проектов на сервере, выбрать нужный
    • Открыть диалог свойств проекта (Проект>Свойства проекта…) и задать его свойства: параметры предварительной обработки изображений, распознавания документов, обработчиков событий, экспорта и процесса обработки.

  3. Создание Определений документов

    Для определения принципов, по которым будет происходить идентификация и обработка определенных типов документов, Оператору Настройки Проектов необходимо создать определения документов. Определение документа содержит информацию о структуре документа, расположении полей, настройках экспорта и процессе обработки документов данного типа и т.д. Для создания определений в комплексе предусмотрен Мастер создания определения документа, а настройка свойств ведется в Редакторе определения документа.

  4. Создание Типов Пакетов

    В комплексе ABBYY FlexiCapture 10 предусмотрен режим пакетной обработки документов: перед началом обработки создается пакет, в него добавляются изображения документов и далее все документы проходят стадии обработки в этом пакете. Обычно пакет соответствует пачке документов, отсканированных за один раз, или импортированных из определенного каталога. Настройки, с которыми будут обрабатывать пакеты документов, задаются в Типе Пакета. Можно создать несколько Типов Пакетов с наиболее часто используемыми наборами настроек обработки. Тогда, при создании нового пакета, оператор может задать его тип. В этом случае пакет будет обрабатываться согласно настройкам выбранного Типа Пакета.

    Замечания.

    • Если не было создано ни одного Типа Пакетов, документы обрабатываются в пакетах с настройками по умолчанию, заданными в свойствах проекта.
    • Верифицировать и экспортировать документы можно не только целыми пакетами, но и по документно. Эти настройки также задаются в Типе Пакета.

  5. Создание Профилей импорта изображений

    Чтобы автоматизировать процесс добавления изображений на Станции Настройки можно создать Профили импорта изображений. Предусмотрено создание двух типов профилей: с использованием сканера, с использованием горячей папки. Профиль импорта с использованием сканера можно использовать для отладки проекта. Импорт с помощью горячих папок производится в автоматическом режиме на Станции Обработки.

    Замечания.

    • Профиль импорта изображений с использованием сканера доступен только на Станции Настройки Проектов.
    • Для запуска импорта изображений с помощью горячих папок необходимо включить их для данного проекта с помощью Монитора Сервера Обработки.


Консоль Администрирования и Мониторинга

Внимание. Для корректной работы Консоли администрирования и мониторинга в браузере должны быть разрешены JavaScript и всплывающие окна.

Консоль администрирования и мониторинга позволяет выполнять два типа операций: настройку комплекса перед работой и непосредственно мониторинг работы.

Консоль администрирования и мониторинга является web-интерфейсом пользователя Сервера Приложений. Консоль предоставляет доступ к Серверу приложений с помощью обычного интернет-браузера. Консоль можно открыть на любом компьютере, имеющем доступ к Серверу приложений, указав в адресной строке браузера строку http://<AppServer>/FlexiCapture10, где вместо <AppServer> необходимо указать наименование компьютера, на который установлен Сервер Приложений.

Консоль администрирования и мониторинга автоматически запускается после завершения установки сервера. Это позволяет сразу после установки настроить соединение с Базой Данных: подключиться к уже созданной или создать новую.

Замечание. Оператор, который создает Базу Данных на Сервере Приложений, автоматически получает права Администратора комплекса.

Для того чтобы настроить соединение, откройте страницу Текущие настройки (Сервис>Сервер приложений) и нажмите на кнопку Подключиться к существующей базе данных, чтобы подключиться к уже созданной базе данных или Создать новую базу данных, чтобы создать новую. Затем, последовательно, в соответствующих полях, укажите:

  • Имя экземпляра сервера

  • Имя базы данных

  • В разделе Аутентификация для доступа к базе данных укажите тип аутентификации

  • Использовать файловое хранилище

    Файловое хранилище используется для хранения файлов проектов. Файлы демо-проектов можно хранить в Базе Данных, для остальных проектов нужно использовать файловое хранилище - локальную папку на компьютере, на котором установлен Сервер Приложений. Для этого отметьте опцию Использовать внешнее файловое хранилище и пропишите локальный путь к папке.

При обновлении может возникнуть необходимость изменить структуру базы данных. Для этого необходимо использовать скрипт, предоставляемый вместе с обновлением. Для запуска скрипта нажмите кнопку Применить обновление и укажите путь к файлу скрипта на открывшейся странице.

Кроме установки соединения с Базой Данных, Администратору необходимо настроить права доступа и распределить роли для операторов станций.

Внимание. Права Администратору, Оператору Мониторинга, Серверу Обработки выдаются на все проекты. Поэтому их можно задать сразу после установки соединения с Базой Данных. Всем остальным операторам комплекса права выдаются на определенный проект. Поэтому прежде чем задать им права, Администратор должен создать и экспортировать на Сервер Приложений проекты. До тех пор, пока на Сервере Приложений нет ни одного проекта, добавить таких операторов и задать для них права нельзя.

Права доступа, предоставляемые Оператору Мониторинга, имеют следующие ограничения:

  • Не разрешается удаление страниц в разделе Мониторинг > Сессии. Просмотр раздела разрешен.
  • Не разрешается удаление пакетов в разделе Мониторинг > Пакеты. Просмотр раздела разрешен.
  • Не разрешается просмотр всех разделов на закладке Сервис (Сервер приложений, Очистка, Необрабатываемые документы, Режим записи в журнал событий).
  • Не разрешается просмотр всех разделов на закладке Разрешения (Пользователи, Группы, Запросы).

Вторая задача станции - это мониторинг работы комплекса (отслеживание текущего состояния комплекса и формирование отчетов). На основании полученных сведений о текущем состоянии системы принимаются решения об изменении конфигурации или перераспределении ресурсов.

В комплексе можно получить информацию о текущем состоянии Пакетов, Заданий, Сессий, Состояние обработки, Журнал событий и Журнал ошибок.

Для этого укажите проект и в меню Мониторинг выберите соответствующий пункт. Полученный список можно просмотреть на экране, распечатать или сохранить в формате CSV.

Оператор Мониторинга, работающий с Консолью Администрирования и Мониторинга может получать информацию не только о текущем состоянии комплекса, но и создавать отчеты о работе комплекса.

Можно создать следующие отчеты:

  • Общий отчет о работе операторов позволяет оценить загрузку операторов на выбранном этапе или получить информацию о загрузке выбранного оператора на всех доступных этапах или определенном этапе.
  • Общий отчет об обработке документов и Отчет об обработке документов клиента отображает следующую информацию о документах, обработанных за заданный период времени: число обработанных пакетов, документов и страниц, число подтвержденных полей и символов и т.д.
  • Отчет об обработке исключений отображает информацию о заданиях, отправленных в исключения.
  • Отчет о выполнении заданий на станциях обработки может применяться в пилотных проектах для вычисления загрузки и определения узких мест системы. Данный отчет позволяет сравнить производительность на рабочих станциях, сгруппированных по типу этапу.
  • Старые отчеты - отчеты, заимствованные из предыдущей версии:
    • Общий отчет об обработке документов отображает количество документов проекта, обработанных на каждом этапе (сканирование, распознавание и т.д.).
    • Полный отчет о работе операторов верификации данных позволяет получить информацию о работе всех операторов верификации данных с детализацией по заданиям.
    • Общий отчет о работе операторов верификации данных позволяет получить общую информацию о работе операторов без детализации по заданиям.
    • Полный отчет о работе операторов верификации позволяет получить информацию о работе всех операторов верификации с детализацией по заданиям.
    • Общий отчет о работе операторов верификации показывает общую информацию о работе операторов без детализации по заданиям.
    • Попакетный отчет операторов верификации отображает информацию о работе операторов с детализацией по типам пакетов.
    • Полный отчет операторов сканирования отображает информацию о работе операторов сканирования с детализацией заданиям.

    • Подробная информация о работе с Консолью Администрирования и Мониторинга приведена в справочной системе Консоли Администрирования и Мониторинга.


Станция Сканирования

Внимание. Подробную информацию о работе станции вы сможете найти в Справке Станции Сканирования.

Станция Сканирования призвана решить задачу поточного сканирования большого объема документов. Станция Сканирования может работать как в локальной сети, так и удаленно, через Интернет, авторизация при этом осуществляется с помощью логина и пароля.

Она может быть первой в процессе обработки документов. Работой этой станции управляет Оператор Сканирования, который для добавления изображений может:

  • создать и использовать профили сканирования и/или ручного добавления изображений документов
  • добавить уже отсканированные изображения документов из папки

Профили помогают автоматизировать процесс добавления изображений, т.е. выполнить добавление с заданными настройками по нажатию одной кнопки.

Помимо непосредственного добавления изображений Оператор Сканирования может редактировать добавленные изображения (более подробную информацию вы сможете найти в Справке Станции Сканирования).

Сценарий действий Оператора Сканирования:

  • Запустить Станцию Сканирования. При запуске Станции Сканировании происходит загрузка типов пакетов с сервера, если при настройке проекта или Станции Сканирования были указаны соответствующие настройки. Если автоматическое получение типов пакетов с сервера не настроено, типы пакета можно загрузить вручную после запуска станции.
  • При наличии не отправленного пакета продолжить его обработку. При отсутствии таких пакетов создать новый.
  • Если профили импорта уже созданы, выбрать один из профилей и запустить сканирование. Если профилей нет, каждый оператор может создать необходимые ему профили и использовать их.
  • В процессе добавления изображений оператор может визуально контролировать качество и при необходимости отредактировать изображения или даже, поменяв настройки, пересканировать нужные страницы.
  • Проконтролировать качество сборки страниц в документы и исправить, если необходимо.
  • Отправить готовый пакет на сервер задав регистрационные параметры.
  • Повторить действия для обработки следующей партии изображений документов или закрыть станцию.


Станция Верификации Данных

Станция Верификации Данных предназначена для проверки неуверенно распознанных символов. Оператор Верификации Данных последовательно выполняет проверку неуверенно распознанных символов в документах в режиме групповой, а затем контекстной верификации. Станция Верификации Данных может работать как в локальной сети, так и удаленно, через Интернет, авторизация при этом осуществляется с помощью логина и пароля.

В процессе групповой верификации на проверку подаются группы одинаково распознанных символов. Задача оператора - выделить отличающиеся символы, распознанные неправильно, и исправить их значения, просмотрев, если нужно, изображения поля с этим символом. При невозможности исправления символы можно пометить как сомнительные.

В процессе контекстной верификации на проверку подаются поля с известной областью значения. Задача оператора - проверить неуверенно распознанные символы в контексте всего поля. Контекстная верификация имеет два режима: режим просмотра одного поля с нарезкой символов и режим просмотра нескольких однотипных полей.

Замечание. Помимо Оператора Верификации Данных доступ к станции имеют Оператор Верификации и Старший Оператор Верификации. Но независимо от того какой из этих операторов работает на станции, ему доступна только очередь верификации данных.

Для того чтобы запустить проверку данных необходимо:

  • Запустить Станцию Верификации Данных (Пуск>Программы>ABBYY FlexiCapture 10 Stations>Станция Верификации Данных)
  • В открывшемся диалоге выбрать проект.
  • Запустить верификацию, нажав на кнопку

    Замечание. Процесс начинается с групповой верификации, за ней следует контекстная. Если в определении документа нет полей включенных в групповую или контекстную верификацию, то документ не попадет в очередь на верификацию.

При необходимости можно включить режим автоматического получения заданий, нажав кнопку [image] или выбрав в меню пункт Задания>Получать задания автоматически.

По окончании работы пакет (порция документов) отправляется для последующей обработки на следующий этап, определяющийся настройками процесса обработки.

В случае возникновения проблем при обработке пакета Оператор Верификации Данных может отправить пакет (документы) как проблемный на этап Исключений, нажав на кнопку [image].


Станция Верификации

Станция Верификации предназначена для более сложной проверки, чем Станция Верификации Данных. Помимо проверки распознанных данных, станция позволяет обрабатывать проблемные пакеты (документы), осуществлять проверку ошибок сборки, правил, целостности пакета. Станция Верификации может работать как в локальной сети, так и удаленно, через Интернет, авторизация при этом осуществляется с помощью логина и пароля.

Отличие удаленной станции Верификации от локальной состоит в том, что удаленная станция Верификации не поддерживает фоновые процессы, такие как импорт, распознавание и экспорт. Таким образом, операции, которые включают фоновые процессы (например, наложение Определения документа, требующее распознавания), могут выполняться только на локальной станции Верификации.

На Станции Верификации могут работать операторы: Оператор Верификации Данных, Оператор Верификации, Старший Оператор Верификации. В зависимости от Роли, под которой зашел оператор, он может видеть и обрабатывать задания только из определенных очередей:

  • Оператор Верификации Данных может обрабатывать задания только из очереди Верификация данных;
  • Оператор Верификации может обрабатывать задания со всех этапов, кроме Исключений и Подтверждения экспорта;
  • Старший Оператор Верификации может обрабатывать задания из всех очередей. Помимо списка очередей, Старшему Оператору Верификации также доступен список пакетов (см. описание ниже), а также вид просмотра каждой очереди, который позволяет выбрать конкретную задачу в очереди.

Замечание. Список доступных ролей зависит от прав оператора. Если оператору доступна только одна роль, список ролей показываться не будет.

Очереди, доступные для обработки на Станции Верификации.

  • Любая

    Из этой очереди оператор станции может взять задание, сформированное в любой очереди. Список доступных очередей зависит от Роли, под которой оператор зашел на станцию. Задания берутся в порядке заданного приоритета.

  • Верификация Данных

    Процесс проверки данных начинается с групповой верификации, за ней следует контекстная. Если в определении документа нет полей включенных в групповую или контекстную верификацию, то документ не попадет в очередь на верификацию.

  • Проверка сборки документов

    Для многостраничных документов нужно исправить возможные ошибки сборки документов. Правило сборки документа задается при создании определения документа и определяет порядок следования и количество повторений страниц. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа. При несовпадении оператор увидит сообщение об этом и значения ключевых полей будут отображены красным цветом. Ошибки сборки удобнее всего исправлять в режиме эскизов страниц, т.к. оператор хорошо видит изображения страниц и их принадлежность к документам.

  • Верификация

    В случае, если параметрами обработки не определены отдельные очереди, в очередь на Верификацию попадают все задания с ошибками сборки документов, проверки данных и правил.

  • Проверка целостности пакета

    Правила, задающие проверку целостности пакета, устанавливают связь между данными документов пакета и служат для проверки этих данных.

  • Подтверждение экспорта

    Экспорт данных может происходить в двух режимах - автоматическом и ручном. В случае, если параметрами обработки не определена отдельная очередь для подтверждение экспорта, документы экспортируются в автоматическом режиме. Если отдельная очередь определена, то Старший Оператор Верификации сначала должен проверить документы в задании, после чего они отправляются на Экспорт. В случае возникновения ошибок при экспорте, документы автоматически попадут в очередь Исключений.

  • Исключения

    В очередь исключений попадают проблемные пакеты (документы), которые операторы или станции по каким-то причинам не смогли обработать.

Замечание. Параметры обработки документов (использование отдельных очередей) настраиваются для Типов Пакетов или на проект, если типы пакетов не создаются.

Для того, чтобы выполнить задание, в списке очередей необходимо выбрать нужную и нажать на кнопку [image]. При этом будет сформировано задание из текущей очереди.

При необходимости можно включить режим автоматического получения заданий, нажав кнопку [image] или выбрав в меню пункт Задания>Получать задания автоматически.

Просмотр документов задания возможен в режимах Детали и Эскизы страниц. В режиме Детали отображаются только документы текущего задания. В режиме Эскизы страниц отображаются все страницы пакета, при этом страницы, не входящие в текущее задание, выделены серым.

Помимо списка очередей с заданиями Старшему оператору верификации также доступен полный список пакетов данного проекта. Для этого необходимо выбрать пункт меню Вид>Пакеты или нажать соответствующую кнопку на панели инструментов.

В режиме просмотра пакетов оператору доступна информация об уверенности распознавания пакета, количестве страниц и документов, типе пакета и т.д. Выделив мышью пакет из списка, можно отправить его на любой этап обработки, задать приоритет, выбрать конкретного пользователя и дополнить комментарием. Таким образом, можно собрать документы пакета, находящиеся в различных очередях обработки и отправить их на один этап.

С помощью двойного щелчка можно раскрыть пакет, просмотреть список документов, отверифицировать данные, исправить возможные ошибки правил, сборки и т.д. Выделив мышью один или несколько документов, можно отправить выборочные документы на какой-либо этап обработки, сформировать для них отдельное задание.

Замечание. При отправке пакетов на стадии, следует проверять, что документы пакета не входят в уже сформированные задания, так как иначе будут созданы пустые задания. Проверить, входит ли документ в задание, можно в столбце ID задания документа.


Web-станция Верификации Данных

Так же, как и Станция Верификации Данных, Web-станция Верификации Данных предназначена для проверки неуверенно распознанных символов. Оператор последовательно выполняет проверку неуверенно распознанных символов в документах в режиме групповой, а затем контекстной верификации.

Использование Web-станции Верификации Данных позволяет работать на станции через Интернет. Для подключения к станции можно использовать как Windows-аутентификацию, так и базовую аутентификацию. Для входа на станцию используется следующая ссылка: http://<Application_Server>/dataverification, где <Application_Server> - имя компьютера, на который установлен Сервер Приложений.

При работе с заданиями на Web-станции Верификации Данных, вы можете выполнить следующие действия с помощью ссылок в правом нижнем углу страницы: просмотреть Свойства задания, Сохранить изменения локально на рабочей станции, Отменить задание или Отправить задание в Исключения.

Замечание. Некоторые функции Станции Верификации Данных не доступны при рабочет через Web-интерфейс, в том числе:

  • добавление новых изображений в задание;
  • сохранение изображений на локальный компьютер (вы можете только отправить задание на сервер FlexiCapture);
  • автоматическая проверка некоторых правил. Проверка выполняется при нажатии кнопки Проверить правила, а также при принятии документа или пакета;
  • анализ и перераспознавание документа. Значения неналоженных или неверно наложенных полей необходимо вводить вручную. Для гибких описаний также можно использовать режим быстрого ввода данных из кеша распознавания.

Подробнее о работе со Станцией Верификации Данных через Web-интерфейс читайте в справке Web-станции Верификации Данных.


Web-станция Сканирования

Web-станция Сканирования предназначена для сканирования бумажных документов и отправки их для дальнейшей обработки на сервер ABBYY FlexiCapture 10. Оператор последовательно выполняет сканирование или загрузку изображений из файлов, коррекцию изображений (при необходимости) и отправку их на сервер.

Работа на Web-станции Сканирования осуществляется через Интернет. Для подключения к станции можно использовать как Windows-аутентификацию, так и базовую аутентификацию. Для входа на станцию используется следующая ссылка: http://<Application_Server>/Scanning, где <Application_Server> - имя компьютера, на который установлен Сервер Приложений.

Замечание: Некоторые функции Станции Сканирования не доступны при рабочет через Web-интерфейс, в том числе:

  • создание документов на этапе сканирования и разделение пакетов на документы;
  • сохранение изображений на локальный компьютер (вы можете только отправить задание на сервер FlexiCapture);
  • редактирование изображений.

Подробнее о работе со Станцией Сканирования через Web-интерфейс читайте в справке Web-станции Сканирования.


Web-станция Ввода Документов

Web-станция Ввода Документов предназначена для удаленного внесения информации с бумажных документов в систему. Оператор последовательно выполняет сканирование документов с последующей корректировкой полученных изображений, проверку и исправление распознанных данных и экспорт испавленных данных.

Работа на Web-станции Ввода Документов осуществляется через Интернет. Для подключения к станции можно использовать как Windows-аутентификацию, так и базовую аутентификацию. Для входа на станцию используется следующая ссылка: http://<Application_Server>/Capture, где <Application_Server> - имя компьютера, на который установлен Сервер Приложений.

Замечание: Некоторые функции обычных станций не доступны при рабочет через Web-интерфейс, в том числе:

  • создание документов на этапе сканирования и разделение пакетов на документы;
  • автоматическая проверка некоторых правил. Проверка выполняется при нажатии кнопки Проверить правила, а также при принятии документа или пакета;
  • анализ и перераспознавание документа. Значения неналоженных или неверно наложенных полей необходимо вводить вручную. Для гибких описаний также можно использовать режим быстрого ввода данных из кеша распознавания.

Подробнее о работе с Web-станцией Ввода Документов читайте в справке Web-станции Ввода Документов.


Станция Обработки

Станции Обработки работают в автоматическом режиме и выполняет следующие задания: загрузка изображений из Горячих Папок, применение определений документов и распознавание, экспорт результатов в заданные хранилища. Распределением заданий между станциями занимается Сервер Обработки.

Для того чтобы просмотреть текущие задания, выполняемые станцией, необходимо:

  1. Запустить Монитор Станции Обработки (Пуск>Программы>ABBYY FlexiCapture 10 Stations>Станция Обработки).

    Замечание. Чтобы запустить Станцию Обработки, в Мониторе Сервера Обработки выберите команду Запустить в локальном меню выбранной станции или в меню Действия. Также можно запустить станцию, нажав соответствующую кнопку на панели. Станция работает в качестве службы.

  2. В открывшемся диалоге Подключиться к станции указать расположение Сервера Обработки.
    • Сетевой хост и имя компьютера, на котором установлен Сервер Обработки (если Сервер Обработки и Станция Обработки установлены на разные компьютеры).
    • Локальный хост (если Сервер Обработки и Станция Обработки установлены на один компьютер).

Все текущие задания, выполняемые Станцией Обработки отображаются в столбце Задание. По каждому из заданий можно просмотреть следующую информацию: Время запуска, Прогресс выполнения задания, Статус задания, Приоритет выполнения задания, Имя станции, Создатель задания. Сортировать задания можно по каждому столбцу.


Этапы обработки

Процесс обработки документов проходит в несколько этапов, на каждом из которых выполняется определенное действие (автоматически или с участием оператора). Все этапы упорядочены, и для прохождения этапа, необходимо, чтобы предыдущие были пройдены. В общем виде процесс обработки сводится к этапам: добавление изображений, распознавание, верификация, экспорт.

На каждом из этапов формируется очередь из заданий на обработку (подробнее см. Формирование заданий). Очередь представляет собой набор заданий на соответствующем этапе. В процессе обработки документы перемещаются от начальной очереди (Сканирование) до финальной (Обработано).

Для повышения эффективности обработки при больших объемах, этап верификации можно разделить на более мелкие, которые будут обрабатывать разные операторы. Т.е. создать отдельные этапы для верификации данных, верификации, проверки сборки документов, проверки целостности пакета, подтверждения экспорта.

Некоторые этапы обработки и соответствующие очереди опциональны, в то время как другие являются обязательными. Необходимость того или иного этапа зависит от выбранного режима обработки.

Очереди

  1. Сканирование

    Задания этого этапа обрабатываются на Станции Сканирования. В Обычном режиме пакеты на этом этапе обрабатываются целиком.

  2. Повторное сканирование

    Задания этого этапа обрабатываются на Станции Сканирования. Задание всегда отправляется тому оператору, который выполнял сканирование.

  3. Распознавание

    Распознавание производится на Станции Обработки автоматически. В Обычном режиме пакеты на этом этапе обрабатываются целиком

  4. Проверка сборки документов

    Задания этого этапа обрабатываются на Станции Верификации. Если в настройках не указан отдельный этап проверки сборки, документы (пакеты) с ошибками сборки будут обработаны на этапе Верификация.

  5. Верификация данных

    Задания этого этапа могут быть обработаны на Станции Верификации Данных или на Станции Верификации.

  6. Верификация

    В случае, если параметрами обработки не определены отдельные этапы, на этап Верификации попадают все задания с ошибками сборки документов, проверки данных и правил. Задания этого этапа обрабатываются на Станции Верификации.

  7. Проверка целостности пакета

    На этот этап попадают пакеты с ошибками проверки целостности. Условия проверки целостности пакета задаются с помощью скриптов в настройках Типа Пакета. Задания этого этапа обрабатываются на Станции Верификации.

  8. Подтверждение экспорта

    Этот этап позволяет усилить контроль за качеством данных. Пакет (документ) будет экспортирован только, если оператор подтвердит экспорт. Задания этого этапа обрабатываются на Станции Верификации.

  9. Экспорт

    Задания этого этапа обрабатываются на Станции Обработки.

  10. Обработано

    На этот этап отправляются обработанные документы.

  11. Исключения

    В эту очередь попадают документы, при автоматической обработке которых возникли ошибки. Операторы также могут отправить в эту очередь документы, которые по каким-то причинам не могут быть обработаны.

Формирование заданий

Для достижения наибольшей эффективности можно разбить на отдельные задания.

Задания создаются из документов на Сервере Приложение, как только документы приходят на этап и должны стать доступными для обработки. Задания формируются в зависимости от указанных настроек процесса обработки.

В Расширенном режиме число документов в задании можно указать в свойствах этапа.

Если отмечена опция Ожидать все документы пакета, число документов в задании не ограничено. Документы, отправленные на этап в составе некоторого задания, будут находиться в ожидании завершения обработки всех документов данного пакета.

Этап проверки целостности пакета требует возможности доступа оператора ко всем документам пакета, поэтому на данном этапе оператор всегда получает пакет целиком.

Также возможно пересылать на этап задания, которые были сформированы ранее, например при отправке документов на этап на Станции Верификации, если в диалоге оптравки была отмечена опция Сформировать задание.

Замечание. Для заданий, созданных в более ранних версиях ABBYY FlexiCapture, а также для заданий, выпавших из процесса обработки, необходимо заново сформировать задания в Консоли Администрирования и Мониторинга.

Режим обработки выбирается в настройках Типа пакета.

См. также Типы пакетов, Настройка процесса обработки, Процесс обработки.


Процесс обработки

Процесс обработки документов может проводиться с использованием как преднастроенных схем обработки, так и пользовательской схемы. Преднастроенная схема может быть автоматической (Автоматический режим), либо с участием операторов (Обычный режим). Для настройки пользовательской схемы обработки используется Расширенный режим. Также существует отдельный режим для Web-станции ввода документов.

Особенности режимов Обычный, Расширенный, Автоматический и для Web-станции ввода документов:

В Обычном режиме обработка происходит с участием операторов. В этом режиме можно использовать отдельные этапы для пересканирования, верификации данных, проверки сборки документа, верификации, проверки целостности пакета и подтверждения экспорта. Для верификации данных, проверки сборки документа, верификации, проверки целостности пакета и подтверждения экспорта можно также использовать web-станции. Документы (или пакеты целиком) могут проходить данные этапы автоматически (при отсутствии ошибок) или после проверки и исправления оператором. В очередь исключений попадают документы, при обработке которых возникли ошибки. Также документы могут быть оправлены в очередь исключений операторами.

В Расширенном режиме можно настроить сложные схемы обработки. Этот режим позволяет изменять настройки базовых этапов, а также создавать пользовательские этапы и включать их в процесс обработки. Также в этом режиме можно использовать двойную верификацию, что позволяет осуществлять проверку документов двумя различными операторами на Станции верификации или Станции верификации данных. Использование Расширенного режима также позволяет обрабатывать документы и пакеты при помощи скриптов.

В Автоматическом режиме документы обрабатываются и экспортируются без участия операторов. В случае возникновения ошибок, нераспознанные изображения можно сохранить в отдельную папку (настраивается на закладке Экспорт), а обработанные документы будут автоматически экспортированы. В автоматическом режиме пакеты обрабатываются целиком.

В режиме для Web-станции ввода документов можно указать условие отправки документов на верификацию. Данный режим применятся к документам, обрабатываемым на Web-станции ввода документов.

Последовательность обработки пакета указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и таким образом формируется последовательность обработки этого пакета.

В случае, если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект.


Настройка программы

Перед началом массового ввода документов, программа должна быть настроена для обработки документов нужного типа. Все необходимые настройки выполняются на Станции Настройки Проектов.

Для того, чтобы настроить обработку документов, нужно создать проект, который включает в себя:

  • профили импорта изображений
  • одно или несколько определений документов
  • типы пакетов документов для обработки.

В проект можно включать различные определения документов, тогда разные документы будут обрабатываться в рамках одного проекта в зависимости от наложенного определения. Тем не менее, если потоки документов не пересекаются, то для них можно создать отдельные проекты.

Создание проекта
Определения документов
Профили импорта изображений
Настройки экспорта по умолчанию
Типы пакетов
Пакеты документов
Индексные поля


Настройка комплекса ABBYY FlexiCapture 10

Для настройки распределенной работы ABBYY FlexiCapture необходимо выполнить следующие действия:

  1. Настроить сервер приложений с помощью Консоли администрирования и мониторинга.
  2. Загрузить проект на сервер приложений.
  3. Настроить права доступа пользователей к проекту с помощью Консоли администрирования и мониторинга.
  4. Настроить работу сервера и станций обработки с помощью Монитора сервера обработки.
  5. Настроить процесс обработки с помощью Станции настройки проектов.


Настройка Сервера Приложений

Настройка Сервера Приложений осуществляется Администратором комплекса с помощью Консоли Администрирования и Мониторинга.

Для того чтобы настроить Сервер Приложений необходимо запустить Консоль Администрирования и Мониторинга, перейти на страницу Создание новой базы данных (Сервис>Сервер приложений) и последовательно задать:

  • Имя экземпляра сервера
  • Имя базы данных
  • Тип аутентификации

    Замечание. Вы можете выбрать Windows аутентификацию или Аутентификацию сервера базы данных. Рекомендуется использовать Аутентификацию сервера базы данных, так как Windows аутентификация может не работать в некоторых конфигурациях. Для проверки выбранного типа подключения используйте кнопку Протестировать соединение.
    Дли обоих вариантов аутентификации требуются права администратора на сервер базы данных.

  • Использовать файловое хранилище и указать путь к папке

    Замечание. Папка для хранения файлов проекта должна располагаться на том же компьютере, на котором установлен Сервер Приложений, если Сервер Приложений не развернут на кластере.

Файлы проекта можно хранить как в специальной папке - Файловом хранилище, так и непосредственно в базе данных. Если файловое хранилище не используется, файлы хранятся в базе данных. Базу данных можно использовать для хранения файлов демо-проектов. Для остальных проектов нужно указать резервное файловое хранилище.


Настройка прав доступа пользователей

Настройка прав доступа пользователей осуществляется Администратором комплекса с помощью Консоли Администрирования и Мониторинга. Администратор предоставляет права доступа пользователям и назначает роли операторам.

Подробнее о настройке прав доступа смотрите в справке Консоли Администрирования и Мониторинга.


Настройка Сервера и Станций Обработки

Настройка Сервера Обработки осуществляется с помощью приложения Монитор сервера обработки, который автоматически устанавливается вместе с сервером.

Для того чтобы настроить Сервер Обработки необходимо:

  1. Запустить Монитор сервера обработки (Пуск>Программы>ABBYY FlexiCapture 10 Servers>Сервер обработки)
  2. Добавить сервер указав его расположение (Действия>Добавить сервер…)
  3. Прописать путь к Серверу Приложений (Действия>Свойства)
  4. Запустить Сервер Обработки (Действия>Запустить)

    Замечание. Для запуска Сервера Обработки Администратор должен выдать права учетной записи, под которой работает сервер (т.е.<имя домена\имя компьютера>$).

  5. Сформировать список станций обработки, задать их свойства и запустить станции:
  • Чтобы добавить станцию, нужно перейти в раздел Станции в дереве сервера обработки и выбрать Действия>Добавить станции…
  • Чтобы настроить станцию, нужно выбрать ее в списке всех добавленных станций, вызвать контекстное меню станцию и выбрать Свойства.
  • В открывшемся диалоге настроить параметры станции: запуск, приоритет, допустимые типы заданий и т.д.

    Внимание. Максимальное количество одновременно выполняющихся процессов (поле Максимальное количество процессов) не может превышать допустимого количества (поле Допустимое количество процессов). При этом общее количество одновременно выполняющихся процессов на всех Станциях Обработки не может превышать заданного в лицензии значения. Т.е. если в процессе запуска станций этот лимит будет превышен, оставшиеся станции не запустятся.

Станции Обработки и Сервер Обработки могут работать под разными учетным записями. Однако по умолчанию или в случае запуска под службой Network Service Станции Обработки работают под такой же учетной записью, что и Сервер Обработки. Права станциям выдает Сервер Обработки при подключении станций к нему.

Монитор Сервера Обработки также позволяет настроить работу Горячих Папок.

Для того чтобы включить Горячие Папки проекта необходимо:

  1. В дереве сервера обработки выбрать Горячие папки;
  2. В списке всех проектов выбрать нужный;
  3. В главном окне выбрать команду Действия>Подключить.

Замечание. Регистрация изображений из Горячих Папок начнется только после подключения соответствующего проекта на Сервере Обработки.

Помимо настройки, Монитор Сервера Обработки позволяет устанавливать приоритеты выполнения заданий и отслеживать их выполнение. Для этого перейдите в узел Задания дерева сервера обработки.

В списке заданий доступна информация о типе задания (импорт из горячей папки, предобработка, распознавание, экспорт), времени начала выполнения, названии пакета, прогрессе выполнения, статусе, приоритете, авторе и названии станции, выполняющей задание, а также указывается путь к проекту.

С помощью контекстного меню задания (а также с помощью соответствующих кнопок на панели инструментов) можно изменить приоритет его выполнения. Градация приоритетов - высокий, нормальный, низкий. Это позволит обеспечить более быструю обработку важного задания и отложить обработку менее критичных документов.

Успешно выполненное задание имеет статус Успешно, при возникновении ошибок в процессе выполнения заданию присваивается статус Неудачно. Так же статус отображается в виде иконки рядом с названием задания.

Замечание. Если в процессе выполнения задания возникают информационные сообщения, предупреждения, ошибки, но при этом выполнение задания считается успешным (проблемы не являются критичными для задания), то отследить подобные состояния можно по иконкам выполненных заданий. Например, подобная ситуация может возникнуть в случае неудачно выполненного необязательного варианта экспорта документов из-за отсутствия доступа к приемнику данных.

С помощью пункта Просмотреть журнал можно открыть дополнительное окно с детализацией всех действий, выполняемой программой в процессе обработки выделенного задания (например, можно отследить процесс выбора программой нужного определения документа при распознавании документа, изучить информационные сообщения и предупреждения).

Список всех событий можно сохранить в текстовый файл (*.txt). Для этого выберите пункт Экспортировать список…

По умолчанию Монитор сервера обработки настроен так, что информация об успешно завершенных заданиях автоматически удаляется из списка заданий. Дополнительно настроить отображение и удаление заданий из списка можно с помощью меню Файл>Настройки…. Снимите опцию Убирать завершенные задания из списка, если требуется хранить в списке полную статистику выполнения заданий на сервере обработки.


Настройка процесса обработки

Последовательность обработки пакета указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и таким образом формируется последовательность обработки этого пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…, закладка Процесс обработки).

Настройка процесса обработки пакетов осуществляется на закладке Процесс обработки диалога Свойства Типа пакетов.

Предусмотрено четыре режима обработки: Обычный, Расширенный, Автоматический и для Web-станции ввода документов.

Обычный режим включает следующие этапы: Сканирование, Повторное сканирование, Распознавание, Верификация данных, Проверка сборки документов, Верификация, Проверка целостности пакета, Подтверждение экспорта, Экспорт и Обработано.

Вы можете настроить следующие параметры обработки:

  1. Обрабатывать пакеты целиком
    • если опция отмечена, то пакет обрабатывается целиком (т.е. до тех пор, пока не будут обработаны все документы пакета, он не будет отправлен на следующий этап).
    • если опция не отмечена, то документы по мере обработки будут отправляться на следующий этап, не дожидаясь обработки всех документов пакета.
  2. Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен - документ будет направлен на верификацию только при наличии ошибок, либо если количество подсвеченных символов больше значения, указанного в поле % на документ.
    Замечание. Если в настройках контекстной верификации какого-нибудь поля документа выбрано значение всегда, то документ обязательно будет направлен на верификацию.
  3. Использовать отдельные этапы для:
    • Повторное сканирование
    • Верификация данных
    • Проверка сборки документов
    • Верификация
    • Проверка целостности пакета
    • Подтверждение экспорта

    Все этапы, кроме этапа Верификация, необязательны.

    Формируя отдельные очереди, можно разбить работу по проверке распознанных документов на этапы и выделить на каждую отдельного оператора. Таким образом, оператор верификации будет занят одной задачей - либо проверкой данных, либо проверкой сборки документов и т.д.

    Если все эти очереди обрабатывает один оператор, то в этом случае ему нужно будет последовательно выполнить задания: сначала забрать документ из очереди на проверку сборки документа, только проверив сборку он сможет проверить данные, взяв задание из очереди на верификацию данных и т.д.

    Также можно использовать web-станции для всех этапов, за исключением этапа Повторное сканирование. Для этого в столбце Разрешить web-станции поставьте галочку напротив нужного этапа. Верификация данных будет осуществляться на web-станции Верификации данных, остальные этапа будут обрабатываться на web-станции Верификации.

В режиме Расширенный можно настраивать сложные схемы обработки. Этот режим позволяет как редактировать базовые этапы, так и создавать этапы самостоятельно.

Замечание: Существует задержка во времени между тем, когда настройки применяются на Станции настройки проекта и тем, когда они отражаются на Станции верификации.

Режим Расширенный включает следующие базовые этапы:

  • Исключения
  • Сканирование
  • Повторное сканирование
  • Распознавание
  • Автоматическая обработка
  • Верификация данных
  • Верификация
  • Проверка сборки документов
  • Проверка целостности пакета
  • Подтверждение экспорта
  • Экспорт
  • Обработано

Отметьте этапы, которые должны быть включены в схему обработки. Все этапы, кроме Scanning и Обработано, опциональны.
Чтобы изменить порядок следования этапов, используйте кнопки Выше и Ниже справа. Для этапов, которые не могут быть выполнены ранее или позднее, соответствующие кнопки отключены.

Для каждого этапа в столбце Документов в задании указано максимальное количество документов, которое может содержаться в задании. Чтобы изменить это количество для выбранного этапа, щелкните по числу и введите новое значение.
Замечание: На этапах Проверка целостности пакета и Обработано пакеты обрабатываются целиком и не разделяются на задания, поэтому для этих этапов изменить число документов в задании нельзя.

В столбце Базовый тип для каждого этапа указан его базовый тип - тип, настройки которого использовались при создании данного этапа.

Для каждого этапа можно просматривать и редактировать его свойства. Чтобы открыть диалоговое окно с настройками для выбранного этапа, нажмите кнопку Правка… справа. Смотрите также Свойства этапа.

Помимо базовых этапов, можно также создавать пользовательские этапы и включать их в процесс обработки. Пользовательские этапы могут быть созданы на основе инструментов этапов. Добавление пользовательских этапов позволяет создавать этапы, имеющие один базовый тип, но различные свойства этапа.

Для добавления этапа нажмите кнопку Этап… справа. В открывшемся окне выберите базовый этап, на основе которого будет создан пользовательский этап и укажите свойства нового этапа. Созданный этап будет включен в схему. Смотрите также Создание пользовательских этапов.
Чтобы удалить выбранный пользовательский этап, нажмите кнопку Удалить справа.

Если переход на этап определяется условиями, этап отмечен значком [image]. Если документы всегда допускаются на этап, этап имеет значок [image].

В режиме Автоматический документы обрабатываются и экспортируются без участия операторов. В случае возникновения ошибок, нераспознанные изображения можно сохранить в отдельную папку (настраивается на закладке Экспорт), а обработанные документы будут автоматически экспортированы. В автоматическом режиме пакеты обрабатываются целиком.

Режим для Web-станции ввода документов позволяет указать условие отправки документов на верификацию при работе на Web-станции ввода документов. Отметьте опцию Пропускать верификацию и верификацию данных, если процент символов, требующих верификации, меньше или равен, если вы хотите отправлять документы на верификацию только при наличии ошибок, либо если количество подсвеченных символов больше значения, указанного в поле % на документ


Создание пользовательских этапов

Добавление пользовательских этапов происходит в режиме Расширенный настройки процесса обработки.
Чтобы добавить пользовательский этап, нажмите кнопку Этап… справа. В открывшемся окне Создание этапа обработки содержится список базовых и ранее созданных пользовательских этапов, на основе которых можно создать новый этап. Свойства выбранного этапа отображаются в нижней части диалогового окна под заголовком Выбранные настройки.

В режиме Расширенный можно создать этап одного из следующих тип:

  1. Автоматические - задания этого типа выполняются на Станции обработки без участия оператора.
    Этап Автоматические включает следующие подэтапы:
    • Распознавание
    • Unattended Processing
    • Экспорт
  2. Интерактивные - задания этого типа обрабатываются операторами на Станции верификации, Станции верификации данных и Станции сканирования.
    Этап Интерактивные включает следующие подэтапы:
    • Scanning
    • Верификация данных
    • Проверка сборки документов
    • Верификация
    • Проверка целостности пакета
    • Подтверждение экспорта
  3. Пользовательские - задания этого типа обрабатываются внешними клиентами при помощи Web Service API и возвращаются на следующий этап.

Замечание: Чтобы включить в схему скрипт обработки, выберите этап Автоматические.

Выберите этап, на основе которого будет создан пользовательский этап, и нажмите OK. Откроется окно Свойства этапа обработки. Это окно содержит следующие закладки:

  • Общие
  • Набор данных (только для этапов Верификация данных и Верификация stages only)
  • Скрипт (только для этапа Автоматические)
  • Маршруты выхода (для всех этапов, кроме Исключения, Повторное сканирование и Обработано)
  • Условия входа (для всех этапов, кроме Исключения и Обработано)
  • Роли (для этапов, основанных на пользовательских инструментах этапов)

Настройки на каждой закладке зависят от выбранного этапа. Подробное описание настроек смотрите на странице Свойства этапа обработки.


Свойства этапа обработки

В режиме Расширенный настройки процесса обработки вы можете задать свойства этапа при создании нового этапа, а также редактировать свойства базовых и ранее созданных пользовательских этапов.
Редактирование свойств этапа происходит в окне Свойства этапа обработки. Чтобы открыть это диалоговое окно для выбранного этапа, нажмите кнопку Правка… справа.
Свойства сгруппированы на закладках. Число закладок и набор доступных для редактирования свойств на каждой закладке определяется базовым типом выбранного этапа.

Свойство

Описание

Этап

Закладка Общие

Имя

В этом поле можно ввести название этапа

Для всех этапов

Инструмент

Название используемого инструмента. Название инструмента совпадает с базовым типом этапа.
Замечание: Для этапа Интерактивные можно выбрать один из следующих инстументов:

  • Проверка сборки документов
  • Верификация
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта
    • .
В зависимости от выбранного инструмента, этапу будет присвоен соответствующий базовый тип.

Только для этапов:

  • Интерактивные
  • Проверка сборки документов
  • Верификация данных
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта

Документов в задании

Устанавливает максимальное количество документов в задании

Можно изменять для всех этапов, кроме Проверка целостности пакета и Обработано

Ожидать все документы пакета

Нужно ли обрабатывать ли пакеты целиком или отправлять документы на следующий этап по мере обработки

Для всех этапов, кроме Проверка целостности пакета и Обработано

Ограничить количество обрабатываемых определений документов

Позволяет ограничить набор определений документов, докускаемых на этап.
Замечание: Если набор используемых определений документов ограничен и отмечена опция Ожидать все документы пакета, то на данном этапе будут обрабатываться только документы из указанного набора, но в задание отправки на следующий этап будут включены все документы пакета.

Для всех этапов, кроме Исключения и Обработано

Разрешить web-станции

 Нужно ли использовать web-станцию

Только для этапов:

  • Исключения
  • Верификация данных
  • Верификация
  • Проверка целостности пакета
  • Подтверждение экспорта

Закладка Набор данных (присутствует только у этапов Верификация данных и Верификация)

Данные, обрабатываемые на этапе

Нужно ли обрабатывать все данные или только выбранные поля. Для обработки выбранных полей в списке Доступные поля выберите поля, которые нужно обрабатывать. Список содержит Определения документов, указанные на закладке Общие.
Используйте кнопки ">" и ">>" для добавления требуемых полей в список Выбранные поля.
Кнопка ">" добавляет в список выбранный элемент (Определение документов, страницу, группу полей или поле).
Кнопка ">>" добавляет все Определения документов из списка Доступные поля в список Выбранные поля.
Кнопки "<" и "<<" удаляют соответственно выбранный элемент или все элементы из списка Выбранные поля.

Только для этапов Верификация данных и Верификация

Скрывать изображение страницы вне выбранных полей

Нужно ли скрывать поля, не включенные в Набор данных. Отметьте эту опцию, если требуется обеспечить высокий уровень безопасности при распределенной верификации.

Только для этапа Верификация данных

Двойная верификация

Нужно ли использовать двойную верификацию на этапе. Если эта опция выбрана, документ будет верифицироваться двумя различными операторами.

Только для этапа Верификация данных

Закладка Скрипт (присутствует только у этапа Автоматические)

Тип

В выпадающем списке выберите один из скриптов обработки: скрипт обработки документа или скрипт обработки пакета.

Только для этапа Автоматические

Правка скрипта…

Открывает окно редактора скрипта.

Только для этапа Автоматические

Закладка Маршруты выхода (отсутствует у этапов Исключения, Повторное сканирование и Обработано)

Следующий этап

Выберите, каким образом определяется следующий этап:

  • Следующий по схеме
  • Указанный (выберите следующий этап в выпадающем списке)

Для всех этапов, кроме Исключения, Повторное сканирование и Обработано

Условия отправки документов на другие этапы

Содержит список этапов, на которые может быть отправлено задание при выполнении заданных условий.
Для добавления этапа нажмите кнопку Этап…. Откроется окно Следующий этап. В этом диалоговом окне вы можете выбрать этап и задать условия, при которых задание будет отправлено на данный этап. Используйте кнопки справа для настройки этапов:

  • Правило… - открывает диалоговое окно Настройки правила для добавления нового правила.
  • Правка… - открывает диалоговое окно Настройки правила для редактирования настроек выбранного правила.
  • Удалить - удаляет выбранный элемент (правило или группу правил).
  • Группа… - открывает диалоговое окно Группа правил для добавления группы правил. Укажите название группы и условие, при котором будет выполнена группа правил: при выполнении "Хотя бы одного правила в группе" или "Всех правил в группе".
  • Выше - перемещает выбранное правило или группу правил на одну позицию вверх.
  • Ниже - перемещает выбранное правило или группу правил на одну позицию вниз.
Для редактирования выбранного этапа нажмите кнопку Правка…. Откроется окно Следующий этап, содержащее настройки правил для выбранного этапа.
Для удаления выбранного этапа нажмите Удалить.
Используйте кнопки Выше и Ниже для изменения порядка расположения этапов.

Для всех этапов, кроме Исключения, Повторное сканирование и Обработано

Закладка Условия входа (отсутствует у этапов Исключения и Обработано)

Документы на этап допускаются

Укажите, допускаются ли документы на этап всегда или при определенных условиях. Если выбрана опция При условиях, используйте кнопки справа для задания условий.
Для добавления правила нажмите кнопку Правило…. Откроется окно Настройки правила.
Для редактирования выбранного правила нажмите Правка…. Откроется диалоговое окно Настройки правила, в котором содержатся настройки выбранного правила.
Для удаления выбранного элемента (правила или группы правил) нажмите Удалить.
Для добавления группы правил нажмите кнопку Группа…. В открывшемся окне Группа правил укажите название группы и условие, при котором будет выполнена группа правил: при выполнении

  • Хотя бы одного правила в группе или
  • Всех правил в группе
Используйте кнопки Выше и Ниже для изменения порядка следования правил внутри группы.

Замечание. Если условие не выполняется, документ переходит на следующий этап, указанный в настройках процесса обработки.

Для всех этапов, кроме Исключения и Обработано

Замечание. Информация о выбранном маршруте выхода и проверявшихся условиях входа записывается в Журнале событий.


Диалоговое окно Настройки правила

В режиме Расширенный настройки процесса обработки вы можете указывать маршруты выхода и условия входа на этап при помощи правил.
Правила позволяют указать как условия, при которых задания будут отправлены на следующий этап, так и условия, при которых документы допускаются на данную стадию.

Правила отправки на следующий этап настраиваются в окне Следующий этап, которое открывается при добавлении или редактировании этапа на закладке Маршруты выхода окна Свойства этапа обработки.
Правила, определяющие условия, при которых документы допускаются на этап, настраиваются на закладке Условия входа окна Свойства этапа обработки.

Маршруты выхода и условия входа на этап могут быть заданы с помощью стандартных правил либо с помощью правила этапа.

Для добавления правила нажмите кнопку Правило…. Для редактирования правила нажмите Правка….

Диалоговое окно Настройки правила содержит следующие поля:

Поле | Описание
Имя | Название правила.
Тип условия Вы можете выбрать один из следующих типов условия:
  • Стандартное правило
  • Скрипт

Для типа условия Стандартное правило:
Правило выполняется, если Выберите условие применения правила:
  • Условие выполняется
  • Условие не выполняется
Условие Выберите одно из следующих условий:
  • Задача обработана успешно
  • Количество символов для верификации удовлетворяет выражению
  • Процент символов для верификации удовлетворяет выражению
  • Количество полей для обязательной верификации удовлетворяет выражению
  • Количество символов для двойной верификации удовлетворяет выражению
  • Есть ошибки правил
  • Есть ошибки сборки
  • Есть ошибки целостности пакета
  • Значение поля удовлетворяет выражению
Для условий, в которых содержится выражение, введите эталонное значение и укажите, как проверяемое значение должно относиться к эталонному: быть равным эталонному, быть не равным, быть меньше, быть меньше или равным, быть больше, быть больше или равным.

Для условия Значение поля удовлетворяет выражению укажите также поле, значение которого будет сравниваться с эталонным значением. Для этого нажмите кнопку Выбрать… и выберите требуемое поле из списка.

Для типа условия Скрипт:
Скрипт… | Открывает окно редактора скрипта, где вы можете редактировать правило этапа. После закрытия редактора сохраненный код скрипта отображается в окне Настройки правила слева от кнопки Скрипт….


Создание проекта

Для начала работы необходимо создать проект. Проект включает в себя:

  • профили импорта изображений;
  • одно или несколько определений документов;
  • типы пакетов документов.

В дальнейшем созданный проект необходимо загрузить на сервер приложений.

Проект создается на Станции Настройки Проектов. Загрузку проекта на Сервер приложений можно выполнять после настройки сервера с помощью Консоли Администрирования и Мониторинга.

Для создания нового проекта выберите пункт меню Файл>Новый проект…

Свойства проекта
Определения документов
Профили импорта изображений
Типы пакетов
Пакеты документов


Свойства проекта

Свойства проекта можно просмотреть и отредактировать в диалоге, который открывается при выборе пункта меню главного окна Проект>Свойства проекта….

На закладке Общие отображаются общие свойства проекта: название проекта, путь к файлам проекта, описание, приоритет пакета по умолчанию и качество отображения изображений. Также в поле Корневой путь экспорта можно выбрать корневую папку для экспорта в файлы и указать настройки инструмента.

На закладке Инструменты этапов отображается список инструментов этапов, которые могут использоваться при настройке процесса обработки в режиме Расширенный. Инструмент этапа представляет собой этап, имеющий свой набор скриптов и настраиваемый интерфейс. Можно как редактировать базовые инструменты этапов, так и создавать пользовательские инструменты. Подробнее см. Инструменты этапов.

На закладке Предобработка изображений можно просмотреть и отредактировать опции предварительной обработки изображений. Подробнее см. Параметры обработки изображений.

На закладке Распознавание можно отметить опцию Удалять пустые страницы во время распознавания - тогда пустые страницы будут удаляться на этапе распознавания. Также на данной закладке можно подключить к проекту классификатор гибких описаний.

На закладке Верификация отметьте опцию Группировать поля при контекстной верификации, если вы хотите группировать поля на этом этапе. Поля группируются по имени поля или группы, указанной в свойствах поля.

На закладке Обработчики событий можно просмотреть список событий, которые могут быть обработаны при помощи скриптов. Для того чтобы создать обработчик события, выберите событие из списка и нажмите кнопку Правка скрипта…. В открывшемся редакторе скрипта напишите текст скрипта. Подробнее см. Обработчики событий.

На закладке Экспорт можно просмотреть и изменить настройки экспорта. Для экспорта нераспознанных документов отметьте опцию Экспортировать нераспознанные документы и укажите параметры экспорта.

На закладке Процесс обработки настраивается процесс обработки пакетов (для типа пакетов "по умолчанию"). Подробнее о настройке процесса обработки см. в разделе Настройка процесса обработки.

На закладке Роли пользователя добавляются роли пользователей, которые могут обрабатывать этап, созданный на основе пользовательского инструмента этапа.

На закладке Сборки .Net можно подключать внешние сборки, которые могут использоваться в скриптах и глобальных модулях. Можно использовать как стандартные, так и откомпилированные пользовательские сборки. Для добавления сборки нажмите Добавить…. В открывшемся диалоговом окне укажите тип: Стандартное имя сборки или Путь к прикрепленному файлу. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки. Подробнее см. Подключение внешней сборки.


Типы пакетов

В комплексе ABBYY FlexiCapture 10 предусмотрен пакетный режим обработки документов: перед началом обработки создается пакет, в него добавляются изображения документов и далее они могут обрабатываться в этом пакете. Пакеты создаются автоматически или вручную при импорте изображений (сканировании или добавлении уже отсканированных изображений документов). Настройки, с которыми будут обрабатывать пакеты документов, задаются в Типе Пакета. Можно создать несколько Типов Пакетов с наиболее часто используемыми наборами настроек обработки. Тогда, чтобы указать с какими настройками должен обрабатываться пакет, оператору необходимо просто задать тип пакета.

Тип пакета определяет следующие параметры обработки документов:

  • способ предварительной обработки изображений;
  • список и порядок наложения определений документов;
  • подключенные внешние сборки;
  • используемые обработчики событий;
  • настройки экспорта;
  • процесс обработки пакета;
  • общие настройки: название проекта, путь к файлам проекта, описание, приоритет пакета по умолчанию и качество отображения изображений.

Также тип определяет список регистрационных параметров пакета - текстовой информации, характеризующей конкретный пакет.

Типы пакетов создаются Редактором Настроек Проектов в рамках определенного проекта.

Для того, чтобы создать Тип Пакета нужно:

  • запустить Станцию Настройки Проектов (Пуск>Программы>ABBYY FlexiCapture 10 Stations>Станция Настройки Проектов) и открыть проект на сервере (Файл>Открыть проект на сервере…)
  • открыть диалог Типы пакетов (Проект>Типы пакетов…)
  • запустить мастер создания типов пакетов по кнопке Новый и следовать его инструкциям.

Созданные типы пакетов будут автоматически экспортированы на Сервер Приложений и доступны для работы операторов.

Замечание. Для того чтобы операторы станций могли работать с пакетами созданных типов, Администратор при назначении ролей операторам должен указать типы пакетов, документы из которых может обрабатывать данный оператор.


Регистрационные параметры

Регистрационные параметры – текстовые свойства, позволяющие идентифицировать конкретный пакет или документ. В качестве таких свойств можно использовать, например, дату сканирования, фамилию оператора сканирования и т. д. Регистрационный параметр может быть обязательным и необязательным для указания.

Регистрационные параметры могут присваиваться пакету при создании (если пакет создается автоматически при использовании профилей импорта). Также регистрационные параметры могут быть присвоены пакетам и документам на станции сканирования и переданы в ABBYY FlexiCapture вместе с изображениями.

Регистрационные параметры можно изменить на закладке Регистрационные параметры диалогового окна свойств пакета или документа соответственно (пункт Свойства… локального меню).

Замечание. Рекомедуется указывать различные имена для регистрационных параметров документа и пакета. В случае совпадения имен, при подстановке значения регистрационного параметра всегда используется регистрационный параметр документа. Например, при формировании имен файлов во время экспорта.


Загрузка проекта на сервер

Созданный проект необходимо загрузить на Сервер Приложений. В процессе выгрузки проекта на Сервер Приложений копируется информация о настройках проекта, а также файлы с определениями документов, вспомогательные словари и т.д.

Внимание. Если в проекте были созданы пакеты, в процессе выгрузки проекта на сервер, пакеты не копируются.

Для того чтобы загрузить проект на Сервер Приложений необходимо выбрать Файл>Загрузить проект на сервер… в главном меню Станции Настройки Проектов.

Замечание. Только Администратор комплекса может создавать проекты. Настройку созданного проекта осуществляет Оператор Настройки Проектов. Поэтому после выгрузки созданного проекта на Сервер Приложений и выдачи прав операторам станций (настраивает Администратор через Консоль Администрирования и Мониторинга на данный проект), Оператору Настройки Проектов необходимо открыть проект на сервере выбрав в главном меню станции команду Файл>Открыть проект на сервере… и настроить его (создать определения, профили импорта, настройки экспорта и т.д.)

Внимание! Для корректного экспорта после загрузки проекта на сервер путь должен быть указан в формате UNC (\\computer_name\share_name[\path]). Убедитесь, что все станции, осуществляющие экспорт, имеют доступ к указанному пути.

В загруженном на сервер проекте будут возникать ошибки экспорта, если путь указан в формате <disk:>\[path]. Если будет указан относительный путь экспорта, данные будут доступны только помощью программного интерфейса (API). Для доступа к данным иным образом необходимо указать в формате UNC корневой каталог для относительных путей (это можно сделать при настройке свойств проекта).


Тестовый проект

Тестовый проект может использоваться в случае, если вы хотите проверить работоспособность проекта, прежде чем сохранять изменения в рабочей копии проекта.

Для создания тестовой копии проекта выберите пункт меню Проект>Создать тестовую копию.

На Станции настройки проекта работать с тестовой копией проекта может только пользователь, создавший тестовую копию.

После внесения изменений и проверки работы тестовой копии вы можете либо применить сделанные изменения к рабочей копии проекта, для этого в меню Проект выберите пункт Применить тестовую копию, либо удалить тестовую копию, выбрав пункт меню Проект>Удалить тестовую копию.


Настройки инструмента

Диалог Настройки инструмента позволяет настроить обработку определнных событий для всех типов пакета. При создании пакета он причисляется к определенному типу и таким образом формируется последовательность обработки этого пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…).

Настройки инструмента применяются к пакетам всех типов до входа на этап.

Для открытия диалога Настройки инструмента нажмите кнопку Правка… на закладке Общие в свойствах проекта. В открывшемся диалоговом окне вы можете указать следующие настройки:

Настройка | Описание
Группа Параметры события
Кнопка Добавить… | Открывает диалоговое окно Добавление события для выбора события, которое необходимо обрабатывать. Чтобы написать скрипт-обработчик события, нажмите кнопку Правка скрипта….
Кнопка Правка скрипта… | Открывает диалоговое окно Редактор кода скрипта для ввода текста скрипта.
Кнопка Удалить | Удаляет выбранный инструмент из списка.
Группа Настройки оболочки
Кнопка Редактировать… | Открывает диалоговое окно Настройки оболочки для настройки внешнего станции.
Кнопка Сбросить | Сбрасывает настройки оболочки на изначальные.


Инструменты этапа

Инструменты этапов

Закладка Инструменты этапов диалогового окна Свойства проекта позволяет настроить инструменты этапов обработки. С помощью данной закладки можно добавлять и удалять инструменты и редактировать их параметры.

Для создания нового инструмента этапа обработки, нажмите кнопку Новый... В диалоговом окне Создание инструмента этапа обработки укажите название инструмента обработки и его описание и выберите тип этапа в выпадающем списке Тип. Для добавления инструмента в список, нажмите кнопку ОК.

Для редактирования существующего этапа выберите его в списке и нажмите кнопку Правка. В диалоговом окне Настройки инструмента этапа обработки укажите следующие настройки:

Настройка | Описание
Группа Параметры события
Кнопка Добавить… | Открывает диалоговое окно Добавление события для выбора события, которое необходимо обрабатывать. Чтобы написать скрипт-обработчик события, нажмите кнопку Правка скрипта… для открытия диалогового окна Редактор кода скрипта.
Кнопка Правка скрипта… | Открывает диалоговое окно Редактор кода скрипта для ввода текста скрипта.
Кнопка Удалить | Удаляет выбранный инструмент из списка.
Группа Настройки оболочки
Кнопка Редактировать… | Открывает диалоговое окно Настройки оболочки для настройки внешнего вида этапа.
Кнопка Сбросить | Сбрасывает настройки оболочки на изначальные.


Настройки оболочки

Диалоговое окно Настройки оболочки позволяет настроить внешний вид станции, используя инструменты этапа обработки и настройки инструмента. Чтобы настроить вид для выбранного инструмента, нажмите кнопку Правка... и в открывшемся диалоге нажмите Редактировать…

На закладке Панели инструментов можно настроить панели управления для выбранного инструмента. Для каждого инструмента список панелей управления содержит четыре обязательных пункта: Задания, Стандартная, Вид и Навигация. Для добавления новой панели управления нажмите кнопку Новая... Укажите в открывшемся диалоговом окне наименования панели управления и нажмите кнопку OK для добавления ее в список. Для изменения наименования созданной панели нажмите кнопку Переименовать…

На закладке Команды можно изменить команды меню и панелей управления. Отметьте пункт Меню или Панель и выберите в выпадающем списке наименование пункта меню или панели, которую необходимо изменить. Раздел Команды содержит список доступных для выбора команд, для каждой из которых с помощью кнопок доступны следующие действия:

Кнопка | Действие
Новая... | Открывает диалоговое окно Редактировать команду для добавления новой команды.
Правка... | Открывает диалоговое окно Редактировать команду, в котором вы можете изменить название команды.
Удалить | Удаляет выбранную команду из списка.
Выше и Ниже | Перемещает выбранную команду выше или ниже в списке.
Сбросить | Восстанавливает настройки по умолчанию.

Поле Подсказка содержит текст подсказки для команды и горячие клавиши (если для команды указаны горячие клавиши).

Замечание. При добавлении пользовательской команды вы можете ввести для нее текст подсказки. Максимальная длина текста подсказки составляет 80 символов. Горячие клавиши для пользовательских команд настраиваются на закладке Сочетания клавиш меню Сервис > Опции…

При добавлении и редактировании команд панелей управления можно выбрать, каким образом отображать команду на панели: в виде текста либо в виде иконки. Если выбран пункт Использовать пиктограмму, нажмите кнопку Обзор (bmp, 24x24)…, чтобы загрузить изображение, которое будет использоваться в качестве иконки команды. Изображение должно быть в формате .bmp и иметь размер 24x24 пикселя. Для команд панели Задания размер изображения должен быть 32x32 пикселя.

Для добавления пункта меню, позволяющего показывать/скрывать все команды на пользовательской панели, выберите на закладке Команды пункт меню, в который будет добавлен список пользовательских панелей и нажмите Правка... В открывшемся диалоге Редактировать команду выберите в списке Категории Вид и в списке Команды выберите Настраиваемые панели инструментов.

Замечание. Команду Настраиваемые панели инструментов можно добавить только в меню. Добавить команду на панель инструментов нельзя.


Качество отображения изображений

Настройка Качество отображения изображений определяет качество изображений при загрузке на станциях.

Качество отображения изображений указывается для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и изображения пакета отображаются с заданным качеством.

В случае если не создано ни одного Типа Пакетов, изображения пакетов будут отображаться с качеством, указанным в свойствах проекта (Проект>Свойства проекта…, закладка Общие).

Можно выбрать следующие значения качества изображений: 20%, 40%, 60%, 80% или 100%.

Отображение изображений в более низком качестве может применяться для ускорения загрузки изображений, в случае низкой пропускной способности сетевого соединения на компьютерах операторов (например, при удаленной работе). Если выбрано более низкое качество, изображения будут загружаться быстрее за счет уменьшению размера.


Определения документов

Создание определения документа – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Работа с определениями документов доступна только на Станции Настройки Проектов.

Определение документа определяет расположение элементов документа, указывает, откуда будут извлечены данные. При создании определения документа определяются свойства полей, их область значений. Задаются также настройки экспорта данных.

Для начала создания определения документов запустите Мастер создания определения документа:

  1. В главном меню ABBYY FlexiCapture 10 выберите пункт Проект>Определения документов…
  2. В открывшемся диалоге Определения документов нажмите кнопку Новое…
  3. Следуйте инструкциям Мастера создания определения документа.
Мастер создания определения документа
Автоматическое выделение полей и статических элементов
Статические элементы
Создание полей определения документов
Свойства полей
Проверка с помощью правил
Настройка экспорта данных
Настройка отображения данных в окне документа
Свойства определения документов
Импорт определения документа для форм, созданных в программе ABBYY FormDesigner
Создание определений для многостраничных документов
Создание определения для обработки гибких документов
Создание определений для документов с приложениями
Обработка неструктурированных документов
Редактирование и публикация определения документа
Тестирование определения документа


Мастер создания определения документа

Для создания нового определения документа выберите пункт основного меню Проект>Определения документов… и в диалоге Определения документов нажмите кнопку Новое… Откроется Мастер создания нового определения документа.

  1. В диалоге Создание нового определения документа задайте основные свойства определения документа: название и комментарий, используемый язык (Язык (регион)) и стиль написания (Стиль написания). По умолчанию, выпадающий список содержит только языки со словарной поддержкой. Чтобы выбрать язык без словарной поддержки, отметьте опцию Показать все. Очень важно правильно задать язык: от этого зависит правильность распознавания документов. Стиль написания тоже может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания.

    Показать примеры разных стилей написания цифр
    - русская двойка
    - американская двойка
    - "обычная" пятерка – может встретиться в любом стиле
    - японская пятерка
    - русская единица
    - немецкая единица
    - "обычная девятка" – может встретиться в любом стиле
    - чешская девятка с кольцом справа
    - американская девятка без "крючка" внизу

    Задайте тип текста:

    • ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;
    • OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Позже вы сможете изменить тип текста для отдельных полей, а указанный на данном этапе тип будет использоваться по умолчанию.

    Нажмите кнопку Далее (Next) для перехода к следующему шагу.

  2. На втором шаге добавьте изображение страницы вашего документа для создания определения документа. Вы можете отсканировать изображение незаполненной страницы или загрузить его из файла.

    Замечание. определение для жестких форм создается на основе изображения, полученного при сканировании незаполненной формы. Это изображение должно быть хорошего качества, без искажений (не содержать перекосов, сдвигов и т.д.). Для цветных фоновых форм при создании определения следует использовать страницы, отсканированные без применения фильтров, так, чтобы фон не исчезал при сканировании. (Позже, когда вы будете сканировать изображения страниц для распознавания данных, вы выберете режим сканирования, при котором фон пропадает).

    Если ваш документ состоит из нескольких страниц, то загрузите первую страницу, а для добавления остальных руководствуйтесь рекомендациями раздела Создание определения для многостраничного документа.

    Если вам нужно использовать гибкое описание, созданное в программе ABBYY FlexiLayout Studio, то отметьте опцию Загрузить гибкое описание и введите путь к файлу, содержащему гибкое описание. Подробнее см. Создание определения для обработки гибких документов.

    Нажмите кнопку Далее (Next).

  3. На следующем шаге выберите типы полей, которые должны быть найдены на изображении автоматически. Вы можете отметить метки и текстовые поля ввода, особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

    Замечание. Автоматический поиск реперов производится всегда. Если на форме есть реперы, то они будут найдены и отмечены на изображении.

    Нажмите кнопку Готово (Finish).

После окончания работы Мастера создания определения документа откроется окно Редактора определения документа, в котором выполняются дальнейшие действия по созданию определения. На следующем этапе создания определения нужно разметить поля и статические элементы на изображении страницы и определить их свойства.


Автоматическое выделение полей и статических элементов

Автоматическое выделение при добавлении изображения:

При добавлении изображения страницы, автоматически производится поиск реперов на этом изображении. Стандартные реперы (например, черные квадраты) будут найдены и отмечены. Поиск текстовых полей и меток производится в том случае, если необходимость их поиска указана пользователем, то есть отмечены опции Текст или Метки. Особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

Автоматическое выделение в окне редактора определения документа:

Для автоматического выделения в окне редактора определения документа, выберите нужный режим работы (поля или статические элементы) и выберите пункт меню Сервис>Найти объекты на изображении…. Отметьте типы полей или статических элементов, которые должны быть найдены автоматически.

Если вы хотите автоматически выделять конкретные объекты на изображении, то выберите нужный режим работы (поля или статические элементы) и нажмите [image] на панели инструментов. Затем щелкните мышью в области элемента - он будет выделен прямоугольником. Тип элемента будет определен автоматически.

Автоматическое выделение области:

Для того, чтобы область поля или статического элемента определенного типа была выделена автоматически, выполните следующие действия:

  1. Выберите нужный режим работы (поля или статические элементы);
  2. Выберите тип поля или статического элемента с помощью нужной кнопки панели инструментов;
  3. Нажмите Shift;
  4. Щелкните левой кнопкой мыши в области поля или статического элемента.


Статические элементы

Статические элементы служат для наложения определения документа и идентификации. Из них не извлекаются никакие данные.

Для работы со статическими элементами в редакторе определения документа нужно переключиться в режим статических элементов - по кнопке [image].

Статические элементы могут использоваться для наложения определения документа и идентификации, способ использования определяется при задании свойств элемента. С помощью реперов производится совмещение определения документа с изображением формы. Идентификаторы нужны для определения принадлежности страницы к одной из форм, если в одном потоке обрабатываются разные формы. Подробнее см. Создание машиночитаемых форм.

У статических элементов нет названий, есть только области на изображении.

При наложении определения на изображение документа производится поиск статических элементов и по их расположению выбирается определение документа. Распознавание значений статических элементов (текста и штрих-кода) производится только в том случае, если это необходимо для идентификации. См. Задание значений идентификаторов.

В программе предусмотрены статические элементы следующих типов:

Статический элемент | Кнопка на панели инструментов
Репер |
Разделитель |
Реперный текст |
Реперный штрих-код |

Поиск реперов производится автоматически при добавлении изображения.

Как создать статический элемент вручную:

  1. Выберите режим статических элементов;
  2. Выберите инструмент для создания элемента нужного типа;
  3. Установите курсор мыши в угол элемента, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол илинажмите Shift и щелкните левой кнопкой мыши в области элемента.

Область статического элемента будет обведена прямоугольником, цвет которого зависит от типа статического элемента. Статическому элементу присваиваются свойства по умолчанию.

Как изменить свойства статического элемента:

  1. Выделите область элемента на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства статического элемента в открывшемся диалоге.

Подробнее о статических элементах:

  • Реперы
  • Разделители
  • Реперный текст
  • Реперный штрих-код


Реперы

Реперы - статические элементы, выделяются на изображении автоматически.

Для того, чтобы выделить реперы вручную:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];

  3. Установите курсор мыши в угол репера, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области репера.

Свойства репера

Чтобы изменить свойства репера:

  1. Выделите репер;
  2. Щелкните в области репера правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы репер использовался для наложения определения документа (рекомендуется);
    • Использовать для идентификации определения документа - отметьте эту опцию для использования репера в качестве идентификатора;
    • Вид репера - для правильного наложения определения документа важно, чтобы была указана форма репера: черный квадрат, крестик или уголок.


Реперный текст

Реперный текст - статический элемент. Это любой статический текст на изображении - заголовки, пояснительные подписи.

Для того, чтобы выделить реперный текст:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол текста, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области текста.

Свойства реперного текста

Чтобы изменить свойства реперного текста:

  1. Выделите текст;
  2. Щелкните в области текста правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы текст использовался для наложения определения документа;
    • Использовать для идентификации определения документа - отметьте эту опцию для использования текста в качестве идентификатора;
    • Значение - если вы используете реперный текст в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить;
    • Допустимое число ошибок - вы можете задать максимальное количество возможных ошибок в строке реперного текста.

    На закладке Распознавание нужно задать опции распознавания, чтобы статический текст был распознан с максимальной точностью:

    • ICR (рукопечатный) – отметьте эту опцию, если статический текст написан от руки.

    • OCR (печатный) – отметьте эту опцию, если статический текст напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машине и т.д.) См. Поддерживаемые типы текста.

    • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.

    • Тип данных – выберите язык, на котором написан текст. Для выбора воспользуйтесь кнопкой Выбрать…

    • Регистр – выберите регистр букв статического текста, если в тексте встречаются как строчные, так и заглавные буквы, оставьте значение Любой.

    • Ориентация – задайте ориентацию текста.

    • Для однострочного текста отметьте опцию Однострочное.

    • Если текст не содержит пробелов, то есть, состоит из одного слова, отметьте опцию Одно слово.

    • Задайте опции обработки изображения при распознавании:
    • Инвертировать – инвертировать изображение.
    • Удалять текстуру – удалять текстуру.
    • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Разделители

Разделители - статические элементы. Это любые горизонтальные и вертикальные линии на изображении.

Для того, чтобы выделить разделители:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол области разделителя, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области разделителя.

Свойства разделителя

Чтобы изменить свойства разделителя:

  1. Выделите разделитель;
  2. Щелкните в области разделителя правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения определения документа – эта опция должна быть отмечена, чтобы разделитель использовался для наложения определения документа;
    • Использовать для идентификации определения документа – отметьте эту опцию для использования разделителя в качестве идентификатора.


Реперный штрих-код

Реперный штрих-код - статический элемент.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это завит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения определения документа или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства статического элемента - реперного штрих-кода, см. также поле штрих-код.

Для того, чтобы выделить реперный штрих-код:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол штрих-кода, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области штрих-кода.

Свойства реперного штрих-кода

Чтобы изменить свойства реперного штрих-кода:

  1. Выделите штрих-код;
  2. Щелкните в области штрих-кода правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения определения документа - эта опция должна быть отмечена, чтобы штрих-код использовался для наложения определения документа;
    • Использовать для идентификации определения документа - отметьте эту опцию для использования штрих-кода в качестве идентификатора;
    • Значение - если вы используете реперный штрих-код в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить
    • Требуется для наложения определения - если эта опция отмечена, то определение документа может быть наложено, только если будет наложен штрих-код. Штрих-код следует делать обязательным для наложения определения документа, если в пакете много определений и остро стоит задача выбора, например, из очень похожих определений документов, отличающихся только значением штрих-кода, или даже значением одного из нескольких штрих-кодов. Тогда обязательное наложение штрих-кода ускорит выбор определения. Не следует отмечать эту опцию, если вы хотите, чтобы определение могло быть наложено даже при отсутствии штрих-кода или если он плохо пропечатан.

    На закладке Распознавание:

    • Тип кода - задайте тип штрих-кода (обычно определяется автоматически);
    • Ориентация - задайте ориентацию штрих-кода.

    Можно задать опции обработки изображения штрих-кода:

    • Инвертировать - инвертировать изображение;
    • Удалять текстуру - удалять текстуру;
    • Очищать изображение - задайте эту опцию, чтобы производилось очищение изображения от "мусора";
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Задание значений идентификаторов

Идентификаторы служат для определения принадлежности страницы к той или иной форме и используется для выбора определения документа при наличии в пакете нескольких определений со сходным набором реперов. В случае одновременной обработки нескольких форм в одном потоке, программа определяет, к какой форме относится данная страница, по расположению идентификаторов.

Если в качестве идентификаторов используются реперный штрих-код или реперный текст, то можно задать значения таких идентификаторов. В этом случае при попытке наложить определение документа, программа будет сравнивать распознанные данные на изображении со значением идентификатора, и наложение определения будет возможным только при совпадении значений.

Значения идентификаторов задаются в диалоге свойств статических элементов на закладке Общие. Значение текста и штрих-кода можно ввести автоматически, для этого предусмотрена кнопка Подставить.

Замечание. Если можно однозначно идентифицировать страницу только по расположению элементов, значения задавать не нужно. Не следует без крайней необходимости пользоваться этой возможностью, т.к. задание значения идентификатора запускает модуль распознавания на этапе наложения определения документа, тем самым замедляя наложение определений на изображения.


Создание полей определения документа

Поля предназначены для извлечения информации.

Для работы с полями в редакторе определения документа нужно переключиться в режим разметки полей - по кнопке [image].

Все области на изображении, откуда предполагается извлечение информации, должны быть отмечены как поля. Данные в этих полях распознаются, их значения могут экспортироваться.

У полей есть названия, список которых отображается в окне структуры документа. Обычно, поля имеют область на изображении, но можно создать поля и без области (например, для хранения промежуточных результатов).

Предусмотрены поля следующих типов:

Поле | Кнопка на панели инструментов
Текстовое поле ввода |
Метка |
Группа меток |
Штрих-код |
Картинка |
Таблица |
Группа полей |

Чтобы создать поле:

  1. Выберите режим разметки полей;
  2. Выберите инструмент для создания поля нужного типа;
  3. Установите курсор мыши в угол поля, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол илинажмите Shift и щелкните левой кнопкой мыши в области поля.

Область поля будет обведена прямоугольником, цвет которого зависит от типа поля.

Созданному полю по умолчанию присваивается название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля. Это название появится в списке полей на закладке Поля в окне структуры документа.

Полю присваиваются свойства по умолчанию.

  • Создание групп меток
  • Создание таблиц
  • Создание групп полей
  • Как изменить название поля
  • Копирование, перемещение, удаление полей
  • Поля без разметки
  • Свойства полей


Создание группы меток

В группу объединяются логически связанные метки и, как правило, соответствующие взаимоисключающим ответам на один вопрос. В этом случае из группы выбирается одна метка, чье значение и будет экспортироваться. Однако, это не обязательное условие, вы можете разрешить отмечать более одной метки из группы (опция в свойствах группы меток).

Первый способ создания группы меток:

Чтобы создать группу меток:

  1. Выбрав инструмент [image], создайте метки, входящие в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все метки, которые будут входить в данную группу.
  3. Метки, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы меток. Свойства меток, входящих в группу, одинаковы и не редактируются по отдельности.

Второй способ:

Не обязательно отмечать каждую метку, входящую в группу.

  1. Не выделяя метки по отдельности, сразу выберите инструмент [image] и обведите прямоугольником метки, которые будут входить в данную группу.
  2. Метки, оказавшиеся внутри прямоугольника, будут автоматически найдены, им присваиваются названия и они объединяются в группу.


Создание групп полей

Создание группы полей

Поля могут быть объединены в группы для наглядности структуры документов, а также для создания повторяющихся групп полей. Например, город, улица и номер дома могут быть объединены в группу "Домашний адрес". Создать поля для "Рабочего адреса" можно простым копированием группы полей "Домашний адрес".

Чтобы создать группу полей:

  1. Создайте поля, которые будут входить в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все поля, которые должны входить в группу.
  3. Поля, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы.

Если на форме есть повторяющиеся группы полей, то после создания одной группы вы можете создать несколько экземпляров группы. Все свойства полей, а также правила, заданные внутри группы, будут работать для каждого экземпляра группы. См. Поля с несколькими экземплярами.

Вы также можете копировать группу полей, но в этом случае результатом копирования будет создание еще одной независимой группы.


Создание таблицы

ABBYY FlexiCapture 10 позволяет создавать определения документов, содержащих таблицы. Создание полей типа Таблица существенно облегчает настройку, извлечение данных и экспорт данных из таблиц. Поле Таблица представляет собой набор из столбцов одного типа и повторяющихся строк.

Столбцы таблицы могут относится к одному из типов:

  • текст
  • метки
  • штрих-коды
  • картинки

Чтобы создать таблицу:

  1. Выберите инструмент [image] и обведите прямоугольником область таблицы. Шапка таблицы не должна быть включена в обведенную область. На панели появится дополнительный инструмент для удаления разделителя:
    Удаление разделителя
  2. Разметьте ячейки таблицы, создав нужное количество разделителей. Для создания вертикальных разделителей поместите курсор в нужное место таблицы таблицы, нажмите клавишу Shift и зафиксируйте его там щелчком мыши. Горизонтальные разделители создаются аналогично при нажатой клавише Alt. Также можно осуществить автоматический поиск разделителей. Для этого выделите созданную таблицу и воспользуйтесь пунктами локального меню: Найти вертикальные разделители и Найти горизонтальные разделители.
  3. Создайте столбцы таблицы. Чтобы создать столбец, щелкните в области столбца и выберите тип столбца из выпадающего списка.


Как изменить название поля

Для того чтобы изменить название поля:

  • Щелкните на название поля в структуре документа, нажмите на правую кнопку мыши, выберите пункт локального меню Переименовать и введите новое название.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Подобрать название. Полю будет присвоено название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Распознать название с изображения…. Затем обведите курсором мыши пояснительный текст, который подходит для названия поля. Название поля изменится на выбранный текст.

или

  • Откройте диалог свойств поля и измените название на закладке Общие.


Копирование, перемещение, удаление полей

Поля можно копировать, удалять, перемещать, изменять их размеры. Названия скопированных полей отличаются цифрами. Можно выделить одновременно несколько полей, удерживая нажатой кнопку Ctrl. Тогда выполняемое действие будет применено ко всем выделенным полям.

Для того чтобы удалить поле, выделите его и нажмите клавишу Delete или выберите пункт Удалить локального меню. Для того чтобы удалить только разметку, а поле оставить в структуре документа, нужно нажать клавиши Shift+Delete или выбрать пункт Удалить область локального меню поля. См. Поля без разметки.


Поля без разметки

Поля могут не иметь соответствующей области на изображении. Названия полей без разметки в списке помечены красной звездочкой. Такие поля могут использоваться для хранения промежуточных результатов вычислений, производимых со значениями распознаваемых полей. Например, можно объединить значения нескольких полей с помощью правила объединения значений полей, а результат сохранить в поле без разметки.

Поля без разметки обладают всеми свойствами, присущими тому типу, к которому они относятся. Значения этих полей также можно экспортировать.

Создать поле без разметки можно двумя способами:

  1. В окне редактора определения документа выберите пункт меню Правка>Создать поле и создайте поле нужного типа. Название поля появится в списке и будет помечено звездочкой. В этом случае создается поле структуры документа, но не создается его область на изображении.
  2. Второй способ заключается в удалении разметки обычного поля. Выделите нужное поле на изображении или в списке и выберите пункт локального меню Удалить область. Разметка будет удалена, а название поля будет помечено красной звездочкой.

Чтобы создать область для полей, не имеющих области на изображении, выберите [image] на панели инструментов и выделите мышью соответствующую область. Если в списке есть поля, помеченные звездочкой, то программа предложит вам выбрать название одного из таких полей.


Исключение региона из распозавания

Исключение региона из распознавания

Иногда бывает необходимо исключить из распознавания некоторую область, например, область с пояснительным текстом, который мешает извлечению данных из поля.

Чтобы исключить регион из распознавания, выберите инструмент [image] и выделите с помощью мыши область, которую нужно исключить.


Создание поля с непрямоугольной областью

Иногда возникает необходимость создавать поля с непрямоугольной областью, как показано на примере анкеты:

Чтобы создать область поля непрямоугольной формы:

  1. Выберите инструмент для создания поля нужного типа.
  2. Выделите прямоугольную область, к которой можно будет добавить или исключить фрагменты для создания области нужной формы.
  3. Выберите инструмент [image] и убедитесь, что созданная прямоугольная область выделена.
  4. Чтобы добавить фрагмент области: нажмите shift (при этом под курсором появится знак "плюс") и выделите фрагмент для добавления.
  5. Чтобы исключить фрагмент области: нажмите alt (при этом под курсором появится знак "минус") и выделите фрагмент для исключения.


Поля с несколькими областями

Поле может состоять из нескольких областей на изображении, причем эти области могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле.

Несколько областей удобно создавать для полей, расположенных на нескольких страницах, например, для больших таблиц.

Показать пример

Чтобы создать поле с несколькими областями, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать продолжение области…;
  3. Переместите изображение области в нужное место на странице.


Поля с несколькими экземплярами

На формах могут встречаться повторяющиеся элементы – поля или группы полей, встречающиеся на форме несколько раз и описывающие схожие объекты, например, одни и те же сведения о нескольких сотрудниках, о детях, о счетах. Для таких объектов создаются поля с несколькими экземплярами.

Любое поле может иметь несколько экземпляров, их области могут располагаться на расстоянии друг от друга, даже на разных страницах. Экземпляры полей обладают одними и теми же свойствами. Экспортируются они в отдельные файлы или таблицы базы данных.

Несколько экземпляров можно создать для группы полей, если на форме есть повторяющиеся группы.

Показать пример

Чтобы создать поле с несколькими экземплярами, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать экземпляр области…;
  3. Переместите изображение области в нужное место на странице.


Свойства полей

Очень важно правильно задать свойства каждого поля. Свойства полей влияют на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку. Некоторые свойства очень важны для распознавания данных, например, способ разметки для текстового поля ввода: если он задан неправильно, то разметка, не исчезающая при сканировании, не будет отделена от символов и результат распознавания может быть неудовлетворительным.

Поле каждого типа имеет свой набор свойств. Когда вы «нарисовали» на изображении поле определенного типа, ему присваиваются свойства по умолчанию.

Как изменить свойства поля:

  1. Выделите название поля в структуре документа или область поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства поля в открывшемся диалоге.

Подробнее о свойствах полей:

маркированный список | Текстовые поля ввода
маркированный список | Метки
маркированный список | Группы меток
маркированный список | Штрих-коды
маркированный список | Картинки
маркированный список | Таблицы
маркированный список | Группы полей
маркированный список | Служебные поля


Текстовое поле ввода

При создании текстового поля ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Типы данных
Свойства распознавания
Свойства верификации
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Не может быть пустым – отметьте эту опцию, если вы хотите, чтобы заполнение этого поля было обязательным.
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Индексное поле – отметьте эту опцию, если предполагается производить индексацию документов по этому полю. При обработке документов вы сможете отобразить значение этого поля для каждого документа, производить сортировку и поиск документов по значению поля.
  • Комментарии – вы можете ввести любые комментарии.


Типы данных текстового поля ввода

Одними из самых важных параметров текстовых полей, влияющих на качество распознавания, предварительную проверку и модификацию данных поля, являются настройки типа данных.

С помощью параметров типа данных текстового поля можно задать:

тип содержимого поля, тем самым, указывая программе, данные какого типа мы ожидаем увидеть в этом поле: будут ли это цифры, число, дата, символы из определенного набора, слово из некоторого словаря (имя, фамилия, город, страна и т.д.) или что-то другое. Тип содержимого используется программой в процессе распознавания данных текстового поля. Правильное задание содержимого поля повышает качество распознавания данных, увеличивает процент уверенности распознавания символов и как результат сокращает время, затрачиваемое оператором на этапе верификацию данных. Механизм задания типов содержимого очень гибок. Пользователю предоставляется возможность не только выбирать из предоставленного набора типов содержимого для выбранного языка распознавания, но и создавать свои собственные типы на основе алфавита, регулярного выражения или пользовательского словаря, подходящие для решения конкретной задачи;

параметры автозамены, с помощью которой можно осуществить автоматическую коррекцию распознанного значения поля, например, заменить или удалить лишние символы, пробелы, изменить регистр символов и т.д. Данные параметры обеспечивают автоматическое преобразование данных к требуемому для экспорта виду и сокращают ручной труд оператора на исправление данных поля. При задании опций автозамены можно воспользоваться стандартными параметрами, либо создать пользовательский скрипт для более сложного преобразования значения поля. Подробнее см. Обработка введенного значения;

параметры проверки значения для задания формата введенного значения, а также ограничения значений, например, проверки длины текста, задания минимального и максимального значений для числа, интервала времени для даты и т.д. Ограничить список возможных значений поля можно также с помощью внешнего источника - текстового файла или базы данных. Параметры проверки и ограничения значений зависят от выбранного типа содержимого поля. Несоответствие распознанных данных параметрам проверки значения приводит к возникновению форматных ошибок в окне документа на этапе верификации.

Замечание. В настройках типа данных поля пользовательский список значений (подгружаемый из файла или базы данных) можно использовать для:

  • повышения качества распознавания поля путем предложения программе не только алфавита символов, но и списка возможных слов. Значения из данного списка используются программой в процессе распознавания. В качестве результата распознавания текстового поля предлагается вариант идентичный или наиболее близкий к какому-либо значению из загруженного списка. Если распознаваемое значение отсутствует в словаре, то для распознавания используется только алфавит. Для решения данной задачи пользовательский словарь требуется подключить в настройках типа содержимого поля.
  • проверки уже распознанного текстового значения по списку допустимых значений. Сразу после распознавания поля осуществляется поиск его значения среди значений списка допустимых значений (локального или из внешнего источника). Если значение не найдено, то выдается сообщение о форматной ошибке поля. Для решения данной задачи список значений требуется загрузить или подключить в настройках проверки значения поля.

Тип данных для текстового поля ввода задается на закладке Тип данных диалога задания свойств поля. В зависимости от типа содержимого варьируется вид свойств в диалоге свойств поля.

Текст
  1. Если в данное поле будет введен текст, выберите Текст в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, использование словарей или задать более узкий тип данных, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Для стандартного текстового типа (в списке Тип содержимого выбрано Стандартный) можно использовать встроенный словарь и/или пользовательский словарь. Тогда значение поля будет проверяться на вхождение в эти словари. Для использования встроенного словаря отметьте опцию Использовать встроенный словарь. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный текстовый тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для текстового типа данных.
Число
  1. Если в данное поле будет введено числовое значение, выберите Число в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, изменить целое число на дробное или наоборот, выбрать более узкий тип данных, например, двузначное число или римские цифры, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Отметить опцию Целое, если значение поля должно быть целым числом и снять эту отметку для дробного числа.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для обычного целого или дробного числа.
    • Специальный тип числа (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для числа.
Внимание! Не следует использовать числовые типы данных для полей, значения которых состоят из цифр, но по сути числом не являются (например, номера карт или паспортов). Использование числового типа для этих полей может привести к проблемам, например, нули в начале строки отбрасываются. В таких случаях можно либо создать текстовый пользовательский тип данных с алфавитом 0-9 и, при необходимости, задать регулярное выражение, либо использовать числовой тип данных и отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.

Дата
  1. Если в данное поле будет вводиться дата, выберите Дата в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, изменить порядок следования компонентов даты, добавить время или день недели, выбрать более узкий тип данных, например, обозначение месяца римскими цифрами, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать из списка нужный Порядок компонентов даты.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для даты, записанной стандартным способом. Для стандартного типа даты вы также можете отметить опции: Возможно написание месяца словом - если возможно написание месяца словом, а не только числом, Может содержать день недели - если дата может включать день недели, Может содержать время - если дата может также включать время.
    • Специальный тип даты (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для даты.
Внимание! Если дату невозможно привести к стандартному формату или вам не нужно работать со значением как с датой, то следует отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.
Время
  1. Если в данное поле будет вводиться время, выберите Время в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, изменить формат времени, выбрать более узкий тип данных, например, 12-часовой формат времени, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого выберите нужный язык из выпадающего списка или отметьте галочку Все языки.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для времени, записанного стандартным способом.
    • Специальный тип времени (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Для этого нужно ограничить область значений для поля Дата. Заданное ограничение будет применяться также ко времени. Подробнее см. Ограничение области значений для даты.
Внимание! Если время невозможно привести к стандартному формату или вам не нужно работать со значением как со временем, то следует отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.
Денежная сумма
  1. Если в данное поле будет вводится сумма денег, выберите Денежная сумма в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык или выбрать более узкий тип данных, например, аббревиатуру валюты, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выберите стандартный тип (в списке Тип содержимого выбрано Стандартный) для денежной суммы, если значение поля представляет собой число или число, сопровождаемое общепринятым обозначением валюты.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для денежной суммы производится также, как и для числа. Подробнее см. Ограничение области значений для числа.
Внимание! Если денежную сумму невозможно привести к стандартному формату или вам не нужно работать со значением как с числом, то следует отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.
Адрес
  1. Если в данное поле будет вводится адрес, выберите Адрес в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, адрес электронной почты или почтовый индекс, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для адреса. В этом случае целесообразно использовать пользовательский словарь. Для этого отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для адреса производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.
Имя
  1. Если в данное поле будет вводится имя, выберите Имя в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, фамилию или отчество, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для имени. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для имени производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.
Код
  1. Если в данное поле будет вводится буквенно-цифровой код, выберите Код в списке Содержимое. В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, номер социального страхования, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для буквенно-цифрового кода. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для кода производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.


Создание пользовательских типов данных

Чтобы создать новый тип данных, выберите одно из значений в списке Содержимое на закладке Тип данных свойств поля. Вы можете выбрать любое значение из списка, которое соответствует смыслу вашего пользовательского типа: создание нового типа от этого не зависит, но храниться новый тип данных будет в выбранной категории.

Затем нажмите кнопку Правка… справа от поля Детали.

В открывшемся диалоге выберите значение Специальный в поле Тип содержимого.

Нажмите кнопку Новый… справа от поля Типы данных для выбранного языка.

Следуйте инструкциям Мастера создания нового типа данных.

На первом шаге мастера выберите способ создания типа данных, вы можете создать новый тип данных на основе словаря, регулярного выражения или алфавита или создать новый тип на основе уже существующего типа данных, например, добавив к его алфавиту недостающие вам символы или дополнив словарь.

Чтобы создать новый тип данных на основе словаря, регулярного выражения или алфавита:

  1. Выберите Новый тип данных на основе и отметьте соответствующую опцию, в зависимости от того, будете вы создавать новый тип данных на основе словаря, регулярного выражения или алфавита. Вы можете выбрать одну или несколько опций. Выберите Язык (регион) для вашего типа данных. Нажмите Далее (Next).
  2. Если на первом шаге вы выбрали словарь, то на следующем шаге нужно задать принцип использования словарей. Отметьте опцию Использовать встроенный словарь, если вы хотите использовать встроенный словарь для выбранного на первом шаге языка. Чтобы определить наличие слова в словаре, нажмите Просмотр… и введите искомое слово. При нажатии на кнопку Посмотреть вы получите парадигму слова или сообщение об отсутствии слова в словаре. Отметьте опцию Пользовательские словари для использования пользовательского словаря и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic. Нажмите Далее (Next).
    Замечание. Чтобы создать пользовательский словарь, содержащий слова вида:

    201.01.063.030
    201.01.063.031
    201.01.063.040

    , нужно создать файл с расширением .txt, содержащий следующие данные:

    DICTIONARY_PROPERTIES=USE_CONFIDENCE
    201.01.063.030 100
    201.01.063.031 100
    201.01.063.040 100

  3. Если на первом шаге вы выбрали регулярное выражение, то на следующем шаге нужно задать это выражение. Правильно составить регулярное выражение вам поможет кнопка [image] справа от окна для ввода выражения. Подробнее см. Алфавит, используемый в регулярных выражениях. Нажмите Далее (Next).
  4. Если на первом шаге вы выбрали алфавит, или использовали не включенные в алфавит языка символы при создании регулярного выражения, то на следующем этапе нужно задать алфавит для вашего типа данных. Символы можно вводить с клавиатуры, или вы можете нажать Изменить… и выделите нужные символы с помощью мыши.

    Чтобы добавить знаки препинания и исключенные (запрещенные) символы, нажмите Расширенные параметры…. Эти символы тоже можно вводить с клавиатуры или нажать кнопку справа и выбирать среди возможных символов.

    Нажмите Далее (Next).

  5. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Чтобы создать новый тип данных на основе существующего типа:

  1. На первом шаге Мастера создания нового типа данных выберите На базе существующих типов. Выберите язык (или несколько языков). Нажмите Далее (Next).
  2. На следующем шаге нужно выбрать исходный тип данных (несколько типов), на основе которого вы хотите создать свой тип. В левой части диалога в поле Доступные типы данных вы увидите типы данных, соответствующие выбранным языкам. В папке Текст содержаться натуральные языки, выбранные на первом шаге. В папке Пользовательские содержаться типы данных, созданные пользователями. В остальных папках содержаться типы данных, относящиеся к соответствующей категории и специальному типу содержимого. Чтобы выбрать базовый тип данных, выделите его в поле Доступные типы данных (можно выделить несколько, удерживая клавишу ctrl) и перенесите его в правую часть с помощью кнопки Добавить ->. Нажмите Далее (Next).
  3. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Созданные типы данных появятся в списке предопределенных типов данных при выборе того содержимого, которое было выбрано и при создании типа данных.

Таким образом, чтобы задать созданный тип данных для вашего поля:

  1. На закладке Тип данных диалога задания свойств поля выберите нужное значение в списке Содержимое;
  2. Нажмите на кнопку Правка… справа от поле Детали;
  3. В списке Тип содержимого выберите Специальный;
  4. Найдите в списке созданный тип данных (пользовательские типы данных отличаются от встроенных значком), выберите его и нажмите ОК.


Ограничение области значений для текстового типа данных

В диалоге Настройка проверки значения вы можете задать ограничения области значений для вводимого в поле текста.

Замечание. Текстовым типом считаются не только типы данных с содержимым Текст, но и типы с другим содержимым, у которых отмечена опция Обрабатывать как текст.

  • Ограничение количества символов – задайте максимальное количество символов в поле;
  • В поле Ограничение содержимого выберите из списка значение Регулярное выражение, если необходимо производить проверку значений поля с помощью регулярного выражения.

    Правильно составить регулярное выражение вам поможет кнопка [image]. Подробнее см. Алфавит, используемый в регулярных выражениях.

    Для улучшения читаемости сообщений об ошибках при проверке с помощью регулярного выражения укажите в поле Описание регулярного выражения описание регулярного выражения, которое будет отображаться при возникновении ошибок.

  • В поле Ограничение содержимого выберите из списка значение Допустимые значения, если необходимо задать список допустимых значений для поля. Для того чтобы добавить значение, нажмите кнопку Добавить… и введите значение в появившемся диалоге. Для редактирования значения нажмите кнопку Правка…, для удаления – Удалить. Для загрузки допустимых значений из файла нажмите кнопку Загрузить….

  • Отметьте опцию Использовать внешний источник допустимых значений, если требуется проверять распознанное значение по списку допустимых значений из внешнего текстового файла или базы данных. Укажите источник значений, нажав кнопку Правка…. При этом типе проверки список допустимых значений не копируется в проект, подключение к внешнему источнику осуществляется непосредственно в момент проверки.

  • Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением. Наличие предупреждений не мешает оператору отправить документы на следующий этап обработки, тогда как неисправленные форматные ошибки требуют дополнительного подтверждения отправки документов оператором.


Ограничение области значений для числа

Чтобы задать ограничение области значений для числа:

  1. Отметьте опцию Использовать ограничение.
  2. Задайте минимальное и максимальное значения числа.
  3. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.

При обработке документов будет производится проверка на попадание введенного значения в заданный интервал.


Ограничение области значений для даты

В диалоге Настройка проверки значения вы можете задать интервал, в который должна попадать дата, введенная в данное поле.

  1. Отметьте опцию Дата должна попадать в интервал.
  2. Выберите Фиксированный чтобы задать фиксированный интервал времени или Относительно даты верификации чтобы задать интервал времени, относительно даты верификации документов.
  3. Введите начало и конец интервала.
  4. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.


Обработка введенного значения

Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого на закладке Тип данных диалога свойств поля нажмите кнопку Правка… справа от поля Автозамена.

Задайте необходимые параметры автоматической замены или обработки текста.

Обработка будет производится только один раз после распознавания значения поля, если отмечена опция Производить замену только один раз после распознавания. В противном случае, замена будет производиться при каждом изменении значения поля.

  • Для того чтобы произвести автоматическую замену символов в распознанном значении поля, нажмите на кнопку Правка… справа от поля Замена символов. В открывшемся диалоге вы можете добавлять символы для автоматической замены. Добавленные значения будут отсортированы по алфавиту. Если указанные символы встретятся в распознанном значении поля, они будут автоматически заменены. Укажите следующие параметры автозамены:
    1. В поле Заменить введите один или несколько символов, которые требуется заменять.
    2. В поле На введите один или несколько символов для замены.
      Замечание. Замена на несколько символов может использоваться, если замена осуществляется по всему тексту. Для остальных опций (Префикс, Суффикс, Префикс и Суффикс) для замены используется только первый символ.
      Показать пример

      Так как замена выполняется в префиксе, "A" заменяется на первый символ из указанной для замены строки.

      Так как замена выполняется по всему тексту, каждый символ строки "ENT" заменяется на "WXY".

    3. В поле Заменить в укажите, где требуется осуществлять замену: в префиксе, суффиксе, префиксе и суффиксе или по всему тексту.
      Если замена осуществляется в префиксе, будут замены все идущие подряд символы из поля Заменить, начиная с начала текста. Замена в суффиксе выполняется с конца текста.
      Например, при замене символов " B" на "%" и символов "AC" на "#" в префиксе строка "ABC ENTERTAC CORP" будет замена на "#%#%ENTERTAC CORP".
      Показать пример

  • Для того чтобы произвести автоматическую замену всего значения поля или отдельных слов в значении поля, нажмите на кнопку Правка… справа от поля Замена текста.

    В открывшемся диалоге вы можете добавлять слова и выражения для автоматической замены. Для замены поля только целиком выберите опцию Заменять поля целиком.

    Если вы отметите опцию Точный поиск, то будет производиться поиск и замена строго введенного слова или выражения, а при выборе Неточный поиск будет найдено и заменено слово или выражение, близкое к введенному. Количество допустимых ошибок зависит от длины слова.

    Отметьте опцию Учитывать регистр, если важен регистр слова или выражения для замены.

  • Выберите один из способов преобразования букв текста в выпадающем списке Изменить регистр:

    Не изменять – без преобразования;

    ЗАГЛАВНЫЕ – все буквы будут преобразованы в заглавные;

    строчные – все буквы будут преобразованы в строчные;

    Первая буква заглавная – первая буква будет заглавной, остальные - строчные.

  • Удалить лишние пробелы – отметьте эту опцию, чтобы удалить лишние пробелы.

Также можно выполнять автозамену с помощью скрипта. Для этого необходимо отметить опцию Использовать скрипт, открыть окно редактирования скрипта с помощью кнопки Правка… справа от опции и ввести текст скрипта.


Свойства распознавания текстового поля

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

В поле Filling type выберите один из режимов распознавания: Стандартное распознавание, Не распознавать или Распознавание с помощью скрипта.

Для режима Стандартное распознавание укажите следующие опици:

  • ICR (рукопечатный) – отметьте эту опцию, если текст в данном поле будет написан от руки.

  • OCR (печатный) – отметьте эту опцию, если текст в данном поле будет напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машинке и т.д.) См. Поддерживаемые типы текста.

  • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.

  • Тип разметки – выберите тип разметки, выбор облегчают образцы разметки в выпадающем списке. Если разметка исчезает при сканировании, то рекомендуемый тип разметки является моноширинным (Gray boxes), а если разметка не исчезает при сканировании и разделена на ячейки для знакомест, то обязательно нужно ввести общее число ячеек. При автоматическом нахождении полей с такой разметкой, число ячеек также определяется автоматически.

  • Регистр – выберите регистр букв в поле. Если поле может быть заполнено как строчными, так и заглавными буквами, оставьте значение Любой.

  • Ориентация – задайте ориентацию текста.

  • Для однострочного поля отметьте опцию Однострочное.

  • Для поля, значение которого всегда будет состоять из одного слова, отметьте опцию Одно слово. Отметьте эту опцию, если вы хотите, чтобы регулярное выражение применялось ко всему полю, независимо от того, содержит ли поле одно слово или несколько.

  • Задайте опции обработки изображения при распознавании:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – отметьте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.

Выберите режим Не распознавать если это поле по каким-либо причинам не может быть распознано (например, если текст в поле написан слитными буквами), и его значение будет вводиться вручную оператором. В этом случае не нужно вводить другие свойства распознавания, так как такое поле распознаваться не будет, а при проверке оператору будет предложено ввести значение поля.

Выберите режим Распознавание с помощью скрипта, если при распознавании вы хотите применять пользовательский алгоритм. Подробнее см. Скрипт пользовательского распознавания.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания определения документа вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Для того, чтобы поле верифицировалось оператором, отметьте опцию Требуется верификация.

Настройте параметры отображения символов:

  • Если необходимо подсвечивать все символы, подаваемые на верификацию, выберите пункт Подсвечивать все символы;
  • Если подсвечивать символы не требуется, выберите пункт Не подсвечивать символы;
  • Если необходимо подсвечивать символы в зависимости от уверенности их распознавания, выберите пункт Подсвечивать, если уверенность меньше и укажите в выпадающем списке уверенность распознавания, ниже которой требуется подсвечивание.

Групповая верификация

  • Для того чтобы символы поля отправлялись на групповую верификацию , отметьте опцию Отправлять символы на групповую верификацию.
  • Выберите символы, которые будут отправляться на групповую верификацию: только подсвеченные символы или все символы.
  • Выберите набор символов для групповой верификации: Только цифры или Собственный. При необходимости измените пользовательский набор символов, нажав кнопку Правка…

Контекстная верификация

  • Для того чтобы поле отправлялось на контекстную верификацию, отметьте опцию Отправлять на контекстную верификацию.
  • Выберите, в каком случае отправлять поле на контекстную верификацию: всегда или если поле содержит подсвеченные символы или ошибки формата.
  • Укажите Имя группы полей, чтобы отправить поле на верификацию в составе этой группы. Для группировки полей на этапе контекстной верификации отметьте соответствующую опцию на закладке Верификация диалогового окна Свойства проекта.

Двойная верификация

  • Для того чтобы поле отправлялось на двойную верификации, отметьте опцию Требуется двойная верификация.


Пользовательский скрипт

Пользовательский скрипт - скриптовое правило, которое выполняется не автоматически, а по запросу пользователя при просмотре поля во время контекстной верификации либо при просмотре документа в редакторе документа. Скрипт запускается с помощью кнопки … справа от значения поля.

Пользовательский скрипт задается на закладке Пользовательский скрипт в свойствах поля. Добавление и удаление полей, информация о которых будет доступна в пользовательском скрипте, осуществляется с помощью кнопок Добавить… и Удалить соответственно. Редактирование скрипта осуществляется в окне Редактор кода скрипта, которое открывается при нажатии кнопки Правка…

Чтобы скрипт был доступен операторам, отметьте опцию Включить пользовательский скрипт.

Замечание. Пользовательский скрипт нельзя применить на Web-станции Верификации Данных.

Подробно о параметрах скрипта см. Пользовательский скрипт.


Метки

Внимание! Свойства меток, объединенных в группы, задаются сразу для всей группы меток. При попытке редактирования свойств метки, входящей в группу, откроется диалог редактирования свойств группы.

При создании поля метки ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Комментарии – вы можете ввести любые комментарии.


Типы данных для меток

Тип данных для меток задается на закладке Тип данных диалога задания свойств поля.

Тип данных для меток определяет значения, которые будут присвоены полю метки в случае отмеченной и неотмеченной метки.

Выберите подходящие варианты значений метки:

  • Да / Нет – если метка отмечена, значение поля будет "Yes", не отмечена – "No".
  • 1 / 0 – если метка отмечена, значение поля будет 1, не отмечена - 0.
  • <Название метки> / Пустая строка – если метка отмечена, значение поля будет совпадать с названием метки, не отмечено – полю будет присвоено пустое значение.
  • Пользовательские значения – отметив эту опцию, вы можете ввести свои значения, Если метка выбрана – для отмеченной метки, Если метка не выбрана – для неотмеченной.


Свойства распознавания меток

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

  • Тип метки – выберите тип метки. Это свойство очень важно для правильного распознавания меток.

    Квадрат – выберите этот тип метки, если метки ставятся в ограниченные квадратные области.

    Без рамки – выберите этот тип метки, если метки ставятся на белом фоне, без ограничителя.

    Автоматическое определение – при выборе этого типа, программа будет определять тип метки автоматически. Этот тип следует выбирать только в том случае, если первые два типа не подходят, например, у метки есть ограничитель, но он имеет неквадратную форму. Внимание! При выборе Автоматическое определение изображение метки на бланке не должно быть заполнено, т.к. программа будет определять проставлена ли метка, сравнивая изображение данной области в обрабатываемом документе и на бланке, на основе которого создается определение документа.

  • Допускать исправления – отметьте эту опцию, если вы хотите разрешить исправления для каких-либо меток: полностью заштрихованные метки в этом случае будут считаться неотмеченными. Но если вы выбрали тип Автоматическое определение, то для таких меток исправления допускать нельзя.

    Можно задать опции обработки изображения поля:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания определения документа вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Для того, чтобы поле верифицировалось оператором, отметьте опцию Требуется верификация.

Групповая верификация

  • Для того, чтобы символы поля отправлялись на групповую верификацию , отметьте опцию Отправлять символы на групповую верификацию.
  • Выберите символы, которые будут отправляться на групповую верификацию: только подсвеченные символы или все символы.

Контекстная верификация (только для Групп меток)

  • Для того чтобы поле отправлялось на контекстную верификацию, отметьте опцию Отправлять на контекстную верификацию.
  • Выберите, в каком случае отправлять поле на контекстную верификацию: всегда или если поле содержит подсвеченные символы или ошибки формата.

Двойная верификация

  • Для того чтобы поле отправлялось на двойную верификации, отметьте опцию Требуется двойная верификация.


Группы меток

Внимание! Свойства группы распространяются на все метки, входящие в группу меток.

Значение группы меток представляет собой список имен выбранных меток, разделенных точкой с запятой (;). Если ни одна метка не выбрана, то значение группы меток - пустая строка.

При создании группы меток, ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Типы данных для групп меток

Тип данных для группы меток задается на закладке Тип данных диалога задания свойств поля.

Допускать, если не выбрано ни одной метки – отметьте эту опцию, если в группе должна быть обязательно отмечена хотя бы одна метка. Тогда в случае, если ни одна метка их группы не будет отмечена, программа выдаст соответствующее предупреждение.

Допускать множественный выбор – отметьте эту опцию, если вы допускаете, что в группе будут отмечены несколько меток. Если эта опция не отмечена, то программа выдает предупреждение при наличии нескольких отмеченных метках в группе.

На этой закладке отображается список названий меток, входящих в данную группу. Вы можете изменить названия меток группы, для этого выделите нужную строку и нажмите кнопку Правка…. В открывшемся диалоге вы можете задать название поля метки и название метки для экспорта.

Вы можете определить экспортируемые значения в случае, если не было выбрано ни одной метки и в случае, если в группе выбрано более одной метки. Для этого выберите в списке одно из значений <Не выбрано ни одного значения> или <Выбрано несколько значений…>, нажмите на кнопку Правка… и в открывшемся диалоге задайте значение в поле Название метки. Если значения для экспорта не заданы, то в случае, если ни одна метка не выбрана, экспортируется пустая строка, а в случае выбора нескольких меток экспортируются их значения через запятую.

Создание группы меток


Штрих-код

При создании поля штрих-кода ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это завит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения определения документа или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства поля, см. также реперный штрих-код.

Основные свойства
Свойства распознавания
Свойства верификации
Проверка с помощью правил


Типы данных для штрих-кода

Тип данных для штрих-кода задается на закладке Тип данных диалога задания свойств поля.

Выберите подходящие варианты значений штрих-кода:

  • Ограничение количества символов – задайте максимальное количество символов в поле.
  • Ошибку при проверке значения считать\n предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением. Наличие предупреждений не мешает оператору отправить документы на следующий этап обработки, тогда как неисправленные форматные ошибки требуют дополнительного подтверждения отправки документов оператором.


Свойства распознавания штрих-кода

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

  • Не распознавать значение поля, оно будет введено вручную - эту опцию следует отметить в том случае, если значение штрих-кода будет вводиться оператором вручную. В этом случае не нужно задавать остальные настройки распознавания.
  • Тип кода – задайте тип штрих-кода (обычно определяется автоматически). Нажмите кнопку Выбрать типы…, чтобы указать типы штрих-кода вручную.

    Замечание. Поиск штрих-кодов типа QR Code, Aztec и DataMatrix может замедлять работу, поэтому рекомендуется выбирать штрих-коды данных типов, только если они действительно встречаются в проекте. Выделение этих штрих-кодов должно происходить, только если хотя бы одно Определение документа из данного типа пакета содержит жесткий или гибкий раздел, где используется двухмерный штрих-код (QR Code, Aztec или DataMatrix), или если двухмерный штрих-код используется в классификаторе, подключенном к типу пакета.

  • Ориентация – задайте ориентацию штрих-кода.

Можно задать опции обработки изображения штрих-кода:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания определения документа вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Для того, чтобы поле верифицировалось оператором, отметьте опцию Требуется верификация.

  • Для того, чтобы поле отправлялось на контекстную верификацию, отметьте опцию Отправлять на контекстную верификацию.
  • Выберите, в каком случае отправлять поле на контекстную верификацию: всегда или если поле содержит подсвеченные символы или ошибки формата.


Картинки

При создании картинки ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из четырех закладок, на каждой из которых редактируется определенная группа свойств.

Основные свойства
Свойства распознавания
Экспорт
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Комментарии – вы можете ввести любые комментарии.


Свойства распознавания картинки

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля).

  • Исключить из распознавания – отметьте эту опцию, если область поля Картинка должна быть исключена из области распознавания остальных полей. (Эта опция доступна только для поля Картинка и используется для совместимости с определениями FormReader 6.5.)


Экспорт картинок

Для каждой картинки в определении документа можно настроить параметры экспорта, такие как тип файла, качество, цвет и разрешение. Эти параметры задаются на закладке Экспорт диалога задания свойств поля (пункт Свойства… локального меню поля). Можно задать:

  • Тип файла (TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits, PNG).
  • Качество. Для файлов формата TIFF, JPEG или JPEG2000 можно выбрать качество экспортируемого файла (наилучшее, высокое, обычное, низкое).
  • Тип цвета - цветной, градации серого, полутона (ч/б).

Чтобы установить разрешение экспортируемой картинки, отметьте опцию Установить разрешение равным и выберите нужное значение разрешения из списка или введите его вручную.

Имя файла, в который будет сохранена картинка, формируется автоматически на основании критериев, заданных пользователем. Для того чтобы задать параметры нажмите кнопку Изменить… и в открывшемся диалоге Имя файла экспорта выберите необходимые опции.


Таблицы

При создании таблицы ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Столбцы
Проверка с помощью правил


Столбцы таблицы

На закладке Столбцы отображается список столбцов данной таблицы. Каждый столбец таблицы относится к определенному типу полей (см. Создание таблицы) и обладает свойствами, присущими этому типу поля.

Для редактирования свойств одного из столбцов:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…


Группа полей

При создании группы полей ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств

Основные свойства
Поля
Проверка с помощью правил


Поля группы

На закладке Поля отображается список полей, входящих в группу.

Для редактирования свойств одного из полей:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…

Создание группы полей


Служебное поле

При создании служебного поля ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из двух закладок, на каждой из которых редактируется определенная группа свойств

маркированный список | Основные свойства
маркированный список | Источник данных


Источник данных

На закладке Источник данных указывается источник и тип данных служебного поля:

  1. В списке Источник выберите источник данных для поля.
  2. Если выбрано значение Регистрационный параметр документа или Регистрационный параметр пакета, в поле Имя параметра укажите наименование регистрационного параметра, который будет использован в качестве источника данных.
  3. В блоке Тип данных выберите тип данных служебного поля.


Проверка с помощью правил

Правила – один из инструментов для расширения возможностей автоматической проверки результата. Правила позволяют задать ограничения на данные, то есть определить условия, которым должны удовлетворять значения в тех или иных полях.

Если значения в документах не удовлетворяют условиям правил, то такие страницы помечаются флажком с соответствующим сообщением. Основная цель применения правил – это проверка целостности данных документа.

Кроме того, с помощью правил можно обработать введенные значения: соединить значения нескольких полей или заменить распознанные значения соответствующими значениями из базы данных.

ABBYY FlexiCapture 10 позволяет задать правила следующих видов:

  • Проверка суммы – проверка суммы нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле.
  • Сравнение значений полей – правило сравнения значений нескольких полей.
  • Проверка по базе данных – производится проверка введенных значений путем их сравнения со значениями из определенной базы данных.
  • Объединение значений полей – правило объединения значений нескольких полей. При объединении можно добавлять любые разделители.
  • Скрипт – ограничения описываются пользователем с помощью скрипта.
  • Сравнение суммы цифрами с суммой прописью – правило сравнения суммы цифрами с суммой прописью (только на русском языке).

Правилу можно присвоить статус ошибки или предупреждения, при невыполнении условия поле помечается красным флажком в случае ошибки, желтым – в случае предупреждения. См. Верификация правил.

Правила задаются на закладке Правила диалога задания свойств объекта (поля, раздела, документа и т.д.).

В иерархической структуре правила хранятся на уровне того объекта, в котором они были созданы: это может быть поле, раздел или само определение документа. В большинстве случаев место хранения правил не имеет значения. Но если вы создаете определение документа со сложной структурой, с группами полей или повторяющимися элементами, то нужно следить за местом хранения правил. Например, если у вас есть группа полей, и некоторые поля группы связаны каким-либо правилом, то при создании нового экземпляра этой группы правило будет скопировано и корректно выполняться в новом элементе только в том случае, если правило хранится в самой группе или в одном из ее полей, а не на уровне выше. Из диалога свойств объекта доступен просмотр правил, которые работают с данным объектом, либо правил, хранящихся в данном объекте и в его дочерних объектах. Вы можете указать, какие правила вы хотите просмотреть, выбрав одно из значений выпадающего списка Показывать в списке:

  • Правила, использующие данный элемент – в списке отобразятся правила, которые работают с данным объектом (диалог свойств которого открыт в данный момент).
  • Правила, хранимые в данном элементе – в списке отобразятся правила, которые хранятся в данном объекте.
  • Правила, хранимые в данном элементе и во вложенных элементах – в списке отобразятся правила, которые хранятся в данном объекте и в его дочерних объектах (например, если объект является группой, то отобразятся правила, хранящиеся в группе и во входящих в группу полях).

Замечание. Создать новое правило можно только в режимах отображения Правила, хранимые в данном элементе и Правила, хранимые в данном элементе и во вложенных элементах. В режиме Правила, использующие данный элемент новое правило создать нельзя.

Каждое правило имеет статус ошибки или предупреждения. При попытке экспортировать документы с ошибками правил, будет выдаваться сообщение об этом. Наличии предупреждений правил не помешает экспорту.

Замечание. Если в свойствах поля не отмечена опция Показывать в Форме данных, то ошибки, связанные с этим полем, не будут выводиться при верификации.

Проверка суммы
Сравнение нескольких полей
Проверка по базе данных
Объединение значений полей
Правило сравнения суммы цифрами с суммой прописью
Правило, заданное с помощью скрипта


Правило проверки суммы значений

Это правило предназначено для проверки суммы значений нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле. Например, если в документе есть поля с суммой оклада, премии, иных начислений, а также есть поле с общей суммой дохода, то можно задать правило, проверяющее совпадает ли сумма значений полей со значением в результирующем поле. При несовпадении будет выдаваться сообщение об ошибке.

Замечание: При использовании данного правила для поля типа Таблица вычисление будет зависеть от уровня, на котором создается правило. При необходимости сравнения суммы значений всех ячеек некоторой колонки таблицы с вычисляемым или заданным числом правило нужно создавать в свойствах определения документа или раздела документа. При необходимости сравнения каждой ячейки некоторой колонки или суммы ячеек нескольких колонок таблицы с вычисляемым или заданным числом правило нужно создавать в свойствах таблицы или колонки таблицы. Также подобным принципом нужно руководствоваться при создании правила проверки суммы значений полей с несколькими экземплярами.

Чтобы создать правило проверки суммы, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Проверка суммы и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Добавьте в список Суммировать значения полей поля, сумму значений которых вы хотите проверить, для добавления используйте кнопку Добавить….
  7. Выберите одну из опций:
    • полем – для сравнения суммы со значением результирующего поля. Название этого поля выберите с помощью кнопки Выбрать….
    • числом – для сравнения суммы с заданным числом. Введите это число.
  8. Дробная часть сравниваемых значений – введите количество знаков в дробной части числа, чтобы определить точность сравнения.
  9. Отметьте опцию Необходимы хотя бы два непустых объекта, если требуется, чтобы при суммировании было как минимум два непустых и ненулевых слагаемых. В случае невыполнения данного условия при проверке правила появится сообщение в окне ошибок правил документа.
  10. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило сравнения значений нескольких полей

Это правило предназначено для сравнения значений нескольких полей. Его можно применять, если в вашем документе есть несколько полей, значения которых должны быть одинаковыми. При несовпадении значений для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Сравнение значений полей и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Добавьте в список Сравнить значения полей поля, значения которых вы хотите сравнивать, для добавления используйте кнопку Добавить….
  7. Выберите тип сравнения:
    • Четкое – для точного сравнения значений;
    • Нечеткое – для нечеткого сравнения. В этом случае сравнение будет производиться без учета регистра и лишних пробелов, а для значений полей длиннее 4-х символов допускается одна ошибка.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило проверки по базе данных

Проверка значений полей по базе данных заключается в том, что распознанное значение поля сравнивается со значениями из таблицы базы данных и считается правильным, если значение поля найдено среди значений в базе данных. В противном случае выдается сообщение об ошибке правила.

С помощью данного правила можно проверить вхождение требуемого значения в базу данных, обеспечить нечеткий поиск значения в таблице даже при наличии опечаток\ошибок в значении поля, заменить значения поля документа оригинальным значением из базы данных, скопировать в поля документа необходимые значения из базы данных.

Чтобы создать правило проверки по базе данных, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Проверка по базе данных и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Установите соединение с базой данных. Необходимые настройки задаются в диалоге, открывающемся при нажатии кнопки Установить…
    Совет. В качестве OLE DB Provider рекомендуется выбирать:
    • При экспорте в SQL - OLE DB Provider for ODBC Drivers. При выборе OLE DB Provider for SQL Server могут возникнуть проблемы при работе с некоторыми типами данных, при работе с длинными полями.
    • При экспорте в Oracle - Oracle Provider for OLE DB.
  7. Выберите из списка схему и таблицу базы данных.
  8. Отметьте опцию Не проверять, если все поля пустые для того, чтобы проверка правила не выполнялась в случае отсутствия значений в полях, участвующих в сравнении (это позволит сократить время на проверку правил документа).
  9. Установите соответствие между полями определения документа и полями таблицы базы данных. Для этого нажмите кнопку Добавить… Откроется диалог Соответствие полей. Выберите из списка поле определения документа и соответствующее ему поле таблицы базы данных (тип данных поля документа и формат значения из базы данных должны совпадать). Выберите тип сравнения:
    • Четкое – значения полей должны точно совпадать (при сравнении регистр символов не учитывается).
    • Нечеткое – значения полей должны совпадать частично. Данный тип сравнения можно использовать только для текстовых полей. (В этом случае происходит поиск наиболее близких слов, таких, чтобы для получения исходного слова нужно было добавить, удалить или заменить наименьшее количество букв. Количество допустимых ошибок зависит от длины исходного слова.) Если несколько вариантов значений подходит под критерии нечеткого поиска, то в окне документа оператору выдается сообщение об ошибке правила Найдено слишком много записей. и список наиболее похожих значений поля из базы данных. Оператор может выбрать подходящее значение из списка. Отметьте опцию Копировать значение поля из базы данных, если хотите, чтобы значение поля документа было заменено соответствующим значением из базы данных. Если с помощью нечеткого сравнения требуемое значение было найдено в базе данных, то оно автоматически подставляется в поле документа.

      Замечание. В случае если в поле ничего не введено, сообщение об ошибке не выдается, даже если база данных не содержит пустое значение.

    • Не сравнивать – сравнение производиться не будет, значение поля будет автоматически заменено на значение поля из базы данных (при данном типе сравнения опция Копировать значение поля из базы данных всегда отмечена). Данный тип сравнения часто используется при необходимости скопировать в документ несколько значений из базы данных (для этого в определении документа необходимо создать пустые поля без областей). Поиск записи в базе данных, содержащей значение для автоматической подстановки, необходимо предварительно задать с помощью другого соответствия полей, заданного четким или нечетким типом сравнения. Если требуемая запись не найдена, то значение поля остается неизменным.
  10. С помощью кнопок Добавить…, Правка… и Удалить можно добавлять, редактировать и удалять связи (соответствия) между полями.


Правило объединения значений полей

Это правило предназначено для объединения значений нескольких полей. Значения полей при объединениии можно отделять друг от друга точкой, пробелом или другими разделителями.

Чтобы создать правило объединения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Объединение значений полей и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next). Ошибка такого правила будет возникать, если, например, одно из полей, участвующих в объединении, было удалено из определения документа.
  6. Добавьте в список Поля для объединения значений поля, которые будут участвовать в объединении, для добавления используйте кнопку Добавить…. Выберите Записать результат в поле – поле, в котором будет храниться результат объединения. Введите в окно Разделитель нужный разделитель.
  7. По умолчанию, разделители будут добавлены между непустыми значениями. Если вы хотите, чтобы разделители добавлялись в любом случае, даже при наличии пустых значений полей, то отметьте опцию Добавлять разделитель при пустом значении.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.

Результат объединения может храниться в любом поле определения документа, удобно использовать с этой целью поля без разметки.

Если вам нужно экспортировать только значение результирующего поля, а не полей, участвующих в объединении, то у последних можно отключить опцию Экспортировать значение поля.


Правило, заданное с помощью скрипта

Программа ABBYY FlexiCapture 10 позволяет задать правило проверки данных с помощью скрипта.

Чтобы создать такое правило, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт О пределение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое….
  4. Из списка типов правил выберите Скрипт и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. В списке Доступные поля отображается список доступных объектов. Вы можете добавлять и удалять поля в помощью кнопок Добавить… и Удалить. Значения полей, у которых отмечена опция Только для чтения, доступны для чтения, а значения полей из списка, у которых эта опция не отмечена, могут быть перезаписаны с помощью скрипта.
  7. Нажав кнопку Правка…, откройте специальное окно для редактирования скрипта.
  8. Выберите язык скрипта и введите текст скрипта.
  9. Проверку скрипта можно с помощью пункта меню Сервис>Проверить скрипт.
  10. Сохраните скрипт с помощью пункта меню Файл > Сохранить.
  11. Нажмите Готово (Finish). Созданное правило отобразится в списке на закладке Правила.

Подробно о параметрах скрипта см. Скрипт правила


Правило сравнения суммы цифрами с суммой прописью

Внимание! Правило работает только для русского языка. Это правило можно задать только в том случае, если установлен русский язык распознавания для определения документа (меню Определение документа>Свойства определения документа…, закладка Распознавание).

Это правило предназначено для сравнения суммы цифрами с суммой прописью на русском языке. При несовпадении сумм для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения суммы цифрами с суммой прописью, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Сравнение суммы цифрами с суммой прописью и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Нажмите кнопку Выбрать… справа от поля Сумма цифрами и выберите поле определения документа, в котором находится предназначенная для сравнения сумма цифрами.
  7. Нажмите кнопку Выбрать… справа от поля Сумма прописью и выберите поле определения документа, в котором находится предназначенная для сравнения сумма прописью.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило вычисления суммы значений

Это правило предназначено для вычисления суммы значений нескольких полей и записи его в указанное поле. Например, если в документе есть поля с суммой оклада, премии, иных начислений, то можно задать правило, вычисляющее их сумму и записывающее результат в указанное поле.

Также можно использовать данное правило для подсчета суммы значений в колонке таблицы. Для этого необходимо создать правило в свойствах определения документа или раздела документа. При этом опция Необходимы хотя бы два непустых объекта не должна быть отмечена.

Чтобы создать правило вычисления суммы, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств определения документа (меню редактора определения документа, пункт Определение документа>Свойства определения документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Вычисление суммы и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее.
  6. Добавьте в список Поля для суммирования поля, сумму значений которых необходимо найти, для добавления используйте кнопку Добавить….
  7. В поле Записать результат в поле укажите поле, в которое надо записать результат суммирования. Используйте для этого кнопку Выбрать…
  8. Отметьте опцию Необходимы хотя бы два непустых объекта, если требуется, чтобы при суммировании было как минимум два непустых и ненулевых слагаемых. В случае невыполнения данного условия при проверке правила появится сообщение в окне ошибок правил документа.

    9. Замечание: при применении данной опции в параметрах правила необходимо добавить к суммированию минимум два поля (или два столбца таблицы) документа. Поэтому не отмечайте опцию в случае использования данного правила для суммирования значений из всех ячеек одного столбца таблицы.

  9. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Настройка экспорта данных

Чтобы задать способ сохранения данных, полученных в ходе обработки бумажных документов, необходимо настроить экспорт для каждого определения документа. Возможен экспорт пяти типов: в файл заданного формата, изображений в файлы, в базу данных, в библиотеку документов MS SharePoint или экспорт, описанный с помощью скрипта. От выбранного типа экспорта зависит вид последующих настроек. В рамках одного определения документа можно указать несколько вариантов экспорта.

Для каждого варианта экспорта указывается, какие документы - с ошибками и / или без ошибок - будут экспортироваться.

Для каждого варианта экспорта указывается, обязателен он или нет. Если вариант экспорта установлен как Обязательный, то в случае непрохождения экспорта по данному варианту (например, при отсутствии доступа к файлу или ошибке подключения к базе данных) возникает сообщение об ошибке экспорта в журнале событий и заданию экспорта присваивается статус Неудачно. Если вариант экспорта не обязателен, то при непрохождении экспорта задание завершается с предупреждениями в журнале событий и статусом Успешно.

При экспорте изображений можно скрывать изображения отдельных полей (удалять конфиденциальную информацию), причем список полей определяется независимо для каждого варианта экспорта. Таким образом можно ограничивать доступ сотрудников к той или иной информации. Для скрытия полей выберите при настройке экспорта изображений опцию Удалять конфиденциальную информацию, нажмите кнопку Выбрать поля для удаления… и в открывшемся диалоговом окне Выберите конфиденциальные поля укажите список полей, изображения которых необходимо скрывать.

Возможность автоматического экспорта (для версии FlexiCapture Standalone) настраивается на закладке Экспорт окна свойств определения документа. Чтобы документы, готовые к экспорту, могли экспортироваться автоматически (без нажатия оператором кнопки, инициализирующей экспорт), выберите опцию Разрешить автоматический экспорт.
Автоматический экспорт работает только в случае, если количество страниц в определении документа задано явно. Таким образом, если страницы в разделе могут повторяться либо число разделов задано интервалом, автоматический экспорт не работает.

Замечание. Если документы экспортируются автоматически, проверка целостности пакета не выполняется и в лог задания записывается предупреждение.

При задании вариантов экспорта можно указать сохранение распознанных данных и/или изображений документов в файловую систему. При использовании абсолютного пути к папке хранения данных можно указать локальный или сетевой путь (в формате UNC).

Если в настройках экспорта указывается относительный путь к приемнику, т.е. название подпапки, в которую требуется сохранять файлы, без указания полного пути, то по умолчанию данная подпапка будет создана в подпапке Экспорт папки проекта. Для того чтобы указать путь хранения файлов, отличный от папки по умолчанию, задайте Корневой путь экспорта в свойствах проекта. Все новые подпапки для хранения данных будут создаваться относительно корневого пути. Корневой путь может быть локальным или указывать сетевую папку (в формате UNC).

Для того чтобы настроить экспорт, в окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта… и опишите необходимые способы экспорта в диалоге Настройки экспорта.

Экспорт в файл
Экспорт изображений в файлы
Экспорт в базу данных
Экспорт в SharePoint
Экспорт, описанный с помощью скрипта


Экспорт данных в файл

Чтобы настроить экспорт в файл, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в файлы данных в поле Тип.
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, необходимо ли экспортировать изображения.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>. Настраиваемые параметры экспорта зависят от значения, выбранного в поле Цель.

      Воссоздать структуру подпапок Горячей Папки;

      При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.

      Экспортировать все в один файл;

      При выборе данного значения все данные будут экспортированы в один файл.. При настройке такого экспорта необходимо указать в поле Имя файла путь и название файла, в который будут экспортироваться данные.

      Экспортировать каждый документ в отдельный файл;

      При выборе данного значения каждый документ будет экспортирован в отдельный файл:

      • Укажите путь и первые символы названия файла в поле Префикс файла.
      • Для того, чтобы каждый пакет экспортировался в отдельную папку, отметьте опцию Создавать отдельную папку для каждого пакета.
      Экспортировать с заданным шаблоном имени файла;

      При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.

      • Укажите корневой путь экспорта в поле Корень экспорта.
      • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
      • Выберите в поле Если файл существует действие, которое необходимо выполнять, если файл со сформированным именем уже существует.

      Внимание! Для корректного экспорта после загрузки проекта на сервер корневой путь экспорта должен быть указан в формате UNC (\\computer_name\share_name[\path]). Убедитесь, что все станции, осуществляющие экспорт, имеют доступ к указанному пути.

      В загруженном на сервер проекте будут возникать ошибки экспорта, если путь указан в формате <disk:>\[path]. Если будет указан относительный путь экспорта, данные будут доступны только помощью программного интерфейса (API). Для доступа к данным иным образом необходимо указать в формате UNC корневой каталог для относительных путей (это можно сделать при настройке свойств проекта).

  7. Выберите тип файла (поддерживаются форматы CSV, DBF, TXT, XLS, XML), задайте дополнительные свойства экспорта для выбранного типа файла и при необходимости кодировку текста, соот. Затем нажмите кнопку Далее>.

    Microsoft Office Excel workbook (*.xls);
    • Выберите версию Excel (5.0/95; 97-2003; 97-2003 (совместимость с 5,0/95));
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все данные будут экспортироваться с типом General;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Для версии Excel 5.0/95 выберите кодовую страницу.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    XML Document (*.xml);
    • Отметьте, какие дополнительные данные хотите экспортировать (расположение полей, тип полей, ошибки, данные о качестве распознавания);
    • При отмеченной опции Сохранять тип значения при экспорте сохраняется xml-схема, в которой описаны типы полей;
    • Выберите кодировку.
    • При необходимости настройте наименования полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей.
    Comma-sepatated values file (*.csv);
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    Text file (*.txt);
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    • При необходимости настройте наименования и формат полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей и формат для числовых полей и дат.
    DBase file (*.dbf);
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все поля будут текстовыми;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • При необходимости настройте наименования полей. Для этого нажмите кнопку Соответствие полей и в диалоговом окне Соответствие полей укажите наименования полей.
  8. Если необходимо сохранять изображения, укажите параметры сохранения изображений и нажмите кнопку Далее>.
    • Укажите, сохранять ли изображения вместе с данными или выберите папку для сохранения изображений.
    • Выберите способ именования файлов изображений: так же, как и файлов данных, либо по-другому. Подробнее см. Критерии формирования имен файлов экспорта.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.
  9. Если необходимо сохранять изображения, укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска тексовый слой формируется из проверенных на верификации значений полей и областей документа за пределами полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
  10. Введите имя профиля экспорта и нажмите кнопку Finish.

Результатом экспорта будет файл или файлы выбранного формата, содержащий значения всех полей документов.

Замечание. Повторяющиеся поля, то есть поля с несколькими экземплярами и таблицы, экспортируются в отдельные файлы. Для них создается папка, имя которой совпадает с именем файла экспорта. Можно отключить экспорт повторяющихся полей в отдельные файлы, сняв галочку Создавать отдельные файлы для повторяющихся элементов на закладке Формат (доступна для файлов всех форматов, кроме XML). Тогда повторяющиеся поля будут экспортироваться в общий файл экспорта и для каждого экземпляра элемента будет добавлена новая строка.


Экспорт изображений в файлы

Чтобы настроить экспорт изображений в файл, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в файлы изображений в поле Тип.
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.
  5. Укажите параметры экспорта и нажмите кнопку Далее>. При необходимости выберите поля, которые необходимо скрывать при экспорте. Настраиваемые параметры экспорта зависят от значения, выбранного в поле Цель.
      Воссоздать структуру подпапок Горячей Папки;

      При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.

      Экспортировать каждый документ в отдельный файл;

      При выборе данного значения каждый документ будет экспортирован в отдельный файл:

      • Укажите путь и первые символы названия файла в поле Префикс файла.
      • Для того, чтобы каждый пакет экспортировался в отдельную папку, отметьте опцию Создавать отдельную папку для каждого пакета.
      Экспортировать с заданным шаблоном имени файла;

      При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.

      • Укажите корневой путь экспорта в поле Корень экспорта.
      • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
      • Выберите в поле Если файл существует действие, которое необходимо выполнять, если файл со сформированным именем уже существует.

      Внимание! Для корректного экспорта после загрузки проекта на сервер корневой путь экспорта должен быть указан в формате UNC (\\computer_name\share_name[\path]). Убедитесь, что все станции, осуществляющие экспорт, имеют доступ к указанному пути.

      В загруженном на сервер проекте будут возникать ошибки экспорта, если путь указан в формате <disk:>\[path]. Если будет указан относительный путь экспорта, данные будут доступны только помощью программного интерфейса (API). Для доступа к данным иным образом необходимо указать в формате UNC корневой каталог для относительных путей (это можно сделать при настройке свойств проекта).

  6. Укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска тексовый слой формируется из проверенных на верификации значений полей и областей документа за пределами полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
      Отметьте опцию Использовать MRC (Mixed Raster Content), если вы хотите получить более высокую скорость распознавания и малый размер конечных файлов. При использовании этой опции поля, для которых выбран режим Не распознавать, могут экспортироваться с ухудшением качества.
  7. Введите имя профиля экспорта и нажмите кнопку Завершить.


Экспорт в базу данных

Чтобы настроить экспорт в базу данных, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить… и выберите значение Экспорт в ODBC-совместимую базу данных в поле Тип.
  3. Укажите, является ли экспорт обязательным.
  4. Укажите, необходимо ли экспортировать изображения.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>.

    • Установите соединение с базой данных. Введите строку соединения в окно Строка соединения или нажмите на кнопку Установить… и задайте параметры соединения в открывшемся диалоге.
      Совет. В качестве OLE DB Provider рекомендуется выбирать:
      • При экспорте в SQL - OLE DB Provider for ODBC Drivers. При выборе OLE DB Provider for SQL Server могут возникнуть проблемы при работе с некоторыми типами данных, при работе с длинными полями.
      • При экспорте в Oracle - Oracle Provider for OLE DB.

    • Выберите схему из выпадающего списка.
    • Вы можете проверить соединение с базой данных, нажав на кнопку Тестировать.
    • Нажмите кнопку Создать таблицы автоматически для того, чтобы в базе данных были автоматически созданы новые таблицы для экспорта данных из документов. Для каждого раздела документа будет создана отдельная таблица. Структура и формат полей автоматически созданных таблиц соответствуют набору полей определения документа и их типам данных.
    • Если необходимо экспортировать данные в существующие таблицы базы данных, то установите соответствие полей определения документа столбцам таблиц базы данных с помощью кнопки Соответствие полей…
    • В диалоге Соответствие полей нужно определить, в какие таблицы и столбцы таблиц базы данных будут экспортироваться значения полей определения документа.
      Подробнее...

      В диалоге Соответствие полей слева расположены разделы и поля документа, в правой части им нужно поставить в соответствие таблицы и поля базы данных. Если в базе данных уже есть таблицы для экспорта данных, то в диалоге Соответствие полей выберите таблицу базы данных для каждого раздела и столбец таблицы базы данных для каждого поля документа. (Помимо прямого экспорта данных в таблицы баз данных существует возможность сохранять данные в базу данных посредством хранимых процедур. См. подробнее Особенности настройки экспорта данных с использованием хранимых процедур баз данных)

      Если в базе данных нет таблиц для экспорта, можно создать таблицы базы данных автоматически, для этого надо нажать на кнопку Создать таблицы автоматически. При ее нажатии создаются таблицы именно той структуры, которые нам нужны для экспорта. Полям документа будут поставлены в соответствие столбцы таблиц.

      Группы полей, поля с несколькими экземплярами, таблицы документа экспортируются в отдельные таблицы базы данных. Для связи между главной и подчиненными таблицами используются первичный ключ (Primary key) и внешний ключ (Foreign key). В главной таблице к каждой записи добавляется первичный ключ, а в подчиненной таблице к каждой записи добавляется внешний ключ, в который записывается значение первичного ключа той записи из главной таблицы, к которой относится данная запись. Первичный и внешний ключи добавляются автоматически, где необходимо. Нужно только указать, в какое поле ключ должен быть проэкспортирован.

      Выберите столбец таблицы базы данных для каждого поля документа.

      Если в таблице отсутствует столбец для экспорта данных какого-либо поля, то его можно добавить автоматически в существующую таблицу. Для этого достаточно оставить соответствие поля документа полю базы данных с аналогичным названием и с комментарием (авто) в скобках или нажать кнопку Авто, предварительно выделив мышью требуемое поле. Также с помощью кнопки Авто можно создать новую таблицу в базе данных с названием аналогичным названию раздела или таблицы определения документа.

      Если в диалоге настройки соответствия полей требуется создать новую таблицу с именем и названиями столбцов, отличными от имен полей определения документа, то воспользуйтесь кнопкой Новый для создания таблицы и каждого из полей.

      Кнопками Вверх и Вниз можно управлять порядком следования столбцов в автоматически создаваемой таблице базы данных.

      С помощью кнопки Формат… можно настроить параметры сохранения типизированных полей, например, количество десятичных знаков в значении поля типа Число или формат и разделители для поля типа Дата.

  7. Если необходимо сохранять изображения (изображения документов и/или изображения полей типа Картинка), укажите параметры сохранения и нажмите кнопку Далее>.
    • Укажите, где именно необходимо сохранять изображения - в базе данных или в виде файлов.
    • При сохранении изображений в файлы укажите папку, формат имени файлов (окно вызывается с помощью кнопки Правка…) и признак перезаписи файлов при совпадении названий. Подробнее см. Критерии формирования имен файлов экспорта.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.

    Замечание. В зависимости от выбранной опции содержимое полей типа Картинка и изображения документов можно экспортировать в файловую систему или базу данных. При экспорте в отдельные файлы имя и путь к файлу картинки\изображения сохраняются в базе данных в соответствующем поле (настраивается при установке соответствия полей). Если в качестве пути к папке экспорта (для изображений, картинок и т.д.) указывается сетевой диск, убедитесь, что станции обработки, работающие с проектом, имеют к нему доступ. При экспорте изображений и картинок в базу данных изображения сохраняются в бинарном виде в поля формата BLOB (Binary Large OBject). С помощью специальной процедуры из любой базы данных можно преобразовать бинарное изображение в файл.

  8. Если была выбрана опция сохранения изображений, то укажите формат файлов изображений и нажмите кнопку Далее>.

    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
      • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска тексовый слой формируется из проверенных на верификации значений полей и областей документа за пределами полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.

  9. Введите имя профиля экспорта и нажмите кнопку Закончить.

Замечания.

  1. Картинки экспортируются в отдельные файлы. Имя и путь к файлу картинки можно хранить в базе данных в соответствующем поле (настраивается при установке соответствия полей).
  2. Если в качестве пути к папке экспорта (для изображений, картинок и т.д.) указывается сетевой диск, убедитесь, что станции обработки, работающие с проектом, имеют к нему доступ.

Особенности настройки экспорта данных с использованием хранимых процедур баз данных

Помимо прямого экспорта данных в таблицы баз данных существует возможность сохранять данные в базу данных посредством хранимых процедур.

Хранимая процедура — объект базы данных, представляющий собой набор SQL-инструкций, который компилируется один раз и хранится на сервере. В хранимых процедурах могут производиться числовые вычисления и операции над символьными данными, результаты которых могут присваиваться переменным и параметрам, а также выполняться стандартные операции с базами данных.

Преимущества использования хранимых процедур над прямым экспортом в таблицы баз данных:

  • Быстродействие работы с базой данных
  • Возможность использовать дополнительные вычисления
  • Обеспечение целостности данных

Пример хранимой процедуры для MS SQL:

Create procedure Export( @userId as int, @lastName as nvarchar(255), @firstName as nvarchar(255) ) as begin if Exists( Select Id from Users where Id = @userId ) begin Update Users set LastName = @lastName, FirstName=@firstName where Id = @userId end else begin Insert into Users ( Id, LastName, FirstName ) values( @userId, @lastName, @firstName ) end end

При экспорте данных из FlexiCapture в базу данных посредством данной процедуры выполняются следующие действия:

На вход процедуре передаются 3 параметра (3 поля документа FlexiCapture): идентификатор (UserId), имя (FirstName), фамилия (LastName). Если в таблице базы данных (Users) нет записи с таким идентификатором, то в таблицу добавляется новая запись. Если запись с таким идентификатором присутствует, то в данной записи данные об имени и фамилии заменяются новыми значениями (значения полей из FlexiCapture).

Настройка экспорта с использованием хранимых процедур

Для того чтобы настроить экспорт данных с помощью хранимых процедур, необходимо вначале установить подключение к базе данных (см. выше). Далее нажмите кнопку Установить соответствие… для определения соответствия полей документа параметрам хранимой процедуры.

В диалоге соответствия полей из списка таблиц и хранимых процедур базы данных выберите в качестве приемника для сохранения данных требуемую хранимую процедуру.

В отличие от настройки экспорта напрямую в столбцы таблицы базы данных, в качестве полей для экспорта предлагаются параметры хранимой процедуры. Параметры процедуры являются типизированными. Для установки соответствия необходимо, чтобы тип параметра совпадал с типом данных поля определения документа.

Установите соответствие полей документа параметрам хранимой процедуры базы данных.

Замечание. Если необходимо экспортировать из документа не только отдельные поля, но и таблицы, сложные поля (например, поля с несколькими экземплярами), то требуется настроить корректные индексы для связи дочерних записей с основной записью данных документа. В качестве экспортируемого первичного ключа (ROW_INDEX) необходимо указать возвращаемое значение (@RETURN_VALUE), либо выходной (output) параметр хранимой процедуры. Таким образом, при экспорте данных процедура будет записывать данные в таблицу базы данных и возвращать идентификатор текущей записи, который будет передаваться в хранимую процедуру для экспорта дочерних записей.


Экспорт данных в библиотеку документов SharePoint

Программа ABBYY FlexiCapture 10 позволяет настроить экспорт документов в библиотеку документов Microsoftтм SharePont. В результате можно получить библиотеку изображений документов, а дополнительные колонки для каждого документа будут заполнены значениями определенных полей.

Замечания.

  1. ABBYY FlexiCapture 10 поддерживает следующие версии Microsoftтм SharePont: MS SharePoint 2003, MS SharePoint 2007 и MS SharePoint 2010.
  2. Для настройки экспорта в SharePoint необходимо иметь права администратора, для осуществления экспорта достаточно прав участника (contributor).
  3. Колонки в SharePoint, в которые планируется записывать данные, должны иметь тип Single line of text или Multiple lines of text.

Чтобы настроить экспорт в SharePoint, выполните следующие действия:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить…
  3. Выберите значение Экспорт в SharePoint в поле Тип.
  4. Укажите, является ли экспорт обязательным.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.

  6. Укажите параметры экспорта и нажмите кнопку Далее>.

    • URL сервера (например, http://myserver) – введите адрес сервера, где находятся ваши библиотеки SharePoint. C помощью кнопки Настройки соединения… можно настроить параметры аутентификации (по умолчанию используются параметры аутентификации для входа в Windows) и настройки Proxy, если это необходимо.
    • Ниже отображается состояние соединения, если соединения нет, его можно восстановить с помощью кнопки Соединение.
    • После соединения с сервером SharePoint выберите библиотеку из списка Выберите библиотеку SharePoint.
    • Нажмите кнопку Обзор… и укажите папку в библиотеке.
    • Выберите тип содержимого для документов в поле Тип содержимого (поддержано начиная с SharePoint 2007). В этом случае экспорт значений можно будет настроить в поля, относящиеся к выбранному типу содержания.
    • Далее нужно настроить, какие поля определения документа будут экспортироваться и куда. Для этого нажмите на кнопку Соответствие полей… и произведите необходимые настройки в открывшемся диалоге Соответствие полей. В этом диалоге нужно поставить в соответствие полям определения документа колонки документов в SharePoint. Поля определения документа отображаются слева. Для каждого экспортируемого поля определения (кроме групп и таблиц) можно выбрать еще не занятую колонку в SharePoint.
  7. Если необходимо сохранять изображения, укажите параметры сохранения изображений и нажмите кнопку Далее>.
    • При сохранении изображений в файлы укажите папку, формат имени файлов (окно вызывается с помощью кнопки Правка…) и признак перезаписи файлов при совпадении названий.
    • При необходимости укажите поля, изображения которых необходимо скрывать при экспорте.
  8. Если необходимо сохранять изображения, укажите параметры хранения изображений и нажмите кнопку Далее>.
    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска тексовый слой формируется из проверенных на верификации значений полей и областей документа за пределами полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

      Язык распознавания определяется следующим образом:

      • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
      • При полнотекстовом распознавании используется язык Определения документа.
      • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
  9. Введите имя профиля экспорта и нажмите кнопку Завершить.

В результате экспорта, документы будут сохранены в библиотеке SharePoint, каждому документу будут соответствовать колонки со значениями из определенных полей документа. Эти значения можно использовать для поиска и индексации документов.


Экспорт, описанный с помощью скрипта

Чтобы настроить экспорт с помощью скрипта:

  1. В окне редактора определения документа выберите пункт меню Определение документа > Настройки экспорта…
  2. Нажмите кнопку Добавить…
  3. Выберите значение Пользовательский экспорт (скрипт) в поле Тип.
  4. Укажите, является ли экспорт обязательным.
  5. Укажите, какие документы (с ошибками и / или без) будут экспортироваться и нажмите кнопку Далее>.
  6. Выберите язык скрипта.
  7. Введите текст скрипта в окне редактора, которое появляется при нажатии на кнопку Правка скрипта…. Затем нажмите кнопку Далее>.
  8. Введите имя профиля экспорта и нажмите кнопку Завершить.

Подробне о параметрах скрипта см. Скрипт экспорта.


Критерии формирования имен файлов экспорта

Имена файлов и пути к ним при экспорте формируются автоматически на основании критериев, заданных пользователем. Настроить можно как имена файлов данных, так и имена файлов с изображениями.

Замечание. Задать шаблон имени для файлов данных можно при экспорте в файлы, для изображений – при экспорте в файлы, в ODBC-совместимую базу данных, в Sharepoint, в файлы изображений.

Настройка формирования имен и путей к файлам экспорта выполняется в окне Назначение и шаблон именования файлов. В зависимости от выбранного варианта экспорта переход в данное окно осуществляется с помощью кнопок Настроить… (слева от поля с шаблоном имени файла) или Задать имена файлов…

Возможны два вида формирования шаблона для файлов экспорта, выбираемых в поле Вид:

Обычный;

В данном виде можно выбрать дополнительный путь (за исключением настройки экспорта изображений совместно с экспортом данных в файл), значимую часть имени файла и добавить к ней при необходимости дополнительные идентификаторы.

Для указания дополнительного пути отметьте опцию Использовать дополнительный путь и выберите способ указания дополнительного пути: аналогично структуре горячей папки (пункт Путь к источнику относительно корневого каталога Горячей папки) или по имени пакета (пункт Название пакета).

В качестве значимой части имени файла может использоваться

  • Имя оригинального файла изображений;
  • Имя определения документа;
  • Заданное имя - сочетание символов, указанное пользователем.

В качестве дополнительных идентификаторов могут использоваться

  • Идентификатор документа (отметьте опцию Добавлять к имени уникальный индекс документа);
  • Значение индексного поля (отметьте опцию Добавлять к имени значение индексного поля, нажмите кнопку … и выберите индексное поле в окне Выбор полей).
Расширенный.

В данном виде шаблон имени файла вводится в виде текстовой строки в поле Шаблон имени файла. Шаблон может содержать неизменную часть и теги, вместо которых будет подставляться информация для конкретных файлов. Теги можно вводить с клавиатуры, либо добавлять и удалять с помощью кнопок Добавить тег… и Удалить тег соответственно.

Для корректного формирования имен файлов экспорта нужно задать критерии таким образом, чтобы имена не оказались пустыми. Если имена файлов могут оказаться пустыми, программа выдаст предупреждение об этом.

Замечание. В именовании файлов изображений документов, которые необходимо экспортировать вместе с данными, можно использовать ту же схему, что и для данных. Для этого в разделе Настройки экспорта изображений отметьте опцию Аналогично настройкам для данных (диалог Назначение и шаблон именования файлов).


Настройка отображения данных в окне документа

После того, как данные будут распознаны, пользователь увидит их в окне документа. По умолчанию данные будут расположены по порядку, подписи к ним будут соответствовать названиям полей определения документа.

Однако можно изменить представление данных, расположив их удобным для пользователя способом или изменив названия элементов. Представление данных можно отредактировать в нижней правой части окна редактора определения документа.

Можно изменить подпись поля в форме данных, не меняя его названия в структуре документа. Для этого введите другое имя в поле Заголовок на закладке Общие диалога свойств поля. Это имя и будет служить подписью для поля в форме данных. Этой возможностью удобно пользоваться, например, для задания пользовательских названий столбцов в таблицах, особенно при использовании гибкого описания, где имена полей менять нельзя.

Шрифт и размер текста для отображения названий полей и распознанных значений данных можно задать на закладке Форма данных диалога свойств определения документа (определение документа > Свойства определения документа…). Размер можно также изменить, щелкнув в окне Форма данных правой кнопкой мыши и выбрав нужный размер (пункт локального меню Размер текста).

Поля можно перемещать, менять их названия или другие свойства. Чтобы вернуть исходное расположение полей, выберите пункт локального меню

Вы можете добавить любой текст, например, какие-либо пояснения. Для этого щелкните в окне Форма данных правой кнопкой мыши и выберите пункт локального меню Вставить текстовую метку. Введите нужный текст вместо текста Текстовая метка.


Свойства определения документа

Основные свойства определения документа, такие как название, язык и стиль написания, задаются в процессе работы Мастера создания определения документа. Другие свойства определяются по умолчанию.

Просмотреть и изменить свойства определения документа можно в диалоге свойств, который открывается при выборе пункта меню определение документа>Свойства определения документа… в окне Редактора определения документа.

Диалог состоит из шести закладок.

Закладка Общие

На этой закладке вы можете изменить название определения и ввести или отредактировать комментарий. Опция Включен включает/исключает определение из обработки документов.

Закладка Распознавание

На данной закладке вы можете изменить общие свойства распознавания определения документа:

  • Язык (регион) – для правильного распознавания данных важно правильно задать используемый язык. Это свойство определяет как язык заполнения, так и другие локальные установки, такие как формат даты, валюты и др.
  • Стиль написания – стиль написания может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания.

  • Задайте тип текста:

    ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;

    OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Вы можете изменить тип текста для отдельных полей, а указанный на этой закладке тип будет использоваться по умолчанию.

  • Вы можете отметить одну или несколько опций из группы Возможные положения страниц, для того, чтобы при автоматическом подборе ориентации страницы, она поворачивалась на 180°, 90° по часовой стрелке или 90° против часовой стрелки.
  • Нажмите на кнопку Расширенные настройки…, чтобы настроить исправление линейных и нелинейных искажений изображения.

    Замечание. Отметьте опцию Исправлять линейные искажения, чтобы указать параметры растяжения/сжатия изображений по высоте и ширине. Масштабирование изображений выполняется по имеющимся реперам (черный квадрат, крестик или уголок), а также горизонтальным и вертикальным разделителям.

  • Сохранять распознанные слова в кэше - отметьте эту опцию, чтобы при заполнении значений полей в процессе верификации можно было использовать распознанные данные из кеша.

Закладка Сборка

Эта закладка предназначена для задания правил сборки многостраничных документов.

В самом простом случае определение документа состоит из одного раздела, повторяющегося один раз. Если определение документа состоит из нескольких разделов, список их названий отображается на данной закладке. Вы можете задать количество повторений каждого раздела, изменив цифры в столбцах Минимальное количество и Максимальное количество.

  • Использовать правило сборки по совпадению ключевых полей – отметьте эту опцию, если вы хотите осуществлять проверку сборки документов по ключевым полям. Затем в столбце Ключевое поле выберите ключевое поле для каждого раздела. При вводе документов, правильно собранными будут считаться документы, у которых совпадают значения ключевых полей в каждом раздела. При несовпадении значений, будет выдано сообщение об ошибках сборки.
  • Использовать стандартные правила сборки - отметьте эту опцию, если вы хотите осуществлять проверку сборки документов с использованием следующих стандартных правил:
    • Отключить проверку порядка разделов - отметьте эту опцию, если вы хотите отключить проверку порядка следования разделов в документе. Отключение такой проверки требуется, например, если порядок следования разделов не важен для сборки документов. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет.
    • Допускать страницы приложений – отметьте эту опцию, если вы хотите обрабатывать документы с приложениями. Если разрешена обработка документов с приложениями, можно также отметить опцию Определять приложения на основе структуры документа, без анализа (быстро) для более быстрого определения страниц приложений на основе структуры документа.

      Замечание. Опция Определять приложения на основе структуры документа, без анализа (быстро) применяется только для документов, исключенных из сборки. Документы исключаются из сборки в случае, если они были получены путем разделения на этапе импорта либо с помощью API с использованием специального флага.

  • Использовать пользовательские правила сборки - отметьте эту опцию, если вы хотите осуществлять проверку сборки документов, используя скрипт сборки документа. Пользовательский скрипт сборки может выполняться как отдельно, так и совместно со стандартной проверкой сборки. Для редактирования скрипта нажмите кнопку Правка скрипта сборки…. Откроется окно редактора скрипта.

Подробнее см. Создание определений для многостраничных документов, Сборка страниц в документы и Создание определений для документов с приложениями.

Закладка Правила

Эта закладка предназначена для работы с правилами определения документа. Вы можете удалять, редактировать и создавать новые правила.

Подробнее см. Проверка с помощью правил.

Закладка Экспорт

На этой закладке отображаются текущие настройки экспорта данного определения документа. Для изменения настроек экспорта нажмите кнопку Изменить…

Подробнее см. Настройка экспорта данных.

Закладка Форма данных

На этой закладке можно изменить начертание и размер шрифта для отображения распознанных данных.

В группе Параметры текста данных – настройки шрифта для отображения распознанных значений.

В группе Параметры текстовых меток – настройки для отображения пояснительного текста (названий полей).

Подробнее см. Настройка отображения данных в окне документа.

Закладка Сборки .Net

На этой закладке можно подключать внешние сборки, которые могут использоваться в скриптах и глобальных модулях. Можно использовать как стандартные, так и откомпилированные пользовательские сборки. Для добавления сборки нажмите Добавить…. В открывшемся диалоговом окне укажите тип: Стандартное имя сборки или Путь к прикрепленному файлу. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки.

Подробнее см. Особенности .Net скриптов.


Импорт определений документов, созданных в программе ABBYY FormDesigner

ABBYY FormDesigner является удобным инструментом, разработанным специально для создания машиночитаемых форм. Создавая формы с помощью ABBYY FormDesigner, вы не только получаете формы, удовлетворяющие всем требованиям автоматизированной обработки документов, но и почти готовое определение документа для обработки этих форм в программе ABBYY FlexiCapture 10.

Чтобы получить определение документа для обработки созданных в программе ABBYY FormDesigner форм, нужно:

В ABBYY FormDesigner:

  1. Создать форму;
  2. Опубликовать ее;
  3. Экспортировать в формат XML Form Definition. Будет получен файл с расширением .xfd

Подробнее о создании формы, публикации и экспорте читайте в справке и руководстве ABBYY FormDesigner 10.

В ABBYY FlexiCapture:

  1. В главном окне программы выбрать пункт меню Проект > Определения документов…;
  2. В диалоге Определения документов нажать кнопку Импорт…;
  3. В открывшемся диалоге Открытие файла для импорта выберите значение XML Form Definition Files (*.xfd) в выпадающем списке Files of type и укажите путь к *.xfd файлу;
  4. Название нового определения документа появится в списке диалога Определения документов.

Открыв импортированное определение документа для редактирования, вы увидите, что разметка полей и статических элементов уже присутствует на изображении. Вам осталось только отредактировать свойства полей и настроить экспорт.


Создание определений для многостраничных документов

ABBYY FlexiCapture 10 позволяет создавать определения для многостраничных документов. определение документа может состоять из произвольного количества разделов, каждый из которых может содержать одну или несколько страниц. Для определений многостраничных документов задается порядок следования разделов, их количество и правила сборки страниц в документы.

После завершения работы Мастера создания нового определения создается простое определение документа, не содержащее разделов. Вы можете добавлять в определение страницы. При добавлении страницы ее изображение добавляется в область изображения в окне редактора определения документа, а поля, созданные на ней, будут фигурировать в общем списке полей. В этом случае документ состоит из одного раздела, хотя он может содержать несколько страниц.

Добавлять страницы в один раздел следует, если в документе есть блоки, переходящие со страницы на страницу, повторяющиеся на разных страницах блоки, таблицы, переходящие на следующую страницу. Такой же способ используется при загрузке многостраничного гибкого описания (см. Создание определения для обработки гибких документов). Все поля гибкого описания должны относиться к одному разделу определения документа.

Другой способ заключается в добавлении к определению документа разделов. В наиболее простом случае один раздел содержит одну страницу. Так можно поступать, если наборы полей на страницах независимы. Такой способ более наглядный: в структуре документа видно, к какому разделу относятся поля, а также вы можете задать произвольную структуру сборки документа. Например, в вашем документе страницы трех типов, причем страницы первого и третьего типа содержатся в документе 1 раз, а страница второго типа может повторяться от 2 до 5 раз. Тогда нужно создать 3 раздела: для каждого типа страницы отдельный раздел, а потом задать структуру документа, то есть последовательность и количество повторений разделов.

Более сложный случай – определение документа, состоящее из нескольких разделов, причем некоторые разделы содержат более одной страницы. Это, например, определение, состоящее из жестких разделов и гибкого многостраничного раздела. Или определение, определяющее документы, содержащие двусторонний лист, который может повторяться несколько раз. Допустим, вам нужно создать определение документа, содержащего титульный лист (страницу A) и некоторое количество двусторонних листов (последовательность страниц BCBC…). Тогда создаем раздел A, состоящий из одной страницы A и раздел BC, состоящий из двух страниц B и С. Структуру документа зададим следующим образом: раздел A повторяется 1 раз, за ним следует раздел BC, повторяющийся, например, от 3 до 7 раз.

Для определения документа, состоящего из нескольких разделов, кроме последовательности и числа повторений разделов, можно задать проверку ключевых полей. Для этого в каждом разделе документа определяются ключевые поля, значения которых в разных разделах должны быть одинаковыми. В качестве ключевого поля можно взять, например, фамилию заполняющего документ, которую он должен написать на каждой странице, или некий идентификационный номер.

При обработке пакета программа пытается собрать в документы следующие друг за другом страницы, производя при этом проверку правил сборки. При выборе соответствующей опции будет произведена проверка значений ключевых полей. При несовпадении ключевых полей на страницах одного документа, появится сообщение об ошибке. Иногда это происходит из-за того, что страницы документов перепутаны при сканировании, и для выполнения правил сборки документов достаточно изменить порядок следования страниц. См. Сборка страниц в документы.

Для того чтобы добавить страницу в раздел, воспользуйтесь пунктом меню редактора определения документа О пределение документа > Добавить страницу… или пунктом локального меню изображения Добавить страницу… После этого загрузите изображение новой незаполненной страницы и выберите типы объектов, которые должны быть отмечены на странице автоматически.

Для того чтобы добавить новый раздел, воспользуйтесь пунктом меню О пределение документа > Добавить раздел документа… в окне редактора определения документа. Откроется мастер создания раздела, который поможет вам задать все необходимые параметры. Следуя инструкциям мастера, выполните следующие действия:

  • задайте название раздела;
  • загрузите изображение незаполненной страницы (отсканируйте или загрузите из файла) либо загрузите файл гибкого определения;
  • выберите типы объектов, которые будут отмечены автоматически.

Новый раздел и содержащиеся в нем поля отобразятся в окне структуры документа.

Также можно импортировать раздел из другого определения документа, входящего в проект. Для этого выберите в меню пункт Определение документа > Импортировать секцию документа… и выберите раздел в диалоговом окне Выберите определение секции для импорта.

Замечание: При импорте разделов разделяемые скриптовые модули не импортируются. Это может приводить к тому, что скриптовые правила, написанные в новом разделе, станут неработоспособными или будут работать неправильно.

Для того чтобы просмотреть получившуюся структуру документа при создании определения, в окне Структура документа редактора определения документа перейдите на закладку Страницы. На ней представлена структура документа в режиме эскизов страниц. На этой закладке можно изменить количество вхождений разделов в документ (для этого введите новое значение – число или интервал – в квадрате справа от названия раздела), подключить страницы приложения, изменить порядок страниц в разделе и перенести страницы из одного раздела в другой простым перетаскиванием изображения страницы.

Для страниц, которые могут повторяться в разделе, отметьте опцию Может повторяться в разделе документа в свойствах страницы. Чтобы открыть диалог свойств страницы, выберите пункт Свойства... в локальном меню страницы или нажмите Alt+Enter.

Показать окно структуры документа
Для того чтобы задать последовательность и число повторений разделов, а также правило сборки, воспользуйтесь пунктом меню Определение документа > Свойства определения документа… в окне редактора определения документа.

На закладке Сборка задайте минимальное и максимальное число вхождений каждого раздела в документ (по умолчанию 1).

Если вы хотите проверять значения ключевых полей, отметьте опцию Использовать правило сборки по совпадению ключевых полей и выберите ключевое поле в каждом разделе.

Укажите, какие правила сборки должны использоваться. Вы можете использовать как стандартные, так и пользовательские правила сборки.

Стандартные правила сборки позволяют отключить проверку порядка разделов и включать в документы страницы приложений.Отключение проверки порядка следования разделов в документе (опция Отключить проверку порядка разделов) требуется, например, если порядок не важен для сборки документов. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет. Для того чтобы включать в сборку страницы приложений, отметьте опцию Допускать страницы приложений. Если вы хотите определять страницы приложений на основе структуры документа, отметьте соответствующую опцию.

Для того чтобы осуществлять сборку документа при помощи скрипта сборки, отметьте опцию Использовать пользовательские правила сборки. Для редактирования скрипта, нажмите кнопку Правка скрипта сборки….

Показать закладку Сборка


Создание определения для обработки гибких документов

Для счетов, платежных поручений и других аналогичных документов невозможно создать определение документа с жестким расположением полей, потому что местоположение, размеры и количество полей на разных экземплярах могут не совпадать, а значит, жесткое описание не может быть наложено на все документы. На таких документах поля ищутся после предварительного распознавания всей страницы целиком, и на основе ключевых слов и взаимного расположения полей создается гибкое описание. Для разработки гибких описаний предназначен специальный компонент программы ABBYY FlexiLayout Studio 10 (поставляется вместе с ABBYY FlexiCapture 10). Подробное руководство создания гибкого описания вы найдете в справке для ABBYY FlexiLayout Studio 10.

Гибкое описание экспортируется в .afl файл, а затем подключается в ABBYY FlexiCapture 10. Мы можем использовать гибкое описание для всего определения документа или в качестве одного из разделов. Гибкое описание может быть многостраничным.

Подключение гибкого описания

Гибкое описание можно подключить на этапе создания определения документа. Для этого на втором шаге Мастера создания определения документа добавьте изображение документа, а затем отметьте опцию Загрузить гибкое описание и введите путь к файлу с расширением .afl, содержащему гибкое описание.

Вы можете подключить гибкое описание и из окна Редактора определения документа, в диалоге свойств описания раздела документа.

  1. Выберите раздел документа. (Если определение документа состоит из одного раздела, то в окне Структура документа перейдите на закладку Страницы и выберите название единственного раздела.) Нажмите на правую кнопку мыши и выберите пункт локального меню Свойства…
  2. Перейдите на закладку Гибкое описание.
  3. Нажмите Загрузить…
  4. Выберите нужный .afl файл, содержащий гибкое описание.

После подключения гибкого описания геометрическая разметка полей уже будет присутствовать на изображении. Теперь нужно задать свойства полей точно так же, как и для жесткого определения документа. Определите свойства распознавания, верификации, экспорта, задайте необходимые правила.

Обновление гибких описаний

Для того чтобы обновить используемые гибкие описание, выберите пункт меню Сервис > Обновить гибкие описания…. В открывшемся окне укажите путь к гибкому описанию и нажмите Обновить.

Замечание. При импорте гибкого описания, содержащего текстовые файлы со списками возможных значений полей, данные файлы размещаются по относительным путям, указанным при создании гибкого описания. При этом относительные пути отсчитываются от файла проекта. Для редактирования данных файлов необходимо сохранить проект локально (пункт меню Проект>Экспортировать проект…), отредактировать файлы и обновить проект на сервере (пункт меню Проект>Обновление проекта…).


Создание определений для документов с приложениями

ABBYY FlexiCapture 10 позволяет создавать определения для документов с приложениями. Приложения – это дополнительные страницы, которые могут сопровождать каждую форму, на эти страницы не будет наложено определение документа, но они учитываются при сборке документов. Например, к заявлению на получение кредита (жесткая форма) прилагается справка с места работы, составленная в свободном стиле. Эта справка может обрабатываться как приложение.

Чтобы создать определение документа с приложением:

Первый способ:

  1. Перейдите на закладку Страницы в окне Структура документа (правая часть редактора определения документа).
  2. Включите опцию Подключить раздел приложения в документе.
  3. Введите количество или диапазон страниц приложения в появившемся квадрате справа от названия раздела.
Показать окно структуры документа
Второй способ:
  1. Откройте диалог свойств определения документа (Определение документа > Свойства определения документа… в окне редактора определения документа);
  2. Перейдите на закладку Сборка;
  3. Отметьте опцию Допускать страницы приложений. В списке разделов появится строка Страницы приложения;
  4. Введите минимальное и максимальное количество страниц в приложении.
Показать диалог

Для того чтобы сохранить текст приложения, нужно при настройке экспорта задать опции сохранения изображений (в диалоге Настройки экспорта). Если вы выберите формат PDF searchable для сохранения изображения, то текст будет распознан и сохранен в PDF с возможностью поиска.


Обработка неструктурированных документов

Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, приложения, то и в этом случае поможет ABBYY FlexiCapture 10. Неструктурированные документы с текстом или изображениями, разделенные пустыми страницами или страницами со штрих-кодом, обрабатываются и экспортируются в PDF файлы с возможностью поиска или в файлы графических форматов.

Обработка таких документов обычно состоит в том, чтобы перевести документы в электронный вид и организовать их поиск по значениям ключевых полей.

Если возможно, поиск ключевых полей (например, номер контракта) на таких документах производится с помощью гибкого описания, созданного в приложении ABBYY FlexiLayout Studio. См. Создание определения для обработки гибких документов.

Если автоматический поиск ключевых полей невозможен, то их значения могут вводиться вручную оператором. Для этого создайте определение документа с одним полем (или с несколькими полями, если нужно), и в свойствах распознавания этого поля (полей) отметьте опцию Не распознавать значение поля, оно будет введено вручную. В этом случае при запуске процесса верификации оператору будет предложено ввести значения ключевых полей вручную.

Для хранения документов нужно настроить экспорт: значения ключевых полей вы можете экспортировать в файл или базу данных, а изображения документов сохранить в удобном для вас формате. Вы можете сохранять изображения документов в графических файлах или в PDF с возможностью поиска.

Обратите внимание на сборку страниц в документы: для неструктурированных документов бывает сложно определить, к какому документу относится та или иная страница. Для автоматизации сборки неструктурированных документов рекомендуется разделять документы чистыми страницами или страницами со штрих-кодами. Тогда при добавлении изображений в пакет (путем сканирования, добавления из файлов или при создании профиля импорта) нужно отметить опцию Для изображений, разделенных и выбрать из выпадающего списка значение пустыми страницами или страницами со штрих-кодом в зависимости, от того, какие страницы используются в качестве разделителя. Сборка страниц в документы будет произведена автоматически: страницы будут добавляться в текущий документ, пока не встретится страница-разделитель. Подробнее см. Добавление изображений страниц.


Редактирование и публикация определения документа

Редактирование определения документа производится в окне редактора определения документа, в котором вы можете изменять расположение полей и статических элементов, редактировать их свойства, правила, настройки экспорта и т.д.

Для того чтобы при редактировании определения документа не влиять на работу других участников проекта, в программе предусмотрена возможность редактирования локальной копии определения, в то время как для распознавания используется последняя опубликованная версия. Такой режим работы позволяет вносить изменения и тестировать определение документа локально, а операторам даст возможность завершить верификацию и экспорт документов, распознанных в старой версии, даже если определение документа сильно изменено или удалено. Редактируемое определение недоступно для редактирования другими пользователями. После завершения редактирования можно опубликовать определение документа, тогда новая версия становится доступной для распознавания документов, или отменить все сделанные изменения.

Чтобы отредактировать определение документа, выполните следующие действия:

  1. В главном окне программы выберите пункт меню Проект>Определения документов…
  2. Выберите в списке определение документа для редактирования.
  3. Нажмите кнопку Правка… в диалоге Определения документов, чтобы начать редактирование определения документа. Локальная версия определения будет скопирована на ваш компьютер. определение документа станет недоступно для редактирования другими пользователями.
  4. Сделайте необходимые изменения в окне редактора определения документа. Сохраните определение.
  5. Протестируйте определение документа на нескольких изображениях. Для отладки определения используются тестовые пакеты, которые работают с локальной версией определения.
  6. Нажмите кнопку Опубликовать в диалоге Определения документов, чтобы опубликовать определение. После публикации новая версия определения будет использоваться для распознавания документов из рабочих пакетов. определение документа снова станет доступно для редактирования другими администраторами. Для того чтобы вернуть определение, но без сделанных изменений, нужно нажать кнопку Отменить правку.
  7. Наложение определений документов осуществляется в том порядке, в котором они перечислены в диалоговом окне Определения документов. При необходимости измените порядок наложения определений документов.
  8. Для ускорения наложения гибких описаний отметьте опцию Использовать первое подошедшее гибкое описание: в этом случае будет использоваться первое наложившееся описание. Если опция не отмечена, приложение будет пытаться наложить все гибкие описания, с последующим выбором наилучшего.

Новая версия определения документа начинает использоваться при распознавании и дальнейшей обработке документов сразу после публикации. Однако для документов, обрабатывавшихся на момент публикации определения, используется предыдущая версия. При необходимости можно обновить версию определения и для обрабатывающихся документов. Для этого выберите пункт меню Сервис>Обновить до последней версии. При этом в зависимости от изменений в определении документа будет выведено сообщение о необходимости повторно отправить документы на распознавание (если изменились параметры распознавания), на проверку правил (если изменились правила документов) либо просто проэкспортированы с новыми настройками (если изменились только настройки экспорта).


Тестирование определений документов

Прежде чем приступать к массовому вводу документов, необходимо протестировать определения документов. Тестирование производится на документах, добавляемых в тестовые пакеты, т.к. эти пакеты работают с локальной версией определения. Эти пакеты доступны из меню Вид>Тестовые пакеты главного окна программы. Также к ним можно перейти из окна редактора определения документа, выбрав пункт меню Пакет>Режим тестовых пакетов….

Внимание! С тестовыми пакетами может работать только пользователь, создавший их. При необходимости, роль постоянных тестовых пакетов могут играть рабочие пакеты, используемые как источник изображений для тестового пакета.

Тестировать определение документа можно прямо в редакторе определения документа, на том изображении, которое используется для создания определения. Чтобы начать тестирование, выберите пункт меню Тестирование>Начать тестирование. Форма данных отобразится также, как и при обработке документов, будут показаны форматные ошибки, неуверенно распознанные символы и ошибки правил.

Для удобного расположения окон при тестировании воспользуйтесь меню Тестирование>Вид, а для навигации между объектами верификации, неуверенно распознанными символами и ошибками правил, меню Тестирование>Верификация. Для выхода из режима тестирования нажмите на кнопку Закончить тестирование документа или выберите пункт меню Тестирование>Закончить тестирование.

Замечание. В режиме тестирования перемещение разметки поля в окне изображения не приводит к перераспознаванию поля, как это происходит при работе в окне документа.

Для тестирования определения на других изображениях нужно выбрать тестовый пакет, перейти к нему можно из редактора определения документа, выбрав пункт меню Пакет>Режим тестовых пакетов…. Перед вызовом диалога выбора тестового пакета происходит проверка правильности определения документа. В случае если ошибок нет, определение сохраняется и вызывается диалог выбора тестового пакета. При выборе какого-либо пакета происходит переключение на этот пакет в главном окне программы (главное окно становится активным).

Рекомендуется проверить каждое определение не менее, чем на 20 изображениях документов (если документы заполняются от руки, то желательно, чтобы они были заполнены разными людьми).

Тестирование необходимо для того, чтобы выяснить:

  1. Достаточно ли выделенных реперов и идентификаторов для уверенного наложения определения документа на изображения.
  2. Корректно ли заданы свойства полей.
  3. Корректно ли заданы правила.
  4. Корректно ли настроен экспорт.

При тестировании должна быть проделана вся последовательность действий, выполняемая при обработке документов.

Если в результате тестирования были обнаружены ошибки в правилах, некорректно заданные значения свойств полей и т.д., то для их исправления необходимо отредактировать определение.

Только после устранения всех найденных проблем можно опубликовать определение документа и приступать к массовому вводу документов.

Работа оператора с настроенным проектом


Классификатор проекта

Классификатор - проект ABBYY FlexiLayout Studio, предназначенный для предварительной идентификации отдельных страниц и отнесения их к определенному типу (например, по используемому гибкому описанию / варианту гибкого описания). После разработки классификатор используется в ABBYY FlexiCapture для классификации документов на уровне проекта или типа пакета.

Для того чтобы подключить проект классификатора на уровне проекта, необходимо

  • открыть проект;
  • в главном окне в меню Проект выбрать Свойства проекта…;
  • в открывшемся диалоге свойств проекта перейти на закладку Распознавание и нажать на кнопку Загрузить…;
  • выбрать нужный .cfl файл, содержащий классификатор.

Замечание. Если при создании пакета был указан тип По умолчанию, он будет обрабатываться согласно настройкам, заданным в свойствах проекта.

Для того чтобы подключить проект классификатора на уровне типа пакета, необходимо

  • открыть диалог Типы Пакетов (Проект>Типы пакетов…);
  • в диалоге в списке выбрать нужный тип пакета и нажать на кнопку Правка…;
  • в открывшемся диалоге свойств типов пакетов перейти на закладку Распознавание и в разделе классификатора нажать на кнопку Загрузить…;
  • выбрать нужный .cfl файл, содержащий классификатор.

Классификаторы могут использоваться в следующих целях:

  • Для ускорения выбора определения документа для наложения. Использование классификатора позволяет не перебирать все определения документа для поиска наиболее подходящего, а выбирать нужное определение на основании классификационных признаков. При этом порядок перебора определяется пользователем с помощью выбора классификационных признаков и построения дерева классификатора. Ускорение наиболее заметно для крупных проектов, содержащих большое количество определений документов.
  • Для распределения классифицирующих признаков по дереву классификатора. На верхнем уровне можно отбирать документы, поступившие от определенной компании, по наличию поля с ее наименованием. На следующем уровне классификации отобранные документы можно различать по типам с помощью заголовков или, например, количества разделителей на странице.
  • Для управления наложением гибких описаний сторонней разработки. Возможна ситуация, когда описания, полученные от стороннего разработчика, накладываются неправильно (не на те документы, на которые требуется). В данном случае классификатор можно использовать для управления наложением определений документов, не обращаясь к разработчику описаний.
  • Для ускорения работы проектов, содержащих определения документов на разных языках. При использовании классификатора предраспознавание для классифицируемых документов будет осуществляться не по количеству языков всех определений в проекте, а два раза: при классификации и при наложении выбранного определения документа.

Подробная информация о классификаторах приведена в справочной системе ABBYY FlexiLayout Studio.


Профили импорта изображений

Обработка документов начинается с добавления новых изображений. Обычно добавление изображений осуществляется с помощью Станции Сканирования (подробная информация о Станции Сканирования содержится в ее справочной системе). Однако возможно добавление изображений на Станции Верификации, Станции Настройки Проектов, а также автоматически с помощью горячих папок.

Если действия по добавлению регулярно поступающих из одного и того же места изображений на Станции Верификации и / или Станции Настройки Проектов выполняются часто, их можно автоматизировать. Для этого нужно создать на Станции Настройки Проектов профиль импорта изображений для определенного проекта. Кроме того, можно настроить параметры обработки поступающих изображений и периодическое добавление изображений в фоновом режиме. Если произведены необходимые настройки, то при нажатии одной кнопки выполняется сканирование или импорт из заранее настроенного источника, а полученные изображения обрабатываются (например, очищаются от «мусора»). При желании пользователь может сменить источник ввода изображений или его настройки.

В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

Создание профиля импорта

Чтобы добавить профиль импорта, выберите пункт меню Проект > Профили импорта изображений… главного окна программы. В открывшемся диалоге вы можете создавать новые профили импорта, редактировать, удалять и копировать существующие профили.

Создать новый профиль импорта вам поможет мастер создания профиля, который запустится из диалога Профили импорта изображений при нажатии кнопки Новый…. На первом шаге мастера выберите источник импорта. Источником импорта может служить сканер или горячая папка.

Создание профиля импорта с использованием сканера
  1. В качестве источника импорта выберите Сканер.

    Внимание! Сканер должен быть подключен. Чтобы правильно подключить сканер, обратитесь к документации, прилагаемой к сканеру. При установке не забудьте установить все программное обеспечение, поставляемое вместе со сканером.

  2. На следующем шаге мастера вы можете задать опции сканирования и обработки поступающих изображений:
    • Стиль диалога настроек – выберите способ взаимодействия программы со сканером:
      • Настройки сканирования FlexiCapture: в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера. Нажмите на кнопку Настройки… чтобы установить опции сканирования. Если вы отметите Показывать настройки перед сканированием, то при выборе данного профиля импорта перед началом сканирования будет появляться диалог программы ABBYY FlexiCapture Настройки сканера.
      • Системные настройки сканирования: для настройки опций сканирования будет использоваться диалог соответствующего драйвера сканера. В этом случае при создании профиля импорта нельзя изменить опции сканирования, но диалог настроек сканирования будет появляться каждый раз перед началом сканирования изображений.
    • Отметьте, хотите ли вы сканировать одно или несколько изображений за один раз.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений.
  4. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.
Создание профиля импорта с использованием горячей папки
  1. В качестве источника импорта выберите Горячая папка. Выберите тип папки: Локальная или сетевая папка, POP3-сервер, MAPI (почтовый ящик) или FTP-сервер. Задайте путь к горячей папке с помощью кнопки Обзор… или учетную запись и пароль с помощью кнопки Настройка…

    Внимание! Для добавления изображений из горячей папки пользователь должен обладать правами на чтение и запись в данную папку.

    Чтобы настроить импорт через MAPI (почтовый ящик)
    • На компьютере должна быть настроена почтовая учетная запись.
    • Импортирующий процесс (пользовательская станция или станция обработки) должен быть запущен под учетной записью пользователя, чей почтовый ящик указан в настройках импорта.
      Замечание. Microsoft Outlook должен быть запущен под этой учетной записью пользователя на этом компьютере хотя бы один раз перед настройкой профиля импорта.
    • Для выбора доступного почтового ящика, нажмите Обзор…
    Чтобы настроить импорт через POP3-сервер
    • Введите адрес POP3-сервера.
    • Нажмите Настройка… и в открывшемся окне введите имя пользователя и пароль для получения доступа к сообщениям на сервере.

    Замечание. Если все настройки указаны верно, но ABBYY FlexiCapture не получает сообщения от сервера электронной почты POP3, убедитесь, что сетевой экран не блокирует соединение с почтовым сервером.

    Замечание. ABBYY FlexiCapture не поддерживает работу с почтовыми серверами POP3, использующими SSL-протокол (порт 995).

    Замечание. ABBYY FlexiCapture не поддерживает работу с 64-разрядной версией Microsoft Outlook 2010.

  2. На втором шаге задайте опции загрузки изображений:
    • Проверять Горячую папку каждые – отметьте эту опцию и введите промежуток времени, чтобы производилась автоматическая проверка наличия новых изображений в горячей папке.

      Замечание. Для запуска импорта с помощью горячих папок необходимо включить их для данного проекта с помощью монитора сервера обработки.

    • В области Настройки пакета выберите одну из опций, чтобы определить, в какой пакет будут добавлены новые изображения.
      • Добавлять изображения в текущий пакет – отметьте эту опцию, чтобы изображения из горячей папки были добавлены в текущий пакет;
      • Добавлять в пакет – отметьте эту опцию и выберите название пакета в выпадающем списке, чтобы изображения были добавлены в указанный пакет.
      • Создавать новые пакеты изображений автоматически – отметьте эту опцию, чтобы пакеты для новых изображений создавались автоматически. В этом случае при каждой проверке горячей папки (отметьте опцию Проверять Горячую папку каждые) будет создаваться один или несколько пакетов, в которые будут добавляться найденные в папке изображения в соответствии с указанным ниже правилом.
        В поле Тип пакета укажите тип автоматически создаваемого пакета. При необходимости укажите регистрационные параметры пакета (кнопка Регистрационные параметры…) и измените его приоритет в поле Приоритет.

        • Замечание. Если задания импорта обрабатываются на Сервере обработки, нужно выбрать опцию Создавать новые пакеты изображений автоматически. Опции Добавлять изображения в текущий пакет и Добавлять в пакет могут быть выбраны, только при импорте на Станции настройки проекта или при использовании версии Standalone.

    • В выпадающем списке Количество файлов выберите одно из значений, чтобы определить, сколько файлов будет добавлено в указанный или вновь созданный пакет:
      • В соответствии с файлом определения – файлы будут добавлены согласно описанию. Чтобы задать имя и тип файла описания, нажмите кнопку Настройки… Подробнее см. Файл описания.
      • Все файлы – будут добавлены все файлы, обнаруженные в горячей папке. Файлы из подкаталогов добавляться не будут.
      • Из подпапки - будут добавлены файлы из подкаталогов, имя которых совпадает с заданным форматом. Для задания формата имени нажмите кнопку Настройки…
        Замечание. Для обозначения любой последовательности символов используется звездочка *, для обозначения одного символа используется вопросительный знак ?.

        Замечание. Переименовывать подкаталог в соответсвии с заданным форматом нужно только после того, как в него были скопированы все требуемые файлы. В противном случае может возникнуть конфликт доступа к файлу.

      • Несколько файлов – будут добавлены несколько файлов. Чтобы определить количество файлов, нажмите кнопку Настройки… и введите число или диапазон значений. Файлы из подкаталогов добавляться не будут.
        Замечание. Если задано число, например 5, а в горячей папке осталось 4 файла, то эти файлы импортироваться не будут. Если же задан интервал 1-5, то оставшиеся 4 файла будут импортированы.
      • Один файл – будет добавлен один файл.
      • Прикреплено к письму – будут добавлены все прикрепленные к письму файлы.
      Замечание. Новые изображения добавляются в пакет в порядке возрастания имен.
    • Если профиль предназначен для импорта фотографий, а не сканированных изображений, отметьте опцию Обрабатывать изображение как фотографию.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений.

  4. На четвертом шаге мастер создания профиля предложит вам задать опции очищения горячей папки после импорта: успешно импортированные изображения можно удалять или перемещать в указанную папку. Изображения, в процессе обработки которых произошла ошибка, можно оставлять в Горячей папке или также перемещать в указанную папку. Если вы хотите перемещать изображения, задайте папки для перемещения.

  5. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.

Редактировать и создавать новые профили импорта можно также из диалога Выбор профиля импорта, который открывается при выборе пункта Файл>Импортировать изображения… главного меню.

Добавление изображений страниц


Файл описания

Файл описания – сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. В зависимости от формата файла описания, отличается набор файлов для формирования пакета.

В программе используются файлы описания следующих типов:

  1. Captiva QuickScan В пакет добавляются все файлы изображений, перечисленные в сопроводительном файле. Порядок следования файлов соответствует порядку в сопроводительном файле.
  2. Capture Software for Kodak В пакет добавляются файлы изображений, находящиеся в папке Kodak-пакета, указанной в сопроводительном файле, в порядке возрастания имен.
  3. Пустой файл Данный файл служит маркером, свидетельствующим о необходимости создать новый пакет. Содержание файла не имеет значения, существенно только его имя. Добавление изображений из горячей папки осуществляется в алфавитном порядке. При обнаружении файла, наименование которого соответствует маске, указанной в поле Название, система создает новый пакет. Таким образом, если задана маска *.dat, и горячая папка содержит следующие файлы: Contract1.jpg Contract2.jpg Contract3.dat Contract4.jpg Contract5.jpg Contract6.dat то для файлов Contract1.jpg and Contract2.jpg будет создан первый пакет (при нахождении файла Contract3.dat), а для файлов Contract4.jpg and Contract5.jpg - второй (при нахождении файла Contract6.dat).
  4. Файл XML Файл в xml-формате с документированной структурой. Предназначен для случаев, когда три предыдущих типа файлов не подходят, но есть возможность генерировать собственный файл сопровождения. В пакет добавляются файлы изображений, указанные в сопроводительном файле.

    Структура файла:

    XML-документ должен содержать корневой элемент Batch со следующими дочерними элементами: RegistrationParams, Documents и Images.

    Элемент Images, в свою очередь, должен включать в себя элементы Image, количество которых соответствует количеству страниц в создаваемом пакете.

    Элемент Batch содержит следующие теги:

    • Priority - приоритет пакета. Может иметь значения: Lowest, Low, Normal, High или Highest. Необязательный тег.
    • Name - желаемое имя пакета.
    • TypeName - имя типа пакета.
    • SourceID - строковый идентификатор источника пакета.
    • Description - описание.
    • RegistrationParams - список регистрационных параметров пакета.
    • Documents - список документов (не участвуют в автоматической сборке).
    • Images - список отдельных страниц (участвуют в автоматической сборке).

    Элемент Parameter содержит следующие теги:

    • Name (атрибут) - название регистрационного параметра.
    • Value - значение регистрационного параметра.

    Элемент Document содержит следующие теги:

    • Index (обязательный атрибут) - индекс документа (начиная с нуля) среди документов пакета.
    • Priority - приоритет. Может иметь значения: Lowest, Low, Normal, High или Highest. Необязательный тег.
    • Name - имя документа.
    • Barcode - значение штрих-кода.
    • RegistrationParams - список регистрационных параметров документа.
    • Images - список страниц документа.

    Элемент Image содержит следующие теги:

    • Index (обязательный атрибут) - индекс страницы (соответствующего документа для страниц из элемента Images) среди страниц документа (документов пакета); нумерация начинается с нуля.
    • PageIndex (атрибут) - номер страницы (начиная с нуля) в многостраничном импортируемом файле.
    • SourcePath (атрибут) - путь к папке с исходными изображениями.
    • SourceFile (атрибут) - исходный файл с изображением страницы (путь относительно SourcePath).
    • SourceFilePageIndex (атрибут) - номер страницы (начиная с нуля) в многостраничном исходном файле.
    • SourceDetails (атрибут) - произвольное описание источника (название сканера).
    • Value - путь к импортируемому файлу, указанный для страницы относительно горячей папки.

    Программу сканирования рекомендуется настроить таким образом, чтобы отсканированные изображения помещались в саму горячую папку или ее подпапки первого уровня. При создании пакета в него будут добавлены все изображения, пути к которым указаны в элементах Image соответствующего файла сопровождения. Порядок добавления изображений соответствует порядку их следования в файле.


Параметры обработки изображений

При добавлении изображений в пакет производится их предварительная обработка: деление изображений по документам, очищение, поворот изображений и т.д.

Параметры обработки изображений задаются в диалоге (на закладке) Предобработка изображений. Их можно задать:

  1. Для проекта. Тогда они будут использоваться по умолчанию при ручном добавлении изображений в пакеты проекта. Для этого в главном окне программы выберите пункт меню Проект>Свойства проекта… и в открывшемся диалоге перейдите на закладку Предобработка изображений.
  2. Для типа пакета. Тогда они будут использоваться для обработки изображений пакетов данного типа. Для этого при создании типа пакета задайте необходимые параметры на шаге Предобработка изображений.
  3. Для профиля импорта. Эти параметры будут использоваться при добавлении изображений с помощью данного профиля импорта. Для этого при создании профиля импорта задайте параметры обработки изображений на шаге Предобработка изображений.
  4. Для изображений, добавляемых вручную. Для этого при добавлении изображений из файла нажмите на кнопку Параметры обработки изображений… в диалоге Загрузка изображений.

Замечание. При сканировании вручную предварительная обработка изображений не осуществляется. Только при сканировании с использованием профиля импорта.

Пользователь может определить следующие параметры предварительной обработки изображений:

  • Опции для добавления изображений в документы:
    • Автоматически при наложении определения документа – отметьте эту опцию, если вы хотите, чтобы изображения собирались в документы при наложении определения документа (при распознавании). В этом случае при добавлении изображений документы формироваться не будут, они соберутся по результатам анализа страниц при распознавании согласно структуре, описанной для данного определения документа. Подробнее см. Создание определений для многостраничных документов и Сборка страниц в документы.
    • Для каждого файла – новый документ будет создан для каждого файла (файл изображения может быть многостраничным).
    • Для изображений, разделенных – страницы будут добавляться в один документ, пока не встретится страница-разделитель, тогда будет создан следующий документ и страницы будут добавляться в него и т.д. В качестве разделителя могут быть использованы пустые страницы, в этом случае выберите пустыми страницами в выпадающем списке. Также можно использовать в качестве разделителя страницы со штрих-кодами, в этом случае выберите страницами со штрих-кодом. Для штрих-кодов или пустых страниц можно задать дополнительные параметры, для этого нужно нажать кнопку Настройки…. Если страницы-разделители не нужно добавлять в пакет, то отметьте опцию Удалять страницу - разделитель. Если она не будет отмечена, страницы-разделители добавляются в пакет и становятся первыми страницами каждого документа.

    Замечание. Страницы-разделители для определения разбивки по документам использовать не обязательно. Без них нельзя обойтись только в одном случае: когда по виду страницы невозможно определить, относится она к предыдущему документу, или к следующему. Например, когда документ состоит из произвольного количества одинаковых страниц, а в пакете может присутствовать более одного такого документа.

  • Опции обработки поступающих изображений:
    • Очищать изображения – изображения будут очищаться от мусора;
    • Конвертировать цветные и серые изображения в черно-белые – изображения будут конвертированы в черно-белые;
    • Поворачивать изображения на – будет осуществляться разворот изображений в указанном направлении.
  • Опции выравнивания изображений. Эти опции по умолчанию включены и при добавлении изображений производится их выравнивание по черным квадратам и по вертикальным и горизонтальным разделителям и по тексту. Опции выравнивания не рекомендуется отключать, кроме тех случаев, когда выравнивание производится неправильно, например, программа может интерпретировать сторону неровно поставленного штампа или наклонную линию графика как разделитель и выровнять изображение по нему. В этом случае выравнивание по разделителям можно отключить.
    • Выравнивать изображения по разделителям – при включенной опции изображения выравниваются по сепараторам;
    • Выравнивать изображение по чёрным квадратам – при включенной опции изображения выравниваются по черным квадратам.
    • Выравнивать изображение по тексту - при включенной опции изображения выравниваются по тексту на изображении.


Настройки экспорта

Настройки экспорта указываются для каждого Типа Пакетов. При создании пакета он причисляется к определенному типу и экспорт пакета осуществляется в соответствии с настройками данного типа пакета.

В случае если не создано ни одного Типа Пакетов, все пакеты будут обрабатываться с настройками <По умолчанию>, которые задаются на проект (Проект>Свойства проекта…, закладка Экспорт).

На этой закладке вы можете разрешить удаление проэкспортированных документов, а также указать настройки экспорта для нераспознанных документов. Распознанные документы экспортируются в соответствии с настройками, указанными в Определении документа.

Вы можете указать следующие опции:

Опция | Описание
Группа Обработка документов после экспорта
Удалить документы после экспорта | Отметьте эту опцию, если вы хотите удалять документы после экспорта.
Удалять обработанные пакеты после | Отметьте эту опцию, если вы хотите отложить удаление обработанных пакетов на заданное количество часов или дней. Данная опция не может применяться к пакетам, хранящимся локально. Отложенное удаление обработанных пакетов в процессе ручной или автоматической очистки настраивается в консоли Администрирования и мониторинга. По умолчанию удаление обработанных пакетов осуществляется каждые 14 дней.
Группа Нераспознанные документы
Экспортировать нераспознанные документы | Отметьте эту опцию, если вы хотите экспортировать нераспознанные документы.
Группа Настройки экспорта изображений
Тип файла Выберите требуемый формат сохранения из списка. Поддерживаются следующие форматы: TIFF, JPEG, PDF, PDF/A, BMP, JPEG2000, PCX packbits, PNG.
Нажмите кнопку Настройки…, чтобы указать настройки для выбранного формата. Для всех форматов доступны следующие настройки:
  • Качество: Наилучшее, Высокое, Обычное или Низкое.
  • Цвет: Цветное, Градации серого, Полутона (ч/б).
  • Изменение разрешения на новое значение (в dpi).
Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF-файл с возможностью поиска. В PDF с возможностью поиска тексовый слой формируется из проверенных на верификации значений полей и областей документа за пределами полей. Для таких областей выполняется полнотекстовое распознавание. В поле Искать укажите, где должен выполняться поиск: на всех страницах, на страницах разделов или на страницах приложений.

Язык распознавания определяется следующим образом:

  • Для полей язык распознавания указывается на закладке Тип данных свойств поля.
  • При полнотекстовом распознавании используется язык Определения документа.
  • Для страниц-приложений вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в определении документа. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. По умолчанию используется язык Определения документа.
Отметьте опцию Использовать MRC (Mixed Raster Content), если вы хотите получить более высокую скорость распознавания и малый размер конечных файлов. При использовании этой опции поля, для которых выбран режим Не распознавать, могут экспортироваться с ухудшением качества.
Цель Выберите требуемую цель экспорта из выпадающего списка. В зависимости от выбранной цели экспорта, укажите дополнительные настройки. Вы можете выбрать один из следующих вариантов:
  • Экспортировать с заданным шаблоном имени файла
    При выборе данного значения можно формировать имя файлов и структуру подпапок в зависимости от параметров документов.
    • Укажите корневой путь экспорта в поле Корень экспорта.
    • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Настроить… и настройте правила именования файлов и папок. Подробнее см. Критерии формирования имен файлов экспорта.
    • Выберите в поле Если файл существет действие, которое необходимо выполнять, если файл со сформированным именем уже существует.
  • Экспортировать каждый документ в отдельный файл
    Укажите путь и первые символы названия файла в поле Префикс файла.
  • Воссоздать структуру подпапок Горячей Папки
    При выборе данного значения будет создана структура папок, повторяющая структуру подпапок Горячей Папки, из которой были импортированы изображения документов. При настройке такого экспорта необходимо указать в поле Корень экспорта папку, относительно которой будет воссоздаваться структура Горячей Папки.


Пакеты документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

На Станциях Обработки пакеты формируются автоматически при импорте изображений из горячих папок. На Станции Сканирования операторы могут создавать пакеты вручную, либо автоматически при соответствующих настройках в профилях сканирования. При формировании пакета указывается его тип, определяющий порядок обработки пакета.

Добавление изображений страниц документов производится в процессе потокового ввода. Подробнее см. Добавление изображений страниц.

На Станции Настройки Проектов, для отладки определений документов, можно создавать пакеты, добавлять в них изображения документов и обрабатывать их (распознавать, верифицировать, экспортировать данные). Для создания пакета выберите пункт контекстного меню New Batch..., появляющегося при нажатии правой кнопки мыши в главном окне со списком пакетов.

Рабочие и тестовые пакеты

Тестовые пакеты используются для тестирования и отладки определений документов. С тестовыми пакетами работает Оператор Настройки Проектов. Рабочие пакеты - это пакеты документов, предназначенные для обработки документов в комплексе ABBYY FlexiCapture 10. Оператор Настройки Проектов тоже может получить к ним доступ. Это может понадобиться, если в процессе обработки документов на станциях комплекса возникли ошибки в настройках. Оператор может открыть пакет, проверить и исправить ошибку. Отличие этих пакетов в том, что для обработки документов из тестовых пакетов используется локальная версия определения документа, а для обработки документов из рабочих пакетов – опубликованная версия. Cм. Редактирование и публикация определения документа.

Переход к списку пакетов документов осуществляется на Станции Настройки Проектов из меню Вид. Рабочие пакеты: Пакеты, тестовые пакеты: Тестовые пакеты.


Приложения

Пользовательские приложения могут быть добавлены для страниц, документов и пакетов. Добавленные приложения доступны дальнейшего редактирования и загрузки.

Вы можете прикрепить файлы любого формата, например, добавить файл с цифровой подписью при сканировании изображений.

Приложения могут быть добавлены одним из следующих способов:

  1. При загрузке изображений из горячей папки в соответсвии с настройками, указанными в файле описания.
  2. На закладке Приложения в диалоговом окне свойств страницы, документа или пакета нажмите кнопку Новое…. В открывшемся диалоговом окне укажите имя приложения и путь к нему.
  3. С помощью скрипта, используя метод IUserAttachments.AddNew. Методы интерфейса IUserAttachment также позволяют редактировать добавленные приложения.
  4. Используя Web Service API.

Чтобы сохранить приложение на жесткий диск, нажмите кнопку Сохранить как… на закладке Приложения либо используйте метод IUserAttachment.ToFile.


Индексные поля

Для удобства поиска документов при их обработке, можно проиндексировать документы по значениям любых полей определения документа. Тогда в списке документов в главном окне программы кроме основной информации можно будет вывести значения индексного поля для каждого документа, производить сортировку документов по этим значениям и легко находить нужные документы.

Для того чтобы производить индексирование по значению поля, нужно отметить свойство Индексное поле для этого поля (редактор определения документа, диалог свойств поля, закладка Общие).

Чтобы отобразить значения индексного поля в списке документов:

  • В главном окне программы откройте пакет документов и перейдите в режим детализованного списка документов (кнопка [image] панели инструментов).
  • Нажмите правую кнопку мыши в области шапки таблицы (названий колонок) и выберите в выпадающем списке пункт Настроить…
  • В диалоге Настройка столбцов нажмите кнопку Новая…
  • В диалоге Правка столбца нажмите Выбрать… справа от Индексное поле. В открывшемся диалоге можно выбрать одно из полей, у которых отмечена опция Индексное поле. Можете также ввести любое название столбца и задать способ выравнивания.
  • В таблице появится еще одна колонка со значениями индексного поля. Щелкнув левой кнопкой мыши на ее названии, вы можете произвести сортировку документов по значению индексного поля.


Работа оператора с настроенным проектом

В ходе процесса обработки документы проходят различные этапы. При создании и настройке проекта указывается, на каких этапах и в каком случае необходим контроль человека (или исправление ошибок). Для данных этапов создаются очереди заданий. Также существует специальная очередь - Исключения.

Операторы - пользователи, осуществляющие контроль за обработкой и исправление ошибок документов (пакетов) в рамках настроенного проекта. В следующей таблице приведен список операторов ABBYY FlexiCapture, доступных им станций и очередей.

Оператор | Станции | Очереди | Функции
Оператор мониторинга | Консоль администрирования и мониторинга | - | Мониторинг работы комплекса
Оператор сканирования | Станция сканирования | - | Потоковый ввод документов (сканирование или импорт из файлов), отправка документов на обработку
Оператор верификации данных | Станция верификации данных Станция верификации (только групповая и контекстная верификация) | Верификации данных | Проверка и исправление неуверенно распознанных символов (групповая и контекстная верификация)
Оператор верификации | Станция верификации данных Станция верификации | Верификации данных Верификации Проверки сборки Проверки целостности пакета | То же, что и оператор верификации данных + проверка и исправление сборки страниц в документы, исправление ошибок сборки пакета
Старший оператор верификации | Станция верификации данных Станция верификации | Верификации данных Верификации Проверки сборки Проверки целостности пакета Подтверждения экспорта Исключений | То же, что и оператор верификации + подтверждение экспорта документов, обработка исключительных ситуаций

В соответствии с предоставленными им правами доступа операторы запускают станции и выполняют требуемые действия.


Процесс обработки

Процесс обработки документов проходит в несколько этапов. Этап обработки - это процесс (автоматический или с участием оператора) по преобразованию документов. Все этапы упорядочены и для прохождения этапа, необходимо чтобы предыдущие были пройдены. В общем виде процесс обработки сводится к этапам: добавление изображений, распознавание, верификация, экспорт.

На каждом из этапов формируется очередь из заданий (список документов от одного до пакета) на обработку. В процессе обработки документы перемещаются от начальной очереди на распознавание до финальной - очереди на экспорт. Как правило очереди соответствуют этапам обработки, но есть и специальные, например, очередь исключений.

Этапы.

  1. Импорт изображений.

    Загрузка изображений может производиться автоматически с помощью Горячих папок или под управлением Оператора Сканирования на Станции Сканирования. Оператор Сканирования может сканировать и добавлять уже отсканированные изображения. Для автоматизации процесса (т.е. добавления изображений с заданными настройками по нажатию одной кнопки) каждый Оператор Сканирования на своей станции может создавать профили сканирования.

  2. Распознавание. Очередь на распознавание обрабатывается на Станции Обработки в автоматическом режиме.
  3. Верификация. Очередь на верификацию обрабатывается оператором на Станции Верификации.
  4. Экспорт. Очередь на экспорт обрабатывается на Станции Обработки в автоматическом режиме.

Для повышения эффективности обработки при больших объемах, этап верификации можно разделить на более мелкие. В этом случае можно добиться большего разделения обязанностей между операторами.

Можно создать отдельные очереди:

  • Проверка сборки документов
  • Верификация данных - групповая и контекстная проверки неуверенно распознанных символов и форматных ошибок
  • Верификация - проверка правил и проверка в окне документа
  • Проверка целостности пакета
  • Подтверждение экспорта

Замечание. Необходимость выделения той или иной очереди задается для Типа Пакетов.

Задания из очередей обрабатываются операторами с правами:

  • Оператор Верификации Данных - только очередь Верификация данных
  • Оператор Верификации - Верификация данных, Верификация, Проверка сборки документов, Проверка целостности пакета
  • Старший Оператор Верификации - все очереди

Замечание. На Станции Верификации Данных, не зависимо от прав, можно обрабатывать только очередь Верификация данных.


Добавление изображений страниц

Обработка документов начинается с добавления в проект изображений страниц документов – импорта изображений. Изображения поступают со Станции Сканирования либо автоматически извлекаются из горячих папок.

Фоновый импорт изображений

Импорт изображений может производиться в фоновом режиме, если настроен соответствующий профиль импорта. Изображения из горячей папки автоматически импортируются в систему, проверка наличия новых изображений производится через указанный в настройках интервал времени.

Добавление изображений в ручном режиме

При необходимости можно добавить изображения в пакет в ручном режиме на Станции Верификации (Старший оператор верификации) либо Станции Настройки Проектов. Добавление изображений осуществляется в режиме просмотра пакетов. Откройте пакет, в который необходимо добавить изображения, либо просто выделите его в списке.

Добавить изображения в пакет можно несколькими способами:

  1. Загрузить ранее сохраненные изображения из файлов;
  2. Отсканировать изображения;
  3. Произвести импорт изображений, используя один из ранее настроенных профилей импорта изображений (cм. Профили импорта изображений.)

Добавление изображений осуществляется выбором соответствующего пункта в контекстном меню пакета.

Добавление изображений из файла

Для того чтобы загрузить изображения из файла, выберите пункт меню Загрузить изображения… или нажмите комбинацию клавиш Ctrl+O. В открывшемся диалоге выберите нужные файлы с изображениями и задайте опции импорта изображений:

  • Создавать новый документ – для добавленных изображений будут созданы новые документы.
  • Добавить в текущий документ – изображения будут добавлены в текущий, выделенный документ.
  • Вы также можете задать параметры предварительной обработки изображений. Для этого нажмите на кнопку Параметры обработки изображений… и задайте нужные параметры в открывшемся диалоге. Подробнее см. Параметры обработки изображений.

Сканирование изображений

Для добавления изображений со сканера, выберите пункт меню Сканировать изображения…. Выберите сканер, установите параметры сканирования и отсканируйте изображения.

Добавление изображений с использованием профилей импорта

При выборе пункта Импортировать изображения… откроется диалог Выбор профиля импорта, в котором нужно выбрать профиль импорта из списка и нажать кнопку Импортировать для начала импорта изображений.


Установка параметров сканирования

Как правило, документы поступают на обработку со Станции Сканирования или из горячих папок. Тем не менее существует возможность отсканировать документы непосредственно на Станции Верификации или на Станции Настройки Проекта. При этом необходимо установить параметры сканирования.

Качество распознавания во многом зависит от того, насколько хорошее изображение получено при сканировании. Качество изображения регулируется установкой основных параметров сканирования: типа изображения, разрешения и яркости.

При сканировании через программу ABBYY FlexiCapture возможно два варианта взаимодействия программы со сканерами через TWAIN или ISIS драйвера:

  • через интерфейс ABBYY FlexiCapture:
    в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера; параметры сканирования можно установить при создании профиля импорта с источником импорта Сканер.
  • через интерфейс TWAIN или ISIS-драйвера сканера:
    для настройки опций сканирования используется диалог соответствующего драйвера сканера. Этот диалог открывается автоматически при выборе пункта Сканировать изображения… выпадающего меню кнопки импорта.

Основные параметры сканирования

  • Тип изображения – сканирование в сером (256 градаций) является оптимальным режимом для системы распознавания. В случае сканирования в сером режиме осуществляется автоматический подбор яркости.

    Черно-белый тип изображения обеспечивает более высокую скорость сканирования, но при этом теряется часть информации о буквах, что может привести к ухудшению качества распознавания на документах среднего и низкого качества печати.
    Если вы хотите, чтобы содержащиеся в документе цветные элементы (картинки, цветные буквы и цветной фон) были переданы в электронный документ с сохранением цвета, необходимо выбрать цветной тип изображения. В других случаях используйте серый тип изображения.

  • Яркость и контрастность – нужно подобрать так, чтобы, во-первых, были сохранены реперные блоки, и, во-вторых, изображения распознаваемых блоков получились как можно более четкими и разборчивыми.
    В большинстве случаев подходит среднее значение яркости – 50%.
    На некоторых документах при сканировании в черно-белом режиме может понадобиться дополнительная настройка яркости.
  • Разрешение – рекомендованные разрешения для обработки форм, заполненных от руки, – 300 dpi. Разрешение изображений при сканировании обрабатываемых форм должно совпадать с разрешением изображения исходного документа.

Замечания.

  1. Сканирование с разрешением 400-600 dpi вместо 300 dpi или сканирование в сером или в цвете, а не в черно-белом, может занять существенно больше времени. На некоторых моделях сканеров сканирование с разрешением 600 dpi занимает в 4 раза больше времени, чем сканирование с разрешением 300 dpi. Не рекомендуется сканировать с разрешением менее 200 dpi.
  2. При использования диалога драйвера сканера, опции для установки параметров сканирования могут называться по-разному, в зависимости от модели сканера. Например, яркость может называться brightness, threshold, изображаться "солнышком" или черно-белым кружком. Смысл опций описан в документации, прилагаемой к вашему сканеру.
Советы по режиму сканирования
  1. Сканирование цветных фоновых форм на нецветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо оборудовать сканер соответствующей лампой фильтрации цвета: для «розовых» форм – красной лампой (Red-Lamp), для «зеленых» форм – зеленой лампой (Green-Lamp).
  2. Сканирование цветных фоновых форм на цветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо в настройках параметров сканирования задать режим фильтрации соответствующего цвета.
  3. Сканирование цветных фоновых форм светлых тонов. Если вы обрабатываете цветные формы светлых оттенков, то за счет слабой насыщенности цвета фон может исчезать при сканировании белой лампой и без программной фильтрации цвета. Способ сканирования форм выбирается, как правило, на этапе разработки формы.
Советы по подбору яркости
  1. Отсканированное изображение должно быть читаемым (для того, чтобы просмотреть отсканированное изображение, откройте его в окне документа).
  2. Если в полученном изображении буквы "разорванные", светлые или тонкие:
    • Уменьшите яркость, увеличьте контрастность (сделайте изображение темнее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).
  3. Если в полученном изображении грязный фон; искаженные, залитые или склеенные символы; темные, толстые буквы:
    • Увеличьте яркость (сделайте изображение светлее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).


Распознавание

Распознавание документов осуществляется системой автоматически на Станциях Обработки.

При этом программа производит наложение определения документа, выбирая его по реперам и идентификаторам, и производит распознавание данных в областях документов, которые совпадают с областями полей выбранного определения.

Процентное соотношение уверенно распознанных символов к общему количеству отображается в колонке Уверенность.

В случае если во время распознавания в проект были внесены изменения, при обработке пакетов (документов) в режиме с верификацией, Оператор Верификации и Старший Оператор Верификации могут перераспознать документы с новыми настройками вручную. Для этого нужно запустить Станцию Верификации и в главном меню выбрать Сервис>Обновить до последней версии.

Замечание. В процессе распознавания может возникнуть следующее сообщение об ошибке: "Cannot create <ProjectDirectory>\<BatchName>\BatchHeader.tmp". The specified file already exists." Данное сообщение возникает в результате влияния службы индексирования Windows Search на работу комплекса. Служба индексирования Windows Search обрабатывает временные файлы, которые создаются и удаляются в папке проекта в процессе работы комплекса, что приводит к возникновению ошибки. По этой причине мы рекомендуем отключать службу Windows Search.


Предварительный анализ изображений и наложение определения документа

Распознавание, анализ и наложение определения документа осуществляются автоматически. Тем не менее Оператор Верификации и Старший Оператор Верификации могут, при необходимости, запустить анализ и наложение определения документа в ручном режиме. Для этого нужно запустить Станцию Верификации и в главном меню выбрать Сервис > Повторный анализ. Если определение документа может быть наложено, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни одно из определений проекта не может быть наложен на изображение, то страница остается необработанной.

Программа также позволяет наложить на страницу или на весь документ определенное определение документа. В большинстве случаев правильно созданное в программе определение накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить его вручную.

Чтобы произвести наложение определения документа:

  1. Выделите документ;
  2. Выберите пункт Наложить определение документа… локального меню документа или пункт главного меню Распознавание>Наложить определение документа…;
  3. В открывшемся диалоге Выберите определение документа выберите одно из определений документов и нажмите OK.

Если наложение выбранного определения документа прошло успешно, документу и входящим в него страницам будут присвоены названия соответствующего определения документа и его разделов.

Чтобы произвести наложение определения документа на одну из страниц:

  1. Выделите страницу;
  2. Выберите пункт Наложить определение документа… локального меню страницы или пункт главного меню Распознавание>Наложить определение документа…;
  3. В открывшемся диалоге Выбор определения для наложения выберите одно из определений документов и нажмите OK.

Если наложение определения документа прошло успешно, то выбранной странице будет присвоено название соответствующего раздела определения.


Верификация распознанных данных

Верификация, или проверка распознанных данных – самая трудоемкая часть работы оператора. Поэтому процесс верификации в ABBYY FlexiCapture 10 организован таким образом, чтобы быть максимально удобным для оператора, и чтобы количество ошибок сводилось к минимуму.

Символы, насчет правильности распознавания которых нет абсолютной уверенности, помечаются программой как неуверенно распознанные. Процесс верификации предназначен для того, чтобы проверить такие символы, удостовериться, что они распознаны правильно или исправить их.

Проверка правил производится автоматически, если значения полей удовлетворяют правилам, то эти поля могут быть помечены как уверенно распознанные и не участвовать в процессе верификации. Если же значения полей не удовлетворяют правилам, то такие поля подаются на проверку оператору.

Для многостраничных документов сначала следует проверить сборку страниц в документы.

Затем запускается процесс верификации. Процесс верификации производится в 2 этапа – групповая верификация и контекстная. Если в определении документа нет полей, включенных в групповую или контекстную верификацию (см. Свойства верификации поля), то соответствующий этап верификации будет пропущен.

После прохождения этапов групповой и контекстной верификации, производится проверка в окне документа. Те символы, которые не были подтверждены на более ранних этапах, остаются подсвеченными красным цветом.

Переход к предыдущей и следующей ошибке осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил и т.д.

маркированный список | Сборка страниц в документы
маркированный список | Групповая верификация
маркированный список | Контекстная верификация
маркированный список | Верификация в окне документа
маркированный список | Верификация правил


Сборка страниц в документы

Сборка страниц в документы производится автоматически либо по явной команде пользователя. Принцип сборки может быть описан при создании определения для обработки многостраничных документов, а также при настройке пользовательских стадий обработки в свойствах типа пакета. Сборка, описанная в свойствах определения документа, и сборка, описанная в свойствах типа пакета, выполняются в разное время и имеют доступ к различному набору документу.

Особенности сборки, описанной в свойствах определения документа:

  1. Выполняется:
    • по выборе команды Сервис > Обновить сборку
    • после распознавания/анализа группы документов; при этом в сборку включены только документы, участвующие в распознавании/анализе
  2. Могут использоваться как стандартные правила сборки, так и пользовательский скрипт сборки.
  3. В сборке не участвуют документы, для которых выставлен флаг IsExcludedFromAutomaticAssembly. Флаг IsExcludedFromAutomaticAssembly принимает значение true в следующих случаях:
    • структура документов определяется при импорте (по XML-описаниям, при разбиении по пустым страницам, штрих-кодам или многостраничным файлам)
    • для документа выполняется команда Наложить определение документа…
    • флаг может быть выставлен из скрипта, в котором доступно редактирование документа
  4. Сборка не выполняется, если документы были распознаны с помощью разных определений документов, либо разных версий одного определений документа.
  5. Сборка не выполняется, если определение документа не было наложено. Например, если все страницы в пакете определены как страницы-приложения, сборка не происходит.
  6. Сборка не позволяет менять порядок страниц в пакете.

Особенности сборки, описанной в свойствах типа пакета

  1. Выполняется, когда документы приходят на соответствующую стадию.
  2. Описывается с помощью скриптов обработки.
  3. Позволяет перемещать и удалять документы и страницы.

Задача оператора состоит в том, чтобы выявить и исправить возможные ошибки сборки документов.

Ошибки сборки удобнее всего исправлять в режиме просмотра эскизов страниц, т.к. пользователь хорошо видит изображения страниц и их принадлежность к документам. В этот режим можно переключиться с помощью кнопки [image].

Замечание. Вы можете изменять масштаб эскизов страниц для просмотра деталей, для этого нажмите Ctrl и вращайте колесо мыши.

При создании определения документа задается правило сборки документа: порядок следования и количество повторений разделов документа. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа.

Замечание. Порядок следования разделов не проверяется, если при создании определения документа в свойствах определения на закладке Сборка отмечена опция Отключить проверку порядка разделов. В этом случае проверяется только наличие разделов документа, но не их порядок.

Документы с ошибками сборки помечаются значком [image]. Описание ошибки выводится текстом красного цвета под названием определения документа.

Как исправить ошибки сборки

  1. Неправильный порядок страниц в документе

    Возможно, страниц не хватает или присутствуют лишние страницы, либо страницы документа следуют не по порядку. Чтобы получить подсказку, наведите курсор мыши на страницу, помеченную красным крестиком:

    Для исправления таких ошибок можно переместить страницу с помощью мыши, как в пределах одного документа, так и из одного документа в другой.

    Соединить страницы нескольких документов в один документ можно следующим образом:

    • Выделите документы для объединения (несколько документов можно выделить удерживая нажатой клавишу ctrl);
    • Нажмите на правую кнопку мыши и выберите пункт локального меню Объединить.

    Чтобы разделить страницы документа и поместить каждую из них в отдельный документ:

    • Выделите документ для разделения страниц;
    • Выберите пункт локального меню Разделить.

  2. Если в определении документа задано, что для правильной сборки страниц должна производиться проверка по ключевым полям, то значения ключевых полей будут отображены под изображением каждой страницы:

    • серым цветом - в случае совпадения;
    • красным цветом - в случае несовпадения.

    Ключевые поля могут не совпадать из-за того, что они были неправильно распознаны или заполнены. Проверьте значения ключевых полей. Если же значения ключевых полей все равно не совпадают, то, вероятно, такие страницы не относятся к одному документу. Если был перепутан порядок страниц, то найдите страницы с одинаковыми ключевыми полями и соберите их в документы, с помощью приемов, описанных в пункте 1.


Групповая верификация

Групповая верификация – это просмотр оператором изображений символов, распознанных с одинаковым значением. Таким образом легко заметить и исправить символы, выделяющиеся из общей массы.

При групповой верификации оператор может просмотреть контекст проверяемого символа, выбрав пункт Показать изображение символа в локальном меню выделенного символа или нажав клавишу F2.

Можно также включить режим, при котором будет отображаться поле, содержащее символ, при наведении курсора мыши на проверяемый символ. Для этого нужно выбрать пункт меню Вид>Изображение поля>Показывать изображение поля в окне верификации, либо нажать комбинацию клавиш Ctrl+I.

Неправильно распознанные символы можно исправить следующим образом: выделите символ, который не соответствует символу группы, и введите его правильное значение. Это значение отобразится зеленым цветом в левом верхнем углу изображения символа.

Если в качестве символа было распознано постороннее изображение, его можно удалить, нажав клавишу Delete.

Если вы сомневаетесь в значении символа даже после просмотра контекста, нажмите на символ левой кнопкой мыши: символ будет помечен красным знаком вопроса. Его можно будет подтвердить или исправить во время контекстной верификации.

Статус символа можно изменять также с помощью кнопки Изменить статус панели инструментов.

Когда все неверно распознанные символы исправлены или отложены, можно подтвердить все остальные символы, нажав кнопку Подтвердить все панели инструментов. Также можно подтвердить отдельные символы с помощью локального меню, выбрав пункт Подтвердить.


Контекстная верификация

Контекстная верификация – это режим верификации, предназначенный для эффективного исправления ошибок «хорошо определенных» полей, то есть полей, область значений которых известна или легко идентифицируется. Таким полем, например, является название страны или города: нам известно, какие значения может принимать данное поле.

Для принятия решения о том, как нужно исправить значение поля, пользователю достаточно видеть только это поле и знать его область значений. Исправляются не только ошибки заполнения, но и ошибки формата поля.

Для исправления неправильно распознанных символов можно использовать стандартные режимы текстовых редакторов: режим вставки и замены символов, переключаться между ними можно с помощью кнопки Insert на клавиатуре.

При необходимости можно изменить способ корректировки значений полей, например, включить выделение всего поля для того, чтобы вводить его значение целиком вместо правки отдельных символов. Также можно настроить внешний вид окна контекстной верификации для отображения дополнительной информации: изображения поля, изображений аналогичных полей других документов и т. д.

Пользователь последовательно просматривает результат распознавания каждого поля, при необходимости исправляет его и подтверждает с помощью кнопки Подтвердить поле.

Значения полей нужно исправить, а если исправить не удается, то пропустить поле или отложить проверку значения поля с помощью кнопки Отложить поле, чтобы внести исправления при верификации документа целиком на стадии верификации.


Верификация в окне документа

Окно документа также позволяет проверить правильность распознавания и исправить неверно распознанные символы. Окно документа открывается при двойном щелчке на названии страницы и состоит из области данных, изображения страницы и области ошибок (если такие ошибки есть). При необходимости можно выбрать типы отображаемых ошибок: ошибки сборки, ошибки формата, ошибки правил, ошибки неналожения региона или любую их комбинацию. Для отображения ошибок определенного типа надо нажать на соответствующую кнопку в правом верхнем углу области ошибок.

В окне документа оператор видит уже не группы символов или отдельные поля, а весь документ целиком. Вид окна можно настроить с помощью кнопки Вид окна. Для просмотра изображения страницы на втором мониторе нажмите на стрелочку рядом с кнопкой Вид окна и выберите Окно изображения > Не закреплено. В этом режиме вы можете приблизить изображение страницы, выделить блок, удалить лишние разделители.

Показать окно документа

В области данных неуверенно распознанные и сомнительные символы выделяются цветом, поля с неверными типами данных и невыполненными правилами подсвечиваются.

Поле с неуверенно распознанными символами можно подтвердить, установив курсор в данное поле и нажав Enter.

Поля для просмотра и редактирования распознанных данных могут располагаться не только в порядке следования, но и в любом другом порядке, удобном для пользователя. Их расположение можно изменить в редакторе определения документа, см. Настройка отображения данных в окне документа.

Переход к следующей ошибке в окне документа осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, ошибки правил, несовпадение ключевых полей и т.д.

Быстрый ввод значений для неналоженных полей

Данная функциональность доступна для проектов, использующих гибкие описания, и позволяет быстро ввести значение поля, если даное поле не было наложено.

Режим быстрого ввода данных позволяет перенести данные в активное поле, выделив регион поля с помощью мыши. Для того чтобы в процессе верификации можно было использовать данный режим, в свойствах определения документа нужно отметить опцию Сохранять распознанные слова в кэше. В этом случае при подстановке будут использоваться распознанные значения из кеша.

Если значение поля не найдено или найдено неправильно, то для быстрого ввода значения щелкните кнопкой мыши по региону поля на странице. Можно также выделить часть текста, зажав левую клавишу мыши. Если в документе есть только одно поле без региона, значение будет добавлено автоматически. Если таких полей несколько, вам будет предложено выбрать, для какого поля следует ввести значение.

Если ни одно из предложенных значений не подходит, то при верификации на Станции настройки проекта или Станции верификации можно выделить регион и контекстном меню региона выбрать пункт Распознать(Ctrl+R). В этом случае поле будет распознано с использованием настроек, указанных для данного поля в определении документа. При верификации на Web-станциях данная возможность недоступна.

Режим навигации по неналоженным полям

Для навигации по полям, регионы которых не найдены, в контекстном меню окна документа нужно выбрать опцию Перейти к следующему ненайденному полю при наложении. При выборе данного режима в фокусе окажется первое поле с неналоженным регионом. При вводе значения поля или при навигации с помощью кнопок [image] и [image], будет осуществляться переход к следующему полю без региона.

Замечание. Для того чтобы в случае неналожения региона поле было подсвечено и доступно в режиме Перейти к следующему ненайденному полю при наложении, необходимо, чтобы в свойствах поля была отмечена опция Должно быть наложено.


Верификация правил

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки.

Ошибки правил отображаются в отдельном окне редактора документов, а документы с невыполненными правилами отмечены красными флажками.

При наличии невыполненных правил оператору надо проверить, как распознаны данные, если это ошибка распознавания – исправить ее, а если это ошибка заполнения, которую невозможно исправить, не экспортировать документ. Документы с ошибками можно проверить позже, сверяясь с бумажными документами или другими имеющимися источниками.

Для запуска повторной проверки ошибок правил нажмите на стрелку справа от кнопки Начать верификацию… и выберите пункт меню Перепроверить правила. Если правила выполняются после исправления значений полей, то флажки будут сняты.


Распределенная верификация

Распределенная верификация позволяет ограничить набор полей, требующих верификации. Вы можете указать набор данных как для этапа Верификации данных, так и для этапа Верификации. Для этого на закладке Набор данных диалога свойств соответствующей стадии выберите поля, которые должны обрабатываться на данном этапе.

Внимание! При этом, если ошибки содержатся в полях документа, не включенных в заданный набор, сообщение об ошибке выведено не будет.

Вы также можете создать пользовательский этап на основе этапа Верификация данных или Верификация и выбрать другой набор данных для созданного этапа. Правило, описывающее, на какой этап должен быть отправлен документ, настраивается с помощью скрипта. Таким образом, различные поля документа могут быть верифицированы на разных этапах.

Для этапа Верификации данных можно использовать опцию Скрывать изображение страницы вне выбранных полей. Если выбрана данная опция, оператору будут доступны только поля, включенные в заданный набор данных. Все остальные поля на изображении будут скрыты. Эту опцию рекомендуется использовать при необходимости обеспечить высокий уровень безопасности для документов.

Замечание. Если выбрана опция Скрывать изображение страницы вне выбранных полей, но при наложении Определения документа регион поля был определен неверно либо со смещением, может оказаться невозможным верифицировать поле. В этом случае оператор должен отправить изображение на этап Исключений.


Двойная верификация

Двойная верификация – это режим верификации, при котором проверка полей осуществляется двумя операторами.

Для того чтобы поле отправлялось на двойную верификацию:

  1. Отметьте в свойствах поля опцию Требуется двойная верификация.
  2. Отметьте опцию Двойная верификация на закладке Набор данных в диалоговом окне свойств этапа.

Слияние результатов верификации, полученных операторами, осуществляется на Сервере обработки. Если результаты совпадают, документ переходит на следующий этап. В случае несовпадения результатов первой и второй руки верификации, осуществляется проверка результирующей рукой.

Для двойной верификации могут быть использованы Web-станции верификации данных.


Экспорт распознанных данных

Экспорт документов осуществляется автоматически. Процесс обработки может включать в себя этап подтверждения экспорта старшим оператором верификации. Экспорт производится согласно настройкам определения документа, а при их отсутствии - согласно настройкам проекта. Если требуется экспортировать документы вне очереди, можно отправить их непосредственно в очередь на этапе экспорта.

Также при необходимости можно произвести экспорт в ручном режиме на Станции Верификации либо на Станции настройки проектов.

Экспорт данных в файл

  1. Для экспорта данных в файл выберите в контекстном меню документа пункт Экспортировать в>файлы данных…
  2. При необходимости изменить настройки экспорта нажмите в открывшемся диалоговом окне Экспорт в файл кнопку Настройки... и укажите параметры экспорта, после чего нажмите кнопку ОК.
  3. Для экспорта документа нажмите кнопку Экспорт.

Экспорт изображений в файл

  1. Для экспорта изображений в файл выберите в контекстном меню документа пункт Экспортировать в>файлы изображений…
  2. При необходимости изменить настройки экспорта нажмите в открывшемся диалоговом окне Экспорт в файлы изображений кнопку Настройки… и укажите параметры экспорта, после чего нажмите кнопку ОК.
  3. Для экспорта документа нажмите кнопку Экспорт.

Экспорт в базу данных

  1. Для экспорта данных в базу данных выберите в контекстном меню документа пункт Экспортировать в>Базу данных...
  2. Укажите настройки экспорта в диалоговом окне Экспорт в ODBC-совместимую базу данных.
  3. Для экспорта документа нажмите кнопку ОК.


Фоновый режим

Фоновые процессы

Этапы обработки, не требующие вмешательства человека, выполняются Сервером обработки автоматически. Однако существует возможность осуществлять их в ручном режиме на Станции Верификации или на Станции Настройки Проектов. В этом случае их можно выполнять в фоновом режиме.

Для того чтобы перевести задачу в фоновый режим, надо в открывшемся диалоге Добавление изображений… (Распознавание… или Экспорт…) нажать кнопку Фоновый режим.

Автоматически в фоновом режиме выполняются задачи:

  • Загрузки документов при использовании соответствующего профиля импорта.
  • Распознавания документов, если отмечена опция Автоматически распознавать добавленные изображения ( Сервис > Опции…, закладка Обработка документов).

При переходе в фоновый режим на панели задач появляется иконка [image], открывающая диалог Фоновые задачи, в котором отображается список задач.

  • Задачи выполняются в порядке их поступления или же в соответствии с расставленными пользователем приоритетами (кнопка Приоритет…).
  • Для контроля выполнения заданий и отслеживания ошибок ведется журнал, параметры которого можно настроить (Сервис > Опции…, закладка Выполнение задачи). Для просмотра надо нажать кнопку Журнал.
  • Прервать выполнение задачи можно кнопкой Снять задачу.

Программа также может информировать пользователя о ходе выполнения фоновых процессов при помощи всплывающей подсказки (в правом нижнем углу) - при старте, ошибке и завершении задач. См. Дополнительные настройки.


Интерфейс программы ABBYY FlexiCapture 10

Этот раздел содержит обзор основных элементов интерфейса программы ABBYY FlexiCapture 10: основных окон, меню и панелей инструментов.

Станция настройки проектов
Меню станции настройки проектов
Панели инструментов станции настройки проектов
Станция верификации
Меню станции верификации
Панели инструментов станции верификации
Станция верификации данных
Меню станции верификации данных
Панели инструментов станции верификации данных
Редактор определения документа
Меню редактора определения документа
Панели инструментов редактора определения документа
Окно групповой верификации
Меню
Панель инструментов
Окно контекстной верификации
Меню
Панель инструментов


Главное окно станции настройки проектов

В главном окне программы отображается список пакетов документов, входящих в состав проекта, с которым ведется работа.

Показать главное окно со списком пакетов

Чтобы увидеть содержимое пакета, откройте его двойным щелчком мыши. Вы увидите список документов, входящих в пакет.

Вернуться к списку пакетов можно, выбрав пункт меню Проект>Пакеты (или Тестовые пакеты при работе с тестовыми пакетами).

В верхней части окна располагается меню, под ним – инструментальные панели.

Остальное пространство Главного окна занимает рабочее окно Пакет со списком входящих в него документов.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Для проектов, хранящихся на сервере, можно настроить отображение пакетов с помощью фильтра. В выпадающем списке выберите, какие пакеты нужно показывать:

  • Все пакеты, за исключением обработанных
  • Пакеты на этапах… - в открывшемся диалоговом окне выберите нужную(-ые) стадию(-и)
  • Пакет с префиксом имени… - введите префикс имени пакета
  • Пакет с ID… - введите ID пакета
  • Пакет, содержащий документ с ID… - введите ID документа

По умолчанию, показываются все пакеты, кроме обработанных.

На одной странице может отображаться до 500 пакетов. Для перехода по страницам используйте стрелки справа.

Для проверки распознанных данных нужно открыть Окно документа. Для этого щелкните дважды по названию документа или одной из его страниц. Окно документа состоит из трех частей:

  • изображение страницы документа;
  • распознанные данные;
  • ошибки правил (эта часть отображается только при наличии ошибок правил).

При наведении курсора на поля, содержащие даты и числа, появляется всплывающая подсказка. Формат данных в тексте подсказки засисит от региональных настроек на компьютере, поэтому формат даты в самом поле и во всплывающей подсказке может отличаться. Также время заполнения формы, отображающееся в подсказке, показывается с учетом часового пояса.

Подробнее см. Верификация в окне документа

Показать окно документа

Меню станции настройки проектов
Панели инструментов станции настройки проектов


Меню станции настройки проектов

Файл
Пункт меню | Описание
Новый проект… | Позволяет создать новый проект
Открыть проект… | Позволяет открыть существующий проект
Открыть проект на сервере… | Позволяет открыть существующий проект на сервере приложений
Закрыть проект | Закрывает текущий проект
Сохранить | Сохраняет изменения
Новый пакет… | Создает новый пакет
Загрузить изображения… | Позволяет загрузить изображения из файлов
Сканировать изображения… | Позволяет добавить изображения путем сканирования
Импортировать изображения… | Позволяет импортировать изображения с использованием одного из настроенных профилей импорта
Экспортировать в |
файлы данных… | Позволяет экспортировать данные в файл
файлы изображений… | Позволяет экспортировать изображения в файлы
базу данных… | Позволяет экспортировать данные в базу данных
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCaptuer 10
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Объединить | Объединяет выделенные страницы в один документ
Разделить | Разделяет выделенный документ на страницы
Выделить все | Выделяет все
Найти… | Позволяет найти заданный текст
Найти следующий | Позволяет найти следующий ранее заданный текст
Перейти |
К следующему документу | Позволяет перейти к следующему документу в пакете
К предыдущему документу | Позволяет перейти к предыдущему документу в пакете
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Перевернуть горизонтально | Переворачивает изображение горизонтально (относительно вертикальной оси)
Перевернуть вертикально | Переворачивает изображение вертикально (относительно горизонтальной оси)
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Изменить разрешение… | Изменяет разрешение изображения
Сохранить как… | Позволяет сохранить изображение с указанным именем
Вид
Пункт меню | Описание
Тестовые пакеты | Открывает список тестовых пакетов
Пакеты | Открывает список пакетов
Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Настройка столбцов… | Позволяет настроить список столбцов, отображаемых в детализированном списке
Редактор документа |
Изображение | Показывает изображение страницы в окне документа
Данные | Показывает распознанные данные в окне документа
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения страниц документов
Размер текста данных | Позволяет выбрать размер шрифта для отображения распознанных данных
Показать панель инструментов | Позволяет показать/спрятать панель инструментов в окне документа. Эта панель инструментов позволяет исправить некоторые ошибки наложения, например, дорисовать не найденное поле, добавить или удалить разделитель таблицы. Такая возможность используется, в основном, при работе с гибкими описаниями.
Показать ошибки формата | Позволяет указать способ отображения ошибок формата
Отображать в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц документа в черно-белом режиме
Размер эскизов | Позволяет выбрать размер эскизов страниц
Панели инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Свойства… | Открывает диалог свойств документа или страницы
Распознавание
Пункт меню | Описание
Проанализировать | Анализирует страницы документов, подбирая для них подходящее определение
Наложить определение документа… | Производит наложение выбранного пользователем определения на выделенный документ или страницу
Распознать | Запускает процесс распознавания
Верификация
Пункт меню | Описание
Начать верификацию… | Запускает процесс верификации
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет переход к предыдущему объекту верификации
Следующий документ с ошибками сборки | Осуществляет переход к следующей ошибке сборки
Предыдущий документ с ошибками сборки | Осуществляет переход к предыдущей ошибке сборки
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Проект
Пункт меню | Описание
Определения документов… | Открывает диалог со списком определений документов, из которого осуществляются действия по работе с определениями: создание, редактирование, импорт, удаление (Этот пункт меню доступен только в режиме работы администратора)
Типы пакетов… | Открывает диалог со списком типов пакетов, из которого осуществляются действия по работе с типами: создание, редактирование, удаление (Этот пункт меню доступен только в режиме работы администратора)
Профили импорта изображений… | Открывает диалог со списком профилей импорта изображений, из которого осуществляются действия по работе с профилями импорта: создание нового профиля, копирование существующего, редактирование, удаление (Этот пункт меню доступен только в режиме работы администратора)
Защитить паролем… | Позволяет защитить паролем текущий проект (Этот пункт меню доступен только в режиме работы администратора)
Снять пароль… | Позволяет снять защиту паролем с проекта (Этот пункт меню доступен только в режиме работы администратора)
Экспортировать проект… | Экспортирует проект в указанную папку. При экспорте проекта изображения берутся из текущего пакета.
Обновление проекта… | Устанавливает обновление проекта. Сообщения и ошибки, возникающие при импорте, можно сохранять в файл (правая кнопка мыши - Экспортировать в файл).
Свойства проекта… | Открывает диалог свойств проекта
Сервис
Пункт меню | Описание
Обновить до последней версии | Применяет изменения в проекте к обрабатывающимся в данный момент документам
Повторный анализ | Производит повторный анализ документов
Повторное распознавание | Производит повторное распознавание документов
Обновить сборку | Обновляет сборку страниц в документы
Перепроверить правила | Производит повторную проверку правил
Проверить целостность пакета | Производит проверку целостности пакета
Изменить приоритет пакета | Позволяет выбрать приоритет пакета
Изменить тип пакета… | Изменяет тип пакета
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture 10 в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 10, содержащий краткую информацию о программе.


Панели инструментов станции настройки проектов

Стандартная панель инструментов

Название | Кнопка | Описание
Открыть проект |  | Позволяет открыть другой проект
Сохранить изменения |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Представления документов

Название | Кнопка | Описание
Детали |  | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц |  | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Список тестовых пакетов |  | Позволяет перейти к списку тестовых пакетов
Список рабочих пакетов |  | Позволяет перейти к списку рабочих пакетов
Обновить |  | Обновляет информацию в главном окне
Навигация

Название | Кнопка | Описание
Предыдущий объект верификации |  | Осуществляет переход к предыдущему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Следующий объект верификации |  | Осуществляет переход к следующему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Предыдущий документ |  | Осуществляет переход к предыдущему документу.
Следующий документ |  | Осуществляет переход к следующему документу.
Настройки проекта

Название | Кнопка | Описание
Определения документов… |  | Открывает окно со списком определений документов, входящих в проект.
Типы пакетов… |  | Открывает окно со списком типов пакетов, входящих в проект.
Свойства проекта… |  | Открывает окно свойств проекта.
Показать профили импорта изображений |  | Открывает окно со списком профилей импорта изображений, входящих в проект.
Загрузить проект на сервер… |  | Открывает окно загрузки проекта на сервер приложений.


Главное окно станции верификации

В главном окне программы отображается список очередей, из которых выбираются задания для обработки.

Оператору верификации и Старшему оператору верификации доступно для обработки несколько очередей с заданиями (назначение очередей см. в статье Станция Верификации).

Показать главное окно со списком очередей

В окне заданий доступна следующая информация:

Число всех заданий – общее количество заданий данной очереди, автоматических и сформированных операторами, находящихся в обработке в текущий момент времени.

Максимальный приоритет – наивысший приоритет, присвоенный одному или нескольким заданиям данной очереди.

Персональных заданий – количество заданий, переданных на обработку данному оператору.

Число документов вне обработки – количество документов, которое требуется обработать в составе заданий, сформированных программой автоматически.

Число сформированных заданий – количество заданий, сформированных вручную операторами, например, при принудительной отправке в данную очередь документов в качестве отдельного задания (с использованием опции Сформировать задание в диалоге отправки).

Число пакетов вне обработки – количество пакетов, отправленных оператором вручную в данную очередь, без формирования отдельного задания.

После получения задания в окне отображается список документов задания.

Показать главное окно со списком документов

В верхней части окна располагается меню, под ним – инструментальные панели.

Остальное пространство Главного окна занимает рабочее окно со списком очередей или документов.

В режиме просмотра пакетов выводится следующая информация о пакетах проекта: число документов и страниц в пакете, приоритет, число распознанных, верифицированных и проэкспортированных символов и т.д. Для проектов, хранящихся на сервере, можно настроить отображение пакетов с помощью фильтра. В выпадающем списке выберите, какие пакеты нужно показывать:

  • Все пакеты, за исключением обработанных
  • Пакеты на этапах… - в открывшемся диалоговом окне выберите нужную(-ые) стадию(-и)
  • Пакет с префиксом имени… - введите префикс имени пакета
  • Пакет с ID… - введите ID пакета
  • Пакет, содержащий документ с ID… - введите ID документа

По умолчанию, показываются все пакеты, кроме обработанных.

На одной странице может отображаться до 500 пакетов. Для перехода по страницам используйте стрелки справа.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Меню станции верификации
Панели инструментов станции верификации


Меню станции верификации

Файл
Пункт меню | Описание
Открыть проект на сервере… | Позволяет открыть существующий проект на сервере приложений
Закрыть проект | Закрывает текущий проект
Сохранить | Сохраняет изменения на сервере
Загрузить изображения… | Позволяет загрузить изображения из файлов
Сканировать изображения… | Позволяет добавить изображения путем сканирования
Экспортировать в |
файлы данных… | Позволяет экспортировать данные в файл
файлы изображений… | Позволяет экспортировать изображения в файлы
базу данных… | Позволяет экспортировать данные в базу данных
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCaptuer 10
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Объединить | Объединяет выделенные страницы в один документ
Разделить | Разделяет выделенный документ на страницы
Выделить все | Выделяет все
Найти… | Позволяет найти заданный текст
Найти следующий | Позволяет найти следующий ранее заданный текст
Перейти |
К следующему документу | Позволяет перейти к следующему документу в пакете
К предыдущему документу | Позволяет перейти к предыдущему документу в пакете
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Перевернуть горизонтально | Переворачивает изображение горизонтально (относительно вертикальной оси)
Перевернуть вертикально | Переворачивает изображение вертикально (относительно горизонтальной оси)
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Изменить разрешение… | Изменяет разрешение изображения
Сохранить как… | Позволяет сохранить изображение с указанным именем
Вид
Пункт меню | Описание
Пакеты | Открывает список пакетов
Очереди | Открывает список очередей
Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Настройка столбцов… | Позволяет настроить список столбцов, отображаемых в детализированном списке
Редактор документа |
Изображение | Показывает изображение страницы в окне документа
Данные | Показывает распознанные данные в окне документа
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения страниц документов
Размер текста данных | Позволяет выбрать размер шрифта для отображения распознанных данных
Показать панель инструментов | Позволяет показать/спрятать панель инструментов в окне документа. Эта панель инструментов позволяет исправить некоторые ошибки наложения, например, дорисовать не найденное поле, добавить или удалить разделитель таблицы. Такая возможность используется, в основном, при работе с гибкими описаниями.
Показать ошибки формата | Позволяет указать способ отображения ошибок формата
Отображать в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц документа в черно-белом режиме
Размер эскизов | Позволяет выбрать размер эскизов страниц
Панели инструментов | Позволяет отобразить/спрятать панели инструментов
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Распознавание
Пункт меню | Описание
Проанализировать | Анализирует страницы документов, подбирая для них подходящее определение
Наложить определение документа… | Производит наложение выбранного пользователем определения на выделенный документ или страницу
Распознать | Запускает процесс распознавания
Задания
Пункт меню | Описание
Получить задание | Получает задание из выбранной очереди
Закрыть задание | Закрывает текущее задание и возвращает его на сервер приложений как выполненное
Показывать комментарий к заданию | Позволяет показывать комментарий к заданию
Отменить задание | Отменяет текущее задание и возвращает его на сервер приложений
Отложить задание… | Откладывает текущее задание для последующей обработки
Отправить задание в Исключения... (для старшего оператора верификации - Отправить задание на этап обработки...) | Отправляет текущее задание в Исключения (старший оператор верификации имеет возможность отправить задание на любой этап обработки
Получать задания автоматически | Включает/выключает режим автоматического получения заданий
Отправить документы в Исключение... | Отправляет выбранные документы в новое Исключение
Добавить документы в Исключение... | Добавляет выбранные документы к имеющемуся Исключению
Удалить документы из Исключения | Удаляет документы из Исключения
Просмотреть список Исключений... | Позволяет просмотреть список Исключений
Редактировать пакет | Команда доступна, если хотя бы один документ пакета принадлежит заданию. Если все документы принадлежат одному заданию, открывает это задание. Если документы принадлежат разным пакетам, создает задание для пакета на этапе Исключений.
Редактировать документ | Команда доступна, если хотя бы один из выделенных документов принадлежит заданию. Если выделенные документы принадлежат одному заданию, открывает это задание. Если документы принадлежат разным заданиям, выполняет редактирование всего пакета и создает задание для этого пакета на этапе Исключений.
Верификация
Пункт меню | Описание
Начать верификацию… | Запускает процесс верификации
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет переход к предыдущему объекту верификации
Следующий документ с ошибками сборки | Осуществляет переход к следующей ошибке сборки
Предыдущий документ с ошибками сборки | Осуществляет переход к предыдущей ошибке сборки
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Сервис
Пункт меню | Описание
Обновить до последней версии | Применяет изменения в проекте к обрабатывающимся в данный момент документам
Повторный анализ | Производит повторный анализ документов
Повторное распознавание | Производит повторное распознавание документов
Обновить сборку | Обновляет сборку страниц в документы
Перепроверить правила | Производит повторную проверку правил
Проверить целостность пакета | Производит проверку целостности пакета
Изменить приоритет пакета | Позволяет выбрать приоритет пакета
Изменить тип пакета… | Изменяет тип пакета
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture 10 в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 10, содержащий краткую информацию о программе.


Панели инструментов станции верификации

Стандартная панель инструментов

Название | Кнопка | Описание
Открыть проект |  | Позволяет открыть другой проект
Сохранить изменения |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Представления документов

Название | Кнопка | Описание
Детали |  | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц |  | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Список тестовых пакетов |  | Позволяет перейти к списку тестовых пакетов
Список рабочих пакетов |  | Позволяет перейти к списку рабочих пакетов
Обновить |  | Обновляет информацию в главном окне
Навигация

Название | Кнопка | Описание
Предыдущий объект верификации |  | Осуществляет переход к предыдущему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Следующий объект верификации |  | Осуществляет переход к следующему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Предыдущий документ |  | Осуществляет переход к предыдущему документу.
Следующий документ |  | Осуществляет переход к следующему документу.
Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание из выбранной очереди.
Закрыть задание |  | Возвращает задание на сервер.
Пометить документы для отправки в исключения |  | Помечает задание для отправки в исключения (для старшего оператора верификации - на выбранный этап обработки). При закрытии или отмене задания, программа предлагает отправить отмеченные документы в исключения.
Пометить документы для отправки на повторное сканирование |  | Помечает документ для отправки на повторное сканирование. При закрытии или отмене задания, программа предлагает отправить отмеченные документы на повторное сканирование.
Снять отметку |  | Снимает отметку с выделенного документа, отмеченного для отправки.
Отложить задание… |  | Откладывает задание для обработки позднее.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Главное окно станции верификации данных

В главном окне программы отображается наименование очереди, из которой берутся задания (очереди верификации данных).

После получения задания в окне последовательно открываются окна групповой и контекстной верификации.

В верхней части окна располагается меню, под ним – инструментальные панели.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Меню станции верификации данных
Панели инструментов станции верификации данных


Меню станции верификации данных

Файл
Пункт меню | Описание
Открыть проект на сервере… | Позволяет открыть существующий проект на сервере приложений
Закрыть проект | Закрывает текущий проект
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCapture 10
Вид
Пункт меню | Описание
Панели инструментов | Позволяет отобразить/спрятать панели инструментов
Строка состояния | Позволяет отобразить/спрятать строку состояния
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Обновить | Обновляет отображаемую информацию
Задания
Пункт меню | Описание
Получить задание | Получает задание из выбранной очереди
Показывать комментарий к заданию | Позволяет показывать комментарий к заданию
Отменить задание | Отменяет текущее задание и возвращает его на сервер приложений
Отправить задание в Исключения… | Отправляет текущее задание в Исключения
Получать задания автоматически | Включает/выключает режим автоматического получения заданий
Сервис
Пункт меню | Описание
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
Техническая поддержка | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY | Открывает страницу Как купить программу ABBYY FlexiCapture 10 в справке программы
Web-сайт ABBYY | Открывает Web-страницу компании ABBYY
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 10, содержащий краткую информацию о программе.


Панели инструментов станции верификации данных

Очереди и задания

Название | Кнопка | Описание
Получить задание |  | Открывает задание из выбранной очереди.
Отправить задание в Исключения… |  | Отправляет задание в Исключения.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию в главном окне
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Окно редактора определения документа

Основные действия по созданию и редактированию определения документа производятся в окне редактора определения документа.

Чтобы открыть редактор определения документа из главного окна программы, нужно:

  1. Выбрать пункт меню Проект>Определения документов…;
  2. В диалоге Определения документов выделить название определения документа и нажать кнопку Правка….

Окно редактора определения документа также открывается после завершения работы мастера создания определения документа.

Показать окно редактора определения документа

Окно редактора определения документа состоит из трех частей:

  1. Слева сверху расположено изображение страницы с разметкой полей и статических элементов.

    Для работы с полями и статическими элементами предусмотрено два режима:

    • режим разметки полей – включается по кнопке [image];
    • режим статических элементов – включается по кнопке [image].
  2. Слева внизу находится редактор для настройки отображения распознанных данных.
  3. В правой части отображается структура документа со списком всех полей определения документа (закладка Поля). Также можно переключиться в режим просмотра эскизов страниц (закладка Страницы).

Меню редактора определения документа
Панели инструментов редактора определения документа


Меню редактора определения документа

Определение документа
Пункт меню | Описание
Добавить страницу… | Позволяет добавить в определение документа изображение новой страницы
Добавить раздел документа… | Позволяет добавить в определение документа новый раздел
Импортировать секцию документа… | Импортирует выбранные разделы документа
Скриптовые модули |
Правила… | Открывает Редактор кода скрипта - Модуль для правил. Подробнее о скриптовых модулях см. Использование скриптов во FlexiCapture 10.
Экспорт… | Открывает Редактор кода скрипта - Модуль для экспорта. Подробнее о скриптовых модулях см. Использование скриптов во FlexiCapture 10.
Настройки экспорта… | Открывает диалог Настройки экспорта для настройки параметров экспорта данных
Свойства определения документа… | Открывает диалог для просмотра и редактирования свойств определения документа
Сохранить | Сохраняет изменения
Закрыть | Закрывает редактор определения документа
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Удалить область | Удаляет области на изображении выделенных объектов
Выделить все | Выделяет все
Выделить по типу… | Позволяет выделить объекты определенного типа
Создать поле |
Текст | Добавляет текстовое поле ввода в структуру документа (без разметки на изображении)
Метка | Добавляет поле метки в структуру документа (без разметки на изображении)
Группа меток | Добавляет поле группы меток в структуру документа (без разметки на изображении)
Штрих-код | Добавляет поле штрих-кода в структуру документа (без разметки на изображении)
Картинка | Добавляет поле картинки в структуру документа (без разметки на изображении)
Таблица | Добавляет поле таблицы в структуру документа (без разметки на изображении)
Группа | Добавляет группу полей в структуру документа (без разметки на изображении)
Сгруппировать | Позволяет сгруппировать выделенные объекты
Разгруппировать | Позволяет разгруппировать выделенные объекты
Копировать текст с изображения… | Позволяет получить текст из любой области изображения и записать его в буфер обмена. После выбора команды меню нужно выделить мышью область, откуда будет взят текст.
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Изменить разрешение… | Открывает диалог Установить разрешение, в котором можно указать новое разрешение изображения
Сохранить как… | Позволяет сохранить изображение страницы документа в указанном файле
Заменить… | Позволяет произвести замену изображения страницы документа
Вид
Пункт меню | Описание
Разметка изображения |
Статические элементы | Переключает в режим статических элементов
Области полей | Переключает в режим разметки полей
Структура документа |
Показать структуру документа | Отображает/прячет окно структуры документа
Поля | Переключает окно структуры документа в режим отображения полей
Страницы | Переключает окно структуры документа в режим отображения страниц
Форма данных | Отображает/прячет окно редактора данных
Панель инструментов окна разметки |
Горизонтальная | Размещает горизонтально панель инструментов окна разметки изображения
Вертикальная | Размещает вертикально панель инструментов окна разметки изображения
Строка состояния | Отображает/прячет строку состояния
Показывать изображение в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц в черно-белом режиме
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения
Свойства… | Открывает диалог для просмотра и редактирования свойств выделенного объекта
Тестирование
Пункт меню | Описание
Начать тестирование | Позволяет начать тестирование определения документа на изображении документа
Закончить тестирование | Закрывает режим тестирования
Режим изображения | Показывает изображение страницы в окне документа
Режим данных | Показывает распознанные данные в окне документа
Вид |
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Сверху | Располагает окно изображения в верхней части окна
Снизу | Располагает окно изображения в нижней части окна
Слева | Располагает окно изображения в левой части окна
Справа | Располагает окно изображения в правой части окна
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Сверху | Располагает окно ошибок в верхней части окна
Снизу | Располагает окно ошибок в нижней части окна
Слева | Располагает окно ошибок в левой части окна
Справа | Располагает окно ошибок в правой части окна
Панель инструментов | Позволяет отобразить/спрятать панель инструментов в режиме данных. В режиме изображения панель инструментов отображается всегда
Верификация |
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет предыдущему к следующему объекту верификации
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Пакет
Пункт меню | Описаниее
Режим тестовых пакетов… | Позволяет использовать тестовые пакеты для тестирования определения документа
Закрыть тестовый пакет… | Закрывает тестовый пакет
Обзор |
Детали | Переключает в режим Детали
Эскизы страниц | Переключает в режим Эскизы страниц
Настроить таблицу документов… | Открывает диалог Выбор колонок, где вы можете выбрать столбцы, которые будут отображаться, и настроить их вид
Загрузить изображения… | Открывает диалог Load Images, где вы можете выбрать изображения, которые требуется загрузить, и указать опции предобработки изображений
Сканировать изображения… | Открывает диалог сканирования изображений для добавления в пакет
Распознать | Распознает изображения пакета
Начать верификацию… | Запускает верификацию изображений пакета
Экспортировать | Экспортирует пакет
Экспортировать в |
файлы данных… | Открывает диалог, где вы можете указать параметры экспорта данных
файлы изображений… | Открывает диалог, где вы можете указать параметры экспорта изображений
базу данных… | Открывает диалог настройки соединения с базой данных
Сервис
Пункт меню | Описание
Найти объекты на изображении… | Позволяет автоматически найти и выделить на изображении поля или статические элементы определенного типа (в зависимости от режима)
Проверить определение документа | Производит проверку определения документа
Наложить раздел | Производит проверку наложения раздела определения документа
Обновить гибкие описания… | Позволяет обновить используемое гибкое описание
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
Отправить отзыв… | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.


Панели инструментов редактора определения документа

Стандартная панель инструментов

Название | Кнопка | Описание
Сохранить |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Проверить определение документа |  | Позволяет произвести проверку определения документа. Результаты проверки отображаются в нижней части окна редактора определения документа
Панель инструментов окна разметки изображения

Панель инструментов окна разметки изображения используется для создания статических элементов и полей определения документа. Набор кнопок на панели инструментов меняется в зависимости от выбранного режима.

В режиме статических элементов:

В режиме разметки полей:

Данная панель инструментов может располагаться горизонтально или вертикально. Изменить ориентацию панели инструментов можно, воспользовавшись пунктом меню Вид>Панель инструментов окна разметки.
Название | Кнопка | Описание
Общие
Режим статических элементов |  | Переключает в режим статических элементов
Режим разметки полей |  | Переключает в режим разметки полей
Масштаб |  | Позволяет увеличить масштаб изображения
Автоматический поиск объектов |  | Позволяет автоматически найти и выделить объекты на изображении. Выберите этот инструмент, а затем щелкните левой кнопкой мыши в области объекта.
Выделить область |  | Позволяет выделять области объектов, уже размеченных на изображении. Для выделения области выберите этот инструмент и щелкните левой кнопкой мыши в области объекта.
В режиме статических элементов
Создать репер |  | Позволяет создать репер. Выберите этот инструмент, а затем с помощью мыши обведите репер прямоугольником.
Создать разделитель |  | Позволяет создать разделитель. Выберите этот инструмент, а затем с помощью мыши обведите разделитель прямоугольником.
Создать реперный текст |  | Позволяет создать реперный текст. Выберите этот инструмент, а затем с помощью мыши обведите текст прямоугольником.
Создать реперный штрих-код |  | Позволяет создать реперный штрих-код. Выберите этот инструмент, а затем с помощью мыши обведите штрих-код прямоугольником.
В режиме разметки полей
Создать текстовое поле |  | Позволяет создать текстовое поле ввода. Выберите этот инструмент, а затем с помощью мыши обведите область для ввода текста прямоугольником.
Создать метку |  | Позволяет создать поле метки. Выберите этот инструмент, а затем с помощью мыши обведите область метки прямоугольником.
Создать группу меток |  | Позволяет создать группу меток. Выберите этот инструмент, а затем с помощью мыши обведите прямоугольником метки, которые должны входить в группу.
Создать штрих-код |  | Позволяет создать поле Штрих-код. Выберите этот инструмент, а затем с помощью мыши обведите штрих-код прямоугольником.
Создать картинку |  | Позволяет создать поле Картинка. Выберите этот инструмент, а затем с помощью мыши обведите картинку прямоугольником.
Создать таблицу |  | Позволяет создать поле Таблица. Выберите этот инструмент, а затем с помощью мыши обведите таблицу прямоугольником. На панели инструментов появятся дополнительные кнопки для разметки таблиц.
Создать группу |  | Позволяет создать группу полей. Выберите этот инструмент, а затем с помощью мыши обведите прямоугольником поля, которые будут входить в группу.
Создать область для поля без разметки |  | Позволяет создать область для поля, которое есть в структуре документа, но не имеет области на изображении. Выберите этот инструмент, а затем с помощью мыши обведите область поля прямоугольником. Выберите название из выпадающего списка. (Список состоит из названий полей, не имеющих области на изображении).
Создать нераспознаваемую область |  | Позволяет выделить область, которая будет исключена из распознавания.
Кнопки для разметки таблиц Отображаются, если в данном разделе определения документа создана хотя бы одна таблица
Удалить разделитель |  | Позволяет удалить разделитель


Окно групповой верификации

Окно групповой верификации появляется при запуске процесса групповой верификации.

Это окно предназначено для визуальной проверки символов, распознанных с одинаковым значением. Одинаково распознанные символы выводятся на экран, чтобы можно было легко заметить и исправить выбивающиеся из общей массы символы. См. Групповая верификация.

Меню окна групповой верификации
Панель инструментов окна групповой верификации


Меню окна групповой верификации

Очереди и задания (данный пункт меню доступен на станции верификации данных)
Пункт меню | Описание
Получить задание | Получить новое задание на верификацию данных
Отправить задание в Исключения… | Отправить текущее задание в Исключения
Отменить задание | Отменить текущее задание (в дальнейшем оно вновь будет направлено оператору)
Обновить | Обновить информацию о заданиях
Верификация
Пункт меню | Описание
Подтвердить все | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Отложить все | Откладывает верификацию всех символов, помечая их знаком вопроса как сомнительные
Изменить статус | Откладывает верификацию выделенного символа, помечая его знаком вопроса как сомнительный символ
Следующая страница | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Предыдущая страница | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Закрыть | Закрывает окно верификации
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Выделить все | Выделяет все символы
Вид
Пункт меню | Описание
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификации
Снизу | Размещает изображение поля в нижней части окна верификации
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Показывать изображение поля | Позволяет показать изображение символа
Панель инструментов | Позволяет показать/спрятать панели инструментов
Панели информации | Позволяет показать/спрятать панель информации
Строка состояния | Позволяет показать/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Сервис
Пункт меню | Описание
Опции… | Позволяет настроить вид окрестности символа
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 10, содержащий краткую информацию о программе.


Панели инструментов окна групповой верификации

Стандартная панель инструментов

Название | Кнопка | Описание
Предыдущая страница |  | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Следующая страница |  | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Подтвердить все |  | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Изменить статус символа |  | Изменяет статус символа на отклоненный и обратно
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Очереди и задания (панель доступна только на станции верификации данных)

Название | Кнопка | Описание
Получить задание |  | Открывает задание на верификацию данных.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию о заданиях
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Окно контекстной верификации

Окно контекстной верификации появляется при начале контекстной верификации.

Это окно предназначено для визуальной проверки неуверенно распознанных символов в контексте всего поля. См. Контекстная верификация.

Меню окна контекстной верификации
Панель инструментов окна контекстной верификации


Меню окна контекстной верификации

Очереди и задания (данный пункт меню доступен на станции верификации данных)
Пункт меню | Описание
Получить задание | Получить новое задание на верификацию данных
Отправить задание в Исключения… | Отправить текущее задание в Исключения
Отменить задание | Отменить текущее задание (в дальнейшем оно вновь будет направлено оператору)
Обновить | Обновить информацию о заданиях
Верификация
Пункт меню | Описание
Подтвердить поле | Подтверждает поле
Отложить поле | Откладывает проверку поля
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующее поле | Позволяет перейти к следующему полю
Предыдущее поле | Позволяет перейти к предыдущему полю
Закрыть | Закрывает окно верификации
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Удалить все | Удаляет все объекты
Выделить все | Выделяет все
Вставить перенос строки | Вставляет перенос строки
Объединить символы | Позволяет объединить выделенные символы, если в процессе распознавания какой-либо символ был некорректно разбит на несколько символов
Вид
Пункт меню | Описание
Данные поля |
Показывать распознанный текст | Показывает/прячет распознанный текст
Нарезка изображений символов | Переходит в режим показа поля с нарезкой символов
Показывать специальные символы | Показывает/прячет специальные символы
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификации
Снизу | Размещает изображение поля в нижней части окна верификации
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Аналогичные поля | Позволяет показать/спрятать аналогичные поля в других документах
Показать изображение символа | Позволяет отобразить/спрятать изображение символа
Панель инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Панель информации | Позволяет отобразить/спрятать панель информации
Строка состояния | Позволяет отобразить/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Сервис
Пункт меню | Описание
Опции… | Позволяет настроить вид окна верификации: вид окрестности символа, шрифт и цвет текста
Справка
Пункт меню | Описание
Вызов справки | Открывает справку программы ABBYY FlexiCapture 10
О программе ABBYY FlexiCapture | Открывает диалог О программе ABBYY FlexiCapture 10, содержащий краткую информацию о программе.


Панели инструментов окна контекстной верификации

Стандартная панель инструментов

Название | Кнопка | Описание
Предыдущее поле |  | Позволяет перейти к предыдущему полю
Следующее поле |  | Позволяет перейти к следующему полю
Подтвердить/Пропустить поле |  | Позволяет подтвердить корректное распознавание всех символов поля и осуществляет переход к следующему полю. Если значение поля не удовлетворяет формату поля, то название кнопки меняется на Пропустить поле. Если значение поля нельзя исправить, то его проверку можно только отложить, или пропустить.
Отложить поле |  | Позволяет отложить проверку поля, если его невозможно исправить
Предыдущий неуверенно распознанный символ |  | Позволяет перейти к предыдущему неуверенно распознанному символу
Следующий неуверенно распознанный символ |  | Позволяет перейти к следующему неуверенно распознанному символу
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Очереди и задания(панель доступна только на станции верификации данных)

Название | Кнопка | Описание
Получить задание |  | Открывает задание на верификацию данных.
Отменить задание |  | Отменяет задание. В дальнейшем сервер направит задание другому оператору.
Обновить |  | Обновляет информацию о заданиях
Получать задания автоматически |  | Включает/выключает режим автоматического получения заданий.


Окно редактора кода скрипта

Редактор кода скрипта служит для написания и редактирования скриптов.

Вы можете выбрать язык скрипта: VBScript, JScript.Compact, JScript, C#.Net, VisualBasic.Net или JScript.Net.

Для редактирования кода используйте команды меню или кнопки на панели редактора кода скрипта.

Для проверки написанного кода:

  • нажмите Проверка на панели
  • или выберите команду Проверить скрипт в меню Сервис
  • или нажмите F9

Для добавления пользовательской функции выберите доступный глобальный модуль в выпадающем списке на панели инструментов: Модуль для правил, Модуль для экспорта, Events или NonInteractiveProcessor.

Чтобы закрыть редактор кода скрипта, выберите Файл > Выход или нажмите на кнопку закрытия окна в правом верхнем углу.

Более подробную информацию о скриптах в ABBYY FlexiCapture вы можете найти в разделе Использование скриптов.


Приложения

Использование скриптов в ABBYY FlexiCapture 10
Руководство по созданию машиночитаемых форм
Горячие клавиши
Различия в правилах FormReader 6.5 и FlexiCapture 10
Поддерживаемые языки распознавания
Шрифты для корректного отображения символов
Поддерживаемые типы текста
Поддерживаемые типы штрих-кодов
Поддерживаемые графические форматы
Форматы файлов экспорта
Алфавит, используемый в регулярных выражениях
Патенты
Технологии других компаний


Использование скриптов в ABBYY FlexiCapture 10

В данном разделе описано использование скриптов для настройки стадий обработки и для настройки интерфейса станций в ABBYY FlexiCapture 10.

Поддерживаемые языки

ABBYY FlexiCapture 10 поддерживает написание скриптов на следующих языках: C#.Net, VisualBasic.Net, JScript.Net, JScript®, JScript.Compact и VBScript.

Особенности .Net скриптов

Особенности использования

В языке VBScript нулевой параметр передается с ключевым словом "Me", в языке JScript для передачи нулевого параметра используется ключевое слово "this". В .Net скриптах нулевой параметр передается как как обычный парамерт.

Для каждого типа скрипта заведомо известны права на все параметры скрипта. Эти права определяют подмножество методов, доступных из скриптов. При обращении к методам объектов права на возвращаемые объекты всегда наследуются из исходного объекта, за некоторыми исключениями, описанными в комментарии к соответстующим методам.

Замечание. Объекты скрипта не должны использоваться после завершения скрипта, так как в этом случае поведение объекта становится неопределенным.

Замечание. Для отладки скриптов, написанных в редакторе скрипта в ABBYY FlexiCapture, можно использовать метод MessageBox.

Пользовательские функции

Редактор скрипта позволяет создавать собственные функции и процедуры и вызывать их в дальнейшем из кода скрипта.

Пользовательские функции и процедуры следует записать в глобальный модуль. Этот модуль доступен из редактора скрипта, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать доступный глобальный модуль: Модуль для правил, Модуль для экспорта, Events или NonInteractiveProcessor.

Все функции внутри одного модуля должны быть написаны на одном языке. Основной код скрипта может быть написан на языке, отличном от используемого в соответствующем глобальном модуле.

Из скриптовых языков JScript®, JScript.Compact и VBScript можно вызвать глобальную функцию, написанную на каком-либо из этих языков. Например, можно из кода правила на VBScript вызывать функцию из глобального модуля, написанного на JScript.

Из скриптов, написанных на языках .Net, можно вызывать глобальные функции, также написанные на языках .Net (C#.Net, VisualBasic.Net или JScript.Net).

Для обращения к функциям глобальных модулей нужно использовать префиксы Rules, Export, Events и NonInteractiveProcessor соответственно. Например, функция DoSomething из модуля Модуль для правил вызывается следующим образом: Rules.DoSomething ().

Замечание. Для скриптов на языках .Net вызов функций глобальных модулей осуществляется без использования префикса.

Таймаут на выполнение скрипта

По умолчанию заданы следующие таймауты – 10 секунд для скриптов правил и 1 минута для скриптов экспорта.

Для изменения значения таймаута необходимо задать новое значение в следующей ветви реестра:

HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\10.0\Controller\ScriptSupport\DefaultScriptTimeout

Значение таймаута в реестре задается в миллисекундах. Если скрипт выполняется дольше, чем заданный таймаут, то его выполнение будет прервано и возникнет ошибка "Таймаут выполнения скрипта". Для скриптов, являющихся частью задачи импорт, распознавания, или экспорта, аналогичное сообщение будет записано в лог.

Важно! Таймаут на выполнение скрипта действует только для скриптов, написанных на языках JScript и VBScript.

Важно! Если скрипт выполняется под сервисом NetworkService, то для изменения значения таймаута нужно вносить изменения в ветвь реестра соответствующего профиля.

Объектная модель

Объектная модель совместима со скриптами, созданными в предыдущих версиях ABBYY FlexiCapture.

Подробнее об используемой объектной модели


Особенности .Net скриптов

Ниже описаны некоторые особенности .Net скриптов.

  • Параметры скриптов, передаваемые в обычные скрипты как "this", в .Net скрипты передаются в качестве обычных параметров. Например, в правилах, написанных на .Net, контекст правила передаётся как параметр с именем "Context".
  • Проект должен быть скомпилирован с среде Microsoft .Net Framework версия 3.5 (или более ранняя). Версию .Net Framework можно задать в свойствах проекта в Visual Studio.
  • В скриптах и глобальных модулях разрешается использовать внешние сборки. Можно использовать как стандартные, так и откомпилированные пользовательские сборки. Все классы из добавленных сборок будут доступны всем скриптам и глобальным модулям. Подробнее смотрите Внешние сборки.
  • После компиляции откомпилированные тела .Net скриптов хранятся там же, где они определены. Поэтому .Net скрипты могут занимать больше места, чем обычные скрипты.
  • Все объекты FlexiCapture описаны в виде COM, поэтому работа .Net скриптов может быть замедлена при частом обращении обращении к различным полям объектов FlexiCapture из-за managed-unmanaged перехода.
  • Объекты FlexiCapture не поддерживают многопоточность.
  • Для отладки .Net скриптов используется метод System.Diagnostics.Debugger.Break. Подробное описание метода можно найти на MSDN: http://msdn.microsoft.com/ru-ru/library/system.diagnostics.debugger.break.aspx.
  • При отладке .Net скриптов помимо сборки требуется также .pdb-файл с символьной информацией. PDB-файл имеет большой размер, и его не рекомендуется хранить вместе со скриптами в рабочем проекте. Однако перед компиляцией необходимо указывать, что скрипт должен компилироваться с отладочной информацией.
    Если используется MS Visual Studio 2010, то для отладки библиотек можно подсоединяться к процессу, в котором выполняет .Net-код. Подробнее об этом можно прочитать на сайте компании Microsoft.
  • Интерфейсы ControllerInterop находятся в сборке ControllerInterop.dll и принадлежат пространству имен ABBYY.FlexiCapture. Файл сборки ControllerInterop.dll хранится в корневой папке программы.
  • Интерфейсы ShellInterop находятся в сборке ShellInterop.dll и принадлежат пространству имен ABBYY.FlexiCapture.ClientUI. Файл сборки ShellInterop.dll хранится в корневой папке программы.
  • Все классы ABBYY FlexiCapture доступны .Net скриптам под их собственными именами как классы из пространства ABBYY.FlexiCapture и ABBYY.FlexiCapture.ClientUI. Например:

    ABBYY.FlexiCapture.IDocument document = Batch.Documents[i];

    ABBYY.FlexiCapture.ClientUI.IToolbars toolbars = TaskWindow.MainWindow.Toolbars;

  • Using-директивы могут использоваться в заголовке кода. При этом используется тот же синтакс, что и в языке программирования: using в языке C#.Net, Import в языке JScript.Net и Imports в языке VisualBasic.Net. Например:

    using System.Drawing;

    Image img = Image.FromFile( @"D:\2.png" );

    FCTools.ShowMessage( img.VerticalResolution.ToString(), false );

    Замечание. Такое использование Using-директив является особенностью скриптов FlexiCapture.

    Using-директивы также могут использоваться в глобальных модулях, например:

    using ABBYY.FlexiCapture;

    using ABBYY.FlexiCapture.ClientUI;

  • Функции глобальных модулей вызываются из .Net скриптов напрямую, без указания названия модуля.
  • Если функция имеет опциональные параметры и вы не хотите задавать конкретное значение опционального параметра, то в качестве опционального параметра необходимо передавать System.Type.Missing.

Замечание. Если скрипт выполняет не в интерактивном режиме (процессом FlexiEx.exe, а не FlexiCapture.exe), то по умолчанию кнопка Debug не отображается в окне "Поиск решений" (для скриптов, в которых установлен breakpoint). Для того чтобы отобразить кнопку, нажмите на иконку Центр поддержки на панели задач и отметьте опцию Настройка центра поддержки > Параметры отчетов о неполадках > Не проверять на наличие новых решений.


Внешние

Внешние сборки

В скриптах и глобальных модулях разрешается использовать внешние сборки. Можно использовать как стандартные, так и откомпилированные пользовательские сборки.

Подключение внешней сборки

Внешние сборки добавляются на закладке Сборки .Net в свойствах типа пакета, в свойствах проекта или в свойствах определения документа. Пример кода пользовательской сборки, содержащей пространство имен, класс и метод этого класса:

namespace TestNameSpace

{

public class Test

{

public void Show(string text)

{

// will show text by standard FlexiCapture means – static method void ShowMessage(string text, bool IsError) from static class FCTools ABBYY.FlexiCapture.FCTools.ShowMessage(text, false);

}

}

}

Для того чтобы классы и методы из добавленной сборки были доступны из скриптов-обработчиков событий, сборка должна быть добавлена на закладке Сборки .Net свойств типа пакета (для определенного типа пакета) или свойств проекта (для типа пакета Unknown).

Для следующих скриптов внешние сборки добавляются на закладке Сборки .Net свойств определения документа:

  • скрипт правила
  • скрипт автозамены
  • скрипт экспорта
  • пользовательский скрипт
  • скрипт сборки документа
  • скрипт пользовательского распознавания

Для добавления сборки нажмите Добавить…. В открывшемся диалоговом окне укажите тип: Стандартное имя сборки или Путь к прикрепленному файлу. В зависимости от выбранного типа введите стандартное имя сборки или укажите путь к файлу сборки.

Скрипт, использующий классы и методы из внешней сборки, должен содержать следующий код:

TestNameSpace.Test test = new TestNameSpace.Test(); // creates an object of Test class

test.Show(“hello world”); // calls void Show() method from Test class

Отладка .Net-сборки

Для отладки внешних сборок, помимо самой сборки, требуется также .pdb-файл с символьной информацией. Отладка возможна только для сборок, для которых загружена символьная информация. Этот файл имеет большой размер, поэтому загрузку символьной информации желательно отключать в рабочем проекте.

Ключи в реестре, контроллирующие загрузку симовольной информации:

В реестре можно задать следующие ключи, позволяющие подключать .pdb-файл с символьной информацией (можно задать один ключ или оба):

  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\10.0\Controller\ScriptSupport\ [LoadSymbolsFromOriginalPath]- определяет, нужно ли загружать pdb-файлы из той же папки, откуда загружена сборка (для загрузки файлов нужно установить значение ключа True);
  • HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\10.0\Controller\ScriptSupport\ [PDBSearchLocations] = <путь к папке с PDB-файлами> - служит для перечисления путей, по которым нужно искать pdb-файлы для сборок (пути должны быть перечислены через точку с запятой; при поиске загружается файл с символьной информацией (.pdb), имя которого совпадает с именем сборки).

В реестре ключи по умолчанию не создаются. Администратор при необходимости может добавить эти ключи в реестр пользователя.

Изменения в реестре вступают в силу после перезапуска программы.

Для отладки сборки нужно подключаться к managed-коду.


Объектная модель

Ниже описаны особенности используемой объектной модели.

Работа с коллекциями

Все коллекции в используемой объектной модели поддерживают следующие методы:

Название | Тип | Доступ | Описание
Count | int | Read only | Число элементов коллекции
Item( index : int ) | ItemInterface | Read only | Получение элемента коллекции с заданным индексом. Нумерация начинается с нуля.

Замечание: К методам коллекции можно обращаться без метода Item, используя вместо этого круглые или квадратные скобки в зависимости от выбранного языка скрипта. В языках JScript, VBScript и Visual Basic.Net используются круглые скобки, в языке C#.Net допустимо использование только квадратных скобкок, язык JScript.Net допускает использование как круглых, так и квадратных скобок.

Например, Items( 1 ).Text = "Hello" или Items[ 1 ].Text = "Hello"

Все коллекции могут использоваться в конструкциях типа for each.

Работа с повторяющимися полями и таблицами

Все поля документа, кроме таблиц, могут быть повторяющимися.

В структуре документа повторяющие поля представлены специальным полем-прототипом, имеющим ненулевую коллекцию Items.

Поле-прототип не имеет дочерних элементов и у него нет значения. Оно служит только для хранения множества повторений этого поля. Дочерние поля и/или значение поля присущи лишь повторениям поля, доступным через метод Items объекта IField.

Таблицы всегда имеют коллекцию Rows ( Items является ее синонимом). В этой коллекции содержатся строки таблицы, ячейки которых можно получить через метод Children строк объекта IField.

Формирование путей к полям

Методы Field, HasField и IndexedItemValue объекта IDocument используют в качестве параметра пути к полям на форме. Эти пути строятся по следующему принципу (в форме Бэкуса-Наура):

<Путь> ::= <Компонент_пути> | <Путь> "\" <Компонент_пути>

<Компонент_пути > ::= <Имя_поля> | <Имя_поля> "["<Номер повторения поля>"]"

Где Имя_поля – имена полей документов, как они заданы в определении документа, а Номер_повторения_поля – номер повторения повторяющегося поля (для таблиц это номер строки), начиная с нуля.

Путь может быть полным или относительным. Полные пути строятся, начиная с имени раздела документа, относительные – начиная с имени дочернего элемента в группе.

Например, обращение к третьей строке колонки "Total" в таблице "Table", расположенной в разделе "Section", записывается следующим образом:

"Section\Table[2]\Total"

Метод FullName объекта IField позволяет построить такое полное имя.


Использование скриптов для настройки стадий обработки

В данном разделе описано использование скриптов для написания собственных правил, экспорта и обработчиков событий в продукте ABBYY FlexiCapture 10.

Типы скриптов
Объекты
Примеры


Типы скриптов

Во FlexiCapture 10 вы можете создавать скрипты следующих типов:

Скрипт правила
Скрипт автозамены
Скрипт экспорта
Пользовательский скрипт
Скрипт сборки документа
Скрипт пользовательского распознавания
Правило этапа
Скрипты обработки
Обработчики событий

Посмотреть примеры скриптов вышеперечисленных типов вы можете в разделе Примеры скриптов.


Скрипт правила

Назначение

Правила на основе скриптов (ScriptRule) позволяют создавать произвольно сложные алгоритмы проверки и нормализации документа.

Скрипт правила настраивается на закладке Правила свойств определения документа.

Параметры

Имя | Тип | Права | Значение
Context | IRuleContext | В соответствии с настройками правила | Контекст правила

Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для правил. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Правила….

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

Также о настройке скрипта правила см. Правило, заданное с помощью скрипта.


Скрипт автозамены

Назначение

Позволяет преобразовывать строки, содержащиеся в полях, и осуществлять проверки формата, не зависящие от контекста.

Описывается на закладке Тип данных диалога свойств поля.

Параметры

Имя | Тип | Права | Значение
Value | IValue | Чтение/запись | Значение поля

Замечание. Если включена опция Производить замену только один раз после распознавания, то сообщение об ошибке формата, указанное в IValue.ErrorMessage, не показывается, так как такую ошибку нельзя будет исправить.
Если данная опция не отмечена, скрипт может выполняться несколько раз даже в пределах одного этапа.

Замечание. Скрипт вызывается при подтверждении поля на станции Верификации Данных. При подтверждении поля на Web-станции Верификации Данных вызов скрипта не происходит.

Если в скрипте используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Обработка введенного значения.


Скрипт экспорта

Назначение

Позволяет настраивать экспорт.

Скрипт экспорта добавляется на закладке Экспорт свойств определения документа.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только чтение | Экспортируемый документ
Processing | IProcessingCallback | Только чтение | Объект для записи информации в лог

Замечание: Информация о результатах экспорта должна записываться в поле Document.Action.

Процедуры, которые вы хотите использовать в нескольких скриптах экспорта, следует записать в глобальный модуль экспорта. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для экспорта. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Экспорт….

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

Подробнее о настройке скрипта экспорта см. Экспорт, описанный с помощью скрипта.


Пользовательский скрипт

Назначение

Действия, описанные в скрипте, выполняются при нажатии на кнопку в процессе верификации поля или в окне редактора документа.

Скрипт задается на закладке Пользовательский скрипт в диалоговом окне свойств поля.

Параметры

Имя | Тип | Права | Значение
Context | IRuleContext | В соответствии с настройками правила | Контекст правила

Если в скрипте или используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Пользовательский скрипт.


Скрипт сборки документа

Назначение

В этом скрипте пользователю передаётся массив документов, и пользователь должен определить, можно ли эти документы объединить в один.

Для этого пользователь генерирует ошибки сборки, которые будут в результирующем документе. Сборка осуществляется следующим образом: два документа объединятся в один, если в результирующем документе число ошибок сборки не больше, чем в любом из исходных.

Скрипт настраивается на закладке Сборка свойств определения документа. Чтобы открыть редактор скрипта, нажмите кнопку Правка скрипта сборки… под опцией Использовать пользовательские правила сборки.

Скрипт выполняется автоматически после распознавания, либо может быть вызван вручную для обновления сборки (для этого выберите команду Сервис > Обновить сборку). В первом случае в скрипт попадут также ошибки сборки, сгенерированные стандартной проверкой.

Параметры

Имя | Тип | Права | Значение
Documents | IDocuments | Только чтение | Множество документов, страницы которых объединяются
AssemblingErrors | IAssemblingErrors | Полные права | Результирующие ошибки сборки

Замечание. Для оптимизации работы сборки желательно не обращаться к внутренним данным документов (данным, недоступным из скриптов, имеющим доступ только к заголовкам документов и страниц), так как это приводит к полной загрузке документа и может стать причиной замедления работы. Если требуется обращение к полям документа, то по возможности следует пользоваться индексными полями.

Замечание. Ошибки сборки, содержащиеся в параметре скрипта AssemblingErrors, различаются в зависимости от того, каким из двух возможных способов был получен параметр:

  1. AssemblingErrors может передавать в скрипт в качестве одного из параметров. В этом случае он будет содержать ошибки сборки текущей проверки.
  2. В скрипт в качестве параметра также передаётся коллекция документов, для которых вызывается скрипт сборки. У каждого документа есть свои ошибки сборки, которые можно получить так: document.AssemblingErrors. В этом случае параметр AssemblingErrors будет содержать ошибки сборки последней проверки для данного документа.

Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для правил. Также глобальный модуль правил доступен из редактора определения документа, меню Определение документа>Скриптовые модули>Правила….

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Создание определений для многостраничных документов.


Скрипт пользовательского распознавания

С помощью этого скрипта вы можете определить свой алгоритм распознавания (или инициализации) полей, имеющих регионы.

Скрипт распознавания задается на закладке Распознавание диалога свойств поля.

Вызов скрипта происходит в момент инициализации значения поля из результатов распознавателя. На вход скрипту передаётся распознаваемая область изображения. Форма документа в этот момент не проинициализирована, потому доступ к полям документа запрещён (при этом регистрационные и другие параметры доступны).

Параметры

Имя | Тип | Права | Значение
Result IValue / ICheckmarkValue / ICheckmarkGroupValue Полные права. Доступ к параметру CharacterParams.NeedVerification запрещен. Флаг CharacterParams.IsSuspicious доступен на чтение/запись. Результирующее распознанное значение. В зависимости от типа поля скрипт будет получать параметры следующих типов:
  • IValue - для полей на основе текста
  • ICheckmarkValue - для меток
  • ICheckmarkGroupValue - для групп меток
FieldRegion | IFieldRegion | Только чтение, только заголовки документов и страниц (права применяются также к родительским объектам) | Регион, который нужно распознать

Если в скрипте используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств определения документа.

См. также Свойства распознавания текстового поля.


Правило этапа

Назначение

Используется для того, чтобы определить может ли документ быть отправлен на стадию. Применяется при настройке правил в Расширенном режиме процесса обработки.

Если во время работы скрипта происходит ошибка, документ будет отправлен на стадию исключений.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только чтение | Документ, для которого нужно принять решение о маршрутизации
Result | IRoutingRuleResult | Чтение/запись | Результат работы правила этапа

Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать NonInteractiveProcessor.

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств типа пакета (для определенного типа пакета) или свойств проекта (для типа пакета Unknown).


Скрипты обработки

Назначение

Скрипты обработки документа или пакета позволяют изменять структуру документа (пакета), указывать порядок разделов в документе или документов в пакете. Скрипты обработки можно добавить при создании пользовательской стадии в Расширенном режиме процесса обработки.

Оба скрипта служат для обработки множества документов и имеют возможность писать лог процесса обработки.

Скрипт обработки одного документа

Скрипту обработки одного документа подаются по очереди все документы, которые нужно обработать.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Полные права | Документ, который нужно обработать
Processing | IProcessingCallback | Полные права | Объект для записи в лог информации об обработке

Замечание. Если задача отменяется, то Processing Status принимает значение false (как и при использовании свойства IProcessingCallback.ReportError).

Скрипт обработки пакета

Скрипту обработки пакета передаётся пакет и множество документов в нём, которые нужно обрабатывать. Переход по документам осуществляется пользователем.

Преимущество этого типа скрипта в том, что в нем доступны методы, меняющие структуру пакета. С помощью данного скрипта можно перемещать и удалять документы и страницы.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение, только заголовки документов и страниц | Пакет
Documents | IDocuments | Полные права. Также можно менять структуру пакета для этих документов. | Документы, которые нужно обработать
Processing | IProcessingCallback | Полные права | Объект для записи в лог информации об обработке


Обработчики событий

Во FlexiCapture 10 можно создавать обработчики для событий пакета, событий документа и событий поля.

Обработчики событий хранятся в типе пакета и настраиваются на закладке Обработчики событий свойств типа пакета (для определенного типа пакета) или свойств проекта (для типа пакета Unknown).

Процедуры, которые вы хотите использовать в нескольких обработчиках, следует записать в глобальный модуль. Этот модуль доступен из редактора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Events.

Если в скрипте или в глобальном модуле используются классы и методы из внешней сборки, внешнюю сборку нужно подключить на закладке Сборки .Net свойств типа пакета (для определенного типа пакета) или свойств проекта (для типа пакета Unknown).

События пакета
После создания пакета
Перед удалением пакета
Перед изменением свойств пакета
После добавления страницы
Перед удалением страницы
После создания документа
Перед удалением документа
Перед перемещением страниц
После открытия пакета
Перед закрытием пакета
Проверка целостности пакета
События документа
Перед изменением свойств документа
После изменения состояния документа
После завершения экспорта
Перед наложением
События поля
Запрос верификации поля


Создание пакета

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-либо действия с пакетом, например, сохранить данные в регистрационные параметры пакета.

Когда вызывается

Вызывается сразу после добавления пакета в проект.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Доступны только заголовки документов и страниц пакета. Заголовки документа и страниц доступны только на чтение. | Вновь добавленный пакет


Удаление пакета

Назаначение

Обработчик этого события используется в том случае, если нужно удалить какие-либо данные, связанные с пакетом.

Когда вызывается

Вызывается непосредственно перед удалением пакета.

Замечание. При удалении пакета не происходит события удаления документов и страниц пакета.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Доступны только заголовки документов и страниц пакета. Заголовки документа доступны только на чтение. | Удаляемый пакет


Изменение свойств пакета

Назначение

Обработчик этого события можно использовать для осуществления форматирования некоторых свойств пакетов.

Свойства

  • Тип пакета (имя типа пакета)
  • Имя пакета
  • Описание пакета
  • Значение регистрационного параметра
  • Приоритет пакета. Задается строкой. Допустимые значения перечислены в описании объекта TProcessingPriority.

Когда вызывается

Вызывается перед изменением одного из свойств.

Замечание. Задать новое значения для свойства "тип пакета" с помощью данного сприпта нельзя.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Доступны только заголовки документов и страниц пакета. Заголовки документа доступны только на чтение. | Пакет, свойство которого изменяется.
PropertyModification | IPropertyModificationInfo | Полные права | Содержит информацию об изменяющемся свойстве. Позволяет подменять выставляемое значение.


Изменение состава пакета (Добавление/Удаление страниц или документов)

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-то действия с пакетом, документом, страницей в зависимости от нового изображения. Например, если ведется подсчет общего числа страниц, добавлявшихся в данный пакет, чтобы убедиться, что никакие страницы не были потеряны.

Когда вызывается

Вызывается непосредственно после добавления и перед удалением страниц или документов.

Замечание. При удалении документа не происходит события удаления страниц документа.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Доступны только заголовки докуметов и страниц пакета | Пакет, в котором происходит удаление/добавление страниц или документов
Document (или Page) | IDocument (или IPage) | Заголовки изменяемого документа (страницы) можно модифицировать. Документы (страницы) пакета, в том числе удаленный документ (страница), доступны только на чтение. | Удаляемый/добавляемый объект


Перемещение страниц

Замечание: Перемещение страниц может производиться в том числе в момент сборки.

Назначение

Обработчик этого события используется в том случае, если нужно произвести какие-то манипуляции с новым документом на основе исходных документов. Например, сохранить объединенные регистрационные параметры.

Если один документ полностью вливается в другой, то его страницы в массиве Pages идут подряд и в том же порядке, в котором они идут в документе.

Замечание: После объединения страниц форма целевого документа может измениться.

Когда вызывается

Вызывается непосредственно перед перемещением страниц из документа в документ.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Только заголовки документов и страниц | Пакет
TargetDocument | IDocument | Полные права | Документ, в который перемещаются страницы
InsertionPosition | int | Только чтение | Позиция в документе, куда перемещаются страницы
Pages | IPages | Только чтение | Массив перемещаемых страниц


Открытие/закрытие пакета

Когда вызывается

Вызывается после открытия пакета или перед закрытием пакета.

Параметры

Имя | Тип | Права | Значение
Batch | IBatch | Доступ только на чтение и только к заголовкам докуметов и страниц пакета. Заголовки документа доступны только на чтение. | Пакет


Проверка целостности пакета

Назначение

Проверяет состав пакета. Например, с помощью данного скрипта можно проверить наличие обязательных документов в пакете или сравнить количество документов, указанное на контрольной странице, с количеством обработанных документов.

Когда вызывается

Вызывается перед отправкой (если в настройках маршрутизации включена соответствующая опция) или по явной команде пользователя.

Параметры

Имя | Тип | Права | Значение
CheckResults | IBatchCheckResults | Только чтение, только заголовки документов и страниц | Объект, предоставляющий доступ к проверяемому пакету, а также служащий для выставления результатов проверки.


Изменение свойства документа

Назначение

Обработчик этого события можно использовать для осуществления форматирования некоторых свойств пакетов.

Свойства документа

  • Комментарий
  • Значение регистрационного параметра
  • ExternalID
  • Приоритет документа. Задается строкой. Допустимые значения указаны в описании объекта TProcessingPriority.

Когда вызывается

Вызывается перед изменением свойства документа.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только заголовки документов и страниц | Документ
PropertyModification | IPropertyModificationInfo | Полные права | Информация об изменяемом свойстве


Изменение состояния документа

Назначение

В любой момент состояние документа можно описать массивом флагов. Данное событие происходит каждый раз, когда это состояние меняется. На вход событие получает множество флагов, описывающее изменение в состоянии документа.

Флаги, определяющие состояние:

  • Предобработанность
  • Проанализированость
  • Распознаность
  • Имеет ли ошибки правил/ форматные ошибки
  • Собраность
  • Верифицирован
  • Проэкспортирован
  • Имеет ли форму

Когда вызывается

Вызывается при сохранении документа, если с момента чтения его состояние изменилось.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Полные права | Документ
ChangedStates | IScriptBinaryAttributes<TStateType> | Только чтение | Объект, содержащий информацию об изменении состояния документа


Скрипт после экспорта

В качестве входного параметра скрипт получает результаты экспорта.

Когда вызывается

Вызывается после завершения задания экспорта. Если для этапа экспорта отмечена опция Обрабатывать пакеты целиком, задание будет включать все документы пакета. Если опция не отмечена, количество документов в задании может варьироваться от одного документа до всех документов пакета. Скрипт вызывается независимо от того, успешно ли прошел экспорт. В этом основное отличие данного скрипта от события "Изменение состояния документа".

Если в текущей сессии экспорт документ не экспортировался в какую-либо цель, так как экспорт в эту цель прошёл ранее, то для соответствующих результатов параметр Applied будет иметь значение false.

Параметры

Name | Type | Access | Description
ExportResults | IDocumentsExportResults | Только чтение, только заголовки документов и страниц | Результаты экспорта во все цели для всех документов
Processing | IProcesingCallback | Полные права | Объект для хранения информации о процессе работы


Перед наложением определений документов

Назначение

С помощью этого события пользователь может управлять тем, какие разделы или определения документов будут накладываться на очередную страницу, а также задавать порядок их наложения.

С помощью данного скрипта можно отключить распознавание документов после наложения определений документа. Для этого нужно присвоить параметру IMatchingInfo.NeedRecognition значение false. Это может потребоваться, если значения полей будут вводиться вручную.

Возможно также пометить страницу как страницу-приложение без распознавания. Для этого нужно указать пустой список разделов и присвоить параметру IMatchingInfo.ForceMatch значение true.

Когда вызывается

Вызывается непосредственно перед тем, как накладывать разделы на очередную страницу.

Параметры

Имя | Тип | Права | Значение
Document | IDocument | Только чтение, только только заголовки документов и страниц | Документ, страницы которого анализируют
PageIndex | int | Только чтение, только только заголовки документов и страниц | Номер страницы в документе, которую сейчас будут анализировать
Matching | IMatchingInfo | Полные права | Объект, определяющий некоторые параметры наложения


Запрос на верификацию поля

Назначение

Позволяет пользователю управлять тем, какие поля не попадут на контекстную верификацию. Может быть использовано для того, чтобы верифицировать разные поля на разных этапах обработки.

На вход обработчику события передается поле и документ.

Когда вызывается

Событие вызывается для всех полей перед тем, как они поступают на контекстную верификацию. Для полей, пропускающих контекстную верификацию, событие не выполняется.

Параметры

Имя | Тип | Права | Значение
Field | IField | Только чтение | Поле, для которого осуществляется проверка
Document | IDocument | Только чтение | Документ, содержащий поле
NeedVerification | IBoxedBoolean | Полные права | Нужно ли верифицировать поле. Записав в этот параметр значение "false", пользователь отказывается от верификации поля.


Объекты

Этот раздел содержит описание используемых в скриптах объектов, их методов и свойств.

Замечание: Некоторые свойства и методы являются устаревшими и оставлены только для совместимости со скриптами, созданными в более ранних версиях. Названия таких свойств и методов начинаются со слова [Obsolete] в квадратных скобках.

IActionResult
IAssemblingError
IAssemblingErrors
IBatch
IBatchCheckResults
IBoxedBooleanValue
ICharacterParams
ICharactersParams
ICheckmarkGroupValue
ICheckmarkValue
IDocument
IDocumentDefinitionInfo
IDocumentExportResults
IDocuments
IDocumentsExportResults
IEditablePictureObject
IExportImageSavingOptions
IField
IFieldRegion
IFieldRegions
IFields
IFlexiCaptureTools
IMatchedSectionInfo
IMatchingInfo
IPage
IPageClassificationResult
IPages
IPictureObject
IPrincipal
IPrincipals
IProcessingCallback
IProject
IProperties
IProperty
IPropertyModificationInfo
IRect
IRects
IRoutingRuleResult
IRuleContext
IRuleError
IRuleErrors
IScriptBinaryAttributes
IStageInfo
IUserAttachment
IUserAttachments
IValue
IVARIANTArray
TAssemlingErrorType
TExportFieldType
TExportType
TPageClassificationType
TPrincipalType
TProcessingPriority
TPropertyType
TRuleErrorType
TStateType


IActionResult

Назначение

Описывает специальный объект для описания того, успешно ли прошёл экспорт (или событие пост-экспорта) конкретного документа.

Свойства

Имя | Тип | Права | Значение
Succeeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли операция успешной
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке
Result | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Формальное описание результата операции. Для экспорта – описание того, куда был проэкспортирован документ (например, путь к файлу).
Name | string | Только чтение | Имя профиля экспорта
Type | TExportType | Только чтение | Тип профиля экспорта (для использование в скрипте "после экспорта")
Applied bool Только чтение Был ли экспорт произведён в течение текущей сессии экспорта. В случае если параметр имеет значение false:
  • если значение флага Succeeded равно true, это означает, что документ был проэкспортирован в эту цель ранее;
  • если значение флага Succeeded равно false, это означает, что документ не подходит для экспорта в данную цель (например, из-за ошибок в документе).


IAssemblingError

Назначение

Ошибка сборки документа.

Свойства

Имя | Тип | Права | Значение
Type | TAssemblingErrorType | Только чтение | Тип ошибки сборки
Description | string | Только чтение | Описание
SectionName | string | Только чтение | Имя недостающего раздела (для AET_ObligatoryItemOmitted). Для страниц-приложений пусто.
Position | int | Только чтение | Позиция в документе
Weight | string | Только чтение | Вес ошибки


IAssemblingErrors

Назначение

Коллекция объектов IAssemblingError.

Можно менять только в скрипте сборки документа.

Методы

Определение | Описание
AddSectionOmittedError( int position, sectionName : string, [optional] description ) | Позволяет добавить ошибку о пропущенном разделе
AddRedundantPageError( int position, [optional] description ) | Позволяет добавить ошибку о лишней странице
AddCustomError( descriotion : string, [optional] weight : int ) | Позволяет добавить пользовательскую ошибку сборки

Важно! Метод AddCustomError следует использовать осторожно и только в том случае, когда не подходят другие типы ошибок. Так как сборка документа полностью определяется числом ошибок сборки, то при добавлении таких ошибок нужно правильно выставлять вес, а правильный выбор веса является непростой задачей.

Желательно не объединять в CustomError несколько стандартных ошибок, порождая одну ошибку с сообщением обо всех возникших ошибках.


IBatch

Назначение

Служит для представления пакета.

Методы

Важно! Методы ниже требуют права на модификацию структуры пакета. Эти методы могут быть вызваны только из скрипта обработки пакета.

Определение | Описание
MovePage( source : IDocument, target : IDocument, sourcePageIndex : int, int targetPageIndex : int ) | Перемещение страницы с индексом "sourcePageIndex" из документа "source" в документ "target" в позицию "targetPageIndex"
MoveDocument( source : IDocument, targetPosition : int ) | Перемещение документа в указанную позицию в пакете
CreateDocumentFromPage( targetPosition : int, page : IPage ): IDocument | Извлечение страницы из документа для создания на ее основе нового документа
DeleteDocument( document : IDocument ) | Удаление документа
DeletePage( page : IPage ) | Удаление страницы
CreatePageFromImage( page : IPictureObject, [optional] target : IDocument, [optional] position : int, [optional] sourceInfo : string ) : IPage | Создает страницу из объекта IPictureObject и возвращает созданную страницу. Если указан документ, страница добавляется в этот документ. Для создания одностраничного документа в качестве документа нужно указать null. Если указана позиция, происходит добавление страницы на указанную позицию в документе (если документа задан) либо добавление одностраничного документа на указанную позицию в пакете (если в качестве документа указан null). Начальной позиции соответствует значение "0", позиции в конце документа или покета - значение "-1". Если указан параметр sourceInfo, он записывается в информацию об источнике страницы. Если параметр sourceInfo не указан, в информацию об источнике страницы записывается информация, полученная из объекта IPictureObject.
CleanRecognitionResults( document : IDocument ) | Удаление результатов распознавания документа.
[Obsolete] RegistrationProperty( name : string ) : string | Получение регистрационного параметра по имени. Устаревший метод, оставленный для совместимости.

Свойства

Имя | Тип | Права | Значение
BatchTypeName | string | Только чтение | Имя типа пакетов
Documents | IDocuments | Только чтение | Документы пакета
Id | int | Только чтение | Идентификатор пакета. Уникален в пределах проекта.
Name | string | Чтение/запись | Имя пакета
Properties | IProperties | Только чтение | Именованные параметры пакета
Comment | string | Чтение/запись | Комментарий
Project | IProject | Только чтение | Проект, содержащий пакет
Priority | TProcessingPriority | Чтение/запись | Приоритет пакета
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений
[Obsolete] RegistrationProperties | IProperties | Только чтение | Регистрационные параметры пакета. Устаревшее свойство, оставлено для совместимости.


IBatchCheckResults

Назначение

Объект – контекст события "Проверка целостности пакета".

Свойства

Имя | Тип | Права | Значение
Batch | IBatch | Только чтение | Пакет
CheckSucceeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли проверка успешна
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке


IBoxedBoolean

Назначение

Объект для передачи в скрипты in-out булевого значения.

Свойства

Имя | Тип | Права | Значение
Value | bool | Чтение/запись | Значение


ICharacterParams

Назначение

Информация о свойствах символа.

Методы

Определение | Описание
SetRect( newRect : string, [optional] pageId : int ) | Задает новый прямоугольник для символа. Параметр newRect нужно передавать в виде строки "[left, top, right, bottom]". Задаваемый прямоугольник должен полностью входить в регион поля, содержащего символ. Замечание. В скрипте автозамены данный метод недоступен.

Свойства

Имя | Тип | Права | Значение
Symbol | string | Чтение/запись | Символ (строка, состоящая из одного символа).
IsSuspicious | bool | Чтение/запись | Уверенно ли распознан символ. Выставлять значение этого флага имеет смысл только в скрипте распознавания.
NeedVerification | bool | Чтение/запись | Требуется ли символу верификация. Значение этого флага определяет, будет ли символ подсвечен.
Rect | IRect | Только чтение | Прямоугольник символа. Если прямоугольник не задан, возращает null.
PageId | int | Только чтение | Идентификатор страницы, на которой расположен прямоугольник символа (для многостраничных полей).
Confidence | int | Только чтение | Уровень уверенности распознанного символа. Хранится только в случае, если выставлена настройка "сохранять уровень уверенности в типе пакетов". Может принимать значения от 0 до 55.


ICharactersParams

Назначение

Массив объектов типа ICharacterParams.

Методы

Определение | Описание
Add( value : Object, [optional] position : int ) | Вставляет элемент value в текст на указанную позицию. Если позиция не указана, элемент добавляется в конец. Замечание. Параметр value может быть символом, строкой, объектом ICharacterParams, а также объектом ICharactersParams. Таким образом, можно копировать символы или текст из других полей с сохранением разметки и подсветки. Если регионы символов не помещаются в регион нового поля, копирование не выполняется.


ICheckmarkGroupValue

Назначение

Коллекция объектов ICheckmarkValue.


ICheckmarkValue

Назначение

Служит для представления значения метки.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя метки (имя поля в Определении документа)
Value | bool | Чтение/запись | Значение метки
IsSuspicious | bool | Чтение/запись | Уверенно ли распознано значение метки
Rect | IRect | Только чтение | Прямоугольная область метки


IDocument

Назначение

Служит для представления документа.

Методы

Определение | Описание
Field( name : string ) : IField | Доступ к полю документа по полному пути к нему. Используются полные пути. Метод недоступен из скриптов, имеющих доступ только к заголовкам документов и страниц. В правилах запрещено.
HasField( name : string ) : bool | Есть поле с указанным путём. Используются относительные пути. Метод недоступен из скриптов, имеющих доступ только к заголовкам документов и страниц. В правилах запрещено.
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) Сохраняет изображение документа. Если в опциях формат сохранение не указан, изображение сохраняется *.tif. Метод недоступен из скриптов, имеющих доступ только к заголовкам документов и страниц.
Данный метод нельзя использовать при сохранении в форматы, не поддерживающие многостраничность (например, JPEG). Для сохранения в такие форматы следует использовать метод IPage.SaveAs.
IndexedItemValues( name : string ) : IVARIANTArray | Позволяет получить множество индексных полей, соответствующих одному полю в Определении документа. Если поле помечено как индексное в повторяющемся разделе, метод возвращает все значения этого поля для всех разделов. Доступно из заголовков документов и страниц. Разрешается использовать имя поля или полный путь к полю в документе. Использование в правилах запрещено.
IndexedItemValue( name : string ) : VARIANT | Позволяет получить значение поля по пути к нему или по имени. Доступно из заголовков документов и страниц. Разрешается использовать имя поля или полный путь к полю в документе. Использование в правилах запрещено.
CheckRules( ) | Проверяет все правила в документе. Требуются права на запись в документ.
Property( name : string ) : VARIANT Возвращает значение предопределённого свойства по его имени. Возвращаемое значение может быть в виде строки, числа или времени. Имена свойств и возвращаемые значения:
  • Exported - время экспорта
  • ExportedBy - кто экспортировал документ
  • Created - время создания
  • CreatedBy - кем был создан документ
  • Recognized - время распознавания
  • RecognizedBy - кем был распознан докуметн
  • Modified - время последнего редактирования
  • ModifiedBy - кем редактировался документ
  • TotalSymbolsCount - общее число символов
  • UncertainSymbolsCount - общее число неуверенно распознанных символов
  • RecognizedSymbolsCount - число распознанных символов
  • Comment - комментарий к документу
  • ProcessingErrors - ошибки обработки документа
  • ProcessingWarnings - прудупреждения обработки документа

Важно! Метод Property не следует путать с коллекцией Properties, которая содержит свойства документа, задаваемые пользователем.

Свойства

Имя | Тип | Права | Значение
Pages | IPages | Только чтение | Страницы документа
Children | IFields | Только чтение | Дочерни поля документа – разделы. В отличие от метода Sections, порядок разделов соответствует их порядку в определении документа. Повторяющиеся разделы предствлены одним элементом и сами повторения доступны через метод Items такого элемента. Недоступно из скриптов, имеющих доступ только к заголовкам документов и страниц.
Sections | IFields | Только чтение | Плоский список разделов документа. Если раздел повторяется, то в списке лежат все повторения раздела. Порядок разделов в списке соответствует порядку первых страниц разделов в документе. Разделы без страниц идут последними в списке. Недоступно из скриптов, имеющих доступ только к заголовкам документов и страниц.
IsAssembled | bool | Только чтение | Собран ли документ
IsVerified | bool | Только чтение | Верифицирован ли документ
IsExported | bool | Только чтение | Проэкспортирован ли документ
IsAnalyzed | bool | Только чтение | Проанализирован ли документ. Документ считается проанализрованным, если проанализирована каждая страница документа.
IsRecognized | bool | Только чтение | Распознан ли документ. Документ считается распознанным, если каждая страница документа либо распознана, либо является страницей-приложением.
HasUnpreparedImages | bool | Только чтение | Содержит ли документ непредобработанные страницы.
DefinitionName | string | Только чтение | Имя определения документа
ProcessingErrors | string | Только чтение | Ошибки процесса обработки, разделённые через перенос строки
ProcessingWarnings | string | Только чтение | Предупреждения процесса обработки, разделённые через перенос строки
TotalSymbolsCount | int | Только чтение | Общее число символов
RecognizedSymbolsCount | int | Только чтение | Число распознанных символов
UncertainSymbolsCount | int | Только чтение | Число неуверенно распознанных символов
SymbolsForVerificationCount | int | Только чтение | Число символов, для которых требуется верификация
Id | string | Только чтение | Идентификатор документа (External Id)
BatchName | string | Только чтение | Имя пакета
Batch | IBatch | Только чтение | Пакет. Независимо от прав скрипта на документ, доступ к пакету будет только на чтение, с доступом только к заголовкам документов и страниц.
Properties | IProperties | Только чтение | Регистрационные параметры документа
Action | IActionResult | Только чтение | Использование этого свойства имеет смысл только в скриптах экспорта и пост-экспорта
AssemblingErrors | IAssemblingErrors | Только чтение | Коллекция ошибок сборки. Доступ к коллекции всегда только на чтение.
IsExcludedFromAutomaticAssembling | bool | Чтение/запись | Участвует ли документ в автоматической сборке.
Comment | string | Чтение/запись | Комментарий документа
HasErrors | bool | Только чтение | Есть ли в документе ошибки правил или формата
HasWarnings | bool | Только чтение | Есть ли в документе предупреждения правил или формата
StageInfo | IStageInfo | Только чтение | Информация о стадии обработки документа на сервере приложений
Index | int | Только чтение | Индекс документа в пакете.
Priority | TProcessingPriority | Только чтение | Приоритет документа.
DocumentDefinition | IDocumentDefinitionInfo | Только чтение | Детальная информация о наложенном на документ Определении документа. Для нераспознанных и необработанных документов свойство возвращает пустую строку.
RuleErrors | IRuleErrors | Только чтение | Коллекция ошибок в документе (ошибки формата, ошибки правил, ошибки при слиянии результатов двойной верификации). Доступно только для открытых документов.
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений
[Obsolete]TemplateName | string | Только чтение | Имя определения документа. Свойство оставлено для совместимости.
[Obsolete]RegistrationProperty( name : string ) | string | Только чтение | Получение регистрационного параметра по имени. Свойство оставлено для совместимости.
[Obsolete]RegistrationProperties | IProperties | Только чтение | Регистрационные параметры документа. Свойство оставлено для совместимости.


IDocumentExportResults

Назначение

Объект представляет множество результатов экспорта в разные цели для одного документа. Объект является коллекцией объектов IActionResult, содержащих информацию об экспорте для конкретных целей.

Свойства

Имя | Тип | Права | Значение
Succeeded | bool | Только чтение | Был ли экспорт документа успешен.
ErrorMessage | string | Только чтение | Сообщение, описывающее, почему экспорт завершился неудачно.
Document | IDocument | Только чтение | Документ, которому соответствуют данные результаты.


IDocuments

Назначение

Коллекция объектов IDocument.


IEditablePictureObject

Назначение

Represents a picture that can be edited in ABBYY FlexiCapture. Расширяет интерфейс IPictureObject.

Методы

Определение | Описание
Rotate( angle : int ) | Поворачивает изображение по часовой стрелке на указанный угол в градусах.
FlipHorizontal() | Отражает изображение относительно вертикальной оси.
FlipVertical() | Отражает изображение относительно горизонтальной оси.
Invert( [optional] rectString : string ) | Инвертирует изображение. Можно указать строку с координатами прямоугольника, который нужно инвертировать.
ConvertToBW( [optional] threshold : int ) | Преобразует изображение в черно-белое. Можно указать значение пороговой яркости, выше которого точки будут считаться белыми, а ниже – чёрными. Пороговая яркость указывается в диапозоне от 0 до 255.
Deskew( [optional] byLines : bool, [optional] byBlackSquares : bool, [optional] byText : bool ) | Автоматически исправляет перекос изображения. Коррекция перекоса изображения может осуществляться на основе прямых линий, по черным квадратам или по тексту. По умолчанию параметр byText имеет значение true.
Despeckle( [optional] garbageSize : int ) | Очищает черно-белое изображение от мусора. Точки не крупнее заданной величины garbageSize удаляются. Если значение параметра garbageSize не задано, размер определяется автоматически. Важно! Метод применим только к черно-белым изображениям.
Erase( rectangle : string, [optional] red : int, [optional] green : int, [optional] blue : int ) | Затирает область на изображении. Можно указать цвет, используемый при затирании. По умолчанию используется черный цвет.
CutOut( rect : string ) : IEditablePictureObject | Вырезает из изображения заданный прямоугольник и возвращает этот прямоугольник.
Crop( rect : string ) | Обрезает края изображения за пределами заданного прямоугольника rect.
Scale( ratio : int ) | Растягивает или сжимает изображение относительно базового размера в 100%. Метод изменяет только пиксельные размеры изображения. Физические размеры изображения остаются прежними.
FreeScale( newWidth : int, newHeight : int, newResolution : int ) | Масштабирует страницу в соответствии с указанными значениями.

Замечание: Параметр rect, передаваемый на вход методам CutOut и Crop, представляет собой строку вида «[left, top, right, bottom]». Получить такую строку можно либо вызвав метод ToString для любого объекта типа IRect, либо с помощью метода FCTools::Rect.


IDocumentDefinitionInfo

Назначение

Содержит информацию о наложенном на документ Определении документа.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя Определения документа.
Version | int | Только чтение | Версия Определения документа.


IDocumentsExportResults

Назначение

Коллекция объектов IDocumentExportResults.

Представляет результаты экспорта для множества документов.


IExportImageSavingOptions

Назначение

Описывает настройки сохранения изображений.

Свойства

Имя | Тип | Права | Значение
Format | string | Чтение/запись | Формат сохранения изображений. Допустимые выражения: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf" + параметры "-s" (PDF Searchable) и "-a" (PDF/A). Строки не чувствительны к регистру. Параметры пишутся начиная с "-" через табуляцию или пробел или без разделителей (например, "pdf -s", "pdf-a-s").
ColorType | string | Чтение/запись | Цветовая схема. Допустимые значения: "FullColor", "GrayScale", "BlackAndWhite". Строки не чувствительны к регистру.
Resolution | int | Чтение/запись | Разрешение изображения (в DPI).
ShouldOverwrite | bool | Чтение/запись | Разрешается ли перезапись существующего файла.
Quality | int | Чтение/запись | Качество изображения для jpeg-сжатия (в процентах).
AddProperFileExt | bool | Чтение/запись | Если выставлено значение "true", то при сохранении изображения его расширение выставится в соответствии с форматом. По умолчанию выставлено значение "false".
RecognitionLanguages | string | Чтение/запись | Множество языков, которые можно использовать при распознавании документов для экспорта в PDF с возможностью поиска. Список должен содержать внутренние имена языков на английском, разделенные точкой с запятой без пробелов. Если список пуст, то используется язык определения документов, наложенного на документ. Использование свойства имеет смысл только для страниц-приложений, так как для страниц, на которые наложены разделы, текстовый слой имеют только распознанные поля. Такие поля распознаются на этапе распознавания, а не на этапе экспорта, и задание этого свойства не влияет на их распознавание.


IField

Назначение

Поле документа. Тип поля можно установить из свойства Type. Для полей-таблиц доступны методы Rows и Cell.

Методы

Определение | Описание
Suggest( VARIANT newSuggest ) | Позволяет добавить подсказку к полю
Field( Path : string) : IField | Поиск дочернего поля относительно данного. Используются относительные пути. В правилах разрешено только использование синонимов имён полей в том виде, как они заданы в настройках правил.
HasField( parameter : string) : bool | Проверяет, есть ли поле с указанным путём. Используются относительные пути. В правилах разрешено только использование синонимов имён полей в том виде, как они заданы в настройках правил.
Cell( columnName : string, rowNum : int ) : IField | Позволяет получить ячейку таблицы по имени столбца и номеру строки. Метод доступен только для таблиц. В скриптах правил этот метод недоступен.
CheckRules( ) | Проверяет правила для данного поля и всех дочерних полей. В правилах этот метод недоступен.

Свойства

Имя | Тип | Права | Значение
Type | TExportFieldType | Только чтение | Тип поля
Name | string | Только чтение | Имя поля в определении документа
Items | IFields | Только чтение | Повторения поля (для таблиц - строки таблицы)
Value | VARIANT | Чтение/запись | Значение поля в виде VARIANT. Для полей-картинок в правилах возвращает пустую строку, во всех остальных скриптах возвращает объект IPictureObject. Для пустых полей типа Date и Number возвращает DBNull.
Text | string | Чтение/запись | Текстовое представление значения поля
Symbols | ICharactersParams | Только чтение | Детализированная информация о свойствах символов текста
IsVerified | bool | Чтение/запись | Заверифицировано ли поле. В правилах можно присваивать этому полю значение "true" даже при отсутствии прав на запись в поле. Для того чтобы сбросить выставленный флаг, требуются права на запись.
NeedVerification | bool | Чтение/запись | Требуется ли верификация самому полю (не символам, из которых оно состоит)
IsMatched | bool | Только чтение | Наложено ли поле
IsValid | bool | Только чтение | Валидно ли значение поля
IsCertain | bool | Чтение/запись | Уверенно ли распознано поле (содержит ли неуверенно распознанные символы)
Regions* | IFieldRegions | Только чтение | Массив регионов поля. Перетекающие поля могут иметь несколько регионов.
ReadOnly | bool | Только чтение | Доступно ли поле только на чтение (в соответствии с настройками шаблона). В скриптах правил этот флаг означает, что правило имеет права на запись в данное поле.
IsExportable | bool | Только чтение | Предназначено ли поле для экспорта (в соответствии с настройками шаблона).
IsIndexed | bool | Только чтение | Является ли поле индексируемым. Если да, то значение этого поля может быть доступно из заголовков документов и страниц определения документа.
IsVisible | bool | Только чтение | Должно ли поле отражаться в форме документа (в соответствии с настройками шаблона).
HasRuleError | bool | Чтение/запись | Связано ли с данным полем ошибка или предупреждение правила. Замечание. В скриптах правил данное свойство определяет, отображать ли данное поле в сообщении об ошибке (будет ли поле содержать ошибку правила в случае, если проверка данного правила завершится неуспешно). Указав значение свойства "false", можно отключить показ части полей в сообщении об ошибке.
Children | IFields | Только чтение | Дочерние элементы поля (для строк таблицы - ячейки) В скриптах правил это свойство недоступно.
FullName | string | Только чтение | Полное имя поля относительно документа. Уникально идентифицирует поле в документе. Может быть использовано для поиска полей в документе через метод Field. В скриптах правил возвращаемое значение совпадает с Name и не является уникальным.
Rows | IFields | Только чтение | Множество строк таблицы. Свойство недоступно для полей, не являющихся таблицами.
[Obsolete]SuspiciousSymbols* | string | Только чтение | Строка из нулей и единиц, обозначающих уверенно распознанные символы. Устаревшее свойство, оставлено для совместимости.

* - Свойство недоступно, если в свойствах лицензии отключена опция Расширенный экспорт в Xml.


IFieldRegion

Назначение

Служит для представления региона поля документа.

Свойства

Имя | Тип | Права | Значение
PageIndex | int | Чтение/запись | Номер страницы в документе, где расположен регион
Page | IPage | Только чтение | Страница, содержащая регион
Rects | IRects | Только чтение | Массив прямоугольников, из которых состоит регион
SurroundingRect | IRect | Только чтение | Прямоугольник, описывающий весь регион
Picture | IPictureObject | Только чтение | Картинка, соответствующая региону
IsMatched | bool | Только чтение | Наложен ли данный регион
Field | IField | Только чтение | Поле документа, соответствующее региону. Может быть "0".

Замечание. В скрипте пользовательского распознавания значение свойства Field всегда "0", так как на момент распознавания поле еще не существует.


IFieldRegions

Назначение

Коллекция объектов IFieldRegion.


IFields

Назначение

Коллекция объектов IField.

Методы

Определение | Описание
AddNew( insertAt : int ) | Добавляет новое вхождение повторяющегося поля. Аргумент insertAt указывает позицию нового элемента в коллекции. Метод позволяет создавать строки для табличного блока без региона. В скриптах правил этот метод недоступен. Пример кода: Document.Field( "Page 1\\Address" ).Items.AddNew( 0 );
Delete( what : Object ) | Удаляет вхождение поля или строку таблицы. В качестве аргумента what можно указать объект в коллекции, который нужно удалить, либо его индекс. В скриптах правил этот метод недоступен.


IFlexiCaptureTools

Назначение

Глобальный объект FCTools, реализующий данный интерфейс, доступен из скриптов. Все методы глобального объекта FCTools можно вызывать как статические, например: FCTools.ShowMessage( “Test” );

Методы

Определение | Описание
NewImageSavingOptions() : IExportImageSavingOptions | Создаёт новый объект типа IExportImageSavingOptions.
Rect( left : int, right : int, top : int, bottom : int ) : string | Генерирует по координатам строку, представляющую прямоугольник.
IsModuleAllowedByLicense( authorId : string, moduleName : string ) : bool | Проверяет, разрешен ли указанный модуль лицензией.
LoadImage( filePath : string, [optional] pageNumber : int ) : IEditablePictureObject | Загружает из файла изображение, которое в дальнейшем можно редактировать.
PictureFromHBitmap( bitmap : HBITMAP, [optional] resolution : int ) : IEditablePictureObject | Создает из объекта HBITMAP изображение с указанным разрешением, доступное для дальнейшего редактирования. Пример кода: System.Drawing.Bitmap bitmap = System.Drawing.Image.FromHbitmap( handle ); <do something> IPictureObject FinalPicture = FCTools.PictureFromHBitmap( bitmap.GetHbitmap().ToInt32(), 300 ); Замечание. Так как объект HBITMAP берется во владение, для него не нужно вызывать метод CloseHandle после генерации изображения.
ShowMessage( text : string, [optional] isError : bool ) | Показывает сообщение пользователю. Если значение флага isError равно true, будет показано сообщение об ошибке, иначе будет показана нотификация. Если данный скрипт выполняется внутри какого-либо процесса обработки, то сообщение запишется в лог процесса обработки.
ClassifyPage( page : IPage, [optional] callback : IProcessingCallback, [optional] detectClassesWithoutLayout : bool ) : IPageClassificationResult | Классифицирует страницу и, если операция была успешной, возращает результат классификации. Результатом классификации может быть имя класса из классификатора в типе пакетов или пустое значение. Замечание. Если значение параметра detectClassesWithoutLayout равно true, то при классификации используются только классы из классификатора без учета имеющихся определений документов. Замечание. Вы можете либо использовать имеющийся интерфейс IProcessingCallback, либо реализовать этот интерфейс самостоятельно.

Замечание. В отличие от использования классификатора, метод ClassifyPage определяет класс страницы, но не применяет к странице результат классификации. Например, если классификатор не содержит определение документа Banking_eng, метод ClassifyPage может вернуть для страницы раздел данного определения документа.


IMatchedSectionInfo

Назанчение

Содержит детальную информацию о наложенном на страницу разделе Определения документа.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя раздела.
IsFlexible | bool | Только чтение | Является ли раздел гибким.
FlexibleInstanceId | int | Только чтение | Индекс гибкого раздела. Множество страниц с одинаковым индексом гибкого раздела образуют один раздел документа. Поле имеет смысл только для гибких разделов. Если для двух страниц с одним и тем же определением гибкого раздела значение парамерта FlexibleInstanceId различно, это означает, что страницы принадлежат разным разделам документа.
FlexibleInstanceId | int | Только чтение | Номер страницы в определении жёсткого раздела, наложенного на данную страницу. Поле имеет смысл только для жестких разделов.
DocumentDefinition | IDocumentDefinitionInfo | Только чтение | Информация об Определении документа, содержащем раздел.


IMatchingInfo

Назначение

Объект для хранения параметров наложения разделов и определений документов на страницу.

Свойства

Имя | Тип | Права | Значение
DefinitionsList | string | Чтение/запись | Список разделов или определений документов, которые нужно накладывать на страницу, разделённых точкой с запятой.
ForceMatch | bool | Чтение/запись | Нужно ли принудительно накладывать разделы. Значение этого флага может быть "true", только если задано не более одного раздела. Если список разделов пустой и выставлен этот флаг, то страница будет помечена как страница-приложение без распознавания.
NeedRecognition | bool | Чтение/запись | Нужно ли распознавание полей внутри разделов. Если выставлено значение "false", то после наложения поля в документе распознаваться не будут.

Замечание: Имена определений документов или имена разделов в них могут быть заданы в виде <DefinitionName>\<SectionName>. Допустимо использовать только существующие разделы и определения документов.

Например, задать первый раздел из документа Banking_eng можно следующим образом: Banking_eng\Page 1.

Замечание: Чтобы распознать страницу со всеми разделами, не изменяйте свойство DefinitionsList. Если задан пустой список DefinitionsList и не выставлен флаг ForceMatch, то страница не будет распознана, а в лог запишется сообщение "No Document Definitions to match". Если флаг ForceMatch выставлен, то страница будет помечена как страница-приложение.


IPage

Назначение

Служит для представления страницы.

Методы

Определение | Описание
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Позволяет сохранить изображение страницы в соответствии с настройками. Если опции сохранения не заданы, изображение сохраняется как *.tif. Недоступно из скриптов, имеющих доступ только к заголовкам документов и страниц.
ReplaceImage( newPicture : IPictureObject ) | Заменяет изображение страницы на новое. Новое изображение может быть загружено из файла с помощью метода FCTools.LoadImage, создано из имеющегося в пямяти изображения (например, .NET System.Drawing.Image) с помощью метода FCTools.PictureFromHBitmap либо получено путем редактирования другого объекта IPictureObject.

Свойства

Имя | Тип | Права | Значение
Document | IDocument | Только чтение | Документ, сдержащий страницу
Index | int | Только чтение | Индекс страницы в документе
ImageSourceType | string | Только чтение | Строка "File", "Scanner" или "Custom" в зависимости от типа источника
ImageSource | string | Только чтение | Для файлов - полный путь к файлу. Для других источников - то, что было указано в ImageSourceDetails.
ImageSourcePageNumber | int | Только чтение | Номер исходной страницы в файле
ImageSourceFileSubPath | string | Только чтение | Путь исходного изображения относительно корневого каталога HotFolder или папки, из которой изображения были импортированы.
Rect | IRect | Только чтение | Прямоугольник страницы. Недоступно из скриптов, имеющих доступ только к заголовкам документов и страниц.
ExcludedFromDocumentImage | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Используется при экспорте изображения документа. Означает, что изображение данной страницы не нужно экспортировать при экспорте всего документа. Недоступно из скриптов, имеющих доступ только к заголовкам документов и страниц.
SectionName | string | Только чтение | Имя раздела документа
Id | string | Только чтение | Идентификатор страницы
Picture | IPictureObject | Только чтение | Изображение страницы. Недоступно из скриптов, имеющих доступ только заголовкам документов и страниц.
IsAnalyzed | bool | Только чтение | Проанализирована ли страница.
Attachments | IUserAttachments | Только чтение | Пользовательские файлы приложений
[Obsolete] TemplateName | string | Только чтение | Имя раздела документа (то же, что и SectionName). Свойство оставлено для совместимости.


IPageClassificationResult

Назначение

Содержит информацию о результатах классификации страницы.

Свойства

Имя | Тип | Права | Значение
PageType | TPageClassificationType | Только чтение | Тип страницы
MatchedSections | string | Только чтение | Список разделов, которые могут быть наложены. Содержит записи вида <Document Definition Name>\<Section Name>, разделенные точкой с запятой. Этот список может быть в неизменном виде передан объекту IMatchingInfo в качестве параметра DefinitionsList (IMatchingInfo::DefinitionsList). Замечание. При передаче результатов классификации в скрипт Перед наложением определений документов, установите для флага IMatchingInfo.ForceMatch значение false, для того чтобы не выполнялась повторная классификация страниц при помощи скрипта.


IPages

Назначение

Коллекция объектов IPage.


IPictureObject

Назначение

Представление изображения страницы или региона.

Объект реализует интерфейс IPicture и предоставляет доступ к некоторым его свойствам через интерфейс IDispatch.

Подробнее об интерфейсе IPicture вы можете прочитать в соответствующей статье на MSDN.

Методы

Определение | Описание
SaveAs( filename : string, [optional] options : IExportImageSavingOptions ) | Позволяет сохранить изображение. Если опции сохранения не указаны, изображение сохраняется как *.tif.
CreateEditableCopy() : IEditablePictureObject | Создает копию данного изображения, которую можно редактировать.
DetectPageOrientation( [optional] language: string ) : int | Определяет ориентацию страницы по тексту на ней. В качестве входного параметра передается внутреннее имя языка. Если язык не указан, используется язык текущей локали машины. Возвращает угол (в градусах), на который нужно повернуть страницу. Может вернуть следующие значения: 0, 90, 180 и 270.

Свойства

Имя | Тип | Права | Значение
Handle | OLE_HANDLE | Только чтение | Handle объекта Windows GDI. Это поле может использоваться для получения в .Net объекта картинки методом System.Drawing.Image.FromHbitmap.
hPal | OLE_HANDLE | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | GDI Handle палитры изображения. Это поле может использоваться в качестве второго параметра при вызове метода System.Drawing.Image.FromHbitmap.
Type | SHORT | Только чтение | Тип изображения
Width | int | Только чтение | Ширина изображения в точках
Height | int | Только чтение | Высота изображения в точках
IsBlackWhite | bool | Только чтение | Является ли изображение черно-белым
XResolution | int | Только чтение | Горизонтальное разрешение изображения
YResolution | int | Только чтение | Вертикальное разрешение изображения


IPrincipal

Назначение

Представление пользователя или группы в скриптах.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя пользователя или группыp
Id | int | Только чтение | Уникальный идентификатор
Type | TPrincipalType | Только чтение | Тип принципала


IPrincipals

Назначение

Общая коллекция пользователей и групп пользователей (коллекция объектов IPrincipal).


IProcessingCallback

Назначение

Объект для передачи информации о ходе процесса обработки.

Методы

Определение | Описание
ReportMessage( message : string ) | Записывает в лог информационное сообщение.
ReportWarning( warning : string ) | Записывает в лог предупреждение.
ReportError( error : string ) | Записывает в лог сообщение об ошибке. Операция, содержащая сообщения об ошибке, считается неуспешной.

Свойства

Имя | Тип | Права | Значение
ShouldStop | bool | Только чтение | Проверяет, не отменена ли задача (нажал ли пользователь кнопку "Отмена").


IProject

Назначение

Представление проекта в скриптах.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя проекта
Principals | IPrincipals | Только чтение | Массив пользователей или групп
ExportRootPath | string | Только чтение | Корневой путь для экспорта в том виде, в котором он указан в настройках проекта. Может быть пустой строкой.


IProperties

Назначение

Коллекция объектов типа IProperty.

Методы

Определение | Описание
Get (name : string) : string | Позволяет получить значение свойства по имени
Set (name : string, value : string) | Устанавливает значение именованного свойства. Создаёт свойство, если его не было.
Has (name : string) : bool | Проверяет, есть ли во множестве свойство с заданным именем.
Delete (name : string) | Удаляет свойство с заданным именем.


IProperty

Назначение

Именованный параметр документа или пакета.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя свойства
Value | string | Только чтение | Значение свойства


IPropertyModificationInfo

Назначение

Информация об изменении свойства документа или пакета.

Выставляемое значение свойства можно подправить.

Свойства

Имя | Тип | Права | Значение
PropertyType | TPropertyType | Только чтение | Тип изменяемого свойства
NewValue | string | Чтение/запись | Новое значение свойства. В скрипте можно выставлять другое новое значение, например, нормализовать его.
Name | string | Только чтение | Имя именованного параметра (только для типа PT_NamedPropertyValue)


IRect

Назначение

Прямоугольник.

Методы

Определение | Описание
ToString() : string | Представление прямоугольника в виде строки вида "[left,top,right,bottom]".

Свойства

Имя | Тип | Права | Значение
Left | int | Только чтение | Левая координата
Right | int | Только чтение | Правая координата
Top | int | Только чтение | Верхняя координата
Bottom | int | Только чтение | Нижняя координата


IRects

Назначение

Коллекция объектов IRect.


IRoutingRuleResult

Назначение

Результат работы скрипта маршрутизации.

Свойства

Имя | Тип | Права | Значение
CheckSucceeded | bool | Чтение/запись | Была ли проверка правила успешной.
PrincipalId | int | Чтение/запись | Идентификатор пользователя или группы, который будет присвоен документу в случае успешной маршрутизации. Если в скрипте маршрутизации документ не назначен ни одному пользователю, идентификатор имеет значение "0". Ноль означает, что задачу с таким документом может взять в обработку любой пользователь. Смотрите описание параметра IPrincipal.
Priority | TProcessingPriority | Чтение/запись | Приоритет документа, который будет выставлен, если в результате работы скрипта маршрутизации будет возвращено значение "true".


IRuleContext

Назначение

Контекстный объект правил. Представляет тот объект, на уровне которого создано правило.

Реализует интерфейс IField (предоставляя доступ к контекстному полю правила), а также имеет дополнительные методы.

Свойства

Имя | Тип | Права | Значение
Fields | IFields | Только чтение | Коллекция полей правила. Задаётся в настройках правила.
Document | IDocument | Только чтение | Доступ к документу
CheckSucceeded | bool | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Была ли проверка правила успешной
ErrorMessage | string | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Сообщение об ошибке правила
FocusedField | IField | Чтение/запись. Можно изменять даже в скриптах с правами только на чтение. | Поле, на которое требуется установить фокус при нажатии на ошибку правила (поле, вызвавшее ошибку правила)
ParentWindow | int | Только чтение | Дескриптор родительского окна. Применяется только в "пользовательском скрипте".
FocusRect | IRect | Только чтение | Прямоугольник в экранных координатах, к которому относится выполняемое действие (прямоугольник окна). Применяется только в "пользовательском скрипте".
[Obsolete] FieldsObject | IFR65Fields | Только чтение | Для поддержки скриптов, созданных в FormReader 6.5. Устаревшее свойство, оставлено для совместимости.
[Obsolete] ErrorObjectObject | IFR65Errors | Только чтение | Для поддержки скриптов, созданных в FormReader 6.5. Устаревшее свойство, оставлено для совместимости.


IRuleError

Назначение

Служит для представления ошибки правила, формата или объединения.

Методы

Определение | Описание
GetFields() : IFields | Возвращает поля, связанные с данной ошибкой поля.

Свойства

Имя | Тип | Права | Значение
Message | string | Только чтение | Текст сообщения об ошибке.
IsWarning | bool | Только чтение | Проверяет, является ли сообщение предупреждением.
Type | TRuleErrorType | Только чтение | Тип ошибки.
RuleName | string | Только чтение | Имя правила, вызвашего ошибку. Для ошибок формата и объединения возвращает пустую строку.


IRuleErrors

Назначение

Коллекция объектов IRuleError.


IScriptBinaryAttributes

Назначение

Множество булевых флагов.

Методы

Определение | Описание
Has( TStateType : int ) : bool | Проверяет, выставлен ли запрошенный флаг


IStageInfo

Назначение

Информация о стадии обработке документа.

Свойства

Имя | Тип | Права | Значение
StageID | int | Только чтение | Идентификатор текущей стадии обработки
StageName | int | Только чтение | Имя текущей стадии обработки
TaskId | string | Только чтение | Идентификатор задачи. При отсутствии задачи идентификатор равен нулю.
PrincipalId | string | Только чтение | Идентификатор пользователя или группы, который может получать задачу с данным документов. "0" означает, что данная задача не назначена конкретному пользователю или группе. Смотрите описание параметра IPrincipal.


IUserAttachment

Назначение

Интерфейс используется для работы с содержимым файла пользовательского приложения. Объект является массивом байт. Доступ к байтам осуществляется так же, как к объектам в коллекции. Разрешается менять значение байтов в любой позиции.

Методы

Определение | Описание
SetSize( newSize : int) : bool | Изменяет размер файла. Если файл имеет размер меньше указанного, размер файла увеличивается; файлы, имеющие размер больше указанного, обрезаются.
ToFile( fileName : string) | Сохраняет файл на диск по указанному пути.
FromFile( fileName : string) | Заменяет содержимое приложение файлом, расположенным по указанному пути.
UploadAttachment( ) | Сохраняет все изменения, сделанные в приложении.

Свойства

Имя | Тип | Права | Значение
Name | string | Только чтение | Имя файла.
AsString | string | Чтение/запись | Представление файла в виде одной Unicode-строки. Файлы можно как записывать, так и читать в виде Unicode-строки.


IUserAttachments

Назначение

Коллекция объектов IUserAttachment.

Методы

Определение | Описание
Has( name : string) : bool | Проверяет, существует ли файл-приложение с указанным именем.
Get( name : string) : IUserAttachment | Позволяет получить доступ к файлу-приложению с указанным именем.
AddNew( name : string) : IUserAttachment | Позволяет создать новый файл-приложение и начать его редактировать. Важно! Метод создает новый экземпляр IUserAttachment, не добавляя его в коллекцию, и возвращает ссылку на созданный экземпляр. Чтобы созданный экземпляр был добавлен в коллекцию и был доступен из коллекции, нужно вызвать метод UploadAttachment( ). Замечание. Если коллекция уже содержит вложение с таким именем, имеющее ненулевой размер, будет возвращено исключение.
Delete( name : string) | Удаляет файл-приложение с указанным именем. Замечание. При удалении наличие удаляемого элемента не проверяется. Таким образом, данный метод выполнится успешно, даже если удаляемый элемент отсутствует в коллекции.

Свойства

Имя | Тип | Права | Значение
Names | IVariantArray | Только чтение | Массив с именами файлов-приложений.
IsEmpty | bool | Только чтение | Проверяет, есть ли в массиве какие-либо файлы приложений.


IValue

Назначение

Служит для представления значения поля.

Свойства

Имя | Тип | Права | Значение
Text | string | Чтение/запись | Текстовое представление значения
ErrorMessage | string | Чтение/запись | Сообщение об ошибке форматирования значения
Symbols | ICharactersParams | Только чтение | Детализированная информация о свойствах символов
[Obsolete] SuspiciousSymbols | string | Чтение/запись | Строка из нулей и единиц, описывающая, какие символы являются подозрительными для распознавателя. Устаревшее свойство, оставлено для совместимости.


TAssemlingErrorType

Назначение

Тип ошибки сборки.

Допустимые значения:

  • AET_ObligatoryItemOmitted = 0 - Недостающий раздел
  • AET_RubbishItem = 1 - Лишняя страница
  • AET_AssemblingRuleError = 2 - Пользовательская ошибка сборки
  • AET_KeyValuesMismatch = 3 - Не совпадают значения ключевых полей (возможно не более одной ошибки этого типа на документ)


TExportFieldType

Назначение

Перечисление, имеет тип int. Описывает тип полей документа.

Допустимые значения:

  • EFT_TextField = 0 - Текстовое поле
  • EFT_DateTimeField = 1 - Поле с датой
  • EFT_NumberField = 2 - Поле с числом
  • EFT_PictureField = 3 - Поле-картинка
  • EFT_CurrencyField = 4 - Поле с валютой
  • EFT_Checkmark = 5 - Метка
  • EFT_CheckmarkGroup = 6 - Группа меток
  • EFT_Group = 7 - Обычная группа
  • EFT_Table = 8 - Таблица. Через методы Items или Rows объекта IField можно получить доступ к строкам таблицы.
  • EFT_Section = 9 - Раздел документа
  • EFT_Document = 10 - Документ. Поля такого типа встречаются только в правилах, написанных на уровне документа. Большинство параметров таких полей недоступно.
  • EFT_TableRow = 11 - Строка в таблице. Ячейки в ней являются дочерними полями и доступны через метод Children.
  • EFT_TimeField = 12 - Поле со временем


TExportType

Назначение

Тип назначения экспорта.

Допустимые значения:

  • ET_File = 1 - Экспорт в файл
  • ET_Database = 2 - Экспорт в базу данных
  • ET_Script = 3 - Скриптовый экспорт
  • ET_SharePoint = 4 - Экспорт в SharePoint
  • ET_Unknown = 5 - Тип не задан, если есть ошибки, не относящиеся к определённому экспортёру


TPageClassificationType

Назначение

Тип страницы, определенный Классификатором. Используются в интерфейсе IPageClassificationResult.

Допустимые значения:

  • PCT_Unknown = 0 - Неизвестный тип страницы.
  • PCT_Empty = 1 - Пустая страница.
  • PCT_FixedForm = 2 - Страница с жесткой структурой.
  • PCT_FlexibleMultiPageFormHeader = 3 - Заголовок многостраничного гибкого раздела.
  • PCT_FlexibleMultiPageFormNonHeader = 4 - Страница в многостраничной гибком разделе, не являющая заголовком.
  • PCT_FlexibleSinglePageForm = 5 - Одностраничный гибкий раздел.
  • PCT_ClassWithoutDefinition = 6 - Страница класса без определения документа.


TPrincipalType

Назначение

Типы принципалов (пользователей или процессов, имеющих учетную запись (account) в данной среде).

Допустимые значения:

  • PT_User = 0 - Обычный пользователь
  • ST_Group = 1 - Группа пользователей


TProcessingPriority

Назначение

Приоритет обработки документа или пакета.

Замечание: Значение приоритета передается в события "Изменение свойства документа" и "Изменение свойства пакета" в виде строки. Новое значение также должно задаваться в виде строки.

Допустимые значения:

  • PP_Lowest = -2 - Низший приоритет. Передается в виде строки "lowest".
  • PP_Low = -1 - Низкий приоритет. Передается в виде строки "low".
  • PP_Normal = 0 - Нормальный приоритет. Передается в виде строки "normal".
  • PP_High = 1 - Высокий приоритет. Передается в виде строки "high".
  • PP_Highest = 2 - Высший приоритет. Передается в виде строки "highest".


TPropertyType

Назначение

Тип свойств документов или пакетов. Используется в объекте IPropertyModificationInfo.

Типы:

  • PT_Name = 0 - Имя (только для пакетов).
  • PT_Comment = 1 - Комментарий.
  • PT_BatchType = 2 - Тип пакета (только для пакетов).
  • PT_NamedPropertyValue = 3 - Именованное свойство (то же, что регистрационный параметр во FlexiCapture 10)
  • PT_Id = 4 - Идентификатор (ExternalId документа). Значение меняется редко и только у документов. Изменение значения происходит главным образом в момент импорта.


TRuleErrorType

Описание

Тип ошибки. Используется в интерфейсе IRuleError.

Типы:

  • ET_RuleError = 0 - Ошибка правила.
  • ET_FormatError = 1 - Ошибка формата.
  • ET_MergeVersionError = 2 - Ошибка объединения разных версий документа.


TStateType

Назначение

Типы состояния документа. Используются в событии "Изменение состояния документа". С помощью параметра ChangedState этого события можно узнать про каждый тип состояния, изменилось ли оно.

Допустимые значения:

  • ST_Preprocessed = 0 - Документ предобработан. Значение может меняться только "false" на "true".
  • ST_Analyzed = 1 - Проанализирован ли документ.
  • ST_Recognized = 2 - Распознан ли документ (документ считается распознанным, если в нём распознано хотя бы одно поле).
  • ST_HasErrors = 3 - Есть ли ошибки в документе (в том числе форматные).
  • ST_Assembled = 4 - Документ собран.
  • ST_Verifyed = 5 - Документ полностью верифицирован.
  • ST_Exported = 6 - Документ проэкспортирован.
  • ST_HasLayout = 7 - На документ наложена форма. (Проанализированный документ также может не иметь формы, например, если это страница неизвестного типа.)


Примеры скриптов

В этом разделе приведены примеры скриптов, написанные на языках JScript® и VBScript.

Примеры скриптов для создания пользовательских правил
Примеры скриптов для описания экспорта
Другие примеры скриптов


Примеры скриптов для создания пользовательских правил

Automation правило

Данный пример демонстрирует проверку данных в таблице. В правиле проверяется соответствие данных таблицы значению, содержащемуся в итоговом поле. Таблица имеет колонки с ценами и количеством некоторых товаров. Правило написано на уровне раздела, содержащего таблицу и результирующее поле.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Код ActiveX компоненты

Здесь приведен код класса CheckDoc из проекта AutomationRule, который используется в указанных выше скриптах.

Option Explicit

' Проверяет соответствие данных в таблице результату

' column1 - колонка цен

' column2 - колонка количества

' resultField - результирующее поле (<Итого> или подобное ему )

' docObj - проверяемый узел документа

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' суммирование данных по таблице

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' сравнение с точностью до 2-го знака после запятой

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Данные в таблице не соответствуют итоговому значению"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Поиск в списке вариантов

Код правила, приведенный ниже, проверяет, что значение поля соответствует одному из значений списка. Если это не так, то устанавливается флажок ошибки правила, а поле получает список предлагаемых значений(suggests). В зависимости от результата проверки поле помечается либо как уверенно распознанное, либо как неуверенно.

[VBScript]

'запомнить значение поля

Dim fieldValue

fieldValue = me.Field("Field6").Value

'создать список значений для проверки

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

'проверить значение поля на соответствие значениям из списка

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

'в зависимости от результатов проверки выставить уверенность полю

me.Field("Field6").IsCertain = success

'заполнить список подсказок для поля - подсказкой может быть любое из

'подходящих значений

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

'установить флажок ошибки

me.CheckSucceeded = success

[JScript]

// запомнить значение поля

var fieldValue = Field("Field6").Value;

// создать список значений для проверки

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// проверить значение поля на соответствие значениям из списка

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// в зависимости от результатов проверки выставить уверенность полю

Field("Field6").IsCertain = success;

// заполнить список подсказок для поля - подсказкой может быть любое из

// подходящих значений

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// установить флажок ошибки

CheckSucceeded = success;

Проверка наложения полей

Код правила, приведенный ниже, определяет, наложилось ли проверяемое поле.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Field InvoiceNumber is not matched"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Field InvoiceNumber is not matched";

}

Проверка метки

Код правила, приведенный ниже проверяет, отмечена метка или нет

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Page status is not checked"

me.FocusedField = me.Field("Page status")

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Page status is not checked";

FocusedField = Field("Page status");

}

Проверка меток в группе

Код правила, приведенный ниже, перебирает все метки в группе и, если ни одна из них не выбрана, выбирает первую. Правило написано на уровне группы меток. В список полей, участвующих в правиле, добавлены все метки из данной группы. Сама группа удалена из списка полей. Для метки по умолчанию (первой) снят флажок Readonly. Если в группе нет ни одной метки, устанавливается флаг ошибки правила.

Данный пример демонстрирует возможность итерации по всем полям правила. Поскольку имена полей в коде не используются, код может быть использован для любой группы меток.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "В группе нет меток"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "В группе нет меток";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}

Проверка уверенности распознавания поля
Скрипт проверяет количество неуверенно распознанных символов в поле и очищает его, если их количество больше или равно трем. Данный скрипт является скриптом автозамены.

[VBScript]

Dim totQty, suspQty

Dim i

totQty = me.Symbols.Count

suspQty = 0

for i = 0 to totQty - 1

if me.Symbols.Item(i).IsSuspicious = true then

suspQty = suspQty + 1

end if

next

if suspQty >= 3 then

me.Text = ""

end if

[JScript]

var susp, qty, strpos, i, SC, strposPrev

strposPrev = 1

qty = 0

SC = "1"

susp = SuspiciousSymbols

for ( i = 0; i < susp.length; i++) {

strpos = susp.indexOf (SC,i)

if ((strpos != strposPrev) && (strpos != -1)) {

qty = qty + 1

strposPrev = strpos

}

}

if (qty >= 3) {

text = ""

}

Проверка целостности пакета
Проверяет, совпадает ли количество документов на специальной контрольной страничке с описью в пакете (inv) и количеством обработанных документов в пакете. Если не совпадает, выдает ошибку.

[VBScript]

dim DQty

dim i

for i = 0 to me.Batch.Documents.Count - 1

if me.Batch.Documents.Item(i).TemplateName = "Inv" then

DQty = me.Batch.Documents.Item(i).IndexedItemValue("DocQty")

exit for

end if

next

dim AcQty

AcQty = me.Batch.Documents.Count

if acqty <> DQty then

me.CheckSucceeded = false

me.ErrorMessage = "Некорректное количество документов в пакете:" & " " & AcQty& ". " & "Должно быть:" & " " & DQty & "!"

end if

[JScript]

for ( i = 0; i < [Batch.Documents.Count - 1]; i++ ) {

var TemplName = Batch.Documents.Item(0).TemplateName;

if (TemplName = "Inv") {

var DQty = Batch.Documents.Item(i).IndexedItemValue("DocQty");

break ;

}

}

var AcQty = Batch.Documents.Count -1

if (AcQty != DQty) {

CheckSucceeded = false;

ErrorMessage = "Некорректное количество документов в пакете:" + " " + AcQty + "." + "Должно быть:" + " " + DQty +"!" ;

}


Примеры скриптов для описания экспорта

Получение значения поля при экспорте
Код данного примера демонстрирует, каким образом можно получить значение определенного поля при экспорте. Это может потребоваться, например, чтобы использовать это значение для именования файлов экспорта изображений или данных. Если такого поля в документе не окажется, то при выполнении скрипта возникнет ошибка.

Структура экспортируемого документа:

Section 1

Field1

…

Group1

Field2

…

…

FieldN

Section 2

Field1

…

FieldK

[VBScript]

Dim field1Value, field2Value

' Получение значения поля Field1 из раздела Section 1

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Получение значения поля Field2 из группы Group1 из раздела Section 1

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Получение значения поля Field1 из раздела Section 1 в случае множественного раздела

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Получение значения поля Field1 из раздела Section 1

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Получение значения поля Field2 из группы Group1 из раздела Section 1

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Получение значения поля Field1 из раздела Section 1 в случае множественного раздела

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Экспорт изображений страниц

Код данного примера демонстрирует, каким образом можно проэкспортировать изображения всех страниц документа, используя нужный формат файла, цветовую схему и разрешение. Изображения сохраняются постранично, т.е. каждая страница в свой файл.

В примере файлы именуются "page1.tif", "page2.tif" и т.д. по количеству страниц документа. При необходимости можно задать любое другое имя файла. Например, можно сформировать имя файла, используя значение какого-либо поля документа.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' задаем желаемое имя и расширение файла в соответствии с выбранным форматом

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // задаем желаемое имя и расширение файла в соответствии с выбранным форматом

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Экспорт таблицы

Пример демонстрирует экспорт таблицы в текстовый файл формата txt.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject")

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Экспорт документа с произвольным уровнем вложенности

Пример показывает, каким образом осуществить экспорт полей документа с произвольным уровнем вложенности, используя собственные функции из глобального модуля экспорта. Экспорт осуществляется в текстовый файл формата txt. Для экспорта полей документа произвольной вложенности лучше воспользоваться внешней COM-компонентой (см. следующий пример)

Основной код экспорта

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Код функций глобального модуля экспорта

[VBScript]

' Процедура осуществляет экспорт документа - создает папку экспорта,

' сохраняет в нее файлы изображений страниц и текстовый файл с полями

' документа и информацией о документе

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject")

    ' создание папки экспорта

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during create export folder: " + Err.Description

        Err.Clear

        Exit Subub

    End if

    ' экспорт изображений

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export images: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' создание текстового файла

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' экспорт информации о документе

    ExportDocInfo docObj, txtFile

    ' экспорт полей

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export data: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Функция экспорта изображений.

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' задание опций экспорта

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' постраничный экспорт

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pageses

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Процедура экспорта информации о документе

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Процедура экспорта полей из коллекции fields

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next

End Sub

' Проверяет значение поля на null

' Если значение поля невалидно, то при любом обращении к нему(даже при

' проверке на null) может возникнуть исключение

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Процедура экспорта поля

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' сохраняем имя поля

    txtFile.Write (indent & field.Name)

    ' сохраняем значение поля, если оно доступно

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("    " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' экспорт дочерних полей

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' экспорт экземпляров поля

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' Функция создает папку экспорта и возвращает полный путь к ней

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderName

    ' основная папка

    exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' папка указанного определения документа

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End IfIf

    ' папка экспортируемого документа

    Dim i

    i = 1

    folderName = fso.BuildPath(docFolder, i)

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath(docFolder, i)

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// Функция осуществляет экспорт документа - создает папку экспорта,

// сохраняет в нее файлы изображений страниц и текстовый файл с полями

// документа и информацией о документе

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // создание папки экспорта

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during create export folder: " + e.description;

        return;n;

    }

    // экспорт изображений

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export images: " + e.description;

        return;

    }

    // создание текстового файла

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile(fileName, true);

    // экспорт информации о документе

    ExportDocInfo( docObj, txtFile );

    // экспорт полей

    txtFile.WriteLine( "Fields:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) { {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export data: " + e.description;

        txtFile.Close();

        return;

    }

    txtFile.Close();

    txtFile = 0;

    fso = 0;

}

// Функция экспорта изображений. В случае ошибки при экспорте изображений

// возвращает сообщение об этой ошибке, в противном случае - пустую строку

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // задание опций экспорта

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // постраничный экспорт

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Процедура экспорта информации о документе

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Процедура экспорта полей из коллекции fields

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Проверяет значение поля на null

// Если значение поля невалидно, то при любом обращении к нему(даже при

// проверке на null) может возникнуть исключение

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Процедура экспорта поля

function ExportField(field, txtFile, indent)

{

    // сохраняем имя поля

    txtFile.Write(indent + field.Name);

    // сохраняем значение поля, если оно доступно

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    } }

    if( field.Children != null ) {

        // экспорт дочерних полей

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // экспорт экземпляров поля

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// Функция создает папку экспорта и возвращает полный путь к ней

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // / основная папка

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    } }

    // папка указанного определения документа

    docFolder = fso.BuildPath(exportFolder, templateName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder);

    }

    // папка экспортируемого документа

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder(folderName);

    return folderName;

}

Использование внешней COM-компоненты

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Код ActiveX компоненты на VisualBasic

Здесь приведен код класса Exporter из проекта AutomationExport, который используется в указанных выше скриптах.

Option Explicit

Dim mFso As New Scripting.FileSystemObject

' Процедура осуществляет экспорт документа - создает папку экспорта,

' сохраняет в нее

' файлы изображений страниц и текстовый файл с полями документа и

' информацией о документе

Public Sub Export(ByRef docObj As Object, ByRef exportTools As Object)

On Error GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' создание папки экспорта

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Cannot create export folder"

        Exit Sub

    End If

    ' экспорт изображений

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' создание текстового файла

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' сохранение информации о проблемах при экспорте изображений

    If imageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' экспорт информации о документе

    exportDocInfo docObj, txtFile

    ' экспорт полей

    txtFile.WriteLine "Fields:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Error during export data"

    End If

    txtFile.Close

    ' если в процессе экспорта произошли ошибки, надо сбросить флаг

    'успешности экспорта в False

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

Exit Sub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

End Sub

' Функция экспорта изображений. В случае ошибки при экспорте изображений

' возвращает сообщение об этой ошибке, в противном случае - пустую строку

Private Function exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

On Error GoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' задание опций экспорта

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' постраничный экспорт

    Set pages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

Exit Function

err_h:

    exportImages = Err.Description

End Function

' Процедура экспорта информации о документе

Private Sub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

On Error GoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

Exit Sub

err_h:

    txtFile.WriteLine Err.Description

End Sub

' Функция экспорта полей из коллекции fields

Private Function exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim curField As Object

    exportFields = True

    For Each curField In fields

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

        End If

    Next curField

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

End Function

' Проверяет значение поля на null

' Если значение поля невалидно, то при любом обращении к нему(даже при

' проверке на null) может возникнуть исключение

Function IsNullFieldValue(ByRef field As Object) As Boolean

On Error GoTo err_h

    IsNullFieldValue = IsNull(field.Value)

Exit Function

err_h:

    IsNullFieldValue = True

End Function

' Функция экспорта поля

Private Function exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim result As Boolean

    result = True

    ' сохраняем имя поля

    txtFile.Write (indent & field.Name)

    ' сохраняем значение поля, если оно доступно

    If Not IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' экспорт дочерних полей

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' экспорт экземпляров поля

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

End Function

' Функция создает папку экспорта и возвращает полный путь к ней

Private Function createExportFolder(ByVal templateName As String) As String

On Error GoTo err_h

    Dim docFolder As String, folderName As String

    ' основная папка

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' папка указанного определения документа

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' папка экспортируемого документа

    Dim i As Long

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

Exit Function

err_h:

    createExportFolder = ""

End Function

Использование внешней компоненты, написанной на .Net( C# )

Для использования внешней компоненты, написанной на .Net следует выполнить следующие действия:

  1. Создать проект типа ClassLibrary
  2. Добавить в References проекта ControllerInterop.dll – в списке References появится ABBYY.FlexiCapture и все интерфейсы скриптовых объектов будут доступны в проекте.
  3. Определить disp-интерфейс и класс, реализующий этот интерфейс, а также ProgId (это нужно, чтобы из кода скрипта можно было работать с .Net компонентой так же, как с ActiveX ).
  4. После сборки проекта зарегистрировать сгенерированную библиотеку типов (это можно сделать автоматически, если включить соответствующую опцию в свойствах проекта).
  5. Из кода экспорта вызывать метод компоненты обычным образом:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

Ниже приведен код такой компоненты:

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// Интерфейс компоненты экспорта, с которым можно работать из скрипта

// При создании новой компоненты следует сгенерировать новый GUID

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// Класс с реализацией функциональности компоненты экспорта

// При создании новой компоненты следует сгенерировать новый GUID и

// задать свой ProgId

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// Функция осуществляет экспорт документа - создает папку

// экспорта, сохраняет в нее файлы изображений страниц и

// текстовый файл с полями документа и информацией о документе

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// создание текстового файла

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// экспорт информации о документе

exportDocInfo( docRef, sw );

// экспорт полей

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// Функция создает папку экспорта и возвращает полный путь к ней

private string createExportFolder( string templateName )

{

string docFolder, folderName;

// основная папка

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// папка указанного определения документа

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// папка экспортируемого документа

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

return folderName;

}

// Функция экспорта изображений.

private void exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions();

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Экспортирует информацию о документе

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Экспортирует коллекцию полей

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Проверяет значение поля на null

// Если значение поля невалидно, то при любом обращении к

// нему(даже при проверке на null) может возникнуть исключение

private bool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// Экспортирует указанное поле

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// сохраняем имя поля

sw.Write( indent + field.Name );

// сохраняем значение поля, если оно доступно

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// экспорт дочерних полей

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// экспорт экземпляров поля

exportFields( field.Items, sw, indent + " " );

}

}

}

}

Обработчик экспорта

Код данного примера демонстрирует простейший обработчик экспорта, который сохраняет информацию о проэкспортированных документах и результатах экспорта в текстовые файлы. В примере использованы два текстовых файла – со списком успешно проэкспортированных документов и документов, при экспорте которых, возникли ошибки.

[VBScript]

dim curDoc

dim fso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

set fso = CreateObject("Scripting.FileSystemObject")

' создание файла со списком ошибочных документов

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

set txtErrorFile = fso.CreateTextFile( fileErrorName, true )

' создание файла со списком успешно проэкпортированных документов

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

set txtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

dim i, exprortResult, docInfo

' проитерируем коллекцию проэкспортированных документов

for i = 0 To me.Count - 1

    set exportResult = me.Item(i)

    docInfo = "DocumentId:" & exportResult.Document.Id

    if exportResult.Succeeded then

        docInfo = docInfo & " - Exported successfully."

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & " - Export error: " & exportResult.ErrorMessage

        txtErrorFile.WriteLine docInfo

    end if

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

// создание файла со списком ошибочных документов

var fileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

var txtErrorFile = fso.CreateTextFile( fileErrorName, true );

// создание файла со списком успешно проэкпортированных документов

var fileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

var txtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

var i

// проитерируем коллекцию проэкспортированных документов

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Проэкспортирован успешно.  Результат:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Ошибка при экспорте: " + curDoc.Action.ErrorMessage + "  Результат:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Другие примеры скриптов

Сборка по возрастанию значения поля

Тип: скрипт сборки документа.

Скрипт для сборки документа с одностраничным повторяющимся разделом без приложений. Страницы собираются в один документ по возрастанию поля "PageIndex".

[VBScript]

dim lastValue, pageIndex, sections, field, validPages(), validPagesSize, pageIsValid

lastValue = ""

pageIndex = 0

for i = 0 to me.Count - 1

set sections = me.Item( i ).Sections

redim validPages( 0 )

validPagesSize = 0

' Проверка полей в разделах

for j = 0 to sections.Count - 1

if sections.Item( j ).HasField( " PageIndex " ) then

set field = sections.Item( j ).Field( " PageIndex " )

if not( field.Text = "" ) then

if lastValue = "" or field.Text > lastValue then

' Правильный порядок страниц

' Пометить все страницы раздела как правильные

for k = 0 to sections.Item( j ).Regions.Count - 1

validPagesSize = validPagesSize + 1

redim preserve validPages( validPagesSize )

validPages(validPagesSize - 1) = sections.Item( j ).Regions.Item( k ).PageIndex

next

end if

lastValue = field.Text

end if

end if

next

' Отметить все неправильные страницы

for j = 0 to me.Item( i ).Pages.Count - 1

pageIsValid = false

' Проверка правильности страницы

for k = 0 to validPagesSize - 1

if validPages(k) = j then

pageIsValid = true

exit for

end if

next

if not pageIsValid then

AssemblingErrors.AddRedundantPageError( pageIndex )

end if

pageIndex = pageIndex + 1

next

next

[JScript]

var lastValue = "";

var pageIndex = 0;

for( i = 0; i < this.Count; i++ ) {

var sections = this.Item( i ).Sections;

var validPages = new Array();

// Проверка полей в разделах

for( j = 0; j < sections.Count; j++ ) {

if( sections.Item( j ).HasField( "PageIndex" ) ) {

var field = sections.Item( j ).Field( " PageIndex " )

if( field.Text != "" ) {

if( lastValue == "" || field.Text > lastValue ) {

// Правильный порядок страниц

// Пометить все страницы раздела как правильные

for( k = 0; k < sections.Item( j ).Regions.Count; k++ ) {

validPages.push( sections.Item( j ).Regions.Item( k ).PageIndex );

}

}

lastValue = field.Text;

}

}

}

// Отметить все неправильные страницы

for( j = 0; j < this.Item( i ).Pages.Count; j ++ ) {

var pageIsValid = false;

// Проверка правильности страницы

for( k = 0; k < validPages.length; k++ ) {

if( validPages[k] == j ) {

pageIsValid = true;

break;

}

}

if( !pageIsValid ) {

AssemblingErrors.AddRedundantPageError( pageIndex );

}

pageIndex ++;

}

}

Событие объединения документов

Тип: обработчик события "Перемещение страниц".

Иллюстрирует, как из события "Перемещение страниц" можно выделить событие "Объединение документов". Логика выполнения скрипта следующая: если все страницы документа участвуют в перемещении, значит, этот документ полностью вливается в целевой.

Скрипт выполняется по событию "Перемещение страниц". Процедура Events.OnDocumentsMerge - некая процедура, обрабатывающая событие объединения.

[VBScript]

Dim currentDocument, currentDocumentPagesMoved

set currentDocument = Pages( 0 ).Document

currentDocumentPagesMoved = 0

For i = 0 to Pages.Count - 1

If Pages( i ).Document.Id <> currentDocument.Id Then

' Следующий документ

If currentDocument.Pages.Count = currentDocumentPagesMoved Then

' Из предыдущего документа все страницы перемещаются – порождаем событие

Events.OnDocumentsMerge TargetDocument, currentDocument

End If

Set currentDocument = Pages( i ).Document

Else

Next

If currentDocument.Pages.Count = currentDocumentPagesMoved Then

' Из последнего документа все страницы перемещаются – порождаем событие

Events.OnDocumentsMerge TargetDocument, currentDocument

End If

[JScript]

var currentDocument = Pages( 0 ).Document;

var currentDocumentPagesMoved = 0;

for( i = 0; i < Pages.Count - 1; i++ ) {

if( Pages( i ).Document.Id != currentDocument.Id ) {

// Следующий документ

if( currentDocument.Pages.Count == currentDocumentPagesMoved ) {

// Из предыдущего документа все страницы перемещаются – порождаем событие

Events.OnDocumentsMerge( TargetDocument, currentDocument );

}

currentDocument = Pages( i ).Document;

} else {

currentDocumentPagesMoved = currentDocumentPagesMoved + 1;

}

}

if( currentDocument.Pages.Count == currentDocumentPagesMoved ) {

// Из последнего документа все страницы перемещаются – порождаем событие

Events.OnDocumentsMerge( TargetDocument, currentDocument )

}

Объединение регистрационных параметров документов при слиянии

Тип: обработчик события "Объединение документов".

Иллюстрирует наиболее простой способ объединения регистрационных параметров при слиянии документов: при слиянии в целевой документ добавляются только те параметры из новых документов, которых в нём ещё не было.

Код следует расположить в каком-нибудь разделяемом модуле и процедуру. Процедуру OnDocumentsMerge нужно вызывать в момент слияния документов. Подробнее смотрите описание события "Объединение документов".

[VBScript]

Sub MergeProperty(ByVal TargetDocument, ByVal propertyName, ByVal propertyValue)

If TargetDocument.Properties.Get(propertyName) = "" Then

' Такого параметра не было в документе

TargetDocument.Properties.Set(propertyName, propertyValue)

End If

End Sub

Sub OnDocumentsMerge(ByVal Target, ByVal Document)

' Будем объединять регистрационные параметры

For i = 0 To Document.Properties.Count - 1

MergeProperty(Target, Document.Properties(i).Name,

Document.Properties(i).Value)

Next

End Sub

[JScript]

function MergeProperty( TargetDocument, propertyName, propertyValue )

{

if( TargetDocument.Properties.Get( propertyName ) == "" ) {

// Такого параметра не было в документе

TargetDocument.Properties.Set( propertyName, propertyValue );

}

}

function OnDocumentsMerge( Target, Document )

{

// Будем объединять регистрационные параметры

for( i = 0; i < Document.Properties.Count - 1; i++ ) {

MergeProperty( Target, Document.Properties(i).Name, Document.Properties(i).Value );

}

}


Переход к скриптам в программе FlexiCapture 10 после использования FormReader 6.5

Переход с правил FormReader 6.5 на скрипт-правила

Проверка с условием

Замена функций и методов:

  1. Функция Error(field, message). Вместо этой функции следует использовать сочетание свойств проверяемого узла – CheckSucceeded, ErrorMessage и FocusedField.

    Например, такой код:

    if [City].IsEmpty() then Error( [City] , "the city name should be filled")

    должен быть изменен следующим образом:

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "the city name should be filled"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "the city name should be filled";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Операции со строками. В настоящем разделе описывается, как реализовать строковые операции, имевшиеся в правиле «Проверка с условием», в используемых языках скриптов

    [VBScript]

    .Length() – есть аналогичная функция Len(string)

    .CmpNoCase(str) – для сравнения строк без учета регистра можно использовать функцию LCase(string) или UCase(string)

    .Mid(position, count) – есть аналогичная функция Mid(string, pos, count)

    [JScript]

    .Length() – есть аналогичное свойство length у строковой переменной

    .CmpNoCase(str) – для сравнения строк без учета регистра можно использовать методы toLowerCase() или toUpperCase() строковых переменных

    .Mid(position, count) – аналогичный метод строковой переменной substr(start, [length])

  3. Операции с вещественными числами

    [VBScript]

    Floor(d), Ceil(d) – предопределенных аналогов в VBScript нет, при необходимости можно написать собственную реализацию

    Round(d),Round(d, i) - аналогичная функция Round(d, [i])

    [JScript]

    Floor(d), Ceil(d) – нужно воспользоваться методами floor(d) и ceil(d) объекта Math

    Round(d) – метод round(d) объекта Math

    Round(d, i) – предопределенного аналога в JScript нет, при необходимости можно написать собственную реализацию

  4. Операции с текстовым полем

    IsEmpty() – надо сравнить текстовое значение поля Field("fieldName").Text с пустой строкой

    Text() - Field("fieldName").Text

    Length() – надо получить текстовое значение поля, а длину полученного строкового значения определить, как описано в п.2

    SetText(text) - Field("fieldName").Text = text

  5. Операции с меткой

    IsValid() – можно воспользоваться свойством IsVerified

    Value() - Field("fieldName").Value теперь возвращает булевское значение, а не 0/1, как было в версии 6.5

    SetValue(newValue) - Field("fieldName").Value = newValue

  6. Операции с группой меток

    IsValid() – можно воспользоваться свойством IsVerified для определения уверенности поля группы. Чтобы выяснить, сколько меток выбрано следует проитерировать метки группы, как показано в примере «Проверка меток в группе» (см. Примеры скриптов для создания пользовательских правил), и определить количество выбранных меток.

    Value() – для получения номера выбранной метки можно воспользоваться одним из двух способов:

    1. Задать меткам группы числовые имена – «0», «1» и т.д. Тогда в Field("groupName").Value будет содержаться либо номер выбранной метки, либо список номеров(выбрано несколько), либо пустая строка(не выбрана ни одна). 2. Добавить для участия в правиле только метки данной группы, причем добавить обязательно в порядке следования меток. Проитерировать метки, как показано в примере «Проверка группы меток», и определить номер выбранной метки.

    Text() - Field("groupName").Value

    SetValue(newValue) – чтобы изменить значение группы меток, надо установить/сбросить нужные метки в этой группе. Метки должны быть выбраны для участия в правиле и флаг ReadOnly для них должен быть выключен.

Automation-правило

Для того, чтобы написанные для FormReader 6.5 Automation-компоненты можно было использовать во FlexiCapture, следует внести в них некоторые изменения.

  1. Метод внешней компоненты, реализующей логику правила, следует вызывать из скриптового правила, как показано в примерах. Никаких требований к сигнатуре такого метода нет, Главное, чтобы параметры, передаваемые из скиптового правила в метод внешней компоненты, соответствовали выбранной сигнатуре метода. Она может быть, например, такой:

    Public Sub Check(ByRef docObj As Object)

    2. docObj – ссылка на проверяемый узел документа

  2. Методы объекта fieldsObj, использовавшегося в FR6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта fieldsObj новым методам:
Методы fieldsObj | Пример кода на VisualBasic, на который можно заменить вызов старого метода
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | Не поддерживается
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Для работы с колонками таблицы следует добавить для участия в правиле поля колонок. Определить, наложился столбец или нет, можно также, как и для любого другого поля:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Для работы с ячейками таблицы следует добавить для участия в правиле поля колонок.

Работа с этими полями будет зависеть от того, на каком уровне написано правило. Если правило написано на уровне колонки или таблицы, то оно работает для каждой строки, оперируя значениями колонок из проверяемой строки (т.е. работает с ячейками):

Dim cell As Object Set cell = docObj.Field("ColumnName") Dim cellValue as String cellValue = cell.Value

Таким образом, например, можно написать правило, которое на основании данных в первых двух колонках таблицы, заполняет третью колонку:

Dim cellResult As Object Set cellResult = docObj.Field("ColumnResult") cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Если правило написано на уровне узла, содержащего таблицу (группа, раздел, документ), то для получения доступа к ячейкам конкретной колонки ее потребуется проитерировать, как показано в примере «Automation-правило».

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' получение подсказок для поля

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' получение подсказок для поля

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Доступ к полю ячейки осуществляется также, как описано и для метода SetTableCellValue.

Далее с полученной ячейкой можно работать также, как и с любым другим полем. Т.е. задание подсказки будет выглядеть так:

cell.Suggest cellSuggest

  3. Методы объекта errorsObj, использовавшегося в FR6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта errorsObj новым методам:
Методы errorsObj | Пример кода на VisualBasic, на который можно заменить вызов старого метода
SendFieldError( ErrMsg As String, Index As Integer) | docObj.ErrorMessage = ErrMsg docObj.CheckSucceeded = false docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant ) | docObj.ErrorMessage = ErrMsg docObj.CheckSucceeded = false Если правило написано на уровне таблицы или колонки, то в качестве ошибочных выделяются все ячейки проверяемой строки, поля которых (колонки), включены в правило. Чтобы поставить фокус на нужную ячейку следует написать такой код: docObj.FocusedField = docObj.Field("ColumnName") Если правило написано на более высоком уровне, то ячейки не выделяются и не получают фокус.

Переход с Automation-экспорта FormReader 6.5 на скрипт-экспорт

Метод внешней компоненты, реализующей логику экспорта, следует вызывать из скриптового экспорта, как показано в примерах. Никаких требований к сигнатуре такого метода нет, главное, чтобы параметры, передаваемые из скипта в метод внешней компоненты, соответствовали выбранной сигнатуре метода. Она может быть, например, такой:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – ссылка на экспортируемый документ

exportTools – ссылка на объект ExportTools

Методы объекта fieldsObj, использовавшегося в FormReader R6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта fieldsObj новым средствам работы с экспортируемым документом:

Методы fieldsObj | Описание возможной реализации в применении к новой объектной модели
GetFieldsCount As Integer | Для получения количества полей в экспортируемом документе следует проитерировать дерево полей как показано в примере «Использование внешней COM-компоненты» и произвести подсчет.
GetFieldsNames(Names As Variant) | Для получения имен всех полей экспортируемого документа следует проитерировать дерево полей как показано в примере «Использование внешней COM-компоненты» и заполнить массив именами полей.
GetFieldsTypes(FieldTypes As Variant) | Не поддерживается
GetFieldByIndex(Index As Integer, FieldValue As Variant) | Доступ по индексу не имеет смысла, так как новая модель документа имеет иерархическую структуру. Дерево полей документа может быть легко проитерировано, как показано в примере «Использование внешней COM-компоненты»
GetFieldByName(Name As String, FieldValue As Variant) | Dim fieldValue fieldValue = docObj.Field(Name).Value


Использование скриптов для обработки событий интерфейса

В ABBYY FlexiCapture 10 вы можете использовать скрипты для обработки событий интерфейса. Это позволяет настраивать функционирование и интерфейс станции, изменять поведение станции при определенных условиях, реализовывать пользовательские команды.

Такие скрипты могут быть добавлены для интерактивных стадий процесса обработки и для инструментов, настраиваемых в диалоге Настройки инструмента.

Все объекты скриптов доступны на чтение и запись и не кешируются.

Права доступа к объектам ControllerInterop, используемым в скриптах обработки событий интерфейса, определяются состоянием объектов. Метод DocumentState() интерфейса ITaskWindow возвращает состояние документа на данный момент. Если документ имеет состояние DS_Opened, то объекты ControllerInterop для этого документа доступны на чтение и запись. При других состояниях объекты ControllerInterop доступны только на чтение.

Ниже описаны события, которые могут быть обработаны с помощью скриптов, и параметры этих событий.

События
Объекты

Замечание: При закрытии станции изменения в интерфейсе, сделанные с помощью скриптов, не сохраняются. Все настройки, заданные через скрипт, сбрасываются на изначальные.

Замечание: Web-станции не поддерживают работу со скриптами.


События

Ниже перечислены события в оболочке программы, которые могут быть обработаны с помощью скриптов:

При активации документа
При закрытии документа
При закрытии проекта
После закрытия документа
При активации поля
При деактивации поля
При открытии документа
После закрытия проекта
При изменении региона
При отображении региона
При возврате из задания
При открытии окна задания
При изменении режима окна задания
При подтверждении текстового поля
При вызове пользовательской команды


После закрытия документа

Когда вызывается

Вызывается во время закрытия документа в редакторе документа после подтверждений изменений.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа


После закрытия проекта

Когда вызывается

Вызывается во время закрытия проекта после того, как пользователь подтверждает действия в окне опроса (в случае показа окна опроса).

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно


При активации документа

Когда вызывается

Вызывается перед активизацией документа в окне задания (двойным щелчком мыши, из меню программы и т.д.).

Если значение параметра CanOpen равно true, то после завершения скрипта документ будет открыт в редакторе документа. Если значение параметра CanOpen равно false, документ не будет открыт.

По умолчанию значение параметра CanOpen равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задач
DocumentItem | IDocumentItem | Чтение/запись | Обрабатываемый документ
CanOpen | IBoolean | Чтение/запись | Нужно ли открывать документ после выполнения скрипта


При активации поля

Когда вызывается

Вызывается после активации поля.

Параметры

Имя | Тип | Права | Значение
Context | IFieldControl | Чтение/запись | Активированное поле

Замечание: Активировать какое-либо другое поле из этого скрипта нельзя.


При активации страницы в окне задания

Когда вызывается

Вызывается перед активизацией страницы в окне задания (двойным щелчком мыши или из меню программы).

Если значение параметра DoDefaultAction равно true, то после завершения скрипта документ, содержащий данную страницу, будет открыт в редакторе документа. Если параметр DoDefaultAction имеет значение false, документ не будет открыт.

По умолчанию значение параметра DoDefaultAction равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задач
PageItem | IPageItem | Чтение/запись | Обрабатываемая страница
DoDefaultAction | IBoolean | Чтение/запись | Нужно ли открывать документ после выполнения скрипта


При возврате из задания

Когда вызывается

Вызывается при завершении работы с текущей задачей после подтверждения изменений пользователем.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задания


По запросу пользователя

При вызове пользовательской команды

Когда вызывается

Событие происходит при вызове пользовательской команды (для этого в главном меню или на панели инструментов должен быть размещен соответствующий пункт).

Идентификаторы пользовательских команд можно представить в виде CI_UserCommand + <неотрицательное целое число>.

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно приложения
CommandId | TCommandID | Чтение/запись | Идентификатор пользовательской команды

Замечание. Чтобы добавить пользовательскую команду на панель инструментов или в главное меню, нужно использовать методы AppendButton/InsertButton объекта IToolbar и AppendItem/InsertItem объекта IMenu соответственно. В качестве пунктов меню необходимо использовать идентификаторы CI_UserCommand или CI_UserCommand + <неотрицательное целое число>.

Код, приведенный ниже, иллюстрирует добавление пункта меню для пользовательской команды с идентификатором CI_UserCommand + 1.

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

IMenu menu = MainWindow.MainMenu[0].Submenu;

menu.AppendItem( userCommand1, “User command” );

Добавленная кнопка или пункт меню для пользовательской команды будут иметь статус "disabled" до тех пор, пока не будет добавлен обработчик события "По запросу пользователя".

Пример кода ниже иллюстрирует обработку события "По запросу пользователя".

ABBYY.FlexiCapture.ClientUI.TCommandID commandID = ( ABBYY.FlexiCapture.ClientUI.TCommandID )( CommandId );

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand = ABBYY.FlexiCapture.ClientUI.TCommandID.CI_UserCommand;

ABBYY.FlexiCapture.ClientUI.TCommandID userCommand1 = (ABBYY.FlexiCapture.ClientUI.TCommandID) ((int)userCommand + 1);

if( commandID == userCommand1 ) {

<… вызываем нужные методы …>


При деактивации поля

Когда вызывается

Вызывается перед тем, как поле перестает быть активным.

В качестве параметра передается поле, которое будет активно следующим. Этот параметр можно изменить.

Параметры

Имя | Тип | Права | Значение
Context | IFieldControl | Чтение/запись | Поле, которое перестает быть активным
WasModified | bool | Чтение/запись | Было ли поле модифицировано
NewActiveControl | IBoxedFieldControl | Чтение/запись | Активизированное поле. Замечание. Имеет нулевое значение, если поле, которое будет активировано, находится в другом документе.


При закрытии документа

Когда вызывается

Вызывается при закрытием документа в редакторе документа перед подтверждением изменений. Например, при попытке перейти к другому документу или закрыть редактор.

Если значение параметра CanClose равно false, документ не будет закрыт. Если значение параметра CanClose равно true, произойдет закрытие документа.

По умолчанию параметр CanClose имеет значение true.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа
CanClose | IBoolean | Чтение/запись | Нужно ли закрывать документ после выполнения скрипта


При закрытии задания

Когда вызывается

Вызывается перед закрытием текущего задания.

Если значение параметра CanClose равно true, то после выполнения скрипта задание будет закрыто. Если параметр CanClose имеет значение false, закрытия задания не произойдет.

По умолчанию значение параметра CanClose равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задания
CanClose | IBoolean | Чтение/запись | Нужно ли закрывать задание


При закрытии проекта

Когда вызывается

Вызывается при закрытии проекта перед показом окна опроса пользователя. Диалоговое окно опроса пользователя появляется в случае, если перед продолжением работы требуется подтвердить какое-либо действие.

Если значение параметра CanClose равно false, то после выполнения скрипта главное окно не будет закрыто. Если параметр CanClose имеет значение true, произойдет закрытие главного окна.

По умолчанию значение параметра CanClose равно true.

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно
CanClose | IBoolean | Чтение/запись | Нужно ли закрывать главное окно


При изменении региона

Когда вызывается

Вызывается перед изменением блока в окне изображения.

Если значение параметра AllowChangeRegion равно true, то после выполнения скрипта произойдет изменение блока. Если параметр AllowChangeRegion имеет значение false, изменение не произойдет.

По умолчанию значение параметра AllowChangeRegion равно true.

Параметры

Имя | Тип | Права | Значение
Context | IFieldRegionControl | Чтение/запись | Регион
NewRegionParam | IShellRects | Чтение/запись | Прямоугольники региона. Для таблицы в качестве агрумента передается весь прямоугольник таблицы. Замечание. При изменении региона контейнера возвращается новый регион этого контейнера, новые регионы дочерних элементов возвращены не будут. При изменение региона дочернего элемента, будет возвращен только новый регион измененного дочернего элемента. Для таблиц регион самой таблицы возвращается всегда, в том числе при изменении региона строки или столбца таблицы.
AllowChangeRegion | IBoolean | Чтение/запись | Нужно ли выполнять действие после завершения скрипта


При изменении режима окна задания

Когда вызывается

Вызывается при изменении вида окна задач (при переключении на другой вид).

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задач


При открытии документа

Когда вызывается

Вызывается после открытия документа в редакторе документа (при открытии окна редактора или при переходе на новый документ).

На момент запуска скрипта все окна внутри редактора документа уже созданы.

Параметры

Имя | Тип | Права | Значение
Context | IDocumentEditor | Чтение/запись | Редактор документа

Замечание. Закрыть документ из этого скрипта нельзя. Использование команды DocumentEditor.TaskWindow.CloseEditorWindow(); вызовет сообщение об ошибке: "System.Runtime.InteropServices.COMException (0x80004005): Document editor cannot be closed."


При открытии окна задания

Когда вызывается

Вызывается после создания окна задания.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задания


При отмене задания

Когда вызывается

Вызывается перед отменой задания.

Если значение параметра CanReject равно true, то после выполнения скрипта задание будет отменено. Если параметр CanReject имеет значение false, отмены задания не произойдет.

По умолчанию значение параметра CanReject равно true.

Замечание. Событие происходит только при вызове команды Отменить задание. При закрытии станции данное событие не происходит.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задания
CanReject | IBoolean | Чтение/запись | Нужно ли отменять задание


При отправке задания на этап

Когда вызывается

Вызывается перед отправкой задания в Исключение.

Если значение параметра CanSend равно true, то после выполнения скрипта задание будет отправлено в Исключение. Если параметр CanSend имеет значение false, задание не будет отправлено в Исключение.

По умолчанию значение параметра CanSend равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITaskWindow | Чтение/запись | Окно задания
CanSend | IBoolean | Чтение/запись | Нужно ли отправлять задачу в Исключение


При подтверждении текстового поля

Когда вызывается

Вызывается при проверке элементом управления значения, введенного в текстовое поле, например, при выборе значения поля из предложенных вариантов или когда поле теряет фокус.

Если значение параметра CanApply равно true, то после завершения скрипта в качестве значения поля будут применены введенные данные. Если параметр CanApply имеет значение false, то будет восстановлено значение поля до редактирования.

По умолчанию значение параметра CanApply равно true.

Параметры

Имя | Тип | Права | Значение
Context | ITextEditor | Чтение/запись | Редактор поля документа
CanApply | IBoolean | Чтение/запись | Нужно ли сохранять изменения


Объекты

В этом разделе содержится описания объектов, используемых в скриптах, их методов и свойств.

IBoolean
IBoxedFieldControl
IDocumentEditor
IDocumentItem
IDocumentItems
IDocumentsCollection
IDocumentsWindow
IDrawContext
IErrorControl
IErrorControls
IErrorsWindow
IFieldControl
IFieldRegionControl
IFieldRegionControls
IFormWindow
IImageWindow
IMainMenu
IMainWindow
IMenu
IMenuItem
IPageControl
IPageItem
IPageItems
IPagesCollection
IPoint
ISelection
IShellRational
IShellRect
IShellRects
ITaskWindow
ITextEditor
IToolbar
IToolbarButton
IToolbars
TCommandBarType
TCommandID
TDockingType
TErrorType
TSelectionType
TTaskWindowMode
TTextSize
TUserRole
TWorkWindowType


IBoolean

Назначение

Используется для передачи в скрипт in-out булевого значения.

Свойства

Имя | Тип | Права | Значение
Value | bool | Чтение/запись | Значение

Замечание. Чтобы присвоить значение объекту типа IBoolean, нужно использовать свойство Value. Например, чтобы присвоить значение true объекту A типа IBoolean, нужно написать A.Value = true. Запись A = true является некорректной.


IBoxedFieldControl

Назначение

Хранит управляющий элемент поля документа.

Свойства

Имя | Тип | Права | Значение
Value | IFieldControl | Чтение/запись | Поле


IDocumentEditor

Назначение

Служит для представления редактора документа.

Методы

Определение | Описание
Save() : bool | Сохраняет документ

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
Document | IDocument | Только чтение | Редактируемый документ
Modified | bool | Только чтение | Модифицирован ли документ
TaskWindow | ITaskWindow | Только чтение | Окно задания
ImageWindow | IImageWindow | Только чтение | Окно изображения документа
FormWindow | IFormWindow | Только чтение | Окно формы
ErrorsWindow | IErrorsWindow | Только чтение | Окно ошибок
FormMode | bool | Чтение/запись | Включен ли режим показа данных


IDocumentItem

Назначение

Служит для представления документа в окне документов.

Свойства

Имя | Тип | Права | Значение
TaskWindow | ITaskWindow | Только чтение | Окно задания
TaskDocument | bool | Только чтение | Принадлежит ли документ текущему заданию
Rect | IShellRect | Только чтение | Прямоугольник, занимаемый документом в окне IDocumentsWindow
Selected | bool | Чтение/запись | Выделен ли документ
Expanded | bool | Чтение/запись | Развернут ли в окне документ
Collection | IDocumentItems | Только чтение | Коллекция документов, в которой находится документ
Document | IDocument | Только чтение | Документ
PageItems | IPageItems | Только чтение | Коллекция страниц, содержащихся в документе

Замечание: Если выбран вид Эскизы страниц, то значение свойства Expanded всегда будет равно true. Изменение значения этого свойства на false не вызовет ошибок, однако значение останется равным true.

Замечание. Если документ свернут, свойство DocumentItem.PageItems.Count возвращает "0".


IDocumentItems

Назначение

Коллекция объектов IDocumentItem. Служит для представления коллекции документов в окне документа.


IDocumentsCollection

Назначение

Коллекция объектов IDocument.


IDocumentsWindow

Назначение

Окно показа документов в режиме Эскизы страниц или Детали.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден
FindDocumentItem( document : IDocument ) : IDocumentItem | Находит объект IDocumentItem по объекту IDocument из ControllerInterop
FindPageItem( page : IPage ) : IPageItem | Находит объект IPageItem по объекту IPage из ControllerInterop

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0, 0).
TotalRect | IShellRect | Только чтение | Прямоугольник всего окна
ScrollPos | IPoint | Чтение/запись | Позиция ползунка прокрутки
Docking | TDockingType | Чтение/запись | Позиция окна IDocumentsWindow в окне Редактора документа
Ratio | IShellRational | Чтение/запись | Отношение размера окна к размеру родительского окна
TaskWindow | ITaskWindow | Только чтение | Окно задания
Items | IDocumentItems | Только чтение | Коллекция документов
SelectedItems | IDocumentItems | Только чтение | Выделенные документы
FocusedItem | IDocumentItem | Только чтение | Документы, находящиеся в фокусе


IDrawContext

Назначение

Контекст для рисования. Позволяет с помощью скрипта нанести простейшие геометрические объекты. Цвет задается с помощью стандартной последовательности из 4-х байтов: 0x00BBGGRR, где BB – байт для обозначения синего цвета, GG – зеленого, RR – красного.

Методы

Определение | Описание
GetPixel( x : int, y : int ) : int | Возвращает цвет пиксела (в RGB) с координатами x и y.
SetPixel( x : int, y : int, rgbColor : int ) : int | Устанавливает цвет пиксела (в RGB) с указанными координатами x и y. Возращает значение предыдущего цвета пиксела.
Line( start : IPoint, end : IPoint, rgbColor : int ) | Рисует линию с началом в точке "start" и концом в точке "end".
Rect( rect : IShellRect, rgbColor : int ) | Рисует рамку указанного цвета.
FillRect( rect : IShellRect, rgbColor : int ) | Рисует закрашенный прямоугольник указанного цвета.
FillAlphaRect( rect : IShellRect, rgbColor : int, alpha : int ) | Рисует закрашенный прямоугольник определенной прозрачности, которая устанавливается параметром "transparency".

Свойства

Имя | Тип | Права | Значение
Handle | int | Read only | Дескриптор контекста


IErrorControl

Назначение

Служит для представления элемента в списке окна ошибок IErrorsWindow.

Методы

Определение | Описание
Field( index : int ) : IField | Находит поле, связанное с ошибкой, по номеру ошибки

Свойства

Имя | Тип | Права | Значение
Type | TErrorType | Только чтение | Тип ошибки
Error | string | Только чтение | Текст ошибки
IsWarning | bool | Только чтение | Является ли ошибка предупреждением
FieldsCount | int | Только чтение | Количество полей, связанных с ошибкой
Index | int | Только чтение | Номер ошибки в окне ошибок IErrorsWindow


IErrorControls

Назначение

Коллекция объектов IErrorControl.


IErrorsWindow

Назначение

Служит для представления окна ошибок.

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentWindow | IDocumentEditor | Только чтение | Редактор документа
Controls | IErrorControls | Только чтение | Коллекция элементов
FocusedControl | IErrorControl | Чтение/запись | Ошибка, которая находится в фокусе
Docking | TDockingType | Чтение/запись | Позиция окна IErrorsWindow по отношению к окну IFormWindow в редакторе документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окна IErrorsWindow (числитель) к размеру окон IFromWindow + IErrorsWindow (знаменатель).
ShowAssemblingErrors | bool | Чтение/запись | Показывать ли ошибки сборки
ShowRuleErrors | bool | Чтение/запись | Показывать ли ошибки правил
ShowFormatErrors | bool | Чтение/запись | Показывать ли ошибки формата
ShowUnmatchedRegionErrors | bool | Чтение/запись | Показывать ли ошибки, связанные с неналоженными полями


IFieldControl

Назначение

Служит для представления элемента управления поля документа.

Свойства

Имя | Тип | Права | Значение
Field | IField | Только чтение | Поле
FormWindow | IFormWindow | Только чтение | Окно формы
TextEditor | ITextEditor | Только чтение | Редактор поля. Для неактивных полей возвращает null.
IsExpandable | bool | Только чтение | Можно ли разворачивать поле. Если значение равно true, поле можно сворачивать и разворачивать на форме.
IsExpanded | bool | Чтение/запись | Развернуто ли поле.
IsUserReadOnly | bool | Чтение/запись | Можно ли редактировать поле. Если значение свойства равно true, редактирование поля не разрешается. Если значение свойства равно false, возможность редактирования поля зависит от настроек шаблона.
DeviceRect | IShellRect | Только чтение | Прямоугольник поля
FieldFullName | string | Только чтение | Полное имя поля
FieldRegionControls | IFieldRegionControls | Только чтение | Кллекция регионов поля документа. Для полей, у которых нет регионов, значение свойства равно null.
Parent | IFieldControl | Только чтение | Родительский элемент управления поля
First | IFieldControl | Только чтение | Первое поле-потомок
Last | IFieldControl | Только чтение | Последний дочерний элемент управления поля
Prev | IFieldControl | Только чтение | Предыдущий элемент управления поля
Next | IFieldControl | Только чтение | Следующий элемент управления поля


IFieldRegionControl

Назначение

Служит для представления региона поля документа.

Свойства

Имя | Тип | Права | Значение
FieldRegion | IFieldRegion | Только чтение | Регион поля документа
Page | IPageControl | Только чтение | Страница, содержащая регион
Window | IImageWindow | Только чтение | Окно изображения документа
DeviceRect | IShellRect | Только чтение | Прямоугольник окна
Visible | bool | Чтение/запись | Виден ли регион
FieldControl | IFieldControl | Только чтение | Поле документа, связанное с регионом
Parent | IFieldRegionControl | Только чтение | Родительский регион
First | IFieldRegionControl | Только чтение | Первый потомок-регион
Last | IFieldRegionControl | Только чтение | Последний потомок-регион
Prev | IFieldRegionControl | Только чтение | Предыдущий регион
Next | IFieldRegionControl | Только чтение | Следующий регион


IFieldRegionControls

Назначение

Коллекция объектов IFieldRegionControl.


IFormWindow

Назначение

Служит для представления окна формы документа.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден
FindControl( field : IField ) : IFieldControl | Осуществляет поиск поля по значению региона поля из ControllerInterop

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentWindow | IDocumentEditor | Только чтение | Редактор документа
Control | IFieldControl | Только чтение | Главный элемент на форме
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0,0).
TotalRect | IShellRect | Только чтение | Прямоугольник всей формы. Если размер клиентской области меньше, чем размер всей формы, то окно формы будет иметь полосы прокрутки.
ScrollPos | int | Чтение/запись | Позиция ползунка прокрутки
ActiveControl | IFieldControl | Чтение/запись | Активный элемент на форме. Из событий При активации поля и При деактивации поля изменять значение активного элемента нельзя.
TextSize | TTextSize | Чтение/запись | Размер текста
Docking | TDockingType | Чтение/запись | Позиция окна IFormWindow относительно позиции окна IImageWindow в окне редактора документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окон IFormWindow + IErrorsWindow (числитель) к размеру окна IDocumentEditor (знаменатель). Если значение Docking равно DT_Top или DT_Bottom, отношение измеряется по высоте. В противном случае отношение измеряется по ширине.


IImageWindow

Назначение

Служит для представления окна изображения.

Методы

Определение | Описание
EnsureRectVisible( imageRect : IShellRect ) | Перемещает ползунок прокрутки так, чтобы указанный прямоугольник был виден

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
DocumentEditor | IDocuementEditor | Только чтение | Редактор документа
First | IPageControl | Только чтение | Первая страница
Last | IPageControl | Только чтение | Последняя страница
ClientRect | IShellRect | Только чтение | Прямоугольник клиентской области (в координатах окна). Верхний левый угол главного окна имеет координаты (0, 0). Если размер клиентской области меньше, чем размер области TotalRect, то окно изображения будет иметь полосы прокрутки.
TotalRect | IShellRect | Только чтение | Прямоугольник, занимаемый изображениями всех страниц
ScrollPos | IPoint | Чтение/запись | Позиция ползунка прокрутки
Docking | TDockingType | Чтение/запись | Позиция окна IImageWindow относительно окна IFormWindow в окне редактора документа.
Ratio | IShellRational | Чтение/запись | Отношение размера окна IImageWindow (числитель) к размеру окна IDocumentEditor (знаменатель). Если значение Docking равно DT_Top или DT_Bottom, отношение измеряется по высоте. В противном случае отношение измеряется по ширине.
ShowBWImages | bool | Чтение/запись | Нужно ли показывать черно-белое изображение
ImageScale | IShellRational | Чтение/запись | Масштаб изображения. Диапазон допустимых значений от 1/8 до 8.
ShowToolbar | IShellRational | Чтение/запись | Нужно ли показывать панель инструментов
IsDocked | bool | Чтение/запись | Определяет, закреплено ли окно изображения.


IMainMenu

Назначение

Коллекция объектов IMenuItem. Служит для представления меню главного окна.

Для всех элементов этого меню идентификатор TCommandID равен CI_SubMenu.

Методы

Определение | Описание
Reset() | Сбрасывает изменения и возвращает меню в исходный вид.

Важно! Применение метода Reset приводит к уничтожению имеющегося объекта IMainMenu и порождению нового объекта. Вследствие этого все ссылки на имеющийся объект становятся недействительными и попытки использовать этот объект будут порождать исключение. Необходимо либо создать новый объект IMainMenu, либо заново инициализировать имеющийся объект.

Код, приведенный ниже, иллюстрирует применение метода Reset. В результате применения метода объект menu становится недействительным и не может быть использован.

// Define a new IMainMenu object and initialize it

IMainMenu menu = TaskWindow.MainWindow.MainMenu;

// Call the Reset method

menu.Reset();


IMainWindow

Назначение

Служит для представления главного окна.

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
MainMenu | IMainMenu | Только чтение | Главное меню
Toolbars | IToolbars | Только чтение | Коллекция панелей инструментов
WorkWindowType | TWorkWindowType | Только чтение | Тип рабочего окна
TaskWindow | ITaskWindow | Только чтение | Окно задания
UserRole | TUserRole | Только чтение | Роль пользователя
Selection | ISelection | Только чтение | Выделение


IMenu

Назначение

Коллекция объектов IMenuItem. Служит для представления меню или подменю.

Методы

Определение | Описание
Find( commandId : TCommandID ) : int | Находит индекс первого объекта с указанным идентификатором команды в коллекции.
Delete( index : int ) | Удяляет элемент по его индексу в коллекции.
InsertItem( index : int, commandId : TCommandID, text : string ) | Добавляет элемент с указанным идентификатором команды commandId и текстом Text на позицию Index. Можно использовать любые идентификаторы (в том числе CI_SubMenu и CI_Separator), кроме CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.
AppendItem( commandId : TCommandID, text : string ) | Добавляет элемент с указанным идентификатором команды commandId и текстом Text в конец меню. Можно использовать любые идентификаторы (в том числе CI_SubMenu и CI_Separator), кроме CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.


IMenuItem

Назначение

Служит для представления элемента меню.

Свойства

Имя | Тип | Права | Значение
Command | TCommandID | Только чтение | Идентификатор команды. Для заголовка подменю возвращает CI_SubMenu. Для разделителя возвращает CI_Separator. Если среди значений TCommandID отсутствует идентификатор команды, возвращается CI_Undefined.
Enable | bool | Чтение/запись | Определяет включенность/выключенность пунктов меню. Если значение свойства равно false, то все пункты меню с указанным идентификатором Command будут выключены. Если значение свойства равно true, включенность/выключенность зависит от внутренней логики программы. Для разделителей и заголовков подменю значение свойства всегда равно true.
Text | string | Чтение/запись | Текст пункта меню. Замечание. Данное свойство не позволяет изменять названия заголовков главного меню: Файл, Правка, Вид и т.д.
Submenu | IMenu | Только чтение | Подменю. Если подменю отсутствует, возвращает null.


IPageControl

Назначение

Служит для представления страницы в окне изображения.

Методы

Определение | Описание
ImageToDevice( imageRect : IShellRect ) : IShellRect | Преобразует координаты изображения в оконные координаты

Свойства

Имя | Тип | Права | Значение
Page | IPage | Только чтение | Страница
ImageWindow | IImageWindow | Только чтение | Окно изображения документа
DeviceRect | IShellRect | Только чтение | Прямоугольник, занимаемый страницей
First | IFieldRegionControl | Только чтение | Первый потомок-регион
Last | IFieldRegionControl | Только чтение | Последний потомок-регион
Prev | IPageControl | Только чтение | Предыдущая страница
Next | IPageControl | Только чтение | Следующая страница


IPageItem

Назначение

Служит для представления страницы в окне документов.

Свойства

Имя | Тип | Права | Значение
TaskWindow | ITaskWindow | Только чтение | Окно задания
DeviceRect | IShellRect | Только чтение | Прямоугольник, занимаемый страницей в окне IDocumentsWindow
Selected | bool | Чтение/запись | Выделена ли страница
DocumentItem | IDocumentItem | Только чтение | Документ, содержащий страницу
Page | IPage | Только чтение | Страница


IPageItems

Назначение

Коллекция объектов IPageItem.


IPagesCollection

Назначение

Коллекция объектов IPage.


IPoint

Назначение

Служит для представления точки.

Свойства

Имя | Тип | Права | Значение
X | int | Чтение/запись | X-координата
Y | int | Чтение/запись | Y-координата


ISelection

Назначение

Служит для представления выделения (документов или страниц).

Свойства

Имя | Тип | Права | Значение
Type | TSelectionType | Только чтение | Тип выделения
DocumentItems | IDocumentItems | Только чтение | Выделенные документы
Documents | IDocumentsCollection | Только чтение | Объекты типа IDocument, соответствующие выделенным документам
PageItems | IPageItems | Только чтение | Выделенные страницы
Pages | IPagesCollection | Только чтение | Объекты типа IPage, соответствующие выделенным страницам

Замечание. Если документ свернут, свойство DocumentItems[i].PageItems.Count возвращает "0".


IShellRational

Назначение

Служит для представления дроби.

Свойства

Имя | Тип | Права | Значение
Numerator | int | Чтение/запись | Числитель
Denominator | int | Чтение/запись | Знаменатель


IShellRect

Назначение

Служит для представления прямоугольника.

Методы

Определение | Описание
ToString() : string | Представление прямоугольника в виде строки вида "[left,top,right,bottom]"

Свойства

Имя | Тип | Права | Значение
Left | int | Чтение/запись | Левая координата
Right | int | Чтение/запись | Правая координата
Top | int | Чтение/запись | Верхняя координата
Bottom | int | Чтение/запись | Нижняя координата


IShellRects

Назначение

Коллекция объектов IShellRect.


ITaskWindow

Назначение

Служит для представления окна задания.

Методы

Определение | Описание
DocumentState( document : IDocument ) : TDocumentState | Определяет состояние документа в окне задач. Замечание. Метод может вызываться только из основного потока.
OpenDocument( document : IDocument ) | Открывает документ для редактирования с помощью скрипта. Метод можно вызывать также в случае, если документ открыт в редакторе документа с правами только на чтение. При вызове данного метода происходит изменение состояния документа.
CloseDocument( document : IDocument ) | Закрывает документ из состояния для редактирования из скрипта. При вызове данного метода происходит изменение состояния документа.
EditDocument( document : IDocument, page : IPage ) : IDocumentEditor | Открывает документ для редактирования в редакторе документа. Замечание. В случае успешного открытия документа метод возвращает объект типа IDocumentEditor. Иначе возвращает null. При вызове данного метода происходит изменение состояния документа.
CloseEditorWindow() | Закрывает открытый редактор документа. Внимание! При закрытии редактора документа все несохраненные изменения будут утеряны. При вызове данного метода происходит изменение состояния документа.

Свойства

Имя | Тип | Права | Значение
Handle | int | Только чтение | Дескриптор окна
MainWindow | IMainWindow | Только чтение | Главное окно
Batch | IBatch | Только чтение | Пакет
Mode | TTaskWindowMode | Чтение/запись | Режим показа окна
DocumentsWindow | IDocumentsWindow | Только чтение | Окно документов
EditorWindow | IDocumentEditor | Только чтение | Редактор документа


ITextEditor

Назначение

Служит для представления редактора поля документа.

Методы

Определение | Описание
GetSelection( startPos : int, endPos : int ) | Определяет начало и конец выделения. Если выделение отсутствует, присваивает параметрам startPos и endPos значение "0".
SetSelection( startPos : int, endPos : int ) | Устанавливает новое выделение
ApplyChanges() : bool | Применяет сделанные изменения
ResetChanges() | Сбрасывает сделанные изменения
ShowSuggestList() | Показывает список подсказок. Если подсказок нет, ничего не происходит.

Свойства

Имя | Тип | Права | Значение
Control | IFieldControl | Только чтение | Элемент управления поля
Modified | bool | Только чтение | Модифицировано ли поле
Text | string | Только чтение | Текст поля
FormWindow | IFormWindow | Только чтение | Окно формы


IToolbar

Назначение

Коллекция объектов IToolbarButton. Служит для представления панели инструментов.

Методы

Определение | Описание
Reset() | Сбрасывает изменения и возвращает панель инструментов в исходный вид
Find( commandId: TCommandID ) : int | Находит в коллекции индекс кнопки с указанным идентификатором
Delete( index: int ) | Удаляет элемент по его индексу в коллекции
InsertButton( index: int, commandId: TCommandID, text: string ) | Добавляет на панель элемент с идентификатором команды commandId на позицию Index с текстом Text. Можно использовать любые идентификаторы (в том числе CI_Separator), кроме CI_SubMenu и CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.
AppendButton( commandId: TCommandID, text: string ) | Добавляет элемент с идентификатором команды commandId и текстом Text в конец меню. Можно использовать любые идентификаторы (в том числе CI_Separator), кроме CI_SubMenu и CI_Undefined. Для CI_Separator параметр Text будет игнорироваться.

Свойства

Имя | Тип | Права | Значение
Type | TCommandBarType | Только чтение | Тип панели
Name | string | Только чтение | Имя панели
Visible | bool | Чтение/запись | Видна ли панель инструментов


IToolbarButton

Назначение

Служит для представления кнопки на панели управления.

Свойства

Имя | Тип | Права | Значение
Command | TCommandID | Только чтение | Идентификатор команды. Возвращаемое значение не может равняться CI_SubMenu. Если среди значений TCommandID отсутствует идентификатор команды, возращается CI_Undefined
Enable | bool | Чтение/запись | Определяет включенность/выключенность кнопок. Если значение свойства равно false, то все кнопки с указанным идентификатором Command будут выключены. Если значение свойства равно true, включенность/выключенность зависит от внутренней логики программы.
Visible | bool | Чтение/запись | Видимость кнопки или разделителя
Text | string | Чтение/запись | Текст на кнопке


IToolbars

Назначение

Коллекция объектов IToolbar.


TCommandBarType

Описание

Тип меню (панели инструментов). Используется в интерфейсе IToolbar.

Допустимые значения:

  • CBT_Undefined = 0 - Панель не определена.
  • CBT_GroupVerification = 1 - Панель инструментов с командами групповой верификации.
  • CBT_FieldVerification = 2 - Панель инструментов с командами полевой верификации.
  • CBT_Standard = 3 - Стандартная панель инструментов.
  • CBT_Navigation = 4 - Панель навигации при сканировании и распознавании. Содержит кнопки К предыдущему документу, К следующему документу, Предыдущий объект верификации и т.д.
  • CBT_Views = 5 - Панель переключения вида. Содержит кнопки Детали и Эскизы страниц.
  • CBT_Tasks = 6 - Панель инструментов с командами операций над заданиями.
  • CBT_Setup = 7 - Панель инструментов с основными кнопками управления проектом. Содержит кнопки Определения документов…, Типы пакетов…, Свойства проекта… и другие.
  • CBT_ScanAndRead = 8 - Панель инстументов с кнопками импорта, распознавания и других операций над изображениями.
  • CBT_UserToolbar = 9 - - Панель инстументов, добавленная пользователем в настройках внешнего вида этапа.


TCommandID

Описание

Идентификатор команды.

Допустимые значения:

Общие команды
  • CI_SubMenu - Заголовок подменю
  • CI_Separator - Разделитель
  • CI_Undefined - Неопределенный идентификатор
Команды меню Файл
  • CI_NewProject - Новый проект…
  • CI_BrowseProject - Открыть проект…
  • CI_BrowseWebProject - Открыть проект на сервере…
  • CI_CloseProject - Закрыть проект
  • CI_UploadProject - Загрузить проект на сервер…
  • CI_Save - Сохранить
  • CI_NewBatch - Новый пакет…
  • CI_LoadImage - Загрузить изображения…
  • CI_ScanImages - Сканировать изображения…
  • CI_ImportImage - Импортировать изображения…
  • CI_Export - Экспортировать
  • CI_ExportToFile - Экспортировать данные в файлы
  • CI_ExportImages - Экспортировать изображения в файлы
  • CI_ExportToDB - Экспортировать в базу данных
  • CI_RecentFiles - Открыть предыдущий проект
  • CI_Exit - Выход из ABBYY FlexiCapture 10
Команды меню Правка
  • CI_EditUndo - Отменить
  • CI_EditRedo - Повторить
  • CI_EditCut - Вырезать
  • CI_EditCopy - Копировать
  • CI_EditPaste - Вставить
  • CI_EditClear - Удалить
  • CI_MergeDocuments - Объединить в документ
  • CI_SplitDocuments - Разделить документ
  • CI_EditSelectAll - Выделить все
  • CI_EditFind - Найти…
  • CI_EditFindNext - Найти следующий
  • CI_MoveToNextItem - К следующему документу
  • CI_MoveToPreviousItem - К предыдущему документу
  • CI_ImageClean - Очистить изображение
  • CI_ImageInvert - Инвертировать изображение
  • CI_ImageMirrorHorizontal - Перевернуть горизонтально
  • CI_ImageMirrorVertical - Перевернуть вертикально
  • CI_ImageRotate90 - Повернуть на 90° по часовой стрелке
  • CI_ImageRotate270 - Повернуть на 90° против часовой стрелки
  • CI_ImageRotate180 - Повернуть на 180°
  • CI_ImageChangeResolution - Изменить разрешение
  • CI_ExportImage - Сохранить изображение

Дополнительные команды для удаленной станции Верификации (полевая верификация):

  • CI_EditDeleteAll - Удалить все символы
  • CI_EditInsertLineBreak - Вставить пустую строку
  • CI_VerificationMergeSymbols - Объединить символы
Команды меню Вид
  • CI_ShowTestBatches - Показать тестовые пакеты
  • CI_ShowWorkBatches - Показать пакеты
  • CI_ShowQueues - Показать очереди
  • CI_ShowDetails - Показать детали
  • CI_ShowThumbnails - Показать эскизы страниц
  • CI_SetupDetailsView - Настройка столбцов
  • CI_DocModeImage - Редактор документов в режиме изображений
  • CI_DocModeForm - Редактор документов в режиме данных
  • CI_DockImageOnTop - Изображение сверху от документа
  • CI_DockImageOnBottom - Изображение снизу от документа
  • CI_DocImageOnLeft - Изображение слева от документа
  • CI_DocImageOnRight - Изображение справа от документа
  • CI_DocImageUndocked - Не закреплено
  • CI_DocErrorsOnTop - Ошибки сверху от документа
  • CI_DocErrorsOnBottom - Ошибки снизу от документа
  • CI_DocErrorsOnLeft - Ошибки слева от документа
  • CI_DocErrorsOnRight - Ошибки справа от документа
  • CI_ImageScalePageWidth - Подобрать по ширине масштаб изображения
  • CI_ImageScalePageHeight - Подобрать по высоте масштаб изображения
  • CI_ImageScaleWholePage - Подобрать наилучший масштаб изображения
  • CI_ImageScale400 - Установить в 400% масштаб изображения
  • CI_ImageScale200 - Установить в 200% масштаб изображения
  • CI_ImageScale100 - Установить в 100% масштаб изображения
  • CI_ImageScale75 - Установить в 75% масштаб изображения
  • CI_ImageScale50 - Установить в 50% масштаб изображения
  • CI_ImageScale25 - Установить в 25% масштаб изображения
  • CI_ImageScaleCustom - Выбрать масштаб изображения
  • CI_ImageScaleZoomIn - Увеличить масштаб изображения
  • CI_ImageScaleZoomOut - Уменьшить масштаб изображения
  • CI_TextSizeLargest - Наибольший размер текста данных
  • CI_TextSizeLarger - Большой размер текста данных
  • CI_TextSizeMedium - Средний размер текста данных
  • CI_TextSizeSmaller - Маленький размер текста данных
  • CI_TextSizeSmallest - Наименьший размер текста данных
  • CI_ViewToolbarsLayout - Показать панель инструментов в редакторе документов
  • CI_ShowFormatErrorInBallon - Показывать ошибки формата во всплывающей подсказке
  • CI_ShowFormatErrorInErrorView - Показывать ошибки формата вверху
  • CI_ShowFormatErrorInFormView - Показывать ошибки формата внизу
  • CI_BWImageMode - Черно-белый режим показа изображений
  • CI_ThumbnailSizeSmallest - Минимальный размер эскизов
  • CI_ThumbnailSizeDefault - Размер эскизов по умолчанию
  • CI_ThumbnailSizeLargest - Максимальный размер эскизов
  • CI_ThumbnailSizeIncrease - Увеличить размер эскизов
  • CI_ThumbnailSizeDecrease - Уменьшить размер эскизов
  • CI_ViewToolbarsStandard - Показать/спрятать стандартную панель инструментов
  • CI_ViewToolbarsDocuments - Показать/спрятать панель инструментов представления документов
  • CI_ViewToolbarsNavigation - Показать/спрятать панель инструментов навигации
  • CI_ViewToolbarsScanAndRead - Показать/спрятать панель инструментов сканирования
  • CI_ViewToolbarsProjectSetup - Показать/спрятать панель инструментов настройки проекта
  • CI_ViewToolbarsTasks - Показывает/прячет панель инструментов очередей и заданий
  • CI_ShowToolbar1 - Показать панели инструментов
  • CI_ViewStatusbar - Показать/спрятать строку состояния
  • CI_ViewFullScreen - Переключиться в полноэкранный/оконный режим
  • CI_Refresh - Обновить
  • CI_ViewProperties - Показать свойства

Дополнительные команды для удаленной станции Верификации (групповая верификация):

  • CI_ShowFieldImage - Показать/Убрать изображение поля
  • CI_ShowFieldImageOnTop - Показывать изображение поля сверху
  • CI_ShowFieldImageOnBottom - Показывать изображение поля снизу
  • CI_ShrinkToFit - Подобрать наилучший масштаб изображения поля
  • CI_ContextImageScale400 - Установить в 400% масштаб изображения поля
  • CI_ContextImageScale200 - Установить в 200% масштаб изображения поля
  • CI_ContextImageScale150 - Установить в 150% масштаб изображения поля
  • CI_ContextImageScale100 - Установить в 100% масштаб изображения поля
  • CI_ContextImageScale75 - Установить в 75% масштаб изображения поля
  • CI_ContextImageScale50 - Установить в 50% масштаб изображения поля
  • CI_ShowCharacterImage - Показать изображение символа
  • CI_ShowActionsToolBar - Показать/Спрятать панель инструментов Действия
  • CI_ShowVerInfoBar - Показать/Спрятать панель информации
  • CI_VerificationOptions - Показать свойства верификатора

Дополнительные команды для удаленной станции Верификации (полевая верификация):

  • CI_ShowRecognizedText - Показать распознанный текст
  • CI_ShowSymbolImagesCutting - Включить/Выключить обрезку изображения символа
  • CI_ShowSpecialSymbols - Показать/Спрятать специальные символы
  • CI_ShowAnalogousFields - Показать/Спрятать аналогичные поля
Команды меню Задание
  • CI_GetTask - Получить задание
  • CI_ReturnTask - Закрыть задание
  • CI_ShowTaskComment - Показывать комментарий к заданию
  • CI_CancelTask - Отменить задание
  • CI_DeferTask - Отложить задание
  • CI_SendTaskToException - Отправить задание в исключения
  • CI_SendTaskToRescan - Отправка на повторное сканирование
  • CI_SendTaskToStage - Отправить задание на этап
  • CI_AutoTaskReceive - Включить/выключить автоматическое получение заданий
  • CI_CI_AddDocsToMarked - Добавить документы к отмеченным
  • CI_UnmarksDocs - Снять отметку с документов
  • CI_MarkDocsToException - Отметить документы для отправки в Исключения
  • CI_MarkDocsToRescan -Отметить документы для отправки на повторное сканирование
  • CI_MarkDocsToStage - Отметить документы для отправки на этап
  • CI_ViewMarkedGroupList - Просмотреть список отмеченных
Команды меню Распознавание
  • CI_ApplyTemplate - Проанализировать
  • CI_SetDocTemplate - Наложить определение документа
  • CI_ReadActive - Распознать
Команды меню Верификация
  • CI_VerifyAll - Начать верификацию
  • CI_GotoNextError - Следующий объект верификации
  • CI_GotoPrevError - Предыдущий объект верификации
  • CI_GotoNextAssembleError - Следующий документ с ошибками сборки
  • CI_GotoPrevAssembleError - Предыдущий документ с ошибками сборки
  • CI_GotoNextUnkCharacher - Следующий неуверенный символ
  • CI_GotoPrevUnkCharacher - Предыдущий неуверенный символ
  • CI_GotoNextRuleError - Следующая ошибка правил
  • CI_GotoPrevRuleError - Предыдущая ошибка правил

Дополнительные команды для удаленной станции Верификации (групповая верификация):

  • CI_VerificationConfirmAll - Подтвердить все
  • CI_VerificationPostponeAll - Отложить все
  • CI_VerificationToggleSelected - Переключить значение для выбранного объекта
  • CI_VerificationNextPage - Следующая страница верификации
  • CI_VerificationPrevPage - Предыдущая страница верификации
  • CI_VerificationClose - Закрыть верификатор

Дополнительные команды для удаленной станции Верификации (полевая верификация):

  • CI_VerificationConfirmField - Подтвердить поле
  • CI_VerificationNextUncertain - Следующий неуверенный символ
  • CI_VerificationPrevUncertain - Предыдущий неуверенный символ
  • CI_VerificationNextField - Следующее поле
  • CI_VerificationPrevField - Предыдущее поле
Команды меню Проект
  • CI_ShowTemplatesList - Показать список определений документов
  • CI_ShowBatchTypes - Показать список типов пакетов
  • CI_ShowImportProfiles - Показать список профилей импорта
  • CI_SwitchToAdminMode - Переключиться в режим администратора
  • CI_ProtectProject - Защитить проект паролем
  • CI_UnprotectProject - Снять пароль с проекта
  • CI_ExportProject - Экспортировать проект
  • CI_ImportProject - Обновление проекта
  • CI_ViewProjectProperties - Показать свойства проекта
  • CI_CreateTestCopy - Создать тестовую копию
  • CI_CommitTestCopy - Применить тестовую копию
  • CI_DeleteTestCopy - Удалить тестовую копию
Команды меню Сервис
  • CI_DocPriorityLowest - Установить документу самый низкий приоритет
  • CI_DocPriorityLow - Установить документу низкий приоритет
  • CI_DocPriorityNormal - Установить документу обычный приоритет
  • CI_DocPriorityHigh - Установить документу высокий приоритет
  • CI_DocPriorityHighest - Установить документу самый высокий приоритет
  • CI_UpdateDocToLatestVersion - Обновить документы до последней версии проекта
  • CI_Reanalize - Повторный анализ
  • CI_Reread - Повторное распознавание
  • CI_AssembleDocuments - Обновить сборку
  • CI_RecheckRules - Перепроверить правила
  • CI_CheckBatchIntegrity - Проверить целостность пакета
  • CI_BatchPriorityLowest - Установить пакету самый низкий приоритет
  • CI_BatchPriorityLow - Установить пакету низкий приоритет
  • CI_BatchPriorityNormal - Установить пакету обычный приоритет
  • CI_BatchPriorityHigh - Установить пакету высокий приоритет
  • CI_BatchPriorityHighest - Установить пакету самый высокий приоритет
  • CI_ChangeBatchType - Изменить тип пакета
  • CI_ViewOptions - Показать настройки
Команды локального меню поля
  • CI_ExecuteCustomAction - Выполнить пользовательский скрипт
Пользовательские команды
  • CI_UserCommand - Команды пользователя
Команды меню Справка
  • CI_HelpAbbyyWebSite - Web-сайт ABBYY
  • CI_HelpAbout - О программе ABBYY FlexiCapture
  • CI_HelpContent - Вызов справки
  • CI_HelpPurchaseInfo - Как купить продукцию ABBYY
  • CI_HelpSendFeedback - Отправить отзыв…
  • CI_HelpTechSupport - Техническая поддержка


TDockingType

Описание

Сторона основного окна, к которой примыкает данное окно.

Допустимые значения:

  • DT_Undefined = 0 - Сторона не определена или окна не смежные.
  • DT_Left = 1 - Левая сторона.
  • DT_Right = 2 - Правая сторона.
  • DT_Top = 3 - Верхняя сторона.
  • DT_Bottom = 4 - Нижняя сторона.


TDocumentState

Описание

Состояние документа в окне задач. Используется в интерфейсе ITaskWindow.

Допустимые значения:

  • DS_Locked = 0 - Документ заблокирован. Никакие действия с документом невозможны.
  • DS_Edited = 1 - Документ редактируется в редакторе документа.
  • DS_Closed = 2 - Документ в данный момент закрыт. Его можно как начать редактировать, так и открыть.
  • DS_Opened = 3 - Документ открыт. Документ в данном состоянии можно изменять из скрипта.
  • DS_EditedAndOpened = 4 - Документ редактируется в редакторе документа и доступен для редактирования из скрипта.
  • DS_EditedAndLocked = 5 - Документ открыт в редакторе документа и заблокирован для любых действий.


TErrorType

Описание

Тип ошибки. Используется в интерфейсе IErrorControl.

Допустимые значения:

  • ET_Assembling = 0 - Ошибка сборки
  • ET_Rule =1 - Ошибка правил
  • ET_Format = 2 - Ошибка формата


TSelectionType

Описание

Тип выделения. Используется в интерфейсе ISelection.

Допустимые значения:

  • ST_Undefined = 0 - Выделение не определено
  • ST_Documents = 1 - Выделены документы
  • ST_Pages = 2 - Выделены страницы


TTaskWindowMode

Описание

Режим показа окна. Используется в интерфейсе ITaskWindow.

Допустимые значения:

  • TWM_Undefined = 1 - Вид не определен.
  • TWM_ListView = 1 - Детали.
  • TWM_ThumbnailView = 2 - Эскизы страниц.


TTextSize

Описание

Размер текста. Используется в интерфейсе IFormWindow.

Допустимые значения:

  • TS_Undefined = 0 - Размер текста не определен
  • TS_Smallest = 1 - Самый маленький размер текста
  • TS_Smaller = 2 - Размер текста меньше среднего
  • TS_Medium = 3 - Средний размер текста
  • TS_Larger = 4 - Размер текста больше среднего
  • TS_Largest = 5 - Самый большой размер текста


TUserRole

Описание

Роль пользователя. Используется в интерфейсе IMainWindow.

Допустимые значения:

  • UR_Undefined = 0 - Роль не определена
  • UR_VerificationOperator =1 - Оператор верификации
  • UR_SeniorVerificationOperator = 2 - Старший оператор верификации


TWorkWindowType

Описание

Тип рабочего окна.

Допустимые значения:

  • WWT_Undefined = 0 - Тип окна неопределен.
  • WWT_Task = 1 - Окно задания.


Создание машиночитаемых форм

Анкеты, карточки социального страхования, опросные листы, бюллетени, гарантийные талоны и т.д. - все это формы, используемые для сбора разного рода информации.

Что отличает формы от обычных документов?

  1. В отличие от обычных документов форма всегда имеет фиксированный набор полей.
  2. В каждом поле формы может находиться информация строго определенного содержания: например, в поле "Фамилия" может находиться только фамилия (если, конечно, заполнивший форму не вписал туда по ошибке адрес), в поле Дата - дата и т.д.

Использование форм обычно подразумевает получение информации от большого числа респондентов с последующей компьютерной обработкой полученных данных.

Ручной ввод информации в компьютер очень трудоемок. Более того, такая форма работы ведет к большому количеству ошибок (опечаток), на исправление которых уходит много времени. Поэтому эффективнее автоматизировать процесс ввода форм.

Процесс автоматизированного ввода форм состоит из следующих стадий:

  1. Настройка программы автоматизированного ввода на обработку формы данного образца (описание формы, выделение на образце формы данных для распознавания).
  2. Создание изображения формы (сканирование).
  3. Обработка изображений программой автоматизированного ввода (распознавание и проверка данных).
  4. Экспорт данных во внешнюю информационную систему.

Наиболее просто и эффективно производится автоматическая обработка форм, удовлетворяющих специальным требованиям. Им и будет посвящена эта глава.

Машиночитаемая форма
Элементы машиночитаемой формы
Заполнение формы
Виды машиночитаемых форм
Выбор вида формы
Требования к машиночитаемым формам


Машиночитаемая форма

При обработке форм программа автоматизированного ввода сталкивается с рядом задач, от решения которых зависит качество распознавания данных из формы.

Выделим две из них:

  1. Определение положения элементов на изображении формы.
  2. Отделение внесенной в форму информации (данных) от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Чтобы облегчить программе решение этих задач, создаются специальные машиночитаемые формы.

Для решения первой задачи машиночитаемым формам выдвигается требование точного соответствия формы образцу. Это значит, что у всех форм одного образца расположение элементов формы должно быть одинаковым (совпадать на просвет).

Для решения второй задачи к машиночитаемым формам предъявляется требование специального дизайна формы: он должен позволять корректно отделить собственно данные от элементов формы: разметки текста, границ полей, фона, пояснительных надписей и др.


Элементы машиночитаемой формы

Рассмотрим подробнее элементы машиночитаемой формы:

Текст
Поле для ввода
Поле метки
Группа меток
Репер
Разделитель
Идентификатор
Картинка
Таблица
Группа элементов


Текст

Текст - это элемент машиночитаемой формы, представляющий собой описательный текст (название формы, название полей, пояснения к полям и т.д.)


Поле для ввода

Поле для ввода - это элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы. Для удобства ввода символов в таком поле может присутствовать разметка. Поле для ввода обычно сопровождается описательным текстом, поясняющим смысл вводимого текста.

Показать поле для ввода

Существует несколько типов разметки текста:

Текст на линии | Тип разметки текста, при котором ограничителем текста является линия снизу.
Буквы в рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки не изолированы друг от друга.
Буквы в изолированных рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки изолированы друг от друга.
Буквы в гребенке | Тип разметки текста, при которой ограничителем текста является гребенка.
Текст в рамке | Тип разметки текста, при котором ограничителем текста является рамка.
Текст в рамке с гребенкой | Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки.


Поле метки

Поле метки - это элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении формы вносится метка (галочка, крест, сплошная закраска и т.д.).

Поле метки обычно сопровождается описательным текстом, поясняющим смысл метки.

Показать поле метки

Поле метки может иметь ограничители следующих типов:

Квадрат
Круг
Подчеркивание

Возможны и другие типы ограничителей поля метки: многоугольник, овал и т.д.


Группа меток

Группа меток - это элемент машиночитаемой формы, объединяющий несколько находящихся вблизи друг от друга полей меток, из которых при заполнении формы будет заполнено только одно. Группа меток обычно сопровождается описательным текстом, поясняющим смысл группы.

Показать группу меток


Репер

Репер - это элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

Первое, что определяется при распознавании данных из формы, это принадлежность формы к тому или другому образцу. Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование точного соответствия формы образцу. Количество и расположение реперов является основной характеристикой принадлежности формы к тому или другому образцу. Настроенная на работу с формами данного образца программа автоматизированного ввода ориентирует форму, т.е. пытается расположить её так, чтобы реперы совпали с реперами образца. Если реперы совпали, то программа может определить, к какому образцу относится данная форма и где находятся данные для распознавания.

Стандартные реперы:

Черный квадрат
Уголок
Крест
Черный прямоугольник

Присутствие стандартных реперов на машиночитаемой форме крайне желательно, хотя в некоторых случаях в качестве репера может использоваться разделитель, описательный текст или штрих-код. Эти варианты реперов считаются приемлемыми, но по возможности их следует избегать, т.к. они могут привести к ухудшению распознавания формы.


Разделитель

Разделитель - это элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Разделитель используется для визуального разделения формы на несколько смысловых частей.


Идентификатор

Идентификатор - это элемент машиночитаемой формы, однозначно характеризующий форму данного образца. Если при распознавании невозможно однозначно определить по реперам принадлежность формы к образцу (т.е. реперы у нескольких форм различных образцов совпадают), то для точного определения используется идентификатор. Рекомендуется в качестве идентификатора использовать штрих-код.

Штрих-код - это набор штриховых знаков, кодирующих информацию посредством чередующихся полос черного и белого цвета различной ширины.

Показать штрих-код

Возможно использование и других элементов в качестве идентификаторов.


Картинка

Картинка - это элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в графическом формате.

Любое графическое изображение, место для печати или подписи - все это картинки.


Таблица

Таблица содержит столбцы с однотипными элементами.

Столбцы таблицы могут содержать элементы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.

Таблица может содержать строку с заголовками столбцов.


Группа элементов

Группа элементов - элемент машиночитаемой формы, предназначенный для объединения в группу нескольких логически связанных элементов.


Заполнение формы

Форма может быть заполнена следующими способами:

  • От руки.
  • На матричном принтере.
  • На пишущей машинке.
  • Типографским способом. К данному способу относится также заполнение на принтерах (не матричных), которые обеспечивают разрешение не менее 300 точек на дюйм.
  • Заполнение представляет собой комбинацию любых способов заполнения, перечисленных в предыдущих пунктах.


Виды машиночитаемых форм

Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование к дизайну формы: дизайн формы должен позволять корректно отделить внесенную в форму информацию от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Существует два различных подхода для реализации этого требования:

  1. Дизайн формы создается таким образом, чтобы при сканировании формы и последующей очистке изображения разметка текста, границы полей и фон исчезали.
  2. Дизайн формы создается таким образом, чтобы на изображении формы после сканирования и очистки изображения были четко выделены разметка текста и границы полей.

При использовании первого подхода на изображении формы после сканирования и очистки остаются только реперы, описательный текст и информация, которую ввели при заполнении формы. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении данные, не ограниченные никакой разметкой, что сузит задачи программы и повысит качество распознавания.

Для реализации этого подхода используются формы следующих видов: цветные фоновые формы, черно-белые формы с растровым фоном, черно-белые формы с растровыми границами, и черно-белые линейчатые формы.

При использовании второго подхода на изображении формы после сканирования остаются реперы, описательный текст, информация, которую ввели при заполнении формы, а также разметка текста и границы полей. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении именно ограниченные разметкой данные. Отсутствие разметки приведет к ухудшению качества распознавания.

Для реализации этого подхода используются черно-белые линейчатые формы.


Цветные фоновые формы

Цветные фоновые формы - это формы с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация. Например, Серые фоновые формы. Фон этих форм выполнен серым цветом.

Частным случаем цветных фоновых форм являются форма, на которых фоном выделены только ограничители полей для ввода информации.

Знакоместо - это прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.)

Цвет фона имеет большое значение, т.к. при сканировании фон таких форм должен "пропадать". Обычно фон имеет светлый "розово-оранжевый" или "зеленый" оттенок. Существуют цвета, рекомендованные для использования в качестве фона для фоновых форм (подробнее см. Рекомендуемые цвета для разработки цветных фоновых форм).

Показать цветную фоновую форму

В идеальном случае после сканирования и очистки изображения с цветной фоновой формы должны "пропадать" все элементы, за исключением реперов и информации, внесенной во время заполнения формы.

Пояснительная информация может оставаться на форме (если она выполнена в черном цвете); но можно добиться того, что и этот элемент будет "пропадать" при сканировании. Для этого пояснительную информацию необходимо выполнить в том же цвете, что и фон формы, но с большей насыщенностью.

Выбирая между черным цветом и цветом фона для пояснительной информации, учитывайте следующее:

  • Размер файла изображения формы с пояснительной информацией, выполненной в черном цвете (или любом другом, который останется после сканирования на форме), больше, чем размер файла изображения формы с пояснительной информацией, выполненной в цвете фона (или любом другом, который исчезнет после сканирования на форме).
  • Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов на расстояние, не меньшее 1,5-2 мм. В случае пояснительной информации, выполненной в цвете фона, можно не так пристально отслеживать расстояние между пояснительной информацией и другими элементами формы.

Форма с пояснительной информацией, выполненной в черном цвете, является более читаемой. Рекомендуется использовать именно черный цвет для пояснительной информации, если на форме отсутствуют реперы.

Совет
Для настройки определения документов с пояснительной информацией, выполненной в цвете фона, сканируйте форму в цвете или оттенках серого, иначе границы элементов формы и пояснительная информация не будут видны.

Рассмотрим приемы обработки фоновых форм. Технологической основой "пропадания" фона при сканировании является отсечение цвета фона с помощью цветной лампы или цветного фильтра. Цвет лампы подбирается в зависимости от того, какой оттенок имеет цвет фона "розово-оранжевый" или "зеленый".

Итак, сканирование производится:

  • На цветном сканере с программной фильтрацией красного или зеленого цвета в зависимости от оттенка фона формы.
  • На нецветном сканере с "красной лампой" (Red-Lamp) или "зеленой лампой" (Green-Lamp) соответственно (аппаратная фильтрация цвета).
  • На нецветном сканере с использованием белой лампы и красного или зеленого фильтра соответственно. Качество фильтрации, в отличие от первого и второго вариантов, хуже - может остаться фон формы или исчезнуть часть значимой информации.
  • На нецветном сканере с использованием белой лампы и без фильтра.

При сканировании с использованием белой лампы возможно отсечение различных цветов светлых оттенков без фильтрации. Исчезновение фона достигается за счет слабой насыщенности цвета фона. В этом случае подбор цвета формы и его насыщенность должны производиться опытным путем для каждого конкретного сканера.

Замечание. У многих цветных сканеров, кроме того, есть режим программной фильтрации синего цвета. Но не рекомендуется выполнять формы в "синих" оттенках, поскольку нельзя гарантировать, что все формы будут заполнены только черной, а не темно-синей ручкой. В случае сканирования форм с фильтрацией синего цвета данные, написанные синей ручкой, "исчезнут".

Подбор цвета

Если выбирать между зелеными и красными оттенками форм, то надо иметь в виду, что красно-оранжевые оттенки предпочтительнее, так как они являются максимально контрастными к синему цвету, что улучшает качество полученных при сканировании изображений и распознавания текста, написанного синей ручкой.

В разделе Рекомендуемые цвета для разработки цветных фоновых форм приводится список рекомендуемых цветов, которые "пропадают" при сканировании форм практически любым сканером. Для каждого конкретного сканера можно также получить у производителя или дилера список цветов в стандарте Pantone (или любом другом), которые можно использовать с данным сканером.


Черно-белые формы с растровым фоном

Черно-белые формы с растровым фоном - это формы с растровым фоном (растр - мелкие черные точки), на котором белыми прямоугольниками выделены знакоместа

Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
(а также поля меток и др.), в которые при заполнении формы вносится информация. Фон должен состоять из отдельных точек. Рекомендуемый размер точек растра не более 0,1 мм. Расстояние между точками растра должно быть около 1 мм. Размер точек и расстояние между точками имеют большое значение, т.к. они должны восприниматься программой распознавания как мусор и удаляться с изображения при очистке. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровым фоном.

Растровый фон не исчезает непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации изображение уже не содержит точек растра после очистки.


Черно-белые формы с растровыми границами

Черно-белые формы с растровыми границами - это формы без фона, на которых границы знакомест,

Знакоместо - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками). Размер точки растра 0,39 - 0,5 пункта. Рекомендуемый размер точки растра 0,39 пункта. Расстояние между точками растра должно быть в пять раз больше размера самой точки.

Размер точек и расстояние между точками имеют большое значение, т.к. при очистке изображения точки растра должны восприниматься программой распознавания как мусор и удаляться с изображения. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровыми границами.

Растровые границы не исчезают непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации после очистки изображение уже не содержит точек растра.


Черно-белые линейчатые формы

Черно-белые линейчатые формы - это формы без фона (как правило), на которых границы знакомест,

Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены черными линиями.

Границы полей черно-белой линейчатой формы остаются на изображении после сканирования и очистки.

Замечание. Формы этого вида особенно чувствительны к качеству заполнения. Под качеством заполнения подразумевается следующее: при заполнении формы текст помещается внутри ограничителей, и становится крайне важно, чтобы внесенный текст не заезжал на ограничители, а в идеале, и не касался их. В случае касания или "наползания" символов на ограничитель программа распознавания будет воспринимать символы и ограничитель как единое целое и качество распознавания ухудшится.


Выбор вида формы

Кроме учета особенностей дизайна и обработки форм необходимо учитывать следующие характеристики видов форм: сложность изготовления, тиражирование, стоимость печати, размер изображения, режим сканирования, время обработки изображения, качество распознавания, расположение пояснительной информации, привлекательность, качество заполнения. Для удобства сравнения видов форм, мы собрали их характеристики в сводную таблицу:

Критерий | Цветная фоновая форма |  | Черно-белая растровая форма |  | Черно-белая линейчатая форма
 | Недостаток | Преимущество | Недостаток | Преимущество | Недостаток | Преимущество
Сложность изготовления |  | Простота изготовления в любом редакторе. | Ограниченные возможности по созданию форм в текстовых редакторах. Важность размера точек растра. |  |  | Простота изготовления в графических редакторах.
Тиражирование | Сложность тиражирования в условиях офиса. |  |  | Возможность тиражирования в условиях офиса. |  | Возможность тиражирования в условиях офиса.
Стоимость печати | Выше стоимость изготовления при типографском способе тиражирования по сравнению с черно-белой формой. |  |  | Ниже стоимость изготовления при типографском способе тиражирования по сравнению с цветной фоновой формой. |  | Ниже стоимость изготовления при типографском способе тиражирования (по сравнению с цветной фоновой формой).
Размер изображения |  | Меньший размер отсканированного изображения. | Больший размер отсканированного изображения. |  | Больший размер отсканированного изображения. |
Режим сканирования | Сканирование только в определенных режимах. |  | Меньшая свобода в подборе яркости и контрастности. |  | Меньшая свобода в подборе яркости и контрастности. |
Время обработки изображения |  | Меньше среднее время автоматической обработки. | Больше среднее время обработки за счет необходимости очистки "мусора" на изображении. |  | Большая вероятность ошибок распознавания при касании или "наползании" символов на ограничители. |
Качество распознавания |  | Очень высокое качество распознавания. |  | Высокое качество распознавания. | Сильно зависит от аккуратности заполнения. | При правильном заполнении высокое качество распознавания.
Расположение пояснительной информации |  | Более гибкое расположение пояснительной информации (вплоть до размещения непосредственно внутри полей для ввода). | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |  | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |
Привлекательность и читаемость | Выбор низкой контрастности фона и цвета пояснительной информации может снизить читаемость формы. | Наиболее привлекательный вид формы. | Менее привлекательные формы. Не очень удобны для зрительного восприятия. |  | Менее привлекательные формы. | Хорошая читаемость.
Качество заполнения |  | Менее чувствительны к выходу текста за рамки полей. | При заполнении формы символы должны быть написаны четко и крупно, чтобы они не были удалены вместе с мусором. | Менее чувствительны к выходу текста за рамки полей. | Очень чувствительны к выходу текста за рамки полей. |


Требования к машиночитаемым формам

Познакомившись с элементами машиночитаемых форм, их видами и типами разметки текста, систематизируем и сформулируем требования, при соблюдении которых созданная форма будет машиночитаемой.

Требования к фону формы
Требования к реперам формы
Требования к полю метки
Требования к геометрическим параметрам разметки текста на формах
Требования к размещению элементов формы
Требования к тиражированию
Требования к заполнению форм от руки


Требования к фону формы

  1. По возможности используйте цветную фоновую форму
    Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.
     или форму с растровыми ограничителями полей ввода.
    Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).
  2. При проектировании цветной фоновой формы используйте цвет, фильтруемый при сканировании. Перечень рекомендованных цветов приведен в разделе Рекомендуемые цвета для разработки цветных фоновых форм.
  3. На цветной фоновой форме пояснительную информацию рекомендуется выполнять в том же цвете, что и фон формы (кроме случаев, когда по каким-либо причинам вы не можете разместить на форме стандартные реперы и вынуждены использовать черный статический текст в качестве реперов). Если цвета фона и пояснительной информации совпадают, то пояснительная информация может быть размещена внутри полей ввода.
  4. Не используйте оттенки синего для фона тех форм, которые будут заполняться от руки. Такой фон может слиться с синей ручкой, что отрицательно скажется на качестве распознавания.


Требования к реперам формы

  1. Рекомендуется размещать на форме стандартные реперы
    Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
     (черные квадраты, уголки, кресты) в количестве 5 штук: четыре - по углам формы (при соединении центров этих реперов должен получаться прямоугольник) и один - на одной из сторон этого прямоугольника.
  2. Если по каким-то причинам на форме невозможно разместить стандартные реперы, то рекомендуются следующие комбинации элементов: а) не менее 2-х горизонтальных разделителей
    Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.
     и 2-х вертикальных разделителей; б) не менее 4-х элементов Текст
    Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.
         и элемент Идентификатор;
    Элемент машиночитаемой формы, однозначно характеризующий данную форму.
     в) возможны другие комбинации этих элементов.
  3. Расстояние от репера до ближайшего элемента формы должно быть не менее 3 мм.
  4. Расстояние от репера до края листа должно быть не менее 8 мм.
  5. Реперы должны быть выполнены в темном цвете, не исчезающем при сканировании. Лучше всего для этого подходит черный цвет.
  6. На форме должны быть реперы, расположенные так, чтобы все заполняемые поля находились внутри ограниченной ими области.

Помимо вышеперечисленных общих требований ко всем реперам, для каждого типа реперов существуют специальные требования:

Требования к Черным квадратам

На формах одного типа все квадраты должны иметь одинаковый размер: от 4х4 мм до 8х8 мм. Рекомендуемый размер 5х5 мм. Прямоугольники не допускаются.

Требования к Уголкам и Крестам

  1. Длина стороны квадрата, описанного вокруг реперов, должна находиться в интервале от 4 мм до 8 мм. Рекомендуемый размер 5 мм.

  2. Размеры реперов одного вида должны быть одинаковыми внутри одной формы.

  3. Стороны реперов должны быть равными.

  4. Толщина линий реперов должны быть одинаковыми внутри одной формы и находиться в интервале от 0,3 мм до 1 мм. Рекомендуемая толщина 0,5 мм.

Требования к элементу Текст (в случае использования элемента в качестве репера)

Должен использоваться шрифт размером не менее 7 пунктов. Для заголовков и крупных надписей рекомендуется использовать шрифт размером не менее 14 пунктов.

Требования к элементу Разделитель (в случае использования элемента в качестве репера)

Толщина линии должна быть не менее 0,8 пункта. Рекомендуемая толщина 0,8-1,5 пункта.

Требования к штрих-коду (в случае использования элемента в качестве репера)

  1. Ширина штрих-кода (расстояние между крайней левой и крайней правой полосами штрих-кода) - 47-50 мм.
  2. Высота штрих-кода (без учета цифр) - 12-15 мм.
  3. Ориентация штрих-кода (направление полос) должна совпадать с ориентацией формы.
  4. Рекомендуется использовать штрих-код типа EAN 13.
  5. Рекомендованное расстояние от штрих-кода до любых элементов формы должно быть не менее 10 мм.


Требования к полю метки

  1. Рекомендуемый размер поля метки
    Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
    - 3,5х3,5 мм; 4х4 мм; 4,5х4,5 мм; 5х5 мм (в случае ограничителя поля метки типа Круг приведенный размер - это размер квадрата, в который вписан ограничитель)
  2. Рекомендуемая толщина линии ограничителя поля метки - 0,4 мм (при любом размере поля метки).


Требования к геометрическим параметрам разметки текста на формах

Точки растра:

  1. В случае использования черно-белой формы с растровыми границами
    Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).
     размер точек растра должен составлять 0,39 пункта.
  2. Оптимальное расстояние между точками растра - в пять раз больше размера самой точки.

    Внимание! Обычно угроза "склеивания" точек возникает по углам знакоместа,

    Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
    поэтому особое внимание следует уделять именно угловым точкам.

    Совет
    Если редактор не позволяет задать расстояние между точками растра, необходимо выбрать такой стиль линии, чтобы ее точки были расположены на достаточном расстоянии друг от друга и не "склеивались" на отсканированном изображении.

Размер знакоместа:

  1. Рекомендуемый размер знакоместа - 4х5 мм, меньший размер знакоместа использовать не рекомендуется, т.к. поля с таким размером знакоместа требуют более аккуратного заполнения, что не всегда удается обеспечить. Также не рекомендуется использовать знакоместа очень большого размера: для получения хорошего результата при распознавании такие поля требуется заполнять непривычно большими буквами. Размер знакоместа должен примерно соответствовать общепринятым нормам письма.
  2. Рекомендуемое расстояние между строчками: не менее 2,5-3 мм. Расстояние между знакоместами по горизонтали: не менее 1-1,2 мм.
Показать иллюстрацию

Толщина линий разметки текста:

  1. Если границы представлены черными линиями, что соответствует типам разметки Текст в рамке, Буквы в изолированных рамках или Буквы в рамках, - толщина линий должна составлять 1 пункт.
Показать иллюстрацию

Гребенки:

  1. Рекомендуемый шаг гребенки в пределах одного поля формы: 5 мм.
  2. Рекомендуемое расстояние между строчками: не менее 7,5-8 мм.
  3. Рекомендуемая высота "гребенки": 0,9-1,2 мм.
  4. Рекомендуемая толщина линий гребенки: 1 пункт.
  5. В случае выполнения границы в виде "гребенки в рамке" минимальное расстояние между рамками должно быть 2,5-3 мм.
Показать иллюстрацию


Требования к размещению элементов формы

  1. Рекомендуется оставлять по краям формы отступы. Это требование вызвано тем, что элементы, размещенные слишком близко к краям формы, могут пропасть при сканировании, что приведет к потере части информации.
  2. Рекомендуемое расстояние между элементами формы: не менее 2 мм.
  3. Рекомендуемое расстояние между полем метки
    Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
    и поясняющим текстом: не менее 2/3 размера поля метки.
  4. Пояснительная информация должна размещаться на форме так, чтобы она не пересекалась с полями для ввода информации.
  5. Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов не менее 1,5-2 мм. Если пояснительная информация выполнена в цвете фона, можно не отслеживать расстояние между пояснительной информацией и другими элементами формы.


Требования к тиражированию форм

При изготовлении форм необходимо выполнять следующие требования:

  1. Формы могут быть изготовлены типографским способом или распечатаны на принтере. Цветные фоновые формы
    Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.
    рекомендуется изготавливать в типографии, в противном случае необходимо тестирование цвета формы на сканере. Необходимо проводить тестирование пробного тиража, полученного из типографии.
  2. Все экземпляры одного типа должны быть отпечатаны с одного образца. Они должны "совпадать на просвет".
  3. Поля формы (расстояние от края листа до ближайшего объекта) должны быть не менее 8 мм, рекомендуется делать поля не менее 12 мм.
  4. Допустимое отклонение по линейным размерам элементов на форме не более 0.15%, что составляет 0,5 мм при формате А4.
  5. При печати формы нужно использовать лазерные принтеры с разрешением не менее 600 точек на дюйм.
  6. Желательно распечатывать формы на одном и том же принтере или на разных принтерах одной и той же модели.
Совет
Не рекомендуется множить машиночитаемые формы с использованием копировальной техники. В этом случае происходит изменение размеров и смещение элементов формы: утолщение рамок или растра ограничителей полей ввода, изменение насыщенности цветов, что ухудшает качество распознавания.


Требования к заполнению форм от руки

Цвет и вид ручки

Формы лучше всего заполнять черной перьевой, капиллярной, гелевой или шариковой ручкой. Темно-синяя или фиолетовая ручка тоже дает хорошие результаты (особенно на цветных фоновых формах). Фломастер приводит к более низкому качеству распознавания из-за заливания мелких деталей. Хуже всего распознаются карандаш и светлая цветная ручка.

Размер и написание букв

Для улучшения качества распознавания формы лучше всего заполнять раздельными прописными буквами. Размер буквы должен быть таким, чтобы буква занимала все пространство знакоместа,

Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
но не касалась его границ.

Если знакоместа явно выделены на форме, т.е. используются следующие типы разметки текста: буквы в рамках, буквы в изолированных рамках, то проще управлять заполняющим форму, т.к. требуемый размер букв явно указан знакоместом и явное наличие знакомест мешает написать буквы слитно.

Сложнее ситуация при использовании разметки текста следующих типов: текст в рамке с гребенкой или буквы в гребенке. Здесь задается ширина знакоместа, но из-за отсутствия полных боковых ограничителей ничто не мешает заполняющему форму написать буквы слитно. И если в первом случае высота знакоместа указана явно, то во втором случае может возникнуть ситуация, когда заполняющий форму впишет слишком маленькие или слишком высокие буквы.

В разметках текста "текст в рамке" или "текст по линии" вообще не содержится информации о ширине знакоместа. Поэтому ничто не мешает заполняющему форму написать буквы слитно, что приведет к значительному ухудшению качества распознавания. В разметке текста "текст по линии" также отсутствует информация о высоте знакоместа, поэтому этот тип разметки не рекомендуется применять для форм, требующих высокого качества распознавания данных.

Помимо размера букв и раздельности написания, важным требованием является требование отсутствия "наползания" символов на ограничители. Это требование не так актуально для цветной фоновой или черно-белой растровой формы, т.к. ограничители в этих формах пропадут после сканирования и очистки изображения. А для черно-белой линейчатой формы это требование очень актуально, т.к. нарушение этого требования влечет за собой значительное ухудшение качества распознавания.

Образец заполнения

Чтобы обратить внимание респондента на перечисленные особенности заполнения формы, на форме рекомендуется указывать образец заполнения. Обычно он содержит рекомендации по заполнению данной формы и образцы букв, цифр и символов, необходимых для заполнения.


Рекомендуемые цвета для разработки цветных фоновых форм

Таблицы содержат примеры цветов фона (с номерами соответствующих пантонов), "исчезающих" при сканировании

  • любым сканером;
    Показать таблицу
  • цветным сканером с фильтрацией красного или нецветным сканером с красной лампой/красным фильтром.
    Показать таблицу


Горячие клавиши

В этом разделе приведен список горячих клавиш, используемых в различных окнах программы. Использование горячих клавиш может сэкономить ваше время и сделать работу с программой более удобной.

Горячие клавиши станции настройки проектов
Горячие клавиши станции верификации
Горячие клавиши станции верификации данных
Горячие клавиши в окне редактора определения документа
Горячие клавиши в окне групповой верификации
Горячие клавиши в окне контекстной верификации


Горячие клавиши на станции настройки проектов

Меню | Команда | Горячие клавиши
Файл | Новый проект… | Ctrl+Shift+N
 | Открыть проект… | Ctrl+Shift+O
 | Сохранить | Ctrl+S
 | Новый пакет… | Ctrl+N
 | Загрузить изображения… | Ctrl+O
 | Сканировать изображения… | Ctrl+K
 | Импортировать изображения… | Ctrl+I
 | Экспортировать в файлы данных… | Alt+Shift+S
 | Экспортировать в базу данных… | Alt+Shift+D
 | Выход | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Найти… | Ctrl+F
 | Найти следующий | F3
 | Перейти > К следующему документу | Ctrl+D
 | Перейти > К предыдущему документу | Ctrl+Shift+D
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Отобразить Тестовые пакеты | Ctrl+Shift+B
 | Отобразить Пакеты | Ctrl+B
 | Отобразить документы в режиме Детали | Alt+1
 | Отобразить документы в режиме Эскизы страниц | Alt+2
 | Отобразить окно документов в режиме Изображение | Ctrl+1
 | Отобразить окно документов в режиме Данные | Ctrl+2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Увеличить размер эскизов | Ctrl+Shift+Num+
 | Уменьшить размер эскизов | Ctrl+Shift+Num-
 | Полноэкранный режим | F11
 | Обновить | F5
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Распознавание | Проанализировать | Ctrl+E
 | Наложить определение документа… | Alt+Shift+E
 | Распознать | Ctrl+R
Верификация | Начать верификацию… | F7
 | Следующий объект верификации | F4
 | Предыдущий объект верификации | Shift+F4
 | Следующий документ с ошибками сборки | F9
 | Предыдущий документ с ошибками сборки | Shift+F9
 | Следующий неуверенный символ | F8
 | Предыдущий неуверенный символ | Shift+F8
 | Следующая ошибка правил | F6
 | Предыдущая ошибка правил | Shift+F6
Проект | Определения документов… | Ctrl+T
 | Типы пакетов… | Ctrl+Shift+T
 | Профили импорта изображений… | Ctrl+Shift+I
Сервис | Обновить до последней версии | Alt+Shift+U
 | Повторный анализ | Ctrl+Alt+E
 | Повторное распознавание | Ctrl+Alt+R
 | Перепроверить правила | Ctrl+F6
 | Проверить целостность пакета | Ctrl+Shift+E
Справка | Вызов справки | F1
Общие команды | Открыть окно документа (если выделен документ или страница) | Enter


Горячие клавиши на станции верификации

Меню | Команда | Горячие клавиши
Файл | Сохранить | Ctrl+S
 | Новый пакет… | Ctrl+N
 | Загрузить изображения… | Ctrl+O
 | Сканировать изображения… | Ctrl+K
 | Экспортировать в файлы данных… | Alt+Shift+S
 | Экспортировать в базу данных… | Alt+Shift+D
 | Выход | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Найти… | Ctrl+F
 | Найти следующий | F3
 | Перейти > К следующему документу | Ctrl+D
 | Перейти > К предыдущему документу | Ctrl+Shift+D
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Отобразить Пакеты | Ctrl+B
 | Отобразить Очереди | Ctrl+Q
 | Отобразить документы в режиме Детали | Alt+1
 | Отобразить документы в режиме Эскизы страниц | Alt+2
 | Отобразить окно документов в режиме Изображение | Ctrl+1
 | Отобразить окно документов в режиме Данные | Ctrl+2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Увеличить размер эскизов | Ctrl+Shift+Num+
 | Уменьшить размер эскизов | Ctrl+Shift+Num-
 | Полноэкранный режим | F11
 | Обновить | F5
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Задания | Получить задание | Ctrl+G
Распознавание | Проанализировать | Ctrl+E
 | Наложить определение документа… | Alt+Shift+E
 | Распознать | Ctrl+R
Верификация | Начать верификацию… | F7
 | Следующий объект верификации | F4
 | Предыдущий объект верификации | Shift+F4
 | Следующий документ с ошибками сборки | F9
 | Предыдущий документ с ошибками сборки | Shift+F9
 | Следующий неуверенный символ | F8
 | Предыдущий неуверенный символ | Shift+F8
 | Следующая ошибка правил | F6
 | Предыдущая ошибка правил | Shift+F6
Сервис | Обновить до последней версии | Alt+Shift+U
 | Повторный анализ | Ctrl+Alt+E
 | Повторное распознавание | Ctrl+Alt+R
 | Перепроверить правила | Ctrl+F6
 | Проверить целостность пакета | Ctrl+Shift+E
Справка | Вызов справки | F1
Общие команды | Открыть окно документа (если выделен документ или страница) | Enter
 | Регистрационные параметры | Ctrl+P


Горячие клавиши на станции верификации данных

Меню | Команда | Горячие клавиши
Файл | Выход | Alt+F4
Вид | Полноэкранный режим | F11
 | Обновить | F5
Задания | Получить задание | Ctrl+G
Справка | Вызов справки | F1

Печать


Горячие клавиши в окне редактора определения документа

Меню | Команда | Горячие клавиши
Определение документа | Добавить страницу… | Ctrl+P
 | Добавить раздел документа… | Ctrl+Alt+S
 | Свойства определения документа… | Ctrl+T
 | Сохранить | Ctrl+S
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Удалить область | Shift+Del
 | Выделить все | Ctrl+A
 | Выделить по типу… | Ctrl+Shift+A
 | Создать поле Текст | Alt+Shift+T
 | Создать поле Метка | Alt+Shift+C
 | Создать поле Группа меток | Alt+Shift+M
 | Создать поле Штрих-код | Alt+Shift+B
 | Создать поле Картинка | Alt+Shift+P
 | Создать поле Таблица | Alt+Shift+L
 | Создать поле Группа | Alt+Shift+G
 | Сгруппировать | Ctrl+G
 | Разгруппировать | Ctrl+Shift+G
 | Копировать текст с изображения… | Ctrl+Alt+C
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Перейти в режим статических элементов | Ctrl+1
 | Перейти в режим разметки полей | Ctrl+2
 | Открыть/закрыть окно со структурой документа | Alt+F1
 | Переключить окно структуры документа в режим отображения полей | Alt+1
 | Переключить окно структуры документа в режим отображения страниц | Alt+2
 | Открыть/закрыть окно Форма данных | Alt+F2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Документ | Начать тестирование. | Ctrl+R
Сервис | Найти объекты на изображении… | Ctrl+D
 | Проверить определение документа | F9
 | Наложить раздел | Ctrl+E
Справка | Вызов справки | F1

Окно разметки изображения

Команда | Горячие клавиши
Активировать инструмент выбора | Esc
Автоматическое выделение объектов | Ctrl+Shift+D
Создать репер | A
Создать разделитель | S
Создать реперный текст | X
Создать реперный штрих-код | D
Создать текстовое поле | T
Создать метку | C
Создать группу меток | M
Создать штрих-код | B
Создать картинку | P
Создать таблицу | L
Создать группу полей | G
Создать область для поля без области | R
Создать нераспознаваемую область | O
Создать столбец таблицы | U
Добавить в таблицу разделитель | F
Удалить разделитель таблицы | E
Выровнять область | Ctrl+Alt+A
Подобрать название | Ctrl+Alt+N
Распознать название с изображения… | Ctrl+Alt+I
Определить тип разметки | Ctrl+Alt+D

Окно структуры документа

Команда | Горячие клавиши
Показать изображение выделенного поля | Enter
Переименовать выделенное поле | F2
Если выделено поле таблицы: |
Добавить столбец с текстом | Alt+Shift+T
Добавить столбец с метками | Alt+Shift+C
Добавить столбец со штрих-кодами | Alt+Shift+B
Добавить столбец с картинками | Alt+Shift+P
Если выделена группа меток: |
Добавить в группу метку | Alt+Shift+C


Горячие клавиши в окне групповой верификации

Меню | Команда | Горячие клавиши
Верификация | Подтвердить все | Enter
 | Отложить все | Ctrl+Enter
 | Изменить статус | Space
 | Следующая страница | Page Down
 | Предыдущая страница | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Выделить все | Ctrl+A
Вид | Изображение поля > Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Увеличить масштаб изображения поля | Ctrl+Num+
 | Уменьшить масштаб изображения поля | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1
Локальное меню символов | Показать изображение символа | F2
 | Подтвердить | Ctrl+E
 | Отложить | Ctrl+R
 | Отменить изменение статуса | Esc

Печать


Горячие клавиши в окне контекстной верификации

Меню | Команда | Горячие клавиши
Верификация | Подтвердить поле | Enter
 | Отложить поле | Ctrl+Enter
 | Следующий неуверенный символ | F4
 | Предыдущий неуверенный символ | Shift+F4
 | Следующее поле | Page Down
 | Предыдущее поле | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Вставить перенос строки | Shift+Enter
 | Объединить символы | Ctrl+M
Вид | Данные поля > Показывать распознанный текст | Alt+F1
 | Данные поля > Нарезка изображений символов | Alt+F2
 | Изображение поля > Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Изображение поля > Масштаб изображения > Увеличить | Ctrl+Num+
 | Изображение поля > Масштаб изображения > Уменьшить | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1

Печать


Сочетания клавиш

Для часто используемых команд можно настроить удобные сочетания клавиш. Для этого выберите в меню пункт Сервис>Опции… и перейдите на закладку Сочетания клавиш.

Для настройки сочетаний клавиш выполните следующие действия:

  1. Выберите тип команды в списке Категории. Если неизвестно, к какому типу относится команда, выберите значение Все команды.
  2. Выберите команду в списке Команды. Список Текущее сочетание содержит текущие сочетания клавиш, при нажатии которых выполняется выбранная команда.
  3. Для выбора нового сочетания перейдите в поле Нажмите клавиши и нажмите комбинацию клавиш. Она будет отображена в поле. Нажмите кнопку Назначить, чтобы сохранить новое сочетание. Если сочетание клавиш используется для другой команды, будет отображено информационное сообщение. Подтвердите смену команды, нажав кнопку Да. Нажмите кнопку Нет, чтобы отказаться от смены команды.
  4. Чтобы удалить сочетание клавиш, назначенное команде, выберите его в списке Текущее сочетание и нажмите кнопку Удалить.
  5. Чтобы восстановить исходные сочетания клавиш для выбранной команды, нажмите кнопку Сбросить. Если необходимо восстановить сочетания клавиш для всех команд, нажмите кнопку Сбросить все.


Различия в правилах FormReader 6.5 и FlexiCapture 10

FormReader 6.5

Поддержка во FlexiCapture 10 Автоматическая конверсия

Проверка полей формы по базе данных

Правило проверки по базе данных

Нет

Проверка суммы чисел

Правило проверки суммы

Нет

Объединение блоков

Правило объединения полей

Да

Проверка с помощью VBScript

Скриптовое правило

Нет

Поиск в списке вариантов

Свойства поля, закладка Тип данных. Список вариантов задается с помощью настройки Ограничения. Применимо для всех типов, за исключением Дата и Число. См. Типы данных текстового поля ввода.

Да

Проверка наложения блоков

Можно реализовать через скриптовое правило

Нет

Проверка с условием

Скриптовое правило

Нет

Замена значений из списка

Свойства поля, закладка Тип данных. Тип Текст, настройка Обработка. См. Типы данных текстового поля ввода.

Да

Замена символов из списка

Свойства поля, закладка Тип данных. Тип Текст, настройка Обработка. См. Типы данных текстового поля ввода.

Да

Нормализация и проверка даты

Свойства поля, закладка Тип данных.. В списке типов следует выбрать Дата, а с помощью списка форматов и поля Ограничения задать все необходимые настройки. См. Типы данных текстового поля ввода.

Нет

Регулярное выражение

Свойства поля, закладка Тип данных. Регулярное выражение можно задать в поле Ограничения. Применимо для всех типов, за исключением Дата и Число. См. Типы данных текстового поля ввода.

Да

Automation-проверка

При использовании Automation-объектов для реализации правил в предыдущей версии, такие компоненты требовали регистрации на целевом компьютере, что осложняло процесс переноса пакетов между компьютерами пользователей.

В настоящей версии всю логику большинства подобных правил целесообразно реализовывать с помощью скрипта.

В тех случаях, когда логика правила столь сложна, что может быть реализована только посредством внешней компоненты, такую компоненту следует вызывать из кода скриптового правила и передавать ей на вход ссылку на объект проверяемого документа.

Нет

Нормализация цены

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.

Нет

Проверка серии и номера паспорта

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.

Нет

Проверка соответствия числа цифрами числу прописью

Правило сравнения суммы цифрами с суммой прописью

Нет

Сравнение и нормализация цены цифрами - цены прописью

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.

Нет


Резервное копирование

Вы можете создать резервную копию ABBYY FlexiCapture и использовать ее для восстановления в случае падения системы.

Резервное копирование

Чтобы создать резервную копию системы:

  1. Остановите работу системы.
  2. Закройте все сессии.
  3. Выполните резервное копирование базы данных средствами MS SQL.
  4. Выполните резервное копирование файлового хранилища, используя какую-либо утилиту для резервного копирования (например, nnBackup).

Восстановление

Для восстановления системы после падения:

  1. Подготовьте компьютер(ы) к установке и установите систему. Вначале установите внешние компоненты, затем серверы и станции.
  2. Подключите лицензионный ключ или активируйте лицензию.
  3. Сделайте восстановление базы данных на SQL сервере из резервной копии.
  4. Сделайте восстановление файлового хранилища.
  5. Откройте Консоль администрирования и мониторинга и подключитесь к имеющейся базе данных. Введите новые пути к базе данных и к файловому хранилищу.

Замечание. Для переноса системы требуются права администратора. В целях упрощения процесса мы рекомендуем, чтобы перенос системы выполнялся администратором, создавшим базу данных. Если перенос системы осуществляется другим администратором, убедитесь, что у него есть права доступа к новому серверу и к базе данных на SQL-сервере.


Дополнительные настройки

Пользователь может гибко настроить процесс обработки документов и интерфейс программы в соответствии со своими задачами. Выберите пункт Опции… в меню Сервис главного окна Станции настройки проектов. При этом откроется диалог, состоящий из 5 закладок:

  • Закладка Выполнение задачи.

    При выполнении задач в фоновом режиме пользователь может контролировать процесс в окне выполнения задач, по журналу, а также по всплывающим подсказкам. Здесь вы можете выбрать, какая именно информация должна заноситься в журнал, и в каких случаях должна появляться подсказка.

  • Закладка Настройки цвета.

    Вы можете изменить цвета элементов интерфейса, таких как рамки для выделения полей в редакторе определения документа, рамки и заливка для выделения полей с ошибками и предупреждениями. Для этого выберите нужный элемент и нажмите на кнопку Цвет.

  • Закладка Обработка документов.

    Распознавание изображений может производиться автоматически, сразу после добавления изображений в пакет. Для этого нужно отметить опцию Автоматически распознавать добавленные изображения.

    При необходимости процесс распознавания можно запускать в фоновом режиме. Для этого отметьте опцию Запустить процесс распознавания в фоновом режиме.

    Если отмечена опция Не экспортировать вручную документы с ошибками, то наряду с успешно обработанными документами будут экспортироваться и документы с ошибками.

    При обнаружении ошибки в скрипте запускается отладчик VisualStudio. Для Active Scripting кода можно отметить опцию Не использовать внешние средства отладки скриптов, в этом случае отладчик запускаться не будет и будет выдаваться сообщение об ошибке.

  • Закладка Диалоги.

    По умолчанию при запуске программы показывается диалог Открытие проекта, где вы можете выбрать один из существующих проектов. Если вы не хотите каждый раз видеть этот диалог, вы можете отменить его показ, отключив опцию Показывать диалог открытия проекта при запуске программы (или непосредственно в диалоге Открытие проекта).

    Программа предупреждает о наличии неопубликованных определений документов при попытке закрыть список определений. Чтобы программа больше не показывала это предупреждение, нужно отменить опцию Показывать предупреждение при наличии неопубликованных определений документов. Также это можно сделать непосредственно в диалоге Неопубликованные определения документов.

    При необходимости выводить уведомление при экспорте документов, содержащих ошибки, выберите опцию Показывать предупреждение при экспорте документов с ошибками.

    Выберите опцию Запрашивать сохранение изменений при переключении между документами для того, чтобы при переключении между документами не терять сделанные изменения.

  • Сочетания клавиш

    На этой закладке можно настроить сочетания клавиш для часто используюмых команд.


Встроенные примеры проектов FlexiCapture

Для того чтобы каждый пользователь мог увидеть работу программы на конкретных примерах и подробнее ознакомиться с функциями программы ABBYY FlexiCapture 10, вместе с программой поставляется стандартный набор готовых проектов. Проекты полностью настроены, содержат готовые определения документов и изображения документов для обработки.

Проекты расположены в папке %allusersprofile%\Application Data\ABBYY\FlexiCapture\10.0\Samples.

Замечание. Для OC Microsoft Windows Vista, Windows 7, Windows Server 2008 и Windows Server 2008 R2 проекты расположены в папке %public%\ABBYY\FlexiCapture\10.0\Samples.

В папке Samples находятся следующие папки:

  1. FlexiCapture - в ней находятся проекты для FlexiCapture.
  2. FlexiLayoutStudio - в этой папке содержатся проекты FlexiLayout Studio, созданные для обработки полуструктурированных документов. Эти проекты можно открыть в приложении ABBYY FlexiLayout Studio 10. Некоторые из них подробно описаны в справке FlexiLayout Studio (см. разделы "Обучение на примерах", "Советы и рекомендации").
  3. FormDesigner - в этой папке содержатся жесткие формы, разработанные в приложении FormDesigner. Файлы с расширением *.fdd можно открыть и редактировать в приложении ABBYY FormDesigner 10. Эти формы используются в следующих проектах FlexiCapture: Banking Card Application и Questionnaire.
  4. Images - в этой папке содержатся отсканированные изображения документов для проектов FlexiCapture.

Ниже приведен список проектов FlexiCapture и их краткое описание.

Пример проекта с документами разных типов

Папки с примерами содержат проекты FlexiCapture.

  1. Single Entry Point

    Этот проект демонстрирует возможность обработки документов разных типов. Предварительная сортировка документов не требуется, жесткие формы и гибкие документы различных видов могут обрабатываться в одном потоке. Эти определения документов также вынесены в отдельные проекты, описанные ниже.

    Проект содержит все типы документов: Banking Card Applications, Invoices, Contracts, Letters, Prices.

Примеры жестких форм

Папки с примерами содержат формы, разработанные в приложении FormDesigner, и проекты FlexiCapture.

  2. Banking Card Application

    В данном примере продемонстрированы следующие возможности программы:

    • Автоматический поиск полей в жестких формах (для того чтобы увидеть, как работает автоматический поиск, удалите все поля в определении документов, а затем выберите Сервис > Найти объекты на изображении…)
    • Поддержка сложной структуры документов:
      1. Многостраничные документы (в примере рассматриваются трехстраничные заявления)
      2. Работа с разделами документов (в примере каждая страница выделена в один раздел)
      3. Правила сборки документов
      4. Обработка приложений.
    • Поддержка сложных полей документа:
      1. Работа с таблицами в жестких формах (таблица "Opened Accounts")
      2. Повторяющиеся группы полей (группы "Address" и "Requested Accounts")
    • Проверка формата данных (задан формат для всех полей с числовыми значениями и для дат)
    • Индивидуальная настройка формы данных.
    • Экспорт по нескольким адресам.
    • Скрытие конфиденциальной информации.
  3. Questionnaire

    Этот пример подробно описан в руководстве пользователя, он помогает продемонстрировать пошаговую настройку определения документов. Наиболее простые формы выбраны для демонстрации базовой функциональности FlexiCaprute. В руководстве пользователя предлагается заполнить анкету из данного примера, произвести обработку и прислать проэкспортированные данные в компанию ABBYY.

Примеры гибких документов

Папки с примерами содержат проекты FlexiLayout Studio и проекты FlexiCapture.

  4. Invoice

    В этом примере показана обработка полуструктурированных документов и продемонстрированы следующие возможности программы:

    • Непостоянное количество страниц в документах (от 1 до 3)
    • Многостраничные таблицы
    • Использование внешнего словаря (из текстового файла) для поиска ключевых слов
    • Правило, описанное на JScript, используемое для сравнения суммы, полученной суммированием значения Total во всех строках таблицы, с суммой из поля "Total".

  5. Prices

    В этом примере показана обработка полуструктурированных документов и продемонстрированы следующие возможности программы:

    • Поддержка повторяющихся групп. Данный пример демонстрирует, как повторяющиеся группы могут быть использованы для описания вложенных таблиц (таблиц с подзаголовками).

  6. Letters&Contracts

    В этом примере показана обработка неструктурированных документов, из которых извлекаются 2-3 поля и продемонстрированы следующие возможности программы:

    • Непостоянное количество страниц в документах (от 1 до 4)
    • Настройка экспорта в PDF с возможностью поиска.


Поддерживаемые языки распознавания

Программа ABBYY FlexiCapture 10 поддерживает следующие языки распознавания со словарной поддержкой:

Язык | OCR* | ICR**
английский | ü | ü
армянский (восточный, западный, грабар) | ü |
башкирский | ü |
болгарский | ü | ü
венгерский | ü | ü
греческий | ü | ü
датский | ü |
иврит | ü |
индонезийский | ü | ü
испанский | ü | ü
итальянский | ü | ü
каталанский | ü |
латышский | ü | ü
литовский | ü | ü
немецкий (старая, новая орфография) | ü | ü
нидерландский (Нидерланды и Бельгия) | ü | ü
норвежский (нюнорск и букмол) | ü |
польский | ü | ü
португальский (Португалия и Бразилия) | ü |
румынский | ü | ü
русский | ü | ü
словацкий | ü | ü
словенский | ü | ü
староанглийский | ü |
староитальянский | ü | ü
староиспанский | ü | ü
старонемецкий | ü | ü
старофранцузский | ü | ü
тайский | ü |
татарский | ü |
турецкий | ü | ü
украинский | ü | ü
финский | ü | ü
французский | ü | ü
хорватский | ü | ü
чешский | ü | ü
шведский | ü |
эстонский | ü | ü

Более подробно о шрифтах для поддерживаемых языков см. раздел "Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе ABBYY FlexiCapture".

Полный актуальный список поддерживаемых типов данных и подробная информация о них приведены на сайте http://www.abbyy.ru.

* - OCR - Optical Character Recognition. Оптическое распознавание типографских текстов.

** - ICR - Intelligent Character Recognition. Распознавание рукопечатных текстов.


Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе FormReader

Шрифты, необходимые для корректного отображения символов поддерживаемых языков в редакторе ABBYY FlexiCapture

Язык | Шрифт
Со словарной поддержкой |
армянский (восточный, западный, грабар) | Arial Unicode MS(2)
татарский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
Без словарной поддержки |
абхазский | Arial Unicode MS(2)
аварский | Arial Unicode MS(2), Lucida Sans Unicode(3)
агульский | Arial Unicode MS(2), Lucida Sans Unicode(3)
адыгейский | Arial Unicode MS(2), Lucida Sans Unicode(3)
азербайджанский (кириллица), азербайджанский (латиница) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
алтайский | Arial Unicode MS(2), Lucida Sans Unicode(3)
башкирский | Arial Unicode MS(2), Palatino Linotype(2)
бурятский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
гагаузский | Arial Unicode MS(2)
даргинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
дунгаский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
зулу | Arial Unicode MS,(2), Lucida Sans Unicode(3)
ингушский | Arial Unicode MS(2), Lucida Sans Unicode(3)
кабардино-черкесский | Arial Unicode MS(2), Lucida Sans Unicode(3)
казахский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
калмыцкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
каракалпакский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
киргизский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
корякский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лакский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лезгинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
мансийский | Arial Unicode MS(2), Lucida Sans Unicode(3)
марийский | Arial Unicode MS(2)
монгольский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
ненецкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
осетинский | Arial Unicode MS(2)
русский (старая орфография) | Arial Unicode MS(2), Palatino Linotype(2)
табасаранский | Arial Unicode MS(2), Lucida Sans Unicode(3)
таджикский | Arial Unicode MS(2), Palatino Linotype(2)
тувинский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
туркменский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
удмуртский | Arial Unicode MS(2)
узбекский (кириллица) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
хакасский | Arial Unicode MS(2)
хантыйский | Arial Unicode MS(2)
хауса | Arial Unicode MS(2), Lucida Sans Unicode(3)
чеченский | Arial Unicode MS(2), Lucida Sans Unicode(3)
чувашский | Arial Unicode MS(2)
чукотский | Arial Unicode MS(2), Lucida Sans Unicode(3)
якутский | Arial Unicode MS(2)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Поддерживаемые типы текста

Программа ABBYY FlexiCapture 10 поддерживает следующие типы текста:

Тип текста | Описание
Типографский, лазерный или струйный принтер | Текст, напечатанный типографским способом, на лазерном или на струйном принтере
Пишущая машинка | Текст, напечатанный на пишущей машинке
Матричный принтер | Текст, напечатанный на матричном принтере
Index | Специальный набор символов, включающий только цифры для написания почтового индекса. Выглядит следующим образом:
OCR-A | Моноширинный шрифт, разработанный специально для оптического распознавания символов. Широко используется банками и в смежных отраслях. Может выглядеть следующим образом:
OCR-B | Шрифт, разработанный специально для оптического распознавания символов. Может выглядеть следующим образом:
MICR E-138 | Специальный набор цифр, напечатанный магнитными чернилами. MICR - Magnetic Ink Character Recognition. Может выглядеть следующим образом:
MICR CMC-7 | Специальный шрифт MICR (CMC-7). Может выглядеть следующим образом:


Поддерживаемые типы штрих-кодов

Программа ABBYY FlexiCapture 10 поддерживает штрих-коды следующих форматов:

  • EAN 13
  • EAN 8
  • Code 39
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Check CodaBar
  • Aztec
  • Datamatrix
  • QR code

Замечание. Для распознавания штрих-кодов с кириллической кодировкой нужно использовать штрих-код в формате Datamatrix.


Поддерживаемые графические форматы

Тип | Цвет
BMP | ч/б, серый, цветной
PCX, DCX | ч/б, серый
PNG | ч/б, серый, цветной
JPEG | серый, цветной
JPEG-2000 | серый, цветной
TIFF | ч/б – несжатый, CCITT3, CCITT4, Packbits, ZIP; серый – несжатый, Packbits, JPEG, ZIP; цветной – несжатый, JPEG, ZIP.
JBIG2 | ч/б
GIF | цветной
PDF, PDF/A* |
PDF, PDF/A* с возможностью поиска |
DjVu | ч/б, серый, цветной

* - PDF/A файлы, созданные в ABBYY FlexiCapture 10, соответствуют стандартам PDF/A-1a и PDF/A-1b.


Форматы файлов экспорта

Форматы файлов, в которые ABBYY FlexiCapture 10 экспортирует данные из документов

  • Microsoft Office Excel Workbook (*.XLS)
  • DBase file (*.DBF)
  • Comma Separated Values File (*.CSV). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Comma Separated Values File (*.CSV) в формате Unicode (UTF-8, UTF-16)
  • Простой текст (*.TXT). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Простой текст (*.TXT) в формате Unicode (UTF-8, UTF-16)
  • XML Document (*.XML)


Алфавит, используемый в регулярных выражениях

Название | Условное обозначение | Пример использования
Любой символ | * | "к"*"т" – допускает слова типа кит, кот и т.п.
Буква | С | С"от" – допускает слова типа Рот, рот, кот, Кот, мот и т.д.
Заглавная буква | А | A"от" – допускает слова типа Рот, Кот, Мот, Дот и т.п.
Строчная буква | а | а"от" – допускает слова типа рот, кот, мот, дот и т.п.
Буква или цифра | Х | X – допускает любую одиночную цифру или букву.
Цифра | N | N"-й" допускает слова типа 5-й, 4-й, 1-й и т.п.
Строка | " " | "кот"
Или | | | "пл"("о"|"а")"т" – допускает слова "плот" и "плат".
Символ из группы | [] | [тм]"от" – допускает слова тот и мот.
Символ не из группы | [^] | [^т]"от" – допускает слова "кот", "лот" и т.п., но не допускает слова "тот".
Пробел (в группе) | \s | [A\s] допускает только букву А либо пробел.
Любое число повторений (распространяется на стоящее слева выражение или подвыражение) | {-} | [АБ74]{-} – допускает любые комбинации символов А, Б, 7, 4 произвольной длины.
Количество повторений n | {n} | N{2}"-й" допускает слова типа 25-й, 84-й, 11-й и т.п.
От n до m повторений | {n-m} | N{1-3}"-й" допускает слова типа 5-й, 84-й, 111-й и т.п.
От 0 до n повторений | {-n} | N{-2}"-й" допускает слова типа -й, 84-й, 1-й и т.п.
От n и больше повторений | {n-} | N{2-}"-й" допускает слова типа 25-й, 834-й, 311-й, 34576-й и т.п.
Подвыражение | () |
Символ "дефис" | [\-] |
Символ "слеш" | [\\] |

Примеры регулярных выражений:

  1. Почтовый индекс: [0-9]{6} Пример значения: "142172"
  2. Zip код (США): [0-9]{5}("-"[0-9]{4}){-1} Примеры значений: "55416", "33701-4313"
  3. Доход: N{4-8}[,]N{2} Примеры значений: "15000,00", "4499,00"
  4. Месяц числом: ((|"0")[1-9])|("10")|("11")|("12") Примеры значений: "4", "05", "12"
  5. Дробное число: ("-"|)([0-9]{1-})(|(("."|",")([0-9]{1-}))) Примеры значений: "1234,567", "0.99", "100,0", "-345.6788903"
  6. E-mail: [A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-3}"@"[A-Za-z0-9_]{1-}(("."|"-")[A-Za-z0-9_]{1-}){-4}"."([A-Za-z]{2-4}|"asia"|"museum"|"travel"|"example"|"localhost") Примеры значений: "support@abbyy.com", "my-name@company.org.ru", "info@gallery.museum"


Патенты

Патенты США № 5,490,216, 5,625,465, 5,768,416 и 6,094,505


Технологии других компаний

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

All rights reserved.

Подробнее

Настоящей лицензией любому лицу (далее - "Пользователь"), получившему копию настоящего программного обеспечения и сопроводительную документацию к нему (далее - "ПО"), безвозмездно предоставляется право распоряжаться ПО без каких-либо ограничений, включая право использовать, копировать, изменять, встраивать, воспроизводить, публиковать, распространять и/или продавать копии ПО, а также разрешать лицам, которым передается ПО, совершать аналогичные действия при условии соблюдения нижеперечисленных условий:

  1. Любые копии или значительные части ПО должны содержать вышеприведенные уведомления об авторских правах, настоящую лицензию и нижеприведенный отказ от гарантий.

  2. Имя владельца авторских прав не должно использоваться для поддержки или рекламы продуктов, созданных на основе настоящего ПО, без предварительного письменного согласия владельца авторских прав.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ ЯВЛЯЕТСЯ НЕОТЪЕМЛЕМОЙ ЧАСТЬЮ НАСТОЯЩЕЙ ЛИЦЕНЗИИ.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ РАСПРОСТРАНЯЕТСЯ НА ЛЮБОЕ ИСПОЛЬЗОВАНИЕ ПО. ПО ПРЕДОСТАВЛЯЕТСЯ ВЛАДЕЛЬЦАМИ АВТОРСКИХ ПРАВ "ТАКИМ, КАКОВО ОНО ЕСТЬ" БЕЗ КАКИХ-ЛИБО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ (НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ) ГАРАНТИЙ ТОГО, ЧТО ПО ПРИГОДНО К ПРОДАЖЕ, ПРИГОДНО ДЛЯ КОНКРЕТНОГО ИСПОЛЬЗОВАНИЯ И НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ЛЮБЫЕ КОСВЕННЫЕ, ПРЯМЫЕ ИЛИ СЛУЧАЙНЫЕ УБЫТКИ, А ТАКЖЕ ЗА ЛЮБЫЕ УБЫТКИ ИЗ-ЗА НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПО, ПОТЕРИ ДАННЫХ ИЛИ УПУЩЕННОЙ ВЫГОДЫ В РЕЗУЛЬТАТЕ НЕВЫПОЛНЕНИЯ ОБЯЗАТЕЛЬСТВ ПО КОНТРАКТУ, НЕБРЕЖНОСТИ ИЛИ ИНЫХ ВРЕДОНОСНЫХ ДЕЙСТВИЙ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ИЛИ РАБОТОЙ ПО. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ ГАРАНТИРУЮТ, ЧТО ПО НЕ НАРУШАЕТ ПАТЕНТОВ И ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ТРЕТЬИХ ЛИЦ. КАЖДЫЙ ИЗ ВЛАДЕЛЬЦЕВ АВТОРСКИХ ПРАВ ОТКАЗЫВАЕТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ПОЛЬЗОВАТЕЛЯМИ ЗА ИСКИ ТРЕТЬИХ ЛИЦ В СВЯЗИ С НАРУШЕНИЕМ ИХ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ИЛИ ИНЫМИ НАРУШЕНИЯМИ. ДЛЯ ИСПОЛЬЗОВАНИЯ ПРАВ, ПРЕДОСТАВЛЯЕМЫХ НАСТОЯЩЕЙ ЛИЦЕНЗИЕЙ, КАЖДЫЙ ПОЛЬЗОВАТЕЛЬ ПРИНИМАЕТ НА СЕБЯ ЕДИНОЛИЧНОЕ ОБЯЗАТЕЛЬСТВО ПРИОБРЕСТИ НЕОБХОДИМЫЕ ПРАВА ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, ЕСЛИ ТАКОВЫЕ ПОТРЕБУЮТСЯ. ПО НЕ ОБЛАДАЕТ ОТКАЗОУСТОЙЧИВОСТЬЮ И НЕ ПРЕДНАЗНАЧЕНО ДЛЯ ИСПОЛЬЗОВАНИЯ В УСЛОВИЯХ, ТРЕБУЮЩИХ БЕЗОТКАЗНОЙ РАБОТЫ, ТАКИХ КАК ЯДЕРНЫЕ УСТАНОВКИ, АВИАЦИОННЫЕ НАВИГАЦИОННЫЕ ИЛИ КОММУНИКАЦИОННЫЕ СИСТЕМЫ, АВИАДИСПЕТЧЕРСКИЕ СИСТЕМЫ, АППАРАТЫ ПО ПОДДЕРЖАНИЮ ЖИЗНИ, ОРУЖИЕ ИЛИ СИСТЕМЫ, В КОТОРЫХ ОТКАЗ ПО ИЛИ СИСТЕМЫ МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, СЕРЬЕЗНОМУ УЩЕРБУ ЗДОРОВЬЮ ИЛИ ОКРУЖАЮЩЕЙ СРЕДЕ ("ДЕЯТЕЛЬНОСТЬ, СВЯЗАННАЯ С ПОВЫШЕННЫМ РИСКОМ"). ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НАСТОЯЩИМ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРИГОДНОСТИ ПО ДЛЯ ДЕЯТЕЛЬНОСТИ, СВЯЗАННОЙ С ПОВЫШЕННЫМ РИСКОМ.

Товарные знаки

QuickScan является товарным знаком, а Captiva является зарегистрированным товарным знаком корпорации Captiva Software Corporation.

KODAK является товарным знаком компании Eastman Kodak Company.


Техническая поддержка

Если при использовании программы ABBYY FlexiCapture 10 у вас возникли вопросы, то вы можете воспользоваться детальным описанием функциональности этой программы, приведенном в Справке и Руководстве пользователя ABBYY FlexiCapture 10. А также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать вам квалифицированные рекомендации, сотрудникам службы технической поддержки необходимо иметь следующую информацию:

  • Фамилия, Имя, Отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер дистрибутива
  • Выпуск (см. меню Справка/О программе ABBYY FlexiCapture)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия системы Windows
  • Другая информация, которую вы считаете важной
Координаты офисов ABBYY


Как купить программу ABBYY FlexiCapture 10

Чтобы оформить заказ на покупку ABBYY FlexiCapture и задать любые сопутствующие вопросы, обращайтесь в региональные офисы ABBYY.


ABBYY Offices

Координаты офисов компании ABBYY

Россия | ABBYY Россия Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: 127273, Россия, Москва, а/я 32 Физический адрес: Москва, ст. м. Отрадное, ул. Отрадная, 2Б, строение 6, бизнес-цент "Отрадный" E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru Сайт: http://www.abbyy.ru Схема проезда
США, Мексика, Центральная Америка | ABBYY USA Тел.: +1 408-457-9777 Факс: +1 408-457-9778 Адрес: 880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Канада | ABBYY Canada Тел.: +1 408 457 9777 Факс: +1 408 457 9778 Адрес: 555 Legget Dr., Suite 304 Kanata, Ontario K2k 2X3, Canada E-mail: info_canada@abbyyusa.com Техническая поддержка: support_canada@abbyyusa.com Сайт: http://www.abbyy.com
Африка, Азия, Южная Америка, Греция, страны Балтики | ABBYY 3A Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Адрес: Россия, 127273, Москва, а/я 32, ООО «Аби» E-mail: sales_3A@abbyy.com Техническая поддержка: support@abbyy.com Сайт: http://www.abbyy.cn http://www.abbyy.com.br http://latam.abbyy.com
Восточная Европа и страны Средиземноморья | ABBYY Украина Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: Украина, 02002 Киев, а/я 23 E-mail: sales@abbyy.ua Техническая поддержка: тел. +380 44 490 9463, e-mail: support@abbyy.ua Сайт: http://www.abbyy.ua
Западная Европа | ABBYY Europe GmbH Тел.: +49 89 511 159 0 Факс: +49 89 511 159 59 Адрес: Elsenheimerstrasse 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com Сайт: http://www.abbyy.de http://www.france.abbyy.com http://www.abbyy.com
Соединенное королевство | ABBYY UK Ltd. Тел.:+0870 600 0231 Факс: +01344 392 611 Адрес: Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom E-mail: sales_UK@abbyy.com Техническая поддержка: support_eu@abbyy.com Сайт: http://www.abbyy.co.uk
Япония | ABBYY Japan Тел.:+81-42-795-1901 Факс: +81-42-795-1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Австралия и Новая Зеландия | ABBYY Australia Адрес: Citigroup Building, level 39, 2 Park Street, Sydney, NSW, 2000, Australia E-mail: sales_au@abbyy.com Техническая поддержка: support@abbyy.com Сайт: http://www.abbyy.com
Тайвань | ABBYY Taiwan Тел.:+886-2-2655-0556 Факс: +886-2-2655-2339 Адрес: Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Сайт: http://www.abbyy.com
Все другие регионы | ABBYY Poccuя Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Адрес: Россия, 127273, Москва, а/я 32, ООО «Аби» E-mail: sales@abbyy.com Техническая поддержка: support@abbyy.ru Сайт: http://www.abbyy.ru, http://www.abbyy.com


Лицензионный договор с конечным пользователем

ABBYY FlexiCapture 10

Важно! Внимательно прочитайте нижеследующие условия перед установкой, копированием или иным использованием ABBYY FlexiCapture 10. Установка, копирование или иное использование ABBYY FlexiCapture 10 означает ваше согласие с нижеследующими условиями.

Настоящий лицензионный договор с конечным пользователем (далее – Лицензионный договор) является юридически обязательным соглашением между компанией ABBYY и вами, конечным пользователем программы для ЭВМ ABBYY FlexiCapture 10, которая предоставляется вместе с настоящим Лицензионным договором, включая все носители, печатные материалы, а также «он-лайн» или электронную документацию (далее по тексту – «программное обеспечение» и/или «ПО»).

Устанавливая, копируя или иным способом используя ПО, вы подтверждаете, что настоящий Лицензионный договор был вами прочитан, условия его вам понятны, и вы согласны использовать ПО в соответствии с этими условиями.

Права на ABBYY FlexiCapture 10 охраняются действующим законодательством и международными соглашениями. Вы подтверждаете свое согласие с тем, что настоящий Договор имеет такую же юридическую силу, как и любой другой письменный договор, заключенный вами.

Настоящий Лицензионный договор считается заключенным с момента, когда вы примете его условия, выбрав в процессе установки ПО пункт «Я принимаю условия лицензионного договора» на экране вашего компьютера, и нажмете на кнопку «Далее» в программе установки, либо с момента, когда вы начнете использовать ПО любым способом (далее – «Дата заключения договора»).

Если ПО сопровождается Лицензионным договором и в электронной, и в письменной форме, то в случае расхождений в содержании между настоящим текстом и текстом в письменной форме преимущественную силу имеет текст подписанного лицензионного договора в письменной форме.

В случае если вы не согласны с условиями настоящего Лицензионного договора, не устанавливайте и не используйте ПО, отметьте пункт «Я не принимаю условия лицензионного договора» и затем нажмите на кнопку «Отмена» для выхода из программы установки.

Определения:

«ПО» означает программу для ЭВМ ABBYY FlexiCapture 10, представляющую собой набор программ, баз данных и сопроводительной документации (как в письменной, так и в электронной форме). ПО охраняется законами об авторском праве.

«Компонент ПО» означает любую составную часть ПО, включая любые программы для ЭВМ в составе ПО.

«Компьютер» означает электронное устройство с одним или более центральным процессорным устройством, которое получает информацию в цифровой или аналогичной цифровой форме и обрабатывает её в соответствии с набором инструкций для получения определенного результата.

«Виртуальная машина» означает устройство в виртуальной (или иным образом эмулированной) аппаратной системе.

«Вы» означает любое физическое лицо (в том числе индивидуальный предприниматель) или юридическое лицо, которые получили ПО и/или от имени которых используется ПО.

«Лицензия» означает предоставляемое Вам Компанией ABBYY право на установку ПО и использование функциональности ПО на условиях простой (неисключительной) лицензии, в соответствии с условиями настоящего Лицензионного договора.

«Серийный номер» означает уникальный идентификатор лицензии или группы лицензий со сходными параметрами, предоставленный Конечному пользователю.

«Активация ПО» означает процесс, при помощи которого установленное ПО переводится в полнофункциональный режим и начинает выполнять все функции в соответствии с сопроводительной документацией и объемом приобретенной Вами Лицензии.

«Компания ABBYY» означает:

компанию ABBYY USA Software House Inc., зарегистрированную по адресу 880 США, 95035 Калифорния, г. Мильпитас, Норт Маккарти бульвар 220, когда применяется п. 17.1 настоящего Лицензионного договора;

компанию ABBYY Europe GmbH, зарегистрированную по адресу 80687, Германия, г. Мюнхен, Эльзенхаймерштрассе 49, когда применяется п. 17.2 настоящего Лицензионного договора;

компанию ABBYY UK Ltd., зарегистрированную по адресу Великобритания, TW20 9EY графство Суррей, г. Эгхэм, Хай-стрит 65, «Хитроу бизнес сентер», когда применяется п. 17.3 настоящего Лицензионного договора;

ООО «Аби», зарегистрированное по адресу Россия, 111398, Москва, ул. Перовская, дом 22, корпус 1, когда применяется п. 17.4 настоящего Лицензионного договора;

компанию ABBYY Software House Ukraine, зарегистрированную по адресу Украина, 03680, ул. Дегтяревская, дом 31, когда применяется п. 17.5 настоящего Лицензионного договора;

и компанию ABBYY Solutions Ltd., зарегистрированную по адресу CY 2404, Республика Кипр, г. Никосия, Энгоми, Михаил Караоли 2, во всех остальных случаях.

«Партнер Компании ABBYY» означает юридическое лицо или индивидуального предпринимателя, которое предоставляет Вам ПО и/или право на его использование на основании договора с Компанией ABBYY, предоставляющего для такой деятельности необходимый объем прав.

1. Предмет договора

1.1. При условии соблюдения Вами условий настоящего Лицензионного договора Компания ABBYY предоставляет Вам Лицензию на установку и использование функциональности ПО, включая любые изображения, фотографии, анимированные изображения, аудио- и видеокомпоненты, музыку, текст и дополнительные программы, входящие в состав ПО, а также сопроводительные материалы и копии ПО в соответствии с условиями, указанными ниже. Все условия, оговоренные далее, относятся как к ПО в целом, так и к Компонентам ПО в отдельности.

1.2. В случае если применяется п. 17.4 Лицензионного договора и Вы являетесь физическим лицом, то территория, на которой допускается использование ПО, включает в себя весь мир. В случае если применяется п. 17.4 Лицензионного договора и Вы являетесь юридическим лицом (либо обособленным подразделением юридического лица), то территория, на которой допускается приобретение и использование ПО, ограничена страной регистрации юридического лица (либо обособленного подразделения данного юридического лица), если иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY.

2. Права на ПО

2.1. Компания ABBYY гарантирует, что имеет все необходимые права на лицензирование и распространение ПО (в том числе любых включенных в него графических изображений, фотографий, текстов, анимированных изображений, аудио- и видеокомпонентов, музыки и дополнительных программ), а также сопровождающих ПО печатных материалов и всех копий ПО.

2.2. Все права на любые объекты интеллектуальной собственности, не содержащиеся в ПО, но доступные посредством использования ПО, принадлежат своим законным владельцам (правообладателям) и охраняются применимыми законами об авторском праве или иными законами и соглашениями об интеллектуальной собственности. Настоящий Лицензионный договор не предоставляет Вам никаких прав на такую интеллектуальную собственность.

2.3. ПО содержит коммерческую тайну и конфиденциальную информацию, принадлежащую Компании ABBYY и/или третьим лицам, которая охраняется применимыми законами об авторском праве и международными соглашениями.

2.4. Любое использование ПО в нарушение условий настоящего Лицензионного договора рассматривается как нарушение прав Компании ABBYY и/или третьих лиц и является достаточным основанием для лишения Вас предоставленных по настоящему Лицензионному договору прав.

2.5. Вы согласны с тем, что ПО защищено от копирования и неограниченного использования и может сопровождаться программными и аппаратными ключами (далее – «Лицензионный ключ») для обеспечения такой защиты.

2.6. Объем Лицензии зависит от ряда факторов, определяемых при заказе/приобретении ПО: набора функций, разрешенного количества работающих в сети копий ПО, разрешенного количества используемых ЦПУ, разрешенного для обработки количества страниц, окончания срока действия Лицензии и других. Вся эта и другая информация записана в Лицензионном ключе. Лицензионный ключ техническими средствами ограничивает использование ПО объемом Лицензии, которую Вы приобрели.

2.7. Вы имеете право один раз передать данное ПО непосредственно другому конечному пользователю. В случае если Вы являетесь юридическим лицом, Вы не имеет права передавать ПО другому конечному пользователю без предварительного письменного согласия Компании ABBYY. Такая передача должна включать все ПО (все Компоненты ПО, носители и печатные материалы, а также любые полученные Вами новые версии) и настоящий Лицензионный договор. Такая передача не может быть осуществлена косвенно или через какое-либо третье лицо. Лицо, получающее ПО в результате такой единовременной передачи, должно согласиться со всеми условиями настоящего Лицензионного договора, включая обязательство более никому не передавать ПО. В случае такой передачи ПО Вы обязуетесь удалить ПО и его Компоненты, установленные на всех Ваших Компьютерах или в локальной вычислительной сети.

2.8. За исключением случая, описанного в п. 2.7, Вы не имеете права передавать, продавать или сублицензировать ПО третьим лицам, равно как и права, предоставленные Вам по настоящему Лицензионному договору, и/или любые другие права на ПО. Компания ABBYY имеет право в одностороннем порядке расторгнуть настоящий Лицензионный договор в случае такой передачи или продажи.

2.9. Настоящий Лицензионный договор не предоставляет Вам никаких прав на товарные знаки, принадлежащие Компании ABBYY.

2.10. Компания ABBYY сохраняет за собой все права, которые не предоставлены явным образом настоящим Лицензионным договором.

3. Условия использования

3.1. Вы имеете право использовать ПО в соответствии с объемом Лицензии.

3.2. Вы имеете право установить ПО на неограниченном количестве Компьютеров или Виртуальных машин.

3.3. Функциональность ПО и количество Компьютеров или Виртуальных машин (если использование Виртуальных машин разрешено вашей Лицензией), которое Вы можете запускать одновременно определяется серийным номером, предоставляемым Вам вместе с ПО.

3.4. В случае если ПО или Компоненты ПО используются в виртуальной среде (например, VMware, Citrix, или «ghosting»), одна и та же Лицензия не должна использоваться несколькими машинами одновременно, если только это не разрешено Вашей лицензией. Вы обязуетесь не обрабатывать при помощи ПО больше страниц, чем общее количество страниц, которое разрешено Вашей Лицензией.

3.5. Если Вы получаете доступ к ПО через терминальные службы (Terminal Services), которые разрешают доступ к ПО на удаленном компьютере с помощью сети, Вы имеете право одновременно запускать и использовать такое количество копий ПО, которое разрешено объемом Вашей Лицензией и настоящим Лицензионным договором.

3.6. Если Вы получаете доступ к ПО через сеть интернет с удаленного Компьютера при помощи веб-браузера, Вы имеете право одновременно запускать и использовать такое количество копий ПО, которое разрешено объемом приобретенной Вами Лицензии и настоящим Лицензионным договором.

3.7. Вы имеете право использовать ПО для предоставления услуг по распознаванию и конвертации и/или предоставлять третьим лицам результаты, полученные посредством ПО, только если в Вашем Лицензионном ключе есть параметр «BPO services enabled».

3.8. Вы не имеете права использовать ПО для предоставления третьим лицам платных или бесплатных услуг по распознаванию или конвертированию и/или предоставлять результаты или доступ к результатам, полученным при помощи ПО, в составе другой услуги, одним из компонентов которой является распознавание или конвертирование, без предварительного заключения письменного договора с Компанией ABBYY.

3.9. Если версия ПО обозначена как «испытательная» или «демонстрационная» («Try&Buy», «Trial» или «Demo»), то независимо от остальных условий настоящего Лицензионного договора Вы имеете право использовать ПО только в тестовых или демонстрационных целях. Вы согласны с тем, что ПО может иметь ограниченную функциональность и/или ограниченное время работы. Если срок использования ПО является ограниченным по времени, то по истечении определенного периода времени, указанного в Лицензии, оно прекратит работать.

3.10. Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:

3.10.1. Восстанавливать структурную схему, деассемблировать, декомпилировать (преобразовывать объектный код в исходный текст) ПО (включая программы, базы данных и любые Компоненты ПО), за исключением случаев, разрешенных применимым законодательством, и только в объеме, явным образом разрешенном применимым законодательством. Если применимое законодательство разрешает подобные действия, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть незамедлительно сообщена Компании ABBYY. Вся такая информация является конфиденциальной и принадлежит Компании ABBYY.

3.10.2. Модифицировать, адаптировать или переводить ПО, в том числе вносить изменения в объектный код программ или баз данных к ним, за исключением тех изменений, которые вносятся средствами, включенными в комплект ПО и описаны в сопроводительной документации.

3.10.3. Исправлять ошибки в ПО без предварительного письменного согласия Компании ABBYY.

3.10.4. Сдавать в аренду, сублицензировать, передавать или уступать права, предоставленные Вам по настоящему Лицензионному договору, и любые другие права, связанные с ПО, третьим лицам, а также разрешать копировать ПО целиком или его части на Компьютеры других пользователей, если иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY или Партнером Компании ABBYY.

3.10.5. Создавать условия для использования ПО лицами, не имеющими прав на использование ПО и работающими с Вами в одной многопользовательской системе.

3.10.6. Удалять, менять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

4. Носители

4.1. ПО может предоставляться на нескольких носителях, в том числе через сеть интернет. Независимо от количества носителей, на которых Вы получили ПО, Вы имеете право использовать ПО только в соответствии с условиями настоящего Лицензионного договора.

5. Ограничения

5.1. Вы не сможете использовать предоставленные Вам настоящим Лицензионным договором права в отношении ПО до тех пор, пока не будет произведена Активация ПО.

5.2. Все условия и ограничения использования, поддержки и сопровождения ПО указаны в настоящем Лицензионном договоре, если иное не оговорено в отдельном письменном соглашении между Вами и Компанией ABBYY или Партнером Компании ABBYY.

6. Базы данных конечного пользователя

6.1. Вы имеете право создавать свои базы данных к программам, входящим в комплект ПО, если такая возможность предусмотрена ПО и описана в сопроводительной документации.

7. Распространение ПО

7.1. Распространение ПО любыми способами, за исключением способа, описанного в п. 2.7, запрещено. Распространение включает в себя в том числе предоставление доступа к ПО третьим лицам, сублицензирование, продажу ПО, прокат, сдачу ПО в аренду или предоставление ПО взаймы.

8. Сопровождение и техническая поддержка

8.1. Компания ABBYY или Партнер Компании ABBYY может предоставить Вам сопровождение и техническую поддержку ПО на условиях, изложенных в Приложении А к настоящему Лицензионному договору, если иное не оговорено в отдельном письменном соглашении между Вами и Компанией ABBYY или Партнером Компании ABBYY.

9. Ограниченная гарантия

9.1. Компания ABBYY гарантирует удовлетворительное качество носителей, входящих в комплект ПО (если ПО поставляется на материальных носителях), и их работоспособность при обычных условиях использования в течение минимального гарантийного срока, установленного законодательством страны приобретения ПО, начиная с даты приобретения ПО. В случае если ПО было приобретено в одной из стран, указанных в п. 17.4, гарантийный срок составляет 30 (тридцать) дней с даты покупки.

9.2. ПО, обновления, новые версии и сопровождение ПО предоставляются «как есть», и Компания ABBYY не предоставляет на них никаких гарантий. Компания ABBYY и Партнеры Компании ABBYY не гарантируют и не могут гарантировать производительность и результаты, которые Вы можете получить посредством использования ПО. За исключением гарантий и условий, которые не могут быть исключены или ограничены в соответствии с применимым законодательством, Компания ABBYY и Партнеры Компании ABBYY не предоставляют никаких гарантий (явно выраженных или подразумевающихся в статутном или общем праве, или обычаями делового оборота или иначе) ни на что, включая, без ограничения, гарантии о соблюдении прав третьих лиц, товарной пригодности, интегрируемости, удовлетворительного качества, годности к использованию для выполнения частных задач. Компания ABBYY также не гарантирует, что ПО не содержит ошибок, будет удовлетворять Вашим требованиям или что ПО будет нормально функционировать при использовании совместно с программным обеспечением и оборудованием других производителей. Все риски, связанные с качеством работы и производительностью ПО, возлагаются на Вас.

9.3. Компания ABBYY не предоставляет никаких гарантий относительно программного обеспечения других производителей, которое поставляется вместе или в составе ПО.

10. Ограничение ответственности

10.1. Компания ABBYY ни при каких обстоятельствах не несет перед Вами никакой ответственности за ущерб, вынужденные перерывы в деловой активности, потерю деловых либо иных данных или информации, претензии или расходы, косвенные или случайные убытки, а также упущенную выгоду и утерянные сбережения, вызванные использованием или связанные с использованием ПО, а также за ущерб, вызванный возможными ошибками и опечатками в ПО, даже если представителю Компании ABBYY стало известно о возможности такого ущерба, потерь, претензий или расходов, равно как и за любые претензии со стороны третьих лиц. Вышеперечисленные ограничения и исключения действуют в той степени, насколько это разрешено применимым законодательством. Единственная ответственность Компании ABBYY по настоящему Лицензионному договору ограничивается суммой, которую Вы уплатили за ПО.

10.2. Ограниченная ответственность перед пользователями, проживающими в Германии и Австрии.

Если Вы приобрели ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то

10.2.1. С учетом условий п. 10.2.2, ответственность Компании ABBYY за убытки ограничивается следующим: (i) Компания ABBYY несет ответственность только в том размере, который можно предвидеть в момент заключения договора купли-продажи для убытков в результате незначительного нарушения существенного контрактного обязательства и (ii) Компания ABBYY не несет ответственности за убытки в результате незначительного нарушения несущественного контрактного обязательства.

10.2.2. Ограничение ответственности, изложенное в п. 10.2.1, не распространяется на обязательную ответственность, предусмотренную законом, в частности, на ответственность по Закону ФРГ об ответственности производителя, на ответственность за предоставление конкретной гарантии и на ответственность за причиненные увечья.

10.2.3. Вы обязуетесь предпринять все разумные меры с целью избежать ущерба и сократить ущерб, в частности, делать резервные копии ПО и данных на Вашем компьютере в соответствии с условиями настоящего Лицензионного договора.

11. Встроенные шрифты

11.1. Шрифтовые программы охраняются авторским правом, и их владельцы могут налагать условия на использование шрифтов. Одним из условий может быть необходимость наличия лицензионной версии шрифтовой программы для встраивания шрифтов при создании новых PDF-файлов. Компания ABBYY не несет никакой ответственности за любые убытки, вызванные использованием Вами встраиваемых шрифтов.

12. Библиотека Adobe® PDF Library

12.1. «ПО Adobe» означает библиотеку Adobe® PDF Library для Windows 2000, и Windows XP и сопутствующую документацию, а также любые обновления, измененные версии, дополнения или копии вышеперечисленного. ПО использует ПО Adobe для конвертирования PDF-файлов в файлы изображений.

12.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Adobe, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора. Вы имеете право сделать одну резервную копию ПО Adobe, входящего в состав ПО, при условии, что резервная копия не устанавливается на другой Компьютер и не используется на другом Компьютере.

12.3. Права на интеллектуальную собственность. ПО Adobe, входящее в состав ПО, является собственностью Adobe и поставщиков Adobe, а его структура, организация и программный код являются производственным секретом Adobe и поставщиков Adobe. ПО Adobe также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО Adobe, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Все копии, которые Вы имеете право сделать в соответствии с настоящим Лицензионным договором, должны включать в себя те же уведомления об авторских правах и о правах собственности, которые содержатся в или на ПО. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Adobe, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО Adobe.

12.4. Лицензия на использование шрифтов. В случае если само ПО или ПО Adobe, входящее в состав ПО, включает шрифты, Вы можете встраивать шрифты или контуры шрифтов в Ваши электронные документы, если такое встраивание разрешено правообладателем шрифтов. Данный комплект может содержать как шрифты, принадлежащие Adobe, так и шрифты, не принадлежащие Adobe. Вы имеете право встраивать любые шрифты, принадлежащие Adobe.

12.5. Гарантия. Компания ABBYY не МОЖЕТ гарантировать и не гарантируЕт результаты, которые Вы можете получить путем использования ПО Adobe, входящего в состав ПО.

12.6. Экспортные ограничения. Вы признаете, что ПО Adobe, входящее в состав ПО, не будет поставляться, передаваться, экспортироваться или использоваться в нарушение Закона США о контроле над экспортом (The United States Export Administration Act) или иных нормативно-правовых актов, накладывающих экспортные ограничения (далее все вместе – экспортные ограничения). Кроме того, в случае если ПО Adobe, входящее в состав ПО, в экспортных ограничениях определено как продукт, подлежащий экспортному контролю, Вы гарантируете, что не являетесь гражданином страны, на которую наложено эмбарго, не находитесь в такой стране и что экспортными ограничениями Вам не запрещено приобретать ПО Adobe, входящее в состав ПО. В случае несоблюдения Вами условий настоящего Лицензионного договора Вы лишаетесь всех прав на использование ПО Adobe, входящего в состав ПО, предоставленных Вам настоящим Лицензионным договором.

12.7. Товарные знаки. Adobe и Adobe PDF Library являются товарными знаками или зарегистрированными товарными знаками Adobe Systems Incorporated в США и/или в других странах.

13. Библиотеки PixTools® Scan

13.1. «ПО EMC Software» означает библиотеки Scan, драйверы Level 1 ISIS Drivers, драйверы Level 2 ISIS Drivers, и драйверы Level 3 ISIS Drivers. ПО использует ПО EMC Software для осуществления обмена данными между сканером и ПО через интерфейс ISIS.

13.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО EMC Software, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора.

13.3. Права на интеллектуальную собственность. ПО EMC Software, входящее в состав ПО, является собственностью EMC Corporation и поставщиков EMC Corporation, а его структура, организация и программный код являются производственным секретом EMC Corporation и поставщиков EMC Corporation. ПО EMC Software также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО EMC Software, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО EMC Software, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО EMC Software.

13.4. ГАРАНТИЯ. КОМПАНИЯ ABBYY НЕ МОЖЕТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЕТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО EMC SOFTWARE, ВХОДЯЩЕГО В СОСТАВ ПО. EMC CORPORATION И ПОСТАВЩИКИ EMC CORPORATION НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ УПУЩЕННУЮ ВЫГОДУ ИЛИ ПОТЕРЯННЫЕ СБЕРЕЖЕНИЯ, РАВНО КАК И ЗА ПРЕТЕНЗИИ, ПРЕДЪЯВЛЕННЫЕ ТРЕТЬИМИ ЛИЦАМИ.

Некоторые штаты и юрисдикции запрещают исключение или ограничение ответственности за косвенные или специальные убытки, поэтому вышеперечисленные ограничения могут на Вас не распространяться. У Вас могут быть и другие права, которые зависят от штата и юрисдикции.

13.5. Товарные знаки. ISIS и PixTools являются товарными знаками или зарегистрированными товарными знаками EMC Corporation в Соединенных Штатах Америки и/или в других странах.

14. Программное Обеспечение LIZARDTECH

14.1. «ПО LIZARDTECH» означает инструментарий разработчика DjVu Decoder Software Development Kit производства LIZARDTECH, а также любые сопровождающие его носители, печатные материалы и электронную документацию. Вы приобрели ПО, которое включает в себя ПО LIZARDTECH, лицензированное ABBYY у компании LIZARDTECH, INC. ПО использует ПО LIZARDTECH для конвертирования файлов в формате DjVu в файлы изображений.

14.2. ПО LIZARDTECH охраняется законами об авторском праве и международными соглашениями. ПО LIZARDTECH лицензируется, а не продается.

14.3. Лицензия. Вам предоставляется персональная, не подлежащая сублицензированию, не подлежащая передаче другому лицу, неисключительная лицензия на использование ПО LIZARDTECH, интегрированного в ПО (включая сопроводительную документацию). Вы не имеете права сдавать в аренду, продавать или иным образом распространять ПО LIZARDTECH или любую его часть.

14.4. ОТСУТСТВИЕ ГАРАНТИЙ НА ПО LIZARDTECH. ПО LIZARDTECH поставляется таким, каково оно есть, со всеми ошибками. ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВСЕ РИСКИ, СВЯЗАННЫЕ С УДОВЛЕТВОРИТЕЛЬНЫМ КАЧЕСТВОМ, ПРОИЗВОДИТЕЛЬНОСТЬЮ, ТОЧНОСТЬЮ И НЕОБХОДИМЫМИ УСИЛИЯМИ (ВКЛЮЧАЯ ОТСУТСТВИЕ НЕБРЕЖНОСТИ). ТАКЖЕ ВАМ НЕ ПРЕДОСТАВЛЯЕТСЯ НИКАКИХ ГАРАНТИЙ НА ТО, ЧТО НИКТО НЕ ПОМЕШАЕТ ВАШЕМУ ВЛАДЕНИЮ ПО LIZARDTECH, И НА ТО, ЧТО ПО LIZARDTECH НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ЕСЛИ ВЫ ПОЛУЧИЛИ КАКИЕ-ЛИБО ГАРАНТИИ НА ПО ИЛИ НА ПО LIZARDTECH, ТАКИЕ ГАРАНТИИ БЫЛИ ПРЕДОСТАВЛЕНЫ НЕ КОМПАНИЕЙ LIZARDTECH, И КОМПАНИЯ LIZARDTECH НЕ БЕРЕТ НА СЕБЯ НИКАКИХ ОБЯЗАТЕЛЬСТВ В СВЯЗИ С ТАКИМИ ГАРАНТИЯМИ.

14.5. ИСКЛЮЧЕНИЕ ОТВЕТСТВЕННОСТИ ЗА ОПРЕДЕЛЕННЫЕ ВИДЫ УЩЕРБА. ЕСЛИ НЕ ЗАПРЕЩЕНО ЗАКОНОМ, КОМПАНИЯ LIZARDTECH НЕ НЕСЕТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА КАКИЕ-ЛИБО КОСВЕННЫЕ, ФАКТИЧЕСКИЕ ЛИБО СЛУЧАЙНЫЕ УБЫТКИ, ВОЗНИКАЮЩИЕ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ПО LIZARDTECH ЛИБО ЕГО ФУНКЦИОНИРОВАНИЕМ. НАСТОЯЩЕЕ ОГРАНИЧЕНИЕ ПРИМЕНЯЕТСЯ, ДАЖЕ ЕСЛИ КАКОЕ-ЛИБО СРЕДСТВО СУДЕБНОЙ ЗАЩИТЫ НЕ ДОСТИГНЕТ СВОЕЙ ОСНОВНОЙ ЦЕЛИ.

14.6. Ограничения на обратную разработку, декомпиляцию и деассемблирование. Вы не имеете права восстанавливать структурную схему и алгоритм работы, декомпилировать или деассемблировать ПО LIZARDTECH, за исключением случаев и только в объеме, явным образом разрешенном применимым законодательством.

14.7. Экспортные ограничения. Вы признаете, что ПО LIZARDTECH, любая его часть, любой процесс или служба, которые являются непосредственным продуктом ПО LIZARDTECH («компоненты с экспортными ограничениями»), произведены в США. Вы обязуетесь соблюдать все применимые международные и национальные законы, которые распространяются на такие продукты, включая Правила Экспортного управления США, а также ограничения на конечных пользователей, на конечное использование и на страны или регионы конечного использования, налагаемые правительством США и правительствами других стран.

15. Другие лицензируемые технологии

15.1. Настоящее ПО используется согласно лицензиям на патенты США № 5 490 216, 5 625 465, 5 768 416 и 6 094 505.

16. Экспортные ограничения

16.1. Настоящее ПО не должно экспортироваться или реэкспортироваться в нарушение экспортных ограничений, имеющихся в законодательстве страны, в которой ПО приобретено или получено. Вы также подтверждаете, что применимое законодательство не запрещает Вам приобретать или получать ПО.

17. Применимое право

17.1. В случае если Вы приобрели ПО на территории США, Канады, Мексики, стран Центральной Америки (Белиза, Коста-Рики, Сальвадора, Гватемалы, Гондураса, Монтсеррата, Никарагуа, Панамы, островов Теркс и Кайкос, Виргинских островов США), Тайваня или Японии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство штата Калифорния (Соединенные Штаты Америки). Все споры в отношении настоящего Лицензионного договора и/или ПО подлежат разрешению в федеральном суде и/или суде штата в округе Санта-Клара (штат Калифорния). Во избежание споров Вы согласны с тем, что в случае приобретения Вами ПО на территории Соединенных Штатов Америки, считается, что Вы приобрели ПО у ABBYY USA Software House Inc.

17.2. В случае если Вы приобрели ПО на территории Австрии, Бельгии, Германии, Дании, Испании, Италии, Люксембурга, Нидерландов, Португалии, Финляндии, Франции, Швеции, или на территории любого другого государства, являющегося членом Европейского Союза и не указанного явно в п. 17.3 - 17.5 настоящего Лицензионного договора (исключая Грецию, Кипр и Мальту) а также на территории Исландии, Лихтенштейна, Норвегии, Нормандских островов или Швейцарии, к отношениям по настоящему Лицензионному договору применяется законодательство, действующее в г. Мюнхене (Германия). Все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в суде г. Мюнхена, Германия.

17.3. В случае если Вы приобрели ПО на территории Соединенного Королевства Великобритании и Северной Ирландии или Республики Ирландия, к отношениям по настоящему Лицензионному договору применяется законодательство, действующее на территории Англии и Уэльса. Стороны принимают юрисдикцию судов Англии и Уэльса.

17.4. В случае если Вы приобрели ПО на территории России, Белоруссии, Казахстана, или другого государства, являющегося членом Содружества Независимых Государств (СНГ), за исключением Украины и Молдовы, а также на территории Грузии, Латвии, Литвы и Эстонии, к отношениям по настоящему Лицензионному договору применяется материальное право Российской Федерации.

17.5. В случае если Вы приобрели ПО на территории Албании, Болгарии, Боснии и Герцеговины, Венгрии, Израиля, Македонии, Польши, Румынии, Словакии, Словении, Турции, Хорватии, Чехии, Сербии, Черногории, Украины или Молдовы, к отношениям по настоящему Лицензионному договору применяется материальное право Украины.

17.6. В случае если Вы приобрели ПО в стране, указанной в п. 17.4, и являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Арбитражном суде г. Москвы, Российская Федерация. В случае если Вы приобрели ПО в стране, указанной в п. 17.4, и являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Перовском районном суде г. Москвы, Российская Федерация.

17.7. В случае если Вы приобрели ПО в стране, указанной в п. 17.5, и являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Международном коммерческом арбитражном суде при Украинской торгово-промышленной палате в соответствие с ее регламентом. Решение данного суда является окончательным и обязательным к исполнению обеими сторонами. В случае если Вы приобрели ПО в стране, указанной в п. 17.5, и являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Шевченковском районном суде г. Киева, Украина.

17.8. К настоящему Лицензионному договору не применяются никакие коллизионные нормы любой юрисдикции, а также Конвенция ООН о договорах международной купли-продажи.

17.9. В случае если Вы приобрели ПО в стране, не указанной в пп. 17.1-17.5, к отношениям по настоящему Лицензионному договору применяется действующее законодательство страны, в которой Вы приобрели ПО.

18. Срок действия и расторжение договора

18.1. Настоящий Лицензионный договор вступает в силу с Даты заключения договора. Настоящий Лицензионный договор действует в течение всего срока действия исключительного права на ПО, если иное не оговорено в настоящем Лицензионном договоре или в отдельном письменном договоре между Вами и Компанией ABBYY.

18.2. Вы имеете право расторгнуть Лицензионный договор, удалив ПО, сопроводительную документацию и все их копии.

18.3. Без ущерба для каких-либо иных прав Компания ABBYY имеет право расторгнуть настоящий Лицензионный договор в случае нарушения Вами каких-либо условий настоящего Лицензионного договора. В этом случае Вы обязаны удалить все копии ПО и Компонентов ПО. Такое расторжение настоящего Лицензионного договора не освобождает Вас от обязательств по оплате ПО и/или Сопровождения ПО.

18.4. Пп. 2.2 - 2.5, 2.9 – 2.10, 3.1, 7, 9.2, 9.3, 10, 17, 20.2 и 20.3 сохраняют свою силу и после расторжения настоящего Лицензионного договора, однако это не дает Вам права продолжать использовать ПО после расторжения настоящего Лицензионного договора.

19. Использование ПО правительственными учреждениями

19.1. В случае если ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных - Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

20. Общие положения

20.1. В случае если какая-либо часть настоящего Лицензионного договора будет признана утратившей юридическую силу (недействительной) и не подлежащей исполнению, остальные части Лицензионного договора сохраняют свою юридическую силу и подлежат исполнению.

20.2. Вы соглашаетесь на добровольную передачу Компании ABBYY своих персональных данные в ходе установки ПО, Активации ПО, регистрации ПО и использования ПО. Вы соглашаетесь с тем, что Компания ABBYY имеет право собирать, обрабатывать и использовать Ваши персональные данные в соответствии с применимым законодательством и при условии сохранения их конфиденциальности. Предоставленные Вами персональные данные будут храниться и использоваться только Компанией ABBYY и ее аффилированными лицами и не будут раскрываться третьим лицам, за исключением случаев, предусмотренных действующим законодательством.

20.3. Компания ABBYY имеет право отправлять Вам письма, в том числе по электронной почте, с информацией о Компании ABBYY, продуктах и специальных предложениях Компании ABBYY, с советами по использованию продуктов Компании ABBYY и другой информацией, имеющей отношение к Компании ABBYY и продуктам Компании ABBYY, в случае если Вы явно согласились получать такого рода информацию от Компании ABBYY. Вы можете в любой момент удалить свой адрес электронной почты из списка рассылок Компании ABBYY.

20.4. Компания ABBYY может предоставить Вам печатные материалы, включая руководство пользователя.

20.5. Вознаграждением по настоящему Лицензионному договору признается стоимость Лицензии на ПО, установленная Компанией ABBYY или Партнерами Компании ABBYY, и подлежащая уплате в соответствии с определяемым ими порядком, либо стоимость Лицензии на ПО, которая входит в стоимость приобретаемого Вами оборудования или полной версии ПО. Если Вы являетесь физическим лицом, данный Лицензионный договор может быть безвозмездным.

20.6. В случае предъявления любых претензий или исков, связанных с использованием Вами ПО Вы обязуетесь сообщить Компании ABBYY о таких фактах в течение трех (3) дней с момента, когда Вам стало известно об их возникновении. Вы обязуетесь совершить необходимые действия для предоставления Компании ABBYY возможности участвовать в рассмотрении таких претензий или исков, а также предоставлять необходимую информацию для урегулирования соответствующих претензий и/или исков в течение семи (7) дней с даты получения запроса от Компании ABBYY.

Приложение A

Соглашение о сопровождении ПО

Настоящее Приложение А является неотъемлемой частью Лицензионного договора, если только иное не оговорено в отдельном письменном договоре между Вами и Компанией ABBYY.

1. Определения

1.1. «Обновление» – улучшения текущей версии ПО, обычно включающие в себя исправления ошибок.

1.2. «Новая версия» – следующая по порядку версия ПО, которая выпускается взамен основной версии используемой Вами на основании Лицензионного договора (например, версия 1.5 заменит собой версию 1.0, версия 2.x заменит собой версию 1.x).

1.3. «Ошибка» – любая неспособность ПО выполнять функции, перечисленные в документации. Возможны следующие три типа ошибок:

1.3.1. Ошибка с приоритетом 1 – ошибка, при которой нет способа обойти проблему, в результате чего производственный процесс на Вашем предприятии останавливается, в том числе ошибка сопровождающаяся сообщением «Внутренняя программная ошибка», «Нехватка памяти», «Нарушение прав доступа», «Общее нарушение защиты», «Общая ошибка защиты» или «Деление на ноль»;

1.3.2. Ошибка с приоритетом 2 – ошибка, которую можно обойти;

1.3.3. Ошибка с приоритетом 3 – незначительная проблема, не сказывающаяся на производственном процессе на Вашем предприятии.

1.4. «Поддержка ПО» означает

(i) предоставляемая Вам Компанией ABBYY Поддержка ПО в случае обнаружения Ошибки с целью восстановить работу ПО в соответствии со спецификацией. Такая поддержка может включать в себя предоставление Вам способа обхода обнаруженной Вами Ошибки или предоставление Вам Обновления для ПО, устраняющего Ошибку;

(ii) информацию, предоставленную Вам Компанией ABBYY в ответ на Ваши вопросы о функциональности, установке, Активации ПО и эксплуатации ПО.

1.5. «Подписка на Новые версии» – часть Сопровождения, которая дает Вам право на получение Новых версий.

2. Сопровождение ПО

2.1. Сопровождение ПО может включать в себя предоставление Обновлений, Подписки на Новые версии и Поддержку ПО или любой комбинации вышеперечисленного.

2.2. Минимальный первоначальный срок Сопровождения ПО после приобретения составляет двенадцать (12) месяцев с даты отправки ПО.

2.3. Для продления периода Сопровождения, необходимо оплатить Компании ABBYY или Партнеру Компании ABBYY продление периода Сопровождения. Если применяется статья 17.2 или 17.3, то срок Сопровождения ПО будет продлен на 12 месяцев без последующего уведомления, если Вы не откажетесь от Сопровождения ПО в течение 45 дней перед окончанием срока Сопровождения ПО. В случае Вашего решения об отказе, оно должно быть выполнено в письменной форме.

2.4. Компания ABBYY или Партнеры Компании ABBYY могут сообщать Вам дополнительные условия Сопровождения ПО.

2.5. Компания ABBYY сохраняет за собой право по своему усмотрению изменять форму и содержание Сопровождения ПО.

2.6. Любой дополнительный код ПО, предоставленный Вам как часть Сопровождения ПО, является частью ПО, и на него распространяются все условия настоящего Лицензионного договора.

3. Новые версии и Обновления

3.1. Новые версии и Обновления должны поставляться на компакт-дисках или по каналам передачи данных (посредством протокола FTP). Затраты на транспортировку, если таковые будут, должны оплачиваться Вами.

3.2. В случае если Вы приобрели Сопровождение в форме Обновлений, Вы имеете право на получение Обновлений от Компании ABBYY или Партнера Компании ABBYY. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Вам Обновления для ПО по мере их появления.

3.3. В случае если Вы приобрели Сопровождение в форме Новых версий, Вы имеете право на получение Новых версий от Компании ABBYY или Партнера Компании ABBYY. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Вам Новые версии ПО по мере их появления.

3.4. В случае если Вы разработаете приложение, которое включает в себя ПО, части ПО или интегрируется с ПО, любая новая главная версия такого приложения должна включать в себя последнее Обновление для ПО, предоставленное Вам Компанией ABBYY не ранее чем за три (3) месяца до выпуска такой главной версии (либо самой последнее Обновление, если последнее Обновление было выпущено более чем за три (3) месяца до выпуска такой главной версии).

4. Поддержка ПО

4.1. В случае если Вы приобрели Сопровождение в форме «Поддержка ПО», компания ABBYY или Партнеры Компании ABBYY обязуются предоставить Поддержку ПО в соответствии с действующими правилами оказания поддержки, опубликованными на веб-сайте Компании ABBYY по адресу http://www.abbyy.com/support/policy. Компания ABBYY сохраняет за собой право в любое время изменять правила оказания поддержки без предварительного уведомления.

4.2. Компания ABBYY или Партнеры Компании ABBYY обязуются предоставлять Поддержку ПО без дополнительной платы для исправления Ошибок с приоритетом 1.

4.3. В случае если Вы приобрели Сопровождение в форме «Поддержки ПО», Компания ABBYY или Партнер Компании ABBYY обязуется предоставить Поддержку ПО не более чем для восьми (8) запросов, касающихся Ошибок с приоритетами 2 и 3 в течение двенадцати (12) месяцев. Поддержка ПО для дополнительных запросов в связи с Ошибками с приоритетами 2 и 3 должны приобретаться дополнительно.

4.4. Компания ABBYY или Партнеры Компании предоставляют Поддержку ПО в течение рабочего дня по телефону или по электронной почте.

4.5. ABBYY или Партнеры Компании обязуются предпринимать разумные усилия для выпуска экстренных Обновлений для ПО, не предусмотренных планом выпуска, для устранения любых Ошибок с приоритетом 1, о которых им было сообщено. В остальных случаях Ошибки с приоритетами 2 и 3 могут исправляться по мере выхода Новых версий. Экстренные Обновления должны выпускаться только для текущей версии ПО с целью исправления Ошибок с приоритетом 1.

4.6. При сообщении об Ошибках Вы обязуетесь предоставлять Компании ABBYY или Партнерам Компании ABBYY информацию, которая необходима для идентификации Ошибки. Такая информация включает в себя описание проблемы, указание платформы и операционной системы, на которых произошла Ошибка, копию входных данных, которые вызвали Ошибку, копию файла формата, который использовался в момент обнаружения Ошибки, и все дампы, которые были сделаны в результате Ошибки. Компания ABBYY или Партнер Компании ABBYY может использовать вышеперечисленную информацию в своих коммерческих целях, в том числе для поддержки и разработки продуктов, при условии что Компания ABBYY или Партнер Компании не использует такую информацию в любой форме, которая позволяет идентифицировать Вашу личность.


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Не может быть пустым – отметьте эту опцию, если вы хотите, чтобы заполнение этого поля было обязательным.
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Индексное поле – отметьте эту опцию, если предполагается производить индексацию документов по этому полю. При обработке документов вы сможете отобразить значение этого поля для каждого документа, производить сортировку и поиск документов по значению поля.
  • Должно быть наложено - отметьте эту опцию, чтобы при верификации данное поле было подсвечено, если его регион не будет найден. В случае неналожения поля оно также будет доступно при переходе по полям документа в режиме Перейти к следующему ненайденному полю при наложении.
  • Комментарии – вы можете ввести любые комментарии.

Свойства полей


Контекстная верификация

Программа позволяет настроить положение курсора при начале верификации поля. Выберите в меню пункт Сервис>Опции… и перейдите на закладку Контекстная верификация.

По умолчанию выделен первый символ поля. Выберите опцию Установить курсор у первого неуверенно распознанного символа, чтобы автоматически выделять первый неуверенно распознанный символ поля.

Если предпочтительнее набирать текст поля целиком, выберите опцию Выделить все поле. В этом случае опция Установить курсор у первого неуверенно распознанного символа будет недоступна для выбора.


Глоссарий

A-Z

ABBYY FlexiCapture

Программное решение для потокового ввода данных с документов различного типа - структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных (документов в свободном стиле).

ABBYY FlexiLayout Studio

Программа, позволяющая создать описание структуры документа произвольного формата, необходимое для его дальнейшего автоматического распознавания.

ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка макета формы является важным этапом, так как от "правильности" разработанного макета (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

ADF

Automatic Document Feeder. Устройство для автоматической подачи бумаги, позволяющее отсканировать большое количество документов без дополнительного вмешательства оператора.

dpi

Dots per Inch. Количество точек на дюйм; единица измерения разрешения.

FlexiLayout

Описание структуры гибкого документа. Это описание разрабатывается в программе ABBYY FlexiLayout Studio и передается в ABBYY FlexiCapture. FlexyLayout – своего рода «инструкция» о том, как следует искать и идентифицировать поля на гибкой форме.

MRC (смешанное растровое содержание)

Процесс применения методов сегментации изображений для улучшения контрастного разрешения растрового изображения, состоящего из пикселей.

OCR

Optical Character Recognition. Оптическое распознавание типографских текстов.

OMR

Optical Mark Recognition. Оптическое распознавание меток. Так называется технология, позволяющая ABBYY FlexiCapture не только уверенно распознавать на формах обычные метки (галочки, крестики, и т.п.), но и правильно идентифицировать метки, отмеченные по ошибке и затем полностью закрашенные.

ICR

Intelligent Character Recognition. Так называют технологии или системы, предназначенные для массовой обработки документов, заполненных печатными буквами и цифрами от руки, то есть для распознавания рукопечатных символов.

XFD

XML Form Definition (*.xfd) – специальный формат файла формы, созданной в программе ABBYY FormDesigner. Файл формата XML Form Definition используется для создания определения документа в программе ABBYY FlexiCapture.

А

Администратор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит настройка программы для ввода документов: создание и редактирование определений документов, профилей импорта.

Алфавит

Набор символов, используемых в описываемом языке.

Б

Буквы в гребенке

Тип разметки текста, при которой ограничителем текста является гребенка. Показать...

Буквы в изолированных рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки изолированы друг от друга. Показать...

Буквы в рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки не изолированы друг от друга. Показать...

В

Верификация

Проверка распознанных данных оператором. Производится путем сравнения результатов распознавания с исходным изображением части документа. Технология верификации реализована в продуктах ABBYY с учётом основных психосоматических особенностей человека: выработки привычек, использования навыков, целостности и целенаправленности восприятия. См. Верификация распознанных данных.

Ввод форм

Извлечение данных из информационных полей форм.

Г

Гибкое описание

Формализованное описание структуры документа, нацеленное на поиск местоположения полей. Создается в ABBYY FlexiLayout Studio. Файл формата *.afl. См. FlexiLayout.

Гибкое определение

Определение документа или раздела, разработанное для обработки гибких документов. Создается путем подключения гибкого описания. Поля таких документов не имеют фиксированного местоположения, их поиск производится с помощью гибкого описания. См. Создание определения для обработки гибких документов.

Горячая папка

Каталог на жестком диске локального или удаленного компьютера, используемый для импорта изображений. Как правило используется для многократной периодической загрузки изображений без участия пользователя. См. Профили импорта изображений.

Группа меток

Элемент машиночитаемой формы, объединяющий несколько меток, находящихся вблизи друг от друга. В Группе меток может выбираться одна или несколько меток.

Групповая верификация

Режим верификации, при котором одинаково распознанные символы поступают на верификацию группой. Подробнее...

    На групповую верификацию подаются поля, в свойствах которых отмечена опция Отправлять символы на групповую верификацию.

    Целесообразно подавать на групповую верификацию символы из полей, которые заполняются цифрами, а также метки.

Д

Данные из документа

Данные, полученные в результате обработки (распознавания, проверки и редактирования результатов распознавания) изображений страниц документа.

Документ

Совокупность одного или нескольких изображений страниц и извлеченной из них информации.

Ж

Жесткая форма

Документ, имеющий заданные информационные поля, оформление, количество и местоположение которых строго определены и не меняются от одного экземпляра документа к другому.

Жесткое описание

определение документа или раздела документа, разработанное для обработки жестких форм. Поля жесткого описания имеют фиксированное расположение.

З

Задание

Набор документов из одного пакета, обрабатывающихся совместно. В зависимости от настроек проекта и этапа обработки может содержать различное количество документов. Если этап обработки предполагает обработку пакета целиком, то в задание входит весь пакет. При автоматическом формировании заданий на верификацию в них попадает по 10 документов (если в пакете менее 10 неверифицированных документов, то они все обрабатываются в одном задании).

Замена изображения

Замена одного изображения другим при редактировании определения.

Запрещенный символ

Символ, который заведомо не может встретиться в определяемом типе данных. Подробнее...

    Указание таких символов может существенно увеличить скорость и надежность распознавания. Например, при распознавании текстов, в которых встречаются только заглавные буквы, в качестве запрещенных следует указать все строчные буквы.

И

Игнорируемый символ

Символ, встречающийся внутри слов (например, маркер (bullet)) или символ мягкого переноса (табуляции и т.д.), наличие которого не мешает слову принадлежать к определяемому типу данных. Подробнее...

    Эти символы исключаются из слов, т.о. принадлежность указанному типу данных определяется для слов без этих символов.

Идентификатор

Статический элемент, который используется для однозначного выбора определения среди нескольких с одинаковым расположением реперов. В свойствах таких статических элементов должна быть отмечена опция Использовать для идентификации определения документа.

Идентификация определений документов

Процесс выбора нужного определения документа с помощью идентификаторов.

Изображение

Электронный образ страницы бумажного документа, полученный в результате сканирования.

Инвертированное изображение

Изображение, текст которого напечатан на темном фоне светлыми буквами.

Индексное поле

Поле, по значению которого производится индексация документов для сортировки и поиска. См. Индексные поля.

Импорт изображений

Добавление в пакет изображений для обработки. Импорт может производиться путем добавления изображений из файлов, путем сканирования или с использованием профилей импорта. См. Добавление изображений страниц.

Исправленная метка

Метка, отмеченная по ошибке, и с целью исправления полностью заштрихованная. В случае если у поля метки включена опция Допускать исправления, то программа распознает заштрихованную метку как незаполненную.

К

Картинка

Элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в виде графического объекта (например, файла).

Классификатор

Проект FlexiLayout Studio, предназначенной для предварительной идентификации страниц перед наложением определений документов и выбора подходящего гибкого описания или его варианта.

Ключевое поле

Поле, позволяющее автоматически проверить сборку страниц в документы. Значения ключевых полей должны совпадать на всех страницах одного документа.

Контекстная верификация

Режим верификации, при котором распознанные символы поступают на верификацию в контексте поля. Подробнее...

    В режиме контекстной верификации неуверенно распознанные символы проверяются в контексте всего поля.

    На контекстную верификацию подаются поля, в свойствах которых отмечена опция Отправлять на контекстную верификацию. Целесообразно подавать на контекстную верификацию те поля, область значений которых известна или легко определяется. Например, таким полем может быть название страны, города: нам известно, какие значения могут встретится в данном поле.

Контрастность

Соотношение яркости самой темной и самой светлой области изображения.

Крест

Репер в виде креста.

М

Матричный принтер

Тип распознаваемого текста, представляющий собой текст, напечатанный на матричном принтере.

Машиночитаемая форма

Форма, специально изготовленная для целей автоматического ввода, которая содержит служебные элементы (реперы, штрих-коды, линии и т.д.), необходимые для ее успешной обработки.

Метка

Элемент машиночитаемой формы, в который при заполнении вносится отметка (галочка, крест, точка, сплошная закраска и т.д.).

Многостраничный документ

Документ, состоящий из нескольких страниц.

Множество допустимых символов

Набор символов, встречающихся в определяемом типе данных. Подробнее...

    Этот набор определяется типом данных. Т.е. тип данных, подключенный к полю, определяет множество символов, используемых при распознавании.

    Помимо непосредственного выбора символов, входящих в это множество, возможно задать дополнительные параметры, его ограничивающие. Например, можно указать:

    • Символы, которые заведомо не могут встретиться при распознавании данного поля, - запрещенные символы (например, для поля, в котором могут быть только заглавные символы, в качестве запрещенных могут быть указаны все строчные буквы).
    • Символы, которые могут встречаться внутри слов, но при этом не влияют на проверку этого слова - игнорируемые символы (например, знаки слогоделения, ударения и т.д.)

Моноширинный текст

Тип разметки текста, при котором под каждую букву слова отводится одинаковая по высоте и ширине рамка, но границы рамки при сканировании исчезают.

Н

Наложение определения документа

Процесс подбора определения документа и наложение полей определения на изображение.

Нераспознаваемый регион

Область изображения, исключенная из распознавания. Нераспознаваемый регион нужен для исключения области с пояснительным текстом или рисунком, мешающим распознаванию поля. См. Исключение региона из распознавания.

Неструктурированный документ

Документ, содержащий информацию, изложенную в свободном стиле. Например, контракты, письма, приказы, графики являются неструктурированными документами. См. Обработка неструктурированных документов.

Неуверенно распознанный символ

Статус, присваиваемый символу автоматически в процессе распознавания, если он был распознан со значительной долей неуверенности.

О

Область поля

Область изображения, выделенная в определении документа и предназначенная для извлечения информации.

Ограничитель текстовых полей

Графический элемент, ограничивающий текстовое поле: рамка, гребенка, линия.

Оператор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит ввод документов: добавление изображений, распознавание, верификация, экспорт распознанных данных.

Определение документа

определение документа определяет принципы, по которым будет происходить идентификация и обработка документов данного типа, и содержит:

  • Структуру документа, т.е. описание допустимой последовательности страниц, которая образует документ данного типа. Структура документа задает правило сборки документа.
  • Описания разделов документа.
  • Список правил, которым должны удовлетворять данные полей.
  • Расположение полей и подписей к ним в окне "Данные" (вид формы данных).
  • Настройки экспорта для документов данного типа.
  • Настройки процесса обработки документов данного типа.

Описание раздела документа

Составная часть определения документа. Соответствует одной или нескольким страницам, содержащим логически завершенный набор полей. Поля внутри одного раздела могут переходить с одной страницы на другую (например, многостраничные таблицы), а наборы полей разных разделов не пересекаются.
Описание раздела может быть гибким, либо жестким.

Ориентация страницы

Расположение страницы относительно правильного расположения: сверху вниз, слева направо. Ориентация страницы может быть автоматически определена при распознавании изображения страницы; с этой целью в программе ABBYY FlexiCapture 10 предусмотрено задание возможной ориентации.

Ориентация текста

Направление текста в поле относительно расположения страницы.

Очередь

Документы, объединенные в задания и / или пакеты, ожидающие обработки на определенном этапе. См. Этапы обработки и очереди

Очистка изображения

Удаление с изображения отдельных мелких черных точек. Лишние точки могут появиться в процессе сканирования и для качественного распознавания данных их лучше удалить. Также при очистке изображения происходит удаление точек фона или ограничительных линий с растровых форм.

Ошибка документа

Если в процессе обработки документа выясняется, что его данные не полностью соответствуют структуре документа и заданным ограничениям на значения полей, а также контрольным правилам, то все несоответствия заносятся в список ошибок и предупреждений документа.

П

Пакет документов

Совокупность документов, сгруппированная пользователем. Обычно пакет соответствует пачке документов, отсканированных за один раз, или импортированных из определенного каталога. См. Пакеты документов.

Пишущая машинка

Тип распознаваемого текста, представляющий собой текст, написанный на пишущей машинке.

Поворот изображения

Поворот изображения вокруг его центра.

Поле

Элемент документа, предназначенный для извлечения данных. Поля могут быть простыми (не имеющими внутренней структуры) или составными, как, например, поле типа «таблица», где каждая ячейка также может рассматриваться как отдельное «дочернее» поле таблицы. См. Создание полей определения документа.

Поле без разметки

Поле, определенное в определении документа, но не имеющее области на изображении. См. Поля без разметки.

Поле Группа Меток

Поле определения документа, содержащее группу меток.

Поле для ручного ввода

Поле определения документа, содержащее нераспознаваемый текст (например, состоящий из слитных букв), который необходимо ввести с клавиатуры.

Поле Картинка

Поле определения документа, содержащее картинку.

Поле Метка

Поле определения документа, содержащее метку.

Поле с несколькими областями

Поле, состоящее из нескольких областей на изображении. Области такого поля могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле. Обычно используется для объектов, расположенных на нескольких страницах, например, для больших таблиц. См. Поля с несколькими областями.

Поле с несколькими экземплярами

Поле, используемое для описания нескольких объектов одинакового типа (повторяющихся объектов). По сути, эти объекты являются одним и тем же полем, и обладают общими свойствами, но их несколько. Для того чтобы не создавать несколько одинаковых полей, используются поля с несколькими экземплярами. Поля с несколькими экземплярами экспортируются в отдельные файлы или таблицы базы данных. См. Поля с несколькими экземплярами.

Поле Таблица

Поле определения документа, содержащее таблицу. Это составное поле, каждый столбец таблицы представляет собой набор полей одного типа: текст, метки, штрих-коды или картинки.

Поле Штрих-код

Поле определения документа, содержащее штрих-код, предназначенный для распознавания.

Полуструктурированный документ

Документ, содержащий набор информационных полей, оформление, количество и расположение которых может значительно отличаться в разных экземплярах документа. См. Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture 10.

Пользовательский тип данных

Тип данных, созданный пользователем. См. Создание пользовательских типов данных.

Потоковый ввод данных

Автоматизированное извлечение данных из аналоговых (печатных) и цифровых (отсканированных изображений в файлах) документов.

Потоковый ввод документов

Автоматизированный перевод бумажных документов в электронный вид.

Пояснительный текст

Элемент машиночитаемой формы, представляющий собой описательный текст (название формы, названия полей, пояснения к полям и т.д.)

Правила

Некоторые условия, накладываемые на данные в полях и автоматически проверяемые программой. См. Проверка с помощью правил.

Приложение

Страницы, не содержащие полей, но участвующие в сборке документа. Из этих страниц не извлекаются данные, но они могут быть сохранены в виде изображения или PDF с возможностью поиска. См. Создание определений для документов с приложениями.

Проверка правил

Автоматическая проверка распознанных данных на соответствие заданным правилам. См. Верификация правил.

Проект

Проект – это единая среда, объединяющая пакеты документов и настройки, необходимые для их обработки, такие как определения документов, профили импорта и другие. См. Создание проекта.

Простой текст

Тип разметки текста, при котором текст вписывается в блок без каких-либо ограничителей.

Профиль импорта

Совокупность настроек, используемых для добавления в пакет изображений: источник импорта, опции обработки изображений, опции очистки горячей папки и др. См. Профили импорта изображений.

Публикация определения документа

Предоставление доступа к новой версии определения документа после редактирования. Опубликованная версия участвует в обработке документов из рабочих пакетов, в то время как неопубликованная, локальная версия, может участвовать только в обработке документов из тестовых пакетов. См. Редактирование и публикация определения документа.

Р

Рабочие пакеты

Пакеты документов, предназначенные для ввода данных. Для обработки рабочих пакетов используются только опубликованные определения документов. См. Пакеты документов.

Раздел определения документа

Набор страниц (или одна страница) и полей, находящихся на них, соответствующий логически законченной части документа. Разделы документа могут описываться "жестким" или "гибким" описанием. См. Создание определений для многостраничных документов.

Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную линию.

Разметка страницы

Схема расположения полей на изображении.

Разметка текста

Способ оформления области страницы, предназначенной для ввода текста. Примеры разметки текста см. в статье Поле для ввода.

Разрешение

Параметр изображения. Измеряется количеством точек, приходящихся на дюйм изображения.

Распознавание

Нахождение соответствия элементов изображения определенным символам.

Распознавание меток (OMR)

Определение наличия отметки в поле метки на форме.

Распознавание текста (OCR, ICR)

Перевод графического изображения в текстовый вид.

Распознавание штрих-кода

Перевод графического изображения штрих-кода в числовой или текстовый вид.

Растровая линия

Линия, состоящая из точек, расположенных на одинаковом расстоянии друг от друга.

Растровая форма

Форма, на которой информационные поля выглядят как белые прямоугольники на сером фоне, состоящем из растровых линий, или как прямоугольники, ограниченные растровыми линиями.

Регулярное выражение

Описание структуры слова или любого вводимого значения на специальном языке. Таким образом, можно определить не только набор допустимых символов, но и структуру содержимого поля. Описать структуру с помощью регулярного выражения можно при задании ограничений для текстового поля или при создании пользовательского типа данных. См. Алфавит, используемый в регулярных выражениях.

Репер

Статический элемент, представляющий собой черный квадрат, прямоугольник, крестик или уголок, и предназначенный для наложения определения. Подробнее...

    Реперы - это специальные элементы дизайна формы, по которым система производит "привязку к местности" после сканирования (выравнивает перекос, компенсирует линейные и нелинейные дефекты сканирования, вычисляет расположение блоков). Наиболее надежными реперами служат черные квадраты, расположенные, как правило, по углам формы. При отсутствии на изображении специальных реперов, для наложения определения документа могут использоваться другие статические элементы: разделители, то есть вертикальные или горизонтальные линии, такие как линии таблиц, оформляющие рамки и т.д., или четкий статический текст, а именно: заголовок формы, подписи к полям, пояснительная информация и т.д. У статических элементов, служащих для наложения определения, должно быть отмечено свойство Использовать для наложения определения документа.

Реперный текст

Статический элемент, представляющий собой текст, присутствующий на незаполненной форме и не предназначенный для извлечения информации. Это может быть любой пояснительный текст или заголовок. Реперный текст может использоваться для наложения определения документа и для идентификации.

Реперный штрих-код

Статический элемент, представляющий собой штрих-код, не предназначенный для извлечения информации. Реперный штрих-код может использоваться для наложения определения документа и для идентификации.

Роль оператора

Свойство учетной записи пользователя ABBYY FlexiCapture 10, определяющее доступные пользователю данные и действия с ними. См. Работа оператора с настроенным проектом

Рукопечатный текст

Тип распознаваемого текста, представляющий собой текст, написанный от руки раздельными буквами..

С

Серая фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на сером фоне, исчезающем при сканировании.

Сканирование

Процесс получения электронного образа страницы бумажной формы с помощью сканера.

Словарь

Список слов, используемый при определении конкретного типа данных. Подробнее...

    Словарь указывается при создании типа данных. Таким образом, тип данных, подключенный к полю, определяет используемый при распознавании и проверке словарь. Помимо существующих предопределенных типов данных с готовыми словарями, программа позволяет подключать типы данных, созданные на основе пользовательских словарей. Данные для словаря могут быть введены вручную или загружены из текстового файла.

Статические элементы

Нераспознаваемые элементы, служащие для наложения определения документа и идентификации. Такими элементами являются: реперы, реперный текст, разделители, реперные штрих-коды.

Стиль написания

Манера написания, присущая определенной группе людей, например американская манера написания цифр. Подробнее...

    Опция, которая задает стиль написания рукопечатных букв в формах. Стиль зависит от региона, в котором формы были заполнены (Россия, Германия, Чехия, США, и т.д.).

Страница

Изображение страницы бумажного документа и результаты его обработки.

Т

Таблица

Данные, расположенные по двумерной сетке, не обязательно видимой. В программе обрабатываются таблицы, состоящие из столбцов, каждый из которых содержит данные одного типа, и повторяющихся строк.

Текст в рамке

Тип разметки текста, при котором ограничителем текста является рамка. Показать...

Текст в рамке с гребенкой

Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки. Показать...

Текст на линии

Тип разметки текста, при котором ограничителем текста является линия снизу. Показать...

Текстовое поле

Элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы.

Тестовые пакеты

Пакеты документов, предназначенные для тестирования и отладки определений документов. Для обработки тестовых пакетов используются локальные копии определений документов. См. Пакеты документов.

Тип данных

Признак поля, описывающий известные ограничения на возможное значение поля и используемый при его распознавании для уменьшения числа возможных вариантов распознавания. Подробнее...

    Одной из характеристик поля является тип данных: число, дата, текст, фамилия, имя, адрес и т.д. Тип данных определяет множество слов, которые могут встречаться в данном поле.

    Тип данных является важным параметром распознавания, влияющим на качество распознавания. Правильно указанный тип данных может существенно уменьшить количество неуверенно распознанных символов.

Тип пакета

Свойство пакета, описывающее параметры обработки документов в соответствующих пакетах. См. Типы пакетов

Типографский текст

Тип распознаваемого текста, представляющий собой текст, полученный типографским способом или с помощью лазерного или струйного принтера с разрешением не менее 300 точек на дюйм.

У

Уголок

Репер в виде уголка.

Ф

Файл описания

Сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. Подробнее см. Файл описания.

Форма

Документ, состоящий из одной или нескольких страниц и предназначенный для заполнения человеком от руки или любым печатным способом.

Ц

Цветная фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на цветном фоне, исчезающем при сканировании.

Ч

Черный квадрат

Репер в виде черного квадрата.

Черно-белая линейчатая форма

Форма, границы информационных полей которой задаются обычными линиями, не исчезающими при сканировании.

Ш

Штрих-код

Элемент машиночитаемой формы, представляющий собой штриховые знаки, кодирующие цифровую информацию посредством чередующихся полос черного и белого цвета определенной длины. Штрих-код в документе может предназначаться для извлечения информации (поле штрих-код) или для наложения или идентификации определения документа (реперный штрих-код).

Э

Экспорт

Процесс передачи обработанных данных во внешнюю информационную систему или файл.

Эталон текста

Файл, содержащий образцы начертания всех символов алфавита.

Этап обработки

Стадия процесса обработки, на которой над документом (или пакетом документов в целом) выполняется определенное действие (автоматически или с участием оператора). См. Этапы обработки и очереди

Я

Язык (регион)

Свойство поля, определяющее язык написания и соответствующие ему наборы региональных параметров (например, способ написания даты или адреса).

Яркость

Порог световой чувствительности, определяющий, начиная с какого значения полутона шкалы градаций серого будут восприниматься сканером как белый цвет.


Глоссарий

A-Z А Б В Г Д Ж З И К М Н О П Р С Т У Ф Ц Ч Ш Э Я


Внутренние имена языков распознавания

Назначение

Внутренние имена языков распознавания используются в свойстве RecognitionLanguages объекта IExportImageSavingOptions.

Соответствие языков распознавания и их внутренних имен:

Abkhaz->Abkhaz Adyghe->Adyghe Afrikaans->Afrikaans Agul->Agul Albanian->Albanian Altaic->Altaic Arabic (Saudi Arabia)->Arabic Armenian (Eastern)->ArmenianEastern Armenian (Grabar)->ArmenianGrabar Armenian (Western)->ArmenianWestern Avar->Awar Aymara->Aymara Azerbaijani (Cyrillic)->AzeriCyrillic Azerbaijani (Latin)->AzeriLatin Bashkir->Bashkir Basque->Basque Bemba->Bemba Blackfoot->Blackfoot Portuguese (Brazilian)->PortugueseBrazilian Breton->Breton Bugotu->Bugotu Bulgarian->Bulgarian Buryat->Buryat Belarusian->Belarusian Catalan->Catalan Chamorro->Chamorro Chechen->Chechen Chinese Simplified->ChinesePRC Chinese Traditional->ChineseTaiwan Chukchee->Chukcha Chuvash->Chuvash Corsican->Corsican Crimean Tatar->CrimeanTatar Croatian->Croatian Crow->Crow Czech->Czech Danish->Danish Dargwa->Dargwa Dungan->Dungan Dutch->Dutch English->English Eskimo (Cyrillic)->EskimoCyrillic Eskimo (Latin)->EskimoLatin Esperanto->Esperanto Estonian->Estonian Even->Even Evenki->Evenki Faroese->Faeroese Fijian->Fijian Finnish->Finnish Dutch (Belgian)->DutchBelgian French->French Frisian->Frisian Friulian->Friulian Scottish Gaelic->GaelicScottish Gagauz->Gagauz Galician->Galician Ganda->Ganda German->German German (new spelling)->GermanNewSpelling German (Luxembourg)->GermanLuxembourg Greek->Greek Guarani->Guarani Hani->Hani Hausa->Hausa Hawaiian->Hawaiian Hebrew->Hebrew Hungarian->Hungarian Icelandic->Icelandic Ido->Ido Indonesian->Indonesian Ingush->Ingush Interlingua->Interlingua Irish->Irish Italian->Italian Japanese->Japanese Kabardian->Kabardian Kalmyk->Kalmyk Karachay-balkar->KarachayBalkar Karakalpak->Karakalpak Kasub->Kasub Kawa->Kawa Kazakh->Kazakh Khakass->Khakas Khanty->Khanty Kikuyu->Kikuyu Kirghiz ->Kirgiz Kongo->Kongo Korean->Korean Koryak->Koryak Kpelle->Kpelle Kumyk->Kumyk Kurdish->Kurdish Lak->Lak Sami (Lappish)->Lappish Latin->Latin Latvian->Latvian Latvian Gothic->LatvianGothic Lezgi->Lezgin Lithuanian->Lithuanian Luba->Luba Macedonian->Macedonian Malagasy->Malagasy Malay (Malaysian)->Malay Malinke->Malinke Maltese->Maltese Mansi->Mansi Maori->Maori Mari->Mari Maya->Maya Miao->Miao Minangkabau->Minankabaw Mohawk->Mohawk Moldavian->RomanianMoldavia Mongol->Mongol Mordvin->Mordvin Nahuatl->Nahuatl Nenets->Nenets Nivkh->Nivkh Nogay->Nogay Norwegian (Bokmal)->NorwegianBokmal Norwegian (Nynorsk)->NorwegianNynorsk Nyanja->Nyanja Occidental->Occidental Ojibway->Ojibway Old English->OldEnglish Old French->OldFrench Old German->OldGerman Old Italian->OldItalian Old Spanish->OldSpanish Ossetian->Ossetic Papiamento->Papiamento Tok Pisin->PidginEnglish Pinyin->Pinyin Polish->Polish Portuguese->PortugueseStandard Occitan->Provencal Quechua->Quechua Rhaeto-Romanic->RhaetoRomanic Romanian->Romanian Romany->Romany Rwanda->Ruanda Rundi->Rundi Russian (Old Spelling)->RussianOldSpelling Russian->Russian Samoan->Samoan Selkup->Selkup Serbian (Cyrillic)->SerbianCyrillic Serbian (Latin)->SerbianLatin Shona->Shona Dakota->Sioux Slovak->Slovak Slovenian->Slovenian Somali->Somali Sorbian->Sorbian Sotho->Sotho Spanish->Spanish Sunda->Sunda Swahili->Swahili Swazi->Swazi Swedish->Swedish Tabasaran->Tabassaran Tagalog->Tagalog Tahitian->Tahitian Tajik->Tajik Tatar->Tatar Thai->Thai Jingpo->Tinpo Tongan->Tongan Tswana->Tswana Tun->Tun Turkish->Turkish Turkmen->Turkmen Tuvinian->Tuvin Udmurt->Udmurt Uighur (Cyrillic)->UighurCyrillic Uighur (Latin)->UighurLatin Ukrainian->Ukrainian Uzbek (Cyrillic)->UzbekCyrillic Uzbek (Latin)->UzbekLatin Cebuano->Visayan Vietnamese->Vietnamese Welsh->Welsh Wolof->Wolof Xhosa->Xhosa Yakut->Yakut Yiddish->Yiddish Zapotec->Zapotec Zulu->Zulu Korean (Hangul)->KoreanHangul Russian and English->Mixed Norwegian->Norwegian Chinese Simplified and English->ChinesePRC+English Chinese Traditional and English->ChineseTaiwan+English Japanese and English->Japanese+English


IVARIANTArray

Назначение

Представляет коллекцию элементов типа Variant.


При открытии проекта

Когда вызывается

Вызывается после открытия нового проекта.

Параметры

Имя | Тип | Права | Значение
Context | IMainWindow | Чтение/запись | Главное окно


При перерисовывании региона

При отображении региона

Когда вызывается

Скрипт выполняется перед перерисовыванием региона.

Если значение параметра DrawDefault равно true, перерисовывание региона будет прекращено. В противном случае регион будет перерисован.

По умолчанию значение параметра DrawDefault равно false.

Parameters

Имя | Тип | Права | Значение
Context | IFieldRegionControl | Чтение/запись | Регион
DrawContext | IDrawContext | Чтение/запись | Контекст изображения
DrawDefault | IBoolean | Чтение/запись | Признак необходимости перерисовывания региона


Свойства описания раздела документа

Просмотреть и изменить свойства описания раздела документа можно в диалоге свойств, который открывается при выборе пункта локального меню раздела Свойства…

Диалог состоит из трех закладок.

Закладка Общие

На этой закладке вы можете изменить название раздела документа, ввести или отредактировать описание, ввести или изменить число минимальное и максимальное число повторений раздела в документе. Опция Включен включает/исключает описание раздела из обработки документов. Подробнее о многостраничных документах и о работе с разделами см. Создание определений для многостраничных документов.

Закладка Гибкое описание

Если к разделу подключено гибкое описание, то на этой закладке отображается его Название, Версия и Комментарий. Вы можете подключить гибкое описание с помощью кнопки Загрузить… и отключить его с помощью кнопки Выгрузить.

Подробнее см. Создание определения для обработки гибких документов.

Закладка Изображения
На этой закладке отображаются параметры изображений страниц, из которых состоит раздел. Вы можете просмотреть значения следующих параметров изображений: размер, разрешение, размер для печати, цветовой режим.

Закладка Правила

Эта закладка предназначена для работы с правилами определения. Вы можете удалять, редактировать и создавать новые правила.

Подробнее см. Проверка с помощью правил.