Что такое ABBYY FlexiCapture 8.0 Professional

Программа ABBYY FlexiCapture 8.0 Professional – это программное решение для автоматизированного ввода данных с бумажных документов в информационные системы и базы данных.

Используя передовые технологии распознавания типографских и рукопечатных символов, обработки изображений и анализа документов, ABBYY FlexiCapture 8.0 Professional позволяет автоматизировать извлечение значимой информации с документов любого типа, обрабатываемых в одном потоке – структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных документов, оформленных в свободном стиле. В результате пользователи ABBYY FlexiCapture 8.0 Professional избавляются от трудоемкого и неэффективного труда, связанного с ручной сортировкой документов и перепечаткой информации с них.

Основной сценарий обработки документов сводится к следующему:

  1. Документы кладутся в автоподатчик сканера и запускается процесс сканирования.
  2. Отсканированные изображения документов поступают на распознавание, в процессе которого программа автоматически идентифицирует документы, в том числе многостраничные, находит значимые поля, извлекает данные и запускает правила проверки.
  3. При необходимости, по окончании распознавания запускается процесс визуальной проверки данных и ошибок правил.
  4. Распознанные и проверенные данные, а также электронные копии документов сохраняются в базу данных, информационную систему или в файл.


Новые возможности ABBYY FlexiCapture 8.0 Professional по сравнению с FormReader 6.5 Desktop

Типы обрабатываемых документов

Многостраничные документы со сложной структурой

Программа предоставляет возможность автоматически идентифицировать и обрабатывать структурированные, полуструктурированные и неструктурированные документы с различным числом страниц, повторяющимися страницами и с приложениями.
Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture 8.0
Создание шаблонов для многостраничных документов
Создание шаблонов для документов с приложениями

Неструктурированные документы

Неструктурированные документы с текстом или изображениями разделенные пустыми страницами, страницами со штрих-кодом или patch-кодом, индексируются с помощью простых шаблонов, обрабатываются и экспортируются в PDF файлы с возможностью поиска или в файлы графических форматов.
Обработка неструктурированных документов

Частично структурированные многостраничные документы со сложными или расположенными на нескольких страницах таблицами

Частично структурированные многостраничные документы с таблицами, перетекающими с одной страницы на другую, идентифицируются, собираются в документы и обрабатываются с использованием одного гибкого описания.
Создание шаблона для обработки гибких документов

Жесткие формы с таблицами

Для упрощения обработки документов, содержащих таблицы, добавлена поддержка таблиц в жестких формах.
Создание таблицы

Повторяющиеся элементы

В структурированных и частично структурированных документах поддерживаются повторяющиеся группы полей. Это упрощает настройку обработки документов, содержащих идентичные группы элементов, повторяющиеся несколько раз, включая обработку сложных таблиц с такими группами.
Создание группы полей

Архитектура программы

Режимы работы Оператора и Администратора

Режимы работы Оператора и Администратора включаются при выборе разных команд меню Пуск, они могут быть установлены на разных компьютерах. В режиме работы Администратора, будут доступны все функции программы. В режиме работы Оператора будет закрыт доступ к редактированию шаблонов документов, профилей импорта и к тестовым пакетам.
Режимы работы администратора и оператора

Работа с проектами

Проект - это единая среда, объединяющая пакеты документов и настройки, необходимые для их обработки, такие как шаблоны документов, профили импорта и другие.

Проект может использоваться разными копиями программы: его можно экспортировать и импортировать как единый объект, обновлять и переносить с одного компьютера на другой. Кроме того, возможна совместная работа разных станций с одним проектом по сети, это позволяет распараллелить и ускорить обработку документов.
Создание проекта
Свойства проекта

Удобные инструменты для работы с фоновыми процессами

Длительные операции, такие как добавление изображений, распознавание, экспорт, могут выполняться в фоновом режиме, что существенно сокращает время обработки документов. Пользователи в любой момент могут проверить статус всех фоновых процессов, изменить приоритет задач, просмотреть журнал.

Фоновый режим

Редактор шаблонов документов

Работа на уровне документов

Шаблоны создаются для всего документа, как единицы обработки, и называются шаблонами документов. Шаблон документов определяет способ идентификации и обработки документов соответствующего типа. Каждый шаблон документов содержит изображения страниц, правила сборки, описания полей и статических элементов, правила проверки, настройки верификации, описания типов данных и настройки экспорта данных.
Создание шаблонов для многостраничных документов

Переключение режимов изображения

В редакторе шаблонов появилась возможность переключения между двумя режимами изображения: возможен просмотр изображений с исходным цветом и в черно-белом варианте, вне зависимости от того, в каком виде изображения будут добавлены в пакет. Цветное изображение облегчает создание шаблона для цветных форм, т.к. в таком режиме видна разметка полей и пояснительный текст: это нужно для рисования области поля и для присвоения полю названия. Просмотр черно-белых изображений важен для того, чтобы убедиться, что реперы и статический текст видны после бинаризации, происходящей в процессе распознавания.

Редактор формы данных

Редактор формы данных позволяет легко создать пользовательское представление извлеченных данных и показывать их в виде, наиболее удобном для оператора.
Настройка отображения данных в окне документа

Отображение полей в виде дерева

Структура документа наглядно представлена в виде дерева полей. Такое представление полей позволяет быстро редактировать, копировать, удалять и перемещать поля.
Отображение структуры документа в виде эскизов страниц

Структура документа представлена в удобном виде эскизов страниц. Это упрощает просмотр, редактирование и создание шаблонов многостраничных документов.
Раздельный просмотр статических элементов и полей

Статические элементы и поля отображаются отдельно. Такое отображение статических элементов и полей упрощает создание шаблона: его можно разделить на два этапа, статические элементы создаются отдельно, а при создании полей реперы, разделители, реперный текст и штрих-коды не мешают создавать областей полей.

Создание полей шаблона документов
Статические элементы
Группировка полей

Поля могут быть объединены в группы для наглядной структуры документов, а также для создания повторяющихся групп полей.

Создание группы полей
Свойства группы полей
Таблицы в жестких шаблонах

В жестких шаблонах появилась возможность создавать поле типа Таблица, что существенно облегчает настройку, извлечение данных и экспорт данных из таблиц. Поле Таблица представляет собой набор из столбцов одного типа и повторяющихся строк.

Создание таблицы
Свойства таблицы
Повторяющиеся элементы в жестких шаблонах

Повторяющиеся элементы – это поля или группы полей, встречающиеся на форме несколько раз и описывающие схожие объекты, например, одни и те же сведения о нескольких сотрудниках, о детях, о счетах. Структура таких повторяющихся элементов сходна с табличной: набор полей представляет собой столбец, а каждое повторение – строку таблицы. Редактор шаблонов документов позволяет облегчить настройку и обработку таких полей.

Поля с несколькими экземплярами
Поля, расположенные на нескольких страницах формы

Если на вашей форме есть поля, область которых расположена на нескольких страницах (например, длинные таблицы), Редактор шаблонов документов позволяет рассматривать их как единое поле, что существенно облегчает настройку и обработку.

Поля с несколькими областями
Автоматизация создания жестких шаблонов

В редакторе шаблонов появились новые средства для автоматизации и упрощения создания жестких шаблонов:

  • автоматическое нахождение текстовых полей с разметкой;
  • автоматическое нахождение вертикальных и горизонтальных разделителей в таблицах;
  • автоматическое нахождение поля одним щелчком кнопки мыши в области поля;
  • автоматическое присвоение полю названия, совпадающего с ближайшим пояснительным текстом;
  • распознавание и копирование статического текста с изображения шаблона в свойства поля;
  • автоматическая подгонка границ поля.
Автоматическое выделение полей и статических элементов
Как изменить название поля
Улучшение настройки типов данных

Переработана настройка типов данных с целью упрощения создания шаблонов документов, улучшения извлечения и проверки данных из полей. Наиболее часто используемые типы данных (текст, дата и время, валюта, число) входят в набор предопределенных типов данных. Наиболее часто используемые форматы предопределенных типов данных входят, в свою очередь, в набор предопределенных форматов и могут быть выбраны из списка без необходимости создавать сложные правила для проверки формата.
Типы данных текстового поля ввода
Создание пользовательских типов данных

Правила проверки, описанные на языке JScript®

Теперь правила проверки могут быть описаны в виде скрипта на языке JScript® (в дополнение к языку VBScript). Это позволяет задавать любые пользовательские правила для проверки извлекаемых данных.
Правило, заданное с помощью скрипта
Использование скриптов для создания правил

Индексные поля

Если в свойствах поля отмечена опция Индексное поле, то значения этого поля могут отображаться в виде дополнительной колонки в окне пакета документов. Документы можно сортировать по значению этого поля. При экспорте значения индексных полей могут быть присоединены к именам файлов, что облегчает поиск нужных данных.
Индексные поля
Критерии формирования имен файлов экспорта

Дополнительные статусы шаблонов документов

При открытии шаблона документа в редакторе шаблонов, автоматически создается временная локальная версия шаблона. Эта редактируемая версия не участвует в обработке документов, пока она не будет опубликована. Эта функциональность позволяет организовать работу с шаблонами в разделяемых проектах.
Редактирование и публикация шаблона

Тестирование шаблонов документов в редакторе шаблона документов и на специальных пакетах

Для упрощения и ускорения создания шаблонов, редактируемые шаблоны могут быть протестированы в процессе их создания, без необходимости закрывать редактор шаблонов документов. Шаблон можно протестировать в процессе создания, на том изображении документа, на основе которого создается шаблон. Также для тестирования предусмотрены специальные тестовые пакеты, которые не участвуют в процессе основной обработки документов.
Тестирование шаблонов документов
Пакеты документов

Импорт изображений

Автоматическая сборка страниц в документы

Входящий поток изображений, поступающий со сканера или из горячей папки, может быть автоматически разделен на документы при использовании:

  • многостраничных форматов изображений, таких как TIFF или PDF;
  • пустых страниц, страниц со штрих-кодами или patch-кодами.
Добавление изображений страниц
Параметры обработки изображений
Профили импорта изображений

Профили импорта изображений предназначены для создания наборов предопределенных настроек для различных источников импорта документов (сканеров или папок). Профиль импорта сохраняется, и ему присваивается название, которое потом просто выбирается из списка оператором.
Профили импорта изображений

Импорт при нажатии одной кнопки

Импорт изображений, в соответствии с настройками последнего используемого профиля, можно производить при нажатии одной кнопки.
Добавление изображений страниц

Фоновый режим импорта

Импорт может производиться в фоновом режиме, поиск новых изображений в горячей папке производится через заданный период времени.

Фоновый режим

Классификация, наложение шаблонов, распознавание

Полнотекстовое распознавание для экспорта в PDF с возможностью поиска

Поддержан сценарий полнотекстового распознавания документов с последующим экспортом в файлы формата PDF и PDF\A с возможностью поиска, что актуально для архивирования неструктурированных и частично структурированных документов.
Новые языки распознавания

Киргизский, казахский (OCR/ICR)

Тайский (OCR)

Поддерживаемые языки распознавания
Новые типы штрих-кодов

Matrix 25, Industrial 25, PostNet.

Поддерживаемые типы штрих-кодов
Нахождение исправленных символов в жестких формах

Если ошибочно написанный символ плотно заштрихован, он подается оператору в процессе верификации, для того чтобы оператор ввел правильный символ вручную.
Удаление страниц- разделителей

Страницы со штрих-кодами, patch-кодами и пустые страницы, используемые в качестве разделительных листов, могут быть автоматически удалены из пакета.

Параметры обработки изображений
Удаление пустых страниц

Пустые страницы могут быть удалены на этапе распознавания.

Свойства проекта

Верификация данных

Улучшение интерфейса для верификации
  • Полноэкранный режим.
  • В строке состояния отображается текущий процент проверенных символов.
Верификация распознанных данных
Новые возможности настройки интерфейса
  • Пользователь может изменять расположение окна с изображением поля, помещая его сверху или снизу от проверяемых данных.
  • Масштаб окна можно изменять, появилась функция автоматического подбора наилучшего масштаба.
  • Пользователь может менять размер шрифта символов.
Верификация распознанных данных
Улучшения групповой верификации
  • Всплывающая подсказка с контекстом символов.
  • Настройка размера и контрастности прилегающей к символу области.
Групповая верификация
Улучшения контекстной верификации
  • Форматные правила теперь можно проверить в процессе контекстной верификации. Пользователь видит описание ошибки и располагает списком подсказок для замены значения.
  • Доступен режим отображения поля с нарезкой символов.
  • Поддерживаются многострочные поля.
  • Всплывающие подсказки для символов, которые облегчают понимание, например, буква "O" и цифра "0".
Контекстная верификация
Распознавание полей "на лету"

В процессе верификации в окне документа, каждое изменение границ области поля приводит к автоматическому перераспознаванию соответствующей области изображения. Эта возможность упрощает и ускоряет извлечение данных из полей с неточно заданной областью.
Улучшенный интерфейс для исправления ошибок правил
  • Каждое правило в списке ошибок правил сопровождается ссылкой на соответствующее поле. Эти ссылки обеспечивают быстрый переход к полям с возможной ошибкой.
  • Список ошибок правил может быть размещен в нижней, верхней, правой или левой части окна документа.
Верификация правил
Исправление ошибок сборки документов в режиме показа эскизов страниц

Доступен новый режим эскизов страниц документов пакета. Этот режим очень удобен для исправления ошибок сборки документов, т.к. он позволяет:

  • увидеть эскизы страниц, сгруппированные по документам;
  • увидеть несовпадение значений ключевых полей и описание ошибок сборки;
  • исправлять ошибки сборки, перемещая страницы из одного документа в другой, перетаскивая изображения с помощью мыши;
  • изменять масштаб эскизов страниц для просмотра деталей (нажав Ctrl + вращая колесо мыши).
Сборка страниц в документы
Возможность открытия файлов PDF, защищенных паролем

Добавление файлов в формате DjVu
Поддерживаемые графические форматы

Экспорт

Экспорт в MS SharePoint

Добавлена возможность настройки экспорта в SharePoint через интерфейс программы.

Экспорт данных в библиотеку документов SharePoint
Экспорт при нажатии одной кнопки

Если заданы настройки экспорта, экспорт пакета документов осуществляется при нажатии одной кнопки. Это освобождает оператора от выполнения лишних действий и ускоряет процесс ввода документов.

Экспорт распознанных данных
Экспорт изображений документов вместе с данными

Вместе с экспортом данных может осуществляться экспорт изображений соответствующих документов.
Удобные критерии формирования имен файлов экспорта

При экспорте в файл и в SharePoint имена файлов формируются автоматически на основании критериев, заданных пользователем. К имени файла экспорта можно присоединить значения индексных полей, значения штрих-кода со старниц-разделителей и т.д. Удобные наименования значительно облегчает поиск нужных данных.
Критерии формирования имен файлов экспорта

Новые форматы документов и изображений

PDF, PDF/A с возможностью поиска

Поддерживаемые графические форматы
Привязка полей при экспорте в базу данных

Настройка экспорта в базу данных сопровождается удобным интерфейсом для привязки полей, позволяющим быстро поставить в соответствие полям документов поля базы данных.

Экспорт в базу данных
Экспорт, описанный с помощью скрипта

Пользователь может описать любые процедуры экспорта на языках VBScript и JScript®.

Экспорт, описанный с помощью скрипта
Использование скриптов для описания экспорта
Изменения разрешения изображений при экспорте

Разрешение экспортируемых изображений может быть изменено для удовлетворения требований их хранения.

Настройка экспорта данных
Экспорт картинок в виде файла

Изображение всего документа или отдельного поля типа "Картинка" может быть экспортировано в отдельный графический файл.
Удаление из пакета проэкспортированных документов

Если нет необходимости хранить проэкспортированные документы в пакете, их можно удалять сразу после осуществления экспорта.

Экспорт распознанных данных
Дополнительные настройки


Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture 8.0

ABBYY FlexiCapture 8.0 Professional – программное решение для потокового ввода данных с документов различного типа.

Документы различных типов могут обрабатываться в одном потоке. Можно также настроить обработку документов смешанного типа, например, состоящих из жестких и гибких разделов. Тип документов влияет только на настройку системы, а именно, на способ создания шаблона документов. Работа оператора не зависит от типа обрабатываемых документов.

С помощью ABBYY FlexiCapture вы сможете настроить автоматизированный ввод следующих документов, в том числе в одном потоке:

структурированных – жестких форм;
К структурированным относятся документы с набором выделенных информационных полей, оформление, количество и местоположение которых не меняются от одного экземпляра документа к другому. Такие документы называются жесткими формами. Например, анкеты, опросники, заявления чаще всего являются жесткими формами. Чаще всего такие формы распространяются в виде бланков и заполняются от руки.

Чтобы идентифицировать жесткую форму в потоке документов и извлечь из нее данные, необходимо создать единую жесткую разметку, которая укажет программе места расположения полей, из которых нужно извлечь данные.

Наиболее эффективно производится обработка жестких форм, созданных с учетом требований автоматического ввода. Такие формы называют машиночитаемыми формами. Подробнее о требованиях к таким формам и способах их создания читайте в разделе Создание машиночитаемых форм.

В состав программы входит удобный инструмент разработки машиночитаемых форм ABBYY FormDesigner 8.0 (Поставляется вместе с ABBYY FlexiCapture 8.0 Professional). О создании форм с помощью ABBYY FormDesigner 8.0 читайте в руководстве и справке к этой программе.

Основные этапы создания шаблона описаны именно для структурированных документов.
частично структурированных – гибких форм и документов;
К ним относятся документы, содержащие набор информационных полей, оформление, количество и расположение которых могут значительно отличаться в разных экземплярах документа. Эти документы называются гибкими. К примеру, счета являются гибкими документами, т.к. они часто отличаются как количеством позиций, так и форматированием, потому что они поступают от разных компаний. На всех счетах присутствуют номер счета и сумма платежа, но и они расположены в разных местах.

Для идентификации гибких форм и извлечения из них данных программа ABBYY FlexiCapture 8.0 Professional использует гибкую разметку (FlexiLayout). Для создания гибкой разметки используется специальный модуль ABBYY FlexiLayout Studio, подробную информацию о работе которого можно найти в руководстве и справке к этому модулю.

Процесс обработки гибких документов отличается от обработки жестких форм только на этапе создания и подключения разметки. Подробнее см. Создание шаблона для обработки гибких документов.
неструктурированных документов, оформленных в свободном стиле.
Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, графики, то и в этом случае поможет ABBYY FlexiCapture 8.0 Professional. Неструктурированные документы могут быть автоматически идентифицированы программой либо как приложения к жестким или гибким формам, либо с помощью гибкой разметки, а затем экспортированы в виде PDF файлов с возможностью поиска или файлов графических форматов. Извлекать индексные поля из неструктурированных документов можно как автоматически с помощью гибкой разметки, так и с помощью ручного ввода.

Типичным сценарием обработки неструктурированных документов является задача перевода бумажного архива в электронный вид с необходимостью извлечения двух-трех индексных полей для организации быстрого поиска по атрибутам.

Подробнее см. Обработка неструктурированных документов.


Краткое описание процесса обработки документов с помощью программы ABBYY FlexiCapture 8.0 Professional

В этом разделе вы узнаете, как обрабатывать документы с помощью программы ABBYY FlexiCapture 8.0 Professional. Информация в этом разделе носит обзорный характер.

Подробно процесс работы с программой описан в разделах Настройка программы и Работа оператора с настроенным проектом.

Обзор настройки программы для обработки документов
Обзор работы с настроенной программой


Краткое описание настройки программы для обработки документов

Настройка программы для обработки документов определенного типа выполняется администратором. Чтобы подготовить программу к обработке документов, нужно:

  1. Создать проект

    Проект включает в себя все настройки для обработки документов определенного типа: профили импорта изображений, шаблоны документов, пакеты документов для обработки.

  2. Создать один или несколько шаблонов документов

    Создание шаблона – основной и самый ответственный этап настройки проекта. Если вы собираетесь обрабатывать в одном потоке документы разного типа, то в рамках одного проекта нужно создать несколько шаблонов.

  3. Создать профили импорта изображений

    Профили импорта создаются для удобства и ускорения работы оператора. Если профили импорта не настроены, то при добавлении изображений приходится каждый раз выбирать источник импорта и задавать необходимые настройки, а профили импорта позволяют добавлять изображения нажатием одной кнопки, а также легко переключаться между источниками импорта.

  4. Создать пакет документов

    Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки. При попытке добавления изображений при отсутствии пакетов, пакет будет создан автоматически.

Подробнее о настройке программы


Создание проекта

В рамках одного проекта можно обрабатывать различные документы, для этого в проекте должно быть несколько шаблонов. Если же потоки документов не пересекаются и настройки для их обработки сильно отличаются, то для них можно создать отдельные проекты.

Для начала работы нужно создать хотя бы один проект.

При запуске программы открывается диалог Открытие проекта, который позволяет выбрать один из существующих проектов или создать новый, нажав на кнопку Новый….

Если программа ABBYY FlexiCapture 8.0 Professional уже запущена и открыт один из проектов, то для создания нового проекта выберите пункт меню Файл>Новый проект…

Подробнее о создании проекта


Обзор создания шаблона документов

Создание шаблона – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Шаблон описывает расположение элементов документа, указывает, откуда будут извлечены данные.

Для начала создания любого шаблона, нужно запустить Мастер создания шаблона документов, для этого:

  1. В главном меню ABBYY FlexiCapture 8.0 Professional выберите пункт Проект>Шаблоны документов…
  2. В открывшемся диалоге Шаблоны документов нажмите кнопку Новый…
  3. Следуйте инструкциям Мастера создания шаблона документов.

Основные этапы создания шаблона зависят от типа обрабатываемых документов.

Основные этапы создания шаблона для жестких форм
  1. Создание нового шаблона документов с помощью Мастера создания шаблона документов. В процессе работы Мастера нужно открыть изображение страницы документа, на основе которого будет произведена разметка шаблона.
  2. Разметка статических элементов - реперов и идентификаторов, задание их свойств. Статические элементы используются для наложения шаблона и идентификации. Статические элементы обычно выделяются автоматически и им присваиваются свойства по умолчанию.
  3. Разметка полей на изображении. Поля используются для извлечения данных.
  4. Задание свойств полей. Свойства полей влияют и на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку, определяют типы данных и область значений поля.
  5. Для создания шаблонов многостраничных документов: добавление страниц и повторение всех этапов для каждой страницы.
  6. Настройка экспорта данных.
  7. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  8. Тестирование шаблона на изображениях нескольких документов.

Замечание. Если вы создавали машиночитаемые формы с помощью программы ABBYY FormDesigner, то вместо первых трех этапов достаточно импортировать файл с расширением *.xfd. Откроется изображение страницы с готовой разметкой (или нескольких страниц, если в программе ABBYY FormDesigner была создана многостраничная форма). Подробнее см. Импорт шаблона для форм, созданных в программе ABBYY FormDesigner.

Основные этапы создания шаблона для гибких документов
  1. Создание гибкого описания (файл *.afl) с помощью программы ABBYY FlexiLayout Studio. Подробнее см. справку программы ABBYY FlexiLayout Studio.
  2. Создание нового шаблона документов с помощью Мастера создания шаблона документов. В процессе работы Мастера нужно открыть изображение страницы документа и подключить гибкое описание (созданный файл *.afl). После завершения работы мастера разметка полей уже будет присутствовать на изображении.
  3. Задание свойств полей. Производится аналогично заданию свойств в шаблоне для жестких форм.
  4. Настройка экспорта данных.
  5. При необходимости, можно настроить отображение данных в окне документа, проверку с помощью правил и т.д.
  6. Тестирование шаблона на изображениях нескольких документов.

Для документов смешанного типа, содержащих как страницы с жесткими формами, так и полуструктурированные разделы, можно подключить гибкое описание в качестве одного из разделов шаблона. Начните создание шаблона с любого раздела (гибкого или жесткого), а затем добавьте новый раздел другого типа.

Документы разных типов можно обрабатывать в одном потоке: в одном проекте можно создать шаблоны и для жестких форм, и для гибких документов, и шаблоны для документов смешанного типа. Шаблон выбирается программой автоматически.

Для обработки документов с приложениями создайте шаблон документа, а затем в свойствах шаблона отметьте опцию Подключить страницы приложения. Cм. Создание шаблонов для документов с приложениями.

Подробнее о создании шаблонов


Создание профилей импорта

Оператор начинает работу с добавления в проект новых изображений: это могут быть бумажные документы, которые он должен отсканировать, или уже имеющиеся электронные изображения.

Часто выполняемые действия по добавлению регулярно поступающих из одного и того же места изображений можно автоматизировать, тогда импорт будет производиться нажатием одной кнопки. Для этого нужно создать профиль импорта изображений. Кроме того, можно настроить параметры обработки поступающих изображений и периодическое добавление изображений в фоновом режиме. Если произведены необходимые настройки, то при нажатии одной кнопки выполняется сканирование или импорт из заранее настроенного источника, а полученные изображения обрабатываются (например, очищаются от «мусора»). При желании пользователь может сменить источник ввода изображений или его настройки.

В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

Чтобы добавить профиль импорта, выберите пункт меню Проект > Профили импорта изображений… главного окна программы. В открывшемся диалоге вы можете создавать новые профили импорта, редактировать, удалять и копировать существующие профили.

Подробнее о создании профилей импорта


Создание пакетов документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

Если в проекте нет ни одного пакета, то при попытке добавления изображений пакет будет создан программой автоматически.

Чтобы создать новый пакет выберите пункт контекстного меню Новый пакет, появляющегося при нажатии правой кнопки мыши в главном окне со списком пакетов.

Подробнее о создании пакетов документов


Обзор работы оператора с настроенной программой

Оператор работает с программой, уже настроенной для обработки документов определенного типа. Процесс обработки документов не зависит от типа документов и состоит из следующих этапов:

  1. Добавление изображений

    Удобнее всего добавлять изображения страниц документов, если в проекте настроены профили импорта. Также можно добавлять изображения путем сканирования или загружать их из файлов.

  2. Запуск процесса распознавания

    Распознавание производится автоматически: программа определяет шаблон документа по расположению статических элементов, заданных в шаблонах, производит наложение шаблона и распознает данные из указанных в шаблоне областей - полей. До запуска распознавания можно произвести анализ документов или их страниц, а также наложить на изображение указанный шаблон.

  3. Верификация

    Верификация – процесс проверки данных – самый трудоемкий этап работы оператора. Он подразделяется на:

    • Верификацию сборки документов – проверку правильности сборки страниц в документы;
    • Групповую верификацию – визуальную проверку группы одинаково распознанных символов;
    • Контекстную верификацию – проверку неуверенно распознанных символов в контексте полей с известной областью значений;
    • Верификацию правил – проверку ошибок правил.

  4. Экспорт данных

    Экспорт производится при нажатии одной кнопки согласно настройкам экспорта, заданным в шаблоне. Кроме того, можно экспортировать данные в файл или в базу данных, не используя настройки экспорта шаблона.

Подробнее о работе оператора с настроенным проектом


Добавление изображений

Для того чтобы добавить изображения, выберите нужный пакет или создайте новый пакет. Кнопка импорта позволит вам добавить изображения разными способами, надпись на кнопке меняется в зависимости от выбранного способа импорта.

Если в проекте настроены профили импорта, то их названия будут отображаться в качестве пунктов меню кнопки импорта. Для того чтобы приступить к импорту, достаточно выбрать один из них.

Чтобы загрузить изображения из файла, нажмите на стрелку справа от кнопки импорта и выберите пункт меню Загрузить изображения…. Выберите файлы с изображениями, задайте необходимые опции и выполните импорт.

Чтобы добавить изображения со сканера, нажмите на стрелку справа от кнопки импорта и выберите пункт меню Сканировать изображения…

При выборе пункта меню Импортировать изображения… вы сможете не только выбрать один из существующих профилей импорта изображений и приступить к импорту, но и добавить новый профиль или отредактировать один из существующих.

Подробнее о добавлении изображений


Запуск процесса распознавания, анализ и наложение шаблона

Распознавание производится при нажатии кнопки Распознать.

Для предварительного анализа изображений нажмите на стрелку справа от кнопки Распознать и выберите пункт меню Наложить шаблон…. Если шаблон может быть наложен, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни один из шаблонов проекта не может быть наложен на изображение, то страница остается необработанной.

Программа также позволяет наложить на страницу или на весь документ определенный шаблон. В большинстве случаев правильно созданный в программе шаблон накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить шаблон вручную. Чтобы наложить шаблон, выделите документ или страницу, нажмите на стрелку справа от кнопки Распознать и выберите пункт меню Наложить шаблон…

Подробнее о распознавании


Верификация

Процесс верификации запускается при нажатии кнопки Начать верификацию…. Процесс начинается с групповой верификации, за ней следует контекстная. Если в шаблоне нет полей включенных в групповую или контекстную верификацию, то соответствующий этап верификации будет пропущен.

Для многостраничных документов нужно исправить возможные ошибки сборки документов. Сборка страниц в документы производится автоматически. Документы с ошибками сборки помечаются значком [image]. Описание ошибки выводится текстом красного цвета под названием шаблона документа. При создании шаблона документа задается правило сборки документа: порядок следования и количество повторений страниц. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа. При несовпадении пользователь увидит сообщение об этом и значения ключевых полей будут отображены красным цветом. Ошибки сборки удобнее всего исправлять в режиме эскизов страниц, т.к. пользователь хорошо видит изображения страниц и их принадлежность к документам.

В процессе групповой верификации на проверку подаются группы одинаково распознанных символов. Задача оператора - выделить отличающиеся символы, распознанные неправильно, и исправить их значения, просмотрев, если нужно, изображения поля с этим символом. При невозможности исправления символы можно пометить как сомнительные.

В процессе контекстной верификации на проверку подаются поля с известной областью значения. Задача оператора - проверить неуверенно распознанные символы в контексте всего поля. Контекстная верификация имеет два режима: режим просмотра одного поля с нарезкой символов и режим просмотра нескольких однотипных полей.

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки. Оператору нужно проверить поля с ошибками правил и, по возможности, исправить их значения. Для запуска верификации ошибок правил нажмите на стрелку справа от кнопки и выберите пункт меню Перепроверить правила. Если правила выполняются после исправления значений полей, то флажки будут сняты.

Верификация данных также производится в окне документа (открывается двойным щелчком мыши на названии документа или страницы). В окне документа пользователь видит уже не отдельные поля, а весь документ целиком. Также ему видны все неуверенно распознанные символы, ошибки правил и т.д.

Подробнее о верификации


Экспорт

Для того чтобы выполнить экспорт распознанных и верифицированных документов, достаточно нажать на кнопку Экспортировать. Экспорт будет выполнен согласно настройкам, заданным в шаблоне документов.

Если вы хотите выполнить экспорт в файл, нажмите стрелку справа от кнопки и выберите меню Экспортировать в файлы…

Для экспорта в базу данных выберите пункт меню Экспортировать в базу данных…

При необходимости измените настройки экспорта, используемые по умолчанию, и выполните экспорт.

Подробнее об экспорте


Установка и запуск программы

В данном разделе содержится основная информация об установке, защите и запуске программы ABBYY FlexiCapture 8.0 Professional, системные требования для установки программы.

Защита программы
Программа для управления ключом защиты License Manager
Программные и аппаратные требования
Установка программы ABBYY FlexiCapture 8.0 Professional
Запуск программы


Защита программы

Виды защиты

Для установки и корректной работы ABBYY FlexiCapture 8.0 Professional требуется наличие ключа защиты.

В поставку ABBYY FlexiCapture 8.0 Professional может входить один из двух видов ключа защиты:

  • аппаратный ключ защиты или
  • программный ключ защиты.

Защита аппаратным ключом

Защита аппаратным ключом представляет собой защиту с помощью ключа для USB-порта (USB-ключ).

Для корректной работы ABBYY FlexiCapture 8.0 Professional с аппаратным ключом защиты необходимо установить драйвер из программы установки. Работа с программой возможна только в том случае, если ваш ключ защиты подключен к USB-порту компьютера.

В аппаратном ключе записаны параметры лицензии.

Можно активировать пустой аппаратный ключ удаленно, имея на руках только серийный номер лицензии. Для этого надо запустить инструмент DongleUpdate (DongleUpdate.FlexiCapture.exe), нажать кнопку Новая лицензия и ввести серийный номер. Программа свяжется с сервером активации (по интернет), запросит параметры этого серийного номера и запишет их в ключ.

Внимание! Для работы с USB-ключами защиты необходимо, чтобы запускался стандартный сервис SmartCard.

Защита программным ключом

Программный ключ представляет собой лицензионный файл.

Для корректной работы ABBYY FlexiCapture 8.0 Professional с программным ключом лицензионный файл должен быть активирован на сервере активации ABBYY. Это может быть сделано из программы установки ABBYY FlexiCapture 8.0 Professional или из программы License Manager.

Информация для активации передается в виде кода (Product ID), который генерируется на основе информации о компьютере, на который установлена программа ABBYY FlexiCapture 8.0 Professional. При генерации кода не используется никакая персональная информация о пользователе или его компьютере и этот код не может быть использован для идентификации пользователя.

Способы активации:

  • Через интернет
    Активация через интернет производится автоматически и занимает всего несколько секунд. Для активации лицензионного файла этим способом требуется подключение компьютера к интернету.
  • По электронной почте
    Для активации по электронной почте пользователь должен отправить автоматически сгенерированное сообщение, содержащее необходимую для активации информацию. Чтобы обеспечить быстрый ответ от почтового робота, пожалуйста, не изменяйте текст и тему письма.

При активации через интернет, весь процесс происходит автоматически. При активации по электронной почте, полученный активационный файл необходимо загрузить через мастер активации, который вызывается из программы License Manager.

Повторная активация

Вы можете переустанавливать программу ABBYY FlexiCapture 8.0 Professional на том же компьютере неограниченное число раз без повторной активации. Однако, если вы производили значительные обновления, форматировали жесткий диск или переустанавливали операционную систему, вам может понадобиться повторная активация.

Для каждого серийного номера ведется подсчет количество возможных активаций. После превышения этого лимита активация невозможна. Пользователь может освободить активированную лицензию используя деактивацию, при этом счетчик потраченных активаций уменьшится.

Внимание! Лицензионный файл, активированный для одного компьютера, не будет работать на другом компьютере, т.к. в нем прописываются параметры компьютера, на котором происходит его активация.


Программа для управления ключом защиты License Manager

Программа License Manager управляет работой ключа защиты и позволяет получить информацию о лицензии программы ABBYY FlexiCapture 8.0 Professional.

Внимание!

Программа License Manager является административной программой. Для работы с программой License Manager необходимо, чтобы пользователь имел права локального администратора.

Программа License Manager устанавливается:

  • при локальной установке: на компьютер, на который произведена локальная установка ABBYY FlexiCapture 8.0 Professional.
  • при сетевой установке: на сервер.

Чтобы запустить программу License Manager:

  • В меню Пуск>Программы>ABBYY FlexiCapture 8.0 Professional>Инструменты выберите пункт ABBYY FlexiCapture 8.0 Professional License Manager.

Управление лицензиями

Добавление новой лицензии

Чтобы добавить лицензию, в главном окне программы License Manager нажмите на кнопку Добавить новую... В открывшемся диалоге введите новый серийный номер и нажмите Добавить, либо нажмите Из файла... и укажите текстовый файл, в котором содержаться серийные номера.

Новая лицензия (лицензии) появится в списке главного окна программы License Manager.

Активация лицензии

Лицензию необходимо активировать, для этого после ее добавления в список нажмите кнопку Активировать... Лицензию можно активировать по Интернет (рекомендуемый способ) или по электронной почте. Следуйте инструкциям программы.

Обновление лицензии

Чтобы обновить лицензию, выделите ее в списке главного окна программы License Manager нажмите на кнопку Обновить лицензию... Вам также потребуется активация по Интернет или по электронной почте. Следуйте инструкциям программы.

Параметры лицензии

В программе License Manager можно просмотреть параметры лицензии, для этого выделите ее в списке и нажмите Параметры лицензии...


Параметры лицензии

У каждой лицензии есть свой серийный номер. Лицензия состоит из набора параметров. Набор параметров лицензии определяет право пользователя на выполнение отдельных операций.

Есть два типа лицензий для рабочих станций:

  • Полнофункциональная лицензия – разрешает запуск станции администратора и всех инструментов (FormDesigner, FlexiLayout Studio). Если нет свободных лицензий оператора, то разрешает также запуск станции оператора.
  • Лицензия оператора – разрешает запуск станции оператора.

В лицензии обязательно указано количество полнофункциональных станций и станций оператора, которые могут работать одновременно. Например, 2 полнофункциональных и 5 станций оператора означает, что можно запустить две станции администратора (на разных компьютерах, или на одном компьютере, но под разными пользователями) и 5 станций оператора одновременно. Если заняты 5 лицензий оператора, то при попытке запуска еще одной станции оператора используется полнофункциональная лицензия.

Параметры лицензии:

  • Дата истечения срока действия – показывает, на какое время рассчитана лицензия.
  • Ограничение количества страниц – показывает, сколько страниц можно распознать за определенный период времени.
  • Открытие файлов PDF – разрешает открывать PDF документы.
  • PDF с возможностью поиска – позволяет экспортировать в PDF с полнотекстовым поиском.
  • Гибкие описания – позволяет пользоваться гибкими описаниями.
  • Максимальное количество полей – определяет максимально допустимое количество полей в одном шаблоне документа.
  • FlexiLayout Studio – позволяет запускать FlexiLayout Studio.
  • FormDesigner – позволяет запускать FormDesigner.


Программные и аппаратные требования

  1. ПК с процессором семейств Intel® Pentium®/Celeron®/Xeon™/Athlon™/Duron™/Sempron™ или совместимым с ними процессором, тактовая частота которого составляет:
    • не менее 500 МГц. (рекомендуется: процессор 2 ГГц и выше) - для Microsoft Windows Vista;
    • не менее 350 МГц (рекомендуется: процессор 2 ГГЦ выше) - для Windows 2000/XP/2003.
  2. Операционная система:
    • Microsoft ® Windows Vista™;
    • Microsoft Windows Server 2003;
    • Microsoft Windows XP (Service Pack 2 и выше);
    • Microsoft Windows 2000 (Service Pack 3 и выше);
    • Microsoft Windows Server 2000 (Service Pack 3 и выше).

    Для работы с локализованным интерфейсом операционная система должна обеспечивать необходимую языковую поддержку.

  3. Оперативная память:
    • не менее 512 Mб. (рекомендуется 1024 Mб.) - для Windows Vista;
    • не менее 128 Mб. (рекомендуется 512 Mб.) - для Windows ХР/2003;

    При работе в многопроцессорных системах требуется дополнительно 16 Мб оперативной памяти для каждого дополнительного процессора.

  4. Свободное место на диске: 420 Мб - минимальная конфигурация (установка только станции оператора), 450 Мб для обычной локальной установки (станция оператора и администратора, инструменты FlexiLayout Studio и FormDesigner); 200 Мб для работы системы (рекомендуется: 1 Гб).
  5. Сканер с поддержкой TWAIN или ISIS.
  6. Интернет-соединение для активации серийного номера, USB-порт для аппаратного ключа защиты.
  7. Видеоплата и монитор с разрешением не менее 800×600.
  8. Клавиатура, мышь или другое указательное устройство.


Установка программы ABBYY FlexiCapture 8.0 Professional на локальный компьютер

Установка программы ABBYY FlexiCapture 8.0 Professional

На время установки программы ABBYY FlexiCapture 8.0 Professional рекомендуем вам закрыть все другие приложения (например, Microsoft Outlook, Microsoft Word и т.п.).

Для того чтобы установить программу ABBYY FlexiCapture 8.0 Professional:

  1. Вставьте установочный компакт-диск ABBYY FlexiCapture 8.0 Professional в дисковод для компакт-дисков.
  2. Выберите пункт Локальная установка в меню программы Autorun (или запустите программу установки setup.exe с компакт-диска) и следуйте указаниям программы установки.
  3. Выберите язык установки (русский или английский). После выбора языка производится сравнение языка (locale) системы и выбранного языка установки, если они несовместимы, то выводится сообщение об этом.
  4. Далее производится проверка операционной системы и наличие прав администратора Если используемая операционная система не поддерживается или пользователь не обладает правами администратора, выводится сообщение об этом и установка прерывается.
  5. Если все проверки прошли успешно, откроется диалог с лицензионным соглашением. Внимательно прочитайте лицензионное соглашение. Если вы согласны с его положениями, выберите соответствующую опцию и продолжите установку, нажав кнопку Далее.
  6. Откроется диалог для ввода информации о пользователе. Введите данные и продолжите установку.
  7. В открывшемся диалоге выберите режим установки:
    • Полная установка – будет произведена полная установка программы, вы сможете работать в режиме администратора, в режиме оператора, а также пользоваться приложениями FormDesigner 8.0 и FlexiLayout Studio 8.0.
    • Только станция оператора – будет установлена только станция оператора. (Станция администратора, FormDesigner 8.0 и FlexiLayout Studio 8.0 установлены не будут).
  8. Далее, вы можете выбрать папку установки. По умолчанию программа будет установлена в папку <имя диска>:\Program Files\ABBYY FlexiCapture 8.0 Professional. При недостатке места на выбранном диске появляется окно со списком дисков и количеством доступного и необходимого места для установки. Можно выбрать другую папку для установки. Продолжите установку.
  9. Файлы будут скопированы на ваш компьютер. После завершения появится диалог об успешном завершении установки.
  10. После завершения установки будет запущено приложение FlexiCapture 8.0 Professional License Manager для активации серийного номера. Введите ваш серийный номер и активируйте программу.


Сетевая установка программы ABBYY FlexiCapture 8.0 Professional

Программа ABBYY FlexiCapture 8.0 Professional обладает удобными возможностями для установки и работы в сети.

Чтобы начать сетевую установку, в меню программы Autorun следует выбрать пункт Сетевая установка и следовать указаниям программы.

Сетевая установка программы ABBYY FlexiCapture 8.0 Professional нужна для удобного развертывания программного комплекса на несколько компьютеров. Сетевая установка производится в два этапа – на один из компьютеров локальной сети (сервер) устанавливается программа управления лицензией License Manager и ключ защиты, а также по желанию копируется дистрибутив программы ABBYY FlexiCapture 8.0 Professional, после чего проводится установка программы ABBYY FlexiCapture 8.0 Professional на компьютеры локальной сети (Рабочие станции).

Подробнее о сетевой установке см. Руководство администратора по установке, которое вы также можете открыть из меню Autorun.


Установка программы ABBYY FlexiCapture 8.0 Professional на локальный компьютер

Изменение режима установки, восстановление и удаление программы ABBYY FlexiCapture 8.0 Professional

Чтобы изменить режим установки (полная установка/станция оператора):

  1. Выберите пункт меню Start > Control Panel > Add or Remove Programs, выберите в списке программу ABBYY FlexiCapture 8.0 Professional и нажмите на кнопку Change.

  2. Выберите пункт Modify и нажмите кнопку Next.

  3. В появившемся диалоге выберите нужный режим установки.

Чтобы восстановить испорченные или удаленные файлы:

  1. Выберите пункт меню Start > Control Panel > Add or Remove Programs, выберите в списке программу ABBYY FlexiCapture 8.0 Professional и нажмите на кнопку Change.

  2. Выберите пункт Repair и нажмите кнопку Next.

Чтобы удалить программу ABBYY FlexiCapture 8.0 Professional:

  1. Выберите пункт меню Start > Control Panel > Add or Remove Programs, выберите в списке программу ABBYY FlexiCapture 8.0 Professional и нажмите на кнопку Remove.

  2. Подтвердите удаление программы.


Запуск программы

Чтобы запустить программу ABBYY FlexiCapture 8.0 Professional

  • в режиме администратора: выберите пункт Станция администратора в меню Пуск/Программы/ABBYY FlexiCapture 8.0.
  • в режиме оператора: выберите пункт Станция оператора в меню Пуск/Программы/ABBYY FlexiCapture 8.0.

Внимание! Перед запуском программы убедитесь, что:

  • Используемый сканер подключен к компьютеру и включен в сеть.
    Если ваш сканер еще не подключен, воспользуйтесь руководством пользователя сканера.
    Для того, чтобы сканер работал корректно, необходимо сначала включить сканер и только после этого – компьютер.
  • На ваш компьютер установлен ключ защиты. Без ключа защиты запуск программы будет невозможен.

Ключи в реестре, задающие параметры запуска программы

В реестре (в подразделе Shell\StartUp) можно задать следующие ключи, позволяющие контролировать параметры запуска программы:

  • AdminMode - задает режим работы (оператора или администратора);
  • Project - задает проект, открываемый автоматически при запуске программы;
  • Batch - задает пакет, открываемый автоматически при запуске программы, (работает, только если задан проект);
  • ProhibitChangePath - позволяет запретить в режиме оператора менять пакет и проект, открываемые автоматически (для этого нужно установить значение ключа True).

В реестре ключи по умолчанию не создаются. Администратор при необходимости может добавить эти ключи в реестр пользователя.

Ключи реестра можно перекрыть соответствующими параметрами запуска FlexiCapture через командную строку.

Параметры запуска программы через командную строку

Для запуска программы через командную строку используются следующие параметры:

FlexiCapture.exe [/Station:(Admin,Operator)] [/Project:"путь к проекту"] [/Batch:"имя пакета"] [/ProhibitChangePath].

  • [/Station:(Admin,Operator)] - задает режим работы (оператора или администратора). Если режим не указан, при запуске программы появляется диалог для выбора нужного режима;
  • [/Project:"путь к проекту"] - задает проект, открываемый автоматически;
  • [/Batch:"имя пакета"] - задает пакет, открываемый автоматически;
  • [/ProhibitChangePath] - позволяет запретить изменять в режиме оператора проект и пакет, открываемые автоматически.


Использование пакетов, созданных в предыдущих версиях ABBYY FormReader

Использование шаблонов, созданных в предыдущих версиях ABBYY FormReader

Шаблоны, созданные в ABBYY FormReader 6.5 и 6.0, можно импортировать в ABBYY FlexiCapture 8.0 Professional.

При этом импортируется разметка страниц (кроме служебных полей) и типы данных. Типы данных копируются в папку Пользовательские в типах данных шаблона документа. См. Типы данных текстового поля ввода.

Внимание! Правила проверки и настройки экспорта не импортируются. Также не импортируются изображения, содержащиеся в пакете.

Чтобы импортировать шаблон, созданный в ABBYY FormReader 6.5 или 6.0:

  1. Запустите программу ABBYY FlexiCapture 8.0 Professional в режиме администратора.
  2. Создайте новый проект или откройте один из существующих проектов, в который вы хотите импортировать шаблон из предыдущей версии.
  3. Выберите пункт главного меню Проект > Шаблоны документов…
  4. В диалоге со списком шаблонов документов нажмите кнопку Импорт…
  5. В списке типов файлов (Files of type) выберите Пакеты FormReader 6.5 (*.frm) и укажите файл пакета.

В списке шаблонов появится новый шаблон, созданный на основе импортированного пакета. Если в пакете было несколько шаблонов, то все они появятся в списке. Если в ABBYY FormReader 6.5 была задана структура для многостраничных документов, то описанные в этой структуре шаблоны будут объединены в один многостраничный шаблон.

Советы.

  1. Подробно об использовании правил в старой и новой версии см. Различия в правилах FormReader 6.5 и FlexiCapture 8.0 Professional.
  2. Рекомендации по переходу от использования правила проверки с условием, Automation-правил и Automation-экспорта в FormReader 6.5 к использованию скриптов во FlexiCapture 8.0 Professional вы найдете в статье Переход к скриптам в программе FlexiCapture 8.0 Professional после использования FormReader 6.5.


Интерфейс программы ABBYY FlexiCapture 8.0 Professional

Этот раздел содержит обзор основных элементов интерфейса программы ABBYY FlexiCapture 8.0 Professional: основных окон, меню и панелей инструментов.

Главное окно программы
Меню главного окна
Панели инструментов главного окна
Редактор шаблонов документов
Меню редактора шаблонов документов
Панели инструментов редактора шаблонов документов
Окно группового верификатора
Меню
Панель инструментов
Окно контекстного верификатора
Меню
Панель инструментов


Главное окно программы ABBYY FlexiCapture 8.0 Professional

В главном окне программы отображается список пакетов документов, входящих в состав проекта, с которым ведется работа.

Показать главное окно со списком пакетов

Чтобы увидеть содержимое пакета, откройте его двойным щелчком мыши. Вы увидите список документов, входящих в пакет.

Вернуться к списку пакетов можно, выбрав пункт меню Проект>Рабочие пакеты (или Тестовые пакеты при работе с тестовыми пакетами).

Показать главное окно с открытым пакетом документов

В верхней части окна располагается меню, под ним – инструментальные панели.

Остальное пространство Главного окна занимает рабочее окно Пакет со списком входящих в него документов.

В нижней части окна расположена информационная панель (еще ее называют строкой состояний), где вы можете получить сведения о состоянии программы и производимых ею операциях, а также краткую справку о выбираемых вами пунктах меню и кнопках.

Для проверки распознанных данных нужно открыть Окно документа. Для этого щелкните дважды по названию документа или одной из его страниц. Окно документа состоит из трех частей:

  • изображение страницы документа;
  • распознанные данные;
  • ошибки правил (эта часть отображается только при наличии ошибок правил).

Подробнее см. Верификация в окне документа

Показать окно документа

Меню главного окна
Панели инструментов главного окна


Меню главного окна программы ABBYY FlexiCapture 8.0 Professional

Файл
Пункт меню | Описание
Новый проект… | Позволяет создать новый проект
Открыть проект… | Позволяет открыть существующий проект
Закрыть проект | Закрывает текущий проект
Сохранить | Сохраняет изменения
Загрузить изображения… | Позволяет загрузить изображения из файлов
Сканировать изображения… | Позволяет добавить изображения путем сканирования
Импортировать изображения… | Позволяет импортировать изображения с использованием одного из настроенных профилей импорта
Экспортировать | Позволяет экспортировать данные, используя настройки экспорта шаблонов документов
Экспортировать в |
Файл… | Позволяет экспортировать данные в файл
Базу данных… | Позволяет экспортировать данные в базу данных
Недавно открытые проекты | Позволяет открыть один из ранее открытых проектов
Выход | Закрывает ABBYY FlexiCaptuer 8.0
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Выделить все | Выделяет все
Найти… | Позволяет найти заданный текст
Найти следующий | Позволяет найти следующий ранее заданный текст
Перейти |
К следующему документу | Позволяет перейти к следующему документу в пакете
К предыдущему документу | Позволяет перейти к предыдущему документу в пакете
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Вид
Пункт меню | Описание
Документы |
Детали | Представляет документы и их страницы в виде детализованного списка
Эскизы страниц | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Редактор документа |
Изображение | Показывает изображение страницы в окне документа
Данные | Показывает распознанные данные в окне документа
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Отображать панель инструментов в режиме данных | Позволяет показать/спрятать панель инструментов в окне документа. Эта панель инструментов позволяет исправить некоторые ошибки наложения, например, дорисовать не найденное поле, добавить или удалить разделитель таблицы. Такая возможность используется, в основном, при работе с гибкими описаниями.
Панели инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Строка состояния | Позволяет отобразить/спрятать строку состояния
Показывать изображение в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц документа в черно-белом режиме
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения страниц документов
Размер текста данных | Позволяет выбрать размер шрифта для отображения распознанных данных
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Свойства… | Открывает диалог свойств документа или страницы
Импорт и распознавание
Пункт меню | Описание
Импортировать изображения… | Импортирует изображения с использованием одного из настроенных профилей импорта
Проанализировать | Анализирует страницы документов, подбирая для них подходящий шаблон
Наложить шаблон… | Производит наложение выбранного пользователем шаблона на выделенный документ или страницу
Распознать | Запускает процесс распознавания
Верификация
Пункт меню | Описание
Начать верификацию… | Запускает процесс верификации
Следующая ошибка сборки | Осуществляет переход к следующей ошибке сборки
Предыдущая ошибка сборки | Осуществляет переход к предыдущей ошибке сборки
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Проект
Пункт меню | Описание
Рабочие пакеты | Закрывает текущий пакет и переходит к списку рабочих пакетов документов
Тестовые пакеты | Закрывает текущий пакет и переходит к списку тестовых пакетов документов (Этот пункт меню доступен только в режиме работы администратора)
Шаблоны документов… | Открывает диалог со списком шаблонов документов, из которого осуществляются действия по работе с шаблонами: создание нового шаблона, редактирование, импорт, удаление (Этот пункт меню доступен только в режиме работы администратора)
Профили импорта изображений… | Открывает диалог со списком профилей импорта изображений, из которого осуществляются действия по работе с профилями импорта: создание нового профиля, копирование существующего, редактирование, удаление (Этот пункт меню доступен только в режиме работы администратора)
Режим администратора… | Позволяет перейти в режим работы администратора (Этот пункт меню доступен только в режиме работы оператора)
Защитить паролем… | Позволяет защитить паролем текущий проект (Этот пункт меню доступен только в режиме работы администратора)
Снять пароль… | Позволяет снять защиту паролем с проекта (Этот пункт меню доступен только в режиме работы администратора)
Экспортировать проект… | Экспортирует проект в указанную папку. При экспорте проекта изображения берутся из текущего пакета.
Обновление проекта… | Устанавливает обновление проекта. Сообщения и ошибки, возникающие при импорте, можно сохранять в файл (правая кнопка мыши - Экспортировать в файл).
Свойства проекта… | Открывает диалог свойств проекта
Сервис
Пункт меню | Описание
Повторный анализ | Производит повторный анализ документов
Повторное распознавание | Производит повторное распознавание документов
Обновить сборку | Обновляет сборку страниц в документы
Перепроверить правила | Производит повторную проверку правил
Опции… | Открывает диалог Опции для задания различных настроек, таких как обработка фоновых задач, вид окон и др.
Справка
Пункт меню | Описание
Вызов справки… | Открывает справку программы ABBYY FlexiCapture 8.0 Professional
Техническая поддержка… | Открывает страницу Техническая поддержка в справке программы
Как купить продукцию ABBYY… | Открывает страницу Как купить программу ABBYY FlexiCapture 8.0 Professional в справке программы
Web-сайт ABBYY… | Открывает Web-страницу компании ABBYY
Отправить отзыв | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.
О программе ABBYY FlexiCapture 8.0… | Открывает диалог О программе ABBYY FlexiCapture 8.0 Professional, содержащий краткую информацию о программе.


Панели инструментов главного окна программы ABBYY FlexiCapture 8.0 Professional

Стандартная панель инструментов

Название | Кнопка | Описание
Открыть проект |  | Позволяет открыть другой проект
Сохранить изменения |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Эскизы страниц |  | Позволяет просматривать изображения страниц документов в виде уменьшенных копий
Детали |  | Представляет документы и их страницы в виде детализованного списка
Предыдущий объект верификации |  | Осуществляет переход к предыдущему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Следующий объект верификации |  | Осуществляет переход к следующему объекту верификации. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.
Предыдущий документ |  | Осуществляет переход к предыдущему документу .
Следующий документ |  | Осуществляет переход к следующему документу.
Панель обработки документов

Данная панель инструментов предназначена для прохождения всего процесса обработки документов. Кнопки этой панели инструментов многофункциональны и имеют несколько режимов работы.

Надпись на первой кнопке - кнопке для добавления изображений - меняется в зависимости от выбранного режима и при нажатии на нее производится действие, соответствующее надписи.

Для выбора режима нужно нажать на треугольник справа от кнопки и выбрать соответствующий пункт меню.

Кнопка | Режим | Описание
 | Загрузить изображения… | Позволяет загрузить изображения из файлов и добавить их в текущий пакет
 | Сканировать изображения… | Позволяет добавить изображения в пакет путем сканирования
 | Импортировать изображения… | Позволяет импортировать изображения, используя один из настроенных профилей импорта изображений
 | Список существующих профилей импорта | Для того чтобы начать импорт изображений, достаточно выбрать из списка один из настроенных профилей импорта.
 | Распознать | Запускает процесс распознавания
 | Проанализировать | Анализирует страницы документов, подбирая для них подходящий шаблон
 | Наложить шаблон… | Производит наложение выбранного пользователем шаблона на выделенный документ или страницу
 | Начать верификацию… | Запускает процесс верификации
 | Перепроверить правила | Запускает процесс перепроверки правил
 | Экспортировать | Экспортирует данные согласно профилю экспорта, настроенному в шаблонах документов
 | Экспортировать в файлы… | Позволяет произвести экспорт данных в файл
 | Экспортировать в базу данных… | Позволяет произвести экспорт данных в базу данных


Окно редактора шаблонов документов

Основные действия по созданию и редактированию шаблона производятся в окне редактора шаблона документов.

Чтобы открыть редактор шаблона документа из главного окна программы, нужно:

  1. Выбрать пункт меню Проект>Шаблоны документов…;
  2. В диалоге Шаблоны документов выделить название шаблона и нажать кнопку Правка….

Окно редактора шаблона документов также открывается после завершения работы мастера создания шаблона документов.

Показать окно редактора шаблона документов

Окно редактора шаблона документов состоит из трех частей:

  1. Слева сверху расположено изображение страницы с разметкой полей и статических элементов.

    Для работы с полями и статическими элементами предусмотрено два режима:

    • режим разметки полей – включается по кнопке [image];
    • режим статических элементов – включается по кнопке [image].
  2. Слева внизу находится редактор для настройки отображения распознанных данных.
  3. В правой части отображается структура документа со списком всех полей шаблона (закладка Поля). Также можно переключиться в режим просмотра эскизов страниц (закладка Страницы).

Меню редактора шаблонов
Панели инструментов редактора шаблонов


Меню редактора шаблонов

Шаблон
Пункт меню | Описание
Добавить страницу… | Позволяет добавить в шаблон изображение новой страницы
Добавить раздел документа… | Позволяет добавить в шаблон новый раздел
Скриптовые модули |
Правила… | Открывает Редактор кода скрипта - Модуль для правил. Подробнее о скриптовых модулях см. Использование скриптов во FlexiCapture 8.0.
Экспорт… | Открывает Редактор кода скрипта - Модуль для экспорта. Подробнее о скриптовых модулях см. Использование скриптов во FlexiCapture 8.0.
Настройки экспорта… | Открывает диалог Настройки экспорта для настройки параметров экспорта данных
Свойства шаблона документа… | Открывает диалог для просмотра и редактирования свойств шаблона документа
Сохранить | Сохраняет изменения
Закрыть | Закрывает редактор шаблонов документов
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Удалить область | Удаляет области на изображении выделенных объектов
Выделить все | Выделяет все
Выделить по типу… | Позволяет выделить объекты определенного типа
Создать поле |
Текст | Добавляет текстовое поле ввода в структуру документа (без разметки на изображении)
Метка | Добавляет поле метки в структуру документа (без разметки на изображении)
Группа меток | Добавляет поле группы меток в структуру документа (без разметки на изображении)
Штрих-код | Добавляет поле штрих-кода в структуру документа (без разметки на изображении)
Картинка | Добавляет поле картинки в структуру документа (без разметки на изображении)
Таблица | Добавляет поле таблицы в структуру документа (без разметки на изображении)
Группа | Добавляет группу полей в структуру документа (без разметки на изображении)
Сгруппировать | Позволяет сгруппировать выделенные объекты
Разгруппировать | Позволяет разгруппировать выделенные объекты
Копировать текст с изображения… | Позволяет получить текст из любой области изображения и записать его в буфер обмена. После выбора команды меню нужно выделить мышью область, откуда будет взят текст.
Изображение |
Очистить | Очищает изображение
Инвертировать | Инвертирует изображение
Повернуть на 90° по часовой стрелке | Разворачивает изображение на 90° по часовой стрелке
Повернуть на 90° против часовой стрелки | Разворачивает изображение на 90° против часовой стрелки
Повернуть на 180° | Разворачивает изображение на 180°
Сохранить как… | Позволяет сохранить изображение страницы шаблона в указанном файле
Заменить… | Позволяет произвести замену изображения страницы шаблона
Вид
Пункт меню | Описание
Разметка изображения |
Статические элементы | Переключает в режим статических элементов
Области полей | Переключает в режим разметки полей
Структура документа |
Показать структуру документа | Отображает/прячет окно структуры документа
Поля | Переключает окно структуры документа в режим отображения полей
Страницы | Переключает окно структуры документа в режим отображения страниц
Форма данных | Отображает/прячет окно редактора данных
Панель инструментов окна разметки |
Горизонтальная | Размещает горизонтально панель инструментов окна разметки изображения
Вертикальная | Размещает вертикально панель инструментов окна разметки изображения
Показывать изображение в черно-белом режиме | Позволяет показывать цветные и серые изображения страниц в черно-белом режиме
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения
Свойства… | Открывает диалог для просмотра и редактирования свойств выделенного объекта
Документ
Пункт меню | Описание
Начать тестирование | Позволяет начать тестирование шаблона на изображении документа
Закончить тестирование | Закрывает режим тестирования
Режим изображения | Показывает изображение страницы в окне документа
Режим данных | Показывает распознанные данные в окне документа
Вид |
Окно изображения | Позволяет выбрать расположение изображения в окне документа
Сверху | Располагает окно изображения в верхней части окна
Снизу | Располагает окно изображения в нижней части окна
Слева | Располагает окно изображения в левой части окна
Справа | Располагает окно изображения в правой части окна
Окно ошибок | Позволяет выбрать расположение окна ошибок в окне документа
Сверху | Располагает окно ошибок в верхней части окна
Снизу | Располагает окно ошибок в нижней части окна
Слева | Располагает окно ошибок в левой части окна
Справа | Располагает окно ошибок в правой части окна
Отображать панель инструментов в режиме данных | Позволяет отобразить/спрятать панель инструментов в режиме данных. В режиме изображения панель инструментов отображается всегда
Верификация |
Следующий объект верификации | Осуществляет переход к следующему объекту верификации
Предыдущий объект верификации | Осуществляет предыдущему к следующему объекту верификации
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующая ошибка правил | Осуществляет переход к следующей ошибке правил
Предыдущая ошибка правил | Осуществляет переход к предыдущей ошибке правил
Сервис
Пункт меню | Описание
Найти объекты на изображении… | Позволяет автоматически найти и выделить на изображении поля или статические элементы определенного типа (в зависимости от режима)
Проверить шаблон документа | Производит проверку шаблона документов
Наложить раздел | Производит проверку наложения раздела шаблона
Тестовые пакеты… | Позволяет использовать тестовые пакеты для тестирования шаблона
Справка
Пункт меню | Описание
Вызов справки… | Открывает справку программы ABBYY FlexiCapture 8.0 Professional
Отправить отзыв | Позволяет отправить отзыв в компанию ABBYY: мнение пользователя о программе, замечания и пожелания.


Панели инструментов редактора шаблонов

Стандартная панель инструментов

Название | Кнопка | Описание
Сохранить |  | Сохраняет изменения
Вырезать |  | При работе с данными в окне документа позволяет вырезать выделенный объект
Копировать |  | Копирует выделенный объект
Вставить |  | Вставляет ранее скопированный объект из буфера обмена
Удалить |  | Удаляет выделенный объект
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие
Проверить шаблон документа |  | Позволяет произвести проверку шаблона. Результаты проверки отображаются в нижней части окна редактора шаблонов
Панель инструментов окна разметки изображения

Панель инструментов окна разметки изображения используется для создания статических элементов и полей шаблона. Набор кнопок на панели инструментов меняется в зависимости от выбранного режима.

В режиме статических элементов:

В режиме разметки полей:

Данная панель инструментов может располагаться горизонтально или вертикально. Изменить ориентацию панели инструментов можно, воспользовавшись пунктом меню Вид>Панель инструментов окна разметки.
Название | Кнопка | Описание
Общие
Режим статических элементов |  | Переключает в режим статических элементов
Режим разметки полей |  | Переключает в режим разметки полей
Масштаб |  | Позволяет увеличить масштаб изображения
Автоматический поиск объектов |  | Позволяет автоматически найти и выделить объекты на изображении. Выберите этот инструмент, а затем щелкните левой кнопкой мыши в области объекта.
Выделить область |  | Позволяет выделять области объектов, уже размеченных на изображении. Для выделения области выберите этот инструмент и щелкните левой кнопкой мыши в области объекта.
В режиме статических элементов
Создать репер |  | Позволяет создать репер. Выберите этот инструмент, а затем с помощью мыши обведите репер прямоугольником.
Создать разделитель |  | Позволяет создать разделитель. Выберите этот инструмент, а затем с помощью мыши обведите разделитель прямоугольником.
Создать реперный текст |  | Позволяет создать реперный текст. Выберите этот инструмент, а затем с помощью мыши обведите текст прямоугольником.
Создать реперный штрих-код |  | Позволяет создать реперный штрих-код. Выберите этот инструмент, а затем с помощью мыши обведите штрих-код прямоугольником.
В режиме разметки полей
Создать текстовое поле |  | Позволяет создать текстовое поле ввода. Выберите этот инструмент, а затем с помощью мыши обведите область для ввода текста прямоугольником.
Создать метку |  | Позволяет создать поле метки. Выберите этот инструмент, а затем с помощью мыши обведите область метки прямоугольником.
Создать группу меток |  | Позволяет создать группу меток. Выберите этот инструмент, а затем с помощью мыши обведите прямоугольником метки, которые должны входить в группу.
Создать штрих-код |  | Позволяет создать поле Штрих-код. Выберите этот инструмент, а затем с помощью мыши обведите штрих-код прямоугольником.
Создать картинку |  | Позволяет создать поле Картинка. Выберите этот инструмент, а затем с помощью мыши обведите картинку прямоугольником.
Создать таблицу |  | Позволяет создать поле Таблица. Выберите этот инструмент, а затем с помощью мыши обведите таблицу прямоугольником. На панели инструментов появятся дополнительные кнопки для разметки таблиц.
Создать группу |  | Позволяет создать группу полей. Выберите этот инструмент, а затем с помощью мыши обведите прямоугольником поля, которые будут входить в группу.
Создать область для поля без разметки |  | Позволяет создать область для поля, которое есть в структуре документа, но не имеет области на изображении. Выберите этот инструмент, а затем с помощью мыши обведите область поля прямоугольником. Выберите название из выпадающего списка. (Список состоит из названий полей, не имеющих области на изображении).
Создать нераспознаваемую область |  | Позволяет выделить область, которая будет исключена из распознавания.
Кнопки для разметки таблиц Отображаются, если в данном разделе шаблона создана хотя бы одна таблица
Создать столбец |  | Позволяет создать столбец таблицы и определить его тип. Чтобы создать столбец, выберите этот инструмент и щелкните в области столбца. Выберите тип столбца из выпадающего списка.
Нарисовать разделитель |  | Позволяет добавлять в таблицу горизонтальные и вертикальные разделители
Удалить разделитель |  | Позволяет удалить разделитель


Окно группового верификатора

Окно группового верификатора появляется при запуске процесса верификации (меню главного окна Verification>Начать верификацию…) при условии, что в шаблоне есть поля, в свойствах которых отмечена опция Включить в групповую верификацию. Подробнее cм. Свойства верификации поля.

Это окно предназначено для визуальной проверки символов, распознанных с одинаковым значением. Одинаково распознанные символы выводятся на экран, чтобы можно было легко заметить и исправить выбивающиеся из общей массы символы. См. Групповая верификация.

Меню окна группового верификатора
Панель инструментов окна группового верификатора


Меню окна группового верификатора

Верификация
Пункт меню | Описание
Подтвердить все | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Отложить все | Откладывает верификацию всех символов, помечая их знаком вопроса как сомнительные
Изменить статус | Откладывает верификацию выделенного символа, помечая его знаком вопроса как сомнительный символ
Следующая страница | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Предыдущая страница | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Закрыть | Закрывает окно верификатора
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Выделить все | Выделяет все символы
Вид
Пункт меню | Описание
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификатора
Снизу | Размещает изображение поля в нижней части окна верификатора
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Показать изображение символа | Позволяет показать изображение символа
Панель инструментов | Позволяет показать/спрятать панель инструментов
Строка состояния | Позволяет показать/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Настройки… | Позволяет настроить вид окрестности символа
Правка
Пункт меню | Описание
Вызов справки… | Открывает справку программы ABBYY FlexiCapture 8.0 Professional
О программе ABBYY FlexiCapture 8.0… | Открывает диалог О программе ABBYY FlexiCapture 8.0 Professional, содержащий краткую информацию о программе.


Панель инструментов окна группового верификатора

Название | Кнопка | Описание
Предыдущая страница |  | Позволяет перейти к предыдущей странице, если все символы не умещаются на одном экране
Следующая страница |  | Позволяет перейти к следующей странице, если все символы не умещаются на одном экране
Подтвердить все |  | Позволяет подтвердить корректное распознавание всех символов и осуществляет переход к следующему экрану
Изменить статус символа |  | Изменяет статус символа на отклоненный и обратно
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие


Окно контекстного верификатора

Окно контекстного верификатора появляется после завершения процесса групповой верификации при условии, что в шаблоне есть поля, в свойствах которых отмечена опция Включить в контекстную верификацию. Подробнее cм. Свойства верификации поля.

Это окно предназначено для визуальной проверки неуверенно распознанных символов в контексте всего поля. См. Контекстная верификация.

Меню окна контекстного верификатора
Панель инструментов окна контекстного верификатора


Меню окна контекстного верификатора

Верификация
Пункт меню | Описание
Подтвердить поле | Подтверждает поле
Отложить поле | Откладывает проверку поля
Следующий неуверенный символ | Осуществляет переход к следующему неуверенно распознанному символу
Предыдущий неуверенный символ | Осуществляет переход к предыдущему неуверенно распознанному символу
Следующее поле | Позволяет перейти к следующему полю
Предыдущее поле | Позволяет перейти к предыдущему полю
Закрыть | Закрывает окно верификатора
Правка
Пункт меню | Описание
Отменить | Отменяет предыдущее действие
Повторить | Восстанавливает ранее отмененное действие
Вырезать | Вырезает выделенные объекты
Копировать | Копирует выделенные объекты в буфер обмена
Вставить | Вставляет содержимое из буфера обмена
Удалить | Удаляет выделенные объекты
Выделить все | Выделяет все
Вставить перенос строки | Вставляет перенос строки
Объединить символы | Позволяет объединить выделенные символы, если в процессе распознавания какой-либо символ были некорректно разбит на несколько символов
Вид
Пункт меню | Описание
Данные поля |
Показывать распознанный текст | Показывает/прячет распознанный текст
Нарезка изображений символов | Переходит в режим показа поля с нарезкой символов
Показывать специальные символы | Показывает/прячет специальные символы
Изображение поля |
Показывать изображение поля | Позволяет показать/спрятать изображения поля, содержащего текущий символ
Сверху | Размещает изображение поля в верхней части окна верификатора
Снизу | Размещает изображение поля в нижней части окна верификатора
Масштаб изображения | Позволяет выбрать подходящий масштаб изображения поля
Окружающие поля | Позволяет показать/спрятать окружающие поля
Показать изображение символа | Позволяет отобразить/спрятать изображение символа
Панель инструментов | Позволяет отобразить/спрятать панели инструментов главного окна
Строка состояния | Позволяет отобразить/спрятать строку состояния
Размер символа | Позволяет выбрать подходящий размер символов
Полноэкранный режим | Осуществляет переход в полноэкранный режим
Настройки… | Позволяет настроить вид окна верификатора: вид окрестности символа, шрифт и цвет текста
Справка
Пункт меню | Описание
Вызов справки… | Открывает справку программы ABBYY FlexiCapture 8.0 Professional
О программе ABBYY FlexiCapture 8.0… | Открывает диалог О программе ABBYY FlexiCapture 8.0 Professional, содержащий краткую информацию о программе.


Панель инструментов окна контекстного верификатора

Название | Кнопка | Описание
Предыдущее поле |  | Позволяет перейти к предыдущему полю
Следующее поле |  | Позволяет перейти к следующему полю
Подтвердить/Пропустить поле |  | Позволяет подтвердить корректное распознавание всех символов поля и осуществляет переход к следующему полю. Если значение поля не удовлетворяет формату поля, то название кнопки меняется на Пропустить поле. Если значение поля нельзя исправить, то его проверку можно только отложить, или пропустить.
Отложить поле |  | Позволяет отложить проверку поля, если его невозможно исправить
Предыдущий неуверенно распознанный символ |  | Позволяет перейти к предыдущему неуверенно распознанному символу
Следующий неуверенно распознанный символ |  | Позволяет перейти к следующему неуверенно распознанному символу
Отменить |  | Отменяет предыдущее действие
Повторить |  | Повторяет ранее отмененное действие


Настройка программы

Перед началом массового ввода документов, программа должна быть настроена для обработки документов нужного типа. Все необходимые настройки выполняются администратором.

Для того, чтобы настроить обработку документов, нужно создать проект, который включает в себя:

  • профили импорта изображений
  • один или несколько шаблонов документов
  • пакеты документов для обработки.

В проект можно включать различные шаблоны, тогда разные документы будут обрабатываться в рамках одного проекта в зависимости от наложенного шаблона. Тем не менее, если потоки документов не пересекаются, то для них можно создать отдельные проекты.

Режимы работы администратора и оператора
Создание проекта
Шаблоны документов
Профили импорта изображений
Настройки экспорта по умолчанию
Пакеты документов
Индексные поля


Режимы работы администратора и оператора

Для организации потокового ввода данных с помощью ABBYY FlexiCapture 8.0 Professional нужно настроить систему для обработки определенного вида документов. Все необходимые настройки выполняет администратор, а ввод документов осуществляется операторами. Количество рабочих мест определяется в зависимости от числа и объема обрабатываемых документов.

Администратор выполняет настройку системы и контролирует ее работу. Обязанностями администратора являются:

  • разработка бланков новых форм (это может входить в обязанности дизайнера);
  • настройка импорта изображений, параметров сканирования;
  • подготовка шаблонов документов.
  • мониторинг процесса ввода данных в настроенной системе, консультирование операторов.

Операторы выполняют ввод документов. Они работают с уже настроенной администратором системой, готовой к обработке заполненных документов определенного вида. В обязанности операторов входит:

  • сканирование или импорт документов;
  • верификация данных;
  • экспорт данных.

Распознавание документов производится автоматически.

В программе предусмотрены два режима работы: режим администратора и режим оператора.

Администратор имеет доступ ко всем функциям программы, режим администратора может быть защищен паролем. Оператор не имеет доступа к созданию и редактированию шаблонов, созданию профилей импорта.

Оператору можно разрешить работу только с одним проектом или только с одним пакетом.

При установке программы можно установить только станцию оператора или выбрать полную установку, в этом случае можно будет работать как в режиме администратора, так и в режиме оператора. Вы можете запустить программу в одном из этих режимов, выбрав соответствующий пункт меню Пуск > Программы > ABBYY FlexiCapture 8.0 > Станция администратора или Пуск > Программы > ABBYY FlexiCapture 8.0 > Станция оператора. (Подробнее см. Запуск программы).

В режиме администратора в меню Проект присутствуют пункты Тестовые пакеты, Шаблоны документов…, Профили импорта изображений…, Защитить паролем…, Снять пароль… недоступные в режиме работы оператора. Таким образом, работать с тестовыми пакетами, шаблонами документов, профилями импорта можно только в режиме администратора. Администратор также может защитить проект с помощью пароля и снять пароль. При попытке открыть защищенный проект в режиме администратора запрашивается пароль.

В режиме оператора в меню Проект присутствует пункт Режим администратора…, при выборе которого откроется текущий проект и пакет. Если в режиме оператора запрещено менять текущий проект или пакет, соответствующие пункты меню и панели инструментов отсутствуют.


Создание проекта

Для начала работы необходимо создать проект. Проект включает в себя:

  • профили импорта изображений
  • один или несколько шаблонов документов
  • пакеты документов для обработки.

При запуске программы откроется диалог Открытие проекта, который позволяет вам выбрать один из существующих проектов или создать новый.

Для создания нового проекта:

  1. нажмите на кнопку Новый…;
  2. задайте папку для хранения проекта и имя проекта;
  3. нажмите Создать.

Если программа ABBYY FlexiCapture 8.0 Professional уже запущена и открыт один из проектов, то для создания нового проекта выберите пункт меню Файл>Новый проект…

Свойства проекта
Шаблоны документов
Профили импорта изображений
Пакеты документов


Свойства проекта

Свойства проекта можно просмотреть и отредактировать в диалоге, который открывается при выборе пункта меню главного окна Проект>Свойства проекта….

На закладке Общие отображаются название проекта, путь к файлам проекта и описание.

На закладке Обработка изображений можно просмотреть и отредактировать опции предварительной обработки изображений. Подробнее см. Параметры обработки изображений.

На закладке Распознавание можно отметить опцию Удалять пустые страницы во время распознавания - тогда пустые страницы будут удаляться на этапе распознавания.

На закладке Экспорт можно просмотреть и изменить настройки экспорта по умолчанию, а также настроить обработчик экспорта, включаемый опцией Запуск скрипта после экспорта. Подробнее об обработчике экспорта см. в разделах Использование скриптов для описания экспорта и Примеры скриптов для описания экспорта


Шаблоны документов

Создание шаблона – основной и самый ответственный этап настройки проекта, от которого зависит качество данных, получаемых в результате обработки документов.

Работа с шаблонами доступна только в режиме администратора.

Шаблон описывает расположение элементов документа, указывает, откуда будут извлечены данные. При создании шаблона определяются свойства полей, их область значений. Задаются также настройки экспорта данных.

Для начала создания шаблона документов запустите Мастер создания шаблона:

  1. В главном меню ABBYY FlexiCapture 8.0 Professional выберите пункт Проект>Шаблоны документов…
  2. В открывшемся диалоге Шаблоны документов нажмите кнопку Новый…
  3. Следуйте инструкциям Мастера создания шаблона документов.

Мастер создания шаблона документов
Автоматическое выделение полей и статических элементов
Статические элементы
Создание полей шаблона документов
Свойства полей
Проверка с помощью правил
Настройка экспорта данных
Настройка отображения данных в окне документа
Свойства шаблона документов
Импорт шаблона для форм, созданных в программе ABBYY FormDesigner
Создание шаблонов для многостраничных документов
Создание шаблона для обработки гибких документов
Создание шаблонов для документов с приложениями
Обработка неструктурированных документов
Редактирование и публикация шаблона
Тестирование шаблона


Мастер создания шаблона документов

Для создания нового шаблона выберите пункт основного меню Проект>Шаблоны документов… и в диалоге Шаблоны документов нажмите кнопку Новый… Откроется Мастер создания нового шаблона.

  1. В диалоге Создание нового шаблона документа задайте основные свойства шаблона: название и комментарий, используемый язык (Язык (регион)) и стиль написания (Стиль написания). По умолчанию, выпадающий список содержит только языки со словарной поддержкой. Чтобы выбрать язык без словарной поддержки, отметьте опцию Показать все. Очень важно правильно задать язык: от этого зависит правильность распознавания документов. Стиль написания тоже может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания.

    Показать примеры разных стилей написания цифр
    - русская двойка
    - американская двойка
    - "обычная" пятерка – может встретиться в любом стиле
    - японская пятерка
    - русская единица
    - немецкая единица
    - "обычная девятка" – может встретиться в любом стиле
    - чешская девятка с кольцом справа
    - американская девятка без "крючка" внизу

    Задайте тип текста:

    • ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;
    • OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Позже вы сможете изменить тип текста для отдельных полей, а указанный на данном этапе тип будет использоваться по умолчанию.

    Нажмите кнопку Далее (Next) для перехода к следующему шагу.

  2. На втором шаге добавьте изображение страницы вашего документа для создания шаблона. Вы можете отсканировать изображение незаполненной страницы или загрузить его из файла.

    Замечание. Шаблон для жестких форм создается на основе изображения, полученного при сканировании незаполненной формы. Это изображение должно быть хорошего качества, без искажений (не содержать перекосов, сдвигов и т.д.). Для цветных фоновых форм при создании шаблона следует использовать страницы, отсканированные без применения фильтров, так, чтобы фон не исчезал при сканировании. (Позже, когда вы будете сканировать изображения страниц для распознавания данных, вы выберете режим сканирования, при котором фон пропадает).

    Если ваш документ состоит из нескольких страниц, то загрузите первую страницу, а для добавления остальных руководствуйтесь рекомендациями раздела Создание шаблона для многостраничного документа.

    Если вам нужно использовать гибкое описание, созданное в программе ABBYY FlexiLayout Studio, то отметьте опцию Загрузить гибкое описание и введите путь к файлу, содержащему гибкое описание. Подробнее см. Создание шаблона для обработки гибких документов.

    Нажмите кнопку Далее (Next).

  3. На следующем шаге выберите типы полей, которые должны быть найдены на изображении автоматически. Вы можете отметить метки и текстовые поля ввода, особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

    Замечание. Автоматический поиск реперов производится всегда. Если на форме есть реперы, то они будут найдены и отмечены на изображении.

    Нажмите кнопку Готово (Finish).

После окончания работы Мастера создания шаблона документов откроется окно Редактора шаблона документов, в котором выполняются дальнейшие действия по созданию шаблона. На следующем этапе создания шаблона, нужно разметить поля и статические элементы на изображении страницы и определить их свойства.


Автоматическое выделение полей и статических элементов

Автоматическое выделение при добавлении изображения:

При добавлении изображения страницы, автоматически производится поиск реперов на этом изображении. Стандартные реперы (например, черные квадраты) будут найдены и отмечены. Поиск текстовых полей и меток производится в том случае, если необходимость их поиска указана пользователем, то есть отмечены опции Текст или Метки. Особенно хорошо производится автоматический поиск текстовых полей с разметкой и меток прямоугольной формы. Если же поля ввода на вашей форме не имеют разметки, а метки будут проставляться на белом фоне, то их обычно выделяют вручную.

Автоматическое выделение в окне редактора шаблонов документов:

Для автоматического выделения в окне редактора шаблонов документов, выберите нужный режим работы (поля или статические элементы) и выберите пункт меню Сервис>Найти объекты на изображении…. Отметьте типы полей или статических элементов, которые должны быть найдены автоматически.

Если вы хотите автоматически выделять конкретные объекты на изображении, то выберите нужный режим работы (поля или статические элементы) и нажмите [image] на панели инструментов. Затем щелкните мышью в области элемента - он будет выделен прямоугольником. Тип элемента будет определен автоматически.

Автоматическое выделение области:

Для того, чтобы область поля или статического элемента определенного типа была выделена автоматически, выполните следующие действия:

  1. Выберите нужный режим работы (поля или статические элементы);
  2. Выберите тип поля или статического элемента с помощью нужной кнопки панели инструментов;
  3. Нажмите Shift;
  4. Щелкните левой кнопкой мыши в области поля или статического элемента.


Статические элементы

Статические элементы служат для наложения шаблона и идентификации. Из них не извлекаются никакие данные.

Для работы со статическими элементами в редакторе шаблона документов нужно переключиться в режим статических элементов - по кнопке [image].

Статические элементы могут использоваться для наложения шаблона и идентификации, способ использования определяется при задании свойств элемента. С помощью реперов производится совмещение шаблона с изображением формы. Идентификаторы нужны для определения принадлежности страницы к одной из форм, если в одном потоке обрабатываются разные формы. Подробнее см. Создание машиночитаемых форм.

У статических элементов нет названий, есть только области на изображении.

При наложении шаблона на изображение документа, производится поиск статических элементов и по их расположению выбирается шаблон документа. Распознавание значений статических элементов (текста и штрих-кода) производится только в том случае, если это необходимо для идентификации. См. Задание значений идентификаторов.

В программе предусмотрены статические элементы следующих типов:

Статический элемент | Кнопка на панели инструментов
Репер |
Разделитель |
Реперный текст |
Реперный штрих-код |

Поиск реперов производится автоматически при добавлении изображения.

Как создать статический элемент вручную:

  1. Выберите режим статических элементов;
  2. Выберите инструмент для создания элемента нужного типа;
  3. Установите курсор мыши в угол элемента, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол
    или
    нажмите Shift и щелкните левой кнопкой мыши в области элемента.

Область статического элемента будет обведена прямоугольником, цвет которого зависит от типа статического элемента. Статическому элементу присваиваются свойства по умолчанию.

Как изменить свойства статического элемента:

  1. Выделите область элемента на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства статического элемента в открывшемся диалоге.

Подробнее о статических элементах:

  • Реперы
  • Разделители
  • Реперный текст
  • Реперный штрих-код


Реперы

Реперы - статические элементы, выделяются на изображении автоматически.

Для того, чтобы выделить реперы вручную:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];

  3. Установите курсор мыши в угол репера, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области репера.

Свойства репера

Чтобы изменить свойства репера:

  1. Выделите репер;
  2. Щелкните в области репера правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения шаблона - эта опция должна быть отмечена, чтобы репер использовался для наложения шаблона (рекомендуется);
    • Использовать для идентификации шаблона - отметьте эту опцию для использования репера в качестве идентификатора;
    • Вид репера - для правильного наложения шаблона важно, чтобы была указана форма репера: черный квадрат, крестик или уголок.


Реперный текст

Реперный текст - статический элемент. Это любой статический текст на изображении - заголовки, пояснительные подписи.

Для того, чтобы выделить реперный текст:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол текста, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области текста.

Свойства реперного текста

Чтобы изменить свойства реперного текста:

  1. Выделите текст;
  2. Щелкните в области текста правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения шаблона - эта опция должна быть отмечена, чтобы текст использовался для наложения шаблона;
    • Использовать для идентификации шаблона - отметьте эту опцию для использования текста в качестве идентификатора;
    • Значение - если вы используете реперный текст в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить;
    • Допустимое число ошибок - вы можете задать максимальное количество возможных ошибок в строке реперного текста.

    На закладке Распознавание нужно задать опции распознавания, чтобы статический текст был распознан с максимальной точностью:

    • ICR (рукопечатный) – отметьте эту опцию, если статический текст написан от руки.

    • OCR (печатный) – отметьте эту опцию, если статический текст напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машине и т.д.) См. Поддерживаемые типы текста.

    • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.

    • Тип данных – выберите язык, на котором написан текст. Для выбора воспользуйтесь кнопкой Выбрать…

    • Регистр – выберите регистр букв статического текста, если в тексте встречаются как строчные, так и заглавные буквы, оставьте значение Любой.

    • Ориентация – задайте ориентацию текста.

    • Для однострочного текста отметьте опцию Однострочное.

    • Если текст не содержит пробелов, то есть, состоит из одного слова, отметьте опцию Одно слово.

    • Задайте опции обработки изображения при распознавании:
    • Инвертировать – инвертировать изображение.
    • Удалять текстуру – удалять текстуру.
    • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Разделители

Разделители - статические элементы. Это любые горизонтальные и вертикальные линии на изображении.

Для того, чтобы выделить разделители:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол области разделителя, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области разделителя.

Свойства разделителя

Чтобы изменить свойства разделителя:

  1. Выделите разделитель;
  2. Щелкните в области разделителя правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:
    • Использовать для наложения шаблона – эта опция должна быть отмечена, чтобы разделитель использовался для наложения шаблона;
    • Использовать для идентификации шаблона – отметьте эту опцию для использования разделителя в качестве идентификатора.


Реперный штрих-код

Реперный штрих-код - статический элемент.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это завит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения шаблона или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства статического элемента - реперного штрих-кода, см. также поле штрих-код.

Для того, чтобы выделить реперный штрих-код:

  1. Перейдите в режим работы со статическими элементами;
  2. На панели инструментов выберите [image];
  3. Установите курсор мыши в угол штрих-кода, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол

    или

    нажмите Shift и щелкните левой кнопкой мыши в области штрих-кода.

Свойства реперного штрих-кода

Чтобы изменить свойства реперного штрих-кода:

  1. Выделите штрих-код;
  2. Щелкните в области штрих-кода правой кнопкой мыши и выберите пункт локального меню Свойства…;
  3. Измените свойства в открывшемся диалоге:

    На закладке Общие:

    • Использовать для наложения шаблона - эта опция должна быть отмечена, чтобы штрих-код использовался для наложения шаблона;
    • Использовать для идентификации шаблона - отметьте эту опцию для использования штрих-кода в качестве идентификатора;
    • Значение - если вы используете реперный штрих-код в качестве идентификатора, вы можете задать его значение. Для автоматической подстановки значения нажмите кнопку Подставить
    • Требуется для наложения шаблона - если эта опция отмечена, то шаблон может быть наложен, только если будет наложен штрих-код. Штрих-код следует делать обязательным для наложения шаблона, если в пакете много шаблонов и остро стоит задача выбора, например, из очень похожих шаблонов, отличающихся только значением штрих-кода, или даже значением одного из нескольких штрих-кодов. Тогда обязательное наложение штрих-кода ускорит выбор шаблона. Не следует отмечать эту опцию, если вы хотите, чтобы шаблон мог быть наложен даже при отсутствии штрих-кода или если он плохо пропечатан.

    На закладке Распознавание:

    • Тип кода - задайте тип штрих-кода (обычно определяется автоматически);
    • Ориентация - задайте ориентацию штрих-кода.

    Можно задать опции обработки изображения штрих-кода:

    • Инвертировать - инвертировать изображение;
    • Удалять текстуру - удалять текстуру;
    • Очищать изображение - задайте эту опцию, чтобы производилось очищение изображения от "мусора";
    • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Задание значений идентификаторов

Идентификаторы служат для определения принадлежности страницы к той или иной форме и используется для выбора шаблона при наличии в пакете нескольких шаблонов со сходным набором реперов. В случае одновременной обработки нескольких форм в одном потоке, программа определяет, к какой форме относится данная страница, по расположению идентификаторов.

Если в качестве идентификаторов используются реперный штрих-код или реперный текст, то можно задать значения таких идентификаторов. В этом случае при попытке наложить шаблон, программа будет сравнивать распознанные данные на изображении со значением идентификатора, и наложение шаблона будет возможным только при совпадении значений.

Значения идентификаторов задаются в диалоге свойств статических элементов на закладке Общие. Значение текста и штрих-кода можно ввести автоматически, для этого предусмотрена кнопка Подставить.

Замечание. Если можно однозначно идентифицировать страницу только по расположению элементов, значения задавать не нужно. Не следует без крайней необходимости пользоваться этой возможностью, т.к. задание значения идентификатора запускает модуль распознавания на этапе наложения шаблона, тем самым замедляя наложение шаблонов на изображения.


Создание полей шаблона документов

Поля предназначены для извлечения информации.

Для работы с полями в редакторе шаблона документов нужно переключиться в режим разметки полей - по кнопке [image].

Все области на изображении, откуда предполагается извлечение информации, должны быть отмечены как поля. Данные в этих полях распознаются, их значения могут экспортироваться.

У полей есть названия, список которых отображается в окне структуры документа. Обычно, поля имеют область на изображении, но можно создать поля и без области (например, для хранения промежуточных результатов).

Предусмотрены поля следующих типов:

Поле | Кнопка на панели инструментов
Текстовое поле ввода |
Метка |
Группа меток |
Штрих-код |
Картинка |
Таблица |
Группа полей |

Чтобы создать поле:

  1. Выберите режим разметки полей;
  2. Выберите инструмент для создания поля нужного типа;
  3. Установите курсор мыши в угол поля, нажмите левую кнопку мыши и, не отпуская кнопки, потяните в противоположный по диагонали угол
    или
    нажмите Shift и щелкните левой кнопкой мыши в области поля.

Область поля будет обведена прямоугольником, цвет которого зависит от типа поля.

Созданному полю по умолчанию присваивается название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля. Это название появится в списке полей на закладке Поля в окне структуры документа.

Полю присваиваются свойства по умолчанию.

  • Создание групп меток
  • Создание таблиц
  • Создание групп полей
  • Как изменить название поля
  • Копирование, перемещение, удаление полей
  • Поля без разметки
  • Свойства полей


Создание группы меток

В группу объединяются логически связанные метки и, как правило, соответствующие взаимоисключающим ответам на один вопрос. В этом случае из группы выбирается одна метка, чье значение и будет экспортироваться. Однако, это не обязательное условие, вы можете разрешить отмечать более одной метки из группы (опция в свойствах группы меток).

Первый способ создания группы меток:

Чтобы создать группу меток:

  1. Выбрав инструмент [image], создайте метки, входящие в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все метки, которые будут входить в данную группу.
  3. Метки, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы меток. Свойства меток, входящих в группу, одинаковы и не редактируются по отдельности.

Второй способ:

Не обязательно отмечать каждую метку, входящую в группу.

  1. Не выделяя метки по отдельности, сразу выберите инструмент [image] и обведите прямоугольником метки, которые будут входить в данную группу.
  2. Метки, оказавшиеся внутри прямоугольника, будут автоматически найдены, им присваиваются названия и они объединяются в группу.


Создание групп полей

Создание группы полей

Поля могут быть объединены в группы для наглядности структуры документов, а также для создания повторяющихся групп полей. Например, город, улица и номер дома могут быть объединены в группу "Домашний адрес". Создать поля для "Рабочего адреса" можно простым копированием группы полей "Домашний адрес".

Чтобы создать группу полей:

  1. Создайте поля, которые будут входить в группу.
  2. Выберите инструмент [image] и обведите прямоугольником все поля, которые должны входить в группу.
  3. Поля, оказавшиеся внутри прямоугольника, будут выделены. Их названия в структуре документа будут объединены и помещены под название группы.

Если на форме есть повторяющиеся группы полей, то после создания одной группы вы можете создать несколько экземпляров группы. Все свойства полей, а также правила, заданные внутри группы, будут работать для каждого экземпляра группы. См. Поля с несколькими экземплярами.

Вы также можете копировать группу полей, но в этом случае результатом копирования будет создание еще одной независимой группы.


Создание таблицы

ABBYY FlexiCapture 8.0 Professional позволяет создавать шаблоны для документов, содержащих таблицы. Создание полей типа Таблица существенно облегчает настройку, извлечение данных и экспорт данных из таблиц. Поле Таблица представляет собой набор из столбцов одного типа и повторяющихся строк.

Столбцы таблицы могут относится к одному из типов:

  • текст
  • метки
  • штрих-коды
  • картинки

Чтобы создать таблицу:

  1. Выберите инструмент [image] и обведите прямоугольником область таблицы. Шапка таблицы не должна быть включена в обведенную область. На панели появятся дополнительные инструменты для работы с таблицами:
    Создание столбца таблицы
    Создание разделителей
    Удаление разделителя
  2. Разметьте ячейки таблицы, создав нужное количество разделителей. Разделители можно создавать, выбрав инструмент [image]. Для создания вертикальных разделителей поместите курсор в область таблицы. Перетащите пунктирный разделитель в нужное место таблицы и зафиксируйте его там щелчком мыши. Горизонтальные разделители создаются аналогично при нажатой клавише Alt. Также можно осуществить автоматический поиск разделителей. Для этого выделите созданную таблицу и воспользуйтесь пунктами локального меню: Найти вертикальные разделители и Найти горизонтальные разделители.
  3. Создайте столбцы таблицы. Чтобы создать столбец, выберите инструмент [image] и щелкните в области столбца. Выберите тип столбца из выпадающего списка.


Как изменить название поля

Для того чтобы изменить название поля:

  • Щелкните на название поля в структуре документа, нажмите на правую кнопку мыши, выберите пункт локального меню Переименовать и введите новое название.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Подобрать название. Полю будет присвоено название, совпадающее с пояснительным текстом, расположенным наиболее близко к области поля.

или

  • Щелкните в области поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Распознать название с изображения…. Затем обведите курсором мыши пояснительный текст, который подходит для названия поля. Название поля изменится на выбранный текст.

или

  • Откройте диалог свойств поля и измените название на закладке Общие.


Копирование, перемещение, удаление полей

Поля можно копировать, удалять, перемещать, изменять их размеры. Названия скопированных полей отличаются цифрами. Можно выделить одновременно несколько полей, удерживая нажатой кнопку Ctrl. Тогда выполняемое действие будет применено ко всем выделенным полям.

Для того чтобы удалить поле, выделите его и нажмите клавишу Delete или выберите пункт Удалить локального меню. Для того чтобы удалить только разметку, а поле оставить в структуре документа, нужно нажать клавиши Shift+Delete или выбрать пункт Удалить область локального меню поля. См. Поля без разметки.


Поля без разметки

Поля могут не иметь соответствующей области на изображении. Названия полей без разметки в списке помечены красной звездочкой. Такие поля могут использоваться для хранения промежуточных результатов вычислений, производимых со значениями распознаваемых полей. Например, можно объединить значения нескольких полей с помощью правила объединения значений полей, а результат сохранить в поле без разметки.

Поля без разметки обладают всеми свойствами, присущими тому типу, к которому они относятся. Значения этих полей также можно экспортировать.

Создать поле без разметки можно двумя способами:

  1. В окне редактора шаблона выберите пункт меню Шаблон>Создать поле и создайте поле нужного типа. Название поля появится в списке и будет помечено звездочкой. В этом случае создается поле структуры документа, но не создается его область на изображении.
  2. Второй способ заключается в удалении разметки обычного поля. Выделите нужное поле на изображении или в списке и выберите пункт локального меню Удалить область. Разметка будет удалена, а название поля будет помечено красной звездочкой.

Чтобы создать область для полей, не имеющих области на изображении, выберите [image] на панели инструментов и выделите мышью соответствующую область. Если в списке есть поля, помеченные звездочкой, то программа предложит вам выбрать название одного из таких полей.


Исключение региона из распозавания

Исключение региона из распознавания

Иногда бывает необходимо исключить из распознавания некоторую область, например, область с пояснительным текстом, который мешает извлечению данных из поля.

Чтобы исключить регион из распознавания, выберите инструмент [image] и выделите с помощью мыши область, которую нужно исключить.


Создание поля с непрямоугольной областью

Иногда возникает необходимость создавать поля с непрямоугольной областью, как показано на примере анкеты:

Чтобы создать область поля непрямоугольной формы:

  1. Выберите инструмент для создания поля нужного типа.
  2. Выделите прямоугольную область, к которой можно будет добавить или исключить фрагменты для создания области нужной формы.
  3. Выберите инструмент [image] и убедитесь, что созданная прямоугольная область выделена.
  4. Чтобы добавить фрагмент области: нажмите shift (при этом под курсором появится знак "плюс") и выделите фрагмент для добавления.
  5. Чтобы исключить фрагмент области: нажмите alt (при этом под курсором появится знак "минус") и выделите фрагмент для исключения.


Поля с несколькими областями

Поле может состоять из нескольких областей на изображении, причем эти области могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле.

Несколько областей удобно создавать для полей, расположенных на нескольких страницах, например, для больших таблиц.

Показать пример

Чтобы создать поле с несколькими областями, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать продолжение области…;
  3. Переместите изображение области в нужное место на странице.


Поля с несколькими экземплярами

На формах могут встречаться повторяющиеся элементы – поля или группы полей, встречающиеся на форме несколько раз и описывающие схожие объекты, например, одни и те же сведения о нескольких сотрудниках, о детях, о счетах. Для таких объектов создаются поля с несколькими экземплярами.

Любое поле может иметь несколько экземпляров, их области могут располагаться на расстоянии друг от друга, даже на разных страницах. Экземпляры полей обладают одними и теми же свойствами. Экспортируются они в отдельные файлы или таблицы базы данных.

Несколько экземпляров можно создать для группы полей, если на форме есть повторяющиеся группы.

Показать пример

Чтобы создать поле с несколькими экземплярами, выполните следующие действия:

  1. Создайте поле;
  2. Выделите его, щелкните правой кнопкой мыши в области поля и выберите пункт локального меню Создать экземпляр области…;
  3. Переместите изображение области в нужное место на странице.


Свойства полей

Очень важно правильно задать свойства каждого поля. Свойства полей влияют на правильность их распознавания, и на то, будут ли их значения экспортироваться и подаваться оператору на проверку. Некоторые свойства очень важны для распознавания данных, например, способ разметки для текстового поля ввода: если он задан неправильно, то разметка, не исчезающая при сканировании, не будет отделена от символов и результат распознавания может быть неудовлетворительным.

Поле каждого типа имеет свой набор свойств. Когда вы «нарисовали» на изображении поле определенного типа, ему присваиваются свойства по умолчанию.

Как изменить свойства поля:

  1. Выделите название поля в структуре документа или область поля на изображении, нажмите на правую кнопку мыши и выберите пункт локального меню Свойства….
  2. Измените свойства поля в открывшемся диалоге.

Подробнее о свойствах полей:

Текстовые поля ввода
Метки
Группы меток
Штрих-коды
Картинки
Таблицы
Группы полей


Текстовое поле ввода

При создании текстового поля ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Типы данных
Свойства распознавания
Свойства верификации
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Не может быть пустым – отметьте эту опцию, если вы хотите, чтобы заполнение этого поля было обязательным.
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Индексное поле – отметьте эту опцию, если предполагается производить индексацию документов по этому полю. При обработке документов вы сможете отобразить значение этого поля для каждого документа, производить сортировку и поиск документов по значению поля.
  • Комментарии – вы можете ввести любые комментарии.


Типы данных текстового поля ввода

Для текстового поля ввода очень важно правильно задать тип данных, тем самым, указывая программе, данные какого типа мы ожидаем увидеть в этом поле: будут ли это одни цифры, буквы какого-либо алфавита, символы из определенного набора, дата или что-то другое. Механизм задания типов данных очень гибок и пользователю предоставляется возможность не только выбирать из предоставленного набора типов данных, но и создавать свои типы данных, подходящие для решения конкретной задачи.

При задании типов данных можно настроить проверку формата введенного значения, а также задать ограничения значения, например, ограничение длины текста, минимальное и максимальное значения для числа, промежуток времени для даты.

Если в процессе обработки документов распознанное значение поля не будет соответствовать заданному типу данных, оператор увидит сообщение об ошибке.

Тип данных для текстового поля ввода задается на закладке Тип данных диалога задания свойств поля.

Текст
  1. Если в данное поле будет введен текст, выберите Текст в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, использование словарей или задать более узкий тип данных, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Для стандартного текстового типа (в списке Тип содержимого выбрано Стандартный) можно использовать встроенный словарь и/или пользовательский словарь. Тогда значение поля будет проверяться на вхождение в эти словари.
      Для использования встроенного словаря отметьте опцию Использовать встроенный словарь.
      Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный текстовый тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для текстового типа данных.
Число
  1. Если в данное поле будет введено числовое значение, выберите Число в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, изменить целое число на дробное или наоборот, выбрать более узкий тип данных, например, двузначное число или римские цифры, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Отметить опцию Целое, если значение поля должно быть целым числом и снять эту отметку для дробного числа.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для обычного целого или дробного числа.
    • Специальный тип числа (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для числа.
Внимание! Не следует использовать числовые типы данных для полей, значения которых состоят из цифр, но по сути числом не являются (например, номера карт или паспортов). Использование числового типа для этих полей может привести к проблемам, например, нули в начале строки отбрасываются. В таких случаях можно либо создать текстовый пользовательский тип данных с алфавитом 0-9 и, при необходимости, задать регулярное выражение, либо использовать числовой тип данных и отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.

Дата
  1. Если в данное поле будет вводиться дата, выберите Дата в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, изменить порядок следования компонентов даты, добавить время или день недели, выбрать более узкий тип данных, например, обозначение месяца римскими цифрами, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать из списка нужный Порядок компонентов даты.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для даты, записанной стандартным способом. Для стандартного типа даты вы также можете отметить опции:
      Возможно написание месяца словом - если возможно написание месяца словом, а не только числом,
      Может содержать день недели - если дата может включать день недели,
      Может содержать время - если дата может также включать время.
    • Специальный тип даты (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Подробнее см. Ограничение области значений для даты.
Внимание! Если дату невозможно привести к стандартному формату или вам не нужно работать со значением как с датой, то следует отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.
Денежная сумма
  1. Если в данное поле будет вводится сумма денег, выберите Денежная сумма в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык или выбрать более узкий тип данных, например, аббревиатуру валюты, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выберите стандартный тип (в списке Тип содержимого выбрано Стандартный) для денежной суммы, если значение поля представляет собой число или число, сопровождаемое общепринятым обозначением валюты.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для денежной суммы производится также, как и для числа. Подробнее см. Ограничение области значений для числа.
Внимание! Если денежную сумму невозможно привести к стандартному формату или вам не нужно работать со значением как с числом, то следует отметить опцию Обрабатывать как текст. В этом случае значение поля будет обрабатываться как текст, для проверки значения может использоваться пользовательский словарь, а область значений задается также, как и для текста. См. Ограничение области значений для текстового типа данных.
Адрес
  1. Если в данное поле будет вводится адрес, выберите Адрес в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, адрес электронной почты или почтовый индекс, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для адреса. В этом случае целесообразно использовать пользовательский словарь. Для этого отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для адреса производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.
Имя
  1. Если в данное поле будет вводится имя, выберите Имя в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, фамилию или отчество, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для имени. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для имени производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.
Код
  1. Если в данное поле будет вводится буквенно-цифровой код, выберите Код в списке Содержимое.
    В поле Детали вы увидите описание выбранного типа данных. Если вам необходимо поменять язык, задать пользовательский словарь или выбрать более узкий тип данных, например, номер социального страхования, нажмите на кнопку Правка… справа от описания. В открывшемся диалоге вы можете:
    • Изменить язык распознавания для данного поля. Для этого нажмите кнопку "..." справа от поля Язык. Можно выбрать один или несколько языков.
    • Выбрать стандартный тип (в списке Тип содержимого выбрано Стандартный) для буквенно-цифрового кода. Для использования пользовательского словаря отметьте опцию Подключить пользовательский словарь и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic.
    • Специальный тип (в списке Тип содержимого выбрано Специальный) содержит предопределенные типы данных, среди которых вы можете выбрать подходящий для данного поля. При выборе руководствуйтесь описанием, которое отображается в нижней части диалога. Вы также можете создать собственный пользовательский тип данных, если ни один из предопределенных типов вам не подходит. Подробнее см. Создание пользовательских типов данных.
  2. Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого нажмите кнопку Правка… справа от поля Автозамена. В открывшемся диалоге задайте необходимые параметры обработки текста. Подробнее см. Обработка введенного значения.
  3. Также можно настроить проверку распознанного значения поля: проверять, попадает ли значение в заданную область. Чтобы задать ограничение области значений для поля, нажмите кнопку Правка… справа от поля Проверка значения. Настройка проверки значения для кода производится также, как и для текста. Подробнее см. Ограничение области значений для текстового типа данных.


Создание пользовательских типов данных

Чтобы создать новый тип данных, выберите одно из значений в списке Содержимое на закладке Тип данных свойств поля. Вы можете выбрать любое значение из списка, которое соответствует смыслу вашего пользовательского типа: создание нового типа от этого не зависит, но храниться новый тип данных будет в выбранной категории.

Затем нажмите кнопку Правка… справа от поля Детали.

В открывшемся диалоге выберите значение Специальный в поле Тип содержимого.

Нажмите кнопку Новый… справа от поля Типы данных для выбранного языка.

Следуйте инструкциям Мастера создания нового типа данных.

На первом шаге мастера выберите способ создания типа данных, вы можете создать новый тип данных на основе словаря, регулярного выражения или алфавита или создать новый тип на основе уже существующего типа данных, например, добавив к его алфавиту недостающие вам символы или дополнив словарь.

Чтобы создать новый тип данных на основе словаря, регулярного выражения или алфавита:

  1. Выберите Новый тип данных на основе и отметьте соответствующую опцию, в зависимости от того, будете вы создавать новый тип данных на основе словаря, регулярного выражения или алфавита. Вы можете выбрать одну или несколько опций. Выберите Язык (регион) для вашего типа данных. Нажмите Далее (Next).
  2. Если на первом шаге вы выбрали словарь, то на следующем шаге нужно задать принцип использования словарей.
    Отметьте опцию Использовать встроенный словарь, если вы хотите использовать встроенный словарь для выбранного на первом шаге языка. Чтобы определить наличие слова в словаре, нажмите Просмотр… и введите искомое слово. При нажатии на кнопку Посмотреть вы получите парадигму слова или сообщение об отсутствии слова в словаре.
    Отметьте опцию Пользовательские словари для использования пользовательского словаря и нажмите Правка… для редактирования словаря. Пользовательский словарь можно создать, добавляя в него слова по одному с помощью кнопки Добавить…, или загрузив список слов из файла. Чтобы загрузить слова из файла, нажмите Загрузить… и укажите путь к файлу с расширением .txt или .dic. Нажмите Далее (Next).
  3. Если на первом шаге вы выбрали регулярное выражение, то на следующем шаге нужно задать это выражение. Правильно составить регулярное выражение вам поможет кнопка [image] справа от окна для ввода выражения. Подробнее см. Алфавит, используемый в регулярных выражениях. Нажмите Далее (Next).
  4. Если на первом шаге вы выбрали алфавит, или использовали не включенные в алфавит языка символы при создании регулярного выражения, то на следующем этапе нужно задать алфавит для вашего типа данных. Символы можно вводить с клавиатуры, или вы можете нажать Изменить… и выделите нужные символы с помощью мыши.

    Чтобы добавить знаки препинания и исключенные (запрещенные) символы, нажмите Расширенные параметры…. Эти символы тоже можно вводить с клавиатуры или нажать кнопку справа и выбирать среди возможных символов.

    Нажмите Далее (Next).

  5. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Чтобы создать новый тип данных на основе существующего типа:

  1. На первом шаге Мастера создания нового типа данных выберите На базе существующих типов. Выберите язык (или несколько языков). Нажмите Далее (Next).
  2. На следующем шаге нужно выбрать исходный тип данных (несколько типов), на основе которого вы хотите создать свой тип. В левой части диалога в поле Доступные типы данных вы увидите типы данных, соответствующие выбранным языкам. В папке Текст содержаться натуральные языки, выбранные на первом шаге. В папке Пользовательские содержаться типы данных, созданные пользователями. В остальных папках содержаться типы данных, относящиеся к соответствующей категории и специальному типу содержимого.
    Чтобы выбрать базовый тип данных, выделите его в поле Доступные типы данных (можно выделить несколько, удерживая клавишу ctrl) и перенесите его в правую часть с помощью кнопки Добавить ->. Нажмите Далее (Next).
  3. На последнем шаге мастера введите название нового типа данных и его описание. Если вы хотите продолжить редактирование свойств созданного типа данных, отметьте опцию Редактировать свойства. Нажмите Готово (Finish).

Созданные типы данных появятся в списке предопределенных типов данных при выборе того содержимого, которое было выбрано и при создании типа данных.

Таким образом, чтобы задать созданный тип данных для вашего поля:

  1. На закладке Тип данных диалога задания свойств поля выберите нужное значение в списке Содержимое;
  2. Нажмите на кнопку Правка… справа от поле Детали;
  3. В списке Тип содержимого выберите Специальный;
  4. Найдите в списке созданный тип данных (пользовательские типы данных отличаются от встроенных значком), выберите его и нажмите ОК.


Ограничение области значений для текстового типа данных

В диалоге Настройка проверки значения вы можете задать ограничения области значений для вводимого в поле текста.

Замечание. Текстовым типом считаются не только типы данных с содержимым Текст, но и типы с другим содержимым, у которых отмечена опция Обрабатывать как текст.

  • Ограничение количества символов – задайте максимальное количество символов в поле;
  • Регулярное выражение – отметьте эту опцию, если вы хотите производить проверку значений поля с помощью регулярного выражения.

    Правильно составить регулярное выражение вам поможет кнопка [image]. Подробнее см. Алфавит, используемый в регулярных выражениях.

  • Допустимые значения – отметьте эту опцию, если вы хотите задать список допустимых значений для поля. Для того чтобы добавить значение, нажмите кнопку Добавить… и введите значение в появившемся диалоге. Для редактирования значения нажмите кнопку Правка…, для удаления – Удалить.

  • Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.


Ограничение области значений для числа

Чтобы задать ограничение области значений для числа:

  1. Отметьте опцию Использовать ограничение.
  2. Задайте минимальное и максимальное значения числа.
  3. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.

При обработке документов будет производится проверка на попадание введенного значения в заданный интервал.


Ограничение области значений для даты

В диалоге Настройка проверки значения вы можете задать интервал, в который должна попадать дата, введенная в данное поле.

  1. Отметьте опцию Дата должна попадать в интервал.
  2. Выберите Фиксированный чтобы задать фиксированный интервал времени или Относительно даты верификации чтобы задать интервал времени, относительно даты верификации документов.
  3. Введите начало и конец интервала.
  4. Ошибку при проверке значения считать предупреждением – отметьте эту опцию, чтобы нарушение заданных ограничений считалось не ошибкой, а предупреждением.


Обработка введенного значения

Для любых типов данных можно произвести автоматическую обработку введенного значения: убрать лишние пробелы, преобразовать буквы в заглавные или строчные, автоматически заменить указанные символы или текст. Для этого на закладке Тип данных диалога свойств поля нажмите кнопку Правка… справа от поля Автозамена.

Задайте необходимые параметры автоматической замены или обработки текста.

Обработка будет производится только один раз после распознавания значения поля, если отмечена опция Производить замену только один раз после распознавания. В противном случае, замена будет производиться при каждом изменении значения поля.

  • Для того чтобы произвести автоматическую замену символов в распознанном значении поля, нажмите на кнопку Правка… справа от поля Замена символов. В открывшемся диалоге вы можете добавлять символы для автоматической замены. Если указанные символы встретятся в распознанном значении поля, они будут автоматически заменены.
  • Для того чтобы произвести автоматическую замену всего значения поля или отдельных слов в значении поля, нажмите на кнопку Правка… справа от поля Замена текста.

    В открывшемся диалоге вы можете добавлять слова и выражения для автоматической замены. Для замены значения поля, отметьте опцию Только целое значение поля. В этом случае автоматическая замена будет произведена только в том случае, если указанное слово или выражение является значением всего поля. Для замены отдельных слов отметьте опцию Найденные слова.

    Если вы отметите опцию Точный, то будет производиться поиск и замена строго введенного слова или выражения, а при выборе Неточный будет найдено и заменено слово или выражение, близкое к введенному. Количество допустимых ошибок зависит от длины слова.

    Отметьте опцию Учитывать регистр, если важен регистр слова или выражения для замены.

  • Выберите один из способов преобразования букв текста в выпадающем списке Изменить регистр:

    Не изменять – без преобразования;

    ЗАГЛАВНЫЕ – все буквы будут преобразованы в заглавные;

    строчные – все буквы будут преобразованы в строчные;

    Первая буква заглавная – первая буква будет заглавной, остальные - строчные.

  • Удалить лишние пробелы – отметьте эту опцию, чтобы удалить лишние пробелы.


Свойства распознавания текстового поля

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

  • Не распознавать значение поля, оно будет введено вручную – эту опцию следует отметить, если это поле по каким-либо причинам не может быть распознано (например, если текст в поле написан слитными буквами), и его значение будет вводиться вручную оператором. В этом случае не нужно вводить другие свойства распознавания, так как такое поле распознаваться не будет, а при проверке оператору будет предложено ввести значение поля.

  • ICR (рукопечатный) – отметьте эту опцию, если текст в данном поле будет написан от руки.

  • OCR (печатный) – отметьте эту опцию, если текст в данном поле будет напечатан. В выпадающем списке выберите стиль печати (типографским способом, на матричном принтере, печатной машинке и т.д.) См. Поддерживаемые типы текста.

  • Дополнительно – используйте эту опцию для выбора нескольких типов или задания пользовательского типа текста.

  • Тип разметки – выберите тип разметки, выбор облегчают образцы разметки в выпадающем списке. Если разметка исчезает при сканировании, то рекомендуемый тип разметки является моноширинным (Gray boxes), а если разметка не исчезает при сканировании и разделена на ячейки для знакомест, то обязательно нужно ввести общее число ячеек. При автоматическом нахождении полей с такой разметкой, число ячеек также определяется автоматически.

  • Регистр – выберите регистр букв в поле. Если поле может быть заполнено как строчными, так и заглавными буквами, оставьте значение Любой.

  • Ориентация – задайте ориентацию текста.

  • Для однострочного поля отметьте опцию Однострочное.

  • Для поля, значение которого всегда будет состоять из одного слова, отметьте опцию Одно слово.

  • Задайте опции обработки изображения при распознавании:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – отметьте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания шаблона вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Выберите значение в выпадающем списке:

  • Верифицировать неуверенно распознанные символы – символы поля будут подаваться на верификацию, если они распознаны неуверенно. Это значение присваивается всем полям по умолчанию.
  • Верифицировать все символы – символы поля будут обязательно подаваться на верификацию. Значение все можно выбрать в том случае, если в значении данного поля недопустимы ошибки.
  • Не верифицировать – символы данного поля не будут подаваться на верификацию.

Отметьте опции:

  • Включить в групповую верификацию – чтобы символы поля были включены в групповую верификацию. В групповой верификации могут участвовать все поля, но наиболее целесообразно отправлять на групповую верификацию только метки и поля, содержащие цифры, а буквы лучше проверять в контексте значения поля.
  • Включить в контекстную верификацию – чтобы поле участвовало в контекстной верификации.


Метки

Внимание! Свойства меток, объединенных в группы, задаются сразу для всей группы меток. При попытке редактирования свойств метки, входящей в группу, откроется диалог редактирования свойств группы.

При создании поля метки ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Комментарии – вы можете ввести любые комментарии.


Типы данных для меток

Тип данных для меток задается на закладке Тип данных диалога задания свойств поля.

Тип данных для меток определяет значения, которые будут присвоены полю метки в случае отмеченной и неотмеченной метки.

Выберите подходящие варианты значений метки:

  • Да / Нет – если метка отмечена, значение поля будет "Yes", не отмечена – "No".
  • 1 / 0 – если метка отмечена, значение поля будет 1, не отмечена - 0.
  • <Название метки> / Пустая строка – если метка отмечена, значение поля будет совпадать с названием метки, не отмечено – полю будет присвоено пустое значение.
  • Пользовательские значения – отметив эту опцию, вы можете ввести свои значения, Если метка выбрана – для отмеченной метки, Если метка не выбрана – для неотмеченной.


Свойства распознавания меток

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

  • Тип метки – выберите тип метки. Это свойство очень важно для правильного распознавания меток.

    Квадрат – выберите этот тип метки, если метки ставятся в ограниченные квадратные области.

    Без рамки – выберите этот тип метки, если метки ставятся на белом фоне, без ограничителя.

    Автоматическое определение – при выборе этого типа, программа будет определять тип метки автоматически. Этот тип следует выбирать только в том случае, если первые два типа не подходят, например, у метки есть ограничитель, но он имеет неквадратную форму.
    Внимание! При выборе Автоматическое определение изображение метки на бланке не должно быть заполнено, т.к. программа будет определять проставлена ли метка, сравнивая изображение данной области в обрабатываемом документе и на бланке, на основе которого создается шаблон.

  • Допускать исправления – отметьте эту опцию, если вы хотите разрешить исправления для каких-либо меток: полностью заштрихованные метки в этом случае будут считаться неотмеченными. Но если вы выбрали тип Автоматическое определение, то для таких меток исправления допускать нельзя.

    Можно задать опции обработки изображения поля:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания шаблона вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Выберите значение в выпадающем списке:

  • Верифицировать неуверенно распознанные символы – символы поля будут подаваться на верификацию, если они распознаны неуверенно. Это значение присваивается всем полям по умолчанию.
  • Верифицировать все символы – символы поля будут обязательно подаваться на верификацию. Значение все можно выбрать в том случае, если в значении данного поля недопустимы ошибки.
  • Не верифицировать – символы данного поля не будут подаваться на верификацию.

Отметьте опции:

  • Включить в групповую верификацию – чтобы символы поля были включены в групповую верификацию. В групповой верификации могут участвовать все поля, но наиболее целесообразно отправлять на групповую верификацию только метки и поля, содержащие цифры, а буквы лучше проверять в контексте значения поля.


Группы меток

Внимание! Свойства группы распространяются на все метки, входящие в группу меток.

Значение группы меток представляет собой список имен выбранных меток, разделенных точкой с запятой (;). Если ни одна метка не выбрана, то значение группы меток - пустая строка.

При создании группы меток, ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Свойства распознавания
Типы данных
Свойства верификации
Проверка с помощью правил


Типы данных для групп меток

Тип данных для группы меток задается на закладке Тип данных диалога задания свойств поля.

Допускать, если не выбрано ни одной метки – отметьте эту опцию, если в группе должна быть обязательно отмечена хотя бы одна метка. Тогда в случае, если ни одна метка их группы не будет отмечена, программа выдаст соответствующее предупреждение.

Допускать множественный выбор – отметьте эту опцию, если вы допускаете, что в группе будут отмечены несколько меток. Если эта опция не отмечена, то программа выдает предупреждение при наличии нескольких отмеченных метках в группе.

На этой закладке отображается список названий меток, входящих в данную группу. Вы можете изменить названия меток группы, для этого выделите нужную строку и нажмите кнопку Правка…. В открывшемся диалоге вы можете задать название поля метки и название метки для экспорта.

Вы можете определить экспортируемые значения в случае, если не было выбрано ни одной метки и в случае, если в группе выбрано более одной метки. Для этого выберите в списке одно из значений <Не выбрано ни одного значения> или <Выбрано несколько значений…>, нажмите на кнопку Правка… и в открывшемся диалоге задайте значение в поле Экспортируемое значение. Если значения для экспорта не заданы, то в случае, если ни одна метка не выбрана, экспортируется пустая строка, а в случае выбора нескольких меток экспортируются их значения через запятую.

Создание группы меток


Штрих-код

При создании поля штрих-кода ему присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из пяти закладок, на каждой из которых редактируется определенная группа свойств.

Внимание! Штрих-код может быть выделен как поле или как статический элемент. Это завит от назначения штрих-кода в обрабатываемых документах: если он должен служить для наложения шаблона или идентификации, то его следует создавать в режиме статических элементов, а если из штрих-кода нужно считывать информацию, то его следует создавать в режиме разметки полей. Свойства штрих-кода отличаются в зависимости от того, является ли он полем или статическим элементом. В данном разделе описаны свойства поля, см. также реперный штрих-код.

Основные свойства
Свойства распознавания
Свойства верификации
Проверка с помощью правил


Свойства распознавания штрих-кода

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля). Правильно определенные свойства поля значительно повысят качество распознавания и снизят вероятность появления ошибок.

  • Не распознавать значение поля, оно будет введено вручную - эту опцию следует отметить в том случае, если значение штрих-кода будет вводиться оператором вручную. В этом случае не нужно задавать остальные настройки распознавания.
  • Тип кода – задайте тип штрих-кода (обычно определяется автоматически).
  • Ориентация – задайте ориентацию штрих-кода.

Можно задать опции обработки изображения штрих-кода:

  • Инвертировать – инвертировать изображение.
  • Удалять текстуру – удалять текстуру.
  • Очищать изображение – задайте эту опцию, чтобы производилось очищение изображения от "мусора".
  • Чистить мусор только определенного размера – отметьте эту опцию, если вы хотите производить очистку "мусора" определенного размера. Задайте размер "мусора". Если эта опция не отмечена, а отмечена только опция Очищать изображение, размер "мусора" будет подбираться автоматически.


Свойства верификации поля

Верификация – это проверка распознанных данных оператором. Неуверенно распознанные символы помечаются программой и подаются оператору на проверку, но можно задать свойства поля таким образом, что поле будет подаваться на проверку, даже если в нем нет неуверенно распознанных символов, либо наоборот, не будет подаваться на проверку, даже при наличии неуверенно распознанных символов. Оператор видит распознанный символ и его изображение и либо соглашается с результатом распознавания, либо исправляет его.

В процессе создания шаблона вы можете задать опции верификации на закладке Верификация диалога задания свойств поля.

Выберите значение в выпадающем списке:

  • Верифицировать неуверенно распознанные символы – символы поля будут подаваться на верификацию, если они распознаны неуверенно. Это значение присваивается всем полям по умолчанию.
  • Верифицировать все символы – символы поля будут обязательно подаваться на верификацию. Значение все можно выбрать в том случае, если в значении данного поля недопустимы ошибки.
  • Не верифицировать – символы данного поля не будут подаваться на верификацию.

Отметьте опцию:

  • Включить в контекстную верификацию – чтобы поле участвовало в контекстной верификации.


Картинки

При создании картинки ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из четырех закладок, на каждой из которых редактируется определенная группа свойств.

Основные свойства
Свойства распознавания
Экспорт
Проверка с помощью правил


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Комментарии – вы можете ввести любые комментарии.


Свойства распознавания картинки

Свойства распознавания задаются на закладке Распознавание диалога задания свойств поля (пункт Свойства… локального меню поля).

  • Исключить из распознавания – отметьте эту опцию, если область поля Картинка должна быть исключена из области распознавания остальных полей. (Эта опция доступна только для поля Картинка и используется для совместимости с шаблонами FormReader 6.5.)


Экспорт картинок

Для каждой картинки в шаблоне документа можно настроить параметры экспорта, такие как тип файла, качество, цвет и разрешение. Эти параметры задаются на закладке Экспорт диалога задания свойств поля (пункт Свойства… локального меню поля). Можно задать:

  • Тип файла (TIFF, JPEG, BMP, JPEG2000, PCX packbits, PNG).
  • Качество. Для файлов формата TIFF, JPEG или JPEG2000 можно выбрать качество экспортируемого файла (наилучшее, высокое, обычное, низкое).
  • Тип цвета - цветной, градации серого, полутона (ч/б).

Чтобы установить разрешение экспортируемой картинки, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное значение из списка.


Таблицы

При создании таблицы ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств:

Основные свойства
Столбцы
Проверка с помощью правил


Столбцы таблицы

На закладке Столбцы отображается список столбцов данной таблицы. Каждый столбец таблицы относится к определенному типу полей (см. Создание таблицы) и обладает свойствами, присущими этому типу поля.

Для редактирования свойств одного из столбцов:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…


Группа полей

При создании группы полей ей присваиваются свойства по умолчанию. Изменить свойства можно, выбрав пункт Свойства… локального меню. Диалог для изменения свойств состоит из трех закладок, на каждой из которых редактируется определенная группа свойств

Основные свойства
Поля
Проверка с помощью правил


Поля группы

На закладке Поля отображается список полей, входящих в группу.

Для редактирования свойств одного из полей:

  1. Выберите его название в списке.
  2. Нажмите на кнопку Свойства…

Создание группы полей


Проверка с помощью правил

Правила – один из инструментов для расширения возможностей автоматической проверки результата. Правила позволяют задать ограничения на данные, то есть определить условия, которым должны удовлетворять значения в тех или иных полях.

Если значения в документах не удовлетворяют условиям правил, то такие страницы помечаются флажком с соответствующим сообщением. Основная цель применения правил – это проверка целостности данных документа.

Кроме того, с помощью правил можно обработать введенные значения: соединить значения нескольких полей или заменить распознанные значения соответствующими значениями из базы данных.

ABBYY FlexiCapture 8.0 Professional позволяет задать правила следующих видов:

  • Проверка суммы – проверка суммы нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле.
  • Сравнение значений полей – правило сравнения значений нескольких полей.
  • Проверка по базе данных – производится проверка введенных значений путем их сравнения со значениями из определенной базы данных.
  • Объединение значений полей – правило объединения значений нескольких полей. При объединении можно добавлять любые разделители.
  • Скрипт – ограничения описываются пользователем с помощью скрипта.
  • Сравнение суммы цифрами с суммой прописью – правило сравнения суммы цифрами с суммой прописью (только на русском языке).

Правилу можно присвоить статус ошибки или предупреждения, при невыполнении условия поле помечается красным флажком в случае ошибки, желтым – в случае предупреждения. См. Верификация правил.

Правила задаются на закладке Правила диалога задания свойств объекта (поля, раздела, документа и т.д.).

В иерархической структуре правила хранятся на уровне того объекта, в котором они были созданы: это может быть поле, раздел шаблона или сам шаблон. В большинстве случаев место хранения правил не имеет значения. Но если вы создаете шаблон со сложной структурой, с группами полей или повторяющимися элементами, то нужно следить за местом хранения правил. Например, если у вас есть группа полей, и некоторые поля группы связаны каким-либо правилом, то при создании нового экземпляра этой группы правило будет скопировано и корректно выполняться в новом элементе только в том случае, если правило хранится в самой группе или в одном из ее полей, а не на уровне выше. Из диалога свойств объекта доступен просмотр правил, которые работают с данным объектом, либо правил, хранящихся в данном объекте и в его дочерних объектах. Вы можете указать, какие правила вы хотите просмотреть, выбрав одно из значений выпадающего списка Показывать в списке:

  • Правила, использующие данный элемент – в списке отобразятся правила, которые работают с данным объектом (диалог свойств которого открыт в данный момент).
  • Правила, хранимые в данном элементе – в списке отобразятся правила, которые хранятся в данном объекте.
  • Правила, хранимые в данном элементе и во вложенных элементах – в списке отобразятся правила, которые хранятся в данном объекте и в его дочерних объектах (например, если объект является группой, то отобразятся правила, хранящиеся в группе и во входящих в группу полях).

Замечание. Создать новое правило можно только в режимах отображения Правила, хранимые в данном элементе и Правила, хранимые в данном элементе и во вложенных элементах. В режиме Правила, использующие данный элемент новое правило создать нельзя.

Каждое правило имеет статус ошибки или предупреждения. При попытке экспортировать документы с ошибками правил, будет выдаваться сообщение об этом. Наличии предупреждений правил не помешает экспорту.

Проверка суммы
Сравнение нескольких полей
Проверка по базе данных
Объединение значений полей
Правило сравнения суммы цифрами с суммой прописью

Правило, заданное с помощью скрипта


Правило проверки суммы значений

Это правило предназначено для проверки суммы значений нескольких полей. Сумма значений указанных полей сравнивается с заданным числом или со значением в другом поле. Например, если в вашем документе есть поля с суммой оклада, премии, иных начислений, а также есть поле с общей суммой дохода, то мы можем задать правило, проверяющее совпадает ли сумма значений полей со значением в результирующем поле. При несовпадении будет выдаваться сообщение об ошибке.

Чтобы создать правило проверки суммы, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Проверка суммы и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Добавьте в список Суммировать значения полей поля, сумму значений которых вы хотите проверить, для добавления используйте кнопку Добавить….
  7. Выберите одну из опций:
    • полем – для сравнения суммы со значением результирующего поля. Название этого поля выберите с помощью кнопки Выбрать….
    • числом – для сравнения суммы с заданным числом. Введите это число.
  8. Дробная часть сравниваемых значений – введите количество знаков в дробной части числа, чтобы определить точность сравнения.
  9. Отметьте опцию Необходимы хотя бы два непустых объекта, если требуется, чтобы при суммировании было как минимум два ненулевых слагаемых.
  10. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило сравнения значений нескольких полей

Это правило предназначено для сравнения значений нескольких полей. Его можно применять, если в вашем документе есть несколько полей, значения которых должны быть одинаковыми. При несовпадении значений для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Сравнение значений полей и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Добавьте в список Сравнить значения полей поля, значения которых вы хотите сравнивать, для добавления используйте кнопку Добавить….
  7. Выберите тип сравнения:
    • Четкое – для точного сравнения значений;
    • Нечеткое – для нечеткого сравнения. В этом случае сравнение будет производиться без учета регистра и лишних пробелов, а для значений полей длиннее 4-х символов допускается одна ошибка.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Правило проверки по базе данных

Проверка значений полей по базе данных заключается в том, что распознанное значение поля сравнивается со значениями из таблицы базы данных и считается правильным, если значения совпадают. При несовпадении значений выдается сообщение об ошибке правила.

Чтобы создать правило проверки по базе данных, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Проверка по базе данных и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Установите соединение с базой данных. Необходимые настройки задаются в диалоге, открывающемся при нажатии кнопки Установить…
  7. Выберите из списка схему и таблицу базы данных.
  8. Установите соответствие между полями шаблона документа и полями таблицы базы данных. Для этого нажмите кнопку Добавить… Откроется диалог Соответствие полей. Выберите из списка поле шаблона документа и соответствующее ему поле таблицы базы данных. Выберите тип сравнения:
    • Четкое – значения полей должны точно совпадать.
    • Нечеткое – значения полей должны совпадать частично. (В этом случае происходит поиск наиболее близких слов, таких, чтобы для получения исходного слова нужно было добавить, удалить или заменить наименьшее количество букв. Количество допустимых ошибок зависит от длины исходного слова.) Отметьте опцию Копировать значение поля из базы данных, если хотите, чтобы значение поля документа было заменено соответствующим значением из базы данных.
    • Не сравнивать – сравнение производиться не будет, значение поля будет заменено на значение поля из базы данных (опция Копировать значение поля из базы данных отмечена).
  9. С помощью кнопок Добавить…, Правка… и Удалить можно добавлять, редактировать и удалять связи между полями.


Правило объединения значений полей

Это правило предназначено для объединения значений нескольких полей. Значения полей при объединениии можно отделять друг от друга точкой, пробелом или другими разделителями.

Чтобы создать правило объединения значений, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Объединение значений полей и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next). Ошибка такого правила будет возникать, если, например, одно из полей, участвующих в объединении, было удалено из шаблона.
  6. Добавьте в список Поля для объединения значений поля, которые будут участвовать в объединении, для добавления используйте кнопку Добавить…. Выберите Записать результат в поле – поле, в котором будет храниться результат объединения. Введите в окно Разделитель нужный разделитель.
  7. По умолчанию, разделители будут добавлены между непустыми значениями. Если вы хотите, чтобы разделители добавлялись в любом случае, даже при наличии пустых значений полей, то отметьте опцию Добавлять разделитель при пустом значении.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.

Результат объединения может храниться в любом поле шаблона, удобно использовать с этой целью поля без разметки.

Если вам нужно экспортировать только значение результирующего поля, а не полей, участвующих в объединении, то у последних можно отключить опцию Экспортировать значение поля.


Правило, заданное с помощью скрипта

Программа ABBYY FlexiCapture 8.0 Professional позволяет задать правило проверки данных с помощью скрипта.

Чтобы создать такое правило, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое….
  4. Из списка типов правил выберите Скрипт и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. В списке Доступные поля отображается список доступных объектов. Вы можете добавлять и удалять поля в помощью кнопок Добавить… и Удалить. Значения полей, у которых отмечена опция Только для чтения, доступны для чтения, а значения полей из списка, у которых эта опция не отмечена, могут быть перезаписаны с помощью скрипта.
  7. Выберите язык скрипта и введите текст скрипта. Нажав кнопку Правка…, можно открыть специальное окно для редактирования скрипта. Проверку скрипта можно осуществить при нажатии кнопки Проверить
  8. Нажмите Готово (Finish). Созданное правило отобразится в списке на закладке Правила.

Замечание. Процедуры, которые вы хотите использовать в нескольких правилах, следует записать в глобальный модуль правил. Этот модуль доступен из редктора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для правил. Также глобальный модуль правил доступен из редактора шаблона документа, меню Шаблон>Скриптовые модули>Правила….

Подробнее о создании правил с помощью скрипта, см. Использование скриптов во FlexiCapture 8.0


Правило сравнения суммы цифрами с суммой прописью

Внимание! Правило работает только для русского языка. Это правило можно задать только в том случае, если установлен русский язык распознавания для шаблона (меню Шаблон>Свойства шаблона документа…, закладка Распознавание).

Это правило предназначено для сравнения суммы цифрами с суммой прописью на русском языке. При несовпадении сумм для документа будет выдаваться сообщение об ошибке правила.

Чтобы создать правило сравнения суммы цифрами с суммой прописью, выполните следующие действия:

  1. Откройте диалог свойств поля (локальное меню, пункт Свойства…) или диалог свойств шаблона документа (меню редактора шаблона, пункт Шаблон>Свойства шаблона документа…).
  2. Перейдите на закладку Правила.
  3. Нажмите кнопку Новое…
  4. Из списка типов правил выберите Сравнение суммы цифрами с суммой прописью и нажмите ОК.
  5. Введите название правила и выберите тип правила: Предупреждение или Ошибка и нажмите Далее (Next).
  6. Нажмите кнопку Выбрать… справа от поля Сумма цифрами и выберите поле шаблона документа, в котором находится предназначенная для сравнения сумма цифрами.
  7. Нажмите кнопку Выбрать… справа от поля Сумма прописью и выберите поле шаблона документа, в котором находится предназначенная для сравнения сумма прописью.
  8. Нажмите Готово (Finish) для завершения создания правила. Название правила отобразится на закладке Правила.


Настройка экспорта данных

Чтобы задать способ сохранения данных, полученных в ходе обработки бумажных документов, администратор настраивает экспорт для каждого шаблона. Возможен экспорт четырех типов: в файл заданного формата, в базу данных, в библиотеку документов MS SharePoint или экспорт, описанный с помощью скрипта.

Для того чтобы настроить экспорт, в окне редактора шаблона документа выберите пункт меню Шаблон > Настройки экспорта… и задайте необходимые опции в диалоге Настройки экспорта.

Тип экспорта (файл, база данных, SharePoint или скрипт) нужно задать в поле Вид экспорта. От значения, выбранного в этом поле, зависит вид последующих настроек.

Экспорт в файл
Экспорт в базу данных
Экспорт в SharePoint
Экспорт, описанный с помощью скрипта


Экспорт данных в файл

Чтобы настроить экспорт в файл, выполните следующие действия:

  1. В окне редактора шаблона документа выберите пункт меню Шаблон > Настройки экспорта…
  2. Выберите значение Экспорт в файлы в поле Вид экспорта.

  3. На закладке Место сохранения:

    • Путь – с помощью кнопки Обзор… выберите папку для хранения файлов экспорта.

      Внимание! Если в качестве пути к папке экспорта указывается сетевой диск, убедитесь, что все операторы, работающие с проектом, имеют к нему доступ.

    • Создавать папку для каждого пакета – отметьте эту опцию, для того чтобы результаты экспорта одного пакета документов хранились в отдельной папке.
    • Экспортировать каждый документ в отдельный файл – отметьте эту опцию, для того чтобы результаты экспорта одного документа хранились в отдельном файле, иначе все документы будут экспортироваться в один файл.
    • Отметьте опцию Разрешить перезапись файлов, если вы допускаете перезапись файлов экспорта.
    • Задайте критерии формирования имен файлов экспорта. Для этого нажмите на кнопку Задать имена файлов… и введите нужные критерии в открывшемся диалоге. Подробнее см. Критерии формирования имен файлов экспорта.

  4. На закладке Формат выберите тип файла (поддерживаются форматы CSV, DBF, TXT, XLS, XML) и задайте дополнительные свойства экспорта для выбранного типа файла. Вы также можете указать кодировку текста.

    5. Microsoft Office Excel workbook (*.xls);
    • Выберите версию Excel (5.0/95; 97-2003; 97-2003 (совместимость с 5,0/95));
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все данные будут экспортироваться с типом General;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Для версии Excel 5.0/95 выберите кодовую страницу.
    XML Document (*.xml);
    • Отметьте, какие дополнительные данные хотите экспортировать (расположение полей, тип полей, ошибки, данные о качестве распознавания);
    • При отмеченной опции Сохранять тип значения при экспорте сохраняется xml-схема, в которой описаны типы полей;
    • Выберите кодировку.
    Comma-sepatated values file (*.csv);
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    Text file (*.txt);
    • Выберите Разделитель столбцов;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.
    • Выберите кодировку.
    DBase file (*.dbf);
    • Отметьте опцию Сохранять тип значения при экспорте, чтобы экспортировать данные с учетом их типов. Если снять галочку с этой опции, все поля будут текстовыми;
    • Отметьте опцию Создавать отдельные файлы для повторяющихся элементов, если хотите, чтобы поля с несколькими экземплярами и таблицы экспортировались в отдельные файлы. См. замечания.

  5. На закладке Изображения вы можете задать параметры хранения изображений.

    • Отметьте опцию Сохранять изображения документов, если вы хотите сохранять изображения страниц документов.

    • Отметьте опцию в папку данных, чтобы изображения сохранялись в той же директории, куда экспортируются данные.

    • Отметьте опцию в папку и укажите путь к директории, если вы хотите сохранять изображения в другом месте.

    • Выберите формат хранения изображений, задайте качество и цвет.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF с возможностью поиска. Вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в шаблоне документов. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. Если вы хотите использовать язык шаблона, то в поле Язык должно быть значение Как в шаблоне.

Результатом экспорта будет файл или файлы выбранного формата, содержащий значения всех полей документов.

Замечания.

  1. Повторяющиеся поля, то есть поля с несколькими экземплярами и таблицы, экспортируются в отдельные файлы. Для них создается папка, имя которой совпадает с именем файла экспорта. Можно отключить экспорт повторяющихся полей в отдельные файлы, сняв галочку Создавать отдельные файлы для повторяющихся элементов на закладке Формат (доступна для файлов всех форматов, кроме XML). Тогда повторяющиеся поля будут экспортироваться в общий файл экспорта и для каждого экземпляра элемента будет добавлена новая строка.
  2. Картинки экспортируются в отдельные файлы, в ту же папку, что и повторяющиеся поля. Имя картинки состоит из названия поля и номера документа. Формат файла для картинок задается на закладке Экспорт диалога свойств для поля Картинка. См. Экспорт картинок.


Экспорт в базу данных

Чтобы настроить экспорт в базу данных, выполните следующие действия:

  1. В окне редактора шаблона документа выберите пункт меню Шаблон > Настройки экспорта…
  2. Выберите значение Экспорт в ODBC-совместимую базу данных в поле Вид экспорта.

  3. На закладке Соединение:

    • Установите соединение с базой данных. Введите параметры соединения в окно Строка соединения или нажмите на кнопку Установить… и задайте параметры соединения в открывшемся диалоге.
      Совет. В качестве OLE DB Provider рекомендуется выбирать OLE DB Provider for ODBC Drivers. При выборе OLE DB Provider for SQL Server могут возникнуть проблемы при работе с некоторыми типами данных, при работе с длинными полями.
    • Выберите схему из выпадающего списка.
    • Вы можете проверить соединение с базой данных, нажав на кнопку Тестировать.
    • Установите соответствие полей шаблона документа столбцам таблиц базы данных. Для этого нажмите Соответствие полей…
    • В диалоге Соответствие полей нужно определить, в какие таблицы и столбцы таблиц базы данных будут экспортироваться значения полей шаблона документа.
      Подробнее...

      В диалоге Соответствие полей слева расположены разделы и поля документа, в правой части им нужно поставить в соответствие таблицы и поля базы данных. Если в базе данных уже есть таблицы для экспорта данных, то в диалоге Соответствие полей выберите таблицу базы данных для каждого раздела и столбец таблицы базы данных для каждого поля документа.

      Если в базе данных нет таблиц для экспорта, можно создать таблицы базы данных автоматически, для этого надо нажать на кнопку Создать таблицы автоматически. При ее нажатии создаются таблицы именно той структуры, которые нам нужны для экспорта. Полям документа будут поставлены в соответствие столбцы таблиц.

      Группы полей, поля с несколькими экземплярами, таблицы документа экспортируются в отдельные таблицы базы данных. Для связи между главной и подчиненными таблицами используются первичный ключ (Primary key) и внешний ключ (Foreign key). В главной таблице к каждой записи добавляется первичный ключ, а в подчиненной таблице к каждой записи добавляется внешний ключ, в который записывается значение первичного ключа той записи из главной таблицы, к которой относится данная запись. Первичный и внешний ключи добавляются автоматически, где необходимо. Нужно только указать, в какое поле ключ должен быть проэкспортирован.

      Опция Показывать связанные столбцы отмечена по умолчанию, если с нее снять отметку, то в списках доступных колонок таблиц в правой части дерева не будут отображаться колонки, в которые уже настроен экспорт.

  4. На закладке Изображения можно задать параметры хранения изображений.

    • Вы можете сохранять изображения в базу данных или в файл (в этом случае укажите директорию хранения).

    • Выберите формат хранения изображений, задайте качество и цвет.

    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.

    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF с возможностью поиска. Вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в шаблоне документов. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. Если вы хотите использовать язык шаблона, то в поле Язык должно быть значение Как в шаблоне.

Замечания.

  1. Чтобы отключить сохранение изображений при экспорте в базу данных, нужно при настройке соответствия полей в диалоге Соответствие полей указать значение NotExported для узла, содержащего изображение документа.
  2. Картинки экспортируются в отдельные файлы, формат файла для картинок задается на закладке Экспорт диалога свойств для поля Картинка. См. Экспорт картинок. Имя и путь к файлу картинки можно хранить в базе данных в соответствующем поле (настраивается при установке соответствия полей).
  3. Если в качестве пути к папке экспорта (для изображений, картинок и т.д.) указывается сетевой диск, убедитесь, что все операторы, работающие с проектом, имеют к нему доступ.


Экспорт данных в библиотеку документов SharePoint

Программа ABBYY FlexiCapture 8.0 позволяет настроить экспорт документов в библиотеку документов Microsoftтм SharePont. В результате можно получить библиотеку изображений документов, а дополнительные колонки для каждого документа будут заполнены значениями определенных полей.

Замечания.

  1. Для настройки экспорта в SharePoint необходимо иметь права администратора, для осуществления экспорта достаточно прав участника (contributor).
  2. Колонки в SharePoint, в которые планируется записывать данные, должны иметь тип Single line of text или Multiple lines of text.

Чтобы настроить экспорт в SharePoint, выполните следующие действия:

  1. В окне редактора шаблона документа выберите пункт меню Шаблон > Настройки экспорта…
  2. Выберите значение Экспорт в SharePoint в поле Вид экспорта.

  3. На закладке Соединение с SharePoint:

    • URL сервера (например, http://myserver) – введите адрес сервера, где находятся ваши библиотеки SharePoint. C помощью кнопки Настройки соединения… можно настроить параметры аутентификации (по умолчанию используются параметры аутентификации для входа в Windows) и настройки Proxy, если это необходимо.
    • Ниже отображается состояние соединения, если соединения нет, его можно восстановить с помощью кнопки Соединение.
    • После соединения с сервером SharePoint выберите библиотеку из списка Выберите библиотеку SharePoint.
    • Выберите тип содержимого для документов в поле Тип содержимого (поддержано начиная с SharePoint 2007). В этом случае экспорт значений можно будет настроить в поля, относящиеся к выбранному типу содержания.
    • Далее нужно настроить, какие поля шаблона будут экспортироваться и куда. Для этого нажмите на кнопку Соответствие полей… и произведите необходимые настройки в открывшемся диалоге Соответствие полей. В этом диалоге нужно поставить в соответствие полям шаблона колонки документов в SharePoint. Поля шаблона отображаются слева. Для каждого экспортируемого поля шаблона (кроме групп и таблиц) можно выбрать еще не занятую колонку в SharePoint.
    • Задайте критерии формирования имен файлов экспорта. При экспорте в SharePoint - это файлы изображений документов. Для этого нажмите на кнопку Задать имена файлов… и введите нужные критерии в открывшемся диалоге. Подробнее см. Критерии формирования имен файлов экспорта.

  4. На закладке Изображения нужно задать параметры хранения изображений.

    • Выберите формат, в котором вы хотите сохранять изображения документов, в выпадающем списке Тип файла.

    • Выберите качество изображений в поле Качество.

    • Выберите тип цвета изображений в поле Тип цвета.
    • Чтобы изменить разрешение исходных изображений, отметьте опцию Установить разрешение равным и введите разрешение или выберите нужное из списка.
    • Если вы выбрали формат PDF или PDF/A для хранения изображений, то вы также можете создать PDF с возможностью поиска, для этого следует отметить опцию Создать PDF с возможностью поиска. Вы можете выбрать язык (или несколько языков, если ваш документ написан на нескольких языках), отличный от языка, заданного в шаблоне документов. Для этого нажмите на кнопку Выбрать… справа от поля Язык и добавьте нужные языки. Если вы хотите использовать язык шаблона, то в поле Язык должно быть значение Как в шаблоне.

В результате экспорта, документы будут сохранены в библиотеке SharePoint, каждому документу будут соответствовать колонки со значениями из определенных полей документа. Эти значения можно использовать для поиска и индексации документов.


Экспорт, описанный с помощью скрипта

Чтобы настроить экспорт с помощью скрипта:

  1. В окне редактора шаблона документа выберите пункт меню Шаблон > Настройки экспорта…
  2. Выберите значение Пользовательский экспорт (скрипт) в поле Вид экспорта.
  3. Выберите язык скрипта (JScript® или VBScript).
  4. Введите текст скрипта в окне редактора, которое появляется при нажатии на кнопку Редактировать….

Замечание. Процедуры, которые вы хотите использовать в нескольких скриптах экспорта, следует записать в глобальный модуль экспорта. Этот модуль доступен из редктора скриптов, для этого следует в выпадающем списке на панели инструментов редактора скриптов выбрать Модуль для экспорта. Также глобальный модуль правил доступен из редактора шаблона документа, меню Шаблон>Скриптовые модули>Экспорт….

Подробнее об описании экспорта с помощью скрипта, см. Использование скриптов во FlexiCapture 8.0


Критерии формирования имен файлов экспорта

Имена файлов при экспорте формируются автоматически на основании критериев, заданных пользователем. Задать эти критерии можно при настройке экспорта в файлы или в SharePoint. Для этого нажмите на кнопку Задать имена файлов… на закладке Место сохранения при настройке экспорта в файлы или на закладке Соединение с SharePoint при настройке экспорта в SharePoint. Откроется диалог Имя файла экспорта, в котором и следует определить критерии формирования имен файлов.

К имени файла экспорта можно автоматически присоединять:

  • название проекта: для этого отметьте опцию Название проекта;
  • название пакета документов: для этого отметьте опцию Название пакета;
  • название шаблона документов: для этого отметьте опцию Имя шаблона документа;
  • идентификатор документа, то есть значение штрих-кода со страницы разделителя, если разделители со штрих-кодами использовались при добавлении изображения (подробнее см. Параметры обработки изображений): для этого отметьте опцию Идентификатор документа;
  • значение индексного поля (см. Индексные поля): для этого отметьте опцию Значение индексного поля и выберите индексное поле с помощью кнопки Выбрать….

В поле Шаблон имени файла отображается шаблон, по которому будут формироваться имена файлов экспорта. Если вы хотите добавить какой-либо текст к имени файлов, вы можете дописать его в этом поле.

Для корректного формирования имен файлов экспорта нужно задать критерии таким образом, чтобы имена не оказались пустыми. Если имена файлов могут оказаться пустыми, программа выдаст предупреждение об этом.


Настройка отображения данных в окне документа

После того, как данные будут распознаны, пользователь увидит их в окне документа. По умолчанию данные будут расположены по порядку, подписи к ним будут соответствовать названиям полей шаблона.

Однако, можно изменить представление данных, расположив их удобным для пользователя способом или изменив названия элементов. Представление данных можно отредактировать в окне Форма данных редактора шаблона.

Можно изменить подпись поля в форме данных, не меняя его названия в структуре документа. Для этого введите другое имя в поле Заголовок на закладке Общие диалога свойств поля. Это имя и будет служить подписью для поля в форме данных. Этой возможностью удобно пользоваться, например, для задания пользовательских названий столбцов в таблицах, особенно при использовании гибкого описания, где имена полей менять нельзя.

Шрифт и размер текста для отображения названий полей и распознанных значений данных можно задать на закладке Форма данных диалога свойств шаблона (Шаблон > Свойства шаблона документа…). Размер можно также изменить, щелкнув в окне Форма данных правой кнопкой мыши и выбрав нужный размер (пункт локального меню Размер текста).

Поля можно перемещать, менять их названия или другие свойства. Чтобы вернуть исходное расположение полей, выберите пункт локального меню

Вы можете добавить любой текст, например, какие-либо пояснения. Для этого щелкните в окне Форма данных правой кнопкой мыши и выберите пункт локального меню Вставить текстовую метку. Введите нужный текст вместо текста Текстовая метка.


Свойства шаблона документов

Основные свойства шаблона документов, такие как название, язык и стиль написания, задаются в процессе работы Мастера создания шаблона документов. Другие свойства определяются по умолчанию.

Просмотреть и изменить свойства шаблона документов можно в диалоге свойств, который открывается при выборе пункта меню Шаблон>Свойства шаблона документа… в окне Редактора шаблона документов.

Диалог состоит из шести закладок.

Закладка Общие

На этой закладке вы можете изменить название шаблона и ввести или отредактировать описание. Опция Включен включает/исключает шаблон из обработки документов.

Закладка Распознавание

На данной закладке вы можете изменить общие свойства распознавания шаблона документов:

  • Язык (регион) – для правильного распознавания данных важно правильно задать используемый язык. Это свойство определяет как язык заполнения, так и другие локальные установки, такие как формат даты, валюты и др.
  • Стиль написания – стиль написания может сильно отличаться в разных странах, поэтому нужно задать страну для определения характерного стиля написания.

  • Задайте тип текста:

    ICR (рукопечатный) – выберите эту опцию, если большинство полей документов будут заполнены от руки;

    OCR (печатный) – выберите эту опцию, если значения в большинстве полей будут напечатаны. Выберите тип печати в выпадающем списке.

    Замечание. Не для всех языков поддерживается распознавание рукопечатного текста. Для некоторых языков этот тип распознавания будет недоступен. См. Поддерживаемые языки распознавания.

    Вы можете изменить тип текста для отдельных полей, а указанный на этой закладке тип будет использоваться по умолчанию.

  • Вы можете отметить одну или несколько опций из группы Возможные положения страниц, для того, чтобы при автоматическом подборе ориентации страницы, она поворачивалась на 180°, 90° по часовой стрелке или 90° против часовой стрелки.
  • Нажмите на кнопку Расширенные настройки…, чтобы настроить исправление линейных и нелинейных искажений изображения.

Закладка Сборка документов

Эта закладка предназначена для задания правил сборки многостраничных документов.

В самом простом случае шаблон состоит из одного раздела, повторяющегося один раз. Если шаблон состоит из нескольких разделов, список их названий отображается на данной закладке. Вы можете задать количество повторений каждого раздела, изменив цифры в столбцах Минимальное количество и Максимальное количество.

  • Проверять совпадение ключевых полей – отметьте эту опцию, если вы хотите осуществлять проверку сборки документов по ключевым полям. Затем в столбце Ключевое поле выберите ключевое поле для каждого раздела. При вводе документов, правильно собранными будут считаться документы, у которых совпадают значения ключевых полей в каждом раздела. При несовпадении значений, будет выдано сообщение об ошибках сборки.
  • Подключить страницы приложения – отметьте эту опцию, если вы хотите обрабатывать документы с приложениями.
  • В некоторых случаях бывает необходимо отключить проверку порядка следования разделов в документе, например, если порядок не важен для сборки документов. Для этого отметьте опцию Не проверять порядок разделов в документе. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет.

Подробнее см. Создание шаблонов для многостраничных документов, Сборка страниц в документы и Создание шаблонов для документов с приложениями.

Закладка Правила

Эта закладка предназначена для работы с правилами шаблона. Вы можете удалять, редактировать и создавать новые правила.

Подробнее см. Проверка с помощью правил.

Закладка Экспорт

На этой закладке отображаются текущие настройки экспорта данного шаблона. Для изменения настроек экспорта нажмите кнопку Изменить настройки…

Подробнее см. Настройка экспорта данных.

Закладка Форма данных

На этой закладке можно изменить начертание и размер шрифта для отображения распознанных данных.

В группе Параметры текста данных – настройки шрифта для отображения распознанных значений.

В группе Параметры текстовых меток – настройки для отображения пояснительного текста (названий полей).

Подробнее см. Настройка отображения данных в окне документа.


Свойства шаблона раздела документа

Просмотреть и изменить свойства шаблона раздела документа можно в диалоге свойств, который открывается при выборе пункта локального меню раздела Свойства…

Диалог состоит из трех закладок.

Закладка Общие

На этой закладке вы можете изменить название раздела документа, ввести или отредактировать описание, ввести или изменить число минимальное и максимальное число повторений раздела в документе. Опция Включен включает/исключает шаблон раздела из обработки документов. Подробнее о многостраничных документах и о работе с разделами см. Создание шаблонов для многостраничных документов.

Закладка Гибкое описание

Если к разделу подключено гибкое описание, то на этой закладке отображается его Название, Версия и Комментарий. Вы можете подключить гибкое описание с помощью кнопки Загрузить… и отключить его с помощью кнопки Выгрузить.

Подробнее см. Создание шаблона для обработки гибких документов.

Закладка Изображения
На этой закладке отображаются параметры изображений страниц, из которых состоит раздел. Вы можете просмотреть значения следующих параметров изображений: размер, разрешение, размер для печати, цветовой режим.

Закладка Правила

Эта закладка предназначена для работы с правилами шаблона. Вы можете удалять, редактировать и создавать новые правила.

Подробнее см. Проверка с помощью правил.


Импорт шаблона для форм, созданных в программе ABBYY FormDesigner

ABBYY FormDesigner является удобным инструментом, разработанным специально для создания машиночитаемых форм. Создавая формы с помощью ABBYY FormDesigner, вы не только получаете формы, удовлетворяющие всем требованиям автоматизированной обработки документов, но и почти готовый шаблон для обработки этих форм в программе ABBYY FlexiCapture 8.0 Professional.

Чтобы получить шаблон документа для обработки созданных в программе ABBYY FormDesigner форм, нужно:

В ABBYY FormDesigner:

  1. Создать форму;
  2. Опубликовать ее;
  3. Экспортировать в формат XML Form Definition. Будет получен файл с расширением .xfd

Подробнее о создании формы, публикации и экспорте читайте в справке и руководстве ABBYY FormDesigner 8.0.

В ABBYY FlexiCapture:

  1. В главном окне программы выбрать пункт меню Проект > Шаблоны документов…;
  2. В диалоге Шаблоны документов нажать кнопку Импорт…;
  3. В открывшемся диалоге Открытие файла для импорта выберите значение XML Form Definition Files (*.xfd) в выпадающем списке Files of type и укажите путь к *.xfd файлу;
  4. Название нового шаблона документа появится в списке шаблонов диалога Шаблоны документов.

Открыв импортированный шаблон для редактирования, вы увидите, что разметка полей и статических элементов уже присутствует на изображении. Вам осталось только отредактировать свойства полей и настроить экспорт.


Создание шаблонов для многостраничных документов

ABBYY FlexiCapture 8.0 Professional позволяет создавать шаблоны для многостраничных документов. Шаблон может состоять из произвольного количества разделов, каждый из которых может содержать одну или несколько страниц. Для шаблонов многостраничных документов задается порядок следования разделов, их количество и правила сборки страниц в документы.

После завершения работы Мастера создания нового шаблона создается простой шаблон, не содержащий разделов. Вы можете добавлять в шаблон страницы. При добавлении страницы ее изображение добавляется в область изображения в окне редактора шаблонов, а поля, созданные на ней, будут фигурировать в общем списке полей. В этом случае документ состоит из одного раздела, хотя он может содержать несколько страниц.

Добавлять страницы в один раздел следует, если в документе есть блоки, переходящие со страницы на страницу, повторяющиеся на разных страницах блоки, таблицы, переходящие на следующую страницу. Такой же способ используется при загрузке многостраничного гибкого описания (см. Создание шаблона для обработки гибких документов). Все поля гибкого описания должны относиться к одному разделу шаблона документа.

Другой способ заключается в добавлении к шаблону разделов. В наиболее простом случае один раздел содержит одну страницу. Так можно поступать, если наборы полей на страницах независимы. Такой способ более наглядный: в структуре документа видно, к какому разделу относятся поля, а также вы можете задать произвольную структуру сборки документа. Например, в вашем документе страницы трех типов, причем страницы первого и третьего типа содержатся в документе 1 раз, а страница второго типа может повторяться от 2 до 5 раз. Тогда нужно создать 3 раздела: для каждого типа страницы отдельный раздел, а потом задать структуру документа, то есть последовательность и количество повторений разделов.

Более сложный случай – шаблон, состоящий из нескольких разделов, причем некоторые разделы содержат более одной страницы. Это, например, шаблон, состоящий из жестких разделов и гибкого многостраничного раздела. Или шаблон, описывающий документы, содержащие двусторонний лист, который может повторяться несколько раз. Допустим, вам нужно создать шаблон для документа, содержащего титульный лист (страницу A) и некоторое количество двусторонних листов (последовательность страниц BCBC...). Тогда создаем раздел A, состоящий из одной страницы A и раздел BC, состоящий из двух страниц B и С. Структуру документа зададим следующим образом: раздел A повторяется 1 раз, за ним следует раздел BC, повторяющийся, например, от 3 до 7 раз.

Для шаблона, состоящего из нескольких разделов, кроме последовательности и числа повторений разделов, можно задать проверку ключевых полей. Для этого в каждом разделе документа определяются ключевые поля, значения которых в разных разделах должны быть одинаковыми. В качестве ключевого поля можно взять, например, фамилию заполняющего документ, которую он должен написать на каждой странице, или некий идентификационный номер.

При обработке пакета программа пытается собрать в документы следующие друг за другом страницы, производя при этом проверку правил сборки. Будет произведена проверка значений ключевых полей. При несовпадении ключевых полей на страницах одного документа, появится сообщение об ошибке. Иногда это происходит из-за того, что страницы документов перепутаны при сканировании, и для выполнения правил сборки документов достаточно изменить порядок следования страниц. См. Сборка страниц в документы.

Для того, чтобы добавить страницу в раздел, воспользуйтесь пунктом меню редактора шаблона документа Шаблон > Добавить страницу… или пунктом локального меню изображения Добавить страницу… После этого загрузите изображение новой незаполненной страницы и выберите типы объектов, которые должны быть отмечены на странице автоматически.

Для того чтобы добавить новый раздел, воспользуйтесь пунктом меню Шаблон > Добавить раздел документа… в окне редактора шаблона. Откроется мастер создания раздела, который поможет вам задать все необходимые параметры. Следуя инструкциям мастера, выполните следующие действия:

  • задайте название раздела;
  • загрузите изображение незаполненной страницы (отсканируйте или загрузите из файла) либо загрузите файл гибкого описания;
  • выберите типы объектов, которые будут отмечены автоматически.

Новый раздел и содержащиеся в нем поля отобразятся в окне структуры документа.

Для того чтобы просмотреть получившуюся структуру документа при создании шаблона, в окне Структура документа редактора шаблонов документов перейдите на закладку Страницы. На ней представлена структура документа в режиме эскизов страниц. На этой закладке можно изменить количество вхождений разделов в документ (для этого введите новое значение – число или интервал – в квадрате справа от названия раздела), подключить страницы приложения, изменить порядок страниц в разделе и перенести страницы из одного раздела в другой простым перетаскиванием изображения страницы.

Показать окно структуры документа

Для того, чтобы задать последовательность и число повторений разделов, а также правило сборки, воспользуйтесь пунктом меню Шаблон > Свойства шаблона документа… в окне редактора шаблона.

На закладке Сборка документов задайте минимальное и максимальное число вхождений каждого раздела в документ (по умолчанию 1).

Если вы хотите проверять значения ключевых полей, отметьте опцию Проверять совпадение ключевых полей и выберите ключевое поле в каждом разделе.

В некоторых случаях бывает необходимо отключить проверку порядка следования разделов в документе, например, если порядок не важен для сборки документов. Для этого отметьте опцию Не проверять порядок разделов в документе. Наличие всех разделов в документе в любом случае будет проверяться, а порядок следования разделов - нет.

Показать закладку Сборка документов


Создание шаблона для обработки гибких документов

Для счетов, платежных поручений и других аналогичных документов невозможно создать шаблон с жестким расположением полей, потому что местоположение, размеры и количество полей на разных экземплярах могут не совпадать, а значит, жесткий шаблон не может быть наложен на все документы. На таких документах поля ищутся после предварительного распознавания всей страницы целиком, и на основе ключевых слов и взаимного расположения полей создается гибкое описание. Для разработки гибких описаний предназначен специальный компонент программы ABBYY FlexiLayout Studio 8.0 (поставляется вместе с ABBYY FlexiCapture 8.0 Professional). Подробное руководство создания гибкого описания вы найдете в справке для ABBYY FlexiLayout Studio 8.0.

Гибкое описание экспортируется в .afl файл, а затем подключается в ABBYY FlexiCapture 8.0 Professional. Мы можем использовать гибкое описание для всего шаблона или в качестве одного из разделов. Гибкое описание может быть многостраничным.

Подключение гибкого описания

Гибкое описание можно подключить на этапе создания шаблона документов. Для этого на втором шаге Мастера создания шаблона документов добавьте изображение документа, а затем отметьте опцию Загрузить гибкое описание и введите путь к файлу с расширением .afl, содержащему гибкое описание.

Вы можете подключить гибкое описание и из окна Редактора шаблонов документов, в диалоге свойств шаблона раздела документа.

  1. Выберите раздел документа. (Если шаблон состоит из одного раздела, то в окне Структура документа перейдите на закладку Страницы и выберите название единственного раздела.) Нажмите на правую кнопку мыши и выберите пункт локального меню Свойства…
  2. Перейдите на закладку Гибкое описание.
  3. Нажмите Загрузить…
  4. Выберите нужный .afl файл, содержащий гибкое описание.

После подключения гибкого описания геометрическая разметка полей уже будет присутствовать на изображении. Теперь нужно задать свойства полей точно так же, как и для жесткого шаблона. Определите свойства распознавания, верификации, экспорта, задайте необходимые правила.


Создание шаблонов для документов с приложениями

ABBYY FlexiCapture 8.0 Professional позволяет создавать шаблоны для документов с приложениями. Приложения – это дополнительные страницы, которые могут сопровождать каждую форму, на эти страницы не будет наложен шаблон, но они учитываются при сборке документов. Например, к заявлению на получение кредита (жесткая форма) прилагается справка с места работы, составленная в свободном стиле. Эта справка может обрабатываться как приложение.

Чтобы создать шаблон документа с приложением:

Первый способ:

  1. Перейдите на закладку Страницы в окне Структура документа (правая часть редактора шаблона).
  2. Включите опцию Подключить раздел приложения в документе.
  3. Введите количество или диапазон страниц приложения в появившемся квадрате справа от названия раздела.
Показать окно структуры документа

Второй способ:
  1. Откройте диалог свойств шаблона документа (Шаблон > Свойства шаблона документа… в окне редактора шаблона);
  2. Перейдите на закладку Сборка документов;
  3. Отметьте опцию Подключить страницы приложения. В списке разделов появится строка Страницы приложения;
  4. Введите минимальное и максимальное количество страниц в приложении.
Показать диалог

Для того чтобы сохранить текст приложения, нужно при настройке экспорта задать опции сохранения изображений (на закладке Изображения диалога Настройки экспорта). Если вы выберите формат PDF searchable для сохранения изображения, то текст будет распознан и сохранен в PDF с возможностью поиска.


Обработка неструктурированных документов

Если вам нужно обрабатывать неструктурированные документы, содержащие информацию, изложенную в свободном стиле, например, контракты, письма, приказы, приложения, то и в этом случае поможет ABBYY FlexiCapture 8.0 Professional. Неструктурированные документы с текстом или изображениями, разделенные пустыми страницами или страницами со штрих-кодом, обрабатываются и экспортируются в PDF файлы с возможностью поиска или в файлы графических форматов.

Обработка таких документов обычно состоит в том, чтобы перевести документы в электронный вид и организовать их поиск по значениям ключевых полей.

Если возможно, поиск ключевых полей (например, номер контракта) на таких документах производится с помощью гибкого описания, созданного в приложении ABBYY FlexiLayout Studio. См. Создание шаблона для обработки гибких документов.

Если автоматический поиск ключевых полей невозможен, то их значения могут вводиться вручную оператором. Для этого создайте шаблон документов с одним полем (или с несколькими полями, если нужно), и в свойствах распознавания этого поля (полей) отметьте опцию Не распознавать значение поля, оно будет введено вручную. В этом случае при запуске процесса верификации оператору будет предложено ввести значения ключевых полей вручную.

Для хранения документов нужно настроить экспорт: значения ключевых полей вы можете экспортировать в файл или базу данных, а изображения документов сохранить в удобном для вас формате. Для этого на закладке Изображения диалога Настройки экспорта отметьте опцию Сохранять изображения документов и задайте параметры сохранения изображений. Вы можете сохранять изображения документов в графических файлах или в PDF с возможностью поиска.

Обратите внимание на сборку страниц в документы: для неструктурированных документов бывает сложно определить, к какому документу относится та или иная страница. Для автоматизации сборки неструктурированных документов рекомендуется разделять документы чистыми страницами или страницами со штрих-кодами. Тогда при добавлении изображений в пакет (путем сканирования, добавления из файлов или при создании профиля импорта) нужно отметить опцию Для изображений, разделенных и выбрать из выпадающего списка значение пустыми страницами или страницами со штрих-кодом в зависимости, от того, какие страницы используются в качестве разделителя. Сборка страниц в документы будет произведена автоматически: страницы будут добавляться в текущий документ, пока не встретится страница-разделитель. Подробнее см. Добавление изображений страниц.


Редактирование и публикация шаблона

Редактирование шаблона производится в окне редактора шаблона документов, в котором вы можете изменять расположение полей и статических элементов, редактировать их свойства, правила, настройки экспорта и т.д.

Для того чтобы при редактировании шаблона не влиять на работу других участников проекта, в программе предусмотрена возможность редактирования локальной копии шаблона, в то время как для распознавания используется последняя опубликованная версия. Такой режим работы позволяет администраторам вносить изменения и тестировать шаблон локально, а операторам даст возможность завершить верификацию и экспорт документов, распознанных в старой версии, даже если шаблон сильно изменен или удален. Редактируемый шаблон недоступен для редактирования другими пользователями. После завершения редактирования администратор может опубликовать шаблон, тогда новая версия становится доступной для распознавания документов, или отменить все сделанные изменения.

Чтобы отредактировать шаблон выполните следующие действия:

  1. В главном окне программы выберите пункт меню Проект>Шаблоны документов…
  2. Выберите в списке шаблон для редактирования.
  3. Нажмите кнопку Правка… в диалоге Шаблоны документов, чтобы начать редактирование шаблона. Локальная версия шаблона будет скопирована на ваш компьютер. Шаблон станет недоступен для редактирования другими пользователями.
  4. Сделайте необходимые изменения в окне редактора шаблона документов. Сохраните шаблон.
  5. Протестируйте шаблон на нескольких изображениях. Для отладки шаблона используются тестовые пакеты, которые работают с локальной версией шаблона.
  6. Нажмите кнопку Опубликовать в диалоге Шаблоны документов, чтобы опубликовать шаблон. После публикации новая версия шаблона будет использоваться для распознавания документов из рабочих пакетов. Шаблон снова станет доступен для редактирования другими администраторами. Для того чтобы вернуть шаблон, но без сделанных изменений, нужно нажать кнопку Отменить правку.


Тестирование шаблонов документов

Прежде чем приступать к массовому вводу документов, необходимо протестировать шаблоны. Тестирование производится на документах, добавляемых в тестовые пакеты, т.к. эти пакеты работают с локальной версией шаблона. Эти пакеты доступны из меню Проект>Тестовые пакеты главного окна программы. Также к ним можно перейти из окна редактора шаблона документа, выбрав пункт меню Сервис>Тестовые пакеты….

Внимание! С тестовыми пакетами может работать только пользователь, создавший их. При необходимости, роль постоянных тестовых пакетов могут играть рабочие пакеты, используемые как источник изображений для тестового пакета.

Тестировать шаблон можно прямо в редакторе шаблона документа, на том изображении, которое используется для создания шаблона. Чтобы начать тестирование, выберите пункт меню Документ>Начать тестирование. Форма данных отобразится также, как и при обработке документов, будут показаны форматные ошибки, неуверенно распознанные символы и ошибки правил.

Для удобного расположения окон при тестировании воспользуйтесь меню Документ>Вид, а для навигации между объектами верификации, неуверенно распознанными символами и ошибками правил, меню Документ>Верификация. Для выхода из режима тестирования нажмите на кнопку Закончить тестирование документа или выберите пункт меню Документ>Закончить тестирование.

Замечание. В режиме тестирования перемещение разметки поля в окне изображения не приводит к перераспознаванию поля, как это происходит при работе в окне документа.

Для тестирования шаблона на других изображениях нужно выбрать тестовый пакет, перейти к нему можно из редактора шаблона документа, выбрав пункт меню Сервис>Тестовые пакеты…. Перед вызовом диалога выбора тестового пакета происходит проверка правильности шаблона. В случае если ошибок нет, шаблон сохраняется и вызывается диалог выбора тестового пакета. При выборе какого-либо пакета происходит переключение на этот пакет в главном окне программы (главное окно становится активным).

Рекомендуется проверить каждый шаблон не менее, чем на 20 изображениях документов (если документы заполняются от руки, то желательно, чтобы они были заполнены разными людьми).

Тестирование необходимо для того, чтобы выяснить:

  1. Достаточно ли выделенных реперов и идентификаторов для уверенного наложения шаблона на изображения.
  2. Корректно ли заданы свойства полей.
  3. Корректно ли заданы правила.
  4. Корректно ли настроен экспорт.

При тестировании должна быть проделана вся последовательность действий, выполняемая при обработке документов.

Если в результате тестирования были обнаружены ошибки в правилах, некорректно заданные значения свойств полей и т.д., то для их исправления необходимо отредактировать шаблон.

Только после устранения всех найденных проблем можно опубликовать шаблон и приступать к массовому вводу документов.

Работа оператора с настроенным проектом


Профили импорта изображений

Оператор начинает работу с добавления новых изображений: это могут быть бумажные документы, которые он должен отсканировать, или уже имеющиеся электронные изображения.

Часто выполняемые действия по добавлению регулярно поступающих из одного и того же места изображений можно автоматизировать, тогда импорт будет производиться нажатием одной кнопки. Для этого нужно создать профиль импорта изображений. Кроме того, можно настроить параметры обработки поступающих изображений и периодическое добавление изображений в фоновом режиме. Если произведены необходимые настройки, то при нажатии одной кнопки выполняется сканирование или импорт из заранее настроенного источника, а полученные изображения обрабатываются (например, очищаются от «мусора»). При желании пользователь может сменить источник ввода изображений или его настройки.

В случае если источники импорта часто меняются, то во избежание необходимости настройки источников можно создать несколько профилей импорта и переключаться между ними.

Создание профиля импорта

Чтобы добавить профиль импорта, выберите пункт меню Проект > Профили импорта изображений… главного окна программы. В открывшемся диалоге вы можете создавать новые профили импорта, редактировать, удалять и копировать существующие профили.

Создать новый профиль импорта вам поможет мастер создания профиля, который запустится из диалога Профили импорта изображений при нажатии кнопки Новый…. На первом шаге мастера выберите источник импорта. Источником импорта может служить сканер или горячая папка.

Создание профиля импорта с использованием сканера
  1. В качестве источника импорта выберите Сканер.

    Внимание! Сканер должен быть подключен. Чтобы правильно подключить сканер, обратитесь к документации, прилагаемой к сканеру. При установке не забудьте установить все программное обеспечение, поставляемое вместе со сканером.

  2. На следующем шаге мастера вы можете задать опции сканирования и обработки поступающих изображений:
    • Стиль диалога настроек – выберите способ взаимодействия программы со сканером:
      • Настройки сканирования FlexiCapture: в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера. Нажмите на кнопку Настройки… чтобы установить опции сканирования. Если вы отметите Показывать опции перед сканированием, то при выборе данного профиля импорта перед началом сканирования будет появляться диалог программы ABBYY FlexiCapture Настройки сканера.
      • Системные настройки сканирования: для настройки опций сканирования будет использоваться диалог соответствующего драйвера сканера. В этом случае при создании профиля импорта нельзя изменить опции сканирования, но диалог настроек сканирования будет появляться каждый раз перед началом сканирования изображений.
    • Отметьте, хотите ли вы сканировать одно или несколько изображений за один раз.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений.
  4. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.

Внимание! Если администратор, создавший профиль импорта с использованием сканера, хочет разрешить другим пользователям данной машины с правами обычных пользователей (члены группы Users) создавать или редактировать профили импорта с использованием сканера, то он должен вручную дать право обычным пользователям на модификацию файла: %allusersprofile%\Application Data\ABBYY\FlexiCapture\Scanning\Profiles.

Создание профиля импорта с использованием горячей папки
  1. В качестве источника импорта выберите Горячая папка. Задайте путь к горячей папке с помощью кнопки Обзор…

    Внимание! Для добавления изображений из горячей папки пользователь должен обладать правами на чтение и запись в данную папку.

  2. На втором шаге задайте опции загрузки изображений:
    • Проверять Горячую папку каждые – отметьте эту опцию и введите промежуток времени, чтобы производилась автоматическая проверка наличия новых изображений в горячей папке.

      Замечание. Автоматическая проверка горячей папки запускается при команде пользователя импортировать изображения, используя профиль, в котором отмечена опция Проверять Горячую папку каждые. Проверка горячей папки прекращается при закрытии проекта, либо при снятии отметки с данной опции в свойствах профиля.

    • В области Настройки пакета выберите одну из опций, чтобы определить, в какой пакет будут добавлены новые изображения.
      • Добавлять изображения в текущий пакет – отметьте эту опцию, чтобы изображения из горячей папки были добавлены в текущий пакет;
      • Добавлять в пакет – отметьте эту опцию и выберите название пакета в выпадающем списке, чтобы изображения были добавлены в указанный пакет;
      • Создавать новые пакеты изображений автоматически – отметьте эту опцию, чтобы пакеты для новых изображений создавались автоматически.
    • В выпадающем списке Количество файлов выберите одно из значений, чтобы определить, сколько файлов будет добавлено в указанный или вновь созданный пакет:
      • В соответствии с файлом описания – файлы будут добавлены согласно описанию. Чтобы задать имя и тип файла описания, нажмите кнопку Настройки… Подробнее см. Файл описания.
      • Все файлы – будут добавлены все файлы, обнаруженные в горячей папке.
      • Несколько файлов – будут добавлены несколько файлов. Чтобы определить количество файлов, нажмите кнопку Настройки… и введите число или диапазон значений.
        Замечание. Если задано число, например 5, а в горячей папке осталось 4 файла, то эти файлы импортироваться не будут. Если же задан интервал 1-5, то оставшиеся 4 файла будут импортированы.
      • Один файл – будет добавлен один файл.
  3. На следующем шаге мастера вы можете задать опции для определения принципа добавления изображений в документы и опции обработки изображений. Подробнее см. Параметры обработки изображений.

  4. На четвертом шаге мастер создания профиля предложит вам задать опции очищения горячей папки после импорта: успешно импортированные изображения можно удалять или перемещать в указанную папку. Изображения, в процессе обработки которых произошла ошибка, можно оставлять в Горячей папке или также перемещать в указанную папку. Если вы хотите перемещать изображения, задайте папки для перемещения.

  5. На последнем шаге мастера вы можете изменить имя, присвоенное профилю импорта по умолчанию, и ввести комментарий.

Название созданного профиля импорта изображений появится в выпадающем меню кнопки импорта. Для того, чтобы произвести импорт изображений с использованием данного профиля, достаточно нажать на стрелку справа от кнопки импорта и выбрать пункт с названием профиля.

Редактировать и создавать новые профили импорта можно также из диалога Выбор профиля импорта, который открывается при выборе пункта Импортировать изображения… выпадающего меню кнопки импорта.

Добавление изображений страниц


Параметры обработки изображений

При добавлении изображений в пакет производится их предварительная обработка: деление изображений по документам, очищение, поворот изображений и т.д.

Параметры обработки изображений задаются в диалоге (на закладке) Обработка изображений. Их можно задать:

  1. Для проекта. Тогда они будут использоваться по умолчанию при ручном добавлении изображений в пакеты проекта. Для этого в главном окне программы выберите пункт меню Проект>Свойства проекта… и в открывшемся диалоге перейдите на закладку Обработка изображений.
  2. Для профиля импорта. Эти параметры будут использоваться при добавлении изображений с помощью данного профиля импорта. Для этого при создании профиля импорта задайте параметры обработки изображений на шаге Обработка изображений.
  3. Для изображений, добавляемых вручную. Для этого при добавлении изображений из файла нажмите на кнопку Параметры обработки изображений… в диалоге Загрузка изображений.

Замечание. При сканировании вручную предварительная обработка изображений не осуществляется. Только при сканировании с использованием профиля импорта.

Пользователь может определить следующие параметры предварительной обработки изображений:

  • Опции для добавления изображений в документы:
    • Автоматически при наложении шаблона – отметьте эту опцию, если вы хотите, чтобы изображения группировались в документы при наложении шаблона (при распознавании). В этом случае при добавлении изображений документы формироваться не будут, они соберутся по результатам анализа страниц при распознавании согласно структуре, описанной для данного шаблона. Подробнее см. Создание шаблонов для многостраничных документов и Сборка страниц в документы.
    • Для каждого файла – новый документ будет создан для каждого файла (файл изображения может быть многостраничным).
    • Для изображений, разделенных – страницы будут добавляться в один документ, пока не встретится страница-разделитель, тогда будет создан следующий документ и страницы будут добавляться в него и т.д.
      В качестве разделителя могут быть использованы пустые страницы, в этом случае выберите пустыми страницами в выпадающем списке.
      Также можно использовать в качестве разделителя страницы со штрих-кодами, в этом случае выберите страницами со штрих-кодом. Для штрих-кода можно задать его тип и/или значение, для этого нужно нажать кнопку Настройки…. Если тип или значение не заданы, то разделителем будет считаться любая страница, на которой есть штрих-код. Если заданы, то только страницы со штрих-кодами, удовлетворяющими заданным параметрам.
      Если страницы-разделители не нужно добавлять в пакет, то отметьте опцию Удалять страницу-разделитель. Если она не будет отмечена, страницы-разделители добавляются в пакет и становятся первыми страницами каждого документа.

    • Замечание. Страницы-разделители для определения разбивки по документам использовать не обязательно. Без них нельзя обойтись только в одном случае: когда по виду страницы невозможно определить, относится она к предыдущему документу, или к следующему. Например, когда документ состоит из произвольного количества одинаковых страниц, а в пакете может присутствовать более одного такого документа.

  • Опции обработки поступающих изображений:
    • Очищать изображения – изображения будут очищаться от мусора;
    • Конвертировать цветные и серые изображения в черно-белые – изображения будут конвертированы в черно-белые;
    • Разворачивать изображения на – будет осуществляться разворот изображений в указанном направлении.
  • Опции выравнивания изображений. Эти опции по умолчанию включены и при добавлении изображений производится их выравнивание по черным квадратам и по вертикальным и горизонтальным разделителям. Опции выравнивания не рекомендуется отключать, кроме тех случаев, когда выравнивание производится неправильно, например, программа может интерпретировать сторону неровно поставленного штампа или наклонную линию графика как разделитель и выровнять изображение по нему. В этом случае выравнивание по разделителям можно отключить.
    • Выравнивать изображения по разделителям – при включенной опции изображения выравниваются по сепараторам;
    • Выравнивать изображение по чёрным квадратам – при включенной опции изображения выравниваются по черным квадратам.


Настройки экспорта по умолчанию

Настройки экспорта по умолчанию используются при экспорте в файл или базу данных без использования настроек шаблона, а также в шаблоне, для которого еще не задан экспорт.

Настройки экспорта задаются для каждого шаблона документов, но иногда может понадобиться произвести экспорт в другое место хранения данных, например, для тестового экспорта. В этом случае оператор может воспользоваться меню кнопки экспорта и произвести экспорт в файл или базу данных с настройками, отличными от настроек шаблона. См. Экспорт распознанных данных. Первый раз при экспорте используются настройки по умолчанию, потом, если настройки были изменены, сохраняются настройки экспорта, использованные последний раз.

Настройки по умолчанию для экспорта в файл или базу данных можно задать на закладке Экспорт диалога Свойства проекта (пункт меню главного окна Проект > Свойства проекта…). На этой закладке отображаются текущие настройки экспорта по умолчанию. Вы можете задать настройки экспорта в файл либо в базу данных. Для изменения настроек экспорта по умолчанию нажмите на кнопку Изменить настройки… и задайте настройки экспорта аналогично настройкам экспорта в шаблоне (см. Настройка экспорта данных).


Пакеты документов

Обрабатываемые документы добавляются в пакеты. Принцип распределения документов по пакетам произволен и выбирается пользователем: можно обрабатывать все документы в рамках одного пакета, или объединять в пакеты документы, введенные одной и той же датой или из отсканированной за раз пачки.

Для добавления пакетов в проект выберите пункт контекстного меню Новый пакет, появляющегося при нажатии правой кнопки мыши в главном окне со списком пакетов.

Если в проекте нет ни одного пакета, то при попытке добавления изображений пакет будет создан программой автоматически.

Добавление изображений страниц документов производится оператором в процессе потокового ввода. Подробнее см. Добавление изображений страниц.

Для того чтобы увидеть документы, добавленные в пакет, нужно открыть его двойным щелчком мыши. Вернуться к списку пакетов из окна работы с документами, можно, выбрав пункт главного меню программы Проект>Рабочие пакеты.

Рабочие и тестовые пакеты

Для обработки документов используются рабочие пакеты. В режиме оператора доступны только они. Тестовые пакеты используются администратором в процессе отладки шаблона. Отличие этих пакетов в том, что для обработки документов из тестовых пакетов используется локальная версия шаблона, а для обработки документов из рабочих пакетов – опубликованная версия. Cм. также Режимы работы администратора и оператора и Редактирование и публикация шаблона.

Переход к списку пакетов документов осуществляется из меню Проект главного окна программы. Рабочие пакеты: Рабочие пакеты, тестовые пакеты: Тестовые пакеты.


Индексные поля

Для удобства поиска документов при их обработке, можно проиндексировать документы по значениям любых полей шаблона. Тогда в списке документов в главном окне программы кроме основной информации можно будет вывести значения индексного поля для каждого документа, производить сортировку документов по этим значениям и легко находить нужные документы.

Для того чтобы производить индексирование по значению поля, нужно отметить свойство Индексное поле для этого поля (редактор шаблонов документов, диалог свойств поля, закладка Общие).

Чтобы отобразить значения индексного поля в списке документов:

  • В главном окне программы откройте пакет документов и перейдите в режим детализованного списка документов (кнопка [image] панели инструментов).
  • Нажмите правую кнопку мыши в области шапки таблицы (названий колонок) и выберите в выпадающем списке пункт Настроить…
  • В диалоге Настройка таблицы документов нажмите кнопку Новая…
  • В диалоге Правка столбца нажмите Выбрать… справа от Индексное поле. В открывшемся диалоге можно выбрать одно из полей, у которых отмечена опция Индексное поле. Можете также ввести любое название столбца и задать способ выравнивания.
  • В таблице появится еще одна колонка со значениями индексного поля. Щелкнув левой кнопкой мыши на ее названии, вы можете произвести сортировку документов по значению индексного поля.


Работа оператора с настроенным проектом

Для того чтобы оператор мог приступить к обработке документов, проект должен быть настроен администратором. Процесс обработки документов можно настроить таким образом, чтобы операции сканирования или импорта изображений, распознавания и экспорта данных выполнялись с минимальным участием человека. В этом случае основным этапом работы оператора будет проверка и исправление распознанных данных – верификация.

Работа оператора не зависит от вида документов.

Процесс обработки документов состоит из четырех этапов и каждому этапу соответствует кнопка на панели инструментов.

1. Добавление изображений

Стрелка справа позволяет выбрать одну из опций импорта изображений: Загрузить изображения…, Сканировать изображения… или произвести импорт, выбрав один из настроенных профилей. Надпись на кнопке изменяется и соответствует выполняемому действию.

2. Распознавание

Запускает процесс распознавания документов. С помощью стрелки справа вы также сможете произвести анализ документов или наложение одного из шаблонов.

3. Верификация

Запускает процесс верификации. С помощью стрелки можно также запустить процесс верификации ошибок правил.

4. Экспорт

Запускает экспорт данных согласно определенным в шаблоне настройкам. С помощью стрелки можно осуществить экспорт в файл или базу данных.


Добавление изображений страниц

Обработка документов начинается с добавления в проект изображений страниц документов – импорта изображений. Для начала работы выберите или создайте новый рабочий пакет, в который будут добавлены изображения (для создания щелкните правой кнопкой мыши в главном окне программы и выберите Новый пакет). Двойным щелчком мыши откройте нужный пакет, либо просто выделите его в списке.

Замечание. При попытке добавить изображения в проект, где нет ни одного пакета, пакет документов будет создан автоматически.

Добавить изображения в пакет можно несколькими способами:

  1. Загрузить ранее сохраненные изображения из файлов;
  2. Отсканировать изображения;
  3. Произвести импорт изображений, используя один из ранее настроенных администратором профилей импорта изображений (cм. Профили импорта изображений.)

Чтобы выбрать способ добавления изображений, надо нажать на стрелку справа от кнопки импорта и выбрать один из пунктов меню.

Добавление изображений из файла

Для того чтобы загрузить изображения из файла, выберите пункт меню Загрузить изображения… или нажмите комбинацию клавиш Ctrl+O. В открывшемся диалоге выберите нужные файлы с изображениями и задайте опции импорта изображений:

  • Создавать новый документ – для добавленных изображений будут созданы новые документы.
  • Добавить в текущий документ – изображения будут добавлены в текущий, выделенный документ.
  • Вы также можете задать параметры предварительной обработки изображений. Для этого нажмите на кнопку Параметры обработки изображений… и задайте нужные параметры в открывшемся диалоге. Подробнее см. Параметры обработки изображений.

Сканирование изображений

Для добавления изображений со сканера, выберите пункт меню Сканировать изображения…. Выберите сканер, установите параметры сканирования и отсканируйте изображения.

Добавление изображений с использованием профилей импорта

Если профили импорта были настроены администратором, то их названия отобразятся в меню кнопки импорта. Для начала импорта изображений достаточно выбрать пункт с одним из названий профилей импорта.

При выборе Импортировать изображения… откроется диалог Выбор профиля импорта, в котором нужно выбрать профиль импорта из списка и нажать кнопку Импортировать для начала импорта изображений. Если вы работаете в режиме администратора, то из этого диалога можно также создать новый профиль импорта или отредактировать существующие профили.

Фоновый импорт изображений

Импорт изображений может производиться в фоновом режиме, если настроен соответствующий профиль импорта. Изображения из горячей папки автоматически импортируются в систему, проверка наличия новых изображений производится через указанный в настройках интервал времени.

Автоматическая проверка горячей папки запускается при команде пользователя импортировать изображения, используя профиль, в котором отмечена опция Проверять Горячую папку каждые. Проверка горячей папки прекращается при закрытии проекта, либо при снятии отметки с данной опции в свойствах профиля. См. Профили импорта изображений.

Замечание. Для добавления изображений из горячей папки у пользователя должны быть права на чтение и запись в данную папку.


Установка параметров сканирования

Качество распознавания во многом зависит от того, насколько хорошее изображение получено при сканировании. Качество изображения регулируется установкой основных параметров сканирования: типа изображения, разрешения и яркости.

При сканировании через программу ABBYY FlexiCapture возможно два варианта взаимодействия программы со сканерами через TWAIN или ISIS драйвера:

  • через интерфейс ABBYY FlexiCapture:
    в этом случае для настройки опций сканирования используется диалог программы ABBYY FlexiCapture Настройки сканера; параметры сканирования можно установить при создании профиля импорта с источником импорта Сканер.
  • через интерфейс TWAIN или ISIS-драйвера сканера:
    для настройки опций сканирования используется диалог соответствующего драйвера сканера. Этот диалог открывается автоматически при выборе пункта Сканировать изображения… выпадающего меню кнопки импорта.

Основные параметры сканирования

  • Тип изображения – сканирование в сером (256 градаций) является оптимальным режимом для системы распознавания. В случае сканирования в сером режиме осуществляется автоматический подбор яркости.

    Черно-белый тип изображения обеспечивает более высокую скорость сканирования, но при этом теряется часть информации о буквах, что может привести к ухудшению качества распознавания на документах среднего и низкого качества печати.
    Если вы хотите, чтобы содержащиеся в документе цветные элементы (картинки, цветные буквы и цветной фон) были переданы в электронный документ с сохранением цвета, необходимо выбрать цветной тип изображения. В других случаях используйте серый тип изображения.

  • Яркость и контрастность – нужно подобрать так, чтобы, во-первых, были сохранены реперные блоки, и, во-вторых, изображения распознаваемых блоков получились как можно более четкими и разборчивыми.
    В большинстве случаев подходит среднее значение яркости – 50%.
    На некоторых документах при сканировании в черно-белом режиме может понадобиться дополнительная настройка яркости.
  • Разрешение – рекомендованные разрешения для обработки форм, заполненных от руки, – 300 dpi при сканировании в черно-белом режиме, и 200 dpi при сканировании в тонах серого. Разрешение изображений при сканировании обрабатываемых форм должно совпадать с разрешением изображения шаблона.

Замечания.

  1. Сканирование с разрешением 400-600 dpi вместо 300 dpi или сканирование в сером или в цвете, а не в черно-белом, может занять существенно больше времени. На некоторых моделях сканеров сканирование с разрешением 600 dpi занимает в 4 раза больше времени, чем сканирование с разрешением 300 dpi. Не рекомендуется сканировать с разрешением менее 200 dpi.
  2. При использования диалога драйвера сканера, опции для установки параметров сканирования могут называться по-разному, в зависимости от модели сканера. Например, яркость может называться brightness, threshold, изображаться "солнышком" или черно-белым кружком. Смысл опций описан в документации, прилагаемой к вашему сканеру.
Советы по режиму сканирования
  1. Сканирование цветных фоновых форм на нецветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо оборудовать сканер соответствующей лампой фильтрации цвета: для «розовых» форм – красной лампой (Red-Lamp), для «зеленых» форм – зеленой лампой (Green-Lamp).
  2. Сканирование цветных фоновых форм на цветном сканере. Для того, чтобы фон «исчезал» при сканировании, необходимо в настройках параметров сканирования задать режим фильтрации соответствующего цвета.
  3. Сканирование цветных фоновых форм светлых тонов. Если вы обрабатываете цветные формы светлых оттенков, то за счет слабой насыщенности цвета фон может исчезать при сканировании белой лампой и без программной фильтрации цвета. Способ сканирования форм выбирается, как правило, на этапе разработки формы.
Советы по подбору яркости
  1. Отсканированное изображение должно быть читаемым (для того, чтобы просмотреть отсканированное изображение, откройте его в окне документа).
  2. Если в полученном изображении буквы "разорванные", светлые или тонкие:
    • Уменьшите яркость, увеличьте контрастность (сделайте изображение темнее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).
  3. Если в полученном изображении грязный фон; искаженные, залитые или склеенные символы; темные, толстые буквы:
    • Увеличьте яркость (сделайте изображение светлее) или
    • Попробуйте отсканировать в сером (в этом случае осуществляется автоподбор яркости).


Распознавание

Распознавание производится при нажатии кнопки Распознать. При этом программа производит наложение шаблона, выбирая его по реперам и идентификаторам, и производит распознавание данных в областях документов, которые совпадают с областями полей выбранного шаблона.

Распознавание изображений может производиться автоматически, сразу после добавления изображений в пакет. Для этого нужно отметить опцию Автоматически распознавать добавленные изображения (меню Сервис главного окна, пункт Опции…, закладка Обработка документов).

Процентное соотношение уверенно распознанных символов к общему количеству отображается в колонке Уверенность распознавания.

После распознавания оператор может перейти к верификации документов.

Еще до начала распознавания можно, при необходимости, выполнить Предварительный анализ изображений и наложение шаблона.


Предварительный анализ изображений и наложение шаблона

Еще до начала распознавания страницы можно проанализировать, то есть определить, какой шаблон может быть наложен на страницу. Для этого нужно выбрать пункт главного меню Импорт и распознавание > Проанализировать или нажать на стрелку справа от кнопки Распознать и выбрать Проанализировать. Если шаблон может быть наложен, то у страницы и документа, в который входит страница, появляются соответствующие названия. Если ни один из шаблонов проекта не может быть наложен на изображение, то страница остается необработанной.

Программа также позволяет наложить на страницу или на весь документ определенный шаблон. В большинстве случаев правильно созданный в программе шаблон накладывается на страницы автоматически, однако в некоторых случаях может возникнуть необходимость наложить шаблон вручную.

Чтобы произвести наложение шаблона документа:

  1. Выделите документ;
  2. Выберите пункт Наложить шаблон… локального меню документа или пункт главного меню Импорт и распознавание>Наложить шаблон… или нажмите на стрелку справа от кнопки Распознать и выберите Наложить шаблон…;
  3. В открывшемся диалоге Выберите шаблон документа выберите один из шаблонов и нажмите OK.

Если наложение выбранного шаблона прошло успешно, документу и входящим в него страницам будут присвоены названия соответствующего шаблона и его разделов.

Чтобы произвести наложение шаблона на одну из страниц:

  1. Выделите страницу;
  2. Выберите пункт Наложить шаблон… локального меню страницы или пункт главного меню Импорт и распознавание>Наложить шаблон…;
  3. В открывшемся диалоге Выбор шаблона для наложения выберите один из шаблонов и нажмите OK.

Если наложение шаблона прошло успешно, то выбранной странице будет присвоено название соответствующего раздела шаблона.


Верификация распознанных данных

Верификация, или проверка распознанных данных – самая трудоемкая часть работы оператора. Поэтому процесс верификации в ABBYY FlexiCapture 8.0 Professional организован таким образом, чтобы быть максимально удобным для оператора, и чтобы количество ошибок сводилось к минимуму.

Символы, насчет правильности распознавания которых нет абсолютной уверенности, помечаются программой как неуверенно распознанные. Процесс верификации предназначен для того, чтобы проверить такие символы, удостовериться, что они распознаны правильно или исправить их.

Проверка правил производится автоматически, если значения полей удовлетворяют правилам, то эти поля могут быть помечены как уверенно распознанные и не участвовать в процессе верификации. Если же значения полей не удовлетворяют правилам, то такие поля подаются на проверку оператору.

Для многостраничных документов сначала следует проверить сборку страниц в документы.

Затем запускается процесс верификации при нажатии кнопки Начать верификацию… или при выборе пункта меню Верификация>Начать верификацию…. Процесс верификации производится в 2 этапа – групповая верификация и контекстная. Если в шаблоне нет полей включенных в групповую или контекстную верификацию (см. Свойства верификации поля), то соответствующий этап верификации будет пропущен.

После прохождения этапов групповой и контекстной верификации, производится проверка в окне документа. Те символы, которые не были подтверждены на более ранних этапах, остаются подсвеченными красным цветом.

Переход к предыдущей и следующей ошибке осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил и т.д.

Сборка страниц в документы
Групповая верификация
Контекстная верификация
Верификация в окне документа
Верификация правил


Сборка страниц в документы

Сборка страниц в документы производится автоматически. Для этого при создании шаблона для обработки многостраничных документов должен быть описан принцип сборки, может быть также задана проверка по ключевым полям.

Задача оператора состоит в том, чтобы выявить и исправить возможные ошибки сборки документов.

Ошибки сборки удобнее всего исправлять в режиме просмотра эскизов страниц, т.к. пользователь хорошо видит изображения страниц и их принадлежность к документам. В этот режим можно переключиться с помощью кнопки [image].

Замечание. Вы можете изменять масштаб эскизов страниц для просмотра деталей, для этого нажмите Ctrl и вращайте колесо мыши.

При создании шаблона документа задается правило сборки документа: порядок следования и количество повторений разделов документа. Может быть также задана проверка сборки по значениям ключевых полей: в этом случае значения ключевых полей должны совпадать на всех страницах документа.

Замечание. Порядок следования разделов не проверяется, если при создании шаблона документа в свойствах шаблона на закладке Сборка документов отмечена опция Не проверять порядок разделов в документе. В этом случае проверяется только наличие разделов документа, но не их порядок.

Документы с ошибками сборки помечаются значком [image]. Описание ошибки выводится текстом красного цвета под названием шаблона документа.

Как исправить ошибки сборки

  1. Неправильный порядок страниц в документе

    Возможно, страниц не хватает или присутствуют лишние страницы, либо страницы документа следуют не по порядку. Чтобы получить подсказку, наведите курсор мыши на страницу, помеченную красным крестиком:

    Для исправления таких ошибок можно переместить страницу с помощью мыши, как в пределах одного документа, так и из одного документа в другой.

    Соединить страницы нескольких документов в один документ можно следующим образом:

    • Выделите документы для объединения (несколько документов можно выделить удерживая нажатой клавишу ctrl);
    • Нажмите на правую кнопку мыши и выберите пункт локального меню Объединить.

    Чтобы разделить страницы документа и поместить каждую из них в отдельный документ:

    • Выделите документ для разделения страниц;
    • Выберите пункт локального меню Разделить.

  2. Если в шаблоне задано, что для правильной сборки страниц должна производиться проверка по ключевым полям, то значения ключевых полей будут отображены под изображением каждой страницы:

    • серым цветом - в случае совпадения;
    • красным цветом - в случае несовпадения.

    Ключевые поля могут не совпадать из-за того, что они были неправильно распознаны или заполнены. Проверьте значения ключевых полей. Если же значения ключевых полей все равно не совпадают, то, вероятно, такие страницы не относятся к одному документу. Если был перепутан порядок страниц, то найдите страницы с одинаковыми ключевыми полями и соберите их в документы, с помощью приемов, описанных в пункте 1.


Групповая верификация

Групповая верификация – это группировка изображений символов, распознанных с одинаковым значением, и их вывод на экран верификатора с тем, чтобы он мог легко заметить и исправить выбивающиеся из общей массы символы.

Показать окно групповой верификации

При групповой верификации оператор может просмотреть контекст проверяемого символа, выбрав пункт Показать изображение символа в локальном меню выделенного символа или нажав клавишу F2.

Можно также включить режим, при котором будет отображаться поле, содержащее символ, при наведении курсора мыши на проверяемый символ. Для этого нужно выбрать пункт меню Вид>Изображение поля>Показывать изображение поля в окне верификатора, либо нажать комбинацию клавиш Ctrl+I.

Неправильно распознанные символы можно исправить следующим образом: выделите символ, который не соответствует символу группы, и введите его правильное значение. Это значение отобразится зеленым цветом в левом верхнем углу изображения символа.

Если вы сомневаетесь в значении символа даже после просмотра контекста, нажмите на символ левой кнопкой мыши: символ будет помечен красным знаком вопроса.

Статус символа можно изменять также с помощью кнопки на панели инструментов Изменить статус.

Правильно распознанные символы можно подтвердить с помощью локального меню, выбрав пункт Подтвердить. Можно также подтвердить сразу все символы, нажав кнопку Подтвердить все на панели инструментов.

Замечание. В процессе создания шаблона опции верификации задаются при определении свойств поля. На групповую верификацию подаются символы из тех полей, для которых отмечена опция Включить в групповую верификацию на закладке Верификация в диалоге задания свойств поля. См. Свойства верификации поля. На групповую верификацию целесообразно подавать метки и поля, которые заполняются только цифрами. Буквы лучше проверять в контексте поля.


Контекстная верификация

Контекстная верификация – это режим верификации, предназначенный для эффективного исправления ошибок «хорошо определенных» полей, то есть полей, область значений которых известна или легко идентифицируется. Таким полем, например, является название страны или города: нам известно, какие значения может принимать данное поле.

Для принятия решения о том, как нужно исправить поле, пользователю достаточно видеть только это поле и знать его область значений. Исправляются не только ошибки заполнения, но и ошибки формата поля.

Показать окно контекстной верификации

Для исправления неправильно распознанных символов можно использовать стандартные режимы текстовых редакторов: режим вставки и замены символов, переключаться между ними можно с помощью кнопки Insert на клавиатуре.

Пользователь последовательно просматривает результат распознавания каждого поля, при необходимости исправляет его и подтверждает с помощью кнопки Подтвердить поле.

Значения полей нужно исправить, а если исправить не удается, то пропустить поле или отложить проверку значения поля с помощью кнопки Отложить поле, чтобы внести исправления позже.

Замечание. На контекстную верификацию подаются те поля, для которых отмечена опция Включить в контекстную верификацию на закладке Верификация в диалоге задания свойств поля. См. Свойства верификации поля. На контекстную верификацию целесообразно подавать однострочные поля, область значений которых хорошо известна.


Верификация в окне документа

Окно документа также позволяет проверить правильность распознавания и исправить неверно распознанные символы. Окно документа открывается при двойном щелчке на названии страницы и состоит из области данных, изображения страницы и области ошибок правил (если такие ошибки есть). Вид окна можно настроить с помощью кнопки Вид окна. В окне документа оператор видит уже не группы символов или отдельные поля, а весь документ целиком.

Показать окно документа

В области данных неуверенно распознанные и сомнительные символы выделяются цветом, поля с неверными типами данных и невыполненными правилами подсвечиваются.

Поле с неуверенно распознанными символами можно подтвердить, установив курсор в данное поле и нажав Enter.

Поля для просмотра и редактирования распознанных данных могут располагаться не только в порядке следования, но и в любом другом порядке, удобном для пользователя. Их расположение можно изменить в редакторе шаблона документа, см. Настройка отображения данных в окне документа.

Переход к следующей ошибке в окне документа осуществляется с помощью кнопок [image] и [image] панели инструментов главного окна. Навигация производится по всем имеющимся ошибкам, включая ошибки сборки, неуверенно распознанные символы, ошибки правил, несовпадение ключевых полей и т.д.


Верификация правил

Невыполненные правила помечаются флажком: желтым [image] в случае предупреждения, красным [image] в случае ошибки.

Ошибки правил отображаются в отдельном окне редактора документов, а документы с невыполненными правилами отмечены красными флажками.

При наличии невыполненных правил оператору надо проверить, как распознаны данные, если это ошибка распознавания – исправить ее, а если это ошибка заполнения, которую невозможно исправить, не экспортировать документ. Документы с ошибками можно проверить позже, сверяясь с бумажными документами или другими имеющимися источниками.

Для запуска повторной проверки ошибок правил нажмите на стрелку справа от кнопки Начать верификацию… и выберите пункт меню Перепроверить правила. Если правила выполняются после исправления значений полей, то флажки будут сняты.


Экспорт распознанных данных

После проверки распознанных данных оператор осуществляет экспорт пакета, нажав кнопку Экспортировать. Экспорт производится согласно настройкам шаблона документов.

Вы также можете произвести экспорт в файл или базу данных, не используя настройки экспорта, заданные в шаблоне.

Замечание. При экспорте в файл или базу данных можно использовать настройки по умолчанию, либо изменять их по своему усмотрению. Настройки экспорта по умолчанию задаются в диалоге свойств проекта (пункт меню главного окна Проект>Свойства проекта…), на закладке Экспорт. См. Настройки экспорта по умолчанию.

Экспорт в файл

  1. Для экспорта данных в файл нажмите на стрелку справа от кнопки экспорта и выберите пункт меню Экспортировать в файлы…
  2. Выберите место хранения и префикс названия файла (полное название будет начинаться с этого префикса, к которому прибавится название шаблона документа, название пакета и номер документа, если вы будете сохранять каждый документ в отдельный файл (см. п.3)
  3. Отметьте опции:
    • Файл для каждого документа – для того, чтобы данные каждого документа были сохранены в одном файле;
    • Разрешить перезапись файлов – если вы хотите перезаписывать файл экспорта;
    • Сохранять изображения документов – для сохранения изображений документов.
  4. Если вы хотите изменить другие настройки экспорта, нажмите кнопку Настройки… Подробнее о настройке экспорта см. Настройка экспорта данных.
  5. Если вы хотите сохранить измененные настройки экспорта, в диалоге Настройки экспорта в файлы нажмите на кнопку Сохранить в шаблоне... и выберите шаблон документов, в котором вы хотите сохранить текущие настройки.

Экспорт в базу данных

  1. Для экспорта данных в базу данных нажмите на стрелку справа от кнопки экспорта и выберите пункт меню Экспортировать в базу данных…
  2. Установите соединение c базой данных. Подробнее см. Экспорт в базу данных.
  3. Перейдите на закладку Изображения и задайте настройки сохранения изображений.

Замечания.

  1. Документы, данные из которых были успешно экспортированы, могут автоматически удаляться из пакета. Это происходит в том случае, если в диалоге Опции на закладке Обработка документов отмечена опция Удалять обработанные документы после экспорта.
  2. При попытке экспортировать документы с ошибками правил, будет выдаваться сообщение об этом. Наличие предупреждений правил не помешает экспорту.


Фоновый режим

Импорт, распознавание и экспорт документов, не требующие контроля оператора, могут производиться в фоновом режиме.

Для того чтобы перевести задачу в фоновый режим, надо в открывшемся диалоге Добавление изображений… (Распознавание… или Экспорт…) нажать кнопку Фоновый режим.

Автоматически в фоновом режиме выполняются задачи:

  • Загрузки документов из горячей папки при использовании соответствующего профиля импорта.
  • Распознавания документов, если отмечена опция Автоматически распознавать добавленные изображения ( Сервис > Опции…, закладка Обработка документов).

При переходе в фоновый режим на панели задач появляется иконка [image], открывающая диалог Фоновые задачи, в котором отображается список задач.

  • Задачи выполняются в порядке их поступления или же в соответствии с расставленными пользователем приоритетами (кнопка Приоритет…).
  • Для контроля выполнения заданий и отслеживания ошибок ведется журнал, параметры которого можно настроить (Сервис > Опции…, закладка Выполнение задачи). Для просмотра надо нажать кнопку Журнал.
  • Прервать выполнение задачи можно кнопкой Снять задачу.

Программа также может информировать пользователя о ходе выполнения фоновых процессов при помощи всплывающей подсказки (в правом нижнем углу) - при старте, ошибке и завершении задач. См. Дополнительные настройки.


Приложения

Руководство по созданию машиночитаемых форм
Горячие клавиши
Использование скриптов во FlexiCapture 8.0
Различия в правилах FormReader 6.5 и FlexiCapture 8.0 Professional
Поддерживаемые языки распознавания
Шрифты для корректного отображения символов
Поддерживаемые типы текста
Поддерживаемые типы штрих-кодов
Поддерживаемые графические форматы
Форматы файлов экспорта
Алфавит, используемый в регулярных выражениях
Патенты
Технологии других компаний


Создание машиночитаемых форм

Анкеты, карточки социального страхования, опросные листы, бюллетени, гарантийные талоны и т.д. - все это формы, используемые для сбора разного рода информации.

Что отличает формы от обычных документов?

  1. В отличие от обычных документов форма всегда имеет фиксированный набор полей.
  2. В каждом поле формы может находиться информация строго определенного содержания: например, в поле "Фамилия" может находиться только фамилия (если, конечно, заполнивший форму не вписал туда по ошибке адрес), в поле Дата - дата и т.д.

Использование форм обычно подразумевает получение информации от большого числа респондентов с последующей компьютерной обработкой полученных данных.

Ручной ввод информации в компьютер очень трудоемок. Более того, такая форма работы ведет к большому количеству ошибок (опечаток), на исправление которых уходит много времени. Поэтому эффективнее автоматизировать процесс ввода форм.

Процесс автоматизированного ввода форм состоит из следующих стадий:

  1. Настройка программы автоматизированного ввода на обработку формы данного образца (описание формы, выделение на образце формы данных для распознавания).
  2. Создание изображения формы (сканирование).
  3. Обработка изображений программой автоматизированного ввода (распознавание и проверка данных).
  4. Экспорт данных во внешнюю информационную систему.

Наиболее просто и эффективно производится автоматическая обработка форм, удовлетворяющих специальным требованиям. Им и будет посвящена эта глава.

Машиночитаемая форма
Элементы машиночитаемой формы
Заполнение формы
Виды машиночитаемых форм
Выбор вида формы
Требования к машиночитаемым формам


Машиночитаемая форма

При обработке форм программа автоматизированного ввода сталкивается с рядом задач, от решения которых зависит качество распознавания данных из формы.

Выделим две из них:

  1. Определение положения элементов на изображении формы.
  2. Отделение внесенной в форму информации (данных) от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Чтобы облегчить программе решение этих задач, создаются специальные машиночитаемые формы.

Для решения первой задачи машиночитаемым формам выдвигается требование точного соответствия формы образцу. Это значит, что у всех форм одного образца расположение элементов формы должно быть одинаковым (совпадать на просвет).

Для решения второй задачи к машиночитаемым формам предъявляется требование специального дизайна формы: он должен позволять корректно отделить собственно данные от элементов формы: разметки текста, границ полей, фона, пояснительных надписей и др.


Элементы машиночитаемой формы

Рассмотрим подробнее элементы машиночитаемой формы:

Текст
Поле для ввода
Поле метки
Группа меток
Репер
Разделитель
Идентификатор
Картинка
Таблица
Группа элементов


Текст

Текст - это элемент машиночитаемой формы, представляющий собой описательный текст (название формы, название полей, пояснения к полям и т.д.)


Поле для ввода

Поле для ввода - это элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы. Для удобства ввода символов в таком поле может присутствовать разметка. Поле для ввода обычно сопровождается описательным текстом, поясняющим смысл вводимого текста.

Показать поле для ввода

Существует несколько типов разметки текста:

Текст на линии | Тип разметки текста, при котором ограничителем текста является линия снизу.
Буквы в рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки не изолированы друг от друга.
Буквы в изолированных рамках | Тип разметки текста, при которой ограничителем каждого символа текста является рамка; рамки изолированы друг от друга.
Буквы в гребенке | Тип разметки текста, при которой ограничителем текста является гребенка.
Текст в рамке | Тип разметки текста, при котором ограничителем текста является рамка.
Текст в рамке с гребенкой | Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки.


Поле метки

Поле метки - это элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении формы вносится метка (галочка, крест, сплошная закраска и т.д.).

Поле метки обычно сопровождается описательным текстом, поясняющим смысл метки.

Показать поле метки

Поле метки может иметь ограничители следующих типов:

Квадрат
Круг
Подчеркивание

Возможны и другие типы ограничителей поля метки: многоугольник, овал и т.д.


Группа меток

Группа меток - это элемент машиночитаемой формы, объединяющий несколько находящихся вблизи друг от друга полей меток, из которых при заполнении формы будет заполнено только одно. Группа меток обычно сопровождается описательным текстом, поясняющим смысл группы.

Показать группу меток


Репер

Репер - это элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.

Первое, что определяется при распознавании данных из формы, это принадлежность формы к тому или другому образцу. Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование точного соответствия формы образцу. Количество и расположение реперов является основной характеристикой принадлежности формы к тому или другому образцу. Настроенная на работу с формами данного образца программа автоматизированного ввода ориентирует форму, т.е. пытается расположить её так, чтобы реперы совпали с реперами образца. Если реперы совпали, то программа может определить, к какому образцу относится данная форма и где находятся данные для распознавания.

Стандартные реперы:

Черный квадрат
Уголок
Крест
Черный прямоугольник

Присутствие стандартных реперов на машиночитаемой форме крайне желательно, хотя в некоторых случаях в качестве репера может использоваться разделитель, описательный текст или штрих-код. Эти варианты реперов считаются приемлемыми, но по возможности их следует избегать, т.к. они могут привести к ухудшению распознавания формы.


Разделитель

Разделитель - это элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.

Разделитель используется для визуального разделения формы на несколько смысловых частей.


Идентификатор

Идентификатор - это элемент машиночитаемой формы, однозначно характеризующий форму данного образца.
Если при распознавании невозможно однозначно определить по реперам принадлежность формы к образцу (т.е. реперы у нескольких форм различных образцов совпадают), то для точного определения используется идентификатор.
Рекомендуется в качестве идентификатора использовать штрих-код.

Штрих-код - это набор штриховых знаков, кодирующих информацию посредством чередующихся полос черного и белого цвета различной ширины.

Показать штрих-код

Возможно использование и других элементов в качестве идентификаторов.


Картинка

Картинка - это элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в графическом формате.

Любое графическое изображение, место для печати или подписи - все это картинки.


Таблица

Таблица содержит столбцы с однотипными элементами.

Столбцы таблицы могут содержать элементы следующих типов:

  • текст;
  • поле ввода;
  • дата;
  • число;
  • метка.

Таблица может содержать строку с заголовками столбцов.


Группа элементов

Группа элементов - элемент машиночитаемой формы, предназначенный для объединения в группу нескольких логически связанных элементов.


Заполнение формы

Форма может быть заполнена следующими способами:

  • От руки.
  • На матричном принтере.
  • На пишущей машинке.
  • Типографским способом. К данному способу относится также заполнение на принтерах (не матричных), которые обеспечивают разрешение не менее 300 точек на дюйм.
  • Заполнение представляет собой комбинацию любых способов заполнения, перечисленных в предыдущих пунктах.


Виды машиночитаемых форм

Как уже говорилось, машиночитаемые формы создаются с учетом требования автоматизированного ввода, одним из которых является требование к дизайну формы: дизайн формы должен позволять корректно отделить внесенную в форму информацию от разметки текста, границ полей, фона, пояснительных надписей и т.д.

Существует два различных подхода для реализации этого требования:

  1. Дизайн формы создается таким образом, чтобы при сканировании формы и последующей очистке изображения разметка текста, границы полей и фон исчезали.
  2. Дизайн формы создается таким образом, чтобы на изображении формы после сканирования и очистки изображения были четко выделены разметка текста и границы полей.

При использовании первого подхода на изображении формы после сканирования и очистки остаются только реперы, описательный текст и информация, которую ввели при заполнении формы. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении данные, не ограниченные никакой разметкой, что сузит задачи программы и повысит качество распознавания.

Для реализации этого подхода используются формы следующих видов: цветные фоновые формы, черно-белые формы с растровым фоном, черно-белые формы с растровыми границами, и черно-белые линейчатые формы.

При использовании второго подхода на изображении формы после сканирования остаются реперы, описательный текст, информация, которую ввели при заполнении формы, а также разметка текста и границы полей. Настроенная на работу с такими формами программа автоматизированного ввода будет искать на изображении именно ограниченные разметкой данные. Отсутствие разметки приведет к ухудшению качества распознавания.

Для реализации этого подхода используются черно-белые линейчатые формы.


Цветные фоновые формы

Цветные фоновые формы - это формы с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация. Например, Серые фоновые формы. Фон этих форм выполнен серым цветом.

Частным случаем цветных фоновых форм являются форма, на которых фоном выделены только ограничители полей для ввода информации.

Знакоместо - это прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.)

Цвет фона имеет большое значение, т.к. при сканировании фон таких форм должен "пропадать". Обычно фон имеет светлый "розово-оранжевый" или "зеленый" оттенок. Существуют цвета, рекомендованные для использования в качестве фона для фоновых форм (подробнее см. Рекомендуемые цвета для разработки цветных фоновых форм).

Показать цветную фоновую форму

В идеальном случае после сканирования и очистки изображения с цветной фоновой формы должны "пропадать" все элементы, за исключением реперов и информации, внесенной во время заполнения формы.

Пояснительная информация может оставаться на форме (если она выполнена в черном цвете); но можно добиться того, что и этот элемент будет "пропадать" при сканировании. Для этого пояснительную информацию необходимо выполнить в том же цвете, что и фон формы, но с большей насыщенностью.

Выбирая между черным цветом и цветом фона для пояснительной информации, учитывайте следующее:

  • Размер файла изображения формы с пояснительной информацией, выполненной в черном цвете (или любом другом, который останется после сканирования на форме), больше, чем размер файла изображения формы с пояснительной информацией, выполненной в цвете фона (или любом другом, который исчезнет после сканирования на форме).
  • Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов на расстояние, не меньшее 1,5-2 мм. В случае пояснительной информации, выполненной в цвете фона, можно не так пристально отслеживать расстояние между пояснительной информацией и другими элементами формы.

Форма с пояснительной информацией, выполненной в черном цвете, является более читаемой. Рекомендуется использовать именно черный цвет для пояснительной информации, если на форме отсутствуют реперы.

Совет
Для настройки шаблона форм с пояснительной информацией, выполненной в цвете фона, сканируйте форму в цвете или оттенках серого, иначе границы элементов формы и пояснительная информация не будут видны.

Рассмотрим приемы обработки фоновых форм. Технологической основой "пропадания" фона при сканировании является отсечение цвета фона с помощью цветной лампы или цветного фильтра. Цвет лампы подбирается в зависимости от того, какой оттенок имеет цвет фона "розово-оранжевый" или "зеленый".

Итак, сканирование производится:

  • На цветном сканере с программной фильтрацией красного или зеленого цвета в зависимости от оттенка фона формы.
  • На нецветном сканере с "красной лампой" (Red-Lamp) или "зеленой лампой" (Green-Lamp) соответственно (аппаратная фильтрация цвета).
  • На нецветном сканере с использованием белой лампы и красного или зеленого фильтра соответственно. Качество фильтрации, в отличие от первого и второго вариантов, хуже - может остаться фон формы или исчезнуть часть значимой информации.
  • На нецветном сканере с использованием белой лампы и без фильтра.

При сканировании с использованием белой лампы возможно отсечение различных цветов светлых оттенков без фильтрации. Исчезновение фона достигается за счет слабой насыщенности цвета фона. В этом случае подбор цвета формы и его насыщенность должны производиться опытным путем для каждого конкретного сканера.

Замечание. У многих цветных сканеров, кроме того, есть режим программной фильтрации синего цвета. Но не рекомендуется выполнять формы в "синих" оттенках, поскольку нельзя гарантировать, что все формы будут заполнены только черной, а не темно-синей ручкой. В случае сканирования форм с фильтрацией синего цвета данные, написанные синей ручкой, "исчезнут".

Подбор цвета

Если выбирать между зелеными и красными оттенками форм, то надо иметь в виду, что красно-оранжевые оттенки предпочтительнее, так как они являются максимально контрастными к синему цвету, что улучшает качество полученных при сканировании изображений и распознавания текста, написанного синей ручкой.

В разделе Рекомендуемые цвета для разработки цветных фоновых форм приводится список рекомендуемых цветов, которые "пропадают" при сканировании форм практически любым сканером. Для каждого конкретного сканера можно также получить у производителя или дилера список цветов в стандарте Pantone (или любом другом), которые можно использовать с данным сканером.


Черно-белые формы с растровым фоном

Черно-белые формы с растровым фоном - это формы с растровым фоном (растр - мелкие черные точки), на котором белыми прямоугольниками выделены знакоместа

Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
(а также поля меток и др.), в которые при заполнении формы вносится информация. Фон должен состоять из отдельных точек. Рекомендуемый размер точек растра не более 0,1 мм. Расстояние между точками растра должно быть около 1 мм. Размер точек и расстояние между точками имеют большое значение, т.к. они должны восприниматься программой распознавания как мусор и удаляться с изображения при очистке. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровым фоном.

Растровый фон не исчезает непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации изображение уже не содержит точек растра после очистки.


Черно-белые формы с растровыми границами

Черно-белые формы с растровыми границами - это формы без фона, на которых границы знакомест,

Знакоместо - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками). Размер точки растра 0,39 - 0,5 пункта. Рекомендуемый размер точки растра 0,39 пункта. Расстояние между точками растра должно быть в пять раз больше размера самой точки.

Размер точек и расстояние между точками имеют большое значение, т.к. при очистке изображения точки растра должны восприниматься программой распознавания как мусор и удаляться с изображения. Также точки растра не должны "слипаться" при сканировании.

Рассмотрим приемы обработки черно-белых форм с растровыми границами.

Растровые границы не исчезают непосредственно при сканировании. Но при очистке изображения точки растра фильтруются как мусор, и в идеальной ситуации после очистки изображение уже не содержит точек растра.


Черно-белые линейчатые формы

Черно-белые линейчатые формы - это формы без фона (как правило), на которых границы знакомест,

Знакомeсто - прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены черными линиями.

Границы полей черно-белой линейчатой формы остаются на изображении после сканирования и очистки.

Замечание. Формы этого вида особенно чувствительны к качеству заполнения. Под качеством заполнения подразумевается следующее: при заполнении формы текст помещается внутри ограничителей, и становится крайне важно, чтобы внесенный текст не заезжал на ограничители, а в идеале, и не касался их. В случае касания или "наползания" символов на ограничитель программа распознавания будет воспринимать символы и ограничитель как единое целое и качество распознавания ухудшится.


Выбор вида формы

Кроме учета особенностей дизайна и обработки форм необходимо учитывать следующие характеристики видов форм: сложность изготовления, тиражирование, стоимость печати, размер изображения, режим сканирования, время обработки изображения, качество распознавания, расположение пояснительной информации, привлекательность, качество заполнения.
Для удобства сравнения видов форм, мы собрали их характеристики в сводную таблицу:

Критерий | Цветная фоновая форма |  | Черно-белая растровая форма |  | Черно-белая линейчатая форма
 | Недостаток | Преимущество | Недостаток | Преимущество | Недостаток | Преимущество
Сложность изготовления |  | Простота изготовления в любом редакторе. | Ограниченные возможности по созданию форм в текстовых редакторах. Важность размера точек растра. |  |  | Простота изготовления в графических редакторах.
Тиражирование | Сложность тиражирования в условиях офиса. |  |  | Возможность тиражирования в условиях офиса. |  | Возможность тиражирования в условиях офиса.
Стоимость печати | Выше стоимость изготовления при типографском способе тиражирования по сравнению с черно-белой формой. |  |  | Ниже стоимость изготовления при типографском способе тиражирования по сравнению с цветной фоновой формой. |  | Ниже стоимость изготовления при типографском способе тиражирования (по сравнению с цветной фоновой формой).
Размер изображения |  | Меньший размер отсканированного изображения. | Больший размер отсканированного изображения. |  | Больший размер отсканированного изображения. |
Режим сканирования | Сканирование только в определенных режимах. |  | Меньшая свобода в подборе яркости и контрастности. |  | Меньшая свобода в подборе яркости и контрастности. |
Время обработки изображения |  | Меньше среднее время автоматической обработки. | Больше среднее время обработки за счет необходимости очистки "мусора" на изображении. |  | Большая вероятность ошибок распознавания при касании или "наползании" символов на ограничители. |
Качество распознавания |  | Очень высокое качество распознавания. |  | Высокое качество распознавания. | Сильно зависит от аккуратности заполнения. | При правильном заполнении высокое качество распознавания.
Расположение пояснительной информации |  | Более гибкое расположение пояснительной информации (вплоть до размещения непосредственно внутри полей для ввода). | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |  | Наличие жестких требований по размещению пояснительной информации и других элементов формы. |
Привлекательность и читаемость | Выбор низкой контрастности фона и цвета пояснительной информации может снизить читаемость формы. | Наиболее привлекательный вид формы. | Менее привлекательные формы. Не очень удобны для зрительного восприятия. |  | Менее привлекательные формы. | Хорошая читаемость.
Качество заполнения |  | Менее чувствительны к выходу текста за рамки полей. | При заполнении формы символы должны быть написаны четко и крупно, чтобы они не были удалены вместе с мусором. | Менее чувствительны к выходу текста за рамки полей. | Очень чувствительны к выходу текста за рамки полей. |


Требования к машиночитаемым формам

Познакомившись с элементами машиночитаемых форм, их видами и типами разметки текста, систематизируем и сформулируем требования, при соблюдении которых созданная форма будет машиночитаемой.

Требования к фону формы
Требования к реперам формы
Требования к полю метки
Требования к геометрическим параметрам разметки текста на формах
Требования к размещению элементов формы
Требования к тиражированию
Требования к заполнению форм от руки


Требования к фону формы

  1. По возможности используйте цветную фоновую форму
    Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.
     или форму с растровыми ограничителями полей ввода.
    Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).
  2. При проектировании цветной фоновой формы используйте цвет, фильтруемый при сканировании. Перечень рекомендованных цветов приведен в разделе Рекомендуемые цвета для разработки цветных фоновых форм.
  3. На цветной фоновой форме пояснительную информацию рекомендуется выполнять в том же цвете, что и фон формы (кроме случаев, когда по каким-либо причинам вы не можете разместить на форме стандартные реперы и вынуждены использовать черный статический текст в качестве реперов). Если цвета фона и пояснительной информации совпадают, то пояснительная информация может быть размещена внутри полей ввода.
  4. Не используйте оттенки синего для фона тех форм, которые будут заполняться от руки. Такой фон может слиться с синей ручкой, что отрицательно скажется на качестве распознавания.


Требования к реперам формы

  1. Рекомендуется размещать на форме стандартные реперы
    Элемент машиночитаемой формы, необходимый для определения принадлежности формы к определенному образцу форм и ориентации формы во время автоматизированного ввода.
     (черные квадраты, уголки, кресты) в количестве 5 штук: четыре - по углам формы (при соединении центров этих реперов должен получаться прямоугольник) и один - на одной из сторон этого прямоугольника.
  2. Если по каким-то причинам на форме невозможно разместить стандартные реперы, то рекомендуются следующие комбинации элементов:

    а) не менее 2-х горизонтальных разделителей
    Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную черную линию.
     и 2-х вертикальных разделителей;
    б) не менее 4-х элементов Текст
    Элемент машиночитаемой формы, представляющий собой описательный текст формы: название формы, название полей, пояснительная информация к полям и т.д.
         и элемент Идентификатор;
    Элемент машиночитаемой формы, однозначно характеризующий данную форму.
    в) возможны другие комбинации этих элементов.
  3. Расстояние от репера до ближайшего элемента формы должно быть не менее 3 мм.
  4. Расстояние от репера до края листа должно быть не менее 8 мм.
  5. Реперы должны быть выполнены в темном цвете, не исчезающем при сканировании. Лучше всего для этого подходит черный цвет.
  6. На форме должны быть реперы, расположенные так, чтобы все заполняемые поля находились внутри ограниченной ими области.

Помимо вышеперечисленных общих требований ко всем реперам, для каждого типа реперов существуют специальные требования:

Требования к Черным квадратам

На формах одного типа все квадраты должны иметь одинаковый размер: от 4х4 мм до 8х8 мм. Рекомендуемый размер 5х5 мм. Прямоугольники не допускаются.

Требования к Уголкам и Крестам

  1. Длина стороны квадрата, описанного вокруг реперов, должна находиться в интервале от 4 мм до 8 мм. Рекомендуемый размер 5 мм.

  2. Размеры реперов одного вида должны быть одинаковыми внутри одной формы.

  3. Стороны реперов должны быть равными.

  4. Толщина линий реперов должны быть одинаковыми внутри одной формы и находиться в интервале от 0,3 мм до 1 мм. Рекомендуемая толщина 0,5 мм.

Требования к элементу Текст (в случае использования элемента в качестве репера)

Должен использоваться шрифт размером не менее 7 пунктов. Для заголовков и крупных надписей рекомендуется использовать шрифт размером не менее 14 пунктов.

Требования к элементу Разделитель (в случае использования элемента в качестве репера)

Толщина линии должна быть не менее 0,8 пункта. Рекомендуемая толщина 0,8-1,5 пункта.

Требования к штрих-коду (в случае использования элемента в качестве репера)

  1. Ширина штрих-кода (расстояние между крайней левой и крайней правой полосами штрих-кода) - 47-50 мм.
  2. Высота штрих-кода (без учета цифр) - 12-15 мм.
  3. Ориентация штрих-кода (направление полос) должна совпадать с ориентацией формы.
  4. Рекомендуется использовать штрих-код типа EAN 13.
  5. Рекомендованное расстояние от штрих-кода до любых элементов формы должно быть не менее 10 мм.


Требования к полю метки

  1. Рекомендуемый размер поля метки
    Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
    - 3,5х3,5 мм; 4х4 мм; 4,5х4,5 мм; 5х5 мм (в случае ограничителя поля метки типа Круг приведенный размер - это размер квадрата, в который вписан ограничитель)
  2. Рекомендуемая толщина линии ограничителя поля метки - 0,4 мм (при любом размере поля метки).


Требования к геометрическим параметрам разметки текста на формах

Точки растра:

  1. В случае использования черно-белой формы с растровыми границами
    Форма без фона, на которых границы знакомест, полей меток и др. элементов, в которые при заполнении формы вносится информация, выполнены растром (мелкими черными точками).
     размер точек растра должен составлять 0,39 пункта.
  2. Оптимальное расстояние между точками растра - в пять раз больше размера самой точки.

    Внимание! Обычно угроза "склеивания" точек возникает по углам знакоместа,

    Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
    поэтому особое внимание следует уделять именно угловым точкам.

    Совет
    Если редактор не позволяет задать расстояние между точками растра, необходимо выбрать такой стиль линии, чтобы ее точки были расположены на достаточном расстоянии друг от друга и не "склеивались" на отсканированном изображении.

Размер знакоместа:

  1. Рекомендуемый размер знакоместа - 4х5 мм, меньший размер знакоместа использовать не рекомендуется, т.к. поля с таким размером знакоместа требуют более аккуратного заполнения, что не всегда удается обеспечить. Также не рекомендуется использовать знакоместа очень большого размера: для получения хорошего результата при распознавании такие поля требуется заполнять непривычно большими буквами. Размер знакоместа должен примерно соответствовать общепринятым нормам письма.
  2. Рекомендуемое расстояние между строчками: не менее 2,5-3 мм. Расстояние между знакоместами по горизонтали: не менее 1-1,2 мм.
Показать иллюстрацию

Толщина линий разметки текста:

  1. Если границы представлены черными линиями, что соответствует типам разметки Текст в рамке, Буквы в изолированных рамках или Буквы в рамках, - толщина линий должна составлять 1 пункт.
Показать иллюстрацию

Гребенки:

  1. Рекомендуемый шаг гребенки в пределах одного поля формы: 5 мм.
  2. Рекомендуемое расстояние между строчками: не менее 7,5-8 мм.
  3. Рекомендуемая высота "гребенки": 0,9-1,2 мм.
  4. Рекомендуемая толщина линий гребенки: 1 пункт.
  5. В случае выполнения границы в виде "гребенки в рамке" минимальное расстояние между рамками должно быть 2,5-3 мм.
Показать иллюстрацию


Требования к размещению элементов формы

  1. Рекомендуется оставлять по краям формы отступы. Это требование вызвано тем, что элементы, размещенные слишком близко к краям формы, могут пропасть при сканировании, что приведет к потере части информации.
  2. Рекомендуемое расстояние между элементами формы: не менее 2 мм.
  3. Рекомендуемое расстояние между полем метки
    Элемент машиночитаемой формы (чаще всего квадрат), в который при заполнении вносится метка (галочка, крест, сплошная закраска и т.д.).
    и поясняющим текстом: не менее 2/3 размера поля метки.
  4. Пояснительная информация должна размещаться на форме так, чтобы она не пересекалась с полями для ввода информации.
  5. Размещая на форме пояснительную информацию, выполненную в черном цвете, необходимо отступить от других элементов не менее 1,5-2 мм. Если пояснительная информация выполнена в цвете фона, можно не отслеживать расстояние между пояснительной информацией и другими элементами формы.


Требования к тиражированию форм

При изготовлении форм необходимо выполнять следующие требования:

  1. Формы могут быть изготовлены типографским способом или распечатаны на принтере. Цветные фоновые формы
    Форма с цветным фоном, на котором белыми прямоугольниками выделены знакоместа (а также поля меток и др. поля), в которые при заполнении формы вносится информация.
    рекомендуется изготавливать в типографии, в противном случае необходимо тестирование цвета формы на сканере. Необходимо проводить тестирование пробного тиража, полученного из типографии.
  2. Все экземпляры одного типа должны быть отпечатаны с одного образца. Они должны "совпадать на просвет".
  3. Поля формы (расстояние от края листа до ближайшего объекта) должны быть не менее 8 мм, рекомендуется делать поля не менее 12 мм.
  4. Допустимое отклонение по линейным размерам элементов на форме не более 0.15%, что составляет 0,5 мм при формате А4.
  5. При печати формы нужно использовать лазерные принтеры с разрешением не менее 600 точек на дюйм.
  6. Желательно распечатывать формы на одном и том же принтере или на разных принтерах одной и той же модели.
Совет
Не рекомендуется множить машиночитаемые формы с использованием копировальной техники. В этом случае происходит изменение размеров и смещение элементов формы: утолщение рамок или растра ограничителей полей ввода, изменение насыщенности цветов, что ухудшает качество распознавания.


Требования к заполнению форм от руки

Цвет и вид ручки

Формы лучше всего заполнять черной перьевой, капиллярной, гелевой или шариковой ручкой. Темно-синяя или фиолетовая ручка тоже дает хорошие результаты (особенно на цветных фоновых формах). Фломастер приводит к более низкому качеству распознавания из-за заливания мелких деталей. Хуже всего распознаются карандаш и светлая цветная ручка.

Размер и написание букв

Для улучшения качества распознавания формы лучше всего заполнять раздельными прописными буквами. Размер буквы должен быть таким, чтобы буква занимала все пространство знакоместа,

Прямоугольник, предназначенный для написания ровно одного символа (буквы, цифры и т.д.).
но не касалась его границ.

Если знакоместа явно выделены на форме, т.е. используются следующие типы разметки текста: буквы в рамках, буквы в изолированных рамках, то проще управлять заполняющим форму, т.к. требуемый размер букв явно указан знакоместом и явное наличие знакомест мешает написать буквы слитно.

Сложнее ситуация при использовании разметки текста следующих типов: текст в рамке с гребенкой или буквы в гребенке. Здесь задается ширина знакоместа, но из-за отсутствия полных боковых ограничителей ничто не мешает заполняющему форму написать буквы слитно. И если в первом случае высота знакоместа указана явно, то во втором случае может возникнуть ситуация, когда заполняющий форму впишет слишком маленькие или слишком высокие буквы.

В разметках текста "текст в рамке" или "текст по линии" вообще не содержится информации о ширине знакоместа. Поэтому ничто не мешает заполняющему форму написать буквы слитно, что приведет к значительному ухудшению качества распознавания. В разметке текста "текст по линии" также отсутствует информация о высоте знакоместа, поэтому этот тип разметки не рекомендуется применять для форм, требующих высокого качества распознавания данных.

Помимо размера букв и раздельности написания, важным требованием является требование отсутствия "наползания" символов на ограничители. Это требование не так актуально для цветной фоновой или черно-белой растровой формы, т.к. ограничители в этих формах пропадут после сканирования и очистки изображения. А для черно-белой линейчатой формы это требование очень актуально, т.к. нарушение этого требования влечет за собой значительное ухудшение качества распознавания.

Образец заполнения

Чтобы обратить внимание респондента на перечисленные особенности заполнения формы, на форме рекомендуется указывать образец заполнения. Обычно он содержит рекомендации по заполнению данной формы и образцы букв, цифр и символов, необходимых для заполнения.


Рекомендуемые цвета для разработки цветных фоновых форм

Таблицы содержат примеры цветов фона (с номерами соответствующих пантонов), "исчезающих" при сканировании

  • любым сканером;
    Показать таблицу
  • цветным сканером с фильтрацией красного или нецветным сканером с красной лампой/красным фильтром.
    Показать таблицу


Горячие клавиши

В этом разделе приведен список горячих клавиш, используемых в различных окнах программы. Использование горячих клавиш может сэкономить ваше время и сделать работу с программой более удобной.

Горячие клавиши в главном окне
Горячие клавиши в окне редактора шаблона
Горячие клавиши в окне группового верификатора
Горячие клавиши в окне контекстного верификатора


Горячие клавиши в главном окне программы

Меню | Команда | Горячие клавиши
Файл | Новый проект… | Ctrl+Shift+N
 | Открыть проект… | Ctrl+Shift+O
 | Сохранить | Ctrl+S
 | Новый пакет | Ctrl+N
 | Загрузить изображения… | Ctrl+O
 | Сканировать изображения… | Ctrl+K
 | Импортировать изображения… | Ctrl+I
 | Экспортировать | Ctrl+U
 | Экспортировать в Файл… | Alt+Shift+S
 | Экспортировать в Базу данных… | Alt+Shift+D
 | Выход | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Найти… | Ctrl+F
 | Найти следующий | F3
 | Перейти > К следующему документу | Ctrl+D
 | Перейти > К предыдущему документу | Ctrl+Shift+D
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Отобразить документы в режиме Детали | Alt+1
 | Отобразить документы в режиме Эскизы страниц | Alt+2
 | Отобразить окно документов в режиме Изображение | Ctrl+1
 | Отобразить окно документов в режиме Данные | Ctrl+2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Полноэкранный режим | F11
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Импорт и распознавание | Импортировать изображения… | Ctrl+I
 | Проанализировать | Ctrl+E
 | Наложить шаблон… | Alt+Shift+E
 | Распознать | Ctrl+R
Верификация | Начать верификацию… | F7
 | Следующий объект верификации | F4
 | Предыдущий объект верификации | Shift+F4
 | Следующая ошибка сборки | F5
 | Предыдущая ошибка сборки | Shift+F5
 | Следующий неуверенный символ | F8
 | Предыдущий неуверенный символ | Shift+F8
 | Следующая ошибка правил | F6
 | Предыдущая ошибка правил | Shift+F6
Проект | Рабочие пакеты | Ctrl+B
 | Тестовые пакеты | Ctrl+Shift+B
 | Шаблоны документов… | Ctrl+T
 | Профили импорта изображений… | Ctrl+Shift+I
Сервис | Повторный анализ | Ctrl+Alt+E
 | Повторное распознавание | Ctrl+Alt+R
 | Перепроверить правила | Ctrl+F6
Справка | Вызов справки | F1
Общие команды | Открыть окно документа (если выделен документ или страница) | Enter


Горячие клавиши в окне редактора шаблона

Меню | Команда | Горячие клавиши
Шаблон | Добавить страницу… | Ctrl+P
 | Добавить раздел документа… | Ctrl+Alt+S
 | Свойства шаблона документа… | Ctrl+T
 | Сохранить | Ctrl+S
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Удалить область | Shift+Del
 | Выделить все | Ctrl+A
 | Выделить по типу… | Ctrl+Shift+A
 | Создать поле Текст | Alt+Shift+T
 | Создать поле Метка | Alt+Shift+C
 | Создать поле Группа меток | Alt+Shift+M
 | Создать поле Штрих-код | Alt+Shift+B
 | Создать поле Картинка | Alt+Shift+P
 | Создать поле Таблица | Alt+Shift+L
 | Создать поле Группа | Alt+Shift+G
 | Сгруппировать | Ctrl+G
 | Разгруппировать | Ctrl+Shift+G
 | Копировать текст с изображения… | Ctrl+Alt+C
 | Изображение > Очистить | Ctrl+Alt+K
 | Изображение > Инвертировать | Ctrl+Alt+V
 | Изображение > Повернуть на 90° по часовой стрелке | Ctrl+W
 | Изображение > Повернуть на 90° против часовой стрелки | Ctrl+Shift+W
Вид | Перейти в режим статических элементов | Ctrl+1
 | Перейти в режим разметки полей | Ctrl+2
 | Открыть/закрыть окно со структурой документа | Alt+F1
 | Переключить окно структуры документа в режим отображения полей | Alt+1
 | Переключить окно структуры документа в режим отображения страниц | Alt+2
 | Открыть/закрыть окно Форма данных | Alt+F2
 | Увеличить масштаб изображения страницы | Ctrl+Num+
 | Уменьшить масштаб изображения страницы | Ctrl+Num-
 | Открыть диалог свойств выделенного объекта | Alt+Enter
Документ | Run Test. | Ctrl+R
Сервис | Найти объекты на изображении… | Ctrl+D
 | Проверить шаблон документа | F9
 | Наложить раздел | Ctrl+E
Справка | Вызов справки | F1

Окно разметки изображения

Команда | Горячие клавиши
Активировать инструмент выбора | Esc
Автоматическое выделение объектов | Ctrl+Shift+D
Создать репер | A
Создать разделитель | S
Создать реперный текст | X
Создать реперный штрих-код | D
Создать текстовое поле | T
Создать метку | C
Создать группу меток | M
Создать штрих-код | B
Создать картинку | P
Создать таблицу | L
Создать группу полей | G
Создать область для поля без области | R
Создать нераспознаваемую область | O
Создать столбец таблицы | U
Добавить в таблицу разделитель | F
Удалить разделитель таблицы | E
Выровнять область | Ctrl+Alt+A
Подобрать название | Ctrl+Alt+N
Распознать название с изображения… | Ctrl+Alt+I
Определить тип разметки | Ctrl+Alt+D

Окно структуры документа

Команда | Горячие клавиши
Показать изображение выделенного поля | Enter
Переименовать выделенное поле | F2
Если выделено поле таблицы: |
Добавить столбец с текстом | Alt+Shift+T
Добавить столбец с метками | Alt+Shift+C
Добавить столбец со штрих-кодами | Alt+Shift+B
Добавить столбец с картинками | Alt+Shift+P
Если выделена группа меток: |
Добавить в группу метку | Alt+Shift+C


Горячие клавиши в окне группового верификатора

Меню | Команда | Горячие клавиши
Верификация | Подтвердить все | Enter
 | Отложить все | Ctrl+Enter
 | Изменить статус | Space
 | Следующая страница | Page Down
 | Предыдущая страница | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Выделить все | Ctrl+A
Вид | Изображение поля > Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Увеличить масштаб изображения поля | Ctrl+Num+
 | Уменьшить масштаб изображения поля | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1
Локальное меню символов | Показать изображение символа | F2
 | Подтвердить | Ctrl+E
 | Отложить | Ctrl+R
 | Отменить изменение статуса | Esc


Горячие клавиши в окне контекстного верификатора

Меню | Команда | Горячие клавиши
Верификация | Подтвердить поле | Enter
 | Отложить поле | Ctrl+Enter
 | Следующий неуверенный символ | F4
 | Предыдущий неуверенный символ | Shift+F4
 | Следующее поле | Page Down
 | Предыдущее поле | Page Up
 | Закрыть | Alt+F4
Правка | Отменить | Ctrl+Z
 | Повторить | Ctrl+Y
 | Вырезать | Ctrl+X
 | Копировать | Ctrl+C
 | Вставить | Ctrl+V
 | Удалить | Del
 | Выделить все | Ctrl+A
 | Вставить перенос строки | Shift+Enter
 | Объединить символы | Ctrl+M
Вид | Данные поля > Показывать распознанный текст | Alt+F1
 | Данные поля > Нарезка изображений символов | Alt+F2
 | Изображение поля > Показывать изображение поля | Ctrl+I
 | Изображение поля > Сверху | Alt+1
 | Изображение поля > Снизу | Alt+2
 | Изображение поля > Масштаб изображения > Увеличить | Ctrl+Num+
 | Изображение поля > Масштаб изображения > Уменьшить | Ctrl+Num-
 | Показать изображение символа | F2
 | Полноэкранный режим | F11
Справка | Вызов справки | F1


Использование скриптов во FlexiCapture 8.0

В данном разделе описано использование скриптов для написания собственных правил, экспорта и обработчиков экспорта в продукте FlexiCapture 8.0.

Поддерживаются два языка скриптов – JScript® и VBScript.

Особенности использования

В VBScript обязательно использование ключевого слова Me для обращения к методам и полям текущего объекта (аналог this в С++ и Java). Под текущим объектом понимается проверяемый узел документа (узел, содержащий правило) для правил и экспортируемый документ для экспорта.

Me.CheckSucceeded = False

В JScript® в этой же ситуации this может опускаться:

this.CheckSucceeded = false; CheckSucceeded = false;

Ошибки типа "метод или свойство не найдены" определяются только во время выполнения скрипта:

ChecckSucceeded = false; // runtime error

Синтаксические ошибки выявляются при сохранении скрипта:

CheckSucceeded +++ false; // syntax error

Пользовательские функции

Редактор скрипта позволяет создавать собственные функции и процедуры и вызывать их в дальнейшем из кода правил или экспорта.

Пользовательские функции создаются в одном из глобальных модулей – модуле экспорта или модуле правил. Модуль, в котором создается функция, можно выбрать в редакторе скрипта.

Все функции внутри одного модуля должны быть написаны на одном языке. Основной код правила или экспорта может быть написан на языке, отличном от используемого в соответствующем глобальном модуле.

Например, можно из кода правила на VBScript вызывать функцию из глобального модуля, написанного на JScript.

Функции можно вызывать только из «своего» модуля. Т.е. из кода правил можно вызывать только функции из глобального модуля правил, а из кода экспорта – из глобального модуля экспорта. В противном случае возникнет ошибка во время выполнения.

Вызов функций осуществляется следующим образом:

[VBScript]

result = Rules.SomeFunction( param1, param2 ... )

Export.SomeFunction param1, param2 ...

[JScript]

result = Rules.SomeFunction( param1, param2 ... );

Export.SomeFunction( param1, param2 ... );

Таймаут на выполнение скрипта

По умолчанию заданы следующие таймауты – 10 секунд для правил и 1 минута для экспорта.

Для изменения заданных по умолчанию значений таймаутов необходимо задать значения следующих параметров в реестре:

  1. Для правил - HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\DefaultScriptTimeout
  2. Для экспорта - HKEY_CURRENT_USER\Software\ABBYY\FlexiCapture\8.0\Controller\ScriptSupport\ExportScriptTimeout

Значение таймаута в реестре следует задавать в миллисекундах. Если скрипт выполняется дольше, чем заданный таймаут, то его выполнение будет прервано. В случае правил возникнет ошибка правила «Таймаут выполнения скрипта», в случае экспорта аналогичное сообщение появится в окне пакета в колонке Processing Notes.

Использование скриптов для создания правил
Использование скриптов для описания экспорта
Переход к скриптам в программе FlexiCapture 8.0 Professional после использования FormReader 6.5


Использование скриптов для создания правил

Правила на основе скриптов (ScriptRule) позволяют пользователям создавать произвольно сложные алгоритмы проверки и нормализации документа с использованием стандартных скриптовых языков JScript® и VBScript.

Замечание. Некоторые скрипты правил, созданные в первом релизе ABBYY FlexiCapture, могут перестать работать во втором релизе. Причина в том, что значения полей стали типизированными, а в первом релизе были текстовыми. При возникновении такой проблемы её можно решить, заменив свойство Value на свойство Text, в тех случаях, где работа скрипта построена на работе с текстом поля; либо нужно изменить использование свойства Value в соответствии с актуальным описанием. См. свойства объекта Поле.

Объектная модель

Правило следует рассматривать как метод проверяемого узла документа, то есть ссылка this или Me указывает на объект типа [Проверяемый узел документа], к которому это правило в настоящий момент применяется.

Правило может выполнять проверку документа на основе значения одного или более полей. При этом в случае обнаружения ошибки необходимо выставить флаг ошибки, а далее, по необходимости, описание ошибки, фокусируемое поле и предлагаемые варианты замены. Правило может также пометить некоторое поле как уверенно распознанное.

Правило может выполнять нормализацию документа, изменяя значения полей с приведением их к нормальному виду, либо добавляя информацию (например, дату последней обработки).

Проверяемый узел документа

Свойства:

Имя | Тип | Доступ | Описание
CheckSucceeded | булевский | Чтение/запись | Флаг ошибки. True – ошибки правила нет, False - есть
ErrorMessage | строка | Чтение/запись | Сообщение об ошибке
FocusedField | [Поле] | Чтение/запись | Фокусируемое поле
Field("AliasName") [Поле] Чтение Поле с псевдонимом AliasName

Псевдоним – это специальное имя для поля, которое используется при обращении к полю из кода правила. Поэтому переименование поля никак не отражается на использовании поля в коде правила.

Применение псевдонимов также позволяет использовать в правиле поля с одинаковыми именами (например, из разных разделов).

Псевдоним может совпадать с именем поля, а может отличаться.

При добавлении поля в правило псевдонимы им назначаются автоматически, но можно изменить сгенерированный программой псевдоним на любой другой.

Fields | [Коллекция полей] | Чтение | Коллекция полей, участвующих в правиле
Document | [Документ] | Чтение | Документ, содержащий проверяемый узел

В том случае, когда проверяемый узел документа является полем, то он поддерживает все свойства и методы, имеющиеся у объекта типа [Поле]. Если проверяемый узел не является полем, обращаться к этим свойствам и методам нельзя – это вызовет ошибку.

Поле

Свойства:

Имя | Тип | Доступ | Описание
Value Variant Чтение/запись

Типизированное значение поля.

Для числовых полей содержит число с плавающей точкой.

Для полей "Дата/Время" содержит значение даты (VT_DATE).

Для полей типа "Валюта" содержит значение денежной суммы (VT_CY)

Для меток булевское значение. При присваивании значения метке можно использовать как булевские значения true/false, так и текстовые "True"/"False" (с учетом регистра символов).

Значение группы меток представляет собой список имен выбранных меток, разделенных точкой с запятой (;). Если ни одна метка не выбрана, то пустая строка. Для того, чтобы изменить значение группы меток, следует присвоить значение true тем меткам, которые должны быть выбраны, и false тем меткам, которые не должны быть выбраны. При этом все эти метки должны быть обязательно включены в правило.
Для групп, таблиц и картинок – пустая строка.

Присваивать значения группам, группам меток и таблицам нельзя. Попытка присвоить значение полям такого типа вызовет ошибку.

Text строка Чтение Текстовое значение поля. Для всех типов полей, кроме меток, совпадает с Value.
Для меток значение этого свойства определяется в соответствии с настройками свойств поля (закладка "Тип данных").
Внимание: значение свойства Text не изменяется во время выполнения правила, т.е. изменение свойства Value в коде правила не приведет к одновременному изменению свойства Text.
В приведенном ниже примере значения oldText и newText будут совпадать:

Dim oldText, newText
oldText = me.Field("FieldName").Text
me.Field("FieldName").Value = newValue
newText = me.Field("FieldName").Text

Name | строка | Чтение | Имя поля
IsVerified булевский Чтение/запись Флаг верифицированности поля. Поле, помеченное как верифицированное, будет проигнорировано при верификации и подсчете статистики символов, требующих верификации.

Значение этого свойства равно true в том случае, если поле подтверждено пользователем при верификации, а также, если какое-нибудь правило уже установило значение свойства в true.

В противном случае, значение свойства - false.

IsCertain булевский Чтение/запись Флаг уверенности поля. Поле, помеченное как уверенно распознанное, игнорируется при верификации и подсчете статистики символов, требующих верификации.

Свойство устарело, оставлено для совместимости. Следует пользоваться свойством IsVerified.

IsMatched | булевский | Чтение | Флаг, показывающий, наложилось поле или нет.
Items | [Коллекция полей] | Чтение | В случае множественного поля коллекция его экземпляров. Если поле не множественное – 0.

Методы:

Имя | Параметры | Описание
Suggest( text ) | Variant | Добавляет подсказку с предлагаемым значением поля. Чтобы задать несколько вариантов, следует последовательно вызвать метод нужное кол-во раз. Добавляемое значение подсказки должно соответствовать типу поля. То есть для числовых полей - число, для полей "Дата/Время" – дата и т.д.

Коллекция полей

Свойства:

Имя | Тип | Доступ | Описание
Count | Целый | Чтение | Количество полей в коллекции.
Item(index) | [Поле] | Чтение | Поле с индексом index. Index принимает значения от 0 до Count – 1.

Документ

Свойства:

Имя | Тип | Доступ | Описание
Pages | [Коллекция страниц] | Чтение | Коллекция страниц документа.

Методы:

Имя | Параметры | Описание
Property( name ) | name – имя свойства | Возвращает значение запрошенного свойства. Тип возвращаемого значения – Variant.

Свойства документа, получаемые с помощью метода Property (cвойства документа, получаемые с помощью этого метода, доступны только в режиме чтения):

Значение | Тип | Описание
"TemplateName" | Строка | Название шаблона
"TotalSymbolsCount" | Целый | Количество символов
"UncertainSymbolsCount" | Целый | Количество неуверенно распознанных символов
"RecognizedSymbolsCount" | Целый | Количество распознанных символов
"Comment" | Строка | Комментарий
"Created" | Дата | Когда был создан
"CreatedBy" | Строка | Кем был создан
"Recognized" | Дата | Когда распознан
"RecognizedBy" | Строка | Кем распознан
"Modified" | Дата | Когда последний раз модифицировался
"ModifiedBy" | Строка | Кем модифицировался
"ProcessingErrors" | Строка | Ошибки
"ProcessingWarnings" | Строка | Предупреждения

Коллекция страниц

Свойства:

Имя | Тип | Доступ | Описание
Count | Целый | Чтение | Количество страниц в коллекции.
Item(index) | [Страница] | Чтение | Страница с индексом index. Index принимает значения от 0 до Count-1.

Страница

Предоставляет информацию о страницах проверяемого документа.

Свойства:

Имя | Тип | Доступ | Описание
ImageSourceType | Строка | Чтение | Тип источника изображения, может принимать значения "File" или "Scanner".
ImageSource | Строка | Чтение | Источник изображения. В случае файла - имя файла с полным путём. В случае сканера - имя сканера.
ImageSourcePageNumber | Целый | Чтение | Номер страницы внутри источника изображений. Нумерация страниц начинается с нуля. Только для файлов.

Примеры скриптов для создания пользовательских правил


Примеры скриптов для создания пользовательских правил

Automation правило

Данный пример демонстрирует проверку данных в таблице. В правиле проверяется соответствие данных таблицы значению, содержащемуся в итоговом поле. Таблица имеет колонки с ценами и количеством некоторых товаров. Правило написано на уровне раздела, содержащего таблицу и результирующее поле.

[VBScript]

dim autoRule

set autoRule = CreateObject( "AutomationRule.CheckDoc" )

autoRule.CheckResult me.FIELD("cost"), me.FIELD("number"), _

me.FIELD("Result"), me

[JScript]

var autoRule = new ActiveXObject( "AutomationRule.CheckDoc" );

autoRule.CheckResult( Field("cost"), Field("number"),

Field("Result"), this );

Код ActiveX компоненты

Здесь приведен код класса CheckDoc из проекта AutomationRule, который используется в указанных выше скриптах.

Option Explicit

' Проверяет соответствие данных в таблице результату

' column1 - колонка цен

' column2 - колонка количества

' resultField - результирующее поле (<Итого> или подобное ему )

' docObj - проверяемый узел документа

Public Sub CheckResult(ByRef column1 As Object, ByRef column2 As Object, _

ByRef resultField As Object, ByRef docObj As Object)

On Error GoTo err_h

Dim costItems As Object, numItems As Object

    Dim curCost As Double, curNum As Long, sum As Double

Dim result As Double

Dim i As Long

Set costItems = column1.Items

Set numItems = column2.Items

' суммирование данных по таблице

sum = 0

For i = 0 To costItems.Count - 1

curCost = costItems.Item(i).Value

curNum = numItems.Item(i).Value

sum = sum + curNum * curCost

Next

' сравнение с точностью до 2-го знака после запятой

result = resultField.Value

If (Round(result, 2) = Round(sum, 2)) Then

docObj.CheckSucceeded = True

Else

docObj.CheckSucceeded = False

docObj.ErrorMessage = "Данные в таблице не соответствуют итоговому значению"

resultField.Suggest sum

End If

Exit Sub

err_h:

docObj.ErrorMessage = Err.Description

docObj.CheckSucceeded = False

End Sub

Поиск в списке вариантов

Код правила, приведенный ниже, проверяет, что значение поля соответствует одному из значений списка. Если это не так, то устанавливается флажок ошибки правила, а поле получает список предлагаемых значений(suggests). В зависимости от результата проверки поле помечается либо как уверенно распознанное, либо как неуверенно.

[VBScript]

'запомнить значение поля

Dim fieldValue

fieldValue = me.Field("Field6").Value

'создать список значений для проверки

Dim list(5)

dim i

for i = 0 to 4

list(i) = "2" & i

next

dim success

success = false

'проверить значение поля на соответствие значениям из списка

for i = 0 to 4

if list(i) = fieldValue Then

success = true

exit for

end if

next

'в зависимости от результатов проверки выставить уверенность полю

me.Field("Field6").IsCertain = success

'заполнить список подсказок для поля - подсказкой может быть любое из

'подходящих значений

if success = false then

for i = 0 to 4

me.Field("Field6").Suggest( list(i) )

next

end if

'установить флажок ошибки

me.CheckSucceeded = success

[JScript]

// запомнить значение поля

var fieldValue = Field("Field6").Value;

// создать список значений для проверки

var list = new Array(5);

for( i = 0; i < 5; i++ ) {

list[i] = "2" + i

}

var success = false;

// проверить значение поля на соответствие значениям из списка

for( i = 0; i < 5; i++ ) {

if( list[i] == fieldValue ) {

success = true;

break;

}

}

// в зависимости от результатов проверки выставить уверенность полю

Field("Field6").IsCertain = success;

// заполнить список подсказок для поля - подсказкой может быть любое из

// подходящих значений

if( !success ) {

for( i = 0; i < 5; i++ ) {

Field("Field6").Suggest( list[i] );

}

}

// установить флажок ошибки

CheckSucceeded = success;

Проверка наложения полей

Код правила, приведенный ниже, определяет, наложилось ли проверяемое поле.

[VBScript]

if me.Field("InvoiceNumber").IsMatched then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Field InvoiceNumber is not matched"

end if

[JScript]

if( Field("InvoiceNumber ").IsMatched ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Field InvoiceNumber is not matched";

}

Проверка метки

Код правила, приведенный ниже проверяет, отмечена метка или нет

[VBScript]

if me.Field("Page status").Value then

me.CheckSucceeded = true

else

me.CheckSucceeded = false

me.ErrorMessage = "Page status is not checked"

me.FocusedField = me.Field("Page status")

end if

[JScript]

if( Field("Page status").Value ) {

CheckSucceeded = true;

} else {

CheckSucceeded = false;

ErrorMessage = "Page status is not checked";

FocusedField = Field("Page status");

}

Проверка меток в группе

Код правила, приведенный ниже, перебирает все метки в группе и, если ни одна из них не выбрана, выбирает первую. Правило написано на уровне группы меток. В список полей, участвующих в правиле, добавлены все метки из данной группы. Для метки по умолчанию (первой) снят флажок Readonly. Если в группе нет ни одной метки, устанавливается флаг ошибки правила.

Данный пример демонстрирует возможность итерации по всем полям правила. Поскольку имена полей в коде не используются, код может быть использован для любой группы меток.

[VBScript]

if me.Fields.Count = 0 then

me.CheckSucceeded = false

me.ErrorMessage = "В группе нет меток"

else

dim isChosen, i

isChosen = false

for i = 0 to me.Fields.Count - 1

if me.Fields.Item( i ).Value then

isChosen = true

exit for

end if

next

if Not isChosen then

me.Fields.Item(0).Value = true

end if

me.CheckSucceeded = true

end if

[JScript]

if( Fields.Count == 0 ) {

CheckSucceeded = false;

ErrorMessage = "В группе нет меток";

} else {

var isChosen = false;

var i;

for( i = 0; i < Fields.Count; i++ ) {

if( Fields.Item( i ).Value ) {

isChosen = true;

break;

}

}

if( !isChosen ) {

Fields.Item(0).Value = true;

}

CheckSucceeded = true;

}


Использование скриптов для описания экспорта

Объектная модель

Данная модель используется как в скриптах экспорта, так и в скрипте обработчика экспорта.

Обработчик экспорта – это специальный скрипт, который запускается сразу после окончания экспорта (если это задано настройками, то есть отмечена опция Запуск скрипта после экспорта в диалоге свойств проекта на закладке Экспорт и тело скрипта непустое).

Экспорт следует рассматривать как метод экспортируемого документа, то есть ссылка this или Me указывает на объект типа [Экспортируемый документ], который в настоящий момент экспортируется.

В обработчике экспорта ссылка this или Me указывает на объект типа [Результаты экспорта].

Возможность изменения значений полей во время экспорта не предусмотрена.

Экспортируемый документ

Свойства:

Имя | Тип | Доступ | Описание
IsAssembled | булевский | Чтение | Флаг показывает, собран документ или нет.
IsVerified | булевский | Чтение | Флаг показывает, отверифицирован документ или нет.
IsExported | булевский | Чтение | Флаг показывает, проэкспортирован ли уже документ.
TemplateName | строка | Чтение | Имя шаблона документа.
ProcessingErrors | строка | Чтение | Текст сообщения об ошибке, произошедшей при обработке.
ProcessingWarnings | строка | Чтение | Подсказки и/или предупреждения, выдававшиеся пользователю в процессе обработки.
TotalSymbolsCount | целый | Чтение | Общее количество символов (кроме распознанных символов, включает также символы, добавленные пользователем и правилами).
RecognizedSymbolsCount | целый | Чтение | Количество распознанных символов.
UncertainSymbolsCount | целый | Чтение | Количество неуверенно распознанных символов.
Id | строка | Чтение | Идентификатор документа.
BatchName | строка | Чтение | Имя пакета.
Field(FieldName) | [Узел документа] | Чтение | Узел с именем FieldName. Может возвращать как поле, так и секцию. FieldName представляет собой имя узла с полным путем (начиная с раздела). Например: "Section 1\Group\Field 1" Внимание: В случае, когда какой-то из компонентов пути к полю является множественным, следует указывать индекс этого компонента. Например, для множественной группы, приведенная выше строка будет выглядеть так: "Section 1\Group[index]\Field 1" index принимает значение от 0 до Count-1, где Count – количество экземпляров множественного компонента.
Children | [Коллекция узлов документа] | Чтение | Коллекция разделов документа.
Pages | [Коллекция страниц] | Чтение | Коллекция страниц документа.
IndexedItemValue | Variant | Чтение | Значение индексного поля с указанным именем: IndexedItemValue(fieldName).
Action | [Результат работы] | Чтение | Специальный объект, содержит информацию о результатах работы экспорта. При экспорте информация записывается в этот объект. В обработчике, запускаемом после завершения экспорта, эта информация может быть использована при необходимости.

Методы:

Имя | Параметры | Описание
SaveAs (filename, imageSaveOptions) | fileName – имя файла imageSaveOptions – параметры сохранения изображения (необязательный) | Сохраняет изображения всех страниц документа в файл.

Узел документа

Представляет собой раздел или поле.

Свойства:

Имя | Тип | Доступ | Описание
Value Variant Чтение

Типизированное значение узла.

Для числовых полей возвращает число с плавающей точкой.

Для полей "Дата/Время" возвращает значение даты (VT_DATE).

Для полей типа "Валюта" возвращает значение денежной суммы (VT_CY).

Для меток возвращает булевское значение.

Для групп меток возвращает список выбранных меток или пустую строку, если ни одна метка не выбрана.

Для картинки возвращает объект [Картинка].

Если у узла нет значения, то возвращает null. Перед попыткой прочитать значение узла, всегда следует проверять, не равно ли оно null (см. примеры скриптов).

Если попытаться прочитать значение, являющееся null, это приведет к ошибке.

Value равно null, например, у разделов, табличных и групповых полей.

Также Value может быть равно null в случае, когда содержимое поля (распознанный или введенный пользователем текст) не соответствует типу поля.

Text строка Чтение

Текстовое значение узла.

Для меток возвращает значения «Yes»/ «No»

Для групп меток возвращает список выбранных меток или пустую строку, если ни одна метка не выбрана.

Для любых узлов, не имеющих значения, (например, картинка, группа, секция и т.п. ) возвращает пустую строку.

Name | строка | Чтение | Имя узла.
IsExportable | булевский | Чтение | Признак необходимости экспорта узла.
IsIndexed | булевский | Чтение | Является ли узел индексным полем.
SuspiciousSymbols строка Чтение

Строка из нулей и единиц, где единицы соответствуют неуверенным символам.

Для меток возвращается строка из одного символа.

Для узлов, не имеющих значения, возвращается пустая строка.
Children [Коллекция узлов документа] Чтение Коллекция дочерних узлов. Если дочерних узлов нет – 0.
Дочерние узлы имеют, например, группа, группа меток, строка таблицы.
Items | [Коллекция узлов документа] | Чтение | В случае множественного узла – коллекция его экземпляров. Если узел не множественный – 0.
Regions | [Коллекция областей] | Чтение | Коллекция областей поля.

Картинка

Представляет собой картинку, которую можно сохранить в файле на диске.

Методы:

Имя | Параметры | Описание
SaveAs (filename, imageSaveOptions) | fileName – имя файла imageSaveOptions – параметры сохранения изображения(необязательный) | Сохраняет изображение поля в файл.

Коллекция узлов документа

Может представлять собой коллекцию полей или коллекцию разделов

Свойства:

Имя | Тип | Доступ | Описание
Count | целый | Чтение | Количество узлов в коллекции
Item(index) | [Узел] | Чтение | Экземпляр узла. Index принимает значения от 0 до Count – 1

Коллекция страниц

Свойства:

Имя | Тип | Доступ | Описание
Count | целый | Чтение | Количество страниц в коллекции
Item(index) | [Страница] | Чтение | Страница с индексом index. index принимает значения от 0 до Count – 1

Страница

Свойства:

Имя | Тип | Доступ | Описание
TemplateName | строка | Чтение | Имя раздела
ImageSourceType | строка | Чтение | Тип источника изображения, может принимать значения «File» или «Scanner»
ImageSource | строка | Чтение | Источник изображения. В случае файла – имя файла с полным путем. В случае сканера – имя сканера.
ImageSourcePageNumber | целый | Чтение | Номер страницы внутри источника изображений. Нумерация страниц начинается с нуля. Только для файлов.

Методы:

Имя | Параметры | Описание
SaveAs (filename, imageSaveOptions) | fileName – имя файла imageSaveOptions – параметры сохранения изображения(необязательный) | Сохраняет изображение страницы.

Коллекция регионов

Свойства:

Имя | Тип | Доступ | Описание
Count | целый | Чтение | Количество регионов в коллекции
Item(index) | [Регион] | Чтение | Регион с индексом index. index принимает значения от 0 до Count – 1

Регион

Свойства:

Имя | Тип | Доступ | Описание
PageIndex | целый | Чтение | Индекс страницы, на которой расположен данный регион
Rects | [Коллекция прямоугольников] | Чтение | Коллекция прямоугольников, из которых состоит регион. В случае прямоугольного региона содержит только один прямоугольник.
SurroundingRect | [Прямоугольник] | Чтение | Охватывающий прямоугольник региона
Picture | [Картинка] | Чтение | Картинка для данного региона

Коллекция прямоугольников

Свойства:

Имя | Тип | Доступ | Описание
Count | целый | Чтение | Количество прямоугольников в коллекции
Item(index) | [Прямоугольник] | Чтение | Прямоугольник с индексом index. index принимает значения от 0 до Count – 1

Прямоугольник

Свойства:

Имя | Тип | Доступ | Описание
Left | целый | Чтение | Левая координата прямоугольника на странице
Top | целый | Чтение | Верхняя координата прямоугольника на странице
Right | целый | Чтение | Правая координата прямоугольника на странице
Bottom | целый | Чтение | Нижняя координата прямоугольника на странице

ExportTools

Глобальный объект, используется для получения объекта [Параметры сохранения изображения]

Методы:

Имя | Параметры | Описание
NewImageSavingOptions |  | Создает объект [Параметры сохранения изображения]

Параметры сохранения изображений

Определяет параметры, используемые при сохранении изображения страницы.

Свойства:

Имя | Тип | Доступ | Описание
Format | строка | Чтение/запись | Формат изображения. Может принимать одно из значений: "tif", "jpg", "bmp", "jpg2000", "pcx", "png", "pdf", "pdf-s", "pdf-a", "pdf-a-s", "pdf-s-a". Регистр символов не учитывается.
ColorType | строка | Чтение/запись | Тип используемой цветовой схемы. Может принимать одно из значений: "FullColor", "GrayScale", "BlackAndWhite". Регистр символов не учитывается.
Resolution | целый | Чтение/запись | Разрешение изображения в dpi
ShouldOverwrite | булевский | Чтение/запись | Флаг определяет, следует ли перезаписывать существующий файл при сохранении. Если этот флаг установлен в false, то при вызове метода SaveAs возникнет ошибка в случае существования файла с указанным именем.

Результаты работы

Содержит информацию о результатах работы экспорта

Свойства:

Имя | Тип | Доступ | Описание
Succeeded | булевский | Чтение/запись | Содержит значение true, если экспорт выполнен успешно, в противном случае – false.
ErrorMessage | Строка | Чтение/запись | Сообщение об ошибке, произошедшей во время экспорта
Result | Строка | Чтение/запись | Формальное описание результата. Для файлового экспорта содержит имя файла с полным путем. Для экспорта в БД – название основной таблицы экспорта. Для экспорта в SharePoint – URL проэкспортированного документа.

Результаты экспорта

Свойства:

Имя | Тип | Доступ | Описание
Documents | [Коллекция экспортируемых документов] | Чтение | Коллекция документов, проэкспортированных в течение одной сессии экспорта
Type | целый | Чтение | Тип экспорта. Может принимать одно из значений: ET_File – экспорт в файловые форматы ET_Database – экспорт в БД ET_Script - пользовательский экспорт на основе скрипта ET_SharePoint – экспорт в SharePoint

Коллекция экспортируемых документов

Свойства:

Имя | Тип | Доступ | Описание
Count | целый | Чтение | Количество документов в коллекции
Item(index) | [Экспортируемый документ] | Чтение | Документ с индексом index. index принимает значения от 0 до Count – 1

Примеры скриптов для описания экспорта


Примеры скриптов для описания экспорта

Получение значения поля при экспорте
Код данного примера демонстрирует, каким образом можно получить значение определенного поля при экспорте. Это может потребоваться, например, чтобы использовать это значение для именования файлов экспорта изображений или данных. Если такого поля в документе не окажется, то при выполнении скрипта возникнет ошибка.

Структура экспортируемого документа:

Section 1

Field1

...

Group1

Field2

...

...

FieldN

Section 2

Field1

...

FieldK

[VBScript]

Dim field1Value, field2Value

' Получение значения поля Field1 из раздела Section 1

if Not IsNull( me.Field( "Section 1\Field1" ).Value ) then

field1Value = me.Field( "Section 1\Field1" ).Value

end if

' Получение значения поля Field2 из группы Group1 из раздела Section 1

if Not IsNull( me.FIELD( "Section 1\Group1\Field2" ).Value ) then

field2Value = me.Field( "Section 1\Group1\Field2" ).Value

end if

' Получение значения поля Field1 из раздела Section 1 в случае множественного раздела

if Not me.Field( "Section 1" ).Items Is Nothing then

dim curPage

for each curPage in me.Field( "Section 1" ).Items

if Not curPage.Children Is Nothing then

dim curField

for each curField in curPage.Children

if curField.Name = "Field1" And Not IsNull( curField.Value ) then

field1Value = curField.Value

exit for

end if

next

end if

next

end if

[JScript]

// Получение значения поля Field1 из раздела Section 1

if( Field("Section 1\\Field1").Value != null ) {

var field1Value = Field("Section 1\\Field1").Value;

}

// Получение значения поля Field2 из группы Group1 из раздела Section 1

if( Field("Section 1\\Group1\\Field2").Value != null ) {

var field2Value = Field("Section 1\\Group1\\Field2").Value;

}

// Получение значения поля Field1 из раздела Section 1 в случае множественного раздела

if( Field( "Section 1" ).Items != null ) {

var i, j;

for( i = 0; i < Field( "Section 1" ).Items.Count; i++ ) {

var curPage = Field( "Section 1" ).Items.Item( i );

if( curPage.Children != null ) {

for( j = 0; j < curPage.Children.Count; j++ ) {

var curField = curPage.Children.Item( j );

if( curField.Name == "Field1" && curField.Value != null ) {

var field1Value = curField.Value;

break;

}

}

}

}

}

Экспорт изображений страниц

Код данного примера демонстрирует, каким образом можно проэкспортировать изображения всех страниц документа, используя нужный формат файла, цветовую схему и разрешение. Изображения сохраняются постранично, т.е. каждая страница в свой файл.

В примере файлы именуются "page1.tif", "page2.tif" и т.д. по количеству страниц документа. При необходимости можно задать любое другое имя файла. Например, можно сформировать имя файла, используя значение какого-либо поля документа.

[VBScript]

dim fso, folderName

set fso = CreateObject("Scripting.FileSystemObject")

folderName = "d:\ExportImages"

if Not fso.FolderExists( folderName ) then

fso.CreateFolder folderName

end if

dim imageOptions

set imageOptions = ExportTools.NewImageSavingOptions

imageOptions.Format = "tif"

imageOptions.ColorType = "BlackAndWhite"

imageOptions.Resolution = 600

dim i

for i = 0 to me.Pages.Count - 1

dim fileName

    ' задаем желаемое имя и расширение файла в соответствии с выбранным форматом

fileName = fso.BuildPath( folderName, "page" & (i+1) & ".tif" )

me.Pages.Item(i).SaveAs fileName, imageOptions

next

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

var folderName = "d:\\ExportImages";

if( !fso.FolderExists( folderName ) ) {

fso.CreateFolder( folderName );

}

var imageOptions = ExportTools.NewImageSavingOptions();

imageOptions.Format = "tif";

imageOptions.ColorType = "BlackAndWhite";

imageOptions.Resolution = 600;

var i;

for( i = 0; i < Pages.Count; i++ ) {

    // задаем желаемое имя и расширение файла в соответствии с выбранным форматом

var fileName = fso.BuildPath( folderName, "page" + (i+1) + ".tif" );

Pages.Item(i).SaveAs( fileName, imageOptions );

}

Экспорт таблицы

Пример демонстрирует экспорт таблицы в текстовый файл формата txt.

[VBScript]

dim fso, txtFile, fileName

set fso = CreateObject("Scripting.FileSystemObject")

fileName = "d:\TestExportTable.txt"

set txtFile = fso.CreateTextFile( fileName, true )

txtFile.WriteLine "Table"

dim table, row, cell, rowNumber

set table = me.Field("Page 1\Table")

rowNumber = 1

for each row in table.Items

txtFile.WriteLine "RowNumber = " & rowNumber

for each cell in row.Children

txtFile.Write cell.Value & " "

next

txtFile.WriteBlankLines 1

rowNumber = rowNumber + 1

next

txtFile.Close

set txtFile = nothing

set fso = nothing

[JScript]

var fso, txtFile, fileName;

fso = new ActiveXObject("Scripting.FileSystemObject");

fileName = "d:\\TestExportTable1.txt";

txtFile = fso.CreateTextFile( fileName, true );

txtFile.WriteLine( "Table" );

var table, i, j;

table = Field("Page 1\\Table");

var rows = table.Items;

for( i = 0; i < rows.Count; i++ ) {

txtFile.WriteLine( "RowNumber = " + ( i+1 ) );

var cells = rows.Item(i).Children;

for( j = 0; j < cells.Count; j++ ) {

txtFile.Write( cells.Item(j).Value + " " );

}

txtFile.WriteBlankLines(1);

}

txtFile.Close();

Экспорт документа с произвольным уровнем вложенности

Пример показывает, каким образом осуществить экспорт полей документа с произвольным уровнем вложенности, используя собственные функции из глобального модуля экспорта. Экспорт осуществляется в текстовый файл формата txt. Для экспорта полей документа произвольной вложенности лучше воспользоваться внешней COM-компонентой (см. следующий пример)

Основной код экспорта

[VBScript]

Export.ExportDocument me, ExportTools

[JScript]

Export.ExportDocument( this, ExportTools );

Код функций глобального модуля экспорта

[VBScript]

' Процедура осуществляет экспорт документа - создает папку экспорта,

' сохраняет в нее файлы изображений страниц и текстовый файл с полями

' документа и информацией о документе

Sub ExportDocument(ByRef docObj, ByRef exportTools)

    Dim folderName

    Dim txtFile, fileName

    Dim fso

    On Error Resume Next

    set fso = CreateObject("Scripting.FileSystemObject")

    ' создание папки экспорта

    folderName = CreateExportFolder(docObj.TemplateName, fso)

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during create export folder: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' экспорт изображений

    ExportImages docObj, exportTools, folderName, fso

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export images: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    ' создание текстового файла

    fileName = fso.BuildPath(folderName, "doc.txt")

    Set txtFile = fso.CreateTextFile(fileName, True)

    ' экспорт информации о документе

    ExportDocInfo docObj, txtFile

    ' экспорт полей

    txtFile.WriteLine "Fields:"

    ExportFields docObj.Children, txtFile, ""

    txtFile.Close

    if Err.Number <> 0 then

        docObj.Action.Succeeded = false

        docObj.Action.ErrorMessage = "Error during export data: " + Err.Description

        Err.Clear

        Exit Sub

    End if

    Set txtFile = Nothing

    Set fso = Nothing

End Sub

' Функция экспорта изображений.

Function ExportImages( ByRef docObj, ByRef exportTools, ByVal exportFolder, ByRef fso )

    Dim pages, page, imageOptions

    Dim fileName, pageNum

    ' задание опций экспорта

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "bmp"

    imageOptions.ColorType = "FullColor"

    imageOptions.Resolution = 100

    ' ' постраничный экспорт

    Set pages = docObj.Pages

    pageNum = 1

    For Each page In pages

        fileName = fso.BuildPath(exportFolder, "page" & pageNum & ".bmp")

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next

End Function

' Процедура экспорта информации о документе

Sub ExportDocInfo(ByRef docObj, ByRef txtFile)

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

End Sub

' Процедура экспорта полей из коллекции fields

Sub ExportFields(ByRef fields, ByRef txtFile, ByVal indent)

    Dim curField

    For Each curField In fields

        ExportField curField, txtFile, indent

    Next

End Sub

' Проверяет значение поля на null

' Если значение поля невалидно, то при любом обращении к нему(даже при

' проверке на null) может возникнуть исключение

Function IsNullFieldValue( ByRef field )

    on error resume next

    IsNullFieldValue = IsNull( field.Value )

    if Err.Number <> 0 then

        IsNullFieldValue = True

        Err.Clear

    End if

End Function

' Процедура экспорта поля

Sub ExportField(ByRef field, ByRef txtFile, ByVal indent)

    ' сохраняем имя поля

    txtFile.Write (indent & field.Name)

    ' сохраняем значение поля, если оно доступно

    If IsNullFieldValue(field) Then

        txtFile.WriteLine

    Else

        txtFile.WriteLine ("    " & field.Text)

    End If

    If Not field.Children Is Nothing Then

        ' экспорт дочерних полей

        ExportFields field.Children, txtFile, indent & "    "

    ElseIf Not field.Items Is Nothing Then

        ' экспорт экземпляров поля

        ExportFields field.Items, txtFile, indent & "    "

    End If

End Sub

' Функция создает папку экспорта и возвращает полный путь к ней

Function CreateExportFolder(ByVal templateName, ByRef fso)

    Dim docFolder, folderNameme

    ' ' основная папка

    Const exportFolder = "d:\ScriptExport"

    If fso.FolderExists(exportFolder) = False Then

        fso.CreateFolder (exportFolder)

    End If

    ' папка указанного шаблона документа

    docFolder = fso.BuildPath(exportFolder, templateName)

    If fso.FolderExists(docFolder) = False Then

        fso.CreateFolder (docFolder)

    End If

    ' папка экспортируемого документа

    Dim i

    i = 1

    folderName = fso.BuildPath(docFolder, i)

    While fso.FolderExists(folderName)

        i = i + 1

        folderName = fso.BuildPath(docFolder, i)

    Wend

    fso.CreateFolder (folderName)

    CreateExportFolder = folderName

End Function

[JScript]

// Функция осуществляет экспорт документа - создает папку экспорта,

// сохраняет в нее файлы изображений страниц и текстовый файл с полями

// документа и информацией о документе

function ExportDocument(docObj, exportImageTools)

{

    var folderName

    var txtFile, fileName

    var fso

    fso = new ActiveXObject("Scripting.FileSystemObject");

    // создание папки экспорта

    try {

        folderName = CreateExportFolder(docObj.TemplateName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during create export folder: " + e.description;

        return;

    }

    // экспорт изображений

    try {

        ExportImages(docObj, exportImageTools, folderName, fso);

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export images: " + e.description;

        return;

    }

    // создание текстового файла

    fileName = fso.BuildPath(folderName, "doc.txt");

    txtFile = fso.CreateTextFile(fileName, true);

    // экспорт информации о документе

    ExportDocInfo( docObj, txtFile );

    // экспорт полей

    txtFile.WriteLine( "Fields:" );

    try {

        ExportFields( docObj.Children, txtFile, "" );

    } catch( e ) {

        docObj.Action.Succeeded = false;

        docObj.Action.ErrorMessage = "Error during export data: " + e.description;

        txtFile.Close();

        return;

    }

    txtFile.Close();

    txtFile = 0;

    fso = 0;

}

// Функция экспорта изображений. В случае ошибки при экспорте изображений

// возвращает сообщение об этой ошибке, в противном случае - пустую строку

function ExportImages( docObj, exportImageTools, exportFolder, fso )

{

    // задание опций экспорта

    var imageOptions = exportImageTools.NewImageSavingOptions();

    imageOptions.Format = "bmp";

    imageOptions.ColorType = "FullColor";

    imageOptions.Resolution = 100;

    // постраничный экспорт

    var pages = docObj.Pages;

    var i

    for( i = 0; i < pages.Count; i++ ) {

        var fileName = fso.BuildPath( exportFolder, "page" + (i+1) + ".bmp" );

        pages.Item(i).SaveAs( fileName, imageOptions );

    }

}

// Процедура экспорта информации о документе

function ExportDocInfo(docObj, txtFile)

{

    txtFile.WriteLine( "Doc info:" );

    txtFile.WriteLine("IsAssembled " + docObj.IsAssembled);

    txtFile.WriteLine("IsVerified " + docObj.IsVerified);

    txtFile.WriteLine("IsExported " + docObj.IsExported);

    txtFile.WriteLine("ProcessingErrors " + docObj.ProcessingErrors);

    txtFile.WriteLine("ProcessingWarnings " + docObj.ProcessingWarnings);

    txtFile.WriteLine("TotalSymbolsCount " + docObj.TotalSymbolsCount);

    txtFile.WriteLine("RecognizedSymbolsCount " + docObj.RecognizedSymbolsCount);

    txtFile.WriteLine("UncertainSymbolsCount " + docObj.UncertainSymbolsCount);

    txtFile.WriteLine();

}

// Процедура экспорта полей из коллекции fields

function ExportFields(fields, txtFile, indent)

{

    var i

    for( i = 0; i < fields.Count; i++ ) {

        ExportField( fields.Item(i), txtFile, indent );

    }

}

// Проверяет значение поля на null

// Если значение поля невалидно, то при любом обращении к нему(даже при

// проверке на null) может возникнуть исключение

function IsNullFieldValue( field )

{

    try {

        return ( field.Value == null );

    } catch( e ) {

        return true;

    }

}

// Процедура экспорта поля

function ExportField(field, txtFile, indent)

{

    // сохраняем имя поля

    txtFile.Write(indent + field.Name);

    // сохраняем значение поля, если оно доступно

    if( IsNullFieldValue( field ) ) {

        txtFile.WriteLine();

    } else {

        txtFile.WriteLine("    " + field.Text);

    }

    if( field.Children != null ) {

        // экспорт дочерних полей

        ExportFields( field.Children, txtFile, indent + "    " );

    } else if( field.Items != null ) {

        // экспорт экземпляров поля

        ExportFields( field.Items, txtFile, indent + "    " );

    }

}

// Функция создает папку экспорта и возвращает полный путь к ней

function CreateExportFolder(templateName, fso)

{

    var docFolder, folderName

    // основная папка

    var exportFolder = "d:\\ScriptExport";

    if( !fso.FolderExists(exportFolder) ) {

        fso.CreateFolder (exportFolder);

    }

    // папка указанного шаблона документа

    docFolder = fso.BuildPath(exportFolder, templateName);

    if( !fso.FolderExists(docFolder) ) {

        fso.CreateFolder(docFolder);

    }

    // папка экспортируемого документа

    var i = 1;

    folderName = fso.BuildPath(docFolder, i);

    while( fso.FolderExists(folderName) ) {

        i++;

        folderName = fso.BuildPath(docFolder, i);

    }

    fso.CreateFolder(folderName);

    return folderName;

}

Использование внешней COM-компоненты

[VBScript]

dim autoExport

set autoExport = CreateObject( "AutomationExport.Exporter" )

autoExport.Export me, ExportTools

[JScript]

var autoExport = new ActiveXObject("AutomationExport.Exporter");

autoExport.Export( this, ExportTools );

Код ActiveX компоненты на VisualBasic

Здесь приведен код класса Exporter из проекта AutomationExport, который используется в указанных выше скриптах.

Option Explicit

Dim mFso As New Scripting.FileSystemObject

' Процедура осуществляет экспорт документа - создает папку экспорта,

' сохраняет в нее

' файлы изображений страниц и текстовый файл с полями документа и

' информацией о документе

Public Sub Export(ByRef docObj As Object, ByRef exportTools As Object)

On Error GoTo err_h

    Dim folderName As String

    Dim txtFile As TextStream, fileName As String

    Dim imageExportResult As String, errMessage As String

    ' создание папки экспорта

    folderName = createExportFolder(docObj.templateName)

    If folderName = "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = "Cannot create export folder"

        Exit Sub

    End If

    ' экспорт изображений

    imageExportResult = exportImages(docObj, exportTools, folderName)

    ' создание текстового файла

    fileName = mFso.BuildPath(folderName, "doc.txt")

    Set txtFile = mFso.CreateTextFile(fileName, True)

    ' сохранение информации о проблемах при экспорте изображений

    If imageExportResult <> "" Then

        txtFile.WriteLine imageExportResult

        errMessage = errMessage & imageExportResult

    End If

    ' экспорт информации о документе

    exportDocInfo docObj, txtFile

    ' экспорт полей

    txtFile.WriteLine "Fields:"

    If Not exportFields(docObj.Children, txtFile, "") Then

       errMessage = errMessage & " Error during export data"

    End If

    txtFile.Close

    ' если в процессе экспорта произошли ошибки, надо сбросить флаг

    'успешности экспорта в False

    If errMessage <> "" Then

        docObj.Action.Succeeded = False

        docObj.Action.ErrorMessage = errMessage

    End If

    Set txtFile = Nothing

    Set mFso = Nothing

Exit Sub

err_h:

    docObj.Action.Succeeded = False

    docObj.Action.ErrorMessage = Err.Description

    txtFile.Close

    Set mFso = Nothing

End Sub

' Функция экспорта изображений. В случае ошибки при экспорте изображений

' возвращает сообщение об этой ошибке, в противном случае - пустую строку

Private Function exportImages(ByRef docObj As Object, ByRef exportTools As Object, _

    ByVal exportFolder As String) As String

On Error GoTo err_h

    Dim pages As Object, page As Object, imageOptions As Object

    Dim fileName As String, pageNum As Long

    exportImages = ""

    ' задание опций экспорта

    Set imageOptions = exportTools.NewImageSavingOptions

    imageOptions.Format = "png"

    imageOptions.ColorType = "GrayScale"

    imageOptions.Resolution = 300

    ' постраничный экспорт

    Set pages = docObj.pages

    pageNum = 1

    For Each page In pages

        fileName = mFso.BuildPath(exportFolder, page.templateName + "_page" & pageNum & "." & imageOptions.Format)

        page.SaveAs fileName, imageOptions

        pageNum = pageNum + 1

    Next page

Exit Function

err_h:

    exportImages = Err.Description

End Function

' Процедура экспорта информации о документе

Private Sub exportDocInfo(ByRef docObj As Object, ByRef txtFile As TextStream)

On Error GoTo err_h

    txtFile.WriteLine "Doc info:"

    txtFile.WriteLine ("DocumentId " & docObj.Id)

    txtFile.WriteLine ("IsAssembled " & docObj.IsAssembled)

    txtFile.WriteLine ("IsVerified " & docObj.IsVerified)

    txtFile.WriteLine ("IsExported " & docObj.IsExported)

    txtFile.WriteLine ("ProcessingErrors " & docObj.ProcessingErrors)

    txtFile.WriteLine ("ProcessingWarnings " & docObj.ProcessingWarnings)

    txtFile.WriteLine ("TotalSymbolsCount " & docObj.TotalSymbolsCount)

    txtFile.WriteLine ("RecognizedSymbolsCount " & docObj.RecognizedSymbolsCount)

    txtFile.WriteLine ("UncertainSymbolsCount " & docObj.UncertainSymbolsCount)

    txtFile.WriteLine

Exit Sub

err_h:

    txtFile.WriteLine Err.Description

End Sub

' Функция экспорта полей из коллекции fields

Private Function exportFields(ByRef fields As Object, ByRef txtFile As TextStream, ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim curField As Object

    exportFields = True

    For Each curField In fields

        If Not exportField(curField, txtFile, indent) Then

            exportFields = False

        End If

    Next curField

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportFields = False

End Function

' Проверяет значение поля на null

' Если значение поля невалидно, то при любом обращении к нему(даже при

' проверке на null) может возникнуть исключение

Function IsNullFieldValue(ByRef field As Object) As Boolean

On Error GoTo err_h

    IsNullFieldValue = IsNull(field.Value)

Exit Function

err_h:

    IsNullFieldValue = True

End Function

' Функция экспорта поля

Private Function exportField(ByRef field As Object, ByRef txtFile As TextStream, _

    ByVal indent As String) As Boolean

On Error GoTo err_h

    Dim result As Boolean

    result = True

    ' сохраняем имя поля

    txtFile.Write (indent & field.Name)

    ' сохраняем значение поля, если оно доступно

    If Not IsNullFieldValue(field) Then

        txtFile.WriteLine ("    " & field.Value)

    Else

        txtFile.WriteLine

    End If

    If Not field.Children Is Nothing Then

        ' экспорт дочерних полей

        result = result And exportFields(field.Children, txtFile, indent & "    ")

    ElseIf Not field.Items Is Nothing Then

        ' экспорт экземпляров поля

        result = result And exportFields(field.Items, txtFile, indent & "    ")

    End If

    exportField = result

Exit Function

err_h:

    txtFile.WriteLine Err.Description

    exportField = False

End Function

' Функция создает папку экспорта и возвращает полный путь к ней

Private Function createExportFolder(ByVal templateName As String) As String

On Error GoTo err_h

    Dim docFolder As String, folderName As String

    ' основная папка

    Const exportFolder = "d:\AutomationExport"

    If mFso.FolderExists(exportFolder) = False Then

        mFso.CreateFolder (exportFolder)

    End If

    ' папка указанного шаблона документа

    docFolder = mFso.BuildPath(exportFolder, templateName)

    If mFso.FolderExists(docFolder) = False Then

        mFso.CreateFolder (docFolder)

    End If

    ' папка экспортируемого документа

    Dim i As Long

    i = 1

    folderName = mFso.BuildPath(docFolder, i)

    While mFso.FolderExists(folderName)

        i = i + 1

        folderName = mFso.BuildPath(docFolder, i)

    Wend

    mFso.CreateFolder (folderName)

    createExportFolder = folderName

Exit Function

err_h:

    createExportFolder = ""

End Function

Использование внешней компоненты, написанной на .Net( C# )

Для использования внешней компоненты, написанной на .Net следует выполнить следующие действия:

  1. Создать проект типа ClassLibrary
  2. Добавить в References проекта Controller.dll – в списке References появится FlexiCaptureScriptingObjects и все интерфейсы скриптовых объектов будут доступны в проекте.
  3. Определить disp-интерфейс и класс, реализующий этот интерфейс, а также ProgId (это нужно, чтобы из кода скрипта можно было работать с .Net компонентой так же, как с ActiveX ).
  4. После сборки проекта зарегистрировать сгенерированную библиотеку типов (это можно сделать автоматически, если включить соответствующую опцию в свойствах проекта).
  5. Из кода экспорта вызывать метод компоненты обычным образом:

[VBScript]

dim autoExport

set autoExport = CreateObject( "ExportLibrary1.Export" )

autoExport.ExportDocument me, ExportTools

[JScript]

var autoExport = new ActiveXObject("ExportLibrary1.Export");

autoExport.ExportDocument( this, ExportTools );

Ниже приведен код такой компоненты:

using System;

using System.Runtime.InteropServices;

using System.IO;

using FlexiCaptureScriptingObjects;

namespace ExportLibrary1

{

// Интерфейс компоненты экспорта, с которым можно работать из скрипта

// При создании новой компоненты следует сгенерировать новый GUID

[Guid("32B10C3B-EEA3-4194-B0A0-E358C310225A")]

[InterfaceType(ComInterfaceType.InterfaceIsIDispatch)]

public interface _cExport

{

[DispId(1)]

void ExportDocument(ref IExportDocument DocRef, ref IExportTools Tools);

}

// Класс с реализацией функциональности компоненты экспорта

// При создании новой компоненты следует сгенерировать новый GUID и

// задать свой ProgId

[Guid("3BA19BD7-C6DC-4f63-BC08-0D95254DADC3")]

[ClassInterface(ClassInterfaceType.None)]

[ProgId("ExportLibrary1.Export")]

[ComVisible(true)]

public class Export : _cExport

{

public Export()

{

}

// Функция осуществляет экспорт документа - создает папку

// экспорта, сохраняет в нее файлы изображений страниц и

// текстовый файл с полями документа и информацией о документе

public void ExportDocument( ref IExportDocument docRef, ref IExportTools exportTools )

{

try

{

string exportFolder = createExportFolder( docRef.TemplateName );

exportImages( docRef, exportTools, exportFolder );

// создание текстового файла

string fileName = exportFolder + "//" + "doc.txt";

StreamWriter sw = File.CreateText( fileName );

// экспорт информации о документе

exportDocInfo( docRef, sw );

// экспорт полей

sw.WriteLine( "Fields:" );

exportFields( docRef.Children, sw, "" );

sw.Close();

}

catch( Exception e )

{

docRef.Action.Succeeded = false;

docRef.Action.ErrorMessage = e.ToString();

}

}

// Функция создает папку экспорта и возвращает полный путь к ней

private string createExportFolder( string templateName )

{

string docFolder, folderName;

// основная папка

string exportFolder = "d:\\DotNetExport";

if( !Directory.Exists(exportFolder) )

{

Directory.CreateDirectory(exportFolder);

}

// папка указанного шаблона документа

docFolder = exportFolder + "\\" + templateName;

if( !Directory.Exists(docFolder) )

{

Directory.CreateDirectory( docFolder );

}

// папка экспортируемого документа

int i = 1;

folderName = docFolder + "\\" + i;

while( Directory.Exists(folderName) )

{

i++;

folderName = docFolder + "\\" + i;

}

Directory.CreateDirectory(folderName);

return folderName;

}

// Функция экспорта изображений.

private void exportImages( IExportDocument docRef, IExportTools exportTools, string exportFolder )

{

string baseFileName = exportFolder + "\\page_";

IExportImageSavingOptions imageOptions = exportTools.NewImageSavingOptions();

imageOptions.Format = "bmp";

imageOptions.ColorType = "FullColor";

imageOptions.Resolution = 100;

int i = 1;

foreach( IExportPage curPage in docRef.Pages )

{

string fileName = baseFileName + i + ".bmp";

curPage.SaveAs( fileName, imageOptions );

i++;

}

}

// Экспортирует информацию о документе

private void exportDocInfo( IExportDocument docRef, StreamWriter sw )

{

sw.WriteLine( "Doc info:" );

sw.WriteLine("DocumentId " + docRef.Id );

sw.WriteLine("IsAssembled " + docRef.IsAssembled);

sw.WriteLine("IsVerified " + docRef.IsVerified);

sw.WriteLine("IsExported " + docRef.IsExported);

sw.WriteLine("ProcessingErrors " + docRef.ProcessingErrors);

sw.WriteLine("ProcessingWarnings " + docRef.ProcessingWarnings);

sw.WriteLine("TotalSymbolsCount " + docRef.TotalSymbolsCount);

sw.WriteLine("RecognizedSymbolsCount " + docRef.RecognizedSymbolsCount);

sw.WriteLine("UncertainSymbolsCount " + docRef.UncertainSymbolsCount);

sw.WriteLine();

}

// Экспортирует коллекцию полей

private void exportFields( IExportFields fields, StreamWriter sw, string indent )

{

foreach( IExportField curField in fields )

{

exportField( curField, sw, indent );

}

}

// Проверяет значение поля на null

// Если значение поля невалидно, то при любом обращении к

// нему(даже при проверке на null) может возникнуть исключение

private bool IsNullFieldValue( IExportField field )

{

try

{

return ( field.Value == null );

}

catch( Exception e )

{

return true;

}

}

// Экспортирует указанное поле

private void exportField( IExportField field, StreamWriter sw, string indent )

{

// сохраняем имя поля

sw.Write( indent + field.Name );

// сохраняем значение поля, если оно доступно

if( IsNullFieldValue( field ) )

{

sw.WriteLine();

}

else

{

sw.WriteLine( " " + field.Text );

}

if( field.Children != null )

{

// экспорт дочерних полей

exportFields( field.Children, sw, indent + " " );

}

else if( field.Items != null )

{

// экспорт экземпляров поля

exportFields( field.Items, sw, indent + " " );

}

}

}

}

Обработчик экспорта

Код данного примера демонстрирует простейший обработчик экспорта, который сохраняет информацию о проэкспортированных документах и результатах экспорта в текстовые файлы. В примере использованы два текстовых файла – со списком успешно проэкспортированных документов и документов, при экспорте которых, возникли ошибки.

[VBScript]

dim curDoc

dim fso, fileErrorName, txtErrorFile, fileSucceedName, txtSucceedFile

set fso = CreateObject("Scripting.FileSystemObject")

' создание файла со списком ошибочных документов

fileErrorName = "d:\ExportResults\ErrorsDocuments.txt"

set txtErrorFile = fso.CreateTextFile( fileErrorName, true )

' создание файла со списком успешно проэкпортированных документов

fileSucceedName = "d:\ExportResults\SucceedDocuments.txt"

set txtSucceedFile = fso.CreateTextFile( fileSucceedName, true )

Dim docInfo

' проитерируем коллекцию проэкспортированных документов

for each curDoc in me.Documents

    docInfo = "DocumentId:" & curDoc.Id

    if curDoc.Action.Succeeded then

        docInfo = docInfo & ". Проэкспортирован успешно.  Результат:" & curDoc.Action.Result

        txtSucceedFile.WriteLine docInfo

    else

        docInfo = docInfo & ". Ошибка при экспорте: " & curDoc.Action.ErrorMessage & "  Результат:" & curDoc.Action.Result

        txtErrorFile.WriteLine docInfo

    end if

next

txtErrorFile.Close

txtSucceedFile.Close

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

// создание файла со списком ошибочных документов

var fileErrorName = "d:\\ExportResults\\ErrorsDocuments.txt";

var txtErrorFile = fso.CreateTextFile( fileErrorName, true );

// создание файла со списком успешно проэкпортированных документов

var fileSucceedName = "d:\\ExportResults\\SucceedDocuments.txt"

var txtSucceedFile = fso.CreateTextFile( fileSucceedName, true );

var i

// проитерируем коллекцию проэкспортированных документов

for( i = 0; i < Documents.Count; i++ ) {

    var curDoc = Documents.Item( i );

    var docInfo = "DocumentId: " + curDoc.Id;

   if( curDoc.Action.Succeeded ) {

        docInfo = docInfo + ". Проэкспортирован успешно.  Результат:" + curDoc.Action.Result;

        txtSucceedFile.WriteLine( docInfo );

    } else {

        docInfo = docInfo + ". Ошибка при экспорте: " + curDoc.Action.ErrorMessage + "  Результат:" + curDoc.Action.Result;

        txtErrorFile.WriteLine( docInfo );

    }

}

txtErrorFile.Close();

txtSucceedFile.Close();


Переход к скриптам в программе FlexiCapture 8.0 Professional после использования FormReader 6.5

Переход с правил FormReader 6.5 на скрипт-правила

Проверка с условием

Замена функций и методов:

  1. Функция Error(field, message). Вместо этой функции следует использовать сочетание свойств проверяемого узла – CheckSucceeded, ErrorMessage и FocusedField.

    Например, такой код:

    if [City].IsEmpty() then Error( [City] , "the city name should be filled")

    должен быть изменен следующим образом:

    [VBScript]

    if me.Field("City").Text = "" then

    me.CheckSucceeded = false

    me.ErrorMessage = "the city name should be filled"

    me.FocusedField = me.Field("City")

    else

    me.CheckSucceeded = true

    end if

    [JScript]

    if( Field("City").Text == "" ) {

    CheckSucceeded = false;

    ErrorMessage = "the city name should be filled";

    FocusedField = Field("City");

    } else {

    CheckSucceeded = true;

    }

  2. Операции со строками. В настоящем разделе описывается, как реализовать строковые операции, имевшиеся в правиле «Проверка с условием», в используемых языках скриптов

    [VBScript]

    .Length() – есть аналогичная функция Len(string)

    .CmpNoCase(str) – для сравнения строк без учета регистра можно использовать функцию LCase(string) или UCase(string)

    .Mid(position, count) – есть аналогичная функция Mid(string, pos, count)

    [JScript]

    .Length() – есть аналогичное свойство length у строковой переменной

    .CmpNoCase(str) – для сравнения строк без учета регистра можно использовать методы toLowerCase() или toUpperCase() строковых переменных

    .Mid(position, count) – аналогичный метод строковой переменной substr(start, [length])

  3. Операции с вещественными числами

    [VBScript]

    Floor(d), Ceil(d) – предопределенных аналогов в VBScript нет, при необходимости можно написать собственную реализацию

    Round(d),Round(d, i) - аналогичная функция Round(d, [i])

    [JScript]

    Floor(d), Ceil(d) – нужно воспользоваться методами floor(d) и ceil(d) объекта Math

    Round(d) – метод round(d) объекта Math

    Round(d, i) – предопределенного аналога в JScript нет, при необходимости можно написать собственную реализацию

  4. Операции с текстовым полем

    IsEmpty() – надо сравнить текстовое значение поля Field("fieldName").Text с пустой строкой

    Text() - Field("fieldName").Text

    Length() – надо получить текстовое значение поля, а длину полученного строкового значения определить, как описано в п.2

    SetText(text) - Field("fieldName").Text = text

  5. Операции с меткой

    IsValid() – можно воспользоваться свойством IsVerified

    Value() - Field("fieldName").Value теперь возвращает булевское значение, а не 0/1, как было в версии 6.5

    SetValue(newValue) - Field("fieldName").Value = newValue

  6. Операции с группой меток

    IsValid() – можно воспользоваться свойством IsVerified для определения уверенности поля группы. Чтобы выяснить, сколько меток выбрано следует проитерировать метки группы, как показано в примере «Проверка меток в группе» (см. Примеры скриптов для создания пользовательских правил), и определить количество выбранных меток.

    Value() – для получения номера выбранной метки можно воспользоваться одним из двух способов:

    1. Задать меткам группы числовые имена – «0», «1» и т.д. Тогда в Field("groupName").Value будет содержаться либо номер выбранной метки, либо список номеров(выбрано несколько), либо пустая строка(не выбрана ни одна).
    2. Добавить для участия в правиле только метки данной группы, причем добавить обязательно в порядке следования меток. Проитерировать метки, как показано в примере «Проверка группы меток», и определить номер выбранной метки.

    Text() - Field("groupName").Value

    SetValue(newValue) – чтобы изменить значение группы меток, надо установить/сбросить нужные метки в этой группе. Метки должны быть выбраны для участия в правиле и флаг ReadOnly для них должен быть выключен.

Automation-правило

Для того, чтобы написанные для FormReader 6.5 Automation-компоненты можно было использовать во FlexiCapture, следует внести в них некоторые изменения.

  1. Метод внешней компоненты, реализующей логику правила, следует вызывать из скриптового правила, как показано в примерах. Никаких требований к сигнатуре такого метода нет, Главное, чтобы параметры, передаваемые из скиптового правила в метод внешней компоненты, соответствовали выбранной сигнатуре метода. Она может быть, например, такой:

    Public Sub Check(ByRef docObj As Object)

    2. docObj – ссылка на проверяемый узел документа

  2. Методы объекта fieldsObj, использовавшегося в FR6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта fieldsObj новым методам:
Методы fieldsObj | Пример кода на VisualBasic, на который можно заменить вызов старого метода
GetFieldsCount As Integer Dim count as Long

count = docObj.Fields.Count()
GetFieldsNames(Names As Variant) Dim i As Long, count As Long

Dim Names() As String

count = docObj.Fields.count

ReDim Names(count - 1)

For i = 0 To count - 1

Names(i) = docObj.Fields.Item(i).Name

Next
GetFieldsTypes(FieldTypes As Variant) | Не поддерживается
GetFieldByIndex(Index As Integer, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Fields.Item(index).Value
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue

fieldValue = docObj.Field(Name).Value
GetTableColumnsList(FieldIndex As Integer, TableColumns As Variant) Для работы с колонками таблицы следует добавить для участия в правиле поля колонок. Определить, наложился столбец или нет, можно также, как и для любого другого поля:

Dim isMatched isMatched = docObj.Field("ColumnName").IsMatched

SetFieldByIndex(Index As Integer, FieldValue As Variant) | docObj.Fields.Item(index).Value = newValue
SetFieldByName(Name As String, FieldValue As Variant) | docObj.Field(Name).Value = newValue
SetTableCellValue(Index As Integer, Row As Integer, Column As Integer, FieldValue As String) Для работы с ячейками таблицы следует добавить для участия в правиле поля колонок.

Работа с этими полями будет зависеть от того, на каком уровне написано правило. Если правило написано на уровне колонки или таблицы, то оно работает для каждой строки, оперируя значениями колонок из проверяемой строки (т.е. работает с ячейками):

Dim cell As Object
Set cell = docObj.Field("ColumnName")
Dim cellValue as String
cellValue = cell.Value

Таким образом, например, можно написать правило, которое на основании данных в первых двух колонках таблицы, заполняет третью колонку:

Dim cellResult As Object
Set cellResult = docObj.Field("ColumnResult")
cellResult.Value = docObj.Field("Column1").Value + docObj.Field("Column2").Value

Если правило написано на уровне узла, содержащего таблицу (группа, секция, документ), то для получения доступа к ячейкам конкретной колонки ее потребуется проитерировать, как показано в примере «Automation-правило».

SetSuggestByIndex(Index As Integer, Suggests As String)

Dim suggests() As Variant

' получение подсказок для поля

' ...

Dim field As Object

Set field = docObj.Fields.Item(index)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetSuggestByName(FieldName As String, Suggests As String)

Dim suggests() As Variant

' получение подсказок для поля

' ...

Dim field As Object

Set field = docObj.Field(Name)

For i = LBound(suggests) To UBound(suggests)

field.Suggest suggests(i)

Next
SetTableCellSuggest(Index As Integer, Row As Integer, Column As Integer, Suggests As String) Доступ к полю ячейки осуществляется также, как описано и для метода SetTableCellValue.

Далее с полученной ячейкой можно работать также, как и с любым другим полем. Т.е. задание подсказки будет выглядеть так:

cell.Suggest cellSuggest

  3. Методы объекта errorsObj, использовавшегося в FR6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта errorsObj новым методам:
Методы errorsObj | Пример кода на VisualBasic, на который можно заменить вызов старого метода
SendFieldError( ErrMsg As String, Index As Integer) | docObj.ErrorMessage = ErrMsg docObj.CheckSucceeded = false docObj.FocusedField = docObj.Fields.Item(index)
SendTableError( ErrMsg As String, FieldIndex As Integer, ErrorCells As Variant ) | docObj.ErrorMessage = ErrMsg docObj.CheckSucceeded = false Если правило написано на уровне таблицы или колонки, то в качестве ошибочных выделяются все ячейки проверяемой строки, поля которых (колонки), включены в правило. Чтобы поставить фокус на нужную ячейку следует написать такой код: docObj.FocusedField = docObj.Field("ColumnName") Если правило написано на более высоком уровне, то ячейки не выделяются и не получают фокус.

Переход с Automation-экспорта FormReader 6.5 на скрипт-экспорт

Метод внешней компоненты, реализующей логику экспорта, следует вызывать из скриптового экспорта, как показано в примерах. Никаких требований к сигнатуре такого метода нет, главное, чтобы параметры, передаваемые из скипта в метод внешней компоненты, соответствовали выбранной сигнатуре метода. Она может быть, например, такой:

Public Sub Check(ByRef docObj As Object, ByRef exportTools As Object)

docObj – ссылка на экспортируемый документ

exportTools – ссылка на объект ExportTools

Методы объекта fieldsObj, использовавшегося в FormReader R6.5, должны быть заменены на методы, поддержанные в текущей версии. Ниже приведена таблица соответствия методов объекта fieldsObj новым средствам работы с экспортируемым документом:

Методы fieldsObj | Описание возможной реализации в применении к новой объектной модели
GetFieldsCount As
Integer 		Для получения количества полей в экспортируемом документе следует проитерировать дерево полей как показано в примере «Использование внешней COM-компоненты» и произвести подсчет.
GetFieldsNames(Names As Variant) | Для получения имен всех полей экспортируемого документа следует проитерировать дерево полей как показано в примере «Использование внешней COM-компоненты» и заполнить массив именами полей.
GetFieldsTypes(FieldTypes As Variant) | Не поддерживается
GetFieldByIndex(Index As Integer, FieldValue As Variant) Доступ по индексу не имеет смысла, так как новая модель документа имеет иерархическую структуру.
Дерево полей документа может быть легко проитерировано, как показано в примере «Использование внешней COM-компоненты»
GetFieldByName(Name As String, FieldValue As Variant) Dim fieldValue
fieldValue = docObj.Field(Name).Value


Различия в правилах FormReader 6.5 и FlexiCapture 8.0

Различия в правилах FormReader 6.5 и FlexiCapture 8.0 Professional

FormReader 6.5

Поддержка во FlexiCapture 8.0 Professional

Проверка полей формы по базе данных

Правило проверки по базе данных

Проверка суммы чисел

Правило проверки суммы

Объединение блоков

Правило объединения полей

Проверка с помощью VBScript

Скриптовое правило

Поиск в списке вариантов

Свойства поля, закладка Тип данных. Список вариантов задается с помощью настройки Ограничения. Применимо для всех типов, за исключением Дата и Число. См. Типы данных текстового поля ввода.

Проверка наложения блоков

Можно реализовать через скриптовое правило

Проверка с условием

Скриптовое правило

Замена значений из списка

Свойства поля, закладка Тип данных. Тип Текст, настройка Обработка. См. Типы данных текстового поля ввода.

Замена символов из списка

Свойства поля, закладка Тип данных. Тип Текст, настройка Обработка. См. Типы данных текстового поля ввода.

Нормализация и проверка даты

Свойства поля, закладка Тип данных.. В списке типов следует выбрать Дата, а с помощью списка форматов и поля Ограничения задать все необходимые настройки. См. Типы данных текстового поля ввода.

Регулярное выражение

Свойства поля, закладка Тип данных. Регулярное выражение можно задать в поле Ограничения. Применимо для всех типов, за исключением Дата и Число. См. Типы данных текстового поля ввода.

Automation-проверка

При использовании Automation-объектов для реализации правил в предыдущей версии, такие компоненты требовали регистрации на целевом компьютере, что осложняло процесс переноса пакетов между компьютерами пользователей.

В настоящей версии всю логику большинства подобных правил целесообразно реализовывать с помощью скрипта.

В тех случаях, когда логика правила столь сложна, что может быть реализована только посредством внешней компоненты, такую компоненту следует вызывать из кода скриптового правила и передавать ей на вход ссылку на объект проверяемого документа.

Нормализация цены

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.

Проверка серии и номера паспорта

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.

Проверка соответствия числа цифрами числу прописью

Правило сравнения суммы цифрами с суммой прописью

Сравнение и нормализация цены цифрами - цены прописью

Может быть реализовано с помощью внешней COM-компоненты, вызываемой из скриптового правила.


Дополнительные настройки

Пользователь может гибко настроить процесс обработки документов и интерфейс программы в соответствии со своими задачами. Выберите пункт Опции… в меню Сервис главного окна. При этом откроется диалог, состоящий из 4 закладок:

  • Закладка Выполнение задачи.

    При выполнении задач в фоновом режиме пользователь может контролировать процесс в окне выполнения задач, по журналу, а также по всплывающим подсказкам. Здесь вы можете выбрать, какая именно информация должна заноситься в журнал, и в каких случаях должна появляться подсказка.

  • Закладка Настройки цвета.

    Вы можете изменить цвета элементов интерфейса, таких как рамки для выделения полей в редакторе шаблона документа, рамки и заливка для выделения полей с ошибками и предупреждениями. Для этого выберите нужный элемент и нажмите на кнопку Цвет.

  • Закладка Обработка документов.

    Распознавание изображений может производиться автоматически, сразу после добавления изображений в пакет. Для этого нужно отметить опцию Автоматически распознавать добавленные изображения.

    Если отмечена опция Удалять обработанные документы после экспорта, то документы, данные из которых были успешно экспортированы, будут удаляться из пакета.

    При обнаружении ошибки в скрипте запускается отладчик VisualStudio. Если отметить опцию Не использовать внешние средства отладки скриптов, отладчик запускаться не будет и будет выдается сообщение об ошибке.

  • Закладка Диалоги.

    По умолчанию при запуске программы показывается диалог Открытие проекта, где вы можете выбрать один из существующих проектов. Если вы не хотите каждый раз видеть этот диалог, вы можете отменить его показ, отключив опцию Показывать диалог при запуске программы (или непосредственно в диалоге Открытие проекта).

    Программа предупреждает о наличии неопубликованных шаблонов документов при попытке закрыть список шаблонов. Чтобы программа больше не показывала это предупреждение, нужно отменить опцию Показывать предупреждение при наличии неопубликованных шаблонов. Также это можно сделать непосредственно в диалоге Неопубликованные шаблоны документов.


Встроенные примеры проектов FlexiCapture

Для того чтобы каждый пользователь мог увидеть работу программы на конкретных примерах и подробнее ознакомиться с функциями программы ABBYY FlexiCapture 8.0 Professional, вместе с программой поставляется стандартный набор готовых проектов. Проекты полностью настроены, содержат готовые шаблоны документов и изображения документов для обработки.

Проекты расположены в папке <имя диска>:\Documents and Settings\All Users\Application Data\ABBYY\FlexiCapture\8.0\Samples.

Замечание. Для OC Microsoft Windows Vista проекты расположены в папке <имя диска>:\Users\Public\ABBYY\FlexiCapture\8.0\Samples.

В папке Samples находятся следующие папки:

  1. Тип содержимого- в ней находятся проекты для FlexiCapture.
  2. FlexiLayoutStudio - в этой папке содержатся проекты FlexiLayout Studio, созданные для обработки полуструктурированных документов. Эти проекты можно открыть в приложении ABBYY FlexiLayout Studio 8.0. Некоторые из них подробно описаны в справке FlexiLayout Studio (см. разделы "Обучение на примерах", "Советы и рекомендации").
  3. FormDesigner - в этой папке содержатся жесткие формы, разработанные в приложении FormDesigner. Файлы с расширением *.fdd можно открыть и редактировать в приложении ABBYY FormDesigner 8.0. Эти формы используются в следующих проектах FlexiCapture: Banking Card Application и Questionnaire.
  4. Images - в этой папке содержаться отсканированные изображения документов для проектов FlexiCapture.

Ниже приведен список проектов FlexiCapture и их краткое описание.

Пример проекта с документами разных типов

Папки с примерами содержат проекты FlexiCapture.

  1. Single Entry Point

    Этот проект демонстрирует возможность обработки документов разных типов. Предварительная сортировка документов не требуется, жесткие формы и гибкие документы различных видов могут обрабатываться в одном потоке. Эти шаблоны также вынесены в отдельные проекты, описанные ниже.

    Проект содержит все типы документов: Banking Card Applications, Invoices, Contracts, Letters, Prices.

Примеры жестких форм

Папки с примерами содержат формы, разработанные в приложении FormDesigner, и проекты FlexiCapture.

  2. Banking Card Application

    В данном примере продемонстрированы следующие возможности программы:

    • Автоматический поиск полей в жестких формах (для того чтобы увидеть, как работает автоматический поиск, удалите все поля в шаблоне документов, а затем выберите Сервис > Найти объекты на изображении…)
    • Поддержка сложной структуры документов:
      1. Многостраничные документы (в примере рассматриваются трехстраничные заявления)
      2. Работа с разделами документов (в примере каждая страница выделена в один раздел)
      3. Правила сборки документов
      4. Обработка приложений.
    • Поддержка сложных полей документа:
      1. Работа с таблицами в жестких формах (таблица "Opened Accounts")
      2. Повторяющиеся группы полей (группы "Address" и "Requested Accounts")
    • Проверка формата данных (задан формат для всех полей с числовыми значениями и для дат)
    • Индивидуальная настройка формы данных.

  3. Questionnaire

    Этот пример подробно описан в руководстве пользователя, он помогает продемонстрировать пошаговую настройку шаблона документов. Наиболее простые формы выбраны для демонстрации базовой функциональности FlexiCaprute. В руководстве пользователя предлагается заполнить анкету из данного примера, произвести обработку и прислать проэкспортированные данные в компанию ABBYY.

Примеры гибких документов

Папки с примерами содержат проекты FlexiLayout Studio и проекты FlexiCapture.

  4. Invoice

    В этом примере показана обработка полуструктурированных документов и продемонстрированы следующие возможности программы:

    • Непостоянное количество страниц в документах (от 1 до 3)
    • Многостраничные таблицы
    • Использование внешнего словаря (из текстового файла) для поиска ключевых слов
    • Правило, описанное на JScript, используемое для сравнения суммы, полученной суммированием значения Total во всех строках таблицы, с суммой из поля "Total".

  5. Prices

    В этом примере показана обработка полуструктурированных документов и продемонстрированы следующие возможности программы:

    • Поддержка повторяющихся групп. Данный пример демонстрирует, как повторяющиеся группы могут быть использованы для описания вложенных таблиц (таблиц с подзаголовками).

  6. Letters&Contracts

    В этом примере показана обработка неструктурированных документов, из которых извлекаются 2-3 поля и продемонстрированы следующие возможности программы:

    • Непостоянное количество страниц в документах (от 1 до 4)
    • Настройка экспорта в PDF с возможностью поиска.


Поддерживаемые языки распознавания

Программа ABBYY FlexiCapture 8.0 Professional поддерживает следующие языки распознавания со словарной поддержкой:

Язык | OCR* | ICR**
английский | ü | ü
армянский (восточный, западный, грабар) | ü |
башкирский | ü |
болгарский | ü | ü
венгерский | ü | ü
греческий | ü | ü
датский | ü |
индонезийский | ü | ü
испанский | ü | ü
итальянский | ü | ü
казахский | ü | ü
каталанский | ü |
киргизский | ü | ü
латышский | ü | ü
литовский | ü | ü
немецкий (старая, новая орфография) | ü | ü
нидерландский (Нидерланды и Бельгия) | ü | ü
норвежский (нюнорск и букмол) | ü |
польский | ü | ü
португальский (Португалия и Бразилия) | ü |
румынский | ü | ü
русский | ü | ü
словацкий | ü | ü
словенский | ü | ü
тайский | ü |
татарский | ü |
турецкий | ü | ü
украинский | ü | ü
финский | ü | ü
французский | ü | ü
хорватский | ü | ü
чешский | ü | ü
шведский | ü |
эстонский | ü | ü

Более подробно о шрифтах для поддерживаемых языков см. раздел "Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе ABBYY FlexiCapture".

Полный актуальный список поддерживаемых типов данных и подробная информация о них приведены на сайте http://www.abbyy.ru.

* - OCR - Optical Character Recognition. Оптическое распознавание типографских текстов.

** - ICR - Intelligent Character Recognition. Распознавание рукопечатных текстов.


Шрифты, необходимые для корректного отображения символов поддерживаемых типов данных в редакторе FormReader

Шрифты, необходимые для корректного отображения символов поддерживаемых языков в редакторе ABBYY FlexiCapture

Язык | Шрифт
Со словарной поддержкой |
армянский (восточный, западный, грабар) | Arial Unicode MS(2)
татарский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
Без словарной поддержки |
абхазский | Arial Unicode MS(2)
аварский | Arial Unicode MS(2), Lucida Sans Unicode(3)
агульский | Arial Unicode MS(2), Lucida Sans Unicode(3)
адыгейский | Arial Unicode MS(2), Lucida Sans Unicode(3)
азербайджанский (кириллица), азербайджанский (латиница) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
алтайский | Arial Unicode MS(2), Lucida Sans Unicode(3)
башкирский | Arial Unicode MS(2), Palatino Linotype(2)
бурятский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
гагаузский | Arial Unicode MS(2)
даргинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
дунгаский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
зулу | Arial Unicode MS,(2), Lucida Sans Unicode(3)
ингушский | Arial Unicode MS(2), Lucida Sans Unicode(3)
кабардино-черкесский | Arial Unicode MS(2), Lucida Sans Unicode(3)
казахский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
калмыцкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
каракалпакский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
киргизский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
корякский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лакский | Arial Unicode MS(2), Lucida Sans Unicode(3)
лезгинский | Arial Unicode MS(2), Lucida Sans Unicode(3)
мансийский | Arial Unicode MS(2), Lucida Sans Unicode(3)
марийский | Arial Unicode MS(2)
монгольский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
ненецкий | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
осетинский | Arial Unicode MS(2)
русский (старая орфография) | Arial Unicode MS(2), Palatino Linotype(2)
табасаранский | Arial Unicode MS(2), Lucida Sans Unicode(3)
таджикский | Arial Unicode MS(2), Palatino Linotype(2)
тувинский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
туркменский | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
удмуртский | Arial Unicode MS(2)
узбекский (кириллица) | MS Core Fonts 2.82(1) (Arial, Courier New и Times New Roman)
хакасский | Arial Unicode MS(2)
хантыйский | Arial Unicode MS(2)
хауса | Arial Unicode MS(2), Lucida Sans Unicode(3)
чеченский | Arial Unicode MS(2), Lucida Sans Unicode(3)
чувашский | Arial Unicode MS(2)
чукотский | Arial Unicode MS(2), Lucida Sans Unicode(3)
якутский | Arial Unicode MS(2)

(1) http://www.microsoft.com/

(2) MS Office 2000

(3) Windows NT 4.0


Поддерживаемые типы текста

Программа ABBYY FlexiCapture 8.0 Professional поддерживает следующие типы текста:

Тип текста | Описание
Типографский, лазерный или струйный принтер | Текст, напечатанный типографским способом, на лазерном или на струйном принтере
Пишущая машинка | Текст, напечатанный на пишущей машинке
Матричный принтер | Текст, напечатанный на матричном принтере
Index | Специальный набор символов, включающий только цифры для написания почтового индекса. Выглядит следующим образом:
OCR-A | Моноширинный шрифт, разработанный специально для оптического распознавания символов. Широко используется банками и в смежных отраслях. Может выглядеть следующим образом:
OCR-B | Шрифт, разработанный специально для оптического распознавания символов. Может выглядеть следующим образом:
MICR E-138 | Специальный набор цифр, напечатанный магнитными чернилами. MICR - Magnetic Ink Character Recognition. Может выглядеть следующим образом:
MICR CMC-7 | Специальный шрифт MICR (CMC-7). Может выглядеть следующим образом:


Поддерживаемые типы штрих-кодов

Программа ABBYY FlexiCapture 8.0 Professional поддерживает штрих-коды следующих форматов:

  • EAN 13
  • EAN 8
  • Code 39
  • Check Code 39
  • Interleaved 25
  • Check Interleaved 25
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code


Поддерживаемые графические форматы

Тип | Цвет
BMP | ч/б, серый, цветной
PCX | ч/б, серый
PNG | ч/б, серый, цветной
JPEG | серый, цветной
JPEG-2000 | серый, цветной
TIFF ч/б – несжатый, CCITT3, CCITT4, Packbits, ZIP;
серый – несжатый, Packbits, JPEG, ZIP;
цветной – несжатый, JPEG, ZIP.
PDF, PDF/A
PDF, PDF/A с возможностью поиска
DjVu | ч/б, серый, цветной


Форматы файлов экспорта

Форматы файлов, в которые ABBYY FlexiCapture 8.0 Professional экспортирует данные из документов

  • Microsoft Office Excel Workbook (*.XLS)
  • DBase file (*.DBF)
  • Comma Separated Values File (*.CSV). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Comma Separated Values File (*.CSV) в формате Unicode (UTF-8, UTF-16)
  • Простой текст (*.TXT). ABBYY FlexiCapture поддерживает различные кодовые страницы (Windows, DOS)
  • Простой текст (*.TXT) в формате Unicode (UTF-8, UTF-16)
  • XML Document (*.XML)


Алфавит, используемый в регулярных выражениях

Название | Условное обозначение | Пример использования
Любой символ | * | "к"*"т" – допускает слова типа кит, кот и т.п.
Буква | С | С"от" – допускает слова типа Рот, рот, кот, Кот, мот и т.д.
Заглавная буква | А | A"от" – допускает слова типа Рот, Кот, Мот, Дот и т.п.
Строчная буква | а | а"от" – допускает слова типа рот, кот, мот, дот и т.п.
Буква или цифра | Х | X – допускает любую одиночную цифру или букву.
Цифра | N | N"-й" допускает слова типа 5-й, 4-й, 1-й и т.п.
Строка | " " | "кот"
Или | | | "пл"("о"|"а")"т" – допускает слова "плот" и "плат".
Символ из группы | [] | [тм]"от" – допускает слова тот и мот.
Символ не из группы | [^] | [^т]"от" – допускает слова "кот", "лот" и т.п., но не допускает слова "тот".
Пробел (в группе) | \s | [A\s] допускает только букву А либо пробел.
Любое число повторений (распространяется на стоящее слева выражение или подвыражение) | {-} | [АБ74]{-} – допускает любые комбинации символов А, Б, 7, 4 произвольной длины.
Количество повторений n | {n} | N{2}"-й" допускает слова типа 25-й, 84-й, 11-й и т.п.
От n до m повторений | {n-m} | N{1-3}"-й" допускает слова типа 5-й, 84-й, 111-й и т.п.
От 0 до n повторений | {-n} | N{-2}"-й" допускает слова типа -й, 84-й, 1-й и т.п.
От n и больше повторений | {n-} | N{2-}"-й" допускает слова типа 25-й, 834-й, 311-й, 34576-й и т.п.
Подвыражение | () |
Символ "дефис" | [\-] |
Символ "слеш" | [\\] |


Патенты

U.S. Patent Nos. 5,258,855, 5,369,508, 5,625,465, 5,768,416 и 6,094,505


Технологии других компаний

JasPer License Version 2.0

Copyright (c) 2001-2006 Michael David Adams
Copyright (c) 1999-2000 Image Power, Inc.
Copyright (c) 1999-2000 The University of British Columbia

All rights reserved.

Подробнее

Настоящей лицензией любому лицу (далее - "Пользователь"), получившему копию настоящего программного обеспечения и сопроводительную документацию к нему (далее - "ПО"), безвозмездно предоставляется право распоряжаться ПО без каких-либо ограничений, включая право использовать, копировать, изменять, встраивать, воспроизводить, публиковать, распространять и/или продавать копии ПО, а также разрешать лицам, которым передается ПО, совершать аналогичные действия при условии соблюдения нижеперечисленных условий:

  1. Любые копии или значительные части ПО должны содержать вышеприведенные уведомления об авторских правах, настоящую лицензию и нижеприведенный отказ от гарантий.

  2. Имя владельца авторских прав не должно использоваться для поддержки или рекламы продуктов, созданных на основе настоящего ПО, без предварительного письменного согласия владельца авторских прав.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ ЯВЛЯЕТСЯ НЕОТЪЕМЛЕМОЙ ЧАСТЬЮ НАСТОЯЩЕЙ ЛИЦЕНЗИИ.

НАСТОЯЩИЙ ОТКАЗ ОТ ГАРАНТИЙ РАСПРОСТРАНЯЕТСЯ НА ЛЮБОЕ ИСПОЛЬЗОВАНИЕ ПО. ПО ПРЕДОСТАВЛЯЕТСЯ ВЛАДЕЛЬЦАМИ АВТОРСКИХ ПРАВ "ТАКИМ, КАКОВО ОНО ЕСТЬ" БЕЗ КАКИХ-ЛИБО ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ, В ТОМ ЧИСЛЕ (НО НЕ ОГРАНИЧИВАЯСЬ ЭТИМ) ГАРАНТИЙ ТОГО, ЧТО ПО ПРИГОДНО К ПРОДАЖЕ, ПРИГОДНО ДЛЯ КОНКРЕТНОГО ИСПОЛЬЗОВАНИЯ И НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ЗА ЛЮБЫЕ КОСВЕННЫЕ, ПРЯМЫЕ ИЛИ СЛУЧАЙНЫЕ УБЫТКИ, А ТАКЖЕ ЗА ЛЮБЫЕ УБЫТКИ ИЗ-ЗА НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПО, ПОТЕРИ ДАННЫХ ИЛИ УПУЩЕННОЙ ВЫГОДЫ В РЕЗУЛЬТАТЕ НЕВЫПОЛНЕНИЯ ОБЯЗАТЕЛЬСТВ ПО КОНТРАКТУ, НЕБРЕЖНОСТИ ИЛИ ИНЫХ ВРЕДОНОСНЫХ ДЕЙСТВИЙ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ИЛИ РАБОТОЙ ПО. ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НЕ ГАРАНТИРУЮТ, ЧТО ПО НЕ НАРУШАЕТ ПАТЕНТОВ И ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ТРЕТЬИХ ЛИЦ. КАЖДЫЙ ИЗ ВЛАДЕЛЬЦЕВ АВТОРСКИХ ПРАВ ОТКАЗЫВАЕТСЯ ОТ ЛЮБОЙ ОТВЕТСТВЕННОСТИ ПЕРЕД ПОЛЬЗОВАТЕЛЯМИ ЗА ИСКИ ТРЕТЬИХ ЛИЦ В СВЯЗИ С НАРУШЕНИЕМ ИХ ПРАВ ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ ИЛИ ИНЫМИ НАРУШЕНИЯМИ. ДЛЯ ИСПОЛЬЗОВАНИЯ ПРАВ, ПРЕДОСТАВЛЯЕМЫХ НАСТОЯЩЕЙ ЛИЦЕНЗИЕЙ, КАЖДЫЙ ПОЛЬЗОВАТЕЛЬ ПРИНИМАЕТ НА СЕБЯ ЕДИНОЛИЧНОЕ ОБЯЗАТЕЛЬСТВО ПРИОБРЕСТИ НЕОБХОДИМЫЕ ПРАВА ИНТЕЛЛЕКТУАЛЬНОЙ СОБСТВЕННОСТИ, ЕСЛИ ТАКОВЫЕ ПОТРЕБУЮТСЯ. ПО НЕ ОБЛАДАЕТ ОТКАЗОУСТОЙЧИВОСТЬЮ И НЕ ПРЕДНАЗНАЧЕНО ДЛЯ ИСПОЛЬЗОВАНИЯ В УСЛОВИЯХ, ТРЕБУЮЩИХ БЕЗОТКАЗНОЙ РАБОТЫ, ТАКИХ КАК ЯДЕРНЫЕ УСТАНОВКИ, АВИАЦИОННЫЕ НАВИГАЦИОННЫЕ ИЛИ КОММУНИКАЦИОННЫЕ СИСТЕМЫ, АВИАДИСПЕТЧЕРСКИЕ СИСТЕМЫ, АППАРАТЫ ПО ПОДДЕРЖАНИЮ ЖИЗНИ, ОРУЖИЕ ИЛИ СИСТЕМЫ, В КОТОРЫХ ОТКАЗ ПО ИЛИ СИСТЕМЫ МОЖЕТ ПРИВЕСТИ К ГИБЕЛИ ЛЮДЕЙ, ТРАВМАМ, СЕРЬЕЗНОМУ УЩЕРБУ ЗДОРОВЬЮ ИЛИ ОКРУЖАЮЩЕЙ СРЕДЕ ("ДЕЯТЕЛЬНОСТЬ, СВЯЗАННАЯ С ПОВЫШЕННЫМ РИСКОМ"). ВЛАДЕЛЬЦЫ АВТОРСКИХ ПРАВ НАСТОЯЩИМ ОТКАЗЫВАЮТСЯ ОТ ЛЮБЫХ ЯВНЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ ГАРАНТИЙ ПРИГОДНОСТИ ПО ДЛЯ ДЕЯТЕЛЬНОСТИ, СВЯЗАННОЙ С ПОВЫШЕННЫМ РИСКОМ.

Товарные знаки

QuickScan является товарным знаком, а Captiva является зарегистрированным товарным знаком корпорации Captiva Software Corporation.

KODAK является товарным знаком компании Eastman Kodak Company.


Техническая поддержка

Если при использовании программы ABBYY FlexiCapture 8.0 Professional у вас возникли вопросы, то вы можете воспользоваться детальным описанием функциональности этой программы, приведенном в Справке и Руководстве пользователя ABBYY FlexiCapture 8.0 Professional. А также зайдите на наш сайт www.abbyy.ru в раздел технической поддержки. Возможно, вы найдете ответ на свой вопрос.

Для того чтобы дать вам квалифицированные рекомендации, сотрудникам службы технической поддержки необходимо иметь следующую информацию:

  • Фамилия, Имя, Отчество
  • Название организации
  • Телефон (факс, адрес электронной почты)
  • Серийный номер дистрибутива
  • Выпуск (см. меню Справка/О программе ABBYY FlexiCapture 8.0…)
  • Общее описание проблемы с полным текстом сообщения об ошибке (если такое имеется)
  • Тип вашего компьютера, тип процессора
  • Версия системы Windows
  • Другая информация, которую вы считаете важной
Координаты офисов ABBYY


Как купить программу ABBYY FormDesigner 8.0 Professional

Как купить программу ABBYY FlexiCapture 8.0 Professional

Чтобы оформить заказ на покупку ABBYY FlexiCapture и задать любые сопутствующие вопросы, обращайтесь к авторизированным партнерам компании ABBYY или в региональные офисы ABBYY.


Координаты офисов ABBYY

Координаты офисов компании ABBYY

Россия | ABBYY Poccuя Тел.: +7 495 783 3700 Факс: +7 495 783 2663 Почтовый адрес: Россия, 129301, Москва, а/я 49, ООО "Аби" Физический адрес: Москва, ст. м. ВДНХ, ул. Касаткина, дом 11, строение 1 E-mail: sales@abbyy.ru Техническая поддержка: support@abbyy.ru Web: http://www.abbyy.ru СХЕМА ПРОЕЗДА
Северная /Центральная Америка | Для пользователей в США, Канаде, а также Мексике и странах Центральной Америки: ABBYY USA Тел.: +1 510 226 6717 Факс: +1 510 226 6069 Адрес: 47221 Fremont Boulevard, Fremont, California 94538, USA E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Web: http://www.abbyy.com
Восточная Европа и страны Средиземноморья | Для пользователей в Албании, Боснии и Герцеговине, Болгарии, Хорватии, в Чехии, Венгрии, Израиле, Македонии, в Молдавии, Польше, Румынии, Сербии, Словакии, Словении, Турции, на Украине и в Черногории: ABBYY Украина Тел.: +380 44 490 9999 Факс: +380 44 490 9461 Адрес: Украина, 02002 Киев, а/я 23 E-mail: forms@abbyy.ua Техническая поддержка: Тел.: +380 44 490 94 63 E-mail: formssupport@abbyy.ua Web: http://www.abbyy.ua
Западная Европа | Для пользователей в Австрии, странах Бенилюкса, Великобритании, Дании, во Франции, в Германии, Греции, Италии, Ирландии, Норвегии, Португалии, Испании, Швеции, Швейцарии и других странах этого региона: ABBYY Europe GmbH Тел.: +49-(0)89-511 159 0 Факс: +49-(0)89-511 159 59 Адрес: Elsenheimerstrasse 49, 80687 Munich, Germany E-mail: sales_eu@abbyy.com Техническая поддержка: support_eu@abbyy.com Web: http://www.abbyy.com
Япония | Для пользователей в Японии: ABBYY Japan Тел.: +81 42 795 1901 Факс: +81 42 795 1901 Адрес: 658-1 Tsuruma, Machida-shi, Tokyo 194-8510 E-mail: sales@abbyyusa.com Техническая поддержка: support@abbyyusa.com Web: http://www.abbyy.com
Другие регионы | Для пользователей в других странах, не упомянутых выше: ABBYY Россия Тел.: +7 495 783-3700 Факс: +7 495 783-2663 Почтовый адрес: Россия, 129301, Москва, а/я 49, ООО "Аби" Физический адрес: Москва, ст. м. ВДНХ, ул. Касаткина, дом 11, строение 1 E-mail: sales@abbyy.com Техническая поддержка: support@abbyy.ru Web: http://www.abbyy.ru; http://www.abbyy.com


Лицензионный договор с конечным пользователем

ABBYY FlexiCapture 8.0 Professional

Важно! Прочтите внимательно нижеизложенное, прежде чем устанавливать, копировать или иным образом использовать приобретенный продукт. Любое использование Вами приобретенного продукта, в том числе его установка и копирование, означает Ваше согласие с условиями приведенного ниже Лицензионного договора.

Настоящий Лицензионный договор является юридически обязательным соглашением, заключаемым между Вами, конечным пользователем (под которым подразумевается в том числе и организация, для которой было приобретено программное обеспечение) и Компанией ABBYY; соглашение заключается относительно указанного выше программного обеспечения, которое поставляется вместе с настоящим Лицензионным договором, включая все носители, печатные материалы и электронную документацию (далее по тексту – ПО).

Устанавливая, копируя или иным способом используя ПО, Вы подтверждаете, что настоящий Лицензионный договор был Вами прочитан, условия его Вам понятны, и Вы согласны использовать ПО в соответствии с ними.

Права на ПО защищаются действующим законодательством и международными соглашениями. Вы подтверждаете свое согласие с тем, что настоящий Лицензионный договор имеет такую же юридическую силу, как и любой другой письменный договор, подписанный Вами.

Если поставка ПО сопровождается Лицензионным договором в бумажном виде, то в случае расхождений в содержании между текстом настоящего Лицензионного договора и текстом Лицензионного договора в бумажном виде преимущественную силу имеет текст Лицензионного договора в бумажном виде.

Настоящий Лицензионный договор считается заключенным с момента, когда Вы примете его условия, а именно: в процессе установки ПО отметите пункт «Я принимаю условия лицензионного договора» на экране Вашего компьютера и нажмете на кнопку «Далее»; договор сохраняет силу в течение всего срока действия авторского права на ПО.

В случае если Вы не согласны с условиями настоящего Лицензионного договора, не используйте ПО и отметьте пункт «Я не принимаю условия лицензионного договора» и затем нажмите на кнопку «Отмена» для выхода из программы установки. Деньги, уплаченные Вами при приобретении ПО, будут Вам возвращены полностью при условии, что Вы:

(i) отказались от использования ПО; и

(ii) вернули ПО, включая всю относящуюся к ПО документацию, носители и упаковку, с предъявлением подтверждающего покупку документа организации, у которой Вы приобрели ПО, в течение 30 (тридцати) дней с момента покупки, если иное не оговорено законодательством страны его приобретения или правилами возврата, действующими в месте приобретения.

1. Определения

«ПО» набор компьютерных программ, баз данных, и документации (на бумажных носителях или в электронной форме) ABBYY FlexiCapture 8.0 Professional, который защищен законами об авторских правах.

«Компонент ПО» означает любую составную часть ПО, включая любые Компьютерные программы в составе ПО.

«Компьютер» означает электронное устройство с одним или более ЦПУ, которое получает информацию в цифровой или аналогичной цифровой форме и обрабатывает её в соответствии с набором инструкций для получения определенного результата.

«Копия ПО» означает копию ПО или Компонента ПО, установленную на Компьютер и функционирующую в соответствии с документацией на ПО.

«Инструментарий для дизайна» означает модуль ABBYY FlexiLayout Studio или ABBYY FormDesigner в составе ПО.

«Лицензия» означает предоставляемое Вам Компанией ABBYY неисключительное право на использование ПО в соответствии с условиями настоящего Лицензионного договора.

«Активация ПО» означает процедуру, при помощи которой установленное ПО переводится в полнофункциональный режим и начинает выполнять все функции в соответствии с документацией на ПО.

«Использование ПО» означает выполнение любых действий, перечисленных в документации на ПО, а также использование любой функции ПО.

«Сопровождение» означает услуги, предоставляемые Вам Компанией ABBYY или ее Поставщиком: обновления и/или новые версии ПО и/или поддержка.

«Поставщик» означает юридическое или физическое лицо, которому Компания ABBYY предоставила право на поставку ПО и/или Сопровождение.

«Компания ABBYY» означает:

компанию ABBYY USA Software House Inc., зарегистрированную по адресу 47221 Fremont Boulevard, Fremont, California 94538, USA, когда применяется статья 21.1 настоящего Лицензионного договора;

компанию ABBYY Europe GmbH, зарегистрированную по адресу Elsenheimerstr. 49, 80687 Munich, когда применяется статья 21.2 настоящего Лицензионного договора;

компанию ABBYY LLC, зарегистрированную по адресу Россия, 109451, Москва, улица Братиславская, когда применяется статья 21.3 настоящего Лицензионного договора;

компанию ABBYY Software House Ukraine, зарегистрированную по адресу Украина, 03680, Киев, улица Дегтяревская 31, когда применяется статья 21.4 настоящего Лицензионного договора;

компанию ABBYY Solutions Ltd., зарегистрированную по адресу Касторос 2, СY 1087, Никосия, Кипр, во всех остальных случаях.

«Группа компаний ABBYY» означает Компания ABBYY вместе со всеми Аффилированными лицами.

«Аффилированное лицо ABBYY» означает организацию, которая прямо или косвенно, через одного или нескольких посредников, управляет, управляется или находится под общим управлением Компании ABBYY.

«Вы» означает любое физическое лицо или организацию, которые получили и/или используют ПО.

2. Предмет договора

2.1. При условии соблюдения Вами настоящего Лицензионного договора Компания ABBYY предоставляет Вам неисключительное ограниченное право («Лицензию») на использование ПО, включая любые изображения, фотографии, анимированные изображения, аудио- и видеокомпоненты, музыку, текст и дополнительные программы, входящие в состав ПО, а также сопроводительные материалы и копии ПО исключительно способами, указанными ниже. Все условия, оговоренные далее, относятся как к ПО в целом, так и ко всем Компонентам ПО в отдельности.

3. Права на ПО

3.1. Компания ABBYY гарантирует, что имеет все необходимые права на лицензирование и распространение ПО (в том числе любых включенных в него графических изображений, фотографий, текстов, анимированных изображений, аудио- и видеокомпонентов, музыки и дополнительных программ), а также сопровождающих ПО печатных материалов и всех копий ПО.

3.2. Все права на материалы, не содержащиеся в ПО, но доступные посредством использования ПО, принадлежат своим законным владельцам и защищены применимыми законами об авторском праве или иными законами и соглашениями об интеллектуальной собственности. Настоящий Лицензионный договор не предоставляет Вам прав на такую интеллектуальную собственность.

3.3. Вы согласны с тем, что ПО защищено от несанкционированного копирования и неограниченного использования и может сопровождаться программными и аппаратными ключами (далее – «Лицензионный ключ») для обеспечения такой защиты.

3.4. Объем Лицензии зависит от ряда факторов, определяемых при покупке: набора функций, разрешенного количества работающих в сети копий ПО, разрешенного количества используемых ЦПУ, разрешенного для обработки количества страниц, окончания срока действия Лицензии и других. Вся эта и другая информация записана в Лицензионном ключе. Лицензионный ключ техническими средствами ограничивает использование ПО объемом Лицензии, которую Вы приобрели.

3.5. ПО содержит коммерческую тайну и иную конфиденциальную информацию, принадлежащую Компании ABBYY и третьим лицам, которая защищена действующим законодательством об авторском праве, включая законодательство США, международные соглашения и применимое законодательство страны использования ПО. Любое использование ПО в нарушение условий настоящего Лицензионного договора рассматривается как нарушение прав Компании ABBYY и/или третьих лиц и является достаточным основанием для лишения Вас предоставленных по настоящему Лицензионному договору прав.

3.6. Вы имеете право один раз передать данное ПО непосредственно другому конечному пользователю. Такая передача должна включать все ПО (все Компоненты ПО, носители и печатные материалы, а также любые полученные Вами новые версии и настоящий Лицензионный договор). Указанная передача не может быть осуществлена косвенно или через какое-либо третье лицо. Лицо, получающее ПО в результате такой единовременной передачи, должно согласиться со всеми условиями настоящего Лицензионного договора, включая обязательство более никому не передавать настоящий Лицензионный договор и само ПО. В случае такой передачи ПО Вы обязуетесь деинсталлировать Компоненты ПО, установленные на всех Ваших Компьютерах или в локальной вычислительной сети.

3.7. Вы не имеете права передавать или продавать ПО третьим лицам, равно как и права, предоставленные Вам по настоящему Лицензионному договору и/или любые другие права на ПО. Компания ABBYY имеет право в одностороннем порядке расторгнуть настоящий Лицензионный договор в случае такой передачи или продажи.

3.8. Настоящий Лицензионный договор не предоставляет Вам никаких прав на товарные знаки, принадлежащие Компании ABBYY.

3.9. Сохранение прав. Компания ABBYY сохраняет за собой все права, которые не предоставлены явным образом настоящим Лицензионным договором.

4. Условия использования

4.1. Вы имеете право использовать ПО в соответствии с объемом Лицензии.

4.2. Вы имеете право установить ПО без Активации ПО на неограниченном количестве Компьютеров.

4.3. Вы имеете право одновременно запускать и использовать такое количество копий ПО, которое разрешено объемом Вашей Лицензии.

4.4. Количество одновременно работающих копий Инструмента для дизайна не должно превышать количества одновременно работающих копий ПО, разрешенных объемом Лицензии.

4.5. Если Вы получаете доступ к ПО через Терминальные Службы (Terminal Services), Вы имеете право одновременно запускать и использовать столько копий ПО, сколько разрешено объемом Лицензии и настоящим Лицензионным договором.

4.6. Вы имеете право использовать ПО для предоставления услуг по распознаванию и конвертации и/или предоставлять третьим лицам результаты, полученные посредством ПО, только если в Вашем Лицензионном ключе есть параметр «BPO services enabled».

4.7. Вы обязуетесь не допускать, предотвращать и компенсировать Компании ABBYY любые потери, связанные с любыми претензиями, обязанностями, действиями, ущербом и/или судебными исками, включая оплату гонораров адвокатам, которые могут быть прямо или косвенно вызваны использованием ПО.

5. Поставка на нескольких носителях

5.1. ПО может поставляться на нескольких носителях, в том числе через Интернет. Независимо от количества носителей, на которых Вы получили ПО, Вы имеете право использовать ПО только в соответствии с условиями настоящего Лицензионного договора.

6. Базы данных Конечного пользователя

6.1. Вы имеете право создавать свои базы данных к программам, входящим в комплект ПО, если такая возможность предусмотрена ПО.

7. Распространение ПО

7.1. Распространение ПО любыми способами за исключением способов, описанных в п. 3.6, запрещено. Распространение включает в себя в том числе продажу ПО, прокат, сдачу ПО внаем или предоставление ПО взаймы.

8. Ограничения

8.1. Вы согласны с тем, что ПО снабжается средствами защиты от несанкционированного копирования и/или использования. Вы не сможете использовать предоставленные Вам настоящим Лицензионным договором права в отношении ПО до тех пор, пока не будет произведена активация Вашей копии ПО. В процессе активации в Компанию ABBYY не передается никаких Ваших персональных данных и сохраняется полная анонимность. В момент активации на основе данных о конфигурации Компьютера создается уникальный параметр. Этот параметр не включает в себя никакой персональной информации, а также никакой информации о программном обеспечении и данных на Компьютере и о модели Компьютера. Этот параметр идентифицирует Компьютер исключительно для целей активации. Кроме этого параметра, в процессе активации на сервер Компании ABBYY передается название, серийный номер и номер версии ПО. Эта информация используется только для того, чтобы правильно выбрать содержание сообщения о результатах активации, и не будет использована ни в каких других целях.

8.2. Все условия и ограничения использования ПО указаны в настоящем Лицензионном договоре, если иное не оговорено в отдельном соглашении между Вами и Компанией ABBYY.

8.3. Если ПО обозначено как «не для продажи» («Not for Resale» или «NFR»), то, независимо от остальных условий настоящего Лицензионного договора, допускается использование такого ПО только в целях демонстрации, проверки или оценки ПО. Вы не имеете права продавать или иным образом с выгодой для себя передавать ПО и/или результаты работы ПО.

8.4. Вы обязуетесь не осуществлять самостоятельно и не разрешать третьим лицам осуществлять следующие действия:

8.4.1. Деассемблировать, декомпилировать (преобразовывать объектный код в исходный текст) ПО (включая программы, базы данных и любые Компоненты ПО), за исключением случаев и только в объеме, явным образом разрешенном применимым законодательством. Если применимое законодательство разрешает подобные действия, любая информация, полученная таким способом, не должна раскрываться третьим лицам, если только такое раскрытие не предусмотрено применимым законодательством, и должна быть незамедлительно сообщена Компании ABBYY. Вся такая информация является конфиденциальной и принадлежит Компании ABBYY.

8.4.2. Модифицировать, адаптировать или переводить ПО, в том числе вносить изменения в объектный код программ или баз данных к ним, за исключением тех изменений, которые вносятся средствами, включенными в комплект ПО и описанными в документации.

8.4.3. Сдавать в аренду, сублицензировать, передавать или уступать права, предоставленные Вам по настоящему Лицензионному договору, и любые другие права, связанные с ПО, третьим лицам, а также разрешать копировать ПО целиком или его части на Компьютеры другого пользователя (за исключением случаев, указанных в п. 3.6 настоящего Лицензионного договора).

8.4.4. Создавать условия для использования ПО лицами, не имеющими прав на использование данного ПО и работающими с Вами в одной многопользовательской системе.

8.4.5. Удалять или делать малозаметными любые уведомления об авторских правах, правах на товарные знаки или патенты, которые указаны на предоставленном Вам ПО.

9. Соблюдение условий Лицензии

9.1. Вы обязуетесь по требованию Компании ABBYY или уполномоченного представителя Компании ABBYY в течение тридцати (30) дней полностью задокументировать и подтвердить факт соблюдения Вами условий настоящего Лицензионного договора.

10. Техническая поддержка

10.1. Компания ABBYY или её Поставщик предоставляет Вам услуги по Сопровождению ПО на условиях, перечисленных в Приложении А к настоящему Лицензионному договору, если иное не оговорено отдельно между Вами и Компанией ABBYY или между Вами и Поставщиком Компании ABBYY.

11. Испытательные версии ПО

11.1. Если версия ПО обозначена как «испытательная» или «демонстрационная» («Try&Buy», «Trial» или «Demo»), то, независимо от остальных условий настоящего Лицензионного договора, до тех пор пока не будет приобретена лицензия на полнофункциональную версию ПО, применяется настоящий раздел. Вы согласны с тем, что ПО имеет ограниченную функциональность и/или ограниченное время работы. ПО предоставляется таким, каково оно есть, и предназначено исключительно для целей предварительного знакомства с ПО. Если срок использования ПО ограничен по времени, то по истечении определенного периода времени, явно указанного в ПО, оно прекратит работать. По истечении данного периода Лицензия прекращает свое действие. Лицензия может быть продлена Компанией ABBYY в случае приобретения Вами у Компании ABBYY лицензии на полную версию ПО.

12. Срок действия и расторжение договора

12.1. Если иное не оговорено отдельно между Вами и Компанией ABBYY или между Вами и Поставщиком Компании ABBYY, настоящий Лицензионный договор действует до момента расторжения его сторонами. Вы можете расторгнуть Лицензионный договор, уничтожив ПО, и сопроводительную документацию и все их копии. Без ущерба другим правам, Компания ABBYY может расторгнуть настоящий Лицензионный договор в случае нарушения Вами условий настоящего Лицензионного договора. В этом случае вы обязаны уничтожить все копии ПО и Компонентов ПО. Такое расторжение настоящего Лицензионного договора не освобождает Вас от обязательств по оплате ПО и/или Сопровождения ПО.

12.2. Пп. 3.3–3.5, 3.8, 3.9, 4.7, 7, 8, 11, 13.2–13.4, 14–21, 23, 24 сохраняют свою силу и после расторжения настоящего Лицензионного договора, однако это не дает Вам права продолжать использовать ПО после расторжения настоящего Лицензионного договора.

13. Гарантии

13.1. Компания ABBYY гарантирует удовлетворительное качество носителей, входящих в комплект ПО (если ПО поставляется на физических носителях), и их работоспособность при обычных условиях использования в течение минимального гарантийного срока, установленного законодательством страны приобретения ПО, начиная с даты приобретения ПО.

13.2. ПО, обновления, новые версии и Сопровождение ПО поставляются «как есть», и Компания ABBYY не предоставляет на них никаких гарантий. Компания ABBYY и её Поставщики не гарантируют и не могут гарантировать производительность и результаты, которые Вы можете получить посредством использования ПО. За исключением гарантий и условий, которые не могут быть исключены или ограничены в соответствии с применимым законодательством, Компания ABBYY и её Поставщики не предоставляют никаких гарантий (явно выраженных или подразумевающихся в статутном или общем праве, обычаях делового оборота или иначе) ни на что, включая, без ограничения, гарантии о соблюдении прав третьих лиц, товарной пригодности, интегрируемости, удовлетворительного качества, годности к использованию для выполнения частных задач. Компания ABBYY также не гарантирует, что ПО не содержит ошибок, будет удовлетворять Вашим требованиям или что ПО будет нормально функционировать при использовании совместно с ПО и оборудованием других производителей. Все риски, связанные с качеством работы и производительностью ПО, возлагаются на Вас.

13.3. Компания ABBYY не предоставляет никаких гарантий относительно программного обеспечения других производителей, которое поставляется вместе или в составе ПО.

13.4. Ограниченная гарантия для пользователей, проживающих в Германии и Австрии.

Если Вы приобрели ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то, в соответствии с законодательством Германии, Компания ABBYY или её Поставщики гарантируют, что ПО предоставляет функциональность, перечисленную в сопроводительной документации (далее – договорная функциональность) в течение ограниченного гарантийного срока, отсчитываемого с момента получения Вами ПО, при условии использования ПО на оборудовании рекомендованной конфигурации. В настоящем пункте термин «ограниченный гарантийный срок» означает 1 (один) год в случае коммерческого использования ПО и для юридических лиц и 2 (два) года в случае некоммерческого использования ПО. Незначительные отклонения от договорной функциональности во внимание не принимаются и не являются основанием для действия вышеуказанной гарантии. Настоящая ограниченная гарантия не распространяется на ПО, предоставленное Вам бесплатно, например, на обновления, предварительные версии, испытательные версии, пробные версии, версии «не для продажи» или на ПО, которое было изменено Вами до такой степени, что в нем появился дефект. Для того чтобы воспользоваться предоставленной гарантией в течение ограниченного гарантийного периода, Вы должны вернуть (за счет Компании ABBYY) ПО продавцу вместе с документом, подтверждающим покупку. В случае если функциональность ПО значительно отличается от договорной функциональности, Компания ABBYY имеет право на выбор по своему усмотрению исправить или заменить ПО. Если проблема не будет устранена, Вы имеете право на скидку (уменьшение первоначальной цены) или на расторжение договора купли-продажи (аннулирование договора). Дополнительную информацию о гарантийных обязательствах можно получить в Службе поддержки пользователей в Германии по адресу: ABBYY Europe GmbH, Elsenheimerstrasse 49, 80687 Munich, tel.: +49 (0)89 51 11 590, fax: +49 (0)89 51 11 5959.

14. Ограниченная ответственность

14.1. Компания ABBYY и её Поставщики ни при каких обстоятельствах не несут перед Вами никакой ответственности за ущерб, вынужденные перерывы в деловой активности, потерю деловых либо иных данных или информации, претензии или расходы, косвенные или случайные убытки, а также упущенную выгоду и утерянные сбережения, вызванные использованием или связанные с использованием ПО, а также за ущерб, вызванный возможными ошибками и опечатками в ПО, даже если представителю Компании ABBYY стало известно о возможности такого ущерба, потерь, претензий или расходов, равно как и за любые претензии со стороны третьих лиц. Вышеперечисленные ограничения и исключения действуют в той степени, насколько это разрешено применимым законодательством. Единственная ответственность Компании ABBYY и её Поставщиков по настоящему Лицензионному договору ограничивается суммой, которую Вы уплатили за ПО и Сопровождение. Никакие условия настоящего Лицензионного договора не ограничивают ответственность Компании ABBYY перед Вами в случае смерти или увечий, вызванных халатностью Компании ABBYY, равно как и ответственность за правонарушение или обман (мошенничество). Компания ABBYY действует от имени своих Поставщиков в том, что касается отказа от, исключения или ограничения обязательств и гарантий по настоящему Лицензионному договору, но ни в каких других случаях. Дополнительную информацию см. в разделе о соответствующей юрисдикции в статье 21 настоящего Лицензионного договора или свяжитесь со службой поддержки пользователей Компании ABBYY.

14.2. Ограниченная ответственность перед пользователями, проживающими в Германии и Австрии.

Если Вы приобрели ПО в Германии или Австрии и обычно проживаете в одной из этих стран, то

14.2.1. С учетом условий п. 14.2.2, ответственность Компании ABBYY и её Поставщиков за убытки ограничивается следующим: (i) Компания ABBYY несет ответственность только в том размере, который можно предвидеть в момент заключения договора купли-продажи для убытков в результате незначительного нарушения существенного контрактного обязательства и (ii) Компания ABBYY не несет ответственности за убытки в результате незначительного нарушения несущественного контрактного обязательства.

14.2.2. Ограничение ответственности, изложенное в п. 14.2.1, не распространяется на обязательную ответственность, предусмотренную законом, в частности, на ответственность по Закону ФРГ об ответственности производителя, на ответственность за предоставление конкретной гарантии и на ответственность за причиненные увечья.

14.2.3. Вы обязуетесь предпринять все разумные меры с целью избежать и сократить ущерб, в частности, делать резервные копии ПО и данных на Вашем компьютере в соответствии с условиями настоящего Лицензионного договора.

15. Встроенные шрифты

15.1. Шрифтовые программы защищаются авторским правом, и их владельцы могут налагать условия на использование шрифтов. Одним из условий может быть необходимость наличия лицензионной версии шрифтовой программы для встраивания шрифтов при создании новых PDF файлов. Компания ABBYY не несет никакой ответственности за любые убытки, вызванные использованием Вами встраиваемых шрифтов.

16. Библиотека Adobe® PDF Library

16.1. «ПО Adobe» означает библиотеку Adobe PDF Library для Windows 2000, XP и сопутствующую документацию, а также любые обновления, измененные версии, дополнения или копии вышеперечисленного. ПО включает в себя ПО Adobe.

16.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Adobe, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора. Вы имеете право сделать одну резервную копию ПО Adobe, входящего в состав ПО, при условии, что резервная копия не устанавливается на другой Компьютер и не используется на другом Компьютере.

16.3. Права на интеллектуальную собственность. ПО Adobe, входящее в состав ПО, является собственностью Adobe и поставщиков Adobe, а его структура, организация и программный код являются производственным секретом Adobe и поставщиков Adobe. ПО Adobe также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО Adobe, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Все копии, которые Вы имеете право сделать в соответствии с настоящим Лицензионным договором, должны включать в себя те же уведомления об авторских правах и о правах собственности, которые содержатся в или на ПО. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Adobe, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО Adobe.

16.4. Лицензия на использование шрифтов. В случае если само ПО или ПО Adobe, входящее в состав ПО, включает шрифты, Вы можете встраивать шрифты или контуры шрифтов в Ваши электронные документы, если такое встраивание разрешено правообладателем шрифтов. Данный комплект может содержать как шрифты, принадлежащие Adobe, так и шрифты, не принадлежащие Adobe. Вы имеете право встраивать любые шрифты, принадлежащие Adobe.

16.5. Гарантия. КОМПАНИЯ ABBYY И ЕЁ ПОСТАВЩИКИ НЕ МОГУТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЮТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО ADOBE, ВХОДЯЩЕГО В СОСТАВ ПО.

16.6. Экспортные ограничения. Вы признаете, что ПО Adobe, входящее в состав ПО, не будет поставляться, передаваться, экспортироваться или использоваться в нарушение закона США «О контроле над экспортом» (The United States Export Administration Act) или иных нормативно-правовых актов, накладывающих экспортные ограничения (все вместе – «экспортные ограничения»). Кроме того, в случае если ПО Adobe, входящее в состав ПО, в экспортных ограничениях определено как продукт, подлежащий экспортному контролю, Вы гарантируете, что не являетесь гражданином страны, на которую наложено эмбарго, не находитесь в такой стране и что экспортными ограничениями Вам не запрещено приобретать ПО Adobe, входящее в состав ПО. В случае несоблюдения Вами условий настоящего Лицензионного договора Вы лишаетесь всех прав на использование ПО Adobe, входящего в состав ПО, предоставленных Вам настоящим Лицензионным договором.

16.7. Товарные знаки. Adobe и Adobe PDF Library являются товарными знаками или зарегистрированными товарными знаками Adobe Systems Incorporated в США и/или в других странах.

17. Microsoft XML Core Services

17.1. В ПО используются сервисы Microsoft XML Core Services (MSXML) для анализа и обработки XML-документов.

17.2. Идентифицированные программы. Лицензия на ПО предоставляется Вам при условии, что Вы обязуетесь (a) не включать Идентифицированные программы в MSXML или комбинировать Идентифицированные программы с MSXML или производными от него продуктами; (b) не распространять Идентифицированные программы вместе с MSXML; и (c) не использовать Идентифицированные программы для разработки программ, производных от MSXML продуктов. «Идентифицированные программы» означает программное обеспечение, лицензируемое на условиях, которые прямо или косвенно (i) вызывают или имеют целью вызвать для Microsoft обязательства в связи с MSXML или производным от него продуктом или (ii) предоставляют или имеют целью предоставить третьим лицам права или иммунитет в связи с правами интеллектуальной собственности или правами собственности Microsoft на MSXML или производного от него продукта. Идентифицированные программы включают в себя без ограничений любое программное обеспечение, которое требует в качестве условия для своего использования, изменения и/или распространения, чтобы иное программное обеспечение, включенное в него, созданное на его основе или распространяемое совместно с ним, (a) распространялось или раскрывалось в форме исходного кода; (b) лицензировалось для целей создания производных продуктов или (c) могло распространяться на безвозмездной основе.

18. Библиотеки PixTools® Scan и драйверы ISIS® Drivers

18.1. «ПО Captiva Software» означает библиотеки Scan, драйверы Level 1 ISIS Drivers, драйверы Level 2 ISIS Drivers, и драйверы Level 3 ISIS Drivers. ПО использует ПО Captiva для осуществления обмена данными между сканером и ПО через интерфейс ISIS.

18.2. Лицензия и ограничения. Компания ABBYY предоставляет Вам неисключительное право использовать ПО Captiva, входящее в состав ПО, в соответствии с условиями настоящего Лицензионного договора.

18.3. Права на интеллектуальную собственность. ПО Captiva, входящее в состав ПО, является собственностью Captiva и поставщиков Captiva, а его структура, организация и программный код являются производственным секретом Captiva и поставщиков Captiva. ПО Captiva также защищено законами США и международными соглашениями об авторском праве. Вы не имеете права копировать ПО Captiva, входящее в состав ПО, за исключением случаев, оговоренных в настоящем Лицензионном договоре. Вы обязуетесь не изменять, не адаптировать, не переводить, не восстанавливать структурную схему и алгоритм работы, не декомпилировать, не деассемблировать и не пытаться иным способом получить исходный код ПО Captiva, входящего в состав ПО. За исключением вышеперечисленного, настоящий Лицензионный договор не предоставляет Вам никаких авторских прав на ПО Captiva.

18.4. Гарантия. КОМПАНИЯ ABBYY И ЕЁ ПОСТАВЩИКИ НЕ МОГУТ ГАРАНТИРОВАТЬ И НЕ ГАРАНТИРУЮТ РЕЗУЛЬТАТЫ, КОТОРЫЕ ВЫ МОЖЕТЕ ПОЛУЧИТЬ ПУТЕМ ИСПОЛЬЗОВАНИЯ ПО ADOBE, ВХОДЯЩЕГО В СОСТАВ ПО. CAPTIVA И ПОСТАВЩИКИ CAPTIVA НЕ НЕСУТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА ПРЯМЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ УПУЩЕННУЮ ВЫГОДУ ИЛИ ПОТЕРЯННЫЕ СБЕРЕЖЕНИЯ, РАВНО КАК И ЗА ПРЕТЕНЗИИ, ПРЕДЪЯВЛЕННЫЕ ТРЕТЬИМИ ЛИЦАМИ.

Некоторые штаты и юрисдикции запрещают исключение или ограничение ответственности за косвенные или специальные убытки, поэтому вышеперечисленные ограничения могут на Вас не распространяться. У Вас могут быть и другие права, которые зависят от штата и юрисдикции.

18.5. Товарные знаки. ISIS и PixTools являются товарными знаками или зарегистрированными товарными знаками Captiva Software Corporation в Соединенных Штатах Америки и/или в других странах.

19. ПО LIZARDTECH

19.1 «ПО LIZARDTECH» означает инструментарий разработчика DjVu Decoder Software Development Kit производства LIZARDTECH, а также любые сопровождающие его носители, печатные материалы и электронную документацию. Вы приобрели ПО, которое включает в себя ПО LIZARDTECH, лицензированное ABBYY у компании LIZARDTECH, INC. ПО использует ПО LIZARDTECH для конвертирования файлов в формате DjVu в файлы изображений.

19.2 ПО LIZARDTECH охраняется законами об авторском праве и международными соглашениями. ПО LIZARDTECH лицензируется, а не продается.

19.3 Лицензия. Вам предоставляется персональная, не подлежащая сублицензированию, не подлежащая передаче другому лицу, неисключительная лицензия на использование ПО LIZARDTECH, интегрированного в ПО (включая сопроводительную документацию). Вы не имеете права сдавать в аренду, продавать или иным образом распространять ПО LIZARDTECH или любую его часть.

19.4 ОТСУТСТВИЕ ГАРАНТИЙ НА ПО LIZARDTECH. ПО LIZARDTECH поставляется «таким, каково оно есть» со всеми ошибками. ВЫ ПРИНИМАЕТ НА СЕБЯ ВСЕ РИСКИ, СВЯЗАННЫЕ С УДОВЛЕТВОРИТЕЛЬНЫМ КАЧЕСТВОМ, ПРОИЗВОДИТЕЛЬНОСТЬЮ, ТОЧНОСТЬЮ И НЕОБХОДИМЫМИ УСИЛИЯМИ (ВКЛЮЧАЯ ОТСУТСТВИЕ НЕБРЕЖНОСТИ). ТАКЖЕ ВАМ НЕ ПРЕДОСТАВЛЯЕТСЯ НИКАКИХ ГАРАНТИЙ НА ТО, ЧТО НИКТО НЕ ПОМЕШАЕТ ВАШЕМУ ВЛАДЕНИЮ ПО LIZARDTECH, И НА ТО, ЧТО ПО LIZARDTECH НЕ НАРУШАЕТ ПРАВ ТРЕТЬИХ ЛИЦ. ЕСЛИ ВЫ ПОЛУЧИЛИ КАКИЕ-ЛИБО ГАРАНТИИ НА ПО ИЛИ НА ПО LIZARDTECH, ТАКИЕ ГАРАНТИИ БЫЛИ ПРЕДОСТАВЛЕНЫ НЕ КОМПАНИЕЙ LIZARDTECH, И КОМПАНИЯ LIZARDTECH НЕ БЕРЕТ НА СЕБЯ НИКАКИХ ОБЯЗАТЕЛЬСТВ В СВЯЗИ С ТАКИМИ ГАРАНТИЯМИ.

ИСКЛЮЧЕНИЕ ОТВЕТСТВЕННОСТИ ЗА ОПРЕДЕЛЕННЫЕ ВИДЫ УЩЕРБА. ЕСЛИ НЕ ЗАПРЕЩЕНО ЗАКОНОМ, КОМПАНИЯ LIZARDTECH НЕ НЕСЕТ НИКАКОЙ ОТВЕТСТВЕННОСТИ ЗА КАКИЕ-ЛИБО КОСВЕННЫЕ, ФАКТИЧЕСКИЕ ЛИБО СЛУЧАЙНЫЕ УБЫТКИ, ВОЗНИКАЮЩИЕ В СВЯЗИ С ИСПОЛЬЗОВАНИЕМ ПО LIZARDTECH ЛИБО ЕГО ФУНКЦИОНИРОВАНИЕМ. НАСТОЯЩЕЕ ОГРАНИЧЕНИЕ ПРИМЕНЯЕТСЯ, ДАЖЕ ЕСЛИ КАКОЕ-ЛИБО СРЕДСТВО СУДЕБНОЙ ЗАЩИТЫ НЕ ДОСТИГНЕТ СВОЕЙ ОСНОВНОЙ ЦЕЛИ.

19.5 Ограничения на обратную разработку, декомпиляцию и деассемблирование. Вы не имеете права восстанавливать структурную схему и алгоритм работы, декомпилировать или деассемблировать ПО LIZARDTECH, за исключением случаев и только в объеме, явным образом разрешенном применимым законодательством.

19.6 Экспортные ограничения. Вы признаете, что ПО LIZARDTECH, любая его часть, любой процесс или служба, которые являются непосредственным продуктом ПО LIZARDTECH (все вышеперечисленное совместно называется «компоненты с экспортными ограничениями»), произведены в США. Вы обязуетесь соблюдать все применимые международные и национальные законы, которые распространяются на такие продукты, включая «Правила Экспортного управления США», а также ограничения на конечных пользователей, на конечное использование и на страны или регионы конечного использования, налагаемые правительством США и правительствами других стран.

20. Эталонные тесты

20.1. Вы не имеете права раскрывать результаты каких бы то ни было эталонных тестов с использованием ПО третьим лицам без предварительного письменного разрешения Компании ABBYY.

21. Экспортные ограничения

21.1. Настоящее ПО не должно экспортироваться или реэкспортироваться в нарушение экспортных ограничений, имеющихся в законодательстве страны, в которой приобретено или получено ПО. Также Вы подтверждаете, что применимое законодательство не запрещает Вам приобретать или получать ПО.

22. Применимое право

22.1. В случае если Вы приобрели ПО на территории США, Канады, Мексики, стран Центральной Америки, Тайваня или Японии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство штата Калифорния (Соединенные Штаты Америки). Все споры в отношении настоящего Лицензионного договора и/или ПО подлежат разрешению в федеральном суде и/или суде штата округа Аламеда или Санта-Клара (штат Калифорния).

22.2. В случае если Вы приобрели ПО на территории Австрии, Бельгии, Великобритании, Германии, Греции, Дании, Ирландии, Испании, Италии, Люксембурга, Нидерландов, Португалии, Финляндии, Франции, Швеции, или на территории любого другого государства, являющегося членом Европейского Союза и не указанного явно в п. 22.3. или 22.4. настоящего Лицензионного договора, а также на территории Исландии, Лихтенштейна, Норвегии, Нормандских островов или Швейцарии, к отношениям по настоящему Лицензионному договору применяется законодательство, действующее в г. Мюнхен (Германия). Все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в суде г. Мюнхен (Германия).

22.3. В случае если Вы приобрели ПО на территории России, Белоруссии, Казахстана, или другого государства, являющегося членом Содружества Независимых Государств (СНГ), за исключением Украины и Молдовы, а также на территории Латвии, Литвы и Эстонии, к отношениям по настоящему Лицензионному договору применяется действующее законодательство Российской Федерации.

22.4. В случае если Вы приобрели ПО на территории Албании, Болгарии, Боснии и Герцеговины, Венгрии, Израиля, Кипра, Македонии, Мальты, Польши, Румынии, Словакии, Словении, Турции, Хорватии, Чехии, Сербии, Черногории, Украины или Молдовы, к отношениям по настоящему Лицензионному договору применяется действующее законодательство Украины.

22.5. В случае, если ПО было приобретено в стране, указанной в п.22.3., и Вы являетесь юридическим лицом или индивидуальным предпринимателем, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в арбитражном суде г. Москва, Российская Федерация. В случае, если ПО было приобретено в стране, указанной в п.22.3., и Вы являетесь физическим лицом, все споры, вытекающие из настоящего Лицензионного договора, подлежат разрешению в Люблинском районном суде г. Москвы, Российская Федерация.

22.6. В случаях, описанных в пп.22.1-22.4, к отношениям по настоящему Лицензионному договору не применяются никакие коллизионные нормы, а также конвенции ООН, регламентирующие обязательства, вытекающие из договоров международной купли-продажи.

22.7. Если ПО было приобретено в стране, не указанной в пп.22.1-22.4, к отношениям по настоящему Лицензионному договору применяется действующее законодательство страны, в которой Вы приобрели ПО.

22. Прочие условия

22.1. В случае если Вы получили настоящую копию ПО в качестве улучшения текущей версии ПО или в качестве обновления ПО до новой версии, устанавливая эту копию ПО Вы добровольно отказываетесь от Ваших прав в связи с любыми предыдущими версиями ПО, включая право на использование ПО. Вы согласны с тем, что любые обязательства Компании ABBYY или её Поставщика по поддержке предыдущих версий ПО заканчиваются в момент появления настоящей копии ПО.

22.2. В случае если Вы приобрели или получили ПО, включая ПО «не для продажи» («Not for Resale») и/или ПО, обозначенное как «обновление» («Upgrade»), через Интернет, Компания ABBYY не передает Вам никаких печатных материалов, включая руководство пользователя.

23. Использование программного обеспечения правительственными учреждениями

23.1. В случае если данное ПО используется правительством США или правительственными учреждениями США, применяются следующие дополнительные условия: (1) ПО предоставляется с ограниченными правами, как это определено в статье «Права в области данных - Общие» «Правил закупки для федеральных нужд» (52.227-14); (2) любое использование, воспроизведение или раскрытие программного обеспечения правительством подпадает под ограничения подпараграфа (c) (1) (ii) статьи «Права в области технических данных и программного обеспечения» «Правил закупки для оборонных нужд» (252.227-7013).

24. Общие положения

24.1. В случае если какая-либо часть настоящего Лицензионного договора будет признана утратившей юридическую силу и не подлежащей исполнению, остальные части Лицензионного договора сохраняют свою юридическую силу и подлежат исполнению. Ни при каких условиях настоящий Лицензионный договор не может ущемлять законные права потребителей.

Приложение A

Соглашение о сопровождении ПО

Настоящее Приложение А является неотъемлемой частью Лицензионного договора, если только иное не оговорено в отдельном договоре с Компанией ABBYY.

1. Определения

1.1. «Обновление» – улучшения текущей версии ПО.

1.2. «Новая версия» – следующая по порядку версия ПО, которая выпускается взамен основной версии используемой Вами на основании Лицензионного договора (например, версия 2.x заменит собой версию 1.x).

1.3. «Ошибка» – любая неспособность ПО выполнять функции, перечисленные в документации. Возможны следующие три типа ошибок:

1.3.1. Ошибка с приоритетом 1 – проблемная ситуация, в которой нет способа обойти проблему, в результате чего производственный процесс на Вашем предприятии останавливается, в том числе ошибки, сопровождающиеся сообщениями «Внутренняя программная ошибка», «Нехватка памяти», «Нарушение прав доступа», «Общее нарушение защиты», «Общая ошибка защиты» и «Деление на ноль»;

1.3.2. Ошибка с приоритетом 2 – ошибка, которую можно обойти;

1.3.3. Ошибка с приоритетом 3 – незначительная проблема, не сказывающаяся на производственном процессе на Вашем предприятии.

1.4. «Услуги по поддержке» – услуги, предоставляемые Вам Компанией ABBYY или Поставщиком с целью устранить Ошибки, о которых Вы сообщили.

1.5. «Подписка на Новые версии» – часть Сопровождения, которая дает Вам право на получение Новых версий.

2. Сопровождение ПО

2.1. Сопровождение ПО может включать в себя предоставление Обновлений, Подписки на Новые версии и Услуг по поддержке или любой комбинации вышеперечисленного. Минимальный первоначальный период, на который Вы можете приобрести Сопровождение ПО, составляет двенадцать (12) месяцев с даты отправки или доставки ПО. Для продления периода Сопровождения, необходимо оплатить Компании ABBYY или Поставщику пролонгацию периода Сопровождения. Компания ABBYY сохраняет за собой право по своему усмотрению изменять форму и содержание Сопровождения ПО. Любой дополнительный код ПО, предоставленный Вам как часть Сопровождения ПО, является частью ПО, и на него распространяются все условия настоящего Лицензионного договора.

3. Новые версии и Обновления

3.1. Новые версии и Обновления должны поставляться на компакт-дисках или по каналам передачи данных (посредством протокола FTP). Затраты на транспортировку, если таковые будут, должны оплачиваться Вами.

3.2. В случае если Вы приобрели Сопровождение в форме Обновлений, Вы имеете право на получение Обновлений от Компании ABBYY или Поставщика. Компания ABBYY или ее Поставщики обязуются предоставлять Вам Обновления для ПО по мере их появления.

3.3. В случае если Вы приобрели Сопровождение в форме Новых версий, Вы имеете право на получение Новых версий от Компании ABBYY или Поставщика. Компания ABBYY или ее Поставщики обязуются предоставлять Вам Новые версии ПО по мере их появления.

3.4. В случае если Вы разработаете приложение, которое включает в себя ПО, части ПО или интегрируется с ПО, любая новая главная версия такого приложения должна включать в себя последнее Обновление для ПО, предоставленное Вам Компанией ABBYY не ранее чем за три (3) месяца до выпуска такой главной версии (либо самой последнее Обновление, если последнее Обновление было выпущено более чем за три (3) месяца до выпуска такой главной версии).

4. Услуги по поддержке

4.1. ABBYY или Поставщик обязуется предоставлять бесплатные Услуги по поддержке для исправления Ошибок с приоритетом 1.

4.2. В случае если Вы приобрели Сопровождение в форме Услуг по поддержке, ABBYY или Поставщик обязуется предоставить Услуги по поддержки не более чем для восьми (8) запросов, касающихся Ошибок с приоритетами 2 и 3. Услуги по поддержке для дополнительных запросов в связи с Ошибками с приоритетами 2 и 3 должны приобретаться дополнительно.

4.3. ABBYY или Поставщик предоставляет Услуги по поддержке ПО в течение рабочего дня по телефону или по электронной почте.

4.4. ABBYY или Поставщик обязуется предпринимать разумные усилия для выпуска экстренных Обновлений для ПО, не предусмотренных планом выпуска, для устранения любых Ошибок с приоритетом 1, о которых им было сообщено. В остальных случаях Ошибки с приоритетами 2 и 3 могут исправляться по мере выхода новых версий. Экстренные Обновления должны выпускаться только для текущей версии ПО с целью исправления Ошибок с приоритетом 1.

4.5. При сообщении об Ошибках Вы обязуетесь предоставлять ABBYY или Поставщику информацию, которая необходима для идентификации Ошибки. Такая информация включает в себя описание проблемы, указание платформы и операционной системы, на которых произошла Ошибка, копию входных данных, которые вызвали Ошибку, копию файла формата, который использовался в момент обнаружения Ошибки, и все дампы, которые были сделаны в результате Ошибки. ABBYY или Поставщик может использовать вышеперечисленную информацию в своих коммерческих целях, в том числе для поддержки и разработки продуктов, при условии что ABBYY или Поставщик не использует такую информацию в любой форме, которая позволяет идентифицировать Вашу личность.


Основные свойства поля

Основные свойства поля можно задать на закладке Общие.

Тип поля отображается на этой закладке в виде пиктограммы справа от имени.

  • Название поля – название поля. Название задается автоматически при создании поля и соответствует пояснительному тексту, расположенному наиболее близко от поля. При редактировании свойств, вы можете изменить название, присвоенное по умолчанию. См. также Как изменить название поля.
  • Заголовок – название поля, которое отобразится в форме данных.
  • Экспортировать значение поля – эта опция должна быть отмечена, если нужно экспортировать значение поля (отмечено по умолчанию). Отключение этой опции может понадобиться, если, например, значение этого поля используется для получения значения вычисляемого поля (см. Проверка с помощью правил), и нужно экспортировать только конечный результат.
  • Показывать в Форме данных – эта опция должна быть отмечена, если поле должно быть видимым в форме данных (отмечено по умолчанию).
  • Не может быть пустым – отметьте эту опцию, если вы хотите, чтобы заполнение этого поля было обязательным.
  • Только для чтения – отметьте эту опцию, если поле должно быть доступно только для просмотра, то есть оператор не сможет изменить его значение. Вы можете отметить эту опцию для полей, значение которых должно вычисляться автоматически, с помощью правила, например, для поля, в котором планируется сохранять сумму или объединение других полей (см. Проверка с помощью правил).
  • Индексное поле – отметьте эту опцию, если предполагается производить индексацию документов по этому полю. При обработке документов вы сможете отобразить значение этого поля для каждого документа, производить сортировку и поиск документов по значению поля.
  • Комментарии – вы можете ввести любые комментарии.

Свойства полей


Глоссарий

A-Z

ABBYY FlexiCapture

Программное решение для потокового ввода данных с документов различного типа - структурированных (жестких форм), частично структурированных (гибких форм и документов) и неструктурированных (документов в свободном стиле).

ABBYY FlexiLayout Studio

Программа, позволяющая создать описание структуры документа произвольного формата, необходимое для его дальнейшего автоматического распознавания.

ABBYY FormDesigner

Программа ABBYY FormDesigner предназначена для создания макетов машиночитаемых форм, которые после тиражирования и заполнения планируется обрабатывать с помощью системы автоматизированного ввода форм ABBYY FlexiCapture. Разработка макета формы является важным этапом, так как от "правильности" разработанного макета (его машиночитаемости) зависит эффективность всех последующих этапов обработки: сканирования, распознавания, проверки и экспорта.

ADF

Automatic Document Feeder. Устройство для автоматической подачи бумаги, позволяющее отсканировать большое количество документов без дополнительного вмешательства оператора.

dpi

Dots per Inch. Количество точек на дюйм; единица измерения разрешения.

FlexiLayout

Описание структуры гибкого документа. Это описание разрабатывается в программе ABBYY FlexiLayout Studio и передается в ABBYY FlexiCapture. FlexyLayout – своего рода «инструкция» о том, как следует искать и идентифицировать поля на гибкой форме.

OCR

Optical Character Recognition. Оптическое распознавание типографских текстов.

OMR

Optical Mark Recognition. Оптическое распознавание меток. Так называется технология, позволяющая ABBYY FlexiCapture не только уверенно распознавать на формах обычные метки (галочки, крестики, и т.п.), но и правильно идентифицировать метки, отмеченные по ошибке и затем полностью закрашенные.

ICR

Intelligent Character Recognition. Так называют технологии или системы, предназначенные для массовой обработки документов, заполненных печатными буквами и цифрами от руки, то есть для распознавания рукопечатных символов.

XFD

XML Form Definition (*.xfd) – специальный формат файла формы, созданной в программе ABBYY FormDesigner. Файл формата XML Form Definition используется для создания шаблона документа в программе ABBYY FlexiCapture.

А

Администратор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит настройка программы для ввода документов: создание и редактирование шаблонов документов, профилей импорта. См. Режимы работы администратора и оператора.

Алфавит

Набор символов, используемых в описываемом языке.

Б

Буквы в гребенке

Тип разметки текста, при которой ограничителем текста является гребенка. Показать...

Буквы в изолированных рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки изолированы друг от друга. Показать...

Буквы в рамках

Тип разметки текста, при которой ограничителем каждого символа является рамка; рамки не изолированы друг от друга. Показать...

В

Верификация

Проверка распознанных данных оператором. Производится путем сравнения результатов распознавания с исходным изображением части документа. Технология верификации реализована в продуктах ABBYY с учётом основных психосоматических особенностей человека: выработки привычек, использования навыков, целостности и целенаправленности восприятия. См. Верификация распознанных данных.

Ввод форм

Извлечение данных из информационных полей форм.

Г

Гибкий документ

Документ, содержащий набор информационных полей, оформление, количество и расположение которых может значительно отличаться в разных экземплярах документа. См. Типы документов, обрабатываемых с помощью программы ABBYY FlexiCapture 8.0.

Гибкий шаблон

Шаблон документа или раздела, разработанный для обработки гибких документов. Создается путем подключения гибкого описания. Поля такого шаблона не имеют фиксированного местоположения, их поиск производится с помощью гибкого описания. См. Создание шаблона для обработки гибких документов.

Гибкое описание

Формализованное описание структуры документа, нацеленное на поиск местоположения полей. Создается в ABBYY FlexiLayout Studio. Файл формата *.afl. См. FlexiLayout.

Горячая папка

Каталог на жестком диске локального или удаленного компьютера, используемый для импорта изображений. Как правило используется для многократной периодической загрузки изображений без участия пользователя. См. Профили импорта изображений.

Группа меток

Элемент машиночитаемой формы, объединяющий несколько меток, находящихся вблизи друг от друга. В Группе меток может выбираться одна или несколько меток.

Групповая верификация

Режим верификации, при котором одинаково распознанные символы поступают на верификацию группой. Подробнее...

    На групповую верификацию подаются поля, в свойствах которых отмечена опция Включить в групповую верификацию.

    Целесообразно подавать на групповую верификацию символы из полей, которые заполняются цифрами, а также метки.

Д

Данные из документа

Данные, полученные в результате обработки (распознавания, проверки и редактирования результатов распознавания) изображений страниц документа.

Документ

Совокупность одного или нескольких изображений страниц и извлеченной из них информации.

Ж

Жесткая форма

Документ, имеющий заданные информационные поля, оформление, количество и местоположение которых строго определены и не меняются от одного экземпляра документа к другому.

Жесткий шаблон

Шаблон документа или раздела документа, разработанный для обработки жестких форм. Поля жесткого шаблона имеют фиксированное расположение.

З

Замена изображения

Замена одного изображения другим при редактировании шаблона.

Запрещенный символ

Символ, который заведомо не может встретиться в определяемом типе данных. Подробнее...

    Указание таких символов может существенно увеличить скорость и надежность распознавания. Например, при распознавании текстов, в которых встречаются только заглавные буквы, в качестве запрещенных следует указать все строчные буквы.

И

Игнорируемый символ

Символ, встречающийся внутри слов (например, маркер (bullet)) или символ мягкого переноса (табуляции и т.д.), наличие которого не мешает слову принадлежать к определяемому типу данных. Подробнее...

    Эти символы исключаются из слов, т.о. принадлежность указанному типу данных определяется для слов без этих символов.

Идентификатор

Статический элемент, который используется для однозначного выбора шаблона среди нескольких с одинаковым расположением реперов. В свойствах таких статических элементов должна быть отмечена опция Использовать для идентификации шаблона.

Идентификация шаблонов

Процесс выбора нужного шаблона с помощью идентификаторов.

Изображение

Электронный образ страницы бумажного документа, полученный в результате сканирования.

Инвертированное изображение

Изображение, текст которого напечатан на темном фоне светлыми буквами.

Индексное поле

Поле, по значению которого производится индексация документов для сортировки и поиска. См. Индексные поля.

Импорт изображений

Добавление в пакет изображений для обработки. Импорт может производиться путем добавления изображений из файлов, путем сканирования или с использованием профилей импорта. См. Добавление изображений страниц.

Исправленная метка

Метка, отмеченная по ошибке, и с целью исправления полностью заштрихованная. В случае если у поля метки включена опция Допускать исправления, то программа распознает заштрихованную метку как незаполненную.

К

Картинка

Элемент машиночитаемой формы, не подлежащий распознаванию и предназначенный для экспорта в виде графического объекта (например, файла).

Ключевое поле

Поле, позволяющее автоматически проверить сборку страниц в документы. Значения ключевых полей должны совпадать на всех страницах одного документа.

Контекстная верификация

Режим верификации, при котором распознанные символы поступают на верификацию в контексте поля. Подробнее...

    В режиме контекстной верификации неуверенно распознанные символы проверяются в контексте всего поля.

    На контекстную верификацию подаются поля, в свойствах которых отмечена опция Включить в контекстную верификацию. Целесообразно подавать на контекстную верификацию те поля, область значений которых известна или легко определяется. Например, таким полем может быть название страны, города: нам известно, какие значения могут встретится в данном поле.

Контрастность

Соотношение яркости самой темной и самой светлой области изображения.

Крест

Репер в виде креста.

М

Матричный принтер

Тип распознаваемого текста, представляющий собой текст, напечатанный на матричном принтере.

Машиночитаемая форма

Форма, специально изготовленная для целей автоматического ввода, которая содержит служебные элементы (реперы, штрих-коды, линии и т.д.), необходимые для ее успешной обработки.

Метка

Элемент машиночитаемой формы, в который при заполнении вносится отметка (галочка, крест, точка, сплошная закраска и т.д.).

Многостраничный документ

Документ, состоящий из нескольких страниц.

Множество допустимых символов

Набор символов, встречающихся в определяемом типе данных. Подробнее...

    Этот набор определяется типом данных. Т.е. тип данных, подключенный к полю, определяет множество символов, используемых при распознавании.

    Помимо непосредственного выбора символов, входящих в это множество, возможно задать дополнительные параметры, его ограничивающие. Например, можно указать:

    • Символы, которые заведомо не могут встретиться при распознавании данного поля, - запрещенные символы (например, для поля, в котором могут быть только заглавные символы, в качестве запрещенных могут быть указаны все строчные буквы).
    • Символы, которые могут встречаться внутри слов, но при этом не влияют на проверку этого слова - игнорируемые символы (например, знаки слогоделения, ударения и т.д.)

Моноширинный текст

Тип разметки текста, при котором под каждую букву слова отводится одинаковая по высоте и ширине рамка, но границы рамки при сканировании исчезают.

Н

Наложение шаблона

Процесс подбора шаблона и наложение полей шаблона на изображение.

Нераспознаваемый регион

Область изображения, исключенная из распознавания. Нераспознаваемый регион нужен для исключения области с пояснительным текстом или рисунком, мешающим распознаванию поля. См. Исключение региона из распознавания.

Неструктурированный документ

Документ, содержащий информацию, изложенную в свободном стиле. Например, контракты, письма, приказы, графики являются неструктурированными документами. См. Обработка неструктурированных документов.

Неуверенно распознанный символ

Статус, присваиваемый символу автоматически в процессе распознавания, если он был распознан со значительной долей неуверенности.

О

Область поля

Область изображения, выделенная в шаблоне и предназначенная для извлечения информации.

Ограничитель текстовых полей

Графический элемент, ограничивающий текстовое поле: рамка, гребенка, линия.

Оператор

Пользователь программы ABBYY FlexiCapture, в обязанности которого входит ввод документов: добавление изображений, распознавание, верификация, экспорт распознанных данных. См. Режимы работы администратора и оператора.

Ориентация страницы

Расположение страницы относительно правильного расположения: сверху вниз, слева направо. Ориентация страницы может быть автоматически определена при распознавании изображения страницы; с этой целью в программе ABBYY FlexiCapture 8.0 предусмотрено задание возможной ориентации.

Ориентация текста

Направление текста в поле относительно расположения страницы.

Очистка изображения

Удаление с изображения отдельных мелких черных точек. Лишние точки могут появиться в процессе сканирования и для качественного распознавания данных их лучше удалить. Также при очистке изображения происходит удаление точек фона или ограничительных линий с растровых форм.

Ошибка документа

Если в процессе обработки документа выясняется, что его данные не полностью соответствуют структуре документа и заданным ограничениям на значения полей, а также контрольным правилам, то все несоответствия заносятся в список ошибок и предупреждений документа.

П

Пакет документов

Совокупность документов, сгруппированная пользователем. Обычно пакет соответствует пачке документов, отсканированных за один раз, или импортированных из определенного каталога. См. Пакеты документов.

Пишущая машинка

Тип распознаваемого текста, представляющий собой текст, написанный на пишущей машинке.

Поворот изображения

Поворот изображения вокруг его центра.

Поле

Элемент документа, предназначенный для извлечения данных. Поля могут быть простыми (не имеющими внутренней структуры) или составными, как, например, поле типа «таблица», где каждая ячейка также может рассматриваться как отдельное «дочернее» поле таблицы. См. Создание полей шаблона документов.

Поле без разметки

Поле, определенное в шаблоне документа, но не имеющее области на изображении. См. Поля без разметки.

Поле Группа Меток

Поле шаблона документа, содержащее группу меток.

Поле для ручного ввода

Поле шаблона, содержащее нераспознаваемый текст (например, состоящий из слитных букв), который необходимо ввести с клавиатуры.

Поле Картинка

Поле шаблона, содержащий картинку.

Поле Метка

Поле шаблона, содержащее метку.

Поле с несколькими областями

Поле, состоящее из нескольких областей на изображении. Области такого поля могут располагаться на расстоянии друг от друга, даже на разных страницах. Значения из всех областей одного поля объединяются и экспортируются вместе, как одно поле. Обычно используется для объектов, расположенных на нескольких страницах, например, для больших таблиц. См. Поля с несколькими областями.

Поле с несколькими экземплярами

Поле, используемое для описания нескольких объектов одинакового типа (повторяющихся объектов). По сути, эти объекты являются одним и тем же полем, и обладают общими свойствами, но их несколько. Для того чтобы не создавать несколько одинаковых полей, используются поля с несколькими экземплярами. Поля с несколькими экземплярами экспортируются в отдельные файлы или таблицы базы данных. См. Поля с несколькими экземплярами.

Поле Таблица

Поле шаблона, содержащее таблицу. Это составное поле, каждый столбец таблицы представляет собой набор полей одного типа: текст, метки, штрих-коды или картинки.

Поле Штрих-код

Поле шаблона, содержащее штрих-код, предназначенный для распознавания.

Пользовательский тип данных

Тип данных, созданный пользователем. См. Создание пользовательских типов данных.

Потоковый ввод данных

Автоматизированное извлечение данных из аналоговых (печатных) и цифровых (отсканированных изображений в файлах) документов.

Потоковый ввод документов

Автоматизированный перевод бумажных документов в электронный вид.

Пояснительный текст

Элемент машиночитаемой формы, представляющий собой описательный текст (название формы, названия полей, пояснения к полям и т.д.)

Правила

Некоторые условия, накладываемые на данные в полях и автоматически проверяемые программой. См. Проверка с помощью правил.

Приложение

Страницы, не содержащие полей, но участвующие в сборке документа. Из этих страниц не извлекаются данные, но они могут быть сохранены в виде изображения или PDF с возможностью поиска. См. Создание шаблонов для документов с приложениями.

Проверка правил

Автоматическая проверка распознанных данных на соответствие заданным правилам. См. Верификация правил.

Проект

Проект – это единая среда, объединяющая пакеты документов и настройки, необходимые для их обработки, такие как шаблоны документов, профили импорта и другие. См. Создание проекта.

Простой текст

Тип разметки текста, при котором текст вписывается в блок без каких-либо ограничителей.

Профиль импорта

Совокупность настроек, используемых для добавления в пакет изображений: источник импорта, опции обработки изображений, опции очистки горячей папки и др. См. Профили импорта изображений.

Публикация шаблона

Предоставление доступа к новой версии шаблона документов после редактирования. Опубликованная версия участвует в обработке документов из рабочих пакетов, в то время как неопубликованная, локальная версия, может участвовать только в обработке шаблонов из тестовых пакетов. См. Редактирование и публикация шаблона.

Р

Рабочие пакеты

Пакеты документов, предназначенные для ввода данных. Для обработки рабочих пакетов используются только опубликованные шаблоны документов. См. Пакеты документов.

Раздел шаблона документа

Набор страниц (или одна страница) и полей, находящихся на них, соответствующий логически законченной части документа. Разделы документа могут описываться "жестким" или "гибким" шаблоном. См. Создание шаблонов для многостраничных документов.

Разделитель

Элемент машиночитаемой формы, представляющий собой вертикальную или горизонтальную линию.

Разметка страницы

Схема расположения полей на изображении.

Разметка текста

Способ оформления области страницы, предназначенной для ввода текста. Примеры разметки текста см. в статье Поле для ввода.

Разрешение

Параметр изображения. Измеряется количеством точек, приходящихся на дюйм изображения.

Распознавание

Нахождение соответствия элементов изображения определенным символам.

Распознавание меток (OMR)

Определение наличия отметки в поле метки на форме.

Распознавание текста (OCR, ICR)

Перевод графического изображения в текстовый вид.

Распознавание штрих-кода

Перевод графического изображения штрих-кода в числовой или текстовый вид.

Растровая линия

Линия, состоящая из точек, расположенных на одинаковом расстоянии друг от друга.

Растровая форма

Форма, на которой информационные поля выглядят как белые прямоугольники на сером фоне, состоящем из растровых линий, или как прямоугольники, ограниченные растровыми линиями.

Регулярное выражение

Описание структуры слова или любого вводимого значения на специальном языке. Таким образом, можно определить не только набор допустимых символов, но и структуру содержимого поля. Описать структуру с помощью регулярного выражения можно при задании ограничений для текстового поля или при создании пользовательского типа данных. См. Алфавит, используемый в регулярных выражениях.

Репер

Статический элемент, представляющий собой черный квадрат, прямоугольник, крестик или уголок, и предназначенный для наложения шаблона. Подробнее...

    Реперы - это специальные элементы дизайна формы, по которым система производит "привязку к местности" после сканирования (выравнивает перекос, компенсирует линейные и нелинейные дефекты сканирования, вычисляет расположение блоков). Наиболее надежными реперами служат черные квадраты, расположенные, как правило, по углам формы. При отсутствии на изображении специальных реперов, для наложения шаблона могут использоваться другие статические элементы: разделители, то есть вертикальные или горизонтальные линии, такие как линии таблиц, оформляющие рамки и т.д., или четкий статический текст, а именно: заголовок формы, подписи к полям, пояснительная информация и т.д. У статических элементов, служащих для наложения шаблона, должно быть отмечено свойство Использовать для наложения шаблона.

Реперный текст

Статический элемент, представляющий собой текст, присутствующий на незаполненной форме и не предназначенный для извлечения информации. Это может быть любой пояснительный текст или заголовок. Реперный текст может использоваться для наложения шаблона и для идентификации.

Реперный штрих-код

Статический элемент, представляющий собой штрих-код, не предназначенный для извлечения информации. Реперный штрих-код может использоваться для наложения шаблона и для идентификации.

Рукопечатный текст

Тип распознаваемого текста, представляющий собой текст, написанный от руки раздельными буквами..

С

Серая фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на сером фоне, исчезающем при сканировании.

Сканирование

Процесс получения электронного образа страницы бумажной формы с помощью сканера.

Словарь

Список слов, используемый при определении конкретного типа данных. Подробнее...

    Словарь указывается при создании типа данных. Таким образом, тип данных, подключенный к полю, определяет используемый при распознавании и проверке словарь. Помимо существующих предопределенных типов данных с готовыми словарями, программа позволяет подключать типы данных, созданные на основе пользовательских словарей. Данные для словаря могут быть введены вручную или загружены из текстового файла.

Статические элементы

Нераспознаваемые элементы, служащие для наложения шаблона и идентификации. Такими элементами являются: реперы, реперный текст, разделители, реперные штрих-коды.

Стиль написания

Манера написания, присущая определенной группе людей, например американская манера написания цифр. Подробнее...

    Опция, которая задает стиль написания рукопечатных букв в формах. Стиль зависит от региона, в котором формы были заполнены (Россия, Германия, Чехия, США, и т.д.).

Страница

Изображение страницы бумажного документа и результаты его обработки.

Т

Таблица

Данные, расположенные по двумерной сетке, не обязательно видимой. В программе обрабатываются таблицы, состоящие из столбцов, каждый из которых содержит данные одного типа, и повторяющихся строк.

Текст в рамке

Тип разметки текста, при котором ограничителем текста является рамка. Показать...

Текст в рамке с гребенкой

Тип разметки текста, при котором ограничителем текста является рамка с нижней границей в виде гребенки. Показать...

Текст на линии

Тип разметки текста, при котором ограничителем текста является линия снизу. Показать...

Текстовое поле

Элемент машиночитаемой формы, предназначенный для ввода текста при заполнении формы.

Тестовые пакеты

Пакеты документов, предназначенные для тестирования и отладки шаблонов. Для обработки тестовых пакетов используются локальные копии шаблонов документов. См. Пакеты документов.

Тип данных

Признак поля, описывающий известные ограничения на возможное значение поля и используемый при его распознавании для уменьшения числа возможных вариантов распознавания. Подробнее...

    Одной из характеристик поля является тип данных: число, дата, текст, фамилия, имя, адрес и т.д. Тип данных определяет множество слов, которые могут встречаться в данном поле.

    Тип данных является важным параметром распознавания, влияющим на качество распознавания. Правильно указанный тип данных может существенно уменьшить количество неуверенно распознанных символов.

Типографский текст

Тип распознаваемого текста, представляющий собой текст, полученный типографским способом или с помощью лазерного или струйного принтера с разрешением не менее 300 точек на дюйм.

У

Уголок

Репер в виде уголка.

Ф

Файл описания

Сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. Подробнее см. Файл описания.

Форма

Документ, состоящий из одной или нескольких страниц и предназначенный для заполнения человеком от руки или любым печатным способом.

Ц

Цветная фоновая форма

Форма, все информационные поля которой выполнены в виде белых прямоугольников на цветном фоне, исчезающем при сканировании.

Ч

Черный квадрат

Репер в виде черного квадрата.

Черно-белая линейчатая форма

Форма, границы информационных полей которой задаются обычными линиями, не исчезающими при сканировании.

Ш

Шаблон документа

Шаблон документа определяет принципы, по которым будет происходить идентификация и обработка документов данного типа, и содержит:

  • Структуру документа, т.е. описание допустимой последовательности страниц, которая образует документ данного типа. Структура документа задает правило сборки документа.
  • Шаблоны разделов документа.
  • Список правил, которым должны удовлетворять данные полей.
  • Расположение полей и подписей к ним в окне "Данные" (вид формы данных).
  • Настройки экспорта для документов данного типа.
  • Настройки процесса обработки документов данного типа.

Шаблон раздела документа

Составная часть шаблона документа. Соответствует одной или нескольким страницам, содержащим логически завершенный набор полей. Поля внутри одного раздела могут переходить с одной страницы на другую (например, многостраничные таблицы), а наборы полей разных разделов не пересекаются.
Шаблон раздела может быть гибким, либо жестким.

Штрих-код

Элемент машиночитаемой формы, представляющий собой штриховые знаки, кодирующие цифровую информацию посредством чередующихся полос черного и белого цвета определенной длины. Штрих-код в документе может предназначаться для извлечения информации (поле штрих-код) или для наложения или идентификации шаблона (реперный штрих-код).

Э

Экспорт

Процесс передачи обработанных данных во внешнюю информационную систему или файл.

Эталон текста

Файл, содержащий образцы начертания всех символов алфавита.

Я

Язык (регион)

Свойство поля, определяющее язык написания и соответствующие ему наборы региональных параметров (например, способ написания даты или адреса).

Яркость

Порог световой чувствительности, определяющий, начиная с какого значения полутона шкалы градаций серого будут восприниматься сканером как белый цвет.


Глоссарий

A-Z А Б В Г Д Ж З И К М Н О П Р С Т У Ф Ц Ч Ш Э Я


Файл описания

Файл описания – сопроводительный файл, который используется для определения принципа формирования пакета при добавлении изображений из Горячей папки. В зависимости от формата файла описания, отличается набор файлов для формирования пакета.

В программе используются файлы описания следующих типов:

  1. Captiva QuickScan
    В пакет добавляются все файлы изображений, перечисленные в сопроводительном файле. Порядок следования файлов соответствует порядку в сопроводительном файле.
  2. Capture Software for Kodak
    В пакет добавляются файлы изображений, находящиеся в папке Kodak-пакета, указанной в сопроводительном файле, в порядке возрастания имен.
  3. Пустой файл
    Содержимое такого файла не имеет значения. Из Горячей папки в пакет добавляются все файлы, которые по имени идут раньше сопроводительного файла, в порядке возрастания имен.
  4. Файл XML
    Файл в xml-формате с документированной структурой. Предназначен для случаев, когда три предыдущих типа файлов не подходят, но есть возможность генерировать собственный файл сопровождения. В пакет добавляются файлы изображений, указанные в сопроводительном файле.

    Структура файла:

    Файл XML должен содержать корневой элемент Batch с дочерними элементами Images.

    Элемент Images, в свою очередь, должен включать в себя элементы Image, количество которых соответствует количеству страниц в создаваемом пакете. Каждый элемент Image должен в качестве значения содержать путь в формате UNC к файлу соответствующего изображения. Путь к папке, содержащей данное изображение, должен быть одинаковым для всех элементов Image.

    <Batch>

    ...

    <Images>
    <Image>\\HotFolder\Page1.tif</Image>
    <Image>\\HotFolder\Page2.tif</Image>
    <Image>\\HotFolder\Page3.tif</Image>

    </Images>

    </Batch>

    Программу сканирования рекомендуется настроить таким образом, чтобы отсканированные изображения помещались в саму горячую папку или ее подпапки первого уровня. При создании пакета в него будут добавлены все изображения, пути к которым указаны в элементах Image соответствующего файла сопровождения. Порядок добавления изображений соответствует порядку их следования в файле.