关于 ABBYY 扫描工作站

ABBYY 是一款针对大量文档的批处理文件扫描的软件解决方案。ABBYY 扫描工作站可以：

  • 管理扫描仪，即启动和停止扫描过程，选择所需的扫描仪设置
  • 控制扫描图像的质量
  • 准备图像供在 ABBYY FlexiCapture 10 中后续处理

要启动 ABBYY 扫描工作站，选择开始 > 程序 > ABBYY FlexiCapture 10 工作站 > 扫描工作站或开始 > 程序 > ABBYY FlexiCapture 10 扫描工作站 > 扫描工作站

在启动 ABBYY 扫描工作站时，将打开工作站的主窗口，在主窗口可以通过工具栏、 批处理文件窗口、图像窗口、注册参数窗口和主菜单来控制文档的扫描和导出。

有关主要使用场景的指示，请参考使用 ABBYY 扫描工作站一节。

本应用程序的界面在 ABBYY 扫描工作站界面一节中进行了描述。


ABBYY扫描工作站的新功能

项目符号 Clickonce 安装

Clickonce（点击一次）安装使您可通过在相应链接上单击一次即可安装该程序。该程序将自动安装和启动。已安装的程序只能由用户在其安装的账户下运行。
项目符号 重新扫描任务

如果某些已扫描的图像需要重新扫描，校验操作员可将相应任务发送至 ABBYY 扫描工作站，以重新扫描页面并在批处理文件中替换它们。

项目符号 重新扫描任务
项目符号 使用脚本的可能性

使用 ABBYY 扫描工作站可通过现在使用脚本来实现。

项目符号 在 ABBYY 扫描工作站中使用脚本
项目符号 新程序界面

已添加注册参数窗口。现在，您可以在主窗口中直接管理文档和批处理文件的注册参数。

新的脚本工具栏使您可以通过单击相应按键运行脚本。您可以根据您的首选项自定义脚本工具栏。

项目符号 | 注册参数窗口
项目符号 | 工具栏自定义


使用 ABBYY 扫描工作站

ABBYY 扫描工作站提供如下两种主要方案：

  • 使用预先选择的选项处理批处理文件类型中的文档
    该方案适合用于大量相似文档的扫描。用户要创建一种批处理文件类型，在其中指定扫描、批处理文件和文档分隔、图像处理和导出选项。
  • 使用手动选择的选项处理批处理文件中的文档
    该方案适合用于少量文档的非经常性扫描。无需进行其它设置。如果用户未进行设置，将使用默认设置来处理图像。


处理批处理文件类型

特定批处理文件类型的批处理文件的处理步骤如下：

  1. 创建新的批处理文件
    在工具栏上的当前批处理文件类型。字段中选择批处理文件类型。要创建选定类型的批处理文件，选择菜单文件 > 新建批处理文件 或按 Ctrl+N。根据批处理文件类型设置，可以在扫描开始时或在扫描特定数量页面后自动创建新批处理文件。如果批处理文件类型属性要求输入注册参数，将提示您输入该注册参数。
  2. 启动扫描进程
    在工具栏上，选择要设置为当前类型的新建批处理文件类型。单击工具栏上的扫描按钮，启动扫描。
  3. 导出扫描文档
    完成扫描后，单击工具栏上的发送至按钮来导出文档。如果批处理文件类型属性要求输入注册参数，必须在输入注册参数后才能导出批处理文件。

有关如何更改单个批处理文件的处理选项的指示，请参考手动选择批处理文件处理选项一节。

要更改特定类型的所有批处理文件的处理选项，可采用处理批处理文件类型一节中的建议。


手动选择批处理文件处理选项

在启动某个处理阶段后，可以立即为各个批处理文件选择处理选项。使用 ABBYY 扫描工作站处理文档的批处理文件，其基本使用步骤如下：

  1. 扫描
    单击工具栏上的扫描，启动扫描。将采用最上一次使用的扫描仪来源。可以单击右侧的箭头来选择扫描仪来源。有关扫描和导入图像的详细信息，请参阅扫描图像一节。

    重要事项！扫描仪必须连接您的计算机。有关连接扫描仪的说明，请参阅扫描仪文档。如果未连接扫描仪，只能使用虚拟扫描仪从文件夹导入图像。
  2. 文档和批处理文件分隔
    在批处理文件窗口或图像窗口中，可以将扫描页面组合成文档和批处理文件。有关详细的操作指示，请参考处理批处理文件、文档和页面。
  3. 编辑图像
    在导入图像前，可以对图像进行编辑。有关详细的操作指示，请参考编辑图像。
  4. 导出扫描文档
    完成批处理文件处理后，可将其保存至本地文件夹或 FTP 文件夹，或者导出至 ABBYY FlexiCapture 或 ABBYY 识别服务器。单击主窗口上的发送至按钮，可选择导出目标。选择导出目标后单击确定。 有关详细的操作指示，请参考导出批处理文件一节。

如果需要对一系列常用批处理文件的处理进行设置，请参考 处理批处理文件类型一节。


编辑图像

在加载图像后，可以对这些图像进行手动编辑。可以使用图像窗口的工具栏、主窗口的页面菜单或页面的快捷菜单：

旋转图像
页面的标准方向为文本行保持水平且文本从上至下的方向。如果页面方向不同于标准方向，应旋转页面。在图像窗口中，选择要旋转的页面，然后：
  • 要顺时针旋转图像 90°，单击 [image] 或从主窗口的页面菜单或从快捷菜单选择顺时针旋转 90°
  • 要逆时针旋转图像 90°，单击 [image] 或从主窗口的页面菜单或从快捷菜单选择逆时针旋转 90°
  • 要旋转图像 180°，单击 [image] 或从主窗口的页面菜单或从快捷菜单选择旋转 180°
翻转图像
在图像窗口中，选择要翻转的页面，然后：
  • 要沿垂直轴旋转图像，单击 [image] 或从主窗口的页面菜单或从快捷菜单选择水平翻转
  • 要沿水平轴旋转图像，单击 [image] 或从主窗口的页面菜单或从快捷菜单选择垂直翻转
裁剪图像
  1. 在图像窗口中，选择要裁剪的图像。
  2. 单击 [image] 或从主窗口的页面菜单或从快捷菜单选择裁剪。
  3. 将鼠标指针放在要保留的图像区域的一角，并按住鼠标左键，呈对角拖动此框。保留区域将被一个矩形包围（可以在选项对话框的常规选项卡上更改颜色）。
  4. 按 Enter 以裁剪框外的图像部分。
反转图像颜色
如果图像中有深色背景的浅色文本，应反转突显颜色以方便 OCR。在图像窗口中，选择要反转的页面，并单击 [image] 或从主窗口的页面菜单或从快捷菜单选择反转。
将彩色和灰度图像转换为黑白图像
如果不需要保留原始图像颜色，可以将图像转换为黑白图像。在图像窗口中，选择要转换的页面，并单击 [image] 或从主窗口的页面菜单或从快捷菜单选择黑白。
消除图像倾斜
在图像窗口中，选择要消除歪斜的页面，并单击 [image] 或从主窗口的页面菜单或从快捷菜单选择消除歪斜。
去除图像噪点
如果图像有太多“噪声”，即扫描中低清晰度的文档时带入的多余的点，可能会对 OCR 质量造成不利影响。要移除过多的点，在图像窗口中选择要清除的页面，并单击 [image] 或从主窗口的页面菜单或从快捷菜单选择去斑。

重要事项！如果源文本的颜色很浅，或者使用的字体很细小，应用去斑命令可以清除所有句点、逗号或细小的字母元素。

从图像中删除敏感信息
  1. 在图像窗口中，选择要删除的敏感信息所在的页面。
  2. 单击 [image] 或从主窗口的页面菜单或从快捷菜单选择编辑。
  3. 将鼠标指针放在要编辑的图像区域的一角，并按住鼠标左键，呈对角拖动此框。选定区域中的文本将被颜色矩形删除。您可以在选项对话框（视图 > 选项… > 常规 > 编辑颜色）中选择该矩形的颜色。
要在图像窗口中缩放图像
    采用以下一种方法选择所需的图像比例：

    • 使用状态栏中的下拉列表
    • 按 Ctrl+Num+ 放大，按 Ctrl+Num- 缩小
    • 按住 Ctrl 并使用鼠标滚轮进行缩放
    • 从视图 > 比例中选择所需的图像比例
    • 在图像窗口或在批处理文件窗口中，双击一页以单独显示该页。
要更改图像分辨率
  1. 在图像窗口或在批处理文件窗口中，选择要更改分辨率的页面。
  2. 单击本程序主窗口的页面菜单或上下文菜单上的更改分辨率…。
  3. 在 设置分辨率对话框中，指定所需的分辨率。


导出批处理文件

完成扫描并将图像分隔到文档和批处理文件中后，可以将批处理文件保存到本地文件夹或 FTP 文件夹、发送到 ABBYY FlexiCapture 10 或通过使用脚本导出。在导出至本地文件夹或 FTP 文件夹时，应用程序将创建一个包含批处理文件相关信息（名称、类型、注册参数、文档）的描述文件<批处理文件名称>.xml。

以下是每个导出方案的个别导出选项。要设置导出选项，选择文件 > 导出选项…，并单击所需方案相应的选项卡：

  • 导出至文件夹选项
  • 导出至 FTP 选项
  • 发送至 FlexiCapture 选项
  • 由脚本发送选项

也可以为单独的每种批处理文件类型选择导出选项。

要以上次选择的方案启动导出过程，请单击主窗口工具栏上的发送至。

要手动选择方案，请单击工具栏上发送至按钮旁边的箭头，选择所需的导出方案，再选择导出选项，最后单击确定启动导出过程。此外，也可以选择文件 > 发送批处理文件。

导出后即可立即删除已导出的批处理文件。要启用该选项，选择选项对话框（工具 > 选项…）常规选项卡上的导出之后自动删除批处理文件。

本程序还允许在选项对话框的 发送任务选项卡上设置后台导出选项。

要取消导出批处理文件，右键单击该批处理文件并从快捷菜单中选择取消导出。


处理批处理文件类型

批处理文件类型决定了此类批处理文件的处理方式。批处理文件类型包括扫描、图像处理、要使用的导出选项的相关信息。您可以创建、更改或删除批处理文件类型。可以将批处理文件类型导出至 XML 文件和传给其他用户。如果要使用由其他用户创建的批处理文件类型，必须先将该类型导入到您的应用程序中。

默认的批处理文件类型预先安装在名称为“未分类”的应用程序中。打开选项对话框（工具 > 选项…），可查看为该批处理文件类型选择的选项。

应用程序可以在管理员或操作员模式下运行。在管理员模式下，对批处理文件类型的操作没有限制：您可以随意地创建、更改、导出和导入批处理文件类型。在操作员模式下，只能导入批处理文件类型。此外，操作员模式禁用“未分类”的批处理文件类型（即操作员不能创建或更改此类批处理文件类型）。

在从文件导入批处理文件类型时，将选择管理员或操作员模式。如果所导入的批处理文件类型有密码保护，需输入密码才能进入管理员模式。在操作员模式下处理批处理文件类型不需输入密码。

可以对批处理文件类型执行的主要操作如下：

  1. 创建批处理文件类型
    从工具菜单中，选择批处理文件类型…项目。在批处理文件类型对话框中，单击新建…。将启动“批处理文件类型向导”。根据向导的提示，进行必要的设置。有关详细的操作指示，请参考“批处理文件类型向导”的相关章节。
    也可以在列表中选择某个现有的批处理文件类型并单击制作副本，为该类型创建一份副本。然后可以更改其属性来编辑新建的批处理文件类型。
  2. 编辑批处理文件类型
    要编辑某种批处理文件类型，请在批处理文件类型对话框中的可用批处理文件类型的列表中将其选中，并单击编辑…按钮。在批处理文件类型属性对话框中，进行必要的更改并单击确定。
  3. 删除批处理文件类型
    要删除某种批处理文件类型，请在批处理文件类型对话框中的可用批处理文件类型的列表中将其选中，并单击删除按钮。属于这种批处理文件类型的批处理文件，将被分配“未分类”批处理文件类型。
  4. 导出批处理文件类型
    要导出某种批处理文件类型，请在批处理文件类型对话框中的可用批处理文件类型的列表中将其选中，并单击导出按钮。在导出批处理文件类型对话框，指定应导出的批处理文件类型（全部类型或仅选中的类型）。如果要防止批处理文件类型被更改，请选择禁止编辑批处理文件类型并输入密码两次。然后单击“确定”，并提供目标文件的名称和位置。
  5. 导入批处理文件类型
    要导入某种批处理文件类型，请在批处理文件类型对话框中的可用批处理文件类型的列表中将其选中，并单击导入…按钮。如果早先创建或导入了批处理文件类型，程序将显示一条警告消息，提示先前的所有批处理文件类型均会被删除（属于这种批处理文件类型的批处理文件将被分配以“未分类”批处理文件类型）。接下来，指定要导入这些批处理文件类型的文件，并单击打开。
  6. 处理密码保护批处理文件类型
    在导入密码保护批处理文件类型时，或在编辑密码保护批处理文件类型时，如果尚未输入密码，程序将提示您输入密码以切换到管理员模式。要继续以操作员模式处理，单击取消。

处理批处理文件类型的典型方案如下：

  1. 管理员创建批处理文件类型并将它们导出至带有以下设置的服务器：
    • 如果不允许操作员编辑批处理文件类型，应选择禁止编辑批处理文件类型选项；
    • 如果批处理文件类型数据应被加载至所有绑定到服务器的扫描工作站，应选择将这些批处理文件类型分发至所有扫描工作站选项。
  2. 操作员启动扫描工作站，会自动在启动时接收到批处理文件类型数据（如果管理员选择了将这些批处理文件类型分发至所有扫描工作站选项）或使用导入…按钮从服务器加载批处理文件类型。

注：在从命令行启动应用程序时，可以从一个文件自动导入批处理文件类型。要导入批处理文件类型，可使用 /BatchFiles:<FilePath>\<Filename>.xml 命令行命令。


界面元素

本节对主要界面元素进行了概述。

项目符号 主窗口
项目符号 | 主窗口菜单
项目符号 | 主窗口工具栏
项目符号 | 批处理文件窗口
项目符号 | 图像窗口
项目符号 | 注册参数窗口
项目符号 | 对话框


主窗口

主窗口包含的元素有：

  • 主窗口菜单
  • 主窗口工具栏，提供扫描进程所需的工具
  • 批处理文件窗口，以树状图显示批处理文件的结构
  • 图像窗口，显示已扫描的图像
  • 注册参数窗口，显示批处理文件和文档的注册参数


主窗口菜单

文件
菜单项 | 描述
新建批处理文件 | 创建新的批处理文件。
创建文档 | 从页面创建文档。
分解文档 | 所谓分解文档，就是将此文档中的页面放在当前批处理文件中，同时删除文档本身。
扫描页面 | 扫描页面，并将页面图像放入选定类型的批处理文件中。
选择并扫描… | 打开选择并扫描对话框，在选择可用的扫描仪来源后启动扫描过程。
重新扫描选定页面 | 重新扫描选定的页面。
插入页面 | 扫描文档页面，并将这些页面放到批处理文件中用户指定的页面后面。
停止 | 停止扫描过程或图像导入过程。
加载图像… | 从文件中加载图像。
发送批处理文件 |
至本地文件夹… | 将批处理文件导出至本地文件夹。可以在导出至文件夹选项对话框中选择导出选项。
至 FTP 文件夹… | 将批处理文件导出至 FTP 文件夹。可以在导出至 FTP 选项对话框中选择导出选项。
至 FlexiCapture… | 将批处理文件导出至 ABBYY FlexiCapture 10。您可以在发送至 FlexiCapture 选项对话框中选择导出选项。
通过脚本 | 通过使用脚本导出批处理文件 您可以在由脚本发送选项对话框中选择导出选项。
导出选项… | 打开导出选项对话框，选择批处理文件导出选项。
退出 | 退出 ABBYY 扫描工作站。
编辑
菜单项 | 描述
撤销 | 撤消上一操作。
重做 | 恢复上次撤消的操作。
剪切 | 剪切选定项目。
复制 | 将选定项目复制到剪贴板。
粘贴 | 粘贴剪贴板中的项目。
删除 | 删除选定项目。
全选 | 选择所有项目。
下一个要重新扫描的文档 | 从重新扫描任务打开下一文档。
上一个要重新扫描的文档 | 从重新扫描任务打开上一文档。
确认重新扫描的文档 | 确认已重新扫描的文档
删除空白页面 | 删除批处理文件中的所有空白页。
分隔文档 | 扫描后将页面分隔成文档。文档分隔将根据批处理文件选项选项卡上的选项对话框中选择的选项，以及根据在批处理文件类型向导中创建批处理文件时指定的批处理文件类型属性，或批处理文件选项卡上的批处理文件类型属性对话框中指定的属性进行。
运行脚本 | 运行选定脚本的执行
视图
菜单项 | 描述
显示批处理文件 | 显示/隐藏批处理文件窗口。
显示注册参数 | 显示/隐藏注册参数窗口。
批注册参数 | 在注册参数窗口切换至批处理文件选项卡。
文档注册参数 | 在注册参数窗口切换至文档选项卡。
工具栏 |
扫描并发送 | 显示/隐藏扫描并发送工具栏。
批处理文件编辑 | 显示/隐藏批处理文件编辑工具栏。
图像编辑 | 显示/隐藏图像编辑工具栏。
Document Navigation | 显示/隐藏Document Navigation工具栏。
重新扫描 | 显示/隐藏重新扫描工具栏。
脚本 | 显示/隐藏脚本工具栏。
自定义… | 打开工具栏自定义窗口
状态栏 | 显示/隐藏状态栏。
显示所选类型的批处理文件 | 启用/禁用只显示批处理文件类型工具栏中选定类型的批处理文件。
折叠 | 折叠批处理文件窗口中的树状图。
转至上一页 | 移至上一页。
转至下一页 | 移至下一页。
转至上个文档 | 将选择移至上一个文档。
转至下个文档 | 将选择移至下一个文档。
比例 | 控制图像窗口中的图像显示。
放大 | 将图像放大两倍。
缩小 | 将图像缩小两倍。
按比例增加 | 显示一页按比例增加的页面。
一页 | 只显示一页。
较大缩略图 | 以较大缩略图显示页面。
中等缩略图 | 以中等大小的缩略图显示页面。
较小缩略图 | 以较小缩略图显示页面。
超小缩略图 | 以极小的缩略图显示页面。
页面
菜单项 | 描述
顺时针旋转 90° | 将选定页面顺时针旋转 90°。
逆时针旋转 90° | 将选定页面逆时针旋转 90°。
旋转 180° | 将选定页面旋转 180°。
水平翻转 | 相对于垂直轴翻转选定页面。
垂直翻转 | 相对于水平轴翻转选定页面。
裁剪 | 裁剪选定页面。
反转 | 反转选定页面上的颜色。
黑白 | 将选定页面转换为黑白页面。
消除歪斜 | 纠正选定页面上的歪斜。
去斑 | 消除选定图像的“背景噪声”。
编辑 | 使用颜色矩形模糊页面上的某个区域。可以在工具 > 选项… > 常规 > 编辑颜色中选择颜色。
更改分辨率… | 为选定的页面设置新图像分辨率（按 DPI 计算）。
加载全屏缩略图 | 为重新扫描任务的选定页面加载缩略图。
属性 | 显示选定项目的属性。如果选定的是页面，该菜单将打开页面属性对话框，如果选定的是文档，将打开文档属性对话框，如果是批处理文件，将打开批处理文件属性对话框。
工具
菜单项 | 描述
批处理文件类型… | 打开批处理文件类型对话框，在该对话框中可以管理批处理文件类型：创建新批处理文件类型，调整现有的批处理文件类型，导入和导出批处理文件类型。
重新扫描任务… | 打开重新扫描任务对话框，在该对话框可以管理重新扫描任务：选择任务、发送任务、拒绝任务和根据注册参数在批处理文件上检索信息。
选项… | 打开选项对话框，在该对话框中可以针对创建和导出批处理文件、后台处理等选择各种程序选项。
帮助
菜单项 | 描述
帮助主题 | 打开 ABBYY 扫描工作站帮助。
技术支持 | 打开“帮助”中的技术支持页面。
如何购买 ABBYY 产品 | 打开“帮助”中的如何购买页面。
ABBYY 网站 | 在浏览器中打开 ABBYY 网站。
发送反馈… | 允许发送反馈给 ABBYY。
关于 | 打开关于...对话框，该对话框显示有关本程序的简要信息。


主窗口工具栏

主窗口有 7 个工具栏：

扫描和发送工具

此工具栏的按钮执行这些基本操作：扫描、停止扫描和导出扫描文档。

按钮 描述
采用上次使用的扫描仪来源启动扫描。

要选择可用的扫描仪来源，单击按钮右侧的箭头并选择选择并扫描…项目。在选择并扫描对话框中，选择一个可用的扫描仪来源。
停止扫描进程。在扫描过程中，此按钮可替代扫描按钮。
将文档导出至选定的导出目标。将鼠标指向该按钮时，会显示当前目标的名称。

单击该按钮旁边的箭头并选择下面的一个目标：

  • 发送至文件夹… – 将批处理文件发送至本地文件夹。
  • 发送至 FTP 文件夹… – 将批处理文件发送至 FTP 文件夹。
  • 发送至 FlexiCapture… – 将批处理文件发送至 ABBYY FlexiCapture。
  • 由脚本发送… – 通过使用脚本发送批处理文件。

选择配置文件时，在打开的对话框中可以选择配置文件的发送选项。选择所需的选项并单击确定开始导出文档。

批处理文件类型工具

此工具栏的按钮用于选择批处理文件类型、显示批处理文件类型属性，以及更改批处理文件窗口的外观。

按钮 | 描述
当前批处理文件类型 （下拉列表） | 选择批处理文件类型并将其标记为当前类型。默认的批处理文件类型是未分类。
 | 打开批处理文件类型属性对话框，可查看和编辑选定批处理文件类型的设置。此按钮不适用未分类批处理文件。要查看默认选项，请选择工具 > 选项…
 | 单击此按钮仅显示批处理文件窗口中当前类型的批处理文件。

注：如果没有用户创建的批处理文件类型，此工具栏将处于隐藏状态。

批处理文件编辑工具

此工具栏的按钮用于更改批处理文件的结构。

命令 | 按钮 | 描述
创建新批处理文件 |  | 创建当前类型的新批处理文件。新批处理文件的名称由批处理文件类型属性中指定的批处理文件命名规则决定。要更改批处理文件的名称，请在批处理文件窗口中选择批处理文件，然后按鼠标左键或按 F2。
创建新文档 |  | 在当前批处理文件中创建一个包含选定页面的文档。新文档的名称由批处理文件类型属性中指定的文件命名规则决定。要更改文档的名称，请在批处理文件窗口中选择批文档，然后按鼠标左键或按 F2。
分解文档 |  | 分解文档，就是将此文档中的页面放在当前批处理文件中，同时删除该文档本身。
删除 |  | 删除选定项目。
图像编辑工具

此工具栏的按钮用于编辑图像。

命令 | 按钮 | 描述
重新扫描页面 |  | 重新扫描选定的页面。
扫描页面放在选定页面后面 |  | 扫描文档页面，并将这些页面放到批处理文件中用户指定的页面后面。
顺时针旋转 90° |  | 将选定页面顺时针旋转 90°。
逆时针旋转 90° |  | 将选定页面逆时针旋转 90°。
旋转 180° |  | 将选定页面旋转 180°。
水平翻转 |  | 相对于垂直轴翻转选定页面。
垂直翻转 |  | 相对于水平轴翻转选定页面。
裁剪 |  | 裁剪选定页面。
反转 |  | 反转选定页面上的颜色。
黑白 |  | 将选定页面转换为黑白页面。
消除歪斜 |  | 消除选定页面上的歪斜。
去斑 |  | 消除选定图像的“背景噪声”。
编辑 |  | 使用颜色矩形模糊页面上的某个区域。可以在工具 > 选项… > 常规 > 编辑颜色中选择颜色。
文档导航工具

此工具栏的按钮使您可以在文档之间浏览。

命令 | 按钮 | 描述
转至上个文档 |  | 将选择移至上一个文档。
转至下个文档 |  | 将选择移至下一个文档。
重新扫描工具

此工具栏的按钮使您可以在来自重新扫描任务的文档之间浏览、确认重新扫描结果和启动重新扫描任务对话框。

命令 | 按钮 | 描述
重新扫描任务 |  | 打开重新扫描任务对话框。
上一个要重新扫描的文档 |  | 打开当前批处理文件的上一文档。
下一个要重新扫描的文档 |  | 打开当前批处理文件的下一文档。
确认重新扫描的文档 |  | 确认重新扫描文档的结果

当从服务器接收到有关新添加重新扫描任务的信息时，新的重新扫描任务可用。消息会出现。单击链接打开重新扫描任务对话框。

脚本工具栏

此工具栏上的按钮使您可以运行与每个按钮相关联的脚本。

您可以在工具栏自定义对话框自定义脚本工具栏。


批处理文件窗口

批处理文件窗口显示批处理文件结构，您也可以更改结构（使用工具栏上的按钮）。

有关处理批处理文件和文档的详细信息，请参阅处理文档、批处理文件和页面。

批处理文件窗口中的页面可能标有黄色三角形。这表示页面的分辨率、垂直大小或水平大小与为该批处理文件指定的不一致。要查看选定页面的警告，打开页面属性对话框。有关更改页面分辨率的信息，请参阅编辑图像。

要更改批处理文件窗口的大小，请将鼠标指针放在右侧窗口边框上，按住鼠标左键并将该边框移至目标位置。要隐藏窗口，双击左侧窗口边框。要恢复原始窗口，双击图像窗口的左侧边框即可。或者也可以选择视图 > 显示批处理文件。


图像窗口

图像窗口显示选定批处理文件的页面。使用状态栏中的下拉列表可以更改此窗口的外观。要编辑图像，可使用相应工具栏上的按钮。

有关处理图像的详细指示，请参阅编辑图像部分。


注册参数窗口

注册参数窗口显示批处理文件和文档的注册参数。您可以在批处理文件和文档选项卡之间切换，查看批处理文件或文档的注册参数。在文档选项卡上，您也可以修改文档的注册参数。

要更改注册参数窗口的大小，请将鼠标指针放在左侧窗口边框上，按住鼠标左键并将该边框移至目标位置。要隐藏窗口，双击左侧窗口边框。要恢复原始窗口，双击图像窗口的右侧边框即可。另外，您也可以选择视图 > 显示注册参数。

有关注册参数的详细信息，请参见如何指定注册参数。


ABBYY 扫描工作站对话框

本节说明 ABBYY 扫描工作站中的对话框：

项目符号 扫描选项和导出选项
项目符号 | 选择并扫描
项目符号 | 扫描仪设置
项目符号 | 导出至文件夹选项
项目符号 | 导出至 FTP 选项
项目符号 | 发送至 FlexiCapture 选项
项目符号 | 由脚本发送选项
项目符号 | 处理发送任务
项目符号 批处理文件类型选项
项目符号 | 批处理文件类型向导
项目符号 | 批处理文件类型属性
项目符号 | 批处理文件类型
项目符号 | 批处理文件类型常规选项
项目符号 | 批处理文件类型扫描选项
项目符号 | 批处理文件类型分隔选项
项目符号 | 空页面检测设置
项目符号 | 图像处理参数
项目符号 | 批处理文件类型发送选项
项目符号 | 图像格式选项
项目符号 | 配置脚本
项目符号 | 页面参数控制
项目符号 | 设置注册参数
项目符号 | 调整注册参数
项目符号 | 注册参数
项目符号 | 存储批处理文件类型设置
项目符号 | 批处理文件类型存储
项目符号 其它对话框
项目符号 | 选项
项目符号 | 常规处理选项
项目符号 | 工具栏自定义
项目符号 | 脚本编辑器
项目符号 | 批处理文件属性
项目符号 | 文档属性
项目符号 | 页面属性
项目符号 | 发送任务


扫描选项和导出选项

选择并扫描
扫描仪设置
导出至文件夹选项
导出至 FTP 选项
发送至 FlexiCapture 选项
由脚本发送选项
选项对话框的发送任务选项卡


选择并扫描

在该对话框中，可以选择扫描仪来源，如硬件扫描仪或虚拟扫描仪。对话框外观的改变取决于所选的扫描仪来源。如果将程序设置为显示选择扫描仪来源对话框，则启动扫描会显示该对话框。单击工具栏上扫描按钮左侧的箭头，并选择选择并扫描…选项。

从扫描仪：下拉列表选择可用的扫描仪来源并进行必要的设置。

对于硬件扫描仪...
选项 | 描述
使用本地扫描仪接口 | 选择此选项以使用扫描仪提供的界面。
使用应用程序界面 | 选择此选项以使用本应用程序提供的界面。
扫描选项… | 打开扫描仪设置对话框。如果选择扫描仪的界面，可以看到由扫描仪驱动程序提供的对话框。如果选择应用程序的界面，可以看到由应用程序提供的扫描仪设置对话框。
扫描之前显示扫描选项 | 如果选择该选项，每次启动扫描时程序将显示扫描仪设置对话框。
对于虚拟扫描仪...
选项 | 描述
文件夹： | 指定导入图像的文件夹的路径（可单击浏览…来浏览至所需的文件夹）。
浏览… | 单击此按钮查找有图像的文件夹。
移除成功加载的文件 | 如果要在加载文件后将其从源文件夹中移除，可选择此选项。

单击扫描启动扫描。单击取消退出该对话框。


扫描仪设置

如果选择了 ABBYY 扫描工作站扫描仪界面，可以在该对话框中设置扫描仪。

设置图像分辨率、彩色模式、亮度、纸张大小、压缩和旋转的值。您可以根据需要选择多页扫描选项。要扫描和预览页面，请单击预览。扫描过程结束时，扫描页面的图像会显示在预览按钮上方的窗口中。如有需要可以调整选择的值。单击关闭返回扫描仪配置文件属性。

注:ISIS 扫描仪不具备预览功能。
选项 | 描述
扫描仪设置
分辨率： （下拉列表） | 用于设置扫描图像的分辨率。扫描字号较小的文本应选择较高的分辨率。
彩色模式： （下拉列表） | 允许您选择扫描图像的彩色模式。OCR 最适合采用灰色模式。
压缩： （下拉列表） | 允许您选择扫描图像压缩。
旋转： （下拉列表） | 允许您旋转图像。
亮度： （下拉列表） | 允许您选择自动或手动调整亮度。移动下拉列表下方的滑动条可以更改亮度。
纸张设置
纸张大小： （下拉列表） | 允许您选择纸张大小。 注：如果提供的纸张大小均不符合您的需要，可以创建自定义纸张大小。从列表中选择自定义…，并在自定义页面大小对话框中指定所需的纸张高度和宽度。
多页扫描
使用自动文档送纸机 (ADF) | 如果使用的是配备有 ADF 的扫描仪，请选择此选项。
双面扫描 | 双面扫描请选择此选项。
暂停时间 n 每页扫描间隔（秒数） | 如果希望在每页扫描后暂停 n 秒，请选择从选项。键入所需的暂停秒数。
预览 （按钮） | 要扫描和预览一页，请单击此按钮。扫描进程结束时，扫描页面的图像会显示在此按钮上方的窗口中。ISIS 扫描仪不具备“预览”功能。


导出至文件夹选项

在该对话框中，可以选择将批处理文件导出至文件夹的选项。选择文件 > 导出选项…，然后选择文件夹选项卡。也可以在选择发送至文件夹…导出目标（通过单击主窗口工具栏上的发送至按钮）时打开此对话框。

指定保存文档批处理文件的文件夹的路径，并选择所需的文件格式。

选项 | 描述
导出文件夹
文件夹： 选择该选项以指定要保存文档批处理文件的文件夹的路径。单击浏览…选择现有文件夹。
浏览…
（按钮） 		单击此按钮以浏览至一个现有文件夹。
格式选项
格式：
（下拉列表） 		选择所需的文件格式：
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
彩色模式：

（下拉列表）

选择所需的彩色模式：
  • 彩色
  • 灰度
  • 中间色 (bw)
质量：

（下拉列表）

选择保存图像的质量：
  • 最佳
  • 高
  • 正常
  • 低
多页格式选项 选择保存批处理文件中的文档的方法。
  • 将文档另存为多页文件
    可以将文档另存为多页文件。此选项仅适用于 TIFF、DCX packbits 和 PDF 格式。
  • 将文档另存为文件夹
    可以将文档另存为文件夹。如果选择该选项，将以选定格式的独立文件显示文档页面。
导出之前显示选项 | 如果下次想以相同的选项将数据导出至本地文件夹，请禁用该选项。对于这种情形，下次启动导出进程时不会显示对话框。


导出至 FTP 选项

在该对话框中，可以选择将批处理文件导出至 FTP 的选项。选择文件 > 导出选项…，然后单击 FTP 选项卡。也可以在选择发送至 FTP 文件夹…导出目标（通过单击主窗口工具栏上的发送至按钮）时打开此对话框。

指定要保存文档批处理文件的 FTP 文件夹的名称、登录和密码，或选择匿名登录。然后指定所需的文件格式。

选项 | 描述
FTP 选项
URL： 指定要保存文档批处理文件的 FTP 文件夹的名称。
登录： 输入登录。
密码： 输入密码。
匿名登录 | 匿名访问 FTP 服务器请使用该选项。
格式选项
格式：
（下拉列表） 		选择所需的文件格式：
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
彩色模式：

（下拉列表）

选择所需的彩色模式：
  • 彩色
  • 灰度
  • 中间色 (bw)
质量：

（下拉列表）

选择保存图像的质量：
  • 最佳
  • 高
  • 正常
  • 低
多页格式选项 选择保存批处理文件中的文档的方法。
  • 将文档另存为多页文件
    可以将文档另存为多页文件。此选项仅适用于 TIFF、DCX packbits 和 PDF 格式。
  • 将文档另存为文件夹
    可以将文档另存为文件夹。如果选择该选项，将以选定格式的独立文件显示文档页面。
导出之前显示选项 | 如果下次想以相同的选项将数据导出至 FTP 文件夹，请禁用该选项。对于这种情形，下次启动导出进程时不会显示对话框。


导出至 FlexiCapture 选项

发送至 FlexiCapture 选项

在该对话框中，可以选择将批处理文件导出至 ABBYY FlexiCapture 的选项。选择文件 > 导出选项…，并单击 FlexiCapture 选项卡。也可以在选择发送至 FlexiCapture… 导出配置文件（通过单击主窗口工具栏上的发送至按钮）时打开此对话框。

在该对话框中，可以选择要对其导出数据的 ABBYY FlexiCapture 项目以及该项目中的某个批处理文件。

  1. 在项目：列表中选择该项目。单击选择项目…查找项目。对于远程项目，在选择远程 FlexiCapture 项目对话框（单击选择项目…按键打开）：
    • 在服务器字段中指定格式为 http://server 的服务器路径。
    • 在安全性对话框中指定连接设置。可以使用 Windows 验证或输入用户特定的名称和密码。

      注：要启用按名称和密码验证，必须在安装应用程序服务器的计算机上对 Internet Information server 进行相应设置，即允许对 FlexiCapture\Server 文件夹进行基本验证。详情请联系系统管理员。

    • 单击更新项目。所有可用的 ABBYY FlexiCapture 项目将出现在项目：列表中。从该列表选择所需的项目并单击确定。
  2. 指定项目的类型和处理优先级。
  3. 如果希望下次采用相同选项来向 ABBYY FlexiCapture 导出数据，可禁用发送之前显示选项选项。对于这种情形，下次启动导出进程时不会显示该对话框。
  4. 按格式选项…按钮，指定图像格式选项。在图像格式选项对话框中，您可以指定以下设置：
    • 格式：TIFF、BMP、JPG、JPEG2000、DCX packbits、PCX packbits、PNG 和 PDF
    • 彩色模式：：彩色、灰度、中间色 (b)
    • 质量：：最佳、高、正常、低

    通过更改图像格式选项，必要情况下可在发送批处理文件时降低网络加载。

  5. 如果需要指定选定项目的注册参数，项目：字段上将显示提示。
    要使用默认指定的参数，请选择指定默认注册参数选项。
  6. 在批处理文件选项选项卡上指定批处理文件名称和描述。


由脚本发送选项

在该对话框中，您可以通过使用脚本指定导出批处理文件的选项。选择文件 > 导出选项…并单击脚本选项卡。您也可以通过单击主窗口工具栏上发送至按钮旁的箭头，在选择由脚本发送…导出配置文件时打开此对话框。

选择所需的脚本语言：JScript® 或 VBScript 并按编辑脚本…按钮，打开脚本编辑器窗口。

如果您希望下次采用相同选项来使用脚本导出数据，可禁用导出之前显示选项。对于这种情形，下次启动导出进程时不会显示该对话框。


选项对话框的发送任务选项卡

发送任务对话框选项选项卡

在该选项卡上，可以指定处理导出任务的选项。选择工具 > 选项…，并单击发送任务选项卡。

选项 | 描述
从列表中移除完成的任务 | 选择该选项，以从导出任务对话框中的列表删除完成的任务。该对话框包含已导出的批处理文件、任务状态、启动时间和进度的信息。在导出期间或在导出后，可以通过单击 Windows 任务栏的通知区域的快捷方式，来打开该对话框。
当任务处于以下状态时显示汽球... 选择此选项以在如下状态时启用快捷消息：
  • 开始
    开始处理任务时。
  • 已停止且出现错误
    在任务处理期间发生错误时。
  • 已完成
    任务处理完成时。
指定发送时间范围 | 您在此可以指定批处理文件应发送至其目标的每日时间段。
通过网络重复已失败任务：... 选择该选项以启用通过网络重新发送已失败的任务：
  • 在 n 分钟内
    再次发送任务的尝试将在 n 分钟内进行。
  • 尝试数：
    发送任务的尝试将进行 n 次。


批处理文件类型选项

批处理文件类型向导
批处理文件类型属性
批处理文件类型
批处理文件类型名称和注释
选择扫描仪来源
设置文档和批处理文件分隔选项
空页面检测设置
设置图像处理参数
设置批处理文件类型的导出选项
图像格式选项
配置脚本
页面参数控制
设置注册参数
指定注册参数
注册参数
选项对话框的 FlexiCapture 服务器选项卡
选择批处理文件类型存储对话框


批处理文件类型向导

当您单击批处理文件类型对话框中的新建…按钮时，批处理文件类型向导会打开。

批处理文件类型向导将提示您设置如下批处理文件类型参数：

  • 扫描仪来源
  • 文档和批处理文件分隔选项
  • 图像处理选项
  • 导出选项
  • 脚本
  • 注册参数
  • 文档注册参数
  • 页面大小控制
  • 批处理文件类型名称和注释

完成批处理文件类型的设置后，可以将该类型选为当前的批处理文件类型。要编辑批处理文件类型，打开批处理文件类型对话框，选择所需的批处理文件，并单击编辑…。


批处理文件类型属性

在该对话框中，可以编辑选定批处理文件类型的属性。

  • 常规属性（常规选项卡）
  • 扫描仪设置（扫描选项卡）
  • 文档和批处理文件分隔选项（批处理文件选项选项卡）
  • 图像处理选项（图像处理选项卡）
  • 导出选项（发送至选项卡）
  • 脚本配置选项（脚本）
  • 页面大小控制选项（页面大小控制选项卡）；
  • 文档注册参数（文档注册参数选项卡）
  • 批处理文件注册参数（批注册参数选项卡）

从工具栏上的当前批处理文件类型。下拉列表选择所需的批处理文件类型，并单击批处理文件类型属性按钮，可更改批处理文件类型属性。


批处理文件类型

在该对话框中，可以管理批处理文件类型：创建、复制、编辑、删除、导出和导入批处理文件。要打开该对话框，请选择工具 > 批处理文件类型…。

该列表显示批处理文件类型的名称以及这些批处理文件所使用的扫描仪来源。可以使用列表右侧的按钮来管理批处理文件类型。

选项 | 描述
新建… | 启动批处理文件类型向导，创建新的批处理文件类型。
制作副本 | 复制选定的批处理文件类型。
编辑… | 编辑选定的批处理文件类型。
删除 | 删除选定的批处理文件类型。
导出 | 打开导出批处理文件类型对话框，您可以在此为批处理文件类型指定导出选项。 选择要导出的批处理文件类型（导出所有批处理文件类型或导出所选批处理文件类型）。 通过选择禁止编辑批处理文件类型并输入密码，可禁止更改批处理文件类型。在这种情况下，无论是导入还是编辑批处理文件类型，程序都会要求用户输入有效密码。 单击确定，并在选择批处理文件类型存储器对话框中选择用来存储符合批处理文件类型描述的 XML 文件的文件夹。
导入… | 从 XML 文件导入批处理文件类型。在打开的选择批处理文件类型存储器对话框中，指定包含该批处理文件类型描述的 XML 文件的路径。 重要事项！在导入批处理文件时，所有现有的批处理文件均会被删除。
关闭 | 关闭对话框。


批处理文件类型名称和注释

批处理文件类型和注释的名称可在使用批处理文件类型向导创建批处理文件类型时指定，它们可以在批处理文件类型属性对话框的常规选项卡上进行调整。

指定批处理文件类型的名称，并根据需要添加注释。


选择扫描仪来源

可以为单个的批处理文件，或者为一组特定类型的批处理文件选择扫描仪来源。对于单个的批处理文件，可在扫描对话框的扫描选项卡上选择相应选项。特定批处理文件类型的选项则是在使用批处理文件类型向导创建批处理文件类型时选择，并且可以在批处理文件类型属性 对话框的扫描选项卡上调整。

要选择适当的扫描设置：

  1. 选择一个可用的扫描仪。也可以选择一个虚拟扫描仪从文件夹导入图像。
  2. 根据选定的扫描仪来源进行必要的设置：
    • 对于硬件扫描仪
      选择扫描所要使用的界面。可以选择扫描仪提供的界面，也可以选择应用程序提供的界面。单击扫描选项…按钮后扫描仪选项将变为可用状态。如果选择扫描仪的界面，可以看到由扫描仪驱动程序提供的对话框。如果选择应用程序的界面，可以看到由应用程序提供的       扫描仪设置对话框。
      通过选择或清除扫描之前显示扫描选项方框，指定是否在每次启动扫描时显示扫描选项对话框。
  • 对于虚拟扫描仪
    指定要导入图像的文件夹的路径（可单击浏览…来浏览至所需的文件夹）。
    如果要在导入后将该图像从其源文件夹删除，可选中移除成功加载的文件方框。

  3. 当您单击扫描页面按钮或从文件菜单选择相应项目时，如果您希望扫描过程自动启动，请选择使用指定的扫描选项。页面图像将用指定的设置进行扫描。
    如果取消选择该选项，每次扫描页面时，都将提示您选择扫描仪并指定扫描设置。


设置文档和批处理文件分隔选项

可以为单个的批处理文件，或者为一组特定类型的批处理文件选择文档和批处理文件的命名和分隔选项。对于单个的批处理文件，可在批处理文件对话框的选项选项卡上选择相应选项。特定批处理文件类型的选项则是在使用批处理文件类型向导创建批处理文件类型时选择，并且可以在批处理文件选项对话框的批处理文件类型属性选项卡上调整。

指定批处理文件和文档所需的分隔选项和命名选项。
选项 | 描述
批处理文件分隔
命名方案… 打开批处理文件名称对话框，您可以在其中为所选的批处理文件类型设置批处理文件命名规则。

在批处理文件命名模式：字段指定批处理文件命名规则。创建新批处理文件时将使用该命名模板。

在给批处理文件命名时，批处理文件命名规则将使用当前的时间、日期、批处理文件类型、自动编号和注册参数。如果要在批处理文件命名规则中添加这些项目，可选择相应的方框。这些元素在规则中将以尖括号 (<>) 括住。所有其它项目不应在尖括号中输入（未括在尖括号中的项目按其原样使用）。
例如：Batch_<T> – 每个新批处理文件的名称将包含前缀“Batch_”和当前时间。

创建新批处理文件 指定在扫描过程中何时创建新的批处理文件：
  • 从不
    所有图像放到一个批处理文件中。
  • 每次启动扫描时
    每次启动扫描进程时创建一个新批处理文件。
  • 每 n 页
    每个有 n 页的批处理文件。
文档分隔
命名方案… 打开文档名对话框，您可以在其中为所选的批处理文件类型设置文档命名规则。

在批处理文件命名模式：字段中指定文档命名规则。创建新文档时将使用该命名模板。

文档命名规则可以采用当前时间、日期、条形码值、自动编号和批处理文件名称。如果要在批处理文件命名规则中添加这些项目，可选择相应的方框。这些元素在规则中将以尖括号 (<>) 括住。所有其它项目不应在尖括号中输入（未括在尖括号中的项目按其原样使用）。
例如：Document_<T> – 每个新批处理文件的名称将包含前缀“Document_”和当前时间。
创建新文档 指定在扫描过程中何时创建新文档：
  • 从不
    所有扫描图像放到批处理文件中，不创建新文档。
  • 每 n 页
    每个有 n 页的文档。
  • 对于通过以下项分隔的图像：...
    在检测到批处理文件中有空白页面或条形码页面时，创建一个新文档（可从下拉列表选择相应选项）。
    如果选择由空白页面分隔文档，可以在空页面检测设置对话框（可通过单击选项…按钮打开） 中指定空白页面检测参数。
    如果您选择通过条码分隔文档，您可以在条形码选项对话框中指定条码的类型和值，该对话框将在您单击选项…按钮时打开。如果选择任何类型，只要检测到受支持的条码，就将创建一个新文档。
删除分隔页面 | 移除用于分隔文档的空白页面或条形码页面。


空白页面检测设置对话框

空页面检测设置对话框

在该对话框中，可以指定文档分隔所使用的空页面的检测设置。在使用批处理文件类型向导创建批处理文件类型时，在批处理文件类型属性对话框的批处理文件选项选项卡上选择空页面分隔之后，单击选项…，即可打开该对话框。

选项 | 描述
裁剪图像边框 (mm)： | 要在定义页面是否为空时自动裁剪页面（在上、下、左、右方向，以毫米计），可选择此选项。裁剪后，将对生成的页面检查其它参数。
最大黑方形数目： | 如果希望将含有一定数量的黑色方块（特殊形状设计元素）的页面视为空页面，可选择此选项。指定一个页面上允许的最大黑色方块数。
最大文本对象数目： | 如果希望将含有一定数量的文本对象的页面视为空页面，可选择此选项。文本对象包括任何独立的文本片段。例如，可以对有页眉页脚的页面使用该选项。指定一个页面上允许的最大文本块数。
最大条形码数目： | 如果希望将含有一定数量的条形码的页面视为空页面，可选择此选项。指定一个页面上允许的最大条形码数。
最大黑色百分率： | 如果希望将含有一定黑色百分比的页面视为空页面，可选择此选项。指定一个页面上允许的最大黑度百分比。黑白比在图像二进制化后确定。


设置图像处理参数

可以为单个的批处理文件，或者为一组特定类型的批处理文件选择图像处理选项。对于单个的批处理文件，可在图像处理对话框的图像处理项卡上选择相应选项。特定批处理文件类型的选项则是在使用批处理文件类型向导创建批处理文件类型时选择，并且可以在图像处理图像处理选项卡上调整。

指定所需的图像处理选项
选项 | 描述
去斑 | 消除图像噪声。如果图像上的噪声太多，比如在扫描中低质量的文档时产生的斑点，可以选择此选项。
将彩色和灰色图像转换为黑白 | 将图像转换为黑白图像。
通过以下方式旋转图像： 图像的旋转方式：
  • 90°（顺时针）
  • 90°（逆时针）
  • 180°
通过以下方式旋转图像： 消除图像的歪斜。选择歪斜消除法：通过黑色分隔符或黑色方块消除歪斜，或两种方法兼用。


设置批处理文件类型的导出选项

在使用批处理文件类型向导创建批处理文件类型时，可以设置其导出选项。然后可以在发送至对话框的批处理文件类型属性选项卡上调整导出选项。

指定这类批处理文件是否应始终导出至选定目标，然后选择相应的导出选项。
选项 描述
使用指定的发送选项： 选择是否将这类批处理文件导出至相同的导出目标。
发送目标： 选择导出目标：文件夹、FTP 文件夹、ABBYY FlexiCapture 或脚本。
导出选项 该组包含的选项适用于选定的导出目标。这些选项在其相应的对话框中作了详细描述：
  • 导出至文件夹选项
  • 导出至 FTP 选项
  • 发送至 FlexiCapture 选项
  • 由脚本发送选项

注：在 ABBYY FlexiCapture 中设置导出时，可以导入批处理文件类型的注册参数：选择 ABBYY FlexiCapture 项目和批处理文件类型后，单击导入注册参数按钮。


图像格式选项

在该对话框中，可以指定导出选定批处理文件类型图像的选项。可以在使用批处理文件类型向导来创建批处理文件时设置这些选项，并在创建批处理文件类型后进行调整。在批处理文件类型属性对话框中，单击发送至选项卡，选择使用指定的发送选项：，然后单击导出选项下的格式选项…按钮，可以调整图像导出选项。

指定所需的输出格式和多页文档的保存方式。

选项 描述
格式：
（下拉列表） 		选择所需的文件格式：
  • BMP
  • TIFF
  • JPEG
  • JPEG2000
  • DCX packbits
  • PCX packbits
  • PNG
  • PDF
彩色模式：
（下拉列表） 		选择所需的彩色模式：
  • 彩色
  • 灰度
  • 中间色 (bw)
质量：
（下拉列表） 		选择保存图像的质量：
  • 最佳
  • 高
  • 正常
  • 低
多页格式选项 选择保存批处理文件中的文档的方法。
  • 将文档另存为多页文件
    可以将文档另存为多页文件。此选项仅适用于 TIFF、DCX packbits 和 PDF 格式。
  • 将文档另存为文件夹
    可以将文档另存为文件夹。如果选择该选项，将以选定格式的独立文件显示文档页面。


配置脚本

可以为单个的批处理文件或为一组特定类型的批处理文件配置脚本。对于单个的批处理文件，可在选项对话框的脚本选项卡上配置脚本。对于特定的批处理文件类型，在使用批处理文件类型向导创建批处理文件类型时，或者在批处理文件类型属性对话框的脚本选项卡对它们进行配置时，您可以添加、编辑或删除脚本。

窗口显示脚本和触发它们的事件名称。

要添加新脚本，单击添加…按钮。要修改选择的脚本，单击编辑…。脚本编辑器将打开。

单击删除将除去选择的脚本。

单击自定义工具栏…按钮将打开工具栏自定义窗口。

注：如果在当前的批处理文件类型中没有脚本，按钮将是灰色的。

通过从编辑菜单选择运行脚本命令，能够运行已添加的脚本。在将要打开的运行脚本对话框中，从可用的脚本列表中为给定的批处理文件类型选择一个脚本，然后单击确定。您可以通过单击脚本工具栏中的相应按钮运行脚本。

有关在 ABBYY 扫描工作站中使用脚本的更多信息，请参阅使用脚本部分。


页面参数控制

您可以配置批处理文件的分辨率以及页面的垂直大小和水平大小。如果页面参数与指定参数的不一致，将在批处理文件窗口中标记黄色的警告三角形。打开页面属性对话框可查看警告。

您既可以控制单独的批处理文件的页面参数，也可以控制一组同类型批处理文件的页面参数。在前一种情况中，可以在页面大小控制对话框的选项选项卡上配置该设置。对于后一种情况，可以在批处理文件类型向导中创建批处理文件类型期间配置，或以后在页面大小控制对话框的批处理文件类型属性选项卡上配置。

通过选定并调整值的范围可以配置所需的参数。
选项 | 描述
分辨率 | 控制每英寸点数 (dpi)。
垂直大小 | 控制图像的垂直大小（单位为像素）。
水平大小 | 控制图像的水平大小（单位为像素）。


设置注册参数

批处理文件和文档的注册参数可以进行指定。

对于典型的批处理文件和所包括文档的注册参数，可以在使用批处理文件类型向导创建批处理文件类型期间配置，并且可以在批处理文件类型属性 对话框的注册参数和文档注册参数选项卡上调整。

该窗口显示如下信息：

  • 参数名称
  • 是否为必填参数
  • 是否为只读
  • 参数值
  • 注释

要创建新参数，单击添加…按钮。在 注册参数对话框中，指定所需的参数。

要调整参数，单击编辑…。单击删除可移除参数。

在创建新的批处理文件时，会提示操作员填写或检查指定的注册参数。也可以在批处理文件属性对话框中创建批处理文件之后，再填写批处理文件的注册参数。文档的注册参数是在文档属性对话框中创建文档后填写。


指定注册参数

批处理文件和文档的注册参数可以进行指定。

如果必须为当前批处理文件类型提供注册参数，可在创建该批处理文件时在指定注册参数对话框中指定，或者在创建批处理文件后在批处理文件属性对话框（注册参数选项卡）中指定。

文档的注册参数可在注册参数选项卡上的文档属性对话框中进行配置。

在值：一栏输入注册参数的值。您可能会发现，注释：栏提供的注释十分有用。必填的注册参数标有星号 (*)。必须配置好必填的注册参数，才能发送批处理文件。


注册参数

在该对话框中，可以为批处理文件创建注册参数。在使用批处理文件类型向导创建配置文件时可以指定注册参数，并且可以在创建批处理文件类型后进行调整。可以单击批处理文件类型属性对话框上的注册参数或文档注册参数选项卡上的编辑…按钮，来调整注册参数。

输入注册参数的名称，选择注册参数类型。根据选择的类型，配置所需的设置。

选项 | 描述
名称： 注册参数的名称。
类型： 注册参数的类型：
  • 文本
    此类参数包含一个文本行。可以在默认值：行中指定要用作默认注册参数值的值。
    此值可包含启动工作站的用户的名称、安装本应用程序的计算机的名称、工作站标识符、批处理文件的创建日期和时间。如果要在该值中包含这些部分，请分别选择操作员、工作站、工作站 ID、时间和日期。这些部分放在尖括号 <> 中。其余部分不需括起来。没有尖括号的部分将在不进行任何更改的情况下用作注册参数值。
    如果不希望操作员更改默认值，选择 只读。
  • 下拉列表
    此类参数可以包含 可能值 列表中的元素之一。要向列表添加元素，单击添加…。将打开一个对话框提示您输入列表元素值。
    列表元素可包含启动工作站的用户的名称、安装本应用程序的计算机的名称、工作站标识符、批处理文件的创建日期和时间。如果要在该值中包含这些部分，请分别选择操作员、工作站、工作站 ID、时间和日期。这些部分放在尖括号 <> 中。其余部分不需括起来。没有尖括号的部分将在不进行任何更改的情况下用作注册参数值。
    要从列表中删除元素，单击删除。可以单击向上和向下来更改元素顺序。
    单击导入…可从文本文件导入元素列表。独立的行将被视为列表元素。
必需 | 指定是否为必填参数。如果参数被标为必填参数，除非输入参数值，否则将不能导出批处理文件。
描述： 在此字段中输入注册参数的注释。


选项对话框的 FlexiCapture 服务器选项卡

FlexiCapture 服务器对话框的 选项选项卡

在该选项卡上，可以指定存储批处理文件类型设置的 FlexiCapture 服务器地址。单击工具 > 选项… 并在打开的对话框中单击 FlexiCapture 服务器选项卡，配置必要的参数。

选项 | 描述
服务器：[http://server] | 指定 http://server 格式的服务器路径。
验证… | 打开安全性对话框，指定连接服务器的信息。可以使用 Windows 验证或输入用户特定的名称和密码。 要启用按名称和密码验证，必须在安装应用程序服务器的计算机上对 Internet Information server 进行相应设置，即允许对 FlexiCapture\Server 文件夹进行基本验证。详情请联系系统管理员。
测试连接 | 用于检查服务器的连接情况。
在启动时自动更新批处理文件类型 | 如果希望每次启动扫描工作站时自动更新批处理文件类型列表，可选择此选项。在源：([http://server][/file.xml]) 中指定列表更新使用的文件。
加载带有较小缩略图的重新扫描页面 | 选择该选项以便从重新扫描任务加载带有较小缩略图的页面。


选择批处理文件类型存储对话框

选择批处理文件类型存储器对话框

通过该对话框，可以选择文件夹来存储符合批处理文件类型描述的 XML 文件。在批处理文件类型发送和导入期间，将打开该对话框（请参阅批处理文件类型）。

符合批处理文件类型描述的 XML 文件既可以存储到本地的同一台计算机上，也可以存储到远程服务器上。选择本地文件或远程。

对于本地文件，请在路径：字段中指定路径。单击浏览…来查找所需位置。

对于远程文件，请指定 http://server[/file.xml] 格式的路径。

当发送批处理文件类型时，您可以选择将这些批处理文件类型分发至所有扫描工作站选项。如果选择了该选项，所有绑定到服务器的扫描工作站在启动时都将尝试从服务器加载批处理文件类型数据。如果取消选择该选项，扫描工作站将不会访问服务器以接收批处理文件类型。


其它对话框

选项
选项对话框的常规选项卡
工具栏自定义
脚本编辑器
批处理文件属性
文档属性
页面属性
发送任务对话框


选项

在此对话框中，可以选择扫描工作站的常规选项：

  • 裁剪线条颜色、编辑颜色和在发送后是否删除批处理文件（常规 选项卡）
  • 扫描选项（扫描选项卡）
  • 创建文档和批处理文件并进行命名的选项（批处理文件选项选项卡）
  • 图像处理选项（图像处理选项卡）
  • 页面大小控制选项（页面大小控制选项卡）；
  • 脚本配置选项（脚本选项卡）
  • 发送选项（发送任务选项卡）
  • FlexiCapture 服务器地址（FlexiCapture 服务器 选项卡）

要打开该对话框，请选择工具 > 选项…。


选项对话框的常规选项卡

常规对话框的常规选项卡

在该选项卡上，可以指定常规处理选项。选择工具 > 选项…，并单击常规选项卡。

选项 | 描述
工作站 ID | 工作站标识符。
裁剪线条颜色 | 选择此选项以指定裁剪线条颜色。要选择所需的颜色，请单击此按钮。
编辑颜色 | 选择此选项以指定编辑图像使用的填充颜色（页面 > 编辑）。要选择所需的颜色，请单击颜色按钮。
其他
导出之后自动删除批处理文件 | 如果要在完成导出后删除批处理文件，请选择此选项。


工具栏自定义

该对话框使您可以为单独的批处理文件或为特定的批处理文件类型自定义脚本工具栏。要为单独的批处理文件自定义脚本 工具栏，单击工具 > 选项…对话框中脚本选项卡上的自定义工具栏…按钮。对于特定的批处理文件类型，您可以在用 批处理文件类型向导创建批处理文件类型时自定义脚本 工具栏，或者在 批处理文件类型属性对话框中进行调整。对于这种情况，请单击脚本选项卡上的自定义工具栏…按钮。

工具栏自定义对话框将打开。

窗口显示脚本名和与其相关的图标。

要添加将运行选定脚本的按钮，请单击添加按钮…并从对当前批处理文件类型可用的脚本的下拉列表中选择脚本。

要在脚本工具栏的两个按钮之间添加分隔符，请选择您想在其后添加分隔符的按钮并单击添加分隔符按钮。

使用向上和向下按钮将选定按钮分别向上和向下移动一个位置。

您可以通过单击删除来除去按钮。

加载位图按钮使您可以为脚本按钮添加图标。

注意：为所有图标仅加载一个 *.bmp 文件是可能的。要对一个以上的按钮添加图标，您必须加载一个包含所有必要图片的位图。*.bmp 文件的尺寸必须等于 24*< 图标的数量 >x24 像素。已加载的位图将自动分割。要用图标替换按钮，请首先单击脚本名，然后单击所需的图标。图标将出现在脚本名旁边。


脚本编辑器

脚本编辑器使您可以为单独的批处理文件或为一组特定类型的批处理文件编写和编辑脚本。

要打开脚本编辑器，请单击脚本选项卡上的编辑…按钮。

您可以为脚本选择所需的脚本语言：JScript® 或 VBScript。

要编辑脚本，使用脚本编辑器工具栏上的菜单命令或按钮。

要检查脚本代码：

  • 单击工具栏上的检查按钮，或
  • 从工具菜单选择检查脚本 ，或
  • 按 F9

如果您想要添加 自定义功能，单击脚本名旁的箭头并选择全局模块，在事件的全局模块或导出的全局模块中创建您的功能。

要关闭脚本编辑器，请选择文件 > 退出或按窗口右上角的“关闭”按钮。

有关脚本的更多信息，请参阅使用脚本部分。


批处理文件属性

该对话框显示所选批处理文件的属性。

右键单击批处理文件，并从快捷菜单选择属性，或选择页面 > 属性，或按 Alt+Enter，均可打开此对话框。

Tab 键 描述
常规 显示所选批处理文件的常规属性：其名称、其优先级、其类型、批处理文件中的文档和页面数、（已导出批处理文件的）导出目标和导出时间。可以更改批处理文件名称、其优先级和类型。

要更改选定批处理文件的类型，请单击更改…按钮。在将要打开的选择批处理文件类型对话框中，选择可用的批处理文件类型之一，然后单击确定。
中断的导出任务 显示中断的导出任务的属性
  • 目标位置
    任务的目标
  • 时间
    任务开始的时间
  • 进度
    任务进度
  • 原因
    为何任务中断

您可以继续处理这些任务或者移除这些任务（通过分别单击继续或除去按钮）。
注册参数 显示所选批处理文件的注册参数。
  • 名称
    必填的注册参数标有星号 (*)。
    必须配置好必填的注册参数，才能发送批处理文件。
  • 值：
    在该列中，您可以输入注册参数的值。
  • 注释：
    注释可能包含有关注册参数的有用信息。


文档属性

该对话框显示所选文档的属性。

要打开该对话框，在批处理文件窗口或图像窗口中选择所需的文档，然后选择页面 > 属性，或右键单击该文档并从快捷菜单中选择属性，或者按 Alt+Enter。

Tab 键 | 描述
常规 | 显示选定文档的常规属性：其名称、其优先级、其批处理文件、其在批处理文件中的编号、文档中的页面数。可以更改文档名称和文档优先级。
注册参数 显示选定文档的注册参数。
  • 名称
    必填的注册参数标有星号 (*)。
    必须配置好必填的注册参数，才能发送批处理文件。
  • 值：
    在该列中，您可以输入注册参数的值。
  • 注释：
    注释可能包含有关注册参数的有用信息。


页面属性

在这个窗口，可以查看选定页面的属性。

  • 页面的批处理文件，
  • 批处理文件中的页数，
  • 页面来源，
  • 页面大小（单位为像素），
  • 分辨率，
  • 打印尺寸（单位为英吋），
  • 彩色模式，
  • 扫描质量警告。

在批处理文件窗口或图像窗口中选择所需的图像，然后选择页面 > 属性，或右键单击该图像并从快捷菜单选择属性，或者按 Alt+Enter，均可打开该窗口。


发送任务对话框

发送任务对话框使您可以查看发送任务的属性。如果发送任务中断，您可以分别通过单击继续或除去按钮继续处理该任务或除去它。您还可以取消正在执行的任务。为此，请单击取消按钮。

您可以通过单击任务栏中的图标 [image] 打开发送任务对话框。

属性 | 描述
数量 | 任务的数量
批处理文件 | 批处理文件名
状态 | 任务的状态
启动时间 | 任务开始的时间
进度 | 任务进度
目标 | 任务的目标
处理注意事项 | 任务执行的注意事项


在 ABBYY 扫描工作站中使用脚本

自定义脚本使您能够创建您自己的使用 ABBYY 扫描工作站的方案。某些典型的方案如下：

  • 在双面扫描之后，将已扫描页面按正确的顺序放置
  • 扫描后自动分割大尺寸页面
  • 为新创建的批处理文件和文档自动填充注册参数
  • 对有外部组件的页面进行质量检查
  • 有可能将页面存储到两个目标，其中一个用作备份

脚本可自动启动（对特定事件的响应），也可以通过明确的用户命令启动。

受支持的脚本语言

以下脚本语言受支持：JScript® 和 VBScript。

使用细节

当引用当前对象的方法和字段时，在 VBScript 中强制使用关键字 "Me" （在 JScript 中则使用 "this" ）。在导出脚本中，关键字 "Me" (VBScript) 或 "this" (JScript) 实现 IExportBatch 接口。在事件脚本中，关键字 "Me" 或 "this" 实现 IWorkSpace 接口。

使用集合

所有集合支持以下方法：

名称 | 类型 | 访问 | 描述
Count | int | 只读 | 集合中的项目数量
Item( index : int ) | 项目接口 | 只读 | 使用给定索引检索集合中的项目。 枚举从 "0" 开始。

注：您可以使用圆括号来查找集合中的项目，而非使用方法 Item。

例如，Items( 1 ).Text = "Hello".

所有集合可在 "for each" 和类似构造中使用。

注册表键选项

对于 ABBYY 扫描工作站中启动的脚本，您可以更改注册表中的以下值：

HKEY_CURRENT_USER\Software\ABBYY\ScanStationFC\2.0\Shell\Script\DisableDebugging

HKEY_CURRENT_USER\Software\ABBYY\ScanStationFC\2.0\Shell\Script\DisableEventScripts

在默认情况下，两个值都设置为 "false"。

更改 "DisableEventScripts" 的值为 true 可防止启动新脚本。已运行的脚本将不会被此命令禁用。

自定义函数

脚本编辑器允许用户创建他们自己的函数和过程，然后从事件脚本的代码和发送脚本的代码中调用它们。

自定义函数可在全局模块（事件全局模块或导出全局模块）之一中进行创建。要添加自定义函数，在脚本编辑器中单击脚本名称旁的箭头并选择全局模块。

一个模块内的所有函数必须用同一种语言编写。发送脚本或事件处理器的核心代码可用不同于相应全局模块中使用的语言编写。

例如，从用 VBScript 编写的事件脚本，您可以调用全局模块中包含的用 JScript 编写的函数。

函数只可以从“它们自己”的模块调用。这意味着从事件脚本中，您只能调用在全局事件模块中包含的函数；从发送脚本的代码中，您只能调用在全局导出模块包含的函数。否则，您在执行中将出现错误。


事件

可通过脚本处理的事件描述如下。自动脚本是根据批处理文件类型设置的。在撤销操作中不调用它们。

在启动工作站时自动调用。

在工作站启动之后执行。

在关闭工作站之前自动调用。

在关闭工作站之前执行。

在扫描会话完成之后自动调用

在扫描会话完成之后执行。此类型的脚本用于根据自定义规则修改已扫描的批处理文件。

在添加页面后自动调用。

在将页面添加至批处理文件后执行。此类型的脚本用于修改页面。

在创建批处理文件后自动调用。

在批处理文件在扫描过程中手动或自动创建之后执行。此类型的脚本用于填写批处理文件的注册参数，根据自定义规则重命名批处理文件等。

在形成文档后自动调用。

在文档在扫描过程中手动或自动形成之后执行。此类型的脚本用于填写文档的注册参数，根据自定义规则重命名批处理文件，使用外部组件搜索条形码值等。

在删除工作空间的元素之前自动调用。

在用户删除元素之前执行。此类型的脚本用于防止删除重要元素。

在页面上的操作进行之前自动调用

在用户应用页面修改操作之前执行。此类型的脚本用于防止修改已被修改的页面。该脚本提供了有关正在执行的操作的信息。

在页面操作完成之后自动调用。

在用户应用页面修改操作之后执行。此类型的脚本用于保存有关已修改页面的信息。该脚本提供了有关正在执行的操作的信息。

在导出前自动调用

在任务发送至后台之前，但在批处理文件注册参数定义之后执行。如果调用失败，则导出任务未执行，且向用户显示预定义消息。此类型的脚本可以修改批处理文件。

在导出之后自动调用

在导出任务在后台中成功完成之后执行，但与导出任务不同，脚本是在主应用程序中执行的。如果主应用程序在导出完成之时关闭，脚本将在工作站下次启动时执行。此类型的脚本可以修改批处理文件。

导出的其他类型

与其他类型的导出类似，在后台中执行。此类型的脚本无法修改批处理文件，它们只可以返回结果路径和/或失败的原因及批处理文件的已导出元素列表。如果导出继续，列表和路径都将提供给脚本。

脚本导出在导出选项卡的批处理文件类型中设置。

由显式的用户命令调用。

脚本的已命名列表已在批处理文件类型中进行声明。当为已打开的批处理文件调用相应的命令时，您可以从该列表中选择所需的脚本来执行。

来自任何类型列表的脚本可以作为独立的按钮添加至其他用户脚本工具栏。

注意：工具栏自定义可以从脚本列表调用，也可以从主菜单调用。

在脚本列表中，也可能指定触发脚本的事件。


对象

本节包含了在脚本中使用的对象的描述、其属性和方法。

导出脚本对象
事件脚本对象


来自导出脚本的可用对象

从导出脚本您可以访问以下对象：

IExportBatch
IBatchType
IExportBatchItems
IExportBatchItem
IExportDocumentInfo
IPageInfo
IScriptProperties
IExportRegistrationProperties
IExportRegistrationProperty
IExportPageSourceInfo
IPageRect
IScriptResult
IImageSavingOptions


IBatchType

功能

表示批处理文件类型。

属性

名称 | 类型 | 访问 | 描述
名称 | 字符串 | 只读 | 批处理文件类型的名称
UID | 字符串 | 只读 | 批处理文件类型的唯一标识


IExportAttachmentByteArray

功能

表示附件二进制数据。

属性

名称 | 类型 | 访问 | 描述
名称 | 字符串 | 只读 | 数组名称


IExportAttachments

功能

适用于将用户二进制数据或文件与工作空间项目关联。

方法

定义 | 描述
Has (name: string): bool | 检查附件数组是否包含带有指定名称的附件
SaveToFile (name: string, path: string) | 将带有指定名称的附件保存至指定路径

属性

名称 | 类型 | 访问 | 描述
名称 | 变体 | 只读 | 一组附件名称
IsEmpty | bool | 只读 | 指定该组用户附件是否为空
ByteArray (name: string) | IAttachmentByteArray | 只读 | 按其名称检索附件的二进制数据


IExportBatch

功能

表示可导出的批处理文件。该对象在脚本中用关键字 "this" 表示。

方法

定义 | 描述
CalcExportedPageCount () : int | 计算已导出页面数
NotifyProcessingProgress (itemsProcessed: int, itemsRemained: int) | 显示有关导出过程的通知
CheckCanceled () | 检查用户是否取消了导出任务。如果任务被取消，将返回异常。
NewPageRect () : IPageRect | 定义页面的矩形
NewImageSavingOptions () : IImageSavingOptions | 设置图像保存选项

属性

名称 | 类型 | 访问 | 描述
ScriptEnvInfo | 字符串 | 只读 | 有关脚本触发条件的环境信息。 在导出事件中，这是导出任务 ID。
结果 | IScriptResult | 只读 | 脚本执行的结果
类型 | IBatchType | 只读 | 批处理文件的类型
源 ID | 字符串 | 只读 | 工作站标识符
名称 | 字符串 | 只读 | 批处理文件的名称
优先级 | int | 只读 | 批处理文件的优先级
PageCount | int | 只读 | 批处理文件中的总页面数。
子级 | IExportBatchItems | 只读 | 子项目
RegistrationProperties | IExportRegistrationProperties | 只读 | 批处理文件的注册属性
ResultPath | 字符串 | 读/写 | 产生的导出路径
ScriptProperties | IScriptProperties | 只读 | 脚本属性


IExportBatchItem

功能

表示文档或页面

方法

定义 | 描述
SaveAs (fileName: string, [optional] options: VARIANT) | 保存文档页面（或页面图像）至文件。 当在单页格式保存多页文档时，将返回异常。

属性

名称 | 类型 | 访问 | 描述
IsDocument（或 IsPage） | 布尔 | 只读 | 检查项目是否为文档（或页面）。
DocumentInfo（或 PageInfo） | IExportDocumentInfo（或 IExportPageInfo） | 只读 | 项目属性。如果已请求的属性与项目类型不一致，IsDocument/IsPage 检查就会执行。
子级 | IExportBatchItems | 只读 | 子项目
父级 | IExportBatchItem | 只读 | 父项目
上一步 | IExportBatchItem | 只读 | 上一个项目
下一步 | IExportBatchItem | 只读 | 下一个项目
索引 | int | 只读 | 在父集合中的项目索引
名称 | 字符串 | 只读 | 项目的名称
ScriptProperties | IScriptProperties | 只读 | 脚本属性
IsExported | 布尔 | 读/写 | 指定项目是否已导出


IExportBatchItems

功能

IExportBatchItem 对象的集合。


IExportDocumentInfo

功能

存储文档属性。

属性

名称 | 类型 | 访问 | 描述
优先级 | int | 只读 | 文档的优先级
条形码 | 字符串 | 只读 | 文档条形码的值
RegistrationProperties | IExportRegistrationProperties | 只读 | 文档的注册属性


IExportPageSourceInfo

功能

存储有关页面图像来源的信息。

属性

名称 | 类型 | 访问 | 描述
编辑... | 字符串 | 只读 | 扫描仪详细信息。对于从文件接收的图像，为空。
路径 | 字符串 | 只读 | 文件的路径（没有文件名）。从扫描仪接收的图像为空。
文件 | 字符串 | 只读 | 文件名
FilePageIndex | int | 只读 | 源文件中的页面索引。对于从扫描仪接收的图像，为 "-1"。


IExportRegistrationProperties

功能

IExportRegistrationProperty 对象的集合

方法

定义 | 描述
Has (name: string) : bool | 检查指定的属性是否存在
Value (name: string) : string | 根据名称检索注册属性的值


IExportRegistrationProperty

功能

表示注册属性。

属性

名称 | 类型 | 访问 | 描述
名称 | 字符串 | 只读 | 注册属性的名称
Value | 字符串 | 只读 | 注册属性的值


IImageSavingOptions

功能

存储图像保存选项。

属性

名称 | 类型 | 访问 | 描述
格式 | 字符串 | 读/写 | 图像保存格式。可接受的表达式："tif"、"dcx"、"jpg"、"bmp"、"jpg2000"、"pcx"、"png"、"pdf"。 字符串对大小写不敏感。
ColorType | 字符串 | 读/写 | 颜色方案。可接受的值："FullColor"、"GrayScale"、"BlackAndWhite"。字符串对大小写不敏感。
质量 | int | 读/写 | JPEG 压缩的图像质量（以百分数计算）
矩形 | IPageRect | 读/写 | 保存的区域
ShouldOverwrite | 布尔 | 读/写 | 指定是否覆盖现有文件
AddProperFileExt | 布尔 | 读/写 | 如果该值设置为 "true"，扩展名将根据在图像保存中使用的图像格式来设置。


IPageInfo

功能

存储页面属性。

属性

名称 | 类型 | 访问 | 描述
高度 | int | 只读 | 页面的高度
宽度 | int | 只读 | 页面的宽度
分辨率 | int | 只读 | 页面的分辨率
SourceInfo | IExportPageSourceInfo | 只读 | 有关页面来源的信息。


IPageRect

功能

表示页面的矩形

属性

名称 | 类型 | 访问 | 描述
左 | int | 读/写 | 左侧坐标
右 | int | 读/写 | 右侧坐标
顶部 | int | 读/写 | 顶部坐标
底部 | int | 读/写 | 底部坐标


IScriptProperties

功能

存储有关在代码执行过程中所执行操作的信息。如果再次调用脚本，可能会使用此信息。

方法

定义 | 描述
Has (name: string): bool | 检查一组脚本属性中是否包含指定的属性
Set (name: string, value: string) | 设置属性的名称和值
Delete (name: string) | 删除指定的属性
DeleteAll ( ) | 删除所有的属性

属性

名称 | 类型 | 访问 | 描述
名称 | 变体 | 只读 | 由用户指定的一组属性名
IsEmpty | 布尔 | 只读 | 指定这组脚本属性是否为空
Value (name: string) | 布尔 | 读/写 | 属性的值。在脚本中，您可以使用单词 "Value" 来访问属性的 "Name" 参数，也可以不使用它来访问。您可以使用圆括号，而不是 "Value"。因此，您可以编写 params( "Name" ) = "newValue"，而不是 params.Value( "Name" ) = "newValue"。


IScriptResult

功能

表示脚本执行的结果。

属性

名称 | 类型 | 访问 | 描述
已成功 | 布尔 | 读/写 | 指定操作是否已成功
错误消息 | 字符串 | 读/写 | 错误消息


来自事件脚本的可用对象

从事件脚本，您可以访问以下对象：

IWorkspace
IBatchTypes
IBatchType
IWorkspaceItems
IWorkspaceItem
IBatchInfo
IDocumentInfo
IPageInfo
IScriptProperties
IRegistrationProperties
IRegistrationProperty
IScriptValues
IPageSourceInfo
IPageRect
IScriptResult
IImageSavingOptions
IEmptyPageDetectionOptions
IBarcodeFindingOptions
IScriptFoundBarcodes
IScriptFoundBarcode


IAttachmentByteArray

功能

表示附件二进制数据。

方法

定义 | 描述
Add (value: BYTE) | 将新字节添加至数组。
InsertAt (value: BYTE, pos: int) | 将新字节插入数组的指定位置。
DeleteAt (pos: int) | 删除指定位置的数组元素。
DeleteAll ( ) | 删除数组的所有元素。

属性

名称 | 类型 | 访问 | 描述
名称 | 字符串 | 只读 | 数组名称


IAttachments

功能

适用于将二进制数据或文件与工作空间项目关联。将批处理文件发送至 FlexiCapture 服务器时，会传递数据。将批处理文件发送至文件夹或 FTP 文件夹时，附件会放入存储批处理文件的文件夹，相应的条目会添加至 XML 描述文件。

方法

定义 | 描述
Has (name: string): bool | 检查附件数组是否包含带有指定名称的附件
AddNew (name: string) : IAttachmentByteArray | 添加带有指定名称的新数组
AddFromFile (name: string, path: string) | 从指定路径添加带有指定名称的新附件
SaveToFile (name: string, path: string) | 将带有指定名称的附件保存至指定路径
Delete (name: string) | 删除带有指定名称的附件文件
DeleteAll ( ) | 删除所有附件

属性

名称 | 类型 | 访问 | 描述
名称 | 变体 | 只读 | 一组附件名称
IsEmpty | bool | 只读 | 指定该组用户附件是否为空
ByteArray (name: string) | IAttachmentByteArray | 只读 | 按其名称检索附件的二进制数据


IBarcodeFindingOptions

功能

存储用于检测条形码的选项。

属性

名称 | 类型 | 访问 | 描述
矩形 | IPageRect | 读/写 | 在页面上限制条形码区域的矩形。如果所有的尺寸等于 "0"，该矩形将被认为等于整个页面。
类型 | IScriptValues | 只读 | 条形码的类型。要获得可接受值的列表，请参见有关 IScriptFoundBarcode 对象的描述。
方向 | IScriptValues | 只读 | 条形码方向要获得可接受值的列表，请参见有关 IScriptFoundBarcode 对象的描述。


IBatchInfo

功能

存储批处理文件属性。

属性

名称 | 类型 | 访问 | 描述
类型 | IBatchType | 只读 | 批处理文件的类型
优先级 | int | 读/写 | 批处理文件的优先级
PageCount | int | 只读 | 批处理文件中的总页面数。
RegistrationProperties | IRegistrationProperties | 只读 | 批处理文件的注册属性
ResultPath | 字符串 | 读/写 | 产生的导出路径。只可在导出前脚本中进行修改。
ExportError | 字符串 | 只读 | 批处理文件导出错误


IBatchTypes

功能

IBatchType 对象的集合

方法

定义 | 描述
Has (name: string) : bool | 检查集合是否包含指定的批处理文件类型
UID (name: string) : string | 根据批处理文件名检索批处理文件类型的唯一标识


IDocumentInfo

功能

存储文档属性。

属性

名称 | 类型 | 访问 | 描述
优先级 | int | 读/写 | 文档的优先级
条形码 | 字符串 | 读/写 | 文档条形码的值
RegistrationProperties | IRegistrationProperties | 只读 | 文档的注册属性


IEmptyPageDetectionOptions

功能

存储检测空白页面的选项

属性

名称 | 类型 | 访问 | 描述
KernelRect | IPageRect | 读/写 | 页面内核的相对矩形（以缇测量）。如果所有尺寸等于 "0"，该矩形可自动定义。
MaxBarcodesCount | int | 读/写 | 可在空白页面上放置的最大条形码数。如果该值是 "-1"，则该属性未使用。
MaxBlackSquaresCount | int | 读/写 | 可在空白页面上放置的最大黑色方块数。如果该值是 "-1"，则该属性未使用。
MaxTextObjectsCount | int | 读/写 | 可在空白页面上放置的最大文本对象数。如果该值是 "-1"，则该属性未使用。
MaxBlacknessPercentage | int | 读/写 | 可在空白页面上放置的黑色空格（按百分比计算）的最大相对数目。如果该值是 "-1"，则该属性未使用。


IPageInfo

功能

存储页面属性。

属性

名称 | 类型 | 访问 | 描述
高度 | int | 只读 | 页面的高度
宽度 | int | 只读 | 页面的宽度
分辨率 | int | 只读 | 页面的分辨率
SourceInfo | IPageSourceInfo | 只读 | 有关页面来源的信息。


IPageSourceInfo

功能

存储有关页面图像来源的信息。

属性

名称 | 类型 | 访问 | 描述
编辑... | 字符串 | 读/写 | 扫描仪详细信息。对于从文件接收的图像，为空。
路径 | 字符串 | 读/写 | 通向文件的路径（没有文件名）。从扫描仪接收的图像为空。
文件 | 字符串 | 读/写 | 文件名
FilePageIndex | int | 读/写 | 源文件中的页面索引。对于从扫描仪接收的图像，其值为 "-1"。


IRegistrationProperties

功能

IRegistrationProperty 对象的集合

方法

定义 | 描述
Has (name: string) : bool | 检查指定的属性是否存在
Add (name: string) : IRegistrationProperty | 添加注册属性
InsertAt (name: string, pos: int) : IRegistrationProperty | 在给定位置插入指定的注册属性
Delete (name: string) | 删除指定名称的注册属性
DeleteAt (pos: int) | 从指定位置删除注册属性
DeleteAll ( ) | 删除所有注册属性

属性

名称 | 类型 | 访问 | 描述
Value (name: string) | 字符串 | 只读 | 属性的值


IRegistrationProperty

功能

表示注册属性。

属性

名称 | 类型 | 访问 | 描述
名称 | 字符串 | 只读 | 注册属性的名称
Value | 字符串 | 读/写 | 注册属性的值
注释 | 字符串 | 读/写 | 注释
IsReadOnly | 布尔 | 读/写 | 指定对属性的访问是否是只读
IsRequired | 布尔 | 读/写 | 指定属性是否是强制的
PossibleValues | IScriptValues | 只读 | 要从下拉列表中选择的值。 如果列表为空，属性将在编辑框中指定。


IScriptFoundBarcode

功能

表示已找到的条形码

属性

名称 | 类型 | 访问 | 描述
矩形 | IPageRect | 只读 | 页面上条形码区域的矩形
值 | 字符串 | 只读 | 已找到条形码的值
类型 | 字符串 | 只读 | 条形码类型。可接受的值："Code39"、"CheckCode39"、"Interleaved25"、"CheckInterleaved25"、"EAN13"、"Code128"、"EAN8"、"PDF417"、"Codabar"、"CheckCodabar"、"UPCA"、"UPCE"、"Industrial25"、"IATA25"、"Matrix25"、"Code93"、"Postnet"、"UCC128"、 "Patch"、"Code39WithoutAsterisk"、"Aztec"、"Datamatrix"、"QRCode"。字符串对大小写不敏感。
方向 | 字符串 | 只读 | 条形码的方向。可接受的值："LeftToRight"、"DownToTop"、"RightToLeft"、"TopToDown"。字符串对大小写不敏感。


IScriptFoundBarcodes

功能

IScriptFoundBarcodes 对象的集合。


IScriptValues

功能

表示一组唯一的字符串值。支持 Item 和 Count 方法。

方法

定义 | 描述
Has (name: string) : bool | 检查指定的值是否存在
Add (name: string) | 添加新值
Delete (name: string) | 删除带有指定名称的值
DeleteAll ( ) | 删除所有值


IWorkSpace

功能

表示工作站的工作空间。该对象在脚本中以关键字 "this" 提供

方法

定义 | 描述
ClearSelection () | 清除当前的选择
AddBatch (target: IWorkspaceItem, name: string, type: IBatchType): IWorkspaceItem | 添加批处理文件 如果未指定名称，将根据批处理文件设置生成。
AddDocument (page: IWorkspaceItem, name: string): IWorkspaceItem | 将页面插入新文档。如果页面已经包括在文档中，将创建三个文档：一个带有以前页面的文档，一个当前页面的文档和一个带有以下页面的文档。如果 IWorkspaceIteme.Name 属性为空，名称将根据批处理文件设置生成。
AddPages (fileName: string, target: IWorkspaceItem, [optional] inside: bool): IWorkspaceItems | 从文件添加页面
DeleteItem (item: IWorkspaceItem) | 删除指定项目
Wait (millisecond: int) | 在指定时间内暂停脚本执行（以毫秒计算）
FindPageBarcodes (page: IWorkspaceItem, [optional] options: IBarcodeFindingOptions): IScriptFoundBarcodes | 在页面上寻找条形码
DetectPageEmpty (page: IWorkspaceItem, [optional] options: IEmptyPageDetectionOptions): bool | 检测空白页
SetPageImage (page: IWorkspaceItem, fileName: string, [optional] filePageIndex: int) | 更改页面图像
Scan ([optional] folder: string) | 用当前批处理文件类型的设置开始扫描
RunScript (scriptName: string, [optional] info: string, [optional] skipShowError: bool): IScriptResult | 运行脚本执行
Send (batch: IWorkspaceItem) | 用当前批处理文件类型的设置导出批处理文件
SendToFolder (batch: IWorkspaceItem, skipShowExportOptions: bool) | 用当前批处理文件类型的设置将批处理文件导出至文件夹 skipShowExportOptions 参数指定了在发送批处理文件前是否显示导出选项对话框。
SendToFTP (batch: IWorkspaceItem, skipShowExportOptions: bool) | 用当前批处理文件类型的设置将批处理文件导出至 FTP 文件夹 skipShowExportOptions 参数指定了在发送批处理文件前是否显示导出选项对话框。
SendToFC (batch: IWorkspaceItem, skipShowExportOptions: bool) | 用当前批处理文件类型的设置将批处理文件发送至 ABBYY FlexiCapture skipShowExportOptions 参数指定了在发送批处理文件前是否显示导出选项对话框。
SendByScript (batch: IWorkspaceItem, skipShowExportOptions: bool) | 用当前批处理文件类型的设置通过使用脚本发送批处理文件 skipShowExportOptions 参数指定了在发送批处理文件前是否显示导出选项对话框。
Exit ( ): bool | 完成工作站工作
NewPageRect ( ): IPageRect | 定义页面矩形
NewImageSavingOptions ( ): IImageSavingOptions | 设置图像保存选项
NewEmptyPageDetectionOptions ( ): IEmptyPageDetectionOptions | 设置用于检测空页面的选项
NewBarcodeFindingOptions ( ): IBarcodeFindingOptions | 设置条形码查找选项

属性

名称 | 类型 | 访问 | 描述
ScriptEnvInfo | 字符串 | 只读 | 有关脚本触发条件的环境信息。 对导出前或导出后自动触发的脚本，其值是 "<exportType> <taskID>"，"exportType" 可以是 "Folder"、"FTP"、"FC"、"RS" 或 "Script"，而 "taskID" 是导出任务标识符。 对页面转换前或页面转换后自动触发的脚本，属性具有以下值之一："Rotate <angle>"、"FlipHorizontal"、"FlipVertical"、"Invert"、"ConvertToBW"、"Descew"、"Despeckle"、"Erase <rectLeft> <rectTop> <rectRight> <rectBottom>"、"Crop <rectLeft> <rectTop> <rectRight> <rectBottom>"、"SplitHorizontal <pos>"、"SplitVertical <pos>"、"ChangeResolution <newRes>"、"Scale <ratio>"、"FreeScale <newWidth>, <newHeight>, <newRes>"。
结果 | IScriptResult | 只读 | 脚本执行的结果
源 ID | 字符串 | 只读 | 工作站标识符
BatchTypes | IBatchTypes | 只读 | 批处理文件类型
CurrentBatchType | IBatchType | 读/写 | 当前的批处理文件类型
批处理文件 | IWorkspaceItems | 只读 | 批处理文件
ActiveBatch | IWorkspaceItem | 读/写 | 活动的批处理文件
选择 | IWorkspaceItems | 只读 | 当前的选择。包含仅批处理文件、仅文档或仅页面。
ScriptProperties | IScriptProperties | 只读 | 脚本属性
ScriptItems | IWorkspaceItems | 只读 | 对其调用脚本的项目。对不同的事件返回的值也不同。 对于事件 "在工作站已启动时" 和 "在工作站关闭时"，返回值为空。 对事件 "在扫描完成时"，返回值是在扫描会话过程中添加的页面列表。 对于其他事件，返回值根据事件的不同，分别是批处理文件、文档或页面。 当脚本由显式的用户命令启动时，将返回当前选择的项目集合。


IWorkspaceItem

功能

表示工作空间的项目。可能是批处理文件、文档或页面。

方法

定义 | 描述
SaveAs (fileName: string, [optional] options: IImageSavingOptions) | 保存页面/页面图像/批处理文件至文件。 当以单页格式保存多页文档（或批处理文件）时，会返回异常。
Move (target: IWorkspaceItem, [optional] inside: bool) | 在目标项目之后，或在目标项目内部移动文档或页面。
Copy (target: IWorkspaceItem, [optional] inside: bool): IWorkspaceItem | 在目标项目之后，或在目标项目内部复制文档或页面。
Rotate (angle: int) | 旋转文档的一个页面（或所有页面）或批处理文件
FlipHorizontal ( ) | 水平翻转文档的一个页面（或所有页面）或批处理文件
FlipVertical ( ) | 垂直翻转文档的一个页面（或所有页面）或批处理文件
Invert ([optional] rect: IPageRect) | 反转文档的一个页面（或所有页面）或批处理文件
ConvertToBW ( ) | 将文档的一个页面（或所有页面）或批处理文件转换为黑白图像。
Descew ([optional] byLines: bool, [optional] byBlackSquares: bool, [optional] byText: bool) | 为文档的一个页面（或所有页面）或批处理文件消除歪斜。默认情况下，byLines 和 byBlackSquares 参数设置为 "false"，而 ByText 参数设置为 "true"。
Despeckle ([optional] garbageSize: VARIANT) | 为文档的一个页面（或所有页面）或批处理文件去斑。
Erase (rect: IPageRect, [optional] rColor: int, [optional] gColor: int, [optional] bColor: int) | 删除文档的一个页面（或所有页面）或批处理文件上的某个区域
Crop (rect: IPageRect) | 裁剪文档的一个页面（或所有页面）或批处理文件上的某个区域
SplitHorizontal (pos: int) | 水平分割文档的一个页面（或所有页面）或批处理文件
SplitVertical (pos: int) | 垂直分割文档的一个页面（或所有页面）或批处理文件
ChangeResolution (int) | 将文档的一个页面（或所有页面）或批处理文件的图像分辨率更改至指定值。
Scale (ratio: int) | 相对于基本值 100，缩放文档的一个页面（或所有页面）或批处理文件。
FreeScale (newWidth: int, newHeight: int, newResolution: int) | 根据指定的值缩放文档的一个页面（或所有页面）或批处理文件。

属性

名称 | 类型 | 访问 | 描述
IsBatch（IsDocument 或 IsPage） | 布尔 | 只读 | 指定项目是否为批处理文件、文档或页面
BatchInfo（DocumentInfo 或 PageInfo） | IBatchInfo/IDocumentInfo/IPageInfo | 只读 | 项目属性。如果已请求的属性与项目类型不一致，IsBatch（IsDocument 或 IsPage）检查就会执行。
子级 | IWorkspaceItems | 只读 | 子项目
父级 | IWorkspaceItem | 只读 | 父项目
上一步 | IWorkspaceItem | 只读 | 上一个项目
下一步 | IWorkspaceItem | 只读 | 下一个项目
索引 | int | 只读 | 在父集合中的项目索引
名称 | 字符串 | 读/写 | 项目名称
ScriptProperties | IScriptProperties | 只读 | 脚本属性
IsSelected | 布尔 | 读/写 | 指定项目是否已选定为特定项目更改该属性值不会影响其他项目。 如果当前选择包含不同类型的元素，则不起作用。
IsExported | 布尔 | 读/写 | 指定项目是否已导出。只可在导出前脚本为批处理文件项目进行修改。


IWorkspaceItems

功能

IWorkspaceItem 对象的集合。


样本脚本

自动工作站

自动工作站扫描图像，导出已接收的批处理文件并关闭。

[JScript]

Scan();

var batch = Batches( Batches.Count - 1 );

Send( batch );

while( !batch.IsExported ) {

Wait( 100 );

}

Exit();

Fully functional export

[JScript]

var fso = new ActiveXObject("Scripting.FileSystemObject");

if( ResultPath == "" ) {

ResultPath = "C:\\Export";

}

if( !fso.FolderExists( ResultPath ) ) {

fso.CreateFolder( ResultPath );

}

var params = NewImageSavingOptions();

params.AddProperFileExt = true;

params.Format = "bmp";

var exportedPageCount = CalcExportedPageCount();

NotifyProcessingProgress( exportedPageCount , PageCount - exportedPageCount );

for( i = 0; i < Children.Count; i++ ) {

var item = Children.Item( i );

if( item.IsDocument ) {

if( item.IsDocument ) {

var docDir = ResultPath + "\\" + item.Name;

if( !fso.FolderExists( ResultPath ) ) {

fso.CreateFolder( docDir );

}

for( j = 0; j < item .Children.Count; j++ ) {

CheckCanceled();

var page = item.Children.Item( j );

if( item.IsDocument ) {

page.SaveAs( docDir + "\\" + page.Name, params );

exportedPageCount++;

NotifyProcessingProgress( exportedPageCount , PageCount - exportedPageCount );

page.IsExported = true;

}

}

item.IsExported = true;

}

} else {

CheckCanceled();

if( item.IsDocument ) {

item.SaveAs( ResultPath + "\\" + item.Name, params );

exportedPageCount++;

NotifyProcessingProgress( exportedPageCount , PageCount - exportedPageCount );

item.IsExported = true;

}

}

}


附录

软件和硬件要求
键盘快捷键
受支持的条形码类型
专利
拷贝保护
技术支持
如何购买
ABBYY 办事处
最终用户许可协议


硬件和软件要求

硬件要求

  1. 配备 2 GHz 或速度更高的 Intel® Core™2/2 Quad/Pentium®/Celeron®/Xeon™、AMD K6/Turion™/Athlon™/Duron™/Sempron™ 处理器的 PC
  2. 最低需求 1 GB 内存
  3. 1 GB 硬盘空间，其中 50 MB 用于安装
  4. TWAIN、WIA 或 ISIS 扫描仪
  5. 最低需求 1024×768 显卡和显示器
  6. 键盘、鼠标或其他定位设备

软件要求

操作系统：

  • Windows XP SP3;
  • Windows Server 2003 SP2;
  • Windows Vista SP2;
  • Windows Server 2008 SP2 + Desktop Expirience;
  • Windows 7;
  • Windows Server 2008 R2 + Desktop Expirience.

操作系统必须有相应的语言支持，才能操作本地化界面。

其他软件：

  • .Net FrameWork 3.5 或更高版本
  • Microsoft Internet Explorer 6、7、8、9 或任一浏览器（带有附加程序，以便 ClickOnce 部署安装扫描工作站）


键盘快捷键

菜单 | 命令 | 键
文件 | 新建批处理文件 | Ctrl+N
 | 创建文档 | Ctrl+Shift+C
 | 分解文档 | Ctrl+Shift+D
 | 扫描页面 | Ctrl+S
 | 选择并扫描… | Ctrl+Shift+S
 | 停止 | Ctrl+Alt+S
 | 加载图像… | Ctrl+L
 | 发送批处理文件 | Ctrl+E
 | 导出选项… | Ctrl+Shift+E
 | 退出 | Alt+F4
编辑 | 撤销 | Ctrl+Z
 | 重做 | Ctrl+Y
 | 剪切 | Ctrl+X
 | 复制 | Ctrl+C
 | 粘贴 | Ctrl+V
 | 删除 | Del
 | 全选 | Ctrl+A
 | 下一个要重新扫描的文档 | F4
 | 上一个要重新扫描的文档 | Shift+F4
 | 确认重新扫描的文档 | F7
视图 | 批注册参数 | Ctrl+B
 | 文档注册参数 | Ctrl+Shift+B
 | 转至上一页 | Ctrl+Shift+P
 | 转至下一页 | Ctrl+P
 | 转至上个文档 | Ctrl+Shift+D
 | 转至下个文档 | Ctrl+D
 | 比例 > 放大 | Ctrl+Num+
 | 比例 > 缩小 | Ctrl+Num-
页面 | 加载全屏缩略图 | F9
 | 属性 | Alt+Enter
工具 | 批处理文件类型… | Ctrl+Shift+T
 | 重新扫描任务… | Alt+G
帮助 | 打开帮助 | F1


受支持的条形码类型

ABBYY FlexiCapture 10 支持以下条形码格式：

  • EAN 13
  • EAN 8
  • Code 39
  • 检查 Code 39
  • 交叉 25 码
  • 检查交叉 25 码
  • Code 128
  • Codabar
  • UPC-A
  • UPC-E
  • Code 93
  • UCC-128
  • PDF-417
  • IATA 25
  • Matrix 25
  • Industrial 25
  • PostNet
  • Patch code
  • Aztec
  • Datamatrix
  • QRCode


专利

美国专利号 5,490,216、5,625,465、5,768,416 和 6,094,505


技术支持

如果有任何关于 ABBYY 扫描工作站的使用问题，请参阅帮助、用户指南和 www.abbyy.ru 网站上的技术支持部分。

联系 ABBYY 技术支持服务时，请提供以下信息：

  • 您的全名
  • 您的公司名称
  • 电话（传真、电子邮件）
  • 程序副本的序列号
  • 副本的 Build 号（可选择关于 菜单中的帮助项目来查找）
  • 对问题的总体描述以及错误消息的全文（如有）
  • 您的计算机和处理器的类型
  • Windows 操作系统版本（要了解您的系统的相关信息，请选择帮助 > 关于，单击系统信息…按钮并选择发送。
  • 您认为有用的其他任何信息
ABBYY 办事处


如何购买 ABBYY 扫描工作站

要购买 ABBYY 扫描工作站和进行其他询商，请联系最近的 ABBYY 办事处。


ABBYY 办事处

ABBYY Russia | 电话：+7 495 783 3700 传真：+7 495 783 2663 邮寄地址：Russia, 127273, Moscow, P.O.box 32, ABBYY 营业地址：Moscow, ul.Otradnaya 2B, str.6, Otradny Business Centre 电子邮件： sales@abbyy.ru 技术支持： support@abbyy.ru 网站： http://www.abbyy.ru 地图
ABBYY USA | 电话：+1 408-457-9777 传真：+1 408-457-9778 地址：880 North McCarthy Blvd., Suite #220 Milpitas, CA 95035, USA 电子邮件： sales@abbyyusa.com 技术支持： support@abbyyusa.com 网站： http://www.abbyy.com
ABBYY Ukraine | 电话：+380 44 490 9999 传真：+380 44 490 9461 地址：P.O.Box 23, 02002 Kiev, Ukraine 电子邮件： forms@abbyy.ua 支持电话：+380 44 490 9463 支持电子邮件： formsupport@abbyy.ua 网站： http://www.abbyy.ua
ABBYY Europe GmbH | 电话：+49 (0)89 511 159 0 传真：+49 89 (0)511 159 59 地址：Elsenheimerstraße 49, 80687 Munich, Germany 电子邮件： sales_eu@abbyy.com 支持电子邮件： support_eu@abbyy.com 网站： http://www.abbyy.com http://www.abbyy.de http://www.france.abbyy.com
ABBYY UK Ltd. | 网站：+0870 600 0231 传真：+01344 392 611 地址：Abbey House, Grenville Place, Bracknell RG12 1BP, United Kingdom 电子邮件： sales_UK@abbyy.com 支持电子邮件： support_eu@abbyy.com 网站： http://www.abbyy.co.uk
ABBYY Japan | 电话：+81-42-795-1901 传真：+81-42-795-1901 地址：658-1 Tsuruma, Machida-shi, Tokyo 194-8510 电子邮件： sales@abbyyusa.com 支持电子邮件： support@abbyyusa.com 网站： http://www.abbyy.com
ABBYY Taiwan | 电话：+886-2-2655-0556 传真：+886-2-2655-2339 地址：Room #524, 5Fl, Building E, No.19-11, Sanchong road, Nangang District, Taipei 115, Taiwan, R.O.C. 电子邮件： sales@abbyyusa.com 支持电子邮件： support@abbyyusa.com 网站： http://www.abbyy.com


最终用户许可协议

ABBYY FlexiCapture 10

重要事项！在安装、复制和/或使用 FlexiCapture 10（以下简称“软件”）之前，请仔细阅读以下条款。安装、复制或使用该软件，即表明您接受这些条款。

本 ABBYY 最终用户许可协议（以下简称“ EULA”）是您（附有本 EULA 的上述确定的 ABBYY 软件产品[包括任何和所有相关介质、打印材料和“在线”或电子文档]（统称为“软件”）的最终用户）与 ABBYY 之间签订的一份法律协议。

通过安装、复制或以其他方式使用该软件，即表明您确认您已阅读并理解本 EULA，并同意受其条款约束。

该软件受版权法和国际公约条款保护。您同意本 EULA 与您签署的任何书面协议一样均可执行。

本 EULA 在您选择该软件安装程序中“我接受许可协议条款”选项并单击“下一步”以接受本协议所有条款的日期，或您以任何方式开始使用该软件的日期生效。此事件日期即为生效日期。

如果该软件随附了由双方签署的许可协议原件的硬拷贝，那么在本 EULA 的文本与许可协议硬拷贝中的文本出现内容不一致的情况时，以许可协议硬拷贝中的文本为准。

如果您不同意本 EULA 的条款，不要安装和使用该软件，请选择该软件安装程序中“我不接受该许可协议的条款”选项并单击“取消”。

定义：

“软件”应指 ABBYY FlexiCapture 10 软件，它包括一组受版权法保护的计算机程序、数据库和文档（可能以书面或电子形式提供）。

“软件组件”应指软件的任何组成部分，包括但不限于软件所含的任何计算机程序。

“计算机”应指带有一个或多个 CPU 内核的电子设备，可接受数字或相似形式的信息，并根据一系列指令操纵该等信息以获取特定结果。

“虚拟机”指虚拟（或其他仿真的）硬件系统。

“许可证”应指 ABBYY 授予您的非专属权利，以允许您根据本 EULA 条款安装和使用该软件的功能。

“序列号”指的是向最终用户提供的具有类似参数的许可证或许可证组的唯一标识符。

“软件激活”应指根据该软件文档和您的许可范围使所安装的软件完全可正常运行的程序。

“ABBYY”应指

本 EULA 第 17.1 条适用时，指 ABBYY USA Software House Inc.（注册地址为：880 North McCarthy Boulevard, Suite 220, Milpitas, California 95035, USA）；

本 EULA 的第 17.2 条适用时，指 ABBYY Europe GmbH（注册地址为：Elsenheimerstr. 49 80687 Munich）；

本 EULA 的第 17.3 条适用时，指 ABBYY UK Ltd.（注册地址为：Heathrow Business Centre, 65 High Street, Egham, Surrey TW20 9EY, United Kingdom）；

本 EULA 的第 17.4 条适用时，指 ABBYY LLC（注册地址为：ul. Perovskaya dom 22, korpus 1, 111398, Moscow, Russia），

本 EULA 的第 17.5 条适用时，指 ABBYY Software House Ukraine（注册地址为：31, Degtyarevskaya st., Kiev, Ukraine 03680）；

在其他所有情况下，则指 ABBYY Solutions Ltd.（注册地址为：Michail Karaoli 2, Egkomi, CY 2404, Nicosia, Cyprus）。

“您”、“您的”和“最终用户”意指并包括获取并以自身名义使用该软件的任何个人（包括个体经营户）和/或任何法人实体。

“ABBYY 合作伙伴”应指经 ABBYY 协议授权向您提供该软件及该软件使用权利的法人实体或个体经营户。

1. 许可证授权

1.1. 在您遵守本 EULA 条款的前提下，ABBYY 授予您非专属的有限权利（“许可”）以安装和使用该软件的功能，包括该软件中所含全部图像、照片、动画、音频/视频组件、音乐、文本和 Applet，以及如下所述随附的打印材料和该软件的所有副本。下述所有条款同时适用于该软件整体及其所有组件。

1.2. 如果第 17.4 条适用且您是自然人，则您可在全球范围内使用该软件。如果第 17.4 条适用，且您是法人实体或者其分支机构和/或代表办事处，则您仅可在该法人实体（其分支机构和/或代表办事处）注册的国家/地区使用该软件，除非您与 ABBYY 之间另行签订的协议中有其他规定。

2. 许可证

2.1. ABBYY 作出以下陈述、保证和担保：ABBYY 有充分的权利、职权、法定资格、能力和权限许可并分发该软件，包括该软件中所含全部图像、照片、动画、音频/视频组件、音乐、文本和小程序，以及随附的印刷材料和该软件的所有副本。

2.2. 该软件中未包含但可能通过使用该软件而访问的内容所有权和知识产权，均是各内容所有者的财产，可能受适用的版权法或其他知识产权法和国际公约保护。本 EULA 并非意欲转让该等知识产权的所有权。

2.3. 该软件包含属于 ABBYY 和第三方的有价值的商业秘密和机密信息，这些信息受版权保护，包括但不限于美国版权法、俄罗斯联邦法律、国际公约条款以及使用该软件所在国家或地区适用的法律。

2.4.超出或违反本 EULA 的条款对该软件作出的任何使用，均应构成违反 ABBYY 和/或第三方知识产权，应将因此可撤销根据本 EULA 授予您的使用该软件的所有权利。

2.5. 您确定，该软件经过保护可防止未授权的复制和无限制的使用，其可能包括提供了该等保护的软件或硬件保护密钥（以下称为“许可密钥”）。您所接受的该软件受到所有该等保护。

2.6. 许可范围可能取决于在订购该软件期间指定的多种因素：可用功能的设置、允许在网络中运行软件组件的数量和类型、该软件所用的 CPU 数量、可处理的最多页数及到期日期等。所有此信息和其他信息均编码在许可密钥中。许可密钥技术限制了对该软件的使用，反映了您所订购的许可的范围。

2.7. 您可以永久转让该软件，但仅限一次，并且只能直接转让给另一最终用户。如果您是法人实体，则此类转让需要 ABBYY 的书面批准。该转让必须包含该软件所有部分（包括所有软件组件、介质和打印材料、任何升级和本 EULA）。这种转让不能通过托人代售的方式或任何其他间接的转让方式进行。该等一次性转让的受让人必须同意遵守本 EULA 的条款，包括不得进一步转让该软件的义务。如果转让了该软件，则必须从所有安装了该软件的计算机卸载该软件。

2.8. 除了第 2.7 条中的规定，您不得向任何他人转让、分发或再许可该软件，包括根据本协议向您授予的任何权利和/或与该软件有关的任何其他权利。在出现该等转让或分发时，ABBYY 有权终止本 EULA。

2.9. 本 EULA 并未向您授予与 ABBYY 的任何商标有关的任何权利。

2.10. ABBYY 保留未明确授予的所有权利。

3. 对该软件的使用

3.1. 您可根据您的许可范围使用该软件。

3.2. 您可在任意数量的计算机上或虚拟机上安装该软件。

3.3. 软件功能和您可同时运行该软件的计算机或虚拟机（如果您的许可证允许您使用虚拟机）数量由随该软件提供的序列号定义。

3.4. 如果在虚拟（如 VMware、Citrix 或 克隆）软件环境中部署该软件或任何软件组件，则多台机器无法同时使用同一许可证。您同意在任何时候，该软件使用的页面总数都不会超过许可证允许的页面总数。

3.5. 如果您通过使用终端服务（可使您通过网络访问远程计算机上的该软件）访问该软件，则在您的许可所允许的及本 EULA 所规定的范围内，可同时运行尽量多的该软件的副本。

3.6. 如果您通过使用 Web 浏览器（可使您通过因特网访问远程计算机上的该软件）访问该软件，则在您的许可所允许的及本 EULA 所规定的范围内，可同时运行尽量多的该软件的副本。

3.7. 只有您的许可密钥已启用“BPO 服务”参数时，您才能使用该软件向任何第三方提供识别和转换服务且/或提供通过使用该软件所获取的结果。

3.8. 仅当您与 ABBYY 签署了单独的书面协议之后，您才可以使用该软件向任何第三方提供付费或免费识别及转换服务，以及/或提供通过使用该软件（作为拥有识别和转换功能的另一服务的一部分，即作为其组件）获得的结果或提供此等结果的访问权。

3.9. 如果该软件标有“试用”或“不供转售”，则无论本 EULA 其他部分如何规定，您都只能将该软件用于评估或演示。您确认该软件的功能有限，且/或使用期限有限。如果该软件为超时版本，则在过了您的许可范围所允许的指定期限后，将禁用其功能。

3.10.您不得执行或为他人提供机会执行以下列表中列出的任何活动：

3.10.1.对程序、数据库和该软件的其他软件组件作出倒序制作、反向汇编和/或反向编译（获取目标代表的源代表），除非适用法律明确允许作出该等活动（尽管有此限制）。如果适用的法律允许这类活动，由此发现的任何信息不得向第三方公开（除非法律规定需要进行公开，且这类信息必须立即报告给 ABBYY）。所有这类信息应视为 ABBYY 的机密和专属信息。

3.10.2.修改、改编（更改软件以使其适用于最终用户硬件）或转换该软件，包括更改该软件中包含的应用程序和数据库目标代码，但该软件提供并在文档中描述的更改之外。

3.10.3.未经 ABBYY 的事先书面同意而更正错误。

3.10.4.向任何他人租赁、出租、再许可、分配或转让本协议授予您的任何权利和与该软件相关的其他权利，或者授权将该软件的全部或任何部分复制到任何其他计算机上，除非与 ABBYY 单独签署的协议中另有规定。

3.10.5.使无权使用该软件且与您共用多用户系统的任何人能够使用该软件。

3.10.6.删除、更改或掩盖该软件上按交付给您时的原样显示的任何版权、商标或专公告。

4. 双介质软件

4.1. 您可以通过多种介质接收该软件，包括通过因特网下载。不管您收到的介质数量如何，均会根据本 FULA 许可您使用该软件。

5. 限制

5.1. 您只有激活该软件才能行使本 EULA 授予您的对该软件的使用权。

5.2. 控制该软件的使用、支持和维护的所有使用条款和限制都在该 EULA 中表述，除非与 ABBYY 或 ABBYY 合作伙伴单独签署的协议中另有规定。

6. 最终用户数据库

6.1. 您可为该软件中包含的程序创建您自己的数据库，前提是该软件提供了该等功能且其文档也描述了该功能。

7. 该软件的重新发布

7.1. 除第 2.6 条中规定的之外，严禁对该软件作出任何重新发布。重新发布包括但不限于，向第三方授予访问权、出租、租赁或出借该软件。

8. 维护和技术支持

8.1. ABBYY 或其合作伙伴可根据本 EULA 附录 A 中条款的规定为您提供维护和技术支持服务，除非您与 ABBYY 之间或您与 ABBYY 合作伙伴之间在单独协议中另有协定。

9. 有限保证

9.1. ABBYY 保证在您购买该软件所在国家或地区的法定最短保证期内（从购买日起），在正常使用下，承载该软件的介质（如有）无材质和工艺方面的缺陷。如果该软件是根据第 17.4 条购买的，该期限为从购买日起的三十（30）天。

9.2. 该软件及其任何更新或升级按“原样”交付给您，ABBYY 不作出任何类型的保证。ABBYY 不保证也无法保证您使用该软件可能获得的性能或结果。除您所在司法区域对您适用的法律要求不能免除或限制的任何保证、条件、陈述或条款之外，ABBYY 及其合作伙伴不针对任何事项（包括但不限于不侵权第三方权利、适销性、完整性、质量满意度或符合某特定用途，或该软件无错误、符合您的要求或该软件兼容于其他任何软件或硬件）作出任何保证、条件、陈述或条款（无论是根据成文法、普通法、惯例、习俗或其他法规作出的明示或默示保证）。有关该软件质量和性能的所有风险应由您承担。

9.3. ABBYY 不针对该软件可能嵌有的任何第三方软件产品作出任何保证。

10. 责任限制

10.1. 在任何情况下，对于因使用该软件引起的和/或与之相关的任何损害、业务中断，任何类型（商业或其他性质）的数据或信息丢失、索赔或任何开支或任何后果性的、间接的或附带的损害或任何利润损失或可节省费用的损失，或由该软件中可能存在的错误或排版错误所引起的损害，ABBYY 概不负责，即使 ABBYY 代表已被告知有可能遭受该等损失、损害、索赔或开销或任何第三方提出的任何权利主张。在您所在管辖区适用法律允许的范围内，前述限制和免除事项仍适用。ABBYY 在本 EULA 项下或与之相关的唯一全部赔偿责任不得超过已支付的该软件初始购买价（如有）。

10.2. 对居住在德国或奥地利用户的责任限制
如果您在德国或奥地利获得该软件的副本，并且您在该等国家长期居住，则：

10.2.1. 在任何情况下，对于因使用该软件引起的和/或与之相关的任何损害、业务中断，任何类型（商业或其他性质）的数据或信息丢失、索赔或任何开支或任何后果性的、间接的或附带的损害或任何利润损失或可节省费用的损失，或由该软件中可能存在的错误或排版错误所引起的损害，ABBYY 概不负责，即使 ABBYY 代表已被告知有可能遭受该等损失、损害、索赔或开销或任何第三方提出的任何权利主张。

10.2.2. 第 10.2.1 条中规定的责任限制不得适用于任何强制性法定责任，特别是德国产品责任法规定的责任、承担特定担保的责任或对刑事犯罪所导致的人身伤害所负有的责任。

10.2.3. 您应采取一切合理措施来避免和减少损害，特别是您应根据本 EULA 规定备份该软件的副本和您的计算机数据。

11. 嵌入式字体

11.1.字体程序受版权保护，版权所有者可能会规定限制字体程序使用的条件。其中一个条件可能是，您需要字体程序的许可副本才能将字体嵌入到 PDF 文件中。在任何情况下，ABBYY 均不对您使用嵌入式字体所引起或与之相关的任何损害负有责任。

12. Adobe® PDF Library

12.1.“Adobe 软件”应指 Adobe® PDF Library for Windows 2000, XP 和相关文档及其任何升级、修改版本、更新、补充和副本。该软件使用 Adobe 软件将 PDF 文件转换为图像文件。

12.2.许可授予和限制。ABBYY 授予您非专属的权利根据本 EULA 条款使用该软件中所含 Adobe 软件。您可以制作该软件中所含 Adobe 软件的一个备份副本，前提是该备份副本不在任何计算机上安装或使用。

12.3.知识产权。该软件中含有的 Adobe 软件归 Adobe 及其供应商所有，其结构、组织和代码是 Adobe 及其供应商的有价值的商业秘密。Adobe 软件还受美国版权法和国际公约条款的保护。您不得复制该软件中所含的 Adobe 软件，除非本 EULA 中另有规定。本 EULA 允许您制作的任何副本都必须包含该软件外部或内部显示的相同版权和其他所有权公告。您同意不对该软件中所含 Adobe 软件进行修改、改编、转换、倒序制作、反向编译、反向汇解或以其他方式尝试发现其源代码。除了上述规定，本 EULA 不授予您对 Adobe 软件的任何知识产权。

12.4.字体许可。如果该软件或其中嵌有的 Adobe 软件包括字体软件，则您可以将字体软件或其轮廓嵌入到电子文档中，前提是字体供应商版权所有者允许这类嵌入操作。该软件包中所含字体可以包括 Adobe 和非 Adobe 拥有的字体。您可以完全对 Adobe 拥有的任何字体执行嵌入操作。

12.5.保证。ABBYY 并不且无法保证您通过使用该软件中嵌有的 ADOBE 软件所能获取的性能和结果。

12.6.出口规定。您同意不将该软件中嵌有的 Adobe 软件运输、传输或出口到美国出口管理法或任何其他出口法律、限制或法规（统称为“出口法律”）所禁止的任何国家或地区，也不以该等出口法律所禁止的任何方式对其进行使用。此外，如果该软件中嵌有的 Adobe 软件根据出口法律被确定为出口受控项，您陈述并保证您不是禁止通商国的公民，也不在禁止通商国境内，并且出口法律未禁止您接收该软件中嵌有的 Adobe 软件。授予使用该软件中嵌有的 Adobe 软件的所有权利时基于以下条件：如果您未能遵守本 EULA 条款，您将丧失该等权利。

12.7.商标。Adobe 和 Adobe PDF Library 是 Adobe Systems Incorporated 在美国和/或其他国家或地区的注册商标或商标。

13. PixTools® Scan 运行时库。

13.1.“EMC 软件”应指定 PixTools Scan 运行时库、第 1 级 ISIS 驱动程序、第 2 级 ISIS 驱动程序和第 3 级 ISIS 驱动程序。该软件可能使用 EMC 软件通过 ISIS 接口在扫描仪和软件之间进行通信。

13.2.许可授予和限制。ABBYY 授予您非专属的权利根据本 EULA 条款使用该软件中嵌有的 EMC 软件。

13.3.知识产权。该软件中嵌有的 EMCe 软件归 EMC Corporation 及其供应商所有，其结构、组织和代码均是 EMC Corporation 及其供应商的有价值的商业秘密。EMC 软件还受美国版权法和国际公约条款的保护。您不得复制该软件中嵌有的 EMC 软件。您同意不对该软件中所含 EMC 软件进行修改、改编、转换、倒序制作、反向编译、反向汇解或以其他方式尝试发现其源代码。除了上述规定，本 EULA 不授予您对 EMC 软件的任何知识产权。

13.4.保证。
ABBYY 并不且无法保证您通过使用该软件中嵌有的 EMC 软件所能获取的性能和结果。
在任何情况下，对于任何后果性、间接的、或特殊性的损害，包括任何利润损失或可节省的开支损失或第三方提出的任何权利主张，EMC CORPORATION 或其供应商概不负责。
某些州或管辖区不允许排除或限制附带的、后果性的或特殊的损害，因此上述限制可能不适用于您。您可拥有其他权利，该等其他权利可能因州或管辖区而异。

13.5.商标。
ISIS 和 PixTools 是 EMC Corporation 在美国和/或其他国家或地区的注册商标或商标。

14. LIZARDTECH SOFTWARE

14.1.“LIZARDTECH SOFTWARE”指包括 LIZARDTECH 源代码、任何相关介质、印刷材料和“在线”或电子文档的 DjVu Decoder 软件开发包。您已从 LIZARDTECH, INC. 处获得包含由 ABBYY 许可的 LIZARDTECH SOFTWARE 的软件。该软件使用 LIZARDTECH SOFTWARE，以将 DjVu 文件转换为图像文件。

14.2.LIZARDTECH SOFTWARE 受版权法、国际版权公约以及其他其他知识产权法和公约保护。LIZARDTECH SOFTWARE 已获得许可，但不得用于销售。

14.3.许可证授权。已向您授权个人、不可再许可、不可转让且非独家的许可，以使用该软件中集成的 LIZARDTECH SOFTWARE（以及任何关联的文档）。不得租赁、出售、出租或分发 LIZARDTECH SOFTWARE 或其任何部分。

14.4.对 LIZARDTECH SOFTWARE 未做任何保证 LIZARDTECH SOFTWARE 按“原样”提供且带有所有缺陷。与满意的质量、性能、准确性及努力（包括疏忽过失）相关的所有风险由您自负。另外，我们不保证在您使用 LIZARDTECH SOFTWARE 时，不会出现任何干扰或侵权行为。如果您获得关于该软件或 LIZARDTECH SOFTWARE 的任何保证，那些保证并非源自 LIZARDTECH，且对 LIZARDTECH 无任何约束力。

14.5.对某些损害不负任何责任。除了法律禁止之外，LIZARDTECH 对 LIZARDTECH SOFTWARE 的使用或性能导致或有关的任何间接、特殊、必然或偶然损害不负任何责任。即使任何补救措施未实现其主要目的，本限制也适用。

14.6.对反向工程、反编译和反汇编的限制。不得对 LIZARDTECH SOFTWARE 进行反向工程、反编译或反汇编，除以下情况之外且仅限于以下情况：适用的法律超越此限制而明确允许这类活动。

14.7.出口限制。您认可 LIZARDTECH SOFTWARE 或其任何部分，或者任何程序或服务是源自美国的 LIZARDTECH SOFTWARE 的直接产品（上述统称为“限制组件）。您同意遵守适用于这些产品的所有适用国际和国家法律，包括美国出口管理法规，以及美国及其他政府颁布的最终用户、最终用途和目的地限制。

15. 其他许可的技术

15.1.该软件将在以下美国专利号许可下使用：5,490,216、5,625,465、5,768,416 和 6,094,505。

16. 出口规定

16.1.不得违反获取该软件或以其他方式获得该软件所在国家或地区的法律中任何出口条款而出口或再出口该软件。此外，您陈述并保证适用的法律未禁止您接收该软件。

17. 适用法律

17.1.如果在美国、加拿大、墨西哥、中美洲（伯利兹、哥斯达黎加、萨尔瓦多、危地马拉、洪都拉斯、蒙塞拉特岛、尼加拉瓜、巴拿马、特克斯和凯克斯群岛、美属维尔京群岛）、日本或台湾地区获得该软件，则本 EULA 应受美国加里福尼亚州的法律管辖并据其进行解释。对于因本 EULA 和/或该软件可能引起的任何纠纷，您同意将其提交在加里福尼亚州圣塔克拉拉郡的联邦和/或州法庭进行审判。如果该软件是在美国获得，为免产生疑义，均指从 ABBYY USA Software House Inc. 购买了该软件。

17.2. 如果在奥地利、比利时、丹麦、芬兰、法国、德国、意大利、卢森堡、荷兰、葡萄牙、西班牙、瑞典或本 EULA 第 17.3 - 17.5 条中未提到的其他任何欧盟成员国（希腊、塞浦路斯和马耳他除外），或在海峡群岛、冰岛、列支敦士登、挪威或瑞士获得该软件，则本 EULA 应受在德意志联邦共和国慕尼黑生效的实体法管辖并据其进行解释，并且德意志联邦共和国慕尼黑的管辖法庭应对与本 EULA 相关的所有纠纷具备司法权。

17.3. 如果在大不列颠及北爱尔兰联合王国、爱尔兰共和国获得该软件，则本 EULA 应受英格兰和威尔士的法律管辖并依其解释，并且各相关方接受英格兰和威尔士法庭的审判。

17.4. 如果在俄罗斯、白俄罗斯、哈萨克斯坦或其他任何独联体国家（乌克兰和摩尔多瓦除外）获得该软件，或在格鲁吉亚、拉脱维亚、立陶宛或爱沙尼亚购买该软件，则本 EULA 应受俄罗斯联邦的实体法管辖并据其进行解释。

17.5. 如果在阿尔巴尼亚、波斯尼亚、黑塞哥维那、保加利亚、克罗地亚、捷克共和国、匈牙利、以色列、马其顿、波兰、罗马尼亚、斯洛伐克、斯洛文尼亚、土耳其、塞尔维亚、黑山、乌克兰或摩尔多瓦获得该软件，由本 EULA 应受乌克兰法律管辖并据其进行解释。

17.6. 如果第 17.4 条适用，并且您是法人实体或个体经营户，与本 EULA 相关的所有纠纷应由俄罗斯联邦莫斯科仲裁法庭进行审判。如果第 17.4 条适用，并且您是个人，与本 EULA 相关的所有纠纷应由俄罗斯联邦莫斯科彼得罗夫斯基区域法庭进行审判。

17.7. 如果第 17.5 条适用，并且您是法人实体或个体经营户，所有一切因该协议引起或与之相关的纠纷、争议或意见分歧均应根据乌克兰工商会的国际商业仲裁的仲裁规则和程序进行仲裁而加以最终解决。该法院的裁决是终局的，对双方均有约束力。如果第 17.5 条适用，并且您是个人，与本 EULA 相关的所有纠纷应提交乌克兰基辅市的舍甫琴科夫斯基区域法庭进行审判。

17.8. 本 EULA 不受任何管辖区的法律冲突规则或《联合国国际货物销售合同公约》管辖（明确排除适用上述公约）。

17.9. 如果在第 17.1 － 17.5 条中未指定的国家或地区购得该软件，本 EULA 应受您购买该软件所在国家或地区的实体法管辖并依其解释。

18. 条款

18.1.本 EULA 在生效日期生效。除非您与 ABBYY 之间另有协定或本 EULA 另有规定，本 EULA 将在该软件整个版权期限内有效。

18.2.您可以通过销毁该软件及随附的文档和所有相关副本来终止本 EULA。

18.3.如果您未能遵守本 EULA 的条款，在不损害您的任何其他权利的前提下，ABBYY 可以终止本 EULA。如果出现该等事件，您必须销毁该软件的所有副本及其所有组件。该等终止并不免除您为该软件和/或维护付款的义务。

18.4. 无仍因任何原因终止了本 EULA，条款 2.3、2.8、2.9、3.9、7、9.2、9.3、10、17、20.2 和 20.3 仍然有效，但这并不暗示或造成在终止本 EULA 之后继续使用该软件的任何权利。

19. 政府使用

19.1.如果该软件由美国政府或美国政府的任何部门使用，以下额外条款适用：(1) 美国联邦采购法的“数据权利－常规”条文 52.227-14 中定义的受限计算机软件；以及 (2) 政府的任何使用、复制或公开行为受到 DFARS 252.227-7013 的“技术数据和计算机软件权利”条文的子段落 (c)(1)(ii) 中规定的限制。

20. 一般规定

20.1.如果本 EULA 的任何部分被视为无效且不可执行，则其并不影响本 EULA 其余部分的有效性，其余部分根据其条款仍然有效。

20.2.您同意向 ABBYY 提供您在激活、注册和操作该软件的过程中的个人详细信息。您同意 ABBYY 可以根据适用法律收集、处理和使用您的个人详细信息，前提是保持这些数据的机密性。您提供给 ABBYY 的任何个人详细信息将完全限于 ABBYY 及其附属公司内部存储和使用，不会向任何第三方公开（除适用法律要求公开的情况之外）。

20.3.ABBYY 可能向您发送包含产品和公司新闻、特价信息、产品用法建议以及其他产品和公司相关信息的电子邮件（如果您明确同意从 ABBYY 接收该信息）。您可以随时从 ABBYY 邮件列表中删除您的电子邮件地址。

20.4.ABBYY 可能向您提供印刷材料，包括用户指南。

20.5.本 EULA 项下的酬金是 ABBYY 或 ABBYY 合作伙伴拟定的该软件（或许可证）价格（应根据 ABBYY 或 ABBYY 合作伙伴拟定的付款程序进行付款），或纳入您的硬件购买价格中，或是您因使用完整版本的该软件而应支付的酬金的一部分。对于自然人，本 EULA 可能是免费的。

20.6.如果您因使用该软件而遭受任何索赔或法律诉讼，则应在获悉该等情况后的 3 天通知 ABBYY。您应在收到 ABBYY 的查询后的七天内采取所有必要的措施为 ABBYY 提供机会参与上述索赔或法律诉讼的听证，并为解决相关的索赔或法律诉令提供所需的信息。

附录 A

维护协议

本附录 A 应是 EULA 的重要组成部分，除非您与 ABBYY 单独签订的书面协议中另有规定，或是您与 ABBYY 合作伙伴之间单独签订的协议中另有规定。

1. 定义

1.1. “更新”应指该软件当前版本的增强功能，通常包括错误修正。

1.2. “升级”应指用于替代 EULA 下目前许可给您的主要或次要版本的该软件的下一版本（例如，1.5 将替代 1.0，2.0 将替代 1.x）。

1.3. “错误”应指根据文档列出的规格使用该软件时出现的性能故障。应识别以下三种类型的错误：

1.3.1. 优先级 1 错误应指没有解决方案的问题，您所在场地的生产将停止，包括显示“内部程序错误”、“内存不够”、“违反访问权”、“常见保护故障”、 “常见保护错误”的错误及“除以零”消息；

1.3.2. 优先级 2 错误应指可为其提供解决方案的故障；

1.3.3. 优先级 3 错误应指不妨碍您所在场地的生产的小问题。

1.4. “支持服务”指

(i) 在出错时 ABBYY 向您提供的服务，试图按照规范恢复该软件的操作。这些服务可能包括向您提供所报告错误的解决方案，或是向您提供该错误已消除的软件更新；

(ii) ABBYY 提供给您的信息将回答您关于该软件功能、安装、激活和操作的问题。

1.5. “升级保证”应指向您授予接收升级权的维护部分。

2. 维护

2.1. 维护可能包括发送更新、升级保证和支持服务或其任何组合。

2.2. 维护期限是十二 (12) 个月的初始期限，从发运该软件之日起。

2.3. 如需延长维修期限，则需要从 ABBYY 或其合作伙伴获取该等延期。如果第 17.2 条或第 17.3 条适用，当您在维护期限终止之前的 45 天内未取消维护时，无需作出进一步声明，维护期限将会延长 12 个月的期限。必须针对该等取消作出书面声明。

2.4. ABBYY 或其合作伙伴可能另行向您提供特定维护条款。

2.5. ABBYY 保留不时自行决定更改维护的格式和内容的权利。

2.6. 作为维护的一部分向您提供的该软件的任何补充代码应视为该软件的一部分，并受该 EULA 条款约束。

3. 更亲和升级保证

3.1. 升级和更新就通过光盘和/或电子方式（通过 FTP）交付。运输费用（如有）应由您支付。

3.2. 如果您购买了维护的“更新”部分，则您有权从 ABBYY 或其合作伙伴收到更新。ABBYY 或其合作伙伴将尽快向您提供该软件的更新。

3.3. 如果您购买了维护的“升级保证”部分，则您有权从 ABBYY 或其合作伙伴收到升级。ABBYY 或其合作伙伴将尽快向您提供该软件的升级。

3.4. 如果您开发了包含该软件或其一部分或与该软件相集成的任何应用程序，则此应用程序的任何新的大型发行应包括在该等发行之前的三 (3) 个月内 ABBYY 向您提供的该软件的最新更新（或最新更新，如果该等更新是在该等发行的三 (3) 个月以后发行的）。

4. 支持服务

4.1. 如果您购买了维护的“支持服务”部分，则 ABBYY 或其合作伙伴应按照在 ABBYY 网站 http://www.abbyy.com/support/policy 上发布的当前 ABBYY 支持政策向您提供支持服务。ABBYY 保留随时更改其支持政策而无需事先通知的权利。

4.2. ABBYY 或其合作伙伴应提供支持服务以解决优先级 1 错误。

4.3. 如果您购买了维护的“支持服务”部分，则 ABBYY 或其合作伙伴应在十二 (12) 个月的期限内针对多达八 (8) 次涉及优先级 2 和优先级 3 错误的请求提供支持服务。在此期限内，对于涉及优先级 2 和优先级 3 错误的任何附加请求所提供的支持服务应另行收取费用。

4.4. ABBYY 或其合作伙伴将在正常工作时间内通过电话或电子邮件提供与该软件相关的支持服务。

4.5. ABBYY 或其合作伙伴同意作出商业上合理的努力在正常发行时间表之外发行该软件的紧急更新，以解决向其报告的任何优先级 1 错误。在事件的正常过程中，可能在后续的发行中修复优先级 2 和 3 错误。紧急更新将仅针对该软件的当前版本发行，以解决优先级 1 错误。

4.6. 报告错误时，您同意向 ABBYY 或其合作伙伴提供查找错误并提供其修复和解决方案所需的支持数据。支持数据应包括问题描述、出现问题的平台和操作系统的标识、引起待发现错误的输入的副本、发现错误时所使用的格式文件的副本及错误所造成的任何机器转储。ABBYY 或其合作伙伴可以将上述信息用于商业用途，包括但不限于产品支持和开发，前提是 ABBYY 或其合作伙伴不以可表明您的个人身份的任何形式利用这类信息。


扫描和发送工具

按钮 描述
采用上次使用的扫描仪来源启动扫描。

要选择可用的扫描仪来源，单击按钮右侧的箭头并选择选择并扫描…项目。在选择并扫描对话框中，选择一个可用的扫描仪来源。
停止扫描进程。在扫描过程中，此按钮可替代扫描按钮。
将文档导出至选定的导出目标。将鼠标指向该按钮时，会显示当前目标的名称。

单击该按钮旁边的箭头并选择下面的一个目标：

  • 发送至文件夹…
    将批处理文件导出至本地文件夹。
  • 发送至 FTP 文件夹…
    将批处理文件导出至 FTP 文件夹。
  • 发送至 FlexiCapture…
    将批处理文件导出至 ABBYY FlexiCapture。
  • 由脚本发送…
    通过使用脚本导出批处理文件。

选择配置文件时，在打开的对话框中可以选择该配置文件的导出选项。选择所需的选项并单击确定开始导出文档。


许可证管理

许可证在许可证对话框中进行管理。要打开该对话框，选择帮助 > 关于，并单击License Manager…对话框中的 关于 ABBYY FlexiCapture 10 扫描工作站按钮。

添加新许可证

在许可证窗口中，先单击激活...。输入新序列号后单击下一步。选择许可证激活方法并激活您的许可证。新许可证将显示在许可证窗口中。

更新许可证

要更新许可证，请选择要更新的许可证并单击更新许可证...。同样需要通过因特网或电子邮件激活许可证。根据屏幕上的指示进行操作。

许可证参数

在许可证窗口中，可以查看许可证的参数。


许可证参数

每个许可证都有各自的序列号。许可证包含有一组确定用户是否有权限执行某些文档处理操作的参数。

许可证参数：

  • 常规 – 序列号、许可方法、虚拟机的可用性
  • 许可证用途 – 许可证类型（常规、试用或非转售）
  • 时间 – 使用限制
  • 导入 – 其他导入选项


副本保护

为了正确操作扫描工作站，必须提供有效的保护密钥。ABBYY 扫描工作站随同 ABBYY FlexiCapture 10 交付，它使用的是 ABBYY FlexiCapture 10 的保护密钥。本节及其小节的信息指的是用自带的保护密钥保护的远程扫描工作站。

ABBYY 扫描工作站可以采用如下类型的保护密钥进行保护：

  • 硬件保护密钥
  • 软件保护密钥

硬件保护密钥

硬件保护密钥就是插入计算机 USB 端口上的 dongle (USB dongle)。使用本程序时必须始终插入硬件保护密钥。

硬件保护密钥存储许可证参数。

使用许可证序列号可以远程激活空的硬件保护密钥。这个过程由 License Manager 实用程序完成，该实用程序通过因特网连接激活服务器，请求序列号的参数并将参数保存在密钥中。

重要事项！必须运行 SmartCard 服务才能使用硬件保护密钥。

软件保护密钥

这就是软件许可证文件。

必须在 ABBYY 激活服务器上激活许可证文件，方可对 ABBYY FlexiCapture 10 扫描工作站运行软件保护密钥。可以通过许可证对话框激活许可证文件。要打开许可证对话框，选择帮助 > 关于，并单击关于 ABBYY 扫描工作站对话框中的 License Manager… 按钮。

激活许可证文件所需的信息以代码（产品 ID）的形式发送给 ABBYY，该代码根据安装 ABBYY 扫描工作站的计算机的信息生成。不使用个人信息生成产品 ID，该代码也不能用于识别用户身份。

激活方法：

  • 通过因特网
    激活通过因特网自动进行，只需数秒即可完成。该方法要求有效的因特网连接。对于通过因特网激活的情况，不要求执行其他任何步骤。
  • 通过电子邮件
    如果选择这种激活法，会自动生成一个电子邮件激活请求。将该电子邮件消息发送到指定的地址。不要更改电子邮件消息的正文和主题，否则无法激活。您将收到激活文件回复。选择加载激活文件项目将该文件加载到保护系统中。
  • 通过另一台计算机的电子邮件

    如果无法从激活该应用程序的计算机上发送电子邮件，可以将所需的信息复制到另一台计算机，并从这台计算机发送激活请求。选择通过另一台计算机的电子邮件时，可以将生成的激活请求复制到另一台计算机上。将该激活请求发送到指定的地址。您将收到激活文件回复。将该激活文件复制到安装该应用程序的计算机，并使用加载激活文件项目将该文件加载到保护系统。

  • 加载激活文件

    选择该项目加载从 ABBYY 激活服务器接收的激活文件。

重复激活

您可以在激活ABBYY 扫描工作站的计算机上重新安装 ABBYY 扫描工作站，重新安装的次数不限。但是，如果进行重大升级、格式化硬盘或重新安装操作系统，可能要重新激活本产品。

激活服务器保存每个序列号激活次数的日志。一旦超过该序列号的特定阈值，序列号会被冻结，无法再进行激活。

您可以禁用激活过的许可证，在另一台计算机上使用。禁用许可证时，激活服务器会将该序列号的激活计数器之值减 1。

重要事项！只能在生成该产品 ID 的计算机上使用激活程序。要将程序迁移到另一台计算机，首先要禁用许可证。


重新扫描任务对话框

在此对话框中，您可以使用重新扫描任务：选择任务，发送已处理的任务至验证，拒绝任务或将它们发送至异常，指定注册参数名，其值将在批处理文件信息列中显示。要打开对话框，选择工具 > 重新扫描任务…或按 Alt+G。

对话框将显示有关任务的以下信息：创建时间、状态、优先级、批处理文件注册参数（批处理文件信息）和注释。注释可以由校验操作员在发送任务时添加。

要添加批处理文件信息，单击批处理文件信息…按钮并输入批处理文件注册参数的名称。它们的值以分号分隔，将显示在批处理文件信息列中。如果指定的注册参数丢失，其值将为空。

来自批处理文件信息和注释：列中的值可以帮助操作员区分任务。

右侧的按钮使您可以管理任务：

按钮 | 描述
选择 | 打开选定的任务并将其状态更改至“选定”。
发送 | 发送已处理任务至 ABBYY 校验工作站。
拒绝任务 | 拒绝选定的任务。
至异常… | 发送选定任务至异常。
批处理文件信息… | 打开批处理文件信息对话框，您可以在此添加和删除批处理文件注册参数。
关闭 | 关闭对话框。

有关详细信息，请参阅重新扫描任务。


批处理文件编辑工具

命令 | 按钮 | 描述
创建新批处理文件 |  | 创建当前类型的新批处理文件。新批处理文件的名称由批处理文件类型属性中指定的批处理文件命名规则决定。要更改批处理文件的名称，请在批处理文件窗口中选择批处理文件，然后按鼠标左键或按 F2。
创建新文档 |  | 在当前批处理文件中创建一个包含选定页面的文档。新文档的名称由批处理文件类型属性中指定的文件命名规则决定。要更改文档名称，请在批处理文件窗口中选择文档，然后按鼠标左键或按 F2。
分解文档 |  | 分解文档，就是将此文档中的页面放在当前批处理文件中，同时删除该文档本身。
删除 |  | 删除选定项目。


图像编辑工具

命令 | 按钮 | 描述
重新扫描页面 |  | 重新扫描选定的页面。
扫描页面放在选定页面后面 |  | 扫描文档页面，并将这些页面放到批处理文件中用户指定的页面后面。
顺时针旋转 90° |  | 将选定页面顺时针旋转 90°。
逆时针旋转 90° |  | 将选定页面逆时针旋转 90°。
旋转 180° |  | 将选定页面旋转 180°。
水平翻转 |  | 相对于垂直轴翻转选定页面。
垂直翻转 |  | 相对于水平轴翻转选定页面。
裁剪 |  | 裁剪选定页面。
反转 |  | 反转选定页面上的颜色。
黑白 |  | 将选定页面转换为黑白页面。
消除歪斜 |  | 消除选定页面上的歪斜。
去斑 |  | 消除选定图像的“背景噪声”。
编辑 |  | 使用颜色矩形模糊页面上的某个区域。可以在视图 > 选项… > 常规 > 编辑颜色中选择颜色。


批处理文件类型工具

按钮 | 描述
当前批处理文件类型 （下拉列表） | 选择批处理文件类型并将其标记为当前类型。默认的批处理文件类型是未分类。
 | 打开批处理文件类型属性对话框，可查看和编辑选定批处理文件类型的设置。此按钮不适用未分类批处理文件。要查看默认选项，选择视图 > 选项…
 | 单击此按钮仅显示批处理文件窗口中当前类型的批处理文件。

注：如果没有用户创建的批处理文件类型，此工具栏将处于隐藏状态。